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HTMASC 1.2 Help Contents

Welcome to HTMASC, the easy and fast way to convert pages from the World Wide Web (*.htm) to plain Textfiles
(*.txt).

All of the HTML tags (e.g.<TITLE>, <HEADER> ...) are removed and entities (&quot; &copy; ....) are converted.
HTMASC also offers full text handling capabilities. You get all the standard features like searching for text, using
the Clipboard, printing... and you get nice extras like bookmarks and a powerful undo facility.
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Introduction to HTMASC

Load a HTML File, click on & and the converted textfile will show up in the bottom window! That's all you
have to do to convert Webpages into a more readable format. It's that easy!

Now the screen should look something like this:

Note: For Help with an area of the Main Window click on it in the picture below
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<hlxDan's Poker Dictionarv/hl-

<hard Glossary of Poker Terminology=/ha>-

<ha>By Dan Kimberg</he=

<hi=Copyright scopy: 1995 by Daniel Kimherg</hi3-
<h3>Thiz page iz not affiliated with anvthing.< 3=
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Original File Window
After loading a HTM - File the original text can be viewed. That's only for reference, no editing, copying, searching
etc. is possible.



Converted File Window

The converted file can be fully edited using the mouse or standard CUA keystrokes. You can search for text, cut,
copy, paste, undo, redo ...

Note: The right mouse button displays a PopUp Menu for quick access to most of the Menu commands.



Bookmark
You can define up to 10 Bookmarks in the editor



Selected Text
You can cut, copy or delete the selected text



Shows the full name of the HTM - File



Shows the full name of the converted Textfile



The Toolbar allows quick access to most of the commands



Shows the full path of the current Output Directory



The Options Speed Bar provides shortcuts
for commands from the Options Dialog.




You can vertically resize the File Windows by dragging the separator line that lies between the Converted File Label
and the Original File Window.



Loading *.htm Files

Use the @ icon from the Toolbar or choose File|Open from the Menu to show the Open File Dialog box.




HTMASC Features

Some of the features in alphabetical order:
Bookmarks

File Size

Output Directory

Options Speed Bar

PopUp Menu

Toolbar

Undo/Redo

Window Size and Position

Word Wrap



Bookmarks

Bookmarks provide a means of moving quickly from place to place within a file.
You can define up to 10 Bookmarks.

To set a bookmark, press <CtrIShiftN> where N is a number in the range 0 to 9. To return to that spot later, press
<CtrIN>, where N is the number used to set the bookmark.

New in 1.1:

Clicking the right mouse button in the Converted File Window displays a PopUp Menu for quick access to most of
the Menu commands including Bookmark actions.



Toolbar

Below the Menubar you see a row of buttons called the Toolbar. Toolbar buttons perform an action, just like a menu
selection. Using a Toolbar button couldn't be easier just click on it.

Greyed Out Buttons
Toolbar buttons that are not currently available appear greyed out.

Getting Help with a Toolbar Button
To find out what a Toolbar button does, point at it with the mouse. HTMASC will display a short explanation of the
button's action.

ﬂ Exit the application
@ Open a HTM - File

& Start the conversion

Save the converted file

Save the converted file under a different name

& @ @

Cut selected text to the clipboard

Copy selected text to the clipboard

Paste from clipboard

Open the Find Dialog Box

¥R @

Search again



HTMASC can handle files up to a limit of 16MB.



Undo/Redo

The Converted File Window provides a undo facility that allows multiple edit commands to be undone.
You can either choose Undo/Redo from the Edit Menu or you can use the following keystrokes:

Undo <CtrlZ> or <AltBkSp>
Redo <ShiftCtrlZ>

Note: The editor stores a record of each edit command in a single continuous buffer, which is 64KB. This is also the
maximum which can be undone in one step.



Output Directory

Using the Options Dialog you can specify the directory to store your converted textfiles



Clicking the right mouse button in the Converted File Window displays a PopUp Menu for quick access to most of
the Menu commands



Adapts the text in the Converted File Window to the actual size of the window.



Window Size and Position

If the Save Window Position Checkbox in the Options Dialog is activated(Default) the last window size and position
is saved when you exit HTMASC.



HTMASC Menus
File Menu

Edit Menu

Search Menu

Options Menu

Help Menu



File Menu

The File menu enables you to open, save, convert and print files.
Note: Most of the commands are also available from the Toolbar

Open %

Loads an existing HTML File

Convert %

Starts the conversion

Save %

Saves the file in the Converted File Window using its current name

Save As... @

Saves the file in the Converted File Window using a new name

Print
Sends the file in the Converted File Window to the printer

Print Setup
Opens the Printer Setup Dialog box

Exit @

Closes the open files and exits HTMASC



Edit Menu

The Edit menu enables you to manipulate text in the Converted File Window
Note: Most of the commands are also available from the Toolbar

Undo
Undoes your last action or last deletion

Redo
Reverses an undo

Cut %

Removes selected text and places it on the Clipboard

Copy %

Places a copy of the selected text on the Clipboard, leaving the original in place
Paste %

Copies the contents of the Clipboard into the Converted File Window

Delete
Removes the selected text

Select All
Selects all the text in the Converted File Window



Search Menu

The Search menu enables you to locate text in the Converted File Window.
Note: These commands are also available from the Toolbar

Find E

Opens the Find Dialog Window

Find Next E

This will find the next match for the specified text, starting from the current cursor position.




Find Dialog Window

Use this dialog box to specify text you want to locate, and to set options that affect the search.
Note: For Help with an area of the Find Window click on it in the picture below

~Search Text

~Search Options |

® Search Forward s/ 0K
(! Search Backward

[T Match Case

Cancel
[ Global Search x




Enter a search string



Searches from the current position to the end of the file



Searches from the current position to the beginning of the file



Differentiates uppercase from lowercase when performing a search



Searches the entire file



Options Menu
Use the Options menu to view and change project and environment settings

Word Wrap
Adapts the text in the Converted File Window to the actual size of the window.

Show Lights
Shows the Options Speed Bar.

More...
Opens the Options Dialog Window.



Options Dialog
Use the Options Dialog to view and change project and environment settings.

Alternatively you may use the Options Speed Bar for quick access to most of the options.

Note: For Help with an area of the Options Window click on it in the picture below

Output directory
[FASIKATRTS | [Browse.. |

[X Show Hints

X Save Window Position
[" Output DEM (DDS)

[T Show Links

[ Same Directory

s/ 0K I | x Cancel ? Help




Displays the current output directory and you can enter a new output directory.
If the directory does not yet exist, HTMASC will ask to create it.



Opens the Select Directory Dialog Window




Select Directory Dialog
Use the Select Directory Dialog box to choose a directory for your converted textfiles.

Note: For Help with an area of the Select Directory Window click on it in the picture below

== Select Directory

Output Directory
| d:\delphi\walter\html\testt |

|IEI d: [ - no volume label - ] [;I

(= d:A

(= delphi
[= walter
(= html

« DK X Cancel




Displays the current output directory and you can enter a new output directory.
If the directory does not yet exist, HTMASC will ask to create it.



Select Drive



Select Directory



If ON:
Popup Hints are shown



If ON:
Saves the last window size and position



Options Speed Bar

The Options Speed Bar serves two purposes:

1) To provide shortcuts for commands from the Options Dialog by clicking on the corresponding light.
2) To give quick visual feedback of the presently selected options.

To Show/Hide the Options Speed Bar use Show Lights from the Options Menu.

Note: For Help with an area of the Options Speed Bar click on it in the picture below
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If ON:
Shows these Popup Tooltips



If ON:
Saves the last window size and position



If ON:
Converted File is saved in OEM (=DOS) Format.
File extension is *.ASC.



If ON:
Shows all HREF="xxx..." in the converted file.



If ON:
Converted Files are stored in the directory of the currently open *.htm File.



Help Menu

Contents

Opens the Help file. The online Help provides a contents screen that summarizes the contents of the HTMASC Help
system.

Note: If you do not know how to use Help in Windows, choose Help|How To Use Help from the menu bar.

Topic Search
Displays the Help Search dialog box. The Search dialog box lets you search for Help topics using keywords.

How To Use Help
Displays information on how to use the Windows Help system.

Register

Displays the Register Dialog where you can enter your registration key to turn your Shareware version of HTMASC
into the registered version.

Only You can make a Smiley SMILE!

About
Shows the About HTMASC dialog box with copyright and version information.



Frequently Asked Questions

I'm trying to open a HTML File and I get the error message: "Unknown filetype ..."

When I click on the Smiley button nothing happens, why?
My Registration Key doesn't work.

I can't enter a new Qutput Directory

Why is the file ENTITIES.HTM included?



Error message: "Unknown filetype ..."

Prior to loading a HTML File HTMASC has to determine its type (DOS or UNIX) to allow a proper file handling.
The main difference between DOS and UNIX files is the character used for end of paragraph . DOS uses a
combination of CRLF (Carriage return - Line feed) while UNIX uses only LF.

The most likely cause of this error is a file that differs from this standard, e.g. it uses only a CR for the end of
paragraph marker.



Smiley button

It serves NO specific purpose.

BUT after registering HTMASC Smiley's mood changes from @ to

Only You can make a Smiley SMILE!



Registration Key Problem

If you encounter a problem when you try to register HTMASC, please make sure to verify the following:
e  The User Name must be identical to the name you sent me for registration

e  The Registration Key must be entered exactly

®  The Program Version must be the same that you have registered for.

There is also the possibility that you have found a bug, please send me your name, the version number of
HTMASC and your registration key by E-Mail. I'm sure we will find a solution!



I can't enter a new Output Directory

Check if the 'Same Directory' Option is selected.
You can change this setting using the Options Dialog or click on the SD - Light of the Options Speed Bar.




This file contains all of the HTML Entities.
I included it to prove that HTMASC is able to convert ALL of these Entities.

You might as well use it to compare HTMASC to other conversion programs ;-)



Whats new in Version 1.1

e  Resizeable Windows

e  Options Speed Bar

e Extended Options Dialog

e  Set Bookmarks using the Popup Menu



Whats new in Version 1.2

¢  Bugfix: Fixed incorrect handling of Java Scripts included in *.htm files .

® Change: The program name and the INI file name is now HTMASC (without the version number added to the
filename). This should make it easier for you to install new versions (e.g. you don't have to redo your option

settings after install).

¢ Some minor changes in the conversion routines.



Pricing and Ordering Information
This version of HTMASC is SHAREWARE. The registration price is US$18.- for a single user license.
Ordering HTMASC

There are a number of ways to order HTMASC from us. When we receive your payment, we will e-mail you the
serial number to register HTMASC.

CompuServe
The easiest way to register HTMASC is via CompuServe's shareware registration service (GO SWREG, registration
ID is #10241).

Credit Card
Sorry, only VISA can be accepted!
A registration form for Credit Card Orders is available on:

http://ourworld.compuserve.com/homepages/bite/register.htm

Alternatively you may send us your credit card details by post or e-mail

Cash

We will accept cash in

US dollars ($18.-),

German Marks (DM30.-)

or Austrian Shillings (5200.-).

However, we will take no responsibility for the cash while it's in transit. For your own protection if you want to pay
in cash, we strongly recommend sending it to us by registered mail.

Note: Make sure to include your E-Mail address!!!

What happens when I purchase HTMASC?

When you register, you'll get a key which disables the Shareware Reminder Screen, technical support by E-Mail
AND you get

2 WINDOWS BONUS PROGRAMS!

RWATCH and
STAMP IT!

for FREE!

How to get the latest version

The preferred source of information about HTMASC is our Web site:
http://ourworld.compuserve.com/homepages/bite

You may also try the following forums on Compuserve:
INETRESOURCE Lib9 / WWW/Hypertext Tools

WINSHARE Lib11 /Internet/HTML
PCUTIL Lib4/Windows



PCONLINE Lib9 / Internet

How to reach us

Compuserve: Walter Novacek 100341,240
Internet: 100341.240@compuserve.com
Fido: Walter Novacek@2:310/39.15

You can also use snail mail:

BITE'n'BYTE SOFTWARE
Walter Novacek
Kirchstetterng.56/12
A-1160 Vienna

AUSTRIA



Monitors System Resources (WIN)



Changes DATE/TIME of selected files (WIN)



Credits and Copyrights

HTMASC is the registered trademark of Bite'n'Byte Software.

For Product License Information please read LICENSE.TXT.

This product uses several components from TurboPower Software's Orpheus package.
Special Thanks to Lee Inman from TurboPower Software for his great support.

Thanks to Nick Hodges for his TSmiley, the Delphi Component of the century!



Contacting the Author

The preferred source of information about HTMASC is our Web site:
http://ourworld.compuserve.com/homepages/bite

Here you can download updates and bug fixes to HTMASC, follow links to a number of HTML resources on the
Web, subscribe to our mailing list and much more.

Technical Support

Technical support for HTMASC is available by e-mail to registered users only.

Compuserve: Walter Novacek [100341,240]

Internet: 100341.240@compuserve.com

Fido: Walter Novacek@2:310/39.15

Pricing and Ordering Information










