Media Player Help Index

This Index lists the Help topics available for Media Player. Use the scroll bar to see entries not currently visible in
the Help window.

To learn how to use Help, press F1 or choose Using Help from the Help menu.

If the information you seek is not included in Help, see "Using Media Player" in the Video for Windows User's
Guide. If you cannot find the answer to your question, contact Product Support.
Keyboard
Media Player Keys

Commands

File Menu Commands
Edit Menu Commands
Device Menu Commands
Scale Menu Commands

Procedures
Changing the Scale
Closing a Media Device
Controlling Media Player's Appearance
Editing an Embedded Media Clip
Embedding a Media Sequence in Another Application
Moving to Another Position
Opening a File
Playing a Media Sequence
Quitting Media Player
Selecting Part of a Media Sequence
Setting Video Viewing Characteristics
Setting Media Player Options
Specifying a Media Device
Stopping a Media Sequence

Controls
Eject Button
Mark In Button
Mark Out Button
Next Mark Button
Page Left Button

Page Right Button
Play/Pause Button

Previous Mark Button

Stop Button
Track Bar




Media Player Keys

Use the following keys to perform Media Player functions:

Press To Do

SPACEBAR To invoke the current control.

TAB To select the next control button as the current control.

SHIFT+TAB To select the previous control button as the current control.

ESC To stop playing the current media sequence. This is identical to choosing Stop.

HOME To move to the beginning of the media content.

END To move to the end of the media content.

PAGE DOWN To move to the next page of the media content.

PAGE UP To move to the previous page of the media content.

CTRL+PageDown To move to the beginning of the next track, (available when the Tracks scale is
displayed)

CTRL+PageUp To move to the beginning of the previous track, (available when the Tracks scale is

CTRL+C or CTRL+INS

CTRL+D

CTRL+F

CTRL+L

CTRL+O

CTRL+P

ALT+P or ALT+CTRL+P
CTRL+S
CTRL+U

CTRL+W

CTRL+1
CTRL+2
CTRL+3
CTRL+4

displayed)

To copy information that makes up a Media Player object to the Clipboard. This is
identical to the Copy Object command on the Edit menu.

To edit the Media Player playback device driver configuration. This is identical to the
Configure command on the Device menu.

To select a new file to play with Media Player. This is identical to the Open command
on the File menu.

To edit the current selection. This is identical to the Selection command on the Edit
menu.

To edit the Media Player Options dialog box settings. This is identical to the Options
command on the Edit menu.

To play the media content from the stopped or paused position. Or, to pause the media
content when during playback.

To play the current selection marked in the media content.
To stop playback of the media content.

To close the current file or device. This is identical to the Close command on the Files
menu.

When editing an embedded object, CTRL+U updates the embedded object instead of
closing the current file or device.

To change Media Player from its normal appearance to its abbreviated form and vice-a-
versa.

To zoom the playback image size to the frame size.

To zoom the playback image size to twice the frame size.
To zoom the playback image size to 3 times the frame size.
To zoom the playback image size to 4 times the frame size.



Media Player Commands

To get help with a command, choose the appropriate menu.

File Menu Commands
Open
Close
Exit

Edit Menu Commands
Copy Object
Options
Selection

Device Menu Commands
The Device Menu contains a list of the devices installed on your system and a Configure command that is unique for
each device. Some device types that Media Player can recognize include the following:
Animation
CD Audio
Video for Windows
MIDI Sequencer
Sound
Configure

Scale Menu Commands
Time
Frames
Tracks



Media Player Procedures

The Procedure topics give you step-by-step instructions for using Media Player. Use the scroll bar to see more
topics.

To learn how to use Help, press F1 or choose using Help from the Help menu.

Procedures
Specifying a Media Device
Opening a File
Closing a Media Device
Playing a Media Sequence

Stopping a Media Sequence

Changing the Scale

Moving to Another Position

Selecting Part of a Media Sequence

Controlling Media Player's Appearance

Embedding a Media Sequence in Another Application

Editing an Embedded Media Clip
Setting Video Viewing Characteristics

Setting Media Player Options
Quitting Media Player




Play/Pause Button

E Plays the content of the currently loaded device. When a device is playing, the Pause button replaces the
Play button.

E Pauses the device that is currently playing.



Stop Button

E Halts the media sequence or device that is currently playing.



Previous Mark Button

E Moves the slider to the closest mark to the left. If both the mark-in and mark-out marks are to the right of
the slider, the slider moves to the left edge of the track bar and rewinds the media sequence.
Selecting SHIFT+Previous Mark moves the slider as described above and selects the portion of the video sequence

traversed by the slider.



Page Left Button

E Steps backward through the media sequence loaded in Media Player in approximately 10 percent
increments.



Page Right Button

E Steps forward through the content loaded in Media Player in approximately 10 percent increments.



Next Mark Button

E Moves the slider to the closest mark to the right. If both the mark-in and mark-out marks are to the left of
the slider, the slider moves to the right edge of the track bar and reaches the end of the media sequence.
Selecting SHIFT+Next Mark moves the slider as described above and selects the portion of the video sequence

traversed by the slider.



Track Bar
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Represents the media sequence loaded in the Media Player device. The slider indicates the current playing position
of the media sequence.

You can move the current playing position by dragging the slider to another location on the track bar or by selecting
one of the arrows at its right edge.




Eject Button

@ Ejects the media cartridge from the Media Player device. This button is enabled for devices that have
programmatic control of their eject buttons.



Mark In Button

Marks the beginning edge of a selection.
Together, the Mark In and Mark Out Buttons let you mark a selection of the current media sequence for playing or

for embedding in another application. You can also mark a selection by using the Selection command from the Edit

menu.



Mark Out Button

Marks the ending edge of a selection.
Together, the Mark In and Mark Out Buttons let you mark a selection of the current media sequence for playing or

for embedding in another application. You can also mark a selection by using the Selection command on the Edit

menu.



Media Player

A Microsoft Windows application for playing media sequences and controlling hardware devices. Media Player can
play waveform and Musical Instrument Digital Interface (MIDI) sounds, video sequences, and control any Media
Control Interface (MCI) multimedia device installed in your system. For example, you can use Media Player to
control devices such as audio compact discs or videodisks.

Media Player can run as a stand-alone application or as an embedded application in a document belonging to another
application, such as a spreadsheet, a presentation, or a word processing document. When inserted in another
application, the embedded version of Media Player, its media sequence, and a selection of the media sequence (if it
exists), is called a media clip object.

Media Player uses Object Linking and Embedding (OLE) technology to become part of another document.



Media Player Procedures

The Procedure topics give you step-by-step instructions for using Media Player. Use the scroll bar to see more
topics.

To learn how to use Help, press F1 or choose Using Help from the Help menu.

Procedures
Changing the Scale
Closing a Media Device
Controlling Media Player's Appearance
Editing an Embedded Media Clip
Embedding a Media Sequence in Another Application
Moving to Another Position
Opening a File
Playing a Media Sequence
Quitting Media Player
Selecting Part of a Media Sequence
Setting Video Viewing Characteristics
Setting Media Player Options
Specifying a Media Device
Stopping a Media Sequence




Specifying a Media Device

Media Player supports two types of devices: simple and compound. When you choose a simple device from the
Device menu, Media Player is ready to start playing whatever is currently loaded in the hardware device.
Compound devices require, in addition to the device name, a specified media file (such as the synthesizer that
plays waveform audio).

The contents of the Device menu varies according to your system configuration. For Media Player to list a device
in the Device menu, the device and its software driver must be correctly installed and configured in your system.

To specify a simple device:
* From the Device menu, choose the media device you want.
Names of simple devices are not followed by an ellipsis (. . .).

To specify a compound device:

1 From the Device menu, choose the media device you want.
Names of compound devices are followed by an ellipsis (. . .).
The Open dialog box appears.

2 Type or select the name of the file you want to play.

3 Choose OK.
The first time you specify a compound device (such as Sound), Media Player displays the File Open dialog box
for you to identify a file you want to play. Once you specify the device, you can use the Open command to open
other files available for use by that device. To use a different device, you can choose that device from the
Device menu, or you can choose a different file type from the Open dialog box.

Related Topics
Closing a Media Device

Opening a File
Playing a Media Sequence




Opening a File

If a compound device is already specified, you can open and play files appropriate to play for that device. For
example, if you've specified a MIDI Sequencer device, then you can open and play MIDI files. To play another
type of file, you can change to another device type using the Open dialog box or the Device menu. Media Player
associates the various types of media files with the appropriate devices and automatically allocates the needed
playback resources when you select a file.

To open a file to play:
1 From the File menu, choose Open.
The Open dialog box opens.
2 Type or select the name of the file you want to open.
To change the device type, select another entry in the List Files Of Type box.
3 Choose OK.

Related Topics

Closing a Media Device
Playing a Media Sequence
Specifying a Media Device




Closing a Media Device

When you finish using a device with Media Player, you can release control of that device by closing it. You can
close simple and compound devices using the Close command from the File menu; however, the effects of closing
simple and compound devices differ slightly.

For simple devices, Media Player releases control of the device, allowing other applications to access the device. If
a media sequence is playing on a simple device when it is closed, the sequence continues to play.

For compound devices, Media Player closes the file, then releases control of the device. If a media sequence is
playing on a compound device when it is closed, the Close command halts the sequence

To close a media device:
* From the File menu, choose Close.

Related Topics

Opening a File
Playing a Media Sequence
Quitting Media Player

Specifying a Media Device




Playing a Media Sequence or Device

After specifying a media device and for a compound device, a file, use the following procedures to play the media
sequence or device.

To start play or restart a paused media sequence:
* Select the 2] Play button.
When playback is started, the title bar displays the word "(Playing)" following the device title.
Or, with Media Player embedded in another application's document, double-click the media clip icon.

To play a marked selection in a media sequence:
* With a stand-alone copy of Media Player, press ALT while choosing the Play button.

Or, with Media Player embedded in another application's document, choose Play.

To pause play:II
* Select the L Pause button.
When playback is paused, the title bar displays the word "(Paused)" following the device title.

Related Topics

Changing the Scale

Controlling Media Player's Appearance
Moving to Another Position

Opening a File
Selecting Part of a Media Sequence

Setting Video Viewing Characteristics
Setting Media Player Options
Specifying a Media Device

Stopping a Media Sequence




Stopping a Media Sequence or Device

After specifying a media device and for a compound device, a file, use the following procedures to play the media
sequence or device.

To stop play:
* Select the = Stop button.
When playback is stopped, the title bar displays the word "(Stopped)" following the device title.

To eject a compact disc or other media element:
il
* Select the = Eject button.
The Eject button is available only with devices that include a software-based eject function.

To stop playing a media clip object (in full-screen or in the embedding application):
* Press the ESC or ALT key, or the CTRL+S key combination.

To stop playing a media clip object (in the Media Player window):

* Press the ALT+F4 key combination, click the right mouse button, or double-click the system menu in the upper-
left corner of the Media Player window.

Related Topics

Changing the Scale

Controlling Media Player's Appearance
Moving to Another Position

Opening a File

Playing a Media Sequence

Selecting Part of a Media Sequence
Setting Video Viewing Characteristics
Setting Media Player Options
Specifying a Media Device




Changing the Scale

Media Player displays one of three scales beneath the track bar. You can use a time scale for any media sequence.
But, some media types, such as Video for Windows, can also use another scale to locate specific portions of a
media sequence. You can select one of the following reference scales for the current media sequence.

* Time scale: shows time intervals

* Frames scale: shows frames of a video sequence

* Track scale: shows tracks

To change scales:
* From the Scale menu, select Time, Frames, or Tracks.
Changing the scale erases any mark you set in the current media sequence.

Related Topics
Selecting Part of a Media Sequence




Moving to Another Position

You can move around within a media sequence to play your favorite songs or view the best portions of a video
sequence and not have to play the entire media sequence. To move to another position in a media sequence, move
slider to another location on the track bar; then choose Play to play the media sequence, beginning at the current
position.
To change the playback position:
* Drag the slider to the desired position on the track bar.

-Or-
* Select the scroll arrows at the right edge of the track bar.

-Or-
* Use the LEFT ARROW, RIGHT ARROW, PAGE UP, PAGE DOWN, HOME, and END keys.

-Or-

* Select one or more of the E Page Right,
E Page Left,
Next Mark, and

E Previous Mark buttons.



Selecting Part of a Media Sequence

Media Player allows you to play a media sequence from the current slider location or a selection of a media
sequence. To play a selection, you mark the beginning and end of the selection, then play the selection. You can use
either the Media Player controls or the Selection command to mark a selection of a media sequence for playing.

To mark a selection using Media Player controls:

1 Drag the slider to the beginning of the section you want to mark.
2 Choose the 2= Mark In button.
3 Drag the slider to the end of the section you want to mark.

4 Choose the E Mark Out button.

Or, after dragging the slider to the beginning of the selection you want to mark, hold down the SHIFT key as you
drag the slider to the end of the selection you want to mark.

To mark a selection using the Selection command:

1 From the Edit menu, choose Selection.

Or, double-click the rule of the scale.
2 Select From and enter the beginning time, frame, or track and time of the section.

3 Set the range of the section using either the To box or the Size box.
*  Select the To box and enter the last time, frame, or track and time of the selection.

*  Select the Size box and enter the duration of the selection as elapsed time, frames or tracks and time.
4 Choose OK.

Note Once You've marked a portion of a media sequence you want to play, keep the current scale for the track bar.
Changing the scale clears the selection.

Related Topics
Embedding a Media Sequence in Another Application
Set Selection Dialog Box




Embedding a Media Sequence in Another Application

In addition to using Media Player as a stand-alone application, you can embed Media Player as a media clip object
into another application. For example, you can embed a sound clip in a spreadsheet. When you select the place
marker of the embedded sound clip in the spreadsheet application, the sound clip plays.

To embed a media clip in another application:

1 Start Media Player.

2 From the File menu choose Open and select the file or device you want to play.

3 If the embedded media clip is a video clip or animation, move the slider to a frame that best represents the entire
clip.
When you paste the video clip or animation into an application, the selected frame will be used as the place
marker for the media clip object.

4 From the Edit menu, choose Copy Object.

5 Select the application or document into which you want to insert the media clip object.

6 From the Edit menu, Use the Paste or Paste Special command to embed the media clip.

Note If using the Paste or Paste Special commands doesn't properly insert the media clip into the application,
refer to your application's documentation for additional information about using OLE objects from another
application.

The Cardfile application for Windows accepts Media Player objects when the card is in Edit picture mode. For
additional information, see the Windows User's Guide.

Related Topics

Editing an Embedded Media Clip
Setting Media Player Options




Setting Video-Viewing Characteristics

Media Player uses the Video for Windows device when playing video sequences captured and edited with Video
for Windows. The Video for Windows device is an MCI device that has its own set of configuration options. Once
you have opened the Video for Windows device or another MCI device, you can set its configuration options using
the Configure command from the Media Player Device menu or through the Control Panel Drivers option.

To set video-viewing characteristics:
1 From the Device Menu, choose Configure.

If the Configure command is not accessible or the Video Playback Options dialog box does not appear, you
must first select the Video for Windows device type and specify a .AVI file containing a video sequence.

2 Select the viewing mode and other video sequence options you want.

4 Choose OK.

Note When using Media Player as a stand-alone application, each video sequence initially uses a set of default
values for the Video Playback options. The changes you make for a specific video sequence apply only to that
sequence. If you want all video sequences to use one or more specific options, change the default settings by
choosing the Set Default button.

Note When using Media Player as an object in another application, you can control the Video Playback options
for the media clip object by choosing the Set Default button.

Related Topics

Controlling Media Player's Appearance
Setting Media Player Options

Video Playback Options Dialog Box




Setting Media Player Options

Media Player provides several playback and display options that apply to media clips being copied to other
applications. Two of these options (Auto Rewind and Auto Repeat) can also be used when Media Player runs as a
stand-alone application.

To set Media Player playback options:

1 From the Edit Menu, choose Options.

The Options dialog box appears.
2 Select the presentation and playback options you want to use.
3 Choose OK.

Related Topics

Controlling Media Player's Appearance
Setting Video Viewing Characteristics
Media Player Options Dialog Box




Quitting Media Player

When you close Media Player, simple devices will continue to play (such as audio compact-disc players).
Compound devices stop playing when you quit the application.

To quit Media Player:
* From the File menu, choose Exit.

To quit from a media clip object:
* Select another item or area of the application containing the media clip.

Related Topics
Closing a Media Device




Editing an Embedded Media Clip

You use Media Player to control the playing of a media sequence. However, if you embed a media clip into a
document in another application, you do not have to leave that application to edit the clip. Because the media clip
is embedded, you can start Media Player from the other application, edit the media clip, and then close Media
Player.

To edit an embedded media clip:

1 Open the document in which you have embedded a media clip.
2 Select the embedded clip you want to edit.
3 From the Edit menu, choose Media Clip Object.
The Media Clip menu appears next to the Media Clip Object command.
4 From the Media Clip menu, choose Edit.
Media Player opens with the file open or the device selected.

5 Edit the media clip as needed.
6 From the File menu in Media Player, choose Update.
This updates the embedded media clip in the other application.
7 From the File menu in Media Player, choose Exit.
Media Player closes, and Windows returns you to the document in the other application.
Related Topics

Embedding a Media Sequence in Another Application
Setting Media Player Options




Controlling Media Player's Appearance

Media Player provides an abbreviated form of its controls. For devices that do not require a playback window, the
abbreviated presentation of Media Player includes the track bar, and the Play/Pause and Stop buttons. For video
and animation devices that use a playback window, the playback window is inserted into Media Player above the
abbreviated controls.

To switch to the abbreviated form of Media Player:

* Press CTRL+W to change from the normal Media Player display to the abbreviated presentation.
Or, double-click the Media Player title bar to change to the abbreviated presentation.

* Press CTRL+W again to return to the normal Media Player display.
Or, double-click the Media Player title bar to return to the normal display.

To resize the display window with the abbreviated form of Media Player:

* Choose the Maximize button in the upper-right corner of the window to double the size of the display window.

* Or, drag the window frame to increase the size of the window.

* Or, choose the Restore button in the upper-right corner of the window to restore the window to the default
image size.

Related Topics
Setting Media Player Options
Setting Video Viewing Characteristics




Media Player Options Dialog Box
The Media Player Options dialog box consists of the following options:

Dialog box options:

Auto Rewind

Rewinds a media sequence, selection, or clip to play again when Media Player reaches the content's end.
You can use Auto Rewind with Media Player as a stand-alone application or as a media clip object.

Auto Repeat

Plays a media sequence selection, or clip as a continuous loop. If this option is set in a media clip object,
the media clip will remain open until you select another item or area in the application.
You can use Auto Rewind with Media Player as a stand-alone application or as a media clip object.

Caption
Adds space for a caption at the base of a media clip object. The media clip object uses the text from the box

to the right of the Caption option in the Options dialog box. If this option is not selected, the media clip
object does not display a caption.

Border Around Object
Inserts a thin border around the window of the media clip object.

Play in Client Document
Plays a media clip within the window of the application containing the media clip object. If this option is
not selected and the Control Bar on Playback option is selected, the media clip object opens another
window containing the abbreviated controls (and playback window, if necessary) to play the embedded
media clip.

Control Bar on Playback

Displays a control bar for playback when the media clip object is selected. The control bar includes a
Play/Pause button, a Stop button, and the track bar that you can use to move to another positions in the
media clip.

Dither Picture to VGA Colors
With an embedded video clip or animation, the media clip object is marked in an application with a picture
instead of an icon. The place marker for the media clip object consists of one frame from the embedded
media clip. This option dithers the image of the place marker using the colors from the standard VGA color
palette.

If this option is not selected, the place marker uses the color palette of the video clip or animation, creating
possible color distortion.

Related Topics
Setting Media Player Options




Video Playback Options Dialog Box

For the Video for Windows device, the configuration options let you adjust viewing characteristics of a video
sequence. The Video Playback Options dialog box includes the following options:

Zoom by 2
Doubles the frame size of the playback area in normal and full-screen modes.

Play Only If Waveform Device Available
If a video sequence includes a sound track and the audio resources are already in use, Media Player won't
play the video sequence until the audio resources become available. If this option is not selected, Media
Player plays the video sequence immediately with or without the soundtrack, depending on the availability
of the audio resources.

Seek to Nearest Full Frame

Causes Media Player to choose the nearest full frame when a jump to a non-consecutive frame occurs
(always displaying the correct frame image.)

If this option is not selected, media Player chooses the exact frame when a jump to a non-consecutive frame
occurs. Media Player displays the current frame data correctly. However, if the frame depends on other
frame for some of its data, the frame display might contain inaccuracies.

Skip video Frames If Behind
Prioritizes the sound track of a video sequence above the frame. If Media Player cannot maintain the

playback pace, it skips video frames to keep pace with the audio track. If this option is not selected, media
Player plays all frames of the video sequence and pauses the audio track as needed.

Don't Buffer Offscreen
Provides a slightly faster playback rate by omitting updates to an off-screen buffer of the playback window.
If your system cannot keep pace with the playback rate of a video sequence, but lags only slightly, this
option might allow you to play the video sequence at its normal rate without dropping frames.

If you select this option and your system still lags behind the playback rate of the video sequence, the video
images might become fuzzy. Also, since a copy of the playback window is not being updated off screen,
jumping to another position within a video sequence will probably result in a distorted image until Media
Player reaches the next full frame.

Related Topics
Setting Video Viewing Characteristics




Set Selection Dialog Box

The Set Selection Options dialog box allows you mark a selection for playback and consists of the following
entries:

All
Select this button entry to mark the entire media sequence in your selection.

None
Select this button entry to erase an existing selection or selection markers.

From
Select this button when you want to make a new selection or edit an existing selection.

Once you select the From button, you can enter or edit the From, To, and Size boxes.
The From box specifies the beginning of the selection. The value you enter into the From box identifies the
starting point of the selection from the beginning of the media sequence.

To
Specifies the end of the selection. The value you enter into the To box identifies the ending point of the
selection from the beginning of the media sequence.

Size
Specifies the length of the selection. With a value from either the From or the To box, the value you enter
into the Size box determines where the other selection marker is placed.

Note Entries for the From, To, and Size boxes use the same units as those currently used for the
reference scale: time, frame number, or track and elapsed time within the track.

Related Topics
Selecting Part of a Media Sequence







File Menu Commands

The File Menu contains these commands:
Open
Close
Exit

Scroll down to see descriptions of each command.

Open
Opens a multimedia data file or device to play with Media Player. In addition to loading the selected media file,
Media Player allocates, based on the filename extension, an appropriate device to play the file.

Related Topics

Closing a Media Device

Opening a File

Playing a Media Sequence
Specifying a Media Device

Close
Releases the device allocated by Media Player and, for compound devices, closes the open media file.

Related Topics

Closing a Media Device
Opening a File

Playing a Media Sequence
Specifying a Media Device

Exit
Closes the device and file allocated by Media Player.

Related Topics
Closing a Media Device




Edit Menu Commands

The Edit Menu contains these commands:
Copy Object
Options
Selection

Scroll down to see descriptions of each command.

Copy Object
Copies Media Player and its current media sequence to the Clipboard as a media clip object that can be inserted in
another application.

Related Topics

Embedding a Media Sequence in Another Application
Setting Media Player Options

Options
Describes how to handle end-of-media conditions of the current media sequence and describes the presentation
options of a media clip object when it's copied to the Clipboard.

Related Topics

Embedding a Media Sequence in Another Application
Setting Media Player Options

Selection
Marks a portion of the current media sequence for playback.

Related Topics

Changing the Scale
Selecting Part of a Media Sequence




Device Menu Commands

The Device Menu contains a list of the devices installed on your system and a Configure command that is unique for
each device. Some device types that Media Player can recognize include the following:

Animation

CD Audio

Video for Windows

MIDI Sequencer

Sound

Video Cassette Player

Videodisc

Other devices, if properly installed with an MCI device driver, can be used with Media Player and will appear on the
Device menu.

Scroll down to see descriptions of each command.

Animation
Specifies a device that plays animations converted to the Microsoft Multimedia Movie file format.

CD Audio
Specifies a device that plays digital audio from an audio CD.

Video for Windows

Specifies a device that plays video sequences from .AVI files. The Video for Windows device supports video
sequences made from 8-bit, 16-bit, and 24-bit color images with or without an accompanying sound track.

The Configure command for the Video for Windows device controls the video mode and some of the video
playback options for the copy of Media Player that is running.

MIDI Sequencer
Specifies a device that plays MIDI (.MID or .RMI) files. The number of voices and the degree of polyphony depend
on the characteristics physically supported by the sequencer.

Sound

Specifies a device that plays digital audio (waveform or .WAV) files. The quality level of sound files supported by
the Sound device ranges from a voice-grade recording to Redbook (audio CD) quality sound.

The Configure command for the Sound provides a control to manage the amount of extended memory (RAM) used
to buffer the contents of the sound files.

Video Cassette Player
Specifies a device that plays video cassette cartridges.

Videodisk
Specifies a device that plays videodisks.
Related Topics

Setting Video Viewing Characteristics
Specifying a Media Device




Scale Menu Commands
The Scale Menu identifies the following scales to use with different types of media:
Time
Frames
Tracks

Scroll down to see descriptions of each command.

Time Scale
Displays the scale as elapsed time from beginning to end of the content.

Frames Scale
Displays the scale as a sequence of frames from beginning to end of the currently-loaded video sequence.

Track Scale
Displays the scale as one or more tracks from beginning to end of the content.
Related Topics

Changing the Scale
Selecting Part of a Media Sequence







simple device

A device that plays a media sequence without specifying an associated media file. For example, one such simple
device would be an audio compact-disc player,



compound device

A device that plays media sequences by accessing data files on disk or CD-ROM. For example, to play a waveform
audio device you must specify the device along with the WAV file you want to play.



Media Control Interface (MCI)

A standard control interface for multimedia devices and files. MCI allows a multimedia application to easily
control a variety of multimedia devices and files.



track bar

A bar that appears above the control buttons. The track bar represents the duration of the current media sequence.
The left edge represents the beginning of the sequence and the right edge represents the end of the sequence. The
track bar also includes a slider that indicates Media Player's current playing position.



slider

A pencil-shaped pointer attached to the track bar that that shows the current playing position of Media Player. You
can move the slider to different positions along the track bar.



Product Support

If you purchased Video for Windows directly from Microsoft or through a retail outlet, product support information
is listed at the end of the Video for Windows User's Guide (following the index).

If your copy of Video for Windows is part of an OEM product, you should consult the OEM product
documentation for addition support information.









