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Overview
Whether it's remodeling, adding an addition, or building a home, it's always wise to draw up some plans 
before diving into a project. Floorplan Plus 3D is the software tool for this planning stage, making it 
possible to draw your floor plan in two dimensions and then "walk through" your plan in three dimensions.

Floorplan Plus 3D provides tools for drawing walls, wires, pipes, surfaces, windows, doors, furniture and 
appliances; for calculating measurements; and modifying plans. Drawings are distributed over 13 layers 
in each of up to 20 floors allowing for transparent or simplified views. Drawings can be viewed, printed or 
exported in any combination of layers. Objects you create can be stored in libraries for easy use within 
other drawings.

You can print comprehensive drawings, layers, floors, three dimensional wire frames, shaded illustrations, 
a Materials List and an Object Catalog.

Floorplan Plus has been used in many ways. Catering companies have used Floorplan Plus    to show 
their customers how they plan to set up banquet tables. Fire departments have used it to map out 
buildings and to indicate locations of sprinkler valves and other controls. Even police departments have 
used Floorplan Plus to sketch out accident and crime scenes.

Floorplan Plus 3D's files are compatible with 3D Design for drawing three dimensional objects, and with 
Estimator Plus for easily computing the cost of your project. All of these, and many other intuitive and 
reasonable priced products are available from ComputerEasy.    Call (800) 522-3279 for a catalog.

Whatever your project, we hope Floorplan Plus 3D will help make the planning stage an easy and 
enjoyable one!



Before You Begin
Please note the following before using Floorplan Plus 3D:

Floorplan Plus 3D runs on Windows 3.0 or higher.

Floorplan Plus 3D requires about 8 MB on a hard drive and 2 MB of memory, although 4 MB is 
recommended.

Before using Floorplan Plus 3D, it must be properly installed. See Chapter 2, "Starting Floorplan 
Plus 3D," for complete information on installation.

The Tutorial in Chapter 12 of the User's Guide is an excellent introduction to Floorplan Plus 3D 
and takes about half an hour.



Conventions
This Floorplan Plus 3D    Guide uses the following conventions:

Boldface letters denote the names of keys, menu commands, icons and buttons. For example, 
the Return key is denoted as Return.

Key combinations are denoted by a plus (+). For example, "press the Control key and the H key 
simultaneously" is denoted as Ctrl+H.

Information to be entered is denoted by quotation marks. For example, "chair" instructs you to 
type c-h-a-i-r, exactly as shown.

Variable information that you supply is denoted by italic characters. For example, object_library 
instructs you to enter the object library file name you desire.



Technical Support
ComputerEasy International backs all of its products with a customer support system designed to give 
you fast, effective service. If you have exhausted all other avenues of help and need assistance with a 
specific problem, please follow these steps:

Try to duplicate the problem, keystroke by keystroke, so you can

better explain how the problem was encountered.

Please have some system information handy, including:

¾ The kind of computer you are using.

¾ The Windows version you are running.

¾ The version of Floorplan Plus 3D you are using (Choose About 
Floorplan Plus 3D from the Help menu.)

It is important to call when you are in front of your computer.

Customer support is available Monday through Friday, from 8:00 A.M. to 5:00 P.M. Mountain time at (602) 
731-3134.



Installing Floorplan Plus 3D

To install Floorplan Plus 3D
1. Make backup copies of the Floorplan Plus distribution disk(s). Use the MS-DOS command 

diskcopy to copy the Floorplan Plus 3D disk(s).

2. Start Microsoft Windows.

3. Insert the Floorplan Plus 3D disk #1 into drive A: (or B: if applicable).

4. Choose Run from the File menu in the Windows Program Manager.

5. Type "a:\setup" (or "b:\setupl" if using drive B:) and press Return or click OK.

6. Follow the instructions provided by the installation program.



Running Floorplan Plus 3D

To run Floorplan Plus 3D
1. Double-click on the Floorplan Plus 3D icon.



Parts of the Window

Title Bar
Displays the file name of the current active Floorplan Plus 3D drawing file. If no drawing file is active, 
"untitled.fp3" is displayed.

Menu Bar
Contains a list of menus. Each menu contains commands which perform various actions in Floorplan Plus 
3D.

Ribbon Bar
Contains a collection of icons representing various Floorplan Plus 3D menu commands. Hide the Ribbon 
bar by choosing Ribbon bar from the Options menu.

Tool Bar
Contains a collection of tools used to draw objects in Floorplan Plus 3D. Hide or float the Tool bar by 
choosing Tool bar from the Options menu.

Style Bar
Displays the style and attributes of the selected object or tool and provides for editing attributes. Hide the 
Style bar by choosing Style bar from the Options menu.

Help/Status Bar
Displays instructions or status information for the current command or tool being used. Hide the Status 
bar by choosing Status bar from the Options menu.

Drawing Area
The part of the Floorplan Plus 3D screen where drawings are built and displayed.

Scroll Bars
Allows you to move, or pan, to different parts of a drawing. This is especially useful if your drawing is too 
large to be displayed entirely in the Drawing Area.

Cursor
Used to build your drawing, and to select Floorplan Plus 3D menus and commands. The cursor changes 
shape depending on the tool or command selected.



Menu Bar
The menu bar is a list of menus containing commands which perform various actions in Floorplan Plus 
3D. Choosing commands from the Menu Bar is how you tell Floorplan Plus 3D to perform a particular 
action. Alternatively, many of the commands contained in the menus can also be selected by clicking on a 
corresponding icon. These icons will be explained in a later section. 

Related Topics:
To choose a command from the Menu Bar



To choose a command from the Menu Bar
1. Point to a menu name, click the left mouse button.

2. Point to the command name, and click the left mouse button.



Menus
The Floorplan Plus 3D menus are:

File    Contains commands dealing with Floorplan Plus 3D 
drawing files. These commands are used to configure 
Floorplan Plus 3D, open and save drawings, print, export 
a drawing, run the 3D viewer and roof editor, and quit 
Floorplan Plus 3D. See "Working with Drawing Files," for 
detailed information on using the File commands.

Edit    Contains commands used to edit a Floorplan Plus 3D 
drawing. See    "Editing Drawings and Symbols," for 
detailed information on how to use the Edit commands.

Options    Contains commands to change various options in 
Floorplan Plus 3D, such as the appearance of the 
Drawing Area, and text and drawing options. See 
"Labeling, Measuring and Options," for detailed 
information on how to use the commands in the Options 
menu.

Symbols    Contains commands which deal with Floorplan Plus 3D 
symbols and symbol libraries. See "Symbols and Symbol 
Libraries," for detailed information on how to use Symbol 
Libraries and the Symbol commands.

View    Contains commands used to zoom in and zoom out of 
the current drawing, viewing drawing layers, the grid, 
building layer, reference distance and the status/help 
bar. See "Controlling the Drawing Area," for detailed 
information on how to use the Zoom commands.

Help    Contains commands that access the on-line help 
system.



Ribbon Bar
The Ribbon bar contains icons that represent the most commonly used menu commands in Floorplan 
Plus 3D. To select an icon, simply click on that icon in the Ribbon. Below is a summary of the icons in the 
Ribbon and their functions.

Click To

Floor Draw a floor.

Straight Stair Draw a standard staircase.

Spiral Stair Draw a spiral staircase.

Railing Draw a railing.

Door Place a door.

Window Place a window.

Load Place a symbol from a symbol library.

Adjust Resize or move a wall.

Zoom In Zoom in.

Zoom Out Zoom out.

Zoom to Window Zoom a selected area to fit in the window.

Zoom to Extents Zoom to fit drawing in window.

Dimension Measure length of a reference line.

Area Compute perimeter and area of an area.

Paste Place the contents of the Clipboard.

Undo Reverses the last edit.

Redo Reverses the last "Undo."

3D View the drawing in 3D.



Tool Bar
The Tool bar contains tools used to create or edit objects and shapes in Floorplan Plus 3D. To select a 
drawing tool, simply click on that tool in the Tool bar. Below is a summary of the Tool bar icons and their 
functions. See Chapter Six, "Drawing Tools and Attributes," for detailed information on using each tool.

Click To

Selection Select an item in the current drawing.

Wall Draw a wall.

Wire & Pipe Draw Wire and/or Pipe.

Area Draw an area.

Line Draw a line.

Rectangle Draw a rectangle.

Polygon Draw a regular polygon.

Arc Draw an arc.

Text Draw text.

Circle Draw a circle.

Ellipse Draw an ellipse.

Fill Shape Fill a shape with a pattern.

Freehand Draw freehand.



Style Bar
The Style bar displays the style of the selected object or of the object about to be drawn. The style 
attributes displayed in the Style bar are name, color, line and fill. These style attributes can be changed by 
clicking on the pop-up menu for that attribute. Other attributes that may be associated with the object can 
be changed by clicking the Edit button. Create styles and select default styles for tools by choosing Edit 
Default Styles from the File menu.



Status Bar
The Help/Status bar is along the bottom of the screen, and can be toggled between Help and Status 
mode by clicking on the H and S buttons, respectively, or by choosing the mode from the View menu. The 
Help bar displays instructions for the current command or tool. The Status bar displays the building level, 
the view scale, the grid size and contains buttons for the Snap to Grid, and View Grid commands in the 
View menu.



Starting a New Drawing
The New command resets Floorplan Plus    in preparation for beginning a new drawing.

Related Topics:
To start a new drawing



To start a new drawing
1. Choose New from the File menu.

2. Choose Maximum Drawing Size from the Options menu.

3. Choose the size of your floor plan. Click OK.

Maximum Drawing Size sets the boundaries for the entire drawing and controls the sensitivity of the scroll 
bars. It can be changed at any time. Choose the smallest maximum drawing size you think you will need, 
and increase it as needed. Precision at all drawing sizes is 1 /16".



Opening a Drawing
The Open command loads a previously saved Floorplan Plus 3D drawing from disk, and displays it on the 
Drawing Area, zoomed to the drawing extents.

Related Topics:
To open a previously saved drawing



To open a previously saved drawing
1. Choose Open from the File menu.

2. Click on the appropriate directory, if necessary.

3. Type the file name, double-click on the drawing file name in the scroll box, or click once on a file 
name and click OK.



Saving a Drawing
The Save and Save As commands save the current Floorplan Plus 3D drawing to disk.

Related Topics:
To save the current drawing
To save the current drawing to a new file



To save the current drawing
1. Choose Save from the File menu.

If this is the first time you have saved this file...

2. Type the name of the file, with the extension "FP3".

3. Click Save or press Return.

The Save command saves the file to the same file name each time subsequent to the first save, over 
writing the file previously saved. To maintain the file previously saved and save the current file to a new 
name, use the Save As command.



To save the current drawing to a new file
1. Choose Save As from the File menu.

2. Type a new name for the file, with the extension "FP3".

3. Click Save or press Return.



Reverting to the Last Saved Drawing
The Autobackup feature saves drawings every 5 minutes, by default. You can adjust or turn off 
Autobackup using the Preferences command in the File menu. Autobackup enables you to revert to the 
last saved drawing.

Related Topics:
To revert to the last saved drawing (Auto Backup ON only)



To revert to the last saved drawing (Auto Backup ON only)
1. Choose Open from the File menu.

2. Type the file name "BACKUP.TMP".

3. Press Return or click OK.

4. Choose Save as from File menu to save the file with a new name, with the extention "fp3".



Importing Other Floorplan Plus Drawings and 
Libraries
Floorplan Plus 3D supports Floorplan Plus DOS and earlier versions of Floorplan Plus Windows drawings 
and libraries. 

Related Topics:
To import a drawing or library



To import a drawing or library
1. Choose Import from the File menu, and the import format from the submenu.

2. Select or enter the name of the file to import.



Exporting 
Floorplan Plus 3D provides the capability to export your drawing to a DXF file, a metafile. Also, Floorplan 
Plus 3D has the ability to send a Materials list of your drawing to a text file for use in a word processor or 
Estimator Plus.

Related Topics:
To export a drawing to a DXF file or a metafile
To export a list of materials to an Estimator file
To export a list of materials to a text file



To export a drawing to a DXF file or a metafile
1. Open the drawing to export.

2. Choose Export from the File menu.

3. Choose the file format to export to from the sub-menu.

4. Choose to export All layers or Visible layers and click OK.

5. Type the name of the file to export to and click OK.



To export a list of materials to an Estimator file
1. Open the drawing to export.

2. Choose Export from the File menu.

3. Choose the file format to export to from the sub-menu.

4. Choose to export All levels or only the Current level and click OK.

5. Type the name of the file to export to and click OK.



To export a list of materials to a text file
1. Open the drawing to export.

2. Choose Export from the File menu.

3. Choose the file format to export to from the sub-menu.

4. Choose to export All levels or only the Current level and click OK.

5. Type the name of the file ("filename.TXT") to export to and click OK.

Note: All Floorplan Plus 3D objects, along with symbols loaded from symbol libraries and used in 
the Roof Editor, are used    to generate Material lists and Estimator files. Shapes drawn using the 
other Floorplan Plus 3D drawing tools (Line, Rectangle, Polygon, Arc, Text, Circle, Ellipse, Fill 
Shape, and Freehand) are not included in the Material list or Estimator files, unless saved to a 
symbol library.



Printing a Drawing
The Printer Setup and Print Drawing commands print your drawings. If you have trouble communicating 
with your printer, see the Print Manager in the Main group in the Windows Program Manager. See your 
Windows documentation for more information on the Print Manager. See 3D Viewer for printing drawings 
in 3D.

Related Topics:
To select printer
To print a drawing



To select printer
1. Choose Printer setup from the File menu.

2. Choose the appropriate printer form the pop-up menu and click OK.

3. Click Setup Printer to set printer options.

4. Click OK.

Choosing the Print Drawing command from the File menu will present the Print Options dialog box.



To print a drawing
1. Choose Print drawing from the File menu.

2. Select the the print options and click OK.

Region

Choose to print the Entire Drawing or a selected area.

Color Conversion

Map to Black is used to print black and white, only. Use color will 
print color or shades of gray, depending on your printer.

Layers

Choose to print All Layers or only the Visible Layers selected 
using the Layers command in the View menu.

Print scale

Choose to print the drawing to Fit to Page or set the print scale 
by typing in the 1" or 1 cm scale equivalent, depending on the 
Measurement System selected in Preferences.



Default Styles
You create and select the default styles for Areas, Doors, Floors, Railing, Walls, Windows, and Wire & 
Pipe using the Edit Default Styles command. You can make changes to any style for a selected object by 
selecting Edit in the Style bar. You can save the selection of defaults to a file for future use.

Note: Load default styles before starting a drawing.

Related Topics:
To select a default style
To save a set of default styles
To load a set of saved default styles



To select a default style
1. Choose Edit default styles from the File menu. Select the object to set the default style for from 

the submenu.

2. Click on the symbol style to use as a default from the Description list. Click OK.



To save a set of default styles
1. Choose Save default styles from the File menu.

2. Enter the file name to save the selected default symbol styles to. Click OK.



To load a set of saved default styles
1. Choose Load default styles from the File menu.

2. Enter the file name to load. Click OK.



Creating Symbol Styles
You create symbol styles for Areas, Doors, Floors, Railing, Walls, Windows, and Wire & Pipe using the 
Edit default styles command. 

Related Topics:
To create a style



To create a style
1. Choose Edit default styles from the File menu and choose the symbol to create a style for.

2. Click Add.

3. Complete the Options dialog box and click OK.

Following is a list of the default symbols and their attributes:

Related Topics:
Areas:
Doors:
Floors:
Railing:
Walls:
Windows:
Wire & Pipe:



Areas:

Description

The name of the area style as it will appear in the Attribute bar.

Part number

A part number for use in the Materials list and Estimator files.

Category

Groups the style in the Materials list and Estimator files.

Color

The color that will represent this style in the two-dimensional drawing.

Line style

The type of line that will represent this style when drawn on the screen.

Fill style

The pattern that fills the symbol when drawn on the screen.



Doors:

Description

The name of the door style as it will appear in the Attribute bar.

Part number

A part number for use in the Materials list and Estimator files.

Category

Groups the style in the Materials list and Estimator files.

3D Symbol

Specify the file name of the associated 3D illustration. Click Load to browse and load file name.

2D Color

The color that will represent this style in the two-dimensional drawing.

Line style

The type of line that will represent this style when drawn on the screen.

Fill style

The pattern that fills the symbol when drawn on the screen.

Width 

The width along the wall.

Height

The height of the door.

Dist off floor 

The distance from the floor to the bottom of the door.

Constrain to width of wall

This attribute applies when you are matching the width of the door to the width of the wall, such as in the 
case of a sliding door.

Change Orientation 

Select the 2D symbol and click the Change Orientation button to flip the door opening direction. There are 
four orientations.



Floors:

Description

The name of the floor style as it will appear in the Attribute bar.

Part number

A part number for use in the Materials list and Estimator files.

Category

Groups the style in the Materials list and Estimator files.

Height

This attribute is usually set to "0". However, in cases such as stair landings, set the floor height to the 
distance from the floor to the top of the stairs.

Thickness 

The thickness of the floor. The top of the floor is positioned at "Height", and the thickness extends down 
from that point.

2D Color

The color that will represent this style in the two-dimensional drawing.

3D Color

The color that will represent this style in the three-dimensional drawing.

Line style

The type of line that will represent this style when drawn on the screen.

Fill style

The pattern that fills the area when drawn on the screen.



Railing:

Description

The name of the railing style as it will appear in the Attribute bar.

Part number

A part number for use in the Materials list and Estimator files.

Category

Groups the style in the Materials list and Estimator files.

Height 

The height of the railing, from the bottom bar to the top of the handrail.

Handrail width

Enter the width of the handrail.

Handrail thickness

The distance from the bottom to the top of the handrail.

Opening size 

The distance between the vertical bars of the railing. If the railing is being added to stairs, the opening 
size and distance off floor are calculated.

Dist off floor

The distance from the floor to the bottom bar of the rail. If the railing is being added to stairs, the opening 
size and distance off floor are calculated.

2D Color

The color that will represent this style in the two-dimensional drawing.

Line style

The type of line that will represent this style when drawn on the screen.

3D handrail color

The color the handrail will appear in a three-dimensional drawing.

3D baluster color

The color of the vertical bars in a three-dimensional drawing.



Walls:

Description

The name of the wall style as it will appear in the Attribute bar.

Part number

A part number for use in the Materials list and Estimator files.

Category

A category for use in the Materials list and Estimator files.

Height

The height of the wall. Set to "0" if you don't want the wall displayed when viewing in 3D.

Thickness

The thickness of the wall.

Dist off floor 

The distance from the floor to the bottom of the wall, if the wall is suspended. This is useful when you are 
using walls sections to create a hole or cutouts.



Windows:

Description

The name of the window style as it will appear in the Attribute bar.

Part number

A part number for use in the Materials list and Estimator files.

Category

Groups the style in the Materials list and Estimator files.

3D Symbol

Specify the file name of the associated 3D illustration. Click Load to browse and load file name.

2D Color

The color that will represent this style in the two-dimensional drawing.

Line style

The type of line that will represent this style when drawn on the screen.

Fill style

The pattern that fills the symbol when drawn on the screen.

Width

The width of the window along the wall.

Height

The height of the window.

Dist off floor

The distance from the floor to the bottom of the window.



Wire & Pipe:

Description

The name of the style as it will appear in the Attribute Bar.

Part number

A part number for use in the Materials list and Estimator files.

Category

Group the style for use in the Materials list and Estimator files.

Color

The color that will represent this style in the two-dimensional drawing.

Line style

The type of line that will represent this style when drawn on the screen.



Preferences
The Preferences command allows you to modify the number of Undo levels, the measurement system, 
colors, cursor and libraries used, and turn on Auto backup. Settings are saved for future uses of the 
program, until changed.

Related Topics:
To change the default configuration



To change the default configuration
1. Choose Preferences from the File menu.

2. Set the configuration as desired, and click OK.

The following settings can be changed:

Undo levels

Undo levels can be set from 0 to 20, allowing you to reverse up 
to 20 commands. Higher numbers of Undo levels require more 
memory.

Measurement system

Set the measurement system to Metric or U.S. (feet and inches). 
You can choose to use Fractions rather than inches. Choose the 
number of decimal places to display (0-3) in non-fractional 
measurements.

Auto backup

Auto backup saves the current file to the backup.tmp file, 
automatically, every 5 minutes. You can change the number of 
minutes between backups by double-clicking in the minute box 
and editing. You can disable Auto backup by clicking in the 
Enabled box.

Colors

Click on the pop-up menu for Foreground, Background, Cursor, 
or Selection, and choose a color.

Cursor size

Select your cursor preference: Small, Medium or Large. The 
Aiming rectangle is a small box at the cross of the cursor. The 
Cursor size changes only the appearance of the cursor.

Symbol libraries

The Symbol libraries selected will be opened by clicking on the 
Door and Window icons in the icon bar. You can access different 
libraries by choosing Load symbol from the Symbol menu.



Exiting Floorplan Plus 3D
When you leave Floorplan Plus 3D, you will be asked whether unsaved files should be saved.

Related Topics:
To Exit Floorplan Plus 3D



To Exit Floorplan Plus 3D
1. Choose Exit from the File menu (Alt+F4).

2. If any drawing changes have not been saved prior to exiting, a message will warn you. Click Yes 
or press Return to save changes, click No to disregard changes. Click Cancel to return to 
Floorplan Plus 3D.



Scrolling
Scrolling, or panning, is the process of moving around to different areas of your drawing. Scrolling in your 
drawing is accomplished by using the scroll bars, located directly to the right and to the bottom of the 
Drawing Area.

Each scroll bar is composed of two arrow buttons and a scroll position indicator. The position of the 
indicator relative to the scroll bar indicates the position of the current drawing view relative to the entire 
drawing workspace.

Related Topics:
To scroll around your drawing



To scroll around your drawing
See page 28 in the User's Guide for a diagram of the effects of the scroll bars.



Zooming
The Zoom commands magnify the Floorplan Plus 3D drawings at different levels. You can Zoom-In, 
Zoom-Out, and Zoom to Extents.

Related Topics:
To magnify the current drawing to twice its current magnification
To reduce the view magnification by half of the current drawing
To magnify a specific portion of the drawing
To view the entire drawing



To magnify the current drawing to twice its current magnification
1. Choose Zoom in from the View menu (Ctrl+I).



To reduce the view magnification by half of the current drawing
1. Choose Zoom out from the View menu (Ctrl+O).



To magnify a specific portion of the drawing
1. Choose the Zoom to window command from the View menu (Ctrl+W).

2. Drag a box around the portion of the drawing you wish to magnify.



To view the entire drawing
1. Choose Zoom to extents from the View menu (Ctrl+E).

This command will display the entire drawing, at the largest 
possible size within the Drawing Area.



Layers
The Layers feature is used to view, print or export your drawing by symbols. This is useful for dividing 
your plans into logical sequences, jobs, contracts, etc.

There are 13 predefined layers and symbols are automatically placed on the appropriate layer.

Related Topics:
To change visible layers



To change visible layers
1. Choose Layers from the View menu (Ctrl+L).

2. Modify the Layers dialog box as desired.



Changing the View Scale
The View Scale determines the size of your drawing as it's displayed relative to the physical dimensions 
of your Drawing Area. For example, assume the default View Scale size is 1 inch = 4 feet. This means 
that an object or shape that is drawn 1 inch on the screen is 4 feet in the plan.

The View Scale that Floorplan Plus 3D uses is determined by the Measurement System selected in the 
Preferences command in the File menu, the Maximum drawing size set from the Options menu, and the 
factor of the current Zoom. The following table lists the default View Scales:

SystemDrawing Size Default View Scale
325 X 325 feet 1" = 4ft

650 X 650 feet 1" = 8ft

     U.S. 1300 X 1300 feet 1" = 16ft

2600 X 2600 feet 1" = 32ft

5200 X 5200 feet 1" = 64ft

100 x100 meters 1cm = 0.050m

200 x 200 meters 1cm = 0.100m

      Metric 400 X 400 meters 1cm = 0.250m

800 X 800 meters 1cm = 0.500m

1600 X 1600    meters 1cm = 2.500m

Related Topics:
To set the View Scale



To set the View Scale
1. Choose Current View Scale from the View menu (Ctrl+Z), or click the View Scale button in the 

Status Bar.

2. Type the desired View Scale value. Click OK. The drawing will redraw.



Setting the Grid
Floorplan Plus 3D's drawing grid provides an aid for alignment and the placement of objects in your 
drawing. Grids also make it easy to draw a shape of a given length or size. The grid can either be 
displayed or hidden, and you can Snap to Grid, forcing lines and other objects to be drawn only where 
grid points are defined. In addition, you can define the grid size, or spacing between the grid points.

Note: Floorplan Plus 3D will not display the grid if it becomes too dense due to zooming or grid 
size changes.

Related Topics:
To set the Grid Size
To turn Snap to Grid on or off
To turn the grid on or off



To set the Grid Size
1. Choose Grid Size from the View menu (Ctrl+D), or click on the Grid button in the Status Bar.

2. Type the grid size and press Return.

The grid will be redrawn at the new grid size.



To turn Snap to Grid on or off
1. Choose Snap to Grid from the View menu (Ctrl+S), or click Snap in the Status Bar.

A checkmark will appear next to the Snap to Grid command and 
the Snap button will be red when the grid is turned on. 



To turn the grid on or off
1. Choose View Grid from the View menu (Ctrl+G), or click View in the Status Bar.

A checkmark appears next to the View Grid command and the View button in the Status Bar will be red 
when the grid is displayed.

Related Topics:
Default Grid Sizes



Default Grid Sizes

SystemDrawing Size Default 
GridSize

325 X 325 feet 1ft

650 X 650 feet 2ft

      U.S. 1300 X 1300 feet 4ft

2600 X 2600 feet 8ft

5200 X 5200 feet 16ft

100 X 100 meters 0.305m

200 X 200 meters 0.610m

     Metric 400 X 400 meters
1.219m

800 X 800 meters 2.438m

1600 X 1600 meters 4.877m



Building Levels
Building levels enables you to construct and view up to 20 levels (or stories) in a single drawing file.

Related Topics:
To edit building levels



To edit building levels
1. Choose Edit building levels from the View menu, or click the Level button in the Status Bar.

2. Edit the Building Levels dialog box.

Current level

Change the current level by selecting a level from the scroll box.

Height

Enter the distance from the floor to the ceiling for the current 
level.

Description

Enables you to specify a level name.

Lower-level color

The color that will represent the level's floors and walls when 
viewed from a higher level.

Enabled

Uncheck Enabled to hide the level so it does not appear when 
viewing higher levels. Also prevents the level from appearing in 
3D.



Help/Status Bar
The Help/Status Bar is along the bottom of the drawing window and can be toggled to provide instructions 
or to provide pertinent data about your drawing. See page 12 for the functions of the Help and Status bar 
tools.

Related Topics:
To display the Help bar
To display the Status bar
To hide/show the Help/Status bar



To display the Help bar
1. Choose Display help mode    from the View menu (Ctrl+H), or click the H button in the Status 

Bar.



To display the Status bar
1. Choose Display status mode    from the View menu (Ctrl+T), or click the S button in the Status 

Bar.

The mode of the Help/Status bar is indicated with a check in the 
View menu and a red button in the Status bar.



To hide/show the Help/Status bar
1. Choose Status bar from the Options menu.



Ribbon Bar
The Ribbon bar is along the top of the drawing window, just below the Menu bar, and can be toggled to 
provide icon shortcuts to menu commands. See Chapter 3 for a description of each icon on the Ribbon.

Related Topics:
To hide/show the Ribbon bar



To hide/show the Ribbon bar
1. Choose Ribbon bar from the Options menu.



Style Bar
The Style bar is along the top of the drawing window, just below the Ribbon bar, provides style 
information and editing for the current tool or object. See Chapter 3 for a description of each indicator on 
the Style bar.

Related Topics:
To hide/show the Style bar



To hide/show the Style bar
1. Choose Style bar from the Options menu.



The Tool Bar
The Tool bar is along the left of the drawing window. It can be hidden or changed to a floating Toolbox. 
See Chapter 3 for a brief description of each tool. See Chapter Six for a detailed description of the use of 
each tool.

Related Topics:
To hide the Tool bar
To float the Tool bar
To show the Tool bar



To hide the Tool bar
1. Choose Tool bar from the Options menu.

2. Choose Disabled from the submenu.



To float the Tool bar
1. Choose Tool bar from the Options menu.

2. Choose Floating from the submenu.



To show the Tool bar
1. Choose Tool bar from the Options menu.

2. Choose Left side from the submenu.



Using the Cursor Reference Point
The Cursor Reference Point is used to measure in reference to a specified marker. For example, to 
position the wall phone three feet from the exterior wall, set the cursor reference point on the exterior 
waland load the wall phone symbol. The Help bar will indicate the distance from the cursor in the center of 
the wall phone, to the reference point.

Related Topics:
To set reference point
To display reference distance



To set reference point
1. Choose Set cursor reference point from the View menu.

2. Click to position the reference point in the drawing. The Cursor Reference Point dialog box will 
appear.

3. Choose Horizontal, Vertical or Straight line from the Cursor Reference Point dialog box. Click 
OK.



To display reference distance
1. Choose Display reference distance from the View menu. The Help bar displays the distance 

between the reference point and the cursor.



Redraw
To save time, Floorplan Plus 3D redraws as little of the drawing as possible when being edited. At times, 
this may cause some objects to obscure other smaller objects. In such cases, you can use the Redraw 
command to redraw the entire drawing. The Redraw command draws objects in the following order: 

    Walls and Floors on lower levels

    Floors

    Areas

    Walls

    Doors and Windows

    Symbols and Lines

    Text and Dimensions

Note: The Bring to Front and Send to Back commands work within the above groups.

Related Topics:
To redraw your screen



To redraw your screen
1. Choose Redraw from the View menu.



Floor Tool
The Floor drawing tool is used to draw any style of floor in your floor plan. See Chapter Four, Default 
Symbol Styles, for more information on creating floor styles. Floor attributes include:

    Height

    Thickness

    2D color

    3D color

    Line style

    Fill style

Related Topics:
To draw a floor



To draw a floor
1. Select the Floor tool from the Toolbox or the Draw menu.

2. Select the desired attributes using the Style bar.

3. Click at each vertex of the floor, with the last vertex on the first.

4. Backspace erases the last point, ESC aborts the floor.



Stair Tools
The Stair drawing tools are used to draw any style of stairs in your floor plan. There are two tools, straight 
and spiral, because the attributes of the two styles are quite different. 

The Rise, Run and Angle of each stair is calculated based on the values entered for the attributes above.

The Railing attributes are described under the Rail tool, on page 39.

Related Topics:
To draw straight stairs
To draw spiral stairs



To draw straight stairs
1. Select the Straight Stairs tool from the Toolbox or the Draw menu.

2. Click the Style bar Edit button and define the stair attributes in the Straight Stair Options dialog 
box. 

3. Choose the side for Railing and click Railing options to define the railing attributes. Click OK.

4. Click OK in the Straight Stair Options dialog box.

5. Click and drag on the screen, starting with the current level landing.

The Step angle, number of steps, and headroom is calculated based on the values entered for the 
attributes above.

The Railing attributes are listed under the Rail tool, below.

Note: The arrow indicates the "up" direction.



To draw spiral stairs
1. Select the Spiral Stairs tool from the Toolbox or the Draw menu.

2. Click the Style bar Edit button and define the stair attributes in the Straight Stair Options dialog 
box. 

3. Choose the side for Railing and click Railing options to define the railing attributes. Click OK.

4. Click OK in the Spiral Stair Options dialog box.

5. Click and drag on the screen to define the diameter of the staircase.

6. Click and drag again to specify the position of the front of the first stair on the current level.

7. Click and drag again to specify the position of the back of the last stair.



Rail Tool
The Rail drawing tool is used to draw a straight rail. See page 21 for creating rail styles. The attributes of 
the straight rail is identical to those defined in the Rail options dialog in the Stair Options dialog boxes. 

Related Topics:
To draw a rail



To draw a rail
1. Choose the Railing tool from the Toolbox or the Draw menu.

2. Click the Style bar Edit button to specify the Rail attributes.

3. Click to place the first point, and click again to place the end point. 



Door Tool
The Door drawing tool is used to addl doors in your drawing. Each Door style can be associated with a 
three-dimensional illustration of the door. 3D illustrations are available in the Floorplan Plus 3D libraries, 
or you can create your own using 3D Design Plus. See Chapter Four for creating door styles. The 
attributes of a door are:

    2D color

    Line style

    Fill style

    Width

    Height

    Dist off floor

    Constrain to width of wal

    Orientation

Related Topics:
To draw a door



To draw a door
1. Choose the Door tool from the Toolbox or the Draw menu.

2. Choose the Door style from the Style bar or click the Edit button to specify the Door attributes.

3. Click on the desired wall and position the door. Click again to place the door.



Window Tool
The Window tool is used to represent the windows in your drawings. Windows can be associated with 
three-dimensional illustrations. You can define Window styles (see Chapter Four) or you can define the 
attributes for each window you draw. The Window attributes are:

    2D color

    Line style

    Fill style

    Width

    Height

    Dist off floor

Related Topics:
To draw a window



To draw a window
1. Select the Window tool from the Toolbox or the Draw menu.

2. Select the desired style on the Style bar or click the Edit button to define the attributes of this 
window.

3. Click on the desired wall and position the door. Click again to place the door.



Wall Tool
The Wall tool is used to draw exterior and interior walls in your floor plan. Walls are the foundation for 
drawing doors and windows. Wall attributes are:

    Height

    Thickness

    Dist off floor

    2D color

    3D color

    Line style

    Fill style

Related Topics:
To draw a wall
To move a wall
To adjust a wall angle or size
To automatically add wall dimension labels



To draw a wall
1. Choose the Wall tool from the Toolbox or the Draw menu.

2. Choose the Wall style from the Style bar or click Edit to define the walls attributes.

3. Click to place the start point.

4. Click to place or press Return to enter the wall length and orientation.



To move a wall
1. Use the Selection tool to select the wall.

2. Click and drag to move the wall to the desired location.



To adjust a wall angle or size
1. Choose the Adjust tool from the Ribbon bar or the Edit menu.

2. Click and drag to move or resize the wall.



To automatically add wall dimension labels
1. Choose Auto wall dimensioning from the Options menu.

2. Draw a wall.



Wire & Pipe Tool
The Wire & Pipe tool is used to draw lines which represent wire and pipe in your floor plan. This function 
is useful for showing wiring and plumbing inside walls, under floors, and throughout a property. Attributes 
of the Wire & Pipe tool are:

    Color

    Line style

Related Topics:
To draw wire and/or pipe



To draw wire and/or pipe
1. Select the Wire & Pipe tool from the Toolbox or the Draw menu.

2. Select the desired attributes from the Style bar.

3. Click and drag to draw the wire or pipe.



Area Tool
The Area tool draws a filled area. This function is useful to draw areas on your Floorplan Plus 3D drawing 
with different types of material, such as tile, stone, grass, and walkways.

The function and operation of this tool is almost identical to the Fill Shape tool, with the exception that 
Areas are considered building materials if exporting Materials lists. Filled Shapes are not interpreted as 
building materials. Attributes of the Area tool are:

    Color

    Line style

    Fill style

Related Topics:
To draw an area



To draw an area
1. Choose the Area tool.

2. Select the desired style or attributes from the Style bar.

3. Select the area you wish to fill, by tracing the outline of the desired area: click on each vertex and 
press the right mouse button or Return to fill. Delete erase the last vertex. 



Line Tool
The Line tool is used to create special shapes in your floor plan, such as patios, decks, sidewalks, 
driveways, etc. Lines can be converted to walls using the Convert Lines to Walls command in the Edit 
menu. Attributes of a line are:

    Color

    Fill style

    Line style

Related Topics:
To draw a line



To draw a line
1. Choose the Line tool from the Toolbox or the Draw menu.

2. Select the desired attributes from the Style bar. 

3. Click to set the beginning point. Click again to set the end point.



Rectangle Tool
The Rectangle tool is often used to draw desks, tables, concrete blocks, tile, etc. in a floor plan. Attributes 
of a rectangle are:

    Color

    Fill style

    Line style

Related Topics:
To draw a rectangle



To draw a rectangle
1. Choose the Rectangle tool from the Toolbox or the Draw menu.

2. Select the desired attributes from the Style bar.

3. Click to set each of two opposite corners of the rectangle.



Polygon Tool
The Polygon tool is used to draw multi-sided objects with any number of equal length sides, such as a 
hexagon or octagon. Polygons can be used to draw tiles, tables, spas, gazebos, flag stones, etc. 
Attributes of a polygon are:

    Color

    Fill style

    Line style

Related Topics:
To draw a polygon



To draw a polygon
1. Choose the Polygon tool from the Toolbox or the Draw menu.

2. Select the desired attributes for the lines of the polygon.

3. Choose Polygon Sides from the Options menu. Type the number of sides and press Return. 

4. Clickto set the center of the polygon, and click again to set the desired size.



Arc Tool
The Arc tool is used to draw portions of a circle for rounded corners and other arcs. Attributes of an arc 
are:

    Color

    Fill style

    Line style

Related Topics:
To draw an arc



To draw an arc
1. Choose the Arc tool from the Toolbox or the Draw menu.

2. Select the desired attributes for the line of the arc. 

3. Click where you want the center of the arc to lie (as if it were a full circle) and release the mouse 
button.

4. Move the cursor to where you want the arc to begin, and click. Draw the arc and click again.



Text Tool
The Floorplan Plus 3D Text tool is used to create text of virtually any size, angle, or font. Text attributes 
are:

    Font

    Size

    Color

    Style: Italic, Bold, Underline

Related Topics:
To create text
To create text to fill a specified area



To create text
1. Select the Text tool from the Toolbox or the Draw menu.

2. Select the desired attributes by clicking Edit in the Style bar.

3. Click and drag a line on which you want the text to appear. The Text dialog box will appear.

4. Type the text string and press Return.

Note: Small text is displayed as rectangles, but will print normally.



To create text to fill a specified area
1. Choose the Text tool from the Toolbox or the Draw menu.

2. Select the desired attributes by clicking Edit in the Style bar.

3. Position the cursor where you want the text to start (the base point) and click the left mouse 
button.

4. If Dynamic Text Sizing is enabled (Options menu), the next step is to define the height of the 
text. Move the cursor away from the base point defined in step 3 to a distance equal to the 
desired text height. Click the left mouse button.

5. Move the cursor to draw the text vector, and click. The Text dialog box will appear.

6. Type the text string and press Return.



Circle Tool
The Circle tool is often used to draw shrubs, pipe openings, tables, spas and other round objects in your 
floor plan. Attributes of a circle are:

    Color

    Fill style

    Line style

Related Topics:
To draw a circle



To draw a circle
1. Choose the Circle tool from the Toolbox or the Draw menu.

2. Select the desired attributes for the line of the circle from the Style bar.

3. Click where you want the center of the circle to lie, click again to set the size of the circle.



    Ellipse Tool
The Ellipse tool draws circle-like objects where the width and height are not equal. Ellipses are often used 
to draw tables, pools, atriums, and other oval objects. Attributes of an ellipse are:

    Color

    Fill style

    Line style

Related Topics:
To draw an ellipse



To draw an ellipse
1. Choose the Ellipse tool from the Toolbox or the Draw menu.

2. Select the desired attributes from the Style bar.

3. Click where you want the center of the ellipse to lie, click again to set the size of the ellipse.



    Filled Shape Tool
The Filled Shape tool is used to draw filled shapes. (Filled shapes can also be hollow.)

The function of this tool is almost identical to the Fill Area tool, with the exception that Floorplan Plus 3D 
does not interpret Filled Shapes as building materials. Attributes of a filled shape are:

    Color

    Fill style

    Line style

Related Topics:
To draw a filled shape



To draw a filled shape
1. Choose the Filled Shape tool from the Toolbox or the Draw menu.

2. Select the desired attributes for the filled shape from the Style bar.

3. Trace the outline of the shape to fill by clicking on each vertex and double-clicking when 
complete.

Tip: Save time by using the Filled Shape tool to draw the exterior walls of your a house. After 
outlining, with the shape still selected, choose Convert Lines to Walls from the Edit menu.



Freehand Tool
The Freehand tool draws continuous line shapes not easily drawn with the other drawing tools. Attributes 
of the Freehand tool are:

    Color

    Fill style

    Line style

Related Topics:
To freehand draw



To freehand draw
1. Choose the Freehand tool from the Toolbox or the Draw menu. 

2. Select the desired attributes from the Style bar. 

3. Click and drag to draw.



Overview
Floorplan Plus 3D uses symbols to simplify construction of your drawing. Instead of manually drawing a 
refrigerator, for example, you can load the Floorplan Plus 3D refrigerator symbol. You could edit this 
drawing and save it to a library under a different name, or your could create your own symbols using the 
drawing tools and save it to a library for future use.

Symbols can be just about anything: a piece of furniture, a door, a window, or an electrical outlet. You can 
associate your 2 dimensional symbols with 3 dimensional illustration files from 3D Design Plus if you want 
the symbol to display in the 3D Viewer. 

Commands that make use of symbols and symbol libraries can be accessed from the Symbols menu on 
the Menu bar. You can easily load symbols from the libraries by clicking on the Load button on the Ribbon 
bar.



Libraries
The Floorplan Plus 3D libraries are used to categorize symbols and save disk space. Floorplan Plus 3D 
ships with several libraries and you can create your own. As your libraries become larger, they will save 
you time in finding symbols. Create libraries as you draw and edit symbols, giving them logical names. 
You can always rename a library, delete a library, and print a catalog of the symbols in each library.

Related Topics:
To create a symbol library
To change the name of a symbol library
To delete a symbol library
To write a symbol library catalog



To create a symbol library
1. Choose Create symbol library from the Symbols menu. The Create Symbol Library dialog box 

will appear. 

2. Type the name for the library. Click OK. 

3. Type a file name for the library ("filename.LIB").



To change the name of a symbol library
1. Choose Rename symbol library from the Symbols menu. The Select symbol library dialog box 

will appear. 

2. Select the name of the library to be changed. Click OK. The Rename Symbol Library dialog box 
will appear.

3. Type a new name for the library. Click OK.



To delete a symbol library
1. Choose Delete symbol library from the Symbols menu. The Select Symbol Library dialog box will 

appear. 

2. Select the name of the library to be deleted. Click OK. A confirmation dialog box will appear.

3. Click Yes to remove the library name, file, and symbols from the disk.



To write a symbol library catalog
1. Choose Write symbol catalog from the Symbols menu. The Select Symbol Library dialog box will 

appear. 

2. Select the name of the library to catalog. Click OK. The Write Symbol Catalog dialog box will 
appear.

3. Type the file name of the text file to be created ("filename.TXT").



Symbols
Floorplan Plus 3D symbols are the details of your drawing that bring your floorplan to life. Symbols 
include windows, doors, appliances, fixtures, sinks, and furniture. You can edit the symbols included in 
Floorplan Plus 3D and save them as new symbols, or you can create your own using the drawing tools. 
Symbols are associated with 3 dimensional illustrations for 3D Viewer, the Floorplan Plus 3D feature that 
enables you to "walk through" your floor plan. These three dimensional illustrations can be created with 
3D Design Plus by ComputerEasy).

Related Topics:
To load a symbol
To save a symbol
To edit a symbols attributes in a library
To delete a symbol from a library



To load a symbol 
1. Choose Load symbol from the Symbols menu. The Load Symbol dialog box will appear. 

2. Click on the appropriate library name in the list of libraries. The library's symbols will appear in the 
Symbols list on the left.

3. Click on the symbol name once to view the two dimensional and, if applicable, three dimensional 
illustrations.

4. Click OK or double-click on the symbol name to load the symbol in the drawing.

5. Position the symbol with the mouse, and click to place.



To save a symbol 
1. Use the Selection tool to select objects to be included in the symbol.

2. Choose Save symbol from the Symbols menu, press E, or click Save in the Edit Toolbox 
(press the right mouse button to display the Edit Toolbox). The Symbol Options dialog box will 
appear. 

3. Complete the Symbol Options dialog box, and click OK.

4. Select the library for the symbol and click OK. (If the appropriate library does not exist, click 
Cancel and create the library using the Create symbol library command.)



To edit a symbols attributes in a library 
1. Choose Edit symbol in library from the Symbols menu. The Edit symbol dialog box will appear. 

2. Select the library and the symbol to edit from the lists, and click OK. The Symbol Options dialog 
box will appear.

3. Edit the attributes as necessary and click OK.



To delete a symbol from a library
1. Choose Delete symbol from library from the Symbols menu. The Delete Symbol dialog box will 

appear. 

2. Select the name of the library and the symbol to be deleted. Click OK. A confirmation dialog box 
will appear.

3. Click Yes to remove the symbol from the disk.



3D Symbols
Floorplan Plus 3D can illustrate your floor plan in three dimensions, enabling you to "walk through" your 
floor plan in 3 dimensional wire frame or shaded views. The 3D Viewer will automatically convert your 
Floors, Walls, Stairs, and Railings in to 3D. Doors, Windows and Symbols must be associated with 3D 
illustrations to be viewed using the 3D Viewer. The Doors, Windows and Symbols that ship with Floorplan 
Plus 3D are associated with 3 dimension illustration files (filename.3D). 

You can create your own 3 dimensional illustrations using 3D Design by ComputerEasy. You can then 
import these files for use in Floorplan Plus 3D using the command in the Symbols menu.

Related Topics:
To import a three dimensional illustration from 3D Design Plus



To import a three dimensional illustration from 3D Design Plus
1. Choose Import symbol from the Symbols menu. The Select 3D Design Plus Drawing dialog box 

will appear, with a list of the 3D files that ship with Floorplan Plus 3D. 

2. Select the appropriate directory, such as "3DPLUS," if necessary.

3. Select the file name ("filename.MDL") to import and click OK. The Select Destination File dialog 
box will appear.

4. Select the appropriate directory, such as "FP3", if necessary and type the file name of the 
destination file ("filename.3D"). Click OK. A confirmation dialog box will appear.

5. Press Return or click OK.



Editing a Symbol
Floorplan Plus 3D library symbols are single objects comprised of one or more lines drawn with various 
Floorplan Plus 3D drawing tools. Library symbols can be loaded, edited, and saved as new library 
symbols. Editing may require that the symbol be presented as an assembly of the individual elements of 
the drawing, rather than a single object. The Break symbol command is used for this purpose.

Related Topics:
To break a symbol



To break a symbol
1. Select the symbol to be edited using the Selection tool.

2. Choose Break symbol from the Symbols menu. 

3. Click in another part of the drawing to deselect the symbol.

4. Use the Selection tool to select then edit the elements of the 

symbol.

5. (Optional) Save the new symbol.

Note: A broken symbol will not appear in Materials lists, Estimator files, or the 3D Viewer.



Editing Tools
Once you have selected items for editing, select the editing tool to be used. Editing tools are available in 
the Edit menu, in the Edit Toolbox, and by simply pressing an editing key. Access the Edit Toolbox by 
pressing the right mouse button. 

Related Topics:
Editing Keys



Editing Keys

Press To

R Rotate

S Scale

A Adjust Lines

T Edit Text

H Flip Horizontal

V Flip Vertical

E Save as Symbol

D Delete

C Copy to Clipboard

U Cut to Clipboard

Tip: Floorplan Plus 3D displays step-by-step help in the Help bar to guide you through using 
any editing commands.



Selecting Objects
Each of the Floorplan Plus 3D editing tools requires you to first select the desired item or items you wish 
to edit. An item can be as simple as a single line, or as complex as an entire drawing. 

Note: Selected items are displayed as a simple red line by default. The selection color can be 
changed using the Preferences command in the File menu.

Related Topics:
To select an item to be edited
To select several items to be edited
To select all items in a drawing



To select an item to be edited
1. Choose the Selection tool from the Toolbox or choose Select from the Edit menu.

2. Position the cursor on the outline of the shape or symbol, and click. The item will become a red 
outline.



To select several items to be edited
1. Click the Selection tool from the Tool bar choose Select from the Edit menu.

2. Click and drag to surround all of the items with a rectangle, or click on the outline of each of the 
items to be selected while holding down the Shift key. Each item selected will be displayed as a 
red outline.



To select all items in a drawing
1. Choose Select all from the Edit menu.

Note: When objects are deselected, they are redrawn. This could cause underlying objects to be 
temporarily hidden by the redrawn object. To redraw the entire screen, choose Redraw from the 
View menu.



Moving Objects
To move objects to another building level, use the Cut and Paste commands.

Related Topics:
To move an object



To move an object
1. Using the Selection tool, click on the item to move.

2. Move the cursor until the item's outline is in the desired position.

3. Click the mouse button again to position the item.



    Undo and Redo
The Undo command reverses the last command or action. Choosing Undo again will reverse the 
command or action prior to that, and so on, up to 20 levels. You can reduce the Undo levels to make 
more memory available using the Preferences command in the File menu. The Redo command reverses 
the last Undo command.

Related Topics:
To undo the last drawing or editing action
To reverse the last Undo command



To undo the last drawing or editing action
1. Click Undo in the Ribbon or choose Undo from the Edit menu.



To reverse the last Undo command
1. Click Redo in the Ribbon or choose Redo from the Edit menu.



Cut, Copy and Paste
The Cut, Copy and Paste commands are used to delete, move or duplicate items in the same drawing, 
other Floorplan Plus 3D drawings or to documents created with other compatible applications.

Related Topics:
To copy object(s) to the clipboard and delte them from the drawing
To duplicate item(s)



To copy object(s) to the clipboard and delte them from the drawing
1. Select the object(s) to be moved.

2. Press U, or choose Cut from the Edit Toolbox or from the Edit menu.

Note: Windows and doors are only copied to the clipboard if the corresponding walls are also 
selected.

 



To duplicate item(s)
1. Select the item(s) to be duplicated.

2. Press C, choose Copy in the Edit Toolbox, or from the Edit menu.

3. Position the cursor where you want the duplicate item(s) placed.

4. Click Paste in the Ribbon, or choose Paste from the Edit menu. 



Delete
Use the Delete command to remove items from a drawing. The Delete command can be reversed with 
the Undo command.

Related Topics:
To delete item(s)



To delete item(s)
1. Select the item(s) to be deleted.

2. Press the Delete key, or choose Delete from the Edit menu.



Send to Back and Bring to Front
When drawing symbols, it is common to stack filled items to represent detail. When an item is selected, it 
comes to front. The Send to Back and Bring to Front commands are useful for arranging a stack of 
objects for editing and prior to saving as a symbol.

Related Topics:
To send an object to the back
To bring an object to the front



To send an object to the back
1. Select the object(s).

2. Choose Send to Back from the Edit menu.



To bring an object to the front
1. Select the object(s).

2. Choose Bring to Front from the Edit menu.



Converting Lines to Walls
You may find it useful to "sketch" your floor plan using lines, arcs, or other drawing tools, and then convert 
the lines to a series of connected walls. When you covert the lines, you will define the minimum wall 
length in the series.

Related Topics:
To convert lines to walls



To convert lines to walls
1. Select the line(s) to be converted.

2. Choose Convert lines to walls from the Edit menu.

3. Enter the Minimum Wall Length for curve segments. Click OK.



    Adjusting Walls
After carefully placing a wall, it is useful to change the length or angle of the wall without disturbing its 
anchor. 

Related Topics:
To adjust a wall



To adjust a wall
1. Select a wall using the Selection tool.

2. Choose Adjust walls from the Edit menu.

3. Click toward the end to adjust.

4. Move the mouse to adjust the wall, using the outline as a guide and click to place.



Rotating Objects
The Rotate command allows you to rotate selected objects to very specific angles. The closer to the 
center of the object you place the center of rotation, the more control you will have over the angle. The 
Help bar displays the rotation angle.

Related Topics:
To rotate an object



To rotate an object
1. Select the object using the Selection tool.

2. Press R, or click Rotate in the Edit Toolbox, or choose Rotate from the Edit submenu.

3. Click on the object where you want the center of rotation.

4. Move the mouse to rotate the object and click to place.



Scaling Objects
The Scale command allows you to resizeobjects to the degree of accuracy of the grid. The Help bar 
displays the width and height of an object as you scale it.

There are eight control points on the selection rectangle surrounding the selected item. Control point on 
the side of the selection rectangle will adjust the height or the width of the item. Control points on the 
corners of the selection rectangle will adjust both the height and the width.

Related Topics:
To scale an item or symbol



To scale an item or symbol
1. Select the item or symbol using the Selection tool.

2. Press S, click Scale in the Edit Toolbox, or choose Scale from the Edit submenu.

3. Click on a control point to adjust.

4. Move the mouse to resize the item or symbol and click the mouse to set.

Note: When scaling the corners, press and hold down the Shift key for proportional scaling.



Adjusting Lines
The Adjust Lines command works with simple lines drawn with a Floorplan Plus 3D drawing tool. To 
adjust lines within a symbol, you first need to use the Break Symbol command in the Symbols menu, then 
select the line to adjust.

Related Topics:
To adjust a line



To adjust a line
1. Select the line to adjust using the Selection tool.

2. Press A, click Adjust lines in the Edit Toolbox or choose Adjust lines from the Edit submenu. 
Handles, or control points will appear on the outline.

3. Click a control point to adjust.

4. Move the mouse to adjust the line and click the mouse to set.



Editing Text
Text is created using the Text tool or the Draw Text command. Edit the text style by selecting the text and 
clicking Edit in the Style bar. Edit the text string with the Edit Text tool.

Related Topics:
To edit text



To edit text
1. Select the text object to edit using the Selection tool.

2. Press T, click Edit Text in the Edit Toolbox or choose Edit text from the Edit sub-menu. The 
Text dialog box will appear.

3. Edit the text string. Click OK.



Flipping Objects
Symbols are loaded into a drawing in the same position they were saved. Using the rotation tool can 
leave uneven lines in some positions. To keep the position and angle of an object while reversing the 
direction it faces, use either the Flip Horizontal or the Flip Vertical Edit tool.

Related Topics:
To flip an item or symbol



To flip an item or symbol
1. Select theobject to flip using the Selection tool.

2. Press H or V, click in the Edit Toolbox to select the direction you want the object flipped, or 
choose the Flip horizontal or Flip vertical command from the Edit tools submenu. 



Saving a Symbol
Symbols can be created by editing existing symbols or drawing new ones.

Related Topics:
To save a symbol



To save a symbol 
1. Use the Selection tool to select the symbol to be saved.

2. Choose Save symbol from the Symbols menu, press S, or click Save in the Edit Toolbox. The 
Symbol Options dialog box will appear. 

3. Complete the Symbol Options dialog box, and click OK.

4. Select the library for the symbol and click OK. 



Deleting a Selection
Selections are easily deleted using the Delete key, the Delete command, or the Delete tool.

Related Topics:
To delete a selection



To delete a selection
1. Use the Selection tool to select the symbol to be deleted.

2. Press the Delete key, choose Delete from the Edit menu, press D, or click Delete in the Edit 
Toolbox.



Setting the Drawing Size
The basic step in creating a drawing of the desired dimensions is to set the maximum drawing size. This 
command will adjust the view of the drawing so that a drawing of the full selected size will fit within the 
drawing area. The maximum drawing size can be changed at any time. 

Related Topics:
To set the maximum drawing size



To set the maximum drawing size
1. Choose Maximum drawing size from the Options menu.

2. Select the smallest dimension that you expect your drawing to fit within. Click OK.



Wall Length Labels
You can choose to have all walls automatically labeled with their length as drawn.

Related Topics:
To turn on automatic wall labels
To turn off automatic wall labels



To turn on automatic wall labels
1. Choose Auto wall dimensioning from the Options menu.

2. After drawing a wall, click a second time to position the label.



To turn off automatic wall labels
1. Choose Auto wall dimensioning from the Options menu.

Note: Avoid using Auto wall dimensioning when drawing walls at odd angles. They can be 
misleading because the inside and outside lengths of the walls change when joined to another 
wall. You can go back    and add dimension lines as needed.



    Measuring Lengths
You can measure the distance between any two points in your drawing and optionally record the distance 
with a dimension line.

Related Topics:
To measure the distance between two points



To measure the distance between two points
1. Choose Measure Length from the Options menu.

2. Click on the first point, move the mouse, and click on the second point. The Measure dialog box 
will display the distance between the two points.

3. Click Add dimension line to add a label to the drawing, change the Length to change the 
dimension line, or click Cancel.



    Measuring Area and Perimeter
You can outline any shape using the Area and Perimeter command. As soon as you connect back to the 
initial point, a dialog box will display the area and perimeter in the measurement system selected in the 
Preferences. 

Related Topics:
To measure the area and perimeter of a shape



To measure the area and perimeter of a shape
1. Choose Area and perimeter from the Options menu.

2. Click on the first point, move the mouse, and click on the second point, and so on, to outline the 
shape. Press Delete to erase the last point, ESC to abort, and press the right mouse button, 
Return, or click the initial point to close. The Area and Perimeter dialog box will display the area 
and perimeter of the shape.

3. Click Cancel.

Polygon, text, and label parameters can be modified from the Options menu. The Options menu also 
provides tools for measuring distances, perimeters, and areas.

Note: Area is automatically calculated for Areas and Floors when a Materials list is generated.



Number of Polygon Sides
The Polygon Sides command set the number of sides drawn with the Polygon tool. By default, Floorplan 
Plus 3D polygons have five sides.

Related Topics:
To change the number of polygon sides



To change the number of polygon sides
1. Choose Polygon Sides from the Options menu.

2. Type the number of sides wanted and press Return.



Overview
Floorplan Plus 3D includes the new 3D Viewer for transforming your two dimensional drawing into a three 
dimensional illustration. You set the view position and the light source. You can then "move through" and 
"look around" the wire-frame model. You can quickly and easily "shade" the view with the click of a button.

You can print the 3D illustrations in wire-frame or shaded views and in any combination of layers. Files 
can be exported to DXF and then easily imported into 3D Design Plus and other CAD programs. 

When you enter the 3D Viewer you will notice a change in the Ribbon, Style and Menu bars. The Tool and 
Status bars are not used. This chapter discusses all of the 3D Viewer features and commands.



Running 3D Viewer
The 3D Viewer automatically displays walls, stairs, floors, and rails in three dimensions. Other elements, 
including doors, windows and symbols, display the three dimensional drawing file associated with the two 
dimensional symbol. This association can be done in an object's Options dialog box, displayed by 
selecting the two dimensional object and clicking Edit in the Style bar. 3D Design Plus, for creating three 
dimensional drawings and three dimensional drawing libraries are available from ComputerEasy.

The DOS 3D Viewer is available for real-time shaded "walk-throughs" of your floorplan that would be 
prohibitively slow under Windows. The Printing, Brightness, and Shade Options are not available in the 
DOS Viewer, although the Ribbon commands function the same. Access the DOS Viewer through the File 
menu. 

Note: Using the mouse in the DOS Viewer requires that a mouse driver (the software that comes 
with your mouse) is loaded and executed. The Windows built-in mouse driver will not work with 
the DOS Viewer. If you do not have a mouse driver loaded, use the keyboard commands on page 69.

Related Topics:
To run the 3D Viewer
To run the DOS Viewer



To run the 3D Viewer
1. Choose Run 3D viewer from the File menu, or click 3D in the Ribbon bar. The View pointer will be 

displayed.

2. Position the pointer at the viewpoint in the floor plan. Click the mouse button.

3. Move the mouse to set the viewport. Click the mouse button. The View dialog box will appear.

4. Complete the dialog box and click OK. The floorplan will appear in three dimensional wire frame.

All levels

Displays all building levels and the roof, if applicable. 

Current level

Displays only the current level.

All layers

Displays all layers. Layers can be altered from within the 3D 
Viewer from the View menu.

Visible layers

Displays only the selected layers.

Position of light source 

Affects 3D colors in shaded views. The Horizontal angle 
describes the position of the sun on the horizon with respect to 
East. The Vertical angle applies to the time of day, or the sun's 
position overhead, with respect to East. 

Starting height

Describes the distance of the viewport from the floor.



To run the DOS Viewer
1. Choose Run DOS Viewer from the File menu.

2. Click Exit, or press ESC, to return to the Windows 3D Viewer.



Adjusting the View
The 3D Viewer Ribbon icons adjust the view, enabling you to walk-through the floorplan and move the 
viewport. You can also adjust the view with the keyboard.

Key Action
Left Arrow Turn left

Right arrow Turn right

Up arrow Move forward

Down arrow Move backward

Ins Spin left

Del Spin right

Home Spin down

End Spin up

U Move up

D Move down

L Move left

R Move right

+ Increase move step by 1 foot

- Decrease move step by 1 foot

ESC Quit

Related Topics:
To change the view height
To change the view position
To turn at the current viewpoint
To turn up or down from the current viewpoint
To rotate around the center of the drawing
To select layers for viewing



To change the view height
The Up and Down buttons in the Ribbon bar are used to adjust 
the view height.

1. Click Up in the Ribbon bar to raise the view height.

2. Click Down in the Ribbon bar to lower the view height.



To change the view position
The Left, Right, Forward and Back icons in the Ribbon bar adjust 
the view position without altering the viewport direction.

1. Click Left or Right to move the horizontal view position through the floorplan, without turning.

2. Click Forward or Back to move the view position into or out of the view.



To turn at the current viewpoint
1. Click Turn, either left or right to rotate the view from the current viewpoint.



To turn up or down from the current viewpoint
1. Click Look, either up or down to vertically tilt the viewport.



To rotate around the center of the drawing
1. Click Spin, in the direction you'd like to spin the drawing.



To select layers for viewing
1. Choose Layers from the View menu. The Layers dialog box will appear.

2. Click to check the layers to be viewed. Click the View All or View None buttons to quickly 
check/uncheck all layers. Click OK.



Shading the View
Instantly add surfaces to wire-frame illustrations for a more realistic view of the current view. 

The DOS Viewer allows a real-time shaded walk through, that would be prohibitively slow in Windows. 
Printing, Brightness, and Shade Options are not available in the DOS Viewer. Access the DOS Viewer 
through the File menu. 

Related Topics:
To apply surfaces to a 3D wire-frame illustration
To Shade the View using the full screen



To apply surfaces to a 3D wire-frame illustration
1. Click Shade in the Ribbon bar, choose Shade Viewport from the View menu, or press S to add 

surfaces to your drawing.



To Shade the View using the full screen
1. Choose Shade full screen from the View menu to hide the Title, Menu and Ribbon bars. Click 

the mouse to un-shade the view.



Adjusting the Shade
Use the commands in the View menu to set the brightness, or contrast between dark and light surfaces in 
shaded views, and to set shade options. 

The colors assigned to objects are applied at their brightest shade. Flat surfaces will reflect all objects in 
this shade, 100% brightness, without regard to the light position. Choosing Shaded or Shaded with 
Outlines from the View menu will darken surfaces with regard to the position of the light.

Related Topics:
To adjust the contrast in Shaded views
To display objects in color, 100% brightness, without shade
To apply shades with regard to the position of the light source
To illustrate with surfaces, without color or shades



To adjust the contrast in Shaded views
1. Choose Set brightness level from the View menu. The Adjust Brightness dialog box will appear.

2. Drag the scroll box to the right to reduce contrast, drag to the left to increase contrast, or enter 
the percentage of brightness (0-100). Click OK.



To display objects in color, 100% brightness, without shade
1. Choose Shading options from the View menu.

2. Choose Flat or Flat with outlines from the Shading options submenu.



To apply shades with regard to the position of the light source
1. Choose Shading options from the View menu.

2. Choose Shade or Shade with outlines from the Shading options submenu.



To illustrate with surfaces, without color or shades
1. Choose Shading options from the View menu.

2. Choose Hidden lines removed from the Shading options submenu.



Exporting 3D drawings
Floorplan Plus 3D has the ability to export your floor plan to DXF file format for importing into 3D Design 
Plus    and other CAD programs. This is useful for further design and advanced rendering of your floor 
plan.

Related Topics:
To export to a DXF file



To export to a DXF file
1. Choose Export to DXF from the File menu. The Export to DXF dialog box will appear.

2. Type the name of the file to export to ("filename.DXF"), and select the directory to which to save 
the file. Click OK.



Printing 3D drawings
Use the Printer Setup and Print commands print your 3D drawings. 

Related Topics:
To select printer
To print the drawing



To select printer
1. Choose Printer setup from the File menu.

2. Choose a printer form the pop-up menu and click OK.



To print the drawing
1. Choose Print from the File menu. The Print Options dialog box will appear. 

2. Complete the dialog box and click OK.

Shading Options

Choose to print the drawing in Wireframe, Shaded with or 
without outlines, or with surfaces, black on white (Hidden line).

Color Conversion

Map to Black is used to print black and white, only. Use color will 
print color or shades of gray, depending on your printer.

Layers

Choose to print All Layers or only the Visible Layers selected 
using the Layers command in the View menu.



Exiting the 3D Viewer

To exit the 3D Viewer and return to two dimensional planning
1. Choose Exit from the File menu.



Running the Roof Editor
The roof can be added as soon as the exterior    walls are complete. Interior wall placement is essential, 
however, for planning surface changes and the placement of dormers, skylights and chimneys. The Roof 
Editor can be run stand-alone for creating roof templates or parts, or from the Floorplan Plus 3D File 
menu for adding a roof to a floor plan.

Related Topics:
To run the Roof Editor from Floorplan Plus 3D
To run the Roof Editor as a stand-alone program



To run the Roof Editor from Floorplan Plus 3D
1. Choose Run Roof Editor from the File menu. The walls of your floor plan will appear grey in the 

top view (X,Z plane). 

2. Choose Load from the File menu. Select a roof style and click OK. The roof will be loaded and 
automatically scaled to fit over the walls.

3. Edit the roof as desired, then Update to include the roof in your floor plan.



To run the Roof Editor as a stand-alone program
1. Double-click on the Roof Editor icon. The Roof Editor window will appear.



Roof Editor Files
Roof Editor files are created when you Update from the Roof Editor    File menu and Save your floor plan. 
Update saves the current roof to the current floorplan and returns to the floorplan.    When you Exit the 
Roof Editor, you will have the option of updating your floor plan. Saving your floorplan saves the roof to a 
file, assigning the name of the floorplan with and "RF" extension. You can then Load the files for editing, 
or Merge the files with other roofs or roof part files to create new roofs. 

Choosing New from the File menu will clear the existing roof.

Preferences in the Roof Editor is similar to the Floorplan Plus Preferences. See page 24 for detailed 
information on these fields.

The 3D Viewer is available from the Roof Editor by choosing 3D from the Ribbon or the File menu. See 
Chapter Ten for details on positioning the light source and using the 3D Viewer.



The Roof Editor Window
The Roof Editor window is similar to the floor plan window. The significant differences are:

    The Style bar is at the right of the Ribbon bar.

    The Help bar and Status bar are combined.

    The View bar provides for changing the viewport.

    You have the option of dividing the screen into several Viewports.

The Options menu provides for displaying or hiding the Ribbon bar, Status bar, Angles, Axes, Viewports 
and Reference walls.

Zoom commands are found in the View menu and are similar to Floorplan's Zoom commands. The 
exception is Zoom All to Extents, which is very useful when viewing more than one viewport.

The Grid commands are identical to the Floorplan Grid commands, except they are only available in the 
Roof Editor's View menu.

Choose Pan from the View menu then click on a point to move it to the center of the viewpoint.

The Reference Point in the Roof Editor has the same functionality as Floorplan's Reference point; 
however, the references are displayed for three axes. This becomes very important when drawing in a 
view with only two axes. Position the Reference Point by    choosing Reference Point from the View menu, 
or click on the Status bar. The Reference Point will remain in position as you change views. The Status 
bar displays the distance from the Reference Point to the cursor on each axes and a straight line. 



Editing Tools
Creating a roof from scratch is an artistic skill that you can develop by editing the roof styles included in 
Floorplan Plus 3D. We suggest you examine the included floorplans and their roofs. You can then apply 
these roofs, or other included roofs, to your floorplan. Edit the roof with the tools and tips described below. 
After some concentrated editing, you will become more comfortable creating in three dimensions and the 
Roof Editor, and may want to venture into designs from scratch.

There are four tools and three planes, or axes, to consider when creating your roof. The Tools are in the 
Ribbon and the Draw menu. You can Edit the attributes of each tool by clicking Edit in the Ribbon bar. The 
Axes are displayed in the lower right corner of the Viewport. 

TIP: Begin editing by choosing 3 Viewports from the Options menu. Choose Zoom All to 
Extents from the View menu to maximize each Viewport.



    Selection Tool
The Selection tool can be used in any viewport. Select control points to reposition objects, and select 
objects to delete or change attributes. By selecting multiple objects of the same type and clicking Edit in 
the Ribbon, you can edit all of their styles. Use the following selection methods:

Click to select a control point and all coinciding control points 
from adjacent surfaces.

Click on a line to select the entire surface or object.

Click and drag a box around multiple, adjacent items to be selected.

SHIFT-Click, press and hold the SHIFT key while selecting, to select multiple items.



    Surfaces
Surfaces are drawn flat (0°) in the X,Z dimension. The vertices of each surface is a Control Point. Select 
and drag control points to adjust the shape of the roof in any dimension. Selecting a control point will 
select the coinciding vertices of adjacent surfaces. 

When editing the Angle of a surface, note the color in which the pitch is displayed. A yellow background 
means the surface is flat; a red background means the surface is not planar, and may result in gaps.

Use the Reference Point, by clicking on the Status bar and positioning, to display distances in each axes.

You may find it helpful to use a variety of colors for surfaces. To change the color of a selected surface, 
choose a color from the pop-up menu in the Ribbon bar, or click Edit. Edit allows for Part Number and 
Category descriptions for use in a Materials list or Estimator files.



    Dormers
A dormer widow is set vertically, projecting from a sloping roof. It is typically found in upstairs bedrooms 
and attics, adding visual appeal to the roof.

You can define the size and color of a dormer by clicking Edit after choosing the Dorm tool. You can also 
enter a Part Number and Category for use in the Materials list or Estimator files.

Related Topics:
To create a Dormer



To create a Dormer
1. Position the reference point on a vertex of the surface to contain the Dormer.

2. Select the Dormer tool from the Ribbon or Draw menu.

3. Click Edit to specify the size and color of the Dormer attributes. Click OK.

4. Using three Viewports, click in the Top view to position the base of the Dormer, using the Status 
bar distances as a guide.

5. Select and drag the control point at the base to reposition the Dormer.



    Chimneys
Positioning a chimney in your roof is a simple matter of defining it's size, and knowing the position of the 
fireplace. For purposes of the Roof Editor, you may want to use a Wall style to outline your fireplace in the 
floor plan.

Like other tools, you can define the size and color of a chimney by clicking Edit after choosing the 
Chimney tool. You can also enter a Part Number and Category for use in the Materials list or Estimator 
files.

Related Topics:
To create a Chimney



To create a Chimney
1. Position the reference point on a vertex of the surface to contain the chimney.

2. Select the Chimney tool from the Ribbon or Draw menu.

3. Click Edit to specify the size and color of the chimney. Click OK.

4. Using three Viewports, click in the Top view to position the low base of the chimney, using the 
Status bar distances and other views as a guide.

5. Select and drag the control point at the base to reposition the chimney.



    Skylights
Skylights are becoming increasingly popular in this age of resource consciousness and have bright 
cosmetic benefits as well. Creating skylights in simple in the Roof Editor.

Related Topics:
To create a Skylight



To create a Skylight
1. Position the Reference point on a vertex of the surface to contain the skylight.

2. Select the Skylight tool from the Ribbon or Draw menu.

3. Click Edit to specify the size and color of the skylight. Click OK.

4. Using three viewports, click in the Top view to position the low base of the skylight, using the 
Status bar distances and other views as a guide.

5. Select and drag the control point at the base to reposition the skylight.



Abbreviations
The following is a list of standard abbreviations for items that you may wish to include in your floor plan. 
These abbreviations can be added to your drawing with the Text tool.

A/C Air Conditioning

AD Area Drain

AL Aluminum

AUTO Automatic

BEL Below

BLK Block

BLDG Building

BOT Bottom

BRK Brick

BSMT Basement

CEM Cement

CFT Cubic Foot

CLG Ceiling

CM Centimeter

COL Column

CPT Carpet

CT Ceramic Tile

CTR Counter

CYD Cubic Yard

D Drain

DF Drinking Fountain

DH Double Hung

DIAM Diameter

DR Door

DS Down Spout

D/W Dish Washer

EL Elevation

ELEC Electrical

EMER Emergency

EWC Elec. Water Cooler

EXP Exposed

FA Fire Alarm

FB Face Brick



FBRK Fire Brick

FE Fire Extinguisher

FHS Fire Hose Station

FN Fence

FP Fireproof

FPL Fireplace

FURN Furnace

GAL Gallon

GND Ground

GRTG Grating

GVL Gravel

HDW Hardware

HDWD Hardwood

HT Height

HTR Heater

HW Hot Water

IN Inch

INSUL Insulation

INT Interior

J-BOX Junction Box

KIT Kitchen

KO Knockout

LAM Laminated

LAV Lavatory

LB Pound

LGTH Length

LEV Level

LIN FT Linear Feet

LINO Linoleum

LUM Lumber

M/C Medicine Cabinet

MRB Marble

MAX Maximum

MIN Minimum

MIRR Mirror

MISC Miscellaneous

MLDG Molding



MTL Metal

NO Number

NTS Not To Scale

OPG Opening

OZ Ounce

PER Perimeter

PLAS Plastic

PLAT Platform

PLMB Plumbing

PLY Plywood

PNL Panel

POS Position

PR Pair

PREFAB Prefabricated

PRELIM Preliminary

PSF Pounds per Sq Foot

PSI Pounds per Sq Inch

PTD Painted

PVMT Pavement

RD Roof Drain

RDG Ridge

REF Reference

REFR Refrigerator

REQD Required

RFG Roofing

RIS Riser

SCH Schedule

SCR Screw

SCRN Screen

SD Storm Drain

SDG Siding

SECT Section

SEW Sewer

SH Shower

SHT Sheet

SPECS Specifications

SQ Square



SQFT Square Feet

SQIN Square Inch

SST Stainless Steel

ST Street

SUR Surface

TEL Telephone

TEMP Temperature

THR Threshold

THRM Thermostat

UR Urinal

UTIL Utility

VAN Vanity

VENT Ventilation

VERT Vertical

VIN Vinyl

WDW Window

WH Water Heater

WP Waterproof

WT Weight

WV Wall Vent

YD Yard



Length Conversions
1 Centimeter = 0.3937 inch

1 Meter = 3.28 feet

1 Meter = 1.094 yards

1 Kilometer = 0.621 statute mile

1 Kilometer = 0.5400 nautical mile

1 Inch = 2.54 centimeters

1 Foot = 0.3048 meter

1 Yard = 0.9144 meter

1 Statute Mile = 1.61 kilometers

1 Nautical Mile = 1.852 kilometer



Area Conversions
1 Square Centimeter = 0.155 square inch

1 Square Meter = 10.76 square feet

1 Square Meter = 1.196 square yards

1 Hectare = 2.47 acres

1 Square Kilometer = 0.386 square miles

1 Square Inch = 6.45 square centimeters

1 Square Foot = 0.0929 square meter

1 Square Yard = 0.836 square meter

1 Acre = 0.405 hectare

1 Square Mile = 2.59 square kilometers



Fraction to Decimal Conversions
1 = 1.0000

1/2 = 0.5000

1/3 = 0.3334

1/4 = 0.2500

1/5 = 0.2000

1/6 = 0.1667

1/8 = 0.1250

1/9 = 0.1112

1/10 = 0.1000

1/11 = 0.0910

1/12 = 0.0834

1/13 = 0.0770

1/14 = 0.0715

1/15 = 0.0667

1/16 = 0.0625



How can I change the scale in Floorplan Plus 3D?
A. When you first run Floorplan Plus 3D, the default maximum drawing size is 325 X 325 feet, or 100 x 
100 meters, and the scale setting is 4 feet = 1 screen inch, 1/4" scale, or .050 meters = 1 cm. To change 
the view scale, choose Current View Scale from the View menu. A window will appear on the screen 
displaying the current scale. You can edit this scale by typing in the number of units per unit on the 
screen. 



How can I change the current drawing color?
A. With the exception of the Foreground, Background, Cursor and Selected object colors, all objects use 
the drawing color in the Style Bar. Click on the    Color pop-up menu in the Style bar, and drag to choose 
the desired color. To change the color of the Foreground, Background, Cursor and Selected object colors, 
choose Preferences from the File menu.



Why do some drawings seem sluggish?
Text in a drawing will slow down the screen redraw process. To use text efficiently, you can conserve on 
text until completion or turn off Text Layers. You can choose to display the "text layers" only when 
necessary.



How can I be specific in size and placement of objects and walls?
Use of the Grid commands in the Status bar or View menu makes placing and sizing easy. Choose View 
Grid to display the grid. You can set the Grid Size to any measurement. Choosing Snap To Grid will 
ensure objects and walls are lined up directly on the grid by creating a sort of "magnetic force" on the grid 
lines.

 



Glossary of Terms

Glossary of Terms
3D Viewer
Area
ASCII 
Baluster
Brightness Level
CADD
Catalog
Currrent Level
Dormer
Double-click
Drag
Drawing Area
DXF
Estimator Plus 
Floor plan
Floorplan Plus
Height
Hidden Line Removed
Length
Light Source
Materials Listing
Menu Bar
Object
Pan
Perimeter
Polygon
Pop-Up Menu
Print Scale
Reference Axis
Reference Wall
Rise
Roof Angle
Run
Shape
Snap
Symbol
Symbol Library
Thickness
Vector Line
View Scale
Viewport
Width
Zoom in
Zoom out



3D Viewer
A program within Floorplan Plus 3D for viewing floor plan drawings in 3 dimensions.



Area
The two-dimensional measure of a surface. Primarily used to find the square foot area of floors, yards, 
and other flat surfaces.



ASCII 
Acronym for American Standard Code for Information Interchange. ASCII is a language of number sets 
that represent the English alphabet in computers.



Baluster
The vertical support for a rail, often vase-shaped.



Brightness Level
The degree of contrast between darks and lights in shaded views. The lower the brightness level, the 
more contrast.



CADD
A generic term refering to software for the purpose of computer-aided design and drafting.



Catalog
A list of all objects within a specific object library. See "Object Library."



Currrent Level
The building level being edited in 2 dimensions.



Dormer
A small rectangular structure that projects from a sloping roof and houses a window.



Double-click
An instruction to rapidly press and release the mouse button two times.



Drag
An instruction to position the mouse pointer, press and hold the mouse button down, and move the 
mouse to reposition the pointer or the object to which you are pointing.



Drawing Area
The main area of the Floorplan Plus 3D window where all drawing takes place.



DXF
A file format that can be imported by many other CADD programs. Floorplan Plus 3D exports DXF files.



Estimator Plus 
A software package also published by ComputerEasy International, Inc. that estimates project costs. 
Floorplan Plus 3D generates a file that can be used with Estimator Plus.



Floor plan
A drawing showing the arrangement of rooms, furniture, windows, doors, and/or other data and 
dimensions.



Floorplan Plus
The best-selling home design software available for DOS, WIndows, Macintosh and 3D for WIndows.



Height
The distance from the top of the floor to the top of the object.



Hidden Line Removed
Displays a 3D illustration as white lines on black surfaces, and prints as simple black lines.



Length
The horizontal measurement from the front view.



Light Source
The position of the sun or light as measured from due East.



Materials Listing
A list of areas, doors, floors, railing, stairs, walls, windows, wire & pipe, chimneys, dormers, skylights, and 
roof surfaces generated by Floorplan Plus products.



Menu Bar
The very top line of the screen that displays the six different menu choices: Apple menu, File, Edit, 
Options, Objects and Status Bar. Use menus by clicking on them and dragging to choose a command.



Object
Any combination of lines capable of being selected representing a single symbol, drawing, door, window, 
area, floor, circle, line, etc.



Pan
To move a through a large drawing on the screen, using the mouse and scroll bars, to see different 
portions of the drawing. 



Perimeter
The length of the boundary of an area.



Polygon
A closed plane figure bounded by straight lines.



Pop-Up Menu
A rectangle on the Attribute Bar that allows you to select one of several choices by clicking and dragging 
through a list.



Print Scale
A ratio factor applied to printing so the drawing will fit on paper.



Reference Axis
The axis on which to measure the distance from the cursor to the reference point.



Reference Wall
A top view indication of walls below the current drawing level used for positioning objects on the current 
level.



Rise
The distance from the top of one stair to the top of the next. The Total Rise is the distance from the floor 
to the top of the landing.



Roof Angle
A measurement of the corner formed from a flat surfacel to the highest point of a roof surface as viewed 
from the front or side.



Run
The depth of a straight stair, from from front to back. The Total Run is the distance from the front of the 
bottom stair to the back of the top stair.



Shape
A simple object drawn with a Floorplan Plus 3D tool.



Snap
Turning on the Snap-To-Grid feature activates a "magnetic pull," or snap, on the grid lines, so that objects 
and drawings are easily aligned.



Symbol
A drawing of an object used within a drawing.and stored in Symbol Libraries for future use.



Symbol Library
One file of stored symbols that can be accessed from any drawing.



Thickness
The distance from the top to the bottom of an object.



Vector Line
The line drawn with the Text too that text will appear on.



View Scale
A ratio factor applied to a drawing for viewing on screen.



Viewport
The range of vision set for surveying a 3 dimensional illustration.



Width
The distance from the front to the back of an object.



Zoom in
To enlarge a portion of the drawing to fill more of the screen, to display greater detail.



Zoom out
To reduce the perspective of your view so that you see more of the drawing at one time. 




