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About Icolib

This 'Help' menu option displays a dialog box containing some information about the version number and author of
Icolib.

After you have read the information contained in this window, you must close it before you can continue using
Icolib.

You can close the About Box by clicking on the OK pushbutton, by pressing the return key on the keyboard, or by
using the Control Close features provided by Windows.



Control Close
The Control Close option of the Control Menu closes the active application window. If a dialog box is open and
has a Control menu, choosing this command only closes the dialog box.
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This is the Control Menu icon. Double-clicking this icon is the same as choosing Control Close.

If you are situated in the application's main window then closing this window is the same as choosing the Exit
option under the 'File' menu.




Clicking Operation
The clicking operation is performed by moving the mouse cursor to the item to be clicked, pressing either the left or
right mouse button briefly, and then releasing it without moving the cursor position.

Double clicking involves pressing and releasing the left mouse button twice in quick succession.



Control Maximize
The Control Maximize option of the Control Menu enlarges the active window to fill the available screen space.
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This is the Maximize icon which, if clicked, is the same as choosing Control Maximize.

You can restore a maximized window to its former size by using the Control Restore command.



Control Menu
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This is the Control Menu icon which contains various standard controls for manipulating the size, position and
status of the application window.

Control Restore

Control Move

Control Size

Control Minimize

Control Maximize

Control Close

Control Switch-To

Title Bar




Control Minimize
The Control Minimize option of the Control Menu reduces the active window to a small icon at the bottom of the

screen.

-
This is the Minimize icon which, if clicked, is the same as choosing Control Minimize.

Minimizing is useful when you are running other applications at the same time as the current application and you
wish to unclutter the screen.
This icon appears only on the Title bar of the main application window. It does not appear on any of the dialog box

windows which, therefore cannot be minimized.

You can restore a minimized window to its former size by using the Control Restore command.



Control Move
The Control Move option of the Control Menu allows you to move a window around the screen.

When this control is selected, it displays this four-headed arrow }%: as a cursor, which you can use to move the
window about the screen. By using the keyboard arrow keys, you can manipulate the cursor and change the position
of the window.

An easier method uses the mouse. Move the standard arrow cursor to within the Title bar of the window to be
moved. Pressing the left mouse button while moving the cursor will cause the window to follow.

If a dialog box is open and has a Control menu, you can also use this command to move the dialog box.

If the window is maximized, this command is unavailable.



Control Restore

The Control Restore option of the Control Menu restores the selected window to the size and location on the screen
that it had before you chose either of the Control Maximize or the Control Minimize commands.
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This is the Restore icon which, if clicked, is the same as choosing Control Restore.

Control Restore does not affect changes made to a window with the Control Move or Control Size commands.




Control Size
The Control Size option of the Control Menu allows you to change the size of a window.

When this control is selected, it displays a four-headed arrow G{E’ as the cursor which you can then use to change the
size of the currently selected window. By using the keyboard arrow keys, you can manipulate the cursor and change
the size of the window.

An easier method uses the mouse. Move the standard arrow cursor to any edge or corner of the window to be
resized. When you are in the correct position, the cursor will change to a double ended arrow. Pressing the left

mouse button while moving the cursor will resize that edge or corner of the window.

If the window is maximized, this command is unavailable.



Control Switch-To

The Control Switch-To option of the Control Menu opens a dialog box which lists all of the open applications.

Double clicking on the desktop area behind the displayed windows will have the same effect as choosing Control
Switch-To.

The following pushbuttons are available within this dialog box.

Switch To
This option activates the selected application. An application can also be selected by double clicking on its name in
the list box.

End Task
This option closes the selected application.

Cancel
This option closes the Task List window and cancels the Switch-To dialog box.

Cascade
This option sizes all open application windows so they overlap and each title bar is made visible.

Tile
This option maximizes all open application windows and sizes them so that the upper-left portion of each window is
visible.

Arrange Icons
This option arranges the icons of all minimized applications across the bottom of the screen.



Title Bar

The title bar is the area at the very top of the application window. This area usually contains the name of the
application, although in the case of Icolib, it displays the filename of the currently open Icon Library and the number
of icons in the library.



'File' Menu

The 'File' menu has an option which allows you to start or stop animation of the icons contained in a loaded icon
library, and also an option to stop running Icolib. There are no file options available at this stage but the File menu
name is often expected by Windows users to contain the Exit option.

This menu name has been placed within inverted commas to distinguish it from menu items which are used to
display icon libraries. The 'Help' is also placed within inverted commas for the same reason.

The following options are available under 'File'.

Start Animation
Exit



Exit

This 'File' menu option closes the Icolib window.
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This is the Control Menu icon. Double-clicking this icon is the same as choosing the Exit menu option.

You can also use the Control Close menu option to close Icolib.



'Help' Menu

The "Help' Menu contains shortcuts into the help system for Icolib. It also includes access to the About Box which
gives version and author details for Icolib. If this is the first time you have run this program Getting Started will
provide hints on how to quickly start using Icolib.

Index...

Getting Started...
How to Use...
Icolib Objectives...

Registering...

Using Help...
About Icon Library...




Icolib Menu Index

The following menu items are available to the user. Press on the required menu item for more details of the selected
menu.

Control Menus

[e—

This is the Control Menu icon which contains various standard controls for manipulating the size, position and
status of an application window.

Control Restore

Control Move

Control Size

Control Minimize

Control Maximize

Control Close

Control Switch-To

Title Bar

'File' Menus

The 'File' menu allows you to start or stop icon animations, or to leave the Icolib. No file save or restore options are
available at this stage.

Start Animation

Exit

Icon Library Menus

The contents of the other menus depend on the specifications contained in the icolib.ini file which is modifiable by
the user. These menu items allow the user to select from various categories of icon libraries.

'Help' Menus

The 'Help' Menu contains shortcuts into the help system for Icolib. It also includes access to the About Box which
gives version and author details for Icolib. If this is the first time you have run this program Getting Started will
provide hints on how to quickly start using Icolib.
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Help Using Help

This 'Help' menu option provides information on how to use the Windows help program.

This menu option is also available under the Help menu in the title bar of the Windows Help program.



Icon Library Objectives
Icolib was written to help solve the problem of managing large collections of icons. The following objectives were
considered important and have been met by this application.

Ease of Access
- Group icons into logical catagories so that a particular type of icon is easier to find.

- The Icon Libraries are very easy to display. Just select the required library though the menus, and the client area
will display all the library icon members. This display can be resized, moved, or minimized, just like any other
window. You can display several Icolib windows simultaneously by starting a new instance of the Icolib application
for each library. Each instance of Icolib only uses an additional 14Kb of memory.

- The access speed is also vastly improved by using Icolib because the icons are grouped together so there are less
entries in the disk directory. The directory does not have to be accessed for each individual icon.

- These libraries can be easily expanded by either adding new categories, or by adding new (or improved) icons in
existing categories. The user only needs to modify the icolib.ini file to add or delete categories, or to change icon
filenames or menu descriptions. An icon editor such as Icon Manager is required to create the actual icon library
files. These programs are available as shareware from many sources.

Save Disk Space

- By collecting many icons together into a single library, quite a lot of disk space can be saved. Each individual icon
only uses 766 bytes, but if your disk cluster size is 4096 bytes, you waste 3330 bytes for each icon. If you are storing
the icons in the collection supplied with Icolib as individual files, you would be wasting more than 6 Mbytes of disk
space. The ICL format is not compressed so further savings can be made by compressing these files. You must
uncompress them before they can be used with the Icolib application.

- You only need to keep the categories you are interested in. There is no need to store hundreds of games related
icons if you are only interested in office related ones. All you need do, is modify the icolib.ini file to remove
categories you don't need from the Icolib menu, and then delete or archive the associated filename.ICL file.

- Creating this Icolib has provided me with the opportunity to eliminate hundreds of duplicate icons which I had
collected from various sources. Many of the icons in several collections available on CICA are duplicates of each
other. Sometimes the icon names are different, but the pictures are the same, and these renamed icons made it harder
to find duplicates. These duplicates are also very wasteful of disk space.

Suggestions
This product is certainly not perfect so any suggestions for improvements from users are appreciated.
See Also:

Getting Started...
How to Use...

Registering...



Getting Started

You can load a new icon library by selecting one of the menu options. The libraries are sorted into various high level
categories, the names of which appear as menu items on the menu bar. Each of these categories can have many icon
collections associated with them and can be selected by chosing a menu item under the category menu name. When
a library is loaded, the member icons will be displayed in the Icolib client area. If you load another library, then the
displayed icons will be over-written by the new icons.

The 'File' menu menu option allows the user to start and stop icon animations, and to exit from the Icolib
application.

See also:
How to Use...
Icolib Objectives...

Registering...




How to Use
Loading an Icon Library

When Icolib is first started it creates an empty client area which will display the icons stored in an icon library once
it is loaded. An icon library can be loaded using the menus located between the 'File' and the 'Help' items. These
icolib menu items are specified by the user by modifying parameters in the icolib.ini file.

Vertical Scroll Bar

If there are too many icons to display in the client area, a vertical scroll bar will appear. This control allows the user
to select which icons are to be viewed. The scrollbar is removed if the size of the Icolib window is increased so that
all the icons in the loaded library can be displayed.

Animated Icons

If you wish to animate the displayed icons, you can do so by selecting the Start Animation menu item which is found
under the 'File' menu. It is possible to animate the icons in any library, however, it is usually only effective with icon
libraries which have been design specifically for animation. During animation, the menu description is changed to

Stop Animation.

Context Help

You can obtain help at any time by pressing the F1 key or by selecting the help items under the 'Help' menu. If you
wish to see what a particular control does, then a context help is available by pressing Shift-F1 at which time the
cursor will change to an arrow attached to a question mark. The next item that the user selects will be the one
explained by the help system.

See also:

Getting Started...
Icolib Objectives...

Registering...




Icon Contributions

If anyone has icons which they wish to contribute to the collection, I am willing to accept them for inclusion into the
next release of Icolib. Please try not to send duplicates of what is already contained in the current release. The only
icons that I can handle at the moment are the ones which are in the standard 32x32 bit 16 color format. If you are on
the Internet then you can send any contributions to steve@cc.monash.edu.au.



Start/Stop Animation

If you wish to animate the displayed icons, you can do so by selecting this menu item. It is possible to animate the
icons in any library, however, it is usually only effective with icon libraries which have been design specifically for
animation. Many examples of animated icons have been included with this application. During animation, the menu
item is changed to Stop Animation. Selecting this menu option now will stop any animation in progress. Icolib then
redraws all the members of the currently displayed icon library.

While an animation is in progress, only the top left corner of the Icolib client area is used. The individual members
of the icon library are not shown seperately.



How to Register

Icolib (Icon Library) is distributed as shareware. It is not free. You may use it without registering for a period that
your conscience will allow, but then I would appreciate a registration. It is very discouraging to spend many weeks
working on a program for little or no reward. :(

Registered Users may request the complete source code and all the resources used to develop this program.

Registration costs US$15 and if you wish to receive source code, then see below for additional postage and handling
charges. Foreign customers please do not use personal cheques, but send a Bank Draft or International Money
Order. If you wish to send cash in the mail you do so at your own risk, but cash will be accepted if received. It may
be much cheaper to send cash than trying to deal with banks and post offices and their hefty charges. I actually
prefer to receive cash, but cannot accept responsibility if it is lost in the mail.

Postage Rates

Internet email No Charge
Australia (inc. 3" or 5" disk) US$4.00
Overseas (inc. 3" or 5" disk) US$6.00

You can print the registration form included with this distribution, or if you don't have a printer, you can just write a
letter giving your name and address, and state that you are registering Icolib Version 2. Don't forget to mention what
type of disk you require if you want the source code. Send the form or letter, with your payment made out to
Stephen Balogh, to the following address:

Stephen Balogh

PO Box 414
Caulfield East
Melbourne
AUSTRALIA 3145

By registering, you support shareware development and affordable Windows Software. Your contribution will help
promote future shareware development and the development of future versions of this program. Suggestions for
improving Icolib are very welcome.

Site licenses are available with the following discounts.

2-5  licenses 20% discount. ($12 per copy)

6-20 licenses 35% discount. ($10 per copy)

21 + licenses 55% discount. ($7 per copy)
If you request the source code for the program you will still only receive one disk, so you should only include
postage and handling for a single copy. However, you are entitled to give a copy of the source code to each of the
license holders.

When you register and include postage and handling, you will receive the complete source package used in
developing this program. The package includes all C source code, resource files, and help files (in RTF format). You
are welcome to use this source code as the basis of other Windows applications, however, I would appreciate if it is
not used in direct competition with Icolib. The program was developed using Microsoft C 7.0, Microsoft Help
Compiler 3.1 and Microsoft Software Development Kit 3.1. None of the C++ features of the compiler were used.

The icons which have been distributed with Icolib were obtained mainly from the CICA Windows archive on
Internet, but some were obtained from other sources. I do not own the rights to any of these icons, but they were
obtained from publically accessible areas and reimbursements were not called for. Some collections were given to
me by friends so I don't know of their origin. If someone finds icons which they own and do not wish distributed,
please let me know and I will remove them from the next version.

Once you register, you are entitled to use and modify the source code and all associated files in any manner you



desire. I do not require further royalties or credit.

If you have access to the Internet then any questions or discussion regarding the program, can be made via email.
My Internet email address is steve@cc.monash.edu.au.



Icon Library Files
Modifying ICL Files
The only icon library files that Icolib can use are the ones with the filename suffix ICL. These files can be read by
several icon manager programs such as ICONMASTER by Phillip A. Kaufman and ICON MANAGER by Impact
Software. Unfortunately, only ICON MANAGER can create ICL format icon libraries, so in order to manipulate
icons within these libraries, you will need to obtain a copy of this shareware program. There is a copy available in
the Windows archive on the Internet ftp site called ftp.cica.indiana.edu and its mirrors. Windows BBS systems are
also quite likely to carry this program. If you wish to contact the author of ICON MANAGER, the address is:

Leonard A. Gray

Impact Software

12140 Central Avenue, Suite 133

Chino, CA 91710

Voice: (714) 590-8522

BBS: (714) 590-0500

CIS ID: [71630,1703]

Interface to Program Manager

ICL files are recognised by Windows Program Manager. In order to change the icon for an application in a
Program Manager group, perform the following steps:

- Highlight the desired program icon in one of the Program Manager groups.

- Select the Program Manager Properties... option under the File menu.

- Click on the Change Icon... button in the "Program Item Properties" dialog box.

- Enter one of the ICL files as the File Name in the "Change Icon" dialog box and then click the OK button.

- Select an icon from the "Icon Window". These icons are the ones contained in the ICL file you have just selected.

- Finally, click on the OK button in the "Program Item Properties" dialog box. The icon for the initially selected
program item will have changed to the new icon from the ICL file.

ICL File Compression
ICL files are not compressed, so it is possible to save quite a lot of disk space by compressing these files using
PKZIP or similar archiving programs. However, Icolib will not be able to read any compressed icon library file;

you need to uncompress them before using them with Icolib.

ICL files must be in the same directory as the Icolib application.



ICOLIB.INI File

The icolib.ini file is used by Icolib to generate its menu structure. This allows users to tailor the application to their
own needs. Icon categories can be added, deleted or rearranged. Library file names and menu descriptions can also
be changed by the user.

A sample icolib.ini file is described below:

[Menu_1]

Name=&Computers
Item_1=comms.icl,Communications...
Item_2=cursors.icl,Cursor Icons...

[Menu_2]

Name=&Office
Item_1=books.icl,Books...
Item_2=calc.icl,Calculators...
Item_3=cardfile.icl,Cardfiles...

Each icon category which is to appear on the Icolib menu bar must be specified as [Menu_X] where the X is a
sequential number starting with 1. The menu name that is to appear on the menu bar is then specified by the Name=
index. Placing an & before any letter will make that letter the menu Hot Key. Popup menu items are then specified
with the Item_X= indexes. Once again the X is a sequential number starting at 1. Each item must specify a filename
with an ICL suffix which names the library containing the icon collection, followed by a comma, followed by a
short description of the library as it is to appear on the popup menu item.

Icolib will only recognise changes to the icolib.ini as the program is started, so if you make any changes, you must
restart the Icolib application for the changes to take effect.

icolib.ini must be in the same directory as the Icolib application.









