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Getting Started with Adobe Photoshop 
Album Starter Edition 3.0

Welcome to the Adobe® Photoshop® Album Starter Edition 3.0 application, the fast and easy way to organize your 
lifetime of photos so that you can instantly find the ones you want and share your experiences with anyone, 
anywhere. This document will get you started using Photoshop Album Starter Edition 3.0 immediately. 

Getting photos
Photoshop Album Starter Edition 3.0 automatically detects your camera as soon as you connect it with a USB cable 
to your computer. If you’re having trouble getting photos directly into Photoshop Album Starter Edition 3.0, you can 
save the photos in a folder on your computer and then bring them into Photoshop Album Starter Edition 3.0 as 
described in “Getting photos from your computer” on page 3.

Sometimes you may try to get photos that already exist in your catalog. If this happens, Photoshop Album Starter 
Edition 3.0 displays a dialog box letting you know which photos you already have. These photos won’t be reimported.

To get photos from a digital camera or card reader:

1 Connect your camera or card reader to your computer. For instructions on connecting your device, see the 
documentation that came with it.

2 When the Adobe Photo Downloader appears, choose the name of the connected camera or card reader from the 
Get Photos From pop-up menu. Usually the connected device’s name automatically appears.

Photoshop Album Starter Edition should automatically detect your camera. If the downloader does not appear, click 
the Get Photos button  in the shortcuts bar and then choose From Camera, Mobile Phone, or Card Reader.

3 Thumbnail images of every photo on your camera’s memory card display. To remove photos from the import 
batch, click the check box (to remove the green check mark). To change the size of the thumbnails, drag the slider.

You can rotate any photo you bring in from a digital camera. Select one or more photos you want to rotate. Then click 
the Rotate Left button  or the Rotate Right button .

4 Under Save Files, accept the folder location listed, or click Browse to choose a new location for the files.

5 Under Create Subfolder Using, choose Date/Time of Import if you want the photos you’re getting to be stored in 
their own folder whose name includes the date and time they were imported, or choose New Name to create a folder 
using the name you type in the text box.

6 Select Rename Files to and enter a file name in the text box to over-write the name assigned by your digital camera. 
Each photo in the import batch will share the name, but each photo has a unique number after the name.

7 Click the Get Photos button.

The photos are brought into Photoshop Album Stater Edition and appear in the Photo Well.

Note: If at some point you no longer want the Adobe Photo Downloader to launch when you connect your camera, click 
the Adobe Photo Downloader icon  in the system tray, and then choose Disable.
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Getting photos from Nokia mobile phones

Now in Photoshop Album Starter Edition 3.0, you can get photos from camera-enabled Nokia Suite 6.5 compatible 
mobile phones with the Adobe Photo Downloader. For information on getting photos, see “Getting photos” on 
page 1.

Two important notes:

• If your mobile phone stores photos on a removable flash or memory card, you can use a card reader to transfer 
the photos to your catalog. 

• If you’re having trouble getting photos directly into Photoshop Album Starter Edition 3.0, you can save the photos 
in a folder on your computer and then bring them into Photoshop Album Starter Edition 3.0 as described in 
“Getting photos from your computer” on page 3.

You can also export photos to your Nokia phone by choosing Send to Mobile Phone from the Share button in the 
shortcuts bar.

Getting photos from CDs and DVDs
When you get photos from CDs and DVDs, you can choose whether or not to bring the photos onto the hard disk 
drive of your computer, or leave them on the CD or DVD, known as keeping them offline. A low-resolution copy, or 
proxy file, of a master photo kept offline is shown in your catalog so you can continue to view the photo in Photoshop 
Album Starter Edition 3.0. When you perform an operation that requires the original photo, you will be asked to 
insert the disc on which the offline photo is stored. You can then decide to use the proxy file, bring in the master 
photo, or cancel the procedure.

When you choose to keep a master photo offline, Photoshop Album Starter Edition 3.0 asks you to give the CD or 
DVD a reference name. The reference name you choose should be meaningful to you. It’s smart to write the reference 
name you’ve chosen on the CD or DVD or on the disc’s jewel case. When Photoshop Album Starter Edition 3.0 
requests the master disk, it will provide the reference name so you can insert the correct CD or DVD.

To get photos from a CD-ROM or DVD:

1 Do one of the following:

• Click the Get Photos button  in the shortcuts bar, and then choose From Files and Folders from the pop-up 
menu.

• Choose File > Get Photos > From Files and Folders.

2 Navigate to your CD-ROM or DVD drive.

3 Select the photos you want to import from the CD-ROM or DVD.

4 Select Keep Original Offline to add just a copy of the photo to your Photoshop Album Starter Edition 3.0 catalog. 
If this option is selected, a low-resolution copy (or proxy file) will be downloaded on your computer, and Photoshop 
Album Starter Edition 3.0 will reference it from that location. To download the master photo, leave this option 
deselected.

5 If you’re keeping a master photo offline, type in a Reference name for the CD or DVD that will make it easy for 
you to identify the disc in case Photoshop Album Starter Edition 3.0 requests it at a later time. It’s also a good idea 
to write the reference name on the disc or its case.

6 Click Get Photos. Your photos are brought in to Photoshop Album Starter Edition 3.0.

Note: An offline photo has the CD icon  in its thumbnail. Its file location references the drive from which the CD was 
inserted.
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Getting photos from your computer 
When you import photos from your computer’s hard drive, Photoshop Album Starter Edition 3.0 creates a link to 
the location of the photos. The original photo files remain protected in their locations on your computer. If you move 
a file, Photoshop Album Starter Edition 3.0 might not be able to find the photo until you reconnect it from its new 
location. If you need to move photo files after importing them into Photoshop Album Starter Edition 3.0, it’s best to 
use the Reconnect All Missing Files command on the File menu.

To get photos from your computer:

1 Do one of the following:

• Click the Get Photos button  in the shortcuts bar and then choose From Files and Folders from the pop-up 
menu.

• Choose File > Get Photos > From Files and Folders.

2 Click the triangle icon on the right side of the Look In menu and choose a location on your computer to bring up 
the contents of a folder.

3 Move the pointer over a file or folder. In the case of a file, Photoshop Album Starter Edition 3.0 displays infor-
mation about the photo. Selecting a file displays a preview. Then do one of the following:

• To get a single photo, select it and then click Get Photos. 

• To get multiple photos, select the first file you want to import, hold down Shift, and select the last file you want to 
import (all the files in between are selected). Alternately, hold down the Ctrl key and select additional files (only 
the files you click are selected). When you’re done selecting photos, click Get Photos.

• To get all the photos in a folder, navigate to the location of the folder and select it. Then click Get Photos. 

• If you want to get photos stored in multiple subfolders, navigate to the location of the main folder and select it. 
Select Get Photos from Subfolders, and then click Get Photos.

To drag photos from other applications:

1 Make sure that Photoshop Album Starter Edition 3.0 is open.

2 In your image-editing application, select the photo you want and then drag it into the Photo Well.

3 The Getting Photos dialog box appears, with a preview of the photo you just brought into Photoshop Album 
Starter Edition 3.0. The photo appears by itself in the Photo Well.

Note: Not all image-editing software will allow you to drag photos into Photoshop Album Starter Edition 3.0.

Searching for files on your computer 
Often photos are scattered about in many different locations on your computer. Photoshop Album Starter 
Edition 3.0 makes it easy to import photos by searching for all the photos and video clips on your computer and then 
letting you choose which ones you want to import. Removable media (CDs, DVDs) and network drives (if your 
computer is attached to a network) are not searched.

To search for files:

1 Choose File > Get Photos > By Searching. 
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2 Select a search option from the Look In drop-down menu: 

• All Hard Disks to find all of the photos on your computer (deselect this option if you want to target your search 
more closely). All installed hard disk drives on your PC will be searched, so the search may take a while.

• C Drive to search the main hard disk drive in your computer.

• My Documents to search for all photos in that folder and its subfolders.

• Browse to look for a specific folder.

3 Limit your search:

• Select Exclude System and Program Folders to exclude these directories from the search, since they are unlikely to 
contain your photos.

• Select Exclude Files Smaller Than to only include files large enough to be your full-resolution photos. Then enter 
a minimum file size in kilobytes in the KB text box.

4 Click Search.The search may take a while. Click Cancel if you want to stop the search.

5 When the search is complete, the lower area of the dialog box lists all the folders that were found to contain photos 
and video clips.

6 Click a folder to select it. To select more than one folder, press the Ctrl key and click on another folder name. You 
can preview the items in a folder by clicking the folder name in the list.

7 When you’re done selecting or deselecting folders in the list, click the Import Folders button.

Viewing your photos in the Photo Well
Once your photos are in Photoshop Album Starter Edition 3.0, they appear in the Photo Well as thumbnail images. 
You can adjust the appearance of the thumbnails by dragging the slider below the Photo Well.

Photoshop Album Starter Edition 3.0 also gives you different ways to sort your catalog in the Photo Well. In the 
options bar, you can choose from the following sort options in the Sort pop-up menu: 

• Date (Newest First) to show the most recently taken or imported photos first. (Within a given day, the photos are 
still shown in the order they were taken, oldest-first). Newest-first order is convenient when you need to attach 
tags to the photos you imported most recently.

• Date (Oldest First) to show all the photos in chronological order.

• Import Batch to display photos in the batches in which they were imported. Each batch is separated by a bar that 
displays information about the way you got the photos. 

• Folder Location to display photos by the folders in which they are stored.

Above the Photo Well is the Timeline. It helps you view and find photos by date. The height of each bar in the 
timeline shows the number of photos in each month, import batch, or folder. You can select a range of photos to 
view by clicking a bar or dragging the endpoints of the timeline.

In the options bar just under the Photo Well are controls for viewing photos and their properties. Among the controls 
is a Full Screen Slideshow  button that instantly displays a slideshow of the photos you’ve selected in the Photo 
Well.
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Viewing photos in a full screen slideshow

Full Screen Slideshow provides a full screen view of a set of photos (and video clips) as a slide show, making it a fun 
and efficient way to move through a set of photos. A control bar (which fades out when the pointer is not on it), gives 
you the ability to click through the photos, rotate a photo, apply Auto Smart Fix, or delete a photo. You can mark the 
best photos for printing.

To view photos in Full Screen Slideshow:

1 Select the photos you want to review by doing one of the following:

• In the Photo Well, select the photos.

• In the Calendar View, select a date. All of the photos in the selected day will be displayed in Full Screen.

2 Click the Full Screen Slideshow button  below the thumbnails or choose View > Full Screen Slideshow.

3 Do any of the following:

• To navigate through the photos or view them in a slide show, use the slide show controls. You can also use the left 
arrow key  and right arrow key  to move to the previous or next photo.

• To control the image zoom in Full Screen Slideshow, click Zoom In , Zoom Out , Fit in Window , or 
Actual Size .

• To rotate a photo, click Rotate 90 Degrees Left , or click the Rotate 90 Degrees Right . 

• To delete a photo from the image catalog, click Delete . You can choose whether or not to delete the image from 
the hard drive.

• To apply Auto Smart Fix to a photo, click Auto Smart Fix .

• Click Mark for Printing  if you’d like to print the photo once you’re done in Full Screen. A dialog box appears 
after you close Full Screen Slideshow that lets you print the photos at home, or send the photos to an online 
printer.

• To close Full Screen Slideshow, press the Escape key or click the Exit button .

Viewing video clips

You can view video clips in your catalog using Photoshop Album Starter Edition 3.0.

To view video clips:

In the Photo Well, the first frame of a video clip appears in its thumbnail. The filmstrip icon  identifies a video clip 
in the Photo Well.

1 Double-click the video clip in the Photo Well. 

2 When the video screen appears, click the Play button to start the video. You can click the Pause or Stop buttons 
during the viewing to interrupt or stop the video.

You can drag the position slider through a video clip to view it frame by frame. If you have a long video clip, it may 
jump over a few frames.

3 When you’re finished, click the close button .
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Viewing your photos in the Calendar View

In the Calendar View, you can browse through your photos chronologically or find photos from a particular day, 
month, or year. When you’ve found the day you’re looking for, you can view that day’s photos as a mini-slideshow. 
To switch to the Calendar View, click the Calendar View button  in the shortcuts bar.

To view and find photos in the Calendar View:

1 Click the Calendar View button  in the shortcuts bar. 

2 Navigate to the month and day you want to view by doing one of the following:

• Click the left arrow button  and right arrow button  to go forward or backward. Hold down the arrow 
buttons to move forward more rapidly.

• Click the name of the year to display a list of years from which you can choose. The icon next to the year indicates 
that the year contains photos.

• Click the name of the month to display a list of months from which you can choose. The icon next to the month 
name indicates that the month contains photos.

3 If there is more than one photo in the day, do any of the following:

• To view a photo, click its thumbnail.

• To view all the photos for the selected day as a slideshow in the Calendar View, click the Play button .

• Click the Full Screen Slideshow button  to view the photos for the selected day in full screen (see “Viewing 
photos in a full screen slideshow” on page 5).

4 If you see a photo you want to find in the Photo Well, click the Show in Photo Well button  under the photo. 

Organizing your photos with tags
Photoshop Album Starter Edition 3.0 automatically organizes your photos in the Photo Well based on when they 
were taken. However, you can enhance the organization, sorting, previewing, and finding of photos by using tags. 

Tags are like keywords that you can attach to your photos, video clips, and audio clips. They don’t change the items 
to which they’re attached. They simply give you additional and more flexible ways of finding and organizing them. 

Tags also free you from having to file your items in folders by subject or renaming files. For example, you can create 
a tag called “Dad” and attach it to every photo featuring your father, and then instantly find all photos with that tag, 
regardless of where the photos are stored on your system. 

Moreover, you can attach more than one tag to an item. For instance, you might have tags with the names of 
individual people, places, and events in your life. By attaching multiple tags to your photos, you could search for 
these tags to find a particular person at a particular place and event.

You create and work with tags with the Tags pane of the Photo Well. By default, there are four categories of tags in 
the Tags pane: People, Places, Events, and Other. You can organize tags under these categories, as well as create your 
own categories and multiple levels of subcategories. In addition, two special kinds of tags are displayed at the top of 
the Tags pane:

• Favorites. Photos with the Favorites tag have a star icon attached to them to make it easy to quickly find your 
favorite photos.

• Hidden. Items with a Hidden tag attached don’t appear in the Photo Well unless you specifically select the Hidden 
tag as one of the search criteria. You might apply a Hidden tag to items that you want to keep but generally don’t 
want to see.
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To open the Tag pane:

To use tags, you first need to open the Tag pane. Attach one or more tags from the Tag pane to a photo in the Photo 
Well by dragging and dropping them onto the photo. Tags don’t change the photos they are attached to; they simply 
give you additional and more flexible ways of finding and organizing your photos. 

1 If the Tags tab is not already displayed, click Organize  in the shortcuts bar at the top right of the Photo Well.

2 Click the Tags tab.

3 Display the tags:

• Use the scroll bar to scroll up and down the list of tags, as needed.

• Click the triangle next to a category or subcategory to display the tags under it.

• Choose View > Expand All Tags or View > Collapse All Tags from the menu bar.

To create your own tag:

1 Click the New button  in the Tag pane and choose New Tag.

2 In the Create Tag dialog box, use the Category menu to choose which category or subcategory you want to list the 
tag under.

3 In the Name text box, type the name you want to give the tag.

4 In the Note text box, type any information you want to add about the tag. (For example, you could write that 
Mildred is your mom’s elementary school friend who lives in New York.)

5 Click OK.

The tag appears in the Tag pane under the category or subcategory you selected.

Notice that the tag has a question mark icon . The first time you attach the tag to a photo, it will use that photo 
as its icon. You can change the icon to a different photo. 

To attach a tag to a photo:

Drag the tag from the Tag pane onto the photo in the Photo Well.

To find photos by their tags:

In the Tags pane of the Photo Well, do one of the following:

• Double-click a tag.

• Click the box next to one or more tags.

• Drag the tag(s) from the Tags pane to the find bar near the top of the Photo Well.

The application finds all photos that have any of those tags attached. If you select a category or subcategory of tag 
that has nested subcategories, the application displays all photos in the hierarchy. For instance, suppose the Wedding 
tag has two subcategories: Bride and Groom. If you search for all photos with the Wedding tag, all photos with the 
Bride and Groom tags are displayed as well.

To attach tags to multiple photos:

1 In the Photo Well, select one or more photos.

2 Do one of the following:

• Drag the tag from the Tags pane onto any of the selected photos.



8ADOBE PHOTOSHOP ALBUM STARTER EDITION 3.0

 ReadMe

• Select one or more tags. Then drag the tags onto any of the selected photos.

• Select one or more tags. Then drag the photos onto any of the selected tags in the Tags pane.

The tags are attached to all of the selected photos. If this is the first time you have attached the tag to a photo, the 
photo becomes the icon for that tag. If you selected multiple photos and dragged them onto a tag, the first selected 
photo becomes the icon for the tag. You can change the icon as part of editing a tag.

To apply a tag to the photos in a collection, double-click the collection in the Collections pane. Then click the Tags tab 
to display the Tags pane. Select all of the photos in the Photo Well, and attach the tag to them. 

To remove tags from photos:

Depending on the view in the Photo Well, do one of the following:

• Right-click the photo and choose Remove Tag. 

• In larger views, you can right-click a category icon associated with the photo and choose Remove <name> Tag.

Depending on your view, you can hold the pointer over the category icon to display a list of tags attached to the photo.

• Select the photos. Then right-click one of the selected photos and choose Remove Tag From Selected Items, 
followed by the tag name.

To create and attach tags based on folders

If you have folders of similar photos, you can tag the photos all at once by viewing the photos by their folder location.

1 In the Photo Well, choose View > Arrangement > Folder Location. 

The Photo Well displays photos according to which folder they are in, with the folder’s full path listed above the 
photos it contains.

2 Scroll up or down until you see the folders and photos you want. 

3 Click the separator bar that lists the folder’s path to select all the photos in that folder.

4 Click the New button  in the Tag pane and choose New Tag. 

5 In the Name text box, type a name for the tag, and choose a category.

6 Click OK.

7 Drag the new tag onto the selected photos.

Organizing your photos with collections
A collection is a container that you put photos into. Using the Photo Well, you can drag and drop the photos in a 
collection into a custom order. A number then appears for each photo indicating its position in the order. Unlike 
tags, you can customize the order in which photos in collections appear.

For example, suppose you have photos from your vacation. You could create a collection called “Ten Best Vacation 
Photos,” put your ten favorite photos from that trip into that collection, and organize the photos from tenth best 
photo to best photo. You could then show the collection in Full Screen based on that collection.

A photo can be in more than one collection. For instance, the same photo might appear as the first photo in one 
collection and the last one in another.
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The Collections pane displays all of the collections and collection groups, as well as commands for creating, 
renaming, and deleting them. You can also use the pane to organize collections within collection groups.

To use the Collections pane:

1 If the Collections tab is not already displayed, click Organize  in the shortcuts bar at the top right of the 
Photo Well.

2 Click the Collections tab.

3 Click Back To All Photos if it appears in the find bar, to turn off the search criteria in the Photo Well.

4 Display the collections. Use the scroll bar to scroll up and down the list of collections, as needed.

To create a collection:

1 If the Collections tab is not already displayed, click Organize  in the shortcuts bar at the top right of the 
Photo Well.

2 Click the New button  in the Collections pane of the Photo Well, and choose New Collection.

3 In the Name text box, type a name for the collection.

4 In the Note text box, type any information you want to add about the collection. (For example, you could write 
that the collection represents your garden.)

5 Click OK.

The collection appears in the Collections pane under the collection group you selected.

Notice that the collection has a question mark icon . The first time you put a photo into a collection, it will use 
that photo as its icon. You can later change the icon.

To add photos to a collection:

1 In the Photo Well, do one of the following:

• Select a photo by clicking on it.

• Select multiple photos by holding down the Ctrl key and clicking each photo.

2 Do one of the following:

• Drag the selected photo or photos into the collection in the Collections pane.

• Drag the collection icon onto the selected photos.

The photo is now part of that collection. If this is the first photo you put in that collection, the photo becomes the 
collection icon.

To display photos in a collection:

Because items in a collection are displayed in a custom order, and the same item might be in multiple collections, 
you can view only one collection at a time.

In the Collections pane, do one of the following:

• Double-click a collection.

• Click the box next to the collection.

• Drag the collection from the Collections pane to the find bar near the top of the Photo Well.

To view all of the photos in the Photo Well, click Show All.
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To see which collections a photo is in, hold the mouse pointer over the collection icon  under the photo in the Photo 
Well or use the Properties palette.

To remove photos from a collection:

1 In the Photo Well, select the photos you want to remove from a collection.

2 Do one of the following:

• Right-click the photo and choose Remove (Selected Items) From Collection, followed by the collection name.

• If the collection icon associated with the photo is visible, right-click a collection icon  and choose Remove From 
Collection.

To delete a collection:

Deleting a collection removes the collection, but not the photos in the collection. 

1 Select one or more collections and collection groups in the Collections pane of the Photo Well. 

2 Click the Delete button  in the Collections pane.

Important: Do not press Delete on your keyboard. The application will delete any selected photos, rather than the 
collection.

To change the order of items in a collection:

When you change the order of items in a collection, you change the viewing order.

1 Select the collection in the Collections pane of the Photo Well.

2 Select the items that you want to move.

3 Drag the photos to their new location within the collection.

4 To reset the order of items to oldest first, right-click the collections and choose Reorder <name> Collection By 
Date (Oldest First).

To attach tags to photos in a collection:

1 In the Photo Well, select the collection in the Collections pane to display the photos in that collection.

2 Click the Tags tab to display the Tags pane.

3 Choose Edit > Select All to select all the items in the Photo Well.

4 Select and attach the tags to the photos.

Finding your photos
It’s easy to find photos in Photoshop Album Starter Edition 3.0. Tags give you a quick way to find photos and other 
files. When you use tags to find photos and media files, the find bar expands to show you the tags you’ve selected. 
Searches begin as soon as you select the tags in the Tags pane. You can also use collections to find photos.

Photoshop Album Starter Edition 3.0 automatically organizes your photos in the Timeline of the Photo Well. From 
the Timeline, you can view and find photos and media even if they are not tagged. The Timeline is divided into years 
and months. You can jump to a particular month in any year by clicking that month in the Timeline. The Photo Well 
then displays photos and media files for that month. When you hold the mouse pointer over a bar in the Timeline, 
the name of the corresponding month appears. You can also select a range of time in the Timeline to display photos 
taken or scanned within that range.
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To find photos using tags:

1 In the Photo Well, do any of the following:

• In the Tags pane, click the square next to the name of the tag so that the binoculars icon  appears. (If you change 
your mind, click the binoculars icon to cancel the search.) 

• Drag a tag onto the find bar. The tag appears in the find bar to remind you of the tag you searched for. 

• In the Tags pane, right-click a tag and choose New Search Using Name of Tag(s) from the context menu.

2 To refine your search by adding more search criteria, do one of the following: 

• Click the squares next to multiple tags.

• Drag more tags onto the find bar. 

• Right-click a tag, category or subcategory and choose Add Name of Tag, Category, or Subcategory To Search 
Criteria.

Photoshop Album Starter Edition 3.0 finds photos that have all those tags attached. If no photo matches all the tags 
in your search criteria, the Photo Well displays closely matching photos containing a subset of the tags.

3 To cancel your search, do one of the following:

• Click the Back to All Photos button to show your catalog.

• In the Tags pane, right-click a tag and choose New Search Using Name of Tag, Category or Subcategory.

• In the Tags pane, right-click a tag and choose the Exclude Photos with Name of Tag, Category or Subcategory to 
remove the tag as a search criteria.

To find photos in a collection:

In the Photo Well, do one of the following:

• In the Collections pane, click the square next to the name of the collection or double-click the collection icon to 
search for photos in that collection. The binoculars icon  appears in the square next to the name of the 
collection. (If you change your mind, click the binoculars icon to cancel the search.)

• Right-click a collection icon and choose Find Items in name of collection from the context menu.

To cancel the search and show your catalog, click the Back To All Photos button or right-click the collection icon in 
the find bar and choose Remove name of collection From Search Results from the context menu.

To view and find photos using the Timeline:

In the Timeline, you can view and find photos and other items by date, import batch, or file location, depending on 
the setting you choose in the Photo Well Arrangement menu. Depending on your choice in the Arrangement menu, 
the height of each bar is proportional to the number of files in each month, the number of files you imported 
together (or in a batch), or the number of files in each folder. 

1 Choose an option from the Photo Well Arrangement menu.

2 (Optional) Use the arrows   at ends of the Timeline to navigate to the part of the Timeline that you want 
to search.

3 Do one of the following:

• Drag the Timeline endpoint markers to view a range of time.

• Choose Find > Set Date Range. Type both a start date and end date to specify the range you want to view. Click OK.
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Photoshop Album Starter Edition 3.0 adjusts the date range selection in the Timeline and displays photos within that 
range in the Photo Well. You can always drag the endpoint markers to refine your date range.

Fixing photos in Photoshop Album Starter Edition 3.0
The photos you bring into Photoshop Album Starter Edition 3.0 may not be perfect. They may need to be rotated, 
cropped, lightened, sharpened, or otherwise adjusted. Photoshop Album Starter Edition 3.0 provides a variety of 
ways to fix your photos. 

Rotating photos

Rotating photos is probably the most common type of editing you’ll perform in Photoshop Album Starter 
Edition 3.0. For example, you may have turned your digital camera sideways to take a photo of a person and now 
need to turn the resulting photo so that the person is right-side-up again.

The first opportunity you’ll have to rotate a photo is in the Adobe Photo Downloader. After a photo is in Photoshop 
Album Starter Edition, you can rotate a photo directly in the Photo Well. You can also rotate photos in the Fix Photo 
Window (see “Using the Fix Photo Window” on page 12).

To rotate photos in the Photo Well:

1 Select one or more photos you want to rotate. 

2 Rotate the photo:

• Click the Rotate Left button  or the Rotate Right button  in the options bar.

• Right-Click, and then choose Rotate Right or Rotate Left from the context menu.

• If you selected one photo, choose Edit > Rotate Right or Rotate Left. You can also right-click and choose Rotate 
Right or Rotate Left. 

• If you selected multiple photos, choose Edit > Rotate Selected Photos Right or Rotate Selected Photos Left. You 
can also right-click and choose Rotate Selected Photos Right or Rotate Selected Photos Left.

Using Auto Smart Fix

Auto Smart Fix automatically identifies and fixes problems in a photo. It repairs color problems and balances out 
shadows and highlights to improve the overall quality of the photo. It’s the quickest way to fix photos. Auto Smart 
Fix is available in the Photo Well and the Calendar View. You can also apply Auto Smart Fix in Full Screen Slideshow.

To access Auto Smart Fix:

You can find Auto Smart Fix in the following places:

• In the Photo Well or the Calendar View, choose Edit > Auto Smart Fix.

• In Full Screen Slideshow, click Auto Smart Fix  in the menu bar.

The adjustment is automatically applied.

Using the Fix Photo Window

The Fix Photo dialog box lets you make a variety of adjustments to a photo, all within a single dialog box. It provides 
“before” and “after” previews of the photo being fixed as well as controls for zooming in on and zooming out from 
the preview, and undoing changes.



13ADOBE PHOTOSHOP ALBUM STARTER EDITION 3.0

 ReadMe

The tabs at the top of the Fix Photo Window let you compare different views of the photo you’re working with: 

Original Shows how the photo looked with you opened the Fix Photo Window.

Before This tab shows how the photo looked before you applied correction. 

After This tab shows the photo with all the changes you’ve made since opening the Fix Photo Window. 

Before & After This tab displays the Original or Before version of the photo on one side of the dialog box and the 
After version on the other, for comparison. If you’ve edited the photo before, two options appear below the photo. 
Selecting Original shows how the photo looked when it was first brought into Photoshop Album Starter Edition 3.0. 
Selecting Before shows how the edited photo looked when you opened the Fix Photo Window, before you’ve applied 
any changes.

Note: This tab is the only place you can view the original once you edit the photo, other than by reverting to it. The original 
photo is kept on your system, but is not displayed in the Photo Well or the Calendar View if you have edited it since then.

When you fix a photo, Photoshop Album Starter Edition 3.0 alerts you that you are editing an original photo, but 
that the edits are made to a copy of the photo. The original photo is not changed.

To open the Fix Photo dialog box:

1 Select a photo in the Photo Well. 

2 Call up the Fix Photo Window:

• Click the Fix button  in the shortcuts bar, and choose Fix Photo Window.

• Choose Edit > Fix Photo Window. 

3 Do any of the following:

General Applies automatic corrections for color, levels (overall image appearance), contrast, or sharpening. Click a 
button to apply a fix to a photo. If you’re not happy with the adjustment, click Undo.

Crop Lets you crop a photo to improve the composition or add emphasis to an image. Cropping a photo also 
decreases its file size, making it easier to e-mail to friends and family. Drag the edges of the crop border until 
surrounds the area of the photo you want to keep.

Red Eye Corrects for the red-eye effect caused by a camera flash. Click the red eye to return it to a natural color.

Rotate Left/ Rotate Right Under the preview window, click either the Rotate Left icon or the Rotate Right icon to 
rotate the photo 90 degrees.

The Fix Photo Window can be resized. You may find it best to maximize it so the photo you’re editing is as large as 
possible.

Creating a PDF slideshow
PDF slideshows automatically present your photos in the sequence you specify. Slideshows are a good way to share 
your photos via e-mail and view them on a computer screen. 

PDF is a universal file format that can be read by anyone who has the free Adobe Reader software. PDF provides a 
better photo-viewing experience for your recipients by packaging up all the individual photos into a slideshow, 

complete with transitions. Your recipients can download the free Adobe Reader from the Adobe Web site 
(http://www.adobe.com).
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To create a PDF slideshow:

1 In the Photo Well, select the photos you want to use in the slideshow. If you don’t make a selection, all the photos 
in the Photo Well will be used in the slideshow.

2 Click the Create button  in the shortcuts bar.

3 In the Create PDF Slideshow dialog box, rearrange, duplicate, or remove photos as desired.

4 Click OK and follow the on-screen instruction to save and view your PDF slideshow.

Editing video from your mobile phone
You can edit MPEG-4 (.mp4) and 3GPP (.3gp) formatted videos captured with your mobile phone with the Edit 
Mobile Movie feature. Using the Edit Mobile Movie dialog box, you can trim the video, copy and paste sections of 
the video, select portions of video by setting In and Out points, and play back a selection in a continuous loop.

You can view the video in the video player or you can view individual frames in the timeline. Directly above the Play 
button is the timecode reading, which displays the time as hours:minutes:seconds:frames. You can use this timecode 
to navigate to specific frames in the video.

To view video in the Edit Mobile Movie dialog box:

1 Select a supported video file in the Photo Well and choose Edit > Edit Mobile Movie.

2 In the Edit Mobile Movie dialog box, do any of the following:

• To play the video, click the Play button  or choose Player > Play.

• To move to the beginning of the video, click the Start button  or choose Player > Go To Beginning.

• To move to the end of the video, click the End button  or choose Player > Go To End.

• To fast forward, choose Player > Fast Forward.

• To fast rewind, choose Player > Fast Backward.

• To manually navigate through the video, drag the blue current-time indicator  along the timeline.

• To view the individual video frames, drag the scrollbar along the bottom of the timeline.

• To zoom in or out (to view more or fewer frames in the timeline), drag the zoom slider  to the right or left, 
or choose a zoom setting from the Zoom menu. 

To select a portion of the video:

You need to select portions of video before you can copy, cut, or trim the video. When setting the Out point for your 
selection, you may need to either use the scroll bar under the video track, or drag the zoom slider to the left so that 
you can see the last frame of video and the Out marker. The selected area is indicated by a blue bar in the timeline.

1 In the Edit Mobile Video Editor, do the following:

• To set the In point of the selection, drag the blue current-time indicator to where you want the selection to begin, 
and click the Set Mark In button  or choose Player > Set Mark In. (You can also Shift-click in the timeline 
where you want the In point.

• To set the Out point, drag the blue current-time marker to where you want the selection to end and click the Set 
Mark In button  or choose Player > Set Mark Out. Ctrl-click in the timeline where you want the Out point.

• To adjust the In or Out points, drag the In  or Out  selection markers.
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If you want to mark an In or Out point at a specific point in time, refer to the timecode located directly above the Play 
button.

To play or loop a selection:

You can play or loop the entire video, or a selected portion of video.

1 In the Edit Mobile Movie dialog box, set In and Out points to mark a selection. (If you want to loop the entire 
movie, you don’t need to set these points.)

2 Do one of the following:

• To play the selection, choose Player > Play Selection Only (a check mark appears by the command).

• To play the selection in a continuous loop, choose Player > Play Selection Only (a check mark appears by the 
command), and then choose Player > Loop Selection.

3 Click the Play button .

To trim video:

The Trim command removes the video surrounding a selection. 

1 In the Edit Mobile Movie dialog box, set In and Out points to select the portion of video you want to keep. For 
example, to trim the first second of the video, drag the In selection marker to the right until the timecode under the 
video player reads 00:00:01.00.

2 Click the Trim Selection button  or choose Edit > Trim. The first second of the video is removed.

3 To save the trimmed video, choose File > Save.

To cut, copy, delete, or paste a portion of video:

The Cut, Copy, and Delete commands remove or copy selected video.

1 In the Edit Mobile Movie dialog box, set In and Out points to select the portion of video you want to cut or copy.

2 Do one of the following:

3 To copy the selection, click the Copy Selection button  or choose Edit > Copy.

4 To cut the selection, click the Cut Selection button  or choose Edit > Cut.

5 To delete the selection, click the Delete Selected button  or choose Edit > Delete.

6 To paste the selection, move the current time maker to the point where you want the selection to appear, and click 
the Paste button  or choose Edit > Paste.

7 To save the video, choose File > Save.

Sharing photos using e-mail
Photoshop Album Starter Edition 3.0 does all the work of creating attachments for e-mail by generating a 
preaddressed e-mail message with attached images or PDF slideshows. Before you start e-mailing, you need to set 
e-mail preferences (see “Setting e-mail preferences” on page 15).

Setting e-mail preferences

Before you e-mail photos for the first time, you must give Photoshop Album Starter Edition 3.0 a little information. 

Note: If you use more than one e-mail program, you’ll need to reset this option each time you want to switch programs.
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To get set up for e-mailing:

1 Choose Edit > Preferences.

2 Select E-mail from the list of preferences at the left side of the dialog box.

3 From the Send E-Mail Using pop-up menu, select your preferred e-mail program.

4 Select a size from the Presets For pop-up menu to select a resolution for attached photos:

• Big to send a high-quality photo. The file size will be larger, but the resolution of the photo will be good, so the 
printed photo will look great. Big is the best choice even for on-screen viewing if you want the recipient to have 
the best viewing experience, or if download speed isn't a big concern (if you and the recipient have a high-speed 
Internet connection).

• Medium to send a good-quality photo. The file size of individual photos will be about average, making this a good 
selection if you want to send photos without losing a lot of detail. Medium is the setting that works well for most 
photos.

• Small to send photos with small file sizes. When you decrease the file size, your photos will lose quality, which will 
be most noticeable in photos with large file sizes. Small is recommended only when your priority is to minimize 
file size. Small photos generally don’t print well.

• Leave As Is to keep the settings of the photo. If you choose this option, you won’t be able to use the settings under 
Size and Quality. Choose this option if you want the recipient to be able to produce the best-quality prints.

A file with higher resolution keeps more detail, so it’s a good idea to set the resolution at the highest practical level for 
the way you’re going to share your photo. As you lower the resolution, the details in your photo will be lost.

5 Though there are standard sizes provided for Small, Medium, and Large, you can change the definitions of these 
three sizes if you’d like. From the Maximum Photo Size pop-up menu, choose a maximum width and height for the 
attached photo. Keep in mind that the size of the attached photo affects how quickly the e-mail will download. 

Note: The setting you specify here will become the default, but you can always change the size setting for each individual 
e-mail. Furthermore, the pixel dimensions you choose are only maximums; when a photo is compressed to fit these dimen-
sions, its original ratio of width to height is preserved.

6 Drag the Quality slider to the left to export a smaller, less detailed file, or to the right for a larger, more detailed file.

7 Click OK to save the e-mail settings and return to the main Photoshop Album Starter Edition 3.0 window.

Note: If you use Web-based e-mail, Photoshop Album Starter Edition 3.0 may not be able to automatically create e-mail 
messages and attach files, but it will still create the attachments for you. You’ll need to manually attach the file that 
Photoshop Album Starter Edition 3.0 produces to your e-mail message.

E-mailing your photos

When you want to share your photos with friends and family, you can quickly attach images to an e-mail message 
with the click of a button. If your photos have tags attached, you can include the tags with your attachments, and 
recipients with Photoshop Album Starter Edition 3.0 can import the tags into their own catalogs when they import 
the photos.

To e-mail photos:

1 Select one or more photos in the Photo Well.

2 Click the Share button  in the shortcuts bar, and then choose E-mail from the pop-up menu. Follow the 
on-screen instructions to choose recipients and specify a format for the attachment. 
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Photoshop Album Starter Edition 3.0 automatically resizes and compresses your photos for a smoother e-mail 
delivery. You can also package up multiple photos into a slideshow by clicking the PDF Slideshow button in the 
E-mail window. Photoshop Album Starter Edition 3.0 generates the attachment and then launches your default 
e-mail program. 

Printing photos at home
Photoshop Album Starter Edition 3.0 provides several options for printing your photos on your home printer (you 
can also select a video clip for printing, but only the first frame of it is printed). You can print individual photos, 
contact sheets (thumbnails of each selected photo), or picture packages (a page of a photo printed at various sizes). 

If you’re having trouble getting your photos to print at a particular size, try cropping the photo to the specific 
dimensions you want before you print it. See “Fixing photos in Photoshop Album Starter Edition 3.0” on page 12 for 

directions.

Use the Print Photos dialog box to choose options for your printed photos. The left side of the dialog box shows the 
selected photos, and the right side shows a preview of each page of the print job. When you change a print option, 
Photoshop Album Starter Edition 3.0 updates the preview. This may take a few seconds, depending on how many 
photos you’re printing.

Printing individual photos

If you want individual prints, all you have to do is specify a print size, and Photoshop Album Starter Edition 3.0 
combines as many photos as will fit on one sheet of paper. It’s important to pick a print size that’s compatible with 
the photo’s size. If you choose a print size that will cause the output to be printed at less than 150 dpi, an alert will 
appear so you can change the print size. Before you print, make sure that you have the printer set up properly (choose 
File > Page Setup to set options).

To print individual photos:

1 Make sure that your printer is on and connected to your computer.

2 Select one or more photos or video clips you want to print. If you select a video clip, only the first frame is printed.

3 Do one of the following:

• Click the Print button  in the shortcuts bar and choose Print from the pop-up menu.

• Choose File > Print.

The Print Photos dialog box appears. The left side of the dialog box shows the selected photo(s). If you change a print 
option, Photoshop Album Starter Edition 3.0 updates the preview. This may take a few seconds, depending on how 
many photos you’re printing.

4 Under Layout, select Individual Prints (if it’s not already selected).

5 Under Individual Print Format, do one of the following:

• Choose a preset size from the list. If more than one copy of the selected photo or photos will fit on the page, the 
preview shows the layout of the photos. If only one print will fit on a page, you can scroll through the pages using 
the Forward button  and the Backward button  below the preview at the right side of the dialog box.

• Choose Fit on Page to scale the image to fill the page. Note that if the size of the photo is small, or if it has low 
resolution, this option may not give you good-quality printed output.

• Choose Custom Size to enter a specific size.
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Note: Photoshop Album Starter Edition may rotate your photos to maximize the number of prints on each page.

6 If you want to print one photo per page, rather than printing as many photos as will fit on each page, select Print 
Single Photo Per Page.

7 Leave Crop to Match Print Proportions selected if you want the photo cropped automatically to fill the entire 
space. Deselect this option if you don’t want your photos cropped.

8 Specify how many copies of each photo you want by typing a value in the Use each Photo text box or by clicking 
the up or down arrows next to it.

9 To preview each page of the print job, click the Forward button  and Backward button  below the page 
preview. It may take Photoshop Album Starter Edition 3.0 a few seconds to update the preview.

10 When you’re done setting options and previewing the print job, click Print. 

Printing a picture package

A picture package prints each selected photo in a variety of sizes, similar to portraits purchased from a professional 
photographer. All you need to do is select the layout you want, and then Photoshop Album Starter Edition 3.0 fills 
the page. Each photo you select is printed on its own page (you can’t mix and match photos on one page). You can 
look at each page using the Forward button  and Backward button  below the preview.

To print a picture package:

1 Make sure that your printer is on and connected to your computer.

2 Select one or more photos or video clips you want to print.

Note: If you select a video clip, only the first frame of the clip will be printed.

3 Do one of the following:

• Click the Print button  in the shortcuts bar and choose Print from the pop-up menu.

• Choose File > Print.

The Print Selected Photos dialog box appears. The left side of the dialog box shows the selected photos, and the right 
side of the dialog box shows a preview of each page in the print job. When you change a print option, Photoshop 
Album Starter Edition 3.0 updates the preview. This may take a few seconds, depending on how many photos you’re 
printing.

4 Under Layout, select Picture Package.

5 Select a picture package format from the Layout pop-up menu. Only layouts appropriate for the paper size 
selected in Page Setup will appear. 

6 Each selected photo prints on its own page. To preview each page of the print job, click the Forward and Backward 
buttons below the preview. It may take Photoshop Album Starter Edition 3.0 a few seconds to update the preview.

7 When you’re done setting options and previewing the print job, click Print.

Printing a contact sheet

A contact sheet shows thumbnails of each photo you select in the Photo Well. You can choose to print captions, 
filenames, dates, and page numbers. Printing a contact sheet is useful for creating a printed copy of your catalog.
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To print a contact sheet:

1 Make sure that your printer is on and connected to your computer.

2 Select one or more photos or video clips you want to print.

3 Do one of the following:

• Click the Print button  in the shortcuts bar and choose Print from the pop-up menu.

• Choose File > Print.

The Print Selected Photos dialog box appears. The left side of the dialog box shows the selected photos, and the right 
side of the dialog box shows a preview of each page in the print job. When you change a print option, Photoshop 
Album Starter Edition 3.0 updates the preview. This may take a few seconds, depending on how many photos you’re 
printing.

4 Under Layout, select Contact Sheet.

5 Type the number of columns you want in the Columns text box.

6 Select or deselect other page format options:

Captions: Prints any notations you attached to the photo.

Filename: Labels the thumbnails using their source image filenames. 

Date: Prints the date the photo was taken or imported.

7 Select Show Page Numbers to print page numbers at the bottom of each page (if your contact sheet is more than 
one page long).

8 To preview each page of the print job, click the Forward button  or the Backward button  below the page 
preview. It may take Photoshop Album Starter Edition 3.0 a few seconds to update the preview.

9 When you’re done setting options and previewing the print job, click Print. 

Communicating with Photoshop Album Starter Edition 3.0
Photoshop Album Starter Edition 3.0 keeps you and your software up-to-date with Notification messages and 
automatic updates. Messages and updates ensure that you’re always working with the latest version of Photoshop 
Album Starter Edition. In order to read Notifications and to download updates, you must be connected to the 
internet.

Messages about product updates, tips and tricks, and other interesting news appear in the Notifications dialog box. 
To view the Notifications dialog box, click the View Notifications icon  at the top right corner of the work space. 
In the dialog box, click the name of the message you’d like to read, and then click View. To remove a message, select 
it and then click Delete.

Automatic updates are provided by the Adobe Update Manager. If you are connected to the internet, the Adobe 
Update Manager prompts you to download the latest features and information. If you would like to opt-out of 
update alerts, deselect the Automatically Check for New Services and Updates option in the Photoshop Services 
preferences.
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