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Introduction to NetZIP

What is NetZIP?

NetZIP is the Internet utility for enhancing your World Wide Web capabilities.    NetZIP affords you the 
comfort of surfing the web and instantly accessing archive files    (large files that contain other files) without leaving 
your browser.    NetZIP will manage the logistics of getting archives to you fast.    All you have to do is click.    
NetZIP is right on the web with you!

The purpose of ZIP files is to compress and to combine data to save disk space on your hard drive.    Archives are 
also used to transfer large amounts of data via the Internet.    Since the compressed files take up less room on 
your hard disk, these files can be uploaded and downloaded much quicker than uncompressed files.

NetZIP compresses a file by analyzing the original data and representing it with less information.    NetZIP 
compresses files to reduce the amount of space required to store your data.    The compressed data is reduced to 
a set of instructions used to recreate the original file.

Why do I Need NetZIP?

NetZIP is the only tool that allows you to download archive files automatically from your browser.    There is no 
need to launch a separate program.    NetZIP is already looking while you are surfing the web.    Any time you 
access an archive, the NetZIP window will appear.

NetZIP is the exclusive zip utility that will:

· Easily integrate with your browser

· Instantly Download and install an archive

· Download only a portion of an archive 

· View an archive before spending time downloading

NetZIP File Support

NetZIP supports the following types of archive files: 

Extension File Type

EXE Self Extracting Zip Files

GZ GZIP Files

ARJ ARJ

LHA, LZH, LHZ LHARC

TAR TAR

ZIP ZIP

TZ, TAZ

Z

ARC

In addition to supporting the previous file types, NetZIP allows you to create and work with archive files that 
include any file type (e.g. .doc, .xls, .bmp).

Requirements for NetZIP 6.0

NetZIP requires that you have one of the following for Windows software:



· Windows NT 4.0 or higher

· Windows 95 or higher

NetZIP also requires that you have one of the following browsers:

· MS Internet Explorer 3.02 or higher 

· Netscape Navigator 2.02 or higher



Contact Software Builders International

Software Builders International can be reached by phone Monday through Friday between 8:30 AM and 5:30 PM 
(Eastern Standard Time), by on-line services, or by e-mail via the Internet. 

If your question is not answered in the help file or in this user guide, please check our web site at: 

http://www.netzip.com/Tech_Supp.html 

If you have not found the solution to your question, e-mail us at: 

Techsupp@netzip.com 

Or telephone us at: 

Technical Support    (770) 541-9906

Customer Service    (770) 541-2729 or 1-800-432-0025

Fax 770-541-1700

Note: When you report a problem, please make sure to include all relevant information including:

· Version of NetZIP you are using (Click on Help and then About to find out what version you are using)

· Windows version you are using (Windows 95, Windows 3.x, NT    3.51 or 4.0)

· What feature you are using

· What happens when you use the feature

If you need to contact Software Builders for a reason other than technical support, our mailing address is:

Software Builders International

100 Galleria Parkway

Suite 1020

Atlanta, GA 30339



Installation

The NetZIP installation program is a self-installing file.    Therefore, to install, all you need to do is click on the 
download, evaluate, or purchase button on the web site at www.netzip.com or insert the removable media (CD or 
diskette) that you received from SBI.    If you are installing from removable media, double click on the installation 
program and NetZIP will install.

Your browser will ask you where you would like to store the installation files.    We recommend that you choose the 
default location on your screen or you may select a different location by typing in the Program Folder dialog box.    
Then, go to the default location that the files were installed and double click on PUNZ60.exe.    The installation 
process will automatically begin! 

Hint: All browsers must be closed before you can begin the installation process.    NetZIP will prompt you to close 
browsers before beginning the installation process.    Also, note that installing a newer version of NetZIP will delete 
all previous versions on your system.

Welcome!

The Welcome screen will provide you with hints for installation, as well as prompt you through the end user license 
agreement, electronic registration card, and Internet connection questionnaire.    Please take a moment to 
complete the electronic registration card so that you will be informed of enhancements and upgrades in the future. 
You must complete this screen before you may proceed through installation.

Program Group

After the Welcome screen, the Program Group dialog box will appear.    This option just lets you know that NetZIP 
will reside in your Programs folder on your desktop, unless you specify otherwise.

After installation, your NetZIP Browser Window will display with a "Helpful Tips" file.    Double click on the 
readme.html file to view the contents and to learn some tips for using NetZIP.

Congratulations!    You have completed the installation process!    Now you are ready to join thousands of others 
who find life on the web easier with NetZIP. 



The Help Menu

You can click on the Help Menu on your toolbar to display the Help items available to you.    The Help topics are:

· Contents 

· Getting Started

· Hints and Tips

· Frequently Asked Questions

· Update NetZIP

· Order Information

· NetZIP Home Page

· About NetZIP



Using NetZIP with the Internet

This section explains how NetZIP launches in the browser mode and how it will be available to you when opening 
an archive or self-extracting file from the Internet.    The NetZIP Browser Window is also introduced.    In addition, 
detailed steps for performing the most common NetZIP functions are described such as:

· Installing/ downloading software or files from the Internet to your computer for personal use

· Viewing files with the viewer of your choice to make sure you have the correct archive 

· Checking-out files to a temporary location on your computer

· Extracting and extracting options for archive files that will permanently reside on your computer

Launching NetZIP from the Internet 

Common NetZIP Internet Functions 



Launching NetZIP from the Internet

Once you have installed NetZIP to your computer from the Internet or from removable media, you can surf the 
World Wide Web to access archive files and NetZIP will be right there with you!    When you click on an archive file, 
the NetZIP Browser Window will instantly open.



Common NetZIP Internet Functions

The most common NetZIP Internet functions are installing files or software from the Internet, viewing files, 
checking-out files, and extracting files.    Each of these functions can be found as a button on the NetZIP Browser 
Window.    These functions can also be found under the Tools Menu.

Install 

Checkout

View 

Extract



Install

The Install and the Checkout button will interchange on your NetZIP Browser Window.    Both buttons will perform 
the function of installing files to your computer.    NetZIP recognizes which action you will require based on the files 
with which you are working.    You will never see both buttons at the same time.    As a result, the button on your 
NetZIP Browser Window will toggle between Install and Checkout.    The Install button will appear when there is a 
setup.exe, a single executable program, or an install.exe file present.    If neither of these two is present, the 
Checkout button will appear.

Hint: If you would like to checkout the files and the Checkout button is not present on your NetZIP Browser 
Window, you can click on your Tools Menu and access Checkout. 

Install is the term used for downloading an archive file from the Internet and setting it to execute on your system.    
This option would be used for getting software, screen savers, games, etc. from the Internet.    Install is used for 
archive files that contain a self-extracting or a setup file.    Install will NOT create a desktop shortcut or an icon in 
your Program Group for the archive file.    However, the program within the archive file may create icons and 
shortcuts.    Install will simply execute the file(s) on your computer.    Use Checkout to create a short cut and an 
icon to run on your desktop.

Here's How: To install an archive file from the Internet, follow these steps:

1. Go to the Internet site and click on the archive file to be downloaded and installed or click on the file from your 
desktop.    The NetZIP Browser Window appears.

2. Click the install button in the lower left-hand corner of the screen and the Install dialog box will appear.    
NetZIP will install the files onto your computer into the default location.    The install program will run at this 
point.    After the installation program completes, click OK to return to the NetZIP Browser Window.    If you wish 
to change this default, you may refer to Advanced Options.

3. Follow the NetZIP prompts through the installation process.



Checkout

This feature is similar to Install except that Checkout is a temporary function and will create a desktop short cut 
and an icon in your Start Menu. This option is different from extracting in that Checkout extracts all of the files, 
instead of just a few of the files.    Once you checkout files, they will remain in the temporary directory until you exit 
NetZIP.    Then, NetZIP will ask you if you would like to save the archive upon exiting the program.

Here's How: To checkout a file, follow these steps:

1. Open an archive file by clicking on it from the web sight or from your desktop.    The NetZIP Browser Window 
will appear.

2. Click on the Checkout    button.    The Checkout dialog box appears and tells you the default settings for your 
archive files.    These defaults were automatically selected during installation of the software.

3. Select your options for checking-out the individual archive file.    If you wish to change the default folder for all 
Checkout files, refer to Advanced Options. 

· The Folder box is the destination for the Checkout files.    The files will stay in this temporary location until 
you exit the program. 

· The Group Name box is the name of the Program Group that will be created under Start Menu/ 
Programs.    The default setting is the name of the archive file, unless you specify otherwise. 

· The Maximum Icons box creates icons for each file within the archive up to the maximum number of icons 
allowable or NetZIP will create icons for the files that have programs associated with them that are resident 
on your computer. 

· Create Icons for Programs and Documents Only will only create an icon if the file within the archive is 
an application program or a document.    If this is unchecked, icons will be added to the Start Menu for all 
files within the archive.

·  Create Desktop Shortcut will create a shortcut on your desktop to the program group.    The file will 
appear like a folder short cut. 

4. Select your options, or keep the defaults.    Then, click OK to Checkout the files.



View

NetZIP allows you to view a file within an archive before actually installing or configuring.    This option allows you 
to view a file on your desktop or to view a readme.txt file to see if you are interested before spending time 
installing.    The default viewer in NetZIP is Notepad.    In Advanced Options, you can change this default or set the 
dialog box to appear each time you click on the View button.    The default setting is that when you click the View 
button, NetZIP will take you directly to the default viewing tool.

Hint: The Viewer is dependent on the programs that are resident on your computer.    If a file has a program 
association that is resident on your computer, that program will run.    If the program is not resident on your 
computer, the default viewer will execute.

Here's How: To view a file before extracting, do one of the following steps:

· Double click on the archive file, or click on the file from your NetZIP Browser Window.

· Then, click the View button.    You will automatically go to your associated or default viewer.    Close your 
viewer to get back to the NetZIP Browser Window.    Refer to Advanced Options for more information on how 
to set the default for viewing. 



Extract

This option is for working with just one or some of the files within an archive file.    Extract will extract the files to a 
permanent extract directory.    You may refer to Chapter 4—Advanced Options to select your default extract folder.

Here's How: To extract a file, follow these steps:

1. Select the archive file and open it.

2. Click the extract button.    The Extract Files box appears.

3. Select the folder to which you are extracting for the file(s) in the Extract To Directory box or click on the New 
Folder button to create a new folder. To set a default directory, see Advanced Options. 

4. Next, select the extracting option in the Files box (selected, all files, or specified).    You can also choose a 
filter in the Files box.

5. Select the extracting options at the bottom of the screen (Overwrite Files, Use Folder Names, or Skip).

· Overwrite Files will overwrite an older version of the file, if it exists in the original archive.

· Use Folder Names will store all of the directory information for the file location.

· Skip if archive file is older will only extract the file if it is newer than the file in the archive.

· Convert CF to CR/LF when working with non .zip files so the text will wrap with the screen.

When all your options are selected, click the Execute button or click Cancel to stop the operation.

Hint: To extract multiple files, use a space in between the files (e.g. NetZIP.doc January.doc).    If the file name 
contains a space, then, put quotes around the file name (e.g. "January 97").    Wild cards can also be used (e.g. 
January 199?.doc or January 199*.doc). 



Managing Archive Files

This section will explain the several different options for launching NetZIP from your desktop.    In addition to basic 
NetZIP functions, this section will explain how to setup, get information, and manage your archive files.    Also, 
NetZIP desktop functions are explained:

Locating and opening files after they are downloaded 

Starting NetZIP/Creating/Opening ZIP Files 

Adding files to archive files 

Dragging and dropping files from the Internet and from the desktop 

Advanced Features:

Updating/Freshening/Moving/Copying/Renaming/Deleting 



Locating and opening files after they are downloaded

After a file has been downloaded, it is copied in the default location on your PC.    You can find it through Windows 
Explorer, or from your Start Menu, or from the File Menu at the bottom.    The file will reside in the default folder 
location that is listed in the options window.    If you wish to change this default location, you can refer to Advanced 
Options/Folders tab.



Starting NetZIP/Creating/Opening ZIP Files

There are several different options available for starting NetZIP.    All of these starting options can be configured in 
the Tools Menu/Options/Explorer Tab. 

To start NetZIP:

· Open an archive file from your desktop or from the Internet by double clicking on it, or

· Click on the Start Menu; go to Programs and click on NetZIP, or

· Double click on the NetZIP icon on your desktop.

Once NetZIP is open, you can open the most recent zip files by clicking on the File Menu and the recently opened 
files will appear at the bottom of the menu.    Select the file with which you would like to work.    You may refer to 
Advanced Options to check your NetZIP configuration options.

New ZIP File

Here's How: Click on the New button from your NetZIP Browser Window to create a new archive file.    NetZIP will 
ask you where you would like to store the new file in the New ZIP File dialog box.    Type the file name at the 
bottom of the dialog box.    By default NetZIP will create your archive file as a .zip file.    If you wish to create a self-
extracting ZIP file, change the Save As Type combo box to Self Extract.    Then, click Save.



Adding files to archive files

NetZIP uses the term "Add" to mean to include a file within an archive file.    This term is similar to "Pack" or "Zip." 
NetZIP also uses the term "Extract" to mean to decompress files.    Extract is similar to "Unzip" or "Unpack."

One of the most common desktop functions of NetZIP is adding files to an archive.    This function allows you to 
add files from your computer to an existing archive file.    Adding a file will compress the file and place the contents 
of the file in the archive file.

Here's How: To add a file, follow these steps: 

1. Open the ZIP archive file to which you would like to add files.    The NetZIP window will appear.

2. Click the Add button.    The Add dialog box will appear.

3. In the Look in box, you will see the default directory.    To add files, you can select them in the Add dialog box 
or you can manually type in the file name in the File Name text box. 

4. In the Location box, choose the option you prefer.    The default is nothing checked.    If you are unsure, check 
both boxes (include sub folder and store complete location.)    This will ensure that you will have all 
information available when you access the file.

5. Click on the Advanced button for optional adding functions such as Password, Attributes, Compression and 
Actions, and Spanning Disks.

Location Options:
Action Include sub 

folder
Store 
complete 
location

Files 
Activity

Directory 
Activity

Store no 
directory 
information

Off Off Stores File Nothing

Store the 
directory 
structure of 
the archive 
file

Off On Stores File Stores the 
relative 
path

Store the 
files within 
the archive 
file

On Off Stores File Stores path 
of the 
recursed 
files

Store the 
directory 
structure of 
the archive 
and store 
the files 
within the 
archive

On On Stores File Stores the 
entire path

Hint: To add files using a filter (e.g.: *.doc or *.xls), type the extension in the File Name box.    This option will allow 
you to enter a filter to include only files of a certain type.    For example, if you entered *.bmp in the File Name box, 
NetZIP will only add files with the extension .bmp. The default setting is "*. *" - this option will add all files.    After 
you have selected the correct option, click the Add button to add the selected files.



Dragging and dropping files from the Internet and from the desktop
(New topic text goes here.)



Advanced Adding Actions

Advanced actions include Add, Freshen, Move, and Update.    To activate these options, click on the 
Compression and Actions tab and then click the down arrow in the Action box.    Additional advanced functions 
found under the File Menu are Moving, Copying, Renaming, and Deleting. 

Add Adds the file(s) to the archive file and replaces them if 
they are already in the file.

Freshen Adds the file(s) only if the file(s) already exists in the 
archive and the selected file(s) is/are newer.

Move Adds the file(s) and deletes the selected file(s) after it is 
added to the archive.

Update Adds the file(s) if the selected file(s) is/are newer than 
the file in the archive of it the file(s) is/are not in the 
archive.

 Advanced Desktop Functions

Here's How: To perform advanced desktop functions, follow these steps:

Move
Click on the File Menu on your toolbar.    Then, select Move Archive.    Type the name of the folder in the Move to 
box or select the folder from the Folders box.    To move the file to a new folder, click on the New button.

Copy
Click on the File Menu on your toolbar.    Then, select Copy Archive.    Type the location to copy the file into in the 
Copy to box.    Create a new folder by clicking on the New button.

Rename
Click on the File Menu on your toolbar.    Then, select Rename Archive.    The current file name will display in the 
From box.    Type the new name in the New box.

Delete
Click on the File Menu on your toolbar.    Then, select Delete Archive. NetZIP will confirm that the file will be 
permanently deleted from your computer. 

Sort
Click on the Tools Menu on your toolbar.    Then, select Sort.    NetZIP will ask you how you would like to sort 
based on the headings inside your NetZIP Browser Window.    You can sort by name, date, time, size, %, or path.    
You can also click on the heading inside your NetZIP Browser Window to sort by that header.

Test 
Click on the Tools Menu and then select Test.    This way you can test the integrity of the file to make sure that it 
will run properly on your system.

Hint: When working with archive files other than zip files, some options may not be available to you.    If the option 
is grayed out (inactive) in your view, then it is not available to you.



Optional Adding Options

Once you have mastered the basic NetZIP functions both on the Internet and on your desktop, you may want to 
explore some advanced features like password protection, attributes for operating system functions, spanning, 
compression variations, and other advanced actions like adding, freshening, updating, renaming, copying, and 
deleting.

Here's How: In the Add dialog box, click on the Advanced button.    The Add dialog box will be extended and 
several folder tabs will appear at the base of the window.    These tabs include: Password, Attributes, Compression 
and Actions, and Spanning Disks.

Password

If you wish to password protect your file, click on the Password tab.    Type your password in the text box.

Warning: Once you have set your password, it will be required to access the file.    So, make sure you remember 
it!    There is no way to retrieve the file if you forget the password.

Attributes

This option allows you to set file system attributes.    Check the box that meets your requirements: 

Action Result

Include only if 
archive attribute set

Only files with the operating archive bit set will be 
added to the archive file.

Reset archive 
attribute

After the file is added to the archive, the operating 
system bit is reset (turned off).

System and Hidden 
files are included

Allows files that are marked as hidden and system 
to be added to archive file.

Store filenames in 
DOS format

Store the filenames in the old DOS format.    
Converts long filenames to DOS filenames.    Once 
set, this option cannot be reversed.

Compression and Actions

This tab allows you to set the compression level of your archive.    The default setting is Normal.    The sliding bar 
of compression definitions is defined in the following chart:

Compression Archive Size Speed

No compression Large Fastest

Some 
compression

Medium Super Fast

More compression Medium Fast

Normal Normal Normal

Maximum 
compression

Small Slowest

Spanning Disks

This tab is only present when the files that you are working with are on some form of removable writable media 
(diskette).    You will only want to access this tab if you would like to turn spanning off or if you would like 
NetZIP to format diskettes before spanning.    This tab allows you to add files to span disks when your archive 
is too large to fit on one disk.    This option is a default setting in NetZIP.    NetZIP will prompt you to add another 
disk when one is full. NetZIP will default to span disks.    The following options are available:



Action Result

Span multiple disks Compresses and archives the file to a 
multiple volume set.    This is the default 
setting.

Span and format 
disks

Same as span multiple disks, except the 
media will be formatted before it is 
archived.

Do not span disks This option will turn off span disks.    
When media is too large to fit on one 
piece of media, an error message will 
occur.



Advanced Options

Maintaining NetZIP's default settings is strongly recommended.    The default settings make it easy to launch, 
run and perform NetZIP functions like creating, opening, extracting, adding, and checking-out files.    However, if 
you would like to change the way NetZIP integrates with your computer, you may refer to this section.

There are five different tabs available under the Options Menu.  These options are:

General Basic NetZIP options, like browser integration, file opening options, and viewing options are under 
the General tab.

Explorer The Explorer tab allows you to choose how you would like NetZIP to run on the desktop, or in 
browser mode.

Programs In the Programs tab, you can choose your default viewer.

Folders Your file location and storage information is defined under the Folder tab.

Remote ZIP The Remote ZIP tab allows you to configure your remote zip browser.



General Tab

Under the General tab, several options are available for basic NetZIP integration both with the Internet and with 
your computer.    These options control how NetZIP will appear on your computer.

Enable NetZIP Browser Mode

Select this option to enable NetZIP to run in your browser.    This browser interface is one of the advantages of 
NetZIP.    NetZIP is right on the Web with you!    If you deselect this option, you will have to launch NetZIP from 
your desktop.

Start Browser Mode in new Browser Window

Note that this option is not available in all NetZIP products.    Select this option to open a new browser window 
when NetZIP is launched.    In other words, the browser window where the archive file is located will remain 
unaltered and a new window will open for you to perform NetZIP options.    Having this option enabled allows you 
to click back on the original browser window to get more information, or another file, etc. from the Internet.    If you 
disable this option, the NetZIP window will open inside of the original browser window.

Misc.

This option will affect how NetZIP launches. 

Automatically Show Open Dialog Box
Select this option to display the Open archive dialog box whenever NetZIP is launched.    Deselect this option to 
display the NetZIP window without the Open archive dialog box.    (You will need to click the Open button to open 
an archive).

Prompt
Prompt When View Button is Pushed is used to cause NetZIP to bring up the View dialog box any time you click 
on the View button.    This allows you to change the viewer that is associated with the file you want to view. 

Deselect this option to automatically allow you to view your archive with the default viewer or associated 
application without having to select it each time (this is the default setting).

Prompt When Extract Button is Pushed is used to display the Extract Menu any time you click the Extract 
button.

Warning: Deselecting this option will cause Extract to act as a silent extract.    In other words, NetZIP will not 
ask you where you would like to extract.    The files will be extracted to the default setting location.    Deselecting 
this option is not recommended unless you are extremely comfortable working with archive files.



Explorer Tab

This tab is the most important tab for setting file associations for NetZIP in your Start Menu, and including NetZIP 
on your desktop.    This tab allows you to set how NetZIP will run and integrate on your computer.    You can also 
choose whether NetZIP will default to browser view or desktop view.

Explorer Options

Hint: Keep the defaults and all of the Explorer options will be activated for you.    In other words, NetZIP will open 
any time you open an archive, NetZIP will be included on your Windows Start Menu and on your desktop.    Click 
on the checkbox to turn any of these options off.

Default NetZIP View

Note that this option is not available in all NetZIP products.    This option allows you to set how you will manage 
NetZIP - from the desktop or from your browser. This option will activate NetZIP any time that you open an archive 
file from your browser.    The NetZIP Window will appear.    If you deselect this option, NetZIP will not automatically 
launch when you access an archive file from your browser.



Programs Tab

This tab allows you to choose the viewer program that is associated with NetZIP.

  

Viewer

Click on the    . . . button to choose one of the viewers that is available to you.    If an application association is not 
present with the file type, then the default viewer in the Viewer box will be used.    The default NetZIP viewer is 
Notepad.



Folders Tab

This tab allows you to choose various folders for Add, Open, Extract, or working files.    This tab is important for 
finding your archive files.    The defaults provide a single download location and allows your usage to determine 
the other defaults.

Start-Up Folder

This option allows you to set the folder to which NetZIP will open when launched from your desktop.    This tab is 
important for setting up how NetZIP will interface with your computer.

Choose Last Open Archive and NetZIP will go to the folder location of wherever the last archive was stored every 
time you open an archive file.

Choose Folder to select the default folder to which NetZIP will always point any time you open an archive file.

Default Extract Folder

This option allows you to set the location for extracted files.    Once you have set this option, all of your extracted 
files will go to this folder until you specify otherwise.

Choose Open Archive Folder to extract files to the folder of the opened archive.

Choose Last Extract Folder to send extracted files to the last folder to which you extracted.

Choose Folder to preset the folder to which NetZIP will save all extracted files.    Setting this option means that all 
extracted files will reside in this folder.

Default Add Folder

This option allows you to choose the default folder to which NetZIP will add files.    NetZIP will open this folder 
automatically for you to select files.

Choose Open Archive Folder to add files to the open archive.    NetZIP will open this folder every time you 
perform the Add operation.

Choose Last Add Folder to send added files to the last file to which you added.

Choose Folder to preset the folder to which NetZIP will save all added files.    Each time you add an archive file, 
NetZIP will place it in this default folder unless you specify otherwise.

Working Folder

Select Use for Removable Media Only if you will be saving all archives to diskette.    This means that any time 
you perform a NetZIP operation, the results will be place on your removable media.

OR

Choose the Folder to which all archives will be saved.    This option allows you to save archive to your computer, 
instead of a diskette.

Click on the    . . . button to choose your default download folder, checkout folder, and temp folder.



Select the OK button when all your options are selected.



Remote ZIP Tab

This option is an advanced feature, which is on the cutting edge of Remote ZIP technology.    This allows either the 
user to define an existing I-ZIP server or site that supports Remote ZIP technology so that NetZIP will take 
advantage of its extended features.    The "Attempt Remote ZIP" on unknown servers will cause NetZIP to look for 
Remote ZIP servers for all ZIP files encountered.




