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This document summarizes issues resolved in Canvas 7.0.2. Deneba Software recommends
upgrading to Canvas 7.0.2 for enhanced performance and stability.

Adobe Acrobat Reader 4.0.5a
Adobe Acrobat Reader 4.0.5a is now able to open Canvas files which were saved in PDF format with the PDF “screen
resolution” option selected.

Adobe lllustrator (Al) v8
Canvas now opens and saves Adobe lllustrator version 8 files.

Aligning locked objects
Locked objects can now be aligned, provided the “distribution” option is not selected.

Animation documents
Canvas correctly opens a new Animation document as the default document type, when this option is selected in the
New.... > Type of Document dialog box.

Arrowheads
You are now able to use Paint Objects as Arrowheads.

Camera tool
The Camera tool now respects the document’s grids and guides settings.

Canvas 3.5 files
Files created in Canvas 3.5 can now be opened in Canvas 7.

Canvas 6.0 files
Canvas 6.0 files created and stored on a shared workstation can now be opened in Canvas 7.

Channel Mask
All of Canvas 7’s Paint tools now work correctly after applying a Channel Mask to a Paint object.

Channel Mask resolution
Canvas now applies a Channel Mask resolution to all objects in an object group.

CMYK Preview
Canvas no longer crashes when: a) CMYK Preview is selected; b) the zoom level is between 200% and 400%; and c) the
Bezier tool is selected and the user starts to draw.

Collect for Output
The Fonts option in the Collect for Output dialog box is now correctly implemented.

Color Range
Canvas no longer crashes when an RGB paint object is placed into edit mode, the Image > Select > Color Range... dialog
box is displayed, and the Save button in the dialog box is selected.

Context-sensitive menus
Canvas correctly displays context-sensitive menus at the pointer’s location for Paint Objects, whenever the Canvas
document window is less than full-screen (maximized).

Curve Text
Canvas now correctly places curve text on Master pages.

Dimension Lines
Dimension Lines, created in Canvas 3.5.5 files, now display correctly in Canvas 7.

Dimensioning Standards
The Dimensioning Standards popup menu is now correctly displayed when selected.



Display settings
Canvas now correctly displays dialog boxes in Windows OS when the Large Fonts option is selected in the Desktop
Display > Settings tab > Advanced button > General tab > Font Size menu.

Display Text Boxes
Canvas no longer renders the bounding rectangles of multiple text boxes when Display Text Boxes is selected and the
Image > Area > Render command is chosen.

Document Layout palette

- Canvas no longer crashes when selecting objects via the Document Layout palette across multiple open documents.

- Canvas now correctly scrolls the Documents Layout palette when attempting to move the topmost layer onto a page that
is not visible in multi-page, multi-layer document.

Document Preview thumbnail
Opening multiple copies of the same document correctly displays the document preview thumbnails.

Document Properties
The Font Statistics in Document Properties are now correctly stated.

Easy Shapes
Canvas correctly handles text contained within Easy Shapes when Shadow effects are applied.

Epson Stylus 800 printers
Canvas no longer displays faint white gridlines when printing RGB images to Epson Stylus 800 inkjet printers.

Extrude palette
Canvas now correctly displays the circular extrusion options available in the palette.

Facing Pages
The Facing Pages option is correctly displayed when a Publication document is selected.

Font matching
Canvas now correctly saves and opens documents with fonts whose font name(s) contain spaces.

Grids

- Non-printable Grids are correctly handled in Canvas documents, saved in EPS format and imported into MS Word 97
and/or MS Word 2000.

- Canvas no longer displays an error message when setting the grid to 1 pixel when the screen display resolution is set to
96 dpi on Windows OS computers.

Guides
Guides now “Snap to Grids” in Canvas 7.0.2.

Image Export - GIF/JPEG format

- The GIF/JPEG Image Export option no longer crashes the application when very large (> 35.1 MB) images are exported
in JPEG format.

- Random screen artifacts are no longer displayed in the JPEG preview window at certain zoom levels.

- Canvas no longer changes a channel’s pixels transparent in multi-channel GIF images, when something other than
“Selected Colors” is chosen in the Image > Export >GIF/JPEG dialog box, when the GIF export option selected.

- Canvas no longer generates extraneous screen pixels in the color palette when exporting a paint object as a GIF, and
the number of Max Colors in the GIF Export dialog box is switched from 256, to 128, to 64, to 32, to16, and then to 8.

Inks
The list of Inks in a document no longer displays previously deleted object Inks.

Inks palette:
- The Inks palette correctly resizes to any vertical size.
- Blending colors in the Color tab of the Inks palette correctly handles the number of blend steps chosen.

Kai’s Power Tools plug-in filters, v5
Canvas no longer displays extraneous pixels in KPT filter dialog boxes, when viewed in the small Photoshop-style
thumbnail windows.

Kodak CMS
Canvas no longer crashes in the Kodak CMS with CMYK preview selected when creating Bezier curves at zoom levels
greater then 100%.

Lenses
The Sprite Effects palette correctly displays multiple lenses that were created at the same time.



Levels
- The Levels dialog box no longer crashes Canvas when you attempt to Save Settings.
- Canvas correctly handles an image’s Levels settings when the file is saved and reopened.

Locked objects
Canvas correctly displays “The selection is locked” message for all locked objects.

Macros

- When the pointer is placed over the Macros in the toolbox the hint line no longer reads "Gallery Tool".

- When scaling a macro with the “scale pen” option selected, the pen thickness no longer reverts to its original size when
the macro is unlinked.

Magnifying Glass
The Magnifying Glass tool now allows zooming within a paint edit session when the document resolution is set to 96 dpi.

MS PowerPoint
Canvas no longer crashes when MS PowerPoint slides are imported into Canvas via the Clipboard.

MS Windows 2000
Canvas now correctly prints Type 1 PostScript fonts in Windows 2000.

MS Windows 98
Canvas now correctly animates interface elements when the Animate Windows, Menus and Lists option is selected in MS
Windows 98'’s Display Properties > Effects palette.

MS Windows NT Server
Canvas now correctly handles “.CNV” files that have been stored on a Windows NT Server.

MS Word
Canvas now correctly handles older version Canvas files opened in Canvas 7 and pasted into an MS Word document via
the Edit > Paste Special > Picture command.

New...
Canvas correctly opens all default document types: lllustration, Publication, Animation and Presentation.

Object comments
Canvas now correctly handles changes in “Initials” the File > Preferences > User Info tab when adding comments to an
object.

Object Stacking Order
Canvas now maintains the proper stacking order of deleted objects when using the Undo command.

Object Visibility
Canvas now correctly displays an object’s visibility state in the Document Layout palette.

Onion Skinning
The Onion Skinning feature no longer appears in the Document Layout palette of Presentation template documents.

Online ClipArt

Canvas now includes a new menu option in the Help menu: Online ClipArt. Provided you are connected to the Internet
when choosing Online ClipArt, you will be connected to the Deneba Internet Graphics Server. This server contains all of
the clip art files from your Canvas ClipArt CD-ROMs for online use.

Open...
Canvas now correctly opens files with four-letter extensions, such as JPEG or TIFF.
Open... EPS

Opening files which originated from a Schlumberger PDS to EPS converter no longer crash in Canvas.

Open... PDF format
- Canvas now correctly handles font spacing when opening a document saved in PDF format.
- Canvas correctly opens version 1.1 PDF files.

Out of Memory errors
Canvas correctly handles memory allocation when creating QuickTime movies in Thousands of Colors.

Paint Edit mode
You can now exit Paint Edit mode when all pixels in the selected paint object have been deleted.

Parallel Extrude
Multigon objects can now be extruded using the Parallel Extrude option.



Parallel Strokes
You can now select and edit individual lines in the Parallel Strokes manager of the Strokes palette.

Password-protected Sheets
Canvas correctly handles locked Sheets with Passwords.

Photoshop files
Canvas no longer adds an extra blank Alpha Channel when opening or placing Photoshop files if the “Load merged result
option is selected.
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Pressure-sensitivity
The pressure-sensitivity option in Canvas 7’s Paint tools is fully enabled for Wacom tablets.

Print Preview
Canvas no longer crashes when Print Preview is selected with open Al or EPS format files.

Printing tiled documents
Canvas correctly handles the “Skip Blank Pages” option when printing tiled large format documents.

Print Separations
Canvas now correctly prints separation plates for documents that contain text blocks with multiple strokes and
transparency effects applied to them.

Publication document
Canvas correctly handles the naming of new Grid Layers in Publication documents.

Radial Transparency
Radial transparency edit nodes no longer disappear while editing the transparency.

Rotate Again... command
Canvas correctly displays the Rotate Again... command once the Rotate Other... command has been executed.

Rubber Stamp tool
The Rubber Stamp tool no longer crashes Canvas when multiple selections from its popup menu are selected for use on
very large paint objects.

Save As... Al
- Canvas no longer converts circles into Bezier lines when the document is saved in Adobe lllustrator (Al) format.
- Canvas now correctly preserves Dimension Objects when the document is saved in Adobe lllustrator (Al) format.

Save As... EMF or WMF
Canvas no longer crashes when saving files in EMF or WMF formats.

Save As... EPS
When saving documents in EPS format, Canvas now saves only the fonts included in the document’s font list.

Save As... GIF/JPEG

- RGB images can now be correctly saved as grayscale images in the Save As... GIF/JPEG format options dialog box.
- The render dialog box is no longer displayed when saving an RGB image in GIF/JPEG format.

- Canvas no longer crashes when you create a one pixel high image and export it in GIF/JPEG format for use as a
horizontal rule in a web page.

- Canvas no longer produces extraneous pixels when switching to Max Colors in the color palette of the GIG/JPEG Export
Preview dialog box.

- Canvas no longer corrupts Grayscale paint objects when a —45 degree angle blend has been applied and the paint
object is exported as a 72dpi JPEG image.

- Canvas now correctly purges memory before compressing an RGB paint object, when the paint object is saved as a
GIF/JPEG.

- The render dialog box is no longer displayed when saving an RGB image in GIF/JPEG format.

Save As... PDF

- Saving text in PDF format no longer crashes Canvas.

- Canvas now correctly saves a document in PDF format when the “Printer” option is selected for the document’s graphics
resolution.

Save As... WPG
Canvas now correctly saves a document in WordPerfect Graphic (WPG) format.

Save As... WMF
Canvas now correctly saves the selected layers when saving a document in WMF format and the “Save Layer” option is
enabled.



Save to Web
The Web Publishing Wizard correctly implements the Save As... HTML format options for the document.

Scale
Scaling now correctly scales the stroke weight of text.

Screen Resolution
Canvas now respects a document’s screen resolution whenever the document is saved and reopened.

Select All

The following objects are now selected when their tool is selected in the Toolbox and Select All is chosen from the Edit
menu: Smart Lines, Arc 3-Points, Circle 3-Points, Concentric Circles, Grid, Spiral, Easy Shapes, Dimension, Freehand,
Auto Curve, and Paint objects.

Select through transparency
The Select through transparency option in Preferences > Painting tab is now correctly implemented.

Show Rulers command
Whenever the Show Rulers command is selected, Rulers are now correctly displayed at all magnification levels.

Snap to Guides
Objects will now Snap to Guides without having Snap to Grid selected.

Spell Checker

Canvas 7’s “misspell red lines” are no longer displayed when bound text is rendered.

Status Bar
The Status Bar is no longer hidden from view when opening large Canvas files.

Strokes Palette
Canvas correctly displays the Strokes Palette’s size, location and rollup state.

Text
- Canvas no longer creates corrupted text objects when typing text on top of Paint Objects.
- Canvas now correctly pastes large-width text objects into MS Word 97.

Text justification
Canvas correctly displays the justification of multiple text objects in a single Canvas document, when the Canvas
document is saved as html, css or table, and viewed in any web browser.

Text Rules
The Canvas document window is now displayed correctly whenever text is placed in edit mode, Text>Rules... is selected
and either the Pen or Dash palette is opened.

Text Styles
Text objects created with either Outline or Shadow styles are now correctly displayed at all point sizes and zoom levels
when the Anti-alias text option in the Preferences > Type tab is selected.

Toolbox
The Canvas Toolbox correctly displays and enables tools and when opening a GIF, JPEG or Al document.

Transform
Canvas now provides an unlimited number of object transformations using the Transform palette.

Transparency
Canvas now correctly displays the edit nodes of an elliptical mask in the Transparency palette.

Undo
- The Undo command now works with the Autotrace command.
- The Undo icon now works when the Text Ruler is displayed.

Unlock All
The Object > Unlock All command is no longer available in a new document with no objects.

Update Canvas
The automatic Update Canvas option in the Help menu is set to “Off’ as the default on Mac OS computers.

URL Tag
The URL Tag palette is correctly displayed when it's selected after all open documents are closed.

URL Tag palette
- You can now select either a destination folder or a file when browsing the directory structure.



- Unassigned URL Tags are automatically deleted as they become obsolete.

Vector Transparencies
Canvas now correctly displays vector transparencies applied to rotated objects.

View Fonts
You can now use the arrow keys to scroll through the list of installed fonts when the View Fonts window is open.

Web buttons
Canvas now displays the correct mouse-over state of web buttons when dragging the cursor over multiple buttons.

CONTACTING Deneba Software

We work continually to improve our products and satisfy the needs of out customers. We appreciate your feedback and
suggestions. If you have comments or need additional information or assistance, please contact Deneba by mail, phone,
fax, e-mail, or internet:
Mail:
Deneba Software
Customer Support Department
1150 NW 72 Ave
Penthouse
Miami, FL 33126
Phone: 305-596-5644
Fax: 305-273-9069
E-mail: support@deneba.com
Internet: www.deneba.com (for technical support, product information, software updates, how-to pages, tips, and
company information)

Copyright © 2000 Deneba Systems Inc. Canvas is a trademark of Deneba Systems. All other trademarks are the property of their
respective owners and are used here for information purposes only.
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