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Chapter 1: Introduction
Word Mail Merge Features

Sending Letters Perform mail merges using built-in macros for Word 97 and later versions. The resulting 
merged document can be printed, faxed, or emailed to one or more contacts. Office 2000 

users can also preview and update merged documents before printing.

Logging Letters Letters can be logged automatically from Commence or from Word. The actual merged 
document can be stored with the log item for future reference. Optionally the merged 
document can be discarded after the merge to keep the log size to a minimum in 

Commence.

Adding Templates Commence makes it easier than ever to create letter templates and merge with 
Commence data. Images from the Commence database can be embedded into the merged 
document. Shared letter templates can be personalized with your name, signature, and 

other information about you. New menu commands are installed to the Word toolbar to 
make it faster and easier to create document templates. This feature is only available with 
Office 2000 and later versions.

Outlook Integration Features

Logging Outlook 
E-Mail

E-mail integration with Outlook has been streamlined to simplify the storing of email 
messages to a Commence database, to improve the display of stored email messages, 

and to provide a means for capturing and managing attachments within Commence. Users 
can store and view their Outlook E-mail in Commence. Supported features include:

• One-button logging of email messages into the Commence database

• Stores original message in rich-text or HTML format along with attachments

• Works with incoming and outgoing email

Synchronizing 
with Outlook

This feature enables Commence users to share Contacts, Tasks, and Calendar infor-
mation with Outlook users. The synchronization feature provides the ability to share infor-

mation between a Commence database and Microsoft Outlook® 98, Outlook 2000 or later 
versions. Information is shared by two-way synchronization between Commence and 
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Outlook using the Tools -> Outlook Sync  menu command. This synchronization copies 

information added or modified in Commence into Outlook, and then copies information 
from Outlook and adds or modifies the items in Commence.

Scheduling 
Meetings in 
Outlook

The Tools -> Schedule Meeting  command in Commence can be linked directly with 
Outlook. This allows users to schedule meetings using the group scheduling feature in 

Outlook.

Using the 
Commence 
Address Book

In some cases, it may be preferable to simply access email addresses in Commence 
without actually synchronizing all your Commence data to Outlook. Configuring the 
Microsoft Outlook Address Book preference creates an external Commence Address 

Book that can be used from within Outlook.

Requirements
Commence has been designed to work with the more advanced capabilities offered in 

Microsoft Outlook 98, Outlook 2000 and later versions. Outlook Express and previous 
versions of Outlook do not include these capabilities and are not supported. 

In addition, the E-mail logging feature requires that the Collaboration Data Objects 
(CDO) library be installed. CDO is a component included with Outlook 98 and later, but it 

is not installed by default. Use Control Panel -> Add/Remove Programs  to update your 
installation of Microsoft Office. Choose to "Add or Remove Features" for Microsoft 
Outlook for Windows. Select Collaboration Data Objects from the list of features then 

select "Run from My Computer". This will install the necessary libraries needed to work 
with Commence.

Outlook must be installed on the same PC as Commence RM. To determine if Outlook 
was setup properly, start Outlook and select the Help -> About Microsoft Outlook  menu 

command. Outlook should be setup using either of the following options:

• Corporate or Workgroup: provides full MAPI compliance

• Internet Mail Only: provides services to connect to an Internet Service Provider (ISP).
Introduction: Requirements
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Chapter 2: Word Mail Merge
Sending Letters

Letter to one or 
more recipients

 To create a letter:

1 Open a view containing the contact(s) who should receive the letter.

2 Select the item for whom you want to create a letter by clicking on it once.

3 Select Tools -> Send Letter  or select the  button on the tool bar. The Send Letter Dialog Box 
is displayed.

Note: When this command is launched from a detail form, only a single contact is merged.

Figure 2-1: Send Letter dialog for Microsoft Word Merge

4  By default, a single letter will be sent to the Selected Item  in your view. To perform a mail merge 
for all contacts in the view, choose All Items  from the Send Letter To: list at the top of the dialog.

5 Highlight the letter template you wish to use. Formatted letter templates will be shown as type 
DOC. Letter templates of the type TXT are text letter templates. Graphics and other formatting are 
not supported in Text letter templates.
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Note: Formatted letter templates created with a previous version of the Commence letter macros 
may also be listed. These templates may continue to be used as-is, or new templates may be 
created to take advantage of the latest mail merge features. If there are no .DOC templates defined 
for the selected category, create one by following the steps for “Adding templates from Commence” 
on page 4. 

6 When the letter is logged, the date and time the letter was sent is automatically recorded and 
saved with the contact record(s) to whom the letter was sent. You may also wish to attach a 
copy of the finished letter with your log. This option is recommended if you have made any 
significant modifications to the letter. It also allows you to quickly view the content of any 
document that has been logged. Check the box to Include merged document with log item  to 
attach a copy of the letter in your log history. Custom Document Filename  lets you specify a 
custom path and filename to store the merged document instead of using the auto-generated 
filename.

7 Select Merge . Pressing the Merge button runs the merge process and sends the 
finished documents to the selected destination.

8 If Preview  is turned on, the merged document will open in Word. This enables you to update 
the letter before completing the merge. When sending a letter to multiple contacts, your 
changes will be applied to the merged document for all contacts.

9 Press Continue with Merge  to complete the letter and send it to the destination you selected 
(printer, fax, or email). Press Cancel to discard the letter.

Printing Labels

For more than one 
contact

 To print labels for all contacts in your Commence view:

1 Open a view containing the contacts for which labels will be generated. This view does not need 
to be formatted for labels. 

2 Select Tools -> Send Letter  or select the  button on the tool bar. The Send Letter Dialog 
Box is displayed.

3 By default, a single label will be created for the Selected Item  in your view. To print labels for all 
contacts in the view, choose All Items  from the Send Letter To: list at the top of the dialog.

4 Highlight the label template you wish to use. 

5 Confirm the destination (e.g. Printer) and choose whether or not you wish to preview the labels 
before completing the merge.

6 Select Merge . Pressing the Merge button runs the merge process and sends the 
finished labels to the selected destination.

7 If you chose to preview, the completed labels will be displayed in Word. You may edit the 
finished labels if necessary before printing.

Adding templates from Commence
Commence comes with a variety of pre-defined letter templates that allow you to 

quickly and easily create letters to your Contacts. The merged document can then be 
viewed in Word, printed, faxed, or sent via e-mail. The mail merge process is typically 
configured and launched using the standard Commence menu commands.
Word Mail Merge: Printing Labels
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To add a new template using Commence:

1 From the Commence menu bar, select Tools -> Customize -> Database -> Letter Template . Any 
pre-defined templates for the active category will be listed under Letter Templates, and sorted by 
Type.

2 Press Add Formatted.. . The Add Formatted Letter Template dialog appears.

Figure 2-2: Adding a letter template using Commence

3 Enter a brief description of the template in the Template Name  box. The description could include 
information such as how it will be used, or simply which type of contact will receive the letter. (e.g. 
HelpDesk Fax Cover Sheet)

4 Using the For Category:  drop-down list, select the Commence category that will be used as your 
data source. This category should typically contain the names and addresses of your contacts, 
however templates may be created for any category.

5 The Select Template Type dialog appears.

Figure 2-3: Select the type of template

6 A Commence template can be used to generate letters, labels, or envelopes. Each of these template 
types is designed differently so a different template must be added for each type as needed. Choose 
the type of document that best suits your needs. If more than one type is needed, repeat the steps 
above to add another formatted template, then select a different template type.

7 Press Create Template  to continue with the template creation process.

8 The next step is to select the fields to be used in the template. These field codes can be 
inserted throughout the body of the template. These codes will be replaced with data from 
the Commence item(s) once the document is merged. Proceed with “Inserting Commence 
Fields” on page 11.

9 When you are finished designing your template, save the document. See “Saving Commence 
templates” on page 13. 
Word Mail Merge: Adding templates from Commence
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Adding templates from Word
Mail merge templates can also be managed directly from within Word. The following 

commands are available from the Microsoft Word menu bar.

Adding Letter 
Templates

To add a new letter template using Microsoft Word:

1 From the Word menu bar, select Commence -> Add Letter Template . The Add Commence 
Letter Template dialog appears.

Figure 2-5: Adding a Commence Letter Template from Word

2 Enter a brief description of the template in the Letter Template Name  box. The description 
could include information such as how it will be used, or simply which type of contact will receive 
the letter. (e.g. Trade Show Invitation)

3 Using the Category  drop-down list, select the Commence category that will be used as your 
data source. This category should contain the names and addresses of your contacts.

4 If this template will be used by more than one client in the workgroup, turn on the Shared  
checkbox. Note that you must have been granted Author permissions by the Commence Admin-

Table 2-4: Microsof t  Word menu commands

Microsof t  menu command Descr ipt ion

Fi le->Save Commence Template
Saves the Commence template and re lated 
data source informat ion

Commence->Save Commence Template Same funct ional i ty  as above

Commence->Add Letter  Template Shortcut  to  add a le t ter  template f rom Word.

Commence->Add Label  Template Shor tcut  to  add a label  template f rom Word.

Commence->Add Envelope Template
Shor tcut  to  add an envelope template f rom 
Word

Commence->Inser t  Commence Field
Lets you speci fy  where to  merge Commence 
i tem data with  the document

Commence->Inser t  Commence View Embed a v iew into the merged document

Commence->Commence Preferences
Conf igure a defau lt  fax  and emai l  f ie ld  f rom 
a se lected category to  be used when fax ing 
or  emai l ing the merged document

Commence->Log and Link to  Commence
Creates a log i tem in  Commence for  the 
act ive document in  Word
Word Mail Merge: Adding templates from Word
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istrator to add shared templates. Or you may leave the Shared box unchecked to add a local 
template. Shared templates can be personalized for each client who uses it. See “Inserting My 
personal information” on page 12 for more information.

5 Press Create Letter  to continue with the letter template creation process. Otherwise click Cancel to 
close the template and discard your changes.

6 The next step is to select the fields to be used in the letter. The Get Commence Fields toolbar 
contains a list of fields and connections for the Commence category you selected. See “Inserting 
Commence Fields” on page 11 for more information about using this toolbar.

7 When you are finished designing your template, save the document. See “Saving Commence 
templates” on page 13. 

Adding Label 
Templates

To add a new label template using Microsoft Word:

1 From the Word menu bar, select Commence -> Add Label Template . The Add Commence Label 
Template dialog appears.

Figure 2-6: Adding a Commence Label Template from Word

2 Enter a brief description of the template in the Label Template Name  box. The description could 
include information such as how it will be used, or simply what size label will be produced using the 
template. (e.g. 3x10 Labels).

3 Using the Category  drop-down list, select the Commence category that will be used as your data 
source. This category should contain the names and addresses of your contacts.

4 If this template will be used by more than one client in the workgroup, turn on the Shared  checkbox.

5 Press Create Label  to continue with the label template creation process. The Select Fields for Label 
Template dialog will appear. Clicking Cancel will close the template and discard your template.
Word Mail Merge: Adding templates from Word
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Figure 2-7: Selecting name and address fields for a label template

The next step is to select the fields to be used in the label. The Select Fields for Label 
Template dialog contains a list of fields and connections for the Commence category you 
selected.

6 Using your mouse, click on each field that contains data to be used on the label. Keyboard users 
can scroll through the list of fields using the up and down arrows on the keyboard, and use the 
spacebar to select a field. A checkmark will appear next to all fields that have been selected.

7 Press Create Template  to continue with the label template creation process.

The Merge Helper will guide you through the next steps. This will assist you in making 
the following decisions:

• What label size will you be using? You may choose from Avery and other popular label products 
already configured in Word.

• How will the data appear on the label? This includes arranging the fields appropriately on each 
line so that they create an address block.

8 Choose the product number that corresponds to the correct label size. For this example, choose 
’5160 - Address’ which will create 30 labels to a page. If the size you need is not listed, press F1 
for more information about creating your own custom labels in Word. When you are finished, 
press OK.
Word Mail Merge: Adding templates from Word
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Figure 2-8: Choosing label options

9 Press Insert Merge Field  and select the fields for your label.

10 Design your label by positioning your inserted fields on the label as needed. You may add spaces 
and other punctuation, plus arrange fields on separate lines as needed.

Figure 2-9: Sample label

11 If required, you may place a barcode on your label by pressing Insert Postal Bar Code. You will be 
prompted to select which fields contain the address and zip code information. Use the drop-down list 
to select the appropriate fields from Commence.
Word Mail Merge: Adding templates from Word
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Figure 2-10: Inserting a bar code on the label 

12  When you are finished designing the label, press OK.

13 You may close the Mail Merge Helper by pressing Close . It is not necessary to get a data 
source or merge the data at this point.

14 The finished template will be named PIM*.doc. Save your template in Word by selecting File -> 
Save Commence Template or Commence -> Save Commence Template .

Caution: The Save Commence Template command must be used to save your template before it 
can be used in Commence. See “Saving Commence templates” on page 13 for more details.

This template can now be used to print labels from Commence.

Adding Envelope 
Templates

To add a new envelope template using Microsoft Word:

1 From the Word menu bar, select Commence -> Add Envelope Template . The Add Commence 
Envelope Template dialog appears.

Figure 2-11: Adding a Commence Envelope Template from Word

2 Enter a brief description of the template in the Envelope Template  box. The description could 
include information such as how it will be used, or simply what size envelope will be produced 
using the template. (e.g. Literature fulfillment)

3 Using the Category  drop-down list, select the Commence category that will be used as your 
data source. This category should contain the names and addresses of your contacts.

4 If this template will be used by more than one client in the workgroup, turn on the Shared  
checkbox.

5 Press Create Envelope  to continue with the envelope template creation process. The Select 
Word Mail Merge: Adding templates from Word
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Fields for Envelope Template dialog will appear. Clicking Cancel will close the template and discard 
your template.

The next step is to select the fields to be used in the envelope. The Select Fields for 
Envelope Template dialog contains a list of fields and connections for the Commence 

category you selected.

6 Using your mouse, click on each field that contains data to be used on the envelope. Keyboard 
users can scroll through the list of fields using the up and down arrows on the keyboard, and use the 
spacebar to select a field. A checkmark will appear next to all fields that have been selected.

7 Press Create Template  to continue with the envelope template creation process.

8 Information from Commence can be positioned anywhere on your envelope. The next step allows 
you to arrange the fields you selected on the envelope template. Proceed with “Inserting Commence 
Fields” on page 11.

9 When you are finished designing your template, save the document. See “Saving Commence 
templates” on page 13. 

Inserting Commence Fields
When designing the body of your template, there may be areas that require data from 

Commence to be merged into the document. This is accomplished by inserting fields from 
Commence into the template. The supported field types are discussed below.

Inserting fields Some examples of how fields can be used include:

• the salutation in a letter template (e.g. Dear John,)

• your closing signature in a letter template (your name, title, phone, extension)

• the address block (a contact’s full name, company name, and address)

1 If the Get Commence fields toolbar is not already displayed in Word, select Commence -> Insert 
Commence Field  from Microsoft Word’s menu. The floating toolbar will appear.

Figure 2-12: Floating toolbar

2 This toolbar can be docked at the top of the window along with all the other Word toolbars. Docking 
the toolbar gives you the fastest access and convenience if you plan to create many new templates.

Figure 2-13: Docked toolbar

3 Select a field from the Insert Commence Field  drop-down list. 

4 To move the field to another position in the template, be sure to select the entire field code, including 
brackets, before dragging and dropping it.
Word Mail Merge: Inserting Commence Fields
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Note: Formatting your field code will apply the formatting to the resulting data in the merged 
document. Be sure to select the field code in its entirety, including the brackets. Then apply the 
style or formatting to the selection.

Inserting images Images are photos, electronic signatures, or other graphics stored in image fields in the 
Commence database. Image fields are immediately visible in the detail form when the 
Commence item is opened. These types of images can be inserted and positioned in your 

template in the same way that fields are inserted. See “Inserting fields” on page 11.

Note: You may have other graphic files stored in data file fields in the Commence database. Data 
file fields point to external files on your local and/or shared drives. The path to these files is visible 
when the Commence item is opened but the content of the data file is not viewable directly within 
Commence; the external application must be launched in order to view these files. These data file 
fields are not supported in the mail merge templates. Only direct image fields can be inserted into 
your template.

Inserting 
connected fields

Figure 2-14: Selecting a connection field

In the above example, the merge field code for the Invoice # is shown below.

{ DDEAUTO Commence MergeItem "[GetConnectedItemField(,,\"has\",\"Order 
History\",\"Invoice #\")]" \* CHARFORMAT } 

This field code would resolve to a value of "134708" (the actual invoice #) when the 

letter is sent.

If there is more than one connected item, each item will be displayed on a new line. For 
best results, the fields should be arranged in table format. This will ensure that the 
merged data lines up properly.

Inserting My 
personal 
information

The (-Me-) item can be used to personalize the signature portion of your letter 

template. Some examples of fields you can insert include your name, title, phone, 
signature, and corporate logo. This feature is ideal for shared letter templates used by 
multiple Commence users. Shared templates can contain both general information that 

pertains to everyone, as well as personal information about the one sending the letter.
Word Mail Merge: Inserting Commence Fields
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Figure 2-15: Selecting fields from the (-Me-) item

For example:

{DDEAUTO Commence MergeItem "[GetMeField(\"First Name\")]" \* CHARFORMAT } { 
DDEAUTO Commence MergeItem "[GetMeField(\"Last Name\")]" \* CHARFORMAT }

resolves to: Alice Bayerd

%  Tip Your personal information is stored in the item you have designated as the (-Me-) item. To 

set the (-Me-) item in Commence, select Edit -> Preferences -> Personal Info .

Inserting a view If the Commence Views toolbar is not already displayed in Word, select Commence -> Insert 
Commence View  from Microsoft Word’s menu.

Figure 2-16: Inserting a view

For example:

{ MACROBUTTON CommenceView ["Order History by Customer"] }

resolves to:

Figure 2-17: Sample view inserted into merge document

Saving Commence templates
The standard File -> Save command in Word will save a draft of your document but does 

not save the necessary data source information necessary for Commence templates to 
merge properly. Commence templates should always be saved using the Save Commence 
Template  command.

To save your customized template in Word:

1 From Word, select File -> Save Commence Template or Commence -> Save Commence 
Template .

2 Commence uses the filename (PIM*.DOC) to locate the template during a mail merge. 
Word Mail Merge: Saving Commence templates
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The template can now be used to send letters to one or more contacts within 

Commence. See “Sending Letters” on page 3. All letter templates are stored in the 
"\tmplts" subdirectory of your current database.

Formatted Letter preferences
These preferences determine which word processor is used for formatted letters.

Application To integrate Commence with Microsoft Office 2000/XP, select the Edit -> Preferences -> 
Letters  command in Commence and confirm that your Formatted Letters Application is 
set to "Microsoft Word Merge ". 

Note: The Formatted Letters Application should be set to "Microsoft Word 97" for Office 97 users. 
Not all mail merge features are available with Office 97.

Templates created in Commence will be stored in Word’s native DOC file format and 

may contain whatever formatting features Word provides, in addition to the Field Codes 
used in Commence templates. The same setting used to perform a mail merge with 
Microsoft Word is also capable of sending e-mails and faxes.

Figure 2-18: Commence letter preferences dialog

Program File 
Name

Verify that the Program File Name  is set to the full path where the Microsoft Word 
program file (winword.exe) can be found. You can also use the Select button to browse 
your PC to find the program executable.
Word Mail Merge: Formatted Letter preferences
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Always Preview When creating letters using Microsoft Word Merge, you have the option of previewing the 
document before it is delivered to your fax, printer, or email outbox. The Always Preview  

option can be turned on if your preference is to always preview documents before sending. 
This setting will be used as the default, but you will still have the option of changing your 
preference at the time of each mail merge.

Fax and E-mail preferences

Setting a default 
field for fax and e-
mail

There is a preference in Word that can be configured to simplify the steps for a mail merge. 
This assumes all your contact information is stored in a single Commence category (such as 

Person/Company). For your convenience, you can specify in advance which fields are used 
to store the fax number and email address in that category.

To set a default fax field and/or email field in Word:

1 From Word, select Commence -> Commence Preferences . The Commence Preferences dialog 
will appear.

Figure 2-19: Setting a default fax and/or e-mail field

2 In the Default Category  drop-down list, select the Commence category where contacts are stored. 
It is assumed that most of your templates will use this category as the data source.

3 In the Default Fax Field  box, select the field name where the contact’s Fax number is stored.

4 In the Default EMail Field  box, select the field name where the contact’s E-mail Address is stored. 

Otherwise, you may leave these preferences blank and you will be prompted for this infor-
mation each time you specify a destination of fax or e-mail during a mail merge.

Logging letters
Logging creates an item in Commence that is connected to the recipient(s) and contains 

information about the letter. Information that can be tracked includes the date and time the 
letter was sent, any other notes you may want to add, and even a copy of the letter itself.
Word Mail Merge: Fax and E-mail preferences



16
The letter, also known as a merged document in Microsoft Word, is saved in a file on 

disk. The file name is recorded in the data file field in the log item. The current date is 
entered in the date field of the log item. The log item by default is given the same name 
as the Template that was used to create the letter, but you may enter a custom log item 

name if you prefer.

After the letter has been logged and saved, you can look at the finished letter by 
pressing the View  button in the data file field. This launches Microsoft Word and opens 
the merged document.

Log preferences
Select the Edit -> Preferences -> Event Log  command in Commence to open the Event 

Log preferences dialog. Letter log preferences are set in the lower half of the window in 

the Log Letters to  group box.

Figure 2-20: Event log preferences for logging letters

Category The Category  drop-down box lets you select which category to use when saving the log 

item in Commence. This category typically contains each of the following field types:

• date field: Stores the date when the letter was sent

• time field: Stores the time when the letter was sent

• data file field: Stores the path to an external data file on disk. Provides access to the merged 
document from within Commence.

• text field: Large text area to be used for entering additional comments

• connection field: Creates a link to the recipient item (typically a contact) in Commence

In the tutorial database, the letter log category is set to use the History category. When 

choosing an alternate category for the letter log, you should choose a category similar to 
the defaults given above so that Commence can keep proper track of the details for your 
log item.

Save In Directory The Save In Directory box lets you enter a default path where your merged documents 

will be stored. This path can point to a directory on your local drive or a shared drive. 

By default, this setting points to a subdirectory called "\letters" in your Commence 
program directory. If you want to change this selection, type the name of the new 
directory in the Save In Directory box. You can also use the Select  button to browse your 

hard disk to find a suitable directory.

Each time you create a letter, you have the option of changing this path (in the Custom 
Document Filename  box), or of discarding the letter after the merge is complete (by 
turning off the option to Include merged document with log item ). See “Sending Letters” 

on page 3 for more information.

 

Word Mail Merge: Log preferences
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Chapter 3: E-Mail Logging
To configure any Commence database to log e-mail messages from Outlook, you need to 
follow these steps:

• Prepare your Commence database.  You may need to modify categories and fields to support the 
data coming from Outlook.

• Set Preferences in Commence.  You will also need to select the fields in Commence to use when 
logging e-mail. Commence's preferences allow you to map Commence categories and fields to those 
required for logging e-mail from Outlook.

• Verify Commence Options in Outlook.  These options determine how incoming and outgoing e-
mail messages are handled after being logged in Commence.

Preparing your Commence database
The following changes to your Commence database are required to support logging E-

mail from Outlook.

Commence 
Category Changes

The fields in Commence should be modified to match the fields found in Outlook E-Mail 
messages.  An overview of common changes are:

• Confirm that your personal item (containing your name and E-mail address) is stored in the 
same category where Contacts are stored. If your actual user record is stored in a separate category, 
it will be necessary to copy a minimal amount of information (your name and e-mail address) to a 
record in the contact category.

• Add or modify a selection field in the category where E-mail messages will be stored. This field 
should contain selections for "E-mail Sent" and E-Mail Received" and will be mapped to the Message 
Type field in Outlook.

• Confirm that duplicate items are allowed in the category where E-mail messages will be stored.

• A connection must exist between the log category and the contact category. This link will 
be used to lookup the contact’s e-mail address when logging each message. If a match is 
found, the logged e-mail will be attached to that contact.

Setting Preferences in Commence
To enable E-mail logging for a Commence database you must first configure your E-mail 

Log preferences.  You will be prompted to select the log category in Commence where E-
mail messages will be stored. To complete the setup, map each Outlook field that you wish 
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to capture to a Commence field in the log category. Commence uses this information to 

ensure that the contents of the E-mail message are stored in the appropriate fields in 
Commence. 

Mapping E-Mail 
Log fields

At minimum the following E-mail Log fields need to be mapped: For Contact, Message 
Date, Message Time, and Subject.  This will keep a brief record all logged e-mail 

messages without using additional disk space to store the full email message.

To configure your E-mail Log in Commence:

1 Select Edit -> Preferences -> Other Apps . From the Configure Commence as: Combo Box, 
select E-mail Log .

2 In the Category  list, select the Commence category where your Outlook E-mail will be stored.  If 
you plan to store the entire email message in Commence including attachments, you should 
choose a category that has at least one data file field.

3 Highlight the “Subject” field and press Edit .  The Commence Field  combo box will display all 
fields and connections from the category you selected in the previous step.  Select the Name 
field for this category and click OK. 

4 Select the “For Contact” field and press Edit .  Map this field to the category in Commence where 
E-mail addresses are stored for Contacts. 

5 Select the “Message Date” field and press Edit .  Map this field to "Date".

6 Select the “Message Time” field and press Edit .  Map this field to "Start Time".

7 The remaining fields are not required but recommended. See the chart below for a complete list 
of suggested field mappings. You may continue mapping fields from the selected category as 
needed.

8 Map the "Body" of the mail message in Outlook to any large Text field in the log 
category. With this information, full text searches may be performed on the email 
message. If there is no corresponding field in your Commence database you may skip it.  Only 
data from the mapped fields will appear in your Commence log item.

9 To store the message in its entirety, including attachments,  map the "Message File" 
field in Outlook to a Data File field in the log category. The e-mail can then be viewed 
as it was originally sent: as HTML, Microsoft Outlook rich text or plain text with all its 
attachments intact.

10 When the E-mail Log mappings are completed, click Done  to close the preferences dialog box.

11 Continue by setting the Commence preferences for Microsoft Outlook Contacts. This step is 
required before you can log any E-mail from Outlook.

Table 3-1: Recommended Field Mappings for Out look E-mai l  Log

Out look E-Mai l Suggested F ie ld  Type

Body Text ( large,  more than 80 chars.)

For  Contact  (Required)

Connect ion to category where E-mai l  
addresses are stored.  Incoming mai l  
wi l l  be l inked to the sender(s) .  
Outgoing mai l  w i l l  be l inked to  the 
rec ipient(s) .

Message Date  
(Requi red)

Date
E-Mail Logging: Setting Preferences in Commence
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Attaching logged 
E-Mail messages 
to a Contact

When you log E-Mail from Outlook, Commence will automatically attempt to connect the 
logged message to a Contact in the Commence database. This feature requires that you also 

set the preferences for Outlook Contacts. You do not have to actually synchronize your 
Contacts with the Outlook Address Book, but at minimum you should map the required fields.  
This gives you the flexibility to search for a matching Contact by E-mail address, First Name, 

Last Name, or Company Name.

To configure preferences for Microsoft Outlook Contacts:

1 Select Edit -> Preferences -> Other Apps . From the Configure Commence as: Combo Box, 
select Microsoft Outlook Contacts .

2 Only the minimum fields listed in Table 3-2 need to be mapped. For more detail, refer to the steps for 
mapping fields for Outlook “Setting Preferences” on page 26.

Selecting a folder 
for storing E-Mail 
messages

The E-Mail Log in Commence can be used to view a copy of the entire E-Mail message, 

just like in Outlook. To store the full email message including any attachments, the following 
steps should be taken:

1 When setting the E-Mail log preferences in Commence, be sure to map Outlook’s “Message File” 
field to the Data File field in the log category.

Note: This field mapping will be used when logging all incoming email messages (i.e. 
received messages addressed to you). When logging outgoing messages from your Outbox 
or Sent folder (i.e. messages sent from you), you may prefer to skip the attached .MSG file to 
minimize redundancy and disk space usage.  Select Commence Options -> Outgoing  from the 
Tools  menu in Outlook to change your Outgoing Email Settings. Uncheck the preference to 
"Save Email as MSG file". When adding the log item, Commence will ignore the "Message 
File" field mapping and log all other mapped fields.

Message Time 
(Requi red)

Time

Message Fi le Data Fi le

Subject  (Required) Name

Message Type

Select ion:  

• E-mail Sent

• E-mail Received

Table 3-1: Recommended Field Mappings for Out look E-mai l  Log

Out look E-Mai l Suggested F ie ld  Type

Table 3-2: Minimum Field Mappings for Out look Contacts

Outlook Contacts Suggested F ie ld  Type

Company Name Text

Emai l1  (Requi red) E-Mai l  Address or  Text

Fi le  As (Required) Name

First  Name Text

Last  Name Text
E-Mail Logging: Setting Preferences in Commence
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2 Confirm that the External Data File Directory  points to a valid path. This preference is set via  
Edit -> Preferences->Other . The full E-Mail messages (.MSG files) are stored in this 
directory. If the directory does not exist, an error message will notify you during the 
logging process to correct this problem before continuing.

3 Set the Synchronize Data Files preference to determine if the email message (.MSG file) will be 
synchronized or not. (Workgroup only).

The E-Mail message is copied in its entirety to Commence.  The logged message is not 

linked to your Outlook folders so deleting or modifying a message in Outlook will not 
affect the copy of that message stored in Commence.

In a workgroup environment, the current synchronization method is used to share and 
distribute the .MSG files to other clients.  Synchronization of the message file is 

controlled by the “Synchronize Data Files” option under Edit -> Preferences-> Database .

Note: Outlook 98 or 2000 must be installed on the same PC as Commence to read the .MSG file.

Verifying Commence Options in Outlook

Outgoing Mail By default, the content of the mail message and the original email will be copied to the 

specified fields in the database based on the E-mail Log mappings in Commence. When 
logging outgoing messages in Outlook, you can choose to store a minimum amount of 
detail to save space in the database.

1 Select Commence Options -> Outgoing  from the Tools  menu in Outlook to set the options 
listed below.

2 Click OK to close the dialog.

Note: These settings apply to outgoing e-mail only.

� Send Email: 

This option flags the email for delivery. This option is turned on by default to simplify 
logging newly composed emails. The email is sent automatically after it has been logged 
in Commence.  Messages that have already been sent will be resent.

%  Tip Before logging messages in the Sent Items folder, turn off the "Send Email" option to 

prevent the messages from being resent to the recipient.

� Map Email Content to Commence: 

This option reduces the size of the log entry by excluding the message contents.  

Checking this box will skip the Body  field from Outlook when mapping fields to 
Commence.

� Save Email as MSG file: 

This option reduces the size of the log entry by not saving the original email as a file 
attachment in Commence.  Checking this box will skip the Message File field from 

Outlook when mapping fields to Commence.

� Always show options with Outgoing Email: 
E-Mail Logging: Verifying Commence Options in Outlook
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If unchecked, the default settings for the above options will be used for every email export.  

Checking this option will give you an opportunity to change your preference during each 
export by opening the “Commence RM Outgoing Email Settings” dialog.

Incoming Mail Once you have logged an e-mail message from the Inbox or any folder in Outlook that 
contains incoming mail, the e-mail will then be accessible from the Commence database for 

review. You may wish to mark or delete logged e-mail messages in Outlook to distinguish 
them from messages that have not yet been processed.

1 Select Commence Options -> Incoming  from the Tools  menu in Outlook to set the options listed 
below.

2 Click OK to close the dialog.

Note: These settings apply to incoming e-mail only.

After Email Log:

By default, E-mails that have been successfully logged in Commence are moved out of the 
Inbox to the “Commence Archive” folder. The options listed in Table 3-3 are mutually 

exclusive; turning on one option automatically turns off the other.

� Skip any Email with no Contact match: 

This option does not process e-mail messages from Contacts that are not found in the 

database or where the E-Mail Address does not match the address of an existing Contact in 
the Commence database.

� Always show options with Log: 

If unchecked, the default settings for the above options will be used for every email export.  
Checking this option will give you an opportunity to change your preference during each 
export by displaying the “Commence RM Incoming Email Settings” dialog.

Database Before you begin logging, confirm that only one Commence database is open and that the 

database mapping preferences have been configured properly. Launch Outlook and open any 
folder containing e-mail messages.

Table 3-3: Options for  handl ing Incoming E-mai l

Option Descr ipt ion

Move Emai l  to the 
"Commence Archive"  
Folder

defau lt

Delete Emai l

Flags the e-mai l  to  be deleted f rom 
Out look af ter  i t  has successfu l ly  been 
logged in  Commence. Logged e-mai ls  
are moved to the “Deleted I tems” 
fo lder.

Mark As Read
Flags the e-mai l  as read af ter i t  has 
been logged in Commence.

Leave In Folder
Leaves the e-mai l  in the or igina l  
fo lder  in  Out look for fur ther  rev iew.
E-Mail Logging: Verifying Commence Options in Outlook
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If any of the  settings are blank or invalid, you should correct the preferences in 

Commence before attempting to export your Outlook email to Commence.

1 Select Commence Options -> Database  from the Tools  menu in Outlook to perform a prelim-
inary check. A message will alert you if a problem is found with the settings in Commence.

2 Once you have verified that the settings are correct, click OK to close the dialog.

Commence Database:

Points to the active Commence database.  Confirm that this database is the one that has 
been configured to receive e-mail logs from Outlook.  This setting can be changed in 

Commence by selecting the Edit -> Preferences -> Other Apps  command and updating the 
field mappings for the E-mail Log . See “Setting Preferences in Commence” on page 17 
for more information.

Contact:

Points to the Contact category in the active Commence database.  The E-Mail Address in 
this category is used to attach the logged e-mail to the appropriate contact(s) based on 
the “To:/From:” address in the email message. This setting can be changed in Commence 

by selecting the Edit -> Preferences -> Other Apps  command and updating the category 
and field mappings for Microsoft Outlook Contacts . See “Attaching logged E-Mail 
messages to a Contact” on page 19 for more information.

Outlook Email:

Points to the Log category in the active Commence database where the e-mail message 
will be stored. This setting can be changed in Commence by selecting the Edit -> Prefer-
ences -> Other Apps  command and updating the field mappings for the E-mail Log .

External File Directory:

This points to the directory where the .MSG file will be saved.  Confirm that the directory 

exists and that the path is valid. This setting can be changed in Commence by selecting 
the Edit -> Preferences -> Other  command.

Logging E-Mail in Outlook
All e-mail logging is initiated from Outlook. To facilitate this, a  new “Log to Commence ” 

button is added to the toolbar in Outlook during the Commence RM installation.

New E-mail To log new e-mail messages in Outlook to Commence:

1 Create a new mail message in Outlook. This can be done any number of ways, such as:

• double-clicking on the E-Mail address field in a contact item in Commence

• sending a letter to a contact in Commence using the E-mail option

• select File -> New Mail Message  in Outlook.  Address the message to a contact in the 
Commence Address Book.

2 Compose the mail message.

3 When you are finished, click the   button on the Outlook toolbar in the message. 
This will log and send the message by default.
E-Mail Logging: Logging E-Mail in Outlook
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4 If you chose to "Always show options with Log", a dialog will be displayed. Change the options as 
needed. Click OK to continue logging.

5 A confirmation message will appear indicating the message was successfully logged to Commence.

Finding a 
Matching Contact

When you log E-Mail from Outlook, Commence will automatically attempt to connect the 

logged message with a Contact in the Commence database. One of the following messages 
will be displayed telling you if the match was successful or not.

Exact match found or multiple matches found:  When one or more contacts in 

Commence contains a matching E-Mail address, one log item is created and connected to 
each matching contact.

No matches found: The message is not logged when both of the following conditions are 

met:

• the Email address of the contact does not match any contact in Commence

• and the option to "Skip any Email with no Contact match" is checked

Otherwise a dialog will pop-up allowing you to search the database for a matching contact. 

Click Find  to start the search. If after the search there is still no matching contact, you can 
still log the message by clicking Don’t Match .  This will add a log item that is not attached to 
any contact. 

Existing E-mail To log existing e-mail messages in Outlook to Commence:

1 Open Outlook to any folder containing email messages that have already been sent.

2 Select Commence Options -> Outgoing  from the Tools  menu in Outlook.

3 Verify that the "Send Email" option is not selected. Disabling it prevents messages in the 
folder from being sent again after being logged into Commence.

4 Select one or more email messages. Up to 30 messages at a time may be selected.

Note: Multiple messages cannot be selected in Outlook 98. Open each message to log each one 
individually.

5 Select the Tools -> Log to Commence  menu command in Outlook or click the   button 
on the Outlook toolbar.

6 Click OK to continue logging.

7 A confirmation message will appear indicating the number of messages that were successfully 
logged to Commence.
E-Mail Logging: Logging E-Mail in Outlook
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Chapter 4: Synchronization with 
Outlook

To configure a Commence database to synchronize with Outlook, you need to follow 

these steps:

• Prepare your database. To get the most out of the Outlook Sync you will need to modify your 
Outlook information, such as deleting duplicate items that appear in both Commence and Outlook.

• Modify your database . If you are using a custom database or a database that was 
converted from a previous version of Commence, you may need to modify your 
Commence Database to ensure that all required fields are available in Commence.

• Set Outlook field mappings.  Commence's preferences allow you to map Commence categories 
and fields to those required for synchronizing with Outlook Contacts, Calendar and Tasks.

• Set E-Mail preferences in Commence.  Commence can be configured as a MAPI 32-bit E-
Mail client in order to work seamlessly with Outlook. Select Edit -> Preferences  -> Other 
Apps . From the Configure Commence as:  Combo Box, select E-Mail client. From the Mail 
Program:  combo box, select MS Outlook or MAPI-compatible (32-bit) . Enter your E-Mail User 
Name and Password .

• Synchronize with Outlook.  Details for using the synchronization feature and for all of the 
necessary setup listed above are included in this chapter.

Prepare your Database

Check Calendar 
times

Verify that all calendar items have the end time set later than the start time. Outlook 
does not support appointments with the end time set incorrectly and will prevent the 

synchronization from completing. A new view of the calendar category can be created 
and filtered on items where the Duration field is less than 0 to determine if there are any 
items with an invalid end time value.

Check Calendar 
dates

The calendar synchronization feature is designed to synchronize appointments that 

occurred up to 30 days ago, or are scheduled to occur within the next 90 days. This date 
range may be customized. For more information refer to the topic titled “Calendar Date 
Range” on page 41.

Make sure the 
required fields 
contain values

When adding items to the Commence calendar, the required fields are Description, 

Start Date, Start Time, and End Time. When adding items to the Outlook calendar, be 
sure to enter a value for all of the fields above, plus the End Date. If this field is blank, 
the data will not synchronize properly with Commence. 
Synchronization with Outlook: Prepare your Database
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Caution: It is possible to add an item to the Outlook calendar with no Description filled in, however 
items without a Name are not supported in Commence and will cause the synchronization to stop.

For contacts, the only required field is the Name field-type. If an Outlook contact is added 
with no name, Outlook will automatically assign a name of "(unknown)" to the item. This will 
synchronize successfully and will be filed as "(unknown)" in Commence.

Check for 
duplicate items

When first synchronizing between Outlook and Commence, the feature is designed to copy 

all information present from each application to the other. If you have been copying infor-
mation manually from Commence to Outlook, or vice versa, the initial synchronization will 
cause duplicates to be created. You will need to delete the duplicate records in Outlook or in 

the Commence applications.

Note: A duplicate item is an item that is located in both Commence and Outlook that refers to the same 
information. For example, if both Commence and Outlook Contacts contain an item "Jane Smith" and 
both items refer to the same person, they are duplicate items. If the items refer to two different people, 
both named "Jane Smith", then they are not duplicate items. In either case, if the duplicate items are 
not deleted, you may have more items than expected after synchronization.

Modify the Commence Database
It may be necessary to add fields or make other custom changes to the database to 

integrate with Outlook. To make changes to your Commence categories and fields, select 
Tools -> Customize -> Database -> Category .  This dialog allows you to select the category and 
then add or edit fields as needed.

Prior to making any changes to your Commence database, it is important that you make a 

backup of your Commence database. Select  File -> Open/Manage Database  in Commence to 
backup the database.

If you are using the database in a Workgroup environment you may not have permissions 
to alter the database structure. If this is the case, contact your Commence administrator.

Special 
Considerations

The Title field in Outlook Contacts can optionally be mapped to a comparable selection 

field or text field in Commence. However, when mapping to a selection field additional steps 
must be taken to ensure that the choices available in the selection field match in both 
Commence and Outlook. When entering a new contact in Outlook, the selection field must be 

saved with a value, otherwise synchronization will stop.

 For example, Outlook allows the following values in the Title field: Dr., Miss , Mr., Mrs. , Ms., 
Prof.  If the Outlook Title field is mapped to a selection field in Commence, be sure to modify 
the choices in Commence to match those values exactly. In Outlook, the Title field is left 

blank by default, but Commence requires a value for all selection fields. Before synchro-
nizing with Commence, make sure all contacts in Outlook are saved with an appropriate title.

If data entry into Outlook contact fields does not follow a consistent format, these fields 
should be mapped to a text field in Commence ensuring successful synchronization.
Synchronization with Outlook: Modify the Commence Database
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Set Outlook Field Mappings
In order to copy data back and forth between Commence and Outlook, the fields in 

Commence must be mapped to the equivalent fields in Outlook. These field mappings will 
be used during the synchronization with Outlook to ensure that the data is stored in the 

appropriate field in each application. Only those fields that will be used need to be 
mapped. 

The Microsoft Outlook Contact preferences are used to: 

• find a matching contact when logging E-Mail messages from Outlook into Commence

• select the contact’s name and address when working with the Web Companion

• synchronize your contacts in Commence with Outlook Contacts

Before you can synchronize your calendar in Commence with the Outlook Calendar, the 
Microsoft Outlook Calendar preferences must be set. Likewise, setting the Microsoft 

Outlook Tasks preferences must be completed before synchronizing your To-Do list in 
Commence with the Tasks in Outlook.

Setting 
Preferences

To select which categories will be used to synchronize data with Outlook,

1 Select Edit ->  Preferences  -> Other Apps . From the Configure Commence as:  Combo Box, 
select either Microsoft Outlook Calendar  or Microsoft Outlook Contacts or Microsoft 
Outlook Tasks .

2 From the Category  Combo Box, select the Commence category that most closely matches the 
data in Outlook. To work with the Outlook Calendar, this category must contain a Date and Time 
field. To synchronize Outlook Contacts, this category should contain a field to store E-Mail 
addresses.

3 Double click on the desired Outlook Field on the left side of the form, or highlight the desired 
Outlook Field  on the left and select Edit .

4 Select the corresponding Commence Field  from the Combo Box. Select OK when done.

5 Repeat the steps above for any remaining Outlook fields that correspond to Commence Fields. 
Not all fields need to be mapped.

Caution: The NAME type field from Commence must be mapped. If a Clarify Field is defined for 
the category, that field should also be mapped to any equivalent field in Outlook.

6 When the desired Outlook fields have been mapped to Commence Fields, select Done  to save 
the configuration. If Commence detects that all fields have not been mapped, you will be 
prompted to re-configure the settings. You may select No if you have finished mapping all the 
necessary fields.

7 Proceed with the steps to “Set E-Mail Client Preferences” on page 29.

Table 4-1: Recommended Field Mappings for Out look Contacts

Outlook Contacts Suggested F ie ld  Type

Sync Condi t ion Select ion f ie ld or  connect ion to ( -Me-)

Assistant  Name Text

Assis tant  Phone Telephone
Synchronization with Outlook: Set Outlook Field Mappings
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Business Ci ty Text

Business Country Text

Business ZIP Text

Business State Text

Business St reet Text

Business Fax Telephone

Business Phone Telephone

Company Name Text

Emai l1  (Requi red) E-Mai l  Address

Fi le As (Required) Name

First  Name Text

Home City Text

Home Country Text

Home ZIP Text

Home State Text

Home Street Text

Home Phone Telephone

Job Tit le Text

Last  Name Text

Middle Name Text

Mobi le  Phone Telephone

Pager  Phone Telephone

Spouse Text

Ti t le Text

Homepage Internet Address (URL)

Table 4-2: Recommended Field Mappings for Out look Calendar

Out look Calendar Suggested F ie ld  Type

Sync Condi t ion Select ion f ie ld or  connect ion to ( -Me-)

Body Text ( large,  more than 80 chars.)

End Date (Required) Date

Star t  Date (Requi red) Date

Subject  (Requi red) Name

Star t  Time (Required) Time

End Time (Requi red) Time

Table 4-1: Recommended Field Mappings for Out look Contacts

Outlook Contacts Suggested F ie ld  Type
Synchronization with Outlook: Set Outlook Field Mappings
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Act iv i ty Type
Select ion:  

• Appointment

Table 4-3: Recommended Field Mappings for Out look Tasks

Out look Tasks Suggested F ie ld  Type

Sync Condi t ion Select ion f ie ld or  connect ion to ( -Me-)

Actual  Work Text

B i l l ing In format ion Text ( large,  more than 80 chars.)

Body Text ( large,  more than 80 chars.)

Categor ies Text ( large,  more than 80 chars.)

Completed Checkbox

Complete Date Date

Date Created Date

Due Date Date

Prior i ty

Select ion f ie ld:

• 1

• 2

• 3

• 4

• 5

Modi f ied Date Date f ie ld

Owner

% Complete

Private

Reminder  Set

Reminder  Sound

Reminder  Sound Fi le

Reminder  Date

Sensit iv i ty

Start  Date Date f ie ld

Status

Subject Name f ield

Team Task

Tota l  Work

Reminder  Time

Table 4-2: Recommended Field Mappings for Out look Calendar

Out look Calendar Suggested F ie ld  Type
Synchronization with Outlook: Set Outlook Field Mappings
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Using the Sync 
Condition

The Sync Condition allows you to specify a checkbox or connection field in your 

Commence category to determine whether an item is to synchronize with Outlook. The Sync 
Condition is found at the top of the list of Outlook Fields when using the Edit ->  Preferences -
> Other Apps  menu command. For detailed steps, refer to “Set Outlook Field Mappings” on 

page 26. If the Sync Condition is not mapped, all items in the category will synchronize. This 
option is useful if you have a large number of items in Commence that you don’t want to 
synchronize to Outlook.

If a checkbox is used, then the checkbox must be checked for the item to transfer to 

Outlook. If it is not checked, the item will not be affected by the Outlook synchronization. If 
you change the value of the checkbox from checked to not checked, the item will be deleted 
from Outlook.

If a connection is used, it must be a connection between the selected category and the 

category used by the Personal Information or (-Me-) item. If the item is connected to (-Me-), 
then it will synchronize with Outlook. The (-Me-) item is set using the Edit ->  Preferences -> 
Personal Info  menu command. Refer to the Preferences chapter in the Commence User’s 
Guide for more information.

Using the Activity 
Type

Activity type looks for a selection field with a value of "To-Do". This is used in cases where 
the Commence category that contains your to-dos is the same category used to hold your 
appointments. To-do items added from Commence must be set with an activity type of To-Do 

to synchronize with Outlook Tasks. Tasks that are added from Outlook will have the activity 
type automatically set to To-Do when they synchronize to Commence.

Set E-Mail Client Preferences
Commence must be configured as a MAPI 32-bit E-Mail client in order to synchronize with 

Outlook.

Configuring your 
E-Mail Login 

1 Select Edit ->  Preferences  -> Other Apps . From the Configure Commence as:  Combo Box, 
select E-Mail client .

2 From the Mail Program:  combo box, select MS Outlook or MAPI-compatible (32-bit) .

3 Enter your E-Mail User Name  and Password . Re-enter the password in the Verify Password  box. 
For 32-bit MAPI E-mail applications, the User Name is typically contained within a Profile. Determine 
the Profile Name for Microsoft Outlook and enter it into the box labeled User Name . (e.g., Microsoft 
Outlook Internet Settings)

Note:  If Outlook was installed using the Internet Mail Only option, MAPI will not be available. The User 
Name and Password should be left blank in this case.

4 When completed select Done  to save the configuration.

Act iv i ty Type
Select ion f ie ld:  

• To-Do

Table 4-3: Recommended Field Mappings for Out look Tasks

Out look Tasks Suggested F ie ld  Type
Synchronization with Outlook: Set E-Mail Client Preferences
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Synchronize with Outlook
The Commence synchronization with Outlook can be run manually by selecting a menu 

command or automatically at timed intervals using an agent. This provides the 
Commence user with the flexibility to synchronize data at anytime or at regular intervals.

The First 
Synchronization

When first synchronizing between Commence and Outlook, all items are copied from 

one program to the other. During this process, Commence keeps track of the information 
present in Commence and Outlook, and stores this information in a base file.

Subsequent 
Synchronizations

All data changes in either Commence or Outlook are transferred between each other. 
After the initial synchronization, Commence compares the information currently in 

Commence to the information stored in the base file. The comparison determines if the 
information is new, changed, or deleted.

• New Information . If an item is present in Commence but is not found in the base file, it is a new 
item and is added to Outlook.

• Changed Information . If an item is in Commence but is different from the base file, the item is 
edited in Outlook.

• Deleted Information . Any items that are found in the base file but are not in Commence are 
items that have been deleted, and are removed from Outlook.

This process is repeated, comparing the information found in Outlook with the infor-
mation in the base file in order to update Commence with the latest changes.

Synchronize On 
Demand

To manually synchronize information between Commence and Outlook:

1 Start Commence and open the database that is configured to synchronize with Outlook.

2 In Commence, select Tools  -> Outlook Sync . 

3 A dialog will be displayed showing the status of the synchronization between Commence and 
Outlook.

This command will synchronize all applications that have been mapped.

Note: If both the Outlook Calendar and Outlook Contacts preferences have been mapped in 
Commence, they will both be synchronized using this command.

Automatically 
Synchronize

An agent can be defined to synchronize with Outlook on a regular basis. It can easily 

be modified so the synchronization occurs at a different time.

Table 4-4: Sample agent

Set the opt ion be low. . . to  th is va lue. . .

Tr igger : Timer

Frequency: Dai ly,  a t  9 :00am

Trigger  i f  missed:  checked

Act ion A: Out look Sync
Synchronization with Outlook: Synchronize with Outlook
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The Outlook Sync action allows you to select either Contacts, Calendar, Tasks, or any 

combination of the three. If, for example, Contacts is selected but Calendar and Tasks are 
not, then only the Contact information will synchronize with Outlook. If the agent is designed 
to synchronize just the Calendar, this setting is enforced even if all of the Outlook prefer-

ences are mapped. If all actions are selected (Contacts, Calendar, and Tasks) then the agent 
functions the same as if the Tools -> Outlook Sync  menu command had been selected. 
Synchronization with Outlook: Synchronize with Outlook
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Chapter 5: Group Scheduling

Group scheduling of meetings takes into account the schedules of both Commence and 

Outlook users on the same screen, making it easier to find an available time for the 
meeting.

Note: Because the meeting is being scheduled in Outlook, the meeting will not be displayed in the 
Commence calendar until after you have synchronized Commence with the Outlook calendar.

Configuring Meeting preferences
To use Outlook’s meeting scheduler:

1 Select the Edit -> Preferences -> Meeting  command.

2 Choose "(Use Outlook) " from the Category drop-down list.

3 Click Done  to save the settings.

Scheduling Meetings
To schedule a meeting with one or more attendees:

1 In Commence, select Tools  -> Schedule Meeting . Microsoft Outlook starts and a meeting 
request form is displayed. Refer to the On-line help in Outlook for additional assistance.

2 Click the To:  button on the Appointment screen to open the Address Book. Select attendees and 
resources.

3 Determine a meeting time. 

4 In the Subject:  box, type a description.

5 Select any other options you want using Outlook.

6 Click Send. 

As soon as the Outlook meeting request screen is closed, Outlook will E-Mail your 

meeting request to all the attendees and resources that you selected so they can 
respond to the meeting invitation.

The next time you synchronize with Outlook, the meeting details will be copied to 
Commence.
Group Scheduling: Configuring Meeting preferences
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Chapter 6: Microsoft Outlook Address 
Book

The Address Book feature can be used with Microsoft Outlook 98 and later versions.  

Multiple mail systems such as MS Mail, Internet Mail, CompuServe, and AOL can all plug into 
Microsoft Outlook in order to provide a single, consistent interface for electronic mail. Since 
Microsoft Outlook operates as a front-end for multiple and potentially very different mail 

systems, there are some associated inherent problems. As an example, each mail system 
typically has its own address book, which leads to difficultly in locating an individual's 
address, as well as potentially redundant data.

For instance, if Fred has an AOL account, an Internet ID, as well as a fax machine, infor-

mation about Fred must be entered into three separate address books. Ultimately, it may 
require searching up to three address books in order to determine all the possible means of 
sending him a message. Not only is this time consuming, but frustrating as well.

Commence solves this problem by providing its users with a universal address book. A 

selected category within Commence may now be accessed by Microsoft Outlook for use as 
an Address Book for such applications as addressing electronic mail messages, faxing 
documents, etc. This eliminates the need to enter duplicate information into both Commence 

and Outlook.

Configuring the Outlook Address Book
To configure Commence to be used as the Address Book in Outlook, follow the steps 

below:

1 Set Commence Preferences for the Microsoft Outlook Address Book.  Commence's prefer-
ences allow you to map Commence categories and fields for use in the Outlook Address Book.

2 Add Commence to the Outlook Profile . Configures the Commence Address Book in the Windows 
Control Panel.

3 Configure Outlook to use the Commence Address Book . Choose Commence as the default 
Address Book for sending e-mail and faxes in Outlook.

Each step is described below.

Set Commence 
preferences

In order for Microsoft Outlook to access the correct address information within a 
Commence database, the fields used by Outlook must be mapped to the fields used by 
Commence. For example, Microsoft Outlook might use the field Last Name  for an entry's last 

name, while in Commence, the corresponding field may be labeled Name - Last . By mapping 
Last Name  to Name - Last , the correct information will be located. Only those fields that are 
to be used need to be mapped.

1 Select Edit -> Preferences  -> Other Apps . From the Configure Commence as:  Combo Box, 
select Microsoft Outlook address book .

2 From the Category  Combo Box, select the category that is to be used as the address book. This 
category should have an E-Mail field. Typically, this would be the Person/Company category. 
Microsoft Outlook Address Book: Configuring the Outlook Address Book
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3 Double click on the desired MS Outlook Type  field on the left side of the form, or highlight the 
desired MS Outlook Type  field on the left and select Edit .

4 Select the corresponding Commence Field  from the Combo Box. Select OK when done.

5 Repeat steps 3 and 4 for all remaining MS Outlook Type fields that are to map to Commence 
Fields. Only those fields that will be used need to be mapped.

6 When all MS Outlook Type fields have been mapped to Commence Fields, select Done  to save 
the configuration.

Adding the 
Commence 
Address Book to 
the Outlook Profile

After you have configured your Commence preferences, you should then configure the 
Windows Control Panel to recognize the Commence Address Book.

1 Run the Windows Control Panel .

2 Double click on the Mail and Fax  icon. 

3 Select the Add  button. A list of available services will be displayed. 

4 Highlight the Commence Address Book  selection. Select OK to add the Commence Address 
Book to the Outlook profile.

Note: Steps 5 through 14 configure the default Microsoft Outlook Address Book to be the 
Commence Address Book.

5 Select the Addressing  Tab. 

6 From the Show this address list first:  pull-down menu, select Commence Address Book .

7 From the Keep personal addresses in:  pull-down menu, select Commence Address Book .

8 Click on the Add  button. 

9 Highlight Commence Address Book  and click on the Add  button.

10 Click on Close .

11 The Commence Address Book is now shown in the list of Address Books for the When sending 
mail, check names using these address lists in the following order:  option.

12 Use the  button to move the Commence Address Book  to the top of the list.

13 Select OK.

14 Select OK again, and then close the Windows Control Panel.

Microsoft Outlook is now configured to use the information maintained within 

Commence as an Address Book, called Commence Address Book.

Using the 
Commence 
Address Book in 
Microsoft Outlook

Once Microsoft Outlook and Commence are properly configured as described in the 
preceding sections, outgoing faxes and electronic mail messages can be addressed 
using information found within Commence. Perform the following procedure to address 

an electronic mail message using the Commence Address Book.

1 If not already running, launch Commence. If Commence is not running, it will automatically run 
when Microsoft Outlook attempts to access the Commence Address Book.

2 Open the Microsoft Outlook Inbox icon on the desktop.

3 Compose a new mail message.
Microsoft Outlook Address Book: Configuring the Outlook Address Book
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4 Click on the To. . . button. The Address Book dialog box will be displayed. 

5 Select Commence Address Book  from the Show Names from the:  combo box. 

6 Microsoft Outlook accesses and displays the information stored within the Commence Address 
Book. Highlight the desired recipient, and click on the To-> or Cc-> button. Repeat for each To: and 
Cc: recipient.

7 When all recipients have been included, select the OK button.

8 Complete all remaining areas of the mail note as usual, filling in the Subject: line as well as the body 
of the message. When done, send the message.
Microsoft Outlook Address Book: Configuring the Outlook Address Book
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Chapter 7: Common Questions

General
Q: Can I synchronize Outlook with more than one Commence database?

A: No, this is not supported. Only one Commence database should be used to 

synchronize information with Outlook. If more than one database is used, data corruption 
may occur. If you need your Outlook information on more than one PC, such as at home 
and at work, use Commence’s Sync Link function. For more information on this feature, 

see the online help in Commence.

Q: I only want to synchronize my address book with Outlook. How do I prevent the 
Calendar and Tasks from synchronizing?

A: By clearing the field mappings, you can selectively disable portions of the Outlook 
synchronization. 

Perform the following steps to disable the Outlook synchronization for all but the 

Address Book:

1 In Commence, select Edit -> Preferences -> Other Apps .

2 Under Configure Commence as: , select "Microsoft Outlook Calendar".

3 Set the Category:  to (none). This option is listed first, above all available categories.

4 Under Configure Commence as: , select "Microsoft Outlook Tasks".

5 Set the Category:  to (none).

Q: Which versions of Outlook are able to synchronize data with Commence?

A: Outlook 98, Outlook 2000 and later versions.

Q: What happens if I edit the same item on both Outlook and in Commence?

A: Since information from Commence synchronizes first, changes made in Commence 
take precedence. If the same item has been edited in both Outlook and Commence, the 

changes in Commence will overwrite those in Outlook.

Q: What happens if I delete an item in Commence but edit it in Outlook?

A: Since deleted records cannot be edited, an item deletion always takes precedence.

Q: Can I use the Outlook Sync feature in a Commence Workgroup?
Common Questions: General
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A: Yes. The Outlook Sync will respect the permissions in the database. For example, if you 

do not have permission to delete an item, synchronizing with Outlook will not delete the item 
in Commence and you will be notified with an error. Note that items added within Outlook and 
synchronized with Commence are always added as local items. An agent can be added that 

will promote these items so they are shared with the workgroup.

Q: Can I map information from more than one Commence category to one of the Outlook 
databases?

A: No. The Outlook Calendar and the Outlook Contacts can each be mapped to a single 
Commence category.

Q: What will happen if an item has already synchronized to Outlook but then I set the Sync 
Condition to prevent that item from synchronizing with Outlook?

A: The item will be deleted from Outlook during the next synchronization, but will remain in 
the Commence category.

Contacts
Q: If I change the value of the Name field in Commence, will Outlook still know which item to 

modify when synchronizing changes?

A: Yes. The Outlook synchronization process assigns a unique identifier to every item that is synchro-
nized. This ensures that the correct item is modified during subsequent synchronizations.

Q: I currently store my names using one Name field in the format of "Last Name, First Name". 
Do I have to split the Name field into two separate Last Name and First Name fields?

A: No. You can map your Commence Name field to the Outlook File As field.

Q: I currently store my names using one Name field in the format of "Last Name, First Name". 
Can I split them into two fields?

A: Yes, you can do this either by editing the information manually, or by using Import/Export 

to another program to manipulate the data.

Calendar
Q: Why don’t appointments in Commence from several months ago synchronize with 

Outlook?

A: The Outlook Calendar link is designed to synchronize those items that have a Date 
value within the following range (inclusive): 30 days before today through 90 days after 
today. Any items that are scheduled on dates before or after that range will not synchronize. 

This date range may be customized. For more information refer to the topic titled “Calendar 
Date Range” on page 41.

Q: What will happen If I reschedule an appointment for next quarter?

A: If the appointment has already synchronized, it will be deleted from Outlook during the 

next synchronization. As the scheduled date approaches and the appointment is scheduled 
to occur within the next 90 days, the item will then synchronize with Outlook.
Common Questions: Contacts
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Tasks
Q: My tasks from Outlook are synchronizing to Commence, but none of my To-Do’s from 

Commence are going to Outlook. Why is that?

A: If your Appointments and To-Do’s are stored in the same Commence category, then 
make sure you have also configured your Outlook Task preferences to use the Activity 

Type field. Once this is set, tasks that are added from Outlook will have the activity type 
automatically set to To-Do when they synchronize to Commence. However, to-do items 
added from Commence must be set (either manually or using a script) with an activity 

type of To-Do before they will synchronize with Outlook Tasks. If you need assistance 
with customizing your database, Commence Corporation can supply you with a list of 
Business Partners in your area or you may contact Commence Professional Services at 

(877) COMMENCE.
Common Questions: Tasks
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Appendix A: Special Cases

Outlook Calendar and Tasks

Recurring dates Recurring dates from Outlook are not supported. Only the first occurrence of the item will 
synchronize and appear in Commence. 

For the most compatibility, is recommended that all recurring appointments and tasks are 

added from Commence.  These items can then synchronize with Outlook.

Multiple day 
appointments

Commence does not support appointments that span more than 24 hours. These items will 
not synchronize to Commence. As a workaround, you may create a recurring appointment 
from Commence where the start date and end date spans the entire duration of the 

appointment.

Workgroup Considerations
The Outlook field mapping preferences are are synchronized to all clients in a Commence 

Workgroup during the initial enrollment. Afterward, any changes to the mappings will not 
synchronize and must be configured at each individual client. Refer to Chapter 4 to complete 
the necessary configuration for Outlook integration.
: Outlook Calendar and Tasks
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Appendix B: Re-starting the Outlook 
Synchronization

In some circumstances, you may need to re-start the link to Outlook from the 

beginning. Such circumstances include:

• Outlook has been uninstalled and reinstalled

• All Outlook data has been deleted

• Data in Commence cannot be found

Re-starting the synchronization is accomplished by removing all previously created 
base files causing Commence to treat the next synchronization as if it were the first. 
Follow the steps below to re-start the synchronization.

1 Open the Commence database that has been configured to synchronize with Outlook.

2 Determine the directory where the Commence database is located. Select Help -> System 
Information . From the Display list, choose Directory Information . Take note of the first line 
that shows the name of the active database followed by the path. The path shown is the location 
of the Commence database.

3 Using Windows Explorer, open the directory determined in step 2.

4 Below this directory will be a directory labeled Outlook.

5 Below this directory should be one or more of the following files:
COISCal.dmt-> used for synchronizing Calendar items
COISCon.dmt-> used for synchronizing Contacts

6 Rename each *.dmt file to *.old. If you are having problems with a specific link, such as the 
Contacts list only, you can rename the .dmt file for just that link.

7 When you synchronize again, it will behave as an initial synchronization and all information in 
Commence will transfer to Outlook and vice versa. 

Note: You will need to follow the steps in Chapter 3 of this manual to remove duplicate items in 
Outlook before retrying the synchronization.
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Appendix C: .INI File Settings
The DATA.INI file is an initialization file located in the database directory and maintained 

by Commence. It is automatically updated when you perform various operations using the 
menu commands and dialog boxes in Commence. You should only edit this file on rare 
occasions if you need to customize the settings stored in this file, or if instructed to do so by 

Commence Technical Support.

To locate the DATA.INI, first determine the path to your data. Run Commence and open 
your database. Then select Help -> System Information . Choose to Display: Directory Infor-
mation . Find the name of your database and take note of the path to the right. 

The Outlook integration feature in Commence stores various settings in the [Outlook]  

section of the DATA.INI file. Those settings are described below.

Schedule Meeting Preference
When you set the Meeting preferences in Commence to use the scheduling feature found in 

Outlook, this will change the value of ScheduleMeeting keyword. A value of 1, True , or On 
indicates the preference is set to (Use Outlook) . 

[Outlook]

ScheduleMeeting=1

Calendar Date Range
The calendar synchronization feature is designed to synchronize appointments that 

occurred up to 30 days ago, or are scheduled to occur no later than within the next 90 days. 
This date range can be customized as needed to increase or decrease the number of days in 

the range.

[Outlook]

CalDaysPast=#

CalDaysForward=#

CalDaysPast This keyword is used to specify the number of days in the past to consider when synchro-
nizing Calendar items. Calendar items that are scheduled within that range will synchronize 
with Outlook. The default value is 30 (meaning 30 days before today). Allowable values are 1 

to 32767.

CalDaysForward This keyword is used to specify the number of days in the future to consider when synchro-
nizing Calendar items. Calendar items that are scheduled within that range will synchronize 
with Outlook. The default value is 90 (meaning 90 days after today). Allowable values are 1 

to 32767.
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Appendix D: Outlook Error Messages

Synchronizing Calendar, Contacts, and Tasks
The following are the possible errors that can occur when synchronizing information 

between Commence and Outlook. All of the errors will be displayed in the active.log. 
When the error occurs, you can select the Message Log button in Commence, or at a 

later time, double-click on the active.log file located in the database directory. Each of 
these errors will stop synchronization from continuing. To restart synchronization, correct 
the problem and retry the synchronization process.

Info 805 An error occurred during synchronization with Outlook. Check the Message Log 
for more information.  The synchronization with Outlook did not complete successfully. 

If you selected Tools -> Outlook Sync , more information about the error can be found by 

selecting Help -> Message Log  from Commence. When using an agent to synchronize with 
Outlook, more information can be found in the ACTIVE.LOG file located in the data 
directory. If the log file does not contain sufficient information, close Commence and 

restart using a command line option of /TRACE. 

Confirm that all required fields contain data. The name field in particular cannot be left 
blank. Review the section titled “Prepare your Database” on page 24 to make sure that 
the data being synchronized meets all the guidelines.

Info 806 Synchronization with Outlook was cancelled. Commence was unable to continue 

because the operation was cancelled by the user.

Info 807 Microsoft Outlook could not be loaded; verify that the required version of Outlook 
is installed. Outlook must be installed on the same PC as Commence. Review the 

section titled “Requirements” on page 2 for more information.

Info 808 Could not logon to Microsoft Outlook; verify that your email preferences are set 
correctly. Commence was unable to login to Outlook. Review the section titled “Set E-

Mail Client Preferences” on page 29 for more information.

Info 809 The Outlook integration services could not be loaded. A problem was encountered 

while loading the program files necessary for synchronizing Commence with Outlook. Try 
reinstalling Commence.

Info 810 The Outlook preferences should be configured using the Edit-Preferences-Other 
Apps dialog before using this command. The Tools -> Outlook Sync  command cannot 

be used until after the Outlook Calendar or Outlook Contacts preferences have been 

configured. Refer to the section titled “Set Outlook Field Mappings” on page 26 for a list 
of required fields that must be mapped.
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Logging E-mail

Info 1700 Outlook is not running. Please start Outlook before trying to log email into Commence.

Info 1701 There is a problem with the registry settings within Commence. Please try reinstalling the 
latest version of Commence.

Info 1702 Outlook is running as a background process. Please start Outlook \nbefore trying to log 

email into Commence.

Info 1703 The following message \n\nFrom:\t%1\nSubject:\t%2\n\nhas an invalid email address.

Info 1704 The Commence database configuration has changed since the last log.

Selected Email message(s) will be logged to the following : There is a problem writing to 
the Commence Outlook Email Integration registry CMCDB key for ""%1"" value.

Info 1705 There is a problem writing to the Commence Outlook Email Integration registry CMCInCfg 

key for ""%1"" value.

Info 1706 There is a problem writing to the Commence Outlook Email Integration registry CMCOutCfg 
key for ""%1"" value.

Info 1707 The ""%1"" contact field must be mapped in order to log to Commence. Please map this 
field in Commence and try again.

Info 1708 The 'Name' field for the Commence category selected for Microsoft Outlook Contacts must 

be mapped. Please re-configure this in Commence by using the menu selection in Edit-
>Preferences->Other Apps.

Info 1709 The 'Name' field for the Commence category selected for E-mail Log must be mapped. 
Please re-configure this in Commence by using the menu selection in Edit->Preferences-

>Other Apps.

Info 1710 The directory specified for External Data Files cannot be created. Please re-configure this 
in Commence by using the menu selection Edit->Preferences->Other.

Info 1711 The application cannot create the Commence Archive folder in Outlook. Please try to 
create this folder manually under the Outlook Today folder or change the Commence Inbox 

options.
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Info 1712 A problem was encountered writing to the category mapped for E-mail logging in 
Commence.

Info 1713 The following message \n\nTo:\t%1\nSubject:\t%2\n\nhas an invalid email address. 

Info 1714 There is a problem retrieving the active database name from Commence.

Info 1715 There is a problem accessing the category used for Microsoft Outlook Contacts. Please 
verify that this is configured in Commence by using the menu selection in Edit->Prefer-

ences->Other Apps.

Info 1716 There is a problem accessing the category used for E-mail Logging. Please verify that 
this is configured in Commence by using the menu selection in Edit->Preferences->Other 
Apps.

Info 1717 There is a problem accessing the directory path for External Data Files. Please verify 

that this is configured in Commence by using the menu selection in Edit->Preferences-
>Other.

Info 1718 A problem has been encountered calling the method %1.

Info 1719 A Commence category must be selected to be mapped for Microsoft Outlook Contacts. 

Please configure this in Commence by using the menu selection in Edit->Preferences-
>Other Apps.

Info 1720 A Commence category must be mapped for E-mail Log. Please configure this in 
Commence by using the menu selection in Edit->Preferences->Other Apps.

Info 1721 There was problem while trying to modify the '%1' field in Commence. Please check the 

category used for E-mail logging.

Info 1722 The Commence E-mail Log has encountered an error.

Info 1723 The field mapped to the ""Name"" field of E-mail Log has not been entered with any 
data, please check the email or check the configuration of E-mail Log in Commence by 

using the menu selection in Edit->Preferences->Other Apps.

Info 1724 The field mapped to the ""Name"" field of E-mail Log may be a duplicate name entry, 
please check the email or change the category mapped to the E-mail Log to allow for 
duplicate name entries.
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Info 1725 The item that you have selected is not an email message. This item cannot be logged to 
Commence.

Info 1726 The items that you have selected are not email messages. These items cannot be logged 

to Commence.

Info 1727 Some of the items that you have selected are not email messages. These items cannot be 
logged to Commence.

Info 1728 There must be at least one name or distribution list in the To, Cc or Bcc box. 
IDS_MISSING_RECIPIENTS
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