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Chapter 1.
Introduction

Photo Albums On The Web

Whether it’s for businesses or for personal needs, taking and sharing photographs
has become an essential part of everyday life. More and more families are
separated by distance and many people live thousands of miles away from their
loved ones. It’s tough to stay in touch with your different schedules and time
zones, so you need a better way to keep everyone close to you, even if that
closeness is digitally created. That’s why we created Photo.Web! Email is
wonderful, but a picture is worth a thousand words and with Photo.Web, you can
instantly share your life with those people who mean the most to you.

Your purchase of Photo.Web means that right now you can stop saving your shoe
boxes and use your closet shelves to store really important things — like shoes!

Since the invention of the camera, people just like you have taken thousands of
pictures. They have photographed the important events in the lives of their
families, their vacations, beautiful sights, their friends, and their cherished
belongings. But all of you photographers share a common problem — what do you
do with all the pictures that you accumulate? So, you bought pairs and pairs of
shoes just so you would have a place to store your photos. Those shoe boxes sure
come in handy. They fit neatly in the closet, sit on top of each other and don’t
take up too much room. The problem with shoe boxes is that you never know
where a particular picture is when you want it, so you have to go through all those
shoe boxes every time you want a particular picture.

Another problem with shoe box storage is that you always meant to send Aunt
Tillie those great pictures of the baby cutting his teeth, but it seems you got busy
and the ‘baby’ is about to graduate from high school! Or, maybe, you’re just like
us. We take many rolls of pictures on our trip, run to have them developed, ooh
and aah over them and then store them away in our closet, never looking at them
again, until one day, when the shoe box topples off the shelf.

Photo.Web easily solves all your ‘photo’ problems. Now you can store your
pictures in one safe place and share them with you friends and family in just a few
easy steps! With Photo.Web, you can create one or many photo albums by
creating your own Web site. Now you can safely store your photos on a server,
sharing them instantly with your friends and family around the world.

Not only does Photo.Web store your developed photos, you can transfer pictures
to Photo.Web from a scanner, floppy disk, digital camera, the Web or even your
VCR. It may sound like a lot of complicated work, but in just a few minutes you
will create your first Web-based photo album. So, email your nearest and dearest
and tell them to watch for your personal Web site, coming soon to a monitor near
them!
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Introduction to Photo.Web

Photo.Web is just what it sounds like — your personal photo albums stored on the
Web. It was designed for ‘beginners’ but advanced users will love using its
features. You can create one album or different albums. You can organize your
albums by your interests or your children or your vacations. It’s your choice. You
can add text to a photo if you like and the pages ‘turn’ just like a regular photo
album. Add or remove pictures as often as you like, update your albums and
create new ones. You can customize your album covers and the pages with
whatever interests you, and, the best part is, you can instantly share your
memories with your loved ones and friends.

Look at the advantages of Photo. Web.

e Photo.Web is your solution to the age old problem of what to do with “shoe-
box” pictures.

¢ Photo.Web stores your pictures in organized electronic photo albums.

e Photo.Web will create your personal Web site and become your Web host
provider. For Free! (See Web-hosting details in the Chapter titled “Boomer-
ang Software Products and Services.”)

Documentation Conventions

1-2

The following documentation conventions were applied when putting this User
Guide together:

¢ Commands you are asked to type and specific content you are instructed to
enter are indicated in a sans-serif font, such as: CD\TEMP. Ignore any
punctuation included unless specified otherwise.

e Keystrokes, or individual keys that you are asked to press or type are
indicated with bold, all capital text, such as: ALT, F1, TAB, ENTER.
Ignore any punctuation included unless specified otherwise.

¢ When you are asked to select more than one menu option in sequence, the
options are separated by a greater-than sign (>). The instruction “Select
Format > Object > Properties” asks you to complete these steps in
sequence: (1) select the Format menu; (2) select the Object option in the
Format menu; and (3) select the Properties option in the Object menu.

¢ When you are asked to “select,” “click,” or “double-click” with the mouse,
use the /eft mouse button. In some cases, you will be instructed to “right-
click.” If you have reversed the configuration of the mouse buttons in
Windows, you should reverse the button instructions in this User Guide.

e When you are asked to “select” or “highlight” an object, item, or icon, click
on it once. In some cases, the object selected will be surrounded by blue or
the prevailing “active” Windows system color.

Note: Program operations can be launched by using one of these methods:
(1) clicking on sequential menu option selection, as described above; (2)
clicking on a program button icon from a toolbar; (3) selecting an item or
object, right-clicking and selecting a program option from a pop-up menu; and
(4) pressing a single or combination shortcut key.

ooo Photo.Web Deluxe User Guide



Chapter 2.
Installing Photo.Web

System Requirements

Before installing Photo. Web, make sure that your computer meets the following
minimum system requirements:

A personal computer with a 166/200 MHz. processor with Windows 95, 98,
2000, NT (4.0 or higher), Windows Me or Windows XP installed, with a mouse

16 Mb. of RAM and 150 Mb. of free hard disk space

A printer and printer driver compatible with Windows 95, 98, 2000, NT (4.0
or higher), Windows Me or Windows XP (if you want to use Photo.Web’s
printing features)

A CD-ROM drive for installation

SVGA monitor and graphics card or better

SVGA video card set to True Color (24-bit or 32-bit) mode with a resolution
of 800 x 600 or higher

“Auto-Run” Installation Welcome to

It is recommended that you turn off any virus ‘p | ] J i ) ' :’ J
checking software that may be running in the

background during the installation. Since the Y "" !

program set is provided on CD-ROM and is Jnstauaﬂan = .f =7}
thoroughly checked before the CD is made, i :
the chances of getting a virus from the ...} e B’é‘
installation are extremely small. When done, — “Eeanifes Eoenmcbfires el

you can turn all such programs back on to Figure 2.1 — Installation Title
restore your computer to its normal operation.

Photo.Web installation uses an “auto-run” installation that starts when you insert
the CD-ROM in the drive. If the installation program does not open automati-
cally, use the manual installation procedure described in the next section.

Manual Installation

To open the Photo.Web installation program manually, follow these steps:

1.

With the CD-ROM in the CD drive, select Start > Run. In the Run dialog
box, select Browse. The Browse dialog box appears.

Click the drop-down arrow next to Look in. From the list of available
drives, select the CD-ROM drive. The list of available files appears.

Select the file Setup.exe and click Open. The Run dialog box reappears.
Click OK. The installation program is now running. The Welcome to
Photo.Web title screen appears followed by the Welcome dialog box. Be
sure to close any open programs before continuing with the installation. When
done, click Next. The Software License Agreement dialog box appears.

After reading and accepting the terms of the agreement, click Yes. The
Choose Destination Location dialog box appears.
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5.

The Choose Destination Location dialog box indicates the default
Destination Folder, X:\Program Files\Boomerang
Software\Photo.Web, where X: is the primary hard drive on your system.
For most users, the primary hard drive is C:. If the default folder does not exist
in your system, Photo.Web will create it for you. To change the default installa-
tion location, select Browse. The Choose Folder dialog box appears.

The default Path can be deleted, enabling you to enter a different directory
location and folder. If you have already created a target directory or folder
(other than the default selection), use the Directories section to navigate to
the new folder. When done, click OK. If the folder does not currently exist,
Setup prompts you to confirm the folder destination. To continue, click Yes.
The Choose Destination Location dialog box reappears. Your directory
path and folder is displayed in the Destination Folder section. To
continue, click Next. The Select Program Folder dialog box appears.

Type (or select the Program Folder) that you want to create and click Next.
To launch your program easily, Setup places your program shortcut icons in
the program folder that you specify. The Installation program is now
launched. A status dialog box appears along with several product description
screens. Installation requires one or two minutes to complete.

When done, the Setup Complete dialog box appears. Click Finish. Your
installation is now complete!

To launch Photo.Web

Select Start > Programs > Boomerang Software > Photo.Web.

Registration

The first time you start Photo.Web, the Online Registration dialog box appears.

To register by Internet

1.

You may Register by Internet, which is the easiest way to register if you
have a browser installed on your system. Select Next. The Online
Registration form appears.

Fill out the registration form completely. When the form is filled, select
Next. Your Browser connects to the registration Web site and completes the
registration process in less than a minute. A confirmation message displays.
Select Finish. Photo.Web opens and displays the default Web site project
screen display.

To register by Calling on the Telephone

1.

2.

If you choose not to use the Register by Internet method, you may call
Boomerang Software office at 617-489-3000. Be prepared to give the
following information over the telephone: Name, Company, address, email,
telephone, fax, and the dealer from whom you purchased Photo.Web. Hours
of operation are Monday through Friday, 9 AM to 5 PM EST.

When you call, state that you want to register your Photo.Web application.

That’s it! You have now installed and registered your copy of Photo.Web. The
next step is learning to use the software. Photo.Web offers you several choices to
create your albums, however we will start with the easiest and fastest way, using
the Wizards.

ooo Photo.Web Deluxe User Guide



Chapter 3.
How Does Photo.Web Work?

Definitions

Photo.Web works by creating Web pages along with some associated resource files.

Web Page. A Web page is an HTML file that contains directions about
what to display.

Resource File. A Resource File is any file (including the HTML file) that
is used with a Web site. These can include page files (*.HTM file), image
files ( *.GIF or *.TIFF files) and others.

How does Photo.Web Create a Photo Album?

To present your photo album pictures on a Web page, Photo.Web creates an
Album Object.

An Album Object is selectable object on a Web page. This object has specific
characteristics. These include:

Album Style. Album Style defines a border style. Each border style has a
different character. Use album style to give your album site a particular look
that reflects the content of your photographs.

Page Turning Mode. When an Album Object is displayed in a browser, it
sequentially displays photographs in the order that you specify. As it moves
between photographs, the album “pages” appear to turn. This “page turning”
effect is created by special programming. There are four page turning
modes, Standard, Smooth, Mosaic, and Cool. Each of these Page Turning
Modes creates a different “look” when displayed in a browser. Use Page
Turning Mode to specify the page turning “look” that you want viewers to see.

Note: While an Album Object creates the appearance of several pages that
turn in succession, only one Web page is being displayed in the browser.
This is important to keep in mind, since you will want to go to a specific Web
page, rather than to a specific Album Page. Album ‘pages” are only page
representations used to display your photographs.

Important! The “page turning” effect uses a Java applet. This means that
your viewer’s browser must be one of the latest versions that supports the
use of Java applets. Use Netscape Navigator (NN) versions 4.5 or higher or
Internet Explorer (IE) versions 4.0 or higher. Browser versions earlier than
4.5 (NN) or 4.0 (IE) may not necessarily support Java and may result in a
browser error that prevents the viewer from seeing your pictures.

Sequence of Photographs. This is the sequence of photographs that
you want to appear in the photo album. When you specify this sequence of
photos, you are sequencing a series of image files to display one after the
other.

Important! A photograph is an image resource file that is used with an Album
Object. To work, the Album Object accesses image resource files that you
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specify. To change the placement of an image in your album, you reposition
the image resource file in the album listing.

What Will My Photo Album Web Site Look Like?

While you can specify the “look” of your Web site, every Web site has a number
of common elements that define it as a “Web site.” These include:

Graphically, a Photo Album Web site can be illustrated —

(see Figure 3.1). The Home Page is the doorway into @ne

your Web site. It holds the highest position in your =age

Web site. One level down are the Photo Album Web HomePage
pages linked to the Home Page. These Web pages are =
considered “children” to the Home Page. This is

important to keep in mind, since several program A A A
options default down from “parent” to “child.” In g g g
Photo.Web, each Photo Album Web page contains Family  Friends
only one Album Object. While it is possible to insert

Home Page. The Home Page is the first page that visitors see. This page
normally has a title and some additional text that describes the contents of
the Web site.

Links. These are the navigation tools that help a visitor get from one page
in your Web site to another. Links are very important. Without them, all of
your visitors would be stuck on the Home Page!

Note: With Photo.Web Deluxe your page links are automatically inserted as a
navigation bar (or “NavBar,” for short). NavBars use the Logical Layout page
name to identify where a Web site visitor will go when they click on a NavBar
link. NavBar links are automatically updated whenever you change the logical
name or whenever you add a new Web page.

Photo Album Web Pages. Photo Album Web pages are Web pages that
contain an Album Object. These are the Web pages that your visitors have
come to see! Normally, these pages have a cover title that describes what
visitors should expect to see. Photo Album Web pages really have two parts:
the Web page (that serves as the background for the photo album) and the
Album Object itself (that displays the pictures you want your viewer to see).
Photo Album Web pages are also called “Album Pages” later in this User
Guide.

more than one Album Object onto a Web page, it’s

easier to plan a Web site around the idea that each Figure 3.1 — Web Site
Photo Album Web page contains a single Album

Object. Of course, links must be provided to carry visitors back and forth
between the Home Page and each of the various Photo Album Web pages.

3-2

Note: It is recommended that Web sites be kept to a two-tier Logical Layout.
NavBar links are designed to provide links to parent, children (and sibling)
pages. If you insert a third-level page, the NavBar links for the “parent” page
will automatically be updated to include a child link that goes down to the third
level, while the newly generated “child” page will contain links to parent page
and sibling pages. NavBars are only available if your site is a Template or
Wizard generated one, or if you insert an Album page using the Add Album
button on the Logical Layout toolbar.

ooo Photo.Web Deluxe User Guide



Chaptfter 4.
Getting Started

Selecting an ISP and a Web-Hosting Service

To arrange hosting services, you will need access to an Internet Service Provider
(ISP) or a Web-Hosting Service Provider. These two providers are not the same.
However, while most ISPs do offer Web-hosting services, most Web-hosting
providers do not specialize in Internet access accounts.

Boomerang Software provides 2 megabytes of space for your albums on its
servers for free. Your free site will be in the www.PhotoRing.com community.
You must be a registered user of Photo.web to qualify, must use Photo.web to
build and publish your album-site, and must abide by the rules of
www.PhotoRing.com. Refer to the www.PhotoRing,.com site for more details on
the amount of space, pricing, terms and policies, which can change at any time.

If you want to place your Album on the Boomerang Software servers, Photo.web
connects to the servers, automatically opens an account for you (if you do not
have one) and publishes your album.

What is an ISP?

An ISP is the provider that connects you to the Internet. They offer
services such as email, dial-up or direct access, and of course, the
capability to surf the Web. With an ISP, you gain full access to the World
Wide Web. Normally, this means that you set up an account and make a
connection between your PC and the ISP’s server. With this connection,
you can surf the Web. To make this connection, most people use a modem
(Dial-up Account). However, if you want to get fancy, you could have a
dedicated line that connects your PC to an ISP-server. What is important
is not that you have one or the other kind of networking, but that you
know how you are going to establish your connection with your ISP by a
modem or through a dedicated line.

What is a Web-Hosting Service Provider?

A Web-hosting service provider, also known as a Web-hosting company, is
company that hosts Web sites on the Internet for others. Their only customers are
those who want to put a Web site on the World Wide Web. They are not looking
to give Internet access to individuals. That’s the job of an ISP! They are only
looking to provide hosting services to individuals (or companies) who want to
“publish” a site on the Internet.

Selecting an ISP

In most cases, you need to have an account at an ISP to have access to the
Internet. If you are currently a customer of America Online (AOL), you have
already selected an ISP; however, you should know that you might not be able to
use AOL as a Web-hosting service. Web sites may have specific hosting require-
ments (such as, 100% compatibility with ASP technology) that AOL may not be
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able to satisfy. If you are not a customer of America Online, then you must find
an ISP that gives you the features you want. Typical features to look for in an ISP
include monthly cost, email service, connection method, speed of transmission,
and ASP support.

Selecting a Web-hosting Service

Before looking for a Web-hosting service, you must decide whether you want to
create a full-domain Web site or a sub-domain Web site. A full-domain Web site
is a uniquely identified Web site using a licensed URL (for example,
www.yourname.com). A sub-domain Web site is a uniquely identified Web site
that leases space under a preexisting Community URL (for example,
www.ISPdomainname.com/your name). When making the full- or sub-domain
decision, you must consider how you intend to advertise your Web site. Most
companies seek to have a full-domain Web site, since it more specifically
advertises their company. However, sub-domains may not require a yearly fee and
may be attractive to you. Boomerang Software web hosting services provide both
full- or sub-domain solutions. Visit

www.boomerangsoftware.com/webhosting/webhosting.htm for details.

If you choose to set up a full-domain Web site, you will need to choose and
register your full-domain URL before uploading your Web site to a hosting
service. To search for and verify the availability of a domain name you like,
access the “WHO IS search?” function from any of the domain name registration
services. Companies charge a yearly fee for registering your own full domain
name. Costs and quality of service may vary. Contact

webhosting@boomerangsoftware.com for preferred or suggested registration

services.

To better evaluate your Web-hosting service, you should be concerned with a
number of generic factors not specific to your Web site. These include:

e Method of access. You will access your Web site via the World Wide
Web, using a browser or an FTP application. If your Web-hosting service is
not your ISP, you will be limited by your ISP mode of access, and not your
Web-hosting service mode of access. Web-hosting companies usually run on
faster lines than ISPs.

e Download transfer. Normally stated as MB (megabytes) or GB (gi-
gabytes) per month which, roughly translated, is a measure of total pages
downloaded per month by Internet users (or you can think of it as total
number of hits per month). If you anticipate a high rate of usage, some
companies will tack on an additional charge for usage that exceeds the
standard offer. Some sites offer unlimited download transfer, but you must
verify exactly what that means before signing up.

e Storage space offered. Normally, storage is offered as so many
megabytes (or gigabytes) per site for a flat rate. This is one of the major
variables in selecting a Web-hosting service. If you anticipate a large
number of graphics, then you will need more storage space.

¢  FTP capability. It may sound obvious, but you have to send files over the
Internet via FTP. Any Web-hosting service that does not offer this should not
be used.
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Tech support. You will want to ask about tech support. Normally you
will not need much tech support, but when you do it is a great thing to have.
Tech support concerns issues such as Internet access failures (customers
cannot call up your site); FTP failures (specific images or pages not being
displayed), file retention and back procedures, and Web site installation
(including security). A good service should offer tech support in these areas.

Domain name registration. If you want to have a full-domain Web site
and also want help registering it, many Web-hosting companies offer
registration services to assist you. You can do this on your own, but it’s
often nice to get a little help along the way.

Initial set-up fees. Most companies will assess an initial set-up fee.
Depending upon the provider this may or may not apply to sub-domain Web
sites.

Hosting Requirements

A Web site may have some very specific requirements that you must be aware of
when looking for a Web-hosting service provider. These requirements are
summarized below.

Minimum Storage Space. To insure a maintenance-free Web site, the
minimum space requirement is 5 Mb. for every 50 photographs. Graphic
images are data intensive and require a lot of storage space.

Site Security and Folder Security. You will want to insure security
over your Web site. That means your Web site administrator will have to
place access restrictions on your entire Web site during development, and
more specifically, on your Administration folder and Database folder once
you decide to publish your Web site. Make sure you select a Web-hosting
provider that will correctly set up security.

Additional Graphic Development Services

To prepare your images for uploading, you might want investigate any of the
following products and/or services that allow you to generate digital images.

Digital Film Processing. Most film processors allow you to request
digital output. That means that once your conventional photographic film is
developed, it is transferred to digital format, usually by scanner. When you
go to pick up your pictures, you will receive a CD or floppy disk that you
can put into your floppy disk reader. Each image is a separate file.

Digital Cameras. Rather than using conventional photographic film, you
can now by digital cameras that produce nothing but digital images. These
cameras write images to a flash cards or floppy disks. This is probably the
simplest solution, one that, most likely, will become extremely common in
the future.

Scanners. Another popular alternative is the scanner. Scanners are
peripheral devices that you attach to your computer (along with some
software) that enable you to generate digital images from any flat paper
image. Scanners are optical readers that translate conventional images into
digital format.
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¢ Duplication and Conversion Services. Ifyou have a shoe-box full of
images that you want to put into digital format, it might be easier to submit
them to a service provider who specializes in digital conversion. If you look
in the phone book, under computer services, you will most likely find several
companies specializing in media duplication and conversion. They will be

more than happy to take your shoe-box and return to you a complete set of
digital files.

If you use either a digital camera or a scanner, that is Twain compliant, Photo.Web
can upload your images directly, rather than writing them to disk first. The
process is called “acquiring” an image. It can save you a lot of time since you
eliminate the additional work required to write the image to disk. For more
information see the chapter titled “Acquire and Select Source.”

Browsers and Browser Preferences

What’s a browser? A browser is a software program that interprets HTML code.
Everyone who accesses the Internet must have a browser program installed.
When developing your Web site, be aware that Photo.Web comes with an internal
browser. However, you may want to view your Web site using one of the more
popular Web browsers, such as Netscape Navigator or Internet Explorer.

Setting a Browser Preference

By specifying (or changing) the default browser, you can preview your Web site
through any one of the commercially available browsers.

To set your browser preference

1. Select File > Preferences. The Preferences dialog box appears.

2. Click the Browsers tab. The Browser and Web-Promote ficlds appear.
3. Inthe Browsers section, click Add. The Open dialog box appears.

4.  Point to your preferred browser’s executable file and click Open.
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What is a Photo Album Web Site?

A Photo Album Web site is a Web site that has one or more photo albums
assessable from a Home Page. Each album is one Web page with navigation
buttons that sequentially opens a series of image files that you specify. When you
create a Photo Album Web site, you must have a Home Page and a Photo Album
Web page (also called an Album Page). The Home Page contains navigation links
that take you to the Album Page and each Album Page contains navigation
buttons that sequentially open a series of image files. Each Album Page must
also contain a navigation link to take the viewer back to the Home Page.

Starting a Project

Photo.Web allows you to begin a new project in any one of three ways: (1) using
a template file, (2) using a blank file, or (3) using the Photo.Web Wizard.

To launch Photo.Web

e Open your Photo.Web application by selecting the Start > Program >
Boomerang Software > Photo.Web. The Photo.Web Title screen
appears, followed by the Getting Started screen.

About the Getting Started Screen

The Getting Started screen is an introductory screen that only appears when

you first launch Photo.Web. Use this screen to decide what you want to do. Your

choices are:

e Wizard. Launches the Wizard. Use this to create a new Photo Album Web
site.

¢« Template. Opens a Template. Use this to create a new Photo Album Web
site using a template.

Templates will be Getting Started
described i detail |
1;2?“ ec t more detal Select Option to Get Started

*  Open File. Opens an f \ (-iis \
existing Photo.Web file ] Sk
from your hard disk. —
Use this to update an . Wizard Templates g
Album site that you A L P N e ol
have already created.

* Blank. Opens a blank A ~
Photo.Web file. Use Q_ T
this to create a new g i D
Photo Album Web site Orpen file Bh"‘ k8

that has no predefined
features.

Figure 5.1 — Getting Started
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Each of these choices will be described in more detail once you have created your
first Photo Album Web site.

To start a new project using a blank file or a template

1. After launching the program, select Template from the Getting Started
screen. The New dialog box appears with the “Web Site” tab selected.

2.  Click the Library Name drop-down arrow. A list of libraries appears.

Note: The first template in each library is a blank template.

3. Decide what you want to do:

e To open a template file, select the template you want to use and click
OK. The template is opened. The Site Manager—Logical Layout
window appears.

e To open a blank file, select the blank template (with the X) and click
OK. The blank template is opened. The Site Manager-Logical
Layout window appears.

Note: To open a template quickly, double-click the preview graphic. To open
a blank template you could also select Blank from the Getting Started screen.
The Blank option prevents the New dialog box from appearing.

Template Files

Template files are predesigned Web sites. There are four template libraries from
which to choose: Personal, Kids, Family, and Albums. Each library has at least
three template files from which to choose. When you open a template, Site
Manager appears. Click the Logical Layout tab. Many templates have an
Album Object on the Home Page. Most Templates also have two or more
additional Web pages. Each additional Web page contains only one Album
Object. Template files are designed to use as is. That means no additional Photo
Album Web pages should be added.

To update a template, follow the instructions provided in the Instruction Box.
When you are done, delete the Instruction Box by selecting it and pressing
DELETE. To replace any of the predefined text, click and drag over the text to
select it and then type your new text. Your new text will replace the predefined text.

Site Manager Windows

The Site Manager is one of the most important parts of this program. Unlike
other programs, Site Manager in Photo.Web is not a separate module or program.
It is an integral part of the program and acts as a foundation upon which you build
and manage your entire Web site.

There are two Site Manager windows: Site Manager—Physical Layout and
Site Manager-Logical Layout.

¢ Logical Layout. The Logical Layout window provides a graphical display
of the arrangement of the album pages in a site. The display arranges the
album pages as an “organization chart.” This makes it very easy to see how
the site is organized, particularly when determining which pages are
“parents” or “children” of other pages. In Photo.Web, you are only allowed
to create a two-tier Web site, so every page is a child of the Home Page.
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Figure 5.2 — Logical Layout Window

¢ Physical Layout. The Physical Layout window shows an alphabetically
arranged “tree” of the files and folders for your Web site. This resource tree
is organized and operates in a fashion similar to Windows Explorer.

Note: The program stores all of the Physical Layout information in a single
file. This simplifies the management of your Web site. The folders and files
that you see in the Physical Layout window are not “formally” created until
you generate (or upload) the site.

Window Naming Convention. The naming convention used in the title bar to
identify the content of an open window is “Photo.Web <CNQ file name> -
Web Site - [<logical page name> - <HTML Title>]” If more than one copy
is open “: <Copy #>” is added to the Logical name and HTML Title.

Window elements. Depending upon the window opened the following elements

can be seen:

e Title bar. Indicates the CNQ file that is open and the logical name for the
page being displayed. See “Window Naming Convention” above.

e Menu bar. Indicates the menu opetion available from the current screen.
There are separate options for Site Manager and Page Editor. Page Editor
options are object sensitive. Depending upon the object inserted (or
selected), some options become available while others become unavailable.

e Main toolbar. Appears across the top of the Page Editor window below the
Menu bar and indicates the program functions that are available with all
screens.

¢ Window toolbar. Appears near the bottom of the screen and indicates each
of the various project windows currently open.
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Help/Status bar. Appears at the bottom of the Page Editor window
displays a Help tip for any toolbar button or menu option.

Logical Layout Window elements: To view the following elements, click the
Logical Layout tab on the Site Manager window frame.

Logical Layout Organization Chart. This is graphical display of the
arrangement of the album pages in a site. Use this display to open individual
albums for editing. To open an album in Page Editor, double-click on it.

Logical Layout toolbar. Use this toolbar to perform a variety of

procedures, by clicking on the toolbar icon. All toolbar functions are also

available using the Logical Layout menu commands. The toolbar icons

include:

e Zoom In. Increases the magnification view of the Logical Layout
window.

e Zoom Out. Reverses Zoom In. Displays more of the picture.

zoom out new new rename visual global search  global
| album | | settings spelling
|

|
e

zoom in actual size delete  properties site visual global
settings replace

Figure 14.3 — Logical Layout Toolbar

e Actual Size. Returns the Logical Layout window display to normal.

¢ New Album. Adds a new album page to the Web site. Select the
Home Page and click on the New Album icon. A new album page is
inserted. If no page is selected, the program adds a new page above the
Home Page.

e New. Adds ablank page to the Web site. Select the Home Page and
click on the New icon. A new page is inserted. If no page is selected,
the program adds a new page above the Home Page.

¢ Delete. Deletes a logical page from the Web site.
¢ Rename. Renames a logical page in the site.

¢ Properties. Opens the Properties dialog box. Set the properties for a
page including title and alias. For more information, click the dialog
box Help button.

e Visual Settings. Opens the Page Visual Settings dialog box. Use
this to set the visual style settings for an individual album. These
include background color, link color, and page margins. For more
information, click the dialog box Help button.

e  Site Visual Settings. Opens the Web Site Visual Settings dialog
box. Use this to set the visual style settings for entire Web site. These
include background color, link color, and page margins. For more
information, click the dialog box Help button.

Note: In general, you will want to establish visual settings by album rather
than for the entire site. This will create more visual interest.
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Figure 5.4 — Physical Layout Window

e Global Search. Opens the Find dialog box. Use this dialog box to
search the entire Web site for a specific text string.

e Global Replace. Opens the Replace dialog box. Use this dialog box
to search and replace the entire Web site for a specific text string.

e Global Spelling. Opens the Spelling dialog box. Use this dialog box
to spell check the entire Web site for misspelled words.

Physical Layout Window elements: To view the following elements, click the
Physical Layout tab on the Site Manager window frame.

¢ Physical Layout resource tree. This is a listing of all the resource files
used to create your Web site. As you will discover, developing a Web site
means managing a variety of resource files that, when uploaded to your Web-
server, create the site. Photo.Web makes managing your resource files easy
by automatically storing them where they need to be. The folder icons on the
resource tree operate like Windows Explorer. They can be expanded or
collapsed to either hide or reveal a folders content.

¢ Physical Layout toolbar. Use this toolbar at
to perform a variety of procedures, by clicking icr;ea Z delete
on the toolbar icon. All toolbar functions are i |

also available using the Physical Layout menu e L
commands. The tc;golbar ic}c;ns inclu}c/le: o ﬁl G/ a<|
e Create Folder. Creates a new folder cr;ate renlame
that you can use to store selected folder
resources. The new folder is given the . .
default name “Folder” plus a number. Figure 5.5 — Physical
Layout Toolbar
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You can type a new name for the folder in the space provided.

e Create Image. Creates a new image file and opens Graphic Editor.
To do this, first select an existing folder. The icon becomes active.
Next, click the Create Image button. The Image Properties dialog
box appears. Use this dialog box to specify the image file you want to
create. When done, click OK. The new image file is inserted. The new
image file is given a default name. To rename this file, type a new name
in the space provided. To open the file, double-click on it. The image
file is opened in Graphic Editor.

¢ Rename. Renames any folder or file in the Web site. When you click
Rename, the name editor is activated enabling you to type a new name.
To exit the rename feature without renaming a resource, press ESC.

. Delete. Removes the selected folder or file from the Web site.

Resource Icons on the Physical Layout Resource Tree

The Physical Layout Resource Tree lists several different icons. These include
Folder icons, Web page icons, Image file icons, a Java icon, and a NavBar icon
To understand and read your resource tree the following resource hierarchy
applies:

Root folder. This is the root folder that sits at the top of the resource tree. By
default it is named “WebSite.”

Page icons. These are the Web page representations. A Web page can contain
display text, an album object, or other objects. To update your display text, or
select an album object for update, double-click on the Page icon that you want.
The Web page contents will be displayed in Page Editor.

Photo Album folders. These folders have a camera icon overlaid on a folder
icon and are used to store the image files associated with a single album object.
By default, Photo Album folders have the same name as the page to which they
are associated with the addition of “PhotoAlbum.”

Photo Album image files. These image files have a camera icon overlaid on a
blue image file. Each Photo Album contains two image files: one for the
navigation button that the viewer clicks to turn the album pages and one for
album border that “frames” the images that you insert. These image files are
created when you select an album style.

Photo folders. These folders have a small film clip icon overlaid on a folder
icon. These folders are sub-folders that store the image files that are displayed.
By default, a Photos folder has the same name as the Web page to which it is
associated with the addition of “Photos.” These folders have a small film clip icon
overlaid on a folder icon.

Photo image files. These image files have a small film clip icon. These files
are directly below the Photos folder. These are the photographs that appear when
the photo album is being viewed.

If an album object has been placed on a page, the page icon will be followed by
its associated Photo Album folder. If no album object has been placed on a page,
it will be followed by another Page icon. Every Web site has one Java Applet
icon and one NavBar icon. These icons contain special programming that enables
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the album object to display and updates the page navigation links. By default the
Home Page is named “Index.” If an Album Object has been placed on the Home
Page, the album folder is named “HomePagePhotoAlbum” rather than
“IndexPhotoAlbum.”

Page Editor Window

The Page Editor is where you prepare your album for viewing. Because each
album is displayed as an object on Web page, Page Editor lets you design your
Web page however you want. When you insert an album, the album comes with
several files that enable it to work. Each album comes with a separate graphic
files for the album border and the navigation buttons that are used to sequentially
opens a series of image files that you insert. These image files, when opened in a
browser, will appear to “turn” like individual pages in a photo album as the
viewer moves through the album pictures. From Page Editor you can add text to
the base page, update the page links, or insert an image that will appear as part of
the base page.

To open an album page in Page Editor

¢ From Site Manager—Logical Layout, double-click the album page you
want to open. The Page Editor window appears. Maximize the window as
desired.

W, PhotoWeb Deluxe - [Untitled] - Web Site - [w/ithFamily]

EI File Edit ‘iew Format Insert Effects Tools Table Library QrQLinks Window Help e

DB J[=] 2]2] ble||mwose TSI 2| 22| ] M&
DA =] 0N k] =]

L TEMPLATE TIPS =
Main Toolbar To add photos to album:
1. Click on album to select it. Menu Bar

2. Click the Add Photo(s) - S hutton in the Photo Alhum
| Photo Album Toolbar | Toolbge or uze the Format/Ohject/Add Photo(s)... menu.
3 Mizert photos in the Add Photo(s) dialog boz, by:
- clicking Add... to choose ready-made phaotos,
- chicking Acquire... to scan photos

Instruction Box | 4-Click OK to apply added phatos
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Figure 5.6 — Page Editor Window
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Page Editor Window elements: The following elements can be seen on the
Physical Layout Window:

¢ Instruction Box. This only appears on a template. This short set of
instructions helps you identify what you need to do to set up an album using
a template. Delete this after adding your pictures.

¢ Photo Album toolbar. Use this toolbar to perform a variety of procedures

by clicking on the toolbar icon. All toolbar functions are also available using
the Format > Object menu commands. The toolbar icons include:

Change Style. Opens the Change Style dialog box. Use this to
change the album style.

Add Photos. Opens the Add Photo(s) dialog box. Use this to add
album photos.

Delete Photo. Opens the Delete Photo(s) dialog box. Use this to
delete album photos.

Replace Photo. Opens the Replace Photo(s) dialog box. Use this to
replace album photos.

Add/Edit Photo Comments. Opens the Add/Edit Photo
Comment(s) dialog box. Use this to add/edit a pop-up comment to a
photo.

Select Source. Opens the Select Source dialog box. Use this to
select the source device prior to acquiring an image through a peripheral
device.

Acquire Photos. Opens the Acquire dialog box. Use this to acquire
an image using a peripheral device such as a scanner or digital camera.
Preview. Previews the selected album object. Use this to preview
your images prior to generating and uploading your site to a Web-
server. This option does not launch your internal browser.

1
add photo r;ﬁiize Ss(?u:; preview
| 5= 05| |k =
| | | I
change delete  add/edit acquire
style photo photo photo
comments

Figure 5.7 — Photo Album Toolbar
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Creating a Single Album Site With the Wizard

What’s a Wizard?

A “Wizard” is an easy way for a beginner to generate a final product. You simply
follow the directions on the screen and the system does the work for you.

Using the Wizard to Create a Photo Album

Create a very simple album using the Wizard. Your album will have two pages of
photos and no text. Everything you learn by creating this simple album will be
used with more complex albums. The steps to create an album are very simple:

e Step 1 of 5-Select the album(s) you want.
e Step 2 of 5—Assign each album an album style and place the album pictures.

e Step 3 of 5-Name your Home Page.

e Step 4 of 5-Specify a title for your album cover(s).

e Step 5 of 5-Review the page listing.

When using the Wizard, each step has its own dialog box. When done, you

generate and upload the site to a Web-server. That’s how you make your album
site available on the Web.

To launch the Wizard

1. Open Photo.Web by selecting the Start > Program > Boomerang
Software > Photo.Web. The Photo.Web Title screen appears,
followed by the Getting Started screen.

2. Select Wizard. The Step 1 of 5 dialog box appears.
Step 1 of 5-Select the album(s) you want.

The screen displays a list of album topics and a sample photo. By default the first
topic, Family, is selected.

Step 1 of 5 Options. Select any one of the listed albums. Each album creates a
single page with navigation buttons that sequentially opens a series of image files
that you specify. These image files, when opened, will appear to “turn” the
individual album pages as the viewer moves through the album. By selecting an
album, you are selecting an album library that contains page designs that will
enhance the display of your photographs. For example:

e Family. The album library associated with this option contain page designs
that are relaxed and family-friendly.

¢  Friends. The album library associated with this option contain page
designs that are more cover different kinds of social events.

To select the default album

e Click Next. The Step 2 of 5 dialog box appears.
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Step 2 of 5—-Assign each album an album style and place

the album pictures.

This dialog box identifies the album you have selected and a sample of the photo
album style currently selected. By default, Album Style 1 is initially selected
whenever this dialog box is first opened. This is an important screen because you
will be using it to select your pictures and to assign a page turning style for your album.

Step 2 of 5 Options. The following options are selected using this dialog box.

Album Style. There are twenty-two different album styles from which to
choose. Album style assigns a border style. Each border has a different character.
Use album style to give your album site a particular look that reflects the content
of your photographs.

Page Turning Mode. There are four page turning modes, Standard, Smooth,
Mosaic, and Cool. By default, Smooth is selected.

e Standard. Pages appear all at once with each click of the navigation button.
e Smooth. Pages appear to roll as they are turned.

¢ Mosaic. Pages appear to dissolve into a multitude of pieces and are
reconstructed when the next page appears.

e Cool. Pages appear as 3-D images while the pages turn over.

Fit to Edges. You can elect to have the photos enlarged to fit the photos to the
edge of each page. If you have a horizontal image, the left and right edges will
touch the album border. If you have a vertical image, the top and bottom edges

will touch. If you leave this option unchecked, your photos will be unchanged,
that is, the photo size is determined by the image file and not by the program.

Note: Images can be of any size. You may want to preview your images before
inserting them, especially, if the images have been customized in some way.

To assignh each album an album style, a page turning style and
a fit to page option

1. From the Step 2 of 5 dialog box, select an album from the Selected
Albums list.

Select an album style from the Album Style listing. A preview appears.
3. Decide if you want to use that album style or select another.

e To select another, click a different album style.

e To use the selected style, go to Step 4.

Specify the page turning style you want to assign.
5. Decide if you want to use the Fit to Edges option.

¢ To automatically resize the image, place a check mark in the Fit to
Edges check box.

e To leave the images as they are, leave the Fit to Edges check box clear.
6.  When done, click Choose Photos. The Choose Photos dialog box appears.

Choose Photos Dialog Box

Use the Choose Photos dialog to locate the photos you want to insert. Your
photos must be stored on your hard disk or be available using a peripheral device,
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Check the albums you want lo include
in the site:

Page Turning Mode
Standard € Mosaic ol

™ Fitto edges The album contains 0 photo(s)

Figure 6.1 — Wizard Step 1 of 5
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Figure 6.2 — Wizard Step 2 of 5

such as a digital camera or scanner. If you want to acquire images using a
peripheral device, see the chapter titled “Acquire and Select Source.”

The Choose Photos dialog box is divided into two major areas. The top area
provides information about your hard drive and images that you want to insert.
The bottom area provides information about the image files you have selected for
use with the currently selected album. The image file listing displayed in the
bottom indicates the order in which your photographs will display. To better
understand this dialog box, the following field descriptions are provided:

File and Folder display area. Provides a listing of files and folders that
you can select.

Image Preview area. Provides a preview of the currently selected image
file when Preview checked.

Look In. Identifies your computer’s hard drives and folders. Use this to
navigate between drives and folders.

File Name. Identifies the currently selected file. If you know the file name,
you can type it directly rather than selecting it.

Files of Type. Identifies a type of file. Use this to list photographs in different
file formats. By default, the option, All Importable Files, is selected.

Add. Adds the selected file to the album listing.

Add All. Adds all of the files displayed in the File and Folder display area
to the album listing.

Up. Moves the selected file up one position.

Down. Moves the selected file down one position.

Delete. Deletes the selected file from the album listing.

Delete All. Deletes all of the image files from the album listing.

Acquire. Activates the Acquire feature. See the chapter titled “Acquire and
Select Source” later in this User Guide.

To place pictures into an album from your hard drive

1.

Photo.Web Deluxe User Guide —

From the Choose Photos dialog box, click the drop-down arrow next to
Files of Type and select the file format for the image files you want to insert.

Note: By default, the option, All Importable Files, is selected.
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6.

Click the drop-down arrow
next to Look In and navigate = i [Soer o & =
to the folder that currently

stores file(s) that you want to
insert. PoANTWHERE gv\jnm

Using File and Folder
Filepame: | Add P Preview

display area, verify that the = e froere 5
file(s) that you want to insert aain
are displayed. L B

L
Decide how you want to 5
insert the files. e

fein I Preview

. To insert the files one at o B

a time, select each file
and click Add. The file Figure 6.3 — Choose Photos Dialog Box

W Freview

Help

is added to the album listing.

e To insert a series of files all at the same time, hold down CTRL and
click each file you want. When done, click Add. The selected files are
added to the album listing in the order that you selected them.

*  Toinsert all of the files in the File and Folder display area all at the
same time, click Add All. All of the files are added to the album listing
in the order in which they were displayed in the File and Folder
display area.

When done, click OK. The Step 3 of 5 dialog box is reactivated. Notice

the screen now says “The album contains <total number> photos.”

When done, click Next. The Step 3 of 5 dialog box appears.

Step 3 of 5-Name your Home Page.

This dialog box identifies the Home Page default title and lets you customize the
text and font.

Step 3 of 5 Options. The following options are selected using this dialog box.

Home Page Title. The default title is “Attend our Photo.Web Site.” Insert a
new title by selecting and typing a new title.

Font. Opens the Choose Web Font dialog box. Use this dialog box to select the
font that you want to use.

To name your Home Page

1.

From the Step 3 of 5 dialog box, type your Home Page Title in the
highlighted area. The new title appears on the top right of the screen
preview.

To change the font size and style, click Font. The Choose Web Font
dialog box appears.

Use the Style list to select the HTML font style. Click the font attributes
you want to assign using the Font Attribute check boxes.

To change the font size default, click the font size that you want to assign
from the Font Size list.

When done, click OK. Dialog box Step 3 of 5 reappears. The new title
text and font style appears on the top right of the screen preview.
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Photo Album Wizard - Step 3 of 5

Insert the title test for the Home
Page of your Photo Album on the Jr——
Web

Photo Album Wizard - Step 4 of 5

Select an album t specify the text for
front cover

My Digital Album
e e wan h

Eont Erter the front cover kext
<Back [ Hews | Fish | Cancdl | Help Font...

Figure 6.4 — Wizard Step 3 of 5

<gock [ Mets | Fwsh | Camed | HeR

Figure 6.5 — Wizard Step 4 of 5
6. When done, click Next. The Step 4 of 5 dialog box appears.

Step 4 of 5-Specify a title for your album cover(s).

This dialog box identifies the default title for your Photo album and lets you
customize the cover text and font. If you created more than one album, more than
one album would be listed.

Step 4 of 5 Options. The following options are selected using this dialog box.

Select an Album. Identifies the album title. This title is the same as the album
name selected in Step 1 of 5. To change an album title, see Step 5 of 5.

Enter Front Cover Text. Insert cover text for the selected album by typing in
the space provided. If you created more than one album, more than one album
could be selected and cover text assigned to each. Cover text appears at the top of
the album page when generated. The default font style appears in the preview
area just below the input line.

Font. Opens the Choose Web Font dialog box. Use this dialog box to select
the font that you want to use.

To insert cover text for an album

1. From the Step 4 of 5 dialog box, select the album that you want from the
album listing. If you inserted only one album, then the album is selected for
you by default.

2. Type in the cover text for the selected album using the Enter Front Cover
Text input line. The new text appears in the preview line below it.

3. To change the font size and style, click Font. The Choose Web Font
dialog box appears.

4.  Use the Style list to select the HTML font style. Click the font attributes
you want to assign using the Font Attribute check boxes.

5. To change the font size default, click the font size that you want from the
Font Size list.

6.  When done, click OK. Dialog box Step 4 of 5 reappears. The new font
style appears in the preview line.

7.  When done, click Next. The Step 5 of 5 dialog box appears.
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Step 5 of 5—-Review the page listing.

This is the last step in the Wizard. Review the page listing and change the name
associated with each Photo Album Web Page if you want.

Note: The Home Page is not listed here since it does not contain a photo album.

Step 5 of 5 Options. The following options are selected using this dialog box.

Web Page selection. Identifies
the default Web page title. This et o
title is the same as the album name | teibungbietPase:
selected in Step 1 of 5. If you
created more than one album, more
than one Web page is listed. By
default every site has a Home Page.
It is not listed here. The Home
Page title was assigned in Step 3 of | teammodieubedom
5. The navigation link for the
Eomf Pagﬁ uses the title “Home gk | oo | [ Fown ]| cees | e |
age” in all cases.

Photo Album Wizard - Step 5 of 5

. Figure 6.6 — Wizard Step S of 5
Modify Page Name. Insert a

new page name for the selected album by typing the text desired in the space
provided. If you created more than one album, more than one album could be
selected and a new page name assigned to each. Page names appears as naviga-
tion buttons on each set of automatically generated navigation links. Page names
are also the Logical and Physical names given to each Web page resource.

To review the page listing and rename selected albums

1. From the Step 5 of 5 dialog box, select the album that you want. If you
inserted only one album, then the album is selected for you by default.

2. Type the new Page name in the space provided.

Note: A page name cannot contain spaces or any of the following characters:

“LAVY[ H@D

3. When done, click Finish. The Preview, Upload, or Generate dialog
box appears.

Deciding How You Want To Continue

To help you see your album site quickly, the Wizard offers you three choices:

e Preview the album site on your PC browser (which keeps all of your
resource files on your local PC in one CNQ file),

¢ Upload the album site to the server (which transfers your resource files to a
remote Web-hosting computer), or

e Generate the album site to your local PC (which lets you selectively upload
files to a remote Web-hosting computer) and edit the album site by returning
to the program.

It is recommended that you preview your album on your PC before uploading any
files to a remote server.

Note: To avoid problems, it is highly recommended that you use the following
strategy when making updates to your site. Once you create your site, by
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generating and uploading it to your server—to make changes—do not import
the site from your server or make changes directly on the server. Rather,
open your Web site’s CNQ file from your hard disk and make your changes to
the CNQ file. Then, after completing your changes and saving your file,
regenerate and reload your entire site to your server. By keeping your
resource files together in one CNQ file, potential confusion is minimized.

Preview, upload or generate

To complete your Web site

To preview the Album on your PC brawser select Preview.

ge neration Ta upload and place the Album on pour Intemet server select Upload
° From the PI"eVieW, Upload, & Preview the Album/Site on your lacal PC browser
or Generate dlalog bOX, click " Upload the Album/Site to the server
Preview The Web Site iS ™ Generate the Album/Site on your lacal PC. Return to program for editing

temporarily generated and the
Home Page is displayed in your
default browser. You may now
view your Web site as any Figure 6.7 — Preview, Upload or Generate
Internet visitor would, or click Dialog Box

on the Site Manager window to edit your Web pages.

Note: Previewing your site requires a great deal of free space. If you are
having difficulty during preview, verify that you have at least 100 MB of
available free space on your hard disk, before trying to preview again.

Saving Your Files

By default, Photo.Web saves your Web site in CNQ format whenever you execute
a save. To initially save your Web site project:

1. From any screen display, select File > Save or click Save on the Main
toolbar. The Save As dialog box appears.

Enter the name for your project.
3. Specify the directory location for your file.
Click OK.

Launching a New Web Site on the Internet

As a Photo.Web user, you can receive free server space by using Boomerang
Software as your Web-host service provider. To use this service, your Web site
must be stored as a sub-domain under the Boomerang Software domain name
i1 i Knilcico@Ofca . This URL is managed by Boomerang Software for its
customers. For more information, see the chapter titled “Boomerang Software
Products and Services.”

Generating and Publishing your Album (site)

When you are ready to take your site to the Internet, you must use either Generate
Site or Upload Site. Both of these features are options located on the File menu.

Generate Site takes your albums and creates all of the necessary files and
folders automatically in a local directory. Once you complete site generation, all
of your files are ready for you to upload.

Note: You should always save a copy of your album Web site project file on
your local hard drive. To make changes to an uploaded album on the Web,
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make your changes to your local CNQ file and then generate and upload the
changed file. Your changed files will replace the old files on the Web-server.
Never make changes directly to an uploaded Photo Album Web Site using
previously uploaded server files.

Where Generate Site creates files and folders on your hard disk, Upload Site
only generates files to your remote Web-server. No need to clutter up your hard
drive, take your Web site files directly to your Web server!

Generating A Web Site

Use Generate Site when you want your Web site files stored locally on your
PC. Remember: The files created by Generate Site are upload-ready; however,
you must use an FTP program to upload them to your server.

Once you save your photo album, you are ready to generate your site. This
operation creates and places your Web site files where you specify on your hard
disk. It is recommended that you generate it to another directory or folder
separate from the location of the CNQ file.

Note: Generating your site requires a great deal of free space. If you are
having difficulty during generate, verify that you have at least 100 MB of
available free space on your hard disk, before trying to generate again. This
amount depends upon the size of your album(s).

To generate your site prior to upload
1. Create a new folder title “My WebSite” on your hard drive.
2. To save your file prior to upload, select File > Save.

3.  When ready, select File > Generate Site. The Browse For Folder
dialog box appears.

4. Navigate to and select the folder “My WebSite” that you created.

Note: The Generate Site feature creates and places all the sub-folders and
files necessary for your Web site in the selected folder. To learn the Physical
size of your site after generation, use Explorer’s “Folder > Properties”
command. The folder size is listed under the General tab.

5. Click OK. The program begins processing. This may take some time. When
finished, the message The site has been successfully generated appears.

6. Click OK. Your Web site files are generated.
You can now verify the size of your Web site EeoseFober
prior to'upload by using Explorer’s “Folder > EE=)E) =
Properties” command. To upload your Web site ] e
files from your PC’s hard disk to a remote Web- g dsbesg
server, you must use a separate FTP program. --8 sgts

= Ceddriv

. . . =22 Chis
Publishing your Album (site) -
(-0 Gold 2000 UG FINAL TO PRINTER

Use Upload Site when you want your Web e
site files stored on your remote Web-server. TS e T =
Once you save your photo album, you are ready iR Careel |
to upload your site.

Note: Uploading your site requires a great Figure 6.8 — Browse for Folder
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deal of free space. If you are having difficulty during upload, verify that you
have at least 100 MB of available free space on your hard disk, before trying
to upload again. This amount depends upon the size of your album(s).

To upload your site

1. Select File > Upload Site. The Create New Site or Upload dialog box
appears. The default selection is to create a new site on Boomerang
Software’s Web-server.

Create new site or upload
. “You may upload your album/site to a server. The wiwe. photoring. com
2. Decide what you want to do. R e
i, photoring, com,
To begin the upload process all pou need is an Intemet connection. 1f you
*  Toupload your files to a new e

. N the Upload dislog box sppears, 1f you are uploading to an sxisting
site on Boomerang Software’s | aiumisite on sitier the v phoioring.com server or sams oiher srver.

the Upload Site dislog box appears.

Web-server at hen uploating o an erising abum skl previous fse and foldes il
. . = ovennritten. no orevious files exist. only new files will be create:

www.photoring.com, click the

Create a hew site and Upload to wew phatoring.com

= Cieate a new site and Lpload the alburr

upload the album radio
button. Click OK. The
Upload dialog box appears.
See the topic “Uploading Your

" Upload and update your existing site

Uplaad ta an accaunt or server ather than wew.phetaring. com

" Upload to anather site

Site to www.photoring.com for Cancel

the First Time” later in this - -

chapter. Figure 6.9 — Create New Site Or
Upload Dialog Box

¢ To upload your files to an
existing site on Boomerang Software’s Web-server at
www.photoring.com, click the Upload and update your existing
site radio button. Click OK. The Upload Web Site dialog box
appears. This dialog box is pre-filled only if you have previously
uploaded to the Boomerang Software Web-server. Review the data and
click Upload. Your Photo.Web CNQ file is generated and the resulting
files are stored on your remote Web-server.

+  To upload to a domain name other than i i i Knlkcico &Ofca , click
the Upload to another site radio button. Click OK. The Upload
Web Site dialog box appears. This dialog box is pre-filled only if you
have previously uploaded to another Web-server. Review the data and
click Upload. Your Photo.Web CNQ file is generated and the resulting
files are stored on your remote Web-server.

Uploading Your Site to www.photoring.com for the First Time

To create a new account and then upload your files, you must specify a user name.
This name becomes part of the www.photoring.com community and is also used in
your Web site’s address/URL. Be sure to write down your user name. You will

need it whenever you wish to login to

yOur aCCOunt. Upload Web Site
. FTF Server Mame or Address !"U photoring.com

User name/site name example: ’I’f you Lo
enter the user name “armstrong,” your it [ P P

. . ASTWOI hemember Fasswar
Web site address/URL will be -
www.photoring.com/armstrong. i

. 3 Upload I Cancel i Help |
Note: Uploading your site

requires a great deal of free Figure 6.10 — Upload Web Site
space. If you are having difficulty DialogBox (Second Upload)
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during upload, verify that you have at least 100 MB of available free space on
your hard disk, before trying to upload again. This amount depends upon the
size of your album(s).

To upload your files to www.photoring.com for the first time

Automatic Account & Free Space

1. From the Upload dialog box, type a
user name from 1-64 characters long.

Note: Do not use the following
characters: <>?.;:"f}[]=-_N@#$%*().

2. Type a password from 6—14 characters
long. Use any character except space
and backslash. Re-type the password
to confirm it and click Upload. The
User Information dialog box
appears.

3. Type First Name, Last Name, and
Email Address and click Close.
The Photoring.com server is setting up
your account.

4. When done, the message “Your

account is created successfully.
Press OK to continue” appears.

Upload

Thiz step will enable you to create or open a new account ar
home page and upload the album to this new site. Enter the
name of your site. This will be part of the wiww. photaring. com
community. The site name pou choose will alwo become wour
user name. Tou will need to use it in the buture o login ko s
account. E.g. if you enter armstrong your user name will be
armstrong, and your web site address will be

wiww. phatoring.com/ aimstrong

Enter a name 1 to 64 charachters long,
da not use <> 7. l=_ @)

Your Site will be ; wiww.photoring, com'.

Enter a password for your site. Passwords must be Bto 14
charachters long. ¥ou can use anp charachter expect 4,

Repete the same password to confirm it

|
LCancel I

Figure 6.11 — Upload Dialog Box

5. Click OK. The Site Upload Status box appears. As files are uploaded,
the progress bar reflects the status of the upload process. When done, the
message “Site was successfully generated” appears.

6. Click OK. The upload process is complete. Your album is now stored on

the World Wide Web!

Boomerang Software provides 2 megabytes of space for your albums on its
servers for free. Your free site will be in the www.photoring.com community. You
must be a registered user of Photo.web to qualify, must use Photo.web to build

and publish your album-site, and must
abide by the rules of www.photoring.com.
Refer to the www.photoring,.com site for
more details on the amount of space,
pricing, terms and policies, which can
change at any time. You can also get your
own unique URL or domain name and
more space for bigger or more albums.
refer to 1 1 1 Micca E&-aCschi ~&Hca L
i EAGcéi@adli EAUcai@dkia

If you want to place your Album on the
PhotoRing servers, Photo.web connects to
the servers, automatically opens an
account for you (if you do not have one)
and publishes your album.

User Info

Enter the following information to join wweww. photoring. com
caommunity of PhotoWeb uzers. The information you enter
iz intended for uze by the www photaring. com community
ta monitar Web-server use. [t will not given out to others.

Firgt Name:
Last Name:

LCloze

E-Mail:

Figure 6.12 — User Information
Dialog Box
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Chapfter 7.
Acquire and Select Source

What does Acquire Mean?

Photo.Web includes an Acquire feature that lets you add images from peripheral
devices (such as scanners, digital cameras, and others). This feature lets you
create images without first importing the image files into your hard disk.
Depending upon the project, this can save you a lot of time.

To use this feature, you must have a Twain compliant device installed on your
computer. File > Acquire and File > Select Source are available from either
Site Manager or Graphic Editor.

There is an Acquire button on the Choose Photos, Add Photo(s), Image
Attributes, and Image Library dialog boxes. Each button works in the same
way.

Using Acquire and Select Source

To use Acquire you must first select the source from which you will be importing
the image. Only peripheral devices that use a Twain compliant driver can be used
with this feature. To select a data source, be sure that the data driver associated
with the device has been installed. When adding an image using Acquire,
Photo.Web opens the device driver dialog box associated with the source device
that you select. This dialog box is part of the software installed for use with that
peripheral device.

Note: For detailed instructions on how to use the device driver dialog box
associated with the source device that you select, see the product documen-
tation provided by the manufacturer.

To select a source for use
1. Seclect File > Select Source. The Select Source dialog box appears.

Note: The Select Source
dialog box lists all devices [FETIS ]
that have been installed
with a Twain compliant
driver.

Select device from available Twain compiliant data
snurce drivers list

2. Click the source that you
want to use.

3. Decide if you intend to
acquire multiple images.

¥ Acquire multiple images of frames

¢ To acquire multiple
images, leave the
check mark in the ok | cees | wep |
Acquire Multiple

Images check box. Figure 7.1 — Select Source Dialog Box
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Note: Some source devices do not support the acquisition of multiple images
in a single session.

e To acquire a single image, clear the check mark in the Acquire
Multiple Images check box.

Note: When you acquire a single image, the device driver dialog box is
closed automatically. When acquiring multiple images, the device driver
dialog box remains open. For help, click the dialog box Help button.

When done, click OK. The source driver is selected. Photo.Web will now
open the selected device once the File > Acquire command is performed.

To acquire an image after selecting a source

1.

Select File > Acquire.
If the selected source
device is open, the
device driver dialog box
appears. If the source
device is unopened or
unavailable, the
Acquire dialog box

Acquire Images

Select device from available Twain compiliant data
source drivers list

appears. Select the { Felah Lt ¥

desired source and click YT ——
Acquire. The device

driver dialog box

appears‘ Acquirg I Cancel | Help |
Note: When more than Figure 7.2 — Acquire Dialog Box

one Twain device is

active (that is, selected and open on your computer) you are prompted with
an error message. To avoid this, close any currently opened dialog boxes and
close the currently open Twain device driver dialog box. Begin the acquire
procedure again.

Using the device driver dialog box, Image Name B
transfer the image to the Boomerang

Scanning Utlllty The Image Name Insert name for acquired image: 0K I
dialog box appears. Type an image I Cancel
resource file name and click OK. The
image is imported into Photo.Web.

Figure 7.3 — Name Dialog Box

Note: If you selected Acquire Multiple
Images, the device driver dialog box remains open.

To acquire a second image, select File > Acquire. The device driver dialog
box appears. You can continue acquiring images without having to select a
source device once the device driver is open.

Note: Most PC’s allow you to toggle between open programs (that is,
between the acquiring driver program and Photo.Web). To save time, you
might try using the toggle feature rather than File > Acquire.

When done, close the device driver dialog box. The Acquire feature is now
inactive.
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Using the Acquire Button

To save time when acquiring images, the Choose Photos, Add Photos, Image
Attributes and Library Edit dialog boxes include an Acquire button. This button
initiates the Acquire operation if a device driver is currently open. If a device
driver is not currently open, the Acquire button is inactive.

Note: When done acquiring images, make sure to close the device driver
dialog box.

To activate the Acquire feature

1. Go to Site Manager and select File > Select Source. The Select
Source dialog box appears.

2. Select a data source and decide if you want to acquire multiple images, and
click OK. The Acquire button is now active.

To acquire an image using the Acquire button

1. Click Acquire. If the selected source device is open, the device driver
dialog box appears. If the source device is unopened or unavailable, the
Acquire dialog box appears. Select the desired source and click Acquire.
The device driver dialog box appears.

Note: When more than one Twain device is active (that is, selected and open
on your computer) you are prompted with an error message. To avoid this,
close any currently opened dialog boxes and close the currently open Twain
device driver dialog box. Begin the acquire procedure again.

2. Using the device driver dialog box, transfer the image to the Boomerang
Scanning Utility. The Name dialog box appears. Type an image resource
file name and click OK. The image is imported into Photo.Web.

Note: If you selected Acquire Multiple Images, the device driver dialog box
remains open.

What Support Services Are Available?

To prepare your images for uploading, you might want to investigate any of the
following products and/or services that allow you to generate digital images.

¢ Digital Film Processing. Most film processors allow you to request
digital output. That means that once your conventional photographic film is
developed, it is transferred to digital format, usually by scanner. When you
go to pick up your pictures, you will receive a CD or floppy disk that you
can put into your floppy disk drive. Each image becomes a separate file.

e Digital Cameras. Rather than use conventional photographic film, you
can now by digital cameras that produce nothing but digital images. These
cameras write images to flash cards or floppy disks. This is probably the
simplest solution; one that, most likely, will become extremely common in
the future.

e Scanners. Another popular alternative is the scanner. Scanners are
peripheral devices that you attach to your computer (along with some
software) that enable you to generate digital images from any flat paper
image. Scanners are optical readers that translate conventional images into
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digital format.

¢ Video Input. If you happen to take video home movies, you have an easy

and available source for creating still images for your photo album. Most
digital video cameras can be hooked up to your computer and used to export
digital “frames.” This means that any image that you really like in a home
movie can be imported as a photograph. Like scanners, video input must be
translated, and most likely you will have to look through your video camera’s
documentation to see what your video camera’s requirements are. At
minimum, you will need a video hookup to your computer and some Twain
compliant software. For more specific information, contact your video
camera manufacturer.

¢ Duplication and Conversion Services. Ifyou have a shoe-box full of
images that you want to put into digital format, it might be easier to submit
them to a service provider who specializes in digital conversion. If you look
in the phone book, under computer services, you will most likely find several
companies specializing in media duplication and conversion. They will be
more than happy to take your shoe-box and return to you a complete set of
digital files.

If you use either a digital camera or a scanner (that is Twain compliant),
Photo.Web can upload your images directly, rather than writing them to disk—first.
This process is call “acquiring” an image. It can save you a lot of time since it
lets you eliminate the additional work associated with writing images to disk.
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Adding Text to Your Album or Photo Album
Web Page

How Can | Add Text?

There are two ways to add text to your albums: by placing “title text” on the Web
Page or by inserting “caption text” in a comment box. “Title text” is placed on
the Photo Album Web Page (or Album Page) and is a constant part of the page
background. “Caption text” is associated with a specific picture and normally
explains or describes the picture. “Caption text” that is part of the Album Object
and only appears when the specific image is being displayed. This chapter
explains how to insert both “title” and “caption” text.

Note: If you use the Wizard, ‘title” text is inserted. The Wizard, however,
does not let you insert “caption” text. To insert caption text, you must select
the Album object and click Add/Edit Photo Comments on the Photo Album
toolbar.

Inserting and Formatting Text on an Album Page

To insert “title text” that will appear as a constant part of the page
background

1. From Logical Layout, double-click the Album Page icon you want to edit.
2. Position the cursor where you want the text to display.
3. Type your text as necessary.
4. To insert a soft return, press SHIFT + ENTER.
5. To insert a hard return, press ENTER.
Note: A soft return does not create additional line spacing since it does not

create a new paragraph. Hard returns create new paragraphs and insert
additional line spacing.

Inserting Text with Bullets

Bullets are used quite often in Web pages. Usually they are simple bold dots or
small shapes placed at the beginning of several text lines.

To insert a bullet and turn on the auto-bullet feature

1. Click and drag the cursor over the text that will receive a bullet, or position
your cursor at the point where you want to insert a bullet.

2. Select Insert > Bullet or click Bullets on the Formatting toolbar. The
bullet(s) is inserted.

Note: The paragraph mode changes to accommodate bullets. When you
press ENTER to start another line, the program places a bullet as the first
character of the new text line.
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To turn off the auto-bullet feature

1.

Position your cursor at the point where you want to turn off the auto-bullet
feature.

Select Insert > Bullet or click Bullets on the Formatting toolbar. The
bullet is removed.

To change the bullet style

1.
2.

Click and drag the cursor over the text that currently has a bullet.

Select Format > Bulleting. The Paragraph Properties dialog box
appears.

Decide what you want to do.

e To use a standard shape, select Disk, Circle or Square. The selected
image is previewed.

e To create a custom shape, select Custom. A Resource Selection
box appears with three tabs: Existing Resources, Library and URL.
Click the Library tab. Click the Library Name drop-down arrow. A
library menu appears. Select a library and clip art image to use. The
selected image is previewed.

Note: For detailed information about the dialog box fields and buttons, click
the dialog box Help button.

When done, click OK. The bullet style is changed.

Note: You can import a clip art image to use as a bullet. Use the Import
button and navigate to the file location. Other options include specifying a
URL location for a bullet graphic, acquiring a bullet graphic through a Twain
compliant device, or creating a bullet in Graphic Editor. For information about
these options, click the dialog box Help button.

Inserting Text with Numbers

The Numbering feature inserts a number in the selected paragraph text instead of
a bullet. Each paragraph is numbered in sequence. This feature works in exactly
the same way as the bullet feature. Select Insert > Numbering or click
Numbers on the Formatting

toolbar. You can change the
numbering style by using the Generel | Buleting | Mumbering |

Paragraph Properties dialog T e

box. Select Format > Number- Lot Indentaiion [0 =]

ing. The Paragraph Properties .

dialog box appears.

Text Effects and Style Con-

tl‘OlS v Left Margin .— l

Photo.Web comes with many ways
to change the appearance of text.
Use Format > Paragraph to
access the formatting options ]
associated with the Paragraph

r Clear Attribute:

™ Right Margin

™ Mo'wrapping

Cancel | Help I

style. To change selected words Figure 8.1 — Paragraph Properties Dialog
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rather than the entire paragraph, use Format > Font to access the formatting
options associated with the Font style applied to specific words. Additionally,
both font and paragraph styles can be applied using the Formatting toolbar.

To change the text alignment, style or indentation (paragraph styles)
1. Select text you want to change.

2. Select Format > Paragraph. The Paragraph Properties dialog box
appears.

3. To change alignment, click the Alignment radio button that you want.

To change the assigned style, click the Style drop-down arrow. A list of
heading styles appears. Select heading style you want.

5. To change the current indentation, click the Indentation increase/decrease
arrows.

6. When done, click OK. The specified text effects appear.

Note: The Formatting toolbar includes a drop-down head style list box, text
alignment buttons, and indentation increase/decrease buttons.

To change font style applied to specific words (character styles)
1. Select text you want to change.

2. Select Format > Font. The |[EIreauEi
Choose WEB Font dialog

%]

Eont Size: oK
™ Bold [ Underline -

Nomal

box appears. I lsle T StikeQut — Cancel
. I Lage T Subscipt | (829
3.  Specify t'he effect.s you want to o m | _ tep |
apply using the dialog box T saisble Rich . e
fields and buttons. - Sem
Definition, DFN

Note: The text fonts available

Colar

are only those associated with [ ED ~
HTML 4.1 standard. These are

universal HTML fonts that are Figure 8.2 — Choose WEB Font Dialog
universally supported. For

detailed information about the dialog box fields and buttons, click the dialog
box Help button.

4.  When done, click OK. The selected text is updated.

Note: The Formatting toolbar includes a drop-down text style list box and a
font size list box. These are attributes that are assigned to individual
characters rather than to the entire paragraph.

Inserting Caption Text for Display with Individual Pictures

Caption text is assigned to individual pictures within a Photo Album. To assign
caption text, use Format > Object > Add/Edit Photo Comments. The Add
Edit Photo Comments dialog box appears. This dialog box lists all of images
associated with the selected photo album object. You may enter a comment of up
to 56 characters. The text you enter will appear as a mouse-over “pop-up” box. It
will not display unless the viewer moves the cursor over the image.
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To insert caption text that displays as a mouse-over “pop-up” box

1.
2.
3.

From Logical Layout, double-click the Album Page icon you want to edit.
Click on the album object to select it.

Select Format > Object > Add/Edit Photo Comments or click Add/
Edit Photo Comments on the Photo Album toolbar. The Add Edit
Photo Comments dialog box appears.

Select the image to
which you want to  |EEIE I T
add text. An image
preview appears and
the center input box
becomes active.

Type the text that
you want to display.

Enter a pop-up comment
tor the selected Photo

These clouds are
beautiful

ok I Cancel | Help |

Note: You are

limited to 56 ] . .
characters. Figure 8.3 — Add/Edit Photo Comments Dialog Box

Repeat Steps 4-5 for each image to receive text.

When done, click OK. The album object now has caption text specified for
individual images.

To preview the caption text, click Preview Album on the Photo Album toolbar.
Photo.Web previews the selected Album Object only. To see your caption text,
move the mouse across the image. A pop-up text box appears.

Note: At present, pop-up text appears in a fixed font style and size. These
settings cannot be changed.

ooo Photo.Web Deluxe User Guide
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Linking an Album to Other Web Sites

Why Link to Other Web Sites?

Suppose you want to sell your house. You take a lot of pictures and you set up a
photo album Web site to display your house to potential buyers. Now, how do
you lead potential buyers to the great photo album about your house? Many
listing companies allow you to place links from their site to your site. You
provide some initial sales information on their site and then include a link that
takes the viewer from their site to your site where you can provide additional
information. E-Bay and other listing companies allow you to do this. With the
Photo.Web Cross Links feature, you can link customers that come to the Internet
malls to view your “small” product image to a more comprehensive product
album.

Equally, you can build links from your site to external sites, such as family
member Web sites. Suppose you had a family reunion and three family members
build photo albums of the event. Now, you can provide links to other photo-
graphs that cover that same event! All you need to know is the URL for these
additional sites.

Inserting Links

Links are navigation tools. Links take a Web site visitor to different pages in your
Web site or to entirely different Web sites. To insert these navigation tools, use
the Insert menu.

To insert a link
1. From Logical Layout, double-click the page that will display the link text.
2. Type and select the text that you want to make into a link.

3. Select Insert > Link or click Insert Link on the Insert Objects toolbar.
The Link dialog box appears.

Link Dialog Box

This dialog box has two tabs for  [H&
choosing where you want to take ToPase | Eernd | TEEREE
the viewer. By default the To e R i Bssen AL
Page tab is selected. The To HomePae st Lik
Page fields include a Page list BeplecaLink
box, a Bookmark list box and Dot Link
an Open in New browser Cares
check box. At the bottom is the o
Link Text field. The text you ,E(B:m)k—;l

selected is displayed there. If :

you want to change this text,

simply type over it; the new text i

will be inserted when you

complete the link procedure. Figure 9.1 — Link Dialog Box - To Page
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9-2

To set a link to go to one of the pages listed
*  Select a page from the Page list box and click Assign URL. The page
link is assigned.

If the page you are linking to has a bookmark, you can set the link to go to a
bookmark by selecting the bookmark.

To set a link to go a page that has a bookmark
1. Select a page from the Page list box.
2. Click the Bookmark drop-down arrow. A list of bookmarks appears.

3. Select the bookmark and click Assign URL. The bookmark link is
assigned.

To insert text link from Link dialog box
¢ Type the text you want to appear on the Web page in Link Text box, select a
page and click Replace Link.

The text you specify replaces the selected text on the Web page.

To insert link text without selecting any text on a page

1. Select Insert > Link or click Insert Link on the Insert Objects toolbar.
The Link dialog box appears.

2. Select a page from the Page list box.
3. Type the text you want to appear in Link Text input line.
4. Click Insert Link. The link text is inserted.

To delete an existing link
1. Select the text link that you want to delete.

2. Click Insert Link from the Insert Objects toolbar. The Link dialog box
appears.

3. Click Delete Link. The link text is deleted.

Inserting a Link to Open a New Browser Session

Generally, when a user clicks a hypertext link, the browser display changes and a
new Web page appears. You can force the visitor’s browser to open a new
browser window to display the linked page. In this a case, the old Web page
remains on the screen and a new browser window opens to display the new Web

page.
To insert a link to open a new browser session

1. Type and select the text that you want to make a link.

2. Click Insert Link on the Insert Objects toolbar. The Link dialog box
appears.

3. Select a page from the Page list box.
4. Click the Open in New browser check box.
5. Click Assign URL. The link text is inserted.

Now when a viewer clicks on the text link, the browser will open a new window
and place the referenced page into the new browser window.

ooo Photo.Web Deluxe User Guide
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Typing in Link Mode

Instead of entering your text first in the Web page and then selecting it, you can
type in link mode. With this mode, everything you type becomes a text link.

To type in link mode

1.
2.

Place the cursor in the page where you want to start entering text.

Click Insert Link on the Insert Objects toolbar. The Link dialog box
appears.

Select a page from the Page list box.
Click Lock Link Mode. The Link dialog box disappears.
Type the words you want to use as a link. The specified text is a link.

Note: To disable the lock link mode and switch to normal mode, click Insert
Link on the Insert Objects toolbar.

Inserting External Links

You can insert a link to any external URL location you want.

To insert a link to an external resource

1.
2.

Photo.Web Deluxe User Guide unal 9

Type and select the text that you want to make a link.

Click Insert Link on the Insert Objects toolbar. The Link dialog box
appears.

Click the External tab. The External Link fields appears.

In the URL field, click the drop-down arrow and choose the URL prefix you
want to use.

In the URL address line, type the exact address of the external URL.

Note: Once created, external links are listed in the External links list box. To
assign a link to the same URL address previously assigned to another link,
select the address from the External links list box.

Click Assign URL. The external link is inserted.

ToPage Extemal |

Aszzign URL |
rsert Lk |
Replace Link. |
Delete Link |
Cancel I
Help |

uAL | = |

™ Openin Mew Browser

Link Text I

Figure 9.2 — Link Dialog Box - External

3
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Cross Links

Photo.Web provides a powerful capability to
organize and display photographs on the Web.
Besides having family or company pictures, you Album R Ls
can use the program to show more pictures of =
products you are selling. There are Internet
malls, such as Amazon.com, E-Bay, Yahoo or
others, where you can set up your own online
shop, and sell products.

External/Back links. ..

Figure 9.3 — Cross-Link
Menu

However, the space and features provided by these online malls are limited. They
provide you with a limited number of pictures that you can place for the specific
item you are selling. In some cases, the amount of text is also limited. So your
potential buyers are unable to see more detailed pictures of the products you are
selling.

In such a case, you may use Photo.Web to create an Album site where each Album
is dedicated to one product, and the pages of the Album show the product in its
many angles, colors, sides and renditions. You can then place this site on
www.photoring.com or any other server.

The Cross Links feature, enables you to link customers that come to view your
limited pages on the Internet malls, to the more comprehensive albums you create
with Photo.Web.

As you might guess, an Album site can have many albums. Each album could be
dedicated to one product. You can always place a link from your Internet mall

site to the Home Page of the Album site created by Photo.Web. However, it
would be so much better, if you were able to place a link from a specific picture or
text in your Internet Mall site, directly to the specific album that has more
photographs of the product the buyer is interested in and also enable the viewer to
link back from the album to your specific page or the Internet Mall. The Cross
Links feature provides just that by assigning a specific URL to each album.

Album URL Feature

To use the Cross Links feature, you

must first create your Photo Album ) ) )
. T This dialog box lists the URL addresses of all your albums of this &Album/Site. [f you
site hopefully with more than one want ta place a link from another Site to a specific Album on this Alburm/Site. find
> . the Album Mame, and enter its conesponding URL in the Relative URL column.
album, each dedicated to one
Album Name [ Reelative: URL |
product. Outside: 0utsicle it
WithUs AWithUs. htm
Then from the main menu select
Cross Links > Album URLs.
The Album URLs dialog box is
displayed.
The Album Name COIumn hStS the Mote: the URLs listed below one relative. You must add infront of these URLs the
names of all the albums in your main Website IRL where you have (or willl upload this Album/Site.
. Example: if this Album/Site is on www. photoring. com/pouraccount the complete
Album site. The Relative URL link. URL i v photering, com/vouraccount/RelativeURL.
column lists the URL of the specific
album, which is the HTML file of

the specific album. Figure 9.4 — Album URL Dialog Box
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To place a link in your Internet Mall site to a specific album, enter any text that
you want on your Internet Mall site, and place a URL link on that text using the
tools available at that Internet Mall site.

Note: Since Photo.Web enables you to place your Photo Album site on any
server, the Relative URL lists not the exact URL of the Album but the relative
address.

For example: If the Relative URL lists “/Outside,” and you place your Photo
Album site on www.photoring.com, and your account name is armstrong, then
the exact link you should enter in the Internet Mall site is
http.//www.photoring.com/armstrong/outside.htm. If you place your Photo
Album site on www.aol.com/xx243yy, then the exact link you should enter in
the Internet Mall site is http://www.aol.com/xx243yy/outside.htm.

Insert Back Links Feature

In the previous section, we described how this program enables you to connect
another site to a specific Album. This lets your viewer, who can view your site
anywhere on the Internet, be linked to the specific Album you want on the site
you created with Photo.Web. Once viewers arrive at your site created by
Photo.Web, and look at the specific album you linked them to, they may return
back to the site they came from by clicking on the Back Link placed on each
Album page.

The Insert Back Links feature automatically inserts the back link URL that you
want, on every page of your Album. The back link URL is placed on all pages,
right next to the photos of the Albums.

To insert a Back Link, select Cross Links > External/Back Links menu
option. The Insert External Links dialog box appears.

In the Link Text field, enter the exact

text that you want to appear. This

becomes the link text that the viewer

clicks on. For example: Go Back To

H If you want to insert an extemal or a back-link on every page of
M ain M al I . your Album Site, enter the text and its URL below

Ingert Extemal or Back-Links on Albums

In the Link URL field, enter the exact

URL address of the site where you want
the viewer to go. For example: if your Link LURL _[owintermetmalls comyoshor
main Internet site was on the
www.internetmalls.com/yourshop, then [ o | Cancel |

enter www.internetmalls.com/yourshop
in the Link URL field. Figure 9.5 — Insert External Links

Lirik. text IGo Back Ta Intemet Mal
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Changing an Existing Photo Album Web Site

Introduction

Once you have created your Photo Album Web site using the Wizard, you can
change the album style, add or delete photos, change the cover text, or add photo
comments. You can even add a new Photo Album Web page and create an
additional photo album. To accomplish any of these changes, keep in mind how
your Web site is constructed.

* Home Page. The Home Page is the first page that visitors see. This page
normally has a title and some additional text that describes the contents of
the Web site.

¢ Links. These are the navigation tools that help a visitor get from one Web
page to another. Links are very important. Without them, your visitors are
stuck on the Home Page!

*  Photo Album Web Pages. These are Web pages that contain an Album
Object. They have two parts: the Web page (that serves as the background)
and the Album Object (that displays the pictures you want your viewers to see).

e Album Object. This is a selectable object on a Web page. This object has
specific characteristics. These include: an Album Style, a Page Turning
Mode, and a Sequence of Photographs to be displayed.

Remember: While an Album Object creates the appearance of several pages
that turn in succession, only one Web page is being displayed in the browser.
Also, a photograph is an image resource file that is used within an Album
Object. To work, the Album Object accesses image resource files that you
specify. To change the “placement” of an image in your album, you reposition
the image resource file in the album’s photo listing.

Updating an Existing Web Site (Without Adding New Pages)

When updating an existing Photo Album Web site keep in mind that a launched
Web site exists in two places: (1) in the project file on your hard drive and (2) on
your remote Web-server.

Note: You should always save a copy of your album Web site project file on your
local hard drive. To make changes to an uploaded album on the Web, make your
changes to your local CNQ file and then generate and upload the changed file.
Your changed files will replace the old files on the Web-server. Do not make
changes directly to any uploaded server files! If you do, it will be difficult to
recreate the changes on your local CNQ file—making your CNQ file out-of-date.

If you created your existing Photo Album Web site by template, Wizard, or from
scratch, you can always update it at any time. Most often this simply means
adding a new photo or re-sequencing the photos in an existing Album Object.
Other times, your changes can be more substantial, requiring you to either
redesign the Web page or add an entirely new Web page. This section examines
how to update your existing Photo Album Web site without adding any new Web



Chapter 10. Changing an Existing Photo Album Web Site

pages (or without changing the Logical Layout). Procedures for updating both
Album Objects and Web pages will be covered.

To update an existing Photo Album Web site (without chang-
ing Logical Layout)

Launch Photo.Web. The Getting Started screen appears.

Select Open File. The Open dialog box appears.

3. Navigate to the CNQ file that contains the Photo Album Web site you want
to change. Select it and click OK. The Site Manager-Logical Layout
window appears.

4. Double-click the Logical Page icon for the page that you want to change.
The selected page opens in Page Editor.

5. Decide what kind of change you want to make.

e To change the content of the Web page but not the Album Object, go to
the topic “Making Changes to a Web Page.”

e To change the Album Object but not the rest of the Web page content,
go to the topic “Making Changes to an Album Object.”

Web Page Versus Album Object

Many Photo.Web features are specific to the Web page. These include features
that applied using the Insert Object toolbar or the Standard toolbar. When
updating an existing Web Site, you need to know what you are trying to accom-
plish. To insert a horizontal rule or graphic image, you are inserting a new object
onto the Web page. To add or change text, you are not adding new objects—rather
you are changing the Web page display! An Album Object is a separate object
which requires you to select it before you can change it. When you select an
Album Object, the Photo Album toolbar becomes active. Use this toolbar to make
changes to the selected Album Object.

Note: Changes to the Album Image listing using Add Photo(s), Delete
Photo(s), or Replace Photo(s) do not take effect until you click OK (to close
the dialog box). These dialog boxes also contain Up and Down buttons. You
can change the sequence of photos that will appear by selecting the image
file you want to move and clicking either Up or Down. The image file,
correspondingly, moves up or down one position in the list.

Making Changes to an Album Object

10-2

To change the Album Object

1. With the Photo Album Web page open in Page Editor, select the Album
Object you want to change by clicking on it. A grey border appears.
Go to the Menu bar and select Format > Object. A fly-out menu appears.
3. Choose from among the following options: Add Photo(s), Delete Photo(s),

Replace Photo(s), Change Style, Select Source, Acquire Photo(s), or Add or
Edit Photo/Comments.

Note: Each of these options is available using the Photo Album toolbar.
Some options are not activated unless the Album Object contains photo-
graphs.

ooo Photo.Web Deluxe User Guide
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To add a photo EGERG)
1. Sclect Add Photo(s). The Add —'
Photo(s) dialog box appears. -
Decide how you want to add new revwew ' %‘

images.

2. To add images from your hard e il b ] 0K | Ceneel | Hep |
disk, click Add. The Import Figure 10.1 — Add Photo(s) Dialog Box
dialog box appears.

Decide how you want to add your new images.

. To insert the files one at a time, select each file and click Add. The file
is added to the album listing.

. To insert a series of files all at the same time, hold down CTRL and
click each file you want. When done, click Add. The selected files are
added to the album listing in the order that you selected them.

»  To insert all of the files in the File and Folder display area all at the
same time, click Add All. All of the files are added to the album listing
in the order in which they appear in the File and Folder display area.

3. To insert images from an imaging device, click Acquire. If the selected
source device is open, the device driver dialog box appears. If the source
device is unopened or unavailable, the Acquire dialog box appears.

®  Select the desired source and click Acquire. The device driver dialog
box appears.

®  Using the device driver dialog box, transfer the image to the Boomerang
Scanning Utility. The Name dialog box appears.

®  Type an image resource file name and click OK. The image is inserted
at the end of the photo sequence list.

To delete a photo

1. Select Delete Photo(s). The o
Delete Photo(s) dialog box [ES70
appears. Decide how you i

want to delete one or more of
the current images.

*  To delete the files one ata Lo =P (o] oo | o
time, select each file and Figure 10.2 — Delete Photo(s) Dialog Box
click Delete. The
selected file is deleted from the album listing.

®  To delete a series of files all at the same time, hold down CTRL and
click each file you want. When done, click Delete. The selected files
are deleted from the album listing.

®  To delete all of the files from the album listing at the same time, click
Delete All. The album listing is deleted.

To replace a photo,
1. Select Replace Photo(s). The Replace Photo(s) dialog box appears.
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Decide how you want to replace one [EEEImmG
or more of the current images. ol
Images must be replaced one-for- A
one. You cannot replace one image o

: : : p & == : Wz
with multiple images. & —

2. Toreplace an image from your

b btk b ok | Cencel | Hee |

hard disk:
®  Select the image from the Figure 10.3 — Replace Photo(s) Dialog
album listing and click Box

Replace. The Import
dialog box appears.

*  Navigate to the file you want to use and click OK. The selected file is
replaced.

3. To replace an image using an imaging device:

. Select the image from the album Image Name
listing and click Acquire Photo(s). If |
the selected source device is open, the ||| elh L =
device driver dialog box appears. If _Cemel |
the source device is unopened or
unavailable, the Acquire dialog box Figure 10.4 — Name Dialog Box
appears.

i Select the desired source and click Acquire. The device driver dialog
box appears.

®  Using the device driver dialog box, transfer the image to the Boomerang
Scanning Utility. The Image Name dialog box appears.

®  Type an image resource file name and click OK. The selected file is replaced.

To change the album style
1. Click Change Style. The Change Style dialog box appears.
Decide how you want to change the current Album Style settings. Changes to
Album Style do not take effect until you click OK (to close the dialog box).
e To change the border style, click the Album Style that you want.

*  To change the page turning mode, click the Page Turning Mode
radio button that you want to assign.

»  To change the Fit to Edges option, click the check box to add or
remove the checkmark.

¢ To select an imaging device to use with Acquire, click Select Source.
The Select Source dialog box appears. The Select Source dialog box

lists all devices that have =
Enter & pop-up comment Ii
to the selected Photo,
These clouds are
beautifull
ok I

been installed with a
Cancel | Help |

Add/Edit Photos Comments

Twain compliant driver.
Click the source that you
want to use. Decide if you
intend to acquire multiple
images and click OK. An
imaging device is selected.
To activate this device, see Figure 10.5 — Add/Edit Photos
below. Comments Dialog Box
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e To acquire an image from an imaging device and place the image at the
end of the photo sequence list, select Acquire. If the selected source
device is open, the device driver dialog box appears. If the source
device is unopened or unavailable, the Acquire dialog box appears.
Select the desired source and click Acquire. The device driver dialog
box appears. Using the device driver dialog box, transfer the image to
the Boomerang Scanning Utility. The Name dialog box appears. Type
an image resource file name and click OK. The image is inserted at the
end of the photo sequence list.

*  Toadd or edit photo comments, select Add or Edit Photo/Comments.
The Add or Edit Photo/Comments dialog box appears. Select the
image to which you want to add text. An image preview appears and
the center input box becomes active. Type the text that you want to
display. When done, click OK. The Album Object now has caption
text specified for individual images.

Note: You are limited to a 56 character comment per picture. Currently, these
comments are displayed as pop-up boxes. To see the comment, the viewer
must position the cursor over the image.

When done, click outside the Album Object. The grey border disappears and
the cursor is positioned outside in the Web page.

Previewing an Album Object

A special feature of Photo.Web is the ability to preview an Album Object without
having to generate the entire site. To preview an Album Object, use the Preview
button on the Photo Album toolbar. Because an Album Object can hold a lot of
photographs, it is quicker to preview a single Album Object rather than the entire
Photo Album Web site. This Album Object preview, however, does not make use
of your internal browser. Instead it uses an internal display program. When
previewing an Album Object, only the Next and Previous buttons are active.
You will not see any other part of the current Web page and you cannot test any
links between pages.

To preview the selected Album Object

1.

With the Photo Album Web page open in Page Editor, select the Album
Object you want to change by clicking on it. A grey border appears and the
Photo Album toolbar becomes active.

Click the Preview button on the Photo Album toolbar. The Album
Preview window appears. The first two photos are displayed.

Decide what you want to do.

*  To move forward in the photo album, click Next.

e To move backward in the photo album, click Previous.
e To close photo album, click Close.

Making Changes to a Web Page

To change the Web page

1.

Photo.Web Deluxe User Guide oo

From Site Manager-Logical Layout, double-click the Page icon that you
want to change. The selected page opens in Page Editor.

10-5



Chapter 10. Changing an Existing Photo Album Web Site

2. Decide what you want to do.
¢ To make changes using the Standard toolbar, go to Step 3.
¢ To make changes using the Insert Object toolbar, go to Step 4.

¢ To make changes or additions to the text that appears on the Web page,
see the chapter titled “Adding Text to Your Album or Photo Album Web Page.”

e To make a change to a text link that appears on the Web page, see the
chapter titled “Linking an Album to Another Web Site.”

3. Choose from among the following Standard toolbar options: Paragraph,
Font, Object Properties, Form Properties, Global Search, Global Replace,
Search, Replace, Global Spelling, Spelling, and Show/Hide.

Note: These options are available using either the Format menu options or the
Tools menu options. Some options are not activated unless the cursor has
selected some text or unless an object has been selected. For more informa-
tion, see the chapters titled “Photo.Web Toolbars” and “Photo.Web Menus.”

4. Choose from among the following Insert Object toolbar options: Photo
Album, Form, Link, Bookmark, Table, Image, Horizontal Rule, Text, Java
Applet, Embedded Object, Special Text, and HTML Code.

Note: Each of these options are available using the Object > Insert menu
options. Some options are not activated unless the cursor is positioned in an
open area. For more information, see the chapters titled “Photo.Web
Toolbars” and “Photo.Web Menus.”

5.  When done, select File > Preview in Browser or click Preview on the
Main toolbar. The current Web page is previewed with the Internal Browser.

Previewing a Photo Album Web Site

It is recommended that you preview your Photo Album Web site on your PC
before uploading any files to a remote server. When you preview the Photo
Album Web site, the entire site is temporarily generated and the page that you
were last on is displayed in your default browser. From here you may now view
your Web site as any Internet visitor would, or switch back to Page Editor to edit
your Web pages.

To preview the Photo Album Web site
. Select File > Preview in Browser or click Preview on the Main toolbar.

To change your browser preference, see the topic “Setting a Browser Preference”
in the chapter titled “Getting Started.”

Updating an Existing Web Site (by Adding New Pages)

10-6

When updating a Photo Album Web site, keep in mind that an uploaded (or
launched) Web site exists in rwo places: in the Photo.Web CNQ file on your hard
drive and out on your remote Web-server.

Note: You should always save a copy of your album Web site project file on your
local hard drive. To make changes to an uploaded album on the Web, make your
changes to your local CNQ file and then generate and upload the changed file.
Your changed files will replace the old files on the Web-server. Do not make
changes directly to any uploaded server files! If you do, it will be difficult to
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recreate the changes on your local CNQ file—making your CNQ file out-of-date.

This section examines how to update your existing Photo Album Web site by
adding any Web pages (or by changing your Web site’s Logical Layout). The
procedures covered here teach you how to add a blank Web page, or add a new
Photo Album Web page.

To update an Existing Photo Album Web site (by changing
Logical Layout)

1. Launch Photo.Web. The Getting Started screen appears.

2. Select Open File. The Open dialog box appears.

3. Navigate to the CNQ file that contains the Photo Album Web site you want
to change. Select it and click OK. The Site Manager-Logical Layout
window appears.

4. Decide what kind of change you want to make.
e To add a new Web page, see the topic “Adding Web Pages.”

e Todelete an existing Web page, select the Page icon you want to delete
and right-click. A pop-up menu appears. Select Delete. The Page
icon is deleted.

Note: By deleting a Web page from Logical Layout all of your physical
resources are deleted as well. If you want to save your image files prior to
deleting them, see the procedure, “To move photo images to the Photo.Web
Images folder” later in this chapter.

*  To rename an existing Web page, select the Page icon you want to
rename and right-click. A pop-up menu appears. Select Rename. A
bounding box appears around the Logical Name. Type the new name
and press ENTER. The Page icon is renamed.

Note: By renaming a Web page, the Physical resource name for the Web
page is updated; however, the Folder resource names are not. Album
Objects, when created by the Wizard, receive the Logical Page name and the
suffix “PhotoAlbum.” Renaming a Web page after an Album Object has been
inserted does not update the Folder resource names. Also, page names
cannot contain spaces or any of the following characters: “YWY[ H@

e To change the

visual settings for T S
an existin g Web —E:'D :; ::;m wisual setings and epely them b ol other dependart Site Elemens | “eaon o ek Lol Page
page, select the i
i~ Defaul Colors ——
Page icon you Free EE
want and ri ht- Link Calors Sample
g I~ ol !I ﬁy Home Page.
click. Apop-up | S5 L
- | N Bal his is an Active Link.
meinu a\rl)_pearsl. = wistes| I |. ERrEECrECEE his is a Visited Link.
Select Visua -  EEFEErEEEEC
. mErEEEE-EEC
Settings. The SIS itage Illl’ll""lll‘”l!’“l‘
. e [ 3| WEEEEEECEEC
Page Visual e = M EEEE
Settings dialog * Pl [ &
box appears. Use e |
this dialog box to
specify the visual Figure 10.6 — Visual Settings Dialog Box
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10-8

settings for the selected page. Settings that you can specify include
default colors for text and links, background color, and margin settings.
Visual settings specified using the Page Visual Settings dialog box
will take priority over the Site Visual Settings only when the Set
Own Visual Settings radio button is selected. Visual settings are
designed to default from Site Visual Settings down to Page Visual
Settings, unless the Set Own Visual Settings radio button is
selected.

*  To change the visual settings for the entire Web site, select Site >
Visual Settings. The Site Visual

Settings dialog box appears. Use  [rommw =
this dialog box to specify the visual ~lnfo

settings for the entire site. Settings Pagenamelsf  Uniilad

that you can Specify inClude default Related resourcels): Untitlzdl

colors for text and links, background

color, and margin settings. Visual Tite |

settings specified using the Page e

Visual Settings dialog box will

take priority over the Site Visual

Settings only when the Set Own o | cme | e |
Visual Settings radio button is

selected. Visual settings are Figure 10.7 — Properties
designed to default from Site Visual Dialog Box

Settings down to Page Visual
Settings, unless the Set Own Visual Settings radio button is
selected.

»  To change the properties for a Web page, select the Page icon you
want and right-click. A pop-up menu appears. Select Properties.
The Properties dialog box appears. Use this dialog box to specify the
Properties for the selected page. The Properties that you can specify
include Page Title and Alias. Use Page Title to specify the text that
will appear in the title bar of the browser window. When blank, the
server file path is displayed. By default, the Alias field is empty. Use
this field to change the name that displays in your Nav Bar.

5.  When done, select File > Preview in Browser or click Preview on the
Main toolbar. The Web site is temporarily generated and the Home Page is
displayed in your default browser. You may now view your Web site as any
Internet visitor would, or use Site Manager to edit your Web pages.

Adding Web Pages

The program allows you to add a blank Web page, add a Photo Album Web page, or
copy (duplicate) an existing Web page. If you add a Web page using the Add button
on the Logical Layout toolbar, the only properties set by default are visual settings. If
you add a Photo Album Web page using the Add Album button on the Logical
Layout toolbar, an album object and navigation bar (or page links) are inserted. If you
copy an existing Web page, everything contained on the page is copied as well.

Note: Photo.Web has two commands Copy or Duplicate. Copy stores a copy
of the selected page in the program buffer. Duplicate immediately places the
copied page below the original. With copy, you can specify a new location in
Logical Layout before inserting the copied page. It is recommended that Web
sites be kept to a two tier Logical Layout.
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To add a blank Web page and place it below the Home Page

1.

3.
4.

From the Site Manager-Logical Layout window, select the Home Page
and right-click. A pop-up menu appears.

Select Add. A blank Web page is added. A bounding box appears around
the default name.

Type the name you want to assign to this page.
Press ENTER. The blank Web page is added.

To add a Photo Album Web page and place it below the Home Page

1.
2.

From the Site Manager-Logical Layout window, select the Home Page.

Click Add Album icon on the Logical Layout toolbar. The Insert New
Album dialog box appears.

Type the name you want to assign to this album and to the new logical page.
Click OK. The Photo Album Properties dialog box appears.

Specify the page turning and fit to edge options. When done, click Choose
Photos. The Choose Photo dialog box appears.

Add your photos as necessary. When done, click OK. The Photo Album
Properties dialog box reappears.

Click OK again. The Photo Album Web page is added and Logical Layout is
updated.

Note: If you are updating a template site, the Nav Bar that is inserted on your
new Album Page must be replaced with a copy of a Nav Bar from one of the
pre-existing pages. To do this, open a pre-existing page, select the Nav Bar
object, right-click and select Copy. You can now paste the copy inplace of the
Nav Bar that was inserted on using Add Album. For a template site, logical
page names must also be kept to 8-10 characters.

Important! If you use Add Album to a blank site (without Nav Bars), a Nav Bar
is inserted on both the Home Page and the New Album page. If you have
other pages, you may wish to copy the Nav Bar to each of the other pages in
your site.

To copy an existing Web page and place it below the Home Page

1.

From the Site Manager-Logical Layout window, select the Web page
that you want to copy and right-click. A pop-up menu appears.

Select Copy. A copy of the selected page is stored in the program buffer.

Click once on the Home Page icon and right-click. Select Paste. The
copied Web page is inserted on the same level as the other Photo Album Web
pages. The default name is “CopyOf<Logical Name>.”

Note: By copying a Web page, all of the Physical resources for the Web page
are copied as well. By default, the only folder resource names are updated.
These resource names are “CopyOf<Logical Name>PhotoAlbum” and
“CopyOf<Logical Name>Photos.” The image resources that are stored within
these folders are not updated with a new name.
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To rename the copied Web page and its associated Physical
Resources

This procedure is for advanced users who intend to use Site Manager—Physical
Layout to manage their Web site resources. This kind of management is not
required of normal users.

1.

To rename the copied Web page, select the Page icon and right-click. Select
Rename. A bounding box appears around the Logical Name. Type the new
name and press ENTER. The copied Page icon is renamed and all of your
nav bar references are updated.

Note: The associated physical page resource is renamed as well. This
resource is repositioned alphabetically in Physical Layout. Photo Album
folder resources, however, are not renamed. Once the page is renamed, the
page resource and the folder resources are no longer grouped together on the
Physical Layout resource tree. To keep track of physical resources, it is
recommended that you rename the Folder resources as well.

To rename the copied Folder resources, select the Page icon and right-click.
Select Rename. A bounding box appears around the Logical Name, which
is already selected. With the cursor over the selected text, right-click and
select Copy. The page name is now stored on the Windows Clipboard.
Click the Physical Layout tab. The Site Manager-Physical Layout
window appears.

You now want to rename two Folder Resources: “CopyOf<Logical
Name>PhotoAlbum” and “CopyOf<Logical Name>Photos.”

Locate and select “CopyOf<Logical Name>PhotoAlbum.” Click the
resource folder, right-click, and select Rename. A bounding box appears
around the Physical Name. Select the characters in front of the words
“PhotoAlbum.” With the cursor over the selected text, right-click, select
Paste. The copied characters are inserted. Press ENTER. The remained
resource folder is immediately repositioned under the Page Resource with
the new name. Because the resource folder “CopyOf<Logical
Name>Photos” is contained within the PhotoAlbum resource, it has been
moved as well.

Locate and select “CopyOf<Logical Name>Photos.” Click the resource
folder, right-click, and select Rename. A bounding box appears around the
Physical Name. Select the characters in front of the word “Photos.” With the
cursor over the selected text, right-click, select Paste. The copied charac-
ters are inserted. Press ENTER. All of the associated physical resources
have been renamed.

Note: Some people may find it easier to update the various page links before
renaming the copied page because the default page name, “CopyOf,” clearly
indicates the page which is the copy and the page which is the original.

To modify the contents of a Web page

1.

2.

10-10

From the Site Manager-Logical Layout window, double-click the Page
icon that you want. The selected page opens in Page Editor.

Decide what kind of change you want to make.
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¢ To change the content of the Web page but not the Album Object, go to
the topic “Making Changes to a Web Page” earlier in this chapter.

e To change the Album Object but not the rest of the Web page content,
go to the topic “Making Changes to an Album Object” earlier in this
chapter.

Note: Web sites that are created using a template or the Wizard have page
links that are automatically updated. The Navigation Bar feature cannot be
directly inserted into a blank Web page (however they can be copied and then
pasted). If you selected Add Album, a Navigation Bar is automatically
inserted along with the album object.

Managing Your Photos / Images

To save time when moving photos between albums, Photo.Web has an Images
folder on the Physical Layout resource tree. Use this folder to store images that
you have already brought into your Web site or to move between albums, or that
you want to use with one or more Photo Album Web pages.

To move photo images to the Photo.Web Images folder

1.
2.
3.

4,

From Site Manager, click the Physical Layout tab.
Locate the Photos folder that contains the images that you want to move.

Click and drag the image file icon to the Images folder. The image file
moves with the cursor.

Release the mouse over the Images folder. The image file is moved.

To insert an Image from the Images folder onto a Web page

Use this procedure when you want to place an image onto a Web page-NOT when
you want to place an image into an Album Object (see the topic “Making Changes
to an Album Object” earlier in this chapter).

1.
2.

From Site Manager, click the Logical Layout tab.

Double-click the Page icon that you want. The page is opened in Page
Editor.

Place the cursor where you want to insert the image.

Select Insert > Image or click Insert Image on the Insert Object toolbar.
The Image Attributes dialog box appears.

From the resource tree, select the image that you want to insert from the
Images folder.

Click OK. The image appears on the page.
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What is a Multiple Album Site?

Multiple album sites are Web sites that have more than one album available from
the Home Page. These are really no different from a single album Web site—just
one more Web page with an Album Object that sequentially opens a series of
image files that you specify.

Using the Wizard

When using the Wizard each step has its own dialog box. When done, generate
and upload the site to your Web-server—that’s how you make your album site
available to others! You can launch the Wizard using any one of three options.
All three of these options bring you to the Wizard’s Step 1 of 5 dialog box.

From the Getting Started dialog box

1. Open your Photo.Web application by selecting the Start > Program >
Boomerang Software > Photo.Web. The Photo.Web Title screen
appears followed by the Getting Started screen.

2. Select Wizard.

From the File menu
o Select File > Wizard.

From the New dialog box

1. Select File > New or click New on the Main toolbar. The New dialog box
appears.

2. Click Wizard.

Step 1 of 5-Select the album(s) you want.

The screen displays a list of album topics and a sample photo for each. By default
the first topic, Family, is selected. There are ten album topics from which you
can choose.

To select the albums you want to create
1. Decide which albums you want.

¢ To select an album, place a check mark in the check box next to an
album.

¢ Toremove a selected album, remove the check mark from the check
box.

2. Click Next. The Step 2 of 5 dialog box appears.



Chapter 11. Creating a Multi-Album Site Using the Wizard
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Figure 11.2 — Wizard Step 2 of 5

Step 2 of 5—-Assign each album an album style and place
the album pictures.

This dialog box identifies the album you have selected and a sample of the photo
album style currently selected. By default, Album Style 1 is initially selected
whenever this dialog box is first opened. This is an important screen because you
will be using it to select your pictures and to assign a page turning style for your
album.

To assign each album an album style, a page turning style,
and a fit to page option
1. Select an album from the Selected Albums listing.
2. Click an album style from the Album Style listing. A preview appears.
3. Decide if you want to use that album style or select another.

e To select another, click a different album style.

e To use the selected style, go to Step 4.

Specify the page turning style you want to assign.
5.  Decide if you want to use the Fit to Edges option.

¢ To automatically resize the image, place a check mark in the Fit to
Edges check box.

e To leave the images alone, leave the Fit to Edges check box clear.
6.  When done, click Choose Photos. The Choose Photos dialog box appears.

Choose Photos Dialog Box

Use the Choose Photos dialog box to locate the photos you want to insert.
These photos must be stored on your hard disk or be available using a peripheral
device, such as a digital camera or a scanner. If you want to acquire images using
a peripheral device, see the chapter titled “Acquire and Select Source.” To use the
Choose Photos dialog box, an album must be selected.

To place pictures into an album from your hard drive

1. Using Files of Type, select the file format for the image file you want to
insert.
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e To insert the files
one at a time, select each file and click Add. The file is added to the
album listing.

e To insert a series of files all at the same time, hold down CTRL and
click each file you want. When done, click Add. The selected files are
added to the album listing in the order that you selected them.

*  To insert all of the files in the File and Folder display area all at the
same time, click Add All. The selected files are added to the album
listing in the order displayed in the File and Folder area.

5. Decide if you want to re-sequence or remove some of the inserted files.

e To move a file up in the album listing, select the one you want to move
and click Up. The file is moved up one space. Click Up as many times
as needed.

¢ To move a file down in the album listing, select the one you want to
move and click Down. The file is moved down one space. Click
Down as many times as needed.

e To delete one file from the album listing, select the one you want to
delete and click Delete. The file is removed from the album listing.

e To delete all of the files in the album listing at the same time, click
Delete All. All of the files are deleted from the album listing.

6.  When done, click OK. The Step 3 of 5 dialog box is reactivated. Notice
that the screen message says “The album contains <total number>
photos.”

7. Select the next album that you want place pictures into and click Choose
Photos. The Choose Photos dialog box appears.

8. Repeat Steps 1-8 above for each album.
9.  When done, click Next. The Step 3 of 5 dialog box appears.

Step 3 of 5-Name your Home Page.

This dialog box identifies the Home Page default title and lets you customize the
text and font.
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To name your Home Page

1.

6.

Type your new Home Page Title in the highlighted area. The new title
appears on the top right of the screen preview.

To change the font size and style, click Font. The Choose Web Font
dialog box appears.

Use the Style list to select the HTML font style. Click the font attributes
you want to assign using the Font Attribute check boxes.

To change the font size default, click the font size that you want to assign
from the Font Size list.

When done, click OK. The Step 3 of 5 dialog box reappears. The new
title text and font style appears on the top right of the screen preview.

When done, click Next. The Step 4 of 5 dialog box appears.

Step 4 of 5-Specify a title for your album cover(s).

This dialog box identifies the default title for your Photo album and lets you
customize the cover text and font. If you created more than one album, more than
one album will be listed.

To insert cover text for an album

1.

Select the album that you want.

2. Type the cover text for the selected album using the Enter Front Cover
Text input line. The new text appears in the preview line below it.
3. To change the font size and style, click Font. The Choose Web Font
dialog box appears.
4.  Use the Style list to select the HTML font style. Click the font attributes
you want to assign using the Font Attribute check boxes.
5. To change the font size default, click the font size that you want from the
Font Size list.
6. When done, click OK. The Step 4 of 5 dialog box reappears. The new
font style appears in the preview line.
Repeat Steps 1-7 above for each album.
When done, click Next. The Step 5 of 5 dialog box appears.
Photo Album Wizard - Step 3 of 5
Insert the title tet for the Home Photo Album Wizard - Step 4 of 5
Page of your Photo Album on the s
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Select an album to specify the text for
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Figure 11.5 — Wizard Step 4 of 5
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Step 5 of 5—Review the page listing.
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Select the album that you want. If you inserted only one album, then the
album is selected for you by default.

Type the new Page name in the space provided.

Note: A page name cannot contain spaces or any of the following characters:
“WVY[ H@D

Repeat Steps 1-3 above for Photo Album Web Page.

When done, click Finish. The Preview, Upload or Generate dialog box
appears.

Deciding How You Want To Continue

To help you see your album site quickly, the Wizard offers you three choices:

Preview the album site on your PC browser (which keeps all of your
resource files on your local PC in one CNQ file),

Upload the album site to the server (which transfers your resource files to a
remote Web-hosting computer), or

Generate the album site to your local PC (which lets you selectively upload
files to a remote Web-hosting computer) and edit the album site by returning
to the program.

It is recommended that you preview your album on your PC before uploading any
files to a remote server. By keeping your resource files together in one CNQ file
you will minimize confusion.

Note: Uploading your site requires a great deal of free space. If you are
having difficulty during upload verify that you have at least 100 MB of
available free space on your hard disk, before trying to upload again.
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To complete your Web site generation

Select Preview.
The Web site is
temporarily
generated and the
Home Page is
displayed in your
default browser.
You may now view
your Web site as
any Internet visitor
would, or click the
Site Manager
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Web pages.
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@ Preview the Album/Site on vour local PC browser
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" Generate the Album/Site on pour local PC. Return to program for editing,

Figure 11.7 — Preview, Upload or Generate
Dialog Box

Note: Previewing your site requires a great deal of free space. If you are
having difficulty during preview verify that you have at least 100 MB of
available free space on your hard disk, before trying to preview again.
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Product Promotion for Photo.Web Users

Boomerang Software provides 2 megabytes of space for your albums on its
servers for free. Your free site will be in the www.PhotoRing.com community.
You must be a registered user of Photo.web to qualify, must use Photo.web to
build and publish your album-site, and must abide by the rules of
www.PhotoRing.com. Refer to the www.PhotoRing,.com site for more details on
the amount of space, pricing, terms and policies, which can change at any time.

If you want to place your Album on the Boomerang Software servers, Photo.web
connects to the servers, automatically opens an account for you (if you do not
have one) and publishes your album. Your Web site will be stored as a sub-
domain under the domain name www.PhotoRing.com. This URL is managed
by Boomerang Software for its customers.

Obtaining Server Space

If you want to obtain server space, Boomerang offers several Web-hosting service
plans. To register for Web-hosting services and obtain more information about
possible product promotions:

¢ Go to the Boomerang Photo.Web product site at www.PhotoRing.com, or

*  Go to Boomerang Software’s company site at
www.BoomerangSoftware.com, or

. Send an email to webhostingsupport@boomerangsoftware.com.

WWW.PhotoRing.Com-A Community of Users

To make it easy to be part of the www.photoring.com community of users, the
Photo.Web Wizard provides you with several upload options. One option lets you
automatically create a new account at www.photoring.com. If you click the
Create a new site and upload the album radio button from the Create
New Site or Upload dialog box, the process of creating a new account (and
subdomain) at www.photoring.com begins.

Note: For detail information, see the topic “Uploading Your Site to
www.photoring.com for the First Time” in this chapter titled “Creating a Single
Album Site With the Wizard.”

To create a new account for the first time, you must specify a user name/site
name. This name becomes part of the www.photoring.com community and is part
of your Web site’s subdomain URL address. Be sure to write it down. You will
need it whenever you wish to login to your account.

User name/site name example: 1f you enter the user name “armstrong,” your Web
site address/URL will be www.PhotoRing.com/armstrong.

When registering, you are asked to provide some additional user information.
This information is only used to manage the photoring.com community of users.
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Once your account has been created, Photo.Web uploads your Album Web site
automatically.

Note: Boomerang Software cannot guarantee the safety of your files once
they are uploaded. It is recommended that you maintain a copy of your
*.CNQ project file on your hard disk.

Other Products

The following are other products offered by Boomerang Software.

WebShop

Includes every software tool you need to successfully sell over the Internet.
Features Cascading Style Sheets, predesigned electronic stores, shopping cart
feature, real-time credit card processing and more!

Internet Design Shop

The most comprehensive Web site creation, management an publishing program
for Windows. Features drag and drop frame generator, site manager, navigation
bar generator, graphic editor and more!

Internet Design Shop Gold

An easy and economical WYSIWYG introduction to Web site design and
personal publishing. Runs on Windows 3.1, 95, 98, NT, 2000, Me and XL.

Secure Shuttle Transport (SST)

Boomerang's SST uses the industry’s leading RSA encryption techniques to
provide you with confidentiality and security. It's easy to use and free.
SST lets you:

e Setup special windows. Use these windows to page others who are also
using SST on the Internet.

e Chatin real-time. As you type and send your message, your counterpart can
respond immediately.

¢ Open as many windows as you want so you can communicate with others
simultaneously.

e Selectively decide who you want to receive communications from, by
blocking communications you don't want to receive.

e Send encrypted files and messages that are encrypted before they are sent
and decrypted once they are received.
SST provides unparalleled access and security:

e Enabling others to page you (by letting them know when you are at your
computer).

e Preventing others from reading (or even seeing) the contents of your files
while they are transferred.
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Photo.Web Toolbars

Accessing Toolbars

All program features are accessible through the menus. Most of the important and
frequently used features are also accessible through toolbar buttons or icons. The
toolbar buttons or icons have Quick Tips. These one or two word descriptions are
automatically displayed when you place the mouse on a button and keep it there
for a few seconds. When you place the mouse over icons, toolbars or parts of the
program screen, a one-line help message also appears in the bottom Help/Status
line.

Main Toolbar

The Main toolbar appears at the top of the Photo.Web window just below the
Menu bar. This is a standard application toolbar and is not context specific. It
also cannot be moved.

niw salve Palge urido ci,\t palste prelfer— hfilp pl‘e—
DIS|E| & 2] 756 Fawensie -] E[[v 2] R|R[ &

open print redo copy output type project generate upload
Figure 13.1 — Main Toolbar I
L.
Physical Layout Toolbar b
, el e

The Physical Layout toolbar appears when the Site T T

Manager—Physical Layout window is active. Use create rename

this to manage the physical resources of your site. folder

. Figure 13.2 — Physical

Logical Layout Toolbar gLayout Toolbar

The Logical Layout toolbar appears when the Site Manager—Logical Layout
window is active. Use the Logical Layout window to add, move, and delete
individual pages in your Web site. It displays an organization-type chart showing
the relationship of the pages to one another. Use the toolbar to manipulate the
window display and each of the logical resources associated with your site.

zoom out new new  rename  visual global global

I . ! ! |
glalil| @l &sE 2 8&=
| | | [ T

I
zoom in actual size delete properties site global

Figure 13.3 — Logical Layout Toolbar
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Photo Album Toolbar

Use this toolbar to perform a
variety of procedures by
clicking on the toolbar icon.
All toolbar functions are
also available using the
Format > Object menu
commands.

Insert Object Toolbar

The Insert Object Toolbar
appears and is active only
when the cursor is on a
Album Page. Use this
toolbar to insert a number of
different types of objects
onto a Album Page.

Standard Toolbar

The Standard toolbar

appears whenever you open
a Web page. This toolbar is
automatically displayed and

select

add  replace

pre-

LG e E]

delete add/edit
photo

change acquire

Figure 13.4 — Photo Album Toolbar

photo link table horizon- java  special

] ] ]
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| | | embled— HTIML

form book-  image text

Figure 13.5 — Insert Object

font  form global replace global spell show /

| ] ] ] |
EREEREEEEEE R
I |

|
spell

object global

para- search

Figure 13.6 — Standard Toolbar

cannot be accessed through the View menu. Use this toolbar to change your
visual settings, spell check your document, or assign paragraph styles.

Formatting Toolbar

The Formatting Toolbar appears by default. To remove it from the screen display,
select View > Formatting Toolbar. The program also hides (or removes) the
toolbar from the screen if the cursor is not in a Web page. The Formatting toolbar
includes tools that enable you to format the text and lines on the page. To use it,
simply select the text on the page and click on the formatting icon you want.

(Toolbar not displayed)

Form Fields Toolbar

The Form Fields toolbar appears when
you are in Page Editor and want to
insert a form field. It becomes active
only when you click Insert Form on
the Insert Object toolbar or select
Insert > Form.

ooo

text check combo text

line box box box

I I I I

— =~ | & =
| I |
pushbutton  radio list
button box

Figure 13.7 — From Fields Toolbar
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Accessing Menu Options

All program features are accessible through the menus. Most of the important and
frequently used features are also accessible through toolbar buttons. To access a
menu option from the menu bar, select the menu and a drop-down list appears.
Select your menu option using your cursor or the up and down arrows. Some
menu options also have shortcut commands. These are listed on drop-down
menu.

Note: This chapter introduces only the most important menu options.
For a complete listing see the User Guide Supplement which can be
found on your program CD.

File Menu
Wizard. Opens the Step 1 of 5 dialog box.

Use this option to create a new photo album. wizard. . Chel+
New. Opens the New dialog box. Use this to Hew... Chil+M
start a new photo album. Select a template, or Open... Chil+0
use the Wizard button, to create a photo album Save Cirl+5
Web site. Save As..,
Open. Opens the Open dialog box. Use this el ke
option to open an existing CNQ file. Upload Site...

Freview in Browser  F7

Save. Save the current project under the
current name. If this is the first time the project
file is saved, the Save As dialog box appears.

Save As. Opens the Save As dialog box. Use

Wwieb Promote
“webhost/Services. .
Upgrade...

this option to save the current project under a E{!n: S o
new name or as a template file. L Sl
Generate Site. Opens the Browse for Folder Filpiefices:

dialog box. When using this option, your Web 1 Qur pets.ctm

site files and folders are generated to a folder £ Traveling.ctm

on your hard disk. Specify the folder that you 3 Template1.ctm

want to use. Files and folders created by the 4 TemplateTF.ctm
Generate Site feature are upload ready. You B Al

must now transfer these file to a Web-server

before your Web site can be viewed by others. Figure 14.1 — File Menu

Note: Your project file, as saved by the program, is not upload-ready.
The CNQ file format is an integrated format. Everything is saved in
one file. To upload your project, this single file must be disbursed
into smaller independent files. The Generate Site operation is
performed, in a temporary fashion, every time you view your site
locally from your internal browser. Both Generate Site and Upload
Site perform this operation in a permanent fashion.
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Upload Site. Opens the first of two dialog boxes. The first one lets you decide
if you want to upload your Web site to the Boomerang Software server. There is a
separate option to upload your site to a different Web-host provider. If you select the
Boomerang Software option, the Upload dialog box appears. If you select the
different Web-host provider option, the Upload Web Site dialog box appears. Both of
these dialog boxes ask you for a user ID and password. When using this option, your
Web site files and folders are generated and uploaded directly to your Web-server.

Preview in Browser. Launches the internal browser or the selected default
browser specified in Preferences.

Web Promote. Displays a fly-out menu of Web sites that are helpful when you
want to promote your Web site. By selecting an option, the internal browser is
launched and the selected Web site is displayed.

Webhost/Services. Displays a Help page that describes Boomerang
Software’s Web-hosting services. For more information, go to the Boomerang
Software Web site by clicking the link that is provided.

Upgrade. Displays a Help page that describes Boomerang Software’s product
upgrade. For Photo.Web, the recommended product upgrade is WebShop, the all-
in-one Web site solution.

Print Setup. Opens the Print Setup dialog box. Currently this feature does not work.

Print. Currently this feature is disabled. To print a page from your album, open
the Web site using a print enabled browser.

Preferences. Opens the Preferences dialog box. Use this dialog box to specify your
default browser. Additional fields are available for specifying other program operations.

Insert Menu

14-2

Bullet. Turns on (or off) the bulleting of paragraphs. When used, this feature applies
the current bullet specifications found in the Paragraph Properties dialog box.

Numbering. Turns on (or off) the numbering of paragraphs. When used, this
feature applies the current numbering specifications found in the Paragraph
Properties dialog box.

Increase Indent. Increases the amount of indentation for the selected text or paragraph.
Decrease Indent. Decreases the amount of indentation for the selected paragraph.

Photo Album. Opens the Photo Album Properties dialog box. Use this to insert a
Photo Album object onto an Album Page. A photo album page may contain more
than one photo album. If you place more than one photo album object on an Album
page, be sure to provide bookmarks to direct the view to each album on the page.

Form. Inserts a form in the current page. Forms are used to collect responses
from users. The response may be as simple as selecting a Submit button or as
complicated as filling out an order form.

Form field. Opens a fly-out menu that lists the available form fields. Use this
option to insert a form field into the currently selected form. The fly-out menu
options are the same as the fields specified in the Form Fields toolbar.

Link. Opens the Link dialog box. Use this dialog box to insert a link in the
current page.

ooo Photo.Web Deluxe User Guide
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Bookmark. Opens the Bookmark dialog box.
Use this dialog box to add a bookmark icon to the
current page.

Image. Opens the Image Properties dialog box.
Use this dialog box to place an image in the current
page. You can select an image from a Photo.Web
library, a Web resource, or import an image file.

Bullet
Humbering
Increaze Indent
Decreaze [ndent

Horizontal Rule. Opens the Horizontal Rule oo

dialog box. Use this dialog box to place a Horizon- Eait

tal Rule (that is, a graphic bar used as a divider) at i, o

the cursor’s current location. Use the Horizontal el 1
Rule dialog box to specify Style, Alignment, Width Link. ..

Style (that is, unit of measure), and the Line Eookmark...

Thickness and Width across the page. Ir;age

Text. Opens the Import Text dialog box. Use this
dialog box to import a text file, or part of a text file.

Harizantal Rule...

Text...
Java Applet. Opens the Java Applet Properties Java applet...
dialog box. Use this dialog box to select a Java Erbedded Object
Applet, set its properties, and insert it. E e

opyright. ..

Embedded Object. Opens the Embedded Object K,l ;;yt Dg
Properties dialog box. Use this dialog box to select e
an animated GIF, video, sound, or other multimedia Date...
files and place them in the current page. HTML Code...

Copyright, Mail to, and Date. Opens the
Special Text dialog box. Use this dialog box to a

Figure 14.2 — Insert Menu

copyright line, to insert mail-to link, or to select a date format and insert a date.

HTML Code. Lets you insert your own HTML code in the current page.

Cross Links Menu

Album URLSs. Opens the Album URLs dialog box. Use this dialog box to
identify the Relative URLs associated with each album in a Web site. When
uploaded, these relative URL addresses will assume an exact an URL address.
For example: If the Relative URL lists an photo album as “/Outside,” and you
place your photo album site on www.photoring.com, then the exact URL address

is www.photoring.com/outside.htm.

External/Back Links. Opens the Insert External Links dialog box. Use this

dialog box to insert a text link that will return the viewer to the Internet shopping
mall from which they came. If you are advertising a product for sale using several
Internet shopping mall locations, you will want to have back links to each. These
back links will display on the Photo Album Web page where the Ablum Object
has been placed.

Logical Layout Menu

External/Back links...
Open. Opens the selected page in Page Editor. Use HSNEBact ks

this option to view and edit your Photo Album Web
pages. You can also double-click on the Logical
Layout icons to open a page.

Figure 14.3 — Crosslinks
Menu
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Add. Lets you add a new Photo Album Web page directly below the selected page.
New pages inherit the visual settings of the selected page. When inserted, the Photo
Album Web page is ready to be named. Type the name a press ENTER. To accept
the default name, press ENTER. The names given to Logical Layout pages default
to their associated physical resources.

Logical Layaut

Note: Page names cannot contain 0
spaces or the following characters: LR
.0 »

7\ ?2<>+# Add F3
Note: To move a Photo Album Web Delete F5
page, drag and drop the selected Renare Fz2
page to a new parent page. The —
page that was moved is inserted Lupliee s Ll
directly below the selected parent = .

. . Froperhies. ..
page. Moved pages do not inherit the i ;

visual settings of the selected parent Visual Settings...  F4
page when the Set Own Visual Meta Infarmation. .

Settings radio button is selected.
Figure 14.4 — Logical Layout

Delete. Deletes the selected page. Deleted Menu

pages cannot be restored.

Rename. Renames the selected page. When used, a bounding box appears
around the selected page name. Type the new name and press ENTER. The
names given to Logical Layout pages default to their associated physical re-
sources.

Note: Page names cannot contain spaces or the following charac-
ters: 7/ \:?<>+#”

Duplicate. Duplicates the selected page and places the page copy directly below
the selected page. When inserted, the duplicated Photo Album Web page is ready to
be named. Type the new name a press ENTER. The names given to Logical Layout
pages default to their associated physical resources. Duplicated pages can be moved
to different Logical Layout locations (see the second note under “Add” above).

Properties. Opens the Properties dialog box. Use this option to specify a page
Title and a page Alias. The Title field is the HTML title that appears in the
browser’s title bar. This field defaults from the Logical Layout name unless
specifically altered. By default, the Alias field is empty. Use this field to assign a
different page name for use with a Nav Bar.

Visual Settings. Opens the Page Visual Settings dialog box. Use this option to
specify the visual settings for the selected page. Settings that you can specify
include default colors for text and links, background color, and margin settings.
Visual settings specified using the Page Visual Settings dialog box will take
priority over the Site Visual Settings only when the Set Own Visual Settings radio
button is selected. Visual settings are designed to default from the Home Page
down, unless the Set Own Visual Settings radio button is selected.

Meta Information. Opens the Meta Information dialog box. Use this option to
edit Meta tags in your Web Page. To use Meta tags, you must be familiar with
HTML. Meta tags are used to promote your Web site to search engines. Meta tag
information is stored at the top of your Web page along with the page title,
however this information does not display in the browser.
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Technical Assistance

Assistance in Using Photo.Web and Technical Support

Photo.Web includes the following forms of documentation for your convenience:

User Guide. Provides an overview of the features and functions of
Photo.Web.

Online Help System. For quick reference on a particular operation or
feature, use the Online Help system. To access the Help files, select Help >
Help Topics or press F1. The Online Help system includes a subject
index, word index and extensive cross-reference links to related subjects.
The Online Help system is ideal for finding specific, detailed information.

Technical Support

Before you ask for technical support, please check the Readme file to see if it

can answer your question. If you cannot solve your problem, contact Boomerang
Software Technical Support at:

E-mail: techsupport@boomerangsoftware.com

Fax:

617.489.1486

Mail: Boomerang Software, Inc.

ATTN: Tech Support
90 Concord Ave.
Belmont, MA 02478

When Contacting Tech Support

It is more effective if you follow these guidelines when contacting tech support:

Record the exact sequence of events that created the problem. Make sure
that you reproduce the problem by following the same series of steps.

Know the version number for Photo.Web. To get the exact version number,
choose the Help > About menu option in Photo.Web.

Know the type of computer and the version of Windows that you are using.
Write down and keep handy the following information: amount of free hard
disk space on your drive, your PC’s RAM.

Record the text of any error messages that may appear with regard to the
problem.

Preview (or browser-related problems) can be due to your PC having an
older version browser. You should be using Netscape or Internet Explorer
(version 4.0 or higher). From an open browser window, select Help > About.
Write down the version number of the browser as displayed.

If you are having problems do not return the program. Most problems may
be easily solved. You may check the www.BoomerangSoftware.com Web
site for posted Questions & Answers.
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Using the Online Help System

Photo.Web comes with an Online Help System that you can use to answer some
of your questions about how to use specific feature. To access the Online Help
System, select Help > Help Topics. The Photo.Web Online Help dialog box
appears and the Table of Contents is displayed.

Online Help Window Options

The Photo.Web Online
Help dialog box has several table of  book- related
options that you can select backward contents  mark topics
using the Online Help toolbar I I I I
that appears directly below i Ip @ ’ %\ See Also
the title bar. These options T T
include: forward search
* Backward. Returns Figure 15.1 — Online Help Toolbar
the screen display to the
last topic.

e Forward. Returns the screen display to the next topic in sequence. The
button is only active once the Backward button is used.

¢ Table of Contents. Displays the Table of Contents.

e Bookmark. Opens the Bookmark dialog box. Use this dialog box to
store bookmarks that will take you to selected topics. This listing is user-
defined and is saved when you exit the program.

e Search. Opens the Search dialog box. Use this dialog box to selectively
search for information on a topic. This dialog box has two tabs, Index and
Search. Use the Index tab to select a topic from the topic list. Use the
Search tab to search on a word or phrase. The program returns a list of
topics that contain the specified word or phrase. Click the topic that you
want to see and click Display. For faster access, double-click on the topic.

¢ Related Topics. Moves the cursor to the next available link in the topic
being displayed. Use this feature to quickly access additional topic links
associated with a topic.

Using F1
By pressing F1, the Photo.Web Online Help dialog box appears with the Table
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Appendix A.
Album Styles

Introduction

The following is a complete graphic listing of the albums that come with
Photo.Web. Use this as a reference for the available album styles.
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Appendix B.
License Agreement and Warranty

IMPORTANT

Opening the software package and using Photo.Web indicates acceptance of the terms of this License
Agreement.

NOTICE OF COPYRIGHT

This software program package (“SOFTWARE”) is a proprietary product incorporating elements
developed by Boomerang Software, Inc. (‘BOOMERANG?”). This software is protected by copyright laws
and international treaty. You must treat the SOFTWARE like any other copyrighted material, except that
you may either make one copy of the SOFTWARE for backup or archival purposes, or you may place the
SOFTWARE on a single mass storage device (media), such as a hard disk, provided that you keep the
original software for archival or backup purposes. Copyright laws prohibit making additional copies of the
SOFTWARE for any other reason. You may not copy written materials accompanying the SOFTWARE
without the express permission of BOOMERANG.

The Photo.Web program, its screens, icons, sequence, and organization are copyrighted materials of
BOOMERANG. They may not be copied or duplicated in any medium without the written authorization of
BOOMERANG.

SOFTWARE LICENSE AGREEMENT

The software on the Photo.Web media is licensed to the user. Before using Photo.Web, you should
carefully read the terms and conditions of this Agreement. This Agreement is a legal contract between you
(the end user) and BOOMERANG, governing your use of the software. If you do not agree with these
terms and conditions, please return the software with all accompanying packaging materials to the vendor
from who you purchased it for refund or credit. Return policies of vendors may vary; you should check
with your vendor as to their return policy on returning unused, unregistered software. Return of software is
subject to restocking charges and terms which will be applied and deducted from the initial cost paid by the
customer returning the software. This agreement shall also be binding on any subsequent authorized
licensee. If you have questions regarding this Agreement, contact BOOMERANG at 617-489-3000.

A.  BOOMERANG grants you the right to use one copy of the software on a single-user computer only.
Installing the SOFTWARE on a multi-user computer or network server is a violation of this
Agreement.

B. BOOMERANG further grants you the right to make a backup/archival copy of the SOFTWARE as
set forth in the Notification of Copyright.

C.  Youmay not sublicense, rent, or lease the SOFTWARE, but you may permanently transfer your
license to use the SOFTWARE and accompanying materials by delivering to another party the
original media (that is, the CD-ROM), and original user documentation materials comprising the
SOFTWARE package. The new recipient of the SOFTWARE and accompanying materials accepts
this Agreement and is licensed under the terms of this Agreement upon initially using the
SOFTWARE.

LIMITED WARRANTY / LIMITATION OF REMEDIES

BOOMERANG warrants the original media (that is, the CD-ROM) on which the SOFTWARE is recorded
to be free from defects in workmanship under normal use for a period of thirty (30) days from the date of
your purchase as evidenced by a copy of the original receipt of payment. BOOMERANG?’S entire liability
and your exclusive remedy will be replacement of the media that does not meet BOOMERANG’S limited
warranty and is returned to BOOMERANG with a copy of the original receipt of payment. BOOMER-
ANG will have no responsibility to replace media that has been damaged by accident, abuse, or
misapplication.

Under no circumstances including negligence, shall BOOMERANG be liable for any incidental, special, or
consequential damages that result from use or inability to use the SOFTWARE or related user documenta-
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tion, including all user documentation delivered in digital format, even if BOOMERANG or any
BOOMERANG authorized representatives have been advised of the possibility of such damages, or that
result from mistakes, omissions, interruptions, deletion of files, errors, defects, or delays in operation or
any failure of performance whether or not caused by events beyond BOOMERANG’S reasonable control,
including, but not limited to, acts of God, computer failure, theft, destruction, or unauthorized use of
BOOMERANG program or services provided by BOOMERANG in connection with the publication of the
software covered by the License Agreement.

Because any individual software title which (1) creates files combining multimedia functionality with
hypertext markup language (HTML) functionality and (2) is designed to create a Web site over the public
Internet is subject to many factors beyond the reasonable control of BOOMERANG, including but limited
to the known incompatibilities among widely-distributed programs for viewing HTML files over the public
Internet and private Internet Protocol (IP) networks, improper, insufficient, obsolete, or inoperable
hardware or software configurations on remote PCs accessing the public Internet or private IP networks,
unforeseen congestion on the public Internet or private IP networks, failure of public telecommunication
transmission providers, failure of unknown third parties to deliver access to the public Internet or the legal
or illegal use of public and private communication systems by unknown third parties, you are advised to
verify all work created with this SOFTWARE.

You are further advised to make backup copies of all files, reports, email or any other administrative
information generated as a result of work created with this program or attempts to access Web sites
generated through the use of this program. Boomerang Software cannot guarantee the safety of your files
once they are uploaded to www.photoring.com. Registered users of www.photoring.com assume all
responsibility in the event that their files become damaged or lost.

Boomerang Software, Inc. cannot assume any responsibility or liability for any indirect, special, incidental,
economic, cover or consequential damages arising out of the use of or inability to use Photo.Web or any
component of the documentation included with the program, including any and all documentation delivered
in digital format. In no case shall Boomerang Software be liable for any amount exceeding the purchase
amount paid by a licensed user for the software.

The information contained in the Photo.Web documentation is subject to change. Except as specifically
provided, Boomerang Software makes no warranty or representation, promise or guarantee, either express
or implied, statutory or otherwise, with respect to this software or user documentation, including their
quality, performance, merchantability, or fitness for a particular purpose. No Boomerang Software dealer,
agent distributor, or reseller is authorized to make revisions to this warranty.

Revisions to any component of the program or user documentation included with Photo. Web may occur as
deemed necessary by Boomerang Software, Inc. The information herein is believed to be, and is presented
to be, accurate in all respects. However, Some states do not allow the exclusion or limitation of implied
warranties or limitation of liability for incidental or consequential damages, so the above limitation or
exclusion may not apply to you.

When you install this program, it may change your browser’s default home page. However, you may
change this to any other home page that you want. To change the home page of your browser, for Internet
Explorer from the menu select Tools, then Internet Options, in the General (or the proper) tab’s Home Page
Address field enter the web URL address you want. For Netscape, from the menu select Edit, then
Preferences, select Navigation in Category, check the Home Page setting and enter the web URL you want
in the Home Page Location.

MS DOS, Windows, NT, Internet Explorer, Active Server Pages and True Type are trademarks of
Microsoft Corporation. IBM is a trademark of International Business Machines Corporation. Navigator is
a trademark of Netscape Communications. PhotoSuite is a trademark of MGI Software.

All other product names or trademarks identified in the user documentation accompanying this SOFT-
WARE are trademarks or registered trademarks of their respective companies. They are used in this book
in an editorial fashion only. No such use, or the use of any trade name, is intended to convey endorsement
or other affiliation with Boomerang Software products.
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Other Products And Services From Boomerang Software

You may purchase new products or the upgrades for your existing products
Visit the site for pricing and more details, or email

sales@boomerangsoftware.com
You may also visit your computer and retail stores. Some products are sold direct.
Boomerang Software, Inc.
Tel.: 617-489-3000, Fax: 617-489-1486

www.boomerangsoftware.ccom www.EcommerceCities.com

. WebShop Enterprise — The complete Web Content Management and E-com-
merce solution for Enterprise companies. Includes: Database layer management,
Visual ASP generator, Complete web authoring features, latest HTML support,
Script wizards, E-Commerce Gateways and more. Supports Oracle, MS SQL, and
Access databases.

. WebShop Enterprise Community Builder — Includes WebShop Enterprise
plus the complete On-line community Designer. Enables you to build and launch
on-line communities within days. Includes: Administration and Member provi-
sions, bulletin boards, announcements, gateway E-commerce back end, and other
On-line community options.

] WebShop Professional — The advanced Web page and E-Commerce develop-
ment tool for professional users. Includes WebShop XL plus other options ideal
for interactive media and advertising professionals who need more features and
options to create robust, interactive, and one of a kind E-Commerce or Web sites.

. WebShop XL — The complete tool to make serious Web or E-commerce sites.
Includes every software tool you need to successfully sell on the Net, plus se-
lected web page uploads, Page-hits Statistics, XML compliancy, built-in Forms
Verifications, Visual ASP, Script Wizards, Site Manager, orders processing and
verification emails and more. Create stunning web sites and successfully conduct
your business online, with integrated shopping cart and more. One of the most
complete and affordable E-Commerce and web authoring solutions ever created.

. WebShop XL International — The same as WebShop XL plus provisions to
conduct business internationally in over 160 different currencies, different taxa-
tion options and more. Includes online merchant account application for settling
in foreign banks. Ideal for all merchants outside USA.

= E-Commerce Construction Kit 2.0 Deluxe — The E-Commerce tool for every-
one. Building an online business is easy when you have the right tools. Everything
you need to create online businesses, ready-to-use store templates, powerful
shopping cart creator, and online merchant account application.

. Internet Design Shop XL — A comprehensive Web site creation, management,
and publishing program for windows (no E-commerce functions built-in). For
serious web designers. Supports dynamic HTML, selected web page uploads,
Page-hits Statistics, XML compliancy, built-in Forms Verifications, Visual ASP,
Script Wizards, Site Manager and more.

. Web page Construction Kit 7.0 Deluxe — The easy and complete web design
and publishing program for everyone (no E-commerce functions built-in). In-
cludes: wizards, templates, style sheets, latest web site HTML features, Drag-n-
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Other Products and Services From Boomerang Software
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Drop tools for easy editing.

Total E-Commerce for FrontPage 2000 & 2002 — The leading complete E-
Commerce solution for FrontPage 2000 & FrontPage 2002. Integrates perfectly
with FrontPage. Includes a powerful shopping cart, search engine, On-line new
merchant account applications, On-line Store Administration, Access database
support, orders processing and verification emails, and more.

Total E-Commerce for FrontPage 2000 & 2002 International — The Interna-
tional edition of Total E-Commerce. You can conduct business internationally in
over 160 different currencies. Includes online merchant account applications and
settlement in foreign bank accounts.

Photo.web Deluxe — The all-in-one Internet photo album and photo storage
software. The perfect tool to show your family and friends all the pictures that
you want, on the web simply using Internet browsers. Real-Album style animated
pages that turn, over 20 styles of graphic photo albums to choose from. Create
links to auction sites like ebay to display your auction items and more. Perfect for
Scanners and Digital Camera users.

BoomFTP — The easy to use and complete file transfer software program to
upload/download or transfer your web site or files to hosting servers or across the
LAN or the Internet.

Encrypt and Secure — The Encryption and Security program for files, emails, and
all documents. Excellent to protect desktop or notebook PCs. Encrypts and pro-
tects your data from prying eyes. Even if hackers get through any firewalls, your
documents will be encrypted and protected. Share files and documents that can only
be read by your intended recipient. Includes: File wipe, erase, and shredding of files
to make them unrecoverable, DES and triple DES encryption, Digital Certificates,
and much more. Perfect for Corporate users to protect confidential data. Excellent
for home users who use DSL, modems and cable modems to go online.

Secure Shuttle Transport SST Enterprise (Client Server Solution) — The
leading encryption and Instant Messaging software. Send encrypted instant mes-
sages, Encrypted email attachments, file transfers, voice messages, and real-time voice
conversations over the Internet, securely and privately. Includes Voice Over IP, En-
crypted FTP, and everything needed to secure an entire company’s network and PCs.

Electronic Downloads

Some of the products can be purchased as downloads form the company web site.
You may also purchase optional or additional documentation (in printed or down-
load PDF style) from the site. Click the Download link on the home page at
www.boomerangsoftware.com

Web Hosting Services

Boomerang Software can host your Web or E-Commerce sites. All Boomerang
servers are configured to smoothly host all sites developed using our Web and
E-commerce tools. Dedicated servers are available for active E-Commerce
businesses. Many hosting plans are available. For details visit
www.boomerangsoftware.com/webhosting/webhosting.htm

Other Consulting Services

NT/Windows 2000 server applications, consultation and development for Inter-
net or enterprise applications are also available.
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