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How to use the Clip Library: Overview

The Clip Library is a collection of files, called books, of cuttings. Each book can contain any number of
cuttings, and each cutting can be any amount of text, with an optional "hot spot". If a hot spot is defined
(using "\""), the current selection is substituted at that point. For example, if the current selection is:

A Heading

and the cutting is:
<H1>\* </H1>

The result will be as shown, with the original text still selected:
< H1> A Heading </ H1>

Sampile clip books are supplied for inserting HTML tags, and ANSI, control and HTML characters.
These books can be modified, or you can create your own ones from scratch.

The Clip Library user interface consists of a drop-down list of books, and a scrolling list of the cuttings in
the selected book. The selected cutting can be inserted by double-clicking it, or by pressing the Enter
key. The library may be edited using the commands on its right click context menu.

The interface is turned on and off using the Clip Library command on the View menu, which uses
Ctrl+F3 as a shortcut. Keyboard-only users can also use the shortcut Alt+0 to make it the focus
window, ESC to return the focus to the active document, and Shift+F10 to display its context menu.

Note:

These shortcuts will not be available if you have previously customized your command shortcuts. The
assignments can be made on the Keyboard tab of the Customize dialog box as follows:

Command: Shortcut: Purpose:
View/ViewClipLib CtrI+F3 Show or hide the clip library
View/ActivateClipLib Alt+0 Give input focus to the clip library.

This also displays it if it is not

already visible.
Contributed Clip Libraries:
Visit http://www.textpad.com/addons.html to see the Clip Libraries that have been kindly contributed by
our users.

See also:

Inserting Cuttings
Editing



How to use the Clip Library: Inserting Cuttings
Before you can use the Clip Library, you must first display it, and make it active. To display it, select the
Clip Library command on the View menu. To make it active, either click it with the left mouse button, or
type Alt+0.
To insert a cutting with a hot spot:

1. Either select the text to be substituted for the hot spot, or move the cursor to the insertion position in
the document.

2. Double click or press Enter on the cutting to be inserted.
To insert a cutting without a hot spot:
1. Move the cursor to the insertion position in the document.
2. Double click or press Enter on the cutting to be inserted.
Note:
If the list of entries is sorted, you can quickly jump to an entry by typing the first letter of its name.



How to use the Clip Library: Editing

You can edit the Clip Library, using the following commands on its context menus. To display the
context menu, either right click the Clip Library, or type Shift+F10 on the list of books or list of cuttings.

Menu for list of books:

Command: Action:

Save Saves any changes made to the selected book.

Rename Renames the selected book.

Delete Deletes the selected book.

New book Creates a new, empty book. You will be prompted for its file and
display names. A clip book must have the extension .TCL, and will be
stored in the folder specified on the Folders tab of the Preferences
dialog box.

Refresh Reloads all books. Use this command if you have modified any books
externally.

Close Closes the clip library.

Menu for list of cuttings:

Command: Action:

Insert Inserts the selected cutting in the active document.

Copy Copies the cutting with the specified name to the clipboard.
Rename Saves the changes made to the named book.

Delete Deletes the cutting with the specified name.

Paste new cutting

Copies the contents of the clipboard to the open book. You will be
prompted for a name for this cutting.

Sort When checked, the entries are sorted alphabetically, otherwise they
are displayed in the order they are written in the book. When sorted,
you can quickly jump to an entry by typing the first letter of its name.

Refresh Reloads all books. Use this command if you have modified any books
externally.

Close Closes the clip library.

Notes:
. The clip books that are provided with TextPad are stored in the Samples folder. If you modify

and save them, the changes will be saved in the folder specified for the Clip Library (User by default).
This mechanism is designed to protect your changes from future updates of TextPad.

. The sample clip books use the convention of a trailing "*" in the names of cuttings that have hot
spots.

See also:
Direct Editing



How to use the Clip Library: Direct Editing

Clip Books are plain text files with the extension .TCL. If you are careful, you can use TextPad's main
editor to create and maintain these files. Each file consists of a header, followed by one or more
cuttings.

Header:
ITCL=<id>, <comment>
ITITLE=<title>
ISORT=<y|n>
where:
<id> is an identification number in the range 1-999 (numbers above that are
reserved for our sample clip books). It must be unique for each clip book.
<comment> is any text, such as the author's name.
<title> is a short name that you will use to select this book.
Cuttings:
ITEXT=<title>
<cutting>
!
where:
<title> is a short name that you will use to select this cutting, and to sort them, if
required.
<cutting> is any text, except for an "!" in column 1. If your own text must start with "1",
escape it using "\!". The characters \* will be interpreted as the hot spot. If
you need to use \” literally, escape it using \\*.
! marks the end of a cutting. Precede it with a blank line, if you want the
cutting to finish with a line break.
Notes:
] When you have edited a .TCL file manually, you can make the changes visible by selecting the
Refresh command on the Clip Library's context menu.
. Do not edit the sample clip books in the Samples folder. Copy them to the Clip Library folder first

(specified on the Folders tab of the Preferences dialog box), or your changes will get lost when you next
update TextPad.

. The Clip Library searches for .TCL files in the Clip Library folder first, followed by the Samples
folder. It uses the first one that it finds with a given identification number.
. If you create any interesting clip books that you would like to contribute to our collection, please

let us know. We will make them available from our web site, with full credit given to each author.
See also:

Editing



How to use the Clip Library: Repositioning
32-bit Edition Only:
The Clip Library is normally positioned (docked) at the left hand side of the main window. It can also be
docked at the right hand side, or floated. To move it, click and drag the separator between the drop-

down list of books, and the list of clippings. Double clicking that separator will cause the Clip Library to
float. When it is floating, double click its title bar to move it back to the last docked position.

You can resize the Clip Library, using the mouse, when it is floating or docked.



How to Customize: Overview

You can customize various settings to your own preferences, and these settings are preserved between
sessions (except as explained below). All user-configurable settings are accessible from the Configure
menu. You can also configure properties for the active document by choosing the Properties command
from the popup menu that is displayed when you right click in its window.

Some of the configuration dialogs (e.g. Font) give you the option to have the settings apply to the active
document only, or to all documents. Only settings that are applied to all documents are preserved
between sessions.

Click the Contents button to see the various options that can be customized, or the next item button (>>)
to step through them one at a time.



How to Transfer Preferences between PC's
Before transferring any preferences, first exit from TextPad, so that they are updated.

If you want to transfer any macros, these are stored in files *. TPM, normally in the USER folder in your
TextPad installation directory. Copy those files to the same folder on the other PC. (See also: How to
Customize the Macros Menu.)

If you have customized any key bindings, these are stored in the fle CUSTOM.BND, normally in the
USER folder in your TextPad installation directory. Copy that file to the same folder on the other PC.
Windows 3.1:
All preferences are stored in TEXTPAD3.INI in the WINDOWS directory. Simply copy that file to the
other PC.
Windows 95 and NT 4:
All preferences are stored in the Windows registry. These may be transferred as follows:

1. Run REGEDIT.EXE

2. Select the key HKEY_CURRENT_USER\Software\Helios\TextPad 3

3. From the Registry menu, choose the Export command.

4. Export the selected branch to a .REG file.

5. Copy the file to the other PC and use the corresponding Import command to load the preferences

from the file. (You could also just double click the .REG file in Explorer.)

Windows NT 3.51:

All preferences are stored in the Windows registry. These may be transferred as follows:
. Run REGEDT32.EXE
. Select the key HKEY_CURRENT_USER\Software\Helios\TextPad 3
. From the Registry menu, choose the Save Key command.
. Export the selected branch to a file.

. Copy the file to the other PC and use the corresponding Restore command to load the preferences
from the file.

a b wN -



Set this Option:
Save settings on exit

Save the workspace

Allow multiple instances
to run

Use multiple selection
Open File dialog box

Allow multiple files on
the command line

Working directory
follows active document

Display startup logo

Use OLE drag and drop

Display full path names
on the Document
Selector

Start with a new
document

How to Customize General Preferences
You can customize these general settings by choosing Preferences from the Configure menu:

To Do This:

Save all settings between sessions. Note
that settings are not saved if TextPad is
started with the command line parameter "-
s", which is supplied by Explorer and File
Manager, when you double click a file.

Save the state of open documents between
sessions, so that you can continue from
where you left off.

Allow more than one instance of the
program to run at a time. This is not
possible for the 16-bit edition.

Allow multiple files to be selected in the
Open File dialog.

Allow more than one file at a time to be
passed to TextPad via its command line.
Check this option if you want to use
Explorer's Send To command with more
than one file, but see Erequently Asked
Questions first.

Automatically change working directory, to
match that of the active document.

Suppress the "splash" logo window that is
displayed while TextPad starts up.

Enable the drag and drop capabilities. This
setting can only be changed when no
document windows are open, and OLE2 has
been installed. 16-bit edition only: uses
non-OLE drag and drop when not set.

Display as much of the path as can be fitted
in the Document Selector, otherwise omit the
path and just display the file name.

Open a new document, if no files are
opened when TextPad is started.



How to Customize Binary Extensions

TextPad has a built-in list of file extensions that it associates with binary files, such as ".EXE". If you
open one of these files, it will be displayed in hexadecimal. To modify the list:

1. Choose the Preferences command from the Configure menu.

. Select the Binaries tab.

. To delete an entry, select it from the list, and click Delete.

. To add a new entry, type it in the New Extension box, and click Add.
. To reinstate the defaults, click Set Defaults.

. Click OK.
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How to Customize Colors

The screen colors used for normal and selected text, bookmarks, and the left margin can be modified as
follows:

. Choose the Preferences command from the Configure menu.
. Select the Colors tab on the Preferences dialog box.

. Choose the item that you want to change the color of.

. Select the required foreground and background colors.

. Click OK or Apply.

Notes:

The colors are initially "automatic”. This means that they automatically change to match the colors set
for your Windows desktop.

The background color of bookmarks is not used.

The foreground and background colors of the left margin are used to differentiate the active and inactive
parts of a split view, and to paint line numbers.

—_
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How to Customize Compatibility Preferences
TextPad can be configured for compatibility with other applications as follows:
1. From the Configure menu, choose Preferences;
Select the Compatibility tab on the Preferences dialog box;
Choose the application from the drop-down list box;
Check "Show command shortcuts on menus", if you want to see them there.

Check "Use Microsoft's conventions for mouse click selection”, if you prefer to single click in the left
margin to select the line.

6. Check "Use POSIX regular expression syntax”, if you prefer to use that when searching for text. See
How to Use Regular Expressions for the differences between the default syntax and POSIX syntax.

7. Click OK or Apply.

Notes:

Keystroke compatibility with other applications uses the closest matching command in TextPad. It may
be possible to obtain a closer match in some cases by recording a keystroke macro, and assigning a
compatible shortcut to that.

The default shortcuts for TextPad are listed in the Reference section, under the heading The Keyboard.
You can view and modify the chosen shortcuts on the Keyboard tab of the Customize dialog box.
If you change the compatibility mode, any custom shortcuts that you have defined will be lost.

o wDd



How to Customize Document Preferences

You can customize these document settings by choosing Preferences from the Configure menu to
change all documents, or by choosing Document Properties to change them for the active document:

Set this Option:
Word wrap long lines

Constrain the cursor to
the text

Maintain indentation

Automatically indent
blocks

Remove trailing spaces
when saving

Clear undo buffer when
saving.

Read only

Automatically terminate
the last line

Send documents as e-
mail attachments

Save with no breaks in
lines

Save with hard breaks

Break at column #

To Do This:
Word-wrap lines that are wider than the view,
or than the column specified for hard breaks.

Restrict the position of the cursor to the
existing text. Otherwise it can be placed
anywhere in the document window. In
word-wrap mode, the cursor is always
constrained.

Automatically indent each new line by the
same amount as the preceding line.

Indent a new line following a line ending with
{, and unindent a } on a line on its own.
Maintain Indentation must also be set.

To strip trailing spaces and tabs from each
line as the file is saved.

Prevent edits from being undone, after a file
has been saved. Also reduces the risk of
memory overflows after a lot of edits.

Prevent the document from being edited.
This cannot be set if the document has
already been modified.

To add line termination characters to the last
line when saving the file, if it was
unterminated.

To send the document as an attachment to
e-mail, instead of placing the text in-line in
the message. Files larger than 32kb are
always sent as attachments.

Save word-wrapped documents without
actually breaking the lines as wrapped.

Insert new line characters at line breaks,
when saving word-wrapped documents.

Wrap lines at the specified column position,
otherwise fit to the current view.




How to Customize File Associations

Most applications are entirely responsible for the files that they manage (e.g. MS Word and its .DOC
files), so they can register all file associations during the installation process, and guarantee that the
associations are made correctly. Text editors don't have that luxury. They can be associated with all
sorts of files, with scope for all sorts of problems (and support calls to us) if it's not done right. It was
easy on Windows 3.1: by adding an entry for TextPad to the registry, you could use File Manager's
Associate command to correctly associate an extension with that entry. If you do the same thing on
Windows 95, you lose the correct description for the file, and any additional functionality that the original
association may have had (e.g. with .BAT files, you can either edit or run them). Hence TextPad
provides its own way to make associations.

By associating TextPad with file extensions, Explorer or File Manager will know to start TextPad when
you want to edit such a file. Change the associations as follows:

1. From the Configure menu, choose Preferences. The Preferences dialog box is displayed.
. Choose the Associations tab.

. Type an extension in the New Extension box, or choose one from the drop-down list.

. Type the description of such files in the Description box.

. Click the Add button.

. Repeat steps 3-5 for each new extension.

. Click OK or Apply.

To revert an association back to its default:
1. Select the extension from the list box.
2. Click Delete.
3. Repeat steps 1-2 for each extension to delete.
4. Click OK or Apply.

Notes:
Clicking Cancel will leave your current associations intact.

If you have associated extensions with releases of TextPad earlier than 1.31, they will not show up in the
list initially. You must remake the associations to get them in the list. The uninstall program uses
this list to reinstate the default associations.

~NOoO b~ WDN



How to Customize File Backups

When you save a file, you can keep a backup copy of the original. To customize the settings, choose
Preferences from the Configure menu and select the Backup tab on the Preferences dialog box:

Set this Option: To Do This:

Preserve original file For safety, TextPad (32-bit only) normally
creator when saving saves changes to a temporary file, before
changes deleting the original. This loses the original

file creator. By checking this option, the
original file is overwritten, which preserves
the creator, at the risk of losing the original
file if the save operation fails. This setting is
ignored for FAT file systems, which have no
concept of a file creator.

Automatically save Save all files at the specified interval. The
every xx minutes Save As dialog box will be presented for
each untitled document.
Backup files before Copy the original file to a backup with one of
saving changes the following names, before saving changes.
FILE.BAK Backup FILE.EXT as FILE.BAK
FILE.BAK.EXT Backup FILE.EXT as FILE.BAK.EXT
FILE.EXT.BAK Backup FILE.EXT as FILE.EXT.BAK
FILE.EXT in folder Backup FILE.EXT with the same name in the

specified folder.
Notes:

On file systems that do not support long file names, FILE.EXT will always be backed up as FILE.BAK
(unless a backup folder is given).

Only a single backup copy is kept, which is overwritten on each file save.



How to Customize File Filters

File filters are the list of wild cards in the List Files of Type box on the File Open dialog box. You can
add to the default list as follows:

1.
2.

3.

From the Configure menu, choose Preferences. The Preferences dialog box is displayed.

Select the Filters tab and Click New. The word New is displayed in the Filters and Descriptions
boxes.

Replace this word in the Description box with the text that you would like to describe the filter. eg.
Assembler Files (*.asm, *.inc).

. In the Wild Cards box, type the corresponding list of wild cards, separated by semicolons. eg.

*.asm; *.1inc.

. Click Move Up or Move Down to change the position of this filter in the list. The first entry in the list

will normally be used as the default each time TextPad starts up. However, if TextPad loaded a
workspace when it started, the initial filter will be set to the last one used.

. Click OK.



How to Customize File Preferences

You can customize these file settings by choosing Preferences from the Configure menu:

Set this Option:
Number of recent files
on File menu

Default file extension

Treat Ctrl+Z as end of
file marker.

Work on DOS files in the
ANSI code set.

When files are modified
by another process:
Prompt, Auto-Reload or
Ignore

Default code set:
ANSI or DOS

Create new files as:
PC, UNIX or MAC

To Do This:
Set the number of most recently used files
on the File menu to between 1 and 16.

If you open or save a file using the File Open
or Save As dialog boxes, and do not specify
a file extension, this string will be used. It
must not include spaces or dots.

Prevent TextPad from reading any
characters after a Ctrl+Z (hex 1A) in a file.

Files that you open as DOS will be
converted to ANSI when opened, and back
to DOS when saved if you check this box.
This option can only be changed when no
documents are open.

If an open file is modified by another
process: Prompt will ask if it's OK to reload
it; Auto-Reload will reload it automatically,
unless it's been modified; Ignore will ignore
the change.

Set the default code set used. Click DOS if
you want to use most of your text files with
DOS applications, otherwise click ANSI.
This setting is used for dropped files, and
files opened by double clicking, but can be
overridden for individual files on the Open
File dialog box.

Choose the option for the default end of line
characters saved with new files.



How to Customize Folders

These folders, used to store various file types, can be customized using the Folders tab of the
Preferences dialog box. The default is the folder USER in the TextPad installation directory, so you will
probably want to use a different folder if the installation directory is on a file server.

File Types: Purpose:
Backup Backup copies of files. (Can also be configured on
the Backup tab.)
Clip library (*.TCL) Personal books of cuttings for the Clip Library.
Custom shortcuts (CUSTOM.BND) Personal command shortcuts.
Macros (*.TPM) Personal keystroke macros.
Startup The initial working directory (defaults to the desktop).

This will also be the working directory when no
documents are open. Note that this is overridden by
the "Working directory follows active document”
option on the General tab.

User dictionaries (U*.LEX) Stores words added to the spelling checker.

HTTP Root If you need to edit files in an active local web server
(such as MS Personal Web Server), specify the full
path to its root directory here. More information.

HTTP IP Address The IP address of the local web server, in the form:
http://a.b.c.d. This defaults to the local host IP
address: http://127.0.0.1

To Change a folder:

1. From the Configure menu, choose Preferences. The Preferences dialog box is displayed.
2. Choose the Folders tab.

3. Click the folder in the list, and it will be transferred to the edit box.

4

. Either type the new folder name in the edit box, or click the browse button (32-bit edition only), and
select it graphically.

5. Click Apply, or OK.



How to Customize Hypertext Expressions

You can change the regular expression used in hypertext jumps from the Command Output window as
follows:

1. From the Configure menu, choose Preferences. The Preferences dialog box is displayed.
2. Choose the Jumps tab.

3. Clear the Use Defaults check box.

4

. In the Regular Expression box, type the regular expression that matches the text in the Command
Output window. This must include at least two tagged expressions for the filename and line number,
and optionally a third for the column number. It must also match the start of the line. Up to 10 such
expressions are saved in the drop-down list.

5. In the Register boxes, set the indexes corresponding to the tagged expressions defined in the last
step.

6. Check Use Defaults, if you want to revert to the default expression.
7. Click OK.

More Information:

The Command Output window is used to capture the output from the Run command, or from tools
added to the Tools menu. If the output is from a compiler, or Grep type of program, it can be used to
jump directly to the corresponding source line using left double-click. Built-in support is provided for
output from Microsoft and Symantec (Zortech) compilers, in the form:

filename (line) : message

If this default is not suitable, it will be necessary to specify an alternative hypertext jump regular
expression. For example:

1. Microsoft and Symantec (Zortech) C/C++
Expression = ~\ ([~ (1+\) (\ ([0-9]1+\))
File Register = 1
Line Register = 2
2. Borland C/C++
Expression = *\ (Error\ |Warning\) \ (.+\) \([0-9]1+\):
File Register = 2
Line Register = 3
3. Java
Expression = *\ ([A-Za-z]:[":]1+\) :\ ([0-9]+\) :
File Register = 1
Line Register = 2
4. Keil C51
Expression =~.+ IN LINE \ ([0-9]+\) OF \([":]1+\):
File Register = 2
Line Register = 1
5. IAR Assembler
Expression = "\ ([*"]+\)",\ ([0-9]+\)
File Register = 1
Line Register = 2
6. PowerBASIC
Expression = "Error [0-9]+ in \ ([~ (1+\) (N ([0-9]1+\) :\([0-9]+\)
File Register = 1
Line Register = 2
Column Register = 3
7. Perl for Windows 95
Expression = ~.+at \ (.+\) line \([0-9]1+\)[.,]
File Register = 1
Line Register = 2
8. GNAT ADA
Expression = ~\ (.. [*:1+\) :\ ([0=91+\) :\ ([0-9]+\)



File Register = 1

Line Register = 2

Column Register = 3

. Generic filename(line,column)

Expression = ~\ ([~ (1+\) (N ([0-91+\),\ ([0=-91+\))
File Register = 1

Line Register = 2

Column Register = 3



How to Customize the Language
To choose a language for the user interface:
1. From the Configure menu, choose Preferences. The Preferences dialog box is displayed.
2. Choose the Language tab.
3. Select a language from the list box.
4. Click OK.

Notes:
This effects the language used for menus, dialog boxes, etc, but not the on-line help.
You have to restart TextPad after changing the language, before the change takes effect.

English is always available, but other languages are stored in DLL's with names of the form
"TXP32??7?.DLL" and "TXP16???.DLL". For example "???" is "DEU" for German and "FRA" for

French.



How to Customize the Printer
To choose a particular printer, or to set up the printed page layout and font:

1.
2.

3.

9.

10.
1.

Tip:

From the File menu, choose Print Setup. The Configure Printing dialog appears.
To change the printer, click the Printer button and the standard Print Setup dialog is displayed. Click
its OK button when you have made your selection.

To change the font, click the Font button and the standard Font dialog is displayed. Click its OK
button when you have made your selection. Note that this selection only applies to the printer, not
the screen font.

. To add a header and/or footer to each printed page, type the required text in the Header and Footer

boxes. You can also use header macros to get the file name, date and time:

. If you want the times in the header and footer to correspond to the creation time of the file being

printed, click File Time, else click Print Time.

. To set the page margins, fill in the Left, Right, Top and Bottom boxes. Note that if you set these to

less than the minimum that the printer allows, the settings are ignored.

. If you want lines that are too long for the page width to be wrapped on to the next line, click the Word

Wrap Long Lines box. Otherwise lines that are too long will be truncated.

. If you want line numbers to be printed, click the Line Numbers box. This is independent of any

setting for line numbering in the view.

If you have a color printer, and want to print with the colors you have selected for the screen, click
the In Color box.

Check "Double Space", if you want all lines to be double spaced on the printout.
Click OK when you have completed your changes.

To save on paper, use the Print Preview command on the File menu to check that your printer settings
are satisfactory.



How to Customize the Screen Font

Only fixed width fonts are allowed on the screen, so the screen font is set independently of the printer
font.

1. From the Configure menu, choose Screen Font. The Font dialog box is displayed.

. Check the DOS box, if you want to select a font for working with files in the DOS code set.
. In the Font box, choose from the list of fixed width fonts.

. In the Font Style box, choose from the list of styles.

. In the Size box, choose from the list of font point sizes.

. In the Script box (if available), choose from the list of scripts.

. In the Scope box, select Make Default, if you want these settings to be applied to all documents,
otherwise select Active Document to make a temporary change to the active document only.

8. Check Use on Printer if you want to print with this font as well.
9. Verify that the text displayed in the Sample box is satisfactory.
10. Click OK.

Notes:

Checking the DOS box makes no difference to the set of fonts that are displayed. lts only effect is to
specify that the chosen font will be used for documents that are edited in the DOS code set - even if you
choose an ANSI font. You can determine the code set of the active document either by double clicking
the message area on the status bar, or from the Statistics tab of the Document Properties dialog box.
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How to Customize Tab Stops
Tab stops and indentation can be set at regular intervals as follows:

1.

To change the default settings for all documents, choose Preferences from the Configure menu, and
the Preferences dialog box will be displayed. To make changes for the active document only,
choose Document Properties from the Configure menu, and the Properties For ... dialog box will be
displayed.

. Select the Tabs tab.
. In the Tab Size box, type the character spacing between tab stops.
. In the Indent Size box, type the character spacing for each line indentation. This is best set to the

same value as tab stops, otherwise indentation will be made up of a mixture of spaces and tabs.

. Check Convert New tabs to Spaces, if you want tabs converted to the equivalent number of spaces.
. Check Convert Existing Tabs to Spaces When Saving Files, if you want existing tabs converted to

the equivalent number of spaces. This does not make any changes, until a document is saved.

. Click OK.



Set this Option:
Tool Bar

with regular buttons

Status Bar

Clock

Popup tips

Visible alerts

Stay on top of other

windows

Visible spaces and
tabs

Block cursor

Vertical Splitter

Horizontal scroll bar

Line numbers

Minimize when last
document is closed

How to Customize View Preferences
You can customize these view settings by choosing Preferences from the Configure menu:

To Do This:
Display the tool bar at the top of the main
window.

Display the tool with buttons on it, rather than
using the flat style (32-bit edition only). The
flat style requires COMCTL32.DLL 4.70 from
Microsoft.

Display the status bar at the bottom of the main
window.

Display the digital clock on the status bar.
Display popup help by holding the mouse
pointer over a toolbar button, or a control
character (shows its decimal code).

Flash the window whenever the beeper is
sounded.

Keep the main window on top of all others,
even when another application is active.

In visible mode, spaces are shown as (=) , tabs
as (»), and line ends as (¥)).

Display the cursor as a block, instead of a
vertical bar. The cursor is temporarily changed
to the alternate form in overtype mode.

Allow each view to be split vertically into two
using the Split Window command on the
Window menu. The default is for views to be
split horizontally. This option is disabled if any
windows are open.

Display a horizontal scroll bar in each view.
This option is checked and disabled if Vertical
Splitter is checked.

Display line numbers in the left margin of each
view.

Minimize the main window when the last
document is closed. You can override this
option by holding the Shift key down when
closing the last document.




How to Configure Document Properties
To configure properties for the active document, choose Document Properties from the Configure menu,
then choose one of the following tabs from the dialog box:
Document for word-wrap and indentation settings.
View for scroll bars and visible spaces.
Tabs for tab settings.
Statistics for information about the document, such as its word count.



How to Configure View Properties

You can change these settings for the active view by choosing Document Properties from the Configure
menu, and selecting the View tab:

Set this Option: To Do This:

Horizontal scroll bar Display a horizontal scroll bar in this view.
This option is checked and disabled if Vertical
Splitter is checked on the View tab of the
Preferences dialog box.

Visible spaces and In visible mode, spaces are shown as (s) , tabs
tabs as (»), and line ends as (T)).
Line numbers Display line numbers in the left margin of this

view.



How to View Document Statistics

You can view these properties of the active document by choosing Document Properties from the
Configure menu, and selecting the Statistics tab:

Property: Notes:

Full name Shows the fully qualified file name. You may
need to scroll to the end if the name is longer
than the available display space.

Last saved at Shows the date and time that the document
was last written to its disk file.

Character count Shows the number of characters in the
document.

Line count Shows the number of lines in the document.
Note that a word-wrapped line is counted as a
single line.

Word count Shows the number of words in the document.

A word is composed of letters, numbers,
hyphens, underscores and apostrophes.

Code set This can be ANSI or DOS (OEM)
File type This can be PC, UNIX or MAC.



How to Customize the Keyboard

The shortcuts that are initially assigned to each command depend on the keystroke compatibility
selected on the Compatibility tab of the Preferences dialog box. Some commands are only accessible
if you assign a shortcut to them, since they do not appear on any of the menus.
You can set your own shortcuts for commands as follows:

1. From the Configure menu, choose Customize. The Customize dialog box is displayed.

2. Select the Keyboard tab.

3. Select the command category from the list, and the corresponding commands in that category will be

displayed.

4. Select the command you wish to set a shortcut for.

5. Type the shortcut in the "Press new shortcut key" box. It may consist of one or two characters.

6. Click the Assign button.

Notes:

Once you have customized the keyboard, new shortcuts that we implement in future releases will not be
implemented in your custom settings.

If a shortcut clashes with any you've created on the Windows desktop, the desktop gets precedence.

Shortcuts can use any key, except Ctrl+\, or the lock keys, Tab and Print Screen, in combination with
Ctrl, Shift and Alt modifiers.

No distinction is made between left and right modifier keys.

If you use a single ASCII character, such as "A", as a shortcut, you obviously won't be able to use it in
normal typing!

Two character shortcuts cannot be created if the first key is unmodified, unless it's a function key.

Two character shortcuts are displayed like "Ctrl+Q, B", but the comma is not typed.

If the shortcut is currently assigned to another command, it will be displayed below it on the dialog box.
If you click Assign, the shortcut will be transferred to the new command.

More than one shortcut can be applied to each command, but the shortcut that gets displayed next to
the command on its menu is chosen arbitrarily.

A shortcut can be removed from the list of current keys for a command, by clicking the Remove button.

All shortcuts can be reinstated to the defaults for the selected keystroke compatibility, by clicking the
Reset All button.

All command shortcuts for the selected category can be displayed in the Command Results window, by
clicking the List button.

Modified shortcuts are stored in the file CUSTOM.BND in the folder specified on the Folders tab of the

Preferences dialog box. This file is deleted whenever the compatibility mode is changed, or Reset
All is clicked.




How to Customize the Tools Menu
To can add an executable command:

1.

10.
1.
12.
13.

14.
15.

From the Configure menu, choose Customize. The Customize dialog box is displayed.

2. Select the Tools tab.
3.
4. Either use the Select File dialog to select an executable file and click OK, or click Cancel if you want

Click New, and choose Command. The Select File dialog is displayed.

to add a DOS internal command, such as DIR.

. Make any necessary changes to the command in the Command box. If you clicked Cancel in the

previous step, this will have been initialized to User Tool, which must be changed. Note that the
command must include its full path name, unless it is on your search path.

. Make any necessary changes to the text that will appear on the Tools menu in the Menu Text box.

This box is initialized from the text in the Command box.

. In the Parameters box, type any parameters required to run this tool. You can include any tool

macros here.

. In the Initial Directory box, type the startup directory for the command. This defaults to the directory

containing the tool. You can include directory tool macros here.

. Check Prompt for Parameters, if you want to supply different parameters each time you choose this

tool. The parameters you type in the Tool Parameters dialog at run time will be appended to those
in the Parameters box.

Check Run Minimized, if you want the tool to run displayed as an icon (16-bit edition), or to minimize
the Command Output window while the tool is running (32-bit edition).

Check Capture Output, if you want to see the output from the tool in the Command window. This
only applies to DOS or console commands.

Check DOS Command, if the tool is an internal DOS command, such as DIR or TYPE.

Check Save All Documents First, if the tool works on files that you may be editing. Even if you don't
check this option, and a tool uses any of the macros FC_File, FC_UNIXFile or FC_DOSFile, the
active document will be saved prior to running the tool.

Click Move Up or Move Down to set the order of this tool on the Tools menu.

Click OK.

To can add a 3rd party Windows help file for in-context help:

oA wWN

7.

. From the Configure menu, choose Customize. The Customize dialog box is displayed.
. Select the Tools tab.

Click New, and choose Help. The Select File dialog box is displayed.

. Select the Windows help file that you want to use for in-context help, and click OK.
. The menu text field will be initialized to "?", but you may change it to anything appropriate.
. Do not change any of the other fields. (The Parameters field contains an implicit "$Sel" parameter,

that will cause the current selection to be passed as the help search key.)
Click OK.

Examples:

1.

2.

Compiling the active file with the JAVA compiler:
Menu text: Compile JAVA
Command: JAVAC.EXE
Parameters: S$File
Initial directory: $FileDir
Capture Output: (x)

Viewing the active HTML document with Internet Explorer:
Menu text: View HTML
Command: IEXPLORE.EXE
Parameters: -nohome file:$File



3. Viewing the active HTML document with Netscape:
Menu text: View HTML
Command: NETSCAPE.EXE
Parameters: file://$File



Page Header/Footer Macros

The following macros can be used in the Header and Footer boxes in the Configure Printing
dialog box:

Use To Get

&n The normal font for subsequent text.

&b A bold font for subsequent text.

&1 An italic font for subsequent text.

&I A bold italic font for subsequent text.

&1 Subsequent text to be left justified.

&c Subsequent text to be centered (this is the default).
&r Subsequent text to be right justified.

&d The current date in Windows short form.
&D The current date in Windows long form.
&t The current time in Windows format.

&f The filename, excluding its path.

&F The full filename, including its path.

&p The page number.

&P The total number of pages.

For example: to get a page header that looks like:

Left Center Right
readme.txt Page 1 of 3 10/11/96

Setthe header to "s1lsfscsiPage &p of &P&r&n&d"”
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Quick Open File Dialog Box
This dialog box allows you to open a file, when you do not need the browsing capabilities of the standard
Open File dialog box, and you are willing to type the file name.
Use CtrI+Shift+O to bring up this dialog box. There is no menu or toolbar equivalent command.
It accepts single filenames, wildcards, or files specified as "@filename", where "filename" is the name of
a file containing a list of files to open, one per line. In all cases, UNIX or DOS path separators may be
used.

If you don't type an extension, the default extension (if any), specified on the Eile tab of the Preferences

dialog box, will be appended. If you don't want an extension, either type a trailing ".", or quote the file
name.

If you check "Search subfolders”, TextPad will open all files matching the name in the current folder, and
all its subfolders.

Click the Browse button to get the standard Open File dialog box.



Fill Selected Block Dialog Box
This dialog box appears when you choose the Fill Block command from the Edit menu.

Type in the character or characters that you want to fill the current block selection with. You can fill with
tabs by entering ‘\t’ as the fill character. If you actually want to fill with \t’, enter it as \\".



Manage Files Dialog Box
Use the manage Files dialog to:

O Copy Files

[ Delete Files

[0 Rename Files

O Update Timestamps of Files
The Browse button brings up the standard Open File dialog box, so that you can select the file or files

you want to manage.

Shortcuts:
Keys: F3




Copy/Rename/Move Dialog Box
This dialog box appears when you click Copy or Rename on the Manage Files dialog box.
Confirm that the files in the From box are what you want, and edit them if necessary, then type the
destination file name, wild card or directory name in the To box.
;(Ihe Browse button brings up the standard Open File dialog box, so that you can select the destination
ile name.



Delete/Touch Dialog Box
This dialog box appears when you click Delete or Touch on the Manage Files dialog box.
Confirm that the files in the edit box are what you want, and edit them if necessary. Then click OK.



Tool Parameters Dialog Box

This dialog appears when you choose a user tool from the Tools menu and you checked the Prompt for
Parameters box when you configured this tool.

Type any parameters that the program requires in the Parameters box, and click OK.



Go To dialog box
This dialog box is displayed when you choose the Go To command from the Search menu.
Type the required number in the edit box, and click Go To. You can specify that the number represents a

line, column, page or byte offset in the file. If you make the number signed, it will be interpreted as an
offset relative to the current position.

You can also use this command to go to the next bookmark. In this case, the number in the edit control
is ignored.

If you want to select everything between the current position and the specified offset, check the Extend
Selection box.

The parameters that you set can be recorded in keystroke macros.

Shortcuts:
Keys: Ctri+G



Go To Address dialog box

This dialog box is displayed when you choose the Go To Address command from the Search menu in Hex
views.
Type the required hexadecimal offset in the file in the Go To Address box, and click Go To.

Shortcuts:
Keys: Ctrl+G



Tip of the Day Dialog Box

This dialog box is displayed when the program starts up, or when you choose the Tip of the Day
command from the Help menu.

Click the Next Tip button, if you want to see each tip in turn, and click Close when you've finished. You
can stop the dialog box being displayed automatically by clearing the "Show tips on startup” check box.



Word Count dialog box
This dialog box is displayed when you choose the Word Count command from the Tools menu.

The counts apply to the whole document, if no text is selected, otherwise to the selected text only.

Shortcuts:
Keys: Shift+F9



How to Edit: Overview

TextPad loads an entire file into memory when you edit it, so the original file is not changed until you
save the changes. You can opt to keep the original file as a backup when saving changes.

UNIX, Mac and PC files use different end of line characters, which TextPad automatically recognizes.
These will be preserved when you save the file, unless you choose to save with a different format, using
the Save As command.

If a file has long lines, you can choose to scroll horizontally when the line extends beyond the right
margin, or have words wrapped at the right margin, or at a specified column position. If you specify a
column position, hard line breaks will be inserted where words are wrapped, when you save the
changes. Otherwise, the file is saved with long lines, which you can think of as paragraphs. You can
configure these settings using the Preferences command and selecting the Document tab of the
Preferences dialog box.

The basic functions for moving around in the text, and making simple edits follow the conventions of
other Windows applications, so you can get started immediately. The more powerful editing commands
are all on the menus, with their shortcuts shown against them, so you should be able to get up to speed
quickly.

Any changes you make (except converting the code set between DOS and ANSI) can be undone, and
you can redo changes you undo. You can opt to undo even after saving the changes, using the
Preferences command and selecting the Document tab of the Preferences dialog box.

You can record the commands to make repetitive edits as keystroke macros, which you can playback on
different parts of the text.




How to Move Around in Text

In the table below, you can use the Shift key in conjunction with the given keystrokes (excluding the
ones that use the Alt key), to extend the selection.

To Move the Cursor:
To the mouse cursor position

To the beginning of the file
To the end of the file
To first non-space character on a line

To the left margin

To the end of a line

Forward one character

Back one character

Down one line

Up one line

Forward one word

Back one word

Forward to end of current word
Back to end of previous word

To the start of the next paragraph
To the start of the previous paragraph
To the start of the first visible line
To the start of the last visible line
Scroll down one line

Scroll up one line

To a specified line, column or page
number

Press This Key:
Left button

Ctrl+Home
Ctrl+End

Home (Reassign this key to
"LineLeft", if you prefer it to go to
the left margin.)

Home twice

End

Right arrow

Left arrow

Down arrow

Up arrow

Ctrl+W or Ctrl+Right arrow
Ctrl+B or Ctrl+Left arrow
Unassigned

Ctrl+D

Ctrl+Down Arrow

Ctrl+Up Arrow

Alt+Home

Alt+End

Alt+Down arrow

Alt+Up arrow

Ctrl+G and fill in the number

Cursor Mode:

The cursor can be constrained to positions within the existing text only, or can be free to be placed
anywhere in the document window. This setting is changed with the Constrain Cursor command on the
Configure menu.

When the cursor is constrained, the left and right arrows wrap around to the previous or next line at the
beginning and end of a line respectively.

In block selection mode, the Constrain Cursor command is disabled.



How to Select Text

Text can be selected in block (column) or normal mode. Use the Block Select Mode command on the
configure menu to switch between modes.
To select any text with the mouse:

1. Press and hold the left button down at the start of the text you want to select.

2. Drag the cursor to the end of the selection, and release the button.

or
1. Click the left button at the start of the selection.
2. Hold the Shift key down and click the left button at the end of the selection.

To select any text using the keyboard:
1. Use any of the cursor motion keys to move the cursor to the start of the text you want to select.
2. Press and hold the shift key down while using the motion keys to move the cursor to the end of the
selection.
To select a word:
Move the cursor over the word and double click the left button.

To select a whole line:
Double click (or single click in MS compatibility mode) the left button in the left margin, next to the
line, or non word-wrap only: triple left click anywhere in the line.

To select a whole paragraph:

Word-wrap: triple click anywhere in the paragraph.
Non word-wrap: triple click (or double click in MS compatibility mode) in the left margin.
To select a block of text:
1. Make sure that word-wrapping is turned off.
2. Choose Block Select Mode from the Configure menu.
E Shortcut: Alt+Left click toggles block select mode on and off.
3. Use the keyboard or mouse to mark the selection as normal.
To select the whole document:
Choose Select All from the Edit menu (shortcut: Ctrl+A).
or
Click Ctrl+Left button anywhere in the left margin.

To cancel a selection:
Press ESC.

Notes:
If you want to select a lot of text, place the cursor at the start then do one of the following:

Use the Go To command to extend the selection.

Scroll down with the scroll bar, until the end of the text you want to select is visible, and then click
Shift+Left mouse button. (Scrolling using the Page Up/Down keys normally moves the cursor, but you
can use them instead of the scroll bar if the Scroll Lock key is on.)




How to Use the Clipboard
To insert text from the clipboard:
Position the cursor and choose the Paste (Ctrl+V) command from the Edit menu.
= Toolbar:

To copy selected text to the clipboard:
Choose the Copy (Ctrl+C) command from the Edit menu.
= Toolbar:
To move selected text to the clipboard:
Choose the Cut (Ctrl+X) command from the Edit menu.
= Toolbar:

To copy the line containing the cursor to the clipboard:
Cancel any selection (ESC) and choose the Copy Line command from the Edit menu.

To copy the word containing the cursor to the clipboard:
Cancel any selection (ESC) and choose the Copy Word command from the Edit menu.

To move the line containing the cursor to the clipboard:
Cancel any selection (ESC) and choose the Cut Line command from the Edit menu.

To move the word containing the cursor to the clipboard:
Cancel any selection (ESC) and choose the Cut Word (Ctrl+Q) command from the Edit menu.

To copy all bookmarked lines to the clipboard:
Choose the Copy Bookmarked Lines command from the Edit menu.

To move all bookmarked lines to the clipboard:
Choose the Cut Bookmarked Lines command from the Edit menu.

To append text to the existing contents of the clipboard:
Choose one of the Cut Append or Copy Append commands from the Edit menu.



How to Drag and Drop

You can use the mouse to move or copy text within a document, or to another document, as follows:

To move selected text:
1. Hold the left button down in the selection.
2. Drag the cursor to the new location.
3. Release the left button.

To copy selected text:

1. Hold Citrl+Left button down in the selection.
2. Drag the cursor to the new location.

3. Release the left button.

To cancel a drag-drop:

Press ESC, or

Click the right button, or

Release the left button in the selection.

Notes:

1. The Ctrl key can be pressed or released at any time before releasing the left button, to make the
drag a copy or a move.

2. If the new location is not visible, hold the mouse pointer at the edge of the window nearest to the
destination, and it will scroll through the file until the pointer is moved away.



How to Insert Text

Any normal characters that you type will be inserted at the cursor position. If any text is selected, it will
be deleted before inserting the first character that you type.

To change to overtype mode, where each character that you type replaces the one at the cursor
position, press the Insert key once. This will also change the "Ins" indicator on the status bar to "Ovr",
and the shape of the cursor from a vertical line to a solid block. Press the Insert key again, to switch
back to insert mode.

The Undo command will cancel the effect of consecutively typed characters, up to the end of a line.



How to Delete Text
You can delete different amounts of text as follows:

To Delete This:
Selected text

The next character

The previous character

To the start of the next word
Back to the last start of word
To the end of the line

The current line

The current word

The whole document
Lines with bookmarks

See Also:

Do This:
Delete or Backspace

Delete

Backspace

Ctrl+Delete

Ctrl+Backspace
Ctrl+Shift+Delete

Choose Delete Line from the Edit
menu

Choose Delete Word from the
Edit menu

Alt+Delete
Choose the Delete Bookmarked

Lines command from the Edit
menu.

How to Use the Clipboard for commands to save deleted text on the clipboard.



How to Change Case
Select the text to be changed, and then:
To Do This:
Change all to lower case
Change all to upper case
Invert the case of each character

Make the first character of each

sentence upper case and the rest
lower case

Make the first character of each word
upper case and the rest lower case

Use this Edit Menu Command:
Lower Case (Ctrl+L)

Upper Case (Ctrl+U)
Invert Case (Ctrl+K)
Sentence Case (Ctrl+Shift+K)

Capitalize (Ctrl+Shift+U)



How to Indent Lines
To increase the indentation of the current line or selected lines:
1. Select the lines to be indented.
2. Choose Increase Indent (Ctrl+l) from the Edit menu.
2 Toolbar:

=

To reduce the indentation of the current line or selected lines:
1. Select the lines to be unindented.
2. Choose Reduce Indent (Ctrl+Shift+]) from the Edit menu.

= Toolbar:
Notes:
When multiple lines are selected, you can also indent them using the Tab key or reduce their
indentation using Shift+Tab.
The indentation level of lines changes by increments of the indent size, which can be changed on

the Tab Settings property sheet.



How to Align Text

Currently selected lines, or the line containing the cursor, can be centered, or aligned to the left
or right margin as follows:

1. Place the cursor anywhere on the line, or select the lines to be centered.
2. Choose the required Alignment command from the Edit menu.
Notes:

Text is centered between column 1 and the right margin, as specified on the Document tab of the
Preferences dialog box.



How to Join Lines
You can join single or multiple lines, such that each line in turn is appended to the first, separated by a
single space.
To join a single line to the current line:
1. Cancel any selection (ESC).
2. Choose Join Lines (Ctrl+J) from the Edit menu.

To join multiple lines to the current line:

1. Select all the lines to be joined.

2. Choose Join Lines (Ctrl+J) from the Edit menu.
Note:
In word-wrap mode, this command is not shown on the edit menu, but is still available using its shortcut.



How to Split Long Lines
In word-wrap mode, you can split long lines into separate lines where they are wrapped, as follows:
1. Select the lines to split.
2. Choose Split Wrapped Lines (Ctrl+Shift+J) from the Edit menu.



How to Reformat Paragraphs
You can adjust the lengths of currently selected lines to the word-wrap margin. Words are moved
between the lines as necessary, and blank lines are preserved as paragraph separators.
To reformat paragraphs:
1. Select the lines to reformat. The current paragraph will be reformatted, if nothing is selected.
2. Choose Reformat (Ctrl+Shift+J) from the Edit menu.



How to Insert New Lines

To Create a New Line:

Press This Key:
After the current line Ctrl+Enter
Before the current line Ctrl+Shift+Enter

By splitting the current line Enter



How to Insert the Date or Time
You can insert the current date and time, using the formats defined with the International applet on
Control Panel, as follows:

To Insert this: Choose this Edit Command:
The current time

Insert Time
Today's date in short format

Insert Short Date
Today's date in long format Insert Long Date

Shortcuts:

Mouse: CtrlI+Right click at the insertion point.
Keys: Ctrl+F10.



How to Insert a Page Break
1. Move the cursor to the first line to be printed on a new page.
2. Choose Insert Page Break (Ctrl+Shift+L) from the Edit menu.

More Information:

This actually inserts the ASCII 0xOC (Ctrl+L) character in the text, but displays it on the screen as «, and
draws a line at the point where the page break would occur on a printer.

The Page Break character is only recognised when it is the first character of a line.




How to Insert a File
1. Move the cursor to the insertion point.
2. Choose Paste File (Ctrl+Shift+V) from the Edit menu.
3. Select the file you want to insert on the Open File dialog box.
4. Click OK.




How to Insert Line Numbers
To insert consecutive line numbers at the start of each line:
1. From the Search menu, choose Replace;
2. In the Find What box type "~" (without the quotes);

3. In the Replace With box, type "\1i " (without the quotes), if the line numbers start at 1, or
"\i(100) ",ifthey startat 100, etc.;

4. Check the Regular Expression box;
5. Click Replace All.

More Information:
See How to Generate Sequence Numbers.



How to Transpose Text
To transpose adjacent characters:

1. Move the cursor between the two characters to be transposed.

2. Choose Transpose Characters (Ctrl+T) from the Edit menu. The characters will be swapped
around.

To transpose adjacent lines:

1. Move the cursor to the end of the first line, or start of the second line.
2. Choose Transpose Lines (Ctrl+T) from the Edit menu. The lines will be swapped around.

To transpose adjacent words:

1. Move the cursor between the two words to be transposed. This may be on a space, or intervening
punctuation, or the beginning or end of a line.

2. Choose Transpose Words (Ctrl+Shift+T) from the Edit menu. The words will be swapped around.



How to Fill Blocks

Block filling is only enabled when block select mode has been set from the Configure menu, and a block
of text has been selected.

To fill with Characters:
1. Choose the Fill Block command from the Edit menu.
2. In the Fill Selected Block dialog box, enter the characters you want to fill with.

3. Choose the format of the fill characters within the selected block. They can be aligned left or right,
or repeated to fill the block.

4. Click OK.

To fill with Numbers:
1. Choose the Fill Block command from the Edit menu.

2. In the Fill Selected Block dialog box, enter the starting number, and the amount to increment it by.
These must be integers, and may be positive or negative.

3. Choose the format of the numbers within the selected block. They can be aligned left or right, or
with leading zeros to fill the block.

4. Click OK.

Notes:

To fill with a tab, enter "\t" (without the quotes). If you actually want to fill with the characters "\t", enter it
as "\\".



How to Display Spaces and Tabs

Displays spaces tabs and paragraph marks
as visible characters. Spaces are shown as (

), tabs as (»), and line ends as (1]).

Click the button a second time to hide visible spaces.
You can also turn them on and off from the View tab of the Preferences and Properties dialog boxes.



How to Type International Characters

You can insert any character, if you know its ANSI code, by holding down the Alt key and typing zero,
followed by the 3-digit code on the numeric key pad (Num Lock must be on). Alternatively, you can type
the DOS (OEM) code by omitting the leading zero.

The following table lists the shortcuts defined for common international characters, when using an
English language keyboard:

To obtain: . Type:
a, e, 1,0, u A, Ctrl+" (Grave Accent), the letter

E U
a4,6,i,06,uy,AEI0UY Ctrl+' (Apostrophe), the letter
V] Ctrl+7, the letter

a6 6 AN O Ctrl+~, the letter
4,6,1,0,0,V,AET100Y Ctrl+:, the letter

a, A Ctrl+@, a or A

x®, £ Ctri+&, aor A

o, CE Ctrl+&, 00r O

K3 Ctrl+&, s

¢ C Ctrl+, (Comma), cor C
6,b Ctrl+' (Apostrophe), d or D
2, d Ctrl+/,00r O

e i Ctrl+/, ? or!

Notes:

Do not type the comma, except for ¢ and C.

On the English keyboard layout, the character "A" is typed using Shift+6, so the prefix Ctrl+ is
equivalent to Ctrl+Shift+6. This applies to any other shortcut prefixes in the shift position on your
keyboard.

These shortcuts can all be modified on the Keyboard tab of the Customize dialog box.
The default shortcuts are only defined for TextPad and MS Applications compatibility mode.



How to Type Control Characters

You can type control characters using Ctrl+Num* (* on the numeric keypad), followed by A to Z, or the
characters "\]* ". For example, Ctrl+Num*, A generates the same character code as if you had typed
Ctrl+Ain a DOS window.

You can view control characters in the 32-bit edition by holding the mouse pointer over them. For
example, the BEL character is displayed as "*G (7)" in a popup tip window.



How to Cancel the Last Action

To cancel the last edit:
Choose Undo (Ctrl+Z) from the Edit Menu

Toolbar:

To cancel the last undo:
Choose Redo (Ctrl+Y) from the Edit Menu.

Toolbar:

To cancel all edits:
Type Ctrl+Shift+Z.

To redo all edits:
Type Ctrl+Shift+Y.

Note:
The Undo command can be repeated until all changes made since the file was opened, or last saved,

have been undone.



Frequently Asked Questions
Before reporting any problems, please check this list to see if there is a known solution:

How can TextPad open files with spaces in their names, passed to its command line?

Why can't TextPad open files with spaces in their paths, using the Open File dialog box on NT
3.51?

How can | open more than one file at a time with Explorer's Send To command?

When | save a file as NAME.EXT, why is it saved as NAME.EXT.TXT?

Why doesn't . HTML or .JAVA work as a default file extension?

How do | get the correct characters for visible spaces?

How do | get borders on my toolbar buttons?

Why do | get an error message from CTL3DV2.DLL or CTL3D32.DLL?

Why did drag and drop stop working after | upgraded TextPad?

Why doesn't TextPad preserve the original file's creator (and UNIX access modes) when it saves
changes?

How can | make Notepad use TextPad instead of WordPad for big files?
Why doesn't Page Up/Down move the cursor?
Why can't | delete a folder after | have edited a file in it?



How can TextPad open files with spaces in their names passed to its command
line?
TextPad can open more than one file at a time, using command lines like:
txtpad32.exe filel.c file2.h *.txt
So, if any of the names contain spaces, they must be quoted, as in:
txtpad32.exe "My File 1" "My File 2"

As a special case, a single filename, containing spaces, can be given without quotes, if the parameter -u
is also used, as in:

txtpad32.exe -u My File

Solution:

If you cannot arrange for quotes around file names, you can force TextPad to accept only a single file in
its command line as follows:

1. From theConfigure menu, choose Preferences;

2. Select the General tab on the Preferences dialog box;

3. Clear the checkbox against "Allow multiple files on the command line";
4. Click OK.

Additional Information:

1. This problem generally only arises if you have set up TextPad's file associations manually, using a
command of the form "txtpad32.exe %1", without quoting the "%1". If you use the Associations tab
on the Preferences dialog box to do it, File Manager and Explorer will communicate with TextPad
using DDE, rather than command line parameters, so spaces are not significant.

2. Note that there is a bug in Windows 95 Explorer which causes it to add an invisible "%1" (without the
essential quotes) to the command line when you use it to edit any associations. This overrides any
DDE configuration, and causes problems if filenames contain spaces. This "%1" can only be seen
and removed using REGEDIT.EXE.

3. Windows 95 is very inconsistent about how it handles file names containing spaces. For instance, if
you use Explorer to select some files with spaces in their names, then use Send To, TextPad will
open them successfully. This is because Explorer hands over the DOS 8.3 aliases for the names,
so the spaces disappear. However, when you double click a file, Explorer hands over its long file
name, unquoted, which causes the problem. The Open File dialog box is actually part of Explorer,
and it hands over long file names with quotes around them!



Why can't TextPad open files with spaces in their paths, using the Open File
dialog box on NT 3.51?

TextPad uses the common Open File dialog box, which has a design fault in Windows versions prior to
95 and NT 4. When it is enabled for multiple selection, it uses a space to separate each file name, so
gets confused if a name, or its path, includes spaces. The workaround is to clear the following option:

[ ]Use multiple selection Open File dialog box

on the General tab of the Preferences dialog box (or get the latest version of Windows!).




How can | open more than one file at a time with Explorer's Send To command?

By default, TextPad only allows a single filename to be passed via its command line. This is to avoid
confusion if there are any spaces in its name. Explorer's Send To command avoids this problem by
passing names using their DOS 8.3 aliases.

If you are sure that files with spaces in their names will not cause any problems with other applications
that use TextPad to view files, check the following option:

[ TAllow multiple files on the command line.
on the General tab of the Preferences dialog box.




When | save a file as NAME.EXT, why is it saved as NAME.EXT.TXT?
This is due to the way Microsoft implemented the Save As dialog box: If you supply an extension it

doesn't recognize (including none), it either appends the default extension, if the filter is "*.*", or the first
extension in the list for the selected filter. This behaviour is designed to enforce the strong association
between extensions and applications in Windows 95, but it does get in the way at times. One of the
most irritating aspects of this is that it can create files with names like FILE.XYZ.TXT, when you type

FILE.XYZ.

Solution:

To allow a file to be saved with an arbitrary extension, delete the default extension from the File tab of
the Preferences dialog box, and select "*.*" from the "Save as Type" list on the Save As dialog box.
Alternatively, you can force it to accept exactly what you type by putting quotes around the name.



Why doesn't .HTML or .JAVA work as a default file extension?

If you set the default file extension to .JAVA or .HTML, and save a new file without specifying the
extension, you only get a 3-character extension. This is due to a bug in Windows 95. The workaround
is to type the extension yourself, or use NT 4 instead of Windows 95.



How do | get the correct characters for visible spaces?
In visible mode, spaces should be shown as () , tabs as (»), and line ends as (f]). [f the characters or
your display don't match these, try temporarily selecting a different screen font, then reselecting the
original one.



How to | get borders on my toolbar buttons?
If your computer has version 4.70, or later, of COMCTL32.DLL installed in the SYSTEM
directory,. TextPad will use a flat-style of toolbar, which raises the buttons as you move the mouse over
them. You can revert to the normal style by checking "With regular buttons" on the View tab of the
Preferences dialog box.



Why do | get an error message about CTL3DV2.DLL or CTL3D32.DLL?

These dynamic link libraries must be installed in your Windows system directory only. If you also have
a copy in the TextPad installation directory, or anywhere on your search path, it will notify you that it has
failed to load. The effect is that you will not get 3-D dialogs on Windows 3.1 or NT 3.51. (Windows 95
and NT 4 do not use the DLL's.) The solution is to delete all other copies of these DLL's.



Why did drag and drop stop working after | upgraded TextPad?

Editions of TextPad prior to 2.0 had a fallback implementation of drag and drop that didn't use OLE. It
used an anchor mouse cursor, instead of the conventional OLE one. If you were using that when you
upgraded, drag and drop will have been disabled. To enable it again:

1) Close all documents (in TextPad).

2) From the Configure menu, choose Preferences.

3) On the General tab, check "Use OLE drag and drop".
4) Click OK.

Note that you must have the OLE 2 system installed for this to work. It is standard with Windows 95
and NT, and you can get it for Windows 3.1 from:

http://www.microsoft.com/win32devsupport/content/fag/win32s/
and
CompuServe forum WINSHARE as WN32SOLE.ZIP.



Why doesn't TextPad preserve the original file's creator (and UNIX access modes)
when it saves changes?
For safety, TextPad (32-bit only) normally saves changes to a temporary file, before deleting the original.
This loses the original file's creator on file systems (such as NTFS) that maintain such information.
There is an option on the Backup tab of the Preferences dialog box to change this behaviour. When
selected, the original file is overwritten, which preserves the creator, at the risk of losing the original file if

the save operation fails.



How can | make Notepad use TextPad instead of WordPad for big files?

In Windows 95, when you attempt to open a file with Notepad, which is too large for it, a popup window

comes up asking if you want to open the file with Wordpad. Well, if you are like me, you deleted

Wordpad long ago or didn't even install it. So, how do you get Windows 95 to open the file with

Textpad? Easy! There are several ways like placing a copy oftxtpad32.exe in your WINDOWS folder

and renaming it to Wordpad.exe, but then you don't have access to all the functions of Textpad unless

you copy several other files to WINDOWS. Here is how to do it by changing 2 entries in the Registry.

1. Go to Start/Run, type in Regedit, then locate & open the following path:

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\App
Paths\WORDPAD.EXE

2. Click on the (Default) String Value in right pane and choose Modify

3. Enter the path of your Txtpad32.exe
e.g. C:\Program Files\TEXTPAD\TXTPAD32.EXE

4. Then, right click on WORDPAD.EXE and choose New String Value

. Type in PATH and hit enter.

6. Then right click PATH, choose Modify, and enter the path to your Txtpad32.exe
e.g. C:\Program Files\TEXTPAD

Now, reboot yourcomputer and the next time you click on a file to open it and the popup window comes
up telling you that the file is too large and asking if you want to open it with Wordpad, click OK and the
file will open with Textpad!

()]

This tip is brought to you by:
Alan W. Ray, Ray's Mfg. Co



Why doesn't Page Up/Down move the cursor

When the Scroll Lock key is on, the Page Up/Down keys behave the same way as when you scroll with
the mouse on the scroll bar - i.e. the cursor is not moved. You can then quickly get back to a known
position in the document by pressing one of the arrow keys.



Why can't | delete a folder after | have edited a file in it?

Windows does not allow you to delete a folder, if any application is using it as its current working
directory. The working directory of most Windows applications is automatically changed by the Open
and Save As dialog boxes, and TextPad optionally changes its working directory to match that of the
active document. Hence, you must open a file in another folder to make TextPad change its working
directory, before deleting a folder.

Note that if you have specified a startup folder (on the Folders tab of the Preferences dialog box), and
have not checked the option for the working directory to follow that of the active document (on the
General tab of the Preferences dialog box), TextPad will always change its working directory back to the
startup folder, when the last document is closed.



How to Create a New File
To create a new unnamed document:
From the File menu, choose New.

Toolbar:

The new document may be given a name using the Save As command on the File menu.

To create a new named file:
1. From the File menu, choose Open (Ctrl+O). The File Open dialog appears.

Toolbar:

2. In the Directories box, double-click a directory where you want to store the source file (or move up or
down a path to the appropriate directory).

3. Type the file name in the File Name box, and click OK. The default extension given to a file is .TXT,
unless you specify something else.

4. Click Yes on the message box that appears, asking if you want to create the file.
5. Use the editor to type the contents of the file.



How to Open an Existing File
1. From the File menu, choose Open (Ctrl+O). The File Open dialog appears.

Toolbar:

2. Select the drive and directory where the file is stored. The default is the current drive and directory.

3. Set the types of files to display in the List Files of Type box. Files with the chosen extension are
displayed in the File Name box. This box serves as a filter to display all files with a given extension.
For example, Source (*.cpp,*.c,*.h) displays all files with the given extensions. The drop-down box
initially lists commonly-used file extensions. Alternatively, you can specify wildcard patterns in the
File Name box to display file types. The new wildcard pattern is retained until the dialog box is
closed. You can also use any combination of wildcard patterns, delimited by semicolons. For
example, entering "*.TXT; *.INI" displays all files with those extensions.

4. If you want to override the automatically determined file format, choose from the drop-down list as

follows:
File Definition:
Type:
Auto A file with an extension matching the internal list

of binary extensions will be viewed in
hexadecimal, otherwise it will be opened as a

text file.
Text The file is read as text in the selected code set.
Binary The file is binary and will be viewed in
hexadecimal.

5. If you want to disable edits to the file, check the Read Only box.
6. In the File Name box, click a filename, then click OK.

Shortcut: Double-click a filename.
See Also: The Quick Open command.

Tips:

You can select multiple files to open at once, by using Ctrl+Left button to select each in turn, or
Shift+Left button to select a range of files.

The use of spaces for multiple file opening conflicts with long file names (except on Windows 95),
so to see long file names in the File Open Dialog, uncheck “Use multiple selection Open File dialog box”
on the General tab of the Preferences dialog box.

The default directory for opening and saving files is the current working directory. When TextPad
is started, its working directory is the one defined on the shortcut it was started from. This can be
overridden by defining the "Startup” folder on the Folders tab of the Preferences dialog box.
Subsequently, the working directory is changed whenever you select another directory with the Open or
Save As dialog box. You can also arrange that the working directory is always the same as that of the
active document by checking "Working directory follows active document" on the General tab of the
Preferences dialog box.



How to Open a File or URL Named in a Document
To open a file that is named in an open document, either:

1. Select the file name in the text, and use the Go To File command (Ctrl+Shift+G) to openit. This
command is not on a menu.

2. If the file is specified in an include statement with one of the syntaxes listed below, either right click i,
and choose the Open command from the context menu, or place the cursor anywhere on the file
name, and use the Go To File command.

#include "filename"

#include <filename>

!include "filename"

$include "filename"

<include file="filename">
<!——#include file="filename" -->

To open a URL that is named in an open document:

Select the URL in the text, or place the cursor anywhere in it, and use the Go To File command
(Ctrl+Shift+G) to open it. This command is not on a menu.



How to Open a Hex View of a File
1. From the File menu, choose Open (Ctrl+O). The File Open dialog appears.

Toolbar:
2. Select the file to open.
3. Click the down arrow next to the File Format box.
4. Choose "Binary" from the drop-down list.
5. Click OK.

Tips:
You can select multiple files to open at once, by using Ctrl+Left button to select each in turn, or

Shift+Left button to select a range of files.

The use of spaces for multiple file opening conflicts with long file names (except on Windows 95),
so to see long file names in the File Open Dialog, uncheck “Use Multiple File Open Dialog Box” on the
General tab of the Preferences dialog box.



Binary File Extensions
The following file extensions are assumed to be associated with files containing binary, or non-textual
data:

COM .EXE .DLL SYS DRV .386 .DOS
LIB .OBJ .PIF .RES .SYM .BIN ZIP
FON .FOT .TTF .MID WAV  .GRP .VBX
WMF  TIF PCX BMP .CUR .ICO .TWS
HLP .PPT  .DOT .WRI .MDB  .DBF .FRX
XLS .IMP WK1 WK2  \WK3 WK4

You can customize this list from the Binaries tab of the Preferences dialog box.



How to Save a File
1. Switch to the source window.
2. From the File menu, choose Save (Ctrl+S).

Toolbar:

3. If your file is unnamed, the Save As dialog box is displayed. In the File Name box, type the
filename.

4. In the Drives and Directories boxes, select a drive and directory.
5. Click OK.

Note:

If the file has been modified by another process, since it was opened for editing, the Save As dialog box
will be displayed so that you can opt to save it with a different name.



How to Save a File with a Different Name
1. From the File menu, choose Save As. The Save As dialog box appears.

2. Select the drive and directory where the file is to be stored. The default is the current drive and
directory.

. Choose the File Format if you want to convert from the original.

. In the File Name box, type the filename.

. Check the "Selection only" box, if you want to save the selected text to a new file.
. Click OK.
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How to Save the Workspace

You can arrange for TextPad to "warm start" - that is, start up exactly where you left off when you last
shut it down. To enable this feature:

1. Choose Preferences from the Configure menu. This brings up the Preferences dialog box.
2. On the General tab, check "Save the Workspace".
3. Click OK.

Notes:

The workspace is preserved in a file called TEXTPADO.TWS in your Windows directory.

If more than one instance of TextPad is running, only the workspace of the first one to be started will be
preserved.

If TextPad is started up with the command line parameter "-s" (which is how DDE starts it), the
workspace is not restored, nor saved when you exit.

On Windows 95, if this option is enabled and you shut down Windows while TextPad is still running, it
will be automatically restarted when Windows starts up again.



How to Close a File
1. Switch to the file's window.
2. From the File menu, choose Close. This action closes the active window and any additional views of
the window.
Tip:
When the Document Selector has the input focus, pressing the Delete key closes the highlighted file.



How to Convert a File for PC, Unix or Mac
1. From the File menu, choose Save As. The File Save As dialog appears.

2. Select the drive and directory where the file is to be stored. The default is the current drive and
directory.

3. In the File Name box, type the filename.
4. Choose the file format from the drop-down list as follows:

File Definition:

Format:

PC The file is saved in DOS PC format with a
carriage return/line feed at the end of each
line.

UNIX The file is saved in the UNIX format with a
line feed at the end of each line.

MAC The file is saved in the Apple MAC format

with a carriage return at the end of each line.
5. Click OK.



How to Work with DOS Files

Overview:

Windows applications normally use the ANSI code set, while DOS applications use the DOS code set
(also known as OEM and IBM). The numeric codes that are assigned to the English alphabet, numbers
and various other common characters are the same in both sets, but characters with codes above
decimal 127 (hex 7F), such as the line drawing set, use different codes, and some are unique. Another
factor is that they also depend on which code page is active.

Text on the clipboard presents an additional complication. If it has been cut or copied from a DOS box,
TextPad will convert it to the ANSI code set before pasting, unless you work in the DOS code set as
described in option 3 below.

Fonts:

Some versions of Courier New can display in either the ANSI or DOS code set, but most TrueType fonts
are only available in ANSI. The standard DOS raster font is called Terminal on Windows 95 and NT,
and VGAoem or 85140em on Windows 3.1. In some cases, MS LineDraw may be a suitable TrueType
alternative to the DOS raster font.

If you decide to work on DOS files in the DOS code set (see option 3 below), you can choose which font
will be used by selecting it on the Font dialog box, and setting the DOS check box.

Options for working with DOS files:

1. There is a Convert command on the Tools menu to convert between the code sets. After converting
the text, TextPad selects the appropriate font for the current code set, so that characters are
displayed correctly.

Disadvantage: the process is not reversible for the unique characters.

2. You can choose to edit DOS files in ANSI, by setting the "Work on DOS files in the ANSI code set"
check box on the File tab of the Preferences dialog box. In this case, if you check the "DOS Code
Set" box when you open a file (or set it as the default on the File tab of the Preferences dialog box),
files are automatically converted to ANSI as they are read in, and back to DOS as they are saved.
Disadvantage: the process is not reversible for the unique characters.

3. You can edit a DOS file without converting the characters, by clearing the " Work on DOS files in the
ANSI code set " check box on the File tab of the Preferences dialog box. In this case, if you check
the "DOS Code Set" box when you open a file (or set it as the default on the File tab of the
Preferences dialog box), the font is automatically selected to use the DOS code set.

Disadvantage: edit controls in dialog boxes, such as Find and Replace, continue to use the ANSI
code set, so they will display some characters differently.



How to Set the Default File Folder
You can specify the default file folder using the Folders tab on the Preferences dialog box.

You can also change the default file folder (or working directory), by changing the way TextPad is
started. See under the appropriate heading below for how to do this with the version of Windows that
you have.

From a Windows 3.1/NT 3.51 Program Manager Icon:

1. Click the Program Manager icon for TextPad.

2. Type Alt+Enter to get its properties dialog box.

3. Fill in the Default Directory field with the required directory, and click OK.

From a Windows 95/NT 4 Desktop Icon:

1. Right click the desktop icon for TextPad.

2. Choose Properties to get the properties dialog box.

3. Fill in the Start In field on the Shortcut tab with the required folder name, and click OK.

From the Windows 95/NT 4 Taskbar Start Menu:

. Right click the Taskbar.

. Choose Properties to get the Taskbar Properties dialog box.

. Click the Advanced button on the Start Menu Programs tab.

Select "Programs" on the Explorer view.

Right click TextPad on the right hand pane, and choose Properties.

Select the Shortcut tab, and fill in the "Start In" field with the required folder name.
Click OK to close all the dialog boxes.

No oA wN -

Tip:
To keep TextPad's current working directory in the chosen folder, uncheck "Directory follows Active
Document" on the General tab of its Preferences dialog box.



How to Switch to a File's Window
Do one of the following:
Click anywhere in the window.
Choose the window name from the Window menu.
Double click the window name in the Document Selector.
Press Ctrl+F6 or Ctrl+TAB to cycle through the active source windows one at a time.



How to Create a Second View
You can split any window into 2 panes. By default, the splitter bar is horizontal, but you can change it to
vertical by closing all documents, and checking " Vertical Splitter" on the View tab of the Preferences
dialog box.
Using the Keyboard:
1. From the Window menu, choose Split.
2. Use the arrow keys to move the horizontal bar to where you want to split the window.
3. Press Enter to create the second view, or Escape to cancel.

Using the Mouse:

Drag == from the end of the scroll bar to where you want to split the window.
To Close the Second View:

Drag the splitter bar to the top or bottom of the view.

Note:

When synchronized scrolling is enabled, both views will scroll together. This mode can be disabled with
the command on the Configure menu.



How to Use the Document Selector
The Document Selector is a list box showing the each of the documents you are editing. You can
display it by choosing Use Selector (F11) from the Window menu.
The Document Selector displays the files in alphabetical order, and it can be resized to fit the file names

it lists. Its size and position are remembered between sessions. If " Display full path names on the
Document Selector" is checked on the General tab of the Preferences dialog box, the full path name is

listed, otherwise just the file name.

You can use the following keys when the Document Selector is active:

Use this Key::
Esc

Left Click
Ctrl+Left Click
Shift+Left Click
Left Double Click

Enter
Delete

Up Arrow
Down Arrow
Home

End

You can also choose the following commands from a popup menu, by right clicking the selection:

Command:
Close

Print

* Tile Across

* Tile Down

Properties

To Do This::
Close the Document Selector.

Select the document window. If not
already the active window, activate it.

Add the clicked entry to the current
selection.

Extend the list of selected documents
to the clicked entry.

Select and activate the document
window.

Activate the document window.

Close the selected document window.
Select the previous window in the list.
Select the next window in the list.
Select the first window in the list.
Select the last window in the list.

Function:
Close the selected documents.

Print the selected documents using
the current default settings.

Arrange the selected documents (or
all, if only one is selected) full height
across the main window.

Arrange the selected documents (or
all, if only one is selected) full width
down the main window.

Display the Properties dialog box for
the active document.

* The tile commands are not available on Windows 3.1. If more than 3 documents are selected Tile
Across and Tile Down have the same effect.



How to Print a File

1. Switch to the file’'s window.
2. From the File Menu, choose Print. The Print dialog box appears.

3. Click "All" for the print range.

4. Click OK.
Shortcuts:
Keys: Ctrl+P
Toolbar: @l

(Prints to the default printer, unless you hold Shift down at the same time)



How to Display a Page Before Printing
1. From the File Menu, choose Print Preview.
2. Click OK. The print preview mode will be set, starting at the page containing the cursor.
3. Click Next Page or Prev Page to see each page in turn.
4. Click Close to return to normal viewing mode.

Notes:
When you choose this command, the main window will be replaced with a print preview window in which

one or two pages will be displayed in their printed format. The print preview toolbar offers you options
to view either one or two pages at a time; move back and forth through the document; zoom in and out

of pages; and initiate a print job.

Shortcuts:
Toolbar: @l

Keys: Ctrl+Shift+P



How to Keep a Log
You can keep a log in the same way as with Notepad:

1. On the first line of a document, type the following at the left margin, making sure you include the
period.
LOG

2. On the File menu, choose Save.

Note:

Every time you open this document, TextPad will append the current time and date to the end of the
document, using the formats specified for Windows.



How to Copy a File
1. From the File Menu, choose Manage Files (F3). The Manage Files dialog appears.

Toolbar:

2. Type the name of the file that you want to copy. This may include a path if it is not in the current
working directory. The filename may be a wildcard pattern if you want to copy multiple files.

3. Click Copy. The Copy dialog appears.

4. Type the name that you want to give the copy. If this is just a pathname, the file is copied to that
directory, keeping its original file name.

5. Click OK.



How to Rename a File
1. From the File Menu, choose Manage Files (F3). The Manage Files dialog appears.

Toolbar:

2. Type the name of the file that you want to rename. This may include a path if it is not in the current
working directory. The filename may be a wildcard pattern if you want to rename multiple files.

3. Click Rename. The Rename dialog appears.

4. Type the new name that you want to give the file. If this is just a pathname, the file is moved to that
directory, keeping its original file name.

5. Click OK.



How to Delete a File
1. From the File Menu, choose Manage Files (F3). The Manage Files dialog appears.

Toolbar:

2. Type the name of the file that you want to delete. This may include a path if it is not in the current
working directory. The filename may be a wildcard pattern if you want to delete multiple files.

3. Click Delete. The Delete dialog appears.
4. Click OK to confirm that you really want to delete the file.



How to Update a File's Time Stamp
1. From the File Menu, choose Manage Files (F3). The Manage Files dialog appears.

Toolbar:

2. Type the name of the file that you want to update its last modified date to the current time. This may
include a path if it is not in the current working directory. The filename may be a wildcard pattern if
you want to update multiple files.

. Click Touch. The Touch dialog appears.
4. Click OK to confirm that you really want to update the file.

w



How to Compare Text Files

1

2.

3.

. From the Tools menu, choose the Compare Files command. The Compare Files dialog box

appears.

In the First File box, type the name of the first file to be compared. This is initialized with the
filename of the active document, if appropriate.

In the Second File box, type the name of the second file to be compared. If it has the same name in
another directory, just type the path name.

. Choose if you want to ignore differences due to upper and lower case letters.
. Choose if you want to ignore differences due to the number of spaces or tabs. Note that tabs or

spaces, where there are none in the other file, will still be flagged as a difference, unless they are
leading or trailing.

. Click OK to start the comparison.

The differences are written to the Command Results window using the following conventions:

Symbol: Meaning:
< Precedes each different line from the first file.
Precedes each different line from the second file.

a Means that the lines following were added.
d Means that the lines following were deleted.
c Means that the lines following were changed.

Separates changed lines in the first file from the
second.

For example, "14,26¢122,123" means that lines 14 to 26 in the first file are changed to lines 122 to 123
in the second file.



The ANSI Code Set

This table displays the full ANSI code set, for code page 850, using the Courier font:

0 1 2
00: NUL SOH STX
10: DLE DC1 DC2

20: ! "
30: 0 1 2
40: @ A B
50: P Q R
60: a b
70: o) a r
80: 0 ,
90: O N 4
AQ: i ¢
BO: ° + 2
Co: A A A
DO: b N 0]
EO: a a a
FO: o] fi o

See also: DOS code set
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The DOS Code Set
This table displays the full DOS code set for code page 850, using the Courier font:

oo:
i0:
20:
30:
40:
50:
a0:
70:
g0:
S0:
i0:
EO:
Co:
bo:
EQO:
FO:

See also: ANSI code set
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How to Find Text

You can find each occurrence of a combination of any characters, including uppercase and lowercase
characters, whole words, or parts of words, or regular expression.

To find text:

1. From the Search menu, choose Find (F5).
screen until you close it.

Toolbar:

This starts a modeless dialog box which remains on the

2. In the Find What box, type in the search string, or choose a previous string from the drop-down list.

3. Set the options you want to control the search.

Select:
Text

Hex
Match Whole

Word
Match Case

Regular
Expression

Backwards

Forwards

To:

Specify a text search
string.

Specify a search string
in hexadecimal.

Find occurrences of the
text as a whole word.

Find text having the
given pattern of
uppercase and
lowercase letters.

Specify that the search
string is a regular
expression.

Search the document
above the insertion
point.

Search the document
below the insertion
point.

4. Check "Extend selection", if you want to extend the selection from the cursor position to the matched

text.

5. Choose Find Next. If the search string is found, the screen scrolls so you can see the text in context.

or

Choose Mark All to place a bookmark on each line containing the search string.
6. Either close the dialog by clicking the Cancel button, or continue editing as normal.

Tips

1. The Find What box will be initialised with the current selection, if any (as long as it is on a single

line), or the last search pattern entered.

a b WN

Examples

. The Find Next command (Ctrl+F) will copy the current selection to the Find What box.
. To do a forward search after closing the dialog box, press Ctrl+F.

. To do a backwards search after closing the dialog box, press Ctrl+Shift+F.

. Match Whole Word is equivalent to the regular expression \<RE\>.



How to Replace Text

You can find and replace each or every occurrence of a text pattern, in the current file, or all loaded files.
To Replace Text:

1. From the Search menu, choose Replace (F8). This starts a modeless dialog box which remains on
the screen until you close it.

Toolbar:
2. Specify the text to replace as described in Finding Text.

3. Type the Replacement Expression in the Replace With box, or choose a previous string from the
drop-down list.

4. Set the scope of the search:

Select: To:

Active Search in current

Document document only.

Selected Search in currently

Text selected text in current
document.

All Search in all text in all

Documents open documents.

5. Choose one of the following actions:
a) Click Find Next to select the next occurrence.
b) Click Replace to replace the current selection.
c) Click Replace Next to replace the current selection, and find the next occurrence.
d) Click Replace All to replace all occurrences of the search text, in the specified scope.

Note that Find Next, Replace and Replace Next are only enabled when the scope is Active Document.

6. Either close the dialog by clicking Cancel, or continue editing as normal.

Tips:

The Replace button will replace the current selection, so make sure you press Find Next first.

Because edit controls do not allow tabs to be input, \t' is used (without the quotes) to represent a
tab. If you want to replace text with literal \' and 't' characters, specify \\t' in the Replace With box.

Beware of replacing a pattern that is matched with a regular expression that can optionally match

nothing, such as ".?" or "a*". In these degenerate cases, TextPad can go into a loop, until the line
becomes too long.

Examples



How to Use Regular Expressions

A regular expression (RE) is a search string that uses special characters to match patterns of text.
You can use them with the Find, and Find in Files commands, and with the Replace command in
conjunction with replacement expressions. TextPad's regular expressions are based on POSIX
standard P1003.2, but the syntax can be that of POSIX, or UNIX extended regular expressions (the
default). The choice can be made on the Compatibility tab of the Preferences dialog box.

To use a regular expression:
1. From the Search menu, choose Find, Replace, or Find in Files.
2. In the Find What box, type a regular expression.

3. Check the "Regular expression" box.
Summary of regular expressions:

Default
Operator:

[]

["]

\<
\>
\t
\f
\n

\xdd
\(Y)

POSIX
Operator:

[]

["]

\<
\>
\t
\f
\n

\xdd
()

Description:

Any single character. Example: h. t matches hat, hit, hot
and hut.

Any one of the characters in the brackets, or any of an
ANSI range of characters separated by a hyphen (-), or a
character class operator (see below). Examples:
hlaeiou] [a-z] matches hat, hip, hit, hop, and hut; [A-
za-z] matches any single letter; x [0-9] matches x0, x1,
ey X9.

Any characters except for those after the caret "*".
Example: h[~u] t matches hat, hit, and hot, but not hut.

The start of a line (column 1).

The end of a line (not the line break characters). Use this
for restricting matches to characters at the end of a line.
Example: ends only matches "end" when it's the last word
on a line, and “end only matches "end" when it's the first
word on a line.

The start of a word.

The end of a word.

The tab character.

The page break (form feed) character.

A new line character, for matching expressions that span

line boundaries. This cannot be followed by operators ™',
'+' or {}. Do not use this for constraining matches to the

end of a line. It's much more efficient to use "$".
"dd" is the two-digit hexadecimal code for any character.

Groups a tagged expression to use in replacement
expressions. An RE can have up to 9 tagged expressions,
numbered according to their order in the RE. The
corresponding replacement expression is \x, for x in the
range 1-9. Example: If \ ([a-z]+\) \ ([a-z]+\)
matches "way wrong", \2 \1 would replace it with "wrong
way".

Matches zero or more of the preceding characters or
expressions. Example: ho*p matches hp, hop and hoop.

Matches zero or one of the preceding characters or
expressions. Example: ho?p matches hp, and hop, but
not hoop.

Matches one or more of the preceding characters or
expressions. Example: ho+p matches hop, and hoop, but
not hp.



\{count\}

\{min,\}

\{min,max\}

\

Character Class Operators "[: ... :]":

{count}

{min,}

{min,max}

Matches the specified number of the preceding characters
or expressions. Example: ho\ {2\ }p matches hoop, but
not hop.

Matches at least the specified number of the preceding
characters or expressions. Example: ho\{1,\}p
matches hop and hoop, but not hp.

Matches between min and max of the preceding characters
or expressions. Example: ho\ {1, 2\ }p matches hop and
hoop, but not hp or hooop.

Matches either the expression to its left or its right.
Example: hop\ | hoop matches hop, or hoop.

"Escapes" the special meaning of the above expressions,
so that they can be matched as literal characters. Hence,
to match a literal "\", you must use "\". Example: \<
matches the start of a word, but \ \< matches "\<".

These can be used in class expressions as an alternative way of representing classes of characters.

For example, [a-z0-9] is equivalent to [[:lower:][:digit:]].

Example:

Expression
[:alpha]
[:lower:]
[:upper:]
[:alnum:]
[:digit:]
[:xdigit:]
[:blank:]
[:space:]

[:entrl:]
[:print:]
[:graph:]
[:punct:]

[:word:]
[:token:]

The defined classes are:

Description
Any ANSI letter.

Any lower case ANSI letter.

Any upper case ANSI letter.

Any digit or ANSI letter.

Any digit.

Any hexadecimal digit (0-9, a-f or A-F).
Space or tab.

Space, tab, vertical tab, return, line feed,
form feed.

Control characters (Delete and ASCII codes
less than space).

Printable characters, including space.
Printable characters, excluding space.

Anything that is not a control or
alphanumeric character.

ANSI letters, hypens and apostrophes.
ANSI letters, digits and underscores.

HTML tags are in matched pairs of <...>, such as <FONT SIZE=+1>.

ends on the same line, use the regular expression:
<[*>]*>

This matches a "<", followed by zero or more characters, excluding ">", followed by a ">".

To match any tag that begins and

Note that "*"

finds the longest matching sequence on a line, so the regular expression:

<.*>

would be incorrect, because it would not stop at the first ">", if there was more than one on the line.

For more information and examples, see regular expressions, and replacement expressions in the

Reference section.



How to Generate Sequence Numbers

You can update or insert sequence numbers in a file, using replacement expressions. This is achieved
using the Replace dialog box, with the Regular Expression box checked.

The syntax of the replacement expression is:

Expression: Effect:
\i Replace with numbers starting from 1, in steps of 1.
\i(10) Replace with numbers starting from 10, in steps of 1.
\i(0,10) Replace with numbers starting from 0, in steps of 10.
\i(100,-10) Replace with numbers starting from 100, reducing in
steps of -10.
Examples:
1. To insert line numbers at the start of each line:
Search for: ~
Replace with: \ i

2. To update sequence numbers of the form Axxx, Bxxx, ... ,Zxxx where "xxx" is any number >= 100,
independent of the letters, which are to be preserved:

Search for: \([A-Z]\) [1-9]1[0-9]1[0-9]+
Replace with: \1\1(100)



How to Find in Multiple Files

You can search for strings in either text (excluding Unicode) or binary files, as follows:

1. From the Search menu, choose the Find in Files command (Ctrl+F5). This starts a modeless dialog
box which remains on the screen until you close it.

Toolbar:

2. In the Find What box, either type the search string, or choose a previous string from the drop-down
list. (Check that Text or Hex is correctly set for the type of string in the Conditions box.)

3. In the In Files box, either type a list of files using wild cards, or choose a previous list from the drop-
down list. Note that by creating a file containing a list of file names, one per line, and specifying the
name of that file in this box, preceded by the character '@', this command will search the specified

files.

4. In the In Directory box, either type the pathname to the directory containing the files, or select a
previous directory from the drop-down list, or click Defaults to set it to the current working directory.

5. In the Conditions box, specify the search criteria as follows:

Select: To:

Text Specify a text search
string.

Hex Specify a search string
in hexadecimal.

Match Whole Find occurrences of the

Word text as a whole word.

Match Case Find text having the
given pattern of
uppercase and
lowercase letters.

Regular Specify that the search

Expression string is a regular

expression.
6. In the File Type box, choose Text if the files contain text, or Binary if they contain any NULL
characters.

7. In the Report Detail box, choose All Matching Lines if you want each matching line printed out, or
File Counts Only if you simply want to know how many occurrences there are in each file.

8. Click Search Subdirectories if you want to search through all files in the subdirectories of the
directory specified in step (4) as well.

9. Click Find.

Hypertext Jumps:

Matching strings are listed in the Search Results window. You can use this to jump to a line in its file by
double clicking the line.

To jump to the next occurrence, choose the Jump Next (F4) command from the Search menu.
Toolbar:

To jump to the previous occurrence, choose the Jump Previous (Ctrl+F4) command from the Search
menu.

Toolbar:
Open All:

To open all listed files, right click the Search Results window (or use Shift+F10), and choose Open All
from the popup menu. This can be constrained to a subset of the files by selecting the appropriate lines
first.



How to Find a Matching Bracket
To Find a Matching Bracket:
1. Place the cursor to the left of the bracket to be matched: ([{< or >}1])
2. From the Search menu, choose the Match Bracket command (Ctrl+M). If there is a matching
bracket, it will be selected.
To Find the First Closing Bracket:
1. Place the cursor anywhere in the text.

2. From the Search menu, choose the Match Bracket command (Ctrl+M). If there is one of the
characters >} 1), before the end of file, it will be selected.

To Select Text Between Brackets:
1. Place the cursor to the left of the bracket to be matched.

2. Type Ctrl+Shift+M. If there is a matching bracket, all intervening text will be selected. When
matching forwards, both brackets are selected as well. When matching backwards, neither bracket
is selected.



How to Use Bookmarks
To Set a Bookmark:

Lines can have bookmarks placed on them either by choosing the Toggle Bookmark command (Ctrl+F2)
from the Search menu, or by clicking Mark All on the Find dialog.

To Go to the Next Bookmark:
From the Search menu, choose the Next Bookmark command (F2).

To Go to the Previous Bookmark:
From the Search menu, choose the Previous Bookmark command (Shift+F2).

To Clear a Single Bookmark:
From the Search menu, choose the Toggle Bookmark command (Ctrl +F2).

To Clear all Bookmarks:
From the Search menu, choose the Clear All Bookmarks command (Ctrl+Shift+F2).

To Delete all Bookmarked Lines:
From the Edit menu, choose the Delete Bookmarked Lines command.

To Copy all Bookmarked Lines to the Clipboard:
From the Edit menu, choose the Copy Bookmarked Lines command.

To Cut all Bookmarked Lines to the Clipboard:
From the Edit menu, choose the Cut Bookmarked Lines command.

To Extend the Selection to the Next Bookmark:

From the Search menu, choose the Go To command. Check the Next Bookmark and Extend Selection
options on the Go To dialog box, then click OK.



Examples - Finding Text
See Also: Replacing Text
These examples all use UNIX extended regular expression syntax.
1. Find all trailing spaces:
[ \t]+$
finds one or more spaces or tabs followed by the end of line.
2. Find an empty line:
s
finds the beginning of a line immediately followed by its end.
3. Find everything on a line:
A x
finds the beginning of a line, followed by zero or more of any characters, up to the end of the line.
4. Find "$12.34":

\$12\.34
Note that '.' and '$' have been escaped using the backslash to hide their regular expression
meanings.

5. Find any valid C language variable name:

\ < [ a-zA-Z2][ a-zA-7Z0-9]*
finds a word starting with an underscore or alphabetic character, followed by zero or more
underscores or alphanumeric characters.

6. Find an inner-most bracketed expression:

(r~017*)
finds a left bracket, followed by zero or more characters excluding left and right brackets, followed by
a right bracket.

7. Find a repeated expression:

\([0-97+\)-\1
This uses a tagged expression "\(...\)" to find one or more digits, followed by a hyphen, followed by
the string matched by the tagged expression. So this regular expression will find 12-12, but not 12-
34.



Examples: Replacing Text
See Also: Finding Text

These examples all use UNIX extended regular expression syntax.
1. Find any alphabetic word starting with an upper case letter:

[A-Z] [a-z]+
and replace with the same word all in upper case:

\U&
2. Find a C language variable name starting with a lower case letter:

\<[a-z][_a-zA-Z0-9]1*
and make the first letter upper case:

\ué&
3. Find two numeric strings separated by one or more spaces:

\N([0=91+\) +\([0-91+\)
and swap them around, using a tab to separate them:

\2\t\1
4. Find "paste":
paste
and replace with the contents of the clipboard:
\p
5. To change:
X100000 to X100.000
Y100123 Y100.123
Z600 Z.600
Find: \(IXYZIN)N\N ([0=-91*\)\ ([0-9]1[0-9]1[0-91\)

Replace: \1\2.\3



Regular Expressions

Examples

A regular expression (RE) is a mechanism for describing patterns in text when executing the Find, the
Replace, and the Find in Files commands. An RE is made up of ordinary characters from the ANSI
character set, some of which take on the special meanings described below.

See How to Use Regular Expressions for the differences between the default syntax and POSIX syntax.

Ordinary Characters

An ordinary character is an RE that matches itself. It can be any character in the ANSI character set
except <newline> and the special characters listed below. An ordinary character preceded by a
backslash is treated as the ordinary character itself, except when the character is (, ), <, >, or the letters
f, n, t and x, or the digits 1 through 9.

Hex Characters
Any character can be represented by its hex value. This is specified with the pattern \xdd, where dd
is any 2-digit hexadecimal number, excluding zero.

Tabs
Atab character is represented by the pattern \ t.

Page Breaks
A page break (form feed) character is represented by the pattern \ f.

Line Breaks
Aline break is represented by the pattern \n. This matches carriage return and line feed characters.
Note that these cannot be combined with repetition operators (see below), so you can only match an
exact number of them (e.g. \n\n will match a single blank line.) Do not use this for constraining
matches to the end of a line, as it's much more efficient to use "$" (see Expression Anchoring below).
This pattern should only be used to match text that spans line boundaries.

Special Characters

These special characters, can be rendered ordinary by preceding them with a backslash (\), if they are
single special characters, or removing the preceding backslash if they are compound special characters.

Character Context

N The period, left square bracket, and backslash are special
except when used in a Class Expression.
7+ Asterisk, question mark and plus are special except when

used in a class expression, as the first character of an RE, or
as the first character of a Tagged Expression.

- The hyphen is special in a Class Expression, except as the
first or last character of that expression.

A The circumflex is special when used as the first character of
an entire RE (see Expression Anchoring), or as the first
character of a Class Expression.

$ The dollar sign is special when used as the last character of
an entire RE (see Expression Anchoring).
Wildcard Character
The period (.), when used outside of a class expression, matches any character except newline.

Repetition Operators

The asterisk (*) matches zero or more occurrences of the smallest possible preceding regular
expression, while the question mark (?) matches zero or one, and the plus sign (+) matches at least one
occurrence. For example, A*b+ matches zero or more A's followed by one or more b's.

Interval Operator

Repeats the smallest possible preceding regular expression the given number of times. The options
are:



\{count\} Matches exactly count times.
\{min,\} Matches at least min times.
\{min,max\} Matches between min and max times.

Alternation Operator
The alternation operator (\|) matches either the expression to its left or the one to its right. It has a lower
precedence of any other regular expression operator, so the surrounding RE's must be bracketed with \
(...\) if only a part of them is to be matched.

Class Expressions
A class expression is a RE, enclosed in square brackets ([...]), that matches any one of the elements
contained in the brackets. The permitted elements of a class expression are:
Simple Characters:

These are single characters that match themselves. To match a right square bracket (]), it must be
the first character of the class expression, after any initial circumflex (see Negated Class
Expressions). To match a hyphen, it must be either the first or the last character of the class
expression. For example [AaBb] matches upper or lower case A or B.

Negated Class Expressions:
If the first character of a class expression is the circumflex (*), the expression matches any character
not in the class. For example ["ABA] matches any character except A, B and the circumflex itself.
Range Expressions:

A range expression is two characters separated by a hyphen (-). It matches any of the characters in
the ANSI collating sequence, between the two characters. For example, [A-Za-z0-9-] matches any
upper or lower case letter or digit, or the hyphen itself.

Character Class Operators:

These can be used as an alternative way of representing classes of characters. For example, [a-
z0-9] is equivalent to [[:lower:][:digit:]]. The defined classes are:

Expression Description

[:alpha] Any ANSI letter.

[:lower:] Any lower case ANSI letter.

[:upper:] Any upper case ANSI letter.

[:alnum:] Any digit or ANSI letter.

[:digit:] Any digit.

[:xdigit:] Any hexadecimal digit (0-9, a-f or A-F).

[:blank:] Space or tab.

[:space:] Space, tab, vertical tab, return, line feed,
form feed.

[:entrl:] Control characters (Delete and ASCII codes
less than space).

[:print:] Printable characters, including space.

[:graph:] Printable characters, excluding space.

[:punct:] Anything that is not a control or
alphanumeric character.

[:word:] ANSI letters, hypens and apostrophes.

[:token:] ANSI letters, digits and underscores.

Expression Anchoring
An RE can be restricted to matching strings that begin or end a line or word, as follows:

A A circumflex as the first character of an RE anchors
the expression to the beginning of the line.
$ A dollar sign as the last character of an RE anchors

the expression to the end of the line.



\< The character pair \< anchors the next RE to the
start of a word.

\> The character pair \> anchors the previous RE to
the end of a word.

Tagged Expressions

A tagged expression is an RE that starts with the pair \( and ends with the pair\). There can be up to
nine such expressions in a complete RE. Such an expression matches the same as the expression
without the surrounding \( and \). The first expression defined in this way can be referenced as \1 later
in the RE, and so on up to \9 for the ninth tagged expression. Each such reference matches the same
string as its original tagged expression. For example \(tu\) \1 matches the string "tu tu".

References to tagged expressions can also be used in Replacement Expressions.



Replacement Expressions

Replacement expressions are used to substitute text in conjunction with Tagged Regular Expressions,

when using the Replace command.

Expression Definition

& Substitute the text matching the entire
search pattern.

\0 to \9 Substitute the text matching tagged
expression 0 through 9. \0 is
equivalent to &.

\f Substitute a page break (form feed).

\i<expression> Substitute a sequence number.

\n Substitute a newline.

\p Substitute the contents of the clipboard.

\t Substitute a tab.

\xdd Substitute the character with hex code
dd (must be 2 hex digits, excluding 00).

\u Force the next substituted character to
be in upper case.

\l Force the next substituted character to
be in lower case.

\U Force all subsequent substituted
characters to be in upper case.

\L Force all subsequent substituted
characters to be in lower case.

\E or\e Turns off previous \U or \L.

To substitute a literal \ or &, use \\ and \&.
Warning:

Beware of replacing a pattern that is matched with a regular expression that can optionally match
nothing, such as ".?" or "a*". In these degenerate cases, TextPad can go into a loop, until the line

becomes too long.



The Status Bar

| 1 | 2 ReadOvrBlock|Sync |Rec |Caps | 3:50 pm
The status bar is displayed at the bottom of the main window. To display or hide the status bar, use the
Preferences command in the Configure menu.

Theleft pane of the status bar describes the actions of menu items as you use the arrow keys to
navigate through menus. This area similarly shows messages that describe the actions of toolbar
buttons as you depress them, before releasing them. (If after viewing the description of the toolbar
button command you wish not to execute the command, then release the mouse button while the pointer
is off the toolbar button.)

The right hand panes of the status bar indicate the following information:
Indicator Description

1 The line number of the cursor.

2 The column number of the cursor.

Read The file is read-only, otherwise Edit is shown.

Ovr The Insert key is latched down, otherwise Ins is shown.

Block Block or Normal selection mode, or Wrap for word wrap mode.
Sync Synchronized scrolling of all views is enabled.

Rec A keystroke macro is being recorded.

Caps The Caps Lock key is latched down.

3.50pm The current time.

The status bar is active. This means that you can double left click any of its panes (except for Time) to
change the indicated state.



The Toolbar
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The toolbar is displayed across the top of the main window, below the menu bar. The toolbar provides

quick mouse access to many commands.
To display or hide the toolbar, use the Preferences command in the Configure menu.

The effect of some buttons can be modified by holding the Shift or Ctrl Key down when they are clicked,

as shown in this table:

Click Normal Operation With Shift With Ctrl

Opens a new document.

Opens an existing document Displays the
using the Open File dialog Quick File
box, in which you can locate Open dialog
and open the desired file. box.

Saves the active document Saves all Displays the
with its current name. If you modified files Save As
have not modified or named dialog box.
the document, the Save As
dialog box is displayed.

Displays the Manage Files
dialog box.

Prints the active document, Displays the Displays the
using the default printer. Print dialog Configure

box. Printing
dialog box.

Previews the printed layout of
the active document.

Rege Checks spelling.

Cuts the selection from the Cuts the
document and save it on the selection and
clipboard. appends it to

existing text
on the
clipboard.

Copies the selection to the Appends the
clipboard. selection to

existing text
on the
clipboard.

Inserts what's on the Inserts a file.
clipboard.

Cancels (undo) the last edit Undo all edits
command. back to the

last save
checkpoint.

Cancels (redo) the last Undo Redo all edits
command up to the last

save
checkpoint.

Reduces indentation of
selected text.

Increases indentation of

selected text.
Enables word wrapping.



LELE "

Displays spaces tabs and
paragraph marks as visible
characters.

Displays the Find dialog box.

Displays the Replace dialog
box.

Displays the Find in Files
dialog box.

Starts the keystroke macro
recorder.

Temporarily pauses the
keystroke macro recorder.

Plays back the scratch
keystroke macro.

Jumps to the previous item in
the search or command
window.

Jumps to the next item in the
search or command window.

Displays a cursor to click on
an item you require help on.

Displays the
Playback
Macro dialog
box.



Open File Button (Toolbar)

Normal Operation

Opens an existing document
using the Open File dialog
box, in which you can locate
and open the desired file.

With Shift
Displays the
Quick File
Open dialog
box.

With Ctrl



Save File Button (Toolbar)

Normal Operation With Shift
Saves the active document Saves all
with its current name. If you modified files

have not modified or named
the document, the Save As
dialog box is displayed.

With Ctrl
Displays the
Save As
dialog box.



Print Button (Toolbar)

Normal Operation With Shift With Ctrl
Prints the active document, Displays the Displays the
using the default printer. Print dialog Configure
box. Printing

dialog box.



Copy Button (Toolbar)

Normal Operation

Copies the selection to the
clipboard.

With Shift
Appends the
selection to
existing text
on the
clipboard.

With Ctrl



Cut Button (Toolbar)

Normal Operation

Cuts the selection from the
document and save it on the
clipboard.

With Shift
Cuts the
selection and
appends it to
existing text
on the
clipboard.

With Ctrl



Paste Button (Toolbar)

Normal Operation With Shift With Ctrl
Inserts what's on the Inserts a file.
clipboard.



Undo Button (Toolbar)

Normal Operation With Shift With Ctrl
Cancels (undo) the last edit Undo all edits
command. back to the
last save

checkpoint.



Redo Button (Toolbar)

Normal Operation With Shift With Ctrl
Cancels (redo) the last Undo Redo all edits
command up to the last
save

checkpoint.



Record Button (Toolbar)

Normal Operation With Shift With Ctrl
Starts the keystroke macro
recorder.



Pause Button (Toolbar)

Normal Operation With Shift With Ctrl

E Temporarily pauses the
keystroke macro recorder.



Playback Button (Toolbar)

Normal Operation With Shift With Ctrl
E Plays back the scratch Displays the
keystroke macro. Playback

Macro dialog
box.



The Keyboard

These tables list the default command shortcuts for TextPad. If you have chosen to work in
compatibility mode with another application, you can view the shortcuts on the Keyboard tab of the

Customize dialog box.

Single Key Shortcuts:

Key Modifier
Ctrl
Ctrl
Ctrl+Shift
Ctrl
Ctrl+Shift
Ctrl
Ctrl+Shift
Ctrl
Ctrl+Shift
Ctrl
Ctrl+Shift
Ctrl
Ctrl
Ctrl+Shift
Ctrl
Ctrl+Shift
Ctrl
Ctrl
Ctrl+Shift
Ctrl
Ctrl+Shift
Ctrl
Ctrl

Ctrl+Shift
Ctrl
Ctrl+Shift
Ctrl
Ctrl
Ctrl+Shift
Ctrl
Ctrl+Shift
Ctrl
Ctrl+Shift
Ctrl
Ctrl+Shift
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Ctrl
Ctrl+Shift
Ctrl
Ctrl+Shift
Ctrl

xXss<<

Command
Select All

Move the cursor back to start of word
Select back to start of word

Copy selection to clipboard

Append selection to clipboard

Move cursor back to end of word
Select back to end of word

Center text

Right align text

Find next instance of search pattern
Find previous instance of search pattern
Go to line

Increase indentation

Reduce indentation

Join selected lines

Split word-wrapped lines

Invert case of selection

Convert selection to lower case
Insert a page break

Find matching {[ (<or>)]}

Select to matching {[ (< or>)]}
Create a new document

Open a document using the common Open File dialog
box

Open a document by typing its name

Print active document

Preview the active document as it will print.
Prefix key for two key commands (see below)
Playback the scratch macro.

Record a new macro.

Save the active document

Save all documents

Transpose the lines or characters either side of the cursor
Transpose the words either side of the cursor
Convert selection to upper case

Convert first character of selection to uppercase and the
rest to lower case

Paste text from the clipboard

Insert the contents of a file at the cursor position.
Move cursor forward to start of word

Select forward to start of word

Cut the selection to the clipboard




X Ctrl+Shift Cut and append the selection to the clipboard

Y Ctrl Redo last Undo

Y Ctrl+Shift Redo all Undos

Z Ctrl Undo last edit

Z Ctrl+Shift Undo all edits

0 Alt Activate the Clip Library

Break Ctrl Stop the tool running in the command window (only under
32-bit versions of Windows)

Backspace Delete selection, or character before the cursor, (replace
it with a space in overtype mode).

Backspace Ctrl Delete back to the last start of word.

Delete Delete selection, or character after the cursor.

Delete Ctrl Delete forward to the next start of word.

Delete Ctrl+Shift Delete to the end of the line.

Delete Alt Delete all lines in the document.

End Cursor to end of line.

End Shift Select to end of line.

End Ctrl Cursor to end of document.

End Ctrl+Shift Select to end of document.

End Alt Cursor to start of last visible line.

Enter Start a new line in an edit document, or do a hypertext
jump in a command or search results window.

Enter Ctrl Insert new line after current line

Enter Ctrl+Shift Insert new line before current line

Enter Alt Display in-context properties dialog box

Escape Cancel any existing selection

Home Cursor to start of line. Press twice to go to the left

margin. Reassign this shortcut to "LineLeft" if you
always want it to go to the left margin.

Home Shift Select to start of line. Press twice to select to the left

margin. Reassign this shortcut to "LineLeftSel" if you
always want it to select to the left margin.

Home Ctrl Cursor to start of document.

Home Ctrl+Shift Select to start of document.

Home Alt Cursor to start of first visible line.

Insert Switch between insert and overtype mode..

Scroll Lock Locks cursor position when scrolling with page up/down
keys.

Tab Indent selected lines, or move cursor to next tab stop.

Tab Ctrl Next window (same as Ctrl+F6).

Tab Ctrl+Shift Previous window (same as Ctrl+Shift+F6).

Tab Shift Reduce indentation of selected lines, or move cursor to
previous tab stop.

Left Arrow Cursor left one character.

Left Arrow Shift Select left one character.

Left Arrow Ctrl Cursor left one word

Left Arrow Ctrl+Shift Select left one word

Right Arrow Cursor right one character.

Right Arrow Shift Select right one character.

Right Arrow Ctrl Cursor right one word.



Right Arrow
Down Arrow
Down Arrow
Down Arrow
Down Arrow
Down Arrow
Up Arrow
Up Arrow
Up Arrow
Up Arrow
Up Arrow

F1

F1

F1

F2

F2

F2

F2

F3

F3

F3

F4

F4

F4
F5
F5
F6
F6
F6
F7
F7
F8
F8
F9
F9
F9
F10
F10
F10
F11
F11
F11

Two-key Shortcuts:

Ctrl+Shift

Shift

Alt

Alt +Shift
Ctrl

Shift

Alt
Alt+Shift
Ctrl

Ctrl
Shift

Ctrl
Shift
Ctrl+Shift

Ctrl
Alt

Shift

Ctrl

Ctrl

Ctrl
Ctrl+Shift

Ctrl

Ctrl

Ctrl
Shift

Shift
Ctrl

Ctrl
Shift

Select right one word.

Cursor down one line.

Select down one line.

Cursor down to the start of the next paragraph.
Select to to the start of the next paragraph.
Scroll the view up one line, without moving the cursor.
Cursor up one line.

Select up one line.

Cursor up to the start of the previous paragraph.
Select to to the start of the previous paragraph.
Scroll the view down one line, without moving the cursor.
In-context help

Display document statistics on status bar
Invoke in-context help cursor

Go to next bookmark

Set or clear a bookmark on the current line

Go to previous bookmark

Clear all bookmarks

Invoke the Manage Files dialog box

Show or hide the Clip Library

Invoke Windows File Manager or Explorer

Hypertext jump to next item in Search or Command
Output window

Hypertext jump to previous item in Search or Command
Output window

Close the active window.

Invoke the Find dialog box

Invoke Find in Files dialog box

Activate next view

Activate next window

Activate previous window

Check the spelling of the active document.
Invoke the Playback Macro dialog box.
Invoke Replace dialog

Replace next instance of search pattern
Sort

Compare

Word count

Activate the main menu

Popup the in-context document menu
Popup the insert date/time menu
Invoke the Document Selector

Activate the Command Results window
Activate the Search Results window



Keys

Ctrl+Q, B
Ctri+Q, C
Ctrl+Q, E
Ctri+Q, F
Ctrl+Q, H
Ctrl+Q, L
Ctrl+Q, P
Ctri+Q, R
Ctri+Q, S
Ctrl+Q, Y
Ctri+Q, V
Ctri+Q, W

See Also:

Typing International Characters
Typing Control Characters

Command
Switch in and out of block select mode

Display the Customize dialog box

Switch between read-only and edit modes
Display the Font Selection dialog box
Display/hide the horizontal scroll bar
Display/hide line numbers

Display the Preferences dialog box

Set the right margin at the cursor position

Switch in and out of selection mode

Switch in and out of synchronized scrolling mode
Display/hide visible spaces, tabs and paragraphs.
Switch in and out of word-wrap mode



The Mouse
Cursor Positioning:

To set the insertion position with the mouse, click the left mouse button when the mouse cursor is at the

required character position.

line.

Text Selection:

To do this:
Select any text

Select a single word
Select an entire line

Select an entire
paragraph

Select the entire

In TextPad Mode:

Click on the first character and
drag to the last.

Double click on the word.
Double click in the left margin
next to the line, or non-word-
wrap only: triple click
anywhere in the line.
Word-wrap: Triple click
anywhere in the paragraph.
Non word-wrap: Triple click in
the left margin.

Press Ctrl and click in the left

document margin.
Extend the current Press Shift and click or drag to
selection the new last character
position.
In-context Menus:
Right click a document to pop up the in-context menu.

You can set it to the start of a line by clicking in the left margin next to the

In MS Compatibility Mode:
Click on the first character and
drag to the last.

Double click on the word.

Single click in the left margin
next to the line, or non-word-
wrap only: triple click
anywhere in the line.
Word-wrap: Triple click
anywhere in the paragraph.
Non word-wrap: Double click
in the left margin.

Press Ctrl and click in the left
margin.

Press Shift and click or drag to

the new last character
position.

Ctrl+Right click an edit document to pop up the insert date/time menu.



The cursor is the blinking vertical line or block, which indicates the insertion position for text. Contrast
this with the cursor, which tracks the mouse position.



The mouse cursor is a pointer on the screen which tracks the mouse position. Contrast this with the
cursor, which is the blinking vertical line or block cursor indicating the insertion position for text.






Introducing TextPad

Winner - 1995 and 1997 Ziff-Davis Shareware Awards.
Winner - 1996 Shareware Industry Awards.

When just getting the job done is work enough, the last thing you need is to waste time having to learn
yet another computer application. Your experience with other tools should be relevant to each new
application, making it possible to sit down and use that new application right away.

That's why TextPad is so popular. Whether you simply need a powerful replacement for Notepad, a tool
for editing your web pages, or a programming IDE, TextPad does what you want, the way you would
expect.

TextPad is designed to provide the power and functionality to satisfy the most demanding text editing
requirements. It is Windows™ hosted, and comes in 16 and 32-bit editions. Huge files can be edited
by either - just choose the edition that works best with your PC. The 32-bit edition can edit files up to
the limits of virtual memory, and it will work with Windows 95, Windows NT and Windows 3.1 with
Win32s extensions.

TextPad has been implemented according to the Windows 95 user interface guidelines, so great
attention has been paid to making it easy for both beginners and experienced users. Command
shortcuts can be modified to taste, with emulations provided for WordStar, BRIEF, and Microsoft
applications. In-context help is available for all commands, and in-context menus pop-up with the right
mouse button. The Windows multiple document interface allows many files to be edited simultaneously,
with up to 2 views on each file. Text can be dragged and dropped between files.

In addition to the usual cut and paste capabilities, you can correct the most common typing errors with
commands to change case, and transpose words, characters and lines. Other commands let you
indent blocks of text, reformat paragraphs, and insert whole files. Any change can be undone or
redone, right back to the first one made. Visible bookmarks can be put on lines, and edit commands
can be applied to lines with bookmarks.

Frequently used combinations of commands can be saved as keystroke macros, and the spelling
checker has dictionaries for 10 languages.

It also has a customizable tools menu, and integral file compare and search commands, with hypertext
jumps from the matched text to the corresponding line in the source file (ideal for integrating compilers).

Sumary of Features
Year 2000 Compliance




Summary of Features

Huge files can be edited (up to the limits of virtual memory for the 32-bit edition). See
Specifications for the actual limits.

Supports Universal Naming Convention (UNC) style names, and long file names with spaces.
CUA compliant keyboard commands, which can be fully customized.

Multiple personalities: compatibility with Microsoft applications, WordStar, BRIEF and TextPad 2.
The user interface is available in French, German, Italian, Polish, Portuguese and Spanish.
Multiple files can be simultaneously edited, with up to 2 views per file.

Warm Start feature lets you restart exactly where you left off.

In addition to the usual cut, copy and paste capabilities, selected text can be centered, case

shifted and block indented, and characters, words and lines can be transposed. Cut and copied text can
be appended to the clipboard, as well as replacing its contents.

Text can be automatically word-wrapped at the margin, or at a specified column, if it does not fit
on aline. In this mode, text can be split into separate lines where wrapping occurs, or lines can be
intelligently joined, preserving paragraphs.

OLEZ2 drag and drop editing for copying and moving text between documents.

Unlimited undo/redo capability. The undo buffer can be optionally cleared when a file is saved,
or by using the Mark Clean command.

Block (column) selection mode, and visible display of tabs and spaces.

A spelling checker with dictionaries in 10 languages.

A keystroke macro recorder, with up to 64 active macros.

A Clip Library for organizing frequently used text, such as program templates, or HTML tags.
Sorting, using up to 3 keys.

Text can be automatically aligned and indented, relative to the previous line, to aid block
indentation.

The right mouse button pops up an in-context menu.

The cursor can be constrained to the text, or can be positioned freely in the document view.
Toolbar with fly-by usage hints, and an active status bar.

A powerful search/replace engine using POSIX-style regular expressions. Sets of files in a
directory tree can be searched, and text can be replaced in all open documents at once.

Visible bookmarks can be placed on individual lines, and on all occurrences of a search pattern.
okmarked lines can be cut, copied or deleted.

A built in file manager for fast file copying, renaming, deleting etc.

Print previewing, and printing with customizable headers/footers and page breaks.
Viewer for binary files using a hexadecimal display format.

Command to view HTML documents in a web browser.

Built in file comparison utility, and up to 32 user-defined tools with parameter macros.
Hypertext links from file search and user tool output to the relevant source line.

DDE interface to other tools, such as VC++. The editor detects when an open file has been
modified by another tool, and prompts you to reopen it.
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TextPad® is a registered trademark of Helios Software Solutions
Copyright © 1992-1998 Helios Software Solutions
All Rights Reserved.



Specifications
Conforms to MS Windows User Interface Design Guide 4 recommendations.

The editor can handle files with up to 32,500 lines in the 16-bit edition, and up to the limits of
virtual memory in the 32-bit edition, except that in word-wrapped mode it is also limited to 32,500 lines.

The maximum line length is 4095 characters.

The number of concurrent edits is limited by available memory. In the 16-bit edition, the 64KB
local heap restricts this to a maximum of 28.

Supports Universal Naming Convention (UNC) style, and long file names with spaces.
8-bit text files with DOS, UNIX and Macintosh end of line characters are supported.

Text can be in either the ANSI (Windows) or OEM (DOS) character sets.

Each document has a single MDI window with up to 2 views.

Fonts and tab stops are user selectable (fixed width font for editing).

Up to 16 (user settable) most recently used files are listed on the File menu.

Up to 32 (16 in 16-bit edition) user-defined commands can be added to the Tools menu.
Up to 64 (16 in 16-bit edition) keystroke macros can be added to the Macros menu. This is

restricted to 2 macros in unregistered copies.
Limitations:

The 16-bit edition cannot cut or paste more than 64KB at a time.
Non-OLE drag and drop does not support scrolling.

The 16-bit edition, and the 32-bit edition under Win32s, can only display the output of a user tool
command in a window after the command has completed.

The 32-bit edition cannot mail files under 16-bit Windows.



Purchasing and License Agreements
Registration Benefits
How to Order
Price List

Unregistered User License Agreement
Registered User License Agreement
Distributor License Agreement

Definition of Shareware
Association of Shareware Professionals

Contacting Helios Software Solutions



Helios Software Solutions
Mail Address:

Helios Software Solutions
PO Box 619
LONGRIDGE

PR3 2GW

England

Tel: +44 (1772) 786373
Fax: +44 (1772) 786375

E-Mail Addresses:

Sales: sales@textpad.com

Support: support@textpad.com
WWW URL:

http://www.textpad.com/



Registration Benefits

This product makes use of the most advanced software technology available today. As the technology
improves, so does our software. Your registration fee enables us to keep it at the forefront of
technology, so that you continue to benefit from the productivity gains it gives you.

As a registered user, you will receive:
A copy of the latest release of both 16 and 32-bit editions on 3.5" diskette, unless you opt for the
download only price, which includes a license for both editions.

Alicense file entitling you to use all future *maintenance releases (which will be made available
for downloading from our Internet web site, CompuServe, AOL and MSN). This license file will be e-
mailed to you, if you quote your e-mail address with your order.

The display of your name, company and registration number on the About dialog box.
Technical support by e-mail, FAX, or through the mail, at no charge, for at least 101 days.

* We reserve the right to introduce an upgrade charge for major new releases.



How to Order
Registration Instructions:

The registration fee can be paid in UK pounds, or US dollars using a check or credit card. CompuServe
members can also use their shareware registration service to pay in US dollars.

Value added tax (VAT) is payable by European Community member countries, so payment is required in
UK pounds. VAT need not be paid, except in the UK, if you quote your VAT registration number with the
order..

We always send an invoice if you specify a company name. Private users can request one by stating
"invoice required" in the place of the company name.

If you have already downloaded the latest release, there is no point in paying extra to have the software
on diskettes. Just order it at the no disk price, but make sure you clearly state the e-mail address you
want your license to be sent to.

Online Ordering

Paying Direct in UK Pounds

Paying Direct in US Dollars by Check

Paying through PsL in US Dollars by Credit Card

CompuServe Registration
Purchase Orders




Online Ordering
If you have Internet access, you can place your order online, using a secure order form, if your browser
supports them.

For more information, follow the link to online ordering from the home page on our web site. You may
reach it by clicking the following link, if you are running Windows 95, NT 4 or later:

http://www.textpad.com/



Paying in UK Pounds
We accept payment by cheque, or with the following credit cards:
Visa - MasterCard - American Express - Delta - EuroCard - JCB

Cheques must be in UK pound denominated drafts drawn on a UK bank, or by EuroCheque, or by
Pound Sterling International Money Order. Sorry, but banking fees for payments in other denominations
are prohibitively expensive. (Please note that EuroCheques are not valid for payment in US dollars.)

See the Price List for current pricing, and return the completed Order Form.



Paying in US Dollars by Check

For non-European users, we accept direct payment with a check made out in US dollars. European
users must pay in UK Pounds, to keep our VAT records in order.

See the Price List for current pricing, and return the completed Order Form.



Paying in US Dollars by Credit Card

MasterCard, Visa, American Express, and Discover orders can be placed through PsL, a credit card
order taking service. You can reach PsL 24 hours a day 7 days a week by fax at 1-713-524-6398 or by
e-mail to 11709@pslweb.com. You can also call PsL at 1-800-242-4PsL(4775) or 1-713-524-6394
between the hours of 7:00 am and 6:00 pm CST Monday-Thursday and 7:00 am and 12:30 pm CST on
Fridays, except holidays. You can also mail orders to PsL at P.O. Box 35705, Houston, TX 77235,
USA.

THESE NUMBERS ARE FOR ORDERING ONLY. Any other queries, including the status of the
shipment of the order, must be addressed to Helios Software Solutions. PsL will charge us $2.50 for
any queries you make, then pass them on for us to answer anyway, so please ask us directly!

PsL requires the following information:
Product Name: TextPad

Users:1__ 5 10_ 20 50  Unlimited
Diskettes required: Yes_ No___

E-mail Address:

Credit Card[ ]MasterCard[ ]VISA[ JAMEX][ ]Discover
Credit Card Number:
Expiry Date:

Name On Card:
Company:

Billing Address:

You must specify an e-mail address, unless you order diskettes.

We will automatically send an invoice if you specify your company name. Private users who want one
should state "Invoice Required" in place of the company name.

PsL will notify us within one working day of you placing your order, and we will e-mail a license file to you
if you specify your e-mail address. If you opt for having the software sent on diskettes, we will mail
them directly to you.

Note: e-mail addresses can be quite complicated, and occasionally get written down incorrectly by the
telephone operators. If you have not received your license file within a couple of days, please send an
e-mail message to: orders@textpad.com



CompuServe Shareware Registration Service

Note: This option for payment is only available for single user licenses. Payment for site licenses
must be made directly to us in UK Pounds or by a check in US Dollars.

If you have a CompuServe account you can have the registration fee charged to your account. Simply
GO SWREG and follow the online instructions.

The registration ID numbers are:

ID Number Includes Disks Price
3938 No $27
794 Yes $35

We will automatically send an invoice if you specify your company name. Private users who want one
should state "Invoice Required" in place of the company name.

VAT at 17.5% will be added to these prices for European residents.

CompuServe will notify us on the day of your order and we will e-mail a license file to you. If you opt for
having the software sent on diskettes, we will mail them directly to you.



Purchase Orders

Purchase orders (net 30 days) are accepted only from government and accredited educational
institutions and major corporations, provided that they are submitted on purchase order forms with a
purchase order number. Please be sure to include the European or World wide order form with a
purchase order.

See the Price List for current pricing.



Price List
Valid for 4 months from 26th June, 1998 (please check our web site for current pricing)

Single User Prices:

Currency Without Diskettes With Diskettes
US Dollars $27.00 $35.00
UK Pounds (ex. VAT) £17.00 £20.00
UK Pounds (inc. VAT*) £19.97 £23.50

Site License Prices:
Users US Dollars UK Pounds (ex. VAT) UK Pounds (inc. VAT*)

5 $120.00 £80.00 £94.00
10 $210.00 £140.00 £164.50
15 $300.00 £200.00 £235.00
20 $360.00 £240.00 £282.00
50 $750.00 £500.00 £587.50
Unlimited $1000.00 £680.00 £799.00
Notes:
If you have already downloaded the latest release, there is no point in paying extra to have the
software on diskettes. Order it without diskettes.
When purchasing without diskettes, you must download the software yourself, and must provide

an e-mail address for us to send your license file to.

* VAT at 17.5% is payable by UK residents, and European residents who are not VAT registered.
You must pay in UK Pounds if VAT is applicable.

TextPad can be purchased in US Dollars or UK pounds only. The prices are as shown in the
tables above, and are not subject to exchange rate fluctuations. They are inclusive of shipping and
handling.

A site license is for a single physical site.

Site licenses always include one set of diskettes.

Additional educational discounts for site licenses are available on request.



VAT - Value Added Tax
Value Added Tax (VAT) is known by the following names, in other member countries of the
European Community:

Austria: Mehrwertsteuer (Mwst)

Belgium: Taxe sur la Valeur Ajoutée (TVA)

Denmark: Mervaerdiafgift (Moms)

Finland: Arvonlisavero (ALV)

France: Taxe sur la Valeur Ajoutée (TVA)

Germany: Mehrwertsteuer (Mwst)

Greece: JIIA (FPA)

Italy: Imposta sul Valore Aggiunto (IVA)

Luxembourg: Taxe sur la Valeur Ajoutée (TVA)

Netherlands: Belasting over de Toegevoegde Waarde (BTW)

Portugal: Imposto sobre el Valor Acrescentado (IVA)

Spain: Impuesto sobre el Valor Anadido (IVA)

Sweden: Mervardesskatt (Moms)

VAT at 17.5% must be paid by:

All UK residents.
Residents of all other European Community countries who are not registered for VAT.



TextPad Order Form for Payment in UK Pounds

Please register me as a licensed TextPad user, and send me a copy of the latest release.

Name:

Company:

Address:

Phone:

Fax:

E-mail:

Payment Due (see price list):
Users: 1 5 10 20 50 Unlimited
Diskettes required: Yes  No

Registration Price: £

Price x _ copies = £
VAT at 17.5% (**Europe only): £
Total paid: £

(**No VAT to pay if non-UK European, and VAT number is filled in below.)
VAT Registration No.

By: MasterCard _ VISA _ AMEX _ DELTA _ EUROCARD _ JCB _ Cheque

Cheque/Draft No. (To "Helios Software Solutions")
Credit Card Details:
Number:
Expiry:
Signed:
Date:

How did you hear about TextPad?

Any Comments:

When you have filled in the above details, mail this to:

Helios Software Solutions
PO Box 619
LONGRIDGE

PR3 2GW

England

(FAX: +44 (1772) 786375)

Thank you for your interest in this product.



TextPad Order Form for Payment by Check in US Dollars
Please register me as a licensed TextPad user, and send me a copy of the latest release.

Name:

Company:

Address:

Phone:

Fax:

E-mail:

Payment Due (see price list):
Users: 1 5 10 20 50 Unlimited
Diskettes required: Yes  No

Registration Price: $
Price x copies = £
Total paid: $

Check/Draft No.

Signed:

Date:

Do you require an invoice to be sent?

How did you hear about TextPad?

Any Comments:

Make checks payable to "Helios Software Solutions".
When you have filled in the above details, mail this with your check to:
Helios Software Solutions
PO Box 619
LONGRIDGE
PR3 2GW
England

Thank you for your interest in this product.



Registered User License Agreement

This is a legal agreement between you (either an individual or an entity) and Helios Software Solutions.
By opening the sealed software packages and/or by using the SOFTWARE, you agree to be bound by
the terms of this Agreement. If you do not agree to the terms of this Agreement, promptly return the
disk package and accompanying items for a full refund.

SOFTWARE LICENSE

1. GRANT OF LICENSE. This License Agreement (“License”) permits you to use one copy of the software product identified
above, which may include user documentation provided in “on-line” or electronic form (“SOFTWARE”). The SOFTWARE is
licensed as a single product. Its component parts may not be separated for use on more than one computer or by more than
one user at any time. The SOFTWARE is “in use” on a computer when it is loaded into the temporary memory (i.e. RAM) or
installed into the permanent memory (e.g. hard disk) of that computer. If the SOFTWARE is permanently installed on the hard
disk or other storage device of a computer and one person uses that computer more than 80% of the time, then that person may
also use the SOFTWARE on a portable or home computer.

2. COPYRIGHT. The SOFTWARE is owned by Helios Software Solutions and is protected by United Kingdom copyright laws and
international treaty provisions. Therefore you must treat the SOFTWARE like any other copyrighted material (e.g. a book or
musical recording) except that you may either (a) make one copy of the SOFTWARE solely for backup or archival purposes, or
(b) transfer the SOFTWARE to a single hard disk provided you keep the original solely for backup or archival purposes. You
may not copy the printed materials accompanying the SOFTWARE, nor print copies of any user documentation provided in “on-
line” or electronic form. You must not redistribute the file TEXTPAD.LIC, which licenses your copy of the software.

3. OTHER RESTRICTIONS. This License is your proof of license to exercise the rights granted herein and must be retained by
you. You may not rent or lease the SOFTWARE, but you may transfer your rights under this License on a permanent basis,
provided you transfer this License, the SOFTWARE and all accompanying printed materials, retain no copies, and the recipient
agrees to the terms of this License. You may not reverse engineer, decompile, or disassemble the SOFTWARE, except to the
extent applicable law expressly prohibits the foregoing restriction.

LIMITED WARRANTY

LIMITED WARRANTY. Helios Software Solutions warrants that the SOFTWARE will perform substantially in accordance with the
accompanying printed material and on-line documentation for a period of 101 days from the date of receipt.

CUSTOMER REMEDIES. Helios Software Solutions’ entire liability and your exclusive remedy shall be, at Helios Software
Solutions’ option, either (a) return of the price paid or (b) repair or replacement of the SOFTWARE that does not meet this Limited
Warranty and that is returned to Helios Software Solutions with a copy of your receipt. This Limited Warranty is void if failure of
the SOFTWARE has resulted from accident, abuse, or misapplication. Any replacement SOFTWARE will be warranted for the
remainder of the original warranty period or thirty (30) days, whichever is longer.

NO OTHER WARRANTIES. To the maximum extent permitted by applicable law, Helios Software Solutions disclaims all other
warranties, either express or implied, including but not limited to implied warranties of merchantability and fitness for a particular
purpose, with respect to the SOFTWARE and any accompanying written materials.

NO LIABILITY FOR CONSEQUENTIAL DAMAGES. To the maximum extent permitted by applicable law, in no event shall Helios
Software Solutions be liable for any damages whatsoever (including, without limitation, damages for loss of business profits,
business interruption, loss of business information, or other pecuniary loss) arising out of the use or inability to use the
SOFTWARE, even if Helios Software Solutions has been advised of the possibility of such damages.




Unregistered User License Agreement
LIMITED WARRANTY AND REMEDIES

THE PROGRAM IS PROVIDED "AS I1S" WITHOUT WARRANTY OF ANY KIND, EITHER EXPRESS
OR IMPLIED, INCLUDING, BUT NOT LIMITED TO WARRANTIES OF MERCHANTABILITY OR
FITNESS FOR A PARTICULAR PURPOSE. IN NO EVENT WILL THE AUTHOR BE LIABLE TO
YOU FOR ANY DAMAGES, INCLUDING INCIDENTAL OR CONSEQUENTIAL DAMAGES,
ARISING OUT OF THE USE OF THE PROGRAM, EVEN IF ADVISED OF THE POSSIBILITY OF
SUCH DAMAGES.

YOU ACKNOWLEDGE THAT YOU HAVE READ THIS LICENSE, UNDERSTAND IT AND AGREE
TO BE BOUND BY ITS TERMS AS THE COMPLETE AND EXCLUSIVE STATEMENT OF THE
AGREEMENT BETWEEN US, SUPERSEDING ANY PROPOSAL OR PRIOR AGREEMENT, ORAL
OR WRITTEN, AND ANY OTHER COMMUNICATIONS BETWEEN US RELATING TO THE
SUBJECT MATTER OF THIS LICENSE.

TextPad is a shareware program and is provided at no charge to the user for evaluation. Feel free to
share unlicensed copies with your friends, but please do not give it away altered or as part of another
system. The essence of shareware software is to provide personal computer users with quality
software without high prices, and yet to provide incentive for programmers to continue to develop new
products.

If you find this program useful and find that you continue to use it after a reasonable trial period, you
must make a registration payment (see the registration instructions for details). This registration fee will
license one copy for use on any one computer at any one time. All users will receive a copy of the
latest release when they register, and free technical support for a limited period.

Commercial users must register and pay for their copies within 30 days of first use or their license is
withdrawn. Site License arrangements may be made by contacting Helios Software Solutions.

Anyone distributing this product for any kind of remuneration must first contact Helios Software Solutions
for authorization.

You must treat this software just like a book. For example, this software may be used by any number of
people and may be freely moved from one computer location to another, as long as there is no
possibility of it being used at more than one location ata time. Just as a book cannot be read by two
people at the same time.

You are encouraged to pass a copy of this software along to your friends for evaluation, but you must
include all files in the original distribution. Please encourage them to register their copy if they find that
they make use of it.




Distributor License Agreement

Anyone wishing to charge people a fee for giving them a copy of this software must have the written
authorization of the author, without which, the distributor is guilty of copyright violation. To receive such
authorization, send this completed application, along with a copy of your software library's order form to
Helios Software Solutions. Include £5.00 to cover the cost of processing the application and of sending
you the latest version of the software. For distributors already recognized by the Association of
Shareware Professionals, this application is not necessary.

Name of Organization:

Your Name:
Address:

Terms of Distribution of TextPad:
1. The fee charged may not exceed $10, including postage, mailer and any other charges.

2. Your library's catalog or listing must state that this program is not free, but is copyrighted software
that is provided to allow the user to evaluate it before paying.

3. The offering and sale of the software will be stopped at any time the author so requests.

4. Copies must be made from the copy of the software sent to you with this agreement. This is required
for control purposes.

5. Problems or complaints about the program will be reported to the author for investigation. In return
for a license to charge a fee for the distribution of TextPad, | agree to comply with the above terms of
distribution.

Signed,

your signature date

Keith MacDonald control # date



Definition of Shareware

Shareware distribution gives users a chance to try software before buying it. If you try a shareware
program and continue using it, you are expected to register. Individual programs differ on details --
some request registration while others require it, some specify a maximum trial period. With
registration, you get anything from the simple right to continue using the software to an updated program
with printed manual.

Copyright laws apply to both shareware and commercial software, and the copyright holder retains all
rights, with a few specific exceptions as stated below. Shareware authors are accomplished
programmers, just like commercial authors, and the programs are of comparable quality. (In both
cases, there are good programs and bad ones!) The main difference is in the method of distribution.
The author specifically grants the right to copy and distribute the software, either to all and sundry or to a
specific group. For example, some authors require written permission before a commercial disk vendor
may copy their shareware.

Shareware is a distribution method, not a type of software. You should find software that suits your
needs and pocketbook, whether it's commercial or shareware. The shareware system makes fitting
your needs easier, because you can try before you buy. And because the overhead is low, prices are
low also. Shareware has the ultimate money-back guarantee -- if you don't use the product, you don't
pay for it.



Association of Shareware Professionals

— ™
Association of
Shareware
Professionals

Helios Software Solutions is an approved vendor and associate member of the Association of
Shareware Professionals (ASP).

The primary goals of the ASP include:

o To inform users about shareware programs and about shareware as a method of distributing and
marketing software.

o To foster a high degree of professionalism among shareware authors by setting programming,
marketing, and support standards for ASP members to follow.

o To encourage broader distribution of shareware through user groups and disk dealers who agree
to identify and explain the nature of shareware.

o To assist members in marketing their software.

o To provide a forum through which ASP members may communicate, share ideas, and learn from
each other.

The Association of Shareware Professionals have drafted a code of ethics for all present and future
members. This code of ethics includes the following requirements:

o A member's program (evaluation version) must not be limited (crippled) in any way. In the true
spirit of Try-Before-You-Buy, users must be able to evaluate all the features in a program before
paying the registration fee.

o Members must respond to every registration. At the very least they must send a receipt for the
payment.

o Members must provide technical support for their products for at least 90 days from the date of
registration.

The ASP has put in place a system to help ensure that users are treated fairly and professionally. If a
user is unable to resolve a problem with a member author then the user can contact the ASP
Ombudsman with their complaint. The Ombudsman will then try to help resolve the dispute.

ASP Ombudsman Statement:

Helios Software Solutions is a member of the Association of Shareware Professionals (ASP). ASP
wants to make sure that the shareware principle works for you. If you are unable to resolve a
shareware-related problem with an ASP member by contacting the member directly, ASP may be able to
help. The ASP Ombudsman can help you resolve a dispute or problem with an ASP member, but does
not provide technical support for members' products.

Please write to the ASP Ombudsman at:

ASP Ombudsman
157-F Love Avenue
Greenwood, IN 46142
U.S.A.
E-mail: omb@asp-shareware.org

Fax: +1-317-888-2195



How to Use Keystroke Macros: Overview

Keystroke macros are useful whenever you have the same sequence of editing commands to repeat, or
a block of text to insert. You can record one unnamed (scratch) macro, and up to 64 named ones (16 in
the 16-bit edition), which are added to the Macro menu.

Each macro has a default play mode (once only, repeat through selected text, or repeat to the end of the
document), which can be overridden when you play it back.

Recordable Commands:

Normal typing.
Selection and cursor positioning using keystrokes.
All commands on the Edit menu, except for Undo and Redo.
All commands on the Search menu, except for Find in Files.
The Convert to DOS/ANSI command on the Tools menu.
All commands on the File and Windows menus.
Next Window and Previous Window commands.
Previously recorded, named macros.
Mouse double and triple clicks. Not mouse motion or drag and drop.
Points to Bear in Mind:
You should normally position the cursor before starting the recorder, since the macro will play
back from the current position. The Find/replace commands are exceptions to this rule.

All of the parameters that you set on the Find or Replace dialog box are recorded.

If you record a Find Next or Previous command, the current search string will be used. i.e. the
search string will not be recorded, so when you play it back, it will try and find a pattern matching the last
search string used.

Playback is terminated when the Find command fails to find matching text.

The file name for the Insert File command is recorded.

You can pause the recorder, if you don't want to record some commands in the middle of a
recording.

If you want to be able to play back a macro to the end of the document, it is important that you

record at least one command to move the cursor down a line.
You can cancel a macro, while it is being played back by, releasing the playback button on the
toolbar, or with the Stop Playing command on the Macro menu.
After a macro has finished playing, the Undo command will cancel any changes it made.
The unnamed (scratch) macro is only saved if the option to save the workspace is enabled on the
General tab of the Preferences dialog box.
See also: Recording, Playing, Saving, Example.




How to Record Keystroke Macros
To record a keystroke macro:

1.
2.
3.

4.
5.

6.

If the cursor position is significant, move it to where you want first.

Start the macro recorder with the Record command on the Macro menu.

If you have previously recorded a macro, and not yet saved it, you will be asked if you want to erase
it.

Type as usual, or invoke any of the recordable commands.

When you have finished, select the Stop Recording command on the Macros menu, or click the
record button again on the toolbar.

The first time, you will be prompted to save the macro. You can choose to just use it as an unsaved
(scratch) macro, or to save it with a name, and whether you want to be prompted in future.

Notes:

Macros that are supplied with TextPad are stored in the Samples folder. Any that you create are

stored in the folder specified on the Folders tab of the Preferences dialog box.

If you create any interesting macros that you would like to contribute to our collection, please let

us know. We will make them available from our web site, with full credit given to each author.
Shortcuts:

Toolbar:
Keys: Ctrl+Shift+R
See also: Overview, Playing, Saving, Example.



How to Save a Keystroke Macro
To save the unnamed (scratch) keystroke macro:

1

3.

4.

5.

6.

. Choose the Save command from the Macros menu. The Save Macro dialog box will be displayed.
2.

Choose a file name. The default will be MACROxx.TPM, where xx is a number. The file will be
stored in the folder configured on the Folders tab of the Customize dialog box.

In the Display Name box, type text that you want to appear on the Macros menu. If you insert an '&'
before any character, it will be underlined on the menu, and can be used as the menu accelerator.
Optionally fill in the Author and Comment fields. These can be modified later by clicking the
Properties button on the Macros tab of the Customize dialog box.

Choose the default play mode. This can later be overridden when playing the macro, or modified as
for the Author and Comment fields.

Click OK.

See also: Overview, Recording, Playing, Example.



How to Playback a Keystroke Macro
To play back the unnamed (scratch) keystroke macro:
Choose the Playback command from the Macros menu.
Shortcuts:
Toolbar:
Keys: Ctrl+R
To play back a named macro:
Select it by name from the Macros menu.

4

To play back a macro differently from its default mode:
1. Choose the Multi-play command from the Macros menu. The Playback Macro dialog box will be
displayed.
Shortcut:
Toolbar:  Shift+—*J
2. Select a named macro, or the scratch macro to play.
3. Choose to play it a specified number of times, or through the current selection, or to the end of file.
4. Click OK.

See also: Overview, Recording, Saving, Example.



Macro Examples
Selecting HTML Tags:

HTML tags are in matched pairs of <...>'s, which may extend over several lines. You can create a
macro to select a whole tag as follows:

6.
7.

1. Open the Find dialog box;

2. Type "<" (without the quotes) in the Find What box;
3.
4
5

Start the recorder, using Ctrl+Shift+R, or the toolbar button;

. Click the Find Next button;
. Select up to the matching ">", using the Match Bracket command on the Search menu

(Ctrl+Shift+M);
Stop the recorder, using Ctrl+Shift+R, or the toolbar button;
Save the macro with a suitable name.

If you want to delete the tag, hit the Delete key before stopping the recorder. Then you can play it to
the end of the file to strip all tags.

Tagging Selected Text with HTML <B> ... </B> Tags:

1.
. Open the Replace dialog box;
. Type "&" (without the quotes) in the Find What box;

©~NoOOA®WN

Select some text on a single line;

Type "<B>&</B>" in the Replace With box;

. Check the Regular Expression box;

Start the recorder, using Ctrl+Shift+R, or the toolbar button;

. Click the Find Next button;

. Click the Replace button;
9.

10.

Stop the recorder, using Ctrl+Shift+R, or the toolbar button;
Save the macro with a suitable name.

To use this macro, select the text that you want displayed in a bold font, then playback the macro.



How to Customize the Macros Menu

Macros are initially added to the menu when you save them. However, you can add any macros that
are in your Macros Folder as follows:

1. From the Configure menu, choose Customize;

2. Select the Macros tab on the Customize dialog box;

3. Select any of the macros in the list of Available Macros.

4. Click the Add button to copy them to the list of Macros on Menu.
This is useful if you want to use macros that were created on another PC.

Notes:

The Remove button can be used to remove any selected macros from the menu that you no
longer need. They will remain in your Macros folder, so click the Delete button instead, if you want to
delete the file containing the macro as well.

The order of the macros on the menu can be altered by selecting them and clicking the Move Up
or Move Down buttons.

Shortcuts can be assigned to macros using the Keyboard tab on the Customize dialog box.



How to Change Macro Properties

You can change the properties of a macro by choosing Customize from the Configure menu, and
selecting the Macros tab. If you select a macro, and click the Properties button, you can view or modify

the following properties:

Property:
File Name
Display Name

Author

Description

Default Play
Mode

Description:
The name of the disk file containing this macro.

A name of up to 40 characters that will appear on
the Macros menu. You can insert an '&' to
indicate the character to use as the menu
accelerator.

This is automatically set to the name of the
registered user. It can be up to 40 characters
long.

Up to 128 characters to remind you what the
macro does.

Choose from "Play Once", "Repeat through
Selection", and "Repeat to End of File".



How to Customize Macro Preferences

You can customize these macro settings by choosing Customize from the Configure menu, and
selecting the Macros tab:

Macros Available: lists the macros available in the specified folder, which have not already been

selected. Macros are searched for first in the folder specified on the Folders tab of the Preferences
dialog box, then in the Samples folder.

Macros on menu: lists the macros which have been selected.

Click this button: To do this:

Add Add the selected macro from the Available list
to the menu.

Remove Removes the selected macro from the menu,
and puts it on the Available list.

Delete Permanently deletes the macro file.

Move Up Moves the selected macro up the menu list.

Move Down Moves the selected macro down the menu list.

Properties View or change the macro properties.



New command (File menu)
Use this command to create a new, unnamed document.
You can open a new document, and give it a name at the same time, with the Open command.
Shortcuts:
Toolbar:
Keys: Ctrl+N
More information



Open command (File menu)
Use this command to open an existing document.
Select the file (or multiple files) from the Open File dialog box which appears.
Shortcuts:
Toolbar:
Keys: Ctrl+O
More information



Close command (File menu)
Use this command to close all views containing the active document.

You get prompted to save changes to your document before you close it. If you close a document
without saving, you lose all changes made since the last time you saved it. Before closing an untitled
document, the Save As dialog box appears to suggest that you name and save the document.

Shortcuts:
Keys: Ctrl+F4

More information



Close All command (File menu)

Use this command to close all your documents. If any document has been modified, you will be
prompted to save it before its window is closed.



Revert command (File menu)

Use this command to revert to the last saved state of the active document. You will be asked if it is OK
to lose any changes, before the file is reloaded.



Save command (File menu)
Use this command to save an open document.
When you save an unnamed document for the first time, the Save As dialog box appears, so that you
can give it a name.
Shortcuts:
Toolbar:
Keys: Ctrl+S
More information



Save As command (File menu)
Use this command to save the active document with another name.
The Save As dialog box appears, so that you can supply the new name.

More information



Save All command (File menu)
Use this command to save all modified documents.
When you save an unnamed document for the first time, the Save As dialog box appears, so that you
can give it a name.

Shortcuts:
Keys: CtrlI+Shift+S



Manage Files command (File menu)
Use this command to open copy, rename, delete or update the timestamps of files.
Shortcuts:
Toolbar:
Keys: F5
More information



Properties command (File menu)

Use this command to display statistics about the active document's file. The same information can be
obtained by choosing Properties from the Configure menu, and selecting the Statistics tab on the
Properties dialog box.



Print command (File menu)
Use this command to print the active document.
This command presents a_Print dialog box, where you may specify the range of pages to be printed, the
number of copies, the destination printer, and other printer setup options.
Shortcuts:
Toolbar:
Keys: Ctrl+P
More information




Print Preview command (File menu)
Use this command to display the active document as it would appear when printed.
When you choose this command, the main window will be replaced with a print preview window in which
one or two pages will be displayed in their printed format. The print preview toolbar offers you options
to view either one or two pages at a time; move back and forth through the document; zoom in and out
of pages; and initiate a print job.
Shortcuts:

Toolbar:
Keys: Ctrl+Shift+P



Print Setup command (File menu)
Use this command to select the printer and setup the appearance of the printed page.
You can set margins and headers and footers on the Printer Preferences dialog box which appears.



Send command (File menu)

Use this command to send the active document to another person via electronic mail. You must have a
MAPI compatible e-mail system installed to enable this command.



File Statistics command (File menu)
Use this command to display the size and number of lines in the active document, on the status bar.

Shortcuts:
Keys: Ctrl+F1



1,2, 3,4 .. command (File menu)

Use the numbers and filenames listed at the bottom of the File menu to open the last several documents
you closed. Choose the number that corresponds with the document you want to open.



Exit command (File menu)
Use this command to end your session. You can also use the Close command on the application
Control menu. You are prompted to save any documents with unsaved changes.
Shortcuts:
Mouse: Double-click the application's Control menu button.
Keys: Alt+F4



Undo command (Edit menu)
Use this command to undo the last edit command, including Redo. It is unavailable when there is
nothing to undo.
You can undo each edit you made since the file was last saved by repeated use of this command, or you
can undo all edits at once using Ctrl+Shift+Z.

Shortcuts:

Toolbar:
Keys: Citrl+Z or Alt+Backspace
More information



Redo command (Edit menu)
Use this command to cancel the last Undo command. It is unavailable when there is nothing to redo.
You can redo each undo you cancelled by repeated use of this command, or you can redo all undos at
once using Ctrl+Shift+Y.

Shortcuts:
Toolbar:

Keys: Ctrl+Y

More information



Cut command (Edit menu)

Use this command to remove the currently selected text from the document and put it on the clipboard.
It is unavailable if no text is currently selected.

Cutting text to the clipboard replaces the contents previously stored there.
Shortcuts:
Toolbar:

Keys: Ctrl+X or Shift+Delete
More information



Copy command (Edit menu)

Use this command to copy the selected text from the document to the clipboard. It is unavailable if no
text is currently selected.

Copying text to the clipboard replaces the contents previously stored there.
Shortcuts:
Toolbar:
Keys: Ctrl+C or Ctrl+Insert
More information



Paste command (Edit menu)

Use this command to insert the contents of the clipboard at the cursor position, or to replace the current
selection. It is unavailable if there is no text on the clipboard.

Shortcuts:

Toolbar:
Keys: Citrl+V or Shift+Insert
More information




Copy Selection Append command (Edit menu)
Use this command to copy the currently selected text from the document and append it to any text
already on the clipboard. It is unavailable if no text is currently selected.

Shortcuts:
Keys: Ctrl+Shift+C

More information



Copy Line command (Edit menu)

Use this command to copy the line containing the cursor to the clipboard. It is unavailable if the current
selection extends over a line boundary.

More information



Copy Line Append command (Edit menu)

Use this command to append the line containing the cursor to any text already on the clipboard. ltis
unavailable if the current selection extends over a line boundary.

More information



Copy Word command (Edit menu)

Use this command to copy the word containing the cursor to the clipboard. It is unavailable if any text is
selected.

More information



Copy Word Append command (Edit menu)

Use this command to append the word containing the cursor to any text already on the clipboard. Itis
unavailable if any text is selected.

More information



Cut Selection Append command (Edit menu)
Use this command to remove the currently selected text from the document and append it to any text
already on the clipboard. It is unavailable if no text is currently selected.

Shortcuts:
Keys: Ctrl+Shift+X

More information



Cut Line command (Edit menu)

Use this command to remove the line containing the cursor from the document and put it on the
clipboard. It is unavailable if the current selection extends over a line boundary.

More information



Cut Line Append command (Edit menu)

Use this command to remove the line containing the cursor from the document and append it to any text
already on the clipboard. It is unavailable if the current selection extends over a line boundary.

More information



Cut Word command (Edit menu)
Use this command to remove the word containing the cursor from the document and put it on the
clipboard. It is unavailable if any text is selected.

Shortcuts:
Keys: Ctrl+Q

More information




Cut Word Append command (Edit menu)

Use this command to remove the word containing the cursor from the document and append it to any
text already on the clipboard. It is unavailable if anytext is selected.

Shortcuts:
Keys: Ctrl+Shift+Q

More information



Delete command (Edit menu)

Use this command to delete the currently selected text, or the character after the cursor if nothing is
selected.

Shortcuts:
Keys: Delete




Delete Line command (Edit menu)

Use this command to delete the line containing the cursor from the document. It is unavailable if the
current selection extends over a line boundary.




Delete Word command (Edit menu)

Use this command to delete the word containing the cursor from the document. It is unavailable if any
text is selected.




Delete Bookmarked Lines command (Edit menu)
Use this command to delete all lines that have bookmarks on them.



Cut Bookmarked Lines command (Edit menu)
Use this command to delete all lines that have bookmarks on them, and place them on the clipboard.



Copy Bookmarked Lines command (Edit menu)
Use this command to copy all lines that have bookmarks on them to the clipboard.



Invert Case command (Edit menu)
Use this command to change selected characters from upper to lower case, and vice versa.
If no text is currently selected, the case of the character after the cursor is changed, and the cursor is
moved one position to the right.

Shortcuts:
Keys: Ctri+K

More information




Upper Case command (Edit menu)
Use this command to change selected characters from lower to upper case.
If no text is currently selected, the case of the character after the cursor is changed, and the cursor is
moved one position to the right.
Shortcuts:
Keys: Ctrl+U

More information




Lower Case command (Edit menu)
Use this command to change selected characters from upper to lower case.
If no text is currently selected, the case of the character after the cursor is changed, and the cursor is
moved one position to the right.

Shortcuts:
Keys: Ctrl+L

More information




Sentence Case command (Edit menu)

Use this command to make the first character of the start of each sentence in the current selection upper
case, and the rest lower case.

This command is unavailable if no text is currently selected.

Shortcuts:
Keys: Ctrl+Shift+K

More information



Capitalize command (Edit menu)

Use this command to make the first character of each word in the current selection upper case, and the
rest lower case.

This command is unavailable if no text is currently selected.

Shortcuts:
Keys: Ctrl+Shift+U

More information



Transpose command (Edit menu)
Use this command to transpose lines or characters. If the cursor is at the beginning or end of a line, the
adjacent lines are swapped, otherwise the adjacent characters are swapped.

This command is unavailable if any text is selected.

Shortcuts:
Keys: Ctri+T




Transpose Words command (Edit menu)

Use this command to transpose the words either side of the cursor. Any punctuation between the words
is left in place. If the cursor is in the middle of a word, its two halves are transposed.

This command is unavailable if any text is selected.

Shortcuts:
Keys: Ctrl+Shift+T



Reduce Indent command (Edit menu)

Use this command to reduce the indentation of currently selected lines. Note that if more than one line
is selected, Shift+Tab has the same effect.

Shortcuts:
Toolbar:

Keys: Ctrl+Shift+l

More information



Increase Indent command (Edit menu)

Use this command to increase the indentation of currently selected lines. Note that if more than one line
is selected, the Tab key has the same effect.

Shortcuts:
Toolbar:

Keys: Citrl+l

More information



Align Center command (Edit menu)
Use this command to center currently selected lines between the left and right word-wrap margins.

Shortcuts:
Keys: Ctri+E

More information



Align Left command (Edit menu)
Use this command to align currently selected lines to the left margin.

More information



Align Right command (Edit menu)
Use this command to align currently selected lines to the right margin.

Shortcuts:
Keys: Ctrl+Shift+E

More information



Join Lines command (Edit menu)
Use this command to join currently selected lines. Each line in turn is appended to the first, separated

by a single space.

Shortcuts:
Keys: Ctrl+J

More information



Split Wrapped Lines command (Edit menu)

Use this command when in word-wrapping mode to split currently selected lines at the point where they
are wrapped, by inserting new line characters.



Reformat command (Edit menu)

Reformat:

Use this command to adjust the lengths of currently selected lines to the word-wrap margin. Words are
moved between the lines as necessary, and blank lines are preserved as paragraph separators.

Shortcuts:
Keys: Ctrl+Shift+J



Insert Line After command (Edit menu)
Use this command to open up a new line after the line containing the cursor. It is unavailable if the
current selection extends over a line boundary.

Shortcuts:
Keys: Ctrl+Enter

More information



Insert Line Before command (Edit menu)
Use this command to open up a new line before the line containing the cursor. It is unavailable if the
current selection extends over a line boundary.

Shortcuts:
Keys: Ctrl+Shift+Enter

More information



Insert Page Break command (Edit menu)
Use this command to insert a page break at the start of the line containing the cursor. It is unavailable if
any text is currently selected.

Shortcuts:
Keys: Ctrl+Shift+L

More information



Insert File Name command (Edit menu)

Use this command to insert the full file name of the active document at the cursor position, or to replace
the current selection. This command is disabled for documents that have never been saved to a file.

Shortcuts:
Keys: None



Insert File command (Edit menu)
Use this command to insert the contents of a file at the cursor position, or to replace the current
selection. The File Open dialog box appears to allow you to select the file to insert.

Shortcuts:
Keys: Ctrl+Shift+V

More information



Insert Time command (Edit menu)
Use this command to insert the current time at the cursor position. The format used is as specified with
Control Panel's International applet.
Shortcuts:
Keys: Ctrl+F10




Insert Short Date command (Edit menu)
Use this command to insert the current date at the cursor position. The format used is as specified for
short dates with Control Panel's International applet.
Shortcuts:
Keys: Ctrl+F10




Insert Long Date command (Edit menu)
Use this command to insert the current date at the cursor position. The format used is as specified for
long dates with Control Panel's International applet.
Shortcuts:
Keys: Ctrl+F10




Mark Clean command (Edit menu)

Use this command to cancel, without undoing, any changes that have been made to the active
document. The changes remain, but you will not be prompted to save the document when you close it.

This command also clears the undo buffer for the document.



Fill Block command (Edit menu)
Use this command to fill the selected block of text with a specified character or characters. A dialog box
is displayed for you to enter the characters to fill with. These are repeated if the block to be filled is

wider than the fill characters.
You can fill with tabs by entering \t’ as the fill character. If you actually want to fill with \t’, enter it as \\".
This option is disabled until a selection has been made in block mode.



Clear All command (Edit menu)
Use this command to delete the whole contents of the Command Results window.

Shortcuts:
Keys: Alt+Del



Select All command (Edit menu)
Use this command to select the whole document.

Shortcuts:
Mouse:  Crl+Left click in the left margin.
Keys: Ctri+A

More information



Find command (Search menu)
Use this command to specify a search string and the search criteria, such as whether or not to match
case. It brings up the Find dialog box, which can remain permanently on screen.
Shortcuts:
Toolbar:
Keys: F5
More information



Find Next command (Search menu)

Use this command to find the next occurrence of the selected text. If nothing is selected, or the
selection extends over one line, the last search string, if any, is used.

If one of the Find, Replace, or Find in Files dialog boxes is on the screen, the new search string is
copied to its Find What box.

Shortcuts:
Keys: Ctrl+F

More information



Find Previous command (Search menu)

Use this command to find the previous occurrence of the selected text. If nothing is selected, or the
selection extends over one line, the last search string, if any, is used.

If one of the Find, Replace, or Find in Files dialog boxes is on the screen, the new search string is
copied to its Find What box.

Shortcuts:
Keys: Ctrl+Shift+F

More information



Find in Files command (Search menu)
Use this command to specify a search string, the search criteria, such as whether or not to match case,
and the list of files to search. It brings up the Find in Files dialog box, which can remain permanently on

screen.
Shortcuts:
Toolbar:
Keys: Ctrl+F5
More information



Replace command (Search menu)
Use this command to specify search and replace strings and the search criteria, such as whether or not
to match case. It brings up the Replace dialog box, which can remain permanently on screen.
Shortcuts:
Toolbar:
Keys: F8
More information



Replace Next command (Search menu)
Use this command to replace the current selection with the last defined replacement string.

Shortcuts:
Keys: CtrI+F8

More information



Go To command (Search menu)

For text files, this command moves the cursor to the beginning of a specified line, page, column,or byte
offset. It brings up the Go To dialog box, in which you can type the number. If the number is signed, it
is interpreted as an offset relative to the current position.

For binary files, this command moves the cursor to a specified offset in the file. It brings up the Go To
Address dialog box, in which you type the address in hexadecimal.

Shortcuts:
Keys: Ctri+G



Jump Next command (Search menu)
Use this command to do a hypertext jump to the next item in the Search or Command Results windows.
Which of the Search or Command Results windows is used by this command is set according to the last
one accessed. This is shown with a bullet (. ) against it on the Window menu.
Shortcuts:
Toolbar:
Keys: F4



Jump Previous command (Search menu)
Use this command to do a hypertext jump to the previous item in the Search or Command Results
windows.
Which of the Search or Command Results windows is used by this command is set according to the last

one accessed. This is shown with a bullet ( ) against it on the Window menu.
Shortcuts:
Toolbar:
Keys: Shift+F4



Toggle Bookmark command (Search menu)
Use this command to set or clear a bookmark on the current line.

Shortcuts:
Keys: Ctrl+F2

More information



Next Bookmark command (Search menu)
Use this command to go to the next line containing a bookmark.

Shortcuts:
Keys: F2
More information



Previous Bookmark command (Search menu)
Use this command to go to the previous line containing a bookmark.

Shortcuts:
Keys: Shift+F2

More information



Clear All Bookmarks command (Search menu)
Use this command to remove all the bookmarks from the active document.

Shortcuts:
Keys: Ctrl+Shift+F2

More information



Match Bracket command (Search menu)

Use this command to go to the closing bracket matching the opening bracket after the cursor (or vice
versa).

Shortcuts:
Keys: Ctrl+M

More information




Toolbar command (View menu)

Displays or hides the toolbar. This setting is also available on the View tab of the Preferences dialog
box.



Status Bar command (View menu)

Displays or hides the status bar. This setting is also available on the View tab of the Preferences dialog
box.



Clip Library command (View menu)
Displays or hides the Clip Library.

Shortcuts:
Keys: Ctrl+F3

More information



Horizontal Scroll Bar command (View menu)

Displays or hides the horizontal scroll bar in the active view. This setting is also available on the View
tab of the Properties dialog box. Note that you can set the default for all views on the View tab of the
Preferences dialog box.

Shortcuts:
Keys: Ctrl+Q, H



Line Numbers command (View menu)
Displays or hides line numbers in the active view. This setting is also available on the View tab of the
Properties dialog box. Note that you can set the default for all views on the View tab of the Preferences

dialog box.

Shortcuts:
Keys: Ctrl+Q, L



Visible Spaces command (View menu)

Displays spaces tabs and paragraph marks as visible characters in the active view. Spaces are shown
as () , tabs as (»), and line ends as ().

This setting is also available on the View tab of the Properties dialog box. Note that you can set the
default for all views on the View tab of the Preferences dialog box.
Shortcuts:
Toolbar:

Keys: Ctr+Q, V



In Web Browser command (View menu)

Displays the active document in the default web browser. This command is only available for HTML
documents. Itis also displayed on the context menu for HTML documents.

For this to work, the browser must have associated itself with the extension of the document's file name.

Shortcuts:
Keys: None

More information



Compare Files command (Tools menu)
Use this command to look for differences between two text files. It brings up the Compare Text Files
dialog box, in which you can specify the file names.

Shortcuts:
Keys: Ctrl+F9

More information



Spelling command (Tools menu)
Use this command to check the spelling of the active document.
Shortcuts:
Toolbar:
Keys: F7
More information



Sort command (Tools menu)
Use this command to sort selected lines.

Shortcuts:
Keys: F9
More information



Word Count command (Tools menu)
Use this command to get word, line and character counts for the active document.

Shortcuts:
Keys: Shift+F9

More information



Convert command (Tools menu)
Use this command to convert the character set in the active document between ANSI and DOS (also

known as OEM or IBM).
Note that the conversion is not reversible for characters that are unique to the current character set
(such as line drawing characters), and the command cannot be undone.

TextPad selects the MS LineDraw font, after converting to DOS, and the default font after converting to
ANSI.

More information



HTML Validator command (Tools menu)
Use this command to check the syntax of the active HTML document with CSE 3310 HTML Validator.

Shortcuts:
Keys: None

More information



Explorer/File Manager command (Tools menu)
Use this command start Windows own File Manager, or Explorer.

Shortcuts:
Keys: Alt+F3



Stop command (Tools menu)

Use this command to terminate the user tool whose output is being redirected to the Command Results
window.

Shortcuts:
Keys: Ctrl+Break

More information



Run command (Tools menu)

Use this command to start another application, and optionally redirect its output to the Command
Results window. It brings up the Run dialog box for you to fill in the details.

More information



User Tool command (Tools menu)
Use this command to start an application that has been added to the Tools menu.

More information



Record command (Macros menu)
Use this command to start and stop the macro recorder.
Shortcuts:
Toolbar:
Keys: Ctrl+Shift+R
More information



Pause command (Macros menu)
Use this command to temporarily suspend and resume the macro recorder.

Shortcuts:

Toolbar: e

More information



Playback command (Macros menu)
Use this command to play back the unnamed (scratch) macro.

Shortcuts:
Toolbar:  |*]

Keys: Ctrl +R

More information



Multi-play command (Macros menu)
Use this command to play back a chosen macro macro more than once.
Shortcuts:
Toolbar:  Shift+2J
Keys: Citrl+F7
More information



Save command (Macros menu)
Use this command to save the unnamed (scratch) macro.

More information



User Macro command (Macros menu)
Use this command to play back the selected macro in its default play mode.

Shortcuts:
Keys: Ctrl+Numpad <number>

More information



Block Select Mode command (Configure menu)

Use this command to alternate between block (column) and normal selection modes. A check mark is
shown against this menu item when block selection mode is enabled. The current state is also
displayed on the status bar.

This command is not available in word-wrapping mode.

Shortcuts:
Mouse: Alt+Left button

More information



Word Wrap command (Configure menu)
Use this command to switch in and out of word-wrapping mode.
Shortcuts:
Toolbar:
Keys: Ctrl+Q, W
More information



Synchronize Scrolling command (Configure menu)

Use this command to switch in and out of synchronized scrolling mode. When enabled, "Sync" is
shown on the status bar, and scrolling one view causes all views of all other documents to scroll by the
same amount.



Preferences command (Configure menu)
Use this command to bring up the Preferences dialog box. This lets you configure various settings.

More information



Customize command (Configure menu)

Use this command to bring up the Customize dialog box. This lets you customize TextPad's command
shortcuts, tools and macros.

More information



Screen Font command (Configure menu)

Use this command to bring up the standard Font dialog box. This lets you select the font to be used on
the screen.

More information



Document Properties command (Configure menu)

Use this command to bring up the Document Properties dialog box. This lets you change various
properties of the active document, and view its statistics.

More information



Split Window command (Window menu)

Use this command to split the active window into 2 panes. You may then use the mouse or the
keyboard arrows to move the splitter bar. When you are finished, press the left button, or Enter to leave
the splitter bar in its new location.

Pressing escape cancels this command.
More information



Tile Across command (Window menu)
Use this command to arrange your windows side by side across the screen.



Tile Down command (Window menu)

Use this command to arrange your windows one above another, in a non-overlapped fashion, down the
screen.



Cascade command (Window menu)

Use this command to arrange your windows in an overlapped fashion, from top left to bottom right of the
screen.



Arrange Icons command (Window menu)

Use this command to arrange neatly the icons for minimized windows at the bottom of the main window.
If there is an open document window at the bottom of the main window, then some or all of the icons
may not be visible because they will be underneath this document window.



Clip Library command (Window menu)
Use this command to display or hide the Clip Library.

Shortcuts:
Keys: Ctrl+F3 or Alt+0

More information



Selector command (Window menu)

Use this command to bring up the Document Selector. This is a list of your open documents that
remains permanently on the screen. You can move and resize this to your requirements, and use it to
switch between document windows.

Shortcuts:
Keys: F11

More information



Search Results command (Window menu)

Use this command to switch to the window showing the results of the last Find in Files command. This
command is unavailable if you close the window, until you do another Find in Files.

After you have used this command, a bullet mark ( ) is shown against it on the Window menu, to show
that the Jump Next/Previous commands on the Search menu apply to this window.

Shortcuts:
Keys: Shift+F11

More information



Command Results command (Window menu)

Use this command to switch to the window showing the output of the last tool from the tools menu. This
command is unavailable if you close the window, until you run another tool.

After you have used this command, a bullet mark ( ) is shown against it on the Window menu, to show
that the Jump Next/Previous commands on the Search menu apply to this window.

Shortcuts:
Keys: Ctrl+F11

More information



1,2,... command (Window menu)

Alist of currently open document windows is displayed at the bottom of the Window menu. A check
mark appears in front of the document name of the active window. Choose a document from this list to
make its window active.



Contents command (Help menu)
Use this command to display the opening screen of Help. From the opening screen, you can jump to
step-by-step instructions, and various types of reference information.
Once you open Help, you can click its Contents button whenever you want to return to the opening
screen.



Search for Help command (Help menu)

Use this command to display the Search dialog box. This displays the index of help topics for you to
select from. It is equivalent to clicking the Search button when you are already running the help
system.



Tip of the Day command (Help menu)
Use this command to display the Tip of the Day dialog box.



TextPad on the Web command (Help menu)

Use this command to connect to TextPad's home page with your default browser. The URL is
http://www.textpad.com/, in case this command is unable to connect automatically.



About TextPad command (Help menu)

Use this command to display the About dialog box. This displays various license details, and system
resource information.



Context Help command

Use the Context Help command to obtain help on some portion of the graphical interface. When you
choose the Toolbar's Context Help button, the mouse pointer will change to an arrow and question mark.
Then click somewhere in the application window, such as another Toolbar button. The Help topic will be
shown for the item youclicked.

Pressing escape cancels this command.

Shortcuts:
Keys: Shift+F1



Open Include File (Context menu)

Clicking with the right button on a line beginning #include ..., adds a command to open the included
file to the popup menu. If you choose that command, the file will be opened in a new window.



Open All command (Context menu)

This command is on the context (right click) menu for the Search Results window. It will open all the
files listed, or only those in the current selection, and place bookmarks on each matched line.

More information



Installing TextPad
Minimum Requirements:

16-bit Edition: 32-bit Edition:
386SX CPU with 4MB RAM 486SX CPU with 4MB RAM (12MB for NT)
1.5 MB free disk space 2.5 MB free disk space

Windows 3.1 in 386 enhanced mode Windows NT 3.51, NT 4.0, Windows 95 or Windows
3.1 with the Win32s 1.30.172 subsystem.
Installation:

TextPad has a setup program which configures it for the version of Windows that you are using. Some
things will not work if you do not install it correctly. You have been warned!

The setup program will preserve your existing preferences when updating from an earlier release.

Installing from a ZIP File:

1. Unzip into an empty temporary folder, with PKUNZIP 2.04g.

2. Run SETUP.EXE, and follow the on-screen instructions.

3. Be sure to install TextPad into a different folder from the one used in step 1 above.
4. Delete the files unzipped in step 1 above.

Installing from Diskettes:

To install TextPad run SETUP.EXE from the disk labelled "Setup Disk 1", and follow the on-screen
instructions.

Notes:

Do not attempt to install the 32-bit edition on Windows 3.1 or 3.11 without first installing
Microsoft's Win32s 1.30.172, 32-bit extensions to Windows. Win32s is available from CompuServe forum
MSWIN as PW1118.EXE, and from URL:

http://support.microsoft.com/support/win32dev/fag/all.asp

If you have previously used an unregistered copy of TextPad, its OLE drag-drop capability may
have been disabled. To enable it, run TextPad (without opening any files) and choose the Preferences
command from the Configure menu. Make sure that the "Use OLE Drag and Drop" box is checked on
the General settings tab. If you get an error message, you will need to obtain OLE 2. This is standard
on Windows 95 and NT, is supplied with many Microsoft products, and the relevant files are included with
Win32s.

If you have associated file extensions with TextPad using Explorer or File Manager, remake them
using the Associations tabs on the Preferences dialog box. This will ensure that TextPad is started
correctly when you double-click a file.

What Goes Where:

The setup program creates a two-level directory structure. The top level contains the main program
and README files. The sub-directories contain the following files:

SYSTEM Online help, dynamic link libraries, tips of the day and command shortcut
files.

SPELLING DLL's and standard dictionaries for the spelling checker.

SAMPLES Sample macros and clip library files.

USER Default folder for storing customized command shortcuts, user dictionaries,

macros, and clip library files.

TextPad will not work correctly if its files are not where it expects to find them, so please do not move
them around. The USER folder is under your own control, and the files that are stored in it can be
specified on the Folders tab of the Preferences dialog box.

Personal Preferences:
The 32-bit edition saves your personal preferences in the Windows registry under the key:
HKEY_CURRENT_USER\Software\Helios\TextPad 3



The 16-bit edition saves them in TEXTPADS3.INI, in your WINDOWS directory.
All preferences can be configured from within TextPad, so if you edit them directly, it is at your own risk.

See Also:
Obtaining Updates



How to Sort by Selected Column
To sort lines in your document, using the text in the selected column as a key:

1.
. Click the mouse at the top left of the column, and drag it to the bottom right to select the lines to sort.
. From the Tools menu, choose the Sort command to display the Sort Selected Column dialog box.

. Choose to sort in ascending or descending order.

. Set the comparison to be by character, with capital letters being significant or not, or by numeric

a b wWwN

o

Uncheck word-wrapping and check block select mode on the Configure menu.

value.

. Check the "In character code order" box, if you want characters ordered by their numeric codes,

rather than locale specific conventions.

7. If you want to delete all duplicate lines, check the "Delete duplicate lines" box.
8. Click OK.
Notes:
Character comparisons use the collating sequence conventions for the regional settings selected

with Windows Control Panel.

Numeric comparisons use signed integral values. Floating point values are not supported. If

the key field does not contain a number, the value used for comparison is the ANSI code of the first
character.

See also: Sorting by Keys



How to Sort by Specified Key Positions
To sort selected lines in your document, using up to 3 keys:
1. Uncheck block select mode on the Configure menu.
2. Click the mouse on the first line, and drag it to the last line to sort.
3. From the Tools menu, choose the Sort command to display the Sort Selected Lines dialog box.
4. For each of up to 3 keys:

Specify the start display column position and length. Omit the length if the key extends to the end of
the line.

Choose to sort in ascending or descending order.

Set the comparison to be by character, with capital letters being significant or not, or by numeric
value.

5. Check the " In character code order " box, if you want characters ordered by their numeric codes,
rather than locale specific conventions.

6. If you want to delete all duplicate lines, check the "Delete duplicate lines" box.
7. Click OK.

Notes:

Lines are sorted first by key 1, then key 2, then key 3.
Keys may overlap.

Character comparisons use the collating sequence conventions for the locale selected using
Windows Control Panel.
Numeric comparisons use signed integral values. Floating point values are not supported. If

the key field does not contain a number, the value used for comparison is the ANSI code of the first
character.

See also: Sorting by Column



How to Check Spelling: Overview
TextPad has licensed spelling checking technology from LexSaurus Software, Inc. This gives you the
ability to verify words, correct spelling errors, check capitalization, create your own dictionaries, and
extend the standard ones. Dictionaries are available in the following languages:

dansk Nederlands
Deutsch Norsk
espaniol svenska
francgais UK English
italiano US English

See Obtaining Standard Dictionaries if you don't already have the dictionary you require.

Standard dictionaries must all be installed in the SPELLING sub-folder of your TextPad folder, but you
can specify an alternative folder for custom dictionaries, and personal extensions to standard
dictionaries. (You will want these folders to be different if TextPad is installed on a file server.)
Personal extensions are added to a user dictionary corresponding to the currently selected language or
custom dictionary, so the standard dictionaries can be write protected.

By default, if the corresponding dictionary is available, TextPad will use the one corresponding to the
language you have set for Windows (using Control Panel). You can choose a particular language using
the Preferences command, and selecting the Spelling tab on the Preferences dialog box.

Spelling is checked for the entire document, unless you select the text to be checked first. Parts of
HTML and LaTex documents are ignored by the spelling checker, as described below.

When a word is not recognized, you can add it to the dictionary. If you know in advance of words you
use that are unlikely to be in the dictionary, you can add them all at once from a simple text file.
Normally, such additions are used in conjunction with the corresponding standard dictionary, but you can
have up to two stand-alone custom dictionaries.

Notes regarding HTML documents:

Text in HTML tags will be ignored for documents with standard HTML file extensions. In addition, the
spelling checker will automatically convert to and from HTML syntax for high ANSI characters. For
instance "&Uuml;" will be interpreted as "U".

Notes regarding LaTex documents:

Documents with the file extension ".TEX", are considered to contain LaTex type setting information.
Any word starting with "\" will treated as a command, and be ignored, as will any words in "{ ... }"
immediately following the command. Text between "$ ... $" is treated as mathematical symbols and
also ignored.

Any character from the set "OoUuAas", which is preceded by a double quote is interpreted as the
corresponding character from the set "O6UUAaR", and vice versa.

In case you are wondering why you can't just use the spelling checker of your favorite word processor with TextPad, it's because of
licensing restrictions. You've already paid for the spelling checker, but TextPad cannot use it without a license, and Inso Corp.
were not interested in selling one for use with shareware.



How to Check Spelling

To check the spelling of a whole document, first clear any selection, otherwise select the text to check,
then choose the Spelling command from the Tools menu. You will be presented with the following
dialog box for each word that is not recognized:

Spelling |

Wi'ord not found in dictionany:

[TextPad
Change to:
1 lgnare Ignare All
testa =
textured Change Auto-correct
et =
textual
tactata ;I &dd EUQQESt
Options... e Last Cloge Help

The spelling checker will list suggestions for the correction, if it has any, and place the most likely of
them in the Change To box. If you want to edit the original word, you can copy it to the Change To box
by clicking it.

The actions available are:

Ignore this occurrence of the word, and continue checking.

Ignore All occurrences of the word, and continue checking.

Change the original to the word in the Change To box, and continue checking.

Auto-correct all occurrences of the word to the word in the Change To box, and continue
checking.

Add the original to the dictionary, and continue checking. Note that Shift+Add will add all unique
words in the document to the dictionary.

Suggest other words similar to the one in the Change To box. This button is disabled until you
modify the Change To word.

Undo Last change, and continue checking.
Close the spelling checker.

The Options button allows you to select the language and configure various other settings. You can
also do this using the Preferences command and selecting the Spelling tab on the Preferences dialog
box.



How to Edit User Dictionaries

There is one user dictionary corresponding to each of the available languages. When you edit a
dictionary, no changes are made to the base dictionary.

To edit a user dictionary:
1. Choose the Preferences command on the Configure menu. The Preferences dialog box will be
displayed.
2. Select the Spelling tab.
3. Choose the language to edit.
4. Click the Edit button to display the following dialog box.

Edit US English User Dictionary |

Entries: Add

Iteh|

CompuSerse Heleie

downloaded

Microsoft's Change

TexPad Add File...
Delete All

Automatic replacement;

Ithe Close

The words currently in the dictionary will be listed. Choose from the following actions (none of which
can be undone):

Add the word in the Entries box. If you want an automatic replacement for all occurrences of
this word (e.g. one you frequently mistype, or an abbreviation you want to expand), type it in the
Automatic Replacement box before clicking Add.

Delete the selected word.

Change the selected word to the one in the Entries box. You can change the Automatic
Replacement at the same time.
Add File of words. Prepare the file with one word per line, optionally separated by a space or

tab from its automatic replacement. The automatic replacement may contain spaces, but neither the
word nor its replacement may contain more than 50 characters.

Delete All words in the dictionary.
Close the editor.



How to Obtain Standard Dictionaries

Standard dictionaries for the spelling checker are available for downloading from our web site at
http://www.textpad.com/, and from CompuServe forum WINUTIL, amongst other sources. The following
table shows the name of the file to download for each language.

To install a language file, simply unzip it into the SPELLING sub-folder of your TextPad folder, then
select it on the Spelling tab of the Preferences dialog box.

Language: File Name:
dansk txpaddan.zip
Deutsch txpaddeu.zip
espanol txpadesp.zip
frangais txpadfra.zip
italiano txpadita.zip
Nederlands txpadned.zip
Norsk txpadbok.zip
svenska txpadsve.zip
UK English txpaduk.zip

US English txpadus.zip



How to Configure the Spelling Checker
To configure the spelling checker:
1. Choose the Preferences command on the Configure menu. The Preferences dialog box will be
displayed.
2. Select the Spelling tab.
This tab can also be displayed by clicking the Options button on the Spelling dialog box.
The parameters you can configure are:

Language: choose from the drop-down list of available languages. Automatic selects the language
configured by Control Panel.

Ignore words containing. These settings are on a per language basis:
All CAPITALS - prevent acronyms (e.g. HTML) being checked;

Numbers - prevent sequence numbers, such as "A10", being checked
Underscores - prevent words such as "x_offset" being checked

Single letters - prevent one letter words being checked.

Remember which words to correct automatically. When checked, words corrected using the Auto-
Correct button on the Spelling dialog box are permanently saved in the user dictionary. Otherwise, they
are discarded when you close TextPad.

Prompt for proper nouns and abbreviations. \When not checked, unrecognized words that start with
a capital letter, or end with a period are added to the user dictionary exactly as typed. This means that
if they are later encountered without an initial capital letter or trailing period, they will not be recognized,
and will have to be added as separate words. When this option is checked, you will be asked if a word
starting with a capital letter is a proper noun. If not, it will be added with the first letter in lower case.
Similarly, if a word ends in a period, you will be asked if it is an abbreviation. If not, it will be added
without the trailing period.

Substitute HTML syntax for high-ANSI characters. When checked, characters with diacritical marks,
such as U and &, are automatically converted to their equivalent HTML syntax (e.g. &Uuml;), as you
type, and when spelling errors are corrected. This setting applies to the currently selected language,
and for HTML documents only.

Edit the selected user dictionary.



Getting Assistance While You Work
You can use the on-line help system in various ways to help you as you work:

Press F1 in any context to display help information. For example, highlight a menu command
and press F1 to find out what it does.
Click

on the toolbar, then click

k? where you want help.

Hold the mouse pointer over a toolbar button to find out what it does.
Use the Contents command on the Help menu to display all help topics.



Technical Support
Important: Please read How to Report Problems before submitting any problem reports.
Technical support can also be obtained by sending electronic mail to:
support@textpad.com
You can also fax queries to +44 (1772) 786375, or post them to:

Helios Software Solutions
PO Box 619
LONGRIDGE

PR3 2GW

England



How to Report Problems
Have you checked the frequently asked questions and known problems first?
Please provide at least the following information with any problem report:

. The version number and edition (16/32-bit) of TextPad.

. The version of Windows (and Win32s if appropriate) that you're using.

. Driver manufacturer and version numbers for printer problems.

. Display driver and screen resolution for GPF's, along with any error messages.

. Which compatibility mode you have selected in TextPad.

6. How to reproduce the problem.
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Please do not send large attachments unless we ask you to. A screen dump can create a 2MB bitmap
file, whereas the important information may be represented in only 100 characters.

E-mail your completed report to:
support@textpad.com

or FAX it to:
+44 (1772) 786375

or post it to:

Helios Software Solutions
PO Box 619
LONGRIDGE

PR3 2GW

England



Obtaining Updates
New releases of TextPad will be made available for downloading from various sites, including:
Our Internet Web site at URL: http://www.textpad.com/

Our FTP server at: ftp.textpad.com
Log in as "anonymous", use your e-mail address as the password, and change directory to /pub.

CompuServe forum WINUTIL, as:
TPAD16.ZIP (16-bit edition)
TPAD32.ZIP (32-bit edition)

Note: To maintain full TextPad access rights, registered users must keep their original license file with
each new release.



Here are some tips you may find useful:

' Remember to make use of the right mouse button.
Double left click in the left margin selects the line.
Ctrl+left click in the left margin selects all lines.
Alt+left click toggles block (column) selection mode.
The indicators on the status bar can be changed by double clicking them.
To save a file with a new name, while keeping it open with the original name, select all lines
(Ctrl+A) before using the Save As command, and check "Selection only" on the Save As dialog box,
before clicking the Save button.
"@-files" are normal text files containing a list of file names one per line. They can be used on
the command line and in the Quick Open dialog box, to make TextPad open all the specified files, and in
the "In Files" box on the Find in Files dialog box, to specify the list of files to search. Simply precede the
name of this file with an "@" to make TextPad look inside it, rather than open it as a normal file. (Note
that the "@" character must not be part of the name of the file.)
When you right click a "#include" line in a C/C++ source file, a command to open the included file
is added to the pop up menu.
You can use Explorer's Send To command to open selected files with TextPad. Right click the
selection, choose Send To, and pick TextPad from the cascading menu.
When using the Save As dialog box, Windows 95 will not let you specify a name without an
extension, or an arbitrary extension that it does not recognize, unless you select "All Files (*.*)" as the
Save as type, or enclose the name in quotes.
When the File Open dialog box is enabled for multiple file opening, it does not show long file
names (except on Windows 95 & NT 4). This setting can be changed on the General tab of the
Preferences dialog box.
On Windows 95 and NT 4, you can create directories, and rename and delete files using the
Open File dialog box, just like in Explorer.
You can change the default Open File filter by moving it to the top of the list on the Filters tab of
the Preferences dialog box. Note that if you set the option to save the workspace, on the General tab,
the default is the last filter that you used.
Ctrl+Shift+O brings up a simple dialog box for file opening, in which you can type wild cards, such
as "*.html".

In the Replace dialog box, you can use \t' as a tab and "\f' as a form feed in the search and
replace strings, if you check the Regular Expression check box.
After you have saved the Search or Command output results as an ordinary file, it loses its

hypertext jump property, but you can always load an ordinary file into the Command output window by
capturing the output from the DOS TYPE command.



Known Problems
The following problems have been identified with this release:

1

10.

1.

. Various printer drivers do not work with Win32s (e.g. HP DeskJet and Citizen Swift). The symptoms

are that TextPad 32 goes through the motions of printing a file, but it never gets printed. Try using a
compatible driver from the standard list of Windows printer drivers, instead of the one that comes
with the printer, or contact your supplier for an updated driver. You can get PCL driver 6.1d, to fix
the problem with HP DeskJets, from CompuServe forum HPPERIPHERALS.

. If you use TextPad 16 and you have an HP LaserJet 4M with the Adobe printer driver, you must use

version 3.01 or later. This can also be downloaded from CompuServe forum HPPERIPHERALS.

. WinFax Pro 4 does not work with 32-bit applications that use Win32s to run on 16-bit Windows.

Therefore you must use the 16-bit edition of TextPad if you want to use it to send faxes on Windows
3.1x.

. Print preview does not work with generic text printers.
. The 32-bit edition will not save files from NT 4 to a UNIX server, if connected using Samba, unless

the direct overwrite option is set on the Backup tab of the Preferences dialog box.

. The edit commands to change case don't work in the 32-bit edition, when running on the Hebrew

edition of Windows 3.1 with Win32s. This is due to a bug in Win32s.

. On NT 4.0 (up to SP #3, at least) the Open File dialog box cannot be used to open many files at

once, due to a 256 character limitation. TextPad uses a 2Kb buffer, so this is due to a bug in NT
4.0.

. On NT 4.0 (up to SP #3, at least) TextPad takes a long time to open a file with an associated

extension, if you double click the file on the desktop. This is due to a known problem in NT 4, which
is fixed in the first beta release of NT 5. A workaround is to right click the file, and use the Send To
command.

. The freeware program, ExpNotes, from PC Magazine, will cause TextPad (and IE 3) to crash when

you move the mouse over the flat-style toolbar. The workaround is to select "with regular buttons"
on the View tab of the Preferences dialog box.

Netscape Navigator and Communicator cannot send the text of a TextPad document in-line in an e-
mail message. If you configure them to process e-mail from MAPI-based applications, they replace
the standard MAPI32.DLL with a cut down version that does not have the required functionality. The
workaround is to check "Send documents as e-mail attachments" on the Document tab of the
Preferences dialog box.

If you save a file to a server from a client PC running NT 4 and IBM Antivirus 3.0 for Windows NT, it
will end up full of binary null characters. This problem is not specific to TextPad, so make sure
"Prevent common viruses" and "Check files when accessed" are turned off, to prevent it happening.



How to Uninstall TextPad
From Windows 95:
. Click the Start menu and select Settings/Control Panel.
. Double click Add/Remove Programs.
. Select TextPad from the list and click Add/Remove.
. Confirm that you want to uninstall TextPad.

. When Uninstall has finished, use Explorer to manually delete the TextPad installation directory, and
the uninstall program.
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From Other Versions of Windows:
1. Run UNINSTAL.EXE (or UNINST16.EXE) from your TextPad installation directory.
2. Confirm that you want to uninstall TextPad.

3. When Uninstall has finished, use File Manager to manually delete the TextPad installation directory,
and the uninstall program.

4. Manually delete any Program Manager icons and groups for TextPad.

A Note about File Associations:

Any file associations that you have made with TextPad 1.31 or later will revert back to their defaults
when you uninstall TextPad. If you have previously associated any file extensions with TextPad, and
you want to set them back to their default associations at any time:

1. Run File Manager (WINFILE.EXE)

2. Select any file with the given extension.

3. From the File menu, choose the Associate command.

4. Make the corresponding association from the following table:
.BAT MS-DOS Batch File
INF Setup Information
.INI Configuration Settings
.REG Registration Entries
TIXT Text Document



The Command Results Window

The Command Results Window is used to capture the output from the Run command, or from tools
added to the Tools menu. If the output is from a compiler, or Grep type program, it can be used to
hypertext jump directly to the corresponding source line usingleft double-click. Built-in support is
provided for output from Microsoft and Symantec compilers, in the form:

filename (line) : message

If this default is not suitable, it will be necessary to specify an alternative hypertext jump regular
expression,. This is set from the Hypertext Expression command on the Configure menu for the
Commmand Output window.

Loading a File into the Command Results Window:

If the Command Results to be used for hypertext jumps is written to a file, rather than stdout, it cannot
be captured automatically. However, any file can subsequently be loaded into the Command Results
window by adding the following command to the Tools menu:

Command: TYPE

Menu Text: Load Command Results
Parameters:

Initial Directory: (something suitable)
Prompt for Parameters [X]

Run Minimised: [X]

Capture Output: [X]

DOS Command: [X]

Save files before starting: [1

If the file needs post-processing in any way, use your own filter program, instead of the DOS TYPE
command, to write the processed data to stdout.



Tool Parameter Macros

Programs that you add to the Tools Menu can be started with context dependent information using
parameter macros. These can be specified in the "Command”, "Parameters" and "Initial Directory"
fields of the Tools dialog box, and in the Run and Tool Parameters dialog boxes. The following macros

are defined:

Macro Name
$File

$DOSFile

SUNIXFile
$FileName

$BaseName
$FileDir

$FilePath
SUNIXPath

$Dir
SUNIXDir

$Line
$Col

$Prompt

$Password

$Sel

$SelLine

$SelWord

$Clip

Expanded String
The fully qualified filename of the current
document.

Same as $File, except that DOS aliases
are substituted for any long names in the
path, and characters are converted to
the DOS (OEM) code set.

Same as $File, except any '\' characters
are changed to '/".

The simple filename of the current
document.

$FileName, stripped of any extension.

The drive and directory of the current
document.

The directory of the current document,
stripped of the drive.

Same as $FilePath, except any '\
characters are changed to '/'.

The current working drive and directory.

Same as $Dir, except any '\' characters
are changed to '/'.

The cursor line within the current
document

The cursor column within the current
document

Prompt for a parameter to substitute for
"$Prompt". If it is followed by a string in
brackets, that string will be displayed in
the prompt dialog box. E.g.
$Prompt(Enter user name:).

Prompt for a parameter to substitute for
"$Password ". The parameter will not
be echoed as itis typed Ifitis followed
by a string in brackets, that string will be
displayed in the prompt dialog box. E.g.
$Password(Enter password:).

Selected text in the active document.
This is limited to the first line in a
multiple-line selection.

The text of the current line in the active
document. This will be selected, if
necessary.

The current word in the active document.
This will be selected, if necessary.

Selected text in the active document, or
the whole document if nothing is
selected, is copied to the clipboard
before running the tool. (This is not a



real parameter, in that nothing is
substituted in the command line.)

Notes:
An empty string replaces any macro that is inappropriate in the current context.
Macros can be in any case (eg. $File = = $file = = $FILE).
The macro name can be bracketed to delimit it from subsequent text. (eg. $(Sel)ection), except
for $Prompt and $Password.
If a flename macro contains spaces when expanded, it will automatically be quoted.

Fully qualified is defined to mean drive + path from the root of that drive (e.g. C:
\WINDOWS\WIN.INI).

In any expression using macros, a non-alphabetic character, or the end of line must terminate
each macro.
If a tool uses any of the macros FC_File, FC_UNIXFile or FC_DOSFile, the active document will

be saved prior to running the tool.



Command Line Parameters

The command line parameters listed below can be used to start TextPad. They are not case sensitive,
but must appear before any file names. Surround any parameters containing spaces with quotation
marks ("). Because some of the parameters are mutually exclusive, conflicts are resolved by using the
last option specified. Any other parameters are silently ignored. The switch character can be '/' or '-'
as shown:

Parameter Description

-av Arrange windows vertically tiled.

-ah Arrange windows horizontally tiled.

-ac Arrange windows cascaded.

-am Arrange windows maximized.

-ca Open any specified file name parameters
in the ANSI code set.

-cd Open any specified file name parameters

in the DOS code set.

-i Start minimized (iconized).

-I# User interface language, where # is:
7=German, 9=English, 10=Spanish,
12=French, 16=ltalian.

-m Start another instance, regardless of the

setting for "Allow multiple instances".
(Only available in the 32-bit edition.)

-ol Set landscape orientation for printing.

-op Set portrait orientation for printing.

-p "file" Print the specified file using default printer.

-q Don’t display startup "splash" message.

-r Open any files in the command line as read
only.

] Started by a DDE shell command.

-t "title" Append "title" to the main window title bar.

-u file Open the file, whose name can contain
spaces, but does not need to be quoted.

@file Open all the files that are listed, one per

line, in the specified file. This overrides
the option to load the workspace, specified
on the General tab of the Preferences
dialog box.

Notes:
Except when using the -p option, multiple filenames and/or wildcards can follow these command
parameters, but they must be quoted to allow for filenames containing spaces.
An empty, quoted filename (i.e. ") causes a new document to be created.

If the filename to be edited (not printed) is followed by "(<line>[,<col>])", with no intervening
spaces, the file will be opened with the cursor at that position. If <line> is a hex number (eg. 0x1a22), a
hex view of the file will be created, with the cursor at that address.

eg. TXTPAD32.EXE -ac "Read me.txt(51,20)"

In this example TextPad will start up and open "Read me.txt" at line 51, column 20 and display itin a

cascaded window.




How to Run Other Programs

1.
2.

From the Tools menu, choose the Run command. The Run dialog box appears.

In the Command box, either type the name of the program or command, or choose a previous entry
from the drop-down list. If the program cannot be found in your search path, you will need to supply
its full path name.

. In the Parameters box, type any parameters required by the program. You can use any tool macros

such as $File here, to specify the active file.

. In the Initial Directory box, type the initial working directory for the program. If this box is blank, it

defaults to the directory containing the particular program. You can use directory tool macros here.

. If the command is a DOS internal, such as DIR or TYPE, check the DOS Command box.
. If you want the program to run in a minimized window, check the Run Minimized box.

7. If you want to redirect the output from the program to the Command window, check the Capture
Output box. This has no effect for Windows applications.

8. Click OK.

Note:

If you capture the output of another program in 32-bit versions of Windows, the output is displayed in the
Command window immediately. In 16-bit versions of Windows, the output is displayed when the
program finishes.



How to Use with Compilers

You can configure TextPad to compile the file in the active window, and output any compiler error
messages to the Command Results window. By double clicking an error message, you can go straight
to the corresponding source line.

The first step is to add the command line for your compiler to the Tools menu using the Tools tab on the
Customize dialog box.

Then you may have to define a regular expression that matches compiler error messages, using the
hypertext Jumps tab on the Preferences dialog box. TextPad uses that to extract the file name, and line
and column numbers to open the file at the right spot, when you double click the error message.

For example, to configure TextPad to use Java, add it to the Tools menu as follows:

Menu text: Compile JAVA
Command: JAVAC.EXE
Parameters: S$File

Initial directory: $FileDir
Capture Output: [x]

Save files: [x]

Then set its hypertext jump as follows:
Expression: MN([A-Za-z]:[M:]+\):\([0-9]+\):
File Register: 1
Line Register: 2



How to Use as the Editor for Other Applications

TextPad can easily be used as the editor for other applications. By using its dynamic data exchange
(DDE) capabilities, each file to be edited can beopened in a new window, rather than starting another
copy of TextPad.

The TextPad installation directory contains programs called DDEOPN16.EXE and DDEOPN32.EXE in
the SYSTEM folder. These translate command line requests to open files into the appropriate DDE
commands for the 16 and 32-bit editions of TextPad respectively. The first parameter must be the
registered server name TextPad, and the second parameter is the file to open, with an optional line and
column position immediately following in brackets.

Example 1:

To use TextPad as the editor for WinCIM 2, add the following line to the [General Preferences] section of
WINCIM.INI:

Text-Editor=C:\TEXTPAD\SYSTEM\DDEOPN16.EXE TextPad
Example 2:

To use TextPad as the editor for WinGrep, add the following line as the editor command on its Configure
dialog box:

C:\TEXTPAD\SYSTEM\DDEOPN16.EXE TextPad S$f ($1)
Example 3:

To use TextPad with Visual C++ 1.52, so that it edits the same active file as MSVC, customize the Tools
menu of MSVC.EXE with the following command:

Command Line: C:\TEXTPAD\SYSTEM\DDEOPN16.EXE

Menu Text: &TextPad
Parameters: TextPad S$File(SLine, $Col)
Example 4:

To use TextPad with Visual C++ 5, so that it edits the same active file as MSVC, customize the Tools
menu of MSVC.EXE with the following command:

Command Line: C:\TEXTPAD\SYSTEM\DDEOPN32 .EXE

Menu Text: &TextPad
Parameters: TextPad $(FilePath) ($(CurLine), $ (CurCol))
Notes:

For best performance, you should use DDEOPN32.EXE with 32-bit versions of Windows, and
DDEOPN16.EXE with 16-bit versions.

Whenever TextPad is reactivated, it checks the last modified date of each file that you are editing,
and asks if it should reload any that have been changed by another application.



How to Use with Web Browsers

TextPad can display the active HTML document in a web browser, using the View HTML command on its
View or context (right click) menu. Files with the following extensions are recognized as containing
HTML tags:

HTM, HTML

STM, STML

SHT, SHTML
SGM, SGML

CFM

PTX, PTI, PTE, PT

The file name is passed to the browser using the normal file extension association information, which
was written to the Windows registry when the browser was installed. This means that if the browser
has registered that it can use DDE messages, it will be able to use a single instance to view each file,
otherwise a new instance will be started for each one.

If you edit files directly in a local web server, such as MS Personal Web Server, you should specify its
root path and IP address on the Folders tab of the Preferences dialog box. Then TextPad will tell the
browser to access those files using HTTP, rather than as ordinary files, allowing any macro substitution
to take place.




How to Use with HTML Validator

CSE 3310 HTML Validator is a 3rd party application for validating the syntax of HTML documents, which
is available on the Internet from http://www.htmlvalidator.com/. We do not support it in any way (except
for the interface with TextPad, described below), so please check that web page for support information.

HTML Validator helps you find and correct the following problems in your HTML documents:

Misspelled or invalid tag names, tag attributes, and tag attribute values.

Misspelled or invalid character entities.

Missing quotation marks.

Missing closing tags.

Incorrect placing and nesting of tag names.

Incorrect or incompatible HTML based on a specific browser or HTML version (i.e. Netscape

extensions, HTML 2.0)

Use of high ASCII characters in HTML documents.

If you choose to install it, either by purchasing it, or by downloading an evaluation copy, the 32-bit edition
of TextPad will automatically add a command to run it to its Tools menu, which will be enabled for the
active HTML document. Run this command to output any error messages to the Command Results
window. Double click an error to edit the source document at the corresponding line, or use the Jump
Next and Jump Previous buttons on the toolbar to step through the errors.

You can also add commands to configure HTML Validator to the Tools menu as follows:

1.
2.
3.
4.
5.

From the Configure menu, choose Customize.

Select the Tools tab on the Customize dialog box.

Click New.

Select "HTML Validator setup" from the drop down menu.
Click OK.

You can assign shortcuts to any of these commands using the Tools tab on the Customize dialog box.



How to Use with the Java Development Kit

The Java Development Kit (JDK) is a product from Sun Microsystems for developing Java applications.
It can be downloaded from http://www.sun.com/java/. We do not support it in any way (except for the
interface with TextPad, described below), so please check that web page for support information.

After you have installed the JDK, you can add commands to compile and run Java applications to
TextPad's Tools menu as follows:

1. From the Configure menu, choose Customize.

2. Select the Tools tab on the Customize dialog box.

3. Click New.
4. Select "JDK Commands" from the drop down menu.
5. Click OK.

You can assign shortcuts to either of these commands using the Tools tab on the Customize dialog box.

Notes:

1. If the JDK is already installed when you install TextPad, its Setup program will give you the option to
add these commands at installation time.

2. The option to add JDK commands only appears on that menu if JAVAC.EXE is not run by any
existing tools, and if your PATH variable in AUTOEXEC.BAT includes the path to JAVAC.EXE.
Acknowledgement:

Thanks to Cay Horstman (http://www.horstmann.com/), the co-author of Cora Java (published by
Prentice-Hall), for contributing RUNJAVA.BAT. This figures out whether to run your Java program as an
applet in a web browser, or using the Java interpreter.



DDE Commands
The following DDE commands are recognized. They are all part of the "system" topic.

Command: Function:

[open("filename")] Opens the specified file using
the default code set.

[opendos("filename")] Opens the specified file using
the DOS (OEM) code set.

[command(Append,"string")] Appends the string to the active
document.

[command(SaveAs," filename")] Saves the active document with
the given name.

[command(Save)] Saves the active document.

These commands must be passed exactly as shown, with no embedded spaces, except in the quotes.

Note that the topic is not used to specify the document, so Append, Save and SaveAs all apply to the
active document.



How to Restrict User Capabilities

TextPad can be configured to restrict the ability of a user to make and save changes, manage files, and
work with external tools. The settings must be configured manually with REGEDIT.EXE, so it is
important to restrict access to that program.

To set the same capabilities for all users of a PC, except those with Administrator rights, create the
following key in the registry:

HKEY_LOCAL_MACHINE\Software\Helios\TextPad\Security
Then create a DWORD value under that key, with the name "Capabilities".

To restrict the capabilities of an individual user, except those with Administrator rights, log on as that
user, then create a DWORD value called "Capabilities" under the key:

HKEY_CURRENT_USER\Software\Helios\TextPad 3\Options

This can also be set by the Administrator, by accessing the same key for each user under
HKEY_USERS.

Each bit of "Capabilities" restricts a different capability, as shown in the following table:

Value: Capability:

1 Disallows creation and use of user tools on the Tools menu.
2 Disallows editing existing files.

4 Disallows use of the Save As command.

8 Disallows use of the Manage Files and Explorer commands.

Set "Capabilities" to the sum of the values for each capability you want to disallow.

Windows 3.1 Users

The "Capabilities" setting is stored in TEXTPAD3.INI in your WINDOWS directory, under the section
[Options]. Obviously, access to this file must be restricted, but do not make it read-only, because
TextPad saves all its user preferences there.
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What's New: Enhancements
Release 3.2.5
Updated the interface to CSE HTML Validator 3.0, which locates errors by character position as
well as by line number.
The Go To File command can now be used to open a URL.

Added command line parameters "-ca" and "-cd" to open files listed on the command line in the
ANSI or DOS code set respectively.

The paper size selected for the printer is now persistent.
Added a section to the online help about customizing the Macros menu.
Release 3.2.4

Changed the Window Tile commands to use Microsoft's terminology (in English).
Release 3.2.3

The IntelliMouse wheel now scrolls the window under the cursor.
Added ".SHTM" to the list of HTML extensions.
Increased the number of file extension filters to 16.

New tool parameter macros $SelLine and $SelWord, for selecting and substituting the line or
word under the cursor.

Release 3.2.2

New tool parameter macros, $Prompt and $Password for specifying parameters at run time.
In MS Mouse compatibility mode, mouse activation no longer changes the cursor position.
The Quick Open command now changes the current working directory to match the file path.
Release 3.2.1

Printing odd and even pages, for double sided printouts.
New option on the Compatibility tab of the Preferences dialog box dialog box to choose POSIX
syntax for regular expressions.
Automatic substitution of HTML syntax for high-ANSI characters can now be controlled with an
option on the Spelling tab of the Preferences dialog box.
ASP and WRL are now recognized as extensions for HTML documents.
Repainting has been optimized when running macros.
The Stay on Top command now precedes Close on the System menu.
Release 3.2
Polish user interface.
POSIX standard P1003.2 regular expression compatibility, including operators for matching zero

or one ("?"), a specified range of matches ("{min,max\}"), character classes (e.g. "[:alpha:]"), and
alternation ("this\|that").

View in Web Browser command on the View menu.

The setup program detects if the Java Development Kit (JDK) has been installed, and gives the
option to add compile and run commands to the Tools menu.

The popup menu for the New button on the Tools tab of the Customize dialog box also displays a
command to install the JDK commands, if appropriate. (32-bit edition only.)
A command to run HTML Validator is automatically added to the Tools menu, if that application

has been installed. The popup menu for the New button on the Tools tab of the Customize dialog box
also displays a command to add configuration tools for the validator. (32-bit edition only.)

The Document Selector now supports multiple selection for the Close and Print commands on its
context menu, and the 32-bit edition has new commands to tile the selected windows.
New option on the Document tab of the Preferences dialog box to terminate the last line

automatically.



New command on the Edit menu to insert the file name of the active document.

New option on the Print Setup dialog box to specify double spaced printing.

New option on the Compatibility tab of the Preferences dialog box dialog box to choose
icrosoft's conventions for mouse click selection.

New option on the Quick Open (Ctrl+Shift+O) dialog box to search for the specified file or wild
card in all subfolders.

The Clip Library for HTML characters has been extended to include all those defined for the
ISO-8859-1 (Latin-1) character set in HTML 4.0.

The spelling checker now handles word containing embedded HTML characters, such as
"&eacute;".

High ANSI characters typed in HTML documents are automatically substituted with the equivalent
HTML syntax.
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In LaTex documents, the spelling checker now interprets double quotes before one of "OoUuAas"
as the corresponding "O6UUAAR". It also skips text between "$ ... $", and in contexts such as "\cite{ ... }".
Files larger than 32kb are now e-mailed as attachments, and there is a new option on the

Document tab of the Preferences dialog box to force all e-mail to be sent that way.

The View.ActivateClipLib command (Alt+0) now toggles the focus between the Clip Library and
the active document.

The destination line of a go to or bookmark command is now briefly highlighted.

The positions of the Command and Search Results windows are now persistent.

If the cursor is at the end of the document when its file is reloaded, as a result of changes made
by another process, it will be moved to the new end of document, thus tracking the end of file.

The option to minimize the main window when the last document is closed can now be overridden
by holding the shift key down.

It is now possible to restrict the ability of a user to make and save changes, manage files, and
work with external tools.

If a startup folder has been specified on the Folders tab of the Preferences dialog box, and the

current working directory has not been configured to follow that of the active document, the working
directory will be reset to the startup folder, when the last document is closed.

After a print preview, the cursor is now moved to the top of the last page viewed, unless it is the
initial page.

Release 3.1
Portuguese (Brazilian) user interface.
New option on the Backup tab of the Preferences dialog box to save files automatically, at a
specified interval.
Revert command on the File menu, to revert to the last saved copy of the active document.
The Match Bracket command searches forward for the first closing bracket, if the cursor is not on
a bracket.
Shortcuts are now resolved before opening .LNK files.
When no documents are open, the Paste command now creates a new document to paste into.
The Save command now checks if a file has been modified by another process, and does a Save
As if it has.
New command on the Help menu to connect to our web site.
A DDE "opendos" command for opening files in the DOS code set.

Release 3.0

Multiple personalities: compatibility with Microsoft applications, WordStar, BRIEF, IBM Personal
Editor and TextPad 2 (see later for changes to shortcuts in this release). The chosen personality can be
selected from the new Compatibility tab on the Preferences dialog.

Customizable keystroke shortcuts: new Customize dialog box for customizing the keyboard, user



tools and macros (which were previously on the Preferences dialog box).
Clip Library for inserting frequently used text, such as HTML tags.

International characters, such as € and {, can now be typed using shortcuts compatible with MS
Word, on English keyboards.

Control characters characters can be typed using Ctrl+Num* (* on the numeric keypad), followed
by a letter.

The decimal code for control characters is displayed in a popup tip window, if the mouse pointer
is held over the character. (32-bit edition only.)

New commands on the Edit menu to center and left and right align text.

New View menu, for faster access to some options that are on the Preferences and Properties
dialog boxes.

Word Count command on the Tools menu.

Go to File command (Ctrl+Shift+G) opens a file based on the name in the current selection. This
command is not on a menu.

"@file" processing: opens all the files listed in another file on the command line.

Wild cards and @files on Quick File Open dialog box. It also now appends the default file

extension, unless the name contains a "." or is quoted.
The 32-bit edition now allows up to 64 user macros, and 32 user tools.
New option on the Find dialog box for extending the selection to the matched text.

New options on the Go To dialog box for going to a byte offset in the file, and to the next
bookmark. If the offset is signed, it is treated as a relative offset from the current position. The
parameters of the Go To command are now recorded in keystroke macros.

Support for in-context help using 3rd party Windows help files. These may be configured using
the Tools tab of the Customize dialog box.

Folders for file locations can now all be configured on the new Folders tab on the Preferences
dialog box, including a new one for specifying the startup folder.

The context menu command to View the active HTML file in a web browser now checks if it is in
an active web server, so that any macro content can be expanded by the server.

New option on the General tab of the Preferences dialog box for allowing multiple files in the
command line.

The option, on the Document tab of the Preferences dialog box, for saving word-wrapped files
with hard line breaks is now independent of the word-wrap margin.

The font selection dialog box now has an option to choose the script for international languages.
Locale specific rules are now taken into account when sorting text (32-bit edition only).

The Send command now places the text in-line in the e-mail message, rather than as an
attachment.

Now preserves the preference for paper orientation in the printer.

Macro descriptions are displayed on the status bar, when highlighted on the menu.

Ctrl+Tab now alternates between two windows, if the Ctrl key is released between each use.
Otherwise it cycles through all the windows (like with Ctrl+F6).

The state of the search engine is preserved when running macros.

The "Match whole words" checkbox on find/replace dialog boxes is disabled when the search

string is not a word.
Shift+Find Next button on Find dialog box reverses direction of next find.

The scope on the Replace dialog box is changed to match the selection state.

New regular expression "\&" matches the current selection (i.e. it does not actually search, but
allows you to make replacements based on selected text).

Saving all files before running user tools is now optional.

New tool parameter macros $UNIXPath, and $Clip. Parameter macros are now evaluated for



the actual command, so you can use commands like "$FileDir\$BaseName.exe".

New command line parameters to set default printout orientation, and to force another instance to
start.
The color for drawing page breaks can now be selected.
Sort parameters are now persistent.
The Document Selector now has a context (right click) menu.
In overtype mode, backspace now replaces characters, other than spaces and tabs, with spaces,
rather than deleting them.
It's now possible to specify separate fonts for editing in the ANSI and DOS cose sets.
Notepad style logging is now available, using .LOG as the first line of a file.
New option on the View tab of the Preferences dialog box to minimize the main window when the
last document is closed.
Other new commands:
[l File/Properties
Edit/Copy Line
Edit/Copy Line Append
Edit/Copy Word
Edit/Copy Word Append
Edit/Delete Line
Edit/Delete Word

Edit/Sentence Case

PrintAll (not on menu)
SetRightMargin (not on a menu)
WindowTogglelcon (not on a menu)
WindowToggleZoom (not on a menu)

SelectBegin (not on a menu)

[Z] SelectEnd (not on a menu).

Cursor/LineLeft (not on a menu).
Tools/ToolRerun(not on a menu).
The following shortcuts have changed from TextPad 2:
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Select All Ctrli+A

Center Text Ctrl+E

Right Align Text Ctrl+Shift+E
Redo Ctrl+Y

Redo All Ctrl+Shift+Y
Insert Line After Ctrl+Enter
Insert Line Before Ctrl+Shift+Enter
Increase Indent Ctri+l

Reduce Indent Ctrl+Shift+l
Scroll up/down Ctrl+Up/Down
Paragraph up/down Alt+Up/Down
Sort F9

Compare Ctrl+F9

Word Count Shift+F9
Word Wrap Ctrl+Q, W
Preferences Ctri+Q, P

In addition, some new shortcuts have been defined, and the default shortcuts for user tools and
macros and the cut word commands have been deleted. Backward compatibility can be obtained
by selecting TextPad 2 on the Compatibility tab of the Preferencesdialog box.



What's New: Bug Fixes

Release 3.2.5
Clip Library insertions added an extra new line.
The Tile commands on the Window menu were the wrong way round in the French, Italian,
Portuguese and Spanish user interfaces.
Release 3.2.4
Reverse searches matched arbitrary characters on the last line, after wrapping around the start of
the file.
Delete after backspacing in overtype mode deleted the wrong character.
Clip Library entries longer than 256 characters were split into multiple lines.
Only the first 10 file filters were loaded.

Release 3.2.3

The spelling checker stopped on a word that was too long.

The spelling checker did not trap words beginning with numbers.

The spelling checker prompt for proper nouns is no longer made for German words.

In LaTex documents, words such as F\"ommer were wrongly spell checked as 6mmer.

The RE "\n" did not match the first end of line, if the cursor was already there, or for empty lines.
Registers were not allocated correctly for multiline regular expressions.

The active document is no longer saved when running a tool with the parameters FC_FileName
FC_BaseName.

GPF running macros between two documents.

The cursor column is now maintained when deleting lines.

When a file was already open, clicking its shortcut should not have rewound it.
Could not select all in a document consisting of entirely blank lines.

File change notifications could be missed when TextPad was minimized.

The 16-bit edition added 100 to short form dates > 1999.

Reverse searches for multiple new lines crashed after wrapping around at the start of the
ocument.

Release 3.2.2
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Multiple instances are now detected by a mechanism that is more reliable when the system is
busy.

The Save button is now disabled when the last document is closed.

Relative paths in the Command Results window did not work with hypertext jumps.

Extending selection with Shift+Left click in the left margin did not work in MS mode.

Reverse find failed to match patterns at the start of a line.

The number of selected lines was not updated on the status bar when scroll selecting with the
mouse.

The selection was not updated to show different length spelling corrections.

The "Regular Expression" setting did not operate correctly in the 16-bit edition.

The full pathname was not shown for binary views.

Replace All in a selected column could leave the wrong text selected.

Release 3.2.1

Spell checking crashed when the last line was unterminated, and the last word should have been
nored, because it was all capitals, or contained a number.

Redundant "MDI" entries could appear on the Window menu.
The keyboard layout was not correctly identified on NT 3.51

[ie] [ S



Only the first file matching a wild card was opened when started from command line, and only
one instance was allowed to run.

Under certain circumstances, the prompt to reload externally modified files stopped being given.

Sorting and deleting duplicates, when everything was selected, and word wrap was on could
result in a crash.

' Could not split an unterminated wrapped line.

Replace All did not stop at the end of the current selection, if it was in the middle of a line.
Inserted text could be indented to align with the previous line in the wrong circumstances.
Down arrow ended up in the wrong column after splitting a line with Enter.

Block selection behaved strangely when a new document was opened, and the cursor was
rmally constrained to the text.

Go to column should not have flashed the line.

Couldn't escape the regular expression "\n" with "\n".

If Replace All deleted the line containing the cursor, the selection was incorrect.
Ctrl+Shift+Tab did not cycle through documents in exactly the reverse order of Ctrl+Tab.
Could not right click the context menus for the Selector, macros and Clip Library.

The Selector and Find/Replace dialog boxes could not be used on virtual displays.
Release 3.2
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Block mode should have been cleared when re-enabling word wrapping, after closing all
cuments.

File extension dependent behaviour was not implemented correctly for newly created files.
Focus was lost when replying to multiple "Reload" dialog boxes.

The Window Selector lost focus after selecting an iconized document.

Dropping a file, when in print preview mode, messed up the menu bar.

An INCLUDE environment variable could not have spaces between paths, and included files were
t explicitly searched for in the directory of the parent document.

The number of copies to print was not reset to 1 after each printout.

The limit of 4 macros in unregistered copies has been removed.

Could not record File.New (Ctrl+N) in a macro.

Substituting the new file name in $File, when saving an untitied document before running a user
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tool.

The reformat margin was too small by 1 column when word wrapping was on.

On NT, if a window's title bar was clipped, it became invisible when the workspace was restored.
The 16-bit edition did not free printer device contexts.

The French spelling checker could cause lock ups.

Only the first 255 characters of each line were printed by the Compare command.

The Close All command would close the Command Results window, without prompting, while a

user tool was running.

' Commands on submenus of the Edit menu ignored shortcuts, after being popped up on a read
only document..

The 16-bit edition wrongly used the language set for Windows, to determine the keyboard
language.
Ctrl+Tab did not always cycle through the documents in the correct order.

The Reformat command could corrupt up the last line, if it was unterminated and word wrap mode
was not enabled.

Clip Library inserts did not get indented correctly.
Release 3.1



Incorrect status bar message for Mark All.

Selection of blank line could not be cleared by up/down arrows.

Paragraph selection in word wrap mode should not search forward for a blank line.
No visible paragraph mark at end of new lines.

Undo All after first save did not clear "is modified" condition, when undo stack was emptied at
ch save.

Jump Next missed first instance in Command Results.
Active untitled documents should have been saved before running a tool with $FileName.
The Reformat command worked on the current paragraph, when a line was selected.

@-files on the command line, which did not have a full path name, were given an incorrect full
th, such as c:\@file.

Open All did not work when File Counts Only was selected.

Reformat in macro did not work in files with unterminated last line.

Crash due to bad time stamps on files.

Blank page after duplex printing an even number of pages.

Page fault searching for RE \("\)*\1

Match bracket did not take account of the current selection.

Selection not repainted after void Reformat command.

ANSI & control characters could be inserted in read-only documents using shortcuts.
Goto column did not set preferred cursor column.

Opening a file when in Print Preview mode messed up the user interface.

Find in Files only counted the first instance on each line.

Indent less set the modified flag when no changes were made.

Ctrl+Tab was not recorded in macros.

IE 4 URL's could not be dropped.

An unsuccessful Replace All in Selected text could select an extra line.
Comparisons of files with less than 3 lines always reported differences.

Cursor down on the last row of word wrapped text did not go to the end of the line.
More than one user tool could be run simultaneously, using shortcuts.

Down arrow on the last line, in block mode, incorrectly moved the cursor to column 1.
Dots in path names could confuse the process for generating backup file names.
Release 3.0

The 16-bit edition now checks CTL3DV2.DLL version is >= 2.31, to prevent GPF at startup.

GPF at 0008:EDO08 in 16-bit edition, when moving the mouse over the toolbar, before the program
s obtained focus.

Missing line numbers on printout, when first line is continued from previous page.

Missing word wrap printing for lines that are all spaces up to the right margin.

GPF doing Find in Files for patterns containing "%s" or "%c".

Macros that play to the end of the file, and involve a Find command, could be repeated once too
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Insert mode wasn't restored after running a macro.
Ctri+Left click in the left margin didn't select all in block mode.

Deleting or cutting a selected block of text should have left the cursor at the start, rather than the
end of the selection. Similarly, after pasting a block, the cursor should have been repositioned to the end
of the first line of the block.

"Use on Printer" option on the font dialog box was not persistent.
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GPF using Alt+End when word-wrap is enabled, and the document has fewer lines than can be
displayed in its view.

The command to Replace in All Documents was not recorded.

Sorting when no lines were selected, and the last line was unterminated, did not include the last
line in the sort.

Custom dictionaries now start completely empty.

GPF after indenting a single line file, then turning on word-wrap.

The right margin was sometimes not repainted correctly after selecting in block mode.

When invoked by Explorer's Print command, a new instance of TextPad is always started, to
avoid reentrancy problems.

Ignoring case, when searching for high ANSI characters, had no effect.

Shift+Down arrow on the last line of a file did not select the line, if it was unterminated.

Flat toolbar buttons were not centered vertically.

The keys used for making the choice of colors persistent should have been only in English. This

means that you may have to reconfigure your color scheme, if you were working in one of the other
interface languages.

' The Insert File command failed if the file was being accessed.
The selection was not correctly updated after a replacement that spanned line boundaries.
The "-r'" command line parameter was not forwarded to an already running instance of the
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The initial directory for user tools is now validated before trying to run them.
Until a screen font was explicitly selected, visible spaces were displayed in the wrong characters.
Up and down cursor movement in word-wrapped documents could go to the wrong column.

Deleting the selection by typing a character is now treated as an atomic operation for undo
rposes.

More than one radio button could be selected on the Go To dialog box.

A visible 9 should not have been displayed on the last line of a document.

Incorrect line count when the last line is unterminated.

The right margin was not adjusted when line numbers were turned on in an open document.
Consecutive "™ or '+' characters should not have been allowed in regular expressions.

The Delete Line command only deleted the contents of a line in Block Selection mode.

The Find Previous command did not work in a macro.

It was not possible to print selected text starting after line 32767.

The second copy started on the wrong page when doing duplex printing of an odd number of
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Progress indicator not always deleted when saving to a full disk.



What's New: Enhancements

Release 2.3
Tips of the day introduce you to some of the things you never knew TextPad could do.
The MS IntelliMouse wheel can now be used for scrolling.
The Save As dialog box now has an option to save selected text only.

Release 2.21

New option in View preferences to select the button bar style toolbar (32-bit edition only).
The 32-bit edition now uses the minimize setting for user tools to minimize the Command Output
window. This can be used to speed up tools that generate a lot of output.
Release 2.2
French user interface (not on-line help) is now available. This can be selected on the Language
tab of the Preferences dialog box.
Option to enable line numbering on the View tab of the Preferences dialog box.
File open/save progress indicator on the status bar.
A command has been added to the context (right click) menu for HTML documents, to view them
in the default browser.
Internet Explorer style toolbar for 32-bit edition.

Ctrl+Down Arrow moves to the start of the next paragraph, and Ctrl+Up Arrow to the start of the
previous paragraph. Holding Shift down at the same time extends the selection. Note that to provide
compatibility with Microsoft applications, the previous use of these keystrokes to scroll up and down one
line has been replaced with Alt+Down Arrow and Alt+Up Arrow respectively. Sorry if this inconveniences
you.
Triple left click now selects the whole line (or paragraph in wrap mode).
Bold and italic fonts for printing headers and footers, and a new macro (&P) to print the total
number of pages.

Support for color printers, using the selected color scheme. This can be enabled using the Print
Setup command on the File menu.

The dialog box to configure printing has been added as a tab on the Preferences dialog box.
The command line, or drag and drop file is always brought to the top of any workspace files.

New tool parameter macros: $UNIXFile returns the full file name, and $UNIXDir the full directory
of the active document, substituting a '/' for each '\'.

There is now an option on the Sort dialog boxes to delete duplicate lines.
There is now an option in Spelling preferences to ignore words containing underscores.
The 16-bit edition has been built using the "large" compiler model, so it can open more windows,
and handle bigger macros.
Release 2.1
German user interface (not on-line help) is now available. This can be selected on the Language
tab of the Preferences dialog box.
Faster memory management in 32-bit edition.
The destination of the Go To command can now be a column or page, as well as a line.
Views can now be split vertically instead of horizontally. This is configured on the View tab of the

Preferences dialog box.

Synchronized scrolling can be temporarily disabled by holding the Ctrl key while using the scroll
bar.

All lines will be sorted if none are selected.
When text is selected, cursor left goes to the start of the selection and cursor right to the end.
The spelling checker ignores LaTex commands in documents with the .TEX extension.



New tool parameter macros: $FilePath returns the directory of the active document, stripped of
the drive letter; and $DOSFile returns the full file name substituting DOS aliases for long name
components of the path.

The configuration setting for externally modified files has been moved from the General to the File
tab of the Preferences dialog box. It has a new option to disable checks for modified files.

Command line parameter -r opens any files in the command line as read only.

There is now an option to create a new document on startup, on the General tab of the
Preferences dialog box.

Release 2.0

Up to 16 keystroke macros can be created and assigned to a menu.
A spelling checker with dictionaries in 10 languages.

Sorting by the selected column, or up to 3 specified keys.
Configurable color scheme.

Cut, Copy and Paste are back on the top level of the Edit menu. Some menu mnemonics have
d to be changed in consequence.

Visible spaces in word-wrap mode, and a visible end of line character.

A Load All command on the context menu for the Search Results window.

Ansi/Dos conversion of the active document, and editing in the DOS code set.
Ctrl+Shift+Del deletes to the end of the current line.

Move by word follows programmer's editor semantics for program source files.

The Explorer Send To command now works for multiple files, but this has changed the

L) fo o o) [ [ [ o] e i) )

requirement for quoting file names in command line parameters.

Toolbar buttons for spell checking, keystroke macros, and displaying visible spaces.
Extra shortcuts using toolbar buttons in conjunction with the Shift and Ctrl keys.
Modified files are indicated with an asterisk.

The status bar shows the number of characters or lines selected.

Synchronized scrolling of all views.

Configurable list of extensions recognized as binary files.

The settings for hard line breaks can be set on a per document basis.

New options to:

Strip trailing spaces.

Not treat Ctrl+Z as marking the end of file.

Automatically reload externally modified files.

Disable drag and drop editing in the 32-bit edition.

Store backup files in a specified directory, or with alternative extensions.

Suppress the startup splash message.

Set the default format for new files to PC, UNIX or MAC.

Convert new tabs to spaces, while leaving existing ones alone.

Not clear the undo buffer when files are saved.

Conventional file reads and writes can now optionally be used by the 32-bit edition for accessing
remote files. This should provide better compatibility with Lantastic, PC-NFS and other network systems
that don't fully support memory mapping.

Files that are opened for writing by another process can now be loaded into the editor.

The 32-bit edition now detects changes to file modification dates and read-only status, without
needing to lose and regain active status.

A Replace Next button on the Replace dialog box to replace then find the next occurrence.
Numeric variable in replacement expressions for generating or updating sequence numbers.
Hex character codes (\xdd), newlines (\n), and page breaks (\f) in find/replace regular

expressions.



If current selection extends over one line, the scope is initialised to Selection on the Replace

dialog box.

The current selection can be substituted as a parameter to a user tool using tool macro "$Sel".
The Statistics tab now shows a file's format and character set.

Goto Line can now extend the selection in block mode.

Alt+Home/End moves the cursor to the start of the first/last visible line.

The page break character is now recognized at the end of lines, as well as at the start.

Paste and drop now replace characters in overtype mode, unless the paste or drop is onto
selected text.

After a column of text has been inserted, the insert position is moved to the end of the first, rather
than last line.

Switching to the Search or Command Output window does not change the working directory.
New DDE commands to write to documents and save them.



What's New: Bug Fixes

Release 2.3
The progress indicator wasn't removed from the status bar if the open file command was
cancelled.
The move forward by word command bypassed the end of a line.
Recently used files on the File menu were being marked read-only according to the attributes of
the file, rather than the setting on the Open File dialog box.
If relative paths were used in the command line, the second and subsequent files could not be
found.
Splitting word wrapped lines, which were indented off the right side of the view, could cause an
endless loop.
A filename without an extension could be opened as binary, if a directory component in its path
cantained a binary extension.
Scratch macros containing ordinary typing, and created prior to release 2.2, resulted in an "Invalid
Workspace" error when the workspace was reloaded.
The screen area before indented, word-wrapped text was not always repainted correctly.
The cursor was incorrectly positioned after saving word-wrapped text with hard line breaks.
Backspacing on a new, auto-indented line should have moved the cursor left by the indent size,
rather than the tab size.
On NT 3.51, any attempt to configure user tools with spaces in their path names failed, because
the path was being corrupted.

Release 2.21
The flat-style toolbar background retained ghost images at the old position when it was moved.
Spelling checker now recognizes multiple word replacements.
GPF using Crl+(Numeric Pad Digit), for non-existent macros.

Release 2.2
"Out of memory" error when saving files from the final build of NT 4.0 to disks on Windows 95
systems.
The foreground and background colors were the wrong way around for the left margin. If you

have customized these settings, please reverse them.
Licensing on the Hebrew edition of Windows 3.1x with Win32s.

Incorrect selection placement after changing the case of a single character.
The File Close commands should have been disabled when a macro is being recorded.
In single instance mode, the 32-bit edition was not activated when an attempt was made to start

another instance..
' File auto-save should not have been done for the Explorer tool.
Missing vertical scroll bar in binary views with vertical splitter.
The selector should have been hidden during Print Preview.
Ctrl+Tab and Ctrl+Shift+tab were not recorded in macros.
High ANSI characters could not be recorded in macros.
Cancelling a macro that was played from the menu stopped other macros being played.
The 16-bit edition issued an error message when loading macros.
The DOS (OEM) code set was not used when copying bookmarked lines.
The 16-bit German user interface did not have a print preview mouse pointer.
The Split Wrapped Lines command should not have cleared the selection when it finished.
The regular expression '$' did not match UNIX end of lines in the Find in Files command.
The spelling checker no longer treats double hyphens as part of a hyphenated word.



Errant user tools, or closing the Command Output window while a tool was running, could leave
instances of PLUMB.EXE running (32-bit only).

A horizontal scroll bar was not displayed in hex views, unless it was turned on on the Properties
dialog box.

The default play mode for macros did not work.

The Find Previous command did not work if the cursor was at the start of the document.

The 32-bit edition did not become the foreground window when a file was dropped on it.

Release 2.1

The ordering of files in the Search Results window now matches those in the Document Selector.
16-bit edition could crash doing Find in Files on files containing Ctrl+Z.

File filters > 255 bytes stopped registry saves.

Filename was not quoted when setting up Associations for printing.

When loading from a file, the spell checker should not have prompted for proper nouns and
breviations.

The status bar message was not cleared when all documents were closed.

Modified indicator (*) on Document Selector was only updated when a document was active.
Running some DOS tools with invalid file headers could cause the 32-bit edition to crash.
Insert Line Before an indented line, followed by backspace, deleted too much text.

Incorrect cursor position after splitting word wrapped lines.

The cursor seemed to disappear after indenting a selected block.

If the Search or Command Output windows were saved using the Save button on the toolbar,
ey continued to be used as output windows.
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Files containing bracketed numbers in their paths, such as c:\data(1)\file.ext, could not be opened
by double clicking them in Explorer.

Pasting lines longer than 4K resulted in the split lines being inserted in reverse order.

Cancelling a "play once" macro with Ctrl+R disabled the Playback command on the Macro menu.
Failure to find a search pattern didn't cancel macro playback.

A macro that deleted, but didn't move the cursor, wasn't allowed to run to end of file.

Move cursor by word didn't change the preferred cursor position.

The range of the selection was not updated on the status bar, if it was extended with Shift+Left
click.

File filter customizations could be lost by using the command line to pass a filename to an already
running instance, rather than using DDE, when double clicking an associated file.

Multi-file open only honoured the OEM codeset setting for the first file.
User dictionaries for the spelling checker didn't work on NT 3.51.



What's New: Enhancements in Earlier Releases
Release 1.32a:
Multiple files can now be supplied as command line parameters, provided each name is quoted

(e.g. txtpad32.exe "File1" "File2"). This isto avoid confusion with file names containingspaces. If any of
the files don't exist, TextPad asks if you want to create them.

The commands to insert the date and time now have their own popup menu. This can be
popped up using Ctrl+F 10, or Ctrl+Right click.

The Block Fill command can now fill with a sequence of numbers.

File comparison can now optionally ignore differences due to case of letters, and numbers of
spaces and tabs.

The match brackets command now matches < with >.

If the current selection extends over one line, the scope is initialised to Selection on the Print
dialog box.

When a window is iconised, any file path is stripped from its title.

The combobox has been changed to a listbox on the Filters tabs of the Preferences dialog box.

Release 1.31:

User settable default for the ANSI or DOS character set.

"Options" on the Configure menu has been renamed "Preferences".

Changes to configuration settings are saved immediately.

Associating file extensions with TextPad must now be done from the Associations tab of the
Preferences dialog box. The setup program no longer has that as an option.

Dates and times are displayed according to the Windows regional setting (32-bit only).
Uninstallation now follows the Windows 95 guidelines.

Paths can be omitted from the file names displayed in the Document Selector. This is set from
the General tab of the Preferences dialog box.

The startup "splash" message can be disabled using the command line parameter "-q".

A different cursor is used in overtype mode.

When auto-indent mode is enabled, a "}" is always unindented on an empty line, regardless of
whether or not the cursor is constrained to the text.

The Find Next button on the Replace dialog box stops searching at the end of file, rather than
wrapping around to the beginning, as happens with the Find dialog box.

When run on NT with the 2nd new shell preview, TextPad now uses the new File Open dialog
box.
The environment variable COMSPEC is now used to determine which command interpreter to run
for user tools.

Release 1.30:
The state of the workspace can be saved between editing sessions, includingopen documents,
window positions, bookmarks & fonts.
The Command and Search windows can now be edited, by turning off the read-only property.

(Double-click Read on the status bar.)

Lines with bookmarks can be cut, copied or deleted. The Edit menu has been slightly
rearranged to accomodate the new commands.

A selected block can be filled with a character or string.

The left margin of word-wrapped paragraphs is now aligned with the first line of the paragraph,
when the Maintain Indentation property is set on the Document tab of the Properties dialog box.

Paragraphs can be reformatted when not in word-wrap mode.
The Close All command has been moved from the Window to the File menu.
The Stay on Top command has been added to the System menu.



A word-wrap button has been added to the toolbar.

A file can be printed without bringing up the Print dialog box, by clicking the print button on the
toolbar. The Print command on the File menu still displays the dialog box.

Dragging and dropping files on to a printer icon is now supported on Windows 95.

Text can be converted between the ANSI and DOS (OEM) character sets when opening and
saving files.

The cursor can be set to a flashing block, or a vertical bar from the View tab of the Preferences
dialog box.
If a document is opened read-only because its file has the read-only attribute set, it is
automatically made editable when the state of the file changes. (Useful for source control systems.)
To avoid problems with file names containing spaces, TextPad now only allows a single file name
as a command line parameter.
The pre-release version of the new shell for NT is supported.

Release 1.29:

On Windows 95 and NT, the 32-bit edition uses the Windows Registry, instead of TEXTPAD.INI to
save its settings.

New commands to insert the current date and time were added to the Edit menu.
The installation program automatically registers TextPad's DDE commands.



What's New: Bug Fixes in Earlier Releases
Release 1.32a:

Crash when saving word-wrapped files with hard line breaks.
Command names could not have spaces in user tools.
Parameters to user tools could not be quoted.
Release 1.32:
When the 32-bit edition is restricted to running as a single instance, file names in command line
parameters are now made absolute before passing them over to the previous instance.
Warnings due to unterminated last line are no longer given.
The default tab setting on the Preferences dialog box was wrongly initialised to that of the active
document.
The document width was not recalculated when the tab size was changed.
Release 1.31:
On Windows 95, file extensions are now always displayed, regardless of the setting in Explorer.
Scroll bars now operate correctly on NT 3.5.
When switching from word-wrap mode, horizontal scroll bars are now displayed if set on in View
Preferences.
Double clicking in the margin in word-wrap mode now selects the line as displayed, instead of the
paragraph.
Splitting lines longer than 4095 characters sometimes inserted garbage into a file.
The 32-bit edition could not open some files with particular accented characters in their names.
Starting with parameter "-s" cleared the "Save Workspace" flag on exit.
Command line parameters are no longer case sensitive.
CreateProcess error -1 in Run command on NT with the new shell preview.



Year 2000 Compliance

TextPad allows users to insert dates in text files, and in the headers and footers of printouts, but it does
not manipulate them in any way, nor store them in a binary form. Dates are displayed using the long
and short formats that are configured with the Regional Settings applet on Control Panel.

On Windows 95, 98 and NT, the date and time are obtained by calling one or more of the following
standard Win32 routines:

GetSystemTime

GetFileTime

FileTimeToLocalFileTime

FileTimeToSystemTime

GetTimeFormat
On Windows 3.1, the date and time are obtained by calling one or more of the following standard C
runtime library routines:

time
localtime
_dos_getftime

Hence, as long as the version of MS Windows that TextPad is running on can cope with dates beyond
the end of the century, TextPad will not cause any problems.



File Open dialog box

The following options allow you to specify which file to open:
File Name

Type or select the filename you want to open. This box lists files with the extension you select in the
List Files of Type box.

List Files of Type
Select the type of file you want to open:
Drives
Select the drive containing the file that you want to open.
Directories
Select the directory containing the file that you want to open.
Network...
Choose this button to connect to a network location, assigning it a new drive letter.



File Save As dialog box

The following options allow you to specify the name and location of the file you're about to save:

File Name
Type a new filename to save a document with a different name. A filename can contain up to eight
characters and an extension of up to three characters.

Drives
Select the drive in which you want to store the document.

Directories
Select the directory in which you want to store the document.
Network...
Choose this button to connect to a network location, assigning it a new drive letter.



Title Bar

The title bar is located along the top of a window. It contains the name of the application and
document.

To move the window, drag the title bar. Note: You can also move dialog boxes by dragging their title
bars.

A title bar may contain the following elements:

Application Control-menu button
Document Control-menu button
Maximize button

Minimize button

Name of the application

Name of the document

Restore button



Scroll bars

Displayed at the right and bottom edges of the document window. The scroll boxes inside the scroll
bars indicate your vertical and horizontal location in the document. You can use the mouse to scroll to
other parts of the document.



Size command (System menu)

Use this command to display a four-headed arrow so you can size the active window with the arrow
keys.

&

After the pointer changes to the four-headed arrow:

1. Press one of the DIRECTION keys (left, right, up, or down arrow key) to move the pointer to the
border you want to move.

2. Press a DIRECTION key to move the border.
3. Press ENTER when the window is the size you want.

Note: This command is unavailable if you maximize the window.

Shortcut
Mouse: Drag the size bars at the corners or edges of the window.



Move command (Control menu)

Use this command to display a four-headed arrow so you can move the active window or dialog box with
the arrow keys.

Note: This command is unavailable if you maximize the window.

Shortcut
Keys: Ctrl+F7



Minimize command (application Control menu)

Use this command to reduce the window to an icon.

Shortcut
Mouse: Click the minimize icon =] on the title bar.
Keys: ALT+F9



Maximize command (System menu)

Use this command to enlarge the active window to fill the available space.

Shortcut .
Mouse: Click the maximize icon =1 on the title bar; or double-click the title bar.
Keys: Ctrl+F10 enlarges a document window.



Next Window command (document Control menu)

Use this command to switch to the next open document window. This corresponds to the order in
which you opened the windows.

Shortcut
Keys: Ctrl+F6



Previous Window command (document Control menu)

Use this command to switch to the previous open document window. This corresponds to the order in
which you opened the windows.

Shortcut
Keys: SHIFT+Ctrl+F6



Close command (Control menus)

Use this command to close the active window or dialog box.
Double-clicking a Control-menu box is the same as choosing the Close command.

Shortcuts
Keys: Ctrl+F4 closes a document window
ALT+F4 closes the main window or a dialog box



Restore command (Control menu)

Use this command to return the active window to its size and position before you chose the Maximize or
Minimize command.



Switch to command (application Control menu)

Use this command to display a list of all open applications. Use this "Task List" to switch to or close an
application on the list.

Shortcut
Keys: CtrI+ESC

Dialog Box Options
When you choose the Switch To command, you will be presented with a dialog box with the following
options:
Task List
Select the application you want to switch to or close.
Switch To
Makes the selected application active.
End Task
Closes the selected application.
Cancel
Closes the Task List box.
Cascade
Arranges open applications so they overlap and you can see each title bar. This option does not
affect applications reduced to icons.
Tile
Arranges open applications into windows that do not overlap. This option does not affect
applications reduced to icons.
Arrange Icons
Arranges the icons of all minimized applications across the bottom of the screen.



No Help Available

No help is available for this area of the window.



No Help Available

No help is available for this message box.



Print dialog box

The following options allow you to specify how the document should be printed:

Printer
This is the active printer and printer connection. Choose the Setup option to change the printer and
printer connection.

Setup
Displays a Print Setup dialog box, so you can select a printer and printer connection.

Print Range
Specify the pages you want to print:
All Prints the entire document.
Selection Prints the currently selected text.
Pages Prints the range of pages you specify in the From and To boxes.

The default action is to print all pages in the specified range, but you can choose to print just the odd
or even pages, if you want to print on both sides of the paper.

Copies
Specify the number of copies you want to print for the above page range.

Collate Copies
Prints copies in page number order, instead of separated multiple copies of each page.

Print Quality
Select the quality of the printing. Generally, lower quality printing takes less time to produce.



Print Progress Dialog

The Printing dialog box is shown during the time that <<YourApp>> is sending output to the printer. The
page number indicates the progress of the printing.

To abort printing, choose Cancel.



Print Preview toolbar

The print preview toolbar offers you the following options:
Print

Bring up the print dialog box, to start a print job.
Next Page

Preview the next printed page.

Prev Page

Preview the previous printed page.
One Page / Two Page

Preview one or two printed pages at a time.
Zoom In

Take a closer look at the printed page.

Zoom Out
Take a larger look at the printed page.

Close
Return from print preview to the editing window.



Print Setup dialog box

The following options allow you to select the destination printer and its connection.

Printer
Select the printer you want to use. Choose the Default Printer; or choose the Specific Printer option
and select one of the current installed printers shown in the box. You install printers and configure
ports using the Windows Control Panel.

Orientation
Choose Portrait or Landscape.

Paper Size
Select the size of paper that the document is to be printed on.

Paper Source
Some printers offer multiple trays for different paper sources. Specify the tray here.

Options
Displays a dialog box where you can make additional choices about printing, specific to the type of
printer you have selected.

Network...
Choose this button to connect to a network location, assigning it a new drive letter.






