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W elcome to Wright Design - a unique

digital graphic design program

produced by Wright Technologies.

This program brings together image editing,

photo retouching, color painting, page

layout and text all as separate objects that

can be edited at any time. 

Wright Design is the Ultimate Designer’s

Solution, whether you are a graphic designer

or illustrator creating original artwork, a

photographer that needs to retouch pictures

or a printer or service bureau that has the

need to output color proofs and color sepa-

rations. This software is also ideal to create

pictures for all facets of multimedia.

Wright Design's lightning-fast speed and

versatility lies in a new file format (patent-

pending) developed by Wright called the

DCM Picture file.

Wright Design Version 1.0 and Version 2.0

use the same DCM Picture file format. In

Version 1.0 the file extension is .spl and in

Version 2.0 the file extension is .dcm.

Version 1.0 .spl files are compatible with

Version 2.0.   

The DCM Picture file is automatically gener-

ated as pictures are imported or placed. The

conversion time is negligible (virtually the

same time it takes to read the original

picture).

Before Wright Design, you needed to use a

number of different applications. This does

not allow the creative possibilities that

Wright Design provides.

Using several applications means you

constantly swap between them and have to

save in possibly several different, even

potentially incompatible, file formats. This

has many disadvantages:

● It is time-consuming.

● It is costly as you have to maintain

current versions of each application.

● There may be loss of editability.

● It is an unwieldy process which disrupts

concentration and hinders the flow of

creativity.

For example, you might create an exciting

imaging effect in one application, such as a

picture cutout with a soft shadow and color

corrections, export the picture as an EPS or

TIFF, go into a layout application, import

and place the EPS/TIFF.

Not only have you lost time by switching

between different application, you have also

lost all editability of the placed EPS/TIFF

within the layout application. To make a

change, you have to go back to the imaging

application, do the changes and re-export

the graphic, and then update the picture in

the layout application.

3

Chapter 1 - Introduction



Now with Wright Design you can ...
For the first time, Wright Design brings

together what used to be the exclusive

worlds of vectors and bitmaps.

In Wright Design you can create a picture

cutout as either a vector object (giving a

high resolution clipping path edge) or as an

anti-aliased bitmap object (which can be

feathered for a soft edge effect), apply an

automatic shadow and perform selective

color corrections. 

Truly object-oriented graphics
Wright Design is a truly object based applica-

tion. Each Wright Design object is self con-

tained and independent of any other. This

includes vector or raster picture data or text.

Objects are editable at any time which means

that multiple versions of a design can be

saved (occupying very little disk space),

recalled and edited easily.

All objects can be moved, scaled, rotated,

sheared, mirrored and perspective-trans-

formed at any stage of design (text objects

cannot be perspectively transformed). Even

an airbrush stroke can be moved, scaled,

rotated, recolored and have its relative

priority changed at any time.

Paint styles
Most other applications only allow an object

to have a single paint style, such as a tint

color, or a picture, or a gradient. Wright

Design extends this notion to provide un-

paralleled levels of flexibility. In Wright

Design, each object can have several paint

styles. These can be thought of as ‘layers’

within an object. Each layer can be edited at

any stage. 

For example, you can apply a ‘filter’ paint

style to a picture within an object, then a

second filter. If the second filter only is

chosen for the final design, all you need to

do is delete the first filter. As well, you can

select channels and variables within each

paint style. You can select color from CMYK,

RGB, HSB, PANTONE®, Grayscale or 3

channel Grayscale models.

To take another example, you may have an

object with a ‘picture’ paint style. However,

the picture does not have enough contrast.

Rather than spending valuable time color

correcting the original picture, you simply

add a color curve layer, on top of the first

picture layer and the underlying picture is

instantly color corrected.

Each object layer has its own opacity control,

so the photo compositional possibilities are

enormous.

Compatibility
Wright Design will run on a variety of

powerful desktop platforms. It integrates

with existing programs by importing and

exporting all popular file formats, such as

TIFF and EPS. It can also interface with

Macintosh AppleTalk networks (via Windows

NT server)

You can export an EPS file with a clipping

path from Wright Design that is fully editable

in Photoshop.

Multi-tasking
Wright Design offers the unprecedented (for

a graphic desktop application) ability to
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multi-task. For example, all import/export

operations (including printing) are

performed as background processes. This

means that you do not need to waste time

waiting for your job to print, or file to

export. Just carry on working on another

document.

About this manual
The Wright  Des ign User  Guide provides

detailed step-by-step information on how to

use the tools and commands. It is designed

for you to be able to refer to it easily in the

course of your work.

We assume, however, that you are familiar

with the Windows environment and termi-

nology. We also assume you are familiar with

at least some design concepts, although we

attempt to explain the concepts relating to

the procedures we are describing.

Before using this manual, you need to install

the program by following the instructions

given in the Wright Design Installation
Guide booklet.

Learning Wright Design
Wright Design 2.0 includes the following

printed and online documentation.

The Wright Design Installation Guide
contains system requirements, installation

instructions and registration instructions.

The Wright Design User Guide contains

detailed information on all the features and a

step-by-step procedure for all the tools.

The Wright Design Online Help system

contains an optimized version of the infor-

mation supplied in the Wright Design User

Guide.  

The Wright Design Tutorial Guide is found

on the CD. The documentation is supplied as

a PDF file and the pictures are supplied as

JPEGS. It provides you with three step-by-

step projects to quickly learn how to use

Wright Design.

Wright Technologies Online - for more infor-

mation on Wright Technologies products

and services you can visit our website:

Australia: www.wright.com.au

North America: www.wrightna.com

UK: www.wrighec.co.uk

Technical support
If you have any problems installing or

running the Wright Design CD, please try

contacting your supplier first. If your

supplier cannot help, contact 

Wright Technologies:

Australia - (Head Office) 

Fax:  (61-2) 9519 - 6171

E-mail: design-support@wright.com.au

North America - Canada

Fax:  (416) 497 4568

E-mail: support@wrightna.com

Toll free: (888) 261 2261

America

Toll free: (1 800) 259 5580
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In A Nutshell
Wright Design combines page layout, illustra-

tion and picture editing and manipulation

into a single, integrated application.

Wright Design works with the concept of a

document. A document may be empty, or

contain one or more objects. The objects

may be positioned anywhere within the

document or even across or outside the

document.

There are four different types of
objects:
Three main object types, created using tools

and menu commands:

● Vector

● Bitmap

● Text

A secondary object type, created when

placed into a page (but not into an existing

object):

● Picture.

Vector objects
These objects are mathematically defined.

Each is made up of a list of points that define

the object’s outline. Internally, the points are

stored as Bezier segments. Because these

objects are mathematically defined, they

have no inherent resolution. This means that

they may be used within a page and output

at any resolution without loss of quality.

For instance, the same object may be printed

on an Imagesetter at 2400 dpi or converted

into a TIFF file at 300 dpi. The quality is

preserved because the object is only ever

rasterized when output is required. (In the

case of Imagesetters, the object is rasterized

at the Imagesetter’s RIP resolution).

The points defining the Vector object’s

outline may be edited through the Bezier

tool. Nodes may be moved, deleted or

converted to different types. Vector objects

may optionally have a stroke. A stroke

follows the object’s outline and has a certain

thickness. The stroke may be on top or

below the main Vector object. 

In fact, a Vector object may only be

composed of a stroke, with no fill, thus

becoming a line. Strokes within Vector

objects may be transformed with the object

or left untransformed. Vector objects may be

converted to Bitmap objects at any time.

Bitmap objects
Unlike Vector objects, Bitmap objects do

have an associated resolution. When a

Bitmap object is created a Grayscale mask is

generated (at the current bitmap resolution)

and is stored with your document.          

Why use Bitmap objects? Because Bitmap

objects are, just that, bitmaps, you can do

things not possible with Vectors. It is

possible to invert, grow, shrink and outline

Bitmap objects and to airbrush in or out

areas. In fact, when you airbrush, you’re

really creating a new Bitmap object. Pixel

cloning, a specialised form of airbrushing, is

also carried out through Bitmap objects if

you are using object based cloning.
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In general, it is preferable to work with

vector objects as this will keep file sizes and

memory usage down and make redraws

faster.

Picture objects
Picture objects are closely related to Bitmap

objects. Whenever you place a picture into

the page (not into an existing object), the

new object becomes a Picture object.

A Picture object behaves like a Bitmap

object, in that you can airbrush into it, do

pixel cloning or apply a color mask.

However, a Picture object is really just

‘waiting’ to become either a Vector object or

a Bitmap object.

Rarely do you just include the whole picture

into the page. Usually the picture is cropped,

or cut out from the background or masked in

some way. When you do any of those opera-

tions on a Picture object you are telling it

what type to become.

For instance, if you crop a Picture object

with a Vector tool,  the cropped object

becomes a Vector object.

If you crop a Picture with a Bitmap tool,  the

cropped object becomes a Bitmap object.

It is not possible to feather, grow, shrink,

outline or shadow a Picture object. 

Pictures are always manipulated at their orig-

inal scanned-in resolution. There are no

proxies or view files, we are always working

with the full picture content. Pictures may be

CMYK, RGB, Grayscale or HIFI.

Text objects
Text objects are created through the Text

tool. Any font resident on your system may

be used in any combination, size, style or

color. As with Vector objects, Text objects

are resolution independent. They are more

closely related to Vector objects than to any

other type. In fact, you can convert Text

objects into Vector objects and Bitmap

objects. 

You can create a shadow directly from a text

object. The text remains as a text object and

the shadow is automatically converted to a

bitmap with the feathering applied to it. Text

objects may be used to create special effects.

Glow effects may be achieved by converting

the text object to a bitmap object and feath-

ering the edges.

Text boxes can be automatically or manually

linked to each other. Text that has been

applied to a text box can be converted to a

text container therefore allowing you to type

within the original text.

Working with objects
Any combination of the above objects may be

used when creating a document. Each object

is independent of any other. It may be

deleted, moved, scaled, rotated, sheared or,

in most cases, perspectively transformed at

any time.

More than one object may be selected at a

time, so that the same operation can be

applied to all of them at once. Multiple

selected objects may also be grouped and

subsequently worked on as if they were a

single object.
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Each object or a group may be locked into

position, to prevent accidental movement.

Objects may also be hidden from view to

reduce visual clutter while working on a

page.

Objects may be positioned accurately by

keying their dimensions and positions or by

using rulers and guides and snap-to-guide

tools. The Align tool also provides a powerful

method of aligning objects to other objects.

Naturally, object priorities may be altered at

any time.

Each object is listed in the Object List

palette. The objects are listed in the order of

their priorities and may be moved to a

higher or lower priority by dragging the list

entry up or down the object list. 

Each entry in the Object List has a thumbnail

preview. The thumbnails may be normal size

or large. When an object is created, it is auto-

matically given a name, however, you can

change this name to whatever you like from

the Object List. You may also select, delete,

hide, copy or edit objects from the Object

List.

When a document is saved and then recalled,

objects remain editable. A page may also be

‘flattened’ into a picture (to be reused

within Wright Design or exported to other

applications). The page could also be

exported as a EPS document or may be

printed directly to a PostScript Imagesetter

or a Windows printer.

Paint styles
So far we have  covered the different types of

objects in Wright Design and some of the

common operations that may be performed

on them. However, we have not yet

discussed how an object is rendered (ie, how

it actually looks).

We use the Paint Style palette to control how

an object looks. With the Paint Style palette

you specify a rendering (or paint) style for

the selected object.

Recall that an object has a main ‘Fill’ color,

or, if it is stroked, a ‘Stroke’ color. The Paint

Style palette has identically marked areas at

its top. You may select either Fill or Stroke

by clicking on the appropriate button. We

are now ready to select a paint style. 

There are ten paint styles to choose from.

These are represented as tabs running hori-

zontally across the palette. When you click

on a tab, you are selecting a paint style (for

either Fill or Stroke, depending on selec-

tion). From left to right, the paint styles are

called: Tint, Tint Adjust, Color Curve,

Picture, Filter, Gradient, Color Mask,

Selective Color Correction,

Brightness/Contrast and Hue/Saturation.

● Tint paint style renders an object with

constant color. The color may be specified in

any of the following color models: CMYK,

RGB, HSB, Grayscale, PANTONE® or Alpha.

● Tint Adjust paint style is similar to Tint,

except that it is possible to combine the

specified color with the background using a

variety of operators, such add, subtract,

invert, increase, etc. The color may be speci-
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fied in any of the following color models:

CMYK, RGB, HSB, Grayscale or PANTONE®.

● Color Curve paint style modifies the

picture by remapping it through the use of

‘curves’. The curves may be manipulated in

any way. The color curve may be specified in

any of the following color models: CMYK,

RGB, HSB, Grayscale or Alpha.

● Picture paint style renders an object with

a selected picture. The picture may be speci-

fied in any of the following color models:

CMYK, RGB, Grayscale, 3 channel Grayscale

or Alpha.

● Filter paint style modifies the object’s

background with the selected filter. These

include Sharpen, Blur, Emboss, etc.

● Gradient paint style renders the object

with a gradient. The default gradient is white

to black, but this may be modified by editing

the colors and by adding more color points.

The many different types of gradients

include Linear, Elliptical, Midpoint,

Rectangular, Sunrise, etc. The size and angle

of gradients may further be controlled with

the Gradient tool in the Tool palette. The

gradient may be specified in any of the

following color models: CMYK, RGB, HSB,

Grayscale, PANTONE® or Alpha.

● Color Mask paint style, used together

with the Color Mask Tool from the Tool

palette, is used with Picture or Bitmap

objects to mask certain areas based on image

color content. Typical uses include masking

difficult subjects like hair or fur, or a bicycle

wheel.

● Selective Color Correction paint style is

used to modify or color correct any color in

the picture. It’s called Selective Color

Correction because you can selectively

control which colors you want to affect. For

example, you can make the red in a picture

redder by taking out the cyan in the reds

without affecting other colors. Alternatively

you can change colors completely, such as

reds into blues.

● Brightness/Contrast paint style makes

simple adjustments to the tonal range. This

paint style adjusts the highlights, midtones

and shadows at once.

● Hue/Saturation paint style adjusts the

hue, saturation, and lightness of individual

color components. You can also use the

colorize option. 

Object Layers
So far we have discussed object paint styles.

We have assumed that each object has either

a Fill or Stroke paint style, or both. But

things are far more interesting than that!

Each object may have more that one Fill

paint style and/or more than one Stroke

paint style.

These multiple paint styles are called layers.

Therefore, each object may have one or

more layers. The layers are fully contained

within the object. When the object is moved,

or scaled, etc, so are all its layers (ie, paint

styles).

But what does it mean to have more than

one paint style? Paint styles are stacked on

top of one another, forming layers. The first
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layer corresponds to the first icon in the

Paint Style palette next to either the Fill or

the Stroke buttons.

If there is another layer, it will be indicated

by another icon following the first. Each

layer exactly spans the entire object area.

Each layer affects the one immediately below

it in your page, or to the left, as indicated in

the Paint Style palette.

Multiple layers come in very handy when you

need to do something like the following:

● color correct a cyan cast in a picture

● add a touch of USM

● increase the magenta content in yellows.

First you place the picture into the page, the

Fill paint style (or layer 1) is Picture. Add

another layer on top of the first, of type

Color Curve. Manipulate the cyan channel

curve to remove the cyan cast. Add another

layer, this time a Filter and select Sharpen

USM. Finally add the last layer, Selective

Color to increase magenta content in

yellows.

We now have a Picture object with four paint

styles or layers. The first layer is the Picture

itself. The second layer is the color curve

(which operates on the Picture). The third

layer is the USM Filter (which operates on

the result of the color curve). The final

fourth layer is Selective Color (which oper-

ates on the result of the Filter layer).

We have now achieved the desired effect in

very short order, but even better than that,

all the layers are still editable. Any layer

within any object may be modified at any

time. We could go back to the Filter layer

and change the degree of sharpening, or to

the color curve and readjust the amount of

cyan being taken out. You can change your

mind, even after the document has been

saved.

Also, within each object you can have more

than one Alpha channel. Several of the paint

styles can operate on the Alpha channel. This

is controlled by selecting Alpha as the paint

style (layers) color model.

Think of an Alpha channel as a way of

controlling an object’s opacity. A 100% (solid

black) value means no transparency.

Anything less than 100% imparts a degree of

transparency. A value of 0% means the object

is totally transparent and therefore invisible.
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The Wright Design screen

I n Wright Design, your work environment

is the Wright Design screen. The main

program window is shown below, as it

would appear the very first time you run the

Wright Design application. From then on,

the Wright Design screen will appear as it

was when you last closed the application.

To become proficient with Wright Design, it

is first necessary to become familiar with the

various screen elements. Those who are

familiar with the Windows environment will

have no trouble recognising the usual title

bar, menu and menu commands. Some

elements are particular to Wright Design

such as the status line and the Tool modifier

ribbon.

Chapter 2 - Finding your way around
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Title bar
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Document window
The page area is the white rectangular area

with a drop shadow that represents the

page’s printable area. The page area corre-

sponds to what you select in your document

setup dialog box when you create a new

document.                                        

For information on creating a document see

‘Creating a new document’ on page 56.  

The pasteboard is the area to the left and

right of the page area. You might have to

scroll the window or reduce the magnifica-

tion level to see the Pasteboard.

Objects you create can be placed anywhere

to the left or right of your page. These

objects placed on the pasteboard are saved

with your document but do not print.

Status Line

Title bar

Tool palette

Minimize
Maximize

Close

Menu Tool modifier ribbon

Scrollbars

Page

Pasteboard Pasteboard

The following picture shows you the Wright

Design screen as it would appear with an

open document. 

Note: The look of your screen may vary
depending on where and how you position
your tool palette. 

Paint 
Style
palette



You can work with multiple documents in

Wright Design. Each document appears in its

own document window. See ‘Arranging
windows’ below.

You can move, resize, minimize and maxi-

mize each open document as well as the

main program window.

Rulers are displayed along the top and left

hand borders of the active window area. This

is the default when you open a document.

You may hide the rulers by selecting

Guides > Show Rulers from the menu.

Scrollbars
Scrollbars appear on the edges of your docu-

ment window by default.

To hide Scrollbars:

● Choose Window > Screen View >

Scrollbars.

To display Scrollbars:

● Choose Window > Screen View >

Scrollbars.

A checkmark to the left of Scrollbars  shows

you that Scrollbars are displayed.

To use Scrollbars:

Scrollbars are used to bring other parts of a

window’s contents into view:

● Click the scroll arrow that points in the

direction you want to move. You can scroll

continuously by holding down the cursor

over a scroll arrow. 

● Drag the thumb to the place in the

scrollbar that corresponds to the location

you want to view. 

● Click the scrollbar on either side of the

thumb, in the direction that you want to

view. This scrolls one screen at a time.

Standard Windows features
Arranging windows
You can arrange and switch between docu-

ments in Wright Design.

Window > New Window, creates another

view of the document you have opened.

Window > Cascade, arranges all open docu-

ment windows so that their title bars are

visible and the documents overlap.

Window > Tile Vertical, arranges all open

document windows in Wright Design verti-

cally so they are all the same size and visible.

Window > Tile Horizontal, arranges all open

document windows in Wright Design hori-

zontally so they are all the same size and

visible.

Window > Arrange Icons, arranges icons of

minimised documents at the bottom of the

Wright Design screen.

Window > Close All, will close all documents

that you have open in Wright Design. You

will be prompted to save the documents if

you have not already done so.

Windows Standard Toolbar
To display Windows Standard Toolbar:

● Choose Window > Screen View >

Toolbar.

15
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A checkmark to the left of Toolbar shows

you that the Toolbar is displayed.

To hide the Windows Standard Toolbar:

● Choose Window > Screen View >

Toolbar.

Dialog boxes
A dialog box opens when you choose a menu

command followed by ellipsis points (...)

such as Open... and Save As.... 

Dialog boxes also appear when you double-

click certain palette options.

In dialog boxes you specify names, settings,

sizes, and other properties for commands

and tools. You can press TAB to cycle

through the options in a dialog box.

When you finish adjusting dialog box

settings, choose the OK button (or a button

that signifies a command, such as Open or

Save) to close the dialog box and execute the

command. To abandon the operation,

choose the Cancel button or press ESC to

close the dialog box. In dialog boxes that

retain their settings, choosing the Cancel

button will restore the settings that were in

effect when the dialog box was opened.

Buttons and Boxes
Selecting an option in the menu provides

you with a drop-down menu. You may then

scroll through the drop-down menu and

select the command you require. 

Commands selected without the ellipsis

points (...) are executed directly. Commands

selected with ellipsis points (...) open a

dialog box.                                             

You may also have the option of selecting

another drop-down menu from the

command you first selected if an arrow

appears at the right of the command as

shown below.

Check boxes select or deselect an item.

When a tick appears in a check box, the item

is selected, as shown above; when a check

box is empty, it is not selected, and when a

check box is grey, the function is unavailable.

Radio buttons select one of several options.

You select an option by clicking it. A selected

radio button is filled. To change your selec-

tion, click another option.

Edit Boxes show the numerical value that is 

applied to the selected object. To alter that

value you can key in a new value or use the

spin controls described below.               

Spin controls are located to the right of edit

boxes and consist of an up and a down

arrow. You can select the arrows to adjust

the numerical value in the edit box, either up

or down.
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List boxes are boxes that contain settings

with up and down arrows to the right of the

box. You can scroll through the box to select

the setting you require.   

Combo boxes show the setting that is

selected. Clicking the arrow to the right

produces a drop-down list showing you the

available settings that can then be selected.

Context menus
In addition to the menus that appear at the

top of your screen, Wright Design contains a

number of context-sensitive menus. These

menus display commands that relate to the

active tool, palette or screen. 

To display context menus:

1. Position the cursor over the tool modifier

ribbon, palette or screen.

2. Click the right mouse button. You will

now have a list of options to choose from.

Tip of the Day
The tip of the day dialog box automatically

opens when you first start the Wright Design

application. 

A tip for that day is displayed in the dialog

box as shown above and you may select the

Next Tip button to step through a series of

tips. 

A check-box at the bottom left of the

dialogue box controls when this dialog box is

opened. If this is unchecked you will not

receive a tip of the day when starting the

application from then on.

The Close button will close off the tip of the

day dialog box.

Tool Tips
Tool tips are automatically on when you start

the Wright Design application. 

To show a tooltip, hold the cursor over a

tool and a box will pop up showing you the

tool tip for that particular tool.

Check box

Edit box

Spin controls

Radio button

List box

Combo box



To display tooltips:

1.  Choose File > Preferences > General. 

2.  Check the Show tooltips checkbox.

To turn tooltips off:

1.  Choose File > Preferences > General. 

2.  Uncheck the Show tooltips checkbox.

Status Bar
The Status Bar is located along the bottom of

the Wright Design screen by default.

To hide the Status Bar:

● Choose Window > Screen View > Status

Bar.

To display the Status Bar:

● Choose Window > Screen View > Status

Bar.

A checkmark to the left of Status Bar shows

you that the Status Bar is displayed.

The Status Bar displays the following from
left to right:

● context sensitive help describes what to

do next. 

● color readout of the CMYK or RGB

channel values, in a 1x1 pixel area sampled

by the cursor.

● coordinates read-out that gives you the

x and y coordinates of the cursor relative to

the top left origin of the page.

● three indicators to show you what you

have selected:                               

Insert   or     Overwrite mode

Caps Lock on

Num Lock on

The Menu
The Wright Design menu appears at the top

of the main program window. When you first

open the application you have three menu

commands to select from: File, Window and

Help. On creating or opening a document

you have the following nine menu

commands to select from:

Click on a menu item to open the menu,

then click a command in the menu to choose

it. Many commands have shortcut keys.

See Keyboard Shortcuts on page 40: for an

alphabetical list of all command shortcuts.

The File menu is used to create, open, save,

close and print Wright Design documents, to

import, open, place, convert and export

pictures and to place EPS files. You can also

setup your preferences, respecify your docu-

ment setup, archive your job, load recent

files and exit Wright Design.

The Edit menu is used to undo, redo, cut,

copy, paste, delete, control the clipboard

and select objects.

The View menu is used to specify the way in

which Wright Design displays documents

and objects on screen.
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The Guides menu is used to access

commands relating to Rulers and Guides.

The Object menu is used to perform opera-

tions on objects.

The Text menu is used to control text func-

tionality.

The Filter menu is used to control any 32-bit

Photoshop plug-in filters that you have

linked in the Filter Preference.  

The Window menu is used to specify the way

in which Wright Design displays windows, to

open and close palettes, and to access open

documents.

The Help menu is used to access the

following: on-line help, tips of the day and to

display program information.



Select tool

Text tool

Color mask tool

Clone tool

Gradient tool

Align tool

Eyedropper tool

Bezier tool

Vector tool flyout

Bitmap tool flyout

Brush tool

Grab tool

Replicate tool

Zoom tool

The Tool palette
The tool palette contains tools for selecting,

viewing, creating and editing objects. It also

contains controls for aligning objects,

creating gradients and masks, painting and

cloning. 

The tool palette can be moved around the

screen and its shape is adjustable. It is also

possible to dock your tool palette anywhere

around the outside of the Wright Design

screen. Tool buttons with a red triangle in

the top right corner indicate a tool flyout

that reveals a group of  additional related

tools. Right mouse click on the tool to

display the flyout and select the tool of your

choice (or left mouse click and hold down).

The chosen tool will replace the original tool

in the tool bar.

The tool flyouts can be torn away to create a

separate tool bar. To create a tear-away tool

bar, activate the tool flyout and select an

area surrounding the outside of the flyout. 

A temporary keyline will appear. Move this

away from the tool palette and release your

finger from the mouse. You now have a sepa-

rate tool bar that can be moved or docked

anywhere around the outside of your Wright

Design screen.
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Rectangle Ellipse Straight 
Polygon

Vector
Polygon

Round
Rectangle

Curved
Polygon Freehand/LineStar

Rectangle Ellipse Straight 
Polygon

Bitmap
Polygon

Round
Rectangle

Curved
Polygon Freehand/LineStar

Note: The above tool bars can take on different looks depending on how you have configured

them and where you have them placed.



Tool palette overview

The Select tool allows you to select an

object.

The Bezier tool allows you to alter the

shape of any Vector object or Text

Container.

The Text tool is used to create text objects

and then to type in the text.

The Vector tool flyout allows you to select

the Vector shape you require. You can

then create a Vector object to that shape.

The Color mask tool allows you to create

a mask from similarly colored areas.

The Bitmap tool flyout allows you to select

the Bitmap shape you require. You can

then create a Bitmap object to that shape.

The Clone tool allows you to paint a

portion of a picture to another location.

The Brush tool allows you to paint

objects.

The Gradient tool allows you to change

the length and rotation of your gradient.

The Grab tool allows you to move the

document around the Wright Design

window.

The Align tool allows you to align objects

and also join objects and/or pictures.

The Replicate tool allows you to duplicate

objects to set specifications.

The Eyedropper tool samples colors from

any object in your document.

The Zoom tool magnifies and reduces the

view of your document.                    

Vector Tool flyout overview
The tool that is last selected from the vector tool

flyout (ie. the tools described below) is the tool

that is displayed in the main tool palette.

The Rectangle Vector tool allows you to

create a vector rectangle or square object.

The Round Rectangle Vector tool allows

you to create a vector rectangle object

with rounded corners.

The Ellipse Vector tool allows you to

create a vector ellipse object.

The Curved Polygon Vector tool allows

you to create a vector polygon object with

both curved and straight lines. 

The Straight Polygon Vector tool allows

you to create a vector polygon object with

straight lines.

The Star Vector tool allows you to create a

vector star object.

The Polygon Vector tool allows you to

create a vector regular polygon object.

The Freehand/Line Vector tool allows you

to create a freehand or straight line vector

object.
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Bitmap Tool flyout overview
The tool that is last selected from the bitmap tool

flyout (ie. the tools described below) is the tool

that is displayed in the main tool palette.

The Rectangle Bitmap tool allows you to

create a bitmap rectangle or square object.

The Round Rectangle Bitmap tool allows

you to create a bitmap rectangle object

with rounded corners.

The Ellipse Bitmap tool allows you to

create a bitmap ellipse object.

The Curved Polygon Bitmap tool allows

you to create a bitmap polygon object

with both curved and straight lines. 

The Straight Polygon Bitmap tool allows

you to create a bitmap polygon object

with straight lines.

The Star Bitmap tool allows you to create

a bitmap star object.

The Polygon Bitmap tool allows you to

create a bitmap regular polygon object.

The Freehand/Line Bitmap tool allows you

to create a freehand or straight line

bitmap object.

The Tool Modifier Ribbon
The tool modifier ribbon is located below

the menu. Once again this may vary slightly

depending on where you have positioned

your tool palette.

You can change the position of the tool

modifier ribbon by selecting it with the

cursor and moving it to a different position

on the Wright Design screen. It then turns

into a floating palette and can be moved

around by selecting its title bar. You also

have the ability to close it using the palette’s

close box or choosing Window > Screen

View > Ribbon, which then in turn will also

open the tool modifier ribbon. The tool

modifier ribbon can be docked at the top or

bottom of the Wright Design screen. 

The tool modifier ribbon holds the controls

for most of the main tools in the tool bar.

The Wright Design screen on page 16 and

the picture below shows you the tool modi-

fier ribbon when you are in the select tool. 

If you select a different tool from the tool

palette, the tool modifier ribbon will change.

The only tools without modifier controls are

the grab tool, eyedropper tool and zoom

tool. 

All the controls in the tool modifier ribbon

will be fully explained as we go through each

of the tools in detail.



The Palettes
Wright Design provides several palettes to

help you monitor and modify, objects and

layers within your documents. By default, the

paint style palette appears at the top right of

your screen.

Other palettes are available from the

Windows menu bar.

To show a palette:

Select Windows > Palettes > and the palette

you wish to display (or a shortcut key).

A tick to the left of the palette indicates that

palette is showing.

To hide a palette:

Select Windows > Palettes > and the palette

you wish to hide (or a shortcut key).

Palette overview
The Paint Style (F2) palette controls the

paint style information for the object that is

selected in your document.

The Pen Style (F3) palette controls the char-

acteristics of strokes.

The Brush Gallery (F4) palette allows you to

save your brush settings to the gallery and

also save the entire gallery as a file.

The Task Manager (F5) palette controls the

multi-tasking environment. You can stop,

pause and start any tasks that are processing.

Progress bars indicate the type of task and

the percentage of the task that is complete.
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The Object List (F6) palette displays a list of

all the objects in your page. You can select,

delete, rename, hide and change priority of

objects using the Object list. It also enables

you to copy and/or move layers between

objects. 

The Navigator (F7) palette enables you to

accurately and easily zoom and move around

your document.

The Tool palette(F8) contains tools for

selecting, viewing, creating and editing

objects. It also contains controls for aligning

objects, creating gradients and masks,

painting and cloning. 

The tool palette is explained in more detail

on page 20.

The Spot Colors (F9) palette provides color

values for spot colors (PANTONE®) in your

document, at the point in which the cursor is

situated.  
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Changing the palette display
You are able to change the arrangement and

display of palettes to optimize the work area

on your desktop. Following are techniques

for you to use to organize your palettes:

● Choose Window > Hide Palettes 

(Alt + F2) to hide open palettes except the

tool palette.

● Choose Window > Show Palettes 

(Alt + F2) to show open palettes.

● To move a palette, drag its title bar.

● The Paint Style, Pen Style, Brush Gallery

and Task Manager have minimize and maxi-

mize tabs at the top right of the palettes.

Click on the dash button to minimize and

the square button to maximize the palettes.

● The Object List, Navigator, Tool and Spot

Color palettes are resizeable.

To resize the palettes click and drag at the

any side or corner of the palettes. 

● To hide individual palettes either: select

Window > Palettes > and the palette you

wish to hide, press the related shortcut key,

or click the palette’s close box.

Screen Display
Wright Design saves the positions of all open

palettes and the positions of moveable

dialog boxes when you exit the program. 

You can customize your screen display using

the Screen Layout control or you can use

Shortcut keys to step through different

screen displays.

Changing the screen display

Customized Views
The Screen Layout control allows you to

customize your screen.

To customize your screen:

1.  Choose Window > Screen View > Screen

Layout. (Ctrl + Shift + E)

The Window Setup dialog box will open.

The options that are selected in the Window

Setup are the options that you have open at

the present time.

2.  Select the options you require to be

displayed on screen by clicking to the left of

each option.

3.  Click Apply.

The setup that you have just created will

now be your screen display.

Predefined Views
There are five predefined screen displays

available to you using Shortcut keys. 

Ctrl + Alt + F1:  Normal viewing area - this

option displays all viewing modes that you

have selected.



OR

● Choose Window > Screen View > Normal

viewing area.

Ctrl + Alt + F2:  this option shows all

viewing modes you have selected except the

‘Title Bar’. 

Ctrl + Alt + F3:  this option shows all

viewing modes you have selected except the

‘Title Bar’ and the ‘Tool modifier ribbon’. 

Ctrl + Alt + F4:  this option shows all

viewing modes you have selected except the

‘Title Bar’, ‘Tool modifier ribbon’ and

‘Palettes’ (except the tool palette). 

Ctrl + Alt + F5:  this option displays your

document only. To revert to another display

use one of the above options.

OR

● Choose Window > Screen View >

Maximum view area.

Ctrl + Alt + Up arrow and 

Ctrl + Alt + Down arrow will cycle through

the view options one at a time.

Tool Draw Colors
Wright Design supplies you with a Tool Draw

Colors palette that allows you to change the

color of the object’s outline as you create the

object.

For example: If the Tool Draw Color is set to

gray and you are creating an object on top of

a gray object you cannot see the outline of

the object you are creating. Selecting a

different color from the Tool Draw Color

palette will allow you to see the outline of

your object on creation.

To display the Tool Draw Color palette:

● Choose Window > Screen View > Tool

Draw Colors.

A checkmark will display to the left of Tool

Draw Colors to show you the palette is

displayed.

To hide the Tool Draw Color palette:

● Choose Window > Screen View > Tool

Draw Colors.

To use the Tool Draw Color palette:

● Select the color you wish to use to create

and select objects.
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Viewing your work
Wright Design offers a large number of

viewing options to enable you to work with

maximum control and precision. 

These options include  zooming, moving

and calibrating. 

You also have the choice of  viewing your

document in different color modes and with

interpolation and anti-aliasing.

Moving and zooming
The zoom tool, grab tool, View commands

and the Navigator palette let you view

different areas of your document at different

magnifications.

Moving the view of a page
You can view different areas of a page using

the scroll bars, grab tool or the SPACE bar. 

To scroll using the grab tool:

1. Select the grab tool.

2.  Click and drag on the page to move it to

the position you require.

Drag the grab tool...     to move the view.

To scroll using the SPACE bar:

1. Place the cursor (using any tool except

the text tool)  at the point on your page that

you wish to be centered.

2.  Hit the SPACE bar.

Hit the SPACE bar...      to centre the view.

Magnifying and reducing the view
The zoom tool and the View commands

allow you to magnify and reduce the view of

your page.

To zoom in:

●  Select the zoom tool, and click the area of

the page you wish to magnify. On each click

the magnification doubles.

OR

● Choose View > Zoom In to magnify your

view 100%.

Click...     to zoom in.

OR

● Shortcut key -  Ctrl + ( + )  (keypad only) 
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To zoom out:

●  Select the zoom tool. Hold down Shift to

activate the zoom-out tool, and click the area

of the page you wish to reduce. On each

click the reduction is halved.

OR

●  Choose View > Zoom Out to reduce the

view by 100%.

OR

● Shortcut key -  Ctrl + ( -  ) (keypad only) 

To magnify by dragging:

1. Select the zoom tool.

2.  Drag over the part of the page you wish

to magnify

Drag the zoom tool...   to magnify the view.

The part of the page enclosed by the zoom

marquee is displayed at the maximum magni-

fication possible.

To change the view to fit the screen:

This option modifies the zoom to the largest

percentage possible and still contain the

entire page in the window.

● Choose View > Fit Page in Window.

OR

● Shortcut key -  Ctrl + 0 

(Not the zero on your keypad.)

This option modifies the zoom to the largest

percentage possible and still contain the

entire object in the window.

● Choose View > Fit Object in Window.

To view at the actual size:

This option allows you to view your page at

the size it really is. To be able to view at

actual size you have to first make sure the

dimensions of your screen are set correctly.

1. With a film ruler, measure the width and

height of the open Wright Design application

window when it is maximised. 

2. Choose File > Preferences > General and

set the screen dimensions (width x height).

3. Choose View > View at Actual Size.

To display at a resolution:

This viewing mode will display the selected

object at a percentage of the resolution of

that object. 

Viewing 100% Object Resolution will show 

1 picture pixel  =  1 screen pixel.

The selected object can only be a Bitmap or

a Picture object as these objects are the only

objects that have a resolution.

● Choose View > 100% Object Resolution.

● You also have the choice of viewing at

50% and 200% object resolution.

To refresh the screen:

This viewing mode will redraw the screen. 

● Choose View > Refresh Display.(Ctrl + R)
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Using the Navigator palette
The Navigator palette (F7) lets you quickly

view different parts of your page and change

the magnification of your view. 

The palette displays a reduced view of the

page and a broken line, the viewport, repre-

sents the area displayed in the page window.

This allows you to see exactly what part of

the page is being viewed.

To use the Navigator palette:

1.  From the Navigator palette, drag over the

part of the page you wish to magnify. 

The viewport in the Navigator palette shows

you the area that is magnified. 

2.  To move the viewport around, move the

cursor to any side of the viewport so that

your cursor is showing a four-headed arrow

select the viewport and move it to the new

part of your page. 

3.  To create a new viewport, drag over the

new part of the page you wish to magnify.

Right mouse clicking on the Navigator

palette will give you the following options:

● Always drag viewport -  allows you to

select anywhere within the viewport and

move it around the Navigator palette. To

select a new viewport that is completely

within the old viewport, turn this option off.

● Fit page to window -  modifies the zoom

to the largest percentage possible and still

contain the entire page in the window. 

Viewing
The options in the View command allow you

to view your document in a number of

different modes.

The view options may be selected at any

time. A tick to the left of the command

shows you if the option is selected.

Note, some viewing options may

degrade your screen redraw speed.

Preview Transforms
Preview transforms animates an object as it is

transformed.

When this is not selected, you will only see

an outline of the object as you apply a trans-

formation.

To select Preview Transforms:

● Choose View > Preview Transforms.

Viewport
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Calibrate Display
Calibrate display allows you to apply the cali-

bration to your document that has been set

in the Calibration preferences.

When this is not selected, there will not be a

calibration applied to your document.

To select Calibrate Display:

● Choose View > Calibrate Display.

To learn how to create a calibration file see

‘Preferences’ - ‘Calibration’ on page 37.

Interpolate Bitmaps
Interpolate Bitmaps allows you to view your

pictures and bitmap objects with interpola-

tion. 

This option increases the quality of your

document on screen but takes longer to

calculate. To interpolate for output

purposes, refer to either “Save as Picture” or

“Print”, whichever you require.  

When you re-size a picture, Wright Design

determines how pixels are calculated by

using the bicubic interpolation method.

This is the most precise form of interpola-

tion as it results in the smoothest tonal

gradations.    

This viewing option may degrade your

screen redraw speed significantly.

To select Interpolate Bitmaps:

● Choose View > Interpolate Bitmaps.

Anti-alias Vectors
This option smooths out the jagged edges of

vector objects. It increases the quality of

your Vectors on screen but takes longer to

draw. 

To anti-alias for output purposes, refer to

either “Save as Picture” or “Print”.

To select Anti-alias Vectors:

● Choose View > Anti-alias Vectors.

Viewing Color Modes
Wright Design allows you to view color in

either CMYK mode or RGB mode. 

CMYK is the mode to use when preparing a

file for print. You can also view spot colors.

RGB is the mode to use when preparing a

file to output to transparency or to use on

screen for multimedia and the internet.

To select CMYK color mode:

1.  Choose View > CMYK / Spot. 

A sub-menu appears.

2.  Select the color channel you want to

view. eg Cyan.



OR

● Shortcut keys:    

Cyan Ctrl + 1 

Magenta Ctrl + 2

Yellow Ctrl + 3

Black Ctrl + 4

CMY Ctrl + 5

CMYK Ctrl + 6

To select Spot color mode:

NOTE: You must have Spot colors present in

your page to see them in the CMYK / Spot

menu. 

1.  Choose View > CMYK / Spot. 

A sub-menu appears.

2.  Select the color channel you want to

view. eg PANTONE® 682 CVC.

OR

● Shortcut keys:    

Spot 1 Ctrl + Alt + 1

Spot 2 Ctrl + Alt + 2

Spot 3 Ctrl + Alt + 3

etc.....

To select RGB color mode:

1.  Choose View > RGB. 

A sub-menu appears.

2.  Select the color channel you want to

view. eg Red.

OR

● Shortcut keys:    

Red Ctrl + 1 

Green Ctrl + 2

Blue Ctrl + 3

RGB Ctrl + 4
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Preferences
Preferences are default values and settings

that you can modify to enable, disable and

customize the way in which many automatic

features work.

Wright Design provides a preference dialog

box that contains six tab settings for speci-

fying preferences. The tab settings are:

Folders, General, Guides, Gamma,

Calibration and  Text.

Preference settings are saved each time you

exit the Wright Design application.

Folders
When you install Wright Design, the folder

preferences are all set to the folder where

you installed the application. 

The folder options are: Calibration, Filters,

Guides, Pictures, Documents, Print and EPS

files. 

It is recommended that before producing

any work in Wright Design, you set up your

folder preferences.

Setting up Folders

1. You will first have to create specific

folders using Windows Explorer/Windows NT

Explorer. (ie. create a folder called “Pictures”.

This will be the default folder when you

select “Open Picture” and “Save as Picture”.

These folders do not have to be located in

the folder where the program has been

installed.

For help with this, please see your Windows

documentation.

2.  Choose File > Preferences > Folders.

The following dialog box will appear.

3. Select the folder you want to change. 

(ie. Pictures)  A dialog box called “Browse for

Folder” will appear

.

4. Find the folder called “Pictures” you

created in Step 1. Select OK.



5.  You will now see the Pictures folder

directory path has been updated.

If you created all the folders you require in

Step 1, you can continue updating the

remaining folders following Steps 3 and 4.

If you need to create more folders continue

from Step1 to create and update the

remaining folders.

6.  Select OK.

If you have more than one drive on

your computer, it is preferable to assign the

“Document” folder to one drive and the

“Picture” folder to another drive.

Wright Design will run faster if you do so.

General
Included in General preferences are settings

for Screen dimensions, Measurement units

and the Tooltips control. 

Setting up Screen dimensions

1. With a ruler, measure the width and

height of the open Wright Design application

window when maximised. 

2. Choose File > Preferences > General and

set the screen dimensions (width x height).

Now if you use the command, View > View

at Actual Size your page will display at its

actual size.

3. Click OK.

Setting up Measurement Units

1. Choose File > Preferences > General.  

2. Click the arrow on the combo box and

select the unit of measurement you would

like as the default.

This unit of measurement will now be the

“application default”.

3. Click OK.
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Controlling Tooltips

1. Choose File > Preferences > General.  

2. If you would like tooltips on, check the

box. If you don’t require tooltips leave the

box unchecked.

3. Click OK.

Place pictures as CMYK

This option when checked will convert all

pictures that you place from their original

color model to CMYK color model.

1. Choose File > Preferences > General.  

2. Check the ‘Place pictures as CMYK’ if you

want all pictures that you place to be

converted to CMYK color model.

3. Click OK from the Preferences dialog box.

Guides
The Guides preference controls the color of

your guides and margins and also the snap

and selection distances.

The snap distance is the maximum distance

the cursor can be from a guide to snap an

object to that guide.

The selection distance is the maximum

distance the cursor can be from a guide to

move that guide. 

Setting Guide colors

1. Choose File > Preferences > Guides.  

2. Click on the colored box to the right of

guides. 

3. Move the CMY slider controls to find a

color you like  OR key in a percentage of

CMY  in the boxes to the left of the sliders to

create a color. 

You will see the guide color box change

color. This is your new guide color.

4. Click OK.

Setting Margin colors

1. Choose File > Preferences > Guides.  

2. Click on the colored box to the right of

margins. 

3. Move the CMY slider controls to find a

color you like  OR key in a percentage of

CMY  in the boxes to the left of the sliders to

create a color. 

You will see the margin color box change

color. This is your new margin color.

4. Click OK.
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Setting the Snap distance

1. Choose File > Preferences > Guides.  

2. Key in a vertical and horizontal snap

distance.

The unit of measurement will be the

application default. Right mouse clicking will

give you the following options: mm, cm,

inches, points and pixels.

3. Click OK.

Setting the Selection distance

1. Choose File > Preferences > Guides.  

2. Key in the selection distance.

The unit of measurement is always pixels.

3. Click OK.

Monitor Calibration (Gamma)
Use the Gamma preference to eliminate any

color cast in your monitor, and to ensure

that your monitor displays gray levels as

neutral as possible.

This will help to display colors in a consis-

tent way on different monitors.

Setting Monitor Gamma

1.  You should allow sufficient time for your

monitor to warm up before attempting any

color adjustments. Twenty to thirty minutes

should be sufficient.

If you have a Degauss control on your

monitor, press this to degauss the monitor.

For more information on degauss see your

monitor manual.

2. Ensure your room lighting is at a level

that you intend to use for most of your work.

Avoid direct sunlight or bright reflections off

your monitor. 

Adjust the monitor's brightness and contrast

controls to your liking. Once set, it is a good

idea to tape over them as these controls

should not be changed.   

3. Choose File > Preferences > Gamma.

4. Make sure the Disable checkbox is not

checked. 

5.  Hit the Reset button to make the three

sliders show identical values.

6.  Make sure the Move together checkbox is

checked, so that all  three sliders will

move in unison. 
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Move any one of the sliders until the gray

color swatch matches the adjacent patterned

gray areas, as shown below. 

This setting is only a guide, you should

further tune the gamma by displaying a black

and white gradient and adjusting the sliders

until the solid black part of the gradient

extends no further than approximately 1/8 of

the way from the dark end.

7. Observe the matched gray color. If your

monitor has a color cast, the grey will not be

perfectly neutral, it may be blueish, for

example. 

To eliminate this cast, uncheck the Move

together checkbox. Choose the blue slider

for this example and make small adjustments

until the cast is removed and the color

swatch appears neutral gray.

8. You can hit the Test button at any time to

see the effects of your adjustments on the

page, if you have one open.

9. Click OK to accept the changes. 

Once you have calibrated your monitor, you

should not have to recalibrate unless you

change any of the factors affecting calibra-

tion. 

For example, if you change the room lighting

or readjust the monitor brightness and

contrast controls you will need to recalibrate

the monitor.

Also, over time the monitor color may drift

and you may need to adjust your gamma

settings.



Calibration
The Calibration preference allows you to

adjust calibration settings. These settings are

used to make the picture on-screen match

your output. 

Setting Calibration colors

1.  To calibrate for output you need to print

a standard test picture on your target output

device. 

There are many variables that effect the way

your printed sample will look, even amongst

identical devices. These variables include,

type of printer, inks used, dot gain, printing

stock, temperature, humidity, etc.

The test picture must include color swatches

of the following colors:

● Four swatches made up of 100% cyan,

100% magenta, 100% yellow, 100% each of

cyan, magenta  and yellow.

● Four swatches made up of 50% cyan, 

50% magenta, 50% yellow, 50% each of cyan,

magenta  and yellow.

● Four combination swatches made up of

red (100% each of magenta and yellow),

green (100% each of cyan and yellow), blue

(100% each of cyan and magenta) and 100%

each of cyan, magenta and yellow.

● Four combination swatches made up of

red (50% each of magenta and yellow),

green (50% each of cyan and yellow), blue

(50% each of cyan and magenta) and 50%

each of cyan, magenta and yellow.

These are the primary calibration datum

points. 

The test picture should also include a high

quality scanned picture which contains a full

range of the above primary and secondary

colors.

This will be used for fine tuning.

2.  Having obtained your printed sample and

calibrated your monitor for gamma, follow

these steps:

Place the test picture into your page. Make

sure you have Calibration switched on in

your View menu. Also make sure that

monitor gamma is enabled in your gamma

preferences.

3. Choose File > Preferences > Calibration.  
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4.  Click on the Cyan color button and adjust

its display color using the CMY sliders, until

it matches the corresponding color of the

printed swatch (the 100% cyan swatch). 

Do the same for the remaining color

buttons. 

You may press the Test button at any time to

observe the effects of your calibration.

5.  Now observe the 50% swatches on your

printed sample. If they don't look like the

calibrated 50% swatches in the picture 

on-screen, you will need to adjust the Dot

Gain amount. 

If the screen swatches appear to be lighter

than the printed sample, then increase the

dot gain, if they are darker, then decrease

the amount of dot gain.

You have now completed the primary adjust-

ment phase. Press Test to see the results so

far. 

6.  Now look at the scanned picture on-

screen and compare it to the printed sample.

Chances are that the two will not look

exactly alike.

There may be some variation in certain

tones. This will require some fine tuning.

Identify the colors which show the variation, 

click on the corresponding color button and

make subtle adjustments to the appearance

of those colors with the CMY sliders.

Test the results after each adjustment.

If the overall screen picture appears too light

or too dark, then adjust the CMY color. You

may also need to adjust the dot gain amount.

If your paper stock isn't totally white, you

will need to adjust the White color appear-

ance, though generally, you shouldn't need

to do this.

Text
The Text preference controls the color of the

text container and the color and opacity of

the text highlighter. You also have the

option of greeking and setting when

greeking comes into effect. 

Text greeking is where the text is displayed

onscreen as grey bars to speed screen

redraw.

The enable font preview option when

checked shows you a preview of each font as

you highlight them when selecting a font.



Setting the Text Container color

1. Choose File > Preferences > Text.  

2. Click on the colored box to the right of

container. 

3. Move the CMY slider controls to find a

color you like OR key in a percentage of

CMY  in the boxes to the left of the sliders to

create a color. 

You will see the container color box change

color. This is your new text container color.

4. Click OK.

Setting the Text Selection color

1. Choose File > Preferences > Text.  

2. Click on the colored box to the right of

selection. 

3. Move the CMY slider controls to find a

color you like  OR key in a percentage of

CMY  in the boxes to the left of the sliders to

create a color. 

You will see the selection color box change

color. This is your new text selection color.

4. You now have the option of setting an

opacity for the text selection color. 

To the right of Selection Opacity, key in the

percentage of opacity you require. 

5. Click OK.

Setting Greeking

1. Choose File > Preferences > Text.  

2. If you would like greeking on, check the

box. If you don’t require greeking leave the

box unchecked.

3.  Key in an amount, to the right of “Greek

below:” to indicate when you would like

greeking to take effect.

4. Click OK.

To enable font previews:

1. Choose File > Preferences > Text.  

2. If you would like font previews enabled,

check the box. If you don’t require font

previews leave the box unchecked.

3. Click OK.
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Keyboard Shortcuts
Learn to use the keyboard shortcuts that

appear to the right of the commands in the

menus. These are especially useful for opera-

tions that you perform frequently.

A plus sign between keys tells you to hold

down the key or keys as you press the final

key, then release all keys.

File
Ctrl + N ....................................................New

Ctrl + O ..................................................Open

Ctrl + W .................................................Close

Ctrl + S ....................................................Save

Ctrl + Shift + S....................................Save As

Ctrl + Alt + S .................................Save As Pic

Ctrl + P .......................................Place Picture

Ctrl + E ............................................Place EPS

Ctrl + Shift + P .......................................Print

Ctrl + Shift + I.........................Import Picture

Ctrl + Shift + C ......................Convert Picture

Alt + F4 .....................................................Exit

Edit
Ctrl + Z (or Alt + Backspace) ................Undo

Ctrl + Y ...................................................Redo

Ctrl + X......................................................Cut

Ctrl + C ...................................................Copy

Ctrl + V ...................................................Paste

Del ........................................................Delete

Ctrl + A.............................................Select All

Ctrl + Shift + A ............................Select None

View
Ctrl + R ...............................................Refresh

Ctrl + 0 (not keypad).......Fit Page In Window

Ctrl + 9 .........................Fit Spread In Window

Ctrl + + (keypad only)......................Zoom In

Ctrl + - (keypad only).....................Zoom Out

CMYK / Spot
Ctrl + 1 ....................................................Cyan

Ctrl + 2 ..............................................Magenta

Ctrl + 3 .................................................Yellow

Ctrl + 4 ...................................................Black

Ctrl + 5 ....................................................CMY

Ctrl + 6 ..................................................CMYK

Ctrl + Alt + 1 ........................................Spot 1

Ctrl + Alt + 2 ........................................Spot 2

Ctrl + Alt + 3 ........................................Spot 3

Etc, etc ............................................................

RGB
Ctrl + 1......................................................Red

Ctrl + 2..................................................Green

Ctrl + 3 ....................................................Blue

Ctrl + 4.....................................................RGB

Guides
Ctrl + Alt + R ..............................Show Rulers

Ctrl + Alt + A ..........................Snap To Rulers

Ctrl + M......................................Show Guides

Ctrl + Shift + M .....................Snap To Guides

Ctrl + Alt + M..............................Lock Guides

These shortcut keys are also used to do the

opposite of what is shown here. For example,

Ctrl + Alt + R will Hide Rulers if they are showing

and Show Rulers if they are hidden. 
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Object
Ctrl + D ...........................................Duplicate

Ctrl + G.................................................Group

Ctrl + U.............................................Ungroup

Ctrl + L ....................................................Lock

Ctrl + T...............................................Convert

Ctrl + I ...................................................Invert

Ctrl + F ...............................................Feather

Ctrl + B...................................................Grow

Ctrl + H ..............................................Shadow

Window
F2 ........................................Paint Style Palette

F3 ..........................................Pen Style Palette

F4 ...................................Brush Gallery Palette

F5...............................................Task Manager

F6 ...................................................Object List

F7 .........................................Navigator Palette

F8 .................................................Tool Palette

F9..................................................Spot Colors

Tool palette
Shift + F2 ......................................Select Tool

Shift + F3 ......................................Bezier Tool

Shift + F4 .........................................Text Tool

Shift + F5.......................................Clone Tool

Shift + F6.......................................Brush Tool

Shift + F7 .................................................Tool

Shift + F8 ........................................Align Tool

Shift + F9 .............................Eyedropper Tool

Shift + F10.....................................Zoom Tool

General
● From any tool, Ctrl (while pressed) will

temporarily take you to the Select tool

●  While in the Select tool:

Shift .............................multiple select objects

Shift over corner handles ......................rotate

Shift over middle handles............shear/rotate

Alt over corner handles ............... perspective

●  In Any tool, except the Text tool:

SPACE bar.............................centre your page

●  In Rectangle tool:

Shift ..........................................make a square

●  In Ellipse tool:

Shift ............................................make a circle

●  In Round Rectangle tool:

Shift ..........................................make a square

Alt ...........................change the corner radius

●  In Curved Polygon tool:

Shift ....................................plot a straight line

Backspace .....................remove the last point 

Return ....................................finish the shape

ESC ..............................erase the whole shape

●  In Polygon tool:              

Backspace .....................remove the last point

Alt ............................change the corner radius

Return ....................................finish the shape

ESC ..............................erase the whole shape

Shift ....restrict line angles to 15 degree incre-

ments.
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●  In Freehand/Line tool when used to plot

a two point line

Shift ....restrict line angles to 15 degree incre-

ments

● In Eyedropper tool:

Shift ..........................sample a 3 x 3 pixel area

●  In Zoom tool:

Shift ..................................................zoom out

●  In Bezier tool: 

Ctrl + A ...................................select all nodes

Ctrl + Shift A ......................deselect all nodes

Text
....................................Previous Character

..........................................Next Character

................................................Previous Line

......................................................Next Line

Ctrl + ......................................Previous Word

Ctrl + .............................................Next Word

Ctrl + ...............................Previous Paragraph

Ctrl + .....................................Next Paragraph

Ctrl + Page Up .......................Start of Column

Ctrl + Page Down ...................End of Column

Home ...........................................Start of Line

End ................................................End of Line

Ctrl + Home.............................Start of Article

Ctrl + End .................................End of Article

Ctrl + Shift + ................Select Previous Word

Ctrl + Shift +.......................Select Next Word

Ctrl + Shift +.........................Select to Top of 

Paragraph

Ctrl + Shift + ................Select to Top of Next 

Paragraph

Ctrl + Shift + Page Up...........Select to Top of 

Column

Ctrl + Shift + Page Down- ...Select to Bottom 

of Column

Shift + Home .......Select to Beginning of Line

Shift + End.....................Select to End of Line

Shift + Ctrl +Home .....Select to Beginning of

Article

Shift + Ctrl +End .......Select to End of Article

Insert .....................................Toggle between 

Insert/Overstrike

Delete ....................Delete character forwards

Backspace .............Delete character backward

NOTE: If you have text selected, the

......................................Start of Selected Text

.......................................End of Selected Text

Ctrl + Shift + P........................................Plain

Ctrl + Shift + B........................................Bold

Ctrl + Shift + I ........................................Italic

Ctrl + Shift + S ...................................Shadow

Ctrl + Shift + / .................................Strikeout

Ctrl + Shift + U...............................Underline

Ctrl + Shift + W ....................Word Underline

Ctrl + Shift + H .............................Small Caps

Ctrl + Shift + K ..................................All Caps

Ctrl + Shift + ) .............................Superscript

Ctrl + Shift + ( .................................Subscript

Ctrl + Shift + V .................................Superior

Ctrl + Shift + \ .................................Font Size
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Ctrl + Shift + F ........................................Font

Ctrl + Shift + D ..................................Leading

Ctrl + Shift + T .................................Tracking

Ctrl + Shift + >.........................Increase Font 

(1 pt increment)

Ctrl + Shift + < .......................Decrease Font 

(1 pt decrement)

Ctrl + Shift + L ........................Alignment Left

Ctrl + Shift + C...............Alignment Centered

Ctrl + Shift + R .....................Alignment Right

Ctrl + Shift + J.....................Alignment Justify

Ctrl + Shift + Alt + J .........-Alignment Forced

Justify

Ctrl +Shift + F1 .............Character Properties

Ctrl +Shift + F2 .............Paragraph Properties

Ctrl +Shift + F3.................Feature Properties

Ctrl +Shift + F4...................Article Properties

‘ ..............................................‘(smart quote)

Ctrl + ‘ ...........................................................' 

“ ................................................“(smart quote)

Ctrl + Shift + “ ..............................................."

Click + Click..............................Select a Word

Shift + Click ...................Extend the Selection

Ctrl + Enter ..............................Column Break

In the Text Tool & editing your Text Object:

Ctrl ........................Resizes text object & text.

Ctrl + Shift ............Rotates text object & text.

(corner handles)                                             

Ctrl + Shift .............Shears text object & text.

(center edge handles)                                     
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Photoshop plug-in filters
Wright Design supports 32-bit Photoshop

plug-in filters to extend its functionality.

To install 32-bit Photoshop plug-in filters:

1.  Choose File > Preferences > Folders. 

The following dialog box will display.

2. Select the ‘Filters’ folder button. 

The “Browse for Folder” dialog box will

display.

.

3. Find your Photoshop ‘Plugins’ folder. 

The Photoshop plug-ins have to be loaded

on your machine. 

4.  Select OK.

5.  You will now see the Filters folder direc-

tory path has been updated.

Wright Design will look into the folder you

have selected and all its sub-folders for any

32-bit Photoshop plug-in filters.

To use a 32-bit Photoshop plug-in filter:

See Chapter 6 - Filling Objects with Layers -

‘Using plug-in filters’ on page 201.
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W right Design provides you with two

ways of creating a new document.

You can either open a picture to do

some retouching and enhancements, or you

can create a new document to start

producing your work from a blank page.

Pictures can be bought into Wright Design by

importing from a variety of different file

formats or by scanning a photograph or

slide.

This chapter gives you an overview of the

basic resolution and file size concepts essen-

tial for producing high quality output. It also

provides instructions on how to import and

open pictures in Wright Design, how to

create a new document and how to place

pictures into your document. 

Size and resolution
There are several concepts that are impor-

tant when discussing the characteristics of

bitmap pictures: pixel dimension, picture

resolution, output resolution, and screen

ruling. The following sections discuss these

characteristics. 

Pixel Dimensions
Every bitmap picture contains a fixed

number of pixels. This is measured by the

number of pixels displayed along the height

and width of the picture. The total number

of pixels determines the amount of data in

the picture or the file size. Pixel dimensions,

along with the size and setting of the

monitor, determine how large a picture

appears on-screen. 

A monitor with its display set to 640 x 480

pixels will display pixels that are quite large,

whereas a monitor set to 1152 x 870 will

display small pixels.

If you are planning to display a picture

online (on a Web page, for example), your

maximum picture size is determined by the

lowest pixel dimensions of the monitors

used to display your picture. (ie. 640 x 480

pixels.)

Picture Resolution
The number of pixels displayed per unit of

length in a picture is called the picture reso-

lution. This is usually measured in pixels per

millimetre (ppmm) or dots per inch (dpi).

A picture with a high resolution contains

more, and therefore smaller pixels, than a

picture of the same dimensions with a lower

resolution.

Selecting an picture resolution depends on

how you intend to display or distribute your

picture. Using too low a resolution for a

printed picture results in large pixels that

produce a very coarse-looking output. Using

too high a resolution (ie. pixels smaller than

what an output device can reproduce)

increases the file size unnecessarily and may

increase the time required to print or

distribute the picture.
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72 dpi

300 dpi

Monitor resolution
The pixel setting of the monitor and the size

of the monitor determines the size of the

monitor pixels.

Output Resolution
Output resolution is the number of dots per

inch (dpi) that an imagesetter or laser

printer produces. 

Most laser printers have output resolutions

of 300 to 600 dpi and produce good results

with pictures from 72 dpi to 150 dpi. High-

end imagesetters can print at 1200dpi,

2400dpi or higher and produce good results

with pictures from 200 dpi to 300 dpi.  

Screen ruling and picture resolution
Screen ruling, also known as screen

frequency refers to the number of rows or

lines of dots used to render a picture on film

or paper. Screen ruling is measured in lines

per inch (lpi) is a property of the printing

device.

The relationship between  screen ruling and

picture resolution determines the quality of

detail in the printed picture. As a general

rule, to produce a halftone picture of the

highest quality, use a picture resolution that

is 1.5 to 2 times the screen ruling. 

A newspaper is commonly printed using a

low screen ruling of 85 lpi because of

newsprint’s high absorbency of ink and the

high speed of the press. A four-color maga-

zine printed on coated paper might use a

screen ruling of 150 lpi. A lower screen

ruling would make pictures appear coarse

and less detailed.

Some imagesetters and laser printers

use other screening technologies.

If you are printing on such a printer, consult

your printer documentation for the recom-

mended picture resolutions.

About file size and resolution
The file size of a digital picture is measured

in kilobytes (KB) or megabytes (MB) and is

proportional to the total number of pixels in

the picture.

Pictures with more pixels produce more

detail at a given resolution and their file size

is also larger.
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Scanning Pictures
Wright Design software works with any

scanner that supports the TWAIN 1.6 inter-

face. 

TWAIN is a cross-platform interface for

acquiring pictures captured by certain scan-

ners or other devices. The manufacturer of

the TWAIN device must provide a TWAIN

data source for your device. 

(See the documentation included with your

scanner or other device for installing and

using the TWAIN data source).

To import a picture using the TWAIN inter-
face:

1.  Choose File > TWAIN > Select Source.

The Select Source dialog box will open.  This

dialog box shows you all of the TWAIN data

sources that you have installed on your

machine.

2.  Highlight the source you wish to use.

3.  Press the Select button.

4.  Choose TWAIN > Acquire.

A dialog box for your source will open

enabling you to set up all of the parameters

for your scan. This dialog box varies

depending on what scanner or other device

you are using. 

5.  Type in the parameters you require for

your scan in the dialog box.

Color mode and resolution are the main

parameters that are relevant to Wright

Design.

6.  Press Scan or whatever control is avail-

able to you from your source.

The Save As dialog box will open.  The orig-

inal default folder path, will be the path that

is set for Pictures in your Folder preferences. 

(File > Preferences > Folders > Pictures)
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The default folder path from then on is the

path that you used when you last opened,

placed or saved a picture.

7.  If the default folder path is not the path

you require, click on the arrow to the right

of the “Save As” combo box and select a new

folder path.

8.  The icons across the top of the dialog box

are general Windows functions.

9. Enter a name for your picture in the File

name edit box.

10. Select either:

Scan to disk - where your picture will be

scanned to the folder specified

OR

Scan to document - where your picture will

be scanned to the specified folder and the

picture will be placed into an open docu-

ment in Wright Design when complete. 

If you don’t have a document open in Wright

Design this option will be grayed out. 

11. Click Save.

The scanner will now start scanning your

picture. The source will probably display a

status bar or percentage readout showing

you progress of your scan.

Whilst the picture is scanning you can go

back into Wright Design and keep on

working. 

After the source has completed the

scan, the source will stay up on screen.

Select Wright Design from the Task Bar or

Alt+Tab through to select it.   

Importing pictures
Wright Design works with its own file format

called DCM Picture file and it has the exten-

sion .dcm.

Picture files from Wright Design

Version 1.0 that have a .spl extension are

compatible with Wright Design Version 2.0.

You can import pictures in a variety of

different file formats. 

These include: DCM (.dcm;.spl)

TIFF (.tif)

JPEG (.jpg)

EPS (.eps)

PNG (.png)

BMP (.bmp)

Targa (.tga, .vda, .vst, .icb)

Scitex CT (.sct)

Photoshop (.psd) 

Kodak Photo CD (.pcd)

Compuserve GIF (.gif)

PICT (.pct, .pic)

The DCM file format is automatically gener-

ated as pictures are imported, opened or

placed. The conversion time is negligible

(virtually the same time it takes to read the

original picture).
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There are three ways of importing a picture

into Wright Design. You can either: 

Import picture - This option automatically

converts the foreign file into DCM format. 

Using Import picture is useful for importing

a batch of pictures into DCM format. 

If you require a single picture, it is faster to

use either Open picture or Place picture. 

Open picture - This option automatically

converts the foreign file into DCM format,

creates a new document the same size as the

picture and places the picture inside the

page.

Place picture - This option automatically

converts the foreign file into DCM format

and places the picture into the current page.

This section will describe how to use the

Import picture function. 

Open picture and Place picture are covered

later in this Chapter as they can operate with

either a foreign file or a DCM file. 

To import a picture:

1.  Choose File > Import Picture. 

(Ctrl + Shift + I)

The Import picture dialog box will open. The

original default folder path will be the path

that is set for Pictures in your Folder prefer-

ences. 

(File > Preferences > Folders > Pictures)

The default folder path from then on is the

path that you last used to import a picture.

2.  If the default folder path is not the path

you require, click on the arrow to the right

of the “Look in” combo box and select a new

folder path.

The “Recent” combo box at the bottom left of

the Import picture dialog box allows you to

select a new folder path from recently used

folder paths. 

This area will appear blank if you have not

previously used another directory. 

3.  The icons across the top of the dialog box

are general Windows functions.

4.  From the “Files of Type” combo box, click

on the arrow to the right and select the type

of file format you wish to view.

You can select to view a single file type or

you can view all file types at once.

5. Select the picture you want to import.

The selected thumbnail and filename are

now highlighted.

The Details box at the bottom right of the 

Import picture dialog box displays the rele-

vant information for the file that you have

selected. 

The details include Size, Pixels, Resolution

and Type of file.

Holding down the Shift key whilst

selecting a file will allow you to multiple

select a range of files.

Holding down the Ctrl key whilst selecting a

file will allow you to select multiple files at

random.

6. The file name edit box will show the file

name of the picture you have selected. If you

have multiple pictures selected the file name

showing will be the last picture you selected.
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7. The “Save in” edit box shows the folder

path to which your pictures will be

imported. This defaults to the folder you

have set up for your Pictures in Preferences.

To change this folder path, click the “Save in”

button and select a new folder path.

8. The “As type” combo box shows the file

format of the imported file.

To change this type of file format, click on

the arrow to the right of the combo box and 

select the type of file format for your new

file. 

9. The “Color” combo box shows the color

model of the imported file. 

To change the color model, click on the

arrow to the right of the combo box and

select the color model you require.
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10. Click on the Import button OR double-

click on the picture you have selected.

The Import dialog box will close and the

Task Manager will open showing you the file

is processing. 

This processing involves converting the

foreign file into a DCM Picture file (.dcm).

After the file has finished processing the

picture has been imported into the specified

folder.

11. If you are importing a picture into a

folder that has a picture of the same name, a

warning dialog box as shown below will

appear.

Clicking No will cancel the Import picture.

Clicking Yes will bring up the “Save As” dialog

box. 

12. Type in your new file name in the File

name edit box.

13. Save as Type will be the file format that

you selected in the Import picture dialog

box.

14. Click Save.

To close the Import picture dialog box,

either click on the Cancel button, or click on

the dialog’s close box. (The cross at the top

right of the box.)      

Importing Kodak Photo CD pictures
If you are importing Kodak Photo CD

pictures the following dialog box will appear

after you have selected the file you want to

import and clicked on the Import button.

1.  Select the size of the picture you require

by clicking on the arrow to the right of the

Size dialog box and scrolling down the list.

2.  Key in the Resolution you require in the

Resolution edit box.

Right-mouse clicking on the Resolution

edit box will give you the following resolu-

tion measurement options: 

Pixels/mm:  pixels per millimetre

Pixels/cm:   pixels per centimetre

dpi: dots per inch

3.  If a password is required to import the

selected Kodak Photo CD picture, type in the

password in the Password edit box.
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4.  If you have selected more than one

picture to import and you want them to have

the same size and resolution click on the

‘Apply To All’ checkbox.

5.  Click OK.

The dialog box will close and the Task

Manager will open showing you the file is

processing. 

This processing involves converting the

Kodak Photo CD picture file (.pcd) into a

DCM Picture file (.dcm).

After the file has finished processing the

picture has been imported into the specified

folder.

Opening pictures
As we said earlier in this chapter, there are

two ways of creating a new document in

Wright Design.

You can either open a picture to do some

retouching and enhancements, or you can

create a new document to start producing

your work from a blank page.

The Open picture command opens the

picture you select and also creates a docu-

ment with the dimensions of the selected

picture.

The picture you select can be a DCM format

picture (.dcm;.spl) or any of the following

foreign file formats.

Including: TIFF (.tif)

JPEG (.jpg)

EPS (.eps)

PNG (.png)

BMP (.bmp)

Targa (.tga, .vda, .vst, .icb)

Scitex CT (.sct)

Photoshop (.psd) 

Compuserve GIF (.gif)

PICT (.pct, .pic)

You cannot use Open Picture to open

Kodak Photo CD (.pcd) pictures. You have to

use Import Picture to import the pictures

into DCM Picture file format. 

To open a picture:

1.  Choose File > Open Picture.

The Open picture dialog box will open. The

original default folder path will be the path

that is set for Pictures in your Folder prefer-

ences. 

(File > Preferences > Folders > Pictures)

The default folder path from then on is the

path that you last used to open a picture.

2.  If the default folder path is not the path

you require, click on the arrow to the right

of the “Look in” combo box and select a new

folder path.
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The “Recent” combo box at the bottom left of

the Open picture dialog box allows you to

select a new folder path from recently used

folder paths. 

This area will appear blank if you have not

previously used another folder.

3.  The icons across the top of the dialog box

are general Windows functions.

4.  From the “Files of Type” combo box, click

on the arrow to the right and select the type

of file format you wish to view.

You can select to view a single file type or

you can view all file types at once.

5.  Select the picture you want to open. 

The selected thumbnail and filename are

now highlighted.
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The Details box at the bottom right of the 

Open picture dialog box displays the rele-

vant information for the file that you have

selected. 

The details include Size, Pixels, Resolution

and Type of file.

Holding down the Shift key whilst

selecting a file will allow you to multiple

select a range of files.

Holding down the Ctrl key whilst selecting a

file will allow you to select multiple files at

random.

6. The file name edit box will show the file

name of the picture you have selected. If you

have multiple pictures selected the file name

showing will be the last picture you selected. 

7. Click on the Open Picture button OR

double-click on the picture you have

selected.

The Open picture dialog box will close, a

document the exact size of your picture is

created and the Task Manager will open

showing you the file is processing.

This processing involves converting the

foreign file into a DCM Picture file (.dcm)

and opening the picture. This is a back-

ground function, therefore allowing you to

perform other functions during the

processing time. 

After the file has finished processing the

picture is placed and the Task Manager

closes. 

To close the Open picture dialog box,

either click on the Cancel button, or click on

the dialog’s close box. (The cross at the top

right of the box.)      

Creating a new document
In Wright Design you are always working

with a document.

The document consists of:

The page, which is the white area bounded

with a drop shadow that represents the

documents printable page area. 

The pasteboard, which is the area to the left

and right of the page area. Objects created

and placed on the pasteboard are saved with

the document but do not print.

When you create a new document, you can

specify a name, paper size, positions of

margin guides and resolution. 

To create a new document:

1.  Choose File > New. (Ctrl + N)

The New Document dialog box will open.
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2.  Type in a name for your document in the

Name edit box. The default name is Untitled.

If desired, you can type in any special notes

about the document in the Comments edit

box.

3.  Select a page size from the Page Size

combo box. There are many sizes available,

or select custom page. 

You do have the option of skipping this Step

and going directly to the Dimensions edit

box. 

4.  To specify the unit of measurement select

from the combo box to the right of the

Dimensions edit box. You can select from

mm, cm, Inches, Points or Pixels.

5.  If you have selected custom page or

skipped Step 3, key in the dimensions of

your page in the Dimensions edit box.

The width is the first dimension followed by

the height.

5.  Click on the landscape check box if you

want your page orientation to be landscape.

(ie. the width is greater than the height.)
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6.  To specify the position of margin guides

(nonprinting lines that you use to position

items on a page), enter values in the fields in

the Margin edit boxes.

Right mouse-clicking on the margins

will give you the following units of measure-

ment to choose: mm, cm, Inches, Points,

Pixels and Application default or you can

type in the abbreviations for these measure-

ments.  

Application default is the unit of measure-

ment you have selected under Dimensions in

the New Document dialog box. (Step 4)

7.  To set the document resolution, key in

the resolution you require in the Resolution

edit box. 

Right-mouse clicking on the Resolution

edit box will give you the following resolu-

tion measurement options: 

Pixels/mm:  pixels per millimetre

Pixels/cm:   pixels per centimetre

dpi: dots per inch

7.  Click OK. A document is now created to

the specifications you have set above and as

shown below.

Changing your document
Your document setup can be changed at any

time.

To change your document setup:

1.  Choose File > Document Setup.

The Document Setup dialog box will open.

2.  You can now change any of the

Document setup attributes that you set when

you created the document. 

These attributes are File name, Comments,

Page Size, Dimensions, Units of

Measurement, Margins and Resolution.

3.  The ‘Keep aspect ratio’ checkbox at the

bottom right of the dialog box when checked

allows you to change one page size dimen-

sion and the other page size dimension will

automatically change keeping the aspect

ratio of your page. 

4.  If you have changed the page size or the

dimensions of your document and you have
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objects on your page, the positioning of

these objects will be affected.

The three options to choose from as to how

the objects on your page behave when the

document size has been changed are:

Change page size only: where the docu-

ment size changes from its origin but the

objects on the page stay where they are.

Center features:  where the document size

changes from its origin and the objects are

centred within the new page.

Scale features: where the document size

changes from its origin and the objects on

the page are scaled in proportion to the

document size change. If the document size

change is not proportional both horizontally

and vertically, a warning message box will

open asking if you want to continue, as this

will distort the objects on your page.

4.  Click OK. The changes you have just

made will be applied to your document.

Placing a picture
After you have created a document, you can

place a picture into the document. 

The Place picture command places the

selected picture onto your page at the exact

size that it has been produced.

The picture you select can be a DCM Picture

file (.dcm;.spl) or any of the following

foreign file formats.

Including: TIFF (.tif)

JPEG (.jpg)

EPS (.eps)

PNG (.png)

BMP (.bmp)

Targa (.tga, .vda, .vst, .icb)

Scitex CT (.sct)

Photoshop (.psd) 

Compuserve GIF (.gif)

PICT (.pct, .pic)
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You cannot use Place Picture to place

Kodak Photo CD (.pcd) pictures. You have to

use Import Picture to import the pictures

into DCM Picture file format. 

To place a picture:

1.  Make sure you have a document open.

2.  Choose File > Place Picture. (Ctrl + P)

The Place dialog box will open. The original

default folder path will be the path that is set

for Pictures in your Folder preferences. 

(File > Preferences > Folders > Pictures)

The default folder path from then on is the

path that you last used to place a picture.

3.  If the default folder path is not the path

you require, click on the arrow to the right

of the “Look in” combo box and select a new

folder path.
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The “Recent” combo box at the bottom left of

the Place dialog box allows you to select a

new folder path from recently used folder

paths. 

This area will appear blank if you have not

previously used another folder.

4.  The icons across the top of the dialog box

are general Windows functions.

5.  From the “Files of Type” combo box, click

on the arrow to the right and select the type

of file format you wish to view.

You can select to view a single file type or

you can view all file types at once.

6. Select the picture you want to place.

The selected thumbnail and filename are

now highlighted.

The Details box at the bottom right of the 

Place dialog box displays the relevant infor-

mation for the file that you have selected.

The details include Size, Pixels, Resolution

and Type of file.

Holding down the Shift key whilst

selecting a file will allow you to multiple

select a range of files.

Holding down the Ctrl key whilst selecting a

file will allow you to select multiple files at

random.

In Preferences > General, there is an

option ‘Place pictures as CMYK’. If this is

checked, all pictures that you place will be

converted to CMYK color model.

7. The file name edit box will show the file

name of the picture you have selected. If you

have multiple pictures selected the file name

showing will be the last picture you selected.

8. Click on the Place button.

The Place dialog box will close and the Task

Manager will open showing you the file is

processing.

This processing involves converting the

foreign file into DCM Picture file format

(.dcm;.spl) and placing the picture onto an

opened page. 

After the file has finished processing the

picture is placed and the Task Manager

closes.

To close the Place dialog box, either

click on the Cancel button, or click on the

dialog’s close box. (The cross at the top right

of the box.)      
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Changing resolution
In Wright Design you can change the resolu-

tion of a picture, as long as it is in DCM

Picture file format (.dcm;.spl). 

To change the resolution of a picture:

1.  If your Paint Style palette is not open,

choose Windows > Palette > Paint Style.

(F2)

The Paint Style palette will open.

3.  Select the Picture layer type. (This is the

fourth paint style along as shown in the

picture  below).

4.  The picture paint style icon will now

show in the box to the right of the Fill

button and a picture will appear in the box

with the checkerboard background. 

If there is not a picture already selected, the

Open picture dialog box will open.

Otherwise, click on the Select button to the

right of the checkerboard box.

The Open picture dialog box will now open.

The original default folder path, will be the

path that is set for Pictures in your Folder

preferences. 

(File > Preferences > Folders > Pictures)

The default folder path from then on is the

path that you used to open a picture.

5.  If the default folder path is not the path

you require, click on the arrow to the right

of the “Look in” combo box and select a new

directory path.

The “Recent” combo box at the bottom left of

the Open picture dialog box allows you to

select a new directory path from recently

used directory paths. 
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This area will appear blank if you have not

previously used another directory. 

6.  The icons across the top of the dialog box

are general Windows functions.

7.  From the “Files of Type” combo box, the

only file type that you can select is DCM

(.dcm;.spl)

8.  Select the picture whose resolution you

wish to change.

The selected thumbnail and filename are

now highlighted.

The Details box at the bottom right of the 

Open picture dialog box displays the rele-

vant information for the file that you have

selected. 

The details include Size, Pixels, Resolution

and Type of file.
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Holding down the Shift key whilst

selecting a file will allow you to multiple

select a range of files.

Holding down the Ctrl key whilst selecting a

file will allow you to select multiple files at

random.

9.  The file name edit box will show the file

name of the picture you have selected. If you

have multiple pictures selected the file name

showing will be the last picture you selected. 

10. Click on the Change Res button.

The Set new Picture Resolution dialog box

will open.

12.  Type in the resolution you require and

click OK.

Right mouse-clicking on the Resolution

edit box will give you the following resolu-

tion measurement options: 

Pixels/mm:  pixels per millimetre

Pixels/cm:   pixels per centimetre

dpi: dots per inch

The thumbnails will redraw. If you select the

picture whose resolution you just changed,

you will see its new resolution in the Details

box.

If you have already placed a picture

onto your page before changing its resolu-

tion, Wright Design remembers its old reso-

lution. 

Saving a document
After you open a new document, you can

choose ‘Save’ to save the document to a

specified folder. A Wright Design document

has the extension .wdd.

Once you have saved a document, selecting

Save retains the changes you have made

since the last time you selected Save. 

While you are working on a document, it is

important to save your changes periodically

to reduce the risk of losing work in the event

of system failure, power failure, etc.

You can choose Save As to save a copy of a

document to another folder/or drive, or to

save a copy of the document under a

different name.

To save a new document:

1.  Choose File > Save. (Ctrl + S)

The Save As dialog box will open. The orig-

inal default folder path, will be the path that

is set for Documents in your Folder prefer-

ences. 

(File > Preferences > Folders > Documents) 

The default folder path from then on is the

path that you used when you last opened or

saved a document.
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2.  If the default folder path is not the path

you require, click on the arrow to the right

of the “Save in” combo box and select a new

folder path.

3.  The icons across the top of the dialog box

are general Windows functions.

4.  You have the option here of renaming

the document. To rename the document,

enter a name in the File name edit box.

5.  Click Save. Your document will now be

saved with the file name you specified, to the

folder you specified.

To save changes to a document:

1.  To save changes to a document that has

been previously saved, choose File > Save.

(Ctrl + S)

The disk version will be updated with the

changes you have made since the last time

you saved it.

To create a copy of a document:

1.  Choose File > Save As. (Ctrl + Shift + S)

The Save As dialog box will open. The orig-

inal default folder path will be the path that

is set for Documents in your Folder prefer-

ences. 

(File > Preferences > Folders > Documents) 

The default folder path from then on is the

path that you used when you last opened or

saved a document.

2.  To save a copy of a document using Save

As, you must either rename it or save it to a

different folder and/or drive from the one in

which the original document is saved. If the

default folder path is not the path you

require, click on the arrow to the right of the

“Save in” combo box and select a new folder

path.

3.  The icons across the top of the dialog box

are general Windows functions.

4.  You have the option here of renaming

the document. To rename the document,

enter a name in the File name edit box.

5.  Click Save. Your document will now be

saved with the file name you specified, to the

drive you specified.
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Opening a document
Documents that have been saved in Wright

Design can then be opened at any time. 

The document file types that can be opened

are: Design 2.0 format (.wdd) 

OR Design 1.0 format (.pag) .

To open a document:

1.  Choose File > Open. (Ctrl + O)

The Open document dialog box will open.

The original default folder path, will be the

path that is set for Documents in your Folder

preferences. 

(File > Preferences > Folders > Documents) 

The default folder path from then on is the

path that you used when you last opened or

saved a document.
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2.  If the default folder path is not the path

you require, click on the arrow to the right

of the “Look in” combo box and select a new

folder path.

The “Recent” combo box at the bottom left of

the Open document dialog box allows you to

select a new folder path from recently used

directory paths. 

This area will appear blank if you have not

previously used another folder.

3.  The icons across the top of the dialog box

are general Windows functions.

4.  From the “Files of Type” combo box, click

on the arrow to the right and select the type

of document you wish to open.

You can select to view a single document

type, all document types or, you can view all

file types at once.

5.  Select the document you want to open. 

The selected thumbnail and filename are

now highlighted.

The Details box at the bottom right of the 

Open document dialog box displays the rele-

vant information for the document that you

have selected. 

The details include Size and Type of file.

Holding down the Shift key whilst

selecting a file will allow you to multiple

select a range of files.

Holding down the Ctrl key whilst selecting a

file will allow you to select multiple files at

random.

6. The file name edit box will show the file

name of the document you have selected. If

you have multiple documents selected the

file name showing will be the last document

you selected. 

7. Click on the Open button OR double-click

on the document you have selected.

The Open document dialog box will close,

and the selected document will open. 

If you are opening multiple documents, the

last selected document will be opened last.

To access the other open documents, choose

Window > “File name” at the bottom of the

Windows list.

To close the Open document dialog

box, either select the Cancel button or click

on the dialog’s close box. (The cross at the

top right of the box.)      

To relink missing elements
1.  If there are fonts or pictures missing from

the document you are opening the ‘Relink

Missing Elements’ dialog box will open. 
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2.  To replace the font(s) that are missing

select the ‘Fonts’ tab at the top left of the

dialog box.

3.  Highlight the original font, click on the

arrow to the right of the font combo box and

select the font that you require.

The box to the right of the font combo box

displays each font as it is highlighted.

The folder and filename of the replacement

font will now display to the right of the orig-

inal font.

Follow this procedure for all fonts that need

replacing.

4.  To relink pictures that are missing select

the ‘Pictures’ tab at the top left of the dialog

box.

5.  Highlight the original picture that you

wish to link.

6.  Click on the Browse button.

The Picture dialog box will open.

7.  Select the picture you wish to relink to

your document.

The filename of the picture you are looking

for is displayed at the top right of the dialog

box.

8.  Click on the Open button. 

The folder and filename of the replacement

picture will now display to the right of the

original picture.

If there are more pictures to be replaced

with the same filename that are resident in

the folder that you selected a dialog box will

display asking you “Do you wish to link other

pictures in this folder.”

Clicking Yes will relink the pictures in the

selected folder that have the same filename

as those pictures that need to be replaced.

Clicking No will not update any other

pictures.

Follow this procedure for other pictures that

need replacing that are not in the folder you

selected.

9.  Click on the OK button.

Your pictures will now be relinked.
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Closing a document
1.  Choose File > Close. (Ctrl + W)

The open document will close.

If you have not saved your document, or you

have made changes since the last time you

saved your document, you will receive the

following warning:

2.  Clicking No will close the document

without saving it.

If you have saved the document prior to any

changes, clicking Yes will save the document

and then close it, 

If you have not saved the document, clicking

Yes will open the “Save As” dialog box.

3. Type in your new file name in the File

name edit box.

4. Click Save.

If you try to close a document that has

tasks running in the background a dialog box

will display saying, “There are background

tasks using this document.” You must cancel

these tasks using the Task Manager before

you can close the document.
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T o understand how color is measured

and how Wright Design uses this infor-

mation to define, display and print

color values requires some familiarity.

Every device used to create a color publica-

tion - be it a scanner, color monitor, color

desktop printer, or a commercial printing

press - reproduces a different range of color. 

Scanners and color monitors use a different

color model to describe color from that used

by color desktop printers and commercial

printing presses. As colors are moved from

the computer screen to the printing press,

they’re converted from one color space to

another, so your printed results don’t exactly

match the same colors you see on screen.

This chapter discusses several color models

and how Wright Design uses these color

models. It then describes the process used

to convert pictures from one file format to

another and/or from one color model to

another.

Finally, we go through and describe how

Wright Design uses color channels, how

these color channels can be viewed, how to

read color values and all about calibration.

Color Models
In Wright Design you can choose to work

with a number a color models. These models

are based on established color models for

describing and reproducing color.

The two most common models for pictures

are RGB (red, green and blue) and CMYK

(cyan, magenta, yellow and black). 

Wright Design uses another common model

- hue, saturation and brightness (HSB) - to

represent color in layers from the paint style

palette. Other color models used include:

grayscale, 3 channel grayscale, HIFI and

PANTONE®. 

Another option found in the color model

combo box is Alpha channel. This is used to

blend paint styles.

RGB color model
A large percentage of the visible spectrum

can be shown by mixing three basic compo-

nents of colored light in various proportions

and intensities. These components are

known as the primary colors: red, green and

blue (RGB).

As the primary colors combine to create

white, they are also called additive colors.

Additive colors are used in lighting, video,

film recorders, and monitors. 
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In Wright Design, each pixel in a RGB color

picture is assigned an intensity value ranging

from 0 (black) to 255 (white). For example, a

bright green color might have a R value of

40, a G value of 255 and a B value of 60.

When the value of all three components are

equal, the result is a shade of grey. When the

value of all components is 255, the result is

pure white. When all components have

values of 0, the result is black.

The RGB color model can be used in the

following paint styles in Wright Design:

Tint

Tint Adjust

Color Curve

Picture

Filters

Gradient

RGB is the mode to use when preparing a

file to output to transparency or to use on

screen for multimedia and the internet.

CMYK color model
The CMYK color model is based on the light-

absorbing quality of ink printed on paper. As

white light strikes translucent inks, a portion

of the spectrum is absorbed. Color that is

not absorbed is reflected back to the eye.

In theory, cyan, magenta and yellow

pigments should combine to absorb all color

and produce black. For this reason, they are

also called subtractive colors. Because all

printing inks contain some impurities, these

three inks actually produce a muddy brown

color and must be combined with black ink

to produce a true black. 

In Wright Design, each pixel in a CMYK

picture is assigned a percentage value for

each of the process inks. The lightest (high-

light) colors are assigned small percentages

of process ink colors and the darker

(shadow) colors have higher percentage

values. For example, a bright green might

contain 84% cyan, 5% magenta, 76% yellow

and 0% black. In CMYK pictures, pure white

is generated when all four components have

values of 0%. 

The CMYK color model can be used in the

following paint styles in Wright Design 

Tint

Tint Adjust

Color Curve

Picture

Filters

Gradient

CMYK is the mode to use when preparing a

file for print. 

HSB color model
The HSB color model is based on the human

perception of color. All colors are described

in terms of the following three fundamental

characteristics:

Hue: is a wavelength of light reflected from

or transmitted through an object. Hue is

identified by the name of a color such as

green.

Saturation: is the strength of color.

Saturation represents the amount of grey in

proportion to the hue and is measured as a

percentage from 0% (gray) to 100% (fully

saturated).
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Brightness: is the relative lightness or dark-

ness of the color and is measured as a

percentage from 0% (black) to 100% (white).

The HSB color model can be used in the

following paint styles in Wright Design:

Tint

Tint Adjust

Color Curve

Filters

Gradient

Grayscale color model
The grayscale color model uses up to 256

shades of gray to represent a picture. 

In Wright Design, if you are working in RGB

viewing mode, every pixel of a grayscale

picture has a brightness ranging from 

0 (black) to 255 (white).

If you are working in CMYK viewing mode,

grayscale values are measured as percentages

of black (0% is equal to white and 100% is

equal to black). 

The Grayscale color model can be used in

the following paint styles in Wright Design: 

Tint

Tint Adjust

Color Curve

Picture

Filters

Gradient

3 Channel Gray color model
The  3 channel gray color model uses up to

256 shades of gray to represent a picture. It

is different to the grayscale color model as it

applies the 256 shades of gray to the cyan,

magenta and yellow channels and not the

black channel. 

In Wright Design, if you are working in

CMYK viewing mode, the grayscale values are

measured as percentages of cyan, magenta

and yellow. (0% is equal to white and 100% is

equal to black).

This color model does not have any effect if

you are working in RGB viewing mode.

The 3 channel gray color model can be used

in the Picture paint style in Wright Design.

PANTONE® color model
PANTONE® colors are premixed inks that

designers often specify for spot colors.

PANTONE® Color printing inks are widely

used because each color is standardized and

cataloged. 

There are fourteen PANTONE® Color selec-

tors (lists from which you can select

PANTONE® Colors). These lists display the

catalog of PANTONE® Colors available in

Wright Design.

In Wright Design, the PANTONE® color

model is used to add spot colors to your

document.

The PANTONE® color model can be used in

the following paint styles in Wright Design:

Tint

Tint Adjust

Filters

Gradient



HIFI color model
The HIFI color model contains multiple

channels including spot colors. Each channel

has 256 shades of grey and there is no limit

to the amount of channels in a HIFI picture. 

In Wright Design you can save a document

containing CMYK and spot colors, as a

picture. All spot colors will be retained - they

will not be converted to CMYK.

Alpha channel
The Alpha channel uses up to 256 levels of

opacity. Each shade of grey acts as an opacity

mask. 

In Wright Design, the Alpha channel is used

to control the blend between paint styles or

between a paint style and the background. 

The Alpha channel can be used in the

following paint styles in Wright Design:

Tint

Color Curve

Picture

Gradient

Converting Pictures
The Convert picture command allows you to

convert pictures from one format to another

and/or from one color model to another.

The picture you select to convert, and the

file format you wish to convert the picture

to, can be any of the following file formats.

The color models that each format supports

are also shown.

DCM (.dcm;.spl) - HIFI, CMYK, RGB,

Grayscale.

TIFF (.tif) - CMYK, RGB, Palette, Grayscale, 

Bilevel, CMYK Alpha, RGB Alpha, 

Palette Alpha, Grayscale Alpha.  

JPEG (.jpg) - CMYK, RGB, Grayscale. 

EPS (.eps) - CMYK, RGB, Grayscale, Bilevel.

PNG (.png) - RGB, Palette, Grayscale.

BMP (.bmp) - RGB, Palette, Bilevel.

Targa (.tga, .vda, .vst, .icb) - TRUECOLOR, 

Palette, 

Grayscale. 

Scitex CT (.sct) - CMYK, RGB, Grayscale.

Photoshop (.psd) - CMYK, RGB, Palette, 

Grayscale, Bilevel.  

Kodak Photo CD (.pcd) - RGB, Grayscale, 

Palette

Compuserve GIF (.gif) - Palette.

PICT (.pct, .pic) - 

Kodak Photo CD pictures are READ

only.   
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To convert a picture:

1.  Choose File > Convert Picture. 

(Ctrl + Shift C)

The Convert picture dialog box will open.

The original default folder path, will be the

path that is set for Pictures in your Folder

preferences. 

(File > Preferences > Folders > Pictures) 

The default folder path from then on is the

path that you last used to import a picture.

2.  If the default folder path is not the path

you require, click on the arrow to the 

right of the “Look in” combo box and select a

new folder path.

The “Recent” combo box at the bottom left of

the Convert picture dialog box allows you to

select a new folder path from previously

used folder paths. 
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This area will appear blank if you have not

previously used another directory. 

3.  The icons across the top of the dialog box

are general Windows functions.

4.  From the “Files of Type” combo box, click

on the arrow to the right and select the type

of file format you wish to view.

You can select to view a single file type or

you can view all file types at once.

5. Select the picture you want to convert.

The selected thumbnail and filename are

now highlighted.

The Details box at the bottom right of the 

Convert picture dialog box displays the rele-

vant information for the file that you have

selected. 

The details include Size, Pixels, Resolution

and Type of file.

Holding down the Shift key whilst

selecting a file will allow you to multiple

select a range of files.

Holding down the Ctrl key whilst selecting a

file will allow you to select multiple files at

random.

6. The file name edit box will show the file

name of the picture you have selected. If you

have multiple pictures selected the file name

showing will be the last picture you selected.

7. The “Save in” edit box shows the directory

path where your pictures will be saved after

they have been converted. This defaults to

the folder you have set up for your Pictures

in Preferences.

To change this directory path, click the “Save

in” button and select a new directory path.

8. The “As type” combo box shows the file

format you require.

To change the type of file format, click on

the arrow to the right of the combo box and

select the file format you require for the new

picture.

9. The “Color” combo box allows you to

select the color model of the file you

require.

To change this color model, click on the

arrow to the right of the combo box and

select the color model you require for your

new picture.

10. Click on the Convert button OR double-

click on the picture you have selected.

The Convert dialog box will close and the

Task Manager will open showing you the file

is processing. 

This processing involves converting the

picture from its original file format to the file

format that you have selected.

After the file has finished processing the

picture has been converted into the speci-

fied folder.

11. If you are converting a picture into a

folder that has a picture of the same name, a

warning dialog box as shown below will

appear.
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Clicking No will cancel the Convert picture.

Clicking Yes will bring up the “Save As” dialog

box. 

12. Type in your new file name in the File

name edit box.

13. Save as Type will be the file format that

you selected in the Convert picture dialog

box.

14. Click Save.

To close the Convert picture dialog box

either click on the Cancel button, or click on

the dialog’s close box. (The cross at the top

right of the box.)       

Color Channels
Every picture you use in Wright Design

contains one or more channels. These chan-

nels represent information about the color

elements in the picture.

A CMYK picture always contains four chan-

nels, one containing cyan information, one

containing magenta information, one

containing yellow information and one

containing black information.

By default, a grayscale picture has one

channel and a RGB picture has 3 channels. A

HIFI picture for output can have unlimited

channels.

In Wright Design you can view each of these

channels separately. This view will display all

picture information for the channel you have

selected to view, and any other information

that is in your document for the selected

channel. 

To view channels:

1.  If you are working in CMYK mode choose

View > CMYK / Spot > and the channel you

wish to view. (ie. cyan) 

If you are working in RGB mode choose 

View > RGB > and the channel you wish to

view. (ie. red)

2.  The screen will now show the channel

that you have selected.

3.  To go back to your original view or to

view a different channel:                                    

If you are working in CMYK mode, choose

View > CMYK / Spot > and the channel you

wish to view.
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If you are working in RGB mode, choose

View > RGB > and the channel you wish to

view.

Measuring color values
You can determine the color values of any

part of your document using the color

readout on the status line if you are viewing

your document in CMYK or RGB.  For any

spot colors values use the Spot Colors

palette.

As you move the cursor over your document

a 1 x 1 pixel area is sampled and the result is

shown in the color readout on the status

line.
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To measure color values:

1.  Place the cursor on your document at the

point where you want to read the color

values.

2.  The color readout on the status line will

give you your color values.

CMYK if you are in CMYK view mode.

RGB if you are in RGB view mode.

Keep moving the cursor to read other color

values.

If you are in CMYK view mode you can also

view the color values of spot colors.

To measure spot color values:

1. Choose Window > Palettes > Spot Colors

(F9)

The Spot Colors palette will open. 

2.  Place the cursor on your document at the

point where you want to read the spot color

values.

The Spot Color palette will display a box

showing the color you are reading, a dot

percentage of the color being used and the

name of the color. There is a checkbox to

display the full name of the spot color. 
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Calibration
Many of the problems that arise when trying

to reproduce colors from a computer stem

from the fact that the total set of colors

produced by the red, green and blue phos-

phors of a computer monitor are different to

cyan, magenta, yellow and black inks used in

traditional printing.

The colors in your final artwork may not only

vary from print to on-screen, but also

between output devices and software

programs, that is between two different

monitors or printers or even between

different software packages.

In Wright Design you can use the Gamma

and Calibration tools to ensure as close a

match as possible between your colors on-

screen and your final output.

Use the Gamma preference to eliminate any

color cast in your monitor and to ensure that

your monitor displays gray levels as neutral

as possible.

This will help to display colors in a consis-

tent way on different monitors.

The Calibration preference allows you to

setup calibration settings. These settings are

used to make the picture on-screen match

your output. 

To set your Monitor calibration (Gamma)

see page 35.

To set your Calibration see page 37.
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Chapter 5 - Creating Objects

W right Design is a truly object based

application. Each object is self

contained and independent of any

other object. All objects are editable at any

time which means that multiple versions of a

design can be saved (occupying very little

disk space), recalled and edited easily.

Objects may be positioned accurately by

keying their dimensions and positions or by

using rulers and guides and snap-to-guide

tools. Each object or a group of objects may

be locked into position to prevent accidental

movement. Objects may also be hidden from

view.

Each object is listed in the Object List

palette. The objects are listed in the order of

their display priorities and may be moved to

a higher or lower priority by dragging the list

entry up or down the object list. 

Each entry in the Object List has a thumbnail

preview. When an object is created, it is

automatically given a name, however, you

can change this name to whatever you like

from the Object List. You may also select,

delete, copy, lock or edit objects from the

Object List.

In this chapter we will go through the use of

rulers, guides and grids and how they assist

you in creating objects and laying out your

page.

We will also discuss the different types of

objects that you can create in Wright Design.

These are: Vector objects, Bitmap objects,

Text objects and Picture objects. You will

learn how to create these objects and how to

convert from one type of object to another.

Layout tools
Wright Design enables you to create and

position objects by clicking and dragging the

mouse or by dimension.

The technique of clicking and dragging is

only as accurate as your monitor’s resolu-

tion. To make the click and drag method

more precise Wright Design provides a

number of on-screen layout tools.

Rulers
Rulers are displayed by default along the top

and down the left hand side of the Wright

Design screen when you create a new docu-

ment or open a picture for the first time.

You then have the option of displaying or

hiding your rulers.

You can drag out horizontal and vertical

ruler guides from the rulers and align objects

to them.

To display rulers:

1.  Choose Guides > Show Rulers. 

(Ctrl + Alt + R)

A checkmark appears next to the command

and the rulers will be displayed.



The units of measurement of your rulers will

depend on what you have set in your prefer-

ences.

To change the units of measurement:

1.  Choose File > Preferences > General.

2.  In the Measurement Units combo box,

click on the arrow and select the unit of

measurement you wish to work in. The

choices are: Millimeters (mm)

Centimetres (cm)

Inches

Points

Pixels

This unit of measurement will now be the

“Application Default”.

3.  Click OK.

The rulers will now change to the new unit

of measurement.

To hide the rulers:

1.  Choose Guides > Show Rulers. 

(Ctrl + Alt + R)

The checkmark disappears next to the

command and the rulers are hidden.

To set snap to rulers:

If “Snap to Rulers” is selected, any guide

created by dragging will snap to each incre-

ment along the ruler. 

1.  Make sure your rulers are displayed.

1. Choose Guides > Snap to Rulers.

(Ctrl + Alt + A)

A checkmark appears to show you “Snap to

Rulers” is on.

Guides
Guides are horizontal and vertical lines

created by dragging out from the rulers. In

Wright Design you can also angle the guides

after you have dragged them onto your page.

When Snap to Guides (Guides menu) is

checked, your cursor will snap to the guides

if it is within the user-specified snap

distance, as you are creating objects. 

Guides help you to lay out your page but do

not print with your page.

To create guides by dragging:

1.  Make sure your rulers are displayed.

2.  Choose Guides > Show Guides.

(Ctrl + M)

If you have guides created previously they

will display.

3.  To create a vertical guide, using any tool,

click on the ruler at the left of your screen,

and drag the guide into place.

4.  To create a horizontal guide, using any

tool, click on the ruler at the top of your

screen, and drag the guide into place.

If you release the cursor over the page

when positioning a guide, the guide will only

appear in the page area. This is called a Page

guide.

If you release the cursor outside the page

when positioning a guide, the guide will

appear vertically or horizontally across the

entire screen. This is called a Document

guide.
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As you drag your guides into position the

Status bar shows you a readout of the angle

of the guide you are positioning.

If a cross appears whilst you are

creating guides it means that you cannot

position the guide at that particular point.

Page Guides

Document Guides

To create a grid of guides:

1.  Choose Guides > Show Guides.

(Ctrl + M)

If you have guides created  previously they

will display.

2.  Choose Guides > Create Guides.

The Create Guides dialog box will open.

3.  Select the orientation for your guides.

4.  In the Number of guides edit box type in

the number of guides you require to be

created.

5.  In the Position edit box type in where

you would like the first guide to be posi-

tioned on your page.

6.  In the Spacing edit box type in the

spacing you would like between each of the

guides.

7.  You can now click on the Apply button to

see your guides. This enables you to add

more guides if desired without exiting from

the Create Guides dialog box.

8.  Click OK.

To angle guides:

This will only work with Page guides. (ie.

guides that are only visible inside your page

area.)

1.  Make sure your guides are displayed.

2.  Click on the Select tool .

3.  Place your cursor at the edge of your

page and over the guide that you wish to

move.
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4.  When your cursor changes to a four-

headed arrow click and move the guide.

You can do this to both ends of your guide.

As you drag your guides the Status bar shows

you a readout of the angle of the guide you

are moving.

To move guides:

1.  Make sure your guides are displayed.

2.  Click on the Select tool .

3.  Position the cursor over the guide you

wish to move. When the cursor changes to a

double-sided arrow, click on the guide and

move it.

OR

1.  Make sure your guides are displayed.

2.  Click on the Select tool .

3.  Position the cursor over the guide you

wish to move.

4.  When the cursor changes to a double-

sided arrow, right mouse-click on the guide

and move it to the required position.

A  drop down menu will appear.

5.  Scroll down the menu and select ‘Move

Guide Here’.

The guide will now be moved.

As you drag your guides the Status bar shows

you a readout of the angle of the guide you

are moving.

To copy guides:

1.  Make sure your guides are displayed.

2.  Click on the Select tool .

3.  Position the cursor over the guide you

wish to copy. 

4.  When the cursor changes to a double-

sided arrow, hold down the Ctrl key on your

keyboard, click on the guide and move the

copy to the required position.

OR

1.  Make sure your guides are displayed.

2.  Click on the Select tool .

3.  Position the cursor over the guide you

wish to copy. 

4.  When the cursor changes to a double-

sided arrow, right mouse-click on the guide

and move the copy to the required position.

A  drop down menu will appear.

5.  Scroll down the menu and select ‘Copy

Guide Here’.

The guide will now be copied. 

To delete a single guide:

1.  Make sure your guides are displayed.

2.  Click on the Select tool .

3.  Position the cursor over the guide you

wish to remove. When the cursor has

changed to a double-sided arrow, click on

the guide and move it back to the ruler. The

guide will then be removed.
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To delete all guides:

1.  Make sure your guides are displayed.

2.  Choose Guides > Clear Guides.

The following dialog box will open.

3.  Select yes to delete all the guides from

the document you are working on.

Selecting no will cancel the dialog box.

To hide guides:

1.  Make sure your guides are displayed.

2.  Choose Guides > Hide Guides.

(Ctrl + M)

To show hidden guides:

1.  Choose Guides > Show Guides.

(Ctrl + M)

To lock guides into position:

1.  Choose Guides > Lock Guides.

(Ctrl + Alt + M)

The checkmark appears and your guides are

locked. This can be done even if your guides

are not displayed.

A circle with a line through it will

display if you are trying to create a guide(s)

when guides are not displayed or if you are

trying to move a guide(s) that is locked. 

To set snap to guides:
If “Snap to Guides” is selected, an object

created within the snap distance (set in File

> Preferences > Guides), will align to the

closest guide.

1. Choose Guides > Snap to Guides.

(Ctrl + Shift + M)

A checkmark appears to show you “Snap to

Guides” is on.

To set the snap distance:

1. Choose File > Preferences > Guides.

2. Key in a vertical and horizontal snap

distance.

The unit of measurement will be the applica-

tion default. Right mouse clicking will give

you the following options: mm, cm, inches,

points and pixels.

3. Click OK.

To turn snap to guides off:

1.  Choose Guides > Snap to Guides.

(Ctrl + Shift + M)

The checkmark disappears to show you

“Snap to Guides” is off.

To change the color of guides:

1. Choose File > Preferences > Guides.

The guides preference controls will open.
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2. Click on the colored box to the right of

guides. 

3. Move the CMY slider controls to find a

color you like OR key in a percentage of CMY

in the boxes to the left of the sliders to

create a color. 

You will see the guide color box change

color. This is your new guide color.

4. Click OK.

To save guides to a file:

1.  Choose Guides > Save Guides.

The Save As dialog box will open. The orig-

inal default folder path, will be the path that

is set for Guides in your Folder preferences.

(File > Preferences > Folders > Guides)

The default folder path from then on, is the

path that you used when you last opened or

saved a guide.

2.  If the default folder path is not the path

you require, click on the arrow to the right

of the “Save in” combo box and select a new

folder path.

3.  The icons across the top of the dialog box

are general Windows functions.

4.  Enter a name in the File name edit box.

5.  Select the type of file you wish to save

your guide as. You can save your guide as a

Guide file (.wdu) or as a Design 1 guide file

(.gid).

6.  Click Save. Your guide will now be saved 

with the file name you specified, to the

folder you specified.

To load a guide you have previously saved:

1.  Choose Guides > Load Guides.

The Open dialog box will open. The original

default folder path, will be the path that is

set for Guides in your Folder preferences. 

(File > Preferences > Folders > Guides)

The default folder path from then on, is the

path that you used when you last opened or

saved a guide.

90 Chapter 5 - Creating Objects



2.  If the default folder path is not the path

you require, click on the arrow to the right

of the “Save in” combo box and select a new

folder path.

3.  The icons across the top of the dialog box

are general Windows functions.

4.  Select the type of file you wish to open.

You can open Guide files (.wdu) or Design 1

guide file (.gid).

5.  Select the guide file you wish to open.

The file name will now be displayed in the

File name edit box.

6.  Check the “Clear existing guides” check

box if you want to clear any guides that are

already displayed.

Do not check the “Clear existing guides”

check box if you want to add the guides you

have selected to  any guides that are already

displayed.

7.  Click Open. Your guide file you selected

will now open.

Guides that have been saved from a

document of a certain size cannot be loaded

into a document of a different size.

Objects
In Wright Design you can create four types

of objects. These are: Vector objects, Bitmap

objects, Text objects and Picture objects 

Vector - Created using the Vector tools.

Bitmap - Created using the Bitmap tools, 

Brush tool and Clone tool.

Text - Created using the Text tool.

Picture - Created when you open a picture

or, place a picture into your page.

Whilst these object types are functionally

different, they share the same fundamental

characteristics. Each of these objects act as a

container - they hold layers inside their

container. 

For example, a picture in a rectangle would

consist of a vector rectangle object holding a

picture layer. Multiple layers can be added

inside the one single vector rectangle object.

Creating Objects
When creating objects in Wright Design, the

tool modifier controls how the objects are

created.

There are four tool modifiers common to the

Vector and Bitmap tools and the first three

of those tool modifiers are common to the

Color Mask, Clone and Brush tools.
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The tool modifiers are:

These appear in the tool modifier ribbon

when you select either the Vector, Bitmap,

Color Mask, Clone or Brush tools to create

an object.

You can only apply tool modifiers to

like objects.

For example, if you have a Vector object and

you want to add to it, you can only add to it

using a Vector tool. 

New modifier tool 

The New tool modifier creates a new, inde-

pendent object.

To create a new object:

1. Select one of the Vector or Bitmap object

tools from the tool bar. 

2.  Select the New modifier tool from the

tool modifier ribbon.

3.  Click and drag the cursor to create your

object.

New object

Add modifier tool 

The Add tool modifier adds to an existing

selected object. Each new object created

becomes part of the original selected object

and contains the same paint style.

If you don’t have an object selected a new

object is created.

To add to an existing object:

1.  Select an existing object on your page.

2.  Select one of the Vector or Bitmap object

tools from the tool bar depending on

whether you have a Vector or Bitmap

selected. 

3.  Select the Add modifier tool from the

tool modifier ribbon.

4.  Click and drag the cursor to add to your

existing object.

Original object Add to object

Subtract modifier tool 

The Subtract tool modifier subtracts from an

existing selected object. Effectively it creates

a hole or takes a piece away from an existing

object.

AddNew

Crop

Subtract



To subtract from an existing object:

1.  Select an existing object on your page.

2.  Select one of the Vector or Bitmap object

tools from the tool bar depending on

whether you have a Vector or Bitmap

selected. 

3.  Select the Subtract modifier tool from

the tool modifier ribbon.

4.  Click and drag the cursor to subtract

from your existing object.

Or ig inal  ob jec t Subt rac t  f rom ob jec t

When working with Vector objects you

can only subtract from an area once. If you

use the Subtract modifier on the same area

twice, the area that was removed will reap-

pear.

Crop modifier tool 

The Crop tool modifier is used to crop a

selected object. It is also used to do cut-outs

of pictures.

If you crop an object you can still crop

or edit the object further.

If you crop a Vector object, the original

object remains and a new object with the

same paint style is created. Delete the orig-

inal object if it is not wanted.

To crop an object:

1.  Select an existing object on your page.

2.  Select one of the Vector or Bitmap object

tools from the tool bar depending on

whether you have a Vector or Bitmap

selected. 

3.  Select the Crop modifier tool from

the tool modifier ribbon.

4.  Click and drag the cursor to crop from

your existing object or cut around the

picture if you are doing a cut-out.

The original object disappears and the

cropped object appears in its place.

Or ig inal  ob jec t Cropped ob jec t

Picture objects are neither Vectors or

Bitmaps therefore you can crop a Picture

object using either a Vector object or a

Bitmap object.
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Vector objects
Vector objects are mathematically defined.

Each is made up of a list of points that define

the object’s outline. Internally, the points are

stored as Bezier segments. Because these

objects are mathematically defined, they

have no inherent resolution. This means that

they may be used within a page and output

at any resolution without loss of quality.

For instance, the same object may be printed

on an Imagesetter at 2400 dpi or converted

into a TIFF file at 300 dpi. The quality is

preserved because the object is only ever

rasterized when output is required. (In the

case of Imagesetters, the object is rasterized

at the Imagesetter’s RIP resolution).

The points defining the Vector object’s

outline may be edited through the Bezier

tool. Nodes may be moved, deleted or

converted to different types. Vector objects

may optionally have a stroke. A stroke

follows the objects outline and has a certain

thickness.

In fact, a Vector object may be composed

only of a stroke, with no fill, thus becoming a

line.  Vector objects may be converted to

Bitmap objects at any time.

Vector objects are created by using the

vector tools together with the paint style

palette. The vector tools control the shape of

the vector object and the content of the

vector object is controlled by the paint style

palette.

In general, it is preferable to use the

vector tools to create your objects as these

take up minimal disk space.

Vector objects are created using the vector

flyout tool in the tool palette. 

The tool flyouts can be torn away to create a

separate tool bar. To create a tear-away tool

bar, activate the tool flyout by clicking and

holding down on the mouse until the flyout

appears. Click an area surrounding the

outside of the flyout, move the flyout away

from the tool palette and release your finger

from the mouse. You now have a separate

tool bar that can be moved or docked

anywhere around the outside of the Wright

Design screen.

Vector tool flyout



The vector flyout consists of the following

vector tools:

The object that you create with these

tools is filled with the current paint style in

the paint style palette. For more information

on paint styles see Chapter 6 - Filling Objects

with Layers, ‘The Paint Styles’ on page 136.

The Rectangle vector tool
The rectangle vector tool creates rectangular

or square vector objects.

Rec tang le                     Square

To create a vector rectangle by 
dragging:

1.  Select the rectangle vector tool from

the vector tool bar.

The tool modifier ribbon will show the

following:

2.  Select the new modifier tool from the

tool modifier ribbon.

3.  If you want your object to be square, click

on the square check box or hold down the

Shift key while you drag your object.

4.  Position your cursor at the point where

you would like to start your rectangle.

5.  Click and drag the cursor to where you

want the opposite corner to be.

6.  Release the mouse and your object is

created.

To create a vector rectangle by 
dimension:

1.  Select the rectangle vector tool from

the vector tool bar.

The tool modifier ribbon will show the

following.

2.  Select the new modifier tool from the

tool modifier ribbon.

3.  If you want your object to be square, click

on the square check box.

4.  Type in the X-coordinate and Y-coordi-

nate for the origin of your object.

5.  Type in the width and height for the size

of your object.

6.  Click on the Create button and your

object is created.
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The Round Rectangle vector tool
The round rectangle vector tool creates

rectangular or square vector objects with

rounded corners.

Round Rectangle         Round Square

To create a vector round rectangle by 
dragging:

1.  Select the round rectangle vector tool 

from the vector tool bar.

The tool modifier ribbon will show the

following.

2.  Select the new modifier tool from the

tool modifier ribbon.

3.  If you want your object to be square, click

on the square check box or hold down the

Shift key while you drag your object.

4.  Type in the arc radius measurement for

the corners of your rounded rectangle.

5.  Position your cursor at the point where

you would like to start your round rectangle.

6.  Click and drag the cursor to where you

want the opposite corner to be.

7.  Release the mouse and your object is

created.

To create a vector round rectangle by 
dimension:

1.  Select the round rectangle vector tool 

from the vector tool bar.

The tool modifier ribbon will show the

following.

2.  Select the new modifier tool from the

tool modifier ribbon.

3.  If you want your object to be square, click

on the square check box.

4.  Type in the arc radius measurement for

the corners of your rounded rectangle.

5.  Type in the X-coordinate and Y-coordi-

nate for the origin of your object.

6.  Type in the width and height for the size

of your object.

7.  Click on the Create button and your

object is created.
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The Ellipse vector tool
The ellipse vector tool creates elliptical or

circular vector objects.

Ell ipse         Circ le

To create a vector ellipse by dragging:

1.  Select the ellipse vector tool from the

vector tool bar.

The tool modifier ribbon will show the

following.

2.  Select the new modifier tool from the

tool modifier ribbon.

3.  If you want your object to be a circle,

click on the circle check box or hold down

the Shift key while you drag your object..

4.  Position your cursor at the point where

you would like your ellipse’s bounding box

to start OR from the center if you are

creating a circle.

5.  Click and drag the cursor to where you

want the opposite corner to be, if you are

creating an ellipse OR to the outside of your

circle. 

6.  Release the mouse and your object is

created.

To create a vector ellipse by dimension:

1.  Select the ellipse vector tool from the

vector tool bar.

The tool modifier ribbon will show the

following.

2.  Select the new modifier tool from the

tool modifier ribbon.

3.  If you want your object to be a circle,

click on the circle check box.

4.  Type in the X-coordinate and Y-coordi-

nate for the origin of your object. 

5.  Type in the width and height for the size

of your object.

6.  Click on the Create button and your

object is created.

The Curved Polygon vector tool
The curved polygon vector tool allows you to

create vector objects with both curved and

straight lines. This is the tool you will most

commonly use to cutout or create a clipping

path around a picture.

Curved polygon

To create a vector curved polygon:

1.  Select the curved polygon vector tool 

from the vector tool bar.

97



The tool modifier ribbon will show the

following.

2.  Select the new modifier tool from the

tool modifier ribbon.

3. Click where you want to place the first

point on your page 

4.  Move the cursor to a new position and

click again.

5.  Continue adding points. You will notice

the line you are creating is a curved line. To

create a corner or produce a straight line

hold down the Shift key.

6.  At any time you can delete a point or

several points by hitting the Backspace key

on your keyboard.

If you want to delete your entire path before

you have completed your object, hit the Esc

key on your keyboard. 

7.  When you have completed your object

press Enter to create an open path or bring

the cursor back to the first point where the

cursor will turn into an arrow and click to

create a closed polygon.

You can create a curved/straight line

using this tool. In the Paint Style palette set

up a Stroke but no Fill and press Enter to

create an open path.

8.  If, after you have created your object you

find that you have selected the wrong modi-

fier tool, click on the Previous outline button

in the tool modifier bar. This will take you

back to your outline where you can change

the modifier tool and finish your object as in

step 7. 

The Straight Polygon vector tool
The straight polygon vector tool allows you

to create  vector object’s with straight lines

only.

Straight  polygon

To create a vector straight polygon by drag-
ging:

1.  Select the straight polygon vector tool

from the vector tool bar.

The tool modifier ribbon will show the

following.

2.  Select the new modifier tool from the

tool modifier ribbon.

3. Click where you want to place the first

point on your page 

4.  Move the cursor to a new position and

click again.

5.  Continue adding points.
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6.  At any time you can delete a point or

several points by hitting the Backspace key

on your keyboard.

If you want to delete your entire path before

you have completed your object, hit the Esc

key on your keyboard. 

7.  When you have completed your object

press Enter to create an open path or bring

the cursor back to the first point where the

cursor will turn into an arrow and click to

create a closed polygon.

8.  If, after you have created your object you

find that you have selected the wrong modi-

fier tool, click on the Previous outline button

in the tool modifier bar. This will take you

back to your outline where you can change

the modifier tool and finish your object as in

step 7.

To create a vector straight polygon by
dimension:

1.  Select the straight polygon vector tool

from the vector tool bar.

The tool modifier ribbon will show the

following.

2.  Select the new modifier tool from the

tool modifier ribbon.

3. Type in the X-coordinate and Y-coordi-

nate for the first point of your object. 

4.  Click on the add button to add the

point to the list box.

5.  Type in the X-coordinate and Y-coordi-

nate for the second point of your object. 

6.  Click on the add button to add the

point to the list box.

7.  Keep adding points to the list box until

you have added all the points you require to

create your object.

8.  You can add a new point above an

existing point in the list box. To do so, select

the point in the list box that you want to add

your point above, type in the X-coordinate

and Y-coordinate for the point you want to

add and click on the add above button .

9.  To delete a point from the list box, select

the point you want to delete and click on the

delete button .

10. When you have keyed in all the points

for your object, click on the Create button

and your object is created.

The Star vector tool
The star vector tool allows you to create

many different types of star vector objects.

Star Ir regular  s tar

To create a vector star by dragging:

1.  Select the star vector tool from the

vector tool bar.
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The tool modifier ribbon will show the

following.

2.  Select the new modifier tool from the

tool modifier ribbon.

3.  Key in the number of prongs you require

for your star  in the Prongs edit box.

4. Select the type of star you wish to create.

The styles are shown below.

5.  Click on the invert check box if you want

your prongs to be inverted.

6.  Click on the Randomise checkbox if you

want your prongs to be different sizes.

7.  Click and hold down the mouse where

you want the middle of your star to be.

8.  Drag your mouse out to create the first

circle. This can form either the inside or

outside radius of your star. Release the

mouse.

9.  Click and drag the mouse to create the

length of the prongs on your star. You can

drag either inside or outside your first circle.

10. Click again and your star object is

created.

To create a vector star by dimension:

1.  Select the star vector tool from the

vector tool bar.

The tool modifier ribbon will show the

following.

2.  Select the new modifier tool from the

tool modifier ribbon.

3.  Key in the number of prongs you require

for your star in the Prongs edit box.

4. Select the type of star you wish to create.

The styles are shown below.

5.  Click on the invert check box if you want

your prongs to be inverted.

6.  Click on the Randomise checkbox if you

want your prongs to be different sizes.

7.  Type in the X-coordinate and Y-coordi-

nate for the center of your star. 

8.  Type in the inner radius for your star.

This is the distance from the center point to

the start of the prongs.

9.  Type in the outer radius for your star.

This is the distance from the start of the

prongs to the end of the prongs.
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10. Click on the Create button and your

object is created.

The Vector Polygon tool
The vector polygon tool allows you to create

many different types of regular vector poly-

gons including triangles, octagons and hexa-

gons. You can also create irregular vector

polygons.

Regular  polygon Irregular  polygon

To create a vector polygon by dragging:

1.  Select the vector polygon tool from

the vector tool bar.

The tool modifier ribbon will show the

following.

2.  Select the new modifier tool from the

tool modifier ribbon.

3.  Click on the Randomise checkbox if you

want each side of your polygon to be a

different size. This will give you an irregular

polygon.

4.  Key in the number of sides you require

for your vector polygon, in the Sides edit

box.

5.  Click and hold down the mouse where

you want the middle of your vector polygon

to be.

6.  Drag your mouse out to define the size of

your vector polygon, let go and your object

is created.

To create a vector polygon by 
dimension:

1.  Select the vector polygon tool from

the vector tool bar.

The tool modifier ribbon will show the

following.

2.  Select the new modifier tool from the

tool modifier ribbon.

3.  Click on the Randomise checkbox if you

want each side of your polygon to be a

different size. This will give you an irregular

polygon.

4.  Key in the number of sides you require

for your vector polygon in the Sides edit box.

5. Type in the X-coordinate and Y-coordi-

nate for the center of your vector polygon. 

6.  Type in length you want each side to be

in the Sides edit box.

7.  Click on the Create button and your

object is created.
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The Freehand/Line vector tool
The freehand/line vector tool allows you to

create freehand vector objects or straight

line vector objects.

Freehand ob jec t Line  ob jec t

To create a freehand vector shape by
drawing:

1.  Select the freehand/line vector tool 

from the vector tool bar.

The tool modifier ribbon will show the

following.

2.  Select the new modifier tool from the

tool modifier ribbon.

3.  Click at the point where you want to start

drawing your freehand object

4.  Hold the mouse down and draw the

shape you require.

5.  You can complete your object at any time

by releasing the mouse. If you do this, the

section between where you started and

where you finish will be straight. 

Or you can finish at the point you started

your object by releasing the mouse where

the cursor turns into an arrow.

To create a freehand vector shape by dimen-
sion:

The procedure for creating this object and

the ending result is the same as “To create a
vector straight polygon by dimension” on

page 99.

To create a vector straight line by drawing:

This will only work if you have a stroke paint

style selected. 

To select a Stroke paint style, go to the Paint

Style palette and select the Stroke button.

Select the paint style (layer) from the selec-

tion of paint styles.

For more information on paint styles and the

Paint Style palette, see Chapter 6 - Filling

Objects with Layers, ‘The Paint Style palette’

on page 135 and ‘The Paint Styles’ on page

136.

1.  Select the freehand/line vector tool 

from the vector tool bar.

The tool modifier ribbon will show the

following.

2.  Select the new modifier tool from the

tool modifier ribbon.

3.  Go to the paint style palette and click on

the stroke button. Add a stroke by clicking

the + button to the top right of the palette. 

To learn more about “Paint Styles” and the

“Paint Style palette” see Chapter 6 - Filling

Objects with Layers, ‘The Paint Style palette’

on page 135 and ‘The Paint Styles’ on page

136.
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4.  Go to the pen style palette and key in the

width of your  line. The pen style palette also

controls other attributes of the line.

5.  Click at the point where you want to start

your straight line.

6.  If you want your line to be vertical, hori-

zontal or at 15 degree increments, hold

down the Shift key.

7.  Click at the point where you want to

finish your straight line. Your object is now

created.

To create a vector straight line by dimen-
sion:

The procedure for creating this object and

the ending result is the same as “To create a
vector straight polygon by dimension” on

page 99.

Bitmap objects
Unlike Vector objects, Bitmap objects have

an associated resolution. They have a fill but

no stroke. Bitmap objects are created by

using the bitmap tools together with the

paint style palette. The bitmap tools control

the shape of the bitmap object and the

content of the bitmap object is controlled by

the paint style palette.

When a bitmap object is created a Grayscale

mask is generated and this is stored with

your document. In general, it is preferable to

use the vector tools to create your objects as

these do not take up any disk space.

Why use Bitmap objects? Because Bitmap

objects are, just that, bitmaps, you can do

things not possible with Vectors. It is

possible to feather, grow, shrink and outline

Bitmap objects and to airbrush in or out

areas. In fact, when you airbrush, you’re

really creating a new Bitmap object. Pixel

cloning, a specialised form of airbrushing, is

also carried out through Bitmap objects.

Bitmap objects are created using the bitmap

flyout tool in the tool palette. 
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The tool flyouts can be torn away to create a

separate tool bar. To create a tear-away tool

bar, activate the tool flyout by clicking and

holding down on the mouse until the flyout

appears. Click an area surrounding the

outside of the flyout, move the flyout away

from the tool palette and release your finger

from the mouse. You now have a separate

tool bar that can be moved or docked

anywhere around the outside of the Wright

Design screen.

In general, it is preferable to work with

vector objects as this will reduce file sizes

and memory usage and make redraws faster.

The bitmap flyout consists of the following

bitmap tools:

The object that you create with these

tools is filled with the current paint style in

the paint style palette. Remember that

Bitmap objects contain a Fill but no Stroke.

For more information on paint styles see

Chapter 6 - Filling Objects with Layers, ‘The

Paint Styles’ on page 136.

The Rectangle bitmap tool
The rectangle bitmap tool creates rectan-

gular or square bitmap objects.

Rectangle                     Square

To create a bitmap rectangle by 
dragging:

1.  Select the rectangle bitmap tool from

the bitmap tool bar.

The tool modifier ribbon will show the

following:

2.  Select the new modifier tool from the

tool modifier ribbon.

3.  If you want your object to be square, click

on the square check box or hold down the

Shift key while you drag your object.

4.  In the Resolution edit box key in the

resolution of your object.

Right mouse clicking on the Resolution

edit box will give you the following measure-

ment options: Pixels/mm, Pixels/cm, dpi.

5.  Click on the anti-alias checkbox to

average out the pixels around the edge of

your bitmap object to give a softer effect.
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6.  Position your cursor at the point where

you would like to start your rectangle.

7.  Click and drag the cursor to where you

want the opposite corner to be.

8.  Release the mouse and your object is

created.

To create a bitmap rectangle by 
dimension:

1.  Select the rectangle bitmap tool from

the bitmap tool bar.

The tool modifier ribbon will show the

following.

2.  Select the new modifier tool from the

tool modifier ribbon.

3.  If you want your object to be square, click

on the square check box.

4.  In the Resolution edit box key in the

resolution of your object.

5.  Click on the anti-alias checkbox to

average out the pixels around the edge of

your bitmap object to give a softer effect.

6.  Type in the X-coordinate and Y-coordi-

nate for the origin of your object.

7.  Type in the width and height for the size

of your object.

8.  Click on the Create button and your

object is created.

The Round Rectangle bitmap tool
The round rectangle bitmap tool creates

rectangular or square bitmap objects with

rounded corners.

Round Rec tang le         Round Square

To create a bitmap round rectangle by 
dragging:

1.  Select the round rectangle bitmap tool

from the bitmap tool bar.

The tool modifier ribbon will show the

following.

2.  Select the new modifier tool from the

tool modifier ribbon.

3.  If you want your object to be square, click

on the square check box or hold down the

Shift key while you drag your object.

4.  Type in the arc radius measurement for

the corners of your rounded rectangle.

5.  In the Resolution edit box, key in the

resolution of your object.

Right mouse clicking on the Resolution

edit box will give you the following measure-

ment options: Pixels/mm, Pixels/cm, dpi.
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6.  Click on the anti-alias checkbox to

average out the pixels around the edge of

your bitmap object to give a softer effect.

7.  Position your cursor at the point where

you would like to start your round rectangle.

8.  Click and drag the cursor to where you

want the opposite corner to be.

9.  Release the mouse and your object is

created.

To create a bitmap round rectangle by 
dimension:

1.  Select the round rectangle bitmap tool

from the bitmap tool bar.

The tool modifier ribbon will show the

following.

2.  Select the new modifier tool from the

tool modifier ribbon.

3.  If you want your object to be square, click

on the square check box.

4.  Type in the arc radius measurement for

the corners of your rounded rectangle.

5.  In the Resolution edit box key in the

resolution of your object.

6.  Click on the anti-alias checkbox to

average out the pixels around the edge of

your bitmap object to give a softer effect.

7.  Type in the X-coordinate and Y-coordi-

nate for the origin of your object.

8.  Type in the width and height for the size

of your object.

9.  Click on the Create button and your

object is created.

The Ellipse bitmap tool
The ellipse bitmap tool creates elliptical or

circular bitmap objects.

Ell ipse         Circ le

To create a bitmap ellipse by dragging:

1.  Select the ellipse bitmap tool from

the bitmap tool bar.

The tool modifier ribbon will show the

following.

2.  Select the new modifier tool from the

tool modifier ribbon.

3.  If you want your object to be a circle,

click on the circle check box or hold down

the Shift key while you drag your object..

4.  In the Resolution edit box key in the

resolution of your object.



Right mouse clicking on the Resolution

edit box will give you the following measure-

ment options: Pixels/mm, Pixels/cm, dpi.

5.  Click on the anti-alias checkbox to

average out the pixels around the edge of

your bitmap object to give a softer effect.

6.  Position your cursor at the point where

you would like your ellipse’s bounding box

to start OR from the center if you are

creating a circle.

7.  Click and drag the cursor to where you

want the opposite corner to be, if you are

creating an ellipse OR to the outside of your

circle. 

8.  Release the mouse and your object is

created.

To create a bitmap ellipse by 
dimension:

1.  Select the ellipse bitmap tool from

the bitmap tool bar.

The tool modifier ribbon will show the

following.

2.  Select the new modifier tool from the

tool modifier ribbon.

3.  If you want your object to be a circle,

click on the circle check box.

4.  In the Resolution edit box key in the

resolution of your object.

5.  Type in the X-coordinate and Y-coordi-

nate for the center of your object. 

6.  Type in the width and height for the size

of your object.

7.  Click on the Create button and your

object is created.

The Curved Polygon bitmap tool
The curved polygon bitmap tool allows you

to create  bitmap object’s with both curved

and straight lines. This tool is used to create

cutouts of pictures.

Curved polygon

To create a bitmap curved polygon:

1.  Select the curved polygon bitmap tool 

from the bitmap tool bar.

The tool modifier ribbon will show the

following.

2.  Select the new modifier tool from the

tool modifier ribbon.

3.  In the Resolution edit box key in the

resolution of your object.
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Right mouse clicking on the Resolution

edit box will give you the following measure-

ment options: Pixels/mm, Pixels/cm, dpi.

4.  Click on the anti-alias checkbox to

average out the pixels around the edge of

your bitmap object to give a softer effect.

5. Click where you want to place the first

point on your page 

6.  Move the cursor to a new position and

click again.

7.  Continue adding points. You will notice

the line you are creating is a curved line. To

create a corner or produce a straight line

hold down the Shift key.

8.  At any time you can delete a point or

several points by hitting the Backspace key

on your keyboard.

If you want to delete your entire path before

you have completed your object, hit the Esc

key on your keyboard. 

9.  When you have completed your object

press Enter to create an open path or bring

the cursor back to the first point where the

cursor will turn into an arrow and click to

create a closed polygon.

10. If, after you have created your object you

find that you have selected the wrong modi-

fier tool, click on the Previous outline button

in the tool modifier bar. This will take you

back to your outline where you can change

the modifier tool and finish your object as in

step 9. 

The Straight Polygon bitmap tool

The straight polygon bitmap tool allows you

to create  bitmap object’s with straight lines

only.

Straight  polygon

To create a bitmap straight polygon by drag-
ging:

1.  Select the straight polygon bitmap tool

from the bitmap tool bar.

The tool modifier ribbon will show the

following.

2.  Select the new modifier tool from the

tool modifier ribbon.

3.  In the Resolution edit box key in the

resolution of your object.

Right mouse clicking on the Resolution

edit box will give you the following measure-

ment options: Pixels/mm, Pixels/cm, dpi.

4.  Click on the anti-alias checkbox to

average out the pixels around the edge of

your bitmap object to give a softer effect.

5. Click where you want to place the first

point on your page 
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6.  Move the cursor to a new position and

click again.

7.  Continue adding points.

8.  At any time you can delete a point or

several points by hitting the Backspace key

on your keyboard.

If you want to delete your entire path before

you have completed your object, hit the Esc

key on your keyboard. 

9.  When you have completed your object

press Enter to create an open path or bring

the cursor back to the first point where the

cursor will turn into an arrow and click to

create a closed polygon.

10. If, after you have created your object you

find that you have selected the wrong modi-

fier tool, click on the Previous outline button

in the tool modifier bar. This will take you

back to your outline where you can change

the modifier tool and finish your object as in

step 9.

To create a bitmap straight polygon by
dimension:

1.  Select the straight polygon bitmap tool

from the bitmap tool bar.

The tool modifier ribbon will show the

following.

2.  Select the new modifier tool from the

tool modifier ribbon.

3.  In the Resolution edit box key in the reso-

lution of your object.

4.  Click on the anti-alias checkbox to

average out the pixels around the edge of

your bitmap object to give a softer effect.

5. Type in the X-coordinate and Y-coordi-

nate for the first point of your object. 

6.  Click on the add button to add the

point to the list box.

7.  Type in the X-coordinate and Y-coordi-

nate for the second point of your object. 

8.  Click on the add button to add the

point to the list box.

9.  Keep adding points to the list box until

you have added all the points you require to

create your object.

10. You can add a new point above an

existing point in the list box. To do so, select

the point in the list box that you want to add

your point above, type in the X-coordinate

and Y-coordinate for the point you want to

add and click on the add above button .

11. To delete a point from the list box, select

the point you want to delete and click on the

delete button .

12. When you have keyed in all the points

for your object, click on the Create button

and your object is created.
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The Star bitmap tool
The star bitmap tool allows you to create

many different types of star bitmap objects.

Star Irregular  s tar

To create a bitmap star by dragging:

1.  Select the star bitmap tool from the

bitmap tool bar.

The tool modifier ribbon will show the

following.

2.  Select the new modifier tool from the

tool modifier ribbon.

3.  Key in the number of prongs you require

for your star, in the Prongs edit box.

4. Select the type of star you wish to create.

The styles are shown below.

5.  Click on the invert check box if you want

your prongs to be inverted.

6.  Click on the Randomise checkbox if you

want your prongs to be different sizes.

7.  In the Resolution edit box key in the

resolution of your object.

Right mouse clicking on the Resolution

edit box will give you the following measure-

ment options: Pixels/mm, Pixels/cm, dpi.

8.  Click on the anti-alias checkbox to

average out the pixels around the edge of

your bitmap object to give a softer effect.

9.  Click and hold down the mouse, where

you want the middle of your star to be.

10. Drag your mouse out to create the first

circle. This can form either the inside or

outside radius of your star. Release the

mouse.

11. Click and drag the mouse to create the

length of the prongs on your star. You can

drag either inside or outside your first circle.

12. Click again and your star object is

created.

To create a bitmap star by dimension:

1.  Select the star bitmap tool from the

bitmap tool bar.

The tool modifier ribbon will show the

following.

2.  Select the new modifier tool from the

tool modifier ribbon.

3.  Key in the number of prongs you require
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for your star, in the Prongs edit box.

4. Select the type of star you wish to create.

The styles are shown below.

5.  Click on the invert check box if you want

your prongs to be inverted.

6.  Click on the Randomise checkbox if you

want your prongs to be different sizes.

7.  In the Resolution edit box key in the

resolution of your object.

8.  Click on the anti-alias checkbox to

average out the pixels around the edge of

your bitmap object to give a softer effect.

9. Type in the X-coordinate and Y-coordi-

nate for the center of your star. 

10. Type in the inner radius for your star.

This is the measurement from the center

point to the start of the prongs.

11. Type in the outer radius for your star.

This is the measurement from the start of

the prongs to the end of the prongs.

12. Click on the Create button and your

object is created.

The Bitmap Polygon tool
The bitmap polygon tool allows you to create

many different types of bitmap polygons

including triangles, octagons and hexagons.

You can also create irregular bitmap poly-

gons.

Regular  polygon Irregular  polygon

To create a bitmap polygon by dragging:

1.  Select the bitmap polygon tool from

the bitmap tool bar.

The tool modifier ribbon will show the

following.

2.  Select the new modifier tool from the

tool modifier ribbon.

3.  Click on the Randomise checkbox if you

want each side of your polygon to be a

different size. This will give you an irregular

polygon.

4.  Key in the number of sides you require

for your bitmap polygon, in the Sides edit

box.

5.  In the Resolution edit box key in the

resolution of your object.
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Right mouse clicking on the Resolution

edit box will give you the following measure-

ment options: Pixels/mm, Pixels/cm, dpi.

6.  Click on the anti-alias checkbox to

average out the pixels around the edge of

your bitmap object to give a softer effect.

7.  Click and hold down the mouse, where

you want the middle of your bitmap polygon

to be.

8.  Drag your mouse out to create the size of

your bitmap polygon, let go and your object

is created.

To create a bitmap polygon by 
dimension:

1.  Select the bitmap polygon tool from

the bitmap tool bar.

The tool modifier ribbon will show the

following.

2.  Select the new modifier tool from the

tool modifier ribbon.

3.  Click on the Randomise checkbox if you

want each side of your polygon to be a

different size. This will give you an irregular

polygon.

4.  Key in the number of sides you require

for your bitmap polygon, in the Sides edit

box.

5.  In the Resolution edit box key in the

resolution of your object.

6.  Click on the anti-alias checkbox to

average out the pixels around the edge of

your bitmap object to give a softer effect.

7. Type in the X-coordinate and Y-coordi-

nate for the center of your bitmap polygon. 

8.  Type in length you want each side to be

in the Sides edit box.

9.  Click on the Create button and your

object is created.

The Freehand/Line bitmap tool
The freehand/line bitmap tool allows you to

create freehand bitmap objects.

Freehand

To create a freehand bitmap shape by drag-
ging:

1.  Select the freehand/line bitmap tool 

from the bitmap tool bar.

The tool modifier ribbon will show the

following.



2.  Select the new modifier tool from the

tool modifier ribbon.

3.  In the Resolution edit box key in the

resolution of your object.

Right mouse clicking on the Resolution

edit box will give you the following measure-

ment options: Pixels/mm, Pixels/cm, dpi.

4.  Click on the anti-alias checkbox to

average out the pixels around the edge of

your bitmap object to give a softer effect.

5.  Click at the point where you want to start

drawing your freehand object

6.  Hold the mouse down and draw the

shape you require.

7.  You can complete your object at any time

by releasing the mouse. If you do this, the

section between where you started and

where you finish will be straight. Or you can

finish at the point you started your object, by

releasing the mouse where the cursor turns

into an arrow.

To create a freehand bitmap shape by
dimension:

The procedure for creating this object and

the ending result is the same as “To create a
bitmap straight polygon by dimension” on

page 109.

Picture objects
Picture objects are closely related to Bitmap

objects. Whenever you place a picture into

the page (not into an existing object), that

object becomes a Picture object.

A Picture object behaves like a Bitmap object

in that you can airbrush into it, do pixel

cloning or apply a color mask. However, a

Picture object is really just ‘waiting’ to

become either a Vector object or a Bitmap

object.

Rarely do you just include the whole picture

into the page. Usually the picture is cropped,

or cut out from the background or masked in

some way. When you do any of those opera-

tions on a Picture object you are telling it

what type of object to become.

For instance, if you crop a Picture object

with a Vector tool, the cropped object

becomes a Vector object.

If you crop a Picture with a Bitmap tool, the

cropped object becomes a Bitmap object.

It is not possible to grow, shrink, outline or

shadow a Picture object.

Pictures are always manipulated at their orig-

inal scanned-in resolution. There are no

proxies or view files, we are always working

with the full picture content.

Picture objects are created by using the Place

Picture or Open picture commands in the

File menu. Placing pictures and opening

pictures has been discussed in an earlier

chapter. 
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To create a picture object:

See: “Opening Pictures” on page 54.

OR
“Placing a Picture” on page 59.

Text objects
Text objects are created through the Text

tool. Any font resident on your system may

be used in any combination, size, style or

color. You can create columns, drop caps

and fit text to a curve. 

As with Vector objects, Text objects are reso-

lution independent. They are more closely

related to Vector objects than to any other

type. In fact, you can convert Text objects

into vector objects and bitmap objects. 

You can create your own shadow directly

from a text object. The text remains as a text

object and the shadow is automatically

converted to a bitmap with feathering

applied to it. Text objects may be used to

create special effects. Glow effects may be

achieved by converting the text object to a

bitmap object and feathering the edges.

Text boxes can be automatically or manually

linked to each other. Text that has been

applied to a text box can be converted to a

text container therefore allowing you to type

within the outline of the original text.

To create a text object:

1.  Select the text tool from the tool

palette.
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The tool modifier ribbon will show the

Character attributes when you first start the

application (as shown in the picture on the

prevoius page).

From then on the last used text attribute will

be the one that displays in the tool modifier

bar.

The Text attributes are:

Shown above are the four text attribute

modifier buttons that are used to control

text objects and the text inside the objects.

2.  Position your cursor at the point where

you would like to start your text object.

3.  Click and drag the cursor to where you

want the opposite corner of your text object

to be.

4.  Release the mouse and your text object is

created.

5.  The flashing text insertion bar indicates

the text insertion point, where text is placed

when you enter or import it. 

Start entering your text.

To learn more about Text and text objects

see Chapter 11 - ‘Text’ on page 273.

The Object list
Each object that you create in a document is

listed in the Object list palette. The objects

are listed in the order of their display priori-

ties and may be moved to a higher or lower

priority by dragging the list entry up or down

the object list.

Each entry in the Object list has a thumbnail

preview. The thumbnails may be normal size

or large. When an object is created, it is auto-

matically given a name, however, you can

change this name to whatever you like, from

the Object list. You may also select, delete,

hide, copy or edit objects from the Object

list.

When a document is saved and then recalled,

all the objects remain editable. A document

may also be ‘flattened” into  a picture.

To display the Object list palette:

●  Choose Window > Palettes > Object List.

A checkmark appears next to the command

showing you the Object List palette is

displayed.

OR

●  Select F6 from your keyboard.

To hide the Object list palette:

●  Choose Window > Palettes > Object List.

The checkmark next to the command disap-

pears showing you the Object List palette is

hidden.

OR

●  Select F6 from your keyboard.
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Using the Object List
The document below is made up of twelve

objects. Each object has been created sepa-

rately and each object shows as a separate

item in the object list. 

The picture below shows you the Object List

palette for the document above. 

Selecting an object
You can select one or several objects from

your document using the object list. 

To select an object using the Object List:

●  Click on the icon or name of the object

you want to select. 

The object name is now highlighted and

handles appear around the selected object in

your page.

●  To select more than one object, hold

down the CTRL key on your keyboard as you

click on the icon or name in the Object List

of the object’s you want to select.

The object names are now highlighted and

handles appear around all of the selected

object’s in your page.

OR



To select all of the object’s in the Object
List:

1.  Right mouse-click anywhere inside the

object list.

A drop down menu will appear.

2.  Scroll down and select Select All.

To deselect all of the object’s in the Object
List:

1.  Right mouse-click anywhere inside the

object list.

A drop down menu will appear.

2.  Scroll down and select Select None.

Enhancing the display
Enhancing the display of the object list gives

you a plus (+) or minus ( -) sign before each

object. 

A plus (+) means that you are able to expand

the object. A minus (-) means that you can’t

expand any further, you can only collapse

the object.

You are still able to expand and collapse an

object when you are not in enhanced display

mode. when the display is not enhanced you

don’t see the plus (+) or minus (-) signs.

To enhance the display of the Object List:

1.  Right mouse-click anywhere inside the

object list.

A drop down menu will appear.

2.  Scroll down and select Enhanced Display.

Next time you right mouse-click you will see

a checkmark next to the command, showing

you that the display is enhanced. 

To return to normal display of the Object
List:

1.  Right mouse-click anywhere inside the

object list.

A drop down menu will appear.

2.  Scroll down and select Enhanced Display.

Next time you right mouse-click there will

not be a checkmark next to the command,

showing you that the display is normal.
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Expanding and Collapsing
The object/s in the Object List can be

expanded to see the layers that each object

contains. You can then collapse the objects

in the list to show just its name.

If you have enhanced the display of your

object list (as explained above) you will see a

plus (+) or minus (-) before each object

showing you whether you can collapse or

expand an object in the object list.    

To expand an object in the Object List:

1.  Double-click on the icon or name of the

object you want to expand.

OR

Single-click on the + (plus) icon to the left

of the object you want to expand.

A tree structure will form showing what is

contained inside the object. If for example,

you expanded a vector object, you will now

see a Fill and a Stroke icon.

2.  Double-click on the Fill icon OR single-

click on the + (plus) icon and the tree struc-

ture will expand showing you the types of

fills/layers that are contained inside the

object.

In the example below, the selected object is

called “Vector Curved Polygon”. It has a Fill

but no Stroke.

The first layer in the Fill is an Alpha channel

gradient that has an ellipse shape, and the

second layer is a Picture named FLOWER. 

OR

To expand all of the object’s in the Object
List:

1.  Right mouse-click anywhere inside the

object list.

A drop down menu will appear.

2.  Scroll down and select Expand All.

To collapse an object in the Object List:

1.  Double-click on the Fill icon OR single-

click on the - (minus) icon to the left of the

object you want to select and the tree struc-

ture will collapse showing you Fill and Stroke

icons.

2.  Double-click on the icon or name OR
single-click on the - (minus) icon to the left

of the of the object you want to collapse.
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The tree structure will collapse showing just

the object name.

OR

To collapse all of the object’s in the Object
List:

1.  Right mouse-click anywhere inside the

object list.

A drop down menu will appear.

2.  Scroll down and select Collapse All.

Displaying large icons
At any time you can display large icons in the

Object List.

To display large icons in the Object List:

1.  Right mouse-click anywhere inside the

object list.

A drop down menu will appear.

2.  Scroll down and select Large Icons.

Scroll bars will appear if the informa-

tion inside the Object List exceeds the size of

the Object list. 

You can leave it as is, and use the scroll bars

to move around the Object List or you can

resize the Object List by pulling out any of

the four sides.

To display small icons in the Object List:

1.  Right mouse-click anywhere inside the

Object List.

A drop down menu will appear.

2.  Scroll down and select Small Icons.

Grouped Objects Together
In the Object List you can choose to display

grouped objects in two different ways.

The first way, displays all of your objects

including the objects that are grouped, in

priority. You can see the objects that are

grouped but you cannot see the groups. This

is the default.

The second way, displays each of the objects

you have grouped inside the Group object.

Using this option makes it easier to see what

objects are in a group.

To display grouped objects together in the
Object List:

1.  Right mouse-click anywhere inside the

object list.

A drop down menu will appear.

2.  Scroll down and select Grouped objects

together.
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Any objects that are grouped as one will now

display inside a Group object. 

Group objects and objects that have a

child object connected to them are displayed

in bold in the Object List.

To turn the display grouped objects together
off  in the Object List:

1.  Right mouse-click anywhere inside the

object list.

A drop down menu will appear.

2.  Scroll down and select Grouped objects

together.

Any objects that are grouped as one will now

display as separate objects.

Deleting Objects
There are several ways of deleting objects

from your document. One of them is to

delete the object using the Object lIst

palette.

To delete an object from the Object List:

1.  Right mouse-click on the icon or name of

the object you want to delete.

A drop down menu will appear.

2.  Scroll down and select Delete Selection.

The object will now be deleted

OR

1.  In the Object list, click on the icon or

name of the object you want to delete.

2.  Press the delete key on your keyboard to

delete the object.
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If you delete a Group object or objects

with a Child object connected to them, all

the objects that are contained in that group

will be deleted.

Renaming Objects
When an object is created, it is automatically

given a name, however, you can change this

name to any name up to 32 characters, from

the Object List.

To rename an object in the Object List:

1.  Right mouse-click on the icon or name of

the object you want to rename.

A drop down menu will appear.

2.  Scroll down and select Rename.

The object name of the object you have

selected will be highlighted.

4.  Type in the new name for the object and

press Enter.

Hiding Objects
The Object List also allows you to Hide

objects at any time. Hidden objects are saved

with the document but are not included if

you save as a picture or print your docu-

ment.

To hide an object from the Object List:

1.  Right mouse-click on the icon or name of

the object you want to hide.

A drop down menu will appear.

2.  Scroll down and select Hide.

The object will now be hidden from your

document. The Object List will display the

name of the hidden object but the icon will

not be displayed.
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To show an object that has been hidden
from the Object List:

1.  Right mouse-click on the icon or name of

the object you want to show.

A drop down menu will appear.

2.  Scroll down and select Show.

Changing Object Priority
As objects are created they are listed in the

order of their display priorities. They may be

moved to a higher or lower priority (ie. rela-

tive to other objects) by dragging the list

entry up or down the object list.

You can also change the priority of layers

within each object the same way.

To change the priority of an object in the
Object List:

1.  Click and drag, on the icon or name of

the object whose priority you wish to

change.

As you drag you will see a horizontal line

appear. This is to indicate where you want to

place your object.

3.  Drag the object to the place in the Object

List where you want your object to be and let

go.



You will now see that your object has

changed priority in your document. 

The bottom of the Object List is the

highest priority object.

The top of the Object List is the lowest

priority object.

Copying and Moving Layers
Each object can contain any number of

layers. Layers are added to an object using

the Paint Style palette.

The Object List gives you the ability to copy

or move layers from one object to another.

To copy or move layers from one object to
another:

1.  Right mouse-click and drag on the icon or

name of the layer you wish to copy or move.

2.  Drag the layer and as you drag you will

see a horizontal line appear. This is to indi-

cate where you want to place your layer in

the Object List.

Let go of the mouse at the required position. 

A menu opens asking whether you want to

copy or move your layer.

3.  Select Copy here, if you want to copy the

layer from the original object to the new

object.

Select Move here, if you want to move the

layer from the original object to the new

object.

Select Cancel if you don’t want to copy or

move the layer.
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You can now see in the Object List and in

your document, that a layer has been copied

from one object to another.

Converting Objects
Objects can be converted from one type of

object to another. Converting objects allows

you the freedom of creating one type of

object when you start your page and then

converting the object at a later date to create

a different effect. 

Converting a Vector object to a text

container allows you to create text inside any

type of shape. 

You can convert a Text container to a Vector

object to allow you to color the background

of the Text object. 

You can also convert the actual text inside a

Text container to a bitmap to then maybe

create a ‘glow’ effect by growing the bitmap

and then feathering it. 

Objects that you convert can contain any

Paint Style.

The possibilities to convert from one type of

object to another type of object are:

Vector objects TO Bitmap objects

Text Containers

Text TO Vector objects

Bitmap objects

Text Containers

Text Containers TO Vector objects

Bitmap objects



To convert from a vector object:

1.  Select the Vector object/s you wish to

convert.

2.  Choose Object > Convert. (Ctrl + T)

The Convert to dialog box will open. 

3.  If you are converting to a Bitmap object

select the Bitmap tab.

Vector  object Bitmap object

To convert to a Text Container, click on the

Text Container tab.

Vector  object Text  Container

You can also convert to a Vector object by

selecting the Vector tab. This is another way

of duplicating your Vector object.

Vector  object Vector  object

4.  The Input pane gives you three options.

Select the option you require.

Leave selection - will create the new object

and leave the original Vector object.

Hide selection - will create the new object

and hide the original Vector object.

Delete selection - will create the new object

and delete the original Vector object.

5.  The Output pane gives you different

options depending on what you have

selected to Convert to. Select what you

require.

Create single object - is available if you have

more than one object selected to convert

from or if you are converting text. When

selected this will create a single object from

the multiple objects selected to convert

from.

Insert below selection - will create the new

object below the original object in order of

priority. If you don’t select this option the

new object will be created on top.

Anti-Alias - this option is only available when

you are converting to a Bitmap object.

Checking this option will average out the

pixels around the edge of your new Bitmap

object to give a softer effect.
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Resolution - this option is only available

when you are converting to a Bitmap object.

Key in the resolution that you want your new

Bitmap object to be.

Right mouse clicking on the Resolution

edit box will give you the following measure-

ment options: Pixels/mm, Pixels/cm, dpi.

6.  Click OK.

The Convert to dialog box will close and the

new object/s is created. You can easily see

this by looking at your Object List.

To convert from a text container:

A Text object is made up of the outside

shape, which we call the Text Container and

the Text inside the Text object. 

Here we are dealing with the Text Container

only.

1.  Select the Text object(s) you wish to

convert.

2.  Choose Object > Convert. (Ctrl + T)

The Convert to dialog box will open. 

3.  If you are converting to a Vector object

select the Vector tab.

Text  Container Vector  object

To convert to a Bitmap object, click on the

Bitmap tab.

Text  Container Bitmap object

You can also convert to a Text Container by

selecting the Text Container tab. This is

another way of duplicating your Text object.

Text  Container Text  Container

4.  The Input menu gives you three options.

Select the option you require.

Leave selection - will create the new object

and leave the original Text object.

Hide selection - will create the new object

and hide the original Text object.

Delete selection - will create the new object

and delete the original Text object.

The ‘Hide’ and ‘Delete’ selections will be

grayed out if you were in the Text tool when

you selected Convert. 
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5.  The Text menu gives you two options.

Select ‘Convert container’.  

Convert container - will convert the text

container. 

Convert Text - will convert the text that is

inside the container. This is described in “To

convert from Text”.

6.  The Output menu gives you different

options depending on what you have

selected to Convert to. Select what you

require.

Create single object - is only available if you

have more than one object selected to

convert from or if you are converting text.

When selected this will create a single object

from the multiple objects selected to convert

from.

Insert below selection - will create the new

object below the original object in order of

priority. If you don’t select this option the

new object will be created on top.

Anti-Alias - this option is only available when

you are converting to a Bitmap object.

Checking this option will average out the

pixels around the edge of your new Bitmap

object to give a softer effect.

Resolution - this option is only available

when you are converting to a Bitmap object.

Key in the resolution that you want your new

Bitmap object to be.

Right mouse clicking on the Resolution

edit box will give you the following measure-

ment options: Pixels/mm, Pixels/cm, dpi.

7.  Click OK.

The Convert to dialog  box will close and the

new object/s is created. You can easily see

this by looking at your Object List.  

To convert from text:

A Text object is made up of the outside

shape, which we call the Text Container and

the Text inside the Text object. 

Here we are dealing with the Text inside the

Text object.

1.  Select the Text object/s you wish to

convert.

2.  Choose Object > Convert. (Ctrl + T)

The Convert to dialog box will open. 

3.  If you are converting to a Vector object

leave the Vector tab selected.

Text             Vector  object
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To convert to a Bitmap object, click on the

Bitmap tab.

Text Bitmap object

To convert the Text to a Text Container,

click on the Text Container tab. This option

allows you to type text into a text shape.

Text Text  Container

4.  The Input menu gives you three options.

Select the option you require.

Leave selection - will create the new object

and leave the original Text object.

Hide selection - will create the new object

and hide the original Text object.

Delete selection - will create the new object

and delete the original Text object.

The ‘Hide’ and ‘Delete’ selections will be

grayed out if you were in the Text tool when

you selected Convert. 

5.  The Text menu gives you two options.

Select Convert text.  

Convert container - will convert the text

container. This is described in “To convert

from a Text Container”.

Convert text - will convert the text that is

inside the container. 

6.  The Output menu gives you different

options depending on what you have

selected to Convert to. Select what you

require.

Create single object -  when selected, will

create a single object from the object/s

selected to convert from, ie. the new object

of vector text will be a single object. If not

selected, every character of text will be a

separate object.

Insert below selection - will create the new

object below the original object in order of

priority. If you don’t select this option the

new object will be created on top.

Anti-Alias - this option is only available when

you are converting to a Bitmap object.

Checking this option will average out the

pixels around the edge of your new Bitmap

object to give a softer effect.

Resolution - this option is only available

when you are converting to a Bitmap object.

Key in the resolution that you want your new

Bitmap object to be.

Right mouse clicking on the Resolution

edit box will give you the following measure-

ment options: Pixels/mm, Pixels/cm, dpi.

7.  Click OK.

The Convert to dialog box will close and the

new object/s is created. You can easily see

this by looking at your Object List.  



Placing an EPS
EPS files that you have saved from Wright

Design or other applications (PC or Mac) can

be placed into a document in Wright Design.

When an EPS file is placed into your docu-

ment it is seen as an EPS Picture object in

the Object List. 

It is possible to manipulate the EPS file as an

entire object, ie. resize, rotate, skew,

however you cannot add layers from the

Paint Style palette. An EPS Picture object can

only contain the EPS file.

To place an EPS file:

1.  Make sure you have a document open

and that there are no objects selected.

2.  Choose File > Place EPS. (Ctrl + E)

The Place dialog box will open. The original

default folder path will be the path that is set

for EPS Files in your Folder preferences. 

(File > Preferences > Folders > EPS Files)
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The default folder path from then on is the

path that you last used to place an EPS.

3.  If the default folder path is not the path

you require, click on the arrow to the right

of the “Look in” combo box and select a new

folder path.

The “Recent” combo box at the bottom left of

the Place dialog box allows you to select a

new folder path from previously used folder

paths. 

This area will appear blank if you have not

previously used another folder.

4.  The icons across the top of the dialog box

are general Windows functions.

5.  From the “Files of Type” combo box, click

on the arrow to the right and select the type

of file you wish to view.

You can select to view an EPS file type or you

can view all file types at once.

6. Select the EPS file you want to place.

The selected thumbnail and the filename are

now highlighted.

The Details box at the bottom right of the 

Place dialog box displays the relevant infor-

mation for the file that you have selected. 

The details include Size, Pixels, Resolution

and Type of file.

Holding down the Shift key whilst

selecting a file will allow you to multiple

select a range of files.

Holding down the Ctrl key whilst selecting a

file will allow you to select multiple files at

random.

7. The file name edit box will show the file

name of the EPS file you have selected. If

you have multiple EPS files selected the file

name showing will be the last EPS file you

selected.

8. Click on the Place button.

The Place dialog box will close and the EPS

file is placed onto your page.

If you have created your EPS with the back-

ground set to NONE, the white area that is

visible around the outside of your EPS file is

the Preview display only. This area will drop

out on output of your file.

If you had an object selected when you

placed your EPS file, the EPS will be placed

inside the selected object. If the object is a

Bitmap object the EPS will be rendered at

the resolution of the EPS preview.

To crop your EPS object you should

use the Vector tools.

Using the Bitmap tools will render your EPS

file at the resolution of the EPS preview.     

Make sure the EPS file has been saved

with a preview from the application you

created it from. 

Wright Design automatically creates a

preview when creating an EPS file.  
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Do not place a Bitmap or Picture

object, or a Vector object that is in some way

merging with the background over the top of

an EPS file as this will render your EPS file at

the resolution of the EPS preview.  

131



6



M ost other applications only allow an

object to have a single paint style,

such as a tint color or a picture. In

Wright Design, each object can have several

paint styles providing unparalleled levels of

flexibility. These can be thought of as

‘layers’ within an object and each layer can

be edited at any stage. Each layer has its own

opacity control, so the photo compositional

possibilities are enormous.

In this chapter we will concentrate on the

Paint Style palette. We will discuss the ten

paint styles available and how these paint

styles combine to create layers inside an

object.

The Paint Style palette
The Paint Style palette is the control center

of Wright Design. It controls the layers inside

an object.

The Paint Style palette contains ten paint

styles: Tint, Tint Adjust, Color Curve, Picture,

Filter, Gradient, Color Mask, Selective Color

Correction, Brightness/Contrast and

Hue/Saturation. Each of these appear in the

Paint Style palette as a tab and contain a

wide range of options.

The Paint Style palette is displayed (as

shown below) when you first run the Wright
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Design application. From then on it will be

as it was when you last closed the applica-

tion.

To display the Paint Style palette:

●  Choose Window > Palettes > Paint Style.

A checkmark appears next to the command

showing you the Paint Style palette is

displayed.

OR

●  Select F2 from your keyboard.

To hide the Paint Style palette:

●  Choose Window > Palettes > Paint Style.

The checkmark next to the command disap-

pears showing you the Paint Style palette is

hidden.

OR

●  Select F2 from your keyboard.

The Paint Styles
There are ten paint styles to choose from in

the Paint Style palette as shown below:

There are two ways of working with the Paint

Style palette.

You can either:

●  Create the object first and then apply a

paint style to the selected object.

OR

●  Set up the Paint Style palette and then

create the object. 

This option also allows you to airbrush any

of the paint styles including filters.

To apply a paint style to an object:

1.  With the Select tool from the Tool

Palette select the object to which you want

to apply the paint style. 

2.  To work with the object’s fill click on the

Fill button.

To work with the object’s outline click on

the Stroke button.
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Vector objects have a stroke and a fill

(except Vector objects consisting of an open

path - they are made up of a stroke only).

Bitmaps have a fill and no stroke.

3.  Select the paint style tab you require

from the Paint Style palette.

The paint style button will now show next to

either the Fill or Stroke button, whichever

you have selected. 

‘Tint’  Paint Style added to the object’s  Fill

‘Tint’ Paint Style added to the object’s  Stroke

‘ Tint' Paint St yle added to the object’s  Fill
and Stroke

4.  Set the paint style options. Each paint

style has its own set of options. Refer to the

individual paint styles following for a

complete explanation of all the options.

5.  If you have Auto-apply selected in your

Paint Style palette you will see your object is

updated with the paint style automatically. 

If not, click on the Apply button to apply the

paint style to your object. 

To add another paint style (layer) to an
object:

1.  Select the object with the Select tool 

from the Tool Palette or from the Object List.

2.  To work with the object’s fill, click on the

Fill button.

To work with the object’s outline, click on

the Stroke button.

3.  If you have more than one paint style,

select the paint style that you wish to be

directly under the new paint style.

If not, make sure the single paint style is

selected.

4.  Click on the plus (+) button at the top

right of the Paint Style palette.

Another paint style tab (layer) will be added.

5.  Select a paint style tab from the Paint

Style palette.

This will now show in the second button

across from either the Fill or Stroke button,

whichever you have selected.

‘ Tint’  And ‘ Tint Adjust’  paint St yle added to
the object’s  Fill
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6.  Set the paint style options. Each paint

style has its own set of options. Refer to the

individual paint styles following for a

complete explanation of all the options.

7.  If you have Auto-apply selected in your

Paint Style palette you will see your object is

updated with the paint style automatically. 

If not, click on the Apply button to apply the

paint style to your object. 

To delete a paint style from an object:

1.  Select the object with the Select tool 

from the Tool Palette or from the Object List.

2.  To work with the object’s fill click on the

Fill button.

To work with the object’s outline click on

the Stroke button.

3.  Select the paint style that you wish to

delete.

4.  Click on the minus (-) button at the top

right of the Paint Style palette.

The paint style tab (layer) will be removed.

To create an object with the paint style
already set:

1.  Deselect any object that you may have

selected.

2.  Select the paint style tab you require

from the Paint Style palette.

3.  The paint style tab will now show next to

either the Fill or Stroke button, whichever

you have selected. 

‘Tint’  Paint Style added to the object’s  Fill

‘Tint’ Paint Style added to the object’s  Stroke

‘Tint' Paint Style added to the object’s  Fill
and Stroke

4.  Set the paint style options. Each paint

style has its own set of options. Refer to the

individual paint style’s following, for a

complete explanation of all the options.

5.  Select the tool you require to create your

object from the Tool palette.

6.  Create your object.

The object created will contain the paint

style(s) (layers) that you set in the Paint

Style palette.

You can add or delete paint styles (layers) if

required.
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Right mouse-clicking
Right mouse-clicking on the Paint Style

palette always gives you the following

options:

●  Save Paint Style

●  Load Paint Style

●  Remove Fill Layers

●  Remove Stroke Layers

●  Remove All Layers

●  Remove Current Layers 

When you right mouse-click on the middle

area of the Paint Style palette, the menu may

display more options. These options are

dependant on what paint style (layer) you

have selected. They are explained with each

individual paint style.

To save a paint style:

1.  Right mouse-click anywhere on the Paint

Style palette.

A drop down menu will appear.

2.  Scroll down and select Save Paint Style.

The Save As dialog box will open.

The original default folder path will be the

Programs folder.

The default folder path from then on is the

path that you used when you last saved or

loaded a paint style.

3.  If the default folder path is not the path

you require, click on the arrow to the right

of the “Save in” combo box and select a new

folder path.

4.  The icons across the top of the dialog box

are general Windows functions.

5.  Type in a name for the file you want to

save.

6.  Check one of the following radio buttons:

Save all layers - to save all the layers in the

paint style.

OR

Only save currently selected layer - to only

save the paint style (layer) that you have

selected.

7.  Click on the Save button to save your

paint style (layer/s)

To load a paint style:

1.  Right mouse-click anywhere on the Paint

Style palette.

A drop down menu will appear.

2.  Scroll down and select Load Paint Style.

The Open dialog box will open.
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The original default folder path, will be the

Programs folder.

The default folder path from then on is the

path that you used when you last saved or

loaded a paint style.

2.  If the default folder path is not the path

you require, click on the arrow to the right

of the “Look in” combo box and select a new

folder path.

3.  The icons across the top of the dialog box

are general Windows functions.

4.  Select the file you want to load. This will

display in the filename edit box.

5.  Check one of the following radio buttons:

Replace all layers - to replace all of the

layers in the paint style.

OR

Replace selected layer - to only replace the

paint style (layer) that you have selected.

OR

Insert before selected layer - to insert the

paint style (layer) you want to load before

the selected paint style (layer).

Insert after selected layer - to insert the

paint style (layer) you want to load after the

selected paint style (layer).

6.  Click on the Open button to load the

paint style (layer/s) into the Paint style

palette.

To remove all the Fill paint style’s (layers):

1.  Right mouse-click anywhere on the Paint

Style palette.

A drop down menu will appear.

2.  Scroll down and select Remove Fill

Layers.

All of the Fill paint style’s (layers) are now

deleted from the Paint Style palette.

To remove all the Stroke paint style’s
(layers):

1.  Right mouse-click anywhere on the Paint

Style palette.

A drop down menu will appear.

2.  Scroll down and select Remove Stroke

Layers.

All of the Stroke paint style’s (layers) are

now deleted from the Paint Style palette.

To remove all the Fill and Stroke paint
style’s (layers):

1.  Right mouse-click anywhere on the Paint

Style palette.

A drop down menu will appear.
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2.  Scroll down and select Remove All Layers.

All of the Fill and Stroke paint style’s (layers)

are now deleted from the Paint Style palette.

To remove the selected paint style (layer):

1.  Right mouse-click anywhere on the Paint

Style palette.

A drop down menu will appear.

2.  Scroll down and select Remove Current

Layer.

The selected paint style (layer) will now be

deleted from the Paint Style palette.

Tint paint style
The ‘Tint’ tab in the Paint Style palette

applies a ‘Tint’ paint style (layer) to the

selected object. The tint is a constant color.

Color Model
You can select from CMYK, RGB, HSB,

Grayscale, PANTONE® and Alpha. The color

model chosen here, with the exception of

Grayscale and PANTONE®, is used only to

specify color. It is not the color model used

for the output of your file.
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To select a color model:

1.  Click on the arrow to the right of the

Color Model combo box.

2.  Scroll down and select the color model

you wish to use.

As you select a different color model you will

see the color pickers change. (ie. With CMYK

color model selected you have the CMYK

color sliders and with RGB color model

selected you have RGB color sliders.)

For a full explanation of color models and

their uses refer to Chapter 4 - ‘Color Display

Modes’ on page 73.

Opacity slider
Controls the opacity of the tint layer from 

0 % to 100% where 100% is fully opaque.

To change the opacity:

1.  Click and hold on the triangle under-

neath the opacity slider.

2.  Slide the slider to the opacity you require

and let go.

OR

●  Enter a value in the Opacity edit box and

hit Tab or Enter.

Selecting colors
You can select colors by using the color

pickers, (sliders, rainbow or swatches) or by

entering values in the edit boxes. 

You can also select colors from anywhere on

your page by using the Eyedropper tool. 

After selecting a color you can save it as a

swatch to re-use at any time.

As you select a color it becomes the active

Tint color and is displayed in the color

preview box to the left of the color picker

area.

Now we are going to go through the

different ways of selecting color. This also

applies to Tint Adjust, Filter and Gradient

paint styles. Please refer back to this section

when selecting colors for the paint styles

mentioned above.

To apply a Tint paint style using Sliders:

1.  Make sure the object is selected.

2.  Make sure the ‘Fill’ button is selected.

Select the ‘Tint’ tab in the Paint Style

palette.

The ‘Tint’ tab to the right of the ‘Fill’

button will be selected.

3.  Select the Sliders color picker.
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In CMYK color model as shown above you

have the four CMYK sliders. Other color

models will show their respective sliders.

4.  Click and hold on the triangle under-

neath the cyan color slider.

5.  Slide the slider to the value of Cyan you

require.

OR

●  You can click underneath the Cyan slider

on the value of Cyan you require and the

slider will automatically move to this posi-

tion.

OR

●  Enter a value in the Cyan edit box and hit

Tab or Enter.

6.  Continue Step 2 and 3, for the other

colors.

To show multicolored sliders:

1.  Right mouse-click anywhere inside the

Tint area on the Paint Style palette.

A drop down menu will appear.

2.  Scroll down and select Multicolored

sliders.

Each slider will now show two lines. The top

line shows the normal sliders depending on

what color model you have selected. The

lines underneath each normal line shows you

what the color will be if you move the slider

to that position.

The multicolored sliders will not show

if all colors are set to zero.

To show single color sliders:

1.  Right mouse-click anywhere inside the

Tint area on the Paint Style palette.

A drop down menu will appear.

2.  Scroll down and select Single color

sliders.

Each slider will now show a single line. 

To select a Tint paint style using the
Rainbow picker:

1.  Make sure the object is selected.

2.  Make sure the ‘Fill’ button is selected.

Select the ‘Tint’ tab in the Paint Style

palette.

The ‘Tint’ tab to the right of the ‘Fill’

button will be selected.
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3.  Select the Rainbow color picker.

The Rainbow displays a spectrum of color

according to the color model selected.

4.  Click and drag within the rainbow. As you

drag a cross appears indicating the color you

have selected. 

This color is shown in the preview box and

the corresponding color breakup is shown in

the number boxes.

5.  When you have found the color you

require, release the mouse.

Alternatively you can click anywhere within

the rainbow and the cross will automatically

move to this position.

If you know the value of color you

require, you can specify this in the boxes to

the left of the rainbow.

To select a PANTONE® Tint paint style using
the PANTONE® color model :

1.  Make sure the object is selected.

2.  Make sure the ‘Fill’ button is selected.

Select the ‘Tint’ tab in the Paint Style

palette.

The ‘Tint’ tab to the right of the ‘Fill’

button will be selected.

3.  Select the Sliders color picker.

4.  Select the PANTONE® color model.

The PANTONE® color that has been last

used is selected and will display in the Color

Preview box.

5.  To select a different PANTONE® color

click on the Select button.

The Select PANTONE® Color dialog box will

open.

6.  To select the PANTONE® library file you

require, click on the arrow to the right of the

Library combo box.

A drop-down menu will appear.

7.  Select the PANTONE® library file you

require. This is the color system you will be

using.

8.  To find a PANTONE® color, you can

either:

●  Use the scroll bar to scroll through the

Color selector.

OR

●  Select a color from the Color bar to take

you to the color range you require.

OR

●  Type in the number of the PANTONE®

color you require in the PANTONE® color

box.

9.  Select the PANTONE® color you require

by clicking on the color in the Color

Selector. 
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The selected color will have a keyline

surrounding it.

A CMYK readout will display in the bottom

right-hand corner of the dialog box.

10. Click on the OK button.

11. The selected PANTONE® color will now

show in the Color Preview box.

12. To change the percentage of PANTONE®

color move the colored slider.

To select a Tint paint style using the
Eyedropper tool:

The Eyedropper tool allows you select a

color from any point on your page. 

1.  Select the Eyedropper tool from the

Tool palette.

2.  Click on the desired color on your page.

The color appears in the color preview box.

You can now apply this color to another

object.

The Eyedropper tool reads a 1 x 1 pixel

area. To increase the sample area that the

Eyedropper tool reads to a 3 x 3 pixel area,

hold down the Shift key when you click on

the color you require. 
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To select a Tint paint style using the
Swatches:

1.  Make sure the object is selected.

2.  Make sure the ‘Fill’ button is selected.

Select the ‘Tint’ tab in the Paint Style

palette.

.The ‘Tint’ tab to the right of the ‘Fill’

button will be selected.

3.  Select the Swatches color picker.

The application does not come with a color

swatch palette. This color picker is for

storing colors that you frequently use. 

Swatches can be saved as a palette into a file

to be loaded at any time. (To create and save

your own color swatch see below.)

4.  Click on the color swatch that you

require. The values of this color are

displayed in the number boxes.

If you know the value of color you

require, you can specify this in the boxes to

the left of the swatches.

To create color swatches:

1.  Select either the Sliders or Rainbow color

picker.

2.  Create a color by using the sliders or the

rainbow color picker or, key in a value in the

number boxes. The chosen color will show in

the color preview box.

3.  Right mouse-click anywhere inside the

color picker area on the Paint Style palette.

A drop down menu will appear.

4.  Scroll down the menu and select Add

Swatch.

That color is now saved to the Swatches

color picker.

To create color swatches using the
Eyedropper tool:

This is useful for saving color swatches from

certain areas of a picture to maybe use in

some text.

1.  Select the Swatches color picker.

2.  Select the Eyedropper tool from the

tool palette.

3.  Hold the Eyedropper tool over the color

in your page that you wish to save as a

swatch.

4.  Click on the color. 

The color appears in the color preview box

and a new swatch is generated.

5.  Continue adding swatches as necessary.
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To delete a color swatch:

1.  Select the Swatches color picker.

2.  Select the swatch you want to delete.

3.  Right mouse-click anywhere inside the

color picker area on the Paint Style palette.

A drop down menu will appear.

4.  Scroll down the menu and select Delete

Swatch.

That swatch has now been deleted from the

Swatches color picker.

To delete the entire color swatch palette:

1.  Select the Swatches color picker.

2.  Right mouse-click anywhere inside the

color picker area on the Paint Style palette.

A drop down menu will appear.

3.  Scroll down the menu and select Delete

All Swatches.

The entire color swatch palette has now

been deleted from the Swatches color

picker.

To save a color swatch palette:

1.  Select the Swatches color picker.

2.  Right mouse-click anywhere inside the

color picker area on the Paint Style palette.

A drop down menu will appear.

3.  Scroll down the menu and select Save

Swatches.

The Save As dialog box will open. The orig-

inal default folder path will be the Wright

Design ‘Program’ folder.

The default folder path from then on is the

path that you used when you last opened or

saved a color swatch palette.

4.  If the default folder path is not the path

you require, click on the arrow to the right

of the “Save in” combo box and select a new

folder path.

5.  The icons across the top of the dialog box

are general Windows functions.

6.  Enter a name in the File name edit box.

7.  Select the type of file you  require your

color swatch palette to be. 

You can save your color swatch palette as a

Wright Design Swatch file (.wdw) or as a

Photoshop swatch (.aco).

8.  Click Save. 

Your color swatch palette will now be saved

with the file name you specified to the folder

you specified.

To load a color swatch palette:

1.  Select the Swatches color picker.

2.  Right mouse-click anywhere inside the

color picker area on the Paint Style palette.

A drop down menu will appear.
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3.  Scroll down the menu and select Load

Swatches.

The Open dialog box will open. The original

default folder path will be the the Wright

Design ‘Program’ folder.

The default folder path from then on is the

path that you used when you last opened or

saved a color swatch palette.

4.  If the default folder path is not the path

you require, click on the arrow to the right

of the “Look in” combo box and select a new

folder path.

5.  The icons across the top of the dialog box

are general Windows functions.

6.  Select the file you wish to open.

7.  Select the type of file you wish to open.

You can open a Wright Design Swatch file

(.wdw) or as a Photoshop swatch (.aco).

8.  Click Open. 

Your color swatch palette will now be loaded

into the swatch color picker.

Tint Adjust paint style
The ‘Tint Adjust’ tab in the Paint Style

palette applies a ‘Tint Adjust’ paint style

(layer) to the selected object. It is similar to

‘Tint’, except that it is possible to combine

the specified color with the background

and/or underlying layers, using a variety of

Adjustment operators, such as, add, subtract,

invert etc. 

Color Model
You can select from CMYK, RGB, HSB,

Grayscale or PANTONE®. The color model

chosen here, with the exception of Grayscale

and PANTONE®, is used only to specify

color. It is not the color model used for the

output of your file.

To select a color model:

1.  Click on the arrow to the right of the

Color Model combo box.

2.  Scroll down and select the color model

you wish to use.

As you select a different color model you will

see the color pickers change. (ie. With CMYK

color model selected you have the CMYK

color sliders and with RGB color model

selected you have RGB color sliders.)

For a full explanation of color models and

their uses refer to Chapter 4 - ‘Color Display

Modes’ on page 73.



Opacity slider
Controls the opacity of the tint adjust layer

from 0 % to 100% where 100% is fully

opaque.

To change the opacity:

1.  Click and hold on the triangle under-

neath the opacity slider.

2.  Slide the slider to the opacity you require

and let go.

OR

●  Enter a value in the Opacity edit box and

hit Tab or Enter.

Selecting colors
You can select colors by using the color

pickers, (sliders, rainbow or swatches) or by

entering values in the edit boxes. 

After selecting a color you can save it as a

swatch to re-use at any time.

As you select a color it becomes the active

Tint Adjust color and is displayed in the

color preview box to the left of the color

picker area.

To select a color:

See ‘Tint paint style’ on page 141. (The

color selection controls are the same for the

‘Tint Adjust’ paint style as they are for the

‘Tint’ paint style.)
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Adjustment Operators
Adjustment operators can be divided into

two groups. 

The first consists of Add, Subtract, Increase,

Decrease, Minimum, Maximum, Multiply,

Divide and Invert adjustment operators.

These are based on simple mathematical

formulae and consequently give relatively

predictable results.

The second group consisting of

Invert/Subtract, Xor, Or, And, and

Subtract/Invert adjustment operators, are

based on complex bitwise logical mathemat-

ical operations. The results of these calcula-

tions are much harder if not impossible to

predict. Experiment freely with these to

achieve special effects.

Here we are going explain how to use the

Adjustment operators. The examples

displayed after the explanation of the

Adjustment operators show you two objects

overlapping. The background is an object

containing a ‘Picture’ paint style. The fore-

ground object (letter c) contains a ‘Tint

Adjust’ paint style with different Adjustment

operators on each picture.

Adjustment operators are built not only

into the ‘Tint Adjust’ paint style but also into

the ‘Picture’, ‘Filter’, ‘Gradient’ and

‘Selective Color Correction’ paint styles.

The calculation used in defining the result is

the same for all of the above paint styles but

the final result is always different.

Please refer back to this section when

applying an Adjustment operator in the

other paint styles.

To apply an adjustment operator:

1.  Make sure the object is selected.

2.  Make sure the ‘Fill’ button is selected.

Select the ‘Tint Adjust’ tab in the Paint Style

palette.

3.  The Adjustment operator defaults to

normal.

4.  To change the Adjustment operator, click

on the arrow to the right of the Adjustment

operator combo box.

A drop down menu will appear.

5.  Select the Adjustment operator that you

require.

6.  This option affects all channels. If you

want to control each channel separately,

check the By Channel check box.

Multiple combo boxes will now appear, one

for each channel.

7.  Click on the arrow to the right of each

Adjustment operator combo box and select

the Adjustment operator that you require.

Types of Adjustment operators

NONE - None indicates there is no operation.

The object selected in this way effectively

disappears from the screen. You would most

likely use None as an operator for a single

channel.

NORMAL - The Normal operator is the

default setting. When normal is selected,

there is no adjustment applied. Like the

None operator, you would most likely use

Normal as an operator for a 

single channel.
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ADD - The Add operator adds the pixel

values of the paint style (layer) you have

selected to the paint style (layer) or object

that is underlying.

SUBTRACT - The Subtract operator subtracts

the pixel values of the paint style (layer) you

have selected to the paint style (layer) or

object that is underlying.

INCREASE - The Increase operator increases

the value of the paint style (layer).This is

calculated by taking the percentage of color

in the object you have selected and multi-

plying this by the color underneath. This is

then added to the paint style (layer) or

object that is underlying.

For example:  
A 40% cyan pixel is overlapping a 52% cyan

pixel. The Increase operator will increase the

underlying cyan value by 40%.

Increase by 40%: 52  x  40% = 20.8

Resulting % of cyan:   52  + 20.8 = 72.8%

DECREASE - The Decrease operator

decreases the value of the paint style (layer).

This is calculated by taking the percentage of

color in the object you have selected and

multiplying this by the color underneath.

This is then subtracted from the paint style

(layer) or object that is underlying.

For example:
A 40% cyan pixel is overlapping a 52% cyan

pixel. The Decrease operator will decrease

the underlying cyan value by 40%.

Decrease by 40%: 52  x  40% = 20.8

Resulting % of cyan:   52   -  20.8 = 31.2%

MINIMUM - The Minimum operator takes

the pixel value from the paint style (layer)

you have selected. If this value is lower than

the paint style (layer) or object that is under-

lying, the lower pixel value is applied. 

If the value is higher than the paint style

(layer) or object that is underlying, the orig-

inal pixel value is will be retained.

For example 
If a 40% pixel is overlapping a 75% pixel the

result will be a 40% pixel.

If a 40% pixel is overlapping a 28% pixel the

result will be a 28% pixel.

MAXIMUM - The Maximum operator takes

the pixel value from the paint style (layer)

you have selected. If this value is lower than

the paint style (layer) or object that is under-

lying, the original pixel value is will be

retained. If the value is higher than the paint

style (layer) or object that is underlying, the

higher pixel value is applied.

For example: 

If a 40% pixel is overlapping a 75% pixel the

result will be a 75% pixel.

If a 40% pixel is overlapping a 28% pixel the

result will be a 40% pixel.

MULTIPLY - The Multiply operator multiplies

the foreground and background pixels,

treating them as a percentage. 

For example: 

If a 50% pixel is overlapping another 50%

pixel the result would be 25%.

DIVIDE - The Divide operator actually adds

the two pixels and subtracts their product.

INVERT - The Invert operator inverts the

foreground pixels. The background pixels

have no effect.
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Adjustment Operators -
Here are some examples showing you a background object containing a 

‘Picture’ paint style, combined with the foreground object containing a

‘Tint Adjust’ operator with different Adjustment operators applied to it. 

The results vary greatly depending on the paint style used and its contents.
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Color Curve paint style
The ‘Color Curve’ tab in the Paint Style

palette applies a ‘Color Curve’ paint style

(layer) to the selected object. This modifies

the object and/or layers underneath it by

remapping it through the use of ‘curves’. 

For example, you may have an object with a

‘Picture’ paint style which needs some light-

ning in the ‘shadows’. (The darker area of

your picture.) You can simply add a ‘Color

Curve’ paint style (layer) on top of the

‘Picture’ paint style (layer) and edit the

curve in the ‘shadow’ end.

The ‘Color Curve’ paint style is mainly for

use with pictures, however, you can use it to

color correct any object containing color 

such as ‘Tint’, ‘Gradient’ or ‘Filter’ paint

style.

Color Model

You can select from CMYK, RGB, HSB,

Grayscale or Alpha. The color model chosen

here with the exception of Grayscale, is used

only to specify color. It is not the color

model used for the output of your file.

To select a color model:

1.  Click on the arrow to the right of the

Color Model combo box.

2.  Scroll down and select the color model

you wish to use.
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As you select a different color model you will

see the controls to the right of the Paint

Style palette change.

(ie. With CMYK color model selected you

have a CMYK color curve and with RGB color

model selected you a RGB color curve.)

For a full explanation of color models and

their uses refer to Chapter 4 - ‘Color Display

Modes’ on page 73.

Opacity slider
Controls the opacity of the color curve layer

from 0 % to 100% where 100% is fully

opaque.

To change the opacity:

1.  Click and hold on the triangle under-

neath the opacity slider.

2.  Slide the slider to the opacity you require

and let go.

OR

●  Enter a value in the Opacity edit box and

hit Tab or Enter.

Color Curving
The Color Curve tab allows you to color

correct in two basic ways. The first is to use

the mouse to drag the color curve into a new

position. The second method is to enter

input/output values, for precise color correc-

tion. You can also use a combination of the

two methods when creating a color curve. 

When you drag the curve, the input/output

values change accordingly, and vice versa.

You can apply a color curve to all channels,

select a single channel or several channels.

To apply a color curve by dragging:

1.  Make sure the object is selected.

2.  Make sure the ‘Fill’ button is selected.

If you want to add a ‘Color Curve’ paint style

on top of another paint style click on the

plus button at the top right of the paint style

palette and then select the ‘Color Curve’

button in the Paint Style palette.

OR

To apply only a ‘Color Curve’ paint style to

the selected object select the ‘Color Curve’

button in the Paint Style palette. With this

option the object will appear empty if it is

not overlapping another object as the color

curve will be applied to the white back-

ground.

The ‘Color Curve’ tab to the right of the

‘Fill’ button will be selected.

3.  Select the channel(s) you want to color

curve.

The button to the left of the channel selector

selects all channels in the color model you

are working.

The other buttons in the channel selector

allow you to individually select the color

channel(s) you wish to work with. 
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Holding down the Shift key allows you

to multiple select adjacent channels and

holding down the Crtl key will allow you to

select random channels.

The ‘color curve’ will display the color of

the channel you are working in.

4.  The bottom left of the curve controls the

‘highlights’, the middle of the curve controls

the ‘midtones’, and the top right of the

curve controls the ‘shadows’.

5.  Click on the curve and drag to alter the

shape of the curve.

A red point appears at the selected point on

the curve.

6.  To move the point you have just created,

click on it (the cursor will turn into an

arrow) and drag it to a new point.

As you do this you will see the input/output

values change. The input value shows you

the value of the point before you moved it

and the output value shows you the value

after you have moved it.

7.  To create a new point click somewhere

else on the curve and drag the curve to a

new position.

A new red point appears at the last selected

point on the curve.

8.  You can add as many points as you like to

your curve. The list box shows the input and

output values of all the points on your curve. 

9.  To delete a point from your curve, place

your mouse over the point so that the cursor

displays an arrow. Click on the point and it

will turn red - this shows you the point is

selected. 

10. Click on the Delete point button .
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11. Click on the Smooth Curve checkbox if

you want your curve to be smooth. This will

make the tonal adjustments gradual. 

The endpoints of a color curve can also

be moved. A double headed arrow will

display when your cursor is positioned over

an endpoint. You can then move the

endpoint.

To reset a single channel(s) curve:

1.  Make sure the channel you want to

delete is selected.

2.  Click on the Reset Selected channel(s)

button . 

OR

1.  Right mouse-click anywhere inside the

color curve area on the Paint Style palette.

A drop down menu will appear.

2.  Scroll down the menu and select Reset

Selected Channel(s).

The selected channel(s) will now be reset.

To reset all channel curves:

1.  Click on the Reset All Channels button

.

OR

1.  Right mouse-click anywhere inside the

color curve area on the Paint Style palette

A drop down menu will appear

2.  Scroll down the menu and select Reset

All Channels.

All of the channels will now be reset.

To apply a color curve by keying in input
and output values:

1.  Make sure the object is selected.

2.  Make sure the ‘Color Curve’ tab is

selected next to the Fill button in the Paint

Style palette.

3.  Select the channel(s) you want to color

curve.

The button to the left of the channel

selector, selects all channels in the color

model you are working in.

The other buttons in the channel selector

allow you to individually select the color

channel(s) you wish to work with. 

Holding down the Shift key allows you

to multiple select adjacent channels and

holding down the Crtl key will allow you to

select random channels.

The ‘color curve’ will display the color of

the channel you are working in.

4.  The bottom left of the curve controls the

‘highlights’, the middle of the curve

controls the ‘midtones’, and the top right of

the curve controls the ‘shadows’.
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5.  Enter a value in the Input box. This is the

point on the curve you want to change.

6.  Enter a value in the Output box. This is

the point where your original point will

move to on the curve.

For example, at Input value of 50 we want to

have an output value of 65.

7.  Select the Add point button .

A new red point appears at the point you

have requested.

8.  To delete a point from your curve, place

your mouse over the point so that the

cursor displays an arrow. Click on the point

and it will turn red - this shows you the

point is selected. 

9.  Click on the Delete point button .

10. Click on the Smooth Curve checkbox if

you want your curve to be smooth. This will

make the tonal adjustments gradual. 

To invert selected channel(s):

This option allows you to invert the chan-

nels you have selected automatically.

1.  Right mouse-click anywhere inside the

color curve area on the Paint Style palette.

A drop down menu will appear.

2.  Scroll down the menu and select Invert

Selected Channel(s).

Your curve is now inverted.

To show other channel curve(s) whilst you
are in a single channel:

This option allows you to see for example

the cyan, magenta and black curves when

you are working on the yellow curve.

1.  Right mouse-click anywhere inside the

color curve area on the Paint Style palette.

A drop down menu will appear.

2.  Scroll down the menu and select Show

Resulting Curves.

You will now see the other curves from the

other channels even though you are only

working on the Yellow channel.



Examples of Color Curve

Here are some examples of a ‘Color Curve’ paint style (layer) that has been added to a 

‘Picture’ paint style (layer). These color curves were achieved using the CMYK color model.

Example 1:

This example shows you the original picture in the middle and two examples of color curve.

The top picture shows a color curve that

lightens the three-quarter tones of the 

picture. The bottom picture shows a color

curve  that darkens the three-quarter tones 

of the picture.

Lightening:

1.  Click about three-quarters of

the way up the color curve.

2.  Drag the point down as

shown in the color curve to the right.

Your picture will now appear lighter as 

shown in the top fish picture to the right.

Darkening:

1.  Click about three-quarters of the way up

the color curve.

2.  Drag the point up as shown in the color

curve to the right.

Your picture will now appear darker as 

shown in the bottom fish picture to the 

right.
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Example 2:

The top picture shows a color curve that lightens the midtones of the picture. The bottom

picture shows a color curve that darkens the midtones of the picture.

Lightening:

1.  Click about half way up the color curve.

2.  Drag the point down as shown in the

color curve to the right.

Your picture will now appear lighter as

shown in the top picture

Darkening:

1.  Click about half way up the color curve.

2.  Drag the point up as shown in the

color curve to the right.

Your picture will now appear darker as

shown in the bottom picture at the right.

Example 3:

Unwanted color casts can be corrected by altering the level of a particular color in a picture. 

In the following picture we want to remove a greenish cast, which involves removing a

proportion of Cyan and Yellow from the picture.

Removing a cast:

1.  Select the Cyan and 

Yellow channels.

2.  Click about a quarter of

the way up the color curve.

2.  Drag the point down as

shown in the color curve to

the right.

The cast has now been

removed as shown in the

picture at far right.



Picture paint style
The ‘Picture’ tab in the Paint Style palette

applies a ‘Picture’ paint style (layer) to the

selected object.

Color Model

You can select from Default, Grayscale, 3

channel Grayscale or Alpha (Default is the

color model of the original picture). The

color model chosen here, with the exception

of Grayscale, is used only to specify color. It

is not the color model used for the output of

your file.

To select a color model:

1.  Click on the arrow to the right of the

Color Model combo box.

2.  Scroll down and select the color model

you wish to use.

The default color model is the original color

model of the picture if you placed or opened

the picture OR the color model that you

selected if you imported the picture. 

To change the color model of a picture from

CMYK to RGB or RGB to CMYK, use Convert

Picture - see page 66.

For a full explanation of color models and

their uses refer to Chapter 4 - ‘Color Display

Modes’ on page 73.
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Opacity slider
Controls the opacity of the picture layer

from 0 % to 100% where 100% is fully

opaque.

To change the opacity:

1.  Click and hold on the triangle under-

neath the opacity slider.

2.  Slide the slider to the opacity you require

and let go.

OR

●  Enter a value in the Opacity edit box and

hit Tab or Enter.

Selecting a Picture
We have discussed in earlier Chapters how to

‘Open a picture’ and also how to ‘Place a

Picture’. These options create an object that

is the exact size of the picture.

You can also create an object to the size you

require and apply a Picture paint style to the

object. This can be done by using the Picture

paint style.

To apply a picture paint style:

1.  Make sure the object is selected.

2.  Make sure the ‘Fill’ button is selected.

Select the ‘Picture’ button in the Paint Style

palette.

The ‘Picture’ tab to the right of the ‘Fill’

button will be selected and the Preview box

will show the picture that was last loaded

into the ‘Picture’ paint style.

If there is not a picture already loaded, the

Open picture dialog box will open.

If you have Auto-apply checked, your object

will be updated with the picture.

3.  If you require a different picture click on

the Select button to the right of the checker-

board box.

The Open dialog box will open.

The original default folder path will be the

path that is set for Pictures in your Folder

preferences. 

(File > Preferences > Folders > Pictures)

The default folder path from then on is the

path that you last used to open a picture.

4.  If the default folder path is not the path

you require, click on the arrow to the right

of the “Look in” combo box and select a new

directory path.

The “Recent” combo box at the bottom left of

the Open picture dialog box allows you to

select a new directory path from previously

used directory paths. 

This area will appear blank if you have not

previously used another directory. 

5.  The icons across the top of the dialog box

are general Windows functions.

6.  From the “Files of Type” combo box, the

only file type that you can select is DCM

(.dcm;.spl)

7.  Select the picture that you wish to open.

The selected thumbnail and the filename are

now highlighted.
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The Details box at the bottom right of the 

Open picture dialog box displays the rele-

vant information for the file that you have

selected. 

The details include Size, Pixels, Resolution

and Type of file.

10. The file name edit box will show the file 

name of the picture you have selected.  

11. Click the Open button.

The selected picture will display in the

Preview box.

12. If you have Auto-apply checked in the

Paint Style palette, your object will update

with the new picture.

If you don’t have Auto-apply checked, click

on the Apply button in the Paint Style palette

to update the picture inside your object.
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Adjustment Operators
Adjustment operators can be divided into

two groups. 

The first consists of Add, Subtract, Increase,

Decrease, Minimum, Maximum, Multiply,

Divide and Invert adjustment operators.

These are based on simple mathematical

formulae and consequently give relatively

predictable results.

The second group consisting of

Invert/Subtract, Xor, Or, And, and

Subtract/Invert adjustment operators, are

based on complex bitwise logical mathemat-

ical operations. The results of these calcula-

tions are much harder if not impossible to

predict. Experiment freely with these to

achieve special effects.

To apply an adjustment operator:

See ‘Tint Adjust paint style’ on page 148. 

(The adjustment operator controls are the

same for the ‘Picture’ paint style as they are

for the ‘Tint Adjust’ paint style.) 

The examples displayed in the ‘Tint Adjust’

paint style section show you two objects

overlapping. The background is an object

containing a ‘Picture’ paint style. The fore-

ground object (letter c) contains a ‘Tint

Adjust’ paint style with different Adjustment

operators on each picture. 

The calculation used in defining the result of

the Adjustment operators is the same for all

paint styles but the final result is always

different. By using the ‘Picture’ paint style

with Adjustment operators you can create

different effects.

Filter paint style
The ‘Filter’ tab in the Paint Style palette

applies a ‘Filter’ paint style (layer) to the

selected object. Filters allow you to apply

special effects. 

The filters applied here are standard filters

supplied with Wright Design. To use

Photoshop plug-in filters, see ‘Using plug-in
filters’ on page 201. 

Color Model
In the ‘Filter’ paint style, color models are

only used with the Emboss filter and the

emboss control within the Edge filter. You

can select from CMYK, RGB, HSB, Grayscale

or PANTONE®. The color model chosen

here, with the exception of Grayscale and

PANTONE®, is used only to specify color. It

is not the color model used for the output of

your file.

To select a color model:

1.  Click on the arrow to the right of the

Color Model combo box.

2.  Scroll down and select the color model

you wish to use.

For a full explanation of color models and

their uses refer to Chapter 4 - ‘Color Display

Modes’ on page 73.
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Opacity slider
Controls the opacity of the picture layer

from 0 % to 100% where 100% is fully

opaque.

To change the opacity:

1.  Click and hold on the triangle under-

neath the opacity slider.

2.  Slide the slider to the opacity you require

and let go.

OR

●  Enter a value in the Opacity edit box and

hit Tab or Enter.

Selecting colors

In the ‘Filter’ paint style, you have the

option of selecting a color in the Emboss

filter and the emboss control within the

Edge filter only. You can select colors by

using the color pickers, (sliders, rainbow or

swatches) or by entering values in the edit

boxes. 

After selecting a color you can save it as a

swatch to re-use at any time.

As you select a color it becomes the active

Tint Adjust color and is displayed in the

color preview box to the left of the color

picker area.

To select a color:

See ‘Tint paint style’ on page 141. (The

color selection controls are the same 

for the ‘Filter’ paint style as they are for the

‘Tint’ paint style.)

Selecting a Filter
There are six filters to choose from inside

Wright Design. They are Edge, Emboss,

Motion Blur, Noise, Sharpen and Smooth.

Each filter has a range of sub-options that

greatly extend the effects you can create.

These together with the opacity control,

adjustment operators and color pickers

enable you to achieve subtle or spectacular

effects.

To apply a filter paint style:

1.  Make sure the object is selected.

2.  Make sure the ‘Fill’ button is selected.

If you want to add a ‘Filter’ paint style on

top of another paint style click on the plus

button at the top right of the paint style

palette and then select the ‘Filter’ button in

the Paint Style palette.

OR

To apply only a ‘Filter’ paint style to the

selected object select the ‘Filter’ button in

the Paint Style palette. With this option the

object will appear empty if it is not overlap-

ping another object as the filter will be

applied to the white background.

The ‘Filter’ tab to the right of the ‘Fill’

button will be selected.

3.  Click on the arrow to the right of the

filters combo box.

A drop-down menu will appear.
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4.  Scroll down the menu and select the filter

you require.

5.  The Paint Style palette now displays sub-

options for the filter you have selected.

Enter values and select the options you

require. Each filter is described separately on

the following pages.

6.  If you have Auto-apply checked in the

Paint Style palette, your object will update

with the filter selected.

If you don’t have Auto-apply checked, click

on the Apply button in the Paint Style palette

to update the filter inside your object.

Types of Filters

EDGE - The Edge filters identify the areas of

the underlying paint style (layer) or object,

that have significant transitions, and it

emphasizes the edges.

There are four types of Edge filters. They are:

Sobel, Roberts, Roberts Cross and Prewitt.

These filters have the name of the people

that produced the filters.  

Within each type of Edge filter you have the

choice of four sub-options. They are: Add,

Subtract, Replace and Emboss.

Add - will add the edge that is identified to

the underlying paint style (layer) or object.

Subtract - will subtract the edge that is iden-

tified from the underlying paint style (layer)

or object.

Replace - gives you the actual edge that is

identified from the underlying paint style

(layer) or object.

Emboss - will emboss the edge that is identi-

fied from the underlying paint style (layer) or

object.

To apply an Edge filter:

1.  Select the Edge filter.

2.  Select the type of filter you require. The

options are Sobel, Roberts, Roberts Cross

and Prewitt.

3.  Select the option you require. They are

Add, Subtract, Replace and Emboss.

EMBOSS - The Emboss filter creates a raised

or stamped effect by suppressing the color of

the underlying paint style (layer) or object

and tracing its edges with black.

To apply an Emboss filter:

1.  Select the Emboss filter.

2.  Enter the Extent you require. The Extent

is the height of the Embossing. You can

enter a value between .01mm and 999mm.

The unit of measurement will be the applica-

tion default. Right mouse-clicking will give

you the following options: mm, cm, inches,

points and pixels.

3.  Enter a percentage in the Amount edit

box between 1% and 9999%. 1% produces

the least amount of detail where as 9999%

retains full detail at the edges.

4.  Enter the angle you want the embossing

to be at. You can enter a value between -360

and 360.

5.  Select a color.
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MOTION BLUR - The Motion Blur filter

produces a blur effect in a particular direc-

tion and of a specific intensity. The effect of

this filter simulates taking a picture of a

moving object with a fixed exposure time.

To apply a Motion Blur filter:

1.  Select the Motion Blur filter.

2.  Enter the angle to indicate the direction

the subject should appear to be moving. You

can enter a value between -360 and 360

degrees.

3.  Enter the Extent you require to deter-

mine the intensity of the blur. You can enter

a value between .01mm and 999mm.

The unit of measurement will be the applica-

tion default. Right mouse-clicking will give

you the following options: mm, cm, inches,

points and pixels.

NOISE - The Noise filter applies random

pixels to the underlying paint style (layer) or

object to simulate the effect of shooting

pictures using a high-speed film.

To apply a Noise filter:

1.  Select the Noise filter.

2.  Enter the Amount you require. The

Amount you specify is used as the standard

deviation of the color values of the noise.

You can enter a value between 1% and

9999%.  

3.  Enter a value in the Granularity edit box

between 0mm  and 999mm. Granularity sets

the size of the noise.

The unit of measurement will be the applica-

tion default. Right mouse-clicking will give

you the following options: mm, cm, inches,

points and pixels.

4.  Check Monochrome if required. This

applies the filter to the tonal elements only

of the underlying paint style (layer) or object

without changing colors.

5.  Check Inverse if required.  Inverse will

invert the underlying paint style (layer) or

object, apply the noise and invert it back. 

SHARPEN - The Sharpen filter provided is an

Unsharp Mask filter. This adjusts the contrast

of edge detail, creating the illusion of more

sharpness. This filter can be useful for refo-

cusing a picture that has become blurry from

interpolation or scanning.

To apply a Sharpen filter:

1.  Select the Sharpen filter.

2.  Enter the Extent you require to deter-

mine the depth of pixels that will be affected

at the edge. You can enter a value between

.01mm and 999mm.

The unit of measurement will be the applica-

tion default. Right mouse-clicking will give

you the following options: mm, cm, inches,

points and pixels.

3.  Enter a value in the Amount box to

specify the percentage of the filter’s effect,

between 1% and 999%. The higher the

percentage the stronger the effect of the

filter. 
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SMOOTH - The Smooth filter provides you

with two options. 

Median Smoothing - where the filter

replaces each pixel with the average of all

pixels within a given radius.

This effect blends the brightness of the

pixels within a selection by discarding pixels

that are too different from adjacent pixels.

Normal Smoothing - where the filter

searches the radius of a selection of pixels

and replaces the center pixel with a median

brightness value of those pixels. 

This effect blends the brightness of the

pixels within a selection by discarding pixels

that are too different from adjacent pixels.

To apply a Smooth filter:

1.  Select the Smooth filter.

2.  Enter the Extent you require to deter-

mine 

The unit of measurement will be the applica-

tion default. Right mouse-clicking will give

you the following options: mm, cm, inches,

points and pixels.

3.  Click on either Median or Smooth.

Adjustment Operators
Adjustment operators can be divided into

two groups. 

The first consists of Add, Subtract, Increase,

Decrease, Minimum, Maximum, Multiply,

Divide and Invert adjustment operators.

These are based on simple mathematical

formulae and consequently give relatively

predictable results.

The second group consisting of

Invert/Subtract, Xor, Or, And, and

Subtract/Invert adjustment operators, are

based on complex bitwise logical mathemat-

ical operations. The results of these calcula-

tions are much harder if not impossible to

predict. Experiment freely with these to

achieve special effects.

To apply an adjustment operator:

See ‘Tint Adjust paint style’ on page 148. 

(The adjustment operator controls are the

same for the ‘Filter’ paint style as they are

for the ‘Tint Adjust paint style.) 

The examples displayed in the ‘Tint Adjust’

paint style section show you two objects

overlapping. The background is an object

containing a ‘Picture’ paint style. The fore-

ground object (letter c) contains a ‘Tint

Adjust’ paint style with different Adjustment

operators on each picture. 

The calculation used in defining the result of

the Adjustment operators is the same for all

paint styles but the final result is always

different. By using the ‘Filter’ paint style

with Adjustment operators you can create

some great effects.
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Filter Types -
Here are some examples showing you an object containing a ‘Picture’ paint

style with a ‘Filter’ paint style added on to it. Filters can be added to any type

of paint style (layer) and you can also give each filter an Adjustment operator to

achieve varying results.

EDGE FILTERS
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Sobel  -  SubtractSobel  -  Add

Prewitt  -  Add Prewitt  -  Subtract Prewitt  -  Replace Prewitt  -  Emboss

Roberts  Cross  -
Emboss

Roberts  Cross  -
Replace

Roberts  Cross  -
Add

Roberts  -  EmbossRoberts  -  ReplaceRoberts  -  SubtractRoberts  -  Add

Roberts  Cross  -
Subtract

Sobel  -  Replace Sobel  -  Emboss



EMBOSS MOTION BLUR SMOOTH

NOISE SHARPEN
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Gradient paint style
The ‘Gradient’ tab in the Paint Style palette

applies a ‘Gradient’ paint style (layer) to the

selected object. 

You can create color and grayscale gradients,

or by selecting the Alpha color model you

can use the ‘Gradient’ paint style to blend

objects into the background. 

Color Model
In the ‘Gradient’ paint style, you can select

from CMYK, RGB, HSB, Grayscale,

PANTONE® or Alpha color models. The

color model chosen here, with the exception

of Grayscale and PANTONE®, is used only to

specify color. It is not the color model used

for the output of your file.

To select a color model:

1.  Click on the arrow to the right of the

Color Model combo box.

2.  Scroll down and select the color model

you wish to use.

For a full explanation of color models and

their uses refer to Chapter 4 - ‘Color Display

Modes’ on page 73.
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Gradient Styles
There is a list of sixteen gradient styles to

choose from. Each style gives you a different

effect.

An example of each of the styles is shown

below in black and white, but the gradients

can consist of any color and as many colors

as you like.

You can also transform and tile the gradients

to achieve the effect you want.

Linear Mid-point

Bilinear Rectangular

Cross Star

Elliptical Radial

Spiral Butterfly

Sunrise Blast

Square Ellipse Fingerprint

Diamond Diagonal
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Opacity slider
Controls the opacity of the picture layer

from 0 % to 100% where 100% is fully

opaque.

To change the opacity:

1.  Click and hold on the triangle under-

neath the opacity slider.

2.  Slide the slider to the opacity you require

and let go.

OR

●  Enter a value in the Opacity edit box and

hit Tab or Enter.

Adjustment Operators
Adjustment operators can be divided into

two groups. 

The first consists of Add, Subtract, Increase,

Decrease, Minimum, Maximum, Multiply,

Divide and Invert adjustment operators.

These are based on simple mathematical

formulae and consequently give relatively

predictable results.

The second group consisting of

Invert/Subtract, Xor, Or, And, and

Subtract/Invert adjustment operators, are

based on complex bitwise logical mathemat-

ical operations. The results of these calcula-

tions are much harder if not impossible to

predict. Experiment freely with these to

achieve special effects.

To apply an adjustment operator:

See ‘Tint Adjust paint style’ on page 148. 

(The adjustment operator controls are the

same for the ‘Gradient’ paint style as they

are for the ‘Tint Adjust paint style.) 

The examples displayed in the ‘Tint Adjust’

paint style section show you two objects

overlapping. The background is an object

containing a ‘Picture’ paint style. The fore-

ground object (letter c) contains a ‘Tint

Adjust’ paint style with different Adjustment

operators on each picture. 

The calculation used in defining the result of

the Adjustment operators is the same for all

paint styles but the final result is always

different. By using the ‘Gradient’ paint style

with Adjustment operators you can create

some great effects.

Selecting colors
In the ‘Gradient’ paint style you can select

colors by using the color pickers, (sliders,

rainbow or swatches) or by entering values

in the edit boxes. 

You can also select colors from anywhere on

your page by using the Eyedropper tool. 

After selecting a color you can save it as a

swatch to re-use at any time.

As you select a color it becomes the active

Gradient color and is displayed in the color

preview box above the color picker area.

To select a color:

See ‘Tint paint style’ on page 141. (The

color selection controls are the same for the

‘Gradient’ paint style as they are for the

‘Tint’ paint style.)
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Creating a Gradient
Wright Design allows you to create many

different variations of gradients.  

To apply a gradient paint style:

1.  Make sure the object is selected.

2.  Make sure the ‘Fill’ button is selected.

Select the ‘Gradient’ tab in the Paint Style

palette

The ‘Gradient’ button to the right of the

‘Fill’ button will be selected.

3.  Click on the arrow to the right of the

Gradient styles combo box.

A drop-down menu will appear.

4.  Scroll down the menu and select the

gradient you require.

5.  Now we can select the colors. In this

example we are going to use the CMYK color

model with the Rainbow color picker to

select the color. To use the Sliders or

Swatches to select color see ‘Tint paint style’
on page 141.

6.  Select the top triangle to the right of the

color gradient box. The triangle will turn

black, this shows you it is selected.

This point represents the top of your

‘Gradient’ paint style (layer) inside the

object you have selected.

7.  Select a color using one of the Color

pickers. You will see the color that you

selected display in the top half of the Color

gradient box.

8.  Select the bottom triangle to the right of

the color gradient box. The triangle will turn

black, this shows you it is selected.

This point represents the bottom of your

‘Gradient’ paint style (layer) inside the

object you have selected.

9.  Select a color from the one of the Color

pickers. You will see the color that you

selected display in the bottom half of the

Color gradient box.
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You now have a gradient running from one

color at the top to a different color at the

bottom.

10. You can add points to the Color Gradient

box. This allows you to add more colors or to

alter the point at which the gradation starts

and finishes.

To add a new point, click either inside or on

the right hand side of the Color Gradient

box.

A new triangle is created. The triangle will be

black, this shows you it is selected.

11. To change the color of the gradient at

this point select a color from the one of the

Color pickers.

This color will now show at the selected

point on the Color Gradient box.

There is no limit to the number of points

that can be added to the Color Gradient box.

You can change the color model of

your colors at any time whilst creating your

gradient. 

One end of your gradient can be a CMYK

color model and the other end can be a

PANTONE® color model. Therefore you

have a CMYK color gradating into a

PANTONE® color.

12. You can change the position of the

points(triangles) on the Color Gradient box,

to alter the point at which the gradation

starts and finishes. (The top and bottom

points cannot be moved or deleted.)

To move a point (triangle), click on it to

select it and hold, then drag it to its new

position.

You will see the colors update in the Color

Gradient box as you move the points.
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13. To delete an unwanted point (triangle),

click on it to select it and hold, then drag it

either to the top or bottom of the color

gradient box.

14. Enter a value in the Repeat edit box if

required. This will repeat the colors you

have created by the value specified within

the object you have selected.

You will see this in your object, but not in

the color gradient box.

Repeat is 0 Repeat is 1

15. Check the Tile checkbox if required. This

will tile the entire gradient by the value spec-

ified within the object you have selected.

You cannot see the tiling unless you move

the gradient (LAYER) around inside the

object or you scale up the SHAPE of the

object. 

To do this see Chapter 7 - ‘Editing objects

and/or layers’, ‘Transforming objects’ on

page 223.

No Tile Tile with Gradient 
layer moved

16. Check the Smooth check box if required.

This will smooth out the transition between 

the colors in your gradient.

17.  If you have Auto-apply checked in the

Paint Style palette your object will update

with the gradient selected.

If you don’t have Auto-apply checked click

on the Apply button in the Paint Style palette

to update the gradient inside your object.

To invert a gradient:

1.  Right mouse-click anywhere inside the

Gradient area on the Paint Style palette.

A drop down menu will appear.

2.  Scroll down and select Invert Gradient

The Gradient will now be be inverted. The

color at the top will now be at the bottom,

and the color at the bottom will now be at

the top.

To reset the color gradient box:

1.  Right mouse-click anywhere inside the

Gradient area on the Paint Style palette.

A drop down menu will appear.

2.  Scroll down and select Reset Gradient.
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The Gradient will now be reset to the default

gradient setting running from white to black.

To change the direction of a gradient:

1.  Make sure the object with a Gradient

paint style is selected.

2.  Select the Gradient tool from the tool

palette.

The Gradient tool modifier will display the

following:

The four buttons in the Gradient tool modi-

fier control the direction of the gradient.

3.  To change the direction of the Gradient

select one of the four buttons.

The first button changes the direction

of the gradient to match the direction that is

displayed in the Gradient paint style.

The second button flips or inverts the

gradient so that it is running in the opposite

direction to the gradient above.

The third button changes the direction

of the gradient so that it runs from right to

left. 

The fourth button changes the direc-

tion of the gradient so that it runs from left

to right.

You can also transform a gradient by

selecting the LAYER mode and applying a

transformation.

To change the length of a gradient by drag-
ging:

1.  Make sure the object with a Gradient

paint style is selected.
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2.  Select the Gradient tool from the tool

palette.

3.  Click on your gradient at the bottom

right and drag. 

You will see a line display. This is showing

you the angle and length of your gradient. 

4.  Let go at the top right of your gradient.

Your gradient will now have changed direc-

tion and length.

The effect below was produced by scrolling

from the bottom left to the top right as

above, but the length of the drag was a great

deal smaller.

Color Mask paint style
The ‘Color Mask’ tab in the Paint Style

palette applies a ‘Color Mask’ paint style

(layer) to the selected object. 

The ‘Color Mask’ paint style, together with

the Color Mask tool from the Tool palette, is

used with either Picture or Bitmap objects to

mask certain areas based on color content.

Typical uses include masking difficult

subjects like hair or fur, or a bicycle wheel.

After applying the Color Mask you then build

the mask. On building the mask, the Color

Mask paint style (layer) is converted into a

Mask object and you therefore no longer see

the Color Mask paint style (layer) in the Paint

Style palette. 

A ‘Color Mask’ paint style (layer) can be

applied to any other paint style (layer). In

this example we will go through the proce-

dure of masking a ‘Picture’ paint style

(layer). 

To create a color mask:

1.  Place a picture into your page.
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2.  Select the Color Mask tool from the

Tool palette.

3.  Select a point, or drag over the part of

the picture you wish to mask.

The Paint Style palette will now display the

‘Color Mask’ paint style (layer) added to the

‘Picture’ paint style (layer). This is seen in

the picture above.

The object now displays as black and white.

The black areas correspond to the masked

areas, and the white areas, to the non-

masked areas. 4.  To continue adding to your mask, click

on the Add modifier tool from the tool

modifier ribbon. 
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5.  Select another point, or drag over

another area of the picture you wish to

mask.

If you have the New modifier tool 

selected, any selection you make replaces

the previous selection.

If you have the Subtract modifier tool 

selected, any selection you make subtracts

from those selections you have already

made. 

6.  There are five mask modes in the Paint

Style palette to switch between whilst

creating your mask. 

Each mode gives you a different view and

therefore helps you in creating your mask.

These mask modes also control the way in

which the mask is built.

7.  To select a different view, click on the

mask mode you wish to use.

The five mask modes are as follows :

Black/white mode - shows you the masked

area as black and the unmasked area as

white.

Black mode - shows you the masked area as

black and the unmasked area shows you the

underlying paint style (layer) or object.

White mode - shows you the masked area as

white and the unmasked area shows you the

underlying paint style (layer) or object.

Transparent mode - shows you a transparent

mask.

Background mode - shows you the masked

area as transparent and the unmasked area

shows you the underlying paint style (layer)

or object.

8.  Continue this procedure until you are

satisfied with the mask that has been

created.

If you don’t like the mask you have

created and you want to start creating your

mask from the beginning, click on the None

button in the Paint Style palette or the Select

None button from the tool modifier ribbon.
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Clicking on the All button  in the Paint

Style palette or the Select All button from

the tool modifier ribbon will create a mask of

the entire object.

To undo your mask selections step by step

use the Ctrl + Z keys on your keyboard.

9.  To invert the mask if required, select the

Invert button in the Paint Style palette.

10. The Softness slider defaults to 10. This

controls how the edges of the mask gradate

or fade off. The softness is also shown in the

channel sliders (by the keylined triangles)

and this is updated as you move the Softness

slider.

To change the softness of the mask, click on

the keylined triangle and drag it to its new

position

OR

Type in the value you require in the edit box

to the left of the Softness slider.

11. Some masks that you create don’t need

fine tuning. If you are satisfied with the mask

you have created and you don’t wish to fine

tune it, go to Step18 to build the mask.

Remember that after building the mask

you can add to and subtract from the mask

to edit it.

If you want to fine tune individual channels
continue with Step 12:

12. As you have previously selected areas to

mask, the channel sliders in the Paint Style

palette are automatically adjusted. 

The solid triangles control the range of

color that you are masking out. The edit

boxes to the left and right of the channel

sliders give you a readout of where the solid

triangles are positioned on the channel

sliders.

So in the example shown above, the mask is

being created where the cyan is between

36% and 62%,  the magenta is between 27%

and 52%,  the yellow is between 13% and

32% and the black is between 0% and 1%. 

13. To change the range of color that you

wish to create your mask from, click on the

left solid triangle of one of the channel

sliders and drag it to its new position.

OR

Type in the value you require in the edit box

to the left of the slider.
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You can now see that the left side of the

cyan channel has changed. The mask is now

being created where the cyan is between

24% and 62%.

14. To change the range of color that you

wish to create your mask to, click on the

right solid triangle of one of the channel

sliders and drag it to its new position.

OR

Type in the value you require in the edit box

to the right of the slider.

You can now see that the right side of the

cyan channel has changed. The mask is now

being created where the cyan is between

24% and 74%.

15. As we said earlier, the softness is also

shown in the channel sliders. This is shown

by the distance between the solid triangle

and the keylined triangle.

Each individual channel slider shows the

softness that has been set in the Softness

slider, but you can change the softness of

each individual channel.

16. To change the softness of a single

channel, click on one of the keylined trian-

gles and move it to a new position. 

If you have Auto-apply checked your mask

will update dynamically as you move the

slider. If you don’t have Auto-apply checked,

click on the Apply button to update your

mask.

As you move the keylined triangle on the

channel slider you can see the gradation

between the solid triangle and the keylined

triangle change. This shows you how the

edge of the mask is fading off.

17. You can continue to change the softness

of each individual channel. 

As you do change each individual channel

the Softness slider shows you an average of

all the channels softness.

182 Chapter 6 - Filling Objects with Layers



18. You are now ready to build the mask.

Select the mask mode you require to build

your mask.

Black/white mode - builds the mask object

on top of the original object with the masked

area containing a black ‘Tint’ paint style

(layer).

Black mode - builds the mask object on top

of the original object with the masked area

containing a black ‘Tint’ paint style (layer).

An example: This mode allows you to leave

the masked object ‘Tint’ paint style (layer)

as it is, change the color of the masked

object ‘Tint’ paint style (layer) as below or

change the paint style altogether.

This is used the same as the Black/white

mode and the White mode. 

White mode - builds the mask object on top

of the original object with the masked area

containing a white ‘Tint’ paint style (layer).

This is used the same as the Black/white

mode and the Black mode.

Transparent mode - builds the mask object

on top of the original object with the masked

area containing the original ‘Picture’ paint

style (layer).
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An example: This mode allows you to easily

add a ‘Color Curve’ paint style (layer) to the

‘Picture’ paint style (layer) in the masked

object to darken the color of the sky, but not

affect the balloon.

Background mode - overrides the original

object with the masked object with the back-

ground dropped out.

An example: This mode allows you to drop

out the background of the object containing

the balloon to see through to the underlying

object containing a ‘Picture’ paint style

(layer) of water.

19. Select the Build Mask button from the

tool modifier ribbon.

The Task Manager will display, showing you

the mask is processing.

When the mask has finished processing the

Task Manager will close and the Mask object

will display.

20. The new object will display as a Mask

object in the Object List.

The Mask object is automatically grouped to

the original object and shows as a Group in

the Object List. 

The new Mask object will automatically be

selected.

After you have built your mask the

mask object is a Bitmap object. You can edit

the object by adding to or subracting from it

using the Brush tool. For more information

on using the Brush tool see: Chapter 8 -

‘Painting and Cloning’ - ‘The Brush tool’ on

page 257.
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Selective Color Correction
paint style
The ‘Selective Color Correction’ tab in the

Paint Style palette applies a ‘Selective Color

Correction’ paint style (layer) to the selected

object. 

This paint style is used to modify or color

correct specific colors. You can make a red

color brighter by taking cyan out of reds

without affecting any other colors.

Alternatively, you can change colors

completely, such as reds into blues.

Opacity slider
Controls the opacity of the picture layer

from 0 % to 100% where 100% is fully

opaque.

To change the opacity:

1.  Click and hold on the triangle under-

neath the opacity slider.

2.  Slide the slider to the opacity you require

and let go.

OR

●  Enter a value in the Opacity edit box and

hit Tab or Enter.
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Adjustment Operators
Adjustment operators can be divided into

two groups. 

The first consists of Add, Subtract, Increase,

Decrease, Minimum, Maximum, Multiply,

Divide and Invert adjustment operators.

These are based on simple mathematical

formulae and consequently give relatively

predictable results.

The second group consisting of

Invert/Subtract, Xor, Or, And, and

Subtract/Invert adjustment operators, are

based on complex bitwise logical mathemat-

ical operations. The results of these calcula-

tions are much harder if not impossible to

predict. Experiment freely with these to

achieve special effects.

To apply an adjustment operator:

See ‘Tint Adjust paint style’ on page 148. 

(The adjustment operator controls are the

same for the ‘Selective Color Correction’

paint style as they are for the ‘Tint Adjust

paint style.) 

The examples displayed in the ‘Tint Adjust’

paint style section show you two objects

overlapping. The background is an object

containing a ‘Picture’ paint style. The fore-

ground object (letter c) contains a ‘Tint

Adjust’ paint style with different Adjustment

operators on each picture. 

The calculation used in defining the result of

the Adjustment operators is the same for all

paint styles but the final result is always

different. By using the ‘Selective Color

Correction’ paint style with Adjustment oper-

ators you can create some great effects.

Applying Selective Color Correction
As we said earlier, you can use Selective

Color Correction to adjust a color slightly or

to completely change a color.

We will now explain the operation involved

in creating these effects. The examples used

have an object that contains a ‘Picture’ paint

style (layer), with the ‘Selective Color

Correction’ paint style (layer) added on top.

Applying selective color correction to
change a color slightly:

1.  Make sure the object is selected.

2.  Place a Picture.

3.  Make sure the ‘Fill’ button is selected.

4.  Click on the Add button at the top

right of the Paint Style palette, to add a paint

style (layer).

5.  Select the ‘Selective Color Correction’

tab in the Paint Style palette

The ‘Selective Color Correction’ tab to the

right of the ‘Fill’ button will be selected.
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6.  Select the color you wish to modify from

the selection of Target colors. 

In this example, we select Red.

7.  Now go across to the sliders and click and

drag on the triangle of the color you wish to

add to or subtract from the target color. 

OR

Type in the value you require in the edit box

to the left of the slider.

In this example, we want to take cyan out of

reds. So, we click and drag the cyan slider to

the left.

The sliders’ default positions are in the

center. Adjusting them to the left subtracts

color, and to the right adds color.

If you have Auto-apply checked, your page

will update dynamically as you move the

slider. If you don’t have Auto-apply checked,

click on the Apply button to update your

page.

You can now see that cyan has been taken

out of reds, but no other color has been

affected.

Applying selective color correction to
completely change a color:

1.  Place a Picture.

2.  Make sure the ‘Fill’ button is selected.

3.  Click on the Add button at the top

right of the Paint Style palette, to add a paint

style (layer).

4.  Select the ‘Selective Color Correction’

tab in the Paint Style palette
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The ‘Selective Color Correction’ tab to the

right of the ‘Fill’ button will be selected.

5.  Select the color you wish to modify from

the selection of Target colors. 

In this example, we select Cyan.

6.  Now go across to the sliders and click and

drag on the triangle of the color you wish to

add to or subtract from the target color. 

OR

Type in the value you require in the edit box

to the left of the slider.

In this example, we want to change the color

of the sky. So, we click and drag the magenta

slider to the left to take magenta out. Then

click and drag the yellow slider to the right

to add yellow.

The sliders’ default positions are in the

center. Adjusting them to the left subtracts

color, and to the right adds color.

If you have Auto-apply checked, your page

will update dynamically as you move the

slider. If you don’t have Auto-apply checked,

click on the Apply button to update your

page.

You can now see that magenta has been

taken out of cyans, yellow has been added to

cyans but no other color has been affected.

To set a color back to zero:

1.  Right mouse-click anywhere inside the

Selective Color Correction area on the Paint

Style palette.

A drop down menu will appear.

2.  Scroll down and select Set this Color to

Zero.

The sliders for the selected target color will

now be set to zero.

To set all colors back to zero:

1.  Right mouse-click anywhere inside the

Selective Color Correction area on the Paint

Style palette.

A drop down menu will appear.
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2.  Scroll down and select Set all Colors to

Zero.

The sliders for all the target colors will now

be set to zero.

To reset all the values for the Selective Color
Correction paint style:

1.  Right mouse-click anywhere inside the

Selective Color Correction area on the Paint

Style palette.

A drop down menu will appear.

2.  Scroll down and select Reset all values.

All of the controls in the Selective Color

Correction paint style, including the opacity

and adjustment operators will now be reset.

Brightness/Contrast
paint style
The ‘Brightness/Contrast’ tab in the Paint

Style palette applies a ‘Brightness/Contrast’

paint style (layer) to the selected object. 

This paint style makes simple adjustments to

the tonal range. It adjusts the highlights,

midtones and shadows all at once.

Opacity slider
Controls the opacity of the Brightness

/Contrast layer from 0 % to 100% where

100% is fully opaque.

Brightness/Contrast paint style

Brightness/Contrast paint style (layer)

Brightness slider

Contrast slider



To change the opacity:

1.  Click and hold on the triangle under-

neath the opacity slider.

2.  Slide the slider to the opacity you require

and let go.

OR

●  Enter a value in the Opacity edit box and

hit Tab or Enter.

Applying Brightness and Contrast
You can use the Brightness and Contrast

paint style (layer) to add or subtract bright-

ness or contrast from an underlying paint

style (layer) or object. 

Applying brightness and contrast:

1.  Make sure the object is selected.

2.  Make sure the ‘Fill’ button is selected.

3.  If you want to add a

‘Brightness/Contrast’ paint style on top of

another paint style click on the plus button

at the top right of the paint style palette and

then select the ‘Brightness/Contrast’ button

in the Paint Style palette.

OR

To apply only a ‘Brightness/Contrast’ paint

style to the selected object select the

‘Brightness/Contrast’ button in the Paint

Style palette. With this option the object will

appear empty if it is not overlapping another

object as the brightness and/or contrast will

be applied to the white background.

The ‘Brightness/Contrast’ tab to the right of

the ‘Fill’ button will be selected. 

4.  To change the Brightness of the paint

style (layer), click and drag on the triangle

underneath the Brightness slider.

OR

Type in the value you require in the edit box

to the left of the slider.

Moving the slider to the left will darken the

paint style (layer) and to the right will

lighten the paint style (layer).

5.  To change the Contrast of the paint style

(layer), click and drag on the triangle under-

neath the Contrast slider.

OR

Type in the value you require in the edit box

to the left of the slider.

Moving the slider to the left will give you less

contrast and to the right will give you more

contrast.

To reset all the values for the
Brightness/Contrast paint style:

1.  Right mouse-click anywhere inside the

Brightness/Contrast area on the Paint Style

palette.

A drop down menu will appear.

2.  Scroll down and select Reset all values.

All of the controls in the Brightness/Contrast

paint style, including the opacity will now be

reset.
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Hue/Saturation paint style
The ‘Hue/Saturation’ tab in the Paint Style

palette applies a ‘Hue/Saturation paint style

(layer) to the selected object. 

This paint style allows you to adjust the hue,

saturation, and lightness of individual color

components. You can also colorize using this

paint style.

Opacity slider
Controls the opacity of the Hue/Saturation

layer from 0 % to 100% where 100% is fully

opaque.

To change the opacity:

1.  Click and hold on the triangle under-

neath the opacity slider.

2.  Slide the slider to the opacity you require

and let go.

OR

●  Enter a value in the Opacity edit box and

hit Tab or Enter.
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Applying Hue and Saturation

You can use the Hue and Saturation paint

style (layer) to change the Hue (color),

Saturation and/or Lightness of particular

target colors in the underlying paint style

(layer) or object. 

We will now explain the operation involved

in creating these effects. The examples used

have an object that contains a ‘Picture’ paint

style (layer), with the ‘Hue/Saturation’ paint

style (layer) added on top.

To apply a Hue/Saturation paint style:

1.  Place a Picture.

2.  Make sure the ‘Fill’ button is selected.

3.  Click on the Add button at the top

right of the Paint Style palette, to add a paint

style (layer).

4.  Select the ‘Hue/Saturation’ tab in the

Paint Style palette

The ‘Hue/Saturation’ button to the right of

the ‘Fill’ button will be selected.

5.  Select the color you wish to modify from

the selection of Target colors. 

In this example, we select Blue.

You can click on the Select All button

to select all of the colors. If this is selected,

all of the colors will be modified.

Holding down the Shift key allows you

to multiple select adjacent colors and

holding down the Crtl key will allow you to

select random colors.

6.  To change the Hue, go across to the

sliders and click and drag on the triangle

underneath the Hue slider to select a new

color OR enter a value in the Hue edit box.

The target color selected will now change to

the color you have selected on the Hue

slider.

In this example, we want to change the blue

colors to pink. So, we click and drag the Hue

slider to select a pinky-red color.
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If you have Auto-apply checked your page

will update dynamically as you move the

slider. If you don’t have Auto-apply checked,

click on the Apply button to update your

page.

You can now see that the blue colors are

now a pinky color.

7.  To change the Saturation of the target

color you selected in Step 5, click and drag

on the triangle underneath the Saturation

slider. 

OR

Type in the value you require in the edit box

to the left of the slider.

The slider’s default position is in the

centre. Adjusting the slider to the left will

desaturate and to the right will add satura-

tion.

If you have Auto-apply checked your page

will update dynamically as you move the

slider. If you don’t have Auto-apply checked,

click on the Apply button to update your

page.

8.  To change the Lightness of the target

color you selected in Step 5, click and drag

on the triangle underneath the Lightness

slider. 

OR

Type in the value you require in the edit box

to the left of the slider.

The slider’s default position is in the

centre. Adjusting the slider to the left will

darken and to the right will lighten.

If you have Auto-apply checked your page

will update dynamically as you move the

slider. If you don’t have Auto-apply checked,

click on the Apply button to update your

page.

To apply colorize:

1.  Place a Picture.
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2.  Make sure the ‘Fill’ button is selected.

3.  Click on the Add button at the top

right of the Paint Style palette, to add a paint

style (layer).

4.  Select the ‘Hue/Saturation’ tab in the

Paint Style palette

The ‘Hue/Saturation’ tab to the right of the

‘Fill’ button will be selected.

5.  Check the Colorize check box.

6.  To change the Hue, go across to the

sliders and click and drag on the triangle

underneath the Hue slider to select a new

color.

In this example, we want to colorize the

picture to be orange.  So, we click and drag

the Hue slider to select an orange color.

If you have Auto-apply checked your page

will update dynamically as you move the

slider. If you don’t have Auto-apply checked,

click on the Apply button to update your

page.

You can now see that the picture has been

colorized to orange.

7.  To change the Saturation of the color you

selected,  click and drag on the triangle

underneath the Saturation slider. 

OR

Type in the value you require in the edit box

to the left of the slider.

The slider’s default position is to the

far right (100%). Adjusting the slider to the

left will desaturate the picture.

If you have Auto-apply checked your page

will update dynamically as you move the

slider. If you don’t have Auto-apply checked,

click on the Apply button to update your

page.

8.  To change the Lightness of the color you

selected, click and drag on the triangle

underneath the Lightness slider. 

OR
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Type in the value you require in the edit box

to the left of the slider.

The slider’s default position is in the

centre. Adjusting the slider to the left will

darken and to the right will lighten.

To reset selected channel(s) in the
Hue/Saturation paint style:

1.  Right mouse-click anywhere inside the

Hue/Saturation area on the Paint Style

palette.

A drop down menu will appear.

2.  Scroll down and select Reset Selected

Channel(s).

The selected channel(s) in the Brightness

/Contrast paint style will now be reset.

To reset all values in the Hue/Saturation
paint style:

1.  Right mouse-click anywhere inside the

Hue/Saturation area on the Paint Style

palette.

A drop down menu will appear.

2.  Scroll down and select Reset All Values.

All of the controls in the Hue/Saturation

paint style, including the opacity will now be

reset.

Alpha Channels

Think of an Alpha channel as a way of

controlling an object’s opacity. A 100% (solid

black) value means no transparency.

Anything less than 100% imparts a degree of

transparency. A value of 0% means the object

is totally transparent and therefore invisible. 

All of the paint styles in the Paint Style

palette except the ‘Color Mask’ paint style

have an Opacity control slider. This allows

you to regulate the opacity of each single

layer in an object.

The Alpha channel allows you to actually add

specific paint styles (‘Tint’, ‘Color Curve’,

‘Picture’ or ‘Gradient’) into the Alpha

channel. For example, you can have an Alpha

channel of a ‘Gradient’ paint style set to

linear, underlying a ‘Picture’ paint style. This

will give you the effect of the picture

gradating from fully opaque at the top to

transparent at the bottom. 

Or, as another example, you can create a

spot color separation by having an Alpha

channel of a ‘Picture’ paint style, underlying

a ‘Tint’ paint style with a PANTONE color

model. 

Alpha channels are controlled as a color

model and are added as layers to the Paint

Style palette. You can have as many Alpha

channels in the one object as you like.
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To apply a Gradient Alpha channel to a
Picture paint style (layer):

In this example, we will use the ‘Gradient’

paint style set to an Alpha channel to gradate

a ‘Picture’ paint style from fully opaque at

the top to transparent at the bottom. We will

then use the same Alpha channel to gradate

a ‘Tint’ paint style.

1.  Open or place a picture.

Your Picture object will display.

2.  Select the Picture object you have just

opened.

3.  Go to the Paint Style palette and click on

the Add button at the top right

A new paint style (layer) will be added, the

same as the original paint style.

4.  Select the first paint style (layer). This is

the one on the left. In order of priority, this

is underneath the one that you just added.

5.  Select the ‘Gradient’ paint style (layer).

6.  Select the Alpha color model.

A black triangle will appear in the top right

of the paint style to indicate the paint style

(layer) is an Alpha channel

The ‘Gradient’ paint style (layer) in the

Alpha channel now shows.

If you have Auto-apply checked your page

will update automatically. If you don’t have

Auto-apply checked, click on the Apply

button to update.

7.  To Invert the Gradient, right mouse-click,

scroll down the menu and select Invert

Gradient.
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The result above shows you a linear gradient

with the sliders set to 100% opaque at the

top to 0% at the bottom. 

You can achieve many effects by changing

the options in the ‘Gradient’ paint style

(layer). There are all the different styles of

gradients to choose from and you can add

points anywhere along the slider to change

the effect.

For more information on the ‘Gradient paint
style’ see page 171. 

To apply a Gradient Alpha channel to a ‘Tint’
paint style (layer):

In the example provided we are applying the

Gradient Alpha channel to a blue tint that is

sitting on top of the Tree picture that has an

Alpha channel applied to it.

1.  Make sure that you don’t have any

objects selected.

2.  Go to the Paint Style palette select the

‘Tint’ paint style (layer).

3.  Select the rectangle vector tool from

the vector tool bar.

4.  Select the new modifier tool from the

tool modifier ribbon.

5.  Position your cursor at the point where

you would like to start your rectangle.

6.  Click and drag the cursor to where you

want the opposite corner to be.

7.  Release the mouse and your object is

created.

3.  Go to the Paint Style palette and click on

the Add button at the top right

A new paint style (layer) will be added, the

same as the original paint style.

4.  Select the first paint style (layer). This is

the one on the left. 
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In order of priority, this is underneath the

one that you just added.

5.  Select the ‘Gradient’ paint style (layer).

6.  Select the Alpha color mode.

A black triangle will appear in the top right

of the paint style to indicate the paint style

(layer) is an Alpha channel

The ‘Gradient’ paint style (layer) in the

Alpha channel now shows. 

The result above shows you a linear gradient

with the sliders set to 100% opaque at the

bottom to 0% at the top. You can achieve

many effects by changing the options in the

‘Gradient’ paint style (layer).  

If you have Auto-apply checked your page

will update automatically. If you don’t have

Auto-apply checked, click on the Apply

button to update.

To create a spot (PANTONE®) colored
picture:

In this example, we will use the ‘Picture’

paint style set to an Alpha channel and

combine this with a PANTONE® ‘Tint’ paint

style to achieve a spot color picture.

1.  Open or place a picture.

Your Picture object will display.

2.  Select the Picture object you have just

opened.

3.  Select the Alpha color mode in the Paint

Style palette.

A black triangle will appear in the top right

of the paint style to indicate the paint style

(layer) is an Alpha channel.
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If you have Auto-apply checked, your object

will turn white.

4.  Go to the Paint Style palette and click on

the Add button at the top right.

A new paint style (layer) will be added, the

same as the original paint style.

5.  Select the ‘Tint’ paint style (layer).

6.  Select the PANTONE® color model.

Select the PANTONE® color you require.

For more information on Selecting
PANTONE® colors see page 144.

The PANTONE® ‘Tint’ paint style (layer)

now combines with the ‘Picture’ paint style

(layer) to give you a spot color picture.

NOTE: The above picture has been printed as CMYK

for the purpose of the manual only. 

If you have Auto-apply checked your page

will update automatically. If you don’t have

Auto-apply checked, click on the Apply

button to update.

To color correct the spot (PANTONE®)
colored picture:

In this example, we will use the spot color

picture that we have just explained and add a

‘Color Curve’ paint style set to Alpha

channel above the ‘Picture’ paint style but

below the ‘Tint’ paint style.

1.  Select the object that was just created.

2.  From the Paint Style palette select the

first paint style button.

3.  Click on the Add button at the top

right to add another paint style.

A new paint style (layer) will be added, the

same as the original paint style.

4.  Select the ‘Color Curve’ paint style

(layer).

5.  You can now adjust the color curve. 

In the example below we have taken color

out of the quarter tones, midtones and

three-quarter tones.
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NOTE: The above picture has been printed as CMYK

for the purpose of the manual only. 

Overprinting
Normally in Wright Design, when an object is

created on top of another object, the area

that falls beneath the top object is

completely covered or “knocked out” (unless

you have an Alpha channel or opacity

applied to the top object).

As an option you can prevent knockout to

make overlapping printing inks appear trans-

parent; to do so, you select the Overprint

option in the Paint Style palette.

You can use the Overprint option on the Fill

or Stroke of any object. Overprinting only

affects objects beneath the object that has

overprint selected. 

For example:

Colors knockout 

Green set to overprint

The object set to overprint (green) is

knocking out the colors that it contains and

overprinting the colors that it doesn’t

contain from the object underneath (reddish

color). 
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Using plug-in filters
Wright Design supports 32-bit Photoshop

plug-in filters.

To install 32-bit Photoshop plug-in filters:

See Chapter 2 - ‘Finding Your Way Around’

- ‘Photoshop plug-in filters’ on page 44.

To use 32-bit Photoshop plug-in filters:

1.  Open or place a picture.

You could also create a Vector or Bitmap

object with a ‘Picture’ paint style.

2.  Select the object with the ‘Picture’ paint

style.

3.  Choose Filter > and a drop down menu

will display showing you the plug-in filters

that are available to you.

The filters that are grayed out will only

work with RGB pictures.

If all the filters are grayed out you do not

have an object with a ‘Picture’ paint style

selected

4.  Select the filter you require.

In this example we will selected Distort >

Glass.

The corresponding dialog box will open

unless the filter you selected doesn’t have

one.

5.  Adjust the controls available to create the

effect you are looking for. 

Most of the filters have a preview box

to show you what the filter will look like.

Your cursor will turn into a hand when you

place it over the preview box. Click and drag

to change the position of the preview.

6.  Click OK.

The Filter progress bar dialog box will

display.
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If you want to stop the filter click on the

Abort button.

When the filter has finished processing the

dialog box will close and the new filtered

picture will replace the original picture in

your object.

The new filtered picture will have ‘_flt’

added to its filename. The original picture

will be untouched. 

To undo a filter and select a new filter:

1.  If you have applied a filter to your picture

and you undo the filter and then select a

new filter the ‘Save Filtered Picture As’

dialog box will open.

The original default folder path, will be the

path that is set for Documents in your Folder

preferences. 

(File > Preferences > Folders > Documents) 

The default folder path from then on is the

path that you used when you last opened or

saved a document.

2.  If the default folder path is not the path

you require, click on the arrow to the right

of the “Save in” combo box and select a new

folder path.

3.  The icons across the top of the dialog box

are general Windows functions.

4.  You have the option here of renaming

the document or overwriting the file that was

created with the previous filter. 

To rename the document, enter a name in

the File name edit box.

5.  Click Save. Your filter picture will now be

saved with the file name you specified, to the

folder you specified.

6.  The dialog box for the filter you have

selected will open.

Follow from Step 5 on the previous page to

create your filter.
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W right Design lets you edit and

modify objects and the layers

within objects. This chapter

describes the many editing tools and tech-

niques including how to move, duplicate,

transform and crop objects and layers. 

The first part of this chapter deals with

editing objects. The editing tools described

here apply to all types of objects. 

We explain how to transform objects as well

as transforming the objects shape and layer. 

We then go through the extra tools that are

available to edit one object type.

Editing objects
Wright Design is an object-based application.

Remember, all objects, and all layers within

the objects, created in Wright Design are

editable at any time.  

Selecting objects
In order to be able to work with an object,

you need to select it first. There are several

ways you can select objects.

To select an object:

1.  Select the Select tool from the Tool

palette.

2.  Click on the object in your page that you

wish to select.

The object is now selected. Handles appear

around the object to show you it is selected.

OR 

●  Click on the object you want to select

from the Object List (This is very useful if the

object you want to select is underneath

other objects).

The object is now highlighted in the Object

List and handles appear around the object to

show you the object is selected.

OR  

●  As a shortcut: 

When you have any tool other than the

Select tool selected, hold down the Ctrl key

to temporarily activate the Select tool and

click on the object you wish to select.

The object is now selected. Handles appear

around the object to show you it is selected.

OR  

To select objects that are on top of each

other:

1.  Select the Select tool from the Tool

palette.

2.  Hold down the Alt key and select the

object on top.

The top object will be selected.

3.  Still holding down the Alt key, click on

the top object again.
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The object that is directly underneath the

top object will be selected.

4.  Continue this procedure to select an

object that is directly under the object

selected above, and so on. 

Holding down the Ctrl + Alt key will

allow you to select objects that are on top of

each other as described above, without

having to click on the Select tool.

To select multiple objects:

1.  Select the Select tool from the Tool

palette.

2.  Hold down the Shift key and click on the

object’s in your page that you wish to select.

The objects are now selected. Handles

appear around each object to show you they

are selected.

OR 

●  Hold down the Ctrl key to temporarily

activate the Select tool and click on the

objects you want to select from the Object

List. (This is very useful if the object(s) you

want to select are underneath another

object.)

The objects are now highlighted in the

Object List and the handles appear around

each object to show you they are selected.

OR 

1.  Select the Select tool from the Tool

palette.

2.  Click and drag over the whole area of the

objects you wish to select.

OR 

To select all objects:

●  Choose Edit > Select All  (Ctrl + A)

To deselect an object:

1.  Select the Select tool from the Tool

palette.

2.  Click anywhere on your page or paste-

board area where there is no other object.

The object is now deselected. 

OR 

1.  Select the Select tool from the Tool

palette.

2.  Hold down the Shift key and click on the

object that is selected.

The object is now deselected. 

OR 

●  Hold down the Ctrl key and click on the

object that is selected from the Object List.

The object is now deselected. 

OR  

●  As a shortcut: 

When you have any tool other than the

Select tool selected, hold down the Ctrl key

to temporarily activate the Select tool and

click on the pasteboard to deselect.

The object is now deselected. 

OR  

To deselect all objects:

●  Choose Edit > Select None 

(Ctrl + Shift + A)
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Moving objects

To move an object:

1.  Select the object(s) you wish to move.

2.  Move the cursor on top of the object.

When the cursor turns into a four-headed

arrow, click and hold down on the object

and move it to a new position.

If you selected the object by holding

down the Ctrl key while not being in the

Select tool, keep holding the Ctrl key to

obtain the four-headed arrow and move the

object to a new position.

OR

1.  Select the Select tool from the Tool

palette.

2.  Click on the object(s) that you wish to

move in your page.

3.  From the Select Tool modifier ribbon

type in the coordinates in the X and Y fields

to which you want the object to move.

(The X and Y coordinates or origin of the

object is the top left corner.)

OR

After selecting the object(s), use the four

arrow keys on your keyboard to “nudge” the

selected object in the direction of the arrow

by one screen pixel.

As you move an object, only its outline

is visible. To see the complete object as you

move or apply a transform, choose View >

Preview Transforms.

This option may degrade your screen redraw

speed.

Deleting objects

To delete an object:

1.  Select the object(s) you wish to delete.

2.  Press the Delete key on your keyboard or

Choose Edit > Delete.

OR

1.  Right mouse-click on the object(s) you

want to delete from the Object List.

A drop down menu will appear.

2.  Scroll down and select Delete Selection.

OR

1.  Select the object(s) you wish to delete

from the Object List.

2.  Press the Delete key on your keyboard.

Your object will now be deleted.

Duplicating objects
When an object is duplicated, the new object

is positioned directly on top of the original

object. You can see the newly created object

in the Object List.

To duplicate an object:

1.  Select the object(s) you wish to dupli-

cate.
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2.  Choose Object > Duplicate. (Ctrl + D)

Your object will now be duplicated.

Hiding objects
Objects that you have created can be hidden

at any time. There are two ways of hiding

objects on your page.

To hide objects using the menu:

1.  Select the object(s) you wish to hide.

2.  Choose Object > Hide.

To hide objects using the Object List:

1.  Right mouse-click on the object that you

want to hide in the Object List.

If you have several objects to hide, hold the

Ctrl key down, select the objects you want to

add (except the last object) and whilst still

holding down the Ctrl key right mouse-click

on the last object.

A drop down menu will appear.

2.  Scroll down the menu and select Hide.

The selected object(s) will now be hidden.

To show objects that have been hidden
using the menu:

1.  Select the object(s) you wish to show.

2.  Choose Object > Show.

To show objects that have been hidden
using the Object List:

1.  Right mouse-click on the object that you

want to show in the Object List .

If you have several objects to show, hold the

Ctrl key down, select the objects you want to

show (except the last object) and without

releasing the Ctrl key right mouse-click on

the last object.

A drop down menu will appear.

2.  Scroll down the menu and select Show.

The selected object(s) will now show.

Grouping objects
Besides selecting multiple objects, you can

also group and ungroup them. There are

several ways of grouping objects in Wright

Design.

To group objects from your page:

1.  Multiple select the objects you wish to

group from your page.

In the example below, we have selected the

orange, green and purple objects. The

handles around the objects show they are

selected.

2.  Choose Object > Group. (Ctrl + G)

The selected objects will now be grouped. 

In the example below, the three objects that
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were selected have now been grouped and

the group is selected. This can be seen by

the handles displayed that bound the area of

the grouped objects.

To group objects from the Object List:

1.  Multiple select the objects you wish to

group by holding down the Ctrl key and

selecting each object (except the last object)

from the Object list and whilst still holding

down the Ctrl key, right mouse-click on the

last object that you want to group.

A drop down menu will appear.

2.  Scroll down the menu and select Group.

The selected objects will now be grouped.

New handles will show, bounding the area of

the grouped objects. 

Holding the Shift key down and

selecting objects will select objects that fall

directly after one another in the Object list.

Working with Grouped objects
Having learnt how to group objects, we will

now go through the behaviour of grouped

objects. 

After you have grouped multiple objects,

new handles will show, bounding the area of

the grouped objects.

Grouped Objects in the Object List
After grouping objects in your page, you

have two options for their display in the

Object List.

The first option displays all of your objects

including the objects that are grouped, in

priority. You cannot actually see the Groups.

It is advisable to have this option

selected when changing priority of objects,

using the Object List.

The second option displays each of the

objects you have grouped inside the Group

object. Using this option makes it easier to

see which objects are in a group.

This option also shows objects that have a

Parent/Child link by displaying the Parent

object in bold letters.
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Group objects are also displayed with bold

letters. 

To display grouped objects as a Group in
the Object List:

1.  Right mouse-click anywhere inside the

object list.

A drop down menu will appear.

2.  Scroll down and select, Grouped objects

together.

The grouped objects will now display as a

Group object. 

3.  To display the objects within the group,

double-click on the Group object. 

The objects that have been grouped are now

displayed within the Group object.

It is advisable NOT to have ‘Group

objects together’ selected when you have

objects grouped and you are changing

priority of objects using the Object List.

If you do use this option, the display of the

priority of your objects in the Object List can

become very confusing. For example, you

can change the priority of an object to fit

between two grouped objects, but this would

not display in the Object List even though it

is correct on your page.

To turn the grouped objects together display
off in the Object List:

1.  Right mouse-click anywhere inside the

Object List.

A drop down menu will appear.

2.  Scroll down and select ‘Grouped objects

together’.

The grouped objects will now display as

single objects in the Object List.

To ungroup a grouped object from your
page:

1.  Select the grouped object from your

page.

2.  Choose Object > Ungroup. (Ctrl + U)

The objects will now be ungrouped and each

object will be selected.

To ungroup a grouped object from the
Object List:

1.  Right mouse-click on the Group object in

the Object List.

2.  Scroll down and select Ungroup.
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The objects will now be ungrouped and each

object will be selected.

To add objects to a Group from the Object
List:

1.  Right mouse-click and hold down on the

object in the Object List that you want to add

to a group.

If you have several objects to add to a

Group, hold the Ctrl key down, select the

objects you want to add (except the last

object) and without releasing the Ctrl key

right mouse-click on the last object.

2.  Drag the selected object(s) onto a Group

object.

A drop down menu will appear.

3.  Select Add object(s) to group.

The selected object(s) will now be added to

the Group.

To ungroup selected objects from a Group
in the Object List:

1.  Right mouse-click and hold down on the

object in the Object List that you want to un-

group from a group.

If you have several objects to un-group from

a Group, hold the Ctrl key down, select the

objects you want to un-group, then right

mouse-click on the last object.

A drop down menu will appear.

2.  Select Un-group selected object(s).

The selected object(s) will now be un-

grouped.

Selecting Grouped objects
Objects that are grouped can be selected as a

Group or as an individual object from your

page or from the Object list.  

Objects that are part of a group can be

edited and transformed as a single identity

even though they are part of a group.

To select an object that is grouped from
your page:

1.  To select the group click on any of the

grouped objects on your page.

OR

To select one of the objects in the group,

hold down the Alt key and select the object

you want.

To select an object that is grouped from the
Object List:

1.  To select the group click on the Group

object in the Object List.

OR

To select one of the objects in the group,

select the required object from the Object

List.
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Locking objects
Objects can be locked at any time. When you

lock an object, the object cannot be moved

or transformed in any way. However, you can

change, move and transform the contents

(layers) within the locked object.

To lock an object(s):

1.  Select the object(s) you wish to lock.

2.  Choose Object > Lock. (Ctrl + L)

The object(s) will now be locked. 

When you move the Select tool over the

locked object the cursor will display a

padlock, indicating the object is locked.

To unlock an object(s):

1.  Select the object(s) you wish to unlock.

2.  Choose Object > Unlock. (Ctrl + L)

The object(s) will now be unlocked. 

Prioritizing objects
Wright Design allows you to change the

priority of any object above or below any

other object. This will have the effect of

changing the display order of the objects

when the screen is refreshed.

You can prioritize objects by:

●  Using the Object List

●  Using the Object menu 

(for simple prioritization)

●  Right mouse-click on your page

Using the Object List
The easiest way to change the priority of

object(s) is using the Object List.

This is explained in Chapter 5 - ‘Creating

Objects’ - ‘Changing Object Priority’ on page

122.

Using the Object Menu
The object menu gives you four options for

changing the priorities of objects.

They are:  Bring to Front

Bring Forward

Send to Back

Send Backward

To bring an object to the front:

1.  Select the object(s) you want to bring to

the front.

The red object is selected.

2.  Choose Object > Bring to Front.
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The selected object(s) has now been priori-

tized to the front of all the other objects on

your page.

The red object is now above all of the other

objects.

To bring an object forward:

1.  Select the object(s) you want to bring

forward.

The red object is selected.

2.  Choose Object > Bring Forward.

The selected object(s) has now been priori-

tized one step forward from where it was.

The red object is now above the green

object, but below the blue object.

To send an object to the back:

1.  Select the object(s) you want to send to

the back.

The blue object is selected.

2.  Choose Object > Send to Back.

The selected object(s) has now been priori-

tized to the back of all the other objects on

your page.

The blue object is now below all of the other

objects.

To send an object backward:

1.  Select the object(s) you want to send

backward.

The blue object is selected.

2.  Choose Object > Send Backward.
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The selected object(s) has now been priori-

tized one step backward from where it was.

The blue object is now below the green

object, but above the red object.

Right mouse-click on your page
This option allows you to change the priority

of an object relative to another object.

To change the priority of an object relative
to another object:

1.  Select the object(s) whose priority you

wish to change.

The red object is selected.

2.  Right mouse-click on the object that you

want your selected object to be above or

below. 

In the above example, we right mouse-click

on the blue object.

A drop down menu will appear.

3.  Scroll down and select either, Move

Above or Move Below.

‘Move above’ will move the selected object

just above the object that you right-mouse

click.

Therefore the red object will move just

above the blue object.

‘Move below’ will move the selected object

just below the object that you right-mouse

click.

Therefore the red object will move just

below the blue object.
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Combining objects
Objects can be combined into one object

using the Combine function. Combine can

also be used for combining Vector objects

that you have unnecessarily split.

To combine objects:

1.  Multiple select the objects you want to

combine.

2.  Choose Object > Combine.

The objects selected will now be combined

into one object.

The paint style of the object that you

first selected will be applied to the other

objects that are combined.

Aligning objects
The Align tool aligns selected object(s) both

horizontally and vertically. You can align the

side, corner or center of any object(s) to the

side, center or corner of your selected

object.

You can also align objects to a specified

point or to an offset that is specified from a

point or object.

The object to which you want other objects

to align is called the reference object. 

To align object(s) to an object:

1.  Select the object(s) you want to align.

2.  Select the Align tool from the tool

palette.

The Align tool modifier ribbon will display.

3.  Select the Align objects button from

the tool modifier ribbon.

4.  As we are aligning to an object select the

‘To Object’ radio button.

5.  If you select the Stretch option the edge

of the object you have selected will align, but

the opposite edge of the object will stay in

the same position.
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If you don’t select the Stretch option the

edge selected will be aligned and the rest of

the object will move with it.

Stretch selected  (Align to top)

Stretch NOT selected (Align to top)

6.  Select the Align mode you require.

The Align mode is the position you want to

align to on the object that you want to align.

Align Top: aligns the top of the selected

object(s).

Align Bottom: aligns the bottom of the

selected object(s).

Align Left: aligns the left side of the selected

object(s).

Align Right: aligns the right side of the

selected object(s).

Align Vertical Center: aligns the center of the

selected object(s) in a vertical direction.

Align Horizontal Center: aligns the center of

the selected object(s) in a horizontal direc-

tion.

You can select a combination of these button

to enable you to align the corner of objects

and also the center of objects.

For example, you can select the ‘Align Top’

and ‘Align Left’ buttons to then enable you

to align the top left corner of the selected

object. 

If you select both the ‘Align Vertical

Center’ and the ‘Align Horizontal Center’

you can then align the center of the object.

We will select the ‘Align Right’ and ‘Align

Top’ buttons.
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The cursor displays a diamond shape

with dotted lines. The dotted lines show you

where you have selected to align.

7.  The Offset option allows you to align any

object(s) to another object but offset from

that object.

8.  Now we have to select where and what

we want to align with.

Scroll you cursor over the reference object

and click on the object near the side that you

want your selected object to be aligned.

When you are scrolling your cursor you

will see that the diamond display will turn

from white to black when you are on an

object that can be used for alignment. 

In our example we want the top right corner

of the blue object to be aligned with the top

right corner of the red object.

To achieve this we click on the red object

towards the top right corner. 

The top right corner of the blue object is

now aligned with the top right corner of the

red object.

To align object(s) to a specified position:

1.  Select the object(s) you want to align.

2.  Select the Align tool from the tool

palette.

The Align tool modifier ribbon will display.

3.  Select the Align objects button from

the tool modifier ribbon.

4.  As we are aligning to a position select the

‘To Point’ radio button.

5.  If you select the Stretch option the edge

of the object you have selected will align, but

the opposite edge of the object will stay in

the same position.

6.  Select the Align mode you require.

The Align mode is the position you want to

align to on the object that you want to align.

Align Top: aligns the top of the selected

object(s).

Align Bottom: aligns the bottom of the

selected object(s).

Align Left: aligns the left side of the selected

object(s).

Align Right: aligns the right side of the

selected object(s).
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Align Vertical Center: aligns the center of the

selected object(s) in a vertical direction.

Align Horizontal Center: aligns the center of

the selected object(s) in a horizontal direc-

tion.

You can select a combination of these button

to enable you to align the corner of objects

and also the center of objects.

For example, you can select the ‘Align Top’

and ‘Align Left’ buttons to then enable you

to align the top left corner of the selected

object. 

If you select both the ‘Align Vertical

Center’ and the ‘Align Horizontal Center’

you can then align the center of the object.

We will select the ‘Align Right’ and ‘Align

Top’ buttons.

The cursor displays a diamond shape

with dotted lines. The dotted lines show you

where you have selected to align.

7.  The Offset option allows you to align any

object(s) to another object but offset from

that object.

8.  The Distance option allows you to align

an object to a specified position.

Key in the position where you want your

object(s) to be aligned and click on the

Apply button.

OR

Click on your page at the position you want

your object to be aligned.

Your object will now be aligned to the posi-

tion you specified.

Joining objects/layers
The Join tool allows you to join objects that

have the same Picture paint style.

You can move an object to join another

object with the same Picture paint styles or

you can move the Picture paint style in an

object to join another object with the same

Picture paint style.

The Object you want other objects to join to

is called the reference object.

To join objects:

1.  Select the object you want to join.

In this example we want to join the cutout

object of the flower to the rectangular

object. 

2.  Select the Align tool from the tool

palette.

The Align tool modifier ribbon will display.

3.  Select the Join tool from the tool

modifier ribbon.

4.  We are joining the objects so select the

Move Object radio button.

218 Chapter 7 - Editing objects and/or Layers



5.  Click on the reference object.

Your objects are now joined.

The selected object can have a totally

different transform applied to it than the

reference object and the objects will still

join. This also applies when you are joining a

picture.

To join a picture:

1.  Select the object you want to join.

In this example the flower paint style inside

the cutout object has been scaled and

moved. We want to join the picture in the

cutout object to the picture in the rectan-

gular object. 

2.  Select the Align tool from the tool

palette.

The Align tool modifier ribbon will display.

3.  Select the Join tool from the tool

modifier ribbon.

4.  We are joining the pictures so select the

Move Picture radio button.

5.  Click on the reference object.

Your objects are now joined.

Feathering objects
Feathering allows you to soften the edges of

Bitmap or Vector objects. This makes the

transition between the object and the back-

ground more gradual.

If you feather a Vector object it is automati-

cally converted to a Bitmap object.

To feather object(s):

1.  Select the object(s) you want to feather.
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2.  Choose Object > Feather. (Ctrl + F)

The Feather dialog box will open.

3.  In the Resolution edit box, key in the

resolution you require for your feathering.

Right mouse clicking on the Resolution

edit box will give you the following measure-

ment options: Pixels/mm, Pixels/cm, dpi.

4.  To set the Radius of your feather you can

either:

●  Key in the number of pixels you want to

feather in the edit box to the left of the

Radius slider.

OR

●  Click and drag on the triangle underneath

the Radius slider.

As you move the slider the values in the two

edit boxes will update.

OR

●  Key in the distance you want to feather in

the edit box to the right of the Radius slider.

Right mouse clicking on the Radius

measurement edit box to the right will give

you the following measurement options:

Application Default, mm, cm, Inches and

Points.

5.  To set the way in which the feather will

be created select one of the following radio

buttons:

Bot: the feathering will be applied to both

sides of the selected object(s).

Inside Only: the feathering will be applied to

the inside of the selected object(s).

Outside Only: the feathering will be applied

to the outside of the selected object(s).

6.  Select the Smooth checkbox if you want

the pixels averaged to give a smoother effect.

7.  Click on the OK button.

The Feather dialog box will close and the

Task Manager will open showing you the

object is feathering.

After the file has finished processing the

Task Manager will close and the feathered

object will redisplay on your page.

Feathered object
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Feathered object on a background object 

Applying a Shadow to objects
Shadow is used mainly to create drop

shadows.

Vector, Bitmap and Text objects can have a

shadow applied to them. 

The shadow is a separate object that is offset

from the original object and is joined to the

original object.

To shadow object(s):

1.  Select the object(s) you want to shadow.

This example has been cutout.

2.  Choose Object > Shadow. (Ctrl + H)

The Shadow dialog box will open.

3.  In the Resolution edit box key in the

resolution you require for the feathering of

your shadow or use the spin controls to

enter the value you require.

Right mouse clicking on the Resolution

edit box will give you the following measure-

ment options: Pixels/mm, Pixels/cm, dpi.

4.  To set the offset of your shadow enter a

value in the X and Y edit boxes or use the

spin controls to enter the value you require.

The offset you enter here is not critical as

you can move the shadow object after it has

been created.

Right mouse clicking on the Offset X

and Y edit boxes will give you the following

measurement options: Application Default,

mm, cm, Inches, Points and Pixels.
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5.  To set the radius for the feather of your

shadow you can either:

●  Key in the number of pixels you want to

feather your shadow in the edit box to the

left of the Radius slider.

OR

●  Click and drag on the triangle underneath

the Radius slider.

As you move the slider the values in the two

edit boxes will update.

OR

●  Key in the distance you want to feather

your shadow in the edit box to the right of

the Radius slider.

Right mouse clicking on the Radius

measurement edit box to the right will give

you the following measurement options:

Application Default, mm, cm, Inches and

Points.

5.  To set the way in which the feather of

your shadow will be created select one of the

following radio buttons:

Both Sides: the feathering of your shadow

will be applied to both sides of the selected

object(s).

Inside Only: the feathering of your shadow

will be applied to the inside of the selected

object(s).

Outside Only: the feathering of your shadow

will be applied to the outside of the selected

object(s).

6.  Select the Smooth checkbox if you want

the pixels averaged out to give a smoother

effect.

7.  Click on the OK button.

The Shadow dialog box will close and the

Task Manager will open showing you the

shadow is generating.

After the file has finished processing the

Task Manager will close and the shadow

object will display on your page.

Shadowed object

Shadowed object on a background object

222 Chapter 7 - Editing objects and/or Layers



Correcting a mistake
Wright Design allows you to undo any opera-

tion that you apply to your document. 

There is no limit to the number of times that

you can undo. The Undo control is only

limited by the memory that is available in

your computer.

To undo the last control only:

1.  Choose Edit > Undo. (Ctrl + Z)

To multiple undo:

1.  Choose Edit > Undo (Ctrl + Z) as many

times as you need to get your page back to

the state you want.

Each time you select Edit > Undo (Ctrl + Z),

a single operation is undone.

To redo the last control that you have
undone:

1.  Choose Edit > Redo. (Ctrl + Y)

To multiple redo:

1.  Choose Edit > Redo (Ctrl + Y) as many

times as you need to get your page to the

state you want.

Each time you select Edit > Redo (Ctrl + Y),

a single operation is redone.

Transforming objects
As we said earlier, Wright Design lets you

edit and modify objects and the layers within

objects. 

An ‘Object’ is made up by the ‘Shape’ of the

object and the ‘Layers’ within the object. 

When applying a transform, you have the

choice of applying the transform to the

object, shape or layer. These are called

Transform options.

We will now go through the process of

applying a SCALE transform to an object. We

will explain how to apply the SCALE trans-

form to the object, shape and layer.

SCALE is only one of the many transform

modes that are available to you. Each indi-

vidual transform mode will then be explained

in full. 

With Picture objects, you can only

transform the OBJECT. You cannot transform

the SHAPE or LAYER.

To apply a scale transform:

1.  Select the Select tool from the Tool

palette.

2.  Click on the object in your page that you

wish to transform.
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The Tool modifier ribbon displays the Select

tool modifiers as shown above. The trans-

form options appear to the left, followed by

the transform modes, transform operations

and then the transform readouts. 

3.  Select the transform option you wish to

use.

The final results will show you the outcome

of selecting each of the transform options.

Object will apply the transform to

both the ‘Shape’ of the object and the

‘Layers’ within the object.

Shape will apply the transform to

the shape only.

Layer will apply the transform to

the layer(s) only.

4.  Select the transform mode or the trans-

form operation you wish to use.

In this example we will select the scale 
transform mode. 

The transform mode options are scale,

rotate, shear and perspective.

The transform operation options are vertical

mirror, horizontal mirror, rotate 90° anti-

clockwise, rotate 90° clockwise, remove

perspective and reset. 

If you use a transform operation the

effect is created straight away.

5.  The transform readouts provide informa-

tion on the object, shape or layer transform

option you have selected.

X and Y - Give you the coordinates of the top

left corner (origin) of the object, shape or

layer in relation to the top left corner of

your page. 

R - The angle by which the object, shape or

layer has been rotated.

S - The angle by which the object, shape or

layer has been sheared.
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X% and Y% - Gives you the percentage by

which the object, shape or layer has been

scaled both horizontally and vertically.

W and H - Gives you the width and height of

the object, shape or layer.

6.  You can edit the selected object, shape
or layer by: 

●  Keying in different values in the transform

readouts described above.

OR

●  By clicking and dragging on the handles

of the selected object, shape or layer.

For example:

To scale the selected object, shape or layer
150%, key in 150 in both the X% and Y% edit

boxes.

OR

Place the cursor over the top of one of the

corner handles so it displays an angled

double-headed arrow, click and drag to scale

the object, shape or layer.

Dragging out will enlarge the object, shape
or layer and dragging in will reduce the

object, shape or layer. The transform

readout shows you the percentage that you

are scaling your object, shape or layer as you

drag on the handle.

Scaling the OBJECT
1.  Follow the procedure outlined above

making sure you select the OBJECT trans-

form option.

2.  In the example below, we clicked and

dragged out the bottom left corner to

enlarge the OBJECT (shape and layer).

Original OBJECT

Scaled OBJECT

The original OBJECT (shape and layer) has

been enlarged, therefore the SHAPE and

LAYER have increased in size.
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Scaling the SHAPE
1.  Follow the procedure outlined above

making sure you select the SHAPE transform

option.

2.  In the example below, we clicked and

dragged in all the corner handles separately

to reduce the SHAPE but leave the LAYER

(picture) the same size.

Original SHAPE

Scaled SHAPE

The original SHAPE has been reduced but

the LAYER (picture) has not changed, there-

fore the SHAPE is cropping the LAYER

(picture). 

Scaling the LAYER
1.  Follow the procedure outlined above

making sure you select the LAYER transform

option.

After selecting the LAYER transform option

you will see a keyline appear. The keyline

shows you the full area of the LAYER that is

available to you.

For example: If you are transforming a

Picture LAYER the keyline will show you the

full area of the picture that you can work

with.

2.  In the example below, we clicked and

dragged out the bottom left and top right

corners to enlarge the LAYER (picture).

Original LAYER

Scaled LAYER

The original LAYER (picture) has been

enlarged but the SHAPE has not changed,

therefore scaling the LAYER (picture) inside

the SHAPE.
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Transform modes
Transform modes all work the same way and

can be applied to the object, shape or layer
in the same way that we applied the Scale

transform.

To see how to use the Transform modes see,

‘ To apply a scale transform’ on page 223.

The following Transform modes are available

to you in Wright Design:

Scale

Scale enlarges or reduces the

selected object, shape or layer. You can scale

objects proportionately or scale horizontally

and vertically at different values.

When you choose the Select tool, Scale is the

default Transform mode.

To scale proportionally:

1.  Move the cursor over one of the corner

handles.

The cursor changes to an angled two headed

arrow.

2.  Click and drag

OR

●  Key in different values in the Scale trans-

form readouts.

Original Scaled                         
proportionally

To distort:

1.  Move the cursor over one of the side

handles.

The cursor changes to an vertical or hori-

zontal two headed arrow.

2.  Click and drag.

OR

●  Key in the value you want to scale your

object, shape or layer in the Scale (X% and

Y%) transform readouts.

Original Scaled - distorted

Rotate

Rotate allows you to rotate the

selected object, shape or layer clockwise or

anticlockwise.

To rotate:

1.  Move the cursor over one of the corner

handles.

The cursor changes to a circular arrow.

2.  Click and drag

The object rotates around its center.
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Original Rotated

If you click on the middle side handles

whilst in the Rotate transform mode the

transform mode is changed to the Shear

tool.

OR

●  Key in the value you want to rotate your

object, shape or layer in the transform read-

outs.

The object rotates around the top left

(origin) of the object.

You can activate the Rotate transform

mode when you are in the Scale transform

mode by holding down the Shift key and

clicking on a corner handle of the object.

Shear

Shear allows you to shear or skew

the selected object, shape or layer.

To shear:

1.  Move the cursor over any handle.

The cursor changes to a double headed

arrow.

2.  Click and drag

The object, shape or layer is sheared around

the edge of the object opposite to where you

started to click and drag.

Original

Shear - Shear -
vertically horizontally

OR

●  Key in the value you want to shear your

object, shape or layer in the Shear (S) trans-

form readouts.

You can activate the Shear transform

mode when you are in the Scale transform

mode by holding down the Shift key and

clicking on a side handle of the object.
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Perspective

Perspective allows you to apply

perspective to the selected object, shape or

layer.

(You cannot apply perspective to Text

objects.)

To apply perspective:

1.  Move the cursor over any corner handle.

The cursor changes to a four headed arrow

with a black dot in the middle.

2.  Click and drag

Regular perspective is applied in the direc-

tion that you drag the cursor.

To achieve an irregular perspective

hold down the Alt key and click on one of

the corner handles. Perspective is then only

applied from the selected corner.

Original

Original Perspective irregular

You can activate the irregular

Perspective transform mode when you are in

the Scale transform mode by holding down

the Alt key and clicking on a corner handle

of the object.

Transform operations
Transform operations all work the same way

and can be applied to the object, shape or

layer in the same way that we applied the

Scale transform.

To see how to use the Transform operations

see ‘To apply a scale transform’ on page

223.

The following Transform operations are

available to you in Wright Design:

Vertical Mirror

Vertical mirror allows you to flip the

object, shape or layer about the vertical axis.

To apply a vertical mirror:

●  Click on the Vertical mirror button in the

Select tool modifier.

The object, shape or layer (whatever is

selected) will now be vertically flipped (i.e.

left to right). 
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Original Vertical mirror

Horizontal Mirror

Horizontal mirror allows you to flip

the object, shape or layer about the hori-

zontal axis.

To apply a horizontal mirror:

●  Click on the Horizontal mirror button in

the Select tool modifier.

The object, shape or layer (whatever is

selected) will now be horizontally flipped

(i.e. top to bottom).  

Original Horizontal mirror

Rotate 90° anticlockwise

Rotate 90° anticlockwise allows you

to automatically rotate the object, shape or

layer 90° anticlockwise.

To apply a 90° anticlockwise rotation:

●  Click on the Rotate 90° anticlockwise

button in the Select tool modifier.

The object, shape or layer (whatever is

selected) will now be rotated 90° in an anti-

clockwise direction.

Original Rotate 90° 
anticlockwise

Rotate 90° clockwise

Rotate 90° clockwise allows you to

automatically rotate the object, shape or

layer 90° clockwise.

To apply a 90° clockwise rotation:

●  Click on the Rotate 90° clockwise button

in the Select tool modifier.

The object, shape or layer (whatever is

selected) will now be rotated 90° in a clock-

wise direction.

Original Rotate 90° 
clockwise
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Remove perspective

Remove perspective removes any

perspective that has been applied to an

object, shape or layer.

To remove perspective:

●  Click on the Remove Perspective button

in the Select tool modifier.

The object, shape or layer (whatever is

selected) will now have all perspective

removed.

With perspective             Remove perspective

Reset

Selecting Reset will reset any trans-

form that has been applied to an object,
shape or layer.

To reset:

●  Click on the Reset button in the Select

tool modifier.

The object, shape or layer (whatever is

selected) will now be reset to its original

state.

Replicating objects
Objects can be replicated in Wright Design.

You can select how many copies you require,

the rotation, opacity, scale factor and

distance of the replicated objects. 

To replicate object(s):

1.  Select the object(s) you want to replicate.

2.  Select the Replicate tool from the

tool palette.

The Replicate tool modifier ribbon will

display.

3.  Select either Copies or Spacing.

Copies: controls how many copies of the

selected object you wish to replicate.

This example below shows you three copies.
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Spacing: controls the spacing between the

replicated objects. The spacing is calculated

along an axis that runs through the center of

the replicated objects.

The Replicate tool works out how many

objects it can fit within the specified distance

with the Spacing that has been set. 

In the example above we have selected a

Spacing of 10mm. The Replicate tool then

determined that two objects could be repli-

cated with the set spacing and within the

distance specified.  

4.  If you have selected Copies, key in the

number of copies you want to create in the

Copies edit box or use the spin dials to enter

the value.

If you have selected Spacing, key in the

amount of spacing you require in the

Spacing edit box or use the spin dials to

enter the value.

Right mouse-clicking on the Spacing or

Distance edit boxes will give you the

following measurement options: Application

Default, mm, cm, Inches, Points and Pixels. 

5.  The Rotation option controls the rotation

of the replicated object(s). 

The rotation value specified is applied to the

last object created with the objects in

between receiving a percentage of the rota-

tion specified.

Key in a rotation value in the edit box or use

the spin dials to enter the value.

In the example below we have selected two

copies with a rotation of 45 degrees.
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6.  The End Opacity option controls the

opacity of the replicated object(s). 

The end opacity value specified is applied to

the last object created with the objects in

between receiving a percentage of the end

opacity specified.

Key in a end opacity value in the edit box or

use the spin dials to enter the value.

In the example below we have selected two

copies with an end opacity of 15 percent.

7.  The End Scale option controls the scaling

of the replicated object(s). 

The end scale value specified is applied to

the last object created with the objects in

between receiving a percentage of the end

scale specified.

Key in an end scale value in both the X% and

Y% edit boxes or use the spin dials to enter

the value. Keying in different values in the

X% and Y% edit boxes will distort your

object.

In the example below we have selected four

copies with an end opacity of 15 percent and

an end scale of 25 percent.

8. The Distance option controls the distance

from the center of the object you have

selected to the center of the last object

created in the replication.

The Distance option is ignored if you are

using the cursor to specify the distance of

the replication.

Key in a distance in the X and Y edit boxes.
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In the example above we have selected two

copies with an end opacity of 15 percent and

a distance of 130 mm in both the X and Y

axis.

Therefore the distance between the center of

the original object and the center of the last

object is 130mm. 

9.  There are now three ways of applying the

replication with the values set as explained

above to selected object(s). You can either:

●  Hit the Replicate key on the Replicate

tool modifier ribbon.

Your object(s) will now be replicated.

OR

●  With your cursor click anywhere on the

selected object and drag your cursor to

where you want the center of your last repli-

cated object to be positioned.

Your object(s) will now be replicated.

Using this method you can see a

readout in the Distance edit boxes of the

position of your cursor as you drag it on

your page.

OR

●  With your cursor click where you want

the center of your last replicated object to be

positioned.

Your object(s) will now be replicated.

Editing Vector objects
Each Vector object is made up of a list of

points that define the object’s outline.

Internally, the points are stored as Bezier

segments. The points or nodes defining the

Vector object’s outline may be edited

through the Bezier tool. Nodes may be

moved, deleted or converted to different

types. 

Each node has two control points attached

that control the shape of the path.

Vector objects can be filled by any paint style

and may optionally have a stroke of any paint

style. The stroke is controlled by the Pen

Style palette. A stroke follows the object’s

outline and has a certain thickness. The

stroke may be on top or below the main

Vector object. 

The Bezier tool

The Bezier tool allows you to alter

the shape of any Vector object. 

When you have a Vector object selected,

selecting the Bezier tool from the tool

palette displays nodes along the path of your

object and the bezier tool modifiers are

displayed.

You can select to view small or large nodes.

Small nodes is selected by default or to

display large nodes you can click on the

‘Show large nodes’ checkbox on the Bezier

tool modifier ribbon.
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There are several options to control the posi-

tioning of your nodes and control points

when you are moving them. You can select

to snap your nodes and control points to

either rulers or guides or both.

To view large nodes:

1.  Select the bezier tool from the tool

palette.

2.  Check Show large nodes from the Bezier

tool modifier ribbon.

Large nodes will now be displayed.

To view small nodes:

1.  Select the Bezier tool from the tool

palette.

2.  Uncheck Show large nodes from the

Bezier tool modifier ribbon.

Small nodes will now be displayed.

To snap nodes to rulers:

1.  Choose Guides > Show rulers.

(Ctrl + Alt + R)

2.  Select the Bezier tool from the tool

palette.

3.  Check Snap nodes to rulers from the

Bezier tool modifier ribbon.

When you move your nodes they will now

snap to the increments on your rulers. This

option will be grayed out if you don’t have

your rulers showing.

To snap nodes to guides:

1.  Select the Bezier tool from the tool

palette.

2.  Check Snap nodes to guides from the

Bezier tool modifier ribbon.

When you move your nodes they will now

snap to any guides that you have showing.

The tolerance for the snapping distance is

set in File > Preferences > Guides.

To snap control points:

1.  Select the Bezier tool from the tool

palette.

2.  Check Snap control points from the

Bezier tool modifier ribbon.

If you have Snap nodes to rulers selected

your control points will now snap to rulers.

If you have Snap nodes to guides selected

your control points will now snap to guides.

This option is grayed out if you don’t have

Snap nodes to rulers or Snap nodes to

guides selected.
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To edit a node in a Vector object:

1.  Select a Vector object.

Handles appear around the object.

2.  Select the bezier tool from the tool

palette.

Nodes appear as keylined squares. In the

object selected above there are four nodes,

one for each corner of the square. 

If you were editing a Vector object that had

been plotted there would be a node at every

point that was plotted. 

3.  As you position your cursor over a node,

the cursor changes from a keyline black

arrow to a filled in black arrow.

Select the node you wish to edit by clicking

on it. We have selected the bottom right

node.

When selected, a node is solid and its

control points (if it has any) are displayed.

To select more than one node, use the

Bezier tool to drag a selection box enclosing

the nodes to be selected, or hold down the

Shift key as you click on each node.

When multiple nodes are selected, you can

drag one node to move it and the other

selected nodes will move with it.

4.  Drag the node to a new position to

change the shape of the object.

To select a node:

To select a node you have to be in the bezier

tool.

●  Click on the node.

The node is now selected.

OR

●  Drag a selection box enclosing the node

to be selected.

The node is now selected.

OR

1.  Place the cursor over the node you wish

to select.

236 Chapter 7 - Editing objects and/or Layers

Nodes

Nodes



The cursor changes from a keyline black

arrow to a filled in black arrow.

2.  Right mouse-click on the node.

A drop down menu appears.

3.  Scroll down and click on Select This

Node.

The node is now selected.

To select all nodes:

To select nodes you have to be in the bezier

tool.

●  Drag a selection box enclosing all of the

nodes.

OR

1.  Right mouse-click anywhere on the

screen.

A drop down menu appears.

2.  Scroll down and click on Select All Nodes.

All the nodes are now selected.

OR

●  Choose Edit > Select All. (Ctrl + A)

To deselect a node:

To deselect a node you have to be in the

bezier tool.

●  Click anywhere away from the node.

The node is now deselected.

OR

1.  Place the cursor over the node you wish

to deselect.

The cursor changes from a keyline black

arrow to a filled in black arrow.

2.  Right mouse-click on the node.

A drop down menu appears.

3.  Scroll down and click on Deselect This

Node.

The node is now deselected.

To deselect all nodes:

To deselect nodes you have to be in the

bezier tool.

●  Click anywhere on the screen away from

the nodes.

OR

1.  Right mouse-click anywhere on the

screen.

A drop down menu appears.

2.  Scroll down and click on Deselect All

Nodes.

All the nodes are now deselected.

OR

●  Choose Edit > Select None. 

(Ctrl + Shift +A)

To add a node:

To gain greater control of your Vector object

you can add nodes.

1.  Move your cursor over the path you are

working on.

The cursor changes from a keyline black

arrow to an arrow with a line through it.
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2.  Double click on the path.

A new node is added and is selected.

To delete a node:

1.  Select the node(s) you wish to delete.

The selected node(s) are solid.

2.  Hit the Delete key on your keyboard.

The selected node(s) are deleted.

OR

1.  Place the cursor over the node you wish

to delete (the node does not have to be

selected).

The cursor changes from a keyline black

arrow to a filled in black arrow.

2.  Right mouse-click on the node.

A drop down menu appears.

3.  Scroll down and click on Delete This

Node.

The node is now deleted.

If all the nodes in an object are

selected and you hit the delete button the

whole object will be deleted.

To create a curved line from a straight line
in a Vector object:

1.  Select a Vector object.

Handles appear around the object.

2.  Select the bezier tool from the tool

palette.

Nodes appear as keylined squares. 

3.  As you position your cursor over a node,

the cursor changes from a keylined black

arrow to a solid black arrow.

Select the node you wish to edit by clicking

on it. We have selected the bottom right

node.

When selected, a node is solid and its

control points (if it has any) are displayed.

4.  From the Bezier tool modifier select the

Curve Line style radio button.

The selected node will now display a control

point to the left of the node. The node to

the left of the selected node will display a

control point to its right.
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When we are talking about the left and

right of nodes, this is visualized from inside

the object looking out.

The path to the left of the selected

node is the path that will become a curve.

5.  Click and drag on the control point of the

selected node (bottom right).

As you position your cursor over a control

point, the cursor changes from a keylined

black arrow to an arrow with a circle inside

it.

6.  Click and drag on the control point of the

top right node.

To create a rounded corner from a straight
corner in a Vector object:

1.  Select a Vector object.

Handles appear around the object.

2.  Select the bezier tool from the tool

palette.

Nodes appear as keylined squares. 

3.  As you position your cursor over a node,

the cursor changes from a keylined black

arrow to a solid black arrow.

Select the node you wish to edit by clicking

on it. We have selected the bottom right

node.

When selected, a node is solid and its

control points (if it has any) are displayed.

4.  From the Bezier tool modifier ribbon

select the Curve Line style radio button.
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The selected node will now display a control

point to its left. The node to the left of the

selected node will display a control point to

its right.

5.  Select the node to the left of the node

you originally selected 

6.  From the Bezier tool modifier ribbon

select the Curve Line style.

The selected node will now display a control

point to the left of the node. The node to

the left of the selected node will display a

control point to its right.

7.  Select the original node (bottom right).

The bottom right node now has control

points coming out both the left and right

sides. The node to the left has a control

point to its left and the node at the top right

has a control point to its right.

This now allows you to control the curve of

the node you have just selected.

8.  Select the node style you require. The

Node style is Cusp as default. 

The Node styles available are:

Cusp: the control points move indepen-

dently of each other. This means the curve

can bend sharply.

In the example below we have pushed the

node in towards the center of the square.

Click  and drag on each control point sepa-

rately to turn the curve around (as shown

below).

Smooth: the two control points move in

unison with each other, but the control

point you are moving adjusts in length

whereas the other control point stays the

same length. This can give you a different

curve on each side of the node.
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In the example below we have changed from

the Cusp Node style (no control points

moved) to the Smooth Node style.

We have now moved the right control point.

See that one control point is longer than the

other.

The control point that you moved can

change in length but the other control point

stays the same length.

Symmetrical: the two control points move in

unison with each other and the control

points stay the same length. This gives you

the same curve on both sides of the node.

In the example below we have changed from

the Cusp Node style (no control points

moved) to the Symmetrical Node style.

We have now moved the right control point.

but both the control points stay the same

length.

To convert Line styles from lines to curves
on multiple selected nodes:

1.  Multiple select the nodes with a line style

that you wish to change to a Curve line style.

2.  Right mouse-click anywhere on the

screen.

A drop down menu appears.

3.  Scroll down and click on Convert Lines to

Curves.

All the selected nodes will now have a Curve

line style.

To convert Line styles from curves to lines
on multiple selected nodes:

1.  Multiple select the nodes with a Curve

line style that you wish to change to a Line

style.

2.  Right mouse-click anywhere on the

screen.

A drop down menu appears.

3.  Scroll down and click on Convert Curves

to Lines.

All the selected nodes will now have a Line

styles.
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To convert a node to a corner:

1.  Select the node you wish to change to a

corner.

2.  Click on the Make Corner button on the

Bezier tool modifier ribbon.

The selected node will now be a corner.

To move a line segment:

1.  Select a Vector object.

Handles appear around the object.

2.  Select the bezier tool from the tool

palette.

Nodes appear as keylined squares. 

3.  Position your cursor over the path. The

cursor changes from a keylined black arrow

to an arrow with a line through it.

4.  Click on the line and drag the line

segment to the position you require.

When you click on the line the two nodes on

either side of the nodes are selected and

move as you move the line.

To create a curve from a line segment:

1.  Select a Vector object.

Handles appear around the object.

2.  Select the bezier tool from the tool

palette.

Nodes appear as keylined squares. 

3.  Position your cursor over the path and

hold down the Alt key. The cursor changes

from a keylined black arrow to an arrow with

a keylined half circle inside it.
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4.  Click on the line and drag the curved line

segment to the position you require.

When you click on the line the two nodes on

either side of the nodes are selected and

move as you move the line.

Breaking a path
The Break option on the Bezier tool modifier

ribbon allows you to open a closed path at

any point along the path.

To break a closed object:

1.  Select the Vector object you wish to

break.

Handles appear around the object.

2.  Select the bezier tool from the tool

palette.

Nodes appear as keylined squares. 

3.  Click on a node to select it at the point

where you want to break the object.

To break your object at a point where there

is not a node, double click on the path to

create a node and then click on  it.

4.  Click on the Break button on the Bezier

tool modifier ribbon.

The object will now be broken at the point

you selected and there will be two nodes

overlapping each other at this point.

5.  Select one of the nodes and move it to a

different position.

If the node you select is not the node

you require (as they are overlapping), click

on the Reverse button on the Bezier tool

modifier ribbon to reverse the path. The

other node will now be on top.

You can now see that there is a break in the

object.

If  the object has a stroke and no fill, the

broken object will now be a path.
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Joining a path
An open path Vector object can be closed at

any time.

To close an open path:

1.  Select your open path Vector object.

Handles will appear around the object.

2.  Select the bezier tool from the tool

palette.

Nodes appear as keylined squares. 

3.  Select one of the end nodes.

4.  Right mouse-click on the other end node.

A drop down menu will appear.

5.  Scroll down the menu and select Join to

Current Node.

The two end nodes of the open path will

now be joined to create a closed path.

Splitting a path
The Split option on the Bezier tool modifier

ribbon allows you to split a path to create

two separate objects.

To be able to split a path you have to break

the object twice, unless the object is a path

and then you only have to break the object

once. 

To split an object into two objects:

1.  Select the Vector object you wish to split.

Handles will appear around the object.

2.  Select the bezier tool from the tool

palette.

Nodes appear as keylined squares. 
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3.  Click on a node to select it at the point

where you want to break the object.

To break your object at a point where there

is not a node, double click on the path to

create a node and then click on  it.

4.  Click on the Break button on the Bezier

tool modifier ribbon.

The object will now be broken at the point

you selected and there will be two nodes

overlapping each other at this point.

5.  Click on another node to select it at the

point where you want to break the object for

a second time.

6.  Click on the Break button on the Bezier

tool modifier ribbon.

The object will now be broken at the point

you selected and there will be two nodes

overlapping each other at this point.

7.  Click on the Split button on the Bezier

tool modifier ribbon.

The objects have now been split into two

separate objects.

This can be seen by moving the two objects

apart as shown below.

To recombine the objects:

Objects that have been split can be recom-

bined. This combines the objects into one

object but it does not move them back

together.

See: ‘Combining objects’ in this chapter on

page 215.  

Reversing a path
The Reverse option in the Bezier tool modi-

fier ribbon changes the direction of a path in

Vector objects. 

The path direction is initially set by the order

in which you place the first two points on a

path, but you can change the direction any

time after you have drawn the path.

A path can run clockwise or anticlockwise.

The direction of a closed path drawn when

you create a rectangle, ellipse, straight

polygon or curved polygon is clockwise.

To reverse the direction of a path:

1.  Select the Vector object.

2.  Select the Bezier tool from the tool

palette.
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3.  Click on a node to select it at the point

where you want reverse the direction of the

path.

4.  Click on the Reverse button on the Bezier

tool modifier ribbon.

The path will now be reversed.

The Pen Style palette
The Pen Style palette controls the attributes

of Strokes on Vector and Text objects.

You can set the Pen Style palette up before

you create your Vector object and when you

apply a stroke in the Paint Style palette the

stroke will be created to these specifications.

OR

You can create your Vector object and then

set the controls for the stroke in the Pen

Style palette and apply these to your object.

To set Stroke attribute options: 

1.  Select the Vector or Text object.

2.  Choose Windows > Palettes > Pen Style.

(F3)

The Pen Style palette will display.

3.  The Caps option controls the shape of

the end of the stroke.

Select the Caps option you require.

Butt: is square and finishes flush with the

end of the path.

Round: is rounded and extends beyond the

end of the path by one-half of the stroke

width.

Square: is square and extends beyond the

end of the path by one-half of the stroke

width.

4.  The Join option controls the shape of the

corners.

Select the Join option you require.

Sharp corners: gives you a sharp corner as

long as the miter length is proportional to

the width of the stroke.

Rounded corners: gives you rounded

corners. 

Bevelled: gives you corners that have been

cut off.
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5.  The Width option specifies the thickness

of the stroke which straddles the path.

Enter a width value in the edit box OR click

on the triangle and move the slider to the

width you require

Right mouse-clicking on the Width edit

box will give you the following measurement

options: Application Default, mm, cm,

Inches, Points and Pixels. 

6.  The Miter limit controls when the

program switches from a mitered (pointed)

join to a beveled (squared off) join. The

default miter limit is 10, which means when

the length of the point reaches ten times the

line width, the program switches from a

miter join to a bevel join.

Enter a miter value in the edit box OR click

on the triangle and move the slider to the

miter you require.

Miter value - 10 Miter value - 5

7.  The Scaled option controls the width of

the stroke if you apply a scale factor to the

object that contains the stroke.

Check the Scale option if you want the

stroke of an object scaled in proportion to

the scale factor you may be applying to the

object. 

If the Scale option is not checked, the stroke

of an object will stay the same width when

you scale the object.

The ‘Scale strokes’ checkbox in the

Select tool modifier ribbon has a number of

uses:

●  It shows you if you have selected this

option from the Pen Style palette for the

object you have selected. 

●  If you want scaled strokes and you

haven’t selected it in the Pen Style palette

you can select this from the Select tool

modifier ribbon for the object you have

selected.

●  If you have objects grouped with some

having scaled strokes and others not having

scaled strokes you can select for all of them

to have their strokes scaled or not scaled.

8.  The After Fill option controls where the

stroke sits in relation to the fill.

Check the After Fill option if you want your

stroke to sit above your Fill.

If the After Fill option is not checked, the

stroke will lie behind the fill.

9.  An object that has a Stroke and no Fill is

considered to be a Line.
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The three combo boxes towards the bottom

of the Pen Style palette control the style of a

Line. 

The first combo box controls the start of the

line, the middle combo box controls the line

style and the third combo box controls the

end of a line.  

If an object has a Fill the start and end line

styles are ignored.

Start of line: Click on the arrow to the right

of the first combo box, scroll down the list

and select the option you require. 

If you don’t want to have a style at the begin-

ning of your line leave this option blank as

shown above.

The available styles are:

Line style: Click on the arrow to the right of

the second combo box, scroll down the list

and select the option you require. 

The available Line styles are:

End of line: Click on the arrow to the right

of the third combo box, scroll down the

menu and select the option you require. 

If you don’t want to have a style at the end of

your line leave this option blank

The available styles are:

Example of lines are:

10. The Auto-load option loads the values of

a stroke into the Pen Style palette each time

you select a new object.
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If this option is unchecked the Pen Style

palette will not be updated each time you

select a new object.

11. The Auto-apply option applies the values

from the Pen Style palette to your selected

object as you enter the values.

If this option is unchecked you have to click

on the Apply button to update your selected

object.

To save a Pen style:

1.  Right mouse-click anywhere inside the

Pen Style palette.

A drop down menu will appear.

2.  Scroll down the menu and select Save

Pen Style.

The Save As dialog box will open. The orig-

inal default folder path will be the the Wright

Design ‘Program’ folder.

The default folder path from then on is the

path that you used when you last opened or

saved a pen style.

3.  If the default folder path is not the path

you require, click on the arrow to the right

of the “Save in” combo box and select a new

folder path.

4.  The icons across the top of the dialog box

are general Windows functions.

5.  Enter a name in the File name edit box.

6.  The type of file you will be saving is a

PenStyle file (.wdb).

7.  Click Save. Your pen style will now be

saved with the file name you specified, to the

folder you specified.

To load a Pen style:

1.  Right mouse-click anywhere inside the

Pen Style palette.

A drop down menu will appear.

2.  Scroll down the menu and select Load

Pen Style.

The Open dialog box will open. The original

default folder path will be the the Wright

Design ‘Program’ folder.

The default folder path from then on is the

path that you used when you last opened or

saved a pen style.

5.  If the default folder path is not the path

you require, click on the arrow to the right

of the “Look in” combo box and select a new

folder path.
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6.  The icons across the top of the dialog box

are general Windows functions.

7.  Select the file you wish to open.

8.  Select the type of file you wish to view.

You can view Wright Design Pen Style files

(.wdp) or All files.

9.  Click Open. Your Pen Style will now be

loaded into the Pen Style palette.

Editing Bitmap objects
As discussed previously, Bitmap objects are

made up of pixels and therefore have a reso-

lution. 

There are a few editing tools in Wright

Design that can only be used to edit Bitmap

objects. They are: Invert and Grow.

Inverting objects
Inverting objects actually turns the object

inside out. 

The area that is being masked by the object

becomes white and the area that was white

inside the handles then becomes the masked

area.

To invert object(s):

1.  Select the object(s) you want to invert.

2.  Choose Object > Invert. (Ctrl + I)

Your selected object(s) will now be Inverted.

Growing objects
The Grow control can be used to grow,

shrink or outline Bitmap objects by a speci-

fied amount.

The Outline option produces a keyline

around your object.

To grow object(s):

1.  Select the object(s) you wish to Grow.

2.  Choose Object > Grow. (Ctrl + B)

The Grow dialog box will open.
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3.  To set the growth measurement you can

either:

●  Key in the number of pixels by which you

want your object to grow in the edit box to

the left of the Amount slider.

OR

●  Click and drag on the triangle underneath

the Amount slider.

As you move the slider the values in the two

edit boxes will update.

OR

●  Key in the distance in which you want to

grow your object in the edit box to the right

of the Amount slider.

Right mouse clicking on the Amount

measurement edit box to the right will give

you the following measurement options:

Application Default, mm, cm, Inches and

Points.

4.  Select the Grow radio button.

5.  Click on the OK button.

The Grow dialog box will close and the Task

Manager will open showing you the object is

Growing.

After the file has finished processing the

Task Manager will close and the object with

the grow applied will display on your page.

To shrink object(s):

1.  Select the object(s) you wish to Shrink.

2.  Choose Object > Grow. (Ctrl + B)

The Grow dialog box will open.
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3.  To set the shrink measurement you can

either:

●  Key in the number of pixels by which you

want your object to shrink in the edit box to

the left of the Amount slider.

OR

●  Click and drag on the triangle underneath

the Amount slider.

As you move the slider the values in the two

edit boxes will update.

OR

●  Key in the distance by which you want to

shrink your object in the edit box to the

right of the Amount slider.

Right mouse clicking on the Amount

measurement edit box to the right will give

you the following measurement options:

Application Default, mm, cm, Inches and

Points.

4.  Select the Shrink radio button.

5.  Click on the OK button.

The Grow dialog box will close and the Task

Manager will open showing you the object is

Shrinking.

After the file has finished processing the

Task Manager will close and the object that

has been shrunk will display on your page.

To outline object(s):

1.  Select the object(s) you wish to Outline.

2.  Choose Object > Grow. (Ctrl + B)

The Grow dialog box will open.

3.  To set the outline measurement you can

either:

●  Key in the number of pixels you want the

thickness of  your outline to be in the edit

box to the left of the Amount slider.
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OR

●  Click and drag on the triangle underneath

the Amount slider.

As you move the slider the values in the two

edit boxes will update.

OR

●  Key in the thickness you want your

outline to be in the edit box to the right of

the Amount slider.

Right mouse clicking on the Amount

measurement edit box to the right will give

you the following measurement options:

Application Default, mm, cm, Inches and

Points.

4.  Select the Outline radio button.

5.  Click on the OK button.

The Grow dialog box will close and the Task

Manager will open showing you the object is

outlining.

After the file has finished processing the

Task Manager will close and the object that

has been outlined will display on your page.

Editing picture objects

As we said before, a Picture object behaves

like a Bitmap object, in that you can airbrush

into it, do pixel cloning or apply a color

mask but it is otherwise quite limited.

You can transform a Picture Object but you

cannot transform the Shape or Layer. 

A Picture object is really just ‘waiting’ to

become either a Vector object or a Bitmap

object. 

To crop a picture object:

1.  Open a picture or place a picture onto

your page.

2.  Select the picture object you wish to crop

by clicking on it, or select it from your object

list.

3.  From the tool palette select the vector

rectangle tool or the bitmap rectangle

tool .
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If you crop a Picture object with a Bitmap

tool,  the cropped object becomes a Bitmap

object. If you crop a Picture object with a

Vector tool,  the cropped object becomes a

Vector object.

The tool modifier ribbon will now show the

tools that are connected to either the vector

or bitmap tools, whichever you have

selected.

4.  Select the crop tool from the tool

modifier ribbon. 

The cursor will display showing the crop

icon to the bottom right of the cursor.

If you are cropping using the bitmap

rectangle tool , you can set a resolution

and select anti-aliasing for the cropped

object.

5.  Click and drag over the area you wish to

crop.

The object will now be cropped.
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T he painting tools provided in Wright

Design allow you to brush any paint

style from the Paint Style palette to

create an object. You can brush a Tint, a

Picture or even a Filter paint style. 

The painting tools available are the Brush

tool and the Clone tool. All objects created

using the Brush and Clone tools are Bitmap

objects.

The Brush tool

The Brush tool creates a Bitmap

object when you paint onto the page

containing the paint style that is set in the

Paint Style palette.

You can modify the Brush type, Shape, Size,

Hardness, Spacing, Opacity, Angle, Texture,

Fade, Resolution and Cursor display from the

Brush Tool Modifiers in the Tool Modifier

ribbon. 

These settings can be saved as brushes to the

Brush Gallery.

To set up a brush style: 

1.  Set up a Fill paint style in the Paint Style

palette.

As an example we are selecting a Tint paint

style.

For more information on paint styles see

Chapter 6 - Filling Objects with Layers, ‘The

Paint Styles’ on page 136.

2.  Select the Brush tool from the tool

palette.

The Tool Modifier ribbon will show the

Brush Tool Modifiers.

We will now go through the controls on the

Brush Tool modifier.

3.  From the Brush Tool Modifier select a

Brush style.

The Brush styles are:

Paintbrush:    

Airbrush:

Chalk:
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Charcoal:

Crayon:

Splatter:

Hold down the arrow to the right of the

combo box, scroll down and select the Brush

style you require.

4.  To select the shape of your Brush select

either the Round brush or Square Brush

button.

Round brush            Square brush

5.  To set the Cursor shape hold down the

arrow to the right of the cursor combo box,

scroll down and select the cursor you

require.

If you are using the circle cursor it may

turn back to a cross-hair when your brush is

too big or too small. This depends on the

operating system you are using. Windows NT

supports larger brush sizes than Windows 95.

6.  To set the size of your Brush, key in a

number in the Size edit box or click and drag

on the slider to enter a value. 

Right mouse clicking on the Size edit

box will give you the following measurement

options: Application Default, mm, cm,

Inches, Points and Pixels.

7.  The Hardness controls the size of the

hard center of the brush. 

To set the hardness, key in a number in the

Hardness edit box or click and drag on the

slider to enter a value. 

At zero the brush is feathered from 0%

opacity at the edge of the brush to 100%

opacity at the center of the brush.

At 100 the brush is fully opaque.

0% Hardness
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100% Hardness

8.  The Spacing controls the distance

between the brush dabs in a brush stroke.

To change the spacing key in a number in

the Spacing edit box or click and drag on the

slider to enter a value that is the percentage

of the brush diameter.

50% Spacing

15% Spacing

9.  The Opacity controls the opacity of the

brush from 0 % to 100% where 100% is fully

opaque.

To change the opacity key in a number in

the Opacity edit box or click and drag on the

slider to enter a value.

30% Opacity

100% Opacity

10. The Round/Square value controls the

aspect ratio of your brush. 

If you have a Round brush selected this

control will be ‘round’. If you have a Square

brush selected this control will be ‘square’.

To change the aspect ratio key in a number

in the Round/Square edit box or click and 

drag on the slider to enter a value that is a

percentage of the brush diameter.

10%   50%   100%  Round ratio

10%   50%   100%  Square ratio

The brushes above may show a

different angle depending on the angle value

you have set.

11. The Angle control specifies the angle by

which the brush’s long axis is offset from the

horizontal.

To change the angle, key in a number in the

Angle edit box or click and drag on the slider

to enter a value in degrees.

0°      63°    90°  Angled Round brush

0°      63°    90°  Angled Square brush

The angle of the brush can also be

changed by clicking and dragging on the

Brush preview. 
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12. The Texture control changes the grain

size of the texture in a brush. 

To change the texture, key in a number in

the Texture edit box or click and drag on the

slider to enter a value.

Texture has no effect on the Paintbrush

brush style.

1%          40%   Texture splatter brush

13. The Fade option controls the rate at

which the brush stroke fades out to simulate

actual brush strokes

To activate the Fade control click on the

Fade checkbox.

Enter a number in the Steps edit box or click

and drag on the slider to enter the number

of steps of the fade.

The steps range from 1 to 300. Steps are

individual brush dabs that make up a brush

stroke (See ‘Spacing’).  

With Fade

Without Fade

14. The Resolution option controls the reso-

lution of the Brushed Bitmap object. 

To set the resolution, key in a number in the

Resolution edit box or click on the spin dials

to enter a value.

Right mouse-clicking on the Resolution

edit box will give you the following measure-

ment options: Pixels/mm, Pixels/cm and dpi.

To paint using your brush style:

1.  Set up your brush style. 

2.  Select the Tool modifier you require from

the top left of the Brush tool modifier

ribbon.

New modifier tool: creates a new inde-

pendent object every time you create a brush

stroke. 

Add modifier tool: adds the brush stroke

to the Bitmap object that you have selected.

If you don’t have a Bitmap object selected

when you create an object using the Add tool

modifier a new object will be created.
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Subtract modifier tool: subtracts (erases)

the brush stroke from the Bitmap object that

you have selected.

3.  Start brushing your object.

4.  After you have created your brush stroke

you can edit the object using the Add 

and Subtract modifier tools.

Remember that brush strokes are also

objects. Therefore you can edit the shape of

the object using the transform modes or the

fill of the object using the Paint Style palette.

The Brush Gallery palette

The Brush Gallery palette allows you to save

Brush styles you have created.

From the Brush Gallery palette you can then

save galleries of Brush styles to a file. 

To display the Brush gallery palette:

●  Choose Window > Palettes > Brush

Gallery. (F4)

The Brush Gallery palette will display whilst

you are in the Brush tool but will disappear

when you select a different tool.

To display the Brush Gallery palette at all
times:

●  Select the ‘Show gallery always’ button

at the top left of the Brush Gallery

palette. 

The Brush Gallery palette will now stay

displayed even when you select a different

tool.

The only way of closing the Brush Gallery

palette is to select the cross at the top right

of the palette.

To automatically activate the Brush tool:

If you have the Pin button selected to

display the Brush Gallery palette at all times

you can check the ‘Activate tool’ checkbox

to activate the Brush tool when you select a

brush gallery.

1.  Click on the Activate tool checkbox in the

Brush Gallery palette.

2.  Select a brush style from the Brush

Gallery palette.

The Brush tool is now automatically selected

from the tool palette.

To save a brush style to the Brush Gallery
palette:

1.  Choose Window > Palettes > Brush

Gallery. (F4)

The Brush Gallery palette will display.
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2.  Set up a Brush style as explained on page

257.

3.  To save the brush style that is set in the

Brush Tool modifier click on the plus button

at the top right of the Brush Gallery

palette.

A thumbnail will display showing you the size

of the brush you have just saved.

4.  Keep following the procedure above to

add more brush styles to the Brush Gallery

palette.

To use a brush style from the Brush Gallery
palette:

1.  Click on the thumbnail of the brush style

you wish to use.

This brush style will load into the Brush tool

modifier ribbon.

To delete a brush style from the Brush
Gallery palette:

1.  Click on the thumbnail of the brush style

you wish to delete.

The thumbnail will now be highlighted with

a thick black keyline.

2.  Click on the Delete button in the

Brush Gallery palette.

The selected brush style will now be deleted.

To replace a brush style in the Brush Gallery
palette:

1.  Select the brush style in the Brush

Gallery palette that you wish to replace.

This brush style will load into the Brush tool

modifier ribbon.

2.  Adjust the brush style setting in the

Brush tool modifier.

262 Chapter 8 - Painting and Cloning



3.  Click on the replace button in the

Brush Gallery palette.

The selected brush style will now be

replaced.

The Brush Gallery palette will now display till

you select the Pin button or you close the

palette.

To save a brush gallery from the Brush
Gallery palette to a file:

1.  Click on the Save gallery button in

the Brush Gallery.

The Save As dialog box will open. The orig-

inal default folder path, will be the the

Wright Design ‘Program’ folder.

The default folder path from then on is the

path that you used when you last opened or

saved a brush gallery.

3.  If the default folder path is not the path

you require, click on the arrow to the right

of the “Save in” combo box and select a new

folder path.

4.  The icons across the top of the dialog box

are general Windows functions.

5.  Enter a name in the File name edit box.

6.  The type of file you will be saving is a

Brush gallery file (.wdg).

7.  Click Save. 

Your brush gallery will now be saved with

the file name you specified, to the folder you

specified.

To load a brush gallery file into the Brush
Gallery palette:

1.  Click on the Load gallery button in

the Brush Gallery.

The Open dialog box will display. The orig-

inal default folder path will be the the Wright

Design ‘Program’ folder.

The default folder path from then on is the

path that you used when you last opened or

saved a brush gallery.

3.  If the default folder path is not the path

you require, click on the arrow to the right

of the “Look in” combo box and select a new

folder path.

4.  The icons across the top of the dialog box

are general Windows functions.

5.  Select a file and it will display in the File

name edit box.
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6.  The type of file you will be opening is a

Brush gallery file (.wdg).

7.  If you want to add the gallery you are

opening to a gallery that is already displayed

in the Brush Gallery palette click on the

‘Add to existing gallery’ checkbox.

If you want the gallery you are loading to

replace the gallery that is displayed in the

Brush Gallery palette make sure the ‘Add to

existing gallery’ checkbox is not checked.

8.  Click Open.

The brush gallery you opened will now

display in the Brush Gallery palette.

Adding and Subtracting from Bitmap
or Picture objects
All objects created using the Brush tool are

Bitmap objects therefore you can use the

Brush tool to add to or subtract from (erase)

existing Bitmap or Picture objects.

To add and subtract from a Bitmap or
Picture object:

1.  Select the Bitmap or Picture object you

want to edit.

2.  Select the Brush tool from the tool

palette.

The Tool Modifier ribbon will show the

Brush tool modifiers.

3.  Select the Subtract modifier tool from

the Brush tool modifier ribbon.

The Subtract tool modifier will brush away

from your selected object.

4.  Set your brush style using the controls in

the Brush tool modifier ribbon..

This is explained on page 257.

5.  Start to brush away from your selected

object.

6.  Select the Add modifier tool from the

Brush tool modifier ribbon.

The Add tool modifier will add to your

selected object.
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If you are frequently adding and

subtracting from your selected object you

can hold the Shift key down to reverse the

Tool modifier that you have selected.

For example: If you have the Add modifier

tool selected you can hold the Shift key

down and the brush will switch to the

Subtract modifier tool.

The Clone tool

The Clone tool takes a sample of a

picture which you then paint over another

picture or part of the same picture.

The most common use for Cloning is

removing imperfections or blemishes in a

picture. This is done by sampling adjacent

areas and copying this over the imperfec-

tions and blemishes.

There are two types of cloning:

Flat-plane cloning: works with a single

picture. It lets you paint a copy of a picture

into the same picture. You have the option

of saving a copy of the picture under a new

filename or updating the original picture.

Object-based cloning: works with objects.

The original selected object is cloned to

create one or more new objects anywhere on

your page.

The clone tool consists of two brushes. You

have the Source brush (a cross hair) and the

Destination brush (displayed according to

your cursor setting in the Brush tool modi-

fier ribbon).

To flat-plane clone:

1.  Select the object you wish to clone.

The object you select can be a Vector,

Bitmap or Picture object but it must have a

Picture paint style (layer).

2.  Select the Clone tool from the tool

palette.

The Tool Modifier ribbon will show the

Clone tool modifiers.

3.  Set your brush style using the controls in

the Clone tool modifier ribbon.

265

Clone tool modifiers

Tool 
modifiers

Brush
Shapes

Brush Style

Brush 
view

Cloning
selector

Reset tool
offset



This is explained on page 257.

4.  To flat-plane clone select the ‘Update

Picture’ button at the top right of the Clone

tool modifier ribbon.

If you don’t select this button you will be in

Object-based cloning mode.

5.  To reset your Clone tool select the ‘Reset

tool offset’ button on the Clone tool modi-

fier ribbon.

Your source brush and destination brush will

now be at the same position.

You don’t have to reset the tool offset but it

makes it easier to locate your source and

destination brushes.

6.  Move the source brush to the point

where you want to start cloning.

7.  Hold down the Alt key to anchor your

source brush and move the destination

brush to the point where you want your

clone to go.

8.  Let go of the Alt key.

You can now see the two brushes set apart

from one another.

9.  Start painting. 

A dialog box will open asking you if you want

to copy the picture before modifying it.

10.  Select the option you require.

If you select No the cloning you apply to the

picture will modify the original picture.

If you select Yes the Save as dialog box will

open.

The original default folder path will be the

the Wright Design ‘Program’ folder.

The default folder path from then on, is the

path that you used when you last opened or

saved a picture.

11. If the default folder path is not the path

you require, click on the arrow to the right

of the “Save in” combo box and select a new

folder path.

12. The icons across the top of the dialog

box are general Windows functions.

13. Enter a name in the File name edit box.
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14. The type of file you will be saving is a

DCM file (.DCM).

15. Click Save. 

Your picture will now be copied.

The ‘Picture’ paint style will now update

with the new picture.

This can be seen by the filename that is

displayed for the ‘Picture’ paint style in the

Paint Style palette.

16. Start painting.

You will see the picture is being copied from

the source brush to the destination brush.

In the example below we have copied two

grapes and a strawberry at the center bottom

of the picture. 

17. When you are flat-plane cloning the tool

modifiers react in the following way.

The New and Add modifier tools from

the Clone tool modifier ribbon add the clone

to your picture.

The Subtract modifier tool  from the

Clone tool modifier ribbon is used to

subtract from your picture the clone or part

of the clone you have applied .

You can hold the Shift key down to

change between the Add and Subtract
tool modifier that you have selected.

For example: If you have the Add modifier

tool selected you can hold the Shift key

down and the brush will switch to the

Subtract modifier tool.

To object-base clone:

1.  Select the object you wish to clone.

The object you select can be a Vector,

Bitmap or Picture object but it must have a

Picture paint style (layer).

2.  Select the Clone tool from the tool

palette.

The Tool Modifier ribbon will show the

Clone tool modifiers.

3.  Set your brush style using the controls in

the Clone tool modifier ribbon.

This is explained on page 257.

4.  Make sure the ‘Update Picture’ button at

the top right of the Clone tool modifier

ribbon is not selected.
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If this button is selected you will be in Flat-

plane cloning mode.

5.  To reset your Clone tool select the ‘Reset

tool offset’ button on the Clone tool modi-

fier ribbon.

Your source brush and destination brush will

now be at the same position.

You don’t have to reset the tool offset but it

makes it easier to locate your source and

destination brushes.

6.  Move the source brush to the point

where you want to start cloning.

7.  Hold down the Alt key to anchor your

source brush and move the destination

brush to the point where you want your

clone to go.

8.  Let go of the Alt key.

You can now see the two brushes set apart

from one another.

9.  Start painting. 

You will see the picture is being copied from

the source brush to the destination brush.

With object-based cloning the cloned area is

a new object.

The object can then be moved, scaled or

transformed in any way. 

10. When you are object-based cloning the

tool modifiers react in the following way.

The New modifier tool from the Clone

tool modifier ribbon creates a new object

every time you use the clone tool.

An object you create when using the

Clone tool is automatically a child object of

the original object you are cloning from.

Objects that have child objects

connected to them display with bold letters

in the Object List when you have ‘Grouped

objects together’ selected from the Object

List.

If you are cloning using the New tool modi-

fier and you have ‘Grouped objects

together’ set from the Object List, the

objects that you are cloning are found within

the original object in the Object List as they

are child objects of the original object.

The Add modifier tool from the Clone

tool modifier ribbon keeps adding to the

first cloned object.

The Subtract modifier tool from the

Clone tool modifier ribbon is used to

subtract from the clone or part of the clone

you have applied .
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You can hold the Shift key down to

change between the Add and Subtract
tool modifier that you have selected.

For example: If you have the Add modifier

tool selected you can hold the Shift key

down and the brush will switch to the

Subtract modifier tool.

In the example below the cloned object has

been rotated, scaled moved and had its

opacity changed.

You can ungroup the cloned object

from the original picture by using the Object

> Ungroup command or Ctrl+U.
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Wright Design provides you with standard

text formatting and editing features. 

This chapter will explain how to create and

edit text, how to exchange text with other

programs and how to use the word

processing features. We will go through the

features that enable you to make precise

typographical adjustments to the text in

your document.

Also included will be the capabilities of

fitting text to a curve, around an object

and/or inside a text container.

Text objects and text
In Wright Design you can either enter or

import text into text objects. The Text tool

allows you to create text objects and there

is no limit to the  number of text objects

that you can create in the one document. 

Once you have created a text object in your

page or on the pasteboard you can move,

duplicate, delete and/or modify it. The

ability to modify text objects as well as the

text that is contained in the text object

provides a flexible method of arranging text

on a page.

When you create a text object or select an

existing one, the box becomes active and is

displayed on-screen by a cyan keyline. You

can enter text into, reposition or modify an

active text object.

You must select the Text tool before you

can enter, import or edit text in an active

text object. When the Text tool is selected

the arrow cursor changes to the text inser-

tion bar when you move it over an active

text object. To establish a new text insertion

point, click the text insertion bar at the

position where you want to enter or import

text. The text insertion point is indicated by

a blinking text insertion bar.

Any font resident on your system may be

used in any combination, size, style or

color. 

As with Vector objects, Text objects are

resolution independent. They are more

closely related to Vector objects than to any

other type. In fact, you can convert Text

objects into vector objects and bitmap

objects.

Text objects can be automatically or manu-

ally linked to each other. Text that has been

applied to a text object can be converted to

a text container therefore allowing you to

type within the outline of the original text.

To create a text object:

1.  Make sure you have a document open.

2.  Select the Text tool from the Tool

palette.

The Text tool modifiers will display in the

Tool modifier ribbon.
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The tool modifier ribbon will show the

Character attributes when you first start the

application (as shown above).

From then on the last used text attribute will

be the one that displays in the tool modifier

ribbon.

The Text attributes are:

Shown above are the four text attribute

modifier buttons that are used to control

text objects and the text inside the objects.

2.  Position your cursor at the point where

you would like to start your text object.

3.  Click and drag the cursor to where you

want the opposite corner of your text object

to be.

4.  Release the mouse and your text object is

created.

By default, a cyan keyline will appear around

the outside of the text object showing you

the text object outline.

To display the text object without an outline

choose Text > Draw Outlines (the check-

mark to the left of the Draw Outlines option

will now disappear).

The next text object you create or if you

deselect and select the text object you are

working on will no longer display the cyan

outline

5.  The red flashing bar indicates the text

insertion point where text is placed when

you enter or import it. 

To activate an existing text object:

●  If you are in the Select tool click on

the existing text object.

●  If you are in the Text tool hold down

the Ctrl key and select the text object.

An active text object is displayed with a cyan

keyline and handles at each corner and at

the center of each edge and the center of the

object. 
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The cyan keyline is not displayed if you don’t

have Draw Outlines selected from the Text

menu.

To enter text in a text object:

1.  Make sure you have a document open.

2.  Create a text object as explained above.

The text insertion bar will be positioned

inside the text object at the top left.

3.  Select ‘Tint’ paint style in the Paint Style

palette.

4.  Start keying in your text.

To resize a text object:

1.  Make sure the text object you wish to

resize is selected and you are in the Text tool

.

2.  Place your cursor over one of the handles

and when it turns into a double-headed

arrow click and drag it to the required size.

The corner handles will resize the object

proportionally and the center edge handles

will affect either the width or height of the

object.

3.  You can resize text interactively by

holding down the Ctrl key, placing your

cursor over one of the handles and when it

turns into a double-headed arrow click and

drag it to the required size.

The corner handles will resize the object and

text proportionally and the center edge

handles will affect either the width or height

of the object and text.

You can interactively rotate the text

and text object whilst in the Text tool. Hold

down the Ctrl + Shift key, move the cursor

over one of the corner handles till you get a

circular arrow and click and drag. 
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You can interactively shear the text and

text object whilst in the Text tool. Hold

down the Ctrl + Shift keys, move the cursor

over one of the middle edge handles till you

get a double-sided arrow and click and drag. 

Text can be transformed the same as

any other object (except perspectively trans-

formed). To see how to transform objects

see Chapter 7 - ‘Editing Objects and/or

Layers’ - ‘Transforming Objects’ on page

223.

Editing text
When you enter or import text, characters

are entered at the text insertion point. When

a text box is active the text insertion point is

indicated by the blinking text insertion bar. If

a range of text is highlighted, characters you

enter or import replace the highlighted

range. Editing text requires moving the text

insertion bar within a Text object.

Wright Design provides two methods for

doing this. You can click the text insertion

bar at the place you want to insert text or

you can use keyboard options to move the

text insertion bar.

To replace, cut, copy or delete text you must

highlight it first. To highlight text you can

click and drag the text insertion bar or use

keyboard combinations.

To edit text:

1.  Select the text object containing the text

you wish to edit.

2.  Select the Text tool from the Tool

palette.

3.  To insert text place the text insertion bar

at the point where you want to insert the

text. Make sure the letters ‘INS’ appear in

the left most indicator at the bottom right of

your screen.

To replace text highlight the text that you

wish to replace. Make sure the letters ‘INS’

appear in the left most indicator at the

bottom right of your screen.

To overwrite text select the Insert key on

your keyboard and the letters ‘OVR’ appear

in the left most indicator at the bottom right

of your screen. 

Place your text insertion bar at the point you

want to start overwriting your text.
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4.  Type in your new text.

Inserted the word ‘the’.

Replaced ‘Editing’ with Replacing’.

Replaced ‘Replacing’ with ‘Overwriting’.

There is a range of shortcut keys that

enable you to move the text insertion bar

around your text object and highlight text.

These can be found at the end of this

chapter. 

Importing text
You can generate text using a stand alone

word processing program and import it into

Wright Design. To do this you cut/copy the

text from the word processing program and

paste it into a text object in a Wright Design

document.

ASCII format is a widely used text format

however it does not contain any character

attributes or paragraph format information.

RTF (rich text format) preserves character

attributes such as fonts, size, type style

(bold, italic, etc) and paragraph alignment.

To import text into a text object:

1.  Cut/copy the text from a word processing

program.

2.  Select the text object that you wish to

contain the imported text.

3.  Select the Text tool from the Tool

palette.

4.  Place the text insertion bar at the point

where you want to import the text.

5.  Choose Edit > Paste. (Ctrl + V)

The text will now display in the selected text

object.
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Exporting text
Text that has been generated in Wright

Design can be exported to other stand alone

word processing programs. To do this you

cut/copy the text from Wright Design and

paste it into the other program.

To export text:

1.  Select the text object that you wish to use

to export the text.

2.  Select the Text tool from the Tool

palette.

3.  Highlight the text that you wish to

export.

4.  Choose Edit > Cut (to cut the text from

Wright Design).  (Ctrl + X) 

OR

Edit > Copy (to copy the text from Wright

Design).  (Ctrl + C)

The text will now be copied to the paste-

board and you can paste it into any program

that supports ASCII or RTF (rich text format)

text.

Character Attributes
The first text button in the Tool modifier

ribbon contains the Character Attributes.

These controls enable you to change the font

type, size, horizontal scale, style, leading,

tracking, shift and kerning.

Character attributes can be set before you

key in your text or they can be applied to

highlighted characters.

To apply character attributes:

1.  Select the text object of which you wish

to apply or edit the character attributes.

2.  Select the Text tool from the Tool

palette.

3.  Select the Character attributes button 

from the Tool modifier ribbon if it is not

already selected. (Ctrl + Shift + F1) 

4.  Place the text insertion bar at the point

where you want the character attributes to

start or highlight the text whose character

attributes you wish to change. 
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Font Type
To apply a new font to highlighted charac-

ters or at the text insertion point click on the

arrow to the right of the Font type combo

box and select the font from the drop down

list.

A preview of each font as you highlight it is

displayed at the top right of the font type

combo box.

The preview can be turned off by choosing

File > Preferences > Text and unchecking

the ‘Enable font previews checkbox’.

The selected font will display in the Font

type combo box.

The fonts available in the Font type

drop down list are those fonts that you have

installed on your computer. Wright Design

supports Type 1 and True Type 

fonts. The symbol to the left of the font

shows you the type of font it is.

Font Size
To change the size of highlighted characters

or characters entered at the text insertion

point:

●  select the arrow to the right of the Font

size combo box and select a size from the

drop down list.

OR

●  key in a value in the Font Size combo box 

OR

●  click on the up and down arrows in the

spin controls to the left of the Font size

combo box.

Right mouse-clicking on the Font size

combo box will give you the following incre-

ment settings: Increment 10, Increment 1,

Increment 0.1 and Increment 0.01. These

settings control the increments between

values when using the spin controls no

matter what measurement option you have

selected. 

Right mouse-clicking on the Font size

combo box will give you the following text

measurement options: Points, mm, Inches,

Picas and Ciceros.  

Font Style
To apply a new type style to highlighted

characters or at the text insertion point click

on the font style button(s) in the Tool modi-

fier ribbon.
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You can select a combination of these attrib-

utes at the one time. For example, you may

want Bold, Italic type.

Some attributes cannot be applied in combi-

nation (for example, Superscript and

Subscript and All caps and Small Caps).

(where the ‘2’ has Superscript 

style applied to it)

(where the ‘2’ has Subscript 

style applied to it)

(where the ‘2’ has Superior 

style applied to it)

Character Width
To change the width of highlighted charac-

ters or characters entered at the text inser-

tion point as a percentage:

●  key in a value in the Width of Character

combo box.

OR

●  click on the up and down arrows in the

spin controls to the right of the Width of

Character combo box.

Leading
Leading enables you to change the amount

of space between lines of text.

To change the leading of highlighted charac-

ters or characters entered at the text inser-

tion point:

●  key in a value in the Leading combo box. 

OR

●  click on the up and down arrows in the

spin controls to the right of the Leading

combo box.

Right mouse-clicking on the Leading

combo box will give you the following

measurement options: Auto, Points, mm,

Inches, Picas and Ciceros, Percent and Lines.  

Right mouse-clicking on the Leading

combo box will give you the following incre-

ment settings: Increment 10, Increment 1,

Increment 0.1 and Increment 0.01. These

settings control the increments between

values when using the spin controls no

matter what measurement option you have

selected. 

Tracking
Tracking enables you to adjust the space

between highlighted characters and words.
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You can use negative tracking values to

decrease the space between highlighted

characters or positive values to increase the

space.

To change the tracking amount of high-

lighted characters or characters entered at

the text insertion point:

●  key in a value in the Tracking combo box. 

OR

●  click on the up and down arrows in the

spin controls to the right of the Tracking

combo box.

Right mouse-clicking on the Tracking

combo box will give you the following incre-

ment settings: Increment 10, Increment 1,

Increment 0.1 and Increment 0.01. These

settings control the increments between

values when using the spin controls no

matter what measurement option you have

selected. 

Right mouse-clicking on the Leading

combo box will give you the following

measurement options: Points, mm, Inches,

Picas, Ciceros, Percent and Ems.  

Shift
Baseline shift enables you to move charac-

ters above or below their baselines without

affecting a paragraph’s line spacing. You can

use Shift to raise or lower a single character

or a range of highlighted characters.

To change the baseline shift of highlighted

characters or characters entered at the text

insertion point:

●  key in a value in the Shift combo box. 

OR

●  click on the up and down arrows in the

spin controls to the right of the Shift combo

box.

Right mouse-clicking on the Shift

combo box will give you the following incre-

ment settings: Increment 10, Increment 1,

Increment 0.1 and Increment 0.01. These

settings control the increments between

values when using the spin controls no

matter what measurement option you have

selected. 

Right mouse-clicking on the Shift

combo box will give you the following

measurement options: Points, mm, Inches,

Picas, Ciceros, Percent and Lines.

Kerning
Kerning is the adjustment of space between

character pairs. Wright Design provides auto-

matic kerning based on the font’s built in

kerning table.

To select automatic kerning of highlighted

characters or characters entered at the text

insertion point:

●  check the Kerning check box.

To turn automatic kerning off:

●  uncheck the Kerning check box.
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Paragraph Attributes
The second text button in the Tool modifier

ribbon contains the Paragraph Attributes.

Paragraph attributes are the stylistic specifi-

cations you apply to paragraphs. These

include Paragraph alignments, First line, Left

indent, Right indent, Space above, Space

below, Keep lines together, Keep with next

and Drop caps. 

Paragraph attributes can be set before you

key in your text or they can be applied to a

paragraph that has the text insertion bar

placed within it or part or all of the para-

graph is highlighted..

To apply paragraph attributes:

1.  Select the text object of which you wish

to apply or edit the paragraph attributes.

2.  Select the Text tool from the Tool

palette.

3.  Select the Paragraph attributes button 

from the Tool modifier ribbon if it is not

already selected. (Ctrl + Shift + F2)

4.  Place the text insertion bar within the

paragraph or highlight some or all of the text

in the paragraph whose attributes you wish

to change. 

Paragraph alignments
Wright Design has five paragraph alignments:

Left, Centered, Right, Justified and Forced

Justified.

A left-aligned paragraph has a straight left

margin and a ragged right margin, like the

text on this page. The text in a center-

aligned paragraph is centered between the

paragraph’s indents; both its left and right

margins are ragged. A right-aligned para-

graph has a straight right margin and a

ragged left margin. 

A justified paragraph has straight margins on

both the left and right sides. When a para-

graph is justified, word and character spacing

are adjusted so that the text on each line

extends from the left indent to the right

indent. When a paragraph is forced, space is

added between characters and words in all

lines in the paragraph - including the last,

possibly incomplete line, so that the text

spans the distance between the left and right

indents. 
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To apply a paragraph alignment to high-

lighted characters or at the text insertion

point select the alignment button you

require.

OR

Apply the appropriate shortcut key:

Align Left: Ctrl + Shift + L

Align Center: Ctrl + Shift + C

Align Right: Ctrl + Shift + R

Justify: Ctrl + Shift + J

Forced justify: Ctrl + Alt + Shift + J

Indent First Line
To apply a first line indent to a paragraph
where you have highlighted some text or

placed the text insertion bar within the para-

graph:

●  key in a value in the First combo box. 

OR

●  click on the up and down arrows in the

spin controls to the right of the First combo

box.

If you have a left or right indent set then this

is added to the First Line Indent.

Right mouse-clicking on the First

combo box will give you the following

measurement options: Points, mm, Inches,

Picas and Ciceros.

Left Indent
To apply a left indent to a paragraph where

you have highlighted some text or placed the

text insertion bar within the paragraph:

●  key in a value in the Left combo box. 

OR

●  click on the up and down arrows in the

spin controls to the right of the Left combo

box.

Right mouse-clicking on the Left

combo box will give you the following

measurement options: Points, mm, Inches,

Picas and Ciceros.

Right Indent
To apply a right indent to a paragraph
where you have highlighted some text or

placed the text insertion bar within the para-

graph:

●  key in a value in the Right combo box. 

OR

●  click on the up and down arrows in the

spin controls to the right of the Right combo

box.
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Right mouse-clicking on the Right

combo box will give you the following

measurement options: Points, mm, Inches,

Picas and Ciceros.

Space Above Paragraph
To change the amount of space above a
selected paragraph where you have high-

lighted some text or placed the text insertion

bar within the paragraph:

●  key in a value in the Above combo box. 

OR

●  click on the up and down arrows in the

spin controls to the right of the Above

combo box.

The sum of the Space Above and the Space

Below values determines the total amount of

space between paragraphs.

Right mouse-clicking on the Above

combo box will give you the following

measurement options: Points, mm, Inches,

Picas and Ciceros.

You cannot change the space above the

first paragraph in your text object.

Space Below Paragraph
To change the amount of space below a
selected paragraph where you have high-

lighted some text or placed the text insertion

bar within the paragraph:

●  key in a value in the Below combo box. 

OR

●  click on the up and down arrows in the

spin controls to the right of the Below

combo box.

The sum of the Space Above and the Space

Below values determines the total amount of

space between paragraphs.

Right mouse-clicking on the Below

combo box will give you the following

measurement options: Points, mm, Inches,

Picas and Ciceros.

Keep Together
The Keep Together control will keep all lines

of a selected paragraph in the same column

or on the same page.

To keep all lines together where you have

highlighted some text or placed the text

insertion bar within the paragraph:

●  check the Together checkbox.

With Next
The With Next control prevents a one-line

paragraph at the bottom of a column or page

from becoming separated from the para-

graph that follows.

To keep a paragraph with the next para-
graph where you have highlighted some text

or placed the text insertion bar within the

paragraph:

●  check the With Next checkbox.
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Drop Caps
A drop cap is the first letter of a paragraph

that is enlarged.

To apply a drop cap to a paragraph where

you have highlighted some text or placed the

text insertion bar within the paragraph:

1.  Click on the Drop Caps checkbox.

The first letter of the paragraph is now

enlarged. The Descenders checkbox and

Lines edit box will become available.

2.  Key in the number in the Lines edit box

to specify the number of lines you want the

character to drop.

3.  If the first letter of your paragraph has a

descender (for example the letter ‘g’ where

character flows under the baseline of the

font) you can click on the Descender

checkbox and the letter will be scaled to fit. 

Text Object Attributes
The third text button in the Tool modifier

ribbon contains the Text Object Attributes.

These controls enable you to align your text

vertically, create columns within your text

objects and fit text to a curve. 

Text Object attributes can be set before you

key in your text or they can be applied to the

text object that is selected.

To apply text object attributes:

1.  Select the text object of which you wish

to apply or edit the text object attributes.

2.  Select the Text tool from the Tool

palette.

3.  Select the Text Object attributes button

from the Tool modifier ribbon if it is not

already selected. (Ctrl + Shift + F3) 

Aligning Text Vertically
Wright Design gives you four options for

positioning lines of text vertically within text

objects: Top, Center, Bottom and Forced

Justify.
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In text objects specified as top-aligned, lines

of text are positioned in the object with the

top of the first line positioned at the top of

the text object.

In text objects specified as center-aligned,

lines of text are centered between the top

and bottom of the text object.

In text objects specified as bottom-aligned,

the last line of text is positioned at the

bottom of the text object. The object is filled

from bottom to top as text is entered. 

In text objects specified as forced justify,

lines of text are positioned in the box with

the first line positioned at the top of the

object, the last line positioned at the bottom

of the object and the remaining lines spaced

evenly in between.

To apply vertical alignment to the text object

that is selected select the alignment button

you require.

Columns
Columns are vertical divisions in text objects.

The maximum number of columns in a single

text object is ten.

To apply columns to the text object that is

selected:

●  key in a value in the Columns combo

box. 

OR

●  click on the up and down arrows in the

spin controls to the right of the Columns

combo box.

Two columns
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Gap
The gap is the space between the columns. 

To apply a gap to the text object that is

selected:

●  key in a value in the Gap combo box. 

OR

●  click on the up and down arrows in the

spin controls to the right of the Gap combo

box.

If you have your gap set to zero but you have

more than one column you cannot see the

dividing line for your column(s). 

Right mouse-clicking on the Gap

combo box will give you the following

measurement options: Application default,

Auto, mm, cm, Inches, Points and Pixels.

Border
The border is the space between the inner

edge of a text object and the area that the

text can occupy. A border can be applied

with or without columns. The border value

must be less than one half the width of the

text object (if you don’t have columns) or 

less than one half the width of each column

(if you do have columns).

To apply a border to the text object that is
selected:

●  key in a value in the Border combo box. 

OR

●  click on the up and down arrows in the

spin controls to the right of the Border

combo box.

Right mouse-clicking on the Border

combo box will give you the following

measurement options: Application default,

Auto, mm, cm, Inches, Points and Pixels.

Fit text to a Curve
Wright Design allows you to fit text to a

curve. You can create type that follows an

open or a closed path. You first need to

create a path and convert the path to a text

container. The path can be regularly or irreg-

ularly shaped.

The text can be created Tangent to or

Skewed horizontally or vertically to the path.

You can also create text along a path without

a transform.
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The text can be aligned to the top, middle,

baseline or bottom of the path.

To create an open path:

1.  Select the Vector Curved polygon 

tool from the tool palette.

2.  Set the Paint Style palette ‘Fill’ to have

no paint style and the ‘Stroke’ to have a

‘Tint’ paint style (the color does not

matter). 

3.  Plot your curve by selecting points and to

complete the open path hit the Enter key.

For information on using the Vector Curved

polygon tool see Chapter 5 - Creating

Objects - ‘The Curved Polygon Vector Tool’

on page 97.

To create a closed path:

1.  Select the Vector tool you require for the

shape you want from the Tool palette.

2.  Set the Paint Style palette ‘Fill’ to have

no paint style and the ‘Stroke’ to have a

‘Tint’ paint style (the color does not

matter). 

3.  Plot your shape.

For information on using the Vector tools

see Chapter 5 - Creating Objects - ‘Vector

Objects’ on page 94.

To convert the vector object to a text
container:

1.  Make sure the object you have just

created is selected.

2.  Choose Object > Convert. (Ctrl + T)

The Convert dialog box will display.

3.  Select the Text Container tab.

4.  Select the Delete selection and click OK.

The Vector object will now be a Text

container.

For information on using Convert Objects

see Chapter 5 - Creating Objects -

‘Converting Objects’ on page 124.

To enter type along path:

1.  Make sure the object you have just

converted is selected.

2.  Select the Text tool from the Tool

palette.
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The text path will display if you have 

Text > Draw Outlines selected. If not the

Text object handles will display with the

flashing text insertion bar.

3.  Set the Character attributes for your

text. You can also set or alter these after you

have entered the text. 

Character attributes are explained earlier in

this chapter.

4.  Select the Text Object attributes 

button and check the ‘Fit to curve’

checkbox.

We will use the default ‘Fit to curve’ settings

which are ‘Tangent’ and ‘Align Baseline’

.

The options available to you for fitting text

to a curve are shown at the end of this

section.

4.  Set the Paint Style palette ‘Fill’ to the

paint style you require for your text. You can

also apply a ‘Stroke’ paint style if required.

You can select any paint style to be

applied to your text but you cannot move

the paint styles within the text (i.e. you

cannot move a picture around inside a Text

object).

For the full control of any paint style

that you want to transform within text you

should convert the Text object to a Vector

object.

5.  Enter your text.

To reverse the direction of type along a
path:

1.  Select the text if it is not already selected.

2.  Click on the ‘Reverse text direction along

a curve’ button.

The text has now changed direction.

The effect of reversing the direction of

type along a path will depend on what

options you have selected on the top row of

the ‘Fit text to curve’ options.

Fit text to curve options
The ‘Fit to curve’ options are as follows. You

select one button from the top row and one

from the bottom row.
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‘Tangent’ to the path

‘No transform’ 

‘Skew horizontal’ to the path

‘Skew Vertical’ to the path

The bottom row of the ‘Fit to curve' options

consists of the following:

To create text above and below a circle:

1.  Select the Vector ellipse tool from the

Tool palette.

2.  Set the Paint Style palette ‘Fill’ to have

no paint style and the ‘Stroke’ to have a

‘Tint’ paint style (the color does not

matter). 

3.  Plot your circle.

For information on using the Vector ellipse

tool see Chapter 5 - Creating Objects - ‘The

Ellipse Vector Tool’ on page 97.
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4.  Select the Bezier tool from the tool

palette.

5.  Select the node on the right side of the

circle and click on the ‘Break’ button on the

Bezier tool modifier ribbon.

6.  Select the node on the left side of the

circle and click on the ‘Break’ button on the

Bezier tool modifier ribbon.

7.  Select the ‘Split’ button on the Bezier

tool modifier ribbon.

The circle has now been split into two

objects.

8.  Click on the Select tool from the tool

palette.

9.  Select the object for the top half of the

circle.

10. Choose Object > Convert. (Ctrl + T)

The Convert dialog box will display.

11. Select the Text Container’ tab.

12. Select ‘Delete selection’ and click OK.

The Vector object will now be a Text

container.

For information on using Convert Objects

see Chapter 5 - Creating Objects -

‘Converting Objects’ on page 123.

13. Select the object for the bottom half of

the circle.

Follow steps 10 to12 to convert this object

to a text container.

14. Select the object for the top half of the

circle.

15. Select the Text tool from the Tool

palette.

The text path will display if you have 

Text > Draw Outlines selected. If not the

Text object handles will display with the

flashing text insertion bar.

16. Set the Character attributes for your

text. You can also set or alter these after you

have entered the text. 

Character attributes are explained earlier in

this chapter.

17. Select the Paragraph attributes button

and select the center paragraph align-

ment button.

The text will now flow from the top center of

the circle.

18. Select the Text Object attributes 

button and check the ‘Fit to curve’

checkbox.

291



Select the ‘Tangent’ and ‘Align Baseline’

options.

19. Set the Paint Style palette ‘Fill’ to the

paint style you require for your text. You can

also apply a ‘Stroke’ paint style if required.

You can select any paint style to be

applied to your text but you cannot move

the paint styles within the text (i.e. you

cannot move a picture around inside a Text

object).

For the full control of any paint style

that you want to transform within text you

should convert the Text object to a Vector

object.

20. Enter your text.

21. Select the bottom Text object.

22. Select the Paragraph attributes button

and select the center paragraph align-

ment button.

The text will now flow from the bottom

center of the circle.

23. Select the Text Object attributes 

button and check the ‘Fit to curve’

checkbox.

Select the ‘Tangent’ , ‘Align Top’ and

the ‘Reverse text direction along a curve’ 

options.

24. Set the Paint Style palette ‘Fill’ to the

paint style you require for your text. You can

also apply a ‘Stroke’ paint style if required.

25. Enter your text.

Linking Attributes
The fourth text button in the Tool modifier

ribbon contains the Linking Attributes.

These controls enable you link Text objects

so that text automatically flows from one text

object to another. 

Linking attributes can be set whenever you

have more than one Text object in your

document.

To manually link text boxes:

1.  Create a text object.

2.  Enter text in your text box.
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3.  Create a new Text object.

4.  Select the original Text object.

5.  Select the Linking attributes button 

from the Tool modifier ribbon if it is not

already selected. (Ctrl + Shift + F4)

6.  Click inside the selected text object and a

cyan line with an arrowhead will display.

Whilst still holding down the cursor drag the

cyan arrowhead to the top of the object you

want to link to and let go.

You cannot see the object but your cursor

will snap to the object.

If you had text overflowing from your orig-

inal object, this text will now flow into the

linked object.

If you didn’t have text overflowing you can

keep keying in text into the original object

and when you reach the bottom of this

object the text will automatically flow into

the linked object. 

To see Text objects that have been

linked, select the Linking attribute button

from the Tool modifier ribbon and a cyan

line with an arrowhead will display, showing

you the objects that are linked.

To automatically link text boxes:

1.  Create a text object.

2.  Select the Auto-linking button from

the Text modifier ribbon.

Every Text object you create whilst you have

this button selected will be linked.

To cancel the Auto-linking click on the

Auto-linking button from the Text modifier

ribbon.
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Filling text with layers
Any paint style can be applied to text. You

can apply a ‘Fill’ paint style and/or a

‘Stroke’ paint style to text.

The paint style can be set in the Paint Style

palette before you create your text or you

can highlight existing text and change the

paint styles in the Paint Style palette.

For more information on paint styles see

Chapter 6 - Filling Objects with Layers, ‘The

Paint Styles’ on page 136.

You can select any paint style to be

applied to your text but you cannot move

the paint styles within the text (i.e. you

cannot move a picture around inside a Text

object).

For the full control of any paint style

that you want to transform within text you

should convert the Text object to a Vector

object.

For information on using Convert Objects

see Chapter 5 - Creating Objects -

‘Converting Objects’ on page 124.

Wrapping text around an
object
In Wright Design you can make text wrap

around any object. The Text object that

contains the text to be wrapped around an

object cannot have columns.

To wrap text around an object:

1.  Create your text object(s) and key the

required text into the text object(s).

You can also key in the text after you have

created the object to run around.

2.  Create the object(s) that you wish to run

your text around.

3.  Select the text object.

4.  Select the Bezier tool from the tool

palette.
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The Text object nodes will display.

5.  We now need to add nodes to the Text

object and then move these nodes to edit

the shape of the Text object and therefore

wrap the text around the object.

We will set up some guides and then so we

can snap the nodes we create to the guides.

6.  Add four nodes on the right side of the

Text object by double-clicking on the Text

object path.

7.  Check the ‘Snap nodes to guides’

checkbox on the Bezier tool modifier ribbon.

8.  Leave the top and bottom nodes that you

have created where they are as they will form

the side of the wrap around.

You can move these at a later date if you

wish.

Click on the second node that you created

and move it to snap to the guides that have

been created to the top left of the picture

object.

9. Click on the third node that you created

and move it to snap to the guides that have

been created to the bottom left of the

picture object.

You have now wrapped the text around the

object.
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Printing
Wright Design allows you to print to either

Postscript or non-Postscript devices.

PostScript devices are typically high resolu-

tion imagesetters that output film. Non-

PostScript devices are usually desktop color

or black and white printers. Of course,

desktop devices may also be PostScript

capable.

In Wright Design a document comprises a

page which is defined on-screen by a

rectangular border and shadow. When a

document is printed, everything contained

within this area will be printed. Objects

laying outside the page area will be ignored.

We will go through the procedure used to

print a document. The steps marked with a

(PS) refer to Postscript printing only.

To print a file:

1.  Choose File > Print. (Ctrl + Shift + P)

The Print dialog box will display.
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2.  Select the device you want to print to

from the ‘Name’ combo box.

Click on the arrow to the right of the

‘Name’ combo box and select the device

from the drop down list.

Wright Design distinguishes between

PostScript and non-PostScript devices. If the

PostScript checkbox is enabled the selected

printer can print PostScript. If the

PostScript checkbox is disabled (grayed),

then the printer is not capable of printing

PostScript. 

Certain print options are unavailable for

non-PostScript printers. These options will

be disabled when a non-PostScript printer is

selected.

3.  Click on the ‘Properties’ button to set

various attributes for the currently selected

printer.

A dialog box for the currently selected

printer will display. The settings and

options will differ depending on the printer

selected. 

Any changes you make from the

Properties dialog will only be in effect for

the document you are printing. To make

permanent changes to your printer settings

do so from the Control Panel. 

4.  Select the ‘Print to file’ checkbox if you

want to print to a file and not the selected

printer.

This file may be printed later  by selecting

File > Send to Printer.

Use this option if you are producing EPS

files to be shared with other users and

applications. To create an EPS file see the

‘Options sub-dialog’ on page 303.

Note, if you don't have the PostScript

checkbox checked you will be prompted

with a dialog box to enter a destination file-

name, The destination folder will be the

Print folder set in File > Preferences >

Folders.

5.  Enter the number of printouts you

require in the ’Number of copies’ edit box

or click on the spin controls to the right of

the edit box. This is set to one by default. 

6.  When printing a document, it is more

than likely that it will contain some picture

information. Even if you don’t have a

picture in your document, there may be

bitmap objects or a picture may need to be

generated as a result of the printing

process. 

All picture content must have a target reso-

lution. This output resolution must be spec-

ified in one of three ways:

Printer Resolution checkbox - If checked,

the selected printer's current resolution will

be the resolution at which all picture data

in the document will be ripped. Note that

the resolution is displayed in the now

disabled (grayed) resolution edit box.

Also, the Document Resolution checkbox is

disabled.

Resolution edit box (not labelled) - Enter a

custom resolution in the Resolution edit

box and select the resolution units.
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Document Resolution checkbox - If

checked, the resolution set in your docu-

ment setup is used for printing. Note that

the resolution is displayed in the now

disabled resolution edit box. Also, the

Printer resolution checkbox is disabled.

A note on resolution. You rarely need

to go beyond about 300 dpi for high quality

work (particularly if your printer doesn't go

that high!). The higher the resolution, the

bigger your print file and the longer it will

take to print. If you are after a quick, draft

quality print, select a lower resolution, like

100 dpi. You can achieve some good results

at a lower resolution if you select anti-

aliasing and interpolation.

7.  Check ‘Fit page to printer’ checkbox to

ensure that your page will exactly fit the

imageable area of your printer. 

Most printers that use a particular

page size, such as A4, cannot print over the

whole area because there is usually a non-

printable margin around the page. So, if you

had an A4 page and printed it on an A4

printer and didn't check the Fit page to

printer checkbox, your printed page would

be partially cropped around the edges.

8.  Check the ‘Interpolate Bitmaps’

checkbox to obtain the best quality for

Bitmap objects. Interpolating bitmaps elimi-

nates the stepped or blocky effect that you

might otherwise get, particularly for low

resolution bitmaps. 

Print times may be slightly longer with this

option.

9.  Check the ‘Interpolate Pictures’

checkbox to obtain the best quality for

pictures in your document. Print times may

be longer with this option.

10. Check the ‘Anti-Alias Vectors’ checkbox

to smooth out the edges of all Vector

objects. This effect will only come into play

if a Vector object needs to be ripped into a

bitmap as a result of the printing process.

For high quality work, it is recom-

mended that the three checkboxes;

Interpolate Bitmaps, Interpolate Pictures

and Anti-Alias Vectors, be checked.

11. (PS) Check the ‘Postscript’ checkbox if

you wish to print PostScript.

This option may not be available if the

selected printer is not capable of printing

PostScript. However, you can still produce a

PostScript file by first checking the ‘Print to

file’ checkbox. 

12. (PS) Check the ‘Separations’ checkbox

to print a color separated Postscript file.

This option is only available if ‘PostScript’

is checked. 

By default, all separations in your document

will be selected for printing. You can

choose to print only a sub-set of separa-

tions (see Separations button).
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13. Check the ‘Convert to Process’

checkbox if you have spot colors in your

document but you want them to print as

process colors.

Wright Design will automatically convert all

spot colors to process colors.

14. (PS) The ‘HiRes Spot Pic data’

checkbox comes into play for spot colored

pictures. 

This checkbox is only available if

‘PostScript’ is checked and ‘Separations’

and Convert to Process are not checked. In

other words, if we are PostScript printing

non-separated (i.e.,Color or EPS) files and

spot colors are not converted to process

colors. 

Because PostScript has no natural way of

describing multi-channel spot colored

pictures, Wright Design inserts two descrip-

tions of such pictures. 

One is a normal resolution version used for

separated output from other applications,

and the other version is CMYK, intended for

use for color output from other applica-

tions. 

By checking this checkbox, you are

declaring that the CMYK version will be of

normal resolution. 

If the checkbox is unchecked, then the

CMYK version will be of low resolution (72

dpi). 

If all you are interested in is a draft quality

color proof, then leave this option

unchecked (saving on file size and print

times).

15.  (PS) The ‘Options’ button is only

available if ‘PostScript’ is checked.

If you select the ‘Options’ button a dialog

box will display.

For a detailed discussion of all the options,

see Options sub-dialog on page 303.

16. (PS) The ‘Separations..’ button is only

available if the ‘PostScript’ and

‘Separations’ checkboxes are checked. 

If you select the ‘Separations..’ button a

dialog box will display.

For a detailed discussion of all the options,

see Separations sub-dialog on page 305.

17. Click OK.

Your document will now start printing. If

you are printing to a file, an additional

dialog box will pop up prompting for a file-

name.

When the final dialog is dismissed, the print

job will commence printing as a background

task. The Task Manager will display the

active print task(s).

Click on the Cancel button if you do

not want to proceed with printing. Any

changes to the dialog box settings will be

disregarded.

The ‘Settings’ area summarizes the

main dialog settings when Postscript is

checked.
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Options sub-dialog
Use this dialog to set various PostScript

options.

File format: Click on the arrow to the right

of the ‘File Format’ combo box and select

the print file format you require.

If in the main print dialog box you have

‘Separations’ checked the only possible

print file format is Separated file (*.ps). 

If Separations is unchecked there are two

possible formats: Color file(s) (*.col) and

EPS file(s) (*.eps).

The Separated format produces a single file

with the extension .ps and contains all the

separations arranged in a sequential

fashion.

The Color format produces a single color

(composite) file suitable for any color

device. The file extension is .col. It is not

meant to be shared with other users or

applications and has no preview.

The EPS format produces a single color

(composite) file with extension .eps. EPS

files may be shared with other users and

applications. They also have a low resolu-

tion TIFF preview.

Include fonts: Click on the arrow to the

right of the ‘Include fonts’ combo box and

select Yes or No.

Use this option to control whether or not

fonts will be included in the PostScript file.

If Yes is selected then all fonts used in the

document will be downloaded. This also

includes fonts used in EPS pictures. 

If any fonts cannot be found on your system

and you have the Font Warning checkbox

checked you will be warned with the

following dialog box:

You may then choose to continue with the

print job by selecting Yes or cancel by

selecting No.

Data: Click on the arrow to the right of the

‘Data’ combo box and select Binary, ASCII

or RLE.

This refers to the way in which image data

is encoded. The most common format is

Binary.

However, some printers may not be able to

handle binary data very well therefore you

should try ASCII. Only use ASCII if you

must, as the image data encoded in this way

is twice the size of Binary. The RLE (run

length encoding) format may be more

compact than Binary, particularly for sepa-

rated output. Use it if smaller file sizes are

important to you.
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Scale X% and Y%: By default, the value set

in both edit boxes is 100%, or same size. 

To change the size of your printed page in

relation to your document type in a

percentage value in the X% and Y% edit

boxes.

Keying 50 will halve the page size, and 200

will double it. If you have different values

for X% and Y%, the printed page will be

distorted.

Page bleed: To set the page bleed type in a

number in the edit box.

Page bleed is an extra margin around the

page area. The extra area is marked by page

trim marks sitting just outside the bleed

area. Bleed is usually specified for film

output and is set to 3 to 5 mm.

Right mouse-clicking on the Page

bleed edit box will give you the following

measurement options: Application Default,

mm, cm, Inches, Points and Pixels. 

PostScript Level 1: Check the ‘Postscript

Level 1’ checkbox to generate PostScript

Level 1 instructions, otherwise PostScript

Level 2 instructions will be used. 

Most PostScript devices these days are Level

2 compliant, however, if you're printing to

an older generation device it may be

Postscript Level 1.

Cache EPSes: Check the ‘Cache EPSes’

checkbox to reduce the size of your print

file if it contains one or more EPS files.

When most applications print a page

containing EPS files they include a copy of

the entire EPS with each separation. If the

EPS file is large, say 10 Mb, then for the four

process separations you would get a print

file which is 40 Mb in size. The file size

balloons out further if you've got several

such EPSes in your page and/or you're

printing more than four separations.

Wright Design can drastically reduce print

file sizes by including just one copy of each

unique EPS and simply referring to it in

each separation. In the above example, the

size of the four color separated file would

only be 10 Mb, one quarter the size. This

technique is known as EPS caching and will

take place when you check this checkbox.

If this option is not checked, then Wright

Design will include a copy of each EPS in

each separation.

EPS caching may not work with some

printers, possibly due to their internal disk

space restrictions. If you find this to be the

case do not use this option.

Font warning: Check the ‘Font warning’

checkbox if you wish to be notified of

missing fonts. 

A font will be missing if you have chosen to

include fonts in your print job but you do

not have the font(s) installed on your

system.

Rotate 90 deg: Check the ‘Rotate 90 deg’

checkbox’ to rotate your printed page 90

degrees from its normal orientation.
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Rego marks: Check the ‘Rego marks’

checkbox to allow printer's marks to appear

on your output. These include trim marks,

bleed marks, registration marks, color bar,

filename and the date.

Separations sub-dialog
Use this dialog to set various PostScript

options relating to separated output.

Right Reading/Wrong Reading: Select the

Right reading or Wrong reading radio

button. 

This determines the page orientation rela-

tive to film emulsion. Wrong reading will

produce a 'mirrored' or 'back-to-front'

image, while Right reading will not mirror

the output.

Positive/Negative: Select the Positive or

Negative radio button. 

Positive output means 0% dots will not

mark the print media, while a 100% dot will

appear as black. Negative is the reverse, a

0% dot will appear black, while a 100% will

not mark the print media.

If for example you have selected

Positive output but your job prints as

Negative, its probably because the printer's

Properties are set to Negative. 

You should either change the printer's

properties to Positive or select Negative in

this dialog to cancel out the printer's

Negative setting.

Seps across: Key in the number of separa-

tions you want to step across the printed

page or film area.

This option can save you a lot of film or

paper by positioning the specified number

of separations across the printed page or

film area. You must know the width of your

output media and the size of the page being

printed so that you can calculate how many

separations will fit across.

Page gap: Key in a number in the ‘Page

gap’ edit box to specify the gap between

your separations if you are printing more

than one separation across.

Right mouse-clicking on the Page

bleed edit box will give you the following

measurement options: Application Default,

mm, cm, Inches, Points and Pixels. 

Spot function: Click on the arrow to the

right of the ‘Spot function’ combo box and

select the dot shape you require.

The spot function is what the PostScript

interpreter uses to create a halftone dot.

There are many ways in which this may be

done, each with pros and cons. 
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Wright Design offers six choices: Default,

Euclidean, Square, Circle, Ellipse and Line.

The Default option does not set a spot func-

tion. It uses whatever is set inside the

PostScript interpreter at the time. Do not

use this option unless you are confident in

what you are doing.

Some PostScript devices don't allow

you to set a custom spot function. They use

their own internal spot functions, optimized

for their particular usage. If this is the case

the specified spot function will simply be

ignored.

Print listbox: This listbox contains the

names of all separations found in your page.

Additional information included is the

screen frequency and angle for each separa-

tion. 

By default, all separations are marked for

printing. 

If you wish to print just a single separation,

simply click on that separation, it will

remain checked while all others become

unchecked. 

If you wish to add another separation for

printing hold down the Ctrl key down and

click on that separation.

To prevent a single separation from printing

hold down the Ctrl key down and click on

that separation.

You can also hold the Shift key down and

click to select or de-select a range of separa-

tions.

You can change both the frequency and the

angle of any separation. 

You can have only one separation selected

so that the Load and Apply buttons become

enabled. 

Hit the Load button and the selected sepa-

rations frequency and angle will be loaded

into the Freq & Angle edit boxes. 

Key in a number in the edit boxes. Hit the

Apply button to update the selected separa-

tion in the listbox. You may apply the same

values to other separations.

To save a Print setting file:

1.  Make sure the Print dialog box is open.

2.  Select the ‘Save’ button.

The ‘Save Print Settings As’ dialog box will

open. The original default folder path will

be the the Wright Design ‘Program’ folder.

The default folder path from then on is the

path that you used when you last opened or

saved a print setting file.

3.  If the default folder path is not the path

you require click on the arrow to the right

of the “Save in” combo box and select a new

folder path.
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4.  The icons across the top of the dialog

box are general Windows functions.

5.  Enter a name in the File name edit box.

6.  The type of file you will be saving is a

PrintSetting file (.wpr).

7.  Click Save. Your print setting file will

now be saved with the file name you speci-

fied to the folder you specified.

To load a Print setting file:

1.  Make sure the Print dialog box is open.

2.  Select the ‘Load’ button.

The ‘Load Print Settings’ dialog box will

open. The original default folder path will

be the the Wright Design ‘Program’ folder.

The default folder path from then on is the

path that you used when you last loaded or

saved a print setting file.

3.  If the default folder path is not the path

you require click on the arrow to the right

of the “Look in” combo box and select a new

folder path.

4.  The icons across the top of the dialog

box are general Windows functions.

5.  Select the file you wish to load and the

filename will display in the File name edit

box.

6.  The type of file you will be loading is a

PrintSetting file (.wpr).

7.  Click Open. Your previously saved print

setting file will now be loaded into the Print

dialog box.

Sending files to a printer
Wright Design allows you to send printer

files that you have previously created to a

printer.

To send a printer file:

1.  Choose File > Send to printer.

2.  The ‘Send to printer’ dialog box will

open. The original default folder path will

be the Wright Design ‘Program’ folder.

The default folder path from then on is the

path that you used when you last sent a file

to a printer.

3.  If the default folder path is not the path

you require click on the arrow to the right

of the “Look in” combo box and select a new

folder path.
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4.  The icons across the top of the dialog

box are general Windows functions.

5.  You can select to view All files (*.*),

Separation files (*.ps?), Color files (*.col) or

EPS files (*.eps). 

6.  Select the file that you wish to print and

the filename will display in the File name

edit box.

The size of the file you have selected to

print will display at the bottom right of the

dialog box.

7.  Click on the arrow to the right of the

‘To device’ combo box and select the

device you wish to print to. 

8.  Click Open. 

The ‘Send to Printer’ dialog box will close

and the Task Manager will display the

progress of the file.

Inline Proof
The inline proof command is used to obtain

a color proof from ripped separations. This

form of proofing is the most accurate

because the proof is generated from final

separations that will be used in the printing

process.

Most other proofs are generated from the

document, which is a different process

compared to the one used in making sepa-

rations.

In order to use this type of proofing, you

must have access to a rip which can

produce separated and screened image files

that will be used by an imagesetter to

expose film. The file data must be of type

Bitmap (one bit per pixel) and in a format

recognized by Wright Design.

To create an inline proof:

1.  Choose File > Inline Proof.

The Inline Proof Setup dialog box will

display.

2.  The Proof Filename edit box by default,

displays the name of your current docu-

ment. 

Enter a filename for the proof file you are

going to generate.

The proof file will be placed in your current

File > Preferences > Folders > Picture

folder which is displayed to the right of the

Target Res edit box.

3.  The Target res edit box specifies the

resolution of the generated proof file. 
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The default resolution is 12ppmm (or 304.8

dpi). You may change this to whatever you

like by keying in a value in the Target Res

edit box, though higher resolutions than

the default will not necessarily generate

better results.

Right mouse-clicking on the Target

Res edit box will give you the following

measurement options: Pixels/mm, Pixels/cm

and dpi.

4.  In total there are twelve separations that

you can compose into the color proof file.

Four are reserved for the process colors

cyan, magenta, yellow and black and you

can assign up to eight special or spot colors

to the other separations.

Each line consists of a checkbox which

determines whether the separation will be

used or ignored, a colored square repre-

senting the color of the separation and the

separation location and name. 

5.  Select the Browse button to the very

right of the Cyan separation.

The File Open dialog box will display.

6.  Find and select the ripped cyan separa-

tion and click on the Open button.
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The folder path you have selected will

display to the right of the Cyan button.  

Once you have located the first separation

the folder will be remembered so that the

next time you browse for a different separa-

tion you will be in the correct folder.

7.  Follow steps 5 and 6 for the Magenta,

Yellow and Black separations.

8.  If you have any spot color separations

you need to identify which spot color will

be used. 

To do this you click on the checkbox to the

left of the first Spot button and then select

the ‘Spot’ button.

The Select PANTONE® Color dialog box

will open.

9.  Select the PANTONE® color you require

and click OK.

For more information on selecting spot/

PANTONE® colors see page 144.

The spot color name will now appear on the

button and its color will be displayed in the

color square.

10. Select the Browse button to the very

right of the Spot separation.

The File Open dialog box will display.

11.  Find and select the ripped spot separa-

tion and click on the Open button.
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12. ‘Smooth sub-sampling’ - Typically, the

separation files you have selected will  be

large both in pixel width and height and in

resolution. To make a colorproof file at the

much lower resolution (set in the Target

Res edit box), the separation files must be

sampled down. This may be achieved in one

of two ways, either throw away information

between the samples or use it to achieve a

much more accurate and smoother looking

result.

Checking the ‘Smooth sub-sampling’

checkbox will use a more accurate method

of sampling with the tradeoff of taking more

time to complete.

If unchecked, a less accurate method will be

used but will take less time to complete. 

We recommend that you use the more accu-

rate method.

13. If you wish to proof other files hit the

Apply button. This will set the proofing task

off as a background process and the dialog

will remain allowing you to setup the next

job.

14. If you only need to do the one proof for

now hit the OK button. 

This will start your inline proof as a back-

ground task and the dialog box will close.

15. When the proof file has finished gener-

ating (Task Manager no longer displays the

task) you may open the picture and print it

on your color proofer.

The picture you have created using Inline

Proof will display with a screened pattern.

Archiving
Wright Design provides an archiving control

that copies the document and any neces-

sary picture and EPS files to the drive and

directory you specify.

You can archive to any drive your computer

can see whether it be a network drive,

external drive, to a drive on a server or your

own computer.

You firstly create an archive folder. There is

no limit to the amount of archive folders

you create. You can then save to the archive

folder(s) or load from the archive folder(s).

To create an archive folder:

1.  Choose File > Archive.

2.  The Archive dialog box will open. The

original default folder path will be your

desktop.

The default folder path from then on is the

path that you last used to create an archive

folder or to save or load an archived docu-

ment.

3.  If the default folder path is not the path

you require to archive to, click on the arrow

to the right of the “Look in” combo box and

select a new folder path.

4.  The icons across the top of the dialog

box are general Windows functions.

5.  Now you create an archive folder to

contain the documents that you wish to

archive.

To create the folder click on the Create

button.
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The ‘Create Archive’ dialog box will open. 

6.  Type in a name for your archive folder in

the ‘Name’ edit box and click OK.

7.  The new archive folder icon and

folder name will now display in the archive

window.

There is no limit to the amount of archive

folders that you create. It just depends on

how you want to structure your archiving. 

To save a document to an archive folder:

1.  Choose File > Archive.

2.  The Archive dialog box will open.

The default folder path is the path that you

last used to create an archive folder or to

save or load an archived document.

3.  Double-click on the archive folder that

you wish to use.

The selected archive folder will now display

in the ‘Look in’ combo box and the ‘Save

to’ button on the right of the ‘Archive’

dialog box will become active.
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4.  Click the ‘Save to’ button. 

The ‘Open’ dialog box will display. The

default folder path will be the folder you

have set up for your Documents in

Preferences 

(File > Preferences > Folders >

Documents).

5. Select the document you wish to archive

and click the Open button.

The Copying dialog box will display

showing the files being copied. 

The Copying dialog box will close when the

files have finished copying and the new

archived files will show in the ‘Archive’

dialog box window. 

A warning dialog will display if you try

to Archive a document that is open in

Wright Design.

6.  To view ‘Pictures’ and ‘EPS files’ check

the ‘Show Pictures’ checkbox.

To view ‘Documents’ only uncheck the

‘Show Pictures’ checkbox. 

The Details pane at the bottom right of the

‘Archive’ dialog box shows the details of

the file you have selected.

The files with black filenames are

‘Documents’, the files with blue filenames

are ‘Pictures’ and the files with red file-

names are ‘EPS files’.

To load a document back from an archive
folder:

1.  Choose File > Archive.

2.  The Archive dialog box will open.

The default folder path is the path that you

last used to create an archive folder or to

save or load an archived document.

3.  Double-click on the archive folder that

you wish load an archive from.

The selected archive folder will now display

in the ‘Look in’ combo box and the ‘Load

from’ button on the right of the ‘Archive’

dialog box will become active.

4.  Select the ‘Document’, ‘Picture’ and/or

the ‘EPS file’ you wish to load.

If you load the ‘Document’ the ‘Pictures’

and ‘EPS files’ that are linked to the docu-

ment are also loaded.

5.  From the Destination Folders pane at

the bottom left of the ‘Archive’ dialog box

select the folder where your ‘Document(s)’

and ‘Picture(s)’ will be loaded.

If you are loading a ‘Picture’ or ‘EPS file’

the ‘Document’ button will be grayed out.

Click on the ‘Load from’ button. 

6. The Copying dialog box will display

showing the files being copied. 

The Copying dialog box will close when the

files have finished copying.

‘EPS files’ are loaded into the

selected ‘Picture’ folder.
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Save As Picture
Use this command when you wish to

convert your page into a picture such as

TIFF or JPEG so that it may be used by

other applications that recognize these

formats. 

Saving as a picture involves ripping the

page into a bitmap format. 

This operation may take some time

depending on the complexity of your page

and the rip resolution, but as with all time

intensive operations in Wright Design it is

processed as a background task so you do

not have to wait for it to complete before

doing something else.

To save as a Picture:

1.  Choose File > Save As Picture. 

(Ctrl + Alt + S)

The Save As Picture dialog box will open.

The original default folder path, will be the

path that is set for Pictures in your Folder

preferences. 

(File > Preferences > Folders > Pictures) 

The default folder path from then on is the

path that you used when you last opened or

saved a picture.

2.  If the default folder path is not the path

you require, click on the arrow to the right

of the “Save in” combo box and select a new

folder path.

3.  The icons across the top of the dialog

box are general Windows functions.

4.  Enter a filename for the picture you are

saving in the ‘Filename’ edit box or high-

light a file if you wish to that you wish to

replace. 

5.  To select the file format you require for

your picture click on the arrow to the right

of the ‘Save as Type’ combo box and select

a file format.

The export file formats supported by Wright

Design are:

DCM (.dcm;.spl)

TIFF (.tif)

JPEG (.jpg)

EPS (.eps)

PNG (.png)
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BMP (.bmp)

Targa (.tga, .vda, .vst,.icb)

Scitex CT (.sct)

Photoshop (.psd) 

Compuserve GIF (.gif)

PICT (.pct, .pic)

The DCM (Digital Color Matrix) file format

is Wright Design's native file format. 

Most of the other picture formats are in

popular general use. The format you decide

on will depend on whom you wish to share

the picture.

6.  Select the color space you require by

clicking on the arrow to the right of the

‘Color Space’ combo box and selecting the

color space from the list displayed.

The selected color space will load into the

‘Color Space’ combo box.

Wright Design supports the following color

spaces though not necessarily for each

picture format: HIFI

CMYK

RGB

Palette

Grayscale

BiLevel

CMYK Alpha

RGB Alpha

Palette Alpha

Grayscale Alpha

All picture formats have at least one color

space. A color space is a means of defining

how color data (or pixels) are to be inter-

preted. 

For example, two common color spaces are

CMYK and RGB. RGB has three color chan-

nels, Red, Green and Blue, while CMYK has

four, Cyan, Magenta, Yellow and Black.

HIFI:  This color space is only supported by

Wright Design's native picture format DCM.

A HIFI DCM picture may have process

colors mixed with any number spot colors

or it may have only spot colors and no

process component. 

This is what you will get if you select HIFI

and your page contains objects with spot

colors. If you want the spot colors to be

converted to process colors select CMYK as

the color space.

CMYK:  Color space is used mainly for print

applications where each color represents a

colored ink used in the printing process.

These are Cyan, Magenta, Yellow and Black.

RGB:  This color space is usually used for

non-print applications such as transparency

generation, web and screen use, slide

shows and CAD/CAM applications. It is the

same color space used by your computer

monitor and consists of Red, Green and

Blue components.

Palette:  The palette color space is a limited

form of, usually, RGB data. The palette is

usually a  table of 256 RGB entries or

indexes. Instead of describing each pixel as

RGB (24 bits) an (8 bit) index is used into

the table which contains the RGB data. This
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scheme makes the picture size much

smaller but you are limited to 256 different

colors. Some form of dithering is usually

used to improve the quality of the picture.

These color spaces are typically used for

picture previews for such formats as EPS

documents or for web use.

Grayscale: A grayscale picture has no color

information. It consists only of shades of

gray. Use this color model to create black &

white pictures from color pictures.

BiLevel: A BiLevel picture contains no color

information and it has no shades of gray. A

pixel is either black or white. 

BiLevel files are usually created by Rips

used in imagesetters as a means of exposing

film. These types of pictures can also be

used for line art applications.

Alpha: The Alpha color spaces are the same

as the non-Alpha color spaces described

above except that they contain additional

(Alpha) channels of information. 

Exactly how these extra channels of infor-

mation are interpreted is up to individual

applications. The channels may be masks,

or extra spot separations.

7.  To add bleed to your page as it is being

saved to a picture, key in a number in the

‘Bleed’ edit box.

Right mouse-clicking on the Bleed

edit box will give you the following

measurement options: Application Default,

mm, cm, Inches, Points and Pixels. 

Bleed is another word for an extra uniform

margin around the page. So if you are

saving as a picture an A4 (210 x 297 mm)

page with a 5 mm bleed, the picture size

will be 220 x 307 mm. 

Bleed may also be a negative amount.

8.  Select the resolution units of measure-

ment by clicking on the arrow to the right

of the ‘Units’ combo box and selecting one

of the following: Pixels/mm, Pixels/cm, and

dpi (dots per inch).

9.  To set the horizontal and vertical resolu-

tion of your picture key in a value in the

‘Horiz Res’ edit box. 

When you type something into the ‘Horiz

Res’ edit box the same value will appear in

the ‘Vert Res’ edit box. 

This is because most applications expect

the picture size to be square (horizontal

resolution equal to vertical resolution). 

On the rare occasion that you want non-

square resolutions, simply type a different

value in the ‘Vert Res’ edit box. 

These two editboxes define the resolution

that the page will be ripped at.

OR

Check the ‘Document Resolution’

checkbox to automatically set the resolu-

tion to be whatever your document resolu-

tion is. 

The document resolution is set when you

create a new document or when you change

it using the Document Setup command. 
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If you created your document by using the

Open Picture command the document's

resolution will automatically be set to the

picture's resolution.

10. To select a Preview file click on the

arrow to the right of the ‘Preview’ combo

box and select the type of Preview file you

require.

The preview editbox provides an option to

generate a preview or thumbnail of the

picture so that it may be easily viewed by

other applications. 

Not all picture formats support previews

and so this option may not be available.

Formats like DCM for example, always have

a preview and so the option is not available.

11. Check the ‘Interpolate Bitmaps’

checkbox to obtain the best quality for

Bitmap objects.

Interpolating bitmaps eliminates the

stepped or blocky effect that you might

otherwise get, particularly for low resolu-

tion bitmaps. 

12. Check the ‘Interpolate Pictures’

checkbox to obtain the best quality for

pictures in your document. 

13. Check the ‘Anti-Alias Vectors’ checkbox

to smooth out the edges of all Vector

objects. You can observe the effect in your

document by choosing View > Anti-alias

vectors.

We strongly recommend that you use this

option.

For high quality work, it is recom-

mended that the three checkboxes;

Interpolate Bitmaps, Interpolate Pictures

and Anti-Alias Vectors, be checked.

14. Click the Save button. 

Wright Design will start a background task

which you will see in the Task Manager.

While the Save as Picture task is in progress

you cannot make any changes to the page.

If you try to do so, the following message

box will appear:

You may, however, work on a different page

whilst the task is in progress.

When the task is complete (no longer

visible in Task Manager) you may continue

working on the original page.

Saving as a JPEG file

If you have selected the JPEG picture

format an additional combo box will appear

next to the ‘Color space’ combo labelled

‘Quality’. 

Because JPEG uses compression you need

to be able to specify the amount of

compression you require. 

Compression is related to picture quality.

The higher the compression the smaller the

picture file and the lower the quality. The

lower the compression the bigger the

picture file and the higher the quality. 
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1.  To select the level of quality you require

for the compression of your JPEG, click on

the arrow to the right of the ‘Quality’

combo box and select from the list.

There is a choice of five quality levels: high,

medium high, medium, medium low and

low.

Saving as a PNG file

When you click the Save button and you

have selected the PNG picture format an

additional dialog box will appear.

INTERLACING:  Interlacing is used to

provide a quicker view of the picture as it is

being transmitted over a network (such as

the World Wide Web).

PNG's two-dimensional interlacing scheme

yields an initial image eight times faster

than GIF and it also looks better because

the horizontal and vertical resolution never

differ by more than a factor of two. This

avoids the odd "stretched" look seen when

interlaced GIFs are filled in by replicating

scanlines.

Currently, the only interlacing scheme avail-

able is Adam7.

FILTERS:  PNG filters are used to prepare

the picture data for optimum compression.

Different types of picture content will

respond better or worse to a particular

filter. Feel free to experiment.

Filter Sub: The Sub filter transmits the

difference between each byte and the value

of the corresponding byte of the previous

pixel.

Filter Up: The Up filter is just like the Sub

filter except that the pixel immediately

above the current pixel, rather than just to

its left is used as the predictor.

Filter Average: The Average filter uses the

average of the two neighbouring pixels (left

and above) to predict the value of a pixel.

Filter Paeth: The Paeth filter computes a

linear function of the three neighbouring

pixels (left, above and upper left) then

chooses as predictor the neighbouring pixel

closest to the computed value. This tech-

nique is due to Alan W. Paeth.
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To convert selected object(s)
to a Picture
This command is very similar to the Save As

Picture command. The difference is that

instead of ripping the whole page into a

picture, only the bounding box area of the

selected object(s) is converted to a picture. 

The new picture will contain all objects in

the page that overlap the selected objects'

combined bounding box area. 

To convert selected object(s) to a  Picture:

1.  Select the object(s) that you wish to

convert to a picture.

You must have at least one object selected

to use this command.

2.  Choose Object > To Picture > New

Picture.

The New Picture dialog box will open.

This dialog box is the same as the ‘Save As

Picture’ dialog box.

3.  Select the settings you require in the

‘New Picture’ dialog box and click on the

Save button.

To find out more information on saving

your file as a picture see earlier in this

chapter, ‘Save As Picture’ on page 314.

You may frame a rectangular area of

your  page that you wish to convert to a

picture by drawing a vector rectangle with

no fill and no stroke layers. The rectangle

will be invisible, but its bounds will define

the new picture area.

Exporting a picture as an EPS
with a clipping path
This command is used for exporting clip-

ping paths to other applications. The

picture format is EPS and can contain one

or more clipping paths. 

These clipping paths correspond to a

Wright Design Vector object outline.

Therefore it only works when a single

Vector object is selected. 

In all other respects it works like the New

Picture command.
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To export a picture as an EPS with a clip-
ping path:  

1.  Select the Vector object that you wish to

export with a clipping path.

You can only have one object selected.

2.  Choose Object > To Picture > EPS

Clippath.

The ‘EPS Clipping Path’ dialog box will

open.

This dialog box is the same as the ‘Save As

Picture’ dialog box.

3.  Select the settings you require in the

‘EPS Clipping Path’ dialog box and click on

the Save button.

To find out more information on saving

your file as a picture see earlier in this

chapter, ‘Save As Picture’ on page 314.

For example, you can use this command if

you have done a close cut-out from a placed

picture using the vector Curved Polygon

Tool. After the command is complete, you

will be able to place the resulting EPS file

into another application so that only the

cut-out shows without the background.

Exporting a picture with a
TIFF Alpha Channel
This command is used for exporting bitmap

masks to other applications. The picture

format is TIFF containing an Alpha channel. 

The Alpha channel corresponds to a Wright

Design Bitmap object. Therefore, this

command only works when a single Bitmap

object is selected. In all other respects it

works like the New Picture command.

Use this command to export Bitmap objects

with feathered edges, or brush strokes.

Note also, that if the Bitmap object contains

spot colors, then the extra spot color chan-

nels will also be written to the TIFF as extra

Alpha channels.

To export a picture with a TIFF Alpha
channel:

1.  Select the Bitmap object that you wish

to export with a TIFF Alpha channel.

You can only have one object selected.

2.  Choose Object > To Picture > Tiff Alpha

Channel.

The ‘Tiff Alpha Channel’ dialog box will

open.

This dialog box is the same as the ‘Save As

Picture’ dialog box.
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3.  Select the settings you require in the

‘Tiff Alpha Channel’ dialog box and click on

the Save button.

To find out more information on saving

your file as a picture see earlier in this

chapter, ‘Save As Picture’ on page 314.

This TIFF file can now be taken into

another application and the Alpha channel

used as a mask.
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A
Add adjustment operator   150, 151-152

Add modifier tool   92, 260-261,267,268-269

Additive   73

Adjustment Operators

Add   150, 151-152

And   150, 152

Decrease   150, 151-152

Divide   150, 151-152

Increase   150, 151-152

Invert   150, 151-152

InvSub   150, 152

Maximum   150, 151-152

Minimum   150, 151-152

Multiply   150, 151-152

None 150, 152

Normal   150, 152

Or   150, 152

SubInv   150, 152

Subtract   150, 151-152

To apply   150

Xor 150, 152

Align text vertically   285-286

Align tool 21, 215, 218-219

Aligning objects   215-218

Alpha channel   76, 195-200, 320-321

Alpha color space   315-316

And adjustment operator   150, 152

Anti-alias vectors   30, 301

Archiving

Creating a folder   311-312

Saving   312-313

Loading   313

ASCII   277, 303

Automatically link text boxes   293

B
Bezier tool

About   21, 234-235

Breaking a path   243-244

Control points   234-246

Joining a path   244

Nodes   235-246

Reversing a path   245-246

Splitting a path   244-245

BiLevel   315-316

Bitmap objects   91, 103-113

Bitmap Polygon tool   22, 111-112

Bitmap tool flyout   21-22

BMP

Converting   76-79

Importing   50-54

Opening   54-56

Placing   59-61

Save as   314-317

Border   287

Breaking a path   243

Brightness/Contrast paint style

About   189

Opacity slider   189-190

To apply   190

Brush Gallery palette   23, 261

Brush styles   257-258
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Brush tool

About   21, 257

Angle 259

Brush size   258

Creating a brush   257-260

Cursor shape   258

Fade   260

Hardness controls   258

Opacity   259

Painting   260-261

Resolution   260

Spacing   259

Texture   260

C
Cache EPS’s   304

Calibration   37-38, 82

Changing object priority   122-123

Character Attributes

About   114-115, 278

Character width   280

Font Size   279

Font Style   279-280

Font type   279

Kerning   281

Leading   280

Shift   281

To apply   278

Tracking   280-281

Character width   280

Clipping path   97, 319-320

Clone tool   21, 265-269

Cloning

Flat-plane cloning   265-267

Object-based cloning   265, 267-269

Closing a document   69

CMYK   74, 315

CMYK Alpha   315

Color Channels   79-80

Color Curve paint style

Colorize   193-194

About   153

Color curving   154-157

Color model   153-154

Examples   158-159

Opacity slider   154

Color Mask paint style

About   178

Creating   178-184

Color Mask tool   21, 179

Color Models

3 Channel Gray 75

About   73

CMYK   74

Grayscale   75

HIFI   76

HSB   74-75

PANTONE®   75

RGB   73-74

Color sliders   142-143

Color space   315

Color values (measuring)   80

Columns   286

Combining objects   215

Compuserve GIF

Converting   76-79

Importing   50-54

Opening   54-56

Placing   59-61

Save as   314-317

Context menus   17
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Control points   234-246

Convert to process   302

Converting objects

From a Vector object   125-126

From a Text container   126-127

From text   127-128

Converting pictures   76-79

Copying and moving layers   123-124

Correcting a mistake   223

Crop tool modifier   93

Cropping 93, 253

Curved Polygon bitmap tool   22, 107-108

Curved Polygon vector tool   21, 97-98

Cusp node style   240

Cutout   97, 107

D
DCM

Converting   76-79

Importing   50-54

Opening   54-56

Placing   59-61

Save as   314-317

Decrease adjustment operator   150, 151-152

Document

About   14

Archiving   311-313

Changing   58-59

Closing   69

Creating   56-58

Opening   66-68

Printing   299-307

Relink missing elements   67-68

Saving   64-65

Document resolution   301

Deleting objects   120-121, 207

Displaying the Object List   115

Divide adjustment operator   150, 151-152

Drop caps   285

Duplicating objects 207-208

E
Edge filters   166, 169

Edit   18, 40

Editing Bitmap objects   250-253

Editing Picture objects   253-254

Editing text   276-277

Editing Vector objects   234-250

Ellipse bitmap tool   22, 106-107

Ellipse vector tool   21, 97

Emboss filter   166, 170

Enhancing the display   117

EPS file

Placing   129-131

EPS picture

Clipping path   319-320

Converting   76-79

Importing   50-54

Opening   54-56

Placing   59-61

Save as   314-317

Exporting pictures   314-321

Exporting text   278

Eyedropper tool   21, 145, 146

F
Feathering objects   219-221

File   18, 40

File formats (export)   314-315
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Filter paint style

About   163

Adjustment operators   168

Color model   163-165

Opacity slider   165

Selecting a filter   165-166

Selecting colors   165

Types of filters   166-168, 169-170

Filters - plug-ins   44, 201

Fit page to printer   301

Fit text to curve   287-292

Flat-plane cloning   265

Font previews   39

Font Size 279

Font Style   279-280

Font type 279

Font warning   304

Freehand/Line bitmap tool   22, 112-113

Freehand/Line vector tool   21, 102-103

G
Gamma   35, 82

Gap   287

General preferences   33

Grab tool 21

Gradient paint style

About   171

Adjustment operators   173

Color model   171

Creating a gradient   174-178

Gradient styles   172

Opacity slider   173

Selecting colors   173

Gradient styles   172

Gradient tool   21, 177

Gray (3 Channel)   75

Grayscale   75, 315-316

Grayscale Alpha   315

Greeking   39

Grouped Objects Together   119

Grouping objects

To group   208-209

Working with   209-211

Growing objects   250-251

Guides

Angling   87

Copying   88

Creating   86-87

Deleting   88-89

From the menu   19

Hiding   89

Keyboard shortcuts   40

Locking   89

Moving   88

Setting colors   34

Setting margin colors   34

Setting selection distance   35

Setting snap distance   35

Snap to guides   89

Snapping nodes to   235

To load   90

To save   90

H
Help   19

Hiding objects   121-122, 208

HIFI   76, 315 

HiRes Spot Pic data   302

Horizontal Mirror   230

HSB   74-75
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Hue   74

Hue/Saturation paint style

About   190

Opacity slider   190-191

To apply   191-195

I
Importing pictures   50-54

Importing text   277

Include fonts   303

Increase adjustment operator   150, 151-152

Indent first line   283

Inline proof   308-311

Inserting text   276-277

Interpolate bitmaps   30, 301

Interpolate pictures   301

Invert adjustment operator   150, 151-152

Inverting objects   250

InvSub adjustment operator   150, 152

J
Joining a path   244

Joining objects/layers   218-219

JPEG

Converting   76-79

Importing   50-54

Opening   54-56

Placing   59-61

Save as   314-318

K
Keep together   284

Kerning   281

Keyboard Shortcuts   40

Kodak Photo CD   50, 53-54, 60, 76

L
Layout tools   85

Leading   280

Left indent   283

Line styles   248

Linking Attributes

About   114-115, 292

Automatically   293

Manually   292-293

Loading

Brush gallery   263-264

Color swatch palette   147-148

Guides   90-91

Paint Style   139-140

Pen style   249-250

Print setting   307

Retrieving from archive   313

Locking objects   212

M
Manually link text boxes   292

Margin colors   34

Maximum adjustment operator   150, 151-152

Menu  18

Minimum adjustment operator   150, 151-152

Mirror

Horizontally   230

Vertically   229-230

Monitor calibration (Gamma)   35

Monitor resolution   48

Motion blur filter   167, 170
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Moving objects   207

Multicolored sliders   143

Multiple channels   76

Multiple redo   223

Multiple undo   223

Multiply adjustment operator   150, 151-152

N
Navigator palette   24, 29

Negative  305

New modifier tool   92, 260-261,267,268

Nodes   235-246

Noise filter   167, 170

None adjustment operator   150, 152

Normal adjustment operator   150, 152

O
Object-based cloning   265

Object List

About   115

Changing object priority   122-123

Copying and moving layers   123-124

Deleting objects   120-121

Displaying   115

Expanding and Collapsing   118

Grouped Objects together   119-120

Hiding objects   121-122

Object List palette   24

Renaming objects   121

Selecting objects   116-117

Object List palette   24

Objects

Adding to   92

Aligning objects   215-218

Bitmap objects   91, 103-113

Combining objects   215

Converting   124-128

Creating a new 92

Cropping   94

Deleting    120-121, 207

Duplicating    207-208

Feathering objects   219-221

From the menu   19

Grouping   208-209

Growing    250-251

Hiding   121-122, 208

Inverting    250

Locking    212

Moving    207

Outlining    252-253

Picture objects 91, 113-114

Prioritizing    212-214

Selecting   116-117, 205-206

Shadowing   221-222

Shrinking   251-252

Subtracting from   93

Text objects   91, 114-115, 273

Transforming   223-231

Vector objects   91, 94-102

Opening a document   66-68

Opening pictures   51, 54-56

Options sub-dialog

Cache EPS’s   304

Data   303

File format   303

Font warning   304

Include fonts   303

Page bleed   304

Postscript level 1   304

Rotate 90°   304
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Scale   304

Or adjustment operator   150, 152

Outlining objects   252-253

Output Resolution   48

Overprinting   200

Overwriting text   276-277

P
Page   14, 56

Page bleed   304

Page gap   305

Paint Styles

Brightness/Contrast   189-190

Color Curve   153-159

Color Mask   178-184

Filter   163-170

Gradient   171-178

Hue/Saturation 190-195

Picture   160-163

Selective Color Correction   185-189

Tint    141-148

Tint Adjust   148-152

To apply   136-141

To load   139-140

To save   139

Paint Style palette   23, 135-136

Painting   260-261

Palette (color space)   315-316

Palette Alpha   315

Palettes

Changing palette display   25

Showing and hiding palettes   23

Types of palettes   23-24

PANTONE® colors   75, 144-145,198-200

Paragraph alignments   282-283

Paragraph Attributes

About   114-115, 282

Drop caps   285

Indent first line 283

Keep together   284

Left indent   283

Paragraph alignments   282-283

Right Indent   283-284

Space above paragraph   284

Space below paragraph 284

To apply   282

With next   284

Pasteboard   14, 56

Pen Style palette   23, 246-250

Perspective transform   229

Photoshop

Converting   76-79

Importing   50-54

Opening   54-56

Placing   59-61

Save as   314-317

Photoshop plug-in filters

Installing   44

Using 201

PICT

Converting   76-79

Importing   50-54

Opening   54-56

Placing   59-61

Save as   314-317

Pictures

Converting   76-79

Importing   50-54

Opening   51, 54-56

Placing   51, 59-61

Picture objects
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About   91, 113-114

Cropping   253

Picture paint style

About   160

Color model   160

Opacity slider   161

Selecting a picture   161-163

Adjustment Operators   163

Picture Resolution   47

Pixel Dimensions   47

Place pictures as CMYK   34

Placing a picture   51, 59-61

Placing an EPS file   129-131

PNG

Converting   76-79

Importing   50-54

Opening   54-56

Placing   59-61

Save as   314-318

Positive   305

Postscript   299-306

Postscript level 1   304

Preferences

Calibration   37-38

Controlling Tooltips   34

Folders   32

Guides   34

Measurement Units   33

Monitor Calibration (Gamma)   35

Screen dimensions   33

Text   38

Printer resolution   300

Printing

About   299

Anti-alias vectors   301

Convert to process   302

Document resolution   301

Fit page to printer   301

HiRes Spot Pic data   302

Interpolate bitmaps   301

Interpolate pictures   301

Loading a print setting   307

Options   302

Options sub-dialog   300, 303-305

Postscript   299-307

Print to file   300

Printer resolution   300

Properties   300

Saving a print setting   306-307

Separations   301, 302

Separations sub-dialog   305-306

To print a file   299-307

Print to file   300

Prioritizing objects   212-214

Proof   308

R
Rainbow picker   143-144

Rectangle bitmap tool   22, 104-105

Rectangle Vector tool   21, 95

Redo   223

Rego marks   305

Relink missing elements   67-68

Remove perspective   231

Renaming objects   121

Replacing text   276-277

Replicate tool   21, 231

Replicating objects   231-234

Reset   231

Resolution

About   47
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Brush   260

Changing   62-64

Monitor   48

Output   48

Picture   47

Printing   300

Save as picture   316

Reversing a path   245-246

RGB   73-74, 315

RGB Alpha   315

Right Indent   283-284

Right mouse-clicking   139

Right reading   305

RLE   303

Rotate 90° anticlockwise   230

Rotate 90° clockwise   230

Rotate transform   227-228

Round Rectangle bitmap tool   105-106

Round Rectangle vector tool 96

RTF   277

Rulers   85-86,235

S
Save As Picture

Anti-alias vectors   317

Bleed 316

Color space   315

File formats   314-315

Interpolate bitmaps   317

Interpolate pictures   317

Preview   317

Resolution   316-317

To save   314

Saving

Archiving   312-313

Brush gallery   263

Color Swatch palette   147

Document   64-65

Guides   90

Paint Style   139

Pen style   249

Print setting   306-307

Scale

Scale mode   227

Scaling the LAYER   226

Scaling the OBJECT   225

Scaling the printed page   304

Scaling the SHAPE   225

Scanning Pictures   49

Scitex CT

Converting   76-79

Importing   50-54

Opening   54-56

Placing   59-61

Save as   314-317

Screen Display

Wright Design sceen   13-14

Customized Views   25

Predefined Views   25

Screen ruling (frequency)   48, 306

Scrollbars   15

Select tool   21

Selecting objects   116-117, 205-206 

Selective Color Correction paint style

About   185

Adjustment operators   186

Opacity slider   185

To apply   186-189

Sending files to a printer   307-308

Separated   303

Separations   301, 302, 305-306
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Separations sub-dialog   305-306

Negative   305

Page gap   305

Positive   305

Print listbox   306

Right reading   305

Seps across   305

Spot function   305-306

Wrong reading   305

Seps across   305

Shadowing objects   221-222

Sharpen filter   167, 170

Shear transform   228

Shift   281

Shrinking objects   251-252

Smooth filter   168, 170

Smooth node style   240-241

Space above paragraph   284

Space below paragraph   284

Splitting a path   244-245

Spot Color palette   24, 81

Spot function   305-306

Star bitmap tool   22, 110-111

Star vector tool   21, 99-101

Status Bar   18

Straight Polygon bitmap tool 22, 108-109

Straight Polygon vector tool   21, 98-99

Stroke   136-141, 246-249

SubInv adjustment operator   150, 152

Subtract adjustment operator   150, 151-152

Subtract modifier tool    92, 261, 267, 268-269

Swatches   146-148

Symmetrical node style   241

T
Targa

Converting   76-79

Importing   50-54

Opening   54-56

Placing   59-61

Save as   314-317

Task Manager   23

Text

Character Attributes   114-115, 278-281

Editing text   276-277

Entering text   275

Exporting text   278

Filling text    294

From the menu   19

Importing text   277

Linking Attributes   114-115, 292-293

Paragraph Attributes   114-115, 282-285

Text Object Attributes   114-115, 285-292

Text preferences   38

Wrapping text   294-295

Text attributes   114-115, 274

Text Container color   39

Text Selection color   39

Text Object Attributes

About   114-115,285

Align text vertically   285-286

Border   287

Columns   286

Fit text to curve   287-292

Gap   287

To apply   285

Text objects   91, 114-115, 273

About   91, 114, 273

Entering text   275

Linking   292-293
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Resizing   275-276

Selecting   274-275

To create   114-115, 273-274

Text tool 21, 273-295

TIFF

Alpha channel   320-321

Converting   76-79

Importing   50-54

Opening   54-56

Placing   59-61

Save as   314-317

Tint Adjust paint style

About   148

Adjustment operators   150-152

Color model   148

Opacity slider   149

Selecting colors   149

Tint paint style

About   141

Color model   141-142

Opacity slider   142

Selecting colors   142-147

Tip of the Day   17

Tool Draw Colors   26

Tool flyouts   20-22

Tool Modifier Ribbon   22

Tool palette   20-21, 24

Tool Tips   17, 34

Tools  (see names of individual tools)
Tracking   280-281

Transforming

Layer   223-226

Object   223-226

Shape   223-226

Transform modes

Perspective   229

Rotate   227-228

Scale   227

Shear 228

Transform operations

Horizontal mirror   230

Remove perspective   231

Reset 231

Rotate 90° anticlockwise   230

Rotate 90° clockwise   230

Vertical mirror   229-230

TWAIN   49

U
Undo   223

V
Vector objects   91, 94-102

Vector Polygon tool   21, 101

Vector tool flyout   21

Vertical mirror   229-230

Viewing

Anti-alias vectors   30

Calibrate Display   30

From the menu   18

Interpolate bitmaps   30

Keyboard shortcuts   40

Magnifying and reducing the view   27

Moving the view of a page   27

Preview Transforms   29

Viewing Color Modes   30

CMYK color mode   30

RGB color mode   31

Spot color mode   31
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W
Window menu   19

Windows   13, 15

With next 284

Working with Grouped objects   209

Wrapping text around an object   294-295

Wrong reading   305

X
Xor adjustment operator   150, 152

Z
Zoom tool   21

Zooming   27
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