
What do you want to do?
           Create or open a document  
           Add, replace, or change something  
           Change the look and feel of the document (layout, colors, borders...)  
           Copy, move, resize, delete, or clear an object  
           View pages  
           Save a document or publish it for print, the screen, or the Web  
           What you want to do isn't listed here  



Note the previous and next topics are almost identical.



Leave this paragraph here...for some (unknown) reason, it makes the next topic appear properly.



Technical Support options

There are many options available on our Tech Support Web site including:

A searchable Knowledge Base
A Tech Support Feedback form (to report issues or request features)
FAQs (Frequently Asked Questions)
Faxback support (to have technical documents faxed to you automatically)
Information about how registered i publish users may receive technical support by phone

You may access all of these support resources at:
http://www.design-intelligence.com/
support/support.html.

If you have an issue that cannot be addressed in any of the above areas, you may send email to:
support@design-intelligence.com



Handbook cross-references 

The i publish Handbook comes with the 
CD version of i publish. To purchase the 
Handbook separately, see our Web site:
http://www.design-intelligence.com
/cgi-bin/store/ipublish

To see a topic: Click + next to a chapter, 
find your page, and then click a topic.

Chapter 1 "Getting started" 
(pages 7 - 22)

Chapter 2 "Working with layouts"
(pages 23 - 46)

Chapter 3 "Schemes at work" 
(pages 47 - 60)

Chapter 4 "Publishing online" 
(pages 61 - 74)

Chapter 5 "Step-by-step basics" 
(pages 75 - 84)

Chapter 6 "Getting help" 
(pages 85 - 90)

Tip: To quickly get help, on the i publish Help menu, click Index. Then type what you're looking for.



Handbook cross-references 

The i publish Handbook comes with the 
CD version of i publish. To purchase the 
Handbook separately, see our Web site:
http://www.design-intelligence.com
/cgi-bin/store/ipublish

To see a topic: Click + next to a chapter, 
find your page, and then click a topic.

Chapter 1 "Getting started" 
(pages 7 - 22)

p. 10              Create a new   
document

p. 14 Pictures

             Preview a picture   
before you add it
             Drag and drop   

pictures from the control 
window

Text

             Preview your text   
before you add it
             Drag and drop text   

from the control window

Tables, charts, or diagrams

             Preview your table,   
chart, or diagram before you 
add it

p. 18              Change the layout   
of the entire document
             Change one or more   

schemes for the entire 
document

p. 19              Publish your   
document as a Web page
             Publish your   

document as an onscreen 
presentation
             Print your document  

Chapter 2 "Working with layouts" 
(pages 23 - 46)

Chapter 3 "Schemes at work" 
(pages 47 - 60)

Chapter 4 "Publishing online" 
(pages 61 - 74)

Chapter 5 "Step-by-step basics" 
(pages 75 - 84)

Chapter 6 "Getting help" 
(pages 85 - 90)

Tip: To quickly get help, on the i publish Help menu, click Index. Then type what you're looking for.



Handbook cross-references 

The i publish Handbook comes with the 
CD version of i publish. To purchase the 
Handbook separately, see our Web site:
http://www.design-intelligence.com
/cgi-bin/store/ipublish

To see a topic: Click + next to a chapter, 
find your page, and then click a topic.

Chapter 1 "Getting started" 
(pages 7 - 22)

Chapter 2 "Working with layouts" 
(pages 23 - 46)

p. 26              Fit your text and   
pictures on an   i     publish   page  
             How can you get   

text and pictures to fit better 
on the page?

p. 31              Set where pictures,   
sidebars, and pull quotes 
appear
             Change the   

emphasis of a picture
             Choose individual   

layout options to create a 
custom layout
             Trim (crop) the   

picture
p. 33              Change the style of   

text in a component
p. 37              Choose individual   

layout options to create a 
custom layout

Chapter 3 "Schemes at work" 
(pages 47 - 60)

Chapter 4 "Publishing online" 
(pages 61 - 74)

Chapter 5 "Step-by-step basics" 
(pages 75 - 84)

Chapter 6 "Getting help" 
(pages 85 - 90)

Tip: To quickly get help, on the i publish Help menu, click Index. Then type what you're looking for.



Handbook cross-references 

The i publish Handbook comes with the 
CD version of i publish. To purchase the 
Handbook separately, see our Web site:
http://www.design-intelligence.com
/cgi-bin/store/ipublish

To see a topic: Click + next to a chapter, 
find your page, and then click a topic.

Chapter 1 "Getting started" 
(pages 7 - 22)

Chapter 2 "Working with layouts" 
(pages 23 - 46)

Chapter 3 "Schemes at work" 
(pages 47 - 60)

p. 47              Change one or more   
schemes for the entire 
document

p. 51              Set up your own   
color scheme
             Apply your own   

color scheme
             Add a corporate   

color or font scheme 
standard to all copies of 
i     publish  

p. 57              Set up your own   
font scheme
             Apply your own font   

scheme
             Add a corporate   

color or font scheme 
standard to all copies of 
i     publish  

p. 58              Change the look of   
an intelligent component

p. 59              Change the style of   
text in a component

Chapter 4 "Publishing online" 
(pages 61 - 74)

Chapter 5 "Step-by-step basics" 
(pages 75 - 84)

Chapter 6 "Getting help" 
(pages 85 - 90)

Tip: To quickly get help, on the i publish Help menu, click Index. Then type what you're looking for.



Handbook cross-references 

The i publish Handbook comes with the 
CD version of i publish. To purchase the 
Handbook separately, see our Web site:
http://www.design-intelligence.com
/cgi-bin/store/ipublish

To see a topic: Click + next to a chapter, 
find your page, and then click a topic.

Chapter 1 "Getting started" 
(pages 7 - 22)

Chapter 2 "Working with layouts" 
(pages 23 - 46)

Chapter 3 "Schemes at work" 
(pages 47 - 60)

Chapter 4 "Publishing online" 
(pages 61 - 74)

p. 62              Add a bulleted list  
             Make a nested list  
             Make a following   

paragraph with no bullet
p. 69              Publish your   

document as a Web page
             Publish your   

document as an onscreen 
presentation

p. 72              Change the   
emphasis of a picture

p. 74              Add a Web address   
(URL)
             Set where on the   

Internet you will post your 
Web pages
             Get ready to post   

your Web pages to the Web
             Post your Web   

pages to the World Wide Web

Chapter 5 "Step-by-step basics" 
(pages 75 - 84)

Chapter 6 "Getting help" 
(pages 85 - 90)

Tip: To quickly get help, on the i publish Help menu, click Index. Then type what you're looking for.



Handbook cross-references 

The i publish Handbook comes with the 
CD version of i publish. To purchase the 
Handbook separately, see our Web site:
http://www.design-intelligence.com
/cgi-bin/store/ipublish

To see a topic: Click + next to a chapter, 
find your page, and then click a topic.

Chapter 1 "Getting started" 
(pages 7 - 22)

Chapter 2 "Working with layouts" 
(pages 23 - 46)

Chapter 3 "Schemes at work" 
(pages 47 - 60)

Chapter 4 "Publishing online" 
(pages 61 - 74)

Chapter 5 "Step-by-step basics" 
(pages 75 - 84)

p. 79              Shortcuts: Zooming   
in or out

p. 83              Get ready to post   
your Web pages to the Web
             Set up your Internet   

Service Provider (ISP)
             Install the Microsoft   

Web Publishing Wizard 1.1
             Set where on the   

Internet you will post your 
Web pages

p. 84              View your onscreen   
presentation using your Web 
browser

Chapter 6 "Getting help" 
(pages 85 - 90)

Tip: To quickly get help, on the i publish Help menu, click Index. Then type what you're looking for.



Handbook cross-references 

The i publish Handbook comes with the 
CD version of i publish. To purchase the 
Handbook separately, see our Web site:
http://www.design-intelligence.com
/cgi-bin/store/ipublish

To see a topic: Click + next to a chapter, 
find your page, and then click a topic.

Chapter 1 "Getting started" 
(pages 7 - 22)

Chapter 2 "Working with layouts" 
(pages 23 - 46)

Chapter 3 "Schemes at work" 
(pages 47 - 60)

Chapter 4 "Publishing online" 
(pages 61 - 74)

Chapter 5 "Step-by-step basics" 
(pages 75 - 84)

Chapter 6 "Getting help" 
(pages 85 - 90)

p. 85              Online User's Guide  

p. 89              Technical Support   
options

Tip: To quickly get help, on the i publish Help menu, click Index. Then type what you're looking for.





Note: The context-sensitivity is defined in the .hpj file. For some reason, we had to add 131072 to each context-
sensitivity number.

Here are the numbers we used:

UI Help Text ID Help # 
context ID

With 
131072 
added

File > Open Existing Document IDH_DLG_OPEN 100 131172

File > Open Web Page IDH_DLG_OPEN_URL 200 131272

File > Save As IDH_DLG_SAVE_AS 300 131372

File > Save Component IDH_DLG_SAVE_COMPONENT 350 131422

File > Save Copy As IDH_DLG_SAVE_COPY 400 131472

File > Import > Text File IDH_DLG_INSERT_FILE 1200 132272

File > Import > Picture File IDH_DLG_INSERT_PICTURE 1300 132372

File > Import > Component File IDH_DLG_INSERT_COMPONENT 1550 132622

File > Publish to Printer IDH_DLG_PRINT 500 131572

File > Page Setup IDH_DLG_PAGE_SETUP 600 131672

File > Publish for Web (Publish tab) IDH_PPG_PUBLISH 700 131772

File > Publish for Web (Configure tab) IDH_PPG_CONFIGURE 710 131782

File > Publish for Web (Browsers tab) >    
Add button (Web Browser Information)

IDH_DLG_WEB_BROWSER 715 131787

File > Publish for Web (Browsers tab) IDH_PPG_INTERNET 720 131792

File > Publish for Screen (Publish tab) IDH_DLG_SCREEN 800 131872

File > Publish for Screen (Configure tab) IDH_PPG_CONFIGURE_SCREEN 810 131882

File > Publish for Screen (Shortcuts tab) IDH_DLG_SCREEN_SHORTCUTS 820 131892

Edit > Paste Special IDH_DLG_PASTE_SPECIAL 900 131972

Edit > Find IDH_DLG_FIND 1000 132072

Edit > Replace IDH_DLG_REPLACE 1100 132172

Insert > Clip Art IDH_LOCATEFILE 1350 132422

Insert > OLE Object IDH_DLG_INSERT_OBJECT 1400 132472

Edit > Spelling IDH_DLG_SPELLCHECK 1600 132672

Design > Styles IDH_DLG_STYLE 1700 132772

Design > Tabs IDH_DLG_TABS 1800 132872

Design > Adjust Picture IDH_DLG_CROP 1900 132972

Design > Layouts > Custom (Catalog 
Group), Document tab

IDH_PROPPAGE_SSOPTIONS 2000 133072

Design > Layouts > Custom (Catalog 
Group), Component tab

IDH_PROPPAGE_SSOPTIONSDE
MO

2005 133077

Design > Layouts > Custom 
(Correspondence Group)

IDH_PROPPAGE_SFOPTIONS 2010 133082

Design > Layouts > Custom (Report 
Group)

IDH_PROPPAGE_LFOPTIONS 2020 133092

Design > Layouts > Custom (Newsletter 
Group), Document tab

IDH_PPG_NEWSDOC 2040 133112

Design > Layouts > Custom (Newsletter 
Group), Component tab

IDH_PPG_NEWSCMP 2045 133117

Design > Schemes (Fonts tab) IDH_PPG_FONTSCHEMES 2100 133172



Design > Schemes (Colors tab) IDH_PPG_COLORSCHEMES 2110 133182

Design > Schemes (Effects tab) IDH_PPG_GFXSCHEMES 2120 133192

Design > Schemes (Paragraphs tab) IDH_PPG_PARASCHEMES 2130 133202

Design > Schemes (Level tab) IDH_PPG_LEVEL 2140 133212

Design > Schemes (Advanced tab) IDH_PPG_SCHEMEADV 2150 133222

Design > Insert Empty Component IDH_DLG_PARTS 2200 133272

Edit > Options (General tab) IDH_PPG_GENERAL 2300 133372

Edit > Options (User Info tab) IDH_PPG_USERINFO 2310 133382

Edit > Options (File Locations tab) IDH_PPG_FILELOC 2320 133392

Edit > Options (File Locations tab) > 
Modify button

IDH_DLG_MODIFY_LOC 2321 133393

Edit > Options (Spelling tab) IDH_PPG_SPELLING 2330 133402

Edit > Custom Schemes (Fonts tab) IDH_PPG_CUSTOM_FONT 2340 133412

Edit > Custom Schemes (Colors tab) IDH_PPG_CUSTOM_COLOR 2350 133422

Edit > Options (Colors tab) > Edit button

Or, text color button on the toolbar, then 
click Other

IDH_DLG_COLOR_EDIT 2351 133423

Right-click a text component > Edit IDH_EDIT_TEXT_DIALOG 2400 133472

Help > User's Guide

Help > How Do You > What you want 
isn't listed here

IDH_MAIN 2500 133572

Help > Keyboard Shortcuts IDH_TPC_SHORTCUT 2600 133672

Help > QuickStart (for ipub_nb.hlp only) IDH_TPC_QUICKSTART 2700 133772

Help > Technical Support IDH_TPC_TECHSUP 2800 133872

Browse dialog box (appears all over the 
product)

IDH_DLG_BROWSE 2900 133972

Help > Handbook Cross-References IDH_HANDBOOK 3000 134072

Help > How Do You > Start a document m_crtdc2 3100 134172

Help > How Do You > Add pictures, text, 
or a component

m_add 3110 134182

Help > How Do You > Change the look of 
a document

m_doclook 3120 134192

Help > How Do You > Publish Web pages h_pbweb 3130 134202

Help > How Do You > Publish an 
onscreen presentation

h_pbprst 3140 134212

Error message: ipublish doesn't recognize 
the file format 

m_format 3200 134272

Error message: ipublish can't preview the 
picture file (shows supported picture 
files)

dpformat 3210 134282

Error message: ipublish can't preview the 
text file (shows supported text files)

dtformat 3220 134292

UI Help Text ID Help # 
context ID

With 
131072 
added

SPLITTER File > Split File Across Multiple IDH_SPLITTER 4000 135072



Disks

SPLITTER File > Combine Split Files IDH_UNSPLITTER 4010 135082

SPLITTER Browse For Folder IDH_SPLIT_BROWSE 4020 135092

SPLITTER Open IDH_SPLIT_OPEN 4030 135102

SPLITTER Main topic IDH_SPLIT_MAIN 4040 135112



The "Common Windows Open dialog box" popups are used for: 
Open, Insert File, Insert Picture

Common Windows Open dialog box—Look In combo box



Lists the available drives and folders.

To open a document on a different drive or folder, click this box, and then click the drive or folder you want. The 
contents of the current drive or folder appear below the Look In box.

To open the folder one level above the current one, click .



Common Windows Open dialog box—Toolbar button—Up one level



Click this to move up one folder in the folder structure.



Common Windows Open dialog box—Toolbar button—Add new folder



Click this to add a new folder within the currently open folder.



Common Windows Open dialog box—Toolbar button—List



Click this to show the files and folders in a list.



Common Windows Open dialog box—Toolbar button—Details



Click this to show all details about your files and folders, such as names, file sizes, types of files, and modification 
dates.



Common Windows Open dialog box—File name list



Lists the files and folders contained within the drive or folder displayed in the Look In box. To see what's inside a 
folder, double-click it.

You can also click the Look In box to see the hierarchy of folders.

To open the folder one level above the current one, click .



Common Windows Open dialog box—File name edit box



To specify the file that you want to open or find, type its name in this box.

You can use * as a wildcard. For example, to see a list of all files, type: *.*

You can also type the full path of a file, such as C:\My Documents\MyFile.did



Common Windows Open dialog box—Files of type combo box



To choose the type of files you want to open, click this box, and then click the file type you want.



Common Windows Open dialog box—Open button



Opens the selected file or folder.



All dialog box—OK button



Closes the dialog box and saves any changes you made.



All dialog box—Cancel button



Closes the dialog box without saving any changes you made.



All dialog box—Apply button



Applies the changes you've made but does not close the dialog box.





File menu



Open Existing Document File menu

Opens an existing i publish document. (i publish documents end in .did.)

Tip: If you click All Files (*.*) in the Files Of Type box, you can open a text or picture file created in another 
program. The file opens in the control window (at screen left) where you can preview it before you insert it into 
your i publish document.

Click the picture below for details about each option. 

More Information

How do you...

             Find a file  
             Open an existing document  
             Preview your picture before you add it  
             Preview your text before you add it  
             Automatically open the last document you worked on when you start   i     publish  



Open Web Page File menu

Opens a Web address (URL), such as http://www.design-intelligence.com/, in the control window (at screen left).

Open Web Page is available only if you have installed Internet Explorer 3.02 or later.

Click the picture below for details about each option. 

More Information

How do you...

             Type a specific Web address  



Open Web Page dialog box—Location combo box



Type the Web address (or URL) of a Web site. Or, click the arrow next to this box and choose a Web address that 
you've already visited.



Open Web Page dialog box—OK button



Opens the current Web address in the control window (at screen left).



Save As File menu

Allows you to specify a name and location for a new file. You can also use this box to:
Change the file name of the open file.
Save the open file to a different location.
Make a copy of the open file, naming and saving the copy as a new file while leaving the original version 

intact. 
Note: When you save a copy, i publish closes the original document and opens the new one.

Click the picture below for details about each option. 

More Information

How do you...

             Save a copy of your document to a different location or with a new name  
             Create a new document based on an existing one or a template  



Save As dialog box—Save in combo box



To save your document in a different folder or on a different drive, click this box, and then click the location you 
want. The contents of the current drive or folder appear below the Save In box.

To open the folder one level higher, click .



Save As dialog box—File name list



Lists the files and folders stored in the selected location. To see what's inside a folder, double-click it.

To open the folder one level higher, click .



Save As dialog box—File name edit box



Specifies what the currently open i publish file will be named. 



Save As dialog box—Save as type combo box



Specifies that your document is an i publish document, and that the file name will end in .did



Save As dialog box—Save button



Saves the file with the name you typed and in the location you specified.



Save Copy As

If you get to a point where you like your document, but you want to experiment with cutting text, or dropping in 
other text or pictures, you can create a backup document. A backup prevents you from having to undo changes 
you made to recreate the document you liked.

Tip: Backup copies take up disk space on your hard drive. You may want to delete old backup copies when you've 
completed your document. 

Click the picture below for details about each option. 



Most of the popups for the Save Copy As dialog box are the same as Save As.

Save Copy As dialog box—File name edit box



Specifies the name for the backup copy of the currently open i publish file. 



Save Component File menu

Saves the selected component to a file so you can use it in a different document. Saved component filenames end 
in .dio

Click the picture below for details about each option. 

More Information

How do you...

             Create your own intelligent component  
             Add an intelligent component that you created  
             Select compound components  



Import Text File File menu, Import option

Inserts a text file into your document, placing it in the currently selected text component. You need to select a text 
component before you can insert a text file.

Click the picture below for details about each option. 

More Information

How do you...

             Add a text file from a disk (floppy, hard, CD-ROM)  
             Copy highlighted text from a disk (floppy, hard, CD-ROM)  
             Find a file  

Concepts

             What text formats does   i     publish   support?  



Import Picture File File menu, Import option

Inserts a picture file, placing it in the currently selected picture component. You need to select a picture component 
or a text component before you can insert a picture file.

Click the picture below for details about each option. 

More Information

How do you...

             Add a picture  
             Find a file  

Concepts

             What picture formats does   i     publish   support?  



Import Component File File menu, Import option

Inserts a custom component into your document. 

Note: If the current layout only accepts one of that type of component, then the inserted component replaces the 
current one of that type. For example, some layouts accept only one Banner component, so a custom Banner would 
replace an existing Banner.

Click the picture below for details about each option. 

More Information

How do you...

             Create your own intelligent component  
             Add an intelligent component that you created  



Publish to Printer File menu

Prints either the whole document, a range of pages, or the current selection using the selected printer.

Click the picture below for details about each option. 

More Information

How do you...

             Print your document  
             Print more than one copy at a time  
             Print your document on an outside printer  



Publish To Printer dialog box—Name combo box



Lists the currently selected printer. If you want to use a different one, click this box, and then click the printer you 
want to use.



Publish To Printer dialog box—Printer Status Text button



Shows details about the selected printer. To set specific settings for this printer, click Properties.



Publish To Printer dialog box—Properties button



Sets specific settings for the selected printer. The options available vary depending on the printer.



Publish To Printer dialog box—Print to file checkbox



Prints your document to a file instead of to the printer. After you click OK, i publish asks you for a file name and 
location for the file.



Publish To Printer dialog box—Print range



When you click OK, you can either print:
The entire document.
A range of pages you specify. To print just one page, enter that page number in both boxes.



Publish To Printer dialog box—Copies edit box



Specifies the number of copies to print.

When you print multiple copies:
If Collate is checked, i publish prints a complete copy of your document before printing the first page of 

the next copy. 

If Collate is unchecked, i publish prints the number of copies you want of page 1, then the number of 
copies you want of page 2, and so on.



Publish To Printer dialog box—OK button



Prints the document either to the printer or to a file, depending on the options you set.



Page Setup File menu

Sets options for your page, including the paper size, paper orientation, margins, and starting page number. 

Click the picture below for details about each option. 

More Information

How do you...

             Set page options  
             Change your document to European paper sizes  
             Change the document margins (top, bottom, left, or right)  
             Change the page orientation (portrait or landscape)  
             Change the starting page number for your document  



Page Setup dialog box—Paper—Size combo box



Specifies the size of the paper you want to use.



Page Setup dialog box—Paper—Source combo box



Specifies where the paper you want to use is located in the printer. Different printers support different paper 
sources, such as the upper tray, envelope feed, or manual feed.



Page Setup dialog box—Orientation—Orientation buttons



Specifies whether the document should be printed with its top along the short edge of the paper (portrait) or along 
the long edge of the paper (landscape).



Page Setup dialog box—Margins



Specifies how much space you want for each margin.

If you are creating a newsletter, you can have i publish created mirrored margins, so that the inside and outside 
margins differ.



Page Setup dialog box—Mirrored margins



For newsletters, specifies that inside margins are the same width, and outside margins are the same width.

If your document will eventually be printed on both sides of the paper, you might want your inside margins to be 
larger so that your text isn't covered up by a binding or staple. 



Page Setup dialog box—Page Numbering



Specifies what the starting page number is for the document.

Note: For reports, i publish does not number the cover page or the title page; it numbers the first page of your 
body text as page 1. 



Page Setup dialog box—Reset Defaults



Resets the margins to the document's default margins.



Publish for Web (Publish tab) File menu

Sets the colors and layout for your Web page. When you click OK, i publish publishes your document as a Web page 
either to your computer or to the World Wide Web, depending on the options you set.

Note: The settings on the Configure tab are used for both Web pages and onscreen presentations.

Click the picture below for details about each option. 
To display options on a different tab, click that tab in the picture.

More Information

How do you...

             Create a Web document  
             Update your Web page  
             Publish your document as a Web page  
             Change the look of your Web page  
             Set up your Internet Service Provider (ISP)  
             Post your Web pages to the World Wide Web  

Concepts

             What happens when you Publish for Web?  
             How does   i     publish   create your Web address (URL)?  



Publish for Web (Publish tab) dialog box—Internet vs. My Computer



Specifies whether you want to publish your Web page to your computer or the Web. 

If you're still working on your page, you probably want to publish it to your computer, and then publish it to the 
Web when it's finished. You can change these settings:

Set where on the Internet you will post your Web pages 
             How?  

Set where on your computer your Web pages are stored
             How?  

Use Internet Explorer or Netscape Navigator to view your Web pages
             How?  

Note: The Internet option is only available if you have installed the Microsoft Web Publishing Wizard 1.1.
             How do you install the Microsoft Web Publishing Wizard?  



Publish for Web (Publish tab) dialog box—Web Scheme Set



Specifies what colors are applied to your Web pages.



Publish for Web (Publish tab) dialog box—Layout 



Specifies the layout and where your Table of Contents (Navigation) is placed on your Web pages.

Note: This option is not available for letters, memos, faxes, or press releases.



Publish for Web (Publish tab) dialog box—OK



Saves your settings and publishes your Web pages either to your computer or the Internet, depending on the 
options you set. 



Publish for Web (Publish tab) dialog box—Close



Closes the dialog box without saving any changes you made.



Publish for Web (Configure tab) File menu

Sets the colors and layout for your Web page. When you click OK, i publish publishes your document as a Web page 
either to your computer or to the World Wide Web, depending on the options you set.

Note: The settings on the Configure tab are used for both Web pages and onscreen presentations.

Click the picture below for details about each option. 
To display options on a different tab, click that tab in the picture.

More Information

How do you...

             Create a Web document  
             Update your Web page  
             Publish your document as a Web page  
             Change the look of your Web page  
             Set up your Internet Service Provider (ISP)  
             Post your Web pages to the World Wide Web  

Concepts

             What happens when you Publish for Web?  
             How does   i     publish   create your Web address (URL)?  



Publish for Web (Configure tab) dialog box—Name for top-level page



Specifies the file name for the main page of your Web page or onscreen presentation, ending in .html.



Publish for Web (Configure tab) dialog box—Choose a Web site and New button



Specifies the Internet service provider (ISP) where you will post your Web pages. 

If your Internet service provider is not in the list, click New to open the Microsoft Web Publishing Wizard 1.1 to set 
up your Internet service provider. (Note: You may need to talk to your Internet service provider to get all the 
information you need to enter.)
             How?  

If you don't have the Microsoft Web Publishing Wizard 1.1, you can download it. Or, if you have i publish on a CD 
(compact disc), you can install it from there.
             How?  



Publish for Web (Configure tab) dialog box—Folder on the Web site



Specifies the folder on the Internet service provider's (ISP) computer where you will post your Web pages.

If you leave this blank, your Web pages will be posted to your ISP's default folder.

Note: You may need to talk to your ISP to get this information.



Publish for Web (Configure tab) dialog box—Root folder for Web publishing and Browse button



Specifies the folder on your computer where you will publish your Web pages or onscreen presentation.

Click Browse to choose a different folder.



Publish for Web (Configure tab) dialog box—Remove these files before publishing



Specifies that when you publish your Web pages or onscreen presentation, i publish removes any files with the 
listed extensions before publishing.

If you're going to copy your Web pages or onscreen presentation to a server or other location, this ensures that the 
only files in the folder are the latest ones. 



Publish for Web (Browsers tab) File menu

Sets the colors and layout for your Web page. When you click OK, i publish publishes your document as a Web page 
either to your computer or to the World Wide Web, depending on the options you set.

Note: The settings on the Configure tab are used for both Web pages and onscreen presentations.

Click the picture below for details about each option. 
To display options on a different tab, click that tab in the picture.

More Information

How do you...

             Create a Web document  
             Update your Web page  
             Publish your document as a Web page  
             Change the look of your Web page  
             Set up your Internet Service Provider (ISP)  
             Post your Web pages to the World Wide Web  

Concepts

             What happens when you Publish for Web?  
             How does   i     publish   create your Web address (URL)?  



Publish for Web (Browsers tab) dialog box—List



If your Web page will be viewed on both Internet Explorer and Netscape Navigator, you may want to view your Web 
page in both browsers to ensure you like the results. 

To add another browser, click Add and then locate where the browser is installed on your machine. 
Typically, Internet Explorer is installed in: C:\Program Files\Plus!\Microsoft Internet\Iexplore.exe
Typically, Netscape Navigator is installed in: C:\Program Files\Netscape\Navigator\Program\netscape.exe

You can use Internet Explorer or Netscape Navigator to view your Web pages.
             How?  



Publish for Web (Browsers tab) dialog box—Add button



Opens the Web Browser Information dialog box in which you can set a browser that you want to use to view your 
Web pages.



Publish for Web (Browsers tab) dialog box—Edit button



Opens the Web Browser Information dialog box in which you can edit the settings for the selected browser.



Publish for Web (Browsers tab) dialog box—Remove button



Removes the selected browser from the list, making it unavailable as a way to view your Web page.



Web Browser Information

If your Web page will be viewed on both Internet Explorer and Netscape Navigator, you may want to view your Web 
page in both browsers to ensure you like the results. Use this box to tell i publish about your browser.

Click the picture below for details about each option. 

More Information

How do you...

             Use Internet Explorer or Netscape Navigator to view your Web pages  



Web Browser Information dialog box—Name



Specifies the name of the browser, such as Internet Explorer or Netscape Navigator.



Web Browser Information dialog box—Registered Browser



If you have a browser that you always use, click this option, and then click OK. i publish looks at your system and 
adds your default browser to the list.



Web Browser Information dialog box—Command and Browse button



Specifies the location on your computer where the browser is stored. 
Typically, Internet Explorer is installed in: C:\Program Files\Plus!\Microsoft Internet\Iexplore.exe
Typically, Netscape Navigator is installed in: C:\Program Files\Netscape\Navigator\Program\Netscape.exe

To locate the browser, click Browse.



Web Browser Information dialog box—Arguments



Customizes the way that your browser opens and displays your Web page.

-k Specifies to run your Web page 
in the browser's Kiosk Mode, 
which maximizes the amount of 
space used for your Web page.

This works for both Internet 
Explorer and Netscape 
Navigator.

-nohome If you're running Internet 
Explorer, specifies not to open 
your default home page. 

You probably should use this 
option, because you do not 
want your default home page 
opening first before your new 
i publish Web page.



Browse 

Locates a file or folder.

Click the picture below for details about each option. 

More Information

How do you...

             Find a file  



Publish for Screen (Publish tab) File menu

Publishes your document as an onscreen presentation, turning your printed document into presentation slides.

Note: The settings on the Configure tab are used for both Web pages and onscreen presentations.

Click the picture below for details about each option. 

More Information

How do you...

             Create an onscreen presentation  
             Change the look of your onscreen presentation  
             Update your onscreen presentation  
             Print your onscreen presentation the way it appears onscreen  
             View your document as an onscreen presentation  
             View your onscreen presentation using your Web browser  

Concepts

             What's an onscreen presentation?  

Tips

             Writing and presenting an onscreen presentation  



Publish for Screen dialog box—Presentation Scheme Set



Specifies what colors are applied to your onscreen presentation.



Publish for Screen dialog box—View Presentation



Specifies that you want to publish your onscreen presentation to your computer as well as view it using i publish.

Note: If you don't have Internet Explorer installed, you won't be able to view your presentation using i publish. 
             How do you view your presentation using Netscape Navigator or a different browser?  



Publish for Screen dialog box—OK



Saves your settings and publishes your onscreen presentation to a folder on your computer.



Publish for Screen (Configure tab) File menu

Publishes your document as an onscreen presentation, turning your printed document into presentation slides.

Note: The settings on the Configure tab are used for both Web pages and onscreen presentations.

Click the picture below for details about each option. 

More Information

How do you...

             Create an onscreen presentation  
             Change the look of your onscreen presentation  
             Update your onscreen presentation  
             Print your onscreen presentation the way it appears onscreen  
             View your document as an onscreen presentation  
             View your onscreen presentation using your Web browser  

Concepts

             What's an onscreen presentation?  

Tips

             Writing and presenting an onscreen presentation  



Publish for Screen (Shortcuts tab) File menu

Publishes your document as an onscreen presentation, turning your printed document into presentation slides.

Note: The settings on the Configure tab are used for both Web pages and onscreen presentations.

Click the picture below for details about each option. 

More Information

How do you...

             Create an onscreen presentation  
             Change the look of your onscreen presentation  
             Update your onscreen presentation  
             Print your onscreen presentation the way it appears onscreen  
             View your document as an onscreen presentation  
             View your onscreen presentation using your Web browser  

Concepts

             What's an onscreen presentation?  

Tips

             Writing and presenting an onscreen presentation  



Publish for Screen dialog box—Place shortcut to presentation on desktop



Specifies to create a shortcut to your presentation, and then place that shortcut on your desktop.

To start your presentation, just double-click the shortcut.



Publish for Screen dialog box—Place shortcut to presentation in folder



Specifies to create a shortcut to your presentation, and then place that shortcut in the folder listed below.

To start your presentation, just double-click the shortcut.



Publish for Screen dialog box—Specify folder to hold shortcut



Specifies where you want to save the shortcut to your presentation.

To start your presentation, just double-click the shortcut.



Publish for Screen dialog box—Browse



Opens a dialog box in which you can set the folder you want to use for your presentation shortcut.





Edit menu



Paste Special Edit menu

Pastes the object that's on the Clipboard into your i publish document in the format you choose.

Click the picture below for details about each option. 

More Information

How do you...

             Embed an existing document  
             Embed a new, empty object  
             Edit an embedded object  

Concepts

             What is OLE?  



Paste Special dialog box—Source text



Displays the name of the document that contains the information you copied. 



Paste Special dialog box—Paste radio button



Click this to embed the copied information into your document.

Changes you make to the embedded information will not appear in the original document, and future changes to 
the original document will not appear in your i publish document.



Paste Special dialog box—As list box



Lets you select how the information is pasted into your document. 

Note: This option is not available for all types of documents.



Paste Special dialog box—Results static text



Describes what effect the current settings will have. 



Paste Special dialog box—OK button



Embeds the object in your i publish document using the current settings.



Find Edit menu

Searches for the text you specify from within the entire document or the currently highlighted text.

Click the picture below for details about each option. 

More Information

How do you...

             Find text in your document  
             Search specific text only  
             Search more efficiently  



Find dialog box—Find combo box



Type the characters or words you want to search for. If you've used Find before, click the down arrow to choose the 
text from the list.



Find dialog box—Match Case checkbox



If you want i publish to find words that exactly match the upper and lower case letters that you type, click Match 
Case to add a checkmark.



Find dialog box—Find Whole Words Only checkbox



If you want i publish to treat the text you typed as a whole word, click Find Whole Words Only to add a checkmark. 
For example, if you typed let, i publish finds all occurrences of let, but does not find lettuce.



Find dialog box—Find Next button



Searches your i publish document for the next occurrence of the text you typed.



Replace Edit menu

Searches for the text you specify from within the entire document or the currently highlighted text, and then 
replaces it with the text you typed.

Click the picture below for details about each option. 

More Information

How do you...

             Find and replace text in your document  
             Search for straight quotes and replace them with curly quotes  
             Search specific text only  
             Search more efficiently  



The rest of the popups are the same as the Find dialog box

Replace dialog box—Replace edit box



Type the characters or words you want i publish to insert whenever it finds what you typed in the Find box. If 
you've used Replace before, click the down arrow to choose the text from the list.

To delete occurrences of the text you typed in the Find box, leave the Replace box blank.



Replace dialog box—Replace button



After i publish finds the characters or words that match what you typed, click Replace to replace the highlighted 
text with the text you typed in the Replace box.



Replace dialog box—Replace All button



Replaces all occurrences of the text in the Find box with the text in the Replace box.

To delete occurrences of the text you typed in the Find box, leave the Replace box blank.



Spelling Edit menu

Checks the spelling of your document or the currently highlighted text.

Click the picture below for details about each option. 

More Information

How do you...

             Check the document for misspellings  
             Change spelling options  
             Change the language dictionary   i     publish   uses to check spelling  



Spelling dialog box—Not in Dictionary edit box



Displays a possible spelling or grammar error, such as a misspelled word, a duplicate word, or incorrect 
capitalization.



Spelling dialog box—Change To edit box



To replace the word that i publish highlighted (listed in the Not In Dictionary box), do one of the following:
To accept the word in the Change To box, click Change.
To use a different word, type it in the Change To box, and then click Change. 

Or, select a word from the Suggestions box, and then click Change.



Spelling dialog box—Suggestions list box



Lists suggested replacement words for the highlighted word. If no words are displayed, click Suggest.

If you want i publish to always suggest replacement words without having to click the Suggest button:

1. On the Edit menu, click Options.

2. Click the Spelling tab.

3. Check Always Suggest Spelling Alternatives, and then click OK.



Spelling dialog box—Add Words To combo box



Specifies the current custom dictionary. To add a word that appears in the Not in Dictionary box to the selected 
custom dictionary, click Add.

By default, i publish creates a custom dictionary for you. You can change the custom dictionary:

1. On the Edit menu, click Options.

2. Click the Spelling tab.

3. Under Personal Dictionary, click Browse. Locate your custom dictionary, and then click OK.



Spelling dialog box—Ignore button



To leave a word in the Not In Dictionary box unchanged, click Ignore.



Spelling dialog box—Ignore All button



To leave all instances of the word in the Not In Dictionary box unchanged, click Ignore All.



Spelling dialog box—Change button



To change the word in the Not In Dictionary box to the word in the Change To box, click Change.



Spelling dialog box—Change All button



To change all instances of the word in the Not In Dictionary box to the word in the Change To box, click Change All.



Spelling dialog box—Add button



To add the word in the Not In Dictionary box to the selected custom dictionary, click Add.

To change the custom dictionary:

1. On the Edit menu, click Options.

2. Click the Spelling tab.

3. Under Personal Dictionary, click Browse. Locate your custom dictionary, and then click OK.



Spelling dialog box—Suggest button



To display a list of alternatives for a misspelled word, click Suggest.



Options (General tab) Edit menu

Displays options you can use to customize i publish.

Click the picture below for details about each option. 
To display options on a different tab, click that tab in the picture.

More Information

How do you...

General tab

             Automatically open the last document you worked on when you start   i     publish  
             Change your unit of measurement to inches or centimeters  
             See if you have too much text or too many pictures  

User Info tab

             Edit user or company information  

File Locations tab

             Set the default file locations  

Spelling tab

             Change spelling options  
             Change the language dictionary   i     publish   uses to check spelling  



Options dialog box (General tab)—Reload last document at startup



Specifies that when you open i publish, the last document you worked on is automatically opened for you.



Options dialog box (General tab)—When document is overfit...



Places a red box around components that may be contributing to the document's overfit. Edit one or more of these 
components, and then see if your text or pictures fit better on the page.



Options dialog box (General tab)—Show Control Window At Startup



Specifies that when you open i publish, the control window (screen left) is visible.



Options dialog box (General tab)—Prompt to save before closing files



Specifies that when you close a document, i publish asks you if you want to save your changes first. 



Options dialog box (General tab)—Fit Quality



Specifies how precisely i publish fits the text and pictures on the page.
Production precisely fits everything on the page. (Note: This option may make page layout slower.)
Proof lays out your page faster than Product, but slower than Draft.
Draft lays out the page quickly, but isn't as precise as Production or Proof. 



Options dialog box (General tab)—Measurements



Specifies whether the Tabs box (Design menu) shows your tab stops in inches or centimeters.



Options (User Info tab) Edit menu

Displays options you can use to customize i publish.

Click the picture below for details about each option. 
To display options on a different tab, click that tab in the picture.

More Information

How do you...

General tab

             Automatically open the last document you worked on when you start   i     publish  
             Change your unit of measurement to inches or centimeters  
             See if you have too much text or too many pictures  

User Info tab

             Edit user or company information  

File Locations tab

             Set the default file locations  

Spelling tab

             Change spelling options  
             Change the language dictionary   i     publish   uses to check spelling  



Options dialog box (User Info tab)—Name



Type your name.



Options dialog box (User Info tab)—Address



Type your address.



Options dialog box (User Info tab)—Phone



Type your area code and phone number without spaces, dashes, or parentheses.



Options dialog box (User Info tab)—FAX



Type your area code and FAX number without spaces, dashes, or parentheses.



Options dialog box (User Info tab)—Email



Type your email address, such as YourName@InternetProvider.com



Options dialog box (User Info tab)—Web Site



Type your Company's Web Site address, such as http://www.design-intelligence.com/



Options dialog box (User Info tab)—Company



Type your Company name.



Options dialog box (User Info tab)—Tagline



Type your Company's tagline. For example, the i publish tagline is:
Write once, publish anywhere . . . automatically.™



Options dialog box (User Info tab)—Title



Type your title, such as Director of Operations.



Options dialog box (User Info tab)—Image File



Type the path and file name for the file that contains your company's logo. Or to find the file, click Browse.



Options dialog box (User Info tab)—Browse button



Opens a box in which you can find your company's logo file.



Options (File Locations tab) Edit menu

Displays options you can use to customize i publish.

Click the picture below for details about each option. 
To display options on a different tab, click that tab in the picture.

More Information

How do you...

General tab

             Automatically open the last document you worked on when you start   i     publish  
             Change your unit of measurement to inches or centimeters  
             See if you have too much text or too many pictures  

User Info tab

             Edit user or company information  

File Locations tab

             Set the default file locations  

Spelling tab

             Change spelling options  
             Change the language dictionary   i     publish   uses to check spelling  



Options dialog box (File Locations tab)—Type



Specifies where i publish looks for custom components, picture files, and text files, and where i publish saves your 
documents:

Component Files—Specifies the folder that i publish opens when you look for components that you saved 
for use in other i publish documents.
             How do you create your own intelligent component?  
             How do you add an intelligent component that you created?  

Documents—Specifies the folder where i publish saves your documents.
Picture Files—Specifies the folder that i publish opens when you look for picture files.
Text Files—Specifies the folder that i publish opens when you look for text files.



Options dialog box (File Locations tab)—Location



Specifies the current folder in which i publish looks for your pictures, text files, and custom components, and where 
i publish saves your documents.



Options dialog box (File Locations tab)—Modify button



Click a file type, and then click Modify to change the location.



Options dialog box (File Locations tab)—Clear button



Removes the currently specified location for the selected file type. To specify a new location, click Modify.



Options (Spelling tab) Edit menu

Displays options you can use to customize i publish.

Click the picture below for details about each option. 
To display options on a different tab, click that tab in the picture.

More Information

How do you...

General tab

             Automatically open the last document you worked on when you start   i     publish  
             Change your unit of measurement to inches or centimeters  
             See if you have too much text or too many pictures  

User Info tab

             Edit user or company information  

File Locations tab

             Set the default file locations  

Spelling tab

             Change spelling options  
             Change the language dictionary   i     publish   uses to check spelling  



Options dialog box (Spelling tab)—Language



Sets the language dictionary that i publish uses to check the spelling of your document.



Options dialog box (Spelling tab)—Suggest



Specifies that i publish always suggests spelling alternatives. To speed up checking the spelling of your document, 
you can uncheck this option.



Options dialog box (Spelling tab)—a vs. an



Specifies that if i publish finds an "a" when you should use an "an" (or vice versa), i publish lets you know while 
you're checking the spelling of your document. For example, i publish finds "Have a apple."



Options dialog box (Spelling tab)—Capitalization 



Specifies that if i publish finds a word that may need to change to lower case or upper case, i publish lets you know 
while you're checking the spelling of your document. For example, i publish finds "Let's go to mexico!"



Options dialog box (Spelling tab)—Doubled words



Specifies that if i publish finds two of the same words in a row, such as "the the", i publish lets you know while 
you're checking the spelling of your document.



Options dialog box (Spelling tab)—Hyphenation



Specifies that if i publish finds incorrectly hyphenated words, such as "h-yphenation", i publish lets you know while 
you're checking the spelling of your document.



Options dialog box (Spelling tab)—Personal Dictionary



Specifies where your current personal dictionary is stored. To change the current dictionary, click Browse and then 
find the dictionary you want.

(Note: Personal dictionaries end in .dic)



Options dialog box (Spelling tab)—Browse



Opens a box in which you can find the personal dictionary you want to use. 

(Note: Personal dictionaries end in .dic)



Modify Location

Sets the default folder i publish uses. 

Click the picture below for details about each option. 

More Information

How do you...

             Set the default file locations  



Modify Location dialog box—Old



Lists the folder where i publish looked for your files, before you changed the folder.



Modify Location dialog box—New



Click the new folder that you want i publish to use.

To open a folder, double-click it.



Modify Location dialog box—OK



Sets the new folder location you've specified for where i publish will look for your files.



Edit Color

Specifies a new color to use in i publish. You can either use one of the "basic colors," or click Define Custom Colors 
to add other colors to the palette.

Click the picture below for details about each option. 

More Information

How do you...

             Create a custom color  



Edit Color dialog box—Basic Colors



Shows the "basic colors" available.

To define a custom color, click a basic color that is similar, and then click Define Custom Colors.

To use a color in i publish, click any color tile, and then click OK.



Edit Color dialog box—Custom Colors



Displays any custom colors you have already defined.

To change a custom color, click its color tile, and then specify different settings.

To define a new custom color, click an empty custom color tile, specify a different color, and then click Add To 
Custom Colors.

To use a color in i publish, click any color tile, and then click OK.



Edit Color dialog box—Define Custom Colors button



Displays more of the Color box, in which you can define a custom color.

If this button is unavailable, you are already viewing the custom color area.

To define a custom color, click in the color matrix. Or, specify the color by typing values in the 
hue/saturation/luminosity or the red/green/blue (RGB) boxes. Then, click Add To Custom Colors.



Edit Color dialog box—Color Wheel



Shows a color matrix. To define a custom color, click anywhere in this matrix, and then use the white to gray slider 
(to the right of the color matrix) to adjust the color's attributes.



Edit Color dialog box—White to Black slider



Adjusts the amounts of white and black in the selected color. To change the color, drag the slider arrow up or down.

The result of your choice is displayed in the Color/Solid box.



Edit Color dialog box—Color/Solid box



If you're running in 256 colors, the color on the left shows the amount of white and black in the color you specified. 
The color on the right shows how the color will look if you set 100% of the color with no white and black.

If you're running at 16-bit or 24-bit, you won't see any difference between the two colors.

To adjust the color, use the slider at the right of the color matrix. To specify that you want 100% of the color with 
no white or black, type ALT+O.



Edit Color dialog box—Hue



Specifies the hue for the selected custom color. A combination of hue/saturation, and luminosity can be used to 
define any color.

Hue is the value of a color wheel, where 0 is red, 60 is yellow, 120 is green, 180 is cyan, 200 is magenta, and 240 
is blue.

The easiest way to experiment with different colors is to click the color matrix.



Edit Color dialog box—Sat



Specifies the saturation level for the selected custom color. A combination of hue/saturation, and luminosity can be 
used to define any color.

Saturation is the amount of color in a specified hue, up to a maximum of 240.

The easiest way to experiment with different colors is to click the color matrix.



Edit Color dialog box—Lum



Specifies the luminosity of the selected custom color. A combination of hue, saturation, and luminosity can be used 
to define any color.

Luminosity is the brightness of the color.

The easiest way to experiment with different colors is to click the color matrix.



Edit Color dialog box—Red



Specifies the amount of red in the selected custom color. A combination of red, green, and blue values can be used 
to define any color. 

The easiest way to experiment with different colors is to click the color matrix.



Edit Color dialog box—Green



Specifies the amount of green in the selected custom color. A combination of red, green, and blue values can be 
used to define any color. 

The easiest way to experiment with different colors is to click the color matrix.



Edit Color dialog box—Blue



Specifies the amount of blue in the selected custom color. A combination of red, green, and blue values can be 
used to define any color. 

The easiest way to experiment with different colors is to click the color matrix.



Edit Color dialog box—Add To Custom Colors



Adds the custom color displayed in the Color/Solid box to the Custom Colors palette.

To use this color in i publish, click its color tile, and then click OK.



Edit Color dialog box—OK



Applies the selected color in i publish.



Custom Schemes (Fonts tab) Edit menu

Displays options for creating your own custom color and font schemes.

Click the picture below for details about each option. 
To display options on a different tab, click that tab in the picture.

More Information

How do you...

             Set up your own color scheme  
             Set up your own font scheme  
             Apply your own color scheme  
             Apply your own font scheme  
             Add a corporate color or font scheme standard to all copies of   i     publish  



Custom Schemes dialog box (Fonts tab)—Custom Fonts Scheme title



Shows the currently selected font scheme. You can create two different custom font schemes.
             How do you set up your own font scheme?  
             How do you apply your own font scheme?  



Custom Schemes dialog box (Fonts tab)—Font Size



Sets the font size to Small, Medium, or Large. 

To use a different size, click the box, and then click the size you want.

Tip: Typically, you would choose Large for the Title Font and Medium for the Body Font. You may need to 
experiment until you get the results you want.



Custom Schemes dialog box (Fonts tab)—Font face static text



Shows a sample of the selected font.



Custom Schemes dialog box (Fonts tab)—Font box



Shows your current custom font choice. 

To use a different font, click the box, and then click a different font. You can use any font on your system.



Custom Schemes dialog box (Fonts tab)—Title Font 



Specifies the font (listed below) that will be used for Titles.



Custom Schemes dialog box (Fonts tab)—Body Font



Specifies the font (listed below) that will be used for Body text.



Custom Schemes dialog box (Fonts tab)—Restore Defaults button



If this button is available, then the document you opened uses a custom font scheme that is different from your 
own custom font schemes. (Probably the document was created or edited by someone else.)

To do this: Do this:

Leave the document as is. Click OK.

Remove the custom font 
scheme and use your own 
custom font scheme 
instead.

Click Restore 
Defaults, and 
then click OK.

Make the document's font 
scheme your own custom 
font scheme.

Click Use As 
Default 
Settings, and 
then click OK.



Custom Schemes dialog box (Fonts tab)—Use As Default Settings button



If this button is available, then the document you opened uses a custom font scheme that is different from your 
own custom font schemes. (Probably the document was created or edited by someone else.)

To do this: Do this:

Leave the document as is. Click OK.

Remove the custom font 
scheme and use your own 
custom font scheme 
instead.

Click Restore 
Defaults, and 
then click OK.

Make the document's font 
scheme your own custom 
font scheme.

Click Use As 
Default 
Settings, and 
then click OK.



Custom Schemes (Colors tab) Edit menu

Displays options for creating your own custom color and font schemes.

Click the picture below for details about each option. 
To display options on a different tab, click that tab in the picture.

More Information

How do you...

             Set up your own color scheme  
             Set up your own font scheme  
             Apply your own color scheme  
             Apply your own font scheme  
             Add a corporate color or font scheme standard to all copies of   i     publish  



Custom Schemes dialog box (Colors tab)—Custom Color Scheme static text



Shows the currently selected color scheme. You can create two different custom color schemes.
             How do you set up your own color scheme?  
             How do you apply your own color scheme?  



Custom Schemes dialog box (Colors tab)—Color status box



Shows your current custom color choice. 

To use a different color, click Edit.



Custom Schemes dialog box (Colors tab)—Edit button



Opens the Color dialog box in which you can choose a different color to use for your scheme.



Custom Schemes dialog box (Colors tab)—Restore Defaults button



If this button is available, then the document you opened uses a custom color scheme that is different from your 
own custom color schemes. (Probably the document was created or edited by someone else.)

To do this: Do this:

Leave the document as is. Click OK.

Remove the custom color 
scheme and use your own 
custom color scheme 
instead.

Click Restore 
Defaults, and 
then click OK.

Make the document's color 
scheme your own custom 
color scheme.

Click Use As 
Default 
Settings, and 
then click OK.



Custom Schemes dialog box (Colors tab)—Use As Default Settings button



If this button is available, then the document you opened uses a custom color scheme that is different from your 
own custom color schemes. (Probably the document was created or edited by someone else.)

To do this: Do this:

Leave the document as is. Click OK.

Remove the custom color 
scheme and use your own 
custom color scheme 
instead.

Click Restore 
Defaults, and 
then click OK.

Make the document's color 
scheme your own custom 
color scheme.

Click Use As 
Default 
Settings, and 
then click OK.







View menu—None

Navigate menu—None

Insert menu



Locate File

The button or menu option you clicked is looking for the i publish CD (compact disc). Insert the CD, and then click 
OK.

Click the picture below for details about each option. 

More Information

How do you...

             Find a file  
             Add your picture from a disk (hard, floppy, or CD-ROM) so text wraps around it  
             Add your picture from a disk (hard, floppy, or CD-ROM) into a picture component  



Locate File dialog box—Location



Specifies where i publish is looking for the file. To change the location, click Browse.



Locate File dialog box—Browse



Opens a dialog box in which you can locate the i publish CD.



Insert Component Design menu

Displays a list of i publish components that you can insert. Click the one you want, click Insert, and then add text 
or pictures to the component.

Click the picture below for details about each option. 

More Information

How do you...

             Add a new component  

Concepts

             What's an intelligent component?  



Insert Component dialog box—Show Components For



Lists all components that are part of the currently selected component in the Show Components For box. 

To add a component, click its name, and then click Insert.



Insert Components dialog box—Show Components For



If you don't see the component you're looking for in the list, click Show Components For, and then click a different 
component to see its sub-components.



Insert Components dialog box—Insert button



Inserts the currently selected component into your document. i publish places it in your document based on the 
current layout.



OLE Object Insert menu

Embeds an OLE object in i publish. You can embed a new empty object or an existing file.

Click the picture below for details about each option. 

More Information

How do you...

             Embed an existing document  
             Embed a new, empty object  
             Edit an embedded object  

Concepts

             What is OLE (object linking and embedding)?  



OLE Object dialog box—Create New



Specifies to create a new object and embed it into the open i publish document.

i publish will embed the object, then you can enter information into it.



OLE Object dialog box—Create From File



Specifies to embed all or part of an existing file in the open i publish document.



OLE Object dialog box—Object Type



Lists the types of files that can be embedded.



OLE Object dialog box—Result



Describes the type of file you are embedding. 



OLE Object dialog box—OK



Embeds the object into your document using the settings you specified.



Symbol (Character Map) Insert menu

Inserts a special character or symbol (¼, ½, ä, ™, ©...) at the current location of the insert point in your 
document. You need to select a text component before you can insert a symbol.

Click the picture below for details about each option. 

More Information

How do you...

             Add a special character or symbol  



Symbol dialog box—Font combo box



Specifies the font whose characters and symbols you want to choose from.



Symbol dialog box—Characters to copy edit box



Displays the characters you have selected for copying.



Symbol dialog box—List of characters to insert



Displays the characters and symbols available for the selected font.



Symbol dialog box—Select button



Adds the selected character to the Characters To Copy box.



Symbol dialog box—Copy button



Copies the characters that are in the Characters To Copy box. 

You need to click this before you can paste these characters into your i publish document.



Symbol dialog box—status bar



Lists how to insert the selected symbol using the keyboard. This is a useful method if you often need to insert a 
particular symbol.

For example, to insert the symbol ©:

1. Make sure Num Lock is on.

2. Hold down the ALT key while pressing 0169 on the numeric keypad. 



Design menu



Custom Layout—Catalog Group (Document tab) Design menu, Layouts option

Changes the layout of your document.

Click the picture below for details about each option. 
To display options on a different tab, click that tab in the picture.

More Information

How do you...

             Change the layout of the entire document  
             Change the layout and look of your Web page  
             Change the layout and look of your onscreen presentation  



Custom Layout—Catalog Group (Document tab)—Organization



Specifies whether you are creating a booklet or individual sheets. 
If you choose Booklet, i publish adds a Banner component to the first page, and puts a Profile component 

on the last page.
If you choose Sheets, i publish adds a Banner component and a Profile component to each page.



Custom Layout—Catalog Group (Document tab)—Interior Pages



Specifies the layout, for example: 

Pictures 
At Top

Pictures 
Along Side



Custom Layout—Catalog Group (Document tab)—Number of Item Components



Specifies the number of Item components per page.



Custom Layout—Catalog Group (Document tab)—First page



Specifies whether the first page is different from the rest of the pages.
Same as Interior Pages—Uses the same layout for all pages in your document.
Cover Page—Makes the first page a cover page, and uses a different layout for the rest of the pages.
Single Large Picture—Places a large picture and text on the first page, and uses a different layout for the 

rest of the pages.
First Picture Emphasized—Places one large picture and one small picture on the first page, and uses a 

different layout for the rest of the pages.



Custom Layout—Catalog Group (Document tab)—OK



Closes the dialog box and applies your settings.



Custom Layout—Catalog Group (Component tab) Design menu, Layouts option

Changes the layout of your document.

Click the picture below for details about each option. 
To display options on a different tab, click that tab in the picture.

More Information

How do you...

             Change the layout of the entire document  
             Change the layout and look of your Web page  
             Change the layout and look of your onscreen presentation  



Custom Layout—Catalog Group (Component tab)—Banner Component



Sets the location of logo art in your Banner component, and whether the Banner contains just logo art, or logo art 
and text.



Custom Layout—Catalog Group (Component tab)—Profile Component



Sets the location of the image in your Profile component, and whether the Profile contains just an image or an 
image and text.



Custom Layout—Correspondence Group Design menu, Layouts option

Changes the layout of your document.

Click the picture below for details about each option. 

More Information

How do you...

             Change the layout of the entire document  
             Change the layout and look of your Web page  
             Change the layout and look of your onscreen presentation  



Custom Layout—Correspondence Group—Letterhead Layout



Specifies where the letterhead appears, and whether you have extra white space on the left side of your document. 
For example:

Letterhead at 
Top

Letterhead at 
Side

Letterhead at 
Top, Space on 

Left



Custom Layout—Correspondence Group—Columns



Specifies the number of columns for the main text (body text) in your document. For example:

1 column 2 columns



Custom Layout—Correspondence Group—Format



Specifies whether your document is a letter, fax, memo, or press release.



Custom Layout—Correspondence Group—Picture Placement



Specifies how pictures are placed on the page. 
Balanced on Page—Specifies to balance the pictures on the page to create an attractive layout. When you 

drop a picture on a paragraph, in most cases the picture will appear on the same page as the paragraph, however 
the picture may not be right next to the text.

Anchored to Text—Specifies that when you drop a picture onto a paragraph, the text will appear next to it. 
No matter where the text moves in the document, the picture will move with it.



Custom Layout—Report Group Design menu, Layouts option

Changes the layout of your document.

Click the picture below for details about each option. 

More Information

How do you...

             Change the layout of the entire document  
             Change the layout and look of your Web page  
             Change the layout and look of your onscreen presentation  
             Change the emphasis of a picture  



Custom Layout—Report Group—Cover Treatment



Specifies whether your report has a cover page, title page, or both. There are several layout options for title pages. 
Experiment until you find the cover treatment you like.



Custom Layout—Report Group—Columns



Specifies the number of columns for your main text. You can choose from 1, 2, 3, or 4 columns of text. For 
example:

1 column 2 columns



Custom Layout—Report Group—White Space on Left Side



Specifies to add a column on the left side of the page. The extra column cannot include text, but some pictures 
may extend into the white space depending on the emphasis setting. 

This option is only available for 1-column and 2-column layouts.

2 columns White Space 
on Left Side



Custom Layout—Report Group—Picture Placement



Specifies how pictures are placed on the page. 
Balanced on Page—Specifies to balance the pictures on the page to create an attractive layout. When you 

drop a picture on a paragraph, in most cases the picture will appear on the same page as the paragraph, however 
the picture may not be right next to the text.

Anchored to Text—Specifies that when you drop a picture onto a paragraph, the text will appear next to it. 
No matter where the text moves in the document, the picture will move with it.



Custom Layout—Newsletter Group (Document tab) Design menu, Layouts option

Changes the layout of your document.

Click the picture below for details about each option. 

More Information

How do you...

             Change the layout of the entire document  
             Change the layout and look of your Web page  
             Change the layout and look of your onscreen presentation  
             Change the emphasis of a picture  



Custom Layout—Newsletter Group (Document tab)—Stories and Columns



Specifies the number of columns in the underlying grid, the number of text columns, and where pictures are placed 
on the page.

Think of the underlying grid as vertical lines that split up the page into columns. Text and pictures can span any 
number of these columns, or there might be columns that are only used for white space. 

Experiment with different options until you get the results you want. If you don't like a choice, try another one or 
press CTRL+Z to undo it.



Custom Layout—Newsletter Group (Document tab)—Page Layout



If you're creating a document that will be copied on both sides of each page, turn on this option.



Custom Layout—Newsletter Group (Component tab) Design menu, Layouts option

Changes the layout of your document.

Click the picture below for details about each option. 

More Information

How do you...

             Change the layout of the entire document  
             Change the layout and look of your Web page  
             Change the layout and look of your onscreen presentation  
             Change the emphasis of a picture  



Custom Layout—Newsletter Group (Component tab)—Nameplate



Specifies what you want to appear at the top of your newsletter, and the alignment of it in relation to your 
newsletter text:

Experiment with different options until you get the results you want. If you don't like a choice, try another one or 
press CTRL+Z to undo it.

What's does Banner, Logo, and Logotype mean?

Banner—Your newsletter's title (text).
Logo—An image of some kind that represents your newsletter or company.
Logotype—Text converted to a graphic image, such as the IBM logotype. 



Custom Layout—Newsletter Group (Component tab)—Table of Contents



Specifies whether to show the table of contents, where to place it on the page, and whether to include a logo or 
logotype in the table of contents. 

To put the table of contents in the same column as the newsletter text, click "Aligned With Stories."
To make the table of contents span the full width of the page, click "Center-Aligned."
If you want the table of contents just below your Banner, click "Place at top of page." If you want it at the 

bottom of the page, uncheck this option.

What's does Banner, Logo, and Logotype mean?

Banner—Your newsletter's title (text).
Logo—An image of some kind that represents your newsletter or company.
Logotype—Text converted to a graphic image, such as the IBM logotype. 



Custom Layout—Newsletter Group (Component tab)—Headers and Footers



Specifies whether to show the headers and footers, the alignment of them in relation to your newsletter text, and 
whether to include a logo or logotype in the header. 



Custom Layout—Newsletter Group (Component tab)—Masthead



Specifies whether to show the masthead, and where it appears on your page. 

The masthead is the "credits" section of your newsletter, where you list your writers, editors, illustrators, and so 
on.



Custom Layout—Newsletter Group (Component tab)—Mailing Panel



Specifies:
Whether to show the mailing panel.
Where it appears on your page.
Whether to include a logo, logotype, or banner.
Whether it should be the only information on the last page of your newsletter.

What's does Banner, Logo, and Logotype mean?

Banner—Your newsletter's title (text).
Logo—An image of some kind that represents your newsletter or company.
Logotype—Text converted to a graphic image, such as the IBM logotype. 



Schemes (Fonts tab) Design menu

Using the schemes menu option, you can change the font, color, graphic effects, and paragraph schemes for your 
document. You can also set whether a scheme change affects the entire document, a single component, or multiple 
components.

Click the picture below for details about each option. 
To display options on a different tab, click that tab in the picture.

More Information

How do you...

Fonts tab

             Change the font scheme of the entire document  
             Change the font scheme for an intelligent component  
             Set up your own font scheme  
             Apply your own font scheme  

Colors tab

             Change the color scheme of the entire document  
             Change the color scheme for an intelligent component  
             Set up your own color scheme  
             Apply your own color scheme  
             Reference: RGB values of color schemes  

Effects tab

             Change the graphic effects scheme of the entire document  
             Change the graphic effects scheme for an intelligent component  

Paragraphs tab

             Change the paragraph scheme of the entire document  
             Change the paragraph scheme for an intelligent component  

Level tab

             Intensify the graphic effects scheme in your document  
             Increase the amount of color in your document  



Schemes dialog box (Fonts tab)—List



Lists all the font schemes that you can apply to your document.

Experiment—click a scheme, and then click Apply to see if you like the changes. If you don't like a choice, try 
another one or press CTRL+Z to undo it.

You can apply the selected scheme to the entire document or to a component.

1. Click the Advanced tab. 

2. Under Apply To, click what you want to apply the scheme to.



Schemes (Colors tab) Design menu

Using the schemes menu option, you can change the font, color, graphic effects, and paragraph schemes for your 
document. You can also set whether a scheme change affects the entire document, a single component, or multiple 
components.

Click the picture below for details about each option. 
To display options on a different tab, click that tab in the picture.

More Information

How do you...

Fonts tab

             Change the font scheme of the entire document  
             Change the font scheme for an intelligent component  
             Set up your own font scheme  
             Apply your own font scheme  

Colors tab

             Change the color scheme of the entire document  
             Change the color scheme for an intelligent component  
             Set up your own color scheme  
             Apply your own color scheme  
             Reference: RGB values of color schemes  

Effects tab

             Change the graphic effects scheme of the entire document  
             Change the graphic effects scheme for an intelligent component  

Paragraphs tab

             Change the paragraph scheme of the entire document  
             Change the paragraph scheme for an intelligent component  

Level tab

             Intensify the graphic effects scheme in your document  
             Increase the amount of color in your document  



Schemes dialog box (Colors tab)—List



Lists all the color schemes that you can apply to your document.

Experiment—click a scheme, and then click Apply to see if you like the changes. If you don't like a choice, try 
another one or press CTRL+Z to undo it.

You can apply the selected scheme to the entire document or to a component.

1. Click the Advanced tab. 

2. Under Apply To, click what you want to apply the scheme to.



Schemes (Effects tab) Design menu

Using the schemes menu option, you can change the font, color, graphic effects, and paragraph schemes for your 
document. You can also set whether a scheme change affects the entire document, a single component, or multiple 
components.

Click the picture below for details about each option. 
To display options on a different tab, click that tab in the picture.

More Information

How do you...

Fonts tab

             Change the font scheme of the entire document  
             Change the font scheme for an intelligent component  
             Set up your own font scheme  
             Apply your own font scheme  

Colors tab

             Change the color scheme of the entire document  
             Change the color scheme for an intelligent component  
             Set up your own color scheme  
             Apply your own color scheme  
             Reference: RGB values of color schemes  

Effects tab

             Change the graphic effects scheme of the entire document  
             Change the graphic effects scheme for an intelligent component  

Paragraphs tab

             Change the paragraph scheme of the entire document  
             Change the paragraph scheme for an intelligent component  

Level tab

             Intensify the graphic effects scheme in your document  
             Increase the amount of color in your document  



Schemes dialog box (Effects tab)—List



Lists all the graphic effects schemes that you can apply to your document.

Experiment—click a scheme, and then click Apply to see if you like the changes. If you don't like a choice, try 
another one or press CTRL+Z to undo it.

You can apply the selected scheme to the entire document or to a component.

1. Click the Advanced tab. 

2. Under Apply To, click what you want to apply the scheme to.



Schemes (Paragraphs tab) Design menu

Using the schemes menu option, you can change the font, color, graphic effects, and paragraph schemes for your 
document. You can also set whether a scheme change affects the entire document, a single component, or multiple 
components.

Click the picture below for details about each option. 
To display options on a different tab, click that tab in the picture.

More Information

How do you...

Fonts tab

             Change the font scheme of the entire document  
             Change the font scheme for an intelligent component  
             Set up your own font scheme  
             Apply your own font scheme  

Colors tab

             Change the color scheme of the entire document  
             Change the color scheme for an intelligent component  
             Set up your own color scheme  
             Apply your own color scheme  
             Reference: RGB values of color schemes  

Effects tab

             Change the graphic effects scheme of the entire document  
             Change the graphic effects scheme for an intelligent component  

Paragraphs tab

             Change the paragraph scheme of the entire document  
             Change the paragraph scheme for an intelligent component  

Level tab

             Intensify the graphic effects scheme in your document  
             Increase the amount of color in your document  



Schemes dialog box (Paragraphs tab)—List 



Lists all the paragraph schemes that you can apply to your document. 

Experiment—click a scheme, and then click Apply to see if you like the changes. If you don't like a choice, try 
another one or press CTRL+Z to undo it.

You can apply the selected scheme to the entire document or to a component.

1. Click the Advanced tab. 

2. Under Apply To, click what you want to apply the scheme to.



Schemes (Levels tab) Design menu

Using the schemes menu option, you can change the font, color, graphic effects, and paragraph schemes for your 
document. You can also set whether a scheme change affects the entire document, a single component, or multiple 
components.

Click the picture below for details about each option. 
To display options on a different tab, click that tab in the picture.

More Information

How do you...

Fonts tab

             Change the font scheme of the entire document  
             Change the font scheme for an intelligent component  
             Set up your own font scheme  
             Apply your own font scheme  

Colors tab

             Change the color scheme of the entire document  
             Change the color scheme for an intelligent component  
             Set up your own color scheme  
             Apply your own color scheme  
             Reference: RGB values of color schemes  

Effects tab

             Change the graphic effects scheme of the entire document  
             Change the graphic effects scheme for an intelligent component  

Paragraphs tab

             Change the paragraph scheme of the entire document  
             Change the paragraph scheme for an intelligent component  

Level tab

             Intensify the graphic effects scheme in your document  
             Increase the amount of color in your document  



Schemes dialog box (Level tab)—Colors Used



Sets what color (and how much color) each component gets: 
The farther to the right you set the slider, the more color is applied.
The "Off" setting makes the document black and white, no matter what color scheme you're using.

Experiment—click a setting, and then click Apply to see if you like the setting. If you don't like a choice, try another 
one or press CTRL+Z to undo it.



Schemes dialog box (Level tab)—Graphic Effects Used



Sets the thickness of lines, the amount of shading, and the number of items that receive a graphic effects 
treatment: 

The farther to the right you set the slider, the more complex the scheme (for example, lines may get 
thicker).

The "Off" setting removes the graphic effects scheme altogether.
Experiment—click a setting, and then click Apply to see if you like the setting. If you don't like a choice, try another 
one or press CTRL+Z to undo it.



Schemes (Advanced tab) Design menu

Using the schemes menu option, you can change the font, color, graphic effects, and paragraph schemes for your 
document. You can also set whether a scheme change affects the entire document, a single component, or multiple 
components.

Click the picture below for details about each option. 
To display options on a different tab, click that tab in the picture.

More Information

How do you...

Fonts tab

             Change the font scheme of the entire document  
             Change the font scheme for an intelligent component  
             Set up your own font scheme  
             Apply your own font scheme  

Colors tab

             Change the color scheme of the entire document  
             Change the color scheme for an intelligent component  
             Set up your own color scheme  
             Apply your own color scheme  
             Reference: RGB values of color schemes  

Effects tab

             Change the graphic effects scheme of the entire document  
             Change the graphic effects scheme for an intelligent component  

Paragraphs tab

             Change the paragraph scheme of the entire document  
             Change the paragraph scheme for an intelligent component  

Level tab

             Intensify the graphic effects scheme in your document  
             Increase the amount of color in your document  



Schemes dialog box (Advanced tab)—Apply To



Specifies whether the selected schemes should be applied to the entire document or to specific components.



Schemes dialog box (Advanced tab)—Clear Overrides First



Clears any formatting or schemes you've applied to individual components, so that your new formatting can be 
applied. (This is only relevant to what you select in the Apply To box.)



Tabs Design menu

Adds, deletes, and adjusts tab stops for the text in your document that is currently highlighted.

Note: You need to have a text component selected before you can set tabs.

Click the picture below for details about each option. 

More Information

How do you...

             Set tab stops  
             Remove one or all tab stops  
             Move a tab stop  
             Add dashes, dots, or lines to tab stops  
             Remove dashes, dots, or lines from tab stops  
             Change the unit of measurement to inches or centimeters  



Tabs dialog box—Tab Stop edit box



To create a new tab stop, type the measurement here. 

To change a tab stop in the list, click the incorrect tab stop, click Clear, and then type the correct tab measurement.



Tabs dialog box—Tab Stop list box



Lists all the tabs that are currently set for the selected paragraphs.

To clear a tab stop in the list, click the incorrect tab stop, and then click Clear.



Tabs dialog box—Leaders



To fill the empty space to the left of a tab stop with a leader line (dots, dashes, or a solid line), click option 2, 3, or 
4. The default setting is "None."



Tabs dialog box—Other Leader



To fill the empty space to the left of a tab stop with a repeating character of your choice, such as *, click Other and 
then type the character.



Tabs dialog box—Clear Overrides First



If the selected paragraphs have differing tab stops, click this option so that i publish clears all existing tab stops 
first, and then applies the new ones to the selected paragraphs.



Tabs dialog box—Tab Stops To Be Cleared



Lists the tab stop you just cleared, or lists "All" if you clicked Clear All.



Tabs dialog box—Set



Sets a tab stop for the selected paragraphs at the position you type in the Tab Stop Position box.



Tabs dialog box—Clear



Clears the selected tab stop position from the selected paragraphs.



Tabs dialog box—Clear All



Clears all tabs for the selected paragraphs.



Styles Design menu

Displays all styles that you can apply to the currently highlighted text in your document.

Note: You need to have a text component selected before you can apply a style to text.

Click the picture below for details about each option. 

More Information

How do you...

             Change the style of text in a component  



Styles dialog box—Styles box



Lists all the styles that you can apply to text.



Styles dialog box—Description



Describes the currently selected style, including paragraph alignment, font style, and so on.



Styles dialog box—Preview



Shows a sample of the effect that the selected style will have on your text.



Styles dialog box—Apply button



Applies the selected style to the highlighted text.



Adjust Picture Design menu

Lets you define the part of a picture you never want to see, and the portion that you always want to see. If a 
picture is within wrapping text, you can also set that picture's emphasis.

Note: You need to have a picture selected before you can adjust it.

Click the picture below for details about each option. 

More Information

How do you...

             Trim (crop) the picture  
             Change the emphasis of a picture  

Concepts

             How to get the most out of your pictures  



Adjust Picture dialog box—Image area



The red rectangle trims off the area that you never want to see. 
The green rectangle defines the portion of the picture that you always want to see. If the green rectangle 

is not the same shape as the space available for it in the current layout, i publish uses the portion inside the green 
rectangle plus some of the surrounding picture to fill the available space. 



Adjust Picture dialog box—Emphasis



If a picture is within wrapping text, you can change its visual importance on the page. This may change its size and 
its position in the document. 

Less Emphasis makes the picture smaller.
Normal makes the picture normal size. (This is what most pictures are by default.)
More Emphasis makes the picture larger.
Full Width At Bottom places the picture at the bottom of the page and makes it take up the entire width of 

the text. 
Full Width At Top places the picture at the top of the page and makes it take up the entire width of the 

text. 



Adjust Picture dialog box—Reset



Resets the two rectangles to the outside area of the picture. Then you can drag them again.



Right-click only



Edit Text Right-click menu for text components

Provides a quick way to edit text in Outline view. This feature is also useful when you're in document view, for 
example, when you're zoomed out to look at the whole page.

Click the picture below for details about each option. 

More Information

How do you...

             Edit text in outline view  



Edit text dialog box—Edit box



Type the text that you want to appear in the selected text component. When you're finished, click OK.



Edit text dialog box—OK



Inserts into the selected text component the text you just typed or edited.



Edit text dialog box—Cancel



Discards any new text you typed or changes you made and closes the Edit Text dialog box.





Path:
Main Menu



The first screen of the main menu is now is MAIN.RTF, because Dev points to it on the Help menu.



Path:
Add, replace, or change something



What do you want to add, replace, or change? 

             Text  
             Pictures (photo, logo, scanned image...)  
             Tables, charts, or diagrams  
             Elements for the Web  
             Components  
             What's an intelligent component?  
             The document  



--------------------------TEXT--------------------------
Path:
Add, replace, or change something
Text



What do you want to do?

             Preview your text before you add it  
             Add or replace text  
             Change the look of text  
             Move, copy, delete, or clear text  
             Make a list or change its look  
             Find or replace text  
             Check spelling  
             What you want to do isn't listed here  



Path:
Add, replace, or change something
Text
Add or replace text



Is there a place to put your text?

             A spot already exists  
             There is no place for my text  



Path:
Add, replace, or change something
Text
Add or replace text
A spot already exists



What do you want to do?

             Type text  
             Get text from another   i     publish   document  
             Get text from a disk (floppy, hard, CD-ROM)  
             Get text from the Internet or World Wide Web  
             Add a special character or symbol (¼, ½, ¾, ä, ™...)  
             Add special kinds of text (drop cap, caption, pull quote, table of contents...)  



What kind of text do you want to add?

             Drop cap  
             Caption to a picture  
             Pull quote  
             What's a pull quote?  
             Indented quote  
             Title  
             Table of contents  
             Header, footer, or other repeating text  
             What you want to do isn't listed here  



Path:
Add, replace, or change something
Text
Add or replace text
A spot already exists
Get text from another program



How much of the text do you want?

             Some of the text in the file  
             All of the text in the file  



Path:
Add, replace, or change something
Text
Change the look of text



What text do you want to change?

             Change all the text in the entire document  
             Emphasize a few words (bold, italic, underlined...)  
             Change all the text in a component (heading, caption, or body text...)  
             What's an intelligent component?  
             Make a list or change its look  
             What you want to do isn't listed here  



Path:
Add, replace, or change something
Text
Change the look of text
Text in the entire document



What do you want to do?

             Change text in a component that's longer than a paragraph  
             Change the font or font size  
             Change the indents, alignment, or spacing (paragraph scheme)  
             Change the color (color scheme)  
             What's a scheme?  



Path:
Add, replace, or change something
Text
Change the look of text
Text in a component



What do you want to do?

             Change the font or font size  
             Change the indents, alignment, or spacing  
             Change the color  
             Change the border, shading, or other graphic effects  



Path:
Add, replace, or change something
Text
Make or change the look of a list



What do you want to do?

             Add a bulleted list  
             Make a following paragraph with no bullet  
             What's a following paragraph?  
             Make a nested list  
             What's a nested list?  



Path:
Add, replace, or change something
Text
Move, copy, delete, or clear text



What do you want to copy, move, delete, or clear?

             Highlighted text  
             An entire text component  
             What's a component?  



 Path:
Add, replace, or change something
Text
Move, copy, delete, or clear text
Highlighted text



What do you want to do?

             Copy or move highlighted text in the same document  
             Copy or move highlighted text from another   i     publish   document  
             Delete highlighted text  



Path:
Add, replace, or change something
Text
Move, copy, delete, or clear text
An entire text component



What do you want to do?

             Copy or move a text component within a document  
             Copy or move a text component to another   i     publish   document  
             Reorganize components  
             Delete text and its intelligent component  



Path:
Add, replace, or change something
Text
Find or replace text



What do you want to do?

             Find text  
             Find and replace text  



Path:
Add, replace, or change something
Pictures



What do you want to do?

             Preview a picture before you add it  
             Add or replace a picture (clip art, logo, scanned image...)  
             Trim (crop) or resize a picture  
             Copy, move, or delete a picture  
             What you want to do isn't listed here  



Path:
Add, replace, or change something
Pictures
Add or replace a picture



Where do you want to put the picture?

             In a gray box or to replace another picture  
             In the middle of text  

             There is no place for my picture  



Path:
Add, replace, or change something
Pictures
Add or replace a picture
A spot already exists
In a gray box or replace another picture



How do you want to add or replace the picture?

             Add   i     publish   clip art  
             Add a picture from a disk (hard, floppy, CD-ROM)  
             Add a picture from the Web  
             Add a scanned picture or other TWAIN image  



Path:
Add, replace, or change something
Pictures
Add or replace a picture
A spot already exists
In the middle of text



How do you want to add or replace the picture?

             Add   i     publish   clip art so text wraps around it  
             Add a picture from a disk (hard, floppy, CD-ROM) so text wraps around it  
             Add a picture from the Web so text wraps around it  
             Add a scanned picture or other TWAIN image  



Where do you want to get clip art from?

             The   i     publish   Web site  
             The   i     publish   CD (compact disc)  

Note: This option is not available if you downloaded i publish from the Web.



Path:
Add, replace, or change something
Pictures
Trim (crop) or resize a picture



What do you want to do?

             Resize a picture  
             Trim (crop) the picture  
             What happens when you trim a picture in   i     publish?  
             What you want to do isn't listed here  



Path:
Add, replace, or change something
Pictures
Trim (crop) or resize a picture



What picture do you want to resize?

             A picture that text wraps around  
             Any other picture  



Path:
Add, replace, or change something
Pictures
Copy, move, or delete a picture



What do you want to do?

             Move a picture in the same document  
             Copy a picture in the same document  
             Copy or move a picture to another   i     publish   document  
             Delete a picture  



Where do you want to move the picture?

             In a gray box or to replace another picture  
             In the middle of text  

             There is no place for my picture  



Why do you want to move the picture?

             The picture is associated with the wrong text  
             The picture should be right next to the text it's associated with  
             The pictures should be balanced attractively on the page  
             You don't like the look of the page  



Why do you want to move the picture?

             The picture didn't go to the correct gray box or replace the correct picture  
             You don't like the look of the page  



Where do you want to copy the picture?

             To a gray box or replace a picture  
             In the middle of text  



Where do you want to put the picture?

             In a gray box or to replace another picture  
             In the middle of text  



Path:
Add, replace, or change something
Pictures
Copy, move, or delete a picture
Delete a picture



What do you want to delete?

             The picture, leaving the empty component behind  
             The picture and its component  



--------------------------WEB ELEMENTS--------------------------

Path:
Add, replace, or change something
Web elements



What do you want to do?

             Add a Web address (URL)  
             Add a way for readers to respond via email  
             What you want to do isn't listed here  



--------------------------TABLE, CHART, OR DIAGRAM--------------------------

Path:
Add, replace, or change something
Table, chart, or diagram



What do you want to do?

Note: Tables, charts, and diagrams work like pictures in i publish. You can either add them to a picture component 
or place them inside of text.

             Preview your table, chart, or diagram before you add it  
             Add or replace a table, chart, or diagram to your document  
             Change the look of the table, chart, or diagram  
             Copy, move, or delete a table, chart, or diagram  
             What you want to do isn't listed here  



Where do you want to put the table, chart, or diagram?

             In a gray box  
             In the middle of text  

             There is no place for your table, chart, or diagram  



What do you want to do with the table, chart, or diagram?

             Move or copy it to a gray box  
             Move or copy it to the middle of text  
             Delete a table, chart, or diagram  



--------------------------COMPONENTS--------------------------

Path:
Add, replace, or change something
Components



What do you want to do?

             Add a component  
             Create your own component  
             Change the look of a component  
             Copy, move, delete, or clear a component  
             What you want to do isn't listed here  



What do you want to add?

             A component that came with   i     publish  
             Add a component that you created  



What will the component be used for?

             Picture  
             Caption for a picture  
             Text  
             Title  
             Table of contents  
             Header, footer, or other repeating text  
             Table, chart, or diagram  
             What you want isn't listed here  



Path:
Add, replace, or change something
Intelligent components
Copy, move, delete, or clear a component



What do you want to do?

             Copy or move a component within a document  
             Copy or move a component from one   i     publish   document to another  
             Delete an intelligent component  



Is the component in the middle of text?

             Yes  
             No  



Is the component in the middle of text?

             Yes  
             No  



Path:
Add, replace, or change something
Intelligent components
Copy, move, delete, or clear a component
Delete a component



What do you want to delete?

             The text and pictures, leaving the empty component behind  
             The text, picture, and its component  



Path:
Copy, move, delete, or clear an object



What do you want to copy, move, delete, or clear?

             Text  
             Pictures (photo, logo, scanned image...)  
             Tables, charts, or diagrams  
             Intelligent components  
             What's an intelligent component?  







What do you want to do?

             Create a new document  
             Open an existing document  
             Create your own template  
             Create your own component  
             Delete a document  



What kind of document do you want to create?

Whether you're creating a document to be printed, as an onscreen presentation, or as a Web page, you start from 
the same point, but a few of the steps along the way differ slightly.

             Print document  
             Web page  
             Onscreen presentation  
             Document based on an existing document or template of your own  





Note: the next 2 procedures are almost identical



Create a new document

1. On the Start tab at screen left, click Create New.

2. Click a document group.

Note: If you want to create a print document, and then convert it to a Web page or an onscreen presentation, 
pick the type of print document you want, and i publish will take care of the rest.

3. Click a template and scheme set.

             What's a template?  
             What's a scheme set?  

As you click different templates and scheme sets, notice that the pages on the far right change.

4. Click Finish.

5. Add your information.

Text—Type text, add an entire text file, or drag pieces of text from your word processor, or the Web.
             How?  

Pictures—Add a picture from your computer, a floppy disk, a CD-ROM, a server, or the Web.
             How?  

Web elements—Add a Web address (URL) or a way for people to send you email.
             How?  

6. Save and publish your document.

You can print your document, publish it as an onscreen presentation, or publish it as a Web page.
             How?  

More Information

You can also...

             Change the look of your document  



Leave this paragraph here...for some (unknown) reason, it makes the next topic appear properly.



Create a Web page

1. On the Start tab at screen left, click Create New.

2. Click Web Page.

3. Click a template.

4. Add your information.

Text—Type text, add an entire text file, or drag pieces of text from your word processor, or the Web.
             How?  

Pictures—Add a picture from your computer, a floppy disk, a CD-ROM, a server, or the Web.
             How?  

Web elements—Add a Web address (URL) or a way for people to send you email.
             How?  

5. Publish your document as a Web page.

             How?  
6. Get ready to post your pages to the Web. (You only have to do this once.)
             How?  

7. Post your Web page to the World Wide Web.

             How?  
             What happens when you Publish for Web?  



Create an onscreen presentation

1. On the Start tab at screen left, click Create New.

2. Click Presentation.

3. Click a template.

4. Add your information.

Text—Type text, add an entire text file, or drag pieces of text from your word processor, or the Web.
             How?  

Pictures—Add a picture from your computer, a floppy disk, a CD-ROM, a server, or the Web.
             How?  

5. View your onscreen presentation.

             How?  



What document are you creating?

             A printed document  
             An onscreen presentation  
             A Web document  



Note: the next 2 procedures are almost identical



Create a new document based on an existing one or a template

1. Open the file or template you want to use.

             How?  
2. Save the document to a different name.

             How?  
3. Clear any text or pictures you don't want in the new document.

             How do you clear text?  
             How do you clear pictures?  

4. Add your information.

Text—Type text, add an entire text file, or drag pieces of text from your word processor, or the Web.
             How?  

Pictures—Add a picture from your computer, a floppy disk, a CD-ROM, a server, or the Web.
             How?  

Web elements—Add a Web address (URL) or a way for people to send you email.
             How?  

5. Save and publish your document.

You can print your document, publish it as an onscreen presentation, or publish it as a Web page.
             How?  

More Information

You can also...

             Change the look of your document  



Leave this paragraph here...for some (unknown) reason, it makes the next topic appear properly.



Open an existing document

1. On the File menu, click Open Existing Document.

2. Find the file you want, and then click Open.

Tip: If you worked on this document recently, it may be listed at the bottom of the File menu. If it is, you can open 
the document by simply clicking its name.



Create your own template

If you find yourself using the same layout and scheme settings in many documents, you can save a document to 
use as a template. 

1. On the Start tab at screen left, click Create New.

2. Click a document.

3. Click a template and a scheme set.

4. Click Finish.

5. Save your document.

More Information

What's next?

             Create a document based on your template  

You can also...

             Change the layout of the entire document  
             Change the schemes of the entire document  



Create a document using an existing document as a template

1. If you haven't already done so, create your own template.
             How?  

2. On the File menu, click Open Existing Document.

3. Find the file you want to use as a template.
             How?  

4. On the File menu, click Save As and save the document to a new name.

5. Clear any text or pictures you don't want in the new document.
             How do you clear text?  
             How do you clear pictures?  

6. Add your information.
Text—Type text, add an entire text file, or drag pieces of text from your word processor, or the Web.

             How?  
Pictures—Add a picture from your computer, a floppy disk, a CD-ROM, a server, or the Web.

             How?  
Web elements—Add a Web address (URL) or a way for people to send you email.

             How?  

More Information

What's next?

             Save and publish your document  





The next 2 topics are almost identical



i publish concepts 

The basics

             What's the big picture?  
             How do you get started in   i     publish  ?  
             What things does   i     publish   automate for you?  

Advanced 

             How does   i     publish   fit text and pictures on a page?  
             What programs support OLE?  

Text

             What text formats does   i     publish   import?  

Pictures

             How can you get the most out of your pictures?  
             What picture formats does   i     publish   import?  

Web or Onscreen presentations

             What happens when you Publish for Web?  

What is a...

             Banner  
             Color   

scheme

            
Component
             Curly   

quote
             Drop   

cap

            
Following 
paragraph
             Font   

scheme
             Graphic   

effects scheme

            
Intelligent 
component
             Layout  
             Logo  

            
Logotype

            
Mirrored 
margins

             Nested   
list
             OLE  

            
Onscreen 
presentation

            
Paragraph 
scheme

            
Paragraph style

            
Presentation
             Profile   

component
             Pull   

quote
             Scheme  
             Scheme   

set
             Sidebar  
             Style  

            
Template



Leave this paragraph here...for some (unknown) reason, it makes the next topic appear properly.



What's an intelligent component?

Intelligent components are the building blocks of an i publish document. In fact, they're what make i publish smart. 
Each picture and piece of text in every i publish document is contained in a component. You'll find components 
when you click around in a document. The borders around text and pictures outline components.

Each intelligent component knows its role—Picture, Item Heading, Item Text, and so on. A component knows 
whether it can contain words or images (or both) and what to do with them. For example, a sentence contained in 
an Item Heading component will look like a headline; that same text in an Item Text component will look very 
different.

Because all the text and pictures in a document are contained in intelligent components, i publish knows where to 
position text and pictures and how to format them depending on their function. For example, in a letter, i publish 
puts the Writer's Name and Writer's Title components at the bottom; in a memo, those same components pop to 
the top. Or, in a printed document, an email address is just another piece of text; but in a Web document, it's a link 
the user can click to send email.



What's a layout?

A layout provides a basic structure for your document, giving it an ordered look. i publish layouts, on the other 
hand, are interchangeable. Just make your best guess at picking a layout you like for the document you have in 
mind. It's easy to switch down the road.

Because the layout is truly automatic, you won't need to play with the size of pictures, the length of lines, or the 
position of text and pictures on the page. i publish layouts are smart enough to accommodate that extra picture or 
a lot of text, even adding pages if they're needed. And if you decide to cut things, the layouts know to shrink the 
components and construct the page so everything still fits nicely. 



What's a pull quote?

A pull quote is an excerpt from the main text set off in a larger font size, with a border, shading or some other 
decorative effect. It's used to add visual interest to the page and attract the reader's attention. In i publish a pull 
quote is an intelligent component. 



What's a Profile component?

Use a Profile component in a flier, catalog, onscreen presentation, and some Web pages to feature a person in your 
company. You might include a descriptive sentence or two and a picture along with contact information. For 
example, in a real estate flier about a property, you could profile the listing agent. A Profile component appears at 
the bottom of a sheet layout, and on the last page of a booklet layout. 



What's a sidebar?

A sidebar presents non-essential information related to a main topic. Typically, sidebars are set off from the main 
body with a box or shading. For example, an article on nutrition might have a sidebar on how to tell when you need 
vitamins. In i publish a sidebar is an intelligent component.



What do curly quotes look like?

Use curly quotes rather than straight quotes to give a polish to your document.



What's a nested list?

A nested list is subordinate to the main list and is indented to show that relationship. 

Here's an example:

Oranges are a good source of nutrition, including:
Vitamin C
Folic Acid
Bananas are also nutritious, but they're higher in calories than oranges. 



What's a following paragraph?

A following paragraph provides details about the bulleted item above it. 

Here's an example:

Oranges
They're a great source of nutrition, including: Vitamin C and Folic Acid.

Bananas
They're nutritious, but they're higher in calories than oranges. 



How to get the most out of your pictures

Trimming a picture

When you trim a picture in i publish, you're telling the program what you want to happen with your picture so 
i publish can make it look good in the design you've chosen.

Trimming has two functions, both of which define what part of your picture the user sees: 

The red rectangle trims off the area that you never want to see. 
The green rectangle defines the portion of the picture that you always want to see. If the green rectangle 

is not the same shape as the space available for it in the current layout, i publish uses the portion inside the green 
rectangle plus some of the surrounding picture to fill the available space. 

Change the emphasis of a picture

If a picture is in the middle of a body of text, you can change its visual importance on the page—that is, make it 
bigger or smaller. This may also change its position in the document.

             How?  



What's the difference between delete and clear?

Deleting removes the text, picture, and the intelligent component itself from your document.
Use Delete when you no longer want the component in your document—for example, you could delete a caption 
component if you decided the picture no longer needed it. 

Clearing removes the selected text or picture only, and leaves the empty component in your document.
Use Clear when you want to replace a piece of text or a picture with other text or another picture. 



What's OLE?

Using object linking and embedding (OLE), you can create an object in one program and add it to a document in 
another program such as i publish. For example, you can create a diagram in Visio or a spreadsheet in Excel, and 
then embed it in your i publish file. 

Then, if you want to update the object, you just double-click it in your i publish document. 



What programs support OLE? 

To see a list, click Object on the Insert menu. 

Some OLE programs support linking and embedding for all types of objects. Others support only embedding for 
certain types of objects and only linking for others. If a program doesn't support one or the other for a particular 
kind of object, the OLE program won't be listed when you click Paste on the Edit menu.



What type of file are you trying to import?

             Text file  
             Picture file  



Picture formats i publish imports

For details about specific file compatibility issues, refer to the Release Notes on the i publish CD.

File 
Format extension

Adobe PhotoDeluxe .psd 
files

.psd

Adobe PhotoShop 3.0 
for 1-bit, 8-bit, and 24-
bit files

Note: i publish does not 
support CMYK files.

.psd

Animated GIF (i publish 
imports the first frame 
only)

.gif

Encapsulated PostScript 
raster (i publish imports 
the bitmap preview 
only.)

.eps 

.dcs

GIF .gif

JPEG (Joint Photographic 
Experts Group)

.jpg

.jpeg

Kodak FlashPix .fpx

Kodak PhotoCD .pcd

Microsoft FAX .awd

PC Paintbrush .pcx
.dcx

Portable Network 
Graphics 
(PNG is a new image 
compression format 
specifically for the Web.)

.png

Seattle FilmWorks .sfw

TIFF (Tagged Image File 
Format) without LZW 
compression

.tif

TIFF CCITT and other fax 
formats (one bit per 
pixel formats)

.tif

TWAIN images (typically 
created using a scanner)

—

Windows bitmaps .bmp
.dib
.rle

Windows Metafiles and .wmf



Enhanced Metafiles .emf

Tip: You can also drag and drop Windows shortcut files into i publish, as long as the shortcut points to a file in one 
of the formats listed above.



Text formats i publish imports

File 
Format extension

ASCII .txt

HTML files (i publish will 
import the text without 
including referenced 
pictures or styles.)
             Want to know   

more?

.htm

.html

Lotus AmiPro .sam

Microsoft Word for 
Windows 6.0, 7.0/'95

Note: i publish does not 
import Word 97 (8.0) 
files.

.doc

.dot

Microsoft Works 3.0 .wps

Microsoft Write .wri

Rich text format .rtf

WordPerfect 5.x, 6.0, 
and 6.1

.doc

.wpd

Tip: You can also drag and drop Windows shortcut files into i publish, as long as the shortcut points to a file in one 
of the formats listed above.



The next 2 topics are almost identical



What's a paragraph style? 

Just as intelligent components give structure to every i publish document, paragraph styles organize and format 
blocks of text that contain more than one paragraph. Use a style when you want to differentiate levels of headings, 
create bulleted lists, make quoted passages of text stand out, and so on.

Paragraph styles give i publish direction on how you want each block of text to look. When you apply a style (from 
the toolbar), i publish assigns characteristics to the text based on the current schemes and layout. 

Schemes specify the fonts and font sizes of the paragraph style, the color, and so on.
Layouts govern the text's position on the page. (For example, a layout might direct a heading to span two 

columns.) 
That way, when you change a scheme or layout, the paragraph styles respond accordingly.

How i publish imports text with styles

When you bring in text from another program, such as a word processor, i publish honors the intent of the style. 
i publish does not, however, keep the fonts, font sizes, and so on, because it applies the formatting of the i publish 
schemes you chose. For example, i publish will apply its own Heading 1 style to all headings that you styled as 
first-level headings in your word processor.

How styles impact Web pages and onscreen presentations

Paragraph styles also give i publish information about how to publish a Web page or onscreen presentation. For 
example, if you divide a long report into sections by applying the Section Head style to your main headings, 
i publish puts each section on its own Web page or screen. 



Leave this paragraph here...for some (unknown) reason, it makes the next topic appear properly.



What's a drop cap?

A drop cap (such as the one shown below) is a large, decorative letter used to introduce a block of text and create 
some visual interest on the page. 



The next 2 topics are almost identical



The big picture

The four tabs in the control window (at screen left) of i publish reflect the general order you'll work with documents 
in i publish:

1. Start—Start a new document and then choose a document group and layout, or open an existing document. 

2. Grab—Drag and drop text and pictures from your computer, the World Wide Web, or the i publish Clip Gallery 
onto your document. You can also import text and pictures using the Text File and Picture File buttons. 

3. Design—Experiment! Try different layouts. Apply different schemes (color, font, paragraph, and graphic effects) 
to change the entire look and feel of your document effortlessly.

4. Publish—From here you can publish your document—in print, as an onscreen presentation, or as Web pages for 
a company intranet or the World Wide Web.

You can try these concepts out using the i publish QuickStart. (On the Help menu, click Quick Start.)



Leave this paragraph here...for some (unknown) reason, it makes the next topic appear properly.



What happens when you Publish for Web?

When you use the Publish For Web option, i publish converts your i publish file (.did) into multiple HTML files 
(.htm). When you publish your Web pages:

To My Computer, i publish saves your files in the folder you set (using the Configure tab). 
You can view your pages using i publish or your Web browser.

To the Internet, i publish takes your Web pages and the pictures they use and copies all of it to the Web 
server (such as AOL, CompuServe®, and so on) that you set using the Configure tab.

Then, your Web pages will be available on the World Wide Web for people to visit.



What's a scheme?

You've heard the term "color scheme"—a set of colors, usually chosen by a professional designer, that are designed 
to work well together. i publish uses this familiar idea with four design schemes that together create the look and 
feel of every document:

color
fonts and font sizes
graphic effects, such as borders and shading
paragraph alignment and indents as well as spacing between paragraphs



What's a color scheme?

A color scheme is a professionally-chosen set of coordinated colors that i publish applies to a document—to text, 
graphic elements (such as borders and lines), and backgrounds (such as in a sidebar). You choose the color 
scheme that works best for your document; i publish knows where and how to apply it. 

You can change the colorfulness of your document using the Color Scheme Level. As you raise the level, you 
increase the document's colorfulness. If you set the level at zero, you'll get just black and white. You can also 
increase colorfulness by changing the Graphic Effects level, as it provides elements—such as borders and shading—
that i publish applies color to.



What's a graphic effects scheme?

A graphic effects scheme, which adds such elements as lines, shading, and borders, serves two main purposes in 
your document—to organize it and to decorate it. You choose the graphic effects scheme that works best for your 
document; i publish knows where and how to apply it.

You can accentuate the graphic effects in your document using the Graphic Effects Level. As you raise the level, 
you give the graphic effects more visual importance on the page; this has the added effect of increasing the 
colorfulness of your document because the graphic effects provide something for i publish to apply color to. (Note 
that if you set the level at zero, your document will get no graphic effects at all.)



What's a paragraph scheme?

Paragraph schemes control paragraph alignment and indents, as well as the spacing between paragraphs. You 
choose the paragraph scheme that works best for your document; i publish knows where and how to apply it. 
Some paragraph schemes work in tandem with paragraph styles. For example, to see the large first letter (drop 
cap) in Formal paragraph schemes, you must apply a lead paragraph style (Section Lead, Body Lead, and Deck 
Lead) to see the drop cap in your document.



What's a font scheme?

Font schemes control which fonts (and their relative sizes) are used in a document, including: all the headings, 
subheadings, body text, captions, and so on. It also controls which bullet graphics are used for your text. When 
you change a font scheme, i publish changes all the fonts in your document. You choose the font scheme that 
works best for your document; i publish knows where and how to apply it.

Some font schemes (such as "Times and Arial") use two fonts:
The first font is used for headings and titles.
The second font is used for body text. 

Other schemes (such as "All Arial") apply the same font throughout your document.



What's an onscreen presentation?

In the past, presentations were developed on 35mm slides or printed on overhead transparencies and shown as a 
slide show. Now, presentations such as these can be created and delivered on your computer. Each screen makes 
one point and in i publish you move from screen to screen by clicking back and next arrows. 



What's a scheme set?

A scheme set is made up of settings from all four schemes that together contribute to the document’s look: 
A color scheme, which applies one or more colors in appropriate places on a page.
A font scheme, which sets both fonts and font sizes.
A graphic effects scheme, which controls borders, shading, and lines.
A paragraph scheme, which sets text alignment and spacing. 

When you start a document, you choose a scheme set. However, you’re not locked into your choice. You can still 
change each scheme individually to get just the right look for your document.



What's a template?

A template is made up of:
A layout that controls the arrangements of text and pictures on the page.
Components that contain each picture and piece of text you put in your document.

When you start a document, you choose a template as your starting point. However, you’re not locked into your 
choice. You can still:

Change the layout to rearrange the text and pictures on the page.
Add components to or delete components from your document.



What are mirrored margins?

Most books have different left and right pages. For example, the page numbers might be in the upper-left corner of 
left pages, and upper-right corner of right pages. In addition, there's usually extra space for the inside margins so 
that there's enough room for the binding. These are called mirrored margins.

You can have i publish mirror the margins of any newsletter.



What is indicia?

Newsletters can have mailing panels, so you can send them through the mail without an envelope. Indicia is the 
markings used for stamps or postal information.



What are sample documents?

             How do you view a sample document?  

File Description
Uses this 
template

Sample 1 Spectacular San 
Francisco travel flier

Flier

Sample 2 Spacious Home real 
estate flier

Catalog

Sample 3 Protect your home—
insurance booklet

Catalog

Sample 4 Kauffman and Klause 
Staffing Solutions flier

Catalog

Sample 5 Party Time flier Flier

Sample 6 Baseball Camp 1997 
Season flier

Flier

Sample 7 Black and White Gala 
invitation

Report

Sample 8 Saving with your 
Employer—A discussion 
of Employer Pension and 
Profit Sharing

Report

Sample 9 Golden Years—A One-
Day Seminar to Help You 
Start Saving Now flier

Flier

Sample 10 Jewelry brochure Brochure

Sample 11 Fitness Monthly—
Newsletter for members 
of Fitness Athletic Club

Newsletter

Sample 12 World Trade Newsletter Newsletter

Sample 13 Angelino's Gourmet Fare 
"The Gourmet Gazette" 
newsletter

Newsletter

Sample 14 Angelino's Gourmet Fare 
catalog

Catalog

Sample 15 Angelino's Gourmet Fare 
"Story of Garlic" report

Report

Sample 16 Angelino's Gourmet Fare 
letter

Correspondence
—Letter

Sample 17 Angelino's Gourmet Fare 
memo

Correspondence
—Memo

Sample 18 Angelino's Gourmet Fare 
press release

Correspondence
—Press Release

Sample 19 Angelino's Gourmet Fare 
"Savory Cheeses" flier

Flier

Sample 20 Angelino's Gourmet Fare 
brochure 

Brochure



What's does Banner, Logo, and Logotype mean?

Banner—Your newsletter's title (text).
Logo—An image of some kind that represents your newsletter or company.
Logotype—Text converted to a graphic image, such as the IBM logotype. 

In a newsletter, you can change whether i publish displays your banner, logo, or logotype. (On the Design menu, 
click Layouts, click Custom Layout, and then click the Component tab.)



Fitting your text and pictures on an i publish page

i publish has its own methods for fitting things on the page as it lays out text and pictures for you. For documents 
with small components that hold short blocks of text, if the page gets a little tight, here are some of the techniques 
i publish uses to fit things on the page:

Reduce font size and leading. 
Reduce picture size.
Adjust how much of the picture is shown. i publish can only do this you've given i publish additional 

information about your picture by trimming it. 
             How?  

When things get really tight, i publish alerts you with a red border around the components that may be 
contributing to the problem.

             What else is there to know about your document when it's too full?  
             How can you get text and pictures to fit better on the page?  
             When is fitting an issue?  



How can you get text and pictures to fit better on the page?

If your document is too full, you may solve the problem by making just one of the changes below. 
Edit your text. 
Reduce the height of your picture.

             How?  
Change the level of your graphic effects scheme. 

             How do you change the level of a graphic effects scheme?  
Try a different graphic effects, paragraph, or font scheme altogether.

             How do you change a scheme?  
Try a different layout that gives more room to the component that is too full.

             How?  
Use a different picture.
Delete components to give more vertical space to the component that is too full.

             How?  

             How do you turn off the red rectangles?  



When is fitting an issue?

When your page is very full, it usually means that one of the components is too tall to fit well on the page. You can 
tell your document is too full when:

You see red borders around components that may be contributing to the fit problem.
The black marker in the Status fit indicators at the bottom of your screen are in the red.
Pictures or text are cut off and i publish draws a red border around those components.



Popup from Main Menu



i publish automates many of the tasks you typically do yourself in other programs, so you may not find things you 
want to do listed here. You can find out for sure using the Index in Help. 

Click the Index button above and type the term you're looking for.



Popup from Add, replace, or change Text



i publish automates many of the tasks you typically do yourself in other programs, so you may not be able to 
change things you usually can. For example, based on the layout you choose, i publish takes care of indenting text, 
formatting paragraphs, resizing text areas as you add or remove text, even adding and deleting pages as needed, 
and so on.

But check the Index to see if you can make the changes you want:

Click the Index button above and type the term you're looking for.



Popup from Change the look of text



i publish automates many of the tasks you typically do yourself in other programs, so you may not be able to 
change things you usually can. For example, based on the layout and schemes you choose, i publish takes care of 
setting the font and size, the indents and alignment of text, and so on.

But check the Index to see if you can make the changes you want: 

Click the Index button above and type the term you're looking for.



Popup from Add or replace pictures



i publish automates many of the tasks you typically do yourself in other programs, so you may not be able to 
change things you usually can. Based on the layout and schemes you choose, i publish establishes the size and 
location of pictures, borders, the space around pictures, and so on.

But check the Index to see if you can make the changes you want: 

Click the Index button above and type the term you're looking for.



Popup from Trim (crop) or resize a picture



i publish automates many of the tasks you typically do yourself in other programs, so you may not be able to 
change things you usually can. Based on the layout and schemes you choose, i publish establishes the size and 
location of pictures, borders, the space around pictures, and so on.

But check the Index to see if you can make the changes you want: 

Click the Index button above and type the term you're looking for.



Popup for add, replace, or change a table, chart, or diagram



i publish automates many of the tasks you typically do yourself in other programs, so you may not be able to 
change things you usually can. Based on the layout and schemes you choose, i publish establishes the size and 
location of tables, charts, or diagrams, the borders that appear, and so on.

But check the Index to see if you can make the changes you want: 

Click the Index button above and type the term you're looking for.



Popup for Add, replace, or change a component



If you don't find what you're looking for on this list, try using the Index to find it:

Click the Index button above and type the term you're looking for.



Path:
View menu



If you don't find what you're looking for on this list, try using the Index to find it:

Click the Index button above and type the term you're looking for.



Path:
Doclook menu



i publish automates many of the tasks you typically do yourself in other programs, so you may not be able to 
change things you usually can. For example, based on the schemes you choose, i publish takes care of:

The text indent, paragraphs format, size of text areas.
The size and location of pictures, the borders, the space around pictures.
The font and size, location of text on the page.

But check the Index to see if you can make the changes you want: 

Click the Index button above and type the term you're looking for.



Path:
Add Web elements



If you don't find what you're looking for on this list, try using the Index to find it:

Click the Index button above and type the term you're looking for.







The next 2 topics are almost identical



What do you want to do?

             Change the layout or look of your print document  
             Change the layout and look of your onscreen presentation  
             Change the layout and look of your Web page  
             Find out which schemes are applied to your document  



Leave this paragraph here...for some (unknown) reason, it makes the next topic appear properly.



What do you want to change?

             The type of document (such as switch a letter to a fax)  
             The layout (columns, orientation...)  
             Colors, fonts, paragraph settings, or graphic effects  
             The margins (top, bottom, left, or right)  
             The paper orientation (portrait or landscape)  
             The starting page number  
             What you want to do isn't listed here  



What do you want to change?

             Colors  
             Fonts and font sizes  
             Paragraph scheme  
             What's a paragraph scheme  
             Graphic effects scheme  
             What's a graphic effects scheme  



What do you want to do?

             Choose another set of   i     publish   fonts (font scheme)  
             What's a font scheme?  
             Change just the font size  
             Set up your own font scheme  
             What's a font scheme?  
             Apply your own font scheme  



What do you want to do?

             Use a pre-defined layout  
             Choose individual layout options to create a custom layout  
             Reorganize components on the page  



What do you want to do?

             Choose another set of   i     publish   colors  
             Set up your own color scheme  
             What's a color scheme?  
             Apply your own color scheme  







Change the font scheme of the entire document

This changes the font and font sizes of all text components in your document.

1. Click the Design tab at screen left.

2. Click the Fonts tab.

3. Scroll through the list of schemes, and then experiment by clicking until you find the one you like. 
Every time you click a scheme, your document reflects the changes.

If you don't like the new scheme, 
press CTRL+Z to undo it or click a 
different scheme.

More Information

What if...

             You want to change the font in just one part of your document?  

You can also...

             Find out what schemes and layout are applied to your document  

Concepts

             What's a font scheme?  



Change the paragraph scheme of the entire document

Paragraph schemes set the following for your entire document: indents, alignment, and whether some paragraphs 
have drop caps.

1. Click the Design tab at screen left.

2. Click the Paragraphs tab.

3. Scroll through the list of schemes, and then experiment by clicking until you find the one you like. 
Every time you click a scheme, your document reflects the changes.

If you don't like the new scheme, 
press CTRL+Z to undo it or click a 
different scheme.

More Information

What if...

             You want to change the paragraph scheme in just one part of your document?  

You can also...

             Find out what schemes and layout are applied to your document  

Concepts

             What's a paragraph scheme?  



Change the color scheme of the entire document

This changes the colors applied to the text and graphic effects in your document.

1. Click the Design tab at screen left.

2. Click the Colors tab.

3. Scroll through the list of schemes, and then experiment by clicking until you find the one you like. 
Every time you click a scheme, your document reflects the changes.

If you don't like the new scheme, 
press CTRL+Z to undo it or click a 
different scheme.

More Information

What if...

             The colors look the same after you change them?  
             You want to change the colors in just one part of your document?  
             You have a black and white printer, so you don't want to use color in your document?  

You can also...

             Find out what schemes and layout are applied to your document  
             Make the document more colorful  

Concepts

             What's a color scheme?  



Change the graphic effects scheme of the entire document

This changes the borders and shading applied to your document.

1. Click the Design tab at screen left.

2. Click the Effects tab.

3. Scroll through the list of schemes, and then experiment by clicking until you find the one you like. 
Every time you click a scheme, your document reflects the changes.

If you don't like the new scheme, 
press CTRL+Z to undo it or click a 
different scheme.

More Information

What if...

             The graphic effects look the same after you change them?  

You can also...

             Find out what schemes and layout are applied to your document  
             Intensify the graphic effects scheme in your document  

Concepts

             What's a graphic effects scheme?  



Change the layout of the entire document

1. Click the Design tab at screen left.

2. Click the Layouts tab.

3. Scroll through the list of layouts, and then experiment by clicking until you find the one you like. 
Every time you click a layout, your document reflects the changes.

Tip: If you want more control over the individual layout settings, try creating a custom layout.

             How?  
If you don't like the layout, 

just click a different one.
If you want to go back to 

the layout that was used when you 
last saved the document, on the 
Design menu, click Layouts, and 
then click Original Layout.

More Information

You can also...

             Find out what schemes and layout are applied to your document  



Choose individual layout options to create a custom layout

1. On the toolbar, click the Layout button, shown below.

2. At the bottom of the list, click Custom Layout.
3. Click the options you want, and then click OK.

You can show or hide some components. To see if that's possible for your document, click the Components tab, 
and then click "Don't show" in the drop-down list.

Tip: If you want to know more about a particular option, click the Help button in the dialog box.

If you want to go back to the layout 
that was used when you last saved 
the document, on the Design menu, 
click Layouts, and then click 
Original Layout.

More Information

You can also...

             Find out what schemes and layout are applied to your document  



Change the type of document (such as switch a letter to a fax)

1. Click the Design tab at screen left.

2. Click the Layouts tab.

3. Scroll through the list of layouts, and then experiment by clicking until you find the one you like. 
Every time you click a layout, your document reflects the changes.

If you don't like the layout, just 
click a different one.



Change one or more schemes for the entire document

1. Click the Design tab at screen left.

2. Click one of these tabs: Colors, Effects, Fonts, or Paragraphs.

3. Scroll through the list of schemes, and then experiment by clicking schemes until you find the one you like. 
Every time you click a scheme, your document reflects the changes.

4. Repeat steps 2 and 3 for any other schemes you want to change.

If you don't like the new scheme, 
press CTRL+Z to undo it or click a 
different scheme.



Intensify the graphic effects scheme in your document

The graphic effects scheme level sets the thickness of lines, the amount of shading, and the number of items that 
receive a graphic effects treatment:

The higher the number, the thicker the lines, and the more complex the scheme.
"Off" removes the graphic effects scheme altogether.

1. Click the Design tab at screen left.

2. Click the Effects tab.

3. Watch your document as you drag the Scheme Level slider to get the effect you want. 
If you drag the slider to the far left (Off), your document has no graphic effects in it.
If you don't see an effect in your document, drag the slider further to the right.
If the change is too subtle, drag the color slider further to the right as well.

             How?  



Increase the amount of color in your document

The color scheme level sets what color and how much color each component gets:

The higher the number, the more color applied.
"Off" makes the document black and white, no matter what color scheme you're using.

1. Click the Design tab at screen left.

2. Click the Colors tab.

3. Watch your document as you drag the Scheme Level slider to get the effect you want. 
If you drag the slider to the far left (Off), your document has no colors in it; it's just black and white.
If you don't see an effect in your document, drag the slider further to the right.
If the change is too subtle, drag the graphic effects slider further to the right as well.

             How?  



Set up your own font scheme 

You can create a font scheme using two fonts from your system.

1. On the Edit menu, click Custom Schemes.

2. Click the Fonts tab.

3. Under Title Font, under Size, click the size you want for the title, such as Large.

4. Under Title Font, under Font, click the font you want to use for all titles in your document.

5. Under Body Font, under Size, click the size you want for the body text, such as Medium.

6. Under Body Font, under Font, click the font you want to use for all body text in your document.

7. Click OK.

More Information

How do you...

             Apply your own font scheme  



Apply your own font scheme to the entire document

You can create a font scheme using two fonts from your system.

Note: If you want to show your document on other computers, you may need to copy those font files to the other 
computers. (Make sure you check your font license agreement to ensure your license allows you to copy the fonts.)

If you don't copy the font files, and the new computer does not have the font you used for the scheme, Windows 
will substitute a font, such as Courier.

Click the font scheme button (shown below) on the toolbar, and then click Custom Font Scheme 1 or 2.

More Information

How do you...

             Set up your own font scheme  



Set up your own color scheme

You can create a color scheme using a color you choose.

1. On the Edit menu, click Custom Schemes.

2. Click the Colors tab.

3. Next to the color tile, click Edit.

4. Click the color you want in the Basic Colors, or click Define Custom Colors to define a custom color.
             How do you create a custom color?  

5. Click OK.

More Information

How do you...

             Apply your own color scheme  



Apply your own color scheme to the entire document

You can create a color scheme using a color you choose.

Click the color scheme button (shown below) on the toolbar, and then click Custom Color Scheme 1 or 2.

More Information

How do you...

             Set up your own color scheme  



Change your document's page orientation (portrait or landscape)

1. On the File menu, click Print Setup.

2. Under Orientation, click Portrait or Landscape.

3. Click OK.



Change the document margins

1. On the File menu, click Page Setup.

2. If you are creating a newsletter, and it will be bound into a book (copied on both sides of the paper), click 
Mirrored Margins to add a check.

i publish will then automatically add a bit more to the inside margins to accommodate the binding.
             What are mirrored margins?  

3. Under Margins, enter how much space you want for each margin.

4. Click OK.

To return to the default page 
margins, click Reset Defaults.



Printing on letterhead

1. By default, many i publish documents contain components for your company logo and company name. Since 
you don't want to duplicate your letterhead, delete those components.

             How?  
2. On the File menu, click Page Setup.

3. If your letterhead area is at the top of the page, under Margins, increase the top margin. If your letterhead is 
along the left side of the page, increase the left margin.

4. Print your document.
             How?  

Tip: Don't waste your expensive letterhead! If you're not positive that the margins you changed are the right 
amount, try the following: 

1. Print your document on plain paper.
             How?  

2. Place your letterhead behind the plain paper copy and hold it up to the light. Are your margins the right size?



Change the starting page number for your document

You can change the starting page number for your document. For example, if your report will be bound with a 
number of other reports, you can set what you want for the first page.

By default, i publish does not number the cover page or the title page of a report; it numbers the first page of your 
body text as page 1. 

1. On the File menu, click Page Setup.

2. Under Page Numbering, enter what you want to add or subtract from the normal page numbering.

3. Click OK.



Change the font size for the entire document

1. On the toolbar, click the button below.

2. Click the font size you want.



Add a corporate color or font scheme standard to all copies of i publish

Note: If you've used a font other than those provided with Windows, you may need to put those font files on other 
computers. (Make sure you check your font license agreement to ensure your license allows you to distribute the 
fonts.)

Make the new color or font scheme standard available to your company:

1. Create your corporate color or font scheme.
             How?  

2. Save the document that contains the new scheme.

3. Put the i publish file (.did) on a server or send it through email to everyone that needs the new color or font 
scheme standard.

Apply the new color or font scheme standard to each copy of i publish:

1. On the Edit menu, click Custom Schemes.

2. Click the Colors or the Fonts tab (depending on which scheme you're adding).

3. Click Use As Default Settings to add the corporate color or font scheme to that copy of i publish.

4. Click OK.







Drag and drop text 

When you drag and drop, i publish copies the text from the source and pastes it into i publish.

1. If you haven't already done so, click the highlighted text, and then hold the left mouse button. Move your 
pointer to the text component where you want the text.

2. Watch your pointer.

Can't drop it. Can drop it.

If you change your mind during the drag, just drag it back where it came from.

To undo the drop, press CTRL+Z. If 
you start to drag something, and 
then change your mind, with your 
finger still on the mouse button, 
press the ESC key.



Drag and drop between two programs

You can drag and drop text, pictures, or files between programs using the Windows taskbar. When you drag and 
drop, i publish copies the text or picture from the source and pastes it into i publish.

1. Open the word-processing program that contains the text. 
Or, if you want to use a text or picture file, open the Windows Explorer.

2. Highlight the text you want, and then click the text and hold the left mouse button. 
Or, if you want to use a file, click the file and hold the left mouse button. 

3.

4. Move your pointer to the component in your document where you want the text, picture, or file, and then drop 
it.

To undo the drop, press CTRL+Z. If 
you start to drag something, and 
then change your mind, with your 
finger still on the mouse button, 
press the ESC key.



The next 2 topics are almost identical



Drag and drop rules

In general, when you drop text or pictures onto a page without selecting where it goes first, i publish tries to put it 
where it looks best. Pay attention to your mouse pointer for a clue about where you can drop your content.

Can't drop it. Can drop it.

Dropping text

In most cases, dropping text within existing text works as you would expect from a word processor. In certain 
cases, however, i publish makes intelligent guesses:

If you drop an Internet address onto existing text, i publish creates a Web address (URL) component 
which, when you convert your document to a Web page, will automatically create a link to that URL.

If you drop a large amount of text onto a text component that can only hold a small amount of text, such 
as a title, i publish assumes you want the text to be descriptive text and drops it there instead.

Dropping a picture onto text

When you drop a picture onto long text, i publish creates a Picture component inside the text.

Dropping text onto a picture

When you drop text onto a picture, i publish creates a Caption component for that picture. 

To undo the drop, press CTRL+Z. If 
you start to drag something, and 
then change your mind, with your 
finger still on the mouse button, 
press the ESC key.



Leave this paragraph here...for some (unknown) reason, it makes the next topic appear properly.



Drag and drop a text or picture file

1. Move your pointer over the file you want, and then click and hold the left mouse button.

2. Move your pointer to a text or picture component.

3. Watch your pointer.

Can't drop it. Can drop it.

To undo the drop, press CTRL+Z. If 
you start to drag something, and 
then change your mind, with your 
finger still on the mouse button, 
press the ESC key.



Move intelligent components around on the page

1. Point to the component, and then click the right mouse button. 

2. On the popup menu, point to Select, and then click the component you want to move.

3. Click the component and (holding the left mouse button) move your pointer to the spot where you want it. 
Release the mouse button. (Watch your pointer.)

Can't drop it. Can drop it.

Shortcut: Press SHIFT+F10 to display the popup menu.



Drag and drop a new component on the page

1. If you haven't already done so, click the Design tab, and then click the Components tab.

2. Click the component picture, and then hold the left mouse button.

3. Move your pointer to the exact spot in your document where you want the component.

4. Watch your pointer.

Can't drop it. Can drop it.

To undo the drop, press CTRL+Z. If 
you start to drag something, and 
then change your mind, with your 
finger still on the mouse button, 
press the ESC key.



Drag and drop pictures or text from the Internet or the Web

1. On the File menu, click Open Web Page.

2. Type the Web site you want to use.

3. Select the picture or text and drag it to the component in your document where you want it.

4. Watch your pointer.

Can't drop it. Can drop it.

5. To return to the 
i publish tabs, 
click this button as 
many times as 
necessary. (It's at 
the top of the 
screen.)

To undo the drop, press CTRL+Z. If 
you start to drag something, and 
then change your mind, with your 
finger still on the mouse button, 
press the ESC key.



Zoom in to your document

To zoom in, press CTRL+SHIFT and the = (equals) key.
To zoom out, press CTRL and the - (minus) key.
To go back to the previous zoom setting, press F9.



Start an additional copy of i publish

1. Click the Windows Start button at the bottom of your screen.

2. Point to Programs, point to i publish, and then click i publish.



Scroll to another page

Click the scroll bar to 
see additional pages.

Or, to see more than one page at a time, click the zoom box at the top of the screen, and then click 25% 
or smaller.



Close a program that is open at screen left

Click this 
button at the top of 
the screen until you 
see tabs again.



Type a specific Web address

1. On the File menu, click Open Web Page.

2. Type the Web site that you want, and then click OK.



See a Web page or program full screen

1. On the View menu, click Control Window Only.

2. When you want to see your document again, click Document and Control Windows on the View menu.



Find a file

1. Click the Look In box, and then click where your file is located, either on the hard disk, a floppy disk, CD-ROM, 
or network drive.

2. Double-click folders to open them until you find the folder that contains your file.

3. Click your file, and then click Open.



Find a file in Windows Explorer

1. Click this box, and then click a drive.

             What if you don't see this box?  
2. To open a file or folder, double-click it.

To move up one folder in 
the hierarchy, click this 
button.



Connect to the Web

Some companies have a constant connection to the Web, while others (like home offices) may need to use a dialer 
to connect to the Web.

For specific details, see your Internet service provider's (ISP) documentation.



Install a newer version of Microsoft Internet Explorer

1. Click here to go to a Web site to download the newest version of Internet Explorer.
http://www.design-intelligence.com/
download/compsoft.html

2. Depending on your Web browser settings, you may be asked whether you want to open it or save it to disk. If 
you want to save it, click Save It To Disk, and then click OK. In the Save As box, find the folder where you want 
the self-extracting file to go, and then click Save.
The self-extracting file is different from the installed program—it's just a compressed version of all of the files. 
You can delete the self-extracting file after you install the program, so it's a good idea to put self-extracting files 
in a place you clean out often, such as in a C:\Temp folder.

3. When the self-extracting file is finished downloading, open Windows Explorer. (Click the Windows Start button, 
point to Programs, and then click Windows Explorer.)

4. Locate the file you just downloaded, and double-click it.
The Internet Explorer installation starts.

5. After you've finished installing the Internet Explorer, you can either delete the self-extracting file or archive it in 
case you need to reinstall the program.



Install the Microsoft Web Publishing Wizard 1.1

If you have the i publish CD (compact disc), you can install the Microsoft Web Publishing Wizard from the CD. If 
you don't have the CD, you can download the Microsoft Web Publishing Wizard from the Design Intelligence Web 
site.

1. Click here to go to a Web site to download it: 
http://www.design-intelligence.com/
download/compsoft.html

2. Depending on your Web browser settings, you may be asked whether you want to open it or save it to disk. If 
you want to save it, click Save It To Disk, and then click OK. In the Save As box, find the folder where you want 
the self-extracting file to go, and then click Save.
The self-extracting file is different from the installed program—it's just a compressed version of all of the files. 
You can delete the self-extracting file after you install the program, so it's a good idea to put self-extracting files 
in a place you clean out often, such as in a C:\Temp folder.

3. When the self-extracting file is finished downloading, in Windows Explorer, locate the file you just downloaded, 
and double-click it.
The Microsoft Web Publishing Wizard installation starts.

4. After you've finished installing the Microsoft Web Publishing Wizard, you can either delete the self-extracting file 
or archive it in case you need to reinstall the program.



Create a custom color

1. In the color box, click the color you want to change.

2. Click Define Custom Colors, and then enter new values in either the RGB (red, green, blue) or HLS (hue, 
saturation, and luminescence) color models.

3. Click Add to Custom Colors.



Set up your Internet Service Provider (ISP) 

Before you can post your Web pages to the Web, you need to set up your Internet or Web Service Provider's (ISP) 
information.

1. Talk to your ISP and gather the following information:
What is your user name and password?
In most cases, these should be the ones you use to connect to the Web.
Do you use "Dial-up Networking" (a modem) to access the Internet? Or do you use a "Local Area Network 

(Intranet)"?
What is the URL or Internet Address to which you will post your pages? 
Many ISPs use this format:
http://www.provider.com/~username
What should your main HTML page be called? index.html? default.html? Should the page's name be all 

lower case?
2. On the File menu, click Publish For Web.

3. Click the Configure tab.

4. Under Internet, click New.

5. Follow the instructions onscreen to set up your ISP. 



Set where on the Internet you will post your Web pages

When you publish your HTML files to the Web, the Web address (URL) for your page is automatically generated by 
i publish, using the choices you make on the Configure tab, and also using your Internet service provider's (ISP) 
URL. 

For example, a URL might be generated like this:

1. If you haven't already done so, on the File menu, click Publish For Web.

2. Click the Configure tab.

3. Under Internet, click your Web site or click New to set up a new Web site.
If you're setting up a new Web site, the Microsoft Web Publishing Wizard 1.1 opens. Follow the instructions 
onscreen. (You may need to get this information from your Internet service provider (ISP).)



Set where on your computer your Web pages or onscreen presentation are stored

1. If you haven't already done so, on the File menu, click Publish For Web or Publish For Screen.

2. Click the Configure tab.

3. Under My Computer, click Browse and then locate the folder you want to use.

4. Check "Remove These Files Before Publishing" if you want i publish to remove any files with the listed 
extensions before publishing your Web pages.
If you're going to copy your Web pages to a server or other location, this ensures that the only files in the 
folder are the latest ones. 



Use Internet Explorer or Netscape Navigator to view your Web pages

To set up a browser to use with i publish

You only need to set up your browser once.

1. If you haven't already done so, on the File menu, click Publish For Web.

2. Click the Browsers tab.

3. Click Add.

4. Do one of the following:
If you want to use your default browser, click Registered Browser, and then click OK.
If you want to use a different browser, click Browse. Locate the browser you want, and then click OK.
Typically, Internet Explorer is installed in: C:\Program Files\Plus!\Microsoft Internet\Iexplore.exe
Typically, Netscape Navigator is installed in: C:\Program Files\Netscape\Navigator\Program\Netscape.exe
i publish adds your browser to the list.

To use a browser to view your Web pages

1. Click the Publish tab.

2. Click the My Computer box, and then click your browser.



What type of document are you working on?

             Agenda  
             Announcement  
             Correspondence (letter, memo, fax, or press release)  
             Newsletter  
             Report  
             Resume  



Set where pictures, sidebars, and pull quotes appear

1. On the toolbar, click the Layout button, shown below.

2. At the bottom of the list, click Custom Layout.
3. Click how you want i publish to place the pictures, sidebars, and pull quotes:

Balanced on Page—Specifies to balance the pictures, sidebars, and pull quotes on the page to create an 
attractive layout. 

When you drop a picture, sidebar, or pull quote on a paragraph, in most cases it will appear on the same 
page as the paragraph, however the picture, sidebar, or pull quote may not be right next to the text.

Anchored to Text—Specifies that when you drop a picture, sidebar, or pull quote onto a paragraph, the text 
will appear next to it. No matter where the text moves in the document, the picture, sidebar, or pull quote will 
move with it.
4. Click OK.



Set where pictures, sidebars, and pull quotes appear

1. On the toolbar, click the Layout button, shown below.

2. At the bottom of the list, click Custom Layout.
3. Under Stories and Columns, click how you want i publish to place the pictures, sidebars, and pull quotes.
4. Click OK.





These procedures are only in the index—you can't get to them through the path (unless it's mentioned on a More Info 
screen)



Tabs



What do you want to do with tab stops?

             Set tab stops  
             Remove one or all tab stops  
             Move a tab stop  
             Add dashes, dots, or lines to tab stops  
             Remove dashes, dots, or lines from tab stops  
             Change the unit of measurement to inches or centimeters  



Set tab stops

1. Highlight the text that you want to add the tab stops to.

2. On the Design menu, click Tabs.

3. To remove any pre-existing tab stops before setting new ones, click Clear All.

4. Under Tab Stop Position, type a position for the tab stop.

5. Click Set.

6. Repeat steps 4 and 5 until you've set all of the tab stops you want, and then click OK.

More Information

What if...

             You want to remove a tab stop?  
             You want to move a tab stop?  
             You want to change your unit of measurement to inches or centimeters?  
             Your tabs were the way you wanted, but now they're not?  



Remove one or all tab stops

1. Highlight the text that contains the tab stop you want to remove.

2. On the Design menu, click Tabs.

3. Under Tab Stop Position, click the tab stop you want to remove, and then click Clear.
Or, to remove all tab stops for the highlighted text, click Clear All.

4. Click OK.

If you want the tab stops back, 
press CTRL+Z before you do 
anything else.

More Information

What if...

             You want to move a tab stop?  



Move a tab stop

1. Highlight the text that contains the tab stop you want to move.

2. On the Design menu, click Tabs.

3. Under Tab Stop Position, click the tab stop you want to move, and then click Clear.

4. Under Tab Stop Position, type the new position for the tab stop.

5. Click Set.

6. Click OK.

If you want to undo the move, 
press CTRL+Z before you do 
anything else.

More Information

What if...

             You want to remove a tab stop?  
             You want to add dashes, dots, or lines (leaders) to a tab stop?  
             You want to remove dashes, dots, or lines (leaders) from tab stops?  
             You want to change your unit of measurement to inches or centimeters?  
             Your tabs were the way you wanted, but now they're not?  



Add dashes, dots, or lines (leaders) to tab stops

1. Highlight the text that you want to add leaders to.

2. On the Design menu, click Tabs.

3. Under Tab Stop Position, type the position for the tab stop.

4. Under Leader, click the style you want for the tab stop. 

To set your own leader style, click Other, and then type the character you want to use, such as *.

5. Click Set.

i publish automatically adds leaders to all of the tab stops applied to the highlighted text.

6. Click OK.

More Information

What if...

             You want to remove dashes, dots, or lines (leaders) from tab stops?  



Remove dashes, dots, or lines (leaders) from tab stops

1. Highlight the text that has the leader tab stop you want to change.

2. On the Design menu, click Tabs.

3. Under Tab Stop Position, click the tab stop you want to change.

4. Under Leader, click None.

5. Click OK.



OLE procedures



What do you want to do?

             Embed an existing document  
             Embed and create a new object  
             Edit an embedded object  
             What is OLE (object linking and embedding)?  



Is the object...

             Part of another file?  
             In its own file?  



Embed a new, empty object in i publish

1. Click where you want to put the OLE object:
If you want it to appear next to a paragraph, click the paragraph.
If you want it to be in a picture component or to replace an existing picture, click the picture component.

2. On the i publish Insert menu, click OLE Object.

3. Click Create New, then under Object Type, click the object (such as Paintbrush Picture) that you want to embed.

4. Click OK.
The server application starts automatically.

5. When you're finished creating the object, on the server program's File menu, click Close or Exit & Return to 
display i publish.

More Information

You can also...

             Embed an existing file in   i     publish  
             Embed a portion of a file in   i     publish  



Embed an existing file in i publish

1. Click where you want to put the OLE object:
If you want it to appear next to a paragraph, click the paragraph.
If you want it to be in a picture component or to replace an existing picture, click the picture component.

2. On the i publish Insert menu, click OLE Object.

3. Click Create From File. 

4. Click Browse, and then find the file that contains the object you want to use.

5. Click OK.

More Information

You can also...

             Embed and create a new object  
             Embed a portion of a file in   i     publish  



Embed a portion of a file in i publish

1. Click where you want to put the OLE object:
If you want it to appear next to a paragraph, click the paragraph.
If you want it to be in a picture component or to replace an existing picture, click the picture component.

2. In the server program, highlight the portion of the file you want to embed.

3. On the server program's Edit menu, click Copy. 

4. On the i publish Edit menu, click Paste Special.

5. Click OK.

More Information

You can also...

             Embed and create a new object  
             Embed an existing file in   i     publish  



Edit an embedded object in i publish

Double-click the object
When you're finished making changes, on the server program's File menu, click Close or Exit & Return.



Uninstall i publish

1. Click the Windows Start button, point to Settings, and then click Control Panel.

2. Double-click Add/Remove Programs.

3. In the list, click i publish, and then click Add/Remove.

4. Open Windows Explorer. If you see this folder, delete it: C:\Program Files\Design Intelligence\ipublish.



Add a Profile component

1. Point to a blank part of the document, and then click the right mouse button. 

2. On the popup menu, point to Insert Component, and then click Profile.
If the Profile component is not on the list, it means the Profile component is not available for the layout or type 
of document you're creating. 

Shortcut: Press SHIFT+F10 to display the popup menu.

More Information

Concepts

             What's a profile?  



Add a price, Web address, or flash line

1. Point to the text portion of an Item component, and then click the right mouse button. 

2. On the popup menu, point to Insert Component, and then click Item Flash Line, Item Price, or Item Web 
Address.
If the component you want is not on the list, it means that component is not available for the layout or type of 
document you're creating. 

Shortcut: Press SHIFT+F10 to display the popup menu.



Add a sidebar

1. Point to the text where you want the sidebar, and then click the right mouse button. 

2. On the popup menu, point to Insert Component, and then click Sidebar.
If the Sidebar component is not on the list, it means sidebars are not available for the layout or type of 
document you're creating. 

Shortcut: Press SHIFT+F10 to display the popup menu.



Search specific text only

1. Highlight the text you want to search.

2. On the Edit menu, click Find or Replace.

More Information

You can also...

             Find text in your document  
             Find and replace text in your document  



Change the language dictionary i publish uses to check spelling

1. On the Edit menu, click Options.

2. Click the Spelling tab.

3. Click the Language box, and then click the language you want to use.

4. Click OK.

More Information

You can also...

             Check the document for misspellings  



Search for straight quotes and replace them with curly quotes

When you type text, i publish automatically converts straight quotes to curly (or smart) quotes. When you insert a 
document from another program, i publish does not change straight quotes to curly quotes. To fix this:

1. On the Edit menu, click Replace.

2. In the Find What box, type a 
straight quote mark.

"

3. In the Replace With box, 
type a straight quote mark.

"

It seems strange, but having i publish to replace straight quotes with straight quotes tells i publish that it's OK 
to modify the imported text, so i publish will convert the straight quotes to curly ones.

4. Click Replace All.

5. Click Cancel to close the dialog box.



Options dialog box procedures



Automatically open the last document you worked on 

You can set i publish to open the last document you worked on whenever you restart the program.

1. On the Edit menu, click Options.

2. Under General Options, check Reload Last Document At Startup.

3. Click OK.



See if you have too much text or too many pictures

You can tell your document is too full when:

You see red borders around components that may be contributing to the fit problem.
The black marker in the Status fit indicators at the bottom of your screen are in the red.
Pictures or text are cut off and i publish draws a red border around those components.

             What does   i     publish   do to fit your text and pictures?  

See how full a page is getting

Look at the bottom of the screen:

Text Fit 
Status

Graphics Fit 
Status

As the black line moves closer to the red area, your page is getting more dense. 
             What can you do if the black line is in the red area?  
             When is fitting an issue?  

Outline in red all components contributing to the fit problem

When your page is very full, and one of the Fit Status meters (at the bottom of the screen) is in the red, i publish 
draws a thin red line around all components that may be contributing to the fit problem. 
             What can you do if components are outlined in red?  

To turn this option off:

1. On the Edit menu, click Options.

2. Under General, click When Document Is Overfit, Highlight Contributing Components.

3. Click OK.



Edit user or company information

i publish uses this information to automatically fill in some components in your document.

1. On the Edit menu, click Options.

2. Click the User Info tab.

3. Change the information that's incorrect, and then click OK.



Set the default file locations

You can set where i publish looks for clip art, text files, and i publish documents.

1. On the Edit menu, click Options.

2. Click the File Locations tab.

3. Under Type, click the type of file whose default location you want to change.

4. Click Modify.

5. Find the folder in which you typically keep that type of file.

6. Click OK.

7. When you're finished changing file locations, click OK.



Change spelling options

1. On the Edit menu, click Options.

2. Click the Spelling tab.

3. Do any of the following:
To speed up spelling, turn off Always Suggest Spelling Alternatives. (Make sure there is no checkmark.)
To change the rules for the types of errors i publish looks for, click the options under Rules to add or 

remove checkmarks.
To change the language dictionary, click the Language box, and then click a different language.
To change the personal dictionary you're using, under Personal Dictionary, click Browse. Find the dictionary 

file (ending in .dic) you want, and then click OK.
4. Click OK.

More Information

You can also...

             Check the document for misspellings  



Change your unit of measurement to inches or centimeters

1. On the Edit menu, click Options.

2. On the General tab, click the Measurements box, and then click Inches or Centimeters.

3. Click OK.



Get going with QuickStart

The i publish QuickStart is a short interactive tour designed to introduce you to the important concepts of this new 
approach to personal publishing. 

i publish is different from other programs, so taking the time up front to understand the differences will boost your 
productivity.

On the Start tab of the control window (at screen left), click i publish QuickStart.



Set page options 

1. On the File menu, click Page Setup.

2. Under Paper, set the paper size.

3. Under Orientation, set whether you want the page to be landscape or portrait.

4. Under Margins, change the default values if you want your margins to be smaller or larger.

5. Under Page Numbering, enter what you want as the starting page number for the document.

Note: For reports, i publish does not number the cover page or the title page; it numbers the first page of your 
body text as page 1. 

6. If you are creating a newsletter that will eventually be printed on both sides of the paper, click Mirrored Margins 
to add a checkmark.

             What are mirrored margins?  
7. Click OK.

More Information

You can also...

             Print your document  



Print more than one copy of a document

1. On the File menu, click Publish To Printer. 

2. In the Number Of Copies box, type the number of copies you want to print.

3. Click OK.



Print to a non-default printer

1. Click the Windows Start button, point to Settings, and then click Printers.

2. Using the Windows Explorer, drag your i publish file (which ends in .did) onto the printer icon.

i publish prints the entire file using your default printing settings.



Print using the Run dialog box

1. Click the Windows Start button, and then click Run.

2. In the Open box, type the following, where c:\personal\myfile.did is the name and location of your i publish 
document.

ipublish.exe /p c:\personal\myfile.did



Print your Web page the way it appears onscreen

When you use Publish To Printer, i publish prints documents as they appear in the document window only. To print 
your Web pages as they appears after you Publish For Web, you must first publish them, and then print them one at 
a time.

1. View your document as a Web page.
             How?  

2. Click a blank part of the page.
i publish uses HTML frames to keep your navigation (or table of contents) in a fixed position on your page. 
When you click the page, you're telling i publish which frame you want to print.

3. On the File menu, click Print.
i publish prints the currently displayed Web page.

4. Click a jump (link) to display one of your other Web pages. Repeat steps 2 and 3 until you've printed all of your 
Web pages.



Print your onscreen presentation the way it appears onscreen

When you use Publish To Printer, i publish prints documents as they appear in the document window only. To print 
your onscreen presentation as it appears after you Publish For Screen, you must open the HTML files in your Web 
browser, and then print.

1. Publish your document as an onscreen presentation.
             How?  

2. View your onscreen presentation in your default browser.
             How?  

3. In your Web browser, on the File menu, click Print.

4. Click an arrow to view the next screen.

5. Repeat steps 3 and 4 for each page in your onscreen presentation.



Hide or show parts of the screen (toolbar, status bar, ...)

You can hide or show the main toolbar, format toolbar, navigation toolbar, and status bar.

             What options are on the toolbars?  

To hide part of the screen

On the View menu, click the name of the item you want to hide. 
(When hidden, there is no checkmark next to an item.)

To show part of the screen

On the View menu, click the name of the item you want to show.
(When showing, there is a checkmark next to an item.)



Delete a document

1. Open Windows Explorer. (Click the Windows Start button, point to Programs, and then click Windows Explorer.)

2. Open the folder where you saved the document.

3. Click the document you want to delete, and then press the DELETE key.

4. In the confirmation box, click Yes.

If you didn't find it there...

1. On the Windows Explorer Tools menu, point to Find, and then click Files or Folders.

2. In the Named box, type: *.did

This searches for all i publish document files (which end with .did).

3. Click the Look In box, and then click the drive letter associated with your computer (typically C:).

4. Click Find Now.

5. If necessary, scroll through the list that appears to locate the file you want to delete.

6. Click that file, and then press the DELETE key.



RGB values of color schemes

If you embed an object in i publish, you may want to make the colors in the embedded object match the primary 
color in your color scheme. For example, if you have a pie chart from Excel embedded in i publish, you can make 
the primary color in your chart match your i publish color scheme.

             How can you tell which color scheme you're using  

No color scheme

Color Scheme Red Green Blue

Black and 
White

0 0 0

One accent color

Color Scheme Red Green Blue

Gray 60 60 60

Olive Green 100 88 45

Brown 54 24 5

Dark Blue 7 21 71

Rust 141 38 1

Medium Blue 81 91 133

Burgundy 93 0 30

Two accent color

Color Scheme Red Green Blue

Brown and 
Mint Green

77 31 26

Blue and Gold 3 26 50

Purple and 
Green

66 14 90

Turquoise and 
Purple

1 153 155

Salmon and 
Green

0 66 62

Colored Text

Color Scheme Red Green Blue

All Sage Green 19 53 34

All Bright Blue 56 65 121

All Purple 66 14 90

Brown Text 
with Mint 
Green

77 31 26

Note: This list only applies to color schemes included with i publish; it does apply to color schemes that were 
purchased from the i publish Web site or from other sources.



i publish automates many tasks for you...

i publish automates many of the tasks you typically do yourself in other programs, so you may not be able to 
change things you usually can. (This is because i publish controls the design.) For example, i publish takes care of:

Font formatting, such as kerning, leading, and so on.
Paragraph formatting, such as line spacing, indenting text, resizing text areas as you add or remove text, 

widow control, orphan control, and so on.
Repeating text, by automatically making your title and footer text match.
Document formatting, such as page breaks, and so on.



Change how you view files in the Windows Explorer box

You can customize the Windows Explorer box to match your preferences.

1. On the Grab tab, click From Windows Explorer.

2. On the View menu of the Windows Explorer box, make sure that Toolbar is checked. (If it isn't, click Toolbar to 
check it.)

3. On the toolbar, click the icon that matches how you prefer to view your files.

Large 
icons

Small 
icons

List File 
details

4. On the View menu, click Options.

5. On the Folder tab, choose the option that you want:
If you want to only see one window open, click "Browse folders by using a single window that changes as 

you open each folder."
If you like multiple windows open to show the hierarchy of folders and files, click "Browse folders using a 

separate window for each folder."
6. Click OK.



Undo a scheme applied to a particular component

When you drag and drop a scheme onto a component, i publish formats that component with a scheme that may 
be different from the rest of the document. You can easily make all the formatting in your document the same.

1. On the Design menu, click Schemes.

2. Click the Advanced tab.

3. In the Apply To box, make sure it says The Entire Document.

4. Click Clear Overrides First to add a checkmark.

5. On the Colors, Effects, Fonts, or Paragraphs tab, click the scheme you want to apply to the entire document.

6. Click OK.



Send an i publish document through email

You can send an i publish document through your electronic mail (email) program. 

1. With your document open, on the File menu, click Send.

This displays your email program and a message containing the i publish file.
Note: If this feature is not available, then your email program does not support Messaging Application Program 
Interface (MAPI).

2. Send the email message the same way you would any other message.

View an i publish file sent through email

Open the email message, and then double-click the i publish icon.



Add a page

i publish automates many of the tasks you typically do yourself in other programs, and adding pages is one of 
them.

i publish adds a page when there's no more room for the text and pictures on the current page. 



Delete a page

i publish automates many of the tasks you typically do yourself in other programs, and deleting pages is one of 
them. 

i publish deletes pages when you cut enough text (or pictures) that the additional page is no longer needed.



View sample documents to decide on the layout you want

1. Make sure the i publish CD is in your CD-ROM drive.

2. Click the Start tab, and then click Sample Documents.

3. Find the sample document you want to use.

4. Do one of the following:
To view or use a sample document, click Open.
To see what the sample document looks like as Web pages or as an onscreen presentation, click View Web 

Version or View Screen Version. 
When you're 
finished, click this 
to return to the 
list of sample 
documents.
If you like the way the Web page or the onscreen presentation looks, click Open so you can modify it to your 
own text and pictures. Then, when you're finished, publish it as Web pages or as an onscreen presentation.

5. Clear any text or pictures you don't want in the new document.
             How do you clear text?  
             How do you clear pictures?  

6. Add your information.
Text—Type text, add an entire text file, or drag pieces of text from your word processor, or the Web.

             How?  
Pictures—Add a picture from your computer, a floppy disk, a CD-ROM, a server, or the Web.

             How?  
Web elements—Add a Web address (URL) or a way for people to send you email.

             How?  
7. Save and publish your document.
             How?  

More Information

What's next?

             Change the look of your document  



Viewing your onscreen presentation full screen in your Web browser

1. Click the Windows Start button, and then click Run.

2. In the Open box, type the command that opens your Web browser in "kiosk" mode, followed by the folder 
where your presentation is stored.
For example, if the folder is C:\My Documents, and your presentation's first page is Present.htm, you'd type 
one of the following:

If you're using Internet Explorer, type:
iexplore -k C:\My Documents\Present.htm
If you're using Netscape, type:
netscape -k C:\My Documents\Present.htm



How do you fold a brochure?

Brochure documents are designed to be printed sideways (in landscape orientation). Each side of three panels is 
printed and copied back to back. Then the document is folded into three panels.

These are the pages in i publish:

These are the printed and folded pages:



Tips for working on a brochure

You can dramatically change the look of text and pictures in your document.

To change the look and size of text, apply a paragraph style.
             How?  

To change the size of pictures, change the picture emphasis.
             How?  

More Information

What if...

The brochure is very slow? You may need to adjust how things are fitting.
             How?  



If/When we put a WinWord template out on the Web, add this text to the beginning of the procedure.

1. Use the Microsoft Word template we've provide from our Web site. 

http://www.design-intelligence.com/
download/compsoft.html

Where is this template available on our Web site?

-Or-



Tips for putting text from Microsoft Word into i publish documents

The most efficient way to use Microsoft Word and i publish together is to create styles in Microsoft Word that match 
the style names in i publish. Then, when you import your text into i publish, all of your styles automatically map to 
the correct i publish style.

1. In Microsoft Word, create styles using these names (make sure you use the same spelling and spaces):

Block Quote

Body Lead

Body Text

Bulleted List 1
Bulleted List 2

Deck Lead

Heading 1
Heading 2
Heading 3
Heading 4

Indent 1
Indent 2

Next List 1
Next List 2

Notations

Section Head
Section Lead

Title Head

Note: Use any formatting you like in Microsoft Word. i publish only looks at the style names, and then applies 
formatting based on the layout and schemes you chose.

             How do you create styles in Microsoft Word?  
2. In Microsoft Word, apply styles to your Microsoft Word document.
             How do you apply a style in Microsoft Word?  

3. In i publish, import your text file.
             How?  



To find out how to create a style

1. If you are using Microsoft Word 7.0, on the Microsoft Word Help menu, click Microsoft Word Help Topics.

2. Click the Index tab, and then type: styles, creating and editing

3. Press Enter, click "Create a style," and then click Display.



To find out how to apply a style

1. If you are using Microsoft Word 7.0, on the Microsoft Word Help menu, click Microsoft Word Help Topics.

2. Click the Index tab, and then type: styles, applying

3. Press Enter, click "Apply a style," and then click Display.







Add i publish clip art (from the Web) so text wraps around it

1. If you haven't already done so, connect to the Web.
             How?  

2. In i publish, click the Grab tab at screen left, and then click From i publish Clip Gallery.

3. Find the clip art you want, click "Hi-Res" underneath it, and then wait for the clip art to download completely.

4. Drag the clip art onto a paragraph, and then drop it. (Watch your pointer.)
             How?  

Can't drop it. Can drop it.

The picture will appear below the paragraph you dropped it onto. Wherever you move the paragraph, the 
picture stays with it.

5. To return to the 
i publish tabs, 
click this button as 
many times as 
necessary. (It's at 
the top of the 
screen.)

Note: For many documents, you can change where pictures, pull quotes, or sidebars appear on the page.

             How?  

If you don't like where the clip art 
landed, press CTRL+Z to undo the 
drop.

More Information

What if...

             Your pictures don't look smooth?  

You can also...

             See the Web or a program full screen  
             Move intelligent components on the page  
             Trim (crop) the picture  

Shortcuts

             Adding a caption to a picture  

Concept

             Drag and drop rules  



Add i publish clip art (from your CD) so text wraps around it

1. In i publish, click the Grab tab at screen left, and then click Clip Art From i publish CD. (Make sure the i publish 
CD is in your CD-ROM drive.)
If you can't click the Clip Art From i publish CD button, then clip art does not come with this version of i publish.

2. Find the clip art you want.

3. Drag the clip art onto a paragraph, and then drop it. (Watch your pointer.)
             How?  

Can't drop it. Can drop it.

The picture will appear below the paragraph you dropped it onto. Wherever you move the paragraph, the 
picture stays with it.

4. To return to the 
i publish tabs, 
click this button as 
many times as 
necessary. (It's at 
the top of the 
screen.)

Note: For many documents, you can change where pictures, pull quotes, or sidebars appear on the page.

             How?  

If you don't like where the clip art 
landed, press CTRL+Z to undo the 
drop.

More Information

What if...

             Your pictures don't look smooth?  

You can also...

             See the Web or a program full screen  
             Move intelligent components on the page  
             Trim (crop) the picture  

Shortcuts

             Adding a caption to a picture  

Concept

             Drag and drop rules  



Where do you want to get clip art from?

             The   i     publish   Web site  
             The   i     publish   CD (compact disc)  

Note: This option is not available if you downloaded i publish from the Web.



Add i publish clip art (from the Web) to a picture component 

1. If you haven't already done so, connect to the Web.
             How?  

2. In i publish, click the Grab tab at screen left, and then click From i publish Clip Gallery.
If you can't click the From i publish Clip Gallery button, then clip art does not come with this version of 
i publish.

3. Find the clip art you want, click "Hi-Res" underneath it, and then wait for the clip art to download completely.

4. Drag the clip art over a gray box or a picture you want to replace, and then drop it. (Watch your pointer.)
             How?  

Can't drop it. Can drop it.

5. To return to the 
i publish tabs, 
click this button as 
many times as 
necessary. (It's at 
the top of the 
screen.)

If you don't like where the clip art 
landed, press CTRL+Z to undo the 
drop.

More Information

You can also...

             See the Web full screen  
             Trim (crop) the picture  

Shortcuts

             Adding a caption to a picture  

Concept

             Drag and drop rules  



Add i publish clip art (from the CD) to a picture component 

1. In i publish, click the Grab tab at screen left, and then click Clip Art From i publish CD.
If you can't click the Clip Art From i publish CD button, then clip art does not come with this version of i publish.

2. Find the clip art you want.

3. Drag the clip art over a gray box or a picture you want to replace, and then drop it. (Watch your pointer.)
             How?  

Can't drop it. Can drop it.

4. To return to the 
i publish tabs, 
click this button as 
many times as 
necessary. (It's at 
the top of the 
screen.)

If you don't like where the clip art 
landed, press CTRL+Z to undo the 
drop.

More Information

You can also...

             See the Web full screen  
             Trim (crop) the picture  

Shortcuts

             Adding a caption to a picture  

Concept

             Drag and drop rules  



Add a picture from a disk (hard, floppy, or CD-ROM) so text wraps around it

You can import a picture from your computer, a floppy disk, a CD-ROM, a network, or removable media (zip drive, 
optical drive, and so on).

1. Click the paragraph that you want to be above the picture.

2. Click the Grab tab at screen left, and then click Picture File.

3. Find the file that contains the picture you want, and then click Insert.
             How?  

Wherever you move the paragraph, the picture stays with it.

Note: For many documents, you can change where pictures, pull quotes, or sidebars appear on the page.
             How?  

If you don't like where the picture 
landed, press CTRL+Z to undo the 
drop.

More Information

What if...

             Your picture doesn't look smooth?  
             You can't see your floppy drive or CD-ROM drive in Windows Explorer?  

You can also...

             Move intelligent components on the page  
             Trim (crop) the picture  

Shortcuts

             Dragging and dropping  
             Adding a caption to a picture  

Concept

             Drag and drop rules  
             Picture formats   i     publish   imports  



Add a picture from a disk (hard, floppy, or CD-ROM) into a picture component

You can import a picture from your computer, a floppy disk, a CD-ROM, a network, or removable media (zip drive, 
optical drive, and so on). 

1. Click the picture component (gray box) where you want the picture.

2. Click the Grab tab at screen left, and then click Picture File.

3. Find the file that contains the picture you want, and then click Insert.
             How?  

If you don't like where the picture 
landed, press CTRL+Z to undo the 
drop.

More Information

What if...

             Your picture doesn't look smooth?  
             You can't see your floppy drive or CD-ROM drive in Windows Explorer?  
             The picture is too big or too small to see clearly?  

You can also...

             Move intelligent components on the page  
             Trim (crop) the picture  

Shortcuts

             Dragging and dropping  
             Adding a caption to a picture  

Concept

             Drag and drop rules  
             Picture formats   i     publish   imports  



Add a picture from the Web so text wraps around it

1. If you haven't already done so, connect to the Web.
             How?  

2. Click the Grab tab at screen left, and then click From the World Wide Web.
The Design Intelligence Web site appears.

3. Find the Web site you want.
             How?  

4. Find the picture you want, and then click it.

5. Drag the picture onto a paragraph, and then drop it. (Watch your pointer.)
             How?  

Can't drop it. Can drop it.

The picture will appear below the paragraph you dropped it onto. Wherever you move the paragraph, the 
picture stays with it.

6. To return to the 
i publish tabs, 
click this button as 
many times as 
necessary. (It's at 
the top of the 
screen.)

Note: For many documents, you can change where pictures, pull quotes, or sidebars appear on the page.

             How?  

If you don't like where the picture 
landed, press CTRL+Z to undo the 
drop.

More Information

What if...

             Your pictures don't look smooth?  

You can also...

             See the Web full screen  
             Move intelligent components on the page  
             Trim (crop) the picture  

Shortcuts

             Dragging and dropping  
             Adding a caption to a picture  

Concept

             Drag and drop rules  



Add a picture from the Web into a picture component

When empty, picture components look like gray boxes.

1. If you haven't already done so, connect to the Web.
             How?  

2. Click the Grab tab at screen left, and then click From the World Wide Web.
The Design Intelligence Web site appears.

3. Find the Web site you want.
             How?  

4. Find the picture you want, and then click it.

5. Drag it over a gray box or a picture you want to replace, and then drop it. (Watch your pointer.)
             How?  

Can't drop it. Can drop it.

6. To return to the 
i publish tabs, 
click this button as 
many times as 
necessary. (It's at 
the top of the 
screen.)

If you don't like where the picture 
landed, press CTRL+Z to undo the 
drop.

More Information

What if...

             Your pictures don't look smooth?  

You can also...

             See the Web full screen  
             Move intelligent components on the page  
             Trim (crop) the picture  

Shortcuts

             Dragging and dropping  
             Adding a caption to a picture  

Concept

             Drag and drop rules  



Add a picture from another i publish document so text wraps around the picture

To move pictures or text between two i publish documents, you need to have two copies of i publish open at the 
same time.

1. With i publish already running on your screen, open i publish again.
             How?  

2. In the second copy of i publish, open the i publish document that contains the picture you want to copy.

3. Point to the picture, and then click the right mouse button. (Or, press SHIFT+F10.)

4. On the popup menu, point to Select, and then click what you want to copy. 
If you click Picture, the image and any caption or caption title will be copied. If you click Image, only the art will 
be copied. 

5. On the Edit menu, click Copy.

6. In the first copy of i publish, click the paragraph that you want the picture to stay with. (The picture will always 
appear below this paragraph.)

7. On the Edit menu, click Paste.
If you trimmed the picture, that information is pasted with the picture.

Note: For many documents, you can change where pictures, pull quotes, or sidebars appear on the page.

             How?  

More Information

You can also...

             Move intelligent components on the page  
             Trim (crop) the picture  

Shortcuts

             Adding a caption to a picture  
             Dragging and dropping  

Concept

             Drag and drop rules  



Add a picture from another i publish document into a picture component

To move pictures or text between two i publish documents, you need to have two copies of i publish open at the 
same time. When empty, picture components look like gray boxes.

1. With i publish already running on your screen, open i publish again.
             How?  

2. In the second copy of i publish, open the i publish document that contains the picture you want to copy.

3. Point to the picture, and then click the right mouse button. (Or, press SHIFT+F10.)

4. On the popup menu, point to Select, and then click what you want to copy. 
If you click Picture, the image and any caption or caption title will be copied. If you click Image, only the art will 
be copied. 

5. On the Edit menu, click Copy.

6. In the first copy of i publish, scroll to the page that you want to add the picture to.

7. Click the picture component that you want to hold the picture.

8. On the Edit menu, click Paste.
If you trimmed the picture, that information is pasted with the picture.

More Information

You can also...

             Move intelligent components on the page  
             Trim (crop) the picture  

Shortcuts

             Adding a caption to a picture  
             Dragging and dropping  

Concept

             Drag and drop rules  



Change the emphasis of a picture

Note: You can only change the emphasis or size of pictures that are placed within wrapping text.

1. Click the picture to select it.

2. On the Design menu, click Adjust Picture.

3. Under Set Emphasis For Picture (within Text), click the level of emphasis you want. (Both Full Width options 
make the picture take up the entire width of the text.)
If the choices are gray, you've selected a picture whose emphasis isn't adjustable.

4. Click OK.
If you don't see a change, try another level of emphasis.

More Information

You can also...

             Trim (crop) the picture  

Concepts

             How to get the most out of your pictures  



Trim (crop) the picture 

1. Click the picture to select it.

2. On the Design menu, click Adjust Picture.

3. Drag the red and green handles to trim the picture.
Everything outside the red rectangle will never appear in your document. 
Everything inside the green rectangle defines what you always want to see.
You may need to experiment to get the results you want.

             Want to know more?  
4. Click OK.

To reset both rectangles to an 
uncropped version of the picture, 
click Reset.

More Information

What if...

             You want to see the whole picture again?  



See the whole picture again

You haven't lost any of your picture; you've just concealed parts of it. 

1. Click the picture to select it.

2. On the Design menu, click Adjust Picture.

3. Click Reset, and then click OK.

To return the picture to its trimmed 
state, press CTRL+Z before you do 
anything else.

More Information

Concepts

             How to get the most out of your pictures  



Move a picture so it's associated with the correct text

1. Point to the picture, and then click the right mouse button. (Or, press SHIFT+F10.)

2. On the popup menu, point to Select, and then click what you want to move. 
If you click Picture, the image and any caption or caption title will be moved. If you click Image, only the art will 
be moved. 

3. Drag the picture border onto a paragraph, and then drop it.

If the picture is on a different page, drag the picture to the bottom scroll bar until i publish scrolls to the next 
page.

The picture will appear below the paragraph you dropped it onto. Wherever you move the paragraph, the 
picture stays with it.

Note: For many documents, you can change where pictures, pull quotes, or sidebars appear on the page.

             How?  

If you don't like where the picture 
landed, press CTRL+Z to undo it.

More Information

You can also...

             Move intelligent components on the page  

Shortcuts

             Dragging and dropping  



Copy a picture so text wraps around it

1. Point to the picture, and then click the right mouse button. (Or, press SHIFT+F10.)

2. On the popup menu, point to Select, and then click what you want to copy. 
If you click Picture, the image and any caption or caption title will be copied. If you click Image, only the art will 
be copied. 

3. Press CTRL while you drag the picture border onto a paragraph, and then drop it.
If the picture is on a different page, press CTRL while you drag the picture to the bottom scroll bar until 
i publish scrolls to the next page.

The picture will appear below the paragraph you dropped it onto. Wherever you move the paragraph, the 
picture stays with it.

Note: For many documents, you can change where pictures, pull quotes, or sidebars appear on the page.

             How?  

If you don't like where the picture 
landed, press CTRL+Z to undo it.

More Information

You can also...

             Move intelligent components on the page  

Shortcuts

             Dragging and dropping  



Move a picture to the correct gray box or replace an incorrect picture

1. Point to the picture, and then click the right mouse button. (Or, press SHIFT+F10.)

2. On the popup menu, point to Select, and then click what you want to move. 
If you click Picture, the image and any caption or caption title will be moved. If you click Image, only the art will 
be moved. 

3. Drag the picture border to a different gray box or onto an existing picture.
If the picture is on a different page, drag the picture to the bottom scroll bar until i publish scrolls to the next 
page.

If you don't like where the picture 
landed, press CTRL+Z to undo it.

More Information

You can also...

             Move intelligent components on the page  

Shortcuts

             Dragging and dropping  



Copy a picture to a gray box or replace an incorrect picture

1. Point to the picture, and then click the right mouse button. (Or, press SHIFT+F10.)

2. On the popup menu, point to Select, and then click what you want to copy. 
If you click Picture, the image and any caption or caption title will be copied. If you click Image, only the art will 
be copied. 

3. Press CTRL while you drag the picture border to a gray box or onto an existing picture.
If the picture is on a different page, press CTRL while you drag the picture to the bottom scroll bar until 
i publish scrolls to the next page.

If you don't like where the picture 
landed, press CTRL+Z to undo it.

More Information

You can also...

             Move intelligent components on the page  

Shortcuts

             Dragging and dropping  



Copy or move a picture to a picture component in another i publish document

To move pictures or text between two i publish documents, you need to have two copies of i publish open at the 
same time.

1. With i publish already running on your screen, open i publish again.
             How?  

2. In the second copy of i publish, open the i publish document that contains the picture you want to copy.

3. Point to the picture, and then click the right mouse button. (Or, press SHIFT+F10.)

4. On the popup menu, point to Select, and then click what you want to copy or move. 
If you click Picture, the image and any caption or caption title will be copied or moved. If you click Image, only 
the art will be copied or moved. 

5. On the Edit menu, click Copy or Cut.

6. In the first copy of i publish, scroll to the page that you want to add the picture to.

7. Click a gray box or a picture you want to replace.

8. On the Edit menu, click Paste.

If you don't like where the picture 
landed, press CTRL+Z to undo it.

More Information

You can also...

             Move intelligent components on the page  

Shortcuts

             Dragging and dropping  



Copy or move a picture so text wraps around it in another i publish document

To move pictures or text between two i publish documents, you need to have two copies of i publish open at the 
same time.

1. With i publish already running on your screen, open i publish again.
             How?  

2. In the second copy of i publish, open the i publish document that contains the picture you want to copy.

3. Point to the picture, and then click the right mouse button. (Or, press SHIFT+F10.)

4. On the popup menu, point to Select, and then click what you want to copy or move. 
If you click Picture, the image and any caption or caption title will be copied or moved. If you click Image, only 
the art will be copied or moved. 

5. On the Edit menu, click Copy or Cut.

6. In the first copy of i publish, scroll to the page that you want to add the picture to.

7. Click a paragraph. 

8. On the Edit menu, click Paste.

Note: The picture will appear below the paragraph you clicked. Wherever you move the paragraph, the picture 
stays with it.

Note: For many documents, you can change where pictures, pull quotes, or sidebars appear on the page.

             How?  

If you don't like where the picture 
landed, press CTRL+Z to undo it.

More Information

You can also...

             Move intelligent components on the page  

Shortcuts

             Dragging and dropping  



Clear a picture

When you clear a picture component, you remove the picture, but leave the empty picture component in your 
document. 

1. Click a picture.

2. On the Edit menu, click Clear.
This deletes the picture, but leaves behind the intelligent component (gray box) that held it.

To bring back the deleted picture, 
press CTRL+Z.

More Information

What if...

             The whole picture component went away?  



Delete a picture and its picture component

When you delete a picture component, you remove the picture and the component that held it. 

1. Point to the picture, and then click the right mouse button. 

2. On the popup menu, point to Select, and then click what you want to delete. 
If you click Picture, the image and any caption or caption title will be deleted. If you click Image, only the art 
will be deleted. 

3. On the Edit menu, click Delete.

Shortcut: Press SHIFT+F10 to display the popup menu.

If you deleted more than you 
expected, press CTRL+Z to undo it.

More Information

What if...

             You want to delete the picture, but not its component?  
             You want to delete a compound component, but only part of it was deleted?  



Preview a picture before you add it

You can preview a picture that is stored on your computer, a floppy disk, a CD-ROM, or a server.

1. On the i publish File menu, click Open Existing Document.

2. Click the Files Of Type box, and then click All Files (*.*).

3. Find the file you want to preview, and then click Open.
             How?  

4. Click OK in the message that appears.
The picture opens in its original program at screen left.

5. To return to the 
i publish tabs, 
click this button as 
many times as 
necessary. (It's at 
the top of the 
screen.)

More Information

What's next?

             Add a picture  

What if...

             You can't see your floppy drive or CD-ROM drive in Windows Explorer?  



Change the layout to rearrange pictures or change the size of pictures

1. Click the Design tab at screen left, and then click the Layouts tab.

2. Click a layout that arranges pictures the way you want.

More Information

You can also...

             Position a picture in relation to text  



Position a picture in relation to text 

1. Point to the picture, and then click the right mouse button. (Or, press SHIFT+F10.)

2. On the popup menu, point to Select, and then click what you want to move. 
If you click Picture, the image and any caption or caption title will be moved. If you click Image, only the art will 
be moved. 

3. Drag the picture border onto a paragraph, and then drop it. (Watch your pointer.)
             How?  

Can't drop it. Can drop it.

The picture will appear below the paragraph you dropped it onto. Wherever you move the paragraph, the 
picture stays with it.

Note: For many documents, you can change where pictures, pull quotes, or sidebars appear on the page.

             How?  

More Information

You can also...

             Change the layout to rearrange pictures or change the size of pictures  



Drag and drop pictures from the control window

You can open a picture in the control window, and then drag and drop it into your document.

1. On the i publish File menu, click Open Existing Document.

2. Click the Files Of Type box, and then click All Files (*.*).

3. Find the file you want to preview, and then click Open.
             How?  

4. Click OK in the message that appears.
The picture opens in its original program at screen left.

5. If you have the right picture, drag the picture into your document. (Watch your pointer.)

Can't drop it. Can drop it.

6. To return to the 
i publish tabs, 
click this button as 
many times as 
necessary. (It's at 
the top of the 
screen.)

More Information

What if...

             You can't see your floppy drive or CD-ROM drive in Windows Explorer?  



Add a scanned picture or other TWAIN image

Using your scanner, electronic camera, or other TWAIN device, you can easily insert a picture into your i publish 
document.

Note: In most cases, you need to be sure that your scanner or other TWAIN device is turned on before you start 
your computer.

1. Click the picture component where you want to add the picture.
             How do you add a picture component?  

Tip: When empty, picture components look like gray boxes.

2. On the File menu, click Acquire, and then click Select Source. 

Note: If the Acquire option is not available, then either your scanner or other TWAIN device is not attached, 
your device does not support the TWAIN format, or the scanner's or other TWAIN device's software is not 
installed correctly.

3. Click the source you want to use, and then click Select.

4. On the File menu, click Acquire, and then click Acquire Image.

Your scanner or other TWAIN software automatically starts.

5. Scan or capture your image as you normally do.

As soon as you're finished scanning or capturing your image, i publish appears with the new image already 
inserted into your picture component.

More Information

What if...

             The picture is too big or too small to see clearly?  

You can also...

             Move intelligent components on the page  
             Trim (crop) the picture  

Shortcuts

             Adding a caption to a picture  





The next 2 topics are almost identical



What do you want to do?

             Save your document  
             Save a component that you created  
             Print your document  
             Publish your document as a Web page  
             Publish your document as an onscreen presentation  
             Delete a document  



Leave this paragraph here...for some (unknown) reason, it makes the next topic appear properly.



What do you want to do?

             Save a new or existing document  
             Save a copy of your document to a different location or with a new name  
             Save your document as a template  



What do you want to do?

             Print your document  
             Print your document on letterhead stationery  
             Print your document on an outside printer  



What do you want to do?

             Update your Web page  
             Change the look of your Web page  
             Preview your document as a Web page  
             Post your Web pages to the World Wide Web  



What do you want to do?

             Update your onscreen presentation  
             Change the look of your onscreen presentation  
             View your document as an onscreen presentation  







Print your document

1. On the File menu, click Publish To Printer. 

2. To print Do this

The entire 
document

Under Print Range, 
click All.

A single page Under Print Range, 
click Pages and type 
the page number in 
both the From and 
To boxes.

A range of 
pages

Under Print Range, 
click Pages and type 
the beginning page 
in the From box and 
the ending page in 
the To box.

3. Click OK.

For additional details about printing, click Index and type Print.

More Information

What if...

             Nothing happens when you choose Publish to Printer?  
             Your pictures don't look smooth in your printout?  

You can also...

             Set page options  
             Print more than one copy at a time  
             Print your brochure on both sides of the paper using your desktop printer  
             Print to a non-default printer  
             Print using the Run dialog box  
             Change your document to European paper sizes  



Save your document

On the File menu, click Save.
If this is the first time you've saved the document, i publish gives you the opportunity to name it and put it in 
the folder of your choice.

More Information

You can also...

             Change where   i     publish   saves your documents  



Publish your document as a Web page

1. On the File menu, click Publish For Web.

2. Click the Configure tab, and then set where you want to store your Web pages on your computer. 
             How?  

3. Click the Publish tab, click the "On My Computer" box, and then click whether you want to preview your Web 
page.

4. Click a Web Page Scheme Set and a Layout.
You don't need to specify the layout for Correspondence (letters, memos, and so on), because i publish does it 
automatically.

5. Click OK to publish your document as a Web page.

6. Browse your Web pages, making note of the changes you want to make.

7. When you're done browsing, return to the main i publish window where you can edit your document.

8. Get ready to post your Web pages to the Web. (You only have to do this once.)
             How?  

9. Post your Web pages to the Web.
             How?  

Tip: If you're creating a report, you can divide a long report into sections by applying the Section Head style to your 
main headings, then i publish puts each section on its own Web page. 
             How?  

More Information

You can also...

             View your Web pages using Netscape Navigator or Internet Explorer  
             Update your Web page  

Concepts

             What happens when you Publish for Web?  



Get ready to post your Web pages to the Web

Before you publish your document to the Web, there are a few steps you need to take. You only have to do these 
once.

1. Install the Microsoft Web Publishing Wizard 1.1. 
             How?  

2. Set up your Internet Service Provider (ISP) so that i publish knows where to post your pages.
             How?  

3. Set where on the Web your pages are stored.
             How?  

4. Connect to the Web.
             How?  

5. Post your Web pages to the Web.
             How?  



Post your Web pages to the World Wide Web

1. Get ready to post your Web pages to the Web. (You only have to do this once.)
             How?  

2. On the File menu, click Publish For Web.

3. On the Publish tab, click "Generate files, then publish to the Internet."

4. Click OK to open the Microsoft Web Publishing Wizard and post your pages to the Web. Follow the instructions 
on your screen.
Note: If you aren't able to post your Web pages, you may not have installed the Microsoft Web Publishing Wizard 
1.1.

             How?  

More Information

You can also...

             Update your Web page  

What if...

             You updated your Web document, but the changes don't show up on the Web?  

Concepts

             What happens when you Publish for Web?  
             How does   i     publish   create your Web address (URL)?  



Publish your document as an onscreen presentation

1. On the File menu, click Publish For Screen.

2. Click the Configure tab, and then set where you want to store your onscreen presentation. 
             How?  

3. Click the Publish tab, click the Presentation Scheme Set you want.

4. On the Shortcuts tab, click whether you want i publish to create a shortcut for you.

You can double-click a shortcut to open your onscreen presentation in your default Web browser (Internet 
Explorer or Netscape Navigator).

5. If you are using Internet Explorer 3.02 or later, click View Presentation. 

6. Click OK to publish your document as an onscreen presentation.

Tip: If you're creating a report, you can divide a long report into sections by applying the Section Head style to your 
main headings, then i publish puts each section on its own screen in your presentation. 
             How?  

More Information

You can also…

             View your presentation using Netscape Navigator or Internet Explorer  

What if...

             i     publish   won't be installed on the computer you're using for your presentation?  

Tips

             Writing and presenting an onscreen presentation  



View your onscreen presentation using your Web browser

1. On the File menu, click Publish for Screen.

2. Click the Shortcuts tab.

3. Do one of the following:
Click "Place shortcut to presentation on desktop."
Click "Place shortcut to presentation in folder," and then click Browse to locate the folder you want.

4. Click the Publish tab, and then publish your document as an onscreen presentation.
             How?  

5. Do one of the following:
If you saved the shortcut on the desktop, go to the desktop.
If you saved the shortcut in a folder, use Windows Explorer to locate the shortcut.

6. Double-click the shortcut to start your presentation.

More Information

Tips

             Writing and presenting an onscreen presentation  



Close a document

On the File menu, click Close.
If you've made changes to your document since you last saved it, i publish gives you the opportunity to save 
the changes.



Print your document on an outside printer

If you don't have time to print your document, or if you are not always connected to a printer, you can create a file 
that contains the document you want to print, and you can then print the file at a later time.

If you plan to go to a business that has high-end printers available, you may want to call them in advance. These 
businesses typically have files available for you to install on your computer. You'll typically need these files:

Printer driver file
PPD file (PostScript Printer Description)

Print your document to a file

1. Make sure you have installed the printer driver for the specific printer you'll be using. For details, see the 
Windows online Help.

2. On the File menu, click Print Setup.

3. In the Name box, click the printer that you'll print the file with.

4. If you need to change printer settings, click Properties.

5. On the File menu, click Publish To Printer. 

6. Check the Print To File box, and then click OK.

7. In the File Name box, type a file name, and then click Save.
If you're printing to a PCL printer, i publish adds .prn to the end of the file name. (Such as myfile.prn.)
If you're printing to a PostScript printer, i publish adds .ps to the end of the file name. (Such as myfile.ps.)

Make sure you take the following files with you to the outside printer:

The file you just created, ending in either .prn or .ps.
The file that i publish creates may be too large to fit on a floppy disk. If you need to take this file to another 
business, you may need to use a Zip drive or use a program (such as Pkzip) to put the file on multiple floppy 
disks. 

             How can you save a file across multiple floppy disks?  
The font files for the fonts you used in your document.

You can find your fonts in your C:\Windows\Fonts folder. Fonts end in .ttf

Print the file 

1. Click the Windows Start menu, click Programs, and then click MS-DOS Prompt.

2. Type the following, where "PRINTER" is the name of your printer queue.
net use lpt1 \\PRINTER

3. If you're printing to a PCL printer, type the following, where "yourfile.prn" is the name of your printer file.
copy yourfile.prn > lpt1

If you're printing to a Postscript printer, type the following, where "yourfile.ps" is the name of your printer file.
copy yourfile.ps > lpt1



Change your document to European paper sizes

1. On the File menu, click Print Setup.

2. Under Paper, set the paper size, and then click OK.



Save a copy of your document to a different location or with a new name

1. On the File menu, click Save As.

2. In the Save In section, find the folder where you want to save the file.

3. In the File Name box, type a new file name for the document.

4. Click Save.



Update your Web page

i publish saves only one version of your document. To edit a Web page or an onscreen presentation, you edit the 
original document, not the output.

1. If necessary, open the document that you need to update.

2. Edit your document in i publish.
You will be working with the version of your document that looks appropriate for print.

3. Publish your Web page again. 
             How?  

4. If you've already posted your Web page to the World Wide Web, you'll need to post it again.
             How?  

Advanced users

When you publish your document as a Web page, i publish generates HTML files. If you feel comfortable editing 
HTML code, you can use any text editor (such as Windows Notepad) to edit these HTML files directly. 

Important: Any changes you make to these HTML files will not be reflected in your i publish document (.did) and will 
be lost if you publish your document as a Web page again.

For details about HTML codes, check the Web—there are lots of good, free HTML reference libraries available for 
download.

More Information

What if...

             You updated your Web document, but the changes don't show up on the Web?  

You can also...

             Set where on your computer your Web pages or onscreen presentation are stored  

Concepts

             What happens when you Publish for Web?  
             How does   i     publish   create your Web address (URL)?  



Update your onscreen presentation

i publish saves only one version of your document. To edit a Web page or an onscreen presentation, you edit the 
original document, not the output.

1. If necessary, open the document that you need to update.

2. Edit your document in i publish.
You will be working with the version of your document that looks appropriate for print.

3. Publish your onscreen presentation again. 
             How?  

Advanced users

When you publish your document as an onscreen presentation, i publish generates HTML files. If you feel 
comfortable editing HTML code, you can use any text editor (such as Windows Notepad) to edit these HTML files 
directly. 

Important: Any changes you make to these HTML files will not be reflected in your i publish document (.did) and will 
be lost if you publish your document as an onscreen presentation again.

For details about HTML codes, check the Web—there are lots of good, free HTML reference libraries available for 
download.

More Information

What if...

             i     publish   won't be installed on the computer you're using for your presentation?  

You can also...

             Set where on your computer your Web pages or onscreen presentation are stored  

Tips

             Writing and presenting an onscreen presentation  



Change the look of your Web page

1. On the File menu, click Publish For Web.

2. On the Publish tab, click the On My Computer box, and then click the program you want to use to preview your 
Web page.

3. Under Presentation Scheme Set, click a different scheme.

4. Under Layout, click a different layout.
The names specify where pictures and the table of contents (or navigation) go on your Web pages.
Note: This option is not available for letters, memos, faxes, or press releases.

5. Click OK to publish your document to a Web page.

6. If you chose "Preview using i publish", you can use the toolbar to quickly change the Presentation Scheme Set 
and the Layout.

Click Close to return to the main i publish window.

7. If you've already posted your Web page to the World Wide Web, you'll need to post it again.
             How?  

More Information

What if...

             You updated your Web document, but the changes don't show up on the Web?  

You can also...

             Use Internet Explorer or Netscape Navigator to view your Web pages  
             Set where on your computer your Web pages or onscreen presentation are stored  

Concepts

             What happens when you Publish for Web?  
             How does   i     publish   create your Web address (URL)?  



Change the look of your onscreen presentation

1. On the File menu, click Publish For Screen.

2. On the Publish tab, under Presentation Scheme Set, click a different scheme.

3. To view your onscreen presentation using i publish, click View Presentation. 
Note: This option is only available if you have Internet Explorer 3.02 or later installed.

4. Click OK to publish your document as an onscreen presentation.

5. If you chose "View Presentation", you can click through your presentation to see how you like it. 
When you're done, press the ESC key to return to the main i publish window.

More Information

What if...

             i     publish   won't be installed on the computer you're using for your presentation?  

You can also...

             Set where on your computer your Web pages or onscreen presentation are stored  

Tips

             Writing and presenting an onscreen presentation  



Print your brochure on both sides of the paper using your desktop printer

1. Print the first page of your brochure.
             How?  

2. Put that printout back into your printer paper tray (typically face up, with the top edge facing left), and then 
print the second page of your brochure.

You probably will have to experiment or refer to your printer documentation to be sure about whether to place 
your printout face up or down.

Tip: Until you're sure about which way to place your printout, print your document as black and white, so you 
don't waste your expensive color cartridges. Then, when you're ready, switch back to color.

             How?  

More Information

What if...

             Nothing happens when you choose Publish to Printer?  
             Your pictures don't look smooth in your printout?  

You can also...

             Set page options  



Send your document to i press to be printed

If you want high-resolution printouts of your document, you can send your document to i press, and then printouts 
will be mailed back to you.

Note: The i press printer's margins may slightly vary from your desktop printer's margins. This slight variation may 
subtly alter the placement of page elements; however, i publish automatically formats the page to look good on 
any printer.

1. Before you send your document, print a draft of it. Check it for typos and ensure it's just the way you want it.
             How?  

2. On the Publish tab, click i press.

3. In the form that appears, enter your order information, including the type of paper you want, the number of 
copies, whether your document should be copied back-to-back, and so on.
This form also covers how quickly your order can be printed and mailed back to you.

4. When you're done, press the Print This Form button so you can fax it or send it through the mail.

5. If your file is 2 MB (megabytes) or smaller, send it to i press through email.
             How?  

If your file is larger than 2MB, split it across as many floppy disks as necessary. Mail the floppy disks and the 
printed form (from Step 4) to i press.

             How do you split a file across floppy disks?  







What do you want shortcuts for?

             Dragging and dropping  
             Highlighting and selecting  
             Moving your insertion point in   i     publish  
             Working with text  
             Viewing your document  
             Managing files (New, Open, Save...)  
             Miscellaneous things  



What do you want to do?

             Highlight text with the mouse  
             Highlight a character or a word with the keyboard  
             Highlight lines of text with the keyboard  
             Highlight paragraphs and components with the keyboard  
             Select compound components  



Where do you want to move your insertion point?

             To a character or a word  
             To a line of text  
             To a paragraph or component  
             From component to component  



What do you want to do?

             Format highlighted text  
             Cut, copy, and paste highlighted text  
             Delete text  
             Find text and check spelling  
             Add a caption to a picture  



The next 2 topics are almost identical



What do you want to do?

             View the page  
             View pages on the Web  
             Zoom in or out  
             Play an onscreen presentation  



What do you want to do?

             View the page  
             View pages on the Web  
             Zoom in or out  



Shortcuts in i publish

Shortcuts: Dragging and dropping 

Drag and drop between two programs

Dragging and dropping between two programs can be hard if you have to resize the windows so they fit 
side-by-side on your screen. A faster way is to use the Windows taskbar (at the bottom of your screen).

             How?  

Move text, pictures, or a component

Drag them from one location to another on the i publish page.

Copy text, pictures, or a component

Press CTRL while you drag them from one location to another on the i publish page.
-Or-
Drag them using the right mouse button (instead of the left mouse button), and i publish will ask you if 

you want to move or copy the text, picture, or component.

To undo the drop, press CTRL+Z. 

If you start to drag something, and 
then change your mind, with your 
finger still on the mouse button, 
press the ESC key.

Shortcuts: Highlighting text with the mouse

To highlight Click

A single word Double-click the 
word.

A paragraph Triple-click the 
paragraph.

Section of text Drag the insertion 
point across the text 
you want to highlight.

-Or-

1. Place the insertion 
point at the 
beginning of the 
text you want to 
highlight. 

2. Hold down the 
SHIFT key, and 
then click at the 
end of the text. 

Or, press the 
arrow keys.

3. Release the SHIFT 
key.



Note: You can only highlight text within a single component. 

Shortcuts: Highlighting a character or a word with the keyboard

To highlight Press

Left one character SHIFT+
LEFT ARROW

Left to the 
beginning of a 
word

CTRL+SHIFT+
LEFT ARROW

Right one character SHIFT+
RIGHT ARROW

Right to the end of 
a word

CTRL+SHIFT+
RIGHT ARROW

Shortcuts: Highlighting paragraphs and components with the keyboard

To highlight Press

Up to the beginning 
of a paragraph

CTRL+SHIFT+
UP ARROW

Up to the beginning 
of a text 
component

CTRL+SHIFT+
HOME

Down to the end of 
a paragraph

CTRL+SHIFT+
DOWN ARROW

Down to the end of 
a text component

CTRL+SHIFT+
END

All text in a text 
component

CTRL+A

Shortcuts: Highlighting lines of text with the keyboard

To highlight Press

Left to the 
beginning of a line

SHIFT+HOME

Right to the end of 
a line

SHIFT+END

Up one line SHIFT+
UP ARROW



Down one line SHIFT+
DOWN ARROW

Shortcuts: Moving your insertion point to a character or a word

To move Press

Left one character LEFT ARROW

Left to the beginning 
of a word

CTRL+
LEFT ARROW

Right one character RIGHT 
ARROW

Right to the end of a 
word

CTRL+
RIGHT 
ARROW

Shortcuts: Moving your insertion point to a line of text

To move Press

Left to the beginning 
of a line

HOME

Right to the end of a 
line

END

Up one line UP ARROW

Down one line DOWN 
ARROW

Shortcuts: Moving your insertion point to a paragraph or component

To move Press

Left one screen CTRL+
PAGE UP

Right one screen CTRL+
PAGE DOWN

Up to the beginning of 
a paragraph

CTRL+
UP ARROW

Up to the beginning of 
a text component

CTRL+HOME



Down to the end of a 
paragraph

CTRL+
DOWN 
ARROW

Down to the end of a 
text component

CTRL+END

Shortcuts: Formatting highlighted text

To apply Press

Bold CTRL+B

Underline CTRL+U

Italic CTRL+I

Apply a style 1. Highlight the text 
that you want to 
apply a style to.

2. Press 
CTRL+SHIFT+S to 
activate the Styles 
box on the toolbar.

3. Use the Up or 
Down arrow key to 
pick a style.

4. Press ENTER to 
apply the style to 
the highlighted 
text.

Shortcuts: Cutting, copying, and pasting highlighted text

To Press

Copy CTRL+C 

Cut CTRL+X

Paste CTRL+V

If you are copying and pasting into an intelligent component:

1. Point to it, and then click the right mouse button (right-click). Or, press SHIFT+F10.

2. On the popup menu, click Copy.

3. Right-click the component where you want it, and then click Paste.



Shortcuts: Deleting text

To delete Press

Left one character BACKSPACE

Right one DELETE
character

Next word CTRL+DEL

Previous word CTRL+BACKSPACE

Selected text DELETE or 
BACKSPACE

Shortcuts: Managing files (New, Open, Save...)

To Press

Create a new 
document

CTRL+N

Open an existing 
document

CTRL+O

Or, on the File 
menu, click a file at 
the bottom of the 
menu.

Get help F1

Save your document CTRL+S

Save your document 
with a different name 
(Save As)

F12

Check the spelling in 
your document

F7

Print your document CTRL+P

Exit i publish ALT+F4

Shortcuts: Miscellaneous things

To Press

Activate the i publish 
menu bar

F10

Move the focus back 
and forth between the 

F6
SHIFT+F6



Control window 
(screen left) and the 
Document window

Expand the i publish 
window to take up the 
entire screen 

ALT+F10

Refresh an HTML page 
at screen left

F5

Display an intelligent 
component's right-
click (or popup) menu

Shift+F10

Shortcuts: Viewing the page

You can choose from several different views of your document. When you first open a document, i publish displays 
it at the last zoom that you used. 

To Press

Go to the next page PAGE DOWN

Go to the previous PAGE UP
page

Scroll to the right CTRL+PAGE 
DOWN

Scroll to the left CTRL+PAGE UP

Zoom in CTRL+SHIFT 
and = (equals)

Zoom out CTRL and 
- (minus)

Go back to the 
previous zoom setting

F9

View the whole page CTRL+W

View the document at 
100%

CTRL+1

Shortcuts: Finding text and checking spelling

To Press

Find text CTRL+F

Replace text CTRL+H

Check the spelling in F7



your document

Shortcuts: Zooming in or out

To zoom Press

Zoom in CTRL 
and +

Zoom out CTRL 
and - 
(minus)

Whole Page CTRL+W

50% CTRL+5

75% CTRL+7

100% CTRL+1

200% CTRL+2

400% CTRL+4

Go back to 
the last zoom 
setting

F9

Shortcuts: Selecting compound components

Try one of the following:
Point to any part of the component, and then click the right mouse button. On the popup menu, point to 

Select, and then click the component you want.
If there is more than one component on the menu, the last component is the one that contains all the other 
listed components. For example, the Item component contains the Picture component.

Each compound component has a spot (shown as a red dot below) where you can click to select the 
compound component. You may need to experiment to find the exact spot.

You can also press SHIFT+F10 to display the popup menu.



Shortcuts: Moving from component to component

To move to Press

Component to the 
right

ALT+
RIGHT 
ARROW

Component to the left ALT+
LEFT 
ARROW

Component above ALT+
UP ARROW

Component below ALT+
DOWN 
ARROW

Next component CTRL+TAB

Previous component CTRL+
SHIFT+TAB

Shortcuts: Viewing pages on the Web

To do this Do this

Move backward 
or forward 

Click these buttons 
at the top of the 
screen.

View a specific 
Web site

1. On the File 
menu, click 
Open Web Page 
Location. 

2. Type the Web 
site that you 
want, and then 
click OK.

View the Design 
Intelligence Web 
site

On the Navigate 
menu, click Go To 
Design Intelligence 
Web Site.

Stop a Web page 
while it’s loading

Click this button at 
the top of the 
screen.

View only the 
control window 
(at screen left)

On the View menu, 
click Control 
Window Only.

View only your On the View menu, 



i publish 
document

click Document 
Window Only.

View the control 
window and your 
i publish 
document

On the View menu, 
click Document and 
Control Windows.

Shortcuts: Adding a caption to a picture

Do one of the following:

Drag a small section of text onto the picture. 
i publish automatically converts the text into a picture caption.

Point to the picture, and then click the right mouse button. On the popup menu, point to Insert 
Component, and then click Caption.

You can also press SHIFT+F10 to display the popup menu.

Shortcuts: Adding a picture to a document

Do one of the following:

Drag a picture file onto the document. 
Point to the text in your document, and then click the right mouse button. On the popup menu, point to 

Insert Component, and then click Picture.
If you don't see Picture on the list, then the component you pointed to cannot accept a picture. Try pointing to a 
different component.

You can also press SHIFT+F10 to display the popup menu.



Shortcuts: Playing an onscreen presentation

To close your presentation and get back to i publish, press Alt+F4 or Esc.





Path:
Add, replace, or change something
ADD OR CHANGE TABLES, CHARTS, OR DIAGRAMS



Add or replace a table, chart, or diagram in a picture component

1. In another program, create the table, chart, or diagram.

2. In the other program, select the object, and then click Copy on the Edit menu.

3. In your i publish document, click a gray box or an existing picture or object where you want to put the object.

4. On the Edit menu, click Paste Special.

5. Click OK.
The object appears in your document.

More Information

What if...

             You couldn't add a table, chart, or diagram this way?  
             The Paste Special command isn't available?  
             The changes you made to the OLE object don't show up in   i     publish?  
             The File menu of the source program doesn't have an Exit & Return command?  

Concepts

             What's OLE?  
             What programs support OLE?  

You can also...

             Make the colors in the table, chart, or diagram match your color scheme  



Add or replace a table, chart, or diagram so text wraps around it

1. In another program, create the table, chart, or diagram.

2. In the other program, select the object, and then click Copy on the Edit menu.

3. Click a paragraph. 

4. On the Edit menu, click Paste Special.

5. Click OK.
The object appears in your document.
Note: The object will appear below the paragraph you clicked. Wherever you move the paragraph, the object 
stays with it.

Note: For many documents, you can change where pictures, pull quotes, or sidebars appear on the page.

             How?  

More Information

What if...

             You couldn't add a table, chart, or diagram this way?  
             The Paste Special command isn't available?  
             The changes you made to the table, chart or diagram don't show up when you get it into   i     publish?  
             The File menu of the source program doesn't have an Exit & Return command?  

Concepts

             What's OLE?  
             What programs support OLE?  

You can also...

             Make the colors in the table, chart, or diagram match your color scheme  



Change the look of a table, chart, or diagram 

1. Double-click the table, chart, or diagram to open it.

2. Edit the object.

3. To return to your i publish document, on the File menu, click Exit & Return or Close.

More Information

What if...

             The changes you made to the OLE object don't show up in   i     publish?  

You can also...

             Make the colors in the OLE object match your color scheme  



Delete a table, chart, or diagram

1. Click the table, chart, or diagram.

2. To delete the object but leave an empty Picture component in your document, click Clear on the Edit menu.
To delete the object and the Picture component, click Delete on the Edit menu.

To restore the table to your 
document, press CTRL+Z.



Preview your table, chart, or diagram before you add it

1. On the i publish File menu, click Open Existing Document.

2. Click the Files Of Type box, and then click All Files (*.*).

3. Find the file you want to preview, and then click Open.
             How?  

4. Click OK in the message that appears.
The object file opens in its original program at screen left.

5. To return to the 
i publish tabs, 
click this button as 
many times as 
necessary. (It's at 
the top of the 
screen.)

More Information

What's next?

             Add a table, chart, or diagram  



Move or copy a table, chart, or diagram to a gray box

1. Click the table, chart, or diagram.

2. On the Edit menu, click Cut or Copy.

3. If necessary, scroll to the page you want to add the object to.
             How?  

4. Click the gray box or a picture you want to replace.

5. On the Edit menu, click Paste.



Move or copy a table, chart, or diagram so text wraps around it

1. Click the table, chart, or diagram.

2. On the Edit menu, click Cut or Copy.

3. If necessary, scroll to the page you want to add the object to.
             How?  

4. Click a paragraph. 

5. On the Edit menu, click Paste.

Note: The object will appear below the paragraph you clicked. Wherever you move the paragraph, the object 
stays with it.

Note: For many documents, you can change where pictures, pull quotes, or sidebars appear on the page.

             How?  







Type text

1. Click an empty text component or click within text at the place you want to start typing.
i publish highlights any placeholder text.

2. Zoom in if you need to.
             How?  

3. Type your text.
The text you type replaces the placeholder text.
To see how your text looks, click outside the text component in which you are typing.

More Information

What if...

             The title changes size as you type?  
             Your text is too small?  

You can also...

             Create a heading or title  
             Add a bulleted list  

Shortcuts

             Highlighting text  
             Moving your insertion point in text  
             Formatting highlighted text  



Copy or move highlighted text from another i publish document

To move pictures or text between two i publish documents, you need to have two copies of i publish open at the 
same time.

1. With i publish already running on your screen, open i publish again.
             How?  

2. In the second copy of i publish, open the i publish document that contains the text you want.

3. Highlight the text you want.

4. On the Edit menu, click Copy or Cut.

5. In the first copy of i publish, do one of the following:
Click a text component.
Place the insertion point in existing text.
Highlight text you want to replace.

6. On the Edit menu, click Paste.

If the text didn't go where you 
wanted, press CTRL+Z to undo it.

More Information

What if...

             You pasted text in   i     publish   and nothing happened?  

You can also...

             Reorganize components  

Shortcuts

             Dragging and dropping  

Concept

             Drag and drop rules (these apply to Paste too)  



Copy highlighted text from a disk (floppy, hard, CD-ROM)

You can copy text from your computer, a floppy disk, a CD-ROM, or a server.

1. On the i publish File menu, click Open Existing Document.

2. Click the Files Of Type box, and then click All Files (*.*).

3. Find the file you want, and then click Open.
             How?  

4. Click OK in the message that appears.
The text file opens in its original program at screen left.

5. Highlight the text you want.

6. Drag the text over a text component, and then drop it. (Watch your pointer.)
             How?  

Can't drop it. Can drop it.

Note: If the text doesn't appear, then the other program may not support drag and drop. Try copy and paste 
instead.

7. To return to the 
i publish tabs, 
click this button as 
many times as 
necessary. (It's at 
the top of the 
screen.)

If the text didn't go where you 
wanted, press CTRL+Z to undo it.

More Information

What if...

             Your text is too small?  
             You can't drag text from Microsoft Word and drop it into   i     publish?  
             You can't see your floppy drive or CD-ROM drive in Windows Explorer?  
             You pasted text in   i     publish   and nothing happened?  
             Text that was in the original text file doesn't appear in   i     publish?  
             The text dropped in the wrong spot in the document?  
             You can't drag your text onto the page?  

You can also...

             See a program full screen  
             Tips for putting text from Microsoft Word into   i     publish   documents  

Shortcuts

             Dragging and dropping  

Concept

             Drag and drop rules  



Add text from the Internet or the Web

1. If you haven't already done so, connect to the Web.
             How?  

2. Click the Grab tab at screen left, and then click From the World Wide Web.
The Design Intelligence Web site appears.

3. Find the Web site that you want.
             How?  

4. Find the text that you want, and then highlight the text.

5. Drag the text onto a text component, and then drop it. (Watch your pointer.)
             How?  

Can't drop it. Can drop it.

6. To return to the 
i publish tabs, 
click this button as 
many times as 
necessary. (It's at 
the top of the 
screen.)

If the text didn't go where you 
wanted, press CTRL+Z to undo it.

More Information

What if...

             Your text is too small?  
             The text dropped in the wrong spot in the document?  
             You can't drag your text onto the page?  

You can also...

             See the Web full screen  

Shortcuts

             Dragging and dropping  

Concept

             Drag and drop rules  



Add a text file from a disk (floppy, hard, CD-ROM)

You can import a text file from your computer, a floppy disk, a CD-ROM, or a server.

1. Click the text component where you want the text.

2. Click the Grab tab at screen left, and then click Text File.

3. Find the file that contains the text you want.
             How?  

Tip: Split up the text between multiple text components: open the program, open the file, and then drag 
highlighted text one portion at a time. 
             How?  

If the text didn't go where you 
wanted, press CTRL+Z to undo it.

More Information

What if...

             You can't drag text from Microsoft Word and drop it into   i     publish?  
             You can't see your floppy drive or CD-ROM drive in Windows Explorer?  
             Text that was in the original text file doesn't appear in   i     publish?  
             You can't drag your text onto the page?  

What's next?

             Create a heading or title  
             Add a bulleted list  

Shortcuts

             Dragging and dropping  

Concept

             Drag and drop rules  
             Text formats   i     publish   imports  



Add a special character or symbol

1. Zoom in if you need to.
             How?  

2. Click within text where you want to put the symbol.

3. On the Insert menu, click Symbol.

4. Click the symbol you want, click Select, and then click Copy.
To add a sequence of symbols, repeat this step until you have all the symbols you want.

5. Click Close.

6. On the Edit menu, click Paste.
i publish pastes the symbol(s) into your document at the insertion point.



Add a drop cap 

1. Click the Design tab at screen left, and then click the Paragraphs tab.

2. On the Paragraphs tab, click a scheme that contains drop caps. 

If you don't like the new paragraph 
scheme, press CTRL+Z to undo it or 
click a different scheme.

More Information

Concepts

             What's a drop cap?  



Add a pull quote

1. Point to the main text of your document, and then click the right mouse button. 
             What's an intelligent component?  

2. On the popup menu, point to Insert Component, and then click Pull Quote.

If the Pull Quote component is not on the list, it means pull quotes are not available for the type of document 
you're creating. 

i publish places the pull quote based on the current layout, but in many cases, you can drag it to a new spot.

4. Copy and paste a quote from the body text into the Pull Quote component.

More Information

You can also

             Move intelligent components on the page  

Concepts

             What's a pull quote?  



Add a table of contents

1. On the first page, point to an area that doesn't contain components, and then click the right mouse button. 
             What's an intelligent component?  

2. On the popup menu, point to Insert Component, and then click Table of Contents.
If the Table of Contents component is not on the list, it means table of contents are not available for the layout 
or type of document you're creating. 

i publish places the table of contents based on the current layout, and automatically generates the appropriate 
entries and page numbers.

Shortcut: Press SHIFT+F10 to display the popup menu.



Delete a table of contents

1. Point to the table of contents, and then click the right mouse button. 

2. On the popup menu, point to Select, and then click the component you want. 
If there is more than one component on the menu, the last component is the one that contains all the other 
listed components.
i publish places a border around what will be deleted.

3. On the Edit menu, click Delete.
i publish removes all the text, the picture if there is one, and the intelligent component, too.

Shortcut: Press SHIFT+F10 to display the popup menu.

If you deleted more than you 
expected, press CTRL+Z.

More Information

Shortcuts

             Selecting compound components  



Add a caption to a picture

1. Point to the picture, and then click the right mouse button. 

2. On the popup menu, point to Insert Component, and then click Caption.
If you don't see the Caption component on the list, then a Caption component is not available for the current 
picture. For example, your company logo wouldn't have a caption.

3. Zoom in if you need to.
             How?  

4. Click the Caption component, and then type your text.

Shortcut: Press SHIFT+F10 to display the popup menu.

More Information

Shortcuts

             Adding a caption to a picture  



Make text bold, italic, or underline

1. Zoom in if you need to.
             How?  

2. Highlight the text.

3. At the top of the screen, click the appropriate formatting button.

To remove any style, click the 
button again while the text is 
highlighted.

More Information

What if...

             The text looks the same after you changed it?  



Create a heading or title

1. Zoom in if you need to.
             How?  

2. Highlight the text.

3. Click the styles list at the top of the screen, and then click one of the Heading styles.

To remove the style, click the styles 
list, and then click Body Text.

More Information

What if...

             The text looks the same after you changed it?  
             The styles list isn't available?  

Concepts

             What's a paragraph style?  

Shortcuts

             Applying styles  



Add a title component

1. Point to a component, and then click the right mouse button. 

2. On the popup menu, point to Insert Component, and then click the title component you want to add.

Shortcut: Press SHIFT+F10 to display the popup menu.



Change the look of a heading or title

1. Zoom in if you need to.
             How?  

2. Highlight the text.

3. Click the styles list at the top of the screen, and then click a different Heading style.

To remove the style, click the styles 
list, and then click Body Text.

More Information

What if...

             The text looks the same after you changed it?  
             The styles list isn't available?  

Concepts

             What's a paragraph style?  

Shortcuts

             Applying styles  



Change the look of a title

1. Click the Design tab at screen left, and then click the Fonts tab.

2. On the Fonts tab, click and drag the scheme you want onto the title. 

Don't be afraid to experiment—
press CTRL+Z until you get your 
previous scheme back.



Indent a quotation

1. Zoom in if you need to.
             How?  

2. Highlight the text that you want as an indented quotation.

3. Click the styles list at the top of the screen, and then click Block Quote, Indent 1, or Indent 2.

To remove the style, click the styles 
list, and then click Body Text.

More Information

What if...

             The text looks the same after you changed it?  
             The styles list isn't available?  

Concepts

             What's a paragraph style?  

Shortcuts

             Applying styles  



Add a bulleted list

1. Zoom in if you need to.
             How?  

2. Highlight the text that you want to make into a list.

3. Click the styles list at the top of the screen, and then click Bulleted List 1 or Bulleted List 2.

To remove the bullet, click the 
styles list, and then click Body Text, 
Next List 1, or Next List 2.

More Information

What if...

             The text looks the same after you changed it?  
             You want to remove the bullet, but keep the indent?  
             The styles list isn't available?  

You can also...

             Make a nested list  

Shortcuts

             Applying styles  



Remove bullets from a list

1. Highlight the text that has bullets, letters, or numbers you want to remove.

2. Click the styles list at the top of the screen, and then click Body Text, Next List 1, or Next List 2. 

More Information

What if...

             The styles list isn't available?  

Shortcuts

             Applying styles  



Make a following paragraph with no bullet

1. Click the following paragraph.

2. Click the styles list at the top of the screen, and then click Next List 2. 

To remove the style, click the styles 
list, and then click Body Text.

More Information

What if...

             The text looks the same after you changed it?  
             The styles list isn't available?  

Concepts

             What's a paragraph style?  

Shortcuts

             Applying styles  



Make a nested list

1. Highlight the text that you want to make into a nested list.

2. Click the styles list at the top of the screen, and then click Bulleted List 2.

To remove the style, click the styles 
list, and then click Body Text.

More Information

What if...

             The text looks the same after you changed it?  
             The styles list isn't available?  

Concepts

             What's a nested list?  
             What's a paragraph style?  

Shortcuts

             Applying styles  



Copy or move text in the same document

1. Highlight the text.

2. On the Edit menu, click Copy or Cut.

3. If necessary, scroll to the page you want to add the text to.
             How?  

4. Click the text component or place the insertion point in the text, and then click Paste on the Edit menu.

More Information

What if...

             You pasted text in   i     publish   and nothing happened?  

You can also...

             Move intelligent components on the page  
             Reorganize components  

Shortcuts

             Cutting, copying, and pasting highlighted text  
             Dragging and dropping  



Delete highlighted text

1. Highlight the text you want to delete.

2. Press the DELETE or BACKSPACE key. 

To bring back the deleted text, 
press CTRL+Z before you take any 
other action.



Delete the text and its intelligent component

When you delete a text component, you remove both the component and its contents. 

1. Click the text component you want to remove.

2. On the Edit menu, click Delete Text Component.

If you deleted more than you 
expected, press CTRL+Z to undo it.

More Information

What if...

             You want to delete a component, but only part of it was deleted?  

You can also...

             Delete the text, but not its component  



Find text in your document

1. If you want to search specific text, highlight that text. Otherwise, i publish searches the entire document 
starting with the current page.

2. On the Edit menu, click Find.

3. In the Find box, type the text you want to find.

4. Click Find Next.

5. When you're finished, click Cancel.

More Information

What if...

             You want to search specific text only?  
             You're unsure of how to spell the words you're looking for?  

You can also...

             Search more efficiently  



Find and replace text in your document 

1. If you want to search specific text, highlight that text. Otherwise, i publish searches the entire document 
starting with the current page.

2. On the Edit menu, click Replace.

3. In the Find What box, type the text you want to find.

4. In the Replace With box, type the replacement text.
Tip: To delete the text you're searching for, leave this box empty.

5. Click Find Next to find the next occurrence of the text.

6. Do one of the following:
To change the found text, click Replace. 
To change all occurrences of the found text, click Replace All.
To continue searching without replacing the selected text, click Find Next.

7. When you're finished, click Cancel.

If you replaced the wrong text, 
press CTRL+Z to undo the 
replacement.

More Information

What if...

             You want to search specific text only?  
             You're unsure of how to spell the words you're looking for?  

You can also...

             Search more efficiently  



Check the document for misspellings

1. If you want to check specific text, highlight that text. Otherwise, i publish checks the entire document starting 
with the current page.

2. On the Edit menu, click Spelling.
When i publish finds a word that isn't in the current dictionary, it highlights the word and lists suggestions. 

3. Do one of the following:
To use a suggestion, click it, then click Change. 
To change all occurrences of the word to the suggested word, click Change All.
To type the word you want, highlight the word in the Change To box, type the word, and then click 

Change.
To have i publish move on without changing the word, click Ignore. To ignore all occurrences of the word, 

click Ignore All.

More Information

What if...

             You want to change the current dictionary  
             i     publish   keeps listing words, abbreviations, or acronyms you don't want to change?  
             There's no Spelling option on the menu?  



Preview your text before you add it

You can preview text that you stored on your computer, a floppy disk, a CD-ROM, or a server.

1. On the i publish File menu, click Open Existing Document.

2. Click the Files Of Type box, and then click All Files (*.*).

3. Find the file you want to preview, and then click Open.
             How?  

A message appears telling you that the file isn't an i publish file.
Note: This works for any program that is also an OLE (object linking and embedding) server.

4. Click OK.
The text file opens in its original program at screen left.

5. To return to the 
i publish tabs, 
click this button as 
many times as 
necessary. (It's at 
the top of the 
screen.)

More Information

What's next?

             Add text  

What if...

             You can't see your floppy drive or CD-ROM drive in Windows Explorer?  



Apply color to highlighted text

1. Highlight the text you want to apply color to.

2. On the toolbar, click the button below.

3. Click the color you want to use, or click Other to create a custom color.
             How do you create a custom color?  



Add a header or footer

Headers and footers repeat on most pages in a document; however, in some cases they don't appear, like on a 
cover page. Headers and footers typically contain information like the page number and company name.

Note: If you want to change the document title that appears in the header or footer, change that text in the main 
title of your document. i publish will automatically display the updated title in the header or footer.

1. Point to the document where there are no components, and then click the right mouse button. 
             What's an intelligent component?  

2. On the popup menu, point to Insert Component, and then click Header or Footer.
If you don't see the Header or Footer component on the list, then they are not available for this layout or type 
of document. 

3. Click the Caption component, and then type your text.

Shortcut: Press SHIFT+F10 to display the popup menu.



Change the style of text in a component 

In i publish, styles are used in text components that can accept more than a single paragraph. 

             Want to know more?  
1. Zoom in if you need to.
             How?  

2. Highlight the text.

3. Click the styles list at the top of the screen, and then click the style you want.

To remove the style, click the styles 
list, and then click Body Text.

More Information

What if...

             The text looks the same after you changed it?  
             The styles list isn't available?  

Concepts

             What's a paragraph style?  

Shortcuts

             Applying styles  



Drag and drop text from the control window

You can open a file with text in the control window, and then drag and drop it into your document.

1. On the i publish File menu, click Open Existing Document.

2. Click the Files Of Type box, and then click All Files (*.*).

3. Find the file you want to preview, and then click Open.
             How?  

A message appears telling you that the file isn't an i publish file.
Note: This works for any program that is also an OLE (object linking and embedding) server.

4. Click OK.
The text file opens in its original program at screen left.

5. Highlight the text you want, and then click and hold the left mouse button.

6. Move your pointer to a text component.

7. Watch your pointer.

Can't drop it. Can drop it.

8. To return to the 
i publish tabs, 
click this button as 
many times as 
necessary. (It's at 
the top of the 
screen.)

More Information

What if...

             You can't see your floppy drive or CD-ROM drive in Windows Explorer?  
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What if the whole intelligent component went away?

Press CTRL+Z to undo. When you try again, make sure that you click Clear on the Edit menu, not Delete.



What if the picture and its component went away?

Press CTRL+Z to undo. When you try again, make sure that you click Clear on the Edit menu, not Delete.



What if the whole text component went away?

Press CTRL+Z to undo. When you try again, make sure that you click Clear on the Edit menu, not Delete.



OLE



What if you couldn't add a table, chart, or diagram this way? 

Check the other program's documentation to make sure that it supports OLE.



What if the Paste Special command isn't available?

You may not have chosen the Copy command in the program in which you created the table, chart, or diagram. Or, 
the program you copied from doesn't support OLE for this type of object. 



What if the changes you made to the OLE object don't show up in i publish?

You may not have saved or updated the changes before you returned to i publish. After you click Exit & Return, 
make sure that you click Yes when you're asked whether you want to update the object. 



What if the File menu of the source program doesn't have an Exit & Return command?

Some programs may use different wording for the command. If it's not obvious which command to use, see the 
manual or online help for that program.



What if you can't drag your text onto the page? 

One of the following may be the problem:

You might have a picture component selected. Click a text component and try again.
You may be trying to drop a lot of text on a component that can only hold a small amount of text, such as 

a title. Try dropping the text onto a different text component.
             What are the rules for drag and drop?  

The text's format may not be supported by i publish. Try saving it in a format that i publish supports.
             What text formats are supported?  



What if you can't drag your picture onto the page? 

One of the following may be the problem:

You might be trying to drag the picture onto a text component that can't accept a picture, like a title. Try 
dragging the picture onto a different text component or onto a picture component (gray box).

The picture's format may not be supported by i publish. Try saving it in a format that i publish supports.
             What picture formats are supported?  



What if the text looks the same after you changed it?

You may not have highlighted the text before you tried to change it. Highlight the text, and then try changing it.



What if the colors or graphic effects look the same after you changed them?

Colors and graphic effects have sliders that set how much color and effects are applied.

1. On the Design menu, click Schemes.

2. Click the Level tab.

3. Under Colors Used or Graphic Effects Used, drag the slider further to the right.



What if you have a black and white printer, so you don't want to use color in your document?

The colors schemes have a slider that set how much color is applied to your document—you can turn the color off.

1. On the Design menu, click Schemes.

2. Click the Level tab.

3. Under Colors Used, drag the slider all the way to the left to "Off."



What if text prints as gray or black on your color printer?

Many people set their color printers to convert colors to shades of gray so that printing is faster. Check it 
out:

1. On the File menu, click Publish to Printer. 
2. Under Printer, click Properties. 
3. Check the settings to see if they're set to print in black and white colors (sometimes called grayscale).

If you use more than one printer, you may be printing to a non-color printer. Check it out:
1. On the File menu, click Publish to Printer. 
2. Under Printer, check what printer you're using. 

If necessary, switch to the color printer.



What if you can't see anything after you zoom in? 

Scroll up, down, or side-to-side, because you may be looking at a blank area of your page.

Or, you may not have clicked the text or picture before you zoomed. When nothing is selected, i publish zooms to 
the top, left corner of the current page. Zoom out, then click the text or picture and try zooming in again.

To zoom in, press CTRL+SHIFT and the = (equals) key.
To zoom out, press CTRL and the - (minus) key.
To go back to the last zoom setting, press F9.



What if your pictures don't look smooth?

Did you get your picture off the Web?

Pictures you take from the Web are usually 72 dpi (dots per inch), so although they look fine on your screen, you 
may not be satisfied with their printed quality. Typically, pictures in a magazine or other printed documents are 300 
dpi. Try using a higher resolution picture.

Is your picture a bitmap?

If you add a small bitmap to a large picture component, you may not get the results you want. i publish scales the 
bitmap to fit the space, which may cause the bitmap to look grainy. (i publish always scales it proportionally 
though.) Try saving the bitmap in a different file format.

Are you creating an onscreen presentation?

If your pictures don't look smooth in your onscreen presentation, try one of the following:

Use higher resolution pictures in your i publish document, so that when i publish enlarges them for the 
screen, they still have enough resolution to look good.

If you've tightly cropped the picture, try uncropping it to show more of the picture.
             How?  



What if you clicked and typed text, but you don't see your text anywhere?

You may have clicked a picture component or the entire document. Zoom in by pressing CTRL+SHIFT and the = 
(equals) key, click a text component, and then try typing your text again.



What if the styles list isn't available?

One of the following may be the problem:

You might have a picture component selected. Click a text component and try again.
You can only apply a style to a paragraph in a text component that can hold a lot of text. You may have a 

single paragraph text component selected, such as a title.



What if the control window (at screen left) has no buttons or tabs in it?

You probably installed i publish before you installed Microsoft Internet Explorer.

To solve the problem:

1. In Windows Explorer, open this folder: C:\Program Files\Design Intelligence\ipublish\Program.

2. Double-click the INSTFIX.EXE file. 

If the INSTFIX.EXE program finds that you have an older version of Internet Explorer, it displays a list of outdated 
files. You should use Microsoft Internet Explorer 3.02 or later.

If you have an older version of Internet Explorer:

1. Download and install Internet Explorer.
             How?  

2. In Windows Explorer, open this folder: C:\Program Files\Design Intelligence\ipublish\Program.

3. Double-click the INSTFIX.EXE file. 



What if you updated your Web page, but the changes didn't show up in your Web browser?

Using Internet Explorer

To be able to display pages quickly, your browser has a "cache" where it stores Web pages that you've already 
looked at. Sometimes you have to tell your browser to reload or refresh a page.

Click 
this button.

Using Netscape

Try Netscape's Refresh button first. If that doesn't work, it could be because Netscape sometimes has trouble 
refreshing Web pages that use HTML frames. Try this:

1. Click  to minimize your Netscape window.
2. Click Netscape in the Windows taskbar (at the bottom of your screen) to display it again.

You should now see your updated Web page.



What if the scheme changes in just one part of your document?

Make sure that you just click the scheme—if you drag and drop the scheme, it applies only to the component that 
you dropped it on.



What if the title changes size as you type?

As you type text into a title, i publish formats the text so that it fills the line. As you add more text, i publish 
reduces the size of your text. If you add too much text to fit on one line, i publish moves text to the next line and 
increases the text size so that both text lines fill the title space.



How does i publish handle imported fields, footnotes, and end notes?

In general, if you have fields, footnotes, or end notes in your original text file, those will not show up in i publish.



What if there's no Spelling option on the menu?

You may be in outline view, switch back to document view, and try again. You can't check your spelling in outline 
view, because it doesn't show you all of your text.

At the bottom of your screen, click the Document tab.



What if i publish crashes when you run Netscape Navigator or Microsoft Exchange?

If your program crashes when running i publish with Netscape Navigator or Microsoft Exchange, you may need to 
change the virtual memory setting for Windows.

1. Click the Windows Start button.

2. Point to Settings, and then click Control Panel.

3. Double-click System.

4. Click the Performance tab.

5. Under Advanced Settings, click Virtual Memory.

6. Make sure that "Let Windows Manage My Virtual Memory Settings (Recommended)" is selected.
This allows Windows to automatically shrink or grow the virtual memory based on usage.



What if nothing happens when you choose Publish to Printer?

You need to be in document view to print your document. 

If you're in outline view, click the Document tab at the bottom of the screen.



i publish minimum system requirements

486 or faster processor
16 MB RAM (32 MB recommended)
Windows 95 or Windows NT 4.0 (but not Windows 3.x or the Macintosh)
65 MB hard disk space
SVGA Monitor (800 x 600 and high color) recommended
Mouse or equivalent pointing device
Microsoft Internet Explorer 3.02 or later recommended

             How do you get this version?  



What if you can't drag text or pictures from a program and drop it into i publish?

The program may not work with the drag and drop feature, or the feature may be turned off. In that case, all you 
have to do is turn it on.

             How do you do that in Microsoft Word?  



What if you can't drag text from Microsoft Word and drop it into i publish?

If Microsoft Word's drag and drop feature is turned off, you cannot drag text out of Microsoft Word and drop it into 
your i publish document. To fix this:

1. On the Microsoft Word Tools menu, click Options.

2. Click the Edit tab.

3. Make sure that "Drag-and-Drop Text Editing" is checked.

4. Click OK.



What if you pasted text in i publish and nothing happened?

You may have tried to paste a lot of text into a component that could only hold a small amount of text. Try 
selecting a component that can hold more text (has a larger box), and try pasting the text again.

Or, the text may not have gotten copied or cut, so it can't be pasted. Try copying or cutting the text again.



What if your tab stops used to look right, but now they don't?

You may have switched your layout. If you switch from a 2-column layout to a 3-column layout, some of your tab 
stops may not be able to fit within the new column width. Try switching back to your previous layout.

             How?  

The Agenda document is formatted using tab stops, so if you change your layout to one with more columns, the 
tab stops will not look right. If this is the problem, switch back to the original layout.

Or, you may have changed your font scheme so that the font is larger, the tab stop positions may not be right for 
the new font. Try switching to a different font scheme.

             How?  



What if your text is too small?

The font scheme you're using may not suit your document. Try switching to a different font scheme.

             How?  

Or, if you have a lot of text or pictures on a page, i publish automatically handles most situations by reducing the 
size of the text or pictures. 

However, you can get to a point where i publish has to reduce your text to a font size that is smaller than you 
want. The reason this can happen is that i publish can't break some components across two pages, because that 
wouldn't look professional. 

             How can you tell when this happens, and how do you fix it?  



You're not sure how a word is spelled

If you know how to spell part of a word, but not the entire word, type the portion of the word you're certain of. 
Then, make sure there is no checkmark in the Find Whole Words Only box before you begin your word search.



Ways to search more efficiently

Do any of the following:

To find a specific word, but ignore instances of that word within other words (for example, to find let but 
ignore letter), click the Find Whole Words Only box.

To find text that matches the exact combination of capital and small letters you typed in the Find box, click 
the Match Case box.



Prevent i publish from stopping at words, abbreviations, or acronyms that you don't want to change

To prevent i publish from stopping at a particular word or abbreviation each time it's found, click Add when 
the word appears in the Not In Dictionary box. (This adds the word to your custom dictionary. As long as you're 
using the same custom dictionary, i publish will never stop on that word again.)



Why are there red boxes around some of your components?

In some cases, when too much text, pictures, or too many components are placed on a page, i publish has to do 
some work to attempt to fit them on the page. 

When your page is very full, and one of the Fit Status meters (at the bottom of the screen) is in the red, i publish 
draws a thin red line around all components that may be contributing to the fit problem. 

Note: If your page is so full that i publish can't accommodate the information, your text or picture may be clipped. 
In these cases, i publish draws a red box around that component, regardless of whether you have the option 
(below) turned off.

To turn this option off:

1. On the Edit menu, click Options.

2. Under General, click When Document Is Overfit, Highlight Contributing Components.

3. Click OK.
             How can you tell when your document is overfit?  
             What should you do when your document is overfit?  
             When is fitting an issue?  



What if i publish is slow after you change your document?

If i publish is taking too long to lay out your document, change the fit quality to Draft as you create your 
document, and then change it to Production when you're ready to print.

1. On the Edit menu, click Options.

2. Under Fit Quality, click the option you want:
Production precisely fits everything on the page. (Note: This option may make page layout slower.)
Proof lays out your page faster than Product, but slower than Draft.
Draft lays out the page quickly, but isn't as precise as Production or Proof. 

3. Click OK.



What if the text in your report is very small?

If you add a lot of text to the Document Title component, i publish scales the font size of all of the text in the 
document. So, the point size of your body text may become too small. Try any of the following:

Edit your title to make it shorter, and then click the main body text so that i publish can lay out your 
report again.

Split up your title into:
Main title—Put this in the Document Title component.
Subtitle—Put this in the Subtitle component. 
The Subtitle component uses a smaller font, so it can accommodate more text than the Document Title 

component.
Split up your title into:
Main title—Put this in the Document Title component.
Subtitle—Put this in the body text of your report, using a paragraph style: Heading 1, Section Head, or 

Deck Lead. 
             How do you apply a paragraph style?  



What if your text is clipped?

Some components, like pull quotes and sidebars, can only hold a certain amount of text. If you add more text than 
it can hold, your text will be clipped, and i publish will draw a red box around it (indicating that it is too full). To fix 
this, try any of the following:

Edit your text. 
Try changing the level of your graphic effects scheme. Or, try a different graphic effects, paragraph, or 

font scheme.
             How do you change the level of a graphic effects scheme?  
             How do you change a scheme?  

Try a different layout that gives more room to the component. 
             How?  



What if there is too much white space next to your picture?

If you add a picture that is very tall and narrow, i publish places it in the picture placeholder, but you may have a 
lot of white space next to the picture. To reduce the amount of white space: 

Reduce the height of your picture.
             How?  

Use a different picture.



What if there is a red box just around your picture?

If you add a picture that is very tall and narrow, i publish may not be able to accommodate it. If it's larger than will 
fit in your document, i publish draws a red box around it to tell you that you need to do one of the following:

Reduce the height of your picture.
             How?  

Use a different picture.



What if your Kodak PhotoCD picture is rotated?

i publish brings in photos from a CD as is; i publish has no way of knowing that you want a different side to be the 
top of the picture. So, if the image is rotated in your PhotoCD viewer, it will still be rotated in i publish. 

To fix this, import the photo into a graphics program, rotate it, and then save it.

             What picture formats are supported?  



What if your Web page doesn't print well to a black and white printer?

Some of the Web layouts have a bold background that looks great online. However, if you print it to a black and 
white printer, the printed background may be too dark. Black and white printers substitute black or dark gray for 
intense colors, so your Web page background may print very dark. 

To fix this:

1. Temporarily publish your Web pages using a different color scheme, such as Parchment with Black and White. 
             How?  

2. Print your Web page.
             How?  

3. Publish your Web pages again using the color scheme that you want for your Web site.
             How?  



What if you got an out of disk space message while printing?

Were you printing directly to a printer?

When you print your file, the printer software (driver) creates a temporary file on your computer's hard disk, and 
then the printer software sends the temporary file to the printer, using your network or your printer cable. When 
the complete temporary file is sent to the printer, the temporary file is removed from your hard disk. 

If you don't have enough available disk space to create the temporary file, the printer software will display an error 
message. If disk space is the problem, delete any unnecessary files to create more available hard disk space. 

You can also refer to your printer documentation for details.

Were you printing to a file (to print on an outside printer)?

When you print to a file, i publish uses the printer software (driver) to create a file: 
.prn file, if you're using a PCL printer.
.ps file, if you're using a PostScript printer.

If you don't have enough available disk space to create the file, the printer software will display an error message. 
If disk space is the problem, delete any unnecessary files to create more available hard disk space.

You can also refer to your printer documentation for details.

             Want to know more about printing your document on an outside printer?  

For additional details about printing, click Index and type Print, and then press ENTER.



What if you got an error message while installing SPRYNET from the i publish CD?

SPRYNET is an Internet service provider (ISP). You can install the SPRYNET software from the i publish CD, but it 
requires that your system be setup for Dial-Up Networking. 

For details about how to change your system, see the SPRYNET Readme file located on the i publish CD:

D:\SPRYNET\CD\Readme.txt. 

Search the SPRYNET Readme file for "DIAL-UP".



About importing HTML files into i publish

When you import an HTML file into i publish, all of the text imports, but i publish cannot import the pictures or style 
sheet information. The reason i publish can't import the pictures is that HTML files include graphics using a file 
reference, such as:

<IMG SRC="../art/art.gif">

i publish has no way of knowing if the picture file is on your computer, or if you got the HTML file from the Web, 
and the picture does not exist on your computer.

To include the text and pictures from an HTML Web page:

1. Import the HTML file.

Where is the HTML file stored?
             On a Web site  
             On your computer  

2. Import the picture.

Where is the picture file stored?
             On a Web site  
             On your computer  



Why can't you change the colors of a picture inside i publish?

i publish is designed to lay out your text and pictures. To change the color or color palette of a picture, use the 
program that created it, or another picture editing program. Then, add the picture to your i publish document 
again.



Why can't you resize an intelligent component?

Because i publish is an automatic page layout program, the size and location of every object on the page is 
determined by the layout you choose. This is your guarantee of an attractive finished document. If you don't like 
the size or location of a picture, try another layout that appeals to you—there are lots to choose from. 

Using Adjust Picture (Design menu), you can change the emphasis of a picture—thereby changing the picture's 
size.

             How?  

This applies only to pictures that are within wrapping text.



What if you don't want lines between columns?

The lines between columns come from the graphic effects scheme. Do one of the following:

Use a different graphic effects scheme that doesn't have rules.
             How?  

Set the graphic effects scheme to Off.
             How?  



What if your report text or logo changed after installing i publish 2.0?

i publish 2.0 uses content linking, so it automatically ensures that your cover page title, report title, and header 
text all match. 
If your title changed to something you don't want, simply change the title anywhere, and i publish will 
automatically update that information in all areas of your document.
             What if you don't want the text on your cover page and title page to match?  



What if you don't want the text or logo on your cover page and title page to match?

i publish automatically makes the text and logo on your cover page, title page, and header match. 

If you want them to differ: first change the layout of your document to use only a title page, and then create a 
different cover page document.

Change your document's layout to use only a title page

1. On the toolbar, click the Layout button, shown below.

2. At the bottom of the list, click Custom Layout.
3. Under Cover Treatment, uncheck Cover Page.

Create a different cover page document

1. On the File menu, click Create New Document.

2. Click Cover Page, and then click Next.

3. Click a template, and then click Next.

4. Click a scheme set, and then click Finish.



What if two letters are dropped capped?

Anytime you have a two letter word, i publish automatically applies the drop cap formatting to both.

If you don't like it, choose a paragraph scheme that doesn't use drop cap formatting.

             How?  



What if my quotes or apostrophes are dropped capped?

Anytime a quote or an apostrophe is one of the first two letters of a paragraph, i publish automatically applies the 
drop cap formatting to it.

If you don't like it, choose a paragraph scheme that doesn't use drop cap formatting.

             How?  



How do you import Microsoft Word '97 files?

Currently, i publish cannot import Microsoft Word '97 files. To import one of these files, save it in Word 6.0/95 
format.

1. Open your Microsoft Word '97 document.

2. On the Word '97 File menu, click Save As.

3. For Save As Type, click "Word 6.0/95."

4. Type a name and folder for the document, and then click Save.

5. Add the file to your document.
             How?  



What if one of my brochure panels takes up 2/3 of the page width?

By default, a brochure has 6 panels. If you delete one of the inside panels, the last panel will take up 2/3 of the 
page width.

             Want to know more about brochures?  

To add it back:

1. Point to the panel that you want to be to the left of the new panel, and press the right mouse button.

2. On the popup menu, click Insert Component, and then click Panel.

3. Switch to outline view.
             How?  

4. At the bottom of the outline, click  next to "Panel" to expand it.
5. Point to a Panel Block, and press the right mouse button.
6. On the popup menu, click Insert Component, and then click Picture, Text Block, or Sidebar.
7. Switch back to document view, and then add your text and pictures.
             How do you add text?  
             How do you add pictures?  



What if your computer is slow while running i publish?

If your computer has 16 MB of RAM or less, your computer may slow down while running i publish. The reason is 
that the i publish control window (screen left) uses Microsoft Internet Explorer, and Internet Explorer requires at 
least 16 MB of RAM. So, that may be slowing down your computer. 

To fix this:

While you're editing your document, change your view to just show the document window. (On the View 
menu, click Document Window Only.)



What if the tabs in your Web page or onscreen presentation don't look right?

When i publish converts your document to a Web page or onscreen presentation, it uses a fixed width space for 
each tab, because HTML doesn't use tabs. If your tabs don't align well in your online document, try this:

1. Set multiple tab stops at regular intervals, such as: .5", 1.0", 1.5", and so on. 
If you've set tab stops for multiple paragraphs, apply the same tab stops to all of the paragraphs. 

             How?  
2. Publish your document again as a Web page or an onscreen presentation.
             How?  

Note: The Agenda document is formatted using tab stops, so it may take some tweaking before your document 
looks the way you want as a Web page or an onscreen presentation.



What if you changed the font size for a Banner or Kicker component, but you don't see a change?

Try any of the following:

Try scaling each component that makes up the Banner or Kicker.
             How?  

Try reducing the amount of text in the component. i publish may be having trouble fitting the component 
in the allocated space.
             What else can you do to make a component fit?  



What if you changed the emphasis of your newsletter picture, but you don't see a change?

If your layout has pictures at the left or right (not within columns of text), then i publish keeps the pictures the 
same size, but places the pictures in the order of emphasis. The picture with the most emphasis is placed first in 
the document, the picture with the next most emphasis is placed second, and so on.

If you want your pictures to be different sizes, under "Columns and Picture Placement," choose "Pictures Within 
Text Columns" in the Custom Layout dialog box.

             How?  







Move between pages

To move between 
pages, click the scroll bar 
on the right side of the 
screen. 

At the bottom of your screen, you'll see information telling you which page(s) you're looking at.

More Information

Shortcuts

             Viewing the page  
             Zooming in or out  



Zoom in or out

To zoom in, press CTRL+SHIFT and the = (equals) key.
To zoom out, press CTRL and the - (minus) key.
To go back to the previous zoom setting, press F9.

More Information

What if...

                You can't see anything after you zoom in?  
             You want to scroll to another page  

Shortcuts

             Viewing the page  
             Zooming in or out  



Switch between document view and outline view

At the bottom of your screen, click the appropriate tab.

More Information

You can also...

             Reorganize components  
             Edit text in outline view  



Reorganize components

You can reorganize and rearrange text and pictures in a newsletter, flier, catalog, bulletin, restaurant menu, or 
onscreen presentation using the Outline view.

1. To switch to Outline view, click the Outline tab at the bottom of the screen.

2. To expand a compound component to see its sub-components, click  next to that compound component.
Tip: Compound components are represented by a colored icon, and their names are in bold type.

3. Click the icon next to the component (not  or 
)and drag it before or after other components in the list.

Tip: To make an Item or Story component the first one in the list, drop it on the "Item List" or "Stories" 
component.
When you drop an Item or Story component on another one, i publish places the dropped component after the 
one you dropped it on. For example, if you drop B onto A, i publish puts A first, and then B next. 

4. To switch back to Document view, click the Document tab at the bottom of the screen.

More Information

You can also...

             Edit text in outline view  



Edit text in outline view

1. If you haven't already done so, click the Outline tab at the bottom of the screen.

2. To expand a compound component to see its sub-components, click  next to that compound component.
Tip: Compound components are represented by a colored icon, and their names are in bold type.

3. Point to a text component, and then click the right mouse button. 
4. On the popup menu, click Edit.
5. Type or edit your text, and then click OK.

Shortcut: Press SHIFT+F10 to display the popup menu.

More Information

You can also...

             Reorganize components  



See multiple pages at once

Click the zoom box at the top of the screen, and then click 25% (or a smaller percentage).

Or, press CTRL and the - (minus) key until you can see more than one page.

More Information

Shortcuts

             Viewing the page  
             Zooming in or out  



See more of your document or the control window

1. Position your pointer over the border between the control window (at screen left) and the document window. 

2. When you see this pointer, 
drag the bar to the left or 
right.

More Information

Shortcuts

             Viewing the page  



Make your document fill the screen

By default, i publish displays both the control window (at screen left) and your document. You can adjust this view 
to see just your document.

On the View menu, click Document Window Only.

To see your document and the 
control window together again, on 
the View menu, click Document and 
Control Windows.

More Information

Shortcuts

             Viewing the page  



Make the control window fill the screen

By default, i publish displays both the control window (at screen left) and your document. You can adjust this view 
to see just the control window.

On the View menu, click Control Window Only.

To see your document and the 
Control Window together again, on 
the View menu, click Document and 
Control Windows.

More Information

Shortcuts

             Viewing the page  
             Viewing pages on the Web  



Find out what layout and which schemes are applied to your document

On the toolbar, click the appropriate button. 
The applied scheme or layout has a checkmark next to it.

Layout Font Color Graphic 
effect 

Paragraph 





The next 2 topics are almost identical



What do you want to do?

             Move between pages  
             Zoom in or out  
             Switch between document view and outline view  
             View your document as a Web page or an onscreen presentation  
             Change the   i     publish   window  
             What you want to do isn't listed here  



Leave this paragraph here...for some (unknown) reason, it makes the next topic appear properly.



What do you want to do?

             View your document as a Web page  
             View your document as an onscreen presentation  



What do you want to do?

             See more of your document or the control window  
             Make your document fill the screen  
             Make the control window fill the screen  





Tips: Writing and presenting an onscreen presentation

             Advantages of doing onscreen presentations  
             Writing a presentation  
             Preparing for your presentation  
             Giving your presentation  
             What's an onscreen presentation?  



Tips: Advantages of doing onscreen presentations

When you do a presentation using a 35mm slide carousel or an overhead projector, you need to factor in a lot of 
lead time to print or develop your slides. 

With an onscreen presentation, you can change your presentation up to the last minute. For example, you can 
customize your presentation by adding your client's company name. This personal touch could lead to future sales!



Tips: Writing your presentation

             How do you create an onscreen presentation?  

Use these ideas to organize your presentation

Beginning of presentation
Tell them what you're going to tell them—Give an overview of your presentation.

¼ into presentation
Present your key points. Make sure that you follow the outline you established in your presentation.

½ into presentation
Present the small details. Again, follow your outline.

¾ into presentation
Tell them what you told them—Start wrapping up and hit your key points again.

Ending of presentation
Question—Leave a little time at the end for audience questions.

Other tips to look professional

Spelling and proofing
This might be the most important step towards looking professional. Check your spelling and have someone 
else read through it to be sure there are not grammatical errors. 

             How do you check your document for misspellings?  
Keep it short

Many presenters make the mistake of including every detail on the presentation slides. Just hit the highlights on 
your slides so that your audience doesn't spend a lot of time reading instead of listening. 



Tips: Preparing for your presentation

Presentation notes—Print out your slides, and then make notes on them about what additional information 
you want to cover. You may not need this, but it will make you feel calm to know the information is available if you 
need it.
             How?  

Preview your presentation—Make sure you run all the way through your presentation to be sure it's just 
the way you want it.
             How?  

Practice makes perfect—Try practicing in front of a mirror to help you become comfortable. Practice hand 
gestures, walking away from the podium, and pointing at the screen.

Audience handouts—Print out your slides and make copies for your audience so that your audience can 
focus on your message. (This also makes you look very professional.)
             How?  



Tips: Giving your presentation

             How do you view your document as an onscreen presentation?  

Use these ideas to prepare and give your presentation

Arrive early—Make sure you have plenty of time to set up your computer and test it before people arrive.
Talk slowly—Try talking more slowly than you think you should; you'll end up talking at normal speed.
Rely on experts—If you're asked a question that you don't know, ask the audience for help. You don't have 

to be the only expert.
Relax—You've prepared and practiced, so you will be able to make the impact you want.







Add a Web address (URL)

To create a jump to another Web site or an FTP server address, type the full Web address (URL) anywhere in any 
document (except in To, From, or Date components). When i publish creates the Web page, it automatically creates 
the link for you.

i publish will automatically create a jump when you use any of the tags in this table.

Include this... Followed by this...

http://

(This is 
optional if 
www is at 
the start.)

Web site or Web page, such as:
http://www.design-

intelligence.com/
www.design-

intelligence.com
http://www.design-

intelligence.com/
support/support.html

NEWS: Newsgroup, NNTP

MAILTO:

(This is 
optional)

Email address, such as 
YourName@InternetProvider.com

TELNET: Telnet (remote computer access)

GOPHER:// Gopher site (text info)

FTP:// FTP site (file transfer)

Or, if you want to use an i publish component, so that the Web address moves around your page intelligently as 
you change the layout: 

1. Point to the component that you want to add a Web address to, and then click the right mouse button. 

2. On the popup menu, point to Insert Component, and then click Web Address.
If you don't see Web Address on the list, then this component cannot contain a Web Address component. You 
can still type your Web address, but i publish won't be able to turn it into a link in your Web page.

3. Zoom in if you need to.
             How?  

4. Click the Web Address component and type your Web address (also called a URL).

Shortcut: Press SHIFT+F10 to display the popup menu.

More Information

You can also...

             Add a way for readers to respond via email  



Add a way for readers to respond via email

To create a way for readers to respond via email, simply type your email address anywhere in your document 
(except in To, From, or Date components). When i publish creates the Web page, it automatically creates the email 
link for you. For example: 

MyName@WebProvider.com 

Or, if you use an i publish component, the email address moves around your page intelligently as you change the 
layout: 

1. Point to the component that you want to add an Email Address component to, and then click the right mouse 
button. 

2. On the popup menu, point to Insert Component, and then click Email Address.
If you don't see Email Address on the list, then this component cannot contain an Email Address component. 
You can still type your email address, but i publish won't be able to turn it into a link in your Web page.

3. Zoom in if you need to.
             How?  

4. Click the Email Address component and type your email address, such as:
YourName@InternetProvider.com

Shortcut: Press SHIFT+F10 to display the popup menu.

More Information

You can also...

             Add a Web address (URL)  







Toolbars

Click the pictures below to see what each button does.

Main toolbar

Format toolbar

Navigation toolbar

Design toolbar

Status bar



Main toolbar



New—Creates a new document.

More information

             Create a new document  



Open—Opens an existing document.

More information

             Open an existing document  



Save—Saves the open document.

More information

             Save your document  
             Save a component that you created  



Print—Prints the document.

More information

             Print your document  



Spell Check—Checks the spelling of the document.

More information

             Check spelling  



Find—Finds specific text.

More information

             Find or replace text  



Cut—Cuts the selection and places it on the Windows clipboard.

More information

             Copy, move, resize, delete, or clear an object  



Copy—Copies the selection and places it on the Windows clipboard.

More information

             Copy, move, resize, delete, or clear an object  



Paste—Pastes the contents of the Windows clipboard in your i publish document.

More information

             Copy, move, resize, delete, or clear an object  



Undo—Undoes the last action.



Redo—If you undo an action, you can do the action again. 

For example, if you apply bold formatting to text, then undo that formatting, click this button to apply the bold 
formatting again.



Zoom—Zooms in to get a closer look or zooms out to see the whole page.

More information

             Zoom in or out  



Format toolbar



Paragraph Styles—Changes the paragraph style of the selected text.

More information

             Change text in a component that's longer than a paragraph  



Bold—Bolds the selected text.

More information

             Emphasize a few words (bold, italic, underlined...)  



Italic—Italicizes the selected text.

More information

             Emphasize a few words (bold, italic, underlined...)  



Underline—Underlines the selected text.

More information

             Emphasize a few words (bold, italic, underlined...)  



Font Color—Changes the color of the selected text.

More information

             Apply color to highlighted text  



Scale Document Fonts—Increases or decreases the font size of the entire document.

More information

             Change the font size for the entire document  



Scale Component Fonts—Increases or decreases the font size of the selected component.

More information

             Change the font size for part of the document  



Picture Emphasis—Changes the size of the selected picture. (Picture must be in flowing text.)

More information

             Resize a picture  



Layouts—Changes the layout of the entire document.

More information

             Change the layout of your print document  
             Change the layout of your onscreen presentation  
             Change the layout of your Web page  



Font Schemes—Changes the font scheme for the entire document.

More information

             Change the font scheme  
             What's a font scheme?  
             Set up your own font scheme  
             Apply your own font scheme  



Color Schemes—Changes the color scheme for the entire document.

More information

             Change the color scheme  
             What's a color scheme?  
             Set up your own color scheme  
             Apply your own color scheme  



Graphic Effects Schemes—Changes the graphic effects scheme for the entire document.

More information

             Change the graphic effects scheme  
             What's a graphic effects scheme?  



Paragraph Schemes—Changes the paragraph scheme for the entire document.

More information

             Change the paragraph scheme  
             What's a paragraph scheme?  



Navigation toolbar



Back—Displays the previous page in the control window.



Next—Displays the next page in the control window.



Stop—Stops a Web page from loading into the control window.



Refresh—Refreshes the Web page in the control window.



Grab Tab—Displays the Grab Tab.



Design Intelligence on the Web—Displays the Design Intelligence Web site in the control window. 



Web Site—After you enter a Web address, displays that Web site in the control window.

More information

             Type a specific Web address  
             Drag and drop pictures or text from the Internet or the Web  



Status bar



Text Fit Status—Shows how well the text fits in your document.

More information

             How does   i     publish   fit text and pictures on a page?  
             See if you have too much text or too many pictures  



Graphics Fit Status—Shows how well the pictures fit in your document.

More information

             How does   i     publish   fit text and pictures on a page?  
             See if you have too much text or too many pictures  



Pages—Shows the page that is currently displayed, and how many pages there are in the document.





Path:
Add, replace, or change something
ADD OR CHANGE INTELLIGENT COMPONENTS



Add a new component

1. Click the Design tab at screen left.

2. Click the Components tab and find the component you want to add.
You'll see a list of components you can add to your document. This list varies by document group.

3. Drag the component onto your document, and then drop it. (Watch your pointer.)
i publish knows where to put the component based on the layout.

Can't drop it. Can drop it.

More Information

What's next?

             Add text  
             Add pictures  
             Reorganize components  

Concepts

             What's an intelligent component?  

Shortcut

             Add a new component to an existing component  



Add a new component to an existing component

1. Point to a text component or a picture component, and then click the right mouse button. 

2. On the popup menu, point to Insert Component, and then click the component you want to add.

Shortcut: Press SHIFT+F10 to display the popup menu.

More Information

What's next?

             Add text  
             Add pictures  



Add a new text component

1. Point to the document or a component, and then click the right mouse button. 
             What's an intelligent component?  

2. On the popup menu, point to Insert Component, and then click the component you want.
If you don't see the component you want, try clicking somewhere else. The component you want may not be 
available for this layout or type of document. 

Shortcut: Press SHIFT+F10 to display the popup menu.

More Information

What's next?

             Add text  



Add a new picture component

1. Point to the component that you want to contain the picture component, and then click the right mouse button. 
             What's an intelligent component?  

2. On the popup menu, point to Insert Component, and then click Picture.
If you don't see the Picture component on the list, then a Picture component may not be available for the 
selected component. 

Shortcut: Press SHIFT+F10 to display the popup menu.

More Information

What's next?

             Add a picture  
             Add a caption to your picture  



Add a new component to hold a table, chart, or diagram

If there is no place in your document for a new table, chart, or diagram, add a Picture component, and then fill it 
with your table, chart, or diagram.

1. Point to the component that you want to contain the table, chart, or diagram, and then click the right mouse 
button. 

             What's an intelligent component?  
2. On the popup menu, point to Insert Component, and then click Picture.

If you don't see the Picture component on the list, then a Picture component is not available for the selected 
component. 

Shortcut: Press SHIFT+F10 to display the popup menu.

More Information

What's next?

             Add a table, chart, or diagram  



Copy or move a component (such as a picture or a sidebar) within wrapping text 

Note: For many documents, you can change where pictures, pull quotes, or sidebars appear on the page.
             How?  

Select the component

1. Point to the component, and then click the right mouse button. (Or press SHIFT+F10.)

2. On the popup menu, point to Select, and then click the component you want.
If there is more than one component on the menu, the last component is the one that contains all the other 
listed components.

Depending on how you like to work, you can either drag the component to the new paragraph, or use Copy and 
Paste.

Drag the component onto a different paragraph

With the component selected, drag the component's border onto a paragraph, and then drop it. (Watch 
your pointer.)

To copy the component, press CTRL while you drag the component's border.

Can't drop it. Can drop it.

Note: The component will stay near the paragraph you dropped it onto. Wherever you move the paragraph, the 
component stays with it.
i publish places the component based on the current layout.

Copy or paste the component onto a different paragraph

1. With the component selected, on the Edit menu, click Copy or Cut.

2. If necessary, scroll to the page you want to add the component to.
             How?  

3. Click a paragraph. 

4. On the Edit menu, click Paste.
Note: The component will appear near the paragraph you clicked. Wherever you move the paragraph, the 
component stays with it.
i publish places the component based on the current layout.



Move a component by changing the layout

By changing the layout, you can dramatically change your document.

1. Click the Design tab at screen left.

2. Click the Layouts tab.

3. Scroll through the list of layouts, and then experiment by clicking until you find the one you like. 
Every time you click a layout, your document reflects the changes.

If you don't like the layout, just 
click a different one.

More Information

You can also...

             Find out what schemes and layout are applied to your document  



Copy or move a component into wrapping text in another document

1. With i publish already running in an open window, open i publish again.
             How?  

2. In the second copy of i publish, open the i publish document that contains the component you want.

3. Point to the component, and then click the right mouse button. (Or press SHIFT+F10.)

4. On the popup menu, point to Select, and then click the component you want.
If there is more than one component on the menu, the last component is the one that contains all the other 
listed components.

5. On the Edit menu, click Copy or Cut.

6. Display the i publish document that you want to add the component to.

7. Click a paragraph. 

8. On the Edit menu, click Paste.
Note: The component will appear below the paragraph you clicked. Wherever you move the paragraph, the 
component stays with it.
i publish places the component based on the current layout.

Note: For many documents, you can change where pictures, pull quotes, or sidebars appear on the page.

             How?  

If you don't like where the 
component landed, press CTRL+Z 
to undo the move.



Copy or move a component into another document

1. With i publish already running in an open window, open i publish again.
             How?  

2. In the second copy of i publish, open the i publish document that contains the component you want.

3. Point to the component, and then click the right mouse button. (Or press SHIFT+F10.)

4. On the popup menu, point to Select, and then click the component you want.
If there is more than one component on the menu, the last component is the one that contains all the other 
listed components.

5. On the Edit menu, click Copy or Cut.

6. Display the i publish document that you want to add the component to.

7. Click a component in the second copy of i publish.

8. On the Edit menu, click Paste.
i publish places the component based on the current layout, and the i publish drag and drop rules.

If you don't like where the 
component landed, press CTRL+Z 
to undo the move.

More Information

Concept

             Drag and drop rules  



Delete a component

When you delete an intelligent component, you remove both the component and its contents. 

Note: If your component is larger than one page, even though you might be looking at just one page, i publish will 
delete the component from all of the pages in your document.

1. Point to the component, and then click the right mouse button. 

2. On the popup menu, point to Select, and then click the component you want. 
If there is more than one component on the menu, the last component is the one that contains all the other 
listed components.
i publish places a border around what will be deleted.

3. On the Edit menu:
Click Delete to delete a picture component.
Click Delete Text Component to delete a text component.

i publish removes all the text, the picture if there is one, and the intelligent component, too.

Shortcut: Press SHIFT+F10 to display the popup menu.

If you deleted more than you 
expected, press CTRL+Z.

More Information

Shortcuts

             Selecting compound components  



Clear a component

When you clear an intelligent component, you remove the text and pictures, but the empty component remains in 
your document. 

Note: If your component is larger than one page, even though you might be looking at just one page, i publish will 
clear the component from all of the pages in your document.

1. Click the text or picture you want to remove. (You don't need to highlight the text.)

2. On the Edit menu, click Clear.
i publish removes the text or picture, but leaves the intelligent component in your document.

Note: To clear a compound component, clear its text or pictures one at a time.

If you cleared more than you 
expected, press CTRL+Z.

More Information

What if...

             The whole intelligent component went away?  



Change the look of an intelligent component

You can change the color, graphic effects, font, or paragraph scheme of a component to completely change its look.

1. Click the Design tab at screen left.

2. Click the Colors, Effects, Fonts, or Paragraphs tab.

3. Click and drag the scheme you want onto the component. 

Tip: To change just the font size of a component: click it, click the button below on the toolbar, and then click a font 
size.

If you don't like the new scheme, 
press CTRL+Z to undo it or click a 
different scheme.



Change the font size of a component

1. Select the component you want to change. 

2. On the toolbar, click the button below.

3. Click the font size you want.



Change the font scheme for an intelligent component

1. Click the Design tab at screen left.

2. Click the Fonts tab.

3. Click and drag the scheme you want onto the component. 

If you don't like the new scheme, 
press CTRL+Z to undo it or click a 
different scheme.



Change the paragraph scheme for an intelligent component

1. Click the Design tab at screen left

2. Click the Paragraphs tab.

3. Click and drag the scheme you want onto the component. 

If you don't like the new scheme, 
press CTRL+Z to undo it or click a 
different scheme.



Change the color scheme for an intelligent component

1. Click the Design tab at screen left.

2. Click the Colors tab.

3. Click and drag the scheme you want onto the component. 

If you don't like the new scheme, 
press CTRL+Z to undo it or click a 
different scheme.



Change the graphic effects scheme for an intelligent component

1. Click the Design tab at screen left.

2. Click the Effects tab.

3. Click and drag the scheme you want onto the component. 

If you don't like the new scheme, 
press CTRL+Z to undo it or click a 
different scheme.



Clear all the text in a text component, but not the component itself

When you clear a text component, you remove the text, but leave the empty text component in your document. 

1. Click the text component you want to clear. (You don't need to highlight the text.)

2. On the Edit menu, click Clear. 

To bring back the deleted text, 
press CTRL+Z before you take any 
other action.

More Information

What if...

             The whole text component went away?  



Apply your own color scheme to part of the document

You can create a color scheme using a color you choose, and then apply it to just one component in your 
document, such as a Nameplate.

1. Point to the component, and then click the right mouse button. 

2. On the popup menu, point to Select, and then click the component you want.

3. On the Design menu, click Schemes.

4. Click the Colors tab, and then click Custom Color Scheme 1 or Custom Color Scheme 2.

5. Click the Advanced tab.

6. Under Apply To, click what part of the document you want to use the color scheme.

7. Click Clear Overrides First to add a checkmark, and then click OK.

Shortcut: Press SHIFT+F10 to display the popup menu.

More Information

How do you...

             Set up your own color scheme  



Apply your own font scheme to part of the document

You can create a font scheme using two fonts from your system, and then apply it to just one component in your 
document, such as a Nameplate.

Note: If you want to show your document on other computers, you may need to copy those font files to the other 
computers. (Make sure you check your font license agreement to ensure your license allows you to copy the fonts.) 

If you don't copy the font files, and the new computer does not have the font you used for the scheme, Windows 
will substitute a font, such as Courier.

1. Point to the component, and then click the right mouse button. 

2. On the popup menu, point to Select, and then click the component you want.

3. On the Design menu, click Schemes.

4. Click the Fonts tab, and then click Custom Font Scheme 1 or Custom Font Scheme 2.

5. Click the Advanced tab.

6. Under Apply To, click what part of the document you want to use the font scheme.

7. Click Clear Overrides First to add a checkmark, and then click OK.

Shortcut: Press SHIFT+F10 to display the popup menu.

More Information

How do you...

             Set up your own font scheme  



Create your own intelligent component 

You can save a component you've created so that you can use it in other documents. For example, if you get your 
nameplate just the way you like it, you can save it and use it in other documents. 

When you add an intelligent component that you've created, i publish automatically changes it to match the current 
document's layout. However, if you applied a scheme to just that component, that scheme remains applied to the 
new component in the new document.

1. Select the entire component you want to save. 
             How?  

2. On the File menu, click Save Component.

3. In the Save In section, find the folder where you want to save the component.

4. In the File Name box, type a file name for the component (ending in .dio).

5. Click Save.

More Information

What's next?

             Add an intelligent component that you created  



Add an intelligent component that you created

1. On the File menu, click Import, and then click Component File.

2. Find your saved component.
             How?  

3. Click OK to insert it into your document.

More Information

How do you...

             Create your own intelligent component  



Change the look of all similar intelligent components 

You can change the font, color, graphic effects, or paragraph scheme of all similar components to completely 
change their look. For example, you could change all of the products in a catalog at once to a specific color 
scheme.

1. Point to one of the components, and then click the right mouse button. 

2. On the popup menu, point to Select, and then click the component you want.

3. On the Design menu, click Schemes.

4. Click the Fonts, Colors, Effects, or Paragraphs tab, and then click the scheme you want.

5. Click the Advanced tab.

6. Under Apply To, click what part of the document you want to change.

7. Click Clear Overrides First to add a checkmark, and then click OK.

Shortcut: Press SHIFT+F10 to display the popup menu.

If you don't like the new scheme, 
press CTRL+Z to undo it.



Set the default folder for saved components

1. On the Edit menu, click Options. 

2. Click the File Locations tab.

3. Under Type, select Component Files.

4. Click Modify.

5. Find the folder in which you want to keep these files.

6. Click OK until you return to your document.

More Information

How do you…

             Create your own intelligent component  
             Add an intelligent component that you created  





What do you want to do?

              Split files across multiple floppy disks  
              Combine split files back into one file  



Split files across multiple floppy disks

If you need to put your i publish file (or another file) on a floppy disk, but it's too large to fit on one disk, you can split 
the file across multiple disks.

1. On the i publish File menu, click "Split File Across Multiple Disks."

Or, if you don't have i publish open, click the Windows Start button, point to Programs, point to i publish, and then 
click "Split File Across Multiple Disks." 

2. Click the Browse button, and then select the file you want to split up.

Tip: To choose a file other than an i publish file (like a Microsoft Word file), click the Files Of Type box, and then 
click All Files (*.*).

3. If necessary, change the Output Drive box to your floppy disk drive letter.

4. Click Split.

5. Insert floppy disks as prompted.

Note: For best results, use empty floppy disks.

6. When you're finished, click Close.

More Information

How do you...

              Combine split files back into one file  



Combine split files back into one file

If you've split a file across multiple floppy disks, you can combine them back into one file.

1. On the i publish File menu, click Combine Split Files.

Or, if you don't have i publish open, click the Windows Start button, point to Programs, point to i publish, and then 
click Combine Split Files.

2. If necessary, change the Input Drive to your floppy disk drive letter.

3. Click the Browse button, and then select the folder where you want to save the combined file.

4. Click Combine.

5. Insert the floppy disks as prompted.

6. When you're finished, click Close.

More Information

How do you...

              Split files across multiple floppy disks  



Split File Across Multiple Disks File menu

If you need to put your i publish file (or another file) on a floppy disk, but it's too large to fit on one disk, you can split 
the file across multiple disks.

Note: For best results, use empty floppy disks.

Click the picture below for details about each option. 

More Information

How do you...

              Split files across multiple floppy disks  
              Combine split files back into one file  



Split File Across Multiple Disks dialog box—Input File Name



Specifies the file that will be split across multiple floppy disks. Click Browse to open the "Open" dialog box in which 
you can select the file you want to split across floppy disks.

              Show me the Open dialog box.  



Split File Across Multiple Disks dialog box—Output drive



Specifies the floppy disk drive letter where the split file will be copied.



Split File Across Multiple Disks dialog box—Split



Starts splitting the file across multiple floppies.



Split File Across Multiple Disks dialog box—Close button



Closes the "Split File Across Multiple Disks" program.



Combine Split Files File menu

If you've split a file across multiple floppy disks, you can combine it back into one file.

Click the picture below for details about each option. 

More Information

How do you...

              Split files across multiple floppy disks  
              Combine split files back into one file  



Combine Split Files dialog box—Input Drive



Specifies the floppy disk drive letter.



Combine Split Files dialog box—Output Folder



Specifies the folder where you want to save the combined file. Click Browse to open the "Browse For Folder" dialog 
box in which you can set which folder you want to save the combined file.

              Show me the Browse For Folder dialog box.  



Combine Split Files dialog box—Combine



Starts combining the split files.



Combine Split Files dialog box—Close button



Closes the Combine Split Files program.



Open

Specifies the file that you want to split across multiple floppy disks.

Click the picture below for details about each option. 

More Information

How do you...

              Split files across multiple floppy disks  
              Combine split files back into one file  



Open dialog box—Look In combo box



Lists the available drives and folders.

To open a document on a different drive or folder, click this box, and then click the drive or folder you want. The 
contents of the current drive or folder appear below the Look In box.

To open the folder one level above the current one, click .



Open dialog box—Toolbar button—Up one level



Click this to move up one folder in the folder structure.



Open dialog box—Toolbar button—Add new folder



Click this to add a new folder within the currently open folder.



Open dialog box—Toolbar button—List



Click this to show the files and folders in a list.



Open dialog box—Toolbar button—Details



Click this to show all details about your files and folders, such as names, file sizes, types of files, and modification 
dates.



Open dialog box—File name list



Lists the files and folders contained within the drive or folder displayed in the Look In box. To see what's inside a 
folder, double-click it.

You can also click the Look In box to see the hierarchy of folders.

To open the folder one level above the current one, click .



Open dialog box—File name edit box



To specify the file that you want to open or find, type its name in this box.



Open dialog box—Files of type combo box



To choose a file other than an i publish file (like a Microsoft Word file), click the Files Of Type box, and then click All 
Files (*.*).



Open dialog box—Open button



Specifies the file that will be split across multiple disks.



Browse For Folder

Sets the folder in which the combined file is saved.

Click the picture below for details about each option. 

More Information

How do you...

              Split files across multiple floppy disks  
              Combine split files back into one file  



Browse For Folder dialog box—List



Lists all drives the folders on each drive. Click the one you want to save the combined file in.



Browse For Folder dialog box—OK



Sets the folder in which the combined file is saved.



Browse dialog box—Cancel button



Closes the dialog box without saving any changes you made.



These are the context sensitivity numbers.

UI Help Text ID Help # 
context ID

With 
131072 
added

SPLITTER File > Split File Across Multiple 
Disks

IDH_SPLITTER 4000 135072

SPLITTER File > Combine Split Files IDH_UNSPLITTER 4010 135082

SPLITTER Browse For Folder IDH_SPLIT_BROWSE 4020 135092

SPLITTER Open IDH_SPLIT_OPEN 4030 135102

SPLITTER Main topic IDH_SPLIT_MAIN 4040 135112






