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Welcome to OfotoNow  
 
Thanks for downloading OfotoNow. This easy-to-use photo-editing tool helps you get 
your digital photos ready for printing by Ofoto. 
 
Many software programs let you improve or alter your photos in a wide variety of ways. 
Usually, however, you only need to make a few simple corrections - trim the photo a bit, 
or get rid of the red flash in your subject's eyes. We don't think you should have to pay to 
make a simple fix to your photos.  We've created OfotoNow to give you the basic photo-
editing functions you need. 
 
The OfotoNow User Manual explains how you can use OfotoNow to get the very best 
photographic prints from your digital photos. Use OfotoNow to: 
 

• Get your photos from a digital camera or scanner to your computer. 
 

• View all your photos: zoom in or out within each photo, view all images as 
thumbnails, view your images as a slideshow, make copies of the photos and save 
them to a different location. 

 
• Make sure your photo looks just the way you want before you print it.  You can 

rotate your photo onscreen to make it appear right side up, trim out the parts you 
don’t want to print, and even fix the “red-eye” flash effect. 

 
• Upload your photo to Ofoto and receive the finest printed photos on Professional 

Kodak paper – without leaving home! 
 
 
System Requirements 
 
OfotoNow for Windows requires a Pentium class machine running Windows 95, 98, 
98SE, ME, NT (with Service Pack 4 and above), and 2000.  For best results these 
machines should be equipped with at least 32Mb of RAM (64Mb for NT and 2000) and a 
video card that supports thousands of colors (16 bit) at 800x600 pixel resolution. 
 
OfotoNow for the Macintosh requires OS 8.6 and above. For best results these machines 
should have 32Mb, or more, of RAM installed. 
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Getting Help 
 
OfotoNow is a very simple tool that's easy to understand and use. If you do have trouble, 
don't worry. We're here to answer your questions.  
 
If you have a problem while using OfotoNow, consult this manual or click the Help 
button at the top right of the screen. If you don't find the solution there, ask us! Under the 
Help menu you'll also find a direct link to our e-mail: support@ofoto.com. 
 
 
 
 

. 



 Copyright © 1999-2001 Ofoto, Inc. All Rights Reserved.  7 

Using OfotoNow 
 
In five simple steps, OfotoNow helps you optimize your photos and get them ready for 
printing. 
 
1. Get the Photo 
2. View the Photo 
3. Edit the Photo 
4. Save the Photo 
5. Upload the Photo to Ofoto for Printing 
 
You can access program functions through pull-down menus (File, Edit, Get Photos, 
View, and Help) and the toolbar (Get photos, Rotate, Trim, Red Eye, Instant Fix, Delete, 
Slideshow, Fullscreen, Address Book, Zoom). For a concise explanation of each menu 
command and toolbar icon, see the Toolbar Buttons and Menu Commands sections of 
this manual. 
 
You can use the default settings or customize OfotoNow. For more details on 
customizing, see the Preferences section of this document. 
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Step 1. Get the Photo 
 
Start by opening the photo you want to work on. To do this, you will use the Get Photos 
command. 
 
Get Stored Photos from Your Hard Drive, a Floppy, or a Photo CD 
 

If you already have photos they might be stored on your computer's hard drive, from 
a floppy disk, or a CD.  To find your photos with OfotoNow click the Get Photos 
button, or use the Get Photos Menu. Scroll through the folders until you find the one 
that contains your photos. Thumbnail images of your photos will appear on the right-
hand side of the screen. Highlight the folder you want and click OK. 
 
By default, each time you start OfotoNow it will open to the last folder you used. 
You can set OfotoNow to look in one particular folder - perhaps the one in which 
you keep all your photos.  For details, see the Preferences section of this document. 

 
 
Get Photos from your Digital Camera or Scanner 
 

Use the Get Photos command to retrieve photos that are still in your camera, or to use 
your scanner with OfotoNow.  Get Photos directs your computer to look for either a 
connected digital camera or scanner, and to bring photos from those devices to your 
PC. Click Get Photos for the following drop-down options: retrieve photos from an 
attached folder, camera, scanner, or your clipboard. (To view the photos stored in 
your camera or scanner, you must (1) have a scanner or camera connected to your PC 
and (2) have a Twain driver installed. A Twain driver tells your PC what kind of 
hardware is attached to it, and how to use that hardware. If you cannot view the 
photos, see the respective manuals for those devices for properly configuring a Twain 
device.) 
 
For details, see the Get Photos Menu in the Menu Commands section of this manual. 
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Step 2. View the Photo 
 
Browse through a folder of photos to find the one you wish to edit and print. When you 
choose a folder, OfotoNow displays thumbnail images of your photos along the left side 
of the screen. When you click a thumbnail, a full-size display of your photo appears in 
the main window to the right. 
 
The Slideshow, Zoom, and Fullscreen options give you more ways to view your photos. 
For details, see the View Menu in the Menu Commands section of this manual. 
 
 
Slideshow 
 

Click the Slideshow button, choose Slideshow from the View menu, or press S to 
begin a presentation of all the photos in the selected folder. To end the slideshow at 
any time, click the slideshow button or select  Slideshow from the View menu again, 
or press Esc. You can adjust the Delay between Photos setting in the Preferences 
control. For details, see the Preferences section of this document. 

 
 
Full Screen 
 

To see your photo displayed across your entire monitor, click the Fullscreen button, 
choose Full Screen View from the View menu, or press the Space bar. To return to 
the standard view, press Esc. 
 
 

Zoom  
 

Click the Zoom + button, choose Zoom In from the View menu, or press the + key 
on the number pad to make the photo in the main window larger. Click the Zoom - 
button, choose Zoom Out from the View menu, or press the - key on the number pad 
to make the photo smaller. Use the Zoom % window to choose a size between 10% 
and 200% percent of the original. Shrink the image back to window size from the 
Zoom % window or the View menu. If the image gets too big for the window, use the 
scroll bars to find the part of the photo you want to see. 
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Step 3. Edit the Photo 
 
Now you can make changes to your photos. The Edit menu lets you Rotate, Trim, and 
remove Red Eye from your photos. 
 
Rotate 
 

You don't have to rotate a photo to print it, but it's easier to edit a photo that's 
displayed right side up. Use the Rotate command to straighten out upside down or 
sideways pictures. Each click of either of the Rotate buttons, the Rotate Left or Right 
command from the Edit menu, or Alt + R turns the photo 90 degrees clockwise or 
counterclockwise. OfotoNow has special software that performs 'lossless' rotation of 
JPEG images. This means that when you rotate your JPEG photos using OfotoNow 
you will not lose any valuable photographic information. 

 
 
Trim 
 

When you Trim a photo, you crop out the parts you don't want to keep. It's a simple 
process that makes sure your print shows what you want. For example, let's say you 
have a photo of a deer in the woods. Your photo shows a lot of trees, and the deer 
looks very small. You'd like the deer to be the focus of the photo. Use the Trim tool 
to eliminate some of the trees from the edges so that the deer takes up more of the 
picture area. Your 4 x 6" is now a print of a deer amidst trees, not a forest with a tiny 
deer in the middle. 
 
When you click the Trim button, or select Trim Photo from the Edit menu, a red 
rectangle appears on your photo. Everything outside the rectangle appears faded, 
indicating that it will be trimmed from the final photo. Click and grab an edge or 
corner of the red rectangle on your photo to move or resize it until you have the exact 
photo you want to trim to.  
 
Tip: You can change the size of the rectangle, but you can't change its proportions. 
That's because the trimming boundary always snaps to a particular shape that 
conforms to the general aspect ratio of a print. "Aspect ratio" means that if the height 
is a certain number, the width corresponds to it exactly. For example, if the photo is 4 
inches high, it's also 6 inches wide, to conform to the standard aspect ratio of a 4 x 6" 
print.  
 
OfotoNow offers three different aspect ratio settings, one for 4 x 6" photos, one for 5 
x 7" photos and one for 8 x 10" photos. In order to print the best photos possible, 
OfotoNow's default Trim setting limits the amount of trimming that you can do to 
your images. The standard, default settings for the Trim tool (which correspond to 
Ofoto's recommended sizes for printing) are as follows: 
 
 4 x 6" aspect ratio: Smallest trim size =  640 x 480 pixels 
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 5 x 7" aspect ratio: Smallest trim size = 1024 x 768 pixels 
 8 x 10" aspect ratio: Smallest trim size = 1220 x 960 pixels 
 
 
Changing the trim default: The Trim tool defaults to standard sizes so that your 
print will fit in a regular frame or photo album. Ofoto's printing service allows you to 
make your photo whatever aspect ratio you want.  You can temporarily override 
these settings by selecting Trim Photo from the Edit menu and then choosing No 
Bounding. Alternatively, as you are trimming a photo you can click on the words 
Trim Photo in the main image window and select No Bounding from the drop down 
menu. To turn off this feature completely: go to the Edit menu, choose Preferences, 
click on the Settings tab and choose 'Do not bound trim selection.' 
 
Tip: Be careful not to trim too much from your photo. Trimming a little off the edges 
of your photo can make for a much-improved print. But too much trimming  trying to 
compensate for not being close enough when you actually snapped the photograph  
will result in a poor print. When you trim a photo, you are taking a part of the 
original photo and stretching it out to fill the whole print. Digital photos are made up 
of lots of small dots; so if you stretch out a part of the photo over a large print, you 
will end up with a photo that looks like a lot of big dots. This is especially true if you 
are making a print larger than 4 x 6", or working with a low-resolution camera.   

 
When you have used the Trim tool, OfotoNow will ask if you want to save your 
photo before you do anything else.  If you don't want to save your changes, you don't 
have to. Remember: Saving the trimmed photo permanently eliminates the original 
photo! If you are not sure, work on a copy of the photo rather than the original; or use 
the Save As command to make a copy of the trimmed photo under a new name, 
leaving the original photo untouched. 

 
Red Eye 
 

Have you ever used a flash to take a picture of people or pets, only to have the print 
come back with their eyes glowing red with reflected light? Removing this red-eye 
effect is the most-used feature in all photo-editing programs. To use the Red Eye 
Removal tool: 
 
1. Open the photo. 
 
2. Click the Red Eye button or choose Remove Red Eye from the Edit menu. 
 
3. A rectangular selection area appears over the photo. Place the rectangle over the 

eye or eyes that need correction. You can do this by placing the cursor in the 
rectangle, then clicking and holding down the mouse button while you drag the 
rectangle to the appropriate spot. You can adjust the size of the area by dragging 
the square "handles" at the corners. 
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You can also place your cursor at the corner of the eye and drag a rectangle over 
the area that needs correction. Try to confine your rectangle to just the eyes that 
need correction if your rectangle is too large, the Red Eye remover will attempt to 
correct areas that do not need correction. 

 
4. Repeat with all red eyes in the photo.  
 
5. When you're happy with your changes, save the photo.  You can choose Save As 

to save the corrected photo with a different name and leave the original photo 
untouched. 

 
 
Instant Fix 

 
Is your image too dark? Is there little difference between the darker areas of the photo 
and the lighter areas? If this is the case then you can use OfotoNow's Instant Fix tool. 
The Instant Fix tool adjusts the overall brightness and contrast of your photos. When 
your photo is in the main window of OfotoNow click on the Instant Fix button. If you 
like the results, save your image (use Save As if you want to leave the original image 
untouched). If you're not pleased with the results, or the changes were too slight to 
detect, you can simply select Cancel in the main window title bar (next to Accept 
Instant Fix). 
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Step 4. Save the Photo 
 
Each time you edit your photo you need to save your changes. Choose Save from the File 
menu, or press Ctrl-S. This permanently records the changes you have made.  Use the 
Save As command under the File menu to make a new copy of your original photo, with 
any changes you may have made, under a different name. If you don't like the results of 
your edited photo, you can delete it by clicking the Delete button, choosing Delete from 
the Edit menu, or pressing the Delete key. 
 
Tip: If you delete a photo accidentally, don't panic! You can still get your photo back. In 
Windows, deleted items go into the recycle bin, where they remain until you choose to 
empty the bin. 
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Step 5. Upload the Photo to Ofoto for Printing 
 
When you are satisfied with your photo or photos, the next step is to send it from your 
computer to ours for printing. Uploading photos with OfotoNow is a simple three-step 
process. 
 

1. Select photos: Click the thumbnail of the photo you want to upload to Ofoto and 
mark the checkbox. Click the Select All button or choose Select All for Upload 
from the Edit menu to select all the photos shown. If you change your mind, click 
the Deselect button or choose Deselect All for Upload from the Edit menu. When 
you're ready, click the Upload button or choose Upload to Ofoto from the File 
menu.  A new window will appear asking you to Sign In.  This is the connection 
to transfer your photos from your computer to your Ofoto account. 

 
1. Sign in: If you already have an account with Ofoto, you will be asked to sign in 

with your email address and password. If you do not have an account with Ofoto, 
follow the link "Create one". When you're done, you can sign in to Ofoto with 
your newly created email address and password. 

 
1. Select album: Click the radio button next to the album into which you want to 

upload your photos. If you are new to Ofoto, you can create your first album right 
now. When you're ready, click the Upload Now button to send your photos to 
Ofoto. You can upload multiple times in one session by selecting different photos 
and then clicking Upload Now again. 

 
1. View photos: A Confirm dialogue box asks if you would like to view your photos 

on Ofoto. Click OK to launch Ofoto and see your new photos.  
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Toolbar Buttons 
 
The toolbar buttons are shortcuts to features located within OfotoNow's menus. These 
buttons represent the most frequently used features of OfotoNow. 
 
Get Photos 

 
See a list of the folders on your hard drive, your floppy drive, or your CD drive. 

 
Rotate 
 

Change the position of a photo on your screen. Each click rotates the photo 90 
degrees. 

 
Trim 
 

Begin trimming your photo. 
 
Red Eye 
 

Remove the red glow in eyes, caused by use of a flash camera. 
 
Instant Fix 
 

Adjust the brightness and contrast of your photos. 
 

Delete 
 

Discard the selected photo (this moves the photo to the Windows Recycle Bin.) 
 
Slideshow 
 

See the photos in the selected folder one after the other. 
 
Fullscreen 
 

See your photo shown the full size of your monitor. 
 

Address Book Upload 
 

Upload email addresses from your own address book to your Ofoto account. 
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Zoom + 
 

Make the photo in the main window larger. 
 
Zoom - 
 

Make the photo in the main window smaller. 
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Menu Commands 
 

The File Menu  
 
Save (Ctrl + S) 
 

Permanently record any changes you have made to your photo. 
 
Save As 
 

Make a new file on your computer of the photo you have open. 
 
Upload to Ofoto 
 

Connect to the Ofoto website and upload your photos for sharing or printing. 
 
Upload Email Addresses 
 

Upload your collection of email addresses from your Microsoft Outlook 98/2000 or 
your Netscape 4.5/5/6 address books to share your photos with friends and family. 
Start by clicking the Upload Email Addresses menu item and choosing one or more 
address books. Then select the addresses you want to upload to your Ofoto account. 
Use the Shift key to select multiple addresses, or the Ctrl. key to pick and choose 
multiple addresses. Click on Continue to send the addresses you have selected to 
Ofoto. For security reasons you must sign in to Ofoto in order to add the addresses to 
your Ofoto account. Simply enter your email address and your Ofoto password and 
the email addresses will be added to your Ofoto address book. 

 
Delete (Delete key) 
 

Eliminate the photo you have selected or opened. The file will be moved to the 
Windows Recycle Bin. 

 
Printing (Ctrl + P) 
 

Send the open photo to your desktop printer.  
 
Set Photo as Wallpaper 
 

Use any photograph on your computer as the background on your Windows desktop. 
Simply open the photo and click this function. You can "undo" this setting by reusing 
the command after opening another photo for your desktop background. Using this 
feature makes no changes to the photograph itself.   

 
Photo Information (Ctrl + I) 
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Open a window to read the date of the photo, its size in pixels, and the color depth.  

 
Exit (Ctrl + Q) 
 

Quit OfotoNow. The program will ask you if you want to save the last changes you 
made to the open photo. 

 
 
The Edit Menu 
 
Undo Changes (Ctrl + Z) 
 

Return the open photo to the way it was before you made your changes. If you don't 
like an edit or change you've made to your photo, choose this command. 

 
Rotate Left (Alt + L)/Right (Alt + R) 
 

Rotate your photo on the screen a quarter-turn. See the Rotate button description for 
more details.  

 
Trim Photo (Alt + C) 
 

Select a smaller area of your photo for printing and delete the remainder of the photo. 
 

Remove Red Eye 
 

Eliminate the flash-reflecting glow in a person's or animal's eyes in a photo. 
 
Instant Fix 
 

Adjust the brightness and the contrast of your photos. 
 
Copy Photo to Clipboard 
 

Copy the open photo into the Windows Clipboard (short-term memory) so that you 
can paste it into a document in another application. It makes no changes to your 
picture in OfotoNow. 

 
 
Preferences 
 

Open the Preferences dialog box, described in detail in the Preferences section. 
Choose Preferences to customize OfotoNow's features and functions.  Further 
information is available in the Preferences section. 
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The Get Photos Menu  
 
Get Photos From Folder 
 

Open a window to display the contents of your PC's hard drive. You can select any 
folder on your computer through this window. Scroll through the folders to one 
containing your photos. If a folder contains photos, the pictures will show in the 
window when you highlight the folder. When you have chosen the folder you wish to 
work with, click OK. 

 
Get Photos From Camera 
 

This option acquires photos from a camera connected to your PC. You must have a 
Twain driver installed.  A Twain driver is a type of software that allow your 
computer to communicate with other devices such as digital cameras and scanners. 
 If you cannot connect to your camera with this feature, first check the Preferences 
for Twain (see instructions under Advanced Preferences). If that does not work, 
please see the instructions in your camera's manual for properly configuring a Twain 
device.   

 
Get Photos From Scanner 
 

Get photos from a scanner connected to your PC. You must have a Twain driver 
installed. If you cannot connect to your scanner with this feature, first check the 
Preferences for Twain (see instructions under Advanced Preferences).  If that does 
not work, please see the instruction in your scanner's manual for properly configuring 
a Twain device.  

 
Get Photos From Clipboard 
 

Paste the contents of the Clipboard into a new window. You can copy a photo into 
the clipboard from another program by choosing the Copy command from the Edit 
menu or typing Ctrl + V.  

 
 
The View Menu  
 
Full Screen (Space bar) 
 

Display the photo across your entire monitor.  Pressing the Page Up or Page Down 
keys while in Fullscreen mode will change the displayed image to the next photo or 
the previous photo, respectively. To return to the standard view press either the Esc. 
key or the spacebar on your keyboard. 

 
Slideshow 
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Display your photos individually in an automated slideshow  one picture after 
another. Choosing Slideshow will start a presentation of all the photos within the 
folder you have open. To end the slideshow at any time, press Esc., or click on the 
Slideshow button in the toolbar. You can adjust the amount of time images are 
displayed during Slideshow. To do this go to the Edit menu, select Preferences, and 
choose a new time in the Delay between photos option under the Display tab. 
 

Zoom 
 

Get a closer look at the picture you are working with. You can access the Zoom 
controls in several ways: through the Zoom menu command, by clicking either side 
of the Zoom + /  button on the toolbar, or by pressing + or  on the number keypad. 
Clicking on the current display size box on the toolbar (to the right of the buttons) 
will display a drop down menu with different zoom options. If you zoom so close 
you can't see a particular spot, use the scroll bars on the right side and bottom of the 
photo window to move the photo up and down and left and right. 
 

 
Shrink to Window Size 
 

Refit the display of the photo so that it is all visible in the main window.  
 
Tip: Un-checking this menu choice will display your photo at 100% "full size." 

 
 
The Help Menu 
 
OfotoNow Help 
 

Open a window with a searchable index of the OfotoNow documentation. 
 
Go to Ofoto Website 
 

Launch Ofoto to view your online albums. 
 
Go to Ofoto Support Page 
 

The Ofoto support page has the latest version of our OfotoNow User Guide, as well 
as a list of Frequently Asked Questions, tips for using photos and getting better 
prints, and information on how to get in touch with the Ofoto technical support staff 
for additional assistance. 

 
Other software from Xequte 
 

Go to the Xequte website to find out more about other software developed by 



 Copyright © 1999-2001 Ofoto, Inc. All Rights Reserved.  21 

Xequte. 
 
About 
 

Determine which version of the OfotoNow client software you have installed, the 
exact number is given after the word Build on this screen. 
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OfotoNow Preferences 
 
Display Tab 
 
Photo Display: These settings control how OfotoNow shows your photos on screen. By 
default, OfotoNow will display your photo to fit within the screen (Shrink to Fit). You 
can choose instead to Show Photo Full Size. This will enable you to see greater detail, but 
you may have to use the scroll bars to move the photo about to see parts of it, or zoom 
out to see all of it. Check the option that best suits you. 
 
Slideshow:  OfotoNow gives you a Slideshow feature for displaying all the photos in a 
folder. The Slideshow presents photos one at a time, with each photo filling the screen. 
You can control: 

 
• Delay between photos  length of time (in seconds) photo is displayed before 

changing to the next photo. Adjustable between 0 (change occurs as fast as 
possible) and 60 seconds. 

 
Other:  
 

• Hide file extensions: All files on a DOS/Windows computer have a three-letter 
tag called an extension. Photos are generally JPEGs (.jpg), or bitmaps (.bmp). By 
default, OfotoNow will show these extensions. 

 
• Selecting new photo cancels loading of current photo: A large photo can take a 

number of seconds to open. If you change your mind or realize you selected the 
wrong photo, you can click another photo and the first will stop opening. If you 
un-check this option, photos will continue to load even if a second photo is 
chosen.  

 
• Override default background color with: This setting lets you choose 

OfotoNow's background color. Click the box to see a list of colors from which to 
make a selection. 

 
 
Settings Tab 
 
Trim Settings: The Trim tool opens a rectangle on your photo that you can move about, 
shrink, and enlarge. When you double-click inside the rectangle, the parts of your photo 
outside the trim area are discarded. By default, the rectangle always maintains the aspect 
ratio of a standard photographic print, no matter how you move it. A warning will come 
up if you try to trim an image below Ofoto's recommended size. 
 
 
File Management: This option lets you control how OfotoNow works with your files: 
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• Confirm deletion of files: When you choose to delete a photo (with either the 

menu selection or toolbar button), OfotoNow will ask you to confirm that you 
really do want to delete the photo. If you un-check this option, OfotoNow will not 
ask you for confirmation and will delete the photo as soon as you choose the 
command. 

 
 
Startup Folder: 

 
• Remember folder from previous OfotoNow session: OfotoNow will start up by 

opening the photos from the last folder you used with the program. 
 

• Default to the following folder: This option lets you choose which folder (and 
photos) OfotoNow opens when you start the program. 

 
 
 

Advanced Preferences Tab 
 
Default Twain Sources: This panel lets you choose which Twain driver OfotoNow will 
use out of the ones you've installed. You can set a Twain driver for your camera and your 
scanner. 
 
Click the Change button to see a list of the drivers installed on your PC. Click the one 
you want to use, then click OK. If no drivers appear in this list, please make sure you 
have properly installed the software that came with your camera or scanner. 
 
(Please note: You do not have to use the Twain method to connect your PC to a camera 
or scanner. They may work fine with whatever software they came with. This option 
merely allows you to use the hardware directly from within OfotoNow. If it does not 
work, you can still acquire photos from your camera or scanner using the dedicated 
software they came with, and then use those photos with OfotoNow through the Get 
Photos - Folder command. 
 
Proxy: If you are working on a corporate intranet or are using another nonstandard 
method for Web access, you may have to enter an IP address and Port number in this 
field to log onto the Ofoto printing service. Please contact your networking administrator 
for help. 
 
JPEG Settings: Control how OfotoNow handles JPEG photo compression. When you 
save a photo in OfotoNow, it is always saved as a JPEG compressed file. JPEG 
compression is an efficient means of compressing images so the images will take up less 
space. An image compressed by the JPEG method commonly ends up about one tenth its 
original size. Most digital cameras save photos as JPEGs. However, the amount of 
compression in a JPEG can be varied  more compression makes a smaller file, but the 
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photo may not look as good as one that has undergone less compression. 
 

• Make OfotoNow default application for JPEG files: This option sets Windows 
to always use OfotoNow when you open a JPEG photo file from the desktop 
Explorer or the File Manager. By default, this is not checked in case you are 
already using another photo editor, or prefer to open JPEG files in your Web 
browser. 

 
• Prompt for JPEG quality settings on file saving: When you save a new photo, 

by default OfotoNow will ask you to set the amount of JPEG compression you 
want. We recommend 95% - this results in no noticeable file size change and 
produces great photographic prints. 

 
• Do not prompt: OfotoNow will automatically use the JPEG compression figure 

you enter in this option box. It will not prompt you for a decision every time you 
save a file. It will use the default JPEG photo quality setting of 95%. 
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	Welcome to OfotoNow
	Thanks for downloading OfotoNow. This easy-to-use photo-editing tool helps you get your digital photos ready for printing by Ofoto.
	Many software programs let you improve or alter your photos in a wide variety of ways. Usually, however, you only need to make a few simple corrections - trim the photo a bit, or get rid of the red flash in your subject's eyes. We don't think you should
	The OfotoNow User Manual explains how you can use OfotoNow to get the very best photographic prints from your digital photos. Use OfotoNow to:
	Get your photos from a digital camera or scanner to your computer.
	View all your photos: zoom in or out within each photo, view all images as thumbnails, view your images as a slideshow, make copies of the photos and save them to a different location.
	Make sure your photo looks just the way you want before you print it.  You can rotate your photo onscreen to make it appear right side up, trim out the parts you don’t want to print, and even fix the “red-eye” flash effect.
	Upload your photo to Ofoto and receive the finest printed photos on Professional Kodak paper – without leaving home!
	
	
	
	
	System Requirements





	Getting Help
	OfotoNow is a very simple tool that's easy to understand and use. If you do have trouble, don't worry. We're here to answer your questions.
	If you have a problem while using OfotoNow, consult this manual or click the Help button at the top right of the screen. If you don't find the solution there, ask us! Under the Help menu you'll also find a direct link to our e-mail: support@ofoto.com.
	.
	Using OfotoNow
	In five simple steps, OfotoNow helps you optimize your photos and get them ready for printing.
	1.	Get the Photo
	2.	View the Photo
	3.	Edit the Photo
	4.	Save the Photo
	5.	Upload the Photo to Ofoto for Printing
	You can access program functions through pull-down menus (File, Edit, Get Photos, View, and Help) and the toolbar (Get photos, Rotate, Trim, Red Eye, Instant Fix, Delete, Slideshow, Fullscreen, Address Book, Zoom). For a concise explanation of each menu
	You can use the default settings or customize OfotoNow. For more details on customizing, see the Preferences section of this document.
	Step 1. Get the Photo
	Start by opening the photo you want to work on. To do this, you will use the Get Photos command.
	Get Stored Photos from Your Hard Drive, a Floppy, or a Photo CD
	If you already have photos they might be stored on your computer's hard drive, from a floppy disk, or a CD.  To find your photos with OfotoNow click the Get Photos button, or use the Get Photos Menu. Scroll through the folders until you find the one that
	By default, each time you start OfotoNow it will open to the last folder you used. You can set OfotoNow to look in one particular folder - perhaps the one in which you keep all your photos.  For details, see the Preferences section of this document.
	Get Photos from your Digital Camera or Scanner
	Use the Get Photos command to retrieve photos that are still in your camera, or to use your scanner with OfotoNow.  Get Photos directs your computer to look for either a connected digital camera or scanner, and to bring photos from those devices to your
	For details, see the Get Photos Menu in the Menu Commands section of this manual.
	Step 2. View the Photo
	Browse through a folder of photos to find the one you wish to edit and print. When you choose a folder, OfotoNow displays thumbnail images of your photos along the left side of the screen. When you click a thumbnail, a full-size display of your photo app
	The Slideshow, Zoom, and Fullscreen options give you more ways to view your photos. For details, see the View Menu in the Menu Commands section of this manual.
	Slideshow
	Click the Slideshow button, choose Slideshow from the View menu, or press S to begin a presentation of all the photos in the selected folder. To end the slideshow at any time, click the slideshow button or select €Slideshow from the View menu again, or p
	Full Screen
	To see your photo displayed across your entire monitor, click the Fullscreen button, choose Full Screen View from the View menu, or press the Space bar. To return to the standard view, press Esc.
	Zoom
	Click the Zoom + button, choose Zoom In from the View menu, or press the + key on the number pad to make the photo in the main window larger. Click the Zoom - button, choose Zoom Out from the View menu, or press the - key on the number pad to make the ph
	Step 3. Edit the Photo
	Now you can make changes to your photos. The Edit menu lets you Rotate, Trim, and remove Red Eye from your photos.
	Rotate
	You don't have to rotate a photo to print it, but it's easier to edit a photo that's displayed right side up. Use the Rotate command to straighten out upside down or sideways pictures. Each click of either of the Rotate buttons, the Rotate Left or Right
	Trim
	When you Trim a photo, you crop out the parts you don't want to keep. It's a simple process that makes sure your print shows what you want. For example, let's say you have a photo of a deer in the woods. Your photo shows a lot of trees, and the deer look
	When you click the Trim button, or select Trim Photo from the Edit menu, a red rectangle appears on your photo. Everything outside the rectangle appears faded, indicating that it will be trimmed from the final photo. Click and grab an edge or corner of t
	Tip: You can change the size of the rectangle, but you can't change its proportions. That's because the trimming boundary always snaps to a particular shape that conforms to the general aspect ratio of a print. "Aspect ratio" means that if the height is
	OfotoNow offers three different aspect ratio settings, one for 4 x 6" photos, one for 5 x 7" photos and one for 8 x 10" photos. In order to print the best photos possible, OfotoNow's default Trim setting limits the amount of trimming that you can do to y
	4 x 6" aspect ratio:	Smallest trim size =  640 x 480 pixels
	5 x 7" aspect ratio:	Smallest trim size = 1024 x 768 pixels
	8 x 10" aspect ratio:	Smallest trim size = 1220 x 960 pixels
	Changing the trim default: The Trim tool defaults to standard sizes so that your print will fit in a regular frame or photo album. Ofoto's printing service allows you to make your photo whatever aspect ratio you want.  You can temporarily override these
	Tip: Be careful not to trim too much from your photo. Trimming a little off the edges of your photo can make for a much-improved print. But too much trimming  trying to compensate for not being close enough when you actually snapped the photograph  will
	When you have used the Trim tool, OfotoNow will ask if you want to save your photo before you do anything else.  If you don't want to save your changes, you don't have to. Remember: Saving the trimmed photo permanently eliminates the original photo! If y
	Red Eye
	Have you ever used a flash to take a picture of people or pets, only to have the print come back with their eyes glowing red with reflected light? Removing this red-eye effect is the most-used feature in all photo-editing programs. To use the Red Eye Rem
	1.	Open the photo.
	2.	Click the Red Eye button or choose Remove Red Eye from the Edit menu.
	3.	A rectangular selection area appears over the photo. Place the rectangle over the eye or eyes that need correction. You can do this by placing the cursor in the rectangle, then clicking and holding down the mouse button while you drag the rectangle to
	You can also place your cursor at the corner of the eye and drag a rectangle over the area that needs correction. Try to confine your rectangle to just the eyes that need correction if your rectangle is too large, the Red Eye remover will attempt to corr
	4.	Repeat with all red eyes in the photo.
	5.	When you're happy with your changes, save the photo.  You can choose Save As to save the corrected photo with a different name and leave the original photo untouched.
	Instant Fix
	Is your image too dark? Is there little difference between the darker areas of the photo and the lighter areas? If this is the case then you can use OfotoNow's Instant Fix tool. The Instant Fix tool adjusts the overall brightness and contrast of your pho
	Step 4. Save the Photo
	Each time you edit your photo you need to save your changes. Choose Save from the File menu, or press Ctrl-S. This permanently records the changes you have made.  Use the Save As command under the File menu to make a new copy of your original photo, with
	Tip: If you delete a photo accidentally, don't panic! You can still get your photo back. In Windows, deleted items go into the recycle bin, where they remain until you choose to empty the bin.
	Step 5. Upload the Photo to Ofoto for Printing
	When you are satisfied with your photo or photos, the next step is to send it from your computer to ours for printing. Uploading photos with OfotoNow is a simple three-step process.
	Select photos: Click the thumbnail of the photo you want to upload to Ofoto and mark the checkbox. Click the Select All button or choose Select All for Upload from the Edit menu to select all the photos shown. If you change your mind, click the Deselect
	Sign in: If you already have an account with Ofoto, you will be asked to sign in with your email address and password. If you do not have an account with Ofoto, follow the link "Create one". When you're done, you can sign in to Ofoto with your newly crea
	Select album: Click the radio button next to the album into which you want to upload your photos. If you are new to Ofoto, you can create your first album right now. When you're ready, click the Upload Now button to send your photos to Ofoto. You can upl
	View photos: A Confirm dialogue box asks if you would like to view your photos on Ofoto. Click OK to launch Ofoto and see your new photos.
	Toolbar Buttons
	The toolbar buttons are shortcuts to features located within OfotoNow's menus. These buttons represent the most frequently used features of OfotoNow.
	Get Photos
	See a list of the folders on your hard drive, your floppy drive, or your CD drive.
	Rotate
	Change the position of a photo on your screen. Each click rotates the photo 90 degrees.
	Trim
	Begin trimming your photo.
	Red Eye
	Remove the red glow in eyes, caused by use of a flash camera.
	Instant Fix
	Adjust the brightness and contrast of your photos.
	Delete
	Discard the selected photo (this moves the photo to the Windows Recycle Bin.)
	Slideshow
	See the photos in the selected folder one after the other.
	Fullscreen
	See your photo shown the full size of your monitor.
	Address Book Upload
	Upload email addresses from your own address book to your Ofoto account.
	Zoom +
	Make the photo in the main window larger.
	Zoom -
	Make the photo in the main window smaller.
	Menu Commands
	The File Menu
	Save (Ctrl + S)
	Permanently record any changes you have made to your photo.
	Save As
	Make a new file on your computer of the photo you have open.
	Upload to Ofoto
	Connect to the Ofoto website and upload your photos for sharing or printing.
	Upload Email Addresses
	Upload your collection of email addresses from your Microsoft Outlook 98/2000 or your Netscape 4.5/5/6 address books to share your photos with friends and family. Start by clicking the Upload Email Addresses menu item and choosing one or more address boo
	Delete (Delete key)
	Eliminate the photo you have selected or opened. The file will be moved to the Windows Recycle Bin.
	Printing (Ctrl + P)
	Send the open photo to your desktop printer.
	Set Photo as Wallpaper
	Use any photograph on your computer as the background on your Windows desktop. Simply open the photo and click this function. You can "undo" this setting by reusing the command after opening another photo for your desktop background. Using this feature m
	Photo Information (Ctrl + I)
	Open a window to read the date of the photo, its size in pixels, and the color depth.
	Exit (Ctrl + Q)
	Quit OfotoNow. The program will ask you if you want to save the last changes you made to the open photo.
	The Edit Menu
	Undo Changes (Ctrl + Z)
	Return the open photo to the way it was before you made your changes. If you don't like an edit or change you've made to your photo, choose this command.
	Rotate Left (Alt + L)/Right (Alt + R)
	Rotate your photo on the screen a quarter-turn. See the Rotate button description for more details.
	Trim Photo (Alt + C)
	Select a smaller area of your photo for printing and delete the remainder of the photo.
	Remove Red Eye
	Eliminate the flash-reflecting glow in a person's or animal's eyes in a photo.
	Instant Fix
	Adjust the brightness and the contrast of your photos.
	Copy Photo to Clipboard
	Copy the open photo into the Windows Clipboard (short-term memory) so that you can paste it into a document in another application. It makes no changes to your picture in OfotoNow.
	Preferences
	Open the Preferences dialog box, described in detail in the Preferences section. Choose Preferences to customize OfotoNow's features and functions. €Further information is available in the Preferences section.
	The Get Photos Menu
	Get Photos From Folder
	Open a window to display the contents of your PC's hard drive. You can select any folder on your computer through this window. Scroll through the folders to one containing your photos. If a folder contains photos, the pictures will show in the window whe
	Get Photos From Camera
	This option acquires photos from a camera connected to your PC. You must have a Twain driver installed. €A Twain driver is a type of software that allow your computer to communicate with other devices such as digital cameras and scanners. €If you cannot
	Get Photos From Scanner
	Get photos from a scanner connected to your PC. You must have a Twain driver installed. If you cannot connect to your scanner with this feature, first check the Preferences for Twain (see instructions under Advanced Preferences). €If that does not work,
	Get Photos From Clipboard
	Paste the contents of the Clipboard into a new window. You can copy a photo into the clipboard from another program by choosing the Copy command from the Edit menu or typing Ctrl + V.
	The View Menu
	Full Screen (Space bar)
	Display the photo across your entire monitor. €Pressing the Page Up or Page Down keys while in Fullscreen mode will change the displayed image to the next photo or the previous photo, respectively. To return to the standard view press either the Esc. key
	Slideshow
	Display your photos individually in an automated slideshow €one picture after another. Choosing Slideshow will start a presentation of all the photos within the folder you have open. To end the slideshow at any time, press Esc., or click on the Slideshow
	Zoom
	Get a closer look at the picture you are working with. You can access the Zoom controls in several ways: through the Zoom menu command, by clicking either side of the Zoom + / €button on the toolbar, or by pressing + or €on the number keypad. Clicking on
	Shrink to Window Size
	Refit the display of the photo so that it is all visible in the main window.
	Tip: Un-checking this menu choice will display your photo at 100% "full size."
	The Help Menu
	OfotoNow Help
	Open a window with a searchable index of the OfotoNow documentation.
	Go to Ofoto Website
	Launch Ofoto to view your online albums.
	Go to Ofoto Support Page
	The Ofoto support page has the latest version of our OfotoNow User Guide, as well as a list of Frequently Asked Questions, tips for using photos and getting better prints, and information on how to get in touch with the Ofoto technical support staff for
	Other software from Xequte
	Go to the Xequte website to find out more about other software developed by Xequte.
	About
	Determine which version of the OfotoNow client software you have installed, the exact number is given after the word Build on this screen.
	OfotoNow Preferences
	Display Tab
	Photo Display: These settings control how OfotoNow shows your photos on screen. By default, OfotoNow will display your photo to fit within the screen (Shrink to Fit). You can choose instead to Show Photo Full Size. This will enable you to see greater det
	Slideshow:  OfotoNow gives you a Slideshow feature for displaying all the photos in a folder. The Slideshow presents photos one at a time, with each photo filling the screen. You can control:
	Delay between photos €length of time (in seconds) photo is displayed before changing to the next photo. Adjustable between 0 (change occurs as fast as possible) and 60 seconds.
	Other:
	Hide file extensions: All files on a DOS/Windows computer have a three-letter tag called an extension. Photos are generally JPEGs (.jpg), or bitmaps (.bmp). By default, OfotoNow will show these extensions.
	Selecting new photo cancels loading of current photo: A large photo can take a number of seconds to open. If you change your mind or realize you selected the wrong photo, you can click another photo and the first will stop opening. If you un-check this o
	Override default background color with: This setting lets you choose OfotoNow's background color. Click the box to see a list of colors from which to make a selection.
	Settings Tab
	Trim Settings: The Trim tool opens a rectangle on your photo that you can move about, shrink, and enlarge. When you double-click inside the rectangle, the parts of your photo outside the trim area are discarded. By default, the rectangle always maintains
	File Management: This option lets you control how OfotoNow works with your files:
	Confirm deletion of files: When you choose to delete a photo (with either the menu selection or toolbar button), OfotoNow will ask you to confirm that you really do want to delete the photo. If you un-check this option, OfotoNow will not ask you for conf
	Startup Folder:
	Remember folder from previous OfotoNow session: OfotoNow will start up by opening the photos from the last folder you used with the program.
	Default to the following folder: This option lets you choose which folder (and photos) OfotoNow opens when you start the program.
	Advanced Preferences Tab
	Default Twain Sources: This panel lets you choose which Twain driver OfotoNow will use out of the ones you've installed. You can set a Twain driver for your camera and your scanner.
	Click the Change button to see a list of the drivers installed on your PC. Click the one you want to use, then click OK. If no drivers appear in this list, please make sure you have properly installed the software that came with your camera or scanner.
	(Please note: You do not have to use the Twain method to connect your PC to a camera or scanner. They may work fine with whatever software they came with. This option merely allows you to use the hardware directly from within OfotoNow. If it does not wor
	Proxy: If you are working on a corporate intranet or are using another nonstandard method for Web access, you may have to enter an IP address and Port number in this field to log onto the Ofoto printing service. Please contact your networking administrat
	JPEG Settings: Control how OfotoNow handles JPEG photo compression. When you save a photo in OfotoNow, it is always saved as a JPEG compressed file. JPEG compression is an efficient means of compressing images so the images will take up less space. An im
	Make OfotoNow default application for JPEG files: This option sets Windows to always use OfotoNow when you open a JPEG photo file from the desktop Explorer or the File Manager. By default, this is not checked in case you are already using another photo e
	Prompt for JPEG quality settings on file saving: When you save a new photo, by default OfotoNow will ask you to set the amount of JPEG compression you want. We recommend 95% - this results in no noticeable file size change and produces great photographic
	Do not prompt: OfotoNow will automatically use the JPEG compression figure you enter in this option box. It will not prompt you for a decision every time you save a file. It will use the default JPEG photo quality setting of 95%.


