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Save time by using templates
Default settings are all very 

well but if they don’t suit you,

you’ll end up having to change

the font, stylesheet and type 

size on each new document 

you create. Overcome this by

creating a template – that is, 

a boilerplate document containing settings,

formatting and styles you frequently 

use in your most-used application, be 

it Word, Excel or PowerPoint.

• Word 2002 Whether you regularly have to

create letters, memos, legal documents,

web pages, faxes or marketing materials,

Word offers templates that you can

customise. To find these, choose File,

New, which will open the Task Pane with

the New Document Pane onscreen. Under

‘New from template’, click General

Templates. Select a file document, such

as fax, and follow the directions, replacing

the boilerplate text with your own. 

If you’d prefer to create from scratch 

a template, which will automatically 

open every time you open Word, you 

need to edit Word’s blank document

template called normal.dot. You can

change the default font (to Arial, for

example) or point size and your changes

will apply to every subsequent document

you create. 

First, locate normal.dot on your system

– its location will depend on your Windows

configuration. To find this file, go to the

Windows Taskbar, choose Start, Search,

For Files or Folders and type normal.dot in

the Search field. When Windows displays

the file, right-click its icon and choose

Open. To change the default font to Arial,

choose it in the Font drop-down list, then

save the document and close it. 

If you don’t want all your new

documents to default to Arial, create 

a new template and use that instead.

Open a new document, adjust the 

required settings, then save the file 

to the Templates folder, making sure 

to use the DOT file extension. 

Click General Templates in the Task

Pane to open the Templates dialog box

and select the General tab. Click on the

blank document to highlight it. This will be

the basis for your custom template. Under

Create New, in the lower righthand corner

of the dialog box, choose Template, ok.

Edit the template to suit your needs then

save. Your new template will now appear

under the General tab. Just click its icon

to open a blank document. 

• Excel 2002 Custom templates can also

save a lot of time in Excel, particularly if

you often create routine worksheets such

as invoices or purchase

orders. To check out Excel’s

built-in templates, open the

Task Pane by choosing File,

New. In the Task Pane’s ‘New

from template’ section, click

General Templates. In the

Templates dialog box, click

the Spreadsheet Solutions tab to display

the templates that come with Excel. Just

like in Word, you can use these as your

worksheets, customise them or, if you

prefer, create your own templates from

scratch from a blank worksheet. 

To use an existing worksheet to create

your own template, open the Task Pane 

by choosing File, New. Next, click ‘Choose

Workbook’ from the Task Pane’s ‘New

from existing workbook’ section. Find 

and select your worksheet, click Create

New and customise the file as you wish. 

To save a new template, whether

you’ve customised an existing one or

created it from scratch, choose File, Save

As. In the ‘Save as type’ drop-down list,

choose Template (*.xlt). Excel

automatically switches it to the Templates

folder. Name your template, making sure

to keep the XLT file extension, and click

Save. As with Word, you can access your

template from General Templates on the

Task Pane, then click the General tab in

the Templates dialog box and double-click

the template’s icon. 

• PowerPoint 2002 To customise PowerPoint

templates, go to the Task Pane and click

General Templates to open the dialog box.

Here, you’ll find three tabs: General,

Design Templates and Presentations. The

Design Templates tab offers a slew of

slide designs, while the Presentations tab

offers complete presentations, ready for

you to fill in the blanks. Simply double-click

a design to launch a template. 

To create a custom template, open the

file you want to save as a template by

clicking ‘Choose presentation’ from the

Task Pane’s ‘New from existing

presentation’ section (or create one from

scratch). Choose File, Save As. In the

Save as type drop-down list, choose

k Choose from a variety of 
readymade presentation templates 
in PowerPoint – simply fill in the
blanks for a quick, easy and
professional looking presentation

v To permanently alter a default
document in Word, right-click its 
icon, select Open and then make 
your required changes

x Create your own templates in Excel by
making changes to an existing template
then saving it with the file extension XLT
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Office XP is touted as both easier 

to use and more customisable than 

older versions of Microsoft’s office 

suite, but it takes time to learn all 

the labour-saving ways to tailor Word,

Excel and PowerPoint to your needs.

Jim Welp shows you how to get more

from those everyday applications 

and build a better Office relationship 

When Microsoft released its updated Office suite in the first half of 2001, 

PC Advisor readers greeted its launch with cynicism. Weary of buggy Microsoft

software and the huge disk space demands it makes, many readers said they

were in no hurry to upgrade to Office XP. Our online poll at the time showed less than

half of respondents were intending to migrate anytime soon. 

However, Office XP incorporates a number of useful features not found in its

predecessor Office 98 and, since the interface is broadly the same as that of the

previous version, upgrading shouldn’t be too much of a headache. What’s more,

Microsoft has heeded user complaints about adding bulk rather than functionality, 

so XP has usability galore. 

Since last year’s Office XP launch, Microsoft has also released a brand-new version

of its Windows operating system which, on the whole, has been favourably received. 

This will no doubt have prompted some of you to update your system software and,

along with it, your office suite too. Next month, we’ll be comparing the different office

suites and individual applications available. Here, we highlight some of Office XP’s

features and show you how to make the most of the enhanced user controls it provides. 
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Use Smart Tags effectively
When Office XP was released, a lot of

controversy surrounded Smart Tags

because they appeared to direct users to

sites and services in which Microsoft had

an interest. However, the UK version has

(allegedly) fewer Smart Tags and its ability

to recognise when people’s names, dates,

telephone numbers and the like recur in

one or more applications makes this

feature extremely useful. 

• Word 2002 Let’s say that you were writing

a memo in Word about a forthcoming

meeting, so you type in the names of

attendees and the date of the meeting. 

If these details are listed in your Outlook

2002 contacts and calendar databases,

Word will underline the keywords in purple

to alert you. Click on this underlined

name, date or phone number and a small

icon will appear above it with the Smart

Tag drop-down menu. 

From here, you can synchronise related

tasks such as sending an email invitation

to the meeting in Outlook or finding free

time for it to take place. You can also

import contact details for someone whose

name appears in a Word document by

simply hitting the Add to Contacts option

from the pop-up menu hovering over the

name in question. This saves lots of

chopping and changing

between applications.

An Options list is

accessed by choosing

Tools, AutoCorrect and

clicking on the Smart Tags

tab. Here, you can specify

which sort of keywords to

alert you to. If you find that

recognising names, phone

numbers, dates, times,

recent email recipients and

addresses isn’t a

sufficiently comprehensive

list, you can click on the

More Smart Tags tab and

find further elements to add to the list

from Microsoft’s website. If you decide you

no longer wish Office XP to apprise you of

commonly used names or dates, go to

Tools, AutoCorrect, Smart Tags and hit the

Remove Smart Tags button. 

• Excel 2002 Unlike Word, which highlights

Smart Tags by underlining keywords, Excel

2002 displays a purple triangle in the

lower righthand corner of a cell. This

application only recognises two types of

text: recent email recipients and financial

symbols. However, the Smart Tags pop-up

menu is identical to Word’s, so use the

directions explained earlier to alter your

Excel Smart Tag preferences. 

Excel's email-recipient Smart Tag lets

you initiate various Outlook actions, as it

did in Word. From the Smart Tag drop-

down menu, you can send an email,

schedule a meeting, open an Outlook

contact, add to contacts or insert an

address into your worksheet. 

If you enter a stock, or financial,

symbol in your worksheet, Smart Tags will

recognise it and offer a menu of options.

You can choose to insert a refreshable

stock table into your Excel worksheet, or

link to the latest price for that stock, news

about that company, or get a report on

that company from the web (at MSN

MoneyCentral, naturally). ■

Office XP has added on a handy feature for retrieving files

you’ve recently opened in Word, Excel, and PowerPoint.

You’ll find a list of these most recent documents at the 

bottom of the File menu in each Microsoft application, as well

as in the New Document (or New Workbook or New Presentation)

Task Pane. 

Not-so-recently used files

By default, the File menu and Task Pane let you choose from the 
four most recently opened documents. To lengthen this list to 

nine, choose Tools, Options and click the General tab

1

In the box next to Recently
used file list, type the

number of files you’d like 
your File menu or Task Pane 
to display. If you don’t want
recently used files to appear 
on the File menu or in the Task
Pane, uncheck the box. You’ll
need to open more than four 
files to notice the change taking
effect. You can also retrieve
recently used files from 
any Windows application 
by selecting Start, Documents,
then choosing a file from the 
list that appears

2

h You can customise Word 2002’s Smart Tags – or turn them off
completely, if you so choose – from the AutoCorrect dialog box 
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Template (*.pot). PowerPoint automatically

switches to the Templates folder. Choose

a name for your template, making sure to

preserve the POT file extension, and click

Save. You’ll find your new template on the

General tab in the Templates dialog box. 

Manage multiple documents  
Even after all these years, Microsoft is still

grappling with making application and

document windows convenient, without

cluttering up the joint. Office XP offers

more flexibility on how you display

documents in windows than previous

versions. Depending on which version of

Office you upgraded from, you’ll be used

to viewing either a single Taskbar for Word,

Excel and PowerPoint or an extra Taskbar

icon for open documents in each. 

The default Office XP setting for Excel,

PowerPoint and Word is to display a

separate icon in the Windows Taskbar for

each open document. This tends to be

less confusing than using both the toggle

Taskbar and the Window menu, but if you

routinely work with several documents at

once, the Taskbar can get pretty messy.

You can change the setting in Word, Excel

and PowerPoint by choosing Tools,

Options. Select the View tab, then

navigate to the Show section of the dialog

box and click to turn off the Windows in

Taskbar option. You can also try using Ctrl,

F6 to toggle between documents, again

with Windows in Taskbar turned off.

Similarly, switching off this option means

you can use the same set of icons, rulers

and other tools for multiple documents

you’ve got onscreen at any one time. 

Office XP lets you create macros that perform fiddly or

repetitive tasks, then run them whenever you want by

clicking an icon or pressing a key combination. There’s almost

no limit to the kinds of tasks you can automate in Word, Excel

and PowerPoint, and the process for recording a macro is very

similar in each application. Here we show you how using Word.

Creating macros: keyboard shortcuts

To open the Task Pane, choose View, Task Pane and the Task Pane
appears on the right. You can also bring up the Task Pane using a

three-key shortcut (Alt, V, K). The macro we are creating will simplify this
process to Alt, T

1
With the Task Pane closed, open a new
Word document. Choose Tools, Macro,

Record New Macro. In the Record Macro dialog box, type ‘taskpane’ under Macro name.
Leave the ‘Store macro in’ list set to All Documents (Normal.dot) and highlight the text
in the Description field. Type ‘Opens the Task Pane’. Next click the Keyboard icon

2

This opens the Customize Keyboard dialog box. Move the cursor to the
Press new shortcut key field and press Alt, T. Leave the Save changes in

list set to Normal.dot. Finally, click Assign, then click Close

3 You’re now recording, so press Alt, V, K then click the Stop Recording icon (the little
square) on the floating Macro toolbar. Word opens the Task Pane and the Macro

toolbar disappears. Now, any time you want to open the Task Pane, just press Alt, T

4
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