
Medical Drug Reference 3.0 Help Topics

This portion of the Medical Drug Reference online Help system contains general information on 
operating the program, including instructions on all the menu options, desktop elements, and numerous 
features. For convenience, the information has been divided into different areas represented by the 
buttons displayed above. You can move to an area by clicking the appropriate button. The areas and 
topics are linked so that you can move quickly from one area directly to another by clicking icons or 
underlined words (or move to a selection using Tab or the arrow keys, then press Enter).

If you are operating Medical Drug Reference in Windows 95, see the topic Tips for Windows 95 Users 
for information on additional features available in 32-bit applications.

Click  to return to this window.



Tips for Windows 95 Users

The features that Windows 95 users can take advantage of in Medical Drug Reference 3.0 are:

Longer file names--When you save your personal drug list, you are not limited to 8-characters as in 
previous versions.

Drag and Drop--The drag and drop feature allows you to click on a drug product in a drug list or 
search results list, then drag and drop it into a personal list. 



Long File Name Feature

If you are operating Medical Drug Reference in Windows 95, you can take advantage of the long file 
names (up to 255 characters) that the application supports. If you are running in Windows 3.1, you will be 
limited to 8 characters when naming your drug lists. 

Drug lists created in the 32-bit application cannot be opened in the 16-bit (Windows 3.1) Medical Drug 
Reference 3.0 Version. However, if you select the Print to File option in the Custom Print dialog, the    drug 
information is saved as a text file that you can name and open in any word processing program (either 
16-bit or 32-bit application). 

For more information see:

Saving Personal Lists 
What   ́ s New   



Introducing Medical Drug Reference 3.0

Welcome to Medical Drug Reference, providing reliable data from First DataBank, Inc. on thousands of 
prescription and nonprescription drugs. You now have access to information you should know before 
taking certain medications, how to make them effective, what to do if you miss a dose, even a glossary of 
drug terms and abbreviations used in prescription orders by your doctor.

How to Use Medical Drug Reference Help

· Access a Help topic appropriate to your program location by pressing F1.

· Click the  toolbar button and drag it to the location in question on the desktop. When you 
release the mouse, a topic appropriate to your location will open.

· Access the opening contents page of Help by selecting the Contents option on the Help menu. 

· Click Help command buttons in dialogs to open a topic.

· Click  in a Help topic to move to an example for the topic.

· Use the browse buttons in a Help window to move through related Help topics.

For more information on using Help, select the How to Use Help option on the Help menu.

For more information see:

Navigating the Desktop 
Help Menu 



What´s New ...



Tip of the Day

The Welcome screen for Medical Drug Reference 3.0  displays a helpful tip each time you start the 
program. Clicking OK closes the dialog.
To view the next tip in the list, click the Next Tip button. New features in this version of Medical Drug 
Reference can be viewed by clicking What´s New. You can disable the Tip of the Day feature by clicking 
on the check box near the bottom of the dialog. To enable the dialog once you´ve marked this check box, 
select the Tip of the Day option on the Help menu.

For more information see:

Navigating the Desktop 
What   ́ s New   



Toolbars Dialog

Selecting the Toolbars option on the View menu opens the Toolbars dialog where you make selections for 
how the toolbar is displayed on the desktop. By default, the toolbar is displayed in a standard format. You 
can hide the toolbar display by clicking on the check box displayed in the dialog. 

To add or remove color in the buttons displayed, display larger buttons, or hide or display ToolTips, mark 
the appropriate box(es). Click OK to accept your changes and close the dialog, or Cancel to ignore the 
changes and exit the dialog.

For more information see:

Navigating the Desktop 
Toolbar



Popup (Contextual) Menus

Clicking the right mouse button in most program locations displays a contextual menu like the one shown 
here, providing easy access to several program functions. This provides a shortcut, or alternative, to the 
main menu commands and toolbar buttons. 
The menu displayed here is seen when you click the right mouse on the left side of a drug list window. If 
you click the right mouse button in a drug information window, options for highlighting text, adding a 
bookmark, and printing the information are provided on the menu. Make your selection from a pop up 
menu options by clicking on it. 

For more information see:

Navigating the Desktop 
Reference Information
What   ́ s New   



Drag and Drop

If you are running the program in Windows 95, the Drag and Drop feature is available when you are 
creating a personal list and want to copy a drug from one window into the personal list without using the 
Copy Drug and Paste Drug toolbar buttons (or menu options). This applies to drug products listed:

· in the database drug lists (Sort by Name and Sort by Therapeutic Class),

· in a personal drug list, and 

· in a search results window.

To copy a drug product from a database drug list or search results window into a personal list, 
click and hold the mouse button on the drug as you drag the mouse to the personal list window. You must 
release the mouse on the left side of the window where the drug will be inserted alphabetically according 
to the current sort order. If you try to release the mouse on the right side of the window, the copying 
process will be canceled.

To copy a drug product from one personal list to another, press Ctrl as you drag the drug product. A 
plus sign is displayed on the cursor to indicate it is being copied (as opposed to cut). Again, you can only 
drop the drug product being cut or copied onto the left side of the personal list window.

To cut a drug product in a personal list and paste it into another, click and hold the mouse button on 
the drug product as you drag the mouse.

For more information see:

Navigating the Desktop 
Reference Information
Search Results
What   ́ s New   



Reference Information

Most program options in Medical Drug Reference 3.0  can be selected using either the keyboard or a 
Microsoft (or compatible) mouse. Before you run the program, make sure the “mouse driver” software 
provided with the mouse has been properly installed. Because most Windows users tend to use a mouse, 
we emphasize mouse operation in our program documentation and in the online Help. If you are new to 
mouse operations, please refer to your Windows manual for assistance.

Selecting Options: You can select program options using one of the following methods:

· Position the mouse pointer on the option and click.

· Use the cursor keys (arrows, PgUp, PgDn, Home, or End) to move the highlight to the option or 
item and your choice, and press Enter.

· Press Alt plus the underlined “pick letter” of the option.

Familiarize yourself with the toolbar buttons and main menu options, as well as the popup menus that 
are available at many program locations when you click your right mouse button. You will also be required 
to make selections using check boxes and radio buttons.

Entering Information in Fields: Many of the windows and dialogs in Medical Drug Reference 3.0  
display blank spaces, called fields, ready for you to enter information. You can enter the information much 
like you would using any word processor. When you first access a window or dialog, a highlight bar 
usually appears in the first field. This highlight indicates your current location on the screen. To move the 
highlight from field to field, use Tab, Enter, the arrow keys, or your mouse. Fields are designed to accept 
the keyboard characters you enter. As you start to type characters, a blinking cursor indicates your 
location within the field.

Using the Windows Clipboard: You can use the Windows Clipboard to transfer information from one 
Microsoft Windows application to another. See your Microsoft Windows manual for further details on the 
Clipboard. You will also want to review the Drag and Drop topic if you are a Windows 95 user.

For more information see:

Navigating the Desktop 
Tips for Windows 95 Users



Copyright Information

Medical Drug Reference is a trademark of Parsons Technology, Inc. The Medical Drug Reference 3.0 for Windows and Medical 
Drug Reference 3.0 Deluxe for Windows Software are Copyright 1994-96 by Parsons Technology, Inc. Medical Drug Reference 
3.0 for Windows User´s Guide Copyright 1996 by Parsons Technology, Inc. All rights reserved.

IBM is a registered trademark and PC is a trademark of International Business Machines Corporation. Microsoft, and Microsoft 
Mouse are registered trademarks and Windows and Windows 95 are trademarks of Microsoft Corporation.

The Medical Drug Reference for Windows software and User´s Guide (documentation) are licensed property of Parsons 
Technology. Use of the software indicates your acceptance of the following License Statement, Disclaimer of Warranty, and Choice 
of Law.

License Statement

Medical Drug Reference for Windows (this software) is licensed for the exclusive use of the original purchaser (you) for use on 
one computer only. This software is not copy protected. Parsons Technology authorizes you to make backup copies of the software 
for your archives only, for the sole purpose of protecting your investment from loss.

You are free to move this software from one computer locations to another, as long as there is no possibility of it being used at two 
locations at one time. This software should be treated like a book, which cannot be read by two people at two different locations at 
the same time (unless, of course, the Parsons Technology license agreement has been violated).

Disclaimer of Warranty

We have made every effort to verify that Medical Drug Reference for Windows is an effective reference tool for drug information. 
However, you must be aware that Medical Drug Reference for Windows is sold to you as is without any warranty of any kind. The 
only exception is the 30-day warranty extended for replacement of defective disks. 

IN NO EVENT SHALL PARSONS TECHNOLOGY BE LIABLE OR RESPONSIBLE FOR ANY PROBLEMS THAT ARISE BECAUSE 
OF DEFECTS WITH MEDICAL DRUG REFERENCE FOR WINDOWS.

Choice of Law

This statement shall be construed, interpreted, and governed by the laws of the State of Iowa, United States of America.

For more information see:

Product Support



Prescription Terms and Abbreviations

Many of the symbols and abbreviations used in prescription orders are derived from Latin or Greek 
words. They are listed here to remove some of the mystery associated with reading an order placed by 
your physician. For a measurement conversion chart, click here.

Please note: You should always consult a physician or pharmacist if you have any questions or 
doubts about the contents of a prescription label.

Abbreviation Translated as

A
of each

ac, a.c. before meals
ad lib at pleasure
AD, a.d. right ear
ad to, up to
AL, a.l. left ear
AM, A.M. morning
aq water
aq. destdistilled water
AS, a.s. left ear
au, a.u. both ears

B
bid, b.i.d. twice a day
bm bowel movement
b.p. blood pressure

C
C 100
c. a gallon

with
cap, caps. capsule
cc, cm, or cm3 cubic centimeter
comp. compound

D
d. day
dil. dilute
disp, disp. dispense
div. divide
dtd#, d.t.d. give this number

E
ea each
el. elixir
e.m.p. as directed
et and
ex aq. in water
ext for external use

F
f., ft. make, let be made
FDA Food and Drug Administration

G
Gm., g. gram
gr. grain



gtt drops
gt drop

H
h hour
hs, h.s., hor som at bedtime

I
i.m., IM. intramuscular
i.v. intravenous

L
liq. a liquor, solution

M
M. mix
M ft make
mcg. microgram
mg. milligram
mitt# give this number
mixt. a mixture
ml, m.l. milliliter

N
N.F. National Formulary
no. number
noc. in the night
non. rep. do not repeat, no refills

O
O, Oct. pint
OD, o.d. right eye
OL, o.l. left eye
OS, o.s. left eye
OU, o.u. each eye

P
pc, p.c., post. cib. after meals
PM, P.M. evening
po, p.o. by mouth
prn, p.r.n. as needed

Q
every

q.a.d. every other day
qd, q.d. once a day
qid, q.i.d. four times a day
qod, q.o.d. every other day
q.s. a sufficient quantity
q.s. ad a sufficient quantity to make
q.v. as much as you wish

R
Rx take, a recipe
rep. let it be repeated

S
without

s day
s.a. according to art
sat. saturated
Sig., sig label as follows
sl under the tongue
SOB shortness of breath



sol, sol. solution
solv. Dissolve

, ss half unit, one-half
stat, stat. at once; first dose
supp. suppository
susp suspension
syr. syrup

T
tab tablet
tal. such
tal. dos.such doses
tid, t.i.d. three times a day
tinct. tincture
top apply topically
tr. tincture
trit. triturate
tsp. teaspoonful

U
UD as directed
ung or ungt ointment
USAN official adopted names
U.S.P. United States Pharmacopeia
UT under the tongue
ut dict, ut. dict. as directed

W
w.a. while awake

X
x times



Menu Options

The Medical Drug Reference menu bar options are:

File--Open and close drug lists, save personal lists, print drug information, set up your printer, and 
exit the program.

Edit--Cut, copy, and paste text, search for drug information, attach and view bookmarks to drug 
products or information windows, attach notes to drugs and access a list of notes, and apply or 
remove text highlights in drug information windows.

View--Select fonts and font attributes, toggle the tool and status bars off or on, set preferences for the 
desktop, and access a list of drug information windows opened during the current work session.

Drug Lists--Select and view drug lists by either name or therapeutic class, find specific drug products 
in the list, open drug information windows, and access the check for interactions feature. Additional 
options are for deleting, copying, and pasting drug products in personal drug lists.

Window--Arrange open windows on your desktop, arrange minimized window icons, close all 
windows on the desktop, and view a list of the ten windows most recently opened on the desktop.

Help--Access online help for program operation, information on how to use Help, how to obtain 
product support, and how to order drug updates. You also can read about the people who brought 
you the Medical Drug Reference program.

For more information see:

Popup (Contextual) Menus
Navigating the Desktop 



File Menu

The options on the File menu are:

New Personal List -- Opens an empty drug list window where you can create a personal drug list.

Open Personal List--Open a previously saved personal drug list by making selections in the Open 
dialog.

Open Drug List--Opens the Medical Drug Reference Sort by Name window. You also can open this 
drug list by clicking on the corresponding toolbar button.

Close--Closes the active window on the desktop. 

Save--Saves updated information in your active personal drug list.

Save As--Opens the Save As dialog where you indicate the path and file name for the active personal 
list.

Print--Prints the current, active window.

Custom Print--Opens the Custom Print dialog where you make selections for the printed format of 
your document.

Print Setup--Make selections for your printer setup in the standard Windows Print Setup dialog.

Exit--Selecting Exit closes the Medical Drug Reference.

For more information see:

Menu Options 
Popup (Contextual) Menus



Edit Menu

The options on the Edit menu are:

Undo--Ignores the most recent editing action.

Cut--Removes selected text from a text entry field or Note dialog.

Copy--Copies selected text to the Windows Clipboard.

Paste--Pastes text to Note dialog or text entry field.

Search--Search for specific information in Medical Drug Reference. You can narrow the search 
using Boolean operators and by specifying other search criteria.

Bookmark--Attach a bookmark to a drug product in a drug list or to a drug information window you 
have open on the desktop.

List of Bookmarks--Opens the Bookmark dialog listing the drug products or information windows you 
have bookmarked. You can open a topic or delete bookmarks in the dialog.

Note--Opens a Note dialog where you can enter text and attach the note to a drug information 
window you have open on the desktop.

List of Notes--Opens a List of Notes dialog listing the drug information windows to which you have 
attached notes. You can open the drug information window by highlighting it and clicking the Goto 
button in the dialog.

Highlighter--Highlight selected text in a drug information window.

Remove Highlight--Remove the highlight from selected text in a drug information window.

For more information see:

Menu Options 
Popup (Contextual) Menus



Cut Text

The Cut option (Ctrl+X) on the Edit menu allows you to edit text in a Note dialog or text entry field.

To cut text in a Note dialog,

1. Highlight the text.

2. Press Ctrl +X. 

To cut text in a text entry field,

1. Highlight the text.

2. Select the Cut option on the Edit menu (or press Ctrl +X). 

NOTE: You can undo either action if you immediately select the Undo option on the Edit menu.

For more information see:

Menu Options 
Copying Text 
Pasting Text 



Copying Text

You can copy selected text in a Note dialog, drug information window, or text entry field to paste into 
another Windows application, text entry field, or Note dialog. (The text is copied to the Windows 
Clipboard.)

To copy text in a Note dialog,

1. Highlight the text you wish to copy by holding down your left mouse button and dragging the cursor over 
the desired text.

2. Press Ctrl+C.

To copy text in a drug information window or text entry field,

1. Highlight the text you wish to copy by holding down your left mouse button and dragging 
the cursor over the desired text.

2. Choose Copy from the Edit menu (Ctrl+C).

The text is copied to the Windows Clipboard. You can then paste the text into a Windows application 
(such as a word processing or text editing program), a Note dialog, or text entry field in a dialog or 
window. See the topic Pasting Text for information on retrieving the text.

NOTE: To copy drug products from a drug list and place them in a personal list, see the topic 
Copying Drugs.

For more information see:

Cutting Text
Pasting Text



Pasting Text

You can paste text you have cut or copied into a Note dialog or text entry field in a dialog or window.

To paste text in a Note dialog,

1. Position your cursor in the Note dialog at the point you want the text inserted.

2. Press Ctrl+V.

To paste text in a text entry field,

1. Position your cursor in the field.

2. Select the Paste option on the Edit menu (Ctrl+V).

For more information see:

Copying Text 
Cutting Text 



View Menu

The View menu options are for setting preferences for the way things appear on your desktop and for 
accessing topics viewed during the current work session. They are:

Font--Select fonts and font attributes for the text displayed in the preview panes of a drug list, the 
drug information window, and for printed text.

Toolbars--Opens the Toolbars dialog where you make selections for how the toolbar and its buttons 
are displayed on the desktop.

Status Bar--Toggles the status bar off or on.

Preferences--Opens a Preferences dialog where you make selections for various desktop elements 
and optional settings.

Topic History--View a list of the drug information windows you have opened during the current 
working session. Clicking on a drug product listed in the window opens the drug information window 
on your desktop.

For more information see:

Menu Options 
Popup (Contextual) Menus



Topic History Dialog

Selecting the Topic History option on the View menu opens a dialog listing the drug information windows 
you have viewed in the current work session (since you started the program).

The drugs included in the list include any drug information windows you currently have open and any you 
have already closed. You can open (or switch to) any of the drugs listed by double-clicking on the desired 
name or by highlighting the name and clicking the Goto button. The Topic History List dialog closes and 
the corresponding drug information window opens on screen. To return to the History List, access it again 
using either of the above methods.

Exiting the History List

When you have finished using the History List, click the Close button to close the Topic History List dialog 
and return to your previous program location.

For more information see:

Navigating the Program 
Browsing Drug Lists 
Accessing Additional Topics 



Drug Lists Menu

Options on the Drug Lists menu are:

Sort by Name--Selecting this option sorts the current drug list open on your desktop by the drug 
name.

Sort by Therapeutic Class--Selecting this option sorts the current drug list open on the desktop by 
its therapeutic class.

Toggle Locator--Selecting this option toggles the Locate Drug feature to search at the drug product 
name level or at the root level. You also can click on the Toggle Locator button to toggle the Locate 
Drug feature.

Drug Information--Selecting this option in an open drug list opens the drug information window for 
the currently highlighted drug product displayed in the list.

Cut Drug--Delete a drug product from a personal drug list.

Copy Drug--Copy a drug product in a drug list.

Paste Drug--Paste a drug product into a personal drug list.

Interactions Checker--Check for potentially harmful reactions or adverse interactions.

For more information see:

Menu Options 
Popup (Contextual) Menus



Window Menu

The Window menu options let you arrange and access your open windows on the desktop, or close your 
open windows. Click on an option to display a description.

Cascade

Tile Horizontal

Tile Vertical

Arrange Icons

Close All 

Additionally, the most recently accessed windows (up to nine) are listed at the bottom of the Window 
menu. If you have opened more than nine, you can click on More Windows to view additional windows. 
Clicking on an item on the menu or list opens the corresponding window.

For more information see:

Menu Options 
Adjusting Windows and Display Panes 
Accessing Additional Windows 



Help Menu

Help menu options provide information, hints, and tips for operating the program and learning more about 
Parsons Technology and the Medical Drug Reference program. They are:

Contents--Program operation Help topics you can access to move you through the program with a 
minimum of effort.

Search for Help on--Opens an index to assist you in locating specific online Help topics.

How to Use Help--General information on using the online Help system.

Tip of the Day--Open the informational Tip of the Day dialog.

Product Support--Information on how to contact Parsons Technology for product support, customer 
assistance, and ordering other products.

Ordering Drug Updates--Keep your database up-to-date by ordering new information available 
periodically.

About Medical Drug Reference--Copyright information on the product and the people who made 
Medical Drug Reference 3.0 possible.

For more information see:

Menu Options 
Introducing Medical Drug Reference 3.0 



Navigating the Program

You can use pull down menus and toolbar buttons to access the many features of Medical Drug 
Reference. Click on any component of the desktop illustrated here to pop up a description.

NOTE: The screens displayed here and throughout this online Help system show the application 
running under Windows 95. If you are using an earlier version of Windows, your screens will look 
somewhat different.

For more information see:

Menu Options 
Program Options 



Program Options

You can select preferences for the way certain elements of the desktop are displayed on your desktop by 
accessing the View menu options. You can:

· Select a font for the text that is displayed in portions of the drug lists, in the drug information 
windows, and for your printed text. Clicking on the Font option opens the Font dialog.

· Make selections for how the toolbar is displayed on the desktop or you can choose to hide it 
completely.

· Hide or display the status bar on the desktop.

· Make selections for the highlighted text, searched text, and for saving your desktop when you exit 
the program by opening the Preferences dialog. You also can hide or display the background 
screen for Medical Drug Reference.

For more information see:

Menu Options 
Toolbar
Navigating the Program



Selecting Fonts

You can select the font you want used for text that is displayed in the various windows on your desktop 
and for printed text.

To select a font, choose the Font option on the View menu or click on the Font toolbar button. A Font 
Dialog opens where you can select the font type, style, and size that you prefer. You can choose any of 
the fonts you have installed with Microsoft Windows from the list of fonts in the dialog. For more 
information on installing and selecting fonts, see your Windows manual.

For more information see:

Program Options 
Toolbar 
Navigating the Program 
Viewing Drug Lists 
Viewing Drug Information 



Toolbar

Below the menu bar is a toolbar you can use to access frequently used functions of the program. You 
can hide or display the toolbar or change its appearance by making selections in the Toolbars dialog. 
Each toolbar button is displayed and briefly described below.

New Personal List: Opens an empty drug list on your desktop.

Open Personal List: Opens a previously saved personal list.

Open Drug List: Opens the Sort by Name or Sort by Therapeutic Class drug list.

Save Personal List: Saves a personal list.

Print: Prints the contents of the active window.

Cut: Cuts the currently selected item.

Copy: Copies the currently selected item to the Windows Clipboard.

Paste: Pastes the contents of the Windows Clipboard at the current cursor location.

Undo: Undoes the most recent editing action.

Search: Opens the Search dialog where you select or enter criteria for conducting a search for 
information.

Font: Opens the Fonts dialog where you select a font and font attributes for displayed and printed text.

Interactions Checker: Opens the Interactions Checker dialog.

Add Note: Opens the Note dialog where you can enter text pertaining to the active drug information 
window on your desktop.



Bookmark: Attaches a bookmark to a drug product in a list or to the active drug information window.

Highlight Text: Applies highlight to currently selected text.

Remove Highlight: Removes the highlight from currently selected text.

Help: Click and drag the button to open an online Help topic appropriate to the location.

For more information see:

Drug List Window Toolbar 
Menu Options 
Navigating the Program 



Exiting the Program

To exit Medical Drug Reference, do ONE of the following:

· Select the Exit option on the File menu.

· Press Alt+F4.

· Use the Control-menu box. 

· In Windows 95, click the X in the upper right corner of the application window.

If you want to save the desktop, click here on Preferences   to learn how.  

Do NOT use Ctrl+Alt+Del to exit the program. Doing so may cause you to lose information. It also may 
cause any other applications you may be running under Windows to lose data. Also, make sure you exit 
Medical Drug Reference and Windows before turning off your computer.

For more information see:

Menu Options 
Navigating the Program 
File Menu 



Opening Drug Lists

Sort by Name and Therapeutic Class Lists
To open a database drug list and view drug products, click on the Open Drug List toolbar button, or 
select the Open Drug List (Ctrl+O) option on the File menu.

In the window that opens, you can sort the drugs listed by either their drug name or therapeutic class. The 
toolbar provides quick and easy access to many of the Medical Drug Reference drug list features. To 
make viewing the drug lists easier, you can customize the look of the text in the preview panes by 
selecting specific fonts and font sizes and you can resize the window and adjust the size of the display 
panes within the window. See the related topics below for more information or click on Viewing Drug List 
Windows.

Personal Lists
To open a drug list window and create your own personal list, click the New Personal List toolbar button 
(or select the option on the File menu).

To open a previously saved personal drug list, click the Open Personal List toolbar button (or select that 
option on the File menu), and select the list in the file selector dialog that opens on the desktop.

For more information see:

Creating a Personal List
Menu Options 
Adjusting Windows and Display Panes 
Toolbar 
Navigating the Desktop 
Drug Forms 



Viewing Drug List Windows

You can access a drug list window by clicking on the Open Drug List toolbar button. (Click on Opening 
Drug Lists for more information). Click on a component of the drug list window pictured here to pop up an 
explanation.

For more information see:

Opening Drug Lists 
Creating a Personal List 
Adjusting Windows and Display Panes 
Selecting Fonts 
Toolbar 
Navigating the Program 



Sort by Name Drug List

You can view the drugs in the database sorted and alphabetically arranged by the drug product name. 
Clicking on the Open Drug List toolbar button opens the Sort by Name list by default. You also can 
access the Sort by Name list by clicking on the Name toolbar button in the Sort by Therapeutic Class drug 
list (or select the Sort by Name option on the Drug Lists menu).

The components of a Sort by Name drug list include:

Toolbar--Provides access to frequently used features for finding drug products in the list. See the 
topic Viewing Drug List Windows for complete information on the toolbar buttons in drug list 
windows.

Drug List--The pill bottle icon indicates the root level of a group of drug products. Clicking on the 
root level (or the pill bottle) displays a description of the drug products in the preview pane to the 
right. Double-clicking on the root level expands the list to display the various drug products. The 
drug product name is displayed, preceded by an icon depicting the drug form (for instance 
capsule, tablet, or ointment) and followed by its dosage.

Preview Pane--Provides a preview description of the item selected in the drug list. If you have an 
upper level (root) item highlighted, a description of the drug´s use is provided. If you have a drug 
product selected, a summary of its use is provided.

Rx Pad--Depending on your location in the Sort by Name list, the Rx Pad guides you through 
additional branches or provides access to the drug information window for a highlighted drug 
product.

For more information see:

Menu Options 
Creating a Personal List
Opening Drug Lists 
Toolbar 
Navigating the Program 



Sort by Therapeutic Class Drug List

You can view the drugs in the database sorted by their therapeutic class. You can open the Therapeutic 
Class drug list by clicking on the Class toolbar button in the Sort by Name drug list or selecting the Sort 
by Therapeutic Class option on the Drug Lists menu.

The components of a therapeutic class window include:

Toolbar--Provides access to frequently used features for finding drug products in the list. See the 
topic Viewing Drug List Windows for complete information on the toolbar buttons in drug list 
windows.

Drug List--The pill bottle icon displays the therapeutic subclasses. You can continue clicking on 
subclasses to display additional subclasses or, if there are no other subclasses, to the various 
drug products included in the therapeutic class.

Preview Pane--Provides an explanation of the therapeutic classification. Clicking on the next 
level displays a more specific summary of the therapeutic class.

Rx Pad--Depending on your location in the Sort by Therapeutic Class list, the Rx Pad guides you 
through additional branches or provides access to the drug information window for a highlighted 
drug product.

For more information see:

Menu Options 
Creating a Personal List
Opening Drug Lists 
Navigating the Program 



Opening Personal Drug Lists

To open a previously saved personal drug list, click on the Open Personal List toolbar button (or select 
the Open Personal List option on the File menu--Ctrl+L). In the dialog that opens on the desktop, select 
the path and file name for the personal list you want opened, and click OK. To open an empty personal 
drug list that you can add drugs to and personalize, click the New Personal List toolbar button. See the 
topic Creating a Personal List.

For more information see:

Copying Drugs in a Personal List 
Pasting Drugs in a Personal List 
Saving Personal Drug Lists 
Printing Personal Lists 



Creating a Personal List

You can create a personal list of drugs that you are currently taking or have used. Since you can create 
as many personal drug lists as you like with each having a unique name, you can maintain drug lists for 
every member of your family, your friends, or anyone else you like. 

A personal list is a convenient reference tool for you, your family physician, or your pharmacist. With the 
information, you can run checks for interactions between drugs that are in the list, print information in the 
drug list, attach notes and bookmarks, and conduct searches for specific words or phrases in the lists, 
just as you can with the database drug lists that are sorted by name and therapeutic class.

To create a personal list, select the New Personal List option (Ctrl+N) on the File menu, or click the New 
Personal List toolbar button. An empty drug list information window will open on the desktop, looking 
much like the Sort by Name and Sort by Therapeutic Class drug list windows.

You can begin to copy information into the drug information window, then save it for future reference. 
You can reopen a personal list by clicking on the Open Personal List toolbar button and make selections 
in the file selector dialog that opens. 

For more information see:

Copying Drugs to a Personal List 
Opening Personal Drug Lists 
Deleting Drugs in a Personal List 
Saving Personal Drug Lists 
Printing Personal Lists 



Deleting Drugs in a Personal Drug List

To delete or cut a drug product displayed in an active personal drug list, highlight the drug product name 
and select the Cut Drug option on the Drug Lists menu, or click the right mouse and select Cut Drug from 
the menu that is displayed on the desktop.

For more information see:

Creating a Personal List
Copying Drugs in a Personal List 
Pasting Drugs in a Personal List 
Saving Personal Drug Lists 
Opening Personal Drug Lists 



Pasting Drugs in a Personal List

To paste a drug product you have copied in a drug list window:

1. Click anywhere in the destination personal drug list window (or Ctrl+Tab) making it the active 
window.

TIP FOR WINDOWS 95 USERS: You can use the Drag and Drop feature to copy drugs into 
your personal list. For more information, click here.

2. Click on the Paste Drug toolbar button, or

Select the Paste Drug option on the Drug Lists menu, or

Click the right mouse button and select Paste Drug from the menu that is displayed on the 
desktop.

Note: While it is unnecessary for you to know both the generic and brand name(s) of a drug 
when copying information from a drug list, the program will paste both if you select a brand name 
for pasting into the drug list.

For more information see:

Creating a Personal List
Copying Drugs in a Personal List 
Opening Personal Drug Lists 



Copying Drugs in a Personal List

You can copy a drug product in

· a Sort by Name drug list, or

· a Sort by Therapeutic Class drug list, or

· a personal drug list,

and paste it into a personal list you have open on the desktop. Note that you cannot copy the root level of 
the drug; you must select an actual drug product in an expanded list.

TIP FOR WINDOWS 95 USERS: In addition to copying and pasting drugs from a list 
described above, you can copy drug products from a Search Results window and paste 
them into a personal drug list that you have created using the drag and drop feature. For 
more information, click here.

To copy and paste a drug product,

1. Select (highlight) the drug product name in the drug list you want to copy to a personal list.

2. Click the Copy Drug toolbar button on the drug list window toolbar, or

Select the Copy Drug option on the Drug Lists menu, or

Click the right mouse button and select Copy Drug from the menu that is displayed on the 
desktop.

3. Activate the personal drug list window and click the Paste Drug toolbar button. You also can 
choose the Paste Drug option from either of the menus mentioned in Step 2 (above). 

Note: While it is unnecessary for you to know both the generic and brand name(s) of a drug 
when copying information from a drug list, the program will paste both if you select a brand name 
for pasting into the drug list.

For more information see:

Creating a Personal List 
Pasting Drugs in a Personal List 
Saving Personal Drug Lists 
Deleting Drugs in a Personal List 



Saving Personal Lists

To save the active personal drug list that is open on the desktop:

1. Click on the Save Personal List toolbar button, or select the Save As option on the File menu.

2. In the Save As dialog that opens, indicate the path and file name for the personal list. Medical 
Drug Reference attaches the .MDR file extension to the personal list file name you designate in 
the appropriate field.

TIP FOR WINDOWS 95 USERS: The program recognizes the long file name feature 
available in Windows 95. You are not limited to the 8-character file name of previous 
versions.

3. Click on the OK button in the dialog to save the personal list and close the Save As dialog.

Once you have named and saved a personal list, you can click on the Save Personal List toolbar button 
(or select the Save option on the File menu) to save edits or changes to the personal list.

For more information see:

Creating a Personal List
Deleting Drugs in a Personal List 
Printing Personal Lists 
Long File Name Feature



Drug Forms

The icons displayed to the left of a drug name in both the Sort by Name and Sort by Therapeutic Class 
drug lists are illustrated and labeled here.



Adjusting Drug List Windows
and Display Panes

You can resize and arrange the windows open on your desktop just as you would in any Windows 
application. You also can minimize a window to an icon and restore it using the minimize and maximize 
buttons located in the upper right corner.

To change the font and font size for text displayed in the preview panes of a drug list, and the text in a 
drug information window, see the topic Selecting Fonts.

To adjust the size of the pane containing the drug list, move the mouse over the vertical bar that divides 

the drug list and the drug summary information. When the mouse pointer displays , click and hold the 
mouse as you drag the vertical bar to the left or right. Releasing the mouse button repositions the vertical 
bar and alters the display sizes of the panes in your drug list window.

For more information see:

Navigating the Desktop 
Window Menu 



Searching and Browsing Drug Lists

You have several options for finding specific information in the Medical Drug Reference. You can search 
for a specific drug using very general or more specific search criteria. You also can browse the Medical 
Drug Reference using the Locate Drug text entry field on a drug list´s toolbar.

Once you have located information, you can switch easily between drug information windows and lists, 
and compare one drug information window with another right on the desktop.

To browse a drug list and access information, see Browsing Using Locate Drug.

To search for specific information, see the topic Searching for Information.

For more information see:

Menu Options 
Selecting Fonts 
Toolbar 
Navigating the Program 



Browsing Drug Lists

The information in the Medical Drug Reference is sorted and organized into two categories--by Name 
and by Therapeutic Class. You can view either list and access complete information on a drug product 
from either drug list window. Clicking on an upper level drug product name expands the drug product list 
in a tree-like fashion to display more information. 

You can use the text entry field labeled Locate Drug (Alt+A) located near the top of the drug list (just 
under the toolbar) to enter a drug name you want to locate in the list. Clicking Locate Next button (or 
pressing Enter) searches the list and locates the first occurrence in the list. Clicking on it again moves 
you to the next occurrence, etc. When you have reached the end of the list, a message dialog will ask if 
you want to continue.

You can use Locate Next, your arrow keys, or the scroll bar to browse through the list to locate related 
drug products. Clicking on the Rx pad expands the list or opens a drug information window containing 
specific information on a drug product.

To review a list of the drug information windows you have opened during the current working session, 
choose Topic History List on the View menu. A Topic History List dialog appears listing the drug 
information windows you have opened thus far. (The list will display the names of up to 32 drug 
information windows.) You can quickly open any drug information window listed by double-clicking its 
name. 

For more information see:

Browsing Using Locate Drug 
Viewing Drug Lists 
Searching for Information 
Navigating the Desktop 



Accessing Additional Topics

When you access a drug information window from a drug list, the drug list remains open on the desktop. 
The drug information window will typically be open on top of the list. You can return to the drug list by 
clicking on any part of the drug list window to move it to the front of the desktop. You can access an 
additional drug information window or windows from the list without ever having to close a window that is 
open on the Medical Drug Reference desktop. The number of windows you have open on your desktop 
is limited only by your system´s capabilities.

You can return to drug information windows you have opened during the current session by selecting the 
Topic History option on the View menu.

If you would like to compare the data in your open windows, you can use the Window menu options to 
arrange your open windows for easy comparison. Use the Tile feature to view all your open windows on 
screen at once. Or, use the Cascade feature to layer the windows on top of one another. You can even 
switch to another open window by selecting it from the list at the bottom of the Window menu.

Use the options on the Window menu to arrange the open windows on your desktop, or reduce them to 
icons by clicking on the minimize button in the upper right corner of each window.

For more information see:

Selecting Fonts 
Toolbar 
Navigating the Program 
Menu Options 
Viewing Drug Lists 
Searching for Information 



Locate Drug

Entering a drug product name in the text entry field and clicking  searches 
the active drug list for the drug product.



Browsing Using the Locate Drug Feature

The text entry field located on the toolbar of either drug lists can be used for locating a specific drug 
product in the active drug list. The Locate Drug feature move you to specific locations in the drug list. If 
you know the drug product name, the Locate Drug feature is much quicker than scrolling or moving the 
highlight through the list with your arrow keys.

To use the Locate Drug feature, enter text from your keyboard (up to 45 characters) into the text entry 

field and click on the  button (or press Enter) to move to a location in the list. You can indicate at 
which level within the list you want to search by clicking on the button to the left of the text entry field 
(called the Toggle Locator button).

When the  is active, only the root level and the levels before the drug product name are searched 
for the text in the Locate Drug field. When the 

 is active, the expanded level or category will be searched. If a drug is found in a lower level, the 
tree will be expanded.

For more information see:

Searching and Browsing Drug Lists 



Preferences Dialog

The Preferences dialog allows you to customize the look of selected text and other attributes on the 
Medical Drug Reference desktop. Click on a component of the dialog to display a description and 
instructions for making a selection.

For more information see:

Selecting Fonts 
Custom Printing 



Font Dialog

Clicking on the Font toolbar button (or selecting the Font option on the View menu) opens the Font dialog 
where you make selections for text attributes displayed in Medical Drug Reference windows. Use the 
scrolling lists to select a font, font style, and font size. You can move the highlight to your selection by 
clicking on it or using the arrow keys. As you make selections an example of how the text will appear is 
displayed on the lower right.

You also can choose special effects by marking a check box on the left and access a list of text colors by 
clicking on the arrow at the end of the Color field. Your selections will determine how the text appears in 
the preview pane of a drug list window and in a drug information window.

For more information see:

Selecting Preferences 
Custom Printing 



Searching for Information

Utilizing the Search feature searches ten sections of a drug information window (excluding the section 
titled Name) for text, based on criteria you enter and select in a Search dialog.

Note that drug product names are best located using the Locate Drug feature in the drug list 
windows. It is specifically designed to look for drug product names.

To search for text in drug information windows, do one of the following:

· Click the Search button on the toolbar.

· Choose Search from the Edit menu.

· Press F3.

A Search dialog opens where you select search criteria. There are many search options available to limit 
your search. Therefore, the more careful you are about defining your search criteria, the more useful your 
search results will be.

For instructions on searching, click Performing a Search. 

For more information see:

Reviewing Search Results 
Menu Options 
Viewing Drug Lists 
Selecting Fonts 
Toolbar 
Navigating the Desktop 



Performing a Search

Clicking on the Search toolbar button (or selecting the Search option on the Edit menu) opens the Search 
dialog where you will enter text and make selections for conducting a search.

To perform a search from the Search dialog:

1. Enter text in the text entry field and make selections in the Select sections to search pane by 
marking the radio buttons and check boxes for the search criteria on the Search for tab. (You can 
use the command buttons      on the right to make selections as well.)

2. If you want to use Boolean operators, click here on AND/OR/NOT Tab to learn more about this 
option.

3 Click the Start Search button to initiate the search. The program will use the criteria you have 
entered or selected on the tab cards in the Search dialog to locate the specified information.

Search Results

Search results are displayed in a Search Results window that opens on the desktop. Progress is 
indicated by the meter displayed near the bottom of the window and you can halt a search at any time by 

clicking on the  button in the Search Results window.

You can access a drug information window on a drug product listed in the window while the search 
process continues. Click Using the Search Results Window for more information on viewing the results 
of your search.

NOTE: Results from a search cannot be saved. However, Windows 95 supports the drag and 
drop feature to copy drug products in the search results window to a personal drug list and save 
it for future reference.

For more information see:

Viewing Drug Lists 
Searching for Information 
Navigating the Desktop 



AND/OR/NOT Search Tab

To use Boolean operators in your search for information, click on the AND/OR/NOT tab in the Search 
dialog. The AND/OR/NOT card moves to the front of the dialog and you can make additional entries and 
selections for your search criteria.

For more information see:

Accessing Topics from the Search Results Window 
Locating Search Word(s) in a Topic 
Performing a Search 
Searching for Information 



Search Results Window

When you perform a search, any drugs meeting your designated search criteria are displayed in a search 
results window with the search criteria displayed in the title bar. Note that the window/list opens while 
searching continues. Additional topics will be added to the window/list as the search feature locates 
additional matches. The progress meter near the bottom of the window shows the status of the search.

You can cancel the search at any time by clicking the  button. You can jump to the drug information 
window for a drug product listed in the window by double-clicking on it.

When you are finished viewing the results you can:
· Close the window.

· Minimize it to an icon on the desktop or task bar so you can refer to it later.

· Copy any of the drugs in the window and paste them into a personal list that can be saved and 
printed or referred to at a later time. (See the topic Copying Drugs in Personal Lists for more 
information).

NOTE: Results from a search cannot be saved. However, Windows 95 users can use the drag 
and drop feature to copy drug products in the search results window to a personal drug list and 
save it for future reference.

For more information see:

Accessing Topics from the Search Results Window 
Locating Search Word(s) in a Topic 
Preferences Dialog 
Performing a Search 
Viewing Drug Lists 
Searching for Information 



Locating Search Word(s) in a Topic

To locate the searched word(s) in a topic shown in the Search Results window, open the desired topic 
and press Tab to move to the first occurrence. Press Tab again to move to the next occurrence, and so 
forth. The word (or words) used in your search phrase are highlighted in the topic for easy reference. The 
highlighted color is determined by your selection in the Preferences Dialog.

For further details on the Search Results List, see:

Accessing Topics from the Search Results Window 
Reviewing the Search Results 
Searching for Information 



Accessing Topics from the Search Results Window

From the Search Results window, you can double-click on any item in the list to open the corresponding 
drug information window even while the search process is active. The search feature will pause 
momentarily while the program opens the information window and will resume searching once the window 
is open. This allows you to view the initial results of your search while waiting for the final search results.

For more information see:

Reviewing the Search Results 
Searching for Information 
Viewing Drug Lists 
Searching for Information 



Interactions Checker

The Interactions Checker feature of the Medical Drug Reference program is provided to help you 
become and stay well informed about your medical condition(s) and the medication that you take as a 
result of it. It is not intended to encourage self-treatment.

A check for interactions may help you avoid complications or adverse reactions to medications that can 
sometimes result from any number of reasons. More specifically, the Medical Drug Reference program 
helps to identify potential interactions with other drugs, medical conditions, and foods. Similarly, it can 
help identify if two or more drugs are serving the same purpose, often referred to as duplicate therapy.

You can open the Interactions Checker dialog from a drug list or drug information window by:

· Clicking the Interactions Checker toolbar button, or

· Selecting the Interactions Checker option on the Drug Lists menu, or

· Clicking the right mouse button and selecting the Interactions Checker option on the contextual 
(popup) menu that is displayed.

Options for conducting a check are presented on tab cards labeled Drugs to Check, and Check for.

You can make selections, then click Start to begin the process. Once a check is complete, the results are 
presented in a Drug Interactions window, and the contents of the window can be printed as a report. 

For more information see:

Printing Interactions Results 



Drugs to Check Tab

The Drugs to Check tab is where you select the drugs you want to have checked for interactions. The 
illustration shows you the components of the tab. Note that the drugs listed in the Select Drug(s) pane on 
this card depends on your location in the program. For example, if you accessed the Interactions Checker 
from a personal list, all the drug products in the list will be displayed in the Select Drug(s) pane. If you 
accessed it from the Sort by Name or Therapeutic Class lists or from a drug information window, only the 
drug product selected will be displayed.
To remove a highlight on an item on the list, click on it, or move to it using your arrow keys and press the 
spacebar. The command buttons on the right side of the tab also allow you to select or deselect items. 
The Select All button highlights all the drugs, while the Clear All button removes the highlight from all of 
the drugs in the list. Clicking a drug product highlights it and includes it in the check for interactions 
process.

Clicking on the New Personal List button opens an unnamed personal drug list window. A message 
dialog asks if you want to include the drugs already listed in the Select Drug(s) pane. Click here on New 
Personal List to pop up a description of your options.

Clicking on the Start button begins the checking process. Before clicking on the button, you may want to 
make selections on the Check for Tab.

Clicking Cancel ignores any selections and closes the dialog.

For more information see:

Interactions Checker 
Drug Interactions Window 
Printing Interactions Results 
Check for Tab 



Check for Tab

Clicking on the Check for tab moves you to additional options for checking for drug interactions. 
You can mark or unmark an option by clicking on it or by pressing the spacebar when an item is 
selected. By default, all four check boxes will be marked. Note that multiple drugs cannot be 
checked against the entire database--only against each other.
The options on the tab are:
Drug Disease Contraindications--to check for drugs with conflicting purposes.

Duplicate Therapy Checking--to check for drugs that provide the same benefits.

Drug-Drug Interactions--to check for drugs that may conflict with other drugs.

Drug-Food Interactions--to check for drugs that can have adverse reactions when certain foods 
are ingested while taking the medication.

To begin the interactions checker process, click the Start button.

For more information see:
Interactions Checker 
Drugs to Check Tab 
Drug Interactions Window 
Printing Interactions Results 



Drug Interactions Window

The results of a check (or search) for interactions are displayed in a report form in the Drug Interactions 
window on the desktop. General information on checks for interactions is presented near the top of the 
window, followed by the drug products included in the report. The remaining report information format is 
determined by your selections in the Interactions Checker dialog.

Each section in the report is preceded by a header labeling the information (for instance, Drug-Drug 
Interactions) followed by a general explanation. If a drug product has the potential for an adverse reaction 
or interaction, a discussion of the situation is provided. 

For drug-drug and drug-food interactions, the discussions may include all or selected subtopics, including:

· Significance Level--The level of significance for the potential problem area.

· Mechanism of Action--A technical explanation detailing how the interaction occurs.

· Clinical Effects--The clinical effect(s) on the patient (for instance, may observe increased 
bleeding).

· Predisposing Factors--Circumstances that may lend to the occurrence of or enhance the 
likelihood of an interaction

· Patient Management--How the patient can manage the interaction.

· Discussion--Any additional explanation that is inappropriate to the subtopic labels listed here.

· References--A list of references you may wish to consult for further study (for instance, the name 
of a journal, its issue number, and the pages for the related article).

You can print the results in a report form by clicking the Print toolbar button (Ctrl+P). Selecting the 
Custom Print option on the File menu opens the Custom Print dialog where you can make specific 
selections for the report format.

For more information see:

Interactions Checker 
Check for Tab 



Drug Information Windows

Once you have selected a drug product on a drug list, you can access detailed information on it by:

· Double-clicking on the drug name in the drug list, or

· Clicking on the prescription pad located in the lower right corner of the drug list when a drug 
product is highlighted in the drug list, or

· Highlighting the drug product name and selecting the Drug Information option on the Drug Lists 
menu.

A drug information window opens on the desktop. Scroll bars allow you to scroll through the information, 
or you can move quickly to specific areas using the Quick Find buttons displayed on the right. You can 
select the font style and size and other text attributes by making selections in the Font dialog.

The buttons and a brief description of the information available within the text of a drug information 
window are displayed here.

Title--general name for the drug and indicates if it is a prescription or nonprescription drug.
Uses--symptoms and/or purpose for prescribing the drug.
How to Use--instructions on how to use the drug
Side Effects--explains any unusual or out of the ordinary reactions your system may exhibit as a result of 
taking the drug.
Precautions--helps you anticipate any special circumstances that should be avoided or attended to.
Interactions--alerts you to other drug products the drug may react to (typically in an adverse or negative 
way).
Drug Tips--to give you special insight on information not provided in any other category listed here. This 
can vary from "bed rest recommended while taking the drug" to tests that are available for monitoring the 
drug´s effectiveness.
Miss Dose--tells you what to do if you are unable to take a dose at the prescribed interval(s).
Storage--details on proper storage of the medication to keep it effective.
Med Alert--if any complications might occur in a medical emergency while you are taking the drug, you 
will want to carry some form of identification alerting medical personnel. Click here on Medic Alert for 
more information.
Names--lists the brand names, forms, and doses available for the drug. (Click here for a description of the 
drug forms.)

For more information see:

Viewing Drug Lists 



Searching for Information 
Navigating the Desktop 



Attachments

With Medical Drug Reference you can attach a bookmark or a note to a drug information window that is 
open on the desktop. Later, you can return to that note or bookmark by making selections in the List of 
Bookmarks or List of Notes dialogs, available as options on the Edit menu. Additionally, you can 
bookmark an item on a drug list.

You also can highlight text within a drug information window and customize the look of your drug 
information windows. Click on a topic listed here for more information on the feature.

For more information see

Attaching Notes
Attaching Bookmarks
Preferences 



Attaching Notes

You can attach a note to any drug included in the Medical Drug Reference, then retrieve the note, and 
print it with the drug product information for future reference. You can even review a list of the drugs to 
which you have attached notes for easy reference.

To attach a note to a drug information window you currently have open on the desktop,

1. Position the cursor in the text where you want the note to appear. Open the Note feature by 
clicking the Add Note toolbar button, selecting the Note option on the Edit menu, or pressing 
Ctrl+T.

2. In the Note dialog that opens, enter your notes in the workspace provided. Click Entering Note 
Text for more details on entering note text and pasting from the Windows Clipboard.

3. When you have finished entering your note text, click the OK button to attach your note to the 

current topic. A  icon appears in the upper right corner of the drug information window. A 

 icon appears within the text of the drug information window, depending on your cursor location at the 
time you accessed the Note dialog.
You can view a list of drug products to which you have attached notes to by selecting the List of Notes 
option on the Edit menu. Highlighting a drug product in the list and clicking the Goto button opens the 
appropriate drug information window on your desktop. To learn how to retrieve a note in a drug 
information window, click here on the Help topic Viewing Notes.

For more information see:

Deleting Notes 
Attaching Bookmarks 
Highlighting Information 
Customized Printing 
Menu Options 
Viewing Drug Lists 
Searching for Information 
Selecting Fonts 
Toolbar 
Navigating the Desktop 



Entering Note Text

You can enter text into the Note dialog directly from your keyboard just as you would in any text editing or 
word processing program.

Additionally, you can paste information you have in the Windows Clipboard by positioning your cursor in 
the Note dialog and pressing Ctrl+V. You also can highlight text within a drug information window, copy it 
to the Windows Clipboard (Ctrl+C), and paste it into your Note dialog.

For more information see:

Attaching Notes 
Attaching Bookmarks 
Highlighting Information 
Customized Printing 
Viewing Drug Lists 
Toolbar 
Navigating the Desktop 



Viewing Notes

List of Notes option

The List of Notes option on the Edit menu lists the drug information windows that have notes attached to 
them. Highlighting a drug product listed in the List of Notes dialog and clicking the Goto button opens the 
appropriate drug information window where you will see the Note icon.

Viewing Notes

To view a note attached to an open drug information window,

1. Position your cursor on the  within the drug information window and double click on the icon 
to open the Note dialog containing the note text.

2. You can view or edit the text, copy the text to the Windows Clipboard, or delete the note by 
clicking the Delete button. Use the scroll bars to view text not visible in the note dialog.
To close the Note dialog, click the Close button.

For more information see:

Attaching Notes 
Entering Note Text
Deleting Notes 
Printing Notes 
Attaching Bookmarks 
Highlighting Information 
Customized Printing 



Printing Notes

You can print the contents of a note you have attached to a drug information window that is open on the 
desktop. To print the note text:

1. Select the Custom Print option on the File menu.

2. In the Custom Print dialog that opens, mark the Print Notes check box on the Drug Information 
tab. You can mark and unmark other appropriate selections, then click on the OK button.

The note text will be printed on its own page with the drug product name appearing as a header across 
the top of the page.

For more information see:

Attaching Notes 
Deleting Notes 
Customized Printing 



Deleting Notes

To delete a note attached to a drug information window that is open on the desktop:

1. Open the Note dialog containing the note text by positioning your cursor on the  and 
double-clicking the mouse.

2. In the Note dialog that opens containing the note text you wish to delete, click on the Delete 
button. A Confirmation dialog will open asking you to verify the process. Click Yes to delete the note and 
return to the drug information window.

For more information see:

Attaching Notes 
Entering Note Text 
Attaching Bookmarks 
Highlighting Information 



Attaching Bookmarks

 You might use bookmarks to identify important drug information or to mark your place in the drug list if 
you are interrupted during a work session. To place a bookmark in a drug list or drug information window 
you have open on the desktop, 

· Click on the Bookmark toolbar button, or

· Select the Bookmark option on the Edit menu, or

· Press Ctrl+B.

A  icon will appear in the lower right pane of a drug list, and/or the upper right pane of a drug 
information window, depending on your location when you placed the bookmark. To learn how to remove 
the bookmark, click here on Deleting Bookmarks. 

For more information see:

Accessing Bookmarks 



Accessing Bookmarks

To open a list of drug products you have marked with a bookmark, choose the List of Bookmarks option 
on the Edit menu. A List of Bookmarks dialog opens displaying the drug product names to which you have 
attached bookmarks.

Highlighting an item in the List of Bookmarks dialog and clicking on the Goto button opens the 
bookmarked drug information window on your desktop. 

For more information see:

Attaching Bookmarks 
Deleting Bookmarks 
Navigating the Desktop 



Deleting Bookmarks

To delete a bookmark from an open drug information window, simply click on the Bookmark toolbar 
button (or select the Bookmark option on the Edit menu).

Similarly, to delete a bookmark from a drug product on a drug list open on the desktop, move to the drug 
product and click on the Bookmark button (or select the Bookmark option on the Edit menu).

You also can remove bookmarks by opening the List of Bookmarks dialog, highlighting a drug product 
listed, and clicking on the Delete button.

For more information see:

Attaching Bookmarks 
Accessing Bookmarked Topics 



Highlighting Information

You can highlight information in a drug information window to draw attention to it or to place emphasis on 
some particular piece of information within the text. The next time you access the drug information 
window, the highlight will remain intact as a reference point. Your selections in the Preferences dialog 
determine the color of the highlight.

To highlight text, hold down your left mouse button and drag the cursor over the desired text. Click the 
Highlight toolbar button, choose the Highlighter option on the Edit menu, or press Ctrl+H.

To remove the highlight from text in an open drug information window, select the text by dragging the 
cursor over the text with your mouse, then click on the Remove Highlight toolbar button (Ctrl+R).

For more information see:

Attaching Bookmarks 
Customized Printing 



Setting Up Your Printer

The Medical Drug Reference allows you to print a variety of information to your current Windows printer. 
If you plan to use this printer, no additional printer setup is necessary from within the program.

If, however, you would like to use a different printer or would like to print your data in landscape (wide) 
format rather than portrait (tall), for example, you can use the Print Setup option on the File menu to 
select the desired printer and print options.

See your Windows or printer manual if you need help with printer setup.

For more information see:

Printing 
Custom Printing 



Printing 

You can print drug information windows, personal lists, and results from a check for interactions in 
Medical Drug Reference.

The font defaults to the font you have selected in the Font dialog, accessible on the View menu. All other 
formatting options default to the default settings in the Custom Print dialog. This is where you can make 
selections for printing selected information in a drug information window, to print notes attached to a drug 
information window, to set margins, to indicate the number of copies to print, as well as for printing to a 
file.

For specific information on printing personal drug lists, click here  .  

For specific information on printing drug information windows, click here.

For more information on printing the results from a check for interactions, click here.

To print using a different font, see the topic Selecting Fonts.

For more information see:

Setting Up Your Printer 
Printing Notes 
Printing to a File 



Printing Drug Information Windows

To print an active drug information window in its entirety:

· Click on the Print toolbar button, or

· Select the Print option on the File menu, or 

· Press Ctrl+P,

to send the active drug information text to your Windows printer for print output.

To print selected information in the drug information window, see the topic Custom Printing.

For more information see:

Printing 
Printing Drug Interactions Results
Printing Personal Lists
Setting Up Your Printer 
Printing Notes 
Printing to a File 



Printing Interactions Results

To print the text in a currently selected (active) interactions results window:

· Click the Print toolbar button, or

· Select the Print option on the File menu, or

· Press Ctrl+P.

You can customize the printed output (set margins, select the printer, and other print options) by selecting 
the Custom Print option on the File menu.

NOTE:    When you access the Custom Print dialog from an active interactions results window, 
the options on the Drug Information tab are not available as those options are not relevant to 
printing the interactions results.

For more information see:

Printing 
Setting Up Your Printer 
Printing Drug Information Windows
Printing Personal Lists
Printing Notes 
Printing to a File 



Printing Personal Drug Lists

To print the active personal drug list: 

· Click the Print toolbar button, or

· Select the Print option on the File menu, or

· Press Ctrl+P.

The printed output will include the drug product name displayed in the list with the generic name 
displayed in parentheses. For information on how you might use your personal list, click here

NOTE: You cannot print the entire database of drug products (the Sort by Name or Sort by 
Therapeutic Class drug lists).

For more information see:

Printing 
Printing Drug Information Windows
Printing Drug Interactions Results
Setting Up Your Printer 
Printing to a File 
Printing Notes 
What   ́ s New   



Custom Printing

You can set certain preferences for printing the text in a drug information window and for customizing the 
printed output format. Select the Custom Print option on the File menu to open the Custom Print dialog 
and make your selections.

In the dialog that opens, your choices appear on tab cards. Clicking on a card´s tab (or press Ctrl+Tab) to 
move the tab to the front.

You can mark options on either card by clicking on an option with the mouse or highlighting an option and 
pressing the spacebar. Note that you can save the settings you select by marking the Save Custom Print 
setting check box. That way, the next time you open the Custom Print dialog, your customized settings 
will be displayed. You can always return to the default settings by clicking on the Default button.

Click here for an explanation of the options on the Drug Information Tab.

Click here for an explanation of the options on the Options Tab.

For more information see:

Printing 
Setting Up Your Printer 
Printing to a File 
Printing Notes 



Drug Information Tab

The Drug Information tab in the Custom Print dialog displays all the categories that are included in a drug 
information window. By default, all the options on the Drug Information tab are marked and the program 
prints the information as it appears in a drug information window on your desktop. You can change these 
settings by marking selections and then clicking on the Save Custom Print settings check box.

If you mark the Include Notes check box, the drug information you have marked will be printed with an 
additional printed page containing the text from any note you have attached to the drug information 
window. The drug name will appear as a header across the top of the printed page for easy reference. A 
superscript indicator will be printed within the drug information window text to show where the note was 
attached in the window.

You can return to the default settings by clicking on the Default button. To select options for the margins 
of your printed page or to access the Print Setup dialog, click on the Options Tab. To accept changes you 
have made on the Drug Information tab and print the drug information, click OK. To ignore changes and 
close the Custom Print dialog, click on Cancel.

For more information see:

Custom Printing 
Setting Up Your Printer 
Printing to a File 
Printing Notes 



Options Tab

The Options tab in the Custom Print dialog displays options for setting up the margins for your printed 
page or you can select the Print to File option if you want your drug information saved as a file, perhaps 
for access in your word processing or other text editing program.

To select a margin setting, use the arrow keys at the end of the margin field to select from a standard 
margin settings, or highlight the text in a field and enter the new numbers from your keyboard.

Clicking the Default button on the right returns the margins to the default settings. Clicking the Setup 
button opens the Print Setup dialog where you can make selections for your Windows printer.

To accept changes you have made on the Options tab and print the drug information, click OK. To ignore 
changes and close the Custom Print dialog, click on Cancel. To return to the Drug Information tab, click 
on it with your mouse.

For more information see:

Custom Printing 
Drug Information Tab 
Setting Up Your Printer 
Printing to a File 



Printing to a File

The Print to File option on the Options tab in the Custom Print dialog allows you to save text in a drug 
information window to a file that you can open in another program. For instance, you can save the 
information as a .TXT file and open it in your favorite word processing program for text editing or 
formatting. The drug information window print format is not saved with the text, so you can format the text 
to suit your personal tastes.

To print a drug information window to a file,

1. Mark the Print to file option on the Options card in the Custom Print dialog you access by 
selecting Custom Print on the File menu.

2. Click OK to open the Save As file selector dialog. Designate a file name and path for the drug 
information in the dialog and click OK.

For more information see:

Custom Printing 
Setting Up Your Printer 



Troubleshooting

If you are having a problem operating the Medical Drug Reference, there are a variety of options 
available to help you resolve your difficulty. The Troubleshooting Procedure topic includes a list of steps 
you should follow to resolve any problem you may have. 

For more information see:

Customer Assistance 
Technical Support 



Troubleshooting Procedure

Whenever you encounter a problem with the program or have a software-related question, follow this 
procedure:

1. Access the Medical Drug Reference online Program Information Help (F1). This system 
presents up-to-date operational information and is often context-sensitive, reflecting a topic 
related to your current location and function.

2. Refer to the contents and index within the Medical Drug Reference User´s Guide for specific 
topic and page numbers.

3. Refer to any README file included on your program disks. This file contains current information 
about the Medical Drug Reference.

4. Use an automated service (such as CompuServe or America Online) to get help. SmartFax can 
provide information, too. 

5. If you still cannot resolve your problem, contact Technical Support Department.

For more information see:

Customer Assistance 
Registering the Medical Drug Reference 



Product Support

Thank you for purchasing the Medical Drug Reference. Select from the following topics to learn more 
about:

Registering the Program 
Troubleshooting 
Getting Help--Customer Assistance and Technical Support 
Purchasing Other Products From Parsons Technology



Registering the Program

When you purchase any product directly from Parsons Technology, you are automatically registered in 
our customer database. Therefore, you do not need to send in a registration card. Registration entitles 
you to the following registered customer benefits:

· Free, unlimited technical support for current versions of all our programs.

· Notices of updates to current products.

· Announcements of new products.

If you purchased this product through a distributor, be sure to complete and return the customer 
registration card included with your packet. Fax the registration card to us at 1-319-395-7449.

If you have misplaced the registration card, you can register your product by calling 1-800-847-6995 or 
Contact us at these same numbers with any address changes so that we can keep you current with 
Parsons Technology developments.

See also:

Getting Help--Customer Assistance and Technical Support 
Purchasing Other Products From Parsons Technology 



Getting Help

Parsons Technology addresses customer needs and concerns in two departments:

Customer Assistance 
Technical Support 

See also:

Registering the Program 
Purchasing Other Products From Parsons Technology 



Customer Assistance

At Parsons Technology, you--the customer--are first. If you need help with any of the following, please call 
our Customer Assistance Department at 1-319-395-0115 or fax us at 1-319-395-0466. A friendly 
representative will be happy to help you.

· Questions or problems about your bill.

· Defective user´s guides.

· Questions or problems about your shipment.

· Questions about returning a product.

See also:

Technical Support 
Registering the Program 
Purchasing Other Products From Parsons Technology 



Technical Support

Registered customers get free technical support for current versions of all our products. (See Registering 
the Program for information on registering.) 

We offer phone support that is best used for getting you up and running. In-depth and ongoing support is 
mainly and best provided via CompuServe and other online services, as detailed below. Because of time 
delays associated with corresponding by mail, we do not accept written correspondence.

NOTE:    If you are hearing-impaired or have other physical disabilities that affect your 
communication, please mention this in your correspondence along with the method by which you 
prefer for us to respond to you.

Contact Technical Support for help with:

· Installation.

· Defective disks.

· Problems with printing.

· Data conversion issues.

· Questions about program operations.

Before you contact us for technical support:

· Have you checked the User´s Guide, the online Help, and the README file supplied with the 
software disks for possible solutions?

· Can you duplicate the problem at will? Please try to repeat the steps that initially caused the 
problem.

· Have you tried booting with a system-formatted DOS disk and running the program? See your 
DOS manual if you need help formatting a system disk. 

If you are unable to resolve the problem after checking the above items, please contact us by one of the 
following methods rather than by mail: 

· The best way to get help quickly is to talk to us on CompuServe Information Service.

· To contact us on America Online, use the keyword PARSONS.

· Another good way to get help is call one of our representatives on the Telephone at 1-319-395-
7314.

· SmartFax gives you even more information. 

See also:

Customer Assistance
Purchasing Other Products From Parsons Technology 



Purchasing Other Products From Parsons Technology

Parsons Technology offers a full line of quality products. All our products come with an unconditional, 
money-back guarantee. If you are not satisfied with a program or our service, simply return your package 
within 30 days for a full refund (excluding shipping). No questions asked!

To order Parsons Technology products, contact our Orders Department toll-free 24 hours a day at 1-800-
223-6925 or visit your local software retailer. Outside North America, call 1-319-395-7300.

Our order line staff are eager to help you, but they are not trained in the mechanics of our software. 
Please do not call them with technical support questions. They cannot transfer your call to Technical 
Support.

You can order products using online services, too. The URL for Parsons Technology´s World Web Site on 
the Internet is:

http://www.parsonstech.com

To shop using CompuServe Information Service, type GO PA. If you use America Online use the 
keyword PARSONS.

See also:

Ordering Medical Drug Reference Updates 
Registering the Medical Drug Reference 



Ordering Medical Drug Reference Updates

You can keep your Medical Drug Reference database current with up-to-the minute drug information 
with database updates that are released on a regular basis. New drugs will be added, and the information 
about all drugs will be updated when appropriate. You can locate the date of the drug data in your 
database by selecting the About Medical Drug Reference option on the Help menu. 

Call 1-800-223-6925 to order the latest update, or if you have a modem and can access the Internet, you 
can download the updated files. 

The URL for the Parsons Technology World Wide Web site on the Internet is 
http://www.parsonstech.com

To shop using CompuServe Information Service, type GO PA. If you use America Online, use 
the keyword PARSONS.

See also: 

Purchasing Other Products from Parsons Technology 
Customer Assistance



Why create a personal list?

People with severe or multiple health problems frequently see more than one health care specialist, often 
times more than once or twice a year. It is always wise to provide any health care provider with a 
complete list of medications you are currently taking, whether they be over-the-counter or prescribed drug 
products. 

By creating a personal list of drugs, you can supply this information to your physician with a minimum of 
effort. You can print the personal drug list from the program along with drug information window text 
and include it with your personal drug list, as well as any personal notes you have made about the drug 
using the Note dialog in Medical Drug Reference. (Also see the topic Printing to a File.)

Other reasons for creating a personal list include checking for interactions with other drugs and foods, for 
duplicate therapy, or to ensure you are not taking any drugs that may conflict with a medical condition. 
See the topic on the Interactions Checker.

Inventory of Over-the-Counter Drugs 

You can use a personal list to keep track of the drugs you have purchased and have on hand at home for 
use by family members. For instance, if you purchased a cough syrup for one of the children, and it would 
be appropriate for other family members, you can include it in a personal list, attach a note to it describing 
its use, purchase/expiration date, and o other comments, and have the information readily available in the 
event that another family member develops the same symptoms and can use the same medication. 



When should I use the custom print feature?

The custom print features in Medical Drug Reference allow you to customize the printed format of 
information and print only portions of the comprehensive material provided. If you are making the 
information available to other individuals, you can consider their circumstances and create documents 
that would best suit their needs.



Why does the Medical Drug Reference list so many different names for the same 
drug?

Manufacturers of drugs can produce and market drugs to both consumers and other companies. They 
typically have their own trade name for a drug they manufacture and sell to consumers. This trade, or 
"brand," name is registered or trademarked to the company and no one else can use it.

The generic name is more universal in nature; that is, it is more easily recognized by pharmacists, 
physicians, and other health care professionals. It is often times a shortened form of the chemical name 
and is not protected by a trademark registration. Therefore, anyone can use the name and can market 
drugs or drug products by the generic name.

By providing the numerous names of drugs in the Medical Drug Reference, you can quickly identify a 
drug product, and are able to supply accurate and appropriate information to health care providers and 
pharmacists.



Why would I save drug information as a text file and open it in another 
application, such as my word processing program?

With the many features available in Medical Drug Reference, you can copy and paste any combination 
of the information available into another application for personalized formatting and presentation of 
information.

For instance, you might save drug information and the results of an interactions check in a text file format 
then edit and rearrange the text to suit your needs. This might be appropriate for:

Þ Students completing course work in health occupations and related fields.

Þ Parents of children with health care concerns or problems who want to make the information 
available to day care providers, schools, and others.

Þ Adult children whose parents are moving to an assisted living or health care facility and will 
require assistance with medications.

Þ Patients under the care of more than one physician. Generating a report format of current 
medications and questions, notes, and so on can generate questions and contributes to a more 
productive discussion during consultations.



When would I use the Note feature?

While you are sure to find additional uses for the Notes feature, some suggestions are listed below.

Þ Keep track of any ideas that you think of while reading the information.

Þ Attach a note to a drug information window, then copy and paste the text into a note attached to 
another drug information window.

Þ Remind yourself when you used a specific drug and what the results were.

Þ Print the note so your observations or thoughts can be made available to a health care provider 
or appropriate care giver.

Þ If you have created a personal list to help keep track of over-the-counter medications you have on 
hand at home, attach notes to the drug products to record who took what, when they took it, even 
purchase or expiration dates.



When would I use the Bookmark feature?

Some ideas for using bookmarks include:

Þ Mark topics that were located during a particular search, so you can differentiate them from other 
search topics.

Þ Mark a topic you want to read at a later time.

Þ Identify drug products in the drug list that cause you to have an allergic reaction, an upset 
stomach, or other side effect or unpleasant reaction.

Þ Identify brands of a drug product that you want to discuss with your pharmacist.

Þ Identify topics related to a particular report or research project you are working on.



What type of information will I find during an interactions check?

The amount of information generated during an interactions check is determined by the results found. If 
the potential for an interaction does not exist, the report will provide general information on interactions, 
including a statement that you should consult your physician or pharmacist with any concerns you may 
have about medication you are taking. Each individual is unique, so it is possible that even though the 
Medical Drug Reference interactions check does not produce significant information, you could still have 
symptoms or side effects that make your situation unique.

The remaining information is generated depending on the situation (or medications) you present in the 
Interactions Checker dialog and may include:

Drug-Disease Contraindications: The drugs, the implied disease they are treating, and the drug that 
may be contraindicating (causing a negative effect) are listed. The report generated includes reference 
materials that may be appropriate to your situation.

Duplicate Therapy: When at least one ingredient from a drug listed in the Interactions Checker dialog is 
having the same therapeutic effect as the ingredient of another drug, it is possible that one of the drugs is 
unnecessary. The potentially duplicative drug products are listed and you are encouraged to seek medical 
advice.

Drug-Drug Interactions: In addition to taking more than one medication, many factors can influence the 
outcome of ingesting more than one medication (whether they are prescribed, over the counter, or a 
combination of both). All these factors cannot be covered in this check; however, if there is a potential for 
two drug products to interact negatively, the drug products with conflicts are listed and more complete 
information is provided in a drug monograph format. You should read this information carefully and share 
any concerns you have with your physician or pharmacist.

Drug-Food Interactions: Chances are you have been told by a pharmacist that a particular medication 
should be taken with food, or perhaps without food, or never ingested with alcohol. There are drug 
products that cannot be as effective or will cause adverse reactions when accompanied by certain food 
products. As with the Drug-Drug Interactions report, the Drug-Food Interactions information includes the 
drug-food pair having the potential for an interaction, followed by a drug monograph explaining the 
situation. Again, share any concerns you may have with your physician and/or pharmacist.



Cascade

Open windows are arranged in an overlapped fashion on the desktop so that all 
title bars are displayed.



Tile Vertical

Open windows are placed side-by-side on the desktop.



Tile Horizontal

Open windows are placed in a stacked style across the desktop.



Arrange Icons

Icons of minimized windows are displayed horizontally across the bottom of the 
desktop.



Close All

All open windows on the desktop are closed.



Marking Options

Many times you will make selections by marking or unmarking a check box or 
radio button. To place or remove an X in a check box, click on the box preceding 
your selection, or Tab to the box, and press the spacebar. You can mark or 
unmark as many check boxes in a dialog as you like.

Radio buttons are used to select one option over another. You can mark a radio 
button using your mouse to click on it or using the Tab key to reach the first radio 
button in the group and using your arrow keys to move to any additional buttons 
displayed.



Drug Information Window

A window displaying all the information available for a drug product in the 
Medical Drug Reference. You can open a drug information window by 
selecting a drug listed in the Sort by Name, Sort by Therapeutic Class, or 
personal drug list, as well as from a Search Results window and Drug 
Interactions window.



Defective Disk Replacement

Usually you receive one of these messages if you have a bad disk:

"General failure error reading drive ..." "Sector not found ..."

"CRC error ..." "Bad sector ..."

"Unrecoverable read error ..." "Address mark not found ..."

To check, use the DISKCOPY command to copy the entire disk. DISKCOPY 
reports any bad sectors. (See your DOS manual.) Check all disks. To replace 
defective disks, call Technical Support at 1-319-395-7314. Within 30 days of 
purchase, we replace disks free. After this, contact Technical Support for prices. 



CompuServe Information Service

If you are a CompuServe member, type GO PARSONS at any menu prompt. 
Select the Parsons Technology Forum. Please complete the problem report 
found in Library 1 - Misc. Info. (file name: SYSPRO.TXT). We do our best to 
respond to questions within 24 hours in our Forum.

You may also discover that many of your questions have already been answered. 
You can tap into our library of application bulletins and other information 
releases. You can participate in a progressive dialog with experts and other 
helpful users.

If you would like to receive a free introductory membership to CompuServe, call 
their Telephone Sales and Inquiry Department at 1-800-848-8199 and ask for 
Representative #194. (You will need a telecommunications program and a 
modem.)



Telephone

The voice number for Technical Support is 1-319-395-7314. Before you call, 
make sure your computer is turned on and the relevant program running (if 
possible).

An automated attendant will direct you to the right location and give Technical 
Support Department hours. We are a service-oriented company and will take all 
the time needed to answer your questions. But when you first dial in, you may 
have to wait a short time while we offer this same attention to the callers ahead of 
you.



SmartFax

Parsons Technology maintains a SmartFax system that lets you receive technical 
bulletins, product descriptions, and other information about our products 
automatically. Just call from your own FAX machine. The SmartFax number is 1-
319-395-0176.

The system will answer with a voice and will ask you which document you would 
like to receive. Choose document 100 for instructions for using the system and a 
partial directory of available information. Choose 101 for a complete directory. 
The item you choose will be sent directly to your FAX machine. This service is 
available 24 hours a day.



Browse Buttons

Located below the menu bar in a Help window, the browse buttons display 
directional arrows and move you through related Help topics in the Medical Drug 
Reference.



OK 

Selecting OK accepts your request and exits the dialog.



Cancel

Selecting Cancel ignores your request and exits the dialog.



Status Bar

The Status Bar option toggles the status bar off and on. The status bar is 
displayed by default and a check mark appears next to the item. To hide the 
status bar, remove the check mark by clicking on it with your mouse.



Active window

The active window, also known as the current window, is indicated by a 
highlighted (or different colored) title bar.



Toolbar

The toolbar, located just below the menu bar, contains buttons you can use to 
quickly access program features. The first time you access the program, the 
toolbar is displayed by default. To hide the bar or make selections for how it is 
displayed, select the Toolbars option on the View menu.



Desktop

The Medical Desk Reference desktop includes anything that appears within the 
application window. For example, the desktop may contain a toolbar, a status bar, 
drug information, minimized window icons, etc.



Menu bar

A horizontal list of menu options that appears along the top of the application 
window, just below the title bar. The menu bar is also referred to as the main 
menu. When you select any of the options, a pull down menu appears listing 
additional choices and access to program features.



Status bar

The bar located along the very bottom of the Medical Drug Reference 
application window. The status bar displays important information as you work 
with the program, including descriptions of how toolbar buttons operate.



Title bar

The top bar of a program window or dialog box that displays the title of the 
program or dialog. If the window is the currently active window, the title bar will be 
a highlighted (or different) color.



Maximized window

A window that has been expanded to full screen size. You maximize a window by 
clicking on the button in the upper right corner of the window. When you 
maximize a window, the button changes to display both up and down arrows. 
Clicking on the button in this mode returns the window to its original size.



Minimize button

In Windows 3.1 applications, you can click the small down arrow button located in 
the upper right corner of the application window (or any other windows you have 
open on the desktop) to reduce the window to an icon. In Windows 95, clicking 
the button displaying a hyphen ( - ) places the application on the status bar for 
easy retrieval. To return a minimized window or application to its previous size, 
double-click on the icon or the application name.



Maximize button

The small up arrow button located in the upper right corner of the application 
window or other windows on the desktop in Windows 3.1. Clicking on the button 
increases the size of the application or window so that it fills the entire screen. 
When an application is maximized, the button displays an up and down arrow 
symbol. You can click on this button to return the window to its previous size.



Scroll bar

A horizontal bar displayed at the bottom, or a vertical bar displayed on the right 
edge, of a window whose entire contents cannot be viewed on screen. Use the 
arrow buttons to move one line at a time, or click and hold an arrow button to 
scroll continuously. You also can click and drag the box on the scroll bar to move 
to another location within the window. Click above or below the box on the scroll 
bar to jump about one screen.



Closing Windows

To close an open window or dialog, double-click in the far upper left corner of a 
window on either the icon or box(or button). In Windows 3.1 clicking on the box 
(called a Control menu-box) drops down a menu listing options. Click on an 
option to select it. 

In Windows 95, you also can click on the X in the upper right corner to close the 
window.



Boolean operators

The Boolean operators in Medical Drug Reference place limitations on search 
criteria using the AND, OR, and AND NOT operatives. For example, if you are 
searching for pain relievers but you do not want to view information on 
analgesics, you could select the Boolean operator NOT as your search criteria on 
the AND/OR/NOT tab in the Search dialog.



Word or Phrase field

Text entry field where you enter the word or phrase criterion for the search. Once you 
have used the Search feature, you can click the arrow at the end of the Word or 
Phrase text entry field to access a list of your previous search descriptions. (The 
dialog retains information on the last 20 searches.)



Select sections to search pane

The sections listed here coincide with the sections displayed in a drug 
information window. Mark or unmark a section to search by clicking on the check 
box.



Command Buttons

Clicking on the Select All command button marks all the check boxes in the 
Select sections pane, while Clear All removes all the check marks from the boxes 
preceding the various sections.



Save Desktop

By default, the Medical Drug Reference desktop will be saved when you exit the 
program so that the next time you open it, your windows, minimized icons, and 
other features will appear the same. Mark or unmark the check box to suit your 
personal needs.



Display Picture Background

You can disable the background picture on the Medical Drug Reference desktop 
by unmarking the check box. The default is to have the background displayed.



Highlight Color

You can select the color of any text you choose to highlight in a drug information 
window. Clicking on this button opens a Color selector dialog where you can click 
on your choice and change the color of any highlighted text.



Search Color

You can select the color for the highlight on text you have searched using the 
Search dialog. The text you enter as search criteria is highlighted in a drug 
information window. Clicking on the button opens a Color selector dialog where 
you indicate your color choice.



Medic Alert

The Medic Alert Symbol worn or carried by an individual signals that they are 
taking a medication or have a condition that may cause complications in a 
medical emergency. The symbol is typically displayed on a bracelet or can be 
found on some other form of identification on the individual. For more information 
on Medic Alert, call 1-800-854-1166.



Drug List Pane

The drug products are listed on the left side of the drug list window. Their sort 
order (by name or therapeutic class) is determined by the toolbar button selection 
(or Drug Lists menu option). Drug product names are preceded by a drug form 
icon (for instance, capsule or tablet), and followed by the drug dose. You can 
resize the drug list pane by clicking and dragging the vertical bar near the center 
of the window.



Preview Pane

When a drug product is highlighted (or selected) in the drug list window, 
information previewing the text in a drug information window is displayed on the 
right side of the drug list window. The information displayed is dependent on the 
sort order (name or therapeutic class). 

Sort by Name Preview: Displays the root level name and drug product name, 
followed by a description of the drug usage.

Sort by Therapeutic Class Preview: Displays the current class or drug product 
name and any broader classes followed by information about the therapeutic 
class, or drug usage.



Rx Pad

Depending on your location, messages displayed here guide you through the 
levels of the drug product or open the drug information window for a selected 
drug product.



Close Level

Collapse an expanded drug product listing in the drug list window by clicking this 
button.



Toggle Locator

Click on the button to move to the root or extended level in the drug list.



Locate Drug

Enter a drug product name that you want to locate in the list and press Enter.



Locate Next

Clicking here moves you to the next occurrence of a drug product in the drug list.



Name/Class

Clicking on a button sorts the drugs in the drug list window by either drug product 
name or therapeutic class.



Copy Drug

Highlighting a drug product on a drug list and clicking on this button copies the 
drug product for pasting into another list.



Paste Drug

Clicking on this button pastes the most recently copied drug product to the active 
personal drug list window.



Drug List

The drug list displays the drug products in Medical Drug Reference, sorted by 
either the drug product name or the therapeutic class. An icon preceding the drug 
product name indicates its drug form (for instance capsule, tablet, etc.). The 
drug dose follows the drug product name in the list.



Prompt to Save Personal Lists

By default, when you exit the program, you will be prompted to save any personal 
lists you have created or edited. Unmark the check box to disable this prompt. 



Drug List Toolbar

The toolbar in the drug list window provides easy access to the many features of 
the drug lists and performs various functions. See the topic Drug List Toolbar for 
complete information on each toolbar button. 



New Personal List

To create a new personal list from the Interactions Checker dialog, click on the 
New Personal List button. You will be asked whether you want to create a list 
with the drugs listed in the Interactions Checker. Yes opens a list displaying the 
drugs; No opens an empty list; and Cancel closes the dialog and returns you to 
the Interactions Checker dialog.



Interactions Tips

By default, a dialog with tips for using the Interactions Checker will appear when 
you access the Interactions Checker dialog. You can disable this option by 
unmarking the check box.



Check Box

When you click on a check box with your mouse, an X appears in the box. Note 
that when you open some dialogs, one or more items may already be checked by 
default. To change the selection, move the cursor to the box in front of the option 
of interest and press the spacebar (or just click on it with your mouse). If the item 
was previously selected the X is removed from the box. If the item was not 
selected, an X appears in the box.



Radio Button

Radio buttons allow you to select program options or features where you can 
make only one choice. Sometimes, radio buttons are selected by default, but you 
can change this selection by clicking on another radio button. The selections will 
move from the default (if there was one) to your new choice. You cannot deselect 
a radio button by clicking on it; you must select an alternative option.



Undo

Selecting the Undo option on the Edit menu ignores the most recent editing 
action (such as cut or paste).



Display Start Up Screen 

To disable the opening splash display each time you start the program, unmark 
this check box by clicking on it.



Show Tips 

To disable the Tip of the Day display each time you start the program, unmark 
this check box by clicking on it.



Conversion Table

Body temperature:

Normal body temperature of 37 degrees Celsius is equivalent to 98.6 degrees Fahrenheit.

If you know the degrees Fahrenheit and want to convert to Celsius, subtract 32 
from Fahrenheit, then multiply the remainder by 5/9.

EXAMPLES:

98.6F - 32 =    66.6 x 5/9 = 37C (or 102F-32 = 70 x 5/9 =38.8C)

37C x 9/5 = 66.6 + 32 = 98.6F (or 39C x 9/5 = 70.2 + 32 = 102.2F)

Weight/ volume

1 kilogram(kg) = 1000 grams (Gm)

1 gram (Gm) = 1000 milligrams (mg)

1 milligram (mg) = 1000 micrograms (mcg)

1 liter (L) = 1000 milliliters (ml)

Weights

1 ounce (oz) = 30 grams (Gm)

1 gram (Gm) = 15 grains

1 grain = 60 milligrams (mg)

1 kilogram(Kg) = 2.2 pounds (lbs)

Volume

1 cubic centimeter (cc) = 1 milliliter (ml)

1 fluid ounce (oz) = 30 milliliters (ml)= 30 cc

1/2 measuring teaspoon (tsp) = 2.5 milliliters (ml) = 2.5 cubic centimeters (cc)

1 measuring teaspoon (tsp) = 5 milliliters (ml)

1 measuring tablespoon (tbsp)    = 15 milliliters (ml)

2 measuring tablespoons (tbsp) = 1 fluid ounce (oz)



World Wide Web Site

You can join in the fun and access a wealth of information on products when you reach the Parsons Club 
House on the Internet at http://www.parsonstech.com

You will find:

· Information on all our products.

· Demos that you can download on the spot.

· Tips and tricks for using Parsons products.

· Answers to frequently asked questions (FAQ´s).

· Updated information on maintenance releases and upgrades.

· A form for ordering products.

And much, much more.

See also:

Customer Assistance
Purchasing Other Products From Parsons Technology 



Drug List Toolbar

The toolbar buttons located across the top of a drug list window provide quick and easy access to 
features. The text entry field labeled Locate Drug can be used to find specific drug products in the list. 
See the topic Browsing Drug Lists for more information on this feature.

The items on the toolbar in the drug list window are displayed here. Click on an item for an explanation.

For more information see:

Viewing Drug Lists 
Toolbar 
Navigating the Desktop 
Popup (Contextual) Menus 



Note icon

Indicates a note has been attached to the drug product. For more information, 
see the topic Attaching Notes. 



Bookmark icon

Indicates a bookmark has been attached to the drug product. For more 
information see the topic Attaching Bookmarks  .   



About Medical Drug Reference 3.0

Displays information about your copy of Medical Drug Reference, including the 
version number; the date of the drug data in the database, the copyright, notices; 
and members of the development team that produced the program.



Color Dialog

Make selections for the color of your highlighted and searched for text by making selections in the Color 
dialog. To access the dialog, click the Highlight Color or Search Color in the Preferences dialog. In the 
Color dialog that opens, select a basic (preset) color displayed by clicking on it, then click on the OK 
button. 

To create a custom color, click on the Define Custom Colors button., click on the color with the mouse: 
and drag the Crosshair control to your selection. Use the Pointer control on the right to make 
adjustments. Your color is displayed in the display box on the lower left labeled Color/Solid. 

You select a color with a keyboard by typing numbers into the text boxes in the Color Dialog. Unless you 
are already familiar with the concepts of computer display color creation, and have a specific color in 
mind, it is easier to select a color using the mouse. 

To add the custom color to the palette, click the Add to Custom Colors button. To apply your selection 
and close the dialog, click on the OK button. 



Credits Dialog

The Credits dialog displays the names of the individuals on the Medical Drug Reference 3.0 software 
development team as well as those who produced the multimedia version (Medical Drug Reference 3.0 
Deluxe Edition), publications and documentation specialists, and those who tested the program for 
quality assurance.



Tips of the Day

¨ Keep the phone number for your local poison control center available in case of drug overdose or 
improper dosage.    This number can be found on most medication containers, or inside your local 
phone directory.

¨ Over time your body may build up a drug tolerance, reducing the drug´s effect.    The dosage of 
prescribed drugs should be increased only with a physician´s supervision.

¨ Prevent an accident by never taking medication in the dark.    Know what you´re taking!

¨ Refill your prescription before the current supply is used up.

¨ Keep all drugs, including seemingly harmless medications, locked away out of the reach of 
children to prevent accidental overdose or poisoning.

¨ Store all medications away from heat, cold or sun.    Exposure to these elements can cause a 
drug to lose its potency.

¨ Know the appearance of your drugs, and check that refills are identical.    Many drugs can be 
compared with their picture, accessible from the drug information.

¨ Discard all drugs that have passed their expiration date, as well as any drugs that may be 
discolored or deteriorated.

¨ Do not mix drugs in the same container for an extended period. The drugs may interact with each 
other, lessening their medicinal effect.

¨ The Food and Drug Administration, or FDA, enforces the safety of all prescription and non-
prescription drugs in the United States. The manufacturers of drugs must test all drugs and report 
to the FDA to get marketing approval.

¨ Save money!    Shop around to get the best price for your medication.    Ask your doctor or 
pharmacist if a generic form of your drug is available, which will generally be less expensive.

¨ A drug must be taken as directed to have maximum benefit.    Two out of five people for whom a 
drug is prescribed do not take it properly.

¨ Ask your physician or pharmacist about possible reactions to your drug and what you should do if 
they occur.    Also be aware of any foods or other drugs you should avoid during treatment.

¨ It is a good idea to order all your prescription drugs from the same pharmacy. Your drug profile 
can call attention to possible interactions.

¨ Be sure you understand your prescription before leaving the physician´s office. Your pharmacist is 
also a good source of information about drug actions, interactions, and adverse effects for both 
prescription and over the counter drugs.

¨ Take a drug for the entire time prescribed by your physician.    Stopping drug treatment before the 
course is complete can cause harmful effects or a recurrence of the original condition.

¨ Know exactly when to take your medication.    Does three times a day mean three times during 
waking hours, or every 8 hours? Try to take your dose at the recommended intervals; taking them 
too close together increases the risk of side effects.

¨ A drink of cold water taken immediately after an unpleasantly-flavored medication will often hide 
the taste.

¨ Check out the features new to Medical Drug Reference 3.0!    What´s New is available from the 
Tip of the Day dialog or the Help index.

¨ Shake the bottle before measuring each dose of liquid medication, or you may give yourself an 
improper dosage.    The active substance may have risen to the top or settled at the bottom of the 
bottle.



¨ Save time by making certain that your prescription is filled out entirely before leaving the 
physician´s office.    Check that the patient´s name and address, drug name and instructions, and 
physician´s signature are completed.

¨ If you take several different medications, it is useful to make a chart to remind yourself of when 
each should be taken.    This will also help anyone who looks after you, or a new physician 
unfamiliar with your drug treatment.

¨ When in the drug list, typing a single letter will move the highlight to the next listing beginning with 
that letter.

¨ Don´t take any prescribed or over the counter drugs without first consulting your physician if you 
are pregnant or trying to conceive.

¨ Don´t take medication that has been prescribed for someone else, even if your symptoms are the 
same.    Drugs affect each individual differently.

¨ Taking alcohol with drugs can cause adverse reactions by enhancing the drug´s action, or 
lessening it´s effect by increasing your body´s elimination of the drug.

¨ Keeping medication in its original container protects it from light, which could lessen the drug´s 
effect, and prevents your confusing it with another medication.

¨ Always measure your dose carefully using an accurate measure such as a dropper or children´s 
medication spoon or a 5 ml spoon when a teaspoon is specified.

¨ When measuring liquid medication, keep in mind that one measuring teaspoon is equal to 5ml or 
5cc.    For more measurement conversions, see the conversion table in the Medical Drug 
Reference Help.

¨ Tell your physician about any medications you are taking, both prescription and over the counter, 
as well as any allergic reactions you have experienced with past drug treatments.

¨ Locate a drug quickly using Locate Drug on the drug list windows. Enter the whole or partial drug 
name to move the highlight to that drug. The Toggle Locator button allows you to look in the drug 
name or class levels.

¨ Do you know exactly what your prescription says? Prescription Terms and Abbreviations, found in 
the Medical Drug Reference Help, defines commonly used symbols and abbreviations found on 
your prescription.

¨ The most frequently prescribed drug is Amoxicillin, a Penicillin or antibiotic used to treat a wide 
variety of bacterial infections.

¨ The Minimum/Maximum Adult Daily Dose included in the drug information for many medications 
is based on a 70kg (154 lb.) male with normal liver and kidney function.

¨ To help ease the difficulty swallowing large tablets or capsules, make sure the patient is sitting 
upright with a full glass of water. Or try crushing the tablet and mixing it with food. A liquid form of 
your medication may also be available.

¨ Discuss with your doctor the forms your medication is available in, and which is best for you.    
Many forms are manufactured for different tolerance and sensitivity levels.

¨ Technique is important in administering medications, for example, inhalers. Be sure you know the 
correct method or ask for a different form.

¨ Generally, a missed dose should be taken as soon as remembered.    Check the Missed Dose 
section of the drug information for your medication.

¨ You may be prescribed a drug for a reason not listed in the Uses section of the drug information. 
Talk with your doctor or pharmacist if you question why you are taking a particular medication.

¨ The amount of possible side effects for any drug may be alarming. The Side Effects section in the 
drug information lists adverse reactions that may have occurred even in only one person. The 



possible benefits received by taking a drug usually far outweigh the risks.

¨ The prescribed dosage may have been modified for your particular condition, because of some 
other complicating medical conditions or more current recommendations. Ask your doctor or 
pharmacist if you have questions about your prescribed dosage.

¨ Childproof caps greatly reduce the number of accidental poisonings.    However, if they are hard 
to open and there are no children in your home, request an easy-open cap from your pharmacist.

¨ Before surgery or emergency treatment, tell your physician or dentist of any medications you are 
taking.

¨ When pouring liquid medication from a bottle, hold the label against the palm of your hand to 
prevent dripping medicine from staining the label.

¨ Before replacing the cap on a bottle of liquid medicine, wipe the top and neck of the bottle to 
prevent the cap from sticking.

¨ Replace the lid of an open medication container before opening a second one to avoid confusing 
the lids and the medications.

¨ A bottle with a medicine dropper may not be completely full. A small amount of air in the bottle    
provides proper control of the dropper.

¨ When applying topical ointment or cream, a thin layer is equally effective as a thick layer and is 
less expensive.

¨ Children should be taught to never take medication unless given to them by an adult.

¨ If you are traveling, remember to carry at least 3 days worth of medication with you.    It is a good 
idea to pack enough medicine to cover the entire trip, plus extra in case of loss.

¨ Never refer to medicine as "candy".    A child may be poisoned by taking an overdose of 
medication.

¨ Start eating and living healthier with Parsons Technology’s Diet Analyst. Monitor your nutrient 
intake and exercise, choosing from thousands of food and recipe items. Add Personal Chef for 
even more nutrition analysis. Call 1-800-223-6925 for more information, or visit the Parsons 
Clubhouse, our World Wide Web site, at http://www.parsonstech.com.

¨ Personal Chef’s database of hundreds of recipes can be analyzed for nutritional information. 
Adjust recipes for any number of servings or add your own. Additional recipe collections are 
available. Call 1-800-223-6925 for more information, or visit the Parsons Clubhouse, our World 
Wide Web site, at http://www.parsonstech.com. 

¨ The Family Guide to Home Remedies offers solutions for coping with or treating day-to-day 
health concerns. Leading healthcare professionals offer practical, at-home advice for over a 
hundred common ailments. Call 1-800-223-6925 for more information, or visit the Parsons 
Clubhouse, our World Wide Web site at http://www.parsonstech.com.

¨ Keep your Medical Drug Reference database current. Drug Updates are released regularly, 
adding new drug information and updating your current database of drugs. Call 1-800-223-6925 
for more information, or visit the Parsons Clubhouse, our World Wide Web site at 
http://www.parsonstech.com.

 




