
About MIDI Studio Professional Quick Reference

MIDI Studio Professional Quick Reference provides quick help on every command in the program.



Main Menu > About the Main Menu

All main menu commands are global and can be found in the main menu.

The corresponding key commands are shown behind the menu entries (e.g., <<Ctrl+1>> for <<Open 
Arrange>>). For some functions, it is also possible to create additional user-defined key commands.



Main Menu > File > New

Creates a new song.

Key Command:
New
(Global Commands)
Global Key Command: Ctrl+N



Main Menu > File > Open...

Use the Open dialog to load a song file.

Key Command:
Open...
(Global Commands)
Global Key Command: Ctrl+O



Main Menu > File > Close Song

Closes the active song file. If recent editing has not been stored Logic displays a warning.

Key Command:
Close Song
(Global Commands)



Main Menu > File > Save

Use the Save dialog to store a song.

Key Command:
Save
(Global Commands)
Global Key Command: Ctrl+S



Main Menu > File > Save as...

Allows to store the active song file under a new name.

Key Command:
Save Song as...
(Global Commands)
Global Key Command: Ctrl+M



Main Menu > File > Revert to Saved

Replaces the active song file with the previously saved version. All editing carried out since the last 
storage is lost.

Key Command:
Revert to Saved
(Global Commands)



Main Menu > File > Page Setup...

Use the Page Setup command to set up the paper format.

Key Command:
Page Setup...
(Global Commands)



Main Menu > File > Print

Use the Print... command to start printing the current score.

Key Command:
Print
(Global Commands)
Global Key Command: Ctrl+P



Main Menu > File > Import...

Use the Import... dialog to import song files in different formats, e.g. MIDI files.

Key Command:
Import...
(Global Commands)



Main Menu > File > Export Selection as MIDI File...

Allows export of the selected sequences as a MIDI file. Make sure you normalize, and copy any loops out 
the right number of times first, as well as doing any other preparatory work.

Key Command:
Export Selection as MIDI File...
(Global Commands)



Main Menu > File > Quit

Quits Logic. If recent editing has not been stored, Logic displays a warning.

Key Command:
Quit
(Global Commands)
Global Key Command: Ctrl+Q



Main Menu > Edit > Undo

Cancels the last editing of a song file.

Key Command:
Undo
(Global Commands)
Global Key Command: Ctrl+Z



Main Menu > Edit > Cut

Deletes the selected portion of data and copies it to the clipboard.

Key Command:
Cut
(Global Commands)
Global Key Command: Ctrl+X



Main Menu > Edit > Copy

Copies a selected portion of data to the clipboard.

Key Command:
Copy
(Global Commands)
Global Key Command: Ctrl+C



Main Menu > Edit > Paste

Inserts the contents of the clipboard.

Key Command:
Paste
(Global Commands)
Global Key Command: Ctrl+V



Main Menu > Edit > Clear

Deletes a selected portion of data.

Key Command:
Clear
(Global Commands)
Global Key Command: Rück



Main Menu > Audio > Audio-Studio...

Starts the 'Audio-Studio' application.



Main Menu > Audio > Sample Editor...

Opens a new Sample Editor window.

Key Command:
Open Sample Editor...
(Global Commands)
Global Key Command: Ctrl+0



Main Menu > Audio > Audio Window...

Opens a new Audio window.

Key Command:
Open Audio Window...
(Global Commands)
Global Key Command: Ctrl+9



Main Menu > Audio > Audio Preferences...

Opens the Audio Preferences page of the Preferences window. 



Main Menu > Audio > Audio Hardware & Drivers...

Opens the Audio Hardware & Drivers page of the Preferences window.



Main Menu > Audio > System Performance...

Opens a window displaying the current system performance.

Key Command:
Open System Performance...
(Global Commands)



Main Menu > Options > Settings > Synchronisation Settings...

Opens a window with all parameters necessary for synchronization.

Key Command:
Open Synchronisation Window...
(Global Commands)



Main Menu > Options > Settings > Metronom Settings...

Opens an Environment window in the layer with the object "MIDI Metronome Click".



Main Menu > Options > Settings > Recording Options...

Opens the Recording Options page of the Song Settings window.

Key Command:
Recording options...
(Global Commands)
Global Key Command: Ctrl+T



Main Menu > Options > Settings > MIDI Options...

Opens the MIDI Options page of the Song Settings window.



Main Menu > Options > Settings > Chase Events...

Opens the Chase Events page of the Song Settings window.



Main Menu > Options > Settings > Global Preferences...

Opens the Global Preferences page of the Preferences window. 



Main Menu > Options > Settings > Display Preferences...

Opens the Display Preferences page of the Preferences window. 



Main Menu > Options > Settings > Score Preferences...

Opens the Score Preferences page of the Preferences window. 



Main Menu > Options > Settings > Reset Preferences...

Opens the Reset Preferences page of the Preferences window. 



Main Menu > Options > Settings > Key Commands...

Opens the Key Commands window. It is possible to assign a certain keyboard shortcut, and a MIDI 
command to each of the functions listed here.



Main Menu > Options > Marker > Create

Creates a marker at the current position.



Main Menu > Options > Marker > Delete

Deletes a marker.



Main Menu > Options > Marker > Goto Next

Moves the song position line to the position of the next marker.



Main Menu > Options > Marker > Goto Previous

Moves the song position line to the position of the previous marker.



Main Menu > Options > Marker > Goto Marker Number...

Use the following dialog to enter the marker number Logic shall move to.



Main Menu > Options > Marker > Edit Marker

Opens a window to allow editing of the marker text.



Main Menu > Options > Tempo > Adjust Tempo using object length & Locators

Adjusts the tempo according to object length. Use the locators to determine the number of bars intended 
to correspond to the length of the selected objects. This function is implemented to calculate the 
corresponding tempo automatically.

Key Command:
Adjust Tempo using object length and Locators
(Arrange Window)



Main Menu > Options > Tempo > Tempo List Editor...

Displays a list of tempo changes similar to the event list.

Key Command:
Open Tempo List...
(Global Commands)



Main Menu > Options > Tempo > Tempo Graphic Editor...

Use this function to edit the tempo graphically.



Main Menu > Options > Event Float...

Displays the data of the selected events in a small floating window.



Main Menu > Options > Video Player...

Use the Video Player dialog to choose a movie file to run in a separate window locked to the sequencer. 

Key Command:
Open Movie...
(Global Commands)



Main Menu > Options > Video Player as Float...

Use the Video Player dialog to choose a movie file to run in a separate window locked to the sequencer. 
The movie will be displayed in a floating window afterwards.



Main Menu > Options > Video Settings...

Opens a dialog where you can change various video settings.



Main Menu > Options > Groove Templates > Make Groove Template

Enters the selected sequence as quantization template to make its grid accessible in Quantize menu.

Key Command:
Make Groove Template
(Arrange Window)



Main Menu > Options > Groove Templates > Remove Groove Template from List

Removes the selected sequence from quantization template list. Its grid will not be availible in Quantize 
menu any more.

Key Command:
Remove Groove Template from list
(Arrange Window)



Main Menu > Options > Send to MIDI > Maximum Volume

Sets the MIDI volume of the attached devices to maximum.

Key Command:
Send Maximum Volume
(Global Commands)



Main Menu > Options > Send to MIDI > Reset Controllers

Logic sends controller messages to the attached devices in order to reset them to a default value (e.g. 
volume to 127, panorama to 64, etc.).

Key Command:
Send Reset Controllers
(Global Commands)



Main Menu > Options > Send to MIDI > Send Used Instruments MIDI Settings

Instrument settings are automatically transmitted after the Song is loaded.

Key Command:
Send Used Instruments MIDI Settings
(Global Commands)



Main Menu > Windows > Screensets > Lock Screenset

Locks the currently acive screenset.

Key Command:
øLock/Unlock Current Screenset
(Global Commands)
Global Key Command: Alt+L



Main Menu > Windows > Screensets > Copy Screenset

Copies the active screenset to the clipboard.

Key Command:
Copy Screenset
(Global Commands)



Main Menu > Windows > Screensets > Paste Screenset

Pastes a screenset from the clipboard to the active screenset.

Key Command:
Paste Screenset
(Global Commands)



Main Menu > Windows > Open Arrange

Opens a new Arrange window.

Key Command:
Open Arrange Window...
(Global Commands)
Global Key Command: Ctrl+1



Main Menu > Windows > Open Track Mixer

Opens an Adaptive Mixer window.

Key Command:
Open Track Mixer...
(Global Commands)



Main Menu > Windows > Open Event List

Opens a new Event Editor window.

Key Command:
Open Event Editor...
(Global Commands)
Global Key Command: Ctrl+2



Main Menu > Windows > Open Score

Opens a new Score window.

Key Command:
Open Score Editor...
(Global Commands)
Global Key Command: Ctrl+3



Main Menu > Windows > Open Drum Edit

Opens a new Drum Editor window.

Key Command:
Open Hyper Editor...
(Global Commands)
Global Key Command: Ctrl+5



Main Menu > Windows > Open Transform

Opens a new Transform window.

Key Command:
Open Transform
(Global Commands)
Global Key Command: Ctrl+4



Main Menu > Windows > Open Matrix Edit

Opens a new Matrix Editor window.

Key Command:
Open Matrix Editor...
(Global Commands)
Global Key Command: Ctrl+6



Main Menu > Windows > Open Environment

Opens a new Environment window.

Key Command:
Open Environment...
(Global Commands)
Global Key Command: Ctrl+8



Main Menu > Windows > Open Transport

Opens a new Transport window.

Key Command:
Open Transport...
(Global Commands)
Global Key Command: Ctrl+7



Main Menu > Windows > Larger View

Increases the size of display of the active window.

Key Command:
Larger View
(Global Commands)
Global Key Command: Ctrl+Num-+



Main Menu > Windows > Smaller View

Decreases the size of display of the active window.

Key Command:
Smaller View
(Global Commands)
Global Key Command: Ctrl++Num--



Main Menu > Windows > Next Window

Activates the next window.



Main Menu > Windows > Zoom Window

Adjusts the size of the active window to fit its content.

Key Command:
Zoom Window
(Global Commands)
Global Key Command: Ctrl+#



Main Menu > Windows > Close Window

Closes the active window.

Key Command:
Close Window
(Global Commands)



Main Menu > Windows > Tile Windows

Arranges all open windows on the screen and adjusts their size to make them all visible.

Key Command:
Tile Windows
(Global Commands)



Main Menu > Windows > Tile Windows horizontally

Arranges all open windows horizontally on the screen and adjusts their size to make them all visible.

Key Command:
Tile Windows horizontally
(Global Commands)



Main Menu > Windows > Stack Windows

Stacks all open windows.

Key Command:
Stack Windows
(Global Commands)



Main Menu > Help > Help...

Opens this help.
Global Key Command: F1



Main Menu > Help > Search Help...

Allows the search for term in the help file.



Main Menu > Help > How to use Help

Tips on ho to use help.



Main Menu > Help > About MIDI Studio Professional...

Displays information about MIDI Studio Professional.



Arrange > About the Arrange Window

All Arrange commands can be found in the menu when an Arrange window is active.



Arrange > Edit > Undo

Cancels the last editing of a song file.

Key Command:
Undo
(Global Commands)
Global Key Command: Ctrl+Z



Arrange > Edit > Cut

Deletes the selected portion of data and copies it to the clipboard.

Key Command:
Cut
(Global Commands)
Global Key Command: Ctrl+X



Arrange > Edit > Copy

Copies a selected portion of data to the clipboard.

Key Command:
Copy
(Global Commands)
Global Key Command: Ctrl+C



Arrange > Edit > Paste

Inserts the contents of the clipboard.

Key Command:
Paste
(Global Commands)
Global Key Command: Ctrl+V



Arrange > Edit > Paste at original Position

Inserts objects from clipboard at their original position.



Arrange > Edit > Clear

Deletes a selected portion of data.

Key Command:
Clear
(Global Commands)
Global Key Command: Rück



Arrange > Edit > Select > Select All

Selects all objects in the active window.

Key Command:
Select All
(Global Commands)
Global Key Command: Ctrl+A



Arrange > Edit > Select > Select All Following

Selects all following objects in the active window.

Key Command:
Select All Following
(Arrange and Various Sequence Editors)
Global Key Command: Alt+F



Arrange > Edit > Select > Select Inside Locators

Selects all objects within the locators in the active window.

Key Command:
Select inside Locators
(Arrange and Various Sequence Editors)
Global Key Command: Alt+I



Arrange > Edit > Select > Toggle Selection

Reverses the current selection in the active window. Selects all objects that are not selected, and vice 
versa.

Key Command:
Toggle Selection
(Arrange and Various Sequence Editors)
Global Key Command: Alt+T



Arrange > Edit > Select > Select Empty Objects

Selects all empty objects in the active window.



Arrange > Edit > Select > Select Overlapped Objects

Selects all overlapping objects in the active window.



Arrange > Edit > Select > Select Muted Objects

Selects all muted objects in the active window.



Arrange > Edit > Select > Select Equal Colored Objects

Selects all identically colored objects in the active window.



Arrange > Edit > Select > Select Similar Objects

Selects all objects in the active window similar to the currently selected data. Use this function to select 
for instance all 'A' notes without referring to a certain octave.



Arrange > Edit > Select > Select Equal Objects

Selects all objects in the active window corresponding to the currently selected data. Use this function to 
select for instance all controllers 10 with the value 80.



Arrange > Edit > Select > Select Equal Channels

Selects all objects in the active window with the same MIDI channel as the currently selected data. 



Arrange > Edit > Select > Select Equal Subpositions

Selects all objects in the active window with the same bar position as the currently selected data. 



Arrange > Functions > Track > Create

Creates a new track.

Key Command:
Create Track
(Arrange Window)



Arrange > Functions > Track > Delete

Deletes the active track. If the track contains any data Logic displays a warning.

Key Command:
Delete Track
(Arrange Window)



Arrange > Functions > Track > Delete unused

Deletes all tracks not in use, i.e. tracks which do not contain any sequences, folders, or regions.

Key Command:
Delete unused Tracks
(Arrange Window)



Arrange > Functions > Track > Delete redundant audio tracks

When loading a song containing audio from versions before 3.5 it is possible that this song now has audio 
tracks not needed any more. This command checks on that and deletes any audio track that is not 
necessary any more.



Arrange > Functions > Track > Create Trackname

Creates a track name not mapped to an instrument for the active track.

Key Command:
Create Trackname
(Arrange Window)



Arrange > Functions > Track > Delete Trackname

Deletes a track name not mapped to an instrument from the active track.

Key Command:
Delete Trackname
(Arrange Window)



Arrange > Functions > Track > Create New Instrument

Creates a new instrument for the active track in the Environment window.



Arrange > Functions > Track > Open SoundDiver for Instrument

If SoundDiver has been started Logic uses this editor to select the active instrument.

Key Command:
Open SoundDiver for Instrument
(Arrange Window)



Arrange > Functions > Folder > Pack Folder

Packs the selected portions of data into a folder. Afterwards, the Arrange window displays a folder 
containing the selected objects.

Key Command:
Pack Folder
(Arrange Window)
Global Key Command: Ctrl+P



Arrange > Functions > Folder > Unpack Folder (Create new tracks)

Unpacks the selected folder. Its content will be moved to the next higher level, the folder deleted. New 
tracks will be created.

Key Command:
Unpack Folder
(Arrange Window)
Global Key Command: Ctrl+Alt+P



Arrange > Functions > Object > Repeat Objects

Use the Repeat Objects... dialog to repeat one or more selected objects.

Key Command:
Repeat Objects...
(Arrange and Various Sequence Editors)



Arrange > Functions > Object > Move Selected Objects to current track

Moves the selected objects to the active track.

Key Command:
Move Selected Objects to track
(Arrange Window)



Arrange > Functions > Object > Set Locators by Objects

Sets locators at start and end of currently selected objects.

Key Command:
Set Locators by Objects
(Global Commands)
Global Key Command: Shift+O



Arrange > Functions > Object > Set Optimal Object Sizes

Adjusts start and end of a sequence or folder to fit the size of its content.



Arrange > Functions > Object > Snap Objects

Moves the beginning of the selected objects to the first beat of the next bar.



Arrange > Functions > Object > Remove Overlaps

Alters the length of any selected objects which overlap, so that the overlaps are removed.



Arrange > Functions > Object > Tie Objects by Length Change

Ties the selected sequences together by changing their length.



Arrange > Functions > Sequence Parameter > Normalize Sequence Parameters

Writes the sequence parameters of the selected sequences to their data.

Key Command:
Normalize
(Arrange Window)
Global Key Command: Shift+N



Arrange > Functions > Sequence Parameter > Turn Loops to Real Copies

Turns loops into real data containing copies. 

Key Command:
Turn Loops to Real Copies
(Arrange Window)
Global Key Command: Alt+Shift+C



Arrange > Functions > Demix > Demix by Event Channel

Splits the selected sequences according to the MIDI channels of the events. Thus, type 0 MIDI files (all 
data in one sequence) can be split to assign each instrument to an individual track.



Arrange > Functions > Demix > Demix by Note Pitch

Splits the selected sequences according to pitch.Thus, chords can be split to create an individual track for 
each voice.



Arrange > Audio > Regions to original Record Position

Resets the selected audio regions to the original recording position.

Key Command:
Set Region(s) to Recording Position
(Arrange Window)



Arrange > Audio > Digital Mixdown

Use this function to merge various selected sequences to create a single new one.
If several audio regions are selected use this command to make a digital mixdown. The result will be a 
new audio file with the same settings for volume, panorama, and crossfade.
Global Key Command: Shift+M



Arrange > Audio > Default Audio Crossfade Options...

Use this dialog to set a crossfade time and curve when crossfading audio regions during digital mixdown.



Arrange > Audio > Search Zero Crossings

Activate this function to search zero crossings for cutting the material there. This may lead to a slight 
deviation from the intended cut but avoids the formation of clicks.



Arrange > View > Hyper Draw > off

Switches off Hyper Draw in selected sequences.

Key Command:
Hyper Draw: Disable
(Arrange Window)



Arrange > View > Hyper Draw > Channel

Choose the MIDI channel for display and editing in Hyper Draw.



Arrange > View > Hyper Draw > Volume

Displays the selected sequences with Hyper Draw for volume (controller 07).

Key Command:
Hyper Draw: Volume
(Arrange Window)



Arrange > View > Hyper Draw > Pan

Displays the selected sequences with Hyper Draw for panorama (controller 10).

Key Command:
Hyper Draw: Pan
(Arrange Window)



Arrange > View > Transport

Shows or hides transport functions in the active window.



Arrange > View > Parameters

Shows or hides parameters in the active window.

Key Command:
Hide/Show Parameters
(Various Windows)
Global Key Command: Ctrl+H



Arrange > View > Toolbox

Shows or hides the toolbox in the active window.



Arrange > View > Delay in ms

Switches display of delay time between ms and ticks.



Arrange > View > Grid

Shows or hides the grid in the active window.



Arrange > View > White Background

Switches background color (white) on or off.



Arrange > View > Object Content

Shows or hides schematic display of object contents.



Arrange > View > Track numbers/Level meters

Shows or hides display of track numbers and level meters.



Arrange > View > Mute Switch

Shows or hides switches to mute tracks.



Arrange > View > Record Switch

Shows or hides switches to arm tracks for recording.



Arrange > View > Instrument Icon

Shows or hides instrument symbols.



Arrange > View > Instrument Name

Shows or hides instrument names.



Arrange > View > Track Name

Shows or hides track names.



Arrange > View > Scroll To Selection

Scrolls to the current selection by moving the content of the active window.

Key Command:
Scroll To Selection
(Arrange and Various Sequence Editors)



Arrange > View > Instrument Colors To Objects

Replaces the colors of selected objects with the colors of the corresponding instruments.



Arrange > View > Tracknames To Objects

Names selected objects after track names.



Arrange > View > Object Colors...

Opens color palette to assign colors to sequences, instruments, selections, etc.

Key Command:
Open Object Colors...
(Global Commands)



Track Mixer > About the Trackmixer

All Track Mixer commands can be found in the menu when a Track Mixer window is active.



Track Mixer > Tracks > MIDI Tracks

Activates the display of mixer objects for MIDI Tracks in the current track mixer.



Track Mixer > Tracks > Audio Tracks

Activates the display of mixer objects for Audio Tracks in the current track mixer.



Track Mixer > Tracks > Folder Tracks

Activates the display of mixer objects for Folder Tracks in the current track mixer.



Track Mixer > Tracks > Other Tracks

Activates the display of mixer objects for any other tracks in the current track mixer.



Track Mixer > Tracks > Add Bus Return(s)

Adds mixer objects for audio bus returns.



Track Mixer > Tracks > Add Master(s)

Adds mixer objects for audio masters.



Track Mixer > Tracks > Add GS/XG Effects

Adds objects to edit the GS/XG effects of an instrument.



Track Mixer > View > Legend

Displays a legend showing the names of the assignable controllers.



Track Mixer > View > Instrument Name

Shows or hides instrument names.



Track Mixer > View > Program

Displays the names of the instrument's programs in the mixer object.



Track Mixer > View > Bank

Displays the number of the instrument's banks in the mixer object.



Track Mixer > View > Assign 1

Displays knobs for the first assignable MIDI controller in all MIDI instrument track mixer objects.



Track Mixer > View > Assign 2

Displays knobs for the second assignable MIDI controller in all MIDI instrument track mixer objects.



Track Mixer > View > Assign 3

Displays knobs for the third assignable MIDI controller in all MIDI instrument track mixer objects.



Track Mixer > View > Assign 4

Displays knobs for the fourth assignable MIDI controller in all MIDI instrument track mixer objects.



Track Mixer > View > Assign 5

Displays knobs for the fifth assignable MIDI controller in all MIDI instrument track mixer objects.



Track Mixer > View > Pan

Displays knobs for pan in all valid track mixer objects.



Track Mixer > View > Volume

Displays volume faders in all valid track mixer objects.



Track Mixer > View > Track Name

Shows or hides track names.



Track Mixer > View > Track Number

Switches the display of the track number in all mixer objects on or off.



Track Mixer > Options > Send All Mixer Data

Forces logic to send all values of the current mixer settings.



Track Mixer > Options > Change Track in Record Mode

When selecting a mixer object in record mode the according track is selected in arrange.



Track Mixer > Options > Change Track in Play Mode

When selecting a mixer object in play mode the according track is selected in arrange.



Event List > About the Event List

All Event List commands can be found in local menues in the Event List window.



Event List > Edit > Undo

Cancels the last editing of a song file.

Key Command:
Undo
(Global Commands)
Global Key Command: Ctrl+Z



Event List > Edit > Cut

Deletes the selected portion of data and copies it to the clipboard.

Key Command:
Cut
(Global Commands)
Global Key Command: Ctrl+X



Event List > Edit > Copy

Copies a selected portion of data to the clipboard.

Key Command:
Copy
(Global Commands)
Global Key Command: Ctrl+C



Event List > Edit > Paste

Inserts the contents of the clipboard.

Key Command:
Paste
(Global Commands)
Global Key Command: Ctrl+V



Event List > Edit > Paste at original Position

Inserts objects from clipboard at their original position.



Event List > Edit > Clear

Deletes a selected portion of data.

Key Command:
Clear
(Global Commands)
Global Key Command: Rück



Event List > Edit > Select > Select All

Selects all objects in the active window.

Key Command:
Select All
(Global Commands)
Global Key Command: Ctrl+A



Event List > Edit > Select > Select All Following

Selects all following objects in the active window.

Key Command:
Select All Following
(Arrange and Various Sequence Editors)
Global Key Command: Alt+F



Event List > Edit > Select > Select Inside Locators

Selects all objects within the locators in the active window.

Key Command:
Select inside Locators
(Arrange and Various Sequence Editors)
Global Key Command: Alt+I



Event List > Edit > Select > Toggle Selection

Reverses the current selection in the active window. Selects all objects that are not selected, and vice 
versa.

Key Command:
Toggle Selection
(Arrange and Various Sequence Editors)
Global Key Command: Alt+T



Event List > Edit > Select > Select Empty Objects

Selects all empty objects in the active window.



Event List > Edit > Select > Select Overlapped Objects

Selects all overlapping objects in the active window.



Event List > Edit > Select > Select Muted Objects

Selects all muted objects in the active window.



Event List > Edit > Select > Select Equal Colored Objects

Selects all identically colored objects in the active window.



Event List > Edit > Select > Select Similar Objects

Selects all objects in the active window similar to the currently selected data. Use this function to select 
for instance all 'A' notes without referring to a certain octave.



Event List > Edit > Select > Select Equal Objects

Selects all objects in the active window corresponding to the currently selected data. Use this function to 
select for instance all controllers 10 with the value 80.



Event List > Edit > Select > Select Equal Channels

Selects all objects in the active window with the same MIDI channel as the currently selected data. 



Event List > Edit > Select > Select Equal Subpositions

Selects all objects in the active window with the same bar position as the currently selected data. 



Event List > Functions > Set Locators by Objects

Sets locators at start and end of currently selected objects.

Key Command:
Set Locators by Objects
(Global Commands)
Global Key Command: Shift+O



Event List > Functions > Quantize again

Quantizes the selected objects in the active window once more.



Event List > Functions > De-Quantize

De-quantizes the selected objects in the active window.



Event List > View > Length as absolute Position

Displays the absolute position of the end of a note instead of the note length.
(Beginning + note length = end of note)

Key Command:
Length as Absolute Position
(Event Window)
Global Key Command: Ctrl+P



Event List > View > Local Position

Displays the positions in relation to the beginning of    the sequence. Usually, the display refers to the 
whole song.

Key Command:
Local Position
(Event Window)



Event List > View > Parameters

Shows or hides parameters in the active window.

Key Command:
Hide/Show Parameters
(Various Windows)
Global Key Command: Ctrl+H



Event List > View > SysEx in Hex Format

Displays System Exclusive Data (SysEx) in decimal or hexadecimal numbers. In many cases, 
manufacturers choose the hexadecimal form.



Event List > View > Scroll To Selection

Scrolls to the current selection by moving the content of the active window.

Key Command:
Scroll To Selection
(Arrange and Various Sequence Editors)



Score > About the Score Editor

All Score Editor commands can be found in local menues in the Score Editor window.



Score > Edit > Undo

Cancels the last editing of a song file.

Key Command:
Undo
(Global Commands)
Global Key Command: Ctrl+Z



Score > Edit > Cut

Deletes the selected portion of data and copies it to the clipboard.

Key Command:
Cut
(Global Commands)
Global Key Command: Ctrl+X



Score > Edit > Copy

Copies a selected portion of data to the clipboard.

Key Command:
Copy
(Global Commands)
Global Key Command: Ctrl+C



Score > Edit > Paste

Inserts the contents of the clipboard.

Key Command:
Paste
(Global Commands)
Global Key Command: Ctrl+V



Score > Edit > Clear

Deletes a selected portion of data.

Key Command:
Clear
(Global Commands)
Global Key Command: Rück



Score > Edit > Repeat Objects

Use the Repeat Objects... dialog to repeat one or more selected objects.

Key Command:
Repeat Objects...
(Arrange and Various Sequence Editors)



Score > Edit > Select All

Selects all objects in the active window.

Key Command:
Select All
(Global Commands)
Global Key Command: Ctrl+A



Score > Edit > Select All Following

Selects all following objects in the active window.

Key Command:
Select All Following
(Arrange and Various Sequence Editors)
Global Key Command: Alt+F



Score > Edit > Select Inside Locators

Selects all objects within the locators in the active window.

Key Command:
Select inside Locators
(Arrange and Various Sequence Editors)
Global Key Command: Alt+I



Score > Edit > Toggle Selection

Reverses the current selection in the active window. Selects all objects that are not selected, and vice 
versa.

Key Command:
Toggle Selection
(Arrange and Various Sequence Editors)
Global Key Command: Alt+T



Score > Edit > Select Similar Objects

Selects all objects in the active window similar to the currently selected data. Use this function to select 
for instance all 'A' notes without referring to a certain octave.



Score > Edit > Select Equal Objects

Selects all objects in the active window corresponding to the currently selected data. Use this function to 
select for instance all controllers 10 with the value 80.



Score > Functions > Set Locators by Objects

Sets locators at start and end of currently selected objects.

Key Command:
Set Locators by Objects
(Global Commands)
Global Key Command: Shift+R



Score > Functions > Quantize again

Quantizes the selected objects in the active window once more.



Score > Functions > De-Quantize

De-quantizes the selected objects in the active window.



Score > Attributes > Accidentals > Default Accidental

Resets the setting of selected notes as to enharmonic shifts to Logic's default values.

Key Command:
Default Accidental
(Score Window)
Global Key Command: Alt+A



Score > Attributes > Accidentals > Enharmonic Shift: #

Allows selected notes to be expressed as sharps (#) due to enharmonic shift. 

Key Command:
Enharmonic Shift: #
(Score Window)
Global Key Command: Shift+#



Score > Attributes > Accidentals > Enharmonic Shift: b

Allows selected notes to be expressed as flats (b) due to enharmonic shift. 

Key Command:
Enharmonic Shift: b
(Score Window)
Global Key Command: Shift+B



Score > Attributes > Stems > Default

Resets the setting of selected notes as to the direction of stems to Logic's default values.

Key Command:
Stems: default
(Score Window)
Global Key Command: Alt+S



Score > Attributes > Stems > Up

Displays selected notes with stems upwards.

Key Command:
Stems: up
(Score Window)
Global Key Command: Alt+U



Score > Attributes > Stems > Down

Displays selected notes with stems downwards.

Key Command:
Stems: down
(Score Window)
Global Key Command: Alt+D



Score > Attributes > Beaming > Default

Resets the setting of selected notes as to beaming to Logic's default values.

Key Command:
Default Beams
(Score Window)
Global Key Command: Alt+Shift+B



Score > Attributes > Beaming > Beam Selected

Forces the selected notes to be beamed as far as possible.

Key Command:
Beam Selected Notes
(Score Window)
Global Key Command: Alt+B



Score > Attributes > Beaming > Unbeam Selected

Removes the beams from selected notes.

Key Command:
Unbeam Selected Notes
(Score Window)
Global Key Command: Alt+V



Score > Attributes > Syncopation > Default

Uses Logic's default settings for selected dotted notes.

Key Command:
Default Syncopation
(Score Window)



Score > Attributes > Syncopation > Force

Expresses the selected dotted notes as syncopes.

Key Command:
Force      Syncopation
(Score Window)



Score > Attributes > Syncopation > Defeat

Supresses syncopes of selected notes and expresses them as dotted notes.

Key Command:
Defeat    Syncopation
(Score Window)



Score > Attributes > Interpretation > Default

Uses Logic's default settings as to interpretation of the selected notes.

Key Command:
Default Interpretation
(Score Window)



Score > Attributes > Interpretation > Force

Forces interpretation of selected notes.

Key Command:
Force      Interpretation
(Score Window)



Score > Attributes > Interpretation > Defeat

Suppresses interpretation of selected notes.

Key Command:
Defeat    Interpretation
(Score Window)



Score > Attributes > Reset All Attributes

Deletes all manually set attributes of the selected notes.



Score > View > Page Edit

Displays the active notation in page view mode.

Key Command:
Page Edit
(Score Window)
Global Key Command: Alt+P



Score > View > Explode Folders

Displays the sequences of the selected folders as independent sequences.

Key Command:
Explode Folders
(Score Window)



Score > View > Toolbox

Shows or hides the toolbox in the active window.



Score > View > Parameters

Shows or hides parameters in the active window.

Key Command:
Hide/Show Parameters
(Various Windows)
Global Key Command: Ctrl+H



Score > View > White Background

Switches background color (white) on or off.



Score > Options > Diatonic Insert

If this option is activated it is only possible to enter notes corresponding to the currently selected key.



Score > Options > Score Preferences...

Use this dialog to define global score preferences.



Score > Options > Score Font...

Opens a dialog in which the fonts of the score may be chosen.



Drum Edit > About the Drum Edit

All Drum Edit commands can be found in the menu when a Drum Edit window is active.



Drum Edit > Hyper > Create Hyper Set

Creates a new hyper set.



Drum Edit > Hyper > Create GM Drum Set

Vreates a new Hyper Set initialized for a GM Drum Set.



Drum Edit > Hyper > Clear Hyper Set

Deletes the active hyper set.



Drum Edit > Hyper > Create Event Definition

Creates a new event definition ("track") in the active hyper set.

Key Command:
Create Event Definition
(Hyper Edit)



Drum Edit > Hyper > Delete Event Definition

Deletes the selected event definition ("track") in the active hyper set.

Key Command:
Delete Event Definition
(Hyper Edit)



Drum Edit > Hyper > Multi Create Event Definition...

Use this dialog to create several new event definitions ("tracks") in the active hyper set.



Drum Edit > Hyper > Convert Event Definition...

Use this dialog to edit several event definitions ("tracks") in the active hyper set.



Drum Edit > Hyper > Copy Event Definition

Copies the selected event definition ("track") in the active hyper set.

Key Command:
Copy Event Definition
(Hyper Edit)



Drum Edit > Hyper > Paste Event Definition

Inserts a copied event definition ("track") into the active hyper set.

Key Command:
Paste Event Definition
(Hyper Edit)



Drum Edit > Hyper > Select All Event Definitions

Selects all event definitions ("tracks") in the active hyper set.

Key Command:
Select All Event Definitions
(Hyper Edit)



Drum Edit > Edit > Undo

Cancels the last editing of a song file.

Key Command:
Undo
(Global Commands)
Global Key Command: Ctrl+Z



Drum Edit > Edit > Cut

Deletes the selected portion of data and copies it to the clipboard.

Key Command:
Cut
(Global Commands)
Global Key Command: Ctrl+X



Drum Edit > Edit > Copy

Copies a selected portion of data to the clipboard.

Key Command:
Copy
(Global Commands)
Global Key Command: Ctrl+C



Drum Edit > Edit > Paste

Inserts the contents of the clipboard.

Key Command:
Paste
(Global Commands)
Global Key Command: Ctrl+V



Drum Edit > Edit > Paste at original Position

Inserts objects from clipboard at their original position.



Drum Edit > Edit > Clear

Deletes a selected portion of data.

Key Command:
Clear
(Global Commands)
Global Key Command: Rück



Drum Edit > Edit > Select > Select All

Selects all objects in the active window.

Key Command:
Select All
(Global Commands)
Global Key Command: Ctrl+A



Drum Edit > Edit > Select > Select All Following

Selects all following objects in the active window.

Key Command:
Select All Following
(Arrange and Various Sequence Editors)
Global Key Command: Alt+F



Drum Edit > Edit > Select > Select Inside Locators

Selects all objects within the locators in the active window.

Key Command:
Select inside Locators
(Arrange and Various Sequence Editors)
Global Key Command: Alt+I



Drum Edit > Edit > Select > Toggle Selection

Reverses the current selection in the active window. Selects all objects that are not selected, and vice 
versa.

Key Command:
Toggle Selection
(Arrange and Various Sequence Editors)
Global Key Command: Alt+T



Drum Edit > Edit > Select > Select Empty Objects

Selects all empty objects in the active window.



Drum Edit > Edit > Select > Select Overlapped Objects

Selects all overlapping objects in the active window.



Drum Edit > Edit > Select > Select Muted Objects

Selects all muted objects in the active window.



Drum Edit > Edit > Select > Select Equal Colored Objects

Selects all identically colored objects in the active window.



Drum Edit > Edit > Select > Select Similar Objects

Selects all objects in the active window similar to the currently selected data. Use this function to select 
for instance all 'A' notes without referring to a certain octave.



Drum Edit > Edit > Select > Select Equal Objects

Selects all objects in the active window corresponding to the currently selected data. Use this function to 
select for instance all controllers 10 with the value 80.



Drum Edit > Edit > Select > Select Equal Channels

Selects all objects in the active window with the same MIDI channel as the currently selected data. 



Drum Edit > Edit > Select > Select Equal Subpositions

Selects all objects in the active window with the same bar position as the currently selected data. 



Drum Edit > Functions > Set Locators by Objects

Sets locators at start and end of currently selected objects.

Key Command:
Set Locators by Objects
(Global Commands)
Global Key Command: Shift+O



Drum Edit > Functions > Quantize again

Quantizes the selected objects in the active window once more.



Drum Edit > Functions > De-Quantize

De-quantizes the selected objects in the active window.



Drum Edit > View > Transport

Shows or hides transport functions in the active window.



Drum Edit > View > Parameters

Shows or hides parameters in the active window.

Key Command:
Hide/Show Parameters
(Various Windows)
Global Key Command: Ctrl+H



Drum Edit > View > Scroll To Selection

Scrolls to the current selection by moving the content of the active window.

Key Command:
Scroll To Selection
(Arrange and Various Sequence Editors)



Drum Edit > View > Event Float...

Opens a small floating window containing the data of the selected event.



Matrix Edit > About the Matrix Edit

All Matrix Edit commands can be found in the menu when a Matrix Edit window is active.



Matrix Edit > Edit > Undo

Cancels the last editing of a song file.

Key Command:
Undo
(Global Commands)
Global Key Command: Ctrl+Z



Matrix Edit > Edit > Cut

Deletes the selected portion of data and copies it to the clipboard.

Key Command:
Cut
(Global Commands)
Global Key Command: Ctrl+X



Matrix Edit > Edit > Copy

Copies a selected portion of data to the clipboard.

Key Command:
Copy
(Global Commands)
Global Key Command: Ctrl+C



Matrix Edit > Edit > Paste

Inserts the contents of the clipboard.

Key Command:
Paste
(Global Commands)
Global Key Command: Ctrl+V



Matrix Edit > Edit > Paste at original Position

Inserts objects from clipboard at their original position.



Matrix Edit > Edit > Clear

Deletes a selected portion of data.

Key Command:
Clear
(Global Commands)
Global Key Command: Rück



Matrix Edit > Edit > Select > Select All

Selects all objects in the active window.

Key Command:
Select All
(Global Commands)
Global Key Command: Ctrl+A



Matrix Edit > Edit > Select > Select All Following

Selects all following objects in the active window.

Key Command:
Select All Following
(Arrange and Various Sequence Editors)
Global Key Command: Alt+F



Matrix Edit > Edit > Select > Select Inside Locators

Selects all objects within the locators in the active window.

Key Command:
Select inside Locators
(Arrange and Various Sequence Editors)
Global Key Command: Alt+I



Matrix Edit > Edit > Select > Toggle Selection

Reverses the current selection in the active window. Selects all objects that are not selected, and vice 
versa.

Key Command:
Toggle Selection
(Arrange and Various Sequence Editors)
Global Key Command: Alt+T



Matrix Edit > Edit > Select > Select Empty Objects

Selects all empty objects in the active window.



Matrix Edit > Edit > Select > Select Overlapped Objects

Selects all overlapping objects in the active window.



Matrix Edit > Edit > Select > Select Muted Objects

Selects all muted objects in the active window.



Matrix Edit > Edit > Select > Select Equal Colored Objects

Selects all identically colored objects in the active window.



Matrix Edit > Edit > Select > Select Similar Objects

Selects all objects in the active window similar to the currently selected data. Use this function to select 
for instance all 'A' notes without referring to a certain octave.



Matrix Edit > Edit > Select > Select Equal Objects

Selects all objects in the active window corresponding to the currently selected data. Use this function to 
select for instance all controllers 10 with the value 80.



Matrix Edit > Edit > Select > Select Equal Channels

Selects all objects in the active window with the same MIDI channel as the currently selected data. 



Matrix Edit > Edit > Select > Select Equal Subpositions

Selects all objects in the active window with the same bar position as the currently selected data. 



Matrix Edit > Functions > Set Locators by Objects

Sets locators at start and end of currently selected objects.

Key Command:
Set Locators by Objects
(Global Commands)
Global Key Command: Shift+O



Matrix Edit > Functions > Quantize again

Quantizes the selected objects in the active window once more.



Matrix Edit > Functions > De-Quantize

De-quantizes the selected objects in the active window.



Matrix Edit > View > Transport

Shows or hides transport functions in the active window.



Matrix Edit > View > Parameters

Shows or hides parameters in the active window.

Key Command:
Hide/Show Parameters
(Various Windows)
Global Key Command: Ctrl+H



Matrix Edit > View > White Background

Switches background color (white) on or off.



Matrix Edit > View > Scroll To Selection

Scrolls to the current selection by moving the content of the active window.

Key Command:
Scroll To Selection
(Arrange and Various Sequence Editors)



Matrix Edit > View > Event Float...

Opens a small floating window containing the data of the selected event.



Matrix Edit > View > Hyper Draw > off

Switches off Hyper Draw in selected sequences.

Key Command:
Hyper Draw: Disable
(Arrange Window)



Matrix Edit > View > Hyper Draw > Channel

Choose the MIDI channel for display and editing in Hyper Draw.



Matrix Edit > View > Hyper Draw > Volume

Displays the selected sequences with Hyper Draw for volume (controller 07).

Key Command:
Hyper Draw: Volume
(Arrange Window)



Matrix Edit > View > Hyper Draw > Pan

Displays the selected sequences with Hyper Draw for panorama (controller 10).

Key Command:
Hyper Draw: Pan
(Arrange Window)



Environment > About the Environment

All Environment commands can be found in the menu when a Environment window is active.



Environment > New > Instrument

Creates a new instrument in the current layer.



Environment > New > Multi Instrument

Creates a new multi instrument in the current layer.



Environment > New > Mapped Instrument

Creates a new mapped instrument in the current layer.



Environment > Edit > Undo

Cancels the last editing of a song file.

Key Command:
Undo
(Global Commands)
Global Key Command: Ctrl+Z



Environment > Edit > Cut

Deletes the selected portion of data and copies it to the clipboard.

Key Command:
Cut
(Global Commands)
Global Key Command: Ctrl+X



Environment > Edit > Copy

Copies a selected portion of data to the clipboard.

Key Command:
Copy
(Global Commands)
Global Key Command: Ctrl+C



Environment > Edit > Paste

Inserts the contents of the clipboard.

Key Command:
Paste
(Global Commands)
Global Key Command: Ctrl+V



Environment > Edit > Clear

Deletes a selected portion of data.

Key Command:
Clear
(Global Commands)
Global Key Command: Rück



Environment > Edit > Clear Cables only

Deletes only currently selected cables.

Key Command:
Clear Cables only
(Environment Window)
Global Key Command: Alt+Entf



Environment > Edit > Select All

Selects all objects in the active window.

Key Command:
Select All
(Global Commands)
Global Key Command: Ctrl+A



Environment > Edit > Toggle Selection

Reverses the current selection in the active window. Selects all objects that are not selected, and vice 
versa.

Key Command:
Toggle Selection
(Arrange and Various Sequence Editors)



Environment > Edit > Select Used Instruments

Selects all objects addressed by Arrange objects.



Environment > Edit > Select Unused Instruments

Selects all objects not addressed by Arrange objects.



Environment > Edit > Select Cable Destination

Selects all destination objects of a selected cable connection.

Key Command:
Select Cable Destination
(Environment Window)
Global Key Command: Ctrl+B



Environment > Edit > Select Cable Origin

Selects all objects leading to a selected source object.

Key Command:
Select Cable Origin
(Environment Window)



Environment > Edit > Select Similar Objects

Selects all objects in the active window similar to the currently selected data. Use this function to select 
for instance all 'A' notes without referring to a certain octave.



Environment > Edit > Select Equal Objects

Selects all objects in the active window corresponding to the currently selected data. Use this function to 
select for instance all controllers 10 with the value 80.



Environment > View > Protect Cabling/Positions

Protects object positions as well as cabling.

Key Command:
Protect Cabling/Positions
(Environment Window)



Environment > View > Snap Positions

Moves the selected objects to the next coordinate of the grid.



Environment > View > Cable(s)

Shows or hides display of cabling.

Key Command:
Hide/Show Cables
(Environment Window)



Environment > View > Parameters

Shows or hides parameters in the active window.

Key Command:
Hide/Show Parameters
(Various Windows)
Global Key Command: Ctrl+H



Environment > View > by Text

Allows to switch to list display in the active window.



Environment > View > Colored Cables

Use this function to display the cables in the same color as the object they come from.



Environment > View > Object Colors...

Opens color palette to assign colors to sequences, instruments, selections, etc.

Key Command:
Open Object Colors...
(Global Commands)



Environment > Options > goto previous Layer

Displays previous layer.

Key Command:
goto previous Layer
(Environment Window)



Environment > Options > goto Layer of Object

Switches from 'All Objects' layer to the layer corresponding to the currently selected object.

Key Command:
goto Layer of Object
(Environment Window)



Environment > Options > Reset Selected Faders

Resets the selected faders.



Environment > Options > Send All Fader Values except Sysex

Sends all current Environment fader values except for those defined by SysEx.



Environment > Options > Send All Fader Values

Sends all current values of the Environment faders.

Key Command:
Send All Fader Values
(Environment Window)



Environment > Options > Send Selected Fader Values

Sends all current values of the selected faders.

Key Command:
Send Selected Fader Values
(Environment Window)



Environment > Options > Define Custom Bank Messages...

Use this dialog to enter individual bank change messages for each instrument if the default message type 
does not comply with standards.



Environment > Options > Layer > Delete

Deletes the current layer including all objects.



Environment > Options > Layer > Insert

Creates a new Environment layer.



Environment > Options > Clean up > Align Objects

Cleans up the positions of the selected objects.

Key Command:
Align Objects
(Environment Window)



Environment > Options > Clean up > Positions by Grid

Positions the selected objects by grid.

Key Command:
Clean up Positions
(Environment Window)



Environment > Options > Clean up > Size by Default

Sets the size of the selected objects to default object size.

Key Command:
Reset Sizes
(Environment Window)



Environment > Options > Cable serially

Cables the selected objects serially.

Key Command:
Cable serially
(Environment Window)



Environment > Options > Import Layer...

Imports a complete layer of a different song file.



Transport > About the Transport Window

All Transport commands can be found in the menu when a Transport window is active.



Transport > Tempo and Synchronisation > Internal Sync

Activates internal synchronization. Logic results to be master.



Transport > Tempo and Synchronisation > SMPTE Sync (MTC)

Activates SMPTE synchronization via MTC. Logic results to be MTC slave.



Transport > Tempo and Synchronisation > MIDI Clock Sync

Activates MIDI clock synchronization. Logic results to be MIDI clock slave.



Transport > Tempo and Synchronisation > Auto Sync In

Logic locks to MTC or MIDI clock automatically on receiving the sync source.



Transport > Tempo and Synchronisation > MIDI Machine Control (MMC)

Switches MMC on or off.



Transport > Tempo and Synchronisation > Synchronisation...

Opens a window with all parameters necessary for synchronization.



Transport > Tempo and Synchronisation > Open Graphic Tempo...

Opens a window to edit the tempo grafically.



Transport > Tempo and Synchronisation > Open Tempo List...

Displays a list of tempo changes similar to the event list.



Transport > View > smaller

Decreases the size of the Transport window.



Transport > View > larger

Increases the size of the Transport window.



Transport > View > Size

Allows to directly select the size of the transport window.



Transport > View > Legend

Displays a legend showing the names of the assignable controllers.



Transport > View > Position Slider

Hides or shows an indicator for the current position relative to the entire song length.



Transport > View > Giant SMPTE Display

Converts the Transport window into a large display of the current SMPTE time.



Transport > View > Giant Bar Display

Converts the Transport window into a large bar display.



Transport > Recording > Record

This starts recording. Logic then begins recording on the selected track from the current location of the 
Song Position Line. You also get a count-in if you've set one up in the Song Settings.

Key Command:
Record
(Global Commands)



Transport > Recording > Record Repeat

The last recording run is repeated. The last recording you made is erased and recording recommences 
from the same place you began your last recording run.

Key Command:
øRecord Repeat
(Global Commands)



Transport > Recording > Record Toggle

Switches Record Mode on and off. In this way, you can (for example) switch into Record Mode during 
playback of some previously recorded material. If you do this, playback will not be interrupted.

Key Command:
øRecord Toggle
(Global Commands)



Transport > Recording > Recording Options...

Opens the Recording Options screen of the Song Settings window.

Key Command:
Recording options...
(Global Commands)



Transport > Recording > Set Audio Record Path ...

Opens a dialog where you can set the file path and various options for recording audio data.



Audio > About the Audio Window

All Audio commands can be found in the menu when an Audio window is active.



Audio > Audio File > Add Audio File ...

Use this dialog to add an existing audio file to the current song.



Audio > Audio File > Add Region

Adds a new region to the selected audio file.



Audio > Audio File > Set Audio Record Path ...

Opens a dialog where you can set the file path and various options for recording audio data.



Audio > Audio File > Delete File(s)

Deletes selected files from hard disk. Attention, this function is irreversible!



Audio > Audio File > Backup File(s)

Creates backup files of the selected audio files.



Audio > Audio File > Copy/Convert File(s)

Copies the selected files, and allows you to select a new file format for the copies as it does so.



Audio > Audio File > Move File(s)

Moves selected files to a new folder.



Audio > Audio File > Convert to Wave Stereo

Creates new stereo Wave files from the selected (stereo) files. These may be used for further processing 
in other applications.



Audio > Audio File > Update File Information

Updates file information for the selected audio files.



Audio > Audio File > Refresh Overview(s)

Use this function to recalculate the wave form overview(s) of the selected audio files.



Audio > Edit > Undo

Cancels the last editing of a song file.

Key Command:
Undo
(Global Commands)
Global Key Command: Ctrl+Z



Audio > Edit > Cut

Deletes the selected portion of data and copies it to the clipboard.

Key Command:
Cut
(Global Commands)
Global Key Command: Ctrl+X



Audio > Edit > Copy

Copies a selected portion of data to the clipboard.

Key Command:
Copy
(Global Commands)
Global Key Command: Ctrl+C



Audio > Edit > Paste

Inserts the contents of the clipboard.

Key Command:
Paste
(Global Commands)
Global Key Command: Ctrl+V



Audio > Edit > Clear

Deletes a selected portion of data.

Key Command:
Clear
(Global Commands)
Global Key Command: Rück



Audio > Edit > Select All

Selects all objects in the active window.

Key Command:
Select All
(Global Commands)
Global Key Command: Ctrl+A



Audio > Edit > Select Used

Selects all regions and files used in the Arrange window.

Key Command:
Select Used
(Audio Window)



Audio > Edit > Select Unused

Selects all regions and files not used in the Arrange window.

Key Command:
Select Unused
(Audio Window)



Audio > Edit > Info

Displays information as to the used audio files and regions.



Audio > Edit > Search Zero Crossings

Activate this function to search zero crossings for cutting the material there. This may lead to a slight 
deviation from the intended cut but avoids the formation of clicks.



Audio > View > Files sorted by > None

Displays audio files unsorted.



Audio > View > Files sorted by > Name

Displays audio files sorted by name.



Audio > View > Files sorted by > Size

Displays audio files sorted by size.



Audio > View > Files sorted by > Drive

Displays audio files sorted by drive.



Audio > View > Show File Infos

Displays information about selected files.



Audio > View > Show All Regions

Lists all regions.

Key Command:
Show All Regions
(Audio Window)



Audio > View > Hide All Regions

Hides all regions.

Key Command:
Hide All Regions
(Audio Window)



Audio > View > Sort Regions by > Start

Displays regions sorted by starting point.



Audio > View > Sort Regions by > Length

Displays regions sorted by length.



Audio > View > Sort Regions by > Name

Displays regions sorted by name.



Audio > View > Show Length as > None

Displays regions unsorted.



Audio > View > Show Length as > Min:Sec:Ms

Displays length in minutes, seconds, and milliseconds.



Audio > View > Show Length as > Samples

Displays length as samples.



Audio > View > Show Length as > SMPTE Time

Displays length as SMPTE time.



Audio > View > Show Length as > Bars/Beats...

Displays length in bars and beats.



Audio > View > Object Colors...

Opens color palette to assign colors to sequences, instruments, selections, etc.

Key Command:
Open Object Colors...
(Global Commands)



Audio > Options > Sample Rate 44100

Sets the sample rate to 44100 Hz.



Audio > Options > Sample Rate 48000

Sets the sample rate to 48000 Hz. Note that some hardware does not support this sample rate.



Sample Edit > About the Sample Edit

All Sample Edit commands can be found in the menu when a Sample Edit window is active.



Sample Edit > Audio File > Create Backup

Creates a backup of the active file.



Sample Edit > Audio File > Revert to Backup

Reverts to the last backup file. All editing since the last storage operation is lost.



Sample Edit > Audio File > Save A Copy As...

Stores a copy of the active file under a new name.



Sample Edit > Audio File > Save Selection As...

Stores a copy of the current selection under a new name.



Sample Edit > Audio File > Update File Information

Updates file information for the selected audio files.



Sample Edit > Audio File > Refresh Overview(s)

Use this function to recalculate the wave form overview(s) of the selected audio files.



Sample Edit > Edit > Undo

Cancels the last editing of a song file.

Key Command:
Undo
(Global Commands)
Global Key Command: Ctrl+Z



Sample Edit > Edit > Cut

Deletes the selected portion of data and copies it to the clipboard.

Key Command:
Cut
(Global Commands)
Global Key Command: Ctrl+X



Sample Edit > Edit > Copy

Copies a selected portion of data to the clipboard.

Key Command:
Copy
(Global Commands)
Global Key Command: Ctrl+C



Sample Edit > Edit > Paste

Inserts the contents of the clipboard.

Key Command:
Paste
(Global Commands)
Global Key Command: Ctrl+V



Sample Edit > Edit > Clear

Deletes a selected portion of data.

Key Command:
Clear
(Global Commands)
Global Key Command: Rück



Sample Edit > Edit > Select All

Selects all objects in the active window.

Key Command:
Select All
(Global Commands)
Global Key Command: Ctrl+A



Sample Edit > Edit > Region -> Selection

Sets selection borders to start and end of the current region.

Key Command:
Region -> Selection
(Sample Edit Window)



Sample Edit > Edit > Selection -> Region

Replaces start and end of the current region by selection borders.

Key Command:
Selection -> Region
(Sample Edit Window)



Sample Edit > Edit > Create New Region

Creates a new region.

Key Command:
Create New Region
(Sample Edit Window)



Sample Edit > Edit > Search Zero Crossings

Activate this function to search zero crossings for cutting the material there. This may lead to a slight 
deviation from the intended cut but avoids the formation of clicks.



Sample Edit > Functions > Normalize

Normalizes selected portions of data, i.e. calculates the maximum level for the highest amplitude of the 
file. All other data are processed proportionally.

Do not confuse with Normalize function in the Arrange window, which has the same name.

Key Command:
Normalize
(Sample Edit Window)



Sample Edit > Functions > Change Gain...

Use this dialog to enter a relative numeric value for calculating the required level change for the current 
selection.

Key Command:
Change Gain...
(Sample Edit Window)



Sample Edit > Functions > Fade In

Creates a linear fade in for the selected portion of data.

Key Command:
Fade In
(Sample Edit Window)



Sample Edit > Functions > Fade Out

Creates a linear fade out for the selected portion of data.

Key Command:
Fade Out
(Sample Edit Window)



Sample Edit > Functions > Silence

Sets the selected portion of data to level 0, i.e. silence.

Key Command:
Silence
(Sample Edit Window)



Sample Edit > Functions > Invert

Inverts the selected portion of data, i.e. the phase is shifted.

Key Command:
Invert
(Sample Edit Window)



Sample Edit > Functions > Reverse

Inverts the selected portion of data as to time axis in order to play it backwards.

Key Command:
Reverse
(Sample Edit Window)



Sample Edit > Functions > Trim

Deletes the regions outside the selected portion of data from the file.

Key Command:
Trim
(Sample Edit Window)



Sample Edit > Functions > Remove DC Offset

Removes any direct current components from the selected portion of data.



Sample Edit > Functions > Adjust Tempo by Selection & Locators

Adjusts the tempo according to object length. Use the locators to determine the number of bars intended 
to correspond to the length of the selected objects. This function is implemented to calculate the exact 
tempo automatically.



Sample Edit > Functions > Search Peak

Searches for the passage with the highest level in the current selection.

Key Command:
Search Peak
(Sample Edit Window)



Sample Edit > Functions > Search Silence

Searches for silent passages in the current selection.

Key Command:
Search Silence
(Sample Edit Window)



Sample Edit > Factory > Time and Pitch Machine...

Opens the Time and Pitch Machine window to adjust length and pitch for the selected area of an audio 
file.

Key Command:
Time and Pitch Machine...
(Sample Edit Window)



Sample Edit > Factory > Groove Machine...

Opens the Groove Machine window to generate a certain swing grid for the selected area of an audio file.



Sample Edit > Factory > Audio Energizer...

Opens the Audio Energizer window to calculate a compressed level for the selected area of an audio file.



Sample Edit > Factory > Sample Rate Convert...

Opens the Sample Rate Converter window to adjust the sample rate for the selected area of an audio file.

Key Command:
Sample Rate Convert...
(Sample Edit Window)



Sample Edit > Factory > Audio to Score...

Opens the Audio to Score window to generate MIDI data from the selected area of an audio file.

Key Command:
Audio to Score...
(Sample Edit Window)



Sample Edit > View > Samples

Displays length as samples.



Sample Edit > View > Min:Sec:Ms

Displays length in Min:Sec:Ms.



Sample Edit > View > SMPTE Time

Displays length as SMPTE time.



Sample Edit > View > Bars/Beats...

Displays length in bars and beats.



Sample Edit > View > Amplitude Percentage

Displays amplitude in percent.



Sample Edit > View > Amplitude Sample Value

Displays amplitude as sample values.



Sample Edit > View > Show as Sample & Hold

Display of amplitude corresponds to digital data.



Sample Edit > View > Wave Color...

Opens the color palette to color sequences, instruments, selections, etc.

Key Command:
Open Object Colors...
(Global Commands)



Key Commands > About the Key Commands

All Key Commands commands can be found in the menu when the Key Commands window is active.



Key Commands > Options > Import Key Commands...

Allows you to import the settings for the Key Commands from an other preferences file.



Key Commands > Options > Copy Key Commands to Clipboard

Copies the currently displayed Key Commands to the clipboard. They can then be inserted into a word 
processing software where the can be printed.



Key Commands > Options > Save Preferences

Normally Logic automatically saves its preferences when it is quit. This option allows you to manually 
save the preferences.



Key Commands > Options > Scroll To Selection

Scrolls to the current selection by moving the content of the active window.



Key Commands > Options > Initialize > all Preferences except Commands

Initializes all preferences except the key commands.



Key Commands > Options > Initialize > all Key Commands

Initializes all key commands.



Preferences > About the Preferences

The Preferences are Logic's global settings, which hold sway in all songs at once. All the settings made 
under «Preferences» can be found in the various sub-screens accessed via the "Options > Settings >" 
menu.



Preferences > Global > Add 'Last Edit Function' to sequence name

The last editing function carried out on a sequence will be added automatically to the sequence's name.



Preferences > Global > Disable safety alert for 'Undo'

This allows you to turn off the 'Are You Sure?' dialog which appears every time you call up the Undo 
function.



Preferences > Global > Disable 'Living Groove' connection

Normally, if you change a sequence which has been defined as a 'Groove Template', the Quantization 
grid which has been created from it also changes. This option disables the connection between Groove 
Template sequence and quantization grid.



Preferences > Global > Enable Catch when sequencer starts

The 'Catch' function is activated automatically when the sequencer is started.



Preferences > Global > Enable Catch when moving song position

The 'Catch' function is activated automatically when the sequencer's position is altered.



Preferences > Global > Allow Content Catch by Position if Catch and Link enabled

If this option is checked, the 'Content Catch' function will be switched on in windows where the Catch and 
Link functions are already active.



Preferences > Global > Limit dragging to one direction in Matrix and Score

This option limits the direction in which notes may be dragged in the Matrix and Score editors.



Preferences > Global > Limit dragging to one direction in Arrange

This option limits the direction in which objects may be dragged in the Arrange window.



Preferences > Global > 'Export MIDI File...' saves single sequences as Format 0

When exporting a MIDI file, file format 0 will be used, provided the data being exported is from a single 
sequence.



Preferences > Global > Double Click Sequence zo open ... in Arrange

In this menu you can choose which editor opens when a sequence is double clicked in the arrange 
window.



Preferences > Global > Auto Backup ... song versions

When a song is saved you may choose to automatically backup a number of previos versions.



Preferences > Display > Wide Song Position Line

Selects a wider Song Position Line for ease of visibility.



Preferences > Display > Display Middle C as C3 (Yamaha)

Middle C is displayed as C3 (as on Yamaha synths).



Preferences > Display > Sort Instrument menu by Layers

The entries on the Instrument menu are sorted according to the Environment layer in which they appear.



Preferences > Display > Sort Instrument menu by Icons

The entries on the Instrument menu are sorted according to the icon assigned to the instrument.



Preferences > Display > Language

Allows you to choose the language in which all menues are displayed.



Preferences > Score > Dashed Song Position Line

If you wish, the Song Position Line may be displayed as a broken line.



Preferences > Score > Show Sequence selection colored

Selected sequences are diplayed in color.



Preferences > Score > Fast (Lower Resolution) Curves on Screen

A lower resolution (resulting in faster display) may be used to display curves on screen if you wish.



Preferences > Reset-Messages > Reset Messages

This sets up the various reset messages which are sent as MIDI data when the sequencer is halted. 
Various data types may be sent per port and then reset.



Preferences > Audio > Sample Edit > Warning before closing Sample Edit

If this option is checked, you will be asked if you really want to close the Sample Editor when you try to!



Preferences > Audio > Sample Edit > Warning before process Function in Sample Edit (Key)

If this option is checked, you will be asked if you're sure you want to when you try to call up a data 
processing function in the Sample Editor via the keyboard.



Preferences > Audio > Sample Edit > Warning before process Function in Sample Edit (Menu)

If this option is checked, you will be asked if you're sure you want to when you try to call up a data 
processing function in the Sample Editor via the menu.



Preferences > Audio > Sample Edit > Ask for complete Backup before process in Sample Edit

If this option is checked, you will be asked if you want to make a backup copy of your data when you call 
up a data processing function in the Sample Editor.



Preferences > Audio > Sample Edit > Create Undo file for "Normalize"

If this option is checked, Logic Audio even creates an Undo file for the Normalize function, which makes it 
possible to return to the state prior to normalization if you decide afterwards you don't like the effect the 
processing has had on your file.



Preferences > Audio > Display > Display Color in Audio Window

If this option is active, colours may be displayed in the audio window.



Preferences > Audio > Global > Release Audio in Background if Stopped

If Logic is halted and no longer the current application, you can free up external audio hardware, just as 
with the computer's serial ports.



Preferences > Audio > Global > Prepare Audio Playback when Stopped

Activating this setting causes Logic Audio to prepare audio for playback even when the sequencer is 
halted. This can minimise response time when you initiate playback.



Preferences > Audio > Global > Create Overview after Recording

If this option is not checked, Logic will not bother to automatically create the waveform display overview of 
recorded audio once recording is complete. Of course, if you wish, you may manually instigate this later.



Preferences > Audio > Global > Force record convert interleaved into split stereo file(s)

When activated stereo recording is always done using split stereo files. When opening am interleaved 
stereo file it is automatically converted into split stereo.



Preferences > Audio Drivers > PC AV > PC AV

Acitvates the driver for an audio hardware accessed by the windows multimedia driver.



Preferences > Audio Drivers > PC AV > Driver

In this menu the driver to be used for audio may be chosen.



Preferences > Audio Drivers > PC AV > Delay

This value determines the delay when recording and playing back audio via the mulimedia    audio 
hardware.



Preferences > Audio Drivers > Audiowerk > Audiowerk

Activates the Audiowerk 8 driver.



Preferences > Audio Drivers > Audiowerk > Input

This is where you decide how to use the input: analog or digital?



Preferences > Audio Drivers > Audiowerk > Monitor Response

Allows you to set the response of the monitor signal.



Preferences > Audio Drivers > Audiowerk > Monitoring

If monitoring is on the signal coming into the audio input is directly routed to the output while recording.



Song Settings > About the Song Settings

Song Settings, as the name suggests, are settings specific to individual Songs; ones which only affect the 
current Song. All the settings may be accessed under the 'Options > Settings' menu.



Song Settings > Recording Options > Merge New Recording With Selected Sequences (r)

Newly recorded data is merged with the selected sequences.



Song Settings > Recording Options > Merge only New Sequences in Cycle Record (n)

If recording is taking place in Cycle mode, any newly created sequences are merged with existing 
sequences on the same track.



Song Settings > Recording Options > Auto Mute in Cycle Record (m)

In Cycle mode, previously recorded sequences are muted automatically.



Song Settings > Recording Options > Auto Create Tracks in Cycle Record (c)

In Cycle mode, recorded sequences are automatically placed on a new track.



Song Settings > Recording Options > Auto Demix by channel if Multitrack Recording

When recording on multiple MIDI tracks events are automatically demixed to the channel of the 
instruments on those tracks.



Song Settings > Recording Options > Allow Tempo Change Recording

Allows tempo changes to be recorded.



Song Settings > Recording Options > MIDI Data Reduction

Following recording, the amount of resultant audio data will be reduced by complex processing to the 
bare minumum required.



Song Settings > Recording Options > Click while playing (p)

Activates the metronome during playback.



Song Settings > Recording Options > Click while recording (e)

Activates the metronome while recording.



Song Settings > Recording Options > Polyphonic Clicks

Allows different metronomes to be used simultaneously.



Song Settings > Recording Options > Speaker Click

Activates the metronome via the internal loudspeaker.



Song Settings > Recording Options > MIDI Click

Activates the metronome via MIDI.



Song Settings > Recording Options > Count-in

This menu determines the length of the count-in when commencing recording.



Song Settings > Recording Options > Click only during Count-in (Record)

The metronome only sounds during the count-in.



Song Settings > MIDI Options > Input Filter

Deactivating an event symbol means that these events will be filtered before recording and so will not be 
stored with the other recorded data.



Song Settings > MIDI Options > Sysex with MIDI Thru function

Switches the SysEx Thru function on or off, so that SysEx may be passed via MIDI Thru or not.



Song Settings > MIDI Options > Instrument without MIDI Thru function

Any instruments selected in this menu will not have MIDI data passed through them.



Song Settings > MIDI Options > Transmit MIDI Clock

Activates MIDI Clock transmission. The port to which MIDI Clock may be sent can also be included here.



Song Settings > MIDI Options > Transmit MTC (MIDI Time Code)

Activates transmission of MTC (MIDI Time Code). The port to which MTC may be sent can also be 
included here.



Song Settings > MIDI Options > Auto Sync In

When this function is active, Logic automatically syncs to MIDI Clock or MTC as soon as either of these 
are received.



Song Settings > MIDI Options > MMC (MIDI Machine Control )

Switches MMC on or off.



Song Settings > MIDI Options > Send Used Instr. MIDI Settings after loading

Instrument settings are automatically transmitted after the Song is loaded.



Song Settings > MIDI Options > Send All Fader Values after loading

Fader settings are automatically transmitted after the Song is loaded.



Song Settings > Chase Events > Chase Events...

When playback starts, Logic seeks out any data events of the selected type that are relevant to playback 
of the current section (pitch-bend or other control messages, for example) and retransmits these. 



Song Settings > Chase Events > Chase Control    0-15

Activates the Chase function for MIDI controllers 0 to 15.



Song Settings > Chase Events > Chase Control 64-71

Activates the Chase function for MIDI controllers 64 to 71.



Song Settings > Chase Events > Chase all other Controls

Activates the Chase function for all other MIDI controller numbers.



Song Settings > Chase Events > Chase sustained Notes

Activates the Chase function for any notes being held by Sustain messages.



Song Settings > Chase Events > Chase Notes in 'No Seq Trp' instruments

Activates the Chase function for any instruments set not to transpose via the    'No Seq Trp' parameter.



Song Settings > Chase Events > Chase sep. channels in 'All Cha' instruments

Activates the Chase function for any instruments set to 'All Cha'.



Song Settings > Chase Events > Chase on Cycle Jump

Activates the Chase function in Cycle mode.



Song Settings > Chase Events > Chase Notes on Cycle Jump

Activates the Chase function for notes in Cycle mode.



Song Settings > Chase Events > Send full MIDI Reset before Chasing

Transmits MIDI Reset messages before the transmission of Chase data.



About the Key Commands      (Key Command)

Key Commands are assigned to different keys on your computer keyboard in a special window, which is 
opened from the Open Key Commands option in the Windows menu.

The commands are arranged in several groups, as follows:

- Global Commands
Keys which have Global commands assigned to them will function no matter what window you are 
working in.

- Various Windows
The commands in this group will function when you are working in several different windows.

- Arrange and Various Sequence Editors
These commands will function when you are working in the Arrange window and the various editors only.

- Arrange Window
- Environment Window
- Score Window
- Event Window
- Hyper Edit
- Audio Window
- Sample Edit Window

Commands in these groups will only function in the corresponding windows (eg. Event Window 
commands only work in the Event Window). In this way, you can assign different commands in various 
windows to the same keystroke or key combination.



Main Menu > File > New

Creates a new song.

Key Command:
New
(Global Commands)
Global Key Command: Ctrl+N



Main Menu > File > Open...

Use the Open dialog to load a song file.

Key Command:
Open...
(Global Commands)
Global Key Command: Ctrl+O



Main Menu > File > Close Song

Closes the active song file. If recent editing has not been stored Logic displays a warning.

Key Command:
Close Song
(Global Commands)



Main Menu > File > Save

Use the Save dialog to store a song.

Key Command:
Save
(Global Commands)
Global Key Command: Ctrl+S



Main Menu > File > Save as...

Allows to store the active song file under a new name.

Key Command:
Save Song as...
(Global Commands)
Global Key Command: Ctrl+M



Main Menu > File > Revert to Saved

Replaces the active song file with the previously saved version. All editing carried out since the last 
storage is lost.

Key Command:
Revert to Saved
(Global Commands)



Main Menu > File > Page Setup...

Use the Page Setup command to set up the paper format.

Key Command:
Page Setup...
(Global Commands)



Main Menu > File > Print

Use the Print... command to start printing the current score.

Key Command:
Print
(Global Commands)
Global Key Command: Ctrl+P



Main Menu > File > Import...

Use the Import... dialog to import song files in different formats, e.g. MIDI files.

Key Command:
Import...
(Global Commands)



Main Menu > File > Export Selection as MIDI File...

Allows export of the selected sequences as a MIDI file. Make sure you normalize, and copy any loops out 
the right number of times first, as well as doing any other preparatory work.

Key Command:
Export Selection as MIDI File...
(Global Commands)



Main Menu > File > Quit

Quits Logic. If recent editing has not been stored, Logic displays a warning.

Key Command:
Quit
(Global Commands)
Global Key Command: Ctrl+Q



Main Menu > Edit > Undo

Cancels the last editing of a song file.

Key Command:
Undo
(Global Commands)
Global Key Command: Ctrl+Z



Main Menu > Edit > Cut

Deletes the selected portion of data and copies it to the clipboard.

Key Command:
Cut
(Global Commands)
Global Key Command: Ctrl+X



Main Menu > Edit > Copy

Copies a selected portion of data to the clipboard.

Key Command:
Copy
(Global Commands)
Global Key Command: Ctrl+C



Main Menu > Edit > Paste

Inserts the contents of the clipboard.

Key Command:
Paste
(Global Commands)
Global Key Command: Ctrl+V



Main Menu > Edit > Clear

Deletes a selected portion of data.

Key Command:
Clear
(Global Commands)
Global Key Command: Rück



Arrange > Edit > Select > Select All

Selects all objects in the active window.

Key Command:
Select All
(Global Commands)
Global Key Command: Ctrl+A



Smaller View      (Key Command)

Decreases the size of display of the active window.

Key Command:
Smaller View
(Globale Kommandos)



Larger View      (Key Command)

Increases the size of display of the active window.

Key Command:
Larger View
(Globale Kommandos)



Main Menu > Windows > Zoom Window

Adjusts the size of the active window to fit its content.

Key Command:
Zoom Window
(Global Commands)
Global Key Command: Ctrl+#



Main Menu > Windows > Tile Windows

Arranges all open windows on the screen and adjusts their size to make them all visible.

Key Command:
Tile Windows
(Global Commands)



Main Menu > Windows > Tile Windows horizontally

Arranges all open windows horizontally on the screen and adjusts their size to make them all visible.

Key Command:
Tile Windows horizontally
(Global Commands)



Main Menu > Windows > Stack Windows

Stacks all open windows.

Key Command:
Stack Windows
(Global Commands)



Transport > Recording > Record

Starts recording on the selected track at the current position of the song position line. The recording is 
preceded by a count-in if this is defined in the song settings.

Key Command:
Record
(Global Commands)



Transport > Recording > Record Repeat

Repeats the last recording at the same position and replaces the previously recorded data.

Key Command:
*Record Repeat
(Global Commands)
This function is only available as a Key Command.



Transport > Recording > Record Toggle

Switches between playback and record mode, e.g. during recording, without any interruptions.

Key Command:
*Record Toggle
(Global Commands)
This function is only available as a Key Command.



Play      (Key Command)

Starts playback mode at the current position of the song positon line.

Key Command:
Play
(Global Commands)



Pause      (Key Command)

Pauses the sequencer. This command corresponds to the pause button in the Transport window.

Key Command:
Pause
(Global Commands)



Stop      (Key Command)

Stops the sequencer.

Key Command:
Stop
(Global Commands)



Rewind      (Key Command)

Rewinds the song position line by one bar.

Key Command:
Rewind
(Global Commands)



Forward      (Key Command)

Forwards the song position line by one bar.

Key Command:
Forward
(Global Commands)



Fast Rewind      (Key Command)

Rewinds the song position line by eight bars.

Key Command:
Fast Rewind
(Global Commands)



Fast Forward      (Key Command)

Forwards the song position line by eight bars.

Key Command:
Fast Forward
(Global Commands)



Scrub Rewind      (Key Command)

Rewinds the song position line by one beat playing back MIDI data and - if the audio hardware supports 
this function - audio data as well.

Key Command:
Scrub Rewind
(Global Commands)



Scrub Forward      (Key Command)

Forwards the song position line by one beat playing back MIDI data and - if the audio hardware supports 
this function - audio data as well.

Key Command:
Scrub Forward
(Global Commands)



Goto Left Locator      (Key Command)

Moves the song position line to the left locator.

Key Command:
Goto Left Locator
(Global Commands)



Goto Right Locator      (Key Command)

Moves the song position line to the right locator.

Key Command:
Goto Right Locator
(Global Commands)



*goto Position...      (Key Command)

Use this dialog to enter a numeric value to define the position of the song position line.

Key Command:
*goto Position...
(Global Commands)
This function is only available as a Key Command.



Set Left Locator...      (Key Command)

Use this dialog to enter a numeric value to define the position of the left locator.

Key Command:
Set Left Locator...
(Global Commands)



Set Right Locator...      (Key Command)

Use this dialog to enter a numeric value to define the position of the right locator.

Key Command:
Set Right Locator...
(Global Commands)



Arrange > Functions > Object > Set Locators by Objects

Sets locators at start and end of currently selected objects.

Key Command:
Set Locators by Objects
(Global Commands)
Global Key Command: Shift+O



Set rounded Locators by Objects      (Key Command)

Sets the locators at start and end of currently selected objects with their positions rounded to the next bar.

Key Command:
Set rounded Locators by Objects
(Global Commands)



*Set Locators & Play      (Key Command)

Sets the locators according to the current selection, moves the song position line to the left locator, and 
starts playback.

Key Command:
*Set Locators & Play
(Global Commands)
This function is only available as a Key Command.



*Set rounded Locators & Play      (Key Command)

Sets the locators rounded to the next bar according to current selection, moves the song position line to 
the left locator, and starts playback.

Key Command:
*Set rounded Locators & Play
(Global Commands)
This function is only available as a Key Command.



Cycle      (Key Command)

Switches cycle mode on or off. This command corresponds to the button in Transport window.

Key Command:
Cycle
(Global Commands)



Drop      (Key Command)

Switches auto drop mode on or off. This command corresponds to the button in Transport window.

Key Command:
Drop
(Global Commands)



Replace      (Key Command)

Switches replace mode on or off. This command corresponds to the button in Transport window.

Key Command:
Replace
(Global Commands)



Solo      (Key Command)

Switches solo mode on of off. This command corresponds to the button in Transport window.

Key Command:
Solo
(Global Commands)



Sync intern/extern      (Key Command)

Switches between internal and external synchronization. This command corresponds to the button in 
Transport window.

Key Command:
Sync intern/extern
(Global Commands)



MIDI/Monitor Metronome Click      (Key Command)

Changes the output of the MIDI metronome. It corresponds to the button in the Transport window.

Key Command:
MIDI/Monitor Metronome Click
(Global Commands)



Main Menu > Options > Send to MIDI > Reset Controllers

Logic sends controller messages to the attached devices in order to reset them to a default value (e.g. 
volume to 127, panorama to 64, etc.).

Key Command:
Send Reset Controllers
(Global Commands)



Send discrete Note Offs (Panic)      (Key Command)

Logic sends controller messages to the attached devices in order to reset them to a default value (e.g. 
volume to 127, panorama to 64, etc.).

Key Command:
Send discrete Note Offs (Panic)
(Global Commands)



Main Menu > Options > Send to MIDI > Maximum Volume

Sets the MIDI volume of the attached devices to maximum.

Key Command:
Send Maximum Volume
(Global Commands)



Main Menu > Options > Send to MIDI > Send Used Instruments MIDI Settings

Sends instrument parameter settings to the MIDI devices.

Key Command:
Send Used Instruments MIDI Settings
(Global Commands)



Main Menu > Windows > Screensets > Copy Screenset

Copies the active screenset to the clipboard.

Key Command:
Copy Screenset
(Global Commands)



Main Menu > Windows > Screensets > Paste Screenset

Pastes a screenset from the clipboard to the active screenset.

Key Command:
Paste Screenset
(Global Commands)



Main Menu > Windows > Screensets > Lock Screenset

Enables or disables protection for the current screenset. Protection mode is indicated by a "ø" next to the 
screenset number. It is also possible to alter a protected screenset but it will appear in the protected 
window configuration again when called up the next time. 

Key Command:
*Lock/Unlock Current Screenset
(Global Commands)
This function is only available as a Key Command.
Global Key Command: Alt+L



Main Menu > Options > Settings > Recording Options...

Opens the Recording Options page of the Song Settings window.

Key Command:
Recording options...
(Global Commands)
Global Key Command: Ctrl+T



Main Menu > Windows > Open Event List

Opens a new Event Editor window.

Key Command:
Open Event Editor...
(Global Commands)
Global Key Command: Ctrl+2



Main Menu > Windows > Open Arrange

Opens a new Arrange window.

Key Command:
Open Arrange Window...
(Global Commands)
Global Key Command: Ctrl+1



Main Menu > Windows > Open Score

Opens a new Score (Notation) window.

Key Command:
Open Score Editor...
(Global Commands)
Global Key Command: Ctrl+3



Main Menu > Windows > Open Matrix Edit

Opens a new Matrix Editor window.

Key Command:
Open Matrix Editor...
(Global Commands)
Global Key Command: Ctrl+6



Main Menu > Windows > Open Drum Edit

Opens a new Hyper Editor window.

Key Command:
Open Hyper Editor...
(Global Commands)
Global Key Command: Ctrl+5



Main Menu > Windows > Open Transform

Opens a new Transform window.

Key Command:
Open Transform
(Global Commands)
Global Key Command: Ctrl+4



Main Menu > Windows > Open Transport

Opens a new Transport window.

Key Command:
Open Transport...
(Global Commands)
Global Key Command: Ctrl+7



Main Menu > Windows > Open Environment

Opens a new Environment window.

Key Command:
Open Environment...
(Global Commands)
Global Key Command: Ctrl+8



Main Menu > Audio > Audio Window...

Opens a new Audio window.

Key Command:
Open Audio Window...
(Global Commands)
Global Key Command: Ctrl+9



Main Menu > Audio > Sample Editor...

 Opens a new Sample Editor window.

Key Command:
Open Sample Editor...
(Global Commands)
Global Key Command: Ctrl+0



Main Menu > Windows > Open Track Mixer

Opens a window with the Adaptive mixer.

Key Command:
Open Track Mixer...
(Global Commands)



Start external Sample Editor      (Key Command)

Opens the selected audio file in an external application.

Key Command:
Start external Sample Editor
(Global Commands)



Main Menu > Audio > System Performance...

Displays the current system performance.

Key Command:
Open System Performance...
(Global Commands)



Main Menu > Options > Settings > Synchronisation Settings...

Opens a window with all parameters necessary for synchronization.

Key Command:
Open Synchronisation Window...
(Global Commands)



Main Menu > Options > Tempo > Tempo List Editor...

Displays a list of tempo changes similar to the event list.

Key Command:
Open Tempo List...
(Global Commands)



Arrange > View > Object Colors...

Opens color palette to assign colors to sequences, instruments, selections, etc.

Key Command:
Open Object Colors...
(Global Commands)



Main Menu > Options > Video Player...

Use the Video Player dialog to choose a movie file to run in a separate window locked to the sequencer. 

Key Command:
Open Movie...
(Global Commands)



Open Movie Again      (Key Command)

Open the previously opened movie again.

Key Command:
Open Movie Again
(Global Commands)



Main Menu > Windows > Close Window

Closes the active window.

Key Command:
Close Window
(Global Commands)



*Show Tools      (Key Command)

Opens the tool box at the current mouse position.

Key Command:
*Show Tools
(Various Windows)
This function is only available as a Key Command.



Zoom Horizontal Out      (Key Command)

Reduces the size of the displayed objects horizontally in windows with telescope function.

Key Command:
Zoom Horizontal Out
(Various Windows)



Zoom Horizontal In      (Key Command)

Enlarges the size of the displayed objects horizontally in windows with telescope function.

Key Command:
Zoom Horizontal In
(Various Windows)



Zoom Vertical Out      (Key Command)

Reduces the size of the displayed objects vertically in windows with telescope function.

Key Command:
Zoom Vertical Out
(Various Windows)



Zoom Vertical In      (Key Command)

Enlarges the size of the displayed objects vertically in windows with telescope function.

Key Command:
Zoom Vertical In
(Various Windows)



Page Up      (Key Command)

Moves the content of the window one page up.

Key Command:
Page Up
(Various Windows)



Page Down      (Key Command)

Moves the content of the window one page down.

Key Command:
Page Down
(Various Windows)



Page Left      (Key Command)

Moves the content of the window one page to the left.

Key Command:
Page Left
(Various Windows)



Page Right      (Key Command)

Moves the content of the window one page to the right.

Key Command:
Page Right
(Various Windows)



Page Top      (Key Command)

Moves the content of the window to the top of the page.

Key Command:
Page Top
(Various Windows)



Page Bottom      (Key Command)

Moves the content of the window to the bottom of the page.

Key Command:
Page Bottom
(Various Windows)



Page Left-most      (Key Command)

Moves the content of the window to its left border.

Key Command:
Page Left-most
(Various Windows)



Page Right-most      (Key Command)

Moves the content of the window to its right border.

Key Command:
Page Right-most
(Various Windows)



Arrange > View > Parameters

Shows or hides parameters in the active window.

Key Command:
Hide/Show Parameters
(Various Windows)
Global Key Command: Ctrl+H



Catch Clock Position      (Key Command)

Moves the content of the window to follow the visible song position line.

Key Command:
Catch Clock Position
(Various Windows)



Link Window (Same Level)      (Key Command)

Links the content of the active window to the upper window and displays the same content.

Key Command:
Link Window (Same Level)
(Various Windows)



MIDI Out Toggle      (Key Command)

Enables or disables the output of selected MIDI events in different editors.

Key Command:
MIDI Out Toggle
(Various Windows)



MIDI In Toggle      (Key Command)

Enables or disables the input of selected MIDI events in different editors.

Key Command:
MIDI In Toggle
(Various Windows)



Mute Folders/Sequences      (Key Command)

Enables or disables muting of selected folders or sequences.

Key Command:
Mute Folders/Sequences
(Various Windows)



Deselect All      (Key Command)

Deselects all objects in the active window.

Key Command:
Deselect All
(Arrange and Various Sequence Editors)



Arrange > Edit > Select > Toggle Selection

Reverses the current selection in the active window. Selects all objects that are not selected, and vice 
versa.

Key Command:
Toggle Selection
(Arrange and Various Sequence Editors)
Global Key Command: Alt+T



Arrange > Edit > Select > Select All Following

Selects all following objects in the active window.

Key Command:
Select All Following
(Arrange and Various Sequence Editors)
Global Key Command: Alt+F



Arrange > Edit > Select > Select Inside Locators

Selects all objects within the locators in the active window.

Key Command:
Select inside Locators
(Arrange and Various Sequence Editors)
Global Key Command: Alt+I



Arrange > View > Scroll To Selection

Scrolls to the current selection by moving the content of the active window.

Key Command:
Scroll To Selection
(Arrange and Various Sequence Editors)



Arrange > Functions > Object > Repeat Objects

Use the Repeat Objects... dialog to repeat one or more selected objects.

Key Command:
Repeat Objects...
(Arrange and Various Sequence Editors)



*Select previous Track      (Key Command)

Selects the track above the active track.

Key Command:
*Select previous Track
(Arrange Window)
This function is only available as a Key Command.



*Select next Track      (Key Command)

Selects the track below the active track.

Key Command:
*Select next Track
(Arrange Window)
This function is only available as a Key Command.



*Select previous Object      (Key Command)

Selects the previous object.

Key Command:
*Select previous Object
(Arrange Window)
This function is only available as a Key Command.



*Select next Object      (Key Command)

Selects the following object.

Key Command:
*Select next Object
(Arrange Window)
This function is only available as a Key Command.



Arrange > Functions > Folder > Pack Folder

Packs the selected portions of data into a folder. Afterwards, the Arrange window displays a folder 
containing the selected objects.

Key Command:
Pack Folder
(Arrange Window)
Global Key Command: Ctrl+P



Arrange > Functions > Folder > Unpack Folder (Create new tracks)

Unpacks the selected folder. Its content will be moved to the next higher level, the folder deleted.

Key Command:
Unpack Folder
(Arrange Window)
Global Key Command: Ctrl+Alt+P



Arrange > Functions > Track > Create

Creates a new track.

Key Command:
Create Track
(Arrange Window)



Arrange > Functions > Track > Delete

Deletes the active track. If the track contains any data Logic displays a warning.

Key Command:
Delete Track
(Arrange Window)



Arrange > Functions > Track > Delete unused

Deletes all tracks not in use, i.e. tracks which do not contain any sequences, folders, or regions.

Key Command:
Delete unused Tracks
(Arrange Window)



Merge Objects/Digital Mixdown      (Key Command)

Use this function to merge various selected sequences to create a single new one.
If several audio regions are selected use this command to make a digital mixdown. The result will be a 
new audio file with the same settings for volume, panorama, and crossfade.

Key Command:
Merge Objects/Digital Mixdown
(Arrange Window)



Arrange > Functions > Track > Create Trackname

Creates a track name not mapped to an instrument for the active track.

Key Command:
Create Trackname
(Arrange Window)



Arrange > Functions > Track > Delete Trackname

Deletes a track name not mapped to an instrument from the active track.

Key Command:
Delete Trackname
(Arrange Window)



Arrange > Functions > Object > Move Selected Objects to current track

Moves the selected objects to the active track.

Key Command:
Move Selected Objects to track
(Arrange Window)



Arrange > Functions > Track > Open SoundDiver for Instrument

If SoundDiver has been started Logic uses this editor to select the active instrument.

Key Command:
Open SoundDiver for Instrument
(Arrange Window)



Main Menu > Options > Tempo > Adjust Tempo using object length & Locators

Adjusts the tempo according to object length. Use the locators to determine the number of bars intended 
to correspond to the length of the selected objects. This function is implemented to calculate the 
corresponding tempo automatically.

Key Command:
Adjust Tempo using object length and Locators
(Arrange Window)



Arrange > Audio > Regions to original Record Position

Resets the selected audio regions to the original recording position.

Key Command:
Set Region(s) to Recording Position
(Arrange Window)



Arrange > Functions > Sequence Parameter > Normalize Sequence Parameters

Writes the sequence parameters of the selected sequences to their data.

Key Command:
Normalize
(Arrange Window)
Global Key Command: Shift+N



Fix Quantize      (Key Command)

Writes the quantization of the selected sequences to their data.

Key Command:
Fix Quantize
(Arrange Window)



Toggle Loop      (Key Command)

Switches the loop status of selected sequences, regions, or folders.

Key Command:
Toggle Loop
(Arrange Window)



Arrange > Functions > Sequence Parameter > Turn Loops to Real Copies

Turns loops into real data containing copies. 

Key Command:
Turn Loops to Real Copies
(Arrange Window)
Global Key Command: Alt+Shift+C



Erase Duplicated Events      (Key Command)

Deletes duplicates of events.

Key Command:
Erase Duplicated Events
(Arrange Window)



Main Menu > Options > Groove Templates > Remove Groove Template from List

Removes the selected sequence from quantization template list. Its grid will not be availible in Quantize 
menu any more.

Key Command:
Remove Groove Template from list
(Arrange Window)



Main Menu > Options > Groove Templates > Make Groove Template

Enters the selected sequence as quantization template to make its grid accessible in Quantize menu.

Key Command:
Make Groove Template
(Arrange Window)



Arrange > View > Hyper Draw > off

Switches off Hyper Draw in selected sequences.

Key Command:
Hyper Draw: Disable
(Arrange Window)



Arrange > View > Hyper Draw > Volume

Displays the selected sequences with Hyper Draw for volume (controller 07).

Key Command:
Hyper Draw: Volume
(Arrange Window)



Arrange > View > Hyper Draw > Pan

Displays the selected sequences with Hyper Draw for panorama (controller 10).

Key Command:
Hyper Draw: Pan
(Arrange Window)



Environment > Edit > Clear Cables only

Deletes only currently selected cables.

Key Command:
Clear Cables only
(Environment Window)
Global Key Command: Alt+Entf



Environment > Options > Clean up > Positions by Grid

Positions the selected objects by grid.

Key Command:
Clean up Positions
(Environment Window)



Environment > Options > Clean up > Size by Default

Sets the size of the selected objects to default object size.

Key Command:
Reset Sizes
(Environment Window)



Environment > Options > Clean up > Align Objects

Cleans up the positions of the selected objects.

Key Command:
Align Objects
(Environment Window)



Environment > View > Cable(s)

Shows or hides display of cabling.

Key Command:
Hide/Show Cables
(Environment Window)



Environment > View > Protect Cabling/Positions

Protects object positions as well as cabling.

Key Command:
Protect Cabling/Positions
(Environment Window)



Toggle Selection      (Key Command)

Reverses the current selection in the active window. Selects all objects that are not selected, and vice 
versa.

Key Command:
Toggle Selection
(Environment Window)



Environment > Edit > Select Cable Destination

Selects all destination objects of a selected cable connection.

Key Command:
Select Cable Destination
(Environment Window)
Global Key Command: Ctrl+B



Environment > Edit > Select Cable Origin

Selects all objects leading to a selected source object.

Key Command:
Select Cable Origin
(Environment Window)



Environment > Options > goto Layer of Object

Switches from 'All Objects' layer to the layer corresponding to the currently selected object.

Key Command:
goto Layer of Object
(Environment Window)



Environment > Options > goto previous Layer

Displays previous layer.

Key Command:
goto previous Layer
(Environment Window)



Environment > Options > Send Selected Fader Values

Sends all current values of the selected faders.

Key Command:
Send Selected Fader Values
(Environment Window)



Environment > Options > Send All Fader Values

Sends all current values of the Environment faders.

Key Command:
Send All Fader Values
(Environment Window)



Environment > Options > Cable serially

Cables the selected objects serially.

Key Command:
Cable serially
(Environment Window)



Score > View > Page Edit

Displays the active notation in page view mode.

Key Command:
Page Edit
(Score Window)
Global Key Command: Alt+P



Explode Folders      (Key Command)

Displays the sequences of the selected folders as independent sequences.

Key Command:
Explode Folders
(Score Windowster)



*Go to Page...      (Key Command)

Opens a dialog where a page number can be entered. The selected page will then be displayed in the 
score window.

Key Command:
*Go to Page...
(Score Window)
This function is only available as a Key Command.



*Next Event      (Key Command)

Selects the following event in the active window.

Key Command:
*Next Event
(Score Window)
This function is only available as a Key Command.



*Previous Event      (Key Command)

Selects the previous event in the active window.

Key Command:
*Previous Event
(Score Window)
This function is only available as a Key Command.



*Next Staff      (Key Command)

Selects the following staff in the active window.

Key Command:
*Next Staff
(Score Window)
This function is only available as a Key Command.



*Previous Staff      (Key Command)

Selects the previous staff in the active window.

Key Command:
*Previous Staff
(Score Window)
This function is only available as a Key Command.



Score > Attributes > Syncopation > Default

Uses Logic's default settings for selected dotted notes.

Key Command:
Default Syncopation
(Score Window)



Score > Attributes > Syncopation > Force

Expresses the selected dotted notes as syncopes.

Key Command:
Force      Syncopation
(Score Window)



Score > Attributes > Syncopation > Defeat

Supresses syncopes of selected notes and expresses them as dotted notes.

Key Command:
Defeat    Syncopation
(Score Window)



Score > Attributes > Interpretation > Default

Uses Logic's default settings as to interpretation of the selected notes.

Key Command:
Default Interpretation
(Score Window)



Score > Attributes > Interpretation > Force

Forces interpretation of selected notes.

Key Command:
Force      Interpretation
(Score Window)



Score > Attributes > Interpretation > Defeat

Suppresses interpretation of selected notes.

Key Command:
Defeat    Interpretation
(Score Window)



Score > Attributes > Stems > Default

Score Window

Key Command:
Stems: default
(Score Window)
Global Key Command: Alt+S



Score > Attributes > Stems > Up

Displays selected notes with stems upwards.

Key Command:
Stems: up
(Score Window)
Global Key Command: Alt+U



Score > Attributes > Stems > Down

Displays selected notes with stems downwards.

Key Command:
Stems: down
(Score Window)
Global Key Command: Alt+D



Score > Attributes > Beaming > Beam Selected

Forces the selected notes to be beamed as far as possible.

Key Command:
Beam Selected Notes
(Score Window)
Global Key Command: Alt+B



Score > Attributes > Beaming > Unbeam Selected

Removes the beams from selected notes.

Key Command:
Unbeam Selected Notes
(Score Window)
Global Key Command: Alt+V



Score > Attributes > Beaming > Default

Resets the setting of selected notes as to beaming to Logic's default values.

Key Command:
Default Beams
(Score Window)
Global Key Command: Alt+Shift+B



Score > Attributes > Accidentals > Default Accidental

Resets the setting of selected notes as to enharmonic shifts to Logic's default values.

Key Command:
Default Accidental
(Score Window)
Global Key Command: Alt+A



Score > Attributes > Accidentals > Enharmonic Shift: #

Allows selected notes to be expressed as sharps (#) due to enharmonic shift. 

Key Command:
Enharmonic Shift: #
(Score Window)
Global Key Command: Shift+#



Score > Attributes > Accidentals > Enharmonic Shift: b

Allows selected notes to be expressed as flats (b) due to enharmonic shift. 

Key Command:
Enharmonic Shift: b
(Score Window)
Global Key Command: Shift+B



Scroll to Previous Event      (Key Command)

Selects the previous event and scrolls to make it visible in the middle of the active window.

Key Command:
Scroll to Previous Event
(Event Window)



Scroll to Next Event      (Key Command)

Selects the next event and scrolls to make it visible in the middle of the active window.

Key Command:
Scroll to Next Event
(Event Window)



Event List > View > Length as absolute Position

Displays the absolute position of the end of a note instead of the note length.
(Beginning + note length = end of note)

Key Command:
Length as Absolute Position
(Event Window)
Global Key Command: Ctrl+P



Event List > View > Local Position

Displays the positions in relation to the beginning of    the sequence. Usually, the display refers to the 
whole song.

Key Command:
Local Position
(Event Window)



*Numerical Edit of Event Position      (Key Command)

Allows you to numerically edit the position of an event.

Key Command:
*Numerical Edit of Event Position
(Event Window)
This function is only available as a Key Command.



*Duplicate Event and Numerical Edit      (Key Command)

Duplicates the current event. Use the following dialog to enter the position of the new event numerically.

Key Command:
*Duplicate Event and Numerical Edit
(Event Window)
This function is only available as a Key Command.



*Copy value to all following events      (Key Command)

Applies the value (VAL) of the current event to all following events of the same type.

Key Command:
*Copy value to all following events
(Event Window)
This function is only available as a Key Command.



Drum Edit > Hyper > Create Event Definition

Creates a new event definition ("track") in the active hyper set.

Key Command:
Create Event Definition
(Hyper Edit)



Drum Edit > Hyper > Delete Event Definition

Deletes the selected event definition ("track") in the active hyper set.

Key Command:
Delete Event Definition
(Hyper Edit)



Drum Edit > Hyper > Copy Event Definition

Copies the selected event definition ("track") in the active hyper set.

Key Command:
Copy Event Definition
(Hyper Edit)



Drum Edit > Hyper > Paste Event Definition

Inserts a copied event definition ("track") into the active hyper set.

Key Command:
Paste Event Definition
(Hyper Edit)



Drum Edit > Hyper > Select All Event Definitions

Selects all event definitions ("tracks") in the active hyper set.

Key Command:
Select All Event Definitions
(Hyper Edit)



Select Previous Audio File      (Key Command)

Selects the previous audio file.

Key Command:
Select Previous Audio File
(Audio Window)



Select Next Audio File      (Key Command)

Selects the next audio file.

Key Command:
Select Next Audio File
(Audio Window)



Play/Stop Region      (Key Command)

Starts or stops playing the current region.

Key Command:
Play/Stop Region
(Audio Window)



Add Audio File ...      (Key Command)

Use this dialog to add an existing audio file to the current song.

Key Command:
Add Audio File ...
(Audio Window)



Add Region      (Key Command)

Adds a new region to the selected audio file.

Key Command:
Add Region
(Audio Window)



Audio > Edit > Select Used

Selects all regions and files used in the Arrange window.

Key Command:
Select Used
(Audio Window)



Audio > Edit > Select Unused

Selects all regions and files not used in the Arrange window.

Key Command:
Select Unused
(Audio Window)



Audio > View > Show All Regions

Lists all regions.

Key Command:
Show All Regions
(Audio Window)



Audio > View > Hide All Regions

Hides all regions.

Key Command:
Hide All Regions
(Audio Window)



Play/Stop Selection      (Key Command)

Starts or stops playing the current selection.

Key Command:
Play/Stop Selection
(Sample Edit Window)



*Play/Stop All      (Key Command)

Starts or stops playing the current audio file.

Key Command:
*Play/Stop All
(Sample Edit Window)
This function is only available as a Key Command.



Region -> Selection      (Key Command)

Sets selection borders to start and end of the current region.

Key Command:
Region -> Selection
(Sample Edit Window)



Selection -> Region      (Key Command)

Replaces start and end of the current region by selection borders.

Key Command:
Selection -> Region
(Sample Edit Window)



*Goto Selection Start      (Key Command)

Display moves to the beginning of the current selection in the active window.

Key Command:
*Goto Selection Start
(Sample Edit Window)
This function is only available as a Key Command.



*Goto Selection End      (Key Command)

Display moves to the end of the current selection in the active window.

Key Command:
*Goto Selection End
(Sample Edit Window)
This function is only available as a Key Command.



*Goto Region Start      (Key Command)

Display moves to the beginning of the current region in the active window.

Key Command:
*Goto Region Start
(Sample Edit Window)
This function is only available as a Key Command.



*Goto Region End      (Key Command)

Display moves to the end of the current region in the active window.

Key Command:
*Goto Region End
(Sample Edit Window)
This function is only available as a Key Command.



*Goto Region Anchor      (Key Command)

Display moves to the anchor of the current region in the active window.

Key Command:
*Goto Region Anchor
(Sample Edit Window)
This function is only available as a Key Command.



Sample Edit > Edit > Create New Region

Creates a new region.

Key Command:
Create New Region
(Sample Edit Window)



Arrange > Functions > Sequence Parameter > Normalize Sequence Parameters

Writes the sequence parameters of the selected sequences to their data.

Key Command:
Normalize
(Sample Edit Window)



Sample Edit > Functions > Change Gain...

Use this dialog to enter a relative numeric value for calculating the required level change for the current 
selection.

Key Command:
Change Gain...
(Sample Edit Window)



Sample Edit > Functions > Fade In

Creates a linear fade in for the selected portion of data.

Key Command:
Fade In
(Sample Edit Window)



Sample Edit > Functions > Fade Out

Creates a linear fade out for the selected portion of data.

Key Command:
Fade Out
(Sample Edit Window)



Sample Edit > Functions > Silence

Sets the selected portion of data to level 0, i.e. silence.

Key Command:
Silence
(Sample Edit Window)



Sample Edit > Functions > Invert

Inverts the selected portion of data, i.e. the phase is shifted.

Key Command:
Invert
(Sample Edit Window)



Sample Edit > Functions > Reverse

Inverts the selected portion of data as to time axis in order to play it backwards.

Key Command:
Reverse
(Sample Edit Window)



Sample Edit > Functions > Trim

Deletes the regions outside the selected portion of data from the file.

Key Command:
Trim
(Sample Edit Window)



Sample Edit > Factory > Time and Pitch Machine...

Opens the Time and Pitch Machine window to adjust length and pitch for the selected area of an audio 
file.

Key Command:
Time and Pitch Machine...
(Sample Edit Window)



Sample Edit > Factory > Sample Rate Convert...

Opens the Sample Rate Converter window to adjust the sample rate for the selected area of an audio file.

Key Command:
Sample Rate Convert...
(Sample Edit Window)



Sample Edit > Factory > Audio to Score...

Opens the Audio to Score window to generate MIDI data from the selected area of an audio file.

Key Command:
Audio to Score...
(Sample Edit Window)



Sample Edit > Functions > Search Peak

Searches for the passage with the highest level in the current selection.

Key Command:
Search Peak
(Sample Edit Window)



Sample Edit > Functions > Search Silence

Searches for silent passages in the current selection.

Key Command:
Search Silence
(Sample Edit Window)




