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Insert menu provides elements that 
can be inserted into an HTML 
document. It helps you easily insert 
elements like images, links, form fields, 
scripts, applets and plug-ins. With this 
menu, you can give your web site 
brilliant effects like animation and 
scrolling text. It enables you to use 
math formulas in you web site freely, 
something that hasn’t been easy until 
now. Inserting layers can also be done 
without difficulty.

. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . LINE BREAK
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This option allows you to change lines without having to change the 
paragraph itself. Two types of line breaks are available from this 
command, the Line Break and Line Break...

Line Break The Line Break is used when you want to insert a single line only. It 
does not start a new paragraph. You can also use <Shift+Enter> on 
your keyboard to insert a line break. Paragraphs (<Enter> on 
keyboard) are different because a paragraph inserts a blank line 
above the current line, whereas a Line Break doesn’t. This is the 
same as entering <BR> into the HTML code.

In a word processor, when you press the <Enter> key, a new line 
starts along with a new paragraph, but an extra blank line above 
the current isn’t created.
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With Line Breaks the appearance, especially left/right margins and 
style sheets, of the current paragraph will remain the same.

Paragraph Break<Enter>

Line Break<Shift+Enter>

Line Break... If you select Line Break... on the Insert menu, you will have four 
options for breaking the lines: Normal Line Break, Clear Left Margin, 
Clear Right Margin and Clear All Margins. The Line Break... is useful 
when you want to enter text around an image or make text start at 
the bottom of it. You will appreciate its value when there are 
images or other objects in the paragraph.

Normal Line Break
If an image is at the left or right margin, it does not clear it.

Clear Left Margin
If an image is at the left margin, it moves the next line down until 
the left margin is cleared.
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Clear Right Margin
If an image is at the right margin, it moves the next line down until 
the right margin is cleared.

Clear All Margins
If an image is at both margins, it moves the next line down until 
both margins are cleared.

Style
This allows you to apply a style supported by CSS specifications. 
When you click the Style button, a Style dialog box appears. For 
more information on using the Style dialog box, see Paragraph 
Style(6-25).

Extended
Use this when Namo WebEditor doesn't support the line break 
option you require due to the addition and change of current HTML 
protocol. This will allow you to either specify an attribute that is not 
in the current HTML protocol or when a new attribute is created. 
You must enter this attribute manually.
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This option allows you to insert a horizontal line at the current 
cursor position. Horizontal Line are used to separate areas of your 
document.

When you select the Horizontal line command on the Insert menu, a 
horizontal line is inserted at the cursor position and is the full width 
of the paragraph. You can modify the length of the line after it has 
been inserted. When you resize the window, the line width changes 
along with the window size.

If you select the Horizontal Line command on the Format menu or 
press <Alt+Enter> while selecting the horizontal line in the 
document, the Horizontal Line Properties dialog box appears. You 
can modify the line properties such as the width/height and 
alignment.

Width
This option allows you to specify the width of the line. You can set it 
by percentage or pixel. If you use percentage, the width will change 
along with the window size of the web browser.

Height
This option allows you to specify the height of the line. You can only 
specify line heights in pixels.
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Alignment
You can specify the alignment here.

Solid Line (no shading)
If you select the Solid Line (no shading) option, the horizontal line 
will be solid.

Style
This allows you to use CSS to change link colors, and other options 
supported by CSS specification. When you click the Style button, 
the Style dialog box appears. For the usage of the Style dialog box, 
see Paragraph Style(6-25).

Extended
Use this when Namo WebEditor doesn't support the options you 
require. This will allow you to either specify an attribute that is not 
in the current HTML protocol or when a new attribute is created. 
You must enter this attribute manually.

. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . COMMENT
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This option will allow you to insert a comment into your document. 
The Comment(<!-- --> tag) is hidden in web browsers, but can be 
seen in the HTML source file.

When you select the Comment command from the Insert menu, the 
Comment dialog box appears. After entering the text you want, 
click OK.
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By default, you cannot view comments in the edit window. To 
display them, select the Format Mark option on the Mark Set 
command on the View menu. 

. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . SYMBOL
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This option allows you to enter special characters or symbols that 
are not on your keyboard.

When you select the Symbol command on the Insert menu, the 
Symbol dialog box appears. Select the symbol you want by clicking 
the Insert button or you can double click the symbol. The symbol is 
then placed at the location of the cursor. The selected symbol is 
shown at the left bottom of the dialog box. 

The Symbol dialog box remains on the screen after you insert the 
symbol allowing you to continue inserting symbols without having 
to reopening the box. To close the box, click the Close button.
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This option allows you to insert an image into the document. All 
major web browsers now support JPEG and GIF. These are fully 
supported by Namo WebEditor.

If you insert an image file that is different from the JPEG or GIF 
format, it will not be shown in the web browsers or Namo 
WebEditor. Only the file location and size are displayed as shown 
below:

WebEditor Internet Explorer  Netscape Navigator

1 When you select the Image command on the Insert menu, the 
Image Properties dialog box appears.

2 Enter the name and path of the image file you want into the Source 
field. If you don’t know the exact path, you can browse your hard 
drive by using the Browse button. 

3 Use the Alt Text field to enter in the information to be displayed as 
an Alt Tag in web browsers, then click OK.

4 Then the image file you specified is now inserted at the current 
cursor position.
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General You specify hyperlink and information on the image file here.

Source
Specify the name and path of the image file you want. You can use 
a file on the local hard disk or from a web site. When you use a file 
on a web site, you must have the exact URL of the file.

Low Resolution
This attribute allows a lower quality, smaller image to be displayed 
while the higher quality image is loading. This function is Netscape 
specific and will not work on Internet Explorer.

Alt Text
You can enter in detailed information on an image here. It will be 
displayed while the image is loading as text, and as a tool tip when 
the mouse is hovered over the image. It is best to put something 
here to supply information for those surfers browsing with images 
turned off, or for those with visual handicaps.

Copy Image
If you select the Copy Image option from within the Image 
Properties dialog box, the Copy Resource dialog box appears when 
you save the document. The Copy Resource dialog box allows you 
to save the image file along with the HTML file within a sub folder. 
The default name for the sub folder is 'images', however you can 
specify a different name.
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This option protects against deleting or damaging files when they 
get published.

The Copy Resource dialog box shows a preview of the image file and 
then asks whether you want to save it or not and where you want it 
to be saved to. The buttons and information on the Copy Resource 
dialog box indicate the following:

Source Displays the location of the image file.

Destination Displays the location to which the image file is 
copied.

Resource Directory You specify the folder in which the image files of 
the HTML document are to be saved. The 
default is 'images'.

Prompt on Creating a Sub-directory
If this option is selected, you will be prompted 
to create a sub-directory for image files if none 
already exists. If this option is not selected, the 
folder will be created without prompting.

Yes If you click the Yes button, image files are 
copied to the specified folder.

No If you click the No button, image files will not be 
copied.

Copy All If you click the Copy All button, all specified 
image files will be copied without prompting.

No to All If you click the No to All button, no image files 
will be copied.
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Clip Art
Select, when you want to choose from the various clip art images 
provided on the Namo WebEditor CD. For more information on 
using clip art, see Clip Art(5-13).

URL
Use this when you want to specify a hyperlink to an image. When 
you click the Edit button, the Create Hyperlink dialog box appears. 
Once you have specified the target of the hyperlink, a surfer can 
move to the linked document by clicking on the image. For more 
information, see Hyperlink(5-55).

Target Frame
Specify the frame that will display the document when the link is 
selected. You can specify the target frame in the Create Hyperlink 
dialog box. When no target frame is specified, the hyperlink target 
will be displayed in the current frame.

Appearance Here you can specify the size and alignment of the image.

Alignment
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This allows you to specify the location of the image when it is 
adjacent to text. You can easily understand each alignment type 
just by looking at the illustrations in the Image�Properties dialog 
box.

Top Aligns the first line of text to the top of the image.

Middle Aligns the first line of text to the middle of the image.

Baseline Aligns the first line of text to the bottom edge of the 
image.

Bottom Aligns the lowest portion of the first line of text to the 
bottom of the image.

Left Aligns the image to the left with the text on the right.

Right Aligns the image to the right, with the text on the left.

Size
You can specify the exact size of an image by percentage or pixel 
units. Only when the Width and Height options are selected will the 
specified values be applied to an image. The percentage option 
relates to the proportion of an image to the size of a window. If you 
specify the width as '100%', the image will be fully displayed. 

It is a wise idea to define the width and height attributes, as it can 
speed up the loading of your page into web browsers. It will also 
insure that your image will be the correct size. If you do not specify 
these attributes, your image can vary widely by browsers. 

Restore Size
If you click the Restore Size button, the Namo WebEditor re-reads 
the width and height of original image and enters that in. The size 
will be displayed in pixels.

Reference The size of the image you specify in the Image Properties dialog 
box, indicates how big or small the image will look in the web 
browser that is viewing it. It has nothing to do with the physical 
size of the file. That is, even if you reduce the width and height of 
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an image file that is 200KB, its size will remain 200KB. To change 
the physical size of an image file, use graphic software such as 
Paint Shop or Photoshop.

Space
You can specify the spaces around the image and the thickness of 
the border (the border only appears when there is a link attached 
to the image).

Horizontal Puts spaces as specified on the left and right sides of 
the image.

Vertical Puts spaces as specified on the top and bottom of the 
image.

Border Specifies the thickness of the border. If you do not 
want a viewable border, set the thickness as 0.

Style
This allows you to use CSS to change link colors, and other options 
supported by CSS specification. When you click the Style button, 
the Style dialog box appears. For the usage of the Style dialog box, 
see Paragraph Style(6-25).

Extended
Use this when Namo WebEditor doesn't support the options you 
require. This will allow you to either specify an attribute that is not 
in the current HTML protocol or when a new attribute is created. 
You must enter this attribute manually.

Resizing Image If you click the image after inserting it, eight size handles will then 
appear. By dragging these, you can freely resize the image. When 
you want to preserve the current proportion of the image, drag the 
size handle at one of the corners. When you only want to change its 
width or height, drag the size handle at the respective side. 
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Enlarging with current proportion

Enlarging only width

. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . CLIP ART
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This option will allow you to insert clip art at the current position, or 
use it as a background image. You can also add new images to clip 
art gallery. The images must be in either JPEG or GIF format.

When you select the Clip Art command from the Insert menu, the 
Clip Art dialog box appears. You may then select from the listed clip 
art images.

Namo WebEditor clip art is classified into six categories: Icon, 
Animation, Background, Bar, Bullet and Image. These six categories 
make up the main folders, these categories are then classified into 
several sub categories. These sub categories also contain sub folders. 
To select and insert clip art, follow the steps below:

1 When you select the Clip Art command from the Insert menu, the 
Clip Art dialog box appears. Select the clip art you want in the same 
way that you use Windows Explorer: When you select a folder in the 
left window, then clip art it contains will be displayed on the right.
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2 In the left window, the clip art folders appear as shown below. The 
open folder is the one you most recently visited. When you find the 
clip art you want here, click it to select it. Use the scroll bar or click 
the plus/minus sign, to see other first level folders.

3 If you select by clicking the second level folder, the list of clip art 
appears in the right window as shown below.
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4 When you select one of the clip art images in the right window, its 
name and path are shown in the bottom of the Clip Art dialog box. 
To select the image, double click on it or click the Insert button. The 
selected image will be inserted at the current cursor position.

5 To modify the appearance of a clip art image or to specify its 
hyperlink, click on the clip art image. Then select the Image 
command from the Format menu. You can right click on the clip art 
image and select the Image command. When the Image Properties 
dialog box appears, you can modify the settings accordingly.

Adding Clip Art You can add clip art which you have either created yourself or 
downloaded from a web site, to the clip art folder.

1 When you select the Clip Art command from the Insert menu, the 
Clip Art dialog box appears.
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2 Select the sub folder that your want to add your new image to.

3 Click the Import Clips button and the Open dialog box appears.

4 Specify the image file to add, then click the Open button. You can 
use a file on the local hard disk as well as one located on a web 
site. When you specify a file from a web site, you must have the 
exact URL. Note that you can only use JPEG or GIF as the format 
for the clip art.

5 The clip art you add will permanently appear in the selected sub 
folder. Click the Close button.
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Reference If you copied the clip art files using the Windows Explorer, click the 
Rebuild Thumbnails button while selecting the respective folder. The 
added clip art will be displayed. 

Adding Clip Art Folder

You can create a new sub folder for new clip art that you wish to 
add.

1 Select the folder or sub folder you want your new directory to 
appear in. When the menu appears, select Add.
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2 After the new folder is created, right click on it. When the menu 
appears, select Rename. Enter the new name and press <Enter>.

3 You can add some clip arts to the new folder by clicking on the 
Import Clips button.

4 Close the Clip Art dialog box by clicking the Close button.

Reference If you click the Insert As Background button after selecting the clip 
art file, it will be inserted as the background image.
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This allows you to insert a layer into your document.

If you select Layer from the Insert menu, a layer will be inserted at 
the current cursor position. If the Format Mark is activated, you can 
see the yellow layer format mark( )and its outline. If the Layer 
window is displayed, the information of the new layer is shown 
here.

For more information on Layer, see Layer(11-2).

Reference The Layer and Time Line are dynamic HTML functions that Namo 
WebEditor supports. To see the full effect of dynamic HTML, 
Internet Explorer 4.0 or Netscape 4.0 or higher is required.

Dynamic HTML can bring a wide range of features to your web site, 
however, if you are a beginner to Internet document publishing you 
should first fully explore basic HTML syntax before trying to tackle 
dynamic HTML.
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This allows you to create an entry form to gather information from 
visitors, make a selection, or to display a check box.

When you point to the Form Field command in the Insert menu, a 
menu of seven items will then appear as shown below. If you select 
one of them, a dialog box allowing you to specify their properties 
will appear. Enter the necessary values and click OK. The selected 
form field is then inserted at the current cursor position.

There are seven types of form fields to choose from inside Form 
Field menu: One-Line Text Box, Scrolling Text Box, Check Box, Radio 
Button, Drop-Down Menu, Push Button and Image. 

After selecting a form field, select Form from the Format menu or 
double click the newly created form field. The Form Properties dialog 
box will appear. You can then proceed to modify the properties of 
the selected form field from within this dialog box.

Reference Form fields are linked to web servers, therefore Namo WebEditor 
only shows you what the form will look like and how the buttons 
will operate. To confirm that the form will properly function it must 
be published to your web server.
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One-Line Text Box 

The One-Line Text Box is used for entering short textual 
information. When you select the One-Line Text Box from the Form 
Field command, the One-Line Text Box properties dialog box 
appears as shown below.

Name
Enter the name of the form field. The name is an important 
element to distinguish the information from other information when 
transferring it to a server or computer, therefore a name must be 
entered.

Initial Value
You can specify the value to be inputted to the form field when it 
originally appears. If you do not enter a value, the form field will 
simply remain empty.

Width in Characters
This allows you to specify the width of the form field. The unit used 
here is letters, therefore 10 would make a field long enough for 10 
letters. This does not limit the amount able to be placed into the 
form field, only its visible size.

Maximum Length
This allows you to put a limit on the amount information that can 
be entered. The procedure for this is the same as setting the width, 
however this will limit the amount of letters to be entered into the 
form field.
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Type
Allows you to specify the type of contents to be entered.

Normal Indicates normal text can be entered here.

Password Indicates the content will be a password or something 
not to be openly visible. The entered contents will be 
displayed as '*'’s. The contents can then only be seen 
by the server or by certain CGI scripts.

File Indicates a file name is to be entered here. In some 
web browsers, a Browse button is automatically 
created, so it's easy to enter the name.

Style
This allows you to use CSS to change link colors, and other options 
supported by CSS specification. When you click the Style button, 
the Style dialog box appears. For the usage of the Style dialog box, 
see Paragraph Style(6-25).

Extended
Use this when Namo WebEditor doesn't support the options you 
require. This will allow you to either specify an attribute that is not 
in the current HTML protocol or when a new attribute is created. 
You must enter this attribute manually.

Event
Specify the script to be linked to the specified event in the form 
field. When you click the Event button, the Form Field Event Script 
dialog box appears as shown below.
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In the window to the left you will see the available events, in the 
window to the right the list of current scripts are displayed. To link 
the events to a script, select the script first and then click the 
arrow-shaped button to the right of the event.

The available events may vary with the type of form field selected. 
You must also prepare the scripts beforehand.

onClick Specifies an event to occur when the field is clicked.

onFocus Specifies an event to occur when focus is set to the 
form field. 

onBlur Specifies an event to occur when focus is moved away 
from the form field. 

onSelect Specifies an event to occur when the contents of the 
form field are selected.

onChange Specifies an event to occur when the focus leaves the 
form field after the contents are changed.

Reference Event is the actions to click the mouse button or to move the 
mouse pointer. Script is a program made for a certain effect. Image 
changing when the mouse pointer is placed on an image or menu 
display when you click the image button are the joint actions 
between event and script.
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Scrolling Text Box The Scrolling Text Box is used to enter multiple lines of text. When 
you select the Scrolling Text Box from the Form Field command, the 
Scrolling Text Box Properties dialog box appears as shown below.

Name
Enter the name of the form field. This name is an important 
element to allow distinction between one form element to another 
and is often used by web servers to separate information entered in 
the web browser.

Initial Value
Specifies the contents to be displayed when the form field appears 
in the browser. If no value is entered, a blank form field will appear.

Width in Characters
This allows you to specify the width of the form field. The unit used 
here is letters, therefore 10 would make a field long enough for 10 
letters. This does not limit the amount able to be placed into the 
form field, only its visible size.

Number of Lines
This allows you to specify the viewable height of the form field. The 
number of lines you specify does not limit the quantity of contents.
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Check Box A Check Box is used to show choices in a form field. When you 
select the Check Box from the Form Field command in the Insert 
menu, the Check Box Properties dialog box appears as shown below.

Name
Enter the name of the form field. This name is an important 
element to allow distinction between one form element to another 
and is used by web servers to separate information entered in the 
web browser.

Value
Specify the value to be sent to a server when the check box is 
selected.

Initial State
Specify how the check box will initially looks in a web browser. Note 
the examples below.

Radio Button The Radio Button is a form field used to select one item from 
several items in a list. When you select the Radio Button from the 
Form Field command, the Radio Button Properties dialog box 
appears as shown below.
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Name
Enter the name of the form field. This name is an important 
element to allow distinction between one form element to another 
and is used by web servers to separate information entered in the 
web browser.

Value
Specify the value to be sent to a server when the radio box is 
selected.

Initial State
Specify how the radio button will initially look in a web browser. 
Note the examples below.

Event
Only the onClick event is available on the Radio Button.

Drop-Down Menu 

The Drop-Down Menu is used to create a single selection item list. 
When you select the Drop-Down Menu from the Form Field 
command on the Insert menu, the Drop-Down Menu Properties 
dialog box appears as shown below.
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Name
Enter the name of the form field. The name is an important 
element to distinguish one form element from another and is often 
used by web servers to separate information entered on the web 
browser.

Add
When you select the Add button, the Drop Down Option dialog box 
appears. If you click OK after entering the name and value, the new 
item will be added. If you want the newly added item to be selected 
by default, selected check box should be on.

Below is a sample of several items being added.

Modify
Changes contents.

Remove
Removes item from list.

Move Up
Moves an item up in the list.
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Move Down
Moves an item down in the list.

Height
Specifies the height of the field. If you specify the number of lines 
as a lesser value than the number of items, a scroll bar will appear 
as shown below.

Allow Multiple Selections
This allows you to choose if the user will be able to select several 
items from the same list or not. If you select Yes, more than one 
item can be chosen.

Push Button  The Button is a form field used to transferring input data to a web 
server or CGI scripting, resetting a form field, activating a script, 
and more. When you select Push Button from the Form Field 
command on the Insert menu, the Push Button Properties dialog box 
appears.

Name
Enter the name of the form field. The name is an important 
element to distinguish one form element from another and is often 
used by web servers to separate information entered on the web 
browser.
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Value
Specify the name of the Push Button. If you enter "Send", "Send" 
appears on the Push Button.

Button Type
Specify the type of push button.

Normal Indicates a button used to transfer a set value. Usually 
used with a JavaScript or Visual Basic Script.

Submit Used to transfer the data on the form to a specified 
web server or CGI software.

Reset Resets all form fields to their default. 

Image The Image is a form field used to transfer the coordinates of the 
location where one clicks. When you select the Image on the Form 
Field command from the Insert menu, the Image Form Field 
Properties dialog box appears.

Name
Enter the name of the form field. The name is an important 
element to distinguish one form element from another and is often 
used by web servers to separate information entered on the web 
browser.
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Source
Specify the name and path of the image file you will use. You can 
use a file on your hard disk or from a web site. When you use the 
image from a web site, you will need the exact URL and name of 
the file. When specifying an image file on the hard disk, use the 
Browse or Clip Art button to save time.

Align
Allows you to choose the way text and images are aligned when the 
text is mingled with images. Bottom sets the text at the bottom of 
the image. Middle sets the text in the middle, Top sets it at the top.

Copy Image
If you select the Copy Image option in the Image Form Field 
Properties dialog box, the Copy Resource dialog box will appear 
when you save the document. The Copy Resource dialog box is used 
to save the image file along with the document in a sub folder of 
the root directory. For more information on the Copy Resource 
dialog box, see Copy Image(5-8).

. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . SCRIPT
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This allows you to insert a JavaScript or Visual Basic Script 
(VBScript) into the document. Scripting is a type of programming 
language that allows you to build a truly interactive web site. It is 
used in combination with HTML. 

When you point to the Script command 
on the Insert menu, a drop down 
menu of three items appears.

If you select the Script Wizard, you can 
insert one of the 11 scripts frequently 
used into your document. These are 
provided by Namo WebEditor as 
default scripts. When selecting the 
Body Script... or Head Script..., you can 
insert them directly.
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Reference JavaScript is a script language that was developed by Netscape to 
be used to make dynamic web sites. Popular web browsers, such as 
Internet Explorer and Netscape Navigator, support JavaScript. 

Visual Basic Script, developed by Microsoft, is a script language 
supported by Internet Explorer. It is based on Visual Basic language 
but with a much simpler structure and is similar to JavaScript in its 
function.

. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . SCRIPT WIZARD
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With the Script Wizard, you can easily insert commonly used special 
effects, created using a script, into your document. 11 scripts, 
including rollover effect, animation effect, etc. are available on this 
menu.

When you select the Script Wizard from the Script command on the 
Insert menu, the Script Wizard-Select Script dialog box appears. 
Select the script you want and click the Next button.
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Rollover Effect Allows you to replace one image with another as the mouse rolls 
over it.

Name Enter the name of the roll over effect.

First Image Location Specify the image to be shown in the 
normal, or ‘off’ state.

Second Image Location
Specify the image to be displayed when the 
mouse ‘rolls over’ the image.

Preview After you specify the two images, you can 
preview the roll over effect in this dialog 
box.

Remove Rollover Effect
When selected, the rollover effect will be 
removed.

Reference When you insert the script for the Rollover Effect into the 
document, the first image is displayed at the current cursor 
position. If you modify the size of the first image from the 
Appearance tab in the Image Properties dialog box that appears 
when you double click on the first image, the size of the second 
image will be modified to the same size as the first.
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To modify the contents of the script for the Rollover Effect, after 
insertion, select the Script Wizard from the Script command on the 
Insert menu while the image selected, or click the Script Wizard 
button on the Standard toolbar.

Caution When using the script for Rollover Effect, do not use spaces or 
special symbols for the name. If you do, when you point to the 
image in the web browser., the Script Error dialog box will appear 
with the message; "An error has occurred in the script on this 
page".

Animation Effect Creates an animation effect on the current paragraph or layer. To 
give animation effect to a layer, you must first create a layer. When 
applying animation effects to a paragraph, the paragraph does not 
have to include text or images. But to clearly see the effect, you 
should enter some text or an image. For the same reason, enter 
text or images in the layer as well. The Animation Effect script 
works only in Internet Explorer or Netscape 4.x.

While placing the cursor position on a paragraph or layer, select the 
Animation Effect from the Script Wizard in the Script command on 
the Insert menu, then a dialog box appears as below.

Layer Name If a layer is selected or the cursor position is 
in it, the name of the layer is displayed 
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here. If the cursor is in a paragraph, the 
name of the layer will be suggested, like 
"alayer1", "alayer2", automatically. You can 
also enter a name of your own choice.

Starting Position Specify the starting position of the 
animation. The final position is where the 
animation will stop. You need to set this to 
see the effects clearly.

Trace Specify the type of trace for the animation. 
You have three options; Line, Curve, Spiral.

No Animation Indicates the animation effect is removed.

Preview You can preview how the animation will 
moves in a web browser from this window.

If you click this  button, you will see more detailed options. The 
options disappear when you click this  button again.

Starting Condition Specify the condition on which the 
animation begins.

Starting Time Specify how long it takes before the 
animation begins after the starting condition 
is satisfied.
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Total Steps Specify the number of steps in which the 
animation is displayed. The larger the 
numbers are, the smoother and slower the 
animation will be.

Only for IE
The Zoom In/Out and Split Each Word functionalities are available 
only in the Internet Explorer.

Zoom In/Out Characters will be larger or smaller when 
being animated. This doesn’t work with 
images.

Split Each Word Words will be animated one bye one.

A pinion appears as below where the animation effect script is 
inserted.

Drop-Down Menu You can create a script that produces a drop down menu and takes 
the viewer to a specified URL once an item on the menu is selected.
Namo WebEditor 3.0 User Manual 5-35



INSERT
Script Wizard55
List Window Indicates a region where items of the drop down menu 
are to be displayed.

Choice Enter the name of the item you want to add to the menu.

URL Enter the name of the URL or document to which the 
viewer will be moved to when an item on the menu is 
selected.

Add When you click the Add button, after entering Choice and 
URL, the item is added and will be displayed in the list.

Edit To modify the contents of an item, select it and modify 
the Choice and URL information. When you are 
finished, click the Add button.

Remove Removes the selected item from the list.

Up Moves the selected item one step higher.

Down Moves the selected item one step lower.

Target Frame Use this to specify the target frame where the 
document linked to the drop down menu item will be 
displayed. For more information on the target frames, 
see Frame Properties(8-13). When the document has 
no frames, leave it as "_self".

Height Specify 
how 
many 
lines on 
the drop 
down 
menu 
will be 
visible 
without 
a scroll 
bar.
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If you specify the number of lines as a lesser value than the 
number of items, a scroll bar will appear as shown below.

Jump Button Allows you to create a script that can allow the user to ‘Jump’ from 
page to page at the press of a button, literally!

Characters on Button Enter the content to be displayed on the 
button.

URL/Back/Forward Enter the name of the URL or document to 
which the visitor will be directed to when 
the button is pressed.

Target Frame Specify the target frame that the URL will 
be set in when the button is clicked. For 
more information on the type of target 
frame to use, see Frame Properties(8-13). 
When the document has no frames, leave it 
as "_self".
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Refresh Page Creates a script that redirects a visitor after a specified period of 
time.

Time Specify the delay before moving to the specified URL.

URL Enter the name of the URL or document where the 
visitor will move after the specified delay.

Remove Refresh
Removes the Refresh effect.

Access Information Allows you to create a script that will gather information from the 
visitor.
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Name of the Form Enter the name of the form where the 
visitor information is to be displayed. You 
can use the default if you are not sure what 
to put. 

Name of the Form Element
Enter the name of the text box to be used 
to display the visitor's information. Again, 
you can choose the default.

Visitor’s Name Enter the contents of the message box that 
will ask the visitor's name.

Date... When selected it will display the last day the 
document was changed.

Visitor’s IP... Displays the visitor's IP. Available only in 
Netscape.

Visitor’s Host... Displays the name of the visitor's host. 
Available only in Netscape.

Reference When you insert the Access Information script into a document, a 
form is created and the one-line text box form field appears. To 
modify the size of the text box where the information is displayed, 
double click the one-line text box form field. When the One-Line 
Text Box Properties dialog box appears, you can modify the Width in 
Characters and Maximum Length of the field.
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Clock in a Box Allows you to insert a virtual watch on your site, with time and 
date.

Name of the Form... Enter the name of the form to be used to 
display the time or use the suggested value.

Name of the Form Element...
Enter the name of the one-line text box or 
use the suggested value.

Time Format Specify the type of display, you can choose 
from either 24 hour or 12 hour.

Reference When you insert the Clock in a box script into a document, a form is 
created and the one-line text box form field appears. To modify the 
size of the text box where the information is displayed, double click 
the one-line text box form field. When the One-Line Text Box 
Properties dialog box appears, you can modify the Width in 
Characters and Maximum Length of the field.
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Scrolling Text in a Box Allows you to create scrolling text in a form field.

Name of the Form Enter the name of form to be used or 
use the suggested value.

Name of the Form Element Enter the name of the one-line text 
box where you will insert the scrolling 
text, or use the default value.

Text Enter the text that you use in the one-
line text box.

Scrolling Period Specify the cycle during which the text 
passes by in the one-line text box. The 
smaller the number, the faster the text 
will move.

Reference When you insert the Scrolling Text in a Box script into a document, a 
form is created and the one-line text box form field appears. To 
modify the size of the text box where the information is displayed, 
double click the one-line text box form field. When the One-Line 
Text Box Properties dialog box appears, you can modify the Width in 
Characters and Maximum Length of the field.
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Scrolling Text in the Status Bar

Allows you to create text that scrolls in the status bar of the 
browser.

Text 1 Enter the text that appears first.

Text 2 Enter the text that appears second.

Text 3 Enter the text that appears last.

Reference To change the contents or options of a script, after inserting it into 
the document using the Script Wizard, you must select the image, 
paragraph, layer or form field first and then select the Script Wizard 
from the Script command on the Insert menu. It is necessary to 
follow the above steps as there may be more than one of the same 
scripts in one document.

The Scrolling text in the Status Bar can be inserted only one time in 
each document, so you don't have to select anything beforehand. 
You can modify the Scrolling text after selecting the scrolling text in 
the status bar from the Script Wizard on the Script command on the 
Insert menu.
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Foldable Contents This script will create a small table of contents that visitors can view 
and navigate through. This is similar to a site map.

List Window A region where the titles of the contents are to be 
displayed.

Add Adds a new title below the selected title.

Remove Deletes the selected title.

Up Moves the selected title one step higher.

Down Moves the selected title one step lower. 

Name Indicates the name of the selected title. When you 
adjust the name, the title name in the contents will be 
changed automatically.

URL Indicates the name of the selected title's URL. 
Changing of URL will be automatically updated to the 
contents in the List window.

Target Frame Specify the target frame where you want to display 
the document linked to the title on the drop down 
menu. For more information on the target frames, see 
Frame Properties(8-13). When the document has no 
frame, leave it as "_self".
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If you click the Next button after creating the contents as shown 
above, a dialog box will then appear to help you decide on the 
appearance of the contents.

Font Select the font that will be applied to the selected title.

Size Select the font size.

Color Select the frame color.

Background Select the background color.

HighLight If you select the Coloring Rollover Effect option, then 
specify the color which will be displayed.

Coloring Rollover Effect
If you select this option it will activate the roll over 
effect. That is, when one points to the item, the color 
changes to the HighLight color.

Height Specify the height of the selected title.

Indentation Specify the indentation of the selected title.
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When you point to the inverted triangle button, the pointer will 
change to a finger. If you click on it, sub titles will then appear. With 
another mouse click, the menu will collapse. If you click the title of 
the URL which is specified, you will be sent there.

Reference The Foldable Contents script works only in Internet Explorer and 
Netscape 4.x or higher.

Layer Action Creates a script that makes an event in a layer affect another layer.

Layer Name Select the layer which the events will occur on.

List Window Displays the Event, Action and Target specified on the 
selected layer.

Event Type Allows you to select the types of event that will be 
checked on the selected layer. The events to be 
checked are OnClick (Click), OnmouseOver (Moving of 
pointer onto the layer), OnmouseOut (Moving of 
pointer out of the layer).
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Action Type Specify the action to be taken on the target layer 
when the specified event occurs. Show Layer makes 
the target layer visible whereas Hide Layer makes it 
invisible. You can choose from either.

Target Specify the target layer.

Add Adds the current setting (event type, action type and 
target) to the List.

Edit Modifies the selected items of the List to the current 
setting.

Remove Deletes the selected items from the List.

Reference The Layer Action script works only in the Internet Explorer and 
Netscape 4.x or higher.
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This allows you to insert a script into the body of a document. It 
means inserting a script to be applied to the internal structure of 
the document (in the <body> tag). The scripts being applied to the 
entire document are ones like the OnmouseOver, they must be 
inserted in Head Script.

When you select Body Script from the Script command on the Insert 
menu, the Body Script dialog box appears as shown below.

Language Specifies the type of script language to be inserted 
into the document. You can choose from JavaScript, 
VBScript and ASPScript.

Style This allows you to use CSS to change link colors and 
other options supported by CSS specification. When 
you click the Style button, the Style dialog box 
appears. For the usage of the Style dialog box, see the 
Paragraph Style(6-25).

Extended When you want to specify an attribute that is not in 
the current HTML protocol or a newly created 
attribute, Namo WebEditor does not support the 
options you require. This Extended option will allow 
you to do but you must enter this attribute manually.
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Head Script Click the Head Script button to create a script to be 
applied to the entire document that is in the <head> 
tag.

. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . HEAD SCRIPT
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Inserts a script between the <head> tags. This will be applied to 
the entire document. 

When you select the Head Script from the Script command on the 
Insert menu, the Script tab appears in the Document Properties 
dialog box. Enter or copy scripts here. 

Reference JavaScript is a script language developed by Netscape that is used 
to build a dynamic web site. Internet Explorer and Netscape 
Navigator both support JavaScript, but not 100% in Internet 
Explorer. JavaScript supported in Internet Explorer is called as 
JScript.

Visual Basic Script, developed by Microsoft, is a scripting language 
supported by Internet Explorer. It is based on the Visual Basic 
language, but with a much simpler structure than JavaScript.

ASP (Active Server Page) Script indicates a script that requires an 
ASP page on a web server. Visual Basic Script and JScript can be 
used together for Active Server pages.
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This option allows you to insert a Java applet, Plug-in or ActiveX 
control.

When you point to the Advanced command on the Insert menu, a 
sub menu of three items will appear as shown below.

Reference Java is an advanced programming language developed by Sun 
Microsystems. Java has many useful functions used on the web. A 
Java applet indicates a lighweight Java application. They can be run 
in web browsers compatible with Java like.

A Plug-in is a software module that must be added to the web 
browser’s software. It helps you use a new feature or service not 
available with traditional HTML. 

An ActiveX control is similar to that of a Java applet, but differs in 
that it directly uses all the features of a Windows. 

As of today, a standard version of Internet Explorer will support 
Java applets, JavaScript and ActiveX controls. Netscape Navigator 
only fully supports Java applets and JavaScripts but can also work 
with ActiveX controls and Visual Basic Script with additional plug-ins 
(see the Netscape site).
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This gives you the option of entering in a Java applet.

When you select the Applet on the Advanced command on the Insert 
menu, then the Applet Properties dialog box appears.

Code Enter the file name of the Java applet to be inserted. 
The extension name of the Java applet should be 
'class' or 'cla'.

Codebase Enter the path of the Java applet file. You can enter 
the URL for it.

Name Specify the Java applet name. It is best to use letters 
while doing this. The name you enter here is not the 
file name but the name used to tell one Java applet 
from another.

Alt Text Enter the description for the applet. When a web 
browser can't display the applet, a surfer can see the 
description instead.

Alignment Basically the alignment is the same as that of the 
image. For more information, see Image(5-7).

Size Specify the width and height of the screen in which the 
Java applet software is launched. When you use pixels, 
you can specify the fixed size. While you can specify 
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the proportional�size to the web browser window, 
using percentages.

Space Specify the margin around the screen where the Java 
applet software is to be launched. When you specify a 
Horizontal value, you will put spaces in pixels as 
specified to the left and right of the applet screen. 
When specifying the Vertical value, you put spaces at 
the top and bottom.

Parameters Use this when you enter the general variables that will 
be handed to the Java applet software. When the 
Parameters dialog box appears, click the Add button. 
Then enter the parameter name and value.

Caution Namo WebEditor only helps you enter the size of the Java applet 
and the associated directives; it doesn't launch it. Therefore, it does 
not show how the Java applet works. To check if it works properly, 
preview the web page in your web browser.

. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . PLUG-IN
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This allows you to insert a plug-in into your web document.

When you select Plug-In from the Advanced command on the Insert 
menu, then the Plug-In Properties dialog box appears.
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Source Specify the file name of the Plug-in.

Alt Text Enter the description for the Plug-in. When a web 
browser can't display the plug-in, the viewer will see 
the description instead.

Alignment The alignment is the same as that of the image. For 
more information, see Image(5-7).

Size Specify the width and height of the screen in which the 
Plug-in file is to launch. When you use pixels, you can 
specify the fixed size. While you can specify the 
proportional size to the web browser window by using 
percentage.

Hide Plug-In When you select this option, the plug-in becomes 
invisible on the screen. If you activate the Format 
Marks, you can see the plug-in format mark.

Space Specify the margin around the plug-in file. When you 
specify a Horizontal value, you put spaces in pixel as 
specified to the left and right of the plug-in. When 
specifying the Vertical value, you put spaces at the top 
and bottom.

Border Put borders around the plug-in file. Because the 
Internet Explorer doesn't support borders, it cannot be 
seen.

. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . ACTIVEX CONTROL
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This allows you to enter in an ActiveX control.

When you select the ActiveX control... from the Advanced command 
on the Insert menu, then the ActiveX control dialog box appears.
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Class ID Enter the class ID of the ActiveX control to be inserted. 
All ActiveX controls have unique class IDs. When you 
click the drop down menu button, the available 
(installed on your system) ActiveX control list appears.

ID Enter the ID that is needed to use the inserted ActiveX 
control in script.

Alt Text Specify the text to be displayed if the ActiveX control 
cannot be loaded.

Codebase Enter the path of the ActiveX control.

Alignment The alignment is same with that of image. You can see 
Image(5-7).

Size Specify the width and height of the ActiveX control. 
When you use pixels, you can specify the fixed size. 
While you can specify the proportional size to the web 
browser window by using percentage.

Space Specify the margin around the ActiveX control. When 
you specify the Horizontal value, you put spaces in 
pixels as you specified at the left and right of the 
control. When specifying the Vertical value, you put 
spaces at the top and bottom.
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Parameters Use this to enter the general variables that will be 
handed to the ActiveX control. When the Parameters 
dialog box appears, click the Add button and enter the 
parameter names and values.

Caution Namo WebEditor only helps you enter the ActiveX control, it doesn't 
launch it. Therefore, it does not show how the ActiveX control 
works. To check that it works properly, preview the page in a web 
browser.

. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . THEME OBJECT
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This allows you to insert a Theme Object into your web document. 
When you select the Theme Object command from the Insert menu, 
the Theme Object Property dialog box appears. For more 
information on this dialog box, see Theme(6-42).
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Sets specific content as a hyperlink. 

When you select the Hyperlink command from the Insert menu or 
press the <F9> key, the Create Hyperlink dialog box appears.

URL Specify the location to be connected to the hyperlink. 
You can specify the URL or name of the HTML file, 
bookmark or image. If the target is a document in the 
same web server, you may then simply enter the path 
and file name. 

Bookmark When you want a bookmark in the linked document as 
a target, specify the bookmark name here. When the 
linked document includes no bookmark, the bookmark 
list is empty. If you specify the URL, however, you can 
see the list of all bookmarks that are set in the current 
document. You can then either select a current 
bookmark, or choose to create your own. 

Target Frame When you create the hyperlink from a document that 
has frames, you will need to specify the target frame 
into which the linked document will open. You don't 
have to specify this in a document

�without frames.

Hyperlink can be easily created with the above three contents. If 
you use the following three buttons, URL specification will be easier.
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Browse Open the Open dialog box. You can specify a file on 
the hard disk through this dialog box.

Open Files Show all the files open at the current time. You can 
select from them.

Clear Link Remove all the contents of the URL field.

URL components are used when you specify the hyperlink location 
more precisely.

Scheme Specify the type of scheme of the hyperlink. When 
creating a normal hyperlink, select 'http://'. To launch 
mail software, select 'mailto'. When you select the 
mailto, 'mailto:' appears instead of 'http://'. You then 
need to enter the e-mail address at the end of 
'mailto:' (e.g. 'info@namo.com').

Host Enter the name of the web server to be connected to 
the hyperlink.

Path Enter the path and file name that will follow the URL of 
the web server.

Bookmark Specify the bookmark name when you want the 
bookmark to be targeted in the linked document.

Parameters Enter the information wanted on the web server, or to 
be passed over to a CGI script or other program. The 
contents entered as the Parameters appear next to ‘;’ 
in the URL field.
5-56 Namo WebEditor 3.0 User Manual



. .
 . 

. .INSERT
Remove Hyperlink
Query This allows you to transfer certain information to CGI 
scripts or other similar programs. The contents 
entered as the Query appear at the next of '?' in the 
URL field.

Encode Path Adjusts the special characters in the URL in the way 
that is agreed on in advance. For example, it changes 
the '@' to '%40', and space to '%20'.

Decode Path Uses the special characters in the URL as it is entered 
first. For example, it changes the '%40' to '@', and 
'%20' to a space.

Reference To check the hyperlink in the edit window, select the Follow 
Hyperlink from the menu which appears when you right click on a 
hyperlink, or when you click while pressing the <Ctrl> key on your 
keyboard.

. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . REMOVE HYPERLINK

�������.���&�
��!���	�

���	����-�


This will remove the hyperlink. When you select the Remove 
Hyperlink command from the Insert menu with the cursor on the 
hyperlink, the hyperlink will be deleted.

. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . EQUATION
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Select, to enter a math formula at the insertion position using the 
Equation editor.

When you select the Equation command from the Insert menu, the 
Equation dialog box then appears. After entering the formula here, 
click the OK button.

On the Visual tab you would usually enter the formula using the 
mouse. However, while on the Script tab, you can enter the formula 
using the Tex/LaTex grammar.
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Visual On the Visual tab, enter the equation using formula and special 
symbol buttons. You now no longer have to remember complex 
symbols and formulas!

1 Use the keyboard when entering all normal variables and symbols. 
A triangle will take the place of a mouse cursor here. When you 
click the formula button you want, the formula will be entered. The 
triangle then appears where the variable or symbol is to be 
entered.
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2 If you click the fraction button, it is displayed as shown below. 
When you click the magnifying glass button, you can resize the 
formula to your specifications.

3 After completing the formula, click the OK button. The formula then 
appears at the current cursor position.

Caution The formula entered by using the Equation editor is inserted as an 
image. It is saved in the same folder as your main HTML file. 
Although it is an image, you can not adjust its properties.
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Script On the Script tab you create the formula by entering the formula 
script directly. This is rather difficult for even advanced users. On the 
formula script, see the 'equation.html' document in the 'DOC' folder, 
it's one of the sub folders of the folder where the Namo WebEditor is 
installed. It will give you more information on formulas.

. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . ETC.
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When you point to the Etc. command on the Insert menu, a sub-
menu of five items appears.
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Nonbreaking Space This will enter a nonbreaking space(&nbsp) into your HTML 
document. This allows you to put more than one space between 
words.

According to the HTML protocol of W3C, two or more successive 
spaces are counted as only one space. Thus when you open a text 
format file in HTML format, all successive spaces are replaced with 
one single space.

There are times when you will have to enter the successive spaces 
into your HTML document, this is when the Nonbreaking Space 
comes in very useful! In Namo WebEditor you don't have to select 
the Nonbreaking Space on the Etc. command every time you want 
to enter in a successive space. In Namo WebEditor, each time you 
press the spacebar after the first space, Nonbreaking Spaces are 
automatically entered.

Time/Date This will enter the time and date at the current cursor position.

When you select Time/Date from the Etc. command on the Insert 
menu, the Date/Time dialog box appears. Select the type you want, 
and click the OK button. The current time and date is inserted at 
the current cursor location as text.

Component This option allows you to enter a component at the current cursor 
position. You can select the type component from the list of forms 
you frequently use.

When you select the Component from the Etc. command on the 
Insert menu, the New dialog box appears. Select the component 
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here and click the OK button. The component is then inserted into 
the current document.

When the Insert Onto the Current Document option is inactive, a 
new document is automatically created and the selected component 
will be inserted inside.

File This allows you to insert a file into your HTML document. The file to 
be inserted will have to be in the HTML or text format.

The file will be inserted at the current cursor position by selecting 
File from the Etc. command on the Insert menu. If you select the 
Open command from the File menu, the document will be displayed 
in a new edit window. In this way you can merge the two 
documents.

HTML Tag This allows you to insert a tag used in a particular browser, or an 
extended tag, into the document. When you want to specify an 
attribute that is not in the current HTML protocol or a newly created 
attribute, Namo WebEditor does not support the options you 
require. This option will allow you to do but you must enter this 
attribute manually.

When you select the HTML Tag on the Etc. command on the Insert 
menu, then the Extended Tag and its Attributes dialog box appears. 
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The tag and attributes you enter in this dialog box can't be shown 
in the Namo WebEditor edit window, you will need to launch a web 
browser to check it.

When you click the Add button, the Attribute Name and Value dialog 
box appears. After entering the name and value of the attribute, 
click OK. You can also add the attribute as you want and then click 
OK.
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