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Thank you for purchasing Namo WebEditor 3.0.

Below are instructions for the use of this manual.

In Chapter 1, you will learn some of the basic functions of Namo 
WebEditor. You will be taken through the entire process of creating 
a Web site, from building and modifying it, to using the Template 
Wizard, to publishing it to the Internet. Chapter 1 will also show 
you how to import the contents of any Web site and forward it by e-
mail to wherever you want.

In Chapters 2 through 10, the manual goes through every 
command on the program menu, in the same order as you see it in 
Namo WebEditor. When necessary, additional information is 
provided in the form of References or Cautions.

In Chapter 11, you get to learn about advanced Internet 
development technologies like Layers, Time Lines, the Namo GIF 
Animator, background information and multi-language support of 
Global IME. If animation effects using a layer interests you, refer to 
the Layer and Time Line sections in this chapter. If you want to 
input Japanese or Chinese into your HTML document, the part on 
the Global IME will be helpful to you.

At the end of the manual is the Index where you can get to any 
part of the manual quickly and easily.

More information on using Namo WebEditor is available in the 
online manual at http://www.namo.com/manual. Please note that 
you must register your software immediately upon installation. 
Also, customer support will only be provided once you have 
registered your software.

Namo Interactive Inc. Web Site http://www.namo.com

Namo WebEditor Online Manual Web Site http://www.namo.com/manual

Technical Support support@namo.com
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The information in this document is subject to change without notice. The names of 
companies, products, people, characters and/or data mentioned herein are fictitious.  All 
the contents of this manual and Namo WebEditor are protected by international copyright 
and computer program protection laws.

No part of this document may be reproduced or transmitted in any form or by any means, 
electronic or mechanical, for any purpose, without the express written permission of Namo 
Interactive Inc. If, however, your only means of access is electronic, permission to print 
one copy is hereby granted.

Copyright ©1997-1999, Namo WebEditor of Namo Interactive Inc. All rights reserved.

First published on May, 1999

For more information on Namo WebEditor 3.0,
please visit our Web site at  www.namo.com or email us at the following addresses.

Namo Interactive Inc. http://www.namo.com

General Information info@namo.com

Order Information order@namo.com

Customer Service support@namo.com

TRADEMARKS

All terms mentioned in this book that are known to be trademarks or service marks have 
been appropriately capitalized. Use of a term in this book should not be regarded as 
affecting the validity of any trademark or service mark.

Microsoft and the Microsoft logo, the Microsoft Internet Explorer logo, Outlook, MS, MS-
DOS, Visual Basic, ActiveX, Verdana, Windows and Windows NT are registered trademarks 
of Microsoft Corporation in the USA and other countries.

CompuServe is a regsitered trademark of CompuServe, Inc.

Arial is a trademark of The Monotype Corporation.

Nestcape Communicator is a registered trademark of Nestcape Communications 
Corporation.

Java is a trademark of Sun Microsystems Inc.

Other product and company names herein may be the trademarks of their respective 
owners.
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Building A Web Site 1

Namo WebEditor offers an easy way to build your web site. With 
Namo WebEditor you don't have to know complex and difficult 
HTML syntax. This is something that had once prevented ordinary 
users from creating their own web site. In this chapter you will see 
just how easy it is to build and publish your web site using Namo 
WebEditor.

Getting Started with the Namo WebEditor 3.0
This is a guide for people who are using the Namo WebEditor for 
the first time. You will get some basic knowledge about using Namo 
WebEditor. Once you finish this guide, you will be able to easily 
enter and edit text and images.

Building a Web Site Quickly
This will show you how to create your web site in just a few 
minutes using the template wizard function.

Publishing Your Web Site
Once your web site is created, you are ready to publish it. We have 
made drastic improvements in the publishing feature since our 
previous release.

Handling Internet Information
Namo WebEditor 3.0 is equipped with new features that make it 
one of the most indispensable HTML editing and publishing 
programs on the market.
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. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . GETTING STARTED

Before you arrive at your final HTML document, you must have 
some knowledge on how to use Namo WebEditor.

Launching WebEditor

Launch the Namo WebEditor from the desktop icon. If you did not 
make the desktop icon, please select Start-Program-Namo 
WebEditor3-Namo WebEditor3, or the location specified by you. The 
Namo WebEditor window will then open.

The Namo WebEditor screen consists of a title bar, toolbars, edit 
window, scroll bar, status bar and buttons.

When you launch Namo WebEditor, a blank document will appear as 
shown below.

Entering Text After Namo WebEditor is launched, the cursor is the only item that 
will blink in the white space. This space is called the edit window, 
this is where you will enter text. 

Mouse pointer. Its shape 
varies with your editing 
actions. You can enter text 
when it is in I shape. 

Cursor. The blinking vertical line. 
Indicates the position where the text 
is entered.
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As you enter text you will notice it becoming underlined in red. The 
red underline indicates that the auto spelling check function of the 
Namo WebEditor is active. Once a word is completed, the red line 
will disappear if the spelling is correct. If the spelling is not correct, 
or the word happens to be a pronoun not currently in the 
dictionary, the red line will remain. For further information on the 
spell check feature, see Spelling(9-1).

If you press the <Enter> key while entering text, a new paragraph 
will begin and the cursor position moves back to the left margin. 
Where a paragraph ends, a Paragraph Mark appears. You can make 
the mark appear or disappear by clicking the Show/Hide Paragraph 
Marks button on Standard toolbar.

The difference between an HTML document and a text document is 
that a blank line is inserted between paragraphs in HTML. To begin 
a new line without starting a new paragraph, press <Shift+Enter>. 
This new line begins without a blank line separating it.

When you enter the e-
mail address, the 
hyperlink is created from 
it automatically. 

Where a new paragraph begins, 
the Paragraph Mark appears 
and the new line is inserted.

Where you change the line by 
pressing the <Shift+Enter>, the 
Line Break appears. A new line 
is not inserted. If you continue entering 

the text to the end of 
one line, the new line 
begins automatically. It 
doesn't start a new 
paragraph. 

Standard toolbar
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Editing Text In the early days of HTML, anyone who edited the HTML document 
had to remember and enter all the complex tags. But with Namo 
WebEditor you no longer have to do this!

For example, to adjust the shape of characters and paragraphs, just 
use the Format menu or Format toolbar. For more information on 
the Format menu, see Format(6-1).

By using Namo WebEditor, beginners could enter text or change the 
font type and size as easily as in a word processor. Where you show 
your work is really the only main difference between using Namo 
WebEditor and a word processor. With Namo you display the HTML 
document on the Internet, or send it as an e-mail. Whereas with a 
word processor, you print it on paper. Note that you can also print 
an HTML on paper.

To change a paragraph to a Heading, place the cursor position on 
the paragraph and select the paragraph type you want from the 
Change Paragraph Style sub menu on the Format toolbar. The shape 
of the characters and paragraph will then change as your selection. 
If you don't like how it looks, you can easily try another type.

The Format toolbar contains tools to control character and paragraph appearance.
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With the cursor position on a paragraph, click the Align Center button on the Format
toolbar. The paragraph will then be centered on the screen.

To display text in yellow, select the text and specify yellow as the background from
the drop down menu. To select the text, drag the mouse over the text or click the
beginning of the text and then click the end of the text while holding <Shift> key.
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Inserting Image Inserting images into the HTML document is also very easy. You can 
select from over 3,400 clip art images provided by Namo WebEditor.

Place the cursor position where you want to insert an image, then 
click the Insert Clip Art button on the Toolbar.

In the Clip Art window, select the image type in the left window, 
then select the image you want in the right widow. Then click the 
Insert button.

The image is inserted at the current cursor position. You can then 
modify the size of the image. 
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Inserting Background Image

This allows you to insert background colors and images. When you 
select the Document Properties command from the Format menu, 
the Document Properties dialog box will appear. Click on the Clip 
Art... button from the dialog box to specify the background image.

In the Clip Art window, select the image you want from the Texture 
sub folder in the Background folder. Then click the Insert button. 
The image you specify will appear as the background of the 
document. For more information on the background image, see 
Document Properties(6-16).
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Viewing HTML Code At the bottom of the edit window are the Edit, HTML and Preview 
tabs. Until now the edit window has been the only one visible on 
the screen, because the Edit tab was selected. 

When you click the HTML tab or press the <F6> key, the HTML 
window will open. You can now see HTML tags along with the text 
you entered. Once you see these HTML tags, you will appreciate 
how easy it is to use Namo WebEditor! 

The text you entered is displayed in black, while the HTML syntax is 
displayed in purple (tag) or red (attribute). The words displayed in 
blue are the attribute values. 

If you have no knowledge of HTML, you should not adjust or delete 
these tags. This could cause your document to show improperly in 
the browser. To return to the edit window, press the <F6> key or 
click on the Edit tab.
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Preview in Web Browser

If you click the Preview tab, you can then see how the document 
will look in Internet Explorer. Internet Explorer 4.0 or higher is 
required for this function. 

When you are using Netscape, press the <F12> key on your 
keyboard. Netscape will start and will display your document.
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Saving Documents You can save the document by: selecting the Save command from 
the File menu, pressing <Ctrl+S>, or by clicking the Save button on 
Standard toolbar. Since this is the first time that you save the 
document, the Save As dialog box appears. Find the folder where 
you want to save the document, enter the file name, and click the 
Save button.

If you used images in your document, the dialog box will then 
appear asking whether Namo WebEditor should save the image files 
to a path inside the directory of your HTML file. When there is no 
particular reason not to save them, click the Yes button. You can, 
however, specify the folder where you would like them saved. If this 
folder does not exist, a dialog box will appear asking whether Namo 
WebEditor should create it. Click the Yes button in the dialog box.

For more information on saving a document, see Save(2-16).
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Closing Document After you are finished editing a document, you should close it. To do 
this, select the Close command from the File menu or press 
<Ctrl+F4> on your keyboard. You can also do this by selecting 
Close on the menu that appears when you right click on the current 
document tab in the edit window.

If you close the document after making changes to it, a dialog box 
will appear asking “Save changes to filename?”. To save it, click the 
Yes button.

Click the Cancel button, if you want to cancel this dialog box and 
return to your document.

Exiting WebEditor If you are done with all editing work and want to close Namo 
WebEditor itself, select the Exit command from the File menu. You 
can also exit by pressing <Alt+F4> on your keyboard. When there 
are documents that have been changed but have not yet been 
saved, a dialog box asking whether Namo WebEditor should save 
the documents or not will appear. To save, click the Yes button or if 
you choose not to save, click the No button.

If you changed the 
contents this sign 
appears.
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. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . BUILDING A WEB SITE QUICKLY

Using the Template Wizard feature in the Namo WebEditor is a 
quick and easy way for you to build an entire web site. With the 
Template Wizard you will use a model, called a theme, as the base 
of your web site; thereby giving you consistency to its structure. It 
is up to you to fill in the substance of the site once the template has 
been created.

Template Wizard When you select the New Project command from the File menu, the 
Create New Project dialog box will appear. A document makes up an 
element of your web site whereas a project manages multiple 
documents as an integrated part of your site. This will allow 
convenience and speed when editing and maintaining your site.

Select the Template Wizard from within the Create New Project 
dialog box and click the Next button. You can then specify the folder 
for the project using the Browse button.

When a folder doesn't exist as you specified, a dialog box asking 
whether Namo WebEditor should create the folder or not will 
appear. To create the folder, click the Yes button, or click No and 
select a pre-existing folder.
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With the Select Theme dialog box open, you can view the themes in 
the Preview window by clicking the theme name. Namo WebEditor 
has 71 themes for you to choose from. To get a more realistic view, 
click the Actual View button. 

When you click the Actual View button, the Theme Gallery dialog box 
appears. In this dialog box, you will have a larger view of the 
selected theme. You can also arrange the buttons in the theme 
horizontally, rather than vertically, by selecting the Horizontal 
option. In the preview box you can also see the rollover effect that 
pertains to the images when they are pointed with the mouse. After 
selecting the theme you want, click the Apply button.
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When you click the Apply button in the Theme Gallery dialog box, 
then the Select Theme dialog box appears. If the selected theme 
appears in the Preview window, click the Next button.

You now are given two options; Personal and Company. These will 
give you a general topic layout for your site. Decide which one suits 
your need and click the Next button. If you select the Horizontal 
Button option in the Select Template dialog box, the buttons will be 
arranged horizontally.

The list of pages to be included in the selected template will be 
shown in the Select Pages dialog box. Click the Next button after 
selecting, or deselecting the pages you don’t want to be included.
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Enter the web site name (note this name will be displayed on your 
banner. It is for your personal use only, not as a filename) and click 
the Finish button.

The web site will be created, saved and the first page of your web 
site is displayed in the edit window.

Congratulations! Now you have your own web site waiting to be 
filled up with information.
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At the left is the Project Window. It allows you to easily manage 
your web site.

Editing a Theme Object

Of the images that make up the theme such as the Banner, Button, 
Bullet, Horizontal Ruler, Cool, Hot and New, you can enter any text 
you want, without using a graphic program!

Select the banner on the top by clicking in it, then right click or 
select the Theme Object... command from the Insert menu. The 
Theme Object Property dialog box then appears. The dialog box will 
also appear when you double click the banner in the edit window.
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You can edit the text and specify the new font and size in the 
Theme Object Property dialog box.

In your HTML document you should not use strange or uncommon 
fonts. When the font you specify is not installed in the browsers 
computer, the document will be displayed in the first font available 
on their system. However, the text that is entered on the Banners 
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and Buttons are converted onto the image, allowing you can specify 
any font you want.

The Banner then appears as specified. 

When you make 
changes to the project 
document, a '*' mark 
appears to the right of 
the file in the Project 
Window. 
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Changing Image Let's now change the image on the first page of the sample web 
site. When you double click on the image in the first page, the 
Image Properties dialog box appears. To change this image to one 
from your hard disk, click the Browse button and search for another 
image (.GIF or .JPG) file. Then the Open dialog box will appear.

We are going to change the existing ‘Personal Homepage’ image to 
a flower. You can choose whatever image file you have instead of a 
flower. Move to the folder where the flower image file locates by 
pressing the drop down menu button. Select the flower image and 
click the Open button.

If you want to insert an image from the web, enter the exact URL, 
including the filename, into the Location(URL) field. For example, 
http://www.namo.com/image/flower.gif.
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The selected image now appears, replacing the previous image.

After saving the document, you can preview it in the web browser 
by pressing the preview button in Standard toolbar.
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. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . PUBLISHING A WEB SITE

To publish your web site on a web server you must first have an 
account setup on it with login, password, and folder information for 
your files. Any host that allows you to upload your web site via FTP 
will be acceptable.

Registering Publish Information

When you select Publish Information from the Site Management 
command in the Tools menu, the Site Information dialog box will 
then appear. Commonly used site hosts are registered here by 
default.

If your host is on the list, it is easy to register the information. To 
do this, select your host and then click the Modify button.

Because all the information needed is entered by default, simply 
complete the Username and Password field.
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After entering the Username and Password, modify the Username in 
the Location field, then click OK.

Close the Site Information dialog box by clicking the Close button.

When you are publishing on your company's web server, you will 
need to consult the server administrator. After getting the 
information you need, click the Add button in the Site Information to 
enter the Site Information. See Manage Site Information(2-23).
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Checking Hyperlinks Before you publish your site, you will need to check everything on 
your web site works. You can do this by previewing your site in a 
web browser. Sometimes, if you are making updates to a very large 
web site you can not view the entire site easily.

When you select the Verify Link option from the Site Management 
command in the Tools menu, Namo WebEditor will check all the files 
in the project and their linkage to each other. It then displays all 
broken hyperlinks in the Link Check section of the Result Window. 
For more information on checking links, see Incremental Verify 
Link(9-25).

Above, the image file 'flowers.gif', linked to 'index.html', is shown 
as having a problem. If the 'flowers.gif' file is not found, the 
hyperlink would be shown as broken. However, in this case, the fact 
that the 'flowers.gif' file is not included in the project is what 
caused the problem. 

This is because the change of the images on the first page 
(index.html) is not reflected in the project. Therefore you need to 
add the image file 'flowers.gif' to the project. To publish your web 

All the open files 
are displayed in 
yellow. 

Document 
designated as 
having a problem. 
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site without errors, all files that are linked to the web site should be 
included inside the project. 

Now you will need to find the image file 'flowers.gif'. According to 
the Target Link, the file is located in the 'images' folder. Click the 
'images' folder in the Project Window. A list of the image files found 
appears.

Find the 'flowers.gif' file in the list. When you find it, right click to 
open the menu. If you select the Add to Project on this menu, the 
file will be added to the project. 

If you check the hyperlinks again, no errors will be found. You may 
now save the project by selecting the Save Project command from 
the File menu.

When the link check is through, you can publish your site on the 
web server.

When you click 
the folder where 
the file is saved, 
the list of the 
image files 
appears.

Here the image 
file is found. 
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Publishing the Whole Web Site

When you select the Publish command on the File menu, or press 
the <F4> key while a project is open, the Publish dialog box will 
appear. In the left window the files in the current project folder are 
displayed. In the right window the files in the specified directory on 
the web server are shown. To connect to your host, choose its 
name from the drop down menu in the upper right hand corner.

After connecting to the server, select the files you want to publish. 
Since this is the first time you are publishing the files, you should 
select them all by clicking the Select All button at the bottom of the 
Publish dialog box.

The files and image 
folder of the project 
are shown. Because 
the files to be 
published are not 
selected yet, the 
check marks do not 
appear in the 
squares at the left.

The check marks 
are displayed at the 
left of the files 
selected to be 
published.
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When you click the Publish button, Namo WebEditor will begin to 
transfer the files one by one while displaying the transfer status of 
each.

When the squares to the left of the published files become green, it 
means they have been transferred. When prompted, click the OK 
button and Close the Publishing... dialog box.
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If the squares at the left of the files turn red, it indicates the files 
have not been published. It is possible that the files have been 
moved or deleted from your computer, and have not been saved or 
shown in your project. Check your links again.

Publishing Unmodified Files

Once you have published the project, and have modified your site, 
you will only need to republish a certain number of files.

When you select the Publish command from either the File menu or 
by pressing <F4> while the project is open, the Publish dialog box 
will appear and you will be automatically connected to the web 
server.

If you click the Select Modified button from the Publish dialog box, 
only the files modified after your last publish are selected. This 
saves you the time from having to select each individual file. 

The files and image 
folder of the project 
are shown. Because 
the files to be 
published are not 
selected yet, the 
check mark doesn't 
appear in the 
squares at the left. 
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When you click the Publish button, Namo WebEditor will begin to 
transfer the selected files, one by one, while displaying their status. 

Your web site is now updated. Check that your web site works 
correctly in a web browser, make sure you refresh/reload your page 
once you view it.

The check marks 
appear in the squares 
at the left of the 
selected files. The 
obscure check marks at 
the left of the 'images' 
folder indicate that not 
all the files in the folder 
are selected. 

You can select the files you are editing at the 
time by clicking the Select Editing Files button 
and adding the image files linked to the 
documents by clicking the Select Images Used 
in HTML Files button.

The squares at the 
left of the published 
files turn to green. 
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. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . HANDLING INTERNET INFORMATION

The importance of HTML documents has been growing as more 
people use the Internet to receive and transfer information. With 
Namo WebEditor you can effectively handle the information in web 
sites and e-mails. Even if you don’t have your own web site, Namo 
WebEditor can still be a great help to you by allowing you to 
process the information you receive from the Internet.

Importing Information from the Web

It's not easy to import specific web site information to a word 
processor. Namo WebEditor, however, supports the all HTML format 
so that all the contents you copy from Internet Explorer or 
Netscape will preserve their full HTML properties. Any graphics you 
see in your browser, including animated GIF files, will also be 
imported into Namo WebEditor.
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When you paste the contents copied from the web browser, Namo will display the
image after it has been downloaded. 

To select specific 
contents from the 
web browser, click at 
the beginning and 
drag to the end. To 
be more specific, click 
the cursor at the 
beginning of the 
document, and click 
another location 
while holding the 
<SHIFT> key down.

Press <Ctrl+A> to select 
the entire document. 

If you select the Copy 
Image option after 
selecting an image by 
double clicking it, you 
can then save the image. 

The image download 
status is shown. 
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Namo WebEditor excels in 
filtering the advertisements 
and logos that are no use to 
you, while importing the 
information you want. For 
example, when you import the 
feature story on the 
millennium bug, you can 
import only the linked lists of 
the related web sites. You can 
import the entire web site by 
selecting the Import from Web 
command on the Tools menu. 

Namo WebEditor can 
import not only images 
but also hyperlinks as 
well. If you import a 
highly detailed linked 
list, it can be more 
convenient than simply 
using a bookmark. 
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E-mail and WebEditor

Namo WebEditor helps you easily save multimedia information 
received via e-mail as well. You can also send an HTML document 
edited by Namo using e-mail software that is compatible with HTML 
documents, like Outlook Express. You could surprise your friend by 
sending a multimedia card on his or her birthday!

Let’s say you received this birthday card from your friend via your e-mail.

After pasting the contents into Namo WebEditor, edit it as you wish and you can
send it back to someone else!

After clicking 
the contents of 
the e-mail, 
press the 
<Ctrl+A> to 
select the 
whole 
contents. Then 
copy it by 
pressing 
<Ctrl+C>. 

In many softwares, 
it is very difficult to 
delete a table. But 
in Namo 
WebEditor, it is 
easy. Place the 
cursor position in 
the table, then 
move it out of the 
table by pressing 
<Shift+Esc>, then 
press <Delete> or 
<Backspace> on 
your keyboard. 
The table will then 
be deleted. 
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Auto Document Outline/TOC

In an HTML document where paragraphs style are applied to its 
titles, a document outline is automatically created. When you select 
the Document Outline option from the Tool Windows command in 
the View menu, or press <Alt+3>, the Document Outline window 
will appear to the left. In this window the titles of paragraph styles 
are displayed. 

If the '+' mark 
appears at the left, 
the sub outlines are 
hidden. While the '-' 
mark indicates all 
the sub outlines are 
shown.

If you right click the 
Document Outline 
window, you can specify 
up to which level of sub 
outlines are shown. 

When you click one 
of the outline 
headings, then the 
paragraph appears in 
the edit window. In 
this way you can 
move easily around a 
long document. 
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Making a TOC The outline is the same as the table of contents, therefore you can 
create a hyperlink from the table of contents by selecting the Make 
TOC command from the shortcut menu that appears when you right 
click the Document Outline window.

Select Make TOC 
after right clicking 
the Document 
Outline window.

Specifications such as the 
hyperlink and bookmark are 
created on the document outline. 

The table of 
contents is 
created at the 
beginning of the 
document. In 
Namo WebEditor 
if you click the 
table of contents 
while pressing 
the <Ctrl> key, 
you can move to 
the linked 
position. 
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. . .
. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .
File 2

The file menu provides various 
functions for managing documents. You 
can create a new document, open a 
document from your hard drive or a web 
site, save a document, and print. You can 
manage projects and publish your web 
site using the commands listed in the File 
menu. It is important that you fully 
understand the commands, as they will 
be used frequently.

. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . NEW
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This is used to create a new document. When you click the New 
button on the tool bar, a blank document will appear as shown 
below.
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Unlike using the New button to create a new document, if you 
select the New... command on the file menu or press <Ctrl+N> on 
your keyboard, the New dialog box will appear. Select the type of 
the new document you want and click the OK button.

If you want to create a document using frames, click the Frameset 
tab. You can then choose the type you want and click the OK button 
from the new dialog box.

Reference The Component tab is not used to create a new document but is for 
inserting a component form into the current document. For more 
information, see Component(5-61).

When you click this option, 
the form that you choose 
will be inserted onto the 
current document.

When you select a 
form, you can preview 
its format here.
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Name of New File The default name of a new document is noname1.htm. The name of 
this document is shown on the Document tab. This is only 
temporary, and will change when you save the document, where 
you will be able to rename the file.

If you create several documents, Namo WebEditor names the docu-
ments in numerical order, like noname1.htm, noname2.htm, etc.

Document Tab The name of the open document is shown on the document tab in 
the top left corner of the edit window. This will allow you to quickly 
switch between documents if you have more than one open.

If you click on one of the document tabs, the selected document 
will appear in the edit window. You can use this to toggle quickly 
between different documents.

Document Display Tab By clicking the Edit, HTML, and Preview tabs at the bottom of the 
edit window, you can change the way the contents are displayed. If 
you want to edit the current document as you would in a word 
processor, click the Edit tab. You can then click the HTML tab to 
directly edit the HTML. Now click the Preview tab and you can see 
exactly how the current document will look in the Internet Explorer.
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. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . OPEN
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Used when you want to open a document from a hard drive to read 
or change it.

1 Select the Open command from the File menu. The Open dialog box 
appears as shown below.

2 Find the folder that contains the document you want.

3 Select the document and click the Open button. The document will 
appear in the edit window, and the name of the file will be shown 
on the Document tab.

File Format You can open HTML, Text, Microsoft Word, and ASP files in the 
Namo WebEditor. When you click on the File Type drop down box, 
all available file types will be shown. If you select one of the types 
listed, only those files will be displayed.
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Opening Text File If you select the Text File from the Open dialog box, the Open File 
As dialog box will appear. Select the file style you want from those 
listed in the Open Type command, then click OK.

Text (Line) This option will open the file as a typical single 
spaced text file. 

Text (Paragraph) This will open the file exactly as if it were a 
Text-Line, but will have double spacing rather 
than single at carriage returns.

HTML This will open the file and convert it to HTML.

Preformatted Text This will open a text file and maintain its 
original formatting if at all possible. 

Opening WP File When you select a Microsoft Word file (from 6.0 to 97 version) in the 
Open dialog box, you can open these documents directly and they 
will look the same as in Microsoft Word.

Opening ASP File When you select an ASP file in the Open dialog box, you can also 
open it directly. An ASP file differs in its content with an HTML file 
but its format is the same. Using ASP (Active Server Page), you can 
insert many features in your Web site without having to use CGI, 
Java Script, or Perl. When a web browser requires an ASP page, the 
web server will create an HTML document that corresponds to the 
syntax in the ASP page.
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Opening Web Document

When you click the Open URL button from the Open dialog box, 
enter the address of a web site into the URL field. Namo WebEditor 
will then automatically connect to the Internet and open the 
document. If you click the drop down menu to the right end of the 
URL field, a list of the addresses you entered previously will be 
shown. You can use this so you don’t have to constantly enter in 
the same address.

Below is the Namo Interactive Inc. web site shown after being 
opened by entering its URL, 'www.namo.com'. This cannot be used 
with all Web sites. When you want to open an entire homepage, 
use the Import from Web command on the Tools menu.
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Reference To open a web site whose URL is not fully shown in the web 
browser's URL field, follow the instructions below:

1 Enter the address of the URL field having the hyperlink that is not 
fully shown in the web browser’s URL field into the Open dialog box, 
and click the Open URL button.

2 While pressing the Ctrl key on your keyboard, click the hyperlink. 
The linked document will then open. By repeating this, you can 
open then open the document you want.
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. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . CLOSE

�����
�����	
���
���

This is used to close the current document shown in the edit 
window. This does not exit from the program itself.

If the current document has not been saved since its last change, 
you will be prompted to save the document. If you choose yes, the 
document will be saved. If you choose no, it will close and revert to 
its last saved point.

Yes Select this to save and close the current document.

No Select this to close the current document without saving it. 
You cannot retrieve the changes once it has been closed 
this way.

Cancel This will cancel the Close command. 

Closing Document Tabs

While the cursor is on the document tab you want to close, right 
click. A menu will appear with various options, select Close and the 
current document will be closed. If you select the Close All 
command, all open documents will be closed.



. .
 . 

. .FILE
New Project

Namo WebEditor 3.0 User Manual 2-9

. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . NEW PROJECT
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This option will allow you to create a new project. While a 
document is only one part of a full web site, a project is the full web 
site from the index to the feedback pages. Once you have created a 
project, you can manage documents as an integrated part of a site. 
It is more convenient than managing documents separately. You 
can create a project quickly by selecting the Create Project in the 
Create New Project dialog box or by using the Template Wizard.

Creating New Project Choose the name of the new project and specify a folder where the 
files of a new project are to be saved.

1 When you select the New Project command on the File menu, the 
Create New Project dialog box appears.

2 Select Create Project from the Create New Project dialog box and 
enter the name of new project.

3 Enter the path of the folder where the files of the project are to be 
saved.

Caution If the folder for the project contains other files, they will be 
included in the new project. It is best to create a new folder for 
each new project.
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4 Click the Finish button in the Create New Project dialog box.

5 If the folder doesn't exist where you specify, you will be asked 
whether to create a new folder or not. Click Yes.

6 When you create a new project, the project window will appear to 
the left of the edit window.

Reference When you create a new project, the '_we_hinfo' folder will be 
created as well in a new project folder. This folder is where project 
information is to be saved and does not affect the contents of the 
web site.
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Creating with Template Wizard

A template is a set of images and text that are pre-designed and 
can be applied to a new web site. You can use a template as a base 
for your web site. Whether you use the suggested templates or 
make one yourself is up to you.

If you create a project using the Template Wizard, the entire 
structure of your web site can be built immediately. All you have to 
do is to fill in each document of your web site.

1 Select New Project from the File menu, then the Create New Project 
dialog box appears.

2 Select the Template Wizard from the Create New Project dialog box 
and enter the path of the folder where you want to save the project 
files. If you do not know exactly where to save the project files, 
click the Browse button in the Create New Project dialog box. Then 
select a folder in the Browse for Folder dialog box.

3 When you click the Next button, the Select Theme dialog box 
appears.
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4 To get a larger view, click the Actual View... button. If you click the 
name of a theme, you can preview the contents of the theme.

5 To preview the buttons being arranged horizontally, click the 
Horizontal option. This does not set the final arrangement. It is just 
a preview. To select the current theme, click the Apply button. If 
you choose not to select a theme, click the Cancel button.
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6 Click the Next button after selecting a theme you want.

7 When the Select Template dialog box appears, select from either 
Company or Personal. Then click the Next button. If you select the 
Horizontal option, the buttons will be arranged horizontally. You only 
can change the arrangement here.

8 Select the pages to use from the template you chose in the Select 
Pages dialog box. Then click the Next button.
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9 When the Enter Name dialog box appears, enter the project name, 
and click the Finish button. If it is a personal web site, enter your 
name. If it is a company web site, enter the company name. Or you 
can enter the subject of the web site.

10 When a new project is created, the project window is displayed and 
a web site document opens in the edit window.
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. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . OPEN PROJECT
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This is to open a project that has already been created. You can 
open a project the same way as you open a file by using the Open 
dialog box. The extension of a project file is 'wej'. To open recent 
projects, select the Recent Project command on the File menu.

. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . SAVE PROJECT
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Select this to save the current project properties. This is not the 
same as saving the currently opened documents.

. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . CLOSE PROJECT
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Selecting this will close the current project. When you do this, a 
dialog box will appear asking whether you want to close the files of 
the current project or not. If you choose No, the project will close 
and leave the files open.



FILE
Save

2-16 Namo WebEditor 3.0 User Manual

22

If you have not saved the file after the last change, a dialog box will 
appear asking whether or not you want to save the changes.

Yes Close the document after saving it.

No Close the document without saving it. You cannot retrieve 
the changes once you have closed the document by clicking 
the No button.

Cancel Cancel the Close command.

. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . SAVE
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This will save the document on the edit window to disk using the 
current file name. When you save a document that hasn’t been 
saved since its creation, you will be prompted to enter a file name. 
If you enter nothing, the default name, noname*.htm, will be used.
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. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . SAVE AS
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This option will allow you to save the current document under a 
different name.

1 When you select the Save As command from the File menu, the 
Save As dialog box will appear.

2 Specify the folder where you want to save the current document.

3 Enter the file name into the File Name field and click the Save 
button.

When the Same File Exists

If a file of the same name exists in the specified folder, a dialog box 
appears as below, asking whether or not you wish to overwrite the 
file.

Yes The document will be saved with the specified name. The 
existing file will be changed into a backup file (*.bak).

No The document will not be saved and the Save As dialog box 
will again appear. The existing file will remain as is.
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Saving in Text Format

When you select the Text Files from the Save As Type drop down 
menu, the Save File As dialog box will appear. Select the Save Type 
in the Save File As dialog box and click OK. For detailed descriptions 
on the choices, see below.

Text (Line) This option will save the file as a typical single 
spaced text file.

Text (Paragraph)This will save the file exactly as if it were a Text-
Line, but will have double spacing rather than 
single at carriage returns.

HTML This will save the file after converting it to HTML.

Reference If you specify the extension of the file as TXT, HTM, HTML, or ASP, 
the document will be saved in the format that matches the 
extension.

Adding Documents to a Project

While a project file is open, if you save a document in the project 
folder with a new name, a dialog box appears as below asking 
whether or not you want to add the document to the project. If you 
want to add the document, click Yes. If you do not, click the No 
button and save it in another folder. When a project file is closed, a 
dialog box will not appear even if you save a new document the 
project folder.
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Saving Document URL

This option will allow you to directly save your file to a web site host 
you have specified in the Publish Information. After you enter the 
URL into the Location (URL) field, enter the file name in the File 
Name field. Once you have done this, click on the Save URL button. 
Once you do this, Namo will need to connect to the internet and 
transfer the files to the host. If you have not registered the host, 
you will need to register it before any files can be transferred. You 
can specify this by selecting Publish Information from the Site 
Management command in the Tools menu.

. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . SAVE ALL
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This option will allow you to save all open files. If you have a file 
that has not been saved since its creation, you will be prompted 
with the Save As dialog box. Enter a file name and location then 
click Save.

Reference You can also use the document tab to save a document. Point to 
the document tab that contains the file you want to save and right 
click. When the menu appears, select Save All.



FILE
Publish

2-20 Namo WebEditor 3.0 User Manual

22

. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . PUBLISH
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This option will allow you to publish the files directly to the web 
server. You can publish only when you are able to connect to the 
Internet.

Publishing Project Select the Publish command on the File menu, while a project is 
open.

1 When you select the Publish command on the File menu, the 
Publish dialog box appears. The folders for the project and list of 
the files will be shown on the left window. The right window is for 
displaying the folders and the list of the files once they are 
published onto the web server. If you do not connected to the web 
server automatically, you will need to select the host you want. 
Once you are connected, the folders and list of the files currently on 
the web server will be displayed in the right window.

Reference When you build and publish your web site, you should use the 
project feature. This feature will allow you to easily create a single 
location for the files, to and from the web server. It will make a 
sites design easy and fun! For more information on publishing web 
sites, see Publishing a Web Site(1-21).
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2 Select the files you want to publish in the left windows. If you click 
the square box in the left side of the file name, you will see the 
check mark, which means it’s been selected. If you click again, the 
check mark will be disappeared, which means deselected. You can 
select some files by using the image icons in the below left part of 
the Publish dialog box.

To select all the open files click the Select Editing Files button ( ). 
To select the image files that are being used in the open document, click 
the Select Images Used in HTML Files button ( ). To select all files, 
HTML, Image, etc., click the Select All button ( ). To deselect all files, 
click the Deselect All button ( ). To select the project files changed 
since the last publish, click the Select Modified button ( ). To 
select the files chosen at the time of the last publish, click the 
Select Previous button ( ).

Reference If the site on which you wish to publish is not registered on the site 
list, you will need to register it by clicking the Properties... button 
from the Publish dialog box. Even though the site may already be 
registered, you must add this site information to Namo Webeditor.
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3 When you click the Publish button, Namo WebEditor will begin to 
transfer the files onto the web server.

4 When the transfer is finished and the publish has successfully been 
completed, a confirmation message will be displayed. Click the OK 
button. The files that are displayed in green are files that have been 
transferred to the web server.

5 To close the Publish dialog box, click the X button at the top right of 
the dialog box.



. .
 . 

. .FILE
Publish

Namo WebEditor 3.0 User Manual 2-23

Manage Site Information

The site information is the information about the web server on 
which you are to publish the files. The information for some of the 
most popular hosts is registered in the Namo WebEditor as default. 

When your host is not on the list, or you want to publish on your 
company's web server, you should consult the web administrator for 
assistance. Note that even though your host may be registered, 
you still need to supply a username and password here. Whenever 
these are changed, they will need to be updated here as well.

1 When you click the Properties... button in the Publish dialog box, 
the Site Information dialog box will then appear.

2 To modify the existing site information from the Publish Information 
dialog box, select the site you want to change and click the Modify 
button. You can then modify the site information as you wish. When 
you are finished, click OK. For example, if you recently changed 
your username, you will need to modify it before you publish to the 
web server again.



FILE
Publish

2-24 Namo WebEditor 3.0 User Manual

22

3 To register a new site, click the Add button from the Publish 
Information List dialog box. When the Publish Information dialog 
box appears, enter the required information and click OK.

Site Name Enter the name for the site (e.g. Namo candice).

Host Enter the FTP host name. This will vary from web 
servers and may be different from the general web 
site address (e.g. members.namo.com).

Port Specify the port number to connect to the web server. 
Port 21 is the most common. You should not need to 
change this. Contact your administrator if you have 
problems.

Directory Enter the directory name to which your files will be 
saved on the web server (e.g. public_html, htmldocs, 
webhome).

Username Enter the username used to identify you to the web 
server.

Password Enter the user password.

Passive Mode Select this option when you will be sending to a web 
server that has a gateway requiring firewall or passive 
mode.

Location Enter the exact URL of the web site. e.g.: 
http://members.namo.com/~candice. However, This 



. .
 . 

. .FILE
Publish

Namo WebEditor 3.0 User Manual 2-25

address is actually ftp://members.namo.com/usr/ 
candice/home/public_html. When you use username, 
'candice', you will be connected automatically to 
ftp://members.namo.com/usr/candice/home/. 
Therefore all you have to do is to enter 'public_html' 
in the Directory field). If you do not know this 
information, contact your administrator.

Publishing Files You can publish the files you want without needing a project.

1 When you select the Publish command from the File menu, then the 
Publish dialog box appears. To the left all project folders and files 
are displayed. To the right, the folders and files currently on the 
web server are displayed. If a project is open, click the top left 
Publish Project option to clear the check and allow you to browse 
your hard drive.

2 Select the files to publish from the left window of the Publish dialog 
box. To select open files only, click the Editing Files button from the 
Publish dialog box.
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3 When you click the Publish button, the Namo WebEditor will begin 
to transfer the selected files to the web server.

4 When the transfer is complete, a confirmation box will be displayed. 
Click the OK button. The files displayed in green are ones that have 
been transferred onto the web server.
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Importing Files You can just as easily copy files from the web server to your local 
hard disk. Select the target files you want and click the Get button 
in the Publish dialog box. This is useful when you need to retrieve 
files that have either been damaged or deleted.
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Reference On the left hand side, you may see files that have red marks next 
to them. This means they have not transferred to the server. It is 
possible these files have been deleted, moved, or had their names 
changed. If this is the case, you should check all the hyperlinks in 
the project by selecting the Verify Link... from the Site Management 
command in the Tools menu. Once this is done, repair whatever 
broken links you come upon.
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This will allow you to print the contents of the window you currently 
have active, whether it is Edit, HTML, or Preview.

Caution To print, the default printer must first be registered in Windows. 
You can check by selecting Start>Setting>Printers. Consult your 
printer manual on how to add your printer. 

When you select the Print to 
File option, the result will 
not be sent to the printer. 
Instead it will be saved on 
hard disk as a file.

To modify the printer 
options, click the 
Properties button in the 
Print dialog box.

You can print all the 
pages of the 
document or specify 
a page range.

Specify the 
number of copies 
you want to 
print.

When you click 
the OK button in 
the Print dialog 
box, after you 
specify the Print 
range, the print 
begins.

When you select the Print to file in the 
Print dialog box, the Print to File dialog 
box appears.

Specify the folder where you 
want to save the result file, 
enter the result file name. Click 
the Save button in the Print to 
File dialog box. You should 
specify the extension as 'PRN', 
to easily identify it later.
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This will allow you to preview the print result on your screen. You 
can preview the actual shape of a document and check anything 
that requires correcting without having to waste paper.

To get a larger view, move the pointer onto the document. The 
pointer will then change into a magnifying glass. If you click on the 
document, it will enlarge. You can get an even larger view by 
clicking again. If you click when the magnifying glass has turned 
into an arrow, the document will returns to the default zoom level. 
You can also click the Zoom In/Out button at the top of the screen.

To see other pages, press the <Page Up> or <Page Down> key. 
You can also click the Next/Prev Page button. If you click the Two 
Page button, two pages will appear on the screen simultaneously.

Caution • As Format marks will not be printed on paper, they will not be

shown on the preview screen.

• The Print Preview is available only when there is a printer.
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This option will allow you to specify the various margins of your 
site, header, footer, etc. The values specified here are applied to the 
entire document. It is best to check the contents of the Page Setup 
before printing.

Margin Specifies the top, bottom, left, and right margins. Default value 
here is 18mm (you can modify the paper by clicking the Properties 
button in the Print dialog box).

Header/Footer The header is printed at the top of the paper, the footer at the 
bottom. This will allow you to change the spacing from the top and 
bottom. The default value is 10.

If you select the Different Odd and Even by checking it, you will then 
be able to specify different headers and footers for even numbered 
and odd numbered pages. Enter the header and footer values, 
which are explained below, after selecting the odd or even radio 
button.

Contents of Header/Footer

The header is printed at the top of paper while the footer is printed 
at the bottom. 
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Enter the header and footer information in the Header and Footer 
field. You can enter specific text (e.g. 'My Home Page'), or you can 
make it the title or page, etc., print by using '&' variable as 
described below:

&date
Displays the current date. The date is displayed in the way specified 
by your computer, to change this go into your clock properties.

&time 
Displays the current time. The time is displayed in the way specified 
by your computer, to change this go into your clock properties.

&filename
Displays the name of the document file. A document saved on hard 
disk is displayed as 'C:\Work\My_home.html' while an internet 
document is displayed as 'http://www.namo.com/index.htm.

&page
Displays the current page number.

&title
Displays the title of document. The title is what is shown in the 
upper bar of a browser window.

&total
Displays the total number of pages in the document. The '&page / 
&total' will be shown as '4/7' on the fourth page of a seven page 
document.

Header/Footer Location

This will allow you to choose the location of the header and footer. 
To be more specific, it is the distance between the header/footer 
and the top/bottom margins of the document. The default value is 
10mm.
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Page Number Start at

Indicates the number the first page will start at. The default value 
is 1. This can be used when you print a document that is divided 
into several files or simply when you want to make the first page 
number larger than 1.

Print Background Image

Usually the background image and color do not get printed, you can 
toggle this option on and off here.

. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . RECENT FILES
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Namo has a rather good memory. In fact, Namo can remember the 
last 10 documents you opened and allow you to re-open one of 
them with the click of a button. The file at the top of this list is the 
most recently edited.

. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . RECENT PROJECT
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Select to open recent projects. The Namo WebEditor can remember 
the location and names of up to 10 files. It is useful when you wish 
to re-open recently edited files. The project at the top of the list is 
the latest edited one.
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. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . EXIT
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This will close all the open documents and exit from the Namo 
WebEditor.

If there is a file that you hasn’t been saved since its last edit, a 
dialog box will appear asking whether or not you want to save the 
changes. 

Yes This will save the document and exit Namo WebEditor.

No This will exit Namo without saving the documents. In this 
way you cannot retrieve the changes you made since your 
last save. 

Cancel This will cancel the exit command and return you to the 
Namo WebEditor screen.
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Edit 3

The edit menu includes functions that 
allow you to do some of the most 
important tasks. Here you can undo and 
redo previous actions, select and edit 
parts of a document, copy the format of a 
character or paragraph, find and replace 
specific characters, and creating 
bookmarks. This menu is vital to editing 
your documents.

. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . UNDO
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Use this command when you want to undo a previous action in the 
current document. Each time you use the Undo command on the 
Edit menu, it will reverse through recent actions one by one. When 
no more actions remain, nothing else will change.

Namo WebEditor can undo up to a maximum of 200 actions in each 
document.

Caution The Undo command can only reverse actions related to the editing 
of text, not actions such as program preferences or document 
attributes. Also, Split Frame actions can not be reversed by the 
Undo command either. Finally, when you are editing on the HTML 
tab, you can undo only the last performed action.
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. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . REDO
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To retrieve an action undone by the Undo command, use the Redo 
command on the Edit menu. Each time you use the command, the 
recent actions cancelled by the Undo action will be restored one by 
one in reverse order. When no more actions to restore remain, 
nothing will change.

You can reverse the Undo command up to 200 times on each 
document.

The same rules apply here as for the Undo command.

. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . CUT
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By using the Cut command on the Edit menu, you can remove 
selected contents and save them to the clipboard. The selected 
contents will then disappear from the screen. They can then be 
inserted into other programs on your computer.

Caution If you edit a numbered list using the Cut command, it will change 
the numbering.

. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . COPY
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Using the Copy command in the Edit menu, you can copy selected 
content to the clipboard while the content still remains on the 
screen. This content will be stored on the clipboard and can then be 
inserted into the current document or other programs. 

Reference The content being stored in the clipboard will be replaced if new 
contents are stored by cutting or copying. Remember this if you 
don't want to wipe away something important from the clipboard.
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. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . PASTE
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By selecting the Paste command from the Edit menu, you can insert 
text or images currently stored on the clipboard to the current 
cursor position. To be able to use the Paste command, you have to 
have selected something to Cut or Copy command beforehand.

If the contents on the clipboard were originally copied from Namo 
WebEditor, you can then insert it into the current document 
regardless of its form. This means that it doesn't matter whether it 
is JavaScript, a Form Field or something else.

Reference Editing selected contents consists of three steps: cutting (Cut) or 
copying (Copy) the selected contents, moving it to the clipboard, 
and then inserting (Paste) it into the location you want. You can 
also delete selected contents by choosing Delete from the Edit 
menu. You can also hit <Del> on your keyboard. 

. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . DELETE
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By selecting the Delete command from the Edit menu, you can 
delete selected text. This text cannot be restored by selecting the 
Paste command. Also, any existing text or image on the clipboard 
will not be affected by the Delete command.

The content deleted by the Delete action can be revived by 
choosing the Undo command from the Edit menu.

Clipboard

Namo WebEditor 

Namo WebEditor is a 
WYSIWYG HTML Editor

Namo WebEditor is 
a small but fast Web 
authoring tool, with 
powerful features.

Cut

Copy

Paste

Namo WebEditor is a 
Visual Web Authoring 
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Reference HTML tags and the Copy command
When you are editing (Cut, Copy and Paste) selected text, Namo 
WebEditor processes its HTML tag information along with it. This 
means you can copy or paste the formatting styles on paragraphs, 
links, and even images. Not only does Namo WebEditor support this 
convenience between the documents opened, but with other 
software that supports HTML in the clipboard.

For example, after selecting the contents of a screen from a web 
browser, choose the Copy command on the Edit menu, or press 
<Ctrl+C> on your keyboard.

Then by selecting the Paste command from the Edit menu, or 
pressing <Ctrl+V> on your keyboard, you can insert it directly into 
a document in Namo WebEditor, just as you would see it on 
Internet Explorer. 
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While you can import information from other software which 
supports the HTML clipboard, the opposite is possible. All programs 
must be able to read HTML from the clipboard or this will not work.

For example, when composing a new message in Microsoft Outlook 
Express, you can insert what you copied from Namo WebEditor by 
selecting the Paste command from the Edit menu of Outlook 
Express. (It may look slightly different, as the information on 
paragraph styles and attributes of the document cannot be fully 
transferred).

If you insert the information into a program that doesn’t support 
the HTML from the clipboard, only the text will appear.
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. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . CUT SPECIAL
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By pressing <Ctrl+Shift+X> on your keyboard, you can add the 
selected text to the clipboard and delete the content from the 
current document. The Cut Special command is different from the 
Cut command in that the existing text or image on the clipboard 
will not be deleted. The content that was just cut will add to the 
clipboard onto the end.

. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . COPY SPECIAL
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By pressing <Ctrl+Shift+C> on your keyboard, you can add the 
selected text to the clipboard while leaving the text on the 
document. The Copy Special command is different from the Copy 
command in that the existing text or image on the clipboard will not 
be deleted but will have the new material added to the clipboard 
onto the end.

Reference The Cut Special and Copy Special command can be useful when you 
want to take seperate parts of documents and insert them together 
in one location. 

Clipboard

<Ctrl+Shift+X>

<Ctrl+Shift+C>

Cut Special

Copy Special

Paste

<Ctrl+Shift+X>
To cut the selected 
document and add 
to the clipboard. <Ctrl+Shift+X>

<Ctrl+Shift+C>
They are used to 
gather and add the 
selected parts to the 
clipboard.

<Ctrl+Shift+C>
To copy the selected 
document and add 
to the clipboard.
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. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . SELECT ALL
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Wherever the cursor is at a location inside a document, you will be 
able to select all the contents by choosing the Select All command 
on the Edit menu. While all the contents are selected, you can 
select Copy, Cut, Delete and Paste.

. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . COPY FORMAT
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To copy specific character, paragraph and document attributes from 
the current cursor position, select Copy Format from the Edit menu. 
You can then later apply these attributes to the selection of your 
choice. When you are simply copying the format, it is not necessary 
to select the content.

When you choose Copy Format from the Edit menu, the Copy 
Format dialog box appears as shown below. Choose the attributes 
you want to copy and click OK.

You can select all the attributes available by choosing All Formats in 
the dialog box. By clicking All Formats again, you can then cancel all 
selections on this screen.

The attributes you can copy will vary with the cursor position. For 
example, you can select Table Properties or Cell Properties from the 
Copy Format dialog box only when the cursor position is in a table. 
To select the Hyperlink or Bookmark option from the dialog box, you 
will need to place cursor on either a hyperlink or bookmark.
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. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . PASTE FORMAT
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To apply what you copied from the Copy Format command to the 
selection on the current document, select the Paste Format 
command from the Edit menu. You must then specify the content to 
which the attributes will be applied beforehand by selecting the 
target content on the current document.

Depending on what attributes you have selected, the way you use 
the Paste Format command and its result may vary.

When pasting the character attributes, choose the Paste Format 
command on the Edit menu after selecting the target characters.

When pasting a paragraph style, you can select the Paste Format 
command from the Edit menu with the cursor position on the target 
paragraph. When several paragraphs are being targeted, you must 
select them all. It is not necessary to select an entire paragraph 
because the Paste Format command is applied to it automatically 
even though the block doesn't cover the entire paragraph.

To paste both character attributes and paragraph style, you must 
select the target paragraph. In this case, the character attributes 
are applied to the selected character, and the paragraph style is 
applied to the entire paragraph to which the target character 
belongs.

. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . FIND
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Use this when you want to find specific text in your document

1 When you select the Find command from the Edit menu, the Find 
dialog box will appear.

2 After typing the text you wish to find into the Find What field, select 
the Options, Direction and Range you want to search, from the 
dialog box and click the Find Next button.
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3 If Namo WebEditor finds the text you are searching for, it will 
become highlighted.

4 Once you have found the text you were looking for, click the Close 
button.

5 When the text which was found is not what you were looking for, or 
you want to find another instance of this text, click the Find Next 
button.

6 If Namo WebEditor cannot find the text, a dialog box will appear as 
shown below. Click OK.

Find Options Match Case Select this option to find the text that matches the  
capitalization of the text you want.

Match Whole Word Only
Select this to find text that matches the full word.

Direction and Range UP This will search from the current cursor 
position to the beginning of the document. 

DOWN This will search from the current cursor 
position to the end of the document. 

From Top of Document This will search from the beginning of the 
document to the very end. 

All Open Documents This will search all open documents from 
top to bottom. 

If you click this drop down 
menu, a list of previously 
searched for text will 
appear. This is useful if 
you constantly search for 
the same text string.



EDIT
Replace

3-10 Namo WebEditor 3.0 User Manual

33

. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . REPLACE
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Select this to replace specific text in a document.

1 When you select the Replace command from the Edit menu, the 
Replace dialog box appear as shown below.

2 Enter the text to search into the Find What field in the Replace 
dialog box. Then you can enter the text you want to replace it with 
in the Replace To field. Then select the Options and Range as 
needed.

3 When you click the Find Next in the Replace dialog box, the text 
found will be highlighted within the document.

4 To replace the text, click Replace in the Replace dialog box. The 
text will then be replaced and Namo WebEditor will look for the 
next instance. 

5 If you do not wish to replace the text found, click the Find Next in 
the Replace dialog box.

6 If there remains no more text to find, a dialog box appears as 
shown below. Click OK.

7 Click Replace All in the dialog box to replace text without being 
prompted first. Namo WebEditor will also tell you the number of 
replacing.

If you click this drop down 
menu button, the list of 
text you entered before 
will be shown. It is useful 
when you need to re-
enter the same text again.
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Replace Options Match Case Select this option, to find the text that matches the 
capitalization of the text you want.

Match Whole Word Only
Select this to find text that matches the full word.

Range From Top of Document This will find and replace the text starting 
from the beginning of the document.

All Open Documents This will allow you to search all open 
documents.

. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . FIND AGAIN
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When you select the Find Again command from the Edit menu, 
Namo WebEditor will repeat the recent Find action.

. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . FIND IN FILES
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To search all the files in a project for specific text, select Find in Files 
command on the Edit menu. It is available only when the project is 
open.

1 If you select the Find in Files command in the Edit menu, the Find 
in Files dialog box appears.

2 Enter the text you want into the Find What field. Select the options 
you want. Click the Find button.
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3 The Result window will then appear and list the files that contain 
the text you are looking for in the Find in Files tab. When you 
double click one of the files, Namo WebEditor opens it in the Edit 
window and will display the text highlighted.

The number at the end of the file 
name indicates how many of the texts 
you specified are included in the file.
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. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . BOOKMARK
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A bookmark is a location on a document that you have given a 
specific name to. A bookmark can be the target of a hyperlink or an 
indicator for the spot that you wish to return to later on.

Create Bookmark To use a bookmark, you must first create one. Follow the 
instructions below:

1 Select the text or an image at which a bookmark will point to.

2 When you select Bookmark from the Edit menu, the Bookmark 
dialog box will appear. If you select a word, it will be automatically 
entered into the Bookmark Name field as the name of the bookmark. 
You can either use the suggested name or enter a new one.

3 If you click the Add button, the name of the new bookmark will be 
added to the list of previously entered bookmarks. Click the Close 
button when you are done.
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Move to Bookmark If you create a bookmark at the location where you plan on 
returning to, it can save you a great deal of time. 

1 When you select Bookmark from the Edit menu, the Bookmark 
dialog box appears. By clicking the name of the bookmark that you 
want to move to, the text or image at which you created a 
bookmark will appear highlighted in the Edit window.

2 When you click the Goto button, the cursor point moves to the 
bookmark. If you click the Close button, the cursor will remain at its 
original position.

Modify Bookmark In the Bookmark dialog box, select the name of the bookmark you 
want to change. Enter the new name into the Bookmark Name field 
then, click the Modify button.

Remove Bookmark In the Bookmark dialog box, select the bookmark you want to 
delete and click the Remove button.

Caution If you delete the text or image at which you created a bookmark in 
the document, the bookmark will also be removed from the list of 
bookmarks.

Reference You can use a bookmark directly from within the current document 
without saving it. However to use the bookmark from another 
document, you must save the current document.
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With the View menu, you 
can arrange the windows and 
toolbars on the current 
document and determine the 
way the Namo WebEditor will 
display documents. You can 
also preview what the current 
document will look like in a 
web browser and modify 
document information by 
clicking Document 
Information.

. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . TOOL SET
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Choose this when you want to hide or display elements like the tool 
bar, status bar, rulers, or document tab.

When you click on Tool Set in the View menu, a sub-menu will be 
displayed as below. By clicking the options on the sub-menu, you 
can change the look of the screen display. The options where the 
check mark appears will be shown on the screen. Options without a 
check mark will not.
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Format Toolbar With this toolbar, you can modify or review the 
character style and paragraph format.

Standard Toolbar Some of the commands from the File, Edit, View, 
and Insert menu are also available on this tool 
bar. You will find the commands on this tool bar to 
come in quite handy.

Status Bar The description for your current choice, input 
status, location of image files, and hyperlinks are 
shown here. You can also check whether or not 
you have made a change in the current 
document.

Horizontal/Vertical Rulers
Scales that help you check the size of the edit 
window. The unit of measurement here is pixels.

Document Tab The document name is shown here. When you 
right click on the tab, a menu appears that will 
allow you to open a pre-existing document or 
create a new one.
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This option allows you to hide and display various windows.

Point to the Tool Windows command on the View menu, the sub-
menu contains five options as shown below. You can use the hot 
keys (<Alt+1>-<Alt+5>) assigned to each tool window, saving the 
time of flipping through a menu.

The image below shows what Namo WebEditor looks like with the 
Project and Result window open.
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Project Window This window helps you manage your site easily by displaying the 
project folder and file list to the left of the edit window. It appears 
when a new project is opened. You can find more information in 
New Project(2-9).

Project tab In the upper window, 
the structure of the 
project folders is 
displayed. In the lower 
window, the files in the 
folder you have 
selected are shown. To 
open a document file, 
double click the file 
name in the lower 
window. Files that are 
currently open are displayed in yellow.

Explorer tab In the upper window, 
the folder structure of 
the current drive is 
displayed. In the lower 
window, the files in the 
currently selected 
folder are shown. You 
can browse the drives 
as you would in the 
Window Explorer.

Graph tab The files linked to 
current document of 
the edit window are 
displayed in chart 
form. From here you 
can only view files.
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Result Window When you check links or find text while a project is open, the 
results will be shown here. It appears right below the edit window.

Link Check tab When you check links 
by selecting the 
Incremental Verify 
Link command in the 
Site Management sub 
menu from the Tools 
menu, the results are 
shown here. This 
option is only 
available when a 
project is open.

Find in Files tab Displays the locations 
of the text that you 
found using the Find 
in Files command. 
You can access this 
command from the 
File menu. This 
option is only 
available when a 
project is open.

Document Outline When a document 
using a heading tag 
is open on the edit 
window, you can see 
the document 
outline. You can see 
the structure of 
document at a glance 
and move to where 
you want in the 
document by double 
clicking their titles.
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Moving Tool Windows You can move the Project Window and Result Window to whatever 
location you wish. Follow the directions below to find out how.

1 Click the double bars 
while holding down 
on the left mouse 
button.

2 Drag the tool 
window to where 
you want, then drop 
it.

3 The tool  window 
appears wherever 
you  dropped it. To 
adjust  the width (or 
height) of the tool 
window, resize the 
borders of window.
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Time Line This is a tool window for creating an animation using layers. You 
can create various animation effects with layers without having to 
know DHTML.

Layer In this window you will see a list of various layers that you have 
created in the current document.

Reference Layer and Time Line are Dynamic HTML functions that are 
supported in Namo WebEditor 3.0 only. These functions allow for 
some amazing effects, but are only supported in version 4 browsers 
(Internet Explorer and Netscape Navigator).

These functions are for advanced Namo WebEditor users, so before 
you delve into Time Line or Layers, make sure you know your 
Namo WebEditor! For more information on the Time Line and Layer, 
see Time Line(11-6) and Layer(11-2).
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This option allows you to hide or display various text markings, like 
format, paragraph, and the space mark. You can also select 
paragraph spacing and how 2 byte  characters  will appear in the 
edit window.

To select this option, highlight the Mark Set command in the View 
menu. Six options will then appear. You can choose those which are 
to be hidden or displayed by clicking on them. Selecting All will 
display or hide all markings.

Format Mark If you select Format Mark from the Mark Set sub-menu, you can 
view the elements as shown below. By default these are hidden, 
but are sometimes required to edit a document properly.

Indicates a value of 0 in the table and cell border 
thickness/The outline of image/applet/plug in.

Insertion point of bookmark.

The starting point of numbered or bulleted list.

Insertion point of image file.

Insertion point of hidden description like comments.

Insertion point of scripts.
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Outline of a form field.

Insertion point of a layer.

Outline of a layer.

Insertion point of an extended HTML tag.

Insertion point of applet information.

Insertion point of plug-in information.

Paragraph Mark If you select Paragraph Mark from the Mark Set sub-menu, you can 
view the line changes(br) and paragraph(p).

Space If you select Space from the Mark Set sub-menu, a normal space 
will be displayed as black bullet mark and the nonbreaking space 
(&nbsp) as a red bullet mark. According to HTML rule, single spaces 
are viewed as one space, whereas several spaces become a 
nonbreaking space.

All If you select the All from the sub-menu in the Mark Set, it will either 
display or hide all formatting marks.
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Paragraph Spacing If you select Paragraph Spacing from the Mark Set sub-menu, 
paragraphs will be spaced as if in a word processor, slightly apart 
from each other. If this option is not checked, paragraphs will not 
have normal spacing between them. When you edit HTML 
documents, this should be selected.

Reference When saving a document edited in Namo WebEditor as plain text, 
you can uncheck the Paragraph Spacing option. This will format the 
spacings as a plain text editor would.

DBCS Align If you select DBCS Align, a 2 byte character word may be separated 
by a letter with the change of a line or paragraph. When this option 
is deselected, a 2 byte character word is recognized as a full unit 
and will not be separated by a line or paragraph change.

. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . IMAGE SET
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You can decide whether a graphic, background image, or animated 
GIF file will be displayed or not by using the Image Set command in 
the View menu.

Click on the Image Set option in the View menu. The sub-menu 
contains three options which are described below. You can then 
choose which images will be hidden or displayed by placing, or 
removing, the checkmark beside the option. Checked options will 
be shown, whereas options that do not have a check will be hidden.
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Image If you select Image from the Image Set sub-menu, you will be able to 
view images in the edit window. When this option is off, a dotted box 
indicating the size and location of the image will appear in its place.

When Image Selected When Image Not Selected

Background Image If you select Background Image from the Image Set sub-menu, the 
background image will be viewable in the edit window. When the 
option is off, only the background color specified for the current 
document will appear instead without the background image.

Reference If you work on a slower computer, it can be helpful to have the 
background image turned off. This will allow editing of your 
documents without slowing you down.
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Animation If you select Animation from the Image Set sub-menu, animated 
GIF files will become visible in the edit window. When this is off, the 
file will appear as still image.

. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . ZOOM IN/ZOOM OUT 

Use this option to adjust the viewing area of the edit window. The 
Zoom In/Out feature is not in the View menu, but is explained here 
as it directly relates to the display.

X% Choose the percentage of the display you want to 
view. The default is 100%.

Page Height This will display the entire contents that would be 
printed on a normal sheet paper. This is useful if 
you are creating printable forms.

Page Width This option will display the full width of document 
in edit window. 

Value Entering This allows you to enter a specific number. It can 
be anywhere from 45% to 500%.

Value Entering 
Field
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Use this to adjust the size of the windows. They can be adjusted to 
match the size of print paper or screen resolution. You can adjust 
the size of the window to fit a specific resolution by simply clicking 
on one of the choices listed. You can also set the window size to 
match that of various paper sizes. Note that this is only for general 
design purpose only, to specifically edit the size, use the Page Setup 
command found in the File menu.

Point to the Window Width command on the View menu, a sub-
menu with five options will appear as shown below. By clicking the 
options in the sub-menu, you can adjust to a specific resolution or 
printer page size.

640x480 This option will change the window size to 640x480 pixels. This is 
the lowest display setting available, and is commonly used by 
laptop owners. This option works best when zoom proportion is set 
to 100% and no other windows are displayed.

800x600 This option will change the window size to 800x600 pixels. This is 
the default resolution for most computers nowadays. As with the 
640x480 setting, it works best when no windows are open and the 
zoom proportion is set to 100%.
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Printer Default Paper This option will change the window size to that specified by your 
printers default page setting.

A4 This setting will change the window size to A4 size to preview the 
way the current document will look when printed on A4 size paper. 
A4 is the default paper size for most of Asia.

Letter This setting will change the window to Letter size to preview the 
way the current document will look when printed on Letter size 
paper. Letter is default paper size for most of the western world.

Reference You must specify the default printer beforehand to properly adjust 
the window size to the size of the printer default, A4, or Letter. This 
is because the top, bottom, left, and right margins will vary widely 
with printers.

. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . PAGE LAYOUT
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Select this to preview the way the current document will look when 
printed on paper. When the checkmark appears before Page Layout, 
it is active. When the checkmark is not displayed, Page Layout is 
inactive.

When the Page Layout is displayed, the background turns gray so 
as to display the size of paper. The page break is displayed by a red 
line. If you modify the margin by selecting the Page Setup 
command in the File menu, the shape of the document will also 
change.

The selection of the Page Layout has nothing to do with the size of 
window or the zoom proportion. To see the left/right margins, while 
the Page Layout is active, choose the Page Width command in the 
Zoom In/Out option.
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Status of Page Layout

. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . PREVIEW IN NETSCAPE NAVIGATOR
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Select this to preview the way the edited document will look in the 
Netscape Navigator.

Reference With the Namo WebEditor, you can preview the way a document 
will look in the two most commonly used web browsers, Netscape 
Navigator and Internet Explorer.
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. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . PREVIEW IN INTERNET EXPLORER
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Select this to preview the way the current document will look in 
Internet Explorer.

Reference You can register web browsers other than Netscape and Internet 
Explorer in the View menu. To register new web browers, select the 
External Program tab in the Preferences command from the Tools 
menu. Select (Other) in the Browser 1 or Browser 2 field and enter 
in a new path. Then specify the DDE Service in the Program 
Preferences dialog box. The DDE Service specified here appears in 
the View menu.

If Namo WebEditor cannot find Netscape Navigator or Internet 
Explorer when you select the Preview function, you will be notified 
by having the External Program tab in the Program Preferences 
dialog box will appear. Enter the full path again and click OK. You 
should now be able to preview the document in a web browser.
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. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . RELOAD DOCUMENT
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Select this to re-open the current document displayed in the edit 
window.

Point to the Reload Document on the View menu, the sub-menu 
appears as seen below. The options will vary between users. You 
can then choose between Auto Detect, current code, or a specific 
language.

When you select a document that has been changed in another 
program, you will be prompted to reload the newer version. If you 
choose yes, the newly changed document will replace the current 
document.

If you choose No, you will return to the edit window. You can 
reopen the document by selecting the Auto Detect on the Reopen 
menu or pressing <F5>.
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If, when you open a document by entering a URL, odd signs appear 
instead of text, select Reload Document from the View menu. You 
can then choose the proper code or language the document was 
coded in. You will now be able to properly read the document. For 
example, if you cannot read a web document written in a foreign 
language, select that language from the Reload sub-menu.

. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . REFRESH SCREEN
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Select this when there is missing information or the document is 
not displayed properly. This will also clear up any improper marks 
on the screen. The hot key associated with this function is 
<Shift+F5>.

. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . DOCUMENT INFORMATION
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Select this to check or modify the current document information. 
When you select Document Information from the View menu, the 
Document Information dialog box will appear as shown below.
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Location Displays the path and name of current file.

Author Displays the information on the Author of current document. When 
you click the Modify button, the Information tab then appears in the 
Document Properties dialog box. You can modify the information here.

Encoding If you have a problem reading a document written in 2 byte 
characters, it is because the encoding has been done improperly. 
When you click the Modify button in the Document Information box, 
the Advanced tab will then appear. You can modify the encoding 
type here.

Background Color This will allow you to change the background color of the current 
document. When you click the Modify button in the Document 
Information dialog box, the Appearance tab will appear. You can 
modify the background color here.

Background Image This will allow you to change the background image of the current 
document. When you click the Modify button in the Document 
Information dialog box, the Appearance tab appears from which you 
can change the background image.

Generator Specifies the editor used to edit the current document. The Namo 
WebEditor is specified by default.

Transfer Size This shows the size of all the files (HTML, image, plug-ins/applets, 
etc.) attached to the current document. When being transferred 
through the Internet, the files are sent as a packet, therefore the 
transfer size is larger than the total size of the files.
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Transfer Time Shows the time it will take to transfer all the files attached to 
current document at a specified speed.

Image Files Shows the path and name of image files used in the current 
document.

Etc. (applet...) Shows list of files (other than image files) being used in the current 
document.

Reference If you click the Modify button from the Document Information dialog 
box, the Document Properties dialog box appears. It is the same as 
selecting the Document Properties command from the Format menu. 
You can find more information about Document Properties(6-16).
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. . .
. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .
Insert 5

Insert menu provides elements that 
can be inserted into an HTML 
document. It helps you easily insert 
elements like images, links, form fields, 
scripts, applets and plug-ins. With this 
menu, you can give your web site 
brilliant effects like animation and 
scrolling text. It enables you to use 
math formulas in you web site freely, 
something that hasn’t been easy until 
now. Inserting layers can also be done 
without difficulty.

. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . LINE BREAK
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This option allows you to change lines without having to change the 
paragraph itself. Two types of line breaks are available from this 
command, the Line Break and Line Break...

Line Break The Line Break is used when you want to insert a single line only. It 
does not start a new paragraph. You can also use <Shift+Enter> on 
your keyboard to insert a line break. Paragraphs (<Enter> on 
keyboard) are different because a paragraph inserts a blank line 
above the current line, whereas a Line Break doesn’t. This is the 
same as entering <BR> into the HTML code.

In a word processor, when you press the <Enter> key, a new line 
starts along with a new paragraph, but an extra blank line above 
the current isn’t created.
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With Line Breaks the appearance, especially left/right margins and 
style sheets, of the current paragraph will remain the same.

Paragraph Break<Enter>

Line Break<Shift+Enter>

Line Break... If you select Line Break... on the Insert menu, you will have four 
options for breaking the lines: Normal Line Break, Clear Left Margin, 
Clear Right Margin and Clear All Margins. The Line Break... is useful 
when you want to enter text around an image or make text start at 
the bottom of it. You will appreciate its value when there are 
images or other objects in the paragraph.

Normal Line Break
If an image is at the left or right margin, it does not clear it.

Clear Left Margin
If an image is at the left margin, it moves the next line down until 
the left margin is cleared.
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Clear Right Margin
If an image is at the right margin, it moves the next line down until 
the right margin is cleared.

Clear All Margins
If an image is at both margins, it moves the next line down until 
both margins are cleared.

Style
This allows you to apply a style supported by CSS specifications. 
When you click the Style button, a Style dialog box appears. For 
more information on using the Style dialog box, see Paragraph 
Style(6-25).

Extended
Use this when Namo WebEditor doesn't support the line break 
option you require due to the addition and change of current HTML 
protocol. This will allow you to either specify an attribute that is not 
in the current HTML protocol or when a new attribute is created. 
You must enter this attribute manually.
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. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . HORIZONTAL LINE
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This option allows you to insert a horizontal line at the current 
cursor position. Horizontal Line are used to separate areas of your 
document.

When you select the Horizontal line command on the Insert menu, a 
horizontal line is inserted at the cursor position and is the full width 
of the paragraph. You can modify the length of the line after it has 
been inserted. When you resize the window, the line width changes 
along with the window size.

If you select the Horizontal Line command on the Format menu or 
press <Alt+Enter> while selecting the horizontal line in the 
document, the Horizontal Line Properties dialog box appears. You 
can modify the line properties such as the width/height and 
alignment.

Width
This option allows you to specify the width of the line. You can set it 
by percentage or pixel. If you use percentage, the width will change 
along with the window size of the web browser.

Height
This option allows you to specify the height of the line. You can only 
specify line heights in pixels.
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Alignment
You can specify the alignment here.

Solid Line (no shading)
If you select the Solid Line (no shading) option, the horizontal line 
will be solid.

Style
This allows you to use CSS to change link colors, and other options 
supported by CSS specification. When you click the Style button, 
the Style dialog box appears. For the usage of the Style dialog box, 
see Paragraph Style(6-25).

Extended
Use this when Namo WebEditor doesn't support the options you 
require. This will allow you to either specify an attribute that is not 
in the current HTML protocol or when a new attribute is created. 
You must enter this attribute manually.

. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . COMMENT
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This option will allow you to insert a comment into your document. 
The Comment(<!-- --> tag) is hidden in web browsers, but can be 
seen in the HTML source file.

When you select the Comment command from the Insert menu, the 
Comment dialog box appears. After entering the text you want, 
click OK.
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By default, you cannot view comments in the edit window. To 
display them, select the Format Mark option on the Mark Set 
command on the View menu. 

. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . SYMBOL
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This option allows you to enter special characters or symbols that 
are not on your keyboard.

When you select the Symbol command on the Insert menu, the 
Symbol dialog box appears. Select the symbol you want by clicking 
the Insert button or you can double click the symbol. The symbol is 
then placed at the location of the cursor. The selected symbol is 
shown at the left bottom of the dialog box. 

The Symbol dialog box remains on the screen after you insert the 
symbol allowing you to continue inserting symbols without having 
to reopening the box. To close the box, click the Close button.
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This option allows you to insert an image into the document. All 
major web browsers now support JPEG and GIF. These are fully 
supported by Namo WebEditor.

If you insert an image file that is different from the JPEG or GIF 
format, it will not be shown in the web browsers or Namo 
WebEditor. Only the file location and size are displayed as shown 
below:

WebEditor Internet Explorer  Netscape Navigator

1 When you select the Image command on the Insert menu, the 
Image Properties dialog box appears.

2 Enter the name and path of the image file you want into the Source 
field. If you don’t know the exact path, you can browse your hard 
drive by using the Browse button. 

3 Use the Alt Text field to enter in the information to be displayed as 
an Alt Tag in web browsers, then click OK.

4 Then the image file you specified is now inserted at the current 
cursor position.
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General You specify hyperlink and information on the image file here.

Source
Specify the name and path of the image file you want. You can use 
a file on the local hard disk or from a web site. When you use a file 
on a web site, you must have the exact URL of the file.

Low Resolution
This attribute allows a lower quality, smaller image to be displayed 
while the higher quality image is loading. This function is Netscape 
specific and will not work on Internet Explorer.

Alt Text
You can enter in detailed information on an image here. It will be 
displayed while the image is loading as text, and as a tool tip when 
the mouse is hovered over the image. It is best to put something 
here to supply information for those surfers browsing with images 
turned off, or for those with visual handicaps.

Copy Image
If you select the Copy Image option from within the Image 
Properties dialog box, the Copy Resource dialog box appears when 
you save the document. The Copy Resource dialog box allows you 
to save the image file along with the HTML file within a sub folder. 
The default name for the sub folder is 'images', however you can 
specify a different name.
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This option protects against deleting or damaging files when they 
get published.

The Copy Resource dialog box shows a preview of the image file and 
then asks whether you want to save it or not and where you want it 
to be saved to. The buttons and information on the Copy Resource 
dialog box indicate the following:

Source Displays the location of the image file.

Destination Displays the location to which the image file is 
copied.

Resource Directory You specify the folder in which the image files of 
the HTML document are to be saved. The 
default is 'images'.

Prompt on Creating a Sub-directory
If this option is selected, you will be prompted 
to create a sub-directory for image files if none 
already exists. If this option is not selected, the 
folder will be created without prompting.

Yes If you click the Yes button, image files are 
copied to the specified folder.

No If you click the No button, image files will not be 
copied.

Copy All If you click the Copy All button, all specified 
image files will be copied without prompting.

No to All If you click the No to All button, no image files 
will be copied.
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Clip Art
Select, when you want to choose from the various clip art images 
provided on the Namo WebEditor CD. For more information on 
using clip art, see Clip Art(5-13).

URL
Use this when you want to specify a hyperlink to an image. When 
you click the Edit button, the Create Hyperlink dialog box appears. 
Once you have specified the target of the hyperlink, a surfer can 
move to the linked document by clicking on the image. For more 
information, see Hyperlink(5-55).

Target Frame
Specify the frame that will display the document when the link is 
selected. You can specify the target frame in the Create Hyperlink 
dialog box. When no target frame is specified, the hyperlink target 
will be displayed in the current frame.

Appearance Here you can specify the size and alignment of the image.

Alignment
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This allows you to specify the location of the image when it is 
adjacent to text. You can easily understand each alignment type 
just by looking at the illustrations in the Image�Properties dialog 
box.

Top Aligns the first line of text to the top of the image.

Middle Aligns the first line of text to the middle of the image.

Baseline Aligns the first line of text to the bottom edge of the 
image.

Bottom Aligns the lowest portion of the first line of text to the 
bottom of the image.

Left Aligns the image to the left with the text on the right.

Right Aligns the image to the right, with the text on the left.

Size
You can specify the exact size of an image by percentage or pixel 
units. Only when the Width and Height options are selected will the 
specified values be applied to an image. The percentage option 
relates to the proportion of an image to the size of a window. If you 
specify the width as '100%', the image will be fully displayed. 

It is a wise idea to define the width and height attributes, as it can 
speed up the loading of your page into web browsers. It will also 
insure that your image will be the correct size. If you do not specify 
these attributes, your image can vary widely by browsers. 

Restore Size
If you click the Restore Size button, the Namo WebEditor re-reads 
the width and height of original image and enters that in. The size 
will be displayed in pixels.

Reference The size of the image you specify in the Image Properties dialog 
box, indicates how big or small the image will look in the web 
browser that is viewing it. It has nothing to do with the physical 
size of the file. That is, even if you reduce the width and height of 
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an image file that is 200KB, its size will remain 200KB. To change 
the physical size of an image file, use graphic software such as 
Paint Shop or Photoshop.

Space
You can specify the spaces around the image and the thickness of 
the border (the border only appears when there is a link attached 
to the image).

Horizontal Puts spaces as specified on the left and right sides of 
the image.

Vertical Puts spaces as specified on the top and bottom of the 
image.

Border Specifies the thickness of the border. If you do not 
want a viewable border, set the thickness as 0.

Style
This allows you to use CSS to change link colors, and other options 
supported by CSS specification. When you click the Style button, 
the Style dialog box appears. For the usage of the Style dialog box, 
see Paragraph Style(6-25).

Extended
Use this when Namo WebEditor doesn't support the options you 
require. This will allow you to either specify an attribute that is not 
in the current HTML protocol or when a new attribute is created. 
You must enter this attribute manually.

Resizing Image If you click the image after inserting it, eight size handles will then 
appear. By dragging these, you can freely resize the image. When 
you want to preserve the current proportion of the image, drag the 
size handle at one of the corners. When you only want to change its 
width or height, drag the size handle at the respective side. 
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Enlarging with current proportion

Enlarging only width

. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . CLIP ART
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This option will allow you to insert clip art at the current position, or 
use it as a background image. You can also add new images to clip 
art gallery. The images must be in either JPEG or GIF format.

When you select the Clip Art command from the Insert menu, the 
Clip Art dialog box appears. You may then select from the listed clip 
art images.

Namo WebEditor clip art is classified into six categories: Icon, 
Animation, Background, Bar, Bullet and Image. These six categories 
make up the main folders, these categories are then classified into 
several sub categories. These sub categories also contain sub folders. 
To select and insert clip art, follow the steps below:

1 When you select the Clip Art command from the Insert menu, the 
Clip Art dialog box appears. Select the clip art you want in the same 
way that you use Windows Explorer: When you select a folder in the 
left window, then clip art it contains will be displayed on the right.
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2 In the left window, the clip art folders appear as shown below. The 
open folder is the one you most recently visited. When you find the 
clip art you want here, click it to select it. Use the scroll bar or click 
the plus/minus sign, to see other first level folders.

3 If you select by clicking the second level folder, the list of clip art 
appears in the right window as shown below.
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4 When you select one of the clip art images in the right window, its 
name and path are shown in the bottom of the Clip Art dialog box. 
To select the image, double click on it or click the Insert button. The 
selected image will be inserted at the current cursor position.

5 To modify the appearance of a clip art image or to specify its 
hyperlink, click on the clip art image. Then select the Image 
command from the Format menu. You can right click on the clip art 
image and select the Image command. When the Image Properties 
dialog box appears, you can modify the settings accordingly.

Adding Clip Art You can add clip art which you have either created yourself or 
downloaded from a web site, to the clip art folder.

1 When you select the Clip Art command from the Insert menu, the 
Clip Art dialog box appears.
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2 Select the sub folder that your want to add your new image to.

3 Click the Import Clips button and the Open dialog box appears.

4 Specify the image file to add, then click the Open button. You can 
use a file on the local hard disk as well as one located on a web 
site. When you specify a file from a web site, you must have the 
exact URL. Note that you can only use JPEG or GIF as the format 
for the clip art.

5 The clip art you add will permanently appear in the selected sub 
folder. Click the Close button.
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Reference If you copied the clip art files using the Windows Explorer, click the 
Rebuild Thumbnails button while selecting the respective folder. The 
added clip art will be displayed. 

Adding Clip Art Folder

You can create a new sub folder for new clip art that you wish to 
add.

1 Select the folder or sub folder you want your new directory to 
appear in. When the menu appears, select Add.
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2 After the new folder is created, right click on it. When the menu 
appears, select Rename. Enter the new name and press <Enter>.

3 You can add some clip arts to the new folder by clicking on the 
Import Clips button.

4 Close the Clip Art dialog box by clicking the Close button.

Reference If you click the Insert As Background button after selecting the clip 
art file, it will be inserted as the background image.



. .
 . 

. .INSERT
Layer

Namo WebEditor 3.0 User Manual 5-19

. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . LAYER

������������


This allows you to insert a layer into your document.

If you select Layer from the Insert menu, a layer will be inserted at 
the current cursor position. If the Format Mark is activated, you can 
see the yellow layer format mark( )and its outline. If the Layer 
window is displayed, the information of the new layer is shown 
here.

For more information on Layer, see Layer(11-2).

Reference The Layer and Time Line are dynamic HTML functions that Namo 
WebEditor supports. To see the full effect of dynamic HTML, 
Internet Explorer 4.0 or Netscape 4.0 or higher is required.

Dynamic HTML can bring a wide range of features to your web site, 
however, if you are a beginner to Internet document publishing you 
should first fully explore basic HTML syntax before trying to tackle 
dynamic HTML.
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. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . FORM FIELD
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This allows you to create an entry form to gather information from 
visitors, make a selection, or to display a check box.

When you point to the Form Field command in the Insert menu, a 
menu of seven items will then appear as shown below. If you select 
one of them, a dialog box allowing you to specify their properties 
will appear. Enter the necessary values and click OK. The selected 
form field is then inserted at the current cursor position.

There are seven types of form fields to choose from inside Form 
Field menu: One-Line Text Box, Scrolling Text Box, Check Box, Radio 
Button, Drop-Down Menu, Push Button and Image. 

After selecting a form field, select Form from the Format menu or 
double click the newly created form field. The Form Properties dialog 
box will appear. You can then proceed to modify the properties of 
the selected form field from within this dialog box.

Reference Form fields are linked to web servers, therefore Namo WebEditor 
only shows you what the form will look like and how the buttons 
will operate. To confirm that the form will properly function it must 
be published to your web server.
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One-Line Text Box 

The One-Line Text Box is used for entering short textual 
information. When you select the One-Line Text Box from the Form 
Field command, the One-Line Text Box properties dialog box 
appears as shown below.

Name
Enter the name of the form field. The name is an important 
element to distinguish the information from other information when 
transferring it to a server or computer, therefore a name must be 
entered.

Initial Value
You can specify the value to be inputted to the form field when it 
originally appears. If you do not enter a value, the form field will 
simply remain empty.

Width in Characters
This allows you to specify the width of the form field. The unit used 
here is letters, therefore 10 would make a field long enough for 10 
letters. This does not limit the amount able to be placed into the 
form field, only its visible size.

Maximum Length
This allows you to put a limit on the amount information that can 
be entered. The procedure for this is the same as setting the width, 
however this will limit the amount of letters to be entered into the 
form field.
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Type
Allows you to specify the type of contents to be entered.

Normal Indicates normal text can be entered here.

Password Indicates the content will be a password or something 
not to be openly visible. The entered contents will be 
displayed as '*'’s. The contents can then only be seen 
by the server or by certain CGI scripts.

File Indicates a file name is to be entered here. In some 
web browsers, a Browse button is automatically 
created, so it's easy to enter the name.

Style
This allows you to use CSS to change link colors, and other options 
supported by CSS specification. When you click the Style button, 
the Style dialog box appears. For the usage of the Style dialog box, 
see Paragraph Style(6-25).

Extended
Use this when Namo WebEditor doesn't support the options you 
require. This will allow you to either specify an attribute that is not 
in the current HTML protocol or when a new attribute is created. 
You must enter this attribute manually.

Event
Specify the script to be linked to the specified event in the form 
field. When you click the Event button, the Form Field Event Script 
dialog box appears as shown below.
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In the window to the left you will see the available events, in the 
window to the right the list of current scripts are displayed. To link 
the events to a script, select the script first and then click the 
arrow-shaped button to the right of the event.

The available events may vary with the type of form field selected. 
You must also prepare the scripts beforehand.

onClick Specifies an event to occur when the field is clicked.

onFocus Specifies an event to occur when focus is set to the 
form field. 

onBlur Specifies an event to occur when focus is moved away 
from the form field. 

onSelect Specifies an event to occur when the contents of the 
form field are selected.

onChange Specifies an event to occur when the focus leaves the 
form field after the contents are changed.

Reference Event is the actions to click the mouse button or to move the 
mouse pointer. Script is a program made for a certain effect. Image 
changing when the mouse pointer is placed on an image or menu 
display when you click the image button are the joint actions 
between event and script.
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Scrolling Text Box The Scrolling Text Box is used to enter multiple lines of text. When 
you select the Scrolling Text Box from the Form Field command, the 
Scrolling Text Box Properties dialog box appears as shown below.

Name
Enter the name of the form field. This name is an important 
element to allow distinction between one form element to another 
and is often used by web servers to separate information entered in 
the web browser.

Initial Value
Specifies the contents to be displayed when the form field appears 
in the browser. If no value is entered, a blank form field will appear.

Width in Characters
This allows you to specify the width of the form field. The unit used 
here is letters, therefore 10 would make a field long enough for 10 
letters. This does not limit the amount able to be placed into the 
form field, only its visible size.

Number of Lines
This allows you to specify the viewable height of the form field. The 
number of lines you specify does not limit the quantity of contents.
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Check Box A Check Box is used to show choices in a form field. When you 
select the Check Box from the Form Field command in the Insert 
menu, the Check Box Properties dialog box appears as shown below.

Name
Enter the name of the form field. This name is an important 
element to allow distinction between one form element to another 
and is used by web servers to separate information entered in the 
web browser.

Value
Specify the value to be sent to a server when the check box is 
selected.

Initial State
Specify how the check box will initially looks in a web browser. Note 
the examples below.

Radio Button The Radio Button is a form field used to select one item from 
several items in a list. When you select the Radio Button from the 
Form Field command, the Radio Button Properties dialog box 
appears as shown below.
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Name
Enter the name of the form field. This name is an important 
element to allow distinction between one form element to another 
and is used by web servers to separate information entered in the 
web browser.

Value
Specify the value to be sent to a server when the radio box is 
selected.

Initial State
Specify how the radio button will initially look in a web browser. 
Note the examples below.

Event
Only the onClick event is available on the Radio Button.

Drop-Down Menu 

The Drop-Down Menu is used to create a single selection item list. 
When you select the Drop-Down Menu from the Form Field 
command on the Insert menu, the Drop-Down Menu Properties 
dialog box appears as shown below.
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Name
Enter the name of the form field. The name is an important 
element to distinguish one form element from another and is often 
used by web servers to separate information entered on the web 
browser.

Add
When you select the Add button, the Drop Down Option dialog box 
appears. If you click OK after entering the name and value, the new 
item will be added. If you want the newly added item to be selected 
by default, selected check box should be on.

Below is a sample of several items being added.

Modify
Changes contents.

Remove
Removes item from list.

Move Up
Moves an item up in the list.
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Move Down
Moves an item down in the list.

Height
Specifies the height of the field. If you specify the number of lines 
as a lesser value than the number of items, a scroll bar will appear 
as shown below.

Allow Multiple Selections
This allows you to choose if the user will be able to select several 
items from the same list or not. If you select Yes, more than one 
item can be chosen.

Push Button  The Button is a form field used to transferring input data to a web 
server or CGI scripting, resetting a form field, activating a script, 
and more. When you select Push Button from the Form Field 
command on the Insert menu, the Push Button Properties dialog box 
appears.

Name
Enter the name of the form field. The name is an important 
element to distinguish one form element from another and is often 
used by web servers to separate information entered on the web 
browser.
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Value
Specify the name of the Push Button. If you enter "Send", "Send" 
appears on the Push Button.

Button Type
Specify the type of push button.

Normal Indicates a button used to transfer a set value. Usually 
used with a JavaScript or Visual Basic Script.

Submit Used to transfer the data on the form to a specified 
web server or CGI software.

Reset Resets all form fields to their default. 

Image The Image is a form field used to transfer the coordinates of the 
location where one clicks. When you select the Image on the Form 
Field command from the Insert menu, the Image Form Field 
Properties dialog box appears.

Name
Enter the name of the form field. The name is an important 
element to distinguish one form element from another and is often 
used by web servers to separate information entered on the web 
browser.
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Source
Specify the name and path of the image file you will use. You can 
use a file on your hard disk or from a web site. When you use the 
image from a web site, you will need the exact URL and name of 
the file. When specifying an image file on the hard disk, use the 
Browse or Clip Art button to save time.

Align
Allows you to choose the way text and images are aligned when the 
text is mingled with images. Bottom sets the text at the bottom of 
the image. Middle sets the text in the middle, Top sets it at the top.

Copy Image
If you select the Copy Image option in the Image Form Field 
Properties dialog box, the Copy Resource dialog box will appear 
when you save the document. The Copy Resource dialog box is used 
to save the image file along with the document in a sub folder of 
the root directory. For more information on the Copy Resource 
dialog box, see Copy Image(5-8).

. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . SCRIPT
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This allows you to insert a JavaScript or Visual Basic Script 
(VBScript) into the document. Scripting is a type of programming 
language that allows you to build a truly interactive web site. It is 
used in combination with HTML. 

When you point to the Script command 
on the Insert menu, a drop down 
menu of three items appears.

If you select the Script Wizard, you can 
insert one of the 11 scripts frequently 
used into your document. These are 
provided by Namo WebEditor as 
default scripts. When selecting the 
Body Script... or Head Script..., you can 
insert them directly.
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Reference JavaScript is a script language that was developed by Netscape to 
be used to make dynamic web sites. Popular web browsers, such as 
Internet Explorer and Netscape Navigator, support JavaScript. 

Visual Basic Script, developed by Microsoft, is a script language 
supported by Internet Explorer. It is based on Visual Basic language 
but with a much simpler structure and is similar to JavaScript in its 
function.

. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . SCRIPT WIZARD
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With the Script Wizard, you can easily insert commonly used special 
effects, created using a script, into your document. 11 scripts, 
including rollover effect, animation effect, etc. are available on this 
menu.

When you select the Script Wizard from the Script command on the 
Insert menu, the Script Wizard-Select Script dialog box appears. 
Select the script you want and click the Next button.
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Rollover Effect Allows you to replace one image with another as the mouse rolls 
over it.

Name Enter the name of the roll over effect.

First Image Location Specify the image to be shown in the 
normal, or ‘off’ state.

Second Image Location
Specify the image to be displayed when the 
mouse ‘rolls over’ the image.

Preview After you specify the two images, you can 
preview the roll over effect in this dialog 
box.

Remove Rollover Effect
When selected, the rollover effect will be 
removed.

Reference When you insert the script for the Rollover Effect into the 
document, the first image is displayed at the current cursor 
position. If you modify the size of the first image from the 
Appearance tab in the Image Properties dialog box that appears 
when you double click on the first image, the size of the second 
image will be modified to the same size as the first.
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To modify the contents of the script for the Rollover Effect, after 
insertion, select the Script Wizard from the Script command on the 
Insert menu while the image selected, or click the Script Wizard 
button on the Standard toolbar.

Caution When using the script for Rollover Effect, do not use spaces or 
special symbols for the name. If you do, when you point to the 
image in the web browser., the Script Error dialog box will appear 
with the message; "An error has occurred in the script on this 
page".

Animation Effect Creates an animation effect on the current paragraph or layer. To 
give animation effect to a layer, you must first create a layer. When 
applying animation effects to a paragraph, the paragraph does not 
have to include text or images. But to clearly see the effect, you 
should enter some text or an image. For the same reason, enter 
text or images in the layer as well. The Animation Effect script 
works only in Internet Explorer or Netscape 4.x.

While placing the cursor position on a paragraph or layer, select the 
Animation Effect from the Script Wizard in the Script command on 
the Insert menu, then a dialog box appears as below.

Layer Name If a layer is selected or the cursor position is 
in it, the name of the layer is displayed 
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here. If the cursor is in a paragraph, the 
name of the layer will be suggested, like 
"alayer1", "alayer2", automatically. You can 
also enter a name of your own choice.

Starting Position Specify the starting position of the 
animation. The final position is where the 
animation will stop. You need to set this to 
see the effects clearly.

Trace Specify the type of trace for the animation. 
You have three options; Line, Curve, Spiral.

No Animation Indicates the animation effect is removed.

Preview You can preview how the animation will 
moves in a web browser from this window.

If you click this  button, you will see more detailed options. The 
options disappear when you click this  button again.

Starting Condition Specify the condition on which the 
animation begins.

Starting Time Specify how long it takes before the 
animation begins after the starting condition 
is satisfied.
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Total Steps Specify the number of steps in which the 
animation is displayed. The larger the 
numbers are, the smoother and slower the 
animation will be.

Only for IE
The Zoom In/Out and Split Each Word functionalities are available 
only in the Internet Explorer.

Zoom In/Out Characters will be larger or smaller when 
being animated. This doesn’t work with 
images.

Split Each Word Words will be animated one bye one.

A pinion appears as below where the animation effect script is 
inserted.

Drop-Down Menu You can create a script that produces a drop down menu and takes 
the viewer to a specified URL once an item on the menu is selected.
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List Window Indicates a region where items of the drop down menu 
are to be displayed.

Choice Enter the name of the item you want to add to the menu.

URL Enter the name of the URL or document to which the 
viewer will be moved to when an item on the menu is 
selected.

Add When you click the Add button, after entering Choice and 
URL, the item is added and will be displayed in the list.

Edit To modify the contents of an item, select it and modify 
the Choice and URL information. When you are 
finished, click the Add button.

Remove Removes the selected item from the list.

Up Moves the selected item one step higher.

Down Moves the selected item one step lower.

Target Frame Use this to specify the target frame where the 
document linked to the drop down menu item will be 
displayed. For more information on the target frames, 
see Frame Properties(8-13). When the document has 
no frames, leave it as "_self".

Height Specify 
how 
many 
lines on 
the drop 
down 
menu 
will be 
visible 
without 
a scroll 
bar.
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If you specify the number of lines as a lesser value than the 
number of items, a scroll bar will appear as shown below.

Jump Button Allows you to create a script that can allow the user to ‘Jump’ from 
page to page at the press of a button, literally!

Characters on Button Enter the content to be displayed on the 
button.

URL/Back/Forward Enter the name of the URL or document to 
which the visitor will be directed to when 
the button is pressed.

Target Frame Specify the target frame that the URL will 
be set in when the button is clicked. For 
more information on the type of target 
frame to use, see Frame Properties(8-13). 
When the document has no frames, leave it 
as "_self".
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Refresh Page Creates a script that redirects a visitor after a specified period of 
time.

Time Specify the delay before moving to the specified URL.

URL Enter the name of the URL or document where the 
visitor will move after the specified delay.

Remove Refresh
Removes the Refresh effect.

Access Information Allows you to create a script that will gather information from the 
visitor.
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Name of the Form Enter the name of the form where the 
visitor information is to be displayed. You 
can use the default if you are not sure what 
to put. 

Name of the Form Element
Enter the name of the text box to be used 
to display the visitor's information. Again, 
you can choose the default.

Visitor’s Name Enter the contents of the message box that 
will ask the visitor's name.

Date... When selected it will display the last day the 
document was changed.

Visitor’s IP... Displays the visitor's IP. Available only in 
Netscape.

Visitor’s Host... Displays the name of the visitor's host. 
Available only in Netscape.

Reference When you insert the Access Information script into a document, a 
form is created and the one-line text box form field appears. To 
modify the size of the text box where the information is displayed, 
double click the one-line text box form field. When the One-Line 
Text Box Properties dialog box appears, you can modify the Width in 
Characters and Maximum Length of the field.
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Clock in a Box Allows you to insert a virtual watch on your site, with time and 
date.

Name of the Form... Enter the name of the form to be used to 
display the time or use the suggested value.

Name of the Form Element...
Enter the name of the one-line text box or 
use the suggested value.

Time Format Specify the type of display, you can choose 
from either 24 hour or 12 hour.

Reference When you insert the Clock in a box script into a document, a form is 
created and the one-line text box form field appears. To modify the 
size of the text box where the information is displayed, double click 
the one-line text box form field. When the One-Line Text Box 
Properties dialog box appears, you can modify the Width in 
Characters and Maximum Length of the field.
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Scrolling Text in a Box Allows you to create scrolling text in a form field.

Name of the Form Enter the name of form to be used or 
use the suggested value.

Name of the Form Element Enter the name of the one-line text 
box where you will insert the scrolling 
text, or use the default value.

Text Enter the text that you use in the one-
line text box.

Scrolling Period Specify the cycle during which the text 
passes by in the one-line text box. The 
smaller the number, the faster the text 
will move.

Reference When you insert the Scrolling Text in a Box script into a document, a 
form is created and the one-line text box form field appears. To 
modify the size of the text box where the information is displayed, 
double click the one-line text box form field. When the One-Line 
Text Box Properties dialog box appears, you can modify the Width in 
Characters and Maximum Length of the field.
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Scrolling Text in the Status Bar

Allows you to create text that scrolls in the status bar of the 
browser.

Text 1 Enter the text that appears first.

Text 2 Enter the text that appears second.

Text 3 Enter the text that appears last.

Reference To change the contents or options of a script, after inserting it into 
the document using the Script Wizard, you must select the image, 
paragraph, layer or form field first and then select the Script Wizard 
from the Script command on the Insert menu. It is necessary to 
follow the above steps as there may be more than one of the same 
scripts in one document.

The Scrolling text in the Status Bar can be inserted only one time in 
each document, so you don't have to select anything beforehand. 
You can modify the Scrolling text after selecting the scrolling text in 
the status bar from the Script Wizard on the Script command on the 
Insert menu.
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Foldable Contents This script will create a small table of contents that visitors can view 
and navigate through. This is similar to a site map.

List Window A region where the titles of the contents are to be 
displayed.

Add Adds a new title below the selected title.

Remove Deletes the selected title.

Up Moves the selected title one step higher.

Down Moves the selected title one step lower. 

Name Indicates the name of the selected title. When you 
adjust the name, the title name in the contents will be 
changed automatically.

URL Indicates the name of the selected title's URL. 
Changing of URL will be automatically updated to the 
contents in the List window.

Target Frame Specify the target frame where you want to display 
the document linked to the title on the drop down 
menu. For more information on the target frames, see 
Frame Properties(8-13). When the document has no 
frame, leave it as "_self".
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If you click the Next button after creating the contents as shown 
above, a dialog box will then appear to help you decide on the 
appearance of the contents.

Font Select the font that will be applied to the selected title.

Size Select the font size.

Color Select the frame color.

Background Select the background color.

HighLight If you select the Coloring Rollover Effect option, then 
specify the color which will be displayed.

Coloring Rollover Effect
If you select this option it will activate the roll over 
effect. That is, when one points to the item, the color 
changes to the HighLight color.

Height Specify the height of the selected title.

Indentation Specify the indentation of the selected title.
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When you point to the inverted triangle button, the pointer will 
change to a finger. If you click on it, sub titles will then appear. With 
another mouse click, the menu will collapse. If you click the title of 
the URL which is specified, you will be sent there.

Reference The Foldable Contents script works only in Internet Explorer and 
Netscape 4.x or higher.

Layer Action Creates a script that makes an event in a layer affect another layer.

Layer Name Select the layer which the events will occur on.

List Window Displays the Event, Action and Target specified on the 
selected layer.

Event Type Allows you to select the types of event that will be 
checked on the selected layer. The events to be 
checked are OnClick (Click), OnmouseOver (Moving of 
pointer onto the layer), OnmouseOut (Moving of 
pointer out of the layer).
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Action Type Specify the action to be taken on the target layer 
when the specified event occurs. Show Layer makes 
the target layer visible whereas Hide Layer makes it 
invisible. You can choose from either.

Target Specify the target layer.

Add Adds the current setting (event type, action type and 
target) to the List.

Edit Modifies the selected items of the List to the current 
setting.

Remove Deletes the selected items from the List.

Reference The Layer Action script works only in the Internet Explorer and 
Netscape 4.x or higher.
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This allows you to insert a script into the body of a document. It 
means inserting a script to be applied to the internal structure of 
the document (in the <body> tag). The scripts being applied to the 
entire document are ones like the OnmouseOver, they must be 
inserted in Head Script.

When you select Body Script from the Script command on the Insert 
menu, the Body Script dialog box appears as shown below.

Language Specifies the type of script language to be inserted 
into the document. You can choose from JavaScript, 
VBScript and ASPScript.

Style This allows you to use CSS to change link colors and 
other options supported by CSS specification. When 
you click the Style button, the Style dialog box 
appears. For the usage of the Style dialog box, see the 
Paragraph Style(6-25).

Extended When you want to specify an attribute that is not in 
the current HTML protocol or a newly created 
attribute, Namo WebEditor does not support the 
options you require. This Extended option will allow 
you to do but you must enter this attribute manually.
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Head Script Click the Head Script button to create a script to be 
applied to the entire document that is in the <head> 
tag.

. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . HEAD SCRIPT
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Inserts a script between the <head> tags. This will be applied to 
the entire document. 

When you select the Head Script from the Script command on the 
Insert menu, the Script tab appears in the Document Properties 
dialog box. Enter or copy scripts here. 

Reference JavaScript is a script language developed by Netscape that is used 
to build a dynamic web site. Internet Explorer and Netscape 
Navigator both support JavaScript, but not 100% in Internet 
Explorer. JavaScript supported in Internet Explorer is called as 
JScript.

Visual Basic Script, developed by Microsoft, is a scripting language 
supported by Internet Explorer. It is based on the Visual Basic 
language, but with a much simpler structure than JavaScript.

ASP (Active Server Page) Script indicates a script that requires an 
ASP page on a web server. Visual Basic Script and JScript can be 
used together for Active Server pages.
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. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . ADVANCED
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This option allows you to insert a Java applet, Plug-in or ActiveX 
control.

When you point to the Advanced command on the Insert menu, a 
sub menu of three items will appear as shown below.

Reference Java is an advanced programming language developed by Sun 
Microsystems. Java has many useful functions used on the web. A 
Java applet indicates a lighweight Java application. They can be run 
in web browsers compatible with Java like.

A Plug-in is a software module that must be added to the web 
browser’s software. It helps you use a new feature or service not 
available with traditional HTML. 

An ActiveX control is similar to that of a Java applet, but differs in 
that it directly uses all the features of a Windows. 

As of today, a standard version of Internet Explorer will support 
Java applets, JavaScript and ActiveX controls. Netscape Navigator 
only fully supports Java applets and JavaScripts but can also work 
with ActiveX controls and Visual Basic Script with additional plug-ins 
(see the Netscape site).
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. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . APPLET
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This gives you the option of entering in a Java applet.

When you select the Applet on the Advanced command on the Insert 
menu, then the Applet Properties dialog box appears.

Code Enter the file name of the Java applet to be inserted. 
The extension name of the Java applet should be 
'class' or 'cla'.

Codebase Enter the path of the Java applet file. You can enter 
the URL for it.

Name Specify the Java applet name. It is best to use letters 
while doing this. The name you enter here is not the 
file name but the name used to tell one Java applet 
from another.

Alt Text Enter the description for the applet. When a web 
browser can't display the applet, a surfer can see the 
description instead.

Alignment Basically the alignment is the same as that of the 
image. For more information, see Image(5-7).

Size Specify the width and height of the screen in which the 
Java applet software is launched. When you use pixels, 
you can specify the fixed size. While you can specify 
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the proportional�size to the web browser window, 
using percentages.

Space Specify the margin around the screen where the Java 
applet software is to be launched. When you specify a 
Horizontal value, you will put spaces in pixels as 
specified to the left and right of the applet screen. 
When specifying the Vertical value, you put spaces at 
the top and bottom.

Parameters Use this when you enter the general variables that will 
be handed to the Java applet software. When the 
Parameters dialog box appears, click the Add button. 
Then enter the parameter name and value.

Caution Namo WebEditor only helps you enter the size of the Java applet 
and the associated directives; it doesn't launch it. Therefore, it does 
not show how the Java applet works. To check if it works properly, 
preview the web page in your web browser.

. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . PLUG-IN
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This allows you to insert a plug-in into your web document.

When you select Plug-In from the Advanced command on the Insert 
menu, then the Plug-In Properties dialog box appears.
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Source Specify the file name of the Plug-in.

Alt Text Enter the description for the Plug-in. When a web 
browser can't display the plug-in, the viewer will see 
the description instead.

Alignment The alignment is the same as that of the image. For 
more information, see Image(5-7).

Size Specify the width and height of the screen in which the 
Plug-in file is to launch. When you use pixels, you can 
specify the fixed size. While you can specify the 
proportional size to the web browser window by using 
percentage.

Hide Plug-In When you select this option, the plug-in becomes 
invisible on the screen. If you activate the Format 
Marks, you can see the plug-in format mark.

Space Specify the margin around the plug-in file. When you 
specify a Horizontal value, you put spaces in pixel as 
specified to the left and right of the plug-in. When 
specifying the Vertical value, you put spaces at the top 
and bottom.

Border Put borders around the plug-in file. Because the 
Internet Explorer doesn't support borders, it cannot be 
seen.

. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . ACTIVEX CONTROL
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This allows you to enter in an ActiveX control.

When you select the ActiveX control... from the Advanced command 
on the Insert menu, then the ActiveX control dialog box appears.
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Class ID Enter the class ID of the ActiveX control to be inserted. 
All ActiveX controls have unique class IDs. When you 
click the drop down menu button, the available 
(installed on your system) ActiveX control list appears.

ID Enter the ID that is needed to use the inserted ActiveX 
control in script.

Alt Text Specify the text to be displayed if the ActiveX control 
cannot be loaded.

Codebase Enter the path of the ActiveX control.

Alignment The alignment is same with that of image. You can see 
Image(5-7).

Size Specify the width and height of the ActiveX control. 
When you use pixels, you can specify the fixed size. 
While you can specify the proportional size to the web 
browser window by using percentage.

Space Specify the margin around the ActiveX control. When 
you specify the Horizontal value, you put spaces in 
pixels as you specified at the left and right of the 
control. When specifying the Vertical value, you put 
spaces at the top and bottom.
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Parameters Use this to enter the general variables that will be 
handed to the ActiveX control. When the Parameters 
dialog box appears, click the Add button and enter the 
parameter names and values.

Caution Namo WebEditor only helps you enter the ActiveX control, it doesn't 
launch it. Therefore, it does not show how the ActiveX control 
works. To check that it works properly, preview the page in a web 
browser.

. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . THEME OBJECT
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This allows you to insert a Theme Object into your web document. 
When you select the Theme Object command from the Insert menu, 
the Theme Object Property dialog box appears. For more 
information on this dialog box, see Theme(6-42).
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. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . HYPERLINK
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Sets specific content as a hyperlink. 

When you select the Hyperlink command from the Insert menu or 
press the <F9> key, the Create Hyperlink dialog box appears.

URL Specify the location to be connected to the hyperlink. 
You can specify the URL or name of the HTML file, 
bookmark or image. If the target is a document in the 
same web server, you may then simply enter the path 
and file name. 

Bookmark When you want a bookmark in the linked document as 
a target, specify the bookmark name here. When the 
linked document includes no bookmark, the bookmark 
list is empty. If you specify the URL, however, you can 
see the list of all bookmarks that are set in the current 
document. You can then either select a current 
bookmark, or choose to create your own. 

Target Frame When you create the hyperlink from a document that 
has frames, you will need to specify the target frame 
into which the linked document will open. You don't 
have to specify this in a document

�without frames.

Hyperlink can be easily created with the above three contents. If 
you use the following three buttons, URL specification will be easier.



INSERT
Hyperlink

5-56 Namo WebEditor 3.0 User Manual

55

Browse Open the Open dialog box. You can specify a file on 
the hard disk through this dialog box.

Open Files Show all the files open at the current time. You can 
select from them.

Clear Link Remove all the contents of the URL field.

URL components are used when you specify the hyperlink location 
more precisely.

Scheme Specify the type of scheme of the hyperlink. When 
creating a normal hyperlink, select 'http://'. To launch 
mail software, select 'mailto'. When you select the 
mailto, 'mailto:' appears instead of 'http://'. You then 
need to enter the e-mail address at the end of 
'mailto:' (e.g. 'info@namo.com').

Host Enter the name of the web server to be connected to 
the hyperlink.

Path Enter the path and file name that will follow the URL of 
the web server.

Bookmark Specify the bookmark name when you want the 
bookmark to be targeted in the linked document.

Parameters Enter the information wanted on the web server, or to 
be passed over to a CGI script or other program. The 
contents entered as the Parameters appear next to ‘;’ 
in the URL field.
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Query This allows you to transfer certain information to CGI 
scripts or other similar programs. The contents 
entered as the Query appear at the next of '?' in the 
URL field.

Encode Path Adjusts the special characters in the URL in the way 
that is agreed on in advance. For example, it changes 
the '@' to '%40', and space to '%20'.

Decode Path Uses the special characters in the URL as it is entered 
first. For example, it changes the '%40' to '@', and 
'%20' to a space.

Reference To check the hyperlink in the edit window, select the Follow 
Hyperlink from the menu which appears when you right click on a 
hyperlink, or when you click while pressing the <Ctrl> key on your 
keyboard.

. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . REMOVE HYPERLINK
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This will remove the hyperlink. When you select the Remove 
Hyperlink command from the Insert menu with the cursor on the 
hyperlink, the hyperlink will be deleted.

. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . EQUATION
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Select, to enter a math formula at the insertion position using the 
Equation editor.

When you select the Equation command from the Insert menu, the 
Equation dialog box then appears. After entering the formula here, 
click the OK button.

On the Visual tab you would usually enter the formula using the 
mouse. However, while on the Script tab, you can enter the formula 
using the Tex/LaTex grammar.
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Visual On the Visual tab, enter the equation using formula and special 
symbol buttons. You now no longer have to remember complex 
symbols and formulas!

1 Use the keyboard when entering all normal variables and symbols. 
A triangle will take the place of a mouse cursor here. When you 
click the formula button you want, the formula will be entered. The 
triangle then appears where the variable or symbol is to be 
entered.
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2 If you click the fraction button, it is displayed as shown below. 
When you click the magnifying glass button, you can resize the 
formula to your specifications.

3 After completing the formula, click the OK button. The formula then 
appears at the current cursor position.

Caution The formula entered by using the Equation editor is inserted as an 
image. It is saved in the same folder as your main HTML file. 
Although it is an image, you can not adjust its properties.
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Script On the Script tab you create the formula by entering the formula 
script directly. This is rather difficult for even advanced users. On the 
formula script, see the 'equation.html' document in the 'DOC' folder, 
it's one of the sub folders of the folder where the Namo WebEditor is 
installed. It will give you more information on formulas.

. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . ETC.
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When you point to the Etc. command on the Insert menu, a sub-
menu of five items appears.
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Nonbreaking Space This will enter a nonbreaking space(&nbsp) into your HTML 
document. This allows you to put more than one space between 
words.

According to the HTML protocol of W3C, two or more successive 
spaces are counted as only one space. Thus when you open a text 
format file in HTML format, all successive spaces are replaced with 
one single space.

There are times when you will have to enter the successive spaces 
into your HTML document, this is when the Nonbreaking Space 
comes in very useful! In Namo WebEditor you don't have to select 
the Nonbreaking Space on the Etc. command every time you want 
to enter in a successive space. In Namo WebEditor, each time you 
press the spacebar after the first space, Nonbreaking Spaces are 
automatically entered.

Time/Date This will enter the time and date at the current cursor position.

When you select Time/Date from the Etc. command on the Insert 
menu, the Date/Time dialog box appears. Select the type you want, 
and click the OK button. The current time and date is inserted at 
the current cursor location as text.

Component This option allows you to enter a component at the current cursor 
position. You can select the type component from the list of forms 
you frequently use.

When you select the Component from the Etc. command on the 
Insert menu, the New dialog box appears. Select the component 
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here and click the OK button. The component is then inserted into 
the current document.

When the Insert Onto the Current Document option is inactive, a 
new document is automatically created and the selected component 
will be inserted inside.

File This allows you to insert a file into your HTML document. The file to 
be inserted will have to be in the HTML or text format.

The file will be inserted at the current cursor position by selecting 
File from the Etc. command on the Insert menu. If you select the 
Open command from the File menu, the document will be displayed 
in a new edit window. In this way you can merge the two 
documents.

HTML Tag This allows you to insert a tag used in a particular browser, or an 
extended tag, into the document. When you want to specify an 
attribute that is not in the current HTML protocol or a newly created 
attribute, Namo WebEditor does not support the options you 
require. This option will allow you to do but you must enter this 
attribute manually.

When you select the HTML Tag on the Etc. command on the Insert 
menu, then the Extended Tag and its Attributes dialog box appears. 
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The tag and attributes you enter in this dialog box can't be shown 
in the Namo WebEditor edit window, you will need to launch a web 
browser to check it.

When you click the Add button, the Attribute Name and Value dialog 
box appears. After entering the name and value of the attribute, 
click OK. You can also add the attribute as you want and then click 
OK.
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. . .
. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .
Format 6

Format menu provides the 
commands that help you make 
your web site look appealing. You 
can decide the appearance of 
characters, paragraphs, forms, 
pages, document, and your web 
site with options available on this 
menu. The characters and 
paragraphs are especially 
important as they will give your 
web site its final look and feel. 
This menu is important and you 
must be capable of using the 
commands and options on this menu to create an effective web 
site. The most frequently used commands are available on the 
Format toolbar for your convenience.

. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . FONT
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Select, to modify the character style, size and color and to change 
the font typeface.

When you select the Font command on the Format menu, the Font 
Properties dialog box appears. Select the options on the font 
properties that you want, then click the OK button. The options 
used frequently are on the Styles tab, and the remainder are on the 
Extended Styles tab.
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Style You can apply five styles to a character while its attributes are 
retained.

Bold <Ctrl+B>  Select to make character boldfaced.

Italic <Ctrl+I>  Select to italicize character, that is, slanting 
it to the right.

Underline <Ctrl+U> Select to underline the word you want.

Strikethrough Select to draw a line running through the 
characters.

Typewriter Select to modify the font type to a 
typewriter-like one.

Super/Subscript Select, to make a character superscripted or subscripted.

Below are examples of super/subscript and various character styles.
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Size You can specify the character size using pre-set sizes as the basis. 
Seven pre-set sizes are available; 1 (8 point), 2 (10 point), 3 (12 
point), 4 (14 point), 5 (18 point), 6 (24 point), and 7 (36 point). 
The Normal size is 3 (12 point) by default. You can change the 
normal size font by clicking the Style button on the Appearance tab, 
in the Document Properties dialog box. This is also a CSS style 
function.

Color You can specify the color for characters. The default color is labelled 
Default in the drop down box. But the Default is not indicating any 
particular color, it is a color that you can choose in the Text item, on 
the Appearance tab in the Document Properties dialog box. That is, 
you can change the Default whenever you want.
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However, you can save time by using Font color button ( ) on the 
Format toolbar, to change the character color. When you click this 
button, the color, below the letter A in the button, will be applied to 
the character. If you want to change the color, click the drop down 
menu button to the right of the Font color button( ). Then select 
the color that you like.

Reference The background color button ( ) is also available at the right of 
the underline
button on the Format toolbar. This button is different 
from the font color button in that it lets you change the background 
color of characters. Using this button is the only way to change the 
character color of a single letter. If you want to adjust the character 
color by paragraph, select Colors, on the Paragraph Style command 
on the Format menu.

Caution When you choose the Font command on the Format menu, while 
selecting words with different attributes, the content of the Font 
Properties dialog box will be slightly different.
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If the check( ) mark appears obscure, or the name of the Size or 
Color options don't appear, it indicates you have selected words that 
have different attributes. If you click the OK button, while these 
attributes remain unchanged, the colors will also not change.

However, after clicking on the options you want or specifying the 
Size or Name of the character, the attributes you selected will be 
applied to the characters overall. Be cautious before you click the 
OK button.

Reference If you select Custom, you will have the choice of your own color 
besides the 16 default colors.

The Color dialog box which appears when the color depth is 256 colors.

After selecting the color that you want on the Custom Colors 
palette, click the OK button. When the color you want is not 
available, you can make your own. After making a color you want, 
click the Add to Custom Colors button. Then the color will be added 
to the Custom Colors palette.

You can change the Window’s color depth from 256 colors to 16 bit 
or 24 bit colors. After right clicking on the Windows screen, select 
the Properties on the short cut menu. Then the Display Properties 
box appears. By selecting the Settings tab you can see the Colors 
and Screen area information. Here, the information pertaining to 
the Colors is the Window’s color depth. When you adjust the 256 
colors to 16 bit or 24 bit colors and there is not enough memory on 
your video card, the Screen area will be reduced.
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The Color dialog box which appears when the color depth is 16 bit or higher. You
can check the HTML color value in the Color dialog box.

Of the colors on the screen, you can select the one you want in the 
Color dialog box. Click the eyedropper shaped button and then click 
the color you want. The color of your choice will be displayed on the 
color palette. The color value for the HTML code is always displayed 
as well.

Extended Styles While the features of characters are maintained, you can apply nine 
kinds of styles to the characters.

Citation Select to indicate text that is cited.

Blink Select to make characters blink with fixed intervals.

eyedropper
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Strong Select to indicate strong emphasis.

Code Select to show that characters indicate program like 
code.

Definition Select to show that characters indicate the definition of 
a certain element.

Emphasis Select to emphasize. This is weaker than the Strong 
emphasis.

Keyboard Select to indicate text that you entered using a 
keyboard-like font.

Sample Select to indicate a sample.

Variable Select to indicate a name of a variable.

Font You can specify the fonts you want to use in your document. The 
Default value, is the same one you chose on the Font tab in the 
Style dialog box. This Style dialog box appears when you click the 
Style button on the Appearance tab in the Document Properties 
dialog box. In case, the font you want is not available, you can 
specify a spare font.

First Font Specify the first font you want.

Second Font Specify the second font to be used when the first font 
is not available. Try to specify a commonly used font.

Caution Any font installed on your system is available. However, if the font 
you select is not installed on a visitor's computer, it will be replaced 
with another font. For this reason, we recommend you use 
commonly used fonts.
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Extended To use a tag not conforming to the HTML rules that Namo 
WebEditor supports, click the Extended button. The Extended 
Attributes dialog box appears. After clicking the Add button here, 
enter the Name and Value of the Attribute. Then click OK.

. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . CHARACTER
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Select to resize the character. Seven pre-set sizes are available; 1(8 
point), 2(10 point), 3(12 point), 4(14 point), 5(18 point), 6(24 
point), and 7(36 point).

Increase Size  Increase the size one step. Text will not be 
increased beyond 7th step.

Decrease Size Decrease the size one step. Text will not be 
decreased beyond 1st step.

CLEAR ALL CHARACTER ATTRIBUTES <Ctrl+E> 
Clear all the attributes of the character, such 
as color, size, and style.
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. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . PARAGRAPH...
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Select to adjust the shape of a paragraph.

When you select the Paragraph... command on the Format menu, the 
Paragraph Properties dialog box appears as below. Select the options 
on the shape of the paragraph as you want, and then click OK.

Type Select the kind of paragraphs that you want. When you choose a 
list, you should specify additional options.

Paragraph Type
Select the paragraph type. To save time, you can use the Change 
Paragraph Style drop down menu on the Format toolbar.

Normal Indicates normal paragraph type. If you specify the 
listed paragraph as the Normal paragraph, the bullets 
or numbers on the list will be removed. However, the 
indent will remain, but will be removed by selecting 
the Decrease Indent command on the Format menu.
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Heading n Indicates the paragraph in the form of the heading. 
Heading 1, 2, 3, 4, 5, and 6 are available. The size of 
character will be at its largest when the Heading 1 is 
selected. It becomes smaller, as it gets to higher 
heading numbers. When you create a new paragraph 
by pressing the Enter key on your keyboard, it will 
become a Normal paragraph automatically.

Formatted Select to keep the content you entered unchanged. If 
you select this option, the line and spaces will not be 
changed. The fixed font is used here, and only the left 
alignment is available with this option.

Address Indicates that the contents is an address. Italics will be 
applied to it.

Definition Term
Indicates it is a heading to be explained. It will appear 
boldfaced and indents cannot be applied to it.

Definition
Indicates it is an explanation for a heading. To select 
this type, it must be preceded by a Definition Term.

Bulleted List A paragraph where a bullet list appears at the start. 
The round bullet will be automatically used if you 
specify a bulleted list on the Change Paragraph Style 
drop down menu on the Format toolbar. When you 
want a square or circle shaped bullet, select it by using 
the Paragraph... command on the Format menu. 
When you press the <Enter> key on your keyboard 
without entering anything, it will become a Normal 
paragraph.

Numbered List
A paragraph where a serial number is displayed at the 
start. When you select a numbered list on the Change 
Paragraph Style drop down menu on the Format 
toolbar, Arabic numbers will be used. To use alphabet 
or Roman instead, or to start from another ordinal 
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number larger than 1 in the Numbered List, you use 
the Paragraph... command on the Format menu. 
When you replace the Arabic number with Roman or 
alphabet, or change the starting number, the following 
numbering will change automatically to match your 
choice. When you press the <Enter> key on your 
keyboard without entering anything, it will become a 
Normal paragraph.

Caution If you change the number from Arabic to Roman or alphabet after 
you specify the 0 as the starting number in the Numbered List, the 
numbering that follows may vary with web browsers. It is best to 
start from 1 or another number.

Reference The Bulleted List and Numbered List are so frequently used that the 
tool buttons for these lists are prepared on the Format toolbar. By 
clicking the buttons once(  ), you can change the type of the 
current paragraph to Numbered List, or you can reverse the change 
by clicking once more.

Align/Line Height Select the way in which a paragraph will be aligned and the height 
of line.

Alignment type You can choose from Left, Right, Center and 
Justify. The Default is the way of alignment that 
you select on the Appearance tab in the Style 
dialog box. The dialog box appears when you click 
the Style button on the Appearance tab in the 
Document Properties dialog box.

Line Height type You can select from three options; 1 line (No Para. 
Space), 1 and 1/2 line and 2 line. The 1 line 
(default) is the line height that you select on the 
Text tab in the Style dialog box. The dialog box 
appears when you click the Style button on the 
Appearance tab in the Document Properties dialog 
box.
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Margin You can specify the distance between the left/right margin and the 
text. You can also indent the first line of a paragraph. You can 
select the unit of value for margin and indentation from the 
following nine options: %, point (1/72 inch), mm, cm, pica (1/6 
inch), inch (2.54cm), pixel, em (height of font), and ex (height of 
small letter x). You can get more detail on the unit at the Paragraph 
Style(6-25).

Line Height You can specify the distance between lines, and the height of the 
top and bottom of the paragraph.

Reference The Margin and Line Height are the most frequently used options of 
CSS (Cascading Style Sheets) with DHTML in modifying the shape 
of a paragraph. If you click the Style button in the Paragraph 
Properties dialog box, you can adjust all the options of a paragraph 
style.

Style Select to adjust the shape of a paragraph with more advanced 
options. If you click the Style... button, the Style dialog box 
appears. The options you select in the Style dialog box will only be 
applied to the current paragraph where the cursor is. You can get 
more information on how to use the Style dialog box in the 
Paragraph Style in this manual.

Extended To use a tag, not bound by the HTML rule that the Namo WebEditor 
supports, click the Extended... button. The Extended Attributes 
dialog box appears. After clicking the Add button here, enter the 
Name and Value of the Attribute. Click OK.
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Caution When you choose the 
Paragraph... command on 
the Format menu while 
you have selected 
paragraphs with different 
attributes, the content of 
the Paragraph Properties 
dialog box will be 
different slightly.

If the check( ) mark, to the right of the margin or height options 
appears obscure, or if the names of the Paragraph Type or 
Alignment options do not appear, it indicates you have selected 
paragraphs that have different attributes. If you click the OK 
button, while their attributes remain unchanged, the attributes will 
remain as before.

However, after clicking on the options you want or specifying the 
Paragraph Type or Alignment, the attributes you select will be 
applied to the paragraphs overall. So be cautious before you click 
the OK button.

The same is applicable to the 
options in the Style dialog box 
that appears when you click the 
Style button in the Paragraph 
Properties dialog box. However, 
it is not applicable to the 
Extended Attributes dialog box 
that appears when you click the 
Extended button. When you 
specify a tag name and value in 
this Style dialog box, if there is a 
paragraph that includes a tag having the same name, the existing 
values will be replaced with new ones automatically.
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Select to change the attributes of a form or form field.

Reference The form is a set of fields into which data is to be entered. The data 
you enter in a form is used to communicate with your server. 
Usually the form is used with a CGI program or scripting language, 
so it will be rather difficult for the first-time user.

Information Form Name Enter a form name that could indicate the function of 
the form.

Target Frame Enter the name of the target frame, if a form is for 
another frame.

Settings Action After filling in a form, specify the URL to which data in 
the form will be transferred. If you do not specify the 
URL or enter a relative URL, the Base URL of the 
current document will be used instead.

Method Specify the way you transfer data. GET and POST are 
two options available. Specify one to conform to your 
CGI program.
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Encoding Type
Specify the type of MIME (Multipurpose Internet Mail 
Extensions) encoding that will be used on the form. 
MIME is a protocol for transferring non-ASCII 
information across the Internet. Using the MIME 
protocol, you can transfer image, sound, and 
multimedia files.

Hidden Field Select to create a hidden field. The hidden field is invisible to the 
user, but its value is transferred with a form. If you click the Hidden 
Field button, then the Attribute Name and Value dialog box appears. 
Enter the name and value of the attributes. Then click OK.

Clear Form If you want to delete a form, select the Form command on the 
Format menu with the insertion position in the form. Click the Clear 
Form button, and then click OK. This is for deleting a form, not a 
form field. To delete a form field, press the <Delete> on your 
keyboard while the insertion position is at the left of the form field.
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Select to modify or check the properties of a document. The 
properties that you modify by using the Document Properties... 
command on the Format menu, will be applied to the current 
document only.

Information The tab for changing or checking the information on a document.

Location The path or URL of a folder that includes the current 
document is shown. You can modify the location 
information in this dialog box. To modify, select the 
Save As command on the File menu.

Base LocationThe field for entering a base location to be assigned to 
a relative URL of the current document. The full URL is 
made by adding 'the relative URL of the document' to 
'the URL assigned to the base location'. The base 
location is ignored, where the absolute URL is used.

Absolute URL: http://www.namo.com/product/index.html

Base location: http://www.namo.com/

Relative URL: product/index.html
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Title Enter the title of the current document. The title of the 
document is shown on the Title toolbar in the web 
browser and the Namo WebEditor. Because some 
search engines show just the title of the web 
document, be sure to enter a meaningful title.

Author Enter the author of the document. If you have already 
entered the author name into the Author field on the 
Document Default tab on the Preferences command 
on the Tools menu, the name will be suggested as the 
author name of the new document. You can also 
change the name in the Document Properties dialog 
box.

Description Enter a short description for the content of the current 
document. The search engine will show the description 
along with the title of the web document.

Keyword Enter the keyword for the document. The search 
engine, such as Yahoo, uses a keyword and 
classification method for the users convenience. If you 
enter the classification or keyword of a document, the 
list server of the search site will classify it properly.

Classification Enter the classification conforming to the content of 
the document.

Default Target Frame
Specify the window or frame to which you want to 
transfer the content of the document.

Appearance You can modify or check the options on the shape of the document 
using this tab. If you are a beginner, just try on a background color 
or image. There will be time later for you to work on the rest.

Document Colors
You can specify the color of the background, characters, and 
hyperlink of a document. You can select from 16 suggested colors 
within the dialog box or select Custom.
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Background Specify the background color of the 
document. The default is white.

Text Specify the color of the characters. The 
default is black.

Hyperlink Specify the color of a hyperlink which has 
not been visited. The default is blue.

Visited Hyperlink Specify the color of a hyperlink which has 
already been visited. The default is purple.

Active Hyperlink Specify the color of hyperlink which is being 
visited. The default is red.

Reference If you select Custom, when specifying the color of characters, you 
will have the choice of your own color besides the 16 colors 
suggested as default colors.

After selecting the color that you want on the Custom Colors 
palette, click the OK button. When the color you want is not 
available, you can make your own. After making a color you want, 
click the Add to Custom Colors button. Then the color will be added 
to the Custom Colors palette.
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Background
Specify the image file for the background of the document or sound 
file that plays when the document opens.

Image Specify the background image of the document. When 
you open the document with background image by 
entering the URL, the name of the image file appears 
here. If you select a small image file for the 
background image, the image will be applied to the 
background repeatedly as long as the background 
space allows.

Clip Art You can select one of various clip arts suggested by 
the Namo WebEditor as background. You can choose 
not only from the files on hard disk but also from a 
Web site. In this case you should have a URL. For 
more information, see Clip Art(5-13).

Browse You can choose the image file for the background 
image, by specifying the URL of the file. You can 
choose not only from the files on hard disk but also 
from a Web site. In this case you should have a URL. 

Copy Image If you select this option, the Copy Resource dialog box 
appears when saving the document. The Copy 
Resource dialog box is for saving the image file along 
with the current document in the sub folder of the 
document. The suggested name for the sub folder is 
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'images', or you can specify your own. The purpose of 
this function is to avoid deleting or damaging the 
resources of the document by mistake when you 
publish. For more information, see Copy Image(5-8).

Sound Specify the sound file that plays when the web 
browser opens a file. The 'WAV (*.wav), MIDI (*.mid), 
AIFF Sound (*.aif, *.aifc, *.aiff), and AU Sound (*.au, 
*.snd) are available.

Loop Specify the number of times that a selected file plays.

Forever Makes the file you choose play repeatedly.

Browse You can specify a sound file for background music by 
entering its URL. You can choose not only from the 
files on a hard disk but also from a Web site. In the 
latter case you should have the full URL of the sound 
file.

 If you click this button, the selected sound file plays 
using the sound card and speaker of your system for a 
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test. This will help you select the file you choose for 
the background music.

Click to stop the file playing.

Reference • The WAV was developed by Microsoft and IBM and is supported 

by Windows. Therefore it has become a standard sound file 

format. Its shortcoming is that its too big.

• The MIDI(Musical Instrument Digital Interface) is the standard 

protocol for playing music made by the electronic music 

business. Almost all sound cards support the MIDI, although 

some of them don't fully support it. Its merit is its small size but 

it only records the sound of musical instruments.

• AIFF(Audio Interchange File Format) was developed by Apple. It 

is the protocol for recording or transferring sample sound. It is 

the standard sound file format for the Macintosh. The size of 

files, 'aifc' or 'aiff' extension names, are rather small, because 

the files are compressed.

• The AU (Audio) file format is widely used in the Unix system. It 

is the standard sound file format for JavaScript.

• The background music inserted in the Namo WebEditor will play 

only Internet Explorer. When you use Netscape, press the 'F6' 
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key. Then insert the HTML tag in the HTML window yourself. For 

example, "<embed src="../FileUpload/webeditor/filename" 

autostart="true" loop="true" hidden="true">. This is because 

the way web browsers interpret the HTML tag is not unified yet.

Style
If you click the Style button in the Document Properties dialog box, 
the Style dialog box which affects the contents of whole document 
will appear. You can see the list of styles that are specific to the 
document on the Class tab.

The values you specify in this dialog box will become the default 
value for your document. For example, the style you select on the 
Class tab becomes the basic style of the document. The font and 
size you select on the Font tab, will be the Primary Font and the 
Normal size.

More information on the Style dialog box is available on Paragraph 
Style(6-25).

Extended
To use a tag not bound by the HTML rule that the Namo WebEditor 
supports, click the Extended... button. The Extended Attributes 
dialog box appears. After clicking the Add button here, enter the 
name and value of the Attribute. Click OK.
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Advanced This tab is for specifying the advanced tags. The ordinary user 
doesn't have to know about this. These tags are not for the body of 
the document but for the meta tag which belongs to the head of 
the document.

System Variables
The HTTP-EQUIV variable is for creating an HTTP 
response header. This header is used by the web 
browser or web server. After clicking the Add button, 
enter the name and value. Click OK.

For example, when you specify 10 seconds as the 
document refreshing time, it will be converted into a 
meta tag like this; <META HTTP-EQUIV="Refresh" 
CONTENT=10">. If you open this document, it will be 
refreshed every 10 seconds.
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If you adjust this meta tag, you can make other URLs 
connect automatically after a fixed time. For example, 
the meta tag for connecting to other URLs after 90 
seconds is <META HTTP-EQUIV="Refresh" 
CONTENT="90; URL= http://www.newurl.com ">

There are many complicated system variables besides 
the variables referred to here. However, these 
variables are not for the ordinary user but for web 
developers who may wish to add more complex 
statements in their web pages.

User Variables
Used to specify user variables. You create a user 
variable for a particular CGI script or browser 
software, thus a regular HTTP or web browser can't 
recognize these variables. The generator variable is 
one of the more frequently used variables. It provides 
the name of the software with which you created the 
web document. Namo WebEditor recognizes and 
protects its own comments, so you can not delete 
them.

Encoding Select the CharSet for the language you will use in 
your document. A web browser chooses the language 
for a document according to the pre-set encoding 
type, and it selects the CharSet that matches the 
CharSet of the web page and displays these 
characters. If a document written in 2 byte characters 
is full of odd signs when you open it, check that the 
CharSet used is conforming to the language.
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Select to adjust the style of paragraph at the current cursor 
position. You specify a new paragraph in your web page whenever 
you press the <Enter> key on your keyboard. This Paragraph Style 
is CSS compliant.

If you select the Paragraph Style command on the Format menu, 
the Style dialog box appears. You can specify the type, size, style, 
color of the font, background image, alignment, line spacing, 
paragraph margins, and paragraph borders.

Class You can specify a pre-set class for the paragraph style. You should 
create a class by selecting the Style Sheet command on the Format 
menu, before you use it. Select a class from the listed classes, then 
click OK. You can't see the options of the selected class in this 
dialog box.

Enter the ID attribute to specify the object name that will help you 
tell objects. The first letter must be alphabetical, and you may use 
the underline(_) after that. To specify the ID, there should not be 
another of the same ID.

Reference The ID is rather difficult for beginners to use and it will only be used 
rarely. Usually it is used to hand over an object as a factor to a 
function in script.
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Font You can adjust the type, size, style, and width of a font.

Font Names
You can specify the Primary Font and Secondary Font as the type of 
fonts to use in the document. When you click the drop down menu 
button to the right of each font field, the list of fonts installed on 
Windows appears. You can also specify more fonts using the fonts 
text box below the Secondary Font

If the font you select as the Primary Font is installed on the web 
browser’s computer, the document will be displayed in the font you 
selected. However, when the Primary Font is not available, the 
Secondary Font will be displayed. 

NOTE: You can select the Secondary Font only from 'serif', 'san-
serif', 'cursive', 'fantasy', and 'monospace'.

Reference The Primary Font and Secondary Font displayed in the Font field are 
separated by a comma (,). If you want to add a third font to them, 
you must separate it with a comma as well (for example, to add the 
'cursive' font, specify as; 'serif, san-serif, cursive'). You may add as 
many fonts as you want in this way.
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Cancelling Options
If you have selected any of the options for a paragraph, a check( ) 
mark will appear in the box on the left. You can click on each of 
these boxes to select (mark with a check) or clear (remove the 
check) those option. In terms of an HTML document, removing the 
check mark is the same as deleting an HTML tag.

Caution When you choose the Paragraph Style on the Format menu, while 
selecting paragraphs with different attributes, the content of the 
Style dialog box will be slightly different.

If the check( ) mark to the right of each option is obscure, it 
indicates you have selected paragraphs that have different 
attributes. If you click the OK button while their attributes remain 
unchanged, the attributes will also not change.
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Once you choose your options, the selected attributes will be 
applied overall. So be cautious before you click the OK button.

Size
You can specify the size of a font in four different ways, using the 
length unit, proportion, relative size, and absolute size. A minus 
value can not be entered.

Proportion(%) Specify the size of font in proportion to the font size 
you select in the Document Properties command of 
the Format menu. This may vary with web browsers 
also.

Length Unit The way of specifying the size of a font using the 
commonly used length unit. When using this method, 
enter the value first and then specify the unit. The 
length unit could be divided into two units; the 
absolute and the relative length. The absolute length 
includes point (1/72 inch), mm, cm, pica (1/6 inch), 
and inch (2.54 cm). The relative length includes pixel, 
em (height of font), and ex (height of small letter x).

The standard for 'em' and 'ex' is the size of font you 
selected Document Properties command of the Format 
menu. This may vary with web browsers also.
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Absolute Size Specify the size of the font using a pre-set size. The 
'xx-small', 'x-small', 'small', 'medium', 'large', 'x-large', 
and 'xx-large' are available. The actual size depends 
on the web browser you use.

Relative Size Specify the size of font using relative size. The relative 
size is not a pre-set one, it is decided by the font size 
you select on the Document Properties command of 
the Format menu. Thus the actual size may vary with 
web browsers. Two kinds of sizes, smaller and larger, 
are available.

Decoration
You can apply the decoration effect to the font. The Decoration has 
five options; underline, overline, line-through, blink, and none.

Style
You can select the options that slant the font. The italic and oblique 
are slightly different. When you use the serif family font, you can 
see the difference between the italic and oblique. But when using 
san-serif family font, the difference can be ignored.
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Weight
You can specify how thick the font will be. You can choose from 13 
options (normal, bold, bolder, lighter, 100-900), but actually your 
range of a choice is from 100 to 900; that is, you really only have 
nine options. The normal is 400 while the bold is 700. The bolder 
and lighter are not fixed thickness, they may vary with the 
thickness of font you select on the Document Properties command 
of the Format menu.

Colors You can select the colors of fonts, background colors, and the 
background image. When you select both the background color and 
image, only the background image will be displayed since it is 
placed above the colored background.

Color
Specify the color and background color of the font.

Foreground Specify the font color. The default (16 suggested 
colors) and Custom are available. If you use the Font 
Color button( ) on the Format toolbar, you can 
specify the color of each letter. The Font Color button 
uses a font tag, while the Foreground color uses a 
style tag.

Background Specify the background color of the font. The default 
(16 suggested colors) and Custom are available. If you 
use the Background Color of Text button( ) on the 
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Format toolbar, you can specify the background color 
of each letter. The Background Color of Text button 
uses a span tag and the Background color uses a style 
tag.

Reference If you select Custom, you will have the choice of your own color 
besides the 16 default colors.

The Color dialog box appears, when the color depth is set as 256 
colors on Windows, and the Color dialog box, appears when the 
color depth is set at 16-bit color. You can also see the HTML color 
value in the Color dialog box. For more explanation, see Color(6-3).

After selecting the color that you want on the Custom Colors 
palette, click the OK button. When the color you want is not 
available, you can make your own. After making a color you want, 
click the Add to Custom Colors button. The color will then be added 
to the Custom Colors palette.

Background Image
You can select the background image for the paragraph and choose 
some options. For the time of your selection being not available, 
you had better select the background color.

URL Specify the location and the name of the image file.

Browse Instead of selecting a file name, you can specify the 
URL of the image file. You can choose not only from 
the image files on hard disk but also from a Web site. 
In this case you should have a URL. For more 
information, see Image(5-7).

Attachment You can decide whether to make the background 
image file scroll along with the document or remain 
fixed. You must select this option clicking Style button 
only on the Document Properties dialog box, not the 
Paragraph Style command. See also Document 
Properties(6-16).
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Repeat You can decide whether to display the background 
image repeatedly or not. Four options are available; 
repeat (repeat horizontally and vertically), repeat-x 
(repeat horizontally), repeat-y (repeat vertically), and 
no-repeat (not repeat).

Vert. Pos. Specify the distance between the left margin of the 
document and the background image. You can specify 
the distance by using one of the following units, %, 
point (1/72 inch), mm, cm, pica (1/6 inch), inch 
(2.54cm), pixel, em (height of font), and ex (height of 
small letter x). The top, center, and bottom are not 
units, but the selected location within the height of the 
document.

Horz. Pos. Specify the distance between the top margin of the 
document and the background image. You can specify 
the distance by using one of the following units, %, 
point, mm, cm, pica, inch, pixel, em, and ex. The left, 
center, and right are not units, but the selected 
location within the width of the document.

Text You decide the way to align, indent, and space between lines and 
characters. You have to select from the pre-set distances when 
using the Increase/Decrease Indent command on the Format menu. 
But you can specify the distances freely here.
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Alignment You can select from the following four ways; left, 
center, right, and justify.

Indent You can specify the distance between the left margin 
of the document and the first line of the paragraph 
using the following units; %, point, mm, cm, pica, 
inch, pixel, em, and ex. 

Line Height You can specify the distance between the lines in a 
paragraph, using the following units; %, point, mm, 
cm, pica, inch, pixel, em, and ex.

Letter Spacing
You can specify the distance between the characters, 
using the following units; %, point, mm, cm, pica, 
inch, pixel, em, and ex.

Box You can specify the margin and padding, using the following units; 
%, point, mm, cm, pica, inch, pixel, em, and ex.

If the border is not specified, there is usually no difference between 
the margin and padding. However, it makes a difference once the 
border is specified, as below. The left illustration shows the 
appearance of the paragraph, when the margin is 30 pixels. The 
right illustration shows when the padding is 30 pixels. The margin is 
displayed outside the border and the padding is displayed inside the 
border.
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Borders You can make a paragraph with a border. The style of the border 
consists of the Style, Color and Width.

You can specify different styles to the right, left, top, and bottom of 
the border. If you specify a style to the left of the border, the style 
will be applied to the other parts.

Style
You can specify the style of the border. You can see the border in 
the edit window. But the four border styles; groove, ridge, inset, 
and outset, can be seen only in a web browser.

none Make the border invisible.

dotted Indicates a dotted line. It can be seen in the Internet 
Explorer 4.01 or higher, with the Macintosh. In the 
Windows system, it looks like a solid line.

dashed Indicates a long-dotted line. It can be seen in the 
Internet Explorer 4.01 or higher with the Macintosh. In 
the Windows system, it looks like a solid line.
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solid Indicates a line without breaks.

double Indicates two parallel lines. Between them, the 
background image or color is shown. In this case, the 
width of the border is the distance between the outer 
borders of each line.

groove Looks like a frame having light coming from the lower 
right.

ridge Looks like a frame having light coming from the upper 
left.

inset Looks like a frame insetting from the outside.

outset Looks like a frame protruding from the inside.

Color
You can specify different colors to the right, left, top, and bottom of 
the border.

Width
You can specify the width of the border. Use one of the following 
nine units; %, point (1/72 inch), mm, cm, pica (1/6 inch), inch 
(2.54cm), pixel, em (height of font), and ex (height of small letter 
x).

Medium, thin, and thick are not the unit of the width, they are the 
type of widths for you to use.

medium Indicates the standard width of a border.

thin Indicates a thinner width than standard.

thick Indicates a thicker width than standard.
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Select to add or adjust styles to be applied to a document. The 
style you create here is shown on the Class tab in the Style dialog 
box. So you can apply it to a paragraph or document repeatedly.

Adding Style To create a new style:

1 When you select the Style Sheet command on the Format menu, the 
Style Sheet dialog box appears.

2 When you click the Add button, the Add Style dialog box appears.

3 Select the type of style Class, ID or Other. Then specify the name of 
style in the Name field, then click OK. In most cases, you will select 
Class as the type of style you want.

Reference The first letter of the Class name must be 
alphabetical, then you can use numbers 
or hyphens, but not any spaces, special 
marks. The Class name is should be in 
English and preceded by period(.).
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4 When the Style dialog box appears, specify the style you want, then 
click OK.

5 The newly created style will be shown in the window of the Style 
Sheet dialog box. It is registered by clicking OK. If you choose not 
to register it, click the Cancel button.

6 If you click the Change CSS drop down menu on the Format 
toolbar, you will find the new style is registered in the style list. If 
you select the new style, it will be applied to the paragraph where 
the cursor is.

.
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Editing Style Sheet To modify an existing style:

1 When you select the Style Sheet command on the Format menu, the 
Style Sheet dialog box appears.

2 Select the line of the style you want to edit, then click the Edit button.

3 When the Style dialog box appears, edit the style as you want. 
Then click OK.

4 After the contents of the style are changed, click OK to register. If 
you choose not to register it, click the Cancel button. Then the 
previous content will remain untouched.

Save Style You can save the styles created in the Style Sheet dialog box in 
other folder by clicking the Save button. When the Save CSS File 
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dialog box appears, select the folder in which the style will be 
saved. And then enter the name of a style file, click the Save 
button. The extension name of style file is 'css'.

If you save the style in this way, you can apply it to other 
documents. This way you don't have to create styles every time 
you create a new document.

Import Style You can import the style information by clicking the Import button 
in the Style Sheet dialog box. When the Open dialog box appears, 
select the folder and style file you want. Then click the Open 
button.
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. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . INCREASE INDENT
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Select to indent the entire paragraph where the cursor is. The 
paragraph is indented by the space of 6 English characters. You can 
not change this unit.

. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . DECREASE INDENT
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Reverse the Increase Indent applied to the paragraph where the 
cursor is. You can use the Decrease Indent only on the paragraph 
where the Increase Indent has been applied.

. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . SPLIT LIST
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Select, to split a list into two. The paragraph where the cursor is 
positioned will be split as a new list. If you split a numbered list, the 
starting number will be changed to 1 by default.

Once you split a list, the other list will not be affected by changing 
the style of bullet, or type of number in the list.
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The red arrow indicates that a list starts here. This mark appears 
only when format marks are displayed.

. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . MERGE LIST
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The Merge List command does the opposite of the Split List 
command. This command merges two neighboring lists into one.

When merging lists, the cursor must be at the first line of the lower 
list and the space of the indentations of the two lists must be the 
same. When the indentations are not the same, you must make 
them the same beforehand.

If you merge the lists, the marks or numbering of the lower list will 
be changed automatically.



FORMAT
Theme

6-42 Namo WebEditor 3.0 User Manual

66

. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . THEME
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Select to change the theme applied to the current project or 
document to another one. 

1 When you select the Theme command on the Format menu, the 
Theme Gallery dialog box appears.

2 If you click one of the theme lists in the left window, the 
appearance of that theme is shown in the right window of the 
Theme Gallery dialog box.
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3 A dialog box appears asking to what files you wish to apply the 
selected theme. Select All files in the project to apply the theme to 
all the files in a project. Select All open files to apply to all the open 
documents. Select The current file only to apply only to the current 
document. Then click the OK button.

Reference One theme consists of nine theme objects: Banner, Button, 
Emphasis Button, Large Bullet, Small Bullet, Horizontal Rule, Cool, 
Hot and New. If you change the type of theme, the objects applied 
to the document will change as well.

Of the theme objects, you can specify the Banner, Button, 
Emphasis Button along with the text that would be shown in them. 
Click the Theme Object, and then select the Theme Object command 
on the Format menu (the Theme Object is the last item of the 
Format menu. Its name will vary with the objects selected), or you 
can press the short cut key <Alt+Enter> on your keyboard. Then, 
the Theme Object Property dialog box appears.

You can modify the type of Theme Object, type of font, size and location 
of character, and the content of the text. When the Banner, Button and 
Emphasis Button can not contain the whole text, you must shorten the 
text, reduce the font size, or change the location of the text.
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. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . PAGE BREAK SET
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Select to force a page break, or to specify the way a not-yet-
finished paragraph is displayed after the new page begins. 
Remember that this command will work only when you are printing 
a document.

If you point to the Page Break Set command on the Format menu, 
you can select one of three options; Page Break, Page Break..., and 
Protect Widow/Orphan.

Page Break If you select the Page Break submenu on the Page Break Set 
command on the Format menu, or press the short cut key 
<Ctrl+Enter> on your keyboard, you can start a new page. And the 
line of the cursor position on the previous page becomes a first 
paragraph of the new page.

Reference To see the page break in the edit window, select Page Layout on the 
View menu. When the page layout is displayed, the location where 
the page changes normally will be shown as a red line. And the 
location where you have forced a page break will be displayed by a 
red solid line.

Page Break... If you select the Page Break... on the Page Break Set command on 
the Format menu, the Page Break dialog box appears. You can 
specify the way a page breaks.
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When you select more than one paragraph, the page break will be 
applied to all the paragraphs selected. When paragraphs are not 
selected, the page break will only be applied to the paragraph of 
the cursor position.

Page-Break-Before
Always Indicates breaking page at the start of a paragraph.

Left Indicates breaking page at the start of a paragraph, 
and making the new page an even numbered one.

Right Indicates breaking page at the start of paragraph, and 
making the new page an odd numbered one.

Avoid Indicates preventing a page break at the top of a 
paragraph.

Auto Reverses preventing action.

Page-Break-Inside
Avoid Indicates preventing a page break within a paragraph.

Auto Reverses preventing action.

Page-Break-After
Always Indicates breaking page at the end of a paragraph.

Left Indicates breaking page at the start of a paragraph, 
and making the new page an even numbered one.

Right Indicates breaking page at the end of a paragraph, 
and making the new page an odd numbered one.

Avoid Indicates preventing a page break at the end of a 
paragraph.

Auto Reverses preventing action.



FORMAT
Page Break Set

6-46 Namo WebEditor 3.0 User Manual

66

Protect Widow/Orphan

If you select Protect Widow Orphan... on the Page Break Set 
command on the Format menu, then the Widows/Orphans dialog 
box appears. You can avoid starting a new page with one or two 
lines of a paragraph that belongs to the previous page. The lines, 
widow orphan can spoil the appearance of a document.

When you select several paragraphs, the Protect Widow Orphan will 
be applied to all the paragraphs selected. When not selected, it will 
applied only to the paragraph of cursor position.

Protect Orphans
Specify how many lines you want to protect at the start of a 
paragraph. If you specify two lines as widow orphan, two lines will 
not be separated from a paragraph.

Below is a sample of protecting orphans.
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Protecting Widows
Specify how many lines you want to protect at the end of a 
paragraph. If you specify two lines as widow orphan, two lines will 
not be separated from the paragraph.

. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . TAG
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Select to modify the attributes of an object you select.

When you select an object like image, horizontal rule, layer, or form 
field by a mouse click, the last command name of the Format menu 
will be changed. The object name you select is shown as the name 
of the last command. If you select an image, the Image... will be 
shown instead of Tag....

You can also select the last item on the short cut menu. The short 
cut menu appears when you right click after selecting an object.
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. . .
. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .
Table 7

Table menu provides features
�

that
�

help you create and design tables. You 
will use tables quite often while creating 
your web site and will be come to be 
one of the most important elements to 
the design of your site.

. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . NEW TABLE
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Select this option to create a new table. You will be asked to specify 
the number of rows and columns you want.

When you select the New Table command from the Table menu, the 
Table Properties dialog box appears as shown below. Select the 
options on the table size and appearance from this dialog box, then 
click OK. If you click the Apply button, the Table Properties dialog 
box will not disappear and you will be able to see the table behind 
the dialog box. This way, you can continue creating or adjusting 
without having to re-open the dialog box.
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Rows and Columns Rows Specify the number of rows you want. 

Columns Specify the number of columns you want.

Size Specify Width Specify the width of table. You have two options; 
relative and absolute width. The relative width is 
decided by the proportion of the table to the full width 
of a window. The absolute width is one that is 
measured in pixels. If you specify the width in pixels, 
the table size will be a fixed size.

Specify Height Specify the height of the table in pixels.

Layout Alignment You can specify the horizontal position of a table by 
selecting from the following options; left, right, center. 
The horizontal position of a table can be specified only 
in the Table Properties dialog box. It is not available on 
the align buttons on the Format toolbar. This will 
decide where on the screen your table will reside.

Caption You can specify the location of the caption, which is 
the description of the table. It can be at the top, 
bottom, left or right. Since you can't enter or edit the 
caption in the edit window of the Namo WebEditor, you 
will need to select the HTML window, then enter or edit 
the caption directly on the HTML source. By default, 
the caption is hidden in the edit window. To see the 
caption, you can use the Preview window or select 
Preview in Netscape from the View menu.

Cell Padding This is the distance between a cell and its content. The 
default is 1. Below is a sample of tables with different 
cell spacing.
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Cell Spacing Specify the border size. This is the distance between 
the cell and the table. The default is 2. Below is a 
sample of tables with different border sizes. 

 

Border Color Specify the color of the border.

Size Specify the border thickness. The default is 1; when 
you specify 0, the border becomes invisible. If you 
activate the Format Mark, from the Mark Set 
command in the View menu, the border with 0 
thickness will be displayed as a dotted line. Below is a 
sample of tables with different border thicknesses.

Reference If you select Custom color when choosing colors, you will have the 
choice of your own colors as well as the 16 suggested colors.

The Color dialog box will appear only when the display is set to 256 
(or more) colors in Windows. As a precaution, we recommend you 
stick with the browser safe colors. For more information on colors, 
see Color(6-3).

Light Color Specify the color for the outer-left, outer-top, inner-
right, and inner-bottom of the border.

Dark Color Specify the color for the inner-left, inner-top, outer-
right, and outer-bottom of the border.
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Reference In Netscape only one color will be used in the way that the same 
color is displayed two ways; lighter and darker.

Background Color Specify the background color of the table. You can 
either choose from the 16 colors or delve into the 
custom color choices. 

Image You can specify image to be used as the background 
of your table. Once you select a background image, 
the background color will no longer be displayed. 

Clip Art You can chose one of the many clip art images Namo 
WebEditor provides as a background image for your 
table. For more information, see Clip Art(5-13).

Browse If you do not know the file name and path, click 
Browse to search your hard drive for the correct file. 
For more information on using background images, 
see Image(5-7).

Light 
Color

Dark 
Color
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Copy Image If you select this option, the Copy Resource�dialog box 
appears the next time you save the document. The 
Copy Resource dialog box is used for saving image 
files along with the current documents into a sub 
folder in your main directory, or the directory that has 
your index.html file in. The suggested name for the 
sub folder is 'images', but you can specify your own. 
This feature not only helps with keeping your site 
organized, but it guards slightly against file damage.

When you specify a background image to the table, it 
will be repeatedly displayed horizontally and vertically.

Style If you click the Style... button in the Table Properties dialog box, the 
Style dialog box appears. The options you select here will be 
applied to the entire table. You can see the list of styles that are 
specified for the document on the Class tab.

The values that you specify in this dialog box will be the default 
values for your table. For example, if you set blue for the 
Foreground color, all the characters in the table will be displayed in 
blue. For more information on the Style dialog box, see Paragraph 
Style(6-25).
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Extended To use a tag, not bound by the HTML rule that the Namo WebEditor 
supports, click the Extended... button. The Extended Attributes 
dialog box will then appear. After clicking the Add button, enter the 
Name and Value of the Attribute and click OK.

Reference You can create a table quickly and easily by using the Create Table 
button on Standard toolbar. When using this button, however, you 
cannot specify the details for the appearance of the table. If you 
want to adjust these attributes, select Table Properties... from the 
Table menu, after creating the table.

1 Click the Create Table button.

2 Select the number of rows and columns that you want by dragging 
the mouse.

3 A table will then be inserted in the edit window at the current 
cursor position.
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. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . DRAW TABLE
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This allows you to draw or erase a table as you would on paper with 
a pencil. This makes it simple to insert a new row or column. You 
can also remove a row or column in a table using this command.

1 Select the Draw Table command from the Table menu. 
The Table Tools toolbar appears, and the pointer 
changes to a pencil.

2 Drag the mouse to draw a table. A table with one cell is then 
created.

3 Draw the horizontal lines as you want them within the table.

4 Draw the vertical lines and place them were you want within the 
table.
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5 You can also draw horizontal/vertical lines within part of the table. 
This feature is indispensable to create complicated tables like this. 

Erasing a Table To remove part of a table, use the Erase Table button on the Table 
Tools toolbar.

1 When you click the Erase Table button, the pointer then changes to 
an eraser.

2 While holding down on the mouse button, move to the line you 
want to remove. It will turn red. 

3 If you release the mouse button, the line will be deleted.
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Escape Drawing Table 

To exit from the drawing function after creating a table, click the 
arrow button on the Table Tools toolbar or press <Esc> on your 
keyboard.

Reference To insert a table within a table, you must use the New Table 
command on the Table menu or click the Create Table button on 
Standard toolbar. You cannot create nested tables with the Draw 
Table feature.

. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . INSERT ROWS OR COLUMNS
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This option will allow you to insert a line within a table. You can 
insert multiple horizontal/vertical lines at a time.

With the cursor inside the table, select the Insert Rows or 
Columns... command from the Table menu. The Insert Rows or 
Columns dialog box will appear. Specify the kind of line, the number 
of lines and where you want to insert the lines within the table, 
then click OK.
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Insert Columns This will insert a vertical line.

Insert Rows This will insert a horizontal line.

Number of Columns Use this to specify the number of lines you 
want to put in your table.

Insert Position Specify the location where the lines are to 
be inserted. When you insert a horizontal 
line, you can select between the two 
positions; left or right of current cell. And 
when you insert a vertical line, you can 
select either above or below.

. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . DELETE ROWS OR COLUMNS
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This will allow you to delete multiple horizontal/vertical lines of the 
table. When you select the Delete Rows or Columns... command on 
the Table menu, while the cursor is inside the cell you want to 
delete, the Delete Rows or Columns dialog box will appear. Specify 
the type and number of lines to delete, then click OK.

Delete Columns This option will delete a vertical line.

Delete Rows This option will delete a horizontal line.

Lines to Delete Specify the number of horizontal/vertical lines to 
delete. Remember that the cell where the cursor 
position is will be included in which lines are to be 
deleted. Note that you can always reverse the 
delete action by selecting the Undo command from 
the Edit menu.
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. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . SPLIT CELL
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This allows you to split cells into columns or rows. In a vertically 
split cell, a new cell will be created to the right of the original. In 
the horizontally split cell, the new cell is created below.

With the cursor inside the table, select the Split Cells command 
from the Table menu. The Split Cell dialog box will then appear. 
Specify the direction (horizontal or vertical) and the number of cells 
to split, then click OK.

. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . MERGE CELL

�����������	����	

This option will merge neighboring cells into one. The content of the 
cells is not deleted by the merge action.

1 In the group of cells you are planning to merge, place the cursor in 
the one that is at the margin. 

2 While holding the <Shift> key, select other cells by clicking on 
them at a time. All the lines between the selected cells will then be 
selected.

3 Select the Merge Cell command from the Table menu. The selected 
cells will now be merged into one.

Reference You can also select the cells by dragging the mouse or clicking while 
pressing the <Shift> key. Choose the way you prefer.



TABLE
Equalize Cell Width

7-12 Namo WebEditor 3.0 User Manual

77

. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . EQUALIZE CELL WIDTH
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This will allow you to equalize the width of neighboring cells. After 
selecting the rows you want to equalize, choose Equalize Cell Width 
from the Table menu.

 

. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . EQUALIZE CELL HEIGHT
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This is the same as equalizing the width, but rather than affect the 
width, the height is equalized. After selecting the columns to 
equalize, choose the Equalize Cell Height command on the Table 
menu.
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This option allows you to adjust the cell properties. It is used 
mostly to adjust properties of small parts in a table. If you want to 
modify the entire table, select Table Properties from the Table 
menu.

When you select the Cell Properties command from the Table menu, 
the Cell Properties dialog box will appear as shown below. Choose 
between the various options and click OK. If you click the Apply 
button, the Cell Properties dialog box will not disappear after you 
have made your selections, and you can continue working on the 
properties.

Alignment Vertical Specify the vertical alignment position of the cell 
contents. You can select from top, middle, bottom and 
baseline.

Horizontal Specify the horizontal alignment position of the cell 
contents. You can select from left, right and center.



TABLE
Cell Properties

7-14 Namo WebEditor 3.0 User Manual

77

Reference When the cell contents consist of one single paragraph, the 
difference between the results of Horizontal Alignment cell 
alignment versus the Paragraph alignment is hardly visible. But 
when the contents make two paragraphs, the differences become 
very visible. If you use the Horizontal Alignment options in the Cell 
properties dialog box, you can adjust the contents of entire cells. 
When you use the Align options in the Paragraph Properties dialog 
box, you can align each paragraph differently.

Size Specify Width Specify the width of a cell. You have two options; 
relative and absolute width. The relative size is the 
proportion of cell to the width of a table. The absolute 
width is measured in pixels. If you specify the width in 
pixels, the total size of the cell widths must be smaller 
than that of the whole table. To explain, if your table is 
600 pixels, your cell widths have to be 599 or less. If 
there is a problem in the size and you cannot get the 
cell to change even after you have adjusted it, use the 
Select Column on the Select command on the Table 
menu. This way you can select all the cells in a column 
and change their widths.

Specify Height Specify the height of cell in pixels. When all the cells in 
a row have different heights, they can be set at the 
size of the largest. If you are unable to fix this even 
after you have adjusted the height of that particular 
cell, try using Select row on the Select command on 
the Table menu. This way you can select all the cells in 
a row and change their height as a group.
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Border Color Specify the border color of the current cell or all 
selected cells. You can choose to use custom colors 
here as well. If you select custom colors, you will have 
a selection of over 256. But if the Light/Dark Colors 
are specified, no border color will be displayed.

Light Color Specify the color for the outer-left, outer-top, inner-
right, and inner-bottom of the border.

Dark Color Specify the color for the inner-left, inner-top, outer-
right, and outer-bottom of the border.

Reference In Netscape, only the same color will instead of separate light and 
dark colors. One color will simply be lighter than the other.

Background Color Specify the background color of the cell. You can use 
Custom color as well as the 16 suggested colors. 
When the background colors are different between the 
cell and the table, the background color of the cell will 
be displayed.

Image You can specify an image file to be used as the 
background image. If you choose a background image 
for the cell and table and select a background color of 
a cell at the same time, the background image of the 
cell will be what is displayed.

Clip Art You can select one of the various clip art images 
supplied by the Namo WebEditor as a background 
image. For more information on this, see Clip Art(5-
13).

Light Dark 
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Browse You can specify the background image by entering the 
location of an image file. You can not only choose an 
image file from your hard drive, but you can also take 
a file straight from the internet simply by inputting the 
correct URL. For more information on how to do this, 
see Image(5-7).

Copy Image If this option is active, the Copy Resource dialog box 
will appear after you save any document. The Copy 
Resource dialog box helps in organizing your 
directories. It gives you the option to save all your 
image files into a sub directory of your main HTML 
directory (whatever you specified to save your original 
document in). The suggested name for this folder is 
'images', but you can change it to something else.

When you specify a background image to the cell, it 
will be repeatedly displayed horizontally and vertically. 
Note that the size of the cell has to be large enough 
for the background image to be displayed.
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Style Header Cell If you select this option, the contents in the cell will be 
changed with a bold look.

Prohibit Wrap This prevents a line from even flowing onto another 
line without hitting enter. It will move the cell walls 
over to compensate for whatever space it needs. The 
default is for this to be in the off mode as it is not 
cross-browser compatible.

Style... If you click the Style... button in the Cell Properties dialog box, the 
Style dialog box will appear. The selected options in it will apply to 
the entire cell. You can see the list of all styles that are specified for 
a document on the Class tab.

The values that you specify in this dialog box will be the default 
values for the cell. Meaning if you set blue for the Foreground color, 
all the characters in the cell will be displayed in blue. For more 
information on the Style dialog box, see Paragraph Style(6-25).

Extended To use a tag, not bound by the HTML rule that Namo WebEditor 
supports, click the Extended... button. Then the Extended Attributes 
dialog box appears. After clicking the Add... button here, enter the 
Name and Value of the Attribute. Then click OK.
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This will allow you to adjust or check the table properties. For more 
information on the Table Properties dialog box, see Draw table(7-7).

You can adjust the properties of the entire table here. If you wish to 
modify the properties of specific cells in the table, select the Cell 
Properties... command from the Table menu.

. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . BORDER
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This will allow you to quickly modify the look of the border.

When you select the Border command from the table menu, you will 
have four options. Each one can drastically change the look of the 
border.

Normal Sets the border size to 1, and gives the default value 
for Light and Dark Color options.

Thin Sets the border to 0, Light Color is white, Dark Color is 
black. This border has a very thin look to it.
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Thick Sets the border size to 0, Light Color is Black, Dark 
Color is White. This border has a thicker look to it.

Hide Border Indicates the Cell Padding is 0 and the Border is 
invisible.

. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . TRIM CELL SIZE
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This will trim the cell size to a specific fixed width.

When you select the Trim Cell Size command from the Table menu, 
three items appear. Please read how they can change your table 
settings.

Trim Cell Size This trims the inside of the cells. Useful when you 
want to bring the original width value back after a cell 
has been modified incorrectly.

Remove Width Attribute
Removes the width attributes tag from the Table/Cell 
Properties.

Remove Height Attribute
Removes the height attributes tag from the Table/Cell 
Properties.

. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . SELECT
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This option will select certain parts inside the table.

When you choose the Select command from the Table menu, four 
items appear. Each one you select will highlight different parts of 
the table. 



TABLE
Select

7-20 Namo WebEditor 3.0 User Manual

77

Select Cell This option will select the current cell. 

Select Row This will select an entire row. You can alternatively do 
this by holding down the <Shift> key and dragging 
the mouse along to select the cells as if you were 
selecting text.

Select Column This will select an entire column. The alternate way to 
select a column is the same as selecting a row, except 
this time it is vertical rather than horizontal. 

Select Table This will select the whole table. Useful to delete or 
copy all the contents of the table. Very helpful for 
selecting a table that is nestled inside other tables.

Reference Sometimes it may be necessary to delete a table that has been 
imported from another web document. If you follow these steps, 
you will be able to do it quickly and easily. Place the cursor inside 
the table and click. The cursor should be focused inside the table. 
Once you have done this, press <Shift+Esc> on your keyboard. 
Then the cursor position will appear on one of the corners of the 
table. When you see this, press <Delete> or <Backspace> to 
delete the table. You can also choose Select Table from the Select 
command on the Table menu and press the <Delete> key after it 
has been highlighted.
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. . .
. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .
Frame 8

Frame menu helps you 
create frames in the Namo 
WebEditor window and manage 
them easily. For beginners the 
frames may seem rather 
difficult. However, once you 
follow this chapter step by 
step, you will have enough 
knowledge to create and 
modify them as you want. 
Namo WebEditor offers you 
pre-designed framesets as templates. You will find them useful.

. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . FRAME AND FRAMESET

There are many web sites that split the screen horizontally and 
vertically thus dividing it into several regions and they then display 
the HTML documents in those regions.

We call each sub window region a 'frame'. 'Frameset' indicates the 
HTML document that contains the information on the number, 
arrangement, name, size and attribute of the frames.

To create a web page that consists of three window regions 
(frames), there must be four HTML documents; 3 frames and 1 
frameset. If you open the frameset file in a web browser, other 
attached frames open automatically. When publishing, you must 
publish all 4 frames so that one can see all the frames in the web 
browser.

When you create a hyperlink from a web page which uses frames, 
you must specify both target frame name and target document 
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name, otherwise the specified target document will not be 
displayed in the specified target frame.

If you open the frameset document, then the current frame name 
and the name of the document file being displayed in the frame 
appear in the brackets on the Title Bar. To the right of the bracket 
the title of the current frame document (title in the head tag) is 
displayed.

If we take the example below, the current frame name is 'detail', 
the current document file name is 'frame3.htm' and the document 
title is 'DHTML’.
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. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . NEW FRAMESET

���������	�����
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Now you can create a new document that uses frames. You can add 
frames by selecting the Split Frame Horizontally/Vertically command 
on the Frame menu. However, when creating a new document using 
frames, select the New Frameset command on the Frame menu, it 
will be more convenient.

When you select the New Frameset command on the Frame menu, 
then the New dialog box appears. Select the frame set you want in 
this dialog box, and click OK. Now the frameset you have selected 
appears in Namo WebEditor window.
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When you create or open the frameset document, the No Frame 
Msg, Frameset Source and Frameset Preview tabs are shown at the 
bottom of the window along with the Edit, HTML, and Preview tabs.

No Frame MSG Tab When someone opens the frameset document in a web browser not 
supporting the frame, he or she won’t be able to see the document. 
You can prepare the description for this occasion. Most of the web 
browsers that are used now support the frame so that the 
description for the occasion can't be seen in them. However, in a 
text web browser not supporting the frame like the Link, the 
description is displayed.

When you click the No Frame Msg tab, a window appears displaying 
the message, "Viewing this page requires a browser capable of 
displaying frames". You can edit this message or open other HTML 
document in this window. After you finish editing, click the Edit tab 
to return to the edit window.
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Caution The contents of the No Frame Msg tab are saved in the frameset 
document, therefore, after editing it you must save the contents by 
selecting the Save Frameset command on the Frame menu.

Frameset Source Tab

When you click the Frameset Source tab, Namo WebEditor displays 
the source file of the current frameset. The frameset includes 
information on the number, rows, columns and size of the frames 
that belong to the current frame. It also contains the description for 
the web browser that can't display the frames. To display the 
source of each frame, not frameset, click the HTML tab or <F6> 
key on your keyboard with the insertion position on the respective 
frame.

When you select the Frameset Source tab, the window displaying 
the frameset source appears. If you select the Show Source with 
Color on the short cut that appears when you right click, the Namo 
WebEditor displays the HTML tags in colors to help you tell them 
from the other contents of the window.
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Frameset Preview Tab

When you click the Frameset Preview tab, you can see how the 
entire frameset looks in the Internet Explorer. If the Internet 
Explorer is not installed on you system, the preview functionality is 
not available. If you use Netscape, select the Preview in Netscape 
command on the View menu or press the <F12> key on your 
keyboard.

With the Preview tab, you can only preview the shape of each 
frame.

. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . NEW PAGE

���������	
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Select to create a new document after closing the document at the 
current cursor position. The New Page command is used to create a 
new document in one of the frames where the cursor position is, 
not to create new documents in all the frames of the frameset.

When you select the New Page command on the Frame menu, 
Namo WebEditor closes the document in the current frame and 
creates a new one in it.

If you didn't save the documents in the editing frame, then a dialog 
box appears asking whether Namo WebEditor should save the 
document or not.

Yes Indicates closing the document after saving it.

No Indicates closing the document without saving it. If 
you click the No button after making changes on the 
document, you can not revive the changes.
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Cancel Select to cancel the close action. Click this button 
when you are not sure whether you save the 
document after making changes. You can select the 
New Page command on the Frame menu later.

Caution The New Page command on the Frame menu is the same as the 
New command on the File menu in that it creates a new document, 
but differs in its basic concept. The New command on the File menu 
opens a new edit window, then creates a new document in it, while 
the New Page command on the Frame menu creates a new 
document in one of the several frames.

. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . OPEN PAGE
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This allows you open an document saved onto the hard disk into 
the current frame. To do this:

1 Place the cursor in the frame in which the new document will open.

2 When you select the Open Page command from the Frame menu, 
the Open dialog box will appear.

3 Move to the folder where the document you want is saved.

4 Click the document to select it and then click the Open button. The 
document will now open in the current frame.

For more information on the Open dialog box, see Open(2-4)



FRAME
Save All

8-8 Namo WebEditor 3.0 User Manual

88

Caution As for the attributes of the document that you opened using the 
New Page command on the Frame menu, it is something you must 
change yourself. This is necessary because Namo WebEditor opens 
documents in the frame, but does not properly set their attributes.

. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . SAVE ALL
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This allows you to save all documents open inside the current frame 
document. This will not save files open in another edit window. 

If you have not saved your frame document since its creation, the 
Save As dialog box will appear for each document. For more 
information on the Save as dialog box, see Save As(2-17).

Reference When you select the Save All command on the Frame menu, Namo 
WebEditor saves only the frames and the frameset documents in 
the current document tab. But if you select the Save All command 
from the File menu, all open documents will be saved. You will also 
get a chance to save documents that have never been saved 
before.

. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . SAVE FRAMESET
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This saves the frameset. The frameset document contains 
information on the number, arrangement, name, size and attribute 
of each of the frames. This means if you adjust the size or shape of 
the frames, you will need to save the frameset along with the rest 
of the frames. Saving the frameset does not save all the 
corresponding frames, they still need to be saved on their own.

Caution Because the extension name of a frameset document is exactly the 
same as other HTML documents, it is difficult to tell the difference 
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between a frameset file and a regular HTML file. It is recommended 
that you name the frameset document in a way that implies its 
location or function. For example, save your left frame as 
‘frameleft.htm’, and save your right frame as ‘frameright.htm’.

. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . SAVE FRAMESET AS
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This allows you to save your frameset as something different than it 
already is. When you select this command, the current frameset is 
saved as the name you specify. 

For more information on the Save as dialog box, see Save As(2-17).

Reference The Save Frameset As command on the File menu is used to change 
the name of the frameset and doesn't affect the names of any 
frame documents inside the frameset. To change the frame 
document name, select the Save As command from the File menu.

. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . PRINT FRAMESET
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Select this to print the current frameset onto paper or into a file. 
This command prints the contents of the current window.

For more information on the Print dialog box, see Print(2-29).

Reference The Print Frameset command on the Frame menu is for checking the 
shape of the frameset. To print the contents of each frame, select 
the Print command from the File menu.
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Caution To print, the default printer must be registered in Windows. You can 
check this by selecting Start-Settings-Printers. For more information 
on how to add a printer to your system or register a default printer, 
see your Windows user manual.

. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . PRINT PREVIEW
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����	
������

This option allows you to get a full view of the frameset before 
printing. You will find the Print Preview feature useful because you 
don't have to print the entire frameset to see the how it looks.

For more information on the Print Preview command, see Print 
Preview(2-30).

. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . SPLIT FRAME HORIZONTALLY

�����������	�����	����������� 

This option splits the current frame into two horizontal frames, one 
on top of the other. You can make the frame even if the current 
document is a plain HTML file.

When you select the Split Frame Horizontally command on the 
Frame menu, Namo WebEditor divides the current window 
horizontally and displays the current contents in the upper window, 
while it creates a blank frame in the lower window.



. .
 . 

. .FRAME
Split Frame Vertically

Namo WebEditor 3.0 User Manual 8-11

. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . SPLIT FRAME VERTICALLY
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Select to split the current frame into two frames vertically. You can 
make the frame even if the current document is plain HTML.

When you select the Split Frame Vertically command on the Frame 
menu, Namo WebEditor divides the current window vertically and 
displays the current contents in the left window, while it creates a 
blank frame in the right window.
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Reference To remove the frames made by the Split Frame 
Horizontally/Vertically command, drag the frame border out of the 
Namo WebEditor window. A dialog box then appears asking 
whether or not Namo WebEditor should remove the frame. Click the 
Yes button. The frame that was dragged off is now gone!
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. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . FRAMESET PROPERTIES
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This option allows you to adjust the properties of the frameset 
document. To do this, select the Frameset Properties command from 
the Frame menu to change the frameset properties.

When you select the Frameset Properties command from the Frame 
menu, the Document Properties dialog box will appear as shown 
below. For more information on the Document Properties dialog box, 
see Document Properties(6-16).

. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . FRAME PROPERTIES
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Here you can specify frame properties like the layout, margin, 
options, border thickness etc.

When you select the Frame Properties... command on the Frame 
menu, the Frame Properties dialog box as shown below.
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Source Shows the name and location of the frame document. 
You can change the document that is displayed in the 
current frame by changing its name here. However, 
You cannot change the file name. To change the 
document name, select the Save As... command from 
the File menu.

Name This is where you should specify the frame name. 
Every frame should have a name, it is used to create a 
hyperlink between all the frames in a frameset. To 
specify the frame name is recommended.

Default Target Frame
This shows which frame the hyperlink will go to. It can 
be either one of the frame names or one of the 
defaults shown below.

_parent The target document will be displayed in the 
parent/main document. 

_self The target document of the hyperlink will be displayed 
inside the frame containing the hyperlink.

_top This will display the target of the hyperlink in a window 
free from frames.

_blank This will display the target of the hyperlink in a new 
window, also free from frames.
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Layout
You can specify the width and height of a frame using the units 
below:

*(relative) Sets the frame size as a proportion. If you set this 
proportion to 3, and another frame gets set to 1, this 
frame will be 3 times as large as the latter. 

% Similar to relative spacing above, except here you 
indicate the actual percentage of the entire frameset 
that the current frame should take up. If you specify a 
frame will take up 50% of the screen, it will have 50% 
of the screen no matter what size the browser window 
is.

pixel This allows you to specify the frame size in pixels. It 
will give you a fixed amount. For example, if you set 
the height to 100 pixels, it will always be 100 pixels, 
and other browsers will have to adapt to this size. It is 
recommended that if you are going to create frames, 
use a percentage or proportion, otherwise you risk the 
visitor suffering because their resolution isn’t good 
enough.

Margin
Specifies the frame margin in pixels. The Width specifies the left 
margin and the Height specifies the top margin.

Resizeable
With this option selected, you can resize the frames in the web 
browser by dragging the mouse. When not selected, the frame 
sizes are fixed. You can see the result of selecting the Resizeable 
option in a web browser or in preview mode.

Scroll Bar
Lets you specify if you want a scrolling bar in your frame. If this 
option is selected, scroll bars only appear when the frame contents 
extends beyond the available screen space.
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Border Thickness
Indicates the border thickness. When you specify the thickness as 
0, the border will not be seen in a web browser. Frame borders are 
always shown in Namo WebEditor (edit mode only) to help you 
editing.

Style
This option will allow you to adjust the appearance of the paragraph 
style in more detail. When you click the Style... button in the Frame 
Properties dialog box, the Style dialog box appears. The options you 
select here apply to the paragraph of the current cursor position 
and do not affect the styles of other paragraphs.

Extended
To use a tag that is not bound by the HTML protocol that the Namo 
WebEditor supports, click the Extended button. The Extended 
Attribute dialog box will appear. Click the Add button here, then 
enter the name and value of the attribute. Click OK.

Reference You cannot undo or redo the actions taken on the location of the 
frame border or background images of a document. In short, 
changing document structure is not reversible.
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. . .
. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .
Tools 9

The tools menu provides various 
options that will help you manage your 
web site and edit documents with ease. 
You can check spelling, make image 
maps, import text, images, even an 
entire web site! You can customize 
toolbars and set the preferences of the 
Namo WebEditor within the Tools menu.

. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . SPELLING
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Select this option to check spelling errors in the current document.

The spell checker will display the spelling errors and offer 
corrections. You can also add custom words into the dictionary, 
such as your name or the name of a city.

The spell checker also has an auto correct feature. It will perform a 
check of the spelling and display incorrectly spelled words by 
underlining them in red. You can turn this option on and off.

To set the options for Namo 
WebEditor’s spell checker, 
click on Preferences... in the 
Tools menu. Select the 
Loading Documents Tab.

When Hide Spelling Errors 
option is turned off in the 
Preferences option box 
(unchecked being off), 
spelling errors will appear as 
below, underlined in red.
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You can correct the unrecognized word in two ways, manually or by 
allowing the spell checker to suggest the corrections. You do this by 
selecting the Spelling command from the Tools menu or pressing 
<F7>. 

When you select the Spelling command from the Tools menu, or 
press <F7> on your keyboard, the Spelling Check dialog box 
appears. The spell checker will then check the document from the 
beginning for spelling errors. 

When the spell checker finds an unrecognized word, it displays the 
word in the Not In Dictionary field, and shows the possible 
corrections in the Suggestions field. The proposed correction is 
located in the Change To field. 

Not In Dictionary
Displays the unrecognized word that is to be 
corrected.

Change To Displays the correction for the unrecognized word. Here 
appears the most possible correction from the words in 
the Suggestions field. When there are no possible 
corrections, the unrecognized word is displayed in this 
field. If you disagree with the choices or know of 
another spelling, you can enter it into this field.

Suggestions Displays possible corrections for the unrecognized 
word. One or more words, sometimes none, will be 
displayed in this field. 
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Ignore This option allows you to ignore the spelling of a 
specific word. This is helpful if you are misspelling a 
word on purpose. 

Ignore All This option allows you to ignore the spelling of a 
specific word throughout the entire document. Please 
note that this does not add the word to the dictionary. 
To do that you must select Add.

Change Choose this to change the current word to the spelling 
displayed in the Change To field.

Change All Allows you to change all misspellings of this word to 
the spelling displayed in the Change To field. 

Add Select this to add the current word to the dictionary.

Suggest To manually check the spelling of a word, enter it into 
the Change To field and click the Suggest button. The 
correct spelling(s) (if any) will then be displayed in the 
Suggestions field. 

Document Top
Click this to make the spell checker restart from the 
beginning of the document. 

User Dic... Selecting this button will open the user dictionary. 
Here you may add or remove words.

User Dictionary
You can also change dictionaries by clicking the combo 
box to the right of Dictionary. This is only available if 
there are more than one user dictionaries available.
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Close This will close the spell checker.

Reference If you make a mistake in changing the spelling of a word, you can 
easily undo it. Place the cursor inside the text you wish to change, 
click on the Edit menu and select Undo, you can also do this by 
pressing <Ctrl+Z>. This will revert the word to its form before it 
was corrected.

. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . USER DICTIONARY
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This option allows you to add new words to a user dictionary. You 
can examine or delete any of the words displayed here. The words 
displayed in the user dictionary are recognized as correct spellings 
by the spellchecker. 

When you select the User Dictionary command from the Tools menu 
or click the User Dic... button in the Spelling Check dialog box, the 
User Dictionary dialog box will then appear. 

Word This field is used to enter a new word into the 
dictionary. When a new word is entered here, the Add 
Word button is activated.

List Displays the words in the user dictionary. 

Dictionary When several user dictionaries exist, you can select 
from them here. 
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Add Word Allows you to add the word that is displayed in the 
Word field to the user dictionary. 

Remove Word Removes the selected word from the user dictionary. 

Making User Dictionary

The user dictionary is saved to the 'Lib/Speller' folder in the Namo 
directory where Namo WebEditor is installed. The filename of the 
default user dictionary is 'user.dic'.

There is no limit on the number of the words you can add to the 
user dictionary, but when you go over ten thousand, it can slow 
your system down and take up valuable space. 

To create a new user dictionary follow these steps: 

1 In the Windows Explorer, move to the Namo directory and open the 
'Lib/Speller' folder.

2 Move the cursor onto the 'User.dic' file and click on the right mouse 
button. Select Copy from this menu. 

3 Deselect the 'User.dic' file by clicking anywhere outside the file. 
Right click and chose the Paste option. 
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4 The 'Copy of User.dic' file is now created.

5 You can now change the filename to whatever you prefer, for this 
example we will use ‘User1.dic’. 
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6 Go back into Namo WebEditor and open the User Dictionary dialog 
box by selecting the User Dictionary command from the Tools 
menu. Click on the combo box and you will see the dictionary you 
created is available. You can now add or delete words from your 
newly made dictionary by clicking on it.

. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . AUTO CORRECT
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Choose this to modify the options in the auto correction feature. 
You can add or delete items from this list. There is a default list of 
over a thousand commonly misspelled words. 

This feature will allow you to correct your most commonly 
misspelled words. It can also be used for other useful purposes.

• You can correct words you commonly misspell.

Sample) "I cna do it." => "I can do it."
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• A hyperlink can be automatically created by entering in a specific 

word. This can be very convenient if you often link to a specific 

web site, such as Microsoft or Netscape. In the sample below 

'@Namo' will return http://www.namo.com. 

Sample) "@Namo" => "http://www.namo.com"

• To save time and effort, Namo WebEditor can automatically 

complete frequently used words or phrases. In the sample 

below, #Namo returns Namo Interactive.

Sample) "#Namo" => "Namo Interactive" 

Reference To undo an Auto Correct action, use the Undo command in the Edit 
menu or by pressing <Ctrl+Z>.

When you select the Auto Correct command on the Tools menu, the 
Auto Correct dialog box will appear as shown below. 

Add This allows you to add a new auto correction item. 
When it is clicked, the Auto Correct Edit dialog box 
appears.

Remove Allows you to remove an item from the list. 

Edit Allows you to modify the selected item in the list. 
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Enable This option will enable the auto correction feature.

Beep When this option is selected, a "Beep" sound is used to 
notify the replacement of a word by the auto 
correction feature. 

Check Box When this option is selected, the dialog box shown 
below will appear before auto correct applies any 
changes.

Add to Auto Correct When you click the Add button in the Auto Correct dialog box, the 
Auto Correct Edit dialog box will then appear as shown below.

Replace Enter the word to be changed by the auto correction. 

With Field used to enter the new word. 

Tip When this option is selected, you can enter in a 
description of the rule. This description appears in the 
Tip area in the Auto Correct Replace and Auto Correct 
dialog box.
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Apply This Rule
If this is selected, the created rule will become 
activated. 

Auto Correct Rule It is best to have your rule planned out beforehand, as it will save 
time and unneeded effort. Below are some tips to note when using 
the auto correction feature:

• You can use wildcard to help you in your correction process.

"-" can double for anything before or after a word, "*" will allow 

the auto correct feature to finish if something is typed beyond 

they key word. Do not use wildcard if you want to be specific in 

your correction. Note the examples below. 

Sample) "-atoin" will correct the following:
"gestatoin" -> "gestation"

Sample) "*Ntscp*" -> "Netscape"
This allows you to type information before and after 
the keyword, while still being able to utilize the auto 
correction feature. An example is "*Ntscp*4.0" -> 
"Netscape4.0"

• To create a hyperlink from the particular word, it must be 

preceded by the "@" symbol. Then simply enter the full URL into 

the With field.

Sample) "@Namo*" ->s"http://www.namo.com*"
If you enter "@Namo", the hyperlink 
"http://www.namo.com" is displayed as a hyperlink 
from the word "Namo".
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This option allows you to record a sequence of keyboard input for 
playback. This can prove to be useful if you have a selection of text 
or commands which need to be repeated.

You can only record keyboard input, actions such as mouse 
movement are not able to be recorded.

Defining Key Macro To begin recording a macro, follow the instructions below:

1 Select the Start Recording option from the Key Macro command in 
the Tools menu or by pressing <Ctrl+Shift+M>. This will start the 
recording. You will notice the REC in the bottom right of the status 
bar. 

2 Type in the key sequence you wish to record, please note that you 
cannot record the start/stop macro record command, 
<Ctrl+Shift+M>, into your macro as it will end the recording.

3 When you are done, you can select the Stop Recording option from 
the Key Macro command in the Tools menu or press 
<Ctrl+Shift+M> on your keyboard. The REC symbol then 
disappears from the status bar, showing that you are finished with 
the recording. 

Playback Recording To playback the recorded keyboard input follow the instructions 
below: 

1 Place the cursor at the location you wish the macro to play. 

2 Select the Playback Recording from the Key Macro command in the 
Tools menu or press <Ctrl+M>.

3 You can repeat the macro as often as you want.
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Caution Only one key macro can be recorded at a time. Therefore if you 
record a new macro or exit Namo WebEditor, the previous one will 
be deleted.

. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . IMAGE MAP
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Select this to specify a hot zone image map in the image of your 
choice. The image map is an image that includes one or more 
invisible regions called hot zones. From these hot zones, you can 
create hyperlinks. By doing this, you can move to different locations 
on one image. For example, you can link a picture of a car to the 
various parts it contains. Clicking on the tires would take you to the 
tire shop, and so on. Namo WebEditor provides rectangular, circular 
and polygon shaped hot zones. 

When you highlight the image you wish to create an image map 
from, two things will happen. First a small toolbar will appear 
allowing you to select the various hot zones. You can also select 
these shapes from the Image Map command inside the Tools sub-
menu.

Select a Hot Zone Select this to move, resize or delete the 
existing hot zone.

Draw a Rectangle Select this to create a rectangular shaped 
hot zone.
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Draw a Circle  Select this to create a circular shaped hot 
zone. 

Draw a Polygon Select this to create a polygon shaped hot 
zone. 

Make Transparent Select this to make a particular color of GIF 
image transparent.

Making Hot Zone A hot zone is an area partially selected to make a hyperlink in an 
image file. We are going to make three hot zones as shown below.

1 Click on the image you wish to create a hot zone on. 

2 Select a shape from either the Image Map menu or from the 
toolbar.

3 When the mouse arrow changes to a cross, move it to the location 
you want to create the hot zone on.

4 Click the left mouse button and drag the cursor. While doing this 
you will see the hot zone increase in size. When it reaches the size 
you want, release the mouse button. You will then be prompted to 
edit the hot zone information. The size and location of the hot zone 
can be adjusted later. 
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5 When the Create Hyperlink dialog box appears, fill in the hyperlink 
information. When you are finished, click OK. 

6 The hot zone is then displayed inside the dotted line. You may now 
resize the image and change its location.

7 Repeat the above if you wnat more hot zones. To exit from the 
image map mode, click outside the image or press <ESC>.

Reference Drawing a polygon hot zone can be rather tricky. When the polygon 
hot zone tool is selected, you will need to set the various corners 
(apexes) of the polygon. To do this, click on the image in the 
locations you wish the corners to be set. You can do this an infinite 
amount of times, so when you have the size and shape you were 
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looking for, double click and the Create Hyperlink dialog box will 
appear as before.

Modifying Hot Zone To modify or move the existing hot zones follow the instructions 
below:

1 Select the image that contains the hot zones by clicking on it.

2 Choose the Select a Hot Zone command from the Image Map menu 
or click the Select button from the Image Tools toolbar.

3 When the hot zone is displayed as a dotted line, click the hot zone 
to allow it to moved or resized.

4 Simply drag the hot zone to move it. To resize it, put the cursor 
over the corners of the hot zone. The cursor will then turn into a 
resize arrow, allowing you to resize the hot zone. 
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5 To adjust the hyperlink information, double click on the hot zone. 
The Edit Hyperlink dialog box will appear and you can then adjust 
the information.

Making Transparent To make a particular color in a GIF image transparent, follow the 
instructions below: 

1 Select the image you want to make transparent. 

2 Select the Make Transparent on the Image Map menu or click the 
Make Transparent button in the Image Tools toolbar. 

3 When the mouse pointer changes to a dropper, click on the color 
you wish to make transparent.
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4 Save the image by clicking the OK button in the Save Image As 
Transparent GIF dialog box. If you do not want to overwrite the 
original image, you change the filename. 

5 The color you selected will no longer appear in the image.

Reference If you select the Interlaced GIF option in the Save Image As 
Transparent GIF dialog box, it will be saved in interlace format. 

Interlaced files are displayed gradually in web browsers. This 
means that if your image is very large, it will start out in a low 
quality format and slowly become clearer. This will allow the visitor 
to see your image from the start, rather than leaving an empty 
space while the full image loads.
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. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . CHANGE CASE
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This option allows you to change the case of letters inside in a 
selected area. 

To change the case, you must first click and drag the mouse over 
the text you want to change, this will highlight the text. 

When you select the Change Case command on the Tools menu, the 
Change Case dialog box will appears. After selecting the options as 
you want, click the OK.

Capitalize First Letter of Sentence
Namo WebEditor -> Namo webeditor

Change All Letters to Lowercase
Namo WebEditor -> namo webeditor

Capitalize All Letters Namo WebEditor -> NAMO WEBEDITOR

Capitalize First Letter of Words
Namo WebEditor -> Namo Webeditor

Toggle Case Namo WebEditor -> nAMO wEBeDITOR
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(Only available for double byte character version)

Select this option to make illegible 2 byte characters readable.

If a document has been incorrectly encoded, 2 byte characters that 
are entered in the 2 byte character Windows system are illegible in 
the system of different language. If you can not read an e-mail 
because it is full of odd signs, copy it by pressing the short cut key 
<Ctrl+A> on your keyboard. Then select the Symbol to DBCS 
command on the Tools menu. Then you can read the e-mail.

. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . IMPORT FROM BROWSER
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This option will allow you to import a web site from a specific web 
browser to the Namo WebEditor. This is the same as opening a URL 
from the Open command in the File menu. 

If you cannot view the imported site properly, chances are it has 
been incorrectly cached. You can fix this by clicking on Refresh or 
Reload in your browser window. After this is done, open the URL 
again.

If you select the Save command from the File menu after editing 
the contents of imported web site, it has the same effect as 
publishing it. You may be required to enter in login name or 
password, however it is rare this will be needed to simply download 
a site.

If all you have is the URL of a web site, you cannot save it back 
onto the server. If you try to save it, the following message will be 
displayed. If this happens and the site you are trying to publish is 
one of yours, enter in the FTP data as shown in the picture. You can 
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save the imported web site on your hard disk by selecting the Save 
As command from the File menu.

. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . IMPORT FROM WEB
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This option will import an entire web site from the Internet. It 
allows you to view and edit it while you are offline after you 
download the web site from Internet. If an entire project becomes 
deleted or corrupted on your hard drive, this tool comes in handy 
by allowing you to download the entire site back onto your hard 
drive. However, a huge web site import from web may be 
impossible.

When you select the Import from Web command from the Tools 
menu, the Download From Web dialog box will then appear. The first 
time you use this function, the Import Property dialog box will 
appear. You must then enter the information on the web site you 
want to import.

Basic Specify the information on the web 
site to import.
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URL Enter the URL of the web site to import. 

Project to Store Select the project name in which the 
imported web site will be saved. It can only 
be saved into an existing project.

Directory to Store Specify the folder where the imported web 
site is to be saved.

Download Pictures Select this if you wish to download the 
images along with the web site.

Download Pictures from Other Site
This option allows you to import pictures 
and files that are in a location outside the 
web site. An example of this would be a 
Geocities page using an image from a 
Microsoft page.

Download Files Under the Specified Location
If selected, only files in a specific location 
will be downloaded.

Level When you import a site that contains links, 
these need to be downloaded as well. A link 
may have a link to a link to a link. They can 
go very deep into a site, therefore you must 
specify a level. The default is 10. The larger 
the level limit, the slower the download of 
the site.

Option This selection gives you the option of using 
a cached version of the files from the web 
site to save time. If you chose the slower 
setting, you will download straight from the 
internet site, getting the most recent 
version and ignoring any previously cached 
copies.
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Authentication There may be times where you will need to enter a login and 
password to a site. You can set this up within the Authentication tab 
under Import Property dialog box.

User ID Enter the web site User ID (this is your login name).

Password Enter the web site User Password.

Verify Re-enter the password to verify there were no typos.

Advanced Select detailed options on importing files from the web site here.
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Limit These options allow you to put a limit on 
the number of files to import.

Do Not Change Links Select this to simply import the hyperlinks. 
This will not import the pages the hyperlinks 
are attached to. Do not select this option if 
you plan on editing the document offline. 

File Type to Include or Exclude
This is used to choose what file types to 
download from the web site. 

Choose Download All to import all the files from the web site. This is 
the default option. 

You can import files of a particular type by specifying them in the 
Extension field. Select either the Download These Files or Except 
These Files option and click on the Add button. You can specify 
multiple file formats at a time by repeating this process. Below is 
the sample of specifying the files that have 'html', 'gif', and 'jpg' 
extension.

You can also chose files that you do not want to import. This is 
done simply by selecting the Except These Files option, entering the 
extension name of the format you don't want to import into the 
Extension field, and clicking on the Add button.
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Download From Web When you click the Download button after selecting the URL and 
specifying the various information, Namo WebEditor will connect to 
the web site and begin downloading these files. 

URL window Shows the URL list of the web site to import.

Status window Monitors the download status.

Download When this is clicked, Namo WebEditor will connect 
to the internet site specified in the URL window. 

Stop Click this to stop Namo WebEditor from 
downloading any further files. 

Close This closes the Download from The Web dialog box.

New Entry Click this to add another site to the URL list for 
downloading.

Modify Entry This will modify the properties of the URL to be 
downloaded.

Remove Removes the URL from the URL list. 

When the site is downloaded, the dialog box below will appear.
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This is used to manage the web site that you created using the 
project feature.

When the Site Management command in the Tools menu is clicked, 
a menu containing 5 items will appear as shown below.

Incremental Verify Link

Checks the hyperlinks of the entire project. The results are then 
displayed in the Link Check tab in the Result Window.

Broken Indicates that the target of the hyperlink is 
missing or the URL is incorrect.

Alone Indicates a page that stands alone, with no linkage 
to it. This is a page that web surfers will not see.

External Link Indicates that the hyperlink is external and has not 
been checked. 

Reference Namo WebEditor 3 no longer supports the external node check 
option as it has proven to be too time consuming. If you need to 
check an external URL, use the external utility. 

Followings are the result of the link verification. The files displayed 
in red or yellow have errors that need to be fixed.
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Verify Link This option will check all the hyperlinks in an entire project and 
display the results. They are displayed in the Link Check tab in the 
Result Window.

Change Characterset According to the HTML protocol 3.2 and 4.0, a character set that 
corresponds to the language used in the HTML document must be 
specified. Netscape Navigator and Internet Explorer can display 
HTML documents that do not have a specified character set but not 
everyone uses Internet Explorer or Netscape Navigator and the 
Windows OS. Therefore it is best to specify the character set as 
recommended by the W3C. 

When you select the Change Characterset 
on the Site Management command on the 
Tools menu, then the Change Character Set 
dialog box appears. Specify the range of 
change and type of the character set, then 
click the Change button.

Selected Files Select to change the character set of selected files. 
The selected files indicate the ones you select in the 
Project Window by clicking them. You can select and 
change several files at a time.
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All Files in Project Select to change the character set of all the 
files in the project at a time. 

Characterset Type Specify the type of character set.

Caution Be cautious, when there are documents written in different 
languages in a project. If you use the English and 2 byte character 
in the documents, you must specify the respective character sets. 
That is, to the documents written in English, specify the 
US/Western European. To the documents written in 2 byte 
character, specify the respective characterset. For example, to 
document written in Korean, specify the Korean (EUC-KR). Thus to 
the project in which two or more languages are used, do not 
changing with selecting All Files in Project option.

The simplest way to take care of specifying the characterset is not 
to specify the characterset to the files at all. To do this, select the 
All Files in Project option in the Change Characterset dialog box and 
specify the type of characterset as User Defined then click the 
Change button. However, in this case, you may have problems, in 
the Netscape Navigator, in reading a document written in 2 byte 
character.

Make Site Map When you select the Make Site Map command from the Site 
Management option in the Tools menu, Namo WebEditor will verify 
all links in the current file. It will then create a sitemap and save it 
in a file named "sitemap.html". This file is a map of your site, 
showing all the pages that are linked to the project. 

When the site map file is created, a dialog box will appear as shown 
below. Click the OK button and make sure you link the site map to 
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your project or it will not be seen! The site map file is located in the 
same directory as your index file.

Publish Information Publish Information contains information for the web server on 
which your files are to be published. 

You can register your site host on this list to directly publish files to 
the internet site without ever having to use an FTP client. If you do 
not have this information, consult your web server administrator. 

For more information on registering and modifying the publish 
information, see Manage Site Information(2-23).

. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . SOURCE CONTROL
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Usually multiple people work on a web site simultaneously, 
especially if the project is quite large. To allow for this, Namo 
WebEditor 3.0 supports Microsoft SourceSafe. However, to use the 
SourceSafe function in Namo WebEditor, the SourceSafe server 
software must be installed on the network server, and the 
SourceSafe client software installed on the user's computer. 

When files are stored on a SourceSafe enabled server, a protection 
method is put into effect. Whenever a user copies a file from the 
server to their computer via the Get Latest Version command and 
then works on that file, other users are notified. This method is 
called "check out" and is similar to checking out a book from the 
library. To check out, select the Check out from the Source Control 
command in the Tools menu. After finishing the work, save the file 
and copy it back to the server by using the "check in" option. To 
check in, select Check In from the Source Control command in the 
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Tools menu. By doing this, multiple people working on the same 
files will always get the latest versions and are notified of any 
changes made. 

Namo WebEditor 3.0 supports and can execute many important 
features of SourceSafe. By doing this, Namo WebEditor users could 
use the SourceSafe functions without having to actually launch 
SourceSafe. Namo WebEditor's SourceSafe supporting feature is 
available only while you are working on a project.

The SourceSafe options are listed in the Source Control sub-menu. 
If you select the Source Control command from the Tools menu, you 
will see the menus shown below.

SourceSafe Project Setting
Select this to save the original web site 
documents on the SourceSafe server. When 
you select this option, the SourceSafe 
project is created on the server and the web 
site documents are transferred to the 
SourceSafe project.

SourceSafe Status Update
If you select this option after making 
changes to a file, the latest change will be 
shown. Use it on the project file in Namo 
WebEditor. 

Get Latest Version Select this to copy files from the SourceSafe 
server onto your computer. Until you 'check 
out' the copied files, the read only attribute 
will remain on the files. Once you 'check 
out', you will be able to save the files.
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Check Out If you 'check out', the read only attribute of 
the files you copied is removed. Your ID will 
then be shown on the SourceSafe server to 
show you have checked out the file. 'check 
out' files are inaccessible to other users, 
thereby making it impossible for more than 
one person to work on a file at a time.

Check Out is the same as the Get Latest 
Version command by copying the files from 
the server. The only difference is whether 
the read only attributes are remain or not.

Check In When someone 'check in' after making 
changes on a file, it is copied back onto the 
SourceSafe server with the read only 
attribute applied. By doing this, the latest 
version is saved on the SourceSafe server. 

Add to Source Control Choose this to add new files to the 
SourceSafe server.

Remove from Source Control
Choose this to delete the files that are no 
longer needed on the SourceSafe server. 

SourceSafe Project Setting

To use the SourceSafe feature in Namo WebEditor, you must follow 
the instructions below. After you have, you can go onto step 1.

Make sure that:

• The web site document files you are going to use are saved 

(checked in) on the SourceSafe server.

• The local directory, in which you will be working on the files 

copied from the SourceSafe server, is specified on your 

computer.
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• The web site document files are saved in the working directory. 

Do this by using the Get Latest Version command.

1 Choose Open Project from the File menu. Make sure you select the 
project in the local directory that is specified in Set Working 
Directory.

2 Specify the files in the project as SourceSafe project files by 
selecting the SourceSafe Project Setting from the Source Control 
command in the Tools menu. 

3 Right click on the project name in the Project window and choose 
Get Latest Version. This will copy the latest files from the 
SourceSafe server.

Reference After you have specified a project as a SourceSafe project, this 
information is saved in a project file (*.wej). This makes it so that 
whenever you open the project in Namo WebEditor, you will 
automatically be connected to the SourceSafe server. 

The options on the Source Control command are available only 
when the SourceSafe client software is installed on the user's 
computer. The SourceSafe Project Setting command is available 
only when the SourceSafe server software is on the network server. 

Your ID must also be registered in the SourceSafe server software. 
If it is not, consult your network server administrator. 

Working on SourceSafe Projects

To edit using the SourceSafe feature, do the following: 

1 Choose Open Project from the File menu. If the project is not open, 
you cannot use the SourceSafe features.

2 To edit the files, use the 'check out' option to remove the read only 
attribute.

3 When you are done editing, save the file and use the 'check in' 
option.



. .
 . 

. .TOOLS
Source Control

Namo WebEditor 3.0 User Manual 9-33

Reference If you right click the files in the Project window, a menu will appear 
containing various SourceSafe commands. Using this can save you 
time and effort.
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This feature allows you to launch the external programs listed on 
the External Programs menu. NotePad and PaintBrush are available 
by default. You can register up to 2 more external programs. 

If you have already specified the external programs, you can select 
the User Defined (1 or 2) from the External Programs command in 
the Tools menu. This will launch the selected program. If there are 
no programs specified, the External Program tab will appear to allow 
you to add an external program. 

You must specify the executable file of the external programs that 
are to be registered as User Defined 1 and 2 in the User Defined 
fields. If you do not know the exact path, click the Browse button 
and you can browse your hard disk for the file. The sample above is 
the result of specifying the "Namo GIF Animator", a program 
offered with Namo WebEditor 3.0.
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This option allows you hide, display, and customize Namo 
WebEditor’s toolbars.

When you select the Customize 
Toolbar command from the Tools 
menu, the Customize dialog box 
will then appear as shown below.
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Toolbars The list of toolbars are shown here. To make a 
toolbar appear, place a check mark by it. To hide 
it, remove the check. 

Show Tooltips When this option is checked, it will make tips 
appear when the mouse points to a toolbar button. 

New Select this to create a new toolbar.

Reset This option will reset the currently selected toolbar 
to its default setting. 

Customizing Toolbars

Customizing your toolbars is simple to do! Simply open the 
Customize dialog box from the Tools menu and click on the 
Commands tab. From here you will see a list of categories to the 
left of the window. Select the category you want and the buttons 
that relate to it will appear on the right. Simply click and drag the 
button you want onto the toolbar of your choice. If you want to 
remove a button, simply drag it off of the toolbar area. 

For example, if you rarely use the Change Font button, you can 
drag it to the side of the Help menu. If you never use the Underline 
button, you can get rid of it by dragging it out of the screen. 
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Creating New Toolbar

Using the customize toolbar feature, you can easily create a new 
toolbar.

1 When you click the New button in the Customize dialog box, the 
New Toolbar dialog box will appear. 

2 Enter the name of the new toolbar and click OK.

Adding Toolbar Buttons

To add buttons on the toolbar follow the instructions below:

1 After selecting the Commands tab, select the categories that contain 
the buttons you wish to add to your toolbar. After this is done, you 
can simply select the button(s) you wish to insert and drag them 
onto the new toolbar.

2 By dragging the buttons you want onto the toolbar, your very own 
customized toolbar is created. See, we told you it was easy!

3 Click the OK button in the Customize dialog box to finish. 
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Deleting Toolbars The default toolbars (Menu, Format, Etc.) cannot be deleted, they 
can only be set to their default status. You can, however, delete any 
toolbars you have created. To do this, select the toolbar from the 
Toolbars tab and click the Delete button.

. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . PREFERENCES
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This option allows you to set the general preferences for Namo 
WebEditor. 

When you select the Preferences command on the Tools menu, the 
Program Preferences dialog box will then appear.

Document Default Allows you to specify default values for new documents. Note that 
all changes made in this menu are applied to all documents created 
after this setting is applied. 
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Colors
Specify the color of the background, font and links of new 
documents.

Background Allows you to specify the background color of 
new documents. The default value is white.

Text Allows you to specify the default font color in 
new documents. The default value is black. 

Hyperlink Allows you to specify the color of links that have 
not been visited. The default value is blue.

Visited Hyperlink Allows you to specify the color of links that 
have been visited. The default value is purple.

Active Hyperlink Allows you to specify the color of links that are 
currently being visited. The default value is red. 

Reference If you select Custom Colors, you will be able to choose from the 
entire color scale, rather than being limited to the 16 default colors. 

The Color dialog box only appears when the system color depth is 
set to at least 256 colors. There are a wide variety of colors to 
choose from here, we recommend you stick with the browser safe 
colors. You can also check the HTML color value here. For more 
information, see Color(6-3).



TOOLS
Preferences

9-40 Namo WebEditor 3.0 User Manual

99

Encoding and Fonts
Here you can specify the characterset, default font size, and type in 
new documents.

Charset Specify the encoding type of new documents. The 
MIME type is decided by the type of characterset. The 
default value is User Defined.

Proportional Specify the font type and size that are to be used in 
Namo WebEditor. The default value is Times New 
Roman, 12 pt.

Fixed Specify the fixed font type and size to be used in 
Namo WebEditor. The default value is Courier New,
10 pt.

Author Specify the name of the person who will be authoring 
the web sites. The name specified here will be 
automatically entered as the author name in all new 
documents. This can also be changed from the 
Information tab in the Document Properties dialog box 
that appears when you select the Document Properties 
command from the Format menu.

Reference The font you specified in the Document Default tab is the font in the 
edit window of the Namo WebEditor. Therefore if you specify the 
font size as 14, it will only be seen this way in Namo WebEditor. 
When it is loaded in a web browser like the Internet Explorer or 
Netscape Navigator, it will be displayed as the font specified there.

Loading Documents Displays options pertaining to the editing of documents.
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Settings
Specify the general editing options.

Lock Insert Key When this is selected, you will no longer be 
able to toggle the <Insert> key on or off. It 
will stay in the mode it was in at the time 
this option was activated. 

Load Last Editing Documents
If you launch Namo WebEditor after 
selecting this option, the last document you 
edited will automatically open. This only 
works with documents that were open at 
the time you closed Namo WebEditor. If you 
finished editing by actually closing a 
document with the Close command it will 
not be automatically opened. 

Automatic URL Conversion
When you select this option, links will be 
automatically created each time a URL or e-
mail address is entered. For example if you 
enter the text "www.namo.com", Namo 
WebEditor will create a link to the Namo 
web site. You can cancel this action by 
pressing <Ctrl+Z> or selecting Undo.
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Loading Documents
Provides options for documents at the time of loading.

Always show a dialog box asking whether remove comments
With this option selected, a dialog box will 
appear each time you open a document 
containing Comments. It will ask or not 
they should be deleted. 

Remove Comments If this option is selected, all the Comments 
in the document will be deleted at the time 
of loading. 

Preserve Comments When you select this option, all Comments 
will be preserved. Comments appear in 
Namo WebEditor via a formatting mark, and 
cannot be seen in web browsers.

Tab Width This specifies the amount of space that 
appears when the <Tab> key is pressed. 
The default value is 8.

Caution When you open the document that contains commented scripting 
such as JavaScript while the Remove Comments option is selected, 
they will be deleted along with any other comment fields. Take heed 
when you choose to delete all comments.

Reference If Namo Web Editor is specified as the 'Generator' inside a Meta Tag, 
the Comments in the document will not be deleted even if the 
option to delete them is selected.
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Speller
This allows you to specify the options for the automatic spelling 
checker. 

Automatic Spelling Check
When this option is selected, your spelling will be 
corrected automatically as you type. 

Hide Spelling Errors
When this option is activated (checked), spelling errors 
will appear with a red line underneath them. This 
option is available only when the Automatic Spelling 
Check option is activated.

Save Documents
Specifies the options when saving documents. 

Make Backup File When this option is selected, Namo 
WebEditor will save a backup copy of the file 
you are working on. This file will be the 
same other than its extension, which Namo 
WebEditor changes to '.bak'. 

Auto Save If selected, the file you are working on will 
automatically be saved in the specified 
interval.

Save Interval This will allow you to specify how often the 
file is to be auto saved. It is only operational 
when Auto Save is activated. The unit is in 
minutes, therefore placing '10' into this field 
will save the file you are working on every 
10 minutes.

HTML Source Width Specify the width of window where the 
HTML source is displayed. The unit here is 
one letter.
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External Program Specify the external programs which will be set as the User Defined 
1 and 2 from the External Programs command in the Tools menu. 
The web browsers are also specified here. 

You can specify the path and type of web browser to preview your 
web document in. Internet Explorer and Netscape Navigator are 
suggested by default. 

Namo WebEditor is a WYSIWYG editor, but there are nuances in 
HTML documents that can cause variations between web browsers. 
Because of this, you need the ability to preview how a document 
will look in various web browsers. You can easily do this in Namo 
WebEditor once you have specified the browser path by pressing 
<F12> or <F11> on your keyboard. 

Editor
Specify the external software to be launched when you select the 
User Defined (1 or 2) from the External Programs command in the 
Tools menu. NotePad and PaintBrush are registered here by default.

Web Browser
You can specify up to two web browsers here.

Browser 1, 2 Specify the web browsers you want to use here. If you 
are using a browser other than Internet Explorer and 
Netscape Navigator, specify (Other) by pressing the 
pull-down menu button.
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Program Location
Enter the path and filename of the web browser. If you 
do not know the exact path, click the Browse button 
and search where the program file locates.

DDE Service Specify the DDE (Dynamic Data Exchange) service 
name of the first web browser. If you specify Internet 
Explorer or Netscape Navigator this will be 
automatically entered. 

Internet This allows you to specify how you connect to the internet to 
transfer files or import sites. 

HTTP
Specify whether Namo WebEditor should use HTTP (Hyper Text 
Transfer Protocol) or not.

Use FTP When Saving Remote Files
This will allow you to save a file onto the web 
server via FTP. This is useful if you plan on creating 
directories. If you do not have this selected, you 
can only save the files without creating directories.
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Show HTTP Transfer Status
If this is selected, Namo WebEditor will display the 
transfer progress when you are publishing a file. 

Off-Line Mode Select this to edit in offline mode. 

DLL
Specify the options on the DLL (Dynamic Link Library) file used to 
import or transfer files.

Use NamoNet.DLL If this is selected, the 'NamoNet.DLL' file will 
be used when importing or transferring 
documents.

Use WinInet.DLL If this is selected, the 'WinInet.DLL' file 
offered with Internet Explorer will be used 
when importing or transferring documents.

Reference It is recommended that you use the 'WinInet.DLL' file. By selecting 
this, you do not have to specify complex proxy settings or cache 
information. If the 'WinInet.DLL' file is not installed on you system, 
you can install it from the Namo WebEditor CD-ROM. The path is as 
follows, where X is the drive letter of your CD drive. 
'x:\Comm\WinINet\Axdist.exe'.

Caution If the web server's operating system uses a 2 byte language, file 
names may be not recognized when you use the 'WinInet.DLL' file. 
If this happens, switch to the 'NamoNet.DLL' file. 
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Proxies
A proxy is a type of cache server installed by your ISP to offer 
faster connections to the Internet. The default value is not to use a 
proxy. If you decide to use a proxy, enter the proxy values in the 
HTTP and FTP field. 

HTTP Enter the URL and port number of the proxy server 
needed to use HTTP.

FTP Enter the URL and port number of the proxy server 
needed to use FTP.

Exceptions Enter the URL of web site to which you want to 
connect without using the proxy server. To enter 
multiple web sites, you can distinguish them by using 
a colon(:) or semi-colon(;). You can also use the 
wildcard(*) symbol to specify multiple servers. For 
example, when you enter "*.namo.com", all the 
servers included in the 'namo.com' domain will not use 
the proxy server.

Cache Policy
The cache is the place for the temporary saving of internet files to 
the hard disk. It allows for quick access to them. The default value 
is to utilize the cache.

Directory Specifies the directory in which the cache is to be 
saved. 

Maximum size Specify the maximum amount of disk space to be 
used in saving the cache.

Clear Cache This option will clear the cache of all files.
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Project Specifies various project options.

Check When Correct Links If this is selected, a dialog box will 
appear every time you repair a link 
in a project file.

Check When Download Files If this is selected, a dialog box will 
appear every time you import a 
file.

Check When Remove Files If this is selected, a dialog box will 
appear before you can delete files.

Check When Overwrite Files If this is selected, a dialog box will 
appear before you can overwrite 
files.
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Window 10

The window menu contains 
commands that help you resize, 
arrange, open and close windows. 
You can also view the list of windows 
that are currently open. You will find 
it very easy to edit multiple 
documents using this feature.

. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . CASCADE

��������	
�	��

Select this to arrange all open windows in a way that they overlap 
one another. Using this option will allow you to view multiple 
windows at a larger size.
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. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . HORIZONTALLY
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Select this to allow for a horizontal view of multiple documents.

. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . VERTICALLY
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Select this to allow for a vertical view of multiple documents.
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Reference There are not many differences between Namo WebEditor and 
software programs that use the standard windows interface. At the 
top right of the window are the buttons used to minimize, 
maximize, restore and close the window.

In Windows, when you click on the minimize button, the window 
disappears from the screen leaving its icon and name shown on the 
task bar. In the Namo WebEditor, when you click the minimize 
button of the document window, the window disappears and the 
document icon is shown at the bottom of the screen.

Now the document window is reduced to an icon. If you click the 
restore button, it will return to its previous size.



WINDOW
Arrange Icons

10-4 Namo WebEditor 3.0 User Manual

1 01 0
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If the icons of the document windows are scattered on the screen, 
you can arrange them by choosing the Arrange Icons command 
from the Window menu.

Then the icons are displayed at the bottom of the window are 
arranged in an orderly fashion. 
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. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . CLOSE
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Select this to close the current document active in the edit window. 
This is not used to exit the Namo WebEditor.

If you have not saved your document since its last close, Namo 
WebEditor will prompt you to save it now.

Yes Click to save and then close the document.

No Click to close the document without saving. If you click 
the No button after changing the document, all 
unsaved changes will be lost.

Cancel Click to cancel the close command. You can proceed to 
close the document after checking it.

. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . CLOSE ALL
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Select this to close all open windows. This is not used to exit the 
Namo WebEditor.

If there are unsaved documents, a dialog box will appear asking 
whether you wish to save the changes. The procedures that follow 
are the same as those in the Close command.
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When you select the Windows List command on the Window menu, 
a list of all open windows will be displayed.

Activate When the Activate button is clicked, the focus will 
shift to the selected document. If the window is 
minimized, it will set focus to the minimized icon. 

Save Document When the Save Document button is clicked, the 
document that is selected in the list will be saved.

Close Document When the Close Document button is clicked, the 
document that is selected in the list will be closed.



Namo WebEditor 3.0 User Manual 11-1

. . . . .
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Supplement 11

Supplement gives you additional information on some features 
that are not fully explained in previous chapters.

Layer
You will see how to create a layer, change its properties and specify 
events. Layers help you place text and images at precise locations 
in the browser window. 

Time Line
Explains how to work with the Time Line that is used to set layer 
animation effects.

Namo GIF Animator
Introduces the use of the GIF animator that has been recently 
added to the Namo WebEditor software suite. The GIF animator 
allows you to create animated gif files.

Global IME
Gives you a description of the Global IME which Namo WebEditor 
now supports. With the Global IME, you can enter 2 byte languages 
in any Windows system.
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. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . LAYER

One of the shortcomings of HTML is that it fails to let users place 
text and images in precise locations. To supplement this 
shortcoming the concept of layers was developed. The layer is one 
of the features that has been added to dynamic HTML. Currently, it 
only works in Internet Explorer and Netscape Navigator 4.0 or 
higher.

A layer is a square-shaped editable and movable region into which 
you can enter text or images. You can overlap several layers and 
decide which one is displayed on top when overlapped. If you use a 
style sheet and scripts, you can make the layer move in the 
document according to user initiated events.

Inserting a Layer To insert a layer, select the Layer command on the Insert menu or 
click the Layer button on Standard toolbar. A layer is then inserted 
into the cursor position. The layer name is created automatically at 
the insertion point and is displayed in the Layer List window.

Layer handle. Shown 
only when the layer is 
selected or the cursor 
position is in the layer. 
The pinion-shaped icon 
appears when you insert 
animation effect script 
using the Script Wizard.

Layer outline. Layer mark 
and outline are shown 
only when the format 
marks are activated.

Layer anchor. 
Indicates the location 
where a layer is 
inserted. Shown only 
when the Format 
Mark is activated.

Layer list window. You can 
display or hide this by 
pressing the short cut key 
<Alt+5>. When the layer 
is inserted, the name and 
properties of it are 
displayed. 

The region where 
the contents of a 
layer are shown.
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Layer Properties When you move the pointer onto the layer outline, the Properties 
pointer changes to a hand. If you double click, then the Layer dialog 
box appears.

Name Enter the layer name.

Position Specify the distance between the left top of the edit 
window and that of the layer. Pixels are used as the 
unit in specifying the Left and Top positions.

Width/Height Specify the layer width and height. The pixel is used as 
the unit in specifying the Width and Height.

Z-Index Indicates the layer display sequence. When layers are 
overlapped, the layer with the larger Z-Index will be 
displayed at the top. At the beginning, the background 
color of the layer is specified as transparent, since the 
Z-Index effect would not be seen clearly when there 
are only layers that contain black characters. You can 

If the size handles 
appear with the 
selection of the layer, 
the layer mark is 
displayed in a 
highlighted shade.

Size handles. You can 
resize the layer by 
dragging the size 
handles. To modify 
both the width and 
height at one time, 
drag the size handle 
at the corner.

When you select a layer, the name of the selected 
layer is displayed in a gray background in the 
Layer list window. When the Name, Z-Index and 
Visibility properties are changed in the Layer 
dialog box, they are changed here as well.
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see the Z-Index effect more clearly when images are 
inserted in layers or other colors are specified for the 
background. The Z-Index is displayed in the Layer list 
window.

Visibility Specify whether Namo WebEditor displays or hides the 
contents of a layer. Select from Default, Inherit, Visible 
and Hidden. When Hidden is specified, the content will 
not be seen even in the edit window. To select an 
invisible layer, click the layer mark. Select Inherit to 
apply the visibility property of upper layer to the sub 
layer. The visibility property of a layer is inherited by 
default.

Reference You can create a layer in a layer. For example, when it is seen in 
the position of the middle layer in the illustration below, the left top 
layer is the upper layer and the right bottom layer is the sub layer. 
When the Hidden visibility property is specified on the left top layer, 
it affects the middle layer also, but not the right bottom one.

You can see the 
relation between layers 
with the layer anchors.

When you overlap the 
upper and sub layers, 
the sub one is 
displayed at the top 
regardless of the Z-
Index.

The sub layer name is 
displayed as indented 
to the right in the 
Layer list window.



. .
 . 

. .SUPPLEMENT
Layer

Namo WebEditor 3.0 User Manual 11-5

Background Color
Specify the background color of the layer. Netscape 
Navigator doesn't display the background color and 
image.

Background Image
Specify the background image. You can use clip art 
suggested by Namo WebEditor by clicking the Clip Art 
button on Standard toolbar.

Save using <layer> tag...
Indicates saving a layer using the <layer> tag that 
Netscape Navigator can recognize. When this option is 
selected, the Internet Explorer doesn't display the 
layer. 

Event When you click the Event button in the Layer dialog 
box, the Script Wizard-Layer Action dialog box appears. 
For more information on the Script Wizard-Layer 
Action, see Layer Action(5-45). If you put the pointer 
on 'layer1', after specifying the options as below, the 
Namo WebEditor hides 'layer2' and displays 'layer2', 
when you move the pointer away from 'layer1'.

You can insert interesting effects into your document if you use the 
action that displays or hides layers. For example, you can create a 
layer with a rollover effect that makes an answer appear when you 
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put the pointer on the layer asking a question. With the layer 
actions specified as above, with 'layer1' as the answer and 'layer2' 
as the query overlapped, when you put the pointer on 'layer1', the 
answer will be shown.

. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . TIME LINE

Time Line is used to create an animation effect by moving the 
position of layers successively. To animate a layer, you must use the 
Time Line window. When you select the Time Line on the Tool 
Windows command on the View menu or press the short cut key 
<Alt+4>, then the Time Line window appears.

Creating an Object After selecting a layer, move it into the Time Line window by 
dragging it. Then the object for animating the layer is created. This 
doesn’t indicate the object itself, but the successive shift of the 
layer.

You can create several layer animation objects on each layer and 
specify the location and length of each object as you wish.



. .
 . 

. .SUPPLEMENT
Time Line

Namo WebEditor 3.0 User Manual 11-7

Create Straight Animation

To animate the layer, specify the position of the layer when it is 
animated. The position indicates where the layer is supposed to be 
when the Time Line, the vertical line in red, moves from one key 
frame to another. The position of the object at the first key frame is 
where it appears at the time of its creation. Then specify the 
position at the last key frame.

Layer anchor

Layer name is 
displayed on the 
object, and the 
circle is displayed 
at the first key 
frame.

The numbers on the 
horizontal axis of the 
Time Line window indicate 
that of the frames. As the 
frame changes, the layer 
moves to the next 
position.

When you right click in 
the Time Line window, 

then the short cut menu 
appears. If you select Add 
Object here, an object on 
the current layer is added.
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1 Select the last key frame in the Time Line window.

2 In the edit window, drag the layer to the position you want, then 
the path of the layer from its first position to its last one is 
displayed in a solid line.

If you select the Auto Start option, you can see the layer move 
along the path in the web browser.

Auto Start Indicates the animation is launched automatically as it 
is specified in the Time Line window. If this option is 
not selected, you must specify the Execute Time Line 
action on the layer to launch the animation by 
selecting Action Type at the Layer Action dialog box in 
the Script Wizard menu.

Repeat Indicates the animation will be repeated.

Layer mark Drag the layer to the position 
you want.

Select the last key frame 
by clicking it.
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Creating Curved Animation

To animate the layer along the curved line, use the Record Path of 
Layer functionality.

1 After right clicking the Time Line window, select the Record Path of 
Layer on the short cut menu.

2 If you move the layer as you want in the edit window, the path will 
be recorded and displayed in the Time Line window. Usually 
multiple key frames are created because the curved movement is 
displayed in short straight lines.

In the web browser, you can see the layer shift rightward along the 
straight line and shift leftward along the curved line.

If the animated layer includes a sub layer, then the sub layer shifts 
along with the animated layer. Because the position of the sub layer 
is decided by the sub layer of the upper layer position.

Layer mark
2. Move the layer as you 
want by dragging it.

3. The movement 
is recorded.

1. Select the Record Path of the Layer.
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You can execute the commands below in the Time Line window.

Add Key Frame Adds the new key frame to the current 
frame on the Time Line. Between the 
frames the layer moves straight, so you 
must add the new key frame to change the 
direction.

Remove Key Frame Removes the key frame on the current 
frame.

Change Object... Changes the layer to which the current 
object is applied to another layer.

Add Frame Adds a new frame to the current frame. 
Consequently the number of frames that 
makes up the object increases.

Remove Frame Removes a new frame from the current 
frame. Consequently the number of frames 
that makes up the object decreases.

Add Object Creates the objects of the current layer and 
inserts it to the current position. At the 
beginning the objects consist of 15 frames, 
but you can increase or decrease them by 
dragging the key frame.

Remove Object Removes the current object. You may also 
press the <Delete> key on your keyboard 
after selecting the object.

Record Path of Layer Starts recording the path of the current 
layer.

Add Time Line Creates a new Time Line. When you 
animate layers that have no relations, it will 
be more convenient for you to work on new 
Time Line after creating them. To select the 
Time Line click on the drop down button at 
the top left of the Time Line window.
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Remove Time Line Deletes the Time Line that is displayed at 
the time. If you delete it by mistake, you 
may revive it by pressing the short cut key 
<Ctrl+Z> in the edit window.

. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . NAMO GIF ANIMATOR

The Namo GIF Animator is used to work with animated GIF files. 
You can create an animated GIF file easily by attaching image files 
in successive order.

1 Launch Namo GIF Animator in the Namo WebEditor 3.0 program 
group from Start button - Programs.

2 To open a new window, click the New button on the toolbar, or 
select the New Animation command on the Animation menu.
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3 When you select the Insert Frame command on the Frame menu or 
click the Insert Frame button on the toolbar, then the Insert Frame 
dialog box appears. Select the image to insert and click the Open 
button.

4 Open the image files to attach as above, then the image files are 
displayed in the new window.

5 To change the position of the images, select the image to move by 
clicking it. Then click the Move Up/Down button.
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6 To see the animation, press the <F5> key on your keyboard or 
select the Preview command on the View menu. You can preview 
the animation using the video control buttons in the Animation 
Preview dialog box.
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. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . GLOBAL IME

What is Global IME Microsoft Windows uses the IME (Input Method Editor) to combine 
2 byte languages such as Korean, Chinese, and Japanese in a 
particular way to allow them to be used in their system. The IME of 
these three languages works only in the system running with the 
respective languages. However, Microsoft released the Global IME 
that works regardless of the languages being used in Windows.

Therefore with the Global IME and the respective language pack 
installed on their computer, the users of these three languages can 
use their language in any Windows system. Until February 1999, 
Microsoft did not open the API for their Global IME while using it 
exclusively with their products, like the Internet Explorer, Outlook 
Express and Office packages.

Now Namo WebEditor 3.0 supports the Global IME. Theoretically 
you can use Korean, Chinese and Japanese freely in the Namo 
WebEditor 3.0 with any Windows system in any country, if the 
Global IME is installed. Other languages that need no particular IME 
can be entered using Unicode.

Installing Global IME

To use Korean/Japanese/Chinese in Namo WebEditor, install the 
Global IME of the respective language. You can download it from:

http://www.microsoft.com/msdownload/iebuild/ime5_win32/en/im
e5_win32.htm

After connecting to the web site, select the type of the Global IME. 
Select one of the three languages and the language pack. To use 
Japanese, choose “Microsoft Global IME for Japanese - with 
Language Pack".
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Reference Once the Language Pack is installed, you can read the respective 
language. It is possible even though your web browser is running 
on Windows that use different languages. That is, you can visit a 
Japanese web site using Internet Explorer with the English Windows 
system. When you install the Global IME on your system, the 
respective Language Pack should also be installed.

Select the site from which you will download the Global IME. To 
start the download, click the Next button.
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After the download ends, double click the JAMONDO.exe on your 
hard disk to install the Global IME. After installing, reboot your 
computer.

Usage of Global IME After installing the Global IME, you can use Korean, Chinese or 
Japanese freely in your system. To use Japanese in Namo 
WebEditor 3.0, follow the steps below:

1 Once the Global IME is installed, the icon for the Global IME is 
created on the right of the Windows task bar.

2 Launch Namo WebEditor. If you click the Global IME icon in Namo 
WebEditor edit window, the short cut menu appears offering the 
following options; English, Japanese IME, and Korean IME. Select 
Japanese IME. The Japanese IME is shown only in the edit window 
and is not available on the HTML, Preview tab, or other dialog box. 
And, of course, it is not available in other software.

3 If you select Japanese IME, the Japanese IME appears in the 
Windows screen. The Global IME icon changes to the Japanese 
IME(JA) icon. Now you can input Japanese.

4 There are three buttons in the Japanese IME. If you click the left 
button, you can choose the input type of Japanese. The middle 
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button is for information of Japanese Properties of the Japanese 
IME, and the right button is for Help.

5 Enter the Japanese in the edit window like below.

6 After you finish editing in 
Japanese, select Japanese 
(Shift-Jis) or Unicode (UTF-8) 
on the Charset command on 
the Format menu, to read 
Japanese in a web browser. 
You can select Japanese or 
Unicode, by clicking the 
Advanced tab in the Document 
Properties dialog box, on the 
Document 
Properties...command on the 
Format menu.



SUPPLEMENT
Global IME

11-18 Namo WebEditor 3.0 User Manual

1111



Symbol
&date .............................................. 2-32

&filename ........................................ 2-32

&nbsp.......................................  4-9, 5-61

&page ............................................. 2-32

&time .............................................. 2-32

&title ............................................... 2-32

&total .............................................. 2-32

Numeric
640x480 .......................................... 4-13

800x600 .......................................... 4-13

A
Absolute Size.................................... 6-29

Absolute URL.................................... 6-16

Access Information............................ 5-38

ActiveX Control................................. 5-52

Insert ........................................ 5-52

AIFF(Audio Interchange File Format) ... 6-21

Alignment Type ................................ 6-11

Alone Link........................................ 9-25

Alt Text ............................................  5-8

Animation

on/off ........................................ 4-12

. . . . . . . . . . . . . . . . . . . . 
Index

Animation Effect ...............................  5-33

Applet

Insert ........................................  5-50

ASP .................................................. 2-5

ASP Script .......................................  5-48

Attachment

Paragraph Background Image.......  6-31

AU(Audio)........................................  6-21

Author............................  4-19, 6-17, 9-40

Auto Correct ...................................... 9-7

Add to Auto Correct....................... 9-9

Auto Document Outline .....................  1-33

Auto Save........................................  9-43

Save Interval..............................  9-43

Automatic Spelling Check ...........  9-2, 9-43

Automatic URL Conversion.................  9-41

B
Background

Cell ...........................................  7-15

Table........................................... 7-4

Background Color .............................  4-19

Background Color of Text Button .......... 6-3

Background Image.....................  1-7, 4-19

Hide/Display...............................  4-11

Paragraph ..................................  6-31

Print..........................................  2-33



INDEX
C

Index-2

Base Location ................................... 6-16

_blank............................................. 8-14

Blink Extended Styles .........................  6-6

Body Script ...................................... 5-47

Bookmark ........................................ 3-13

Hyperlink ................................... 5-55

Modify ....................................... 3-14

Move to...................................... 3-14

Remove ..................................... 3-14

Border

Cell............................................ 7-15

Table ..................................  7-3, 7-18

Borders

Paragraph .................................. 6-34

Broken link....................................... 9-25

Bulleted List ..................................... 6-10

C
Cache.............................................. 9-47

Cell

Border ....................................... 7-15

Equalize Height ........................... 7-12

Equalize Width ............................ 7-12

Merge ........................................ 7-11

Properties................................... 7-13

Specify Height ............................ 7-14

Specify Width ............................. 7-14

Split .......................................... 7-11

Trim Size.................................... 7-19

Change Case .................................... 9-18

Character

Clear All Character Attributes.........  6-8

Decrease Text Size .......................  6-8

Increase Text Size........................  6-8

Characterset

Change......................................  9-27

Check Box .......................................  5-25

Check In..........................................  9-31

Check Out........................................  9-31

Citation Extended Styles...................... 6-6

Class...............................................  6-25

Name ........................................  6-36

Classification....................................  6-17

Clip Art.............................................. 1-6

Adding.......................................  5-15

Adding Clipart Folder ...................  5-17

Insert ........................................  5-13

Clipboard HTML .........................  1-29, 3-4

Clock in Box.....................................  5-40

Close All ............................................ 2-8

Closing

All Documents .............................. 2-8

Document .................................... 2-8

Document Tabs............................. 2-8

Project.......................................  2-15

Window .....................................  10-5

CodeExtended Styles .......................... 6-7

Color......................................................

Font ............................................ 6-3

Comment .......................................... 5-5

Copy................................................. 3-2

Format ........................................ 3-7

Copy Format ...................................... 3-7

Copy Image ....................................... 5-8

Copy Resource ................................... 5-8

Copy Special ...................................... 3-6

Copy Image .....................................  5-30

Creating Curved Animation ................  11-9

Creating an Object............................  11-6

Create Straight Animation..................  11-7

Create Table Button ............................ 7-6



. .
 . 

. .INDEX
D

 Index-3

CSS(Cascading Style Sheets) ............. 6-12

Cursor ..............................................  1-2

Custom Colors ...................................  6-5

Customize Toolbar ............................ 9-35

Cut ..................................................  3-2

Cut Special........................................  3-6

D
dashed ............................................ 6-34

DBCS Align....................................... 4-10

DDE Service ............................  4-16, 9-45

Decode Path..................................... 5-57

Default Target Frame ...............  6-17, 8-14

Definition Extended Styles...................  6-7

Description....................................... 6-17

Difference between

HTML document and text document .....  1-3

DLL ................................................. 9-46

Document Default ............................. 9-38

Document Display Tab........................  2-3

Document File

Close ..................................  1-11, 2-8

Document Colors......................... 6-17

Document Information ................. 4-18

Document Properties ................... 6-16

Editing Text .................................  1-4

Entering Text...............................  1-2

Exit ........................................... 2-34

Load Last Editing Documents ........ 9-41

New............................................  2-1

Open ..........................................  2-4

Print .......................................... 2-29

Recent Files ................................ 2-33

Save.................................  1-10, 2-16

Save Style.................................. 6-38

Style Sheet ................................  6-36

Title ..........................................  6-17

Document Outline............................... 4-5

Document Tab.............................  2-3, 4-2

Close Document............................ 2-8

dotted .............................................  6-34

double.............................................  6-35

Drop-Down Menu.....................  5-26, 5-35

E
Edit Window....................................... 1-2

Editing

Copy ........................................... 3-2

Copy Special ................................ 3-6

Cut.............................................. 3-2

Cut Special................................... 3-6

Delete ......................................... 3-3

Paste........................................... 3-3

Editing Text ....................................... 1-4

em..................................................  6-12

E-mail and WebEditor........................  1-32

Emphasis Extended Styles ................... 6-7

Encode Path.....................................  5-57

Encoding ........................  4-19, 6-24, 9-40

Encoding Type..................................  6-15

Entering Text ..................................... 1-2

Equation Insert.................................  5-57

Event .....................................  5-22, 11-5

ex...................................................  6-12

Exiting WebEditor .............................  1-11

Explorer Tab ...................................... 4-4

Extended Tag..................................... 6-8

External Link....................................  9-25

External Programs ...................  9-34, 9-44

Web Browsers ............................  4-16



INDEX
F

Index-4

F
File

Import ....................................... 2-27

Insert ........................................ 5-62

Publish....................................... 2-25

File Format........................................  2-4

Find .................................................  3-8

Find Again .................................. 3-11

Find in Files ................................ 3-11

Find Again........................................ 3-11

Find in Files...................................... 3-11

Find in Files Tab.................................  4-5

Foldable Contents ............................. 5-43

Font ........................................... 6-1, 6-7

Color ......................................... 6-30

Extended Styles ...........................  6-6

Paragraph Style .......................... 6-25

Style.......................................... 6-29

Font Color Button...............................  6-4

Footer ............................................. 2-31

Foreground Color

Font .......................................... 6-30

Form ............................................... 6-14

Clear ......................................... 6-15

Form Field

Check Box.................................. 5-25

Drop-Down Menu ........................ 5-26

Image........................................ 5-29

Insert ........................................ 5-20

One-Line Text Box....................... 5-21

Push Button................................ 5-28

Radio Button............................... 5-25

Scrolling Text Box ....................... 5-24

Format Toolbar ..................................  4-2

Format Mark......................................  4-8

Formatted........................................ 6-10

Frame ............................................... 8-1

Caution........................................ 8-1

Default Target Frame ..................  8-14

Frame Properties ........................  8-13

New Page..................................... 8-6

Open Page ................................... 8-7

Save All ....................................... 8-8

Split Horizontally.........................  8-10

Split Vertically ............................  8-11

Target Frame ....................  5-10, 5-36

Frameset ....................................  2-2, 8-1

Frameset Properties ....................  8-13

Frameset Source Tab..................... 8-5

New Frameset .............................. 8-3

Print............................................ 8-9

Print Preview ..............................  8-10

Save ........................................... 8-8

Save Frameset As ......................... 8-9

G
Generator ...............................  4-19, 6-24

Global IME.......................................  11-1

Graph Tab ......................................... 4-4

groove ............................................  6-35

H
Handle Internet Information...............  1-29

Head Script......................................  5-48

Header ............................................  2-31

Hidden Field.....................................  6-15

Hide Spelling Errors ...................  9-1, 9-43

Horizontal Arrangement............  2-12, 2-13

Horizontal Line ................................... 5-4

Host................................................  2-24



. .
 . 

. .INDEX
I

 Index-5

Hot Zone ......................................... 9-12

HTML Source Width........................... 9-43

HTML Tag

Insert ........................................ 5-62

HTTP-EQUIV..................................... 6-23

Hyperlink

Active ........................................ 6-18

Follow........................................ 5-57

Insert ........................................ 5-55

Remove ..................................... 5-57

Visited ....................................... 6-18

I
ID(Style) ......................................... 6-25

Image

Inserting Background Image..........  1-7

Changing Image.......................... 1-19

Copy Image................................ 6-19

Hide/Display ............................... 4-10

Inserting Image ...........................  1-6

Image Map....................................... 9-12

Images sub folder ..............................  5-8

IME(Input Method Editor)................. 11-14

Import from Browser......................... 9-19

Import from Web .............................. 9-20

Import Information from Web............. 1-29

inch................................................. 6-12

Indent

Decrease.................................... 6-40

Increase..................................... 6-40

inset................................................ 6-35

Internet Explorer

Preview...................................... 4-16

J
Java................................................  5-49

Applet .......................................  5-49

JavaScript ..................................  5-31

K
Key Frame.....................................  11-10

Key Macro .......................................  9-11

Keyboard Extended Styles ................... 6-7

Keyword..........................................  6-17

L
Language Pack ...............................  11-14

Launch .............................................. 1-2

Layer ..............................................  11-2

Insert ...............................  5-19, 11-2

Properties ..................................  11-3

Layer Action.....................................  5-45

Layer List .......................................... 4-7

Length Unit......................................  6-28

Line Break ......................................... 5-1

Line Break... ..................................... 5-2

Line Height .............................  6-11, 6-12

Link

Check...............................  9-25, 9-27

Jump Button...............................  5-37

Link Check Tab ............................. 4-5

List

Bulleted List ...............................  6-10

Merge........................................  6-41

Numbered List ............................  6-10

Split ..........................................  6-40

Location ..........................................  2-24

Lock Insert Key ................................  9-41



INDEX
M

Index-6

Low Resolution ..................................  5-8

M
Macro .............................................. 9-11

Make Backup File .............................. 9-43

Make Site Map.................................. 9-28

Making a TOC................................... 1-34

Making Transparent Image................. 9-16

Margin............................................. 2-31

Paragraph .................................. 6-12

Mark Set...........................................  4-8

Meta Tag ......................................... 6-23

Microsoft Word File.............................  2-5

MIDI(Musical Instrument

Digital Interface)............................... 6-21

MIME(Multipurpose 

Internet Mail Extensions) ................... 6-15

Minimize Button................................ 10-3

Mouse pointer....................................  1-2

N
Namo GIF Animator......................... 11-11

Namo WebEditor

Exit ........................................... 1-11

Handling E-mail........................... 1-32

Launch........................................  1-2

NamoNet.DLL ................................... 9-46

Netscape

Preview...................................... 4-15

New .................................................  2-1

New Document

Name .........................................  2-3

New Project.......................................  2-9

Nonbreaking Space ....................  4-9, 5-61

Numbered List..................................  6-10

O
One-Line Text Box ............................  5-21

Open................................................. 2-4

Reload Document........................  4-17

Opening ASP File ................................ 2-5

Open URL .......................................... 2-6

Open a Web site 

whose URL is not fully shown ............... 2-7

Open WP File ..................................... 2-5

Opening Web Document ...................... 2-6

outset .............................................  6-35

P
Page

Break ........................................  6-44

Page Layout ...............................  4-14

Page Number Start at..................  2-33

Setup ........................................  2-31

Paragraph

Alignment Type ..........................  6-11

Borders......................................  6-34

Line Height.................................  6-11

Margin.......................................  6-12

Paragraph Mark .....................  1-3, 4-9

Shape.......................................... 6-9

Spacing .....................................  4-10

Style .........................................  6-25

Type............................................ 6-9

Parameters ......................................  5-51

_parent ...........................................  8-14

Passive Mode ...................................  2-24

Paste ................................................ 3-3



. .
 . 

. .INDEX
R

 Index-7

Format........................................  3-8

pica................................................. 6-12

Plug-In ............................................5-49

Insert ........................................ 5-51

point ............................................... 6-12

Preferences ...................................... 9-38

Preview in Web Browser................ 1-9, 2-3

Primary Font .................................... 6-26

Print................................................ 2-29

Print Background Image............... 2-33

Print Preview .............................. 2-30

Prohibit Wrap ................................... 7-17

Project............................................. 9-48

Adding Documents to a Project ..... 2-18

Creating......................................  2-9

Publish....................................... 2-20

Publishing Unmodified Files........... 1-27

Publishing the Whole Web site ...... 1-25

Recent Project ............................ 2-33

Template Wizard ......................... 2-11

Project Tab........................................  4-4

Project Window..................................  4-4

Protect Widow/Orphan....................... 6-46

Proxies ............................................ 9-47

Publish ...................................  1-21, 2-20

Files .......................................... 2-25

Files Not Transferred to Server...... 2-28

Project ...................... 1-25, 1-27, 2-20

Publish Information ........................... 9-29

Register ............................  1-21, 2-23

Push Button ..................................... 5-28

R
Radio Button .................................... 5-25

Recent Files...................................... 2-33

Recent Project..................................  2-33

Record Path of Layer.......................  11-10

Redo................................................. 3-2

Refresh Page....................................  5-38

Refresh Screen.................................  4-18

Relative URL ....................................  6-16

Reload Document .............................  4-17

Repeat

Paragraph Background Image.......  6-32

Replace ...........................................  3-10

Result Window ................................... 4-5

ridge...............................................  6-35

Rollover Effect..................................  5-32

Caution......................................  5-33

Rulers ............................................... 4-2

S
Sample Extended Styles ...................... 6-7

Save ...............................................  1-10

Document ..................................  2-16

Save As a Different Name ............  2-17

Saving Document URL .................  2-19

Saving in Text Format .................  2-18

When the Same File Exists ...........  2-17

Script

ASP...........................................  5-48

Body Script ................................  5-47

Head Script ................................  5-48

Insert ........................................  5-30

Script Tab........................................  5-60

Script Wizard ...................................  5-31

Access Information......................  5-38

Animation Effect .........................  5-33

Clock in Box ...............................  5-40

Drop-Down Menu........................  5-35



INDEX
T

Index-8

Foldable Contents........................ 5-43

Jump Button............................... 5-37

Layer Action ............................... 5-45

Refresh Page .............................. 5-38

Rollover Effect ............................ 5-32

Scrolling Text in a Box ................. 5-41

Scrolling Text in the Status Bar ..... 5-42

Scrolling Text Box ............................. 5-24

Secondary Font................................. 6-26

Select

All ..............................................  3-7

Table ......................................... 7-19

_self................................................ 8-14

Show Tooltips................................... 9-36

Site Management.............................. 9-25

Size

Absolute..................................... 6-29

large.......................................... 6-29

larger ........................................ 6-29

medium ..................................... 6-29

Proportion .................................. 6-28

Relative ..................................... 6-29

small ......................................... 6-29

smaller ...................................... 6-29

x-large .......................................6-29

x-small ...................................... 6-29

xx-large ..................................... 6-29

xx-small..................................... 6-29

solid ................................................ 6-35

Sound ............................................. 6-20

Source Control.................................. 9-29

SourceSafe ...................................... 9-29

Space...............................................  4-9

Special Characters .............................  5-6

Spellchecker......................................  9-1

Automatic....................................  1-3

Standard Toolbar................................ 4-2

Status Bar ......................................... 4-2

Strong Extended Styles ....................... 6-7

Super/Subscript ................................. 6-2

Symbol.............................................. 5-6

Symbol Tab ....................................... 5-6

Symbols to 2B Characters..................  9-19

System Variables..............................  6-23

T
Table

Border ................................  7-3, 7-18

Cell Properties ............................  7-13

Delete Rows or Columns ..............  7-10

Draw........................................... 7-7

Equalize Cell Height.....................  7-12

Equalize Cell Width......................  7-12

Erase........................................... 7-8

Insert Rows or Columns................. 7-9

Merge Cell..................................  7-11

New Table.................................... 7-1

Properties ..................................  7-18

Select........................................  7-19

Specify Height .............................. 7-2

Specify Width ............................... 7-2

Split Cell ....................................  7-11

Trim Cell Size .............................  7-19

Tag........................................  6-47, 11-5

Target Frame ..........................  5-10, 5-36

Hyperlink ...................................  5-55

Template .........................................  2-11

Template Wizard .....................  1-12, 2-11

Tex/LaTex .......................................  5-57

Text File

Open........................................... 2-5



. .
 . 

. .INDEX
U

 Index-9

Save.......................................... 2-18

Theme............................................. 1-13

Gallery....................................... 6-42

Horizontal Arrangement ......  2-12, 2-13

Object........................................ 5-54

Object Property........................... 1-16

Theme Objects............................ 6-43

Time Line..................................  4-7, 11-6

Add ......................................... 11-10

Time/Date........................................ 5-61

Title ................................................ 6-17

Tool

Create ....................................... 9-37

Tool Set............................................  4-1

Tool Windows ....................................  4-3

Move ..........................................  4-6

Toolbar

Add Buttons................................ 9-37

Customize .................................. 9-36

Delete........................................ 9-38

_top ................................................ 8-14

Transfer Size .................................... 4-19

Transfer Time................................... 4-20

Typewriter ........................................  6-2

U
Undo ................................................  3-1

User Dictionary..................................  9-4

Make ..........................................  9-5

User Variables .................................. 6-24

user.dic ............................................. 9-5

V
Variable Extended Styles ..................... 6-7

Viewing HTML Code ............................ 1-8

Visual Basic Script(VBScript) ..............  5-30

Visual Tab........................................  5-58

W
WAV File Format...............................  6-21

we_hinfo folder ................................  2-10

wej .................................................  2-15

Window

Arrange Horizontally....................  10-2

Arrange Icons.............................  10-4

Arrange Vertically .......................  10-2

Cascade.....................................  10-1

Close.........................................  10-5

Close All ....................................  10-5

Windows List ..............................  10-6

WIndow Width..................................  4-13

WinInet.DLL.....................................  9-46

Z
Z-Index...........................................  11-3

Zoom In/Zoom Out...........................  4-12


	Homepage.pdf
	Building A Web Site
	Getting Started
	Launching WebEditor
	Entering Text
	Editing Text
	Inserting Image
	Inserting Background Image
	Viewing HTML Code
	Preview in Web Browser
	Saving Documents
	Closing Document
	Exiting WebEditor

	Building a Web Site Quickly
	Template Wizard
	Editing a Theme Object
	Changing Image

	Publishing a Web Site
	Registering Publish Information
	Checking Hyperlinks
	Publishing the Whole Web Site
	Publishing Unmodified Files

	Handling Internet Information
	Importing Information from the Web
	E-mail and WebEditor
	Auto Document Outline/TOC
	Making a TOC



	File.pdf
	File
	New
	Name of New File
	Document Tab
	Document Display Tab

	Open
	File Format
	Opening Text File
	Opening WP File
	Opening ASP File
	Opening Web Document

	Close
	Closing Document Tabs

	New Project
	Creating New Project
	Creating with Template Wizard

	Open Project
	Save Project
	Close Project
	Save
	Save As
	When the Same File Exists
	Saving in Text Format
	Adding Documents to a Project
	Saving Document URL

	Save All
	Publish
	Publishing Project
	Manage Site Information
	Publishing Files
	Importing Files

	Print
	Print Preview
	Page Setup
	Margin
	Header/Footer
	Contents of Header/Footer
	Header/Footer Location
	Page Number Start at
	Print Background Image

	Recent Files
	Recent Project
	Exit


	Edit.pdf
	Edit
	Undo
	Redo
	Cut
	Copy
	Paste
	Delete
	Cut Special
	Copy Special
	Select All
	Copy Format
	Paste Format
	Find
	Find Options
	Direction and Range

	Replace
	Replace Options
	Range

	Find Again
	Find in Files
	Bookmark
	Create Bookmark
	Move to Bookmark
	Modify Bookmark
	Remove Bookmark



	View.pdf
	View
	Tool Set
	Tool Windows
	Project Window
	Project tab
	Explorer tab
	Graph tab

	Result Window
	Link Check tab
	Find in Files tab

	Document Outline
	Moving Tool Windows
	Time Line
	Layer

	Mark Set
	Format Mark
	Paragraph Mark
	Space
	All
	Paragraph Spacing
	DBCS Align

	Image set
	Image
	Background Image
	Animation

	Zoom In/Zoom Out
	Window Width
	640x480
	800x600
	Printer Default Paper
	A4
	Letter

	Page Layout
	Preview in Netscape Navigator
	Preview in Internet Explorer
	Reload Document
	Refresh Screen
	Document Information
	Location
	Author
	Encoding
	Background Color
	Background Image
	Generator
	Transfer Size
	Transfer Time
	Image Files
	Etc. (applet...)



	Insert.pdf
	Insert
	Line Break
	Line Break
	Line Break...
	Normal Line Break
	Clear Left Margin
	Clear Right Margin
	Clear All Margins
	Style
	Extended


	Horizontal Line
	Width
	Height
	Alignment
	Solid Line (no shading)
	Style
	Extended

	Comment
	Symbol
	Image
	General
	Source
	Low Resolution
	Alt Text
	Copy Image
	Clip Art
	URL
	Target Frame

	Appearance
	Alignment
	Size
	Restore Size
	Space
	Style
	Extended

	Resizing Image

	Clip Art
	Adding Clip Art
	Adding Clip Art Folder

	Layer
	Form Field
	One-Line Text Box
	Name
	Initial Value
	Width in Characters
	Maximum Length
	Type
	Style
	Extended
	Event

	Scrolling Text Box
	Name
	Initial Value
	Width in Characters
	Number of Lines

	Check Box
	Name
	Value
	Initial State

	Radio Button
	Name
	Value
	Initial State
	Event

	Drop-Down Menu
	Name
	Add
	Modify
	Remove
	Move Up
	Move Down
	Height
	Allow Multiple Selections

	Push Button
	Name
	Value
	Button Type

	Image
	Name
	Source
	Align
	Copy Image


	Script
	Script Wizard
	Rollover Effect
	Animation Effect
	Only for IE

	Drop-Down Menu
	Jump Button
	Refresh Page
	Access Information
	Clock in a Box
	Scrolling Text in a Box
	Scrolling Text in the Status Bar
	Foldable Contents
	Layer Action

	Body Script
	Head Script
	Advanced
	Applet
	Plug-In
	ActiveX Control
	Theme Object
	Hyperlink
	Remove Hyperlink
	Equation
	Visual
	Script

	Etc.
	Nonbreaking Space
	Time/Date
	Component
	File
	HTML Tag



	Format.pdf
	Format
	Font
	Style
	Super/Subscript
	Size
	Color
	Extended Styles
	Font
	Extended

	Character
	Paragraph...
	Type
	Paragraph Type

	Align/Line Height
	Margin
	Line Height
	Style
	Extended

	Form
	Information
	Settings
	Hidden Field
	Clear Form

	Document Properties
	Information
	Appearance
	Document Colors
	Background
	Style
	Extended

	Advanced

	Paragraph Style
	Class
	Font
	Font Names
	Cancelling Options
	Size
	Decoration
	Style
	Weight

	Colors
	Color
	Background Image

	Text
	Box
	Borders
	Style
	Color
	Width


	Style sheet
	Adding Style
	Editing Style Sheet
	Save Style
	Import Style

	Increase Indent
	Decrease Indent
	Split List
	Merge list
	Theme
	Page Break Set
	Page Break
	Page Break...
	Page-Break-Before
	Page-Break-Inside
	Page-Break-After

	Protect Widow/Orphan
	Protect Orphans
	Protecting Widows


	Tag


	Table.pdf
	Table
	New Table
	Rows and Columns
	Size
	Layout
	Border
	Background
	Style
	Extended

	Draw table
	Erasing a Table
	Escape Drawing Table

	Insert Rows or Columns
	Delete Rows or Columns
	Split Cell
	Merge Cell
	Equalize Cell Width
	Equalize Cell Height
	Cell Properties
	Alignment
	Size
	Border
	Background
	Style
	Style...
	Extended

	Table Properties
	Border
	Trim Cell Size
	Select


	Frame.pdf
	Frame
	Frame and Frameset
	New Frameset
	No Frame MSG Tab
	Frameset Source Tab
	Frameset Preview Tab

	New Page
	Open Page
	Save All
	Save Frameset
	Save Frameset as
	Print Frameset
	Print Preview
	Split Frame Horizontally
	Split Frame Vertically
	Frameset Properties
	Frame Properties
	Layout
	Margin
	Resizeable
	Scroll Bar
	Border Thickness
	Style
	Extended



	Tools.pdf
	Tools
	Spelling
	User Dictionary
	Making User Dictionary

	Auto Correct
	Add to Auto Correct
	Auto Correct Rule

	Key Macro
	Defining Key Macro
	Playback Recording

	Image Map
	Making Hot Zone
	Modifying Hot Zone
	Making Transparent

	Change Case
	Symbols to DBCS
	Import from Browser
	Import from Web
	Basic
	Authentication
	Advanced
	Download From Web

	Site Management
	Incremental Verify Link
	Verify Link
	Change Characterset
	Make Site Map
	Publish Information

	Source Control
	SourceSafe Project Setting
	Working on SourceSafe Projects

	External Programs
	Customize Toolbar
	Customizing Toolbars
	Creating New Toolbar
	Adding Toolbar Buttons
	Deleting Toolbars

	Preferences
	Document Default
	Colors
	Encoding and Fonts

	Loading Documents
	Settings
	Loading Documents
	Speller
	Save Documents

	External Program
	Editor
	Web Browser

	Internet
	HTTP
	DLL
	Proxies
	Cache Policy

	Project



	Window.pdf
	Window
	Cascade
	Horizontally
	Vertically
	Arrange Icons
	Close
	Close All
	Windows List


	supplement.pdf
	Supplement
	Layer
	Time Line
	Namo GIF Animator
	Global IME
	Layer
	Inserting a Layer
	Layer Properties

	Time Line
	Creating an Object
	Create Straight Animation
	Creating Curved Animation

	Namo GIF Animator
	Global IME
	What is Global IME
	Installing Global IME
	Usage of Global IME



	homepageIX.pdf
	Symbol
	Numeric
	A
	B
	C
	D
	E
	F
	G
	H
	I
	J
	K
	L
	M
	N
	O
	P
	R
	S
	T
	U
	V
	W
	Z


