
 Photoshop : Kai’s Power Tips & Tricks : 
Secrets of Channel Operations:
 #1 You need Chops...
Shadow & Highlight Multipliers

Why?  
Channel operations are definitely the unsung hero of Photoshop.  There are amazingly 
powerful methods to create effects that simply could not be created any other way, no matter 
how good you are with that Wacom airbrush... Since the Adobe documentation has only 4 
pages on this subject and even the PS book only 12 (although both are generally excellent!) 
there are plenty of secrets, examples, techniques to be shared here.
This is NOT one of the One Minute Quickies, but is worth every minute of your download, 
reading and “try-on-your-own” time... (Especially the latter - this is NOT a short story to 
READ. It’s a how-to....)
Rather than a dry lecture on internal math or abstract concepts, I will describe particular real 
life case studies and apply a number of Chops as needed. I may digress from time to time into 
tangential subjects, there may be a bad pun here or there, especially there. Tough cheese.

What?
The old drop shadow is beginning to be THE most overused graphic technique, but still:  life 
ain"t flat and to some degree there will be light & shadow in just about any image. I will start 
with the drop shadows, but progress into much more complex territory beyond that. Either 
way, it"s up to you to use the tools for “goodness, not evil.” Teaching chord progressions 
should not be held responsible for Muzak.

In the book and manual “Alpha Channels” are mentioned in conjunction with these 
calculations and they are often dealt with as “selections” of the main image.   I use them 
somewhat differently and may stray from the traditional ways and naming conventions.

Ok, first up is a new concept I termed “Shadow/Highlight Multipliers.”  The basic technique 
is quite straight forward and I cannot stress enough how useful it is, at least to me. 
This may look like a terribly complicated surgical operation if you just fly across it, but the 
actual process would take less than 30 seconds once you figured it out. 

How?
The effects can be generated at any size, exact numbers are only examples provided for 
repeatable results. 
There are a few basics that need to be covered as we go along.

1) Go to File > “New” and create a 400x300y window, Gray Scale, 72 dpi. 
Note: the Calculate commands are greyed out in the Indexed Color and Bitmap modes. 
Under the Image > Calculate menu you will find these 11 options:
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These operations deal with images as sources, destinations and masks. 

Tip >>> The most basic fact one needs to understand is that they work ONLY if the sizes 
are IDENTICAL. If you try to blend two files that are off by even a single pixel you won’t 
even get to SEE them in the pop-ups... MetaTip >>> the quickest way to check on the sizes is 
by option-clicking on the “Size” box, next to the bottom scroll bar, to get the little info 
window. Then you can scale one of the images to conform to that size. (Image > Image 
Size...)

 

Tip >>> The fact is, though, that these operations are not exactly all in the same class, even 
though they appear in the same menu. Duplicate works one a single channel, while 
Composite works on three and the others compare two. While there are pairs such as 
Add/Subtract and Lighter/Darker, each of the others is quite unique. There is simply no global 
explanation...

2) Lets just jump right in. Many techniques describing subtle shadows start with a trivial 
piece of text which is a selected region that simply gets pasted onto a displaced copy of itself. 
Easy enough if that’s all you need.  Other times there are airbrush techniques. But what if you 
have a complex image (as this rather goofy and meaningless example): Now selection, magic 
wand, pen paths & airbrush are all inappropriate!
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 3) Draw something similar with the brush or line tool. Keep it plain black for now, but 
crisscross any way you like...
4) Select Image > Calculate > Duplicate...and click “ok.” The default settings will create a 
copy of the first window, now  called “Untitled-2” (or as I refer to them shortly “U-2” 
(unless you did other work and are up to “U-133” by now...(My personal record)) 

Tip >>> The fact that this is an “exact same size window” in Gray Scale makes Duplicate an 
ideally suited method to work with Chops. I have a Quickkeys macro defined for 
“Command-D” that takes the current window and simply duplicates it  (and includes the 
click-OK step).

5) This first copy will become our shadow. You could keep it as is - a hard cast shadow, but 
the technique comes really into its own with the possibility to get very realistic soft blend 
shadows. Use Filter > Blur or Blur More or better yet Gaussian Blur set to 2-5. These tiny 
examples using Blur More look roughly the same as a large version using Gaussian at 3:

 
6) Lets move the shadow for more realism. Filter > Other > Offset...  Enter x:6 and  y: 4  Ok. 
(In the tiny samples its only 3 and 2) 

Tip >>> Try not to use identical offset values, as a displacement in exactly 45 degrees can 
create artifacts such as moirés; also: clean diagonal lines would not have any visible shadows 
along their length.

7) Go to Image > Calculate > Subtract... 
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8) Lets look at this for a minute. Basically there are two images, Source 1 & 2, and a 
Destination.  All of these have a “Channel” popup underneath. If we were dealing with full 
color images these channels could be either RGB, R, G or B separately. In Gray Scale the 
pop-up shows only “Black” (more only if you merge or add new channels, which we won’t 
do for now.)
Note : There are two basic methods to use the calculation commands: Generate new windows 
in separate files or generate multi channels inside one file. I will use individual separate files 
mostly, but there are reasons for both. Specifically all channels will only work together with 
identical dimensions. If all channels are inside one file they all get scaled or resized together in 
synch. On the other hand, such multi channel files can only be saved in the native Photoshop 
format, which is larger than say PICT or GIF. There is also more freedom to save, load, 
update and view individual files. Saving with JPEG for instance, will not work with 
multichannels. 

Tip >>> As shall become apparent I often have literally dozens of masks and multipliers to 
create a single image. For simplicity of housekeeping I often combine them all afterwards into 
one huge multi-channel file for archiving. During work, though, I prefer individual files.

9) Note that the currently active window name is already inserted for you. If you click on 
Untitled-2 you will see all files that can be operated on (i.e. all of equal dimensions and 
compatible modes)

Tip >>> If the image you want to blend, add, etc. does not show up in the pop-ups, the size 
does not match the currently active window, or it is in an incompatible mode (e.g. 
Indexed...): Resize and change Mode to Gray Scale or RGB.   MetaTip >>> Even with an 8 
bit card Photoshop works internally in 24 bits. In RGB mode the image may look dithered, 
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but it retains all subtlety. Changing over to Mode > Indexed Color...will look momentarily 
cleaner, but is infinitely less subtle inside. You should always do all work in large size RGB 
mode and only create an additional, separate Preview version of the final art that is dithered to 
an Indexed Color (256) palette at the screen size.

10) Now:   We need to subtract the shadow from the clean original.  Think of the Subtract 
dialog as: Top popup (Source1) minus Bottom popup (Source 2) saved into Destination 
popup (here usually a NEW file). This means that you should click on the top popup and drag 
up to put “Untitled-1”  in there. Photoshop 2.5 defaults the Offset to be 128, so be sure to 
change it to 0. ( I wish there was an easy way to name the windows short of saving them in 
PS format.). Click Ok.
11) Slight hitch: the resulting file will need to be inverted. (should be an option in the Subtract 
dialog) Use Image > Map > Invert, or simply  Command-I. Voila, our Shadow Multiplier:
 

To describe in other words what happened here:   We cut all parts that are black in U-1 out of 
the image in U-2 and put that into U-3.  U-3 now contains what I call the Shadow Multiplier: 
only information about the shadow which will not interfere (by definition) with the original 
artwork. It can now be added to (actually “multiplied into” any other version of the original 
art, even if that art sits on complex textures, color backgrounds, blends, etc...(and THAT is 
the difference to traditional “paste region over offsets,” as we will see. In this simplistic 
example the power is not yet obvious.)
12) Instead of “Add...” we need to use Image > Calculate > Multiply...  (We’ll cover Add... 
later)   Multiply U-3 with U-1  Tip >>> If you are strapped for space, select U-2 as the 
destination now; the blurred U-2 was only a step to get U-3 and is now dispensable.  But 
normally “ok” will create U-4: the original artwork with a displaced soft shadow-  Quod Errat 
Dropshadundum...
 

To sum this up and prove the point that it is quite easy and fast:  Original art, duplicate, blur, 
offset, subtract from original, invert, multiply back into original, done.

You should think of Multiply U-3 with U-1 as : whatever is black in U-3 will be added to 
U-1.  Where U-3 is white, you will get the clean U-1 with nothing added. Whatever is an 
in-between shade of gray in U-3 will just darken U-1. 
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In another way: if you multiply a solid black image with U-1 you will get solid black. If you 
multiply solid white, you won’t affect the image at all and you get U-1. 
The manual describes it as “using a transparency overlay on a light table.”

Now the fun really begins. Once you have that Shadow Multiplier you can go to town and 
add it to anything But while we are talking about similarities, let’s use the cousin of Multiply:  
“Screen...”
13) First we create a background with the Blend tool. Use Image > Calculate > Duplicate on 
any of the windows, which creates U-5, and then clear it to plain white.

TIP >>> To clear a marqueed region hit “delete,” to clear a window double click the Eraser 
tool. Both of these will fill the region or screen with the background color (and are faster than 
paint bucket fill). MetaTip >>> Fastest way to set the background color to white (as well as 
foreground to black) is to double click the Eyedropper tool. This was made even easier in 
Photoshop 2.5. Off to the left, beneath the foreground and background pickers is a miniature 
color picker icon. Clicking on this resets the foreground and background to black and white.

TIP >>> Read the “KPT #5 - Have A Ball” document about more Blend tool tips. It talks 
about spheres, but the hints are applicable for linear backgrounds as well... This one uses 
two blends, the first top to midway of the image at Opacity = 100%, the second goes bottom 
to top with Opacity set to 20%.   Metatip >>> often overlooked:  you can set the transparency 
simply by holding down the “1” through “9” keys... for 20%  that’s the “2” key, very easy 
and much faster than setting it in the dialog.

 

14) Now we can “stencil out” this gray ramp into our original shapes:  Use Image > Calculate 
> Screen... Enter Source 1 = U-1   Source 2 = U-5 and click Ok. This creates U-6 :
 

Aside from all the math descriptions and analogies, I suggest you remember some of the 
Chops simply in terms of specific operations.   If you take two color images and randomly try 
to screen, subtract, multiply etc. you will get pretty strange results, maybe sometimes an 
unexpected bit of creativity, but certainly not anything resembling a usable tool.  If you use 
Gray Scale for image A and Grayscale, RGB or CYMK for B then there are repeatable and 
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very useful applications for all the Chops. 

This would be the summary  so far :  (We will cover all the other channel operations in other 
documents)

“Screen” will stencil out all areas that are black in image A out of image B and put them into 
C.
“Multiply” will add all areas that are black in image A to image B into C.
“Subtract” will cut out all areas that are black in image B out of image A and put the rest of A 
inverted into C

Note > The Gray Scale image can of course contain all shades of gray and the description 
above applies to solid black and has to be linearly extrapolated for those in-between shades. 
White will essentially have no effect at all and a medium grey will have a translucent blend 
effect. Experience helps.

What Else?

TIP >>> One implication of the process is that you may want to tone down the solid blacks 
in the multiplier. Do this with the Image > Adjust > Levels... dialog and move the bottom left 
triangle to the right.

 

Tip >>> This is a very valuable little operation!  You may think of it as ”make the blackest 
black not so black” without affecting the rest of the image very much. Conversely, if you 
move the bottom right triangle toward the left, it is the “make the whitest white not so white” 
tool...    MetaTip >>> The two combined get you a perfect "Toning Down” process, if, for 
example you want to put a subtle background image behind text. In a CD booklet I added 
subtle color images toned way down behind plain black text. Create your images in full color 
and tone down as the last step, rather than trying to create the image itself using only a muted 
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colorscheme. Much easier!
Once you have a toned down Shadow Multiplier you can vary the intensity with repeated 
multiplies.

Let’s show the power of the multiplier and extend it to highlights as well.
I will use a more complex source image:  
Note: This Ambigram (don’t get a headache) is courtesy of Scott Kim. His book 
“Inversions” is magnificent! He also has a Macintosh puzzle/game collection called 
“Letterforms and Illusions”out. You can reach him on AOL under screen name “Scott Kim!”

 
Tip >>> this is a cleaned up scanned version of a faint pencil sketch in a copy of the book. I 
will explain in a separate document how to clean such files and faxes, as it is very useful 
indeed. This is about as clean an edge as can be had at 72 dpi 8 bits...Look for the doc on it!

First the same sequence to create the shadow multiplier:
                         
  K1 

     K2  

   K3   
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  K4 

K1, Duplicate to K2, Gaussian Blur (3), Offset (3x 2y), Subtract K2 from K1 and invert to 
get K3,  Multiply K3 with K1 to get K4. Could you do it in 30 seconds by now?  So far so 
good.

The powerful extension comes by the realization that if you can “multiply a shadow into any 
picture” that you can use and inverted version to “multiply highlights into any picture” as 
well. The advantage of this process is hard to see on these thumbnail sketches (see more 
complex examples such as Turbulence or the Yes Logos),  but you are essentially painting 
with light and shadow and you are doing it without airbrushes or manual selections, but 
algorithmically with masks and channel operations.

Tip >>> By implication the algorithmic method works with any size image and I commonly 
will do exploratory sketching with small sections of an image (better than a resized 
convoluted version of the entire image!) such as the “K” above. Then I record every step into 
a Quickkeys macro and simply replay the macro with the full resolution final image. Such a 
“re-rendering” can then take hours but is completely automatic. Just be sure you have the disk 
space, and that Filter operations, which are RAM limited, work on the full image. Also, 
restart Photoshop so that the initial image will for the macro will have the same name and 
position in the Chops popups as the tiny placeholder did.

To create the matching highlight multiplier we can even re-use K2, the Blurred and Offset 
version. We need to offset it symmetrically to the upper left though. Since there are 
interesting combination effects in store for the offset blur, we Duplicate K2 first, yielding K5.
Now K5: Filter > Other > Offset -6x -4y (back from 3x 2y to zero and then minus that again). 
Same Subtract: K5 from K1 yields K6,  then don’t forget to invert and you get the Highlight 
Multiplier.

K6 

The really cool thing is that between the shadow and the highlight you can now define the 
original shape out of any texture, with a “negative space” (not drawing the shape but drawing 
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all around its edges until you see the shape). For example, this is a texture (derived from the 
method in the “Instant Aluminum” note)

T1 

Tip >>> it works best if the texture contains many medium gray shades so that both light 
and shadow modifications can be distinguished. The larger the shape (and the shadows) the 
less this is necessary, but in this tiny example with the small shadows it helps a great deal to 
have lots of gray.

To multiply the shadow into it is trivial now. K3 times T1 gets K7:

K7 

Tip >>> If in this step you want darker shadows without touching up the whole image, just 
repeat the Multiply:  K3 times K7 (To save space you can set Destination to K7 and Channel  
to 1 instead of “New,” it will then overwrite the first version of K7.  You can always use 
Command-z UNDO for a quick comparison. MetaTip >>> If you forget which way you 
switched look under Edit : it will say Undo after change or Redo if you switched back.

Now for the Highlight Multiplier: There is no channel operation that would multiply a light 
area into an image. So we need to multiply the dark (inverted) version of the highlight into the 
inverted version of the image. No big deal, K6 is already inverted. Now we invert K7:

inv K7 
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 and Multiply it with K6 to get K8, which we then have to invert one last time back to the 
final positive:

K8 

Did you get that? We just used the two multipliers without the original artwork to emboss the 
shape out of a texture file. Of course now that can be ANY texture or image! You can create 
those fancy chiseled marble effects and a zillion others. This tiny example does not do it 
justice, look at some of the sample files (and even those are small screen jpegged or 8 bit... 
The subtlety and major advantage over other methods truly shines at 2000 line 24 bit files).
And really we are just beginning to get into it now! We have 9 windows open:  2 multipliers, 
1 original filled mask shape (as I called the solid black figure), 2 offset blurs, 1 texture and 2 
combinations and one "final" version. That is NOTHING. As mentioned above for the main 
Turbulence CD poster file there were a total of 133 steps with dozens of combinations, and 
probably every Chop used several times over. Still, this is an essential part of the process and 
a universal technique.

To illustrate how Chops really come into their own especially when you start combining them 
sensibly, look at these quickie metamorphoids:
 If you use Blend between the final K8 and the earlier blurred K2 you get this:

K9 

Lets get another useful Lego block into the action.Duplicate the blurred K2 and use Image > 
Map > Equalize which will seriously darken the subtle edge light shades and create a darker 
blob. Then Gaussian Blur that:
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K10 

Multiplying an inverted K10 with the clean K4 gets this:

K11 

Such soft halo backdrops are not easy to do with other methods. (OBVIOUSLY this all 
works with color images...it just gets these documents too big to download)

Using “Difference” between the inverted K10 and K11 gets this:

K12 

This is the perfect Candy Apple Neon Effect! All you have to do is to go to convert to RGB, 
then go to Image > Adjust > Hue... and set the sliders to:

 

and get a perfect neon glow...  (Great Colorization tricks in another document)

The Soft Halo, Glowing Neon, Embossing Marble are all just a few Chops away. Once you 
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understand how the process works and which tool is responsible you can go after such 
effects deliberately.

Tip >>> You can even have a QuickKeys MACRO defined that creates the complete 
multilayer effect automatically for “any black blob!” starting image, at any size or resolution!  
Kind of 2-D rendering...  

Lots more to come!

There is a final colorized multichannel example of the ambigram above, done as a large 24 bit 
image, but resized and jpegged down to 640x370. Worth a peek...it’s in the Photoshop > 
Images area...

PS:
You could add a note in the feedback folder mentioned at the top if you have results to share 
with others. Please let AOL and Adobe know if you find these tips useful.

Happy Photoshopping,     Kai Krause
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Photoshop : Kai’s Power Tips & Tricks : 
Secrets of Channel Operations:
 #2  You need more Chops...
All’s well that blends well

What?  
Because Chops are still the most undervalued tools in Photoshop and ‘algorithmic painting’ is 
the next wave that just hasn’t quite hit yet!  But here you are, owner of Photoshop and ready 
to partake in it right now. Sure this won’t replace 3-D Morphing as the best since sliced bread 
award winner, but in day to day nuts and bolts artwork it is indispensable. Maybe just for 
me? Well, take it or leave it. I LIVE with the stuff.
In the first part about Channel Operations I introduced the concept of shadow and highlight 
multipliers and touched briefly on Subtract, Screen and Multiply. I will assume you have read 
part one first and won’t re-explain the wheel...

How?
This time lets start with a little Blend trick...            
As always, the effects can be generated at any size, exact numbers are only examples 
provided for repeatable results. Please no wagering.

1) I will put a shape in here as a sample. It’s a Roger Dean “G” from a logo letterform: 
“Magazine”             The bumpiness and raggedy lines are by design. ( Yes, it’s another 
cleaned fax...)

fig. 1 

Now, in the days before the Emboss filter made such things very easy I used the following 
technique to create those types of reliefs. Interestingly enough, I still come back to it, as it 
allows other variations than Filter > Emboss (which I use as well, of course) and in this 
context it sheds light on the nature of “Blend”
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Lets have a look at Image > Calculate > Blend...
Interestingly enough, there are a total of nine lines of description in the Adobe Photoshop 
manual and even in the otherwise very useful Photoshop Handbook there is not a single 
mention in the entire book or index!  I guess it must not be of any obvious use? Let’s change 
that!

Blend will add together the brightness values of each pixel in two images. (similar to Add..) 
and it allows you to shift the relative dominance of either one, expressed as a percentage. 
Normally at 50% they are equally “strong”. (Again to develop useful tools, I will keep mostly 
in Grayscale mode, at least for the ‘operand’ file. You can indeed have RGB and CYMK for 
both images and they may create neat effects with Chops, but for the purpose of creating a 
serious ‘vocabulary’ of predictable effects I find it useful to separate the color art from the 
mono masks and channel operators (as seen in the Shadow Multiplier document).  

 

Simple point here: if we duplicate and invert U-1 we will have the ‘exact opposite’ in U-2:

U-1
 Fig. 2a) Normal 

Kai's Power Tips Page  15 Thu, Dec 7, 1995



U-2              
       2b) Inverted

Now it is easy to see that combining each corresponding pixel pair will get you the average of 
the two, which in this case is an even shade of gray... White (256) plus Black (0) gets you 
Gray (128). 
The average is ( A + B ) / 2   in case you had mumps that day.

Note : If the blends and gradients don’t look very smooth to you, check if the little Apple icon 
in the upper left corner has color stripes.  It is supposed to be gray! If you have color there, 
you are still in the 16 shades of gray of the system palette and you are missing 240 additional 
ones... Go to the ‘Control Panel’ under the Apple menu and in ‘Monitors’ set it to 256 
GRAYS! Big difference...

Fig 3)               

Here we see further examples. Doesn’t make for great romantic novel reading, but to 
understand, it helps
Upper left : black plus white yields solid grey.    0 and 256 = 128     56 and 200 = 128 
Upper right : black &white plus gray yields toned versions of the same b&w.   In the 
Formula example       
 black   (0)   and gray (128) gets you lighter black  = gray  (64)  
Lower right: white (256) and gray (128) gets you darker white = gray (192)
Lower left :  black & white plus a gradient gets you the same b & w toned up and down by 
the gradient     You can easily look at corresponding pixels and mentally add them together to 
see how the right resulting image is a true blend of the two...

Well, that’s why they call it Blend anyway. 

Ok, after some of these ‘exercises’ to get an intuitive feel for the operation, here is the trivial 
explanation of a very powerful technique for reliefs of all kinds: If the two images being 
blended (Source 1 and 2) are exact matching duplicates and one is inverted, they ‘cancel each 
other’ and we get plain grey. But what if they are not exactly registered, but slightly offset 
from one another?      Voila, embossing-city...
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Fig. 4) 

The middle image is the inverted duplicate and is moved up and left one pixel. After Blend 
you get the Relief on the right... (that one is damn close to identical to the Embossing filter set 
at 1 pixel....)

Tip >>> you have several options to offset the second image. The most obvious is Filter > 
Other > Offset... where you can just type in the pixels (-1, -1) in this case, and use repeat 
edge for the least nuisance effects. The minus offset is to move it up and left, in order to get a 
highlight up left. You can of course put it anywhere you like... In this case I simply 
marqueed tightly around the shape and used the option key (that causes a copy to be moved, 
which leaves a trail in the edge color behind just moving it would have put a white space 
there...) Since I wanted to move just a pixel, I used the arrow keys (‘nudging’). So “option / 
left arrow / up arrow” takes about a half a second...

Well let’s zoom past the little Emboss filter emulation to other possibilities, because it is a 
LOT more powerful than that!  The plain shape (4a) will be our main image “Source 1” in all 
these examples.
Let us take the inverted duplicate and use Filter > Blur > Gaussian Blur... set to “4” on it. 
This gets us figure 5), a blurred shape, which we then offset  -4x  -3y (left and up). Now 
let’s Blend...!
 

Fig. 5)

Fig.6)  
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Aha! Figure 6) now has a light corona effect and a good shadowy curvature on the right. This 
can be made into very cool effects and images... 
Note : As you may know by now, it is the algorithmic nature of these processes that is so 
powerful and once you have these tool primitives you can combine them to ever more 
complex pictures. One Blend by itself is nothing exciting...but fig 6) is a good intermediate 
mask file to have!
Ok, subtle as it is, here is an example how just the offset direction and one inversion can have 
very interesting results: If we offset Fig. 5 down and right +4x and +3y to undo the previous 
offset and then Command-F to repeat the offset, and then blend with Fig. 4a and then Invert, 
here is how that looks

Fig. 7)  

and if we take fig 5) the blurred shape which has been offset, and use Filter > Stylize > Find 
Edges, then Invert (do not invert if using Photoshop Version 2.0.1), we get this nice version 
of a halo edge: Fig 8)  (The filters have a whole chapter unto themselves. This is a mere 
peek...).   Now using fig 4a) and fig 8) blended and then inverted results in fig 9). Even 
more ‘depthy’ than 7). Actually it is starting to look metallic quicksilvery now, which is not a 
bad thing... (You can go from figure 1) to 9) with a simple 7-step macro automatically....)

Fig. 8)
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Fig. 9)  

The fun is that you now have all these windows open and can start to mix and match!  Blend 
7) & 8) and invert, for example, and you get this depthy morsel:

Fig. 10)  

More combinations: a copy of the original image (Fig. 1, U1, 4a)  offset +4x and +3y, Find 
Edges, Gaussian Blur... gets you Fig 11), which, blended with 10) gets you 12 and with the 
original 8) plus invert gets you fig. 13)...

Fig. 11) 

Fig. 12) 
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Fig 13)  

Not a bad little set of sketches for just a few mouse clicks... and we are still using only 
Blend, we are still mono, we have no other textures open, etc. etc. etc.   And all the pointers 
from the other documents can be combined as well (e.g. multiply a shadow underneath any of 
these, or a halo behind it....)

Since we have merely played with the one Channel Operation, “Blend,” here, there is 
obviously another part III coming, just to cover the basics of the other Chops. And quite 
likely a part IV & V to uncover all the fun tricks that they are capable of in conjunction with 
each other. This should get some of you started in a few new directions...

PS:
You could add a note  if you have results to share with others. Fill out the feedback form in 
this library. Please let Compuserve and Adobe know if you find these tips useful.

Happy Photoshopping,     Kai Krause
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Photoshop : Kai’s Power Tips & Tricks : 

One Minute Quickies :
Instant “Brushed Aluminum” Textures

Why?  
This does not solve any grandiose problem, it’s an interesting extremely quick method to 
create textures and backgrounds with a “brushed aluminum” look. Lots of variations.

How?
The texture can be generated at any size, exact numbers are only examples provided for 
repeatable results. 

1) Go to File > “New” and create a 400x300y window, grayscale, 72 dpi.
2) Use the marquee tool and select a rectangle on the far left side, full height, about 15-20 
pixels wide

TIP >>> Use Window > Show Info. The readouts will show the dynamic size of the 
selection rectangle as you drag the marquee tool. Not critical here but often very useful.

3) Go to Filter > Noise > Add Noise...enter amount 99, Gaussian
4) The 15x300 rectangle should now be filled with Noise as shown here (not to scale)

 
5) Go to Image > Effects > Scale, which adds little handles to the still selected marquee 
rectangle
6) Click and drag the lower right handle all the way to the far lower right corner of the 
window

TIP >>> While dragging you can press the SHIFT key to constrain the movement (not 
critical here)
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7) Upon release you should have created Instant Brushed Aluminum ...Voila!
 

The theory behind this is that the noise pixels of various shades of grey are stretched with the 
Effects Scale feature and are now smooth anti-aliased long strips showing ‘metallic’ 
transitions. 

What Else?
The effect is influenced by several variables: the number of noise pixels, their shape and their 
shades, the width of the source rectangle before and after the Effect Scale stretch, etc.
Try the following variations: 

TIP >>> Use Image> Calculate> Duplicate...to create copies of the work in progress and 
modify them. Easier and faster than UNDO, allows comparative review and multiple channels 
can be combined in myriads of ways for further effects. (Separate Document on that topic)

1) After filling the source rectangle with noise, use the Blur More filter then proceed. A much 
softer transition between the bands results, often more pleasing and less harsh, albeit not as 
‘metallic’. Many other filters affect the texture, either before or after the stretch. Try Stylize > 
Find Edges and Diffuse in the source rectangle. 
2)  The Levels... dialog (and others) can greatly affect the final texture. Goto Image > Adjust 
> Levels and 
    a) move the lower left triangle toward the right. This defines how ‘black’ the dark portions 
are. 
    b) move the lower right triangle toward the left. This defines how ‘white’ the light portions 
are
    Together these two alone can compress the tonal range and soften the texture in the 
process. Considering that you are very likely to superimpose other elements or text it may be 
required to tone down the texture.

TIP >>> You can click in the Title bar (e.g. on the word ‘Levels’) to quickly compare the 
before/after state of the Levels... settings.   This often overlooked feature is true for many 
dialogs that affect  pixel brightness, saturation, etc.. MetaTIP>>> After using the Preview 
button the preview will not work on 24 bit cards. Use Option Preview to restore it...

3) There are many ways to colorize the mono texture, dealt with in detail in another 
document. If the original window is in RGB mode, the noise pixels themselves will already 
be in random hues and processed in color. More subtle results can be obtained by converting 
Mode > Gray Scale to Mode > Indexed Color then using Image > Adjust > Hue/Saturation: 
Colorize. Settings towards Orange/Green can create convincing bronze/gold textures, blue 
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tints result in excellent wave material. (Try the distort filters on such waves, as well as Image 
> Effects > Perspective...) 
4) Many of these textures, especially considering their intrinsic anti-aliased nature, are very 
useful in high quality 3-D rendering, surface and bump mapping.
5) The same technique applied vertically (i.e. a thin 400x15 marqueed selection at the top...+ 
noise, then stretched downward) can create very realistic curtain folds. Use the gradient 
Blend tool at 50% (TIP >>> just hold down the “5” key, often overlooked short cut) intensity 
to darken directionally.
6) As always, in the process of trying these variations you may come across numerous 
interesting mutations and evolutionary sidelines. Save intermediate steps often! Use Duplicate 
to proceed with a copy. You can keep dozens of windows open. 

PS:
You could add a note in the feedback folder mentioned at the top if you have results to share 
with others. Please let Compuserve and Adobe know if you find these tips useful.

Happy Photoshopping,     Kai Krause
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Photoshop : Kai’s Power Tips & Tricks : 
Basic Toolkit :
How to Clean Up...a Fax or a Scan

Why?  
I don’t know about you, but half the jobs here start with some silly napkin sketch, or a fax 
from England or the client walks in with an ancient book of hieroglyphics with THE logo he 
needs.... In short, artwork can have a less than perfect origin. Sure, if it’s simplistic, off you 
go creating bezier outlines to get the smooth curves. This simple technique is not going to fix 
your deadlines or receivables, but its a cute little tool.

How?
As always, exact numbers are only examples provided for repeatable results. 

1) The client needs that Infinity logo. Not the speakers, not the car, but designer Kevlar 
condoms. You get the fax at 2 am and the contract IF you can show them a dozen color 
versions by noon. What do you do?
2) You go to sleep till 9 am, have a betty pot of Earl Grey and slap the fax on the scanner.
3) Here are the ugly results, opened  in Photoshop: (tiny thumbnail, these doc files are big 
enough as it is...)

                                         fig.1 

4) In reality this could of course be much, much more complicated and the idea of tracing the 
outline would be less attractive than in this perfect example of simplicity... In fact, look at the 
“Turbulence” file as an example of a really complex fax cleanup job.
5) Step A : go to Filter > Blur > Gaussian Blur and use amount “1.5”  (Yes it does fractional 
amounts and at this particular size 2 seems a bit much and 1 not quite enough. It is not an 
exact science, though.)

                                          fig.2 

The Gaussian Blur will obviously average the pixels at the white to black edge and create a 
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range of gray shades at that transition. It is the algorithmic nature of the filter that we are 
exploiting to clean up the entire image at once, rather than techniques that follow pen-paths, 
beziers etc.. Let’s see what happens:
6) Step B : use the Image > Adjust > Levels... dialog. You may have thought that one of the 
“Sharpen” filters is called for here and those may do the job sometimes, especially the subtle 
“Unsharp Mask”.     But we are about to add a peculiar benefit: Realtime Control!  (Cool...)

          fig.3
  
This is what it looks like initially after we did the blur. The black lines show the histogram: 
256 possible gray shades and how many pixels there are of each shade.

Tip >>> The histogram is your check if you are doing the best possible job here. It  shows 
that the odd choice of 1.5 was indeed correct and resulted in a nice even distribution of 
shades. Obviously there are peaks at the b & w  ends of the spectrum, but important is that all 
other shades are represented. For comparison too little or too much would look like this :
                     

                                      fig 4: Using “Blur More” twice: spotty...

    

                          ...and  fig. 5:  Using “Gaussian” at ‘4’ : black is gone

Now for the realtime effect:  Dragging the black triangle to the right darkens more and more 
of the gray shades and thickens the image:
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                          fig. 6
 
Dragging the white triangle to the left will change more and more grays to white and thin the 
image:

                          fig. 7
 
Between these two extremes you have quite a number of steps and all of them in realtime! 

Tip >>> “Levels...” does this by altering the gamma table, which works in realtime even on 
24 bit cards!

               fig. 8
 
And here is the final position: determined simply by observing the critical edges and realtime 
adjustment.
Note : If this doesn’t look like a very smooth edge to you, check if the little Apple icon in the 
upper left corner has color stripes.  It is supposed to be gray! If you have color there, you are 
still in the 16 shades of gray of the system palette and you are missing 240 additional ones... 
Go to the ‘Control Panel’ under the Apple menu and in ‘Monitors’ set it to 256 GRAYS! Big 
difference...

To see just how good that cleanup process really is, here is a magnified view:
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      fig.9   Zoom  2:1 Close-Up:  As good as you can get it on a 72 dpi 8 bit screen!

And again: its algorithmic (!) and realtime (!!) which means you have total control and it 
works even for incredibly complex images, where any other method would be suicide!

Tip >>> One of THE MOST USEFUL tips about all the gamma dialogs is the fact that you 
have an instant compare before and after if you simply click inside the title bar of the dialog! 

                    fig. 10  

For the life of me I couldn’t find this in either the manual or the Photoshop book and I use it 
50 times a day! Maybe I missed it, but then, many others may have as well!  Try it,  it is 
immensely useful! It acts as an instant momentary Undo of the current settings, allowing for 
incredibly accurate fine control. It is details like this that make Photoshop a work of art!

Tip >>> If you have a gigantic image to clean up (e.g. a logo scanned at 800 dpi ...) you 
can use a small chunk (pick the trickiest bit, i.e. a thin curve, crossing lines, etc) and find the 
correct settings interactively and fast. Then open the full image and simply replay the settings, 
even as a macro in Quickkeys...

Tip >>> It is after the first pass that you can still clean up by using a small “blur” or 
“Unsharp” or even a manual touch-up.

Tip >>> You can perform the entire operation on an enlarged view, as in Fig. 9 MetaTip 
>>> to zoom up and down, use command ‘+ ‘and command ‘-’. MetaMetaTip >>> Use 
Window > New Window and zoom one up. These are true clones now and everything you 
do will happen in both. Now you have the zoom detail at any level, size the windows any 
way you like and tile/overlap them as well. Incredible control; often overlooked! Great for 
painting and other touch ups as well..

Tip >>> Dragging the triangles with the option key depressed jumps into Threshold mode: a 
one bit b&w transition makes checking very easy. Not that important in this context, but 
useful nonetheless.

Tip >>> Interesting enough, there are several possible positions that create a smooth and 
still reasonably sharp edge. Fig 8 is only one. In fact it is the distance between the three 
triangles that governs Sharpness (the closer b & w get to the grey one the fewer transitional 
grayshades from black to medium grey = the sharper that transition) and it is the position of 
the trio within the length of the histogram that governs how far ‘in and out of the shape’ this 
happens. What it means is that you can create smooth edged versions of the thickened or 
thinned shapes fig 6 & 7...If the grey triangle is at the middle 1.0 position you have closest 
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match to the original shape. Still, it is a matter of visual judgement and you can put it 
wherever it looks best...!

Tip >>> After you have found you visual ‘best guess’ you can double check: Enter the 
Levels dialog again and observe the histogram. Here is what it looked like after Fig 8:

             fig. 11
 
A very nice and even distribution of greys and clear b & w peaks. It’s not proof, but can 
make you feel all warm and fuzzy....

Tip >>> Obviously the effect has to do a great deal with the amount of blur and the 
subsequent ‘tightening’, both of which have a wide range. The caveat for the Blur stage is 
that it can have deteriorating effect on sharp corners that you do intend to keep. Find the most 
sensitive area for that and apply Blur until that spot begins to ‘lose it’. Other tips : marquee 
regions and process them with different settings, spot treat and fix stuff afterwards, add sharp 
edges in the critical spots with drawing tools and look for further hints below.

What Else?
Well the basic technique is only a two step affair, but it has certain conditions and there are 
additional methods worth knowing. First off, the perfect candidate is a monochrome filled 
shape. Not necessarily filled throughout, but the thinnest area should be about 5-10 pixels 
apart. A scanned or faxed monochrome logo or other shape is ideal (hence the title). If you 
need to fix up thin line art or full color images, this won’t work that well. 
You have to realize that it is not a lossless process and thin lines may fall victim to the 
mathematical averaging process. E.g. small serifs in a Roman family font (Times, etc.) can 
present problems. Also if you had a weak scan of a face, this will lose information that may 
be critical. Color images have other idiosyncrasies, namely that the distribution is different in 
the R G B channels and you might need to apply it separately. Although there are better ways 
yet, requiring Channel Operations (quick peek: create a mono mask channel, clean it as above 
but thin the area, then use it as the mask and foreground in a Calculate > Composite with the 
RGB color image as the background, this will cut out a smooth edged part of the color 
image...) More in a later “Chops” document.

fig.12 

In this figure a) there are both thick and thin lines. Isolating the thick area (duplicate, ellipse 
marquee erase inside to get fig b) subtract from a) to get c) (here already cleaned) then 
multiply the two back together to get the clean combination d) (Read the Channel Operation 
Chops documents too).  The last figure 12 e) shows the effect with the same settings but the 
blur ruins thin lines and creates blobs at intersections.
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Here we have another example of a tricky combination. The outside of this shape has been 
cleaned up with the plain Smoothie technique above, but in the process the inside sharp edges 
were softened as well.

                                   fig. 13 a)
  

                                   fig. 13b)                      
             
 

                                        fig. 14 

One method that is a great tool to have in your arsenal is to steal sections that would fit and 
put copies into trouble spots. In this example There is a clean section of the hypothenuse 
(John I’m not giving anything away this time) which we can displace diagonally up and down 
to get sharp corners. 

Tip >>> with the lasso tool use the Option key before the first click, then drag a rubberband 
line to the next point. Very easy to see where the edge and vertex will be and it is an automatic 
straight line!     Keep going, upon release of the option key the last point will be connected to 
the start and close the selected region, as seen in fig 14.

Tip >>> Follow these closely, they are ultra basic techniques you should learn the first day 
of PS work!!! To move a copy of that section do NOT use copy and paste (well, you can, 
nothing bad will happen and the Paste Controls often add power options, but in this case and 
in principle it is MUCH easier to just...:) Click instead inside the marqueed region with the 
option key depressed. MetaTip >>> As soon as you enter the region (the marching ants 
surround it) the cursor will change from tool (in this case lasso) to a right pointing arrow, 
that’s how you can tell.  

Tip >>> Here are the operations that you MUST know by heart. (really, for your own 
good. Trust me)
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a) If you click-hold-drag-away you will move that region somewhere else, leaving behind 
blank space (usually white, but actually the background color. Tip >>> Use 
option-eyedropper to set the background to a color from the image. So if most the image is 
grey, make that the background and you can drag away parts without leaving white blotches. 
MetaTip >>> the eraser tool will work then in grey as well.)

Tip >>> as you drag you can use the Shift key to constrain your movement to straight lines. 
Often overlooked: this action works DURING the dragging (In many other programs such 
modifiers have to be pressed first or not be functional at all)
b) If you press the option key first and then click-drag-away the selection, you will have a 
copy that ‘floats’ above your image. Tip >>> Photoshop is very forgiving with such floaters, 
by the way. It is the biggest downfall of day to day work in programs such as PixelPaint that 
even just a single click will commit the floater and even operations such as zoom window or 
scroll will become the one and only undo-able operation, effectively pasting it. You can do all 
kinds of things in PS and still have your floating selection. Even after a paste, the Undo is 
going to lift it back up, restore the underneath and marquee-select it for you. Again, beauty 
lives in the details like that!
c) More subtle and often overlooked: option+command and then drag will relocate the 
marquee itself, not the selected region! This can be very very useful! Tip >>> say you want 
to capture a circle but don’t know the center point. Simply click and drag your best guess, use 
the option key to be in ‘from center’ mode and the shift key to force true circles. Let go 
whenever you get the proper size circle, even if it is displaced a bit. Usually you get it within 
3-4 pixels. Now, go inside until the cursor changes to the right arrow, depress the option and 
shift key and then use the arrow keys to nudge the circular marquee one pixel at a time up or 
down. You can steer the thing like a little car until it is in the proper place. Easy as pie. TRY 
IT! 
In our case, fig. 14, the techniques are applied as follows: click inside the little trapezoidal 
‘clean edge’ region until you get the right arrow. Press the option key and click-drag-away a 
copy of the region. Bring it somewhere into the right target area (about 5 pixels up and left...)  

Tip >>> from here the easiest method is to get rid of the marching ants! Often underused 
feature : Select > Hide Edges (or Command-h) will remove the marquee, but it remains intact 
and selected. With small regions like this it is quite helpful, with regions of single pixel lines 
it becomes a life saver! I use this SOOOO often, basically with all copy paste operations, that 
I have a Quickkeys macro for command spacebar (next to x-c-v...) to get rid of the ants 
immediately....
Now simply move it around with the nudge arrow keys (also a much underused feature) you 
can deposit it exactly where you need and have instant visual feedback. In this case once you 
have it at the right spot, use the option-click-drag again to move yet another copy to the 
second corner. For the 90 degree one I simply clicked the eraser brush in the corner once. 

Tip >>> With all these types of operations (and they happen a zillion times!) use 
command-z (UNDO) all the time!  Hit  Undo  5-6 times quickly (command down 
z-z-z-z-z-z-) to get an animated before and after view. MetaTip >>> If you forget which way 
you left it, look under Edit if it says Undo or Redo. With Redo you reverted back while 
comparing...do it one more time.

Tip >>> Save, or better yet Duplicate to have incremental versions. ‘Save’ in Photoshop 
native format is the only one where “Save” subsequently works as advertised: no questions 
asked, simple update. It is also the only one where the Untitled name will be updated (should 
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work in all formats, really) Trouble is the PS format is bigger than Pict, much bigger than Gif 
and much much bigger than Jpeg. So I end up with dozens of Untitled windows littering the 
screen... Quit will cycle through all unsaved windows, but does NOT update draw them so 
you are blind ...Should bring them to the front before asking the save question... I have 
macros circumventing such hurdles.

                                       fig. 15 

There we are: Clean all around. Actually, I’d challenge you to get it any cleaner with an 
Illustrator outline, or a 2,000 dpi scan, or a resized 10 inch airbrushed version. This is as 
clean as you can get it in that space and resolution. (and if it were bigger or denser the 
technique will improve along with it...)

There are still other tools that apply to the cleanup processes.

Tip >>> An often overlooked feature of all the painting tools can be used for cleaning 
purposes as well : If you press the shift key after applying a paint tool (click and hold, then 
Shift) you can go to a second point and create a smooth straight vector movement of that tool. 
E.g. if you use the water drop blur tool, click it at point A once then press the shift key and 
click at point B it will travel in a straight line and Blur from A to B neatly. Same with the 
airbrush, brush, pencil, etc...Very very useful and much underused! MetaTip >>> with such 
operations it is important that you see exactly where you click: keep the caps lock key down 
and the cursor will change to a fine cross hair!  Again, a life saver in certain situations. PS 
rules!   Metatip #2 >>> To use the blur tool for clean-up, set its opacity to 20%-40% 
(MetaMetaTip >>> just keep the ‘2’,’3’ or ‘4’ key depressed during blurring. Often 
overlooked, works with all tools) and use both the cross hair and the shift key vector mode. 
(Would be nice if one could play back tools along any path, curves and all...) This actually is 
a very nice way to do edge spot work. the vectors can be kept short for curves and you can 
nicely go back and forth between two point while the shift key is down to apply more 
blurring as needed. You could never get it as smooth as the algorithmic method, but 
combining the two gets you through almost any situation...
You often can get a little subversive and just use outright trickery. In the above example you 
could define a clean white triangle and just paste that in place. Or use a  longer stretch of the 
clean edge,and simply copy drag it up and nudge it until the top edge is in line...as shown 
here:

                                       fig. 16 a)

 

Kai's Power Tips Page  31 Thu, Dec 7, 1995



                                       fig. 16 b)     

Tip >>> If a circle or other curved edge needs repair, look for a similar edge anywhere else 
in the image, even if it needs rotation to fit. You’d be surprized how well that works. With 
just 40-60 degrees of a circle you can create the whole thing with reflections (Image > Flip) 
and rotations.
For full color images, and ‘non-edge’ type clean up, e.g. a face scan with smudges or poor 
color, other techniques come into play. The rubber stamp, for instance may be the very best 
method for many area repairs. Level, Adjust, Balance controls for color, etc. More than 
enough material for another document.

Read the Adobe manual and the Photoshop handbook by David Biedny and Bert Monroy. 
These tips are often complimentary to basic techniques described there.

The sample images, “Turbulence” and “Yes logo” originated from the proverbial faxes from 
England, the file “Ambigram” was derived from a scan of Scott Kim’s dedication in my copy 
of ‘Inversions’. All of them had some of the techniques applied. (Note that small versions 
with lossy compression were uploaded. They still look much nicer in their original form...)    
Hope you get to use some of this successfully.

PS:
You could add a note in here if you have results to share with others. Fill out the feedback 
form in this library. Please let Compuserve and Adobe know if you find these tips useful.
Happy Photoshopping,     Kai Krause
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Photoshop : Kai’s Power Tips & Tricks 
One Minute Quickies :
Have a Ball... Instant Spheres

Why?  
Cause one needs spheres, damn it, and the teeming millions want to know how...
The basic technique is ultra simple. But there are a few tricks worth noting.  

How?
The spheres can be generated at any size, exact numbers are only examples provided for 
repeatable results. 

1) Go to File > “New” and create a 400x300y window, grayscale, 72 dpi.
2) Select the Ellipse Marquee, click and drag from the center of the window to create a circle, 
in our example 200w 200h.

TIP >>> The Shift key will change the marquee to be a true circle and the Option key forces 
it to be centered on the initial click point. Often overlooked is the fact that these keys can be 
combined and operate DURING the dragging (In many other programs such modifiers have 
to be pressed first or not be functional at all)

TIP >>> Use Window > Show Info to see the initial pixel location (i.e. find 200x 150y 
exactly) as well as current cursor position and, while dragging, the width and height of the 
ellipse/circle
 

3) Since the sphere needs a white highlight fading off to darker shadows we need to invert the 
fore and background colors. Use Windows > Show Palette. The pop-up says Fore 
(ground..) : select white from one of the small color samples, or drag the RGB sliders to 255. 
Set the pop-up to Back and select a Black background.

TIP >>> The usual way to set the foreground color is with the eyedropper. Double clicking 
on it will reset the fore and background to b&w. Use the option key while sampling with the 
eyedropper to set the background: if you had even a few black pixels you could reverse the 
colors above with two clicks and without the palette window.  Also: Remember the 
Preferences setting for Eyedropper sampling
TIP TIP >>> Often overlooked is the fact that the eyedropper works across MULTIPLE 
windows! You can get a color from any other window in the background without making that 
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window come to the front ... VERY useful. In Photoshop 2.5 you simply click on the switch 
colors icon, a double-headed arrow located in the box containing the foreground and 
background colors.

4) Double click on the Blend tool (next to the fill bucket) and click  “Type : ‘Radial’”.
5) Now for the Instant Sphere: Click the Blend tool at 150x 100y and drag to  200x 250y 
(exact numbers not critical here). (But the cicular marquee must still be selected!)
       

                          Voila: Instant Plain Sphere: 

  

Notice that the effect works much better with the highlight slightly displaced from the center. 
In this scenario the fill is really only composed of concentric circles and that is detected easily 
if the highlight is in the center.
 
Note : If this doesn’t look like a very smooth sphere to you, check if the little Apple icon in 
the upper left corner has color stripes.  It is supposed to be gray! If you have color there, you 
are still in the 16 shades of gray of the system palette and you are missing 240 additional 
ones... Go to the ‘Control Panel’ under the Apple menu and in ‘Monitors’ set it to 256 
GRAYS! Big difference...

What Else?
The sphere image is influenced by several variables: the start and end color, the position of 
the highlight (initial click) and shadow (drag-release distance), and the settings in the Blend 
tool dialog. Experiment with other positions and settings.
In order to seriously improve the subtlety of the effect to the point of an almost ray-traced 
look, in a fraction of the time, try the following technique:
1) With the basic sphere still shown and its marquee selected we will do overlay fills with the 
blend tool. The key is to use transparency settings. Do as in 5) above but vary the start- and 
end-points.
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Tip >>> To achieve the transparency you could double click on the blend tool and set 
Opacity in the dialog to, say, 33% or 22%..(I use identical digit numbers a lot, its faster). But 
much faster is to simply press the digits 1 through 9 while you operate the tool, setting 
opacity to 10% through 90% instantly. This often overlooked shortcut works for all tools to 
which transparency applies!

2) The effect of multiple overlaying blends is to soften the fill, get rid of the “concentric 
circle” quality, add realistic multiple highlights and generate spheres similar to “Radiosity” 
techniques.

3) With repeated use of the fill you may notice that the sphere’s edge may not retain a 
perfectly circular shape (exaggerated in this small sphere). The quickest and easiest method is 
to use Select > Defringe with a setting of 1-3, which will expand inside pixel color to the edge 
of the selection
 

Tip  >>> In case Defringe is greyed out (it only works on ‘floating selections’) use one of 
the arrow keys to nudge the selection by a pixel.

Tip  >>> Other Methods to clean up the edge of a selection would be a) Edit > Stroke then 
add a 1 or 2 pixel border inside, center or outside (depending on the case) or b) to use Select 
> Border at 2 or 3 and then Blur. The latter will be, well, blurred, the former can create nice 
sharp yet anti-aliased edges but only if either the background or the selection has solid colors 
or the stroke looks like a ‘border’

4) Now to add a finishing touch, here is how to add a quick shadow. First, while the finished 
sphere is still selected, copy it (command-c) to the clipboard.
5) Use the elliptical marquee and select a rough area for the shadow. Be sure to make it quite 
stretched horizontally, as the effect becomes much more unrealistic with the old “concentric 
circle” problem.
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6) Set Select > Feather to a value about half the short diameter. Make it as big as you can 
(20,30,40) until Photoshop complains. This will create a soft band inside and out of the 
selection in which effects are softened.
7) With the background still set to black all you have to do now is hit the “delete” key, voila. 
If the black part interferes with the appearance of the sphere (it might not) paste the ‘clean’ 
version back over it.

 
Tip >>> Very valuable to see the effect of Fringe, Border & other selection work is the 
Select > Hide Edges command. (Command-h as well.)  MetaTIP >>> I use it SO much in 
conjunction with Command X C and V (Cut, copy,paste) that I defined a Quick Key 
“Command-Spacebar” to be available right next to these keys and remove the selection 
marquee ‘dancing ants’ immediately ALL the time.

8) The feathered shadow depends on both the feather size and the background color. Try a 
dark grey instead of black to soften the effect. With the Hidden Edges you can repeatedly 
press the delete key and see the shadow grow and darken interactively..neat! Much better than 
trying to airbrush a freehand shadow in here!  More complex shadows are covered in a 
separate document, as is ‘cleaning up edges’.
9) Final things to try with the sphere : copy the clean sphere onto any other document and use 
the power of Edit >Paste Controls... vary the opacity, fuzzyness, etc to achieve realistic glass 
spheres.  To reflect the background onto the sphere use the spherize filter and paste a half 
opaque version. An example of that is covered in Biedny/Monroy’s PS Handbook.
10) To colorize into a solid color sphere convert to Mode > RGB, then Image > Adjust > Hue 
and Colorize.

TIP >>> You can click in the Title bar (e.g. on the word ‘Levels’) to quickly compare the 
before/after state of the Hue... settings.   This often overlooked feature is true for many 
dialogs that affect  pixel brightness, saturation, etc.. MetaTIP>>> After using the Preview 
button once the preview will not work again on 24 bit cards. Use “Option Preview” to restore 
it...

11) As with any contone grayscale images, the sphere can be affected in interesting ways with 
the Image > Map > Arbitrary... Dialog.  Interrupt the continuous greys with bands of black 
and white by drawing (in the Arbitrary dialog edit window) small lines horizontally at the top 
and bottom as shown here:
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this will create sharp bands in the sphere. Then click “Smooth” to soften the lines. 

Tip >>> you can leave the dialog and the cursor becomes the eyedropper. Click-hold on any 
part of the image and see where in the arbitrary map that grey level falls. You can locate 
specific bands that way (If you need that one special Jupiter ring...) Try this with a greyscale 
human face, too...

Season with the Spherize Filter or Pinch at -99 (Yes it does negative pinching!)  and a couple 
more blends at 10% Opaque (“1” key).   
Not bad for algorithmic painting,  using neither airbrushes nor raytracing...For a better 
example of such spheres, in color, have a look at the sample file KPT BlendoSpheroids. It 
uses these and many other techniques to be covered in future tips files. 

Read the Adobe manual and the Photoshop handbook by David Biedny and Bert Monroy. 
These tips are often complimentary to basic techniques described there.

PS:
You could add a note here if you have results to share with others. Fill out the feedback form 
in this library. Please let Compuserve and Adobe know if you find these tips useful.
Happy Photoshopping,     Kai Krause
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Photoshop : Kai’s Power Tips & Tricks 

Top Ten List:
Often Overlooked Basics

You may have read these things somewhere in the manual the first time you leafed through it, 
but for some reason it just didn’t stick. Re-acquaint yourself.  
There is no real 1 through 10 order of importance.  Nor does it build to the ultimate 
punchline...sorry Dave.

Sure, all of you know 9 of the 10.       Good, you found ONE new thing then.

#1 Magnifying Glass
With the magnifier selected, click-and-drag will marquee a rectangle. On release the current 
window will be maximized and that section shown magnified to fit. Very handy. Double click 
on the magnifier to reset to 1:1 The maximum magnification is 16:1 Notice that the Magnifier 
tool will keep the window dimensions and zoom within those boundaries, whereas the Zoom 
In/Out function under “Window” (shortcut Command”-” and Command “=“   (referred to as 
Command “-” and “+” but that implies the additional shift key, which you can skip....) will 
actually change the window dimensions as well as the zoom status.

#2 Tool Vectors
All the tools can be forced to follow straight vector paths. Click at the starting point with any 
tool or even the marquee, then hold the shift key down. Wherever you now click with the 
brush, pencil, airbrush, blur / sharpener, smudge or eraser will become the endpoint and the 
tool will follow that path. Keep the shift key down to work in ongoing vector mode. Example 
use:  create clean anti-aliased edges by letting the blur or smudge tool travel along the edge 
(use several smaller segments in curves). Set it to 33% opacity for finer control and go back 
and forth several times. After every step evaluate if its a keeper or use the UNDO 
(command-z) immediately. Use a small size and zoomed window for detail work.

#3 Hide Edges
Make it a habit to delete the “marching ants” marquee with the Hide Edges command 
(‘command-h’).      Not only can it speed up operations, it’s quite often mandatory to see the 
inside and outside area side by side. For example if you use Levels or Brightness you will be 
able to judge whether you have identical shades before and after if the edges are hidden. In 
fine detail work it is equally useful to see things as they will actually look.  E.g. pasting 
floating text into a particular position is a hell of a lot easier, faster and then gives you the 
actual final appearance if you first use command-h.  Also before you use the Paste controls I 
recommend strongly you turn off the ants. The effect of the fuzziness setting can reach to the 
edges and is much easier to judge without. Once you get into complex selection regions by 
manipulating the selection in its own channel you can get such complex marqueed regions that 
a mere redraw can take close to a second. Certainly by that time you may come to see the light 
about this command. You can check under the “Select” menu whether you have a region 

Kai's Power Tips Page  38 Thu, Dec 7, 1995



active or not. To unselect all regions use the marquee, ellipse or lasso tool and simply click 
once anywhere in the window.

#4 Nudging
You may have read somewhere that the arrow keys can move things a pixel at a time, called 
nudging. Invaluable when you work on small objects, e.g. aligning text by baseline...(If you 
keep the option key down, you will move a copy of the selection). Great for fixing small 
blotches: use the rubber stamp cloner, hold down the option key and find a good area to steal 
from and position it, then steer it like a little vehicle with the arrow keys. Very precise, no 
jitter, neat.

#5 Constrain 
When moving selections (marqueed, ellipse, lassoed...) use the Shift key to constrain the 
movement. E.g. selecting an area and moving away with the option key depressed will drag a 
copy of the area. If the Shift key is depressed the dragging is constrained to be exactly 
horizontal or vertical or at an angle of 45 degrees. In contrast to many other programs, this 
constraining action works even if the shift key is pressed AFTER the dragging is already 
underway. Example use: moving text horizontally only. Also particularly good with the blend 
tool to create gradients that are truly vertical/horizontal (one pixel difference across the length 
of the blend vector will be quite noticeable!).

#6 Across windows...
Rarely mentioned and little known is the fact that  several tools work outside the current 
window (unlike any other Mac program). The rubber stamp tool will copy one area to another 
(with a bunch of options). Press the option key (notice the cursor change) to select the source 
and then go anywhere: first click is the destination. The source can be defined in ANY open 
Photoshop window...Extremely handy, when you want to fix up an image via cloning, but 
the clean source area is complex but very small:  Marquee a rectangle around the source, use 
Edit > Define Pattern then create another image, select all, fill with pattern. Now you can 
define the rubberstamp source in there and clone around at will...
Another tool that works that way is the eye dropper. You can define the current color (and 
with the option key down the background color) in any window currently open...Utterly 
handy. You can keep another window open just for that: a quick color picker!

#7 New Window
It seems the real use of the New Window command has passed by a few people. The idea is 
to create a true clone second window (not another duplicate copy in another untitled window, 
but just another view of the very same file) and then change what is being looked at in that 
second window. Prime examples: 
a) In a very large file create a left half/right half set of windows and switch with a single click, 
rather than scrolling.  
b) Zoom one window in as much as you wish, leave the other in 1:1 true scale. Now all tools 
will be reflected instantly in both, allowing you to work in the detailed zoom mode and see 
the overall effect at the same time. Notice that you can do it either way: a large window with 
detail and a tiny overview, or a tiny local detail zoom, while you still work in the big picture 
at normal size. 
c) In the color modes, look at each channel in a separate window, E.g. one is RGB the other 
just R G or B. Or three windows with hue, saturation and brightness separately.
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Once you get in the habit of cloning new windows you find more reasons to do so.

#8 Screen Modes
The three icons at the bottom of the tool palette represent the three modes to show windows: 
normal multi window, normal single window (with grey background if its smaller than the 
screen) and full screen mode. In the last mode even the menu bar will be hidden and by using 
the Tab key the tool palette will vanish as well.  This has several advantages: it makes for 
much more impressive presentations focussing solely on the artwork itself. It also shows 
exactly how the edges of the image behave (in the Mac window mode a single black pixel 
surrounds the image. And, it is mandatory for taking screen shots with a camera (yielding 
surprisingly good results! Use a slight tele to reduce barrel and pincushion distortion, shutter 
less than 1/30th up to 2’ (best to bracket 3 or 4 exposures, better yet shoot a test roll))
Note that the single window option in the middle reduces the selective update greatly and can 
speed up work when you have many overlapping windows (as often happens on large 
monitors). Particularly with an 8 bit card all background windows have to be constantly 
updated... Notice also that the screen mode is NOT a global setting, but is remembered for 
each individual window!

#9 Cross Hair
Utterly basic: the cursor is forced to be a thin crosshair if you keep the Caps Lock key down. 
As banal as that sounds it can make a big difference when you apply detailed changes: 
particularly the rubber stamp, smudge and blur tool are sometimes obscuring the actual work 
as well as being a bit ambiguous about the hot spot and active size. Either way the crosshair is 
a much clearer target.

#10 Info Window
This little gadget is highly underrated. Make it a habit to open it early on in your session. I 
usually drag it right underneath the toolpalette ( in fact I wish it were a fly-out bottom 
extension of the tool palette. That vertical column of screen real estate is shot anyway...) It is 
very flexible and changes behavior depending on the operation currently performed: initially it 
shows X-Y position and RGB CYMK color value. If you have a selection marqueed and 
move it around, you will see the delta offset, the angle and distance as well. This is also true 
for the Line tool, making it a nice Distance Measurement utility. (Incidentally if you want to 
use it just for measurements and the Line tool does draw lines (which you could immediately 
undo of course) you should switch to the Blend tool and set opacity to 1 (minimum) and 
fore/background both to white. Then measure with abandon.) (Notice that the units in the 
Info window can be changed from pixels to inches, centimeters etc...in the 
File>Preferences>Units dialog). Just to see the exact size of a marqueed selection is useful 
enough, but you will find many other instances. For instance drawing multiple concentric 
circles is a lot easier if you note the center coordinates, using the cropping tool with the option 
key allows you to rotate with an angle readout, or judging whether to grayshades are really 
identical, (or if that white is really white...) and on and on....

I did not want to clutter the tiny tips in each KPT document every time one of these things 
comes up and so I thought it’s a reasonable idea to decouple them into a small document by 
themselves....
hardly Power Tips & Tricks, but as many of you have let me know, sometimes rediscovering 
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the most obvious ones can be very helpful, too.

PS:
You could add a note here if you have results to share with others. Fill out the feedback form 
in this library. Please let Compuserve and Adobe know if you find these tips useful. Please 
participate...

Happy Photoshopping,     Kai Krause
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Photoshop : Kai’s Power Tips & Tricks 
Filter Skelter:
Displace is nice....

Why?  
Because this thing is very powerful and complementary to all the other Distort filters. Also, it 
is the least obvious and has very little documentation.  There is a file up here which also 
appears in David Biedny’s PS Handbook and that does explain the basic ideas. I hope that the 
examples in this document show a wider range of the possibilities and entice you to modify 
and create your own...
This was at first one very large file discussing all aspects of Displace at once with examples 
from each of the six displacement maps. Unfortunately it was 500K after Stuffing. So I 
decided to split it into 6 separate archives with a small doc file plus the actual filter stuffed 
together. That way you can load them at will as you get into it. Chances are once you play 
with one you will want the others (less than a buck a piece) but its up to you. I was afraid one 
large monster would keep too many away from something quite interesting.

How?
To use the filter maps is quite trivial. To make your own is a little more involved, but not too 
hard either.
For the basics, the description in the manual is straightforward enough.

To really judge the effect of various filter settings, I made myself a “standard test grid’ file. A 
small monochrome version of it is available here. It consists of a grid, concentric circles and a 
contone face of myself.
 

                                                   fig 1) Standard test grid
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This standard test allows you to judge spatial changes in many different ways. Note that 
merely a grid is not enough, as you will see in the examples below. There are ways to 
spatially warp the image which afterwards you can readily identify by the face, but which 
would look like just so many grid lines without it.... Conversely, small aberrations, blurs, 
etc.  can be easily  detected in the grid and circles.  I do believe that the sample image in the 
Adobe manual does not work too well illustrating the effects of many filters.
I will cover unusual applications of other filters, as well as interesting settings in a future 
document. Believe me, there are numerous effects not generally known to casual users and 
some that might intrigue even the most jaded power PSer.

I guess it doesn’t  hurt to restate the obvious for a second:  Displace is a special form of 
distortion which affects each pixel of an image by a shift in position. The pixel can be made to 
move horizontally or vertically, plus or minus, and the instruction for this comes from a 
second image file, referred to as the “Displacement Map” (‘Dmap’) . For ease of illustration 
assume that both files are 200x200 pixels (as is the case with the test grid and the 
displacement maps I provide here) so each pixel in the image has a corresponding pixel in the 
Dmap. The gray value of each pixel in the Dmap can vary from 0 to 255, black to white in 8 
bits.  The rule is very simple:  Black 0 will cause maximum positive displacement, White 255 
will cause maximum negative displacement and the middle gray, 128, will be considered 
neutral, no displacement. That's the crux of it.     
 

                                               Fig 2a) Horizontal X DMap

The black pixels on the left mean “displace maximum positive X”, 
The white pixels on the right mean “displace maximum negative X”,
The neutral gray in the center means “Don’t displace at all”.
 

                                                  Fig 2b) Vertical Y DMap

The black pixels on the top mean “displace maximum positive Y”, 
The white pixels on the bottom mean “displace maximum negative Y”,
The neutral gray in the center means “Don’t displace at all”.
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                     Fig. 2c) The 2 channel DMap applied to the Standard Test Grid
              A spherize effect in the center, multiple copies through the “Wrap” option

Some notes:   
a) All are multiplied by a Scale value entered in the dialog. Special case: If the Scale is set to 
100 then the displacement is exactly the gray value in pixels: e.g. Gray at 148 is a “plus 20 
pixels” from 128...

IMPORTANT NOTE >>> Not documented is the fact that there is a switch from how one 
would intuitively expect this to work. Normally “Plus X” is to the right, “Minus X” to the 
left, right? (Who’s on first) and normally “Plus Y” is up and “Minus Y” is down, right?  Not! 
This is because the X-Y Cartesian coordinate system we all know and love dearly places the 
origin (say in a bar chart) in the lower left corner. In Photoshop the origin 0,0 is instead in the 
upper left corner, a convention that according to some stems from cursor positions in text 
starting at that location, which also led to math routines and display memories being laid out 
that way. Either way is probably equally ‘correct’ (I’ve had that discussion), but one must be 
aware of it. In this case “Maximum Positive Y” is going DOWN not up...
b) Note that the new position of each pixel really has two components, X and Y. The Dmap 
should have two channels, #1 will be interpreted as the horizontal X Dmap and channel #2 
will be the vertical Y Dmap. Additional channels are ignored.
c) If the DMap only is a single channel image, then each pixel will be applied for both X and 
Y equally. This will create mostly diagonal movements. All examples here are two channel 
Dmaps, often with careful four quadrant matching to design specific effects.
While there were a number of examples shipped with PS 2.0 most of them were meant to be 
used in the “tiled” mode. While that can create nice tiling effects, it ignores the entire other 
mode of operation for Displace: In “Stretch to fit” it is the entire image that will create the 
effect.
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Fig 3) The Displace... dialog.  

There are 6 Displacement maps available initially. You can load them as normal picture files 
and see the inner workings as shown here (only in quarter size... )
Each is a three channel file and therefore in native PS format. Channel 1 is the horizontal “X” 
displacement, Channel 2 the vertical “Y” displacement and Channel 3 shows the effect applied 
to the standard test grid, in case they are separated from the doc file.

Tip >>> such multichannel files have to be, by definition, in native Photoshop format. Be 
sure NOT to use JPEG compression, as it is not lossless and will scramble the channel 
information! I.e. A 6 channel file jpegged will not be a 6 channel file afterwards. It is likely to 
not even load at all, let alone in six channels...(Use Spit Channels, Jpeg individually, later 
Merge Channels again)

All channels beyond #2 are ignored in the filter operation. You can delete the example picture 
in Channel #3 if you feel desperate.

Note > It is important to understand that the filter works in actual pixel offsets. This means 
that the effect can vary greatly depending on the size of the initial image!  The maps are 
200x200x8, as is the sample grid. If the image to be filtered is 800x800 the filter will create 
offsets the are extending only a quarter as far!  You can use the Scale field in the Displace 
dialog to compensate for this. In most examples, the scale was set to 33 for both x and y.   To 
refresh your mind: 100 equals the ‘normal’ offset of 128 pixels. You can ‘overdrive’ that up 
to 999, though...   In other words, if the effect you see here at 200x200 should be applied to 
a 800x800 file you would have to have to use 4x the Scale number to achieve that 
(eg.133/133 instead of 33/33, or more...   season to taste)

Here is a real life example, and the actual filter is part of this archive file, so you can apply it 
to any image.

“Moebius Warp”:

                                       fig 4a)
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                                      fig 4b)

                                      fig 4c) 

This one will displace an image with curvature...Notice how it actually wraps 360 degrees 
and creates a complete circle out of the side edges!  This is also a good example of the value 
of the standard test grid. You can readily see that the center portion is spatially warped, but 
relatively intact.  

                                      fig 3d) 

Increasing the Scale to 66 / 66 will actually complete the spatial twist full circle: The black 
areas stem from the “Repeat Edge Pixel” option and would fill up with duplicate images if 
“Wrap” had been used instead.

                                       fig 3e) 
A small setting such as 9 / 9 will create more subtle curvatures and can make nice flags and 
such.
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Big Hint >>> Animation...! As you can see, the scale parameter can vary. 0/0 has no 
effect, 6/6 a slight wave all the way to anamorphic moebius wrapping. A NATURAL for 
unbelievable animation effects...simply crank the warpness from frame to frame and out-do 
the ADOs at their own game. The hardware is coming down to do this. Get ready!

Read the Adobe manual and the Photoshop handbook by David Biedny and Bert Monroy. 
These tips are often complimentary to basic techniques described there.

PS:
You could add a note here if you have results to share with others. Fill out the feedback form 
in this library. Please let Compuserve and Adobe know if you find these tips useful. Please 
participate...

Happy Photoshopping,     Kai Krause
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Photoshop : Kai’s Power Tips & Tricks : 
Displace Filter Examples
KPT Displace.Star Explosion

                                               a)

                               The horizontal offset is controlled by channel #1

The radial spokes in the displacement  map alternate shades of grey and effectively stretch the 
image in thin strips.

                                        fig 1b) 
                                  The vertical offset is controlled by channel #2

The Black spokes in the upper left quadrant pinch downwards, the white ones upwards 
forcing the image into a pinched similar radial starburst effect.

                                          fig 2) 

The combined effect at a scale setting of 33 / 33. The black areas stem from the “repeat edge 
pixel” option and may look  different with other source images. Unlike other DMaps this one 
leaves no discernible image
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                                          fig 3) 
   
Variations on the scale setting: at 3/3 a subtle little ripple effect shows the beginning of the 
distortion.

                                         fig 4)
  
At full blast 99/99 the starburst is complete, the original torn beyond recognition. Be sure to 
surround your image with a black border (Select All, Edit > Stroke.. inside 3 pixels...) to get 
this effect.

Note: The image being displaced here is 200x200 pixels. If your image is larger you have to 
increase the Scale variables accordingly. Read the main Displace document for further details.

Discover,  Displace, Describe the results in the KPT folder..... thanks,  Kai Krause

You could add a note here if you have results to share with others. Fill out the feedback form 
in this library. Please let America Online and Adobe know if you find these tips useful. Please 
participate...
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Photoshop : Kai’s Power Tips & Tricks : 
Displace Filter Examples
KPT Displace.Push from Behind

                                        fig 1a) 
                               The horizontal offset is controlled by channel #1

The whirling black hole inside will displace that entire section toward the right, while the light 
grey will squeeze the image sides toward the left, without disturbances. The left edge at 
medium grey will hardly move at all. Surrounding the center, the varying shades of grey will 
break up the image and give the appearance of torn edges...

                                       fig 1b) 
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                     ‡  The vertical offset is controlled by channel #2

The vertical component is symmetrical to the horizontal. White here is upwards motion, the 
dark on the right moves down. Areas of equal gray shade will displace pixels intact.
  

                                         fig 2)  
  
The combined effect at a scale setting of 33 / 33 gives an uncanny appearance of the center 
portion being pushed or shot from behind, including tears at the edges. Pretty neat....

 

                                         fig 3)    
Variations on the scale setting: at 3/3 the left and top shows the start of the movement...

                               fig 4)  
At 66/66 the motion is breaking up into chaotic areas.  

Be sure to surround your image with a black border (Select All, Edit > Stroke.. inside 3 
pixels...) to get this effect, otherwise the black areas will be filled with long trails of the edge 
pixels. Not necessarily bad, either.

Note: The image being displaced here is 200x200 pixels. If your image is larger you have to 
increase the Scale variables accordingly. Read the main Displace document for further details.

Discover,  Displace, Describe the results in the KPT area on America Online, Keyword 
KPT..... thanks,  Kai Krause
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Photoshop : Kai’s Power Tips & Tricks : 
Displace Filter Examples
KPT Displace.Glassy Spheroid

                                       fig 1a)    
                              The horizontal offset is controlled by channel #1

The grey outside corners will not affect the image at all, while the concentric circles will 
displace in a controlled fashion, darker to the right, lighter to the left.

                                       fig 1b) 
                              The vertical offset is controlled by channel #2

The vertical component is symmetrical to the horizontal. You can modify this with “Levels..”  
too.
  
    

                                         fig 2)  
  
The combined effect at a scale setting of 33 / 33 shows the glassy spheroid effect . In the 
Displacement map the concentric circles create an overall twirl to suggest the sphere, while the 
gray center portions leave portions of the original image, slightly warbled as if diffracted by 
glass.
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                                      fig 3 a)

                                      fig 3 b) 

 At 3/3 the circular ripple effect is beginning to be visible (In this case the test image has a 
circle accentuating the effect...)  while at 66/66 the sphere is quite complete with the center 
image still roughly indentifiable. The advantage over a simple Spherize filter is in the details, 
the typical non-linear distortions, reflections and refractions that make this potentially much 
more realistic. The way the face gets contorted, the nose bent and squashed is quite unlike the 
other filters, which are very ‘clean’.

In fact, while the straight application of this Displacement map may be somewhat harsh, it is 
very useful in supplying raw information to be combined with other general techniques. The 
Instant Sphere document found in this forum (KPT #5) combined with channel operations 
can yield even more realistic spheroid and glassy effects such as seen in fig 4) below.  I may 
include a complex example image in the future.

                                        fig 4) 

 Note: The image being displaced here is 200x200 pixels. If your image is larger you have to 
increase the Scale variables accordingly. Read the main Displace document for further details.

Discover,  Displace, Describe the results in the KPT area on America Online, Keyword 
KPT..... thanks,  Kai Krause
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Photoshop : Kai’s Power Tips & Tricks : 
Displace Filter Examples
KPT Displace.Schizophrenia

                                       fig 1a)    
                               The horizontal offset is controlled by channel #1

The white areas mean maximum horizontal movement to the left, black areas force to the 
right, effectively tearing the image apart left right...

                                       fig 1b) 
                                The vertical offset is controlled by channel #2

The Black area  on top will pinch downwards, the white area upwards squeezing in a 
diagonal bow tie as seen below:

                                       fig 2a)

Kai's Power Tips Page  54 Thu, Dec 7, 1995



                                       fig 2b)

                                       fig 2c)  

The effect is influenced greatly by the Scale settings in the Displace Dialog. With both 
horizontal and vertical set to 3 / 3  (fig 2a) the spatial distortion is minimal. The face shows 
subtle warps.  At 33/33 (fig 2b) the schizoid double image is clearly visible. At 66/66 (fig 2c) 
they have separated into two halves. Notice the emergence of a third small image in the 
center, rotated about 40 degrees ccw....

                        fig 3) 

At over 100 and with the “Wrap” option turned on, the complex spacewarp has gone to its 
extreme. The tiny center image stands on its own, next to all the edges coming together in a 
complete circle... Interesting.

Note: The image being displaced here is 200x200 pixels. If your image is larger you have to 
increase the Scale variables accordingly. Read the main Displace document for further details.

Discover,  Displace, Describe the results in the KPT area on America Online, Keyword 
KPT..... thanks,  Kai Krause
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Photoshop : Kai’s Power Tips & Tricks : 
Displace Filter Examples
KPT Displace.3-D Space Trails

                                               a)    
                              The horizontal offset is controlled by channel #1

The white trail means maximum horizontal movement to the left, black areas force to the 
right, effectively tearing the image apart following the “space trail” curve.

                                       fig 1b) 
                              The vertical offset is controlled by channel #2

The Black area  on the right will pinch downwards, the white area upwards forcing the image 
into a narrow path as seen below:

 

Kai's Power Tips Page  56 Thu, Dec 7, 1995



                         †        fig 2) 

The combined effect at a scale setting of 66 / 66. The black areas stem from the “repeat edge 
pixel” option and may look  different with other source images.

                                       fig 3 a)

                                       fig 3b)  

Variations on the scale setting: 3/3 starts the warping action and at 33/33 it is well underway. 
Interesting how the left eye and hair leave that long trail to the left, while the right half escapes 
relatively unscathed

                                         fig 4) 

At a major overdrive 133/133, the image is twisted in an endless weird path, hence ‘space 
trail’...In this example the “Wrap Around” option is used to fill in undefined areas with 
further copies of the image. Note that in the right center a small copy of the original still 
survives recognizably... strange, but intriguing.

Note: The image being displaced here is 200x200 pixels. If your image is larger you have to 
increase the Scale variables accordingly. Read the main Displace document for further details.

Discover,  Displace, Describe the results in the KPT area on America Online, Keyword 
KPT..... thanks,  Kai Krause
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Photoshop : Kai’s Power Tips & Tricks : 

#8  Arbitrary Maps
Magic other than the wand...

Why?  
The catalyst for this KPT file was a series of messages in the Photoshop discussion area on 
AOL, with people first wondering how to do it, then suggesting certain methods such as the 
wand and then me opening my loud mouth about it. To a call of ‘yeah then tell us how to do it 
if you’re so smart’.  I guess I had that coming.
So I pulled this ahead in the schedule (in fact I had started KPTs on the ‘Arbitrary Map’ and 
‘Coloring’ in different contexts). See, it pays to post questions!  (needle, needle, guilt trip...)

What?
The problem posed is rather a universal one. You import an image with specific colors, say 
an Illustrator file with X number of spot colors, or a scan of such an image printed with 
traditional means (silk screen, etc).
How can you separate the individual colors? And then of course, once they are split, visualize 
each in its own color, process them one at a time, save/print/transfer them individually, and 
finally also....put Humpty-Dumpty back together as well...?
In fact, once you know how to do this, it applies to a minor myriad of situations. To isolate a 
color or range or objects is a rather basic tool.

How?
1)   Ok, let’s start with a sample image. Here is a picture of myself in 5 spot color version. I 
will do this at first in grayscale. In fact the separation process has nothing to do with the 
colors anyway. If this had been a full color image to start with, I would suggest to duplicate 
the RGB image and convert it to grayscale first. Then we’ll separate the grayscale into 
components and later they can be used as masks to extract the actual colors out of the original 
image. There is no advantage to stay in color, in fact it just slows things down and 
complicates matters. Some Arbitrary Map functions won’t even show up in color...

                                           fig 1)  
           Kai in 5 spot colors, converted to grayscale (b&w plus 3 shades of grey )
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Note> Image > Calculate > Duplicate the image before each of the isolations! You will lose 
the “normal” during the conversion and need to start fresh each time. In this case you need 5, 
plus a spare original. I have a macro “option-d” duplicate (Quickkeys) that I just hit 5 times 
(includes the “Ok” button click)
 
2) Now the immediately obvious tool that springs to mind to isolate a shade is the Magic 
Wand. One would tend to jump right in and click on a shade to select it, as shown here:

                                          fig 2)  
                        Using the magic wand to select a region, (here the eye)

In order to do that, one would double click on the wand and in the dialog select “1” as 
tolerance and “no anti aliasing”, then a single click on the eye gets the selection ‘marching 
ants’ (in the picture, the wand was moved away a little, the click was on the eye). So far, so 
good.

Trouble is, that although one can select multiple regions (e.g. the other eye) by clicking on 
them with the Shift key depressed, it is a very time consuming manual task. If the desired 
region includes a lot of single pixels dispersed across the whole area one can use the Select 
Similar... option, but what exactly is included in the selection will have to be tried and re-tried 
with the sensitivity settings. The following technique can include a color with near 
anti-aliasing colors and do so in Real-Time:

3) Alternative Magic method: Launch   Image >  Map > Arbitrary...  which I am sure you 
have mucked around with a few times and marvelled at the instant middle late sixties type 
pop-artsy effects.   Well there is more to it than that. In fact soon you will marvel at the 
instant early nineties type usefulness.
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                                             fig 3)   The Arbitrary Map dialog

Right off the bat an important and often overlooked feature: As soon as the cursor moves out 
of the window and back onto the image, it will change to the Eyedropper tool!  In fig 3) the 
cursor is pointing to the light grey shade on the cheek. Notice the effect (and the reason to do 
this) : It points out  where exactly that shade is located in the Arbitrary Map!     Note> works 
ONLY in grayscale,  not in RGB!

To backtrack for just a second: the window has 256 pixels representing the 8 bits of grayscale 
in PS. Every Input shade of gray has a corresponding X location (white at the far left black at 
the far right) and at a correlated Y location a black pixel determines what Output shade of gray 
is mapped there (white at the bottom black at the top).
As long as the Arbitrary Map is the straight diagonal shown above, each input shade is 
identical to the output shade = nothing happens. (The “Reset” button will get you back to 
this).

4) To continue first with the eyedropper, here are the five shades in our image, selected by 
clicking on points A-E, and then the corresponding points on the map:
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fig 4)  Clicking on shades with the eyedropper and observing the corresponding point in the 
Arbitrary Map

5)  Here now comes the magic. Let’s isolate one spot color, say the light grey on the forehead 
at point “D.” We see it falls in the lower left quadrant on the map. As soon as the cursor 
enters the 256x256 rectangle in the A.Map it will change over to the pencil, allowing you to 
draw a new Y location for each X. This means a new output shade for every one of the 256 
input shades. To isolate the shade at “D” we simply turn all the other shades to white by 
drawing a solid line at the very bottom of the A.Map...
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                                   fig 5 a)  Isolating the spot color at point “D”

                                  fig 5 b) 

Just be sure that all pixels except at “D” are at the Y=0, the far bottom.  
Note: The line is exaggerated in fig 5 a), it would be single pixel thick and, even more 
important, the Mapping operation will not look as you may expect until you hit the Preview 
button!

Voila, what remains is every last little pixel of that particular shade!  And realize that it would 
do this even in a gigantic 3000 line image in near realtime (Compare that to the old wand 
method)
It is really quite brilliant...

Note:  In our example you don’t even have to come very close to the pixels at point “D.” 
Since there are only 5 colors, each occupies ca. 50 pixels on the map and you can be rather 
rough with the line at the bottom. If there are truly 256 shades in a contone grayscale image, 
each one would have an effect!

Tip >>> You could use “Posterize” = 64  or something near that, to reduce the number of 
shades in such an image.  This is recommended before other magic wand type actions as 
well. 

6) Lets do this with another spot color, the dark grey at point “B”.  We take another one of 
the 5 duplicated clean originals, enter the Image >  Map > Arbitrary... dialog and draw a line 
at the bottom everywhere except around the range of pixels at “B”. Click Preview and 
tadaaaa, isolated spot color...
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                                     fig 6 a)  Isolating the spot color at point “B”

                                     fig 6 b)  

Important additional point here. If you want to work with  color (but also in other tasks 
extracting features), what you are really trying to do here is to create a mask! You can use this 
mask in the compositing process via Image > Calculate > Composite, worthy of a whole KPT 
unto itself. The short summary would be: Where that Kai in fig 6 b) is black, use image X 
(flat red, gradient RGB, wood, noise, Lincoln, whatever....) where fig 6 b) is white, use  
image Y (green, Hue, marble, blobs, Quayle, whatever...)
Well, maybe not Quayle....   Anyway, in the Composite dialog Image X would be called 
“background” and Image Y “foreground”, fig 6 b) is the “mask” and they all have to be the 
same size...Read KPT #1 and #2

If the object of the isolation is to create a mask, then it is advantageous that the mask be solid 
black, other wise a translucency factor will creep into the compositing. That can be used 
purposely with great effect, but for normal flat collage type composites, keep it solid.

7)  You could turn a mask such as fig 5 b) or fig 6 b) into black and white via the 
Levels...dialog, or even just simply with the command -e Equalize command, but while you 
are in the actual isolation process you are only one step away from accomplishing this 
quickly: In the example of fig 5) the grayshade is at height “d” corresponding to the light 
grey. After you turned everything else to white at the bottom, simply turn the “D” region to 
black by drawing a short line at the very top=black....takes 2 secs....
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                                     fig 7)  
           Remapping the isolated spot to become black, perfect for use in masks

Note: To turn an image like this into black and white you should not use the Brightness dialog 
where shades constantly interact. Get more familiar with Levels...it is much more precise and 
a true superset of Brightness. Certainly don’t convert to “bitmap” as I have seen people do, 
merely to get b&w...

8)  Some more notes on the Arbitrary Maps included in this archive:

As part of this archive you will find a folder full of Arb.Map files loadable in the Arbitrary 
Dialog. Note that while the names reflect approximate mnemonics in images with continuous 
tone, the effect will vary a great deal depending on the image to which you apply them... It 
ought to give you at least an interesting variety of starting points to experiment.  
Included is among others the “z” banding map mentioned in the Instant Sphere document.  
(the gradient spheres are good source images...)

Tip >>>  As with most “preview” commands in Photoshop, the realtime nature of the dialog 
will seem to be lost (especially on 24 bit cards) after the first application of Preview. This can 
be restored simply by an Option-key depressed Preview...

In color images, the Arbitrary Dialog will load and save only the Master map, not each R,G,B 
map. The eyedropper lookup feature cannot be applied as each falls to varying degrees into 
the 3 planes. It is interesting, though, to load a map such as the Hard Zebra, which creates 
sharp bands and then successively use the Smooth button and Preview each iteration.
In fact this is a very intriguing way to colorize monochrome images, by converting them to 
RGB and then loading these Arb.Maps, plus modifying the individual R,G,B maps by hand. 
Use Smooth to keep continuous tones and non pixellated transitions. (I wish Smooth weren’t 
quite so high-q to have more steps)

Another short abstract of a more complex topic: (while we have these in front of us)
To colorize each layer into the actual spot colors you can take the mono versions above and 
convert each to Mode > RGB Color

Note:  On 8 bit systems this yields dithering with full 24 bit integrity inside. Still, the 
dithering may make this a bit tricky, visually. You can convert to Mode > Indexed Color, 8 
bit Clut images, but none of the filters and smooth edge tools will work after that...Best to 
stay in 24 bits, even save it that way, and get the best preview at the end in a final conversion 
from RGB to Indexed Color...) I recommend a 24 bit card as one of the first things to 
upgrade to. 

Then you go to Image > Adjust > Hue and select the “Colorize” checkbox. Now the sliders 
will change hue, saturation and lightness in realtime (Version 2.0! this has changed a great 
deal between versions! In fact the hue calculation is much faster in 1.x, but 2.0 offers more 
control by adding the lightness as well as individual color control for R,G,B,C,Y,M...and 
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you can eyedrop a spot color. This is another full KPT  though...)
Anyway, it’s a fast way to see each layer in its true color. To match the exact value, simply 
open the Show Info windoid and via the eyedropper read the values of the original color 
image (Tip reminder: you can have both windows open and the eyedropper gets colors from 
the second window without selecting it!) and then in either Adjust > Levels..., or Color 
Balance match the numbers. 
I recommend this highly over using fill bucket type operations!!

I know half of this makes very little sense while reading diagonally short story style...If you 
are in the middle of doing this, it will suddenly pop to life as actual meaningful sentences. 
Albeit still a bad novella.

Here are all five spot colors isolated into separate documents, with the original for 
comparison.  The value of this technique increases with more colors and sidebands. e.g. 
when a 5 color picture is scanned or other wise anti-aliased. If you really only have totally flat 
shades, you can use Select Similar and then Save Selection into other channels. 
 
 

    

                      fig 9) the original and 5 spot color components after isolation.
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I guess to put this all back together, in color, i0r document. Anyone who has problems 
with any of this, send me a note...
You might also find interesting variations on the technique or weird hidden option command 
tab secrets. Post ‘em...

PS:
You could add a note to the foldersin the KPT area on America Online (Keyword KPT) if you 
have results to share with others. 
There is also a less-than-a-minute-download feedback textfile I’d like to get back for further 
statistics and just to find out what you do, where and how and why and with whom.  And so 
far tons of you have downloaded it but not sent it back-You know who you are! 
Shame, shame. Now what if everybody did that!  

Please let America Online and Adobe know if you find these tips useful.
To me, they are utterly useless. I knew this before I started typing....lol

Happy Photoshopping,     Kai Krause
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Photoshop : Kai’s Power Tips & Tricks : 
#9  Undiscovered Heroes:
Polarizing...?

Why?  
Because probably everybody played with each filter at least once or twice and, when it didn’t 
spit out the instant “Mona Lisa” right away, filed it under “yeah, yeah,...next?”.     Bad 
move.

The one little gem I’d like to help to some broader appreciation here is the Polar Coordinate 
converter. Did you have any idea what the hell Polar is all about, and I ain’t talking about 
white bears, either...?
Before you scroll down any further, look at fig 1) and try to imagine quickly what would 
happen to that image if you ran it through the polarizer...
Hey, its a puzzle....  (Not easy, even...)

          fig 1)   
The source image with some text and big dots. What will happen to it in polar coordinates...?

What ?
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Well, without further ado, I present you with the results.  Surprised? Amazed? Befuddled?

                      fig 2) 
What-the-hell-happened-to this-thing?  “after” conversion image....

The math seems relatively obvious: there are two methods to map x-y coordinates onto a two 
dimensional plane, one Rectangular (as in the old Cartesian system) the other Polar  (as you 
may have seen in Filter Response Plots and other time, seasonal or engineering charts).     In 
3-D space, thats analogous to a ‘Cube’ versus a ‘Sphere’, if that helps you to visualize it.

The filter allows you to convert in either direction, here we obviously took the rectangular and 
polarized it (ej, Kai, semantically unorthodox usage of the verb ‘polarize’)     (I know, piss 
off).
 
You notice a few details: the left edge of the rectangular image become the radial line ‘at 
Noon’ and the image is then essentially swept around a 360 degree circle in a 
counterclockwise direction. The bottom of fig 1) travels around the outer edge in the resulting 
fig 2). The entire right edge in fig 1) is concentrated down to a single pixel in fig 2).

One implication is that the bottom area in fig 1) will have to cover a much larger area on the 
outer bands and is therefore stretched much further in fig 2): That will result in an increased 
visual blur, in this case the amplified anti-aliasing of the text. The distortion stretch effect can 
easily be judged by the blobby shapes that the original circles take, and note how that changes 
with distance from the center.
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Ok, after the little demonstration of the basics (read the description of this in the other PS 
sources to compare, all 3 sentences of them....) I want to show you what all this can be used 
for in the real world...and it can do lovely things!

How?
The whole point here is to start ‘thinking polar’ : conjure up something that might be 
interesting and / or useful when swept around a circle.  It’s not hard, take this little example:

        fig 3)  
The original rectangular coordinate system ‘normal’ logo of a company with a loopy name.

This image was placed in the center portion of a 300x300 grayscale window.  Important, 
because if the window were snug around this rectangle....well, try it.
Hit that Filter > Distort > Polar Coordinates... and behold the rotational excellence.

                             fig 4)  The converted logo. Still loopy, but round!

Sure, the arrow is bent a little, but you can clean that up. Of course you could have gone into 
Freehand or Illustrator and create curved path text and import the EPS, but this is a much 
more general method. It will work with anything! And do so rather quickly...
Ok now lets go the other way....
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                     fig 5 a)

                     fig 5 b) 

Here we have the original image in ‘pretend’ polar form which we convert ‘back’ to 
rectangular..whooooaaa
Aside from being a cool way to visualize the math it can make for very interesting effects. 
Can you see it already?

Now are you ready for some magic? Double Polarization into Infinity (not the car)
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                      fig 6 a)

                     fig 6 b) 
Fig 5 b) which was over-rectangularized, flipped up becomes 6 a) which then polarized 
becomes 6 b) 
We don’t call our company  Curved Space for nothing!

                          fig 7) 
If you take the plain 5 a) and directly polarize it here are the circularific results...

This is a really cool technique to come up with textures that are REALLY different...
You may have gotten the hang of it by now. The two directions of the filter are becoming 
predictable and thereby repeatable tools rather than random effects.  For instance, it is now 
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perfectly straghtforward to deduce what would happen to a texture such as the old Instant 
Brushed Aluminum. 
If you start with vertical stripes, look at the far left edge and place that in the center-to-top 
‘noon’ position, then as the image scans to the right you sweep around counterclockwise. It 
is not THAT hard to see that you will create a radial pattern, which in this case gets 
‘modulated’ by the randomized variations. This also inherits features similar to the Zoom 
Blur...a lot faster though.
Lets see this in action:

                       fig 7 a)

 

                      fig 7 b)  
The texture generated via the KPT #3 Brushed Aluminum and its derivative polarized version

And further on, if the stripes are horizontal to begin with, the sweep will generate concentric 
circles...
Tip > for best results pre-blur the lines a little since the polarizing itself is not going to be 
anti-aliased.
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Also notice in fig 8) how the gradation from top to bottom will be turned into a circular 
gradient. It is just like turning the blend tool from linear to radial! (Think about that...neat 
possibilities)

                      fig 8 a)

                     fig 8 b)  
Horizontal lines turn into concentric circles....vertical wash into radial gradient...

You can now literally ‘design’ the results to match. the number of concentric circles, size, 
color....
and if the stripes are vertical with a wash that would look like this variation:
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                                    fig 9 a)

                                   fig 9 b)  
Thin white stripes on a wash result in white ‘rays’ from a point lightsource

The number of variables are surprising and the effect can catch you unexpectedly, too.. Here 
in fig 10) we merely turn the stripes sideways, not much more than fig 8a) at 45 
degrees....but who expected this:

Instant spirals...?

You can tell how many alternates are looming here again. Notice how the gradient that went 
diagonally from the upper left turns into that nice sweep blend... Would you know ANY 
other way to create that?

                    fig 10 a)
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                    fig 10 b)  

Fig 10 b) also shows the error associated with the conversion: in the polar definition the outer 
edges touch on undefined infinities, since all of 10 a) is essentially represented in the inside 
circular area in 10 b)  The square edges are kind of just wrapping around.

A quick conversion and immediate back conversion will show you that Photoshop is doing a 
very good job handling this, but there are mathematical limits and the re-converted image will 
suffer distortions. 
You can also try this with other complementary filters, such as Spherize and Pinch...(both of 
which accept negative numbers as well)
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One last sample of further subtletiesêertically flipped 10 b) further polarized becomes 11 
b), kind of round isobar lines or stress analysis patterns.

                                      fig 11 a)

                                     fig 11 b)    
                     From straight spiral arms to wildly meandering round moires

I think this little filter is quite a gem, and rather undiscovered from what I can see.  I have by 
no means come near exhausting the surprises here, I mostly tried to encircle somewhat 
methodically what the general idea space consists of and how to describe the effects in ways 
that allow you repeatable ‘tool’ results.

PS:
If you have some variation that pushes this envelope, great!  By all means keep it to yourself 
and don’t tell anyone.  Especially don’t post a note in the KPT forum on AOL because others 
will find out quickly and might have other ‘friendly exchanges’ with you. You don’t need 
that! You already have every possible file and know all there is.  And a pat on the back has 
never been good for your fragile psyche.

Please let Compuserve and Adobe know if you find these tips awful.

Happy Photoshopping,     Kai Krause
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Photoshop : Kai’s Power Tips & Tricks : 
#10 Litter Removal:
Moiré, a scanner’s pesky little companion

Why?  
(Dana Carvey Bush voice >)  “Because is baaad, it’s baaaaaaad....”
Seriously, no matter how good you are, these things are bound to happen with any color 
scanner. If it hasn’t happened to you yet, watch out and read on, because otherwise Murphy 
will make sure that it will occur in a really  important image at the worst time possible.

What?
The term “Moiré” refers to a phenomenon that occurs when two patterns overlap or blend and 
then create a third ‘Interference’ effect. Most often this is not intentional and can only be 
described as an artifact or ‘error’. 

                                          fig 1a)

                                         fig 1 b) 
                            Two patterns at an angle to each other can create.......

                                          fig 2a)
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                                          fig 2b)
 
                                       ...the dreaded Moiré interference.

There are two basic categories: Subtractive, where all areas shared by both patterns ‘cancel’ 
each other out (fig 2a) or Additive, where commonalities amplify each other (fig 2b).
Either way, the new Moiré interference is clearly visible in both versions.

Tip >>> You can of course use this in creative and constructive ways. In the above example 
1b) is merely a rotated copy of 1a) and you can achieve 2a) by using Image > Calculate > 
Difference of 1a) & 1b) followed by Image > Map > Invert.  To get 2b) use Image > 
Calculate > Multiply 1a) & 1 b).

There are several instances where this can happen to you with a scanner: either the image 
contains repeating patterned features, or is itself printed in a raster. Either way that can clash 
with the intrinsic raster which the scan process imposes by its nature: using a linear array of 
sensors traveling in lines across the image.

As a very basic suggestion: it should become obvious at this point that the orientation of the 
image on the scanner is one variable that can make a big difference and happens to be easily 
controllable. The scanner makes exact horizontal scans analogous to fig 1a) and if the image 
lies at an angle as in 1 b) then you are inviting the artifacts of fig 2) to rear their ugly little 
heads.

Unfortunately it isn’t as easy as rotating the artwork to that ‘magic angle’ and be done with it, 
since almost every angle will create a new set of moirés, one more interesting or annoying 
than the next. It can be a simple method to eliminate certain local irritants though and is a 
good first option. 

Tip >>> If you find a setting that works for a subset, e.g. for the top but not the bottom, 
consider saving two or more angled scans and open them simultaneously in Photoshop to 
composite the best case. Since this involves rotation to align the parts, its not suggested for 
the novice or casual user.

Note that we are not talking about merely “getting it really straight on the scanner” as the 
simplistic samples seem to imply. This can still happen even with 100% straight art, since 
there is a beating effect with the print raster, which itself has multiple angles in it...

Tip >>> The major source of Moirés is the print raster and it is therefore vastly superior to 
use continuous tone photographs rather than a printed copy!  Always try wherever possible to 
obtain such a contone version and resort to scanning prints only where no alternative exists. 
This goes double, (no, make that RGB triple!)  for color prints.
In fact, the majority of the troubles stem from such color print scans and the majority of this 
doc file is concerned with getting rid of the color moirés that result.
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Some other basics: It seems fairly self-evident that the artifacts are linked to the frequency of 
the raster. What that means in practical terms is: scan with the highest resolution you can 
afford!  A very typical mistake is to back into the scanner settings to match a final size 
objective; e.g. you are trying to create a screen size picture, such as a startup screen, a 
slideshow title, or a logo. Scanning at 72 dpi 640x460  may work just fine sometimes, but in 
tricky situations you should oversample as much as you can.  “Afford” means time, memory 
and disk space, not $$$ in this case.  If you go up to 300dpi or even 600dpi you tend to get a 
rather large file very quickly, 20Megs or even 200 Megs are quite possible.  You may have 
neither the space nor the time to do this a lot, but go as high as you can.

The point is that with the finer resolution the artifacts get smaller as well, and it is a lot easier 
to deal with them and then reduce to size in Photoshop. The other point is one of plain math: 
“if it ain’t in there, you can’t create it”, meaning if information is lost you can’t forge it out of 
thin air. With the high res scan you have much more information and algorithmically sizing it 
down will at least create the proper averaging of neighboring pixels. I could illustrate this 
with many examples, but it seems rather obvious.

There are several other tools you should have in your arsenal, but they tend to get overused in 
this context:  Gaussian Blur and Unsharp Masking.  Their legitimate place is to punch up the 
overall sharpness and reduce fine jitter and speckles, they are however no panacea for 
Moirés!   

Tip >>> Use Gaussian Blur first and while you are still in the highest possible 
size/resolution.  Consider that you can use fractional values, in fact I often find 1 to be too 
little but 2 to be already a bit much (in this context), so I would start with 1.5 or thereabouts.  
MetaTip >>> Select a small marqueed rectangle in a particular area of interest. It is first of all 
much faster to do this in a small area and you can readily judge the difference between before 
and after. Affecting the full screen image with a filter requires that you do the comparison 
against your memory of the before, which can be deceiving. In order to see subtle changes, 
use command ‘h’ “Hide Edges” to get rid of the marching ants.   Another way to do this is to 
use command ‘c’, command ‘n’, return key, command ‘v’,(easy macro candidate)  which 
will copy the selection, make a new window in the correct size, say ok to the dimensions and 
paste the chunk into it.  The advantage is that you can drag the new window over the old for 
comparison and can do any number of operations without worrying over the fact that you can 
only undo one step at a time. I even add another ‘duplicate’ to that in order to work on a copy 
of the area, in order to try again and again.  This is not unlike ‘bracketing’ in Photography 
where you try to under- and overshoot  the right setting.

Tip >>> In something like Gaussian Blur use a deliberately conservative number, erring on 
the small side. Then use command “f” to repeat the last filter operation as often as necessary.   
Caveat : the UNDO command “z” will only revert the last of these applications of the filter!   
MetaTip >>> adding the option key, as in ‘option - command - “f”’ will recall the last filter 
dialog quickly.

If you have done the slight blurring to average minute jitter and other unwanted details, you 
can use Unsharpen Mask to regain the overall sharpness.  If you had done this on a larger 
size than final, consider that the convolution of the Image > Resize operation will have a 
sharpening effect as well, in other words, it is ok that the large image is just a touch blurry. In 
fact I recommend it before any downsizing.
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Of all the Sharpen filters definitely use the Unsharp Mask. It is really a combination edge 
detect / enhance algorithm that will affect flat areas less than edge transitions and can create 
good contrast sharpness without the aliasing artifacts of the other Sharpen options.  Again, 
set it conservatively small and repeat the application with command-’f’.
Other filters such as Despeckle and Median,  Custom Kernels, and others can be applied as 
well. Trouble is that they don’t have any control over the amount and can be rather 
devastating to small details. Watch out for such loss of minutiae! While you are successfully 
eliminating spots in the foreground a small person in the distance may lose both eyes  in the 
process...(see, your mom was right: “be careful you can poke someone’s eye out with that!”)

Another simple method for local cleanups is the rubber stamp cloning brush.  It  can work 
wonders to eliminate specks of dust, scratches, etc...  In case you haven’t figured it out, 
option-click with it on the source and then click to copy that to a destination.

Tips >>> Keep the caps lock key down for the cross hair cursor. Double click on the tool 
and in the dialog set it to smaller size, maybe even at less opacity. Use the option key click 
method to ‘travel’ along straight lines. Get familiar with the options: ‘darken’ ‘lighten’ and 
‘color only’ can make fix ups easier once you know what they do.

All in all, a very basic concept should enter into the discussion here: it is rare that any one of 
these things would work perfectly applied to the image as a whole! Kind of like using a carpet 
spot remover on the entire carpet all the time...   It is highly recommended that you identify 
and isolate particular problem areas and deal with each in its own way!  This might simply 
mean different amounts of the same technique or wholly different methods.  Use the lasso to 
select such areas. Tip >>> with the option key down the lasso works in rubberband mode, 
much easier to control and generating fewer vertices (corner points).  MetaTip >>> You can 
then also use Selection > Make Path to convert the lassoed area to editable bezier control 
points, edit them and convert back to a selection. Coolness!

All the above basics are worth knowing, the trick of course is getting the experience when to 
apply which one...  Still, the dreaded archnemesis Moiréarty will hardly wince at these 
attempts.  It has nothing to do with sharpness, blurriness, resample sizes, and will resist 
manual cloning methods with ease. Quite elusive that little bugger...
What follows is a particular method to attack the kinds of moirés most prevalent with flatbed 
scans of printed source material:  color artifacts, raster beats, interference patterns....             
A real life case:
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fig 3a) a small section of a scanned image with serious Moirés before...

fig 3b) ... and clean after the process...

Note >>> On an 8 bit card this may look a little dithered to you.  The system palette is not 
very well suited for the colors in this image.
The real example used here was scanned from a small postcard at 600 dpi. Shown is about 
20% of the whole picture with a particularly prominent Moiré problem.  I have at times tried 
the Microtek, Umax, Epson and Howtek, all of which would exhibit such behavior to some 
degree. 

At this point it behooves me to tell you that reading the KPT #8 on Arbitrary Maps would 
help in understanding the method, as it involves the same dialog and I may not re-explain the 
basics of it here. So if the following is obtuse, give that a shot.

As a test, I isolated the small center portion of 3a) and copied it into a new window. Then I 
invoked the Image > Map > Arbitrary... dialog. As soon as the cursor leaves the dialog 
window, it turns into the “eye dropper” (As opposed to selecting from the toolpalette!). The 
idea is that it where the eyedropper is positioned in the image, the corresponding point on the 
Arbitrary Map will be circled.
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Note >>> The key to eliminating the color bands is NOT doing it for all three channels 
RGB at the same time. In our case we want to focus on the red channel (Check the ‘red’ box 
in the ArbMap dialog), but you may want/need to do it in more than one channel. But do it 
one by one in each, not in the master, since the settings will be different for each.

As one moves the eyedropper across the moiré bands, the encircled spot on the ArbMap will 
flicker back and forth in a certain range. THAT IS THE ESSENTIAL STEP! 

                                              fig 4)    
                                              moving across the bands....

               fig 5) 
      ...flickers points in a narrow range of the ArbMap. (Red channel selected)

If  you can find these transitions in your moiré problem and they can be confined color by 
color to a certain range, you are almost home free...  All that needs to be done now is to 
exploit an intrinsic feature of the ArbMap. (Again, for a discussion of the basic theory read 
KPT #8 first) 

Each particular Y value represents an assigned output level, i.e. intensity. If you want to 
assign the SAME value to several different input levels, in other words if you want to force 
the Moiré bands to be the same color as the background, all you need to do is draw a 
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horizontal line for each of the shades!  And in true photoshop style the re-mapping will 
happen in realtime in front of your eyes! Amazing....

               fig 6) 
               Assigning the same Y value = intensity to bands eliminating Moirés

Note that this works very, very well and is a procedure of surgical precision. It affects only a 
very narrow range of the total colors (in this case 90% of the red channel is unaffected, and 
green and blue are completely unscathed....) so that for instance it will clean up the moiré sky 
instantly while leaving the white  stars entirely unaffected!   Lesser inspired methods would 
have you mess around with the red channel in Levels... or other Image > Adjust tools, which 
would have upset the balance easily (cyan or pink stars for instance). You need to try this 
with a real life case (the above sample is provided in this archive) to appreciate both the 
power, speed and subtlety of the process.
 
It may seem simple, even downright obvious in hindsight. Let that not deter you from trying 
it. The same was said for “the wheel”, you know...

Note >>> if your problem was ‘magenta’ stripes you may need to do it in both the red and 
blue ArbMap channel, (similarly     cyan = green &blue     yellow = red&green.) 

Tip >>> as always, keep the option key depressed and just click the start and end point 
instead of drawing every pixel in between. Oddly, the shift key vertical constrain does not 
work here.
Although usually a very narrow fraction of the colors are involved, it may still be safer to 
isolate areas via selections and process them one at a time. In this particular case a loose lasso 
of the sky area worked very well indeed.

As a neat side benefit, you get to control not only that the bands are all assigned to the SAME 
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shade, but also WHICH shade that is. So in realtime you can try out several colors. More to 
the point you can use the eyedropper to find any other spot in the image that you would like to 
match, note the Y value for that spot in the ArbMap and simply assign it to the Moiré range. 
Voilâ....

               fig 7) 
                                       varying levels determine the color....

Also if there are certain points that just don’t want to cooperate, use the eyedropper to query 
where on the ArbMap they live (again, one channel at a time) and wipe ‘em out...

Note that you can use “Smooth” to soften the harsh transitions you are creating, or “Reset” to 
start over and try again. The curve gets remembered for each of the 4 options Master, R,G 
and B separately!

If there are gradient color ranges involved, you may also apply the cousin of the ArbMap, 
Image > Adjust > Curves. It would be hard to impossible in the Curves dialog to eliminate 
specific ranges, but it excels in compensating in nonlinear forms, e.g. curves, which is 
correspondingly tricky to do in the ArbMap.

This does not exhaust the topic of scanning, but it ought to get you a little further anyway...

Please let America Online and Adobe know if you find these tips addicting....

Happy Photoshopping,     Kai Krause        
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Photoshop : Kai’s Power Tips & Tricks : 
 #11 One Minute Quickies:
10,000 Volts in 3 steps

Why?  
Tesla and Van der Graaf made me do it. Just thought you might enjoy some more quickies...

What?
This one’s a doosie.  Ever so easy.
1. Get something on the screen. Anything. I put some letters into the middle of a small 
window...

 

                         Fig 1)  some type on the screen, or anything else, really...

2. Now do this: make a copy  (Image > Calculate > Duplicate, click ok) (Tip >>> you may 
start to do this duplicating bit a lot, that’s an excellent candidate for a Quickkeys macro. 
Include the “Ok” in it so you get a copy with a single keystroke. Mine is ‘command-d’) and in 
the new window use Filter > Blur > Gaussian Blur. Set it to something quite high, in this 
example I used 33...
 

                               Fig 2) Blurring the sh*t out of the type....

3. Next up: Use Filter > Stylize > Find Edges and watch what happens.   Not a whole lot.   
What gives?
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                   Fig 3) The seemingly less than exciting results of Find Edges....

4. Now for the coup-de-ville: Hit command-’e’  (that's the shortcut for Image > Map > 
Equalize)
 

                                     Fig 4) Voilá:  Instant Electric Aura! 

How?
Well, to get into the theory behind this: it all revolves around “Find Edges”. This filter marks 
significant transitions in each channel (here only one, gray) with higher intensity, resulting in 
bright edges against a dark background. In color images this happens for R,G and B 
separately, leading to sometimes very messy, though interesting, results.  In our case here, 
we are giving the Find Edges filter a tricky problem: there are hardly any edge transitions left 
after the deep Gaussian Blur and so it does the best it can in the narrow range of transitions. 
This is why figure 3) is almost solid black.

But, beneath the shimmery dark lurks something very fascinating: in a very compressed 
section of the  grayscale are transitions and it is the aliasing mathematical error between them 
that we are seeing here. Kind of the reverse of the De-Moire document, this one generates 
great controlled Moire interferences.
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Instead of invoking the quick Image > Map > Equalize command we can observe better 
what’s going on if after Step 3 we go into Image > Adjust  > Levels...
 

Fig 5) Levels... histogram after Fig 3) shows the extreme compression after the Find Edges 
filter
Move the White Triangle to the left...all the way to the beginning of the Histogram spikes

As you are moving the white triangle you are brightening the image by redefining which gray 
shades emerge as white. Note that the center grey triangle moves right along, centered 
between black and white point. (You can click and drag it as well, though.)

This happens to make a very good demonstration of what “Equalize” really does: You see the 
histogram spikes: Equalize automatically puts the black point (black triangle) to the leftmost 
(darkest) shade and the white point (white triangle) to the rightmost (lightest) shade, 
spreading the dark to light range of shades in an image to go from full black to full white. 

It is still recommended to use ‘Levels...’ rather than just ‘Equalize’ in this case, because there 
are many other settings that might be of interest here... Just try it! You will be amazed at all 
the weird things that happen within half an inch of mouse travel...
Example of further Aura Play
 

Fig 6) a few slight 30% blend gradations across and the technique yields 10,001 volts...
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Fig 7) and just to get myself in trouble, this is what it looks like colorized...
(Teeming Millions : “Where is that stupid Colorization KPT!”) 
(Steaming Millionaire: “yeah yeah, nag, nag. It’s free ain’t it!”)

In the last one, Fig 7), I superimposed the clean text at 30% opacity over the aura image. In 
fact that is the only reason I had you do the duplication step in the very beginning, to keep a 
clean copy around, because obviously this technique destroys the initial picture in the 
process... I recommend you keep making duplicates and muck around with them, rather than 
with the ‘clean’ one.

Don’t mistake this for something ‘to do with text’ or ‘for four letter words beginning with 
“A”...’ (There is such rampant literalism out there, you know who you are). This works with 
ANYTHING. Take a color image of a face. Copy: Blur, Find Edges, Equalize. Then Blend 
with original, or other Chops between multiple versions. Do it 50 times. Throw away the 
ugly 49. You are then beholding : Coolness.

Please let AOL, Compuserve, Adobe, MacWeek, MacUser and MacWorld know if you find 
these tips adrenalinesque. 

Happy Photoshopping,     Kai  Krause        
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Photoshop : Kai’s Power Tips & Tricks : 
#12  Colorization
This is for Ted Turner..........NOT

Why?  
Life is short and then you dye.  And, because you have been bugging me about this for 3 
months now.

What?
Color is a major ingredient in Photoshop. No doubt. No wonder.   
Unless you’re stuck in some 60s Pop-art phase, you will want to meddle with hues. As it 
happens, PS has an amazing array of very powerful methods to deal with color, many of 
which may be entirely new to the mythical “casual user”, but I will also try to dish out a 
sprinkling of ideas that live up to the “Power Tips” moniker I slapped on myself.

How?
Under the guise of Colorization, lets get something gray on the screen first and then see how 
many ways there are to add hues. As a little bonus I will start this one off with an old 
technique which is really fun if you  haven’t seen it yet. And even if...   Some of you learned 
this in an impromptu chat with me in October last year, when I first explained this one. I also 
saw Russell Brown use it a few weeks ago. Credit goes actually to some guy in Berlin who 
had a molecular display system in the early seventies and published this as a short cut 
technique to draw 3-D molecules ‘real quick’. His system did this with thousands at a time 
and I remember being very impressed by the life-like 3-D look. As it happens, it is extremely 
easy to adopt in Photoshop.

1. Go to File > New and make a window 400 wide, 300 high in grayscale. Could be any size 
of course.
Very much like in the Instant Sphere document, we’re using the Blend tool now. First we 
reverse the colors: 
2. Go to Window > Show Palette, which pops up in the lower left. Default is ‘foreground’  
(“Fore” in the pop-up), set to black. Set that to white via the sliders or by picking a white 
box. 
3. Set the background (pop-up to “Back”) to black in the same manner.
4. Now double click on the Blend Tool (to the right of the Paint bucket), which launches the 
Blend Tool options dialog. Make two changes: set it to “Radial” and “Lighten Only”.
5. To erase the Untitled-1 window, double click on the Eraser and click ok: a solid black 
image.
6. The magic can begin: select the Blend tool and click on point A , then drag to B, roughly...
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                                   fig 1)
 

                                   fig 2) 
                            click-and-drag from the center to the edge of a sphere 

This is very smooth in grayscale. In fact if you see any dithering in these, try 256 grays, but 
later color examples require the color settings. 24 bits is the only way to go really. Please 
upgrade. Do it for me....

                                   fig 3)

                                   fig 4) 
Create a second sphere; so far all normal...but then the third one in between the others...
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                                   fig 5) 
                                        Instant molecular docking spheroids

Some say that it’s the cheap way to create simulated ray-traced plasticine rodent cartoony 
figures. Disney lawyers: have your machine call my machine.
The effect is very simple in operation: the edges of the third sphere overlap previously drawn 
sections and since “Lighten Only” is selected, the blend tool simply stops sphere creation at 
those edges, resulting in a striking imitation of shaded balls joining in almost sensual ways. 
So now you can go to town, playing with 3-D lego blocks and dock ‘em anyway you like. 
Here is what it looks like if you run amok for 1 minute:

                                  fig 6a)  The Boobonic Plague (1204-present) 

                                        fig 6b)  Elespherant (one tenth scale)

7. Now back to the topic, lets say you have a few of these things on the screen, in grayscale. 
Lets examine what we can do on the color front. First, simple colorization and then explain a 
few things later. This one is provided in the archive, in case you want to play along:

                                  fig 7) Pearls of Wisdom  (swine not shown)

8) Goto “Mode”, which should be checkmarked “Grayscale” now, and switch to “Indexed 
Color”. The image will look the same at first, as if nothing has happened. But it did....
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9) Now you will find that under Image > Adjust the menu items 4 and 5 are no longer greyed 
out. Choose Image > Adjust > Hue/Saturation, the last menu option.

                          fig 8)  The Image > Adjust > Hue/Saturation dialog:  

10. Click on the “Colorize” checkbox, then move the Hue slider...and voilá, instant 
colorizing action...
It will take you a little while to get the hang of how these, things are all interrelated, but once 
you know it is mega powerful stuff.  

                      fig 9a)

          

                                 fig 9b) 
                    Example settings of the sliders and the resulting color image

In the above example, all three sliders were moved to create the blue spheres. In order to 
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better explain, let me add some pictorial elements to illustrate what's what...:

                     fig 10) 
The Hue/Saturation dialog with visual help for your edification (smooth in 24 bits)

Think of the Hue slider as “WHICH Color” and the above rainbow shows where each color 
falls. (somebody running the ResEdit Power Tips section ought to add this right into the 
dialog, although one gets to remember by heart where they fall fairly quickly). As you see, it 
wakes up on red, and turquoise cyan lies at either end of the spectrum.
Think of the Saturation slider as “How MUCH Color”, with the 100% solid full color at the 
far right ‘100’ and no color at all on the far left ‘0’ setting. Notice that where you wake up at 
50 is NOT the full red available, so move that middle slider to 100, first thing.You can move 
from grayscale smoothly to full color.
Think of the Lightness slider as “How white are the highlights in the overall color range”. At 
the 100 setting everything turns totally white. At ‘0’ its all black. 

11. In the example of 9b) the spheres at first are pale red. Moving the Hue slider to -133 
selects Blue, moving the Saturation slider to 99 brings it to full saturated Blue color, but the 
highlights are fading towards white. Moving the Lightness slider to -33 adjusts that, so the 
brightest areas are now a light blue as well. 

Tip >>> as with all realtime dialogs, clicking in the title bar area acts as an Instant Compare 
with the original setting..! I couldn’t live without this feature...

Essentially these sliders try to navigate you through the 16 million possible colors in the RGB 
color space. Together with all the other color options we’ll cover soon it does a very nice job 
of accessing these shades as well.  You will need experience to find the settings to get there, 
but it can be done.  For example, to go for a pearly soft rosy tinge one would do something 
like this: 
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                 fig 11a)

                               fig 11b) 
dialog settings for the pale pearl “rosy” color, which the future is supposed to look like

You can back into this logically to an extent, for instance that you need to pull back the 
Saturation slider or else the colors are way too strong and the Hue slider has to move from 
Red towards the Pinks and Purples. 

The small movement of the Lightness slider is very essential to get the right range of colors. 
Otherwise the highlights would have been very bright white.

Tip >>> the 6 sample swatches at the bottom turn into an instant display meter in the 
“Colorize” mode. Watch them as you adjust the Lightness slider to judge very quickly 
whether the highlights are where you want them. And read hues and saturation range there as 
well. We will revisit them...
Note: the control here is quite smart: it excludes true grays completely from the action! Only 
the Lightness slider will affect them. Black and white are not part of the hue spectrum.

This is the most primitive way to go from mono to color, getting a single tone only. But 
before we advance into Powerland, a little basic info, some theory and background are called 
for. Yeah, yeah, stop whining. Sit up. Listen.           Chewing gum in line, ehhh?         I hope 
you brought enough for everybody?

12. Let’s talk about modes for a second. There are several basic modes for Photoshop to 
operate in. You can read up on the theory in the manual/book, but for practical purposes, here 
are some other viewpoints:    RGB has 3 channels with 8 bits each. Work in CYMK if you 
can, as that adds another channel just for the black parts and is more accurate for print work. 
Things do slow down, though, as you have 4 channels now.  For the most part, I work in 
RGB.  It is suggested that you pick your color space beforehand, since the conversion can 
have some surprises and artifacts popping up.

Indexed Color is another beast altogether: it is the ‘CLUT’ mode: a “Color Lookup Table”, 
which means there are only 256 colors total (8 bits) for use, that’s it.  The advantage is that if 
you have only an 8 bit card this looks great to you, and also, since there are so few colors 
involved, one can redraw the colors very quickly.   Trouble is, 256 colors ain’t enough. 
Believe me. 
 
It may sound to you like “gee I couldn’t even name 25 colors, so what do you mean ten times 
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that isn’t enough? And what is it with this 16 million color crap? I bet you can’t even see that 
many...”   Arguments of that flavor have been floating around for a long time.

Fact is, this is pure semantics. Sure you may only have names for a few colors, but when 
you look at a Navel Orange and call that color ‘orange’ you are referring to hundreds of 
shades of orange!  If you try to reduce the subtle shades down to just 256 you are beginning 
to get in trouble. And then of course 3 other shaded objects enter the scene and something’s 
got to give...

But Indexed Color mode has more problems: none of the soft edged tools will work in this 
mode, nor will any of the Calculate,  Effects or Filter operations. You are reducing 
Photoshop to almost nothing...

13. What I find is really not very well understood at all is that Photoshop works in 24 bits 
even if you have only an 8 bit card. Many people end up in Indexed Color mode merely 
because they don’t like the dithering effect that shows up immediately when converting to 
RGB, on an 8 bit card.  What happens is that internally PS will generate everything in full 24 
bits but shows a dithered 8 bit preview.   So:

What you should do if you have an 8 bit card (or using the internal 8 bit video on a IIci etc) :  

a) run, don’t walk, to upgrade to a 24 bit card. Seriously, you will never look back. You 
will, like me, curse yourself for not having done this a long time ago. I upgraded first to a full 
screen 1024x768 screen in 8 bits, then added a second 24 bit small screen, then jumped to a 
1180x870 24bit card on a 21” Trini. Every upgrade seemed like a godsend. MetaTip >>> I 
found that in high res refresh is a serious issue. After using 75 Hz on the 21” Thunder there 
is no way back to the 60Hz...Also, fixed frequency monitors (e.g. the 21” SuperMac) seem 
much less prone to flicker than MultiScans, so unless you really really need the switching..... 
(Of course, while you’re at it, go to at least 8 meg memory and more if you can to experience 
great benefits with PS., but that and other money drains are another story altogether)

b) Do most of the work while you can in grayscale. This looks equally good on an 8 bit 
system, because it’s really a CLUT with 256 greys in it. Then add color, as we will cover 
here, in  half a dozen different ways.  Now: Switch to RGB, do your stuff, disregarding that 
it looks badly dithered, and, at will, transform Mode > RGB to Mode > Indexed.  Use the 
default, Adaptive with dithering, and PS will build a histogram of your image, determine the 
most important 256 colors and then dither them for the best possible 8 bit image. Now, be 
ready to either UNDO this right away (I have one finger permanently glued to 
command’z’...) or do this with a Image > Calculate > Duplicate of the RGB file. You can 
also save the 8 bitter.. Think of it as a fairly good preview of the real effects inside. It is 
important to understand how and when to do this. 

By the way this also applies if you want to see a 24 bit file. Say you download a KPT 
example image (I just added QT pict updated new images up there, (Use the More button to 
scroll down to see them) and it comes up in 24 bits, dithered. Then Mode > Indexed Color... 
will build the best 8 bit preview for you, certainly a LOT cleaner than merely gawking at it in 
dithered mode. If you have not done it this way before, go right back and look at them again, 
fill out the feedback form all over and really mean it when you send me love letters. Or take 
back a few of the threats, whereever you fall in the range.
Ok, this may have been less than Powertippy for many of you, but remember when you 
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discovered this for the first time.....I may make an incredible difference to some of you. If 
you think you belong to that group, read it again.  

14. Onwards in the color world: I start with the gray Pearls (e.g. use File > Revert) and 
convert to Indexed Color again. Now go to Image > Adjust > Color Balance and launch the 
dialog. No need to click on Colorize or anything, this will instantly start to tint your grayscale 
image. 
Actually, there are 3 times 3 slider settings in this dialog (Oddly, no Load/Save 
here...something to consider if you need to affect multiple images) Top to bottom here are 
Highlight , Midtone and Shadow settings.

fig 12)  The Color Balance dialog unfolded into the 9 sliders it contains

15. This is the effect these settings are achieving: (again, this is VERY smooth in 24 bits and 
you can just barely make out the subtlety in 8. But I didn’t want to make everyone suffer the 
least common denominator syndrome)

                            fig 13) after applying the Pearls-to-Cherry converter

While it may look like plain red at first glance there is actually quite a variety of shades in 
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here: a dark ruby red, midtones with a crimson component, some orange in the lighter shades 
and a white highlight with blueish halo. In larger files you would be able to make this out 
more clearly, but believe me it’s there. Point is, Color Balance can essentially tear the color 
components from one another to create such subtle multi huedness. Or is it Hueidity...?

16. Some notes on this: the realtime action happens immediately, but it will affect all images 
in all windows on the screen. Use Preview to see clearly what's going on. 
Tip >>> On 24 bit cards you will notice that the realtime action seems to go away. Use 
“Option-Preview” to regain that state. (True for all dialogs with ‘Preview’)
Tip >>> There is no outright “Reset” button, as you would find in the Arbitrary Map. But 
you can use the little known “Option-Cancel” to reset everything without leaving the dialog.

It is important to understand that it is not the absolute setting of each slider, but rather the 
relationship between them that creates the effects. If you moved all three from 0,0,0 to 
99,99,99 you would literally see no difference whatsoever! Try it.

17. The tricky part here is that for exactly that reason you can’t just move each slider one by 
one and be done with it. They all influence one another. You will need some experience how 
to deal with each set of three as a group to fully use the potential in this dialog. It’s not 
particularly hard, but not trivial either. There are a large number of settings that will result in 
‘blooming’, banding and other color artifacts that are not desirable except for rare special 
effects cases.

Note also that the settings are ‘relative’ rather than absolute: if you exit the dialog with the 
‘red cherry’ setting and return you will find all nine sliders set to 0 again, waiting for you to 
set further relative offsets of the color components.

18) By the way: the dialog looks identical in CMYK mode, but since the color gamut is quite 
different the results will also change! To witness:

              fig 14)  same cherry setting in CMYK mode, more like grapes, really

19) I can’t go into color gamut theory at length (as Woody says to Diane in bed: “Not 
now...Not here”), but the two minute description: Print is using inks to achieve colors by 
addition, and that is the idea of 4 color printing with Cyan, Magenta and Yellow able to create 
the spectrum, plus a black layer for gray components and solid black. The screen on the other 
hand uses Phosphors to create the spectrum by subtractive means via Red, Green and Blue. 
There are a number of high intensity R,G,B shades that are simply not possible to create with 
ink and are not within the ‘colorspace’ or ‘gamut’ attainable by CMYK. Conversely there are 
subtle shades in the 4 color process that do not map well into RGB.
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You can see some of the dilemma if you open the Info Window, which reads out both ways, 
and moving along a smooth gradient notice how the numbers do not increment evenly.There 
are gaps...

The image in figure 14) is not an exact demonstration of CMYK, by the way, merely a caveat 
of the settings of the dialog.  Using fig 13) and converting from Mode > RGB to Mode > 
CMYK would yield a near matching image, without maybe quite the intensity. During print 
one can bring this back in the ink choices.

20) My suggestion for the above two dialogs is to use them in combination: either start by 
getting the overall contrast right, eg. fig 130 has the right 3-D sphere’ness factor, the 
highlights are snappy the blacks are deep and dark, no banding, etc. and do that without ANY 
regard for the hue itself. Concentrate only on the tonality. Then afterwards go to Image > 
Adjust  > Hue to rotate the color spectrum.

Other times you may need to do this the other way round, i.e., get the right color first, then 
adjust the balance. It is important to understand that while Color Balance can in effect change 
color, too, and Hue can change tonality, that’s more like using a screw driver to hammer a 
nail.  Know your tools!

We have covered 2 methods of direct colorizing so far. There are at least 6 more. I may need 
to chop this into pieces...? (Yeah, that’s what happened later..read on)

21) The first two dialogs covered here are simply greyed out if your initial image is in 
grayscale. The next 3 are dialogs that are available for monochrome work as well, but they 
metamorphosize to color dialogs when accessed with a color image.  My favorite one overall 
would have to be Image > Adjust > Levels..., even to the degree that I rarely use Color 
Balance any more, and certainly not Brightness/Contrast. All those can be emulated from 
within the Levels dialog and you would do well to get familiar with it.
In simple terms comparing it to Color Balance’s 9 sliders, Levels gives you 20, and a 
Load/Save option to boot! Better yet, it has on the fly histograms showing you the 
distribution in each channel! Very useful....

                fig 15 a)  Image > Adjust > Levels...with a grayscale image
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           fig 15b)                                  
....and with added switching radio buttons when accessed with an RGB color image

22) There are 5 sliders (triangle handles for each) available for each of 4 modes. This adds 
controls such as ‘tinting with an overall green component’ or ‘compressing the red range’ 
which have no counterparts in the other dialogs, yielding subtlety in color gradients and 
overall tonal range that is unique.

                                 fig 16) 
Levels...can directly create even more complex color schemes from mono sources
23) A few tips on Levels... lets look at one of the 4 modes and how the 5 sliders operate.

                               fig 17 a)

                              fig 17 b)  

                   normal grayscale image and after 5 slider adjustments in Levels...
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              fig 18) 
                                  These are the settings resulting in  fig 17b)

The sliders were moved in the “Master” mode, which is analogous to their operation in 
Grayscale, here it means affecting all three components R,G and B simultaneously. The 
action is similar in each single color.

There are 256 steps by the way, corresponding to the 256 (8 bits) in each channel or 
grayscale. The histogram shows a vertical line for each grayshade, i.e. each of the 256 X 
locations.

24) To start with the black triangle at a) It was moved from the far left to a setting of 80. 
Think of this one as: 
“Everything to the left of it is pitch black and as you drag it to the right, the more shades are 
turning darker” 
What that means in this example is that the darker shades in 17 a) have been all re-assigned to 
solid black, accounting for the dark areas in between the circles in 17 b) You can see in the 
histogram in fig 18) exactly how many shades that included, look at the lines right above “a)”

25) The white triangle at b) has moved from the far right ‘256’ to a setting of ‘189’. Think of 
it as
“Everything to the right of it is solid white and as you drag it to the left the more shades are 
turning whiter.”
In 17b) you can see that that created the solid whiter center portion in each circle. That use to 
consist of light grey shades in 17 a), also visible in the histogram right above “b)” and they 
are all remapped to white now.

26) The middle triangle at c) would have normally started at the 1.00 position but then it 
would have travelled along with the other two being dragged and without intervention it stays 
exactly centered between the two others. It defines the linearity of the ramp. It normally has a 
range of 0.1 (all the way to the right) to 7.99 (all the way to the left), but this range can get 
smaller as is the case here. Think of it as:
“From the lightest component to the darkest, it is compressing the range to more light greys if 
dragged to the left and more dark greys if dragged to the right.”
In 17 b) it had the effect to further reducing the light grey bands, making a very narrow halo 
of greys around the white centers.

27) The black triangle at d) has been dragged to the right. Think of it as “Make the darkest 
shade not black but THIS shade” and then move it there. Same with e) “make the lightest 
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shade not bright white, but THIS shade” and move it left...   You can see easily in 17b) in the 
top corners that the centers are not pure white, because of the setting at  e).    Clicking in the 
title bar, as in f), will compare to the previous state, as always.

28) In the color version the operation is exactly the same, instead of White substitute Red, 
Green or Blue. E.g. moving the lower left ‘d)’ triangle to the right, which adds a white 
component to everything in grayscale, will add a red component to everything in the red 
channel, moving the ‘e)’ triangle will remove the white components or R/G/B components.

The only tricky thing is that these action have a visual effect that you will have to get used to. 
For instance: moving a triangle and removing red will result in a stronger remaining presence 
of Green and Blue, which will turn the image more turquoise/cyan like. You have to 
understand that you are not using a Cyan slider but you are removing Red and altering the 
mixture in the process...That simply takes experience. As much as I try to make this the 
‘condensed experience’ I can’t quite download a brain dump.      Thank God!

You therefore need to also understand that in order to turn something ‘orangey’ you need to 
add Red and Green, or remove blue.
29) Now, once you do know all that, you can at will go about turning your vision into reality. 
The step from 17a) to 17b) e.g. from soft spheres to contrasty circles, can be done during 
colorization to achieve blue background with purple spheres with orange pink halos and 
yellow highlights..., which in fact is what figure 16) did in the first place...

Tip >>> a little known fact is that the Levels dialog allows the bottom two triangles to 
actually overlap one another, which results in a complete Invert operation!! you can see in fig 
19 a) that the white triangle is now at the far left and the black at the far right....!  This is 
good to know in grayscale, as you can perform an Invert right within the dialog, but in color 
it gives you an even wider range, because inverting a single channel, as here the Blue and 
Master, results in whole new color schemes, as seen in 19 b)     Try it, works great!   
MetaTip >>> since the invert can mess up all other colors, including the dialog, desktop etc. 
you may need to use Preview to see it realistically. Then Option Preview to get realtime 
changes back...

fig 19 a)

                               fig 19 b)  

The secret Levels Invert operation: overlap the bottom triangles!!  In color, works in each 
channel....
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30)  Well, so much for the basics on Colorization. I’ll call this “A” and add the other basic 
conversion methods in “B”, and then, believe it or not, one gets to the good stuff in “C”, 
because there certainly is a lot more to talk about. It’s all a peculiar mixture of ground work 
and power tips, but you’ll just have to live with that, won’t you... 
What are you gonna do? Send me a feedback note with other ideas?  Ha!   I double dare 
you...

Please let AOL, Compuserve, and Adobe know if you find these tips.

Happy Photoshopping,     Kai Krause        
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Photoshop : Kai’s Power Tips & Tricks : 
Note:
Photoshop 2.5 addendum
This tip works very well in Photoshop 2.0. In PS 2.5 the HSB and HSL color spaces were 
eliminated. These effects still can be produced in PS 2.5 with the HSB/HSL plug-in which is 
included with PS 2.5.1. This filter will allow you to create the effects documented here but 
you will have to convert back to RGB to see them properly. The HSB/HSL plug-in is 
difficult to work with due to the intermediate step of converting back to RGB to view the 
results. This technique may be the reason you've been looking for to keep Photoshop 2.0 on 
your machine.

#13  Colorization II
and Hue and Eye...

Why?  
Well, I didn’t get to finish the job in the first document and I’m not likely to do it with this 
one, either. There are LOTS of ways to meddle with color.   But I scratched the surface pretty 
well.

What?
Colorization is still the topic, meaning how to go from monochrome “grayscale” images to 
color. I assume you have read the first chapter of this, KPT#12, if not, do it now.  You 
wouldn’t read a murder mystery back to front now, would you.    (Chorus of the sickoes 
“Sure we would....”        “I knew it!”)

How?
I have started to throw in little bonus techniques on how to create textures ‘n stuff. Here is a 
One Minute Quickie (with lots of variations to try):                  
1. Make the usual window, File > New,  400x by 300y 72 dpi  in grayscale
Select  Filter > Noise > Add Noise... and use ‘222’,  ‘Uniform’ to make it look like that:

                                             fig 1)  Uniform Noise at 222

2. Now go to Filter > Stylize > Diffuse...and click ok. Repeat that 10 times.( Obviously use 
command-‘f’ to repeat.)   A more structured stucco-like texture emerges. Use Filter > Blur > 
Blur More once.
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                                               fig 2 a)  After 10x Diffuse...

                                              fig 2 b) ...and then  Blur More

This will be our starting texture, and while it now may look a bit like soft Granite (more so in 
a larger area than this sample) there are lots of weird alternate styles hiding in there. I am just 
traversing the idea space in one random way.   To do more explorations from this starting 
image, make a few copies via Image > Calculate > Duplicate now. We’ll come back to them.  
(Is that a macro in your household yet..?)

3. OK, to jump into color a whole other way: Change the image from Mode > Grayscale to 
Mode > RGB, nothing seemingly happens. Now, if you go back to the Mode menu you find 
that the bottom options “HSL” and “HSB” are no longer greyed out.  
 
4. Change from Mode > RGB to Mode > HSB now...  Again nothing really happens, except 
the current window is redrawn and the title bar reads  “Untitled-1  (Brightness,  1:1)“  (by the 
way if that ever says something other than 1:1 you are zoomed in or out and are not seeing the 
real thing... Tiplet >>> Double click on the magnifier tool to reset it. )   This indicates that 
you are seeing one channel, Brightness, which happens to be the original Grayscale image, 
since that information is interpreted as the brightness during the conversion.   

5. We have added two other channels, though. To see one, use Mode > Channel  and the 
hierarchical menu shows Hue, Saturation and Brightness (with their short cuts: command-1, 
2 and 3...). Select Saturation....
The window is redrawn, the title says Untitled, Saturation and everything is.....   black. 
“Nothingness! A void.”  “What kind of a void?”  “An empty void.”   (Make a note to watch 
Love & Death)

6. This channel contains the information on color saturation, in other words “How MUCH 
color is there at any one pixel location”.  The way it works is that this is a 256 grays (8 bit) 
channel and White means FULL color saturation, Black means NONE, greys anywhere 
in-between. In a converted Grayscale image there isn’t any color to begin with, so initially the 
channel is black. But, the beauty is that you have all the tools of Photoshop available to mess 
around with this channel all by itself and create the color information directly! So, let’s do 
that. Use the Blend tool (Under the magnifier) click at the top area of the window and drag 
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down to the bottom  (Tip >  Use the shift key to constrain the movement to true vertical). You 
will get this:

                            fig 3)   Creating a gradient in the Saturation channel

7. Switch to Mode > Channel > Hue where we have the same situation. Now a grayscale 
channel defining WHICH color, pixel by pixel.  Understand that these two work together! 
Defining a color here won’t show up until there is a saturation other than black set in the 
Saturation channel!   Since there is no color after the conversion from grayscale, this, too, is 
initially black. Let’s artificially create different hues here. 

8. Blend tool, click upper left, drag down to lower right...:

                                fig 4)  Creating a gradient in the Hue channel...

Ok to sum this up for a second and as  a mental pop-quiz:  The brightness channel looks just 
like the original grayscale image (in our case that granite texture, but you can use anything 
monochrome). 

Think of the Saturation channel as : “where it is black, there won’t be any color at all, where 
it is bright white, the color (defined in the Hue channel) will be at full intensity and greys fall 
in-between....”

Think of the Hue channel as: “where it is black there will be a certain color in the spectrum 
(‘red’, it turns out) (with the intensity defined in the saturation channel), where it is white, it 
is another color and greys are all the shades in between...”

At white the color is “red” again, it turns out, since the spectrum loops around:
 

fig 5 a)  

Here is how the grayshades (above) map into the colors (below) in the Hue channel:
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fig 5 b)  

9. So, looking at the Hue channel we can guess that it will be red at the lower right, cyan in 
the middle etc. and looking at the Saturation we can assume that there will be no color at the 
top, getting intense toward bottom.
10. To see the results of the experime
nt, we need to reconvert: Goto Mode > RGB. This will take a few seconds and build the 
complete 24 bit RGB image from the HSB channel data. Voila, instant colorizing:

                                          fig 6)  
                                      The completed RGB colorized image...

On an 8 bit card, you can also go one more step now from RGB to “Indexed” to see a better 
approximation.. Still nowhere near as subtle as the real thing. If you do this full  screen it is 
VERY smooth in 24 bits..

Look at fig 6) and read the summary ‘10.’ one more time to see how the channels work 
together. Once you really ‘get’ this, it becomes a re-usable, predictable tool for you.  
That is kind of the crux of all my KPT files, the nirvana state of being able to conjure up any 
image or effect and know all your tools to such an extent that you can create that image...     
(and then there are the happy surprises while you’re on the way )            (kinda like life. 
Hm..   Deep.)

Many of you have already dabbled with these things here or there, but to really KNOW 
what's going on is another matter.

11. ok, hit UNDO...and go back to the multi channel state. Let’s see what variety lurks here. 
( if you did that Indexed step UNDO will just bring back the RGB...you will need to then go 
back and separate to HSB again. Caveat: This conversion is not lossless, as you can see in 
the Hue channel...)

I interject one of the other color dialogs not covered in KPT #12, the Image >Adjust > 
Curves...

Another very powerful one... For this example, simply click one the two points shown here 
and the curve will snap around that immediately. You can also drag the points from the initial 
diagonal if you like...
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                     fig 7) 
                                  The Curves Dialog and two mouse clicks....

                                          fig 8)  
                      ....get you this color splash! In big, this is REALLY splashy.

This redefines in a very complex way how the colors are spread and you end up with an 
incredible variety of shades, hues, and neat little details. I hope you did this with the 400x300 
size or larger to appreciate the subtlety. Very nice.  And if you move the points around or 
click-drag new ones, or do this in individual channels with different curves....you will see a 
bewildering array of color, all from that granite noise.

12. I realize you are not necessarily after a mind altering light show  (although I extend 
greetings to a member of Pink Floyd here, who is not necessarily NOT after that..), but this 
ought to serve as a mere demo of ‘process prowess’.  It is implied that you can pull back to 
the toned down, gentle, plain or business-like color schemes that fit the job in your particular 
case. (Whimp)

Many of the filters have unexpectedly effective benefits when used after the splash stuff.

                                       fig 9 a)  
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                                      fig 9 b) 
          Filter > Stylize >    Solarize and Emboss are very effective with such textures...

Hard to see in the tiny size, but do try them (and others)   Solarize will get very subtle paisley 
effects (Use Adjust Levels and Hue to get it just right) and Emboss (135, 1, 88 is a good 
setting) will create nice pitted rough stucco wall textures.  (Fade out more color and move the 
spectrum to get neat Santa Fe type backgrounds )   Tip on Emboss, do a Blur before and a 
Sharpen after...

13. Well, the technique above inserted gradations into the Hue and Saturation channels to 
synthesize color  information.  The more refined technique calls for  this information to be not 
random but related directly to the original grayscale image.  There are many ways to derive 
such information and I’ll glance over a few here...

14. Lets say we have a grayscale image with some black shape on plain white background. 
I’ll use text here, since that certainly happens a lot, but it could be just about anything.

                                                 fig 10)  
                                                       Grayscale image ....

15. Use  Image > Calculate > Duplicate to create two copies of the original. I will do this with 
separate windows to explain a further element in the colorizing trick bag, although you could 
also do it with multiple channels.

OK. The point is you can modify individual windows with any tools you like, but think of 
them in terms of possible use to define the Hue or Saturation....  and later learn to have such 
ulterior motives with any image you ever see.  Wow. The mind wobbles.
16. In this example, to create a Hue definition we invert the original and gaussian blur it (3 
ish) to create more greyshades.  Remember to now think of greyshades as different hues. 
Forget the edges or blurriness they will be defined by the Brigthness channel.       That is 11 
a)

17. For starters we do the exact same thing to create a saturation channel. In fact you can just 
duplicate 11 a) to get 11 b).  Here it means something different though: the whitest areas in 
the center of the letter shape will have the most intense color saturation, tapering off to the 
sides...

18. We take one of the originals and invert it, plus maybe one simple Blur to get 11 c). 
Interpreted as the Brightness channel it simply means, where there is white we’ll see the 
color...
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                                                          fig 11 a)  Hue 

                                                    fig 11 b)  Saturation 

                                                   fig 11 c)  Brightness         

19. Now for the magic step:  Go to  Mode > Merge Channels    (all the way at the bottom)
You will first encounter a selection of options, namely into which Mode to merge:

                                fig 12)  

                                          The initial Merge Channels dialog

20. The number in the Channels box will tell you how many windows you currently have 
open that are mergable (i.e. the same dimensions and grayscale... If the number is less than 3 
or not what you expect check that all the windows are indeed grayscale and identical size. Old 
tip > option-click on the number next to the scroll bar in the bottom left of each window to get 
the size info)
Simply click on HSB, and the dialog continues: 
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                        fig 13) 
                                      The Merge Channels pop-ups for H S B

21. You will have to remember (or ‘think ahead of time’ or ‘still see’) which window belongs 
into the HSB slot and use the pop-up to assign them.  On a big screen you can drag the 
windows often so you still see it, but with larger files or a smaller screen you’d do better to 
think it through before you merge.

What exactly the pop-ups say will vary with how many windows you have open. E.g. it will 
very likely not be 6, 7 & 8 in your case...

Anyway, as soon as you click ok, the windows will disappear and a new one will pop up in 
the upper left somewhere. You now have an HSB image and see one channel at a time.  You 
can use Mode > Channel to verify and look at each channel (command 1,2,3 as a short cut).

This is merely a different method to get to this stage. If all three are derivatives of one another 
you could have used the Grayscale > RGB > HSB sequence just as well, but I wanted you to 
understand how the Merge Channels command works and what to do with it. In fact, you 
may get one of the channels from somewhere totally different and then you may need to do it 
this way...

Tip >>> you can obviously also merge three files into R, G and B and other such 
variations....

22. Anyway. Now use Mode > RGB and the three channels are interpreted as a single RGB 
24 bit color image  (again, on 8 bits you have the options to further convert to Indexed to see 
it better...) and the color is now following the shapes very nicely...! 

                                        fig 14)  
            The three images in fig 11 merged to HSB and then converted to RGB

23. What you need to understand here is that the color may not be what you want, or the 
intensity, or the background...but all that is fixable!  This was meant only to colorize in a way 
that the color follows the shape of the original. And as always in KPTs (or nearly) it did it 
algorithmically at any size or resolution. In other words, I didn’t draw the little curves into the 
colors or used the smears or airbrush to do it.  Not that I’m against a painterly approach for 
those that are good at it or are looking for that effect. But this method is much cleaner, 
especially across 15 letters in high resolution and also faster in general, accessible by that vast 
majority that would have to call themselves less than proficient “artistes”. Finally there are 
numerous effects that can not be easily handdrawn at all....
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The effects change with scale (especially pixel oriented ones like Find Edges) so don’t worry 
if you don’t get exactly this identical look. It doesn’t matter.

24.

         fig 15     a) Hue     b) Saturation c) Brightness  d) and RGB 24 bit image
                               
Hue :  original letter, Blur once, Blend tool with “4” key down, lower right to upper left
Saturation: Blend tool, up, Blur More, Find Edges, Blur and Find Edges Again
Brightness: Inverted copy of Hue, one more blur and sharpen

25.

          fig 16     a) Hue     b) Saturation c) Brightness  d) and RGB 24 bit image

Hue :  Noise 33, Crystallize 3, Blend 50% twice
Saturation: Blur More, Emboss 135,1,100, OverSharpen (SharpenMore 4 times)
Brightness: Blur, Emboss 135,1,100

26.

          fig 17     a) Hue     b) Saturation c) Brightness  d) and RGB 24 bit image

Hue :  Gaussian Blur 3, Twirl 120
Saturation: Blur More twice, Find Edges, Invert
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Brightness: Gaussian Blur 3, Arbitrary Map adding various sags and highlights, then 
smooth.

In fact, that last one about the Brightness channel brings me to the last dialog that adds color 
controls which we haven’t discussed. We talked about Image > Adjust Hue/Saturation, Color 
Balance (in Colorization A), Levels, Curves...   the only one left is the Arbitrary Map. 

There is a whole KPT on the Arbitrary Map (#8), but that’s focussing on other applications. 
It also surfaces in the Moire Removal (#10), but yet again for a special case. Here now a few 
more basic Colorization ideas.

I suggest to load the image “Blendo Spheroids” to do this, as it happens to contain multiple 
continous tone colors which will demonstrate this effect very nicely. There are two versions 
in the KPT area, C-cube compressed  and a new Quicktime Jpeg version, which is nicer. The 
examples here show a tiny chunk of that image.

27. What I’ve outlined so far works fine to go from grayscale to a flat color or range of 
colors. The following allows you to add interesting spot colors, highlights, reflection effects, 
neon, metallics, etc. etc.
In fact Blendo Spheroids itself serves as the perfect example: I showed the technique in KPT 
#5 in grayscale and then used a number of the Colorization methods on each sphere. (After 
each is created, the selection marquee is still showing ‘marching ants’ and all treatment will 
affect the local selection only. That's how you get a blue and a red sphere)

With BlendoSpheroids on the screen, go to Image > Map > Arbitrary Map... and in the dialog 
notice that in the color mode new radio buttons let you switch from Red, Green, Blue and 
altogether in the Master channel. (These are absent when you enter in grayscale).

Since I can only show the small blue sphere, I’ll mess with the blues (don’t worry, white boy 
ain’t gonna sing none neither) and select the Blue channel. Now here are some basics you 
ought to be familiar with (great additions to your arsenal).  Do read #8 for more background 
though.

When you first enter, the ArbMap is a diagonal line as in fig 18 a)  in each of the 4 modes 
R,G,B, Master. You can draw the opposite diagonal (fig 18b) to create the same effect as 
using Image > Map > Invert. 

                                                        fig 18)  Normal 

                                                           fig 19) Invert 
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28. Couple more basics: the adjustments are done in realtime with Direct Set Entries and this 
will affect  all color on the screen at once. To see the final colors as they will actually come 
out, use Preview. 

Old tip >  On a 24-bit card you need to use option-Preview to get the realtime mode back.  
Clicking in the title bar (on the word “Arbitrary Map”) will momentarily compare to the before 
settings, Option-Cancel will do a reset in all 4. (“Reset” itself only resets R,G,B or Master.) 
If you use Load/Save add a prefix or suffix (“.arbmap”) since there are lots of loadable files 
in PS.  SuperBoomerang is nice for stuff like this, remembering the last chronological list of 
files and graying out other formats)

Note also that the Smooth button works very well and plays a key role for gradual changes, 
but the corner points are anchored! This means that all points except the first and last will be 
interpolated but those 2 stay fixed where you happen to have drawn them! If you modified the 
last point to be at zero you can push “Smooth” all you want and it will never get back to the 
normal diagonal. 

I will first remove all blue entirely from the image and then look for interesting subsections to 
add back in. Drawing ‘near the top’ will add blue at full intensity, drawing ‘near the bottom’ 
will add near black.      (Note > this low = black assignment can be reversed by clicking on 
the little grayramp below the grid. This will mean black is at the top. Other than psychological 
help, if you prefer to think of it one or the other way, I haven’t found any deeper reasons to 
do this)

29. By drawing a quick line (doesn’t matter how wiggly it gets)  (my wife’s favorite line in 
this whole file) near the bottom, all shades will be assigned an output value near black.  
You can do it all the way down at zero, (the Eskimo’s wife’s favorite line), but then it looks 
just like a totally empty dialog.  You can use the shift-click method to draw straight vector 
lines...
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fig 19) The ArbMap dialog, blue channel selected and blue almost removed from the image.
Quick note: I paste b&w dialogs as 1 bit ‘bitmaps’. They look big but they aren’t.

30. Note that the pencil is in the upper right corner. If you click a single pixel at 255, 255 you 
can then use the Smooth button to go from “all black” to “normal” in about 10 steps.  Kind of 
nice to see it build up almost as an animation.

31. Here is a small part of the original Spheroids file. Read the KPT #3 on the technique. It’s 
fun. Here now you can see exactly how the additional reflections and refractions were added 
to the initially monochrome image. 

                                 fig 20 )  The medium size “Blendo Spheroid”. 

This started as a grayscale spheroid and was colorized with you-know-what...Proof of the 
pudding.

32. Now one by one each channel can be modified, as seen in fig 21 a-d). The smooth curves 
in the Green and Blue channel show up as alternate hues with gradations in fig 22)  The little 
dips in the Red channel are ‘isolating’ certain red bands on the sphere. 
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fig 21 a) Master                   b)   Red                      c)   Green                      d)   Blue
                                                                                        

                                   fig 22)  The modified sphere from fig 20) 

Note: if you use discontinuous maps (as the red channel above) you are creating artificial 
aliasing errors and jaggies. They need to be eliminated by other means (e.g. circle selection, 
then Selection > Border and blur within that, or defringe, or others)
Load the arbmaps provided (includes the one in fig 21) and apply them to the whole Blendo 
Spheroid image. VERY interesting effects over the entire image, much more than this tiny 
chunk can show!
To give you some incentive, here are just a couple more examples of what can be coaxed out 
of the plain clean sphere...: 23 a) is the “Ring of Fire” ArbMap, which emphasizes a narrow 
blue range to bring out those ‘continentoids’ on the black planet and a lava ring of fire around 
it...   23 b) is the “Flashed Lines” with an entirely different globe and neat concentric circles 
in the shadow, as if photo-negative in a flash blast Both of these look positively amazing over 
the entire Blendo image, as it affects each sphere differently.

The key to the ring of fire effect is to first predefine a smooth bell shape by drawing the 
crown and the two bottom sides and hit Smooth once. The crown will come way down, since 
Smooth is a veritable Don Juan in the smoothing department. This gives you the blended 
Aura. Then draw a new ‘hard’ crown line about 5-10 pixels wide, about 20 pixels above the 
crown. That extracts the extra bright line. A little tricky but worth mastering...

Complex ArbMaps (provided with this Doc file!)  applied to a small chunk of “Blendo 
Spheroids”:
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                          fig 23 a)

                         fig 23 b) 
  
I hope you have a lot of fun with these methods and get to employ them some day. And if it’s 
only to walk up to your neighbor Bob’s copy of Photoshop and say “betcha didn’t know 
THIS” and show him a thing or two hundred. 

Rule # 273  If you win bar bets over $10,000  I get a cut.

Transloading to other BBSs and reprinting is generally fine. If its a commercial mag drop me 
a line. 
Spell my name right.   Don’t call me before midnight.   Send greetings to the Knolls.   Plant a 
tree.

PS.   I haven’t the foggiest how to get these beautifully printed on a black and white laser. 

Please let Compuserve, AOL, and Adobe know if you find these tips fruity, yet not 
overbearing, with a woodsy aftertaste.

Happy Photoshopping,     Kai Krause        
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Photoshop : Kai’s Power Tips & Tricks : 
#14   Selections
Naturally, Darwin...

Why?  
This may be one of the most important items in all daily Photoshop grunt work, and yet many 
people are missing the boat here.  There are LOTS of special little things to know. Come on 
in. Get to know them.

What?
In almost any image being worked on in Photoshop you need to isolate a section such as an 
object or text and deal with it separate from the rest. There is a whole menu called ‘Select’ to 
deal with this, as well as various marquees, lasso, magic wand etc. But there are many 
methods that are far from obvious and I hope you will come out of this with some real insight 
that you can apply almost every time you launch Photoshop!

How?
Well, let’s start with the basics and work on up to the 
oh-my-god-what-is-he-babbling-on-about-now on the latter pages...

1. There are some shapes on a page. You want to turn some green and some red. You 
need.... Selections:

                     fig 1 a - e) 
                          A few shapes (Zapf dingbat font just to make it easy)

Now, to turn that last figure, 1 e), red, there are many ways.  As a holdover from MacPaint 
style applications many of you might jump to the fill bucket. Sure..that thing is just black, 
will take half a second.
Not so easy. First you convert to RGB mode, set the front color by clicking and picking (or 
better yet, use the Window > Show palette, pick & mix) and you click on the figure.
    

                                                     fig 2) 
                                             Rats, only one petal turns red! 

2. Ok, you are a man of the world. I mean, you’ve done it. You’ve slept with a...  I mean 
slipped a variable or two in your time. You know how to fix this! So you double click on the 
fill bucket tool to get the dialog and you change the color tolerance from the default ‘32’ to a 
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more engrossing, say, ‘55’...Yeah that’s it, that ought to fix it. Sure. Of course. 
      
                                                            Click, click

                                                     fig 3)  
                                                 Rats again, now it’s four...

Closer but not enough, obviously. Crank that puppy up some more! “99” it is...:

                                                     fig 4)  
                          Rodents ever more. STILL can’t get those thin parts...

3. Well, now you figure ”It’s only 6 little strips, I’ll just click on them directly...” and trying 
hard not to miss (old tips : caps lock to get cross hair, easier to see than bucket tool cursor,  
command ‘+’ to enlarge window and see better. At very high magnification use New 
Window to get a second clone and leave that one at normal size)
Soooo, clicking away at the thin parts:

                                                     fig 5)  
                                         argggh, it gets uglier by the minute

4. Now we have bloom and bleed and blancmange and there are even STILL little gray parts.  
This program is just no good. You are convinced that good old PixelPaint did this with more 
style. And you are very much mistaken. It is just not quite as obvious as a fill bucket tool.  
Admit it, you have done this. Hell nobody can blame you. It is the seemingly obvious choice. 
But the whole notion is flawed and what you need is full understanding what is going on 
here.

In Macpaint this all was trivial, because all pixels were just black or white. This shape would 
have been just black and easy to fill.  Photoshop of course went the extra mile to give you 
anti-aliased edges and got you edgy in the process.

                                         fig 6)  
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                      Enlarged view of the multiple greyshades in anti aliased edges

This, of course, is what you are really trying to get: 

                                                     fig 7)   
            All the anti aliasing and smooth edges, but in the color of your choice!

But how to get it...?

Plan B from inner space: “well, I would normally just use the lassoo and shrink right onto 
this thing... Photoshop doesn’t even have a shrinking lassoo.”    Mistaken again.

5. Well, since this is all about selections lets quickly do the old shrinking lasso.

                                                fig 8 a) 
                             If this is the shape you would like to lasso...

...all you have to do is to marquee around it (rectangular, elliptical or lasso) in a generous 
fashion:

                                                fig 8 b)     
                                                      marqueed loosely...

now use the Magic Wand. As soon as you enter the marqueed area it will turn into a cursor, 
indicating that you are within the boundaries of a selection and you can move it around. If 
you press the command key however the magic wand re-appears and now it will function 
within the boundaries of the selection! 

                                                fig 8 c)  
                                and then command-click the magic wand...

This will select the white area inside the selection and leave the shape itself, just like any 
self-respecting shrinking lasso would have done.  Most of you will have known about this 
before, then again, maybe not? Worth a third of a page anyway.

In fact, this method would fit the bill here, but really only because we have a simplistic case. 
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You may have thought, “Gee, why not just click the magic wand right on the shape..?” and 
that’s true, too.  But the method up there works well even if you need to shrink around a 
whole bunch of separate items, such as this

                                                      fig 9) 
                             a whole lot of little shapes can be roped in easily...

A good example of a selection with multiple shapes is ‘text’ after you exit the text tool dialog. 
And if you lost the selection around the letters, this would be away to get them back. 

6. In a more complex example the normal shrinking lasso will not get interior enclosed holes. 

                                        fig 10) 

You need to experiment with the combination of ‘shift command wand’. There are lots. 
Simple repeated ‘command-wand’ clicks inside the hole shapes will add each one to the 
selected area. ‘Shift command wand’ acts quite differently.  Luckily command-shift is 
immediately next to command ‘z’ (“Undo”) so you can try and see what happens. Photoshop 
is very forgiving and allows near perfect Undo (although only one step, so be careful. One 
click too many and you can’t go back.) (Tip >>> learn to glue one finger onto the command z 
key...or F1, but that is much further away...)  (It will be nice when Caspar voice input 
appears on the ‘93 Macs, then you can link Undo to something like “Ooops...”)
In the example of fig 10) there is no easy way to add all the dots to the pretzel shape, nor to 
shrink down to them all without trapping the hole shapes. In fact using the wand there is NO 
way to get all this reliably.

7. So what would you say if I boasted it could be done algorithmically...(that is, without 
manual clicks or decisions about holes or regions..) and in about 5 seconds...? Hm..?

In fact there are TWO ways to do that even.  Puzzles anyone..?
Here is a quick look at the Select menu, (note that some menu items would be grayed out until 
you have a floating selection...)
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                                   fig 11)  
                                                      The Select menu...

8. The first method revolves around Inverse and Similar, both of which are extremely useful 
and much underrated in the casual Photoshopping crowd. In my non-scientific sampling 
during classes I taught there was an overwhelming majority of ‘insurance salesman style’ 
blank stares when it comes to this stuff.

In this case we will exploit the fact that the figure to be selected sits on a flat color 
background. (Note:  it is not in the least important whether that background is black, white or 
anything else, as long as it is flat shade)
First select a small patch of that background with one of the marquee tools. Here in fig. 12 a 
small rectangle is selected in the upper right corner:

                                        fig 12)  
                                           selecting the background pixels
 
As soon as the ‘marching ants’ appear, the Similar menu command is no longer grayed out. 
Use it and presto!,  everything  that is the same shade as the background everywhere in the 
whole window becomes selected... Now all you need to use is Select > “Inverse” and all the 
black shapes, including the dots and excluding the holes(!) becomes selected. Voilà...

9. Two points: First, if you are not sure what is exactly included in a selection and it is hard 
to see with the marching ants, turn them off via command-h and then hit ‘delete’ to clear 

Kai's Power Tips Page  121 Thu, Dec 7, 1995



everything (of course Undo that immediately) (plus this assumes that the background color is 
white. ‘Delete’ clears to that color!) . You can then see readily if you have erased all that 
ought to be included in the selection. In particular if you didn’t catch certain fringe regions, 
such as anti-aliased edges, you will then see them remaining as ‘dirt’... Its a very usable 
technique.

Second, it is not immediately obvious that the ‘Similar’ command is tied to the Magic Wand 
dialog! The Tolerance setting in there affects the operation greatly...!  Default setting of 32 
means that while we chose white as the Similar source, the selection will include the next 32 
shades of light gray as well...which in the case of fig 12) might be some of the light 
anti-aliased edges...  If you entered a value of 250 in the Magic Wand Tolerance, the Similar 
operation would select everything but the darkest black...

Tip >>> you should open the Window > Show Info windoid (on my big screen I always 
drag it under the toolspalette since that vertical chunk is already ‘lost’. I wish it were the same 
width and remembered that position). That way while the cursor flies over certain areas such 
as the smooth edges you can read exactly what the values are and adjust the Tolerance value 
to include just what you want.

Note >>> it is not generally obvious that the tolerance is ‘bi-directional’! That means if you 
specify a tolerance of 100 it will include 100 shades lighter AND 100 shades darker! If you 
wanted a range of 100 gray shades around medium gray, you need to specify ‘50’ or else you 
get 200  not 100.....

10. While we are on the topic of Inverse Selection, here is a cute One Minute Quickie 
interspersed:  There are lots of neat effects that can be done with shapes if you have two 
opposing gradients delineate the area. This is extremely simple to do. While you have a 
selection up, e.g. type some text..., use the blend tool in some direction. Then use Select > 
Inverse and use the blend tool in the opposite direction. 

                                  fig 13)  
                               a northwest and a south east blend define the shape

You can go back and forth between the two selections and tweak the effect. Especially useful 
is to go into the Levels... dialog once the basic gradients are in, because somewhere the 
medium gray shades of identical or similar value will touch. If that hinders the legibility you 
can move the point or tone each down.

11. While we are at this with some text, here is another One Minute Quickie sequence that 
might prove to become a favorite of yours. Instant fancy text in a jiffy.   Type in your text, 
pick a font, anti-aliased, fairly large size. Whatever. click ok..The selected text is floating in 
your window. As soon as the cursor enters inside the region it will change to an arrow (Note: 
it is pointing to the right to distinguish it from the left facing ‘select’ standard Mac arrow, in 
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case you never noticed). Click-and-drag the text to the desired location. While still selected 
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with ‘marching antEis: double click the eyedropper (this resets the colors to b&w) , pick 
the blend tool and while pressing the number ‘1’ key click and drag right below the text, as 
seen in fig 14):

                                 fig 14)  
                   a gradient blend underneath the text with the ‘1’ key depressed

What this does is to draw a blend with only 10% (short-cut keys ‘1’-‘9’ set it in 10 % steps, 
i.e. ‘7’=70%) and starting below the text quickly fills it with 10% gray. 
   
Note >>> An important feature often overlooked about selections is the fact that their 
translucency (and other settings in the Paste Controls dialog) will be created on the fly while 
still floating ! What this means is that if you have a partially translucent figure you can 
re-position it with that transparency setting still active... Try it , its incredible.  We’ll use that 
for our trick here, too.

12. Step 2 involves another very basic fact concerning selections: if you hold the option key 
and then pick up a selection and drag it away, you will leave a copy of it in the original 
position! (You simply must  get familiar with that. It is so much faster than copy, paste...)   
(Again, I suggest ‘Hide Edges..’)

Here that is a double whammy: option key depressed we move the selection,  leaving behind 
the 10% blend and at the same time super-imposing a new  10% opaque blend. Instead of 
dragging it with the mouse I suggest for this trick to use the arrow keys (called ‘nudging’ 
after an obscure sketch by some British people)

Again: simply press ‘option’ key & left arrow, then lift option and press up arrow, another 
left another up.

The effect is that you have a 10% light gray and displaced to the left another copy over it and 
even more toward the upper left a third copy. Every time you press the option key you leave 
another copy, each one of which will successively darken the previous ones, building up a 
darker shadow as you nudge it ..very cute.

                                  fig 15)  
                               The moving self-building translucent shadow...

13. And any time you think you are done with that shadow you can instantly create the actual 
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text. Simply press Option-Delete to fill it black (actually:  fill it with the foreground color...) 
(Note: just Delete will NOT fill it white, but delete the selection itself!)  or, more stylish, 
press the ‘9’ key and do another blend with more opacity across the still selected text in its 
current position.

                                 fig 16)  
                                          A real blend in the final position...

14. Now for another real important little fact about selections! We’ll give it the final polish 
using this...:

(When the last blend is accepted, make the marching ants visible again). Normally if you 
move this selection now you will actually move that last blend to some other position. 
But you can also move the selection itself  ! You need to press the option and command keys 
first and then move it with a click-drag or the arrow keys. In our case, we want a very small 
precise movement: just one pixel left and up (or 2 or 3, whatever...season to taste) so: 
option-command-left arrow-up arrow...

Nothing will happen other than the marching ants being slightly shifted. Doesn’t look like 
much. But the magic is that if you do another blend now it doesn’t quite cover the previous 
one, and Voilà, lovely edge highlights, shadow and light,  reflections, refractions, blablabla. 
The final version of the simple example:

                                fig 17)  
                       another last blend top-down with nice edge highlights

Really, if you try this with any text: it involves nothing more than the blend tool 3 times and 
the arrow keys. It is VERY simple but VERY effective. And it works on any background, 
too. You can also leave weird motion blur shadows (much faster and more controlled than the 
Motion Blur filter).  Do the last one in color.

15. Ok, after the side step (well actually this really did revolve around selections) lets go back 
to the puzzle and try another method, totally unrelated, but opening a whole other chapter on 
selections.

The object was to get all parts of fig 10) into an active selection, remember?
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                                         fig 18) 
            This was the problem, but of course its only a very simple example

In fact, the concept is very, very basic and you really ought to follow this one closely. It 
involves really only two steps again. First the creation of a new alpha channel. Go to the 
Duplicate command:

                    fig 19)  
                      Using Channel Operations ‘Chops” to set up the selection

Now in the dialog, check the ‘Invert’ box, and set the ‘Destination’ to be the same as the 
Source file, but in a new channel. The name of your  window or file may differ, of course.
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fig 20) 
Duplicating an inverted copy of Untitled-1 into a new channel added to Untitled-1.

The window will be re-drawn and you will find yourself in the newly created channel #2. Go 
to Mode > Channel to see that and then switch back to channel #1 there. As you can see in the 
hierarchical, you can also just use command-1 to switch. 

                 fig 21)  
                               Checking and switching between channels...

You are looking at the same image as before, fig 18), but ‘behind’ it is the other channel. 
Now go to the Select menu and you will find the ‘Load Selection’ command no longer grayed 
out. (If you scroll up to fig 11) you will see that back then it was still not available yet.)

Well, just use that Load Selection command now and instantly you get what we were looking 
for....

16. To recap a little and give more theory. The Load Selection command will look at the next 
available alpha channel and interpret it as a selection. All solid white pixels are included in the 
selection, all black pixels are excluded. In our case here is how that looks:

                  fig 22)  
All white pixels in the Alpha channel are interpreted as part of the selection loaded onto the 
original image.

This is a very cool concept that you have to kind of think about. Let me rephrase it a little. For 
any image, mono or color, you can create custom selections by adding one more channel and 
in there hand paint your selection using any tools you like. Whatever is white will become 
part of the selection. You can of course derive that channel algorithmically, as we have done 
here. But consider what all can be done to that channel..!  You can filter it, spin, emboss, 
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equalize, blur, flip and tumble it... Amazingly general power!

A few points:  Use Levels.. and move the white triangle to the left. This will dynamically 
change in-between gray values to become solid white and will in effect ‘grow’ the selection 
region. Or use the black triangle to shrink it. Very interesting results can be obtained this 
way. There is no equivalent way to shrink a selection region by pixels inward (would be nice, 
though), but this will do it...

17. Lets try a couple neat variations!  Here is a single large shape (if you can try this even 
much larger...)

                                                fig 23)  
                                                a simple grayscale shape...

This time lets just use the Mode > Add New Channel command to get our selection channel. 
Initially it will be the current background color (normally white).

You will ‘wake up’ in that new channel right away. Simply use the blend tool to create a 
simple gradient.

                                        fig 24)  
                                                  the ubiquitous blend tool

Now you can tell right away that this will become a selection that you could never create with 
any of the normal tools! The top will be ‘fully selected’ but then it will include less and less 
towards the bottom.  You can bet that this will have amazing repercussions....!

Switch to channel 1 with command ‘1’ or via Mode > Channel > #1 and then Select > Load 
Selection. There is of course no way for the marching ants to properly indicate what is going 
on now. It will try the best it can, but usually in these cases you might as well turn it off 
command -h immediately. In this example it will simply draw a rectangle to the mid gray 
threshold somewhere in the center..

One of the total basic concepts about selections (so basic that I didn’t even mention it. I trust 
you more than that.)  is of course that all tools are restrained within them. If you draw a circle 
marquee then any airbrush or whatever will work inside that circle but stop right at the edges. 
Same with any filters or adjustments.
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Well, as incredibly obvious as that fact may be, the implication for this situation are indeed 
profound. In our gradated selection we now have forced all tools and effects to also taper off 
smoothly without any further efforts. It can seem downright miraculous.         Three 
examples (Undo between each)

Something as basic as a simple Invert will now work with a ‘modulated percentage 
intensity’...:

                                        fig 25)  
             Just hit command-‘i’ (Invert) and create the counter gradient in one step!

A simple brush stroke up & down will magically change intensity by position. How else 
could you do this?

                                         fig 26) 
                                     a solid black brush takes on new qualities

And all the filters will now be modified as well. Here adding plain noise (222 uniform) tapers 
off magically:

                                        fig 27)  
                                            a new effect: gradation noise...

18. I don’t think I need to stress how simplistic this example with a plain up down blend is. 
You can do all kinds of  stuff over in that selection channel and have it modify the tools on the 
actual image. This opens up a whole extra degree of freedom with all filters, for instance. 

The gradated noise combined with gradated Blurring can create very convincing depth 
perspective, with near field defocussing. Perspective Blur is not a bad little filter to synthesize 
yourself this way. A radial blend in the selection can also give you a Zoom Blur similar (but 
actually much more variable..) to the one in the Radial Blur filter, at about 10 times the 
speed...
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                                        fig 28)  
                                           Perspective Noise and Depth Blur 

Try also amazing alternate effects with stuff like Polar Coordinates, Offset, Perspective and 
other less obvious ones. Surprise yourself no end...

19. Ok, another angle on selections, hard as it is to leave that one alone. Lets say you have a 
shape with marching ants. In this case option ‘g’ of the symbol font...

                                               fig 29)   
                                                    some letter or shape....

First while the raw letter is still floating, press command-c to copy the selection to the 
clipboard...

Then go to the Select menu and peruse the Feather dialog. In this case I entered ‘9’. The 
selection marquee will be redrawn and probably resemble some blobby shape.  Now, you 
may have played with feathering before, but let’s examine this in the light of some of our new 
explorations. Go to the Select menu and select Save Selection. This will take the feathered 
selection and copy it into a new alpha channel. (Presuming  you did this with a new single 
channel file, else if there is already a second or third alpha channel you will have a choice 
where to send the selection...)

Interestingly, we can now see exactly what a feathered selection is and how it functions. 

                                        fig 30)   
                     the feathered (9) selection made visible in an alpha channel...

20. If this looks suspiciously like the original heart shape inverted and blurred, its because 
that’s exactly what it is. Furthermore, it happens to be exactly a Gaussian Blur at ‘9’...!!  

This means that if there were no such thing as a feather command we could synthesize it this 
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way!  Neat, eh...     By inference this also means that you now can easily create a feather 
beyond the ‘64’ limit and of course more importantly, there are lots and lots of great alternate 
styles available, such as a motion blur feather or a non-linear feather (by playing with Levels) 
or a solarized feather (by playing with Curves) etc.

Another special version of feathering would be the asymmetrical one, such a s a vignetting or 
halo effect. Since we copied the clean shape first, all you need is a command-‘v’  Paste over 
channel 2 to create that special outward-only feather . Then go back to channel 1 and Load 
Selection to continue normally.

                                         fig 31)  
                               An otherwise unavailable asymmetrical feather!

You could achieve the opposite uni-feather by using Inverse Selection in channel #1, and 
pasting that over channel #2 (plus an Invert). This is all the feathering action of fig 30) but 
only active inside the shape.

                                        fig 32)  
                       The inside-only feather can generate great depth curvature effects

Tip >>> Use ‘Levels...’ right afterwards to adjust the curvature and ‘depthy-ness’ of the 
feather. Works beautifully.

21. Lets do some Color stuff for a sec.
Note:  you cannot work in a two channel mode (grayscale plus selection channel) and then 
convert to color the way you normally would. You are technically in “multichannel” mode. 
Therefore convert your grayscale image to RGB first (looks the same unless you are on an 8 
bit card and it dithers). Then add your selection channel as #4. 

Here we have messed around with the selection channel #4 a little (fig 33). Added some 
noise, blurred it a bit, used Levels to change the shades. In channel ‘0’ we have the clean 
heart shape as in fig 29. and now we use Select > Load Selection #4 and use hide edges 
(because the marching ants are a hopeless mess now).

Using normal Colorization techniques (KPT #12 and 13) will suddenly be modified by that 
spotted selection and create instant complex textures within the original shape. This can work 
absolute wonders. 
Please have the sense to extrapolate beyond these teeny tiny samples....!
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                                        fig 33)   
                in channel #4 we play with the selection using any and all tools of PS

                                        fig 34)  
       in channel #0 (RGB) colorization is affected by the selection definition of fig 33...

Just for completeness sake a few words about the missing selection related items:

22. Select > Grow does not refer to the spatial grow we emulated above, but rather enlarges 
the current selection to include all other pixels with related intensities. Again, this is tied to the 
Magic Wand Tolerance setting (default 32..to grow a selection in finer increments, reduce this 
number) and it also is symmetrical, i.e. the selection will grow towards lighter OR darker 
pixels with that specified tolerance.  

In my opinion the operation is somewhat haphazard and you would do better to deal with the 
selection in an alpha channel. Plus you also have the missing ‘shrink’ option that way! (To 
grow/shrink you simply blur more in the selection channel and then use Levels... to darken or 
lighten (grow/shrink respectively) the selection.)

23. Border is obvious, gives you a new selection along the edges of the current one, pixel 
radius user defined. It is interesting to see what that looks like if you use Save Selection and 
examine it in the new alpha channel. It is not unlike running Find Edges on the (pre-bordered) 
selection in there, in fact it is almost identical to a border setting of ‘2’.  Now of course you 
have much broader control to create borders. How about a rippled or wavy border? Do try it.

24. Defringe is a more subtle function and quite powerful at that. It will take the user supplied 
pixel setting (keep it low, 1,2 maybe 3) and extends from the area inside the selection toward 
the edges. You can use that for anti-aliasing edges. The manual and Biedny’s & Monroys’ 
Photoshop Handbook cover these things anyway.

One note: the Defringe command will be grayed out until there is a ‘floating’ selection. If you 
want to apply it to a selection, simply hit command c&v to copy and paste back into the same 
location. 

Be sure to also read up on how to add to selections with the shift key, subtract sections via 
the command key and intersecting with both.
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Another mundane item of obvious daily use is the pen tool and its various ways to create a 
selection with bezier control points. You should be very familiar with anchor points, how to 
convert a hard to a soft anchor (command control), add or delete parts, convert from path to 
selection and back, etc. etc. Its all in the manual and in particular take another look at the 
plastic quick reference card.

Note >>> If you do the path-to-selection conversion a lot, be sure to experiment with the 
setting for Tracing Tolerance in the File > Preferences dialog!

Other useful items include the Paste Options dialog are commands such as Paste Into. I guess 
there is room for a second volume on this topic. 

happy eclectic selecting...       Kai

Tell AOL, Compuserve and Adobe if you  find these tips addictive or vindictive or vandalous. 
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Photoshop : Kai’s Power Tips & Tricks : 
#15   One Minute Quickies:
Instant Spirals

Why?  
Beats me.  Just so.  I guess because life is ever spiraling towards something.

So?
How to draw a circle is easy. Use the elliptical marquee tool with the option key down, then 
Edit > Stroke to draw a neat circle. Anti-aliased, the lot. Fine. 
But where is the spiral tool? In ANY app..? Do you need to scan the damn things in? 
Nah. Its trivial: Twirl a gradient! Use the blend tool click and drag just a pixel or two:

                       fig 1a)                               fig 1b)                                fig 1c)  
Simply start with this or similar and use the twirl filter, here set at 333 and used a few times.

                       fig 2a)                               fig 2b)                               fig 2c)  
If the gradient is a real blend then the twirl starts soft and retains the slightly blurred quality.

An especially clean spiral can be had with the following addition: Use something like 2 a), a 
full screen diagonal gradient with the blend tool. Now run the Pinch filter, here set at 99 and 
run a few times.  This will draw the shades towards the center resulting in this nippleoid 
shape: fig 3 a) starting the twirl with this gets fig 3b).  Notice how much cleaner that is than 
1c) or 2c)
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                                            fig 3a)                             fig 3b)  
                                  the nipple induced award winning clean spiral 

Just in case you were not aware of the mathematically obvious reality: There are always errors 
associated with conversions and filters. These get exaggerated with larger settings. Compare 
how the twirl filter set at “999” (using fig 1a as a start) has rather serious aliasing artifacts, 
compared rather setting it to “111” and simply running it 9 times successively.  A lot cleaner.  
The values mentioned in this document are only accurate for the sample image size. With 
larger windows you will have to apply larger settings

                                             fig 4a)                               fig 4b)  
                              Setting Twirl at “999” ?     No, rather nine times “111”

Talk about aliasing error. It is rather cute to Un-Twirl by using one horizontal flip and then 
continuing to twirl. Here the flipped version of 4b) is un-twirled nine times, with the aliasing 
error left.  If you do it after a couple of steps, the error is very slight. Compounding losses 
have built up here. In fact, I kinda like it and use it even. An odd circular blur. (Try this with 
other complimentary filters, such as +99-99 Spherize...)

                                           fig 5a)                               fig 5b)  
Twirling the horizontally flipped spiral gets you back to the starting position, almost...

If you have faithfully followed the other KPTs you will have learned about neat selection 
tricks in #14. Taking 4b) and duplicating it into an alpha channel and load it as a selection, 
then using a blend and later the opposite blend with the Inverse Selection gets very nice 
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alternate styles easily.  If you didn’t get this read #14...

                                           fig 6) 
                                The Inverse Selection double gradient trick...

                                          fig 7)  
                       and then of course, in color its all a lot more fun anyway...

Try spiraling in the Hue and Saturation channels separately, as seen in fig 7) Also, combine 
other filters in between spiraling, such as converting to polar coordinates, spiral in that 
domain and convert back. Sometimes values that don’t create full spirals have great effect, 
too. You can get some beautiful space curves, color swirls for backgrounds, tiling, etc.

                                          fig 8) 
                              Spiraling in combination with other distort filters

This ought to set your pixels gyrating for a while...Have fun in orbit.

Tell AOL, Compuserve and Adobe if you  find these tips tops.
 Post messages, download the Feedback form, fill it out, send it back.  Play Go with me.
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Photoshop : Kai’s Power Tips & Tricks : 
#16  Algorithmic Textures Vol. 2
 From Noise to Nice

Why?  
Textures are a staple item in your  Photoshop arsenal. 
Often scanned real images are used, but there are many that can be generated directly in 
Photoshop algorithmically, which means at arbitrary size and resolution. Often you have such 
a degree of control that you can achieve very special custom effects which are hard to come 
by otherwise. Others can be tiled and thus generate huge textured backgrounds with a tiny 
tile.  
The point here is not necessarily replace the real thing, as a scanned piece of cloth versus a 
texture simulation, but that if you gain control over all aspects you may very well come up 
with something that is actually better, more suitable or more unique and artistic than a mere 
scan.    In any case, its a lot of fun...

What?
“Algorithmic Texture” means that we will generate step by step complicated backgrounds for 
any size and resolution, just using Filters and Image controls. Just follow the bouncing ball...

How?
1. File > New  Enter  600x400, grayscale, 72dpi... (a generous big size this time, although 
you can make it smaller if you are in a hurry and larger for serious projects)

2. You can’t create something out of thin air, but indeed it works if you start with thin noise. 
Goto Filter > Noise > Add Noise... and enter 999 uniform. Should look kinda like this.

                                         fig 1)  
                                                    Uniform Noise at 999

3. Now Filter > Blur > Motion Blur... set Angle = 90 and Distance = 45 gets you strips not 
unlike the Instant Aluminum in KPT #3.
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                                          fig 2)  
                                                Motion Blurred vertically

4. This will be the mundane starting point for some startling pix. So to try the first branch of 
texture families, make a copy of fig 2) via Image > Calculate > Duplicate , Ok.

5. Cloth like textures can be easily made by creating a second pass of the Motion Blur 
perpendicularly. So go back to Filter > Blur > Motion Blur.. and set the Angle =90, Distance 
stays at 45.

                                          fig 3)  
                                    Motion Blurred again, now horizontally

Now you will hardly see anything other than mellow mid grays, but let that not deter you. In 
fact after the Electric Aura KPT you might suspect that there are things hiding in here 
somewhere.

6.Lets do two things at once: colorize into the cloth category as well as bringing out the detail. 
First convert the monochrome image : Mode > Grayscale to Mode > RGB, it will be redrawn 
and look identical, although you now have 3 channels (R, G and B) instead of one. Since 
they are all identical at first, it looks gray, and bringing out the differences in each channel 
separately will at the same time allow us to colorize.  If you read the Colorization KPTs (#12 
and #13) you know that there are many ways to achieve this.

7. Lets try it in the Levels.. dialog: As the histogram shows, there are just a few shades of 
gray used, hence the spike in the center. Go into each channel and move the black triangle 
roughly to the left of the spike, then the white triangle to the right shoulder (the gray one 
remains centered between the two. In the example shown below, the gray triangle is already 
displaced to the left in the blue channel, forcing more shades to turn bluish and rendering the 
texture to look something like blue woven cloth.
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                fig 4) 
                  Levels... dialog: adjusting the gray range and tinting at the same time

                                       fig 5 a)

                                      fig 5 b)

                                       fig 5 c)  
         From Jeans to Shroud of Turin to streaky overdrive, its all at your fingertips

8. I supplied a few files in this archive.

With fig 3) on screen enter Image > Levels... and use the Load... button to try these Levels 
settings. Notice that because of the random noise the exact position of the spike will vary and 
therefore these settings are not exact matches of fig 5)

9. Note:  you can also click on the Auto Equalize button in the Levels dialog, (the contrast 
symbol in fig 6)

                                               fig 6)  
                                                    Auto Contrast buttons

This will find the left and right shoulder as in fig 4) automatically in all 4 channels, R,G,B 
and Master. You can also redefine the black and white points with the eye dropper (as you 
leave the dialog the cursor turns into an eyedropper, select your version of ‘black’ shade then 
click on the middle button

10. A few side directions you might try:  Do each with a Duplicate of the cross hatch fig 3. 
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and keep all the windows open at the same time to compare. ( A big 24 bit screen is great for 
stuff like that)

                                          fig 7)  
                    Find Edges with fig 3) then Levels to bring out the subtle detail  
                    Can be used for street map textures, crystalline growth,  etc. etc.

                                          fig 8)  
                     Oversharpen fig 3) using Filter > Sharpen More three times
                            can be made into nice bamboo and other textiles

                                          fig 9)  
                       fig 3) then Filter > Wind set to Stagger, left, then Levels

This looks great in large areas, rotated 90 degrees. It did in a pinch as a Tunneling Electron 
Microscope image, but can also be tuned horizontally into neat cirrus clouds!

                                        fig 10)  
                                                      Instant Star Fields!
Easy, after figure 1) with Noise 999 uniform, just use Filter > Stylize > Diffuse, set to 
“Darken Only” and repeat 3-5 times (via “command-f”). Lets you vary the density step by 
step... Very realistic 
Add a blur and colorize slightly.

Interesting variation, with the thinned out fig 10), reverse the Diffuse to “Lighten Only” and 
do that a few times. You can achieve all kinds of flakes and stucco (as fig 11) and leaves and 
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myriads of speckles. Each one is a perfect starting point to all the above treatments of course. 
Emboss it, Motion Blur, Find Edges....

                                          fig 11a)                             fig 11 b)  
                    one of a zillion Stuccos (embossed)  and DNAs (edges found)

In fact, once you get into the spirit of this you can end up with a hundred open windows with 
weird textures in no time.  On the CD Rom I will publish something like 100 textures and 
supply a full size 640x480 or larger sample you can use instantly, plus the algorithm on how 
to do it yourself.   If you have candidates for such textures, do send me a sample and the 
recipe. I will gladly add it to the collection and give you credits for it. Since I have been 
through several hundred of these by now, consider that I have seen most of the things that 
can be done with just 3-5 steps. It should be a little out of the ordinary.  Then again, if you 
downloaded the “Giger’s Alien Blood Soup” picture in all its ugly detail, it proves that t his 
can be taken to ridiculous extremes. There is NO recipe for that one. It stared at me after 
literally hundreds of steps and dozens of windows littered on the screen.    I will have a 
bunch of those on the disk, too...

But then there are also the simple nice ones that are just tastefully executed, such as this tri 
level motion blur with effective color treatments. The large version of this looks very cool.

        fig 12)  
fig 2) revisited, here Motion blurred at 45, 47 and 43 degrees and colorized with Curves
This is excellent over a full screen, then stencil out letterforms or logos

Well this was meant to be a One Minute Quickie, but got a little larger in the process. Oh 
hell...

Do send me your stuff. I want to get presents, too, sometime. It’s lonely out here sharing all 
day long on a one way street.  At least fill out the damn feedback form.      (There, that got 
‘em.)

Anyway, as usual, happy PhotoShopping,  find out the secret images hidden in your Mac. 
Share ‘em...
Make plenty of textures, because the next few KPTs will be on Compositing and you want to 
have stuff to composite with....!
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Merry greetings       Kai

Tell AOL, Compuserve and Adobe if you  find these tips toasty and warm and they make you 
feel cozy and fuzzy all over.
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Photoshop : Kai’s Power Tips & Tricks : 
#17  Secrets of Chops, Vol.3
Part 1a) XXXVII, Section 4 paragraph 0.8 
(you think I don’t know this numbering stuff is goofy?)

Why?  
Its quite simple: in the last chapter we had tons of textures flying around on the screen. Now 
you have one picture here and a background there and some logo in yet another image. How 
do you get them together, and cleanly...? This will talk about a whole bunch of ways to do it 
and include a lot of lesser known techniques to clean things up.  This could prove to be 
extremely valuable in your set of tools.
(“ He always says that. Everything he says is always really, really important. What an ego 
trip”)

ooh , tough crowd....  :)     Well, you be the judge.

What?
“Chops” are Channel Operations, those functions under the Image menu that you may have 
played around with before, more or less haphazardly. There really has not been very much 
information on this topic, other than self-referential descriptions a la “Multiply takes A and B 
and multiplies them...”

This is called “Volume 3” because KPT # 1 and #2 were about some of the Chops 
commands, even though that did not include Compositing. I do recommend, even almost 
assume, that you read those files. There is a lot of basic information and tiny tips which I may 
not get to repeat here in detail. If you like this at all, please refer to them as well.   

For download size reasons I also have to break this one into several chunks. While the overall 
topic is Compositing, I will meander through a variety of Channel operations first. The bulk 
of the Composite Command is in the second and third part of this document.

How?
Enough preambling ramblings, lets jump right in here.
I will  create a logo with a texture inside and a textured background. In the process I will use 
a whole bunch of chops and explain as I go along.

1. Load the file KPT infinity plain.mask provided as part of this archive. It is a plain black 
Infiniy symbol, which you can also create in most fonts with the key combination option “5”. 
(if you got this text in print form or not from America Online, you can of course do this with 
any  black shape and at any size/resolution.)  The provided file is 600x400

This is what you should have on-screen if you play along while you read this.   (and as 
always the disclaimer: this is not meant for light reading. Its more like a blueprint for a house: 
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work from it! Slap something together!  Sell it to others for ridiculous profits!      oops)

                       fig 1 a)  Plain black mask of the logo, here shown at 120x80...

                              fig 1 b)  ...and a portion at actual size 600x400

2.  The first Image > Calculation we’ll use has been a staple item throughout the KPTs: 
Duplicate.  We need more ingredients to create the elements in the logo.  At first it is a simple 
black shape.  Let’s give it some depth and curvature.   We need shading that follows the 
shape, but changes toward the edges.  Easy as π :
Image > Calculate > Duplicate, click ok.  This creates a new window named “Untitled 2”.   

3.  We need to create shading with this copy of the shape: Filter > Blur > Gaussian 
Blur...type in “9”.
Note > the effect of the blur is size dependent. If you follow this algorithm with a file half the 
size or 4 times larger (and it is the real power of the technique that you can do that!) you may 
have to change settings like the blur to get equivalent results. Use “Levels...” to see the 
histogram and check whether the Gaussian Blur has created a nice even distribution without 
gaps.

           fig 2)  Levels... Histogram,      top: before    bottom: after Gaussian Blur

In fig 2  top you can see that there are minute amounts of 14 gray shades, plus lots of white 
and lots of black.  These shades are inserted by the anti aliasing option in the text tool, in 4 
bits grayscale.
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                                              fig 3)   Gaussian Blur at “9”

4.  This blurred shape will be used a little later, but we might also mess around with it in 
various ways. First we will employ it to create shadow and highlight, similar to the technique 
in KPT #1 and 2, but with a kick...  We need two more copies for that: Image > Calculate > 
Duplicate , ok and again...

Note > No wonder I have a macro for this under the control-’d’ key.  Tip> Quickkeys lets 
you include the menu choice as well as the click on the OK button. You could also assign 
Shift Control D to another macro that does the Duplicate with the Invert option.

We now have three copies of the blurred shape.  One will remain, aligned with the plain 
mask, one will be displaced to make a shadow and the third will be displaced in the opposite 
direction to create a highlight.

Tip >>> When you get into this on a more regular basis (and you will) there is an important 
method to improve the logistics of handling the ever increasing number of windows and files.  
This is especially true on smaller monitors. The masks and other temporary by products such 
as all the windows we have open so far need not be seen at full size. Simply press “command 
- ” 3 times to reduce each window to a thumbnail sketch and then position them  somewhere 
on the side. You can even overlap them nicely so that you see just a bit of the image and read 
the title bar.  Its just a mnemonic reminder of what that window contains. Use the magnifier   
tool and click three times inside a window if you need to see its content at actual resolution, 
yet still contained in the small window.  Do try it..its very handy. 

5. OK here we go: the shadow. Take one of the blurred versions and use Filter > Offset, set 
to 9, 9 ... This will move the image over to the right and down. You could also just drag a 
selection marquee around, of course, but the advantage of the offset filter is a) the precise and 
repeatable amount and b) it features repeat edges and even better, the wrap around option, 
although we’re not using it just now.

6. Now to start Chop-ping...  Image  > Calculate > Blend...     The pop-ups will show the 
currently active window title for your convenience.  Click on one (doesn’t matter which one, 
at least for Blend...) and select the original clean black shape there.   Leave the destination as 
“New”
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                      fig 4)  
                             Blending the displaced blurred and the plain black mask...

                                      fig 5)   
                        ...yields a very nice curvature and slight cast shadow

The Blend function basics are explained at length in KPT #2....   It is actually related to the 
Add. command. Try Add with a scale of 2 to get the same results as Blend.  With Add you 
get the extra option of an offset, which shifts all greyscale values up or down, although I 
prefer to do such processing with Levels... or Curves...       The Blend percentage is a more 
immediate benefit.

7.  Now lets do the inverse steps with the highlight. Pick one of the two remaining blurred 
windows and use the Offset filter on it.   Simply add a negative sign to the numbers (“-9, -9”) 
to displace it up and left. Then use Image > Invert .

                                          fig 6)  
                                 The blurred shape now offset and inverted....
8. Now lets blend that with fig 5) !    
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                                       fig 7)   
                      The highlight and the shadow blended with the original shape

A very ‘depthy’ logo shape with a glowing white highlight and a cast shadow on a medium 
gray background.  And you can do it quite quickly once you know without hesitation what to 
do.

                                      fig 8)  
                                                     The result so far....

9. Now we have many options from this starting point. please keep this image around, we’ll 
use it later in KPT #18 as well.   With the ingredients so far we can achieve a bewildering 
array of results. Plain old experience will guide me, but the feedback loop is such that if you 
look at the results and think about what happened, it will make sense to you. It is only one 
more step or inductive reasoning to think of the desired effect first and back into the necessary 
technique, like little dominoes falling...   For instance:

10. Lets say I wanted a darker flat shape, not as flat as the plain mask, but not tubular either. 
The Image > Calculate > Multiply command can add in the darkness of the original blurred 
image, (in the window Untitled-2, but that may vary depending what you did.... It’s fig 3) 
above.)

                                     fig 9)  
                                                 fig 3) multiplied into fig 8)

A nice flat black shape with just a small bevel highlight. If you like it, continue with a 
duplicate...
11. Consider this thought: figure 6) has a nice soft glow to it, but it sits on a plain black 
background. You can add all parts of fig 9) to that with the “Lighter” command.  
Simply use Image > Calculate > Lighter and insert the appropriate window names (this is 
where it helps to see the thumbnail size windows behind the dialog...)
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                                fig 10)  
                                         Image > Calculate > Lighter...9 & 6

This can really be quite a pleasing effect. Very ‘depthy’ with slight roundness at the corners.

12. The concept behind “Lighter” is inanely obvious, pixel by pixel it compares two source 
images and picks the lighter one for the resulting destination image. The trick is to know what 
that does in real life and when to use it.  You might even create a second channel, which is all 
black and merely concoct a slight specular highlight to add back into the original via Lighter.

Note > This is ultimately what I strived for myself and would encourage others as a goal: to 
be able to think of a final image in terms of many (dozens or hundreds) small elements and 
contributions and then have a way to create each one by itself and bring it all together. The 
single hardest part for a novice with this algorithmic painting technique is to come across 
in-between sketches and identify the one tiny little attribute that is worth keeping around (and 
then know how to extract and apply that).  In the example just now, the statement “with slight 
roundness at the corners” would always raise a little flag with me and I’ll file that away under 
“ if I later want to, here is one with round corners I could steal...” I may even save it as 
“rounded corner mask”...(this is the reason to have optical or DAT storage where it is a 
non-issue to keep stuff around...) 

Tip >>> Mono grayscale masks are saved smallest in gif, fastest in pict and surprisingly 
Jpeg High can end up with larger files than either gif or pict. (it is optimized for 24 bit). Jpeg 
medium I cannot recommend, as the ‘mosquito’ artifacts around sharp edges are emphasized 
and in the context of mask use may propagate into final art. The effects can be akin to film 
grain...

Important Note >>> As mentioned earlier in the message folder: You need to realize that 
when you open a Jpeg file and resave it as Jpeg again, the compression artifacts will worsen 
through the multi pass treatment.  (This is not a Jpeg specific point, it applies to ALL 
non-lossless compression techniques)   Of course, merely viewing compressed images won’t 
harm anything. But if you intend to make several passes of change, do save only the last 
version in a lossy compressed format! 

“Lighter” is one of those things that did not even make it to the index of the manual, or is 
mentioned even once in the Official Handbook. The one line Adobe definition is on page 148 
:  “The Lighter command selects the lighter of the pixels”.    Well, I guess that’s why I am 
writing this in the first place.

Often times the related version “Screen” is more predictable, I’ll use that one later as well.

For now, lets forge on with the logoids...

13.  Lets say we are after a more metallic look. This is not the document to focus on that, but 
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let me mention that there are ways to make very realistic Gold, Chrome, Copper, Titanium 
and more purely within Photoshop.   I will go through one of these here now, but you might 
want to stick with it and try to develop the others as well.  I’ll point to the various off ramps 
as we pass by them.

The essential technique for metallics involves reflections and highlights suggesting the 
environment being mirrored in the glossy finish. (Rust and patina fall into other categories...)

The key to it all is to understand that there is really no such thing as a “Gold” color.  Where in 
the rainbow would you place it? Worse yet, where would you put Silver and Chrome?  All of 
these are actually collective terms for the range of shading that reflections will produce.  The 
physics involved can be quite daunting, but that need not concern us.   

Gold would be characterized by a yellow/orange/greenish tone that can tend toward white in 
specular highlights and toward darker browns in shady areas.  When I first puzzled over what 
makes gold gold the single most educational process was to scan in photographs of golden 
objects, such as the King Tut mask (thanks, Steve M.) and study what happens.  

One can use either the Arbitrary Map or the Curves dialog to create special highlit regions. I 
recommend that you do not simply take the last version just because you think its closest to a 
finished piece and then run Curves on that.  The process may include artifacts such as aliased 
‘raspy’ edges...

Note > it is important not to dismiss intermediate images because of staircase edges, or other 
problems. You can extract just the good stuff.  “Composite” will do exactly that!  Read on...

The perfect starting point is the gaussian blurred original, as in fig 3). It has all shades of gray 
available on a neutral background.  If we didn’t have it already I would have made one just 
like it now.  Since it may come in handy for other effects later, lets do this on another copy 
(Duplicate....)

14. First a quick treatment that can add surface bumps to get the hammered copper look.  
With the simple blurred image (fig 3) run Filter > Find Edges once, then Sharpen More twice.

                                   fig 11)  
                                            Edges, Sharpen gets neat bumps

The Electric Aura KPT file explained a bit more theory behind Find Edges and why it does 
what it does. To be able to predict better what happens you might want to read that.   
Now two more quick steps to tune this: Invert to make the center a highlight and 
Levels...click on the Auto contrast button or drag the black triangle to the right. Also, move 

Kai's Power Tips Page  149 Thu, Dec 7, 1995



the bottom white Triangle to the left “222”. This will  make sure that the center white 
highlight is not true white (some color work will not affect solid white or black)

                                 fig 12 a)  

                                        fig 12 b) 
                                   Levels adjustment will create higher contrast 

15. Now lets colorize it: First change from Mode > Grayscale to Mode > RGB
For more basics and theory on Colorization, read #12 and #13...on Colonization read the 
Columbus log book.  Actually, gotta give the guy kudos for one reported episode: the one 
where he asked “How do you balance an egg on its side?”  Nobody could do it. Then he 
simply smacked it on the table and it stood on the flat dented bottom. He said: “Anything 
seems easy after you are shown how to do it”   My words, exactly.  But I digress.

OK, In RGB mode go to Image > Adjust > Hue/Saturation. Click the Colorize button and set 
the sliders to get  copper or gold, somewhere in the Hue +25-50 range, Saturation 50-100 
and Lightness -25 to -50, as shown here. Season to taste.  Final adjustments later...

  

            fig 13)  
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                                        fig 14)  
                  The inner portion of the image is taking on a hammered metal feel

16 . So now we are looking at the quintessential Compositing task: steal the center portion of 
this metallic image and add it into one of the other backgrounds.

The Image > Calculate > Composite dialog  can do this very easily, but I am afraid you will 
have to download and read part two to find out.    Wasn’t meant to be a cliff hanger, but I 
guess it turned out to be one.    

Merry greetings       Kai

Tell AOL, Compuserve and Adobe if you  find these tips cruel and unusual. 
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Photoshop : Kai’s Power Tips & Tricks : 
#18 Secrets of Chops, Vol.3b
Compositing: Scissors & Glue of the 90s

Why?  
Because I better continue where  #17 left off, or I have an ugly mob on my hands...
In other words, you have to read the first part of this in #17 to really make sense of what 
follows.

So Now What?
1.  To refresh some basics mentioned in KTP #1 and #2:  The windows that show up in the 
pop-ups have to be the same size and mode (I.e. not Bitmap or Indexed)!  Since we are 
working with duplicates of the original shape here you will see all windows in the pop-ups.  
If you are trying to include some other image (e.g. a scanned texture ) be sure to make it 
identical in size and mode. You can use Image > Resize to stretch other images, or Image > 
Canvas to position it in its original size in a window ‘canvas’ of another specified size

Tip > you can use Canvas Size to quickly add a border around an image. Make the 
background color black and go to Image > Canvas Size... add 20 pixels to height and width, 
click Ok and voilá, a slightly larger window with a clean black border. And it contains the 
entire original image.

2. The key to Composite is the center pop-up, the “mask”. It defines the outcome of the 
compositing action.   Note that it is possible to use an RGB file as a mask, but for predictable 
results I suggest that you use a grayscale image.

>>>  Here is the quick summary of it: 
Wherever the mask is black, the background image (lower pop-up) is used, 
Wherever the mask is white, the foreground image (upper pop-up) is used. 
Shades of gray will use corresponding percentages of fore- and background.

A solid flat ‘128’ gray as a mask would result in an even mix (identical to 50% Blend by the 
way) between fore and background images.

Here is a table with examples of the effects the mask can have:   
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fig 1)  the Composite dialog in visual form: three sample setups and results

Note > if what you have to begin with are the complex Foreground and Background images, 
the first two results at the bottom could not easily be produced with alternative methods such 
as Paste!

Also note that simply assigning the mask to 2 of the 3 pop-ups yields simple yet often used 
results. In fact the “Big Letters composed of Small Letters” effect (center example) is often 
requested.  You might want to play around with some of those combinations for a while.

3. Let’s see how this applies to the current example:

                     fig 2)
             The Composite dialog setup to composite the metal into the background 

Where the plain mask is black (the actual shape itself) we get the metal, where its white 
(everything else)  we get fig 7)  (as found in KPT #17, part one of this document).   Since the 

Kai's Power Tips Page  153 Thu, Dec 7, 1995



mask is just black this is a simple ‘cut composite’. Still very useful.
Note > Don’t forget to set the Channel pop-up to “RGB” in order to composite the full color 
image!

 fig 3)  The result so far: a very clean composite of the inside shape with metallic texture 
sitting on fig 7)

                                                 fig 4)  A close-up of fig 3)

4. Very important is the fact that this really is a very, very clean operation. (and we are doing 
this in a tiny size really. Critical work might be at 4,000 x3,000 instead!)  Have a look at this:

Anti-Aliasing!

                                           fig 5 a)                               fig 5 b)     

 

                                          fig 6 a)                               fig 6 b)  
                anti aliasing the mask yields automatically anti aliased composites

Crux Note >>> This simple fact is really very important, because it isolates the 
anti-aliasing step from the other operations.  One can spend extra time to clean up 5a to 5b, 
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knowing that one is abstractly really working on 6a versus 6b, but without actually messing 
around in the artwork !!   Compare that to brushing and blending and blurring and whatever 
contortions people are going through to get 6a to look like 6b.    

Also important note >>> the cleanup step from 5a to 5b came via the anti-aliasing routine 
in the text engine of Photoshop.  If  the initial logo shape had been scanned or sketched 
otherwise, the simple 2 step procedure outlined in KPT #4 (“Cleanup faxes and scans”) 
should be applied.  It will effectively take a “5a-like” hard edged shape and smooth the edges 
to look just like 5b.

In fact I consider it such an important tool and must-know for any Photoshopper that I would 
re-iterate the process here now. But as luck would have it we’ll need the very same technique 
anyway for one of the cooler tricks of compositing.

5.  First lets create another metallic version of the background. Lets use a copy of the first 
composite we made ( fig 7) in the #17...)  the one that looked like this:

                                        fig  7)  
                                   the blended version before metal treatment...

The trick is to find a couple of areas that are to receive bright highlights. With the file from fig 
7) open, go to the Image > Adjust > Arbitrary Map dialog.  if you leave the dialog and roam 
around the window for fig 7) you will have an eyedropper cursor. note where the little circle 
in the ArbMap falls.  (For a full explanation of the Arbitrary Map dialog, read KPT #8 ...)
 
6. You notice that around x=110 and 120 are the specular highlight areas. The picture below 
shows the dialog immediately after the Smooth button was used. In order to get it to look like 
this you would have to draw a horizontal line at 110 near the very top, maybe 10 pixels wide, 
and similarly at 120, not quite as high up....and also force the last shade on the right at 255 to 
0!     Then Smooth.
In order to make it more exact in following this, just load the Silvery.ArbMap file via the 
Open button right in the Arbitrary Map dialog.

Kai's Power Tips Page  155 Thu, Dec 7, 1995



               fig 8)  
                                         the Arbitrary map to turn silvery...

It ought to look like fig 9) afterwards:  silvery sheen with nice positive curvature... the 
teardrop shape is supposed to look like it is raised.  

Notice that the logo shape itself got mangled in the process, including all kinds of ugly 
artifacts near the edges.  This is precisely what I alluded to earlier: a) it is hard for a novice to 
focus on the inside shape and not get distracted by the colorful yet brutal events elsewhere in 
the picture.   b) even though the effects resulted in harsh aliasing and pixellation, once you 
know the tools, you can rest comfortably knowing that you can extract what you need any 
time.  Life is like that, too. Stop worrying.

7.  The metallic silvery sheen should look like this: (including the edge problems)

                         fig 9)  
                                   actual size chunk of the silvery inside shape

Again, looking at fig 9) the first impulse might be for some to grab the blur or the smear tool 
and start “cleaning” up the edges.  First of all, in the algorithmic painting technique there 
should never be any need to do that, except for rare special touch ups (like adding a highlight 
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dot in an eye or something)  and in almost all cases including this one it wouldn’t work very 
well anyway. You could tell in an instant that someone had mucked around with it...

I purposely used a fairly extreme method here to create aliasing (I could have done the silver 
sheen background on an earlier grayscale version before the gold was added...) because there 
are a number of operations that do create them and getting rid of them is an important part of 
this document.

8.  If  we used the same technique as before, Composite with plain mask, sheen and metallic 
as fore and background, you would find that the edge problem will look like this: (you don’t 
have to do this)

                               fig 10)  
                               dirt, or as the English might say, “naughty bits”

The BIG Note >>> The key technique to deal with this (and it happens a zillion times if you 
spend a zillion hours with this stuff as many of us do)   is to modify the masks.

Here  the mask is the black shape that cuts out the gold from a previous document. If we 
enlarge the mask just a bit it will steal a little more of the gold image and in so doing we will 
superimpose it smack over the aliasing problem pixels!
In a case where the two are not necessarily touching one could use two masks, one to cut out 
the gold and another to cut out the silver background. Then composite both of those onto yet 
another third image, which could be for instance merely solid black (or an otherwise 
unobtrusive color, or even a tiled cloned area of the other images...) It seems cumbersome, 
but those 3 steps can yield extremely complex and ultra clean pictures and it is still light years 
faster than any manual touch up, or trying to rope in the parts via selections and then pasting. 
More on that later 

9.  Make a copy of the original plain mask via Duplicate and then run Gaussian Blur at, say, 
4.. . .

                                            fig 11 a)                               fig 11 b) 
                                       Before and after the Gaussian Blur filter

What we need to accomplish with this is to add more transitional grayshades to the mask, so 
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that where it used to jump from black to white, it now steps through dozens of shades. This 
is only the preparation for step 2: with the Image > Adjust > Levels... dialog we can force 
those shades interactively to become black or white !   (The punch line of KPT #4)

Big Deal >>> That lets you control both the size and the sharpness of the edge ! And it does it 
in realtime so you can judge by trial and error. 

10.  In terms of growing and shrinking masks, here is the effect:

   fig 12)  
                   A blurred mask can be shrunk/expanded in the Levels... dialog

The way to do this is to move the black and white triangles inward (The gray one will then 
always follow along centered).  If you set the triad roughly as shown here you can observe 
the two rules:

a) the distance between the triangles will determine edge sharpness. If you move much closer 
than shown here, the edges gets raspy and stairsteppy , any further apart and they get mushy 
and blurry. Simply watch the edge and move a little too far in either direction, then settle in 
between...  Life is like that, too.  Simply watch the edge and move a little too far in either 
direction, then settle in between...

b) the location of the triad of triangles (try it) will determine the overall size of the mask. You 
can blow it up at will or shrink it .  The range here is determined by the initial amount of 
Gaussian Blur.
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Notice that the center setting can be close to identical to the pre blurred original shape of 
11a)!!! In fact this makes it clear that you can ‘grow’ the mask from 11 a) in absolutely 
minute increments, almost sub pixel fine control  (much finer and more realtime than things 
like magic wand tolerance settings)

Kind of important explanatory note >>>  It is operations like Levels... that I greatly prefer to 
do with black mask shapes on a white background.  In that I differ from the nomenclature and 
convention of Photoshop, which likes to think of a mask in original photographic ‘frisket’ 
like terms: the black parts of a mask are obscuring the light and the white parts let it shine 
through. This is why in the Composite dialog the black part would be referred to as the 
‘background’ image, exactly opposite to my way of using it.  I tried to change over just to 
synchronize on the names and to lessen the possible confusion factor I may introduce to 
others, but with best intentions I find myself time and time again gravitating back to black 
shapes for my masks.   It may be less Photo-like, but it is the Mac way to think of objects on 
paper background, while white shapes on black look “inverted” to me.   It is ultimately of no 
technical consequence and does not affect the process or quality one bit one way or the other, 
but many people before me have tripped over this and I felt it necessary to state it once.

11. The mask shape we need here is slightly larger: move the black triangle to ‘130’ and the 
white triangle to ‘160’ which is slightly to the right of center  (the gray triangle’s ‘1’ position 
is at 127, mid between 0-255...the 8 bit range of grayscale images)  (I cherish the thought of 
seeing 12 or 16 bits one day)

                            fig 13 a) 

                            fig 13 b)  
The initial metallic gold and silvery sheen files become the fore and background of 
Composite...
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                               fig 14)  
and the larger smooth edge mask creates this very clean combination...(compare to fig 10 !)

Quod erat demonstrandum...
There is lots more still, both about masks and compositing, as well as Channel Operations.  
So part 3 is coming right up....go get it.

I hope you don’t find all this overly confusing and complicated.  It isn’t really, once you get 
into the swing of it.  The feedback files I have received in the last 6 months do express that. 
Many people have gotten to feel much more comfortable with the techniques after a little 
while.
Plus, I think Albert said it rather succinctly: 
“Things should be made as simple as possible, but not simpler!”

have fun,   Kai

Please tell AOL, Compuserve and Adobe if you found these tips, but then you lost them and 
they are nowhere to be found.  Maybe they can help you look.
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Photoshop : Kai’s Power Tips & Tricks : 
#19 Another Chopping Spree, Vol.3c
Close to the Edge, n’ stuff...

Why?  
There is so much more to do with channels and compositing, it isn’t even funny!  As most of 
you know by now, I am in the process of doing this whole tips thing on a CD ROM with 
LOTS of images and LARGE ones at that. You will see there among literally hundreds of 
‘final art examples’ just what bewildering variety of wilderbeests can be created with the old 
Chops... and when I scroll through them by the dozens I am recalling nearly 5 years worth of 
channeling, tunneling and meddling.  Well, as some of you have found out by looking at the 
more complicated examples, I haven’t spilled every secret yet. But I’m willing to part with a 
bunch more...

Whenceforth?
Lets do some more stuff with masks.   The last time I used a plain black mask and shrunk it 
slightly to steal only the clean insides of an area and that’s certainly a staple technique that can 
yield extremely clean edges.  But there are a number of extensions to the theme.  I will not 
build a whole texture thing from scratch here this time and concentrate on a variety of 
examples without necessarily  making you follow them step by step. We’ll cover Difference 
and cleaning thin lines and other goodies as we go.

1. A typical technique that people use because it seems obvious is to use Select > Border to 
create an outline border region which they then blur and such....   This can have problems 
associated with it! And they can be avoided with a bit of masking Chops! 
Example:  If you do a border around an area, here at 8 pixels, try to use a 50% blend across 
it, or simply an Image > Map > “Invert” and notice the little jaggie artifacts that happen:

                                          fig 1 a)                                  fig 1 b) 
                            Using Select > Border may not work as you expect it to

This is because Border specifies an implicit feathering at the same time!  So what looks like a 
normal region of say Border 6 is at the same time extending 6 pixels feathered in and out....

2.  Note > You might actually remember this artifact and exploit it for some pretty cool 
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‘crystalline growth” type effects... It happens when a feathered selection meets with a 
constant operation at some angle. Just feather a circle at 64 and try various blend/invert 
operations, then Levels/ArbMap/Curves to bring out the details.

                                    fig 2) 
Exploit the artifacts!  Live with your troubles!  That missing leg could be a boon!

3.  So here is what we obviously were REALLY after and got 1b) instead....:

                                       fig 3)  
                      The real MacKai version of 1b), this time done with Chops.

4.  Here is how to do it.  Make a duplicate of the black mask (1 a) and blur it once, just a 
little. Then run Find Edges over it and invert. (In Photoshop 2.5 don't invert).  With a black 
shape one white background this amounts to an edge extraction. Looks like this:
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                                      fig 4 a)                                      fig 4 b) 
Find Edges gets a clean outline, which can be further transformed and blurred...

4 a) could be used as is for a hard edge effect. In order to get fig 3) we simply G. blurred 4a) 
some more.   Now for the Chops part:

It concerns one channel operation we have used without much explanation a few times: 
Difference.

5. If you take two full color images (of the same size) and run Image > Calculate > Difference 
you will get nothing more than one hell of a colorful mess.  In such a random way many 
people have toyed with the chops functions and dismissed them as less than brilliant for ‘real’ 
work.

Au contraire, Claire, as we probably proved many times over around here.  The way I like to 
think of Difference is to use ‘any image at all’ in one source and the second one is a “selective 
inverter”.  Just like Image > Map > Invert inverts the whole window or selection, you can 
invert just like that with “Difference”.   The rule:  “whatever is solid black in the difference 
channel will be inverted, whatever is white will be left alone, whatever is gray in between will 
be inverted proportionally...”  
Just look:
      

                                fig 5a)  
                                                 Source 1: Any Image...

                                fig 5b) 
          Source 2:  a grayscale image designed specifically to invert with its black areas
     

                                fig 5c) 
                        The Difference between them, PLUS an Invert operation
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Fig 5c) is exactly the same as 5 a) except that all areas black in 5 b) are inverted.
For the techno dweebs with hacker backgrounds & pencil holder dreams, this is kind of a 
XOR bit blit, except it works in 8 bit continuous grayscale. It can yield GREAT effects.   The 
point is, you can ‘think’ about the Difference channel as an invert-by-choice tool.  This what 
we did above for fig 3). Simply use 4 b) as the invert channel in Difference (Source 1 and 2 
are exchangeable in Difference) and 1 a) in the other, out pops the desired fig 3)....

6. The edge stuff as a mask (or as a Chops ingredient like we did just now) is quite useful, so 
I should add a few items on how to improve the looks of that.

                                fig 6 ) 
                                       how to get an ‘edge only’ Chops tool....

In previous Chop procedures we kept around duplicates that were blurred and displaced and 
subtracted and blended and clean sharp ones, shrunk, etc.    Well, add “outline” ones to that, 
because they add very cool effects or can cleanly lift off a shape from a texture, etc.etc.

To get 6 ) we simply took a solid black 5 a) and ran Find Edges over it. (Often a little Blur 
More before will smooth things further.)  Now to get much larger and more blobby is 
obvious.  But how to thin and smooth those lines is NOT..!

7.  The technique we used to clean shapes many times now, G.Blur and Levels... as outlined 
first in “how to clean up a fax or scan” and re-iterated in the last couple Chops docs works 
really extremely well on black solid areas. you may have tried it on thin lines before and ran 
into the following scenario:

                                     fig 7 a)  
                                      A thin line in bad need of some cleaning

You have a line, be it from that famous fax or scan or you somehow drew that yourself. Now 
you apply CleanUp 101 only to get a peculiar mixture:
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                                      fig 7 b)  
     The middle looks as needed, but there are clumps and drop outs! What to do....?

The trouble is that the technique relies generating transitional shades from black to white 
which later in Levels get converted to smooth edges. With thin lines though close neighbors 
will blob theirs together and others will thin out prematurely.  Luckily there is a little known 
filter ready to be applied here: The white choke Filters > Other > Maximum set to 1 pixel ! 
Try it... its a minor miracle for these situations!

                                      fig 7 c) 
                            MUCH cleaner process with the Maximum Filter....

It is unfortunate that Maximum works in integer pixels only, but you can tune the results both 
by a slight pre-blurring and a post levels treatment. Thin lines should be forever clean for 
you....

Note:  Incidentally, the Minimum filter chokes white from surrounding black....

8.  If you have a nice edge available such as fig 6 and you do a Difference with the solid 
shape 5 a)

                              fig 8 a) 
     A Chop Difference involving the edge outline creates more complexity : cleanly...

To get more complex and subtle artwork here is a quick example on how to apply it all 
together. It’s a little advanced and assumes you read and know all the previous Chops docs...

Add a gradient to the artillery: simple blend tool coolness.
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                                 fig 8 b) 
                                                   a plain gradient blend

Then we use the solid shape as a mask for a composite with the gradient, and after that the 
outline edge as a mask for the Inverted gradient. Looks like this:

                             fig 8 c)  
     The gradient shining through inside and in the edges, in opposite directions

                             fig 8 d)  
                                              Works in color, of course...

...but for color work remember to keep one Difference channel in grayscale to get predictable 
results.

In fact I suggest to separate the shape work from the hues and color stuff.  Operate on your 
shape and composition in grayscale (3 times faster, too) then add colors and textures later. 
There certainly are enough ways to get color.... :)

9.   I just saw some people struggle the hard way with this so here is a little tip:  If in an 
image such as 8d) you wanted to invert the image, i.e. on a white background, yet keep the 
colors the same, simply realize that there are two Invert options that can be separated: Image > 
Map > Invert will give RGB opposites for every pixel, thereby inverting all colors as well.

    
                              fig 9 a)  
                                                    Inverted all the way...           
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But there is one that deals with JUST the color and will leave all monochrome shades alone!  
It is the Hue control and that can shift the colors right back where you had them before....:

                               fig 9 b)  

                              fig 9 c) 
         simply go to Image > Adjust Hues... and “Wrap the color wheel 180 degrees” 

So remember : After “Invert “ you can get the color back with Hue 180 degrees” (left or right, 
those ends meet..)   A hell of a lot easier than to pick up the black background and try to fill it 
somehow...

And now with the new Chops Difference technique you know how to pick up any inside area 
and selectively invert just that.

There are still umpteen tricks in the bag.   Don’t be sad. Isn’t it a better feeling that there ARE 
still some things left to be found rather than standing at the brick wall dead end?  I am happy 
every time I run across yet another little unknown phenomenon.   Some include my wife 
even....

And so we shall go on.

have fun,   Kai

Tell Adobe and AOL and InterNet and CompuServe and SuperMac and BMUG and BCS and 
MacWorld and MacWeek and MacUser and  your neighbors granddaughters gym teacher’s 
niece-in-laws pool man that you read one more of them things.
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Photoshop : Kai’s Power Tips & Tricks : 
#20 Composing Atoms out of Quarks 
or Pictures in an Exhibition 

Why?  
After all these tips you are still asking why?  Well, wait till you see it, it’s cool.

What?
Ok,  the premise here is very simple: create an image that consists of other tiny images and 
better yet, tiny copies of itself!    The basic technique is real obvious and most of you 
probably played with it at one point. But there may be one or two details that can further your 
fun factor.  Many variations on that theme, too. Let’s jump right in:

1. Load yourself an image. If its not grayscale, convert it to grayscale (we’ll do a color one 
later)
I have the trusty Kai image here.

                               fig 1)    
                                                   A grayscale Image....
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2. Let’s go for the full effect with recursion: We’ll paint my face out of thousands of teeny 
tiny little Kai faces....(just how many is up to you...)   So, first make a copy (Image > 
Calculate > Duplicate) and then Resize that (Image > Image Size...)   to a tiny little version...

Note :  Please do not confuse “Zoom” with “Resize”.   Zoom is merely a quick and dirty 
close-up look to check pixels up close. Image Size will interpolate smoothly and do what’s 
called ‘Resampling”.  Use Zoom In to apply a blur or other tool on a magnified view, Zoom 
Out to make the window smaller and drag it out of the way and Image Size if you really want 
a larger or smaller image...   

Here is my little tiny face (Resized to something like  21x27 )

                                                        fig 2)  
                                                               microKAIsm

Press “command-a” to Select All of the tiny Kai image (fig 2) and then go to Edit > Define 
Pattern (second from bottom, grayed out until you have a selection...).   Nothing will happen  
yet.

3.  Now comes the critical step: change from Mode > Grayscale to Mode > Bitmap. During 
the transition a dialog will come up:

                  fig 3)  
                             Setting the parameters for recursive pattern pictures

The point of the conversion is to click on the “Custom Pattern” choice, which will use the 
pattern we have just defined, namely the tiny  pic.  The way it will do it :  It will take a region 
of the large image equal to the size of the pattern, determine the average brightness and then 
lighten/darken the pattern in one bit mode and substitute it for that section.  

This can be simulated in  Image > Map > Threshold and you can test whether the Pattern has 
enough range of shades available to do the grayscale approximation (a pattern consisting of 
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just some black dots isn’t too great.  Suggested is to blur the pattern or use a gradient blend 
over it...)  Tiny AL is just fine: in threshold you can see that it can go from solid black to 
solid white with plenty of steps in between....

Now the other key point is that it helps a great deal to multiply the output resolution!  Think 
of it this way: The big Albert is, lets say, 200 pixels wide, the tiny one 20 pixels. That means 
you can fit 10 of them horizontally and maybe 13 or 14 vertically.   Each one, though, will be 
a single-bit approximation of that area and all in all it will get very very “blocky”.   By 
changing the output resolution in the pop-up near the top you will create a much larger output 
image (they will always result in Bitmap mode, meaning 1 bit black and white...) utilizing 
many more of the tiny pattern pictures in the process.  
I suggest that you multiply the output in multiples of the screen resolution of 72 dpi: e.g. 144, 
216, 288 and so on. 

The reason is simple: Imagine a chess board at 72 pixels. If you are trying to scale up that 
picture you can make each square exactly twice the size horizontally and vertically and you get 
an exact chess board again. 4 times the size would be 288 and still an exact version of it. If 
instead you simply typed in 300 dpi then something will have to give somewhere. A scaling 
error will appear, aslthough Photohsop does a very nice job in trying to distribute the error 
among all the pixels. Still, it is intrinsically cleaner to choose 288 than 300. Note: this is the 
same as the “4% reduction in the Page Setup ‘options’ dialog...and also applies to 
resampling... go for integer multiples of all numbers whenever you can conveniently do it)
Thus, ‘720’ or ‘1440 ‘ will yield truly excellent quality in gigantic size.  If you apply this for 
a serious project (and you will) do give those higher output settings a try. You may end up 
with a 5 or 10 (or more) megabyte file, in single bit (!), but it’s clearly worth it.   

Here we have set it to 288 dpi.   

4. Ok now as soon as you click ‘OK’ it will happen all by itself.  And here is what it looks 
like (the window would be in 1:8 zoom ratio at first (!)  

                                fig 4)  
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8 times Zoomed Out: an almost reasonable grayscale approximation of the original image...

...but... what looks like little square dots here ... is actually every time a tiny copy of the Kai 
image itself!  Zoom in eight times to really see what is going on!

5.  I can’t paste the huge real result here, put I can show you a detail area: 

fig 5)  
Close-up Zoom:  here is part of the face, eyes and the nose composed of about 300 tiny 
Kais....
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Pretty neat, eh...?     
Needless to say, since this is a single bit result, it prints pretty well even on a plain laser.

6.  Here are some variations:
How about a title, word , company or product name composed of teeny other words or 
letters...? This has been done before in many ads and now you can do it too. 

Example:  A large version of the word “Art ?” (at 1024 size) composed of tiny copies of the 
words “This is not art”  (subliminal truth in advertising)

                                              fig 6)  
The tiny pattern: 4 words, blurred in order to make it easier to create 1 bit gray shades...

                            fig 7) 
The large image: One word. Real size: 1024x768x72dpi, notice the zoomed in rectangles
    
After conversion at 720 dpi the file is 10240 x 7680 pixels in one bit. (!) That’s 9.8 megs, 
although it compresses very well.... At 1:7  Zoom-out it looks like this:

                                    fig 8)  
        Here is a small part of the final Pix ‘n Pix effect, notice the zoomed rectangle

and at full 1:1 range the tiny chunk inside the period under the question mark looks like that:
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                       fig 9) 
                         This is it at full resolution.. You can see how the pattern is 
                            thinned or fattened to create the gray shades needed...

If you set it up just right, you can even get effects that cleanly  modify font boldness (The 
main image should then be toned down in Levels... to eliminate solid black & solid white)  
See final “Bye” below.

7.  A little tiny radial gradient is really well suited, too:

                                                       fig 10)  
                                tiny pattern with plenty of shades to modulate....

You may have already tried the “Adobe Patterns” some of which came with PS 2.01 for these 
conversions.  They are EPS postscript patterns, but I often prefer more blurry ones created 
directly in PS.   It is easy enough to make your own.   Many, many variations.

I have also had good luck with color conversion: Here are the steps (no sample pix..way too 
big..)

a) Take an RGB color image and go to Mode > Split Channels.   You get three grayscale ones 
called image.R,  image.G  and image.B  
b) Define your small pattern
c) go to each r/g/b window and use Mode > Grayscale to Mode > Bitmap... setup the output 
res as needed.  
d) go to each r/g/b window and now use Mode > Bitmap back to Mode > Grayscale.  

Note:  if you are trying to end up with a screen size image, you can use the “Size” option in 
the ‘Bitmap to Grayscale’ dialog to shrink the image. If you say ‘2’ your bitmap image will 
come in half size grayscale, ‘4’ will be quarter size...    With that setting of ‘4’ it will take 
arrays of 4x4  1 bit pixels and average them to a resulting single grayscale pixel. 
It’s a nice way to get grays back from the single bit image and have more manageable sizes as 
well. You don’t really want to convert a 10000x8000x1 image straight to grayscale at 1:1, it 
will needlessly become an 8 times bigger file without any more information in it. Set the size 
to 4 or even higher to get a small true gray image....

You can nicely set the ‘Gray to Bitmap’ at 72 In and 144 Out, then set Bitmap to Gray at size 
“2” coming back to the original image size....

e) Go to Mode > Merge Channels, select RGB and the three images should already be in the 
pop-up (or else pop them in there)...There you are, pix ‘n pix in full color.
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8. Needless to say its fun to try that with splitting into HSB instead and maybe just treating 
the Hue or Saturation channel with some patterning.    (Too bad I can’t upload more color 
examples) 

 

Have fun!
Don’t take it so seriously!
Play around!
Then when you got something good, take it immensely seriously! 

Tell all the usual targets about your favorite tips. Tell me which one that is, too.

P.S.  As some of you know, I was bitten by a rather obnoxious virus. The doctors say it was 
likely contaminated food around the time of my Europe trip (I may never eat there 
again...lol). I am climbing out of the hole, though, it ran its course and I am just a bit weak 
now. This KPT is proof that I am nearly back to normal.  I had to pass on Japan, Siggraph 
and Macworld though.

Some of you should still send the feedback file in. I have such fun finding out what all 
happens out there in the real world....  e-mail to kptsupport@aol.com or kai@aol.com. 
Works great. I have mail from Tokyo to Vienna now...              greetings ..Kai
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Photoshop : Kai’s Power Tips & Tricks : 
#21 TilinggniliTTilinggniliT
Tiles in Style

Why?  
Some of you have resisted getting into tiles. Maybe its the grimy stuff in the grouts 
in-between or who knows why.  You are about to try it and like it.  

What?
Tiling has been around as long as planes to infinitely tile, about 13.8 billion years.  All it 
means is a “repeated pattern”.  Photoshop has a very basic rectangular tile feature, which is 
well explained in the manual. I will try to point out a few interesting patterns and 
modifications to try....

How?
Did you hear the one about the Insomniac Agnostic Dyslexic..?
He was up all night wondering whether there really IS a dog....

So much for complete non-sequiturs. Got the humor out of the way. Tile time.
1. Make a tiny window, use even numbers: 30x30, grayscale.
2. Use the gradient blend tool and drag across the whole window diagonally.

                                                    Fig 1)  
                                                 the tiny pattern for tiling...

3. Use ‘command-a’ for Select All, then go to Edit > Define Pattern.
Note: with a rectangular selection, Define Pattern is grayed out
4. Make a second window. Large, say 400x300 or larger.
5. Command-a again and now go to Edit > Fill...

             fig 2)  
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                          The Fill Dialog... click on “Pattern” to create a tiling

6.  Say Ok and there you are. The large window is tiled full of the little tiny pattern.   This is 
all old hat and you knew all this anyway.

                                     fig 3)  
                                                     basic tiling in action

I, for one, have a QK macro to go into Edit > Fill and use pattern at 100% to tile.  Its a little 
faster if you do it repeatedly...

7.  You might play around a little with different parts of the gradient to vary the tiling. The 
upper 12x12 pixels in the tiny window get a nice dark background for light titles or text.               
And so on...

                                    fig 4 a)                        fig 4 b)  
                            A different section of the tile yields a whole new image

Tip>>> If you want to save the tile for future use, you should realize that the marquee will 
vanish immediately after you select Edit > Define Pattern and the region is deselected.  It is 
therefore advisable to command-c “Copy” it first (command-n, return, command-v will put it 
quickly in its own window). No biggie,  but it helps.

8. Another variation:  go to the tiny window and double click on the gradient blend tool. 
Select ‘Radial’ instead of linear and make a little circular blend. Use command-i to invert the 
image (unless you switched fore- and background colors). We have done these things before, 
I assume you can follow...
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                                       fig 5 a)                     fig 5 b) 
                                   A little Sphere tiled into a larger window...

9. The new wrinkle now: select the small tile window and then go to Filter > Other > 
Offset...

                  fig 6) 
          move the image in the window exactly half way, with the Wrap option on

You have to set the Offset to exactly half the size of the window (which is why I asked you to 
use even numbers in step 1.)  The Wrap option is self explanatory and we use it nicely here.

                                                      fig 7) 
                                              The sphere wrapped halfway

10. Now Edit > Define Pattern with the new shifted image...

11. Select the large Window and go to the Edit > Fill... dialog.   Set it to 100%, but Lighten 
Only !

                                      fig 8) 
                       Yeah!  Two layers of tiling are merging via Lighten Only...!
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The second shifted sphere tile is White exactly where the first one was black... so they join 
up symmetrically and create a new double tile. Cool, eh?   You better believe this has other 
uses.  Try even just the old Levels.. to create wider gaps and other cute variations.

Tip >>> If you don’t remember the size of a window but want to Offset it halfway, simply 
option-click on the size number in the lower left corner, next to the scroll bar.

12.  To change to another method, select the tile window and select just a smaller portion 
now. I used a 12 x 12 area near the bottom right. Edit > Define Pattern.   

Tip >>> After you start dragging press the shift key to force the marquee to be exactly 
square. Makes for better tiles to have them square, unless you want them at another ratio for 
effect.

13. Select the large window. Edit > Fill... this time select Normal mode, Pattern and 33% 
opacity!  
This will overlay a totally different pattern and blend it at a transparency level.

                                    fig 9a)                          fig 9 b)  
                                       Another way to do multi-layer tiling...  

This is now actually a triple layer tiling effect, although not a very imaginative one...  Each 
can also be done in a different color.

Try also to set the offset at a smaller number, say 5,5 and then you have 6 steps to shift back 
to the origin. Each can be tiled over the previous ones at a say 20% opacity...  

As usual, I just want to get you started. There is lots of virgin snow to explore!

Now for a more business-like task involving tiles: A background of a logo, embossed, at an 
angle, tiled

14.  Make a window of say 300x200, exact dimensions not important. (For serious final 
quality that might get much higher, although the tiling source one is not the weakest link in 
that chain)

15.  Type in whatever title, business name, logo or whatever suits your needs.
Here is the example:
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                   fig 10)  
                                 Select the Marquee area with Tiling in mind...

Note that the space on the right and bottom will determine how fast the logo will repeat 
vertically and horizontally...    then Edit > Define Pattern...

16. Make the large window in the size you need for your project. If it is just for screen 
presentation, that maybe 640x480 or 104x768 or 1180x870, but it could also be 3000x2000 
if you are doing big time stuff...  There are more steps involved. Stay in small manageable 
sizes until edge sharpness and ultra smooth blends are really required.  Here I intend to go 
through an Emboss and Rotate still, so it might as well start fairly low res... but it highly 
depends on your project and your set-up, too....

Here is what I got...:

                                     fig 11)  
                  plain tiling, first pass...a 640x480 window shown reduced

The simple tiling yielded several problems. The logo is cut off on the right and bottom...

17. To fix that we can simply go to the Tile window and marquee I slightly smaller 
area...define and fill the large window again to see how it works. A couple of tries and you 
should get it...You could compute it, but what the hell....trial and error is such fun.

Now we WILL compute something though:  I much prefer a staggered tiling and the way to 
get it is to select the second row and use Filter > Other > Offset with Wrap, horizontally only. 
But you must know what number to plug in there.    
18. Turn on the Window > Show Info windoid (I routinely move it underneath the tool 
palette on the left since that vertical area is already shot, so to speak...).  What we need to 
measure now is the number of pixels from peak to peak of the tiling. Its Frequency...
Note : the units shown in the Info windoid can be set in the File > Preferences > Units dialog 
and they must be “pixels” for this to work...
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                fig 12) 
Dragging across with the marquee you can read the distance between any repeating feature

19.  Here it is 214 pixels.  Select the entire second row, go to Filter > Other > Offset and 
enter exactly half that number  (107) for horizontal, ‘0’ for vertical, wrap option on.    Of 
course you might just drag a part of the second row and get it so so, but this is actually so 
damn fast and guaranteed to work on the first try, that I bet it’s quicker almost every time. 
Save your trial and error fun for another day.

                                  fig 13 a) 

                                  fig 13 b) 
                   Shift rotating the second row for a non rectangular tiling effect!

20.  Now in order to tile the whole window in staggered rows, you could of course select the 
entire width and include just the first two rows, Define, etc...., but there is a little known 
feature in Photoshop that makes this ‘in general’ even easier...!   Any Tiler or Tilee should be 
aware of this one:

                                     fig 14)  
Special Photoshop magic: it auto computes the repeat frequencies in any repeating pattern!

What it means is simply: select an area definitely larger than the repeat frequency and define it 
as the pattern.  Photoshop will reduce the redundant parts all by itself and create a smooth tile. 
!   Wow!

Note : this will ONLY work if the repeat pattern is bit by bit the same. If you had run an 
emboss or a blur over this it may be just ever so slightly varying and the auto-tile won’t fly. It 
will then take the literal marquee size...

Kai's Power Tips Page  180 Thu, Dec 7, 1995



21. Now we have the staggered effect as desired...   I would probably continue with a 
Duplicate of this image, since the plain one may come in handy for Chops stuff later...   :)

                                     fig 15)  
                                           A non rectangular tile pattern....!

22. Now for a quick treatment: Blur More, command-f (repeat filter) twice..., the Filter > 
Stylize > Emboss. Set to 135 degrees (clean angle) and height ‘1’.   Should look like this:

                        Fig 16)  
                                Embossed logo (only one shown at actual size)

23. Since I want to overlay other text over this background, I prefer to  tone it down first. 
Note that the slightly blurred look is intentional. you could Sharpen or Unsharp mask it 
afterwards, or not blur as much before hand.  I do recommend at least a 1.2 Gaussian before 
any Emboss though, or you’ll never get rid of the ensuing jaggies... I also greatly prefer a 
low Height setting of ‘1’...

             fig 17)  
 Toning it down in Levels... :  Move the middle gray and the bottom white controls...

Tip >>> Emboss and a few other functions can generate a 128 Gray shade on which the 
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cursor will not be visible!  If you need to work a lot with the image and that might be 
distracting, simply go to Levels.. and move the gray triangle left or right a few pixels... 
visibility-city!

                                    fig 18)  
                                        Rotate the image for the final effect...

24. Simple old method: use the Cropping tool (under the lasso) drag a rectangle, then press 
the option key and go to the lower left handle and drag it up and right. Should look like fig 
18) (ants are a little hard to see..). Then enter the rotated rectangle and with the scissors 
cursor click once:  when you let go the rotated center will become your new cropped normal 
window.

             fig 19)  
                  Final effect of a tiled background.  You might use it some time...

Lots and lots of variations, obviously. You could have them much smaller, un-embossed and 
with all kinds of other different choices at any one point in the path.   For the killer power guy 
this may have been light lunch, but I also like to help the mid section of the demographics to 
escalate ever upwards into the ivory tower snobby section.  And then have them clean up 
there.   You know who you are...:)
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              fig 20)  Puzzle: Find Edges, Emboss and a secondary pattern overlaid.

Read the manual on how to use Offset to put the side seams of a tile in the center and then 
lose them with clone or blur tools in order to make infinitely repeatable tiles without edges. It 
is basic knowledge and I rarely explain things here that are in the manual or book anyway.

Keep playing with the ideas. Send me a note when you find something, better yet, post it!   I 
do see almost everything that gets uploaded, sorry if I can’t contact each and every one of you 
for those, but believe me, I love to see them.

greetings ..Kai

As usual, send waves out to other people. Encourage them to come on-line, encourage 
yourself to post tiplets and pix and moronic questions, which everyone wanted to ask but 
thought they wouldn’t come across THAT dumb and now they are eternally greatful that 
YOU asked it and you will get love letters for weeks and finally marry one of them: a cute 
blonde from Vienna and have 4 children, all of whom become hackers at age 9 and make you 
rich with some weird A.I. app they bring out, until one day you decide to try a Unix machine 
and a beard will grow, which she is allergic to and you move to New Guinea.   No more 
Mac. No more tips from you.
Come to think of it, don’t post anything, it’s clearly way too dangerous.

No,  I really am better.   I think.
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Photoshop : Kai’s Power Tips & Tricks : 
#22   Domain Shifts
Applied Metamorphosis 101 

Why?  
Simple: I haven’t seen enough people do this and they ought to. Its cool. Trust me.

What?
Ok lets start at the beginning: what’s a domain?
Doesn’t really matter that much, really, damain thing is that you gotta change it and then back.
To give you an example, you may recall from high school math that instead of multiplying 
two numbers you can convert  them to their logarithms and then merely add those instead and 
convert the result back.   In our cases here what that translates to is that you can expand the 
possibilities of many filters by applying them in another domain.  Hang with me... no math 
involved,  for you numerophobics

There are not that many reversible domains in Photoshop as yet ( future plugins will provide 
more, I’m sure), but what there is, can be surprising in its effectiveness.

How ?
1.   Simplest in the bunch is a shift in the 2-D spatial domain: move the image, do something 
and move it back.     Check this out for starters: the image here before 

                                             fig 1)    
                                             Mona in fine spirits, centered

2. The idea is to offset the image so the corners move to become the new center. This is done 
by applying the Filter > Other > Offset.     To find out the dimensions, hold down the option 
key and click on the image size area of the window (“30K” here, an obviously ridiculously 
tiny example...) 

                            fig 2)   
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                                    The pop up indicates the height and width.

3. Now simply offset the image half way over and down...:

                     fig 3)  
          Entering exactly half the width and height and turning on the Wrap option

4. That gets you to this stage:

                                             fig 4) 
                              Offset image has the old corners at the center...

5. We then apply something which is “center” based. such as Twirl, Pinch, Spherize etc... 
and afterwards offset back again.    Here is a couple of applications of Pinch at “99” :

                                             fig 5)   
                                             Pinching in the offset domain

6.  Now to see the completed effect all we need to do is to convert the image back to the 
original domain, which in our case is merely a reverse offset.  You can actually simply apply 
the Offset filter again or enter a minus sign in front of each number to move it back.
Here is the final effect:
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                             fig 6)  
                                     A whole new filter:  CORNER PINCH !

7.   As we can see this netted us a new filter type!   Pinch, which was constrained to the 
image center, has now a Corner-Pinch variation.  Pretty cool, but the mere beginning: realize 
that ANYTHING that you do “centered” while in that domain-shifted state will now be 
“cornered” instead.  Very neat, Pete

Here is an example of a zig zag wave applied to corners first, using the above technique, and 
then an additional one in the center, giving lovely interference wave effects. (Complex 
metallic gradient as a background)   Original file much larger of course...

                                      fig 7)  
                                           Liquidity unlike you had before...

The entire process can be made into a simple macro, by the way, except that the image 
dimensions will have to vary.   

Note:   You can also shift the center to any other spot in the image: turn on the info window, 
click on the real center and drag to the desired new center (e.g. Mona’s left eye...)  Note the 
offset numbers in the info window and type them into the Offset filter, then proceed as above. 
Afterwards add a minus sign before the two offsets and you are back...easy.

8.  There are other such conversions: you can use Pinch and Spherize at “-99” then do 
something and convert back via the same filter at “+99”:   the image will be essentially the 
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same (some conversion loss) but the effect you added takes on a curved look ...:

                                               fig 8 a)  The initial image...

                          fig 8 b)  then Spherized at -99 and a linear grid applied

                              fig 8 c)  
        After reconversion with +99 the eye is linear again but the grid is distorted...
 
This too is a very general technique which can apply to any number of effects.  Among the 
linear operations one can even count simple blurs and sharpens or find edges...
The effect can be softened at the edges by feathering...
Remember to think this through as an abstract notion, not a follow the steps, paint by 
numbers deal. 
“This is not Simon says....”, said Simon.   

9.  More complex domain shifts can be had with complementary Displace filters (think about 
that if you are a serious pro here) , but an obvious one is the Polar coordinates.  I touched 
upon it in the tip regarding that filter, but to enhance the description with regards to this topic:  
the conversion from Cartesian rectangular grid space to the domain of Polar co-ordinate 
circular grids can yield some great effects!  
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                                   fig 9 a) 
                                              The original Leonardo image
           (algorithmic Chops/Arbmap gold, by the way...no brush tools whatsoever!)

                                     fig 9 b)                                         fig 9 c)  

b:  first converted from Rectangular to Polar, then a ZigZag filter applied
c: the circular waves after conversion from Polar back become linear ridges!
Of course thats like a new filter, there is no such thing now

                                     fig 9 d)                                         fig 9 e)  
The converse operation is similarly effective: instead of circular-to-inear one can achieve a 
double-circular-effect by converting polar to rectangular first, applying the ZigZag there and 
then converting back to polar...     Very fluid smooth curvature motions can be created easily!  
Do try this!

10. As a little outlook on future domain shifters here is one tiny picture showing another 
mathematical space, the 1/c circular domain.  A future plug-in called “Vortex Tiling” will 
allow access to this and in certain settings back again!  You can imagine that linear operations 
within this domain will come back in amazing perturbations afterward...
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                          fig 10)  
                     Vortex Tiling about 6,000 copies of the original Leonardoid
                      approximate time at 640x480 on a Quadra is 7 seconds (!)

Well, I hope this got your noodle twitching  (I am talking about your brain, dude) on how to 
multiply the effectiveness of your filters far and wide.  This is not a road travelled by many 
and I have seen precious little about this topic (otherwise I wouldn’t have written about it, I 
guess) but there are plenty of subtle new areas to explore and effects to be found. I trust most 
of you know how to interpret tips of icebergs...
Send me examples as you come across them, report your findings in the AOL keyword “kpt” 
area and in general share profusely and sincerely.   

All I ask is that you spell my name right and remember where you found it when they make 
you head of the art department   ; )

As usual, post something warm and fuzzy on Compuserve or whereever the hell you found 
this (its on dozens of services, counting only the ones that I have been told about).  On 
America Online the combined total downloads are now past 30,000     I guess it got a little out 
of hand...thanks for your interest and time though!  

Final advice: read a good book and snuggle up to your significant otherness. 
Once a week: forget the Mac!
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Photoshop : Kai’s Power Tips & Tricks : 
#23   Complexity-city! 
The Snowy Mask Technique 

Why?  
Can you say hypocrite?  
Once he preached on some high horse about sharing your special knowledge without delay 
before someone else turns it into a single button.  And then what did he do?  He sat on his 
special knowledge like the worst of them, and to top it off, even hoped to beat himself to the 
finish and be the one who turns it into a button, too.    Ouch.
I came around though, and after I first taught the technique at various seminar situations, this 
is the inevitable next step.  This one was one of my favorite techniques, the kind of thing I’d 
try first when given the task of making a new logo.    I’m giving all away     (choir,  harps...) 
It leads to many new areas in that special way I love so much: the outcome of the process you 
are steering here is literally not doable in any other way and you would have a VERY  hard 
time achieving the effects even as an accomplished painter.  I won’t be able to upload the very 
large art files I used it on, but you can find traces of this in many of my pieces.
It will be fun for me to see it emerging from other brains and hands in some mutated side 
branch.

What?
I call it the Snowy Mask because the basic notion is to create masks to separate elements and 
areas within any logo, text or other shape.    Its trivial to select edges for instance, but this 
technique will subdivide a shape into amazing and complex structures, but no matter how 
wild and woolly they get, they are related visually to the original shape       and that’s....hard 
to come by otherwise ; )
Give it a whirl.... it will give you a swirl or two.

How ?
As always,  it’s not about following this sequence ‘comma by period’,  I’m not Simon and 
you’re not some parrot, so get a grip!     Try to get the gist of the ‘what and why’ first, then 
go forth and create your own oeuvre.
I don’t think it’s necessary to explain here again just what Channel Calculations are or where 
the ‘Duplicate’ command is found, etc...  If you do need more basic introductions to these 
things, try out the previous 22 chapters...#1, 2, 17, 18, 19 are all about Chops and are 
sprinkled with the basics (even though I’d write it all differently now of course, in the 
beginning I had no idea it was all going to get this far out of hand)..   Anyway here goes:

1.  I am starting here with a 600x400 grayscale window and slap some text in there, like at 
222 points.
antialiased..blablabla.    The teeny redux version looks like this
 

Kai's Power Tips Page  190 Thu, Dec 7, 1995



                          Fig 1.  The start, plain text, font and stuff: your choice

2..  Next, as usual in the beginning of a lengthy Chops series, make a duplicate copy 
(control-d is a good key for a macro to do this all the time), it will appear in a new window, 
same dimensions.

3.   Use Filter > Gaussian Blur on this one, here I set it to “15”.  I will discuss the pro’s and 
con’s of higher and lower values in a minute below.

 

Fig 2.  The copy in a new window, G.Blurred at 15

4.  Duplicate this blurred version once more...you now have three copies

5.  This second blurred one needs to be offset a little...so use the Filter > Other > Offset 
dialog and set it like this... 
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                              Fig 3.  Offset the second blurred copy a little...

(Putting the same number in horizontal & vertical creates an exact 45 degree displacement 
which can contribute unwanted artifacts)   (Repeat Edges is the most benign choice in most 
situations, in this case it would look the same with either of the three...)

6.     Uh oh, I feel an Albert coming on... here comes the heavy theory bit... (put on your 
heat belts)

We are going to use “Difference” channel operation now. The idea is very simple, put two 
source images in (they have to be the same dimensions, which is assured by the duplicate 
process) and out comes a new image containing literally the difference, pixel for pixel.  If  the 
245th pixel in Source 1 and 2 are totally identical, that 245th pixel in the new document will 
be black.  If they are completely different ( eg 0 black in one and 255 white in the other...) 
then the new pixel is white. In between grays are generating corresponding shades of gray.      
So far so good.

By implication, if Source 1 and 2 are identical, the resulting Difference will simply be: 
nothing, all black.

And sure enough, we duplicated the two pictures and that’s what we would get.  
Except, in step 5 we did offset one just a little and that means they won’t totally annihilate one 
another!   Certain portions will be the same of course, but near the edges things won’t cancel 
out and white areas appear as a result, toward the center of the shapes however commonailty 
will tend towards equalizing out to black again. Its a little dance that is played out by the 
shapes...
Lets see how it looks:
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         Fig 4.  Creating a new window with the Difference between the two blurs...

7. And here is the by-now-expected result:
 

                          Fig 5. The Difference Chop result in the new window

Mostly black, soft grays around edges, black again inside....

8.  But the magic that earns it the name Snowy Mask is coming now, because similar to the 
Electric Aura effect there are some amazing things lurking in here, which we now bring out 
using the Levels... controls.:

The idea is to re-map the shades.... In the end what I am striving for here are clean anti 
aliased lines, zipping through the shapes, bisecting them at times, swirling in and out at other 
times.

In this diagram the mid points of these glowing swirls (“1”) is supposed to be a solid white, 
the area inside the shapes but outside the swirls (“2”) should be solid black. 
 

                        Fig 6.  A crosscut and top view of the ‘Swirly Glows’

9.  The first thing to set in Levels (an actually little known featurelet)...the two Output Levels 
triangles can be made to cross one another and achieve an instant ‘invert’ operation. ( Sure, 
the second image could have been inverted via command-’i’, but this way the whole thing is 
one step and un-doable as such.)
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              Fig 7.  Levels...:  doing an invert on the fly by swapping triangles...

By the way, as you cross the triangles and you have video LUT animation set ON ( in 
General preferences, lower left corner in 2.5.1, you SHOULD have this ON, much faster 
preview via Gamma) , the dialog itself will turn black...do not be alarmed by this, its a 
perfectly fine aspect of previewing the inverted state...( I will of course get mail from some 
moron that I broke his system with this and he will of course be published in MacUser saying 
this)

10.  In my example, the numbers to achieve the effects in 8. are as follows:

 

Fig 8.  Remapping the shades of gray to achieve the proper Snowy mask....

11.   And here is the final form....glowing swirlie thingies and all:
The name can maybe now become more logical, maybe not.     
To me the areas in white (“1”) are the ‘snow’ and an inch below that is the black rock (“2”).    

Of course it has nothing to do with snow and rock, its all about visualizing  the shape of the 
final mask.
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                           Fig 9. A Snowy Mask for the text “Snowy Mask”....

Considering how boring the original shape was, 10 plain characters in one font in solid 
black...,  I find the resulting complexity quite intriguing every time I do it.    You can’t read 
the text at this stage, but PLEASE don’t dismiss this for legibility...that’s not what its about!  
We’ll see in a minute how the mask can be applied in various ways for killer results. 

 12.  Before we go on:   it is quite clear that there are many settings in the Levels dialog that 
can greatly affect the shape of the lines...here is a variety of examples.   You cannot simply 
set it to fixed numbers, the mask has to be judged on an ad hoc basis for each image. 

                          Fig 10  a)  Triangles at far left, thin lines, sharp sides

                          Fig 10  b)  Triangles moved further apart, flaring smooth lines
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                          Fig 10  c)  Triangles spread, wide soft glows

13.  The other variables in the process are the amount of Gaussian Blur and the extent of the 
Offset.

Less Blur will result in smaller cleaner features. 
 

               Fig 11)  With smaller G.Blur, the “y” has finer lines bisecting it...

No blur at all however creates mere pop-art Vassareli double shapes ( although this can be 
entertaining if you happen to walk in Vassi’s shoes)

Too much Blur (above 20 normally) will generate artifacts, this is not too hard to understand: 
the Histogram in figure 8. will be reduced to a tiny wedge shape since most areas are 
substantially the same and cancel out. Forcing those few dark grays via Levels can only be 
done at the cost of artifacts, i.e. fuzzy edges.    

Same with the offset. If too small, there is simply too much commonalty between the 
Difference sources and trying to extract the snowy mask will be very ‘raspy’.  In fact you can 
rather try more generous offsets, e.g. 30/25...to get very clean smooth shoulders...

If this finds your approval, a modification to the algorithm would be to make TWO blurred 
copies, offset both in opposite directions at half the setting. This way the larger separation is 
achieved and yet the resulting glowing swirls are still registered with the original shapes. 

Obviously the offset does not have to be in the right/down direction. You can enter negative 
offsets and position it in any direction.  It can be very interesting to have two snowy masks in 
different directions and then combine them in cruel and unusual ways.
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14.  Let’s get into the variations, where the real action is:
I’d like to point you into a few directions  from here, even if I can’t create the step by step 
scenario for each and every one (and I don’t really want to even, you guys ought to be your 
own pioneers!)

You will have to follow the other chapters on channel operations or otherwise be really good 
with the composite, blend, add/subtract, multiply/screen, lighter/darker and difference 
commands.  Simply put it is rather straightforward to extract specific detail bits and pieces out 
of any intermediate step.

The snowy mask for instance can be used so that in the dark areas you get one image, in the 
white areas you get another.  If the original clean shape is used as a mask then you can add 
the glowing swirls inside the shape and the displaced blur outside of it. With some cleanup 
and edges here is what that looks like:
 

      Fig 12.  Inside original text is the snowy swirly stuff, outside is the blur shadow

(Fig 12. was not just a plus b, so don’t try to get that in one step and wonder what you are 
doing wrong...)

And once you have isolated a part you can colorize it separately of course (download size 
prevents me here to show full color examples).    

15.  Here is a good example:  If the offset gaussian blurred image (after Fig. 3)  is subtracted 
from the snowy mask in Fig 9  you effectively extract only the “inside flame swirls”...:
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 Fig 13.  Subtract: Source 1 = Snowy Mask  Source 2 = offset blur   extracts the flames

This is not only an interesting graphic element all by itself...( remember that this is only some 
random lame piece of text...you have no idea what comes out with your logo or your clients 
name in some really cool font...!) but it can also EASILY serve you to do the extraction 
business..!

Lets say you like the basic fig 12. as a masthead or something and now you want the flames 
in fig 13. to be red overlays...   e z :

First convert 12 to RGB so it can accept color.  Then simply use Duplicate  Fig 13 and as the 
destination select fig 12., however in the Channel popup instead of RGB choose “Selection”.

This means that whatever is WHITE in the Source 1 document ( here the flames) will be a 
floating live selection in the Destination document. ( note that this does NOT copy anything 
from Source 1 at all, it merely takes the white areas as selected, the black areas as opaque 
masked, and the grays in between...) 
 

Fig 14. How to let the flames in fig 13 come up as a floating selection in Fig 12, ready for 
colorizing

If you wanted to select the original text shape, you could use Fig 1 as Source 1, but click the 
invert checkbox, since the text is black on a white background. 
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If this is not already second nature to you, I strongly suggest you read it a few times while 
doing it for real within Photoshop...its one of the most useful basic techniques, which I often 
find mysteriously unknown amongst avid shopaholics.

Just as a reminder: this whole tips thing is NOT meant for reading in the bathroom or while 
driving or on a lunch break under a plate of mashed potatoes.  If you can at all, try to read ‘n 
play step by step, or else many of the little details will escape you.   

Trust me, it may look like “ yeah sure, gottit, been there, done that...”  to you, but its an 
entirely different story when you do it in high res with a shape of your own design  and you 
peek into all the side branches.    

16.  To give ourselves more ammunition, we need more shapes and ingredients for further 
Chopping.
Simply reversing the Sources in Fig 13 will do it!!   Check this:

 
Fig 15.  Subtract: Source 1 = offset blur   Source 2 = Snowy Mask   extracts the glow 

Very cool, you now have a gaussian soft glow which is confined to the dark areas of the 
original snowy mask... This can be used for some great enhancing and soft color/hue 
changes or inverted can become a different type of drop shadow.  If you squint a little you 
can make out the relationship of Fig 15 to the original text...and think of how to relate them 
graphically.   With other fonts and wider spacing you can even let these techniques become 
their own brand new fonts in and of themselves!   I can easily see Mondo or Wired using 
such cutting edge font designs...

If you ever make a whole alphabet with snowy masking, send me a letter. ...  as it were... : )

17.  Here is one mutation further down, using another calculation mode: Lighter... combining 
the blur and the snowy mask in this mode will choose the lighter one for each pixel in the 
resulting image. There are various inversion options of all parts of course.  By the time I 
arrived here, I had 81 Untitled windows open...so I may at times arrive at results that look 
different than if you only make the specifics covered here.   
What’s cool about the effect as seen in Fig. 16, is that it can look very layered, like fog 
rolling in over your artwork... A rare graphic stylistic element, because it is so hard to 
achieve otherwise.
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             Fig 16.  The Lighten  calculation mode combines the blur with the font

BTW, this also explains why I rarely do this technique as channels within one document.. 
First and foremost the 16 channel limit, but also viewing and saving separately is of great 
value to me.   Another advantage often cited is to have Resize affect them all at once, and 
although I rarely do that, it can easily be achieved by Merge Channels to Multichannel, which 
is extremely fast. 

TIP >>> to NAME your separate “Untitled” windows quickly...merge them into one 
multichannel document and name them as channels.  If you then split them into individual 
grayscale files again, the names will survive!!!      Have not seen that published anywhere

I do often merge the most useful ingredients e.g. clean start mask, snow, edges, etc... and 
then save the whole source soup as a big “xxxlogo.MULTI”  file. ( in Photoshop 2.5 
format...which is now also run length encoded = losslessly compressed.   This alone was 
enough reason for me to switch to 2.5 since in 2.01 the PS format did not compress and multi 
files were gigantic!   

18.  Further along combinatorics to create more building blocks.   Here is a very cool foggy 
haze drifting over the original text (there are several ways to get this and similar ones like 
Lighter.. between the shape and the snowy mask will get there). The fumes here are still 
related to the shapes and have a natural chaotic structure.  
Believe me, YOU CAN’T DRAW THIS.  A few of you can draw better fumes maybe, but 
even those would have a hard time if you repeat the technique at 4000x3000 (!)
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   Fig 17. Combining the swirls with the logo results in “Fumes” drifting nicely

19.  Reversing the Font image (here after other steps for texture)  and using the swirls 
isolated over that , you get very nice dancing flames ( especially if you colorize them 
separately)

Fig 18 could be done with the swirls in 13 as a mask, (where 13 is white you get 13, where 
its black you get the inverted font)    Or another Lighter..  combination can achieve this.   

I trust that your sense of Sherlockness will be challenged enough to snoop around.
My favorite e-mail messages are the ones where    ‘on the way to get Fig 18 , which I never 
found,  I came across 33 others though...and this one is on the cover of TIME this 
week...thanks”    : )

 

Fig 18. Reverse text and Swirls-only, in Lighten... makes hot dancing multilayer flames...!

20.  As further building blocks for your mixture-torture-feast you can also take any lame 
intermediate windows and instead of deleting them, fill them with a simple gradient for 
instance.

If you delete any bad ones, and have dozens of such masks, blurs, edges, backgrounds, 
flames and snow and who-knows-what  littering your screen.... ( remember to make a macro 
that reduces the size to a 1:8 thumbnail so you can see it all...the fact that the Chops dialogs 
are movable in 2.5.1 is very cool...and don’t forget that hide edges, zooming and such 
keyboard stuff works while you are inside the Chops dialog like composite or even 

Kai's Power Tips Page  201 Thu, Dec 7, 1995



Levels....)  anyway, when you ultimately have 30 or more of the beasts ready for your mad 
scientific experiments, there is no law against playing with the dice (Albert did not say that 
YOU wouldn’t use them, did he...)  and try RANDOM combinations.

Here is a random Untitled 80 as a mask and Untitled 22 as Source 1 and Untitled 38 as source 
2.:
 

                        Fig 19. Who the  %&^@%#$ knows how this worked...?
  
Its...fun, its...weird, its....endlessly surprising.   
You will rarely find a finished masterpiece, but you WILL find really interesting bits over 
here or a nice edge over there or a good background reminding you of your first-grade 
teacher’s wart.   

Since you know you can learn how to keep these jewels and discard the rest...you are in 
business.

Call it  “Bob’s Algorithmic Painting, Inc.” and churn out the logoids all up and down your 
hometown, all happy 90’s looking hipper than ever,  more MTV than MTV is yet...  

Send me the final output examples, keep the cash.        Some deal.

21.  You  don’t have to use the mask as a visible feature itself, but as a way to subdivide the 
shape into sections!  In fact the more subtle uses of all this is what I really sweat you can 
imply.   I often need to show the over-the-top psychedelic-looking brute-force examples  (and 
I don’t like drugs or force..hm) in order to illustrate the top of the tip of the nice berg. The 
below the waterline bulk is for you to dive into, so to speak.

(Yikes: here came a large color example of a Roger Dean font.  In fact I had to take out 5 
color images since it would have pushed the download time to over an hour... )

I cannot stress enough this particular quality of the algorithmic painting approach:   anyone 
may be good enough to paint one letter like that, but to affect the other dozen to look naturally 
the same is very hard indeed!   Worse yet, in high resolution you may see only part of even 
just one single character at a time...and in zoomed out mode, while it affords you to see the 
entirety, all your tools are tiny and behave oddly.   Getting it just ever so slightly wrong can 
be detected instantly as ‘dilettante’ and this is one reason why you very rarely see such 
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custom complex effects drawn by hand...

Hmmm,   I had hoped to continue here with the more complex color examples of snowy 
masks...but alas it has become already annoyingly large as it is. Downloading these tips on 
the dozens of sites they are found on is still the primary method of distribution and I have to 
remain aware of the time and cost penalty involved.   Maybe I can upload a separate file 
containing only color images for the deeper interested, the deeper pocketed or the deeper 
desperate.

On America Online, still the major original source and home for these,  we not only have 
passed 40,000 cumulative downloads of the tips n pix by now, but we are also running a full 
time forum for this stuff as well as my filters.   I won’t mention them explicitly here though, 
this always was and shall remain an altruistic non commercial venture...   If you would like to 
use the tips on your BBS, you are welcome.  If you think of including them in your next 
book opus, you can be sure I will say ‘sure’ and won’t require any payments.. it happened 
often enough this year.    It would be nice to hear about it or see the final results, though.  I 
have been somewhat surprised how often lectures include the material or special ideas 
sometimes verbatim, but as if they never existed before until “he” just invented it.  

I’m not the litigious type and often I merely chuckle.  The stuff is FREE for god’s sake, at 
least they can pay that price...?

Well, its not a problem.  

The recent fires up here in the Malibu mountains defined very nicely thank you just what one 
is supposed to mark in one’s brain as a REAL problem.  Even though it got to within feet on 
several sides of the house, everything survived ok, my wife and children and even all the 
‘stuff’ is just fine.   Before I get hundreds more letters about details than I already got ( thank 
you though!), I  did post a long anecdotal account of the events if you care to read it... It lives 
in the keyword “kpt” section on America Online, in the Blue Sky folder (where we bare our 
deep stuff, some nice unusually rich content hiding in that one...check it out).  Scroll back to 
the early November threads...

I hope this #23 may serve as a gateway to more activity in KPT files for me.  I have had a lot 
of big fish to fry this year, traveled 7 times to Europe and 3 to Japan (OUCH OUCH OUCH 
HELPPPP), the company , HSC, grew from 8 to 45 and we are working on more products 
than I can count comfortably.   Still, this is where much of it started and I would dearly like to 
get back to it at times.  
It would be nice to see more of you readers in person at events like MacWorld, too.

Even with a dozen books and CDs out on Photoshop now ( when I started there was ONE), I 
hope to be able to still come up with new stuff that has not been published anywhere.  At least 
I’ll try, so wherever you get these things, keep looking for more every few weeks or so...

Greets from the moonscape up here, and I’ll leave you with a little excerpt from the first page 
of the fifth part in the trilogy “Hitchhikers Guide to the Galaxy” by the brilliant Douglas 
Adams.  
The connection to KPTs, ( aside from the factoid that a Snowy Mask induced image just may 
grace the cover design soon,  proving a practical side to this whole document )      is in its 
content:
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“Nothing travels faster than the speed of light with the possible exception of bad news, which 
obeys its own special laws.  The Hingefreel people of Arkintoofle Minor did try to build 
spaceships that were powered by bad news but they didn’t work particularly well and were so 
extremely unwelcome whenever they arrived anywhere that there wasn’t really any point in 
being there.”
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