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#
# The beginning of the reference portion of PowerTalk Basics
#

# ####################
# The following panels are for “PowerTalk Overview” reference
# ####################

<DEFINE PANEL> "PowerTalk overview: 1" 
<FORMAT> "full"
PowerTalk system software helps people to work together — to collaborate — more effectively. 
PowerTalk software provides the foundation for software products that give you new ways to 
correspond with others, safeguard your communication, access information on other computer 
systems, and automate routine activities.

<dimmable button data> "Huh?", "Definition of collaboration services"
<END PANEL>

<DEFINE PANEL> "PowerTalk overview: 3" 
<FORMAT> "full"
When you install PowerTalk, a new item appears in the Apple menu — Mail and Catalogs.

Mail and Catalogs contains AppleMail, Find in Catalog, and Personal Catalog.

<coach mark> "apple-mail and catalogs"
<END PANEL>

<DEFINE PANEL> "PowerTalk overview: 2" 
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<FORMAT> "full"
After you install and set up PowerTalk, a new item appears in Mail and Catalogs — Key Chain.

Key Chain allows you to gain access to all your accounts and services by typing a single 
password.

<coach mark> "apple-mail and catalogs"
<dimmable button data> "Huh?", "Definition of Key Chain"

<END PANEL>

<DEFINE PANEL> "PowerTalk overview: 4" 
<FORMAT> "full"
AppleMail is a simple application program you can use to create, send, read, and respond to 
letters and enclosures.

<dimmable button data> "Huh?", "Definition of AppleMail"
<END PANEL>

<DEFINE PANEL> "PowerTalk overview: 5" 
<FORMAT> "full"
You can use Find in Catalog to quickly find a name or address.

Personal Catalog allows you to quickly access frequently used items and addresses.

<dimmable button data> "Huh?", "Definition of personal catalog"
<END PANEL>

<DEFINE PANEL> "PowerTalk overview: 6" 
<FORMAT> "full"
When you install PowerTalk, an icon named “Mailbox” appears on your desktop. After you set up 
PowerTalk, the name of the mailbox icon changes to your name.

The Mailbox contains all your incoming and outgoing mail.

# NEED TO ADD COACH FOR MAILBOX ICON ON DESKTOP
# We can't coach PowerTalk desktop icon
<dimmable button data> "Huh?", "Definition of mailbox"

<END PANEL>

<DEFINE PANEL> "PowerTalk overview: 7" 
<FORMAT> "full"
When you install PowerTalk, the Catalogs icon appears on your desktop.

Catalogs provides access to information you need to communicate with individuals and groups.

# NEED TO ADD COACH FOR CATALOGS ICON ON DESKTOP
# We can't coach PowerTalk desktop icon
<dimmable button data> "Huh?", "Definition of catalog"

<END PANEL>
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<DEFINE PANEL> "PowerTalk overview: 8" 
<FORMAT> "full"
The DigiSign Utility installed by PowerTalk can be used to request approval of a Signer file which 
can be used to approve, or “sign,” a document on your computer. Putting your digital signature on 
a document ensures the integrity of the document.

<coach mark> "finder DigiSign icon"
<dimmable button data> "Huh?", "Digital Signatures Overview"

<END PANEL>

<DEFINE PANEL> "PowerTalk overview: 9" 
<FORMAT> "full"
You can use PowerTalk system software on an AppleTalk network, whether or not you have 
PowerShare servers or other file servers connected to the network. You can send mail directly to 
any PowerTalk-equipped computer connected to an AppleTalk network.

If you add PowerShare servers to your network, you gain additional catalog and mail delivery 
services, as well as added security and privacy for your correspondence.

<dimmable button data> "Huh?", "Definition of PowerShare server"
<END PANEL>

#
# The beginning of the “How do I” portion of PowerTalk Basics
#

# ####################
# The following panels are for “How do I set up PowerTalk software?” 
# ####################

<DEFINE PANEL> "set up PowerTalk: choices" 
<FORMAT> "full"
You only need to set up PowerTalk software once. When you set up your software, you need to 
know whether you have a PowerShare server account. If you aren’t sure, ask your system 
administrator.

How do you want to set up? Click one:

<radio button> "with a PowerShare server account", true,,,,appleguide
<radio button> "without a PowerShare server account", false,,,,appleguide

<END PANEL>
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<DEFINE PANEL> "Special: choose Unlock Key Chain" 
<FORMAT> "tag"
Do This

<FORMAT> "body"
Open the Special menu and choose Unlock Key Chain.

<coach mark> "special-unlock key chain"
<END PANEL>

<DEFINE PANEL> "set up PowerTalk: click Proceed" 
<FORMAT> "tag"
Do This

<FORMAT> "body"
Read the screen and click Proceed.

# Shemin, coach the Proceed button on the dialog
# I don't know if we can coach it

<END PANEL>

<DEFINE PANEL> "set up PowerTalk: click Yes" 
<FORMAT> "tag"

Do This

<FORMAT> "body"
A dialog box appears, asking if you have a PowerShare account.

Click Yes.

# Shemin, coach the Yes button on the dialog
# I don't know if we can coach it

<END PANEL>

<DEFINE PANEL> "PowerShare server: select" 
<FORMAT> "tag"

Do This

<FORMAT> "body"
The computer searches for the PowerShare services available to you.

When the navigation dialog box appears, select the PowerShare service you want to access and 
click OK.

<END PANEL>
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<DEFINE PANEL> "PowerShare account: type name and password" 
<FORMAT> "tag"
Do This

<FORMAT> "body"
Type your name and password as set up by your system administrator, then click OK.

# Shemin, coach the name and password blocks for typing
<END PANEL>

<DEFINE PANEL> "Key Chain Access Code: setting" 
<FORMAT> "tag"
Do This

<FORMAT> "body"
Read the screen and click OK.

PowerTalk initially sets your key chain access code to your PowerShare password.

If you want to change your access code, click Huh? below for instructions.

<Dimmable Button Data> "Huh?","How do I change my access code?"
<END PANEL>

<DEFINE PANEL> "Mailbox: name changed" 
<panel prompt> "read & click"

<FORMAT> "tag"

Notice

<FORMAT> "body"
Your PowerTalk software is set up.

After you set up PowerTalk, your Mailbox is renamed with your name.

<Dimmable Button Data> "Huh?","Definition of mailbox"
<END PANEL>

<DEFINE PANEL> "Computer name: confirm" 
<panel prompt> "override: rdone"
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<FORMAT> "full"
If you are on an AppleTalk network, the name of your computer will appear in the AppleTalk 
catalog. People can send you mail at this “address” without a PowerShare server.

If you want to change the name of your computer, click Huh? below for instructions.

<Dimmable Button Data> "Huh?","How do I name my computer?"
<END PANEL>

<DEFINE PANEL> "set up PowerTalk: click No" 
<FORMAT> "tag"

Do This

<FORMAT> "body"
A dialog box appears, asking if you have a PowerShare account.

Click No.

# Shemin, coach the No button on the dialog
<END PANEL>

<DEFINE PANEL> "Key Chain: type name and access code" 
<FORMAT> "tag"
Do This

<FORMAT> "body"
Type your name and the access code you want to use, then click OK.

# Shemin, coach the name and access code blocks for typing
<END PANEL>

<DEFINE PANEL> "Key Chain Access Code: confirm" 
<FORMAT> "tag"
Do This

<FORMAT> "body"
When the confirmation dialog box appears, type your access code again and click OK.

Read the new screen and click OK.

<END PANEL>

<DEFINE PANEL> "Date & Time: confirm" 
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<FORMAT> "tag"
Do This

<FORMAT> "body"
Read the screen and click OK.

Make sure the date, time, and time zone are all set correctly.

If you need to reset the time or date, click Huh? below for instructions.

<Dimmable Button Data> "Huh?","How do I set the time and date?"
<END PANEL>

# ####################
# The following panels are for “How do I turn on AppleTalk?” 
# ####################

<DEFINE PANEL> "AppleTalk: active" 
<FORMAT> "full"
AppleTalk is already active.

<END PANEL>

<DEFINE PANEL> "Apple: choose Chooser" 
<FORMAT> "tag"
Do This

<FORMAT> "body"
Open the Apple () menu and choose Chooser.

<COACH MARK>"Menu:Front:Apple:Chooser"
<END PANEL>

<DEFINE PANEL> "Chooser: click AppleTalk Active" 
<PANEL PROMPT> "Prompt Override: 27"

<FORMAT> "tag"
Do This

<FORMAT> "body"
In the lower-right area of the Chooser, click the AppleTalk Active button to place a dot in it.

AppleTalk becomes active after you restart the computer (by choosing Restart from the Special 
menu).

<COACH MARK>"CoachMark: 152"
<END PANEL>
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<DEFINE PANEL> "Chooser: close" 
<FORMAT> "tag"
Do This

<FORMAT> "body"
Close the Chooser by clicking the close box at the upper-left corner.

<COACH MARK>"CoachMark: 155"
<END PANEL>

# ####################
# The following panels are for “How do I make an information card for myself?” 
# ####################

<DEFINE PANEL> "info card for me: intro" 
<FORMAT> "full"
PowerTalk introduces a new kind of document — an information card. Each information card is a 
collection of data about a person, place, or thing or a group of people, places, and things. An 
information card can reside in catalogs available on your desktop, on a network, or anywhere on 
a disk.

<Dimmable Button Data> "Huh?","How do I use information cards?"
<END PANEL>

<DEFINE PANEL> "PowerTalk folder: open" 
<FORMAT> "tag"
Do This

<FORMAT> "body"
Open the PowerTalk folder.

If you can’t find the PowerTalk folder, click Huh? below for instructions.

<coach mark> "finder PowerTalk folder"
<Dimmable Button Data> "Huh?","Definitions Tips for finding items"

<END PANEL>

<DEFINE PANEL> "Untitled Info Card: select and rename" 
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<FORMAT> "tag"
Do This

Do This

<FORMAT> "body"
Select the Untitled Info Card in the PowerTalk folder.

Type your name as its title.

If you can’t find the Untitled Info Card, click Huh? below for instructions on how to create a new 
information card.

<coach mark> "finder Untitled Info"
<Dimmable Button Data> "Huh?","How do I create an information card?"

<END PANEL>

<DEFINE PANEL> "Untitled Info Card: open & select additional page" 
<FORMAT> "tag"
Do This

Do This

<FORMAT> "body"
Open the information card and add your information to the first “page.”

Use the pop-up menu to switch to the appropriate page to add personal info, phone numbers, and 
electronic addresses.

If you need more information about modifying an information card, click Huh? below for 
instructions.

# COACH POP-UP MENU ON INFORMATION CARD IF CAN CONTEXT CHECK TO MAKE SURE IT IS OPEN
<Dimmable Button Data> "Huh?","How do I modify an information card?"

<END PANEL>

# ####################
# The following panels are for “How do I send letters and documents?” 
# ####################

<DEFINE PANEL> "howdoi: send: begin" 
<FORMAT> "full"
You can send a document that you already have, or you can use the AppleMail application 
program to write and send a letter. Which do you want to do?

<radio button> "Send an existing document", true,,,,appleguide
<radio button> "Write and send a letter", false,,,,appleguide

<END PANEL>
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<DEFINE PANEL> "locate info card" 
<FORMAT> "tag"
Do This

<FORMAT> "body"
Locate the info card or alias of the person to whom you want to send a document.

If you can’t find the info card or alias of the person, click Huh? below for instructions.

<Dimmable Button Data> "Huh?","How do I find an item in a catalog?"
<END PANEL>

<DEFINE PANEL> "locate document" 
<FORMAT> "tag"
Do This

<FORMAT> "body"
Locate the document you want to send.

<END PANEL>

<DEFINE PANEL> "drag document to card" 
<FORMAT> "tag"
Do This

<FORMAT> "body"
Drag the document to the information card of the person to whom you want to send the 
document.

In the dialog box that appears, click OK.

<END PANEL>

<DEFINE PANEL> "use AppleMail" 
<FORMAT> "tag"
Do This

<FORMAT> "body"
Use the AppleMail application program to write and send your letter. 

To locate AppleMail, open the Apple menu and choose Mail and Catalogs.

For help using AppleMail, choose AppleMail Guide from the Guide menu (on the right, with the ? 
icon) after you open AppleMail.

<END PANEL>
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# ####################
# The following panels are for “How do I read my incoming mail?” 
# Added from “Sending and Receiving”
# ####################

<DEFINE PANEL> "howdoi: read my mail: begin" 
<FORMAT> "full"
The PowerTalk mailbox provides a single place for you to receive all of your electronic mail. 
AppleMail documents and documents sent to you via direct AppleTalk mail are stored in your 
mailbox.

When you install other kinds of PowerTalk-compatible collaboration software, you may receive 
additional kinds of messages in your mailbox.

<END PANEL>

<DEFINE PANEL> "howdoi: read my mail: open mailbox"
<panel prompt> "override: right"

<FORMAT> "tag"
Do This

<FORMAT> "body"
Open your PowerTalk mailbox.

Your PowerTalk mailbox is on your desktop. It is labeled with your name (or the name you used 
when you set up PowerTalk).

<END PANEL>

<DEFINE PANEL> "howdoi: read my mail: enter access code"
<FORMAT> "tag"
Do This

<FORMAT> "body"
Type your access code in the box. 

Be sure to type it exactly as you did when you set up PowerTalk, including capital letters.

<coach mark> "enter access code item"
<END PANEL>

<DEFINE PANEL> "howdoi: read my mail: read mail"
<panel prompt> "override: ddone"
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<FORMAT> "tag"
Do This

<FORMAT> "body"
Open the documents you want to read.

<END PANEL>

# ####################
# The following panels are for “How do I change my access code?” 
# ####################

<DEFINE PANEL> "howdoi: change access code: begin" 
<FORMAT> "full"
Your access code is a special password that keeps your PowerTalk key chain and collaboration 
services secure.

You use the key chain to change your access code.

<dimmable button data> "Huh?", "definition of access code"
<END PANEL>

<DEFINE PANEL> "Apple: choose Key Chain"
<panel prompt> "override: right"

<FORMAT> "tag"
Do This

<FORMAT> "body"
Open the Apple () menu and choose Mail and Catalogs.

Open Key Chain.

If you can’t find the key chain, click Huh? below for instructions. 

<coach mark> "apple-mail and catalogs"
<dimmable button data> "Huh?", "Why can’t I find Key Chain?"

<END PANEL>

## The next panel is from “How do I read my incoming mail?” sequence
## "howdoi: read my mail: enter access code"

<DEFINE PANEL> "howdoi: change access code: click change code"
<FORMAT> "tag"
Do This

<FORMAT> "body"
Click Change Code.
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<coach mark> "change code"
<END PANEL>

<DEFINE PANEL> "howdoi: change access code: new code"
<panel prompt> "override: tip"

<FORMAT> "tag"
Do This

<FORMAT> "body"
Type your old access code, then press the Tab key. Your access code is replaced by bullets (•) to 
protect your privacy.

In the box labeled “New Access Code,” type the new code you want to use, then press Return (or 
click the OK button). Then type the new code again, to make sure you have it the way you want.

Remember your new access code exactly, including capitalization.

<END PANEL>

<DEFINE PANEL> "howdoi: change access code: tips"
<panel prompt> "override: rdone"

<FORMAT> "tag"
Tips

<FORMAT> "body"
Don’t use your name as an access code.

The longer your code is, the harder it will be to guess (it must be at least six characters).

Mix upper- and lowercase letters, and use numbers (for example, “4ME!Only%”).

Make it easy to remember and don’t write it down.

Keep track of which letters are uppercase — the access code is case-sensitive.

<END PANEL>

# ####################
# The following panels are for “How do I add or remove a service?” 
# ####################

<DEFINE PANEL> "add or remove services: choices" 
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<FORMAT> "full"
Your PowerTalk key chain contains your setup information for each collaboration service you use. 
These services can be added or removed.

Which do you want to do? Click one:

<radio button> "add a service", true,,,,appleguide
<radio button> "remove a service", false,,,,appleguide

<END PANEL>

<DEFINE PANEL> "howdoi: add a service: begin" 
<FORMAT> "full"
To add a service to your key chain, you must first install the software for the service.

Use these instructions after you have installed new collaboration software on your hard disk.

<END PANEL>

## The 2nd panel is the same as the second panel in the first sequence 
##    under this topic
## "Apple: choose Key Chain"

## The 3rd panel is from “How do I read my incoming mail?” sequence ##    under this topic
## "howdoi: read my mail: enter access code"

<DEFINE PANEL> "howdoi: add a service: click add"
<FORMAT> "tag"
Do This

Do This

<FORMAT> "body"
Click the Add button.

When a new dialog box appears, click to select the type of service you want to add, then click 
OK.

What happens next depends on the kind of service you are adding. Some services require 
additional setup before you can use them. See the documentation that came with your 
collaboration software.

<coach mark> "add a service"
<END PANEL>

## Panels from “How do I remove a service?” 
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<DEFINE PANEL> "howdoi: remove a service: begin" 
<FORMAT> "full"
Your PowerTalk key chain contains your setup information for each collaboration service you use. 
The information for a service is called a “key.” You should remove a key from the key chain only 
when you know you won’t use that service again.

<END PANEL>

## The 2nd panel is the same as the second panel in the first sequence 
##    under this topic
## "Apple: choose Key Chain"

## The 3rd panel is from “How do I read my mail?” sequence under
## Sending and Receiving topic
## "howdoi: read my mail: enter access code"

<DEFINE PANEL> "howdoi: remove a service: select the service"
<FORMAT> "tag"
Do This

<FORMAT> "body"
Click to select the service you want to remove.

To select more than one service, hold down the Shift key as you click each one.

<END PANEL>

<DEFINE PANEL> "howdoi: remove a service: click remove"
<panel prompt> "override: ddone"

<FORMAT> "tag"
Do This

<FORMAT> "body"
Click the Remove button to remove the service or services you selected. 

When the dialog box appears, click Remove & Restart.

<coach mark> "remove a service"
<END PANEL>

# ####################
# The following panels are for “How do I lock my PowerTalk System?” 
# ####################
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<DEFINE PANEL> "PowerTalk: locked" 
<FORMAT> "full"
PowerTalk is already locked.

To unlock your key chain, choose Unlock Key Chain from the Special menu.

<coach mark> "special-unlock key chain"
<END PANEL>

<DEFINE PANEL> "howdoi: lock my key chain: begin" 
<FORMAT> "full"
If you are going to be away from your computer for a while, you can protect your PowerTalk 
services, accounts, and information by locking your key chain.

To lock your key chain, choose Lock Key Chain from the Special menu. 

<coach mark> "special-lock key chain"
<END PANEL>

# ####################
# The following panels are for “How do I turn PowerTalk on and off?”
# ####################

<DEFINE PANEL> "howdoi: PowerTalk on and off: begin" 
<FORMAT> "full"
You use the PowerTalk control panel to turn PowerTalk on and off. PowerTalk gives you access to 
collaboration services you use to communicate and work with other people.

<dimmable button data> "Huh?", "definition of PowerTalk"
<END PANEL>

<DEFINE PANEL> "Apple: choose control panels"
<panel prompt> "override: right"

<FORMAT> "tag"
Do This

<FORMAT> "body"
Open the Apple () menu and choose Control Panels.

<coach mark> "apple-control panels"
<END PANEL>

<DEFINE PANEL> "PowerTalk Setup: open"
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<FORMAT> "tag"
Do This

<FORMAT> "body"
Open the PowerTalk Setup control panel.

<coach mark> "PowerTalk setup icon"
<END PANEL>

<DEFINE PANEL> "howdoi: PowerTalk on and off: click on and off"
<FORMAT> "tag"
Do This

<FORMAT> "body"
Click the appropriate button to turn PowerTalk on or off.

Your new setting takes effect after you restart your computer.

<coach mark> "PowerTalk setup"
<END PANEL>

<DEFINE PANEL> "howdoi: PowerTalk on and off: close PowerTalk setup"
<panel prompt> "override: ddone"

<FORMAT> "tag"
Do This

<FORMAT> "body"
Click the close box to close the PowerTalk Setup control panel.

<coach mark> "close box"
<END PANEL>

#
# The beginning of the Huh? questions for PowerTalk Basics
#
# Panels for the sequence "How do I set the time and date?"
# ####################
# The following panels are for “How do I set the time and date?” 
# ####################

<DEFINE PANEL> "Date & Time: intro" 
<FORMAT> "full"
You set the time and date in the Date & Time control panel. You can also use the control panel to 
change how times and dates appear.

<END PANEL>

<DEFINE PANEL> "Date & Time: segue to install" 
<PANEL PROMPT> "Standard Prompts"
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<FORMAT> "full"
The software you need, Date & Time control panel, is not installed. You need to install this 
software before you can complete this task.

<END PANEL>

<DEFINE PANEL> "Startup disk: opening"
<FORMAT> "tag"
Do This

<FORMAT> "body"
Open the startup disk.

<COACH MARK>"Finder Desktop BootDisk"
<END PANEL>

<DEFINE PANEL> "System Folder: locate"
<FORMAT> "tag"
Do This

<FORMAT> "body"
Locate the System Folder on your startup disk.
Do not open the folder.

<COACH MARK>"Finder Coach System Folder"
<END PANEL>

<DEFINE PANEL> "Date & Time: locate"
<FORMAT> "tag"
Do This

<FORMAT> "body"
Locate the Date & Time control panel. It’s part of the system software that came with your 
computer.

If you can’t find the control panel, click Huh? below for instructions.

<Dimmable Button Data> "Huh?","Definitions Tips for finding items"
<END PANEL>

<DEFINE PANEL> "Any resource: drag"
<FORMAT> "tag"
Do This

<FORMAT> "body"
Drag the item to the System Folder icon (not the System Folder window). If a message appears, 
read it and then click OK.

<END PANEL>
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# The panel "Apple: choose Control Panels" is shared.

<DEFINE PANEL> "Date & Time: open"
<FORMAT> "tag"
Do This

<FORMAT> "body"
Open the Date & Time control panel.

<COACH MARK>"Finder Coach Date & Time"
<END PANEL>

<DEFINE PANEL> "Date & Time: click date"
<FORMAT> "tag"
Do This

<FORMAT> "body"
To set the day, month, or year, click a number in the current date, and then click the arrows that 
appear. (Or you can type a new number.)

<COACH MARK>"CoachMark: 11"
<END PANEL>

<DEFINE PANEL> "Date & Time: click zone"
<FORMAT> "tag"
Do This

<FORMAT> "body"
To identify the time zone for your location, click the Set Time Zone button, choose a city that’s in 
the same time zone as your current location, then click OK.

Clicking to put an X in the box labeled Daylight Savings Time adjusts the time by an hour.

<COACH MARK>"CoachMark: 12-1" 
<END PANEL>

<DEFINE PANEL> "Date & Time: click time"
<FORMAT> "tag"
Do This

<FORMAT> "body"
To set the hour, minute, or second, click a number in the current time and then click the arrows 
that appear. (Or you can type a new number.)

<COACH MARK>"CoachMark: 12"
<END PANEL>

<DEFINE PANEL> "Date & Time: saving"
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<FORMAT> "tag"
Do This

<FORMAT> "body"
To save your date and time settings, click anywhere outside the date and time boxes, or close the 
control panel.

<END PANEL>

# ####################
# The following panels are for “How do I name my computer?” 
# ####################

<DEFINE PANEL> "Sharing Setup: segue to install" 
<PANEL PROMPT> "Standard Prompts"

<FORMAT> "full"
The software you need, Sharing Setup control panel, is not installed. You need to install this 
software before you can complete this task.

<END PANEL>

# The panel "Startup disk: opening" is shared

# The panel "System Folder: locate" is shared

<DEFINE PANEL> "Sharing Setup: locate"
<FORMAT> "tag"
Do This

<FORMAT> "body"
Locate the Sharing Setup control panel. It’s part of the system software that came with your 
computer.

If you can’t find the control panel, click Huh? below for instructions.

<Dimmable Button Data> "Huh?","Definitions Tips for finding items"
<END PANEL>

# The panel "any resource: drag" is shared.

<DEFINE PANEL> "control panel: Restart for effect" 
<PANEL PROMPT> "Prompt Override: 29"

<FORMAT> "full"
Changes take effect after you restart the computer (by opening the Special menu and choosing 
Restart).

After you restart, you can open the Guide menu (on the right, with the ? icon), choose PowerTalk 
Guide, and return to this question.

<END PANEL>
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# The panel "Apple: choose Control Panels" is shared.

<DEFINE PANEL> "Sharing: open setup"
<FORMAT> "tag"
Do This

<FORMAT> "body"
Open the Sharing Setup control panel.

<COACH MARK>"Finder Coach Sharing Setup"
<END PANEL>

<DEFINE PANEL> "Sharing Setup: type name"
<FORMAT> "tag"
Do This

<FORMAT> "body"
Type your name in the box labeled Owner Name, and press the Tab key.

<COACH MARK>"CoachMark: 97"
<END PANEL>

<DEFINE PANEL> "Sharing Setup: password intro" 
<PANEL PROMPT> "Standard Prompts"

<FORMAT> "full"
Now decide on a password, which you’ll use to connect to your computer from another computer 
on the network. Don’t type the password yet.

Remember your password, including capitalization. Your password can be up to eight characters 
long.

For security, each character is replaced by a bullet (•) after you type it.

<END PANEL>

<DEFINE PANEL> "Sharing Setup: type password"
<FORMAT> "tag"
Do This

<FORMAT> "body"
Type a password in the box labeled Owner Password, and press the Tab key.

<COACH MARK>"CoachMark: 98"
<END PANEL>

<DEFINE PANEL> "Sharing Setup: type computer name"
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<FORMAT> "tag"
Do This

<FORMAT> "body"
Type a name for your computer in the box labeled Macintosh Name.

This is the name others see when they use the Chooser to connect to your computer.

<COACH MARK>"CoachMark: 99"
<END PANEL>

#
# CatalogInfoCard.panel
#
# The panels for “Catalogs & Info Cards”
# ©1993 Apple Computer, Inc.
#

#
# The beginning of the “How do I” portion of Catalogs & Info Card
#

# ####################
# The following panels are for “How do I browse catalog windows?” 
# ####################

<DEFINE PANEL> "browse catalog: intro" 
<FORMAT> "tag"
Do This

<FORMAT> "body"
Open the Catalogs icon on your desktop, then open the catalog you want to look at.

If you want to know more about where catalog information is stored, click Huh? below.

<Dimmable Button Data> "Huh?","Where is catalog information stored?"
<END PANEL>

<DEFINE PANEL> "catalog folders: open" 
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<FORMAT> "tag"
Do This

<FORMAT> "body"
Open catalog folders and the folders within them until you find the information you want.

IMPORTANT:  If you are not a network user, you may not be able to open some catalogs. You can 
still create and use personal catalogs.

<Dimmable Button Data> "Huh?","Where is catalog information stored?"
<END PANEL>

# ####################
# The following panels are for “Where is catalog information stored?” 
# ####################

<DEFINE PANEL> "ref: where is catalog: 1" 
<FORMAT> "full"
The location of information that is displayed when you open a catalog depends on the type of 
catalog. 

A personal catalog — and the information it contains — resides on your hard disk. It is like a 
document or folder stored on your hard disk.

<END PANEL>

<DEFINE PANEL> "ref: where is catalog: 2" 
<FORMAT> "full"
A catalog that displays information about a network — for example, the AppleTalk catalog — is 
not stored on your hard disk. Sometimes the information resides on a specialized server 
connected to the network. Sometimes the information resides on the network itself (this is how 
the AppleTalk catalog works).

<END PANEL>

<DEFINE PANEL> "ref: where is catalog: 3" 
<panel prompt> "override: rdone"

<FORMAT> "full"
If you disconnect your computer from your network, you can still see the information in your 
personal catalog, but some other kinds of catalogs may be empty.

You can copy items from any catalog to your personal catalog. When you do so, the item in your 
personal catalog “points to” the original item. Storing an item in your personal catalog makes it 
easier to find quickly.

<END PANEL>
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# ####################
# The following panels are for “How do I change how catalog items appear?” 
# ####################

<DEFINE PANEL> "howdoi: catalog items appear: begin" 
<FORMAT> "full"
You can change the order in which information is displayed in a catalog. You can also control 
whether all available information is displayed, or just the information you want to see.

To control the way items appear in an active catalog window, you use the View menu.

<END PANEL>

<DEFINE PANEL> "howdoi: catalog items appear: open catalog"
<panel prompt> "override: right"

<FORMAT> "tag"
Do This

<FORMAT> "body"
Open the catalog window you want to view. 

You can find catalogs inside your Catalogs icon. You locate your personal catalog by opening the 
Apple menu and choosing Personal Catalog from Mail and Catalogs.

<END PANEL>

<DEFINE PANEL> "howdoi: catalog items appear: use view menu"
<panel prompt> "override: ddone"

<FORMAT> "full"
To change the order in which items appear, choose one of the first two items in the View menu.

To change the kind of information displayed, choose one of the “filters” from the second part of 
the View menu.

When you choose a filter, only items of that kind are displayed in the catalog window.

<coach mark> "view-"
<END PANEL>

# ####################
# The following panels are for “How do I find an item in a catalog?” 
# ####################
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<DEFINE PANEL> "howdoi: find an item: begin" 
<FORMAT> "full"
You can locate items in any catalog to which you have access. You locate catalog items by 
opening the Apple menu and choosing Find in Catalog from Mail and Catalogs.

<END PANEL>

<DEFINE PANEL> "Apple: choose Find in Catalog"
<panel prompt> "override: right"

<FORMAT> "tag"
Do This

Do This

<FORMAT> "body"
Open the Apple () menu and choose Mail and Catalogs.

Open Find in Catalog.

<coach mark> "apple-mail and catalogs"
<END PANEL>

<DEFINE PANEL> "howdoi: find an item: find what"
<FORMAT> "tag"
Do This

<FORMAT> "body"
Use the Find pop-up menu to select the kind of items you want to find.

<coach mark> "find in findincatalog"
<END PANEL>

<DEFINE PANEL> "howdoi: find an item: find where"
<FORMAT> "tag"
Do This

<FORMAT> "body"
Use the In pop-up menu to specify where you want to search.

<coach mark> "in in findincatalog"
<END PANEL>

<DEFINE PANEL> "howdoi: find an item: start with"
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<FORMAT> "tag"
Do This

<FORMAT> "body"
Type the name of the item you want to find (or just type the first few letters of the name).

<coach mark> "start in findincatalog"
<END PANEL>

<DEFINE PANEL> "howdoi: find an item: click find"
<panel prompt> "override: ddone"

<FORMAT> "tag"
Do This

<FORMAT> "body"
Click Find.

Found items appear in the list in the Find in Catalog window. If no matching items are found, you 
hear a beep or see a message.

To copy an item, drag it from the list to another window or to the desktop.

To automatically copy an item to your personal catalog, click to select the item, then click Save.

<END PANEL>

# ####################
# The following panels are for “How do I use personal catalogs?” 
# ####################

<DEFINE PANEL> "ref: using personal catalogs: 1" 
<FORMAT> "full"
When you install PowerTalk system software, a personal catalog (called “Personal Catalog”) is 
automatically put into Mail and Catalogs in your Apple menu. You can have as many personal 
catalogs as you want. You can store personal catalogs anywhere on your hard disk, or on a 
floppy disk.

If you want to know more about where catalog information is stored, click Huh? below.

<dimmable button data> "Huh?", "Where is catalog information stored?"
<END PANEL>

<DEFINE PANEL> "ref: using personal catalogs: 2" 
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<FORMAT> "full"
One personal catalog is “preferred.” By default, the personal catalog installed in Mail and 
Catalogs in your Apple menu is preferred. You can choose any other personal catalog to be 
preferred. The preferred personal catalog is the one used by AppleMail and other PowerTalk-
compatible software you may have.

If you need more information about selecting a preferred personal catalog, click Huh? below for 
instructions.

<dimmable button data> "Huh?", "How do I select a preferred personal catalog?"
<END PANEL>

<DEFINE PANEL> "ref: using personal catalogs: 3" 
<FORMAT> "full"
You can use one personal catalog for all of the catalog items you want, or you can use several 
personal catalogs, keeping a particular set of items in each one. For example, you might have 
one personal catalog named “Business Contacts,” and another named “Friends.”

If you need more information about adding items to a personal catalog, click Huh? below for 
instructions.

<dimmable button data> "Huh?", "How do I add items to a personal catalog?"
<END PANEL>

# ####################
# The following panels are for “How do I add items to a personal catalog?” 
# ####################

<DEFINE PANEL> "add items to personal catalog: intro"
<FORMAT> "full"
There are many ways to add items to a personal catalog:
• Drag an item from a catalog directly into a personal
catalog window.
• Make an alias of a catalog item, and drag the alias into a personal catalog window.
• Choose Find in Catalog from Mail and Catalogs in the Apple menu, and click Save.
• Drag an item from the Recipients panel in the PowerTalk Mailer (click the Huh? button to find 
out more about the Mailer).

<dimmable button data> "Huh?", "Definition of Mailer"
<END PANEL>

<DEFINE PANEL> "Apple: choose Personal Catalog"
<panel prompt> "override: right"
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<FORMAT> "tag"
Do This

Do This

<FORMAT> "body"
Open the Apple () menu and choose Mail and Catalogs.

Open Personal Catalog. 

<coach mark> "apple-mail and catalogs"
<END PANEL>

<DEFINE PANEL> "catalog item: drag to personal catalog" 
<FORMAT> "tag"
Do This

<FORMAT> "body"
Open a catalog window and drag the desired items into the Personal Catalog window.

This makes a copy of each item and places it in your personal catalog.

If you need more information about removing items from a personal catalog, click Huh? below for 
instructions.

<dimmable button data> "Huh?", "How do I remove items from a personal catalog?"
<END PANEL>

# ####################
# The following panels are for “How do I remove items from a personal catalog?” 
# ####################

<DEFINE PANEL> "remove items from personal catalog: intro" 
<FORMAT> "full"
To delete any item in a personal catalog, drag the icon to the Trash and empty the Trash.

<END PANEL>

# ####################
# The following panels are for “How do I create an additional personal catalog?” 
# ####################

<DEFINE PANEL> "howdoi: personal catalog: begin" 
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<FORMAT> "full"
You can use a personal catalog to store catalog items (such as info cards) anywhere on your 
hard disk. 

You can create a new personal catalog whenever the Catalogs menu is available (the Catalogs 
menu appears when you open a catalog window).

<dimmable button data> "Huh?", "definition of catalog"
<END PANEL>

<DEFINE PANEL> "howdoi: personal catalog: open catalog"
<panel prompt> "override: right"

<FORMAT> "tag"
Do This

<FORMAT> "body"
Open the Catalogs icon.

<END PANEL>

<DEFINE PANEL> "howdoi: personal catalog: choose new"
<panel prompt> "override: ddone"

<FORMAT> "tag"
Do This

<FORMAT> "body"
Open the Catalogs menu and choose New Personal Catalog.

<coach mark> "catalogs-new personal"
<END PANEL>

# ####################
# The following panels are for “How do I select a preferred personal catalog?” 
# ####################

<DEFINE PANEL> "preferred personal catalog: intro" 
<FORMAT> "full"
When you have more than one personal catalog, you can select one to be preferred. The 
preferred personal catalog is indicated by a bookmark icon.

Applications that incorporate PowerTalk software can easily use items in your preferred personal 
catalog regardless of where it is located on your hard disk.

<END PANEL>

<DEFINE PANEL> "personal catalog icon: select" 
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<FORMAT> "tag"
Do This

<FORMAT> "body"
Select the icon of the personal catalog that you want to make preferred.

<END PANEL>

<DEFINE PANEL> "File: choose Get Info" 
<FORMAT> "tag"
Do This

<FORMAT> "body"
Open the File menu and choose Get Info.

<coach mark> "file-get info"
<END PANEL>

<DEFINE PANEL> "personal catalog info: click Set Preferred" 
<FORMAT> "tag"
Do This

<FORMAT> "body"
Click the Set Preferred button. If there is no button, the document you selected is not a personal 
catalog.

IMPORTANT:  If the Locked checkbox in the catalog’s Get Info window is selected, you won’t be 
able to make any changes to the contents of the personal catalog.

# IF WINDOW NAME ENDS IN INFO THEN COACH SET PREFERRED BUTTON
<END PANEL>

<DEFINE PANEL> "Get Info box: close" 
<FORMAT> "tag"
Do This

<FORMAT> "body"
Close the Get Info box.

<coach mark> "closebox"
<END PANEL>

# ####################
# The following panels are for “How do I print a personal catalog?” 
# ####################

<DEFINE PANEL> "howdoi: print catalog: begin" 
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<FORMAT> "full"
You can print a list of the contents of your personal catalog.

<END PANEL>

# The panel "Apple: choose Personal Catalog" is shared

<DEFINE PANEL> "howdoi: print catalog: sort"
<panel prompt> "override: dndone"

<FORMAT> "tag"
Optional

<FORMAT> "body"
You can use the View menu to see and print everything in your personal catalog, or only the items 
you want. 

To see and print everything in your personal catalog, choose All from the View menu. To see and 
print only the items you want, choose a type of item from the View menu.

To change the order of items in the personal catalog window, choose By Name or By Kind from 
the View menu.

<dimmable button data> "Huh?", "How do I change the way items appear in a catalog window?"
<coach mark> "view-"

<END PANEL>

<DEFINE PANEL> "File: choose Print Window"
<panel prompt> "override: ddone"

<FORMAT> "tag"
Do This

<FORMAT> "body"
Open the File menu and choose Print Window.

When the Print dialog box appears, click Print to print your personal catalog.

<coach mark> "file-print window"
<END PANEL>

# ####################
# The following panels are for “How do I use information cards?” 
# ####################

<DEFINE PANEL> "ref: using information cards: 1" 
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<FORMAT> "full"
An information card contains catalog information. A user’s information card can contain practically 
anything, including electronic addresses, telephone numbers, and even pictures.

<dimmable button data> "Huh?", "Definition of electronic addresses"
<END PANEL>

<DEFINE PANEL> "ref: using information cards: 2" 
<FORMAT> "full"
You can use individual information cards for communicating with people, and for looking up 
information about addresses and telephone numbers. To create an information card, you open a 
personal catalog and use the Catalogs menu. You can store information cards anywhere on your 
hard disk or on a floppy disk.

If you need more information about creating information cards, click Huh? below for instructions.

<dimmable button data> "Huh?", "How do I create an information card?"
<END PANEL>

<DEFINE PANEL> "ref: using information cards: 3" 
<panel prompt> "override: rdone"

<FORMAT> "full"
Group icons can be convenient for interacting with teams of people. You can create any number 
of groups. You can add a person to a group by dragging that person’s information card to the 
group information card. You can also add a group to another group.

If you need more information about creating group icons, click Huh? below for instructions.

<dimmable button data> "Huh?", "How do I create group icons?"
<END PANEL>

# ####################
# The following panels are for “How do I create an information card?” 
# ####################

<DEFINE PANEL> "howdoi: create info card: begin" 
<FORMAT> "full"
An information card (info card) represents a person or group you communicate with. You make 
info cards in your personal catalog.

<dimmable button data> "Huh?", "definition of information card"
<END PANEL>

# The panel "Apple: choose Personal Catalog" is shared
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<DEFINE PANEL> "howdoi: create info card: user or group" 
<FORMAT> "full"
You can create an info card that represents a single person, or a group of people. Which do you 
want to do?

<radio button> "Create an info card for a person", true,,,,appleguide
<radio button> "Create an info card for a group", false,,,,appleguide

<END PANEL>

<DEFINE PANEL> "Catalogs: choose New User"
<FORMAT> "tag"
Do This

<FORMAT> "body"
Open the Catalogs menu and choose New User. 

<coach mark> "catalogs-new user"
<END PANEL>

<DEFINE PANEL> "new user info card: type name" 
<panel prompt> "override: ddone"
<FORMAT> "tag"
Do This

<FORMAT> "body"
When the new info card appears, type its name.

<END PANEL>

<DEFINE PANEL> "Catalogs: choose New Group" 
<FORMAT> "tag"
Do This

<FORMAT> "body"
Open the  Catalogs menu and choose New Group.

<coach mark> "catalogs-new group"
<END PANEL>

<DEFINE PANEL> "new group icon: type name" 
<FORMAT> "tag"
Do This

<FORMAT> "body"
When the new group icon appears, type its name.

<END PANEL>
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# ####################
# The following panels are for “How do I modify an information card?” 
# ####################

<DEFINE PANEL> "howdoi: change info card: begin" 
<FORMAT> "full"
You can work with info cards in your personal catalog, or with info cards stored elsewhere on your 
hard disk.

Which do you want to do?

<radio button> "Change an info card in my personal catalog", true,,,,appleguide
<radio button> "Change an info card stored elsewhere", false,,,,appleguide

<END PANEL>

# The panel "Apple: choose Personal Catalog" is shared

<DEFINE PANEL> "howdoi: change info card: find card"
<FORMAT> "tag"
Do This

<FORMAT> "body"
Open the window containing the info cards you want to change. If the info cards are on the 
desktop, make sure you can see them by closing any windows that cover them.

<END PANEL>

<DEFINE PANEL> "howdoi: change info card: user or group" 
<FORMAT> "full"
You can change the information for an individual user, or for the list of people assigned to a 
group. Which do you want to do?

<radio button> "Change an info card for a user", true,,,,appleguide
<radio button> "Change an info card for a group", false,,,,appleguide

<END PANEL>

<DEFINE PANEL> "howdoi: change info card: open user"
<panel prompt> "override: ddone"

<FORMAT> "tag"
Do This

<FORMAT> "body"
Open the info card you want to change. 

To change information in an info card, use the pop-up menu to choose a page, then type your 
new information in the appropriate place.

<END PANEL>
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<DEFINE PANEL> "howdoi: change info card: change group"
<panel prompt> "override: ddone"

<FORMAT> "tag"
Do This

<FORMAT> "body"
To add an item to the group, drag it to the group icon. You can add both users and groups to a 
group. 

To remove an item from the group, open the group icon. Then drag the item out of the window. 
You can drag the item to the desktop, to a folder, or to the Trash.

<END PANEL>

# ####################
# The following panels are for “How do I create group icons?” 
# ####################

<DEFINE PANEL> "create group icons: intro"
<FORMAT> "full"
Group icons can be used to send mail to all members of a specific project or team. You can 
create as many groups as you want.

<END PANEL>

# The panel "Apple: choose Personal Catalog" is shared
# The panel "Catalogs: choose New Group" is shared
# The panel "new group icon: type name" is shared

<DEFINE PANEL> "new group icon: drag to" 
<FORMAT> "tag"
Do This

<FORMAT> "body"
To add users or groups to the group icon, drag user or group icons to it.

<END PANEL>

#
# SendingReceiving.panel
#
# The panels for “Sending and Receiving”
# ©1993 Apple Computer, Inc.
#
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#
# The beginning of the “How do I” portion of Sending and Receiving
#

# ####################
# “How do I send letters and documents?” panels are included in PowerTalkBasic.Panel
# ####################

# ####################
# “How do I read my incoming mail?” panels are included in PowerTalkBasic.Panel
# ####################

# ####################
# The following panels are for “How do I change the way mailbox items appear?” 
# ####################

<DEFINE PANEL> "howdoi: mailbox items appear: begin" 
<FORMAT> "full"
You can change the order in which information is displayed in your mailbox. You can also control 
whether all available information is displayed, or just the information you want to see.

To control the way items appear in an active mailbox window, you use the View menu.

<END PANEL>

## The next 2 panels are the same as the ones in 
## “How do I read my incoming mail?” in PowerTalkBasic.Panel
## "howdoi: read my mail: open mailbox"
## "howdoi: read my mail: enter access code"

<DEFINE PANEL> "howdoi: mailbox items appear: change order"
<panel prompt> "override: shortcut"

<FORMAT> "full"
To change the order in which items appear, choose one of the first set of items in the View menu, 
shown here.

<pict> 1006, center
<END PANEL>

<DEFINE PANEL> "howdoi: mailbox items appear: change filter"
<panel prompt> "read & click"
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<FORMAT> "full"
You can change the kind of information displayed (in the In Tray window) by choosing one of the 
“filters” from the second part of the View menu, shown here.

When you choose a filter, only items of that kind are displayed in the In Tray window.

<pict> 1008, center
<END PANEL>

<DEFINE PANEL> "howdoi: mailbox items appear: shortcut"
<panel prompt> "override: rdone"

<FORMAT> "tag"
Do This

<FORMAT> "body"
To quickly change the order in which items appear in a mailbox window, click a heading over a 
column of information. Mailbox items are sorted according to that type of information.

<END PANEL>

# ####################
# The following panels are for “How do I take my mail with me to read later?” 
# also known as copylocal
# ####################

<DEFINE PANEL> "howdoi: take my mail: begin" 
<FORMAT> "full"
Some kinds of electronic mail appear in your mailbox only when your computer is connected to 
your network. This is because some mail items are stored elsewhere — for example, on a 
PowerShare collaboration server.

If you use a PowerBook, you can make sure that your mail is available when your computer is no 
longer connected to the network. 

To take mail with you, you open your mailbox and copy messages to your local hard disk.

<END PANEL>

## The next 2 panels are the same as the ones in 
## “How do I read my incoming mail?” in PowerTalkBasic.Panel
## "howdoi: read my mail: open mailbox"
## "howdoi: read my mail: enter access code"



PowerTalk Guide Panels 1.0b2 38 May 21, 2025

<DEFINE PANEL> "Edit: choose Select All"
<FORMAT> "tag"
Do This

<FORMAT> "body"
Open the Edit menu and choose Select All.

If Select All is dimmed, there is no mail in your mailbox. Try this procedure again when you have 
mail waiting to be read.

<coach mark> "edit-select all"
<END PANEL>

<DEFINE PANEL> "Mailbox: choose copy local"
<FORMAT> "tag"
Do This

<FORMAT> "body"
Open the Mailbox menu and choose Copy Local.

<coach mark> "mailbox-copy local"
<END PANEL>

<DEFINE PANEL> "howdoi: take my mail: respond"
<panel prompt> "override: ddone"

<FORMAT> "tag"

Do This

<FORMAT> "body"
The original copies of your mail (the copies stored elsewhere) are automatically marked as if you 
have read the mail. To avoid that marking, click to remove the X next to “Mark originals as read.”

Click OK to copy your mail to your local hard disk. 

<END PANEL>

# ####################
# The following panels are for “How do I set mail preferences?” 
# ####################

<DEFINE PANEL> "set mail preferences: intro" 
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<FORMAT> "full"
You can set preferences for displaying mail, announcing the arrival of incoming mail, and letting 
others check their PowerShare mail from your computer.

<END PANEL>

<DEFINE PANEL> "Mailbox: open" 
<panel prompt> "override: right"
<FORMAT> "tag"
Do This

<FORMAT> "body"
Open the mailbox.

# COACH THE MAILBOX ICON
# We can't coach the PowerTalk desktop icon for sure

<END PANEL>

<DEFINE PANEL> "Mailbox: choose Preferences" 
<FORMAT> "tag"
Do This

<FORMAT> "body"
Open the Mailbox menu and choose Preferences.

<coach mark> "mailbox-preferences"
<END PANEL>

<DEFINE PANEL> "Mailbox Preferences: set options" 
<panel prompt> "override: ddone"
<FORMAT> "tag"
Do This

<FORMAT> "body"
Set the options to suit your needs, then click the close box to close the window. Changes take 
effect immediately.

<END PANEL>

# ####################
# The following panels are for “How do I allow a guest to get mail?” 
# ####################

<DEFINE PANEL> "howdoi: guest: begin" 
<FORMAT> "full"
You can use visitors’ mailboxes to let other people receive their electronic mail on your computer. 

<END PANEL>
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## The next 2 panels are the same as the ones in 
## “How do I read my incoming mail?” in PowerTalkBasic.Panel
## "howdoi: read my mail: open mailbox"
## "howdoi: read my mail: enter access code"

# The panel "Mailbox: choose Preferences" is shared

<DEFINE PANEL> "howdoi: guest: allow visitor"
<FORMAT> "tag"
Do This

<FORMAT> "body"
Click to place an X in the box next to “Allow visitor’s mailbox.”

<coach mark> "allow visitor"
<END PANEL>

<DEFINE PANEL> "Special: choose visitor's mailbox"
<FORMAT> "tag"
Do This

<FORMAT> "body"
Open the Special menu and choose Visitor’s Mailbox.

<coach mark> "special-visitor's mailbox"
<END PANEL>

<DEFINE PANEL> "howdoi: guest: visitor access info"
<panel prompt> "override: ddone"

<FORMAT> "tag"
Do This

<FORMAT> "body"
Let your visitor use the dialog box to choose his or her PowerTalk service, and type his or her 
name and password for that service.

A mailbox with your visitor’s name appears on your desktop.

Visitors’ mailboxes go away when you shut down or restart your computer. You can also remove a 
visitor’s mailbox by dragging it to the Trash.

<END PANEL>

# ####################
# The following panels are for “How do I check my mail from another computer?” 
# ####################
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<DEFINE PANEL> "howdoi: another computer: begin" 
<FORMAT> "full"
To receive your electronic mail on a different computer, the owner of that computer must set up 
the PowerTalk software to allow visitors’ mailboxes. 

If the owner of the computer needs help setting up a guest mailbox, click Huh? below for 
instructions.

<dimmable button data> "Huh?", "How do I allow a guest to get mail?"
<END PANEL>

# ####################
# The following panels are for “How do I check the status of mail I've sent?” 
# ####################

<DEFINE PANEL> "howdoi: message I sent: begin" 
<FORMAT> "full"
You use your Out Tray to see what mail you’ve sent, and to check the status of those messages.

<END PANEL>

## The next 2 panels are the same as the ones in 
## “How do I read my incoming mail?” in PowerTalkBasic.Panel
## "howdoi: read my mail: open mailbox"
## "howdoi: read my mail: enter access code"

<DEFINE PANEL> "Mailbox: choose out tray"
<FORMAT> "tag"
Do This

<FORMAT> "body"
Open the Mailbox menu and choose Out Tray.

<coach mark> "mailbox-out tray"
<END PANEL>

<DEFINE PANEL> "howdoi: message I sent: status" 
<panel prompt> "read & click"



PowerTalk Guide Panels 1.0b2 42 May 21, 2025

<FORMAT> "full"
The information under the Status heading indicates the current state of each message you’ve 
sent.

Sending means the message is in the process of being sent.

Waiting means the message is waiting to be sent. Select a waiting message and choose Send 
Now from the Mailbox menu to send the message immediately.

<END PANEL>

<DEFINE PANEL> "howdoi: message I sent: status2" 
<panel prompt> "override: rdone"

<FORMAT> "full"
Done means the message has been sent from your computer.

IMPORTANT: “Done” does not mean that a message has been delivered and received. It only 
means that the message has gone out over the network.

<END PANEL>

# ####################
# The following panels are for “How do I use tags to view mail I receive?” 
# ####################

<DEFINE PANEL> "howdoi: use tags: begin" 
<FORMAT> "full"
Tags are keywords you use to identify and categorize your mail. You can choose to see only the 
items in your In Tray that have a particular tag.

<END PANEL>

## The next 2 panels are the same as the ones in 
## “How do I read my incoming mail?” in PowerTalkBasic.Panel
## "howdoi: read my mail: open mailbox"
## "howdoi: read my mail: enter access code"

<DEFINE PANEL> "howdoi: use tags: with tag"
<FORMAT> "tag"
Do This

<FORMAT> "body"
Choose With Tag from the View menu.

<coach mark> "view-with tag"
<END PANEL>
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<DEFINE PANEL> "howdoi: use tags: choose the tag"
<panel prompt> "override: ddone"

<FORMAT> "tag"
Do This

<FORMAT> "body"
Type in the box a word or phrase to use as a tag.  If you want to use a tag you entered previously, 
choose it from the pop-menu.

Click OK when you’re finished.

<coach mark> "with tag dialog circle"
<END PANEL>

# ####################
# The following panels are for “How do I see tags added to my mail?” 
# ####################

<DEFINE PANEL> "see tags: intro" 
<FORMAT> "full"
Tags appear in an item’s Info box when you open the Info box from within the In Tray.

<END PANEL>

<DEFINE PANEL> "see tags: select items" 
<FORMAT> "tag"
Do This

<FORMAT> "body"
Select the item in the In Tray whose tags you want to see.

<END PANEL>

# The panel "File: choose Get Info" is shared

<DEFINE PANEL> "Info: look in tags area" 
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<FORMAT> "tag"
Do This

<FORMAT> "body"
Look in the Tags area at the bottom of the Info window.

The tags you’ve assigned appear in a list separated by commas.

IMPORTANT: When you move a letter out of the mailbox, tags are removed.

<END PANEL>

# ####################
# The following panels are for “How do I add or remove tags from mail I receive?” 
# ####################

<DEFINE PANEL> "howdoi: add or remove tags: begin" 
<FORMAT> "full"
Tags are keywords you use to identify and categorize your mail. You can add one or more tags to 
each piece of mail in your In Tray.

<END PANEL>

## The next 2 panels are the same as the ones in 
## “How do I read my incoming mail?” in PowerTalkBasic.Panel
## "howdoi: read my mail: open mailbox"
## "howdoi: read my mail: enter access code"

<DEFINE PANEL> "howdoi: add or remove tags: choose item"
<FORMAT> "tag"
Do This

<FORMAT> "body"
Click to select the item you want to work with.

<END PANEL>

<DEFINE PANEL> "Mailbox: choose Tag"
<FORMAT> "tag"
Do This

<FORMAT> "body"
Open the Mailbox menu and choose Tag.

<coach mark> "mailbox-tag"
<END PANEL>
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<DEFINE PANEL> "howdoi: add or remove tags: add or remove"
<panel prompt> "override: ddone"

<FORMAT> "tag"
Do This

<FORMAT> "body"
Type in the box a word or phrase to use as a tag.  If you want to use a tag you entered previously, 
choose it from the pop-menu.

To attach the tag to the item in your In Tray, click Add. To remove the tag from the item, click 
Remove.

<coach mark> "tag dialog circle"
<END PANEL>

# ####################
# The following panels are for “How do I remove a tag from my tag list?” 
# ####################

<DEFINE PANEL> "howdoi: remove a tag: begin" 
<FORMAT> "full"
When you create a tag to use with an item in your In Tray, the tag is added to your tag list.

<dimmable button data> "Huh?", "Definition of tag"
<END PANEL>

## The next 3 panels are the same as the ones in 
## “How do I read my incoming mail?” in PowerTalkBasic.Panel
## "howdoi: read my mail: open mailbox"
## "howdoi: read my mail: enter access code"
## "howdoi: guest: preferences"

<DEFINE PANEL> "howdoi: remove a tag: click edit"
<FORMAT> "tag"
Do This

<FORMAT> "body"
Click Edit.

<coach mark> "edit button"
<END PANEL>

<DEFINE PANEL> "howdoi: remove a tag: tags list"
<panel prompt> "override: ddone"



PowerTalk Guide Panels 1.0b2 46 May 21, 2025

<FORMAT> "tag"
Do This

<FORMAT> "body"
Click a tag in the list to select it, then click Delete.

To select more than one tag, click and drag, or hold down the Shift key when you click each tag.

When you’ve removed all the tags you want to delete, click Done.

<END PANEL>

# ####################
# The following panels are for “How do I activate mail connections?” 
# ####################

<DEFINE PANEL> "activate mail connections: intro" 
<FORMAT> "full"
You can specify your physical location — at work, at home, or on the road — to activate 
appropriate mail connections when you log on. Your choice determines the services through 
which you send and receive mail.

<END PANEL>

<DEFINE PANEL> "Special: choose I’m at..." 
<FORMAT> "tag"
Do This

<FORMAT> "body"
Open the Special menu and choose “I’m at.”

<coach mark> "special-i’m at"
<END PANEL>

<DEFINE PANEL> "Current location: select" 
<FORMAT> "tag"

Do This

<FORMAT> "body"
A dialog box appears, listing all the services you have installed.

Use the pop-up menu to select your current location.

# COACH THE POP-UP MENU
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<END PANEL>

<DEFINE PANEL> "Services: activate" 
<FORMAT> "tag"
Do This

<FORMAT> "body"
Check the services that you want to activate.

If you select “off-line,” all services are automatically unchecked. While offline you can create 
letters for later mailing. “Sending” a letter while you are offline puts the letter in your Out Tray for 
delivery when you are connected to the proper service.

<END PANEL>

<DEFINE PANEL> "setting changes: click OK" 
<FORMAT> "tag"
Do This

<FORMAT> "body"
Click OK when you have finished making changes to your settings.

If you have made changes, you’ll see a message. Read the information and click OK.

<END PANEL>

# ####################
# The following panels are for “How do I copy mail locally to my In Tray?” 
# ####################

<DEFINE PANEL> "copy mail locally to my In Tray: intro" 
<FORMAT> "full"
Mail whose location is marked “remote” in your In Tray resides on a server. You can copy remote 
mail so that it resides locally in your In Tray. 

<END PANEL>

# The panel "Mailbox: open" is shared

<DEFINE PANEL> "In Tray: select remote mail" 
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<FORMAT> "tag"
Do This

<FORMAT> "body"
Select the remote mail you want to copy.

<END PANEL>

# The panel "Mailbox: choose copy local" is shared

<DEFINE PANEL> "original items: mark as read and click OK" 
<FORMAT> "tag"
Do This

<FORMAT> "body"
A dialog box appears.

If you wish, select the option to have the original items marked as read. Click OK.

<END PANEL>

<DEFINE PANEL> "copy mail locally: outro" 
<FORMAT> "full"
A copy of the mail you have selected appears in the mailbox with its location marked “local” 
(meaning it resides on your hard disk).

The original “remote” mail remains on the server and in your In Tray until you remove it.

<END PANEL>

# ####################
# The following panels are for “How do I send mail written off line?” 
# ####################

<DEFINE PANEL> "send mail written off line: intro" 
<FORMAT> "full"
When you “send” mail while you are offline, the mail goes into your Out Tray. The mail is 
automatically sent as soon as you reactivate your mail connections (and unlock your key chain).

<END PANEL>

#
# DigitalSignatures.panel
#
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# The panels for “Digital Signatures”
# ©1993 Apple Computer, Inc.
#

#
# The beginning of the “Overview” portion of Digital Signatures
#

# ####################
# The following panels are for “Digital Signatures Overview” 
# ####################

<DEFINE PANEL> "ref: about digital signature: 1" 
<FORMAT> "full"
You use a DigiSign Signer to approve, or “sign,” a document on your computer. Putting your 
digital signature on a document ensures the integrity of the document. It marks the document in a 
way that any PowerTalk user — even those without Signers of their own — can verify at any time.

For information on the types of Signer files available, click Huh? below.

<dimmable button data> "Huh?", "Definition of Signer approvals"
<END PANEL>

<DEFINE PANEL> "ref: about digital signature: 2" 
<FORMAT> "full"
PowerTalk software comes with a sample DigiSign Signer, which is not “approved.” This means 
that you can use the sample Signer for practice, but it cannot ensure the integrity of the 
documents you sign, because every PowerTalk user has the same sample Signer. The approval 
process gives you a Signer that is yours alone.

If you need more information about signing a document, click Huh? below for instructions.

<dimmable button data> "Huh?", "How do I sign a document?"
<END PANEL>

<DEFINE PANEL> "ref: about digital signature: 3" 
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<FORMAT> "full"
You may be able to use the DigiSign Utility program to begin the process of getting an approved 
Signer (your organization may provide a different program that does the same thing). The 
DigiSign Utility creates a request form with information about you. You print the form, and send it 
to a person or agency with the authority to issue you an approval file.

If you need more information about obtaining a valid Signer, click Huh? below for instructions.

<coach mark> "finder DigiSign icon"
<dimmable button data> "Huh?", "How do I obtain a valid Signer file?"

<END PANEL>

<DEFINE PANEL> "ref: about digital signature: 4" 
<panel prompt> "override: rdone"

<FORMAT> "full"
After you receive your approval file, you use the DigiSign Utility program again to produce your 
approved Signer.

For help using DigiSign Utility, choose DigiSign Utility Help from the Guide menu (on the right, 
with the ? icon) after you open DigiSign Utility.

If you need more information about approving a Signer, click Huh? below for instructions.

<dimmable button data> "Huh?", "How do I approve my Signer file?"
<END PANEL>

#
# The beginning of the “How do I” portion of Digital Signatures
#

# ####################
# The following panels are for “How do I obtain a valid Signer file?” 
# ####################

<DEFINE PANEL> "howdoi: obtain a signer file: begin" 
<panel prompt> "override: moreinfo"

<FORMAT> "full"
To obtain a valid Signer file, you send a request form to a person or agency who has the authority 
to issue you an approval file.

If your company has been authorized to issue approval files for its employees, you will probably 
use a special Signer request form provided by your company.

<END PANEL>
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<DEFINE PANEL> "howdoi: obtain a signer file: use" 
<FORMAT> "full"
To print a form requesting an unaffiliated Signer file, you use the DigiSign Utility program located 
in the PowerTalk folder. (The name of the program may be different if your company has a 
customized DigiSign Utility.)

For information on the types of Signer files available, click Huh? below.

<dimmable button data> "Huh?", "Definition of Signer approvals"
<END PANEL>

<DEFINE PANEL> "DigiSign Utility: open" 
<FORMAT> "tag"
Do This

<FORMAT> "body"
Open the DigiSign Utility program.

The program opens with a welcome screen.

<coach mark> "finder DigiSign icon"
<END PANEL>

<DEFINE PANEL> "File: choose New Request" 
<FORMAT> "tag"
Do This

<FORMAT> "body"
Open the File menu and choose New Request.

A Signer request form appears on the screen.

<coach mark> "file-new request" 
<END PANEL>

<DEFINE PANEL> "Signer request form: type info" 
<FORMAT> "tag"
Do This

<FORMAT> "body"
Type the appropriate information.

Use the Tab key to move from item to item.

IMPORTANT: Memorize the phrase you type for your verification with approval authority. If you 
contact the approval authority with a problem, they will need to know this phrase before they can 
help you.

<END PANEL>
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<DEFINE PANEL> "Signer request form: click Postal Address" 
<FORMAT> "tag"
Do This

<FORMAT> "body"
If your Signer request form has a Postal Address button, click the button and type in the 
information requested.

<END PANEL>

<DEFINE PANEL> "Signer request form: click OK" 
<FORMAT> "tag"
Do This

<FORMAT> "body"
When you are satisfied that the information in the Signer Request is correct, click OK.

#<coach mark> NEED COACH FOR OK
<END PANEL>

<DEFINE PANEL> "Identification code: type" 
<FORMAT> "tag"
Do This

<FORMAT> "body"
When another dialog box appears, type the identification code you'll use when using your 
approved Signer.

For tips for choosing an identification code, click Huh? below.

<dimmable button data> "Huh?", "Tips for choosing an identification code"
<END PANEL>

<DEFINE PANEL> "Identification code creation dialog box: close" 
<FORMAT> "tag"
Do This

<FORMAT> "body"
Click OK to close the identification code creation dialog box.

#<coach mark> NEED COACH FOR OK
<END PANEL>

<DEFINE PANEL> "Signer file: save" 
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<FORMAT> "tag"
Do This

<FORMAT> "body"
When the Save dialog box appears, choose a location for saving your unapproved Signer file and 
click Save.

Another dialog box appears, telling you that the program is creating files for you. (The process 
takes a few minutes.)

#<coach mark> NEED COACH FOR 
<END PANEL>

<DEFINE PANEL> "Files created: OK" 
<FORMAT> "tag"

Do This

<FORMAT> "body"
When the files have been created, a dialog box appears.

Read the information, then click OK.

Your newly generated request form appears with the encoded request information.

<END PANEL>

<DEFINE PANEL> "Request form: save" 
<FORMAT> "tag"
Do This

<FORMAT> "body"
Open the File menu and choose Save.

You have now created two files, a request and an unapproved Signer (which is not yet usable).

<END PANEL>

<DEFINE PANEL> "Request form: print" 
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<FORMAT> "tag"
Do This

<FORMAT> "body"
Print your Signer Request form.

If the software notifies you that your Signer Request form is too long to fit on a single printed 
page, or if your form was generated by a printer whose resolution is less than 300 dots per inch, 
you must also include a copy of the request file on disk.

<END PANEL>

<DEFINE PANEL> "Request form: submit" 
<FORMAT> "full"
To submit a Signer Approval Request to RSA Certificate Services:

•  Take your printed Signer Request form to a notary public (or equivalent) along with three (3) 
forms of identification, as described on the Signer Request form.

•  Mail your notarized Signer Request form and disk containing a copy of the request file (if 
required) to:

                 RSA Certificate Services
                 P.O. Box 2004
                 Belmont, CA 94002
                 USA

<END PANEL>

<DEFINE PANEL> "howdoi: obtain a signer file: end" 
<FORMAT> "full"
If necessary, RSA will contact you for any missing information. Otherwise, RSA will generate and 
send back your Signer Approval File.

If you need more information about approving a Signer, click Huh? below for instructions.

<dimmable button data> "Huh?", "How do I approve my Signer file?"
<END PANEL>

# ####################
# The following panels are for “How do I approve my Signer file?” 
# ####################

<DEFINE PANEL> "howdoi: approve my signer file: begin" 
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<FORMAT> "full"
Before you can approve your Signer file, you must have requested and received a Signer 
Approval file from your approval authority.

If you need more information about obtaining a valid Signer, click Huh? below for instructions.

<dimmable button data> "Huh?", "How do I obtain a valid Signer file?"
<END PANEL>

<DEFINE PANEL> "howdoi: approve my signer file: copy" 
<panel prompt> "override: right"

<FORMAT> "tag"
Do This

<FORMAT> "body"
Make a copy of your unapproved Signer file.

You need to keep a copy of your unapproved Signer in case problems occur during this 
procedure.

<END PANEL>

<DEFINE PANEL> "howdoi: approve my signer file: open" 
<FORMAT> "tag"
Do This

<FORMAT> "body"
Open your unapproved Signer file.

<END PANEL>

<DEFINE PANEL> "Signer: choose approve" 
<FORMAT> "tag"
Do This

<FORMAT> "body"
Open the Signer menu and choose Approve/Renew Signer.

<coach mark> "signer-approve"
<END PANEL>

<DEFINE PANEL> "howdoi: approve my signer file: approve" 
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<FORMAT> "tag"
Do This

<FORMAT> "body"
Choose your Signer Approval file, then click Open.

The process of creating your approved Signer takes a few moments. When it’s finished, click OK 
in the dialog box that appears.

The icon of your Signer changes to show that it is now approved.

<END PANEL>

<DEFINE PANEL> "signer file: important" 
<panel prompt> "override: rdone"

<FORMAT> "full"
IMPORTANT: Treat your approved Signer file as you would an ATM card, keeping it in a secure 
place and limiting access to it. For example, you may want to keep your approved Signer file on a 
floppy disk that you carry with you. Know whom to contact if you ever need to revoke the Signer. 
If you learn that someone is trying to use your Signer, notify your approval authority immediately.

<END PANEL>

# ####################
# The following panels are for “How do I sign a document?” 
# ####################

<DEFINE PANEL> "howdoi: sign a document: begin" 
<FORMAT> "tag"
Do This

<FORMAT> "body"
To use your Signer to digitally sign a document, drag the icon of the document to your Signer 
icon.

<dimmable button data> "Huh?", "What is a digital signature?"
<END PANEL>

<DEFINE PANEL> "howdoi: sign a document: 2" 
<panel prompt> "override: ddone"
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<FORMAT> "tag"
Do This

<FORMAT> "body"
Type your DigiSign Identification Code in the dialog box that appears, and click OK.

IMPORTANT:  Signing a document also locks the document. Changing a signed document 
invalidates the signature.

<END PANEL>

# ####################
# The following panels are for “How do I check a digital signature?” 
# ####################

<DEFINE PANEL> "howdoi: check a digital signature: begin" 
<FORMAT> "full"
When a document has been digitally signed, you can verify who signed the document, and that 
the document has not been changed since it was signed.

You use the Get Info command in the File menu to verify a digital signature.

<END PANEL>

<DEFINE PANEL> "howdoi: check a digital signature: choose item" 
<panel prompt> "override: right"

<FORMAT> "tag"
Do This

<FORMAT> "body"
Select the document you want to verify.

<END PANEL>

# The panel "File: choose Get Info" is shared

<DEFINE PANEL> "howdoi: check a digital signature: verify"
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<FORMAT> "tag"
Do This

Do This

<FORMAT> "body"
Click the verification button to the right of the Comments area. If there is no button, the document 
you selected does not have a digital signature.

A dialog box appears, asking if you want to verify or remove the signature.

Click Verify.

<END PANEL>

<DEFINE PANEL> "howdoi: check a digital signature: verify2"
<FORMAT> "tag"

Do This

<FORMAT> "body"
A progress indicator tells you that the signature is being checked.

If the signature is verified, a dialog box with signature information appears. When you’re finished 
reading the information, click OK.

IMPORTANT: If the signature isn’t verified, contact the person who sent the document or your 
approval authority.

<END PANEL>

<DEFINE PANEL> "howdoi: check a digital signature: verify3"
<panel prompt> "override: rdone"

<FORMAT> "tag"
Tip

<FORMAT> "body"
To verify the digital signature without the dialog box appearing, hold down the Option key while 
you click the verification button.

If the signature is verified, a dialog box with signature information appears.

<END PANEL>
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#
# Troubleshooting.panel
#
# The panels for “Troubleshooting”
# ©1993 Apple Computer, Inc.
#

#
# The beginning of the “Why can’t I” portion of Troubleshooting
#

# ####################
# The following panels are for “Why can’t I access a server on my network?” 
# ####################

<DEFINE PANEL> "access a server on my network: intro" 
<FORMAT> "full"
If you get a message that the system can no longer access a server on your network and a 
Resolve button appears in the notification dialog box, click the button to reconnect.

If you are still having problems, check the cable connection on the back of your computer.

<END PANEL>

# ####################
# The following panels are for “Why can’t I find Key Chain?” 
# ####################

<DEFINE PANEL> "whycanti: find key chain: begin" 
<panel prompt> "override: keychain"

<FORMAT> "full"
If you have thrown away your key chain, you can create a new one using the PowerTalk Setup 
control panel.

If you can’t find the key chain, click Huh? below for instructions. 

<Dimmable Button Data> "Huh?","Definitions Tips for finding items"
<END PANEL>

## The next 2 panels are from “How do I turn PowerTalk on and off?”
## "Apple: choose control panels"
## "PowerTalk Setup: open"
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<DEFINE PANEL> "whycanti: find key chain: click key chain" 
<panel prompt> "override: ddone"

<FORMAT> "tag"
Do This

<FORMAT> "body"
Click Key Chain.

If your key chain still exists it will open. If it doesn't, click Create in the dialog box that appears. 

<coach mark> "key chain…"
<END PANEL>

# ####################
# The following panels are for “Why can’t I find my AppleTalk mail address?” 
# ####################

<DEFINE PANEL> "find my AppleTalk mail address: intro" 
<FORMAT> "full"
If you can’t find your own Direct AppleTalk mail address, the machine name may be missing.

If you don’t know how to name your computer, click Huh? below for instructions.

<Dimmable Button Data> "Huh?","How do I name my computer?"
<END PANEL>

# ####################
# The following panels are for “Why can’t I find the Mailbox or Catalogs icon?” 
# ####################

<DEFINE PANEL> "whycanti: find the Mailbox or Catalogs: begin" 
<FORMAT> "full"
If you can’t find the Mailbox or Catalogs icons, PowerTalk is probably turned off. To turn 
PowerTalk on, use the PowerTalk Setup control panel.

<END PANEL>

## The next 5 panels are from “How do I turn PowerTalk on and off?”
## sequence under “PowerTalk basic” topic

# ####################
# The following panels are for “Why can’t I receive mail?” 
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# ####################

<DEFINE PANEL> "whycanti: can’t receive mail: begin" 
<FORMAT> "full"
If you’re not receiving mail, the machine name may be missing.

If you don’t know how to name your computer, click Huh? below for instructions.

<Dimmable Button Data> "Huh?","How do I name my computer?"
<END PANEL>

# ####################
# The following panels are for “Why can’t I send mail?” 
# ####################

<DEFINE PANEL> "whycanti: can’t send mail: begin" 
<FORMAT> "full"
If someone does not receive a message you sent, you may get a problem report in your In Tray. A 
message that is not delivered is marked with this icon:

<pict> 1004, center

If a message is not delivered, check these things:
• Is the message correctly addressed?
• Has the address of the intended recipient changed because of a change in computer name or 
AppleTalk zone?
• Is the software you used to send the message installed correctly?

<END PANEL>

# ####################
# The following panels are for “Why are catalog icons dimmed?” 
# ####################

<DEFINE PANEL> "AppleTalk or PowerShare catalogs dimmed: intro" 
<FORMAT> "full"
If the AppleTalk or PowerShare catalogs are dimmed in the Catalogs window, you need to turn 
AppleTalk on.

<END PANEL>

## The next 5 panels are from “How do I activate AppleTalk?”
## sequence under “PowerTalk basic” topic

# ####################
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# The following panels are for “Why do I get a Disk Full message sending mail?” 
# ####################

<DEFINE PANEL> "Disk Full message sending mail: intro" 
<FORMAT> "full"
You must have at least 1.5 MB free on your disk to send or receive mail. Remove as many files 
as necessary to provide space. One way to create disk space is to go to the Out Tray and throw 
away items that have already been sent.

<END PANEL>

# ####################
# The following panels are for “Why does a triangle appear on my In Tray?” 
# ####################

<DEFINE PANEL> "triangle icon on In Tray: intro" 
<FORMAT> "full"
If a triangle icon appears on the right side of your In Tray,  a server may be down or you’ve 
temporarily lost connection.

<END PANEL>

<DEFINE PANEL> "triangle icon on In Tray: click triangle" 
<FORMAT> "tag"
Do This

<FORMAT> "body"
Click the triangle icon to get a problem report. Double-click any report to see more information.

If a Resolve button appears at the lower-right corner of the dialog box, click the button to 
reconnect.

<END PANEL>

# ####################
# The following panels are for “Why is my mail marked “remote”?” 
# ####################

<DEFINE PANEL> "mail marked “remote”: intro" 
<FORMAT> "full"
If you’re on someone else’s machine checking PowerShare mail through a visitor's mailbox, your 
mail is marked “remote” in the location column. When you use PowerShare mail, you are looking 
at your mail stored on a server.

<END PANEL>
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# ####################
# The following panels are for “Why doesn’t my Signer work?” 
# ####################

<DEFINE PANEL> "Signer doesn’t work: intro" 
<FORMAT> "full"
If your Signer used to work and no longer does, do the following:

•  Open the Signer file and check the validation information. Apply for a renewal if your Signer has 
expired.

•  Check the Date & Time control panel and change the time.

•  Your Signer file maybe damaged. Make a new copy of your Signer using the backup you 
created when you first received your Signer Approval file.

<END PANEL>

# ####################
# The following panels are for “Why is my Approval Request info too long?” 
# ####################

<DEFINE PANEL> "info exceeds the limits: intro" 
<FORMAT> "full"
When you type your name or address in a DigiSign Utility Approval Request form, you may see a 
message saying that what you’ve typed exceeds the limit. You may have typed more than 64 
characters, or you may have used many complex characters (such as characters with an accent 
or Japanese Kanji). Try to use fewer characters.

<END PANEL>

# ####################
# The following panels are for “Why do I need a file with my Approval Request?” 
# ####################

<DEFINE PANEL> "file required: intro" 
<FORMAT> "full"
When you create your unapproved Signer and request files, you may see a message such as 
“File required to process this request.” Your request information fills more than one printed page. 
You must send a printed, signed, and notarized request form, as well as your request file, to your 
approval agency.

<END PANEL>
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# ####################
# The following panels are for “Definitions Tips for finding items?” 
# This is used in Huh? throughout the PowerTalk database
# ####################

<DEFINE PANEL> "Finding items: tips1"
<PANEL PROMPT> "Prompt Override: 39"

<FORMAT> "full"
If you can’t find the icon you need, try the following:

• Move an open window by dragging its title bar (at the top of the window).

• Make a window bigger by dragging its size box (at the lower-right corner of the window).

• Scroll hidden portions of the window into view by clicking the scroll arrows (along the right and 
bottom edges of the window).

• If only the title bar for a window is visible, double-click the title bar to display the entire window.

<END PANEL>

<DEFINE PANEL> "Finding items: tips2"
<PANEL PROMPT> "Prompt Override: 8"

<FORMAT> "full"
If you can’t find the item by checking the windows on your screen, you can probably locate the 
item by using the Find File command (in the Apple menu).

(You can also choose the Find command from the File menu to begin this procedure.)

<END PANEL>

<DEFINE PANEL> "Apple menu: choose Find File"
<FORMAT> "tag"
Do This

<FORMAT> "body"
Choose Find File from the Apple Menu.

<COACH MARK>"Menu:Front:Apple:Find File"
<END PANEL>

<DEFINE PANEL> "find location: use pop-up"
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<FORMAT> "tag"
Do This

<FORMAT> "body"
Use the pop-up menu labeled “Find items” to specify where you want to search.

You can search on all disks connected to your computer, on shared disks (called servers) only, on 
all disks except shared disks (called local disks), or on individual disks.

<COACH MARK>"Window:Find File:Find Items"
<END PANEL>

<DEFINE PANEL> "find: multiple"
<FORMAT> "tag"
Do This

<FORMAT> "body"
Click the More Choices or the Fewer Choices button until the number of rows is the same as the 
number of search criteria you want to use.

(You can specify as many as 10 criteria in the search window.)

<COACH MARK> "Window:Find File:More/Fewer Choices"
<END PANEL>

<DEFINE PANEL> "find: multiple pop-ups"
<FORMAT> "tag"
Do This

<FORMAT> "body"
Starting with the leftmost pop-up menu, describe the items you want to find.

As appropriate, type text to search for, or click a number and then use the up or down arrow to 
change it.  

If you need to add more search criteria, use the pop-up menus to identify the new criteria. (If 
necessary, expand the window by clicking the More Choices button to add criteria.)

<COACH MARK>"Window:FindFile:MoreCriteria:Rect"
<END PANEL>

<DEFINE PANEL> "find: click Find 4"
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<FORMAT> "tag"
Do This

<FORMAT> "body"
Click Find when you have completed your search criteria.

Only the items that meet all criteria are displayed in the search results window.

(If no matching items were found, you hear a beep or see a message.)

<COACH MARK>"FindFile:Find:Wind:Rect"
<END PANEL>

<DEFINE PANEL> "Finding items: tips3"
<panel prompt> "override: moreinfo"

<FORMAT> "full"
If you can’t find the item by using the Find File command, that item may not be on any disk the 
computer is currently using. Check your backup disks, the original disk on which you received the 
item, or the software that came with your computer.

It’s also possible that the item you want is on a shared disk. You can connect to a shared disk and 
then use the Find File command to search for the item on that disk.

<END PANEL>

<DEFINE PANEL> "Finding items: tips4"
<panel prompt> "override: rdone"

<FORMAT> "full"
If the item you need to find is part of the system software that came with your computer (or that 
you got as part of a system software upgrade), you must use the Installer program to add that 
component to your system software. 

(System software components are compressed when distributed; the Installer program 
uncompresses them during installation. You can identify a compressed component of system 
software by its icon, which has a belt around the middle.)

<END PANEL>

<DEFINE PANEL> "find: list choice"
#<PANEL PROMPT> "Prompt Override: 24"
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<FORMAT> "tag"
Do This

<FORMAT> "body"
Click an item in the list to see its location.

The location of the item selected is displayed in the bottom section of the search results window. 

You can double-click the item to open it. 

You can also choose commands from the File, Edit, and View menus to work with the items 
located in the search.

<COACH MARK>"Item:Find File:results:top"
<END PANEL>

#
# Definitions.panel
#
# The panels for “Definitions”
# ©1993 Apple Computer, Inc.
#

#
# The beginning of the definition portion
#

<DEFINE PANEL> "access code: def"
<FORMAT> "full"
Your access code is a special password that gives you access to the PowerTalk key chain and all 
of your PowerTalk collaboration services.

<END PANEL>

<DEFINE PANEL> "AppleMail: def"
<FORMAT> "full"
AppleMail is an application program you use to create, send, read, and respond to letters and 
enclosures.

<coach mark> "finder applemail icon"
<END PANEL>

<DEFINE PANEL> "catalog: def"
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<FORMAT> "full"
In PowerTalk, a catalog represents a collection of information about people and things you can 
work with. For example, a catalog can contain information about computer users, groups of users, 
and devices on a computer network.

The information contained in a catalog depends on the kind of catalog. One example of a catalog 
is an AppleTalk catalog, which provides information about computers and file servers on an 
AppleTalk network.

Another kind of catalog is a personal catalog, which contains “information cards” with information 
about individuals and groups you communicate with.

<END PANEL>

# ####################
# The following panels are for “Definition of collaboration services” 
# ####################

<DEFINE PANEL> "collaboration services1: def"
<FORMAT> "full"
Collaboration services provide ways for people to work together more conveniently. PowerTalk 
system software provides some collaboration services by itself, including: 
• a mailbox on your desktop
• a way to sign and approve documents electronically
• a key chain that lets you access many services with a single access code
• a way to send files to other people

<END PANEL>

<DEFINE PANEL> "collaboration services2: def"
<panel prompt> "override: rdone" 
<FORMAT> "full"
PowerTalk system software also provides the framework for additional collaboration services. You 
add more PowerTalk collaboration services to your computer by installing products designed to 
work with PowerTalk. These are available from other software and hardware developers.

<END PANEL>

# ####################
# End of “Definition of digital signature” 
# ####################

<DEFINE PANEL> "digital signature: def"
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<FORMAT> "full"
A digital signature is an electronic indicator that can be placed on a document on your hard disk. 
When a document is digitally signed, you and other PowerTalk users can verify the source of the 
document, and that the document has not been changed.

You digitally sign a document with a special kind of file called a Signer. PowerTalk comes with a 
demonstration Signer you can practice with.

If you need more information about obtaining a valid Signer, click Huh? below for instructions.

<dimmable button data> "Huh?", "How do I obtain a valid Signer file?"
<END PANEL>

# ####################
# The following panels are for “Definition of electronic addresses” 
# ####################

<DEFINE PANEL> "electronic addresses1: def"
<FORMAT> "full"
An electronic address is like the address on an envelope you send through the mail. It enables 
one or more computers to find a particular electronic location. The location might be a computer, 
a server, an account, or an electronic mailbox.

An information card for a user includes one or more electronic addresses for that person. You can 
look in the Catalogs icon on your desktop to find information cards for people using PowerTalk 
system software on your network. When you find an information card in that kind of catalog, the 
card automatically includes an electronic address.

<END PANEL>

<DEFINE PANEL> "electronic addresses2: def"
<FORMAT> "full"
If you manually enter an electronic address, be sure that the address you type is correct. Spelling 
or format errors prevent your mail from being delivered. The best way to find someone’s 
electronic address is to ask that person, or ask your network administrator.

<END PANEL>

<DEFINE PANEL> "electronic addresses3: def"
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<FORMAT> "full"
Direct AppleTalk mail addresses take the form: <name>@<zone>. For example, if the computer’s 
name is “Rosemary’s Quadra” and the computer is in the zone “Engineering,” the complete 
address would be Rosemary’s Quadra@Engineering.

PowerShare addresses take the form: <name>@<catalog>:<folder>:<folder>. For example, if the 
user’s name is John Doe, and his account is located in a catalog folder called “Sales Department” 
in a PowerShare catalog called “Western Division,” the complete address would be John 
Doe@Western Division:Sales Department.

<END PANEL>

<DEFINE PANEL> "electronic addresses4: def"
<panel prompt> "override: rdone"

<FORMAT> "full"
Addresses on the Internet typically take the form of a person’s name or identifier, followed by the 
@ symbol, followed by the name or identifier of the organization maintaining the person’s 
computer network or account. No spaces are allowed between characters.

For example if John Doe has an account on a computer at Great Big University, his Internet 
address might be john_doe@gbig.edu.

<END PANEL>

# ####################
# End of “Definition of electronic addresses” 
# ####################

# ####################
# The following panels are for “Definition of electronic mail services” 
# ####################

<DEFINE PANEL> "electronic mail services1: def"
<FORMAT> "full"
PowerTalk system software comes with built-in ways to send and receive electronic mail. 
Programs from other software developers, if they are designed to take advantage of PowerTalk 
services, can give you additional ways to send and receive mail.

<END PANEL>

<DEFINE PANEL> "electronic mail services2: def"
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<FORMAT> "full"
Some electronic mail services copy mail directly to your hard disk. For example, if you receive 
Direct AppleTalk mail, the items you receive reside on your hard disk.

Other electronic mail services, including PowerShare mail, store mail on a server. When you 
receive PowerShare mail, what you actually receive is a notification that mail for you is stored on 
the PowerShare server.

<END PANEL>

<DEFINE PANEL> "electronic mail services3: def"
<panel prompt> "override: rdone"

<FORMAT> "full"
You can find the location of each item in your mailbox In Tray by checking the Location column. 
Items are listed as local (on your hard disk) or remote (on a server).

If you disconnect your computer from the network, you will be able to open only In Tray items that 
are local. If you want, you can copy remote items to your hard disk (by selecting the items and 
choosing Copy Local from the Mailbox menu).

<END PANEL>

# ####################
# End of “Definition of electronic mail services” 
# ####################

<DEFINE PANEL> "information card: def"
<FORMAT> "full"
An information card is a container for information about a person or a group of people.

An information card for an individual usually contains a person's name, postal address, electronic 
address, and telephone numbers. An information card for a group contains pointers (or aliases) to 
information about the individuals in the group.

Information cards are usually stored in catalogs, although you can keep an information card on 
your desktop or in a Finder window.

<END PANEL>

<DEFINE PANEL> "key chain: def"
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<FORMAT> "full"
The PowerTalk key chain is a container for the PowerTalk collaboration services you use, such as 
file servers and communication systems. Your setup and password information for each service 
are stored in the key chain. Your key chain is kept secure by your access code.

You can open your key chain to add, remove, and change collaboration services.

<END PANEL>

<DEFINE PANEL> "mailbox: def"
<FORMAT> "full"
The PowerTalk mailbox is the place that contains all of your correspondence. Inside the mailbox, 
the In Tray contains correspondence you receive, and the Out Tray contains correspondence you 
send.

When you are using PowerTalk, your mailbox is on your desktop. After you set up PowerTalk, 
your mailbox has your name on it.

<END PANEL>

<DEFINE PANEL> "Mailer: def"
<FORMAT> "full"
You use the Mailer to address and send correspondence from an application program rather than 
the Finder. With PowerTalk software, Macintosh developers can add the Mailer to any program. 
When you create a document in such a program, you can send the document immediately.

AppleMail, a program that comes with PowerTalk software, uses the Mailer.

<END PANEL>

<DEFINE PANEL> "personal catalog: def"
<FORMAT> "full"
A personal catalog is a catalog that resides on your hard disk. You can use a personal catalog to 
store items such as info cards, aliases, and groups.

When you install PowerTalk, a personal catalog is automatically put into Mail and Catalogs in your 
Apple menu. You can create more personal catalogs if you want, and store them anywhere on 
your hard disk.

One personal catalog is your default, or “preferred,” personal catalog. The preferred personal 
catalog is the one that is automatically used by programs, such as AppleMail, that use the 
PowerTalk Mailer for addressing and sending messages and documents.
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<END PANEL>

<DEFINE PANEL> "PowerShare server: def"
<FORMAT> "full"
A PowerShare server is a computer running PowerShare software, which provides enhanced 
communication and security features. To use a PowerShare server you must have a PowerShare 
account, which is provided by the system administrator of the server.

<END PANEL>

<DEFINE PANEL> "PowerTalk: def"
<FORMAT> "full"
PowerTalk is system software that provides the foundation for software that offers you new 
collaboration services. Collaboration services provide ways for you to correspond with others, 
safeguard your communications, access information on other computer systems, and automate 
routine activities.

<END PANEL>

# ####################
# The following panels are for “Definition of Signer approvals” 
# ####################

<DEFINE PANEL> "Signer approvals1: def" 
<FORMAT> "full"
There are two types of Signer approvals available: affiliated and unaffiliated.

Affiliated approvals let you make signatures that include an organizational affiliation (such as 
“Jane Doe, VP of Engineering, ACME Inc.”).

Unaffiliated approvals allow you to make signatures that only use your name (such as “Jane 
Doe”).

<END PANEL>

<DEFINE PANEL> "Signer approvals2: def" 
<FORMAT> "full"
You can have multiple Signer approvals allowing you to sign as an employee of your company, 
the representative of an organization (such as a charity), or simply yourself.

If you need more information about obtaining a valid Signer, click Huh? below for instructions.

<dimmable button data> "Huh?", "How do I obtain a valid Signer file?"
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<END PANEL>

<DEFINE PANEL> "tag: def"
<FORMAT> "full"
Tags are keywords you use to identify and categorize your mail. You can attach one or more tags 
to each piece of mail in your In Tray. 

You can choose to see only the items in your In Tray that have a particular tag.

<END PANEL>


