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<DEFINE PANEL> "basics review: intro"
<FORMAT> "Full"
To use your computer effectively, you need to have a few basic skills and understand a 
few key concepts.

• To learn how to control the pointer on the screen (using a mouse, a trackball, or another 
device), open the Guide menu (on the right with the ? icon) and choose the “Tutorial” 
item. (If you don’t see a tutorial item in the Guide menu, use the introductory tour, 
usually named “Basics,” supplied with your computer.)

• To learn about icons, menus, and windows, open the Guide menu  and choose the 
“Tutorial” item. (If you don’t see a tutorial item in the Guide menu, use the materials 
named “Learning Macintosh” or “Basics” supplied with your computer.)

<PANEL PROMPT> "Prompt Override: 4"
<END PANEL>

# Panels for the sequence "How do I use icons?"

<DEFINE PANEL> "icon: select"
<FORMAT> "Full"
You select the icon you want to use by clicking it.

You can select several icons in a window by clicking them while you hold down the Shift 
key.

If the icons are next to each other, you can select them by dragging across them.

<PICT> 1022, Center
<PANEL PROMPT> "Prompt Override: 21"

<END PANEL>

<DEFINE PANEL> "icon: open"



<FORMAT> "Full"
You see what’s on a disk or in a folder by opening its icon. You also open a program or 
document by opening its icon.

Here are two ways to open an icon:

• Click it, then open the File menu and choose Open.

• Double-click it (click it twice quickly without moving the pointer).

(Note:  If your system has a Launcher window, you don’t use the buttons inside that 
window like icons. For information about the Launcher, click Huh? below.)

<Dimmable Button Data> "Huh?","Definitions Launcher"
<PANEL PROMPT> "Prompt Override: 21"

<END PANEL>

<DEFINE PANEL> "icon: drag"
<FORMAT> "Full"
You move, copy, or throw away files by dragging their icons.

For example, you can move a file to another folder by dragging its icon into the new 
folder.  You can copy a file onto another disk by dragging its icon to the disk icon.

You can throw away files by dragging their icons to the Trash.

<PICT> 1024, Center
<PANEL PROMPT> "Prompt Override: 4"

<END PANEL>

# Panels for the sequence  "How do I use menus?"

<DEFINE PANEL> "menu: def with prompt"
<FORMAT> "Full"
You use a menu to choose a command. To use a menu, you put the pointer on the menu 
title and press the button to open it, drag to the item you want, then release the button.

Menus are in the menu bar (at the top of the screen) and in dialog boxes. The Apple menu 
also has extended menus (submenus) for choosing control panels and other items.

<FORMAT> "ResetPen"
<PICT> 1026, Point(35,70)
<PANEL PROMPT> "Prompt Override: 4"



<END PANEL>

# Panels for the sequence "How do I use windows?"

<DEFINE PANEL> "window: def with prompt"
<FORMAT> "Full"
A window is a rectangle on the screen that displays the contents of a disk, folder, or 
document. Some windows display messages or offer choices.

<PICT> 1028, Center
<PANEL PROMPT> "Prompt Override: 4"

<END PANEL>

# Panels for the sequence "How do I use Macintosh Help?"

<DEFINE PANEL> "Help: tips"
<FORMAT> "Tag"

Tip

Tip

Tip

<FORMAT> "Body"
These tips will assist you in using Macintosh Guide.

Do the step described in the Guide window, then click the right arrow at the 
bottom of the window to go to the next step.  (Click the left arrow to see the 
previous step.)  

In some instances, Macintosh Guide will assist you by opening a window or 
bringing a window to the front when you click the right arrow.

You can move the Guide window if it covers what you want to see.
<PANEL PROMPT> "Prompt Override: 1"

<END PANEL>

<DEFINE PANEL> "Help: tips2"
<FORMAT> "Tag"

Tip

Tip

Tip

<FORMAT> "Body"



You can shrink the Guide window by clicking the box at the upper-right 
corner of the window. Click the box again to expand the window.

Click Huh? at the bottom of the Guide window to see definitions of unfamiliar 
words, pictures, or related questions.

If the instructions that appear in the Guide window aren’t the ones you want, 
click Topics at the lower-left corner of the window to return to the list of 
Guide topics.

<PANEL PROMPT> "Prompt Override: 1"
<END PANEL>

<DEFINE PANEL> "Help: tips3"



<FORMAT> "Tag"
Tip

Tip

Tip

<FORMAT> "Body"
To see definitions of items on the screen, choose Show Balloons from the 
Guide menu (on the right with the ? icon) and point to the items you want.

If you can’t find the instructions you need, try searching in a different way.  If 
you usually use the Topics list, click the Index or Look For button.

If you don’t see the items you want in the Guide menu (on the right with the ? 
icon), make sure you are in the Finder. (Open the Application menu at the far 
right corner of the screen and choose Finder.)

<PANEL PROMPT> "Prompt Override: 1"
<END PANEL>

<DEFINE PANEL> "Help: tips4"
<FORMAT> "Tag"

Tip

Tip

<FORMAT> "Body"
When you use the Index section of the Guide window, you can drag the slider 
across the letters at the top of the list. When the slider reaches the edge of the 
box, the letters scroll automatically. You can also scroll through the list of 
terms by clicking the scroll arrows or by dragging  the scroll box.

When you use the Look For section of the Guide window, be sure to click the 
arrow button to activate the typing area before you type the word or phrase 
you want to locate. 

<PANEL PROMPT> "Prompt Override: 1"
<END PANEL>

<DEFINE PANEL> "Help: tips5"
<FORMAT> "Tag"

Tip



Tip

<FORMAT> "Body"
To assure that the step-by-step instructions work successfully for you, don’t 
change the name of the System Folder on your startup disk. Also, leave the 
control panels in their folder (inside the System Folder).

Some other application programs also have instructions in the Guide menu. 
Open the Guide menu while you’re working in that program to see its 
instructions.

<PANEL PROMPT> "Standard Prompts"
<END PANEL>

# Panels for the sequence "How do I turn off the computer?"

<DEFINE PANEL> "Shut Down: intro"



<FORMAT> "Full"
The best way to turn off your computer is to open the Special menu and choose the Shut 
Down command.

The Shut Down command either turns off the computer automatically, or displays a 
message that you can safely turn off the power switch.  See the manual that came with 
your computer for the location of the power switch.  In an emergency, you can use the 
power switch to turn off the computer.

<PANEL PROMPT> "Prompt Override: 8"
<END PANEL>

<DEFINE PANEL> "Special: choose Shut Down"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Open the Special menu and choose Shut Down.

(You can also use the Shut Down command in the Apple menu to shut down 
the computer.)

<COACH MARK> "Menu:MACS:Special:Shut Down"
<PANEL PROMPT> "Prompt Override: 24"

<END PANEL>

<DEFINE PANEL> "Sleep: Shut Down tip"
<FORMAT>  "Tag"

Tip

<FORMAT> "Body"
If your Macintosh can use software for conserving power, you can set a time 
or an interval after which the computer will turn off.

If your computer uses a battery, you can use the Sleep command to make the 
computer inactive without turning it off.

For information about automatic shutdown, click Huh? below.
<Dimmable Button Data> "Huh?","How do I turn off the computer automatically?"
<PANEL PROMPT> "Prompt Override: 10"

<END PANEL>

# Panels for the sequence "How do I open a program?"

<DEFINE PANEL> "program: open"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
To open a program, locate the icon for that program and double-click it.

(You can also click the icon to select it, then choose Open from the File 
menu.)

If you can’t locate the file you want, click Huh? below for instructions.
<Dimmable Button Data> "Huh?","Definitions Tips for finding items"

<END PANEL>



# Panels for the sequence "How do I save my work?"

<DEFINE PANEL> "File: Save"
<FORMAT> "Full"
When you’re ready to save the work that you’ve done using a program, you open the File 
menu and choose Save.

A box appears when you first save a document. You use this box, called a directory dialog 
box, to name your document and to decide where to store it.

For information on how to use the directory dialog box, click Huh? below.
<PANEL PROMPT> "Prompt Override: 24"
<Dimmable Button Data> "Huh?","Definitions directory dialog box"

<END PANEL>

<DEFINE PANEL> "File: Save2"
<FORMAT> "Tag"

Tip

<FORMAT> "Body"
You can specify one of several folders as the standard, or “default,” location 
where an item will be saved. You use the General Controls panel to set a 
location for default saving (and also to limit access to certain programs and 
files).

On some Macintosh models, the system software automatically saves your 
work in a Documents folder.

<PANEL PROMPT> "Prompt Override: 10"
<END PANEL>

<DEFINE PANEL> "File: Save3"
<FORMAT> "Full"
You can use the Save As command in the File menu to save a copy of a document with a 
different name, or in a different location.

Many programs also provide a selection of file formats in which you can save a 
document. To save your work in a different format (such as for use with a DOS 
computer), you use the Save As command and an “options” or “formats” button in the 
directory dialog box.

<PANEL PROMPT> "Prompt Override: 10"
<END PANEL>

# Panels for the sequence "How do I switch between programs?"

<DEFINE PANEL> "App menu: open and choose"



<FORMAT> "Tag"
Do This

<FORMAT> "Body"
Open the Application menu (in the top-right corner of the screen) and choose 
the program you want to switch to.

If the program you want is not in the menu, then it is not open. (It appears in 
the menu after you open it.)

For instructions on opening a program, click Huh? below.
<COACH MARK> "CoachMark: 31"
<Dimmable Button Data> "Huh?","How do I open a program?"

<END PANEL>

# Panels for the sequence "How do I get help for a program?"

<DEFINE PANEL> "Programs: get Help"
<FORMAT> "Full"
To get help with a program, you need to close Macintosh Guide, make the program 
active, and then open the Guide menu (on the right with the ? icon) and choose the item 
you want.

If there are no instructional items in the menu (such as Tutorial or Guide), the program 
may have help available in another menu, or it may not have on-screen help. See the 
documentation for the program.

<PANEL PROMPT> "Prompt Override: 4"
<Dimmable Button Data> "Huh?","Definitions active program"

<END PANEL>

# Panels for the sequence "How do I bring a window to the front?"

<DEFINE PANEL> "Window: bring to front"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
To bring a window to the front, click any part of the window that is visible. 

If you can see only the window’s title bar, double-click the title bar to open 
the window.

You cannot bring a window in front of this Guide window. You can drag the 
Guide window out of the way, or shrink the Guide window by clicking the 
box in the upper-right corner.

<PANEL PROMPT> "Prompt Override: 19"
<END PANEL>

<DEFINE PANEL> "window: NoCanSee"



<FORMAT> "Tag"
Tip

<FORMAT> "Body"
If you can’t find the window you want, try hiding the windows that belong to 
other programs.

For instructions on hiding or showing windows, click Huh? below.
<PANEL PROMPT> "Standard Prompts"
<Dimmable Button Data> "Huh?","How do I hide or show windows?"

<END PANEL>

# Panels for the sequence "How do I hide or show windows?"

<DEFINE PANEL> "Hide or show: intro"
<FORMAT> "Full"
You can hide or show the windows belonging to an open program. You can also shrink 
any window so that only its title bar is showing, or expand it from the title bar. Which do 
you want to do? Click one:

<RADIO BUTTON> "hide windows", true,,, ,APPLEGUIDE
<RADIO BUTTON> "show windows", false,,, ,APPLEGUIDE
<RADIO BUTTON> "shrink or expand windows (to or from the title bar)", false,,,,APPLEGUIDE

<END PANEL>

<DEFINE PANEL> "App menu: hide"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
To hide the windows of the active program, open the Application menu and 
choose the Hide command.

Or, to hide the windows of the programs that are not active, choose Hide 
Others.

(If you inadvertently hide the wrong windows, you can open the Application 
menu and choose Show All or choose your program’s name.)

<COACH MARK> "CoachMark: 31"
<Dimmable Button Data> "Huh?","Definitions active program"

<END PANEL>

<DEFINE PANEL> "App menu: show"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Open the Application menu and choose the program whose windows you want 
to show.

Or, to see the windows of all open programs, choose Show All.

If the program you want isn’t listed in the menu, that means it’s not open.  
(For instructions on opening a program, click Huh? below.)

<Dimmable Button Data> "Huh?","How do I open a program?"
<COACH MARK> "CoachMark: 31"



<END PANEL>

<DEFINE PANEL> "WindowShade: double click"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Click a window’s title bar (using the WindowShade key combination) to 
shrink the window so that only the title bar is showing. Clicking a title bar 
when only it is showing expands the window. (You make the Guide window 
smaller by clicking its upper-right corner.)

You use the WindowShade control panel to verify or change the command 
used to shrink and expand windows or to turn this feature off or on.

For instructions on using the WindowShade control panel, click Huh? below.
<PANEL PROMPT> "Standard Prompts"
<Dimmable Button Data> "Huh?","How do I adjust window shrinking?"

<END PANEL>

# Panels for the sequence "How do I find out which programs are open?"

<DEFINE PANEL> "open programs: intro"
<FORMAT> "Full"
You can have several programs open at the same time.
An open program takes up memory in your computer, even if you’re not using the 
program.

To find out which programs are open, open the Application menu (in the top-right corner 
of the screen).  The active program has a check beside its name.

<COACH MARK> "CoachMark: 31"
<PANEL PROMPT> "Prompt Override: 4"

<END PANEL>

# Panels for the sequence  "How do I change a program’s
#  memory size?"

<DEFINE PANEL> "App RAM: intro"
<FORMAT> "Full"
When you open a program, it sets aside part of your computer’s memory. (You can 
change a program’s preferred and minimum memory sizes in the Info window.)

If you want a program to work with more or larger documents, you can increase its 
memory size.

If you want to open more programs at once, you can decrease the memory size of your 
programs.

<Dimmable Button Data> "Huh?","Definitions memory"
<END PANEL>



<DEFINE PANEL> "App RAM: quit app"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Quit the program if it’s open.

Open the Application menu (in the top-right corner of the screen).  If the 
program is listed there, choose the program, then open the File menu and 
choose Quit.

<COACH MARK> "CoachMark: 31"
<END PANEL>

<DEFINE PANEL> "App RAM: click app icon"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Click the program’s icon to select it. (Do not double-click.)

<END PANEL>

<DEFINE PANEL> "Info: preferred size"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Double-click the preferred size and type a new number. The program sets 
aside this amount of memory if enough memory is available.  (You may need 
to move this window or the Info window to see the preferred size box.)

If you cannot type a new number, then the program is either open or locked. If 
the Locked box has an X in it, click the box.

If you don’t see Memory Requirements in the Info window, then the icon you 
selected is not a program.

<END PANEL>

<DEFINE PANEL> "Info: minimum size"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Double-click the minimum size and type the new number. The program will 
not open unless this amount of memory is available. The minimum size 
should not be less than the suggested size.

<END PANEL>

# Panels for the sequence  "How do I make more memory available?"

<DEFINE PANEL> "Save RAM: intro"
<FORMAT> "Full"
There are several ways to make more memory available. What do you want to do? Click 
one:

<RADIO BUTTON> "quit open programs", true,,, ,APPLEGUIDE
<RADIO BUTTON> "turn off or remove system extensions", false,,, ,APPLEGUIDE
<RADIO BUTTON> "adjust the disk cache", false,,, ,APPLEGUIDE
<RADIO BUTTON> "disconnect network services", false,,, ,APPLEGUIDE
<RADIO BUTTON> "turn off file sharing", false,,, ,APPLEGUIDE



<On Panel Create> DoAppleScript(":Open AppleScripts:Null AS script")
<END PANEL>



<DEFINE PANEL> "Save RAM: quit programs"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Quit any open programs that you are not using.

You can find out how much memory each open program is using by making 
the Finder active, then opening the Apple () menu and choosing About This 
Macintosh.

If quitting programs doesn’t help, you can sometimes clear memory by 
restarting your computer. (Open the Special menu and choose Restart.)

<Dimmable Button Data> "Huh?","Definitions open program"
<END PANEL>

<DEFINE PANEL> "AppleTalk disconnect: intro"
<FORMAT> "Full"
If you don’t need network services (such as shared printers or electronic mail), you can 
save about 100K by turning off AppleTalk in the Chooser.

The following steps show you how to turn off AppleTalk. (Doing so disconnects your 
computer from the network.)

<PANEL PROMPT> "Prompt Override: 8"
<Dimmable Button Data> "Huh?","Definitions AppleTalk"

<END PANEL>

<DEFINE PANEL> "Save RAM: AppleTalk inactive"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
In the lower-right area of the Chooser, click the AppleTalk Inactive button.

If a message appears, read it and then click your choice.
<COACH MARK> "Item:Chooser:AppleTalk Inactive"

<END PANEL>

<DEFINE PANEL> "AppleTalk disconnect: already off"
<FORMAT> "Full"
If you are not using network services (such as shared printers or electronic mail), you can 
save about 100K by turning off AppleTalk in the Chooser.

Since AppleTalk is turned off, you are already taking advantage of this savings.
<Dimmable Button Data> "Huh?","Definitions AppleTalk"

<END PANEL>

<DEFINE PANEL> "Sharing setup: don’t need"
<FORMAT> "Full"
The software you need for file sharing is not installed. So file sharing is already turned 
off.

<END PANEL>



<DEFINE PANEL> "file sharing: already off"
<FORMAT> "Full"
File sharing is already off.

When file sharing is on, it takes about 360K of memory and lets you share files with 
others on the network.

<PANEL PROMPT> "Prompt Override: 4"
<Dimmable Button Data> "Huh?","Definitions file sharing"

<END PANEL>

<DEFINE PANEL> "Off shared disks: intro"
<FORMAT> "Full"
You can save about 360K of memory by turning off file sharing in the Sharing Setup 
control panel.

The following steps show you how.
<PANEL PROMPT> "Prompt Override: 8"
<Dimmable Button Data> "Huh?","Definitions file sharing"

<END PANEL>

<DEFINE PANEL> "Sharing: stop sharing"
<FORMAT> "Tag"

Do This

Do This
<FORMAT> "Body"
Click Stop under File Sharing.

Type a number of minutes in the box, then click OK.
<COACH MARK> "CoachMark: 61"

<END PANEL>

<DEFINE PANEL> "disk cache: intro"
<FORMAT> "Full"
The disk cache is a storage area for frequently used instructions. It helps your programs 
run faster, but the memory it uses is not available for opening programs.

You adjust the disk cache in the Memory control panel. The following steps show you 
how.

<PANEL PROMPT> "Prompt Override: 8"
<END PANEL>

<DEFINE PANEL> "Save RAM: trash extensions intro"
<FORMAT> "Full"
You can save memory by either turning off system extensions or removing system 
extensions you aren’t using.

Which do you want to do? Click one.
<RADIO BUTTON> "turn off extensions", true,,, ,APPLEGUIDE
<RADIO BUTTON> "remove extensions", false,,, ,APPLEGUIDE
<Dimmable Button Data> "Huh?","Definitions system extension"

<END PANEL>

<DEFINE PANEL> "Extensions: open folder"



<FORMAT> "Tag"
Do This

<FORMAT> "Body"
Open the Extensions folder.

<COACH MARK> "Finder Coach Extensions"
<Dimmable Button Data> "Huh?","How do I open an Item?"

<END PANEL>

<DEFINE PANEL> "Extensions: trash extras"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Drag items you do not use out of the Extensions folder and out of the System 
Folder. (For example, you can remove files for printers you’re not using.) Put 
the items in a separate folder outside the System Folder.

The memory used by system extensions becomes available after you restart 
your computer.

<PANEL PROMPT> "Prompt Override: 19"
<END PANEL>

<DEFINE PANEL> "Extensions: trash tip"
<FORMAT> "Tag"

Tip

<FORMAT> "Body"
You can save memory by turning off all system extensions temporarily. Hold 
down the Shift key as you restart your computer. Keep the Shift key down 
until you see the Welcome to Macintosh message.

Note:  Macintosh Guide will not be available if you turn off all extensions or 
the Apple Guide extension.

<PANEL PROMPT> "Standard Prompts"
<END PANEL>

# Panels for the sequence "How do I check how much memory I’m
# using?"

<DEFINE PANEL> "Memory: check intro"
<FORMAT> "Full"
You can see how much memory is available, and how much is being used, in the About 
This Macintosh window.

<Dimmable Button Data> "Huh?","Definitions memory"
<END PANEL>

<DEFINE PANEL> "App menu: choose Finder"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Open the Application menu and choose Finder.

(If there’s a checkmark next to Finder, it’s already active, so you don’t have to 
choose it.)

<COACH MARK> "CoachMark: 31"



<END PANEL>

<DEFINE PANEL> "Apple menu: choose About This Mac"



<FORMAT> "Tag"
Do This

<FORMAT> "Body"
Open the Apple () menu and choose About This Macintosh.

If you want information about items in this window, you can open the Guide 
menu (on the right with the ? icon) and choose Show Balloons, then point at 
items.

<COACH MARK> "Menu:Front:Apple:About this Mac"
<END PANEL>

# Panels for the sequence "How do I copy an item
# between programs?"

<DEFINE PANEL> "Drag copy: intro choice"
<FORMAT> "Full"
You can copy text, images, or sounds within a document, or from one document to 
another.  When you copy from one document to another, the documents can be from the 
same program or from different programs.

You can copy an item between programs in one of two ways—with both documents open 
at the same time, or with only one of the documents open at a time.

Which type of copying do you want to do? Click one:
<RADIO BUTTON> "within a document", true,,, ,APPLEGUIDE
<RADIO BUTTON> "with both documents open at once", false,,, ,APPLEGUIDE
<RADIO BUTTON> "with one document open at a time", false,,, ,APPLEGUIDE

<END PANEL>

# Branch for within a document

<DEFINE PANEL> "Drag copy: drag within doc"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Hold down the Option key, then drag the selected item to the location where 
you want to copy it. (As you drag, an insertion point indicates where the item 
will be copied.)

If the selected item doesn’t move when you try to drag it, your program may 
not allow this method of copying. You can copy the selected item by choosing 
Copy from the Edit menu. Then click at the location where you want to copy 
the item, and choose Paste from the Edit menu.

<END PANEL>

# End Branch

<DEFINE PANEL> "Drag copy: open both"



<FORMAT> "Tag"
Do This

<FORMAT> "Body"
Open the document you want to copy from. Then open the document you 
want to copy to.

Make sure you can see part of each document’s window, with the document 
you’ll copy from in front.

<END PANEL>

<DEFINE PANEL> "Drag copy: drag to doc"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Drag the selected item to the second document. (As you drag, an insertion 
point indicates where the item will be copied.) Release the button when the 
item is where you want to place it.

If the selected item doesn’t move when you try to drag it, your program may 
not allow this method of copying. You can copy the selected item by choosing 
Copy from the Edit menu. Then click at the location in the second document 
where you want to place the item, and choose Paste from the Edit menu.

<END PANEL>

<DEFINE PANEL> "Drag copy: open 1st doc"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Open the document from which you want to copy an item.

<Dimmable Button Data> "Huh?","How do I open an Item?"
<END PANEL>

<DEFINE PANEL> "Drag copy: drag to desktop"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Drag the selected item to the desktop, or to the window of a disk or folder.

Release the button when the item is in the desired location. A new document 
with “clipping” in its name appears. The clipping contains a copy of the item 
you dragged to the new location.

<Dimmable Button Data> "Huh?","Definitions clipping"
<END PANEL>

<DEFINE PANEL> "Drag copy: open 2nd doc"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Open the document to which you want to copy the item you selected 
previously.

<Dimmable Button Data> "Huh?","How do I open an Item?"
<END PANEL>

<DEFINE PANEL> "Drag copy: Drag to 2nd doc"



<FORMAT> "Tag"
Do This

<FORMAT> "Body"
Drag the clipping to the open document. (As you drag, an insertion point 
indicates where the item will be copied.) Release the button when the item is 
where you want to place it.

If you can’t drag the clipping to the open document, the program doesn’t 
allow drag copying. You can copy the item by opening the original document, 
selecting the item to copy, and choosing Copy from the Edit menu. Then click 
at the location in the second document where you want to place the item, and 
choose Paste from the Edit menu.

<END PANEL>

# Panels for the sequence "How do I open unknown item?"

<DEFINE PANEL> "unknown item: intro"
<FORMAT> "Full"
You can open and use many documents even if you don’t have the program that created 
them. The Macintosh uses “translators” (included with the system software and with 
application programs) to open these files with one of the programs you have.

<Dimmable Button Data> "Huh?","Definitions translator"
<END PANEL>

<DEFINE PANEL> "unknown item: open"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Double-click the icon of the item you want to open.

If any of your programs can open this document, you see a box listing those 
programs, or a message naming the one program that can open it. Select a 
program from the list and click Open, or click OK in the message box.

If none of your programs can open the document, a message tells you that. (If 
the item isn’t a document, you may see a window open or a program may 
open a blank document.)

<PANEL PROMPT> "Prompt Override: 24"
<END PANEL>

<DEFINE PANEL> "unknown item: open tip"



<FORMAT> "Full"
Another way to open some documents is first to open a program that uses similar types of 
documents, then choose Open in the File menu. A pop-up menu in the directory dialog 
box shows you the types of files the program can open.

Look at the icons in the directory dialog box. If the icon of the document matches the 
application you’re using, it’s a normal document. If the icon is different, or blank, that 
means translators will be used to open the document.

For information on using the directory dialog box, click Huh? below.
<Dimmable Button Data> "Huh?","Definitions directory dialog box"
<PANEL PROMPT> "Prompt Override: 10"

<END PANEL>

# Panels for the question "How do I use programs with the Power Macintosh?"

<DEFINE PANEL> "Power PC:noCanDo"
<FORMAT> "Full"
The instructions that follow pertain only to the Power Macintosh computer or a 
computer with the Power Macintosh Upgrade Card installed. If your computer is not 
a Power Macintosh, you will not be able to use the information provided for this 
question.

<END PANEL>

<DEFINE PANEL> "Power Macintosh programs: intro"
<FORMAT> "Full"
Power Macintosh computers and Macintosh models with the Power Macintosh Upgrade 
Card can use programs specially designed for the PowerPC microprocessor. These 
computers can also use most older Macintosh programs.

If you have a problem using a program with the Power Macintosh, you can adjust the 
computer’s RAM. 

<Dimmable Button Data> "Huh?","Definitions random-access memory (RAM)"
<On Panel Create> DoAppleScript(":Open AppleScripts:Null AS script")

<END PANEL>

<DEFINE PANEL> "Modern Memory: click on or off"



<FORMAT> "Tag"
Do This

<FORMAT> "Body"
Click On to turn on the Modern Memory Manager (for Power Macintosh 
programs).

Click Off to turn off the Modern Memory Manager (for older Macintosh 
programs).

(If you don’t see the Modern Memory Manager, your computer is not a Power 
Macintosh.)

Your change takes effect when you restart the computer (by choosing Restart 
from the Special menu).

<PANEL PROMPT> "Prompt Override: 24"
<END PANEL>

<DEFINE PANEL> "Power Macintosh programs: tip"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
If your computer has a Power Macintosh Upgrade Card and you have 
problems using an older Macintosh program with Modern Memory Manager 
turned off, try turning off the Power Macintosh Upgrade Card.

<PANEL PROMPT> "Prompt Override: 10"
<END PANEL>

# Panels for the sequence "How do I open an item?"

<DEFINE PANEL> "item: open"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
To open an item, locate the icon for that item and double-click it.

(You can also click the icon to select it, then choose Open from the File menu. 
)

For control panels and applications, documents, or shared disks you’ve used 
recently, you can open these quickly by using the submenus in the Apple 
menu. 

If you can’t locate the item you want, click Huh? below for instructions.
<PANEL PROMPT> "Prompt Override: 24"
<Dimmable Button Data> "Huh?","Definitions Tips for finding items"

<END PANEL>

<DEFINE PANEL> "item: open tip"
<FORMAT> "Tag"

Tip

<FORMAT> "Body"
Even if you don’t have the program that created a document, you may be able 
to open it.



For information about opening an unknown item, click Huh? below.



<PANEL PROMPT> "Prompt Override: 10"
<Dimmable Button Data> "Huh?","How do I open an unknown item?"

<END PANEL>

# Panels for the sequence "How do I find a file or folder?"

<DEFINE PANEL> "Find: intro"
<FORMAT> "Full"
You can locate items on any disk being used by your computer. You locate items 
by opening the Apple menu and choosing Find File. (You can also begin a search 
by choosing Find from the File menu.)

When you search for items, you can specify one or more criteria for the computer to use 
in the search.

<On Panel Create> DoAppleScript(":Open AppleScripts:Null AS script")
<END PANEL>

<DEFINE PANEL> "Apple menu: choose Find File"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Choose Find File from the Apple Menu.

<COACH MARK> "Menu:Front:Apple:Find File"
<END PANEL>

<DEFINE PANEL> "find location: use pop-up"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Use the pop-up menu labeled “Find items” to specify where you want to 
search.

You can search on all disks connected to your computer, on shared disks 
(called servers) only, on all disks except shared disks (called local disks), or 
on individual disks.

<COACH MARK> "Window:Find File:Find Items"
<END PANEL>

<DEFINE PANEL> "find: multiple"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Click the More Choices or the Fewer Choices button until the number of rows 
is the same as the number of search criteria you want to use.

(You can specify as many as 10 criteria in the search window.)
<COACH MARK>  "Window:Find File:More/Fewer Choices"

<END PANEL>

<DEFINE PANEL> "find: multiple pop-ups"



<FORMAT> "Tag"
Do This

<FORMAT> "Body"
Starting with the leftmost pop-up menu, describe the items you want to find.

As appropriate, type text to search for, or click a number and then use the up 
or down arrow to change it.  

If you need to add more search criteria, use the pop-up menus to identify the 
new criteria. (If necessary, expand the window by clicking the More Choices 
button to add criteria.)

<COACH MARK> "Window:FindFile:MoreCriteria:Rect"
<END PANEL>

<DEFINE PANEL> "find: click Find 4"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Click Find when you have completed your search criteria.

Only the items that meet all criteria are displayed in the search results 
window.

(If no matching items were found, you hear a beep or see a message.)
<COACH MARK> "FindFile:Find:Wind:Rect"

<END PANEL>

<DEFINE PANEL> "find: list choice"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Click an item in the list to see its location.

The location of the item selected is displayed in the bottom section of the 
search results window. 

You can double-click the item to open it. 

You can also choose commands from the File, Edit, and View menus to work 
with the items located in the search.

<COACH MARK> "Item:Find File:results:top"
<END PANEL>

<DEFINE PANEL> "find: System file"
<FORMAT> "Tag"

Tip

<FORMAT> "Body"
You can’t use the Find command to locate items inside the System file (which 
is inside the System Folder). You need to open the System file to see its 
contents.

If you’re using the Launcher, the Find command locates items or aliases of 
items inside the Launcher Items folder (instead of the items’ buttons in the 
Launcher window).

<PANEL PROMPT> "Prompt Override: 10"



<Dimmable Button Data> "Huh?","Definitions System file"
<END PANEL>



# Panels for the question "Definitions Tips for finding items"

<DEFINE PANEL> "Finding items: tips1"
<FORMAT> "Full"
If you can’t find the icon you need, try the following:

• Move an open window by dragging its title bar (at the top of the window).

• Make a window bigger by dragging its size box (at the lower-right corner of the 
window).

• Scroll hidden portions of the window into view by clicking the scroll arrows (along the 
right and bottom edges of the window).

• If only the title bar for a window is visible, click the title, using the WindowShade key 
combination. (Click Huh? below for more information about WindowShade.)

<Dimmable Button Data> "Huh?","How do I adjust window shrinking?"
<PANEL PROMPT> "Prompt Override: 39"

<END PANEL>

<DEFINE PANEL> "Finding items: tips2"
<FORMAT> "Full"
If you can’t find the item by checking the windows on your screen, you can probably 
locate the item by using the Find File command (in the Apple menu).

(You can also choose the Find command from the File menu to begin this procedure.)
<PANEL PROMPT> "Prompt Override: 8"

<END PANEL>

<DEFINE PANEL> "Finding items: tips3"
<FORMAT> "Full"
If you can’t find the item by using the Find File command, that item may not be on any 
disk the computer is currently using. Check your backup disks, the original disk on which 
you received the item, or the software that came with your computer.

It’s also possible that the item you want is on a shared disk. You can connect to a shared 
disk and then use the Find File command to search for the item on that disk.

<PANEL PROMPT> "Prompt Override: 6"
<END PANEL>



<DEFINE PANEL> "Finding items: tips4"
<FORMAT> "Full"
If the item you need to find is part of the system software that came with your computer 
(or that you got as part of a system software upgrade), you must use the Installer program 
to add that component to your system software. 

(System software components are compressed when distributed; the Installer program 
uncompresses them during installation. You can identify a compressed component of 
system software by its icon, which has a belt around the middle. )

For instructions on installing system software components, click Huh? below.
<Dimmable Button Data> "Huh?","How do I install system software components?"

<PANEL PROMPT> "Prompt Override: 6"
<END PANEL>

# Panels for the sequence "How do I copy an item?"

<DEFINE PANEL> "copying: intro"
<FORMAT> "Full"
You copy an item by manipulating its icon. You do this type of copying when you’re 
using the Finder (the system software that displays the desktop and manages files, 
folders, and disks).

For instructions on copying part of a document when working in an application program, 
click Huh? below.

<Dimmable Button Data> "Huh?","How do I copy an item between programs?"
<END PANEL>

# Panels for the sequence "How do I find the original of an alias?"

<DEFINE PANEL> "alias original: intro"
<FORMAT> "Full"
You can find the original file that an alias points to using the alias’s Info window.

<Dimmable Button Data> "Huh?","Definitions alias"
<END PANEL>

# Panels for the sequence "How do I create a template?"

<DEFINE PANEL> "stationery: select doc"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Click the document to select it.



<END PANEL>

<DEFINE PANEL> "stationery: click checkbox"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Click the box labeled “Stationery pad” (in the lower-right corner of the Info 
window). (Clicking to remove an X changes the item from a template to a 
document.)

If the box’s label is dimmed, the document may be locked. Click the Locked 
checkbox to remove the X, then click the box labeled “Stationery pad.”

If you don’t see the box, the file you selected isn’t a document.
<COACH MARK> "Wind:Info:Stationery"
<PANEL PROMPT> "Prompt Override: 19"

<END PANEL>

<DEFINE PANEL> "stationery: directory dialog box"
<FORMAT> "Tag"

Tip

<FORMAT> "Body"
Many programs let you save a document as a stationery pad.

When you save a
document, look for
a stationery pad
icon in the box
that appears.
Click the icon to
save the document
as a stationery pad.

<FORMAT> "ResetPen"
<PICT> 1030,  Point(185,50)
<PANEL PROMPT> "Standard Prompts"

<END PANEL>

# Panels for the sequence "How do I arrange icons neatly?"

<DEFINE PANEL> "neat icons: intro"
<FORMAT> "Full"
You can arrange icons along a grid using the Clean Up command in the Special menu.  
You can arrange icons in a list using the View menu. You can change the grid for icons 
using the Views control panel.

What do you want to do? Click one:
<RADIO BUTTON> "arrange all icons in a window", true,,, ,APPLEGUIDE
<RADIO BUTTON> "arrange selected icons", false,,, ,APPLEGUIDE
<RADIO BUTTON> "arrange icons on the desktop", false,,, ,APPLEGUIDE
<RADIO BUTTON> "arrange icons by name or other list view", false,,,,APPLEGUIDE
<RADIO BUTTON> "change the grid", false,,, ,APPLEGUIDE



<On Panel Create> DoAppleScript(":Open AppleScripts:Null AS script")
<END PANEL>

<DEFINE PANEL> "Special: choose Clean Up"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Open the Special menu and choose Clean Up Window.

(The Clean Up command is dimmed if the items appear as a list.  Use the 
View menu to choose an icon view.)

<COACH MARK> "Menu:MACS:Special:1"
<END PANEL>

<DEFINE PANEL> "neat icons: select"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Drag or Shift-click to select the icons you want to arrange.

<Dimmable Button Data> "Huh?","Definitions Shift-clicking"
<END PANEL>

<DEFINE PANEL> "Special: Shift Clean Up"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Hold down the Shift key as you open the Special menu and choose Clean Up 
Selection.

(The Clean Up command is dimmed if the items appear as a list.  Use the 
View menu to choose an icon view.)

<COACH MARK> "Menu:MACS:Special:1"
<END PANEL>

<DEFINE PANEL> "neat icons: desktop"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Click an icon on the desktop (the background pattern on your screen).

<END PANEL>

<DEFINE PANEL> "Special: Clean Up Desktop"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Open the Special menu and choose Clean Up Desktop.

<COACH MARK> "Menu:MACS:Special:1"
<END PANEL>

<DEFINE PANEL> "Special: Option Clean Up Desktop"
<FORMAT> "Tag"

Tip



<FORMAT> "Body"
You can arrange the icons along the right edge of the desktop by holding 
down the Option key, opening the Special menu and choosing Clean Up All.

<PANEL PROMPT> "Prompt Override: 10"
<END PANEL>

<DEFINE PANEL> "View: choose any list"



<FORMAT> "Tag"
Do This

<FORMAT> "Body"
Open the View menu and choose the way you want the icons sorted.

<COACH MARK> "Menu:MACS:Views:none"
<END PANEL>

<DEFINE PANEL> "View: choose Icon"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Open the View menu and choose By Icon.

<COACH MARK> "Menu:MACS:Views:by Icon"
<END PANEL>

<DEFINE PANEL> "Special: Option Clean Up"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Hold down the Option key as you open the Special menu and choose the 
Clean Up command.

<COACH MARK> "Menu:MACS:Special:1"
<END PANEL>

<DEFINE PANEL> "staggered icons: intro"
<FORMAT> "Full"
You can arrange icons along a straight grid or a staggered grid using the Views control 
panel.

<PANEL PROMPT> "Prompt Override: 8"
<END PANEL>

# Panels for the sequence "How do I assign a label to an item?"

<DEFINE PANEL> "label: intro"
<FORMAT> "Full"
You can use a label and its associated color (or shade of gray) to group related items.

You can see labels when you view the contents of a window as a list. You can group 
items by label using the View menu.

<END PANEL>

<DEFINE PANEL> "Label: choose one"



<FORMAT> "Tag"
Do This

<FORMAT> "Body"
Open the Label menu and choose the label and color you want to assign. (The 
color does not appear if your monitor is set to display fewer than 16 colors or 
grays. For instructions on setting your monitor to display colors, click Huh? 
below.)

If the Label menu is dimmed, you haven’t selected an icon. 
<COACH MARK> "Menu:MACS:Label:none"
<PANEL PROMPT> "Prompt Override: 19"
<Dimmable Button Data> "Huh?","How do I display colors or grays?"

<END PANEL>

# Panels for the sequence "How do I move an item?"

<DEFINE PANEL> "move item: intro"
<FORMAT> "Full"
You move an item by manipulating its icon. You move items this way when you’re using 
the Finder (the system software that displays the desktop and manages files, folders, and 
disks).

When you’re working with a document in an application program, you move an item by 
selecting it and then dragging or choosing menu commands.

Which do you want to do? Click one:
<RADIO BUTTON> "move an item in the Finder", true,,, ,APPLEGUIDE
<RADIO BUTTON> "move an item within a document", false,,, ,APPLEGUIDE
<Dimmable Button Data> "Huh?","Definitions icon"

<END PANEL>

<DEFINE PANEL> "housekeeping: move"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
To move the item, drag it to the folder, disk, or window where you want it.

If you drag the item to another disk, a copy of the item is created on that disk. 
The original item remains where it was.

<END PANEL>

<DEFINE PANEL> "Drag move: select item"



<FORMAT> "Tag"
Do This

<FORMAT> "Body"
Select the text, image, or other item you want to move.

(The way you select the item depends on the program you’re using. See the 
program’s instructions if you don’t know how to select an item.)

The item is highlighted when you select it.
<Dimmable Button Data> "Huh?","Definitions highlighting"

<END PANEL>

<DEFINE PANEL> "Drag move: drag within doc"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Drag the selected item to the location where you want to move it. (As you 
drag, an insertion point indicates where the item will be copied.)

If the selected item doesn’t move when you try to drag it, your program may 
not allow this method of moving. You can move the selected item by first 
choosing Cut from the Edit menu. Then click at the location where you want 
to place the item, and choose Paste from the Edit menu.

<END PANEL>

<DEFINE PANEL> "housekeeping: copy intro"
<FORMAT> "Full"
Where do you want to create a copy of the item? Click one:

<RADIO BUTTON> "on the same disk", true,,, ,APPLEGUIDE
<RADIO BUTTON> "on another disk", false,,, ,APPLEGUIDE

<END PANEL>

<DEFINE PANEL> "housekeeping: copy same"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
To make a copy of the item on the same disk, open the File menu and choose 
Duplicate.

If you need instructions on choosing a menu item, click Huh? below.
<COACH MARK> "Menu:MACS:File:Duplicate"
<PANEL PROMPT> "Prompt Override: 19"
<Dimmable Button Data> "Huh?","Why can’t I choose a menu item?"

<END PANEL>

<DEFINE PANEL> "housekeeping: copy same tip"
<FORMAT> "Tag"

Tip

<FORMAT> "Body"
You can also make a copy in another folder on the same disk. To do this, you 
hold down the Option key as you drag the item to the other folder.

<Dimmable Button Data> "Huh?","Definitions Clipping"
<PANEL PROMPT> "Standard Prompts"



<END PANEL>



<DEFINE PANEL> "housekeeping: copy other"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
To make a copy of the item on another disk, drag the item to the other disk. 
(The original item stays where it was.)

<END PANEL>

<DEFINE PANEL> "throw away item: intro"
<FORMAT> "Full"
You throw away an item by manipulating its icon.

<Dimmable Button Data> "Huh?","Definitions icon"
<END PANEL>

<DEFINE PANEL> "housekeeping: retrieve trash"
<FORMAT> "Tag"

Tip

<FORMAT> "Body"
You can get an item out of the Trash.  You open the Trash, select the item, and 
then open the File menu and choose Put Away. The item returns to where it 
was before you put it in the Trash.

<PANEL PROMPT> "Prompt Override: 35",
<END PANEL>

# Panels for the sequence "How do I use a clipping file?"

<DEFINE PANEL> "clipping: intro"
<FORMAT> "Full"
You can copy a clipping file into a document if the program that created the document 
“recognizes” the clipping. (Some programs can’t use clipping files.)

<Dimmable Button Data> "Huh?","Definitions clipping"
<END PANEL>

<DEFINE PANEL> "clipping: drag to doc"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Drag the clipping to the window of a document.

The clipping’s content is copied at the point in the document where you place 
it.  (If the program can’t use a clipping, you can’t drag the icon into the 
document window.)

<END PANEL>

# Panels for the sequence "How do I prepare a disk for use?"

<DEFINE PANEL> "initialize: intro"
<FORMAT> "Full"
Before you can use a new disk, you need to prepare it. This is called initializing (or 
formatting) the disk.

Initializing a disk erases any information on it.
<END PANEL>

<DEFINE PANEL> "initialize: hard or floppy"



<FORMAT> "Full"
Which do you want to prepare for use? Click one:

<RADIO BUTTON> "new floppy disk", true,,, ,APPLEGUIDE
<RADIO BUTTON> "hard disk", false,,, ,APPLEGUIDE

<END PANEL>

<DEFINE PANEL> "insert: floppy"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Insert the new floppy disk in the disk drive.

Some new floppy disks are already initialized. If the floppy disk icon appears 
on the desktop when you insert the disk, the disk is already initialized, and 
you’re done.

For instructions on reinitializing or erasing a disk that is already initialized, 
click Huh? below.

<Dimmable Button Data> "Huh?","How do I erase a disk?"
<END PANEL>

<DEFINE PANEL> "initialize: floppy2"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Choose a format from the pop-up menu, then click Initialize.

The choices in the Format menu vary according to the disk’s capacity and 
type. You usually can choose a format for a Macintosh computer or for a DOS 
computer.

<COACH MARK> "Item:Erase dialog:Format Pop-up"
<END PANEL>

<DEFINE PANEL> "HD setup: open"
<FORMAT> "Full"
To prepare a hard disk, you use the Apple HD SC Setup program. For instructions on 
using this program, see the user’s guide that came with your computer.

For instructions on reinitializing or erasing a disk that is already initialized, click Huh? 
below.

<PANEL PROMPT> "Standard Prompts"
<Dimmable Button Data> "Huh?","How do I erase a disk?"

<END PANEL>

# Panels for the sequence "How do I change the name of an item?"

<DEFINE PANEL> "rename: select item name"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Click the name of the item to select it.  (Do not click the icon.)

<END PANEL>

<DEFINE PANEL> "rename: enter new"



<FORMAT> "Tag"
Do This

<FORMAT> "Body"
Type a new name and press Return.

If you can’t change the name of an icon, click Huh? below for an explanation.
<Dimmable Button Data> "Huh?","Why can’t I change the name of an icon?"

<END PANEL>

# Panels for the sequence "How do I protect a file or disk?"

<DEFINE PANEL> "Protect: intro"
<FORMAT> "Full"
You can protect a file by locking it, by locking the floppy disk that it’s on, or by placing it 
in one of two protected folders—the Applications folder and the System Folder.

If a file or disk is locked, you can open and copy its contents, but you can’t change or 
delete the file. If the Applications folder or the System Folder is protected, you can’t 
remove or change items in it.

Which do you want to do? Click one:
<RADIO BUTTON> "lock a file", true,,, ,APPLEGUIDE
<RADIO BUTTON> "lock a floppy disk", false,,, ,APPLEGUIDE
<RADIO BUTTON> "protect the Applications folder or System Folder", 

false,,, ,APPLEGUIDE
<On Panel Create> DoAppleScript(":Open AppleScripts:Null AS script")
<END PANEL>

<DEFINE PANEL> "Info: click lock"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Click the Locked checkbox to put an X in it.

Some programs do not work properly when they are locked.

Folders and disk icons cannot be locked.
<END PANEL>

# Panels for the sequence "How do I use a RAM disk?"

<DEFINE PANEL> "RAM disk: noCanDo"
<FORMAT> "Full"
Some Macintosh computers come with RAM disk software.  To see if your computer 
does, open the Memory control panel and look for a RAM Disk area.

You can also purchase RAM disk software. To use a RAM disk, you need at least 4 MB 
of RAM.

<PANEL PROMPT> "Prompt Override: 8"
<Dimmable Button Data> "Huh?","Definitions RAM disk"



<END PANEL>

<DEFINE PANEL> "Use RAM disk: intro"
<FORMAT> "Full"
A RAM disk is like any other disk, except that you must save your work onto another 
disk before turning off your computer.

What would you like to do? Click one:
<RADIO BUTTON> "Create a RAM disk", true,,, ,APPLEGUIDE
<RADIO BUTTON> "Erase the contents of a RAM disk", false,,, ,APPLEGUIDE
<RADIO BUTTON> "Resize or remove a RAM disk", false,,, ,APPLEGUIDE
<Dimmable Button Data> "Huh?","Definitions RAM disk"

<On Panel Create> DoAppleScript(":Open AppleScripts:Null AS script")
<END PANEL>

<DEFINE PANEL> "RAM disk: creating intro"
<FORMAT> "Full"
A RAM disk is temporary storage. Any information on it is lost when you turn off your 
computer or if something goes wrong with your computer.

•  Before using a program on a RAM disk, test the
   program on a hard disk or floppy disk to make sure
   it works properly.

•  Don’t store your only copy of a file on a RAM disk.
   Keep a backup copy on a hard disk or a floppy disk.

<PANEL PROMPT> "Prompt Override: 8"
<END PANEL>

<DEFINE PANEL> "RAM disk: creating"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Click On to create the RAM disk, then drag the slider to choose the 
percentage of available memory you want to use for your RAM disk. (Choose 
the smallest size that will accommodate the files you want to put on the RAM 
disk.)

If you don’t see the RAM Disk section in the control panel, your computer 
does not come with RAM disk software.

<COACH MARK> "Item:Memory CP:turn on Ram Disk"
<END PANEL>

<DEFINE PANEL> "RAM disk: choose disk"



<FORMAT> "Tag"
Do This

<FORMAT> "Body"
To erase the contents of the RAM disk, click the RAM disk icon.

(If you don’t see a RAM disk icon on the desktop, you haven’t created one. If 
you aren’t sure whether an icon represents a RAM disk, select the icon and 
choose Get Info from the File menu. The Info window identifies the type of 
disk.)

<COACH MARK> "Finder Desktop Ram Disk"
<END PANEL>

<DEFINE PANEL> "RAM disk: erase no free RAM"
<FORMAT> "Tag"

Tip

<FORMAT> "Body"
Erasing a RAM disk does not remove its icon or make memory available. To 
free the memory that the RAM disk is using, you need to remove the RAM 
disk.

<PANEL PROMPT> "Standard Prompts"
<END PANEL>

<DEFINE PANEL> "RAM disk: resize-remove intro"
<FORMAT> "Full"
Before you can resize or remove a RAM disk, you need to erase its contents.

<PANEL PROMPT> "Prompt Override: 8"
<END PANEL>

<DEFINE PANEL> "Ram Disk icon: opening"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Open the RAM Disk icon.

(If you don’t see a RAM disk icon on the desktop, you haven’t created one. If 
you aren’t sure whether an icon represents a RAM disk, select the icon and 
choose Get Info from the File menu. The Info window identifies the type of 
disk.)

<COACH MARK> "Finder Desktop Ram Disk"
<END PANEL>

<DEFINE PANEL> "RAM disk: copy files"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Copy any files you want to save onto a hard disk or floppy disk.

<END PANEL>

<DEFINE PANEL> "RAM disk: drag items to trash"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Drag everything on the RAM disk to the Trash.



<END PANEL>

<DEFINE PANEL> "Special menu: choose empty trash"



<FORMAT> "Tag"
Do This

<FORMAT> "Body"
Open the Special menu and choose Empty Trash.

If a message appears, click OK.

If you need instructions on choosing a menu item, click Huh? below.
<COACH MARK> "Menu:MACS:Special:Empty Trash"
<Dimmable Button Data> "Huh?","Why can’t I choose a menu item?"

<END PANEL>

<DEFINE PANEL> "RAM disk: drag or click"
<FORMAT> "Tag"

Do This

Do This
<FORMAT> "Body"
To resize the RAM disk, drag the slider to choose the percentage of available 
memory you want to use.

To remove the RAM disk, click the Off button.
<COACH MARK> "Item:Memory CP:size Ram Disk"

<END PANEL>

# Panels for the sequence "How do I make a disk the startup disk?"

<DEFINE PANEL> "select startup: intro"
<FORMAT> "Full"
If you use more than one hard disk, you can specify which hard disk you want the 
computer to use as a startup disk the next time you turn on the computer.

<Dimmable Button Data> "Huh?","Definitions startup disk"
<On Panel Create> DoAppleScript(":Open AppleScripts:Null AS script")
<END PANEL>

<DEFINE PANEL> "Startup Disk: segue to install"
<FORMAT> "Full"
The software you need, Startup Disk control panel, is not installed. You need to install 
this software before you can complete this task.

<PANEL PROMPT> "Prompt Override: 8"
<END PANEL>

<DEFINE PANEL> "Startup Disk: locate"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Locate the Startup Disk control panel. It’s part of the system software that 
came with your computer.

If you can’t find the control panel, click Huh? below for instructions.
<Dimmable Button Data> "Huh?","Definitions Tips for finding items"

<END PANEL>

<DEFINE PANEL> "Startup: open"



<FORMAT> "Tag"
Do This

<FORMAT> "Body"
Open the Startup Disk control panel.

<COACH MARK> "Finder Coach Startup Disk"
<Dimmable Button Data> "Huh?","How do I open an Item?"

<END PANEL>

<DEFINE PANEL> "Startup: choose disk"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Click the icon of the disk you want to use as the startup disk.

The next time you start up or restart the computer, it uses the selected disk (if 
the disk has a System Folder with the system software your computer needs).

<COACH MARK> "WIND:StartupCP:choose startup"
<END PANEL>

# Panels for the sequence "How do I erase a disk?"

<DEFINE PANEL> "erase: choose format"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Choose a format (if a pop-up menu appears next to the word “Format”), then 
click Erase.

You can’t erase the startup disk. You can’t erase a disk if file sharing is turned 
on for that disk.

The choices in the Format menu vary according to the disk’s capacity and 
type. You can choose a format for a Macintosh computer or for a DOS 
computer.

<COACH MARK> "Item:Erase dialog:Format Pop-up"
<END PANEL>

# Panels for the sequence "How do I eject a disk?"

<DEFINE PANEL> "disk: click"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Click the disk icon to select it.

If you select a hard disk, it won’t be ejected, but its icon will be removed from 
the desktop. (The startup disk icon can’t be removed from the desktop.) Also, 
a shared disk can’t be ejected.

<Dimmable Button Data> "Huh?","Definitions desktop"
<END PANEL>

<DEFINE PANEL> "disk: Trash and Eject"



<FORMAT> "Tag"
Tip

<FORMAT> "Body"
You can eject a disk by dragging the icon to the Trash. (This does not erase the 
contents of the disk.)

You also can eject a disk by clicking the disk, opening the Special menu, and 
choosing Eject Disk. The dimmed icon remains on your screen, and the 
computer may ask you to reinsert the disk later.

<PANEL PROMPT> "Standard Prompts"
<END PANEL>

# Panels for the sequence "How do I lock or unlock a floppy disk?"

<DEFINE PANEL> "lock floppy: intro choice"
<FORMAT> "Full"
You lock or unlock a floppy disk by sliding a tab at the upper-right corner of the disk. 
(When a floppy disk is locked, you can’t erase it, save items on it, or move items from it 
to the desktop.)

Which do you want to do? Click one:

<RADIO BUTTON> "lock a floppy disk", true,,, ,APPLEGUIDE
<RADIO BUTTON> "unlock a floppy disk", false,,, ,APPLEGUIDE
<Dimmable Button Data> "Huh?","Definitions disk"

<END PANEL>

# Panels for the sequence "How do I insert a floppy disk?"

<DEFINE PANEL> "Floppy: insert disk"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Hold the floppy disk with the label side up and the metal end toward the disk 
drive opening. Carefully push the disk into the drive.

<Dimmable Button Data> "Huh?","Definitions disk"
<END PANEL>

# Panels for the sequence "How do I prepare a disk in DOS format?"

<DEFINE PANEL> "DOS disk: preparing"
<FORMAT> "Full"
You prepare a DOS disk the same way you prepare a Macintosh disk—by initializing (or 
formatting) it. If the disk has been used previously, you reinitialize it.

Initializing a disk erases any information on it.
<END PANEL>

# Panels for the sequence "How do I open a DOS file on the Macintosh?"



<DEFINE PANEL> "DOS file: intro"
<FORMAT> "Full"
You can open a DOS file on the Macintosh if one of your application programs can read 
the file or if you have a translator to convert the file.

<END PANEL>

<DEFINE PANEL> "DOS file: open"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Double-click the icon of the DOS file you want to open.

When you double-click, either the file opens in one of your Macintosh 
programs, or a message appears.

(If you can’t locate the file you want to open, click Huh? below for 
instructions.)

<Dimmable Button Data> "Huh?","Definitions Tips for finding items"
<END PANEL>

<DEFINE PANEL> "DOS file: choose app"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Read the message, then choose the name of the program with which you want 
to open the DOS file and click Open.

If the message doesn’t list any programs, none of your programs may be able 
to open the file, or you may need to turn on the Macintosh Easy Open control 
panel.

For instructions on setting up your system software to open DOS files, click 
Huh? below.

<Dimmable Button Data> "Huh?","How do I set up my Macintosh to use DOS files?"
<END PANEL>

# Panels for the sequence "How do I create a file in DOS format?"

<DEFINE PANEL> "DOS file: create"
<FORMAT> "Full"
Some Macintosh programs can save files in a variety of formats, including formats for 
use with DOS programs and disks.

<END PANEL>

<DEFINE PANEL> "DOS file: save as"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Create or open a Macintosh document, then choose Save As from the File 
menu.

<COACH MARK> "Menu:Front:File:Save As"
<END PANEL>



<DEFINE PANEL> "DOS file: choose format"



<FORMAT> "Tag"
Do This

<FORMAT> "Body"
In the directory dialog box that appears, use the button or pop-up menu for file 
formats to choose a DOS format. Then click OK (if necessary) and click Save.

In some programs, file format choices may be listed under an “Options” 
button.

If the directory dialog box doesn’t have format choices, you may not be able 
to save a document in DOS format with that program. See the documentation 
for the program to learn about its file format options.

<PANEL PROMPT> "Prompt Override: 36"
<END PANEL>

<DEFINE PANEL> "DOS formats: tips1"
<FORMAT> "Tag"

Tip

<FORMAT> "Body"
You can identify many DOS files by the three-character suffix (the portion 
after the period) in their names. Common DOS formats include:

.TXT           text/word processing

.DOC           text/word processing

.WKS           text/spreadsheet

.WK1           text/spreadsheet

.WK3           text/spreadsheet

.XLS            text/spreadsheet
<PANEL PROMPT> "Standard Prompts"

<END PANEL>

# Panels for the sequence "How do I set up my Macintosh to use DOS files?"

<DEFINE PANEL> "DOS file: setup intro"
<FORMAT> "Full"
You can determine how your Macintosh handles a DOS file when you open that file. You 
can see a list of available programs and choose one each time you want to open a DOS 
file. You can also assign one of your Macintosh programs to open a type of DOS file 
automatically.

Which do you want to do?  Click one:
<RADIO BUTTON> "choose a program each time", true,,, ,APPLEGUIDE
<RADIO BUTTON> "assign a program to open each type of DOS file", false,,,,APPLEGUIDE

<On Panel Create> DoAppleScript(":Open AppleScripts:Null AS script")
<END PANEL>

<DEFINE PANEL> "Easy Open: intro"



<FORMAT> "Full"
You use the Macintosh Easy Open control panel to specify how programs are listed when 
you open a DOS file.

<PANEL PROMPT> "Standard Prompts"
<END PANEL>

<DEFINE PANEL> "Easy Open: segue to install"
<FORMAT> "Full"
The software you need, the Macintosh Easy Open control panel, is not installed. You need 
to install this software before you can complete this task.

<PANEL PROMPT> "Prompt Override: 8"
<END PANEL>

<DEFINE PANEL> "Easy Open: locate"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Locate the Macintosh Easy Open control panel. It’s part of the system 
software that came with your computer.

If you can’t find the control panel, click Huh? below for instructions.
<Dimmable Button Data> "Huh?","Definitions Tips for finding items"

<END PANEL>

<DEFINE PANEL> "Easy Open: open"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Open the Macintosh Easy Open control panel.

<COACH MARK> "Finder Coach Easy Open"
<Dimmable Button Data> "Huh?","How do I open an Item?"

<END PANEL>

<DEFINE PANEL> "Easy Open: choose options"



<FORMAT> "Tag"
Do This

<FORMAT> "Body"
To turn on automatic translation of documents, click On. Then click to put an 
X in one or more of the boxes.
• “Always show dialog box” displays a list of the programs available to open 
the file, from which you select a program.
• “Include applications on servers” also lists programs available on shared 
disks to which your computer is connected.
• “Auto pick if only 1 choice” selects the program to open a file if only one 
program that can open it is available.
• “Translate text documents” evaluates all text files for translation (which 
slows down opening of documents consisting of plain text).

<END PANEL>

<DEFINE PANEL> "Easy Open: tip"
<FORMAT> "Full"
The  Macintosh Easy Open software keeps track of which programs you use to open 
specific types of files and matches your choices when possible. If you click Delete 
Preferences (and then confirm by clicking Delete), your preferences are erased and the 
software begins making a new record of your choices.

When this control panel is set to Off, the list of programs is not displayed. A DOS file 
opens automatically if one of your programs recognizes it; otherwise, you usually see a 
message that the file can’t be opened.

<PANEL PROMPT> "Prompt Override: 10"
<END PANEL>

<DEFINE PANEL> "PC Exchange: intro"
<FORMAT> "Full"
You use the PC Exchange control panel to assign one of your programs to open each type 
of DOS file. Types of DOS files are identified by the three characters after the period in 
their names (called the suffix).

You can add, change, or remove the assignment of a program to a type of DOS file. 
Which do you want to do? Click one:

<RADIO BUTTON> "add a new assignment", true,,, ,APPLEGUIDE
<RADIO BUTTON> "change an assignment", false,,,,APPLEGUIDE
<RADIO BUTTON> "remove an assignment", false,,,,APPLEGUIDE

<END PANEL>

<DEFINE PANEL> "PC Exchange: segue to install"
<FORMAT> "Full"
The software you need, the PC Exchange control panel, is not installed. You need to 
install this software before you can complete this task.



<PANEL PROMPT> "Prompt Override: 8"
<END PANEL>

<DEFINE PANEL> "PC Exchange: locate"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Locate the PC Exchange control panel. It’s part of the system software that 
came with your computer.

If you can’t find the control panel, click Huh? below for instructions.
<Dimmable Button Data> "Huh?","Definitions Tips for finding items"

<END PANEL>

<DEFINE PANEL> "PC Exchange: open"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Open the PC Exchange control panel.

<COACH MARK> "Finder Coach PC Exchange"
<Dimmable Button Data> "Huh?","How do I open an Item?"

<END PANEL>

<DEFINE PANEL> "PC Exchange: add1"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Click Add to make a new assignment.

<COACH MARK> "Window:PC Exchange:Rect:Add button"
<END PANEL>

<DEFINE PANEL> "PC Exchange: add2"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Take the following actions in the directory dialog box that appears:
• Click the box under “DOS Suffix” and type 
  the last three characters of the name for 
  the file type you want to assign to a 
  program.
• Click the Application Program icon and 
  select a program from the list displayed. 
  (Use the scroll arrows and the Eject and 
  Desktop buttons to locate the program.)
• Use the Document Type pop-up menu to 
  choose the type of Macintosh document icon 
  to assign to the DOS file. (If you aren’t sure, 
  choose TEXT.)
• Click OK when the information is complete.



<COACH MARK> "Window:PC Exchange:top sections:Rect"
<END PANEL>



<DEFINE PANEL> "PC Exchange: change1"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Select the assignment you want to modify, then click Change.

<COACH MARK> "Window:PC Exchange:Change button:Rect"
<END PANEL>

<DEFINE PANEL> "PC Exchange: change2"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Change one or more of these items in the directory dialog box that appears:
• Click the box under “DOS Suffix” and type the 
  three characters of the name for the file 
  type you want to assign to a program.
• Click the Application Program icon and select 
  a program from the list displayed. (Use the 
  scroll arrows and the Eject and Desktop buttons 
  to locate the program you want.)
• Use the Document Type pop-up menu to choose 
  the type of Macintosh document icon to assign 
  to the DOS file. (If you aren’t sure, choose 
  TEXT.)
• Click OK when your changes are complete.

<COACH MARK> "Window:PC Exchange:top sections:Rect"
<END PANEL>

<DEFINE PANEL> "PC Exchange: remove"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Select the assignment you want to remove from the list in the control panel, 
then click Remove.

<COACH MARK> "Window:PC Exchange:Remove button:Rect"
<END PANEL>

# Panels for the sequence "How do I use a DOS disk?"

<DEFINE PANEL> "DOS disk: using"



<FORMAT> "Full"
Your Macintosh can recognize most DOS-format floppy disks. Simply insert the disk in 
the computer’s disk drive.
                                                  The disk’s icon appears on
                                                  the desktop. You can open
                                                  the disk by double-clicking
                                                  its icon.

If you see a message that the disk is unreadable, the disk may have been damaged or 
formatted incorrectly. Eject the disk to avoid losing the information stored on it. 
(Initializing the disk will erase any information on it.)

<FORMAT> "ResetPen"
<PICT> 1064, Point(45,50)
<PANEL PROMPT> "Standard Prompts"

<END PANEL>

# Panels for the sequence "How do I prepare a disk in DOS format?"

<DEFINE PANEL> "insert: floppy for DOS"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Insert a floppy disk or a removable cartridge in the disk drive. If you see a 
message that the disk is unreadable, you need to initialize it.

If the standard disk icon appears on the desktop, the disk is initialized in 
Macintosh format, and you need to erase it. If an icon with “PC” on it appears, 
the disk is already in DOS format.

Which do you want to do? Click one:
<RADIO BUTTON> "initialize an unreadable disk", true,,, ,APPLEGUIDE
<RADIO BUTTON> "erase a disk", false,,,,APPLEGUIDE

<END PANEL>

<DEFINE PANEL> "initialize: DOS floppy2"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Choose the format labeled “DOS” from the pop-up menu, then click Initialize.

<COACH MARK> "Item:Erase dialog:Format Pop-up"
<END PANEL>

<DEFINE PANEL> "erase: choose DOS format"



<FORMAT> "Tag"
Do This

<FORMAT> "Body"
Choose the format labeled “DOS” from the pop-up menu, then click Erase.

You can’t erase the startup disk. You can’t erase a disk if file sharing is turned 
on for that disk.

<COACH MARK> "Item:Erase dialog:Format Pop-up"
<END PANEL>

# Panels for the sequence "How do I print?"

<DEFINE PANEL> "printing: connect printer"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Make sure that your computer is connected to a printer, either directly or over 
a network, and that you have selected a printer in the Chooser.

See the user’s guide that came with your computer or the instructions that 
came with your printer if you need to connect a printer. 

For instructions on selecting a printer in the Chooser, click Huh? below.
<Dimmable Button Data> "Huh?","Definitions Choosing a printer"

<On Panel Create> DoAppleScript(":Open AppleScripts:Null AS script")
<END PANEL>

<DEFINE PANEL> "printing: choose printer"
<FORMAT> "Full"
Before you can print, you need to tell your computer which printer to use (even if only 
one printer is connected). You select a printer using the Chooser.

What kind of printer do you want to use? Click one:
<RADIO BUTTON> "printer on a network", false,,,,APPLEGUIDE
<RADIO BUTTON> "printer connected directly to the computer", true,,,,APPLEGUIDE

<Dimmable Button Data> "Huh?","Definitions Chooser"
<END PANEL>

<DEFINE PANEL> "printing: setup options1"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
To check the printer’s options for paper and imaging, click the button labeled 
either “Setup” or “Review” near the bottom of the Chooser.

<COACH MARK> "Item:Chooser:setup button"
<END PANEL>

<DEFINE PANEL> "printing: setup options2"



<FORMAT> "Tag"
Do This

Do This

<FORMAT> "Body"
Read the message in the box that appears, then click Setup.

When the label on the Setup button changes to “Done” (in a few seconds), 
click the button again.

For more information on any options in the box, open the Guide menu, choose 
Show Balloons, and then point to the different areas of the box. (Choose Hide 
Balloons when you are finished.)

<COACH MARK> "Item:Chooser AutoSetUp:setup button"
<END PANEL>

<DEFINE PANEL> "printing: window"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Open the window whose contents you want to print, or click the window to 
make it active.

(If the window contains a document, you can print it with the application 
program you used to create or edit the document.)

<Dimmable Button Data> "Huh?","Definitions active window"
<END PANEL>

<DEFINE PANEL> "File: Print Window"
<FORMAT> "Tag"

Do This

Do This

<FORMAT> "Body"
Open the File menu and choose Print Window.

In the box that appears, choose the options you want and click Print. (Or, if 
the box shows an OK button, choose options and click OK, then choose 
options in the second box and click Print.)

For more information on the options, open the Guide menu, choose Show 
Balloons, and then point to the different options. (Choose Hide Balloons when 
you are finished.)

<COACH MARK> "Menu:MACS:File:Print Window"
<END PANEL>

<DEFINE PANEL> "printing: desktop"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Click an icon on the desktop.

<END PANEL>



<DEFINE PANEL> "File: choose Print Desktop"



<FORMAT> "Tag"
Do This

Do This

<FORMAT> "Body"
Open the File menu and choose Print Desktop.

In the box that appears, choose the options you want and click Print. (Or, if 
the box shows an OK button, choose options and click OK, then choose 
options in the second box and click Print.)

For more information on the options, open the Guide menu, choose Show 
Balloons, and then point to the different options. (Choose Hide Balloons when 
you are finished.)

<COACH MARK> "Menu:MACS:File:Print Desktop"
<END PANEL>

# Panels for the sequence "How do I switch printers?"

<DEFINE PANEL> "printing: switch GX"
<FORMAT> "Full"
When your computer is connected to more than one printer (usually over a network), you 
can create desktop printer icons for each printer you want to use. To switch among 
desktop printers, you drag a document to the printer you want to use. You can also open a 
document, choose Print from the file menu, and select a desktop printer in the dialog box 
that appears.

<Dimmable Button Data> "Huh?","Definitions desktop printer"
<END PANEL>

<DEFINE PANEL> "printing: switch prereq"
<FORMAT> "Full"
Your computer must be connected to more than one printer (usually over a network) 
before you can switch printers. For instructions on making hardware connections to a 
network or to an additional printer, see your user’s guide.

For instructions on connecting to a network, click Huh? below.
<Dimmable Button Data> "Huh?","How do I connect to a network?"
<On Panel Create> DoAppleScript(":Open AppleScripts:Null AS script")

<END PANEL>

<DEFINE PANEL> "printing: switch intro"
<FORMAT> "Full"
You can change the printer you’re using by choosing another printer in the Chooser.

What type of printer do you want to use?  Click one:
<RADIO BUTTON> "printer on a network", false,,,,APPLEGUIDE
<RADIO BUTTON> "printer connected directly to the computer", true,,,,APPLEGUIDE

<Dimmable Button Data> "Huh?","Definitions Chooser"
<END PANEL>



# Panels for the sequence "PrintMonitor: not here"

<DEFINE PANEL> "PrintMonitor: not here"
<FORMAT> "Full"
With a feature called  background printing, you can use your computer for other work 
while documents are printing. To use background printing, the PrintMonitor program 
must be in your System Folder.

<Dimmable Button Data> "Huh?","Definitions System Folder"
<On Panel Create> DoAppleScript(":Open AppleScripts:Null AS script")

<END PANEL>

# Panels for the sequence "How do I manage printing jobs?"

<DEFINE PANEL> "PrintMonitor: intro"
<FORMAT> "Full"
You can watch your documents being printed, or cancel or delay printing, using the 
PrintMonitor program.

<On Panel Create> DoAppleScript(":Open AppleScripts:Null AS script")
<END PANEL>

<DEFINE PANEL> "PrintMonitor: segue"
<FORMAT> "Full"
To use PrintMonitor, you need to install it in your System Folder and turn background 
printing on.

<PANEL PROMPT> "Prompt Override: 8"
<Dimmable Button Data> "Huh?","Definitions Chooser"

<END PANEL>

<DEFINE PANEL> "PrintMonitor: managing prereq"
<FORMAT> "Full"
PrintMonitor opens automatically when you print a document.

<PANEL PROMPT> "Standard Prompts"
<END PANEL>

<DEFINE PANEL> "printing: document"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Print your document.

For instructions on printing, click Huh? below.
<Dimmable Button Data> "Huh?","How do I print?"

<END PANEL>

<DEFINE PANEL> "App menu: choose PrintMonitor"



<FORMAT> "Tag"
Do This

<FORMAT> "Body"
Wait several seconds after printing begins, then open the Application menu 
and choose PrintMonitor.

If PrintMonitor is not listed in the menu, wait another few seconds and try 
again.

If no document appears in PrintMonitor, printing is already finished.
<COACH MARK> "CoachMark: 31"

<END PANEL>

<DEFINE PANEL> "PrintMonitor: choices"
<FORMAT> "Full"
With PrintMonitor, you can do the following. What do you want to do? Click one:

<RADIO BUTTON> "check the printing status of a document", true,,,,APPLEGUIDE
<RADIO BUTTON> "cancel the printing of a document", false,,, ,APPLEGUIDE
<RADIO BUTTON> "set a printing time for a document", false,,, ,APPLEGUIDE

<END PANEL>

<DEFINE PANEL> "PrintMonitor: printing status"
<FORMAT> "Full"
The Printing box shows the name of the document being printed and the name of the 
printer.

The document’s printing status appears at the bottom of the window.
<PANEL PROMPT> "Prompt Override: 21"

<END PANEL>

<DEFINE PANEL> "PrintMonitor: waiting status"
<FORMAT> "Full"
The Waiting box lists documents that are waiting to be printed.

<PANEL PROMPT> "Prompt Override: 21"
<END PANEL>

<DEFINE PANEL> "PrintMonitor: cancel segue"
<FORMAT> "Full"
The following steps describe how to cancel the printing of a document.

<PANEL PROMPT> "Prompt Override: 8"
<END PANEL>

 <DEFINE PANEL> "PrintMonitor: click cancel"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Click Cancel Printing.

<END PANEL>



<DEFINE PANEL> "PrintMonitor: click set print"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Click Set Print Time.

<END PANEL>

<DEFINE PANEL> "PrintMonitor: set time"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Click the time or date and click the up and down arrows until the number you 
want appears. (The time and date that appear in the box initially are the ones 
currently set on your computer’s clock.)

Or, if you want to set a print time later, click Postpone Indefinitely.

When you’ve set a time, click OK.

If you need to change the computer’s clock, click Huh? below for instructions.
<Dimmable Button Data> "Huh?","How do I set the time and date?"

<END PANEL>

<DEFINE PANEL> "PrintMonitor: outro"
<FORMAT> "Full"
PrintMonitor alerts you when the printer needs paper or if there is a printing problem.

If you want to change how PrintMonitor alerts you, open the File menu and choose 
Preferences while PrintMonitor is the active program. (Click OK after choosing options 
in the Preferences box.)

<PANEL PROMPT> "Prompt Override: 21"
<END PANEL>

<DEFINE PANEL> "PrintMonitor: close"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Click anywhere outside the PrintMonitor window to close the window.

<END PANEL>

# GX Panels follow
<DEFINE PANEL> "printing:background GX"

<FORMAT> "Full"
With QuickDraw GX installed you will always be able to print your documents and 
continue working.

<END PANEL>

# How do I share a printer with other users

<DEFINE PANEL> "Share a printer Intro:GX"



<FORMAT> "Full"
If your computer is connected to a network, you can allow other users access to 
a printer that’s directly connected to your computer.

You can limit access to a shared desktop printer to users in your network zone, or 
to users to whom you give a password to the printer.

To share a printer, you select a desktop printer, then choose Sharing from the 
File menu.

<On Panel Create> DoAppleScript(":Open AppleScripts:Null AS script")
<END PANEL>

<DEFINE PANEL> "Create or Use:GX"
<FORMAT> "Full"
If you have not already created a desktop printer for the printer you want to share, you 
must do so before you share the printer. What do you want to do? Click one:

<RADIO BUTTON> "create and share desktop printer", true,,, ,APPLEGUIDE
<RADIO BUTTON> "share a desktop printer already on the desktop", false,,, ,APPLEGUIDE

<END PANEL>

<DEFINE PANEL> "Choose Sharing:GX"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Choose Sharing from the File menu.

<COACH MARK> "Menu:MACS:File:Sharing"
<END PANEL>

<DEFINE PANEL> "Click Share Box:GX"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Click in the box labeled "Share this printer" to allow other users access to the 
printer.

<END PANEL>

<DEFINE PANEL> "Click Non GX box:GX"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
If you want to allow other users access to the printer even if they do not have 
QuickDraw GX on their computers, click the second button.

If the second button is not available, click to place an X in the box labeled 
“Share this Printer.”

<COACH MARK> "Non GX box"
<END PANEL>

<DEFINE PANEL> "Choose Users:GX"



<FORMAT> "Tag"
Do This

<FORMAT> "Body"
Use the pop-up menu to choose the registered users and groups you want to 
allow to use the printer.

If you need to register more users and groups, click Huh? below.
<Dimmable Button Data> "Huh?","How do I register or remove users and groups?"

<END PANEL>

<DEFINE PANEL> "Choose Guests:GX"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Use the Guests pop-up menu to choose whether to allow guests to use the 
printer. If you want, you can restrict guest access to users in your zone on the 
network.

Guests can use the printer without a password.
<END PANEL>

<DEFINE PANEL> "Choose Access:GX"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Click to turn off access of a particular kind for users & groups, and for guests. 

• May Print access means users are able to 
  print on the printer.
• See Files access means users can view 
  documents waiting to print on the printer.
• Change Files access means users can make 
  changes to their documents that are 
  waiting to print on the printer.

<END PANEL>

<DEFINE PANEL> "Close Sharing:GX"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Close the Sharing window.

<END PANEL>

# Begin question: How do I use more than one printer?

<DEFINE PANEL> "Use several printers intro:GX"

<FORMAT> "Full"
You can create a desktop printer for each printer to which your computer is connected, 
directly or over a network. 

You can print on more than one desktop printer at the same time. 

For instructions on creating a desktop printer, click Creating. For instructions on printing, 



click Printing.

<RADIO BUTTON> "Creating", true,,, ,APPLEGUIDE
<RADIO BUTTON> "Printing", false,,, ,APPLEGUIDE



<Dimmable Button Data> "Huh?","Definitions desktop printer"
<On Panel Create> DoAppleScript(":Open AppleScripts:Null AS script")

<END PANEL>

#Begin question: How do I change printing options?

<DEFINE PANEL> "Printing options choice:GX"
<FORMAT> "Full"
You can change printing options for all documents printed on a desktop printer, or for a 
document (such as a window or the contents of the desktop). What do you want to do? 
Click one:

<RADIO BUTTON> "change printing options for a desktop printer", true,,, ,APPLEGUIDE
<RADIO BUTTON> "change printing options for a document", false,,, ,APPLEGUIDE
<On Panel Create> DoAppleScript(":Open AppleScripts:Null AS script")

<END PANEL>

<DEFINE PANEL> "Select DT Printer:GX"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Click the desktop printer you want to work with.

<END PANEL>

<DEFINE PANEL> "Trays or Extensions Choice:GX"
<FORMAT> "Full"
You can change the printing extensions to use with the selected printer,  specify the 
location in which your Portable Digital Documents are saved, or you can specify the type 
of paper loaded in the printer. What do you want to do? Click one:

<RADIO BUTTON> "choose printing extensions to use with the printer", true,,, ,APPLEGUIDE
<RADIO BUTTON> "specify the type of paper loaded in the printer", false,,, ,APPLEGUIDE

<RADIO BUTTON> "specify the location for PDDs", false,,, ,APPLEGUIDE
<END PANEL>

<DEFINE PANEL> "Choose Input Trays:GX"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Choose Input Trays from the Printing menu.

<COACH MARK> "Menu:MACS:Printing:Input Trays"
<END PANEL>

<DEFINE PANEL> "PaperTrays:GX"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Specify the type of paper currently loaded in the printer. 

When you've made your choices, click OK.

For more information about the options in this dialog box, choose Show 
Balloons from the Guide menu.

<END PANEL>



<DEFINE PANEL> "Choose Extension Setup:GX"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Choose Extension Setup from the Printing menu.

<COACH MARK> "Menu:MACS:Printing:Extension Setup"
<END PANEL>

<DEFINE PANEL> "Extensions:GX"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Click to turn on or off each printing extension.

To change the order in which a printing extension is used, drag the extension 
to a new position in the list.

For more information about the options in this dialog box, choose Show 
Balloons from the Guide menu.

<END PANEL>

<DEFINE PANEL> "Choose PDD Setup:GX"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Choose PDD Maker Setup from the Printing menu.

<END PANEL>

<DEFINE PANEL> "PDD Setup:GX"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Choose the folder or hard disk in which you want your Portable Digital 
Documents automatically saved.

For more information about the options in this dialog box, choose Show 
Balloons from the Guide menu.

<COACH MARK> "Menu:MACS:Printing:PDD Maker Setup"
<END PANEL>

<DEFINE PANEL> "Page Setup:GX1"
<FORMAT> "Full"
You use the Page Setup command to change the printing options for a document. 

To change the page setup of a document created with an application, open the document, 
then choose Page Setup from the File menu.

To change the page setup for printing a window or the contents of the desktop.
<PANEL PROMPT> "Prompt Override: 4"

<END PANEL>

<DEFINE PANEL> "Page Setup:GX2"



<FORMAT> "Tag"
Do This

<FORMAT> "Body"
Open the File menu and choose Page Setup.

In the box that appears, choose the options you want and click OK. 

For more information on the options, open the Guide menu, choose Show 
Balloons, and then point to the different options. (Choose Hide Balloons when 
you are finished.)

<COACH MARK> "Menu:MACS:File:Page Setup"
<END PANEL>

# Begin question: How do I create a Portable Digital Document?
<DEFINE PANEL> "Create PDD intro:GX"

<FORMAT> "Full"
To create a Portable Digital Document (PDD), you create a type of desktop printer called 
a PDD Maker. Then you print a document to the PDD Maker.

<Dimmable Button Data> "Huh?","Definitions portable digital document"
<On Panel Create> DoAppleScript(":Open AppleScripts:Null AS script")
<END PANEL>

#Begin sequence for "use a PDD Maker already on the desktop"

<DEFINE PANEL> "locate PDD Maker"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Locate the PDD Maker desktop printer on your desktop.

<END PANEL>

<DEFINE PANEL> "locate doc"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Locate the document you want to use to create a Portable Digital Document.

<END PANEL>

<DEFINE PANEL> "drag Doc To PDD maker"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Drag the document to the PDD Maker desktop printer.

The resulting Portable Digital Document is saved in the location you specify 
when you choose PDD Setup from the Printer menu.

<END PANEL>
#End of sequence for "use a PDD Maker already on the desktop"



#Begin sequence for "create and use a PDD Maker desktop printer"



<DEFINE PANEL> "Chooser:choose PDD maker:GX"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
In the upper-left area of the Chooser, click PDD Maker GX.

You may need to use the scroll bar to find PDD Maker GX.
<COACH MARK> "Item:Chooser:select driver"

<END PANEL>

<DEFINE PANEL> "Chooser: click Create PDD GX"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Click Create to make a desktop icon representing the PDD Maker you chose.

<COACH MARK> "CoachMark: 156"
<END PANEL>

<DEFINE PANEL> "Chooser: PDD maker NoZones:GX"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
In the left area of the Chooser, click PDD Maker GX.

You may need to use the scroll bar to find PDD Maker GX.
<COACH MARK> "Item:Chooser:select zone"

<END PANEL>

# Begin question: How do I manage printing jobs?

<DEFINE PANEL> "No Desktop Printer:GX"
<FORMAT> "Full"
To manage your printing tasks you must first create a desktop printer.  

For instructions on creating a desktop printer, click Huh? below.
<Dimmable Button Data> "Huh?","How do I create a desktop printer?"

<END PANEL>

<DEFINE PANEL> "Manage printing intro:GX"
<FORMAT> "Full"
You can watch your documents being printed, cancel, delay, and schedule printing, and 
set the priority of a print job. To manage your printing jobs in these ways, you open the 
desktop printer on which your documents are being printed.

<On Panel Create> DoAppleScript(":Open AppleScripts:Null AS script")
<END PANEL>

<DEFINE PANEL> "print something:GX"



<FORMAT> "Tag"
Do This

<FORMAT> "Body"
Print your documents.

For instructions on printing, click Huh? below.
<Dimmable Button Data> "Huh?","How do I print?"

<END PANEL>

<DEFINE PANEL> "open printer:GX"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Wait several seconds after printing begins, then double-click the desktop 
printer that's printing your documents.

<Dimmable Button Data> "Huh?","Definitions desktop printer"
<END PANEL>

<DEFINE PANEL> "Manage printing choices:GX"
<FORMAT> "Full"
You can manage your printing jobs in the following ways. What do you want to do? Click 
one:

<RADIO BUTTON> "check the printing status of a document", true,,, ,APPLEGUIDE
<RADIO BUTTON> "set the time for printing a document", false,,, ,APPLEGUIDE
<RADIO BUTTON> "stop printing", false,,, ,APPLEGUIDE
<RADIO BUTTON> "resume printing", false,,, ,APPLEGUIDE

<END PANEL>

<DEFINE PANEL> "check Status:GX"
<FORMAT> "Full"
The printer window shows the document currently printing and any documents waiting to 
print. 

<PANEL PROMPT> "Prompt Override: 41"
<END PANEL>

<DEFINE PANEL> "choose Doc:GX"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
In the printer window, click to select the document you want to work with.

<END PANEL>

<DEFINE PANEL> "choose Set Time:GX"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Choose Set Print Time from the Printing menu.

<COACH MARK> "Menu:MACS:Printing:Set Print Time"
<END PANEL>

<DEFINE PANEL> "set The Time:GX"



<FORMAT> "Tag"
Do This

<FORMAT> "Body"
To choose a print time, click At Time, then click a number in the time or the 
date. Type a new number, or click the arrows to increase or decrease the 
number.

To print the document as soon as possible, click Urgent.

To print the document after documents previously sent to print, click Normal.
<PANEL PROMPT> "Prompt Override: 42"

<END PANEL>

<DEFINE PANEL> "Print Time Tips:GX"
<FORMAT> "Full"
Documents are printed in this order:

1. Any document currently printing
2. Documents with Urgent priority
3. Documents set to print at or before the current time
4. Documents with Normal priority

<PANEL PROMPT> "Prompt Override: 4"
<END PANEL>

<DEFINE PANEL> "stop choice:GX"
<FORMAT> "Full"
You can stop printing in the following ways. What do you want to do? Click one:

<RADIO BUTTON> "temporarily stop a document from printing", true,,, ,APPLEGUIDE
<RADIO BUTTON> "permanently stop a document from printing", false,,, ,APPLEGUIDE
<RADIO BUTTON> "stop all documents waiting to print", false,,, ,APPLEGUIDE

<END PANEL>

<DEFINE PANEL> "hold Doc:GX"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Click Hold. 

<END PANEL>

<DEFINE PANEL> "remove Doc:GX"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Click Remove. 

<END PANEL>

<DEFINE PANEL> "stop Queue:GX"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"



Choose Stop Print Queue from the Printing menu.
<COACH MARK> "Menu:MACS:Printing:Stop Print Queue"



<END PANEL>

<DEFINE PANEL> "resume printing choice:GX"
<FORMAT> "Full"
You can resume printing a document that is currently on hold, or you can resume printing 
all documents at the selected printer. Which do you want to do? Click one:

<RADIO BUTTON> "resume printing a document that is on hold", true,,, ,APPLEGUIDE
<RADIO BUTTON> "resume printing of all documents at this printer", false,,, ,APPLEGUIDE

<END PANEL>

<DEFINE PANEL> "Click Resume:GX"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Click Resume. 

Then enter the page on which to resume printing, and click OK.
<END PANEL>

<DEFINE PANEL> "start Queue:GX"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Choose Start Print Queue from the Printing menu.

<COACH MARK> "Menu:MACS:Printing:Start Print Queue"
<END PANEL>

<DEFINE PANEL> "printerWindowTips1"
<FORMAT> "Full"
In the printer window, you can do the following:

Change the order of the print queue by dragging documents.

Change your view of the print queue by using the View menu (or by clicking the 
headings Document Name, Pages, Copies, Print Time, and Printed By).

Preview how a document will look when printed by double-clicking the document.

Change the priority and print time of a document by selecting it, then choosing Set Print 
Time from the Printing menu.

<END PANEL>

<DEFINE PANEL> "Print background: intro"
<FORMAT> "Full"
With a feature called  background printing, you can use your computer for other work 
while documents are printing.

<END PANEL>

#  Begin question: How do I print?



<DEFINE PANEL>  "choose printer:GX"
<FORMAT> "Full"
Before you can print, you need to tell your computer which printer to use (even if only 
one printer is connected). You do this by setting up a Desktop printer in the Chooser.

What kind of printer do you want to use? Click one:

<RADIO BUTTON> "printer on a network", true,,,,APPLEGUIDE
<RADIO BUTTON> "printer connected directly to the computer", false,,,,APPLEGUIDE

<On Panel Create> DoAppleScript(":Open AppleScripts:Null AS script")
<END PANEL>

<DEFINE PANEL> "Chooser:connect Via:GX"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
The Connect Via pop-up menu shows the most likely method of connection 
between your computer and the printer you chose. If necessary, choose a 
different type of connection from the menu.

Click Huh? for more information about connection methods.
<Dimmable Button Data> "Huh?","Connection info: Gx"

<END PANEL>

<DEFINE PANEL>  "Chooser: connection info GX"
<FORMAT> "Full"
You use AppleTalk to connect to most network printers, and serial with printers that are 
directly connected to your computer. 

Choose Servers to use a printer that is directly connected to another computer on your 
network. For you to use such a printer, the owner of the computer must decide to make 
the printer available by sharing it.

<END PANEL>

<DEFINE PANEL> "Chooser:click Create GX"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Click Create to make a desktop icon representing the printer you chose.

<COACH MARK> "CoachMark: 156"
<END PANEL>

<DEFINE PANEL> "printing:window, desktop, or file"
<FORMAT> "Full"
You can print a document, a list of the files in a window, or a list of the files on the 
desktop. Which do you want to do? Click one:
<RADIO BUTTON> "print a document", true,,, ,APPLEGUIDE
<RADIO BUTTON> "print a list of files in a window", false,,, ,APPLEGUIDE
<RADIO BUTTON> "print a list of files on the desktop", false,,, ,APPLEGUIDE

<END PANEL>



<DEFINE PANEL> "printing:drag document:GX"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Drag the document you want to print to a desktop printer.

For help creating a desktop printer, click Huh? below.
<Dimmable Button Data> "Huh?","How do I create a desktop printer?"

<END PANEL>

#Begin question: How do I preview how my document will print?

<DEFINE PANEL> "Print Preview intro:GX"
<FORMAT> "Full"
When a document is waiting to print on a desktop printer, you can preview the way it will 
look when printed.

You preview a document by opening it in the desktop printer window.
<On Panel Create> DoAppleScript(":Open AppleScripts:Null AS script")
<END PANEL>

<DEFINE PANEL> "Open Printer window"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Double-click your desktop printer icon to open the printer window.

<END PANEL>

<DEFINE PANEL> "Preview:open Document"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Double-click a document in the printer window to see a preview of how it will 
print.

<END PANEL>

<DEFINE PANEL> "Quickdraw GX not installed Placeholder"
<FORMAT> "Full"
To use this feature you need to have the QuickDraw GX software installed on your 
computer.

<PANEL PROMPT> "Prompt Override: 4"
<END PANEL>

<DEFINE PANEL> "HDI Share Printer - GX not installed"
<FORMAT> "Full"
A printer connected to an AppleTalk network can be shared by every computer connected 
to the same network. If you install QuickDraw GX software on your computer, you can 
share with other network users a printer directly connected to your computer. Some 
printers can also be shared by other means (for information, see the documentation that 
came with your printer).

<END PANEL>





#End GX Panels

# Panels for the sequence "How do I install or remove
#  printer software?"

<DEFINE PANEL> "printer drivers: intro"
<FORMAT> "Full"
Your computer needs printer software for each type of printer you use. Which do you 
want to do? Click one:

<RADIO BUTTON> "install printer software", true,,,,APPLEGUIDE
<RADIO BUTTON> "remove printer software", false,,,,APPLEGUIDE

<Dimmable Button Data> "Huh?","Definitions printer software"
<On Panel Create> DoAppleScript(":Open AppleScripts:Null AS script")
<END PANEL>

<DEFINE PANEL> "printer drivers: locate"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Locate the printer software you want to install.  It is usually a file with the 
same name as your printer. It comes with your computer or your printer.

If you can’t find the printer software, click Huh? below for instructions.
<Dimmable Button Data> "Huh?","Definitions Tips for finding items"

<END PANEL>

<DEFINE PANEL> "Printer driver: drag to icon"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Drag the printer software to the System Folder icon — not the System Folder 
window. If a message appears, read it and then click OK.

After you’ve installed the printer software, you need to connect your printer 
and tell the computer what kind of printer you’re using. (This is called 
choosing a printer.)

If you wish to choose a printer, click Huh? below for instructions.
<Dimmable Button Data> "Huh?","How do I switch printers?"

<END PANEL>

<DEFINE PANEL> "Extensions: opening"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Open the Extensions folder inside the System Folder.

<COACH MARK> "Finder Coach Extensions"
<Dimmable Button Data> "Huh?","How do I open an Item?"
<END PANEL>

<DEFINE PANEL> "Extensions: remove drivers"



<FORMAT> "Tag"
Do This

<FORMAT> "Body"
Select the files with the names of printers that you’re not using, and drag them 
out of the Extensions folder. (Be sure to save copies of the files.)

<END PANEL>

# Panels for the sequence "How do I install or remove fonts?"

<DEFINE PANEL> "fonts: intro"
<FORMAT> "Full"
Fonts are in the Fonts folder inside the System Folder of your startup disk. A selection of 
fonts comes with your computer.

Which do you want to do? Click one:
<RADIO BUTTON> "install a font", true,,, ,APPLEGUIDE
<RADIO BUTTON> "remove a font", false,,, ,APPLEGUIDE

<Dimmable Button Data> "Huh?","Definitions font"
<On Panel Create> DoAppleScript(":Open AppleScripts:Null AS script")
<END PANEL>

<DEFINE PANEL> "fonts: locate"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Locate the font you want to install.

If you can’t find the font, click Huh? below for instructions.
<Dimmable Button Data> "Huh?","Definitions Tips for finding items"

<END PANEL>

<DEFINE PANEL> "Fonts folder: opening"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Open the Fonts folder inside the System Folder.

The Fonts folder contains font files (individual fonts) and font suitcases (for 
font families). If you want to remove an individual font within a family, open 
the suitcase.

<COACH MARK> "Finder Coach Fonts"
<Dimmable Button Data> "Huh?","How do I open an Item?"
<END PANEL>

<DEFINE PANEL> "Fonts folder: remove font"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Drag the fonts you want to remove out of the Fonts folder.

<END PANEL>

# Panels for the sequence "How do I find out which fonts
#  are installed?"



<DEFINE PANEL> "fonts: available intro"



<FORMAT> "Full"
You can see which fonts are installed using the Key Caps program.

<Dimmable Button Data> "Huh?","Definitions font"
<On Panel Create> DoAppleScript(":Open AppleScripts:Null AS script")

<END PANEL>

<DEFINE PANEL> "Key Caps: open menu"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Open the Key Caps menu.

Every installed font is listed.

To see what a font looks like, choose it from the Key Caps menu.
<COACH MARK> "Menu:Key Caps:3:none"

<END PANEL>

# Panels for the sequence "How do I find out which
#  characters are in a font?"

<DEFINE PANEL> "Key Caps: intro"
<FORMAT> "Full"
You can open the Key Caps program to see the characters available in each font that’s 
installed.

<Dimmable Button Data> "Huh?","Definitions font"
<On Panel Create> DoAppleScript(":Open AppleScripts:Null AS script")

<END PANEL>

<DEFINE PANEL> "Key Caps: choose font"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Open the Key Caps menu and choose the font whose characters you want to 
see.

Press Shift, Option, or Shift and Option together to see additional characters.
<COACH MARK> "Menu:Key Caps:3:none"

<END PANEL>

# Panels for the sequence "How do I change the font used
#  in icon names?"

<DEFINE PANEL> "font: file names intro"



<FORMAT> "Full"
You can change the font used in icon names and in disk and folder windows.

You use the Views control panel to choose a new font.
<On Panel Create> DoAppleScript(":Open AppleScripts:Null AS script")
<END PANEL>

# Panels for the sequence  How do I connect to a network?"

<DEFINE PANEL> "network connect: outro"
<FORMAT> "Full"
You have prepared the system software for connection to a network. 

You can use shared printers and shared disks. You can also share your files with others.

For instructions on using network services, see the items listed for “network” in the 
Topics section of Macintosh Guide.

<PANEL PROMPT> "Standard Prompts"
<END PANEL>

# Panels for the sequence  How do I gain access to shared files?"

<DEFINE PANEL> "gain access: intro"
<FORMAT> "Full"
You can connect to shared disks on the network and use files on them.

<PANEL PROMPT> "Standard Prompts"
<Dimmable Button Data> "Huh?","Definitions shared disk"

<END PANEL>

<DEFINE PANEL> "gain access: intro.2"
<FORMAT> "Full"
Before you can connect to a shared disk, you need the following information:

• the AppleTalk zone (if any) for the computer that has
   the disk
• the name of the computer
• the name of the shared disk
• your name and password (if you’re a registered user)

If you are not a registered user, make sure that the shared disk allows guest access.
<PANEL PROMPT> "Standard Prompts"

<END PANEL>



<DEFINE PANEL> "Connect box: guest or user"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Click Guest or Registered User. (If the Guest button is dimmed, guest access 
is not
allowed.)

If you’re a registered user, make sure your name is correct, and type your 
password.

Click OK.

If your information is not accepted, click OK and type it again. (Make sure 
you used the correct capitalization and spelling.)

<END PANEL>

<DEFINE PANEL> "Connect box: click shared disk"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Click the shared disk that you want to use.  (You don’t have access to dimmed 
items.)

If you want to connect to the disk automatically whenever you turn on your 
computer, click the box next to the shared disk to put an X in it.

Click OK.
<END PANEL>

<DEFINE PANEL> "gain access: outro"
<FORMAT> "Full"
The shared disk icon should now appear on your desktop.

Depending on your access privileges, you can copy files, create folders, and use items on 
the shared disk as if they were on your hard disk.

<PANEL PROMPT> "Prompt Override: 24"
<END PANEL>

<DEFINE PANEL> "gain access: tip"
<FORMAT> "Tag"

Tip

<FORMAT> "Body"
If you want quick access to this shared disk, you can create an alias for the 
shared disk. When you want to connect to the shared disk, you can open the 
alias (and verify your name and password, if you’re a registered user).

For instructions on creating an alias, click Huh? below.
<PANEL PROMPT> "Standard Prompts"
<Dimmable Button Data> "Huh?","How do I make an item easy to find?"



<END PANEL>

# Panels for the sequence "How do I give others access to my files?"

<DEFINE PANEL> "allow access: intro"
<FORMAT> "Full"
You can share your files with other people on a network. Allowing access to your files is 
called file sharing. It involves three steps:

1. You select the disk or folder you want to share.
2. You decide which people to share it with.
3. You set access privileges for those people.

<Dimmable Button Data> "Huh?","Definitions access privileges"
<On Panel Create> DoAppleScript(":Open AppleScripts:Null AS script")

<END PANEL>

<DEFINE PANEL> "allow access: intro 2"
<FORMAT> "Full"
The files you share can be on your computer or on a shared disk on another computer.

Where are the files you want to share? Click one:
<RADIO BUTTON> "on my computer", true,,, ,APPLEGUIDE
<RADIO BUTTON> "on a shared disk", false,,, ,APPLEGUIDE

<Dimmable Button Data> "Huh?","Definitions shared disk"
<END PANEL>

<DEFINE PANEL> "Sharing: who can share"
<FORMAT> "Full"
Now you need to choose the people you want to share with. You can share with registered 
users or groups, with everyone, or both.

<PANEL PROMPT> "Standard Prompts"
<END PANEL>

# Panels for the sequence   "How do I register or remove
#  users and groups?"

<DEFINE PANEL> "register: intro"
<FORMAT> "Full"
You register users and groups in the Users & Groups control panel. You can also 
temporarily deny access to a registered user, or remove registered users and groups from 
your computer.

What do you want to do? Click one:
<RADIO BUTTON> "register a user or group", true,,,,APPLEGUIDE
<RADIO BUTTON> "remove a user or group", false,,, ,APPLEGUIDE
<RADIO BUTTON> "deny access to a user", false,,,,APPLEGUIDE

<Dimmable Button Data> "Huh?","Definitions registered user or group"
<On Panel Create> DoAppleScript(":Open AppleScripts:Null AS script")
<END PANEL>



<DEFINE PANEL> "register: segue"
<FORMAT> "Full"
To register a user, you name the user and (if you want) give the user a password.

To register a group, you assign users to that group.
<PANEL PROMPT> "Standard Prompts"

<END PANEL>

<DEFINE PANEL> "new user: type name"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
For each user you want to register:

Open the File menu and choose New User. Then type the name of the new 
user.

<COACH MARK> "Menu:Front:File:New User"
<END PANEL>

<DEFINE PANEL> "user: type password"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
For each user you want to assign a password:

Open the user icon. In the “User Password” box, type the password. 

Close the New User window and click Save to save the password.

Be sure to tell each user what the password is, including capitalization.
<PANEL PROMPT> "Prompt Override: 34"

<END PANEL>

<DEFINE PANEL> "File: New Group"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Open the File menu and choose New Group.

<COACH MARK> "Menu:Front:File:New Group"
<END PANEL>

<DEFINE PANEL> "new group: type name"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Type the name of the new group.

<END PANEL>

<DEFINE PANEL> "group: drag members"



<FORMAT> "Tag"
Do This

<FORMAT> "Body"
Drag the icons of registered users to the group window.

<END PANEL>

<DEFINE PANEL> "deny: segue"
<FORMAT> "Full"
Denying access to a user prevents him or her from connecting to your computer. (If 
you’ve turned on guest access, the user can connect as a guest.)

If you deny access to a user who is connected to your computer, he or she is disconnected 
immediately.

If you want to set a delay before the user is disconnected, or if you want to disconnect a 
user temporarily (without denying future access), click Huh? below.

<PANEL PROMPT> "Standard Prompts"
<Dimmable Button Data> "Huh?","How do I know who’s sharing my disks or files?"

<END PANEL>

<DEFINE PANEL> "user: click deny"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Open a registered user icon. Then click the box labeled “Allow user to 
connect” to remove the X.

<END PANEL>

<DEFINE PANEL> "remove: segue"
<FORMAT> "Full"
When you remove a user or group from your list of registered users and groups, you can 
no longer give that user or group special access to a shared item.

<PANEL PROMPT> "Standard Prompts"
<END PANEL>

# Panels for the sequence "How do I set access privileges?"

<DEFINE PANEL> "access privileges: intro"



<FORMAT> "Full"
When you share an item, you can decide what kind of access others can have to the item. 
This is called
“setting access privileges.”

Access privileges are set by the owner of a shared item and by the owner of the computer 
that the shared item is stored on.

If you own both the item and the computer, you can set any access privileges you wish. 
(The steps that follow cover access privileges for items on your own computer. Setting 
access privileges on another computer is the same, except that you don’t have to turn on 
file sharing first.)

<On Panel Create> DoAppleScript(":Open AppleScripts:Null AS script")
<END PANEL>

<DEFINE PANEL> "Shared item: click item"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Click a shared item (a folder or a disk) to select it.

<Dimmable Button Data> "Huh?","Definitions access privileges"
<END PANEL>

<DEFINE PANEL> "access privileges: segue"
<FORMAT> "Full"
You set access privileges by clicking boxes in the Sharing window.

See Folders and See Files let people see, open, and copy folders and files inside the 
shared folder or disk.

Make Changes lets people see, open, copy, delete, add, and change items inside the 
shared folder or disk.

For instructions on registering users and groups, click Huh? below.
<COACH MARK> "CoachMark: 116"
<PANEL PROMPT> "Standard Prompts"
<Dimmable Button Data> "Huh?","How do I register or remove users and groups?"

<END PANEL>

<DEFINE PANEL> "access privileges: everyone info"
<FORMAT> "Full"
Your name should appear as the owner.

If a user or group is listed, it is registered on the computer that the shared item is stored 
on.

“Everyone” is everyone else who has access to the network. Access privileges for 
Everyone take effect if the owner of the computer has turned on guest access.

For instructions on turning on guest access, click Huh? below.
<PANEL PROMPT> "Standard Prompts"



<Dimmable Button Data> "Huh?","How do I turn on guest access?"
<END PANEL>

<DEFINE PANEL> "access privileges: basic"
<FORMAT> "Full"
You give access privileges by clicking boxes. An X in a box means that a privilege is in 
effect.

For example, if you want only yourself and a specific user or group to have access to a 
shared item, click the boxes so that Xs appear only in the boxes next to Owner and 
User/Group.

The next steps show you how to set a shared item to work like a drop box or like a 
bulletin board.

<PANEL PROMPT> "Standard Prompts"
<END PANEL>

<DEFINE PANEL> "access privileges: drop box"
<FORMAT> "Full"
A drop box is like a mailbox. Anyone can put items into it (make changes to it), but only 
you (the owner) can see the contents. To set up a drop box, click the boxes so that they 
look like this:

<PICT> 1036, Center
<END PANEL>

<DEFINE PANEL> "access privileges: bulletin board"
<FORMAT> "Full"
On a bulletin board, anyone can open and copy items, but only you (the owner) can add, 
delete, or change items. To set up a bulletin board, click the boxes so that they look like 
this:

<PICT> 1038, Center
<END PANEL>

# Panels for the sequence "How do I check my access
#  privileges?"

<DEFINE PANEL> "get access: intro"
<FORMAT> "Full"
Your access privileges to a shared item are set by the owner of the item and the owner of 
the shared disk.

<Dimmable Button Data> "Huh?","Definitions access privileges"
<END PANEL>

<DEFINE PANEL> "get access: connect"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Connect to the shared disk that contains the item.

For instructions on connecting to a shared disk, click Huh? below.
<Dimmable Button Data> "Huh?","How do I gain access to shared files?"

<END PANEL>

<DEFINE PANEL> "Shared folder: check privileges"



<FORMAT> "Tag"
Do This

<FORMAT> "Body"
Click the folder or disk to select it. If the item isn’t a folder, click the folder 
that contains the item.

<END PANEL>

<DEFINE PANEL> "Sharing: check access"
<FORMAT> "Full"
The access privileges you have are listed below your name. (If you connected to the 
shared disk as part of a group, the group’s name and privileges are shown.)

(If you own the computer on which the shared item is located, you won’t see the list of 
privileges. Instead, you see the set of boxes in which you can change privileges.)

• See Folders means you can see, open, and copy folders.
• See Files means you can see, open, and copy folders and files. 
• Make Changes means you can see, open, copy, delete, add, and change items.

<PANEL PROMPT> "Standard Prompts"
<END PANEL>

<DEFINE PANEL> "Check access: window icons"
<FORMAT> "Full"
Your access privileges to a shared folder are also indicated by an icon under the close box 
of the folder’s window.

<PICT> 1034, Center
<PANEL PROMPT> "Prompt Override: 4"

<END PANEL>

# Panels for the sequence "How do I change my password?"

<DEFINE PANEL> "password: intro"
<FORMAT> "Full"
There are two kinds of passwords:  the password you use when you connect to another 
computer (as a registered user), and the password you use when you connect to your own 
computer (as the owner).

Which password do you want to change? Click one:
<RADIO BUTTON> "registered user", true,,, ,APPLEGUIDE
<RADIO BUTTON> "computer owner", false,,, ,APPLEGUIDE

<On Panel Create> DoAppleScript(":Open AppleScripts:Null AS script")
<END PANEL>

<DEFINE PANEL> "password: user segue"



<FORMAT> "Full"
To change your password as a registered user, you follow the same procedure as when 
you’re connecting to the shared disk on which you’re a registered user.

Make sure you know the name and password that the owner of the shared disk assigned 
to you. If you don’t type your name and password correctly, you won’t be able to change 
your password or connect to the shared disk.

<PANEL PROMPT> "Standard Prompts"
<END PANEL>

<DEFINE PANEL> "Connect: click password"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Click Set Password.

If a message says that you cannot change your password, the owner of the 
shared disk has not allowed you to change it.

<END PANEL>

<DEFINE PANEL> "Password: type current then new"
<FORMAT> "Tag"

Do This

Do This

Do This

<FORMAT> "Body"
Type your current password. Then press the Tab key and type your new 
password. The characters you type show up as bullets (•) to protect the privacy 
of your passwords.

Remember your new password exactly, including capitalization.

Click OK.  When a message appears, click OK again.

Type your new password a second time, then click OK.
<END PANEL>

<DEFINE PANEL> "password: owner segue"
<FORMAT> "Full"
You change your password as the owner of your computer by using the Sharing Setup 
control panel.

You use this password to gain access to your computer from another computer on the 
network.

<PANEL PROMPT> "Standard Prompts"
<END PANEL>



<DEFINE PANEL> "Sharing: type new password"



<FORMAT> "Tag"
Do This

<FORMAT> "Body"
Click the box labeled “Owner Password,” type your new password, and press 
the Return key. The password is replaced by bullets (•) after you press Return, 
to protect its privacy.

Remember your password exactly, including capitalization.
<END PANEL>

<DEFINE PANEL> "password: unsuccessful"
<FORMAT> "Full"
If your name and old and new passwords were recognized, you see a list of the shared 
items for which you have privileges.

If you see a message that your password is incorrect or the user name is unknown, you 
made a typing error or you are not a registered user for that shared disk.

<PANEL PROMPT> "Standard Prompts"
<END PANEL>

# Panels for the sequence "How do I quickly connect to a
#  shared disk?"

<DEFINE PANEL> "shared disk: auto choice"
<FORMAT> "Full"
You can create a quick connection to a shared disk in these ways.

Which type of quick connection do you want to use?  Click one:
<RADIO BUTTON> "connect quickly using an alias", true,,, ,APPLEGUIDE
<RADIO BUTTON> "connect automatically at startup", false,,, ,APPLEGUIDE
<RADIO BUTTON> "reconnect automatically after disconnect or sleep", false,,, ,APPLEGUIDE
<Dimmable Button Data> "Huh?","Definitions alias"

<On Panel Create> DoAppleScript(":Open AppleScripts:Null AS script")
<END PANEL>

<DEFINE PANEL> "shared disk: auto connect"
<FORMAT> "Full"
When you connect to a shared disk, you can click a box to specify that you want to 
connect to that disk each time you start up the computer.

Click Huh? below to get instructions for connecting to a shared disk.
<PANEL PROMPT> "Prompt Override: 28"
<Dimmable Button Data> "Huh?","How do I gain access to shared files?"

<END PANEL>

<DEFINE PANEL> "shared disk: alias connect"



<FORMAT> "Tag"
Do This

<FORMAT> "Body"
Connect to a shared disk. Then click the disk icon to select it.

Click Huh? below if you need instructions on connecting to a shared disk.
<Dimmable Button Data> "Huh?","How do I gain access to shared files?"

<END PANEL>

<DEFINE PANEL> "shared disk: alias open"
<FORMAT> "Full"

The next time you want to connect to that disk, you just open the alias.

If you’re a registered user, you’ll be asked to enter your password.

For instructions on connecting to a shared disk, click Huh? below.
<Dimmable Button Data> "Huh?","How do I gain access to shared files?"
<PANEL PROMPT> "Prompt Override: 24"

<END PANEL>

<DEFINE PANEL> "shared disk: auto remount"
<FORMAT> "Full"
You can reconnect automatically to a shared disk if the connection has been broken or the 
computer has been in Sleep mode.

You use the AutoRemounter control panel to set up automatic reconnection.
<Dimmable Button Data> "Huh?","Definitions sleep"

<END PANEL>

<DEFINE PANEL> "AutoRemounter: segue to install"
<FORMAT> "Full"
The software you need, AutoRemounter control panel, is not installed. You need to install 
this software before you can complete this task.

<PANEL PROMPT> "Standard Prompts"
<END PANEL>

<DEFINE PANEL> "AutoRemounter: locate"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Locate the AutoRemounter control panel. It’s part of the system software that 
came with your computer.

If you can’t find the control panel, click Huh? below for instructions.
<Dimmable Button Data> "Huh?","Definitions Tips for finding items"

<END PANEL>

<DEFINE PANEL> "AutoRemounter: open"



<FORMAT> "Tag"
Do This

<FORMAT> "Body"
Open the AutoRemounter control panel.

<COACH MARK> "Finder Coach AutoRemounter"
<END PANEL>

<DEFINE PANEL> "AutoRemounter: options"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Click the options you want for automatic reconnection to a shared disk.

Your changes take effect when you close the control panel.
<Dimmable Button Data> "Huh?","How do I open an Item?"

<END PANEL>

# Panels for the sequence "How do I disconnect from a shared disk?"

<DEFINE PANEL> "disconnect: shared disk"
<FORMAT> "Full"
You disconnect from a shared disk the same way you eject a floppy disk.

Before you disconnect, close any files and quit any programs you’ve opened on the 
shared disk.

<END PANEL>

<DEFINE PANEL> "Shared disk: click item"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Click a shared disk to select it.

<END PANEL>

<DEFINE PANEL> "disconnect: shared disk options"
<FORMAT> "Tag"

Tip

<FORMAT> "Body"
You can also disconnect from a shared disk by dragging its icon to the Trash, 
or by restarting or shutting down your computer.

<PANEL PROMPT> "Standard Prompts"
<END PANEL>

# Panels for the sequence "How do I make a shared folder or
# disk private?"

<DEFINE PANEL> "Sharing: privacy intro"



<FORMAT> "Full"
You can restrict others’ access to any shared folder that you own, even if it is on a 
computer you don’t own.

If the shared folder or disk is on your own computer, you can stop sharing it. Or you can 
turn off file sharing, so that none of your files are shared.

What do you want to do? Click one:
<RADIO BUTTON> "restrict access to a shared item", true,,, ,APPLEGUIDE
<RADIO BUTTON> "stop sharing an item", false,,, ,APPLEGUIDE
<RADIO BUTTON> "turn off file sharing", false,,, ,APPLEGUIDE

<Dimmable Button Data> "Huh?","Definitions access privileges"
<On Panel Create> DoAppleScript(":Open AppleScripts:Null AS script")
<END PANEL>

<DEFINE PANEL> "restrict access: segue"
<FORMAT> "Full"
To restrict access to a shared folder or disk, you change the access privileges. (The folder 
or disk icon remains visible to others on the network.)

<PANEL PROMPT> "Standard Prompts"
<END PANEL>

<DEFINE PANEL> "Sharing: restrict access"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Click boxes so that only the boxes next to Owner have Xs in them.

No one else on the network can change the folder or disk or see inside it.

If you can’t click the boxes, that means you don’t own the folder, or the item 
isn’t shared. (The item is shared if the box labeled “Share this item and its 
contents” contains an X.)

<COACH MARK> "CoachMark: 116"
<END PANEL>

<DEFINE PANEL> "take back: segue"
<FORMAT> "Full"
You can stop sharing a folder or disk if it is on your own computer. The item will no 
longer be available to others on the network.

<PANEL PROMPT> "Standard Prompts"
<END PANEL>

<DEFINE PANEL> "Sharing: unshare"



<FORMAT> "Tag"
Do This

<FORMAT> "Body"
Click the box labeled “Share this item and its contents” to remove the X.

<COACH MARK> "CoachMark: 117"
<END PANEL>

<DEFINE PANEL> "Unsharing: close window"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Click the close box to close the window.

If you’ve made changes, a message asks you to confirm them.  Click Save if 
you want to save the changes.

If others on the network are using the disk or folder, you’ll see a second 
message, which tells you that they will be disconnected when you click OK.

<COACH MARK> "CoachMark: 109"
<END PANEL>

<DEFINE PANEL> "sharing turn off: segue"
<FORMAT> "Full"
You can turn off file sharing in the Sharing Setup control panel. After you turn off file 
sharing, your computer’s name does not appear in the Chooser, and no one can connect to 
it.

<PANEL PROMPT> "Standard Prompts"
<END PANEL>

<DEFINE PANEL> "Sharing Setup: turn off"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Click Stop under File Sharing.

In the box that appears, type the delay (in minutes) before file sharing is 
turned off. If you specify a delay, users who are connected to your computer 
are warned to save their work and disconnect.

Click OK.
<COACH MARK> "CoachMark: 100"

<END PANEL>

<DEFINE PANEL> "Any: close window"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Click the close box to close the window (if it is open).

If a message appears, read it and then click your choice.
<COACH MARK> "CoachMark: 109"

<END PANEL>



# Panels for the sequence "How do I give away a shared folder?"



<DEFINE PANEL> "Shared folder: giveaway intro"
<FORMAT> "Full"
You can give away ownership of any folder you own.

The new owner can restrict your access to the folder, so keep a copy of any files you 
need.

(The steps that follow cover shared items on your own computer. Giving away shared 
items on another computer is the same, except that you don’t have to turn on file sharing 
first.)

<PANEL PROMPT> "Standard Prompts"
<END PANEL>

<DEFINE PANEL> "Sharing: choose new owner"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Open the Owner menu and choose a user or group as the new owner.  If you 
see a box  instead of a menu, type the name of a user or group.

The name you type must  be registered by the new owner of the shared disk 
that the folder is stored on.

<COACH MARK> "CoachMark: 115"
<END PANEL>

# Panels for the sequence "How do I know who’s sharing
#  my disks or files?"

<DEFINE PANEL> "sharing monitor: intro"
<FORMAT> "Full"
The File Sharing Monitor control panel lists the users who are connected to your 
computer and lists the shared items on your computer.

You can also use this control panel to disconnect users temporarily.
<On Panel Create> DoAppleScript(":Open AppleScripts:Null AS script")
<END PANEL>

<DEFINE PANEL> "File Sharing Monitor: segue to install"
<FORMAT> "Full"
The software you need, File Sharing Monitor control panel, is not installed. You need to 
install this software before you can complete this task.

<PANEL PROMPT> "Standard Prompts"
<END PANEL>

<DEFINE PANEL> "File Sharing Monitor: locate"



<FORMAT> "Tag"
Do This

<FORMAT> "Body"
Locate the File Sharing Monitor control panel. It’s part of the system software 
that came with your computer.

If you can’t find the control panel, click Huh? below for instructions.
<Dimmable Button Data> "Huh?","Definitions Tips for finding items"

<END PANEL>

<DEFINE PANEL> "File Sharing Monitor: open"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Open the File Sharing Monitor control panel.

<COACH MARK> "Finder Coach File Sharing Monitor"
<Dimmable Button Data> "Huh?","How do I open an Item?"
<END PANEL>

<DEFINE PANEL> "File Sharing Monitor: look"
<FORMAT> "Full"
This area lists any users who are connected to your computer.

<COACH MARK> "CoachMark: 118"
<PANEL PROMPT> "Standard Prompts"

<END PANEL>

<DEFINE PANEL> "File Sharing Monitor: disconnect"
<FORMAT> "Tag"

Do This

Do This

<FORMAT> "Body"
To disconnect a user, click the user’s name and then click Disconnect.  Type 
the delay (in minutes) before the user is disconnected.

Click OK.

If you type a number other than 0, the user is warned before being 
disconnected. A message remains on your screen until time is up. You can 
switch to any open program and continue working. If you type 0, the user is 
disconnected immediately (without a chance to save his or her work).

<COACH MARK> "CoachMark: 118"
<END PANEL>

# Panels for the sequence "How do I connect to my computer
#  from another?"

<DEFINE PANEL> "self access: intro"



<FORMAT> "Full"
You can connect to your computer from another computer on the network. As the owner, 
you have access to all files on your computer.

Before you can connect from another computer, you need to set up file sharing on your 
computer.  Also, you must leave your computer turned on.

<On Panel Create> DoAppleScript(":Open AppleScripts:Null AS script")
<END PANEL>

<DEFINE PANEL> "owner icon: open"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Open the owner icon. (It’s outlined in bold.)

<END PANEL>

<DEFINE PANEL> "owner: click boxes"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Click the boxes under File Sharing so that Xs appear in all of them.

You are giving yourself (as owner) access to your computer from another 
computer on the network.

<END PANEL>

<DEFINE PANEL> "self access: leave it on"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Leave your computer on.

Your computer must be on for you to connect to it.
<END PANEL>

<DEFINE PANEL> "self access: remote connect"
<FORMAT> "Full"
To gain access to your computer from another computer on the network, use the Chooser 
to connect to your computer.

Click Registered User in the box that asks for your name and password.  Then enter your 
owner name and password (which you entered in the Sharing Setup control panel).

For instructions on connecting to your computer or another shared disk, click Huh? 
below.

<Dimmable Button Data> "Huh?","How do I gain access to shared files?"
<END PANEL>

# Panels for the sequence "How do I switch between types of networks?"

<DEFINE PANEL> "Network: intro"



<FORMAT> "Full"
All Macintosh computers have a built-in connector for the AppleTalk network system, 
and most can also connect to other types of networks as well. If your computer is 
equipped for two or more network connections, you use the Network control panel to 
switch between networks.

Follow the instructions that came with your network hardware and software to be sure 
that the computer is connected properly and the necessary software is installed for each 
type of network.

<PANEL PROMPT> "Standard Prompts"
<On Panel Create> DoAppleScript(":Open AppleScripts:Null AS script")
<END PANEL>

<DEFINE PANEL> "Network: segue to install"
<FORMAT> "Full"
The software you need, the Network control panel, is not installed. You need to install 
this software before you can complete this task.

<PANEL PROMPT> "Prompt Override: 8"
<END PANEL>

<DEFINE PANEL> "Network: locate"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Locate the Network control panel. It’s part of the system software that came 
with your computer.

If you can’t find the control panel, click Huh? below for instructions.
<Dimmable Button Data> "Huh?","Definitions Tips for finding items"

<END PANEL>

<DEFINE PANEL> "Network: open"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Open the Network control panel.

<COACH MARK> "Finder Coach Network"
<Dimmable Button Data> "Huh?","How do I open an Item?"
<END PANEL>

 <DEFINE PANEL> "Network: choose"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Click the icon of the network type you want to use. If a message appears, read 
it and click OK to switch networks.

<COACH MARK> "CoachMark: 143"
<END PANEL>

# Panels for the sequence "How do I allow program linking?"



<DEFINE PANEL> "program link: intro"
<FORMAT> "Full"
Some programs can communicate directly with each other over the network. (For more 
information, see the documentation that came with your programs.)

To allow others to link to programs on your computer, you need to turn on program 
linking in the Sharing Setup control panel.

<On Panel Create> DoAppleScript(":Open AppleScripts:Null AS script")
<END PANEL>

<DEFINE PANEL> "program link: click start"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Click Start under Program Linking.

If the button is labeled Stop, then program linking is already on.
<COACH MARK> "CoachMark: 101"

<END PANEL>

<DEFINE PANEL> "program link: click item"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Click the program that you want to share. Do not open the program.

<END PANEL>

<DEFINE PANEL> "program link: click box"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Click the box labeled “Allow remote program linking” so that an X appears in 
it.

If the box or its label is dimmed, then linking does not work with this 
program.

<END PANEL>

<DEFINE PANEL> "program link: segue 2"
<FORMAT> "Full"
To allow others to link to your programs, you use the Users & Groups control panel. (For 
instructions on registering users, click Huh? below.)

Who will be linking to your programs? Click one or both:
<CHECKBOX> "guests", false,,,,APPLEGUIDE
<CHECKBOX> "registered users", false,,, ,APPLEGUIDE
<Dimmable Button Data> "Huh?","How do I register or remove users and groups?"

<END PANEL>

<DEFINE PANEL> "guest link: segue"



<FORMAT> "Full"
The following steps show how to allow guests to link to your programs.

<PANEL PROMPT> "Standard Prompts"
<END PANEL>

<DEFINE PANEL> "Guest: allow linking"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Click the box under Program Linking so that an X appears in it.

<COACH MARK> "CoachMark: 111"
<END PANEL>

<DEFINE PANEL> "users link: segue"
<FORMAT> "Full"
The following steps show how to allow registered users to link to your programs.

<PANEL PROMPT> "Standard Prompts"
<END PANEL>

<DEFINE PANEL> "user: open icon"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Open a registered user icon.

For instructions on registering users, click Huh? below.
<Dimmable Button Data> "Huh?","How do I register or remove users and groups?"

<END PANEL>

<DEFINE PANEL> "user: allow linking"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Click the box under Program Linking so that an X appears in it.

You need to turn on program linking for each registered user individually. To 
do so, open each user icon, and click to place an X in the box under Program 
Linking.

<END PANEL>

# Panels for the sequence "How do I set the time and date?"

<DEFINE PANEL> "Date & Time: intro"
<FORMAT> "Full"
You set the time and date in the Date & Time control panel. You can also use the control 
panel to change how times and dates appear.

<On Panel Create> DoAppleScript(":Open AppleScripts:Null AS script")
<END PANEL>

<DEFINE PANEL> "Date & Time: click date"



<FORMAT> "Tag"
Do This

<FORMAT> "Body"
To set the day, month, or year, click a number in the current date, and then 
click the arrows that appear. (Or you can type a new number.�)

<COACH MARK> "CoachMark: 11"
<END PANEL>

<DEFINE PANEL> "Date & Time: click zone"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
To identify the time zone for your location, click the Set Time Zone button, 
choose a city that’s in the same time zone as your current location, then click 
OK.

Clicking to put an X in the box labeled Daylight Savings Time adjusts the 
time by an hour.

<COACH MARK> "CoachMark: 12-1"  
<END PANEL>

<DEFINE PANEL> "Date & Time: click time"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
To set the hour, minute, or second, click a number in the current time and then 
click the arrows that appear. (Or you can type a new number.�)

<COACH MARK> "CoachMark: 12"
<END PANEL>

<DEFINE PANEL> "Date & Time: saving"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
To save your date and time settings, click anywhere outside the date and time 
boxes, or close the control panel.

<END PANEL>

# Panels for the sequence "How do I change time and date formats?"

<DEFINE PANEL> "Date & Time: formats intro"
<FORMAT> "Full"
You change time and date formats in the Date & Time control panel. (You can also use 
the control panel to set the current time and date.)

What do you want to do? Click one or both:
<CHECKBOX> "change time format", false,,, ,APPLEGUIDE
<CHECKBOX> "change date format", false,,, ,APPLEGUIDE

<On Panel Create> DoAppleScript(":Open AppleScripts:Null AS script")
<END PANEL>

<DEFINE PANEL> "time format: segue"
<FORMAT> "Full"



The steps that follow describe how to change the time format.
<PANEL PROMPT> "Standard Prompts"



<END PANEL>

<DEFINE PANEL> "Date & Time: click time formats"
<FORMAT> "Tag"

Do This

Do This

Do This

<FORMAT> "Body"
Click the Time Formats button.

Open the Time Formats pop-up menu and choose a standard format, or create 
a custom format.

To create a custom format, choose the items and type the characters you want.

A sample of your format appears at the bottom of the window.

When you’re finished, click OK.
<COACH MARK> "Item:Date and Time CP:Time formats"

<END PANEL>

<DEFINE PANEL> "date format: segue"
<FORMAT> "Full"
The steps that follow describe how to change the date format.

<PANEL PROMPT> "Standard Prompts"
<END PANEL>

<DEFINE PANEL> "Date & Time: click date formats"
<FORMAT> "Tag"

Do This

Do This

Do This

<FORMAT> "Body"
Click the Date Formats button.

Open the Date Formats pop-up menu and choose a standard format, or create a 
custom format.



To create a custom format, choose the items and type the characters you want.

A sample of your format appears at the bottom of the window.

When you’re finished, click OK.
<COACH MARK> "CoachMark: 14"

<END PANEL>

# Panels for the sequence  "How do I change number and
# currency formats?"

<DEFINE PANEL> "Numbers: intro"
<FORMAT> "Full"
You use the Numbers control panel to change how numbers and currency are displayed.

<On Panel Create> DoAppleScript(":Open AppleScripts:Null AS script")



<END PANEL>

<DEFINE PANEL> "Numbers: segue to install"
<FORMAT> "Full"
The software you need, Numbers control panel, is not installed. You need to install this 
software before you can complete this task.

<PANEL PROMPT> "Standard Prompts"
<END PANEL>

<DEFINE PANEL> "Numbers: locate"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Locate the Numbers control panel. It’s part of the system software that came 
with your computer.

If you can’t find the control panel, click Huh? below for instructions.
<Dimmable Button Data> "Huh?","Definitions Tips for finding items"

<END PANEL>

<DEFINE PANEL> "Numbers: open"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Open the Numbers control panel.

<COACH MARK> "Finder Coach Numbers"
<Dimmable Button Data> "Huh?","How do I open an Item?"
<END PANEL>

<DEFINE PANEL> "Numbers: format"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Open the Number Format pop-up menu and choose a format, or create a 
custom format.

<COACH MARK> "CoachMark: 15"
<PANEL PROMPT> "Prompt Override: 14"

<END PANEL>

<DEFINE PANEL> "Numbers: custom format"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
To create a custom format, choose the items and type the characters you want.

A sample of your format appears at the bottom of the window.
<END PANEL>

# Panels for the sequence "How do I change how window
# items appear?"

<DEFINE PANEL> "Views: intro"



<FORMAT> "Full"
You use the View menu to change the way your files appear in windows. You can see  
your files as icons or in lists.

You use the Views control panel to choose the font used in windows, how icons are 
arranged in a window, and the types of information included in lists.

Which do you want to do? Click one:
<RADIO BUTTON> "use the View menu", true,,, ,APPLEGUIDE
<RADIO BUTTON> "use the Views control panel", false,,, ,APPLEGUIDE
<Dimmable Button Data> "Huh?","Definitions view"

<On Panel Create> DoAppleScript(":Open AppleScripts:Null AS script")
<END PANEL>

<DEFINE PANEL> "Finder window: make active"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Click a disk or folder window,  or open a disk or folder icon.

<END PANEL>

<DEFINE PANEL> "View: choose view"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Open the View menu and choose any view.

By Icon and By Small Icon shows your files as icons. The other views show 
your files in lists.

If you need instructions on choosing a menu item, click Huh? below.
<COACH MARK> "Menu:MACS:Views:none"
<Dimmable Button Data> "Huh?","Why can’t I choose a menu item?"

<END PANEL>

<DEFINE PANEL> "Views: list info"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Click the types of information you want to see in list views, and click the icon 
size you want in list views.

The types of information you select appear as items in the View menu.
<COACH MARK> "CoachMark: 57"

<END PANEL>

# Panels for the sequence "How do I change items in the
# Apple () menu?"

<DEFINE PANEL> "Apple menu: intro"



<FORMAT> "Full"
You can control what appears in the Apple () menu by dragging items in or out of the 
Apple Menu Items folder (inside the System Folder). You can also adjust the submenus 
that appear in the Apple menu.

Which do you want to do? Click one:
<RADIO BUTTON> "add an item", true,,, ,APPLEGUIDE
<RADIO BUTTON> "remove an item", false,,, ,APPLEGUIDE
<RADIO BUTTON> "adjust submenus in the Apple menu", false,,, ,APPLEGUIDE

<On Panel Create> DoAppleScript(":Open AppleScripts:Null AS script")
<END PANEL>

<DEFINE PANEL> "Apple menu folder: dragging into"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Locate the item that you want to appear in the Apple menu, and drag it to the 
Apple Menu Items folder.

The next time you open the Apple () menu, the item will be there.

If you can’t find the item you want, click Huh? below for instructions.
<COACH MARK> "Finder Coach Apple Menu Items"
<Dimmable Button Data> "Huh?","Definitions Tips for finding items"

<END PANEL>

<DEFINE PANEL> "Apple menu folder: opening"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Open the Apple Menu Items folder.

<COACH MARK> "Finder Coach Apple Menu Items"
<Dimmable Button Data> "Huh?","How do I open an Item?"
<END PANEL>

<DEFINE PANEL> "Apple menu folder: dragging out"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Drag the item out of the Apple Menu Items window.

The next time you open the Apple () menu, the item will not be there.
<END PANEL>

<DEFINE PANEL> "Apple menu: submenus intro"



<FORMAT> "Full"
You can turn off the submenus that appear in the Apple menu and change the number of 
items that appear in each folder containing recently used items. (The contents of these 
folders appear as submenus in the Apple menu.)

You use the Apple Menu Options control panel to make these changes.
<END PANEL>

<DEFINE PANEL> "Apple Menu Options: segue to install"
<FORMAT> "Full"
The software you need, Apple Menu Options control panel, is not installed. You need to 
install this software before you can complete this task.

<PANEL PROMPT> "Prompt Override: 8"
<END PANEL>

<DEFINE PANEL> "Apple Menu Options: locate"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Locate the Apple Menu Options control panel. It’s part of the system software 
that came with your computer.

If you can’t find the control panel, click Huh? below for instructions.
<Dimmable Button Data> "Huh?","Definitions Tips for finding items"

<END PANEL>

<DEFINE PANEL> "Apple Menu Options: open"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Open the Apple Menu Options control panel.

<COACH MARK> "Finder Coach Apple Menu Options"
<Dimmable Button Data> "Huh?","How do I open an Item?"

<END PANEL>

<DEFINE PANEL> "Apple Menu Options: choose options1"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Click Off to turn off submenus in the Apple menu. (Clicking On turns on 
submenus if they are off.)

<COACH MARK> "CoachMark: 157"
<END PANEL>

<DEFINE PANEL> "Apple Menu Options: choose options2"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Click to remove the X from the box labeled "Remember recently used items" 
to turn off submenus for recently used items. (When this box contains an X, 
submenus are displayed for items used recently.)

To change the number of items displayed in a submenu, select a number in the 
box for Documents, Applications, or Servers (shared disks) and type a new 



number.



<COACH MARK> "CoachMark: 158"
<END PANEL>

# Panels for the sequence   "How do I set my location?"

<DEFINE PANEL> "Map: intro"
<FORMAT> "Full"
You use the Map control panel to set your location. You can also find out the time 
difference and the distance between your location and cities around the world.

If you use Map to reset your location when you travel, the time is automatically reset to 
the local time.

<On Panel Create> DoAppleScript(":Open AppleScripts:Null AS script")
<END PANEL>

<DEFINE PANEL> "Map: segue to install"
<FORMAT> "Full"
The software you need, Map control panel, is not installed. You need to install this 
software before you can complete this task.

<PANEL PROMPT> "Prompt Override: 8"
<END PANEL>

<DEFINE PANEL> "Map: locate"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Locate the Map control panel. It’s part of the system software that came with 
your computer.

If you can’t find the control panel, click Huh? below for instructions.
<Dimmable Button Data> "Huh?","Definitions Tips for finding items"

<END PANEL>

<DEFINE PANEL> "Map: open"
<FORMAT> "Tag"

Do This

Tip

<FORMAT> "Body"
Open the Map control panel.

To magnify the map (showing less of the world at a larger scale), hold down 
the Option key while you open the Map.

<COACH MARK> "Finder Coach Map"
<Dimmable Button Data> "Huh?","How do I open an Item?"
<END PANEL>

<DEFINE PANEL> "Map: type location"



<FORMAT> "Tag"
Do This

<FORMAT> "Body"
Type the name of the major city nearest your current location and then click 
the Find button (or press the Return key).

If you hear a beep, it means Map did not find the city you entered. If so, click 
the map at your approximate location.

<COACH MARK> "CoachMark: 85"
<END PANEL>

<DEFINE PANEL> "Map: click set"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Click the Set button to confirm your location.

<COACH MARK> "CoachMark: 86"
<PANEL PROMPT> "Prompt Override: 30"

<END PANEL>

<DEFINE PANEL> "Map: option segue"
<FORMAT> "Full"
After you set your location, you can use Map to find out the time difference and the 
distance of another location. You can also add or remove cities.

What do you want to do? Click one:
<RADIO BUTTON> "compare time and distance", true,,, ,APPLEGUIDE
<RADIO BUTTON> "add a location", false,,, ,APPLEGUIDE
<RADIO BUTTON> "remove a location", false,,, ,APPLEGUIDE

<END PANEL>

<DEFINE PANEL> "Map: find location"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
To find the time difference and distance of another city, type its name and 
click Find. (You can also enter the coordinates of a location and click Find.)

<COACH MARK> "CoachMark: 85"
<END PANEL>

<DEFINE PANEL> "Map: compare locations"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Click Time Zone to see the time difference.

The distance and the local time appear at the bottom of the window. (Clicking 
the distance abbreviation at the lower-left corner displays the distance in a 
different scale.)

<COACH MARK> "CoachMark: 87"
<END PANEL>

<DEFINE PANEL> "Map: click location"



<FORMAT> "Tag"
Do This

<FORMAT> "Body"
To add a city, click its location on the map.

If you magnified the map (by pressing Option when you opened it), you can 
scroll by dragging beyond the map’s edges.

<COACH MARK> "CoachMark: 88"
<END PANEL>

<DEFINE PANEL> "Map: type name"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Type the name of the city you want to add.

If you know the city’s coordinates and time zone, type them in the boxes at the 
bottom of the window.

<COACH MARK> "CoachMark: 85"
<END PANEL>

<DEFINE PANEL> "Map: click add"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Click Add City.

If the city is already in the Map, the button is dimmed.
<COACH MARK> "CoachMark: 89"

<END PANEL>

<DEFINE PANEL> "Map: find to remove"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
To remove a city, type its name and click Find.

If you hear a beep, it means the city isn’t in Map.
<COACH MARK> "CoachMark: 85"

<END PANEL>

<DEFINE PANEL> "Map: click remove"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Click Remove City.

<COACH MARK> "CoachMark: 90"
<END PANEL>

# Panels for the sequence  "How do I change the labels in the
# Label menu?"

<DEFINE PANEL> "Label menu: changing intro"
<FORMAT> "Full"



You use the Labels control panel to change the labels and colors that appear in the Label 
menu.

<On Panel Create> DoAppleScript(":Open AppleScripts:Null AS script")
<END PANEL>

<DEFINE PANEL> "Label: selecting"



<FORMAT> "Tag"
Do This

<FORMAT> "Body"
Drag to select the text of the label you want to change and then type the new 
label.

<COACH MARK> "CoachMark: 25"
<END PANEL>

<DEFINE PANEL> "Label: change labels outro"
<FORMAT> "Tag"

Tip

<FORMAT> "Body"
You can also change the colors in the Label menu.  For instructions, click 
Huh? below.

<PANEL PROMPT> "Prompt Override: 16"
<Dimmable Button Data> "Huh?","How do I change the colors in the Label menu?"

<END PANEL>

# Panels for the sequence   "How do I adjust the mouse or trackball?"

<DEFINE PANEL> "Mouse operation: adjusting choice"
<FORMAT> "Full"
You can change two mouse or trackball settings:  tracking (how far the pointer moves 
when you move the mouse or trackball), and double-click speed.

(If you have another device to move the pointer on the screen, such as a trackpad, look 
for a separate control panel that adjusts the device.)

Which do you want to adjust? Click one or both:
<CHECKBOX> "tracking", false,,,,APPLEGUIDE
<CHECKBOX> "double-click speed", false,,, ,APPLEGUIDE

<On Panel Create> DoAppleScript(":Open AppleScripts:Null AS script")
<END PANEL>

<DEFINE PANEL> "Mouse: segue to install"
<FORMAT> "Full"
The software you need, Mouse control panel, is not installed. You need to install this 
software before you can complete this task.

<PANEL PROMPT> "Prompt Override: 8"
<END PANEL>

<DEFINE PANEL> "Mouse: locate"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Locate the Mouse control panel. It’s part of the system software that came 
with your computer.

If you can’t find the control panel, click Huh? below for instructions.
<Dimmable Button Data> "Huh?","Definitions Tips for finding items"

<END PANEL>



<DEFINE PANEL> "Mouse tracking: choose option"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Click the tracking option you want.

Use the Very Slow option if you have a graphics tablet, or if you need careful 
control of the pointer.

<COACH MARK> "Window:MACS:Mouse:Rect:Tracking"
<END PANEL>

<DEFINE PANEL> "Double-click speed: choose option"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Click the double-click speed you want.

<COACH MARK> "Window:MACS:Mouse:Rect:Double-click"
<END PANEL>

# Panels for the sequence "How do I adjust the way the
# keyboard works?"

<DEFINE PANEL> "Keyboard operation: choice"
<FORMAT> "Full"
You can make several adjustments to the way the keyboard works. What would you like 
to do? Click one or more:

<CHECKBOX> "adjust the repeat rate or delay before repeat", false,,,,APPLEGUIDE
<CHECKBOX> "make keyboard commands easier to type", false,,,,APPLEGUIDE
<CHECKBOX> "set the keyboard to ignore accidental keystrokes", false,,,,APPLEGUIDE
<CHECKBOX> "control the pointer with the keyboard", false,,,,APPLEGUIDE

<On Panel Create> DoAppleScript(":Open AppleScripts:Null AS script")
<END PANEL>

<DEFINE PANEL> "Repeat rate: choosing"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
To adjust the rate at which a key repeats when it is held down, click the button 
for the rate you want.

<COACH MARK> "Wind:MACS:Keyboard:repeat rate"
<END PANEL>

<DEFINE PANEL> "Repeat delay: choosing"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
To adjust the delay before a key starts repeating when it is held down, click 
the button for the delay you want. Or click Off to turn off key repeating.

<COACH MARK> "WIND:MACS:Keyboard:repeat delay"
<END PANEL>

<DEFINE PANEL> "checkbox: generic transition"
<FORMAT> "Full"
You’ve completed one of the items you checked.



(Instructions for another item may follow, if you checked two or more items.)
<PANEL PROMPT> "Checkbox Transition"



<END PANEL>

<DEFINE PANEL> "Sticky Keys: intro"
<FORMAT> "Full"
You can use Sticky Keys to type keyboard commands (such as †-S for the Save 
command) without pressing the keys at the same time.

When Sticky Keys is on, you give a keyboard command by pressing a modifier key (†, 
Option, Control, or Shift), then releasing it and pressing the key for the command you 
want.

You turn Sticky Keys on or off in the Easy Access control panel.
<PANEL PROMPT> "Prompt Override: 8"

<END PANEL>

<DEFINE PANEL> "Sticky Keys: on or off"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Click the appropriate button to turn Sticky Keys on or off.

You can also turn Sticky Keys on or off by pressing the Shift key five times 
(without moving the mouse or trackball).

<COACH MARK> "CoachMark: 8"
<END PANEL>

<DEFINE PANEL> "Sticky Keys: status icon"
<FORMAT> "Full"
When Sticky Keys is on, a symbol appears on the menu bar. It changes when you press or 
lock a modifier key.

You lock a modifier key by pressing it twice. When you lock a modifier key, you can type 
several keyboard commands in succession without pressing the modifier key each time.

You unlock a modifier key by pressing it once.
<COACH MARK> "CoachMark: 9"
<PANEL PROMPT> "Prompt Override: 25"

<END PANEL>

<DEFINE PANEL> "Slow Keys: intro"
<FORMAT> "Full"
You can use Slow Keys to set the keyboard to ignore accidental keystrokes. When Slow 
Keys is on, a keystroke is accepted only when the key is held down for a second or two.

You turn Slow Keys on or off in the Easy Access control panel.
<PANEL PROMPT> "Prompt Override: 8"

<END PANEL>

<DEFINE PANEL> "Slow Keys: on or off"



<FORMAT> "Tag"
Do This

<FORMAT> "Body"
Click the appropriate buttons to turn Slow Keys on or off, and to set the delay 
before the computer accepts a keystroke.

You can also turn Slow Keys on or off by holding down the Return key for 
about 10 seconds (until you hear a soft beep and, about 5 seconds later, an 
ascending or descending tone).

<COACH MARK> "CoachMark: 10"
<END PANEL>

# Panels for the sequence "How do I install or remove a
# keyboard layout?"

<DEFINE PANEL> "keyboard layout: install/remove choice"
<FORMAT> "Full"
Keyboard layouts for several languages or writing systems are included with some 
versions of system software. You can also purchase keyboard layouts or obtain them 
through user groups.

Which do you want to do? Click one:
<RADIO BUTTON> "install a keyboard layout", true,,, ,APPLEGUIDE
<RADIO BUTTON> "remove a keyboard layout", false,,, ,APPLEGUIDE

<Dimmable Button Data> "Huh?","Definitions keyboard layout"
<On Panel Create> DoAppleScript(":Open AppleScripts:Null AS script")
<END PANEL>

<DEFINE PANEL> "keyboard layout: locate"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Locate the keyboard layout you want to install.

If you can’t find the file, click Huh? below for instructions.
<Dimmable Button Data> "Huh?","Definitions Tips for finding items"

<END PANEL>

<DEFINE PANEL> "System file: opening"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Open the System file.

<COACH MARK> "Finder Coach System"
<Dimmable Button Data> "Huh?","How do I open an Item?"
<END PANEL>

<DEFINE PANEL> "System file: remove item"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Drag the item you want to remove out of the System file.



<END PANEL>



# Panels for the sequence  "How do I change the way text is
# displayed?"

<DEFINE PANEL> "Text format: intro"
<FORMAT> "Full"
Some versions of Macintosh system software include a Text control panel that you use to 
work with multiple languages or character sets.

You use the Text control panel to choose the rules, such as capitalization, sorting, and 
direction, that apply to text.

The Text control panel shows a list of scripts. (A script is a writing system. For example, 
the Roman script is the system used to display text in English, French, Italian, and other 
languages.)

<On Panel Create> DoAppleScript(":Open AppleScripts:Null AS script")
<END PANEL>

<DEFINE PANEL> "Text: segue to install"
<FORMAT> "Full"
The software you need, Text control panel, is not installed. You need to install this 
software before you can complete this task.

<PANEL PROMPT> "Standard Prompts"
<END PANEL>

<DEFINE PANEL> "Text: locate"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Locate the Text control panel.
It comes with some versions of system software.

If you can’t find the control panel, click Huh? below for instructions.
<Dimmable Button Data> "Huh?","Definitions Tips for finding items"

<END PANEL>

<DEFINE PANEL> "Text icon: opening"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Open the Text control panel.

<COACH MARK> "Finder Coach Text"
<Dimmable Button Data> "Huh?","How do I open an Item?"
<END PANEL>

<DEFINE PANEL> "Text format: choosing"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Choose the script you want from the Script pop-up menu.

<COACH MARK> "CoachMark: 144"
<END PANEL>



<DEFINE PANEL> "Text format: choosing 2"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Choose the option you want in the Behavior pop-up menu. (Display of text 
conforms to the standard method used in the country whose name you choose 
from this menu.)

<COACH MARK> "CoachMark: 145"
<END PANEL>

# Panels for the sequence  "How do I adjust insertion point blinking?"

<DEFINE PANEL> "Insertion point blinking: intro"
<FORMAT> "Full"
The blinking insertion point marks the place where text you type will appear. You can 
change the blinking rate in the General Controls panel.

<On Panel Create> DoAppleScript(":Open AppleScripts:Null AS script")
<END PANEL>

<DEFINE PANEL> "Blink rate: choosing"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Click the appropriate button to set the blinking rate.

<COACH MARK> "WIND:Rect:GeneralCP:InsertBlinking"
<END PANEL>

# Panels for the sequence   "How do I adjust menu item blinking?"

<DEFINE PANEL> "menu blinking: intro"
<FORMAT> "Full"
You use the General Controls panel to change the number of times a menu item blinks 
when it’s chosen.

<On Panel Create> DoAppleScript(":Open AppleScripts:Null AS script")
<END PANEL>

<DEFINE PANEL> "menu blinking: choosing"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Click a button to set the number of times a chosen menu item will blink.

<COACH MARK> "WIND:Rect:GeneralCP:MenuBlinking"
<END PANEL>

# Panels for the sequence   "How do I turn off the Empty Trash
# warning?"

<DEFINE PANEL> "Trash warning: intro"



<FORMAT> "Full"
To prevent you from deleting items by mistake, a warning appears when you open the 
Special menu and choose Empty Trash.

You can turn the warning off in the Trash’s Info window.
<END PANEL>

<DEFINE PANEL> "Trash warning: click Trash"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Click the Trash icon to select it.

<COACH MARK> "Finder Desktop Trash"
<END PANEL>

<DEFINE PANEL> "Trash warning: click X"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
To turn off the warning, click the “Warn before emptying” box to remove the 
X.

The warning is on when an X appears in the box.
<COACH MARK> "CoachMark: 47"

<END PANEL>

# Panels for the sequence  "How do I turn 32-bit addressing
# on or off?"

<DEFINE PANEL> "32-bit: intro"
<FORMAT> "Full"
Your computer can use more than 8 megabytes of random-access memory (RAM) when 
you turn on 32-bit addressing. You turn on 32-bit addressing in the Memory control 
panel.

Some older programs may not work properly when 32-bit addressing is on.
<On Panel Create> DoAppleScript(":Open AppleScripts:Null AS script")
<END PANEL>

<DEFINE PANEL> "32-bit: click buttons"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Click the appropriate button to turn 32-bit addressing on or off.

The Memory control panel doesn’t contain a section for 32-bit addressing in 
some Macintosh models. These computers cannot change the way they 
address memory.

Your new setting takes effect after you restart your computer.
<COACH MARK> "Item:Memory CP:32-bit addressing on"

<END PANEL>

# Panels for the sequence  "How do I group items in the Launcher?"



<DEFINE PANEL> "Launcher: grouping"
<FORMAT> "Full"
You can arrange items into groups in the Launcher by putting them into specially named 
folders. You create those folders in the Launcher Items folder, which is inside the System 
Folder.

<Dimmable Button Data> "Huh?","Definitions Launcher"
<On Panel Create> DoAppleScript(":Open AppleScripts:Null AS script")
<END PANEL>

<DEFINE PANEL> "File: New Folder"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Open the File menu and choose New Folder.

<COACH MARK> "Menu:MACS:File:New Folder",
<END PANEL>

<DEFINE PANEL> "Folder: name for Launcher"
<FORMAT> "Tag"

Do This

Do This

<FORMAT> "Body"
Type a name for the folder. Then click inside the folder’s name box, 
immediately before the first character in the name.

With the insertion point blinking at the beginning of the folder name, hold 
down the Option key and press the number 8.

The keyboard sequence Option-8 places a round dot, called a bullet, at the 
beginning of the name. This symbol makes the folder into a horizontal button 
in the Launcher.

<END PANEL>

<DEFINE PANEL> "Folder: add Launcher items "
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Create as many folders as you need (each with a bullet as the first character in 
the name), then put aliases of the items you want to group together into these 
folders.

For instructions on putting items in the Launcher, click Huh? below.
<PANEL PROMPT> "Prompt Override: 24"
<Dimmable Button Data> "Huh?","How do I add or remove an item in the Launcher?"

<END PANEL>

<DEFINE PANEL> "Launcher: folder tip"



<FORMAT> "Tag"
Tip

<FORMAT> "Body"
If you open the Launcher window (by choosing Control Panels from the Apple 
menu, then double-clicking the Launcher icon), you can see the folders 
displayed as horizontal buttons.

When you click a horizontal button, the Launcher displays the items you 
placed inside the folder with that name.

<PANEL PROMPT> "Prompt Override: 10",
<END PANEL>

# Panels for the question  "How do I adjust window 
# shrinking?"  

<DEFINE PANEL> "WindowShade: intro"
<FORMAT> "Full"
You use the WindowShade control panel to change the command that shrinks a window 
so that only the title bar shows. The same command expands a window when only the 
title bar is showing. (In either case, you double-click or triple-click the title bar to shrink 
or expand the window.)

You can also resize a window with the size box or the zoom box at the lower- or upper-
right corner. For information about other options for hiding or showing windows, click 
Huh? below.

<Dimmable Button Data> "Huh?","How do I hide or show windows?"
<PANEL PROMPT> "Standard Prompts"

<On Panel Create> DoAppleScript(":Open AppleScripts:Null AS script")
<END PANEL>

<DEFINE PANEL> "WindowShade: segue to install"
<FORMAT> "Full"
The software you need, WindowShade control panel, is not installed. You need to install 
this software before you can complete this task.

<PANEL PROMPT> "Prompt Override: 8"
<END PANEL>

<DEFINE PANEL> "WindowShade: locate"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Locate the WindowShade control panel. It’s part of the system software that 
came with your computer.

If you can’t find the control panel, click Huh? below for instructions.
<Dimmable Button Data> "Huh?","Definitions Tips for finding items"

<END PANEL>

<DEFINE PANEL> "WindowShade: open"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Open the WindowShade control panel.



<COACH MARK> "Finder Coach WindowShade"
<END PANEL>

<DEFINE PANEL> "WindowShade: choose options"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
In the top section of the control panel, click a button for the number of clicks 
to shrink or expand a window. (Clicking Off turns off this feature.)

To avoid inadvertently shrinking a window, click to put an X in one of the 
boxes for a modifier key. You must hold down that key while clicking to 
shrink or expand a window.

To hear a “zip” sound when a window shrinks or expands, click to put an X in 
the box labeled “Make sounds when using WindowShade.”

<PANEL PROMPT> "Prompt Override: 24"
<END PANEL>

<DEFINE PANEL> "WindowShade: zoom tip"
<FORMAT> "Full"
You can also use the zoom box at the upper-right corner of a window to shrink or expand 
the window. The zoom box expands the window to show its complete content (or to fill 
the screen) and shrinks the window to its most recent smaller size.

<PANEL PROMPT> "Prompt Override: 10"
<END PANEL>

# HDI manage extensions in the System Folder

<DEFINE PANEL> "Extensions Manager: intro choice"
<FORMAT> "Full"
Your computer’s system software includes a number of extensions (such as control panels 
and devices that appear in the Chooser). Occasionally extensions may conflict with one 
another, causing the computer to behave erratically.  Or you may want to turn off some 
extensions because they use a lot of memory.

You use the Extensions Manager control panel to determine which extensions are on or 
off when the computer starts up. You can establish sets of related extensions and switch 
them on or off as necessary.

<PANEL PROMPT> "Prompt Override: 6"
<Dimmable Button Data> "Huh?","Definitions system extension"

<On Panel Create> DoAppleScript(":Open AppleScripts:Null AS script")
<END PANEL>

<DEFINE PANEL> "Extensions Manager: segue to install"
<FORMAT> "Full"
The software you need, Extensions Manager control panel, is not installed. You need to 
install this software before you can complete this task.



<PANEL PROMPT> "Prompt Override: 8"
<END PANEL>

<DEFINE PANEL> "Extensions Manager: locate"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Locate the Extensions Manager control panel. It’s part of the system software 
that came with your computer.

If you can’t find the control panel, click Huh? below for instructions.
<Dimmable Button Data> "Huh?","Definitions Tips for finding items"

<END PANEL>

<DEFINE PANEL> "Extensions Manager: open"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Open the Extensions Manager control panel.

<COACH MARK> "Finder Coach Extensions Manager"
<Dimmable Button Data> "Huh?","How do I open an Item?"

<END PANEL>

<DEFINE PANEL> "Extensions Manager: choose options1"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Click a checked item in the list of extensions to turn it off. (Items with 
checkmarks are on.) Shift-click to turn off two or more checked items. 

If you want to turn all extensions off or on, choose All Off or All On from the 
Sets pop-up menu. If you want to use only the extensions that are part of the 
current system software, choose System 7.5 only.

To can changes you’ve made, click Undo.
<COACH MARK> "Extensions Manager:Sets"

<END PANEL>

<DEFINE PANEL> "Extensions Manager: choose options2"
<FORMAT> "Tag"

Do This

Do This

Do This

<FORMAT> "Body"
To create a set of extensions, first turn on the extensions you want to include. 

Next, open the Sets pop-up menu and choose Save Set.

Then type a name for the extension set and click OK.
<END PANEL>



<DEFINE PANEL> "Extensions Manager: choose options3"



<FORMAT> "Tag"
Do This

Do This

<FORMAT> "Body"
To remove a set of extensions, first open the Sets pop-up menu and choose 
Delete Set.

Next click the name of the set you want to delete from the list, then click 
Delete. 

You can’t delete some sets of extensions.

Your change takes effect the next time the computer starts up.
<END PANEL>

# Panels for the sequence "How do I change the highlight
# color or gray?"

<DEFINE PANEL> "Hilight color: trans"
<FORMAT> "Full"
You set the highlight color in the Color control panel.

If your monitor is currently displaying grays, the new highlight color will take effect 
when you set it to display 16 or more colors, using the Monitors control panel. (For 
instructions on setting your monitor to display colors, click Huh? below.)

<PANEL PROMPT> "Standard Prompts"
<Dimmable Button Data> "Huh?","How do I display colors or grays?"

<On Panel Create> DoAppleScript(":Open AppleScripts:Null AS script")
<END PANEL>

<DEFINE PANEL> "Hilight color: set colors to 16"
<FORMAT> "Full"
Before you can see the results of a change in highlight color, you must set your monitor 
to display at least 16 colors or grays (using the Monitors control panel). 

For instructions on setting the monitor to display colors or grays, click Huh? below.
<Dimmable Button Data> "Huh?","How do I display colors or grays?"

<END PANEL>

<DEFINE PANEL> "Highlight color: choosing"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Open the “Highlight color”  menu and choose a color. If you want to use a 
different color,  choose Other.

<COACH MARK> "CoachMark: 42"
<Dimmable Button Data> "Huh?","Definitions highlighting"

<END PANEL>

<DEFINE PANEL> "color choice: outro"
<FORMAT> "Full"
The color you’ve chosen remains in effect until you change it.



<END PANEL>

# Panels for the sequence  "How do I change the color of
# window borders?"

<DEFINE PANEL> "Coloring windows: intro"
<FORMAT> "Full"
You use the Color control panel to choose a color for window borders.

If your monitor is currently displaying shades of gray, the new window border color will 
take effect when you set it to display colors, using the Monitors control panel. (For 
instructions on setting your monitor to display colors, click Huh? below.)

<PANEL PROMPT> "Standard Prompts"
<Dimmable Button Data> "Huh?","How do I display colors or grays?"

<On Panel Create> DoAppleScript(":Open AppleScripts:Null AS script")
<END PANEL>

<DEFINE PANEL> "Window color: set colors to 16"
<FORMAT> "Full"
Before you can see the results of a change in colors, you must set your monitor to display 
at least 16 colors or grays (using the Monitors control panel). 

For instructions on setting the monitor to display colors or grays, click Huh? below.
<Dimmable Button Data> "Huh?","How do I display colors or grays?"

<END PANEL>

<DEFINE PANEL> "Window color: choosing"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Open the “Window color” menu and choose a color.

The color you’ve selected appears in the title bar of the active window.
<COACH MARK> "CoachMark: 46"

<END PANEL>

# Panels for the sequence "How do I change the color of an icon?"

<DEFINE PANEL> "Icons: coloring intro"
<FORMAT> "Full"
You can assign a color to an icon. You choose the color from the Label menu.

If your monitor is set to display fewer than 16 colors or grays, the colors don’t appear in 
the Label menu. (For instructions on setting the monitor to display colors, click Huh? 
below.)



<Dimmable Button Data> "Huh?","How do I display colors or grays?"
<END PANEL>

<DEFINE PANEL> "Icons: select for color"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Click the icon you want to assign a color to.

<END PANEL>

<DEFINE PANEL> "Label menu: choose color"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Open the Label menu and choose the color (and label) you want.

The label appears when items are displayed in a list view, such as View by 
Name or View by Label.

<COACH MARK> "Menu:MACS:Label:none"
<PANEL PROMPT> "Prompt Override: 19"
<Dimmable Button Data> "Huh?","Definitions list view"

<END PANEL>

# Panels for the sequence "How do I change the colors in the
# Label menu?"

<DEFINE PANEL> "Label menu: colors intro"
<FORMAT> "Full"
You can change the colors (and labels) that appear in the Label menu by using the Labels 
control panel.

If your monitor is set to display black and white, you need to display colors (using the 
Monitors control panel) before you can change the colors in the Label menu. For 
instructions on setting the monitor to display colors, click Huh? below.)

(You use the Label menu to assign colors and labels to icons.)
<Dimmable Button Data> "Huh?","How do I display colors or grays?"

<On Panel Create> DoAppleScript(":Open AppleScripts:Null AS script")
<END PANEL>

<DEFINE PANEL> "Label menu: set colors to 16"
<FORMAT> "Full"
Your monitor must be set to display at least 16 colors or grays (using the Monitors 
control panel) before you can change the colors in the Label menu.

For instructions on setting the monitor to display colors, click Huh? below.
<Dimmable Button Data> "Huh?","How do I display colors or grays?"

<END PANEL>

# Panels for the sequence "How do I adjust the speaker volume?"



<DEFINE PANEL> "Speaker volume: intro"
<FORMAT> "Full"
You can set the volume of your computer’s built-in speaker, or of speakers or other sound 
devices connected to your computer, in the Sound control panel. You also set the volume 
of the alert sound in this control panel.

Which do you want to change? Click one:

<RADIO BUTTON> "adjust the computer’s speaker volume", true,,, ,APPLEGUIDE
<RADIO BUTTON> "adjust the volume of an external sound device", 

false,,, ,APPLEGUIDE
<RADIO BUTTON> "adjust the volume of the alert sound (system beep)", 

false,,, ,APPLEGUIDE
<On Panel Create> DoAppleScript(":Open AppleScripts:Null AS script")
<END PANEL>

<DEFINE PANEL> "Sound: choose Alert Sounds"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Open the pop-up menu and choose Alert Sounds (if necessary).

<COACH MARK> "CoachMark: 130"
<END PANEL>

<DEFINE PANEL> "Speaker volume: setting"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Click the icon for the internal speaker (Built-in), then drag the slider to the 
volume level you want. (If Built-in is the only icon, you don’t have to click it 
before moving the slider.)

If a box labeled “Mute” appears with the Built-in icon, clicking to put an X in 
it mutes the sound from that device. (If the box is gray or the word “Mute” is 
dimmed, this option is not available.)

NOTE:  Changing the volume of the internal speaker does not change the 
volume of the alert sound.

<COACH MARK> "CoachMark: 132"
<END PANEL>

# [Branch for “adjust the volume of an external sound device”]

<DEFINE PANEL> "Sound: choose Volumes"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Open the pop-up menu and choose Volumes (if necessary).

<COACH MARK> "CoachMark: 130"



<END PANEL>

<DEFINE PANEL> "External volume: setting"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Click the icon for the external device you want to adjust, then drag the slider 
to the volume level you want.

If a box labeled “Mute” appears with the device icon, clicking to put an X in it 
mutes the sound from that device. (If the box is gray or the word “Mute” is 
dimmed, this feature is not available.)

<COACH MARK> "CoachMark: 132"
<END PANEL>

<DEFINE PANEL> "Alert volume: setting"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Drag the slider to the volume level you want.

If you set the volume to its lowest level, the menu bar flashes when the 
computer needs your attention.

NOTE:  Changing the volume of the alert sound does not change the volume 
of the internal speaker.

<COACH MARK> "CoachMark: 131"
<END PANEL>

# Panels for the sequence "How do I change the beep sound?"

<DEFINE PANEL> "Beep: intro"
<FORMAT> "Full"
You set the beep sound in the Sound control panel.

<Dimmable Button Data> "Huh?","Definitions beep"
<On Panel Create> DoAppleScript(":Open AppleScripts:Null AS script")
<END PANEL>

<DEFINE PANEL> "Beep: setting"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Click the name of the sound you want.

<COACH MARK> "CoachMark: 133"
<END PANEL>

# Panels for the sequence "How do I install or remove a sound?"

<DEFINE PANEL> "Sounds: intro"



<FORMAT> "Full"
You can install or remove sounds. Which do you want to do? Click one:

<RADIO BUTTON> "install a sound", true,,, ,APPLEGUIDE
<RADIO BUTTON> "remove a sound", false,,, ,APPLEGUIDE

<On Panel Create> DoAppleScript(":Open AppleScripts:Null AS script")
<END PANEL>

<DEFINE PANEL> "sounds: locate"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Locate the sound file that you want to install.

Some sounds are installed as part of your system software. You can get 
additional sounds from various sources. You can also record your own sounds.

For instructions on recording a sound, click Huh? below.
<Dimmable Button Data> "Huh?","How do I record a sound?"

<END PANEL>

<DEFINE PANEL> "Sound: click sound"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Click the sound you want to remove.

<COACH MARK> "CoachMark: 133"
<END PANEL>

<DEFINE PANEL> "Sound: click Remove"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Click the Remove button.  If a message appears, read it and then click OK.

<COACH MARK> "CoachMark: 134"
<END PANEL>

<DEFINE PANEL> "Sounds: remove outro"
<FORMAT> "Tag"

Tip

<FORMAT> "Body"
You can also remove a sound by opening the System file (in the System 
Folder) and dragging the sound out of the System Folder.

<PANEL PROMPT> "Prompt Override: 10"
<END PANEL>

# Panels for the sequence "How do I record a sound?"

<DEFINE PANEL> "Sounds: recording intro"



<FORMAT> "Full"
You use the Sound control panel to record a sound.

If your computer does not have a built-in microphone, you need to connect a microphone 
or other audio source to your computer’s sound input port.

<On Panel Create> DoAppleScript(":Open AppleScripts:Null AS script")
<END PANEL>

<DEFINE PANEL> "Sound: choose Sound In"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Open the pop-up menu and choose Sound In (if necessary).

<COACH MARK> "CoachMark: 130"
<END PANEL>

<DEFINE PANEL> "Sound devices: choosing"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Click the icon representing your microphone or other audio source.

If there is only one icon (Built-in), it is already selected, so you don’t have to 
click it.

<COACH MARK> "CoachMark: 135"
<END PANEL>

<DEFINE PANEL> "Sound devices: click Options"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Click the Options button.

If the Options button is dimmed, there are no choices to make for the sound 
source you selected.

<COACH MARK> "CoachMark: 136"
<END PANEL>

<DEFINE PANEL> "Sound input: click device"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Under “Input Source,” click the icon of the sound input device you want to 
use for recording. Make sure that there is not an X in the box labeled “Play-
Through.” Then click OK.

(On some Macintosh models, Play-Through cannot be turned off for one or 
more devices.)

(Skip this step if you could not use the Options button.)
<END PANEL>



<DEFINE PANEL> "Sound: choose Alert Sounds2"



<FORMAT> "Tag"
Do This

<FORMAT> "Body"
Open the pop-up menu and choose Alert Sounds.

<COACH MARK> "CoachMark: 130"
<END PANEL>

<DEFINE PANEL> "Sound devices: adding"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Click the Add button.

<COACH MARK> "CoachMark: 137"
<END PANEL>

<DEFINE PANEL> "Sounds: click record"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Get ready to record, then click the Record button.

Recording starts immediately. You have ten seconds to record.

Click Stop to stop recording. Click Play to hear what you recorded.
<END PANEL>

<DEFINE PANEL> "Sounds: saving"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Click Save to save the sound.

If you want to record again without saving, click Cancel.  Then click Add, 
prepare to record, and click the Record button when you are ready.

<END PANEL>

<DEFINE PANEL> "Sounds: naming"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Type a name for the sound, then click OK.

<END PANEL>

# Panels for the sequence "How do I play a CD audio disc
# repeatedly?"

#  [Branch for AppleCD Audio Player starts here.]

<DEFINE PANEL> "Apple menu: AppleCD Audio"



<FORMAT> "Tag"
Do This

<FORMAT> "Body"
Open the Apple () menu and choose AppleCD Audio Player.



<COACH MARK> "Menu:Front:Apple:AppleCD Audio"
<END PANEL>

<DEFINE PANEL> "AppleCD Audio: repeat choice"
<FORMAT> "Full"
With the program AppleCD Audio Player, you can set the disk to play repeatedly or 
program one or more tracks to repeat.

Which do you want to do?  Click one:

<RADIO BUTTON> "set the disc to play repeatedly" , false,,, ,APPLEGUIDE
<RADIO BUTTON> "program tracks to repeat", true,,, ,APPLEGUIDE

<On Panel Create> DoAppleScript(":Open AppleScripts:Null AS script")
<END PANEL>

<DEFINE PANEL> "AppleCD Audio: repeat disc"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Click the arrow button to set the disk to repeat after the last track ends.  (The 
button changes to a return arrow.)

Clicking the return arrow button sets the disc to play once and stop.
<COACH MARK> "CoachMark: 129",

<END PANEL>

<DEFINE PANEL> "AppleCD Audio: repeat tracks1"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Click the editing arrow ( the tiny down arrow beneath the Normal button) to 
set tracks to repeat in any combination you want.

<COACH MARK> "CoachMark: 127"
<END PANEL>

<DEFINE PANEL> "AppleCD Audio: repeat tracks2"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Drag a track to the playlist (on the right), then drag that track to the position 
immediately below it to repeat the track.

Continue building a playlist of repeated tracks until you have the combination 
you want. If necessary, you can enlarge the window to make more room on 
the playlist.

<COACH MARK> "CoachMark: 128"
<END PANEL>

# [End of AppleCD Audio Player branch]



# Panels for the sequence "How do I select tracks to play on an
# audio CD?"

<DEFINE PANEL> "AppleCD play list: intro"
<FORMAT> "Full"
You can create a play list for any CD audio disc using the AppleCD Audio Player.

<On Panel Create> DoAppleScript(":Open AppleScripts:Null AS script")
<END PANEL>

# [Branch for AppleCD Audio Player begins here.]

<DEFINE PANEL> "AppleCD Audio: program"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Click the Program button. (The bar above the button is lighted when it is 
selected.)

<COACH MARK> "CoachMark: 126"
<END PANEL>

<DEFINE PANEL> "AppleCD Audio: program tracks1"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Click the editing arrow (the tiny down arrow beneath the Normal button) to 
set tracks to play in any combination you want.

<COACH MARK> "CoachMark: 127"
<END PANEL>

<DEFINE PANEL> "AppleCD Audio: program tracks2"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Drag a track to the playlist (on the right), then drag the track again to the next 
position on the list to repeat the track.

Continue building a playlist of repeated tracks until you have the combination 
you want. If necessary, you can enlarge the window to make more room on 
the playlist.

<COACH MARK> "CoachMark: 128"
<END PANEL>

<DEFINE PANEL> "AppleCD Audio: use playlist"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Click the Play/Pause button to play the tracks on the playlist.  



Be sure that the Program button is selected when you want to use a playlist. 



<COACH MARK> "CoachMark: 125"
<END PANEL>

# [End of AppleCD Audio Player branch]

# Panels for the sequence "How do I use more than one monitor?"

<DEFINE PANEL> "Monitors: U Only Have 1"
<FORMAT> "Full"
You can connect additional monitors to your computer. The pointer can move from one 
screen to another.

For information on connecting another monitor, see your user’s guide or the guide that 
came with your monitor.

When your computer has more than one monitor connected, you can find information 
here on using the Monitors control panel to set up your monitors.

<PANEL PROMPT> "Prompt Override: 4"
<END PANEL>

<DEFINE PANEL> "Use two or more monitors: intro"
<FORMAT> "Full"
You use the Monitors control panel to set the positions of your monitors and to choose 
which monitor will display the menu bar.

<PANEL PROMPT> "Standard Prompts"
<On Panel Create> DoAppleScript(":Open AppleScripts:Null AS script")
<END PANEL>

<DEFINE PANEL> "Monitor numbers: checking"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Press and hold the Identify button to determine which icon corresponds to 
which monitor.

A large number appears on each screen, corresponding to the number of an 
icon in the control panel.

<COACH MARK> "CoachMark: 139"
<END PANEL>

<DEFINE PANEL> "Main monitor: positioning menu bar"
<FORMAT> "Tag"

Do This

Tip

<FORMAT> "Body"
Decide which monitor you want to display the menu bar, and drag the small 
menu bar to that icon.

You can also choose which monitor shows the Welcome to Macintosh 



message when you turn on your computer. Hold down the Option key and 
drag the Happy Mac icon to that monitor’s icon.



<COACH MARK> "CoachMark: 27"
<END PANEL>

<DEFINE PANEL> "Monitor icon: positioning"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Drag the monitor icons so that they correspond to the positions of your 
monitors. The pointer can cross from one screen to another where the icons 
touch.

<COACH MARK> "CoachMark: 27"
<END PANEL>

<DEFINE PANEL> "Any changes: after restart"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
If you want changes to take effect after the computer restarts, click the button 
labelled “Rearrange on Restart” at the lower-left corner of the control panel.  
(Changes will then take effect after you open the Special menu and choose 
Restart.)

If you want changes to take effect immediately, click the button labeled 
“Rearrange on Close.” (Your changes take effect when you close the control 
panel.)

<COACH MARK> "WIND:Monitors CP:close or restart"
<END PANEL>

<DEFINE PANEL> "Monitors: NoCanDo"
<FORMAT> "Full"
The Monitors control panel is designed for use only with some Macintosh models. This 
control panel does not work with your Macintosh.

For more information on control panels, click Huh? below.
<PANEL PROMPT> "Prompt Override: 8"
<Dimmable Button Data> "Huh?","Definitions Control panels and your Macintosh model"

<END PANEL>

# Panels for the sequence  "How do I magnify the screen image?"

<DEFINE PANEL> "CloseView: intro"
<FORMAT> "Full"
With the CloseView control panel, you can magnify the image on your screen up to 16 
times.

<On Panel Create> DoAppleScript(":Open AppleScripts:Null AS script")
<END PANEL>

<DEFINE PANEL> "CloseView: segue to install"
<FORMAT> "Full"
The software you need, CloseView control panel, is not installed. You need to install this 
software before you can complete this task.

<PANEL PROMPT> "Prompt Override: 8"
<END PANEL>



<DEFINE PANEL> "CloseView: locate"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Locate the CloseView control panel. It’s part of the system software that came 
with your computer.

You must use the Installer program to install the CloseView control panel.  
Click Huh? below for instructions on installing system software components.

<Dimmable Button Data> "Huh?","How do I install system software components?"
<END PANEL>

<DEFINE PANEL> "CloseView: open"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Open the CloseView control panel.

<COACH MARK> "Finder Coach CloseView"
<Dimmable Button Data> "Huh?","How do I open an Item?"
<END PANEL>

<DEFINE PANEL> "CloseView: turn on"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Click the On button to turn CloseView on.

When CloseView is on and magnification is off, a rectangle follows the 
pointer to indicate which area will be magnified.

<COACH MARK> "Item:CloseView CP:CloseView On"
<END PANEL>

<DEFINE PANEL> "CloseView: magnify"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Click the On button to turn magnification on.

When magnification is on, you drag the pointer to the edge of the screen to see 
another part of the desktop.

<COACH MARK> "Item:CloseView CP:Mag On"
<END PANEL>

<DEFINE PANEL> "CloseView: magnify up or down"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Click the up or down arrow to set the magnification level.

<COACH MARK> "Item:CloseView CP:Mag up/down"
<END PANEL>



# Panels for the sequence "How do I turn off the computer automatically?"

<DEFINE PANEL> "Save power: intro choice"



<FORMAT> "Full"
Some Macintosh models and some monitors can save energy by turning off automatically 
when not in use.

If your computer or monitor has this feature, you use a control panel to set or change the 
interval or time and day for the computer or monitor to turn off. (If you have a 
PowerBook, see the topic “Batteries & Power.”)

Which do you want to do? Click one:

<RADIO BUTTON> "set an interval before the computer turns off", true,,, ,APPLEGUIDE
<RADIO BUTTON> "set a time/day for the computer to turn off once", false,,, ,APPLEGUIDE
<RADIO BUTTON> "set a time /day for repeated turning off", false,,, ,APPLEGUIDE
<RADIO BUTTON> "set an interval for the monitor to turn off", false,,, ,APPLEGUIDE

<On Panel Create> DoAppleScript(":Open AppleScripts:Null AS script")
<END PANEL>

<DEFINE PANEL> "Energy Saver: open"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Open the CPU Energy Saver control panel.

<COACH MARK> "Finder Coach CPU Energy Saver"
<Dimmable Button Data> "Huh?","How do I open an Item?"
<END PANEL>

<DEFINE PANEL> "Auto Power: NA"
<FORMAT> "Full"
Your computer cannot be turned off or dimmed automatically.

<END PANEL>

<DEFINE PANEL> "Energy Saver: click On"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Click the On button to activate the control panel. (If the On button is 
highlighted, the control panel is already on.)

When the control panel is off, the computer will not be turned off 
automatically.

<COACH MARK> "Finder Coach Energy Saver On"
<END PANEL>

<DEFINE PANEL> "Energy Saver: CPU idle1"



<FORMAT> "Tag"
Do This

<FORMAT> "Body"
Click to place an X in the box labeled “Idle time.”

(Removing the X cancels automatic shutdown after the specified period of 
computer inactivity.)

<COACH MARK> "Finder Coach Energy Saver CPU idle"
<END PANEL>

<DEFINE PANEL> "Energy Saver: CPU idle2"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Drag the slider to indicate the amount of time the computer must be idle for 
automatic shutdown.

(The amount of time is indicated below the slider as you drag.)
<COACH MARK> "Finder Coach Energy Saver CPU slider"

<END PANEL>

<DEFINE PANEL> "Energy Saver: idle options1"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Click the Options button to indicate any exceptions to automatic shutdown.

<COACH MARK> "Finder Coach Energy Saver CPU idle Options"
<END PANEL>

<DEFINE PANEL> "Energy Saver: idle options2"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Click to place an X in the box for each condition you want to establish as an 
exception to automatic shutdown. Then click OK.

(Clicking the Use Default button restores the factory settings for these options. 
Removing the X from a box makes that option inactive.)

<END PANEL>

<DEFINE PANEL> "Energy Saver: idle options3"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Click to place an X in the box for each condition you want to be an exception 
to automatic shutdown.

(Clicking the Use Default button restores the factory settings for these options. 
Removing the X from a box turns off that option.)

<END PANEL>



<DEFINE PANEL> "Energy Saver: close"



<FORMAT> "Tag"
Do This

<FORMAT> "Body"
Click the close box.

Your changes take effect when you close the control panel.
<COACH MARK> "CoachMark: 109"

<END PANEL>

# [Branch for set time for CPU off once]

# Repeat panel "AutoPower: NA" here (from earlier in this 
# question)

# Repeat panel "Energy Saver: click On" here (from earlier 
# in this question)

<DEFINE PANEL> "Energy Saver: set time1"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Click to place an X in the box labeled “One Time.”

(Removing the X cancels automatic shutdown at a specified date and time.)
<COACH MARK> "Item:CPU Energy Saver:one time"

<END PANEL>

<DEFINE PANEL> "Energy Saver: set time2"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Click the part of the date and time you want to change. Then use the up or 
down arrow to adjust that value.

Repeat this process for each part of the date and time you want to change.
<COACH MARK> "Item:CPU Energy Saver:set time"

<END PANEL>

<DEFINE PANEL> "Energy Saver: time options1"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Click the Options button to indicate any exceptions to automatic shutdown.

<COACH MARK> "Item:CPU Energy Saver:set time options"
<END PANEL>

# Repeat panel "Energy Saver: idle options2" here (from 



# earlier in this question)   

<DEFINE PANEL> "Energy Saver: notify option"



<FORMAT> "Tag"
Do This

<FORMAT> "Body"
If you want the computer to alert you before automatic shutdown, click the 
box labeled “Notify” to place an X in it. Then type a number for the 
notification interval, and click OK.

(Removing the X cancels notification before automatic shutdown.)
<END PANEL>

# Repeat panel "Energy Saver: close" here (from 
# earlier in this question)   

# [Branch for set time for CPU off repeatedly]

# Repeat panel "AutoPower: NA" here (from earlier in this 
# question)

# Repeat panel "Energy Saver: click On" here (from earlier 
# in this question)

<DEFINE PANEL> "Energy Saver: repeat off1"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Click to place an X in the box labeled “Recurring.”

(Removing the X cancels automatic shutdown at a specified date and time.)
<COACH MARK> "Item:CPU Energy Saver:Recurring"

<END PANEL>

<DEFINE PANEL> "Energy Saver: repeat off2"
Do This

Do This

<FORMAT> "Body"
Click to place an X in the box for each day of the week that you want the 
computer to turn off automatically. 

Click the part of the time you want to change, and use the up or down arrow to 
adjust that value. 

<COACH MARK> "Item:CPU Energy Saver:set day"
<END PANEL>

# Repeat panel "Energy Saver: time options1" here (from 
# earlier in this question)   



# Repeat panel "Energy Saver: idle options2" here (from 
# earlier in this question)   



# Repeat panel "Energy Saver: notify option" here (from 
# earlier in this question)   

# Repeat panel "Energy Saver: close" here (from 
# earlier in this question)   

# [Branch for monitor dimming]

# Repeat panel "Energy Saver: click On" here (from 
# earlier in this question)   

# Repeat panel "Energy Saver: close" here (from 
# earlier in this question)   

<DEFINE PANEL> "Screen off: intro"
<FORMAT> "Full"
Some Macintosh computers are designed so that the screen can turn off automatically. 
You use the Screen control panel to specify a time interval after which the screen will be 
turned off.

<END PANEL>

<DEFINE PANEL> "Screen: NoCanDo"
<FORMAT> "Full"
The Screen control panel is designed for use only with some Macintosh models. It is not 
in the Control Panels folder on your computer, which probably means that this control 
panel does not work with your Macintosh.

If you aren’t sure whether you can use this control panel with your Macintosh, click Huh? 
below for more information.

<PANEL PROMPT> "Prompt Override: 8"
<Dimmable Button Data> "Huh?","Definitions Control panels and your Macintosh model"

<END PANEL>

<DEFINE PANEL> "Screen: open"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Open the Screen control panel.

<Dimmable Button Data> "Huh?","How do I open an Item?"
<END PANEL>

<DEFINE PANEL> "Screen: options1"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Click to place an X in the box labeled “Turn off built-in screen when idle for.”

<END PANEL>



<DEFINE PANEL> "Screen: options2"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Drag the slider to choose the number of minutes until the screen turns off.

Your setting takes effect immediately. 

When the screen has turned off, you turn it on by moving the mouse or 
pressing any letter or number key. The image appears after a few seconds.

IMPORTANT:  When the screen is off, the computer is still on. A light on the 
front of the computer indicates that the computer is on.

<END PANEL>

# Panels for the sequence "How do I use AppleScript?"

<DEFINE PANEL> "AppleScript: intro1"
<FORMAT> "Full"
AppleScript is a scripting language you can use to automate tasks and procedures on your 
computer. For example, you can create a script that makes backup copies of all the 
documents you modified in the last week.

You use a program called Script Editor to create and modify AppleScript scripts. Script 
Editor is located in the AppleScript folder, inside the Apple Extras folder provided with 
your system software.

<PANEL PROMPT> "Prompt Override: 37"
<Dimmable Button Data> "Huh?","Definitions Scripting Language"

<END PANEL>

<DEFINE PANEL> "AppleScript: intro2"
<FORMAT> "Full"
Folders named Automated Tasks and More Automated Tasks (in the AppleScript folder) 
contain a selection of scripts that demonstrate the power of scripting. You can use these 
scripts as they are or modify them to suit your needs. (Click Huh? below for more 
information about the tasks in Automated Tasks and More Automated Tasks.)

A brief guide to creating AppleScript scripts with the Script Editor is included in the 
AppleScript folder. You can read, print, and add to this guide with the SimpleText 
program (on your computer’s hard disk).

<PANEL PROMPT> "Prompt Override: 4"
<Dimmable Button Data> "Huh?","Definitions Useful scripts"

<END PANEL>



# Panels for the sequence "How do I create a script?"

<DEFINE PANEL> "scripting: intro"
<FORMAT> "Full"
You use the Script Editor program to create or modify an AppleScript script. Script Editor 
is in the AppleScript folder, inside the Apple Extras folder. 

To learn how to create working scripts, use the “AppleScript Guide” and study the scripts 
in the Automated Tasks and More Automated Tasks folders. The scripts include examples 
of tasks that can be automated, and they show the correct structure and syntax of the 
AppleScript language.

Additional AppleScript tools and documentation are available from Apple and other 
sources.

<Dimmable Button Data> "Huh?","Definitions AppleScript"
<END PANEL>

# Panels for the sequence "How do I automate a task?"

<DEFINE PANEL> "automate task: intro"
<FORMAT> "Full"
You can automate a task on the computer by creating an AppleScript script that performs 
the steps making up that task. For example, a script could automatically copy an item you 
select and put the copy where you specify.

The Macintosh system software includes some AppleScript scripts, which you use by 
opening the Apple menu, choosing Automated Tasks, and double-clicking the item you 
want. (These scripts and others are in the Automated Tasks and More Automated Tasks 
folders, in the AppleScript folder, inside the Apple Extras folder.)

Click Huh? below for more information about the tasks in Automated Tasks and More 
Automated Tasks.

<PANEL PROMPT> "Prompt Override: 4"
<Dimmable Button Data> "Huh?","Definitions Useful scripts"

<END PANEL>

# Panels For the Sequence "Why won’t the computer recognize
# my disk?"

<DEFINE PANEL> "troubleshooting: disk mount"



<FORMAT> "Full"
If the computer does not recognize a floppy disk, it may be a new disk. (Most new disks 
need to be initialized before the computer can use them.)

If the disk is an external SCSI hard disk, the disk may have the same ID number as 
another SCSI device. Check the ID number of each device and change one  if necessary.

If you know the disk has information on it, the disk may have a format for another kind 
of computer (such as DOS or Apple II), or the disk may be damaged.  If you don’t want 
the information on the disk, you can re-initialize it. (For instructions, click Huh? below.)

Which do you want to do? Click one:
<RADIO BUTTON> "use a DOS file", true,,,,APPLEGUIDE
<RADIO BUTTON> "use an Apple II file", false,,,,APPLEGUIDE
<RADIO BUTTON> "test and repair a disk", false,,, ,APPLEGUIDE

<Dimmable Button Data> "Huh?","How do I prepare a disk for use?"
<END PANEL>

# Panels For the Sequence "Why can’t I see the window I want?"

<DEFINE PANEL> "troubleshooting: windows"
<FORMAT> "Full"
If you can’t see a window, it may be hidden. Open the Application menu and choose the  
program that the window belongs to. That program’s windows will come to the front.

If you still can’t see the window, try moving or resizing windows that are in the way by 
dragging the title bar or size box.  You can also close other windows by clicking the close 
box for each window.

If you see only the title bar of a window, expand the window using the WindowShade 
command. (For more about displaying windows, click Huh? below.)

<Dimmable Button Data> "Huh?","How do I hide or show windows?"
<COACH MARK> "CoachMark: 31"

<END PANEL>

# Panels For the Sequence "Why can’t I type on the keyboard?"

<DEFINE PANEL> "troubleshooting: keyboard"



<FORMAT> "Full"
If nothing happens when you type, make sure that typing is allowed by the program 
you’re using, and make sure that there is an insertion point or selected text. (You can’t 
type in the Guide window, for example, except to enter text in the “Look For” box.)

If you still can’t type, your keyboard cable may be loose. Shut down your computer and 
check the cable connections to your keyboard and ADB port.

Do not disconnect and reconnect your keyboard, mouse, or other ADB device while the 
computer is on. You may damage your equipment.

<Dimmable Button Data> "Huh?","Definitions Apple Desktop Bus (ADB)"
<END PANEL>

# Panels For the Sequence "Why can’t I prepare a disk for use?"

<DEFINE PANEL> "initialize: troubleshooting"
<FORMAT> "Full"
If you can’t initialize or erase a disk, the disk may be locked, or it may be damaged. Or 
there may be a problem with the disk drive.

If you want to prepare a disk in DOS or Apple II (ProDOS) format but the format menu 
doesn’t include the choice you want, you may need to turn on the PC Exchange control 
panel.

Which do you want to do? Click one:
<RADIO BUTTON> "unlock a floppy disk", true,,, ,APPLEGUIDE
<RADIO BUTTON> "test and repair a disk", false,,, ,APPLEGUIDE
<RADIO BUTTON> "prepare a disk in DOS or Apple II format", false,,, ,APPLEGUIDE

<END PANEL>

# [Branch for radio button "prepare a disk in DOS or Apple II format" begins here]

<DEFINE PANEL> "PC Exchange: turn on"
<FORMAT> "Full"
When you see the dialog box for initializing or erasing a floppy disk but there are no 
choices for DOS or Apple II format, the PC Exchange control panel is turned off or not 
installed.

Check that PC Exchange is turned on (by choosing it from the submenu of control panels 
in the Apple menu). 

If PC Exchange is on and you still don’t see the format you want, the disk cannot be 
initialized in that format.

<END PANEL>



# Panels For the Sequence "Why can’t I eject a disk?"

<DEFINE PANEL> "eject: troubleshooting"
<FORMAT> "Full"
If you can’t eject a floppy disk by opening the File menu and choosing Put Away, make 
sure no files or programs on the disk are being used. Then try one of the following:

1. If the disk is in the internal disk drive,
   press † - Shift - 1. 

   If it’s in a second disk drive,
   press † - Shift - 2.

2. Hold down the button on the mouse, trackball, or 
   other device while you restart your computer.

3. Insert a straightened paper clip into the hole next to
   the disk drive opening. Push gently.

<END PANEL>

# Panels For the Sequence "Why can’t I open an alias?"

<DEFINE PANEL> "alias: troubleshooting"
<FORMAT> "Full"
If you can’t open an alias:

• You may have thrown away the original file.

• You may have moved the original file to another disk.

• You may have renamed the disk the original file is on.

• The original file may be on a shared disk on the
   network that is not available now.

<END PANEL>

<DEFINE PANEL> "alias: rebuid desktop"
<FORMAT> "Full"
If you still can’t open an alias, you can try rebuilding the desktop. This procedure often 
restores the connection between an alias and its original file.

For instructions on rebuilding the desktop, click Huh? below.
<Dimmable Button Data> "Huh?","How do I “rebuild the desktop”?"

<END PANEL>

# Panels For the Sequence "Why can’t I change the name of an
# icon?"

<DEFINE PANEL> "rename: troubleshooting"



<FORMAT> "Full"
If you can’t change the name of an icon, make sure that you click the name, not the icon 
itself. When the name is selected, a box appears around it.

If no box appears when you click the name, the name cannot be changed. The item may 
be locked, it may be a shared item, or the name may be set by system software.

To unlock a file, click its icon, open the File menu, and choose Get Info. Then click the 
Locked checkbox to remove the X.

<END PANEL>

# Panels For the Sequence "Why can’t I find an item?"

<DEFINE PANEL> "troubleshooting: find"
<FORMAT> "Full"
If you cannot locate an item using the Find command:

• You may have typed the name incorrectly.

• You may have chosen the wrong selection criteria.

• The item may be on a disk your computer is not using.

• You may have thrown away the item.

• The item may be inside the System file. (You need to
  open the System file to see its contents.)

For instructions on finding items, click Huh? below.
<Dimmable Button Data> "Huh?","How do I find a file or folder?"

<END PANEL>

# Panels For the Sequence "Why can’t I save an item on a disk?"

<DEFINE PANEL> "troubleshooting: save on disk"
<FORMAT> "Full"
If you can’t save on a disk, there may not be enough space on the disk, the disk may be 
locked, or the disk may be damaged.  If you are trying to save on a shared disk, you may 
not have the access privileges you need.  (For more about access privileges, click Huh? 
below.)

The message that appears when you try to save an item gives more information.

Which do you want to do? Click one:
<RADIO BUTTON> "unlock a floppy disk", false,,, ,APPLEGUIDE
<RADIO BUTTON> "test and repair a disk", false,,, ,APPLEGUIDE
<RADIO BUTTON> "throw away an item to create space on a disk", true,,,,APPLEGUIDE

<Dimmable Button Data> "Huh?","How do I check my access privileges?"



<END PANEL>

<DEFINE PANEL> "floppy: unlock tab"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Slide the tab on the back corner of the disk so that the square hole is closed. 
(Use your thumbnail or a push pin.)

<PICT> 1016, Center
<END PANEL>

# Panels For the Sequence "Why can’t I repair a disk?"

<DEFINE PANEL> "Repair disk: troubleshooting"
<FORMAT> "Full"
If Disk First Aid doesn’t correct a problem with your disk, or if Apple HD SC Setup 
reports a problem:

• Use Disk First Aid again. Repeating the process
  occasionally corrects the problem.

• Use another disk repair program. Some programs
  can recover information from a damaged disk.

• Consult a technician or other specialist for help.

• If nothing works, you’ll need to erase (reinitialize)
  the disk. If this doesn’t work, discard the floppy disk
  or take the hard disk to a service provider for repair.

<END PANEL>

# Panels For the Sequence "Why can’t I print?"

<DEFINE PANEL> "troubleshooting: printer on"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Make sure your printer is on and the cable connections are secure.

Verify that the printer cable is connected to the right port, with a cable 
designed for that printer and port. 

If you are using a computer with a combined printer/modem port, you may 
have to disconnect a modem before you can connect a printer.

<END PANEL>

<DEFINE PANEL> "troubleshooting: printer icons have X"



<FORMAT> "Full"
If all of your desktop printer icons are covered with large “X” marks, make sure that:

• The QuickDraw GX extension is in your extensions folder.

• Your computer started up using the System Folder that contains the QuickDraw GX 
extension.

• The QuickDraw GX extension is not turned off in the Extensions Manager control 
panel.

<END PANEL>

<DEFINE PANEL> "Troubleshooting: PowerBook printing"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
If you are using a PowerBook with a combined printer/modem port, you may 
have to disconnect your modem before you can connect a printer. 

If you have an Express Modem on a PowerBook, you may have to change a 
control panel setting. If your Express Modem is version 1.5 or later, be sure 
that “Use Express Modem” is selected in the Express Modem control panel. If 
the modem is an earlier version, be sure that “Internal” or “Normal” is 
selected in the PowerBook Setup control panel.

<END PANEL>

<DEFINE PANEL> "Troubleshooting: printer software"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Make sure that the necessary printer software is installed and that the 
computer recognizes the printer.

If you need information on these procedures, click Huh? below.
<Dimmable Button Data> "Huh?","How do I print?"

<END PANEL>

<DEFINE PANEL> "troubleshooting: ImageWriter"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Make sure that the Select light on your ImageWriter printer is on. If it isn’t, 
press the Select button to turn on the light.

<END PANEL>

<DEFINE PANEL> "troubleshooting: driver version"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Make sure you are using the same printer software as others on the network. 
Check the version number by selecting the icon for your printer in the 
Extensions folder (inside the System Folder), opening the File menu, and 
choosing Get Info.

<Dimmable Button Data> "Huh?","Definitions printer software"
<END PANEL>



<DEFINE PANEL> "troubleshooting: restart printer"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Turn the printer off and then on again. Wait a few minutes while it warms up.

Check the printer and its status lights to see if there is a printer problem (such 
as a paper jam).

If you still cannot print, ask your network administrator or service provider for 
help.

<END PANEL>

# Panels For the Sequence "Why can’t I print with the fonts I want?"

<DEFINE PANEL> "troubleshooting: fonts"
<FORMAT> "Full"
The fonts you want to use may not be installed on your computer.

For instructions on installing fonts, click Huh? below.
<Dimmable Button Data> "Huh?","How do I install or remove fonts?"

<END PANEL>

<DEFINE PANEL> "troubleshooting: fonts memory"
<FORMAT> "Full"
You may not have enough memory available to print your document. (Click Huh? below 
for information about making more memory available.)

The following instructions suggest ways you can work around this problem.
<Dimmable Button Data> "Huh?","How do I make more memory available?"

<END PANEL>

<DEFINE PANEL> "troubleshooting: fonts memory tip 1"
<FORMAT> "Tag"

Try This

<FORMAT> "Body"
Quit the program you’re using immediately after you click Print.

<END PANEL>

<DEFINE PANEL> "troubleshooting: fonts memory tip 2"
<FORMAT> "Tag"

Try This

<FORMAT> "Body"
Use fewer fonts and sizes in your document.

<END PANEL>

<DEFINE PANEL> "troubleshooting: fonts memory tip 3"
<FORMAT> "Tag"

Try This

<FORMAT> "Body"
Open the File menu and choose Page Setup. If Page Setup contains a box 
labeled “Font Substitution,” click to put an X in it. (When font substitution is 
on, the printer automatically uses available fonts.)



<COACH MARK> "Menu:MACS:File:Page Setup"
<END PANEL>

<DEFINE PANEL> "troubleshooting: fonts memory tip 4"
<FORMAT> "Full"
You can use the LaserWriter Utility or LaserWriter Font Utility, which is on a disk that 
came with your LaserWriter printer, to transfer fonts from your computer to the printer.

<END PANEL>

<DEFINE PANEL> "troubleshooting: fonts GX Type 1"
<FORMAT> "Full"
If the fonts you want to use are Type 1 PostScript fonts, they must be modified to be used 
with QuickDraw GX. 

Type 1 fonts that were in your Fonts folder were automatically modified when you 
installed QuickDraw GX.

To modify Type 1 fonts, you use the Type 1 Enabler application. The application is 
located on the disk or disks you used when you installed QuickDraw GX. See the 
QuickDraw GX Read Me document for more information.

<END PANEL>

# Panels For the Sequence "Why can’t I gain access to a
# shared disk?"

<DEFINE PANEL> "troubleshooting: shared disk intro"
<FORMAT> "Full"
Before you can connect to a shared disk, your computer must be on a network and must 
have the appropriate networking software.  In addition, AppleTalk needs to be active (in 
the Chooser) and your computer needs to be named (in the Sharing Setup control panel).

If you need information on these procedures, click Huh? below.
<Dimmable Button Data> "Huh?","How do I connect to a network?"

<END PANEL>

<DEFINE PANEL> "troubleshooting: shared disk segue"
<FORMAT> "Full"
If you can’t connect to a shared disk, check the following:

• Make sure that the computer you’re connecting to is turned on.

• If you are not a registered user on the other computer, make sure guest access is 
allowed.

• If you are registered, make sure you’re entering your name and password exactly as 
they are registered (including capitalization).

<END PANEL>

<DEFINE PANEL> "troubleshooting: shared disk outro"



<FORMAT> "Full"
Check with the owner of the computer or your network administrator for more 
information.

For example, the owner of the computer may have changed the name or password.
<PANEL PROMPT> "Prompt Override: 4"

<END PANEL>

# Panels For the Sequence "Why can’t I share my files on my
# computer?"

<DEFINE PANEL> "troubleshooting: sharing my Mac"
<FORMAT> "Full"
Before you can share your files, your computer must be on a network and must have the 
appropriate networking software.  In addition, AppleTalk needs to be active (in the 
Chooser) and your computer needs to be named (in the Sharing Setup control panel).

If you need information on these procedures, click Huh? below.
<PANEL PROMPT> "Prompt Override: 8"
<Dimmable Button Data> "Huh?","How do I connect to a network?"

<END PANEL>

<DEFINE PANEL> "Sharing software: segue to install"
<FORMAT> "Full"
Some of the software you need, either Sharing Setup control panel or Users & Groups 
control panel (or both), is not installed. You need to install this software before you can 
complete this task.

For instructions on installing file sharing software, click Huh? below.
<PANEL PROMPT> "Prompt Override: 8"
<Dimmable Button Data> "Huh?","How do I install file sharing software?"

<END PANEL>

# Panels For the Sequence "Why can’t I share my files on another
# computer?"

<DEFINE PANEL> "Sharing: checkbox info"
<FORMAT> "Full"
The privileges called See Folders and See Files let people see, open, and copy items 
inside the shared folder or disk.

The privilege called Make Changes lets people see, open, copy, delete, add, and change 
items inside the shared folder or disk.

<COACH MARK> "CoachMark: 106"
<PANEL PROMPT> "Standard Prompts"

<END PANEL>



# Panels For the Sequence "Why can’t I use my name and
# password?"

<DEFINE PANEL> "troubleshooting: password"
<FORMAT> "Full"
Make sure that you are registered on the computer you want to connect to.

Make sure that you enter your name and password
(including capitalization) exactly as they are listed on the other computer.

Check with the owner of the computer or your network administrator for more 
information.

<END PANEL>

# Panels For the Sequence "Why can’t I link to a program?"

<DEFINE PANEL> "troubleshooting: link intro"
<FORMAT> "Full"
If you can’t use program linking, make sure that the program supports linking. (See the 
documentation that came with the program.)

Before you can link programs, your computer must be on a network and must have the 
appropriate networking software.  In addition, AppleTalk needs to be active (in the 
Chooser) and your computer needs to be named (in the Sharing Setup control panel).

If you need information on these procedures, click Huh? below.
<Dimmable Button Data> "Huh?","How do I connect to a network?"

<END PANEL>

<DEFINE PANEL> "troubleshooting: link outro"
<FORMAT> "Full"
Make sure you have registered the users with whom you want to link programs or that 
you’ve turned on guest access, and that you have turned on program linking for each of 
those users in the Users & Groups control panel.

Also make sure that your registered users know the names and passwords (including 
capitalization) you gave them.

For information about these procedures, click Huh? below.
<Dimmable Button Data> "Huh?","How do I allow program linking?"

<END PANEL>

# Panels For the Sequence "Why can’t I display color on the screen?"

<DEFINE PANEL> "troubleshooting: color"



<FORMAT> "Full"
Make sure that you’re using a color or grayscale monitor and that colors or grays are 
turned on in the Monitors control panel.

For instructions on using the Monitors control panel, click Huh? below.
<Dimmable Button Data> "Huh?","How do I display colors or grays?"

<END PANEL>

# Panels For the Sequence "Why can’t I record a sound?"

<DEFINE PANEL> "troubleshooting: record"
<FORMAT> "Full"
If your computer does not have a built-in microphone, make sure a microphone or other 
audio source is connected to your computer. Make sure you have selected the device in 
the Sound control panel.

Some computers need special equipment and software for recording sounds.

For instructions on recording a sound, click Huh? below.
<Dimmable Button Data> "Huh?","How do I record a sound?"

<END PANEL>

# Panels For the Sequence "Why can’t I move the pointer on the screen?"

<DEFINE PANEL> "troubleshooting: pointer"
<FORMAT> "Full"
If you move the mouse, trackball, or other device but the pointer doesn’t move on the 
screen, the device may not be connected properly, or its signals may not be reaching the 
computer.

Shut down your computer and check that the mouse cable is connected securely. Do not 
disconnect or reconnect the mouse or trackball while the computer is on. You may 
damage your equipment.

If the mouse or trackball is connected properly, restarting the computer may resolve the 
problem.

Consult your user’s guide for additional suggestions.
<Dimmable Button Data> "Huh?","Definitions Apple Desktop Bus (ADB)"

<END PANEL>

# Panels For the Sequence "Why can’t I choose a menu item?"

<DEFINE PANEL> "gray menu: click item"



<FORMAT> "Full"
If nothing happens when you open a menu and choose an item, check whether the item is 
dimmed (gray or a pale color). Dimmed means the item is not available right now.

Many commands require you to select something first (an icon or text, for example). 
Make sure that you’ve selected the item you want.

<PANEL PROMPT> "Prompt Override: 4"
<END PANEL>

# Panels For the Sequence "Why did I get a memory warning?"

<DEFINE PANEL> "troubleshooting: memory"
<FORMAT> "Full"
There is not enough memory to open more programs and documents. For tips on making 
more memory available, click Huh? below.

<Dimmable Button Data> "Huh?","How do I make more memory available?"
<END PANEL>

# Panels for the question  "How do I change the resolution on a monitor?" 

<DEFINE PANEL> "Monitor change resolution: intro"
<FORMAT> "Full"
You can change the resolution of images on the monitor with some Macintosh models.

You use the Monitors control panel to change resolution of the screen’s image.
<END PANEL>

<DEFINE PANEL> "Monitor resolution: click Options"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Click the Options button.

(If Options is dimmed, your computer and monitor cannot make this change.)
<COACH MARK> "CoachMark: 40"

<END PANEL>

<DEFINE PANEL> "Monitor resolution: click resolution"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Click an item in the list under “Select a monitor setting” to change the 
resolution, then click OK.

(If you don’t see a list of monitor settings, you can’t change the monitor’s 
resolution.)

Your change takes effect immediately.
<END PANEL>



<DEFINE PANEL> "Monitor memory: intro"
<FORMAT> "Full"
On some Macintosh models, you can change the amount of memory used for images on a 
monitor.

You use the Monitors control panel to allocate memory for a monitor.
<END PANEL>

<DEFINE PANEL> "Monitor memory: click choice"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Click the button for the number of colors or grays you want to display, 
then click OK.

(If you don’t see a Memory Allocation section, you can’t change the memory 
used for a monitor.)

Your change takes effect after you restart the computer.
<END PANEL>

# Panels For the Sequence "How do I find out more about my
# computer?"

<DEFINE PANEL> "Computer: more info"
<FORMAT> "Full"
This program, Macintosh Guide, gives you step-by-step instructions for procedures you 
want to perform with your computer. The Guide menu (on the right, with the ? icon) may 
also include basic instructions, explanations of items on the screen (called balloons), and 
shortcuts.

Some application programs provide instructions in the Guide menu.

See the documentation that came with your computer for information about setting up 
equipment, expanding your system, and getting assistance if the computer is not working 
properly.

<PANEL PROMPT> "Prompt Override: 4"
<END PANEL>

# Panels for the Sequence "How do I get explanations of items on
# the screen?"

<DEFINE PANEL> "Balloons: intro"



<FORMAT> "Full"
Balloons display explanations of items on the screen.

You turn on balloons in the Guide menu (on the right with the ? icon).
<END PANEL>

<DEFINE PANEL> "Help menu: balloons"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Open the Guide menu and choose Show Balloons.

Then point at the item you want an explanation of. A text balloon should 
appear.

You turn off balloons by choosing Hide Balloons from the Guide menu.
<COACH MARK> "CoachMark: 60"

<END PANEL>

# Panels for the Sequence "How do I change the keyboard layout?"

<DEFINE PANEL> "keyboard layout: change choice"
<FORMAT> "Full"
If your system has a Keyboard menu, you use it to change from one layout to another and 
from one script to another.  The Keyboard menu shows the icon of a flag, to represent the 
language in use, or a diamond in the menu bar. (Click Huh? below to see a picture of the 
Keyboard menu.)

Which do you want to do? Click one:
<RADIO BUTTON> "change layout in the Keyboard control panel", true,,,,APPLEGUIDE
<RADIO BUTTON> "change layout in the Keyboard menu", false,,,,APPLEGUIDE

<Dimmable Button Data> "Huh?","Pics only Keyboard menu"
<On Panel Create> DoAppleScript(":Open AppleScripts:Null AS script")
<END PANEL>

<DEFINE PANEL> "Keyboard layout: choosing"



<FORMAT> "Tag"
Do This

<FORMAT> "Body"
To change keyboard layout, click the layout you want to use.

Keyboard layouts for other languages and writing systems are included with 
international versions of system software. Keyboard layouts such as Dvorak 
can also be purchased or obtained through user groups.

For instructions on making other adjustments to the way the keyboard works, 
click Huh? below.

<COACH MARK> "WIND:MACS:Keyboard:Layout"
<Dimmable Button Data> "Huh?","How do I adjust the way the keyboard works?"

<END PANEL>

<DEFINE PANEL> "Keyboard menu: open and choose"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Open the Keyboard menu (the one with a flag icon) and choose the layout you 
want to switch to.

Note:  Not all versions of system software include the Keyboard menu. If your 
system doesn’t have this menu, you use the Keyboard control panel to change 
layouts.

If the layout you want is not in the menu, then you must install that layout. For 
instructions, click Huh? below.

<PANEL PROMPT> "Prompt Override: 22"
<Dimmable Button Data> "Huh?","How do I install or remove a keyboard layout?"

<END PANEL>

<DEFINE PANEL> "Keyboard menu: tips"
<FORMAT> "Full"
You can use two keyboard commands to change layouts without opening the Keyboard 
menu.

Press †-Space bar to switch to the next script in the menu.

Press Option-†-Space bar to switch to the next choice within the script currently in use.
<PANEL PROMPT> "Prompt Override: 23"
<Dimmable Button Data> "Huh?","Definitions keyboard command"

<END PANEL>

# Panels for the Sequence "How do I copy a picture?"

<DEFINE PANEL> "Paint app: select picture"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
In a graphics program, select the picture (or part of a picture) you want to use.

<END PANEL>

<DEFINE PANEL> "Edit menu: choose Copy"



<FORMAT> "Tag"
Do This

<FORMAT> "Body"
Open the Edit menu and choose Copy.

<COACH MARK> "Menu:Front:Edit:Copy"
<Dimmable Button Data> "Huh?","Definitions Clipboard"

<END PANEL>

# Panels for the Sequence "How do I quit a program?"

<DEFINE PANEL> "any program: make active"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Make sure the program is active by choosing it from the Application menu (in 
the top-right corner of the screen).

<COACH MARK> "CoachMark: 31"
<END PANEL>

<DEFINE PANEL> "File menu: choose Quit"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Pull down the File menu and choose Quit.

<COACH MARK> "Menu:Front:File:Quit"
<END PANEL>

# Panels for the Sequence "How do I turn on guest access?"

<DEFINE PANEL> "guest access: segue"
<FORMAT> "Full"
If you want to give everyone on the network access to your files, you need to turn on 
guest access in the Users & Groups control panel.

<PANEL PROMPT> "Standard Prompts"
<On Panel Create> DoAppleScript(":Open AppleScripts:Null AS script")
<END PANEL>

<DEFINE PANEL> "Guest: allow connection"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Click the box under File Sharing so that an X appears in it.

<COACH MARK> "CoachMark: 110"
<END PANEL>

# Panels for the Sequence "Pics only Keyboard menu"

<DEFINE PANEL> "Keyboard menu: pic"
<FORMAT> "Full"

<PICT> 1002, Center



<PANEL PROMPT> "Prompt Override: 7"



<END PANEL>

# Panels for the sequence "How do I make an item easy to find?"

<DEFINE PANEL> "EZ access: intro"
<FORMAT> "Full"
There are several ways to make any item (such as a program, document, folder, or disk) 
easy to find and open. What do you want to do? Click one:

<RADIO BUTTON> "Make an alias for the item", true,,, ,APPLEGUIDE
<RADIO BUTTON> "Put the item or its alias in the Apple () menu", false,,,,APPLEGUIDE
<RADIO BUTTON> "Put the item or its alias on the desktop", false,,,,APPLEGUIDE
<RADIO BUTTON> "Put an alias for the item in the Launcher", false,,,,APPLEGUIDE
<Dimmable Button Data> "Huh?","Definitions alias"

<On Panel Create> DoAppleScript(":Open AppleScripts:Null AS script")
<END PANEL>

<DEFINE PANEL> "Any: select item"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Click the item to select it.

<END PANEL>

<DEFINE PANEL> "File: Make Alias"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Open the File menu and choose Make Alias.

If you need instructions on choosing a menu item, click Huh? below.
<COACH MARK> "Menu:MACS:File:Make Alias"
<Dimmable Button Data> "Huh?","Why can’t I choose a menu item?"

<END PANEL>

<DEFINE PANEL> "Alias: move alias"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Drag the alias where you want it.

When you open an alias, the original item actually opens. You can make as 
many aliases of an item as you want.

<END PANEL>

<DEFINE PANEL> "Startup disk: opening"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Open the startup disk.

<COACH MARK> "Finder Desktop BootDisk"
<Dimmable Button Data> "Huh?","Definitions startup disk"

<END PANEL>



<DEFINE PANEL> "EZ access: open Apple menu folder"



<FORMAT> "Tag"
Do This

<FORMAT> "Body"
Find the Apple Menu Items folder in the System Folder.

<COACH MARK> "Finder Coach Apple Menu Items"
<END PANEL>

<DEFINE PANEL> "EZ access: put item in folder"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Drag the item or its alias to the Apple Menu Items folder.

The next time you open the Apple () menu, the item will appear there. When 
you choose the item in the menu, the item opens.

<END PANEL>

<DEFINE PANEL> "EZ access: desktop"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Drag the item or its alias to the desktop.

<Dimmable Button Data> "Huh?","Definitions desktop"
<END PANEL>

<DEFINE PANEL> "Launcher: add item"
<FORMAT> "Full"
You can add an alias for an item to the Launcher, which lets you open the item simply by 
clicking the button that represents it.

<PANEL PROMPT> "Standard Prompts"
<Dimmable Button Data> "Huh?","Definitions Launcher"

<END PANEL>

# Panels for the sequence "How do I open an item automatically?"

<DEFINE PANEL> "Startup Items: intro"
<FORMAT> "Full"
You can have an item open automatically when you turn on your computer. You do this 
by putting an alias for the item in the Startup Items folder.

<Dimmable Button Data> "Huh?","Definitions alias"
<END PANEL>

<DEFINE PANEL> "Startup Items: click file for alias"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Find the item you want opened automatically. Click the item to select it.

<END PANEL>

<DEFINE PANEL> "Startup Items: find Startup Items"
<FORMAT> "Tag"

Do This



<FORMAT> "Body"
Find the Startup Items folder in the System Folder.



<COACH MARK> "Finder Coach Startup Items"
<END PANEL>

<DEFINE PANEL> "Startup Items: put alias in Startup"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Drag the alias you created to the Startup Items folder.

The next time you turn on your computer, the item represented by the alias 
will open automatically.

<END PANEL>

# Panels for the sequence "How do I change an icon?"

<DEFINE PANEL> "change icon: intro"
<FORMAT> "Tag"

Do This
<FORMAT> "Body"
You can replace some icons with another picture. (Some icons cannot be 
changed.)

First, use a graphics program to select and copy a small picture.

For instructions on copying a picture, click Huh? below.
<Dimmable Button Data> "Huh?","How do I copy a picture?"

<END PANEL>

<DEFINE PANEL> "Single icon: select"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Click the icon to select it.

<END PANEL>

<DEFINE PANEL> "Info: click icon"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Click the icon in the Info window.

<COACH MARK> "Window:Front:Icon in Info window"
<END PANEL>

<DEFINE PANEL> "Edit menu: choose Paste"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Open the Edit menu and choose Paste.



If Paste is dimmed, either the icon cannot be changed, or there is nothing in 
the Clipboard (part of the computer’s memory where a copied item is stored).  
Verify that you have copied an image, then try to Paste again.

If the picture you copied is larger than the icon (32 pixels square), it 
automatically shrinks to fit.

<COACH MARK> "Menu:Front:Edit:Paste"



<PANEL PROMPT> "Prompt Override: 19"
<Dimmable Button Data> "Huh?","Definitions pixel"

<END PANEL>

<DEFINE PANEL> "Change icon: copy tip"
<FORMAT> "Tag"

Tip

<FORMAT> "Body"
You can also copy and paste an icon. You select an icon, choose Get Info from 
the File menu, select the icon in the Info window, then choose Copy from the 
Edit menu.

To paste the icon, you open another icon’s Info window, select the icon in the 
window, and choose Paste.

<PANEL PROMPT> "Standard Prompts"
<END PANEL>

# Panels for the sequence "How do I use hard disk space as
#  memory?"

<DEFINE PANEL> "VM: noCanDo"
<FORMAT> "Full"
Some Macintosh models can use hard disk space as if it were random-access memory 
(RAM).  You can see if your computer has this feature by opening the Memory control 
panel and looking for a Virtual Memory section.

If you don’t see this section in the Memory control panel, your computer isn’t able to use 
hard disk space as memory. You may be able to upgrade your computer to use this 
feature. (See the specifications for your Macintosh model for more information about 
upgrading or adding memory.)

<PANEL PROMPT> "Standard Prompts"
<END PANEL>

<DEFINE PANEL> "VM: intro"
<FORMAT> "Full"
Hard disk space that is used as memory is called virtual memory. This disk space is not 
available for storing files.

For best performance, use virtual memory only when you need to open more programs 
than usual. Your computer should have enough RAM for your regular needs.

You turn virtual memory on or off in the Memory control panel. If you want to use more 
than 8 megabytes of memory, you should also turn on 32-bit addressing (in the Memory 
control panel, if it has a 32-Bit Addressing section).

<PANEL PROMPT> "Standard Prompts"
<Dimmable Button Data> "Huh?","Definitions 32-bit addressing"

<On Panel Create> DoAppleScript(":Open AppleScripts:Null AS script")



<END PANEL>

<DEFINE PANEL> "Memory: segue to install"
<FORMAT> "Full"
The software you need, the Memory control panel, is not installed. You need to install 
this software before you can complete this task.

<PANEL PROMPT> "Prompt Override: 8"
<END PANEL>

<DEFINE PANEL> "System Folder: locate"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Locate the System Folder on your startup disk. 
Do not open the folder.

<Dimmable Button Data> "Huh?","Definitions System Folder"
<COACH MARK> "Finder Coach System Folder"

<END PANEL>

<DEFINE PANEL> "Any resource: drag"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Drag the item to the System Folder icon (not the System Folder window). If a 
message appears, read it and then click OK.

IMPORTANT:  System software files are compressed on their original floppy 
disks or CD-ROM disc.  If you get the software item you need from its 
original disk or CD, you must use the Installer program to install that 
software.  (Dragging a compressed file to the System Folder will not install it 
correctly.)

Click Huh? below for instructions on installing system software components.
<Dimmable Button Data> "Huh?","How do I install system software components?"

<END PANEL>

<DEFINE PANEL> "Apple menu: choose control panels"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Open the Apple () menu and choose Control Panels.

<COACH MARK> "Menu:Front:Apple:Control Panels"
<END PANEL>

 <DEFINE PANEL> "VM: turn on"



<FORMAT> "Tag"
Do This

<FORMAT> "Body"
Click the appropriate button to turn virtual memory on or off. (If you see a 
message when you turn virtual memory on, click OK.)

To use virtual memory, you need available space on your hard disk equal to 
the total amount of memory you want to use.

If you don’t see a Virtual Memory section in the control panel, your computer 
can’t use this feature.

<COACH MARK> "Item:Memory CP:turn VM on"
<PANEL PROMPT> "Prompt Override: 40"

<END PANEL>

<DEFINE PANEL> "VM: choose disk"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Open the Select Hard Disk menu and choose a hard disk to use for virtual 
memory.

The menu is dimmed if virtual memory is not on.
<COACH MARK> "Item:Memory CP:Select HD for VM"

<END PANEL>

<DEFINE PANEL> "VM: set space"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Click the up or down arrow to set the total amount of memory that you want, 
including virtual memory.

(If there is not enough room on the selected disk, no arrows appear.)

Adding more virtual memory than the preset amount (equal to the computer’s 
RAM) will slow down the computer and is not recommended.

<COACH MARK> "Item:Memory CP:size arrows for VM"
<END PANEL>

<DEFINE PANEL> "VM: outro"
<FORMAT> "Full"
When you turn on virtual memory, a file called VM Storage is created on your hard disk. 
This file takes up the amount of space listed in the box labeled “After restart.” This space 
is not available for storing files until you turn off virtual memory.

Virtual memory takes effect after you open the Special menu and choose Restart.
<COACH MARK> "Item:Memory CP:Space after restart"
<PANEL PROMPT> "Prompt Override: 4"

<END PANEL>



# Panels for the sequence "How do I adjust the disk cache?"

# The def panel "disk cache: def" is in the definition file

<DEFINE PANEL> "Memory: locate"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Locate the Memory control panel. It’s part of the system software that came 
with your computer.

If you can’t find the control panel, click Huh? below for instructions.
<Dimmable Button Data> "Huh?","Definitions Tips for finding items"

<END PANEL>

<DEFINE PANEL> "Memory: open control panel"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Open the Memory control panel.

<COACH MARK> "Finder Coach Memory"
<Dimmable Button Data> "Huh?","How do I open an Item?"
<END PANEL>

<DEFINE PANEL> "Memory: adjust cache"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Click the arrows to set the new size. With a smaller cache, more memory is 
available for opening programs. With a bigger cache, programs run faster.

Changes take effect after you restart your computer.
<COACH MARK> "Item:Memory CP:Cache Arrows"

<END PANEL>

# Panels for the sequence "How do I change the background
#  pattern?"

<DEFINE PANEL> "Desktop pattern: intro choice"
<FORMAT> "Full"
You use the Desktop Patterns control panel to choose or create a background pattern 
(called the desktop pattern).

Which do you want to do? Click one:

<RADIO BUTTON> "Choose a pattern", true,,, ,APPLEGUIDE
<RADIO BUTTON> "Create my own pattern", false,,, ,APPLEGUIDE

<On Panel Create> DoAppleScript(":Open AppleScripts:Null AS script")
<END PANEL>

<DEFINE PANEL> "Desktop Pattern: segue to install"



<FORMAT> "Full"
The software you need, Desktop Patterns control panel, is not installed. You need to 
install this software before you can complete this task.

<PANEL PROMPT> "Standard Prompts"
<END PANEL>

<DEFINE PANEL> "Desktop pattern: locate"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Locate the Desktop Patterns control panel. It’s part of the system software that 
came with your computer.

If you can’t find the control panel, click Huh? below for instructions.
<END PANEL>

<DEFINE PANEL> "Desktop pattern: open"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Open the Desktop Patterns control panel.

<COACH MARK> "Finder Coach Desktop Patterns"
<Dimmable Button Data> "Huh?","How do I open an Item?"
<END PANEL>

<DEFINE PANEL> "Patterns: clicking"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Click the arrow at either end of the scroll bar to see the patterns available. 
Drag the scroll box to move rapidly through patterns.

<END PANEL>

<DEFINE PANEL> "Pattern: choose"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Click Set Desktop Pattern when the pattern you want is displayed.

<END PANEL>

<DEFINE PANEL> "Pattern: copy"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
With a graphics program, a scanner, or another source of images, create the 
image you want for a desktop pattern. Then select the image and copy it (by 
choosing Copy from the Edit menu).

<END PANEL>

<DEFINE PANEL> "Pattern: paste"
<FORMAT> "Tag"

Do This



<FORMAT> "Body"
Click anywhere in the Desktop Patterns control panel to make it active, then 
choose Paste from the Edit menu.

<COACH MARK> "Menu:Front:Edit:Paste"
<END PANEL>



<DEFINE PANEL> "Highlight color: change brightness"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Adjust the brightness of the color wheel by dragging the scroll box.

If the color wheel appears black, move the scroll box up.
<COACH MARK> "Color Control: scroll box"

<END PANEL>

<DEFINE PANEL> "Highlight color: pointing"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Click anywhere on the color on the color wheel (or drag the sliders if no color 
wheel is displayed) to adjust the color.  The new color appears in the square 
labeled “New.” 

(For more information about selecting a color, click Huh? below.)

When the color you want is displayed in the square, click OK.
<COACH MARK> "Color Control: Color Wheel"

<END PANEL>

<DEFINE PANEL> "Click OK"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Click OK.

<COACH MARK> "Color Control: OK"
<END PANEL>

# Panels for the sequence "How do I use a CD-ROM disc?"

<DEFINE PANEL> "CD-ROM: how to use"
<FORMAT> "Full"
You can use the files on most CD-ROM discs as you would any other files.

You cannot store anything on a CD-ROM disc. If you want to change its files, you must 
first copy them to another type of disk.

For information on connecting a CD-ROM drive, installing the software it needs, and 
inserting a disc, see the user’s guide that came with your CD-ROM drive.

<PANEL PROMPT> "Prompt Override: 4"
<END PANEL>



# Panels for the sequence "How do I play a CD audio disc?"

<DEFINE PANEL> "CD audio: intro AppleCD Audio Player"
<FORMAT> "Full"
You can play audio compact discs on your CD-ROM drive by using the AppleCD Audio 
Player.

<On Panel Create> DoAppleScript(":Open AppleScripts:Null AS script")
<END PANEL>

<DEFINE PANEL> "AppleCD Audio: NA"
<FORMAT> "Full"
If your computer has a CD-ROM drive and either the AppleCD Audio Player or the CD 
Remote program, you can play CD audio discs.

For information on connecting a CD-ROM drive, installing the software it needs, and 
inserting a disc, see the user’s guide that came with your CD-ROM drive.

<PANEL PROMPT> "Prompt Override: 4"
<END PANEL>

<DEFINE PANEL> "CD audio: insert"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Insert the CD audio disc in the CD-ROM drive.

For instructions on inserting a disc, see the user’s guide that came with the 
CD-ROM drive.

<END PANEL>

<DEFINE PANEL> "CD audio: check Sound In"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
If your computer has different sound-recording options (such as a microphone 
and a CD-ROM drive), make sure you have the CD-ROM drive selected in the 
Sound control panel. 

Click Huh? below for instructions on selecting the CD-ROM drive in the 
Sound control panel.

<Dimmable Button Data> "Huh?","Definitions Selecting an audio source in the Sound control panel"
<END PANEL>

#  Branch for AppleCD Audio Player starts here.

<DEFINE PANEL> "AppleCD Audio: no drive"



<FORMAT> "Full"
You need to connect a CD-ROM drive before you can use the program to play a CD 
audio disc. See the user’s guide for the drive for instructions.

(If a message reports that the CD-ROM drive is not responding, click Cancel to remove 
it.)

<PANEL PROMPT> "Standard Prompts"
<END PANEL>

<DEFINE PANEL> "AppleCD Audio: intro"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
To play the CD audio disc, click the Play/Pause button. (Clicking again pauses 
play.)

Clicking the Stop button (left of Play, with a square on it) stops play.

You can leave AppleCD Audio Player open and switch to another program as 
you listen to the disc.

A description of AppleCD Audio Player’s key features follows.
<COACH MARK> "CoachMark: 125"
<PANEL PROMPT> "Prompt Override: 6"

<END PANEL>

<DEFINE PANEL> "AppleCD Audio: clock & numbers"
<FORMAT> "Full"
• Clock icon
The clock icon is a pop-up menu. Press the clock to choose time elapsed or time 
remaining on the current track or on the disc.

• Numbers
The current track number is displayed on the left and your choice of elapsed or remaining 
time is displayed on the right.

<PANEL PROMPT> "Prompt Override: 6"
<END PANEL>

<DEFINE PANEL> "AppleCD Audio: normal & shuffle"
<FORMAT> "Full"
• Normal
Clicking the Normal button sets tracks to play in sequential order.

• Shuffle
Clicking the Shuffle button sets tracks to play in random order.

<PANEL PROMPT> "Prompt Override: 6"
<END PANEL>

<DEFINE PANEL> "AppleCD Audio: program & arrows"



<FORMAT> "Full"
• Program
Clicking the Program button sets tracks to play in the order on the playlist.

• Direction
Clicking the arrow button sets the disc to play one time (straight arrow) or to play 
continuously (return arrow).

• Editing arrow
Clicking the tiny down arrow below the Normal button opens the playlist-editing section 
of AppleCD Audio Player. (When this section is open, clicking the tiny up arrow closes 
it.)

For instructions on repeating play, click Huh? below.
<Dimmable Button Data> "Huh?","How do I play a CD audio disc repeatedly?"
<PANEL PROMPT> "Prompt Override: 6"

<END PANEL>

<DEFINE PANEL> "AppleCD Audio: editing & lists"
<FORMAT> "Full"
• Track list and Playlist
With Normal or Shuffle selected, a list of tracks is displayed. With Program selected, the 
track list and a playlist (programmed tracks) are displayed.

You create a program by dragging tracks from the track list (left) to the playlist (right). 
You can also move items around on the playlist or remove a track (by dragging it back to 
the track list).

For instructions on programming with AppleCD Audio Player, click Huh? below.
<PANEL PROMPT> "Prompt Override: 6"
<Dimmable Button Data> "Huh?","How do I select tracks to play on an audio CD?"

<END PANEL>

<DEFINE PANEL> "AppleCD Audio: tracks & controls"
<FORMAT> "Full"
• Tracks pop-up menu
The down arrow labeled Audio CD opens a pop-up menu of tracks, which you use to play 
a specific track.

• Control buttons
Buttons on the top row are Stop (square), Play/Pause (right arrow), and Eject (up arrow 
and bar). The bottom buttons are Previous Track, Next Track, Scan Backward (in current 
track), and Scan Forward (in current track).

• Volume
You set the volume by dragging the slider or by adjusting the volume control of the CD-
ROM drive.

<PANEL PROMPT> "Prompt Override: 6"



<END PANEL>

<DEFINE PANEL> "AppleCD Audio: Options menu"
<FORMAT> "Full"
• Options menu
Use the Options menu to
- change the color of the AppleCD Audio Player window
  and indicators
- produce stereo sound or sound through only one channel
- indicate which CD-ROM drive to use with the program

<PANEL PROMPT> "Prompt Override: 6"
<END PANEL>

<DEFINE PANEL> "AppleCD Audio: keys"
<FORMAT> "Full"
• Keyboard controls
You can use certain keys to control CD audio play. The keyboard controls are

Play/Pause                Space bar or Enter key
Stop                             Delete key
Previous track          Left arrow key
Next track                  Right arrow key
Volume                       Up arrow (increase) or 
                                    Down arrow (decrease)
Eject disc                    † and E

<PANEL PROMPT> "Prompt Override: 4"
<END PANEL>

# End of AppleCD Audio Player branch

# Panels for the sequence "How do I display colors or grays?"

<DEFINE PANEL> "display: no colors"
<FORMAT> "Full"
Your computer cannot display colors or shades of gray.

<PANEL PROMPT> "Prompt Override: 4"
<END PANEL>

<DEFINE PANEL> "Monitor display colors: intro"



<FORMAT> "Full"
You use the Monitors control panel to display colors or shades of gray on your monitor.

The number of colors you can use depends on your computer’s video capability 
(sometimes called “bit depth”) and the  monitor you’re using.

<On Panel Create> DoAppleScript(":Open AppleScripts:Null AS script")
<END PANEL>

<DEFINE PANEL> "Monitors: segue to install"
<FORMAT> "Full"
The software you need, Monitors control panel, is not installed. You need to install this 
software before you can complete this task.

<PANEL PROMPT> "Standard Prompts"
<END PANEL>

<DEFINE PANEL> "Monitors: locate"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Locate the Monitors control panel. It’s part of the system software that came 
with your computer.

If you can’t find the control panel, click Huh? below for instructions.
<Dimmable Button Data> "Huh?","Definitions Tips for finding items"

<END PANEL>

<DEFINE PANEL> "control panel: Restart for effect"
<FORMAT> "Full"
Changes take effect after you restart the computer (by opening the Special menu and 
choosing Restart).

After you restart, you can open the Guide menu (on the right with the ? icon), choose 
Macintosh Guide, and return to this question.

<PANEL PROMPT> "Prompt Override: 29"
<END PANEL>

<DEFINE PANEL> "Monitors control panel: opening"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Open the Monitors control panel.

<COACH MARK> "Finder Coach Monitors"
<Dimmable Button Data> "Huh?","How do I open an Item?"
<END PANEL>

<DEFINE PANEL> "Monitor display colors: click button"



<FORMAT> "Tag"
Do This

<FORMAT> "Body"
Click Grays or Colors.

Grayscale monitors can display only shades of gray, even if you click the 
Colors button. For best results, click Grays if you have a grayscale monitor.

<COACH MARK> "CoachMark: 38"
<END PANEL>

<DEFINE PANEL> "Monitor display colors: click number"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Click the number of colors or shades of gray you want to display.

<COACH MARK> "CoachMark: 39"
<END PANEL>

# Panel for the sequence "How do I take a “snapshot” of the
#  screen?"

<DEFINE PANEL> "Screen: snapshot"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Press †-Shift-3 to take a snapshot of what’s on the screen.

A file named Picture 1 is created on the startup disk.  Additional screen shots 
are numbered Picture 2, Picture 3, and so on.

You can work with screen shots using any program that can read PICT files 
(including the SimpleText or TeachText program that came with your 
Macintosh).

<Dimmable Button Data> "Huh?","Definitions PICT"
<END PANEL>

# Panels for the sequence "How do I get information about
#  an item?"

<DEFINE PANEL> "item info: intro"
<FORMAT> "Full"
You can get information about an item using the Get Info command or using the View 
menu. 

The Get Info window provides details about a single item, including type, size, dates 
created and modified, and location. The View menu lets you see the contents of a disk or 
folder in a list format (arranged by name, type, or another attribute) or as icons.

Which do you want to use? Click one or both:
<CHECKBOX> "the Info window", false,,,,APPLEGUIDE
<CHECKBOX> "the View menu", false,,,,APPLEGUIDE



<END PANEL>

<DEFINE PANEL> "View menu: if intro"
<FORMAT> "Full"
The steps that follow show you how to get information using the View menu.

<PANEL PROMPT> "Standard Prompts"
<END PANEL>

<DEFINE PANEL> "window: make active"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Click the window that contains the item.

<Dimmable Button Data> "Huh?","Definitions active program"
<END PANEL>

<DEFINE PANEL> "View: choose any list 2"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Open the View menu and choose any list view. List views show more 
information about the item than icon views.

<COACH MARK> "Menu:MACS:Views:none"
<Dimmable Button Data> "Huh?","Definitions view"

<END PANEL>

# Panels for the sequence "How do I test and repair a disk?"

<DEFINE PANEL> "Repair disk: intro"
<FORMAT> "Full"
Your computer comes with two programs that can test and repair disks: Disk First Aid 
(for hard disks and floppy disks) and Apple HD SC Setup (for hard disks only). These 
programs do not repair disks formatted for DOS computers, however.

For instructions on using these programs, see the
user’s guide that came with your computer.

<END PANEL>

# Panels for the sequence "How do I add or remove an item in the Launcher?"

<DEFINE PANEL> "Launcher: intro choice"



<FORMAT> "Full"
You can control what appears in the Launcher window by dragging items in or out of the 
Launcher Items folder (inside the System Folder).

Which do you want to do? Click one:
<RADIO BUTTON> "add an item", true,,, ,APPLEGUIDE
<RADIO BUTTON> "remove an item", false,,, ,APPLEGUIDE

<Dimmable Button Data> "Huh?","Definitions Launcher"
<END PANEL>

# branch for radio button "add an item"

<DEFINE PANEL> "Launcher: select item"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Find the item you want to add to the Launcher. Click the item to select it.

<END PANEL>

<DEFINE PANEL> "Launcher: open Launcher Items"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Find the Launcher Items folder (in the System Folder) and open it.

<COACH MARK> "Finder Coach Launcher Items"
<END PANEL>

<DEFINE PANEL> "Launcher: drag to folder"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Drag the alias you created to the Launcher Items folder.

If the Launcher Items folder contains other folders (used to group items), the 
alias you created will automatically be added to the Applications group. To 
have the item appear within another group, drag the alias to the folder for that 
group.

For more information about grouping items in the Launcher, click Huh? 
below.

<Dimmable Button Data> "Huh?","How do I group items in the Launcher?"
<END PANEL>

<DEFINE PANEL> "Launcher: drag out"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Locate the alias of the item you want to remove from the Launcher and drag it 
to a location outside the Launcher Items folder.

You may have to open one or more folders inside Launcher Items to find the 
alias.

<END PANEL>



# Panels for the sequence "How do I limit access to programs and files?"



<DEFINE PANEL> "General Controls: protect files"
<FORMAT> "Full"
You use the General Controls panel to protect the contents of two folders on your 
computer’s hard disk—the Applications folder and the System Folder.

With protection turned on, the programs, documents, and folders inside these folders 
can’t be moved, and contents of documents can’t be changed.

<PANEL PROMPT> "Finder Prompts"
<Dimmable Button Data> "Huh?","Definitions System Folder"

<On Panel Create> DoAppleScript(":Open AppleScripts:Null AS script")
<END PANEL>

<DEFINE PANEL> "General Controls: protect intro"
<FORMAT> "Full"
You can limit access to some items in the General Controls panel. Among your options 
are
• hiding the Finder (so that the startup disk icon is
  hidden)
• protecting the System Folder (so it can’t be changed)
• protecting the Applications folder (so it can’t be
  changed)

You can also open the Launcher when the computer starts up and specify where items 
will be saved automatically.

<END PANEL>

<DEFINE PANEL> "General Controls: click protect"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
In the Folder Protection section, click one or both of the boxes labeled 
“Protect System Folder” and “Protect Applications folder” to put an X in 
them. (The boxes are dimmed if file sharing is on.)

With protection turned on, you
• can’t remove items immediately inside the
  protected folder
• can’t change documents immediately inside 
  the protected folder

Folder protection and file sharing can’t be on at the same time. Folder 
protection is turned off automatically when file sharing is turned on. 

<COACH MARK> "Wind:GenCont:FoldrProtect:Rect"
<END PANEL>



# Panels for the sequence "Key features of System 7.5"

<DEFINE PANEL> "System 7.5: features1"
<FORMAT> "Full"
System 7.5 provides significant new capabilities for your Macintosh. 

• Macintosh Guide delivers step-by-step instructions for using your Macintosh and shows 
you which menu, icon, or other item you need to use for each step.

• Opening and exchanging files is easy, using the translation capabilities of system 
software and your programs. 

• Using and formatting DOS floppy disks is as simple as using standard Macintosh disks.
<END PANEL>

<DEFINE PANEL> "System 7.5: features2"
<FORMAT> "Full"
• Copying text, graphics, numbers, and QuickTime movies is as simple as dragging an 
item from one document to another.

• Printing is elegant with QuickDraw GX, which lets you use multiple printers at once 
and drag documents to desktop printer icons for printing.

• Creating sophisticated documents is easy with the wide range of fonts and style 
enhancements offered by QuickDraw GX.

<END PANEL>

<DEFINE PANEL> "System 7.5: features3"
<FORMAT> "Full"
• Powerful network services are available with PowerTalk, which automates and 
consolidates electronic mail, server connections, network addresses, and more.

• Many tasks can be automated, using the scriptable Finder and a scripting language such 
as AppleScript. A group of useful scripts is provided in the Apple menu.

• Access to files and disks is streamlined through the enhanced Apple menu, which 
provides submenus that list control panels and programs, documents, and servers used 
recently.

<END PANEL>

<DEFINE PANEL> "System 7.5: features4"



<FORMAT> "Full"
• Locating files is fast and precise with Find File, which lets you specify up to six criteria 
for a search and to immediately use any item located in the search.

• Enhanced security for system software and essential programs is provided with 
protection of the System Folder and Applications folder.

• Enhanced simplicity of use is available with the Launcher, which lets you open items 
with a single click, and optional Finder hiding when a program is in use (so that you can’t 
inadvertently click outside a window and abruptly change to the Finder).

<END PANEL>

# Panels for the question "Tips for efficient Macintosh use"

<DEFINE PANEL> "Efficient use: intro"
<FORMAT> "Full"
You can work more efficiently and productively by using several features of the 
Macintosh system software. These include

  • locating your files quickly

  • customizing your system

  • using keyboard shortcuts

(If you use a PowerBook, see “Batteries & Power” in the Topics section of Macintosh 
Guide for additional tips.)

<END PANEL>

<DEFINE PANEL> "Efficient use: tips1"
<FORMAT> "Full"
Viewing Files
You can view the contents of a window graphically (by icon), alphabetically (by name or 
other characteristic), or chronologically (by date). To change your view of the active 
window, you use the View menu.

When a window’s contents are displayed as a list, you can click the triangle next to a 
folder name to display or hide the contents of the folder.

<END PANEL>

<DEFINE PANEL> "Efficient use: tips2"



<FORMAT> "Full"
Control Panels
Control panels are special files that let you customize or adjust settings for your 
Macintosh. (Control panels are in the Control Panels folder, inside the System Folder.)

Using a control panel, you can set the time and date, adjust the format for dates and 
numbers, adjust colors on the screen, switch networks, set up file sharing, set up a RAM 
disk, and much more.

You can open a control panel quickly by choosing it from the submenu next to Control 
Panels in the Apple menu.

<Dimmable Button Data> "Huh?","Definitions control panel"
<END PANEL>

<DEFINE PANEL> "Efficient use: tips3"
<FORMAT> "Full"
Locating Files
You can use the Find command in the File menu to locate files quickly. When searching 
for files, you can specify several criteria (such as name, date, or size) for the computer to 
use.

Results of a file search are displayed as a list. You can select an item in the list and see its 
exact location (inside one or more folders, for example) and then move or open that item.

<END PANEL>

<DEFINE PANEL> "Efficient use: tips4"
<FORMAT> "Full"
The Apple Menu
You can quickly open a program, document, or folder by choosing it from the Apple () 
menu.  Some items are placed in the Apple menu during installation of the system 
software.

You can add items to the Apple menu by adding them to the Apple Menu Items folders 
inside the System Folder.

(You may want to put an alias of an item in the Apple menu, rather than the item itself. 
Read the next tip for more information about aliases.)

<END PANEL>

<DEFINE PANEL> "Efficient use: tips5"



<FORMAT> "Full"
Aliases
An alias is an icon you can use as a stand-in for a document, program, folder, or disk. An 
alias is a tiny file that “points” to an item. When you open an alias, the original item 
actually opens.

You make an alias by selecting the item, then choosing Make Alias from the File menu.

Aliases give you access to an item from two or more locations. An alias is especially 
useful for a shared disk or for an item you put in the Apple menu.

<Dimmable Button Data> "Huh?","Definitions alias"
<END PANEL>

<DEFINE PANEL> "Efficient use: tips6"
<FORMAT> "Full"
Keyboard Shortcuts
You can use a keyboard shortcut for many Macintosh commands by holding down the † 
key (called the “Command key”) to the left of the Space bar and typing a letter on the 
keyboard. For example, typing †-Q is the same as choosing Quit from the File menu. 

When you’re working in the Finder, you can select a file by typing a letter on the 
keyboard. In a dialog box, one button usually has a bold line around it. This button is the 
default choice—usually the recommended or safest choice. Pressing the Return key is the 
same as clicking this button.

<PANEL PROMPT> "Prompt Override: 4"
<END PANEL>

<DEFINE PANEL> "General Controls: segue to install"
<FORMAT> "Full"
The software you need, General Controls panel, is not installed. You need to install this 
software before you can complete this task.

<PANEL PROMPT> "Standard Prompts"
<END PANEL>

<DEFINE PANEL> "General Controls: locate"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Locate the General Controls panel. It’s part of the system software that came 
with your computer.

If you can’t find the control panel, click Huh? below for instructions.
<Dimmable Button Data> "Huh?","Definitions Tips for finding items"

<END PANEL>

<DEFINE PANEL> "General controls: opening"



<FORMAT> "Tag"
Do This

<FORMAT> "Body"
Open the General Controls panel.

<COACH MARK> "Finder Coach General Controls"
<Dimmable Button Data> "Huh?","How do I open an Item?"
<END PANEL>

<DEFINE PANEL> "Repair disk: outro"
<FORMAT> "Full"
To test whether you have a problem with your floppy disk drive, try the following:

• Use another disk in the disk drive.

• Use the original disk in another disk drive.

If the second disk also fails, or if the original disk works in the other disk drive, your disk 
drive may need repair.

<PANEL PROMPT> "Prompt Override: 4"
<END PANEL>

<DEFINE PANEL> "alias: click it"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Click the alias to select it.

<END PANEL>

<DEFINE PANEL> "Info: Find Original"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Click Find Original (in the lower-right corner of the Info window).

(You may need to move this window or the Info window to see the Find 
Original button.)

If the original file is on a disk available to your computer, its icon is displayed 
and selected. Otherwise you see a message.

If the Info window doesn’t contain a Find Original button, the item you 
selected is not an alias.

<COACH MARK> "Wind:Info:Original"
<END PANEL>

<DEFINE PANEL> "File menu: Get Info"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Open the File menu and choose Get Info.

If you need instructions on choosing a menu item, click Huh? below.
<COACH MARK> "Menu:MACS:File:Get Info"
<Dimmable Button Data> "Huh?","Why can’t I choose a menu item?"



<END PANEL>



<DEFINE PANEL> "neat icons: all"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Click the window that contains the icons you want to arrange.

<END PANEL>

<DEFINE PANEL> "Special menu: choose restart for RAM disk"
<FORMAT> "Full"
Changes to the RAM disk take effect after you restart your computer (by opening the 
Special menu and choosing Restart).

<COACH MARK> "Menu:MACS:Special:Restart"
<END PANEL>

<DEFINE PANEL> "Special menu: choose Erase Disk"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Open the Special menu and choose Erase Disk.

If you need instructions on choosing a menu item, click Huh? below.
<COACH MARK> "Menu:MACS:Special:Erase Disk"
<Dimmable Button Data> "Huh?","Why can’t I choose a menu item?"

<END PANEL>

<DEFINE PANEL> "Erase disk: intro"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Before you erase a disk, make copies of any files you want to keep.

<END PANEL>

<DEFINE PANEL> "Erase disk: select disk"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Click the icon of the disk you want to erase.

<END PANEL>

<DEFINE PANEL> "Apple: choose Chooser"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Open the Apple () menu and choose Chooser.

<COACH MARK> "Menu:Front:Apple:Chooser"
<Dimmable Button Data> "Huh?","Definitions Chooser"

<END PANEL>

<DEFINE PANEL> "Chooser: close"



<FORMAT> "Tag"
Do This

<FORMAT> "Body"
Close the Chooser (if it is open) by clicking the close box at the upper-left 
corner.

<COACH MARK> "CoachMark: 155"
<END PANEL>



<DEFINE PANEL> "Chooser: click direct driver"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
In the upper-left area of the Chooser, click the type of printer you want to use.

<COACH MARK> "Item:Chooser:select driver"
<END PANEL>

<DEFINE PANEL> "Chooser: click port"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
In the upper-right area of the Chooser, click the icon of the port to which the 
printer is connected.

<COACH MARK> "CoachMark: 151"
<END PANEL>

<DEFINE PANEL> "Chooser: click AppleTalk Inactive"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
In the lower-right area of the Chooser, click the AppleTalk Inactive button.

If a message appears, read it and then click your choice.

You can skip this step if the modem port (the lower icon on the right side of 
the Chooser) is selected.

<COACH MARK> "Item:Chooser:AppleTalk Inactive"
<END PANEL>

<DEFINE PANEL> "Chooser: click AppleTalk Active"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
In the lower-right area of the Chooser, click the AppleTalk Active button to 
place a dot in it. (If AppleTalk Active is already selected, you can skip this 
step.)

AppleTalk becomes active after you restart the computer (by choosing Restart 
from the Special menu).

After restarting, open the Guide menu (on the right with the ? icon), choose 
Macintosh Guide, and choose this question again.

<PANEL PROMPT> "Prompt Override: 27"
<COACH MARK> "Item:Chooser:AppleTalk Active"

<END PANEL>

<DEFINE PANEL> "Chooser: click driver"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
In the upper-left area of the Chooser, click the type of printer you want to use.

<COACH MARK> "Item:Chooser:select driver"



<END PANEL>

<DEFINE PANEL> "Chooser: click AppleTalk zones"



<FORMAT> "Tag"
Do This

<FORMAT> "Body"
In the lower-left area of the Chooser, click the AppleTalk zone where the 
printer is located.

This area does not appear if your network doesn’t have zones.
<COACH MARK> "Item:Chooser:select zone"
<Dimmable Button Data> "Huh?","Definitions AppleTalk zone"

<END PANEL>

<DEFINE PANEL> "Chooser: click printer name"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
In the upper-right area of the Chooser, click the name of the printer you want 
to use (even if only one name is listed).

<COACH MARK> "CoachMark: 151"
<END PANEL>

<DEFINE PANEL> "Chooser: click BG printing on"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
In the lower-right area of the Chooser, click Background Printing On. (Not all 
printers can use background printing. If you don’t see the Background 
Printing buttons, the type of printer you selected cannot use this feature.)

With background printing on, you can use your computer for other work while 
documents are printing.

<COACH MARK> "Item:Chooser:Background printing on"
<END PANEL>

<DEFINE PANEL> "PrintMonitor: locate"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Locate the PrintMonitor program. It is part of the system software that came 
with your computer or your printer.

If you can’t find PrintMonitor, click Huh? below for instructions.
<Dimmable Button Data> "Huh?","Definitions Tips for finding items"

<END PANEL>

<DEFINE PANEL> "BG printing: off"
<FORMAT> "Full"
You turn background printing on in the Chooser.

<PANEL PROMPT> "Prompt Override: 21"
<END PANEL>

<DEFINE PANEL> "PrintMonitor: choose document"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"



In the PrintMonitor window, click the name of the document to select it.
<END PANEL>



<DEFINE PANEL> "Printing: Select Doc icon"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Click on the icon of the document you want to print to select it.

<END PANEL>

<DEFINE PANEL> "File menu: Print"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Choose Print from the file menu.

<COACH MARK> "Menu:MACS:File:Print"
<END PANEL>

<DEFINE PANEL> "printer drivers: segue"
<FORMAT> "Full"
Printer software is in the Extensions folder inside the System Folder of your startup disk. 
Printer software for most Apple printers is automatically installed.

<PANEL PROMPT> "Prompt Override: 8"
<END PANEL>

<DEFINE PANEL> "fonts: quit apps"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Before you can install or remove fonts, you need to quit all open application 
programs (except the Finder).

To quit a program, open the Application menu (at the far right side of the 
menu bar), choose the program, then open the File menu and choose Quit.

<COACH MARK> "CoachMark: 31"
<END PANEL>

<DEFINE PANEL> "System folder: opening"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Open the System Folder.

<Dimmable Button Data> "Huh?","Definitions System Folder"
<COACH MARK> "Finder Coach System Folder"

<END PANEL>

<DEFINE PANEL> "Key Caps: segue to install"
<FORMAT> "Full"
The software you need, Key Caps, is not installed.

<PANEL PROMPT> "Standard Prompts"
<END PANEL>

<DEFINE PANEL> "Key Caps: locate"



<FORMAT> "Tag"
Do This

<FORMAT> "Body"
Locate the Key Caps desk accessory. It’s part of the system software that came 
with your computer.

If you can’t find Key Caps, click Huh? below for instructions.
<Dimmable Button Data> "Huh?","Definitions Tips for finding items"

<END PANEL>

<DEFINE PANEL> "Apple: choose Key Caps"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Open the Apple () menu and choose Key Caps.

<COACH MARK> "Menu:Front:Apple:Key Caps"
<END PANEL>

<DEFINE PANEL> "Views: segue to install"
<FORMAT> "Full"
The software you need, Views control panel, is not installed. You need to install this 
software before you can complete this task.

<PANEL PROMPT> "Prompt Override: 8"
<END PANEL>

<DEFINE PANEL> "Views: locate"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Locate the Views control panel. It’s part of the system software that came with 
your computer.

If you can’t find the control panel, click Huh? below for instructions.
<Dimmable Button Data> "Huh?","Definitions Tips for finding items"

<END PANEL>

<DEFINE PANEL> "Views: open"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Open the Views control panel.

<COACH MARK> "Finder Coach Views"
<END PANEL>

<DEFINE PANEL> "network connect: intro"
<FORMAT> "Full"
Connecting to another computer on the network involves several steps. These include:
• installing networking software
• connecting network cables to your computer
• making AppleTalk active (in the Chooser)
• naming your computer (in the Sharing Setup
   control panel)

<PANEL PROMPT> "Standard Prompts"
<On Panel Create> DoAppleScript(":Open AppleScripts:Null AS script")

<Dimmable Button Data> "Huh?","Definitions network"



<END PANEL>



<DEFINE PANEL> "network connect: software"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Some networking software is not installed.

See your user’s guide for instructions on installing system software (including 
networking software), then open the Guide menu (on the right with the ? 
icon), choose Macintosh Guide, and return to this question.

If you use a networking expansion card (for Ethernet, for example), you may 
have to install additional software. See the instructions that came with the 
card.

<PANEL PROMPT> "Prompt Override: 27"
<END PANEL>

<DEFINE PANEL> "network connect: cables"
<FORMAT> "Full"
Make sure the appropriate cables are connected to your computer. See your user’s guide 
for information, or consult your network administrator (if you have one).

<END PANEL>

<DEFINE PANEL> "Sharing Setup: segue to install"
<FORMAT> "Full"
The software you need, Sharing Setup control panel, is not installed. You need to install 
this software before you can complete this task.

<PANEL PROMPT> "Standard Prompts"
<END PANEL>

<DEFINE PANEL> "Sharing Setup: locate"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Locate the Sharing Setup control panel. It’s part of the system software that 
came with your computer.

If you can’t find the control panel, click Huh? below for instructions.
<Dimmable Button Data> "Huh?","Definitions Tips for finding items"

<END PANEL>

<DEFINE PANEL> "Sharing: open setup"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Open the Sharing Setup control panel.

<COACH MARK> "Finder Coach Sharing Setup"
<END PANEL>

<DEFINE PANEL> "Sharing Setup: type name"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Type your name in the box labeled Owner Name, and press the Tab key.



<COACH MARK> "CoachMark: 97"
<END PANEL>



<DEFINE PANEL> "Sharing Setup: password intro"
<FORMAT> "Full"
Now decide on a password, which you’ll use to connect to your computer from another 
computer on the network. Don’t type the password yet.

Remember your password, including capitalization. Your password can be up to eight 
characters long.

For security, each character is replaced by a bullet (•) after you type it.
<PANEL PROMPT> "Standard Prompts"

<END PANEL>

<DEFINE PANEL> "Sharing Setup: type password"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Type a password in the box labeled Owner Password, and press the Tab key.

<COACH MARK> "CoachMark: 98"
<END PANEL>

<DEFINE PANEL> "Sharing Setup: type computer name"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Type a name for your computer in the box labeled Macintosh Name.

This is the name others see when they connect to your computer over a 
network.

<COACH MARK> "CoachMark: 99"
<END PANEL>

<DEFINE PANEL> "Chooser: click AppleShare"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
In the upper-left area of the Chooser, click the AppleShare icon to select it.

<COACH MARK> "Item:Chooser:select driver"
<END PANEL>

<DEFINE PANEL> "Chooser: click zone"

<FORMAT> "Tag"
Do This

<FORMAT> "Body"
In the lower-left area of the Chooser, click the zone that the computer is in.

This area does not appear if the network doesn’t have zones.
<COACH MARK> "Item:Chooser:select zone"

<END PANEL>

<DEFINE PANEL> "Chooser: click computer name"
<FORMAT> "Tag"

Do This



<FORMAT> "Body"
In the upper-right area of the Chooser, click the name of the computer, and 
then click OK.



<COACH MARK> "CoachMark: 151"
<END PANEL>

<DEFINE PANEL> "Sharing: click item"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Click the folder or disk that has the files you want to share. Make sure that it 
does not contain files that you want to keep private.

<END PANEL>

<DEFINE PANEL> "Sharing: start sharing"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Click Start under File Sharing.

You may see a message asking you to type your name and a name for your 
computer before you can turn on file sharing.  Type these names at the top of 
the control panel.

When file sharing is on, protection of the Applications folder and System 
Folder is automatically turned off. (Click Huh? below for more information 
about protecting these folders.)

<Dimmable Button Data> "Huh?","How do I limit access to programs and files?"
<COACH MARK> "CoachMark: 100"

<END PANEL>

<DEFINE PANEL> "Sharing: click box"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Click the box labeled “Share this item and its contents” to put an X in it.

If the item is inside a folder you have already shared, this box is labeled 
“Same as enclosing folder.” Clicking the box gives the item the same access 
privileges as the folder that contains it.

<COACH MARK> "CoachMark: 117"
<END PANEL>

<DEFINE PANEL> "Sharing: clickbox info"
<FORMAT> "Full"
To give the same access privileges to all folders inside the item, click the box labeled 
“Make all currently enclosed folders like this one” to put an X in it.

To protect the item from being changed, click the box labeled “Can’t be moved, renamed, 
or deleted” to put an X in it. (This box doesn’t appear if the shared item is a disk.)

<COACH MARK> "CoachMark: 103"
<END PANEL>

<DEFINE PANEL> "Sharing: spec users"



<FORMAT> "Tag"
Do This

<FORMAT> "Body"
To share with a user or group, open the User/Group menu and choose the 
registered user or group you want.

If the User/Group menu is dimmed, either click the box labeled “Same as 
enclosing folder” to remove the X or click the box labeled “Share this item 
and its contents” to put an X in it. 

If you want to share the item with everyone, you can skip this step.

If you need to register more users and groups, click Huh? below.
<COACH MARK> "CoachMark: 104"
<Dimmable Button Data> "Huh?","How do I register or remove users and groups?"

<END PANEL>

<DEFINE PANEL> "Sharing: set privileges"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Click boxes next to the User/Group menu to give the user or group the access 
privileges you want.

<COACH MARK> "CoachMark: 105"
<END PANEL>

<DEFINE PANEL> "Sharing: Everyone's privileges"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Click boxes next to Everyone to set access privileges for guests.

These privileges take effect if guest access is turned on.
<COACH MARK> "CoachMark: 107"
<Dimmable Button Data> "Huh?","How do I turn on guest access?"

<END PANEL>

<DEFINE PANEL> "Sharing: Everyone's privileges 2"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Click boxes next to Everyone to set access privileges for guests.

These privileges take effect if guest access is allowed on the computer. (Ask 
the computer’s owner.)

<COACH MARK> "CoachMark: 107"
<END PANEL>
<DEFINE PANEL> "Sharing: close window"

<FORMAT> "Tag"
Do This

<FORMAT> "Body"
Click the close box to close the window.

If you’ve made changes, click Save to confirm them.



<COACH MARK> "CoachMark: 109"
<END PANEL>

<DEFINE PANEL> "Shared disk: segue"



<FORMAT> "Full"
To share files that you have stored on another computer, you must be a guest or registered 
user on that computer, you must have the access privilege to make changes, and you must 
own the folder that contains the files.

If you created the folder, you automatically own the folder.
<PANEL PROMPT> "Standard Prompts"
<Dimmable Button Data> "Huh?","Definitions access privileges"

<END PANEL>

<DEFINE PANEL> "Sharing: type users"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Type the name of the registered user or group that you want to share the item 
with. (Consult the owner of the computer for the correct spelling of the name.)

Then click boxes in the User/Group row to set access privileges.
<COACH MARK> "CoachMark: 112"

<END PANEL>

<DEFINE PANEL> "Shared disk: connect"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Connect to the shared disk that contains the files you want to share.

For instructions on connecting to a shared disk, click Huh? below.
<Dimmable Button Data> "Huh?","How do I gain access to shared files?"

<END PANEL>

<DEFINE PANEL> "troubleshooting: file sharing outro"
<FORMAT> "Full"
Make sure you have registered the users with whom you want to share your files,  and 
that you have given them the appropriate access privileges.

Also make sure that your registered users know the names and passwords (including 
capitalization) you gave them.

<PANEL PROMPT> "Prompt Override: 4"
<END PANEL>

<DEFINE PANEL> "Users & Groups: segue to install"
<FORMAT> "Full"
The software you need, Users & Groups control panel, is not installed. You need to install 
this software before you can complete this task.

<PANEL PROMPT> "Standard Prompts"
<END PANEL>

<DEFINE PANEL> "Users & Groups: locate"



<FORMAT> "Tag"
Do This

<FORMAT> "Body"
Locate the Users & Groups control panel. It’s part of the system software that 
came with your computer.

If you can’t find the control panel, click Huh? below for instructions.
<Dimmable Button Data> "Huh?","Definitions Tips for finding items"

<END PANEL>

<DEFINE PANEL> "Users & Groups: open"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Open the Users & Groups control panel.

<COACH MARK> "Finder Coach Users & Groups"
<END PANEL>

<DEFINE PANEL> "user or group: Trash"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
To remove a user or group, drag its icon to the Trash. Then open the Special 
menu and choose Empty Trash. (If a message appears, click OK.)

To remove a user from a group (but not from your list of registered users), 
open the group icon and drag the user icon inside the group window to the 
Trash.

<END PANEL>

<DEFINE PANEL> "File: Sharing"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Open the File menu and choose Sharing.

If Sharing is dimmed, make sure you’ve selected a folder or disk.  (For 
program linking, make sure you’ve selected a program.)

<COACH MARK> "Menu:MACS:File:Sharing"
<END PANEL>

<DEFINE PANEL> "File: Put Away"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Open the File menu and choose Put Away.

(If you see a message that the disk could not be put away because it is being 
shared, you must turn off file sharing. You do this by opening the Sharing 
Setup control panel and clicking Stop in the File Sharing section. You may 
want to check whether other users are connected to the disk before turning off 
file sharing. Click Huh? below for instructions.)

<COACH MARK> "Menu:MACS:File:Put Away"
<PANEL PROMPT> "Prompt Override: 19"



<Dimmable Button Data> "Huh?","How do I know who’s sharing my disks or files?"
<END PANEL>

<DEFINE PANEL> "Shared folder: click item"



<FORMAT> "Tag"
Do This

<FORMAT> "Body"
Click the shared folder to select it.

<END PANEL>

<DEFINE PANEL> "Color: segue to install"
<FORMAT> "Full"
The software you need, Color control panel, is not installed. You need to install this 
software before you can complete this task.

<PANEL PROMPT> "Standard Prompts"
<END PANEL>

<DEFINE PANEL> "Color: locate"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Locate the Color control panel. It’s part of the system software that came with 
your computer.

If you can’t find the control panel, click Huh? below for instructions.
<Dimmable Button Data> "Huh?","Definitions Tips for finding items"

<END PANEL>

<DEFINE PANEL> "Color icon: opening"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Open the Color control panel.

<COACH MARK> "Finder Coach Color"
<END PANEL>

<DEFINE PANEL> "label: outro"
<FORMAT> "Tag"

Tip

<FORMAT> "Body"
You can change the labels and colors in the Label menu.  For instructions, 
click Huh? below.

<PANEL PROMPT> "Standard Prompts"
<Dimmable Button Data> "Huh?","How do I change the labels in the Label menu?"

<END PANEL>

<DEFINE PANEL> "Sound: segue to install"
<FORMAT> "Full"
The software you need, Sound control panel, is not installed. You need to install this 
software before you can complete this task.

<PANEL PROMPT> "Standard Prompts"
<END PANEL>

<DEFINE PANEL> "Sound: locate"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"



Locate the Sound control panel. It’s part of the system software that came with 
your computer.

If you can’t find the control panel, click Huh? below for instructions.
<Dimmable Button Data> "Huh?","Definitions Tips for finding items"

<END PANEL>



<DEFINE PANEL> "Sound icon: opening"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Open the Sound control panel.

<COACH MARK> "Finder Coach Sound"
<END PANEL>

<DEFINE PANEL> "Date & Time: segue to install"
<FORMAT> "Full"
The software you need, Date & Time control panel, is not installed. You need to install 
this software before you can complete this task.

<PANEL PROMPT> "Standard Prompts"
<END PANEL>

<DEFINE PANEL> "Date & Time: locate"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Locate the Date & Time control panel. It’s part of the system software that 
came with your computer.

If you can’t find the control panel, click Huh? below for instructions.
<Dimmable Button Data> "Huh?","Definitions Tips for finding items"

<END PANEL>

<DEFINE PANEL> "Date & Time: open"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Open the Date & Time control panel.

<COACH MARK> "Finder Coach Date & Time"
<Dimmable Button Data> "Huh?","How do I open an Item?"

<END PANEL>

<DEFINE PANEL> "Views: choose font"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Open the “Font for views” menu and choose a font.

<COACH MARK> "CoachMark: 55"
<END PANEL>

<DEFINE PANEL> "Views: choose size"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Open the size menu and choose a font size.

<COACH MARK> "CoachMark: 56"
<END PANEL>

<DEFINE PANEL> "Views: straight or staggered"
<FORMAT> "Tag"



Do This

<FORMAT> "Body"
Click “Straight grid” or “Staggered grid.”

Click “Always snap to grid” if you want icons to move to the nearest position 
on the grid whenever you drag them.

<COACH MARK> "CoachMark: 54"



<END PANEL>

<DEFINE PANEL> "Labels: segue to install"
<FORMAT> "Full"
The software you need, Labels control panel, is not installed. You need to install this 
software before you can complete this task.

<PANEL PROMPT> "Standard Prompts"
<END PANEL>

<DEFINE PANEL> "Labels: locate"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Locate the Labels control panel. It’s part of the system software that came 
with your computer.

If you can’t find the control panel, click Huh? below for instructions.
<Dimmable Button Data> "Huh?","Definitions Tips for finding items"

<END PANEL>

<DEFINE PANEL> "Labels control panel: opening"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Open the Labels control panel.

<COACH MARK> "Finder Coach Labels"
<Dimmable Button Data> "Huh?","How do I open an Item?"

<END PANEL>

<DEFINE PANEL> "Label color: selecting"
<FORMAT> "Tag"

Do This

Do This

Do This

<FORMAT> "Body"
Click the color you want to change.

Click anywhere on the color wheel (or drag the sliders if no color wheel is 
displayed) to adjust the color. The new color appears in the square labeled 
“New” at the top right. (For more information about selecting a color, click 
Huh? below.)

When the color you want is displayed in the square, click OK.
<COACH MARK> "CoachMark: 26"
<Dimmable Button Data> "Huh?","Definitions Selecting a color"

<END PANEL>

<DEFINE PANEL> "Label: change colors outro"



<FORMAT> "Tag"
Tip

<FORMAT> "Body"
You can also change the labels that appear in the Label menu.  For 
instructions, click Huh? below.

<PANEL PROMPT> "Prompt Override: 10"
<Dimmable Button Data> "Huh?","How do I change the labels in the Label menu?"

<END PANEL>

<DEFINE PANEL> "Mouse control panel: opening"



<FORMAT> "Tag"
Do This

<FORMAT> "Body"
Open the Mouse control panel.

<COACH MARK> "Finder Coach Mouse"
<END PANEL>

<DEFINE PANEL> "Easy Access: open"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Open the Easy Access control panel.

<COACH MARK> "Finder Coach Easy Access"
<END PANEL>

<DEFINE PANEL> "quit app: segue"
<FORMAT> "Full"
Before you can install or remove items in the System file (such as sounds or keyboard 
layouts), you must quit all open programs (except the Finder program).

To quit a program, open the Application menu (in the upper-right corner of the screen) 
and choose the program. Then open the File menu and choose Quit. Repeat these steps 
until only Finder is listed.

<COACH MARK> "CoachMark: 31"
<PANEL PROMPT> "Standard Prompts"

<END PANEL>

<DEFINE PANEL> "floppy: eject if"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
If the floppy disk is in the disk drive, eject the disk.

For instructions on ejecting a floppy disk, click Huh? below.
<Dimmable Button Data> "Huh?","How do I eject a disk?"

<END PANEL>

<DEFINE PANEL> "floppy: slide tab"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
To lock a disk, use your thumbnail or a push pin to slide the corner tab on the 
back of the disk upward. The square hole is open.

You can unlock the disk by sliding the tab back.
<PICT> 1014, Center

<END PANEL>

<DEFINE PANEL> "housekeeping: Trash"



<FORMAT> "Tag"
Do This

<FORMAT> "Body"
To throw away an item, drag the item to the Trash.

The item stays in the Trash (and continues to occupy disk space) until you 
open the Special menu and choose Empty Trash.

<Dimmable Button Data> "Huh?","Definitions disk space"
<END PANEL>

<DEFINE PANEL> "Sharing software: locate"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Locate the Sharing Setup control panel, the Users & Groups control panel, or 
both. They are part of the system software that came with your computer.

If you can’t find the software, click Huh? below for instructions.
<Dimmable Button Data> "Huh?","Definitions Tips for finding items"

<END PANEL>

<DEFINE PANEL> "Keyboard: segue to install"
<FORMAT> "Full"
The software you need, Keyboard control panel, is not installed. You need to install this 
software before you can complete this task.

<PANEL PROMPT> "Prompt Override: 8"
<END PANEL>

<DEFINE PANEL> "Keyboard: locate"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Locate the Keyboard control panel. It’s part of the system software that came 
with your computer.

If you can’t find the control panel, click Huh? below for instructions.
<Dimmable Button Data> "Huh?","Definitions Tips for finding items"

<END PANEL>

<DEFINE PANEL> "Keyboard icon: opening"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Open the Keyboard control panel.

<COACH MARK> "Finder Coach Keyboard"
<END PANEL>

<DEFINE PANEL> "Easy Access: segue to install"
<FORMAT> "Full"
The software you need, Easy Access control panel, is not installed. You need to install 
this software before you can complete this task.

<PANEL PROMPT> "Prompt Override: 8"
<END PANEL>



<DEFINE PANEL> "Easy Access: locate"



<FORMAT> "Tag"
Do This

<FORMAT> "Body"
Locate the Easy Access control panel. It’s part of the system software that 
came with your computer.

If you can’t find the control panel, click Huh? below for instructions.
<Dimmable Button Data> "Huh?","Definitions Tips for finding items"

<END PANEL>

<DEFINE PANEL> "Mouse Keys: intro"
<FORMAT> "Full"
You can use Mouse Keys to control pointer movement from the numeric keypad. (If your 
keyboard has no numeric keypad, you cannot use Mouse Keys.)

You turn Mouse Keys on or off in the Easy Access control panel. When Mouse Keys is 
on, the mouse or trackball still works.

<PANEL PROMPT> "Prompt Override: 8"
<On Panel Create> DoAppleScript(":Open AppleScripts:Null AS script")
<END PANEL>

<DEFINE PANEL> "Mouse Keys: on or off"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Click the appropriate buttons to turn Mouse Keys on or off, to set the delay 
before the pointer starts to move, and to set the maximum speed of the pointer.

You can also turn Mouse Keys on or off by pressing †-Shift-Clear.
<COACH MARK> "Item:Easy Access:Mouse Keys on/off"

<END PANEL>

<DEFINE PANEL> "Mouse Keys: diagram"
<FORMAT> "Full"
With Mouse Keys on, you can
move the pointer in different
directions by holding down the
appropriate keys.

You use the 5 key to click, and
the 0 key to drag. The decimal
point (.) key turns off dragging.

<FORMAT> "ResetPen"
<PICT> 1010, Point(200,10)

<PANEL PROMPT> "Prompt Override: 4"
<END PANEL>

<DEFINE PANEL> "Guest icon: open"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Open the Guest icon.

<END PANEL>



<DEFINE PANEL> "Drag copy: select item"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Select the text, image, or other item you want to copy.

(The way you select the item depends on the program you’re using. See the 
program’s instructions if you don’t know how to select an item.)

The item is highlighted when you select it.
<Dimmable Button Data> "Huh?","Definitions highlighting"

<END PANEL>

<DEFINE PANEL> "move outro tip"
<FORMAT> "Tag"

Tip

<FORMAT> "Body"
You can’t drag an item out of the Launcher window. To move or throw away 
an item in the Launcher, locate the item in the Launcher Items folder (inside 
the System Folder). Then move it to a new location or drag it to the Trash.

<PANEL PROMPT> "Prompt Override: 10"
<Dimmable Button Data> "Huh?","Definitions Launcher"

<END PANEL>

<DEFINE PANEL> "initialize: floppy1"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Type a name for the disk.

<COACH MARK> "Item:Erase dialog:Name field"
<END PANEL>

<DEFINE PANEL> "initialize: floppy3"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Click Continue.

(Clicking Cancel stops initialization and ejects the disk.)
<COACH MARK> "Item:Erase dialog:Continue button"

<END PANEL>

<DEFINE PANEL> "initialize: DOS floppy1"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Type a name for the disk.

Names for DOS disks and files can have up to eight characters, followed by a 
period, followed by three more characters. A longer name will be shortened 
when viewed on a DOS computer; an exclamation mark at the beginning of a 
file name indicates that it has been shortened.

<COACH MARK> "Item:Erase dialog:Name field"



<END PANEL>

<DEFINE PANEL> "Apple II: intro choice"



<FORMAT> "Full"
You can use files and disks from Apple II computers using the ProDOS operating system 
and you can prepare a disk in Apple II ProDOS format.

Which do you want to do?  Click one:
<RADIO BUTTON> "open an Apple II ProDOS file", true,,, ,APPLEGUIDE
<RADIO BUTTON> "use a ProDOS disk", false,,, ,APPLEGUIDE
<RADIO BUTTON> "prepare a disk in ProDOS format", false,,, ,APPLEGUIDE
<Dimmable Button Data> "Huh?","Definitions initializing"

<END PANEL>

<DEFINE PANEL> "Apple II file: intro"
<FORMAT> "Full"
You can open an Apple II ProDOS file on the Macintosh if one of your application 
programs can read the file or if you have a translator to convert the file.

<END PANEL>

<DEFINE PANEL> "Apple II file: open"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Double-click the icon of the ProDOS file you want to open.

When you double-click, either the file opens in one of your Macintosh 
programs, or a message appears.

(If you can’t locate the file you want to open, click Huh? below for 
instructions.)

<Dimmable Button Data> "Huh?","Definitions Tips for finding items"
<END PANEL>

<DEFINE PANEL> "Apple II file: choose app"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Read the message, then choose the name of the program with which you want 
to open the ProDOS file and click Open.

If the message doesn’t list any programs, none of your programs may be able 
to open the file, or you may need to turn on the Macintosh Easy Open control 
panel.

<END PANEL>

<DEFINE PANEL> "Easy Open: options summary"



<FORMAT> "Tag"
Do This

<FORMAT> "Body"
Make sure the On button is highlighted.

For a maximum number of programs that might open an Apple II ProDOS 
file, make sure that all four boxes contain an X. (You can get a definitions of 
the options by choosing Show Balloons from the Guide menu, then pointing 
to each box or its label.)

<END PANEL>

<DEFINE PANEL> "Apple II file: try again"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Double-click the ProDOS file once more.

If no programs are listed in the message that appears, the programs and 
translators you have are not able to open the file.

<END PANEL>

# [Branch for “use a ProDOS disk” begins here.]

<DEFINE PANEL> "Apple II disk: using"
<FORMAT> "Full"
Your Macintosh can recognize most Apple II ProDOS-format floppy disks. Simply insert 
the disk.

The disk’s icon appears on the desktop. You can open the disk by double-clicking its icon.

If you see a message that the disk is unreadable, the disk may have been damaged or 
formatted incorrectly. Eject the disk to avoid losing the information stored on it. 
(Initializing the disk will erase any information on it.)

<PANEL PROMPT> "Standard Prompts"
<END PANEL>

# [End of branch for “use a ProDOS disk.”]

# [Branch for “prepare a disk in ProDOS format” begins here.]

<DEFINE PANEL> "Apple II disk: preparing"
<FORMAT> "Full"
You prepare an Apple II ProDOS disk the same way you prepare a Macintosh disk—by 
initializing (or formatting) it. If the disk has been used previously, you reinitialize it.

Initializing a disk erases any information on it.
<PANEL PROMPT> "Prompt Override: 8"

<END PANEL>

<DEFINE PANEL> "insert: floppy for Apple II"



<FORMAT> "Full"
Insert a floppy disk in the disk drive. If you see a message that the disk is unreadable, you 
need to initialize it.

If the standard disk icon appears on the desktop, the disk is initialized in Macintosh 
format, and you need to erase it.

Which do you want to do? Click one:

<RADIO BUTTON> "initialize an unreadable disk", true,,, ,APPLEGUIDE
<RADIO BUTTON> "erase a disk", false,,, ,APPLEGUIDE

<END PANEL>

<DEFINE PANEL> "initialize: Apple II floppy2"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Choose the format labeled “ProDOS” (with a number for the disk capacity) 
from the pop-up menu, then click Initialize.

(If you don’t see a message asking if you want to initialize the disk, you need 
to insert a floppy disk.)

<COACH MARK> "Item:Erase dialog:Format Pop-up"
<END PANEL>

<DEFINE PANEL> "initialize: Apple II floppy3"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Choose the format labeled “ProDOS” (with a number for the disk capacity) 
from the pop-up menu, then click Erase.

<COACH MARK> "Item:Erase dialog:Format Pop-up"
<END PANEL>

# HDI open the Launcher

<DEFINE PANEL> "Launcher: intro"
<FORMAT> "Full"
The Launcher is a window on the desktop in which you can put programs, documents, 
and other items for easy access.

The Launcher is set to open automatically on some Macintosh models. If you don’t see 
the Launcher window when you turn on the computer, you can display it by opening the 
Launcher control panel.

<PANEL PROMPT> "Prompt Override: 8"
<Dimmable Button Data> "Huh?","Definitions Launcher"

<On Panel Create> DoAppleScript(":Open AppleScripts:Null AS script")
<END PANEL>

<DEFINE PANEL> "Launcher: segue to install"



<FORMAT> "Tag"
Do This

<FORMAT> "Body"
The software you need, Launcher control panel, is not installed. You need to 
install this software before you can complete this task.

<PANEL PROMPT> "Prompt Override: 8"
<END PANEL>

<DEFINE PANEL> "Launcher: locate"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Locate the Launcher control panel. It’s part of the system software that came 
with your computer.

If you can’t find the control panel, click Huh? below for instructions.
<Dimmable Button Data> "Huh?","Definitions Tips for finding items"

<END PANEL>

<DEFINE PANEL> "Launcher: open"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Double-click to open the Launcher.

Click Huh? below for instructions on adding or removing items in the 
Launcher.

<COACH MARK>  "Finder Coach Launcher"
<Dimmable Button Data> "Huh?","How do I add or remove an item in the Launcher?"
<PANEL PROMPT> "Standard Prompts"

<END PANEL>

# This panel is used in the sequence "How do I add or remove an item in the Launcher?"  to 
#  remove any circular reference.

<DEFINE PANEL> "Launcher: open, no Huh button"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Double-click to open the Launcher.

<COACH MARK>  "Finder Coach Launcher"
<END PANEL>

<DEFINE PANEL> "Launcher open: tip"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
You can set the Launcher to open when you turn on the computer (by opening 
the General Controls panel and placing an X in the box labeled “Show 
Launcher at system startup”). 

<PANEL PROMPT> "Prompt Override: 10"
<END PANEL>



<DEFINE PANEL> "TCP connection: intro"



<FORMAT> "Full"
The system software for your computer includes the MacTCP control panel, which you 
can use to specify a type of network connection and to manage transmissions over the 
network.  (TCP stands for transmission control protocol.)

You must install MacTCP with the Installer program before you can use it. (Click Huh? 
below for instructions on installing this control panel.

Because using the MacTCP control panel is technically complex, you should get 
assistance from a network administrator or other communications expert for this 
procedure.

<Dimmable Button Data> "Huh?","How do I install system software components?"
<END PANEL>

<DEFINE PANEL> "Finder hiding: intro"
<FORMAT> "Full"
Ordinarily, when you’re using an application program and you click the desktop or a disk 
or folder window or icon, the application becomes inactive and the Finder becomes the 
active program.  You can avoid inadvertently changing to the Finder from your 
application by “hiding” the Finder. 

You use the General Controls panel to hide the Finder.
<Dimmable Button Data> "Huh?","Definitions Finder"

<END PANEL>

<DEFINE PANEL> "General Controls: hide Finder"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
In the Desktop section, click to remove the X from the box labeled “Show 
Desktop when in background.” (Clicking to put an X in the box keeps the 
Finder icons visible at all times.)

When the Finder is hidden, disk icons and the Trash icon do not show on the 
desktop. You can click anywhere on the screen and still be in the program 
you’re using.  (If you click inside the window for another program, you switch 
to that program.)

The Finder remains hidden until you choose it from the Application menu (at 
the upper-right corner of the screen).

<COACH MARK> "WIND:Rect:GeneralCP:HideFinder"
<END PANEL>

# Panels for the question  "How do I install system software components?"  

<DEFINE PANEL> "install system: intro choice"



<FORMAT> "Full"
Occasionally you may need to install a component of the system software (such as a 
printer driver or a control panel) or reinstall the complete system software.  

You use the Installer program to install part or all of the system software. (The Installer 
program is usually stored on disk number 1 or in a folder with “Install” in its name.)

Which do you want to do? Click one:

<RADIO BUTTON> "Install only part of system software", true,,, ,APPLEGUIDE
<RADIO BUTTON> "Install the complete system software", false,,, ,APPLEGUIDE

<END PANEL>

<DEFINE PANEL> "install: part only"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
To install part of the system software, you use Custom Install in the Installer 
program (by choosing Custom Install from the pop-up menu at the upper-left 
corner of the window).

Custom Install displays a list of components. Click the triangle at left to 
expand the list, then select the items you want to install. (Hold down the Shift 
key to select multiple items.)

Click the Installer’s Help button for information (Macintosh Guide is not 
available). After the computer restarts, return to Macintosh Guide.

<END PANEL>

<DEFINE PANEL> "install: complete"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
To install the complete system software, you use Easy Install in the Installer 
program. Use the Switch Disk button to select the correct disk, then click 
Install.  On-screen messages direct you through the installation process.

Easy Install gives you the recommended set of components for your 
Macintosh model. It doesn’t install all possible components. 

If you want to assemble a customized set of system software components, you 
can choose Custom Install in the pop-up menu, select items from the list, and 
then click Install.

<END PANEL>

# Panels for the sequence "How do I create a folder?"
<DEFINE PANEL> "create folder: intro"



<FORMAT> "Full"
You can use folders to organize your files and to share files with others on a network.

You create new folders when you are using the Finder.
<Dimmable Button Data> "Huh?","Definitions Finder"

<END PANEL>

<DEFINE PANEL> "File: choose New Folder"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Open the File menu and choose New Folder.

A new folder appears in the active window. The folder has “untitled folder” in 
its name, and the name is selected.

If you need instructions on choosing a menu item, click Huh? below.
<COACH MARK>  "Menu:MACS:File:New Folder"
<Dimmable Button Data> "Huh?","Why can’t I choose a menu item?"

<END PANEL>

<DEFINE PANEL> "folder: name it"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Type a name for the new folder.

If the folder’s name is not selected, click the name (not the icon) to select it, 
and then type the name.

You can drag documents, programs, or other folders to the folder’s icon to 
store or copy them in it. You can also share the contents of a folder. (Click 
Huh? below for instructions on sharing a folder.)

<Dimmable Button Data> "Huh?","How do I give others access to my files?"
<PANEL PROMPT> "Prompt Override: 24"

<END PANEL>

<DEFINE PANEL> "create folder: tip"
<FORMAT> "Tag"

Tip

<FORMAT> "Body"
When you view the contents of a disk or folder window as a list, you can see 
the names of all items at once by clicking the triangle to the left of each 
folder’s name. 

Click Huh? below for more information about viewing a window’s contents as 
a list.

<Dimmable Button Data> "Huh?","How do I change how window items appear?"
<PANEL PROMPT> "Prompt Override: 10"

<END PANEL>

# Memory/HDI manage Power Macintosh memory? 

<DEFINE PANEL> "Power Mac: memory intro"



<FORMAT> "Full"
If you find that you are running out of memory when you use Power Macintosh 
programs, try turning on virtual memory.

Virtual memory is space on your hard disk that your computer uses as if it were random-
access memory (RAM). This memory-expanding feature is especially useful for Power 
Macintosh programs, which are often larger and require more memory than earlier 
Macintosh programs.

<Dimmable Button Data> "Huh?","Definitions random-access memory (RAM)"
<END PANEL>

<DEFINE PANEL> "Power Mac: VM tips1"
<FORMAT> "Full"
For instructions on turning on virtual memory, click Huh? below. Keep this window open 
to read the tips for setting virtual memory for your computer. (Drag this window to the 
side if it covers what you want to see.)

• Do not use the preset amount of virtual memory (twice your computer’s built-in RAM). 
Instead, start by setting it to 1 megabyte (MB) more than the amount of RAM in your 
computer.

• If your program still runs out of memory, increase virtual memory by 2 MB and try 
again. Continue making 2 MB increases until you can use the program.

<Dimmable Button Data> "Huh?","How do I use hard disk space as memory?"
<PANEL PROMPT> "Prompt Override: 35"

<END PANEL>

<DEFINE PANEL> "Power Mac: tips2"
<FORMAT> "Tag"

Tip

<FORMAT> "Body"
When virtual memory is turned off, you can find out how much less RAM a 
program would require with virtual memory turned on. This information is at 
the bottom of the program’s Info window (which you open by selecting the 
program’s icon and choosing Get Info from the File menu). 

When virtual memory is on, the Info window tells you how much more 
memory the program will require with virtual memory turned off.

<PANEL PROMPT> "Prompt Override: 10"
<END PANEL>

# Panels for the sequence "How do I   write notes while using any program  ?"  

<DEFINE PANEL> "notes: intro"



<FORMAT> "Full"
You can use either of two programs, Stickies and Note Pad, to write brief notes as you 
work.  

Both programs are available in the Apple menu.
<PANEL PROMPT> "Prompt Override: 6"

<END PANEL>

# Panels for the sequence "How do I disable buttons on the computer’s front?"

<DEFINE PANEL> "Buttons off: intro"
<FORMAT> "Full"
Some Macintosh models have buttons on the computer’s front panel for adjusting screen 
brightness and sound volume. 

If your computer has these controls, you can disable the buttons so that adjustments of the 
screen and sound can be made only with control panels. You use the Button Disabler 
control panel to turn off the buttons.

<END PANEL>

<DEFINE PANEL> "Button Disabler: NoCanDo"
<FORMAT> "Full"
The Button Disabler control panel is designed for use only with some Macintosh 
models. It is not in the Control Panels folder on your computer, which probably means 
that this control panel does not work with your Macintosh.

If you aren’t sure whether you can use this control panel with your Macintosh, click Huh? 
below for more information.

<PANEL PROMPT> "Prompt Override: 4"
<Dimmable Button Data> "Huh?","Definitions Control panels and your Macintosh model"

<END PANEL>

<DEFINE PANEL> "Button Disabler: open"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Open the Button Disabler control panel.

<COACH MARK> "Finder Coach Button Disabler"
<Dimmable Button Data> "Huh?","How do I open an Item?"
<END PANEL>

<DEFINE PANEL> "Button Disabler: click"
<FORMAT> "Tag"

Do This

<FORMAT> "Body"
Click to place an X in the box labeled “Disable Buttons.”

The buttons remain off until you turn them on again (by clicking to remove 
the X from the box).

<PANEL PROMPT> "Standard Prompts"



<END PANEL>

<DEFINE PANEL> "Icons: set colors to 16"
<FORMAT> "Full"
Your monitor must be set to display at least 16 colors or grays (using the Monitors 
control panel) before you can change the color of an icon.

For instructions on setting the monitor to display colors, click Huh? below.
<Dimmable Button Data> "Huh?","How do I display colors or grays?"

<END PANEL>


