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# The following panels are used more than once

<DEFINE PANEL> "Click pair"

<FORMAT> "Tag"
Do this

<FORMAT> "Body"
In the File Assistant Setup window, click one of the linked files 
or folders. (Clicking either one selects the entire pair.)

<END PANEL>

<DEFINE PANEL> "File menu: choose Preferences"

<FORMAT> "Tag"
Do This

<FORMAT> "Body"
Choose Preferences from the File menu.

<COACH MARK> "File:Preferences"
<END PANEL>

<DEFINE PANEL> "Window: Show Setup"
<FORMAT> "Tag"

Do this
<FORMAT> "Body"
Choose Show Setup Window from the Window menu.

<COACH MARK> "Window:Show Setup Window"
<END PANEL>

# General information about PowerBoat

<DEFINE PANEL> "About PowerBoat 1"



<FORMAT> "Full"
You use the PowerBook File Assistant to synchronize files and folders. The items 
you synchronize can be on the same computer or on different computers.

If you use a computer that has more than one hard disk, you can synchronize 
files with copies stored on different disks.

When you synchronize two files or folders, any changes you make to the first file 
are also made to the file it is linked to.

The panels that follow summarize how to synchronize files or folders.
<END PANEL>

<DEFINE PANEL> "About PowerBoat 2"

<FORMAT> "Full"
There are three general steps in synchronizing files or folders:

• Set up a link between two files or two folders.

If you are linking files the two copies must have identical names. If you are linking 
folders they can have different names.

<END PANEL>

<DEFINE PANEL> "About PowerBoat 3"

<FORMAT> "Full"
• Decide the direction of the link.

You can make a link one-way, so that one copy in the pair is the master. Changes 
to the master file or folder are always made to the other copy in the pair.

You can also make a link two-way, so that both copies are always updated when 
either one is changed.

<END PANEL>

<DEFINE PANEL> "About PowerBoat 4"



<FORMAT> "Full"
• Update the pair.

You can choose to update linked files or folders automatically each time changes 
are made. If the two copies are on different computers on a network, you can 
designate that the linked items should be updated whenever your computer is 
connected to the network.

You can also choose to update linked items manually.

For more detailed information about the PowerBook File Assistant, see the other 
Guide questions. If this is the first time you’ve used the File Assistant, choose 
“How do I link files or folders?”

<END PANEL>

# Setting up a link

<DEFINE PANEL> "Set up both computers"

<FORMAT> "Full"
Before you begin: If you are linking files or folders on different computers, set up 
both computers. If the two computers are on a network, turn on file sharing. For 
information on file sharing, go to the Finder and choose Macintosh Guide from 
the Guide menu (marked with the ? icon). 

If you need to connect your PowerBook directly to your desktop Macintosh (using 
a SCSI cable), shut down both computers first. See your PowerBook user’s guide 
for instructions. Return to these instructions when both computers are set up and 
turned on.

<END PANEL>

<DEFINE PANEL> "Link files: begin"



<FORMAT> "Full"
Before you can synchronize files or folders, you need to link them. Linking joins 
two copies of a file or folder together. When you later synchronize the two copies, 
if one has been modified, the other is also changed.

Files cannot be linked if they are not identical copies. Folders do not have to be 
identical to be linked. (See the Guide question “How do I link folders with different 
names?”)

The steps that follow describe how to link files or folders.

<PANEL PROMPT> "Finder Prompts"
<END PANEL>

<DEFINE PANEL> "Link non-matching folders: begin"

<FORMAT> "Full"
Before you can synchronize files or folders, you need to link them. Linking joins 
two copies of a file or folder together. When you later synchronize the two copies, 
if one has been modified, the other is also changed.

The steps that follow describe how to link folders with different names.

<PANEL PROMPT> "Finder Prompts"
<END PANEL>

<DEFINE PANEL> "Link files: locate empty pair"

<FORMAT> "Tag"
Do This

<FORMAT> "Body"
In the File Assistant Setup window, locate a pair of boxes 
labeled “no item selected.” If the window already contains 
linked pairs of files or folders, you may need to scroll the 
window.

<END PANEL>

<DEFINE PANEL> "Link files: click left-hand box"

<FORMAT> "Tag"
Do This

<FORMAT> "Body"
Double-click the left-hand box. From the box that appears, 
choose one of the files or folders you want to link. Then click 
Select. (Note: as an alternative, you can drag the file to the 
selection box.)



<END PANEL>

<DEFINE PANEL> "Link files: click right-hand box"

<FORMAT> "Tag"
Do This

<FORMAT> "Body"
Double-click the right-hand box. From the box that appears, 
choose the other file or folder you want to link. Then click 
Select. (Note: as an alternative, you can drag the file to the 
selection box.)

<END PANEL>

<DEFINE PANEL> "Link files: end"

<FORMAT> "Full"
The two files or folders are now linked. Another pair of boxes (labeled “no item 
selected”) appears for you to use if you want to link more files or folders.

The linked pair is set to “two-way” linking. Changes to either item are made to the 
other whenever you synchronize them.

If you want to change the direction of the link, click Continue. Otherwise, you’re 
done.

<3D BUTTON> 1070,1072, CENTER, LaunchNewSequence("How do I set the direction of a 
link?")
<PANEL PROMPT> "End"

<END PANEL>

# Setting the direction of the link

<DEFINE PANEL> "Set direction: begin"



<FORMAT> "Full"
Once two copies of a file or folder are linked, you can choose a direction for the 
link:

•Two-way linking updates either copy in the pair when its partner changes. Links 
are always two-way unless you change them.

Important: if a link is two-way, and both copies in a pair have changed, the File 
Assistant can’t update the files.

• One-way linking (left to right or right to left) makes one copy the “master”: any 
changes you make to it are automatically made to its partner.

The steps that follow describe how to change the direction of a link.
<END PANEL>

<DEFINE PANEL> "Set direction: end"

<FORMAT> "Tag"
Do this

<FORMAT> "Body"
Open the Synchronize menu and choose the direction you 
want.

• Choose Two Way to update either file when its partner 
changes.

• Choose Left To Right or Right To Left if you want one copy to 
be the “master”: any changes you make to it are automatically 
made to its partner.

<COACH MARK> "Synchronize"
<END PANEL>

# Synchronizing a pair of files

<DEFINE PANEL> "Before you update"



<FORMAT> "Full"
Before you begin: If you are synchronizing files or folders on different computers, 
set up both computers. If the two computers are on a network, turn on file 
sharing. For information on file sharing, go to the Finder and choose Macintosh 
Guide from the Guide menu (marked with the ? icon).  

If you need to connect your PowerBook directly to your desktop Macintosh (using 
a SCSI cable), shut down both computers first. See your PowerBook user’s guide 
for instructions. Return to these instructions when both computers are set up and 
turned on.

<END PANEL>

<DEFINE PANEL> "Update files: begin"

<FORMAT> "Full"
You can synchronize items that you linked in the File Assistant Setup window. 
When you synchronize linked items, changes made to one item are also made to 
the other, depending on how you set the direction of the link.

You can set the File Assistant to synchronize files either manually or 
automatically. Which do you want to do? Click one:

<RADIO BUTTON> "Synchronize manually", true,,,,APPLEGUIDE
<RADIO BUTTON> "Synchronize automatically", false,,,,APPLEGUIDE

<END PANEL>

<DEFINE PANEL> "Update files manually: begin"

<FORMAT> "Full"
When you choose to synchronize manually, you decide when you want to 
synchronize linked items.

<PANEL PROMPT> "Finder Prompts"
<END PANEL>

<DEFINE PANEL> "Update files manually: end"

<FORMAT> "Tag"
Do This

<FORMAT> "Body"
Click the arrow in the File Assistant Setup window.

You can also manually update files that are linked by selecting 
the pair and choosing Synchronize Now from the Synchronize 
menu.



<END PANEL>

<DEFINE PANEL> "Update files automatically: begin"

<FORMAT> "Full"
When you choose to synchronize automatically, changes made to one linked 
item are automatically made to the other.

If you like, you can also set linked items to be synchronized every time you 
connect with another disk.

<PANEL PROMPT> "Finder Prompts"
<END PANEL>

<DEFINE PANEL> "Update files automatically: click arrow"

<FORMAT> "Tag"
Do This

<FORMAT> "Body"
Open the Synchronize menu and choose Automatic.

From now on, the selected linked items will be synchronized 
whenever changes are made. A message will appear when 
files are being synchronized.

<COACH MARK> "Synchronize:Automatic"
<END PANEL>

<DEFINE PANEL> "Update files automatically: end"

<FORMAT> "Tag"
Tip

<FORMAT> "Body"
To set up your system to automatically synchronize linked 
items whenever you reconnect to shared disks, select the 
linked items and choose Automatic from the Synchronize 
menu, as just described. Then set the AutoRemounter control 
panel to automatically reconnect to shared disks, and drag an 
alias of the PowerBook File Assistant icon to the Startup items 
folder.

Whenever AutoRemounter connects your PowerBook to 
shared disks, all automatically linked items are synchronized.

<PANEL PROMPT> "Finder Prompts"



<END PANEL>

# Deleting a link

<DEFINE PANEL> "Delete a link: begin"

<FORMAT> "Full"
If you don’t want to synchronize linked items anymore, you can delete the linked 
items from the File Assistant Setup window. Deleting a link does not remove the 
linked files or folders from your system.

The steps that follow describe how to delete a link.
<END PANEL>

<DEFINE PANEL> "Delete a link: click pair"

<FORMAT> "Tag"
Do This

<FORMAT> "Body"
In the File Assistant Setup window, click one of the linked 
items. (Clicking either one selects both.)

To select more than one pair, hold down the Shift key and click 
other pairs.

To select all pairs, open the Edit menu and choose Select All.
<END PANEL>

<DEFINE PANEL> "Delete a link: end"

<FORMAT> "Tag"
Do This

<FORMAT> "Body"
Open the Edit menu and choose Delete Pairs.

The pairs you selected are deleted from the Setup window. 
(The files or folders in the pair are not thrown away—but they 
are no longer linked.)

<COACH MARK> "Edit:Delete Pairs"
<END PANEL>

# Turning alert messages on and off

<DEFINE PANEL> "Turn alerts on/off: begin"



<FORMAT> "Full"
As you synchronize linked items, the File Assistant displays alert messages 
about the process. You can turn off the alert messages.

The steps that follow describe how.
<END PANEL>

<DEFINE PANEL> "File menu: choose Preferences:set alerts"

<FORMAT> "Tag"
Do this

<FORMAT> "Body"
Choose Preferences from the File menu; then click to remove 
the X from the “Warn when can’t synchronize” checkbox, the 
“Warn before deleting” checkbox, or both.

Click OK after you make your selections.
<COACH MARK> "File:Preferences"
<END PANEL>

<DEFINE PANEL> "Turn alerts on/off: important"

<FORMAT> "Full"
Important: Be very careful if you turn off the “Warn before deleting” alert 
message. The File Assistant puts out-of-date items in the Trash during 
synchronization.

<END PANEL>

# Linking non-matching folders

<DEFINE PANEL> "File menu: choose Preferences:non-matching"

<FORMAT> "Tag"
Do this

<FORMAT> "Body"
Choose Preferences from the File menu, and click the 
checkbox “Allow non-matching folder names” to put an X in it. 
Then click OK.

<COACH MARK> "File:Preferences"
<END PANEL>

# File synchronization definition

<DEFINE PANEL> "Def: File Synch"



<FORMAT> "Full"
File synchronization keeps two copies of the same file or folder up to date. If two 
copies of a file are synchronized, when you change one copy the other is 
automatically updated.

Synchronizing files is especially helpful if you frequently use two computers. If 
you use a PowerBook with a desktop Macintosh, DuoDock, or network file server, 
you may want to keep identical copies of a file or folder in both places.

<END PANEL>


