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#

# The beginning of the reference portion of PowerTalk Basics
#

# TR

# The following panels are for “PowerTalk Overview” reference
# HHHHHHHHHH R

<DEFINE PANEL> "PowerTalk overview: 1"
PowerTalk system software helps people to work together — to collaborate — more effectively.
PowerTalk software provides the foundation for software products that give you new ways to
correspond with others, safeguard your communication, access information on other computer
systems, and automate routine activities.

<dimmable button data> "Huh?", "Definition of collaboration services"

<DEFINE PANEL> "PowerTalk overview: 3"
When you install PowerTalk, a new item appears in the Apple menu — Mail and Catalogs.
Mail and Catalogs contains AppleMail, Find in Catalog, and Personal Catalog.

<coach mark> "apple-mail and catalogs"

<DEFINE PANEL> "PowerTalk overview: 2"
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After you install and set up PowerTalk, a new item appears in Mail and Catalogs — Key Chain.

Key Chain allows you to gain access to all your accounts and services by typing a single
password.

<coach mark> "apple-mail and catalogs"
<dimmable button data> "Huh?", "Definition of Key Chain"

<DEFINE PANEL> "PowerTalk overview: 4"

AppleMail is a simple application program you can use to create, send, read, and respond to
letters and enclosures.

<dimmable button data> "Huh?", "Definition of AppleMail"

<DEFINE PANEL> "PowerTalk overview: 5"
You can use Find in Catalog to quickly find a name or address.
Personal Catalog allows you to quickly access frequently used items and addresses.

<dimmable button data> "Huh?", "Definition of personal catalog"

<DEFINE PANEL> "PowerTalk overview: 6"

When you install PowerTalk, an icon named “Mailbox” appears on your desktop. After you set up
PowerTalk, the name of the mailbox icon changes to your name.

The Mailbox contains all your incoming and outgoing mail.

# NEED TO ADD COACH FOR MAILBOX ICON ON DESKTOP
# We can't coach PowerTalk desktop icon
<dimmable button data> "Huh?", "Definition of mailbox"

<DEFINE PANEL> "PowerTalk overview: 7"
When you install PowerTalk, the Catalogs icon appears on your desktop.
Catalogs provides access to information you need to communicate with individuals and groups.

# NEED TO ADD COACH FOR CATALOGS ICON ON DESKTOP
# We can't coach PowerTalk desktop icon
<dimmable button data> "Huh?", "Definition of catalog"
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<DEFINE PANEL> "PowerTalk overview: 8"

The DigiSign Utility installed by PowerTalk can be used to request approval of a Signer file which
can be used to approve, or “sign,” a document on your computer. Putting your digital signature on
a document ensures the integrity of the document.

<coach mark> "finder DigiSign icon"
<dimmable button data> "Huh?", "Digital Signatures Overview"

<DEFINE PANEL> "PowerTalk overview: 9"

You can use PowerTalk system software on an AppleTalk network, whether or not you have
PowerShare servers or other file servers connected to the network. You can send mail directly to
any PowerTalk-equipped computer connected to an AppleTalk network.

If you add PowerShare servers to your network, you gain additional catalog and mail delivery
services, as well as added security and privacy for your correspondence.

<dimmable button data> "Huh?", "Definition of PowerShare server"

#

# The beginning of the “How do I” portion of PowerTalk Basics

#

# HE B R

# The following panels are for “How do | set up PowerTalk software?”
# HEHHHH R T R R

<DEFINE PANEL?> "set up PowerTalk: choices"
You only need to set up PowerTalk software once. When you set up your software, you need to
know whether you have a PowerShare server account. If you aren’t sure, ask your system
administrator.

How do you want to set up? Click one:

<radio button> "with a PowerShare server account", true,,,,appleguide
<radio button> "without a PowerShare server account", false,,,,appleguide
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<DEFINE PANEL> "Special: choose Unlock Key Chain"

Do This

Open the Special menu and choose Unlock Key Chain.

<coach mark> "special-unlock key chain"

<DEFINE PANEL> "set up PowerTalk: click Proceed"

Do This
Read the screen and click Proceed.

# Shemin, coach the Proceed button on the dialog
# | don't know if we can coach it

<DEFINE PANEL> "set up PowerTalk: click Yes"

Do This

A dialog box appears, asking if you have a PowerShare account.

Click Yes.

# Shemin, coach the Yes button on the dialog
# | don't know if we can coach it

<DEFINE PANEL> "PowerShare server: select"

Do This

The computer searches for the PowerShare services available to you.

When the navigation dialog box appears, select the PowerShare service you want to access and
click OK.
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<DEFINE PANEL> "PowerShare account: type name and password"

Do This

Type your name and password as set up by your system administrator, then click OK.

# Shemin, coach the name and password blocks for typing

<DEFINE PANEL> "Key Chain Access Code: setting"

Do This

Read the screen and click OK.
PowerTalk initially sets your key chain access code to your PowerShare password.
If you want to change your access code, click Huh? below for instructions.

<Dimmable Button Data> "Huh?","How do | change my access code?"

<DEFINE PANEL> "Mailbox: name changed"

<panel prompt> "read & click"

Notice

Your PowerTalk software is set up.
After you set up PowerTalk, your Mailbox is renamed with your name.

<Dimmable Button Data> "Huh?","Definition of mailbox"

<DEFINE PANEL> "Computer name: confirm"

<panel prompt> "override: rdone"
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If you are on an AppleTalk network, the name of your computer will appear in the AppleTalk
catalog. People can send you mail at this “address” without a PowerShare server.

If you want to change the name of your computer, click Huh? below for instructions.

<Dimmable Button Data> "Huh?","How do | name my computer?"

<DEFINE PANEL> "set up PowerTalk: click No"

Do This

A dialog box appears, asking if you have a PowerShare account.
Click No.

# Shemin, coach the No button on the dialog

<DEFINE PANEL?> "Key Chain: type name and access code"

Do This

Type your name and the access code you want to use, then click OK.

# Shemin, coach the name and access code blocks for typing

<DEFINE PANEL> "Key Chain Access Code: confirm"

Do This

When the confirmation dialog box appears, type your access code again and click OK.

Read the new screen and click OK.

<DEFINE PANEL> "Date & Time: confirm"
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Do This

Read the screen and click OK.
Make sure the date, time, and time zone are all set correctly.
If you need to reset the time or date, click Huh? below for instructions.

<Dimmable Button Data> "Huh?","How do | set the time and date?"

HEHHH R T A R
The following panels are for “How do | turn on AppleTalk?”
HHHHHHHH AR

H*H H FH

<DEFINE PANEL> "AppleTalk: active"

AppleTalk is already active.

<DEFINE PANEL> "Apple: choose Chooser"

Do This

Open the Apple (O0) menu and choose Chooser.

<COACH MARK>"Menu:Front:Apple:Chooser"

<DEFINE PANEL> "Chooser: click AppleTalk Active"
<PANEL PROMPT> "Prompt Override: 27"

Do This

In the lower-right area of the Chooser, click the AppleTalk Active button to place a dot in it.

AppleTalk becomes active after you restart the computer (by choosing Restart from the Special
menu).

<COACH MARK>"CoachMark: 152"
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<DEFINE PANEL> "Chooser: close"

Do This

Close the Chooser by clicking the close box at the upper-left corner.

<COACH MARK>"CoachMark: 155"

M
The following panels are for “How do | make an information card for myself?”
HEHHH R T R

H H* FH

<DEFINE PANEL?> "info card for me: intro"
PowerTalk introduces a new kind of document — an information card. Each information card is a
collection of data about a person, place, or thing or a group of people, places, and things. An
information card can reside in catalogs available on your desktop, on a network, or anywhere on
a disk.

<Dimmable Button Data> "Huh?","How do | use information cards?"

<DEFINE PANEL> "PowerTalk folder: open"

Do This

Open the PowerTalk folder.

If you can’t find the PowerTalk folder, click Huh? below for instructions.

<coach mark> "finder PowerTalk folder"
<Dimmable Button Data> "Huh?","Definitions Tips for finding items"

<DEFINE PANEL> "untitled Info Card: select and rename"
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Do This

Do This

Select the Untitled Info Card in the PowerTalk folder.
Type your name as its title.

If you can't find the Untitled Info Card, click Huh? below for instructions on how to create a new
information card.

<coach mark> "finder Untitled Info"
<Dimmable Button Data> "Huh?","How do | create an information card?"

<DEFINE PANEL> "Untitled Info Card: open & select additional page"

Do This

Do This

Open the information card and add your information to the first “page.”

Use the pop-up menu to switch to the appropriate page to add personal info, phone numbers, and
electronic addresses.

If you need more information about modifying an information card, click Huh? below for
instructions.

# COACH POP-UP MENU ON INFORMATION CARD IF CAN CONTEXT CHECK TO MAKE SURE IT IS OPEN
<Dimmable Button Data> "Huh?","How do | modify an information card?"

W
The following panels are for “How do | send letters and documents?”
HHAHHH PR R

o

<DEFINE PANEL> "howdoi: send: begin"

You can send a document that you already have, or you can use the AppleMail application
program to write and send a letter. Which do you want to do?

<radio button> "Send an existing document"”, true,,,,appleguide
<radio button> "Write and send a letter", false,,,,appleguide
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<DEFINE PANEL> "locate info card"

Do This

Locate the info card or alias of the person to whom you want to send a document.
If you can’t find the info card or alias of the person, click Huh? below for instructions.

<Dimmable Button Data> "Huh?","How do | find an item in a catalog?"

<DEFINE PANEL> "locate document"

Do This

Locate the document you want to send.

<DEFINE PANEL> "drag document to card"

Do This

Drag the document to the information card of the person to whom you want to send the
document.

In the dialog box that appears, click OK.

<DEFINE PANEL> "use AppleMail"

Do This

Use the AppleMail application program to write and send your letter.
To locate AppleMail, open the Apple menu and choose Mail and Catalogs.

For help using AppleMail, choose AppleMail Guide from the Guide menu (on the right, with the ?
icon) after you open AppleMail.
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HEHHHH R T R R

The following panels are for “How do | read my incoming mail?”
Added from “Sending and Receiving”

HEHEHHHHEHEHEH

HHHH

<DEFINE PANEL> "howdoi: read my mail: begin"
The PowerTalk mailbox provides a single place for you to receive all of your electronic mail.
AppleMail documents and documents sent to you via direct AppleTalk mail are stored in your
mailbox.

When you install other kinds of PowerTalk-compatible collaboration software, you may receive
additional kinds of messages in your mailbox.

<DEFINE PANEL> "howdoi: read my mail: open mailbox"

<panel prompt> "override: right"

Do This

Open your PowerTalk mailbox.

Your PowerTalk mailbox is on your desktop. It is labeled with your name (or the name you used
when you set up PowerTalk).

<DEFINE PANEL?> "howdoi: read my mail: enter access code"

Do This

Type your access code in the box.
Be sure to type it exactly as you did when you set up PowerTalk, including capital letters.

<coach mark> "enter access code item"

<DEFINE PANEL> "howdoi: read my mail: read mail"
<panel prompt> "override: ddone"
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Do This

Open the documents you want to read.

HHH AR R
The following panels are for “How do | change my access code?”
HHHHHHHH AR

H H H*

<DEFINE PANEL> "howdoi: change access code: begin"

Your access code is a special password that keeps your PowerTalk key chain and collaboration
services secure.

You use the key chain to change your access code.

<dimmable button data> "Huh?", "definition of access code"

<DEFINE PANEL> "Apple: choose Key Chain"

<panel prompt> "override: right"

Do This

Open the Apple (O0) menu and choose Mail and Catalogs.
Open Key Chain.
If you can’t find the key chain, click Huh? below for instructions.

<coach mark> "apple-mail and catalogs"
<dimmable button data> "Huh?", "Why can’t | find Key Chain?"

#it The next panel is from “How do | read my incoming mail?” sequence
#it "howdoi: read my mail: enter access code"

<DEFINE PANEL> "howdoi: change access code: click change code"

Do This

Click Change Code.
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<coach mark> "change code"

<DEFINE PANEL?> "howdoi: change access code: new code"

<panel prompt> "override: tip"

Do This
Type your old access code, then press the Tab key. Your access code is replaced by bullets (¢) to
protect your privacy.

In the box labeled “New Access Code,” type the new code you want to use, then press Return (or
click the OK button). Then type the new code again, to make sure you have it the way you want.

Remember your new access code exactly, including capitalization.

<DEFINE PANEL> "howdoi: change access code: tips"

#
#
#

<panel prompt> "override: rdone"

Tips

Don’t use your name as an access code.

The longer your code is, the harder it will be to guess (it must be at least six characters).
Mix upper- and lowercase letters, and use numbers (for example, “4ME!Only%").

Make it easy to remember and don’t write it down.

Keep track of which letters are uppercase — the access code is case-sensitive.

M
The following panels are for “How do | add or remove a service?”
HEHHH R T R

<DEFINE PANEL> "add or remove services: choices"
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Your PowerTalk key chain contains your setup information for each collaboration service you use.
These services can be added or removed.

Which do you want to do? Click one:

<radio button> "add a service", true,,,,appleguide
<radio button> "remove a service", false,,,,appleguide

<DEFINE PANEL> "howdoi: add a service: begin"
To add a service to your key chain, you must first install the software for the service.

Use these instructions after you have installed new collaboration software on your hard disk.

#it The 2nd panel is the same as the second panel in the first sequence

## under this topic

#it "Apple: choose Key Chain"

#i#t The 3rd panel is from “How do | read my incoming mail?” sequence ## under this topic
## "howdoi: read my mail: enter access code"

<DEFINE PANEL> "howdoi: add a service: click add"
Do This

Do This

Click the Add button.

When a new dialog box appears, click to select the type of service you want to add, then click
OK.

What happens next depends on the kind of service you are adding. Some services require
additional setup before you can use them. See the documentation that came with your
collaboration software.

<coach mark> "add a service"

#t Panels from “How do | remove a service?”
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<DEFINE PANEL> "howdoi: remove a service: begin"

#it
#it
Hif

#i
#it
#it

Your PowerTalk key chain contains your setup information for each collaboration service you use.
The information for a service is called a “key.” You should remove a key from the key chain only
when you know you won't use that service again.

The 2nd panel is the same as the second panel in the first sequence
under this topic
"Apple: choose Key Chain"

The 3rd panel is from “How do | read my mail?” sequence under
Sending and Receiving topic
"howdoi: read my mail: enter access code"

<DEFINE PANEL> "howdoi: remove a service: select the service"

Do This

Click to select the service you want to remove.

To select more than one service, hold down the Shift key as you click each one.

<DEFINE PANEL> "howdoi: remove a service: click remove"

H H

<panel prompt> "override: ddone"

Do This

Click the Remove button to remove the service or services you selected.
When the dialog box appears, click Remove & Restart.

<coach mark> "remove a service"

HEHEHHHHEHEHE
The following panels are for “How do | lock my PowerTalk System?”
TR R
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<DEFINE PANEL> "PowerTalk: locked"
PowerTalk is already locked.
To unlock your key chain, choose Unlock Key Chain from the Special menu.

<coach mark> "special-unlock key chain"

<DEFINE PANEL> "howdoi: lock my key chain: begin"

If you are going to be away from your computer for a while, you can protect your PowerTalk
services, accounts, and information by locking your key chain.

To lock your key chain, choose Lock Key Chain from the Special menu.

<coach mark> "special-lock key chain"

HHHHHHHHH AR
The following panels are for “How do | turn PowerTalk on and off?”
HHHHHHHHH TR

H H

<DEFINE PANEL?> "howdoi: PowerTalk on and off: begin"

You use the PowerTalk control panel to turn PowerTalk on and off. PowerTalk gives you access to
collaboration services you use to communicate and work with other people.

<dimmable button data> "Huh?", "definition of PowerTalk"

<DEFINE PANEL> "Apple: choose control panels”

<panel prompt> "override: right"
Do This
Open the Apple (O0) menu and choose Control Panels.

<coach mark> "apple-control panels"

<DEFINE PANEL> "PowerTalk Setup: open"
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Do This

Open the PowerTalk Setup control panel.

<coach mark> "PowerTalk setup icon"

<DEFINE PANEL> "howdoi: PowerTalk on and off: click on and off"

Do This

Click the appropriate button to turn PowerTalk on or off.
Your new setting takes effect after you restart your computer.

<coach mark> "PowerTalk setup"

<DEFINE PANEL> "howdoi: PowerTalk on and off: close PowerTalk setup"
<panel prompt> "override: ddone"

Do This

Click the close box to close the PowerTalk Setup control panel.

<coach mark> "close box"

The beginning of the Huh? questions for PowerTalk Basics

Panels for the sequence "How do | set the time and date?"
HHHHHHHHHHHH R
The following panels are for “How do | set the time and date?”
HH AT

HHRIBEHHEHER

<DEFINE PANEL> "Date & Time: intro"

You set the time and date in the Date & Time control panel. You can also use the control panel to
change how times and dates appear.

<DEFINE PANEL?> "Date & Time: segue to install"
<PANEL PROMPT> "Standard Prompts"
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The software you need, Date & Time control panel, is not installed. You need to install this
software before you can complete this task.

<DEFINE PANEL> "Startup disk: opening"

Do This

Open the startup disk.

<COACH MARK>"Finder Desktop BootDisk"

<DEFINE PANEL?> "System Folder: locate"

Do This

Locate the System Folder on your startup disk.
Do not open the folder.

<COACH MARK>"Finder Coach System Folder"

<DEFINE PANEL> "Date & Time: locate"

Do This

Locate the Date & Time control panel. It's part of the system software that came with your
computer.

If you can't find the control panel, click Huh? below for instructions.

<Dimmable Button Data> "Huh?","Definitions Tips for finding items"

<DEFINE PANEL> "Any resource: drag"

Do This

Drag the item to the System Folder icon (not the System Folder window). If a message appears,
read it and then click OK.
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# The panel "Apple: choose Control Panels" is shared.

<DEFINE PANEL?> "Date & Time: open"

Do This

Open the Date & Time control panel.

<COACH MARK>"Finder Coach Date & Time"

<DEFINE PANEL> "Date & Time: click date"
Do This
To set the day, month, or year, click a number in the current date, and then click the arrows that
appear. (Or you can type a new number.)

<COACH MARK>"CoachMark: 11"

<DEFINE PANEL> "Date & Time: click zone"
Do This
To identify the time zone for your location, click the Set Time Zone button, choose a city that’s in
the same time zone as your current location, then click OK.

Clicking to put an X in the box labeled Daylight Savings Time adjusts the time by an hour.

<COACH MARK>"CoachMark: 12-1"

<DEFINE PANEL> "Date & Time: click time"
Do This
To set the hour, minute, or second, click a number in the current time and then click the arrows
that appear. (Or you can type a new number.)

<COACH MARK>"CoachMark: 12"

<DEFINE PANEL> "Date & Time: saving"
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Do This

To save your date and time settings, click anywhere outside the date and time boxes, or close the
control panel.

HEHHH R R T R
The following panels are for “How do | name my computer?”
HHHHHHHHH AR

H*H H

<DEFINE PANEL> "Sharing Setup: segue to install"
<PANEL PROMPT> "Standard Prompts"

The software you need, Sharing Setup control panel, is not installed. You need to install this
software before you can complete this task.

# The panel "Startup disk: opening" is shared

# The panel "System Folder: locate" is shared

<DEFINE PANEL> "Sharing Setup: locate"
Do This
Locate the Sharing Setup control panel. It's part of the system software that came with your
computer.
If you can’t find the control panel, click Huh? below for instructions.

<Dimmable Button Data> "Huh?","Definitions Tips for finding items"

# The panel "any resource: drag" is shared.

<DEFINE PANEL> "control panel: Restart for effect"
<PANEL PROMPT> "Prompt Override: 29"

Changes take effect after you restart the computer (by opening the Special menu and choosing
Restart).

After you restart, you can open the Guide menu (on the right, with the ? icon), choose PowerTalk
Guide, and return to this question.
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# The panel "Apple: choose Control Panels" is shared.

<DEFINE PANEL> "Sharing: open setup"

Do This

Open the Sharing Setup control panel.

<COACH MARK>"Finder Coach Sharing Setup"

<DEFINE PANEL?> "Sharing Setup: type name"

Do This

Type your name in the box labeled Owner Name, and press the Tab key.

<COACH MARK>"CoachMark: 97"

<DEFINE PANEL> "Sharing Setup: password intro"
<PANEL PROMPT> "Standard Prompts"

Now decide on a password, which you'll use to connect to your computer from another computer
on the network. Don’t type the password yet.

Remember your password, including capitalization. Your password can be up to eight characters
long.

For security, each character is replaced by a bullet (¢) after you type it.

<DEFINE PANEL> "Sharing Setup: type password"

Do This

Type a password in the box labeled Owner Password, and press the Tab key.

<COACH MARK>"CoachMark: 98"

<DEFINE PANEL> "sharing Setup: type computer name"
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Do This

Type a name for your computer in the box labeled Macintosh Name.
This is the name others see when they use the Chooser to connect to your computer.

<COACH MARK>"CoachMark: 99"

CataloginfoCard.panel

The panels for “Catalogs & Info Cards”
©1993 Apple Computer, Inc.

HHHFHHHR

The beginning of the “How do I” portion of Catalogs & Info Card

H H FH

HHHH R
The following panels are for “How do | browse catalog windows?”
HHH A R R

H*H H FH

<DEFINE PANEL?> "browse catalog: intro"

Do This

Open the Catalogs icon on your desktop, then open the catalog you want to look at.
If you want to know more about where catalog information is stored, click Huh? below.

<Dimmable Button Data> "Huh?","Where is catalog information stored?"

<DEFINE PANEL> "catalog folders: open"
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Do This

Open catalog folders and the folders within them until you find the information you want.

IMPORTANT: If you are not a network user, you may not be able to open some catalogs. You can
still create and use personal catalogs.

<Dimmable Button Data> "Huh?","Where is catalog information stored?"

HHHHEHH T
The following panels are for “Where is catalog information stored?”
HHH AR R

H*H H FHF

<DEFINE PANEL?> "ref: where is catalog: 1"

The location of information that is displayed when you open a catalog depends on the type of
catalog.

A personal catalog — and the information it contains — resides on your hard disk. It is like a
document or folder stored on your hard disk.

<DEFINE PANEL?> "ref: where is catalog: 2"

A catalog that displays information about a network — for example, the AppleTalk catalog — is
not stored on your hard disk. Sometimes the information resides on a specialized server
connected to the network. Sometimes the information resides on the network itself (this is how
the AppleTalk catalog works).

<DEFINE PANEL?> "ref: where is catalog: 3"

<panel prompt> "override: rdone"

If you disconnect your computer from your network, you can still see the information in your
personal catalog, but some other kinds of catalogs may be empty.

You can copy items from any catalog to your personal catalog. When you do so, the item in your
personal catalog “points to” the original item. Storing an item in your personal catalog makes it
easier to find quickly.
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# HHH R R
# The following panels are for “How do | change how catalog items appear?”
# HHHHHHHHH TR

<DEFINE PANEL> "howdoi: catalog items appear: begin"

You can change the order in which information is displayed in a catalog. You can also control
whether all available information is displayed, or just the information you want to see.

To control the way items appear in an active catalog window, you use the View menu.

<DEFINE PANEL> "howdoi: catalog items appear: open catalog"
<panel prompt> "override: right"

Do This

Open the catalog window you want to view.

You can find catalogs inside your Catalogs icon. You locate your personal catalog by opening the
Apple menu and choosing Personal Catalog from Mail and Catalogs.

<DEFINE PANEL> "howdoi: catalog items appear: use view menu"
<panel prompt> "override: ddone"

To change the order in which items appear, choose one of the first two items in the View menu.

To change the kind of information displayed, choose one of the “filters” from the second part of
the View menu.

When you choose a filter, only items of that kind are displayed in the catalog window.

<coach mark> "view-"

HHHHHHHHHHHHHH
The following panels are for “How do | find an item in a catalog?”
HHAHHHHHHHHHHH

H H*
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<DEFINE PANEL> "howdoi: find an item: begin"

You can locate items in any catalog to which you have access. You locate catalog items by
opening the Apple menu and choosing Find in Catalog from Mail and Catalogs.

<DEFINE PANEL> "Apple: choose Find in Catalog"
<panel prompt> "override: right"

Do This

Do This

Open the Apple (O0) menu and choose Mail and Catalogs.
Open Find in Catalog.

<coach mark> "apple-mail and catalogs"
<DEFINE PANEL> "howdoi: find an item: find what"
Do This
Use the Find pop-up menu to select the kind of items you want to find.
<coach mark> "find in findincatalog"
<DEFINE PANEL> "howdoi: find an item: find where"
Do This
Use the In pop-up menu to specify where you want to search.

<coach mark> "in in findincatalog"

<DEFINE PANEL> "howdoi: find an item: start with"
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Do This

Type the name of the item you want to find (or just type the first few letters of the name).

<coach mark> "start in findincatalog"

<DEFINE PANEL> "howdoi: find an item: click find"

<panel prompt> "override: ddone"

Do This

Click Find.

Found items appear in the list in the Find in Catalog window. If no matching items are found, you
hear a beep or see a message.

To copy an item, drag it from the list to another window or to the desktop.

To automatically copy an item to your personal catalog, click to select the item, then click Save.

# HHAHHHHHHHHHHH
# The following panels are for “How do | use personal catalogs?”
# HHAHHHHHHHHHHH

<DEFINE PANEL?> "ref: using personal catalogs: 1"
When you install PowerTalk system software, a personal catalog (called “Personal Catalog”) is
automatically put into Mail and Catalogs in your Apple menu. You can have as many personal
catalogs as you want. You can store personal catalogs anywhere on your hard disk, or on a
floppy disk.

If you want to know more about where catalog information is stored, click Huh? below.

<dimmable button data> "Huh?", "Where is catalog information stored?"

<DEFINE PANEL?> "ref: using personal catalogs: 2"
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One personal catalog is “preferred.” By default, the personal catalog installed in Mail and
Catalogs in your Apple menu is preferred. You can choose any other personal catalog to be
preferred. The preferred personal catalog is the one used by AppleMail and other PowerTalk-
compatible software you may have.

If you need more information about selecting a preferred personal catalog, click Huh? below for
instructions.

<dimmable button data> "Huh?", "How do | select a preferred personal catalog?"

<DEFINE PANEL?> "ref: using personal catalogs: 3"

You can use one personal catalog for all of the catalog items you want, or you can use several
personal catalogs, keeping a particular set of items in each one. For example, you might have
one personal catalog named “Business Contacts,” and another named “Friends.”

If you need more information about adding items to a personal catalog, click Huh? below for
instructions.

<dimmable button data> "Huh?", "How do | add items to a personal catalog?"

HHAHHHHHHH

The following panels are for “How do | add items to a personal catalog?”
HHHHHHHHHH AR

H H

<DEFINE PANEL?> "add items to personal catalog: intro"

There are many ways to add items to a personal catalog:

 Drag an item from a catalog directly into a personal

catalog window.

» Make an alias of a catalog item, and drag the alias into a personal catalog window.

* Choose Find in Catalog from Mail and Catalogs in the Apple menu, and click Save.

 Drag an item from the Recipients panel in the PowerTalk Mailer (click the Huh? button to find
out more about the Mailer).

<dimmable button data> "Huh?", "Definition of Mailer"

<DEFINE PANEL> "Apple: choose Personal Catalog"

<panel prompt> "override: right"
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Do This

Do This

Open the Apple (O0) menu and choose Mail and Catalogs.
Open Personal Catalog.

<coach mark> "apple-mail and catalogs"

<DEFINE PANEL?> "catalog item: drag to personal catalog"

Do This

Open a catalog window and drag the desired items into the Personal Catalog window.
This makes a copy of each item and places it in your personal catalog.

If you need more information about removing items from a personal catalog, click Huh? below for
instructions.

<dimmable button data> "Huh?", "How do | remove items from a personal catalog?"

HHHHHHHHH R
The following panels are for “How do | remove items from a personal catalog?”
HHHHHHHHH TR

H H

<DEFINE PANEL> "remove items from personal catalog: intro"

To delete any item in a personal catalog, drag the icon to the Trash and empty the Trash.

# HHHHHHHHH R
# The following panels are for “How do | create an additional personal catalog?”
# HHHHHHHHH TR

<DEFINE PANEL> "howdoi: personal catalog: begin"



PowerTalk Guide Panels 1.0b2 29 May 20, 2025

You can use a personal catalog to store catalog items (such as info cards) anywhere on your
hard disk.

You can create a new personal catalog whenever the Catalogs menu is available (the Catalogs
menu appears when you open a catalog window).

<dimmable button data> "Huh?", "definition of catalog"

<DEFINE PANEL> "howdoi: personal catalog: open catalog”
<panel prompt> "override: right"

Do This

Open the Catalogs icon.

<DEFINE PANEL?> "howdoi: personal catalog: choose new"
<panel prompt> "override: ddone"

Do This

Open the Catalogs menu and choose New Personal Catalog.

<coach mark> "catalogs-new personal”

HE B R
The following panels are for “How do | select a preferred personal catalog?”
HEHHH R T R R

H H FH

<DEFINE PANEL> "preferred personal catalog: intro"

When you have more than one personal catalog, you can select one to be preferred. The
preferred personal catalog is indicated by a bookmark icon.

Applications that incorporate PowerTalk software can easily use items in your preferred personal
catalog regardless of where it is located on your hard disk.

<DEFINE PANEL?> "personal catalog icon: select"
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Do This

Select the icon of the personal catalog that you want to make preferred.

<DEFINE PANEL> "File: choose Get Info"

Do This

Open the File menu and choose Get Info.

<coach mark> "file-get info"

<DEFINE PANEL> "personal catalog info: click Set Preferred"
Do This
Click the Set Preferred button. If there is no button, the document you selected is not a personal
catalog.

IMPORTANT: If the Locked checkbox in the catalog’s Get Info window is selected, you won't be
able to make any changes to the contents of the personal catalog.

# IF WINDOW NAME ENDS IN INFO THEN COACH SET PREFERRED BUTTON

<DEFINE PANEL> "Get Info box: close"

Do This

Close the Get Info box.

<coach mark> "closebox"

HEHEHHHHEHEHE
The following panels are for “How do | print a personal catalog?”
M

H H*

<DEFINE PANEL> "howdoi: print catalog: begin"
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You can print a list of the contents of your personal catalog.

# The panel "Apple: choose Personal Catalog" is shared

<DEFINE PANEL> "howdoi: print catalog: sort"

<panel prompt> "override: dndone"
Optional
You can use the View menu to see and print everything in your personal catalog, or only the items
you want.

To see and print everything in your personal catalog, choose All from the View menu. To see and
print only the items you want, choose a type of item from the View menu.

To change the order of items in the personal catalog window, choose By Name or By Kind from
the View menu.

<dimmable button data> "Huh?", "How do | change the way items appear in a catalog window?"
<coach mark> "view-"

<DEFINE PANEL> "File: choose Print Window"

<panel prompt> "override: ddone"

Do This

Open the File menu and choose Print Window.
When the Print dialog box appears, click Print to print your personal catalog.

<coach mark> "file-print window"

T R T
The following panels are for “How do | use information cards?”
HHHHHHHHHHH

H*H H FHF

<DEFINE PANEL?> "ref: using information cards: 1"
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An information card contains catalog information. A user’s information card can contain practically
anything, including electronic addresses, telephone numbers, and even pictures.

<dimmable button data> "Huh?", "Definition of electronic addresses"

<DEFINE PANEL?> "ref: using information cards: 2"

You can use individual information cards for communicating with people, and for looking up
information about addresses and telephone numbers. To create an information card, you open a
personal catalog and use the Catalogs menu. You can store information cards anywhere on your
hard disk or on a floppy disk.

If you need more information about creating information cards, click Huh? below for instructions.

<dimmable button data> "Huh?", "How do | create an information card?"

<DEFINE PANEL?> "ref: using information cards: 3"

<panel prompt> "override: rdone"
Group icons can be convenient for interacting with teams of people. You can create any number

of groups. You can add a person to a group by dragging that person’s information card to the
group information card. You can also add a group to another group.

If you need more information about creating group icons, click Huh? below for instructions.

<dimmable button data> "Huh?", "How do | create group icons?"

HHAHHHHHHHHHHH
The following panels are for “How do | create an information card?”
HHAHHHHHHHHHHHH

H H*

<DEFINE PANEL> "howdoi: create info card: begin"

An information card (info card) represents a person or group you communicate with. You make
info cards in your personal catalog.

<dimmable button data> "Huh?", "definition of information card"

# The panel "Apple: choose Personal Catalog” is shared



PowerTalk Guide Panels 1.0b2 33 May 20, 2025

<DEFINE PANEL> "howdoi: create info card: user or group”

You can create an info card that represents a single person, or a group of people. Which do you
want to do?

<radio button> "Create an info card for a person”, true,,,,appleguide
<radio button> "Create an info card for a group”, false,,,,appleguide

<DEFINE PANEL> "Catalogs: choose New User"

Do This
Open the Catalogs menu and choose New User.

<coach mark> "catalogs-new user"

<DEFINE PANEL> "new user info card: type name"
<panel prompt> "override: ddone"

Do This

When the new info card appears, type its name.

<DEFINE PANEL> "Catalogs: choose New Group"

Do This
Open the Catalogs menu and choose New Group.
<coach mark> "catalogs-new group"
<DEFINE PANEL> "new group icon: type name"

Do This

When the new group icon appears, type its name.
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# HHHHHHHH AR
# The following panels are for “How do | modify an information card?”
# HEHEHHHHEHEHE

<DEFINE PANEL> "howdoi: change info card: begin"

You can work with info cards in your personal catalog, or with info cards stored elsewhere on your
hard disk.

Which do you want to do?

<radio button> "Change an info card in my personal catalog", true,,,,appleguide
<radio button> "Change an info card stored elsewhere", false,,,,appleguide

# The panel "Apple: choose Personal Catalog" is shared

<DEFINE PANEL> "howdoi: change info card: find card"
Do This

Open the window containing the info cards you want to change. If the info cards are on the
desktop, make sure you can see them by closing any windows that cover them.

<DEFINE PANEL> "howdoi: change info card: user or group"

You can change the information for an individual user, or for the list of people assigned to a
group. Which do you want to do?

<radio button> "Change an info card for a user", true,,,,appleguide
<radio button> "Change an info card for a group", false,,,,appleguide

<DEFINE PANEL> "howdoi: change info card: open user"
<panel prompt> "override: ddone"

Do This

Open the info card you want to change.

To change information in an info card, use the pop-up menu to choose a page, then type your
new information in the appropriate place.
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<DEFINE PANEL> "howdoi: change info card: change group"
<panel prompt> "override: ddone"

Do This

To add an item to the group, drag it to the group icon. You can add both users and groups to a
group.

To remove an item from the group, open the group icon. Then drag the item out of the window.
You can drag the item to the desktop, to a folder, or to the Trash.

# HEHEHHHHEHEHE
# The following panels are for “How do | create group icons?”
# TR

<DEFINE PANEL?> "create group icons: intro"

Group icons can be used to send mail to all members of a specific project or team. You can
Create as many groups as you want.

# The panel "Apple: choose Personal Catalog" is shared
# The panel "Catalogs: choose New Group" is shared
# The panel "new group icon: type name" is shared

<DEFINE PANEL> "new group icon: drag to"

Do This

To add users or groups to the group icon, drag user or group icons to it.

SendingReceiving.panel

The panels for “Sending and Receiving”
©1993 Apple Computer, Inc.

HHHFHHHR
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The beginning of the “How do I” portion of Sending and Receiving

H*H H FH

HHH A R R
“How do | send letters and documents?” panels are included in PowerTalkBasic.Panel
HHHHHHHHH R

H H

HE B R
“How do | read my incoming mail?” panels are included in PowerTalkBasic.Panel
HEHHH R T R R

H H* FH

B HHHHH
The following panels are for “How do | change the way mailbox items appear?”
HHAHHHHHHH

H HH

<DEFINE PANEL> "howdoi: mailbox items appear: begin"

You can change the order in which information is displayed in your mailbox. You can also control
whether all available information is displayed, or just the information you want to see.

To control the way items appear in an active mailbox window, you use the View menu.

#it The next 2 panels are the same as the ones in

#it “How do | read my incoming mail?” in PowerTalkBasic.Panel
#it "howdoi: read my mail: open mailbox"

# "howdoi: read my mail: enter access code"

<DEFINE PANEL> "howdoi: mailbox items appear: change order"
<panel prompt> "override: shortcut"

To change the order in which items appear, choose one of the first set of items in the View menu,
shown here.

<pict> 1006, center

<DEFINE PANEL?> "howdoi: mailbox items appear: change filter"
<panel prompt> "read & click"
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You can change the kind of information displayed (in the In Tray window) by choosing one of the
“filters” from the second part of the View menu, shown here.

When you choose a filter, only items of that kind are displayed in the In Tray window.

<pict> 1008, center

<DEFINE PANEL> "howdoi: mailbox items appear: shortcut"
<panel prompt> "override: rdone"

Do This

To quickly change the order in which items appear in a mailbox window, click a heading over a
column of information. Mailbox items are sorted according to that type of information.

M

The following panels are for “How do | take my mail with me to read later?”
also known as copylocal

HHHHHHHHHH R

H H HFH

<DEFINE PANEL> "howdoi: take my mail: begin"
Some kinds of electronic mail appear in your mailbox only when your computer is connected to
your network. This is because some mail items are stored elsewhere — for example, on a
PowerShare collaboration server.

If you use a PowerBook, you can make sure that your mail is available when your computer is no
longer connected to the network.

To take mail with you, you open your mailbox and copy messages to your local hard disk.

#it The next 2 panels are the same as the ones in
#it “How do | read my incoming mail?” in PowerTalkBasic.Panel
#it "howdoi: read my mail: open mailbox"

#it "howdoi: read my mail: enter access code”
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<DEFINE PANEL> "Edit: choose Select All"

Do This

Open the Edit menu and choose Select All.

If Select All is dimmed, there is no mail in your mailbox. Try this procedure again when you have
mail waiting to be read.

<coach mark> "edit-select all"

<DEFINE PANEL> "Mailbox: choose copy local"

Do This

Open the Mailbox menu and choose Copy Local.

<coach mark> "mailbox-copy local"

<DEFINE PANEL> "howdoi: take my mail: respond"

<panel prompt> "override: ddone"

Do This

The original copies of your mail (the copies stored elsewhere) are automatically marked as if you
have read the mail. To avoid that marking, click to remove the X next to “Mark originals as read.”

Click OK to copy your mail to your local hard disk.

HHHHHHHHHH R
The following panels are for “How do | set mail preferences?”
HHHHHHHHH TR

H H

<DEFINE PANEL?> "set mail preferences: intro"
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You can set preferences for displaying mail, announcing the arrival of incoming mail, and letting
others check their PowerShare mail from your computer.

<DEFINE PANEL> "Mailbox: open"

<panel prompt> "override: right"

Do This

Open the mailbox.

# COACH THE MAILBOX ICON
# We can't coach the PowerTalk desktop icon for sure

<DEFINE PANEL> "Mailbox: choose Preferences"

Do This

Open the Mailbox menu and choose Preferences.

<coach mark> "mailbox-preferences"

<DEFINE PANEL> "Mailbox Preferences: set options"
<panel prompt> "override: ddone"

Do This

Set the options to suit your needs, then click the close box to close the window. Changes take
effect immediately.

HHHHHHHHH R
The following panels are for “How do | allow a guest to get mail?”
HHHHHHHHH TR

H H H*

<DEFINE PANEL> "howdoi: guest: begin"

You can use visitors’ mailboxes to let other people receive their electronic mail on your computer.
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#it The next 2 panels are the same as the ones in

#it “How do | read my incoming mail?” in PowerTalkBasic.Panel
#it "howdoi: read my mail: open mailbox"

# "howdoi: read my mail: enter access code"

# The panel "Mailbox: choose Preferences" is shared

<DEFINE PANEL?> "howdoi: guest: allow visitor"

Do This

Click to place an X in the box next to “Allow visitor's mailbox.

<coach mark> "allow visitor"

<DEFINE PANEL> "Special: choose visitor's mailbox"

Do This

Open the Special menu and choose Visitor’'s Mailbox.

<coach mark> "special-visitor's mailbox"

<DEFINE PANEL> "howdoi: guest: visitor access info"
<panel prompt> "override: ddone"

Do This

Let your visitor use the dialog box to choose his or her PowerTalk service, and type his or her
name and password for that service.

A mailbox with your visitor's name appears on your desktop.

Visitors’ mailboxes go away when you shut down or restart your computer. You can also remove a
visitor’s mailbox by dragging it to the Trash.

# HEHEHHHHHEHE
# The following panels are for “How do | check my mail from another computer?”
# TR
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<DEFINE PANEL> "howdoi: another computer: begin"

To receive your electronic mail on a different computer, the owner of that computer must set up
the PowerTalk software to allow visitors’ mailboxes.

If the owner of the computer needs help setting up a guest mailbox, click Huh? below for
instructions.

<dimmable button data> "Huh?", "How do | allow a guest to get mail?"

HHAHHHHHHHHHHH
The following panels are for “How do | check the status of mail I've sent?”
HHAHHHHHHHHHHH

H H*

<DEFINE PANEL> "howdoi: message | sent: begin"

You use your Out Tray to see what mail you've sent, and to check the status of those messages.

#i The next 2 panels are the same as the ones in

#it “How do | read my incoming mail?” in PowerTalkBasic.Panel
#it "howdoi: read my mail: open mailbox"

#it "howdoi: read my mail: enter access code"

<DEFINE PANEL?> "Mailbox: choose out tray"

Do This
Open the Mailbox menu and choose Out Tray.

<coach mark> "mailbox-out tray"

<DEFINE PANEL> "howdoi: message | sent: status"
<panel prompt> "read & click"
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The information under the Status heading indicates the current state of each message you've
sent.

Sending means the message is in the process of being sent.

Waiting means the message is waiting to be sent. Select a waiting message and choose Send
Now from the Mailbox menu to send the message immediately.

<DEFINE PANEL> "nhowdoi: message | sent: status2"

<panel prompt> "override: rdone"
Done means the message has been sent from your computer.

IMPORTANT: “Done” does not mean that a message has been delivered and received. It only
means that the message has gone out over the network.

HHH AR
The following panels are for “How do | use tags to view mail | receive?”
HHHHHHHHHH R

H H

<DEFINE PANEL> "howdoi: use tags: begin"

Tags are keywords you use to identify and categorize your mail. You can choose to see only the
items in your In Tray that have a particular tag.

# The next 2 panels are the same as the ones in

#it “How do | read my incoming mail?” in PowerTalkBasic.Panel
#i "howdoi: read my mail: open mailbox"

#it "howdoi: read my mail: enter access code”

<DEFINE PANEL> "howdoi: use tags: with tag"

Do This

Choose With Tag from the View menu.

<coach mark> "view-with tag"
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<DEFINE PANEL> "howdoi: use tags: choose the tag"
<panel prompt> "override: ddone"

Do This

Type in the box a word or phrase to use as a tag. If you want to use a tag you entered previously,
choose it from the pop-menu.

Click OK when you're finished.

<coach mark> "with tag dialog circle"

M
The following panels are for “How do | see tags added to my mail?”
HEHHH R T R

H H* FH

<DEFINE PANEL?> "see tags: intro"

Tags appear in an item’s Info box when you open the Info box from within the In Tray.

<DEFINE PANEL?> "see tags: select items"

Do This

Select the item in the In Tray whose tags you want to see.

# The panel "File: choose Get Info" is shared

<DEFINE PANEL?> "Info: look in tags area"



PowerTalk Guide Panels 1.0b2 44 May 20, 2025

Do This

Look in the Tags area at the bottom of the Info window.
The tags you've assigned appear in a list separated by commas.

IMPORTANT: When you move a letter out of the mailbox, tags are removed.

TR
The following panels are for “How do | add or remove tags from mail | receive?”
HEHHH R R T R

H*H H FH

<DEFINE PANEL> "howdoi: add or remove tags: begin"

Tags are keywords you use to identify and categorize your mail. You can add one or more tags to
each piece of mail in your In Tray.

#it The next 2 panels are the same as the ones in

#it “How do | read my incoming mail?” in PowerTalkBasic.Panel
#it "howdoi: read my mail: open mailbox"

## "howdoi: read my mail: enter access code"

<DEFINE PANEL> "howdoi: add or remove tags: choose item"

Do This

Click to select the item you want to work with.

<DEFINE PANEL?> "Mailbox: choose Tag"

Do This

Open the Mailbox menu and choose Tag.

<coach mark> "mailbox-tag"
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<DEFINE PANEL> "howdoi: add or remove tags: add or remove"

H H

<panel prompt> "override: ddone"
Do This
Type in the box a word or phrase to use as a tag. If you want to use a tag you entered previously,
choose it from the pop-menu.

To attach the tag to the item in your In Tray, click Add. To remove the tag from the item, click
Remove.

<coach mark> "tag dialog circle"

HEHEHHHHEHEHE
The following panels are for “How do | remove a tag from my tag list?”
TR

<DEFINE PANEL> "howdoi: remove a tag: begin"

it
#i
#i#
#it
#it

When you create a tag to use with an item in your In Tray, the tag is added to your tag list.

<dimmable button data> "Huh?", "Definition of tag"

The next 3 panels are the same as the ones in

“How do | read my incoming mail?” in PowerTalkBasic.Panel
"howdoi: read my mail: open mailbox"
"howdoi: read my mail: enter access code"
"howdoi: guest: preferences"”

<DEFINE PANEL> "howdoi: remove a tag: click edit"

Do This

Click Edit.

<coach mark> "edit button"

<DEFINE PANEL> "howdoi: remove a tag: tags list"

<panel prompt> "override: ddone"
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Do This

Click a tag in the list to select it, then click Delete.
To select more than one tag, click and drag, or hold down the Shift key when you click each tag.

When you've removed all the tags you want to delete, click Done.

TR
The following panels are for “How do | activate mail connections?”
HEHHH R R T R

H*H H FH

<DEFINE PANEL> "activate mail connections: intro"

You can specify your physical location — at work, at home, or on the road — to activate
appropriate mail connections when you log on. Your choice determines the services through
which you send and receive mail.

<DEFINE PANEL> "Special: choose I'm at..."

Do This

Open the Special menu and choose “I'm at.”

<coach mark> "special-i'm at"

<DEFINE PANEL> "Current location: select"

Do This

A dialog box appears, listing all the services you have installed.

Use the pop-up menu to select your current location.

# COACH THE POP-UP MENU
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<DEFINE PANEL> "Services: activate"

Do This

Check the services that you want to activate.
If you select “off-line,” all services are automatically unchecked. While offline you can create

letters for later mailing. “Sending” a letter while you are offline puts the letter in your Out Tray for
delivery when you are connected to the proper service.

<DEFINE PANEL> "setting changes: click OK"

Do This

Click OK when you have finished making changes to your settings.

If you have made changes, you'll see a message. Read the information and click OK.

HHHHHHHHHHH
The following panels are for “How do | copy mail locally to my In Tray?”
HHH R R

H*H H

<DEFINE PANEL> "copy mail locally to my In Tray: intro"

Mail whose location is marked “remote” in your In Tray resides on a server. You can copy remote
mail so that it resides locally in your In Tray.

# The panel "Mailbox: open" is shared

<DEFINE PANEL?> "In Tray: select remote mail"
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Do This

Select the remote mail you want to copy.

# The panel "Mailbox: choose copy local" is shared

<DEFINE PANEL?> "original items: mark as read and click OK"

Do This

A dialog box appears.

If you wish, select the option to have the original items marked as read. Click OK.

<DEFINE PANEL?> "copy mail locally: outro"

A copy of the mail you have selected appears in the mailbox with its location marked “local”
(meaning it resides on your hard disk).

The original “remote” mail remains on the server and in your In Tray until you remove it.

HHHHHHHHH R
The following panels are for “How do | send mail written off line?”
HHHHHHHHH TR

H H

<DEFINE PANEL> "send mail written off line: intro"

When you “send” mail while you are offline, the mail goes into your Out Tray. The mail is
automatically sent as soon as you reactivate your mail connections (and unlock your key chain).

# DigitalSignatures.panel



PowerTalk Guide Panels 1.0b2 49 May 20, 2025

#
#
#

H H

H H FH

The panels for “Digital Signatures”
©1993 Apple Computer, Inc.

The beginning of the “Overview” portion of Digital Signatures

HEHEHHHHHEHE
The following panels are for “Digital Signatures Overview”
TR

<DEFINE PANEL?> "ref: about digital signature: 1"

You use a DigiSign Signer to approve, or “sign,” a document on your computer. Putting your
digital signature on a document ensures the integrity of the document. It marks the document in a
way that any PowerTalk user — even those without Signers of their own — can verify at any time.

For information on the types of Signer files available, click Huh? below.

<dimmable button data> "Huh?", "Definition of Signer approvals"”

<DEFINE PANEL?> "ref: about digital signature: 2"

PowerTalk software comes with a sample DigiSign Signer, which is not “approved.” This means
that you can use the sample Signer for practice, but it cannot ensure the integrity of the
documents you sign, because every PowerTalk user has the same sample Signer. The approval
process gives you a Signer that is yours alone.

If you need more information about signing a document, click Huh? below for instructions.

<dimmable button data> "Huh?", "How do | sign a document?"

<DEFINE PANEL?> "ref: about digital signature: 3"
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You may be able to use the DigiSign Utility program to begin the process of getting an approved
Signer (your organization may provide a different program that does the same thing). The
DigiSign Utility creates a request form with information about you. You print the form, and send it
to a person or agency with the authority to issue you an approval file.

If you need more information about obtaining a valid Signer, click Huh? below for instructions.

<coach mark> "finder DigiSign icon"
<dimmable button data> "Huh?", "How do | obtain a valid Signer file?"

<DEFINE PANEL?> "ref: about digital signature: 4"

<panel prompt> "override: rdone"

After you receive your approval file, you use the DigiSign Utility program again to produce your
approved Signer.

For help using DigiSign Utility, choose DigiSign Utility Help from the Guide menu (on the right,
with the ? icon) after you open DigiSign Utility.

If you need more information about approving a Signer, click Huh? below for instructions.

<dimmable button data> "Huh?", "How do | approve my Signer file?"

#

# The beginning of the “How do I” portion of Digital Sighatures

#

# HHH A R

# The following panels are for “How do | obtain a valid Signer file?”
# HHHHHHHHH R

<DEFINE PANEL?> "howdoi: obtain a signer file: begin"

<panel prompt> "override: moreinfo"

To obtain a valid Signer file, you send a request form to a person or agency who has the authority
to issue you an approval file.

If your company has been authorized to issue approval files for its employees, you will probably
use a special Signer request form provided by your company.
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<DEFINE PANEL> "howdoi: obtain a signer file: use"

To print a form requesting an unaffiliated Signer file, you use the DigiSign Utility program located
in the PowerTalk folder. (The name of the program may be different if your company has a
customized DigiSign Utility.)

For information on the types of Signer files available, click Huh? below.

<dimmable button data> "Huh?", "Definition of Signer approvals"

<DEFINE PANEL> "DigiSign Utility: open"

Do This

Open the DigiSign Utility program.

The program opens with a welcome screen.

<coach mark> "finder DigiSign icon"

<DEFINE PANEL?> "File: choose New Request"

Do This

Open the File menu and choose New Request.

A Signer request form appears on the screen.

<coach mark> "file-new request"

<DEFINE PANEL?> "Signer request form: type info"

Do This

Type the appropriate information.
Use the Tab key to move from item to item.

IMPORTANT: Memorize the phrase you type for your verification with approval authority. If you

contact the approval authority with a problem, they will need to know this phrase before they can
help you.
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<DEFINE PANEL> "Signer request form: click Postal Address"

Do This

If your Signer request form has a Postal Address button, click the button and type in the
information requested.

<DEFINE PANEL?> "Signer request form: click OK"

Do This

When you are satisfied that the information in the Signer Request is correct, click OK.

#<coach mark> NEED COACH FOR OK

<DEFINE PANEL?> "Identification code: type"
Do This
When another dialog box appears, type the identification code you'll use when using your
approved Signer.
For tips for choosing an identification code, click Huh? below.

<dimmable button data> "Huh?", "Tips for choosing an identification code"

<DEFINE PANEL?> "Identification code creation dialog box: close"

Do This

Click OK to close the identification code creation dialog box.

#<coach mark> NEED COACH FOR OK

<DEFINE PANEL?> "Signer file: save"
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Do This

When the Save dialog box appears, choose a location for saving your unapproved Signer file and
click Save.

Another dialog box appears, telling you that the program is creating files for you. (The process
takes a few minutes.)

#<coach mark> NEED COACH FOR

<DEFINE PANEL> "Files created: OK"

Do This

When the files have been created, a dialog box appears.
Read the information, then click OK.

Your newly generated request form appears with the encoded request information.

<DEFINE PANEL> "Request form: save"

Do This

Open the File menu and choose Save.

You have now created two files, a request and an unapproved Signer (which is not yet usable).

<DEFINE PANEL> "Request form: print"
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Do This

Print your Signer Request form.
If the software notifies you that your Signer Request form is too long to fit on a single printed

page, or if your form was generated by a printer whose resolution is less than 300 dots per inch,
you must also include a copy of the request file on disk.

<DEFINE PANEL?> "Request form: submit"
To submit a Signer Approval Request to RSA Certificate Services:

 Take your printed Signer Request form to a notary public (or equivalent) along with three (3)
forms of identification, as described on the Signer Request form.

» Mail your notarized Signer Request form and disk containing a copy of the request file (if
required) to:

RSA Certificate Services
P.O. Box 2004

Belmont, CA 94002
USA

<DEFINE PANEL> "howdoi: obtain a signer file: end"

If necessary, RSA will contact you for any missing information. Otherwise, RSA will generate and
send back your Signer Approval File.

If you need more information about approving a Signer, click Huh? below for instructions.

<dimmable button data> "Huh?", "How do | approve my Signer file?"

HE B R
The following panels are for “How do | approve my Signer file?”
HEHHH R T R R

H H FH

<DEFINE PANEL> "howdoi: approve my signer file: begin"
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Before you can approve your Signer file, you must have requested and received a Signer
Approval file from your approval authority.

If you need more information about obtaining a valid Signer, click Huh? below for instructions.

<dimmable button data> "Huh?", "How do | obtain a valid Signer file?"

<DEFINE PANEL?> "howdoi: approve my signer file: copy"

<panel prompt> "override: right"

Do This

Make a copy of your unapproved Signer file.

You need to keep a copy of your unapproved Signer in case problems occur during this
procedure.

<DEFINE PANEL> "howdoi: approve my signer file: open"

Do This

Open your unapproved Signer file.

<DEFINE PANEL> "Signer: choose approve"

Do This

Open the Signer menu and choose Approve/Renew Signer.

<coach mark> "signer-approve"

<DEFINE PANEL?> "howdoi: approve my signer file: approve"



PowerTalk Guide Panels 1.0b2 56 May 20, 2025

Do This

Choose your Signer Approval file, then click Open.

The process of creating your approved Signer takes a few moments. When it’s finished, click OK
in the dialog box that appears.

The icon of your Signer changes to show that it is now approved.

<DEFINE PANEL?> "signer file: important"

<panel prompt> "override: rdone"

IMPORTANT: Treat your approved Signer file as you would an ATM card, keeping it in a secure
place and limiting access to it. For example, you may want to keep your approved Signer file on a
floppy disk that you carry with you. Know whom to contact if you ever need to revoke the Signer.
If you learn that someone is trying to use your Signer, notify your approval authority immediately.

HHHHHHHHH R
The following panels are for “How do | sign a document?”
HHHHHHHHH TR

H H

<DEFINE PANEL> "howdoi: sign a document: begin"

Do This

To use your Signer to digitally sign a document, drag the icon of the document to your Signer
icon.

<dimmable button data> "Huh?", "What is a digital signature?"

<DEFINE PANEL> "howdoi: sign a document: 2"
<panel prompt> "override: ddone"
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Do This

Type your DigiSign Identification Code in the dialog box that appears, and click OK.

IMPORTANT: Signing a document also locks the document. Changing a signed document
invalidates the signature.

HHHHHHHH AR
The following panels are for “How do | check a digital signature?”
HHAHHHHHHH

H H H

<DEFINE PANEL> "howdoi: check a digital signature: begin"

When a document has been digitally signed, you can verify who signed the document, and that
the document has not been changed since it was signed.

You use the Get Info command in the File menu to verify a digital signature.

<DEFINE PANEL> "howdoi: check a digital signature: choose item"
<panel prompt> "override: right"

Do This

Select the document you want to verify.

# The panel "File: choose Get Info" is shared

<DEFINE PANEL> "howdoi: check a digital signature: verify"
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Do This

Do This

Click the verification button to the right of the Comments area. If there is no button, the document
you selected does not have a digital signature.
A dialog box appears, asking if you want to verify or remove the signature.

Click Verify.

<DEFINE PANEL?> "howdoi: check a digital signature: verify2"

Do This

A progress indicator tells you that the signature is being checked.

If the signature is verified, a dialog box with signature information appears. When you're finished
reading the information, click OK.

IMPORTANT: If the signature isn’t verified, contact the person who sent the document or your
approval authority.

<DEFINE PANEL> "howdoi: check a digital signature: verify3"

<panel prompt> "override: rdone"

Tip

To verify the digital signature without the dialog box appearing, hold down the Option key while
you click the verification button.

If the signature is verified, a dialog box with signature information appears.
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H H FH HHHFHHHR

H*H H

Troubleshooting.panel

The panels for “Troubleshooting”
©1993 Apple Computer, Inc.

The beginning of the “Why can’t I” portion of Troubleshooting

HHHHHHHHHH T T
The following panels are for “Why can'’t | access a server on my network?”
HHH A R

<DEFINE PANEL> "access a server on my network: intro"

H*H H FH

If you get a message that the system can no longer access a server on your network and a
Resolve button appears in the notification dialog box, click the button to reconnect.

If you are still having problems, check the cable connection on the back of your computer.

TR
The following panels are for “Why can'’t | find Key Chain?”
HEHHH R R T R

<DEFINE PANEL> "whycanti: find key chain: begin"

#i
#it
#it

<panel prompt> "override: keychain"

If you have thrown away your key chain, you can create a new one using the PowerTalk Setup

control panel.
If you can’t find the key chain, click Huh? below for instructions.

<Dimmable Button Data> "Huh?","Definitions Tips for finding items"

The next 2 panels are from “How do | turn PowerTalk on and off?”
"Apple: choose control panels"
"PowerTalk Setup: open”
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<DEFINE PANEL> "whycanti: find key chain: click key chain"
<panel prompt> "override: ddone"

Do This

Click Key Chain.
If your key chain still exists it will open. If it doesn't, click Create in the dialog box that appears.

<coach mark> "key chain..."

HE B R
The following panels are for “Why can'’t | find my AppleTalk mail address?”
HEHHH R T R R

H H FH

<DEFINE PANEL?> "find my AppleTalk mail address: intro"
If you can’t find your own Direct AppleTalk mail address, the machine name may be missing.
If you don’t know how to name your computer, click Huh? below for instructions.

<Dimmable Button Data> "Huh?","How do | name my computer?"

TR
The following panels are for “Why can't | find the Mailbox or Catalogs icon?”
HEHHH R R T R

H H FH

<DEFINE PANEL> "whycanti: find the Mailbox or Catalogs: begin"

If you can’t find the Mailbox or Catalogs icons, PowerTalk is probably turned off. To turn
PowerTalk on, use the PowerTalk Setup control panel.

#it The next 5 panels are from “How do | turn PowerTalk on and off?”
#it sequence under “PowerTalk basic” topic
# HEHHH R T R

# The following panels are for “Why can't | receive mail?”
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# HEHHH R R T R

<DEFINE PANEL> "whycanti: can’t receive mail: begin"
If you're not receiving mail, the machine name may be missing.
If you don’t know how to nhame your computer, click Huh? below for instructions.

<Dimmable Button Data> "Huh?","How do | name my computer?"

# TR
# The following panels are for “Why can'’t | send mail?”
# HHHHHHHHHH R

<DEFINE PANEL> "whycanti: can’t send mail: begin"

If someone does not receive a message you sent, you may get a problem report in your In Tray. A
message that is not delivered is marked with this icon:

<pict> 1004, center

If a message is not delivered, check these things:

* Is the message correctly addressed?

* Has the address of the intended recipient changed because of a change in computer name or
AppleTalk zone?

« Is the software you used to send the message installed correctly?

HEHEHHHHEHEHE
The following panels are for “Why are catalog icons dimmed?”
T R

H H

<DEFINE PANEL> "AppleTalk or PowerShare catalogs dimmed: intro"

If the AppleTalk or PowerShare catalogs are dimmed in the Catalogs window, you need to turn

AppleTalk on.
#it The next 5 panels are from “How do | activate AppleTalk?”
#it sequence under “PowerTalk basic” topic

# PR T
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# The following panels are for “Why do | get a Disk Full message sending mail?”
# HHHHHHHH AR

<DEFINE PANEL> "Disk Full message sending mail: intro"

You must have at least 1.5 MB free on your disk to send or receive mail. Remove as many files
as necessary to provide space. One way to create disk space is to go to the Out Tray and throw
away items that have already been sent.

M
The following panels are for “Why does a triangle appear on my In Tray?”
HEHHH R T R

H H* FH

<DEFINE PANEL?> "triangle icon on In Tray: intro"

If a triangle icon appears on the right side of your In Tray, a server may be down or you've
temporarily lost connection.

<DEFINE PANEL?> "triangle icon on In Tray: click triangle"

Do This

Click the triangle icon to get a problem report. Double-click any report to see more information.

If a Resolve button appears at the lower-right corner of the dialog box, click the button to
reconnect.

HEHHHH R R T R
The following panels are for “Why is my mail marked “remote”?”
HEHEHHHHEHEHE

H HH

<DEFINE PANEL> "mail marked “remote”: intro"

If you're on someone else’s machine checking PowerShare mail through a visitor's mailbox, your
mail is marked “remote” in the location column. When you use PowerShare mail, you are looking
at your mail stored on a server.
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# HHHHHHHH AR
# The following panels are for “Why doesn’t my Signer work?”
# HEHEHHHHEHEHE

<DEFINE PANEL> "Signer doesn’t work: intro"
If your Signer used to work and no longer does, do the following:

» Open the Signer file and check the validation information. Apply for a renewal if your Signer has
expired.

* Check the Date & Time control panel and change the time.

 Your Signer file maybe damaged. Make a new copy of your Signer using the backup you
created when you first received your Signer Approval file.

# TR R
# The following panels are for “Why is my Approval Request info too long?”
# HEHHHH R R T R

<DEFINE PANEL> "info exceeds the limits: intro"

When you type your name or address in a DigiSign Utility Approval Request form, you may see a
message saying that what you've typed exceeds the limit. You may have typed more than 64
characters, or you may have used many complex characters (such as characters with an accent
or Japanese Kaniji). Try to use fewer characters.

HEHHH R T R R
The following panels are for “Why do | need a file with my Approval Request?”
HHHHHHHHH AR

H*H H FH

<DEFINE PANEL?> "file required: intro"

When you create your unapproved Signer and request files, you may see a message such as
“File required to process this request.” Your request information fills more than one printed page.
You must send a printed, signed, and notarized request form, as well as your request file, to your
approval agency.
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HEHHHH R T R R

The following panels are for “Definitions Tips for finding items?”
This is used in Huh? throughout the PowerTalk database
HEHEHHHHEHEHEH

HHHH

<DEFINE PANEL> "Finding items: tips1"
<PANEL PROMPT> "Prompt Override: 39"

If you can't find the icon you need, try the following:
* Move an open window by dragging its title bar (at the top of the window).
» Make a window bigger by dragging its size box (at the lower-right corner of the window).

« Scroll hidden portions of the window into view by clicking the scroll arrows (along the right and
bottom edges of the window).

« If only the title bar for a window is visible, double-click the title bar to display the entire window.

<DEFINE PANEL> "Finding items: tips2"
<PANEL PROMPT> "Prompt Override: 8"

If you can’t find the item by checking the windows on your screen, you can probably locate the
item by using the Find File command (in the Apple menu).

(You can also choose the Find command from the File menu to begin this procedure.)

<DEFINE PANEL> "Apple menu: choose Find File"

Do This

Choose Find File from the Apple Menu.

<COACH MARK>"Menu:Front:Apple:Find File"

<DEFINE PANEL> "find location: use pop-up"”
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Do This

Use the pop-up menu labeled “Find items” to specify where you want to search.

You can search on all disks connected to your computer, on shared disks (called servers) only, on
all disks except shared disks (called local disks), or on individual disks.

<COACH MARK>"Window:Find File:Find Items"

<DEFINE PANEL> "find: multiple"
Do This
Click the More Choices or the Fewer Choices button until the number of rows is the same as the
number of search criteria you want to use.
(You can specify as many as 10 criteria in the search window.)

<COACH MARK> "Window:Find File:More/Fewer Choices"

<DEFINE PANEL> "find: multiple pop-ups"

Do This

Starting with the leftmost pop-up menu, describe the items you want to find.

As appropriate, type text to search for, or click a number and then use the up or down arrow to
change it.

If you need to add more search criteria, use the pop-up menus to identify the new criteria. (If
necessary, expand the window by clicking the More Choices button to add criteria.)

<COACH MARK>"Window:FindFile:MoreCriteria:Rect"

<DEFINE PANEL> "find: click Find 4"
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Do This

Click Find when you have completed your search criteria.
Only the items that meet all criteria are displayed in the search results window.
(If no matching items were found, you hear a beep or see a message.)

<COACH MARK>"FindFile:Find:Wind:Rect"

<DEFINE PANEL> "Finding items: tips3"

<panel prompt> "override: moreinfo"

If you can’t find the item by using the Find File command, that item may not be on any disk the
computer is currently using. Check your backup disks, the original disk on which you received the
item, or the software that came with your computer.

It's also possible that the item you want is on a shared disk. You can connect to a shared disk and
then use the Find File command to search for the item on that disk.

<DEFINE PANEL> "Finding items: tips4"

<panel prompt> "override: rdone"

If the item you need to find is part of the system software that came with your computer (or that
you got as part of a system software upgrade), you must use the Installer program to add that
component to your system software.

(System software components are compressed when distributed; the Installer program
uncompresses them during installation. You can identify a compressed component of system
software by its icon, which has a belt around the middle.)

<DEFINE PANEL> "find: list choice"
#<PANEL PROMPT> "Prompt Override: 24"
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Do This

Click an item in the list to see its location.
The location of the item selected is displayed in the bottom section of the search results window.
You can double-click the item to open it.

You can also choose commands from the File, Edit, and View menus to work with the items
located in the search.

<COACH MARK>"Item:Find File:results:top"

#

# Definitions.panel

#

# The panels for “Definitions”

# ©1993 Apple Computer, Inc.

#

#

# The beginning of the definition portion
#

<DEFINE PANEL> "access code: def"

Your access code is a special password that gives you access to the PowerTalk key chain and all
of your PowerTalk collaboration services.

<DEFINE PANEL> "AppleMail: def"

AppleMail is an application program you use to create, send, read, and respond to letters and
enclosures.

<coach mark> "finder applemail icon"

<DEFINE PANEL> "catalog: def"



PowerTalk Guide Panels 1.0b2 68 May 20, 2025

In PowerTalk, a catalog represents a collection of information about people and things you can
work with. For example, a catalog can contain information about computer users, groups of users,
and devices on a computer network.

The information contained in a catalog depends on the kind of catalog. One example of a catalog
is an AppleTalk catalog, which provides information about computers and file servers on an
AppleTalk network.

Another kind of catalog is a personal catalog, which contains “information cards” with information
about individuals and groups you communicate with.

# HEHEHHHHHEHE
# The following panels are for “Definition of collaboration services”
# TR

<DEFINE PANEL> "collaboration servicesl: def"

Collaboration services provide ways for people to work together more conveniently. PowerTalk
system software provides some collaboration services by itself, including:

« a mailbox on your desktop

< a way to sign and approve documents electronically

* a key chain that lets you access many services with a single access code

« a way to send files to other people

<DEFINE PANEL> "collaboration services2: def"

<panel prompt> "override: rdone"

PowerTalk system software also provides the framework for additional collaboration services. You
add more PowerTalk collaboration services to your computer by installing products designed to
work with PowerTalk. These are available from other software and hardware developers.

# HHH R R
# End of “Definition of digital signature”
# HHHHHHHHH TR

<DEFINE PANEL?> "digital signature: def"
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A digital signature is an electronic indicator that can be placed on a document on your hard disk.
When a document is digitally signed, you and other PowerTalk users can verify the source of the
document, and that the document has not been changed.

You digitally sign a document with a special kind of file called a Signer. PowerTalk comes with a
demonstration Signer you can practice with.

If you need more information about obtaining a valid Signer, click Huh? below for instructions.

<dimmable button data> "Huh?", "How do | obtain a valid Signer file?"

# HHAHHHHHHH
# The following panels are for “Definition of electronic addresses”
# HHHHHHHH AR

<DEFINE PANEL> "electronic addresses1: def"

An electronic address is like the address on an envelope you send through the mail. It enables
one or more computers to find a particular electronic location. The location might be a computer,
a server, an account, or an electronic mailbox.

An information card for a user includes one or more electronic addresses for that person. You can
look in the Catalogs icon on your desktop to find information cards for people using PowerTalk
system software on your network. When you find an information card in that kind of catalog, the
card automatically includes an electronic address.

<DEFINE PANEL> "electronic addresses?2: def"

If you manually enter an electronic address, be sure that the address you type is correct. Spelling
or format errors prevent your mail from being delivered. The best way to find someone’s
electronic address is to ask that person, or ask your network administrator.

<DEFINE PANEL> "electronic addresses3: def"
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Direct AppleTalk mail addresses take the form: <name>@<zone>. For example, if the computer’s
name is “Rosemary’s Quadra” and the computer is in the zone “Engineering,” the complete
address would be Rosemary’s Quadra@Engineering.

PowerShare addresses take the form: <name>@<catalog>:<folder>:<folder>. For example, if the
user’s name is John Doe, and his account is located in a catalog folder called “Sales Department”
in a PowerShare catalog called “Western Division,” the complete address would be John
Doe@Western Division:Sales Department.

<DEFINE PANEL> "electronic addresses4: def"

H H FH

#
#
#

<panel prompt> "override: rdone"

Addresses on the Internet typically take the form of a person’s name or identifier, followed by the
@ symbol, followed by the name or identifier of the organization maintaining the person’s
computer network or account. No spaces are allowed between characters.

For example if John Doe has an account on a computer at Great Big University, his Internet
address might be john_doe@gbig.edu.

B
End of “Definition of electronic addresses”
HHHHHHHHHHHHH

HEHHH R T R R
The following panels are for “Definition of electronic mail services”
HHHHHHHH AR

<DEFINE PANEL> "electronic mail servicesl: def"

PowerTalk system software comes with built-in ways to send and receive electronic mail.
Programs from other software developers, if they are designed to take advantage of PowerTalk
services, can give you additional ways to send and receive mail.

<DEFINE PANEL> "electronic mail services2: def"
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Some electronic mail services copy mail directly to your hard disk. For example, if you receive
Direct AppleTalk mail, the items you receive reside on your hard disk.

Other electronic mail services, including PowerShare mail, store mail on a server. When you
receive PowerShare mail, what you actually receive is a notification that mail for you is stored on
the PowerShare server.

<DEFINE PANEL> "electronic mail services3: def"

<panel prompt> "override: rdone"

You can find the location of each item in your mailbox In Tray by checking the Location column.
Items are listed as local (on your hard disk) or remote (on a server).

If you disconnect your computer from the network, you will be able to open only In Tray items that
are local. If you want, you can copy remote items to your hard disk (by selecting the items and
choosing Copy Local from the Mailbox menu).

# HHHHHHHHHHHH
# End of “Definition of electronic mail services”
# B

<DEFINE PANEL?> "information card: def"
An information card is a container for information about a person or a group of people.
An information card for an individual usually contains a person's name, postal address, electronic
address, and telephone numbers. An information card for a group contains pointers (or aliases) to

information about the individuals in the group.

Information cards are usually stored in catalogs, although you can keep an information card on
your desktop or in a Finder window.

<DEFINE PANEL?> "key chain: def"
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The PowerTalk key chain is a container for the PowerTalk collaboration services you use, such as
file servers and communication systems. Your setup and password information for each service
are stored in the key chain. Your key chain is kept secure by your access code.

You can open your key chain to add, remove, and change collaboration services.

<DEFINE PANEL> "mailbox: def"

The PowerTalk mailbox is the place that contains all of your correspondence. Inside the mailbox,
the In Tray contains correspondence you receive, and the Out Tray contains correspondence you
send.

When you are using PowerTalk, your mailbox is on your desktop. After you set up PowerTalk,
your mailbox has your name on it.

<DEFINE PANEL> "Mailer: def"

You use the Mailer to address and send correspondence from an application program rather than
the Finder. With PowerTalk software, Macintosh developers can add the Mailer to any program.
When you create a document in such a program, you can send the document immediately.

AppleMail, a program that comes with PowerTalk software, uses the Mailer.

<DEFINE PANEL> "personal catalog: def"

A personal catalog is a catalog that resides on your hard disk. You can use a personal catalog to
store items such as info cards, aliases, and groups.

When you install PowerTalk, a personal catalog is automatically put into Mail and Catalogs in your
Apple menu. You can create more personal catalogs if you want, and store them anywhere on
your hard disk.

One personal catalog is your default, or “preferred,” personal catalog. The preferred personal
catalog is the one that is automatically used by programs, such as AppleMail, that use the
PowerTalk Mailer for addressing and sending messages and documents.
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<DEFINE PANEL> "PowerShare server: def"

A PowerShare server is a computer running PowerShare software, which provides enhanced
communication and security features. To use a PowerShare server you must have a PowerShare
account, which is provided by the system administrator of the server.

<DEFINE PANEL> "PowerTalk: def"

PowerTalk is system software that provides the foundation for software that offers you new
collaboration services. Collaboration services provide ways for you to correspond with others,
safeguard your communications, access information on other computer systems, and automate
routine activities.

HEHEHHHHEHEHE
The following panels are for “Definition of Signer approvals”
M

H H

<DEFINE PANEL> "Signer approvals1: def"
There are two types of Signer approvals available: affiliated and unaffiliated.

Affiliated approvals let you make signatures that include an organizational affiliation (such as
“Jane Doe, VP of Engineering, ACME Inc.”).

Unaffiliated approvals allow you to make signatures that only use your name (such as “Jane
Doe”).

<DEFINE PANEL?> "Signer approvals2: def"

You can have multiple Signer approvals allowing you to sign as an employee of your company,
the representative of an organization (such as a charity), or simply yourself.

If you need more information about obtaining a valid Signer, click Huh? below for instructions.

<dimmable button data> "Huh?", "How do | obtain a valid Signer file?"
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<DEFINE PANEL> "tag: def"

Tags are keywords you use to identify and categorize your mail. You can attach one or more tags
to each piece of mail in your In Tray.

You can choose to see only the items in your In Tray that have a particular tag.



