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#
# The beginning of the “How do I” portion
#

# ####################
# The following panels are for “How do I create a letter?”
# ####################

<DEFINE PANEL> "Aplml:WhichNewLetter" 
<FORMAT> "full"
When you create a letter, you can start with a blank page or with one of the letterheads that comes with AppleMail or 
that you’ve created. Which do you want to do? Click one:

<radio button> "Start with a blank page", true,,,,appleguide
<radio button> "Start with a letterhead", false,,,,appleguide

<END PANEL>

<DEFINE PANEL> "File: choose New" 
<FORMAT> "tag"
Do This

<FORMAT> "body"
Open the File menu and choose New.

<coach mark> "file-new"
<END PANEL>

<DEFINE PANEL> "Letter: type content" 
<panel prompt> "override: ddone"
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<FORMAT> "tag"
Do This

<FORMAT> "body"
Type the letter in the content area.

Use the Font, Size, and Style menus to change the look of the letter.

<END PANEL>

<DEFINE PANEL> "File: choose Letterheads" 
<panel prompt> "override: right"

<FORMAT> "tag"
Do This

<FORMAT> "body"
Open the File menu and choose Letterheads.

<coach mark> "file-letterheads" 
<END PANEL>

<DEFINE PANEL> "Aplml:ChooseLetterhead" 
<FORMAT> "tag"
Do This

<FORMAT> "body"
Select a letterhead from the list and click Open.

<coach mark> "open letterhead"
<END PANEL>

# ####################
# The following panels are for “How do I address a letter?”
# ####################

<DEFINE PANEL> "Aplml:Mailer:Recipients:AddressType" 
<FORMAT> "full"
You can address a letter in the following ways. Which do you want to do? Click one:

<radio button> "Choose an address from my personal catalog", true,,,,appleguide
<radio button> "Choose an address from catalogs", false,,,,appleguide
<radio button> "Search for an address", false,,,,appleguide
<radio button> "Type an address", false,,,,appleguide

<END PANEL>

<DEFINE PANEL> "Letter: not open" 
<panel prompt> "override: makechoice"
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<FORMAT> "tag"

Do This

Do This

<FORMAT> "body"
You need to open an existing letter or create a new letter.

To open an existing letter, open the File menu and choose Open. Select a letter from the list and click Open.

To create a new letter, open the File menu and choose New.

<END PANEL>

<DEFINE PANEL> "Aplml:expandMailer" 
<FORMAT> "tag"
Do This

<FORMAT> "body"
Click the triangle to expand the Mailer.

<coach mark> "expand triangle" 
<dimmable button data> "Huh?", "Definition of Mailer"

<END PANEL>

<DEFINE PANEL> "Aplml:Mailer:Recipients" 
<panel prompt> "override: right"

<FORMAT> "tag"
Do This

<FORMAT> "body"
Click Recipients.

<coach mark> "recipients button" 
<END PANEL>

<DEFINE PANEL> "Aplml:Mailer:Recipients:PersCat" 
<FORMAT> "tag"
Do This

<FORMAT> "body"
To see the addresses in your preferred personal catalog, click the book.

#COACH THE BOOK BUTTON
<END PANEL>
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<DEFINE PANEL> "Aplml:Mailer:Recipients:ChooseAddr" 
<FORMAT> "tag"
Do This

<FORMAT> "body"
Choose an address from the list of recipients.

For instructions on adding addresses to a personal catalog, open the Application menu at the far-right corner of the 
screen and choose Finder. Then open the Guide menu (on the right with the ? icon) and choose PowerTalk Guide.

#COACH THE SCROLLING LIST ON THE RECIPIENTS BOX
<END PANEL>

<DEFINE PANEL> "Aplml:Mailer:Recipients:To/CC/BCC" 
<FORMAT> "tag"
Do This

<FORMAT> "body"
You can address this recipient in the following ways. Which do you want to do? Click one:

<radio button> "Address as a main recipient", true,,,,appleguide
<radio button> "Address as a copied recipient", false,,,,appleguide
<radio button> "Address as the recipient of a blind copy", false,,,,appleguide
<dimmable button data> "Huh?", "Definition of Blind Copy (BCC)"

<END PANEL>

<DEFINE PANEL> "Aplml:Mailer:Recipients:To" 
<FORMAT> "tag"
Do This

<FORMAT> "body"
To address as a main recipient, click To.

#COACH To BUTTON ON RECIPIENTS BOX
<END PANEL>

<DEFINE PANEL> "Aplml:Mailer:Recipients:CC" 
<FORMAT> "tag"
Do This

<FORMAT> "body"
To address as a copied recipient, click CC.

#COACH CC BUTTON ON RECIPIENTS BOX
<END PANEL>
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<DEFINE PANEL> "Aplml:Mailer:Recipients:BCC" 
<FORMAT> "tag"
Do This

<FORMAT> "body"
To address as the recipient of a blind copy, hold down the Option key on your keyboard and click BCC.

<dimmable button data> "Huh?", "Definition of Blind Copy (BCC)"
<END PANEL>

<DEFINE PANEL> "Aplml:Mailer:Recipients:Done" 
<panel prompt> "override: ddone"

<FORMAT> "tag"
Do This

<FORMAT> "body"
When you have finished addressing your recipients, click Done.

#COACH Done BUTTON ON RECIPIENTS BOX
<END PANEL>

<DEFINE PANEL> "Aplml:Mailer:Recipients:Catalogs" 
<FORMAT> "tag"
Do This

<FORMAT> "body"
To see the Catalog Browser, click the globe.

#COACH GLOBE ON RECIPIENTS BOX
<END PANEL>

<DEFINE PANEL> "Aplml:Mailer:Recipients:PickCatalog" 
<FORMAT> "tag"
Do This

<FORMAT> "body"
Use the pop-up menu to choose the catalog you want.

#COACH POP-UP MENU ON RECIPIENTS BOX
<END PANEL>

<DEFINE PANEL> "Aplml:Mailer:Recipients:Search" 
<FORMAT> "tag"
Do This

<FORMAT> "body"
To open the Find panel, click the magnifying glass.
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#COACH MAGNIFYING GLASS ON RECIPIENTS BOX
<END PANEL>

<DEFINE PANEL> "Aplml:Mailer:Recipients:SearchWhat" 
<FORMAT> "tag"
Do This

<FORMAT> "body"
Type the beginning of the name you want to search for.

#COACH THE BOX FOR TYPING IN ON RECIPIENTS BOX
<END PANEL>

<DEFINE PANEL> "Aplml:Mailer:Recipients:SearchWhere" 
<FORMAT> "tag"
Do This

<FORMAT> "body"
Use the pop-up menu to choose a place to search.

#COACH POP-UP MENU ON RECIPIENTS BOX
<END PANEL>

<DEFINE PANEL> "Aplml:Mailer:Recipients:SearchNow" 
<panel prompt> "override: whensee"

<FORMAT> "tag"
Do This

<FORMAT> "body"
Click Find. The search may take a few moments.

If the address you want does not appear, change the name or the location you’re searching, and click Find again.

#COACH FIND BUTTON ON RECIPIENTS BOX
<END PANEL>

<DEFINE PANEL> "Aplml:Mailer:Recipients:Type" 
<FORMAT> "tag"
Do This

<FORMAT> "body"
To open the Type-In Address panel, click the pencil.

#COACH THE PENCIL ON RECIPIENTS BOX
<END PANEL>

<DEFINE PANEL> "Aplml:Mailer:Recipients:TypeAddress" 
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<FORMAT> "tag"
Do This

<FORMAT> "body"
Type the complete mailing address of the recipient.

#COACH THE BOX FOR TYPING THE ADDRESS ON RECIPIENTS BOX
<END PANEL>

<DEFINE PANEL> "Aplml:Mailer:Recipients:KindTyped" 
<FORMAT> "tag"
Do This

<FORMAT> "body"
Use the pop-up menu to specify the catalog service of the address.

#COACH THE POP-UP MENU
<END PANEL>

# ####################
# The following panels are for “How do I expand and collapse the Mailer?”
# ####################

## The panel is defined in “How do I address a letter?”
## "Aplml:expandMailer"

<DEFINE PANEL> "Aplml:collapseMailer" 
<FORMAT> "tag"
Do This

<FORMAT> "body"
Click the triangle to collapse the Mailer.

<coach mark> "expand triangle" 
<dimmable button data> "Huh?", "Definition of Mailer"

<END PANEL>

# ####################
# The following panels are for “How do I work with letterheads?”
# ####################

<DEFINE PANEL> "Aplml:ChooseLetterheadTask" 
<FORMAT> "full"
You can work with letterheads in the following ways. Which do you want to do? Click one:

<radio button> "Open an existing letterhead", true,,,,appleguide
<radio button> "Make a new letterhead", false,,,,appleguide
<radio button> "Choose a letterhead to use all the time", false,,,,appleguide
<radio button> "Delete a letterhead from the list of letterheads", false,,,,appleguide
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<END PANEL>

## The following panels are defined in “How do I create a new letter?”
## "File: choose Letterheads"
## "Aplml:ChooseLetterhead"
## "Aplml:OpenLetterhead"
## "File: choose New"

<DEFINE PANEL> "Aplml:MakeALetterhead" 
<FORMAT> "tag"
Do This

<FORMAT> "body"
To make a new letterhead, write your letter and give it the look you want (by changing fonts, size, and style). Then set 
up the Mailer with the recipients, subject, and enclosures you want to include in the letterhead.

<END PANEL>

<DEFINE PANEL> "File: choose Save As Letterhead" 
<panel prompt> "override: right"

<FORMAT> "tag"
Do This

<FORMAT> "body"
Open the File menu and choose Save As Letterhead.

<coach mark> "file-saveas letterheads" 
<END PANEL>

<DEFINE PANEL> "Aplml:NameLetterhead" 
<panel prompt> "override: ddone"

<FORMAT> "tag"
Do This

<FORMAT> "body"
Type a name for the letterhead, then click OK.

<coach mark> "name letterhead" 
<END PANEL>

<DEFINE PANEL> "Aplml:DefaultLetterhead" 
<FORMAT> "tag"
Do This

<FORMAT> "body"
Select a letterhead from the list and click Set Default.

<coach mark> "Set Default" 
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<END PANEL>

<DEFINE PANEL> "Aplml:LetterheadDelete" 
<FORMAT> "tag"
Do This

<FORMAT> "body"
Select a letterhead from the list and click Delete.

When you see a message asking if you're sure you want to delete the letterhead, click Delete again.

<coach mark> "Delete letterhead" 
<END PANEL>

<DEFINE PANEL> "Aplml:LetterheadDone" 
<panel prompt> "override: ddone"

<FORMAT> "tag"
Do This

<FORMAT> "body"
Click Done.

<coach mark> "Done" 
<END PANEL>

# ####################
# The following panels are for “How do I set up AppleMail the way I want?”
# ####################

<DEFINE PANEL> "Aplml:SetPrefs intro" 
<FORMAT> "full"
Using AppleMail Preferences, you can choose a font to use for all your letters, set the Mailer to be expanded when 
you create or open letters, and define options for sending and receiving letters.

<END PANEL>

<DEFINE PANEL> "Edit: choose Preferences" 
<panel prompt> "override: right"

<FORMAT> "tag"
Do This

<FORMAT> "body"
Open the Edit menu and choose Preferences.

<coach mark> "edit-preferences" 
<END PANEL>
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<DEFINE PANEL> "Aplml:SetPrefs" 
<panel prompt> "override: ddone"

<FORMAT> "tag"
Do This

<FORMAT> "body"
Choose the options you want, then click OK. 

For more information on the options, open the Guide menu (on the right with the ? icon), choose Show Balloons, and 
then point to the different options. (Choose Hide Balloons when you’re finished.)

<END PANEL>

# ####################
# The following panels are for “How do I include sounds and images?”
# ####################

<DEFINE PANEL> "Aplml:ChooseRecordOrPaste" 
<FORMAT> "full"
You can include a sound, picture, or QuickTime movie from another document, or you can record a new sound. (To 
record a new sound you must have a microphone connected to your computer.) Which do you want to do? Click one:

<radio button> "Include an existing sound, picture, or movie", true,,,,appleguide
<radio button> "Record a new sound", false,,,,appleguide

<END PANEL>

<DEFINE PANEL> "Aplml:RecordingInfo" 
<panel prompt> "override: r&c"

<FORMAT> "full"
If your computer does not have a built-in microphone, you need to connect a microphone or other audio source to 
your computer's sound input port.

<END PANEL>

<DEFINE PANEL> "Edit: choose Record Sound" 
<FORMAT> "tag"
Do This

<FORMAT> "body"
To record a sound, open the Edit menu and choose Record Sound.

<coach mark> "edit-record sound" 
<END PANEL>

<DEFINE PANEL> "Aplml:UseRecordBox" 
<panel prompt> "override: ddone"
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<FORMAT> "tag"
Do This

<FORMAT> "body"
Use the controls in the Recording dialog box to record and play back sound. When you’re finished, click Save to keep 
your sound.

<END PANEL>

<DEFINE PANEL> "Aplml:GoGetSomething" 
<panel prompt> "override: right"

<FORMAT> "tag"
Do This

<FORMAT> "body"
Locate the sound, picture, or QuickTime movie you want. (You may need to open the Scrapbook or another 
application program.)

Select the item you want to use, then open the Edit menu and choose Copy.

<END PANEL>

<DEFINE PANEL> "Aplml:makeActive" 
<panel prompt> "override: right"

<FORMAT> "tag"
Do This

<FORMAT> "body"
To make AppleMail active, choose AppleMail from the Application menu (or click an open AppleMail window).

<END PANEL>

<DEFINE PANEL> "Aplml:PasteWhere" 
<FORMAT> "tag"
Do This

<FORMAT> "body"
Click the place in your letter at which you want to insert the material you copied.

<END PANEL>

<DEFINE PANEL> "Edit: choose Paste" 
<panel prompt> "override: ddone"
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<FORMAT> "tag"
Do This

<FORMAT> "body"
Open the Edit menu and choose Paste.

<coach mark> "edit-paste" 
<END PANEL>

# ####################
# The following panels are for “How do I play sounds or movies?”
# ####################

<DEFINE PANEL> "Aplml:PlaySoundOrMovie" 
<FORMAT> "full"
You can play sounds and QuickTime movies that have been included in a letter. Which do you want to do? Click one:

<radio button> "Play a sound", true,,,,appleguide
<radio button> "Play a movie", false,,,,appleguide

<END PANEL>

<DEFINE PANEL> "Aplml:PlaySound" 
<panel prompt> "override: ddone"

<FORMAT> "tag"
Do This

<FORMAT> "body"
Double-click the sound you want to play. Sounds have this icon:

<pict> 1000, center

If the sound is too loud or not loud enough, adjust your computer's volume control.

<END PANEL>

<DEFINE PANEL> "Aplml:PlayMovie" 
<panel prompt> "override: tips"

<FORMAT> "tag"
Do This

<FORMAT> "body"
Double-click the movie you want to play.

<END PANEL>

<DEFINE PANEL> "Aplml:MovieTips" 
<panel prompt> "override: rdone"
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<FORMAT> "full"
Click the film icon to open the movie controls.

<pict> 1002, center

Use the movie controls as shown.

<pict> 1004, center

<END PANEL>

# ####################
# The following panels are for “How do I include a file with a letter?”
# ####################

## The following panel is defined in “How do I create a new letter?”
## "File: choose New"

<DEFINE PANEL> "Aplml:addEnclosure intro" 
<FORMAT> "full"
You can enclose any file, program, or folder in a letter by dragging the item to the Enclosures panel. When you add 
enclosures to a letter, a paper clip appears on the right side of the Mailer.

<END PANEL>

<DEFINE PANEL> "Aplml:DragEnclosure" 
<panel prompt> "override: ddone"

<FORMAT> "tag"
Do This

<FORMAT> "body"
Locate the icon of the item you want to enclose. Drag it to the Enclosures panel.

You can add up to 50 enclosures.

<END PANEL>

# ####################
# The following panels are for “How do I save a letter?”
# ####################

## The following panels are defined in “How do I work with letterheads?”
## "File: choose Save As Letterhead"
## "Aplml:NameLetterhead"

<DEFINE PANEL> "Aplml:SaveAsWhat" 
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<FORMAT> "full"
You can save the active letter in the following ways. Which do you want to do? Click one:

<radio button> "Save the letter in the usual way", true,,,,appleguide
<radio button> "Save a copy of the letter under a new name", false,,,,appleguide
<radio button> "Save the letter as a letterhead", false,,,,appleguide
<radio button> "Save the letter as a text file", false,,,,appleguide

<END PANEL>

<DEFINE PANEL> "File: choose Save" 
<panel prompt> "override: right"

<FORMAT> "tag"
Do This

<FORMAT> "body"
Open the File menu and choose Save.

If Save is not available, type the subject of your letter in the Subject panel of the Mailer.

<coach mark> "file-save" 
<END PANEL>

<DEFINE PANEL> "Aplml:StandardFile:ChooseLocation" 
<panel prompt> "override: right"

<FORMAT> "tag"
Do This

<FORMAT> "body"
Use the list and pop-up menu to choose a location in which to save your letter.

For more information on the options in the Save dialog box, open the Guide menu (on the right with the ? icon), 
choose Show Balloons, and then point to the different options. (Choose Hide Balloons when you’re finished.)

<END PANEL>

<DEFINE PANEL> "Aplml:StandardFile:NameFile" 
<FORMAT> "tag"
Do This

<FORMAT> "body"
Type a name for your letter.

<coach mark> "name letter" 
<END PANEL>

<DEFINE PANEL> "Aplml:StandardFile:ClickSave" 
<panel prompt> "override: ddone"
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<FORMAT> "tag"
Do This

<FORMAT> "body"
Click Save.

<coach mark> "Save letter" 
<END PANEL>

<DEFINE PANEL> "File: choose Save As" 
<panel prompt> "override: right"

<FORMAT> "tag"
Do This

<FORMAT> "body"
To save a copy of a letter under a new name, open the File menu and choose Save As.

<coach mark> "file-saveas" 
<END PANEL>

<DEFINE PANEL> "File: choose Save As Text" 
<panel prompt> "override: right"

<FORMAT> "tag"
Do This

<FORMAT> "body"
To save a letter as a text file, open the File menu and choose Save As Text.

<coach mark> "file-saveas text" 
<END PANEL>

# ####################
# The following panels are for “How do I save a letter using a new name?”
# ####################

<DEFINE PANEL> "Aplml:SaveAsIntro" 
<FORMAT> "full"
You can save a copy of an active letter under a new name.

<END PANEL>

## The following panels are defined in “How do I save a letter?”
## "File: choose Save As"
## "Aplml:StandardFile:ChooseLocation"
## "Aplml:StandardFile:NameFile"
## "Aplml:StandardFile:ClickSave"
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# ####################
# The following panels are for “How do I send a letter?”
# ####################

<DEFINE PANEL> "Aplml:BeforeSending" 
<FORMAT> "full"
To send a letter, you address it and type its subject in the Subject panel of the Mailer. Then you use the Mail menu to 
send the letter.

<END PANEL>

<DEFINE PANEL> "Mail: choose Send" 
<panel prompt> "override: right"

<FORMAT> "tag"
Do This

<FORMAT> "body"
Open the Mail menu and choose Send.

If you need instructions on addressing a letter, click Huh? below.

<coach mark> "mail-send" 
<Dimmable Button Data> "Huh?", "How do I address a letter?" 

<END PANEL>

<DEFINE PANEL> "Aplml:SendOptions" 
<panel prompt> "override: ddone"

<FORMAT> "tag"
Do This

<FORMAT> "body"
Select the options you want, then click Send.

For more information on the options in the Send dialog box, open the Guide menu (on the right with the ? icon), 
choose Show Balloons, and then point to the different options. (Choose Hide Balloons when you’re finished.)

<END PANEL>

# ####################
# The following panels are for “How do I reply to a letter?”
# ####################

<DEFINE PANEL> "Aplml:Reply" 
<FORMAT> "full"
When you reply to a letter, you can add additional recipients or enclosures in the Mailer.

<END PANEL>
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<DEFINE PANEL> "Mail: choose Reply" 
<panel prompt> "override: right"

<FORMAT> "tag"
Do This

<FORMAT> "body"
To reply to a letter, open the Mail menu and choose Reply.

You type your reply in the content area of the new letter that appears. 

<coach mark> "mail-reply" 
<END PANEL>

<DEFINE PANEL> "Aplml:ReplyOptions" 
<panel prompt> "override: ddone"

<FORMAT> "tag"
Do This

<FORMAT> "body"
Select the options you want, then click OK.

For more information on the options in the Reply dialog box, open the Guide menu (on the right with the ? icon), 
choose Show Balloons, and then point to the different options. (Choose Hide Balloons when you’re finished.)

<END PANEL>

# ####################
# The following panels are for “How do I forward a letter?”
# ####################

<DEFINE PANEL> "Aplml:Forward intro" 
<FORMAT> "full"
You can forward mail you receive, changing the content and enclosures as necessary.

<END PANEL>

<DEFINE PANEL> "Letter: existing not open" 
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<FORMAT> "tag"

Do This

<FORMAT> "body"
You need to open a letter you have received.

Open your Mailbox, then open a letter in your In Tray.

<END PANEL>

<DEFINE PANEL> "Mail: choose Forward" 
<FORMAT> "tag"
Do This

<FORMAT> "body"
Open the Mail menu and choose Forward.

A new Mailer form appears on top of the original one with the letter’s old title preceded by Fwd>.

<coach mark> "mail-forward" 
<END PANEL>

<DEFINE PANEL> "Aplml:addForwardAddress" 
<FORMAT> "tag"
Do This

<FORMAT> "body"
Add the forwarding addresses and make any other necessary changes in the forwarding Mailer.

If you need instructions on addressing a letter, click Huh? below.

<Dimmable Button Data> "Huh?", "How do I address a letter?" 
<END PANEL>

# ####################
# The following panels are for “How do I save an address?”
# ####################

<DEFINE PANEL> "Aplml:PickAddress" 
<panel prompt> "override: right"
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<FORMAT> "tag"
Do This

<FORMAT> "body"
Open the Recipients panel of the Mailer and locate the address you want to save.

If you need instructions on addressing a letter, click Huh? below.

<Dimmable Button Data> "Huh?", "How do I address a letter?" 
<END PANEL>

<DEFINE PANEL> "Aplml:DragAddress" 
<panel prompt> "override: ddone"

<FORMAT> "tag"
Do This

<FORMAT> "body"
Drag the address from the Recipients panel to the location where you want to save it (for example, your personal 
catalog or a folder on your hard disk).

<coach mark> "recipients" 
<END PANEL>

# ####################
# The following panels are for “How do I sign a letter?”
# ####################

## The following panel is defined in “How do I send a letter?”
## "Mail: choose Send"

<DEFINE PANEL> "Aplml:BeforeSigning" 
<FORMAT> "full"
To sign a letter, you must have an approved Signer (digital signature) file on your hard disk. If you have this file, you 
can sign your letter by selecting an option when you send the letter.

If you need information on obtaining an approved Signer file, click Huh? below.

<dimmable button data> "Huh?", "How do I obtain an approved Signer file?"
<END PANEL>

<DEFINE PANEL> "Aplml:ClickSign" 
<panel prompt> "override: ddone"
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<FORMAT> "tag"
Do This

<FORMAT> "body"
Click Sign Letter. 

Then when you send the letter, it will be signed with your approved signature, from the Signer file.

<coach mark> "sign" 
<END PANEL>

# ####################
# The following panels are for “How do I obtain an approved Signer file?” 
# ####################

<DEFINE PANEL> "howdoi: obtain a signer file: begin" 
<panel prompt> "override: rdone"

<FORMAT> "full"
To obtain a valid Signer file, you send a request form to a person or agency that has the authority to issue you an 
approval file.

If your company is authorized to issue approval files for its employees, it will probably provide you with a special 
Signer request form.

For instructions on using an outside approval authority to obtain an approval file, open the Application menu at the 
far-right corner of the screen and choose Finder. Then open the Guide menu (on the right with the ? icon) and choose 
PowerTalk Guide.

<END PANEL>

# ####################
# The following panels are for “How do I organize letters?”
# ####################

<DEFINE PANEL> "Aplml:AboutTags" 
<FORMAT> "full"
You can organize letters in your In Tray by using Tags in the Mail menu. 

Tags are labels you can apply to letters. You can have as many tags as you need. A letter can have more than one 
tag.

<END PANEL>

<DEFINE PANEL> "Mail: choose Tag Letter" 
<panel prompt> "override: right"



AppleMail Guide 1.0b4 Panels 21 May 20, 2025

<FORMAT> "tag"
Do This

<FORMAT> "body"
Open the Mail menu and choose Tag Letter.

<coach mark> "mail-tag letter" 
<END PANEL>

<DEFINE PANEL> "Aplml:TagLetter" 
<FORMAT> "tag"
Do This

<FORMAT> "body"
Choose a tag from the pop-up menu, or type a new tag in the box.

<coach mark> "tag name" 
<END PANEL>

<DEFINE PANEL> "Aplml:ClickTag" 
<FORMAT> "tag"
Do This

<FORMAT> "body"
Click Tag.

<coach mark> "click Tag" 
<END PANEL>

<DEFINE PANEL> "Aplml:DoneTagging" 
<panel prompt> "override: ddone"

<FORMAT> "tag"
Do This

<FORMAT> "body"
To apply another tag, choose or type a tag, then click Tag.

When you’ve added as many tags as you want to, click Done.

<coach mark> "done Tagging" 
<END PANEL>

# ####################
# The following panels are for “How do I open a file sent with a letter?”
# ####################

<DEFINE PANEL> "Aplml:OpenEnclosure" 
<panel prompt> "override: ddone"
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<FORMAT> "tag"
Do This

Do This

<FORMAT> "body"
To open an enclosed file, double-click the file in the Enclosures panel.

To copy an enclosed file, drag the file to the location where you want it saved.

<END PANEL>

# ####################
# The following panels are for “How do I open the next letter in my In Tray?”
# ####################

<DEFINE PANEL> "Mail: choose Open Next Letter" 
<panel prompt> "override: ddone"

<FORMAT> "tag"
Do This

<FORMAT> "body"
To open the next letter in your In Tray, open the Mail menu and choose Open Next Letter.

<coach mark> "mail-open next letter" 
<END PANEL>

# ####################
# The following panels are for “How do I delete a letter?”
# ####################

<DEFINE PANEL> "File: choose Delete" 
<panel prompt> "override: ddone"

<FORMAT> "tag"
Do This

<FORMAT> "body"
To delete a letter from your In Tray, open the File menu and choose Delete.

If Delete is not available, the letter you’ve opened may not be in your In Tray.

<coach mark> "file-delete" 
<END PANEL>

# ####################
# The following panels are for “How do I print a letter?”
# ####################
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<DEFINE PANEL> "File: choose Print" 
<panel prompt> "override: right"

<FORMAT> "tag"
Do This

<FORMAT> "body"
To print a letter, open the File menu and choose Print.

<coach mark> "file-print" 
<END PANEL>

<DEFINE PANEL> "Aplml:PrintOptions" 
<panel prompt> "override: ddone"

<FORMAT> "tag"
Do This

<FORMAT> "body"
Select the options you want, then click Print.

For more information on the options in the Print dialog box, open the Guide menu (on the right with the ? icon), 
choose Show Balloons, and then point to the different options. (Choose Hide Balloons when you’re finished.)

<END PANEL>

#
# The beginning of the “Shortcuts” portion
#

# ####################
# The following panels are for “shortcuts for addressing a letter”
# ####################

<DEFINE PANEL> "Aplml:AddrTips" 
<panel prompt> "read & click"

<FORMAT> "full"
The quickest way to address a letter is to drag an information card into the Recipients panel.

<END PANEL>

<DEFINE PANEL> "Aplml:AddrTips2" 
<panel prompt> "read & click"

<FORMAT> "full"
When you type an address, be careful. Spelling or format errors will prevent mail delivery.

<END PANEL>
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<DEFINE PANEL> "Aplml:AddrTips3" 
<panel prompt> "read & click"

<FORMAT> "full"
For any Direct AppleTalk mail address that you type, the system assumes the address is in your zone if you don't 
specify a zone. (It adds "@<your zone>" to the address.)

<END PANEL>

<DEFINE PANEL> "Aplml:AddrTips4" 
<panel prompt> "override: rdone"

<FORMAT> "full"
The more of a PowerShare address you type, the less time the system spends searching for it.

Be sure to use the @ symbol immediately before the name of a catalog, and use a colon (:) immediately before the 
name of a folder.

<END PANEL>

# ####################
# The following panels are for “shortcuts for using the Mailer”
# ####################

<DEFINE PANEL> "Aplml:MailerTips1" 
<panel prompt> "read & click"
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<FORMAT> "full"
Shortcuts for using the Mailer:
To do this…

Expand/Collapse Mailer

Switch areas in Mailer

Open addressing panel

Switch between Mailer 
and AppleMail content 
area

<FORMAT> "full2"
…use this shortcut

Press Command-/

Press Tab

Select Recipients area and 
press Return or Enter

Press Option-Tab
 

<dimmable button data> "Huh?", "Definition of Mailer"
<END PANEL>

<DEFINE PANEL> "Aplml:MailerTips2" 
<panel prompt> "override: moreinfo"
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<FORMAT> "full"
Shortcuts for using the addressing panel of the Mailer:
To do this…

Move up and down a list

Move to next/previous 
panel

Close addressing panel

<FORMAT> "full2"
…use this shortcut

Type first letter or two of 
a name
Press Up or Down Arrow keys

Press Option-Up Arrow key
Press Option-Down Arrow key

Press Escape key
<END PANEL>

<DEFINE PANEL> "Aplml:MailerTips3" 
<panel prompt> "override: moreinfo"

<FORMAT> "full"
Shortcuts for using the addressing panel of the Mailer:
To do this…

Add item as main
recipient

Add item as copy

Add item as blind copy

<FORMAT> "full2"
…use this shortcut

Double-click item
Click item and press Return

Press Shift-Return
Press Shift and double-click item

Press Option and click BCC
Press Shift-Option and double-click item
Press Shift-Option-Return

<END PANEL>
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<DEFINE PANEL> "Aplml:MailerTips4" 
<panel prompt> "override: rdone"

<FORMAT> "full"
Shortcuts for using the addressing panel of the Mailer:
To do this…

Add item to preferred 
personal catalog
<FORMAT> "full2"
…use this shortcut

Press Option and click Save button
Press Option and double-click item
Press Option-Return

<END PANEL>


