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Let’s Tell a Story

What if you wanted to use your own photos, drawings, words and

sounds—combined with pictures from a special Treasure Chest to

tell a story, make a presentation, or just to have fun? With

Imaginator! you can do all this and show off your work as full-

screen slide shows, printed stories, or movies. You can even put your

movies on floppy disks and share them with your friends.

By clicking on a few buttons with your mouse, typing on your key-

board, and talking into your microphone, you can quickly and easily

create lively pages and stories with Imaginator!

Think of the different ways people tell stories. How many different

ways can you think of? How about:

• live storytelling • prose

• mime • poetry

• slide shows • songs

• theater • film

• television • dance

With Imaginator! you have one more way to tell stories—with your

computer. If you’ve ever watched a live storyteller you may have

noticed that the storyteller sometimes uses special props such as a

costume or mask to illustrate certain parts of the story. Instead of

using props you can use pictures, words and sounds to tell your sto-

ries. Instead of putting on a costume you may want to take a photo-

graph of your face (from a Photo CD) and place it on a cartoon from

one of our Treasure Chests of pictures. By adding more characters

and a background, you’ll set the stage for your own very exciting

story—ready to unfold. 
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some of the various types of stories, such as:

• mystery • history

• comedy • science fiction

• fiction • biography

• non-fiction • autobiography

Where does the story take place? Stories typically involve a setting.

Some settings that come to mind are:

• a vacation

• the beach, zoo, or park

• inside or outside a school

• the car, bus, train, plane, etc.

• a family gathering

• your home

• a pretend place

The content of your story can be almost anything. It could include:

• facts • dramatic moments

• jokes • scientific observations

• ideas • rumors

• fantasies • gossip

• dreams

Stories can be created and told by one person, or they can be created

and told by a group. For example, if only one person saw something,

then only that person can tell a story about it. On the other hand, if

an entire class saw something, or learned about something together,

everyone might want to contribute to the same story. One interest-

ing project would be to see what would happen if a group of people

witnessed the same thing and, in the telling of the story, one person

began it and another picked it up, followed by another person, until

the conclusion. How would it be different from just one person

telling the story?
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Remember that a good story has a:

• beginning,

• middle,

• and an end.

Before you start, consider putting together a storyboard or plan for

each part or page of your story. For example, if your story is going to

be ten pages long, try creating a set of index cards that describes the

action for each page. 

Variety helps maintain the attention of your audience. Unusual

sounds, dazzling pictures, brightly colored text, and other special

effects add pizazz!
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QUICK-START GUIDE

To start Imaginator!
After performing the installation (see page 39), find

the Imaginator! application icon and double-click on

it. The application will launch and you will soon see

the Control Panel and a blank page.  If you do not

want to hear the opening music, just click the mouse

or hit any key on your keyboard.

Note:  To hear sounds with the Windows version, you

must have a Sound Blaster or compatible sound

card.

Animate the Control Panel
For fun, you can animate the 

Control Panel icons by clicking 

and holding your mouse on 

each one.

TREASURE CHESTS

PHOTO CD

WRITE 

ADD SOUND

PAINT 

STORYBOARD

PLAY STORY

A special note about this manual
All pictures in this manual are from the Macintosh version.

Imaginator! for Windows may look slightly different.
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Let’s start with the Treasure Chests

Click on the Treasure Chest icon and the viewfinder will appear.

QUICK-START GUIDE
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CLICK ON A
PREVIEW
PICTURE. 1
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Four Easy Steps for Using the Treasure Chests

While in the Treasure Chests: 

1. Click on a preview picture. Notice that the picture becomes

highlighted and a text description may appear in the text box

below the preview pictures. Most importantly, the Add button

becomes available.

2. Click the Add button and the title of the picture you 

choose will appear in the “My Story” area. (You can also dou-

ble-click on a preview picture and it will automatically be

added to your list.)

3. Click the OK button and the picture(s) you added will auto-

matically appear on your page. 

4. Check out our different categories by clicking on the

name of the category you’d like to view. That’s all there is to it!
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You can select as many pictures as you want and add or remove

them from the “My Story” area. To remove a name from “My Story,”

click on the name of the picture, then click on the Remove button;

or double-click on the name of the picture and it will be removed

from your list.

Once your Treasure Chest pictures appear on the page they become

graphic objects that are selectable, movable, and able to be resized.

Work with pictures on the page
• To move a picture, click and hold the mouse in the center of the

picture. When the mouse is in the center of the picture it turns

into a hand. Use the hand to drag the picture to a new location

on the page.

• To re-size a picture, click on it, then click and drag one of the four

square “handles” toward or away from the center of the picture

(towards the center will make the picture smaller, while pulling

away will make the it bigger). The proportions of the picture
will automatically stay the same when it is resized on the
page.

Work with multiple pictures or “objects” on
the page

Imaginator! offers a powerful and easy-to-use

method of working with graphic, text and sound

objects. When pictures are placed on the page

they are arranged on top of each other in invisi-

ble layers. To control the layer in which a pic-

ture appears, you must first click on the picture

you want to move, then choose one of the com-

mands under the Page menu.

QUICK-START GUIDE
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Add sound to a picture or text

Any picture on an Imaginator! page can have both graphic informa-

tion and sound information. You can add as many different sounds

to your page as you have graphic or text objects. 

To add sound to a picture or text object, click on the object to select

it, then click on the Sound icon.  The sound recorder will appear

(as pictured below). Record your voice with your microphone or

import a sound by clicking on the Import button. The sound will

automatically be linked to the picture or text selected. After record-

ing your first sound, a number “1” will appear when the object is

clicked on to indicate this is the first sound you have added to the

page. To add an additional sound to the same page, click on another

object and record your sound. Additional sounds will be numbered

“2”, “3”, etc., according to the order they are recorded. Imaginator!

also allows you to re-order and delete sounds within the page. 

Add more pages

To add more pages to your story, choose the Add Page command

from the Story menu. You can move between pages by clicking and

holding on the Page Indicator in the lower left corner of the screen.

Drag your mouse to the desired page number and release.

QUICK-START GUIDE
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Moving between pages

Notice the page guide on the lower left-hand side of the screen. Click

and drag your mouse on the page guide to move quickly from one

page to another. 

Add a Photo CD picture

If you wish to take advantage of the Imaginator!

Photo CD capability, place your Photo CD into your

CD-ROM drive, then click on the Photo CD icon in the Imaginator!

Control Panel. This will take you to the Photo CD browser. The first

time you request a Photo CD you will get a dialog box asking you to

locate the disc. Once you have selected your Photo CD disc you will

not be asked for its location again during the running of the applica-

tion.

Three Easy Steps for Adding Photo CD Pictures

1. Click on a thumbnail picture. Notice that the picture

becomes highlighted and appears in the Preview area.

2. Click on a size (Thumbnail, Postcard or Full Page). This

is the relative size your picture will be when it appears on the

page. You also have the option to Rotate or Mirror your

picture.

3. Click the OK button. Your picture will be sent to the page.

On the page it becomes a graphic object, ready to be moved, re-

sized, or sent to the Paint Box (by double-clicking) for editing.

You can also add sound to this picture.

QUICK-START GUIDE



After you have finished typing, click somewhere else on the screen

and the text becomes a movable and re-sizable object. Just click once

in the center and four black rectangles (handles) will appear. You

can also add sound to a text object (see Page 4).

When you re-size a text object (by clicking on and dragging the han-

dles) your words will re-flow automatically.

Double-clicking inside the text box will cause it to become highlight-

ed. You can then change the font, font size, style, text color, back-

ground color and background pattern.
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Write

Click the mouse on the Write icon in the

Control Panel and a blank text box will

appear in the center of the page. You can

begin typing in this box. 

Paint

Access the Paint Box by double-clicking 

on any picture or object on the page or by clicking on the Paint icon
in the Control Panel. The difference between the two techniques is

that double-clicking on a graphic object will send that object into the

Paint Box. Clicking on the paint icon in the Control Panel will bring

you into the Paint Box with an empty canvas.

QUICK-START GUIDE
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Try a cookie-cutter

In the Paint Box, our unique Cookie-

Cutter Technology allows you to choose

from a group of shapes, making the diffi-

cult task of cutting and pasting simple

and fun to do! Click and hold the mouse

down on the cookie-cutter tool and you

will  get a pop-up palette. Drag the palette

onto the Paint Box canvas and then release it.

The Paint Box:  Three Important Steps

1. Have fun! Paint your own masterpiece or alter graphics that

you bring in from the page by double clicking.

2. When your work is finished, click on a Cookie-

Cutter or any other selection tool, then click

and drag your mouse across the portion of

your work that you want to send back to

the page.

3. Click once on the Send button (“mailbox”) to send your selec-

tion back to the page!

Working with the cookie-cutter shapes

1. Click on a cookie-cutter shape (apple, hand, tree, etc.) and make

your selection by clicking and dragging the mouse across the

area you want to cookie cut (select).

2. Select Cookie Cut from the Tools menu. 

3. You can also hit the delete key to cut the cookie shape out of

your picture.

QUICK-START GUIDE
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Storyboard

The Storyboard feature allows you to re-order the pages of your

story and set transitions between pages for really exciting full-

screen slide shows. To access the Storyboard click on the

Storyboard icon in the Control Panel. You will see a dialog box

with thumbnail images of each page you have created.

• To re-order the pages in your story click and drag the

thumbnail versions of your pages to their desired location in the

Storyboard.

• To add transitions to your slide show double-click on the

thumbnail version of your page. Then select a transition from the

Transition Selection box which pops up. A graphic representation

of your transition will appear in the lower-left corner of your

page on the Storyboard.

QUICK-START GUIDE



Play your story

To play your slide show click on the Play icon in the

Control Panel. The Play feature displays all the

pages you’ve created, in sequence, with a one second time delay

between pages by default. If you want to alter the time delay or

choose transition effects, first go into the Storyboard and make your

choices. Then run your show!
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• To change the delay time between slides click on the options
button. You can also deselect the automatic button and move
your slide show forward manually with a mouse click each time
you wish to advance through the pages.

Note the icons next to the page number

The Note icon: When you add sound to a picture or text object, the

slash across the note disappears and you can play the sound by click-

ing on this icon (when the object is selected). If you Select All and

then click on the note, all of the sounds on that page will play, in

order.

Windows users: In between the page numbers and the note icon,

there’s a slide transition icon. You can set the slide transition for the

page by clicking on the transition icon and then selecting a transi-

tion. The default setting is a straight “cut” (the jagged line icon).

QUICK-START GUIDE



How to think about the Imaginator! page

Imaginator! uses “the page” as a basis for creating multimedia pre-

sentations or stories. Graphic objects (pictures), text, and sounds are

treated as individual objects that can easily be moved, edited or delet-

ed, either separately or as a group. They are arranged in separate,

invisible layers. Each object can easily be moved from one layer to

another.

In many ways an Imaginator! page is similar to a page from a page-

layout or desktop publishing application. The basic goal of an

Imaginator! page is to prepare for a full-screen slide show, whereas

the goal of a page from a page-layout application is to prepare for

paper output. Although you can print the stories you create with

Imaginator!, you will miss out on the sounds and transitions that can

be an integral part of your stories.

Working with pictures and text objects on the page

To select a picture or text object, move your mouse over the object

you want to select so that the cursor changes to a “hand” and click

once. Four rectangles, called “handles”, appear around the selected

object. If you have multiple objects on a page, the tab key allows you

to move from one selected object to another. Shift-tab cycles your

selections in the opposite direction. 
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To select multiple objects, click on one object, then while holding

down the shift key, click on the other objects you wish to select. All

the objects you click on will be selected. 

To select all of the objects on a page, choose Select All from the

Edit menu.

To move an object, click once in the center of it and hold down the

mouse while dragging it to a new location on the page. (Notice that

the basic shape of the object appears in outline form while the object

is being dragged. This helps in understanding where it is on the

page.) You can also move several objects at once by selecting them

according to the method outlined above.

To re-size an object, click on it, then drag one of the four handles

towards or away from the center of the object (towards the center

will reduce the size of the object, while pulling away will expand the

size of the object). The proportions of the object will always stay the

same. If you want to change the proportions, you can send the object

to the Paint Box by double clicking on it.

De-select an object or objects by clicking on any free space on the

page. If an object completely fills the page, thereby eliminating any

free space, holding down the shift key while clicking once will de-

select a single object.  

To delete an object, make sure it is selected and then hit the delete

key or choose Clear from the Edit menu.

To copy, cut and paste an object from one page to another, or

from another application into Imaginator!, select the object and

choose the Copy or Cut command from the Edit menu.

11

To import a PICT or BMP file, choose Import... from the

File menu.  
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Working with pictures and text in layers

Pictures and text appear on the page in invisible layers. They are

stacked in the order in which they are chosen. To move a picture

from one layer to another, click on it, then choose one of these

options from the Page menu:  Move to Front, Move Forward,

Move to Back, or Move Backward.

In the example to the right,

the Move Backward
command causes the

alligator to move back just

one layer at a time. 

Notice that the alligator

moves between

the gorilla and the couch.

By choosing the Move
Backward command again

the alligator moves back one

more layer, behind the couch.

The Move to Back command sends object(s) to the very back layer

of the page in one step. Move Forward sends object(s) forward one

layer at a time and Move To Front sends object(s) to the front in

one step.
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Backgrounds

Colored and patterned backgrounds are a good way to add visual
excitement to your stories and do not take up much memory.

To change the background color or to add a pattern, choose the
Background command under the Page menu. It offers a choice of
256 colors and a variety of patterns through a pop-up dialog box.
Your background will automatically appear behind any graphic
and/or text objects on the page.

To change the background you must click
on one of the 3 pop-up palettes in the
Page Background box .

Changing the background

The default Imaginator! background is
light green.  To change the background
color to white, for example, click on the
rainbow icon on the left and select the
white box in the upper right hand corner.
To change the pattern, click and hold on
the checkerboard icon in the center and
select your pattern. 

The rainbow palette on the left allows you to change solid back-
grounds and the the black  dots and lines that are created from the
patterns palette to any of 256 colors. 

The rainbow palette on the right allows you to change the white 
dots and lines that are created from the patterns palette to any of
256 colors. 

A preview of the background pattern and color(s) you have selected
appears in the top portion of the Page Background box.

Printing the pages of your story

Choose the Print command under the File menu. Remember that
if you have a black and white printer you may want to remove col-
ored backgrounds from your pages, as the colors will appear black
when printed. Imaginator! supports most color printers, so you can
keep your pages intact if you are outputting to a color printer.



What You’ll See in the Treasure Chest Viewfinder

• Previews of Treasure Chest files: collections of pictures and back-

grounds with titles and text descriptions.

• Preview versions of each picture are displayed in the Treasure

Chest viewfinder. You can scroll through the pictures and/or

backgrounds in each category by clicking your mouse on the up

or down arrows next to row of preview pictures.

• Below the row of preview pictures, there is a text description of

the highlighted picture. 

The Treasure Chest icon gives you easy access to a

large collection of high-quality pictures and back-

grounds. It includes high-resolution photographs and

custom illustrations that can be accessed over and

over again. If you have any suggestions for Treasure

Chest themes, please let us know. We are committed to providing

Treasure Chests that meet the needs of our users.

Imaginator! is designed to seamlessly access Treasure Chest files

when they are placed in the same location on your hard drive as the
Imaginator application. Multiple Treasure Chest files can be

accessed at the same time through the viewfinder.
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THE TREASURE CHESTS



• Because the pictures in the Treasure Chest are divided into sev-

eral different categories such as Just My Type, Imaginator!

People, Imaginator! Places, and Imaginator! Animals, you can

choose which group of pictures or backgrounds you want to see

by making a selection from the Pictures and Backgrounds
list. Click your mouse on any category listed under Pictures and

Backgrounds and a new group of preview pictures appears. 

• The My Story area lists the titles of the pictures and back-

grounds you have selected. These are the pictures and/or back-

grounds that will be sent to your page when you click on the OK
button.

• The Add button places the currently highlighted preview picture

into the My Story area. You can also double-click on a preview

picture to accomplish the same thing. The Remove button

removes a highlighted picture title from the My Story area.

Double-clicking on a picture or background title while it is in the

My Story area will also remove it.

• The OK button sends all of your pictures from the My List area

to the page in one step. The Cancel button simply returns you to

the page without any new pictures.

15

Note: With Imaginator! for Windows, you may need to double-click

on a category folder in the Pictures and Backgrounds area in order

to see the different sub-categories located within that folder. 
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ADD PHOTOS

The Imaginator! Photo CD browser allows you to pre-

view and then select pictures from your own Photo

CDs. 

What is a Photo CD?

A Photo CD is a compact disc capable of storing 35mm photographs

digitally for use on your personal computer. Many local photofinish-

ers can create a Photo CD for you from any 35mm roll of print or

slide film. Once your film is processed, it is scanned, converting the

light into digital information (ones and zeros). This data is then

“written” to a Photo CD. Over 100 photographs fit onto a single

Photo CD. Any Photo CD you create can be viewed on a computer

with the appropriate software and a CD-ROM drive. 

Single-session versus multi-session Photo CDs

Some of the older CD-ROM drives recognize only single-session

Photo CDs (check with your manufacturer). A single-session Photo

CD contains photographs that are all written to the Photo CD at the

same time by the photofinisher. For example, if you drop off one or

two rolls of film to be put on a new Photo CD, you will get back a

Photo CD with one session on it. There is room on that disc for more

pictures to be added later, but that would create multiple sessions.

Only the newer CD-ROM drives recognize multi-session Photo CDs.

If you have a CD-ROM drive that recognizes only single-session

Photo CDs, consider dropping off many rolls of film at one time. Be

sure to specify to your photofinisher that you want single-session

only. Also, check with your CD-ROM manufacturer to see if you need

an updated software driver.



The Photo CD Browser

For basic instructions on accessing Photo CDs, see Page 5 in the

Quick-Start section.
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The Photo CD Browser has several features:

• Photographs on your CD are previewed as thumbnail pictures

that can be browsed by clicking on the up or down arrows. 

• You determine the relative size of the photograph you send to the

page by choosing either Thumbnail, Postcard, or Full Page.

Orientation of the photograph (Rotated, Mirrored) can be

changed by first choosing the picture size, then clicking on the

orientation buttons to the right. The Rotate button will turn the

picture counter-clockwise in 90 degree

increments. When you click on the

Mirror button your picture flips hori-

zontally, creating a mirror image of

itself.

• The OK button sends the currently selected photograph to the

page. Cancel returns you to the page without a new photo. The

Change CD button allows you to switch to another Photo CD

while remaining in the browser.

Note: To bring photographs or other graphic images saved as PICT

(Macintosh) or BMP (Windows) files into Imaginator!, choose

Import... from the Page menu. 

ROTATE       MIRROR



For basic instructions on how to use the Write Box,

see Page 6 in the Quick-Start section.
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WRITE BOX

In addition to being able to choose a font, font size, style, alignment,

and color, you can also add a background color, pattern, and border

to any text box in Imaginator!.

Here’s how to create a background for your text

1) Double–click on any text box you have created.

2) Go to the Text menu and select Background.

3) The Text Background box will appear.

To add a background to your text box, click once on the check box

next to the word “Background”. The default background pattern is

solid. To change the background pattern, click and hold the checker-

board palette in the middle and select your pattern.

The rainbow palette on the left allows you to change a solid color

background or the black dots and lines that are created from the pat-

terns palette to any of 256 colors.

The rainbow palette on the right allows you to change the white 

dots and lines that are created from the patterns palette to any of

256 colors. 



Re-sizing text boxes

Any text box can be selected, re-sized, and moved as any other
graphical object. To adjust the size and shape of your text box,
just click and drag one of the four handles that appear at the corners
when the box is selected. The text will re-flow automatically. 

And finally, you can create a border for your text box and a color

for the border. Click on the check box next to the word “Border”in

the Text Background dialog box, then click and hold the border

thickness palette on the left. The rainbow palette on the right gives

you a choice of 256 colors.
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You can also select (click on) a text object (so that the handles
appear), then add sound to it (see Page 20).

Double-clicking on a text box highlights the text for editing. You can
modify all or part of your text, change the background or border.

You can paste text that you have copied from another application
into Imaginator! by first clicking on the Write icon (to create a text
box), then choosing Paste from the Edit menu.



Imaginator uses a unique way to add sounds to your

story. Rather than attaching sounds to the page itself,

which would limit you to only one sound per page,

sounds can be attached to each picture or text object.

To add sound to a picture or text object, first select it with your

mouse, then click once on the

Sound icon in the Control Panel.

You will then see a dialog box like

the one to the right.

To record sounds, be sure that

your microphone, cassette player,

or other sound input device is plugged into the appropriate port on

your computer. Then click on the Record button (as pictured in the

box above) and either talk into the microphone or press play on your

sound input device.

Click on the Stop button when you have finished recording. You can

also click on the Pause button if you want to temporarily stop record-

ing. Clicking on the Play button will play back what you have record-

ed. (Note: If you were to click on the record button once again, you

would record over your first recording.)

To import a pre-recorded or digitized sound, click on the Import
button in the Sound dialog box. Imaginator! allows approximately 20
seconds of recorded or imported sound per picture or text box.

Once sound is added to an object, the musical note next to the page

number becomes active. If the object is selected, clicking on the note

will play your sound. Click again and the sound will stop. Selecting

several objects and clicking on the note will play several sounds, in

order.

20

SOUND
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Deleting and editing sounds on a page

• To delete a sound, click on a picture or text object and choose
Delete Sound from the Page menu. 

• To edit or replace a sound, select a picture or text object and
choose Edit Sound from the Page menu.

Re-ordering sounds

The sounds attached to pictures and text can be re-ordered on a

page. (Please keep in mind that only one sound can play at a time.)

To re-order the sequence of sounds on a page, choose Re-order
Sounds from the Page menu. You will get a dialog box like the one

below, with a separate window for each picture or text object that

has sound. To re-order your sounds, click on one of the windows and

drag it to a different location. The sounds will automatically re-order

themselves. If you click on the Play button, you will hear the sounds

on the page in sequence. Click on the OK button when you’re done.

Special Note: When creating your stories, adding sound should be the

final step. Sounds attached to objects brought into the Paint Box (by double

clicking) will be erased. Also note that sounds take up a large amount of

disk space. So it’s a good idea to create short sound recordings.



In the Imaginator! Paint Box you can draw and paint

your own pictures or make changes to  pictures from

the Treasure Chests, a Photo CD, or an imported pic-

ture file. 
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PAINT BOX

There are two different ways to enter the Paint Box:

1. Double-clicking on any picture on the page brings that picture

into the Paint Box. Once your picture is in the Paint Box you can

make artistic changes to it. For example, you might want to

paint a mustache on a face. If you bring a picture into the Paint

Box by accident, immediately choose Undo from the Edit menu. 

2. Clicking once on the Paint Box icon in the Control Panel leaves

everything on the page as is, and takes you to the Paint Box with

an empty canvas. You can create a new picture in the Paint Box,

send it back to the page, and not alter anything originally on the

page.  You simply add to it. 

Note: When a picture is brought into the Paint Box, any sound
that may have been added to that object will be erased.
However, when you return to the page, any new artwork that has

been “sent” from the Paint Box becomes a picture you can add sound

to.

For basic instructions on how to use the Paint Box, see Page 6 in

the Quick Start section.

Some important details about the Paint Box

Several pictures can be brought into the Paint Box at one time. Click

on one picture, then while holding down the shift key, click on the

other pictures you wish to select. Finally, double-click on the group

to enter the Paint Box.



Note: When picture(s) are brought into the Paint Box,

the painting surface is automatically cleared of every-

thing except those picture(s). 

A tool from the Paint Box palette is selected by click-

ing on its icon. The icon darkens to indicate that it has 

been selected. Icons with small triangles in the

lower-right corner indicate that more tools are avail-

able as pop-up palettes. 
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To activate the pop-up palettes, click and hold down

the mouse on any icon with a small arrow in the lower

right hand corner. You can also drag the palette onto

the Paint Box canvas and release the mouse. The

palette will detach itself. To close a pop-up palette,

click the close box in the upper-left corner.

The Paint Box Tool Palette

Paint Brush

Choose from eight sizes and any of 256 colors.

Pencil

Has a one-point thickness with a choice of 

256 colors.

Eraser

Choose from eight sizes. Double-clicking on the

eraser clears the screen.



The Preview Area

The preview area is where you can choose colors, patterns and

line/border thicknesses to see how they will look.

Preview line/border colors and thicknesses.

Preview fill colors and patterns.

Paint Bucket

Fills an area with color, including the entire Paint Box.

(Try it as a base for cookie cutters.)

Spray Can

Uses the line color from the Line Preview area (see

below) to spray at four different sizes.

Eye Dropper

Takes the color temperature of a pixel (point) on the Paint

Box canvas and changes the fill color accordingly. Holding

the Shift key changes the color to the Line color.

Rectangles

Make rectangles with different fills, patterns, and line

colors. Rectangle borders can have different thicknesses.

Holding the shift key while dragging the rectangle tool 

will restrict the shape to a square. The same functions are

true for rounded rectangles, except the rectangles will 

be rounded.

Lines & Circles

Uses the color from the Line Preview area. Holding the

shift key while dragging the line tool will restrict the shape

to straight lines at 45 degree angles. Holding the shift key

while dragging the circle tool will restrict the shape to a

perfect circle.
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The Line Width palette gives line widths 

for the rectangle, rounded rectangle, line and

circle tools.
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The Fill Color palette is a pop-up palette with

256 fill colors. 

The Line Color palette uses the same set of 

colors as the Fill Color palette.

The Fill Pattern pop-up palette is used by the

paint bucket, rectangle, rounded rectangle and

circle tools.

Cookie-Cutter Technology

Cookie-Cutter Technology is designed to make it easy for you to cre-

ate special effects in fun shapes. The tools available for this are the

standard rectangle, circle, and lasso tools, along with twenty unique

cookie-cutter shapes.



The term cookie-cutter technology comes from what we do with real

cookie-cutters and cookie dough. Imagine cookie-cutters in all differ-

ent shapes. Now imagine some cookie dough rolled out on a table.

Think of the Paint Box as that dough, but instead of just chocolate

chips you have lots of colors and patterns for making all sorts of

cookies. To put shapes into the real cookie dough you push the cook-

ie-cutter onto the dough, and then remove the shaped dough and put

it onto a baking sheet. In almost this same way you can use the

cookie-cutter tools in the Paint Box to create a shape and then

“send” it back to the page.

Once you have created a picture in the paint box you can:

• Send it back to the page* by selecting all or part of it and

clicking on the “mailbox” tool

• Clear (The delete key acts like

clear.) 

• Move (drag)

• Clone (option-drag—makes a duplicate.)

• Cookie Cut Selection—deletes everything outside of 

the selection

• Flip horizontal * ∆—flips the picture so that you get a mirror

image of the original

• Flip vertical * ∆—flips the picture upside-down

• Rotate counter-clockwise (90 degree increments) * ∆—rotates

the picture counter-clockwise

• Resize * ∆—creates handles for re-sizing

Note: Items with an asterisk (*) must first be “selected” with the

rectangle shaped selection tool. Items marked with a delta (∆) are

available only through the Tools menu.

A note about re-sizing: In the Paint Box, the action of re-sizing

will not maintain the proportions of the image. Proportions of any

graphic image are only maintained during re-sizing on the page.
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The Paint Box palette can be dragged around your screen. To drag

the palette, click and drag the bar at the top of the palette.

For Help in the Paint Box:  Click on the question mark in the bot-

tom left corner.
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Have fun with Cookie-Cutter Technology

Try this!

1. Select a picture from one of the Imaginator! Treasure Chests
and bring it onto your page.

2. Double-click on the picture to bring it into the Paint Box.

2. Choose a fill color from the rainbow palette below the fill color

preview box (see Page 24).

3. Click on the Paint Bucket tool and click anywhere on the white

portion of the screen. (You should see the screen fill with color

behind your picture.)

4. Choose a cooke-cutter shape and click and drag your mouse from

the upper left and across your screen to the lower right. 

5. Choose Cookie Cut from the Tools menu and you should get a

solid shape like the one below.

6. Send your cookie-cutter shape back to your page and it becomes a

graphic object that can be resized and moved anywhere on the

page.  



Click on the Storyboard icon to:
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1. Change the order of the pages you’ve created. For example, you’d

like page 2 to become page 5.

2. Add transitions to your slide show. You can add a left-to-right

fade for one page, and a dissolve effect for another.

3. Change the rate at which the slide show advances from page to

page, and/or whether the show moves forward automatically or

manually with a mouse click.

To change the order of the pages you’ve created, click on the

Storyboard icon in the Control Panel. You will then see a dialog

box like the one below. 

To re-order a page, drag the preview version of it to a new location

on the Storyboard.

STORYBOARD



Double-click on a preview page in the Storyboard and you will see

the Slide Show Transitions dialog box above. This allows you to

choose transitions between pages/slides. A simple cut is the default

transition. The question mark chooses randomly from the other

transitions.

Click on the effect that you want and then click on the OK button. A

small picture which represents your transition will appear in the

lower-left portion of the preview page. You can pick a different tran-

sition for every page.
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By clicking on the Options button in the Storyboard you can

change the delay time between slides during the running of an auto-

matic slide show. (Our “pages” magically become slides during the

slide show mode.) Or you can de-select the automatic button and

move the slide show forward by clicking your mouse. (You can also

over-ride an automatic slide show by clicking the mouse.) Loop the

show by clicking on the Loop Slide Show check box. Stop a looped

slide show by hitting command-period on your keyboard.
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Whenever you’re ready to take a look at how your

story is progressing,  click your mouse once on the

Play Story icon in the Control Panel (or choose the

Play Story command from the Story menu). The

screen will go black for a second, then each page will

fill up the screen and play in sequence. If you didn’t make any

changes in the Storyboard, a one-second delay will take place

between slides by default, and a simple cut will occur between the

slides.

While your slide show is running you can stop it at any time 

by hitting either command-period or the letter “Q” (for quit) on your 

keyboard. 

Note: If you save your story as a Imaginator! file (the standard way

to save), you can add to or change your story later. A second copy of

your story can also be saved as a QuickTime™ or Video for

Windows™ movie under a different name. By saving your story as a

movie, your friends won’t need to have Imaginator! on their comput-

ers to view your movies!

Turn your slide show into a self-running movie!

To save your slide show as a movie choose the Save As... command

in the File menu. For Macintosh: click the Save as QuickTime but-

ton. Give it a different name, unless you want to permanently con-

vert your Imaginator! file into a QuickTime movie file. For Windows:
For Video for Windows, choose Save File as Type: Movie.

Printing

If you want to print your story, choose the Print command under

the File menu. To print your pages in “landscape mode”, be sure to

first change your paper orientation in Page Setup. Imaginator!

supports most color printers, but if you’re using a black and white

laser printer, you may want to eliminate color backgrounds for

cleaner print outs.

PLAY STORY



The File Menu

New—creates a new document.

Open—opens an existing Imaginator! document.

Import—allows you to import a PICT or BMP file from your hard

drive, floppy disk, or CD-ROM.

Close—closes an existing Imaginator! file.

Save—saves a new file as either an Imaginator! file or a QuickTime

movie.

Save As...—saves an Imaginator! file as either a Imaginator! file

with a new name, or as a QuickTime movie.

Page Setup...—gives you choices regarding the way your story will

be arranged on the printed page (e.g., page orientation, etc.).

Print...—gives you choices regarding the way your story will be

printed (e.g., number of copies, etc.).

Quit—quits the Imaginator! application.

The Edit Menu

Undo—undoes a single action.

Cut—cuts an object or a selection and places it on the clipboard. 

Copy—same function as cut except the item stays on the page or on

the Paint Box canvas.

Paste—pastes Imaginator! items or PICT files or text onto the page.

(Text cannot be pasted onto the Paint Box canvas).

Clear—deletes a selected item.

Select All—selects every object or, in the case of the Paint Box, the

entire canvas.

The Story Menu

Add Page—adds a new page to an Imaginator! file.

Delete Page—deletes a page from a file.
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MENUS: Macintosh
Please note that the menus for the Macintosh and Windows versions
are slightly different.



Next Page—goes to the next page of the file.

Last Page—goes to the last page of the file.

Previous Page—goes to the previous page of the file.

Story Size...—brings up a dialog box for adjusting dimensions of

your story to accommodate 12” and 13” monitors.

Play Story Options...—brings up a dialog box with options for con-

trolling automatic and manual slide shows.

Play Story—starts your slide show.

The Page Menu

Move To Front—brings an object to the front layer.

Move Forward—brings an object forward one layer.

Move To Back—sends an object to the back layer.

Move Backward—sends an object backward one layer.

Add Sound...—When an object is selected, brings up a sound

recording box with buttons for recording, pausing, stopping, playing,

and importing sounds.

Delete Sound—deletes sound from a selected object.

Edit Sound...—brings up the sound recording box and allows you to

re-record a sound for the selected object.

Show Sounds—a check mark indicates that numbers will appear

next to any object that has a sound. The numbers show the order in

which the sounds will play when your story is running.

Re-order Sounds...—brings up a dialog box with controls for re-

ordering the sequence of sounds on a page.

Play Sounds—plays sound(s) from selected object(s).

Background...—brings up a dialog box with controls for setting a

background color and pattern for the page.

The Text Menu

Font—allows you to choose a font from any that is in your system.

Size—choose 9, 10, 12, 14, 18, 24, or 36 point size type.

Style—choose from plain, bold, italic, underline, outline, shadow,

condensed, and extended styles.

Alignment—choose left, centered, or right alignment for text.
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Background...—brings up a dialog box and allows you to select pat-

terns and colors for text backgrounds.

The Windows Menu

The Windows menu gives you menu and keyboard shortcuts to all of

the major features of the Imaginator! application. If you don’t want

to hear sounds when activating the control panel, use the windows

menu or the command-key shortcuts. You can also use your

Macintosh’s sound control panel to adjust the volume of the sound.

The Tools Menu (in the Paint Box)

Hide Tools—hides/shows the tool palette.

Rotate*—rotates the selection 90 degrees each time.

Flip Horizontal*—makes a mirror image of a selection.

Flip Vertical*—flips the selection upside-down.

Resize*—places handles on a selection and allows for non-propor-

tional re-sizing of any selection.

Cookie Cut —deletes everything outside of the selection 

Send To Page—sends the selection to the page (the menu equiva-

lent of the “mailbox” button.)

* Applies to selections made with the rectangle cookie-cutter tool.
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The File Menu

New—creates a new file.

Open—opens an existing Imaginator! file.

Close—closes an existing Imaginator! file.

Save—saves a new document as either an Imaginator! file (.kss) or

a Video for Windows movie.

Save As...—saves an Imaginator! file as either an Imaginator! file

with a new name, or as a Video for Windows movie.

Import—allows you to import a PICT or BMP file from your hard

drive, floppy disk, or CD-ROM.

Printer Setup...—gives you choices regarding the way your story

will be arranged on the printed page (e.g., page orientation, etc.).

Print...—gives you choices for printing your story.

Exit—quits the Imaginator! application.

The Edit Menu

Undo—undoes a single action.

Cut—cuts an object or a selection and places it on the clipboard. 

Copy—same function as cut except the item stays on the page or on

the Paint Box canvas.

Paste—pastes objects (pictures or text) onto the page. (Note: text

cannot be pasted onto the Paint Box canvas).

Clear—deletes a selected item.

Select All—selects every object or, in the case of the Paint Box, the

entire canvas.

The Story Menu

Add Page—adds a new page to an Imaginator! file.

Delete Page—deletes a page from a file.

First Page—goes to the first page of the file.

Next Page—goes to the next page of the file.

Last Page—goes to the last page of the file.

Previous Page—goes to the previous page of the file.

MENUS: Windows
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Play Story Options...—brings up a dialog box with options for con-

trolling automatic and manual slide shows.

Play Story—starts your slide show.

The Page Menu

Move To Front—brings an object to the front layer.

Move Forward—brings an object forward one layer.

Move To Back—sends an object to the back layer.

Move Backward—sends an object backward one layer.

Add Sound...—When an object is selected, brings up a sound

recording box with buttons for recording, pausing, stopping, playing

and importing sounds.

Delete Sound—deletes sound from a selected object.

Edit Sound...—brings up the sound recording box and allows you to

re-record a sound for the selected object.

Show Sounds—a check mark indicates that numbers will appear

next to any object that has a sound. The numbers show the order in

which the sounds will play when your story is running.

Reorder Sounds...—brings up a dialog box with controls for re-

ordering the sequence of sounds on a page.

Play Sounds—plays sound(s) from selected object(s).

Background...—brings up a dialog box with controls for setting a

background color and pattern for the page.

The Text Menu

Font—brings up a dialog box with choices for fonts from any that is

in your system; font styles (plain, bold, italic, underline, and strike-

out); color (from a 256-color palette); and font sizes. Clicking OK will

close the dialog box and present your font choices in the text box.

Background...—brings up a dialog box and allows you to select pat-

terns and colors for text backgrounds.
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The View Menu

The Windows menu gives you menu and keyboard shortcuts to all of

the major features of the Imaginator! application. If you don’t want to

hear sounds when activating the control panel, use the windows menu

or the command-key shortcuts. You can also use your Window’s sound

control panel to adjust the volume of the sound.

The Tools Menu (in the Paint Box)

Rotate*—rotates the selection 90 degrees each time.

Flip Horizontal*—makes a mirror image of a selection.

Flip Vertical*—flips the selection upside-down.

Resize*—places handles on a selection and allows for non-proportion-

al re-sizing of any selection.

Cookie Cut—deletes everything outside of the selection.

Send To Page—sends the selection to the page (the menu equivalent

of the “mailbox” button.)

* Applies to selections made with the rectangle cookie-cutter tool.



“I can’t find all of my graphic and/or text objects.”
Try choosing Select All from the Edit menu. You will see the han-

dles of all of your objects on the page. Once you’ve located a hidden

object, click on the item in front of it and choose either the Send
Backward or Send to Back command from the Page menu.

“I can’t get my pictures from the Paint Box to the page.”
You need to make a selection with any of the cookie-cutter tools and

then click on the Send (mailbox) button. See the Paint Box chapter.

A special note about Treasure Chest images: When saving,

keep in mind that an Imaginator! file references the images in the

Treasure Chest and does not resave the actual images into your file

(this saves a lot of space on your hard drive). This means that you

can create large stories and your saved Imaginator! file will still be

small. On the other hand, any images that enter the Paint Box (even

Treasure Chest images), or images that are created in the Paint Box,

will be saved as new data. Photo CD pictures and sound are also

saved in their complete form. Only Treasure Chest images are saved

as references—you can re-size Treasure Chest images and a refer-

ence to the amount of re-sizing is saved.

“I’m not sure how to start my QuickTime or Video for Windows
movie.”
QuickTime or Video for Windows compresses all of the data in a file

so that the file can be shared with those who do not have

Imaginator!. If you save files as movies, they will run as full-screen

movies. To start your movie, just double click your mouse in the cen-

ter of the screen or hit the space bar on your keyboard. To achieve

the best movie compression (i.e. smallest file size), do not add slide

transitions to your movie.
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TROUBLESHOOTING



the Memory control panel). If you are running a Mac with 4 mb of

memory & you can’t launch Imaginator! you will need to remove

unnecessary extensions (e.g., printer drivers from printers that you

don’t use) from the Extensions folder in your system folder. Then re-

start your Mac. Check the About This Macintosh command under

the Apple Menu & make sure the System Software is under 1,600K.

Then try launching Imaginator! again.
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Installation
Installing Imaginator! on the Macintosh:

Insert the Imaginator! CD–ROM into your CD–ROM drive and dou-

ble–click on the installer icon. After the introductory screen you will

be asked to install the software. Choose a place on your hard drive

(e.g., applications folder) and click the Save button. 

Custom installation: The standard Imaginator! installation places

the application and aliases of the treasure chests onto your hard

drive. If you use the standard installation, then the Imaginator! CD

will always be needed (to access the treasure chest images). If you

choose to do a custom install, you can install any or all of the trea-

sure chest files onto your hard drive (or onto a server) and avoid the

need for the CD to be in the CD–ROM drive. However, keep in mind

that many of the treasure chests are large (over several megabytes

in size).

Installing Imaginator! Windows:

Insert the Imaginator! CD–ROM into your CD–ROM drive. Go to the

file manager and choose the CD–ROM drive. Double–click on the

setup.exe icon. Follow the installation instructions. 

Custom installation: The standard Imaginator! installation places

the application and an alias file of the treasure chests onto your

hard drive (aliases are very small files that point to larger files). 

If you use the standard installation, then the Imaginator! CD will

always be needed (to access the treasure chest images). If you 

choose to do a custom install, you can install any or all of the trea-

sure chest files onto your hard drive (or onto a server) and avoid the

need for the CD to be in the CD–ROM drive. However, keep in mind

that many of the treasure chests are large (over several megabytes

in size).
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