
    Welcome to the Documentation Wizard
Even though online Help and printed manuals are completely different mediums that vary in format and 
presentation, they can easily share the same source files. RoboHELP enables you to create printed 
documentation files containing the source and content from your Help systems through its single-source 
technology. 

You can turn your Help systems into high-quality user guides suitable for printed documentation by using the 
Documentation Wizard.

RoboHELP's Documentation Wizard is a powerful, but easy-to-use tool that automatically converts your Help 
project into full-featured printed documentation complete with text formatting, styles, images, a table of contents, 
and an index. 

You choose the conversion options that affect:

· Printed document file organization – you can create one file or multiple files. You can even order topics based on 
the heading levels and order of the Help system's table of contents.

· Style and text formatting – you select the printed document template, style conversion options, converted 
hotspot text color, and regular text color. 

· Printed document tables of contents and index – you can automatically generate a table of contents and an 
index.

· Page layout – you can automatically insert page numbers and choose paper size. 

The Documentation Wizard provides all the features you need for producing hard-copy publications in Microsoft 
Word format. Once the core content of your printed materials is in place, you can focus on transforming its online 
format elements into suitable printed medium format elements. The result can be any type of printed 
documentation you want or need – user guides, policies and procedures, sales and marketing materials, catalogs, 
training guides, quick start materials, reference guides. It all depends on the content of your Help project, your 
needs, and your imagination.



RoboHELP Explorer icon
This icon means the menus and commands listed here are found in the RoboHELP Explorer.



RoboHELP icon
This icon means the menus and commands listed here are found in RoboHELP.



About printed documentation
If you’re like most Help authors, you need to provide some sort of printed documentation (user manuals, training 
guides, quick reference cards, and so on) in addition to your online Help systems. Even though online Help and 
printed manuals are different mediums that vary in format and presentation, they can easily share the same 
source. 

Professional documentation time-saver

RoboHELP's single-source technology saves time and resources by enabling you to create reusable Help project 
files that become the source for high-quality printed documentation. Using RoboHELP's Documentation Wizard, 
you select your preferences and it generates the printed document source files.

The Documentation Wizard converts your Help system into full-featured printed documentation files complete with 
text formatting, styles, images, marked index entries, and more. It provides all the features you need for producing 
hard-copy publications in Microsoft Word format. 

You choose the basic organization and framework for the resulting documents:

· Create one file for the entire project or chapters that mirror the books in the Help system's table of contents 
(Contents file). 

· You can also create printed documentation for one Help document (useful for providing content to reviewers).

· Base the heading styles in the printed documentation on the order of topics as they appear in the table of 
contents (Contents file). This option allows you to automatically format the hierarchy of headings and heading 
levels in the printed document based on your Help system's table of contents.

· Automatically create a Microsoft Word table of contents listing the topics you chose to convert. You can use this 
as the base contents, adding and changing it to generate the final table of contents for your document.

· Automatically create a Microsoft Word index and mark index entries in the printed documents based on Index 
keywords (K-keywords) from your Help topics. You can use this base index and continue to mark new entries 
and to create the final index for your document.

· You select the formatting, styles, and even the template you prefer for your printed documents before the 
conversion. If you prefer, you can even maintain the exact styles and look of your Help source files in the printed 
documentation. Once the basic printed document files are created, you spend less time applying formatting 
changes after the fact. 

Working with the results

Once the core content of your printed materials is in place, you can focus on transforming its online format 
elements into suitable printed medium format elements. (For example, changing hotspots and See Also links into 
suitable printed cross-references, adding screen shots and other images, providing captions for screen shots and 
images, and writing transitions between subjects and chapters.) 

The result can be any type of printed documentation you want or need – user guides, policies and procedures, 
sales and marketing materials, catalogs, training guides, quick start materials, reference guides. It all depends on 
the content of your Help project, your needs, and your imagination.



Advantages of creating printed doc from Help source
RoboHELP provides busy Help authors with a time-saving way to create professional documentation – develop the 
Help system content first then use that content as the source for your printed documentation. Using RoboHELP's 
Documentation Wizard, you select your preferences and let RoboHELP take care of creating the printed 
documentation source files from your original source.

Even though the final format and presentation differs between the two mediums, it makes sense for Help authors 
to create both online and printed deliverables from the same source files – the keyword being SOURCE.

Here are some of the advantages of creating the online Help source first: 

· Simultaneous development. While timing is always an issue, it's generally easier to keep an online Help 
system updated with the latest in application changes. Production time for printed materials can take several 
weeks at the publisher to print professionally. That means any last minute changes or updates in the application 
may go undocumented.

· Faster and more economical. It's faster and more economical to ship electronic documentation than to 
produce a beta manual or other printed document. 

· Documentation for beta or early release. The Help system is more likely to be ready for beta or other early 
releases. Help systems and online books can be accessed from a disk, CD-ROM, or downloaded over the 
Internet. Printed materials can take several weeks after completed to print professionally.

· Modular content. Another benefit of creating the Help source files first is that generally, content organized for 
online use is more modular, making it concise and readable. It's easy to build on - adding more conceptual or 
reference information to the core already established.



Strategies for creating printed documentation
The key to creating quality printed documentation from Help source files is planning. If you plan from the start to 
use the Help system as the source files for your printed documentation, you’ll be able to implement the strategies 
that provide you with the best possible outcome as you write. 

Here are some recommended strategies to make the most of your Help source files: 

· Use styles consistently in the Help file. In Microsoft Word, every word, sentence, and paragraph is 
associated with a style. Since RoboHELP uses Word as its host editor, every word in every topic is also 
associated with a style – whether you selected a style or used Word’s default (Normal). The more consistently 
you use styles in your Help source files, the better the outcome in the printed documentation.

· Match style names 1:1 in both ROBOHELP.DOT and the selected printed documentation template. For 
best style conversion results, each style name you've used in your Help file should have a counterpart in the 
printed document template you select. The two styles can be formatted differently to accommodate the 
differences between online and printed documents. For example, if you use a style named Bullet in your Help 
system, make sure a style named Bullet exists in the printed documentation template. When the source is 
converted, the Documentation Wizard looks for a style name match. This strategy saves time by preventing 
major style cleanup in the printed documentation file.

Note: The Documentation Wizard includes an option to convert text marked with a style name not included in 
the printed document template. This option helps reduce style cleanup in the printed documentation file, but 
matching style names 1:1 produces the best style conversion results.

· Design source file information into modules. Help systems work well when based on a modular design – 
small topics chunked together in logical groups. Modular documentation is recommended by most technical 
writing authorities because it lends itself to being more concise, more readable, easier to update, and easier to 
reuse. If you design your Help source files modularly, you have the added advantage of being able to select one 
module for the printed materials and ignoring another completely. For example, by creating separate Help 
documents for task-oriented and context-sensitive topics, you can convert only Help documents containing task-
oriented topics. 

· Base your printed documents on the Contents (CNT) file. The Contents file of a Help system makes a great 
base for printed documentation. RoboHELP’s TOC tab is a great way to think through the organization of your 
information – Help or printed documentation. The Documentation Wizard provides an option that allows you to 
base the framework for your printed materials on the Contents file. Choosing the heading level and topic order 
option automatically places the printed information inside the framework. Choosing to create a new document 
(DOC) file for each first-level TOC book allows you to divide a large Help system into smaller, more manageable 
files – both for you and for Microsoft Word. 



Starting the Documentation Wizard
Use this procedure to open the Documentation Wizard to create printed documentation from your Help projects. 
The wizard takes you step-by-step through an easy selection process and then automatically creates the printed 
documentation based on your selections.

 To start the Documentation Wizard:

1 Open the Help project you want to convert into printed documentation.

2 From the File menu, select Generate > Printed Documentation. The Documentation Wizard appears.

3 Make your selections on each screen. Click Finish to begin the conversion process.

4 Click View Results, when prompted. The Documentation Wizard opens Microsoft Word and creates the 
documentation in Word, as you watch. When the conversion is completed and the documentation is created, 
the Documentation Wizard displays a DOC file with the name you specified on the first wizard screen.

Tips: 

· If you’re not sure which options you want to select in the Documentation Wizard, just click Help for 
assistance.

· To create your printed documentation even quicker, use Quick Generate to accept the defaults or use the 
current selections in the Documentation Wizard. Open the Single Source folder, right-click on Printed 
Documentation, and select Quick Generate. 

· To see or change the current selections, open the Single Source folder, right-click on Printed 
Documentation, and select Properties.



Viewing Documentation Wizard properties
Use this procedure to view or change the currently selected properties for the Documentation Wizard. These 
properties represent the currently selected conversion options that the wizard uses to create printed 
documentation from the Help project.

The Documentation Properties dialog allows you to view or change the Documentation Wizard's conversion 
option. These settings then become the default options when you use the Documentation Wizard. 

It contains the following tabs:

· File allows you to select the file name and path for the resulting printed documents and the source files from the 
project you want to convert.

· Options allows you determine the structure and organization of the printed documents – including options to 
convert Index keywords into Word index entries, automatically generate a printed document index, and 
automatically generate a table of contents for the printed documentation.

· Template enables you to determine the styles and formatting of the printed documents. This is where you select 
the printed document template to attach and use during the conversion. You also indicate how the 
Documentation Wizard converts text from the Help project that's marked with a style name that doesn't exist in 
the selected printed document template.

· Color and Graphic provides options for determining the color of both hotspot text and regular text, as well as 
options for converting images from the Help file into the printed documentation. You can choose to include 
(embed) images in the printed documents or link to the image file names instead.

· Page Setup allows you to automatically add page numbers and page breaks to the printed documents. It also 
allows you to select the page size for the printed documents.

· Statistics provides information about the last successful printed documentation conversion for this Help project. 
It lists the conversion day and time, person (username) who last converted the file, and the file name and path 
location of the last converted file.

 To view or change printed documentation conversion options:

1 From the Project Manager (Project tab), open the Single Source folder.

2 Right-click on the Printed Documentation folder and select Properties. The Documentation Properties 
dialog appears.

3 Click on the tab containing the options you want to view or change. Make any changes to suit your needs.

4 Click OK to save any changes. 



Troubleshooting printed documentation

“I have a very large document. When I scroll through it, Word occasionally GPF’s (General Protection 
Fault) or my screen freezes.” 

The document may be too big or have too many graphics for the amount of memory on your computer system or 
for Microsoft Word to handle. 

Solution 1:

If your Help project is using a CNT file, let RoboHELP automatically split the one large document into several 
smaller DOC files. Do another conversion to generate the printed documentation. But this time, select the Do you 
want to create documents from Books in the CNT file? option. This option creates a new document (DOC file) 
for each first-level Book in the Help system’s table of contents (CNT file). Each DOC file created contains all Help 
topics under that Book. Topics not part of the Help system’s table of contents become part of a document named 
ExtraTopics.doc.

If you still experience problems with error messages in Microsoft Word, save the file as an RTF format, to strip out 
any formatting Word does not understand. Then save the file again as a DOC file. 

Solution 2:

If your Help project doesn’t use a CNT file, you may need to manually split the one large document into smaller 
DOC files. You can do this by creating one or more new documents, then cutting and pasting text from the larger, 
original document into the smaller, newer documents. You can also use Microsoft Word’s Master Document 
feature. (For more information, refer to your Microsoft Word online Help or documentation.)

Solution 3:

A third solution may be to do another conversion and link graphics to your document instead of embedding them. 
From the RoboHELP Single Source folder, right-click Create Documentation, and then choose Properties. 
Select the Color and Graphics tab and uncheck the box next to Do you want to save graphics inside 
document? Then generate the printed documentation again.



Preparing to create printed documentation
Before you convert your Help system into printed documentation, it's a good idea to do some preparation. Thinking 
through what you want the output to look like will help you decide which options to select in the Documentation 
Wizard. The wizard optimizes converting the content, but it can also optimize the time needed to transform the 
content from online format into printed documentation format.

Here are some questions to ask yourself before you start the conversion:

Document organization

· Will you convert all the Help documents in the project or only some? If you've organized your topics into 
documents by subject, by topic type (task, reference, context-sensitive, and so on), or by module, you may not 
need to convert every document.

· Do you need to create a quick hard copy of a single document? 

· How many printed documentation files do you want to work with – one big file or several smaller files? If multiple 
Help authors will be working on the printed documentation project, it's a good idea to create several files to 
make distributing the workload easier.

Table of contents

· Is the Help project's table of contents basically the same as the printed documentation's table of contents? If so, 
you might want to use the chapter approach and create separate documents for each top-level TOC book. You 
can also model the heading levels and topic order of the printed documents after the headings and order in the 
table of contents. (Even if you aren't creating separate chapters, this is still a good automatic formatting option.)

· Do you want the Documentation Wizard to automatically generate the base table of contents for you? Or do you 
plan to do this in Word later or not at all?

Indexing

· Will you create a printed index file for the printed documentation? If so, you'll want to convert the existing Index 
keywords (K-keywords) into Word index entries.

· Do you want the Documentation Wizard to automatically generate the base index file for you? Or do you plan to 
do this in Word later or not at all?

Styles and formatting

· Which printed document template do you plan to use – ROBODOCS.DOT or a custom printed document 
template?

· Do you need to modify any of the styles in either template before you convert? 

· Do your templates contain the same style names – is there a 1:1 style name match? If not, how do you want the 
Documentation Wizard to convert styles not found in the printed document template?

· What color should hotspot text appear in the printed documentation? Do you want it to blend in with normal text 
in the printed document? Or do you want to search for hotspot text and change it into a cross-reference of some 
sort?

· What color should normal text appear in the printed documentation? If the Help system text is a color other than 
black, should the Documentation Wizard change it to black during the conversion?

Images

· Are you including images from your Help project in your printed documentation? If so, do you want to embed the 
images in the printed document files? Or do you want to externally link to the image files? If the Help project 
contains a lot of images or large image files, linking the images will make the resulting printed document files 
easier to work with in Word. 

· Do you want to convert images in topic titles or other headings?

Page layout

· What paper size do you need for the printed docs?

· Do you want to automatically include page numbers at the bottom of each page?

Tip: 

See Strategies for printed documentation for more useful tips on preparing Help projects for printed output.



Creating one printed documentation file
Use this procedure to create a single document (DOC) file for your printed documentation. You might want to 
select this option if your Help project is small or if you’re planning to finalize your printed materials in an 
application other than Microsoft Word. (One file may be easier to import than several.) 

The Documentation Wizard guides you through the conversion process, prompting you to select your preferences 
– including options to automatically generate a table of contents and an index. You can generate printed 
documentation as many times as you need to, so feel free to experiment with the various options until you get the 
output that best suits your needs.

 To create one printed document file:

1 From the File menu, select Generate > Printed Documentation. The Documentation Wizard appears.

2 Make your selections on the first screen and click Next to go to the second screen.

3 On the second screen, clear the Do you want to create documents from Books in the CNT file option. 

4 Complete your selections on the second, third, and fourth screens and click Finish when you’re done.

5 Click View Results, when prompted. The Documentation Wizard opens Microsoft Word and creates the 
documentation in Word, as you watch. When the conversion is completed and the documentation is created, 
the Documentation Wizard displays a DOC file with the name you specified on the first wizard screen.

Tips: 

· If you’re not sure which options you want to select in the Documentation Wizard, click Help for assistance.

· To create your printed documentation even quicker, use Quick Generate to accept the defaults or use the 
current selections in the Documentation Wizard. Open the Single Source folder, right-click on Printed 
Documentation, and select Quick Generate. 

· To view or change Documentation Wizard properties, open the Single Source folder, right-click on Printed 
Documentation, and select Properties.



Creating separate documents from TOC books
Use this procedure when you want to create multiple printed document files – one DOC file for every first-level 
TOC book in the Help project's Contents file. This option is useful to break up Help projects into smaller, more 
manageable documents. It’s also great for source files containing a lot of images or images that are complex or 
large in size.

The number of documents created depends on the number of top-level books in the Contents file, as illustrated in 
the following example:

Help system table of contents Printed documents

Tools of the trade.doc

 
Daily trek.doc

The Documentation Wizard places topics not included the Contents file in a document named ExtraTopics.doc. It 
also creates a reference document named for the Help project that contains links to each printed document file. To 
access or edit a printed document file in Word, just double-click on the file name.

 To create printed documentation based on books in the Contents file:

1 From the File menu, select Generate > Printed Documentation. The Documentation Wizard appears.

2 Complete your selections on the first screen of the Documentation Wizard. 

3 On the second screen, select the Do you want to use the CNT file to determine heading levels and topic 
order option.

4 Select Do you want to create documents from Books in the CNT file option. 

5 Complete your selections on the second, third, and fourth screens and click Finish when you’re done. 

6 Click View Results, when prompted. The Documentation Wizard opens Microsoft Word and creates the 
documentation in Word, as you watch. When the Documentation Wizard completes the conversion, it displays 
a reference document named for the Help project containing links to each printed document file. If the source 
files contain topics not included in the Contents file, the Documentation Wizard places these topics in a 
document named ExtraTopics.doc.

7 To view or edit a DOC file created by the Documentation Wizard, double-click on the Double Click to Edit text 
in front of the document’s name.

Tips: 

· If you’re not sure which options you want to select in the Documentation Wizard, click Help for assistance.

· To create your printed documentation even quicker, use Quick Generate to accept the defaults or use the 
current selections in the Documentation Wizard. Open the Single Source folder, right-click on Printed 
Documentation, and select Quick Generate. 

· To view or change Documentation Wizard properties, open the Single Source folder, right-click on Printed 
Documentation, and select Properties.



Creating heading levels based on TOC order
Use this procedure to arrange topics in the same order as they appear in the Help system's table of contents (CNT 
file). Book and screen titles from the table of contents are used as headings in the printed document, as shown in 
the following example:

Help system table of contents Printed document

 
 To create heading levels and order topics based on the source Contents file:

1 From the File menu, select Generate > Printed Documentation. The Documentation Wizard appears.

2 Complete your selections on the first screen of the Documentation Wizard. 

3 On the second screen, select the Do you want to use the CNT file to determine heading levels and topic 
order option.

4 (Optional) If you also want to create a document (DOC) file for each first-level TOC book, select Do you want 
to create documents from Books in the CNT file option. (This option breaks up a Help file into multiple 
printed documentation files.)

5 Complete your selections on the second, third, and fourth screens and click Finish when you’re done. 

6 Click View Results, when prompted. The Documentation Wizard opens Microsoft Word and creates the 
documentation in Word, as you watch. When the conversion is completed and the documentation is created, 
the Documentation Wizard displays a DOC file with the name you specified on the first wizard screen. If you 
created multiple documents (one for each top-level TOC book), this information file lists all the documentation 
files created by the wizard.

Tips: 

· If you’re not sure which options you want to select in the Documentation Wizard, click Help for assistance.

· To create your printed documentation even quicker, use Quick Generate to accept the defaults or use the 
current selections in the Documentation Wizard. Open the Single Source folder, right-click on Printed 
Documentation, and select Quick Generate. 

· To view or change Documentation Wizard properties, open the Single Source folder, right-click on Printed 
Documentation, and select Properties.



Creating printed documentation from one Help document
Use this procedure when you want to create printed documentation from a single Help document. While you can 
print the documents directly from RoboHELP, here are some of the benefits to using the Documentation Wizard:

· Review or edit hard copy. This is a great way to provide your internal reviewers and editors a copy of each 
Help module to review. Your reviewers – especially clients – appreciate not having to deal with the footnotes, 
separate pages, and linking format of the Help topics. They can concentrate on reviewing the materials. You can 
give them a table of contents and index to go along with the review copy. 

· Multiple Help author work environments. It’s also a good way to divide work between Help authors when 
creating user guides or other types of printed documentation. Each Help author can generate a printed 
document for the Help documents he or she is responsible for.

 To create printed documentation for one Help document:

1 From the File menu, select Generate > Printed Documentation. The Documentation Wizard appears.

2 You can accept the default in Specify path and filename for the printable documentation.
-or-
Enter the name of the file or path you want the printed documentation to be created in.
-or-
Navigate to the path and click OK.

3 Still on the wizard's first screen under Which source files do you want to convert, select the one Help 
document to convert. Clear all other selections. (A quick way to do this is to click Clear All and then select the 
document you want.) 

4 Complete your selections on the second, third, and fourth screens and click Finish when you’re done. 

5 Click View Results, when prompted. The Documentation Wizard opens Microsoft Word and creates the 
documentation in Word, as you watch. When the conversion is completed and the documentation is created, 
the Documentation Wizard displays a DOC file with the name you entered in step 2. If you chose to create a 
document for each TOC book, this information file lists all the documentation files created by the wizard.

Tips: 

· If you’re not sure which options you want to select in the Documentation Wizard, click Help for assistance.

· To create your printed documentation even quicker, use Quick Generate to accept the defaults or use the 
current selections in the Documentation Wizard. Open the Single Source folder, right-click on Printed 
Documentation, and select Quick Generate. 

· To view or change Documentation Wizard properties, open the Single Source folder, right-click on Printed 
Documentation, and select Properties.



Styles and printed documentation
In Microsoft Word, format and appearance are handled by styles and templates. Every word, sentence, and 
paragraph has a style attached that affects how the text looks, whether the text is a topic or a printed page. 
RoboHELP uses Microsoft Word as its host software, so every word in every topic of your Help source files also 
has an attached style.

The better you plan and implement styles in your Help source files, the less you’ll have to maintain and update 
styles in the printed documentation. After all, the less time you have to spend on cleaning up styles and formatting 
in your printed documents, the more time you can spend on other important things – like manual indexing.

Here are things to think about with your printed documentation styles:

· Know what you want your printed documentation to look like. Do you want to maintain the exact look of 
your Help source files? If you want your Help and printed documentation to look different, which template will 
you select in the Documentation Wizard?

· Use styles consistently in the Help file. In Microsoft Word, every word, sentence, and paragraph is 
associated with a style. Since RoboHELP uses Word as its host word processing software, every word in every 
topic is also associated with a style – whether you selected a style or used Word’s default (Normal). The more 
consistently you use styles in your Help source files, the better the outcome in the printed documentation.

· Map styles one to one in the document template. If you have a Steps style in ROBOHELP.DOT, define a 
Steps style in the printed documentation template you choose. It allows RoboHELP’s Documentation Wizard to 
match the styles exactly – that way, you allow the Documentation Wizard to perform the styles conversion for 
you. If a style in the Help file doesn’t exist in the selected printed document template, the Documentation Wizard 
formats text with these styles based on the style conversion option you selected. Even with this handy feature, 
there's usually at least minimal cleanup involved in the printed document files. 

· Base all styles in the Help file and the printed document template on Normal. This hint comes from 
Microsoft Word and helps you to more reliably predict and troubleshoot style issues. Generally, though, if Word 
can’t find the base style, it uses the Normal style instead. If your styles are based on Normal to begin with, you 
shouldn’t notice your styles changing unexpectedly.



Styles used in the ROBODOCS.DOT template
Among RoboHELP's templates is ROBODOCS.DOT – a printed document template containing basic styles to 
create professional looking printed documentation. 

Most of the styles defined in ROBODOCS.DOT are based on style names found in the Help system template, 
ROBOHELP.DOT. (This is to provide a 1:1 style name match.) The other styles in this template accommodate 
printed document format needs – adding images, captions, tables of contents, and so on.

Here are the main style names and definitions in ROBODOCS.DOT:

Normal

Sample: Used for normal text.

Spec: Times New Roman, 10 pt, Char scale 100%, Indent: Left 0.5", Flush left, Line spacing single, Space before 
10 pt, Widow/orphan control, Body text.

Normal Indent

Sample: Used for indented text.

Spec: Normal + Indent Left 0.75" 

Chapter Number

Chapter 1: Sample
Spec: Normal + Arial, 18 pt, Bold, Keep with next, Keep lines together, Border Top (Single solid line, 2 ¼ pt line 
width), Border spacing 1 pt. 

Heading 1

Sample: Used for first-level headings.
Spec: Normal + Arial, 18 pt, Bold, Indent: Left 0", Space before 0 pt, Keep with next, Keep lines together, Level 1; 
Style for Next Paragraph: Normal.

Heading 2

Sample: Used for second-level headings.
Spec: Normal + Arial, 16 pt, Bold, Indent: Left 0", Keep with next, Keep lines together, Level 2; Style for Next 
Paragraph: Normal.

Heading 3

Sample: Used for tertiary headings.
Spec: Normal + Arial 14 pt, Bold, Left 0", Keep with next, Keep lines together, Level 3.

Heading 4

Sample: Used for fourth-level or other headings.
Spec: Normal + Arial 12 pt, Bold, Keep with next, Keep lines together, Level 4.

Heading 5

Sample: Used for other types of headings or emphasis.
Spec: Normal + Arial 11 pt, Keep with next, Keep lines together, Level 5

Picture

Sample: Used to format images and other pictures in printed documentation.

Spec: Normal + Centered, space after 5 pt.

Caption

Sample: Used to format captions under images and pictures.



Spec: Picture + Italic, Space before 0 pt.

Topic Text Bulleted

· Sample. Use this style for bulleted topic text. 

· This is more bulleted topic text.

· This is one more bulleted topic text.

Spec: Normal + Indent Left .5”, Hanging 0.25”, Tabs.75”, Round bullet (Symbol font).

Topic Text Onestep

 Sample. Use this style when you have a single step. If you used the style as is from RoboHELP.DOC, the 
ONESTEP.BMP image should be in place as the bullet symbol.

Spec: Normal + Tabs: 0.75; Style for Next Paragraph: Normal

Topic Text Indent

Sample. You may want to use this style following a onestep paragraph or between numbered steps. 
This is some topic text indent. This is more topic text indent. This is more topic text indent. This is 
more topic text indent. This is more topic text indent. This is more topic text indent. This is more 
topic text indent.

Spec: Normal Indent

Topic Text Numbered

1 Sample. This is for numbered steps in a topic.

2 This is another Topic Text Numbered.

3 Another Topic Text Numbered.

4 One more Topic Text Numbered.

Spec: Normal + Indent Left 0.5”, Hanging .25”, Numbered.

Tip/Note Heading

Sample. Use for a Tip or Note.

Spec: Normal + Arial, Bold; Style for Next Paragraph: Normal.

Tip/Note Text Bulleted

· Sample. Use this style for bulleted tip or note text. 

· This is another tip or note.

· This is one more bulleted tip.

Spec: Topic Text Bulleted.

Tip/Note Text

Sample. Use this style for indented tip or note text. Indented tip or note text. Indented tip or note text. 
Indented tip or note text. Indented tip or note text. Indented tip or note text. Indented tip or note text. 
Indented tip or note text. Indented tip or note text. Indented tip or note text.

Spec: Normal.

Code

Sample: Used to indicate macro script or other user command inputs.

Spec: Normal + Courier New.

Tip:

You can change the styles in ROBODOCS.DOT to suit your needs or select a different template.



Selecting printed document templates
Use this procedure to select the template used to create printed documentation from RoboHELP source files. The 
main differences between printed documentation and online Help systems are in format, layout, and appearance. 
You can precisely control the styles and formatting of converted text with the printed document template.

RoboHELP includes a template called ROBODOCS.DOT that allows you to create professional-looking printed 
documentation by applying basic styles – Times New Roman for Normal and Arial for Headings. Select 
ROBODOCS.DOT or your own template. Since styles have such a big impact on the resulting printed 
documentation, you may want to review the recommended strategies.

 To select a template for printed documentation:

1 From the File menu, select Generate > Printed Documentation. The Documentation Wizard appears.

2 Complete your selections on the first and second screens of the Documentation Wizard. 

3 On the third screen, under Which template do you want to apply to the document, select or navigate to the 
printed document template you want to use. 

4 In Enable global formatting for Heading styles:

· (Recommended) Select this option to globally apply all the heading styles (Heading 1 through Heading 9) 
from the selected template to the printed documentation content. If you've made individual changes to text 
using a heading style, selecting this option means the style in the printed document reverts to the "default" 
style.

· Clear this option if you've made individual changes to a text using a heading style and you want to keep 
those style changes in the printed documentation. (By choosing this option, you won't be able to globally 
update heading styles in the printed documentation.)

5 Click Next to go to the fourth screen. Complete your selections on the remaining screens and click Finish 
when you’re done. 

6 Click View Results, when prompted. The Documentation Wizard opens Microsoft Word and creates the 
documentation in Word, as you watch. When the conversion is completed and the documentation is created, 
the Documentation Wizard displays a DOC file with the name you specified on the first wizard screen. If you 
chose to create a document for each TOC book, this information file lists all the documentation files created by 
the wizard.

Tips: 

· If you’re not sure which options you want to select in the Documentation Wizard, click Help for assistance.

· To determine how the Documentation Wizard converts text using style names not found in the printed 
document template, select a style conversion option.

· To create your printed documentation even quicker, use Quick Generate to accept the defaults or use the 
current selections in the Documentation Wizard. Open the Single Source folder, right-click on Printed 
Documentation, and select Quick Generate. 

· To view or change Documentation Wizard properties, open the Single Source folder, right-click on Printed 
Documentation, and select Properties.



Selecting style conversion options for printed documents
Use this procedure to select a style conversion option for your printed documents. When the Documentation 
Wizard converts the Help source files, it looks for an exact style name match in the selected printed document 
template:

· If it finds the style name match, it formats the text according to the way that style name is defined in the printed 
document template.

· If it doesn't find a style name match, the Documentation Wizard applies the style conversion option you've 
selected. It converts and formats the non-existing style text according to your selection.

At the end of the conversion, if Documentation Wizard encountered any non-existing style names, it displays an 
informational dialog. This dialog tells you which styles weren't found in the selected printed document and which 
style conversion option it applied to text with those style names, based on your selection.

 To select a style conversion option for printed documents:

1 From the File menu, select Generate > Printed Documentation. The Documentation Wizard appears.

2 Complete your selections on the first and second screens of the Documentation Wizard.

3 On the third screen under How do you want to convert Help topic styles not defined in the printed 
document template option, select an option:

· Keep Help style. Copies the non-existing style name and its style attributes from the Help system into the 
output file. Converted text using this style name appears in the output file exactly as it did in the Help 
system. 

· Keep Help Style but use Normal style indentation and tab stops as defined in printed doc template. 
Copies the non-existing style name from the Help system into the output file, but change the paragraph 
format attributes to match the printed document template's Normal style indentation and tab stops. 
Converted text using this style name appears in the same font (style, size, color, etc.) as in the Help system, 
but it takes on the paragraph attributes of the printed document template's Normal style. 

· Create a new style based on Normal style in the printed doc template. Copies the non-existing style 
name from the Help system into the printed document template. Converted text using this style name is 
formatted with the attributes of the Normal style, as defined in the printed document template, but still retains 
its original style name. This allows you to make global style changes to this style in the printed document 
template.

4 Click Next to go to the fourth screen. Complete your selections on the remaining screens and click Finish 
when you’re done.

5 Click View Results, when prompted. The Documentation Wizard opens Microsoft Word and creates the 
documentation in Word, as you watch. When the conversion is completed and the documentation is created, 
the Documentation Wizard displays a DOC file with the name you specified on the first wizard screen. If you 
chose to create a document for each TOC book, this information file lists all the documentation files created by 
the wizard.

Tips: 

· If you’re not sure which options you want to select in the Documentation Wizard, click Help for assistance.



· To create your printed documentation even quicker, use Quick Generate to accept the defaults or use the 
current selections in the Documentation Wizard. Open the Single Source folder, right-click on Printed 
Documentation, and select Quick Generate. 

· To view or change Documentation Wizard properties, open the Single Source folder, right-click on Printed 
Documentation, and select Properties.



Maintaining styles from the Help project
Use this procedure if you want your printed documentation to look exactly the same as your online Help system. 

 To maintain the look of the Help source files in the printed 
documentation:

1 From the File menu, select Generate > Printed Documentation. The Documentation Wizard appears.

2 Complete your selections on the first and second screens of the Documentation Wizard. 

3 On the third screen, clear Enable global formatting for Heading styles. By clearing this option, your printed 
documentation styles will match the Help source files look. 

4 Complete your selections on the remaining screens and click Finish when you’re done.

5 Click View Results, when prompted. The Documentation Wizard opens Microsoft Word and creates the 
documentation in Word, as you watch. When the conversion is completed and the documentation is created, 
the Documentation Wizard displays a DOC file with the name you specified on the first wizard screen. If you 
chose to create a document for each TOC book, this information file lists all the documentation files created by 
the wizard.

Tips: 

· If you’re not sure which options you want to select in the Documentation Wizard, click Help for assistance.

· To determine how the Documentation Wizard converts text using style names not found in the printed 
document template, select a style conversion option.

· To create your printed documentation even quicker, use Quick Generate to accept the defaults or use the 
current selections in the Documentation Wizard. Open the Single Source folder, right-click on Printed 
Documentation, and select Quick Generate. 

· To view or change Documentation Wizard properties, open the Single Source folder, right-click on Printed 
Documentation, and select Properties.



Generating a table of contents in the printed documentation
Use this procedure to automatically generate a table of contents in the printed documentation. The Documentation 
Wizard's Options screen allows you to select the Create TOC option, which inserts the    Microsoft Word TOC field 
code {TOC \O} into the printed documentation, and then automatically generates the table of contents. The \O 
switch means that the TOC is built by using outline (heading) levels from the corresponding documents.

Where the table of contents appears depends on the number of printed document files you're creating:

· One printed documentation file. The table of contents field code is inserted and generated at the very top of 
the printed documentation .DOC file.

· Multiple printed documentation files. The Document Wizard creates a separate document named TOC.doc 
where it inserts and generates the table of contents. 

If you don't select this option in the Documentation Wizard, you can still use Microsoft Word to design and build a 
table of contents for your printed documentation. (For more information, refer to Microsoft Word's online Help or 
user guide.)

 To generate a table of contents using the Documentation Wizard:

1 From the File menu, select Generate > Printed Documentation. The Documentation Wizard appears.

2 Complete your selections on the first screen and click Next to go to the second screen.

3 Select Create TOC.

4 Complete your selections on the remaining screens and click Finish when you're done.

5 Click View Results, when prompted. The Documentation Wizard opens Microsoft Word and creates the 
documentation in Word, as you watch. When the conversion is completed and the documentation is created, 
the Documentation Wizard displays a DOC file with the name you specified on the first wizard screen. If you 
chose to create a document for each TOC book, this information file lists all the documentation files created by 
the wizard.

Tips: 

· If you’re not sure which options you want to select in the Documentation Wizard, click Help for assistance.

· To base headings and topic order on the Help system's table of contents (CNT file), select the Do you want 
to use the CNT file to determine heading levels and topic order option.

· To create separate printed document files – one for each top-level book in the Help system's table of 
contents, select the Do you want to create document from Books in the CNT file option.

· To create your printed documentation even quicker, use Quick Generate to accept the defaults or use the 
current selections in the Documentation Wizard. Open the Single Source folder, right-click on Printed 
Documentation, and select Quick Generate. 

· To view or change Documentation Wizard properties, open the Single Source folder, right-click on Printed 
Documentation, and select Properties.



Converting keywords into index entries
Use this procedure to convert Index keywords from topics in the Help source files into Microsoft Word index 
entries in the printed documentation. The Documentation Wizard converts each Index keyword using Word's 
INDEX ENTRY field code {xe "keyword"}. It adds Microsoft Word index entries for each corresponding Index 
keyword (K-keyword) in each topic. For example, if a topic includes the keyword "safari" and the topic content 
uses the text "safari" three times. When converted, the Microsoft Word index entry for "safari" becomes {xe 
"safari"}.

This is a great shortcut if you plan to create an index in the printed documentation. If you don't select this option, 
you'll have to manually mark index entries in the printed document files to use Microsoft Word's automatic indexing 
feature.

 To convert Index keywords into Word index entries:

1 From the File menu, select Generate > Printed Documentation. The Documentation Wizard appears.

2 Complete your selections on the first screen and click Next to go to the second screen.

3 Select Convert K-keywords to Index entries.

4 Complete your selections on the remaining screens and click Finish when you're done.

5 Click View Results, when prompted. The Documentation Wizard opens Microsoft Word and creates the 
documentation in Word, as you watch. When the conversion is completed and the documentation is created, 
the Documentation Wizard displays a DOC file with the name you specified on the first wizard screen. If you 
chose to create a document for each TOC book, this information file lists all the documentation files created by 
the wizard.

Tips: 

· If you’re not sure which options you want to select in the Documentation Wizard, click Help for assistance.

· To automatically generate an index in the printed documentation, select the Create Index option.

· To create your printed documentation even quicker, use Quick Generate to accept the defaults or use the 
current selections in the Documentation Wizard. Open the Single Source folder, right-click on Printed 
Documentation, and select Quick Generate. 

· To view or change Documentation Wizard properties, open the Single Source folder, right-click on Printed 
Documentation, and select Properties.



Generating an index in the printed documentation
Use this procedure to automatically generate an index in the printed documentation. The Documentation Wizard's 
Options screen allows you to select the Create Index option, which inserts Word's INDEX field code {INDEX \c 
"#"}. It then generates the index based on existing index entries – which are only available if you selected the 
Convert K-keywords to Index entries option. The \c creates an index with more than one column on the page. The 
"#" indicates the number of columns.

Where the index appears depends on the number of printed document files you're creating:

· One printed documentation file. The index field code is inserted and generated at the very end of the printed 
documentation .DOC file.

· Multiple printed documentation files. The Document Wizard creates a separate document named Index.doc 
where it inserts and generates the index. 

If you don't select this option in the Documentation Wizard, you can still use Microsoft Word to design and build an 
index for your printed documentation. (For more information, refer to Microsoft Word's online Help or user guide.)

 To generate an index using the Documentation Wizard:

1 From the File menu, select Generate > Printed Documentation. The Documentation Wizard appears.

2 Complete your selections on the first screen and click Next to go to the second screen.

3 Select Convert K-keywords to Index entries.

4 Select Create Index.

5 Complete your selections on the remaining screens and click Finish when you're done.

6 Click View Results, when prompted. The Documentation Wizard opens Microsoft Word and creates the 
documentation in Word, as you watch. When the conversion is completed and the documentation is created, 
the Documentation Wizard displays a DOC file with the name you specified on the first wizard screen. If you 
chose to create a document for each TOC book, this information file lists all the documentation files created by 
the wizard.

Tips: 

· If you’re not sure which options you want to select in the Documentation Wizard, click Help for assistance.

· To create your printed documentation even quicker, use Quick Generate to accept the defaults or use the 
current selections in the Documentation Wizard. Open the Single Source folder, right-click on Printed 
Documentation, and select Quick Generate. 

· To view or change Documentation Wizard properties, open the Single Source folder, right-click on Printed 
Documentation, and select Properties.



Selecting hotspot color for printed documents
Use this procedure to determine the color hotspot text appears in the printed documentation. The ability to 
hyperlink text, documents, Help systems, Web sites, and more is unique to Help systems. But the hotspot 
(hyperlink) text doesn't mean anything in the printed document format – not unless you want to transform the 
hotspot text into cross-references or see references. (For example, See page 543 for how to view or change 
Documentation Wizard properties.)

Whether you want to create printed document links (like cross-references or see references) or whether you 
simply want the hotspot text to automatically blend in, the Documentation Wizard allows you to select your 
preference before conversion. 

 To select hotspot color for printed documents:

1 From the File menu, select Generate > Printed Documentation. The Documentation Wizard appears.

2 Complete your selections on the first, second, and third screens and click Next.

3 Under Which color do you want on converted hotspot text, select one of the following options:

· Keep the original color. Retains the original hotspot color used in the Help file. (If you used the standard 
hotspot green, hotspot text remains green. If you used another color, hotspot text remains that color. Useful 
for searching and replacing hotspot text with cross-references or see references in the Word document, 
since the text is usually easy to spot. And you can search for that particular hotspot color.)

· Green. Uses green for all hotspot text in the printed documentation, regardless of original hotspot color. 
(Useful for searching and replacing hotspot text with cross-references or see references in the Word 
document, since the text is usually easy to spot and can be easily searched for by color.)

· Black. Uses black for all hotspot text in the printed documentation, regardless of original hotspot color. 
(Since most printed document text is black, this option causes hotspot text to blend-in with normal text.) 

4 Complete your selections on the remaining screens and click Finish when you're done.

5 Click View Results, when prompted. The Documentation Wizard opens Microsoft Word and creates the 
documentation in Word, as you watch. When the conversion is completed and the documentation is created, 
the Documentation Wizard displays a DOC file with the name you specified on the first wizard screen. If you 
chose to create a document for each TOC book, this information file lists all the documentation files created by 
the wizard.

Tips: 

· If you’re not sure which options you want to select in the Documentation Wizard, click Help for assistance.

· You can also select regular text color and image conversion options on this screen.

· To create your printed documentation even quicker, use Quick Generate to accept the defaults or use the 
current selections in the Documentation Wizard. Open the Single Source folder, right-click on Printed 
Documentation, and select Quick Generate. 

· To view or change Documentation Wizard properties, open the Single Source folder, right-click on Printed 
Documentation, and select Properties.



Selecting text color for printed documents
Use this procedure to select the color for regular, non-hotspot text in the printed documentation.

 To select text color for printed documents:

1 From the File menu, select Generate > Printed Documentation. The Documentation Wizard appears.

2 Complete your selections on the first, second, and third screens and click Next.

3 Under Which color do you want on regular text, select one of the following options:

· Keep the original color. Retains the original text color used in the Help file. 

· Black. Uses black for all non-hotspot text in the printed documentation.

4 Complete your selections on the remaining screens and click Finish when you're done.

5 Click View Results, when prompted. The Documentation Wizard opens Microsoft Word and creates the 
documentation in Word, as you watch. When the conversion is completed and the documentation is created, 
the Documentation Wizard displays a DOC file with the name you specified on the first wizard screen. If you 
chose to create a document for each TOC book, this information file lists all the documentation files created by 
the wizard.

Tips: 

· If you’re not sure which options you want to select in the Documentation Wizard, click Help for assistance.

· You can also select hotspot color and image conversion options on this screen.

· To create your printed documentation even quicker, use Quick Generate to accept the defaults or use the 
current selections in the Documentation Wizard. Open the Single Source folder, right-click on Printed 
Documentation, and select Quick Generate. 

· To view or change Documentation Wizard properties, open the Single Source folder, right-click on Printed 
Documentation, and select Properties.



Selecting image options for printed documents
Use this procedure to determine how the images from the Help system are converted in the printed documents. 
You choose how and where images are saved. You also determine if you want to include or exclude images in 
headings (using heading styles) in your printed document source files.

The Documentation Wizard provides two different options for saving images:

· Insert the images into the printed document files. If you select this option, the Documentation Wizard 
embeds one WYSIWYG copy of the image file for each image reference. That means if you've used the image 
Toolbar.bmp in five topics in the Help system, after conversion Toolbar.bmp is inserted into the printed document 
files five times. This option simplifies file management but increases the printed document file size. (Not 
recommended for large Help files or Help files with lots of graphics. Word sometimes has difficulties with very 
large files.)

· Link the image files externally. If you select this option, the Documentation Wizard saves the images into a 
graphics folder you specify. In the printed document files, the wizard inserts Word's INCLUDE PICTURE field 
code {INCLUDEPICTURE "path\\filename" \* MERGEFORMAT \d.}. This field code links the reference its 
corresponding graphic file. This option results in more files to track but keeps the .DOC file size smaller and 
more manageable. If you send your printed materials to a professional publisher, you'll need to include the 
graphics files, as well. (Recommended for most Help files – especially for larger Help files or Help files with lots 
of graphics.) 

 To select an image conversion option for printed documents:

1 From the File menu, select Generate > Printed Documentation. The Documentation Wizard appears.

2 Complete your selections on the first, second, and third screens and click Next.

3 Under How would you like to save the converted graphics, select one of the following options:

· Save the graphics inside the document. Embeds graphics into documents by saving them with the file. 
(Not recommended for large Help files or Help files with lots of graphics because it increases the .DOC file 
size.)

· Save graphics to files and link to document. Saves the graphic file in the folder specified in Graphic 
folder and links the image reference to its corresponding graphic file using Word's INCLUDE PICTURE field 
code {INCLUDEPICTURE "path\\filename" \* MERGEFORMAT \d.} (Recommended for most Help files – 
especially for larger Help files or Help files with lots of graphics.) 

4 (Optional) In Graphics Folder, enter or navigate to the folder to store the image files. By default, the 
Documentation Wizard creates a folder named "Graphics" and places it as a sub-folder in the printed 
documentation directory. (This option is only available if you select the Save graphics to files and link to 
document option.)

5 (Optional) Select Skip the conversion of graphics inside topic headings if you don't want any of the images 
used in your heading styles to be converted. (Useful if you want to exclude images from headings that appear 
in the printed documentation's table of contents.)

6 Complete your selections on the remaining screens and click Finish when you're done.

7 Click View Results, when prompted. The Documentation Wizard opens Microsoft Word and creates the 



documentation in Word, as you watch. When the conversion is completed and the documentation is created, 
the Documentation Wizard displays a DOC file with the name you specified on the first wizard screen. If you 
chose to create a document for each TOC book, this information file lists all the documentation files created by 
the wizard.

Tips: 

· If you’re not sure which options you want to select in the Documentation Wizard, click Help for assistance.

· You can also select the colors for hotspot text and regular text on this screen.

· To create your printed documentation even quicker, use Quick Generate to accept the defaults or use the 
current selections in the Documentation Wizard. Open the Single Source folder, right-click on Printed 
Documentation, and select Quick Generate. 

· To view or change Documentation Wizard properties, open the Single Source folder, right-click on Printed 
Documentation, and select Properties.



Inserting page numbers in printed documentation
Use this procedure to automatically insert sequential page numbers in your printed documentation. The 
Documentation Wizard provides an option to include sequential page numbers in each document file using Word's 
PAGE field code {PAGE}. This field code is embedded as an object in the footer of the documents. Page numbers 
appear on the first page and alternate on the left and right sides of the document to correspond with odd- and 
even-numbered pages.

 To automatically insert page numbers in printed documentation:

1 From the File menu, select Generate > Printed Documentation. The Documentation Wizard appears.

2 Complete your selections on the first, second, third, and fourth screens and click Next.

3 Select Insert Page Numbers. 

4 Complete your selections on this screen and click Finish when you're done.

5 Click View Results, when prompted. The Documentation Wizard opens Microsoft Word and creates the 
documentation in Word, as you watch. When the conversion is completed and the documentation is created, 
the Documentation Wizard displays a DOC file with the name you specified on the first wizard screen. If you 
chose to create a document for each TOC book, this information file lists all the documentation files created by 
the wizard.

Tips: 

· If you’re not sure which options you want to select in the Documentation Wizard, click Help for assistance.

· You can set other page setup option on this screen, too – paper size and whether you want a page break 
before each topic.

· To create your printed documentation even quicker, use Quick Generate to accept the defaults or use the 
current selections in the Documentation Wizard. Open the Single Source folder, right-click on Printed 
Documentation, and select Quick Generate. 

· To view or change Documentation Wizard properties, open the Single Source folder, right-click on Printed 
Documentation, and select Properties.



Changing paper size for printed documents
Use this procedure to change the paper size for your printed documents. The Documentation Wizard uses 
standard Letter size – 8 ½ inches by 11 inches. But you can select any of the following paper sizes:

· Legal 8 ½ inches by 14 inches

· A4 210 millimeters by 297 millimeters

· A5 148 millimeters by 210 millimeters

· B5 182 millimeters by 257 millimeters 

You can always change the paper size in the printed document files using Word's Page Setup options. 

 To change the paper size for printed documents:

1 From the File menu, select Generate > Printed Documentation. The Documentation Wizard appears.

2 Complete your selections on the first, second, third, and fourth screens and click Next.

3 Under Which paper size do you want to use for the document, select the appropriate paper size. 

4 Complete your selections on this screen and click Finish when you're done.

5 Click View Results, when prompted. The Documentation Wizard opens Microsoft Word and creates the 
documentation in Word, as you watch. When the conversion is completed and the documentation is created, 
the Documentation Wizard displays a DOC file with the name you specified on the first wizard screen. If you 
chose to create a document for each TOC book, this information file lists all the documentation files created by 
the wizard.

Tips: 

· If you’re not sure which options you want to select in the Documentation Wizard, click Help for assistance.

· You can set other page setup option on this screen, too – page numbers and whether you want a page break 
before each topic.

· To create your printed documentation even quicker, use Quick Generate to accept the defaults or use the 
current selections in the Documentation Wizard. Open the Single Source folder, right-click on Printed 
Documentation, and select Quick Generate. 

· To view or change Documentation Wizard properties, open the Single Source folder, right-click on Printed 
Documentation, and select Properties.



Printed documentation source files
The files generated when you use RoboHELP to create printed documentation depend on the choices you select 
in the Documentation Wizard. 

One printed document file

If you chose to create one document file, here's a list of the printed documentation files you can generate using the 
RoboHELP’s Single Source Wizard:

· PROJECTNAME.doc
This is the main DOC file created, named after the Help project. This file contains all the topics in your Help file. 
Depending on the option you selected, topics appear in the same order as the table of contents or in their 
physical order inside each Help document. (Help documents appear in the order they're listed in the Help project 
(HPJ) file. 

This file also includes the TOC and index, if you selected those options. 

Multiple document files (created based on the books in the table of contents)

If you chose to create multiple printed document files, here's a list of the files you can generate using the 
RoboHELP’s Single Source Wizard:

· PROJECTNAME.doc
This is the main DOC file created, named after the Help project. 

· Toc.doc
(If you selected the Create TOC option.) This document contains the coding to generate a Microsoft Word table 
of contents.

· *.doc
The RoboHELP Documentation Wizard creates one document for each first-level book in your project containing 
all topics beneath that first-level book. 

Depending on the option you selected, topics appear in the same order as the table of contents or in their physical 
order inside each Help document. (Help documents appear in the order they're listed in the Help project (HPJ) file.

· ExtraTopics.doc
(If you selected the Do you want to create documents from Books in the CNT file option.) This document 
contains all Help topics not listed in the Help project’s TOC. Often these are popup topics or context-sensitive 
topics. 

· Index.doc
(If you selected the Create Index option.) This document contains the K-keyword Index entries from your Help 
project.

Tip:

To see or set the selections, open the Single Source folder, right-click on Printed Documentation, and select 
Properties.



Working with printed documentation source files
Once you’ve used RoboHELP’s Single Source Documentation Wizard to create your printed documentation 
source files, you can do just about anything to the files you want. 

· Edit them in Microsoft Word. Since Microsoft Word is a popular and familiar word processing environment, 
many Help authors continue to develop their printed documentation using Word. Once RoboHELP converts the 
printed documentation files for you, these files are just like any other Word .DOC file. You can use any of 
Microsoft Word’s powerful features to complete camera-ready or final printed materials.

· Use another application (other than Word) to edit them. Some Help authors use applications other than 
Microsoft Word to create their camera-ready or final printed materials. If that’s your situation, don’t worry. Just 
consult your application’s Help or documentation regarding importing Microsoft Word files.



Viewing and editing printed documentation in Word
Use this procedure when you want to view or edit your printed documentation files in Microsoft Word. You can 
either open the files directly in Microsoft Word or you can open the files from the RoboHELP Explorer. 

 To edit or view printed documentation from the RoboHELP Explorer:

1 From the Single Source folder, right-click on Printed Documentation.

2 Select Edit or View to edit documentation. RoboHELP displays the Projectname.DOC file. 

· If you created a single document, simply open the Projectname.DOC file.

· If you created documents based on the books in the Contents file (TOC), this document provides convenient 
access to all the printed documents created. To edit a specific document, double-click on the Double Click 
to Edit text in front of the document’s name.

Tip:

If you want to use another version of Microsoft Word to edit your printed documentation, specify this on the 
RoboHELP Options: Single Source tab. (For example, if you want to use Word 95 for your printed documents, 
but you are using Word 97 with RoboHELP.) 



Selecting another version of Word to use as an Editor
Use this procedure if you want to use a version of Microsoft Word to edit your printed documentation. For 
example, you use Word 97 with RoboHELP, but you prefer to use Word 95 for your printed documentation.

Important! If you want to use another version of Word, make sure to save a copy of your Help project source files 
document as a 95/6.0 document BEFORE creating the printed documentation.

 To select a different version of Microsoft Word as your printed 
documentation editor:

1 From the Tools menu, select Options.

2 Select the Single Source tab,

3 In Editor, enter the path of the other Microsoft Word or navigate to its location.

4 Click OK.



Using another editor for printed documents
Some Help authors use software packages other than Microsoft Word – like FrameMaker – for their printed 
documents. Since most of these applications can directly import Microsoft Word’s .DOC format and automatically 
make the necessary conversions, you can still use RoboHELP’s Documentation Wizard to create the base source 
files for your printed documentation. Just make sure to save the printed documentation files created by the 
Documentation Wizard first – before converting or importing to another editor.

Consult the application’s online Help or documentation for details on using the .DOC files created by the 
Documentation Wizard. Things you’ll want to know before you begin:

· How formatting attributes do and don’t translate from Word to the application. This may affect the 
template you use to during the RoboHELP conversion. If the application doesn’t translate any of the styles, you 
may just want to attach the Normal.dot template.

· If the application recognizes Word’s index entry marking. If the application doesn’t recognize Microsoft 
Word’s index marking, you probably don’t want to select the RoboHELP option to mark Index K-keyword entries 
when you convert the Help source files.

· File size limitations or recommendations. This may impact whether you create one .DOC file or several and 
whether or not you include graphics in the conversion.



Documentation Wizard Welcome
Use the Document Wizard to create printed documentation from your Help project source files.

What Help project do you want to convert to documentation?

Type a path and filename or click  to browse and select a Help project.



Documentation Wizard: File
Use the File screen to specify the path and file name for the printed documentation and select the Help project 
source files to convert.

Specify path and filename for the printable documentation

Specifies the path and file name for the printed documentation. This is where it saves the printed documentation 
set. By default, the Documentation Wizard creates a folder named "Doc" and places it as a subfolder in the project 
directory. The file name defaults to the Help project name with the DOC extension.

Press Backspace to type a path and file name.

 Displays the Open dialog for navigating to a different path.

Which source files do you want to convert?

Lists the .RTF files in this Help project alphabetically. By default, all .RTF files are selected – with the exception of 
system documents (like HtmlWh.RTF), which shouldn't be selected. 

Select the .RTF source files you want to convert. Clear all source files you don’t want to convert. You may not 
want to convert some files in your project; for example, you may not want to convert an .RTF file that contains only 
context-sensitive Help topics. 

Note: If an .RTF source file is missing from the Help project, a special icon  appears You can't select a missing 
source file for conversion. If you need to include this missing source file, click Cancel to exit the wizard and locate 
the missing source file in RoboHELP Explorer before continuing.

Clear All button

Clears the checkmark next to all selected .RTF files.

Select All button

Selects (checks) all .RTF files.



Documentation Wizard: Options
Use the Options screen to specify the number of printed documentation .DOC files, topic arrangement, heading 
level formatting, table of contents, and index options.

Do you want to use the CNT file to determine heading levels and topic order?

Bases the heading levels in the documents, as well as the order of topics that fall under each heading level, on the 
structure of the Help system's table of contents (CNT file). 

If you don't select this option, the Documentation Wizard uses the order of files in the HPJ file and the order of 
topics in each file to determine the structure.

Do you want to create documents from Books in the CNT file? 

Creates multiple printed documentation files – a separate Word file (.DOC) for each top-level book in the Help 
system's table of contents (CNT file). All sub-books (second-level, third-level, etc.) are included as headings in the 
documents. All topics saved in the top-level book and its sub-books are contained in the resulting document. 
Topics not included in the Help file’s table of contents are placed in a document named ExtraTopics.doc.

If you don't select this option, the Documentation Wizard creates one .DOC file containing all topics and books in 
the Help system. 

Do you want to create a TOC and Index?

Create TOC

Generates a table of contents using Microsoft Word's TOC field code {TOC \O}. The \O switch means that the 
TOC is built by using outline (heading) levels from the corresponding documents. 

Note: If you selected the Do you want to create documents from Books in the CNT file option, the 
Documentation Wizard creates a separate document – TOC.DOC – containing the generated table of contents. 
If you didn't select this option, the Documentation Wizard inserts and generates the table of contents at the top 
of the printed documentation .DOC file.

Convert K-keywords to Index entries

Adds Microsoft Word index entries for each corresponding Index keyword (K-keyword) in each topic. For 
example, if a topic includes the keyword "safari" and the topic content uses the text "safari" three times, each 
occurrence of the keyword is indexed using Word's INDEX ENTRY field code {xe "keyword"}. When 
converted, the Microsoft Word index entry for "safari" becomes {xe "safari"}.

Create Index

Generates an index using Word's INDEX field code {INDEX \c "#"}. The \c creates an index with more than 
one column on the page. The "#" indicates the number of columns. 

Note: If you selected the Do you want to create documents from Books in the CNT file option, the 
Documentation Wizard creates a separate document – INDEX.DOC – containing the generated index. If you 
didn't select this option, the Documentation Wizard inserts and generates the index at the top of the printed 
documentation .DOC file.

For more information about Word field codes, Word's Insert Index and Tables option, and creating tables of 
contents or indexes in printed documentation, refer to Microsoft Word's online Help or user guide.



Documentation Wizard: Template
Use the Template screen to select the template and style options for your printed documentation. The printed 
output will be formatted according to the selections you make on this screen.

Which template do you want to apply to the document?

Specifies the template file (.DOT) you want to use to format text in your printed documentation. The 
Documentation Wizard uses this template and the styles defined in this template to determine text formatting. By 
default, the ROBODOCS.DOT template is selected and its styles applied to the printed documentation. 

You can select a different template from the drop-down list 

 Displays the Open dialog for navigating to another template.

Enable global formatting for Heading styles

Preserves global template formatting for all heading styles, allowing you to make changes in the printed document 
template that apply to all the printed documentation files. 

How do you want to convert Help topic styles not defined in the printed doc template?

· Keep Help style. Copies the non-existing style name and its style attributes from the Help system into the 
output file. Converted text using this style name appears in the output file exactly as it did in the Help system. 

· Keep Help Style but use Normal style indentation and tab stops as defined in printed doc template. 
Copies the non-existing style name from the Help system into the output file, but change the paragraph format 
attributes to match the printed document template's Normal style indentation and tab stops. Converted text 
using this style name appears in the same font (style, size, color, etc.) as in the Help system, but it takes on the 
paragraph attributes of the printed document template's Normal style. 

· Create a new style based on Normal style in the printed doc template. Copies the non-existing style name 
from the Help system into the printed document template. Converted text using this style name is formatted with 
the attributes of the Normal style, as defined in the printed document template, but still retains its original style 
name. This allows you to make global style changes to this style in the printed document template. 

Note: If the Documentation Wizard finds Help styles not in the printed document template, it displays an 
informational dialog at the end of the conversion. This dialog lists the styles in the Help system not in the selected 
printed document template and shows you which of the above selections it applied to text marked with these 
styles. 



Documentation Wizard: Colors and Graphic
Use the Graphics and Color screen to specify hotspot color, regular text color, and image options for your printed 
documentation. 

Which color do you want on converted hotspot text?

· Keep the original color. Retains the original hotspot color used in the Help file. 

· Green. Uses green for all hotspot text in the printed documentation, regardless of original hotspot color.

· Black. Uses black for all hotspot text in the printed documentation, regardless of original hotspot color. 

Which color do you want on regular text?

· Keep the original color. Retains the original text color used in the Help file. 

· Black. Uses black for all non-hotspot text in the printed documentation.

How would you like to save the converted graphics?

· Save the graphics inside the document. Embeds graphics into documents by saving them with the file. 
During the conversion process, the Documentation Wizard replaces each image reference with a WYSIWYG 
copy of the image file. This option simplifies file management but increases the printed document file size. (Not 
recommended for large Help files or Help files with lots of graphics. Word sometimes has difficulties with very 
large files.)

· Save graphics to files and link to document. Saves the graphic file in the folder specified in Graphic folder 
and links the image reference to its corresponding graphic file using Word's INCLUDE PICTURE field code 
{INCLUDEPICTURE "path\\filename" \* MERGEFORMAT \d.} This option results in more files to track but 
keeps the .DOC file size smaller and more manageable. If you send your printed materials to a professional 
publisher, you'll need to include the graphics files, as well. (Recommended for most Help files – especially for 
larger Help files or Help files with lots of graphics.) 

Graphics Folder

Specifies the folder to save the graphics files to. By default, the Documentation Wizard creates a folder named 
"Graphics" and places it as a sub-folder in the printed documentation directory. (This option is only available if 
you select the Save graphics to files and link to document option.)

Skip the conversion of graphics inside topic titles

Removes graphics associated with any style heading level – Heading 1 to Heading 9. 



Documentation Wizard: Page Setup
Use the Page Setup screen to define page numbering, page breaks, and paper size for your printed 
documentation.

Which additional options do you wish to apply to the printable documentation?

· Insert page numbers. Includes sequential page numbers in each document file using Word's PAGE field code 
{PAGE} embedded as an object in the footer of the documents. Page numbers appear on the first page and 
alternate on the left and right sides of the document to correspond with odd- and even-numbered pages.

· Keep page break before each topic. Inserts a page break before each Heading 1 style in the printed 
documentation – each topic appears on a separate page. (Increases the page count in the hard copy.)

Which paper size do you want to use for the document?

Specifies the paper size to use in the printed documentation. The default is Letter size 8½" x 11".



Documentation Properties: File

 Displays the last selected file properties used by the Documentation 
Wizard to create printed documentation from your Help project source files. If you haven't created printed 
documentation using the Documentation Wizard, these selections are the wizard's default selections.

Which filename do you want for the printable documentation?

Displays the path and file name for the printed documentation. This is where the Documentation Wizard saves the 
printed documentation set. 

Press Backspace to type a path and file name.

 Displays the Open dialog for navigating to a different path.

Which source files do you want to convert?

Lists the .RTF files in this Help project alphabetically. Only selected .RTF source files are converted.

Note: If an .RTF source file is missing from the Help project, a special icon 



 appears. You can't select a missing source file for conversion. If you 
need to include this missing source file, click Cancel to exit the wizard and locate the missing source file in 
RoboHELP Explorer before continuing.

Clear All button

Clears the checkmark next to all selected .RTF files.

Select All button

Selects (checks) all .RTF files.



Documentation Properties: Options

 Displays the last selected options for the number of printed documentation 
.DOC files, topic arrangement, heading level formatting, table of contents, and index options used by the 
Documentation Wizard to create printed documentation. If you haven't created printed documentation using the 
Documentation Wizard, these selections are the wizard's default selections.

Do you want to use the CNT file to determine heading levels and topic order?

Bases the heading levels in the documents, as well as the order of topics that fall under each heading level, on the 
structure of the Help system's table of contents (CNT file). 

If not selected, the Documentation Wizard uses the order of files in the HPJ file and the order of topics in each file 
to determine the structure.

Do you want to create documents from Books in the CNT file? 

Creates multiple printed documentation files – a separate Word file (.DOC) for each top-level book in the Help 
system's table of contents (CNT file). All sub-books (second-level, third-level, etc.) are included as headings in the 
documents. All topics saved in the top-level book and its sub-books are contained in the resulting document. 
Topics not included in the Help file’s table of contents are placed in a document named ExtraTopics.doc.

If not selected, the Documentation Wizard creates one .DOC file containing all topics and books in the Help 
system. 

Do you want to create a TOC and Index?

Create TOC

Generates a table of contents using Microsoft Word's TOC field code {TOC \O}. The \O switch means that the 
TOC is built by using outline (heading) levels from the corresponding documents. 

Note: If the Do you want to create documents from Books in the CNT file option is selected, the 
Documentation Wizard creates a separate document – TOC.DOC – containing the generated table of contents. 
If not, the Documentation Wizard inserts and generates the table of contents at the top of the printed 
documentation .DOC file.

Convert K-keywords to Index entries

Adds Microsoft Word index entries for each corresponding Index keyword (K-keyword) in each topic. For 
example, if a topic includes the keyword "safari" and the topic content uses the text "safari" three times, each 
occurrence of the keyword is indexed using Word's INDEX ENTRY field code {xe "keyword"}. When 
converted, the Microsoft Word index entry for "safari" becomes {xe "safari"}.

Create Index

Generates an index using Word's INDEX field code {INDEX \c "#"}. The \c creates an index with more than 
one column on the page. The "#" indicates the number of columns. 

Note: If the Do you want to create documents from Books in the CNT file option is selected, the 
Documentation Wizard creates a separate document – INDEX.DOC – containing the generated index. If not, 
the Documentation Wizard inserts and generates the index at the top of the printed documentation .DOC file.



For more information about Word field codes, Word's Insert Index and Tables option, and creating tables of 
contents or indexes in printed documentation, refer to Microsoft Word's online Help or user guide.



Documentation Properties: Template

 Displays the last selected template and style options for the printed 
documentation. The printed output will be formatted according to the selections on this screen. If you haven't created 
printed documentation using the Documentation Wizard, these selections are the wizard's default selections.

Which template do you want to apply to the document?

Specifies the template file (.DOT) you want to use to format text in your printed documentation. The 
Documentation Wizard uses this template and the styles defined in this template to determine text formatting. By 
default, the ROBODOCS.DOT template is selected and its styles applied to the printed documentation. 

You can select a different template from the drop-down list.

 Displays the Open dialog for navigating to another template.

Enable global formatting for Heading styles

Preserves global template formatting for all heading styles, allowing you to make changes in the printed document 
template that apply to all the printed documentation files. 

How do you want to convert Help topic styles not defined in the printed doc template?

· Keep Help style. Copies the non-existing style name and its style attributes from the Help system into the 
output file. Converted text using this style name appears in the output file exactly as it did in the Help system. 

· Keep Help Style but use Normal style indentation and tab stops as defined in printed doc template. 
Copies the non-existing style name from the Help system into the output file, but change the paragraph format 
attributes to match the printed document template's Normal style indentation and tab stops. Converted text 
using this style name appears in the same font (style, size, color, etc.) as in the Help system, but it takes on the 
paragraph attributes of the printed document template's Normal style. 



· Create a new style based on Normal style in the printed doc template. Copies the non-existing style name 
from the Help system into the printed document template. Converted text using this style name is formatted with 
the attributes of the Normal style, as defined in the printed document template, but still retains its original style 
name. This allows you to make global style changes to this style in the printed document template. 



Documentation Properties: Color and Graphic

 Displays the last selected hotspot color, regular text color, and image 
options for the printed documentation. If you haven't created printed documentation using the Documentation Wizard, 
these selections are the wizard's default selections.

Which color do you want on converted hotspot text?

· Keep the original color. Retains the original hotspot color used in the Help file. 

· Green. Uses green for all hotspot text in the printed documentation, regardless of original hotspot color.

· Black. Uses black for all hotspot text in the printed documentation, regardless of original hotspot color. 

Which color do you want on regular text?

· Keep the original color. Retains the original text color used in the Help file. 

· Black. Uses black for all non-hotspot text in the printed documentation.

How would you like to save the converted graphics?

· Save the graphics inside the document. Embeds graphics into documents by saving them with the file. 
During the conversion process, the Documentation Wizard replaces each image reference with a WYSIWYG 
copy of the image file. This option simplifies file management but increases the printed document file size. (Not 
recommended for large Help files or Help files with lots of graphics. Word sometimes has difficulties with very 
large files.)

· Save graphics to files and link to document. Saves the graphic file in the folder specified in Graphic folder 
and links the image reference to its corresponding graphic file using Word's INCLUDE PICTURE field code 
{INCLUDEPICTURE "path\\filename" \* MERGEFORMAT \d.} This option results in more files to track but 
keeps the .DOC file size smaller and more manageable. If you send your printed materials to a professional 
publisher, you'll need to include the graphics files, as well. (Recommended for most Help files – especially for 
larger Help files or Help files with lots of graphics.) 

Graphics Folder

Specifies the folder to save the graphics files to. By default, the Documentation Wizard creates a folder named 
"Graphics" and places it as a sub-folder in the printed documentation directory. (This option is only available if 
you select the Save graphics to files and link to document option.)

Skip the conversion of graphics inside topic titles

Removes graphics associated with any style heading level – Heading 1 to Heading 9. 



Documentation Properties: Page Setup

 Displays the last selected page numbering, page breaks, and paper size 
options for the printed documentation. If you haven't created printed documentation using the Documentation Wizard, 
these selections are the wizard's default selections.

Which additional options do you want from the converted document?

· Insert page numbers. Includes sequential page numbers in each document file using Word's PAGE field code 
{PAGE} embedded as an object in the footer of the documents. Page numbers appear on the first page and 
alternate on the left and right sides of the document to correspond with odd- and even-numbered pages.

· Keep page break before each topic. Inserts a page break before each Heading 1 style in the printed 
documentation – each topic appears on a separate page. (Increases the page count in the hard copy.)

Which paper size do you want to use for the document?

Specifies the paper size to use in the printed documentation. The default is Letter size 8½" x 11".



Documentation Properties: Statistics

 Displays statistics of the last successful conversion by the Documentation 
Wizard. 

Last generated

Displays the date and time the last printed documentation was generated by the Documentation Wizard.

Generated by

Displays the user name of the person logged on to the PC on which the conversion occurred.

Location

Displays the path and file name of the converted printed documentation files.



Documentation Wizard Result
This window lets you know that the Documentation Wizard successfully created printed documentation. 

If the document template selected did not contain all the styles in your Help project, this window also gives you the 
following information:

· Lists any styles in your project that were not converted because they did not exist in the template selected.

· Shows you which conversion option you selected for styles not defined in the document template. 
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