
Welcome to RoboHELP

Welcome to RoboHELP®, the Industry Standard in Help Authoring from eHelp Corporation. This power-packed version of 
RoboHELP combines exciting new features with the established functionality Help authors have come to rely on.

This project shows you some of the cool things you can do with RoboHELP. Simply:

· Use the browse buttons above to navigate through each topic, or

· Use the Contents on the left to choose which topic you’d like to view.

Tip

This topic use a cloud watermark for the main topic. It’s easy to add watermarks with RoboHELP. When you’re authoring a 
project, simply open the topic, click Topic Properties then use the Watermarks tab.



Invisible and Colored Hotspots

This topic demonstrates ways you can color hotspot text or remove the characteristic underlines normally associated with 
hotspots. 

Click each jump below to find out how we did it!

Tip! Read this caution before you change the links in your projects.

Jumps

Standard Jump

Jump with no underline 

Different color Jump

Invisible Jump somewhere in this text. Can you find it?

Popups

Standard Popup

Popup with no dotted underline

Blue Popup with no dotted underline 

Macro Jumps (Hotspots)

Standard Macro Hotspot 

Red Macro Hotspot 



Green Jump With No Underline

To create this green jump with no underline, you choose the Hidden option when you create the jump, then color the jump Dark 
Green. Here are the exact steps:

1 Click the New Jump button.

2 Type your Hotspot text and choose a topic to jump to.

3 In the Appearance drop down box, choose Hidden.

4 Click OK.

5 Highlight the jump.

6 From the Format menu, choose Font.

7 Choose the Dark Green option, then click OK.



Blue Popup With No Dotted Underline

To create the blue popup hotspot (with no dotted underline) in RoboHELP, you simply choose the Hidden option when you create 
the popup, then color the hotspot. Here are the exact steps:

1 Click the New Popup button.

2 Type your Hotspot text and the text to display in a popup window (or use the Action Type drop down, specify Popup, and 
choose a topic to display in the popup window.

3 In the Appearance drop down box, choose Hidden.

4 Click OK.

5 Highlight the popup text.

6 From the Format menu, choose Font.

7 Choose Blue, then click OK.



Red Macro

To create the red macro hotspot in RoboHELP Classic, you simply choose the Hidden option when you create the macro 
hotspot, then color the hotspot. Here are the exact steps:

1 From the Insert menu, choose Other Hotspots, then choose Macro Hotspot.

2 For Appearance, click Hidden.

3 Choose the macro to be used with the hotspot.

4 Click OK.

5 Highlight the hotspot.

6 From the Format menu, choose Font.

7 Choose Red, then click OK.



Invisible Jump

An invisible jump has no color and no underline. It blends in to existing topic text. To create an invisible jump in RoboHELP 
Classic, you simply choose the Hidden option when you create the jump. Here are the exact steps:

1 Click the New Jump button.

2 In the Appearance drop down box, choose Hidden.



Different Color Jump

To create a different color jump in RoboHELP Classic, you first select No Color while creating the jump, then use the Color 
Palette to color the jump. Here are the exact steps:

1. Click the Jump button.

2. Type your Hotspot text and select a topic to jump to.

3. In the Hotspot drop down box, scroll to and choose No Color.

4. Click OK.

5. From the Format menu, choose Font.

6. Highlight the hotspot, click a color on the Color Palette, and then click Apply.



Standard Topic

This topic is displayed from the Standard Jump, Standard Popup and Standard Macro example hotspots.



Popup With No Underline

To create this popup, choose the Hidden option when you create the popup, then color the popup Dark Green. Here are the 
exact steps:

1 Click the Popup button.

2 Type your Hotspot text and the text to display in a popup window (or use the Action Type drop down, specify Popup, and 
choose a topic to display in the popup window. 

3 In the Appearance drop down box, choose Hidden.

4 Click OK.

5 Highlight the popup.

6 From the Format menu, choose Font.

7 Choose Dark Green then click OK.



Caution!

Note that in standard Help files for the Windows Help Viewer, hotspot text has well established conventions (green text with 
either a dotted or single underline) to allow ease in navigating the Help system. Deviating from these conventions may make 
your Help file harder to navigate. 



Standard Commands - using shortcuts

Examples of WinHelp Internet Access functionality using shortcuts. If you have an Internet Browser set up on your system, try 
out some of the links below.

Access World Wide Web sites

Click here        to access the eHelp Corporation home page

Click here        to access an Internet bookstore

Click here        to access the ESPN Sportszone

Click here        to access the Discovery Channel home page

Click here        to access the Virtual Tourist world map

Click here        to access the Sony home page

Click here        to access the Moviesounds home page

Click here        to access the San Diego Union Tribune home page

Click here        to access the NBA home page

Search the Internet

Click here        to search the Internet

Get started on the Internet

Click here        for information on getting started on the Internet

Tip

To find out how to embed HTML in a standard WinHelp Help system, check out the ‘HTML’ sample.



Standard Commands - using hotspot text

Examples of WinHelp Internet Access functionality using hotspot text. If you have an Internet Browser set up on your system, try 
out some of the links below.

Access World Wide Web Sites

eHelp Corporation 

Internet bookstore 

ESPN Sportszone 

Discovery Channel 

Virtual Tourist world map 

Sony 

Moviesounds 

San Diego Union Tribune 

NBA 

Search the Internet

Search the Internet 

Get Started on the Internet

Getting started 

Tip

To find out how to embed HTML in a standard WinHelp Help system, check out the ‘HTML’ sample.



Advanced Commands

There are other cool ways to add Internet access to your WinHelp systems. Take a look at these ideas.

· Create a link that allows your users to send email right out of your Help system. 

· Create a link that allows your users to download a file from the Internet.

Tip

To find out how to implement these ideas and more, look in the RoboHELP online Help system under Inet WinHelp Macro for 
details.



Overview of WinHelp 4 Features

This Help system demonstrates some of the new styles and features of WinHelp 4 Help and provides tips and examples on how 
to implement them using RoboHELP Classic. 

WinHelp 4 Help uses the WinHelp 4 Help compiler (HCW) and the WinHelp 4 Help Engine. It was introduced with Windows 95 
and is also used on Windows NT 4 and later.

This sample was created using RoboHELP Classic.



256 Color Graphics

With RoboHELP, simply use the New Help Image button to insert 256 color graphics. If you work in RoboHELP’s Dynamic 
WYSIWYG mode, you can see the graphic in your Help project source, without having to compile!

Tip

With RoboHELP Classic, you can now put hotspots on 256 color graphics, just as you do on 16 color graphics. Find the hotspot 
in the bowl of fruit!



Windows Metafile (WMF) Graphics

With RoboHELP Classic, simply use the New Help Image button to insert WMF graphics files.



Default Bitmaps

The WinHelp 4 Help compiler provides “Default Bitmaps”. If you specify a bitmap with one of the following names in your Help 
project, and it is not located with the rest of your bitmaps, the WinHelp 4 Help compiler uses its built-in version.

Bitmap Name WinHelp 4 Built-in 
Bitmap

Bullet.bmp

Emdash.bmp

Shortcut.bmp

Onestep.bmp

Open.bmp

Closed.bmp

Document.bmp

Do-it.bmp

Chiclet.bmp

Prcarrow.bmp



Transparent Bitmaps

WinHelp 4 Help lets you create bitmaps that are transparent against solid backgrounds. When WinHelp displays a transparent 
bitmap, it replaces all white pixels with the background color of the topic window.

Example Transparent Bitmaps

Tips

· Transparent bitmaps must be 16 color bitmaps.

· Transparent bitmaps work best on a solid color background.



Overview of Buttons

WinHelp 4 Help supports pressable buttons that can be used as hotspots. You can easily add these types of buttons to your Help 
systems with RoboHELP Classic. From the Insert menu, choose Help Button (or use the New Help Button tool on the Tool 
Palette).

Authorable Button Samples 

Mini Button Samples 

Shortcut Button Samples 



Authorable Button Samples

An Authorable button is sized to the size of the text. Here are some examples:

{button Small,JI(`',`Sample')}

{button Medium,JI(`',`Sample')}

{button Large Button,JI(`',`Sample')}

Tip 

 You can use the space bar to create a wide button.

{button                                          Order Form                                        ,JI(`',`Sample')}



Sample Topic One

This is a sample topic linked to the Authorable buttons and Mini-buttons. 

Behind the scenes, this topic contains the A-keyword “Topic”. The A-keyword is used for the See Also and Related Topics links in 
the Mini-button sample. 

Click Back to return to the sample.

{button Back,Back()}



Sample Topic Next

This is a sample topic linked to the Authorable buttons and Mini-buttons. 

Behind the scenes, this topic contains the A-keyword “Topic”. The A-keyword is for the See Also and Related Topics links in the 
Mini-button sample. 

Click Back to return to the sample.

{button Back,Back()}



Sample Topic Three

This is a sample topic linked to the Authorable buttons and Mini-buttons. 

Behind the scenes, this topic contains the A-keyword “Topic”. The A-keyword is for the See Also and Related Topics links in the 
Mini-button sample. 

Click Back to return to the sample.

{button Back,Back()}



Shortcut Button Samples

Click  to run Control Panel.



Mini Button Samples

In WinHelp 4, mini buttons are often used at the bottom of a topic for “See Also” and “Related Topics” references. They are often 
linked to the A-link or K-link macros, which allow the Help Author to create a single link to multiple topics. RoboHELP makes it 
easy to create these kinds of buttons.

Here is an example “See Also” button linked to the A-link macro:

{button ,AL(`Topic',0,`',`')}    See Also

Here is an example “Related Topics” button linked to the A-link macro:

{button ,AL(`Topic',0,`',`')}    Related Topics

Tip

· To create the line above “Related Topics”, just use Words Format: Borders and Shading feature.



Overview of Topics

Topics are the units of information in a Help system. There are certain “styles” of topics you will see in WinHelp 4 Help systems. 
The style of topic is determined by the footnotes associated with it. In general, no matter what the “style” of the topic, you can 
create it in RoboHELP Classic by choosing the New Topic button then choosing the options you want associated with the topic. 

You can also quickly create “Definition” Style and “What’s This” Style topics in RoboHELP using the New Popup button.

How-to Style Topics

“How-to” Style Topics explain how to perform a task. They are usually displayed in a secondary window and are usually short 
and concise. In RoboHELP Classic, you can easily create How-to Style Topics by using the New Topic button.

Sample How-to Style Topic

What’s This? Style Topics

“What’s This?” Style Topics are used for context-sensitive Help for an application. They describe a particular field in a dialog 
box. They usually do not have a title ($), browse string (+) or search keyword (K) footnote. It is suggested that they have a Topic 
ID that begins with IDH_. 

If you just need to create a few of these kinds of topics, you can easily create them in RoboHELP Classic using the New Topic 
button (don’t specify a title, index entry, or browse for the topic). If you are creating a complete What’s This? Context sensitive 
Help system, use RoboHELP Classic’s What’s This? Help Composer, which lets you write the topics as you view the dialog 
boxes in your application.

What's This? Example 

Definition Style Topics

“Definition” Style Topics are often used to define terms. They may be used in the text of the Help system to define a word and 
may be included in a Glossary. “Definition” Style Topics are usually not included in a browse sequence or Index, thus they do not 
have browse string (+) or search keyword (K) footnotes. You can quickly create this type of topic in RoboHELP using the New 
Popup button.

Sample Popup Definition Topic



How-to Style Topics

Here are the general steps to create How-to Style Topics:

1 Click the New Topic button to create each topic. 

2 In the New Topic dialog, click the Advanced tab.

3 In Window, choose Second. This ensures the topic will always display in a secondary window. 

4 Click OK.

Use RoboHELP’s built in styles to make formatting easy.

1 Use Topic Text Numbered style for steps (that’s the style we’ve used for the numbered steps in this sample)

2 There are also styles for Topic Text Bulleted:

· Sample Bullet

Tips

· Use Tip/Note Heading style for Tip Headings.

· Use Tip/Note Text style for Tip text.



What's This? Style Topics

What’s This? Style Topics are used for context-sensitive Help for an application. They describe a particular field in a dialog box. 
They usually do not have a title and often have a Topic ID that begins with IDH_. You can quickly create this type of topic in 
RoboHELP Classic, using the New Topic button.

What's This? Example 



Definition Style Topics

Definition Style Topics are often used to define terms. They may be used in the text of the Help system to define a word and may 
be included in a Glossary. This type of topic is usually not included in the browse sequence or Index. You can quickly create this 
type of topic in RoboHELP using the New Popup button.

Sample Popup Definition Topic



Popup Definition Topic

This type of topic can be quickly created in RoboHELP Classic using the Popup button. Topics created this way are usually used 
for Popup definitions. This type of topic does not have Search Keywords or a Browse Sequence.



This is a sample What's This? style topic. This type of topic is used for Context-sensitive Help. By default, it does not have a 
Title, Search Keywords, or a Browse Sequence.



Contents Tabs

WinHelp 4 Help systems will often include a Contents tab as part of the Help Topics dialog box. A Contents tab consists of books 
that can be opened and closed, and pages that jump to topics in the Help system. This Sample WinHelp 4 Help system includes 
a Contents tab. 

Shipping a Contents file with the Help system creates a Contents tab. The Contents file has the same name as the Help system 
and a CNT extension. For example, for a Help system called MYHELP.HLP, the Contents file would be MYHELP.CNT.

You can easily create a Contents tab for your Help system using RoboHELP Classic’s Contents Tab Composer. The Contents 
Tab Composer reads in your Help system source and allows you to use drag and drop to visually design the Contents tab.



Fonts

The standard fonts used for Help have changed for WinHelp 4. RoboHELP is set up to use the new fonts and font sizes so your 
Help systems will have the WinHelp 4 look automatically (note that if you don’t want to use the WinHelp 4 look, you don’t have to 
- you can use any fonts you like with RoboHELP Classic!). 

Here are some examples of the new WinHelp 4 styles:

Topic Titles are Arial 8 pt Bold. In RoboHELP Classic, you’ll use the Heading 1 style for Topic Titles.

Example Topic Title

Topic Text is Arial 8 pt. In RoboHELP Classic, this is the normal style.

Example Topic Text

Tip/Note/Warning Titles are Arial 8 pt Bold. In RoboHELP Classic, use the Tip/Note Heading style.

Example Tip/Note/Warning Title

There is a style for Topic Text Indent. 

Example. This is indented text.

And a style for Topic Text Numbered:

1 This is 

2 An example

3 Numbered list




