
Set page margins

1 To set page margins for one sheet, click the worksheet.

To set page margins for more than one sheet, select the sheets.

2 On the File menu, click Page Setup, and then click the Margins tab.

3 In the Top, Bottom, Left, and Right boxes, enter the margin size you want.

These settings should be larger than the minimum margins required by your printer.

Tip      To see how the page margins will affect the printed document, click Print Preview on the File menu before 
the document is printed. To adjust the margins in print preview, click Margins, and then drag the handles.



Change the worksheet area that appears on a printed page

If your work doesn't fit exactly on the number of printed pages you want, you can adjust, or scale, your printed 
work to fit on more or fewer pages than it would at normal size. You can also specify that you want to print your 
work on a certain number of pages.

What do you want to do?

            Reduce or enlarge a worksheet to fit the page  

            Print a worksheet on a specified number of pages  



Reduce or enlarge a worksheet to fit the page

1 Click the worksheet.

2 On the File menu, click Page Setup, and then click the Page tab.

3 In the Adjust to box, enter the percentage by which you want to reduce or enlarge the worksheet.



Print a worksheet on a specified number of pages

1 Click the worksheet.

2 On the File menu, click Page Setup, and then click the Page tab.

3 Click Fit to.

4 Enter the number of pages on which you want to print the work.

Printed data will not exceed the specified number of pages. Microsoft Excel will not enlarge the data to fill the 
pages.

Note      Microsoft Excel ignores manual page breaks when you fit the worksheets on a specified number of 
pages.



Change the layout of the printed worksheet

You can control the appearance, or layout, of printed worksheets by changing options in the Page Setup dialog 
box. A worksheet can be printed in portrait or landscape orientation, and you can use different sizes of paper. 
Worksheet data can be centered between the left and right margins and the top and bottom margins. You can 
change the order of the printed pages, as well as the starting page number.

What do you want to do?

            Change the page orientation  

            Set the size of the paper  

            Center worksheet data on the printed page  

            Set the printing order of pages  

            Change the page number for the first page  



Center worksheet data on the printed page

1 Click the worksheet.

2 On the File menu, click Page Setup, and then click the Margins tab.

3 To center worksheet data horizontally on the page between the left and right margins, select the Horizontally 
check box.

To center worksheet data vertically on the page between the top and bottom margins, select the Vertically 
check box.



Change the page orientation

1 Click the worksheet.

2 On the File menu, click Page Setup, and then click the Page tab.

3 Click Portrait or Landscape.



Set the size of the paper

1 Click the worksheet.

2 On the File menu, click Page Setup, and then click the Page tab.

3 In the Paper size box, click the size of paper you want.



Change the page number for the first page

1 Click the worksheet.

2 On the File menu, click Page Setup, and then click the Page tab.

3 In the First page number box, type the page number you want to appear on the first page of the worksheet.

To have Microsoft Excel automatically number the pages of the worksheet, enter the word Auto in the First 
page number box.



Set the printing order of pages

1 Click the worksheet.

2 On the File menu, click Page Setup, and then click the Sheet tab.

3 Click Down, then over or Over, then down.



Remove a print area

· On the File menu, click Clear Print Area.



Print row and column headings on every page

Row and column headings describe the location of information on the worksheet. Row headings are the row 
numbers to the left of the worksheet; column headings are the letters or numbers that appear at the top of the 
columns on a worksheet.

1 Click the worksheet.

2 On the File menu, click Page Setup, and then click the Sheet tab.

3 Select the Row and column headings check box.



Print the active sheets, a selected range, or an entire workbook

If the worksheet has a defined print area, Microsoft Excel will print only the print area. If you select a range of 
cells to print and then click Selection, Microsoft Excel prints the selection and ignores any print area defined for 
the worksheet.

1 On the File menu, click Print.

2 Under Print what, select the option you want.

Tip      If you want to print more than one sheet at the same time, select the sheets before you print. For more 
information about selecting multiple sheets, click    .



About the Print Preview window

Before you print a worksheet, click Print Preview on the File menu to see how the sheet will look when you print 
it. The status bar at the bottom of the screen shows the current page number and the total number of pages in 
the selected sheet.

· To preview a specific range of pages, click Print. Under Print range, click Page(s), specify the pages to print 
in the From and To boxes, and then click Preview.

· The way pages appear in the preview window depends upon the available fonts, the resolution of the printer, 
and the available colors.

· If a worksheet contains an embedded chart, print preview displays both the worksheet and the chart. You can 
move or resize the chart in normal view. If you select an embedded chart before you click Print Preview on 
the File menu, Microsoft Excel displays only the embedded chart.

Next
Click Next to display the next page of the sheet.

Previous
Click Previous to display the previous page of the sheet.

Zoom
Click Zoom to switch between a full-page view of a sheet and a magnified view. The Zoom feature does not 
affect printing size. You can also switch between a full-page view and a magnified view of a sheet by clicking any 
area of the sheet.

Print
Click Print to set printing options and then print the selected sheet.

Setup
Click Setup to set options that control the appearance of printed sheets.

Margins
Click Margins to display or hide margin handles that you can drag to adjust page margins, header and footer 
margins, and column widths.

Close
Click Close to close the print preview window and return to the previous view of    the active sheet.



Find text or numbers

1 Select the range of cells you want to search.

To search the entire sheet, click any cell.

2 On the Edit menu, click Find.

3 In the Find what box, enter the text or numbers you want to search for.

4 In the Look in box, click the type of information you want to search for.

5 Click Find Next.

Note      To cancel a search in progress, press ESC.



Change column width

· Drag the boundary on the right side of the column heading until the column is the width you want.

The displayed column width is the average number of digits 0-9 of the standard font that fit in a cell.

Tips

· To change the column width for multiple columns, select the columns you want to change. Then drag the right 
boundary of any selected column heading. To change the column width for all columns on the worksheet, click 
the Select All   button,   and then drag the right boundary of any column heading.

· To make the column width fit the contents, double-click the right boundary of the column heading.



Change row height

· Drag the bottom boundary of the row heading until the row is the height you want.

Tips

· To change the row height for multiple rows, select the rows you want to change. Then drag the bottom 
boundary of any selected row heading. To change the row height for all rows on the worksheet, click the 
Select All   button,   and then drag the bottom boundary of any row heading.

· To make the row height fit the contents, double-click the bottom boundary of the row heading.



Open a workbook

1 On the File menu, click Open.

2 In the Look in box, click the drive, folder, network, or Internet location that contains the workbook. 

3 In the folder list, double-click folders until you open the folder that contains the workbook you want.

If you can’t find the workbook in the folder list, you can search for it.

4 Double-click the workbook you want to open.

Note      Microsoft Excel Viewer can open only Microsoft Excel (.xls) files.

Tip      To open a file you’ve used recently, click the file name at the bottom of the File menu.



Display a subset of rows in a list by using AutoFilter

You can apply filters to only one list on a worksheet at a time.

1 Click a cell in the list you want to filter.

2 On the View menu, click AutoFilter.

3 To display only the rows that contain a specific value, click the arrow in the column that contains the data you 
want to display.

4 Click the value.

5 To apply an additional condition based on a value in another column, repeat steps 3 and 4 in the other 
column.

Note      When you apply a filter to a column, the only filters available for other columns are the values visible in 
the filtered list.



Move and scroll through a worksheet

To move between cells on a worksheet, click any cell or use the arrow keys. When you move to a cell, it 
becomes the active cell. To see a different area of the sheet, use the scroll bars.

To scroll Do this

One row up or down Click the arrows in the vertical scroll bar.

One column left or 
right

Click the arrows in the horizontal scroll 
bar.

One window up or 
down

Click above or below the scroll box in the 
vertical scroll bar.

One window left or 
right

Click to the left or right of the scroll box in 
the horizontal scroll bar.

A large distance Drag the scroll box to the approximate 
relative position. In a very large 
worksheet, hold down SHIFT while 
dragging.

Tip      The size of a scroll box indicates the proportional amount of the used area of the sheet that is visible in the 
window. The position of a scroll box indicates the relative location of the visible area within the worksheet.



Select cells, ranges, rows, and columns

To select Do this

A single cell Click the cell, or press the arrow keys to 
move
to the cell.

A range of cells Click the first cell of the range, and then 
drag
to the last cell.

All cells on a 
worksheet

Click the Select All   button.  

Nonadjacent cells
or cell ranges

Select the first cell or range of cells, and 
then hold down CTRL and select the other 
cells or ranges.

A large range of 
cells

Click the first cell in the range, and then 
hold down SHIFT and click the last cell in 
the range. You can scroll to make the last 
cell visible.

An entire row Click the row heading.

An entire column Click the column heading.

Adjacent rows or 
columns

Drag across the row or column headings. 
Or select the first row or column; then hold 
down SHIFT and select the last row or 
column.

Nonadjacent rows 
or columns

Select the first row or column, and then 
hold down CTRL and select the other rows 
or columns.

More or fewer cells
than the active 
selection

Hold down SHIFT and click the last cell you 
want to include in the new selection. The 
rectangular range between the active cell 
and
the cell you click becomes the new 
selection.



Select sheets in a workbook

If you select more than one sheet, Microsoft Excel repeats the changes you make to the active sheet on all other 
selected sheets. These changes may replace data on other sheets.

To select Do this

A single sheet Click the sheet tab.

Two or more adjacent
sheets

Click the tab for the first sheet, and 
then hold down SHIFT and click the 
tab for the last sheet.

Two or more
nonadjacent sheets

Click the tab for the first sheet, and 
then hold down CTRL and click the 
tabs for the other sheets.



Switch to another sheet in a workbook

· Click the sheet tab for the other sheet.

If you don't see the tab you want, click the tab scrolling buttons to display the tab. Then click the tab.



Cancel a selection of cells

· To cancel a selection of cells, click any cell on the worksheet.



Magnify or reduce the display

· On the View menu, click Zoom. Click the size you want, or enter a number from 10 to 400 in the Custom box.

To enlarge the selected area to fill the window, click Selection.

Note      Changing the magnification does not affect printing. Sheets are printed at 100 percent unless you 
change the scaling on the Page tab of the Page Setup dialog box (File menu).



View different parts of a worksheet at the same time

To view and scroll independently in different parts of a worksheet, you can split a worksheet horizontally and 
vertically into separate panes.

To keep row and column labels or other data visible as you scroll through a sheet, you can "freeze" the top and 
left panes. Data in the frozen panes doesn't scroll and remains visible as you move through the rest of the 
worksheet.

What do you want to do?

            View two parts of a sheet at the same time  

            Keep row and column labels visible as you scroll  

Note      Split or frozen panes do not show when the sheet is printed. To repeat row or column titles on each page 
of a printed worksheet, click Page Setup on the File menu, and then click the Sheet tab. Click in the Rows to 
repeat at top or Columns to repeat at left box, and then select the rows or columns on the worksheet that you 
want to use for the print titles.



View two parts of a sheet at the same time

1 At the top of the vertical scroll bar or at the right end of the horizontal scroll bar, point to the split box.

Note      The split box is not visible if the worksheet contains frozen panes.

2 When the pointer changes to a split pointer    , drag the split box down or to the left to the position you want.

Note      To remove the split, double-click the split bar.



Keep row and column labels visible as you scroll

1 To freeze the top horizontal pane, select the row below where you want the split to appear.

To freeze the left vertical pane, select the column to the right of where you want the split to appear.

To freeze both the upper and left panes, click the cell below and to the right of where you want the split to 
appear.

2 On the Window menu, click Freeze Panes.

Note      To remove the split, click Freeze Panes again on the Window menu.



Connect to Microsoft technical resources

Microsoft provides several no-charge options for you to obtain more technical information about Microsoft Excel 
Viewer. Because Microsoft Excel Viewer is similar to Microsoft Excel, information about a particular topic, such as 
printing from Microsoft Excel, might also be pertinent to Microsoft Excel Viewer. Keep this in mind when looking 
for technical information.

If you don't find the technical assistance you need in online Help, you can get information from several Microsoft 
technical resources on the World Wide Web, including the following:

· Connect to the Microsoft home page.

· Use the Microsoft Knowledge Base (KB), a collection of up-to-date articles that contains detailed how-to 
information, answers to technical-support questions, and known issues.

· Use the Microsoft Software Library (MSL), a collection of free binary (nontext) files, such as device drivers, 
utilities, Help files, and technical articles for all Microsoft products.

If you don’t have access to the Web, you can get information from the following resources:

· Subscribe to the Microsoft TechNet CD-ROM or the Microsoft Developer Network CD-ROM to gain access to 
the KB, MSL, and other technical information.

· Order Microsoft Press books, resource kits, and interactive training materials to train and support yourself and 
others who use Microsoft Office.

· If you have a computer with a modem and a communications software program, use the Microsoft Download 
Service (MSDL) to obtain device drivers, patches, and software updates.

· Order Application Notes and popular articles from the KB by fax by using the toll-free FastTips service.

Where do you want to go for technical information?

            The Microsoft Knowledge Base (KB)  

            Microsoft Software Library (MSL)   

            Microsoft TechNet and Microsoft Developer Network CD-ROMs  

            Microsoft Press  

            Microsoft Download Service (MSDL)  

            FastTips  



The Microsoft Knowledge Base (KB)

The Microsoft Knowledge Base (KB) is the primary source of product information for Microsoft support engineers 
and customers. This comprehensive collection of articles ¾ updated daily ¾ contains detailed how-to information, 
answers to technical-support questions, information about known issues, and ways Microsoft has addressed 
those issues. Use text and keyword queries to find information in the KB.

If you have access to the World Wide Web, click        to go to the Microsoft Knowledge Base. This site provides 
full-text searches and automatic hyperlinks to files in the Microsoft Software Library (MSL). For more information 
on the MSL, click 

.

The KB is also available on the Microsoft TechNet and the Microsoft Developer Network CD-ROMs. For more 
information, click    .

If you have an FTP program service provider, the Microsoft FTP anonymous server provides access to the Microsoft 
Knowledge Base. For more information, click    .



Microsoft Software Library (MSL)

The Microsoft Software Library (MSL) is a collection of free, binary (nontext) files located on the Internet for all 
Microsoft products. For example, the MSL contains device drivers, utilities, Help files, and technical articles.

If you have access to the World Wide Web, click        to go to the Microsoft Software Library.

The MSL is also available on the Microsoft TechNet and the Microsoft Developer Network CD-ROMs. For more 
information, click    .



Microsoft TechNet and Microsoft Developer Network CD-ROMs

Microsoft TechNet is the comprehensive information resource for evaluating, implementing, and supporting 
Microsoft business products. A TechNet subscription delivers the knowledge of Microsoft's entire product support 
division directly to you every month on CD-ROM. TechNet provides fast, in-depth answers to questions about 
programs, network management, system implementation, database administration, drivers and patches, 
technology directions, and product evaluation. More than 150,000 pages of detailed, technical information help 
you get more done in less time. In the United States and Canada, call (800) 344-2121 to subscribe to Microsoft 
TechNet.

The Microsoft Developer Network (MSDN) Library is the comprehensive source of programming information and 
toolkits for those who write programs for the Microsoft Windows, Windows 95, and Windows NT operating 
systems and for those who use Microsoft products for development purposes. MSDN subscribers are kept up-to-
date through regular deliveries of information, a newsletter, and other information sources. In the United States 
and Canada, call (800) 759-5474 to subscribe to the Microsoft Developer Network.

Both numbers are toll-free in the United States and Canada. Outside the United States and Canada, contact your 
local Microsoft subsidiary for information.



Microsoft Press

Microsoft Press has the training and support products you need to help you get more from Microsoft Office, 
Microsoft Windows 95, and Microsoft Windows NT.

Whether you're a beginning user, an advanced user, a support professional, or a software developer, Microsoft 
Press has what you're looking for ¾ from quick-and-easy handbooks and self-paced training guides to desktop 
references, technical resources, and programming titles.

To locate your nearest source for Microsoft Press products worldwide, visit the Microsoft Press Web site, or 
contact your local Microsoft office. In the United States, call (800) MS-PRESS. In Canada, call (800) 667-1115.



Microsoft Download Service (MSDL)

The Microsoft Download Service (MSDL) contains sample programs, device drivers, patches, software updates, 
and programming aids. Direct modem access to MSDL is available by calling (206) 936-6735 in the United States 
or (905) 507-3022 in Canada. The service is available 24 hours a day, 365 days a year. Connect information: 
1200, 2400, 9600, or 14,400 baud, no parity, 8 data bits, and 1 stop bit. Outside the United States and Canada, 
contact your local Microsoft subsidiary for information.



FastTips

Microsoft FastTips is an automated, toll-free service that provides quick answers to your common technical 
questions 24 hours a day, seven days a week when you call (800) 936-4100 from a touch-tone telephone in the 
United States. Using the buttons on your telephone, you can follow the prompts to hear recorded answers to your 
technical questions, to obtain a catalog of available information, and to order items by fax. For example, you can 
order Application Notes and popular articles from the Microsoft Knowledge Base by fax through the FastTips 
service. Outside the United States, contact your local Microsoft subsidiary for information.



pane

Used to view different areas of a large worksheet at the same time. You can split a window into two panes either 
horizontally or vertically. If you split the window both vertically and horizontally, you can display four panes.



range

Two or more cells on a sheet. The cells in a range can be adjacent or nonadjacent.



select

To highlight a cell or range of cells on a worksheet. The selected cells will be affected by the next command or 
action.



list

A series of worksheet rows that contain related data, such as an invoice database or a set of client names and 
phone numbers. A list can be used as a database, in which rows are records and columns are fields. The first 
row of the list has labels for the columns.



copy area

The cells you copy when you want to paste data into another location. After you copy cells, a moving border 
appears around them to indicate that they've been copied.

When you copy cells, references to the original cells aren't affected. Microsoft Excel adjusts relative references of 
formulas that are pasted into a new location.



active cell

The selected cell in which data is entered when you begin typing. Only one cell is active at a time. The active cell 
is bounded by a heavy border.



print area

One or more ranges of cells you can print when you don't want to print an entire worksheet. If a worksheet 
includes a print area, only the print area will be printed. You create a print area by using the Set Print Area 
command (File menu).



Internet

A worldwide network of thousands of smaller computer networks and millions of commercial, educational, 
government, and personal computers. The Internet is like an electronic city with virtual libraries, storefronts, 
business offices, art galleries, and so on.



Uniform Resource Locator (URL)

An address to a specific Internet resource, such as a World Wide Web page or an FTP site. A URL expresses the 
type of resource (such as FTP or HTTP) to be located, the specific site where the information is stored, and 
where the information is located on the site. The first part of a URL identifies the server type or transfer protocol, 
followed by a colon and double forward slashes. For example, http://example.microsoft.com/.



scroll bar

The shaded bars along the right side and bottom of a window. To scroll to another part of the file, drag the box or 
click the arrows in the scroll bar.



Select All button

The gray rectangle in the upper-left corner of a worksheet where the row and column headings meet.

Click        to select all cells on a worksheet.



row heading

The numbered gray area to the left of each row. Click the row heading to select an entire row. To increase or 
decrease the height of a row, drag the line below the row heading.



column heading

The lettered or numbered gray area at the top of each column. Click the column heading to select an entire 
column. To increase or decrease the width of a column, drag the line to the right of the column heading. If you 
are using R1C1 reference style, your column headings will have numbers instead of letters.



tab scrolling buttons

The arrow buttons to the left of the sheet tabs. To scroll between sheet tabs, click an arrow for the direction you 
want to scroll; to select a sheet, click its tab. To scroll several tabs at a time, press SHIFT while you click one of 
the middle tab scrolling buttons. To display a menu of sheets in the workbook, click a tab scrolling button with the 
right mouse button.



sheet tab

A tab near the bottom of a workbook window that displays the name of a sheet. Click the sheet tab to make a 
sheet active. To scroll through the sheet tabs, use the tab scrolling buttons to the left of the tabs.



Application Note

A technical article, written and distributed by Microsoft, that provides additional information about a Microsoft 
product or a fix for a known issue. An Application Note may include a disk that contains new software, 
documentation, sample files, device drivers, utilities, templates, or macros.



hyperlink

Colored and underlined text or a graphic that you click to go to a file, a location in a file, an HTML page on the 
World Wide Web, or an HTML page on an intranet. Hyperlinks can also go to Gopher, telnet, newsgroup, and 
FTP sites.



World Wide Web

The World Wide Web is a system for exploring the Internet by using hyperlinks. When you use a Web browser, 
the Web appears as a collection of text, pictures, sounds, and digital movies.



outline symbols

Symbols you use to change the view of an outlined worksheet. You can show or hide detailed data by using the    
, 

, and 

    outline symbols. To show or hide the symbols, click Options on the Tools menu, click the View tab, and then 
select or clear the Outline symbols check box.



Copy cell data

When you copy a cell by dragging or by clicking Copy on the Edit menu, Microsoft Excel Viewer copies the 
entire cell, including formulas and their resulting values, comments, and cell formats. In Microsoft Excel Viewer, 
you can copy cell data from a workbook and paste it into another document in another program, but you cannot 
paste cell data into a workbook that is open in Microsoft Excel Viewer. This is because you cannot save a file in 
Microsoft Excel Viewer (to save or edit a workbook, you need Microsoft Excel).

Note      If the selected copy area includes hidden cells, Microsoft Excel Viewer also copies the hidden cells.



About Microsoft Excel Viewer 97

Microsoft Excel Viewer 97 is a small, no-charge, freely distributable program you can use to share Microsoft 
Excel files with other people ¾ even if they don't have Microsoft Excel. You can use Microsoft Excel Viewer to 
open, view, filter by using AutoFilter, and print Microsoft Excel files. Microsoft encourages you to copy and 
distribute Microsoft Excel Viewer along with your Microsoft Excel workbooks.

You cannot edit or save an open workbook in Microsoft Excel Viewer. Similarly, you can't create new workbooks 
in Microsoft Excel Viewer ¾ you'll need Microsoft Excel to do these things. For more information about ordering 
Microsoft Excel, click    .

What can Microsoft Excel Viewer 97 do?

View Microsoft Excel files      Microsoft Excel Viewer can open files from Microsoft Excel for Windows 
(versions 2.0 and later) and Microsoft Excel for the Macintosh (versions 2.2a and later). Microsoft Excel 
Viewer cannot open HTML files, but if you click a hyperlink in an open workbook, Microsoft Excel Viewer starts 
your Internet browser and follows the hyperlink.

View templates, macros, and charts      You can view Microsoft Excel templates, charts (.xlc files), and 
macros. However, you can't run macros or create new files based on the templates.

Copy      You can copy from Microsoft Excel Viewer into other programs, but you can't paste into an open 
workbook in Microsoft Excel Viewer. Microsoft Excel Viewer copies charts or drawing objects as pictures. To 
paste these pictures into another program, use the Paste Special command (Edit menu).

Print      You can print from Microsoft Excel Viewer using your computer's Windows or Windows NT printer 
setup.

Explore hyperlinks      If you have an Internet browser installed, you can follow hyperlinks when you click 
them in Microsoft Excel Viewer.

View comments      If your worksheet contains comments, you can view them by resting your mouse pointer 
over them. If a cell contains a comment, you'll see a small red triangle in the upper-right corner of the cell.

PivotTables      You can view PivotTables, although you can't pivot or recalculate the table.

Multiuser workbooks      You can view multiuser workbooks. You can't track changes or view the history 
sheet.

Microsoft IntelliMouse support      If you have the new Microsoft IntelliMouse pointing device, Microsoft 
Excel Viewer supports its scrolling and zooming capabilities.



Obtaining Microsoft Excel Viewer 97

By mail      To order Microsoft Excel Viewer 97 by mail, call the Microsoft Order Desk at (800) 360-7561. The part 
number    is 643-00001 (U.S. version). The Viewer is free, but there is a nominal shipping and handling charge for 
the product. If you are outside the United States, contact the Microsoft subsidiary for your area. To locate your 
subsidiary, call Microsoft International Customer Service at (206) 936-8661. 

From the World Wide Web      To download the Microsoft Excel Viewer 97 from the Web, connect to the 
Microsoft Excel home page, http://www.microsoft.com/excel,.



Distributing Microsoft Excel Viewer 97 with your workbooks

Microsoft encourages you to copy and distribute Microsoft Excel Viewer to friends and co-workers, or post it on 
public electronic bulletin boards, LANs, and Internet sites ¾ anywhere you share Microsoft Excel files with others 
who don't have Microsoft Excel. If you would like to add a reference to Microsoft Excel Viewer at a World Wide 
Web site, please add a hyperlink to http://www.microsoft.com/excel/internet/viewer/. This Microsoft site always 
has the latest version of Microsoft Excel Viewer, along with up-to-date information about it.

Worksheet design considerations

When you prepare a workbook that will be opened in Microsoft Excel Viewer, make sure the workbook is in the 
correct view before you save and close it in Microsoft Excel. For example, refresh and sort the data, update any 
links, make sure charts are displayed correctly, and, in a PivotTable, select the page field items you want to 
display. In Microsoft Excel Viewer, you'll be able to filter a list using AutoFilter and adjust column and row widths, 
but you won't be able to otherwise manipulate the data ¾ you'll need Microsoft Excel to do these things.



Ordering Microsoft Excel

Microsoft Excel Viewer 97 is just that ¾ a viewer. You can view Microsoft Excel workbooks, but you can't create 
new workbooks or edit and save an open workbook in Microsoft Excel Viewer ¾ you'll need Microsoft Excel to do 
these things.

For information on what Microsoft Excel 97 can do for you, see http://www.microsoft.com/excel. For pre-sales 
information in the U.S., contact the Microsoft Sales Information Center at (800) 426-9400. For pre-sales 
information outside the United States, contact the Microsoft subsidiary for your area. To locate your subsidiary, 
call the Microsoft International Sales Information Center at (206) 936-8661. To purchase Microsoft Excel, please 
contact your local reseller.



Installing Microsoft Excel Viewer

For system requirements and installation instructions, see the accompanying file Readme.txt.

For a list of Microsoft Excel Viewer installed file names and locations, click    .



Reinstalling Microsoft Excel Viewer

If you have installed Microsoft Excel Viewer but are observing unusual behavior, you should use Microsoft Excel 
Viewer Setup program to reinstall.

For installation instructions, see the accompanying file Readme.txt. Once Microsoft Excel Viewer Setup starts in 
maintenance mode, click the Reinstall button to restore any missing files or settings.



Removing Microsoft Excel Viewer

1 Quit all programs.

2 Click the Windows Start button, point to Settings, and then click Control Panel.

3 Double-click the Add/Remove Programs icon    .

4 Click Microsoft Excel Viewer on the Install/Uninstall tab, and then click Add/Remove.
5 Click Remove All once the Microsoft Excel Viewer Setup program has launched in maintenance mode.

6 Follow the instructions on the screen.

Note      You may have to restart your computer when the removal process is done.



Microsoft Excel Viewer installed file names and locations

The files installed in the Microsoft Excel Viewer 97 folder are (by default, this folder is C:\Program Files\XLView):

Excel8.srg

License.txt

MSO97v.dll

Msv7enu.dll

Readme.txt

Selfreg.dll

Settings.srg

XL8409.dll

XLintl32.dll

XLview.cnt

XLview.exe

XLview.hlp

The files installed in the Windows System folder are (by default, the Windows 95 folder is C:\Windows\System; 
the Windows NT folder is C:\WinNT\System32):

Docobj.dll

Hlink.dll

Hlinkprx.dll

Msorfs.dll

Urlmon.dll

Wininet.dll



Open a workbook for editing

If Microsoft Excel is installed on your computer, the File menu in Microsoft Excel Viewer also contains the Open 
File for Editing command. This command starts Microsoft Excel and opens the file that is currently active in 
Microsoft Excel Viewer.



Microsoft FTP anonymous server

Use the following procedure to go to the Microsoft Knowledge Base on the Microsoft FTP anonymous server.

1 Log on to your Internet account.

2 At the Internet FTP prompt, type

open ftp.microsoft.com

or use the following IP address:

open 198.105.232.1

3 When prompted for a user name, type

anonymous

4 When asked for a password, type your full e-mail address. For example:

johndoe@test.com

5 Type cd kb to go to the KB subdirectory.

6 Once you are in the KB directory, download the Readme.txt and Index.txt files located in that directory. 
Readme.txt contains important information regarding Knowledge Base articles on the Internet FTP server and 
how to locate them. Index.txt contains a list of article titles and article IDs for each article.








