
Welcome to Quick View Plus
Quick View Plus gives you easy access to files created in over 225 programs, regardless of whether you have those programs 
on your computer.    With Quick View Plus you can work effortlessly with files or parts of files created in the format of text, 
spreadsheets, databases, presentations, and graphics.    Here are some of the key features you will find in Quick View Plus:

View virtually any file

Quick View Plus allows you to overcome the viewing restrictions created by different platforms, formats, and software versions.    
You are instantly enabled to see and work with fully-formatted views of more than 225 Windows, DOS, Macintosh, and Internet 
formats including text, spreadsheet, graphic, database, presentation, and compressed files including PKZIPä, as well as HTML 
and UUE.

Print files

Quick View Plus provides you with the fastest way to view and print all or part of one or multiple files, or you may quickly print 
files without even viewing them.

Copy and paste viewed files

After viewing a file, you can copy all or a portion of any file, or select text for copying, then paste the selection into an application.

Quick Compress

With files in your file system, Quick View Plus allows you to create new ZIP files of that file, or add a viewed file to existing ZIP 
archive files that can be read by other ZIP-related products (PKZIPä, WinZipâ, and Zip Magicâ, just to name a few). This 
feature of Quick View Plus is available from the context menu in Windows Explorer, the Quick View Plus file navigation pane, or 
any application that supports the Explorer context menu.    You can also delete individual files from existing ZIP archive files.

AutoZip e-mail attachments

When you attach files to e-mail messages, Quick View Plus will automatically compress attached files when sent or saved in 
Microsoft Exchange, Outlook, and Lotus Notes clients.    Before e-mail attachments are compressed, you can specify the 
minimum size of attachments to be automatically compressed.

Search for text

By simply using the Find command on the Quick View Plus toolbar, you can utilize a fast, powerful text search function in any 
viewed file containing text, including word processing, spreadsheet, presentation, Internet, and executable file formats.    All text 
search matches are highlighted.

Zoom and rotate

You can zoom in or out on viewed files which will enlarge or reduce the font (for word processing, spreadsheet, database, or 
archive files), or enlarge or reduce the entire viewed file (for bitmap, drawing, and presentation files).    You may also rotate 
bitmap files in 90° increments.

System-to-system information sharing

With Quick View Plus, you can transfer data between Windows, Macintosh, and DOS word processing and presentation 
programs.

View embedded objects

Embedded objects created through object linking and embedded (OLE) can be quickly and easily viewed in Quick View Plus

Start a viewed file’s application

With a simple click of the launch application toolbar button, you can launch the application used to create the file you are 
viewing, with the file open and ready for editing in the application, even if that file does not have the correct file extension for it’s 
type.

File Navigation Panes

The Quick View Plus viewing environment provides you with two-pane navigation, allowing you to quickly navigate through your 
file system and use the same Quick View Plus window to view any files you choose.    The file navigation panes can be oriented in 
either a left-hand or top-attachment manner within a Quick View Plus session.

Browse previously-viewed files

With the left and right arrow buttons on the Quick View Plus toolbar, you can quickly browse forward and back the files you have 
previously viewed in the same Quick View Plus view window.

Netscape plug-ins

Quick View Plus can use Netscape plug-ins to view certain file types within the Quick View Plus view window.

Integration

Quick View Plus integrates with the latest browser and e-mail applications, and can host multimedia plug-ins, allowing you to 
seamlessly view within these programs file formats that they do not support.

You can do all this with files already on your computer or with files downloaded, received, or copied from these sources:



· Internet

· E-mail

· Networks

Quick View Plus integrates seamlessly into Windows 2000, Windows 98, Windows 95, Windows NT 4.x, numerous Windows 
programs, and the most popular World Wide Web browsers and email programs, so it's always there when you need it.

Quick View Plus enhances the Quick View feature in Windows 98, Windows 95, and Windows NT 4.x giving you 225 file types 
for viewing, copying and printing.



System Requirements

Quick View Plus works on any system running Windows 2000, Windows 98, Windows 95, or Windows NT 4.x.    A minimum 
installation requires approximately 16MB of disk space; a full installation requires approximately 17MB of disk space.



Installing Quick View Plus

You can install Quick View Plus with the options users most commonly use, with the minimum required options, or customize 
Quick View Plus by choosing only the options you want to install.

Note: To install Quick View Plus on a computer running Windows NT, you must have administrator rights for that computer.

To install Quick View Plus

1. Insert your Quick View Plus CD into your CD-ROM drive. Quick View Plus offers you the choice of installing Quick View 
Plus, browsing this CD, or exiting the installation.

2. Click on the Install icon.

3. Follow the instructions on your screen.

Note: If you don’t have Acrobat Reader installed on your computer, the Quick View Plus installation program displays a 
screen that asks if you want to install it.    If you choose to install Acrobat Reader, the Acrobat Reader installation 
program starts after the Quick View Plus installation finishes.

To install Quick View Plus on a network
Ø Refer to the Quick View Plus Administrator Notes (included on your Network CD).

To uninstall Quick View Plus

1. Click the Start button. 

2. Point to Programs, point to Quick View Plus, and then click on Uninstall Quick View Plus.

3. Follow the instructions on your screen.

OR 

1. Click the Start button.

2. Point to Settings, and then click Control Panel.

3. Double-click Add/Remove Programs.

4. In the Add/Remove Programs dialog box, click the Install/Uninstall tab.

5. In the Remove window, click Quick View Plus and then click the Add/Remove button.

6. Follow the instructions on your screen.



Getting help

If you need help installing or using Quick View Plus, you can access help or contact information directly through the Quick View 
Plus online help system.

To view online help
Ø On the Quick View Plus menu bar, click Help then select Help Topics to view all online help topics.

To view contact information
Ø On the Quick View Plus menu bar, click Help then select Quick View Plus on the Web.

Contacting Jasc Software
If you need help installing or using Quick View Plus, contact Jasc Software at the location listed below.

For additional information, open the README file in the Quick View Plus Program Menu; also, check out Inso Corporation’s 
FAQs and technical bulletins at www.inso.com.

Jasc Software, 
Inc.
Phone: (952) 930-9171

Fax: (952) 930-9172

Internet: qvpsup@jasc.com

World Wide Web: www.jasc.com

Mail: Jasc Software, Inc.

7905 Fuller Road

Eden Prairie, MN 55344-0997



User's Guide conventions

Within this User's Guide, there are many instructions, specific terms, and references to items within the Quick View Plus program 
that can help you use Quick View Plus in an effective manner. The guide's conventions below are intended to help you find and 
use the information with ease.

· Menu names, buttons, and options are in printed in bold typeface.

· Dialog box names begin with uppercase letters, and are in bold typeface.

· Notes, tips, and accessory information are bordered top and bottom by a line.

The online help system for Quick View Plus allows you to access help as you do with any Windows program through:

· A list of task-oriented and reference topics

· A list of search keywords

· Full-text index of every word in every Quick View Plus online help topic



Starting from the Program menu

To start Quick View Plus from the Program menu

1. Click the Start button, point to Programs, point to Quick View Plus, click on View a File.

2. Using the Quick View Plus file navigation pane, navigate to the Quick View Plus Samples directory (the default location 
is C:\Program files\Quick View Plus\Samples, however if you have installed Quick View Plus in a different location, 
please navigate to the Samples directory in that location).

3. The contents of the Samples directory are listed below or to the right of the Folder Tree pane (depending on which of the 
file navigation options have been chosen – a left-hand or top-attachment orientation).    Click once on Mgfxdrw.drw to 
view this sample file.

Tip: You need only to click once on files in the Quick View Plus file navigation pane to view them in the view window.    
Clicking twice on files will initiate their default editing or viewing application, if it is available on your computer.



Starting from Windows Explorer

To launch a view window from Windows Explorer

1. Click the Start button, point to Programs, and click Windows Explorer.

2. In the left side of the Exploring window, navigate to the location where you installed Quick View Plus (the default 
location is C:\Program files\Quick View Plus), and expand the Quick View Plus folder to display its contents.

3. Click the Samples folder to display its contents in the right pane of the Exploring window.

4. Right-click on the Mgfxdraw.drw file to view the Quick View Plus context menu.

 

5. On the context menu, click Quick View Plus.



Selecting additional files to view in the view window

Once you’ve opened a view window, you can display files (and objects embedded in them) in rapid succession by simply 
cursoring through the file list in the Folder Contents pane with the Up and Down arrows on your keyboard.    This section uses as 
examples a spreadsheet file, an archive file, and a word-processing file with an embedded object to show you how to do this.

To view a spreadsheet file
Ø In the Folder Contents pane where the file name of a currently-viewed file is highlighted, use your Up or Down arrow 

key on your keyboard to highlight the spreadsheet file.

The view window displays the spreadsheet file in place of the file previously displayed. Because this is a spreadsheet 
file, the menu to the right of the View menu changes to Spreadsheet.

To view an archive file

1. In the Folder Contents pane where the file name of a currently-viewed file is highlighted, use your Up or Down arrow 
key on your keyboard to highlight your archive file (zip file).

The view window displays a tree-like representation of the archive’s directory structure with a list of the files in it. The 
menu to the right of the View menu changes to Archive.

2. If you want to view the contents of a file in the archive, click the filename and that file will appear in a view window frame 
below the archive directory structure.

3. If you want to extract (decompress) one or more files from the archive, either:

a) Select one or more files in the view window and then, on the Archive menu, click Extract This File, Extract 
Selected Files, or Extract All Files. In the Choose Destination for Extracted File(s) dialog box, enter the path to 
where you want to save the uncompressed file(s).

b) Select one or more files in the view window, then right click on a highlighted file name.    In the available menu, click 
Extract This File, Extract Selected Files, or Extract All Files. In the Choose Destination for Extracted File(s) 
dialog box, enter the path to where you want to save the uncompressed file(s).

To view a word processing file and separately save an object embedded in it

1. In the file navigation pane where the file name of a currently-viewed file is highlighted, use your Up or Down arrow key 
on your keyboard to highlight your word processing file.

The view window displays the word processing file in place of the file previously displayed. Because this is a word-
processing file, the menu to the right of the View menu changes to Document.

2. To view an object embedded in this file, double-click the graphic.

Quick View Plus displays the object in the Embedded Object window.

3. To save a copy of the embedded object, click Save Copy on the File menu, specify a folder and a name for the copy in 
the Save Copy dialog box, and click Save.

4. To close the Embedded Object window, click Close This View on the File menu.



Starting Quick View Plus using sample files

After installing Quick View Plus, you can open a view window from several places in Windows. If you integrated Quick View Plus 
into any programs or browsers during installation, you can also view documents from within these applications.

When you open a view window, Quick View Plus displays a file-type-specific menu with an appropriate name and appropriate 
options for the type of file; this menu is to the right of the View menu on the main menu bar. If you open a file of a different type 
in the same window, the menu and its options change accordingly.

This section describes how to start Quick View Plus from:

· Program menu 

· Windows Explorer 

· Desktop icon 

· Desktop Context menu 

· Taskbar 

· Find command 

· Windows programs 

· Browsers, E-mail programs, and Groupware 

This chapter also describes how to select additional files to view after viewing a file.



Starting from the desktop icon

To start from a desktop icon

1. Double-click the Quick View Plus icon  

2. In the Quick View Plus file navigation pane, navigate the Folder Tree to find the folder that contains your file.

3. Click once on the file name in the Folder Contents pane to display the file in the view window.



Starting from the desktop context menu

To start from the desktop context menu

1. On the Windows desktop, right-click the file you want to view.

2. On the context menu, click Quick View Plus.

3. Quick View Plus starts, and the selected file is displayed in the view window.



Starting from the Taskbar

After you start Quick View Plus during a Windows session, a 'notification icon' that looks like a magnifying glass appears on the 
taskbar in the lower right corner of your screen. From this icon, you can open a Windows File Open dialog box and use it to 
select a file for viewing.

Ø Do one of the following:

· Double-click the magnifying glass icon , then choose a file to view.

· Point to the magnifying glass icon, click the right mouse button, and click Open a file for viewing… on the menu, 
then choose a file to view.



Starting from the Find command

To start from the Find command

1. Do one of the following:

· Click the Start button, point to Find, then click Files or Folders.

· Right-click the My Computer icon and click Find on the context menu.

2. In the text box provided, specify what to search for and where.

3. Right-click the file you want to view.

4. On the context menu, click Quick View Plus.

Quick View Plus starts, and the selected file is displayed in the view window.



Starting from Windows programs

To start from a Windows program
You can start Quick View Plus and use it to preview files before opening them in any program that uses the Windows File Open 
dialog box.

1. On the File menu in the program, click Open.

2. Right-click the file you want to view.

3. On the context menu, click Quick View Plus.

A Quick View Plus session opens with the selected file in the view window.



Starting from e-mail programs and groupware
Quick View Plus can be integrated into e-mail programs and groupware, allowing you to easily view files from within these 
applications. You can integrate Quick View Plus during installation, or at a later time from within Quick View Plus. For 
instructions, see 'Configuring for applications'. Once Quick View Plus is integrated, you can use it to view and send e-mail 
attachments without having or starting the programs used to create them.

You can view attachments within the following e-mail programs and groupware with Quick View Plus:

Eudora 
Lotus cc:Mail 
Lotus Notes
Microsoft Exchange
Microsoft Outlook and Microsoft Outlook Express 

Eudora

To view attachments in Eudora
Ø Double-click the name of the attached file. Quick View Plus will start, and the selected attachment is displayed in the 

view window.

Note: The default setting for viewing attachments in Eudora is that Quick View Plus will only display files for which there 
is no registered application. However, Quick View Plus can be configured to display all files. To change to this setting, 
use the Options page of the Properties dialog in Eudora.

Lotus cc:Mail

To view attachments in Lotus cc:Mail

1. Right-click on the attachment you want to view.

2. Within the context menu, click Quick View Plus.

3. Quick View Plus will start, and the selected attachment is displayed in the view window.

Note: Quick View Plus for Windows 2000, 98, 95, and NT 4.x can only be integrated within cc:Mail for Windows 98, 95, 
and NT 4.x.

Lotus Notes
You can use Quick View Plus to enhance the attachment-viewing capability of Lotus Notes.    Quick View Plus integration with 
Lotus Notes (version 5 only) allows you to view files in a viewing environment that is similar to viewing files in Quick View Plus 
alone, with a Quick View Plus toolbar and menu options provided. (For information on commands available on the toolbar, see 
`Toolbar buttons'.)

For additional information on the attachment-viewing capability of Lotus Notes, see your Lotus Notes User's Guide.

Quick View Plus menus within Lotus Notes
When Quick View Plus is integrated into Lotus Notes and you are viewing an attachment, the Viewer menu item is replaced by a 
file-type-specific menu item; these menu items are Document, Spreadsheet, Database, Archive, Drawing, and Bitmap. When 
one of these menu items is selected, the drop-down submenu will have the same items available as the Quick View Plus context 
menu:

· The Toolbar menu item displays (checked) and hides (unchecked) the Quick View Plus toolbar directly above the view 
window (in Lotus R5 and later).

· The Font Size menu item contains a submenu that allows you to enlarge, reduce, or reset the size of the font used to display 
a file in normal or draft mode.

· The View and Size menu items are specific to the file type being viewed.

· The Options menu item displays property sheets for changing the Display, Print, and Copy options.

Microsoft Exchange

To view attachments in Microsoft Exchange

1. Right-click on the attachment you want to view.

2. On the context menu, click Quick View Plus.

Microsoft Outlook and Microsoft Outlook Express

To view attachments in Microsoft Outlook and Outlook Express



1. Right-click on the attachment you want to view.

2. On the context menu, click Quick View Plus.

Quick View Plus starts, and the selected attachment is displayed in the view window.

Note: By default, Quick View Plus opens or prints Outlook and Outlook Express file attachments only when the program 
that created them is not on your computer. However, to save time, you can choose to have Quick View Plus open or 
print all file attachments, even if the program that created them is on your computer. To change this setting, see 
'Configure Quick View Plus to work with other applications and plug-ins'.



Starting from World Wide Web browsers

To view a file in Netscape Navigator and Communicator, or in Microsoft Internet Explorer
Ø Within Netscape or Microsoft browsers, you can click on a link that represents a non-HTML file on a server.    If 

integrated with these browsers, Quick View Plus will then view the file within the browser window, along with a Quick 
View Plus toolbar and menu options. (For information on commands available on the toolbar, see `Toolbar buttons'.)    
After a file is displayed by Quick View Plus in a browser viewing window, you can right-click within the window to initiate 
a Quick View Plus context menu, and click the command you want to use.



Using with Netscape Navigator/Communicator and Microsoft Internet Explorer
Quick View Plus can be integrated into World Wide Web browsers, allowing you to easily view supported non-HTML files you 
may encounter on the Internet.    You can integrate Quick View Plus during installation, or at a later time from within Quick View 
Plus. For instructions on integration with browsers, see 'Configuring for plug-ins'. Once Quick View Plus is integrated, you can 
use it to view and send downloadable World Wide Web files without having or starting the programs used to create them.

Virtually all World Wide Web browsers allow outside programs to be used as 'Helper Applications' to open files that the browsers 
themselves can’t display. Quick View Plus can automatically install itself as a helper application to support the most popular Web 
browsers, including Netscape Navigator and Microsoft Internet Explorer.    When installed in this manner, Quick View Plus acts as 
the helper application for a number of common file types. When you click on a link to a file of a supported type within the 
browser, the file then displays in a Quick View Plus window.

If you want to set up Quick View Plus to view additional file types from within your browser, see `Configuring Quick View Plus 
with Netscape', or `Configuring Quick View Plus with Microsoft Internet Explorer'.



Configuring Quick View Plus with Netscape
To change the way Quick View Plus displays files within the Netscape browser, or to add or remove viewing support for specific 
file types, use the Options page of the Properties dialog for Netscape Navigator:

1. While viewing a file in Quick View Plus, click View on the menu bar, then Configure Quick View Plus….

2. In the Applications dialog, select Netscape Navigator then click Properties....

3. Click the Options tab to see the dialog that configures Quick View Plus’ integration with Netscape Navigator or 
Communicator

Note: Netscape Navigator cannot be running while you are trying to configure Quick View Plus with these applications.

The Options dialog consists of a two-column list of the file types viewed by Quick View Plus, and some controls that allow you to 
modify this list.

MIME type column
This list shows the MIME type for which Quick View Plus establishes itself as a plug-in.

Extensions column
The corresponding extensions are listed in the column to the right of the MIME types. Netscape uses these extensions to 
determine MIME type of a file when it is not provided by the server. For instance, when looking at an FTP site. MIME types are 
not included within the files, so Navigator uses these extensions to determine the MIME types of the files. More than one 
extension can be entered for a single MIME type. For instance, both the extensions tif and tiff are associated with the image/tiff 
MIME type, so files named picture.tif and picture.tiff would both be identified as image/tiff. Multiple extensions should be 
separated with commas like so "tif, tiff".

Viewing method
This section is enabled by highlighting one of the MIME types. The viewing method for the highlighted MIME type, Netscape 
Plug-in or Helper Application, can be changed by selecting the alternate radio button.

Add...
Pressing this button generates an Add MIME Type dialog, in which you can define a MIME type not included in the list 
established by Quick View Plus. The corresponding extension(s) can be entered in the File Name Extension(s) box. When 
entering extensions, do not use periods and remember to separate multiple extensions with commas.

Modify...
Pressing this button generates a Modify MIME Information dialog, in which the user can adjust the MIME type and/or subtype. 
This dialog also permits the user to add to or remove from the list of corresponding file name extensions.

Remove
Pressing this button deletes the highlighted MIME types without requesting confirmation from the user. Use of this button causes 
Navigator to return to its default behavior for the MIME type selected for deletion.



Configuring Quick View Plus with Internet Explorer
Like Netscape Navigator, Microsoft’s Internet Explorer allows outside programs to operate within the browser and display files. It 
does this through a mechanism called ActiveX.

ActiveX document viewing

Microsoft Internet Explorer supports the embedding of other applications within the Internet Explorer window. This is 
accomplished through Microsoft’s ActiveX Document specification. An ActiveX Document viewer such as Quick View 
Plus will merge with Internet Explorer’s window frame and menus for a truly seamless integration. When Quick View 
Plus is invoked within Internet Explorer, the Edit and View menus control the Quick View Plus display. Quick View Plus 
help is also available from the Help menu. The Quick View Plus toolbar is also available within the Internet Explorer 
window, and can be displayed or hidden. (For information on the commands available on the toolbar, see the `Toolbar 
buttons' topic).

To change the way Quick View Plus displays files within Internet Explorer, or to add or remove viewing support for specific file 
types, use the Options page of the Properties dialog for Internet Explorer:

1. While viewing a file in Quick View Plus, click View on the menu bar, then Configure Quick View Plus.

2. In the Applications dialog, select Microsoft Internet Explorer, then click Properties....

3. Click the Options tab.

Note: Internet Explorer cannot be running while you are trying to configure Quick View Plus with this applications.

The dialog consists of a two-column list of the file types viewed by Quick View Plus, and two buttons that allow you to modify this 
list.

Name column
This column contains the icon and descriptive name of each file type that will be viewed by Quick View Plus.

Content Type column
This column shows the Internet content type name (MIME type) for each file type.

Add...
Pressing this button will bring up the Add File Type dialog, , in which the user can define a file type not included in the list by 
entering information for the new type.

Remove
Pressing this button deletes the currently selected type or types from the list of file types that will be displayed by Quick View 
Plus.



Configuring Quick View Plus

Quick View Plus can be configured to work with other applications on your system; this is usually done during installation. If, 
however, you need to modify Quick View Plus settings or you install a new application, do one of the following:

· From a Quick View Plus viewing window select View on the menu bar, then Configure Quick View Plus....

· Right-click on the Quick View Plus magnifying glass icon on the Taskbar , and select Configure Quick View Plus....



Configuring for applications

1. In the Configure Quick View Plus with other programs dialog box, click the Application tab to see the list of 
applications.

2. Use the following table to guide you through the steps needed to modify your application settings.

To Do this

Disable a currently enabled 
application

Select Applications, click on the check mark to disable the currently enabled 
application. The message Disable integration will appear in the Action column 
and a red x will appear in the box to the left of the application name.

Enable an application Select Applications, click in the box to the left of the application name to 

generate a check mark  The message Enable Integration will appear in the 
Action column.

Enable a new application Click on the name of the application. The Properties button is activated. Click 
on the Properties button. The properties dialog box displays. It will contain at 
least one tab – General. Some applications, such as, Netscape or Internet 
Explorer will also contain the Options tab.

Under the General tab, you can either scan or browse to add the new 
application. The Options tab displays values relevant to the selected 
application.

Modify the properties of an active 
application

Click on the name of the application. The Properties button is activated. Click 
on the Properties button. The Properties dialog box contains at least one tab – 
General. Some applications such as Netscape or Internet Explorer will also 
contain the Options tab which allows you to customize certain aspects of the 
integration.

Optional Windows Desktop integration
Quick View Plus integration with the Windows Desktop Explorer can be enabled or disabled, according to the same procedures 
listed above for enabling or disabling applications.    When this integration is disabled, you will:

· Not have access to Quick View Plus from the Windows Explorer context menu (for viewing, printing, or compressing)

· Still have use of Microsoft’s Quick View capabilities, if originally installed

If you choose to disable Windows Explorer integration, this will also affect the status of other integrations, including Microsoft 
Outlook, Outlook Express, and Exchange.



Configuring for plug-ins

Programs that can operate within Netscape's web browser are called 'plug-ins'. Netscape allows such plug-ins to display files in 
its browser window. Quick View Plus can view files from within Netscape as either a plug-in or a helper application.

Plug-ins Helper applications

A plug-in is an object that allows some file formats, such 
as Microsoft Word, Lotus 1-2-3 or Microsoft PowerPoint, 
to be displayed and used seamlessly inside Navigator, 
just like the HTML web pages are. A plug-in tells 
Navigator what MIME type it supports and when a file of 
that type is clicked on. Netscape invokes the plug-in to 
display the file. Plug-ins can also be used to display 
files embedded in web pages and to display email 
attachments. From the user’s point of view, the plug-in 
operates seamlessly within Netscape, thus removing 
the intermediate step of having the user tell Netscape to 
run an outside Helper Application.

A Helper Application is an external application that the 
user can instruct Netscape to invoke when it 
encounters a file it cannot normally view. Quick View 
Plus still possesses the ability it always had to function 
as a Helper Application within Netscape, but the 
advent of the plug-in architecture allows Quick View 
Plus to provide a more seamless way to integrate its 
viewers within Netscape.

Netscape has defined a framework that other software developers can use to make their software work within Netscape's Web 
browser as plug-ins. Quick View Plus can also use some of these same plug-ins to display files within the Quick View Plus 
window.

Note: Netscape Navigator versions 2.0 and above support plug-ins. Quick View Plus can only plug into the 
Windows 2000, Windows 98, Windows 95, or Windows NT versions of Netscape Navigator.

If you already have Netscape plug-ins installed on your system that you would like to also use inside of Quick View Plus, you can 
use the Configure Quick View Plus with other programs dialog box to select plug-ins.

If you would like to use a supported plug-in within Quick View Plus but don’t have it installed on your system, the Properties 
dialog for each supported plug-in provides a link that you can use to connect your web browser to the plug-in download site.

To configure Quick View Plus for plug-ins

1. In the Configure Quick View Plus with other programs dialog box, click the Plug-ins tab to see the list of plug-ins.

2. Use the following table to guide you through the steps needed to modify your plug-in settings.

To Do this

Disable a currently enabled plug-in Click in the box to the left of the plug-in name to create a red x mark, then click 
the OK button.

Enable a plug-in
Click in the box to the left of the plug-in name to create a check mark , then 
click the OK button.

Enable a new plug-in Click on the name of the plug-ins to be added. The Properties button will be 
activated. Click on the Properties button. Using the Location tab, you can 
scan or browse to locate a plug-in already on your system or you can select 
Link to URL to download the plug-in.

Using the File Extension(s) tab you can specify which file extensions should 
be used as identifiers of the plug-ins file type. The extensions page is not 
enabled for plug-ins whose file types are recognized by Quick View Plus.

Modify the properties of an active 
plug-in

Click on the name of the plug-in. This activates the Properties button.    Click 
on the Properties button. Use the Location or Extension tabs as described 
in the previous table entry.

Note: Most file types are recognized by Quick View Plus, regardless of the file’s extension (the part of the file name after the 
‘.’). However, there are a few file types supported by plug-ins that Quick View Plus can’t recognize. These are the only file 
types that might require additional information to be recognized by Quick View Plus. This information can be provided by 
doing the following:

1. Highlight the name of the Plug-in.
2. Click the Properties button.
3. Select the File Extension(s) tab in the resulting Plug-in dialog.
4. Enter the extension in the text box in the Extension List section.
5. Click the Add button.
6. Click the Plug-in dialog’s OK button.



Quick View Plus Features

Once you’ve started Quick View Plus in any of the ways described in ‘Starting Quick View Plus using sample files’, you can use 
all its features.    This chapter describes how to accomplish the following tasks:

· View multiple files using the File Navigation panes 

· Open a viewed file for editing 

· Print a viewed file as well as print one or print multiple files without viewing those files

· Use Quick View Plus with Netscape and Microsoft browsers 

· Send a viewed file as an e-mail attachment 

· Save a copy of a viewed file 

· Quick Compress files into .zip files 

· Use online help 

· Close a view window and exit Quick View Plus 



The Quick View Plus viewing environment and File Navigation panes
Quick View Plus allows you to navigate through a file system by providing a dual File Navigation pane:

a) A Folder Tree pane which shows volumes and folders

b) A Folder Contents pane which shows the contents of a folder selected in the Folder Tree. 

There are two orientations for the File Navigation pane, of which you may choose through the Quick View Plus menu to provide 
the best view of the Folder Tree, Folder Contents, and the viewed file.    The two File Navigation orientations available are:

1. A left-hand side orientation, which is the navigation pane default orientation.

 
2. A top-attachment orientation



To change the File Navigation orientation

1. From the menu bar, click View, then click Options….

2. In the Quick View Plus Options dialog, select the Navigation tab.

3. In the File Navigation Options control, click the appropriate button for either left-hand side or top attachment File 
Navigation orientation.

The following topics – Menu options and Toolbar buttons – provide information on the other parts of the viewing environment.



Menu options
Within the image below, you may click any menu name to view a list of its available options.

File menu
· Open another file for viewing… – Initiates the Quick View Plus – Select a file to view dialog which allows you to open a 

file for viewing.

· Save Copy… – Initiates the Save Copy dialog to allow you to save the currently viewed file.

· Open (filename) for editing – Starts the program used to create the file (if the program is on your computer), with the file 
displayed and ready for editing.

· Quick Compress – Provides menu options that allow you to create a Zip file from the currently viewed file, add the currently 
viewed file to a Zip file, or create a Zip file with the same name as the currently viewed file.

· Print… – Displays a Print dialog which allows you to change the print settings for the viewed file.

· Make Wallpaper – Available for any bitmap file (BMP, GIF, TIF, etc.), this option places the current view in the view window 
as your wallpaper, the background for Windows desktop.

· Send (filename)… – Sends the file displayed in the view window as an e-mail attachment with Exchange and most other e-
mail programs.

· Close this View – Closes the current view

· Exit Quick View Plus – Closes all Quick View Plus views

Edit menu
· Copy – Copies a selection within a file to the clipboard

· Select All – Selects the entire content of a file

· Find… – Allows you to specify the text you wish to find within a file

· Find Previous – Finds the previous occurrence of the specified text

· Find Next – Finds the next occurrence of the specified text

View menu
· Toolbar – Shows or hides the Quick View Plus toolbar

· Status Bar – Shows or hides the Quick View Plus status bar

· File Navigator – Toggles between a full view window and the File Navigator window

· Refresh File Navigator – Refreshes the tree and list panes in the file navigator

· View as – Allows you to view a file in it’s native file format, as text, or as hexadecimal

· Text/HTML Encoding – Allows you to choose an encoding format for viewed HTML files

· Options… – Allows you to change various Quick View Plus options

· Configure Quick View Plus… – Allows you to configure the operation of Quick View Plus with the applications available for 
integration

File type-specific menu
Quick View Plus displays a menu with a different name – Archive, Bitmap, Database, Document, Drawing, Spreadsheet – 
and different options for each type of file you display.    You can choose any file type-specific command from the menu bar, or 
from the view window’s context menu, which you open by clicking the right mouse button anywhere in the view window.

To view the specific commands available from each of these menu items for their respective file types, see `Working with specific 
file types in Quick View Plus' in Chapter 4. 

Go menu
· Back – Browse back in the list of files viewed

· Forward – Browse forward in the list of files viewed

· The eight most recently viewed files are listed as well.    To view a previously-viewed file, select it from this list.

Window menu
· Tile Horizontally – Tiles all open Quick View Plus windows horizontally

· Tile Vertically – Tiles all open Quick View Plus windows vertically

· Cascade – Cascades all open view windows



· Pin to Desktop – Pins the current view window to the source from where Quick View Plus was last started

· Attach – Contains commands for the attached location of the current view window when pinning is active 

Help menu
· Help – Displays the online help contents and index

· Quick View Plus on the Web – Provides Web links to the Quick View Plus home page and product support

· About Quick View Plus – Displays program information, version number, and copyright



Toolbar buttons
The view window has all the features of a standard Windows program (title bar and sizing buttons, main menu, and scroll bars). 
It displays the current file and, depending on the view you’re looking at, some combination of the following toolbar buttons.    
These toolbar buttons give you quick access to several menu commands.

 When not activated or 'unpinned', 
causes each newly viewed file to be 
displayed in a new view window.

Note: File selected in the File 
Navigation pane will always be viewed 
in the same window.

 When activated or 'pinned', causes each 
newly viewed file to replace the one already 
in the view window.    (When Quick View Plus 
is pinned to Windows Explorer or the File 
Open dialog, the file navigation pane is 
hidden and the File Navigator button 
disabled.)

 
Toggles between a full window view of a 
file displayed in the view window, and 
the a file displayed alongside the file 
navigation pane. (The button reflects the 
current orientation of the file navigation 
pane.)

 
Launches a new view window with the tree 
view open to the same folder as the current 
Quick View Plus window (if File Navigator 
pane is active); no file will be displayed in the 
view window.

 
Browse back to the files that have been 
viewed.    By right-clicking the small 
arrowhead in the upper-right corner of 
this button, you can select and browse 
back to a file previously displayed.

 
Browse forward to the files that have been 
viewed. By right-clicking the small arrowhead 
in the upper-right corner of this button, you 
can select and browse forward to a file 
previously displayed.

 
Starts the program used to create the 
file (if the program is on your computer), 
with the file displayed and ready for 
editing. (This button changes to reflect 
the program used to create the file.)

 
Displays the Print dialog box so that you can 
change the settings (if necessary) and send 
the file to the printer.

 
Copies the selection to the Clipboard.

 
Finds the next occurrence of a search term 
you type into or select from the Find Text box:

 

 
Finds the previous occurrence of a 
search term you type into or select from 
the Find Text box.

 
For word processing, spreadsheet, database 
documents, or an archive file you display, 
incrementally enlarges the font size scaling to 
a maximum of 300% of its original size. For 
bitmaps, drawings and presentations, zooms 
in on the entire document.

 
For word processing, spreadsheet, and 
database documents, or an archive file 
you display, incrementally reduces the 
font size scaling to a minimum of 40% of 
its original size. For bitmaps, drawings. 
and presentations, zooms out on the 
entire document.

 
For word processing, spreadsheet, and 
database documents, or an archive file you 
display, restores font size scaling or viewing 
size to its original size. For bitmaps, 
drawings, and presentations, restores the 
document to its original size.

  
Displays word processing, spreadsheet, 
and database documents in draft mode.  

Displays word-processing, spreadsheet, and 
database documents in normal mode.

 
Displays word processing document 
pages in preview mode.  

When pressed, displays a word processing 
document fit to window. To toggle between 
preview and fit to window views, click the 
icon. To use this button, the document must 
be in Preview mode.

 
Hides or shows spreadsheet or 
database document gridlines.    This 
button is available only when viewing 
spreadsheet or database files.



Viewing multiple files using the File Navigation panes
After starting Quick View Plus and opening a view window as described in ‘Starting Quick View Plus  ’  , the easiest method by 
which you can view additional files is by using your keyboard to navigate the File Navigation panes – the Folder Tree pane, and 
Folder Contents pane.

To cycle through the File Navigation panes
Ø You may use the TAB key to quickly cycle from the Folder Tree pane, to the Folder Contents pane, to the view window, 

to the secondary view window (if appropriate), and back to the Folder Tree pane.    Press SHIFT+TAB to cycle through 
these windows in reverse order.

To view the contents of Folders in the Folder Tree pane
Ø Use the UP and DOWN arrow keys to navigate through the Folder Tree pane to display, in the Folder Contents pane, 

the files and sub-folders of a highlighted folder or drive.    When a drive or folder is highlighted in the Folder Tree pane:

· Use the RIGHT ARROW key to expand a drive or folder (if a highlighted folder cannot be further expanded, 
pressing the RIGHT ARROW key will highlight the subfolder immediately below).

· Use the LEFT ARROW key to collapse a drive or folder (if a highlighted folder cannot be further collapsed, pressing 
the LEFT ARROW key will highlight the parent folder).

To view files in the Folder Contents pane
Ø Use the UP and DOWN arrow keys to navigate through the Folder Contents pane to display files in the view window.    

Only highlighted files, not folders, will cause a new display in the view window.

To view the contents of folders in the Folder Contents pane
Ø Within the Folder Contents pane, use the ENTER key on a highlighted folder in the Folder Contents pane to cause the 

Folder Tree view to expand to that item; the contents of the highlighted folder are displayed in the same Folder Contents 
pane.

To delete files or folders in the File Navigation panes
Ø You may use the DELETE key for removing files and folders when highlighted in the Folder Tree or Folder Contents 

pane.

Other methods for viewing multiple files in Quick View Plus
a) You can open multiple view windows from the Taskbar, from the Program Menu, or from within Explorer. When you do this, a 

new Quick View Plus window opens for each viewed file. You can open the windows one at a time, or you can select several 
files and open windows for all of them simultaneously.

· Opening multiple-view windows individually

· Opening multiple-view windows simultaneously using the Explorer 

b) You can arrange multiple views using the taskbar or the Window menu in order to make portions of the viewing windows 
visible.

· Arranging multiple views using the Taskbar 

· Arranging multiple views using the Window menu 

c) You can view files sequentially by using the same view window for each file. You can do this by the following methods:
· Dragging a file into the view window 

· Dragging a file from Explorer when Quick View Plus is on the Desktop 

· Pinning the Quick View Plus viewing window to another window 

· Attaching the view window to the Explorer window 

When Pin is active, you can also use the Attach command within the Window menu to attach the view window to the 
Explorer window so that it stays in the same position whenever you select a new file for viewing.



Opening multiple-view windows individually

To open multiple-view windows individually

1. On the menu bar, click Window to confirm that there is no check mark to the left of Pin to the Desktop. (If there is, click 
Pin to the Desktop it to make it disappear.)

2. Select and open each of the files as in ‘Starting from the Taskbar  ’  , ‘Starting from the program menu’, or ‘Starting from 
Windows Explorer’. Repeat the process described until all files have been opened.



Opening multiple-view windows simultaneously using the Explorer

To open multiple-view windows simultaneously using the Explorer

1. In the Explorer window, click the first file.

2. To select additional files, do one of the following:

· To select a sequence of adjacent files, press the SHIFT key and click the last file in the sequence.

· To select a sequence of nonadjacent files, press the CTRL key and click each file.

3. Next, do one of the following:

· With the cursor over one of the selected files, click the right mouse button and select Quick View Plus on the 
context menu.

· On the File menu, click Quick View Plus.



Arranging multiple views using the Taskbar

1. Point to the magnifying glass icon .

2. Click the right mouse button.

3. Select Arrange Views.

4. Click on an organization style for the views: Tile Horizontally, Tile Vertically, or Cascade.



Arranging multiple views using the Window menu
Ø Click Window on the Quick View Plus menu bar, then select an organization style for the views: Tile Horizontally, Tile 

Vertically, or Cascade.



Dragging a file into the view window
1. In the Explorer window, point to the name or icon for the file you want to view.

2. Click and hold either mouse button and drag the filename or icon until it is inside the view window.

3. Release the mouse button.

The view window displays the dropped file in place of the file previously displayed.



Dragging a file from Explorer when Quick View Plus is on the desktop
1. In Windows Explorer, locate the file that you want to view.

2. Make sure the Quick View Plus desktop icon  is visible.

3. Drag the file to the Quick View Plus desktop icon.

4. Release the mouse button.



Pinning the view window to another window
Ø Click Window on the menu bar, then click Pin to Desktop, so that a check mark appears to its left, or click the Pin 

button  on the toolbar to activate pinning so that the button looks like this 

.

Each time you view a new file by dragging it into the view window it replaces the currently viewed file.



Attaching the view window to the Explorer window
1. On the Window menu, make sure there is a check mark to the left of Pin to the Explorer, or click the Pin button 

 to activate pinning. (If there isn’t a check mark, click Pin to the Explorer to make one appear.)

2. On the Window menu, click Attach.

3. To specify where you want to attach the view window, do one of the following:

To attach the view window on the... Click

Right Attach to Right Side of…

Bottom Attach to Bottom of…

Right or Bottom (whichever is better) Choose Right or Bottom Automatically

You may also choose Do Not Attach to… if you do not want to attach the viewing window.



Printing files
You can print all or part of any file displayed in the view window, and you may print one or multiple files without viewing them in 
Quick View Plus.

For details on customizing how Quick View Plus prints specific types of files, see `Customizing Printing'.

For more information about printing, see your Windows 2000, Windows 98, Windows 95, or Windows NT documentation.



Printing a file from the view window
1. On the menu bar click File, then click Print.

2. In the Print dialog box, specify the print settings for the viewed file.

3. By clicking the Setup…, Options…, and Properties… buttons (respective to the Windows platform you are running) 
you can select further options for printing files viewed in Quick View Plus:

· A different printer

· Paper attributes (size, orientation, source)

· Advanced printer settings

· The default font used for printing

· Header and header font

· Page margins

· Further printing options for viewed spreadsheet, database, bitmap, and drawing files

4. Click OK.



Printing a file without viewing the file

To print a file without viewing the file

1. In the Folder Contents pane, click the name of the file you want to print, click the right mouse button to display the 
context menu, then click Quick Print.

2. When the Quick Print confirmation dialog box displays, it provides three options: OK, Cancel, and Printer....    To 
change the printer settings, click on the Printer... button:

· In the Print dialog box, specify the printer name, print range, and number of copies

· If you want to select paper (size, source, and orientation), graphics, fonts, or devices, click Properties, select the 
Page Setup tab and choose the settings for each property.    Click OK.

· If you want to view and change these previous printing attributes, as well as other document options, click 
Properties, then select the Advanced tab.    The Advanced dialog will show you the print settings you have 
chosen, as well as allow you to change the more advanced print settings (Halftone Color Adjustment, Media, etc).    
Click OK.

3. Click OK.

4. Click on OK to print, click on Cancel to abort the operation.



Printing multiple files without viewing those files

To print multiple files without viewing those files

1. In the Folder Contents pane, click one of the files you want to print.

2. To select additional files, do one of the following:

· To select a sequence of adjacent files, press the SHIFT key and click the last file in the sequence.

· To select a sequence of nonadjacent files, press the CTRL key and click each file.

3. With the cursor over one of the selected files, press the right mouse button and click Quick Print on the context menu.

4. When the Quick Print confirmation dialog box displays, it provides three options: OK, Cancel, and Printer.... To change 
the printer settings, click on the Printer... button:

· In the Print dialog box, specify the printer name, print range, and number of copies

· If you want to select paper (size, source, and orientation), graphics, fonts, or devices, click Properties, select the 
Page Setup tab and choose the settings for each property.    Click OK.

· If you want to view and change these previous printing attributes, as well as other document options, click 
Properties, then select the Advanced tab.    The Advanced dialog will show you the print settings you have 
chosen, as well as allow you to change the more advanced print settings (Halftone Color Adjustment, Media, etc).

5. Click OK.

6. Click on OK to print, click on Cancel to abort the operation.



Saving a copy of a viewed file

To save a copy of a viewed file

1. On the File menu, click Save Copy.

2. In the Save Copy dialog, select the folder in which you want to save the file, and specify a name for the file. Quick View 
Plus saves the file in the format of the program used to create it.

3. Click Save.



What is Quick Compress?
Quick Compress allows you to select and compress any combination of files and folders, creating new .zip archive files or adding 
to an existing .zip file.    Quick View Plus Quick Compress commands are available from:

· The Windows Explorer right-click context menu (or any application that supports the Explorer context menu) 

· The Quick View Plus File Navigation pane right-click context menu 

· The Quick View Plus File menu 

You may also quickly add (and compress) files to existing .zip files when you view .zip files in Quick View Plus, as well as choose 
to delete selected files in existing .zip files.    See 'Adding files and folders to a Zip archive' or `Deleting files or folders from a Zip 
archive' for details on how to use these Quick View Plus features.



Quick Compress from Windows Explorer and Quick View Plus

To Quick Compress files or folders from the Windows Explorer context menu

1. In Windows Explorer, right-click on a folder, an individual file, or a selection of multiple files.    You may select multiple 
files by pressing and holding CTRL, clicking on the files to highlight them, then right-click any of the selected files.

2. From the available context menu, select Quick Compress, then select from the menu options listed below.

 
Quick Compress context menu with menu options 

To Quick Compress files or folders viewed in Quick View Plus

1. From the File Navigation Folder Tree or Folder Contents panes, select one or more files or folders.

2. From either:

a) The Quick View Plus context menu (viewed with a right mouse button click) or

b) The Quick View Plus File menu

select Quick Compress, then select from the following menu options:

Select To

Create Zip File… Open a dialog that allows you to select the location where the 
new .zip file will be saved.    The dialog opens to the current 
location of the selected file(s) or folder(s), and the name of the 
file or folder is used as the default name for the .zip file

Add To Zip File… Add the selected file(s) or folder(s) to an existing .zip file.    A 
dialog opens that allows you to select an existing .zip file to 
which you would like to add; the dialog opens to the location 
of the last .zip file added to or created, and the name of 
that .zip file is used as the default.

Add To (file or folder selected).zip Create a .zip file the same name as the file or folder selected. 
When created, this .zip file is located in the same folder as the 
selected file or folder.    For example, if you right-click on 
Msword.doc in the Samples folder, then select Add to 
msword.zip from the Quick Compress menu, a new .zip file, 
Msword.zip, will be created in the Samples folder.

Note: This item is not available if multiple files or folders are 
selected.    Also, if (file or folder selected).zip exists already, 
the selected files and folders are appended to the existing file; 
otherwise, a new file is created which contains the selected 
files and folders.

Add To (last zip file added to).zip Add the selected file or folder to the last zip file that was 
added to or created.    This allows you to build a zip file quickly 
by selecting a sequence of files found in different folders, then 
adding them to one zip file.



Automatically compressing e-mail attachments
Quick View Plus allows you to compress files when they are attached to e-mail messages in Microsoft Exchange, Outlook, and 
Lotus Notes (4.6.2 and later) clients.    You can specify the minimum size of an attachment to compress from the Properties… 
dialogs for each integration.    When files are attached, they will not be compressed until the e-mail message is sent or saved; 
while you are composing a message, you will see only the original, uncompressed file, while the compressed version of the 
attachment will be seen by the recipient (or by you upon opening a saved message).

To specify the size of e-mail attachments to compress

1. From the View menu, select Configure Quick View Plus….

2. In the Configure Quick View Plus with other programs dialog, click once on one of the available
e-mail programs in the list of available application integrations.

3. Click the Properties… button.

4. In the application dialog, select the Options tab.

5. Check the Compress attachments larger than box, then type in a size in the available box, or click the arrows to select 
a new size.    You may leave the default value or change it; 999K is the maximum and 0K the minimum value allowed.

6. Click OK. 



Opening a file for editing
If the program used to create a file is on your computer, you can open the file for editing directly from the view window.

Ø On the File menu, click Open [Filename] for Editing or click the program-specific button  (this button shows a 
program-specific button for a Microsoft Word file, but changes according to the format of file viewed) to the right of the 
Browse Back/Forward buttons on the toolbar. Quick View Plus starts the program used to create the file, with the file 
displayed and ready for editing.

Ø Double-click on the file in the Folder Contents pane.



Sending a file as an e-mail attachment
You can send the file displayed in the viewing window as an e-mail attachment in most e-mail programs.

To send a file as an e-mail attachment:

1. On the File menu, click Send [Filename].

2. In the Choose Profile dialog box, choose an e-mail program and click OK.

An e-mail session opens with the file inserted as an attachment.

Automatically compressing e-mail attachments 



Using online help
You can get online help for Quick View Plus as you do with any Windows program, through:

· A list of task-oriented and reference topics

· A list of search keywords

· Full-text index of every word in every help topic

· Context-sensitive help

To get help on a specific topic

1. On the Help menu, click Help Topics.

2. Do one of the following:

To access help through… Click this tab

Contents (list of task-oriented and reference topics) Contents

Search keywords Index

Full-text index Find

3. Follow the instructions on the screen.

To display context-sensitive help
Ø Do one of the following:

· In a dialog box, click the right mouse button and click the What’s This pop-up menu.

· In the View window, press F1.



Closing a view window and exiting Quick View Plus
After opening one or more view windows, you can close any of them and/or exit Quick View Plus. When you close a view 
window, you end the Quick View Plus session only for that window. Quick View Plus then runs in the background, and you can 
still access it through any of the methods previously described.

When you exit Quick View Plus, you simultaneously close all open view windows and remove Quick View Plus from memory.

To close a view window

1. Position the cursor in the view window you want to close.

2. On the File menu, click Close This View.

To exit Quick View Plus
Ø Do one of the following:

· Position the cursor in any open view window and click Exit Quick View Plus on the File menu.

· Right-click the Quick View Plus taskbar icon in the rightmost corner of the taskbar, and then click Exit Quick View 
Plus on the menu.



Working with specific file types in Quick View Plus

This chapter describes how to work with the different functions available in Quick View Plus when viewing specific file types:

· Word processing files 

· Spreadsheet, Presentation, and Database files 

· Bitmap files 

· Drawing files 

· Archive files 

· Embedded object files 

· Internet files 

· Third-party plug-in files

Quick View Plus displays a file-type-specific menu with a different name and different options for each type of file you display.    
This menu appears to the left of the Go menu on the main menu bar.    You can also choose any file-type-specific command from 
the Quick View Plus view window context menu, which you open by clicking the right mouse button anywhere in the view 
window.

To see the commands available for each file-type-specific menu, see the `Menu options' section.

Follow the instructions in each of the following sections after starting Quick View Plus and displaying a file of the appropriate type 
in the view window.



Viewing word processing files
You can view word-processing files in three modes – Draft, Normal, or Preview.    In Preview mode, you can view word-
processing files in three sizes – Full Size, Fit to Window, and Fit to Window Width.

Selecting a viewing mode for word processing files 
Selecting an on-screen page size for word processing files in Preview mode 
Selecting an on-screen font size for word processing files 
Copying text to the Clipboard 



Selecting a viewing mode for word processing files

To select a viewing mode for word processing files
Ø On the Document menu (which is the file type-specific menu) or on the Quick View Plus context menu (opened by 

clicking the right mouse button anywhere in the view window), do one of the following:

To display text with… Click View, then click….

A single font (selected from the Display tab of the Options 
dialog) with character formatting, paragraph alignment, 
spacing, tabs, but no embedded objects

Draft 

 

 

All fonts, character formatting, paragraph alignment, spacing, 
tabs, and embedded objects

Normal 

 

 

Line wrapping, columns, and page margins; all fonts, character 
formatting, paragraph alignment, spacing, tabs, and 
embedded objects; headers, footers, and annotations

Preview 

 

 



Selecting an on-screen page size for word processing files in Preview mode
Ø On the Document menu or on the Quick View Plus context menu (opened by clicking the right mouse button anywhere 

in the view window), do one of the following:

To set the page’s on-screen size to… Click Size, then click…

The full size of the printed page Full Size

Fit the page entirely within the view window Fit to Window

Fit page width within the width of the view window Fit to Window Width

 



Selecting an on-screen font size for word processing files
Ø On the Document menu or the Quick View Plus context menu (opened by clicking the right mouse button anywhere in 

the view window):

To: Click Font Size, then 
click…

Enlarge the displayed font size scaling Enlarge

 
Reduce the displayed font size scaling Reduce

 
Reset font size scaling Reset

 



Finding text
You can find specific text in any viewed file containing text.    You can do this from the Edit menu or the toolbar.

Note: You can search for text in word processing, spreadsheet, presentation, Internet, or executable (.exe, .dll) file formats. 

To find text with the Edit menu

1. On the Edit menu, click Find.

2. In the Find dialog box, enter the text you want to find.

3. If you want to find text that exactly matches the uppercase and lowercase letters in the Text to Find box, click Match 
Case.

4. To specify the direction of the search, click Forward or Backward.

5. Click Find.

To find text with the toolbar

1. In the Find Text box  on the toolbar do one of the following:

· Enter the text you want to find

· Click the down-pointing arrow next to the Find Text box, and click the text you want to find

2. Click the Find Next  or Find Previous 

 button.

Quick View Plus scrolls the view window to the previous or next occurrence of the text.    Upper and lowercase are 
ignored unless you selected Match Case the last time you entered text in the Find dialog box to find text.



Copying text to the Clipboard

To select and copy text to the Clipboard

1. In a viewed file, place your cursor at the point where you would like to begin copying text.

2. Click and hold the left mouse button and drag your cursor so that the text you wish to copy is highlighted.

3. On the toolbar, click the Copy button, or from the Edit menu click Copy (CTRL+C).

Tip: You may also choose Select All (CTRL+A) from the Edit menu to select the entire viewed file.



Viewing spreadsheet, presentation, and database files
After displaying a spreadsheet, presentation, or database file in the view window, you can:

· View spreadsheets in   Draft   mode   

· Show or hide the gridlines (in spreadsheet or database files) 

· Enlarge or reduce the on-screen font size 

· Display any sheet in a multiple-sheet file 



Viewing spreadsheets in Draft mode

Ø On the Spreadsheet menu, click Draft View, or click the Draft View toolbar button .



Showing or hiding gridlines in spreadsheet and database files
Ø On the Spreadsheet or Database menu, or on the Quick View Plus context menu (opened by clicking the right mouse 

button anywhere in the view window), click Gridlines, or press the Gridlines button  to toggle between enabling 
or disabling the display of gridlines.



Selecting an on-screen font size for spreadsheet, database, and presentation 
files

Ø On the Spreadsheet, Database, or Presentation menu, or the Quick View Plus context menu (opened by clicking the 
right mouse button anywhere in the view window), click:

· Font Size for spreadsheet and database files

· Zoom for presentation files

Then:

To Select
(SS,DB/PRES)

Enlarge the displayed font size scaling Enlarge/In

 
Reduce the displayed font size scaling Reduce/Out

 
Reset font size scaling Reset

 



Displaying multiple-sheet files
Many spreadsheet and database formats allow multiple sheets in a single file. Quick View Plus displays a tab for each sheet on 
the left side of the horizontal scroll bar in the view window.

  
To the left of the tabs are buttons that move tabs in and out of view, and move between consecutive sheets.    For instructions on 
how to use these tabs and buttons when viewing multiple-sheet files, see `Selecting among individual sheets in multiple sheet files'. 
For instructions on how to copy data from a viewed file, see `Selecting data for copying to the Clipboard'.



Selecting among individual sheets in multiple-sheet files
Ø Do any of the following:

To Do this

Switch to the sheet that follows the 
currently displayed sheet

Click the down arrow button  

Switch to the sheet that precedes the 
currently displayed sheet

Click the up arrow button  

Scroll the tabs to the right Click the right-single-arrow button  

Scroll the tabs to the left Click the left-single-arrow button  

Scroll the tabs all the way to the end Click the right-double-arrow button 
(displayed only for files with a large 
number of sheets)

 

Scroll the tabs all the way to the 
beginning

Click the left-double-arrow button 
(displayed only for files with a large 
number of sheets)

 

Change the horizontal size of the tab 
area

Click the small vertical bar on the 
right edge of the tab area and drag 
it to the left or right



Selecting data for copying to the Clipboard
Ø Do one of the following:

To select Do this

A column Click the column heading

A row Click the row number

Adjacent columns or rows Click the first column heading or row number, press and 
hold SHIFT, and then click the last column heading or 
row number.

Non-adjacent columns or rows Click the first column heading or row number, press and 
hold CTRL, and then click additional column headings 
or row numbers.



Viewing bitmap files
After displaying a bitmap file (BMP, GIF, TIF) in the view window, you can adjust the display by:

· Using the entire screen 

· Changing the display size 

· Rotating the bitmap 

· Zooming in or out



Adjusting the display of bitmap files
Ø On the Bitmap menu or on the Quick View Plus context menu (opened by clicking the right mouse button anywhere in 

the view window), do one of the following:

To Click

Use the entire screen to display the bitmap in its original size Show Full Screen

Change the display size of the bitmap: Size; then click:

· Display the bitmap in its original size · Original Size

· Size the bitmap so that it uses the entire view window without 
distorting the aspect ratio

· Fit to Window

· Size the bitmap so that it uses the entire height of the view window · Fit to Window Height

· Size the bitmap so that it uses the entire width of the view window · Fit to Window Width

Rotate the bitmap to the right: Rotation; then click:

None
90°
180°
270°

Zoom in or out on all or part of the bitmap: Zoom; then click:

· Zoom in on the entire bitmap · In
 

· Zoom out on the entire bitmap · Out
 

· Zoom in on a portion you select by clicking in the bitmap and dragging 
the mouse to define a rectangle

·

Selectio
n

· Reset to the size selected in the Size menu · Reset
 



Copying all or part of a bitmap to the Clipboard
1. Do one of the following:

· On the Edit menu, click Select All.

· In the view window, position the mouse pointer in the upper left corner of the section you want to copy. Drag 
diagonally down and to the right until the resulting rectangle outlines the selection you want.

2. On the Edit menu, click Copy .



Creating Windows wallpaper from a graphics file
After displaying any graphics file (BMP, GIF, TIF, etc.) in the view window, you can instruct Windows to use it as your wallpaper 
(the background for the Windows desktop).

Ø On the File menu, click Make Wallpaper.



Viewing drawing files
After displaying a drawing file in the view window, you can adjust the display by:

· Using the entire screen 

· Changing the display size 

· Zooming in or out 

You may also copy all or part of a drawing file to the Clipboard.



Adjusting the display of drawing files

To adjust the display of drawing files
Ø On the Drawing menu or on the Quick View Plus context menu (opened by clicking the right mouse button anywhere in 

the view window), do one of the following:

To Click

Use the entire screen to display the drawing Show Full Screen

Change the display size of the drawing: Size; then click:

· Display the drawing in its original size · Original Size

· Size the drawing so that it uses the entire view window 
without distorting the aspect ratio

· Fit to Window Height

· Size the drawing so that it uses the entire width of the 
view window

· Fit to Window Width

· Size the drawing so that it uses the entire width and 
height of the view window (possibly distorting the aspect 
ratio)

· Stretch to Window

Zoom in or out on all or part of the drawing:  Zoom; then click:

· Zoom in on the entire drawing · In
 

· Zoom out on the entire drawing · Out
 

· Zoom in on a portion you select by clicking in the 
drawing and dragging the mouse to define a rectangle

· Selection

· Reset to the size selected in the Size menu · Reset
 



Copying all or part of a drawing to the Clipboard
1. Do one of the following:

· On the Edit menu, click Select All.

· In the view window, position the mouse pointer in the upper left corner of the section you want to copy. Drag 
diagonally down and to the right until the resulting rectangle outlines the selection you want.

2. On the Edit menu, click Copy .



Viewing archive files
When you view an archive (compressed file or directory: PKZIPä, TAR, etc.) in the view window, Quick View Plus displays a 
tree-like representation of the archive’s directory structure with a list of the files in the archive.    The directory structure of the 
files is either unsorted, or sorted by name, size, or date and time, according to your selections in the More Display Options 
dialog box described in    `Customizing the display'. You can then:

· View a file in an archive 

· Extract (decompress and save) one or more files from an archive 

· Extract selected files from an archive 

· Extract all files from an archive 

If the archive is a Zip archive, you can also to the following:

· Add a file, files, and folders to an archive 

· Delete selected files or folders from an archive 



Viewing a file in an archive
Quick View Plus will open an archive display with a split-pane view.

 
Depending on the File Navigation pane orientation you have chosen, the files contained in the archive are displayed in the top or left 
pane, while the contents of a viewed file are displayed in the bottom or right pane.

To view a file in an archive

1. In the Folder Contents pane, click once on an archive file to highlight it.

2. In the tree representation of the archive file’s directory structure (in the top or left pane, again depending on File 
Navigation configuration), click once on a filename to display the file in the bottom or right pane.

Note: If a file decompressed from an archive is itself an archive, the viewing window will not be split again when viewing 
files in that second archive.    It is necessary to double-click on a file contained in the archive to decompress and view it 
in another Quick View Plus window. 

Note: If a archive contains only one file, you can choose to have that file automatically displayed in the bottom or right 
pane.

If you wish, split-pane functionality in viewing archive files can be disabled by doing the following:

To disable split-pane archive display functionality

1. On the View menu, click Options….

2. In the Quick View Plus Options dialog box, click the Navigation tab.

3. In the Archive View Option control, deselect the View the contents of an archive and a decompressed file in a split 
window checkbox.    By deselecting this checkbox, the If an archive contains one file, automatically decompress 
and view it checkbox option will be made unavailable.

4. Click OK.



Selecting an on-screen font size for archive files

To enlarge or reduce an on-screen font size for archive files
Ø On the Archive menu or the Quick View Plus context menu (opened by clicking the right mouse button anywhere in the 

view window):

Click Font Size, then: Click

Enlarge the displayed font size scaling Enlarge

 
Reduce the displayed font size scaling Reduce

 
Reset font size scaling Reset

 



Extracting files from an archive

To extract one file from an archive

1. Click the filename in the view window.

2. On the Archive menu or on the Quick View Plus context menu (opened by clicking the right mouse button anywhere in 
the view window other than on the file you wish to extract), click Extract This File.

3. In the Choose Destination for Extracted File(s) dialog box, either type or browse for the path to the destination where 
you want the file to be saved.

To extract selected files from an archive

1. Press and hold CTRL, and click each filename in the view window.

2. On the Archive menu or on the Quick View Plus context menu (opened by clicking the right mouse button anywhere in 
the view window), click Extract Selected Files.

3. In the Choose Destination for Extracted File(s) dialog box, enter the path to where you want to save the files.

To extract all files from an archive

1. On the Archive menu or on the Quick View Plus context menu (opened by clicking the right mouse button anywhere in 
the view window), click Extract All Files.

2. In the Choose Destination for Extracted File(s) dialog box, enter the path to where you want to save the files.



Adding files and folders to a Zip archive
Note: For more information on the Quick Compress feature of Quick View Plus, see `What is Quick Compress?'.

1. When you view a .zip file in Quick View Plus, an additional menu item, Add to This Zip File…, is added to the Archive 
menu selections. 

The Archive menu selections available when viewing an archive file in Quick View Plus 

2. When selected, an Add to Zip File dialog opens that allows you to select file(s) to add to the .zip file being viewed in 
Quick View Plus.

To add a file to a viewed .zip file

1.  While viewing the contents of a .zip file in Quick View Plus, either:

a) Click Archive on the menu bar and select the Add to This Zip File… menu item, or

b) In the File Navigation pane that lists the contents of the .zip file being viewed, right-click on the name of the .zip file 
in this pane and select Add to This Zip File… from the context menu.

2. In the Add to Zip File dialog, navigate to the file(s) you wish to add to the .zip file being viewed in Quick View Plus.    
You may select more than one file to add by pressing and holding the CTRL button while clicking on the files to be 
added.    Additionally, this dialog contains options for storing the path information of a compressed file.    Select the Store 
folder information checkbox, then either:

a) Store full path for a root directory path, or

b) Store relative path for path to where the Zip file resides

3. You also have the choice of compressing the contents of subfolders of any folders selected (select Include subfolders), 
and replacing existing files with the same name as the file being compressed (select Replace existing files with the 
same file name).

4. Click OK.

After you have selected the file(s) to add, the Quick View Plus view of the .zip file will close (allowing the selected files to be 
added and saved to the .zip file), then re-open the .zip file with the new file(s) added to its contents.

To drag files and folders from Windows Explorer

1. Select a file or folder from Windows Explorer.



2. Drag and drop the object into the Quick View Plus File Navigation pane that lists the contents of the .zip file being 
viewed.

3. In the Drag & Drop Options dialog, select to:

a) Add the file system object being dropped to the archive being viewed, or

b) Display in the view window the file system object being dropped

4. You can make whichever action you choose be the default action for a drag-and-drop by selecting the Do not display 
this message again checkbox in the Drag & Drop Options dialog.



Deleting files or folders from a Zip archive
1. In the tree representation of the archive file’s directory structure, left or right click on any file name to display the file.

2. Right click on the same file name and, from the available Archive context menu, click Delete Selected Files.



Viewing embedded objects
When you display a word-processing file or another file containing objects embedded using object linking and embedding (OLE), 
you can use Quick View Plus to display those objects or, if the program that created them is on your computer, to start the 
program.    You may also save a copy of an embedded object when it is viewed in an individual Quick View Plus session.



Displaying embedded (OLE) objects
Ø In the view window, double-click the OLE object.

If the program used to create the object is on your computer, it will be initiated.    If it is not, Quick View Plus starts a new 
session and displays the object in the view window.



Saving a copy of an embedded object
1. In the View window, double-click the embedded object.    Quick View Plus displays the object in an    Embedded Object 

– Quick View Plus window.

2. On the File menu, click Save Copy.

3. In the Save Copy dialog box, specify a folder and a name for the file.

4. Click Save.

5. To close the Embedded Object window, click Close This View on the File menu.



Viewing Internet files
You can view the following types of Internet files with Quick View Plus:

· UUEncoded files

· Hypertext Markup Language (HTML) files on local drives

To view UUEncoded files:
Quick View Plus displays the contents of a UUE file differently from other compressed formats; a text document indicates 
technical information about the encoded file, and the name of the file appears as a hyperlink in red print. 

Ø Click on the red hyperlink, and a second Quick View Plus session opens with the file in the view window.

Note: Graphics embedded in HTML files are not displayed unless they are in the same directory as the HTML file.

To view HTML files on local drives
Ø Hypertext files are displayed in the same manner as other files by clicking on the appropriate HTML file in the File 

Navigation pane.

The View menu option Encoding allows you to pick the character set used when viewing a file as text or HTML. This menu 
option is only enabled when Quick View Plus is displaying text or HTML. When the current file is an HTML file, the Encoding 
sub-menu will not allow you to choose non-HTML encoding options. 



File types supported through third-party plug-ins
As described in `Configuring for plug-ins  '  , Quick View Plus can use some plug-ins to display files within the Quick View Plus 
window.    The options available in this view vary, and are specific to and controlled by the third-party plug-in.



Viewing unregistered file types
You can set up Quick View Plus so that double-clicking on a file in Windows Explorer will cause Quick View Plus to view that file, 
if that file is not associated with any application on your system.

To set up viewing for unregistered file types

1. From the Quick View Plus View menu, select Configure Quick View Plus.

2. In the Configure Quick View Plus with other programs dialog, select Windows Explorer, then click the Properties… 
button.

3. In the Windows Explorer dialog, select the Options tab.

4. Click the View Unregistered File Types checkbox to allow or prevent Quick View Plus viewing of unregistered file 
types.



Customizing Quick View Plus

You can customize Quick View Plus to adapt to the ways you use it. You can change the following:

View window – show or hide the Toolbar, Status Bar, and File Navigator; specify how Quick View Plus displays each new view 
window; specify how Quick View Plus should handle unsupported file types; specify whether you want to display the Quick View 
Plus logo in the view window.

Display – specify the default font for text; specify the character set for files whose format is unknown to Quick View Plus; specify 
the format in which to view files: file-type-specific format, text (Standard, Windows, DOS, or Unicode), or hexadecimal; specify 
how to display spreadsheets, databases, and archive files (turn gridlines on or off, and select a sorting order)

Printing – specify the Quick View Plus font, page headers, and page margins (for all file types); gridlines, row names, column 
names, and field names (for spreadsheets and databases); borders and aspect ratio (for bitmaps and drawings)

Clipboard format – specify file formats and fonts (for all file types); table or tab format (for spreadsheets and databases)

Navigation – specify the location of the Folder Tree and Folder Contents within the File Navigation pane; specify how archive 
files and decompressed contents are displayed

Note: Changing the settings in an open Quick View Plus session does not affect subsequently opened sessions until you close 
the window in which you made the changes. After you close that window, the changes become the default settings for all new 
Quick View Plus sessions.



Customizing the view window
When customizing the view window you can:

· Show or hide the Toolbar, Status Bar, and File Navigator at any time when you have a view window open

· Specify how Quick View Plus displays each new view window (with or without the Status Bar and/or Toolbar, Pinned or Not 
Pinned to the window from which you started Quick View Plus, with or without a File Navigation pane displayed)

· Select how Quick View Plus should handle unsupported file types.

· Specify whether you want to display the Quick View Plus logo in the view window each time you start Quick View Plus.



Showing or hiding viewing tools

To show or hide viewing tools
Ø On the View menu, the first three selections – Toolbar, Status Bar, File Navigator – allow you select whether or not 

you wish to view these viewing tools.    By clicking on one of these selections in the View menu, you can toggle the 
check mark to the right on or off, which will show or hide that particular viewing tool.



Specifying settings for new view windows
1. On the View menu, click Options.

2. In the Options dialog box, click the General tab.

3. In the New Views Have control, do one of the following:

· To apply the view window settings used in the most-recently closed Quick View Plus session to all new view 
windows (that is, all new views will have the same Toolbar, Status Bar, Pin settings, and File Navigation settings as 
the last view), select the Auto check box.

Note: When Auto (the default) is selected, the other options become unavailable.

· To specify whether or not new views have a Toolbar, Status Bar, Pinned to another window such as Explorer or 
Exchange, and/or have a File Navigation pane, uncheck the Auto check box then select the appropriate check 
boxes for these three options.

4. In the Unsupported File Types control, do one of the following:

· Click Ask user what to do – When you try to view an unsupported file, a dialog box allows you to choose between 
displaying the file as an unknown file type, opening the file with its registered application, or not displaying the file 
at all.

· Click Open in registered application – When you try to view an unknown file, it is opened by the application 
installed to handle it on your computer. If there is no application installed to open the file’s type, Quick View Plus 
will display the files as an unknown file type. This is equivalent to double-clicking on the file in Windows Explorer.

· Click View file as an unknown file type – Quick View Plus displays the file by using the method for viewing 
unknown files (selected in the Display tab of the Options dialog box, reached by clicking Options on the View 
menu).

5. If you want to display the Quick View Plus logo each time you start Quick View Plus, click the Display Quick View Plus 
logo on startup check box.

6. If you want your selections to take effect immediately, click Apply.

7. Click OK.



Customizing the display
You can specify the default font for text and the character set for files whose format is unknown to Quick View Plus.    You can 
also specify how to display spreadsheets, databases, and archive files (turn gridlines on or off and select a sorting order).

To customize the display

1. On the View menu, click Options.

2. In the Quick View Plus Options dialog box, click the Display tab.

Quick View Plus uses the following defaults to display files:

File type or origin Default

· Files for which not font information is 
available

· Word-processing files in Draft mode

· ASCII and ANSI text files

· Database files

10-point Arial; ANSI 8-bits (the Windows character set, 
with extended characters)

Spreadsheet Gridlines displayed

Database Gridlines displayed

Archive Filenames sorted in the order in which they were added 
to the archive

3. Do one or more of the following:

· If you want to change the default font for text, click Change and select a different font from the Font dialog box.

· If you want to change the character set used to display files for which no font information is available, click the 
appropriate radio button.

· If you want to turn the display of gridlines off or on for spreadsheets and databases, click More, and then click the 
appropriate check box(es) in the More Display Options dialog box to check or uncheck the selections.

· If you want to sort archive files in ascending or descending order by name, size, or date and time, click More and 
then click the appropriate check box(es) in the More Display Options dialog box.

4. Click OK.



Customizing the view format
You can specify the format in which you want to view certain files.

To specify the view format

1. On the View menu, click View As.

2. On the submenu, select a format.

Note: When viewing text or HTML documents, you can use the Text Encoding or HTML Encoding item in the view 
menu to select the character set that Quick View Plus will use to display the current file.    For each of these types of 
documents, the character set you choose will be used to display all future files of that type.    To display characters in a 
foreign character set, you must have a font installed on your system that supports that particular character set.



Customizing printing
You can customize Quick View Plus print settings, as well as how specific file types are printed.

Quick View Plus uses the following defaults for print settings:

Characteristic Default

Font (for unknown fonts and for spreadsheets and 
databases)

10-point Arial

Header 10-point Arial, with the filename on the left and the page 
number on the right, enclosed in a shaded rectangular 
border

Margins 1 inch on the top, bottom, left, and right

To customize the print settings

1. On the View menu, click Options.

2. In the Quick View Plus Options dialog, click the Print tab.

3. Do one or more of the following; when available, you may check the effects of your changes by looking at the Sample 
box.

Adjusting printed page characteristics Do this

Change the default font for text In the Default Font control, click Change, and then 
select a font, it’s style and size in the Font dialog box.

Specify whether to print a header In the Header & Header font control, select or clear the 
Print header check box.

Change the font for the header In the Header & Header font control, click Change, 
and then select a font, it’s style and size in the Font 
dialog box.

Specify what to print on the left side of the header Type the text in the text box within the Job Name 
control (the default, %F, prints the filename).

Change the page margins In the Default Page Margins control, click the up or 
down arrows to increase or decrease the top, bottom, 
left and right margins on the page.

Specify whether to use the margins and paper size of 
the viewed document

In the Default Page Margins control, select or clear the 
Use margins and paper size of original document, if 
known.

Quick View Plus uses the following defaults for printing the following file types:

File Type Default

Spreadsheets Gridlines and the names of rows and columns are 
printed; print job is adjusted to the size of a single page

Databases Gridlines and field names are printed; print job is 
adjusted to the size of a single page

Bitmaps and drawings Original aspect ratio is used (the relationship of height 
to width)

To customize printed characteristics of specific file types

1. On the View menu, click Options.

2. In the Quick View Plus Options dialog, click the Print tab.

3. Click the More… button to open the More Print Options dialog.

4. Do one or more of the following:

Adjusting printed file type characteristics Do this

Change the settings for spreadsheets In the Spreadsheet control, click the appropriate check 
boxes and radio buttons to set spreadsheet print 
options.

Change the settings for databases In the Database control, click the appropriate check 
boxes and radio buttons to set database print options.

Change the settings for bitmaps In the Bitmap control, click the appropriate check boxes 
and radio buttons to set bitmap print options.

Change the settings for drawings In the Drawing control, click the appropriate check 
boxes and radio buttons to set drawing print options.



Customizing the Clipboard format
Quick View Plus uses the following defaults when copying information to the Clipboard:

Characteristic Default

File formats · Text

· Rich text format (RTF)

· Bitmap (BMP)

· Device-independent bitmap (DIB)

· Metafile

· Palette

Font (for copying text from spreadsheets and 
databases, and text for which no format information is 
available)

10-point Arial

Spreadsheet data Copies as a table

Database data Copies as a table and includes field names

To customize the Clipboard formats, fonts, and options

1. On the View menu, click Options.

2. In the Options dialog box, click the Clipboard tab.

3. Do one or more of the following:

To Do this

Specify the formats placed on the Clipboard Select or clear the appropriate check boxes for each 
format

Change the default font for the Clipboard Click Change, then select a font, it’s style and size in 
the Font dialog box.

Specify how spreadsheet data is formatted when 
pasted to your word processor:

· To use table format

· To omit tables for blank fields

· To include tabs for blank fields

Click More… in the Clipboard tab, then in the 
Spreadsheet control in the More Clipboard Options 
dialog, click:

· Copy as Table

· Copy using optimized tabs

· Copy using tabs

Specify how database data is formatted when pasted to 
your word processor:

· To use table format

· To omit tabs for blank fields

· To include tabs for blank fields

· To include field names in the pasted area

Click More… in the Clipboard tab, then in the 
Database control in the More Clipboard Options 
dialog, click:

· Copy as table

· Copy using optimized tabs

· Copy using tabs

· Include field names



Customizing Navigation

To customize File Navigation orientation

1. From the menu bar, click View, then click Options….

2. In the Quick View Plus Options dialog, select the Navigation tab.

3. In the File Navigation Options control, click the appropriate button for either left-hand side or top attachment File 
Navigation orientation.

4. Click OK.

To customize Archive file viewing

1. From the menu bar, click View, then click Options….

2. In the Quick View Plus Options dialog, select the Navigation tab.

3. In the Archive View Option control, you may select/deselect the View the contents of an archive and a 
decompressed file in a split window checkbox if you wish to turn on/off this function.    By deselecting this checkbox, 
the If an archive contains one file, automatically decompress and view it checkbox option will be made unavailable.

4. Click OK.



Using Quick View Plus in an Intranet environment

In a corporate Intranet environment, having Quick View Plus plugged into the web browsers on your user’s machines saves you 
the time and hassle of converting all your content into HTML files. Word documents, 1-2-3 spreadsheets, PowerPoint 
presentations and all the other file types Quick View Plus supports can simply be referenced directly or embedded (using the 
HTML EMBED tag) in your web pages.

The ‘MIME types and setting up MIME types on a server’ topic is intended to help a Webmaster set up a Web server so that 
Quick View Plus can be used in the browsers that access the server to view documents that are not supported by the browser. 
The fundamental problem to address is how best to get the browser to use Quick view Plus when the user is accessing a file 
type that is not supported by the browser.



MIME types and setting up MIME types on a server

The problem with MIME types

Web servers tell a browser the type of file being accessed by specifying the file’s MIME type. There are two problems with MIME 
types.

MIME types have not been defined for all file formats that Quick View Plus supports. While most of the major applications have 
MIME types (like application/msword or application/x-wordperfect6), many of the lesser known formats (like R:Base, Wordstar 
and Q&A Write) don’t. While this is an inconvenience for people who want to expose these legacy file types on the web, it does 
not present a major problem for more recent file types.

MIME types must be specified in a very exact way. In general, Internet file servers use the file’s extension to match a MIME type 
to a document. This means that documents must be named correctly or the MIME type will be wrong and the Web browser will 
not be able to run the right application to view the file. For instance, if you have a WordPerfect document that is named 
Document.doc, your server is likely to tell the browser it is a Microsoft Word document, not a WordPerfect document. Moreover, 
many servers have incomplete or incorrect MIME type associations. This often causes files to be identified by the server as 
some default value like "text/plain" defeating the browser’s ability to choose the correct plug-in viewer.

Setting up MIME types on a server

This is perhaps the simplest way to set up your server’s MIME types so that Quick View Plus can be invoked automatically by 
browsers. Simply put, you should set up your MIME types file so that only a minimal set of file extensions are mapped to MIME 
types, then set the default MIME type to one that is supported by Quick View Plus.

1. Remove all the MIME type mappings except the ones that map to your browser’s built-in types such as text/html, 
image/jpeg, etc.    If you have MIME types for specific applications other than your browser or Quick View Plus that you 
would like to continue to use, don’t remove their mappings either.

2. Once this is done, you can setup the default MIME type on your server to be application/x-quickviewplus (it’s usually 
text/plain). Support for the application/x-quickviewplus MIME type is installed by default when Quick View Plus plugs 
into Netscape Navigator or Microsoft Internet Explorer.

After setting up your mime.types in this way, any file with an extension that is not explicitly mapped in mime.types will be 
viewed in the browser using Quick View Plus.

Note: It is recommended that you not map your browser’s built-in MIME types such as text/plain and text/html to 
application/x-quickviewplus, as it can cause unpredictable behavior.



Running Quick View Plus from a command line

Quick View Plus is normally run from the right-click menu of files listed in the Windows Explorer, or from within mail and Web 
browsing applications known to Quick View Plus. However, some users may want to run Quick View Plus directly from a 
command line - either within an MS-DOS window or as a helper application for another program, such as a Web browser. This 
can be accomplished by running the Quick View Plus executable program with command line parameters.

The executable program for Quick View Plus is QVP32.EXE, located in the Program subdirectory of your Quick View Plus 
installation. In the default installation, the path to this executable is C:\Program Files\Quick View Plus\Program\QVP32.EXE

You can display files in Quick View Plus by specifying the file name as a command line parameter to QVP32.EXE. Additional 
options can be specified that control the appearance and behavior of the Quick View Plus window.



Command line options for QVP32.EXE

If you are running QVP32.EXE from the Start menu Run... command, you do not need to specify a path to QVP32.EXE, nor do 
you need the path if you are running it from another windows program; e.g. as a Netscape Navigator helper application. The path 
only needs to be specified when QVP32.EXE is run from the MS-DOS prompt.

Note: If you are running QVP32.EXE from the MS-DOS command line and the path to the filename contains spaces, you must 
enclose the path in quotation marks. For example, qvp32"C:Program Files\Quick View Plus\readme.doc".    Additionally, since 
MS-DOS only recognizes directory names that contain no more than eight characters, remember to abbreviate long directory 
folder names by typing the first six letters, then the tilde (~), then the number 1.    For example, C:
\Progra~1\Quickv~1\Program\QVP32.EXE.

Here is the general form for running QVP32.EXE with command line parameters:

QVP32.EXE filename [options ]

where filename represents the full path name of file to view, and options represents any combination of the options listed below, 
separated by spaces:

Option Syntax Explanation

-p (position) -p x, y, width, height Position top/left of view window at 
x,y and size view window to width, 
height. Values are in screen 
coordinates. For example:

-p100,100,400,200

Note: Do not use spaces between 
values.

-m (maximize) -m The view window starts maximized 
(-p option still valid)

-i (Iconize) -i The view window starts minimized 
(-p option still valid)

-d (display name) -d text Uses text in place of the file name 
in the Quick View Plus title bar and 
message boxes. 

Note: If this text contains spaces, 
you must enclose it in quotation 
marks. For example: -d "The 
Viewed File"

-dt (disable toolbar) -dt The toolbar is not displayed

-dl (disable launch) -dl The toolbar button and menu item 
for launching the displayed file in 
it's original application are disabled

-dp (disable print) -dp The toolbar button and menu item 
for printing and Quick Print are 
disabled, however Quick Print is 
still available from the context 
menu in the File Navigation pane. 

-dc (disable copy) -dc The toolbar button and menu item 
for copying to clipboard are 
disabled

-ds (disable search) -ds The toolbar button and menu item 
for searching within the displayed 
file are disabled

-dz (disable Quick Compress) -dz The menu item for Quick 
Compress is disabled, however 
Quick Compress is still available 
from the context menu in the File 
Navigation pane.

-db (disable status bar) -db The status bar is not displayed

-da (disable split pane Archive 
view)

-da A split pane viewing window is not 
displayed when viewing an Archive 
file.

-dn (disable File Navigator) -dn The File Navigation pane is 
disabled, however this does not 
disable the ability to browse 
through the history of files being 
viewed.



-x (use existing window) -x The specified file will be displayed 
in a 'pinned' window, replacing any 
file in an existing pinned window if 
one is already displayed.    See 
`Pinning the view window to 
another window'.

Note: If a previous window exists, 
all other options on a command 
line, except -d (display name) will 
be ignored.

-prn (print only) -prn The specified file will be printed 
without being displayed. A status 
dialog with a Cancel button will be 
presented to the user to confirm 
the user desires to Quick Print the 
file.

-sprn* -sprn The specified file will be printed 
without a dialog being invoked.    
The file will not be displayed.

-bprn* -bprn The specified file will be printed 
and a progress dialog will be 
displayed.    The file will not be 
displayed.

* Of these parameters, only one at a time is valid on the command line.



Accepts the current operation and activates any changed settings or selection.



Cancels the current operation and discards any changed settings or selections.



Searches for the previous occurrence of the Find Text string.



Searches for the next occurrence of the Find Text string.



Unrecognized files will be displayed using a hexadecimal representation of the file’s binary data.



Unrecognized files will be displayed using the Windows character set without extended characters.



Unrecognized files will be displayed using the Windows character set with extended characters.



Unrecognized files will be displayed using the DOS character set without extended characters.



Unrecognized files will be displayed using the DOS character set with extended characters.



Unrecognized files will be displayed using the 16 bit Unicode character set.



Unrecognized files will not be displayed.



Unrecognized files will be assumed to contain text in the Japanese ShiftJIS character set.



Unrecognized files will be assumed to contain text in the Chinese Big 5 character set.



Unrecognized files will be assumed to contain text in the Chinese GB character set.



Unrecognized files will be assumed to contain text in the Korean Hangul character set.



Toggles between displaying and not displaying spreadsheet gridlines in the View Window.



Toggles between displaying and not displaying database gridlines in the View Window.



Archive options determine the sort order of multiple files in an archive to be displayed in the View 
Window.



Lists the contents of an archive file without sorting.



Lists the contents of an archive file sorted alphabetically by name.



Lists the contents of an archive file sorted by file size.



Lists the contents of an archive file sorted by date and time.



This group allows you to choose the different types of text and graphical information Quick View Plus 
will copy to the clipboard.



Selected data will be copied in table format.



Data fields will be separated by tab stops set to approximate the original spacing of the columns. 
“Optimized” means that tab stops will not be generated for blank fields.



Data fields will be separated by tab stops set to approximate the original spacing of the columns.



When selected, column and row field names will be copied along with the selected data.



Sends the entire file to the printer.



Sends selected pages to the printer.



Sends only the sections of the file that have been selected to the printer.



Determines how many copies of the file will be printed.



Selects whether multiple copies of the file will print with or without collation.



When selected, places a header on every printed page.



The text that will be placed in the header when the Print Header is selected.



Sets page margins for printing.



A sample of how the printed page will look with the current settings.



When selected, prints the gridlines in spreadsheet and/or database files.



When selected, prints the row and column names in spreadsheet files.



When selected, prints the field names in database files.



When selected, graphics files will be printed with their original height-to-width ratio.



When selected, sizes the width and height of bitmaps and/or drawings to print to the margin edges.



When selected, prints borders around bitmaps and/or drawings.



When selected, displays the Quick View Plus logo during the initial program loading.



When selected, uses the window settings of the last closed Quick View Plus session for all new 
sessions.



When selected, all Quick View Plus sessions will display the Toolbar.



When selected, all Quick View Plus sessions will display the Status Bar.



When selected, all Quick View Plus sessions will be pinned to either the right side or bottom of the 
Explore/Exchange/etc… window.



The default font that will be used in the View Window when font information is not present in the file.



The default font that will be used when printing files that don’t contain font information.



The default font that will be used when copying to the text clipboard that doesn’t contain font 
information.



Allows you to change the default font used for files that don’t contain font information.



Allows you to change the default font to be used when printing.



Allows you to change the default font used when copying to the clipboard.



Allows you to select between viewing and not viewing gridlines in the View Window of spreadsheet and 
database files and to set the sort order archived files will list in the View Window.



Allows you to select how Quick View Plus will handle the printing of spreadsheets, databases, bitmaps 
and drawings.



Allows you to select the format spreadsheets and databases will be copied to the clipboard. This 
information determines how your word processor will display the copied portions when pasted from the 
clipboard.



The default font that will be used in the header of each printed page when Print Header is selected.



Allows you to change the default font used in the page header.



When selected, the user will be asked how Quick View Plus should proceed each time Quick View Plus 
encounters an unsupported file type.



When selected, unsupported file types will be opened by the application on your system that is 
registered to handle them.



When selected, unsupported file types will be displayed in Quick View Plus using the method selected 
for displaying unknown file types.



When selected, the printed page will reflect the document's page margins and orientation.



These are the programs that Quick View Plus can integrate with. They may or may not be present on 
your system.



Provides details and setup information about a selected application from the list above.



Indicates the progress of a scan operation.



These are Internet MIME types registered for Netscape.



Pressing this button allows you to define a new MIME type for Netscape.



Pressing this button will remove the registration of a MIME type.



These file extensions are associated with the selected MIME type.



These are the choices of how Quick View Plus will display files of the selected MIME type.



These file types will be displayed by Quick View Plus within the Internet Explorer window.



Pressing this button allows you to add to the list of file types that Quick View Plus will display within 
Internet Explorer.



Pressing this button will remove the selected file types from the list of file types that Quick View Plus 
will display within Internet Explorer.



This list contains the plug-ins that can be used by Quick View Plus to display files. 



Provides details and setup information about the selected plug-in from the list above. 



Shows the current relationship between Quick View Plus and the selected application. 



Shows the current location of the selected application. 



Pressing this button causes Quick View Plus to search your computer for the selected application. 



Pressing this button causes Quick View Plus to search your computer for the selected plug-in. 



Pressing this button allows you to browse for the location of the selected application. 



Pressing this button allows you to browse for the location of the selected plug-in. 



Information that is particular to the selected application is provided here. 



This is the path to the selected plug-in's location. 



Pressing this button will cause Quick View Plus to run your Web browser and connect to the Web page 
of the provider of the selected plug-in. 



These controls allow you to find the selected plug-in on your computer, network, or the World Wide 
Web. 



Type a file extension here and press the "Add" button to add it to the list of extensions for the selected 
plug-in. 



Pressing this button adds an extension typed into the box on the left to the list of extensions for the 
selected plug-in. 



Pressing this button allows you to make changes to the selected MIME type and its extensions. 



Pressing this button removes a file extension from the list of extensions whose files will be displayed 
with the selected plug-in. 




