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Introduction

Thank you for choosing Amadeus II. This shareware is a powerful tool that allows easily to record, play,
analyze and manipulate sounds. It provides several quite professional features like direct-to-disk sound
manipulation and 24Bit sound handling.

This reference guide describes briefly the main functions of Amadeus II. It is by no means supposed to
be exhaustive. The functionalities described here apply to Amadeus II v2.3. Some functions may not be
present on older versions.

I do not represent any software development company or whatsoever. I am just a graduate student in
physics who likes programming. This program was developed entirely during my free time and is not part
of any bigger project. Because of these reasons, no exhaustive testing could have been performed. Since
some functionalities are system-dependent or even machine-dependent, it may happen that Amadeus II
presents some dysfunctionalities on your personal configuration. If so, please feel free to contact me
at
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. For obvious reasons, I always assume you are in possesion of the
latest available version of Amadeus II. You can check the number of the latest version (and of course
also download it) at
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Just to avoid getting in any trouble, I have to mention that I am not responsable for any damage that may
be caused by any version of Amadeus II to your machine.

About Amadeus 1.44

Amadeus 1.44 is the most recent version of the first generation of Amadeus. Amadeus II has been
rewritten entirely from zero, it is not just an update of version 1.44, so there are some functionalities of
version 1.44 that are not implemented yet. In the case you want to use them, your registration code for
Amadeus II also works for Amadeus 1.44. You can download it from my homepage at
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Installation notice

This release is made of two distinct components.

The Amadeus Application folder contains everything that is needed to make the program work. It is
important not to remove the application file from this folder. At startup, the program looks for the external
files in every folder located at a higher level than the application file in the disk file system. This means
that if you put the program on the desktop, it will scan your whole disk at startup, which may take a
considerable time.

The Amadeus Toolbox folder contains a C++ library allowing you to create your own external filters, as
well as several examples of such filters. The application does not need this folder to work.

1 The documents

There are five types of documents handled by Amadeus II.

1.1 The sound windows

They are the main “working place”. The sound is depicted as a wave showing the pressure as a function
of time. If you create a new window, it is gray, meaning that no sound is present. In order to select a part
of the sound, just click at the beginning of the select and drag the mouse until the end of the selection.
The “shift” key allows you to extend the current selection. If the sound has several channels, all of them
will be selected. In order to select only one channel, hold down the “option” (“alt” on some keyboards)
key.

There are two small white strips above and below the one(s) containing the sound itself. The lower strip
shows a time scale. The upper one contains the marks of the current sound (if some are present). To create
a mark, just click into that strip and drag the mouse to the appropriate location.

There are four small icons at the left bottom of the window. The first one allows to change the
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at which the sound is to be drawn. If you click onto the second one, a dialog showing the characteristics
of the sound opens. If the sound is currently stored on a hard disk, you can try to load it into RAM. The
third icon allows to set the volume level at which the sound is to be played. The last icon allows to set if
the sound has to be looped at playback or not. If the sound is stored on a hard disk, it may not be a good
idea too loop a short sequence, since this causes the reading device to jump very quickly forth and back.
If the hard disk does not “keep up” with the sound playback, your machine may crash.

The small icon at the top right of the window allows to change the
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of the displayed
sound.

1.2 The “Sonogram” windows

A “sonogram” is a graphic representation of a sound showing the frequency as a function of time. The
amplitudes of the different frequencies are shown as colors. For example, a pure sound will be represented
by a straight horizontal line, because there is only one frequency present. Sonograms are a quite useful
tool to compare sounds or to find out which notes are present in an accord for example.

A sonogram window is composed of three parts: A tool bar, the sonogram itself and the sound from which
it was produced.

The tool bar. The “colors” frame contains a pop-up menu that allows to change the color palette and
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a slider that allows to change the
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of the sonogram. The
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determines which
color has to be attributed to which amplitude. If you glide the slider to the right, the color scale becomes
more sensitive, i.e. small amplitudes will become visible.

The second frame contains two icons. The first one opens a dialog that allows to set the different color
palettes. The second one opens a dialog that allows to change the different parameters of the sonogram.
Here is a short description of them. Max. Frequ. is the maximal frequency shown in the sonogram. If
you lower it, you will have a better vertical resolution but you will cut off the high frequencies. Sizes
FFT is the number of points considered in one Fourier transform. If you increase this value, you increase
the quality of the sonogram, but the computation gets slower. Sizes Picture is the vertical size of the
sonogram. Frequ. Scale allows to choose between a linear and a logarithmic frequency scale. Ampl.
Scale allows to choose between a linear and a logarithmic amplitude scale. In the case of a logarithmic
amplitude scale, Gain allows to choose the difference in dB of the amplitudes corresponding to the first
and the last color in the color scale. Emph allows to preemphasis the spectra in order to magnify high
frequencies, which have usually lower amplitudes.

The sonogram. If you click into this part, a small window appears, showing the frequency corresponding
to the location of the mouse, as well as the note that is closest to that frequency.

You can copy the sonogram into the system scrap by choosing Copy in the Edit menu.

The sound. This part of the 7 *�	�*��8���(�5$��(	�/�*�$
behaves exactly like the 7 *���	�/9$��
	�/�*�$

, but you cannot
select anything. The three small icons in particular have the same behavior.

1.3 The “Spectrum” windows

A “spectrum” is a graphic representation of the amplitude as a function of the frequency at one point of a
sound. A spectrum is in fact a “vertical cut” of a sonogram. The meaning of the functions present in the
spectrum windows should be quite clear from what has been said about the sonogram windows.

1.4 The “Animated Spectrum” windows

An animated spectrum contains a sound, together with a sequence of time-equidistant spectra. You can
play the sound by clicking onto the Play button located at the left of the window. You can also hit the
space bar instead. While the sound is being payed, the window shows the spectrum corresponding to the
current position. You can also go to a specific position by using the slider at the bottom of the window
(use it only when the sound is not currently playing). The “Preemphasis” button allows to emphasize
high frequencies. The “Scale” field allows to change the horizontal and vertical scales in order to fit your
personal needs.

If you choose Copy in the Edit menu while an animated spectrum is the frontmost window, the program
copies the sound corresponding to that window into the current scrap.

1.5 The “3D Spectrum” windows

An 3D spectrum is much like an animated spectrum, except that the different spectra are drawn all at the
same time in order to present as much information as possible at a glance. The functions in the window
are essentially the same as for the animated spectrum, except that you can change the color palette used
to colorize the spectra. The available color palettes are the same as for the sonograms.
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If you click into the window, a small window shows up containing the frequency corresponding to the
location of the mouse. If you want to get the frequency of a particular peak, you have to click at the bottom
of the peak to get the right value.

If you choose Copy in the Edit menu while a 3D spectrum is the frontmost window, the program copies
the picture into the scrap.

2 The floating palettes

There are three floating palettes which can be shown/hidden using the submenu Floating palettes of the
Edit menu. Here is a short description of their contents.

The commands palette. There are four icons appearing in this palette. Each of them is linked to a menu
item, i.e. clicking on it has the same effect than choosing the corresponding menu item.

The icon symbolizing a microphone is linked to the Record item of the Edit menu.

The icon symbolizing a highspeaker is linked to the Play item of the Edit menu.

The icon symbolizing a spectrum is linked to the Spectrum... item of the Analyze menu.

The icon symbolizing a sonogram is linked to the Sonogram... item of the Analyze menu.

The memory palette. The progress bar shows the fraction of the heap used by Amadeus II. Total
memory is the total amount of the heap allocated to Amadeus II by the system. This amount can be
changed by selecting the application program in the Finder and selecting the Get info... item in the File
menu. Free memory is the part of the heap that is not used by Amadeus II.

The selection palette. It contains the coordinates of the selection of the sound contained in the frontmost
window. The first time is the length of the selection, the second one is the start of the selection and the
last one the end of the selection. The units can be changed in the Preferences... dialog of the Edit menu.

If you click into this palette, it has the same effect as selecting the Set Selection... item of the Selection
menu.

3 Menu commands

3.1 The “File” menu.

“New”. Creates a new sound file. The characteristics of this file can be set in the Preferences... dialog
of the Edit menu.

“Open...”. Allows to open a file (sound or sonogram) previously saved on disk. Currently recognized
sound formats are

.�:(;�;
, compressed
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and System 7/8

-�)���+
. The recognized sound compression

formats are those provided by the SoundManager, which varies from one system to another (a-Law
compression is only recognized under MacOS 8.5 and later).

If NavigationServices are present (MacOS 8.5 and later), they are used by version 2.11 and later.

If there is not enough memory left to load the sound, Amadeus II opens it anyway and handles it direct-
to-disk. This is very useful to open huge sounds, but of course the performance of the program will
decrease.

“Close”. Closes the frontmost window. If it contains an unsaved document, asks the user if he wants to
save it.
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“Save”. Saves the content of the frontmost window on the hard disk. If there is no file associated to that
window yet, the behavior of Save is the same than that of Save as....

“Save as...”. Shows the standard saving dialog. If NavigationServices are present (MacOS 8.5 and later),
they are used by version 2.11 and later. If the document to be saved is a sound, you can choose between
two formats (Audio International File Format and System Sounds) and several compression laws. Some
compression laws may be grayed out, that means that they are not recognized by your version of the
SoundManager. If you compress a sound, some quality may be lost, particularly if the compression rate
is high, so test the results of the different laws before you use them.

“Print...”. Not implemented yet.

“Page setup...”. Not implemented yet.

“Quit”. Terminates the program after closing all documents.

3.2 The “Edit” menu.

“Undo”. Undoes the last action performed in the frontmost window. For 7 *���	�/=$>�
	�/�*�$�-
, multiple

undoing is supported up to a level that can be set in the Preferences... dialog.

“Redo”. Annihilates the effect of Undo.

“Cut”. Equivalent to Copy followed by Clear.

“Copy”. Copies the selection of the frontmost window into the scrap. If the window is a 7 *���	�/=$��
	�/�*�$
,

the selection is copied into the current internal scrap. The current scrap can be chosen in the Scrap
submenu. If you switch to another application, the current scrap is placed into the system clipboard,
provided that you checked the "export scrap" box in the Preferences... dialog and that there is enough
RAM left.

“Paste”. If no sound is selected, it inserts the content of the current scrap at the insertion point of the
frontmost 7 *���	�/=$��(	�/�*�$

. If a sound is selected, the selection is deleted first. If the quality of the scrap
doesn’t fit the quality of the frontmost 7 *���	�/9$>�
	�/�*�$

, the content of the scrap is first converted as to fit
that quality. Notice that the content of the scrap is not affected by this operation. If you switch from
another application to Amadeus II and the system clipboard contains some sound data, it is placed into
the current scrap.

“Paste special”. Mixes the content of the current scrap to the sound contained in the frontmost 7 *���	�/$��(	�/�*�$
. It will start exactly at the beginning of the selection, not depending of the size of the selection.

If the qualities don’t fit, the content of the scrap is also automatically converted.

“Clear”. Deletes the current selection.

“Select all”. If the frontmost window is a 7 *���	�/9$��(	�/�*�$
, extends the selection of the sound to the whole

sound.

“Current scrap”. Allows to change the current scrap.

“Floating palettes”. Allows to show/hide the different floating palettes.

“Preferences...”. Opens a dialog that allows to change the behavior of Amadeus II. In particular, you
can set the default quality of a new sound and the units at which a time has to be displayed.
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“Reload effects”. Searches for external filters present in any subdirectory of the directory containing the
application file. This is mainly useful for development purposes when you change an external filter and
want to test it without quitting Amadeus II.

3.3 The “Selection” menu.

This menu contains numerous functions that allow to gain full control over the extent of the selection, as
well as some functions to handle marks.

“Set Selection...”. Opens a dialog box that allows to set the selection precisely. The numerical values
have to be entered in milliseconds. If marks are present, the Mark... buttons allow to put the position of
a mark into the corresponding text field.

“Mark Selection...”. Allows to put one mark at the beginning of the current selection and one at the end.
If no sound is selected, it puts a mark at the current insertion point.

“Jump to”. The pop-up menu attached to this item allows you to choose the selection, the whole sound,
a mark or the time between two marks. The program then changes the

���?���4-�����+��
and the position of

the scrollbar of the frontmost 7 *���	�/9$��
	�/�*�$
in a way that the chosen part of the sound fills exactly the

width of the window.

“Extend to Start”. Extends the selection to the beginning of the sound.

“Extend to End”. Extends the selection to the end of the sound.

“Extend to Next Mark”. Extends the selection to the location of the first mark that comes after the end
of the selection. If there is none, it has the same effect as Extend to End. This function can also be
accessed by pressing command-right arrow.

“Extend to Previous Mark”. Extends the selection to the location of the last mark that comes before the
beginning of the selection. If there is none, it has the same effect as Extend to Start. This function can
also be accessed by pressing command-left arrow.

“Save Selection As...”. Behaves like Save As..., except that it creates a sound that contains only the
current selection.

“Split According to Marks...”. Splits the sound into pieces according to the marks. The “Start color”
indicates the color of the marks that specify the beginning of a piece, the “End color” indicates the color
of the marks that specify the end of a piece. The name of each piece is equal to the name of the mark
located at its beginning. Once you’ve selected “OK”, a standard file saving dialog appears, in which you
have to enter the name and location of the folder that will contain the various pieces.

“Clear All Marks”. Deletes all the marks of the frontmost sound.

3.4 The “Sound” menu.

This menu regroups mainly the items involved in the acquisition and the reproduction of sound.

“Play”. Plays the sound contained in the frontmost 7 *���	�/=@��(	�/�*�$
. If the selection is longer than a few

milliseconds, only the selection is played, otherwise the whole sound is played. This menu item can be
accessed by pressing the space bar.
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“Play From Insertion.”. Similar effect than Play, but the sound is played starting from the beginning of
the selection until the end of the sound is reached.

“Play Between Marks...”. opens a dialog box in which you can choose two marks of the current sound.
The sound between the two selected marks will then be played.

“Record...”. Opens a window that allows to record a sound from any input device recognized by the
SoundManager. The first progress bar indicates the length of the recorded sound (If it is filled, the maximal
length has been reached). The maximal length of the recorded sound can be set in the Preferences...
dialog box. If you shorten it, you use less disk space when this window is open. The second progress bar
indicates the volume level measured by the active input device. The “Peak” indicator turns red if a too
high level has been reached at least once during the recording.

The Max. CPU checkbox allows to freeze all the other applications while recording. This is useful to
minimize the risk of having cuts in the recorded sound. The Mark Sound checkbox allows to generate
marks containing the system time at the beginning and at the end of the recording.

“Jump to Play Position.”. When a sound is currently being played, this function selects 250 milliseconds
of sound about 0.2 seconds before the actual playback position and then calls the Jump to selection
function. This can be quite useful to detect the position of a crack in a sound for example.

“Stop”. Stops playing the frontmost sound. If the Recording window is open, stops the recording.

“Pause”. If the Recording window is open, pauses the recording.

“Resume”. If the Recording window is open, resumes the recording.

“Characteristics...”. Opens a dialog allowing to change the characteristics of the frontmost sound. This
operation can be undone in version 2.1 and later.

Be aware of the fact that 24Bit sound can not be recorded by the actual versions of the SoundManager, so
this is mainly useful to preserve high quality even if you apply many effects.

“Playback Pitch...”. Allows to play the sound at a rate different to the recording rate. This function may
not produce satisfactory results if the recording rate of the frontmost sound is too high (more than 32kHz).
This is related to the internal description of the sound header by the SoundManager.

3.5 The “Effects” menu.

“Echo...”. Allows to apply an echo to the current selection. If you check the Go further box and put a
value of A seconds in the text field, the echo of the selection will be prolongated by A seconds. Nevertheless,
no echo will be applied to the A seconds following the selection.

“Amplify...”. Allows to amplify the selection by a given factor. If the “fading time” is non-zero, a smooth
transition is made between the amplified and the non-amplified sound.

“Filter...”. Allows to apply a frequency filter to the current selection. This item is similar to the graphic
equalizer of a hifi chain.

“Reduce background”. Allows to reduce the background noise of a sound. Do not expect miracles from
this function, lost information can simply not be restored! Nevertheless, it works quite fine sometimes,
especially if the sound is not too complicated, for example only a voice speaking. In order to get optimal
results, you’ll probably have to play around with the Expert... function.

The remainder of the Effects menu shows the external filters detected by Amadeus II. For the moment
being, the standard release of Amadeus II contains five filters.
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“Repair”. This effect allows to suppress a crack in a sound. In order to achieve this, first search for the
crack. This can be done for example with the help of the Jump to play position function. Then select the
crack and a very short piece of sound before and after it. Make the selection as short as possible (about
40-50 ms maximum)! Then you can apply the filter. Try different settings to get optimal results.

The actual version of the “Repair” function allows to search automatically for cracks.

“Reverse”. This effect simply makes a time-reversal of the selected sound.

“Simple generators”. This effect allows to generate simple sounds like sine waves, silence or white
noise.

“Fading”. This effect allows to make fade-ins or fade-outs of various types. To change the type of the
fading, open the Settings... dialog and select one of the four different types.

“Set Pitch...”. This effect allows to physically change the pitch of a portion of the sound.

3.6 The “Analyze” menu.

“Spectrum”. Makes a spectral analysis of the selected sound and stores the result in a 7 �����(�����8�5$��
	�/�*�$
.

“Animated Spectrum”. Makes an animated spectrum out of the selected portion of sound. You have to
select at least 10’000 samples (which corresponds approximately to 0.5 seconds of a sound sampled at
22’050 kHz). The modal box that shows up when you select this function allows you to select the number
of spectra per second that are to be computed and the maximal frequency that shows up. If the original
sound is a stereo sound, it also allows you to show both channels.

This function may use a lot of memory since the spectra are always stored in RAM.

“3D Spectrum”. Makes a 3D spectrum out of the selected portion of sound. You have to select at least
10’000 samples (which corresponds approximately to 0.5 seconds of a sound sampled at 22’050 kHz).
The modal box that shows up when you select this function allows you to select the total number of spectra
and the maximal frequency that shows up.

This function may use a lot of memory since the spectra are always stored in RAM.

“Sonogram”. Creates a sonogram from the current selection.

“Real-time spectrum”. Opens a window which shows a real-time spectral analysis of the sound entering
into the current sound input device. There are many options to affect the display of the spectrum. The
“preemphasis” option allows to amplify artificially the high frequencies.

This function seems to me a great pedagogical tool to show how a note is composed of a fundamental
frequency and its harmonics for example.

“Oscilloscope”. Opens a window that shows in real-time the sound entering into the current sound input
device.

4 Registering

The file saving and scrap exporting functions are the only functions that are disabled in the demo version.
Everything else can be accessed. If a function seems to be disabled, it means either that it is not accessible
in the current state of the program or that it is not implemented yet.
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Registering Amadeus II enables the file saving and scrap exporting functions. Moreover, you will be put
in a mailing list that keeps you informed about every new version. If you want to be removed from that
mailing list, just tell me at
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The registration fee for Amadeus II is 25$ US, to be paid to Kagi, not to me directly (It costs me about
7$ to cash a cheque). Kagi will the provide you with a serial code, which has to be entered in the
Registration... dialog of the Apple menu. If, for any reason, Kagi processes your payment but does
not provide you with a serial code, please send me an email and I will provide you with one. For more
information about registering, see the “Read Me (Register)” file in the “Register” folder.


