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Adobe PageMaker 7.0 Filters

 

NOTE TO REVIEWERS: Before I edit this document 

extensively, I want to find out which large sections, if 

any, we can cut. Please check for accuracy and irrele-

vance.

 

This document contains basic information on the 

following import options:

 

Text file formats

 

•

 

Microsoft Word 97/98/2000/20001 for Windows

 

•

 

Microsoft Word 6/7 and RTF

 

•

 

Microsoft Excel / Lotus 1-2-3 Spreadsheet

 

•

 

Corel WordPerfect 6.0-8.0

 

Graphic file formats

 

•

 

Graphic file formats with special import options

 

•

 

Adobe Illustrator Import Filter

 

•

 

Adobe Photoshop Import Filter

 

•

 

Placed PDF Import Filter

 

•

 

Encapsulated PostScript Import Filter

 

•

 

Portable Network Graphics (PNG) Filter

 

•

 

QuickTime Image Import Filter

 

Importing Microsoft Word files

 

The Microsoft® Word import filter lets you import 

Word 97 (Word 7.0), Word 98 (Word 8.0), Word 

2000, and Word 2001 documents into Adobe® 

PageMaker®. If you hold down Shift while you 

double-click the file in the Place dialog box, you 

can specify import options. These options vary, 

depending on which version of Word the 

document was saved in.

For more information on importing word-

processed documents, see the 

 

Adobe PageMaker 7.0 

User Guide

 

. 

 

To place a Word 97/98/2000/2001 file:

 

1

 

In PageMaker's layout view or story editor, 

choose File > Place. PageMaker lists Word files 

with a .doc extension. In Windows, to see a valid 

file without the extension, choose All Files for Files 

of Type. 
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Do one of the following:
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To open the file using the default import 

options, double-click the Word file.

 

4

 

To display the filter preferences dialog box select 

Show Filter Preferences, or hold down Shift while 

you double-click the file. 

 

5

 

If the filter preferences dialog box appears, select 

options for importing Word features as desired. 

For details on setting preferences in the dialog box, 

see the sections below.
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Position the loaded text icon where you want 

the top of the first text block to be, and then click 

to begin flowing the text. 

 

Setting filter preferences for Word 
97/98/2000/2001

 

The Microsoft Word Import Options dialog box 

displays options for importing Word 

97/98/2000/2001 documents. The options you 

select in the dialog box remain in effect until you 

change them or exit PageMaker. The dialog box 

includes the following options:
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Include

 

Imports the following selected items as 

part of the text in the story: Table of Contents Text, 

Index Text, Hyperlink Formatting, Table Contents, 

and Footnotes/Endnotes. For example, if you 

select Table of Contents, the text in the table is 

imported as tab-delimited text; if you select 

Footnotes/Endnotes, footnotes and endnotes are 

imported at the end of the story.

 

Condensed/Expanded Spacing To

 

Interprets 

condensed or expanded spacing as range tracking 

when you select Tracking, or as the set width of 

characters when you select Kerning.

 

Page Break Before Paragraph As

 

Determines how 

page breaks from the word-processing file are 

formatted in PageMaker. You can select Page Break 

Before, Column Break Before, or No Break.

 

Setting filter preferences for Word 6–7

 

The options available for placing Word 6.0 and 

Word 7.0 (Word 95) text differ from those available 

for later versions. When you select an older Word 

file and you select Show Filter Preferences, you can 

choose from these settings:

 

Import TOC Entries from Outline

 

Select to 

construct a table of contents based on the outline 

in the imported Word file. This option is selected 

by default. 

 

Import Index Entry Fields

 

Select to construct an 

index from index entries in the imported Word 

document. This option is selected by default.

 

 

 

Horizontal Scale

 

Select to apply the Horizontal 

Scale attribute to any appropriate text in the 

imported Word document that has the character-

spacing attribute set to a non-default value. 

 

Kerning

 

Select to apply the Kerning attribute to 

any appropriate text in the imported Word 

document that has the character-spacing attribute 

set to a non-default value. This option is selected 

by default.

 

Tracking

 

Select to apply the Tracking attribute to 

any appropriate text in the imported Word 

document that has the character-spacing attribute 

set to a non-default value..

 

Import Page Break Before Paragraph

 

Do not 

select this option or PageMaker will be unable to 

place paragraphs that have the Page Break Before 

attribute set in the Word document. Because of 

this, you may be unable to resize a text block in 

PageMaker by dragging its bottom windowshade 

handle (that is, the windowshade snaps back to its 

original position). When this option is unselected, 

the As Page Break Before and As Column Break 

Before options are unavailable. 

 

Import Tables

 

Select to import tables as tab-

delimited text (that is, each row in the table 

becomes a separate paragraph consisting of the cell 

data separated by tabs). 

 

Word features

 

The following Word 97/98/2000/2001 and Word 95 

features either do not import or are changed in 

some way in the importing process.  

 

Word features that do not import

 

•

 

Annotations

 

•

 

Bookmarks

 

•

 

Bullets and numbering created using the Word 

97/98/2000/2001 Format > Bullets and 

Numbering command or Bullets and Numbering 

buttons.

 

•

 

Character styles: emboss, engrave, and double 

strikethrough. Character styles do not import as 

styles, but any attributes in a character style in 

Word 97/98/2000/2001 text are applied to the 

imported text in PageMaker.

 

•

 

Color in revision bars

 

•

 

Comments

 

•

 

Endnotes

 

•

 

Form fields
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•

 

Graphics created with the Word drawing 

commands

 

•

 

Headers and footers. The contents of headers 

and footers do not import. However, headers and 

footers created using Word 97 and later AutoText 

entries (Insert > AutoText > Header/Footer) and 

inserted into the body of the document import.

 

•

 

Hidden text

 

•

 

Hyperlinks (import as colored text without 

links)

 

•

 

Hyphenation attributes at the paragraph level

 

•

 

Kerning for characters above a particular size 

(Kearning for Fonts feature)

 

•

 

Macros

 

•

 

Multilingual documents. Multiple languages 

within a single document import if multiple 

languages and keyboard layouts are installed. (In 

Windows, click Start on the taskbar, choose 

Settings > Control Panel. Double-click Keyboard 

and click the Language tab. In MacOS, choose 

Control Panels > Keyboard.)

 

•

 

Objects from Equation Editor 1.0 or 2.0

 

•

 

OLE 2 objects

 

•

 

Page breaks

 

•

 

Paragraph borders. Borders are only minimally 

supported by the filter. If a paragraph is boxed or 

has any portion of a box applied, PageMaker 

applies a top and bottom rule. Rules are always 

hairline, 100% black, with the same line length as 

the text, with no indents. 

 

•

 

Page borders. Because text imports as a story, 

which can be placed on any page, page borders set 

up in Word 97 and later do not import.

 

•

 

Password-protected Word documents (remove 

password in Word and documents will import)

 

•

 

Shading, foreground colors, and background 

colors

 

•

 

Scrolling text

 

•

 

Sound

 

•

 

Subdocuments of a master document

 

•

 

Styles containing the Word 97 and later Format > 

Bullets and Numbering command or Bullets and 

Numbering buttons

 

•

 

Table-cell height 

 

•

 

Table grid lines and borders

 

•

 

Templates for files

 

•

 

Text shading

 

•

 

Text wrap in tables

 

•

 

Version information

 

•

 

Vertical text within a text box or table cell (US 

English version of PageMaker)

 

•

 

Video

 

•

 

Widow and orphan protection

 

•

 

WordArt graphics

 

•

 

Word spacing and letter spacing attributes at the 

paragraph level 

 

Word borders that change when imported

 

•

 

DASH_LARGE_GAP (imports as dashed line)

 

•

 

DOT_DASH (imports as dashed line)

 

•

 

DOT_DOT_DASH (imports as dotted line)

 

•

 

Triple (imports as thin line, thick line, thin line)

 

•

 

THIN_THICK_SMALL_GAP (imports as thin 

line, thick line)  

 

•

 

THICK_THIN_SMALL_GAP (imports as thick 

line, thin line)

 

•

 

THIN_THICK_THIN_SMALL_GAP (imports 

as thin line, thick line, thin line)

 

•

 

THIN_THICK_MEDIUM_GAP (imports as 

thin line, thick line)

 

•

 

THICK_THIN_MEDIUM_GAP (imports as 

thick line, thin line)

 

•

 

THIN_THICK_THIN_MEDIUM_GAP 

(imports as thin line, thick line, thin line)

 

•

 

THIN_THICK_LARGE_GAP (imports as thin 

line, thick line)
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•

 

THICK _THIN_LARGE_GAP (imports as thick 

line, thin line)

 

•

 

THIN_THICK_THIN_LARGE_GAP (imports 

as thin line, thick line, thin line)

 

•

 

WAVE (imports as single line)

 

•

 

DOUBLE_WAVE (imports as double line)

 

•

 

DASH_SMALL_GAP (imports as dashed line)

 

•

 

DASH_DOT_STROKED (imports as thick 

dashed line)

 

•

 

EMBOSS_3D (imports as thick line) 

 

•

 

ENGRACE_3D (imports as thick line)

 

Notes on Word paragraphs and styles

 

In addition to features that do not import, note the 

following differences in paragraph formatting and 

styles after importing a Word file:

Paragraph attributes are applied to all imported 

table cells for a particular table. Because 

PageMaker does not treat individual table cells as 

paragraphs, paragraph attributes are not applied 

to individual imported cells.

Tables import as tab-delimited text. The paragraph 

formatting from the first cell in each row is applied 

to each paragraph in the imported table text.

Text that wraps in a table cell does not wrap when 

imported into PageMaker, where it appears on one 

line in the imported table cell.

Styles with duplicate names in PageMaker do not 

import. Text having such a style will be formatted 

according to the style definition in PageMaker.

Numbers created with the Format > Bullets and 

Numbering command, whether written as 

numerals or spelled out, import as arabic 

numerals. (For example, 1st, One, or First import 

as the number 1.)

Footnote-numbering that restarts at each section 

or page, or that starts with a number other than 1, 

imports as continuous numbering beginning with 

the number 1.

Table of contents entries created with the Insert > 

Field command do not import. However, table of 

contents entries created by applying a Table of 

Contents style do import.

Cross references containing page numbers import, 

but the page numbers in the cross references will 

be incorrect if repagination in PageMaker causes 

the cross-referenced text to appear on a different 

page in the PageMaker publication from that of the 

Word document.

Text inside frames is imported as paragraphs with 

borders above and below, but the frame positions 

are not preserved. 

 

Microsoft Excel / Lotus 1-2-3 
Spreadsheet Import Filter 4.0 

 

The spreadsheet import filter lets you import 

spreadsheet files from Microsoft Excel for 

Windows and Mac OS, and Lotus 1-2-3 for 

Windows into PageMaker 7.0 (Windows) publica-

tions. The filter can import spreadsheets from the 

following sources:

 

•

 

Excel 4.0 (Windows)

 

•

 

Excel 4.0 (MacOS)

 

•

 

Excel 5.0 (Windows)

 

•

 

Excel 5.0 (MacOS)

 

•

 

Excel 95 (Windows)

 

•

 

Excel 97/98 (Windows)

 

•

 

Excel 2000 (Windows)

 

•

 

Lotus 1-2-3 3.0 (Windows)

 

•

 

Lotus 1-2-3 4.0 (Windows)

 

•

 

Lotus 1-2-3 5.0 (Windows)

 

Importing a spreadsheet

 

This section covers the basic steps for importing a 

spreadsheet into PageMaker. For more infor-

mation, see the 

 

Adobe PageMaker 7.0 User Guide

 

. 
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To import an Excel or 1-2-3 file:

 

1

 

Before importing an Excel file, apply the AutoFit 

command in Excel (select all cells, choose 

Format > Row > AutoFit, and then choose 

Format > Column > AutoFit Selection). AutoFit 

removes unnecessary space by shrinking the 

spreadsheet to fit the widest entry in each column 

and the deepest entry in each row.

 

2

 

In PageMaker's layout view or story editor, 

choose File > Place. PageMaker lists Excel files with 

the .xls extension, and Lotus 1-2-3 files with .wk3 

and .wk4 extensions. To see a valid file without one 

of these extensions, choose All Files for Files of 

Type. 

 

3

 

Double-click the file you want to place. If 

prompted to select a file type, choose Excel/Lotus 

from the list, and then click OK.

 

4

 

When the filter preferences dialog box appears, 

select options for importing as desired. For details 

on setting preferences in the dialog box, see the 

section below.  
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In layout view, position the loaded text icon 

where you want the contents of the first cell to 

appear, and then click to begin flowing the spread-

sheet data. In story editor, the spreadsheet data 

flows automatically into a new untitled story. 

 

Setting filter preferences

 

The filter preferences dialog box displays options 

appropriate for the file's format. The filter type 

appears in its title bar (for example, Excel 97 

Import Filter). 

 

Personal View

 

(Excel 97 and later only) Select the 

name of one of the personal views available for the 

shared workbook. The default is the first personal 

view defined in the workbook. 

 

Sheet

 

Choose a specific worksheet in the selected 

spreadsheet file from the menu. Excel 4.0 spread-

sheets contain only one worksheet, so only that 

worksheet name will appear in the text box. The 

default is the first visible worksheet in the 

workbook.

 

Cell Range

 

Select a predefined cell range from the 

menu, or specify a range by typing the first and last 

cells separated by a colon (for example, A1:Z12). 

Acceptable ranges depend on the spreadsheet. For 

Excel 97/98, the acceptable range is from A1 to 

IV65536. For Excel 95, the acceptable range is from 

A1 to IV16384. For all other supported spread-

sheets, the acceptable range is A1 to IV8192. If no 

range is specified, the entire selected worksheet is 

imported by default. 

 

Cell Alignment Override

 

Choose Spreadsheet's to 

use the same cell alignments as the selected Excel 

or 1-2-3 spreadsheet (this is the default).  If you 

choose Decimal, you can also specify the number 

of decimal places (the default is 3). The Cell 

Alignment Override option is unavailable if you 

select Apply Default Spreadsheet Style.

 

Places

 

Specify the number of decimal places that 

will be imported for all numeric values in the 

spreadsheet. Accept the default value of 3, or type 

a new value (positive whole numbers from 0 to 20).

 

Apply Default Spreadsheet Style

 

Select to apply 

the selected worksheet's default style to the 

imported file.

 

Truncate at Cell Boundary

 

Select to truncate data 

at each cell's boundary. Note that in Excel 97/98, 

cells can contain approximately 32,000 characters 

(up from 255). However, using extremely long 

character strings may slow the filter down.

 

Excel features that do not import

 

The following Excel features either do not import 

or are changed in some way in the importing 

process. 

 

•

 

Borders

 

•

 

Center across selection

 

•

 

Charts

 

•

 

Conditional formats

 

•

 

Data tables

 

•

 

Data validation 

• Dialogs
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• Double underlines (import as single underlines)

• Excel drawings

• Freeze panes

• Height (imports as leading)

• Hidden text

• Horizontal fills

• Hyperlinks and Web links (import as colored text 

without links)

• Improved text

• Internet graphics formats: new GIF and JPEG 

(no inline graphics import)

• Justified text

• Locked

• Macros

• Modules

• Named styles

• Notes

• Objects

• Outlines

• Page breaks

• Patterns

• Pictures

• Protected workbooks 

• Protections

• Report templates (no templates import)

• Rotated text

• Split screens

• Text wrap

• Time-scale axes

• Unlocked cells

• Vertical alignments

• Vertical text

Additional Excel notes

Be aware of the following import issues:

• In general, most visible data in cells import, but 

the operation (such as a formula) that produces 

the visible data does not import. 

• Data in hidden rows and columns import unless 

you hide the row or column by dragging its 

boundary into an adjacent boundary. 

• Vertically aligned text does not import, but the 

row height of the cells containing the vertical text 

imports as a leading value.

• Merged cells import; what is visible in the cell 

imports.

• Page field layouts in PivotTables import; what is 

visible in the cell imports. 

• In Excel 97/98/2000/2001, you can display a list 

of formulas in the PivotTable; what is visible in the 

cell imports.

• In Excel 97/98/2000/2001, you can define refer-

ences to PivotTable data (GETPIVOTDATA); what 

is visible in the cell imports.

• PivotTable formatting imports as long as the 

formatting contains attributes that normally 

import from Excel files (for example, font styling 

imports, but borders and patterns do not).   

• When importing wide spreadsheets, remember 

that text blocks in PageMaker can be no wider than 

21 inches.

• When converting decimals into fractions, the 

filter might provide a slightly different fraction 

than Excel.

• Due to rounding-off errors, some row heights 

may import with values slightly different than 

those specified in Excel. At most, row heights may 

be off by 0.1 (for example, 35 instead of 35.1).

• Although you cannot import charts, you can use 

the Paste command to transfer the chart from 

Excel to PageMaker. If you paste a chart, it becomes 

a graphic object, which you can manipulate in 

PageMaker (by cropping, transforming, and 

applying color) as you would any graphic; 

however, you cannot edit the text. 
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1-2-3 features that do not import

The following Lotus1-2-3 features do not import:

• Background color

• Borders/Lines/Patterns

• Charts

• Custom text

• Designer frames

• Draw objects

• Evenly spaced text

• Named styles

• Objects

• Protections

• Range versions

• Style templates

• Vertical alignment

• Vertical text

• Word wrap across column

Corel® WordPerfect® 6 - 8 Import 
Filter 2.1
The Corel WordPerfect import filter lets you 

import WordPerfect 6.0 - 8.0 (Windows) 

documents into Adobe PageMaker 7.0 (Windows) 

publications. Note that you cannot use this filter 

with PageMaker versions earlier than 6.5.

This filter update includes WordPerfect 7.0 and 8.0 

enhancements not available for the WordPerfect 

6.0 import filter shipped with PageMaker 6.5.   

Using the WordPerfect 6.0 - 8.0 import 
filter

This section covers the basic steps for importing a 

WordPerfect document into PageMaker. For more 

information on importing word-processed 

documents, see the Adobe PageMaker 7.0 User 

Guide, or see the topic of the same name in online 

Help. 

To place a WordPerfect file:

1 In PageMaker's layout view or story editor, 

choose File > Place. PageMaker lists WordPerfect 

files with .wp6, .wp7, .wp8, .wpd or .wp exten-

sions. To see a valid file without one of these exten-

sions, choose All Files for Files of Type. 

2 Double-click the file you want to place. If 

prompted to select a file type, choose WordPerfect 

6.0/6.1/7.0/8.0 or WordPerfect Graphics 1.0/2.0 

from the list, and then click OK.

3 Position the loaded text icon where you want 

the top of the first text block to be, and then click 

to begin flowing the text. 

WordPerfect 6.0 and 6.1 features

The following WordPerfect 6.0 and 6.1 features 

either do not import or are changed in some way 

in the importing process. Most document 

elements, like text characters, import without 

requiring changes, so you can work in the publi-

cation without having to type or import the text 

again. Other elements convert to similar items that 

require adjustments to prepare the publication for 

final output. (For example, PageMaker and 

WordPerfect use styles differently, so the 

formatting created by styles imports but the styles 

themselves do not import.)  

WordPerfect features that do not import

• Automatic kerning (on or off) 

• Automatic page numbering 

• Bar codes

• Charts

• Comments

• Cross-reference codes (index codes are 

imported)

• Diamond, square, and triangle WordPerfect 

bullets

• Draw objects

• Dot leaders for indexes, lists, tables of author-

ities, tables of contents
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• Drop caps

• Equations

• Figures

• Fills

• Font sizes above 650 pts

• Headers and footers

• Hyphenation (on or off)

• Kerning

• Named character styles

• Overstrike text

• Page and column breaks 

• Password-protected WordPerfect files (remove 

password in WordPerfect and files will import)  

• Right hyphenation zones

• Shading

• Sound

• Text art

• Text created with WordPerfect Fonts/Character 

sets (Arabic, Cyrillic, Greek, Hebrew, Japanese, 

Multinational, Phonetic)

• Watermarks

WordPerfect features that change when 
imported

• Bookmarks (import as text)

• Borders (see "Notes on formatting")

• Extended columns (import as sequential 

paragraphs)

• Font formats (see "Notes on fonts")

• Footnotes and endnotes (see "Notes on 

formatting")

• Graphics (see "Notes on graphics")

• Hanging indents (import if created with 

WordPerfect's hanging indent option)

• Hyperlinks (import as colored text, without 

hyperlinks)

• Hyphenation zone  (imports left zone only)

• Index codes (see "Notes on tables and indexes")

• Inline graphics (see "Notes on graphics")

• Insert date (imports as text)

• Insert filename (imports as text)

• Insert path and filename (import as text)

• Insert counter (imports as text)

• Language formatting for English-Australia (see 

"Notes on languages")

• Letter spacing (see "Notes on formatting")

• Lists (import as text)

• Parallel columns (import as sequential 

paragraphs)

• QuickFormat (imports as text)

• Styles (see "Notes on styles")

• Tables (see "Notes on tables and indexes")

• Tabs (see "Notes on tabs")

• Table of authorities (import as text)

• Table of contents codes (see "Notes on 

formatting")

• Text box (imports text only)

Notes on WordPerfect graphics

Graphics saved in the WordPerfect Graphics 

format (.wpg) import as inline graphics. If the 

WPG graphics are anchored at the page or 

paragraph level, they import at the beginning of 

the paragraph. If the graphics are anchored at the 

character level, they import at the correct character 

position.  

Notes on WordPerfect tabs

Be aware of the following import issues:

• The filter imports only a single leader tab 

character per paragraph. If multiple leader tabs are 

used in the same paragraph, the leader character of 

the last leader tab in the paragraph replaces all 

other leader tab characters in the paragraph.
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• The filter will not properly import tab values 

greater than 22.75 inches, nor will indent values 

greater than 22.75 inches have the intended value. 

Any tab settings beyond the 40th tab on the ruler 

will be ignored. 

Notes on WordPerfect fonts 

Font names in WordPerfect, which include the font 

family name plus type styles such as italic and bold, 

import as regular fonts in PageMaker. The type 

style is applied to the regular font. Because 

PageMaker does not recognize Regular as a type 

style, when the WordPerfect font type style is 

Regular, the PageMaker PANOSE font substitution 

dialog box appears and requests a font substi-

tution. You can eliminate the need for this substi-

tution using the following procedure to adjust font 

substitution for WordPerfect regular fonts:

1 Choose File > Preferences > General.

2 In the Preferences dialog box, click Map Fonts. 

3 In the Font Matching dialog box, click Excep-

tions. 

4 In the PANOSE Font Matching Exceptions 

dialog box, click Add.

5 In the Add Matching Exceptions dialog box, 

type <fontname> Regular for Missing Font, where 

<fontname> is the name of the font (for example, 

Arial Regular).

6 Select or type the Substituted Font without the 

word Regular (for example, Arial).

Notes on WordPerfect styles 

Be aware of the following import issues:

• Nesting of character styles within paragraph 

styles can cause some paragraph style codes to be 

ignored if the nested character styles contain text, 

tabs, or indents.

• Only the paired styles at the beginnings of 

paragraphs are imported and added to the 

PageMaker Styles palette. The properties given to 

characters by open styles or paired styles inside 

paragraphs are imported, but the styles themselves 

are not.

• Formatting created by character styles within 

paragraphs is imported, but character styles 

themselves are not imported.

Notes on WordPerfect formatting

Be aware of the following import issues:

• Borders are only minimally supported by the 

filter. If a paragraph is boxed or has any portion of 

a box applied, PageMaker applies a top and bottom 

rule. Rules are always hairline, 100% black, with 

the same line length as the text, with no indents.

• A story's right edge is based on the right margin 

of the first paragraph of the imported document. A 

story's left edge adheres to the 1-inch left margin, 

the standard WordPerfect default setting.

• Some WordPerfect graphics characters that are 

similar to, but not identical with, ANSI characters 

are replaced with those ANSI characters when 

imported into PageMaker. WordPerfect characters 

that are not similar to any ANSI characters are 

imported as spaces.

• Double underlines import as single underlines. 

Outlined, shadowed, and red text import as 

normal text.

• Both footnotes and endnotes import at the end 

of imported text. Footnotes and endnotes are not 

differentiated. They both appear in the same list, in 

the order the reference codes appear in the text. 

Both import with number reference labels, even if 

letter references were specified in WordPerfect.

• Table of Contents codes import only if they 

appear at the start of a paragraph. WordPerfect 

supports five Table of Contents levels. PageMaker 

imports all five WordPerfect levels as PageMaker 

level one.
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• Parallel columns import as linear text, in 

separate paragraphs.

• Letter spacing in WordPerfect set to any 

percentage other than 100% may not import at the 

correct percentage.

Notes on WordPerfect colors

Color names are not saved within the WordPerfect 

file, and therefore cannot be imported. Unique 

substitute names will be provided by the filter, and 

will take the form: 

R<red value> G<green value> B<blue value>  

An example would be: R241 G45 B10, which is 

RGB color 241,45,10. You can change an RGB 

name to a descriptive name (such as olive green) by 

using the Utilities > Define Colors command.

Notes on WordPerfect tables and indexes

Be aware of the following import issues:

• Tables with cells that are joined or split will be 

imported with cells not properly aligned. Cell-level 

alignment and other cell-level formatting will not 

be imported.

• Text that wraps in a WordPerfect table cell does 

not wrap when imported into PageMaker, where it 

appears on one line in the imported table cell.

• Text marked manually for indexing in 

WordPerfect imports into PageMaker with index 

markers. However, text indexed with a concor-

dance file is not imported into PageMaker with 

index markers.

Notes on WordPerfect languages

Be aware of the following import issues:

Only one language per paragraph is imported.

Croatian imports as None instead of srpski-

hrvatski.

English-Australia imports as Australian English 

instead of UK English. 

Notes on WordPerfect pages 

Imported text comes into PageMaker as a story, 

which can be placed on any page. Therefore, there 

is no concept of page numbering and page borders. 

WordPerfect 7.0 features

The following WordPerfect 7.0 features either do 

not import or are changed in some way in the 

importing process. All of the unsupported and 

changed WordPerfect 6.0/6.1 features described 

above apply here as well.

WordPerfect 7.0 features that do not 
import

• Border styles for columns: Column All, Spacing 

Only, Extra Thick (no columns import) 

• Checkboxes via macros

• Diagonal lines within table cells

• Fills that alternate by rows and columns for table 

cells (no fills import)

• Fill gradient specifications: vertical offset, 

horizontal offset, rotation angle (no fills import)

• Highlighted text

• Page numbering (see "Notes on formatting") 

• Features that change when imported

• Border styles for paragraphs: Column All, 

Spacing Only, Extra Thick (import as hairline, 

100% black, with the same line length as the text, 

with no indents)

• Border styles for pages: Column All, Spacing 

Only, Extra Thick, and fancy styles from 

WordPerfect Graphics files (see "Notes on 

formatting")

• Dot leaders for right-aligned text (text imports 

right-aligned without dot leaders)

• Rotated text within a table cell (imports as text 

without rotation)
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Notes on WordPerfect 7.0 formatting

Text imports as a story, which can be placed on any 

page (or pages); therefore, there is no concept of 

page borders.

WordPerfect 8.0 features

The following WordPerfect 8.0 features either do 

not import or are changed in some way in the 

importing process. All of the unsupported and 

changed WordPerfect 6.0/6.1 and 7.0 features 

described above apply here as well.   

• Character (paired-auto) (does not import)

• Drawing order of objects (objects import as 

inline graphics, without order information)

• Flipped graphics (import without flip attribute)

• Graphical styles: Draw Object, Draw Object Text, 

Sticky Note Text (objects import as inline 

graphics)

• Grouped objects (import as ungrouped inline 

graphics)   

• Objects placed with text (objects import as inline 

graphics, without placement information)

• Version control (imports last saved version only)

Graphic file formats
Several kinds of files can be imported with special 

preference settings. This section lists those 

formats, and explains the preference settings you 

can select. All options selected in the dialog box 

remain in effect until you change them or exit 

PageMaker. 

To select preferences, do one of the following:

• Select the Show Filter Preferences option in the 

Place dialog box.

• Press Shift while you double-click any of the 

following files or file formats in the Place dialog 

box:

• .CDR files from CorelDraw versions 3.0-5.0

• AutoCad DXF files

• .GEM files

• HPGL files (such as those saved from CorelDraw 

or AutoCad)

• Macintosh PICT graphics

• Lotus PIC graphics

• WordPerfect Graphics versions 1 and 2

The options available in the filter dialog box are:

• Retain Gradients. When checked, a graphic 

imports with color gradients. Otherwise, a solid 

color is applied.

• Retain Background. When checked, a graphic 

imports with the background set by the appli-

cation that created it. Otherwise, the graphic 

imports with a white opaque background.

• Emulate Line Style. When checked, a graphic 

imports with shapes that simulate the various line 

styles provided in the software that created the 

graphic. This slows down the import process.

• Import Colors lets you select one of five options 

for handling colors and grays in the graphic.

Adobe Illustrator Import Filter

The options available in the filter dialog box are:

• Spot color options. To ensure accurate spot color 

separations, you can choose to add spot color 

names to the PageMaker Colors palette when 

importing a native Illustrator file. Alternatively, 

you can choose to exclude spot colors, in which 

case the spot colors will be converted to process 

color for separations.

• Preview options. Specify a suitable dots-per-inch 

(DPI) setting for the screen preview that is 

generated when a native Illustrator file is 

imported. You can also select between 256 colors 

and millions of colors for the screen preview. In 

either case, the preview will not effect how the 

Illustrator file is printed, with the exception of PCL 

output.
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Placed PDF Import Filter
The PDF import filter lets you place any single 

page from an Adobe Portable Document Format 

(PDF) file into a PageMaker publication. Using the 

PDF import filter, you can reuse existing PDF 

documents in imaginative and meaningful ways. 

For example, you can select an individual page 

from a catalog saved as PDF and place it into an ad 

or brochure you're creating in PageMaker, thereby 

streamlining workflow and saving time. In 

addition, the PDF Import filter lets you control the 

resolution of the on-screen preview for faster 

performance, yet provides reliable, high-quality 

output to PostScript devices.

The placed PDF is similar to a placed EPS graphic 

in PageMaker in the following ways: the PDF 

appears in the PageMaker publication as an on-

screen preview, using the preferences from the 

filter preferences dialog box; you cannot edit 

objects in the PDF; the PDF always prints at high 

resolution when printed to a PostScript device, but 

prints at the resolution of your screen preview 

when printed to a non-PostScript device. Adobe 

does not recommend using PDFs for graphics or 

text if outputting to non-PostScript devices where 

high resolution is needed.

Importing a PDF page

This section covers the basic steps for importing a 

PDF page into PageMaker. 

To import a PDF page:

Before importing, make sure the PDF document 

contains no security settings.

1 In PageMaker's layout view, choose File > Place. 

In Windows, PageMaker lists PDF documents with 

a .pdf extension. To see a valid file without that 

extension, choose All Files for Files of Type. 

2 Double-click the file to place it, or select the file 

and click Open. If prompted to select a file type in 

Windows, choose Portable Document Format 

from the list, and then click OK.

3 In the filter preferences dialog box, select 

options for importing specific pages, and for 

including PostScript® printing information and 

display settings. For details on setting preferences 

in the dialog box, see the section below.

4 Position the graphics icon where you want the 

PDF to be and click. 

If you have trouble placing the PDF page, try 

opening the document in Acrobat Exchange® and 

saving the document with a new filename. If the 

PDF does not import as expected, see the section 

"Workflow issues" later in this document. 

Setting filter preferences

The PDF Import Filter dialog box displays options 

for including certain PostScript printing infor-

mation and display settings. The dialog box 

includes the following options:

Navigation Arrows Use the arrows beneath the 

thumbnail image to advance through the PDF 

document page by page. A thumbnail image of 

each page appears in the dialog box. The default 

page number is 1.

Page Button Click to display a dialog box where 

you can specify a page number, and then click OK 

to select the page. 
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Ignore Any Halftone Screens  A halftone screen 

(also known as screen frequency, screen ruling, 

screen angle, and line screen) is the number of 

halftone dots that print per inch measured in lines 

per inch (lpi). Select the option to ignore halftone 

and lpi information that was saved with the PDF 

document when it was created. Deselect the option 

to include the information. This may be useful if a 

graphic's lpi was set for a special effect (such as 

heavy lines) and you want to maintain that effect in 

PageMaker. The default setting is on, or the last 

setting applied in the PDF Import Filter dialog 

box.

Note: In Acrobat® Distiller® 3.0 or later, the Preserve 

Halftone Screen Information option must have been 

selected when the PDF was created for this filter 

preference to have any effect. (In Distiller, choose 

Distiller > Job Options, and then click the Advanced 

tab.) You can override Distiller's options from within 

PageMaker using the Export PDF plug-in.  

Entire Page Select to specify a bounding box that 

matches the size of the physical page. A page-size 

PDF will be imported.

Content Area Select to specify a bounding box 

around only the objects on the page. The placed 

PDF will be the cropped version of the page. The 

default setting for this option is on, or the last 

setting applied in the PDF Import Filter dialog 

box. Be aware of the following import issues: 

If the PDF contains text, the bounding box will 

grow to accommodate bold italic attributes, 

regardless of the applied type styles. As a result, 

when the Content Area option is selected, most 

text-intensive PDFs will include extra white space 

on the right side of the text. 

If the bounding box includes a stroked object, the 

box will expand when imported to accommodate 

the width of the stroke, adding white space around 

the PDF. 

Note that in either case the extra white space won't 

print. You can manually crop the extra space, or 

use EPS format instead of PDF.

Resolution Type a value from 18-300 for the 

resolution of the preview, which is the on-screen 

representation of the PDF page in PageMaker. The 

preview resolution affects file size but does not 

determine output resolution on a PostScript 

device. To minimize file size and speed up 

importing, use 72 dpi (dots per inch) or less. The 

default is 72, or the last setting applied in the PDF 

Import Filter dialog box.

Note: For best results when printing to a non-

PostScript device or creating an HTML page from a 

PageMaker publication with a placed PDF (Export > 

HTML), use 72 dpi or higher and select Millions for 

Color Depth (see next option). Be aware that this 

may significantly increase the time required to 

import the PDF and increase the file size.

Color Depth Select a value for the color depth of 

the preview, which is the on-screen representation 

of the PDF page in PageMaker. Like Resolution 

above, the value for Color Depth affects file size 

but does not determine output resolution on a 

PostScript device. To minimize file size and speed 

up importing, use 256. The default is 256, or the 

last setting applied in the PDF Import Filter dialog 

box.

Note: If a memory alert appears, or if the preview 

creation fails and a gray box appears, try reducing 

the preview's resolution or color depth. The 

resolution and color depth are limited by the 

computer's capabilities. If a gray box appears, the 

PDF will still print to a PostScript device.

Estimated Size Represents the approximate 

number of bytes that will be added to the 

PageMaker publication.

Placed PDF import filter features

The following PDF features do not import:

• Bookmarks

• Forms

• Hypertext links 

• Indexes
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• Notes

• QuickTime movies

• Thumbnails

• URLs

• Workflow issues

A completely digital workflow based on PDF will 

ultimately provide everyone in the publishing 

lifecycle with a streamlined production process 

that is reliable and consistent. As PDF evolves, the 

incompatibilities that result from flattening 

PostScript information to create the PDF, and then 

recreating the PostScript information for color 

separations or other uses, will be resolved. This 

section provides solutions for known workflow 

problems when using the PDF Import filter.         

Color models  in PDF import

For accurate results, color models used in PDF 

documents must match the intended output. For 

example, use CMYK for printing, and RGB for on-

screen viewing. Do not use RGB or a device-

independent color model (for example, CIE 

L*a*b) if printing separations generated by 

PageMaker; all the pages will print on the black 

plate. 

When a PDF document containing CIE color is 

placed in a PageMaker publication, the message 

"Page contains CIE color. Special separations 

handling required" appears. This message appears 

only during placement, not when creating color 

separations, so a prepress service provider may not 

know that color separations will not be created. 

To ensure accurate results, do one of the following:

• Return to the creating application and change 

the color model to CMYK.

• Create in-RIP separations, as described below. 

The output device must support in-RIP separa-

tions and must be PostScript version 2017.103 or 

later. 

Important: To determine if color separations will 

image correctly, Adobe recommends creating color 

proofs using an Adobe-licensed PostScript device. For 

more information on creating color proofs, see the 

Adobe PageMaker 7.0 User Guide.

To create in-RIP separations:

1 With the PageMaker publication open, choose 

File > Print.

2 Click Color.

3 Select Separations, and then select Perform on 

Printer. 

4 Set other print settings as needed, and then click 

Print (or click Save to create a PostScript file).

For more information on printing color separa-

tions, see the discussion beginning on page 405 of 

the Adobe PageMaker 7.0 User Guide. 

Spot colors in PDF import

Sometimes separation color spaces (spot colors) 

convert to process colors or are not supported at 

all, depending on the creating application. When 

importing a PDF, be aware of the following spot 

color issues:

Adobe PageMaker No issues using Distiller 3.0 or 

later.

Adobe Photoshop® 3.x or later Spot colors are 

not supported. If spot colors are required, do not 

use PDF. Save the file as EPS.

Adobe Illustrator® 7.0 or 7.01 Spot colors are not 

supported if the Save as PDF command is used. To 

preserve spot colors, save the file as EPS, and then 

distill the file in Distiller 3.0 or later using the 

prologue.ps and epilogue.ps files. (See the 

procedure below.)
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Adobe FrameMaker® 5.x To preserve spot colors, 

create a PostScript file and then distill it in Distiller 

3.0 or later using the prologue.ps and epilogue.ps 

files. (See the procedure below.)

Macromedia FreeHand 7.x Spot colors are not 

supported if the Save as PDF command is used. To 

preserve spot colors, save the file as EPS, and then 

distill the file in Distiller 3.0 or later using the 

prologue.ps and epilogue.ps files. (See the 

procedure below.) 

QuarkXPress 3.3 or later To preserve spot colors, 

create a PostScript file using the Luminous or 

Imation Prepress XTension instead of using the 

Save Page as EPS command in QuarkXPress. Then 

distill the file in Distiller 3.0 or later using the 

prologue.ps and epilogue.ps files. (See the 

procedure below.)

To use the prologue.ps and epilogue.ps files:

1 Move the prologue.ps and epilogue.ps files from 

the Distillr:XTras:high_end folder into the same 

folder as the Distiller application. (For more infor-

mation, see the Readme.txt file in the same 

location.)

2 In Distiller, choose Distiller > Job Options, and 

then click the Advanced tab.

3 Select the Distill with prologue.ps / epilogue.ps 

option and click OK.

Spot color names (PageMaker issue only)

Spot colors named Red, Green, or Blue have special 

implications in the PostScript language. Because of 

this, PDFs created in PageMaker using colors 

named Red, Green, or Blue and placed back into 

PageMaker will not separate as expected. To print 

color separations, open the original file in 

PageMaker, rename the Red, Green, and Blue 

colors (for example, Red1 or Red-1), create a new 

PDF document, and then import the PDF into 

PageMaker. 

High-fidelity colors

High-fidelity colors are not supported by Distiller 

3.x or earlier. Distiller converts high-fidelity colors 

to RGB or CMYK according to user-selected 

options. If high-fidelity colors are required, use 

EPS or TIFF format instead of PDF. 

Overprinting 

An imaging problem occurs when printing color 

separations in PageMaker if you apply a process 

color to an 8-bit or 1-bit image in the placed PDF 

and set the color to overprint.  The image will 

knock out rather than overprint. Note that a 

process color applied to a PageMaker-drawn object 

or text will overprint as expected. 

Duotones 

Duotones included in placed PDFs will not print as 

expected from PageMaker. Duotones are designed 

for color separations, not for composite output. 

Since a PDF is a composite representation of your 

file, the PDF no longer contains enough DCS and 

EPS duotone information for color separations to 

print correctly. The resulting separations will not 

match the original duotone file.

Clipping paths

PageMaker prints clipping paths used in PDF 

graphics only if the PDF document was distilled 

with Distiller 3.0 or later. For example, clipping 

paths in PDF documents created using the Save as 

PDF command in Photoshop 4.0 or 4.01, or  

Adobe Illustrator 7.0 or 7.01 do not import. If a 

clipping path is required, return to the creating 

application, save the document as a PostScript file, 

and then distill the PostScript file in Distiller 3.0 or 

later. 
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Font substitution  

If the required fonts are not embedded in the PDF 

document or available on your computer, the PDF 

Import filter substitutes Courier for the missing 

fonts. To verify that fonts are in the PDF or on the 

computer, open the PDF in Acrobat Exchange, 

choose File > Document Info > Fonts. If the font 

under Used Font is either Adobe Serif MM or 

Adobe Sans MM, Courier will be substituted when 

the PDF is placed in PageMaker. The on-screen 

preview will always look like the original 

document, but Courier will be substituted when 

the document is printed to a PostScript device. 

The EPS Font Scanner plug-in (if installed) should 

detect the missing fonts and display a dialog box 

with appropriate information. For more infor-

mation on how to use the plug-in, see the Adobe 

PageMaker User Guide. 

To ensure correct font handling, do one of the 

following: 

• Return to the creating application and embed the 

fonts in the PDF document. 

• Install all required fonts on your computer. 

• Confirm that your printer contains the required 

fonts.

Illustrator and multiple master fonts

To embed Adobe multiple master fonts in a PDF 

file from Illustrator 6.0 or later, save the file as an 

EPS, and then distill the EPS in Distiller 3.0 or 

later.

Additional troubleshooting

This section contains tips for avoiding additional 

problems when using the filter.

The PDF Import filter always stores PDFs in the 

publication, and the Store Copy in Publication 

option is selected by default in PageMaker's Link 

Options Defaults dialog box (Element > Link 

Options). If you intend to print the PDF, do not 

deselect this option, or the PDF will be lost.

PageMaker incorrectly displays the message "One 

or more of the linked items in this publication may 

not print as expected" if you attempt to print a file 

with a placed PDF to a PostScript device and do 

not have the PDF Import filter installed. You can 

print to a PostScript device anyway, which will 

produce high-resolution output, or install the 

filter. 

Encapsulated PostScript Import 
Filter
The options available in the filter dialog box are:

• Add process and high fidelity color names to 

palette.

• Import nested DCS images for separations.

• Read embedded OPI image links.

• Spot color options. To ensure accurate spot color 

separations, you can choose to add spot color 

names to the PageMaker Colors palette when 

importing a native Illustrator file. Alternatively, 

you can choose to exclude spot colors, in which 

case the spot colors will be converted to process 

color for separations.

• Preview options. Specify a suitable dots-per-inch 

(DPI) setting for the screen preview that is 

generated when a native Illustrator file is 

imported. You can also select between 256 colors 

and millions of colors for the screen preview. In 

either case, the preview will not effect how the 

Illustrator file is printed, with the exception of PCL 

output.

• Create Preview if None Exists. Select this option 

to generate a preview for an EPS file. The preview 

will not affect printing to PostScript, but will be 

used when the file is printed to a printer using PCL. 

When this option is deselected, no preview will be 

generated and a gray box will be displayed for EPS 

files that have no preview.

• Always Create Preview. Select this option to 

generate a new preview of the imported graphic. 

This will replace the preview normally displayed in 

PageMaker.
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Portable Network Graphics (PNG) 
Filter 
The new PNG graphics filter lets you place 

graphics stored in the Portable Network Graphics 

(.png) file format into PageMaker publications. 

The PNG format was developed by a consortium 

of technology companies as a patent-free alter-

native to GIF (Graphics Interchange Format) for 

portable, well-compressed storage of bitmap 

images. The PNG format can store up to 16 bits 

(grayscale) or 48 bits (True Color) per pixel, and 

up to 16 bits of alpha data. In addition, PNG can 

store gamma, transparency, and textual infor-

mation. PNG handles the progressive display of 

image data, and uses an efficient lossless form of 

compression that reduces file size without 

discarding data. 

Importing a PNG graphic

This section covers the basic steps for importing 

PNG graphics into PageMaker. For more infor-

mation on importing graphics, see the Adobe 

PageMaker User Guide. 

To place a PNG graphic:

1 In PageMaker's layout view, choose File > Place. 

PageMaker lists PNG graphics files with a .png 

extension. To see a valid file without that 

extension, choose All Files for Files of Type. 

2 Do one of the following:

• Select the file you want to place. To display the 

filter preferences dialog box for more options 

associated with the graphic, make sure the Show 

Filter Preferences option is checked, and then click 

Open.

• Double-click the file to place it, or hold down 

Shift while you double-click to display the filter 

preferences dialog box before placing the graphic. 

3 If prompted to select a file type in Windows, 

choose PNG Import Filter from the list, and then 

click OK.

4 If the filter preferences dialog box appears, select 

options for using transparency information or 

applying gamma correction as desired. For details 

on setting preferences in the dialog box, see the 

section below.

5 Position the graphics icon where you want the 

top of the graphic to be and click. 

Setting filter preferences

The PNG Import Filter v1.0 dialog box displays 

transparency and gamma information that was 

saved with the PNG graphic by the creating appli-

cation (for example, Adobe Photoshop®), which 

you can change before placing the graphic into 

PageMaker. The dialog box includes the following 

options:

Use Transparency Information The import filter's 

transparency options let you designate a color for 

certain PNG graphics that contained transparency 

information. If the PNG graphic included a 

selected area saved as an alpha channel or was 

created from an indexed-color image with one 

color designated as transparent, you can make the 

unselected or transparent areas white, gray, or the 

background color that was saved with the file (if 

any).

White Background If the PNG graphic does not 

contain a file-defined background color, the White 

Background option will be selected by default. You 

can accept the white background, or click the Use 

Transparency Information to deselect it and 

import the graphic with a gray background.  
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File Defined Background Color If the PNG graphic 

contains a background color, this option will be 

selected by default. Using a file-defined 

background color is useful if, for example, you will 

display the PNG graphic on a Web page with the 

same background image or color, and you want the 

graphic to blend into the background. You can 

accept the background color, click to deselect the 

option so the graphic imports with a gray 

background, or click the White Background 

option to change the background color to white. 

(Changing the background to white may be useful 

if, for example, the graphic was created with a 

background color for a specific paper color and 

you want to use the same graphic on white paper.)  

Apply Gamma Correction The PNG filter lets you 

adjust image gamma (the contrast of midtones 

relative to the highlights and shadows in the 

graphic) before you place the PNG graphic into 

PageMaker. This correction option lets you match 

image gamma to the gamma of the device you will 

use to print or display the graphic (such as a 

desktop printer or computer monitor). 

If the PNG graphic contains gamma information, 

this option will be selected and the value saved 

with the file will appear in the box next to Gamma 

Value.

Gamma Value The Gamma Value edit box is 

available only if Apply Gamma Correction is 

selected. You can accept the default gamma value 

that was saved with the graphic, adjust the gamma 

value for use in PageMaker, or remove it by 

deselecting the Apply Gamma Value option. If the 

PNG graphic does not contain a gamma value, you 

can select the Apply Gamma Correction option. 

The value will default to 1.0. To change the value, 

type a positive number from .001 to 3.0.

Note: Unless you know what gamma value to use 

based on experience with the output device, it's best 

not to change the default value.   

Additional PNG notes

Be aware of the following import issues:

• PNG graphics placed in a PageMaker publication 

convert to JPEG (Joint Photographic Experts 

Group) format when exported to an HTML 

document (File > Export > HTML). If you prefer 

GIF (Graphics Interchange Format), you can 

convert the graphics to GIF by setting that option 

in the Export HTML dialog box. (Choose File > 

Export > HTML, click Options, select All to GIF, 

and then click OK.) 

• Color PNG graphics placed in a PageMaker 

publication are RGB bitmap images, so they print 

only as composites, not color separations.

• Photoshop 4.x does not provide a way to define a 

background color when exporting an image to 

PNG. This means that you won't be able to add a 

background color to the PNG graphic as you can 

when exporting to GIF. 

QuickTime Image Import Filter
The QuickTime image filter displays a Preferences 

dialog box when you import a file. The dialog box 

options are:

• Volume. Controls the volume of the movie 

soundtrack.

• Play button. Starts the movie playback. Click this 

button during play to suspend playback. (You can 

also double-click the movie to start playback.)

• Slider control. Use to move directly to a new 

frame in the movie.

• Left/Right nudge control. Use to advance one 

frame at a time in any direction.


