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iGrafx Professional 2000

Welcome to iGrafx Professional 2000

Welcome and thank you for buying iGrafx Professional 2000. iGrafx 
Professional is an intelligent business diagramming and modeling 
solution designed for knowledge workers, managers, and IT 
professionals. With the intuitive ease of use of iGrafx Professional, it has 
never been easier to create free-form, structured, network, process, 
software, and presentation diagrams.

iGrafx Professional Features

• Intelligent Departments

• Automatic Connectors

• Automatic Off-page Connectors

• Unlimited Page Size

• Powerful Graphics Engine

• Powerful, Flexible Shape Numbering

• Automatic Fit-to-Text

• Crossovers and Intersection Dots

• Multiple Text Areas

• Multiple Fonts, Interline Spacing, Paragraphs, Bullets within Shap

• Visual Basic for Applications 6.0 Support

• VBA iShapes

• Integrated VBA Programming Interface
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• Web Support (HTML and Java)

• 20+ filters, including: CGM, DWG, and Visio®

System Requirements

The minimum system requirements for installing and running iGrafx
Professional are listed below. 

• Pentium processor

• Windows 95, 98, or Windows NT 4.0 or higher

• 16 MB RAM for Windows 95 and 98; 32 MB RAM for NT

• At least 50 MB of hard drive space

• 640x480 256 color monitor (800x600, 16-bit color recommended

• CD-ROM drive

• Mouse or other pointing device

Installing iGrafx Professional

1 Insert the Application CD-ROM in your CD-ROM drive. The 
Setup program automatically starts.

2 Follow the instructions on the screen. The Setup program guide
you through the installation.

The Typical Installation installs all applications included with 
iGrafx Professional and is the recommended installation type.

The Compact Installation saves disk space by installing only the
minimum files required to run each component.
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The Custom Installation lets you choose which applications to 
install. You can also select specific filters to install.

Note
If you don’t have enough disk space to install your selection, you 
can clear off more disk space or change to a location on your hard 
drive where more disk space is available.

Installing Fonts

Windows requires that fonts be installed to the same drive where 
Windows is located. If your computer’s hard disk drive is set up as m
than one drive (for example, drive C: and drive D:), you can choose
install iGrafx Professional to any drive, but you must have enough dis
space available for fonts on the drive that contains Windows.

Uninstalling iGrafx Professional

You can use Windows Add/Remove Programs to uninstall the entire
iGrafx Professional package. For more information on Add/Remove 
Programs, click Help on the Windows Start menu.
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Technical Support

Getting the most out of your investment is central to your success. T
is why we have developed a fee-based support program for register
users in the U.S. and Canada that delivers fast, flexible, and 
comprehensive service for the Micrografx products you own. This 
program is backed by our commitment and all the resources necess
provide you with the service you expect.

Our staff of experienced technical advisors are specialists in the crit
areas and applications important to you. Our experts can assist call
quickly and efficiently.

Complimentary Support

As a registered iGrafx Professional  customer, you are entitled to thirty
days of complimentary support following your first call to our technic
support staff.

You can receive technical support from a technical support advisor 
between the hours of 7:00 a.m. and 5:00 p.m. (Central time), Mond
Friday.

To contact technical support during this time, call (972) 234-2694.

You can fax your questions to (972) 644-3688.

Contact Micrografx through the Internet as follows:

http://www.mgxsupport.com
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Thereafter, whether you want full-service coverage or occasional 
support for your Micrografx products, you will like the flexibility of 
choosing only those services you need.

Using Online Documentation

Online documentation, found in Adobe® Acrobat® PDF format, contains 
all reference materials found in Help and information found in the us
guide. Access the PDF documentation by clicking the Start button, 
pointing to Programs, iGrafx, and then Documentation. The PDF 
documentation is also located on the Application CD-ROM as 
uncompressed files.

Learning About Help

To use iGrafx Professional more effectively, we designed an integrated
online help system using the familiar Windows 95 help system with 
three tabs, Contents, Index, and Find. You access this help system 
through the Help menu on the application.

In addition, help information for iGrafx Professional  is accessible 
through context-sensitive online help. The help system is designed 
that you can easily find the information you want—from conceptual 
topics, to specific procedures, to detailed information on buttons, to
and dialog boxes—with just a few mouse clicks.

The most up-to-date information regarding iGrafx Professional  can be 
found in the Readme.txt on the root of the CD.
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Using iGrafx Professional

This chapter covers the following topics:

• Using Toolbars and Tool Palettes on page 26

• Using Menus and Commands on page 51

Using Toolbars and Tool Palettes

iGrafx Professional uses toolbars and tool palettes to provide much of
functionality. Toolbars contain icons that provide a set of related tool
For example, the Formatting toolbar contains tools for formatting 
elements of the diagram or model. With Tool palettes, you can selec
from a palette of styles or colors. For example, there is an Arrowhea
tool palette for selecting the direction of an arrow or style of an 
arrowhead. There are color palettes for text, lines, and fills.

You can display the following toolbars:

• Standard

• Formatting

• Toolbox

• Draw

• Preset Styles

• Data

• iDiagram
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not 
• Visual Basic

• Model

Customizing Toolbars

When customizing, you can:

• Show the toolbars you are using, and hide the toolbars you are 
using.

• Drag and dock the toolbars.

• Create new toolbars.

• Delete any toolbars you have created and no longer want.

• Add tools to existing toolbars (including the tools on the default 
toolbars).

• Remove tools from toolbars (including the tools on the default 
toolbars).
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Tips
You can resize your Font box, or any other drop-down box, on the 
toolbar while the Customize dialog box is open.  To open the Customize
dialog box, click Customize on the Tools menu.

You can add over 20 custom toolbars that show up in the shortcut men
(displayed when you right-click in the toolbars area).  You must use the
Toolbars command on the View menu to see them. (The number of 
toolbars you can view on the shortcut menu varies depending on your 
screen resolution.)

You can return the Micrografx-supplied toolbars to the way they were 
when you installed the program. To do this, on the View menu, click 
Toolbars. Click the toolbar to reset, and click Reset. Any tools you have
added are removed. Any tools you have deleted are replaced.

You can drag tools off a toolbar. To do this, click on the tool to remove 
and drag it off the toolbar. Note that you cannot undo this action.

Standard Toolbar

The Standard toolbar contains tools that help you perform basic 
functions in iGrafx Professional. Most of these functions appear as 
commands in the File and Edit menus.

Tool Name Description

New Creates a new diagram.

Open Opens a previously existing 
diagram.
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Save Saves the active diagram.

Print Prints the active diagram.

Print Preview Shows the diagram as it looks when 
you print it.

Spelling Checks the spelling of text in your 
diagram.

Cut Removes the selected item and 
places it on the Clipboard.

Copy Copies the selected item and places 
it on the Clipboard.

Paste Places the contents of the 
Clipboard on the diagram.

Format Painter Copies the formatting of the 
selected text, shapes, or lines to 
other text, shapes, or lines.

Undo Undoes an action or change.

Redo Reverses the last undo you made.

View Shape 
Palettes

Shows or hides the Shape palette.

Draw Opens the Arrange Toolbar.

Properties Opens the Properties dialog box.
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Zoom Control Magnifies the diagram by the 
percentage you select or enter.

Help Displays information about the 
item you click next.
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Formatting Toolbar

The Formatting toolbar gives you easy access to the options you us
define the way text, lines, and shapes look in your diagrams. Additio
formatting options are available on the Format menu.

Tool Name Description

Font Name Displays and changes the 
name of the current font. 

Font Size Shows the current point 
size. 

Bold Turns text bold (or 
removes bold, if it is 
already bold).

Italic Turns text italic (or 
removes italic, if it is 
already italic).

Underline Underlines text (or 
removes underline, if it is 
already underlined).

Opaque Makes the text’s 
background transparent.

Text Color Applies color to text.

Vertical Align Specifies Top, Middle, or 
Bottom alignment. Click 
the tool and then choose 
from the menu.
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Horizontal 
Align

Specifies Left, Center, or 
Right alignment. Click the 
tool and then choose from 
the menu.

Insert Field Inserts a new field into a 
shape.

Bullets Makes selected text a 
bulleted list.

Decrease 
Indent

Moves paragraph to the 
left.

Increase 
Indent

Moves paragraph to the 
right.

Increase Line 
Spacing

Increases line spacing in 
selected text.

Decrease Line 
Spacing

Decreases line spacing in 
selected text.

Rotate Text 
Left

Rotates text 90 degrees to 
the left.

Rotate Text 
Right

Rotates text 90 degrees to 
the right.
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Tips
You also can use the commands on the Format menu to specify format
text color, fill color, line color, line styles, line weight, styles for filled 
lines, arrowhead styles, crossover styles, shadows, and 3D effects.

There are also shortcut keys for vertically aligning shapes: Top 
(CTRL+SHIFT+4), Middle (CTRL+SHIFT+6), Bottom 
(CTRL+SHIFT+8).

There are also shortcut keys for horizontally aligning shapes: Left (+3), 
Center (CTRL+SHIFT+5), Right (CTRL+SHIFT+7).

When you click the down arrow next to a color tool, a palette of colors 
opens. If you click a color, the program applies it to the next shape or 
currently selected shapes. To set a custom color, click More Colors, an
the Color dialog box opens.

Toolbox Toolbar

The Toolbox toolbar gives you easy access to the tools you use mo
create and change diagrams.

Tool Name Description

Selector Selects, moves, and resizes drawn 
elements.

Insert 
Department

Adds, edits, or deletes department 
attributes.
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Shapes Places shapes in a diagram and selects 
shape attributes and properties.

You can use different shapes to represent 
steps, documents, events, and other 
information in diagrams.

Connector Line Connects shapes with different types of 
lines. Choose from Direct, Right Angle, 
Curved, Org Chart, Cause and Effect, and 
Lightning Bolt lines.

Text Enters and changes text, types text 
blocks, types text on lines, and changes 
text. (It is not necessary to select the Text 
tool to add text to a selected shape.)

Shape 
Numbering

Numbers shapes.

Zoom Control Changes the view percentage.

Tool Name Description
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Draw Toolbar

The Draw toolbar contains tools that align, flip, rotate, reorder, repla
and otherwise arrange objects. Objects include shapes, text, and lin
You cannot perform all operations on all types of objects.  For exam
you can only rotate or flip shapes.

Tool Name Description

Draw Draws shapes in a diagram.

Selector Selects, moves, and resizes drawn 
elements.

Rotate Rotates selected objects.

Edit Points Edits the connect points in the 
graphic.

Rotate Right Rotates the selected objects 90 
degrees to the right.

Rotate Left Rotates the selected objects 90 
degrees to the left.

Flip 
Horizontal

Flips the selected objects 
horizontally.

Flip Vertical Flips the selected objects vertically.
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Arrange Opens a list of Arrange 
commands for modifying objects 
in the diagram. The Arrange 
commands are:

• Align - aligns shapes 
vertically and horizontally.

• Make Same Size - makes 
selected shapes same size.

• Even Spacing - spaces 
selected shapes evenly.

• Order - moves objects and 
layers in your diagram. 

• Group - groups selected 
objects.

• Ungroup - ungroups 
selected grouped object.

Tool Name Description
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Combine Opens a list of Combine 
commands so you can connect 
and disconnect closed and open 
objects. You can also form 
shapes from different 
combinations of operations. The 
Combine commands are:

• Connect Open - connects 
the selected, closed objects.

• Connect Closed - connects 
the selected open objects 
and closes them.

• Disconnect - disconnects 
the selected connected 
objects.

• Join - creates a new shape 
by joining the selected 
objects together.

• Intersect - creates a new 
shape from the intersection 
of the selected shapes.

• Outline - creates a new 
shape from the outline of 
the selected shapes.

• Slice - slices the selected 
closed shape with the 
selected open shape.

Tool Name Description
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Layer 
Manager

Opens the Layer Manager. In Layer 
Manger, you can change the visible, 
print, and lock properties of layers. 
Also, Layer Manager selects the 
current layer; adds, deletes, and 
renames layers; changes the order of 
layers; and specifies whether you 
want to change the current or all 
layers.

Text Color Applies color to text.

Fill Color Specifies the color for a shape.

Fill Pattern Specifies the pattern for a shape.

Line Color Applies color to lines, line endings, 
and shape borders.

Line Style Changes the style (solid, dashed, 
dotted) for lines and shape borders. 
You can select from several line 
styles, such as solid and dotted, 
which are also used to define the 
border styles for shapes.

Line Weight Determines line weight, or thickness. 
Click the tool and then use the arrows 
to adjust the weight. It is also used to 
set the border weight for shapes.

Tool Name Description
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Arrowheads Sets the arrowhead styles for the 
selected line. When you click the 
tool, a list of the most commonly 
used arrowheads opens. For a wider 
selection of arrowhead styles, click 
More at the bottom of the list.

Note
You cannot change 
arrowhead styles on filled 
lines.

Crossovers Changes the crossover style for the 
currently selected line. To change the 
crossover style for the entire diagram, 
use the Connector Line command on 
the Format menu.

Shadow Places a drop shadow on the current 
shape.

3D Gives the shape a 3-dimensional 
appearance.

Tool Name Description
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Preset Styles Toolbar

The Preset Styles toolbar stores and accesses the styles that you u
most frequently for text, shapes, and lines.

Tool Name Description

Shape Style 
box

Shows the current styles 
for shapes, including the 
border and shadow style 
and width, fill pattern, 
and color. The styles are 
applied to the next 
shape you place in your 
diagram.

Add Shape 
Style tool

Adds the current shape 
style to the Shape Style 
list.

Edit Shape 
Styles tool

Renames or removes the 
selected item from the 
Shape Style list.

Line Style box Shows the current styles 
for lines, including the 
line and arrow styles, 
widths, and colors. The 
styles are applied to the 
next line you draw.

Add Line 
Style tool

Adds the current line 
style to the Line Style 
list.
� � 
 
 � � 
 � � � � � � � � � � � � � 
 � 
 � �  40



�
������

�����

������	
�

�����
����	
�

���������	�
���	��
���
����

����

iDiagram Toolbar

The iDiagram toolbar contains tools that help you set up and run 
iDiagrams.

Edit Line 
Styles tool

Renames or removes the 
selected item from the 
Line Style list.

Text Style box Shows the current styles 
for text, including the 
font, size, style, and 
color. The styles are 
applied to the next 
character you type.

Add Text 
Style tool

Adds the current text 
style to the Text Style 
box.

Edit Text 
Styles tool

Renames or removes the 
selected item from the 
Text Style list.

Tool Name Description

Insert Entity Inserts an entity into the 
selected shape.

Entity Manager Shows or hides the Entity 
Manager.

Execute Runs the diagram.
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Visual Basic Toolbar

Use the Visual Basic toolbar to add or edit Visual Basic properties a
code to iGrafx Professional shapes.

Stop Stops the execution of an 
iDiagram.

Pause/Resume Pauses or resumes the 
execution of an iDiagram.

Step Runs the diagram one step at 
a time.

Tool Name Description

Visual Basic Editor Displays the Visual Basic 
Editor.

Design/Run Mode Switches between the 
Design and the Run modes.

Properties Displays properties for the 
selected object.

Edit Code Edits the code for the object.

Code Assistant Adds code to the object.

Controls Displays controls options.
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Model Toolbar

The Model toolbar contains all the tools needed for modeling functio
Most of the tools on this toolbar also appear as commands in the M
menu. Use these tools with iGrafx Process.

Tool Name Description

Start/Resume Starts or resumes the model 
simulation.

Pause Pauses the model simulation.

Stop Stops running the model 
simulation.

Trace Traces execution of the 
simulation.

Run Setup Modifies run setup data.

Generators Modifies generator attributes.

Resources Creates or modifies resources 
used for the simulation.

Schedules Creates or modifies schedules 
used for the simulation.

Events Creates or modifies events 
used for the simulation.
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To create a new toolbar

1 On the View menu, click Toolbars.

2 Click New.

3 Type a name for the new toolbar, and click OK. 

4 Drag the tools you want from the Customize dialog box to your 
new toolbar.

Tips
You can open the Tools menu and click Customize. With the Customize
dialog box open, press CTRL, drag a tool from a toolbar and drop it into
empty space to create a new toolbar.

Attributes Creates, modifies, or 
initializes attributes used for 
the simulation.

Functions Creates or modifies functions 
used for the simulation.

Monitors Creates, modifies, or finds 
monitors used for the 
simulation.

View Scenario Displays the current scenario.

View Report Displays the report of the 
current scenario.
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To rename a toolbar

1 On the View menu, click Toolbars.

2 Click the toolbar you want to rename.

3 Click Rename.

4 Type a new name for the toolbar.

Note
You cannot rename an iGrafx Professional toolbar. You can rename only 
the toolbars that you create.

To reset a toolbar

1 On the View menu, click Toolbars.

2 Click the toolbar you want to reset.

3 Click Reset.

Notes
Resetting the toolbars returns them to the default, installed setting. This
removes any tools that you added and adds tools that were originally on
the toolbars.

Resetting the toolbars only affects those tools added or removed throug
the Customize feature in the Toolbars dialog box or Customize comman
on the Tools menu. 

Only the selected toolbar is reset.
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To delete a toolbar

1 On the View menu, click Toolbars.

2 Click the toolbar you want to delete.

3 Click Delete.

Note
You cannot delete an iGrafx Professional toolbar. You can delete only 
the toolbars you create.

To make a toolbar a floating palette

1 Click in a blank area of the toolbar.

2 Hold down the mouse button and drag the toolbar from its positi

 To dock a floating toolbar

1 Click in a blank area of the toolbar.

2 Drag the toolbar to any side of the program's window.

3 When the border changes from thick to thin, you can drop the 
toolbar into position.
� � 
 
 � � 
 � � � � � � � � � � � � � 
 � 
 � �  46



�
������

�����

������	
�

�����
����	
�

���������	�
���	��
���
����

����


g 

u 
To create a floating palette from a toolbar tool

1 Click one of the following tools. (These tools are on the Formattin
Toolbar).

2 Drag the palette off the tool.

3 If you want, you can close the Formatting toolbar. The floating 
palette remains open until you close it.

To show or hide toolbars

1 On the View menu, click Toolbars.

2 Select the toolbars you would like to view, or clear the toolbars yo
no longer want to view.

3 Click OK.

Text Color Fill Color Line Color

Line Style Line Weight Arrowheads

Crossovers Shadow 3D
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Using Color Palettes

With iGrafx Professional, you can color text, lines, and fills. You can 
change default color and create as many as 33 custom colors.

To create a custom color

1 Click the Text Color, Fill Color, or Line Color tool on the 
Formatting toolbar.

2 Click More Colors.

3 Click or drag anywhere in the large color window to select a colo

4 Click OK. The color becomes the selected color for the fill, text, o
line. It also appears in the color palette.

Text Color Fill Color Line Color
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Tips
Move the vertical scroll bar on the right to adjust the amount of white 
and black in your color.

For finer control, you can type the values you want in the text boxes. 
Values must be between 0 and 255.

When the custom color palette is full, you can still add more colors. 
When you do, the first custom color (in the upper left corner) is removed
and your new color is added in the lower right corner of the palette.

If you are using Windows-standard VGA (16 colors), certain colors 
appear different when drawing lines and typing text, because of the 
limitations of your display driver.

To color an existing line

1 Click the line that you want to apply color to.

2 Click the Line Color tool.

3 Click the color you want.

To color fill

1 Click the shape that you want to apply color to.

2 Click the Fill Color tool.

3 Click the color you want.

To color existing text

1 Click the text that you want to apply color to.
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2 Click the Text Color tool.

3 Click the color you want.

Using ToolTips

ToolTips are short messages that appear in bubble text. These mes
help explain the name of the tool or button and, in some cases, wha
tool or button does.

To show or hide ToolTips

1 On the View menu, click Toolbars.

2 Click Show ToolTips.

or

Clear the Show ToolTips box.

To use ToolTips

1 On the View menu, click Toolbars.

2 Make sure the Show ToolTips box is checked.

3 Point to a tool or button in the window, and hold the mouse still fo
a short time. A short message (bubble) appears, explaining the t
or button.
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Using Menus and Commands

For every task in iGrafx Professional, there is a command. Commands
help you carry out actions for selected diagrams, models, shapes, t
and lines. You can also use commands to open dialog boxes where 
specific functions take place. In many instances, commands on men
have corresponding tools on toolbars.

File menu

The File menu contains the following commands:

Command Description

New On the File menu, point to New and click one of the 
three commands. 

You can create a new document as:

A Basic Diagram

Process

A new document based on a template
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Open Opens an existing diagram or workspace.

You can open these file types:

Documents (file names ending with an IGX, FLO, 
ABC, AF3, AF2, PFD).

Templates (file names ending with the IGT 
extension).

Workspaces (file names ending with the IGW 
extension).

The shortcut key is CTRL+O.

Close Closes the active document.

Close All Closes all documents.

Save Stores a document or template as a file.

The first time you save a new document choose 
where you want to store the file. Afterwards, each 
time you choose the Save command, your changes 
are saved in that file. You also can save templates 
for use with new documents.

Save As Makes a copy of the document under a new name or 
in another location, so that you have both the 
original document and a copy.

Save 
Workspace

Saves the names of open documents and their 
window arrangement in a file.

When you open a workspace file, the document files 
open and restore the arrangement.

Command Description
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Save as Web 
Page

Saves a iGrafx Professional file with related HTML 
format or Java applets, including graphics, for 
publication on the Web. This feature also converts 
links to the diagram to HTML format. When the 
diagrams are viewed on the Internet or an intranet 
and if you converted the links, clicking on a linked 
shape opens the associated diagram.

Components Manages diagrams and diagram components by 
listing them in a hierarchical, or outline, view. This 
makes it easy to add new diagrams, rename or edit 
existing diagrams, and delete diagrams you are no 
longer using.

Shape 
Library

Adds shapes to the Toolbox toolbar. After you add a 
shape, you can change its size, line width, and color. 
You can also duplicate or add Visual Basic 
functionality to a shape(s).

Template Provides information on the template associated 
with the document.

Command Description
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Page Setup Sets the size of the page. 

Sets the orientation of the page (portrait or 
landscape)

Sets the scaling to fit diagrams on pages

Sets the size of the page margins (borders)

Sets custom headers and footers

Sets the order in which pages are printed

If you change your page margin, the objects on the 
page also move. The default page size is determined 
by the selected printer.

Print Preview Previews how the diagram looks when you print it.

Print Prints your diagrams and adds them to presentations 
and reports.

You can print all the pages, a range of pages, or only 
selected objects in the diagram.

You can also use the shortcut key: CTRL+ P

Send Creates an e-mail message with the current 
document as an attachment.

This feature works with any MAPI E-mail system. 
MAPI e-mail systems include Microsoft Mail, 
Microsoft Exchange, and Lotus cc:Mail.

Command Description
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Edit menu

The Edit menu contains the following commands:

Recent File Lists the last four documents you opened or saved. 
Quickly opens documents you recently changed. 
The complete path name appears for documents 
outside the current directory.

A number appears beside each documents name. 
You can type the number to open the documents or 
click the document name.

Exit Closes open documents and the program. Use this 
command when you finish working with the 
program, or when you want to free memory to work 
in another program.

Command Description

Undo Reverses the last action or change on a diagram. If 
an action cannot be reversed, Can't Undo appears on 
the menu.

Redo Reverses the last undo you made. A description of 
the action to be redone follows the Redo command. 
For example, Redo Move indicates that Redo can 
redo a move action.

If the program cannot reverse the most recent undo, 
Redo is not available.

Cut Removes the selected objects from a diagram and 
places them on the Clipboard.

Command Description
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Copy Copies the selected objects in a diagram and places 
them on the Clipboard.

Paste Places the contents of the Clipboard into the active 
diagram.

Paste Special Pastes information from the Clipboard in various 
formats.

Select Specifies the shapes, lines, text blocks, or OLE 
objects that you want selected in a diagram.

Select All Selects all objects in a diagram.

Clear Deletes the selected objects from a diagram.

The Clear command deletes objects permanently. 
They are not placed on the Clipboard. Use the Undo 
command to recover a cleared object.

Duplicate Duplicates the selected objects.

Find Searches for text in the diagram. You can search the 
diagram (including shapes, lines, and master Items), 
in notes, in data fields, or in all of these elements. 
You can look for the text as a whole word and search 
for the text exactly as you have entered its case.

Replace Searches for and replaces text in shapes, lines, notes, 
and the entire diagram.

You cannot replace shape numbers.

Command Description
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View menu

The View menu contains the following commands:

OLE Links Opens a list of the objects linked to the active 
diagram.

Use this command to update the object with changes 
made in the source file, open the source file, change 
the source file or item, or break the link to the source 
file.

You can only change the links of linked objects. For 
example, you cannot break a link of an inserted 
object.

 Object Opens the object application so you can change the 
linked or embedded object.

Command Description

Normal Displays the diagram graphically.

Tabular Displays the diagram as a table with associated data 
for each shape.

Full Screen Displays all of the elements of your diagram on the 
screen without menus or tools. Press ESC to return to 
the previous view.

Master 
Page

Displays the items that appear on every page. For 
example, if you place a shape in the bottom left-hand 
corner of the master page, this shape appears in the 
same place on every page.

Command Description
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Toolbars Displays or hides toolbars. You can also customize the 
toolbars, reset toolbars, create new toolbars, delete 
custom toolbars, choose large or small tool sizes, 
choose color or black and white tools, and show or 
hide ToolTips using this command.

Status Bar Displays or hides the status bar.

Output Displays or hides the output window.

Gallery Displays or hides the gallery.

Note Displays or hides the Note window.

Properties Displays the Properties dialog box for setting or 
modifying properties of selected objects.

Hidden 
Lines

Displays or hides hidden lines.

Page 
Breaks

Displays or hides page breaks.

Rulers Displays or hides the rulers.

Zoom Changes the magnification of a diagram. To zoom in 
means to magnify. To zoom out means to reduce the 
magnification.

Command Description
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Insert menu

The Insert menu contains the following commands:

Command Description

Link Inserts a link from a shape to another 
diagram, file, or URL.

Department Inserts a new department.

Picture Inserts pictures from other files, Simply3D 
objects, Picture Publisher images.

iGrid Inserts an iGrid.

SPC Diagram Inserts SPC diagrams.

OLE Object Inserts objects from other applications.
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Format menu

The Format menu contains the following commands:

Command Description

Font Sets the font, size, color, and orientation for 
diagram text. 

Text Alignment Selects between horizontal or vertical 
alignment, and sets text orientation and tab 
size.

Text Layout Sets text and subtext area sizes for shapes.

Fields Creates or edits shape fields.

Numbering Displays or hides shape numbers, 
automatically or manually renumbers shapes, 
and sets the next shape number. 

Fill Sets shape fill styles as solid, pattern, or 
gradient.

Line and Border Sets line size, style, and color.

Shadow/3D Chooses shadow or 3D styles for shapes.

Callout Line Chooses callout line sizes, styles, and colors.

Diagram Edits the properties for departments.
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Tools Menu

The Tools menu contains the following commands:

Command Description

Spelling Checks the spelling of any text included in 
documents. You can check the spelling of all the 
text in the document, or only selected text.

Protect 
Diagram

Sets or removes password protection to protect 
your diagram from unauthorized changes.

iDiagram Runs an iDiagram, assigns a starting entity to a 
shape, and opens the Entity Manager.

Visual Basic Uses the Visual Basic Editor to edit codes, views 
VB shape properties, and assign VB macros to 
shapes.

Custom Data Manipulates custom data, inserts legends, creates, 
displays, and updates custom data.

Export Diagram Exports a diagram to another file. 

Customize Customizes the program toolbars and the Toolbox.

Options Sets options for shape spacing and alignment, line 
spacing, spell checking, displaying the Finished 
button, displaying the Welcome dialog, and 
setting the number of Undos and Redos.
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Arrange menu

The Arrange menu contains the following commands:

Command Description

Align Aligns shapes vertically and horizontally.

Make Same Size Makes selected shapes the same size.

Space Evenly Spaces selected shapes evenly.

Grid Snaps a selected object to the grid, displays 
or hides grid dots, or snaps all objects to the 
grid.

Guidelines Displays or hides vertical or horizontal 
guidelines or snaps selected objects to the 
guidelines.

Connect Shapes Uses a connector line to connect selected 
shapes.

Replace Shape Replaces the selected shape(s) with the 
shape in the Shape Library, Shared Media, or 
the Clipboard.

Reverse Ends Reverses the ends of the selected line. This 
changes the direction of the flow for that 
line.

Fit to Text Resizes the selected object or objects based 
on their text.

Rotate/Flip Rotates or flips the selected object.
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Model menu

The Model menu contains the following commands. Use these 
commands with iGrafx Process.

Order Moves objects and layers in your diagram. 
You can send objects to the back, bring 
objects to the front, send an object one level 
backward, or bring an object one level 
forward.

Layers Provides a submenu of commands that opens 
the Layer Manager, edits all layers, adds 
layers, selects a layer to move to, moves the 
layer back one layer, and moves the layer 
forward one layer.

Convert To Converts a shape to a graphic or a graphic to 
a shape.

Combine Connects and disconnects closed and open 
objects. Also, forms new shapes from 
different combinations of operations that you 
can perform with shapes.

Command Description

Run Runs a check, or test, on the simulation. You can 
also start, stop, or trace a simulation.

Run Setup Modifies run setup data.

Generators Modifies generator attributes.

Resources Creates or modifies resources used for the 
simulation.
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Window menu

The Window menu contains the following commands:

Schedules Creates or modifies schedules used for the 
simulation.

Events Creates or modifies events used for the simulation.

Attributes Creates, modifies, or initializes attributes used for 
the simulation.

Functions Creates or modifies functions used for the 
simulation.

Monitors Creates, modifies, or finds monitors used for the 
simulation.

Types Defines the types associated with the simulation.

Transaction 
Groups

Defines the transaction groups associated with the 
simulation.

Find Start Finds the start point for your simulation.

Command Description

New Window Creates a new window for the active diagram.

Tile Vertically Tiles windows vertically.

Tile 
Horizontally

Tiles windows horizontally.

Cascade Cascades windows for minimizing or maximizing.

Command Description
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Help menu

The Help menu contains the following commands:

Split Divides the active window into four panes. You 
can then view more than one window at the same 
time.

Window List Displays the names of the windows open 
currently. The numbers indicate the order in which 
the windows were opened. A check mark 
indicates which window is active.

Command Description

iGrafx Professional 
Help

Displays the help file for finding specific 
information about using the program.

Learn About Help Describes the advantages of using help.

Tip of the Day Displays program tips.

Using Help Describes how to use the help file.

iGrafx Professional 
Home Page

Displays the home page for the iGrafx 
Professional product in the Micrografx 
Internet site.

Micrografx Home Page Displays the Micrografx Internet home 
page.

About iGrafx 
Professional

Displays the program’s version number, 
copyright, and licensing information.

Command Description
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Getting Started with Diagrams

This chapter covers the following topics:

• Creating New Documents on page 66

• Opening Documents on page 70

• Viewing Diagrams on page 74

• Importing Other Formats on page 71

• Using iGrafx Professional Tools on page 77

• Editing Diagrams on page 86

• Printing Diagrams on page 96

• Saving and Closing Documents on page 98

• Distributing Documents on page 103

Creating New Documents

This manual refers to both documents and diagrams. These concep
different because:

Documents are containers—They can be a single component such a
Basic Diagram or a Process, or contain more than one Basic Diagra
Process. When you create a document, it includes one diagram by 
default. You create, open, save, and distribute documents.
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Diagrams are components of the document—In diagrams, you can p
shapes and draw graphics. You can also view, edit, print, and link 
diagrams to other diagrams in a document. Collecting and linking 
mulitiple diagrams to one document keeps corresponding informatio
one place.

iGrafx Professional offers two ways to create documents. You can cre
documents using:

• Welcome dialog

• New command on the File menu

Welcome dialog

The Welcome dialog is the first entry point into iGrafx Professional. 
This dialog offers a graphical point of reference for creating new 
documents and opening existing ones.

Note
You can bypass the Welcome dialog by clicking the Don’t Show This 
Startup Screen Again box in the lower left-hand corner of this dialog.

If you decide later that you want to see the Welcome dialog, use the 
Options command on the Tools menu to make this change.
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New command

The New command creates a new document with or without using a
template. You can use the New command on the File menu during a
part of your session, including startup.

iGrafx Professional includes a manager for templates. Clicking 
Template on the File menu opens the Template dialog box. Use this
to apply templates, check the dates of template updates, and synchr
an opened document with the most up-to-date template.

To create a new document from the Welcome dialog

1 On the Windows Start menu, point to iGrafx, and click 
Professional.

2 In the Welcome Dialog, click New Document, and then click 
Process or Basic Diagram.

To create a new document using the New command

1 On the Windows Start menu, point to iGrafx, and click 
Professional.

2 On the File menu, click New. You can select:
• Process to open a process diagram with a default departmen

lane.

• Basic Diagram to open a new, blank diagram window. 

• From Template to open the New dialog box to select a templa
file.
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To create a document from a template

1 On the File menu, point to New, and click From Template.

2 Click the template you want.

3 Click OK.

4 On the File menu, click Save As.

5 In the Save as type box, select iGrafx Professional (*.igx).

6 Save the document under a new name.

To create a new template

1 On the File menu, point to New, and click Basic Diagram.

2 Make changes to the document settings and styles.

3 On the File menu, click Save As.

4 In the Save as type box, select iGrafx Professional Template (*igt).

5 Give a name to the template in the File name text box.

6 In the Save in box, click the drive where you want to save the 
template.

7 Select the folder where you want to save the template.

8 Click Save.

Note
You cannot use templates created in iGrafx Professional in FlowCharter 
7. Instead you must save them as FLO files and convert them to 
templates within FlowCharter 7.
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Opening Documents

iGrafx Professional offers three ways to open documents:

• Welcome dialog- Use the Welcome dialog to open documents th
you have already created.

• File menu- Use the Open command on the File menu.

To open a document using the Welcome dialog

1 On the Windows Start menu, point to iGrafx, and click 
Professional.

2 On the Welcome Dialog, click New Document, and then click 
Process or Basic Diagram.

To open a document using the Open command

1 On the File menu, click Open.

2 In the Look in box, choose the drive where the document reside

3 Double-click on the folders to open the folder where your 
document resides.

4 If necessary, choose the type of file you want to open in the Files
type box.

5 Click the document you want to open.

Tips
You can also use the shortcut key: CTRL+O or the Open button on the 
Standard toolbar.
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Importing Other Formats

You can take a FlowCharter chart, an Optima file, or an Optima Exp
file, and convert the data into an iGrafx Professional document.

Shapes and lines are automatically converted along with text and 
graphical information. All linked FlowCharter subcharts can be 
imported optionally so that the design maintains the hierarchy of 
processes.

FlowCharter Charts

When importing FlowCharter charts, you may notice a few things:

• Horizontal swimlanes are converted automatically to iGrafx 
Professional departments, and their shapes are converted into 
activities within the appropriate departments. 

• If iGrafx Professional finds links to other FlowCharter charts in the
file, you will receive an Import Options message.

• If you choose Yes, the shapes are converted to Process activ
and the contents of the linked files are converted into 
subprocesses.

• If you choose No, the documents remain separate.
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The following table will help you understand the conversion of Proce
elements:

To open a FLO file

1 On the File menu, click Open.

2 In the Look in box, choose the drive where the file resides.

3 In the box, double-click the folders until you open the folder whe
your file resides.

Element Description

Shapes During conversion, any shape that is 
connected by a line to another shape is 
automatically converted to an activity. 

Graphics and lines Any shape that is not connected to another 
shape is converted to a graphic. Also, any line 
that does not connect shapes is converted to a 
graphic. Any line that connects shapes is 
automatically converted to a connection line. 

Decisions and Splits A shape that has more than one labeled 
output is converted to a Decision activity. A 
shape that has more than one unlabeled 
output, and is not a diamond shape, is 
converted to an implicit Split activity. 

Text Any text object, other than text that labels an 
output line from a symbol, is converted to a 
text graphic.

OLE Any OLE object is converted to an OLE 
graphic.
� � � � 
 
 � � � � � � � � � � � 
 � � � � 
 � � � � � �  72



�
������

�����

������	
�

�����
����	
�

���������	�
���	��
���
����

����


s.
4 In the Files of type box, click Micrografx FlowCharter 7.0 File 
(FLO).

5 Click the FLO file you want to open.

To open a PFD file

1 On the File menu, click Open.

2 In the Look in box, choose the drive where the file resides.

3 Double-click the folders to open the folder where your file reside

4 Click the PFD file you want to open.

To open a DRW file

1 On the File menu, click Open.

2 In the Look in box, choose the drive where the file resides.

3 Double-click on the folders to open the folder where your file 
resides.

4 In the Files of type box, click Micrografx Draw 6.0 File (DRW).

5 Click the DRW file you want to open.
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Viewing Diagrams

iGrafx Professional offers several ways to view new diagrams you are
creating, or view documents you have already created. Before using
view, ask yourself the following questions:

• What type of diagram do I want to create?

• How will I be using a diagram already created?

Normal View

Normal is the most popular view for editing diagrams. In Normal vie
you work with a diagram space, or the area containing shapes, grap
text, and lines. This space is set by default at 100%. Use the Zoom 
Control to change the view percentage to view more or less of the 
diagram space.

Tabular View

The Tabular view can be used for viewing data contained within the
diagram. This includes departments, shapes, and connector lines.

Note
You can edit data in both the Normal and Tabular view.
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Full Screen View

Use the Full Screen view to show someone the diagram and do a c
talk about it. While in full-screen mode, draw on the screen. When y
finish, press ESC to return to the previous view. In the Full Screen v
use the mouse buttons to draw using different colors.

• To draw in red, click the left mouse button and drag.

• To draw in green, click the right mouse button and drag.

• To draw in yellow, click both mouse buttons and drag.

• You can use the following keys when working in Full Screen view

• DEL, Spacebar, E - Erase diagram annotations

• TAB, PAGE DOWN, N - Go to the next diagram window

• SHIFT+TAB, PAGE UP, P - Go to the previous diagram 
window

Master Page View

Master Page view shows you what elements appear on the Master 
Anything placed on the Master Page appears on every page of the 
diagram when printing or using the Print Preview command.

To use Normal view

� On the View menu, click Normal.

To use Tabular view

� On the View menu, click Tabular.
� � � � 
 
 � � � � � � � � � � � 
 � � � � 
 � � � � � �  75



�
������

�����

������	
�

�����
����	
�

���������	�
���	��
���
����

����


 view 
 few 
To use Full Screen view

1 On the View menu, click Full Screen.

2 To draw in red, click the left mouse button and drag.

or

To draw in green, click the right mouse button and drag.

or

To draw in yellow, click both mouse buttons and drag.

3 Click ESC to leave the full-screen view.

To view the Master Page

� On the View menu, click Master Page.

Zooming Diagrams

Changing the zoom percentage on a diagram helps you get a better
of a shape or a group of shapes. Zoom in to see text and notes on a
shapes, or zoom out to see the layout of all shapes.

To choose a zoom percentage

1 Click the object you want centered in the window.

2 Click the down arrow in the Zoom box on the Standard toolbar.

3 Click the viewing percentage at which you want to view the 
diagram.

4 To scale the diagram to fit in the current window, use Best Fit.
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To always view the entire diagram, use View All.

Tips
You can also use the Zoom command on the View menu to change the
zoom percentage.

Using iGrafx Professional Tools

Several tools and commands exist in iGrafx Professional to help you 
change the appearance of diagram components, give you informati
about performing tasks, and split up the visible diagram space.

These tools include:

• Gallery

• Notes

• Output Window

• Status Bar

• Rulers, Page Breaks, and Hidden Lines

• Window commands
� � � � 
 
 � � � � � � � � � � � 
 � � � � 
 � � � � � �  77



�
������

�����

������	
�

�����
����	
�

���������	�
���	��
���
����

����


can 
s and 
ned 
Using the Gallery 

The Gallery is a formatting command center. From the Gallery, you 
drag and drop shapes, change color, add text and lines, add shadow
3D attributes, and change fonts and line ends. The Gallery is positio
on the right-hand side of the screen for easy access.

To show or hide the Gallery

� On the View menu, click Gallery.

Click the tabs to change 
formatting options. The 
Standard tab contains 
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Using iGrafx Share Media

After you install iGrafx Share Media it becomes part of the Gallery. It 
contains many features that makes communicating with graphics ea
and efficient.

With iGrafx Share Media, you can:

• Browse and access media quickly with the Media Browser.

• Customize toolbars and ToolTips.

• Bring in multimedia files, such as AVI, WAV, and Animated GIF 
files.

• Play multimedia files in place when you pause the cursor over th
thumbnail of the file.

• Bring in graphics from a digital camera or scanner.

• Easily customize the look and feel of iGrafx Share Media with th
Customize Workspace Wizard.

• E-mail media to coworkers with the Send Wizard.

• Access frequently used media with the Bookmark feature.

• Create portable collections quickly and easily with the Package 
Media Wizard. This lets you work with graphics when you're awa
from the office.

• Find and import media by file type with the Import Files Wizard.

• Print one or more graphics with the Print Wizard

• Keep Share Media on top of other applications for ease in addin
graphics to your documents
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• Add media using Windows Explorer, even if Share Media is not 
open.

Note
The features you see in Share Media depend upon the way your system 
administrator sets up Share Media on your computer. 

Using Notes

The Note window contains text attached to a certain shape. You can
notes containing detailed information about a step or process that yo
not want displayed in a diagram. Note text can also be copied from 
shape and pasted into another.

Type and change notes inside the Note window. The Note window 
displays the shape number of the selected shape (if any), and the te
attached to the shape. In a diagram, shapes with notes attached ar
marked by default with the letter N.

Tip
In the Format Diagram dialog box, click the Indicators tab to change the
indicator for notes. You can also display the actual text in the diagram 
using the Fields command on the Format menu.
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To open the Note window

� On the View menu, click Note.

Tip
You can press F6 to open and close the Note window.

To attach a note to a shape

1 If the Note window is not displayed, click Note on the View menu

2 Select the shape to which you want to attach a note.

3 Click in the Note window, and type the information you want.

4 Close the Note window.

To delete text in the Note window

1 If the Note window is not displayed, click Note on the View menu

2 Select the shape to which the note is attached.

3 Point inside the Note window. The pointer changes to the I-beam
pointer.

4 Select the text you want to delete.

5 On the Note menu, click Clear or press the DELETE key.
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To print a note

1 On the View menu, click Note.

2 Select the shape to which the note is attached.

3 On the Note menu, click Print.

4 Choose Current Note.

5 Choose the print options you want.

6 Click OK.

Tip
In the Note window, wrapped text moves onto one line. To rewrap the 
text, point to the Note window border, press and hold the left mouse 
button, and drag the border out until the entire line of text appears (or 
drag the window border out and back to its former size).

Using Indicators

Indicators are shadows and symbols added to shapes, and nodes a
to lines. Shape indicators help you identify shapes that are used to 
linked diagrams (or launch other applications) or that have notes 
attached to them.

• Shapes that open linked diagrams (or launch other applications)
can be indicated with text, a shadow, or an icon.

• Shapes that have notes attached to them can be indicated with 
or a shadow.
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You can use shadows and choose the symbols used for indicators. 
default indicators are a shadow for link and -N for notes. You can us
to three text characters to create your own indicators.

You can choose the font, point size, color, and style you want for tex
indicators. The settings you choose are also used for shape numbe

To choose indicators for shapes

1 On the Format menu, click Diagram.

2 In the Format Diagram dialog box, click the Indicators tab.

3 To set the indicator type for a shape with a link, click the down 
arrow in the Link area, and click the type you want to use.

4 If you want to use a text symbol to indicate a shape with a link, ty
up to three characters in the box in the Note area.

5 If you want to use a shadow to indicate a shape with a note, clic
the Shadow check box.

6 If you want to change the indicator style for nodes or intersection
choose a new style and color.

7 Click OK.

Using the Output Window 

The Output window is used to display messages, errors, and warnin
For example, if you add expression information to a shape any erro
this expression will display in the Output window. Double-clicking on
the error in the Output window takes you to the shape where you ca
repair the error.
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To open the Output window

� On the View menu, click Output.

Using the Status Bar

Use the Status Bar for help on toolbar tools and menu commands. 
Passing the cursor over items in the window displays a short descrip
about the item.

To use the Status Bar

� Move the cursor over any toolbar tool or menu command.

A description of the tool or command appears in the lower left-
hand corner of the iGrafx Professional window.

The ToolTip 
labels the tool, 
and the Status 
Bar describes the 
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Using Rulers, Page Breaks, and Hidden Lines

Rulers, page breaks, and hidden lines serve as navigators for the 
diagram space. Without them, it is difficult to align shapes and 
determine logical points that break up the page. This can be a proble
large diagrams where you must use the Zoom Control to view 
everything.

To turn rulers on or off

� On the View menu, click Rulers.

To turn page breaks on or off

� On the View menu, click Page Breaks.

To turn hidden lines on or off

� On the View menu, click Hidden Lines.

Using Window commands

Window commands help you manage your workspace and diagrams
you create or have open. You find these commands on the Window
menu.

To tile windows vertically or horizontally

� On the Window menu, click Tile Vertically or Tile Horizontally.
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To cascade windows

� On the Window menu, click Cascade.

To split windows

� On the Window menu, click Split.

Editing Diagrams

You can find most of the editing functions in iGrafx Professional on the 
Edit menu. On this menu, you can do things like duplicate objects a
find text. Editing is different from formatting in that you are working 
with existing components, and not changing the size, or applying ne
colors, lines, and text.

Through editing, you can do things like:

• Change an open diagram and save it under a new name. This s
you from creating a new one.

• Paste special text and graphics from other applications into iGra
Professional.

• Find text occurrences in diagram shapes or notes, and replace t
with a different word or phrase.

To undo an action

� On the Edit menu, click Undo.

or

Click the Undo tool.
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To redo (reverse) your last undo

� On the Edit menu, click Redo.

or

Click the Redo tool.

Cutting, Copying, and Pasting

With iGrafx Professional, you can cut, copy, and paste objects or grou
of objects to the Clipboard for moving into another diagram or even
another application.

The Paste Special command pastes information from the Clipboard
your diagram in various formats. Use this command to link informat
to the active diagram.

Depending upon the information in the Clipboard, your paste forma
options may include an embedded OLE object, Rich Text Format (RT
non-formatted text, a metafile (which acts as a diagram shape), and
bitmap.

After you link an object to a diagram, any changes made to the obje
its source file in the original program (the object application) are 
reflected in the diagram.
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Note
The difference between the Paste Special command’s Paste Link optio
and the Insert Object command is that when you insert an object, the 
entire object is included in your diagram. With the Paste Link option, 
you can select a portion of a document, spreadsheet, or bitmap and pas
it into your diagram. When something is Paste Linked, you cannot 
change it in your diagram as you can an inserted object.

To cut objects

1 Select the object or objects to cut.

2 On the Edit menu, click Cut.

or

Click the Cut tool.

Tips
The keyboard shortcut for cutting an object is CTRL+X.

Shapes or text cut or copied from the diagram window cannot be paste
into the Note window.

To copy objects

1 Select the object or objects you want to copy.

2 On the Edit menu, click Copy.

or 
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Click the Copy tool.

Tips
You can also press CTRL+C to copy a selected object.

Shapes or text copied or cut from the diagram window cannot be paste
into the Note window.

To paste objects

� On the Edit menu, click Paste.

or

Click the Paste tool.

Tips
You can also press CTRL+V to paste the object.

You can paste notes into the active diagram window using the Paste 
command. Before you can paste something from the Note window, you
must select a shape or click the left mouse button on the active diagram

To use the Paste Special command

1 Select the object(s) or text in another application.

2 On the Edit menu, click Paste Special.

3 Select the paste type (as text, picture) from the list.
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4 Click OK.

Note
If you have copied a linked object or text from another application, the 
Paste Link option is selected on the Paste Special dialog box. This keep
this object or text linked back to its original application.

Selecting, Deleting, and Duplicating Diagram 
Objects

Use the Select and the Select All commands on the Edit menu for 
deleting or duplicating diagram objects. On the Select dialog box, y
can choose which diagram components to select or ignore.

To select diagram components

1 On the Edit menu, click Select.

2 Click one or more of the check boxes to select all objects of that
type.
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Tips
In the Name box, you can click a shape name to select all shapes of tha
kind.

You can also select all objects using the Select All command on the Ed
menu.

You can select multiple objects. Press and hold SHIFT as you click eac
object.

You can select an object beneath other objects. Click the Selector tool, 
press and hold CTRL, and click the top object. As you continue to click,
each object below the top object is selected.

To delete objects

1 Select the object you want to delete.

2 On the Edit menu, click Clear.

Tips
You can also press DELETE to delete the selected object.

When you choose the Clear command, objects are deleted permanentl
They are not placed on the Clipboard.

Use the Undo command to recover a cleared object.

To duplicate objects

1 Select the object or objects you want to duplicate.
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2 On the Edit menu, click Duplicate.

Note
You can also press and hold the CTRL key and drag the selected objec
to duplicate them.

Finding and Replacing Text

Use the Find command to search text in diagrams, custom data field
notes. You can search for exact words or variations of a word. For 
example, select the Match case option on the Find dialog box, type
word auto, and the search finds auto and automobile.

To find text

1 On the Edit menu, click Find.

2 Enter the text to find.

Note
The search finds text only in the diagram. It cannot search inserted OLE
objects from other programs. To find text in inserted objects, open the 
object and search for the text within its program.

Tip
You can search the diagram (including shapes, lines, and master items
in notes, in data fields, or in all of these elements.
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To replace text in a diagram

1 In the Edit menu, click Replace.

2 Type the text you want to find in the Find box.

3 Type the text you want to use as replacement text in the Replac
box.

Spell Checking

The spell checking feature checks spelling by comparing words in y
document with words in a dictionary. The default dictionary is a file 
containing thousands of words. If a word is found that is not in the 
dictionary, the word is considered a possible misspelling.

The program displays a list of words displays similar to the misspell
word. You can select one of the words, type the correct spelling your
ignore the word, or add the misspelled word to the user dictionary.

You can customize the spell checker by:

• Defining user dictionaries for special purposes.

• Specifying that the program ignore words with numbers during 
spell checking.

To choose spelling options

1 On the Tools menu, click Options.

2 Click the Spelling tab.

3 Type the path and file name of the dictionary to be used for spel
checking.
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4 To ignore words with numbers, click Ignore Words with Numbers

5 Click OK.

To check spelling

1 Select the elements you want to spell check. If no elements are 
selected, the entire diagram is spell checked.

2 On the Tools menu, click Spelling.

or

Click the Spelling tool.

Note
Misspelled words are displayed in the Not in Dictionary box. A 
suggested replacement is shown in the Change To box.

3 You can type in a replacement or choose another replacement fr
the list.

4 To correct the word, click Change or Change All.

5 If the word is not misspelled, click Add to add the word to the us
dictionary and continue, or click Ignore or Ignore All to ignore the
word or every instance of the word.
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Protecting Diagrams

At times, you might want to prevent other people from modifying a 
diagram. You can protect a diagram by assigning it a password. No
is able to type field data into it until the password is typed correctly. 
the diagram contains hidden data fields, they are hidden from view u
the password is entered correctly.

You can use password protection to manage linked files. By assigni
each person in a workgroup a different password, you can ensure th
each person has access only to his or her own diagrams.

To protect a diagram

1 On the Tools menu, click Protect Diagram.

2 In the Password field, type a password.

3 In the Verify field, type the same password again.

4 Click OK.

Note
If you open a protected diagram a message reminds you that you have 
type the password before you can make changes to the diagram.

To unprotect a diagram

1 On the Tools menu, click Unprotect Diagram.

2 Type the correct password.
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3 Click OK.

Note
If you enter the wrong password, a message appears telling you that th
password is incorrect. Click OK and enter the correct password. If you 
do not know the password, click Cancel. You can change the diagram 
after you enter the correct password.

Printing Diagrams

When you print a diagram, you can choose several options such as
including or excluding diagram components, queuing just the active
diagram or the entire document set, or printing to a file. You can als
choose the option to print all of the diagrams and components withi
document.

Check the following commands and dialog boxes for printing option

• The Print command on the File menu. This opens the Print dialo
box where you can select or change options.

• The Page Setup command on the File menu. This opens the Pa
Setup dialog box where you can select the Options tab to find oth
print options.

To print a diagram

1 On the File menu, click Print. Information about the printer appea
at the top of the dialog box. (The printer information applies to th
printer to which the next print job is sent.) You can also choose 
another printer.
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2 Choose a Print Range option.

3 In the Copies text box, type the number of copies you want.

4 In the Print What box, select the active diagram or the entire 
document.

5 To send the output to a file instead of a printer, click the Print to 
File box if you want.

6 Click OK.

Tips
You can also use the shortcut key: CTRL+P.

If you choose the Print to File option, a dialog box opens. Type the file 
name you want and click OK. The diagram information is saved in a file
in the current directory.

To print Notes or blank pages, choose the print order, and fit the diagram
to the page, click Page Setup on the File menu, then click the Print 
Options tab.

To see a print preview of your diagram

� On the File menu, click Print Preview.

Tip
You can zoom in by clicking the diagram area you want to see in more 
detail.
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Saving and Closing Documents

You can save a document by naming it or renaming it, and clicking t
following commands on the File menu:

• Save and Save As - Save a document as an iGrafx Professional 
document or template, older FLO files, or a DRW file.

• Save Workspace - Saves your document as an iGrafx Professional 
Workspace (*.igw)

• Save as Web Page - Saves your document(s) for publishing on 
Web.

If you plan on distributing documents to others, save them as Web p
or as older FLO files. Before sharing these documents with others, a
they have a Web browser or an older version of FlowCharter installe

You can close a document or documents using the Close, Close All
Exit commands on the File menu.

To save a document or template

1 On the File menu, click Save. If you are saving a file for the first 
time, the Save As dialog box opens. If you have already saved t
file, your changes are saved in the file you named earlier.

2 Type the file name in the File Name box.

3 Choose the drive and directory in which you want to store the file
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4 Choose the file format (document or template) in the Save as ty
box.

Tips
You can also use the shortcut key: CTRL+S.

A template includes all document settings and styles.

You cannot use templates created in iGrafx Professional in earlier 
versions of FlowCharter. Instead you must save them as FLO or AF3 
files and convert them to templates within those applications.

To save a copy of a document

1 On the File menu, click Save As.

2 Type a file name for the document copy. Use a different name to
distinguish between the copy and the original.

3 Choose the drive and directory in which you want to store the co

4 Click OK.

Saving a Workspace

A workspace is the set of currently open documents. Because you o
work on the same set of documents for a project, the workspace fea
opens them to resume your work. When saving a workspace, you c
save the names of the open documents (not the documents themse
and the arrangement of the documents in the program window.
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To save a workspace

1 On the File menu, click Save Workspace.

2 Type a name for the workspace file in the File Name text box.

3 Choose the drive and directory in which you want to store the 
workspace file.

4 Click OK. 

Note
Only saved documents are included in the workspace file. If any of the 
documents in the workspace have not been saved, the Save File dialog
box opens to save them.

To reopen the workspace

1 On the File menu, click Open.

2 Choose Workspace in the Files of Type box.

3 Choose the drive and directory that contain the workspace file y
want.

4 Click the file you want to open.

5 Click OK. 
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Saving Documents in Older FLO Formats

Saving your documents in the FLO format enables those individuals
who use FlowCharter 7 to open and view documents.

To save documents in FlowCharter 7 format

1 On the File menu, click Save As.

2 Choose the Micrografx FlowCharter 7.0 File (FLO) format in the
Save as type box.

3 Type the file name you want in the File name box.

4 Choose the drive and directory where you want to store the file.

5 Click OK.

Saving as a Web Page

After you create a document in iGrafx Professional, you can publish it 
using Hypertext Markup Language (HTML) or Java applets. HTML is
standard language that defines the layout, text, and graphics of a W
page.

When you save a file to HTML or Java, you specify which parts of th
diagram are to be saved as part of the Web page. You can view the
HTML output with a Web browser such as Netscape Navigator or 
Microsoft’s Internet Explorer, or any other Web browser that support
images, client-side image maps, and tables.
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At the bottom of each Web page is an index of any other diagram lin
that were included.

To save a diagram as a Web page

1 On the File menu, click Save as Web Page.

2 Choose the folder location to save the page(s).

3 Select the diagram(s) and components to save.

4 Choose if you want to output diagrams as Java applets.

5 Click OK.

The Save As Web Page- Finished dialog opens.

6 Click Close or click View to view the page(s) in your Web browse

Element Description

Images The Web browser should be able to view GIF 
files.

Client-side 
image maps

The Web browser should support client-side 
image maps so that the navigation from the 
diagram images works.

Tables The Web browser should support tables 
because the HTML output makes extensive 
use of tables in the navigation elements and in 
the report output. Particularly recommended 
is a Web browser that supports color in table 
backgrounds.
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Distributing Documents

Distributing documents to team members, departments, and even o
companies is a great way to communicate ideas and tasks. With iG
Professional, you have three ways to do this:

• Using iGrafx Share

• Sending documents as e-mail attachments

• Sending documents as HTML or Java applets

Using iGrafx Share Viewer

iGrafx Share Viewer contains many features that help you and your 
coworkers easily collaborate about a diagram.

When you add markups using Viewer, they are displayed when you o
them in iGrafx Professional.

With iGrafx Share Viewer, you can:

• Open and view multiple diagrams.

• Add markups to a diagrams.

• Page tabs let you navigate with ease in multiple-page diagrams.

• Share Viewer remembers which markups belong to each review

• View markups by all reviewers, a particular reviewer, or view onl
your own markups.

• Edit text and marker colors.

• E-mail a diagram that contains your markups.
� � � � 
 
 � � � � � � � � � � � 
 � � � � 
 � � � � � �  103



�
������

�����

������	
�

�����
����	
�

���������	�
���	��
���
����

����


ith 
mail 
 mail 
To open iGrafx Share Viewer

� On the Windows Start menu, point to iGrafx, and click Share 
Viewer.

Sending Documents as E-mail Attachments

iGrafx Professional works with any MAPI E-Mail system, such as 
Microsoft Outlook, allowing you to send documents as attachments w
e-mail messages. The Send command automatically opens your e-
and attaches the open document, so you can address and send the
like any other message.

To send a document as an e-mail attachment

1 Open the document to attach to an e-mail message.

2 On the File menu, click Send.

3 Address the e-mail and create a message as you usually do.

Notes
This feature works with any MAPI E-mail system. MAPI e-mail systems 
include Microsoft Mail, Microsoft Exchange, and Lotus cc:Mail.

If the mail system is not running, it starts when you click the Send 
command.
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Setting Up a Diagram

This chapter covers the following topics:

• Setting Up the Diagram Page on page 106

• Using Headers and Footers on page 110

• Using Guidelines and Grids on page 111

• Setting Up Departments on page 114

Setting Up the Diagram Page

With almost unlimited diagram space on the screen, you can create 
large, in-depth diagrams without getting a clear idea of where page 
breaks occur, the placement of headers and footers, or the size of yo
margins.

This becomes important when you need to print diagram pages. Use
Page Setup dialog box to adjust page options such as scaling and p
order so a diagram prints correctly.

To define the page setup

1 On the File menu, click Page Setup.

2 Click each tab, and select the page setup options you want.

3 Click OK.
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To select the diagram orientation

1 On the File menu, click Page Setup.

2 Select Portrait or Landscape.

3 Click OK.

To set diagram scaling

1 On the File menu, click Page Setup.

2 Select Adjust to, and type a percentage in the normal size box.

or

Select Fit to, and type a number of pages wide by a number of 
pages tall.

3 Click OK.

To set the paper size

1 On the File menu, click Page Setup

2 Select a paper size from the Paper Size list.

or

Type a paper width in the Width box, and a paper height in the 
Height box.

3 Click OK.
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To set page margins

1 On the File menu, click Page Setup.

2 Click the Margin tab.

3 Select each of the Margin boxes individually and type the margin
you want (in inches).

4 Click OK.

Notes
iGrafx Professional rounds the numbers to the nearest hundredth of an 
inch or tenth of a centimeter.

To set diagram titles

1 On the File menu, click Page Setup

2 Click the Options tab.

3 To print out large multi-page diagrams that you can cut and tape
together, select Per Diagram, and set the overlap for extra tapin
room.

or

To print out multi-page diagrams that you can bind in a book, sele
Per Page.
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To set the Print Notes option

1 On the File menu, click Page Setup. 

Notes print after the pages of the diagram print. Notes use shap
numbers to reference back to shapes in the diagram.

2 Click the Options tab.

3 Select the Notes box.

4 Click OK.

To set the page order for printing

1 On the File menu, click Page Setup.

2 Click the Options tab.

3 Select Down, Then Across to print top to bottom and left to right

or

Select Across, Then Down to print left to right and top to bottom

4 Click OK.
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Using Headers and Footers

Headers and footers help you and those who view your diagrams:

• Get information about a diagram using names and page numbe

• Keep up with revisions and diagram opening and saving using d
and time stamps.

With iGrafx Professional, you can insert default header and footer 
information or create custom headers and footers.

To insert a predefined header or footer

1 On the File menu, click Page Setup

2 Click the Header/Footer tab.

3 Select a style and position combination from the Header list.

4 Select a style and position combination from the Footer list.

5 Click OK.

To create a custom header or footer

1 On the File menu, click Page Setup.

2 Click the Header/Footer tab.

3 Click Custom Header or Custom Footer.
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4 To insert the header or footer information you want in each sectio
click inside Left Section, Center Section, or Right Section, and 
then click the buttons.

Note
To add additional text to the header or footer, enter the text in the 
Left Section, Center Section, or Right Section box.

Using Guidelines and Grids

You can use guideline and grid options in iGrafx Professional to 
improve the look of your diagram.

Guidelines

You can use guidelines to align objects. When you drag a shape ne
guideline, the shape’s sides and center snap into alignment with the
guideline. Guidelines help you align shapes of different sizes to ach
an attractive, organized look. Guidelines do not appear in the printe
diagram.

Grids

Grids also help you with alignment by snapping shapes to a series 
snap points on the diagram space. When grid snapping is turned on
every shape that you move locks on to these points. If you open a 
diagram and see that objects are not organized and neat, this could
indication that grid options were not used. Use the Snap Objects to 
command on the Arrange menu to organize these objects in the dia
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To add a horizontal guideline

� On the Arrange menu, point to Guidelines, and click Add Horizon
Guideline.

Tip
You can add a guideline with a right-mouse click. Right-mouse click in 
the ruler area, and click Add Horizontal Guideline.

To add a vertical guideline

� On the Arrange menu, point to Guideline, and click Add Vertical 
Guideline.

Tip
You can add a guideline with a right-mouse click. Right-mouse click in 
the ruler area, and click Add Vertical Guideline.

To move a guideline

1 Point to the guideline you want to move.

2 Press and hold the left mouse button, and drag the guideline wh
you want it.

3 When you are finished, release the mouse button.
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To delete a guideline

1 Click the guideline you want to delete.

2 Press and hold the left mouse button.

3 Drag horizontal guidelines to the horizontal ruler. Drag vertical 
guidelines to the vertical ruler.

4 When the guideline pointer is positioned over the appropriate rul
release the mouse button.

To turn on grid snapping

� On the Arrange menu, point to Grid, and click Snap to Grid.

To show grid dots

� On the Arrange menu, point to Grid, and click Show Grid Dots.

To snap objects to the grid

� On the Arrange menu, point to Grid, and click Snap Objects to t
Grid. 

Tip
To set the grid spacing, click the Options command on the Tools 
menu, and then click the Alignment tab.
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Setting Up Departments

You can use departments to display the flow of information and 
materials between different roles, groups or organizational units. In 
process diagramming, departments help show how tasks flow throu
groups such as manufacturing and customer service toward a final 
outcome or creation of a product. Many processes contain subproce
that appear in their own departments.

Shapes behave the same in departments as they do on a normal di
page. You can still connect lines, edit points, size, move, delete, cha
the text, or change the color of shapes. In addition, you can:

• Name departments

• Set the vertical or horizontal orientation of departments

• Expand or shrink departments

• Reorder departments

• Move the location of department names

When you create departments for the first time in a diagram, you ca
the department orientation and text orientation for headers. After yo
have created your departments, you edit them in the diagram space

Note
When you create a process diagram, iGrafx Professional inserts one 
department and a starting point by default.
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To insert a department

1 On the Insert menu, click Department.

or

Click the Department tool.

2 In the Insert Departments dialog box, click Add.

3 In the Insert Department dialog box, type a name for the 
department in the New Department Name field.

4 Click OK.

To set the lane orientation of departments

1 Click the Department tool.

2 Under Department Orientation, select Horizontal or Vertical.

3 Click OK.

Note
You can only set the lane orientation of departments the first time you 
add departments to a diagram.

To set the text orientation of department labels

1 Click the Department tool.

2 Under Text Orientation, select Horizontal or Vertical.
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3 Click OK.

Note
You can only set the text orientation of department labels the first time 
you add departments to a diagram.

To move the location of department names

1 In an active diagram, click a department label.

2 Click the right mouse button, and click Format Diagram.

3 In the Process tab, select a name location from the Department
Name Area list.

4 Click OK.

To add a color, pattern, or gradient to departments

1 In an active diagram, click a department label.

2 In the Gallery, click the Fill tab, select Fill Color, Fill Pattern, or 
Fill Gradient, and then click a color, pattern, or gradient.

3 Repeat the same procedure for lines and shadows/3D.

To add borders and dividers to department lanes

1 In an active diagram, click a department label.

2 Click the right mouse button, and click Format Diagram.

3 Click the Borders and Dividers tab, and select the area you wou
like to apply borders or dividers from the list.
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4 Select from the various line types, styles, widths, and 
colors available.

5 Click OK.

To edit text in department headers

1 Click the department header. 

The cursor changes to a text cursor.

2 Delete the text, and type a new name.

To delete a department

� ��������	�
	��
��	����	�
	
����
��
	����������

To reorder departments

1 Click the department header that you want to move.

2 Click any area between the black squares.

The cursor changes to four arrows.
• For horizontal departments, drag the department u

or down to the desired position.

• For vertical departments, drag the department left o
right to the desired position.

To change lane margins and minimum lane size

1 In an active diagram, click a department label.

2 Click the right mouse button, and click Format 
Diagram.
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3 Click the Lanes tab, and change the bottom margin, end marg
and minimum lane size.

4 Click OK.
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Working with Shapes and Lines

This chapter covers the following topics:

• Using the Shape Library on page 119

• Placing Shapes in a Diagram on page 123

• Connecting Shapes with Lines on page 125

• Formatting Shapes and Lines on page 132

• Manipulating Shapes and Lines Together on page 140

• Working with Default and Preset Shape and Line Styles on page 157

• Working with Shape Fields on page 164

• Numbering Shapes on page 168

Using the Shape Library

The Shape Library is a custom collection of shapes that you can sele
the Shape Library, you can store shapes that you use most often. By
default, the Shape Library has the Process shape already in it.

In the Shape Library you can:

• Add additional shapes

• Modify the properties of the shapes

• Remove shapes

• Duplicate shapes

• Change the order of the shapes (move up or down)
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• Update shape properties

Any shapes defined with attributes and formatting that you add to a
diagram become part of the Shape Library. Shapes that you add to 
Shape Library using the Toolbox toolbar are also unique to each 
diagram. Saving a diagram saves the shapes that you add to the Lib
Also, saving a diagram as a template is a good way to use an exten
Library more than once.

Tip
You can always copy shapes to the Shape Library directly from Share 
Media.

As you work with a saved diagram, you might find that you use som
shapes more than others. In this case, you can have these shapes 
in the most convenient areas of the Shape Library. You also might w
to organize related shapes together in the Library. You can easily arr
shapes any way you want by moving them up or down.

After you have added shapes to the Library, you can modify them b
editing connect points, adding text layouts, adding VBA code, addin
modeling properties, and changing default formats and fields.
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To add a shape to the Shape Library

1 �����	���������������
����������	���
	�����	������, and then click the arrow 
to display other shapes in the More Shapes flyout menu.

Note
This tool appears under the last shape you added in the Toolbox toolba

2 To open the Shape Library dialog box, click the Shape Library 
command.

3 In the Shape Library box, click Add.

4 Select a subject from the Share Media list.

5 Click the Shape Palette.

6 Use the scroll bar in the Share Media area to scroll through the 
shapes in the subject.

7 Click the shape you want to add, and then click Add.

8 To add more shapes, repeat steps 2 through 5.

9 Click Close.

To add a shape to the Toolbox toolbar

1 In the Shape Library dialog box, click the box to the left of the 
shape you want to add to the Toolbox toolbar.

2 Click Close.
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To remove a shape from the Shape Library

1 In the Shape Library, click the shape you want to remove.

2 Click Remove.

3 Click Close.

Notes
You can only remove a shape from the Shape Library if it is not being 
used by the document.

To edit a shape in the Shape Library

1 In the Shape Library, click the shape you want to edit.

2 Click Edit.

Tip
After you have added shapes to the Library, you can modify them 
by editing connect points, adding text layouts, adding VBA code, 
adding modeling properties, and changing default formats and 
fields.

3 In the Shape Properties dialog box, make the changes.

4 Click OK.

To duplicate a shape in the Shape Library

1 In the Shape Library, click the shape you want to duplicate.

2 Click Duplicate.
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You can duplicate shapes to edit the attributes and formatting so
shapes that might look similar behave differently.

3 Click Close.

To arrange shapes in the Shape Library

1 Click the shape you want to move.

2 Click Move Up or Move Down.

3 Repeat steps 1 and 2 until the shapes are in the order you want

4 Click Close.

Placing Shapes in a Diagram

Because you use many shapes when creating a diagram, several me
exist for placing shapes.

• Placing multiple shapes of the same type—You can place multip
shapes of the same type without having to select the same shap
the Shape Library again. To do this, place a shape in the diagra
space, click anywhere in the diagram, and then place another sh

• Placing multiple types of shapes—You can select each shape in
Shape Library one at a time to place in the diagram space.

You can place shapes in a diagram two ways:

• Using the Shape Library
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• Using the Share Media Subject tabs

Note
Double-clicking on a shape in the Toolbox toolbar lets you place 
multiple shapes of the selected type without having to place a shape, 
click in the diagram space, and then place another shape. You can poin
and click. This also makes the Finished button appear.

Shape Library

Placing shapes using the Shape Library requires using two toolbars

Toolbox toolbar- This toolbar contains the process shape by default
any shapes you designated in the Shapes Library dialog box to appe
the toolbar. Click the arrow below the last shape to open the More 
Shapes flyout menu.

More Shapes toolbar- This toolbar contains the rest of the shapes y
added to the diagram using the Shape Library dialog box. It also 
contains the Shape Library command for opening the Shape Library
dialog box.

Share Media Subject tabs

The Gallery contains Share Media Subject tabs. You can place shapes
a diagram using these tabs. After you open Share Media and select a 
subject to create a tab, click the shapes and drag them to the diagra
space. To open the Share Media, click the Shape Palettes tool on th
Standard toolbar.
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To place a shape using the Shape Library

1 Click the shape on the Toolbox toolbar or the More Shapes flyou
menu that you want to place.

2 Click in the diagram where you want to place the shape.

To place a shape using the Gallery

1 Click a Share Media Subject tab in the Gallery.

2 Click a shape in the palette.

3 Click in the diagram.

Connecting Shapes with Lines

The type of line that you draw is indicated by the Connector Lines to
selected in the Toolbox toolbar. Select the line type that you want to
draw by clicking the arrow under the Connector Lines tool, and then
selecting the line from the flyout menu.

You can use any of the six line (routing) tools to connect shapes:

• Direct Line

• Right Angle Line

• Curved Line

• Org Chart Line
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• Cause and Effect Line

• Lightning Bolt Line

You can connect lines by dragging or clicking, and connect two sha
with a line. When you connect the shapes with a line, the end points
the line snap to the nearest connect points in the shapes.

Using Connector Lines

Connector lines automatically display and snap to points on closed 
shapes. After placing a connector line, you can easily detach it and
reattach it at a different snap point. When you attach connector lines
shape, you can move the shape and the lines remain attached.

���������		
�����
�������������
��������������

The boxes in this chart are 
connected with connector lines.

The line remains connected to 
the box when the box is moved.
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When working with large diagrams spanning many pages, you migh
want to use off-page connectors to keep shapes and lines organized
can add an off-page connector to a line manually by using a right mo
on the line, and then clicking the Format command. In the Format L
dialog box, click the Arrows and Crossovers tab, and select the 
Connectors box.

Note
In the Format Line dialog box, you can change the color and line style fo
a selected line.

You can also set automatic off-page connectors for all lines that bre
between pages. On the Format menu, click the Format command, a
then click the Off-Page Connectors tab. In the Off-Page Connectors
you can set automatic connectors and choose options such as direc
symbols and page numbering.

To connect two shapes by dragging

1 Make sure that you select the desired connector line tool in the 
Toolbox toolbar.

2 Point inside the first shape, press and hold the left mouse button
then drag the pointer to the side of the first shape where you wa
the line to begin.

3 Trace the path you want the line to follow by dragging the pointe
to the side of the second shape where you want the line to end.
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4 Release the mouse button.

Note
Double-clicking on a line in the Toolbox toolbar lets you connect 
multiple lines of the selected type without having to click a line, connect
a line, and then connect another line. You can point and draw. This also
makes the Finished button appear.

You can also draw lines that connect to other lines or lines that remain 
unconnected. On the Tools menu, click Options, and then click the 
Connector Lines tab. Select the Allow lines to connect to other lines box
and Allow unconnected lines box.

To connect two shapes by clicking

1 Click the Connector Lines tool.

2 Click the side of the shape from which you want to start the line.

3 Without clicking the mouse, move the pointer to a connect point 
the shape to which you want to connect the line.

4 Click the connect point. 

A red box on both shapes indicates the connect points that you 
selected on each shape.

To move a line end from one connect point to another on a shape

1 Select a line connected to a shape.

Two red boxes appear on each end of the line.

2 Move the cursor over the line end that you would like to move to
another point.
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3 Click and hold the left mouse button down, and then move the li
end to a new connect point

4 Release the left mouse button.

To edit connect points between shapes

1 In the Shape Library dialog box, select the shape you want to ed

2 Click Edit.

3 Click Symbol.

4 In the Edit symbol dialog box, click the Connect Points tab.

5 Use the Mode or Actions options to add or delete connect points

To connect two shapes using the Connect Shapes command

1 Click and hold the left mouse button down, and draw a bounding
box around the shapes you want to connect.

2 Click the line type you want.

3 On the Arrange menu, click Connect Shapes.

To reverse line ends between shapes

1 Click and hold the left mouse button down, and draw a bounding
box around the shapes with a line you want to reverse.

2 On the Arrange menu, click Reverse Ends.

To choose line routing types

1 Click the Connector Lines tool.
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2 Click the type of line you want. There is a tool for each type.

Tip
To define a frequently used line type and style combination, add a prese
style.

To add a vertex to a line

1 Click either the direct line or the right angle line between two 
shapes.

2 Click the right mouse button, and then click Add Vertex.

An X appears on the line.

3 Slide the X on the line to the position you want.

4 Click the line.

A black box appears at the vertex point.

5 To create the new line bend, click and move the black box.

Direct Line Right Angle Line Curved Line

Org Chart Line Cause and Effect 
Line 

Lightning 
Bolt
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6 Release the left mouse button.

Note
If you move connector lines manually, you can also restore them 
automatically to their original position. To move lines back to their 
original position, use a right mouse click on the line, and then click 
Route Line.

To restore automatic line routing

1 Right mouse click the right angle connector line.

2 Click Route Line.

3 To finish the line move, click in the diagram space.

To add manual off-page connectors to a line

1 Click on a line.

2 Click the right mouse button, and click Format Diagram.

3 In the Format Line dialog box, click the Arrows and Crossovers 
tab, and then select the Connectors box.

4 Click OK.

Note
You can also set automatic off-page connectors for all lines that 
break between pages. On the Format menu, click the Format 
command, and then click the Off-Page Connectors tab. In the Off-
Page Connectors tab, you can set automatic connectors and choose
options such as directional symbols and page numbering.
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Formatting Shapes and Lines

Using the formatting options in iGrafx Professional helps you create 
diagrams that look professional and communicate the message tha
are trying to send.

Formatting options for shapes and lines appear on the Format menu
Formatting toolbar, and the Gallery. You can also use the Shape Lib
Share Media, and the Defaults tab on the Format Diagram dialog box
set formatting options. See Working with Default and Preset Shape an
Line Styles on page 157.

Applying Fill Formats

You can use different colors and fill patterns to differentiate flows and
identify individual shapes. For example, you could use a cross-hatc
gray fill to identify incomplete processes and a solid yellow fill to 
identify completed processes.

To add a color, pattern, or gradient to a shape fill

1 Click the shape you want to fill in.

2 On the Format menu, click Fill.

3 In the Format Shape dialog box, click the Fill tab.

4 Select a solid, pattern, or gradient from the available styles.
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5 Click OK.

Tip
You can also use the Gallery to apply colors and styles.

Applying Line and Border Formats for Shapes

You can choose different line styles for shape outlines. Shape lines 
include not only the outside part of a shape, but also any interior lin
used in the shape and any exterior lines connected to a shape. The
many useful line styles for outlines, including solid, dashed, and cen
lines.

To format lines for shape borders

1 In an active diagram, click the shape you want to format.

2 On the Format menu, click Line and Border.

3 Select from the various line types, styles, widths, and colors 
available.

4 Click OK.

Tip
You can also use the Gallery to apply lines and borders.
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Applying Line Formats for Lines

You can use a number of styles for lines, including solid and dashed
lines. Line styles are commonly used in flowcharts to convey the 
following information:

You can choose different line weight and colors for each line and 
arrowhead. Varying line weights distinguish data flows and draw 
attention to certain transitions or data transfers in a diagram.

To format lines

1 In an active diagram, click the line you want to format.

2 On the Format menu, click Line and Border.

3 Select from the various line types, styles, widths, and colors 
available.

4 Click OK.

Line Style Meaning

Solid lines with 
arrows

Show data flow

Dashed lines Represent multiple transitions and optional 
steps

Center lines Heavier weight lines that represent 
enclosure outlines or draw attention to a 
specific diagram element
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Applying Arrow and Crossover Formats

Arrowheads help indicate direction. iGrafx Professional provides two 
ways to use directional line arrows: 

• Source Arrows

• Destination Arrows

Many beginning and ending arrow styles exist for both source and 
destination ends. Try using color to enhance your diagram. You cou
use one color for all beginning arrowheads and another for all endin
arrowheads.

With crossovers, you can set the style and size when lines cross ov
each other. You can choose from five different styles of crossovers. 
you do not choose a crossover style, the lines cross with no indicati
which can make it difficult to tell which lines connect to which shape

Bunny hops

If the line is on top, it shows the hop; if 
it is on the bottom, it shows as a solid 
line.

Broken lines

If the line is on top, it shows as a solid 
line; if it is on the bottom, it shows as a 
broken line.

Solid lines

If the line is on top, it shows as a solid 
line; if it is on the bottom, it shows as a 
solid line. These cross with no 
indication.
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You can specify the crossover style of individual lines. If you have a
bunny-hop line over a broken line, both the bunny hop and the gap 
appear. If you have a bunny-hop line under a broken line, two solid l
appear. In general it is best to use one crossover style throughout y
diagram.

Tip
When you draw a line that crosses any existing lines or shapes it goes 
behind the lines or shapes. To bring the line to the front, click it, click 
Order, and then click Bring to Front button on the Draw toolbar.

You set the style and size of crossovers by clicking Connector Line 
the Format menu, and then selecting the type and size you want. Yo
also can choose the crossovers style by clicking the Crossovers too
the Formatting Toolbar, and then clicking the type you want.

To choose arrowhead styles

1 Click the line you want to add arrowheads to.

2 On the Format menu, click Line and Border.

3 In the Format Shape dialog box, click the Arrows and Crossover
tab.

4 Choose either a Source Arrow line end, a Destination Arrow line
end, or both.
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5 Click OK.

Note
You cannot change arrowhead styles on filled lines.

To choose a line crossover

1 Click the line you want to cross over another line.

2 On the Format menu, click Line and Border.

3 In the Format Shape dialog box, click the Arrows and Crossover
tab.

4 Select a crossover style and size.

5 Click OK.

Applying Shadow/3D Formats

You can use shadows and 3D formats as indicators for shapes. For
example, shapes with shadows can indicate that a linked diagram e
from a shape. You can choose over ten positions for the 3D appear
of your shape.

To add a shadow or 3D effect to a shape

1 Click the shape you want to add an effect to.

2 On the Format menu, click Shadow/3D.

3 Select Shadow or 3D.

4 Select from the various styles, depths, and colors available.
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5 Click OK.

Tip
You can also use the Gallery to apply shadows and 3D effects.

To color a shadow

1 Click a shape.

2 On the Format menu, click Shadow/3D.

3 Select Shadow.

4 Select a color from the Color list.

5 Click OK.

Tip
Click Apply to see the results of your changes without closing the dialog
box.

To change a shadow depth

1 Click a shape.

2 On the Format menu, click Shadow/3D.

3 Select Shadow.

4 Select a new depth from the Depth list.
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5 Click OK.

Tip
Click Apply to see the results of your changes without closing the dialog
box.

To change a shadow direction

1 Click a shape.

2 On the Format menu, click Shadow/3D.

3 Select Shadow.

4 Scroll through the Style box and select a new direction.

5 Click OK.

Tips
Click Apply to see the results of your changes without closing the dialog
box.

You also can use the Shadow tool on the Formatting toolbar to change 
the shadow direction.
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Manipulating Shapes and Lines Together

iGrafx Professional uses several commands to organize the look and
position of shapes in a diagram. You can find the following comman
on the Arrange menu and in the Draw toolbar.

• Align command

• Make Same Size command

• Space Evenly command

• Rotate/Flip command

• Order command

• Combine command

The Arrange menu also contains time-saving commands that turn 
multiple step operations into one step.

Command Description

Connect Shapes Connects selected shapes with a 
connector line.

Replace Shapes Replaces a selected shape with a shape from 
Share Media or the Shape Library.

Reverse Ends Reverses the line ends between two selected 
shapes.

Fit to Text Fits a select shape to text typed in the 
shape.
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To replace shapes

1 Click the shapes in the diagram you want to replace.

2 On the Arrange menu, click Replace Shapes.

3 In the Replace Shape dialog box, find and click the shape you w
to use as a replacement.

4 Click Replace.

5 Click OK.

Notes
Any manually resized shape or shape that has been fitted to text must b
resized after you replace the shape.

When you replace shapes, the new shapes connect to the lines on the 
shapes. The program automatically chooses the closest connect point o
the new shapes.

iGrafx Professional automatically preserves shape numbers, colors, 
borders, patterns, and text size when it replaces the shape.

To fit shapes to text

1 Click the text block or the shape that contains the text.

2 On the Arrange menu, click Fit to Text.

Tip
Press F8 to fit a shape or a text block to text.
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Align command

To align objects

1 Click the objects you want to align.

Command Draw 
toolbar

Description

Left Aligns the selected object or 
objects vertically based on their 
left edges.

Center Aligns the selected object or 
objects vertically based on their 
centers.

Right Aligns the selected object or 
objects vertically based on their 
right edges.

Top Aligns the selected object or 
objects horizontally based on 
their top edges

Middle Aligns the selected object or 
objects horizontally based on 
their centers.

Bottom Aligns the selected object or 
objects horizontally based on 
their bottom edges.
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2 On the Arrange menu, point to Align, and click Left, Center, Righ
Top, Middle, or Bottom.

Tips
You can use the following shortcut keys for aligning shapes: Align Top 
(CTRL+SHIFT+4), Align Middle (CTRL+SHIFT+6), Align Bottom 
(CTRL+SHIFT+8), Align Left (CTRL+SHIFT+ 3), Align Center 
(CTRL+SHIFT+ 5), and Align Right (CTRL+SHIFT+ 7).

You can also use the align tools (Align Left, Align Center, Align Right, 
Align Top, Align Middle, or Align Bottom) on the Draw toolbar.

Make Same Size command

Command Draw 
toolbar 

Description

Width Makes the selected object(s) the 
same size based on their width.

Height Makes the selected object(s) the 
same size based on their height.

Both Makes the selected object(s) the 
same size based on their width 
and height.

Fit to Text Makes the selected object(s) the 
same size based on their text.
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To make objects the same size

1 Click the objects you want to make the same size.

2 On the Arrange menu, point to Make Same Size, and click Width
Height, Both, or Fit to Text.

Tip
You can also use the Make Same Size tools on the Draw toolbar.

Make Same Size, Width Make Same Size, Height

Make Same Size, Both Make Same Size, Fit to Text

Space Evenly command

Command Draw 
toolbar

Description

Across, 
Centers

Spaces the selected object or 
objects evenly across the 
diagram based on their centers.

Down, 
Centers

Spaces the selected object or 
objects evenly down the 
diagram based on their centers.
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To space objects evenly

1 Click the objects you want to space evenly.

2 On the Arrange menu, point to Space Evenly, and click Across, 
Centers; Down, Centers; Across, Edges; or Down, Edges.

Tip
You also can use the Space Evenly Across, Centers; Space Evenly 
Down, Centers; Space Evenly Across, Edges; and Space Evenly Down
Edges tools.

Space Evenly Across, Centers Space Evenly Down, Centers

Space Evenly Across, Edges Space Evenly, Down Edges

Across, 
Edges

Spaces the selected object or 
objects evenly across the 
diagram based on their edges.

Down, 
Edges

Spaces the selected object or 
objects evenly down the 
diagram based on their edges.

Command Draw 
toolbar

Description
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Rotate/Flip command

To rotate an object

1 Click the object you want to rotate.

Command Draw 
toolbar

Description

Rotate 
Right

Rotates the selected object or 
objects 90 degrees to the right.

Rotate Left Rotates the selected object or 
objects 90 degrees to the left.

Angle Selects the angle and direction 
for the object you want to 
rotate.

Flip 
Horizontal

Flips the selected object or 
objects horizontally.

Flip Vertical Flips the selected object or 
objects vertically.
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2 On the Arrange menu, point to Rotate/Flip, and click either Rota
Right or Rotate Left.

Tip
You can also rotate the object by clicking the Rotate Right tool or the 
Rotate Left tool on the Draw toolbar.

Rotate Right Rotate Left

To rotate an object by angle

1 Click the object you want to rotate.

2 On the Arrange menu, point to Rotate/Flip, and click Angle.

To select the angle and direction for rotating an object

1 On the Arrange menu, point to Rotate/Flip, and click Angle.

2 Type a number to determine how much your object is rotated.

3 Select either clockwise or counter-clockwise for the rotation 
direction.

4 Click OK.

To flip an object

1 Click the object you want to flip.
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2 On the Arrange menu, point to Rotate/Flip, and click either Flip 
Horizontal or Flip Vertical.

Tip
On the Draw toolbar, click either the Flip Horizontal tool or the Flip 
Vertical tool.

Flip Horizontal Flip Vertical

Order command

Command Draw 
toolbar

Description

Bring to 
Front

Moves the selected object or 
objects in front of other objects 
in the diagram.

Send to 
Back

Moves the selected object or 
objects behind other objects in 
the diagram.

Send 
Backward

Moves the currently selected 
object one level toward the 
back.

Bring 
Forward

Moves the currently selected 
object one level toward the 
front.
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To bring an object to the front

1 Click the object you want to bring to the front.

2 On the Arrange menu, point to Order, and click Bring to Front.

3 The selected object appears in front of all overlapping objects.

Tips
To select an object that is beneath other objects, press and hold CTRL,
and click the top object. As you continue to click, the objects below the 
top object are selected.

You can also bring the object to front by clicking the Bring to Front tool 
on the Draw toolbar.

To send an object to the back

1 Click the object you want to move to the back.
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2 On the Arrange menu, point to Order, and click Send to Back. T
selected object appears behind all overlapping objects.

Tips
To select an object that is beneath other objects, press and hold CTRL,
and click the top object. As you continue to click, the objects below the 
top object are selected.

You can also send the object to back by clicking the Send to Back tool o
the Draw toolbar.

Combine command

Command Draw toolbar Description

Group Groups selected objects.

Ungroup Ungroups selected objects

Connect 
Closed

Connects the selected closed 
objects.

Connect Open Connects the selected open 
objects and closes them.

Disconnect Disconnects the selected 
connected objects.
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To group objects

1 Click the shapes you want to group.

2 On the Arrange menu, point to Combine, and click Group.

To ungroup objects

1 Click the shapes you want to group.

2 On the Arrange menu, point to Combine, and click Ungroup.

To connect closed objects

1 Click the closed objects you want to connect.

Join Creates a new shape by 
joining the selected objects 
together.

Intersect Creates a new shape from 
the intersection of the 
selected objects.

Outline Creates a new shape from 
the outline of the selected 
shapes.

Slice Slices the selected closed 
shape with the selected open 
shape.

Command Draw toolbar Description
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2 On the Arrange menu, point to Combine, and click Connect 
Closed.

Tip
You can also use the Connect Closed tool on the Draw toolbar.

To connect open objects

1 Click the open objects you want to connect.

2 On the Arrange menu, point to Combine, and click Connect Ope

Tip
You can also use the Connect Open tool on the Draw toolbar.
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To disconnect objects

1 Click the object you want to disconnect.

2 On the Arrange menu, point to Combine, and click Disconnect.

Tip
You can also use the Disconnect tool on the Draw toolbar.

.

To join objects

1 Click the objects you want to join.

2 On the Arrange menu, point to Combine, and click Join.

Tip
You can also use the Join tool on the Draw toolbar.

To outline objects

1 Click the objects you want to use to form your outline.
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2 On the Arrange menu, point to Combine, and click Outline.

Tip
You can also use the Outline tool on the Draw toolbar.

To intersect objects

1 Click the objects you want to intersect.

2 On the Arrange menu, point to Combine, and click Intersect.

Tip
You can also use the Intersect tool on the Draw toolbar.
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To slice objects

1 Click the open object and the closed object you want to use for 
slice process.

2 On the Arrange menu, point to Combine, and click Slice.

Note
The Slice command is used only when you are using an open object to
slice through a closed object. The Slice command is not available if you
select two open objects.

Tip
You can also use the Slice tool on the Draw toolbar.

Using Spacing Options Between Shapes

When you connect shapes with right angle lines, you can choose ho
the line segments are offset from the shapes. This feature is useful 
line segments are too short or too long. Your choice affects only righ
angle lines. You can set the spacing options in the Connector Lines
on the Options dialog box.

• Horizontal Spacing- The Horizontal shape spacing option lets yo
set the amount of horizontal space between lines and shapes.
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• Vertical Spacing- The Vertical shape spacing option lets you set t
amount of vertical space between lines and shapes.

To set the line spacing between shapes and lines

1 On the Tools menu, click Options.

2 If necessary, click the Connector Lines tab.

3 Click the Horizontal box, and enter the distance you want betwe
the shape and the first right angle of a horizontal line.

4 Click the Vertical box, and enter the distance you want between 
shape and the first right angle of a vertical line.

Tips
The measurements used (inches or centimeters) are displayed next to t
box. These measurements apply to the whole diagram. To change the 
type of measurement used, click the ruler with your right mouse button,
select Measurement, and click the measurement type you want.

You can also create a toolbar with the inches and centimeters buttons. T
do this, click Tools, click Customize, and click the View category. Click 
the buttons, drag them outside of the Customize dialog box, and drop 
them. (When you drop the second button, be sure it is more or less on to
of the first button. That way, it gets added to the same toolbar instead o
creating a second toolbar with one button in it.) Now that you have a 
toolbar with the inches and centimeter buttons, you can click them to 
change the unit of measurement.
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Working with Default and Preset Shape and Line 
Styles

As you create diagrams, you can reuse the same shape and line st
For example, you can use the same border style and fill pattern for 
decision shapes in a certain flow. You can choose the styles you wa
reuse and store them in a list. These styles are called preset styles.
saving new preset shape and line styles, you can open them by clic
the Shape Style or Line Style lists on the Preset Styles toolbar.

You can set and apply shape and line defaults three ways:

• Defaults tab on the Format Diagram dialog box

• Preset shape and line styles

• Shape Library and Share Media

This list is arranged in order of override capabilities: Preset shape a
line styles you create using the Preset Styles toolbar override shape
line settings you create using the Defaults tab. Defaults you create f
individual shapes appearing in the Shape Library and Share Media 
override styles you create using the Preset Styles toolbar and defau
you create using the Defaults tab.
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To set shape and line defaults using the Defaults tab

1 On the Format menu, click Diagram, and then click the Defaults
tab.

Note
You can set several defaults in this tab. This procedure explains 
how to set one type.

2 Click the Shapes box, and then click Fill.

3 In the Format Fill dialog box, choose a fill style or a foreground 
color.

4 Click OK.

5 In the Defaults tab, click OK.

All shapes that you place in the diagram appear with the fill style
and color you selected.

To add a preset shape style

1 Click the Add Shape Style tool on the Preset Styles toolbar.

2 In the Preset Styles dialog box, click New

3 In the Format Fill dialog box, select the shape options that you 
want.

4 Click OK.

5 In the Preset Styles dialog box, click Rename.

6 Type a new name for the shape style.
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7 Click OK.

8 Click OK.

Tips
You also can add a shape style to the list by selecting a shape with the
desired style in steps 2 and 3. If you select multiple shapes, the Add Sty
tool is inoperative.

Click Toolbars on the View menu, and then click Preset Styles to display
the Preset Styles toolbar.

To choose a preset shape style

1 Select the shape(s) to which you want to apply the style.

2 Click the Shape Styles list on the Preset Styles toolbar.

3 Click the shape style you want. 

Note
If no shape is selected, the preset style appears in the Sample tool and
becomes the current shape style.

If you select a shape before you choose a shape style, the style is appli
to the selected shape and to future shapes.

Tip
Click Toolbars on the View menu, and then click Preset Styles to display
the Preset Styles toolbar.
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To rename a preset shape style

1 Click the Edit Shape Styles tool on the Preset Styles toolbar.

2 In the Preset Styles dialog box, click the preset shape style you 
want to rename, and click Rename

3 Type a new name.

4 Click OK.

5 Click OK.

Tip
Click Toolbars on the View menu, and then click Preset Styles to display
the Preset Styles toolbar.

To delete a preset shape style

1 Click the Edit Shape Styles tool on the Preset Styles toolbar.

2 In the Preset Styles dialog box, click the shape style you want to
delete.

3 Click Remove.

4 Click OK.

Tip
Click Toolbars on the View menu, and then click Preset Styles to display
the Preset Styles toolbar.
� � � � 
 
 � � � 
 � � � � � � � � � � � 
 � � � 
 
 � �  160



�
������

�����

������	
�

�����
����	
�

���������	�
���	��
���
����

����


nt.

 

d 
To add a preset line style

1 ��������	��

����	�����	�����������	��
	�	������	��������
�

2 In the Preset Styles dialog box, click the Line tab.

3 Click New.

4 In the Format Line dialog box, select the line options that you wa

5 Click OK.

6 In the Preset Styles dialog box, click Rename.

7 Type a new name for the line style.

8 Click OK.

9 Click OK.

Tip
You can add a line style to the list by selecting a line with the desired 
style in steps 2 and 3. If multiple lines are selected, the Add Style tool is
inoperative.

You can also add a line style to the list using the Preset Styles comman
on the Format menu.

To choose a preset line style

1 Select the line(s) to which you want to apply the style.

2 Click the Line Styles drop down list on the Preset Styles toolbar.
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3 Click the line style you want.

Tips
If no line is selected, the preset style becomes the current 
line style.

If you select a line before you choose a line style, the style is
applied to the selected line and to future lines.

You can also apply a new line style using the Preset Styles 
command on the Format menu.

To rename a preset line style

1 In the Preset Styles toolbar, click the Edit Line Style 
tool.

2 In the Preset Styles dialog box, click the Line tab, and
then click the preset style you want to rename.

3 Click Rename

4 Type a new name.

5 Click OK.

6 Click OK.

Tip
You can also rename a preset line style by clicking the 
Preset Styles command on the Format menu, clicking the 
Line tab, selecting the line style, and clicking Rename.
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To delete a preset line style

1 Click the Edit Line Styles tool on the Preset Styles toolbar

2 In the Preset Styles dialog box, click the line style that you want 
remove.

3 Click Remove.

4 Click OK.

Tip
You can also delete a preset line style by clicking the Preset Styles 
command on the Format menu, clicking the Line tab, selecting the line 
style, and clicking Delete.

To set shape and line defaults using the Shape Library

1 Select a shape in the Shapes list.

2 Click Edit.

3 In the Edit Shape dialog box, clear the Use Diagram Default 
Format box under Shape Defaults.

4 Click Format.

Note
You can select several formatting options in the Format Shape 
dialog box. This procedure explains how to set one type.

5 On the Fill tab, select a fill style, and then click OK.

6 In the Edit Shape dialog box, click OK.
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7 In the Shape Library, click Close.

To set shape and line defaults using Share Media

1 Click on a Share Media subject tab in the Gallery.

2 Right mouse click on a shape, and then click Properties.

3 In the Shape Properties dialog box, click Edit.

4 In the Edit Shape dialog box, clear the Use Diagram Default 
Format box under Shape Defaults.

5 Click Format.

6 On the Fill tab, select a fill style, and then click OK.

7 In the Edit Shape dialog box, click OK.

8 In the Shape Properties dialog box, click OK.

Working with Shape Fields

In iGrafx Professional you can use shape fields to expand the power 
any selected shape. Inserting a field in a shape helps you attach ex
functionality to a shape. It also helps users of your diagram underst
that shapes with fields included give more information or perform 
special functions.
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A shape field can be something simple like a date and time, or 
something more complex, like a Visual Basic expression. The New F
dialog box contains all the field type functions that you can include w
a shape. This dialog box is dynamic. Depending on what field type 
choose, more information appears on the right side of the dialog for
selecting or changing. After choosing a field type, you can also posi
it at different places inside the shape or outside the shape’s border.

To add a field to a shape

1 Click the shape you want to add a field to.

2 On the Format menu, click Fields.

3 In the Shape Fields dialog box, click New Field.

4 In the Field Type list, click the plus signs next to the field types, 
and click the field you want to insert.

5 Click OK.

6 In the Shape Fields dialog box, move the mouse pointer over th
Location box. A black dot follows the pointer.

7 Click the field box within the outline of the shape.

8 While holding the left mouse button down, move the field box to 
the desired position.

9 Release the left mouse button.

10 Click OK.
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To move a shape field in or around a shape

1 Click the shape that contains the shape field.

2 On the Format menu, click Fields.

3 In the Shape Fields dialog box, move the mouse pointer over th
Location box. A black dot follows the pointer.

4 Click the field box within the outline of the shape.

5 While holding the left mouse button down, move the field box to 
the desired position.

6 Release the left mouse button.

7 Click OK.

To include a shape field description with a shape

1 Click the shape that contains the shape field.

2 On the Format menu, click Fields.

3 In the Shape Fields dialog box, select Include Description.

This places the name of the shape field you use before the actu
shape field. For example, if you include a field code for page 
number, PageNumber: appears prior to the page number with th
selected shape.

4 Click OK.

To set the text orientation for a shape field

1 Click the shape that contains the shape field.

2 On the Format menu, click Fields.
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3 In the Shape Fields dialog box, select one of the text orientation
under the Location box.

4 Click OK.

To set advanced shape field options

1 Click the shape that contains the shape field.

2 On the Format menu, click Fields.

3 In the Shape Fields dialog box, click Advanced.
• To wrap the shape field description, select Limit Text Width an

change the Width.

• To hide the shape field from view in or around the shape, sele
Hide Text.

• To prevent moving the shape field text from its set position in o
around the shape, select Freeze Text.

To delete a shape field

1 Click the shape that contains the shape field.

2 On the Format menu, click Fields.

3 In the Shape Fields dialog box, click Delete.
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Numbering Shapes

iGrafx Professional has several options for numbering and renumberi
shapes in a diagram. You can apply numbering commands to indivi
shapes, all shapes in a diagram, new shapes that you place, or exis
shapes in a diagram.

Using numbering commands you can:

• Show or hide shape numbers

• Automatically number shapes

• Manually number shapes

• Change the default number format

• Set an area in a shape where you would like the number to appe

Note
Shape numbering is turned off by default. Before you can make any 
changes to shape numbers, you must select a shape and show its shap
number, or for all shapes, show all shape numbers.
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To show or hide numbers on all shapes

� On the Format menu, point to Numbering, and click Show All Sha
Numbers or Hide All Shape Numbers.

Note
This feature only affects shapes numbered with the Numbering feature. 
you type a number as text in the shape, the number will not be shown o
hidden using this method.

To show or hide numbers on selected shapes

1 Select the shapes whose number you want to show or hide.

2 On the Toolbox toolbar, click the Shape Numbering tool.

3 Click Show Shape Number or Hide Shape Number.

To renumber all shapes automatically

1 On the Format menu, point to Numbering, and click Auto 
Renumber.

2 In the Automatic Renumber dialog box, select All Shapes.

3 Type a starting number in the Starting Number dialog box.

4 Select a renumber style.

5 Click OK.
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To renumber selected shapes automatically

1 Select the shapes in the diagram you want to renumber.

2 On the Format menu, point to Numbering, and click Auto 
Renumber.

3 In the Automatic Renumber dialog box, select Selected Shapes

4 Type a starting number in the Starting Number box.

5 Click OK

To renumber shapes manually

1 On the Format menu, point to Numbering, and click Manual 
Renumber. The pointer changes to the Number pointer when yo
move it into the drawing area.

2 In the Renumber dialog box, type the next number you want 
displayed.

3 Click the first shape in the diagram you want to renumber.

4 Click the other shapes in the order you want them renumbered.

5 In the Renumber dialog box, click Finished.

To set the default number format for new shapes

1 On the Format menu, point to Numbering, and click Default 
Number Format.

2 In the Shape Fields dialog box, click Format.
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3 In the Numbering Format dialog box, select a new example numb
from the Example Number list. 

Note
You can also type your own numbering schemes directly in this 
list.

4 If you selected a two-part example number, click either the left o
right number or letter to increment.

5 Click OK to close the Numbering Format dialog box.

6 Click OK.

To change the number format for existing shapes

1 On the Format menu, point to Numbering, and click Number 
Format.

2 In the Shape Fields dialog box, click Format.

3 In the Numbering Format dialog box, select a new example numb
from the Example Number list.

4 If you selected a two-part example number, click either the left o
right number or letter to increment.

5 Click OK to close the Numbering Format dialog box.

6 Click OK.
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To set the numbering position in a shape

1 On the Format menu, point to Numbering, and click Default 
Number Format.

2 In the Shape Fields dialog box, move the mouse pointer over th
Location box. A black dot follows the pointer.

3 Click the field box within the outline of the shape.

4 While holding the left-mouse button down, move the field box to
the desired position.

5 Release the left-mouse button.

6 Click OK.
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Working with Text

This chapter covers the following topics:

• Creating and Manipulating Text on page 173

• Formatting Text on page 179

• Working with Default and Preset Text Styles on page 184

Creating and Manipulating Text

Five types of text exist in iGrafx Professional:

• Shape - Text that you type directly in a shape. As you type text, t
shape automatically resizes to fit the text. You can use the shape 
to describe only that shape.

• Department Name - Text that you type directly in department 
headers.

• Connector Line

• Decision - Text generated from selections in the Properties dial
box. You cannot delete this text in the diagram space.

• Direct - Text that you create by selecting a line and typing on i

• General

• Graphic - Text that you type directly in graphic.

• Direct - Text that you create by clicking the Text tool on the 
Toolbox toolbar, clicking in the diagram space, and then typing
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• Field - Text that appears as a field in or around a shape. 

You can:

• Create freeform text, shape text, and text on lines.

• Create and format callout lines.

• Set the formatting style for text.

• Set the alignment of a text block.

• Create and set tab sizes.

• Set the text orientation.

• Align text.

• Make text a bulleted list and set the bullet style and spacing.

• Rotate text.

• Make text opaque.

• Set tab spacing.

• Modify line spacing between paragraphs, and set the spacing un

• Increase or decrease text indention.

New Text Features

iGrafx Professional includes the following new text manipulation 
features:

• Shapes automatically adjust to the text you type. 

• When you click a shape, you can automatically begin entering te
into the shape.

• You can add multiple text fields to a shape.

• You have more formatting options for text in a diagram. You can
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• Make the text a bullet list.

• Set tab spacing.

• Modify line spacing between paragraphs.

• Increase or decrease text indention.

• Set the text orientation.

• You have more formatting features that you access directly from
the Formatting toolbar. You can:

• Rotate text blocks.

• Make text opaque.

• Increase and decrease indents and line spacing in text blocks

To create shape text

1 Click within the shape that you want to add text to.

2 Type the text you want in the shape. To start a new line, press 
ENTER.

3 When you finish typing, click outside the shape.

To edit text in department headers

1 Click the department header. 

The pointer changes to a text cursor.

2 Delete the text, and type a new name.
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To create text in the diagram space

1 Click the Text tool on the Toolbox toolbar.

2 Click in the diagram space, and type.

3 When you finish typing, click away from the text.

To add text to a graphic

1 Double-click the graphic. 

2 Type the text in the graphic.

3 To make the text appear in the graphic, click outside of the text b

Tip
You can also use the right mouse menu and click Add Text.

To create text on lines

1 Select the line.

2 Type the text you want in the text block. To start a new line, pres
ENTER.

3 When you finish typing, click outside the text block.

Note
You can have text appear next to lines instead of on lines. On the 
Tools menu, click Options, and then click the Connector Lines tab. 
Under Default Text Line Style, click Next to the line. Text typed 
on a line will appear next to it.
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To select text

� Click the shape or text block you want.

Tips
To select more than one object, Press SHIFT and click. 

iGrafx Professional applies any text options you choose to all the text in 
the selected objects.

To place the text cursor in text

1 Click the shape (including the text block) that contains the text yo
want to change.

2 Point the cursor inside the text you want to change.

To select text by dragging

1 Click the shape (including the text block) that contains the text yo
want to change.

2 Click at the beginning of the text you want to select.

3 Click and hold the left mouse button, and drag across the text yo
want. To select multiple lines of text, drag up or down.

4 Release the mouse button when you are finished.
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To move the text cursor using the keyboard

1 Select the object containing the text.

2 Click to place the text cursor where you want.

3 Press the right or left arrow keys to move the text cursor one 
character at a time. Press CTRL+ right arrow or CTRL+left arrow
to move the cursor one word at a time. To move the cursor one li
press the up or down arrow keys.

To select text using the keyboard

1 Select the object containing the text.

2 Click to place the text cursor at the beginning of the text you wan

3 Press and hold the SHIFT key.

4 Press the right or left arrow keys to select one character at a tim
Press CTRL+right arrow or CTRL+left arrow to select one word a
a time. To select one line up or down from the text cursor, press 
up or down arrow keys.

5 Release the SHIFT key when you are finished.

To delete text

1 Select the object containing the text.

2 Click to place the text cursor where you want to begin deleting te

3 To delete text to the left of the text cursor, press BACKSPACE. T
delete text to the right of the cursor, press DELETE.
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Formatting Text

You can choose styles for text in a diagram. Diagram text consists o
anything you type in the diagram space, in a shape, in a departmen
graphic, or on a line.

Text Appearance

Formatting text includes changing the way the text looks. By changin
font size or color, you change the way text appears on the screen o
printed diagram.

Text Functionality

Formatting text also determines how text relates to other text. Addin
bullets and line indents to a text block helps it look different from oth
text in a diagram. Secondary text areas in shapes create space for 
separate pieces of information.

Text formatting commands appear on the Format menu. You can al
find formatting tools and options on the Formatting toolbar and in th
Gallery.

To choose text styles

1 Select the text you want to change.

2 On the Format menu, click Font.

3 In the Format Text dialog box, scroll through the font list, and 
select the font you want.
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4 To change the font size, scroll through the size list and select th
size you want.

5 To turn text effects on or off, select the box next to Bold, Italic, 
Underline, and Strikethrough. (You can select more than one.)

6 To change the text color, select the Color list and select a color.

7 To set the background of the text to opaque, select the Opaque 

8 Click OK.

Note
To format field text, click the Fields command on the Format 
menu, select the field, and click Font.

To set bullet styles for text

1 On the Format menu, click Text Alignment.

2 In the Format Text dialog box, click the Paragraph tab, and selec
the bullet style from the Bullet Style list.

3 Type the number of tabs for the bulleted text list to move to the 
right in the Indents box.

Notes
You can also use the Bullets tool on the Formatting toolbar.

Bullets Tool

Set the tab spacing (size) in the Block tab.
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4 Click OK.

To set the line spacing for text

1 On the Format menu, click Text Alignment.

2 In the Format Text dialog box, click the Paragraph tab.

3 Under Interline Spacing, select the number of lines to space in t
Spacing box, and select Lines or Points from the Spacing Units 

Note
You can also use the Decrease Line Spacing and Increase Line 
Spacing tools on the Formatting toolbar.

Decrease Line Spacing toolIncrease Line Spacing tool

4 Click OK.

To set text margins inside shapes

1 Click the shape.

2 On the Format menu, click Text Layout.

3 Select Shape Default, Fixed, or Percentage from the Shape Marg
list.

4 Type the shape margins for the top, bottom, left, and right.

5 Click OK.
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To add secondary text areas to a shape

1 Click the shape.

2 On the Format menu, click Text Layout.

3 In the Format Text Layout dialog box, click Add.

4 Click Left, Top, Right, or Bottom.

The secondary text area is highlighted in blue in the preview sha

5 In the Size box, select the size of the text area.

6 Click OK.

Note
You can also format secondary areas in the Format Text Area 
dialog box by clicking Format under Selected Text Area.

To delete secondary text areas from a shape

1 Click the shape.

2 On the Format menu, click Text Layout.

3 In the Format Text Layout dialog box, click the secondary text ar
in the preview shape you want to remove.

4 Click Remove.

5 Click OK.

To align text blocks

1 On the Format menu, click Text Alignment.
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2 In the Format Text dialog box, click the Block tab

3 To change the horizontal block alignment, click Left, Center, or 
Right.

4 To change the vertical block alignment, click Top, Middle, or 
Bottom.

5 Click OK.

To set text orientation

1 On the Format menu, click Text Alignment.

2 In the Format Text dialog box, click the Block tab.

3 Under Text Orientation, click the direction you want your text 
oriented.

4 Click OK.

To rotate text without the shape

1 Click the text block or shape that contains the text you want to 
rotate.

2 Click the Rotate Text Left or Rotate Text Right tool on the 
Formatting toolbar.

3 Repeat step 2 to continue rotating the text until it is in the positio
you want.

4 Click outside the text area.
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To rotate text with a shape

1 Select the text you want to rotate.

2 On the Arrange menu, click Rotate/Flip, and then click Rotate 
Right, Rotate Left, or Angle.

Working with Default and Preset Text Styles

As you create diagrams, you can reuse the same text defaults and s
For example, you can set a default for text appearing only in shapes
another default for text appearing on connector lines. Setting default
different types of text helps the creator and users of a diagram 
understand that text can be used for more than labeling purposes.

You can set and apply text defaults three ways:

• Defaults tab on the Format Diagram dialog box

• Preset text styles

• Shape Library and Share Media

This list is arranged in order of override capabilities: Preset text styl
you create using the Preset Styles toolbar override text settings you
create using the Defaults tab. Defaults you create for individual sha
appearing in the Shape Library and Share Media override styles you 
create using the Preset Styles toolbar and defaults you create using
Defaults tab.
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To set text defaults using the Defaults tab

1 On the Format menu, click Diagram, and then click the Defaults
tab.

Note
You can set several defaults in this tab. This procedure explains 
how to set one type.

2 Click the Shapes box, and then click Font.

3 In the Format Text dialog box, choose a font from the Font list.

4 Click OK.

5 In the Defaults tab, click OK.

All new shapes created will have the default font style applied.

To add a preset text style

1 Select the text with the styles you want (font, size, style, and colo

2 On the Preset Styles toolbar, click the Add Text Style tool.

Tips
To display the Preset Styles toolbar, use a right mouse click in a toolba
area, and click Preset Styles.
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 To apply a preset text style

1 Select the text you want to apply the style to.

2 On the Preset Styles toolbar, select a style from the Text Styles 

To rename a preset text style

1 Click the Edit Text Style tool on the Preset Styles toolbar.

2 In the Preset Styles dialog box, click the style you want to renam

3 Click Rename.

4 In the Rename Style dialog box, type the new name.

5 Click OK.

6 In the Preset Styles box, click OK.

To delete a preset text style

1 Click the Edit Text Style tool on the Preset Styles toolbar.

2 In the Preset Styles dialog box, click the text style you want to 
delete.

3 Click Remove.

4 Click OK.

To set text defaults using the Shape Library

1 In the Shape Library, select a shape in the Shapes list.

2 Click Edit.
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3 In the Edit Shape dialog box, clear the Use Diagram Default 
Format box under Shape Defaults.

4 Click Format, and select Font.

Note
You can select several formatting options in the Format Text 
dialog box. This procedure explains how to set one type.

5 On the Font tab, select a font from the Font list, and then click O

6 In the Edit Shape dialog box, click OK.

7 In the Shape Library, click Close.

Note
New shapes added to the diagram space using this shape will 
default to this text style.

To set text defaults using Share Media

1 Click on a Share Media subject tab in the Gallery.

2 Right mouse click on a shape, and then click Properties.

3 In the Shape Properties dialog box, click Edit.

4 In the Edit Shape dialog box, clear the Use Diagram Default 
Format box under Shape Defaults.

5 Click Format, and select Font.

6 On the Font tab, select a font from the Font list, and then click O

7 In the Edit Shape dialog box, click OK.
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8 In the Shape Properties dialog box, click OK.

Note
New shapes added to the diagram space using this shape will 
default to this text style.
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Drawing Graphics

This chapter covers the following topics:

• Understanding Differences between Graphics and Shapes on page 
189

• Drawing Graphics on page 190

• Manipulating Graphics on page 192

• Drawing Callout Lines on page 195

Understanding Differences between Graphics and 
Shapes

Understanding the differences between a graphic and a shape helps
use shapes more effectively. In iGrafx Professional, graphics and shapes
serve different purposes: Shapes are intelligent and graphics serve a
helpers.

The following table describes some differences between graphics an
shapes:

Graphics Shapes

Draw using Draw Tool 
options.

Place using the Toolbox toolbar or the 
Gallery.

Do not use connector lines. 
Use callout lines to attach 
graphics to other objects.

Use connection lines to connect 
between shapes. Connect lines from 
other shapes to them.
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Things you can do with graphics include:

• Adding Text

• Reshaping

• Rotating

• Attaching to shapes using callout lines

• Converting to a shape

As helpers, graphics can add value to shapes by describing what th
shape is and why it is in the diagram. For example, you can use cal
lines to attach a note (a graphic with text) to a shape. Callout lines 
attached to shapes from graphics move together as one unit. If you m
the shape, the graphic moves with it.

Drawing Graphics

iGrafx Professional contains several options for drawing graphical 
shapes and lines. These options include:

• Square

• Rounded Square

• Rounded Rectangle

• Circle

• Ellipse

Not intelligent. Cannot add 
fields, custom data, VBA 
code, and other shape 
properties.

Intelligent. Add fields, custom data, 
and VBA code.

Graphics Shapes
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• Polygon

• Smoothed Polygon

• Jointed Line

• Curved Line

All graphics have the same attributes. After drawing a graphic, hand
(black boxes) appear around it and a red square appears inside of i

To open the Draw toolbar, click the Draw tool on the Formatting tool

To view drawing options, click the Draw Tool on the Draw toolbar.

When you click a graphic option from the Draw Tool, the pointer 
changes to intersecting lines with a small icon of the graphic. You ca
draw as many graphics as you want while the pointer is displayed.

Tip
You can also tear off the Draw Tool and move it into the diagram space
by clicking the Draw Tool and moving the pointer to the gray bar at the 
top of the flyout. When the bar turns blue, click and hold down the left 
mouse button and drag the flyout to the diagram space. After you tear o
the Draw tool, you can double-click a graphic to draw multiple graphics 
of the same type. When you finish drawing the graphics, click the 
Finished button.
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To draw a graphic

1 On the Draw toolbar, click the Draw Tool.

2 Click a draw option.

3 Move the pointer to the diagram space, press the left mouse but
and drag down and to the right.

4 Release the left mouse button.

Manipulating Graphics

After drawing a graphic, you can move it or resize it. You can also 
arrange and combine a series of graphics. Graphics share some of
same features as shapes such as adding text and rotating. You can
reshape a graphic using points and convert a graphic to a shape.

To add text to a graphic

1 Double-click the graphic. 

2 Type the text in the graphic.

3 To make the text appear in the graphic, click outside of the text b

Tip
You can also use the right mouse menu and click Add Text.
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To move a graphic

1 Click the graphic.

2 Move the pointer inside the graphic.

The pointer changes to four arrows.

3 Click inside the graphic and drag it to a new position.

4 Release the mouse button.

To resize a graphic

1 Click the graphic.

2 Left mouse click any of the black squares surrounding the graph

3 Without releasing the mouse button, drag the square.

4 Release the left mouse button.

5 To finish resizing the graphic, click outside of it.

To rotate a graphic

1 On the Draw toolbar, click the Rotate tool.

The pointer changes to four arrows in a circle and four green circ
appear on each corner of the graphic.

2 Click one of the green circles.

3 Without releasing the left mouse button, rotate the graphic to the
desired position.

4 Release the left mouse button, and then click the Finished butto
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To reshape a graphic

1 On the Draw toolbar, click the Reshape tool.

The pointer changes to a white arrow. When you move the point
over a reshape point (white circle), it changes to a black arrow.

2 Click one of the white circles.

3 Without releasing the left mouse button, drag the reshape point t
new position.

4 Release the left mouse button, and then click the Finished button
the Reshape toolbar.

Note
When you click the Reshape tool, the Reshape toolbar opens. You 
can use the tools on the Reshape toolbar to edit the curve of the 
shape, add reshape points to the shape, or remove reshape points 
from the shape.

To convert a graphic to a shape

1 Click the graphic.

2 On the Arrange menu, point to Convert to, and click Shape.

Note
You can also convert a shape to a graphic. When you convert a 
shape to a graphic, any data attached to the shape, such as field 
codes VBA, or other shape properties, is lost.
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Drawing Callout Lines

Graphics used as notes or descriptions help highlight important 
information about shapes in a diagram. You can attach graphics as 
to shapes using callout lines. You can also attach graphics to conne
lines or other graphics. After you attach a graphic to a shape using 
callout line, its position is relative to the shape. If you reposition the 
shape in the diagram, the graphic moves with it.

To connect a callout line to a shape from a graphic

1 Click the graphic.

2 Move the pointer over the red square in the graphic

The pointer changes to a white arrow.

3 Click the red square.

4 Without releasing the left mouse button, drag the line from the re
box to the shape.

5 Release the left mouse button.

A red box appears on the shape where the callout line is connec

6 Click outside of the shape.

To format a callout line

1 Click the graphic with a callout line attached to it.

2 On the Format menu, click Callout Line.

3 In the Format Callout Line dialog box, select formatting options i
the Line tab.
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4 To add an arrow to the line and change arrow formatting, click th
Arrow tab.

5 Click OK.

Tip
If you want to view lines connecting graphics to shapes, click Hidden 
Lines on the View menu.
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Organizing Diagrams

This chapter covers the following topics:

• Working with Diagram Types and Components on page 197

• Working with Layers on page 201

Working with Diagram Types and Components

Creating multiple components and saving them in a document is a g
way to organize, package, and store similar information. You can cre
three separate component types using iGrafx Professional:

• Diagrams

• Basic Diagrams contain shapes, lines, graphics, and text 
describing ideas or functions.

• Process Diagrams contain shapes, connector lines, departme
other graphics and text. In process diagrams you can add 
modeling data that can be used with iGrafx Process when 
simulating a process.

• Scenario- Contains set up information for simulating a process 
using iGrafx Process.
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• Report- Contains the results of simulating a process using iGraf
Process.

Note
Scenario and Report components are used with iGrafx Process. If you 
used iGrafx Process to run a simulation, you can select and view scenar
and report data in iGrafx Professional.

For any diagram, you can create or add, view, delete, rename or co
paste components. You can also add a component using a saved 
template.

To create a new component

1 On the File menu, click Components.

2 In the Components dialog box, click New, and click Process, Bas
Diagram, Scenario, or Report.

3 Note You can only create a scenario or report if you have one 
process in your document.

4 Click Close.

To create a new component from a template

1 On the File menu, click Components.

2 In the Components dialog box, click New From Template.

3 In the New Component From Template dialog box, browse for th
template you want to use.

4 In the Template Component box, click the component.
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5 If necessary, type a new name in the Name box, and then click O

6 In the Components dialog box, click Close.

To view a component

1 On the File menu, click Components.

2 In the Components dialog box, click All Components, Diagram 
Hierarchy, or Diagrams by Contained Departments.

3 In the tree hierarchy, click the “+” symbol to expand the 
components.

4 Click the component you want to view.

5 Click View.

6 Click Close.

Tip
All Components lists diagrams, reports, and scenarios. Diagram 
hierarchy lists only diagrams. Diagrams by Contained Departments lists
diagrams within departments.

To delete a component

1 On the File menu, click Components.

2 In the Components dialog box, click All Components, Diagram 
Hierarchy, or Diagrams by Contained Departments.

3 If necessary, click the “+” symbol to expand the components.

4 Click the component you want to delete.

5 Click Delete.
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6 Click Close.

To rename a component

1 On the File menu, click Components.

2 In the Components dialog box, click All Components, Diagram 
Hierarchy, or Diagrams by Contained Departments.

3 If necessary, click the “+” symbol to expand the components.

4 Click the component you want to rename.

5 Click Rename.

6 Type the new name over the existing name.

7 Click outside of the text box.

8 Click Close.

To copy and paste a component from one document to another 

1 On the File menu, click Components.

2 In the Components dialog box, click All Components, Diagram 
Hierarchy, or Diagrams by Contained Departments.

3 In the tree hierarchy, click the “+” symbol to expand the 
components.

4 Click the component you want to copy, and then click Copy.

Note
You can select multiple components for copying by pressing 
SHIFT and clicking the components.
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5 Click Close.

6 On the File menu, click Open, navigate to another document, an
then click OK.

7 On the File menu, click Components.

8 In the Components dialog box, click Paste. 

The original copied components now appear in the dialog box.

9 Click Close.

To convert a basic diagram to a process

� With a basic diagram open, point to Change Diagram Type on th
Tools menu, and click Process. 

Note
If you convert a process to a basic diagram, you will lose modeling data

Working with Layers

With iGrafx Professional, you can organize your diagrams in layers. 
You can place some objects on one layer and others on another lay
such as layering several overhead transparencies.

Layers help you do the following:

• Manage complex diagrams with many overlapping objects.

• Categorize objects that logically belong together by layer.

• View certain objects in your drawing while hiding others.
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• Easily select and change objects.

• Protect objects from accidental changes.

• Trace from a template on another layer.

• Print certain objects only.

By default, each diagram has one layer. The default name of each l
is Layer1, Layer2, and so forth. Layer1 is the back layer.

The Layers command on the Arrange menu contains the following 
commands:

• Layer Manger - Opens the Layer Manager that lists the layers 
defined for the active diagram and lets you perform layer 
operations. In Layer Manager, you can change the visible, print,
and lock properties of layers. It also lets you select the current 
layer; add, delete, and rename layers; change the order of layer
and specify whether you want to change the current or all layers

• Edit All Layers - Selects, moves, and changes all objects in the 
active diagram, regardless of the layer on which they are located
When changing all layers, you cannot move an object on a lowe
layer in front of an object on a higher layer.

• Add Layer - Adds a layer to the active diagram.

• Move to Layer - Moves the selected objects to another layer.

• Move Back One Layer - Moves the layer back one layer.

• Move Forward One Layer - Moves the active layer forward one 
layer.
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The Layers command also lets you switch between changing the cu
layer and changing all layers. Changing all layers lets you select, m
and change all objects in the active diagram, regardless of the layer
which they are located. When changing all layers, you cannot move
object on a lower layer in front of an object on a higher layer.

At the bottom of each diagram window is a layer tab bar that shows a
for each layer defined for that diagram. The tabs show the names o
layers and the order for the layers. A white tab indicates the current
layer. When you hide or lock a layer, the name on that tab is gray. W
the tab bar contains more tabs than can be shown at once, scroll ar
appear at the left of the layer tab bar.

Note
If you add markups to a diagram using iGrafx Viewer, a markup tab 
appears next to other layer tabs in iGrafx Professional.

To change the current layer

� On the layer tab bar at the bottom of the diagram window, click t
tab of the layer you want to make the current layer. You may nee
scroll the layer tab bar to locate the tab.

Note
When a layer is hidden or locked, the name of the layer on the tab is 
unavailable. You cannot make a hidden or locked layer the current layer
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To add a layer to the active diagram

� On the Arrange menu, point to Layers, and click Add Layer.

The new layer is added in front of the current layer and become
the new current layer.

Tip
To display a shortcut menu that lets you add a layer, click a layer tab wit
the right mouse button.

To change all layers

� On the Arrange menu, point to Layers, and click Edit All Layers.

Edit All Layers lets you select, move, and change all objects in t
active diagram, regardless of the layer on which they are located
When changing all layers, you cannot move an object on a lowe
layer in front of an object on a higher layer.

Note
New objects are always placed on the current layer, even when you are
changing all layers.

Tips
To switch back to changing just the current layer, clear Edit All Layers.

To display a shortcut menu that lets you edit all layers, use the right 
mouse button and click a layer tab.
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To delete a layer

1 On the Arrange menu, point to Layers, and click Layer Manager

2 Click the name of the layer you want to delete.

3 Click Delete.

Note
When you delete a layer, all objects on the layer are deleted.

Tip
You also can use the Layer Manager button on the Draw toolbar.

To display a shortcut menu that lets you delete a layer, use the right 
mouse button and click the layer tab for the layer you want to delete.

To rename a layer

1 On the Arrange menu, point to Layers, and click Layer Manager

2 Click the name of the layer you want to rename.

3 Click Rename.

4 Type the new name.

5 Click OK.
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6 Click OK.

Tip
You also can use the Layer Manager button on the Draw toolbar.

To display a shortcut menu that lets you rename a layer, use the right 
mouse button and click the layer tab for the layer you want to rename.

To change the order of a layer

1 On the Arrange menu, point to Layers, and click Layer Manager

2 Click the name of the layer you want to reorder.

3 Click Move Up or Move Down as necessary to position the layer 
the list where you want it.

4 Click OK.

Tip
To display a shortcut menu that lets you change the order of the layers,
use the right mouse button and click the layer tab for the layer you wan
to change the order of.

To move an object to a different layer

1 Click the object.

2 On the Arrange menu, point to Layers, and click Move To Layer.

3 Click the layer to which you want to move the object.
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4 Click OK.

Tips
When you move objects to another layer, you can make that layer the 
current layer.

To display a shortcut menu that lets you move a selected object to 
another layer, use the right mouse button and click the layer tab for the
layer you want to move.

To move an object back one layer

1 Click the object.

2 On the Arrange menu, point to Layers, and click Move Back One
Layer.

Tip
You can also press CTRL+F9 to move the selected object back one lay

To move an object forward one layer

1 Click the object.

2 On the Arrange menu, point to Layers, and click Move Forward 
One Layer.

Tip
You can also press CRTL+F10 to move the selected object forward one
layer,
! � � � 
 
 " 
 
 � � � 
 � � � � � �  207



�
������

�����

������	
�

�����
����	
�

���������	�
���	��
���
����

����


.

o 

 
e 

u 

 

.

n 
To show or hide a layer

1 On the Arrange menu, point to Layers, and click Layer Manager

2 To hide a layer, clear the box under the bulb icon for the layer. T
show a layer, select the box under the bulb icon for the layer.

3 Click OK.

Note
You cannot hide the current layer. If you try to hide the current layer, the
Layer Manager does not close until you make the layer visible or chang
the current layer to a visible layer.

Tips
To speed up the redraw of complicated drawings, hide the layers that yo
are not currently working with.

To display a shortcut menu that lets you show or hide a layer, use the 
right mouse button and click the layer tab for the layer you want to show
or hide.

Hiding a layer does not affect its print property.

To make a layer printable or nonprintable

1 On the Arrange menu, point to Layers, and click Layer Manager

To make a layer nonprintable, clear the box under the printer ico
for the layer.
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To make a layer printable, select the box under the printer icon f
the layer.

2 Click OK.

Note
You can print hidden layers unless they are also nonprintable.

Tips
To display a shortcut menu that lets you show or hide a layer, use the 
right mouse button and click the layer tab for the layer you want to make
printable or nonprintable.

You also can use the Layer Manager button on the Draw toolbar.

To lock or unlock a layer

1 On the Arrange menu, point to Layers, and click Layer Manager

2 To lock a layer, select the box under the lock icon for the layer.

3 To unlock a layer, clear the box under the lock icon for the layer.

4 Click OK.
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When a layer is locked, it can be displayed or hidden, but
cannot be changed, reordered, or deleted.

Note
You cannot lock the current layer. If you try to lock the 
current layer, the Layer Manager does not close until you 
unlock the layer or change the current layer to an unlocked 
layer.

Tips
To display a shortcut menu that lets you lock or unlock a 
layer, use the right mouse button and click the layer tab for 
the layer you want to lock or unlock.

You also can use the Layer Manager button on the Draw 
toolbar.
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Linking Diagrams

This chapter covers the following topics:

• Linking and Embedding from Other Applications on page 211

• Inserting an Embedded Object on page 212

• Dragging and Dropping on page 216

• Linking Shapes to Other Diagrams or Web Pages on page 221

Linking and Embedding from Other Applications

OLE is a protocol that is used by many Windows applications to 
exchange information. iGrafx Professional acts as an OLE container 
application. You use OLE to include information from other programs
into your diagrams.

When you include OLE information, you choose whether to embed o
link it. The main difference between linking and embedding is where
data is stored.

Embedding Objects

The advantage to embedding is that one diagram contains all the 
information. If you copy the file to a floppy disk or another computer 
system, all of the objects are stored within it. The disadvantage is th
size and performance are affected as the number of embedded obje
increases.
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Linking Objects

The advantage to linking is that you ensure that the most recent 
information prepared by other users or computer systems can be ke
up-to-date in your file. The disadvantage is that the linked objects co
be moved or become unavailable.

Note
You can create an OLE link to any Windows application that acts as an
OLE server. To link to other iGrafx documents, use the Link command 
on the Insert menu.

Inserting an Embedded Object

When you create a new object, it is automatically an embedded obj
because there is no file to link it to. An embedded object becomes p
of the iGrafx Professional diagram.

When you embed an object, you can specify either that its contents
appear in the diagram or that an icon be displayed. For example, you
put the contents of a Microsoft Excel chart in the diagram, or you ca
display the Excel icon.
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Insert Object dialog box

Element Description

Create New Invokes an application and creates a new 
occurrence of one of its objects. For example, 
you can open a package like Microsoft 
Equation, design a formula, and insert it beneath 
a symbol in the diagram. 

Object Type Displays a list of all applications registered on 
your computer as OLE objects. The list varies 
from installation to installation, depending on 
the software that is available.

Create from File Inserts an object that already exists. This option 
changes the dialog box. Type the full path name 
for the object or use the Browse button to locate 
the file. If you choose Link, the object is linked; 
otherwise, the object is embedded.

Display as Icon Represents the object in the diagram as an icon. 
This option changes the dialog box so that it 
displays the current icon. You can change it by 
clicking on the Change Icon button. 
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Convert To dialog box

Element Description

Convert To Permanently converts the object to the new object 
type, and displays a list of valid types for your 
computer system. For example, if the object is a 
graphic, then the list includes the graphic editors 
that recognize the current type (and therefore can 
be used to edit it).

Activate As Temporarily activates all embedded objects of the 
selected type. For example, converts all 
PowerPoint drawings to a different graphic editor. 
When you edit the object, you use the application 
you choose, but changes are saved in the 
PowerPoint format. This option is available only 
if there are two or more embedded objects of the 
same type.

Display as Icon Displays the object as an icon. You may want to 
change the icon at this point to correlate to the 
new format.
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To insert a new embedded object

1 On the Insert menu, click OLE Object.

Note
The registration database is the source of information used by 
applications that support OLE. This is the database used by iGrafx 
Professional to determine which objects are registered on your computer
for OLE purposes.

The database (called reg.data) is set up and maintained by Windows an
Windows applications and is located in the Windows directory. If iGrafx 
Professional does not recognize an application object, it may be due to a
problem in this database. Do not move or delete this file, since doing so
may result in a loss of functionality in applications that support OLE.

2 In the Insert Object dialog box, select the object type, and then 
click OK.

3 When you finish creating or editing the object that you want, clos
the application.

Note
Some applications ask you to confirm that you want to close and update
the diagram; others do not. If you are satisfied with the object, be sure t
choose Yes or OK to update the diagram.
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To edit an embedded object

� On the Edit menu, point to [Type] Object, and click Edit.

(The [Type] of object may appear in the menu. For example, the
menu item for a document might be Document Object.)

This opens the application that created the object. For example,
you have embedded a CorelDraw drawing, you can open 
CorelDraw and edit the drawing by double-clicking on it in the 
iGrafx Professional diagram.

To convert an embedded object to a different format

� On the Edit menu, point to [Type] Object, and click Convert.

The current type of object is listed at the top of the Convert dialo
box.

Dragging and Dropping

If you have a source application that supports drag and drop and O
you can create an embedded object by copying from a source file a
pasting into a diagram. You can either drag and drop a selected are
use the Paste Special menu.
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Links dialog box

To embed an object into a diagram

1 Open both the source file and the iGrafx Professional diagram, and 
adjust the window sizes so that both applications are fully 
displayed on the screen.

2 Select the area in the source file that you want to link.

3 Drag the area into the diagram.

Element Description

Update Now This updates the linked object. If the source 
has changed since you opened the diagram or 
last updated the link, this option loads the 
new version.

Open Source This opens the source file in its source 
application. 

Change Source This opens the Change Source dialog box so 
you can change the source file. You can 
choose a different file by entering a new path 
or using the Network button to set the 
location.

Break Link This breaks the link and disconnects from the 
application. When you break a link, the 
linked information remains in your diagram. 
However, it can no longer be updated. The 
link becomes a standard graphic. Once you 
break a link, you cannot reconnect it. 
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• To move the area, use the mouse to drag the area into the 
diagram. The cursor indicates that the selected area is being
moved.

• To copy the area, press and hold the CTRL key while you use
the mouse. The cursor changes to indicate that a copy is mad
the selected area.

4 Release the mouse button.

Note
If you drop an area directly over an activity symbol, the area is embedde
in the symbol.

To use Paste Special for OLE objects

1 Make sure that you save the source file before you link the 
information.

2 Open the source file and select the information that you want to 
link.

3 On the Edit menu. click Copy.

4 Switch to iGrafx Professional, and click Paste Special on the Edit 
menu.

5 In the Paste Special dialog box, select Paste or Paste Special.

Paste- Embeds the object. 

Paste Special- Links the object.

6 Select the Format in the As box.

7 To display the link as an icon, select Display as Icon.
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8 Click OK.

To create a link to an object

1 On the Edit menu, click OLE Links.

2 In the Insert Object dialog box, select Create from File.

3 Type the path to the object or use the Browse button to locate it.

4 Select the Link box.

5 If you want to display the contents of the object as an icon, selec
Display as Icon.

Note
If you do not display as an icon, then the contents of the object are 
shown. For example, the first page of a Word document is 
displayed.

To edit linked information

� Click the shape, and click OLE Links on the Edit menu.

The Links dialog box opens, and each link is displayed with its 
path, type, and update method.
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To control how links are updated

1 On the Edit menu, click OLE Links.

2 Select the link that you want to update.

Note
You can select multiple links by holding down the CTRL key 
while you click each link.

3 For Update, select one of the following:

Automatic- Updates linked information every time there is a 
change in the source file.

Manual- Updates linked information only when you save the 
source file yourself.

4 Click OK.

To view as an icon

1 Click a linked object.

2 On the Edit menu, point to [Type] Object, and click Convert.

3 In the Convert dialog box, select the Display as Icon box.

4 To change the type of icon displayed, click Change Icon.

5 Click OK.
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Linking Shapes to Other Diagrams or Web Pages

You can link shapes to other diagrams or Web pages using iGrafx 
Professional. Linking lets you disclose information in levels by linking
shapes in one diagram to a group of related diagrams.

Linking Shapes to Other Diagrams

Linking shapes to other diagrams helps people in organizations of a
sizes deliver several diagrams from one source. For example, a dia
containing marketing goals can have linked shapes to more in-dept
diagrams explaining sales divisions and the goals of each person w
the division.

Use the General and Inputs tabs on the Properties dialog box to:

• Add links to a new diagram

• Add descriptions and key modifiers to linked shapes

• Edit and delete existing links

• Add advanced link settings

• Activate links

Linking Shapes to Web Pages

Linking shapes to Web pages is another way to distribute diagrams
larger audience. A sales manager using the example above could ta
the same diagram source and post it to the company Intranet page.
Travelling sales people can then browse the company Intranet to ge
latest information on goals and what other sales divisions are doing
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To link a shape to a new diagram

1 In the active diagram, click Components on the File menu.

2 In the Components dialog box, click New, and then click Basic 
Diagram or Process.

A new Basic Diagram or Process is created.

3 Click Close.

4 On the Windows menu, click the name of your initial diagram.

5 Use the right mouse button to click the shape that you want to li
the new diagram to, and then click Properties.

6 In the Properties dialog box, click the General tab, and then clic
New.

7 In the Add Link dialog box, select the new diagram from the Nam
box.

8 To add a key modifier, click the Key Modifiers box, and then pres
CTRL, ALT, SHIFT, or any combination of the three.

Key modifiers let you modify the linked shape without activating 
the link. For example, if you select CTRL as a key modifier you 
can do two things:
• Double-click the shape- This opens the Properties dialog box

you can edit the link.

• Press CTRL and double-click the shape- This activates the lin

Note
If you are using hotkeys to move around in the Add Link Dialog box, 
ALT will replace any key modifiers you have set.
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9 To add a description for the link, type a description in the 
Description box.

10 Click OK.

11 In the Properties dialog box, click OK.

To edit a linked shape

1 Use the right mouse button to click the linked shape, and then cl
Properties.

2 In the Properties dialog box, select the link in the Links box.

3 Click Edit.

4 In the Change Link dialog box, make any changes.

5 Click OK.

6 In the Properties dialog box, click OK.

To activate a linked shape

� Double-click or use the assigned key modifier on a shape.

or

Use the right mouse button to click the linked shape, and then cl
the named link at the bottom of the menu.

or

Use the right mouse button to click the linked shape. In the 
Properties Dialog box, click the General tab, select the link in the
Links box, and then click Activate.
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To delete a linked shape

1 Use the right mouse button to click the linked shape, 
and then click Properties.

2 In the Properties dialog box, select the link in the Link
box.

3 Click Delete.

4 Click OK.

5 In the Properties dialog box, click OK.

To add advanced link settings

1 Open the diagram that you want to link to.

2 Use the right mouse button to click the shape that you
want to be the starting point of the diagram, and then 
click Properties.

3 In the Properties dialog box, click the Inputs tab.

4 Select the Start Point box, and click OK.

5 Open the diagram that contains the shape you want to
link.

6 Use the right mouse button to click the shape, and the
click Properties.

7 Click the General tab, and then select the link in the 
Links box.

8 Click Edit.

9 In the Change Link dialog box, click Advanced.

10 In the Advanced Link Settings dialog box, select Start
from the Start Point box.
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11 To accumulate custom data attached to the shape, select 
Accumulate Custom Data.

12 Click OK.

13 In the Change Link dialog box, click OK.

14 In the Properties dialog box, click OK.

To link a shape to a file or Web page

1 Click the shape that you want to link.

2 On the Insert menu, click Link.

3 In the Add Link dialog box, select File or Web Page.

4 To link a shape to a file, type the path in the Path or URL box.

5 To link a shape to a URL, type the relative path in the Path or UR
box.

6 To add a key modifier, click the Key Modifiers box, and then pres
CTRL, ALT, SHIFT, or any combination of the three.

Key modifiers let you modify the linked shape without activating 
the link. For example, if you select CTRL as a key modifier you 
can do two things:
• Double-click the shape- This opens the Properties dialog box

you can edit the link.

• Press CTRL and double-click the shape- This activates the lin

Note
If you are using hotkeys to move around in the Add Link Dialog box, 
ALT will replace any key modifiers you have set.
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7 To add a description for the link, type a description in the 
Description box.

8 Click OK.
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Using Advanced Diagramming Features

This chapter covers the following topics:

• Working with Custom Data on page 227

• Working with Visual Basic for Applications on page 230

• Working with iDiagrams on page 232

• Working with SPC Charts on page 233

• Working with iGrids on page 236

Working with Custom Data

iGrafx Professional lets you add custom data fields to individual shape
in a diagram. Each data field for a shape has its own name and func
For example, you can accumulate data using selections in the Setup
Custom Data dialog box for a shape labeled Test. You can use this feature
to analyze the cost of activities along the critical path of a process:

Field Elements

Cost Name - Type Cost.

Type - Select Currency.

Format - Select $###0.00.

Accumulation Method - Select Sum.
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After applying these selections, type the dollar amount for Cost and
time for Duration in the Custom Data tab on the Properties dialog bo
you have fields set up to display at the bottom of the shape, this is w
the shape looks like in the diagram:

Note
Any information that you change in these fields at a later time will 
automatically update in the diagram.

To add custom data fields to a shape

1 Right mouse click the shape that you want to add fields to.

2 Click Properties.

3 Click the Custom Data tab, and then click Setup.

Duration Name - Type Duration.

Type - Select Duration.

Format - Select #hrs.

Accumulation Method - Select Sum.

Field Elements
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4 In the Setup Custom Data dialog box, type a name for the field i
the Name box.

5 Select a type, format, and accumulation method for the field in 
each of these lists.

To add more fields, clear the Name box and repeat steps four an
five.

6 Click OK.

7 In the Custom Data tab, click the field next to the name, and the
type the field information.

For example, if you have a field labeled Cost, type 15.00.

8 Click OK.

Note
You can display fields in or around the shape. See Working with Shape 
Fields on page 164.

To delete custom data fields from a shape

1 Right mouse click the shape that you want to delete a field from

2 Click Properties.

3 In the Custom Data tab, click Setup.

4 In the Setup Custom Data dialog box, click the field in the Custo
Data box, and then click Delete.

5 Click OK.

6 In the Properties dialog box, click OK.
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To add advanced custom data field options to a shape

1 Right mouse click on a shape containing field(s).

2 Click Properties.

3 In the Custom Data tab, click Setup.

4 In the Setup Custom Data dialog box, click Options.

5 Edit hours per day and days per week, and then click OK.

6 In the Setup Custom Data dialog box, click OK.

7 In the Properties dialog box, click OK.

To insert a legend displaying custom data

� On the Tools menu, point to Custom Data, and click Insert Lege

The Legend displays custom data added to shapes.

Working with Visual Basic for Applications

iGrafx Professional contains Microsoft’s Visual Basic for Applications
(VBA), version 6.0 as its integrated development environment. VBA
provides a programming interface to the powerful features that comp
iGrafx Professional. Used with iGrafx System, you get a powerful 
graphics engine and a development environment that lets you quick
extend the capabilities of applications. For more information on iGra
System, see Developing Custom Solutions with iGrafx System included 
in your box.
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VBA is a widely used programming language and is integrated into 
Microsoft’s Office products. If you have any experience customizing
extending these applications, then you have a head start in develop
with iGrafx System. Even without prior experience, you have the 
advantage of using a widely accepted and standardized developme
tool.

To run a VBA macro

1 On the Tools menu, point to Visual Basic, and click Macros.

2 In the Macros dialog box, select a macro from the list.

3 Click Run.

Note
This procedure assumes that you opened a document containing 
VBA macros. If no macros exist in the document you are creating 
or opening, the Macros command on the Tools menu will not be 
active.

To open a VBA Extension Project

1 On the Tools menu, point to Visual Basic, and click Extension 
Projects.

2 Click Open.

3 Navigate to a iGrafx Extension Project (*.flx), and click Open.

The project is added to list in the Extension Project dialog box.

4 Select the box next to the project, and click Open.
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To modify VBA security settings

1 On the Tools menu, point to Visual Basic, and click Security.

2 In the Security dialog box, select:
• High- Prevents any unsigned macros from automatically 

running.

• Low-Lets all macros run. This is not a recommended setting.

3 Click OK.

Working with iDiagrams

An iDiagram is a diagram that runs like a program. iDiagrams walk y
through shapes containing VBA code, letting you make the decision
you go. These decisions move you along a path from shape to shap
where custom data is collected.

After you place shapes in an iDiagram, you can add code to them u
Visual Basic. Using the iDiagram Entity Manager, you can step thou
stop, and pause an iDiagram. You can also add or delete entities fro
shapes using the Manager.

For more information about developing custom code for use with 
shapes, view the help file provided with Visual Basic.

To create a new entity

1 On the Tools menu, point to iDiagram, and click Entity Manager.

2 Click the Add Entity tool.
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To add an entity to a shape

1 On the Tools menu, point to iDiagram, and click Entity Manager.

2 Select an existing entity, or create a new entity.

3 Click the shape that you want to add the entity to.

To delete an entity from a shape

1 On the Tools menu, point to iDiagram, and click Entity Manager.

2 Select an entity.

3 Press DELETE.

To run an iDiagram

� On the Tool menu, point to iDiagram, and click Execute.

Working with SPC Charts

iGrafx Professional lets you create different kinds of charts that supp
quality and process re-engineering. To implement these processes,
quality charts are needed for relaying complex data in easy to 
understand formats.

With SPC charts, you can:

• Identify unstable processes

• Visualize extent of variation in a process

• Improve decision-making

• Identify special cause variation in a process
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• Predict progress of a process

• Determine current ability of a process

• Analyze processes over time

• Compare data

• Organize data into recognizable categories

• Set priorities of a process

• Illustrate impacts of individual affects

• Show relationship between paired data

To select and place SPC charts in a diagram, use the DataAnalyzer 
wizard. After selecting which chart you want to use, you can type 
information into an active spreadsheet in the diagram space. 
DataAnalyzer then graphically converts the data for display in the 
diagram.

For more information on specific SPC chart types, select a chart in 
DataAnalyzer Chart wizard, and click More. To get information on 
DataAnalyzer functions, view datalyzer.hlp located in iGrafx\Pro\8.0

You can create the following charts using iGrafx Professional and 
DataAnalyzer:

• Process charts 

• Cause-and-effect (Ishikawa or fishbone) charts

• Organization charts

• Deployment charts

• Pareto charts

• Histograms

• Run charts (trend charts)
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• Control charts

• Scatter charts

• Pie charts

To insert a SPC chart in a diagram

1 On the Insert menu, click SPC Chart.

2 In the DataAnalyzer Chart wizard, click Next.

3 Select a chart type, and click Finish.

To add data to a SPC chart

1 Insert an SPC chart in the diagram.

2 In the active spreadsheet, type x and y axis labels in the cells.

3 Click the Data Import Wizard tool.

4 Follow the steps in the Data Import wizard.

5 After you have imported the data, click outside of the SPC chart

The SPC chart is inserted in the diagram.

To delete a SPC chart from a diagram

1 Click the Selector Tool on the Toolbox toolbar.

2 Click the SPC chart.

3 Press DELETE.
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Working with iGrids

iGrids are graphical templates that you can use to diagram hierarch
matrices, comparisons, schedules, timelines, and checklists. Each i
has corresponding options for adding or removing elements, sizing,
placing, and aligning. After choosing from these options, the iGrid 
appears in the diagram space.

Depending on which iGrid you select, a Share Media subject tab will 
appear in the Gallery. Use the clip art in these tabs to add graphics 
color to your iDiagrams

The following chart describes the iGrid templates in iGrafx 
Professional:

iGrid Description

Pyramid Shows hierarchical lists, such as those 
illustrating business values and goals or 
customer requirements.

Basic CoolSheets Shows a grid of squares in the diagram. The grid 
enables you to place objects in precise 
positions.

Block CoolSheets Shows a graphical matrix or gives a brief 
overview of a process.

Cascade Shows items in a sequence, such as steps in a 
process. 

Process Shows the details of a process so that it can be 
readily understood.

Deployment Shows the flow of information and materials 
among different organizational units.
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To insert an iGrid

1 On the Insert menu, click iGrid.

2 In the Insert iGrid dialog box, click the iGrid icon that you want to
insert.

3 Edit the options you want to change.

4 Click OK.

Comparison Shows comparisons of items in columns and 
rows, such as products and features.  These 
charts can represent yes/no relationships (using 
check marks or thumbs up/down) or multiple-
value relationships (using filled bullets). 

Timeline Shows schedules for tasks, projects, and 
procedures.

Circle-Spoke Shows items in a circular arrangement, 
connected to a center shape.  Spoke charts are 
useful for illustrating business principles, the 
key benefits of a product, or a product line.

Target Shows concentric rings of focus, such as with 
increasingly focused customer groups and 
business objectives.

DrawBar Shows general relationship and conceptual 
quantitative relationships (for example, 
something is smaller than or larger than 
something else).

Checklist Shows single or multiple-column visual 
checklists.

iGrid Description
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To edit an iGrid in the diagram space

1 Right mouse click the iGrid.

2 Click Edit iGrid.

Yellow sizing diamonds appear on edges of the iGrid i
the diagram.

3 To change the size of the iGrid, click the diamonds an
drag the iGrid to a new position.

4 To finish the positioning, click the Selector tool, and 
then click outside the diagram space.
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Numerics

3D effects, adding to shapes 137

A

Actions, undoing 86
Adding

fields to shapes 165
preset line styles 161
preset shape styles 158
preset text styles 185
shadow or 3D effects to shapes 137
shape fill color, pattern, or 
gradient 132
shapes to the Shape Library 121
shapes to Toolbox toolbar 121
verticies to lines 130

Advanced shape field options 167
Aligning

objects 140, 142
text blocks 182

Angles, rotating 147
Applying

arrow and crossover formats 135
fill formats 132
line and border formats to 
shapes 133

Arrange menu 62
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Arranging, shapes in the Shape 
Library 123
Arrowheads, choosing 136
Arrows, applying formats 135
Attaching, text to lines 176
Automatic

renumbering of all shapes 169
renumbering of shapes 170

B

Borders
adding to department lanes 116
applying formats 133
formatting lines for shapes 133

Bringing, objects to the front 149
Bullet styles, setting for text 180
Business diagrams, editing 86

C

Callout Lines
connecting to a shape from a 
graphic 195
formatting 195

Cascading, windows 86
Chalk talks 76
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Changing

number format for existing 
shapes 171
shadow depths 138
shadow directions 139
shadow styles 139

Checking, spelling 94
Choosing

arrowheads 136
indicators for shapes 83
line crossovers 137
line routing types 129
preset line styles 161
preset shape styles 159
preset text styles 186
spelling options 93
text styles 179

Clearing, objects 91
Clipboard 81
Closed objects, connecting 151
Closing, documents 98
Color

adding to shadows 138
adding to shape fill 132
adding to text 179

Coloring
lines 49
shapes 49
text 49
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Components

copying and pasting 200
creating from a template 198
creating new 198
deleting 199
renaming 200
viewing 199

Connect points
editing between shapes 129
moving line ends on a shape 128

Connecting
closed objects 151
open objects 152
shapes by clicking 128
shapes by dragging 127
shapes with lines 125
using the Connect Shapes 
command 129

Connectors, choosing for lines 131
Converting, FlowCharter charts 71
Converting, graphics to shapes 194
Copies, saving for documents 99
Copying, objects 88
Creating

colors 48
floating palettes 47
new documents 66
new toolbars 44
shape text 175
templates 69
text blocks 175
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text on lines 176

Crossovers, applying formats 135
Cursors, placing in text 177
Customizing, toolbars 27
Cutting

objects 88
text in the Note window 81

D

Data fields
adding 228
adding advanced options 230
deleting 229

Default number, setting format for 
new shapes 170
Defaults

Default tab, setting for shapes 
and lines 158
Default tab, setting for text 185
setting for arrowheads 136
setting for diagrams 158
setting for text 179
Shape Library

setting for shapes and lines 163
setting for text 186

Share Media
setting for shapes and lines 164
setting for text 187
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Deleting

departments 117
objects 91
preset line styles 163
preset shape styles 160
preset text styles 178, 186
shapes from Shape Library 122
text 178
text in the Note window 81
toolbars 46

Departments
adding borders and dividers 
to lanes 116
adding color, patterns, and 
gradients to 116
changing lane margins and 
minimum lane size 117
deleting 117
editing text in department 
headers 117, 175
inserting 115
moving the location of names 116
reordering 117
setting the lane orientation of 115
setting the text orientation 
for labels 115
setting up 114

Diagram elements, viewing 76
Diagram objects

deleting 90
duplicating 90
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selecting 90

Diagrams
adding layers 204
changing all layers 204
changing current layers 203
changing the order of layers 206
copying and pasting components 200
creating new components 198
creating new components from 
a template 198
defining page setup 106
deleting components 199
deleting layers 205
importing other formats 71
locking 95
making layers printable or 
nonprintable 208
moving an object to a different 
layer 206
moving objects back one layer 207
moving objects forward one 
layer 207
opening VBA Extension 
Projects 231
placing shapes in 123
printing 96
renaming components 200
renaming layers 205
running VBA macros 231
saving as web pages 102
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selecting the page orientation 
for 107
setting defaults for 158
setting the page margins for 108
setting the paper size for 107
setting the Print Notes option 109
setting the scaling for 107
setting titles for 108
setting up a diagram page 106
setting VBA security levels 232
showing or hiding layers 208
unlocking or locking layers 209
unprotecting 95
viewing 74, 76
viewing components 199
zooming 76

Directions, changing for a shadow 139
Disconnecting, objects 153
Distributing, documents 103
Docking, toolbars 46
Documents

closing 98
creating new 66
creating using the New 
command 68
distributing 103
new from a template 69
new from the Welcome dialog 68
opening 70
opening using the Welcome 
dialog 70
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saving 98
saving copies 99
sending as e-mail 104
using the Open command 70
using the Welcome dialog to 
create 67

Dragging and Dropping, OLE 
objects 217
Draw toolbar 35
Drawing, graphics 192
Duplicating

diagram objects 90
objects 91
shapes in Shape Library 122

E

Edit menu 55
Editing

business diagrams 86
connect points between shapes 129
department headers 117, 175
process maps 86
shapes in Shape Library 122

E-mail, sending documents as 104
Encryption 95
Ends, line 136
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F

Field descriptions, including with 
shapes 166
Fields

adding to shapes 165
moving in or around shapes 166

File menu 51
Fills, applying formats 132
Finding, text 92
Fitting, shapes to text 141
Flipping, objects 140, 147
Floating palettes, creating 47
FlowCharter 7.0

opening diagrams in 72
opening files 70

FlowCharter formats, saving 
older documents from 101
Fonts

installing 22
setting text defaults 179

Footers
creating custom 110
inserting 110
using 110

Format menu 60
Formatting

applying fills 132
callout lines 195
lines 134
lines for shape borders 133
' 
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shapes and lines, described 132
text 179

Formatting toolbar 31
Full screen views 76

G

Gallery, placing shapes using 125
Gradient, adding to shape fill 132
Graphics

adding text 176, 192
connecting callout lines to 
shapes 195
converting to shapes 194
drawing 192
formatting callout lines 195
moving 193
reshaping 194
resizing 193
rotating 193

Grids
showing dots 113
snapping objects to 113
turning on for snapping 113
using 111

Grouping, objects 151
Guidelines

adding horizontal 112
adding vertical 112
deleting 113
' 
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moving 112
using 111

H

Headers
creating custom 110
inserting 110
using 110

Help menu 65
Hidden lines

showing 85
using 85
viewing 85

Hiding
diagram layers 208
rulers 85
shape numbers 169
toolbars 47
ToolTips 50

Horizontal alignment, setting for 
text 182
Horizontal lines 156
Horizontally, tiling windows 85
HTML, saving diagrams as 102
' 
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I

iDiagram toolbar 41
iDiagrams

adding entities to shapes 233
creating entities 232
deleting entities from shapes 233
running 233

iGrafx Professional tools, using 77
iGrafx Share Media, using 79
iGrafx Share Viewer, using 103
iGrids

editing 238
inserting 237

Indicators 82, 83
Insert menu 59
Inserting, departments 115
Installation, local 21
Intersecting, objects 154

J

Java, saving diagrams as applets 102
Joining, objects 153

K

Keyboard selection, moving text 178
' 
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L

Lane margins, changing size 117
Lane orientation, setting for 
departments 115
Layers

adding to diagrams 204
changing all in a diagram 204
changing current 203
changing the order of 206
deleting 205
locking or unlocking 209
making printable or 
nonprintable 208
moving an object to a different 
layer 206
moving objects back one layer 207
moving objects forward one 
layer 207
renaming 205
showing or hiding 208

Legends, inserting 230
Line ends

moving from connect points 
on a shape 128
reversing between shapes 129

Line formats, applying 133
Line offset 156
Line spacing, setting for text 181
Lines

adding a vertex to 130
' 
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adding preset styles 161
arrowheads 136
attaching text to 176
callouts 195
choosing crossovers 137
choosing off-page connector
functions 131
choosing preset styles 161
choosing routing types 129
coloring 49
connecting shapes with 125
deleting preset styles 163
ends 136
formatting 132, 134
formatting for shape borders 133
horizontal 156
line ends 136
manipulating with Shapes 140
offset 156
renaming preset styles 162
restoring automatic line moves 131
routing types 129
selecting 90
spacing 156
vertical 156

Linking
controlling OLE objects 220
OLE objects 219

Links
activating 223
adding advanced settings 224
' 
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adding to a file or Web page 225
adding to shapes 222
deleting 224
editing 223

Locking
diagrams 95
layers 209

M

Making objects same size 140, 144
Manipulating, shapes and lines 
together 140
Manual, renumbering of shapes 170
Master Page, viewing 76
Model menu 63
Modifying, connect points between 
shapes 129
Moving

line ends from connect points 
on a shape 128
objects back one layer 207
objects forward one layer 207
objects to the back 149
objects to the front 149
shape fields 166
' 
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N

New command, creating new 
documents 68
Nodes, indicators 82
Normal view, using 75
Notes 81

attaching to shapes 81
in diagrams 89
printing 82, 109

Numbering
all shapes 169
renumbering 170
shapes 168, 170

Numbering position, setting for 
shapes 172

O

Objects 89
aligning 142
angle rotation 147
bringing to front 149
connecting closed 151
connecting open 152
copying 88
cutting 88, 91
disconnecting 153
duplicating 91
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flipping 147
grouping 151
intersecting 154
joining 153
making same size 144
outlining 153
rotating 146, 147
selecting 90
sending to back 149
slicing 155
spacing evenly 145
ungrouping 151

Off-page Connectors, choosing 
for lines 131
Older documents, saving from 
FlowCharter 101
OLE Objects

controlling links 220
converting embedded 216
creating links 219
editing embedded 216
embedding into diagrams 217
inserting new 215
using the Paste Special 
command for 218
viewing as an icon 220

Open command, using 70
Open objects, connecting 152
Opening

documents 70
documents using the Open 
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command 70
documents using the Welcome 
dialog 70
FlowCharter 7.0 diagram 72
Optima! 2.5 file 73
Output window 84
Windows Draw file 73

Optima! 2.5 file, opening 70, 73
Options, spelling 93
Ordering 140
Orientation, setting for text in 
shape fields 166
Outlining, objects 153
Output window, using 83

P

Page breaks
showing 85
using 85
viewing 85

Page margins, setting 108
Page Setup

creating custom headers and 
footers 110
defining 106
inserting headers and footers 110
selecting the page orientation 
for 107
setting diagram titles 108
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setting page margins 108
setting the diagram scaling for 107
setting the page order for 
printing 109
setting the paper size for 107
setting the Print Notes option 109
setting up a diagram page 106
using headers and footers 110

Palettes, as floating toolbars 46
Password protection 95
Paste Special command

using 89
using for OLE objects 218

Pasting 89
notes in diagrams 89
objects 89

Pattern, adding to shape 132
Placing

shapes in diagrams 123
shapes using the Gallery 125
shapes using the Shape Library 125

Presentations 76
Preset line styles

adding 161
choosing 161
deleting 163
renaming 162
working with 157

Preset shape styles
adding 158
choosing 159
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deleting 160
renaming 160
working with 157

Preset Styles toolbar 40
Preset text styles

adding 185
choosing 186
deleting 186
renaming 186

Previewing 97
Printing

diagram layers 208
diagrams 96
notes 82, 109
previewing 97
setting the page order for 
printing 109

Process maps, editing 86
Protecting, diagrams 95

R

Renaming
preset line styles 162
preset shape styles 160
preset text styles 186
toolbars 45

Renumbering
all shapes automatically 169
shapes automatically 170
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shapes manually 170

Reopening, workspaces 100
Reordering, departments 117
Replacing

shapes 141
text 92, 93
text in shapes 93

Resetting, toolbars 45
Reshaping, graphics 194
Reversing

an undo 87
line ends between shapes 129

Rotating 140
graphics 193
objects 146, 147
objects by angles 147
text in a text block 183
text with a shape 184

Rulers
hiding 85
turning off 85
using 85

S

Save as command, using for 
documents 99
Saving

copies of documents 99
diagrams as web pages 102
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documents 98
documents from older FlowCharter 
formats 101
workspaces 99, 100

Searching, text 92
Security 95
Selecting

angle for rotating object 147
diagram objects 90
direction for rotating object 147
objects 90
text 177
text by dragging 177
text using the keyboard 178

Sending
documents as e-mail 104
objects to the back 149

Setting
advanced shape field options 167
bullet styles for text 180
default number format for new 
shapes 170
defaults for arrowheads 136
numbering position in shapes 172
text defaults 179
text orientation 183
text orientation for shape fields 166

Shadows 138
adding to shapes 137
changing directions 139
coloring 138
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indicators 82

Shape field descriptions, including 
with shapes 166
Shape fields, setting text 
orientation 166
Shape Library

adding shapes to 121
arranging shapes in 123
duplicating shapes in 122
editing shapes in 122
placing shapes using 125
removing shapes from 122
setting defaults in 163, 186
using 119

Shape numbers
hiding 169
showing 169

Shape text, creating 175
Shapes

activating links to 223
adding advanced data options 230
adding advanced link settings 224
adding color, pattern, or gradient 
to fill 132
adding data fields 228
adding fields to 165
adding preset shape styles 158
adding secondary text areas 182
adding shadow or 3D effects to 137
adding to the Shape Library 121
adding to the Toolbox toolbar 121
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arranging in the Shape Library 123
attaching to notes 81
changing number format for 
existing shapes 171
choosing indicators 83
choosing preset styles 159
coloring 49
connecting by dragging 127
connecting two shapes by 
clicking 128
connecting with lines 125
deleting data fields 229
deleting links from 224
deleting preset styles 160
deleting secondary text areas 182
duplicating in Shape Libary 122
editing connect points between 129
editing in Shape Library 122
editing links to 223
fitting text to 141
formatting lines for borders 133
formatting, described 132
linking to 222
linking to files or Web Pages 225
making same size 144
manipulating with lines 140
moving fields 166
numbering 168, 169
placing in diagrams 123
placing using the Gallery 125
placing using the Shape Library 125
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removing from Shape Library 122
renaming preset shape styles 160
renumbering 170
renumbering all 169
renumbering manually 170
replacing 141
replacing text 93
reversing line ends between 129
rotating 146
rotating text in 184
selecting 90
setting default number for 
new shapes 170
setting numbering position for 172
setting text margins inside 181
showing numbers 169
spacing evenly 145
using spacing options between 155
using the Connect Shapes 
command 129

Share Media, setting defaults 
in 164, 187
Showing

diagram layers 208
hidden lines 85
page breaks 85
shape numbers 169
toolbars 47
ToolTips 50

Slicing, objects 155
Spacing
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lines 156
objects evenly 145
options between shapes 155

SPC Charts
adding data to 235
deleting from a diagram 235
inserting in a diagram 235

Spelling
checking 94
options 93

Splitting, windows 86
Standard toolbar 28
Status Bar, using 84
Symbols, as indicators 82

T

Tabular view, using 75
Technical Support 23
Templates

creating documents from 69
creating new 69

Text
adding preset text styles 185
adding secondary text areas to 
shapes 182
adding to a graphic 176, 192
aligning 182
choosing preset text styles 186
coloring 49
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deleting 178
deleting in the Note window 81
deleting preset styles 178
deleting preset text styles 186
deleting secondary text areas from 
shapes 182
finding 92
fitting shape to 141
formatting 179
placing cursors in text 177
renaming preset text styles 186
replacing 92, 93
rotating in a text block 183
searching 92
selecting 177
selecting by dragging 177
selecting using the keyboard 178
setting line spacing for 181
setting margins inside shapes 181
setting orientation for 183

Text blocks, creating 175
Text colors 179
Text on lines, creating 176
Text orientation

setting for department labels 115
setting for shape fields 166

Tiling
window horizontally 85
windows vertically 85

Toolbars
as floating palettes 46
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attaching 46
creating new 44
customizing 27
deleting 46
docking 46
Draw 35
Formatting 31
iDiagram 41
Preset Styles 40
renaming 45
resetting 45
showing and hiding 47
Standard 28
Toolbox 33
using 26
Visual Basic 42

Toolbox toolbar 33
Toolbox toolbar, adding shapes 121
Tools menu 61
ToolTips

hiding 50
showing 50
using 50

Turning off, rulers 85

U

Undoing, actions 86
Unencrypting 95
Ungrouping, objects 151
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Uninstalling 22
Unlocking, layers 209
Unprotecting, diagrams 95
Using 78, 80

Bubble help 50
hidden lines 85
iGrafx Professional tools 77
iGrafx Share Media 79
iGrafx Share Viewer 103
menus and commands 51
Normal view 75
Output window 83
page breaks 85
Paste Special command 89
rulers 85
spacing options between shapes 155
Status Bar 84
Tabular view 75
toolbars 26
ToolTips 50
Window commands 85

V

VBA
opening Extension Projects 231
running macros 231
setting security levels 232

Vertical alignment, setting for text 182
Vertical lines 156
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Vertically, tiling windows 85
Verticies, adding to lines 130
View menu 57
Viewing

all diagram elements 76
charts as printed 97
diagrams 74, 76
hidden lines 85
Master Page 76
page breaks 85
presentations 76
previewing 97

Views
using Master Page 76
using Normal 75
using Tabular 75

Visual Basic toolbar 42

W

Web browsers, saving as HTML or 
Java Applets 101
Web pages, saving diagrams as 102
Welcome dialog

creating new documents 68
using to create documents 67

Window commands, using 85
Window menu 64
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Windows

cascading 86
splitting 86
tiling 85

Windows Draw file, opening 70, 73
Workspaces 100

reopening 100
saving 99, 100

Z

Zooming, diagrams 76
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