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The Clean & Zip utility allows you to delete unwanted files from a drive, cleaning up any duplicates, empty 
files, and other clutter that may exist.    You can select any floppy drive, hard drive, or network drive 
(including local drives on other people's systems if you are running a peer-to-peer network such as 
Windows for Workgroups) seen by your system.

This utility is very useful when you want to make room on a drive for Windows 95 or new programs and 
data files.

NOTE:    There are two versions of the Clean & Zip utility -- a 16-bit (Windows 3.x) version and a 32-bit (Windows 95) version.    
When you install Clean & Zip, the program automatically installs the correct version for your system.    The only noticeable difference 
between the two versions is that the 32-bit version handles (and displays) long file names.

Choose from the following help topics to guide you through the use of the Clean & Zip utility:

Selecting a Drive(s) to Read (Scan) 
The Clean & Zip Main Screen 

Filtering the File List 
Sorting the File List 
Printing the File List 
Copying Files 
Moving Files 
Deleting Files 
Renaming Files 
Zipping Files 
Saving Clean & Zip Options 

Accessing Contact Information 
Exiting Clean & Zip 

 



Selecting a Drive(s) to Read (Scan)

When you start Clean & Zip or choose a new drive from the Select Clean & Zip Drive(s) drop-down list, 
you will be prompted to select the drive (A:, B:, C:, etc.) or drives you want to scan.    You can scan both 
individual or multiple drives. To scan multiple files, pressing the Shift key down and choose a range of 
drives.    To scan an individual drive, press the Ctrl key down and choose the drive you want.

The C: drive (or your first hard drive) is selected by default.    Select the drive(s) you want to scan and 
then click the Read button to start the action.    During the scan, you will see the progress thermometer 
provide the status of the scan in terms of a percentage of completion. 

NOTE: You can end a scan at any time by pressing the Cancel button.

See Also:
Clean & Zip Main Screen 

 



Clean & Zip Main Screen

After the scan is complete, the Clean & Zip main program window appears.    A list of the files found for 
the drive(s) you scanned appear in the Clean & Zip window.

The Clean & Zip Main program window contains the following features:

File List
Clean & Zip displays a list of files on your hard drive(s) as dictated in the Filters options.    The default 
setting is to view "All" files.    When you enter this window for the first time, this list display all the files on 
your drive(s) ranked in alphanumeric order.    From this list, you can select files to be moved, deleted, or 
zipped.
 
For every file listed, the following information is provided:

· File -- The complete filename

· Size -- The size (in bytes) of the file 

· Date/Time -- The creation (or last modification) date and time of the file

· Attrib -- The assigned attribute(s) (i.e. read only, archive, hidden) for the file

· Path -- The complete DOS directory tree where the file was found
 
The Filters function allows you to filter the file list for more specific searches.    To access this option, 
press the Filters button or choose the Filters command in the Options menu.
 
If you want to save the list currently residing in Clean & Zip’s File List to a ASCII text file, select the Save 
Listing command in the File menu.
 
You can print the File List by clicking the Print Listing toolbar button or selecting the Print Listing 
command in the File menu.

View By & Criteria Parameters
Next to the Filters button, a brief summary of the type of file list is displayed.    The View By field can be 
one of the following: All files listed, Duplicates, Extensions, Size, or Date.    The Criteria field further 
specifies the parameter in the View By field.
 
For example, if you chose to list by "Date Newer Than 01/01/90" in the Filters window, the View By field 
would display "Date" and the Criteria field would display "Newer Than 01/01/90."
 
Drive(s) Drop-Down List Box
Located in the upper left of the main window, the drive drop-down list allows you to select a new drive to 
read (scan).    When you change the drive, the Select Drives dialog comes up.
 
Total Files Group Box
The Total Files/Size fields provide the cumulative number of files and size of the File List.
 
Currently Selected Group Box
The Selected Files/Size fields provide the cumulative number of files and size of the files that are 
selected.    As you select (or de-select) files, the Selected Files/Size values fluctuate.
 
The Unsaved List Box (Zip Screen Only)
The Unsaved Files/Size fields provide the cumulative number of files and size of the files (in red) that 



have been selected for archiving.    As you select (or de-select) files to be zipped, the values fluctuate.
 
Clean & Zip Buttons
The following buttons can be found on the main Clean & Zip screen:

· Filters (Clean Up Screen Only) -- This function allows you to filter the list of files for more specific 
searches.    You may define a list by choosing one of the following:    list all files, list all duplicates, list 
by file extension, list files that are less or greater than or equal to a size you specify, or list files that 
are older or newer than or equal to a date you specify.    You may also list empty directories or 
hidden/system files by selecting their respective check boxes.

· Clean & Zip -- These buttons toggle between the Clean Up and Zip screens.

· Save Zip (Zip Screen Only) -- Clicking on this button saves the unsaved files in the zip (archive) file.

· Done -- This exits Clean & Zip.    You will receive a confirmation prompt asking if you are sure you 
want to leave Clean & Zip.    Answer by clicking Yes to exit.

See Also:
Copying Files 
Moving Files 
Deleting Files 
Renaming Files 
Filtering the File List 
Sorting the File List 
Printing the File List 
Zipping Files 

 



Filtering the File List

The Filters button or the Filters command in the Options menu takes you to the Filters dialog box where 
you can dictate the type of File List.

You may define a list by choosing one of the following:

· List all files
· List all duplicates (for a more precise list, you may specify duplicate file names with either the same 

date/time and/or size).    The list of duplicates will provide a list of files grouped by file name in 
alphabetical order.    If you select Date/Time or Size, the search will only yield duplicate files that were 
created at the same time or have the same number of bytes in size.

WARNING:    You should not indiscriminately delete any duplicate files unless you are absolutely sure that they are okay to remove.

A warning prompt appears when the Duplicates option is selected that cautions against indiscriminately 
deleting any duplicate files unless you are absolutely sure that they are okay to remove.

· List by file extension (multiple extensions are allowed using a delimiting semi-colon [i.e. 
BAK;TMP;HLP]).

· List files that are greater than, equal to, or less than a size that you specify.    You must specify a 
range for your list by indicating greater than, equal to, or less than the value that you provide.    For 
example, if you want to search for all files over 100KB in size, then choose greater than in the pull-
down list and type 100 in the field.    The default is Equal To 0 KB.

· List files that are older than, newer than, or on a date that you specify.    You must specify a range for 
your list by indicating older than, newer than, or on the value that you provide.    For example, if you 
want to search for all files created after 01/01/90, then choose newer than in the pull-down list and 
type 01/01/90 in the field.

In the Date field, you must enter the date in MM/DD/YY format.    If you do not, you will receive an error 
message.    The default is Equal To the date specified in your CMOS memory, which should be the current 
date.

· List hidden/system files and empty directories.    Hidden/system files and empty directories may be 
displayed by selecting these check boxes.    But these boxes are NOT selected by default because 
most hidden/system files and empty directories are integral to proper system operation and deleting 
them could have severe consequences.    We recommend extreme caution if you select either of 
these boxes.

NOTE: You may only select one Filter criterion at a time--you cannot combine them.

When you are done specifying the criterion for the list, click OK.

 



Sorting the File List

There are two ways in which you can sort the file list--choose the Sort By commands in the Sort By menu, 
or select the desired File List button (Name, Ext, Size, Date/Time, and Path).    If you want to re-order the 
list, use one of these two methods.

You may order the List of Files by one of the following parameters:    Name, Extension, Size, Date (Time), 
or Path (Location).

· Sorting by Name -- Provides a list that is in alphabetical order by filename.

· Sorting by Extension -- Provides a list that is in alphanumeric order based on a file’s extension.    
For example,    VTDA.386 comes before COMMAND.COM, which comes before SYSINI.WRI.

· Sorting by Size    -- Ranks the list from the smallest to largest file.

· Sorting by Date -- Ranks the list from the oldest to the newest file.

· Sorting by Path -- Gives you list starting at the highest-lettered directory and continuing to the last 
directory in lowest-lettered directory.    For example, if you are scanning the two drives C: (with 
ALDUS, TEMP, and UTIL directories) and F: (with DOS and WINDOWS directories), a path sort would 
order these directories in alphabetical order starting with all the files in C:, then C:\ALDUS, C:\TEMP, 
C:\UTIL, F:, F:\DOS, and finally F:\WINDOWS.    The files listed in each of these directories are in 
alphabetical order.    If there are subdirectories within your directories, they will be ordered 
alphabetically--just like the directories.

 



Printing the File List

You can print the File or Zip List by clicking the Print Listing toolbar button, or selecting the Print Listing 
command from the File menu.

 



Saving Clean & Zip Options

You may save the Confirmations, View By, and Sort By settings using the Save Options command from 
the Options menu.

 



Copying Files

To copy files from one location to another, select the file(s) that you want to copy, then click on the Copy 
toolbar button, or select the Copy command from the File menu. The Copy To screen appears.

You must specify where you want the files copied.    Specify the proper directory in the "Directories:" box. 
Use the drive drop-down list to switch drives.

The OK button initiates the copying; the Cancel button exits the Copy To screen; and, the Network... 
button accesses a list of drives, including network drives that are available to you.

 



Moving Files

To move files from one location to another, select the file(s) that you want to move, then click on the Move 
toolbar button, or select the Move command from the File menu.    The Move To screen appears.

You must specify where you want the files moved.    Specify the proper directory in the "Directories:" box. 
Use the drive drop-down list to switch drives.

The OK button initiates the move; the Cancel button exits the Move To screen; and, the Network... button 
accesses a list of drives, including network drives that are available to you.

 



Deleting Files

When you have selected a file(s) for deletion and clicked on the Delete button, or chosen the Delete 
command from the File menu, Clean & Zip functions like the Window's File Manager.    You will be asked if 
you are sure that you want to delete the file(s).    As in File Manager, you can answer the question by 
selecting one of four buttons:

·  Yes (delete the one file)

·  Yes to All (deletes all the selected files)

·  No (does not delete the file)

·  Cancel (immediately ends the deletion process)

See Also:
Receiving Deletion Confirmations 

 



Receiving Deletion Confirmations

To better safeguard you from accidentally deleting crucial files that, if deleted, would impair the 
functionality of an application, Windows, or your system, Clean & Zip will provide a deletion confirmation 
(a warning prompt) asking if you are sure you want to delete the file(s) you have selected.    Using the 
Confirmations command from the Options menu, you can select which files or file types (for example, all 
files with a SYS extension) that, if you try to delete them, a deletion confirmation would appear.

There are four categories of files that you may receive deletion confirmations for:

· Last Duplicate Files -- This feature makes sure that if you are deleting duplicates of files and select 
the last copy of a file to delete, you will receive a deletion confirmation.    This way, Clean & Zip never 
automatically deletes the last copy of a file, unless this feature is not selected.

· Read-only, Hidden, System Files -- As the name implies, this feature issues deletion confirmations 
when you delete read-only, hidden, or system files.

· Special Files -- If you click on the Special Files button, the Edit Special Files dialog appears 
displaying a list of files and file types, which you can append.    If the Special Files check box is 
selected and you delete any of the files or file types on this list, a deletion confirmation will be 
displayed.    To save your list when you update it, click the Save button in the Edit Special Files dialog.

· Special Files in Special Directories -- This feature works the same way as the Special Files feature, 
except its focus is narrower.    Instead of issuing a deletion confirmation when you delete a Special 
File anywhere on your computer, this feature will only issue a deletion confirmation when you delete a 
special file in one of the special directories: your root (usually C:), your Windows directory (C:
\WINDOWS), or your Windows system directory (C:\WINDOWS\SYSTEM).

WARNING:    If you select a range of files to delete, then select "Yes To All" in the deletion confirmation, you will NO LONGER 
receive deletion confirmations for the remaining duplicate files--unless a special file is among the range of files.

We recommend that you leave all four of these check boxes selected at all times.

Advanced Mode
The Advanced Mode command toggles between being in advanced mode and standard mode.    Being in 
advanced mode means that you will be allowed to delete critical system files, which, if deleted, may 
cause DOS and/or Windows to work incorrectly.    This feature is in place as a safeguard to keep you from 
accidentally deleting files that would be devastating to lose.

 



Renaming Files

To rename a file or group of files, select the file(s) that you want to rename, then click on the Rename 
toolbar button, or select the Rename command from the File menu.    The Rename screen appears.

If you select only one file to rename, then that file's name will appear in the "From:" box.    Type in the new 
name in the "To:" box, then click on OK to rename the file.

If you select multiple files, then the file in the "From:" box will be the first in the series of files to be 
renamed.    As with the single-file renaming, put the new name in the "To:" box, then click on OK.    The 
next file in the series will appear for you to rename.    This process will continue until you reach the last file 
in the series of files that you chose to rename.

The Skip button allows you to skip over a file that is in a series of files to be renamed.    For example, if 
you select ten files to be renamed, rename the first five files, then realize that you do not want to rename 
the sixth file, you can use the Skip button to move to the seventh file.

The Cancel button exits the Move To screen.

 



Zipping (Archiving) Files

Clean & Zip provides an archiving feature that allows you to compress files into a single zip file, thus 
reducing the total amount of disk space that is occupied by those files.    The zip files created by Clean & 
Zip are compatible with the PKZIP and PKUNZIP utilities.    Clean & Zip can open zip files created by 
PKZIP.    And PKUNZIP can uncompress zip files created in Clean & Zip.

Creating a Zip File 
Saving a Zip File 
Opening a Zip File 
Adding Files to a Zip File 
Extracting Files from a Zip File 
Removing Files from a Zip File 

 



Creating a Zip File

To create a new zip file, select the file(s) that you want to zip from the File List.    Once that is done, click 
on the New Zip toolbar button, or choose the New Zip command from the Zip menu.    If you are using 
Windows 3.1, the Open dialog box appears.    If you are using Windows 95, the New Archive dialog box 
appears asking you to provide a name and location for the zip file.

Provide a name and location, then click on the OK or Save button.
 
See Also:
Saving a Zip File 
Opening a Zip File 
Adding Files to a Zip File 
Extracting Files from a Zip File 
Removing Files from a Zip File 

 



Saving a Zip File

Once you create a new zip file or make an alteration such as adding or extracting files, you should save 
the zip file.    When you click on the Save Zip toolbar button, or use the Save Zip command from the Zip 
menu, a compression status meter shows the progress of compression for each file going into the zip file.

When all the files are compressed, a save confirmation appears, which states the size of the zip file.    At 
this point, you have the option of deleting the files that you have just zipped -- to free up the disk space 
that those files currently occupy.    To delete the files, click on the Yes button; to leave the files, click on 
No.

See Also:
Creating a Zip File 
Opening a Zip File 
Adding Files to a Zip File 
Extracting Files from a Zip File 
Removing Files from a Zip File 

 



Opening a Zip File
 
You can view a zip file using one of the following methods:

· Click on the Zip button in the upper right of the main screen
· Click on the Open Zip toolbar button
· Choose the Open Zip command from the Zip menu

If you use the Zip button and there is not a zip file currently open, you will receive a prompt to either open 
an existing zip file or create a new one.

When you open an existing zip file, you will be prompted to give the name and location of the file.    After 
opening the zip file, a Zip List will show the individual files that comprise the zipped file.

When viewing a Zip List, the Clean button toggles back to the File List.    Regardless of the filter set on the 
File List, the Zip List is always set to display All Files.

See Also:
Creating a Zip File 
Saving a Zip File 
Adding Files to a Zip File 
Extracting Files from a Zip File 
Removing Files from a Zip File 

 



Adding Files to a Zip File

You can add files to a newly created zip file.    To do this, select the files that you want to add in the File 
List, then click on the Add to Zip List toolbar button, or use the Add to Zip List command from the Zip 
menu.    The files will be added to the Zip List.

To view the files you have added, click on the Zip button in the upper right of the main screen to toggle to 
the Zip List.    The new files that you just added appear in red in the Zip List.    Files that are already saved 
on the Zip List appear in black.

The file(s) will not be added to the zip file until you use the Save Zip command button located in the lower 
right of the main screen.

See Also:
Creating a Zip File 
Saving a Zip File 
Opening a Zip File 
Extracting Files from a Zip File 
Removing Files from a Zip File 

 



Extracting Files from a Zip File

Unlike some zip programs that compel you to "explode" an entire zip file to access individual compressed 
files, Clean & Zip gives you the flexibility of being able to extract individual files from the zip file without 
having to explode the other files.

For example, if you need one document file from a zip file of compressed document files, you can call up 
the zip file using the Open Zip command, select the one document file that you want, then click on the 
Extract From Zip toolbar button, or use the Extract From Zip command from the Zip menu.

You will be prompted to give a path (for example, C:\TEMP) where the file is to be copied.

See Also:
Creating a Zip File 
Saving a Zip File 
Opening a Zip File 
Adding Files to a Zip File 
Removing Files from a Zip File 

 



Removing Files From a Zip File

 
Clicking on the Remove From Zip button or selecting the Remove From Zip command from the Zip menu 
will remove any files that are selected in the Zip List.    This way, you do not have to explode the zip file, 
take out the files that you no longer need, then re-zip the remaining files.

See Also:
Creating a Zip File 
Saving a Zip File 
Opening a Zip File 
Adding Files to a Zip File 
Extracting Files from a Zip File 

 



Exiting Clean & Zip

Clicking on the Done button or selecting the Exit command from the File menu closes the Clean & Zip 
utility.    You will receive a confirmation prompt asking if you are sure you want to leave Clean & Zip.    To 
exit, answer by clicking on Yes.

 



Getting Help

Call you local psychiatrist.    No, actually, the Help (question-mark) button opens the Clean & Zip online 
Help system.    You can also access detailed Help from the Help menu by selecting the Contents 
command.

 



Accessing Contact Information

From the Help menu, select the About command to open the About window.    This window displays the 
version number and copyright information for the Clean & Zip utility.    Here, you can gain access to both 
technical support and license information by clicking on the appropriate button.

Click on the OK button to exit the About window.




