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Welcome 10 CorelDRAW'

CoreIDRAW® is a comprehensive vector-based drawing program
that makes it easy to create professional artwork — from simple
logos to technical illustrations. CorelDRAW’s tools are designed
to meet the demands of the graphic arts professional.

This section introduces the main features of CorelDRAW, provides
information about using the online Help, and offers information
about obtaining technical support.

About Corel CorporaTtion

Corel Corporation is an internationally recognized developer of
award-winning business productivity, graphics, and operating
system solutions on the Windows, Linux, UNIX, Macintosh, and
Java platforms. Corel also develops market-leading, Web-based

solutions including applications, e-commerce and online services.
For access to these services and more information about Corel
and its products, see www.corel.com or www.corelcity.com on
the Internet. Corel is headquartered in Ottawa, Canada. Corel’s
common stock trades on the NASDAQ Stock Market (symbol:
CORL) and on the Toronto Stock Exchange (symbol: COR).

Corel wants your feedback

If you have any comments or suggestions about CorelDRAW
documentation, you can send them by email to
drawdoc@corel.ca or by regular mail to the following address:
Creative Products Documentation Manager

Corel Corporation

1600 Carling Avenue
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Ottawa, Ontario, Canada
K1Z 8R7

Corel can’t respond to your messages individually, but you can
check the CoreDRAW Web site for the latest product news, tips
and tricks, and product upgrade information. You can access the
CoreIDRAW Web site at http://www.corel.com/draw10/index.htm
on the Internet.

Corel training manuals

Corel training manuals are the fast and easy way to learn about
all of our applications. Corel training manuals include easy to
follow, step-by-step instructions, and are illustrated throughout.
Comprehensive, hands-on exercises provide the opportunity to
practice the new concepts and skills that you have learned. The
modular structure of the course material makes Corel training
manuals easily adaptable to different user groups and learning
needs. Designed for both instructor-led training and self-paced
study, the manuals target various levels of software knowledge,
from new to experienced users.

For more information and pricing details, call 1-800-77-COREL or
visit www.corel.com on the Internet.

CoRrel supporT ANd services

The Corel product you are using is supported by the Corel Client
Services team. This team is committed to providing quality

customer service and support that is easy to access and
convenient to use, while fostering one-to-one customer
relationships.

If you have a question about the features and functions of Corel
applications or operating systems, see the user guide or online
Help for the product you are using. Updates and technical
information are also available in the Release Notes.

Year 2000 informaTion

Presenting timely solutions to the Year 2000 needs of users is a
critical concern at Corel. For the latest information about new
products and major upgrades of existing products that have been
tested for Year 2000 date-related issues, visit Corel Corporation’s
year 2000 policy Web site at http://www.corel.com/year2000 on
the Internet.

Registering Corel products

Registering Corel products is important. Registration provides
you with timely access to the latest product updates, valuable
information about product releases and access to free
downloads, articles, tips and tricks, and special offers.

For more information about registering a Corel product see the
online Help for the product or see
http://www.corel.com/support/register on the Internet.

4
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Technical support

The Web address for Corel is http://fwww.corel.com on the
Internet. A list of localized Corel Web sites is available at

http://www.corel.com/international/country.htm on the Internet.

Corel LINUX information is available at http://linux.corel.com on

Self-serve option

How to access

Online Help

Interactive Voice
Answering

Type keyword Technical Support

1-877-42-COREL

the Internet.

Self-serve Technical support oprions

Several self-serve tools are available to address technical
questions 24 hours a day, seven days a week.

Self-serve option

How to access

Support
newsgroups

Knowledge Base

Frequently Asked
Questions (FAQs)

AnswerPerfect

File Transfer
Protocol (FTP)

FTP information

http://www.corel.com/support/newsgroup.htm

http://kb.corel.com

http:/lwww.corel.com/support/faq

http://www.corel.com/support/answerperfect.htm

ftp://ftp.corel.com

http://www.corel.com/support/ftpsite/ftpindex.htm

Network (IVAN)*

Automated Fax 1-877-42-COREL

on Demand*

*IVAN and Fax on Demand are available only in North America.

Telephone Technical supporT oprions

Corel users can use complimentary and fee-based telephone
technical support options. Three levels of support are available.

Installation and Configuration Service

Installation and Configuration Service is a complimentary, 30-day
service designed to address installation, configuration, and new
feature issues. This service begins on the day of your first
technical support call.

Installation and Configuration Service replaces Classic Service,
however, Corel will honor previously purchased Classic contracts.
For more information see
http://www.corel.com/support/options/telephone.htm on the
Internet.
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Installation and Configuration Service is not available for OEM,
“White box,” Jewel Case (CD only), trial, or Academic versions of
Corel products.

Priority Service

Priority Service is a fee-based service for users who require the
help of second-level technicians. Priority Service may be
purchased by the minute, by the incident, or on a term basis.
Options range from core-business-hour access for individual
users to around-the-clock access for multiuser environments.

Premium Service

Premium Service is Corel’s highest level of support. This service
is designed for organizations that want to establish a direct
relationship with Corel and for organizations that employ
dedicated support professionals or have centralized technical
management.

CusTOMER SERVICE

Corel Customer Service can provide you with prompt and
accurate information about Corel product features, specifications,
pricing, availability, and services. Corel Customer Service does
not provide technical support. You can access Customer Service
support through the following avenues.

World Wide Web

You can access general customer service and product information
at http://www.corel.com/support on the Internet.

Mail, fax, email

You can send specific customer-service questions to Corel
Customer Service representatives by mail, fax, and email.

Corel Corporation
Corel Customer Service
1600 Carling Avenue
Ottawa, Ontario
Canada K1Z 8R7

Fax: 1-613-761-9176

Email: custserv2@corel.ca

Telephone

You can telephone Corel Customer Service centers with your
questions.

In North America, you can reach Corel Customer Service by
calling the 1-800-772-6735 toll-free line. The hours of operation
are 9:00 A.M. to 9:00 PM., eastern time (ET), Monday through
Friday, and 10:00 A.M. to 7:00 PM. on Saturdays.
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Corel customers residing outside North America can contact
Corel Customer Service representatives in Dublin, Ireland, by
calling the 353-1-213-3912 toll line, or they can call a local
authorized Corel Customer Service Partner.

Installing and uninsTalling applicaTions

The Corel setup wizard makes it easy to install and uninstall
Corel applications. The setup wizard lets you:

 install any Corel applications included in your software
package
e add components to currently installed applications

e refresh files and configurations of currently installed
applications

e uninstall all or some of the components of Corel applications

To insTall New cCOMPONENTS OR UPAATE YOUR CURRENT
insTallation

1 Close all applications
2 Insert CoreDRAW Disc 1 into the CD drive.

If the Corel setup wizard does not start automatically, click
Start on the Windows taskbar, and click Run. Type D:\Setup,
where D is the letter that corresponds to the CD drive.

3 Select one of the following three options and follow the
instructions in the Corel setup wizard:

* Add New Components — if you want to install
components that are not already installed

* Update Current Installation — if you want to refresh your
installation of the application and restore all settings to
their default values

® Custom Setup — if you want to specify which
components to include

To uninsTall CorelDRAW

1 Click Start on the Windows taskbar and click Programs »
CorelDRAW 10 » Setup and notes » Corel uninstaller.

2 Follow the instructions in the Corel uninstaller wizard.

RegisTering CorelDRAW

You must register CoreDRAW to be eligible for technical support.
Registered users receive our email newsletter, which contains
information about new product releases and updates, free
downloads, articles, tips, and special offers. If you have an
Internet connection, you can register by following the
instructions provided during installation. You can also register
CorelDRAW online after installation.
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To register CorelDRAW

1 Click Start on the Windows taskbar, and click Programs »
CorelDRAW 10 » Setup and notes P Corel registration.

2 Follow the instructions on the screen.

Using Core[DRAW Help

CorelDRAW has a variety of tools that help you work with the
application:

e User guide — lets you access CoreDRAW concepts and
procedures in a paper-based format

* Online documentation — lets you access Help directly from
the user interface and find topics using the contents topic,
index, and word/phrase search tool

e Context help — lets you access online Help that provides
information on a specific screen item

e CorelTUTOR — lets you work through a series of practical
lessons that introduce you to the application’s major
capabilities

* ToolTips — lets you access tips for using CoreDRAW icons
and buttons

To use online Help
1 Click Help » Help topics.
2 Click one of the following tabs:

* Contents — lets you choose a topic from a section of the
online Help

* Index — lets you use the index to find a topic

* Find — lets you find a topic by searching for a particular
word or phrase in the online Help

You can also

Print a specific Help topic Open a Help topic, and click Print.

Print an entire section On the Contents page, choose a
section, and click Print.

To use contText Help

To access context Help for Do the following

Dialog boxes Click in the dialog box, and click
the item you want help on.

Menu commands Click &¥ on the standard toolbar, and
click the item you want help on.

Tools and controls Click 8 on the standard toolbar, and
click the item you want help on.
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To access context Help for Do the following Term Description
Docker windows Click &¥ on the standard toolbar, and Object An independent element that you can modify.
click the item you want help on. Objects include images, shapes, lines, curves,
symbols, and text.
The status bar Click ®* on the standard toolbar, and . )
Drawing The work you create in CorelDRAW; for example,

click the item you want help on.

To use CorelTUTOR
e Click Help » CorelTUTOR.

2 Youcan also select CorelTUTOR from the Welcome
&\ screen at startup.

To display ToolTips

¢ Position the cursor over an icon or a button.

CorelDRAW T1eRMS

Before you get started in CorelDRAW, you should be familiar with
the following terms.

Docker window

Flyouts

Scrapbook

Thumbnails

Artistic text

Paragraph text

custom artwork, calendars, posters, and newsletters.

A window containing available commands in a dialog
box that remains open as you work.

A button that opens a group of related tools.

A folder filled with clipart, photos, fills, outlines, FTP
sites, and other items you can use in your drawings.

Small, low resolution representations of images.

A type of text to which you can apply special effects,
such as shadows.

A type of text that you can use to add blocks of text,
which is useful for drawings such as brochures
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Exploring The work aArea

Tool bar (standard)

The CoreIDRAW 10 work area appears below with the Scrapbook
Docker window open.
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Work area element

Function

Work area element

Function

Title bar

Menu bar

Toolbar

Property bar

Ruler

Toolbox

Drawing page

Desktop

The area displaying the title of the
currently open drawing.

The area containing menu options.

A dockable bar that contains
shortcuts to menus and commands.

A detachable bar with commands
that relate to an active tool or
object. For example, when the text
tool is active, the property bar
displays commands relevant to
creating and editing text.

A border that is used to determine
the size and position of objects in a
drawing.

A dockable bar with tools for
creating, filling, and modifying

objects or page.

The area in which you create a
drawing.

The area outside the drawing page.

Color palette

Status bar

Document navigator

Navigator

Docker

A dockable bar that contains the
current color swatches.

An area that contains information
and tips, as well as the current
type, size, color, fill, and resolution.

The area that contains controls for
moving between pages and adding
pages.

A button that opens a smaller
display to help you locate an object
or area of your drawing.

A dockable window that contains
all available commands for the
current object. Some Docker
windows provide a visual display
area from which you can access
elements such as size, color, and
orientation. The Scrapbook Docker
window is the example shown on
this page.

Welcome o Core|DRAW
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Exploring the Toolbar Press this button To

The toolbar consists of buttons that are shortcuts to many of the )
menu commands. ﬂ Undo an action

Press this button To Restore a canceled action

2

Start a new drawing

El Import a drawing
E Export a drawing

j‘ Set a zoom level

Open a drawing

Save a drawing

Print a drawing

Q Launch Corel applications

Cut selected objects to the

Clipboard ﬁ Launch to Corel Graphics
Community Web site

= b g w2

Copy selected objects to the
Clipboard o Launch What's This? or context
k‘ Help

Ly

Paste the Clipboard contents into
a drawing

®

—l
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Exploring The Toolbox

Each flyout contains a set a related CorelDRAW tools. A small
arrow in the right-hand corner of a toolbox button indicates a
flyout, for example, the Shape edit flyout.

Descriptions of CoreDRAW’s flyouts and their tools appear
below.

Flyout

Description

Flyout Description
Shape edit Lets you access the Shape, Knife,
Eraser, and Free transform tools.
A AFn
Zoom Lets you access the Zoom and Pan
tools.
QY
Curve Lets you access the Freehand,
Bezier, Artistic media, Dimension,
&4 &g and Interactive connector tools.
Object Lets you access the Polygon,
Spiral, and Graph tools.
CoH

Perfect shapes
AR WA

Interactive tools

#Hmmﬁ|i|

Eye dropper

2a]

Outline tool

19Nt ———-m x|

Fill
ArENeX = |

Lets you access the Basic shapes,
Arrow shapes, Flowchart shapes,
Star shapes, and Callout shapes
tools.

Lets you access the Interactive
blend, Interactive contour,
Interactive distortion, Interactive
envelope, Interactive extrude,
Interactive drop shadow, and
Interactive transparency tools.

Lets you access the Eyedropper
and Paintbucket tools.

Lets you access an Outline pen
dialog, Outline color dialog ,
Color Docker window and a
selection of outlines of various
widths.

Lets you access the Fill color,
Fountain fill, Pattern fill, Texture
fill, Postscript fill dialogs, and the
Color Docker window.

Welcome o Core|DRAW
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Flyout

Description

Interactive Fill

|

Tool Description

\ Pick
ﬂ Shape
ﬁ Knife
ﬁ Eraser

Free transform

&

Zoom

Pan

€ B

Lets you access Interactive fill and
Interactive mesh tools.

Lets you select and transform objects.

Lets you edit the shape of objects.

Lets you cut through objects.

Lets you remove areas of your
drawing.

Lets you transform your object by
using the Free rotation, Angle
rotation, Scale, and Skew tools.

Lets you change the magnification
level in the drawing window.

Lets you move the display of the
drawing window.

Lol NN (O =l O

Freehand

Bezier

Artistic media

Dimension

Interactive connector

Rectangle

Ellipse

Polygon

Spiral

Graph paper

Basic shapes

Lets you draw lines and curves.

Lets you draw curves using a
connect-the-dots style of drawing.

Provides access to the Brush, Sprayer,
Calligraphic, and Pressure tools.

Lets you draw vertical, horizontal,
slanted, or angular dimension lines.

Lets you join two objects with a line.

Lets you draw rectangles and squares.

Lets you draw ellipses and circles.

Lets you draw polygons and stars.

Lets you draw symmetrical and
logarithmic spirals.

Lets you draw a grid of lines similar to
that on graph paper.

Lets you choose from a full set of
shapes, including hexagram, a smiley
face, and a right-angle triangle.
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Arrow shapes

Flowchart shapes

Star shapes

Callout shapes

Text

=Dz

Interactive fill

Interactive mesh

Interactive transparency

Interactive blend

Interaction distortion

= el

Lets you draw arrows.

Lets you draw flowchart symbols.

Lets you draw ribbon objects and
explosion shapes.

Lets you draw callouts and labels.

Lets you type words directly on the
screen as artistic text or as paragraph
text.

Lets you apply various fills using the
mouse.

Lets you apply a mesh grid to an
object using the mouse.

Lets you apply transparencies to
objects using the mouse.

Lets you blend two objects.

Lets you apply a Push or Pull
distortion, a Zipper distortion, or a
Twister distortion to an object.

=

ER - A=Y

& &

Interactive envelope

Interactive extrude

Interactive drop shadow

Interactive contour

Eyedropper

Paintbucket

Outline

Fill

Lets you distort an object by dragging
the nodes of the envelope that is
placed on top of the object.

Lets you apply a third dimension to
objects.

Lets you apply a drop shadow to an
object.

Lets you apply a contour to an object.

Lets you select a fill from an object on
the Drawing window using the mouse.

Lets you fill an object on the drawing
window after selecting a fill using the
Eyedropper tool.

Opens a flyout that lets you set the
outline properties.

Opens a flyout that lets you set the fill
properties.

Welcome o Core|DRAW
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GEeTTinG STARTEd

Drawings are the work that you create and edit in CoreIDRAW.

In this section, you'll learn about

starting and opening drawings

using the basic features of CoreIDRAW
undoing, redoing, and repeating actions
specifying the page layout

adding, renaming, and deleting pages
accessing drawing information

setting up the rulers

zooming and panning

saving drawings

* closing drawings and quitting CoreDRAW

STARTING ANd OpeNiNGg drRAWINGS

CorelDRAW lets you start a new drawing from a blank page, from
a template, or from an existing drawing.

A blank page gives you the freedom to specify every aspect of a
drawing.

A template provides you with a starting point and leaves the
amount of customization to you. The templates included with
CorelDRAW are available under the following categories:

e Full page
* Label

CorelDRAW User Guide: Chaprer 2
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¢ Booklet
¢ Side-fold
e Web

Basing a new drawing on an existing drawing lets you reuse
objects and page settings without having to recreate them.
CorelDRAW lets you open existing drawings saved to a variety of
file formats. For information about the file formats CoreIDRAW
lets you open, see “File formats” in the online Help.

CorelDRAW lets you use clipart, photos, and sound files that are
stored on the CoreIDRAW CD, or that are available on Corel’s
Content on the Web site (an http:/protocol site only accessible
from the CoreIDRAW Scrapbook Docker). You can access these
files by browsing or searching.

To sTarT A drRAWING

To Do the following

Start a drawing from a blank page Click File » New.

Click File » New from template, click
the tab that corresponds to the
template category you want, and
choose a template.

Start a drawing from a template

2 You can specify a layout style (template) by clicking
&\ Layout b Page setup, clicking Layout in the list of

categories, and choosing a layout style from the
Layout list box.

To open A drawing

1 Click File » Open.

2 Choose the drive and folder where the drawing is stored.
3 Click a filename.

If you want to view a thumbnail of the drawing, enable the
Preview check box.

4 Click Open.

< You can also open a drawing by clicking the Open
&\  button on the property bar.

To browse for clip art, photos, and sound Files
1 Click Window » Dockers » Scrapbook » Browse.

2 Navigate to a file stored on your computer or on the CD
installed in your CD drive.

18
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To search for clip art, photos, and sound Files
1 Click Window » Dockers » Scrapbook P Search.
2 Type a search keyword in the Search for text box.

3 Click the Search button.

2 You can specify how you want the search results
s\~ displayed by clicking on of the following buttons:
Large icons, Small icons, List icons, Detail view.

Using The basic features of Corel[DRAW

CorelDRAW has a virtually unlimited number of tools and
capabilities to help you create drawings. The following table
provides you with the basic features of CoreIDRAW so that you

can get started.

For information on

See

Drawing lines

Drawing shapes
Creating and manipulating objects

Adding color to objects

Using lines, outlines, and brush
strokes on page 31

Drawing shapes on page 37
Working with objects on page 43

Filling objects on page 81

For information on See

Adding text to a drawing Working with text on page 131

Creating drawings for use on the Publishing to the Web on page
World Wide Web 167

Printing drawings Printing on page 149

Undoing, rRedoing, ANd REPEATING ACTiONS

You can undo the actions you perform on drawing, starting with
the most recent action. Reverting to the last saved version of a
drawing also lets you remove one or more actions.

If you accidentally undo an action, you can redo it. Customizing
the undo settings lets you increase or decrease the number of
actions that you can undo or redo.

You can also repeat an action you apply to create a stronger
visual effect.

To undo, redo, ANd REpEAT AcTiONS

To Do the following

Undo an action Click Edit » Undo.

GerTing sTarTed
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To

Do the following

Redo an action

Undo or redo a series of actions

Revert to the last saved version of

a drawing

Repeat an action

Click Edit » Redo.
Click Tools » Undo Docker, choose
an action from the list, and apply a

new action to the drawing.

Click File » Revert.

Click Edit b Repeat.

S

7

When you undo a series of actions, all actions listed
below the action you choose are undone.

When you redo a series of actions, the action you
choose and all actions listed between it and the last
undone action are redone.

You can also undo or redo a single or series of actions
in the Undo Docker window, by clicking the last
action you want to appear. Actions below the
selected action in the list are undone or redone.

To customize the undo serTings
1 Click Tools » Options.

2 In the list of categories, double-click Workspace and click
General.

3 Type avalue in the Regular box.

“% The value you specify is limited only by your
computer’s memory resources; therefore, the higher
the value you specify, the greater the demand on the
memory resources.

Specifying The page layour

You can begin working on a drawing by specifying settings for
the size, orientation, and layout style of the page.

There are two options for specifying a page size: choosing a
preset page size or creating your own. You can choose from
hundreds of preset page sizes ranging from legal paper and
envelopes to posters and Web pages. If a preset page size does
not meet your needs, you can create a custom page size by
specifying a drawing’s dimensions.

The orientation of the page can be landscape or portrait.
Landscape orientation defines whether the drawing’s width is
greater than its height, while portrait orientation defines
whether the drawing’s height is greater than its width. Any pages

20
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you add to a drawing project assume the current orientation;
however, you can give single pages in a drawing project a
different orientation. The options you choose when specifying

the page layout can be used as a default for all new drawings you

create. You can also adjust the orientation settings of the
drawing to match the standard paper size for printing.

To set The page size ANd orienTATiON

To

Do the following

Choose a preset page size

Specify a custom page size

Set the page orientation for all
pages in a drawing

Click Layout » Page setup, and
choose a paper type and size from
the Paper list box.

Click Layout » Page Setup, choose
Custom from the Paper list box,
and type values in the Width and
Height boxes.

Click Layout » Page Setup, and
enable the Landscape or the
Portrait option.

To Do the following
Set the page orientation for an Click the bottom half of the Set
individual page in a drawing default or current page size and

orientation button on the
property bar, and click the
Landscape or Portrait button.

@: You can also specify the page size and orientation for

&\ individual pages by clicking View » Page sorter view,
clicking a page, and specifying your options using the
buttons on the property bar.

To starT New drawings with specific page layour
OpTioNS

1 Click Tools » Options.
2 In the list of categories, click Document.

3 Enable the Save options as defaults for new documents check
box.

To march the orienTATION SETTINGS TO ThEe pRINTER
SETTINGS

1 Click Layout b Page setup.
2 Enable the Normal paper option.
3 Click Set from printer.

GerTing sTarTed

21



Adding, renaming, ANd deleTing pages

CorelDRAW lets you add a page to a drawing, rename it anytime,
and delete a single page or an entire range of pages.

You can also rearrange the order of pages after you have created
a multipage drawing.

To add a page
1 Click Layout » Insert page.

2 Type the number of pages you want to add in the Insert pages
box.

3 Enable one of the following options:
* Before
* After

@: You can also add pages by clicking the Add page

To RENAME A pAGE
1 Click Layout » Rename page.
2 Type the name of the page in the Page name box.

To deleTe a page
1 Click Layout b Delete page.

2 In the Delete page dialog box, type the number of the page
you want to delete.

2 You can delete a range of pages by enabling the
&\ Through to page check box and typing the number of
the last page in the Through to page box.

To rearranGe The order of pages
1 Click View P Page sorter view.
2 Click and drag a page to its new location.

&\  button on the Document Navigator, if you're on the You can also
first or last page.
pag Copy a page Right-click and drag the page you

You can also choose where to add a page by want to copy and click Copy here.
right-clicking an existing page in the Document Return to normal view Double-click a page to get back to the
Navigator and clicking Insert page after or Insert regular view of that page.
page before.
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@: You can also change the layout and orientation of
&\ individual pages, by clicking the relevant buttons on
the property bar while in Page sorter view.

You can also rearrange the order of pages by clicking
and dragging the page tabs on the Document
Navigator at the bottom of the drawing window.

Accessing drawing informATION

You can access drawing information such as the number of pages
in a drawing, and the types of objects it contains, as you work.
You can also save and print this information.

To access drawing informaTion

1 Click File » Document info.

2 Enable the check box beside each type of information you
want to display.

You can also

Click Save as, specify a drive, folder,
and filename, and click Save.

Save drawing information

Print drawing information Click Print.

Serting up The rulers

The rulers display in the drawing window by default and can help
you size, align, and draw objects precisely. You can hide the
rulers if you don’t need to display them or move them to another
position in the drawing window. You can also customize the ruler
settings to suit your needs. For example, you can set the ruler
origin, choose a unit of measure, and specify how many marks or
ticks display between each full unit mark.

By default, CoreDRAW applies the same units used for the rulers
to the duplicate and nudge distances. For information about
nudging, see “Positioning objects” on page 47. You can change
the default so that you can specify different units for these and
other settings.

To hide or display The rRulers

e (Click View P Rulers.

To move A rRuler

* Hold down SHIFT and drag a ruler to a new position in the
drawing window.

GerTing sTarTed
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To customize rRuler seTTings
1 Click View » Grid and ruler setup.
2 In the list of categories, click Rulers.

3 In the Units area, choose a unit of measure from the
Horizontal list box.

4 In the Origin area, type values in the following boxes:
* Horizontal origin
® Vertical origin

5 Type avalue in the Tick divisions box.

If you don’t want the unit of measure for the placement of
duplicate objects and for the nudge value to be the same as
the rulers units, disable the Same units for duplicate
distance, nudge and rulers check box.

@\: You can specify nudge settings by typing values in the
& \Y Nudge, Super nudge, and Micro nudge boxes. For
more information about nudging, see “Positioning
objects” on page 47.

2 You can specify a different unit of measure for each

&\ ruler by disabling the Same units for horizontal and

vertical rulers check box and typing values in the
boxes.

You can access ruler settings directly by right-clicking
on a ruler and clicking Ruler setup.

Zooming ANd pANNiING

You can change the view of a drawing by zooming in to get a
closer look or by zooming out to see more of the drawing. You
can experiment with a variety of zoom options to see the amount
of detail you want.

Another way in which you can view specific areas of a drawing is
by panning. Panning lets you view areas of the drawing window
page that aren’t displayed at the zoom level you're working with.
While you are panning, you can zoom in and out. This saves you
from having to alternate between the two tools.

You can also view areas that fall outside the drawing page by
using the Navigator in the bottom right-hand corner of the
drawing window. For example, when you work at high
magnification levels or with large drawings, you may not be able
to see everything in a drawing. The Navigator allows you to jump
to a different drawing area without having to adjust the
magnification level.

You can customize the default settings for zooming and panning.
For example, you can specify whether you want to zoom out by a
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factor of two, or display a menu of commands that lets you
quickly choose from a variety of other zoom levels.

To zoom

1 Open the Zoom flyout =< | , and click the Zoom tool i .
2 On the property bar, click one of the following buttons :

e Zoom in

e Zoom out

* Zoom to selected

® Zoom to all objects

® Zoom to page

* Zoom to page width

® Zoom to page height

If you want a different view, you can click the Navigator in the
bottom, right-hand corner of the drawing window, holding
the mouse button down as you do so, and move the drawing
page around in the Navigator pop-up window.

@y

-
IS

The Zoom to selected button is available only when
you select one or more objects before you open the
Zoom flyout.

You can also zoom in by opening the Zoom flyout,
clicking the Hand tool, and double-clicking anywhere

in the drawing window. To zoom out, right-click with
the Hand tool.

To pan in The drawing window
1 Open the Zoom flyout % & | , and click the Hand tool %3

2 Drag in the drawing window until the area you want to view
displays.

@: You can also zoom in by double-clicking with the
&\ Hand tool and zoom out by right-clicking with the
Hand tool.

You can also get a different view of a drawing by
clicking the Navigator in the bottom, right-hand
corner of the drawing window, holding the mouse
button down as you do so, and moving the
cross-haired cursor around in the Navigator pop-up
window.
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To establish defaulr sertings For The Zoom or Hand
Tool

1 Click Tools P Options.

2 Double-click Toolbox, and click Zoom, Hand Tool in the list of
categories..

3 To specify what you want the Zoom or Hand tool to do when
you right-click on it in the drawing window, enable one of the
following options:

® Zoom Out — zooms out by a factor of two

* Context Menu — displays a menu of commands that you
can choose from to zoom to a specific level

Saving drawings

CorelDRAW lets you save a drawing as you work. When you save
a drawing for the first time, you must specify a filename, drive,
and folder. You can specify advanced save options to change a
drawing’s thumbnail, compress a drawing to reduce the file size,
and save blends and extrusions with a drawing.

By default, drawings are saved to the CorelDRAW file format;
however, advanced save options also let you choose other file
formats. For example, if you want to use a drawing in
WordPerfect, you can save it to the WordPerfect Graphic (WPG)
format. If you are saving a drawing to use in another application,
you must save it to a file format that is supported by that

application. You can also save a drawing to a previous version of
CorelDRAW.

Drawings can also be saved as templates, letting you create
drawings based on the properties of saved drawings.

CorelDRAW also lets you save selected objects in a drawing. If
you are working on a large drawing, saving only the selected
objects can decrease the time it takes to load a drawing, and
reduce the demands on your computer’s memory.

To protect changes to a drawing as you work, you can specify
autobackup settings. When you save automatically, you specify a
time interval in which a backup of the current drawing is saved.

To save A drawing

1 Click File » Save.

2 Choose the drive and folder where you want to save the file.
3 Choose a file type from the Files of type list box.

4 Type a filename in the Filename box.

If you want to specify advanced settings, click Advanced, and
specify the settings you want in the Options dialog box.

5 Click Save.
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2 You can also save a drawing by clicking the Save
&\ button on the property bar.

You can save a drawing to an earlier version of
CorelDRAW by choosing CDR-CorelDRAW from the
Files of type list box and choosing a version number
from the Version list box.

To save A drawing with a New filename
1 Click File » Save as.
2 Type a filename in the Filename box.

If you want to change the location where the renamed
drawing is stored, choose a drive and folder.

3 Click Save.

Closing drawings ANd ouvitTing Core[DRAW

You can close one or all open drawings at any time. You can also
quit CorelDRAW.

To close drawings

To close Do the following

One drawing Click File » Close.

All open drawings Click Window » Close all.

To ouit CorelDRAW
Click File » Exit.

From here

For more information about...

In the online Help Index, type...

Saving drawings

Choosing a page background
Calibrating the rulers
Setting up the grid

Setting up guidelines
Setting the drawing scale
Previewing a drawing

Working with views

drawings, saving

page, choosing backgrounds
rulers, aligning objects

grid, setting up

guidelines, adding
drawings, scaling

drawings, previewing

viewing, modes
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Using lines, outlines, ANd brush strokes

CorelDRAW lets you add lines and brush strokes using a variety
of techniques and tools. After you draw lines or apply brush
strokes to lines, you can format them. For information about
formatting lines, see the online Help.

In this section, you'll learn about
e drawing lines

e applying brush strokes

Drawing lines

CorelDRAW lets you draw all kinds of different lines, from curved
or straight freehand lines to calligraphic lines. Curved freehand
lines look hand drawn. If you make a mistake while you're

drawing freehand lines, curved or straight, you have the option
to erase the most recently created portion of the line.

Another type of line you can draw is a bezier line. You can draw
straight or curved segments, adding one segment at a time.
Bezier lines have nodes and control points that you can
manipulate as you draw to shape the lines. You can change the
node type after you draw a line. For information about node
types, see “Working with curve objects” on page 68.

CorelDRAW also lets you simulate the effect of a calligraphic pen
when you draw lines. Calligraphic lines vary in thickness
according to the direction of the line and the angle of the pen
nib. By default, calligraphic lines display as closed shapes drawn
with a pencil. You can control the thickness of a calligraphic line
by changing the angle of the line you draw in relation to the
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calligraphic angle you choose. For example, when you draw
perpendicular to the calligraphic angle, the line is at the
maximum thickness specified by the pen width. Lines drawn at
the calligraphic angle, however, have little or no thickness.

CorelDRAW lets you create pressure-sensitive lines which vary in
thickness. You can create this effect using the mouse or a
pressure-sensitive pen and graphics tablet. Both methods result
in lines with curved edges and varying widths along a path. For
information about using a pressure-sensitive pen on a graphics
tablet, see the manufacturer’s instructions.

CorelDRAW provides preset lines that let you create thick strokes
in a variety of shapes. After you draw a calligraphic or preset line,
you can apply a fill to it as you would to any other object. For

information about applying fills, see “Filling objects” on page 81.

To draw a sTrAiGghT OR curved line

To draw Do the following

A straight line

Open the Curve flyout & & & % | , and click

the Freehand tool # | . Click where you want to

start the line, and click where you want to end it.
A curved line Open the Curve flyout, and click the Freehand
tool. Click and drag across the drawing page.

@: You can constrain the angle at which you draw a
&\ straight line by holding down CTRL as you drag.

You can erase a portion of a curved line before you
release the mouse button by holding down SHIFT and
dragging back over the line.

You can use these procedures to add segments to a
selected line by clicking the line’s end node and
dragging. If you want to draw a closed shape, draw a
line connecting the end node to the beginning node.

To draw bezier lines

To draw Do the following

Open the Curve flyout = # & &I % | , and click

the Bezier tool | . Click where you want to
start the line, and click where you want to change
direction. Press SPACEBAR to finish the line.

A straight or
jagged bezier line

A curved bezier Open the Curve flyout, and click the Bezier tool.
line Click and drag to shape the line.
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4 Drag until the line is the shape you want.

If you want to set the width of the line, type a value in the
Artistic media tool width box on the property bar.

angle of the line you draw in relation to the
calligraphic angle determines the line’s actual width.

%% The width you set is the maximum line width. The

@/ You can also access calligraphic lines by clicking

You can draw jagged lines using You can create complex objects by IS \\‘ Effects b Artistic media, and specifying the settings
the Bezier tool, by clicking each drawing Bezier curves. . . A K
time you want the line to change you want in the Artistic media Docker window.
direction.
To draw A pRrEessuRE-seNsiTivE Line
1 Open the Curve flyout, and click the Artistic media tool &/ .
< You can draw a closed shape while you draw a bezier 2 Click the Pressure button on the property bar.

€AY line, by clicking the first node created. If you want to smooth the edges of the line, type a value in

To draw a calligraphic line the Freehand smoothing box on the property bar.

1 Open the Curve flyout | # # & & | . and click the 3 Drag until the line is the shape you want.
Artistic media tool. If you want to change the width of the line, type a value in the
2 Click the Calligraphic button &/ on the property bar. Artistic media tool width box on the property bar.
3 Type avalue in the Calligraphic angle box on the property .. The width you set represents the line’s maximum
bar. width. The amount of pressure you apply determines
If you want to smooth the edges of the line, type a value in the line’s actual width.

the Freehand smoothing box on the property bar.
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If you are using the mouse, press the UP ARROW or
DOWN ARROW to vary the pen pressure, and,
therefore, the width of the line.

FS

S

You can also access pressure-sensitive lines by
clicking Effects » Artistic media, and specifying the
settings you want in the Artistic media Docker
window.

Applying brush sTrokes

CorelDRAW lets you apply a variety of preset brush strokes,
ranging from strokes with arrowheads to ones that are filled with
rainbow patterns. When you draw a preset brush stroke, you can
specify some of its attributes. For example, you can change the
width of a brush stroke and specify its smoothness.

You can also create custom brush strokes using an object or a
group of objects. For information about grouping objects, see
“Grouping and combining objects” on page 53. The objects that
you use to create a brush stroke can be vector objects or
bitmapped images, including those with dropshadows or
transparencies. When you create a custom brush stroke, you can
save it as a preset.

To apply A preser brush sTroke

1 Open the Curve flyout & & &> % | , and click the Artistic
media tool & .
Click the Brush button on the property bar.

3 Choose a brush stroke from the Brush stroke list box.

If you want to smooth the edges of the brush stroke, type a
value in the Freehand smoothing box on the property bar.

4 Drag until the stroke is the shape you want.

If you want to set the width of the stroke, type a value in the
Artistic media tool width box on the property bar.

@: You can apply a brush stroke that isn’t listed in the

&\ Brush stroke list box by clicking the Browse button
on the property bar, and locating the brush stroke
file.
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To create A custom brush stroke

1 Select an object or a set of grouped objects.

Open the Curve flyout, and click the Artistic media tool.
Click the Brush button on the property bar.

Click the object or grouped objects.

u s W N

Click the Save artistic media stroke button on the property
bar.

Type a name for the brush stroke in the Filename box.
7 Click Save.

=2}

2 You can create custom brush strokes by clicking
s\ Effects b Artistic media, and specifying the settings
you want in the Artistic media Docker window.

From here

For more information about... In the online Help Index, type...
Drawing preset lines lines, drawing preset lines
Formatting lines and outlines lines, formatting

Using lines, outlines, aNd brush sTrokes
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DrAwinGg SHApES
CorelDRAW lets you draw basic shapes, which you can transform DRAWiNq RECTAquES ANd SQUARES

by using special effects and reshaping.

In this section, you'll learn about

drawing rectangles and squares

drawing ellipses, circles, arcs, and wedges
drawing polygons and stars

drawing spirals

drawing grids

drawing pre-defined shapes

CorelDRAW lets you draw rectangles and squares. After you draw
a rectangle or square, you can reshape it by rounding one or
more of its corners.

To draw A recTaNGle OR A sQuARE

To draw a Do the following

Rectangle Click the Rectangle tool [, and
drag in the drawing window until the
rectangle is the size you want.

Drawing shapes

77



Square Click the Rectangle tool, hold down

CTRL, and drag diagonally in the
drawing window until the square is
the size you want.

You can draw a rectangle or a square from its center
outward by holding down SHIFT as you drag.

-
I£S

You can draw a rectangle that covers the drawing
page by double-clicking the Rectangle tool.

To round The corners of A RecTANGlE OR A sQuARE

1 Open the Shape flyout & d-:l':h.l , and click the Shape
tool & .

2 Click a rectangle or a square.

3 Drag a corner node along the outline of the shape.
- To round a single corner of a rectangle or a square,
-

&V click a node with a Shape tool, pause and drag along
the outline of the shape.

Drawing ellipses, circles, arcs, aANd wedges

You can draw an ellipse or circle and change the shape into an arc
or wedge. You can also change the direction of arcs and wedges.

To draw an ellipse or A circle

To draw Do the following

An ellipse Click the Ellipse tool &#| , and drag
in the drawing window until the
ellipse is the shape you want.

A circle Click the Ellipse tool, hold down

CTRL, and drag in the drawing window
until the circle is the size you want.

You can draw an ellipse or a circle from its center
outward by holding down SHIFT as you drag.

23

To drAaw AN ARC OR A WedGE

To draw Do the following

An arc Open the Shape flyout = & A4 # !—l ,
and click the Shape tool. Click the
node of the ellipse or circle, and drag
outside the shape’s perimeter.

A wedge Open the Shape flyout, and click the

Shape tool. Click the node of the
ellipse or circle, and drag inside the
shape’s perimeter.
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To create a wedge, drag the node of an ellipse to the inside of an ellipse, as
shown above and to the left. To create an arc, drag the node to the outside of
the ellipse, as shown above and to the right.

@: You can change the direction of a selected arc or a
S\ wedge by clicking the Clockwise/counterclockwise
arcs or pies button on the property bar.

You can constrain the movement of the node to
15-degree increments by holding down CTRL as you
drag.

Drawing polygons and sTars

CorelDRAW lets you draw polygons and stars and then reshape
them. For example, you can convert polygons to stars and stars
to polygons, change the number of sides on a polygon or the
number of points on a star, and sharpen the points of a star.

You can make the changes in one node apply in the other related
nodes of the polygon or star so that all changes are symmetrical.

To draw A polygon or A sTAR

To draw a Do the following

Polygon Open the Object flyout & & B | ,
click the Polygon tool, and drag in the
drawing window until the polygon is
the size you want.

Star Open the Object flyout, click the

Polygon tool, and drag in the drawing
window until the polygon is the size
you want, and click the Star button on
the property bar.

@: You can draw a polygon or a star from its center by
&\ holding down SHIFT as you drag.

You can draw a symmetrical polygon or a star from its
center by holding down CTRL as you drag.

To reshape A polygon or A sTAR

To

Do the following

Change a polygon to a star or a
star to a polygon

Select a polygon or star, and click
the Polygon or Star button on the
property bar.

Drawing shapes
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To

Do the following

Change the number of sides of a
polygon or number of points on a
star

Sharpen a star’s points

Select a polygon or star, type a
value in the Number of points on
polygon box on the property bar,
and press ENTER.

Select a star, and move the

Sharpness slider on the property
bar.

N2 The Sharpness slider displays only if the star you
select has at least seven points. The sensitivity of the
slider increases with the number of points.

Drawing spirals

You can draw two types of spirals: symmetrical and logarithmic.
Symmetrical spirals expand evenly so that the distance between
each revolution is equal. Logarithmic spirals expand unevenly;
that is, with increasingly larger distances between revolutions.
You can also set the rate by which a logarithmic spiral expands
outward.

A symmetrical spiral (left) and a logarithmic spiral (right).

To draw a spiral
1 Open the Object flyout & & ® | , and click the Spiral tool.
2 Type avalue in the Spiral revolutions box on the property bar.
3 On the property bar, click one of the following buttons:
* Symmetrical spiral
* Logarithmic spiral &

If you want to change the amount by which the spiral expands
as it moves outward, move the Spiral expansion slider.

4 Drag diagonally in the drawing window until the spiral is the
size you want.
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@: You can draw a spiral from its center outward by
&\ holding down SHIFT as you drag.

You can also draw a spiral with even horizontal and
vertical dimensions by holding down CTRL as you
drag.

Drawing GRrids

You can draw a grid-shaped object and set the number of its rows
and columns. A grid is a grouped set of rectangles, which you can
break apart.

To draw a grid
1 Open the Object flyout & & m | , and click the Graph paper
tool HH | .

2 Type values in the top and bottom portions of the Graph
paper columns and rows box on the property bar.

The value you type in the top portion specifies the number of
columns; the value in the bottom portion specifies the
number of rows.

3 Position the cursor where you want the grid to appear.
4 Drag diagonally to draw the grid.

If you want to draw the grid from its center point outward,
hold down SHIFT.

< You can break apart a grid into its component

&7\ rectangles by selecting the grid with the Pick tool and
clicking Ungroup on the Group property bar.

Drawing pre-defined shapes

You can draw pre-defined, nongeometrical shapes, such as basic
shapes, arrows, stars, and callouts using the Perfect Shapes
collection.

Basic shapes, arrows shapes, star shapes, and callout shapes have
glyphs, which let you modify a shape’s appearance. The
right-angle, heart, lightning bolt, and explosion shapes do not
have glyphs.

S
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You can drag a glyph to alter a shape.

Drawing shapes
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You can add text to the inside or outside of the shape. For
example, you might want to put a label inside a flowchart symbol
or a callout.

To draw A pre-defined shape

1 Open the Perfect shapes flyout &% & | , and click one
of the following tools:

Basic shapes
Arrows shapes
Flowchart shapes
Star shapes
Callout shapes

2 Open Perfect shapes picker on the property bar, and click a
shape.

3 Drag in the drawing window until the shape is the size you
want.

To change A pre-defined shape using its glyphs

1 Select a shape with a glyph.

2 Drag a glyph until the shape is the form you want.

%@ Flowchart shapes do not have glyphs.

To aAdd T1ext 10 A pre-defined form

1
2

Click the Text tool & .

Position the cursor inside the shape’s outline until it changes
to a Text cursor box.

Type and format the text font inside the shape.
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Working with objects

Working with objects is an essential part of creating drawings.

In this section, you'll learn about

e selecting objects

e copying, duplicating, and deleting objects
e positioning objects

* sizing and scaling objects

e skewing and stretching objects

e rotating and mirroring objects

e changing the order of objects

e grouping and combining objects

e aligning, distributing, and snapping objects

* cloning objects
* blending objects
* spraying objects along a line

e drawing flow and dimension lines

Selecting objecrts

Before you can change an object, you must select it. You can
select visible objects, hidden objects, and a single object in a
group or a nested group. You can also select all objects at once.

CorelDRAW User Guide: Chapter 7
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When you select an object, selection handles appear around the object. A

small “x” marks the center of the selection box.

You can select a single object from a group of objects.

To select objects

To select

Do the following

An object

Multiple objects

An object, starting with the
first object created and
moving toward the last
object created.

An object, starting with the
last object created and
moving toward the first
object created.

All objects

An object in a group

An object in a nested group

Click an object with the Pick tool &

Hold down SHIFT, and click each object
you want to select.

Press TAB until a selection box displays
around the object you want to select.

Press SHIFT + TAB until a selection box
displays around the object you want to
select.

Click Edit P Select all » Objects.

Hold down CTRL, and click an object in
a group.

Hold down CTRL, and click an object
you want to select until a selection box
displays around it.
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To select Do the following

A hidden object Hold down ALT, and click the topmost
object until a selection box displays
around the hidden object you want to

select.

Hold down ALT + SHIFT and click the
topmost object until a selection box
displays around the hidden objects you
want to select.

Multiple hidden objects

Hold down CTRL + SHIFT and click the
topmost object until a selection box
displays around the hidden object you
want to select.

A hidden object in a group

The status bar displays a description of each hidden
object as you select it.

7

@: You can also select one or more objects by dragging
&\ around the object or objects with the Pick tool.

To deselect objecrts

To deselect Do the following

A single object Click the Pick tool ' &, and click
a blank space in the drawing

window.

Hold down SHIFT, and click the
object using the Pick tool.

A single object in multiple
selected objects

Copying, duplicating, aAnd deleting objecTs

CorelDRAW gives you two ways to copy objects. You can cut or
copy an object to place it on the Clipboard and paste it into a
drawing or you can duplicate an object.

You can copy entire objects or just their fill properties. Cutting an
object to the Clipboard removes it from the drawing; copying an
object to the Clipboard leaves the original in the drawing; and
duplicating an object places a copy directly in the drawing
window, not the Clipboard.

You can create a transformed duplicate of an object while
keeping the original object intact. If you decide that you want to
keep the original object, you can delete the duplicate.
Duplicating an object is also faster than cutting and pasting.
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When you no longer need an object, you can delete it.

To place an object on The Clipboard
1 Select an object.
2 Click Edit, and click one of the following:
* Cut
* Copy

2 You can also cut or copy an object by right-clicking
&\ the object and clicking Cut or Copy.

To paste AN object inTo A drAWING
e C(lick Edit » Paste.

To copy AN object’s Fill properTies To aANoThER
objecr

1 Click the Pick tool &

2 Select the object to which you want to copy another object’s
properties.

3 Click Edit » Copy properties from.

4 Enable any of the following check boxes:
® Qutline pen
® OQutline color
* Fill

* Text properties
5 Click OK.
6 Click the object whose properties you want to copy.

To duplicaTte an objecr
1 Select an object.
2 Click Edit » Duplicate.

To create A Transformed duplicare

1 Select an object.

2 Click Window » Toolbars » Transform.

3 Click Apply to duplicate on the Transform toolbar.
4

Type new values in the Transform toolbar boxes, then press
ENTER.

< You can clear a transformation by selecting an object
&\  and clicking Under arrange » Clear transformations.

To delete an objecr
1 Select an object.
2 Click Edit P Delete.

2 You can also delete an object by right-clicking the
&\ object and clicking Delete.
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Positioning objects

You can position objects by moving them to a new location, by
nudging, or by specifying their horizontal and vertical position.

The values you set in super nudging and micro nudging allow you
to move objects into place by increments. By default, you can
nudge objects in 0.1-inch increments, but you can change the
nudge values to suit your needs.

When you specify the position of an object, you can set
horizontal and vertical coordinates that are relative to the
object’s center anchor point or to another anchor point. You can
also position objects by placing them at specific horizontal and
vertical coordinates in the drawing window according to the
center or one that you specify in the object.

By default, the point of origin (0,0) is at the lower left corner of
the drawing page. When you enable the Relative position check
box in the Transformation Docker window, the H and V boxes
identify the position of the center anchor point as 0,0. When you
specify a different position using the H and V boxes, the values
represent a change from the object’s current position as
measured from the center anchor point.

To move an objecr

* Drag an object to a new position in the drawing.

To Nudge an objecr

To Do the following

Nudge a selected object by the
nudge distance

Press an Arrow key.

Nudge a selected object by a
multiple of the nudge distance

Hold down SHIFT, and press an
Arrow key.

Nudge a selected object by a
fraction of the nudge distance

Hold down CTRL, and press an
Arrow key.

To ser nudge disTances
1 Click Tools » Options.

2 In the list of categories, double-click Document and click
Rulers.

3 Type avalue in the Nudge box.

Type a value in either the Super nudge or the Micro nudge
box.

5 Choose a unit of measure from the Units list box.

< You can also set the nudge distance by deselecting all

& \Y objects and typing a value in the Nudge Offset box in
the property bar.
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To position AN object
1 Select an object.

2 On the property bar, type values in the following stacked
boxes:

® x — lets you position the object on the x axis
® y— lets you position the object on the y axis
3 Press ENTER.

To position aN object using A different anchor
POINT

1 Select an object.
2 Click Window » Dockers » Transformations » Positions.
3 Disable the Relative position check box.
4 Type values in the following boxes:
* H — lets you specify a value for the horizontal position of
an object
® V — lets you specify a value for the vertical position of an
object

5 Enable the check box that corresponds to the anchor point
that you want to set.

6 Click Apply.

Sizing And scaling objects

CorelDRAW lets you size and scale objects. In both cases, you
change the dimensions of an object proportionally by preserving
its aspect ratio. You can size an object’s dimensions by specifying
values or changing the object directly. Scaling changes an object’s
dimensions by a specified percentage.

You can change an object’s anchor point from its center to any of
its eight selection handles. CoreIDRAW also lets you reset the
anchor point to the center of an object.

To size AN object

To Do the following

Size a selected object Drag any of the corner selection

handles.

Size a selected object from its
center

Hold down SHIFT, and drag one of
the selection handles.

Size a selected object to a
multiple of its original size

Hold down CTRL, and drag one of
the selection handles.
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To Do the following

Stretch a selected object as you
size it

Hold down ALT, and drag one of
the selection handles.

= You can also set a precise size for the object by typing

S7\Y values in the Object size boxes on the property bar.
To scale an objecr
1 Select an object.
2 Click Window » Dockers » Transformations P Scale.
If you want to change the object’s anchor point, enable the
check box that corresponds to the anchor point you want to
set.
3 Type values in the following boxes:
* H — lets you specify a percentage by which you want to
scale the object horizontally

® V — lets you specify a percentage by which you want to
scale the object vertically

You can also scale an object by dragging a selection
handle.

-
2

If you want to maintain the aspect ratio, disable the
Non-proportional check box.

Skewing And sTretching objects

You can skew and stretch objects in CorelDRAW. When you skew
an object, you specify the degree by which you want to slant the
object.

Skewing an object horizontally.
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Stretching changes an object’s vertical and horizontal dimensions
nonproportionally. You can stretch an object from its center and
in increments of 100%.

] ]
Stretching an object horizontally.

CorelDRAW also lets you change the skew anchor point of an
object from its default center position. If you move the skew
anchor point, you can reset it to the center again.

To skew an objecr

1 Select an object.

2 Click Window » Dockers » Transformations » Skew.
3 Type avalue in one or both of the following boxes:

* H — lets you specify the number of degrees by which you
want to skew the object horizontally

® V— lets you specify the number of degrees by which you
want to skew the object vertically

4 Click Apply.

2 You can also skew an object interactively by dragging
&\ one of its skew handles.

To stretch an objecr

1 Select an object.

2 Click Window » Dockers » Transformations P Size.
3 Enable the Non-proportional check box.

If you want to change the object’s anchor point, enable the
check box that corresponds to the anchor point you want to
set.

4 Type avalue in one of the following boxes:
* H — lets you specify the width of a selected object
® V — lets you specify the height of a selected object
5 Click Apply.
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You can also Do the following

Stretch an object from its center Hold down SHIFT, and drag a
corner selection handle.

Stretch an object in increments of  Hold down CTRL, and drag a
100% corner selection handle.

To revert the object to its original one-to-one
proportions before transforming it again, you must
disable the Non-proportional check box, and then
re-type the equal values.

Yz

@: You can stretch an object non-proportionally by
s\ holding down ALT and drag a corner selection handle.

RotaTting ANd MiRRORING ObjecTs
CorelDRAW lets you rotate and create mirror images of objects.

You can rotate an object in a drawing by specifying horizontal
and vertical coordinates. You can move the center of rotation to a
specific ruler coordinate or to a point that is relative to the
current position of the object depending on the effect you are
creating.

Rotating objects around a single point.

Mirroring an object horizontally flips it from left to right, top to

bottom, or vice versa. By default, the mirror anchor point is in
the center of the object.

Mirroring an object top to bottom.
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To rotaTE AN object

1 Select an object.

2 Click Window » Dockers » Transformations » Rotate.
3 Disable the Relative center check box.

To rotate an object around a point relative to its current
position, enable the Relative center check box.

N

Type a value in the Angle box.

9]

Type values in any of the following boxes:

* H — lets you specify the horizontal coordinates around
which you want to rotate the object

® V — lets you specify the vertical coordinates around which
you want to rotate the object

Click Apply.

=]

= You can also rotate a selected object by dragging a
&\ rotation handle clockwise or counterclockwise.

To mirroOR AN objecT
1 Select an object.
2 Click Window » Dockers » Transformations » Scale.
3 Click one of the following buttons:
* Horizontal mirror — lets you flip the object left to right

® Vertical mirror — lets you flip the object top to bottom

5 Enable the check box that corresponds to the anchor point
you want to set.

6 Click Apply.

2 You can also mirror a selected object by holding
&\  down CTRL and dragging a selection handle to the
opposite side of the object.

Changing The order of objects

You can change the stacking order of objects on a layer by
sending objects to the front or back, or behind or in front of
other objects. You can also position objects precisely in the
stacking order, as well as reverse the stacking order of multiple
objects.
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The stacking order determines the depth at which objects are positioned. In
this example, objects have been stacked to create a border, background, and
foreground.

To change The order of an objecr
1 Select an object.
2 Click Arrange » Order, and click one of the following:

* To front — moves the selected object to the front of all
other objects

* To back — moves the selected object behind all other
objects

* Forward one — moves the selected object forward one
position

* Back one — moves the selected object behind one
position

* In front of — moves the selected object in front of a
specific object

* Behind — moves the selected object behind a specific
object

Grouping aAnd combining objects
You can group and combine objects in CoreDRAW.

When you group two or more objects, they are treated as a single
unit. This helps prevent accidental changes to the relationships
between objects and lets you apply the same formatting,
properties, and other changes to all the objects at the same time.
CorelDRAW also lets you group grouped objects to create nested
groups.

Single objects retain their individual attributes when they are grouped.
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If you want to edit an object in a group individually, you can
ungroup the objects. You can also add and delete objects to and
from a group.

Combining two or more objects creates a single object with
common fill and outline attributes. You can combine rectangles,
ellipses, polygons, stars, spirals, graphs, or text. CorelDRAW
converts these objects to a single curve object. If you need to
modify the attributes of an object that is combined, you can
break the combined object apart.

AT _} ) ?:*-;
|_|",_]| ]:l

2l I

Combined objects share attributes and change appearance.

To group objects
1 Select the objects.
2 Click Arrange » Group.

You can create a nested group, by selecting two or more
groups of objects and clicking Arrange » Group.

= You can select objects from different layers and group
& S them; however, once grouped, the objects will reside
on the same layer.

You can also group objects by clicking Window »
Dockers » Object manager, and dragging an object’s
name in the Object manager Docker window over the
name of another object.

To ungroup objects
1 Select a grouped object or all grouped objects.
2 Click Arrange » Ungroup.

< You can also ungroup objects by clicking the Ungroup

\\ all button on the property bar.

Aligning, disTributing, ANd snapping
objecrs

CorelDRAW lets you align and distribute objects in a drawing.
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Aligning objects lines up precisely any series of objects. You can,
for example, align a series of objects horizontally and vertically.

Objects before and after alignment.

You can distribute objects at equal intervals in a specified area.

Snapping links one object to another. For example, a callout
snapped to an object will move with that object.

To align A series of objecrs

1 Select the objects.

2 Click Arrange » Align and Distribute.
3 Click the Align tab.

Enable the check boxes that correspond to the horizontal and
vertical alignment you want.

If you want to align objects vertically, enable the Left, Center,
or Right check box.

In the Align area, enable one of the following check boxes:
* Edge of page — aligns objects with the edge of the page
* Center of page — centers objects on the page

* Align to grid — aligns objects with the nearest grid line

2 You can also align objects by selecting them and
&7\ clicking the Align button on the property bar.

To distribute objects

1

2
3
4

Select the objects.

Click Arrange » Align and Distribute.

Click the Distribute tab.

Enable the check boxes that correspond to the distribution
you want.

In the Distribute area, enable a check box that corresponds to
the distribution area.

@: If you want to preview the distributed object, click
SO\ the Preview button.
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Cloning objecrs

When you clone an object, you create a copy of an object that is
linked to the original. Any changes to the original (or master)
object will be reflected automatically in the clone (copy). You can,
however, change the clone independently. If you want, you can
remove those changes by reverting back to the original.

To clone an objecr
1 Select an object.
2 Click Edit » Clone.

You can also

Right-click the clone, and click Select
master.

Specify a clone’s master object

Right-click the master and click Select
clones.

Specify a master’s clone object

To ReVerT 10 A clone’s masTER
1 Right-click a modified clone, and click Revert to master.
2 Enable any of the following check boxes:
® (Clone fill — restores the master fill attributes
® C(lone outline — restores the master outline attributes

® (Clone path shape — restores the master shape attributes

* (lone transformations — restores the master shape and
size attributes

* Clone bitmap color mask — restores the master color
settings

N If you change a clone’s attribute, that attribute will be
no longer linked with the master.

You can only restore attributes that have changed
from the master object’s properties.

Blending objects

CorelDRAW lets you create blends, such as straight-line blends,
blends along a path, and compound blends.

A straight-line blend shows a progression in shape and size from
one object to another. The outline and fill colors of the
intermediate objects progress along a straight-line path across
the color spectrum. The outlines of intermediate objects show a
gradual progression in different thicknesses and shape.
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g, 7
A straight line blend.

After you create a blend, you can copy or clone its settings to
other objects. When you copy a blend, the object takes on all the
blend-related settings, except for their outline and fill attributes.
When you clone a blend, changes you make to the original blend
(also called the master) are applied to the clone.

A blend along a path.

You can fit objects along part or all of a path’s shape, and you can
add one or more objects to a blend to create a compound blend.

A compound blend using four objects and three single blends.
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You can change the appearance of a blend by adjusting the To blend objects
number and spacing of its intermediate objects, and changing the
color progression, the nodes the blends map to, the blend’s path,
and the start and end objects.

To Do the following

Blend along a straight Open the Interactive tools flyout
line Fd-FEEL T | , and click

the Interactive blend tool &F| . Select the
r first object and drag over the second object.
If you want to reset the blend, press ESC as
you drag.
o

Blend an object along a  Open the Interactive tools flyout, and click
freehand path or a the Interactive blend tool. Select the first
shape object. Hold down ALT, and drag to draw a
line to the second object.
The blend on the right was created by mapping the start and end nodes of the ) )
two objects on the left. Fit a blend to a path Select a blend. Hold down the right mouse
button, drag the blend over a curved object,
and click Fit blend to path.

You can also split and remove a blend. Stretch the blend over  Select a blend. Hold down the right mouse
an entire path button, drag the blend over a curved object,
and click Fit blend to path. Click the
Miscellaneous blend options button on the
property bar, and enable the Blend along full
path check box.

Create a compound Using the Interactive blend tool, drag an
blend object to the start or end object of a blend.
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To copy or clone a blend
1 Select the two objects you want to blend.
2 Click Effects, and one of the following:

* Copy effect » Blend from

* (Clone effect » Blend from

3 Select the blend whose attributes you want to copy or clone.

ap,, You can’t copy or clone a compound blend.

To set The distance for inTERmEediaTE objects in A

blend fitted 1o A path

1 Select a blend.

2 Click the Use steps or fixed spacing for blend button on the
property bar.

3 Type avalue in the Number of steps or offset between blend
shapes box on the property bar.

4 Press ENTER.

2 You can set color acceleration rates by clicking the
&\ Object and color acceleration button and moving the
corresponding slider.

To ser The color proGression for inTermediaTe
objects in A blend

1 Select a blend.
2 On the property bar, click one of the following buttons:
* Direct blend
* Clockwise blend
* Counterclockwise blend
%@ You can’t create color progressions using blended

objects filled with bitmapped images, texture, two,
and full-color patterns, and PostScript fills.

@: You can set color acceleration rates by clicking the
&\  Object and color acceleration button and moving the
corresponding sliders.

To map the nodes of a blend
1 Select a blend.

2 Click the Miscellaneous blend options button on the property
bar.

Click the Map nodes button.
Click a node on the start object and on the end object.
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To work with the start or end objects in A blend

To

Do the following

Select the start or end object

Change the start or end object of
a blend

Fuse the start or end object in a
split or compound blend

Select a blend, click the Start and
end object properties button on
the property bar, and click Show
start, or Show end.

Select a blend, click the Start and
end object properties button on
the property bar, and click New
start, or New end. Click an object
you want to use as the start or
end of the blend.

Hold down CTRL, and click the
start or end object of the blend.
Click the Miscellaneous options
button on the property bar. If you
have selected the start object,
click the Fuse start button. If you
have selected the end object, click
the Fuse end button.

2 You can reverse the direction of the blend by clicking
Arrange » Order P Reverse order.

U

To change the blend path

1 Select a blend.

2 Click the Path properties button on the property bar, and

click New path.

3 Click the path you want to use for the blend.

You can also

Detach a blend from a selected
path

To change the path of a selected
freehand blend

Click the Path properties button
on the property bar, and click
Detach from path.

Click the blend path with the

Shape tool #& |, and drag a
path’s node.

ES

=

To select the blend path, click the Path properties
button and click Show path.

You can select and detach a component of a
compound blend by holding down CTRL while you
select the component.
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To split a blend

1 Select a blend.

2 Click the Miscellaneous options button on the property bar.

3 Click the Split button.

4 Click the intermediate object at which you want to split the
blend.

§ . YOu can't split a blend at the intermediate object that
é/ is immediately adjacent to the start or end object.

To remove A blend
1 Select a blend.
2 Click Effects » Clear blend.

= You can also remove a selected blend by clicking the
&\ Clear blend button on the property bar.

Spraying objects along A Line

CorelDRAW lets you spray a series of objects in a line. Besides
graphic and text objects, you can import bitmapped images to
spray along a line. However, the more complex the object you
spray, the more system resources you use, the longer CorelDRAW
takes to produce the line, and the larger your file size.

You can control how a sprayed line appears by adjusting the
spacing between objects so they are closer or farther apart from

each other. You can also vary the order of objects in the line. For
example, if you are spraying a series of objects that includes a
star, a triangle, and a square, you can change the spray order so
that the square appears first, followed by the triangle and then
the star. CoreIDRAW also lets you shift the position of objects in
a sprayed line by rotating them along the path or offsetting them
in one of four different directions: alternating, left, random, or
right. For instance, you can choose a left offset direction to align
the objects you spray to the left of the path.

You can also create a spraylist.

To spray a line

1 Open the Curve flyout & # &i* '-l , and click the
Artistic media tool.
Click the Sprayer button on the property bar.

3 Choose a spraylist from the Spraylist file list box.

If the spraylist you want is not listed, click the Browse button
on the property bar to select the folder in which the file is
located.

Position the cursor where you want the line to start.

5 Drag to draw the line.
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You can also

Adjust the number of objects
sprayed at each spacing point

Adjust the spacing between dabs

Set the spray order

Adjust the size of spray objects

Adjust the size of spray objects
along the path of the line (for
example, increasing the value
causes objects to become larger in
size as you move along the path).

Reset a spraylist to its saved
settings

Type a number in the top box of
the Dabs/Spacing of objects to be
sprayed box on the property bar.

Type a number in the bottom box
of the Dabs/Spacing of objects to
be sprayed box on the property
bar.

Choose a spray order from the
Choice of spray order list box on
the property bar.

Type a number in the top box of
the Size of objects to be sprayed
box on the property bar.

Type a number in the bottom box
of the Size of objects to be
sprayed box on the property bar.

Click the Reset values button on
the property bar.

Spraylists that have more complex objects use more
system resources. CoreDRAW takes longer to

produce lines using complex objects, and these
objects will increase your file size.

From here
For more information about...

Copying, duplicating and deleting
objects

Moving and positioning objects
Sizing and scaling objects
Skewing and stretching objects
Rotating and mirroring objects
Changing the order of objects
Grouping and combining objects

Aligning, distributing and
snapping objects

Cloning objects

In the online Help Index, type...

objects, copying

objects, positioning

sizing objects

objects, skewing and stretching
objects, rotating and mirroring
objects, changing the order of
objects, grouping and combining

objects, aligning

objects, cloning
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For more information about...
Blending objects
Spraying objects

Drawing flow and dimension lines

In the online Help Index, type...
blends, creating
objects, spraying

flow lines, drawing
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Shaping objecrts

CorelDRAW lets you shape objects in various ways.

In this section, you'll learn about
e applying distortion effects

e using envelopes

e working with curve objects

e creating PowerClip0J objects

Applying distorTion effects

You can apply three types of distortion effects to shape objects.

Distortion effect  Description

Push and pull Lets you push the edges of an object in or pull the
edges of an object out.

Zipper Lets you apply a saw tooth effect to the edges of
the object. You can adjust the amplitude and
frequency of the effect.

Twister Lets you rotate an object to create a swirl effect.
You can choose the direction of the swirl, as well
as the origin, degree, and amount of rotation.

Shaping objects
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Original drawing before any of the four distortion effects are applied to it.

1. Pull distortion 2. Push distortion 3. Twister distortion 4. Zipper distortion

After you distort an object, you can change the effect by altering
the center of distortion. This point is a fixed location, identified
by a diamond-shaped handle, around which a distortion appears.
It is similar to a mathematical compass, where the pencil moves
around a stationary point. You can place the center of distortion
anywhere in the drawing window, or choose to center it in the
middle of an object so that the distortion is distributed evenly
and the shape of the object changes in relation to its center.

You can create an even more dramatic effect by applying a new
distortion to an already distorted object. You don’t lose the effect
of the original distortion if, for example, you apply a zipper
distortion on top of a twister distortion.

To disTorT AN object

1 Open the Interactive tool flyout =& B =4 @5 | , and click
the Interactive distortion tool.

2 On the property bar, click one of the following buttons and
specify the settings you want:

* Push and pull distortion &

* Zipper distortion :I

* Twister distortion &

Click where you want to place the center of distortion.

s~ W

Drag until the object is the shape you want.

You can also

Drag the diamond-shaped position
handle to a new location.

Change the center of distortion

Move the slider on the center of
the distortion handle.

Adjust the number of points on a
zipper distortion
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%”}A You can reapply the effects to distorted objects.

@‘ You can center a distortion by clicking the Center
distortion button on the property bar.

To rRemove A disTORTION
1 Select a distorted object.
2 Click Effects » Clear distortion.

%’f/fb Removing a distortion this way clears the most recent
distortion you've applied.

You can also remove a distortion from a selected
object by clicking the Clear distortion button on the
property bar.

-
I£S

To copy A disTorTion

1 Select the object to which you want to copy a distortion.
2 Click Effects » Copy effect » Distortion from.

3 Click a distorted object.

Shaping objects using envelopes

CorelDRAW lets you shape objects, including lines, artistic text,
and paragraph text frames by applying envelopes to them.

Envelopes are made of multiple nodes that you can move to
shape the envelope, and as a result, change the shape of the
object. You can apply a basic envelope that conforms to the
shape of an object or a preset envelope. After you apply an
envelope, you can edit it, or add a new envelope to continue
changing the object’s shape. CorelDRAW also lets you copy and
remove envelopes.

You can edit an envelope by adding and positioning its nodes.
Adding nodes gives you more control over the shape of the
object contained in the envelope. CoreIDRAW also lets you delete
nodes, move multiple nodes simultaneously, change nodes from
one type to another, and change a segment of an envelope to a
line or curve. For more information about the different types of
nodes, see “Working with curve objects” on page 68.

You can also change the mapping mode of an envelope to specify
how the object fits to the envelope. For example, you can stretch
an object to fit the basic dimensions of the envelope, and then
apply the horizontal mapping mode to compress it horizontally
so that it fits the shape of the envelope.

To apply an envelope

1 Select an object.

2 Open the Interactive tools flyout & B &4 & ¢ | ,and

click the Interactive envelope tool.
3 On the property bar, click one of the following buttons:

Shaping objects
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* Envelope straight line mode ] — creates envelopes
based on straight lines, adding perspective to objects

* Envelope single arc mode gl — creates envelopes with
an arc shape on one side, giving objects a concave or
convex appearance

* Envelope double arc mode 1| — creates envelopes with
an S shape on one or more sides

* Envelope unconstrained mode & | — creates freeform
envelopes, that let you change the properties of the
nodes, and add and delete the nodes

4 Drag the nodes to shape the envelope.

If you want to reset the envelope, press ESC before releasing
the mouse.

You can also

Apply a preset envelope Click the Add preset picker on the
property bar and click an envelope

shape.

Apply an envelope to an
object with an envelope

Click the Add new envelope button on
the property bar, and drag the nodes to
change the shape of the envelope.

Remove an envelope Click Effects » Clear envelope.

@‘ You can prevent the object’s straight lines from being
converted to curves by enabling the Keep lines
button on the property bar.

Working with curve objects

CorelDRAW lets you shape objects by manipulating their nodes
and segments. An object’s nodes are the tiny squares that display
at regular intervals along a selected object’s outline. The line
between two adjacent nodes is a called a segment. Moving an
object’s segments lets you make coarse adjustments to the
object’s shape, while changing the position of its nodes lets you
fine-tune the shape of the object.

By converting objects to curves, you can shape them by adding,
removing, positioning, as well as aligning and transforming their
nodes. With the exception of spirals and freehand and bezier
lines, most objects you add to a drawing are not curve objects,
therefore, if you want greater control in changing the shape of a
noncurve object, you must convert that object to a curve object.

Before you can manipulate an object’s nodes, you must select
them. When working with curve objects you can select
individual, multiple, or all of the object’s nodes. Selecting
multiple nodes lets you shape different parts of an object
simultaneously.

68

CorelDRAW User Guide: Chaprer 6



When you add nodes, you increase the number of segments, and,
therefore, the amount of control you have over the shape of the
object. You can also remove nodes to simplify an object’s shape.

When you create an object, it is made up of one path. If you are
working on an open object, such as a freehand line, you can join
its end nodes. When you join end nodes, they are pulled together
to create a closed object. You can break this path apart to create
subpaths, which have end nodes that you can join to create a link
between the subpaths. For information about breaking paths
apart see “Splitting and erasing portions of objects” in the online
Help.

The components of a curve: 1. node 2. segment 3. path and subpath
4. control handle

You can change the nodes of a curve object to one of three types:
cusp, smooth, or symmetrical. Cusp nodes make the node’s
intersecting line take on the shape of a corner or point when you
adjust the position of the node’s control points. Smooth nodes
make the node’s intersecting line take on the shape of a curve.
Each control point can be shortened or lengthened
independently, giving you smaller or larger angles to work with.
Symmetrical nodes make the node’s intersecting line take on the
shape of a curve as well as intersect the node at exactly the same
angle.

After you create a curve object, you can align its nodes. For
example, you can line nodes up horizontally and vertically.

You can also shape objects by stretching, scaling, rotating, and
skewing their nodes. For example, you can scale the corner
nodes of a curve object to enlarge the curve object
proportionally. Stretching, on the other hand, elongates a curve
object so that its shape is distorted. Rotating the nodes of a
curve object allows you to move the object in a counterclockwise
or clockwise direction. You can also skew nodes to shape a curve
object.

CorelDRAW also lets you shape objects by changing the shape of
their segments. You can make a curve segment straight or a
straight segment curved. You can also change the direction of a
segment by reversing the position of its start and end nodes. The

Shaping objects
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effect is transparent only when the ends of a segment are
different.

To convert objects 10 curve objects
1 Select the object.
2 Click Arrange » Convert to curves.

'&”}A You can convert artistic text to curves so that you can
shape individual characters.

@: You can also convert an object to a curve object by

< \\ . . s

s selecting the object and clicking the Convert to
curves button on the property bar.

To select A node

1 Open the Shape edit flyout & dq:l'!»l , and click the Shape
tool & |.

2 Select a curve object.

3 Click a node.

You can also

Select multiple nodes

Select all nodes Click Edit » Select all » Nodes.

Hold down SHIFT, and click each node.

Hold down SHIFT, and click a selected
node.

Hold down SHIFT, and click each
selected node.

Deselect a node
Deselect multiple nodes

Deselect all nodes Click a blank space in the drawing

window.

< You can select the first node in a curve object by
§ V' pressing HOME, or the last node by pressing END.

To add or RemoOvVE A Node

To Do the following
Add a node

Open the Shape edit flyout, click the

Shape tool, select a curve object, and
double-click where you want to add a
node.

Open the Shape edit flyout, click the
Shape tool, select a curve object, and
double-click a node.

Delete a node

To join The end Nodes of A single subpath

1 Open the Shape edit flyout, and click the Shape tool.
2 Hold down SHIFT, and click the end nodes.

3 Click the Auto-close curve button on the property bar.
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Creating PowerClip objects

CorelDRAW lets you place vector objects and bitmapped images,
such as photos, inside other objects, or containers. A container
can be any object, for example artistic text or a rectangle. When
you place an object into a container that is larger than the
container, the object, called the content, is cropped to fit the
form of the container. This creates a PowerClip object.

The picture on the left shows two separate objects before the PowerClip object
is created. The picture on the right shows a PowerClip object created from the
two objects. The bitmapped image becomes the content object and the artistic
text becomes its container.

You can create more complex PowerClip objects by placing one
PowerClip object inside another PowerClip object to produce a
nested PowerClip object. You can also copy the contents of one
PowerClip object to another PowerClip object.

After you create a PowerClip object you can modify the content
and the container. For example, you can lock the content, so that
when you move the container, the content moves with it.
CorelDRAW also lets you extract the content from a PowerClip
object, so that you can delete the content or modify it without
affecting the container.

To create A PowerClip object

1 Select an object.

2 Click Effects » PowerClip » Place inside container.
3 Click the object you want to use as the container.

If you want to create a nested PowerClip object, drag the
PowerClip object inside a container.

@\: You can also create a PowerClip object by holding

&\ down the right mouse button and dragging an object
onto a container, releasing the mouse button, and
clicking PowerClip inside.

To copy The content of A PowerClip objecr
1 Select an object.

2 Click Effects » Copy effect » PowerClip from.

3 Click a PowerClip object.

Shaping objects
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To edit The contTent of A PowerClip object

1 Select a PowerClip object.

2 Click Effects » PowerClip » Edit contents.
3 Edit the contents of the PowerClip object.
4 Click Effects » PowerClip » Finish editing this level.

%@ While you edit, the container displays in Wireframe
mode and cannot be selected.

From here

For more information about...

In the online Help Index,

type...

Editing envelopes
Editing the nodes of curve objects

Splitting and erasing portions of
objects

Welding, trimming, and intersecting
objects

Editing PowerClip objects

envelopes, editing
nodes, manipulating

splitting

trimming

PowerClip objects
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CREATING Web-enabled objecrts

CorelDRAW lets you create Web-enabled objects for optimum
viewing in browsers. You can convert text to a Web compatible
format so that it can be edited in a browser, add Web form
objects such as radio buttons and check boxes, and create
interactive rollovers from CorelDRAW objects.

In this section, you'll learn about
e creating Web-compatible text
e using preset Internet objects
e creating rollovers

* working with bookmarks and hyperlinks

Creating Web-comparible Texr

When you convert paragraph text to Web-compatible text, you
can edit the text of your published document in an HTML
browser. You can change text font characteristics, including the
font type, size, and style. The Web-compatible text sizes,
numbered 1 through 7, correspond to particular point sizes
between the 10-point and 48-point range. For more information
about formatting text, see “Changing the appearance of text” on
page 134

The default Web font style is used automatically, unless you
override it with another font. If you choose to override it, the
default font is used when visitors to your Web site don’t have the
same font installed on their computers. The bold, italic, and
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underline text styles, are also available. You can apply uniform
fills, but not outlines, to Web-compatible text.

Any non-Web-compatible text in your drawing is converted to
bitmapped images when you publish your document to the
World Wide Web as HTML.

To make Text Web-comparible

To Do the following

Select the paragraph text. Click
Text » Make text web compatible.

Change paragraph text to
Web-compatible text

Make new text Web-compatible Click Tools » Options. In the list of
categories, double-click
Workspace, Text, and click
Paragraph. Enable the Make all
new paragraph text frames web
compatible check box.

y_“,, Ensure that the Web-compatible text does not
5/ intersect or overlap other Internet objects or extend
beyond the boundaries of the drawing page;

otherwise the text will be converted to a bitmapped
image, and it will lose its Internet properties.

Artistic text cannot be converted to Web-compatible
text and is always treated as a bitmapped image.
However, you can convert it to paragraph text and
then make it Web compatible.

Using preseT INTERNET objects

CorelDRAW provides you with a set of Internet objects, such as
radio buttons, Java applets, text edit boxes, pop-up menus, and
check boxes to use when designing an HTML page. You can
customize Internet objects by adjusting their parameters.

If your document has form-related Internet objects, you need a
CGl script address to enable these Internet objects to be
automated once a document is published to the World Wide Web
as an HTML file. Except for Java applets and embedded files, the
Internet objects provided by CoreDRAW are form-related.

After you create a preset Internet object, you can save and
optimize the object to a Web-compatible format.
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To add or customize AN INTERNET objecT

To

Do the following

Add an Internet object

Customize an Internet
object

Add a CGI Script
address to an Internet
object

Click Edit P Insert Internet object, and click
the object you want. Click where you want to
place the Internet object.

Right-click an Internet object, and click
Properties. In the Object properties Docker
window, click the Internet object’s tab and
specify the attributes you want to add.

Deselect any objects. Click Edit » Properties.
Click the Form tab, and type the CGI Script
address in the URL of CGI script box. Choose
an HTML equivalent method from the
Method list box and a frame type from the
Target list box.

K

All Internet objects, except for Java applets and

embedded files, require a CGI Script address to
function properly after you publish a drawing to the
World Wide Web.

To save and oprimize AN imaGe To A Web-comparible
formaT

1 Click File » Publish to the Web » Web image optimizer.

2 In each preview window, choose a file format from the list
box.

3 Choose a filter type from the list box.
Click the Edit filter to customize the filter options.

5 In the export window of the file format you want to export to,
choose the options you want.

You can also Do the following

Preview the file download Choose a speed from the Modem speed list
time for a particular box.

modem speed

Save a custom filter Click Add.

Delete a custom filter Click Delete.

Pan to another section of  Click the Hand tool and drag in the

the image preview window.
Zoom in the preview Choose a magnification from the Zoom
window level list box.

Creating Web-enabled objects
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Creating rollovers

You can create rollovers using objects. Rollovers differ from other
Web objects because they change in appearance when they are
clicked or when a cursor is passed over them. When you create a
rollover, you design three separate objects, each of which
represents a rollover state. These three states are grouped by a
single rollover:

¢ Normal — the default state of a button when no mouse
activity is associated with the button

e Over — the state of a button when the cursor passes over it

¢ Down — the state of a clicked button

Rollovers showing Normal (left), Over (center), and Down (right) states.

Before you publish an object to the Internet, you must save it to
a Web-compatible file format; for example, use the GIF, JPEG or
PNG format.

For information about creating and editing objects such as
rollovers, see “Working with objects” on page 43.

To create A rollover objecr
1 Select an object.
2 Click Effects P Rollover » Create rollover.

%”? You cannot create a rollover from a clone.

To edit A rollover objecr

1 Select an object.

2 Click Effects P Rollover » Edit rollover.

3 Specify attributes of the object.

4 Click Effects » Rollover P Finish editing rollover.

You cannot close a drawing in which you are editing a rollover.
You must finishing editing the button first.

You can also edit a rollover object by clicking it and holding
down CTRL. When you are finished editing, hold down CTRL and
click the Web object button.

To view The rollover states
1 Click Window? Dockers » Object manager.

2 Expand any of the rollover objects in the window.
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2 You can preview a rollover object’s states in the
&\ drawing page by clicking View » Enable rollovers.

Working with bookmarks and hyperlinks

CorelDRAW lets you create bookmarks and hyperlinks in your
Web document. You can apply these to rollovers, bitmapped
images, and other objects.

Bookmarks

To create an internal link in an HTML file, you can assign a
bookmark to text or to an object. You can then assign a Uniform
Resource Locator (URL) to an object that links to the bookmark.
The object containing a URL has a hotspot, an area that activates
a hyperlink when clicked in a browser.

Hyperlinks

Hyperlinks connect to any object in a document that is assigned a
bookmark, or to any document published to the World Wide
Web by using that document’s URL.

CorelDRAW applies a crosshatch pattern to an object containing
a hyperlink. You can change the color of the crosshatch pattern
as well as its background fill. You can also set a hotspot that
follows the outline of the object, limits itself to the same areas as
the object’s fill, or fills the object’s bounding box.

After you create hyperlinks, you can display and verify them.

To assign A bookmark

1
2
3
4

Right-click an object and click Properties.

Click Internet tab.

Choose Bookmark name from the Behavior list box.
Type the name of the bookmark.

To assign A hyperlink 1o A bookmark or external
Web site

1

2
3
4

Right-click an object, and click Properties.
Click Internet tab.

Choose URL name from the Behavior list box.
Type a URL address.

You can also

Specify what frame will display Choose a target frame from the
when the button is clicked Target list box.

Add text for the browser status
line

text box.

Type the text in the Alt comments

Creating Web-enabled objects
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You can also

Define the hotspot area Choose Object shape or Bounding
box of object from the Define
hotspot using list box.

@: You can also create a hyperlink using the Internet
&\ toolbar.

You can rename a bookmark and create a hyperlinked
bookmarked object from a document object by using
the Internet bookmark manager Docker window.

URLs to external Web sites must contain the http://
prefix. Other supported protocols include mailto:,
ftp:, and file:.

2y

To assign crossharch and background hotspor
colors

1 Click Window » Dockers P Properties.

2 Click the Internet tab.

3 Open the Cross-hatch color picker, and click a color.
4 Open the Background color picker, and click a color.

S\ If you choose a hyperlinked object first and then
K/ change the crosshatch and background hotspot

colors, the change applies to the selected object only.
If you change the hotspot colors with no object
selected, the default colors are changed for this
drawing and for future sessions of CoreIDRAW.

To display hyperlinked objecrts
e On the Internet toolbar, enable the Show hotspots button.

All objects to which you've assigned URLs display in the
crosshatch and background hotspot colors.

To verify links in A Web document

1 Click Window » Dockers » Link manager.

2 In the list, verify that all URL links display a green check mark.
3 Click the Refresh button to verify any broken links.

@: If you want to test a link by opening an URL in a Web
s\ browser, right-click the object, and click Jump to
hyperlink in browser.
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Filling objecrts

You can add colored, patterned, textured, and other fills to the
inside of objects. After you apply a fill, you can customize it and

set it as a default, so that each object you draw has the same fill.

In this section, you'll learn about
e applying uniform fills

e applying fountain fills

e applying pattern fills

e applying texture fills

* working with fills

Applying uniform Fills

CorelDRAW lets you apply a uniform fill to objects. Uniform fills
are solid colors you can choose or create using color models and
color palettes. For information about creating colors, see
“Working with color” on page 91.

To apply a uniform Fill
1 Select an object.

2 Open the Interactive fill flyout ‘hil , and click
the Interactive fill tool.

3 Choose Uniform fill from the Fill type list box on the property
bar.

4 Specify the settings you want on the property bar.
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@: You can also fill a selected object by clicking a color
&\ on the color palette.

You can mix colors in a uniform fill by selecting an
object, pressing CTRL, and clicking a color on the
color palette.

Applying founTtain Fills

A fountain fill is a smooth progression of two or more colors that
adds depth to an object. There are four types of fountain fills:
linear, radial, conical, and square. A linear fountain fill flows in a
straight line across the object. A conical fountain fill circles from
the center of the object, a radial fountain fill radiates from the
center of the object, and a square fountain fill is dispersed in
concentric squares from the center of the object.

There are four types of fountain fills: 1. Linear 2. Radial 3. Conical
4. Square

You can apply preset fountain fills, two-color fountain fills, and
custom fountain fills to objects. Custom fountain fills can contain
two or more colors, which you can position anywhere in the fill's
progression. After you create a custom fountain fill, you can save
it as a preset.

When you apply a fountain fill, you can specify attributes for the
fill type you choose; for example, the direction of a fill’s color
blend, as well as the fill's angle, center point, midpoint, and edge
pad. You can also adjust the print and display quality of the
fountain fill by specifying the number of fountain steps. By
default, the fountain step setting is locked so that the print
quality of the fountain fill is determined by the value specified in
the print settings and the display quality is determined by the
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default value you can set. However, you can unlock the fountain
steps setting when you apply a fountain fill and specify a value
that applies to both the print and view quality of the fill. For
information about setting fountain fill steps for printing, see
“Fine-tuning print jobs” in the online Help.

To apply A preser fountain Fill
1 Select an object.

2 Open the Fill flyout @® @#®E = =| and click the
Fountain fill dialog button.

3 Choose a fountain fill from the Type list box.
4 Choose a fill from the Presets list box.

If you want to change the fill’s attributes, specify the settings
you want.

To apply a founTain Fill
1 Select an object.

2 Open the Interactive fill flyout ‘hﬁl , and click
the Interactive fill tool.

3 Choose a fountain fill from the Fill Type list box on the
property bar.

4 Open the Fill dropdown picker, and click a color.
5 Open the Last fill picker, and click a color.

If you want to change the fill's attributes, specify the settings
you want.

To apply A custom founTain Fill
1 Select an object.
2 Open the Fill flyout d@F@EER= = | , and click the Fountain

Choose a fountain fill from the Type list box.

s~ W

Enable the Custom option.

5 Click the box at one end of the area just above the color
band, and click a color on the color palette.

6 Click the box at the opposite end of the area just above the

color band, and click a color.

N

Specify the attributes you want.

Filling objecrs
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You can also

Double-click in between the two ends
of the area just above the color band,
and click a color on the color palette.

Add an intermediate color

Change a color Click the pointer just above the color,

and click a color on the color palette.

Delete a color Double-click the pointer just above

the color you want to delete.

Change the position of a color Drag the pointer just above the color

to a new location.

Save the fill as a preset Click the Add button and type a name

in the Presets box.

@\: You can also create a custom fountain fill by dragging
& N colors from the color palette in the drawing window
onto the object’s interactive vector handles.

Applying patTern Fills

You can fill objects with two-color, full-color, or bitmapped
pattern fills. A two-color pattern is composed of only the two
colors that you choose. A full-color pattern is a more complex
vector graphic that can be composed of lines and fills. A
bitmapped pattern is a bitmapped image whose complexity is
determined by its size, image resolution, and bit depth.

You can fill an object with a repeating pattern, set the pattern’s
foreground and background, and mix the colors in the pattern.
CorelDRAW provides preset pattern fills that you can apply to
objects; however, you can also create your own pattern fills. For
example, you can create pattern fills from objects that you draw
or graphics that you import.

You can create a pattern using the Bitmap Pattern Editor, or
import your own 1-bit bitmapped image. You can also remove a
pattern fill from the list of pattern fills.

You can change the tile size of pattern fills. Decreasing the size of
a pattern tile increases the density of the fill. You can also specify
exactly where these fills begin by setting the tile origin.
CorelDRAW also lets you offset tiles in a fill. Adjusting the
horizontal or vertical position of the first pattern, relative to the
top of the object, affects the rest of the fill. You can preview any
changes you make to the offset.

You can rotate, skew, adjust the tile size, and change the center
of the pattern to create a custom fill. You can also adjust the
pattern fill using the on-screen fill tiling vector.

You can choose how the pattern fill appears by specifying
whether to mirror the fill so that alternating tiles are the
reflections of one another. If you want a pattern fill to change
according to actions you perform on the filled object, you can
specify that you want it to transform with the object. For
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example, if you enlarge an object filled with a pattern that
transforms, the pattern becomes larger instead of increasing the
number of tiles.

To apply A Two-color partern Fill
1 Select an object.

2 Open the Interactive fill flyout = #l , and click the
Interactive fill tool.

3 Choose Two color pattern from the Fill type list box on the

property bar. You can apply a pattern of two colors to an entire object or only part of an
4 Open the Fill dropdown picker, and click a pattern. gl;jtig.n.'fhe butterfly’s wings are filled with a blue and green two-color
5 Open the Front color picker, and click a color.
Open the Back color picker, and click a color. To apply a Full-color or bitmap patrern Fill
2 You can also mix colors in a two-color pattern fill by 1 Select an object.
s\ pressing CTRL and clicking a color on the color 2 Open the Interactive fill flyout ‘*a#l , and click the Interactive
palette. fill tool #. .
3 Choose one of the following from the Fill type list box on the
property bar:

® Full-color pattern

* Bitmap pattern
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4 Open the Fill dropdown picker and click a pattern.

A full-color pattern allows you to fill objects with a pattern made up of many
different colors.

A bitmap pattern fill allows you to use a bitmapped image as a pattern fill.

Applying Texture Fills

A texture fill is a random, fractally generated fill that you can use
to give your objects a natural appearance. Texture fills increase
the size of a file and the time it takes to print. Therefore, you
may want to use these fills sparingly, especially with larger
objects.

CorelDRAW provides preset textures, and each texture has a set
of options that you can change. You can use colors from any color
model or palette to customize texture fills. Since texture fills can
only hold RGB colors, however, this can cause a color shift when
you display or print the files. For information about color models,
see “Understanding color models” on page 97.

You can change the tile size of texture fills. Decreasing the size of
a texture tile increases the density of the fill. You can also specify
exactly where the fill begins by setting the tile origin. CoreIDRAW
also lets you offset tiles in a fill. Adjusting the horizontal or
vertical position of the first texture, relative to the top of the
object, affects the rest of the fill. You can preview any changes
you make to the offset.

You can rotate, skew, adjust the tile size, and change the center
of the texture to create a custom fill. You can also adjust the
texture fill using the on-screen fill tiling vector.

You can choose how the texture fill appears by specifying
whether to mirror the fill so that alternating tiles are the
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reflections of one another. If you want a texture fill to change
according to the actions you perform on the filled object, you can
specify that you want it to transform with the object. For
example, if you enlarge an object filled with a texture that
transforms, the texture becomes larger instead of increasing the
number of tiles.

To apply a Texture Fill
1 Select an object.

2 Open the Fill flyout @® EEEx =
Texture fill dialog button.

, and click the

3 Choose a texture library from the Texture library list box.

4 Choose a texture from the Texture list box.

You can also

Create a custom texture fill

Change the size of texture tiles

Set the tile origin of a texture fill

Offset the tile origin of a texture
fill

Rotate a texture fill

Skew a texture fill

Mirror a texture fill

Specify the settings you want in
the Style name area.

Click Tiling, and type values in the
Width and Height boxes.

Type values in the X and Y boxes
in the Origin area.

Enable the Row or Column option,
and type an amount of offset in
the % of tile size box.

Type a value in the Rotate box.

Type a value in the Skew box.

Enable the Mirror fill check box.

'\//0“

You can modify the texture you choose from the

texture library and save it to another library, but you
cannot save textures to or overwrite textures in the

texture library.

Filling objecrs
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@, You can save a custom texture fill by clicking Add and ® Artistic text — applies the default fill color to artistic text
-
&\ typing a name for the fill in the Texture library list you add

box. ® Paragraph text — applies the default fill color to

You can also change the size of texture tiles by paragraph text you add

selecting an object using the Interactive fill tool .|,
and enabling the Small tile for pattern, Medium tile

for pattern, or Large tile for pattern button on the
property bar. 2 Open the Fill flyout @® @ ® P =| and click the No fill

button §

To remove a Fill
Select an object.

WORkINq with fills < You can also remove a fill from a selected object by
There are a number of actions that are common to all types of &\ dlicking the No color swatch on the color palette.
fills. You can choose a default fill so that every object you add to

a drawing has the same fill. You can also remove any fill that From here
you've applied, copy it to another object, or use it to fill the area
surrounded by an open curve. For more information about... In the online Help Index, type...
To choose a defaulr fill color Applying uniform fills fills, applying uniform
1 Click a blank area on the drawing page to deselect all objects.
Applying fountain fills fountain fills, overview

2 Click a color on the color palette.

3 In the Uniform fill dialog box, enable any of the following Adjusting fountain fill quality fountain fills, overview

check boxes: | il i |
Applying pattern fills attern fills, applyin
® Graphic — applies the default fill color to shapes you pPImg P P ppPIng

draw Applying texture fills texture fills, overview

88 CorelDRAW User Guide: Chaprer 8



Copying fills
Filling open curves

Applying and customizing
PostScript texture fills

Applying and customizing mesh
fills

fills, working with
fills, working with

PostScript texture fills, overview

mesh fills, overview

Filling objecrs
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Working with color

Corel graphics applications let you choose and create colors
using various color models.

In this section, you'll learn about

e choosing colors

e working with custom color palettes
¢ reproducing colors accurately

This section includes a reference topic that contains information
about reproducing colors accurately.

Choosing colors

You can choose fill and outline colors using fixed or custom color
palettes, color viewers, color harmonies, or color blends.

For information about applying the colors you choose, and
choosing default colors, see “Applying uniform fills” on page 81
and “Formatting lines and outlines” in the online Help.

Choosing a color using fixed or custom color palettes

Fixed color palettes are provided by third-party manufacturers.
Some examples of these are PANTONE, HKS, and TRUMATCH. It
may be useful to have on hand a manufacturer’s swatch book,
which is a collection of color samples that shows exactly what
each color looks like when printed.

The PANTONE, HKS, and TRUMATCH fixed color palettes are
collections of spot colors. If you create color separations when
you print, each color from these color palettes requires a
separate printing plate. This can significantly increase the cost of
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your print job. If you want to use these colors, but you don’t
want to use spot colors, convert the spot colors to process colors
when printing. For more information, see “Printing color
separations” in the online Help.

Custom color palettes can include colors from any color model or
fixed color palette. Custom color palettes are saved as color
palette files.

Choosing a color using color viewers

Color viewers give a representation of a range of colors using
either one-dimensional or three-dimensional shapes. The default
color viewer is based on the HSB color model, but you can use
this viewer to choose CMYK, CMY, or RGB colors. For information
about color models, see “Understanding color models” on page
97.

To choose A color using A fixed or custom color
palerte

1 Select an object.
2 Do one of the following:

® Open the Fill flyout
color dialog tool.

dFEErEx = |, and click the Fill

® Open the Outline flyout 2B HE = —=—=- = | , and
click the Outline color dialog tool.

w

Click the Palettes tab.

Choose a fixed or custom palette from the Palette list box.

N

5 Click the color scroll bar to set the range of colors displayed
in the color selection area.

6 Click a color in the color selection area.

7, Each color swatch on a fixed color palette is marked
K/ with a small white square.

You should use the same color model for all the
colors in a drawing.

You can display or hide the names of fixed or custom
colors by clicking Options » Show color names.

eS

S

You can swap the old and new colors by clicking
Options » Swap color.

To choose A color using A color viewer
1 Select an object.
2 Do one of the following:

* Open the Fill flyout @F BER= =

color dialog tool.

, and click the Fill

* Open the Outline flyout 2B BEE -~ ——===-= = | ,and
click the Outline color dialog tool.
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Click the Models tab.
Choose a color model from the Model list box.

Click Options » Color viewers, and click a color viewer.

A U1 s W

Click the color scroll bar to set the range of colors displayed
in the color selection area.

7 Click a color in the color selection area.

If you choose a color that is out of the printer’s
gamut, the color in the smaller swatch next to the
New color swatch is the closest in-gamut color to the
color you choose. You can click this closest in-gamut
color, or you can correct the out-of-gamut color. For
information about color correction, see “Reproducing
colors accurately” on page 93.

7

You should use the same color model for all the
colors in a drawing.

-~ You can swap the old and new colors by clicking
s\ Options » Swap color.

You can disable the gamut alarm by clicking Options
» Gamut alarm.

Reproducing colors accuraTtely

You can ensure that colors are reproduced accurately by using
color profiles and color correction.

Each device that you use to create a drawing has a range of
colors, or color gamut, that it can reproduce. The range of colors
of a device is a device gamut. For example, a monitor displays a
different range of colors than a printer reproduces. This means
that your drawing might contain colors that display properly on
your monitor, but cannot be printed properly. Different monitors,
scanners, printers, and other devices might have a different
gamut. To minimize the differences in gamut, you can use a color
management system. A color management system uses color
profiles, which contain the color gamut of various devices.

For more information about color management, see
“Understanding color management” on page 98.
Color profiles

Color profiles contain the color gamut of input and output
devices. You can choose color profiles for a

* monitor
* scanner/digital camera

* composite printer

Working with color
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* separations printer

¢ internal RGB

ICC (International Color Consortium) color profiles are standard
profiles that contain information about how color is reproduced
by devices. The ICC options available in Corel graphics
applications include setting the rendering intent, which is a way
to map colors to various output devices by controlling how the
color management system converts colors between different
spaces.

Color correction

Color correction lets you adjust colors so that they display as
accurately as possible on screen. If you correct only the display
colors, the colors are adjusted according to your monitor’s color
profile. If you display colors as they will print, on-screen colors
are adjusted according to your monitor and your printer’s color
profiles.

Some color management settings can result in on-screen colors
appearing dull. For more information, see “Color management
styles” in the online Help.

To choose a color profile
1 Click Tools » Color management.
2 Click a profile name under one of the following icons:

# . Scanner/digital camera

¥# Separations printer
L& Monitor
s Composite printer

% Internal RGB
3 Choose a profile from the list box.

@: You can access a color profile online by choosing
&\ Color profiles online from the list box.

You can access profiles on a disk by choosing Get
profiles from disk from the list box. The profiles are
stored in the Color folder on CorelDRAW Disc 1.

To choose ICC oprions
1 Click Tools » Color management.
2 Click on the Internal RGB icon i .

3 From the Rendering intent list box, choose one of the
following:

* Absolute colorimetric — good for images that use spot
colors

* Automatic — default setting
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® Perceptual — good for a variety of images, especially Always embed using export option, you can choose a

bitmapped and photographic images profile from the list box.
* Relative colorimetric — good for producing proofs on When you enable the Embed internal RGB profile or
inkjet printers the Always embed using export options, certain file
¢ Saturation — good for vector graphics (lines, text, and formats are exported with an embedded ICC profile.
solid colored objects) These file formats are: TIFF (.tif), EPS (.eps), COREL
4 Choose an option from the Color engine list box. PHOTO-PAINT (.cpt), CorelDRAW (.cdr), JPEG (jpg),

PDF (.pdf).

To choose advanced imporT ANd EXpORT SETTINGS ) )
) To choose advanced seTtings ForR pRINTERS
1 Click Tools » Color management. .
) ) . 1 Click Tools » Color management.
2 Click the Import/Export icon _ T . 2 Click one of the following icons:

3 In the Import area, enable one of the following options :
* Use embedded ICC profile

* Always convert using

® Composite printer iy«
* Separations printer "

3 Choose a setting from the list box.
* Ignore embedded ICC profile

4 In the Export area, enable one of the following options:
* Embed internal RGB profile

* Always embed using

8 o If you choose an advanced setting, that setting will
override the profile that displays under the printer
icon in the Color management dialog box.

* Do not embed ICC profiles

N\ When you enable the Use embedded ICC profile or
Always convert using import options, as well as the
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To enable the gamur alarm

1 Click Tools » Color

management.

2 Click the Monitor icon §& .
3 Enable the Highlight display colors out of printer gamut

check box.

If you want to show CMYK in percentages, enable the Show

CMYK in percentages check box.

@: You can map spot colors into the CMYK gamut by
s\ enabling the Map spot colors into CMYK gamut

check box.

You can change the warning color of the gamut alarm
by opening the Warning color picker and choosing a

color.
To correct colors

To

Do the following

To Do the following

Display for a composite Click Tools » Color management, and click

printer the arrow that points from the Composite
printer icon &g to the Monitor icon ‘!' .
The arrow should appear orange.

Display for a color Click Tools » Color management, and click

separations printer the arrow that points from the Separations
printer icon 'f' to the Monitor icon &l
The arrow should appear orange.

Simulate separations Click Tools » Color management, and click
printer output on the arrow that points from the Separations
composite printer printer icon %#* to the Composite printer

icon e . The arrow should appear orange.

Correct display colors

Click Tools » Color management, and click
the arrow that points from the Internal RGB

icon & to the Monitor icon Nail .

N\ Arrows appear orange when they are turned on, and

K/ grayed and broken when they are turned off. For
more information about using the arrows for color
correction, see “Understanding the management
dialog box” on page 98.
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To use color manNaGemenT sTyles

1 Click Tools » Color management.

2 Choose one of the following from the Styles list box:

Color management off

Default settings

Optimized for desktop printing
Optimized for professional output
Optimized for the Web

%@ Some color management settings, such as Default,

Optimized for desktop, and Optimized for
professional output, can result in on-screen colors
appearing dull. For a brighter display of on-screen
colors, choose another color management setting, or
turn off color management.

@: You can add or delete a color management style by
AN
SHAN

clicking on the plus (+) or minus (-) buttons.

Reference: Working with color

You can work with color more effectively when you understand
basic color models and color management.

In this reference topic, you'll learn about

e understanding color models

e understanding the Color management dialog box

Understanding color models

You need a precise method to define colors. Color models
provide various methods to define colors, each model defining
colors through the use of specific color components. There are a
range of color models to choose from when creating graphics.

CMYK color model

The CMYK color model defines color using the following
components:

* c¢yan (C)

* magenta (M)
e yellow (Y)

e black (K)

The cyan, magenta, yellow, and black components are the
amounts of cyan, magenta, yellow, and black ink that a CMYK
color contains and are measured in percent from 0 to 100.

The CMYK color model is a subtractive color model. Subtractive
color models use reflected light to display color. Printed materials
are produced using the CMYK color model. The combinations
and the amounts of cyan, magenta, yellow, and black ink define
the colors in the CMYK color model. When you combine cyan,

Working with color

97



magenta, yellow, and black, so that the value of each component
is 100, the result is black. When the value of each component is
0, the result is pure white.

RGB color model

The RGB color model defines color using the following
components:

e red (R)
e green (G)
* blue (B)

The red, green, and blue components are the amounts of red,
green, and blue light that an RGB color contains and are
measured in values ranging from 0 to 255.

The RGB color model is an additive color model. Additive color
models use transmitted light to display color. Monitors use the
RGB color model. The combination of red, green, and blue light
defines the colors in the RGB color model. When you add red
light, blue light, and green light together, so that the value of
each component is 255, the color white displays. When the value
of each component is 0, the result is pure black.

HSB color model

The HSB color model defines color using the following
components:

* hue (H)
e saturation (S)
* brightness (B)

Hue describes the pigment of a color and is measured in degrees
from 0 to 359 (for example, 0 degrees is red, 60 degrees yellow,
120 degrees green, 180 degrees cyan, 240 degrees blue, and 300
degrees magenta). Saturation describes the vividness or dullness
of a color and is measured in percent from 0 to 100 (the higher
the percentage, the more vivid the color). Brightness describes
the amount of white that the color contains and is measured in
percent from 0 to 100 (the higher the percentage, the brighter
the color).

Grayscale color model

The Grayscale color model defines color using only one
component, lightness, and is measured in values ranging from 0
to 255. Each Grayscale color has equal values of the red, green,
and blue components of the RGB color model.

Understanding The Color management dialog box

Color management is the process of matching colors between
various devices, such as scanners, digital cameras, printers, and
monitors. Corel graphics applications feature color management
controls designed to ensure color matching between various
devices.
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The Color management dialog box, with its default settings,

looks like this:
3 L=
ey Pl
a . 'I.I Ij
bt vl BER b -
Erie CHYT il ol L Crifsing o i bl b il W
i Ml -
T o m o m

In the Color management dialog box, you can activate the
following visual elements :

Scanner/digital camera icon

Separations printer icon

Monitor icon

@S h

Composite printer icon

L

|

Import/export icon

4 4

Internal RGB icon

e

Arrows
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With the exception of the scanner/digital camera icon, you can
click these elements to choose color management options. When
you click on the icons, you can choose advanced settings that
relate to the devices they represent. For example, clicking on the
composite printer icon allows you to link color profiles with any
printer connected to your computer.

You can also click the caption text under the icons. Clicking the
text under the icons allows you to choose profiles for the devices
listed above. You can also choose to get profiles from Disc 1 of
the CorelDRAW discs, or get profiles online. You should check the
manufacturer’s documentation for a device to choose the
appropriate profile.

In addition, you can click the arrows to turn them on or off. The
arrows appear orange when on, and grayed and broken when off.
You can use the arrows to correct colors between devices, and
control how colors are displayed.

The following table contains descriptions of what happens when
an arrow is on or off.

Arrow On Off

From the The scanner/digital
scanner/digital camera camera profile is used
to internal RGB for color correction.

The profile is not
used.

Arrow

On

off

From internal RGB to
the monitor

From internal RGB to
the composite printer

From the composite
printer to the monitor

From internal RGB to
the separations
printer

From the separations
printer to the monitor

Colors are calibrated
for display using the
monitor’s color
profile.

The printer’s profile is
used for color
correction.

The monitor
simulates a composite
printer output.

The separations
printer profile is used
for color correction
when printing color
separations.

The monitor
simulates color
separations printer
output.

The profile is not
used.

The profile is not
used.

The monitor does not
simulate a composite
printer output.

The profile is not
used. You can
override this setting
in the Print dialog
box.

The monitor does not
simulate color
separations printer
output.
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Arrow On

Off

From the separations  The composite printer The composite printer
printer to composite  simulates separations  does not simulate
printer printer output. separations printer

output.

From the internal RGB Internal RGB profiles  ICC profiles are not

to the import/export  are embedded. embedded.
From the Embedded ICC ICC profiles are
import/export to the  profiles are used. ignored.
internal RGB

From here

For more information about...

In the online Help Index, type...

Choosing colors

Working with custom color
palettes

Reproducing colors accurately

Understanding color models and
color management

colors, choosing

working with custom palettes

colors, reproducing

color reference

Working with color
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Adding 7-D effects 10 objecrts

You can create the illusion of three-dimensional depth in ConToUuRiNG objecTs
CorelDRAW objects by adding contour, perspective, extrusion, or

You can contour an object to create lines that progress to the
drop-shadow effects. ) prog

center, inside, or outside of the objects. The lines create a series
In this section, you'll learn about of concentric steps within an object.

e contouring objects
» applying perspective to objects
* creating vector extrusions

e creating drop shadows
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CorelDRAW also lets you set the number and distance of the
contour lines.

After contouring an object, you can copy or clone its contour
settings to another object.

You can also change the colors of the fill between the contour
lines and the contour lines themselves. You can set a color
progression in contour, where one color blends into another. The
color progression can follow a straight, clockwise, or
counterclockwise path through the color spectrum.

A center contour applied to an object.
To conTouR AN objecr

1 Open the Interactive tools flyout & & = cd &y | , and click
the Interactive contour tool.

2 Click an object or a set of grouped objects and drag the start
handle toward the center to create an inside contour.

3 Move the slider to change the number of contour steps.

You can also Do the following
Specify the number of contour Click the Inside button on the
An outside contour applied to an object. lines property bar, and type a value in
the Contour steps box on the
property bar.
Specify the distance between Type a value in the Contour offset
contour lines box on the property bar.
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You can also Do the following

Click the Object and color
acceleration button on the
property bar and adjust the object
slider.

Accelerate contour line
progression

2 You can create an outside contour by dragging the
S\ start handle away from the center.

To copy or clone A conTOUR

1 Select the object you want to contour.

2 Click Effects » and click one of the following:
* Copy effect » Contour from
® (Clone effect » Contour from

3 Click a contour object.

To specify an outline color for The conTour objecr

1 Open the Interactive tools flyout, and click the Interactive
contour tool.

2 Select a contour object.

3 Open the Outline color picker on the property bar, and click a
color.

Applying perspecTive To objects

You can create a perspective effect by shortening one or two
sides of an object. This effect gives an object the appearance of
receding in one or two directions, thereby creating a one-point
perspective or a two-point perspective.

@

Graphics 2 and 3 show one-point and two-point perspective applied to the
object in graphic 1.

You can add a perspective effect to objects or grouped objects.
However, you can’t add a perspective effect to paragraph text,
bitmapped images, linked groups, such as contours, blends,
extrusions, and objects created with the Artistic media tool.

Adding %-D effects 10 objects
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After you apply a perspective effect, you can copy it to other
objects in your drawing, and you can remove it from the object.

To apply A ONE-pPOINT PERSPECTIVE
1 Select an object.

2 Click Effects » Add perspective.

3 Hold down CTRL, and drag a node.

%, Holding down CTRL constrains the node’s movement
5/ to the horizontal or vertical axis to create a one-point
perspective effect.

You can move opposing nodes the same distance in
opposite directions, by holding down CTRL + SHIFT
as you drag.

-
IS

To apply A TWO-pOINT PERSPECTIVE

1 Select an object.

2 Click Effects » Add perspective.

3 Drag two nodes to apply the effect you want.

To copy aN object’s perspective effecr

1 Select an object to which you want to apply a perspective
effect.

2 Click Effects » Copy effect » Perspective from.
3 Select an object whose perspective effect you want to copy.

To remove AN object’s perspective effect
1 Select an object that has a perspective effect.
2 Click Effects » Clear perspective.

To adjust The perspecTive

1 Open the Shape edit flyout & dﬂ'tl , and click the
Shape tool.

2 Select an object that has a perspective effect.

3 Drag a node to a new position.

@: You can also adjust the perspective by dragging one
&\ or both of the vanishing points.

You can move opposing nodes the same distance in
opposite directions by holding down CTRL + SHIFT.

CREATING VECTOR EXTRUSIONS

You can make objects appear three-dimensional by creating
vector extrusions. You can create vector extrusions by projecting
points from an object and joining them to create an illusion of
three dimensions.
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Basic vector extrusions and a beveled extrusion (right).

After you create an extrusion, you can copy or clone its attributes
to a selected object. You can also change its form by rotating it,
changing its direction, and rounding its corners.

Bevels

Another way in which you can give an object a three-dimensional

appearance is by applying a beveled edge to an extrusion. A bevel
creates the illusion that an object’s extruded edges are cut on an

angle. You can specify the angle and depth values of the bevel to

control the effect.

Extruded fills

You can apply fills to an entire vector extrusion, the extruded
surfaces only, or to the beveled surfaces of a vector extrusion.
You can cover each surface individually with the fill, or you can
drape the fill so that it blankets the entire object with no breaks
to the pattern or texture.

@
Fills for vector extrusions. Clockwise from the top left: object fill, bevel to
extrusion fill, beveled fill, and draped fill.

Lighting

You can enhance vector extrusions by applying light sources. You
can add up to three light sources to project toward the extruded
object with varying intensity. When you no longer need light
sources, you can remove them.

Adding %-D effects 10 objects
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A light source applied to an extrusion.

Vanishing points

You can create a vector extrusion in which the lines of the
extrusion converge at a vanishing point. The vanishing point of a
vector extrusion can be copied to another object so that both
objects appear to recede toward the same point. You can also
give two vector extrusions the same vanishing point.

P

Vector extrusions with different vanishing points.

Vector extrusions with the same vanishing point.
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To CREATE A VECTOR EXTRUSION

1 Open the Interactive tools flyout =& B = & ¢ | ,and
click the Interactive extrude tool.

N

Click the Vector extrusion mode button on the property bar.

w

the property bar.

S

Select an object.

[9)]

Drag the object’s selection handles to set the direction and
depth of the extrusion.

If you want to reset the extrusion, press ESC before releasing
the mouse button.

2 You can apply preset extrusions by selecting the
&\ shape you want to extrude, clicking the Interactive
extrude tool and choosing the Preset list box.

To copy or cloNe A VECTOR EXTRUSION

1 Select the object you want to extrude.

2 Click Effects » and click one of the following:
* Copy effect » Extrude from
* (Clone effect » Extrude from

3 Click an extruded object.

Choose an extrusion type from the Extrusion type list box on

T You can’t edit a cloned object’s extrusion settings;
X/A any changes must be made to the master object.

To REMOVE A VECTOR EXTRUSION

Select an extruded object.

2 Click Effects » Clear extrude.

< You can also remove a vector extrusion by clicking
&\  the Clear extrude button on the property bar.

To apply A fill To A vecTOR exTRUSION

Select an extruded object.

2 Click the Color button on the property bar.
3 Click one of the following buttons:

* Use object fill — applies the object’s fill to the extrusion.
® Use solid color — applies a solid color to the extrusion

® Use color shading — applies a gradient fill to the
extrusion

2 You can drape the object’s fill by enabling the Drape
S\ fill check box when you enable the Use object fill
button.
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To change the vanishing poinT of A vEcTOR exTRusioON
You can also

Apply an extrude fill to bevels Click Use extrude fill for bevel and To Do the following

click a color on the Bevel color picker. Lock a vanishing point  Double-click an extruded object. Choose VP

locked to object or VP locked to page from
the Vanishing point properties list box on the
property bar.

Apply a solid fill to bevels Click Use solid color button and click a
color on the Bevel color picker.

Copy a vanishing point Double-click an extruded object. Choose Copy

To light A vecTor exTrUSiON extr ¢ 0s¢
VP from the Vanishing point properties list

1 Select an extruded object. box on the property bar. Select the extruded
2 Click the Lighting button on the property bar. object that has the vanishing point you want
. . t .
3 Click any of the three Light buttons. 0 copy.
The lights appear as numbered circles in the preview window. Set one vanishing Double-click an extruded object. Choose
4 Drag the numbered circles in the Light intensity preview point for two Shared vanishing point from the Vanishing
: ‘e : i i ies list box on the property bar.
window to position the lights. extrusions point properties prop
p J Select the extruded object that has the
If you want to create more realistic shading, enable the Use vanishing point you want to share.
full color range check box.
You can also CreaTing bitmapped exTrusions
Adjust the intensity of a light ~ Select a light in the Light intensity You can apply extrusions to bitmapped objects created in
source preview window and move the CorelDRAW. You can also apply preset beveled edges to the front
Intensity slider. face of a bitmapped extrusion, the back face, or both, and specify
Remove a light source Click an active Light button.
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the height and width of a bevel. To apply A bitmapped exTrusioN

1 Open the Interactive tools flyout & B =4 8¢ | ,and
click the Interactive extrude tool.

N

Select an object.

w

Click the Bitmap extrusion mode button on the property bar.
4 Double-click the object to create and add extrude effects.

S\ You cannot remove a bitmapped extrusion from an
k/ object.

@/ You can render a bitmapped extrusion by clicking

. . . <
A bevel applied to a bitmapped extrusion. S outside its bounding box.

You can change the depth and fill of a bitmapped extrusion as To position a bitmapped extrusion

well as rotate it and change its position. 1. Double-click a bitmapped extrusion.

You can add two kinds of lighting effects — ambient and point. 2 On the property bar, type values in the following boxes:

Ambient light is uniform, has no specific origin, and casts no * X object(s) position
shadows. It is the equivalent of daylight and radiates in every * Y object(s) position
direction. You can position the point light to project it toward

the object from one or more directions. You can also change the

intensity and color of a point light.
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To apply beveled edges 10 A bitmapped exTrusion

To

Do the following

Add beveled edges

Adjust the size of
beveled edges

Double-click a bitmapped extrusion. Click
Front bevel or Back bevel on the property

bar to choose bevel edges for the extrusion.

Double-click a bitmapped extrusion. Click
the Bevels button on the property bar, and
type values in the Bevel width and Bevel
height boxes.

To edit A bitmapped exTrusion

To

Do the following

Set the depth of a
bitmapped extrusion

Rotate a bitmapped
extrusion

Add afillto a
bitmapped extrusion

Double-click the bitmapped extrusion, and
type a value in the Extrude depth box.

Double-click the bitmapped extrusion, to
rotate the object along the cross-hairs.

Double-click a bitmapped extrusion with the
Pick tool & , and choose a color from the
color palette or another fill from the Fill
flyout.

T Texture fills significantly increase the size of a file and
the time it takes to print.

To apply ambient Llight 10 A bitmapped exTrusion
1 Double-click a bitmapped extrusion.

Click the Ambient light button on the property bar.
Enable the On check box.

Open the Color picker, and click a color.

u s W N

Move the Brightness slider.

To apply a point light

Double-click a bitmapped extrusion.

Click the Point light button on the property bar.

Click the Add light button.

Drag the light source to position it in the preview window.
Open the Color picker, and click a color.

DUl W N =

Move the Brightness slider.

< You can remove a point light by clicking the light
&\ source in the preview window and clicking the
Remove light button.
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CreaTing drop shadows

Drop shadows simulate light falling on an object from one of five
particular perspectives: flat, right, left, bottom, and top.

>

A drop shadow applied to an object.

You can add drop shadows to most objects or groups of objects,
including artistic text, paragraph text, and bitmapped images.
When you add a drop shadow, you can change its perspective,
and you can adjust attributes such as color, opacity, fade level,
angle, and feathering.

The feathered effect softens the edges of a drop shadow.

After you create a drop shadow, you can copy it or clone it to a
selected object. When you copy a drop shadow, the original and
copy have no connection and can be edited independently. In
cloning, a master object’s drop shadow attributes are
automatically applied to its clone.

By separating a drop shadow from its object, you can gain more
control over the drop shadow itself. You can also set the
rendering resolution of a drop shadow.

You can also remove a drop shadow.

Adding %-D effects 10 objects
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To add A drop shadow

1 Open the Interactive tools flyout & B &4 & ¢ | , and click
the Interactive drop shadow tool.

2 Click an object.

3 Drag from the center or side of the object until the drop
shadow is the size you want.

4 Specify any attributes on the property bar.

You can’t add drop shadows to linked groups, such as
blended objects, contoured objects, beveled objects,
extruded objects, objects created with the Artistic
media tool, or other drop shadows.

7

To copy or clone A drop shadow

1 Select the object to which you want to copy or clone a drop
shadow.

2 Click Effects and click one of the following:
* Copy effect » Drop shadow from
® Clone effect » Drop shadow from

3 Click an object that has a drop shadow.

To remove A drop shadow
1 Select an object that has a drop shadow.
2 Click Effects » Clear drop shadow.

< You can also remove a drop shadow from an object by
&\ cdlicking the Clear drop shadow button on the

property bar.
From here
For more information about... In the online Help Index, type...
Contouring objects objects, applying contours
Creating vector extrusions extrusions, vector
Creating bitmapped extrusions extrusions, applying to bitmapped
images
Creating drop shadows drop shadows
Applying lenses lenses, creating
Editing lenses lenses, changing viewpoint
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Changing The TRANSpARENCY of objects

You can apply a transparency to an object so that all objects
behind it show through. CoreIDRAW also lets you specify how
the color of the transparent object combines with the color of
the object beneath it.

In this section, you'll learn about
e applying a transparency

e applying merge modes

Applying A TRANSPARENCY

When you apply a transparency to an object, you create a
grayscale mask similar to a fill. By positioning a transparent
object on top of another object, you simulate a lens. You can
apply transparencies using the same kind of fills you apply to

objects; that is, uniform, fountain, texture, and pattern. For more
information about these fills, see “Filling objects” on page 81.

After you decide what type of transparency you want to apply,
you have several options. By default, CoreDRAW applies all
transparencies to the object’s fill; however you can specify
whether you want the transparency to apply to the object’s
outline only or to both the fill and the outline.

You can also copy a transparency from one object to another.
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To apply a uniform TRANSPARENCY

1
2

Select an object.

Open the Interactive tools flyout & B =@y | , and click
the Interactive transparency tool.

On the property bar, choose Uniform from the Transparency
type list box.

Click a color on the color palette.

Type a value in the Starting transparency box on the property
bar, and press ENTER.

-~ You can fix the contents of the transparency so that

d
s\ the contents move with the object, by clicking the

Freeze button on the property bar.

A uniform transparency

To apply A founTain TRANSPARENCY

1

Select an object.

2 Open the Interactive tools flyout _# B =@ ¢ | , and click

the Interactive transparency tool | .

On the property bar, choose one of the following fountain
transparencies from the Transparency type list box:

® Linear
¢ Radial
* Conical
* Square

Point to where you want the transparency to start on the
object, and drag to where you want the transparency to end.

If you want to reset the transparency, press ESC before
releasing the mouse button.

Type a value in the Transparency midpoint box on the
property bar, and press ENTER.

< You can fix the contents of the transparency so that
&7\ the contents move with the object, by clicking the
Freeze button on the property bar.
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A fountain transparency.

To apply A TexTured TRANSpPARENCY

1 Select an object.

2 Open the Interactive tools flyout _#ELEH &T | , and click
the Interactive transparency tool _‘H .

3 Choose Texture from the Transparency type list box on the
property bar.

4 Choose a sample from the Texture library list box on the
property bar.

5 Open the First transparency picker on the property bar and
click a texture.

6 On the property bar, type values in the following boxes:

® Starting transparency — lets you change the opacity of
the starting color

¢ Ending transparency — lets you change the opacity of the
ending color

2 You can fix the contents of the transparency so that
s\ the contents move with the object, by clicking the
Freeze button on the property bar.

A textured transparency.

To apply A PATTERN TRANSPARENCY

1 Select an object.

2 Open the Interactive tools flyout _# B =& | , and click
the Interactive transparency tool _'H .

3 On the property bar, choose one of the following from the
Transparency type list box:

Changing The Transparency of objects
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® Two-color pattern — a simple picture composed of “on”
and “off” pixels. The only colors included in the picture
are the two that you assign.

* Full-color pattern — a picture composed of lines and fills,
instead of dots of color like bitmapped images. These
vector graphics are smoother and more complex than
bitmapped images and are easier to manipulate.

* Bitmap pattern — a color picture composed of patterns of
light and dark or differently colored pixels in a rectangular A pattern transparency.
array.

4 Open the First transparency picker on the property bar and

To specify the location of A TRANSpARENCY
click a pattern.

1 Open the Interactive tools flyout _#B& S & ¥ | , and click
the Interactive transparency tool i] .
Select the object.

5 On the property bar, type values in the following boxes:
¢ Starting transparency

* Ending transparency 3 On the property bar, choose one of the following from the

2 You can fix the contents of the transparency so that Apply transparency to list box:

s\ the contents move with the object, by clicking the * Fill
Freeze button on the property bar. e OQutline
e All
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To copy A TRANSPARENCY

1 Select an object.
2 Click Effects » Copy effect » Lens from.

3 Using the horizontal cursor, select an object with the
transparency you want to copy.

Applying merge modes

You can apply a merge mode to a transparency to specify how the
color of a transparency is combined with the color of the object

behind it.

Merge mode

Description

Normal

Add

Subtract

Difference

Applies the transparency color on top of the base
color.

Adds the values of the transparency color and the
base color.

Adds the values of the transparency color and the
base color together, and then subtracts 255.

Subtracts the transparency color from the base color
and multiplies by 255. If the transparency color value
is 0, the result will always be 255.

Merge mode

Description

Multiply

Divide

If lighter

If darker

Texturize

Hue

Multiplies the base color by the transparency color,
and then divides by 255. This has a darkening effect,
unless you are applying color to white. Multiplying
black with any color results in black. Multiplying
white with any color leaves the color unchanged.

Divides the base color by the transparency color, or
conversely, divides the transparency color by the base
color, depending on which color has the higher value.

Replaces any base color pixels that are a darker color
with the transparency color. Base color pixels that are
lighter than the transparency color are not affected.

Replaces any base color pixels that are a lighter color
with the transparency color. Base color pixels that are
darker than the transparency color are not affected.

Converts the transparency color to grayscale, and
then multiplies the grayscale value by the base color.

Uses the hue of the transparency color, as well as the
saturation and lightness of the base color. If you are
adding color to a grayscale image, there will be no
change because the colors are desaturated.
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Merge mode

Description

Merge mode

Description

Saturation Uses the lightness and hue of the base color and the Green Applies the transparency color to the green channel
saturation of the transparency color of RGB objects
Lightness Uses the hue and saturation of the base color and the Blue Applies the transparency color to the blue channel of
lightness of the transparency color RGB objects
Invert Uses the transparency color’s complementary color. If
a transparency color value is 127, there will be no To APP'-Y MERGE modes
f}l?:rli‘folie;;liel the color value falls in the center of 1 Open the Interactive tools flyout & EE&H & | , and click
: the Interactive transparency tool 5 .
Logical AND Converts the transparency and base colors to binary 2 Select an object with a fountain, texture, or pattern
values, and then applies the Boolean algebraic transparency.
formula AND to these values . .
3 Choose a merge mode from the Transparency operation list
Logical OR Converts the transparency and base colors to binary box on the property bar.
values, and then applies the Boolean algebraic
formula OR to these values
Logical XOR Converts the transparency and base colors to binary
values, and then applies the Boolean algebraic
formula XOR to these values
Red Applies the transparency color to the red channel of
RGB objects
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Working with bitmapped images

You can scan, import, and edit bitmapped images in Core]DRAW.
You can also add special effects and change the color and tone of
the images.

In this section, you'll learn about

e adding bitmapped images

e cropping and editing bitmapped images

* applying special effects to bitmapped images

Adding bitmapped images

You can import a bitmapped image into a drawing either directly
or by linking to an external image file. When you link to an

external file, any changes to the original file can be updated in
the imported image.

You can also add a bitmapped image by scanning it or by loading
it from a digital camera.

To imporrt A bitmapped image
1 Click File » Import.

2 Choose the drive and folder where the bitmapped image is
stored.

3 Double-click the folder to open it.

If you want to link the image to the drawing, enable the Link
bitmap externally check box.

CorelDRAW User Guide: Chaprer 12
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4 Select the file.
5 Click Import.
6 Click where you want to place the bitmapped image.

Ensure that Files of type is set to All file formats
when you import an image.

7

The status bar provides information about the
bitmapped image, including color mode, size, and
resolution.

@: You can import a bitmapped image in its original size
s\ by pressing SPACEBAR when you click the Import
button.

To scan A bitmapped image
1 Click File » Acquire image » Select source.

2 Select a scanner from the Select source dialog box, and click
Select.

3 Place an image on your scanner.

N

Click File » Acquire image P Acquire.

Refer to scanner’s documentation for details on

To load a bitmapped image from A digital camera

1 Click File » Acquire image » Select source.

2 From the Sources list, click the selection that corresponds to
your digital camera.

3 Click Select.
Click File » Acquire image P Acquire.

Cropping ANd editing bitmapped images

After you add a bitmapped image to a drawing, you can crop,
resample, inflate, and edit the image.

Cropping removes unwanted areas of a bitmapped image.
Resampling changes the size or the resolution of a bitmapped
image by adding or removing pixels. When you resample a
bitmapped image, you can change the image size, the resolution,
or both.

Editing a bitmapped image is done in Corel PHOTO-PAINT, which
starts automatically when you start to edit the bitmapped image.
For more information about editing bitmapped images, see Corel
PHOTO-PAINT online Help.

n ! i CorelDRAW automatically inflates a bitmapped image to make a
scanning procedures and options. special effect cover the entire image. You can disable the
automatic inflate and specify how much you want to inflate the
bitmap manually.
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To crop A bitmapped image

1 Open the Shape flyout & :# -.ﬂ:-l , and click the Shape
tool & .

Select a bitmapped image.

w N

Drag nodes to crop the bitmapped image.
4 Click Bitmaps » Crop bitmap.

2 You can also crop a bitmapped image by clicking the
&\~ Crop bitmap button on the property bar.

To change The size of A bitmapped image
1 Select a bitmapped image.
2 Click Bitmaps » Resample.

3 Choose a unit of measure from the list box beside the Width
and Height boxes.

4 Type values in any of the following boxes:
* Width
* Height

If you want to minimize the jagged appearance of curves,
enable the Anti-alias check box.

2 You can maintain the proportions of the bitmapped
&\ image by enabling the Maintain aspect ratio check

box and typing a value in either the Width or the
Height box.

You can also resample the bitmapped image as a
percentage of its original size by typing values in the
% boxes.

Applying special effects 1o bitmapped
iMAGES

You can apply a wide range of special effects to bitmapped
images, such as three-dimensional and artistic effects.

Adding plug-in filters to CoreIDRAW provides additional features
and effects that you can use to edit images. You can enable or
disable plug-in filters and you can remove them when you no
longer need them.

Special effect type Description

3-D Lets you create the illusion of
three-dimensional depth. The 3-D effects
include embossing, page curl, and
perspective.

Working with bitmapped images

12%



Special effect type

Description

Special effect type

Description

Art strokes

Blur effects

Color transform

Contour

Creative

Distort

Lets you apply hand-painted techniques.
The art strokes effects include crayon,
impressionist, pastels, watercolor, and
pen and ink.

Lets you blur an image to simulate
gradual change, movement, or speckling.
The blur effects include Gaussion blur,
motion blur, and zoom.

Lets you create photographic illusions by
using color reduction and replacements.
The color transform effects include
half-tones, psychedelic, and solarizing.

Lets you highlight and enhance the edges
of an image. The contour effects include
edge tracing and highlighting.

Lets you apply a variety of textures and
shapes to an image. The creative effects
include fabric, glass block, crystal
fragments, vortex, and stained glass.

Lets you distort image surfaces. The
distort effects include ripples, blocks,
swirl, and tile.

Noise

Sharpen

Plug-ins

Lets you modify the graininess of an
image. The noise effects include adding
noise, applying dust and scratch, and
diffusing to change an image’s
granularity.

Lets you create a sharpening effect to
focus and enhance edges. The sharpen
effects include accentuating edge detail
and sharpening smooth areas.

Lets you apply effects from a third-party
filter to bitmapped images in CoreDRAW.
An installed plug-in appears at the
bottom of the Bitmaps menu.
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The following pictures show an original image followed by the
same image with special effects applied.

Original image E”?bPSSI eﬁfft in Cubist artistic effect Mosaic creative effect  Distort pixelate effect Add noise effect
original color

Zoom blur effect Solarize color Edge detect contour
transform effect e

Sharpen effect
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To apply a special effecr

1 Click Bitmaps, choose a special effect type and click an effect.

2 Adjust any special-effect settings.

From here

For more information about...

In the online Help Index, type...

Cropping and editing bitmapped
images

Applying special effects to
bitmapped images

Applying color and tone effects
Changing the color mode of
bitmapped images

Changing bitmapped images to
black and white color mode

Changing bitmapped images to
paletted color mode

Changing bitmapped images to
the duotone color mode

cropping images
special effects, applying to
bitmapped images

bitmapped images, applying color
and tone effects to

bitmapped images, color modes
color modes, changing to
black-and-white

paletted color mode

duotone color mode
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WorkinGg with TeXT

CorelDRAW lets you use text to create or enhance drawings.
In this section, you'll learn about

¢ adding and selecting text

* finding, editing, and converting text

* moving text

e changing the appearance of text

e formatting paragraph text

Adding and selecting TexT

There are two types of text you can add to drawings — artistic
text and paragraph text. Artistic text can be used to add short
lines of text to which you can apply a large range of effects, such

as drop shadows. Paragraph text can be used for larger bodies of
text that have greater formatting requirements.

You can add text directly in the drawing window; however, you
must create a text frame for each paragraph text object that you
want to add.

A text frame can be fixed-sized or automatically sized. A
fixed-sized text frame displays a limited amount of paragraph
text. Any text that continues past the bottom right border of the
text frame is hidden until you enlarge the text frame. An
automatically sized text frame adjusts as you type to display all
the text.

Inserting paragraph text frames in graphic objects lets you use
objects as containers for text so that you can change the shape of

CorelDRAW User Guide: Chaprer 17
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the text frames. You can also separate a text frame from a
container object. When you do, the text frame retains the
object’s shape.

To modify text, you must first select it. You can select entire text
objects, specific characters, or single characters. The tool that
you use to select text depends on whether you want to affect an
entire text object (for example, a paragraph text frame) or only a
portion of the text.

To add ArTisTic TEXT

e C(Click anywhere in the drawing window using the Text tool
£ and type.

To add paragraph Texr

To Do the following

Add paragraph text Click the Text tool #4| . Drag in the drawing

window to size the paragraph text frame, and

type.

Add paragraph text in  Click the Text tool. Move the cursor over the

To Do the following

Separate a paragraph
text frame from an

Select the object using the Pick tool 'k |

. click Arrange P Break paragraph text inside a
object path apart. Click a blank space in the drawing
window, select either the text frame or the
object, and drag to a new location.

2 You can adjust the size of a paragraph text frame by
&\ dlicking the text frame using the Pick tool, and
dragging any selection handle.

To add paragraph Text in AN auTomaTically sized
frame

1 Click Tools » Options.
2 Double-click Text and click Paragraph in the list of categories.

3 Enable the Expand and shrink paragraph text frames to fit
text check box.

To select Texr

To select Do the following

an object object’s outline, and click the object when the
cursor changes to an Insert in object cursor. An entire text object  Click the text object using the Pick tool. | &
Type inside the frame.
Specific characters Drag across the text using the Text tool. 44
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2 You can select multiple text objects by holding down
&\ SHIFT and clicking each text object.

Finding, ediTinGg, ANd CONVERTING TEXT

You can find text in a drawing and replace it without having to
retype the text. This is especially useful when a drawing consists
of a lot of text. You can also retype selected text directly in the
drawing window.

CorelDRAW lets you convert artistic text to paragraph text if you
decide you require more formatting options, and paragraph text
to artistic text if you'd like to apply special effects. You can also
convert artistic text to curves so that you can modify the shape
of characters and preserve their appearance when you open a
drawing on another computer.

Converting text to curves transforms characters to single line and
curve objects, letting you add, delete, or move the nodes of a
character to alter its shape. By converting artistic text to curves,
you can change the shape of individual characters. For more
information, see “Working with curve objects” on page 68.

To Find Texr
1 Click Edit » Find and replace » Find text.
2 Type the text you want to find in the Find what box.

If you want to find the exact case of the text you specified,
enable the Match case check box.

3 Click Find next.

To find and replace Texr
1 Click Edit » Find and replace » Replace text.
2 Type the text you want to find in the Find what box.

If you want to find the exact case of the text specified, enable
the Match case check box.

3 Type the replacement text in the Replace with box.
4 Click Replace.

To edit Texr

1 Select the text.

2 Click Text b Edit text.
3 Retype the text.

You can also

Select the text using the Text tool, and
retype the text.

Edit text in the drawing window

Working with Texr
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o You can edit artistic text only if it hasn’t been
%/ converted to curves.

To CONVERT TEXT

To convert Do the following

Select the text using the Pick tool 'k
and click Text » Convert to artistic
text.

Paragraph text to artistic text

Artistic text to paragraph text Select the text using the Pick tool, and

click Text » Convert to paragraph
text.

You cannot convert paragraph text to artistic text
when the paragraph text is linked to another frame,
has special effects applied to it, or overflows its
frame.

K

You can also convert selected artistic text to curves
by right-clicking the text, and clicking Convert to
curves.

-
IS

Moving TexT

CorelDRAW lets you move paragraph text between frames,
artistic text between artistic text objects, and both types of text
between paragraph text and artistic text. You can also move

artistic text to create an artistic text object, and you can move
paragraph text to create a paragraph text frame.

To MOVE TEXT

* Drag the text using the Pick tool 'k

Changing the appearance of Texr

You can enhance artistic text and paragraph text by modifying
their character properties. For example, you can change the font
type and size or make the text bold or italic. You can also change
the default text style, so that every artistic or paragraph text
object you create has the same properties, and change the case
of text to lowercase or uppercase without deleting or replacing
letters. If a drawing includes scientific notation, you can make
text subscript or superscript.

You can also add underlines, overscores, and strikethrough lines
to text and change the thickness of these lines, as well as the
distance between text and a line.

As you add text, you can change its appearance. By default, the
unit of measure is points; you can change this setting for the
active drawing and all subsequent drawings you create.

Greeking text lets you increase the redraw speed by representing
text with lines. You can make text readable again by reducing the
greeking value.
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To change font aTTRibUTES

1 Select the text.

2 Click Text » Format text.

3 Click the Character tab.

4 Specify the font attributes you want.

To change The default Texr style

1 Click a blank space in the drawing window using the Pick
tool 'k

Click Text » Format text.
Click the Character tab.
Specify the properties you want, and click OK.

u s W N

Enable any of the following boxes:
® Artistic text
® Paragraph text

@: You can also change the default text style by clicking

s\ Tools » Graphic and text styles, and dragging a text
object over either the Default artistic text, or Default
paragraph text style in the Graphic and text styles
Docker window.

To change TexT case

1 Select the text.

2 Click Text » Change case.

3 Enable one of the following options:

* Sentence case — capitalizes the initial letter of the first
word in each sentence

* Lowercase — makes all text lowercase
* Uppercase — makes all text uppercase
* Title case — capitalizes the initial letter of each word

* Toggle case — reverses the case; all uppercase letters
become lowercase and all lowercase letters become
uppercase

ForRmMATTING pARAGRAPH TEXT

CorelDRAW offers various formatting options for paragraph text.
By default, CoreIDRAW applies formatting to all selected
paragraph text frames; however, you can change your settings so
that formatting is applied to all linked frames, selected frames, or
all selected and subsequently created frames. For example, if you
make the text in one text frame bold, you can choose whether
you want all the linked frames to include bold text or just those
you specify. For information on linking paragraph text frames,
see “Combining and linking paragraph text frames” in the online
Help.

Working with Texr
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You can fit text to a paragraph text frame. Fitting text to a frame
increases or decreases the point size of text so that it fits the text
frame exactly.

You can use columns to lay out text-intensive drawings, such as
newsletters, magazines, and newspapers. You can create columns
of equal or varying widths and gutters. Adding, editing, or
deleting columns lets you maintain the width of the paragraph
text frame. You can also edit the columns and gutters
proportionately.

Applying drop caps to paragraphs enlarges the initial letter and
insets it into the body of text. You can remove the drop cap at
any point, without deleting the letter. You can also customize a
drop cap by changing its settings. For example, you can change
the distance between the drop cap and the body of text, or
specify the number of lines of text you want to appear beside the
drop cap.

You can use bulleted lists to format nonsequential, parallel pieces
of information consistently. You can add bullets that text wraps
around. You can also offset a bullet from text to create a hanging
indent. After you add a bullet, you can remove it without deleting
the text. CorelDRAW also lets you customize bullets by changing
their size, position, and distance from text. You can also make
your own bullets by adding symbols to a symbol set. For more
information, see “Embedding graphics and adding symbols” in
the online Help.

You can add tabs to indent paragraph text. You can also remove
tabs and change tab alignment. Setting trailing leader tabs
automatically creates dots that precede the tab. You can
customize a trailing leader tab by changing the leader character
and by increasing or decreasing the space between the
characters.

Indenting changes the space between a paragraph text frame and
the text that it contains. You can indent an entire paragraph, the
first line of a paragraph, all but the first line of a paragraph (a
hanging indent), or indent from the right side of the frame. You
can also remove an indent without deleting or retyping text.

Hyphenating divides words at the end of lines instead of
wrapping them to the next line. For example, you can specify the
minimum number of letters before and after a hyphen, as well as
the distance from the right margin that CoreDRAW starts
hyphenating words, which is called the hot zone.

Managing paragraph text frames helps you use them more
effectively. CoreDRAW lets you size a paragraph text frame like
any other object.
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To choose paragraph Text frame FormAaTTING OpTiONS
1 Click Tools » Options.

2 In the list of categories, double-click Text, and click
Paragraph.

3 Click one of the following options:

* To all linked frames — applies the same text formatting
to all connected frames

* To selected frames only — applies the same text
formatting only to selected frames

* To selected and subsequent frames — applies the same
text formatting only to selected and succeeding linked
frames

7, Youcan add color to text but you must apply it to
each linked frame or to the text object separately.

To Fit Text 10 A paragraph Text FrRAME
1 Select a paragraph text frame.
2 Click Text » Fit text to frame.

w If you fit text to linked paragraph text frames,
CorelDRAW adjusts the size of text in all the linked
text frames. For more information about linking
frames, see “Combining and linking paragraph text
frames” in the online Help.

To add columns To paragraph Text FrRAMES
1 Select a paragraph text frame.

2 Click Text » Format text.

3 Click the Columns tab.

4 Type avalue in the Number of columns box.

5 Specify the options you want.

< You can also change the size of columns and gutters
&\ by dragging a side selection handle using the Text
tool.

To add a drop cap

1 Select a paragraph text frame.

2 Click Text » Format text.

3 Click the Effects tab.

4 Choose Drop cap from the Effect type list box.
5 Click one of the following:

* Dropped — wraps text around the drop cap

Working with Texr
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* Hanging indent — offsets the drop cap from the body of
text

You can also

Specify the number of lines beside Type a value in the Dropped lines
a drop cap box.

Specify the distance between the
drop cap and the body of text

Type a value in the Distance from
text box.

i i (&

g ’isilmnemudeum ﬁ ’isir outem wel eum
iriure dolar im iriure delar in

Iremdrerit in wulpulate velit hendrerit i wulpulate
ese molestie mnsequat, vel molestie consequot,
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feugnit nulle facilisi.

fagilisis of vero eros et
occumsan ef iuste odic

proeent luptofum feuguit

1. You can make the first character in a paragraph a drop cap so that it
appears as part of the text.

2. You can make the first character in a paragraph a hanging indent so that
it is offset from the paragraph.

To add a buller

Select the paragraph text.

Click Text » Format text.

Click the Effects tab.

Choose Bullet from the Effect type list box.
Choose a font from the Font list box.

Choose a symbol from the Symbol picker.

N O U e W

Click one of the following:
* Bulleted — wraps text around the bullet

* Hanging indent — adds a bullet with a hanging indent.
Type a value in the Position box to specify the distance the
bullet is indented from the paragraph text frame.

You can also

Change the bullet size Type a value in the Size box.

Raise or lower a bullet Type a value in the Baseline shift box.

Change the amount of space
between the bullet and text

Click the Paragraph tab and type the
same value in the First line and Left
boxes.

2 You can also choose a bullet symbol by typing its
&\ ASCII number in the Symbol # box.
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To add A 1ab

1

u s W N

Select the paragraph text.
Click Text » Format text.
Click the Tabs tab.

Click Add tab.

Click the new cell in the Tabs column, and type a value.

You can also

Change the alignment of tabs Double-click the cell in the

Alignment column, and choose an
alignment option from the list

box.
Set tabs with trailing leader Click the cell in the Leadered
characters column.
Delete a tab Click the Delete button =

2 You can also add, remove, or change the alignment of
&7\ tabs in selected text using the horizontal ruler.

Visit autem ....... , i
imhendrerit ... covnnnn... Y7
invulputate ... 3

Lorem ipsum.......... i
mulla faclisi............. 75
duisauiem .............. 76

The arrow points to the trailing leader tab. Trailing leader tabs are often used

in tables of contents and indexes.

From here

For more information about...

In the online Help Index, type...

Greeking text

Indenting and hyphenating
paragraph text

Shifting, rotating and spacing text

Aligning text

text, changing the appearance of

paragraph text, formatting

text, manipulating

text, aligning
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For more information about...

In the online Help Index, type...

Adding graphics and symbols to
text

Displaying nonprinting characters
Assigning language to text
Formatting Asian text

Using Asian line breaking rules

Formatting Arabic or Hebrew text

symbols, adding to text

nonprinting characters
languages, alternating in text
formatting, Asian text

Asian text, using line-breaking
rules

Arabic text, formatting
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Shaping TEXT

i TR

CorelDRAW lets you shape both paragraph and artistic text in

the object. You can also adjust the amount of space between

unique ways. For example, you can make paragraph text straddle paragraph text and the object or text, as well as remove any

an object or a sentence follow the outline of a circle.
In this section, you'll learn about
* wrapping paragraph text around objects and text

* fitting text to a path

WRrAppinG TeEXT AROUNd objects aAnd TexT

You can change the shape of text by wrapping a paragraph text
frame around an object, artistic text, or another paragraph text
frame. You can wrap text using contour or square wrapping
styles. The contour wrapping styles follow the curve of the
object. The square wrapping styles follow the bounding box of

wrapping style you apply.
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1. You can wrap text around an object using the contour wrapping style so
that the text follows the shape of the object.

2. You can wrap paragraph text around an object using the square wrapping
style so that the text follows the bounding box of the object.

Shaping Texr
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To wrap paragraph Text ArRound AN objecT or TEXT
1 Select the object or text.
2 Click Window » Dockers » Properties.

3 In the Object properties Docker window, click the General tab
and choose a wrapping style from the Wrap paragraph text
list box.

If you want to change the amount of space between wrapped
text and the object or text, type a value in the Text wrap
offset box.

4 Click the Text tool 4|, and either draw a new or drag an
existing paragraph text frame over the object or text.

5 Type text in the paragraph text frame.

You can wrap existing paragraph text around a
selected object by applying a wrapping style to the
object and dragging the paragraph text frame over
the object.

To ReMOVE A WRAPPING sTYLE
1 Select the object or wrapped text.
2 Click Window » Dockers » Properties.

3 In the Object properties Docker window, choose None from
the Wrap paragraph text list box.

Fitting TexT TO A path

You can position artistic text along the path of an open object

(for example, a line) or a closed object (for example, a square).

V Visit augess 6 €um.

7 .

1. Artistic text following the path of an open object.
2. Artistic text following the path of a closed object.

After you fit text to a path, you can adjust the text’s position
relative to that path. For example, you can place the text on the
opposite side of the path, or you can adjust the distance between
the text and the path.

CorelDRAW treats text fitted to a path as one object; however,
you can separate the text from the object if you no longer want it
to be part of the path. When you separate text from a curved or
closed path, the text retains the shape of the object to which it
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was fitted. Straightening reverts the text to its original
appearance.

To Fit TexT 10 A path

1 Select the path using the Pick tool 'k
2 Click Text » Fit text to path.

3 Type along the path.

2 The text is centered along the path.

You can'’t fit text to the path of another text object.

@: You can also fit text to a path by clicking the Text tool
SN 44| , pointing over an object, clicking where you
want the text to begin, and typing the text.

To adjust the position of Texr fitted 10 A path
1 Select the text using the Pick tool 'k

2 On the property bar, choose a setting from any of the
following list boxes:

* Distance from path
* Vertical placement
* Horizontal offset

* Text orientation

* Text placement

@: You can also change the horizontal position of fitted
s\ text by selecting it with the Shape tool & |, and
dragging the character nodes you want to reposition.

S

Using the Pick tool, you can move text along the path
by dragging the small red node that appears beside
the text.

To separaTe Text FrRom A path
1 Select the fitted text using the Pick tool k
2 Click Arrange P Break apart.

To sTraighTeN TexT

1 Select the fitted text using the Pick tool.
2 Separate the text from the path.

3 Click Text b Straighten text.

Shaping Texr
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ManAGinG fonTs

CorelDRAW lets you substitute missing fonts in drawings you
open for those installed on your computer. You can also embed
fonts and format them.

In this section, you'll learn about

¢ substituting unavailable fonts

SubsTituting unavailable Fonts

You can use PANOSE to access a list of TrueType fonts that can be
used as substitutes for fonts not installed on your computer. You
can accept a substitute font, or you can choose another font to
install. You can apply the substitution to the active drawing only
or apply it to all drawings.

You can also build a list of matches for uninstalled fonts and
specify the Windows equivalents for Macintosh fonts in a
drawing.

To change A FonT subsTiTuTion
1 Open a drawing.

2 In the PANOSE font matching results dialog box, enable one
of the following options:

* Temporary — displays the font of your choice in place of
the missing font, but only in the current session of the
drawing. The missing font remains applied to the text

* Permanent — substitutes the font of your choice for all
text objects in the drawing that use the missing font

CorelDRAW User Guide: Chaprer 17
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3

4

Choose the font match you want to substitute for each
missing font.

Choose a new font from the Substituted font list box.
. In order for the PANOSE font matching results dialog

box to display, the drawing that you open must
contain fonts that aren’t installed on your computer.

To build a list of marches for missing fonts

1

2
3
4

Click Tools » Options.
In the list of categories, double-click Text, and click Fonts.
Click PANOSE font matching.

In the PANOSE font matching preferences dialog box, click
Exceptions.

In the PANOSE font matching exceptions dialog box, click
Add.

In the Add matching exceptions dialog box, type the name of
the font you want to replace in the Missing font box.

Choose a font that is installed on your computer from the
Substituted font list.

To match A Windows font 10 A Macintosh Font

1

2
3
4

[=2IE) ]

Click Tools » Options.

In the list of categories, double-click Text, and click Fonts.
Click PANOSE font matching.

In the PANOSE font matching preferences dialog box, click
Spelling.

Click Add.

Choose a Windows font name from the Windows name box.
Type the Macintosh spelling for the font in the Macintosh
name box.

The PANOSE font matching feature works only with
CorelDRAW (.cdr) and CorelDRAW template (.cdt)
files, or with imported Adobe Illustrator files. It does
not work with text that you copy from the Clipboard.

From here

For more information about...

In the online Help Index,

type...

Smoothing font edges
Embedding fonts

Customizing font lists

fonts, smoothing
fonts, embedding

fonts, listing
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CorelDRAW 10 provides extensive options for printing your work.

In this section, you'll learn about
e printing your work
* laying out print jobs

* previewing print jobs

PRrinTiNG YOUR WORK

In CorelDRAW, you can print multiple copies of the same
drawing. You can specify what to print, as well as which parts of
a drawing to print; for example, you can print selected vectors or
bitmapped images.

Before printing a drawing, you can specify printer properties,
including paper size, graphics, and device options.

To SeET PRINTER PROPERTIES

1 Click File » Print.

2 Click the General tab.

3 Click Properties.

4 In the Properties dialog box, set any properties.

PRrinTingG
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To prinT your work
Click File » Print.
Click the General tab.

Choose a printer from the Name list box.

1

2
3
4

Type a value in the Number of copies box.

If you want the copies collated, enable the Collate check box.

Enable one of the following options:

Current document — prints the active drawing
Current page — prints the active page

Pages — prints the pages that you specify
Documents — prints the drawings that you specify

Selection — prints the objects that you specify

Yz

- You can preview your work by clicking on the Mini

J . .
SAN preview button on the title bar.

You must select objects before printing a selection.

To print selected vectors, bitmapped images, or
TEXT

1 Click File P Print.
2 Click the Misc tab.

3 In the Proofing options area, enable any of the following
check boxes:

® Print vectors
* Print bitmaps
® Print text

@: You can print graphics in full color, monochrome, or
&\ grayscale, by enabling the corresponding check boxes
in the Bitmap downsampling area.

You can print all text in black by enabling the Print all
text in black check box.

To print selected layers

1 Click Tools P Object manager.

2 Click the printer icon that corresponds to a layer.
3 Click File » Print.

Laying ouT pRINT jobs

You can lay out a print job by specifying the size, position, and
scale. Tiling a print job prints portions of each page on separate
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sheets of paper that you can assemble into one sheet. You would,
for example, tile a print job that is larger than your printer paper.

If the orientation of a print job differs from the orientation
specified in the printer properties, a message prompts you to
adjust the paper orientation of the printing device. You can
disable this prompt, so that the printer adjusts paper orientation
automatically.

To specify the size and position of A prinT job
1 Click File » Print.
2 Click the Layout tab.
3 Enable one of the following options:
* Asin document — sizes and positions the printed image

* Fit to page — sizes and positions the print job to fit to a
printed page

* Reposition images to — lets you reposition the print job
by choosing a position from the list box

2 Enabling the Reposition images to option lets you
specify size, position, and scale in the corresponding
boxes.

To tile A prinT job
Click File » Print.
Click the Layout tab.

1

2
3
4

Enable the Print tiled pages check box.

Type values in the following boxes:

Tile overlap — lets you specify the number of inches by
which to overlap tiles

% of page width — lets you specify the percentage of the
page width the tiles will occupy

# of tiles — lets you specify the number of horizontal and
vertical tiles

~ Enable the Tiling marks check box to include tiling
-

s7\Y alignment marks.

PRrinTingG
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To change The paGe oRrienNTATION prOMPT

1 Click Tools » Options.

2 In the list of categories, double-click Global, and click
Printing.

3 Choose Page orientation prompt from the Option list.

4 Choose one of the following from the Setting list box:
* Off — always match orientation
® On — ask if orientations differ

® Off — don’t change orientation

PRreviewing pRINT jobs

You can preview your work to show you how the position and
size of the print job will appear on paper. For a detailed view, you
can zoom in on an area. You can view how the individual color
separations will appear when printed. You can also increase the
speed of a print preview by hiding the graphics.

Before printing your work, you can view a summary of issues for
a print job to find potential printing problems. For example, you
can check the current print job for print errors, possible print
problems, and suggestions for resolving issues.

To preview A prinT job
e Click File » Print preview.

< You can also preview your work by clicking on the
&\ Mini preview button [®#] on the title bar.

To magnify The preview page

1 Click File P Print preview.

2 Click View » Zoom.

3 Enable the Percent option, and type a value in the box.

@: You can also magnify the preview page by choosing a
&\ preset zoom level.

You can also zoom in on a portion of the print
preview by clicking the Zoom tool Ei| in the
toolbox and marquee selecting an area.

To preview color sepArATiONS
1 Click File P Print preview.
2 Click View » Preview color » Color.
3 Click View » Preview separations P Separations.
%% You can only preview color separations if you have

enabled the Print separations check box under the
Separations tab in the Print dialog box.
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@: You can preview the composite by clicking View »
&\ Preview separations » Composite under the View
menu.

You can view individual color separations by clicking
on the tabs at the bottom of the application window.

To hide or display graphics
1 Click File » Print preview.
2 Click View » Show image.

A check mark beside the menu command name indicates the
graphic is displayed.

S When the Show image menu command is disabled,
é/ the print job is represented by a bounding box that
you can use to position and size the job.

To view A summary of issues for A prinT job
1 Click File » Print.
2 Click the Issues tab.
If you don’t want Preflight to check for certain issues, click

Settings, double-click Printing warnings, and disable any
check boxes that correspond to issues you want overlooked.

2 You can save settings by clicking the plus sign (+) and
sO\Y  typing a name in the Save preflight style box.

Commercial prinTing

With CorelDRAW, you can prepare a print job for commercial
printing.

In this section, you'll learn about

e preparing a print job for a service bureau

e working with imposition layouts

* printing printer’s marks

e specifying In-RIP trapping settings

PrepARiNG A pRINT job for A service bureau

You can use the Prepare for service bureau wizard to guide you
through the process of sending a file to a service bureau. The
wizard simplifies processes such as creating PostScript and PDF
files; gathering different pieces required for outputting an image;
and copying the original image, embedded image files, and fonts
to a user-defined location.

Printing a drawing to a file lets the service bureau send the file
directly to an output device. If a PostScript file is to be trapped or
imposed by a service bureau, you can ensure that the file
conforms to the Document Structuring Convention (DSC). If you
are unsure about which settings to choose, consult the service
bureau.

PRrinTingG
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You can include a job information sheet with all the prepress
settings that you have specified.

To use The Prepare for Service Bureau wizard
1 Click File » Prepare for service bureau.
2 Enable one of the following buttons:
® Gather all files associated with this document
® Choose a profile provided by your service bureau
3\ The PDF file settings created by the service bureau
are identical to the PDF for prepress style settings.
For information about the PDF for prepress style

settings, see “Saving documents as PDF files” on page
165.

To prinT 10 A File

1 Click File » Print.

2 Click the General tab.

3 Enable the Print to file check box.
4

Click the flyout arrow, and click one of the following
commands:

* For Mac — saves the drawing to be readable on a
Macintosh computer

* Single file — prints pages to a single file

* Pages to separate files — prints pages to separate files
* Plates to separate files — prints plates to separate files
5 Click Print.
Choose one of the following from the Save as type list box:
* Print file — saves the file as a .prn file
® PostScript file — saves the file as a .ps file
7 Choose the drive and folder where you want to save the file.
Type a filename in the File name box.
If you prefer not to prepare PostScript files, service
bureaus equipped with the application in which you
created your work can take the original files (for

example, CorelDRAW files) and apply the required
prepress settings.

7

To conform 10 DSC

1 Click File » Print.

2 Click the PostScript tab.

3 Enable the Conform to DSC check box.
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To include A job informaTion sheer with The print
job

Click File P Print.

Click the Misc tab.

Enable the Print job information sheet check box.
Click Info settings.

In the Information area, disable any of the options.

DU A W N =

In the Destination area, enable one of the following :
* send to text file

* send to printer

Working with imposition layouTs

Working with imposition layouts lets you print more than one
page of a document on each sheet of paper. You can choose a
preset imposition layout to create documents such as magazines
and books to print on a commercial printing press; produce
documents that involve cutting or folding, such as mailing labels,
business cards, pamphlets, or greeting cards; or print multiple
thumbnails of a document on one page. You can also edit a
preset imposition layout to create your own layout.

You can select a binding method by choosing from three preset
binding methods or you can customize a binding method. When

you choose a preset binding method, all but the first signature
are automatically arranged.

You can arrange pages on a signature manually or automatically.
When you arrange the pages automatically, you can choose the
angle of the image. If you have more than one page across or
down, you can specify the size of gutters between pages; for
example, you can choose the automatic gutter spacing option,
which sizes gutters so that the document’s pages fill the entire
available space in the layout.

When printing on a desktop printer, you can adjust the margins
to accommodate the nonprintable area of a page. If the margin is
smaller than the nonprintable area, the edges of some pages or
some printer’s marks may be clipped by your printer.

To choose A preser imposition layour

1 Click File P Print.

2 Click the Layout tab.

3 Choose an imposition layout from the Imposition layout list
box.

S\ The layout you choose does not affect the original
document, only the way it is printed.

PRrinTingG
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To edit an imposition layour

1
2
3

N O U s

Click File » Print.
Click the Layout tab.

Choose an imposition layout from the Imposition layout list
box.

Click Edit.
Edit any imposition layout settings.
Click Save layout on the property bar.
Type a name for the imposition layout in the Save as box.
o When editing an imposition layout, you should save it

with a new name; otherwise the settings for a preset
imposition layout will be overwritten.

To select A binding method

1
2
3

Click File » Print preview.
Click the Imposition layout tool FA .

Choose Edit basic settings from the What to edit list box on
the property bar.

Type values in the Pages across/down boxes.
If you want the page to be double-sided, click the
Single/double sided button.

Select one of the following binding methods from the Binding
mode list box:

* Perfect binding
* Saddle stitch
* Collate and cut

® Custom binding

If you choose either Perfect binding or Custom
binding, type a value in the corresponding box.

When you click the Single/double sided layout for
double-sided printing, and you are printing on a
nonduplex printing device, a wizard automatically
provides instructions on how to insert the paper into
the printer, so that you can print on both sides of the
page.

To ARRANGE pAGES

1
2
3

Click File » Print preview.
Click the Imposition layout tool Ek .

Choose Edit page placements from the What to edit list box
on the property bar.

Click one of the following buttons:
* Intelligent auto-ordering 'il|

* Sequential auto-ordering il

* Cloned auto-ordering &5

126

CorelDRAW User Guide: Chaprer 16



If you want to arrange the page numbering manually, click on
the page and specify the page number in the Page sequence
number box.

5 Choose an angle from the Page rotation list box.

To edit GuTTERS
1 Click File » Print preview.
2 Click the Imposition layout tool Elk .

3 Choose Edit gutters and finishing from the What to edit list
box on the property bar.

4 Click one of the following buttons:
* Auto gutter spacing ¥fj
* Equal gutters 2fj

5 Click one of the following buttons:
* Cut location ||
* Fold location L1

N\ If you click the Equal gutters button, you must
é/ specify a value in the Gutter size box.

You can edit the gutters only if you've selected an
imposition layout with two or more pages across and
down.

To Adjust mMARGiNS
1 Click File » Print preview.
2 Click the Imposition layout tool EJk .

3 Choose Edit margins from the What to edit list box on the
property bar.

4 Click one of the following buttons:
* Auto margins *%j

* Equal margins =fj

N If you click the Equal margins button, you must
specify values in the Top/left margin boxes.

When preparing a job for a commercial press, the
service bureau may request minimum margin sizes,
such as for page grippers and printer’s marks.

PRiNTING PRINTER’S MARkS

Printing printer’s marks lets you print information on a page
about how a drawing should be printed. You can set crop/fold
marks, bleed limits, and registration marks; print composite
crop/fold marks, color calibration marks, and densitometer
scales; and include page numbers and file information, such as
the job name and date. You can also specify the position of the
printer’s marks on the page.

The available printer’s marks are as follows:

PRrinTingG
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Crop/fold marks — represent the size of the paper and print
at the corners of the page. You can print crop/fold marks to
use as guides to trim the paper. If you print multiple pages
per sheet (for example, two rows by two columns) you can
choose to print the crop/fold marks on the outside edge of
the page so that all marks are removed after the cropping
process, or you can choose to add crop/fold marks around
each row and column.

Bleed limit — determines how far an image can extend
beyond the crop/fold marks. When you use a bleed to extend
the print job to the edge of the page, you must set a bleed
limit. A bleed requires that the paper you are printing on is
larger than the size of paper you ultimately want, and the

print job must extend beyond the edge of the final paper size.

Registration marks — are required to line up film for
proofing or printing plates on a color press. They print on
each sheet of a color separation.

Color calibration bars — are color scales that print on each
sheet of a color separation and ensure accurate color
reproduction. To see calibration bars, the page size of the
print job must be larger than the page size of the work you
are printing.

Densitometer scale — is a series of gray boxes ranging from
light to dark. These boxes are required to test the density of
halftone images. You can position the densitometer scale

anywhere on the page. You can also customize the levels of
gray that appear in each of the seven squares on the
densitometer scale.

Page numbers — help you collate pages of an image that do
not include any page numbers or do not contain page
numbers that correspond to the actual number of pages.

File information — prints file information, such as, the color
profile; halftone settings; name, date, and time the image was
created; plate number; and job name.

To print crop and fold marks

Click File » Print.

2 Click the Prepress tab.
3 Enable the Crop/fold marks check box.

If you want to print only the exterior crop/fold marks, enable
the Exterior only check box.

S\ . 1O print crop and fold marks, the paper on which you
k/ print must be 0.5 inches larger on all sides than the
page size of the image that you are printing.

@: To set crop and fold marks, see “To edit gutters” on
&\ page 157.
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To prinT composiTe crop/fold marks To print registrations marks, the paper on which you

/))/\,
1 Click Tools » Options. print must be 0.5 inches larger on all sides than the
2 In the list of categories, double-click Global, and click page size of the image that you are printing.
Printing. . . . .
rinting ) o To prinT color calibration bars and densitomeTer
3 Choose Composite crop marks from the Option list. scales
4 Choose Output in CMYK from the Setting list. 1 Click File » Print.

To seT A bleed limit 2 Click the Prepress tab.

1 Click File » Print. 3 In the Calibration bars area, enable any of the following

] check boxes:
Click the Layout tab.

2
3 Enable the Bleed limit check box.
4 Type a bleed limit in the Bleed limit box.

® Color calibration bar

* Densitometer scales

If you want to customize the levels of gray in one of the
densitometer scale squares, choose a number from the
Densities list (lower values represent lighter squares) and type
a new density for that square.

Usually, a bleed limit of .125 to .25 inches is
sufficient. Any object extending beyond that uses
memory needlessly and may cause problems when
you print multiple pages with bleeds on a single

2y

sheet of paper. To prRiNT paGe Numbers
Click File » Print.
Click the Prepress tab.

To prinT REGisTRATION MARkS

1 Click File » Print.

Click the Prepress tab. 3 Enable the Print page numbers check box.

2
3 Enable the Print registration marks button. If you want to position the page number inside the page,
4

Choose a registration mark style from the Style list box. enable the Position within page check box.
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To prinT File informaTioN

1 Click File » Print.

2 Click the Prepress tab.

3 Enable the Print file information check box.

4 Type a job name in the Job name/slug line box.

If you want to position the file information inside the page,
enable the Position within page check box.

To position prinTeR’s marks
1 Click File » Print preview.
2 Click the Marks placement tool ¥ .

3 Click the Auto-position marks rectangle button on the
property bar.

Specifying IN-RIP TRAppiING SETTINGS

In-RIP (raster image processor) trapping allows you to specify
advanced trapping settings. Before selecting In-RIP trapping,
ensure that your PostScript 3 printer has In-RIP options.

You can select a trap width — the amount that one color spreads
into another. You can also specify image trap placement, which
determines where the trap occurs. You can, for example, specify
whether the trap is a choke or a spread, depending upon the
neutral densities of adjacent colors. Neutral density indicates the
lightness or darkness of a color and helps determine how
adjacent colors spread into one another.

You can specify a threshold at which a trap will be created by
specifying a step trap limit. If trap colors are of similar neutral
densities, the trap placement will be adjusted accordingly. The

4 TType values in the Marks alignment rectangle boxes. step trap limit specifies a threshold at which a trap will adjust.
@: You can also change the position of printer’s marks Before trapping, you can set the inks; for example, you can set an
s“\Y by dlicking on a printer’s mark icon in the print ink to opaque, as in the case of a metallic ink, so that nothing

preview window and dragging the bounding box. shows through it. To reduce the visibility of a trap, you can
If you want to affix printer’s marks to the object’s decrease the amount of ink color in a trap. This is especially
bounding box instead of to the page bounding box, helpful in the case of pastel colors, contrasting colors, and colors
click the Prepress tab in the Print dialog box, and with similar neutral densities.
enable the Marks to objects button.
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Examples of image trap placement (from left to right): spread, choke, and
trapped object.

To select a TrRap width

1 Click File » Print.

Click the Separations tab.

Enable the In-RIP trapping check box.
Click Settings.

Type a value in the Trap width box.

u s W N

If you are trapping to black, type a value in the Black trap
width box.

o, 1O select In-RIP trapping options, you must have
selected PostScript 3 from the Compatibility list box
under the PostScript tab of the Print dialog box.

To specify image Trap placement

1

u s W N

Click File » Print.

Click the Separations tab.

Enable the In-RIP trapping check box.
Click Settings.

From the Image trap placement list box, choose one of the
following placements:

® Neutral density — used to determine the lighter object
and thus, the direction and placement of the trap

® Choke — used to trap a dark foreground object to a light
background image

® Spread — used to trap a light foreground object to a dark
background image

¢ Centerline — used when adjacent images and objects
have similar neutral densities or when image density
changes along an object’s edge

If you want to trap an object to an image, enable the Trap
objects to images option.

PRrinTingG

161



To specify a threshold To ser inks for TRApPpING
1 Click File » Print. 1 Click File b Print.
2 Click the Separations tab. 2 Click the Separations tab.
3 Enable the In-RIP trapping check box. 3 Enable the In-RIP trapping check box.
4 Click Settings. 4 Click Settings.
5 Type avalue in one or any of the following boxes: 5 Click Type, and for each color separation, select one of the
* Step limit — specifies a threshold between color following:
variations. The lower the threshold value, the more likely * Transparent — the selected ink doesn’t get trapped, but
it is that a trap will be created anything beneath it does
¢ Black limit — specifies the threshold at which process * Neutral density — the neutral density of the selected ink
black is considered pure black determines how it is treated
* Black density limit — specifies a neutral density value for * Opaque — the selected ink is treated as opaque
the black ink * Opaque ignore — the selected ink doesn’t get trapped
¢ Sliding trap limit — specifies the difference between the nor does anything beneath it
neutral densities of adjacent colors at which a trap adjusts .
(slides) from the darker side of a color edge toward the To select a Trap color reducTion
centerline. The lower the sliding trap limit, the more 1 Click File » Print.
gradual the transition. 2 Click the Separations tab.
3 Enable the In-RIP trapping check box.
4 Click Settings.
5 Type avalue in the Trap color reduction box.
N A reduction value of 100% indicates no reduction,
é/ while a lower value reduces the neutral density.
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From here

For more information about...

In the online Help Index, type...

Applying print styles

Fine tuning print jobs
Printing colors accurately
Printing to a PostScript device
Using Print Merge wizard
Setting up halftone screens
Maintaining OPI links

Printing color separations
Working with color trapping

Printing to film

printing, applying print styles
printing, fine tuning

colors, printing accurately
printing, PostScript printer
print merge, wizard

halftone screens, printing
printing, OPI links

color separations, printing
trapping

printing, to film
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Publishing To PDF

PDF is a file format designed to preserve fonts, images, graphics,
and formatting of an original application file.

In this section, you'll learn about

¢ saving documents as PDF files

Saving documents as PDF files

You can save a document as a PDF file. A PDF file can be viewed,
shared, and printed on any platform provided that users have
Adobe Acrobat or Acrobat Reader installed on their computers. A
PDF file can also be placed on an Intranet or the World Wide
Web. You can also export a selection or all of a document to a
PDF file.

When you save a document as a PDF file, you can choose from
five preset PDF styles, which apply settings that are specific to a
particular PDF style. For example, with the PDF for the Web style,
the resolution of the images in the PDF file will be optimized for
the World Wide Web. You can also create a PDF style or edit a
preset style.

To save A documenTt as A PDF file
1 Click File » Publish to PDE
2 From the PDF style list box, choose one of the following:

* PDF for document distribution — is best used for general
document delivery. These documents can be printed on a
laser or desktop printer.

Publishing To PDF
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PDF for prepress — contains LZW bitmap compression,
embeds fonts, and preserves spot color options best
designed for high-end quality printing. Consult the service
bureau for their preferred settings.

PDF for the Web — contains JPEG bitmap compression,
embeds fonts, and compresses text for publishing the
document to the World Wide Web.

PDF for editing — contains LZW compression, embeds all
fonts, and includes hyperlinks, bookmarks, and
thumbnails. It displays the PDF file with all the fonts, all of
the images at full resolution, and hyperlinks, so that you
can edit the file at a later date.

PDF/X-1 — contains ZIP bitmap compression, embeds
fonts, and preserves spot color options. This style contains
the basic settings for prepress.

3 Choose the drive and folder where you want to save the file.

4 Type a filename in the File name box.

From here

For more information about...

In the online Help Index, type...

Creating PDF files

Editing PDF files

PDF, creating and editing

PDF, creating and editing

For more information about...

In the online Help Index, type...

Including hyperlinks, bookmarks
and thumbnails in PDF files

Reducing PDF file size
Working with fonts in a PDF file

Exporting PDF files in an encoding
format

Setting the number of fountain
steps in PDF files

Embedding files in a PDF file
Outputting objects in PDF files

Preparing PDF files for a service
bureau

Viewing preflight summaries for
PDF files

Optimizing PDF files

PDF, including hyperlinks

PDF, reducing file size
PDF, fonts

PDF, exporting in encoding format

PDF, setting fountain steps

embedding files, PDF
PDF, outputting objects

PDF, preparing for service bureau

Preflight, for PDF files

PDF, optimizing files
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Publishing To The Web

You can ensure that your CorelDRAW files and objects publish to CorelDRAW provides options for publishing your document to
HTML successfully by setting document elements to be the World Wide Web. You can determine layout options, set link
Web-compatible, selecting the settings you want, and checking colors, and select HTML text preferences.

preflight issues. You can then use the HTML and images in HTML

authoring software for creating a Web site or page. You can check the download times of your Web page objects

through a browser preview. A statistics frame displays the times

In this section, you'll learn about of individual objects and entire pages for modems of different
e Preparing files and objects for Web publishing speeds.
e Uploading to the Web To change HTML layout exporT preferences
1 Click Tools » Options.
PRl:lp'AEqu files and ObJECTS for Web 2 Type values in the following boxes:
publisHING * Position tolerance — lets you specify the number of pixels
You can prepare your files and objects for the Web by setting text can be automatically nudged to avoid introducing
preferences and verifying the objects before you export them. rows or columns that are 1 or 2 pixels in size
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* Image white space — lets you specify the number of
pixels that can occur in an empty cell before it’'s merged
with an adjacent cell. This lets you avoid splitting a single
graphic that spans adjacent cells. Cells, or tables, are used
to position Internet objects in your Web document when
you choose the HTML Tables layout method.

* Position white space — lets you specify the amount of
white space allowed in an image. so that your published
HTML is simpler.

To change Text and link exporT preferences

To change

Do the following

HTML text export preferences

HTML link export preferences

Click Tools » Options. Click
Document, Publish to Web and
Text. Enable one of the following
options:

Export Web-compatible text as
text —exports the
Web-compatible text as text

Export all text as
images—exports the text images
and ensures compatibility for all
browsers

Export Web-compatible text as
text using TrueDoc—exports the
text using TrueDoc for use in
Netscape Communicator

Click Tools » Options. Click
Document, Publish to the Web
and Links. Enable the Underline
check box. Enable Normal link,
Active link, and Visited link check
boxes, and select a color for each.
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%*}A The link colors set in the Options dialog box will You can export your graphics to preset JPEG, GIF, or PNG formats.
override the default link colors used in the Web

browser, eliminating any conflict between link color To set Web preflight oprions

and your document’s page background color. 1 Click File » Publish to the Web » HTML.

Exporting all text as images increases download 2 Click the Issues tab.

times. 3 Choose Web output in the Preflight for drop-down list.
To view Web page performance 4 Chc: Settings. hecl for | d the Web publishi
1 Click Files » Publish to the Web » HTML. > il:ete ¢ Issues to check for list, expand the Web publishing

2 Click the General tab.

6 Deselect the issues you do not want to check.
3 Click the Browse preview button.

To publish to The Web

Publishing To HTML 1 Click File » Publish to the Web — HTML.

CorelDRAW provides several options for publishing your 2 Set the following options in the Publish to the Web dialog.
document or selection for use on the World Wide Web. You can * General — contains options for HTML layout, folder for
choose several options such as image format, HTML layout, HTML file and images, and file transfer protocol (FTP) site
export range, and file transfer protocol (FTP) site parameters for and export range. You can also select, add, and move
uploading your files. dialog presets.

You can publish your document as a single image, from which * Details — contains details of HTML files produced,
CorelDRAW creates an image map. An image map is a including page name and file name.

hypergraphic whose hotspots link to different URLs when you * Images — lists all images for the current HTML export.
view the HTML document with a browser. Note that image maps You can set individual objects to JPEG, GIF, and PNG.
will cause slow downloads for those with a slow Internet formats. Click Options to select presets for each image
connection. type.
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® Advanced — provides options for generating Javascript
and Cascading Style Sheets

* Summary — shows statistics for files according to various
download speeds

* Issues — a list of potential issues displays, including
explanations, suggestions, and tips

CorelDRAW assigns the extension .HTM to
documents you publish in the HTML format. By
default, .HTM files share the same name as the
CorelIDRAW .CDR source file and are saved in the last
folder you used to store exported Web documents.

@y

@: You can set all images to a single format — JPEG, GIF,

s\ or PNG — by clicking Tools » Options. In the list of
categories, double-click Document, Publish to the
Web, and click Image. Enable one of the image
format options.
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ImporTinGg ANd ExpoORTinG files

Corel applications provide filters that convert files from one
format to another when you import or export files. In this
section, you will learn about

e importing files

e exporting files

ImporTing files

Corel applications let you import files created in other
applications. For example, you can import a JPEG, GIF, or text file.
You can import a file and place it in the active application
window as an object. The imported file becomes part of the
active file. You can also import a file by opening it in a new
application window. While importing a graphic, you can resample

it to change the number of pixels, eliminate unusable detail, and
reduce the file size. You can also crop a graphic to select only the
exact area and size of the image you want to import.

To imporT A file inTo AN AcTive drAWING

1 Click File » Import.

Choose the drive and folder where the file is stored.
Choose a file format from the Files of type list box.

Click the filename.

Uu = W N

Enable any of the following check boxes:

* Link bitmap externally — lets you link a bitmapped image
externally instead of saving it in a file

CorelDRAW User Guide: Chaprer 19
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* Combine multi-layer bitmap — lets you import
bitmapped images that contain multiple layers

* Extract embedded ICC profile — lets you save the
embedded International Color Consortium (ICC) profile to
the color directory where the application was installed

® Check for watermark — lets you check for an encoded
Digimarc watermark when you import files

* Do not show filter dialog — lets you use the filter’s
default settings without opening its dialog box

® Maintain layers and pages — lets you maintain layers and
pages when importing files

@: You can also import a file by opening it in a new

&\ application window. For more information about
opening a file in a new application window, see “To
open a drawing” on page 18.

You can change the sorting order of the file formats
in the Files of type list box by choosing a sorting
method from the Sort type list box.

Exporting Files

Corel applications let you export and save files to a variety of file
formats that can be used in other applications. For example, you
can export a file to the JPEG or GIF format.

You can export a file to a selected file format. You can also export
a file by saving the open file under a different name or to a
different file format while leaving the open file in its existing
format.

To exporr a file
Click File » Export.
Choose a file format from the Files of type list box.

1
2
3

Type a filename in the File name box.

The file extension for the file format you choose is appended
to the filename automatically.

Enable any of the following check boxes:

Selected only — saves only the objects selected in the
active drawing

Web_safe_filenames — replaces the white space in a
filename with an underscore. Special characters are
replaced by characters suitable for Web-based filenames.

Do not show filter dialog — suppresses dialog boxes that
provide other options when exporting

Click Export.

7

If a dialog box for the export format opens, specify
the options you want. For detailed information about
file formats, see “File formats” in the online Help.
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2 To compress an image while exporting, choose a
&\ compression type from the Compression Type list
box.

To save A file To A different formar

1 Click File » Save as.

2 Choose a file format from the Files of type list box.
3 Type a filename in the File name box.

The file extension for the file format you choose is appended
to the filename automatically.

4 Enable any of the following check boxes:
* Selected only — saves only the objects selected in the
active drawing

* Web_safe_filenames — replaces the white space in a
filename with an underscore. Special characters are
replaced by characters suitable for Web-based filenames

¢ Embed fonts using TrueDoc — ensures that the fonts in a
drawing can be viewed on a computer on which those
fonts are not installed

¢ Save with embedded VBA project — saves a Visual Basic
for Applications (VBA) project in your file

5 Click Save.

From here

For more information about...
Importing files
File formats

Object linking and embedding
(OLE)

Filter technical notes

In the online Help Index, type...

importing files, overview
file formats

objects, linking

file formats

ImporTing ANd exporTing files
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Reference inforRmATION

The CorelDRAW 10 User Guide provides information about
concepts, as well procedures, to help you become productive
quickly. The Reference section in the online Help provides
additional information and technical notes about application
tools, procedures, and CoreDRAW concepts.

From here

For more information about... In the online Help Index, type...
Specifying memory options memory, specifying options
Viewing system information system information

Disabling warning messages warning messages

For more information about...

In the online Help Index, type...

Creating, applying, and editing
graphic or text styles

Customizing the Graphic and text
styles Docker window

Creating, applying, and editing
graphic or text styles

Creating and applying color styles

Editing and sorting color styles

styles, applying

graphic and text styles,
customizing docker window

styles, applying

color styles, creating and applying

color styles, sorting
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For more information about...

In the online Help Index, type...

For more information about...

In the online Help Index, type...

Moving and copying color styles
Working with templates
Creating layers

Changing and moving layers

Moving and copying objects
between layers

Viewing layers and objects
Printing layers

Setting multiple workspaces
Customizing keyboard shortcuts
Customizing menus
Customizing color palettes
Customizing toolbars

Customizing the property bar

color styles, moving
templates, working with
layers, creating

layers, changing and moving

layers, moving and copying
objects between

layers, viewing

printing, layers

multiple workspaces

keyboard shortcuts, customizing
menus, customizing

color palettes, customizing
toolbars, customizing

property bar, customizing

Customizing the status bar
Customizing filters
Customizing file associations

Automating application tasks- VBA

status bar, customizing
filters, customizing
file associations

VBA
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