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Introduction

What is Drive Image?

PowerQuest® Drive Image® 7.0 is a disaster recovery and backup 
solution. Wizards guide you through creating an exact copy, or 
backup image, of your hard drive. 

Drive Image also makes it easy to copy everything from your hard 
drive to a new hard drive when you upgrade the hardware in your 
computer. 

What Are the Benefits of Using Drive Image?

If you back up your computer, you can restore it after having a 
failure. Drive Image protects your valuable documents, pictures, 
financial records—and everything else you have on your computer. 
So if you have a catastrophic failure, instead of just getting some 
files back, you get the operating system, applications, and your data 
files from the drive. Having a good backup also lets you restore 
individual files and folders if necessary.

Using Drive Image protects you from the following problems:

• Virus attack
• Poorly performing software
• Faulty Internet downloads
• Hard drive failure
• Files accidentally deleted or overwritten
• Corrupted files
• Accidentally emptied the recycle bin
• Damaged hard drive partitions
• Partitions deleted by FDISK



Quick Start Guide2

Glossary

backup image – A file that includes all the data (including the 
operating system, applications, and user data) selected for backup.

backup location – Area where an image is saved. Drive Image can 
save images to a partition on the hard drive, a local USB or 
FireWire drive, a network directory, or external media such as a CD 
or DVD.

create – The process of saving the files that make up the operating 
system, applications, and data on a hard drive into an image, which 
can be compressed and stored in a separate location for backup.

drive – A partition on your hard drive or on a network that has been 
assigned a drive letter, such as C:\. 

PQRE – The PowerQuest Recovery Environment, used for 
recovering data when Windows is not operable on the backed up 
machine.
restore – The process of converting an image into files that make 
up the operating system, applications, and data on a hard drive.

See the glossary in the Drive Image user guide (UserGuide.pdf) on 
the Drive Image CD for more glossary definitions.

Troubleshooting

The Drive Image online help includes troubleshooting information. 
Click Help > Contents to display the online help.

The knowledge base at the PowerQuest web site, 
www.powerquest.com/support, also includes helpful 
troubleshooting information. 
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Getting More Information

This quick start guide is only a brief overview of the features 
available in Drive Image. For details beyond what is included in 
this manual, refer to the online help (Help > Contents) or the 
manual that is in PDF format in the \English\Docs folder on the 
Drive Image CD. 

Drive Image for Windows 2000, 
Windows XP

Getting Started

How Does Drive Image Work?

You do not have to choose individual files or folders to include in a 
backup image. Instead, you choose a drive to back up; Drive Image 
copies the contents of that drive into a file called a backup image. 

You can save the backup image to a hard drive, a local USB or 
FireWire drive, a network drive, or to removable media.

When you experience a problem with your computer or if you need 
to recover a file or folder for any reason, you can restore a file, 
folder, or an entire drive from your existing backups.

What’s New in Version 7.0?
• Improved network support – Previous versions of Drive 

Image required the use of Boot Disk Builder to save some 
backups to a network. In Drive Image 7.0, network support is 
built in, with no additional setup needed. Drive Image 7.0 also 
supports saving backup images to a shared network drive on a 
peer-to-peer network. 
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• Hot backups – Previous versions of Drive Image sometimes 
used DOS to create the actual backup images. Drive Image 7.0 
creates backups “hot,” without leaving Windows. 

• Ability to save backups to USB and FireWire drives and to 
DVD – With Drive Image 7.0, you can save backups to USB 
and FireWire drives and to DVD—as well as to a local drive, 
network drive, or other removable media (such as CD-R, 
CD-R/W, Zip, or Jaz drives). 

• ImageExplorer renamed – With version 7.0, ImageExplorer 
has been redesigned and renamed Backup Image Browser.

System Requirements 

Operating system Windows 2000 Professional, 
Windows XP Home, Windows XP 
Professional

For other operating systems, see 
“Drive Image for Windows 95, 98, 
Me, NT 4.0 Workstation” on page 19.

Processor Pentium 150 MHz or faster

RAM 256 MB

Hard drive free 
space

45 MB for program files

Storage space for your backup images, 
unless you choose to store them to a 
network or on removable media (The 
amount of space required for backups 
depends on the amount and type of 
files you back up.)
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Installing Drive Image

1 Insert the Drive Image CD. If the CD browser screen does not 
appear automatically, browse the CD and double-click 
AUTORUN.EXE.

2 (If prompted) Install the Microsoft .NET Framework. 

3 From the CD browser screen, click Install. 

4 At the welcome screen, click Next. 

5 Read the license agreement. Select I accept the terms in the 
license agreement, then click Next. 

6 (Optional) Click Change if you want to change the default 
location for the Drive Image program files.

7 Click Next. 

CD or DVD drive To see a list of supported drives, go to 
www.powerquest.com/driveimage.

To run the PQRE, you must be able to 
boot your machine from the CD or 
DVD drive, which usually requires 
making a change to BIOS settings. 
See the Drive Image online help for 
instructions on making the CD or 
DVD drive bootable.

Software When you install Drive Image, you 
will be prompted to install the 
Microsoft .NET Framework if it has 
not already been installed. (Requires 
40 MB of hard drive space)
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8 Click Yes or No to specify whether you will use Drive Image 
with a network.

9 If you have a network, the Agent Setup screen appears. Type a 
user name, domain or computer name, and password that will 
give Drive Image read-write access to the network for saving 
and restoring backups. Then click Next. 

The user information you provide must have administrative 
rights to the machine where the backup images will be stored.

10 Review the summary information, then click Install.

A progress screen shows the status of the installation. 

11 Click Finish when the install is complete. 

Testing the PQRE

As part of the installation process, you should test the PQRE to 
ensure it runs properly on your system. To test the PQRE, insert the 
Drive Image CD and boot your computer. (See the Drive Image 
online help for instructions on making your computer boot from a 
CD.) 
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The PQRE should run, displaying the following menu. 

If the PQRE does not run as expected, you can take action early to 
fix the problems. Then if your backed up machine experiences a 
catastrophic failure later, you’ll be assured that you can run the 
PQRE to recover the system or your data. 

The Drive Image online help and PDF user guide include PQRE 
troubleshooting information. 

Activating Drive Image

You must activate Drive Image. Otherwise, the software will expire 
in 30 days.
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1 From the Drive Image main screen, click Help > Activate 
Product. 

2 Read the license agreement, then select Accept license 
agreement to indicate that you accept the terms of the license 
agreement.

3 If you do not have a serial number for Drive Image (because 
you have not purchased the software), click Buy Now to pay 
for the software and receive a serial number. 

4 Type the Drive Image serial number from the DVD case or 
from the e-mail message you received from PowerQuest.

5 Click OK. 

The licenser distinguishes your computer from others without 
storing information about you or your computer’s hardware and 
software. Activating your software may trigger an optional 
registration. Registration data is generally used for demographic 
purposes and is not resold. You can opt out of marketing-oriented 
uses of your data as part of registration.
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Starting Drive Image

1 Click Start > Programs > PowerQuest Drive Image 7.0. 

Basic and Advanced Views 

Drive Image includes two views. The basic view (shown above) is 
the default. It incudes a menu bar, icons for common tasks in the 
right pane, and shortcuts for switching views and doing tasks in the 
left pane.

The basic view provides quick, easy access to the most commonly 
used features. 
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From the basic view, you can click View > Advanced to display 
the advanced view. 

The advanced view provides a quick overview of the drives on the 
machine, backup jobs you have created, the backup history for each 
drive, and Drive Image-related event messages. 

From the basic view, you can choose to back up a drive 
immediately. The advanced view lets you create backup jobs to 
schedule backups for the future and choose a regular schedule to 
repeat backups.

PowerQuest Backup Image Browser

The Backup Image Browser, included with Drive Image, simplifies 
the management and maintenance of your backup image files. 
Working within a single screen, you can view backup image file 
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contents, restore individual program and data files from the backup 
image, or you can mount a selected volume and share it across a 
network.

Opening the PowerQuest Backup Image Browser

1 From the Windows Start menu, click Programs > 
PowerQuest Drive Image > Backup Image Browser.

All the features of Backup Image Browser are accessed from the 
main program screen or by right-clicking anywhere in the tree pane. 

Tree pane – Shows a hierarchical tree view of all the backup image 
files that you have opened in the Backup Image Browser. From the 
left pane, you can:

• Mount or dismount a volume inside a backup image.
• Verify that the selected backup image file is valid.
• Browse folders inside a backup image.
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• View the properties of a selected backup image file.
• Open or close backup image files.

Content pane – Shows the contents of the selected drive, folder, 
backup image file, or volume. From the content pane, you can: 

• Restore selected files and folders from a backup image file.
• Mount or dismount a volume inside a backup image.
• View the contents of a selected file.
• View the properties of a selected volume.

Where Do I Go From Here?

Here’s a list of the things you can do with Drive Image, along with 
pointers on how to get started.  

What can I do? How do I get there?

Back up a drive now. From the right panel of the basic 
view, click Back Up Drives.

Back up a drive later. From the left panel of the 
advanced view, click Create 
Backup Job.

Back up a whole drive on a 
regular schedule.

From the left panel of the 
advanced view, click Create 
Backup Job.

See the backups I have 
scheduled.

From the advanced view, click 
the Backup Jobs tab.

Restore a file or folder 
from a backup image.

From the right panel of the basic 
view, click Restore Files or 
Folders.
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Creating Backup Images

When you create a backup, Drive Image takes a snapshot of your 
hard drive at a single point-in-time and saves it as a backup image 
(a *.V2i file). 

You may want to read “Deciding Where to Store Backups” on page 
15 before you back up your drives. 

Restore a backup image 
from within Windows.

From the right panel of the basic 
view, click Restore a Drive.

Restore a backup to recover 
a crashed machine.

Boot from the Drive Image CD to 
run the PowerQuest Recovery 
Environment.

See the history of backups 
done on a drive.

From the advanced view, click 
the Backup History tab.

Set a default location for 
backup images.

From the menu bar, click Tools > 
Options.

Copy the contents of my 
hard drive to a new hard 
drive.

From the right panel of the basic 
view, click Copy One Drive to 
Another.

Check to see if my backups 
are working the way they 
are supposed to.

From the advanced view, click 
the Events tab.

Send e-mail if backups do 
not work as planned.

From the menu bar, click Tools > 
Options, then click the 
Notifications tab.

What can I do? How do I get there?
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Creating a Single Backup

It is useful to create a backup if you are about to install a new 
product, some critical files have changed, or many file changes 
have occurred in a session, and you want to create a backup 
immediately.

1 From the basic view, click Back Up Drives. 

2 Follow the instructions in the wizard. If you want more 
detailed instructions, see the Drive Image online help or the 
Drive Image user guide.

Scheduling Backups

You can create backups at regular intervals you specify, such as 
every week or every month. You do so by creating backup jobs.

1 From the advanced view, click the Drives tab, then click 
Tools > Create Backup Job.



PowerQuest Drive Image 15

2 Complete the wizard, choosing the type of backup you want to 
create, where you want to save the backup image files, the 
schedule for creating backups, and other options. 

Deciding Where to Store Backups

You can save backup images to a local hard drive, local removable 
media, a network drive, or local USB or FireWire drives. Each 
option has advantages and disadvantages.  

Advantages Disadvantages

Hard drive Fast create and 
restore

Can schedule 
unattended backups

Inexpensive because 
drive space can be 
overwritten 
repeatedly

Uses valuable drive 
space

Vulnerable to loss if 
the hard drive fails

Removable 
media (local)

Protection from hard 
drive failure

Ideal for off-site 
storage

Reserves hard drive 
space for other uses

Cannot create 
unattended backups; 
process is manual

Media can be 
expensive

Restore can be 
slower than from 
other locations, 
especially for 
individual files and 
folders
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USB/FireWire 
drive (local)

Fast create and 
restore

Can schedule 
unattended backups

Drive space can be 
overwritten 
repeatedly

Off-site storage is 
possible

Reserves hard drive 
space for other uses

Additional expense 
for the drive itself

Must have supported 
storage device 
drivers to restore 
from the PQRE; 
could require 
additional media 
along with the 
PowerQuest recovery 
CD

Network drive Fast create and 
restore

Can schedule 
unattended backups

Inexpensive because 
drive space can be 
overwritten 
repeatedly

Protection from local 
hard drive failure

Must have supported 
NIC drivers to restore 
from the PQRE

Must understand and 
assign the 
appropriate rights for 
backups and restores

Advantages Disadvantages
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Restoring Backups

You can restore an entire backup, or you can restore files and 
folders from a backup. The following chart is an overview of the 
restore options and how to perform each type of restore. 

Problem How to restore needed backup

You can run Windows, 
but you have lost data, 
programs, or hardware 
files on a drive.

From the basic view, click Restore 
Files or Folders to start the Backup 
Image Browser. See “Using Backup 
Image Browser” on page 18.

You cannot run 
Windows and you have 
lost data, programs, or 
hardware files on a 
drive.

Boot your machine using the Drive 
Image CD to start the PowerQuest 
Recovery Environment (PQRE). 
From the PQRE menu, select 
Backup Image Browser. See 
“PQRE Troubleshooting” on page 
18.

You can run Windows, 
but you want to restore 
your machine to a point 
in time contained in a 
backup image.

From the basic view, click Restore a 
Drive. Complete the wizard to 
restore one of your backups.

Your machine has 
suffered a catastrophic 
failure. You cannot run 
Windows, and you need 
to restore a backup.

Boot your machine using the Drive 
Image CD to start the PQRE. From 
the PQRE menu, select System 
Restore. Complete the wizard to 
restore one of your backups.
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PQRE Troubleshooting

The PQRE can take a while to start up, so do not be alarmed if that 
is the case. 

If you cannot boot your machine from the Drive Image CD to run 
the PQRE, you may need to modify your system BIOS to make the 
CD or DVD a bootable drive. 

When you start the PQRE, you may not see your storage device or 
network drives. You may need to load the appropriate drivers as 
you boot to the PQRE.

See the “PQRE Troubleshooting” section of the Drive Image online 
help or user guide for information about solving any PQRE issues.

Using Backup Image Browser

You can restore files and folders from a backup image using 
Backup Image Browser. 

1 In the left pane, browse to the backup image (*.V2i). 

2 Double-click the backup image in the left pane to display the 
available folders and files. 

3 To display files, double-click folders in the backup image.

4 Select the file or folder you want to restore, then click File > 
Restore.

Copying Drives

You can use Drive Image to copy the operating system, 
applications, and data from one hard drive to another. This is 
especially useful if you are upgrading to a larger hard drive. 
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You can also use this feature to create a backup that is not 
compressed and saved as a backup image (*.V2i file).

You must have your hardware configured correctly before you can 
copy data from one drive to another. The Drive Image user guide 
and online help include additional information about preparing to 
copy drives.

1 From the basic view, click Copy One Drive to Another. 

2 The wizard will guide you through selecting the right drive to 
copy, the destination drive, and the options for copying the 
data from one drive to another.

Copying drives is like a create and restore operation combined. 
Drive Image copies all the data from one hard drive to another 
without creating an image file (*.V2i) in the process.

Drive Image for Windows 95, 98, 
Me, NT 4.0 Workstation
Drive Image 7.0 does not run under Windows 9x, Windows Me, or 
Windows NT 4.0 Workstation. If you have one of these operating 
systems, use the Drive Image CD that is marked for your operating 
system.

Getting Started

System Requirements

Under these operating systems, Drive Image requires a 
Pentium-compatible processor or higher, 32 MB RAM, 35 MB of 
hard drive space, a CD drive (any speed), and a high-density floppy 
disk drive. 
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Installing Drive Image

1 Insert the appropriate Drive Image CD into your CD drive.

2 If CD auto-run is enabled, the CD browser is displayed 
automatically when you place the Drive Image CD in your CD 
drive. If the CD auto-run is not enabled, insert the CD, click 
Start > Run, then type drive:\AUTORUN (where drive is 
the drive letter of your CD drive), then click OK.

3 Choose the option that matches what you want to do. 

You will be presented with an option to install Iomega, SCSI, and 
Fujitsu drivers. You do not need these drivers unless you have 
Iomega, SCSI, or Fujitsu hardware that requires them.

Using Drive Image the First Time

When you use Drive Image the first time, you are prompted to run 
one of two wizards. 

• Run the Initial Backup wizard if you want to create a backup to 
CD-R or CD-R/W. (Check www.powerquest.com/driveimage to 
see that your CD drive is supported.)
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• Run the Setup wizard if you want to make a special area 
(partition) on your hard drive for backups. The setup wizard 
will divide your hard drive, so some will be used for your 
existing data and some will be reserved for backup images.

Click Cancel if you do not want to run either wizard.

Creating Backup Images

1 Close all applications except Drive Image.

2 Click Start > Programs > PowerQuest > PowerQuest Drive 
Image 2002 > Drive Image 2002. 

3 Click Create Image. 

Shortcut: If you have created a backup image previously, the 
overview screen displays the settings that you used before. 
You can click Finish to create another image using the same 
settings.
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4 Click Select Drives to select the drives that you want to 
include in the backup image. Click the checkbox to the left of 
the drives you want to back up.

5 Click Select Destination to choose where the image will be 
saved. 

6 Click a drive in the Select location for image file box, or click 
Browse to select a filename and location for the image.

To save a backup to a network drive, you must create Drive 
Image network boot diskettes using Boot Disk Builder, then 
use those diskettes to create the backup image. The network 
diskettes enable Drive Image to see the network drive from 
DOS boot mode. See “Using Drive Image 2002 with Network 
Drives” in the Drive Image quick start guide (DM2002.pdf in 
the \English\Docs folder on the Drive Image CD).

7 (Optional) Click Options to select the compression level for 
the image, add a password to the image, split the image into 
multiple files, check for file system errors before creating the 
image, verify disk writes when creating the image, or verify 
image contents after creating the image.

For details about these options, click Help from the Options 
screen.

8 (Optional) Click Schedule to set a time for the image to be 
created if you do not want to create it immediately.

9 Click Finish.

10 If you are creating a backup image of the drive that includes 
your operating system or a drive that includes open files, click 
Yes to reboot the machine so Drive Image can create the image 
in boot mode.
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If you save an image to removable media, Drive Image will 
automatically span it across media as needed. The first segment of 
the image will have a PQI extension. Subsequent segments will be 
named with .001, .002, and so forth. For example, if your image 
spans two CDs, it might be named MyBackup.pqi and 
MyBackup.001.

Restoring Backups

If your computer is not performing well, you can restore a backup 
image to return the computer to the state it was in when you created 
the backup image. Any changes you made on your computer after 
creating the backup image (such as installing applications or saving 
data files) are lost when you restore the image. 

If you only want to restore files or folders from a backup, see 
“Restoring Files and Folders” on page 25.

1 From the Drive Image main screen, click Restore Image. The 
currently selected settings appear on the Overview screen.

2 Click Select Image File. 
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3 Select an image from the list, or click Browse to find the 
image. 

4 Click the checkboxes for the drives you want to restore.

5 Click Select Destination, and click the partition or unallocated 
space where you want the image to be restored. If you select a 
partition, it will be deleted before the backup image is restored. 

6 (Optional) Click the Restore to original locations checkbox if 
you want to restore the partitions to the location they were 
created from.

7 (Optional) To free up space for restoring partitions, click the 
checkbox for a partition, then click Delete Partition. This 
operation can be undone by clicking Undo Delete.
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8 (Optional) Click Options to change settings that affect how the 
image is restored, whether drives are hidden after they are 
restored, and whether drives should be restored as 
primary/logical drives or just logical drives. Click Help at the 
Options screen to display information about these settings.

9 Click Finish.

10 If your machine is set to boot from the CD drive first, remove 
the CD from the drive after you click Finish.

When Drive Image is ready to pull the image from the CD, you 
will be prompted to reinsert it. If you do not remove the CD, 
Drive Image DOS will boot from the CD, prompting you to 
choose the image and destination again. (If your computer is 
not set to boot from the CD drive first, this step is 
unnecessary.)

11 After restoring an image from a CD, remove the CD from the 
drive.

Restoring Files and Folders

ImageExplorer allows you to browse your backup images and 
restore files and folders from backups. 

1 Click Start > Programs > PowerQuest > PowerQuest Drive 
Image 2002 > ImageExplorer, or click ImageExplorer from 
the Drive Image main screen.

ImageExplorer works much like Backup Image Browser for 
restoring files and folders from a backup. See “Using Backup 
Image Browser” on page 18. You will browse to the *.PQI file 
instead of a *V2i file.
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Copying Drives

You can use Drive Image to copy the operating system, 
applications, and data from one hard drive to another. This is 
especially useful if you are upgrading to a larger hard drive. 

You can also use this feature to create a backup that is not 
compressed and saved as a backup image (*.PQI file).

You must have your hardware configured correctly before you can 
copy data from one drive to another. The CopyDrives.pdf file in the 
\English\Docs folder on the Drive Image CD gives instructions for 
copying drives, including the hardware setup required for 
upgrading to a new hard drive.

PowerQuest Technical Support
You must furnish your product license (serial) number when you 
contact PowerQuest for technical support.

Technical support for PowerQuest products is available beginning 
with the release of the product and ending six months after the 
release of the next major version of the product or after PowerQuest 
discontinues the product line.

Complimentary Technical  Support

PowerQuest’s complimentary technical support consists of 
self-help support tools that are available at 
www.powerquest.com/support (in English only).

• An easy-to-use, powerful knowledge base that helps you find 
answers to the most frequently asked product questions, as well 
as “how-to” procedures and technical information about all 
PowerQuest products. 

http://www.powerquest.com/support
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• Easy-to-use video clips that step you through product features. 

E-Mail Support

Requests for e-mail support in North America are processed 8:00 
am to 5:00 pm MST, Monday through Friday. To obtain e-mail 
technical support for specific technical questions, fill out the form 
at www.powerquest.com/support/ emsupport.cfm. You can choose 
an English, German, or French form from the Language 
drop-down list.

Fee-Based Support

PowerQuest’s fee-based technical support program consists of live 
telephone support during regular business hours (8:00 a.m. to 5:00 
p.m. MST, Monday through Friday). Step-by-step consultations on 
product features and functionality fall under the fee-based support 
program. 

Language Location Telephone Number and Fee

English U.S.A. 800-757-5049 at $30.00 USD per 
incident, charged to a credit card

English U.K. +44 (0)20 7341 5517 at $30.00 USD 
or €34.50 (Euros) per incident, 
charged to a credit card

French France +33 (0)1 69 32 49 30 at $30.00 USD 
or €34.50 (Euros) per incident, 
charged to a credit card

German Germany +49 (0)69 66 568 516 at $30.00 USD 
or €34.50 (Euros) per incident, 
charged to a credit card
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Fee-Based After-Hours Support

PowerQuest offers fee-based after-hours support by telephone only. 
After-hours support is designed for anyone who requires support 
outside of regular business hours (8:00 a.m. to 5:00 p.m. MST, 
Monday through Friday). The price is $95.00 USD per incident.
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