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PowerQuest® PartitionMagic® License Agreement

IMPORTANT: Read this before using your copy of PowerQuest software.

This document is a legal agreement between you (an individual or business) and PowerQuest Corporation. Use of the enclosed 
software indicates your acceptance of these terms. As used in this License Agreement, the term "Software" means the software 
included on the CD or disk media provided with this License Agreement. The term "Software" does not include any software that is 
covered by a separate license offered or granted by a person other than PowerQuest Corporation.

IF YOU DO NOT AGREE TO THESE TERMS AND CONDITIONS, EITHER DESTROY OR RETURN, INTACT, THE 
SOFTWARE PACKAGE, CONTAINING THE CD OR DISK MEDIA, TOGETHER WITH THE OTHER COMPONENTS OF 
THE PRODUCT TO THE PLACE OF PURCHASE FOR A REFUND OF THE PURCHASE PRICE.

1. PROPRIETARY RIGHTS. The Software and any accompanying documentation are the proprietary products of PowerQuest 
Corporation (PowerQuest) or its licensors and are protected under national laws and international treaty provisions. Ownership of 
the Software and all copies, modifications, translations, and merged portions thereof shall at all times remain with PowerQuest or 
its licensors.

2. GRANT OF LICENSE and TERM. The Software and accompanying documentation are being licensed to you, which means you 
have the right to use the Software only in accordance with this License Agreement. The Software is considered in use on a 
computer when it is loaded into temporary memory or installed into permanent memory.

PERSONAL LICENSE. This license is personal to you. You may not sublicense, lease, sell, or otherwise transfer the Software or 
any of the accompanying documentation to any other person. You may use the Software only for your own personal use if you are 
an individual, or for your own internal business purposes if you are a business.

COMPUTER-SPECIFIC LICENSE. Each permitted copy of the Software may be used only in connection with hard disks that are 
permanently connected to ONE specific computer (either a stand-alone computer or a computer connected to a network) owned or 
leased by you. Once a copy of the Software has been used on a computer, it may not be used on any other computer. If the Software 
is made available on a network, it may be accessed only by ONE specific computer. Once the Software has been accessed by ONE 
specific computer it may not be used on any additional computers without purchasing additional licenses.

NUMBER OF COPIES LICENSED. If you have NOT purchased a professional license or a multiple pack license, then you are 
authorized to use ONLY a single copy of the Software on a single computer. If you have purchased a professional license, refer to 
the Professional License Agreement for specific terms and conditions. If you have purchased a multiple pack license, you are 
authorized to use the software on NO MORE THAN the number of computers for which you have purchased licenses. All copies of 
the Software must include the PowerQuest copyright notice and other legal notices. To purchase a professional license or multiple 
pack license, contact PowerQuest at 1-800-379-2566 or sales@powerquest.com.

BOOTMAGIC SOFTWARE. If the Software includes a copy of PowerQuest BootMagic®, the rights granted in paragraph 2 do not 
apply to BootMagic. You may use ONE copy of BootMagic on ONE PC for evaluation purposes only. Additional licenses for 
BootMagic may be purchased from PowerQuest by contacting PowerQuest Sales at 1-800-379-2566 or sales@powerquest.com.

UPDATES AND SUPPORT. You are entitled to receive complementary technical support for a period of 90 days from your first 
call to PowerQuest technical support. This support period is valid during the life of the product, which commences when the 
product is released to manufacturing and ceases 6 months after the release of the next major version of the product. Technical 
support shall be limited to telephone or e-mail support from PowerQuest's offices, unless PowerQuest specifically agrees otherwise. 
You are entitled to receive Software updates (updates are indicated by version number changes to the right side of the decimal) in 
accordance with PowerQuest policies as announced from time to time on terms comparable to those offered to other users of the 
Software under the single-user license.

TERM. This license is effective from your date of purchase and shall remain in force until terminated. You may terminate the 
license and this License Agreement at any time by destroying the Software and the accompanying documentation, together with all 
copies in any form.

3. BACKUP COPY. Only ONE copy of the Software may be created for archival or backup purposes.

4. NONPERMITTED USES. Without the express prior written permission of PowerQuest, you may not (a) use, copy, modify, alter 
or transfer, electronically or otherwise, the Software or documentation except as expressly permitted in this License Agreement, or 
(b) translate, reverse program, disassemble, decompile, or otherwise reverse engineer the Software.

5. EXPORT CONTROLS. Certain uses of the Software by you may be subject to restrictions under U.S. regulations relating to 
exports and ultimate end uses of computer software. You agree to fully comply with all applicable U.S. laws and regulations, 
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including but not limited to the Export Administration Act of 1979 as amended from time to time and any regulations promulgated 
thereunder.

6. U.S. GOVERNMENT RESTRICTED RIGHTS. If you are acquiring the Software on behalf of any unit or agency of the United 
States Government, the following provision applies:  It is acknowledged that the Software and the documentation were developed 
at private expense and that no part is in the public domain and that the Software and documentation are provided with 
RESTRICTED RIGHTS. Use, duplication, or disclosure by the Government is subject to restrictions as set forth in subparagraph 
(c)(1)(ii) of the Rights in Technical Data and Computer Software clause at DFARS 252.227-7013 or subparagraphs (c)(1) and (2) 
of the Commercial Computer Software-Restricted Rights at 48 CFR 52.227-19, as applicable. Contractor/Manufacturer is 
PowerQuest Corporation/P.O. Box 1911/Orem, UT 84059-1911/U.S.A.

7. LIMITED WARRANTY. (a) PowerQuest warrants to you, the original end user, (i) that the Software, other than third-party 
software, will perform substantially in accordance with the accompanying documentation and (ii) that the Software is properly 
recorded on the disk media. This Limited Warranty extends for ninety (90) days from the date of purchase. PowerQuest does not 
warrant any third-party software that is provided with the Software, but PowerQuest agrees to pass on to you any warranties of the 
owner or licensor to the extent permitted by the owner or licensor. (b) This Limited Warranty does not apply to any Software that 
has been altered, damaged, abused, mis-applied, or used other than in accordance with this license and any instructions included on 
the Software and the accompanying documentation. (c) PowerQuest's entire liability and your exclusive remedy under this Limited 
Warranty shall be the repair or replacement of any Software that fails to conform to this Limited Warranty or, at PowerQuest's 
option, return of the price paid for the Software. PowerQuest shall have no liability under this Limited Warranty unless the 
Software is returned to PowerQuest or its authorized representative, with a copy of your receipt, within the warranty period. Any 
replacement Software will be warranted for the remainder of the original warranty period or 30 days, whichever is longer. (d) THIS 
WARRANTY IS IN LIEU OF AND EXCLUDES ALL OTHER WARRANTIES NOT EXPRESSLY SET FORTH HEREIN, 
WHETHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO ANY WARRANTIES OF MERCHANTABILITY, 
FITNESS FOR A PARTICULAR PURPOSE, NON-INFRINGEMENT, OR WARRANTIES ARISING FROM USAGE OF 
TRADE OR COURSE OF DEALING. (e) THIS WARRANTY GIVES YOU SPECIFIC LEGAL RIGHTS; YOU MAY HAVE 
OTHERS WHICH VARY FROM STATE TO STATE. (f) Your failure to return the enclosed registration card or complete the 
electronic registration included with the Software may result in PowerQuest's inability to provide you with updates to the Software, 
and you assume the entire risk of performance and result in such an event.

8. LIMITATION OF LIABILITY. IN NO EVENT SHALL POWERQUEST'S LIABILITY RELATED TO ANY OF THE 
SOFTWARE EXCEED THE LICENSE FEES ACTUALLY PAID BY YOU FOR THE SOFTWARE. EXCEPT FOR A RETURN 
OF THE PURCHASE PRICE UNDER THE CIRCUMSTANCES PROVIDED UNDER THE LIMITED WARRANTY, 
NEITHER POWERQUEST NOR ITS SUPPLIERS SHALL IN ANY EVENT BE LIABLE FOR ANY DAMAGES 
WHATSOEVER ARISING OUT OF OR RELATED TO THE USE OF OR INABILITY TO USE THE SOFTWARE, 
INCLUDING BUT NOT LIMITED TO DIRECT, INDIRECT, SPECIAL, INCIDENTAL, OR CONSEQUENTIAL DAMAGES, 
AND DAMAGES FOR LOSS OF BUSINESS PROFITS, BUSINESS INTERRUPTION, LOSS OF BUSINESS INFORMATION, 
OR OTHER PECUNIARY LOSS, EVEN IF POWERQUEST CORPORATION HAS BEEN ADVISED OF THE POSSIBILITY 
OF SUCH DAMAGES, WHETHER SUCH LIABILITY IS BASED ON CONTRACT, TORT, WARRANTY, OR ANY OTHER 
LEGAL OR EQUITABLE GROUNDS. BECAUSE SOME STATES DO NOT ALLOW THE EXCLUSION OR LIMITATION 
OF LIABILITY FOR CONSEQUENTIAL OR INCIDENTAL DAMAGES, THE ABOVE LIMITATION MAY NOT APPLY TO 
YOU.

9. NO WAIVER. Any failure by either party to this agreement to enforce a specific part of the agreement in a specific situation is 
not a waiver of rights under the agreement. The party may still enforce the rest of the agreement in that situation and may still 
enforce some or all of the agreement in other situations.

10. This License Agreement constitutes the entire agreement between you and PowerQuest pertaining to its subject matter. This 
License Agreement is governed by the laws of the State of Utah. Any litigation arising from this license will be pursued only in the 
state or federal courts located in the State of Utah. Even if part of the agreement is held invalid, the rest of the agreement is still 
valid, binding and enforceable.

Should you have any questions concerning this Agreement, or if you desire to contact PowerQuest Corporation for any reason, 
please write:  PowerQuest Corporation/P.O. Box 1911/Orem, UT 84059-1911/U.S.A.

© 1994-1999, PowerQuest Corporation. All rights reserved. U.S. patents 5,675,769; 5,706,472; and 5,930,831; other patents 
pending in the U.S.A. and elsewhere. PowerQuest and PartitionMagic are registered trademarks of PowerQuest Corporation.
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PowerQuest International Software License Agreement

IMPORTANT: Read this before using your copy of PowerQuest® PartitionMagic®.

(WARNING: For Austria, The Czech Republic, Hungary, Luxembourg, Poland, Slovakia, Slovenia and Switzerland, please refer to 
the German version of this Agreement)

This International Software License Agreement ("License") is a legal agreement between you, the "End User", and PowerQuest 
Corporation("PowerQuest").  Use of the enclosed software indicates the End User's acceptance of these terms.  As used in this 
License, the term "Software" means the software included on the CD or disk media provided with this License.  The term 
"Software" does not include any software that is covered by a separate license offered or granted by a person other than 
PowerQuest and this License does not grant any rights in such software.

IF THE END USER DOES NOT AGREE TO THESE TERMS AND CONDITIONS, THE END USER MUST EITHER 
DESTROY OR RETURN, INTACT, THE SOFTWARE PACKAGE, CONTAINING THE CD OR DISK MEDIA, TOGETHER 
WITH THE OTHER COMPONENTS OF THE PRODUCT TO THE PLACE OF PURCHASE.

1. PROPRIETARY RIGHTS.  The Software and any associated documentation are proprietary products of PowerQuest or its 
licensors and are protected under U.S. and European copyright, trademark, patent, and trade secret laws and international treaty 
provisions.  Sole ownership of the Software and all copies, modifications, translations, and merged portions thereof shall at all 
times remain with PowerQuest or its licensors.

2. GRANT OF LICENSE AND TERM. PowerQuest hereby grants to the End User a non-exclusive, non-transferable license to use 
the Software only in accordance with the terms of this License.  The Software is considered in use on a computer when it is loaded 
into temporary memory or installed into permanent memory.

a. PERSONAL LICENSE.  This License is personal (including with respect to corporate entities) to the End User and the End User 
shall not assign or transfer any interest in it or grant any right under it to any third party or seek to exercise this License for the 
benefit or on the data of any third party.

b. COMPUTER-SPECIFIC LICENSE.  Each permitted copy of the Software may be used only in connection with a hard drive(s) 
that is (are) permanently connected to ONE specific computer (either a stand-alone computer or a computer connected to a 
network) owned or leased by the End User.  Once a copy of the Software has been used on a computer, it may not be used on any 
other computer.  If the Software is made available on a network, it may be accessed only by ONE specific computer.  Once the 
Software has been accessed by ONE specific computer it may not be used on any additional computers without purchasing 
additional licenses.

c. NUMBER OF COPIES LICENSED.  If the End User has NOT purchased a PROFESSIONAL LICENSE or a MULTIPLE 
PACK LICENSE, then the End User is authorized to use ONLY a single copy of the Software on a single computer.  If the End 
User has purchased a  PROFESSIONAL LICENSE, the End User must refer to the Professional License Agreement for specific 
terms and conditions.  If the End User has purchased a MULTIPLE PACK LICENSE, the End User is authorized to use the 
software on NO MORE THAN the number of computers for which the End User has purchased licenses.  All copies of the 
Software must include the PowerQuest copyright, confidentiality, trademark, and patent notices..  To purchase a  PROFESSIONAL  
LICENSE or MULTIPLE PACK LICENSE, contact PowerQuest International Sales at 1(801)437-8900 or 
intlsales@powerquest.com.

d. TERM.  (i) This License is effective from the date of purchase of the License and shall remain in force until terminated.  The 
End User may terminate this License at any time by destroying the Software and its associated documentation, together with all 
copies in any form.  (ii) Notwithstanding subparagraph d(i) above, this License may be terminated at any time by written notice of 
termination given by PowerQuest to the End User in any of the following circumstances:  (A) If the End User shall expressly or 
impliedly repudiate this License by refusing or threatening to refuse to observe any of the conditions to which this License is 
subject; or (B) If the End User shall fail to make any payment due under and pursuant to this License or to observe any of the 
conditions to which this License is subject and, after the End User's attention has been drawn by notice to such failure, shall fail to 
remedy the matter to PowerQuest's reasonable satisfaction within thirty days of the giving of such notice; or (C) If the End User 
shall have a receiver or administrative receiver or administrator appointed or shall enter into liquidation whether compulsory or 
voluntary or if the End User shall be unable to pay its debts as and when they fall due.  (iii) On expiry, surrender or other 
termination of this License, however such termination may arise, the End User shall cease to load, store, copy or use the Software 
and the associated documentation, shall delete the Software from its computers and shall either surrender the Software and the 
associated documentation, together with all copies in any form, to PowerQuest or shall destroy the same.  The End User shall 
continue after termination to observe and enforce confidentiality and secrecy in respect of the Software and its associated 
documentation for the benefit of PowerQuest, and however termination may occur it shall not prejudice any right of action or 
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remedy which may have occurred prior to termination.

3. BACKUP COPY.   The End User may make a single copy of the Software solely for backup purposes.  All copies of the 
Software must include the PowerQuest copyright, confidentiality, trademark, and patent notices.

4. INTEGRITY OF THE SOFTWARE.  The End User shall not enhance or vary any part of the Software nor procure or permit the 
whole or any part of the Software (whether in its original or in any updated, enhanced or varied form) to be incorporated into any 
other software or computer system.  Translations, reverse programming, disassembling and reverse engineering of the Software are 
expressly prohibited.  Provided, however, that nothing in these conditions shall restrict (i) decompilations, notwithstanding that 
decompilation may involve adaptation, if the sole purpose of such decompilation is to achieve the interoperability of an 
independently created program with other programs, or (ii) any other act permitted to the End User by applicable laws and 
regulations of the End User's jurisdiction.

5. UPDATES AND SUPPORT.  The End User is entitled to receive 90-days technical support from the date of purchase.  
Technical support shall be limited to telephone or e-mail support from PowerQuest's offices, unless PowerQuest specifically agrees 
otherwise.  The End User is entitled to receive Software updates (updates are only version number changes to the right side of the 
decimal) in accordance with PowerQuest policies as announced from time to time on terms comparable to those offered to other 
users of the Software under the  Professional License.

6. EXPORT CONTROLS.  Certain uses of the Software by the End User  may be subject to restrictions under U.S. regulations 
relating to exports and ultimate end uses of computer software.  The End User agrees to fully comply with all applicable U.S. laws 
and regulations, including but not limited to the Export Administration Act of 1979 as amended from time to time and any 
regulations promulgated thereunder.

7. LIMITED WARRANTY. (a) PowerQuest warrants to the End User, (i) that the Software (not including any third-party software) 
will perform substantially in accordance with the associated documentation and (ii) that the Software is properly recorded on the 
disk media.  This Limited Warranty extends for ninety (90) days from the date of purchase of this License.  PowerQuest does not 
warrant any third-party software that is provided with the Software, but PowerQuest agrees to pass on to the End User any 
warranties of the owner or licensor to the extent permitted by the owner or licensor.  (b) This Limited Warranty does not apply to 
any Software that has been altered, damaged, abused, mis-applied, or used other than in accordance with this License and any 
instructions included on the Software and the associated documentation.  (c) PowerQuest's entire liability  under this Limited 
Warranty shall be the repair or replacement of any Software that fails to conform to this Limited Warranty or, at PowerQuest's 
option, the return of the price paid for this License.  PowerQuest shall have no liability under this Limited Warranty unless the 
Software is returned to PowerQuest or its authorized representative, with a copy of the End User's receipt, within the warranty 
period.  Any replacement Software will be warranted for the remainder of the original warranty period or 30 days, whichever is 
longer.  (d) THIS WARRANTY IS IN LIEU OF AND EXCLUDES ALL OTHER WARRANTIES NOT EXPRESSLY SET 
FORTH HEREIN, WHETHER EXPRESS OR IMPLIED, SUBJECT TO CONTRARY ORDRE PUBLIC REQUIREMENTS IN 
THE END USER'S JURISDICTION. (e) The End User's failure to return the enclosed registration card or complete the electronic 
registration included with the Software may result in PowerQuest's inability to provide the End User with updates to the Software, 
and the End User assumes the entire risk of performance and result in such an event.

8. CONFIDENTIALITY AND CONTROL OF THE SOFTWARE.  The Software, all associated documentation, and all copies are 
secret and confidential to PowerQuest and shall be retained under the effective control of the End User during the period of this 
License.  The End User shall take all measures necessary to preserve confidentiality and secrecy in the Software during the period 
of this license and after its termination, however such termination may arise.

9. INDEMNITIES AND LIMITATION OF LIABILITY.  (a) Subject to 9(b) below, PowerQuest warrants to the End User that the 
Software as supplied by PowerQuest will not infringe any copyright, patent or other intellectual property right of any third party.  
Conditionally upon the End User's promptly giving notice to PowerQuest of any claim of alleged infringement and allowing 
PowerQuest to have sole control of negotiations on, and any defense of the claim, PowerQuest shall in its discretion and at its own 
cost either compromise or defend the claim and shall hold the End User harmless from any resulting final judgment, order or 
settlement.  PowerQuest shall have the right to replace or change the Software so as to avoid infringement and require the End User 
to accept a license to use such replaced or changed Software in substitution for this License, provided that the Software as 
substituted is substantially suitable for the End User's utilization.  (b) PowerQuest's maximum liability to the End User under 9(a) 
above shall not exceed the License fees actually paid by the End User for the Software.  If PowerQuest becomes aware of a 
potential claim under 9(a) above, PowerQuest shall be entitled then or at any time thereafter to discharge its liabilities (including 
potential, accruing and accrued liabilities) to the End User under 9(a) above by requiring the End User to surrender this License and 
to cease use of the Software upon PowerQuest's paying to the End User a sum equivalent to the maximum amount of PowerQuest's 
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liability as stated above.  (c) GENERAL LIMITATION OF LIABILITY AND INDEMNITIES.  POWERQUEST'S MAXIMUM 
LIABILITY RELATED TO ANY OF THE SOFTWARE SHALL NOT EXCEED THE LICENSE FEES ACTUALLY PAID BY 
THE END USER FOR THE SOFTWARE.  

FOR BELGIUM, FRANCE, IRELAND, AND THE NETHERLANDS:  IN NO EVENT SHALL POWERQUEST BE LIABLE 
TO THE END USER, EXCEPT IN RESPECT OF (a) DEATH, PERSONAL INJURY OR DAMAGE TO PROPERTY CAUSED 
BY POWERQUEST'S NEGLIGENCE OR (b) POWERQUEST'S GROSS NEGLIGENCE OR WILLFUL MISCONDUCT, FOR 
AN AMOUNT IN EXCESS OF THE MAXIMUM AMOUNT OF POWERQUEST'S LIABILITY AS STATED IN 9(b) ABOVE, 
BY REASON OF ANY REPRESENTATION OR IMPLIED WARRANTY, CONDITION OR OTHER TERM OR ANY DUTY 
AT LAW, OR UNDER THE TERMS OF THIS AGREEMENT, FOR ANY CONSEQUENTIAL LOSS OR DAMAGE 
(WHETHER FOR LOSS OF PROFIT, BUSINESS INTERRUPTION, LOSS OF BUSINESS INFORMATION OR OTHERWISE) 
ARISING OUT OF OR IN CONNECTION WITH ANY ACT OR OMISSION OF POWERQUEST RELATING TO THE USE 
OR INABILITY TO USE THE SOFTWARE BY THE END USER. 

FOR GREECE: IN NO EVENT SHALL POWERQUEST BE LIABLE TO THE END USER, EXCEPT IN RESPECT OF 
DEATH, DAMAGE TO PROPERTY OR PERSONAL INJURY CAUSED BY POWERQUEST'S FRAUD OR GROSS 
NEGLIGENCE, FOR AN AMOUNT IN EXCESS OF THE MAXIMUM AMOUNT OF POWERQUEST'S LIABILITY AS 
STATED IN 9(b) ABOVE, BY REASON OF ANY REPRESENTATION OR IMPLIED WARRANTY, CONDITION OR 
OTHER TERM OR ANY DUTY AT LAW, OR UNDER THE TERMS OF THIS AGREEMENT, FOR ANY CONSEQUENTIAL 
LOSS OR DAMAGE (WHETHER FOR LOSS OF PROFIT, BUSINESS INTERRUPTION, LOSS OF BUSINESS 
INFORMATION OR OTHERWISE) ARISING OUT OF OR IN CONNECTION WITH ANY ACT OR OMISSION OF 
POWERQUEST RELATING TO THE USE OR INABILITY TO USE THE SOFTWARE BY THE END USER.  

FOR ITALY: IN NO EVENT SHALL POWERQUEST BE LIABLE TO THE END USER, EXCEPT IN RESPECT OF DEATH, 
DAMAGE TO PROPERTY OR PERSONAL INJURY CAUSED BY POWERQUEST'S FRAUD OR GROSS NEGLIGENCE OR 
VIOLATION OF A DUTY ARISING FROM APPLICABLE ORDINE PUBBLICO RULES, FOR AN AMOUNT IN EXCESS 
OF THE MAXIMUM AMOUNT OF POWERQUEST'S LIABILITY AS STATED IN 9(b) ABOVE, BY REASON OF ANY 
REPRESENTATION OR IMPLIED WARRANTY, CONDITION OR OTHER TERM OR ANY DUTY AT LAW, OR UNDER 
THE TERMS OF THIS AGREEMENT, FOR ANY CONSEQUENTIAL LOSS OR DAMAGE (WHETHER FOR LOSS OF 
PROFIT, BUSINESS INTERRUPTION, LOSS OF BUSINESS INFORMATION OR OTHERWISE) ARISING OUT OF OR IN 
CONNECTION WITH ANY ACT OR OMISSION OF POWERQUEST RELATING TO THE USE OR INABILITY TO USE 
THE SOFTWARE BY THE END USER.  

FOR DENMARK, FINLAND AND NORWAY: IN NO EVENT SHALL POWERQUEST BE LIABLE TO THE END USER, 
EXCEPT (i) IN RESPECT OF DEATH OR PERSONAL INJURY CAUSED BY POWERQUEST'S GROSS NEGLIGENCE OR 
WILLFUL MISCONDUCT OR (ii) IF SUCH LIABILITY LIMITATION IS UNREASONABLE UNDER ALL RELEVANT 
CIRCUMSTANCES, FOR AN AMOUNT IN EXCESS OF THE MAXIMUM AMOUNT OF POWERQUEST'S LIABILITY AS 
STATED IN 9(b) ABOVE, BY REASON OF ANY REPRESENTATION OR IMPLIED WARRANTY, CONDITION OR 
OTHER TERM OR ANY DUTY AT LAW, OR UNDER THE TERMS OF THIS AGREEMENT, FOR ANY CONSEQUENTIAL 
LOSS OR DAMAGE (WHETHER FOR LOSS OF PROFIT, BUSINESS INTERRUPTION, LOSS OF BUSINESS 
INFORMATION OR OTHERWISE) ARISING OUT OF OR IN CONNECTION WITH ANY ACT OR OMISSION OF 
POWERQUEST RELATING TO THE USE OR INABILITY TO USE THE SOFTWARE BY THE END USER.  

FOR PORTUGAL: IN NO EVENT SHALL POWERQUEST BE LIABLE TO THE END USER, EXCEPT IN RESPECT OF 
DEATH, DAMAGE TO PROPERTY OR PERSONAL INJURY CAUSED BY POWERQUEST'S GROSS NEGLIGENCE OR 
WILLFUL MISCONDUCT, FOR AN AMOUNT IN EXCESS OF THE MAXIMUM AMOUNT OF POWERQUEST'S 
LIABILITY AS STATED IN 8(b) ABOVE, BY REASON OF ANY REPRESENTATION OR IMPLIED WARRANTY, 
CONDITION OR OTHER TERM OR ANY DUTY AT LAW, OR UNDER THE TERMS OF THIS AGREEMENT, FOR ANY 
CONSEQUENTIAL LOSS OR DAMAGE (WHETHER FOR LOSS OF PROFIT, BUSINESS INTERRUPTION, LOSS OF 
BUSINESS INFORMATION OR OTHERWISE AND WHETHER OCCASIONED BY POWERQUEST'S NEGLIGENCE OR 
ITS AGENTS OR OTHER REPRESENTATIVES) ARISING OUT OF OR IN CONNECTION WITH ANY ACT OR OMISSION 
OF POWERQUEST RELATING TO THE USE OR INABILITY TO USE THE SOFTWARE BY THE END USER.  

FOR SPAIN: IN NO EVENT SHALL POWERQUEST BE LIABLE TO THE END USER, EXCEPT IN RESPECT OF DEATH, 
DAMAGE TO PROPERTY OR PERSONAL INJURY CAUSED BY POWERQUEST'S  BAD FAITH CONDUCT, FOR AN 
AMOUNT IN EXCESS OF THE MAXIMUM AMOUNT OF POWERQUEST'S LIABILITY AS STATED IN 9(b) ABOVE, BY 
REASON OF ANY REPRESENTATION OR IMPLIED WARRANTY, CONDITION OR OTHER TERM OR ANY DUTY AT 
LAW, OR UNDER THE TERMS OF THIS AGREEMENT, FOR ANY CONSEQUENTIAL LOSS OR DAMAGE (WHETHER 
FOR LOSS OF PROFIT, BUSINESS INTERRUPTION, LOSS OF BUSINESS INFORMATION OR OTHERWISE) ARISING 
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OUT OF OR IN CONNECTION WITH ANY ACT OR OMISSION OF POWERQUEST RELATING TO THE USE OR 
INABILITY TO USE THE SOFTWARE BY THE END USER.  

FOR SWEDEN: IN NO EVENT SHALL POWERQUEST BE LIABLE TO THE END USER, EXCEPT IN RESPECT OF 
DEATH, DAMAGE TO PROPERTY OR PERSONAL INJURY CAUSED BY POWERQUEST'S  GROSS NEGLIGENCE OR 
WILLFUL MISCONDUCT, FOR AN AMOUNT IN EXCESS OF THE MAXIMUM AMOUNT OF POWERQUEST'S 
LIABILITY AS STATED IN 9(b) ABOVE, BY REASON OF ANY REPRESENTATION OR IMPLIED WARRANTY, 
CONDITION OR OTHER TERM OR ANY DUTY AT LAW, OR UNDER THE TERMS OF THIS AGREEMENT, FOR ANY 
CONSEQUENTIAL LOSS OR DAMAGE (WHETHER FOR LOSS OF PROFIT, BUSINESS INTERRUPTION, LOSS OF 
BUSINESS INFORMATION OR OTHERWISE) ARISING OUT OF OR IN CONNECTION WITH ANY ACT OR OMISSION 
OF POWERQUEST RELATING TO THE USE OR INABILITY TO USE THE SOFTWARE BY THE END USER.  

FOR THE UNITED KINGDOM: IN NO EVENT SHALL POWERQUEST BE LIABLE TO THE END USER, EXCEPT IN 
RESPECT OF (a) DEATH OR PERSONAL INJURY CAUSED BY POWERQUEST'S NEGLIGENCE OR (b) DAMAGE TO 
PROPERTY OR OTHER LOSS CAUSED BY POWERQUEST WHERE SUCH LIABILITY LIMITATION IS 
UNREASONABLE UNDER ALL RELEVANT CIRCUMSTANCES.  FOR AN AMOUNT IN EXCESS OF THE MAXIMUM 
AMOUNT OF POWERQUEST'S LIABILITY AS STATED IN 9(b) ABOVE, BY REASON OF ANY REPRESENTATION OR 
IMPLIED WARRANTY, CONDITION OR OTHER TERM OR ANY DUTY AT LAW, OR UNDER THE TERMS OF THIS 
AGREEMENT, FOR ANY CONSEQUENTIAL LOSS OR DAMAGE (WHETHER FOR LOSS OF PROFIT, BUSINESS 
INTERRUPTION, LOSS OF BUSINESS INFORMATION OR OTHERWISE) ARISING OUT OF OR IN CONNECTION WITH 
ANY ACT OR OMISSION OF POWERQUEST RELATING TO THE USE OR INABILITY TO USE THE SOFTWARE BY 
THE END USER.

10. This License constitutes the entire agreement between the End User and PowerQuest pertaining to its subject matter.  This 
License is governed by the laws of the State of Utah (except that body of laws controlling conflict of laws).  Any litigation arising 
from this license will be pursued only in the state or federal courts having appropriate jurisdiction located in the State of Utah.  
Even if part of the agreement is held invalid, the rest of the agreement shall still be valid, binding and enforceable.  The failure of 
either party to exercise a right does not waive future exercise of that right or other rights.

Should the End User have any questions concerning this License, or if the End User desires to contact PowerQuest for any reason, 
please write:  PowerQuest Corporation, PO Box 1911, Orem, UT 84059-1911, U.S.A.

© 1994-1999, PowerQuest Corporation.  All rights reserved.  U.S. patents 5,675,769, 5,706,472, and 5,930,831; other patents 
pending in the U.S.A., the European Union, and elsewhere.  PowerQuest and PartitionMagic are registered trademarks of 
PowerQuest Corporation.
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About This Guide

This user guide can help you set up and use PowerQuest® PartitionMagic®. 

The information and screen shots in this user guide are for Windows 95® and Windows 
98. However, the information is applicable no matter which version you are using. Where 
there are differences between executables, they are noted.

The user guide consists of the following sections: 

• The Introduction  provides an overview of PartitionMagic and outlines hardware and 
software requirements.

• Chapter 1: Getting Started outlines step-by-step instructions on installing, running, 
and navigating PartitionMagic.

• Chapter 2: Automating Tasks provides an overview of PartitionMagic’s wizards to 
create partitions, redistribute free space, resize partitions, and merge partitions. This 
chapter also provides an overview of scripting for PartitionMagic Pro.

• Chapter 3: Completing Hard Disk Operations provides information about and 
step-by-step instructions on using the Operations menu options, such as Resize/Move, 
Create, and Format.

• Chapter 4: Completing Advanced Operations explains how to use advanced 
partitioning operations, such as setting an active partition and resizing clusters.

• Chapter 5: Converting Partitions provides step-by-step instructions on converting 
from one file system to another, for example, converting FAT to FAT32.

• Chapter 6: Using PartitionMagic Utilities explains how to use the utilities included 
with PartitionMagic, such as DriveMapper™, and MagicMover™.

• Chapter 7: Using BootMagic provides an overview of BootMagic and instructions 
for some common BootMagic tasks.

• Appendix A: Using PartitionMagic with Other Programs provides information 
about using PartitionMagic with programs such as disk compression utilities and 
virus protection software.

• Appendix B: Troubleshooting provides answers to problems you may encounter 
while using PartitionMagic and describes error messages and their solutions.

• Appendix C: PowerQuest Technical Support covers what you should do before 
contacting technical support and provides information on various technical support 
options.

• The Index helps you locate topics discussed in the user guide.
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Introduction
This section includes the following information:

• What Is PartitionMagic?

• New Features

• PartitionMagic System Requirements

• Before Running PartitionMagic
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What Is PartitionMagic?

Imagine how disorganized your office would be if you kept all your files in one drawer. 
Surprisingly, this is similar to the way many people organize the space on their hard disks. 
With PartitionMagic, you can quickly and easily create partitions, which act as “file 
drawers,” on your hard disks for storing valuable information such as data files, 
applications, and operating systems. Storing information in separate partitions helps you 
organize and protect your data, safely run multiple operating systems, and reclaim wasted 
disk space.

PartitionMagic enables you to secure your data by physically separating it from other files. 
Separate partitions also make backups to networks and removable drives easy.

PartitionMagic helps you reliably run multiple operating systems on the same computer. 
Some versions of PartitionMagic also include BootMagic, a powerful boot manager that 
helps you safely install new operating systems and lets you choose which operating 
system you want to use when starting your computer.

Because of limitations with the FAT file system (for DOS, Windows 95, and Windows 98), 
as much as 40 percent of your hard disk space can be wasted. PartitionMagic reclaims 
wasted space quickly and safely by using more efficient partition sizes. It can also convert 
FAT partitions to FAT32 and vice versa.

In addition to powerful partitioning features, PartitionMagic offers a variety of other 
options. For instance, you can perform partitioning operations and view the changes that 
will be made before applying them to your system. Additionally, you can view 
comprehensive information about your hard disk geometry and your hardware system, and 
you can resize root directories to make room for more long filenames.

IMPORTANT! PartitionMagic is not designed to work with servers. We recommend 
PowerQuest® ServerMagic® for partitioning Windows NT and NetWare 
servers. Contact PowerQuest Sales or go to the PowerQuest web site 
www.powerquest.com for additional information about ServerMagic.



PowerQuest PartitionMagic 5

New Features

PowerQuest PartitionMagic 5.0 includes the following new features: 

• Ability to merge FAT and FAT32 partitions

• Improved interface: color key to indicate file system type, indicators for the 2 GB 
boot boundary and 1024 cylinder boundary, used and unused space indicators within 
partitions

• Option to hide wizard buttons on the main window

• More options for converting file systems for a partition: NTFS to FAT, NTFS to 
FAT32, primary to logical, and logical to primary

• Improved wizards: create new partition, merge partitions, redistribute free space, and 
resize partitions

• Ability to view a list of pending operations

• Improved online Help

• Added automatic error-fixing

• Support for NTFS 5

• (PartitionMagic Pro only) Improved user-interface for scripting

PartitionMagic System Requirements

Hardware/
Software

PartitionMagic 
for Windows 95 
and Windows 98

PartitionMagic 
for Windows NT 
Workstation

PartitionMagic 
for DOS (rescue 
disks)

Processor Intel 486 DX or 
above (33 MHz)

Intel 486 DX or 
above (33 MHz)

Intel 486 DX or above 
(33 MHz)

RAM 16 MB (32 MB 
recommended for 
FAT32 
partitions)*

16 MB (32 MB 
recommended for 
FAT32 partitions)*

8 MB (16 MB for 
NTFS partitions; 32 
MB recommended for 
FAT32 partitions)*

Hard-disk space 12 MB 12 MB 611 K (if installing to 
hard disk instead of 
running from floppy 
disks)
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Before Running PartitionMagic

You should back up your hard disk before using PartitionMagic. While PartitionMagic has 
been thoroughly tested to be safe and reliable, other factors, (such as power failures, 
operating system bugs, and hardware defects), can put your data at risk. Before using any 
utility that makes extensive changes to your hard disk, you should back up your data.

If you run PartitionMagic under any version of Windows, make sure no other applications 
are running and no other users are attached to your workstation (in a peer-to-peer network) 
before running PartitionMagic.

PartitionMagic cannot run while other low-level disk utilities are running. Close all such 
utilities prior to starting PartitionMagic.

Operating 
system

Windows 95a or 
later (Windows 
95b or Windows 
98 for FAT32 
support)

Windows NT 4.0 
Workstation only

MS-DOS 5.0 (6.2 or 
later recommended) 
for Windows 3.x

3.5-inch diskette 
drive

High-density High-density High-density

CD-ROM drive 4 x 4 x None

Monitor VGA-compatible VGA-compatible VGA-compatible

* More memory may be required to manipulate FAT32 partitions on hard disks larger 
than 4 GB.
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C H A P T E R1
Getting Started
This chapter contains the following information:

• Installing PartitionMagic Under Windows

• Installing PartitionMagic Under DOS or OS/2

• Installing PartitionMagic Under Linux

• Running PartitionMagic

• The PartitionMagic Main Window—An Overview

• Getting Help

• Completing Tasks Manually—A Four-Step Process

Selecting a Hard Disk

Selecting a Partition

Selecting an Operation

Applying Changes to Your System

• Changing PartitionMagic Preferences

• Supported File Systems

• Uninstalling PartitionMagic
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Installing PartitionMagic Under Windows

You can install PartitionMagic from the following operating systems: Windows 3.x, 
Windows 95, Windows 98, and Windows NT 4.0 Workstation. If you are using DOS, see 
“Running PartitionMagic from Rescue Disks” on page 85.

IMPORTANT! PartitionMagic must be installed on a local drive, not on a network drive.

1 Insert the PartitionMagic CD-ROM into your CD-ROM drive.

2 Follow the instructions for your operating system.

The installation program installs PartitionMagic for the operating system currently 
running. If you want to install PartitionMagic for a different operating system, 
complete the Custom installation.

Installing PartitionMagic Under DOS or OS/2

You can create rescue disks to run PartitionMagic from DOS. You must also create rescue 
disks if you are using OS/2, since there is not a native version of PartitionMagic for OS/2. 
The rescue disk version of PartitionMagic includes the same features as the Windows 
version, except there are no wizards.

1 Open the DOS-OS2 folder on the PartitionMagic CD.

Operating System Instructions

Windows 95, Windows 
98, or Windows NT 4.0 
Workstation

1 If the installation program does not start 
automatically, click Start ➤ Run on the Windows 
taskbar.

2 Type drive :\SETUP , where drive  is the drive 
letter of your CD-ROM drive.

3 Click OK , and follow the on-screen installation 
instructions.

Windows 3.x 1 In Program Manager, click File ➤ Run.

2 Type drive :\SETUP , where drive  is the drive 
letter of your CD-ROM drive.

3 Click OK , and follow the on-screen installation 
instructions.
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2 Type MAKEDISK A: , where A: is the drive letter for your floppy disk drive.

You can also install the DOS version of PartitionMagic to your hard disk using this 
process. If you install to your hard disk, the PartitionMagic files (but not the system 
files) will be installed to a PQMAGIC directory at the root of the disk, and you will 
not need floppy disks.

Installing PartitionMagic Under Linux

To install PartitionMagic under Linux, refer to the README.1ST document in the 
English\Linux folder on the PartitionMagic CD. (The file README-D.1ST file contains 
the same information and is readable under DOS.)

Running PartitionMagic

IMPORTANT! PartitionMagic must be run from a local drive, not from a network drive.

If you are using Windows 95, Windows 98, or Windows NT 4.0 Workstation, click 
Start ➤ Programs ➤ PowerQuest PartitionMagic ➤ PartitionMagic 5.0 for 
Win95/98 (or WinNT).

If you are using Windows 3.x, open the PowerQuest PartitionMagic program group and 
double-click the PartionMagic 5.0 program icon.

If you are using DOS, OS/2, or Linux, see “Running PartitionMagic from Rescue Disks” 
on page 85. Note that the rescue disk version appears similar on screen and has the same 
features as the Windows version, except there are no wizards. The tasks and information 
outlined in this user guide apply to both the Windows and rescue disk versions of 
PartitionMagic.

The PartitionMagic Main Window—An Overview

The PartitionMagic main window appears the same under Windows and the rescue disk 
version of PartitionMagic, except the rescue disk version does not display the wizards. 

The menu bar and a toolbar appear at the top of the window. The menu bar gives you 
access to all of PartitionMagic’s features, while the toolbar gives you quick access to 
commonly used options.
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Partition Information

The partition area displays information about the selected hard disk’s partitions. It consists 
of two areas: the partition map, which displays information graphically; and the partition 
list, which displays partition information in text form. For general information about 
partitions, see “Understanding Partitions” in Basic Concepts in Help. 

Menu Bar
Toolbar

Partition 
Information

Wizards

Partition 
Map

Partition 
List

Used Space 
(shaded)
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Partition Map 

The partition map shows the partitions approximately to scale. Each partition is 
represented by a different color according to the file system it uses. If the selected hard 
disk contains logical partitions, the logical partitions are shown within an extended 
partition.

Each partition is color-coded to show used and unused space within the partition. Note that 
the operations you can perform on white (unformatted) or yellow (unknown) partitions are 
limited.

The partition map also shows unallocated space (space not assigned to any partition).

There are triangle indicators to mark the 2 GB boot boundary and the 1024 cylinder limit. 
The boundary markers can help you as you create, move, or resize partitions, so you will 
not make primary partitions unbootable by accident. For additional information about the 
boot boundaries, refer to “Understanding the BIOS 1024 Cylinder Limit” or 
“Understanding the 2 GB Boot Code Boundary” in the PartitionMagic online help.

Partition List 

The partition list displays the following information about each partition: drive letter, 
volume label, file system type, size, amount of used and unused space, status, and whether 
the partition is a primary or logical partition.

Color Description

Brown Linux swap

Dark blue HPFS

Dark green FAT32

Light blue Extended

Light green FAT

Pink NTFS

Purple Linux Ext2

White Unformatted

Yellow Unknown
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Primary partition drive letters are flush left, followed by a colon and the volume name. 
Logical partition drive letters and volume labels are indented. An asterisk (*) appears in 
place of a drive letter for:

• Hidden partitions 
• Extended partitions 
• Partitions with file systems not supported by the active operating system
• Unallocated space 

The partition size, used space, and unused space values are displayed in megabytes.

A partition’s status can be:

• Active: The partition the computer boots from.

• Hidden: Partitions that do not have a drive letter. Partitions can be hidden by the 
operating system (it hides all primary partitions except the active one) or by 
BootMagic, or you can hide partitions with PartitionMagic.

• None: Partitions that are not active or hidden.

Wizards

To help you quickly and easily complete several common partitioning tasks, 
PartitionMagic includes these wizards:

• Create new partition
• Redistribute free space
• Resize partitions
• Merge partitions

To start a wizard, click the wizard icon. For more information about using the wizards, see 
Chapter 2 of this user guide. 

You do not have access to the wizards if you run PartitionMagic from the rescue disks.

Getting Help

PartitionMagic Help provides in-depth information on features as well as step-by-step 
instructions for specific tasks.

To access Help, click Help ➤ Contents on the menu bar in the PartitionMagic main 
window.
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The PowerQuest PartitionMagic Help is organized into books and pages.

Each book focuses on a different aspect of PartitionMagic, so you can quickly locate the 
information you need. When you double-click a topic, the information displays in the right 
window.

You can click the key tab to search for a topic using keywords.

Context-Sensitive Help

By clicking Help in the lower right corner of a dialog, you can open context-sensitive help 
for the dialog. Clicking Hints in a wizard dialog displays helpful information about the 
task the wizard is performing.

README File

The README.TXT file includes information that changed since this guide was written, 
corrections to the manual or help system, and information specific to installation or 
configuration issues.

Completing Tasks Manually—A Four-Step Process

PartitionMagic offers two ways to complete tasks: using wizards and completing tasks 
manually. For information about using the wizards, see Chapter 2 of this user guide. To 
manually complete a task, follow this general four-step process:

Find information 
with the Index 
(key) and Find 
(binoculars) 
tabs.

Double-click a 
page to read 
the help topic.

Double-click a 
book to view the 
pages in it.
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1 Select a hard disk.

2 Select a partition.

3 Select an operation and enter details about the changes you want to perform.

4 Apply changes to your system.

Selecting a Hard Disk

The Disk option on the toolbar displays the currently selected disk and its size in 
megabytes (MB).

There are two ways to select a hard disk:

• On the toolbar, click the arrow button to the right of the currently selected disk to 
open a drop-down list of all the disks on your system. Then click the disk you want to 
select.

• On the menu bar, click Disks, then select a disk.

Disks does not appear on the menu bar unless you have multiple hard disks.

Using PartitionMagic with Removable Media

Please note that PartitionMagic is not designed to work on removable media. PowerQuest 
technical support does not guarantee they will be able to resolve problems you encounter 
when partitioning removable media.

Windows 2000 Disks

Windows 2000 uses basic disks and dynamic disks. A basic disk has an industry standard 
disk format with primary and logical partitions, partition tables, and so forth. Windows 
2000 has introduced “dynamic disks.” Dynamic disks do not conform to industry 
standards and are visible only when Windows 2000 is running. You cannot perform 
PartitionMagic operations on dynamic disks.

Selecting a Partition 

There are three ways to select a partition:

• Click the partition in the partition list or on the partition map.

• On the menu bar, click Partitions, then select a partition.

• Press <Alt+P> to activate the Partitions menu, press <Up Arrow>  or <Down 
Arrow>  to highlight the desired partition, then press <Enter>. 
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The selected partition is highlighted in the partition list. 

Selecting an Operation

After you have selected a disk and a partition, you can select an operation using the 
toolbar, the context menu, the menu bar, or the keyboard. If an operation cannot be 
performed on the selected partition, the operation is unavailable (menu item appears 
dimmed).

• Click one of the operations buttons on the toolbar. 

When you place the pointer on a toolbar button, a pop-up window displays the 
button’s function.

• In the partition map or partition list, right-click the partition you want to change, then 
click the desired operation from the context menu.

• On the menu bar, click Operations, then choose the desired operation. 

• Press <Alt+O> , then type the underlined letter of the desired operation.

For more information about the items on the Operations menu, see Chapter 3 of this user 
guide.

Applying Changes to Your System

As you complete tasks using the Operations menu, the partition map and partition list 
reflect the changes you have made. However, no changes physically take place on your 
system until you apply them. You can perform several operations and then apply all the 
changes at once.

You can tell when changes have been made but not yet applied to your system when the 
status box in the lower right corner of the main window indicates that operations are 
pending. If the wizard icons are displayed, the Apply Changes and Discard Changes icons 
also display at the bottom of the window when there are operations pending.

To apply changes to your system, click General ➤ Apply Changes, or click  on the 
toolbar. If the wizard icons are displayed, you can also click the Apply Changes icon at 
the bottom of the window. If you have open files, PartitionMagic may need to go to DOS 
mode or reboot your computer before the changes are applied.

You can click Apply Changes ➤ Details to view a list of the operations that will be 
applied.
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To discard the changes and start over, click General ➤ Discard Changes, or click  
on the toolbar. If the wizard icons are displayed, you can also click the Discard Changes 
icon at the bottom of the window. You cannot discard or undo changes after you have 
applied them.

Changing PartitionMagic Preferences

1 In the main window, click General ➤ Preferences.

A check mark next to a preference indicates it is enabled.

2 Click checkboxes to enable or disable preferences, then click OK .

Allow 64K FAT Clusters for Windows NT

This preference lets you create FAT partitions with 64 KB clusters, which enables 
Windows NT to support large hard disks.

IMPORTANT! Because DOS, Windows 3.x, Windows 95, and Windows 98 do not 
support cluster sizes larger than 32K, you cannot access a 64K partition 
using these operating systems. You should only use 64K partitions with 
Windows NT. If you are using multiple operating systems, we recommend 
not using 64K clusters.

To prevent you from inadvertently creating partitions with 64K clusters, this preference is 
disabled every time you exit PartitionMagic.

When enabled, the 64K cluster size is available in the Resize/Move Partition and Resize 
Clusters dialogs.

Indicates whether 
the current 
operating system 
supports FAT32 
partitions.
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Ignore OS/2 EA Errors on FAT

This preference tells PartitionMagic whether to ignore OS/2 Extended Attribute errors 
when it checks a FAT partition.

WARNING! If OS/2 is on your computer, do not enable this preference. Data loss could 
occur because problems might go undetected.

Skip Bad Sector Checks

When PartitionMagic modifies partitions, it performs extensive testing to detect bad 
sectors on your hard disk. Newer disk types (such as Enhanced IDE and SCSI) often 
handle bad sectors internally, making such testing superfluous. For this reason, 
PartitionMagic lets you bypass these tests with Skip Bad Sector Checks. When this 
preference is enabled, the Resize/Move, Create, Copy, and Format operations run faster.

WARNING! If you skip bad sector checks and your hard disk has bad sectors, data loss 
can result.

Bad sector checking is on by default. PartitionMagic lets you set this preference 
individually for each of your hard disks. If your system has an older disk and a newer one, 
you could check the older disk and skip the newer one. A check mark next to a disk means 
to skip bad sector checking for that disk. 

Set as Read-Only for PartitionMagic

This preference lets you prevent PartitionMagic from making any changes to a hard disk. 
You can set this preference individually for each of your hard disks.

There are some exceptions to how this preference is applied:

• If the disk contains the boot partition, some files may be changed, such as the 
Windows NT boot initialization (BOOT.INI) file.

• If you tell PartitionMagic to run DriveMapper automatically, certain files, such as 
initialization files and shortcut files, may be changed.
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Supported File Systems

PartitionMagic supports the following partition types.

Partition 
Type Description

Extended The extended partition gets around the arbitrary four-partition limit 
for a disk. An extended partition is a container in which you can 
further divide your disk space by creating logical partitions. An 
extended partition does not directly hold data. You must create logical 
partitions within the extended partition to store data.

Extended-X An extendedx partition functions like an extended partition but is not 
limited to the first 1024 cylinders on a drive.

Linux kernels below 2.2 do not support Extended-X partitions.

FAT Uses file allocation table (FAT) and clusters. The FAT file system is 
used by DOS, Windows 3.x, and most Windows 95 installations. A 
FAT partition is also accessible by Windows NT and OS/2.

FAT16x FAT16x is a proprietary file system developed by Microsoft to enable 
FAT partitions beyond 1024 cylinders (~8GB).

FAT32 FAT32 is an enhancement of the FAT file system. It uses 32-bit file 
allocation table entries, rather than the 16-bit entries used by the FAT 
system, so FAT32 supports larger disk or partition sizes (up to 2 
terabytes). The minimum size for a FAT32 partition is 256 MB.

A FAT32 partition is only accessible by Windows 95 OSR2 (version 
4.00.950B), Windows 98, and Windows 2000, when available. DOS, 
Windows 3.x, Windows NT 3.51/4.0, earlier versions of Windows 95, 
and OS/2 don’t recognize FAT32 and cannot use files on a FAT32 
partition.

FAT32x FAT32x is a proprietary file system developed by Microsoft to enable 
FAT32 partitions beyond 1024 cylinders (~8GB). Windows 95 OSR2 
and Windows 98 may use FAT32x partitions.

HPFS The High Performance File System (HPFS) is accessible only by 
OS/2, older versions of Windows NT (v. 3.51 and earlier), or versions 
of Windows NT that were upgraded from v. 3.51 or earlier. 
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HPFS/386 HPFS/386 is a file system used by OS/2 Advanced Server. The only 
difference from HPFS is that HPFS/386 uses Access Control Lists 
(ACLs), and HPFS does not. In both file systems, each file and 
directory structure is anchored on a structure called an fnode. In 
HPFS/386, each fnode has internal storage space for ACLs and 
Extended Attributes. If a file has more than 16 ACLs, they are stored 
outside of the fnode on disk, and the fnode has a pointer telling where 
to find the ACLs.

Linux Ext2 The Linux Ext2 file system is only accessible by Linux, a freeware 
version of UNIX. The Linux Ext2 file system supports a maximum 
partition size of 4 terabytes. 

Linux Swap Holds a Linux swap file. The maximum usable size of a Linux swap 
file is 128 MB. The default size shown when you create a Linux swap 
partition may be slightly larger because of the physical geometry on 
the hard disk.

NTFS The New Technology File System (NTFS) is accessible only by 
Windows NT. NTFS is not recommended for use on disks less than 
400 MB because it uses a great deal of space for system structures.

Unformatted Unformatted partitions reserve a portion of the disk but are not 
assigned a file structure.

Unallocated 
space

Unallocated space is the portion of a hard disk that is not currently 
assigned to any partition.

Partition 
Type Description
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Uninstalling PartitionMagic

Exit PartitionMagic, then follow the instructions for your operating system. 

Operating System: Instructions:

Windows 95, Windows 
98, or Windows NT 4.0 
Workstation

1 On the Windows taskbar, click Start ➤ 
Settings➤ Control Panel. 

2 Double-click Add/Remove Programs.

3 Select PartitionMagic 5.0.

4 Click Add/Remove.

Windows 3.x Double-click the Uninstall PartitionMagic  icon in the 
PowerQuest PartitionMagic program group.
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C H A P T E R2
Automating Tasks
This chapter includes the following information:

• Wizard Overview

Running Wizards

Applying Changes

Create New Partition Wizard

Resize Partitions Wizard

Redistribute Free Space Wizard

Merge Partitions Wizard

Hiding Wizard Icons

• Scripting
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Wizard Overview

PartitionMagic includes four wizards for common tasks. The wizards provide an 
alternative to performing the tasks manually using the commands on the Operations 
menu.

Running Wizards

There are two ways to run a wizard:

• Click Wizards on the menu bar, then click the wizard you want to run.
• Click the appropriate wizard icon in the PartitionMagic main window.

Applying Changes

When you complete a wizard, the partition map and partition list in the main window 
reflect the changes you entered. However, the changes do not actually affect your system 
until you apply them.

You can apply (or discard) changes that you enter using wizards in three ways:

• Click  on the toolbar to apply the changes, or click  on the toolbar to discard 
the changes and start over.

• Click General ➤ Apply Changes (or Discard Changes).

• Click the Apply Changes or Discard Changes icon at the bottom of the main 
window.

After running a wizard, you can run other wizards or perform other partition operations 
and then apply or discard all the pending changes at once.

Create New Partition Wizard

The Create new partition wizard creates a new primary or logical partition.

You should be aware of the following considerations when creating a new partition:

• Creating a new partition may cause your drive letters to change. For example, if you 
have one primary partition (C:) on your hard drive and a CD-ROM drive (D:), and 
you create a new logical partition on your hard drive, the new partition becomes D: 
and the CD-ROM drive changes to E: after you reboot your computer. As a result, any 
programs on your hard drive that were linked to the CD-ROM no longer function 
because the paths to files have changed. PowerQuest recommends that you allow 
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DriveMapper to automatically update your drive letter references when prompted to 
do so. However, you can update drive letter references manually. Refer to “Changing 
Drive Letter References with DriveMapper” on page 80 for additional information.

For more information about why drive letters change, refer to “How the OS Assigns 
Drive Letters” and “Problems Caused by Drive Letter Changes” in Basic Concepts in 
Help.

• The file system you choose for the new partition will affect which operating systems 
can access the partition. The wizard dialogs will instruct you about the choices you 
make. For example, if you choose to create a FAT32 partition, the wizard will inform 
you that FAT32 partitions are used by Windows 95 OEM Service Release 2, 
Windows 98, and Windows 2000 but that Windows 3.x and DOS cannot access them. 
Pay close attention to the information in the dialog boxes, or you may inadvertently 
make your data inaccessible.

• Before installing Windows NT, make sure that all the partitions that you want 
Windows NT to recognize end prior to cylinder 1024. Otherwise, Windows NT will 
not install and will report that all the partitions are corrupted. If you cannot resize and 
move all partitions, you must obtain updated drivers from Microsoft before installing 
Windows NT.

• If you choose to create a Linux Ext2 partition, the wizard will prompt you to create a 
new Linux swap partition, as well.

• After you apply the changes from the wizard and reboot your computer, the operating 
system assigns the new partition a drive letter. You can then save data or install an 
operating system to your new partition.

If you created a new primary partition and plan to install an operating system on it, refer to 
“Installing a New Operating System” on page 36 for additional information.

Resize Partitions Wizard

The Resize Partitions wizard helps you resize a partition and lets you specify how the 
resize will affect other partitions on the same disk. For example, if you have C: and D: 
partitions and you choose to enlarge C:, the wizard could take space from D: and allocate 
it to C:.

For information about resizing partitions without the wizard, see “Resizing and Moving 
Partitions” on page 26.
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Redistribute Free Space Wizard

The Redistribute free space wizard spreads the free space on a hard disk evenly across 
partitions. Free space refers to unused space within partitions and space that is not 
allocated to any partition.

You can redistribute free space on one hard disk at a time. You cannot redistribute free 
space across several disks.

For information about redistributing free space without the wizard, see “Resizing and 
Moving Partitions” on page 26.

Merge Partitions Wizard

The Merge Partitions wizard helps you merge two adjacent FAT or FAT32 partitions. You 
choose two partitions, and the first will be expanded to include the second. The contents of 
the second partition are added as a folder inside the first partition.

PowerQuest recommends that you run DriveMapper to update drive letter references after 
merging partitions. The wizard will prompt you to run DriveMapper automatically.

Hiding Wizard Icons

You can choose whether to display the wizard buttons near the bottom of the 
PartitionMagic main window. Hiding the wizard buttons increases the display area of the 
partition list.

1 Click Wizards ➤ Hide Wizard Buttons.

A check mark displays by the menu command if the wizard buttons are hidden. 
Choose the command again to redisplay the buttons.

The setting you choose will remain in effect until you reset it.

Scripting

PartitionMagic Pro includes the ability to change the partitions on a computer by running 
a script that you create with Script Builder. The script is an ASCII file with text statements 
that define the operations to take place. To run a script, you pass the script filename to the 
program on the command line.

For additional information about script processing, refer to the PartitionMagic online help.
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C H A P T E R3
Completing Hard Disk 
Operations
This chapter includes the following information:

• Integrity Checks

• Resizing and Moving Partitions

• Creating Partitions

• Deleting Partitions

• Changing Partition Labels

• Formatting Partitions

• Copying Partitions

• Checking Partitions

• Merging Partitions

• Getting Information About Partitions

• Scanning a Disk for Errors

• Viewing Pending Operations
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Integrity Checks

PartitionMagic checks disk integrity with a sophisticated system of analysis and validation 
that operates behind the scenes every time you start the program or complete an operation. 
An initial integrity check scans your disk and reports any partition problems that may 
prevent PartitionMagic from operating properly. This integrity check acts as an early 
warning system that informs you of your disk’s status and assures that the disk’s structure 
is thoroughly analyzed and verified before you alter it.

If your physical disk passes the initial integrity check, you can select the disk’s partitions 
and use PartitionMagic’s options; otherwise, an error message appears instead of the 
partition list. This indicates a problem with your disk, not with PartitionMagic (because no 
disk modification operations have been initiated). If PartitionMagic finds errors that it can 
fix automatically, you will be prompted. It is safe to allow PartitionMagic to fix errors. 
Correct the disk problem, and then restart PartitionMagic. For additional information, see 
“Resolving Partition Table Errors” on page 114.

In addition to the integrity check at startup time, PartitionMagic performs two integrity 
checks during any operation. The first check tests the integrity of the file system in the 
partition before an operation begins (similar to CHKDSK or ScanDisk), and the second 
check validates your disk’s data after an operation is completed. From start to finish, 
PartitionMagic examines your disk and informs you immediately if it detects any 
irregularities.

Resizing and Moving Partitions

The Resize/Move operation lets you change the size of a partition and/or move it to 
another location on a hard disk.

1 From the Disk drop-down list (located on the toolbar), select the disk with the 
partition you want to resize/move.

2 On the partition map or in the partition list, select the partition you want to 
resize/move.

You cannot move Windows NT volume or stripe sets with PartitionMagic.

3 On the toolbar, click .

You can also click Operations ➤ Resize/Move on the menu bar or right-click the 
partition and click Resize/Move on the context menu.



PowerQuest PartitionMagic 27

The Resize/Move Partition dialog appears.

The current size of the partition is shown on a partition map at the top of the dialog. 
The map also depicts the used and unused space within the partition and the 
unallocated space surrounding the partition (if any exists). The minimum and 
maximum sizes to which you can resize the partition appear below the map. 

4 Choose whether to resize or move the partition.

To do this: Do this:

Move 1 Place the pointer on the partition. 

The pointer changes to .

2 Drag the partition to the desired location.

There must be unallocated space adjacent to the partition to move 
it. If there is none, and the partition contains unused space, make 
the partition smaller and then move the partition.

You cannot move unknown partitions, partitions failing the 
Check operation, or unallocated space.

Current 
partition 
size

Used space 
(minimum 
size)

Unallocated 
space 
outside 
partition

Unused 
space 
inside 
partition

Right 
partition 
handle

Left 
partition 
handle
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If you know your disk has no bad sectors, Skip bad sector checks in Preferences to 
make Resize/Move operations faster. 

3 (Optional) Click the Cluster Size drop-down list and select a new size.

PartitionMagic changes the Free Space Before, New Size, and Free Space After 
values to show how the partition size is affected.

Move 
(continued)

Your Windows NT system partition cannot be moved past 4 GB, 
or Windows NT will not be bootable.

IMPORTANT! Exercise caution when moving a bootable 
partition. Operating systems can become 
unbootable if moved beyond certain boundaries. 
For more information, see “Creating Bootable 
Partitions” on page 35.

Resize 1 Place the pointer on the left or right partition handle. 

The pointer changes to .

2 Drag the handle until the desired partition size is reached.

You can also resize the partition by typing new values in the Free 
Space Before, New Size, and Free Space After boxes or by 
clicking the arrows next to the boxes. The values you enter may 
change slightly to values supported by the drive’s geometry. The 
arrow buttons resize the partition by the minimum increment, 
allowing you to make very fine adjustments. Changes are 
reflected in the partition map. 

To make a partition smaller, unused space must exist within the 
partition. To enlarge a partition, there must be unallocated space 
adjacent to it. For additional information about resizing 
partitions, refer to “Notes about Resizing Partitions” below.

IMPORTANT! Resizing your NTFS system partition over 7.8 GB 
may render your workstation unbootable. If you 
resize an NTFS system partition over this limit by 
accident, you can recover your system by using 
the PartitionMagic rescue disks to resize the 
NTFS system partition below 7.8 GB.

To do this: Do this:
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This option is only available for FAT and FAT32 partitions. For more information, 
see “Resizing Clusters” on page 64.

4 Click OK .

5 Click  on the toolbar to apply the changes, or click  on the toolbar to discard 
the changes and start over.

You can also perform other partition operations and then click Apply Changes after 
completing all of them.

Notes about Resizing Partitions

When you resize a partition, data is consolidated, not compressed. To make a partition 
smaller, unused space must exist within the partition. To enlarge a partition, there must be 
adjacent unallocated space. If there is unallocated space on the disk, but it is not adjacent 
to the partition you want to enlarge, adjust the location of the space by moving other 
partitions.

IMPORTANT! Exercise caution when resizing partitions smaller, especially a partition 
containing an operating system. Leave at least 50 MB more space in the 
partition than the operating system requires. Swap files, drivers, and other 
files may require the extra space. Additionally, operating systems can 
become unbootable if moved beyond certain boundaries. For more 
information, see “Creating Bootable Partitions” on page 35.

Resizing FAT and FAT32 partitions smaller may reduce the amount of wasted space on a 
hard disk. When you resize a FAT or FAT32 partition, PartitionMagic automatically 
resizes the clusters to their optimal size for the partition. For more information, see 
“Resizing Clusters” on page 64.

You should be aware of the following limitations when resizing partitions:

• You cannot make a partition smaller unless it contains unused space. You can only 
reduce a partition to the used size shown in the partition map plus a small buffer area. 
During a Resize/Move operation, data is consolidated to the front of the partition as 
needed, but no data compression takes place. Because of the way a FAT partition is 
structured, you can often resize a partition a second time and make it even smaller or 
larger than the first time you resized it.

• In certain instances, you cannot make a FAT partition larger when the partition 
contains no unused space. If you have a full partition and plenty of unallocated space 
adjacent to it, yet are not able to enlarge your partition, you may have to delete some 
files in the partition so that PartitionMagic has room to work. You may be able to 
slightly enlarge the partition (1 MB or less) and then enlarge the partition a second 
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time to provide the necessary buffer area for PartitionMagic. To see how much space 
is needed in a partition to resize past a cluster boundary, see the table in “Freeing Disk 
Space Before Enlarging a FAT Partition” in Help.

• It is difficult to calculate in advance the minimum size to which an NTFS or HPFS 
partition may be resized. During an NTFS or HPFS Resize/Move operation, if 
PartitionMagic runs out of space, it returns an error without completing the operation. 
The integrity of the NTFS or HPFS partition and data is never compromised.

Scenario 1: Adding Free Space to a Logical Partition

This scenario outlines the step-by-step procedures for adding space to a logical partition. 
You can also use the Resize Partitions wizard to perform the same operations.

Sample Configuration

One 1 GB hard disk containing:

• One active primary FAT32 partition (C:) running Windows 98

• One extended partition enclosing one logical FAT partition (D:)

Objective

Resize drive C: smaller and add the newly created free space to drive D:.

Procedure

1 Resize drive C: smaller by the amount you want to add to drive D:. 

Resize or move C: so that the unallocated space is on the right.

2 Enlarge drive D: to occupy the unallocated space just created.

The extended partition is automatically enlarged to accommodate drive D:.

3 Apply the changes to your system.

Result

Drive D: has room for additional files.
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Scenario 2: Adding Free Space to a Primary Partition

Sample Configuration

One 4 GB hard disk containing:

• One active primary FAT32 partition (C:) running Windows 95
• One hidden primary NTFS partition
• One extended partition enclosing one logical FAT partition (D:) and a block of free 

space

Objective

Add the block of free space to the NTFS partition.

Procedure

1 Move drive D: to the right (so the unallocated space is on the left).

2 Enlarge the NTFS partition to occupy the unallocated space.

The extended partition is automatically resized to accommodate the NTFS partition.

3 Apply the changes to your system.

Result

The NTFS partition has room for growth and adequate space for operating system files 
such as drivers and swap files.

Creating Partitions

The Create operation lets you create primary partitions, extended partitions, and logical 
partitions.

If you have multiple hard disks and partitions, the process and available options may differ 
slightly from the following steps. For examples of creating partitions on more complex 
systems, see the scenarios that begin on page 38 of this user guide.
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1 From the Disk drop-down list (located on the toolbar), select the disk where you wish 
to create the new partition.

On a single hard disk, you can have up to four primary partitions or three primary 
partitions and one extended partition. Within an extended partition, you can create 
unlimited additional subdivisions called logical partitions. 

2 On the partition map or in the partition list, select a block of unallocated space.

If no unallocated space exists, you must resize or delete an existing partition to create 
unallocated space. For instructions on resizing and deleting partitions, see “Resizing 
and Moving Partitions” on page 26 and “Deleting Partitions” on page 41.

3 On the toolbar, click .

You can also click Operations ➤ Create on the menu bar or right-click the 
unallocated space and click Create on the context menu.

The Create Partition dialog appears.

4 From the Create as drop-down list, select Logical Partition or Primary Partition .

You should create primary partitions to install operating systems and logical 
partitions for all other purposes (such as storing data and applications). If you have 
multiple hard disks, you can improve speed by installing operating systems and 
applications on separate disks. If you do not know what type of partition you want to 
create, see “Understanding Partitions” in Help.

You should create a primary partition if you plan to install an operating system. Refer 
to “Creating Bootable Partitions” on page 35 and “Installing a New Operating 
System” on page 36 for additional information.
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If you select Logical Partition , PartitionMagic automatically creates an extended 
partition to enclose the logical partition, or, if you already have an extended partition, 
resizes the extended partition larger to encompass the logical partition (the free space 
must be inside of or adjacent to the extended partition).

If Logical Partition  is unavailable, you may already have four primary partitions on 
the hard disk. Or, if you have an extended partition, you may not have selected a 
block of free space inside of or adjacent to the extended partition.

5 From the Partition Type  drop-down list, select the desired file system type:

FAT  is the most common file system type. It is used by DOS, Windows 3.x, 
Windows 95, Windows 98, Windows NT, Windows 2000, and OS/2.

FAT32 is used by Windows 95 OEM Service Release 2, Windows 98, and 
Windows 2000.

HPFS is used by OS/2 and Windows NT 3.51 (and earlier versions).

NTFS is used by Windows NT and Windows 2000.

Linux Ext2  and Linux Swap are used only by Linux.

Extended creates an extended partition which can contain any number of logical 
partitions. Extended is not an option if the hard disk already contains an extended 
partition or four primary partitions.

Unformatted creates an unformatted partition on your hard drive.

6 (Optional) Enter a label (up to 11 alphanumeric characters) for the new partition.

7 In the Size box, enter the desired size for the partition.

PartitionMagic automatically calculates a recommended size (based on the most 
efficient use of disk space), which you can accept or change.

8 If the size you specified for the new partition is smaller than the available unallocated 
space, you can position the partition at the beginning (recommended) or end of the 
unallocated space. In the Position box, click Beginning of free space or End of free 
space.

9 In the Drive Letter  field, note the drive letter that will be assigned to the new 
partition after reboot.

If you have an existing primary partition and you create another primary partition,  
the new primary partition is automatically hidden and will not receive a drive letter 
assignment because only one primary partition can be active at a time. An exception 
is Windows NT, which can handle multiple visible primary partitions.
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(Windows NT only) In the Drive Letter  box, type or select the drive letter you wish 
to assign to the partition.

10 Click OK . 

11 Click  on the toolbar to apply the changes, or click  on the toolbar to discard 
the changes and start over.

You can also perform other partition operations and then click Apply Changes after 
completing all of them.

If you created a new primary partition and plan to install an operating system on it, 
refer to “Installing a New Operating System” on page 36 for additional information.

After creating a partition, you can move applications to the partition using 
MagicMover. For more information see “Moving Applications with MagicMover” on 
page 81.

WARNING! Because of conflicts that can result from different hardware and system 
configurations, do not create a partition on a hard disk and then move that 
hard disk to another computer. Data loss may occur.

Managing Drive Letter Changes

Creating a new partition may cause your drive letters to change. For example, if you have 
one primary partition (C:) on your hard drive and a CD-ROM drive (D:), and you create a 
new logical partition on your hard drive, the new partition becomes D: and the CD-ROM 
drive changes to E: after you reboot your computer. As a result, any programs on your 
hard drive that were linked to the CD-ROM no longer function because the paths to files 
have changed.

PowerQuest recommends that you allow DriveMapper to automatically update the drive 
letter references in application shortcuts, initialization files, and registry entries when 
prompted to do so. However, you can update drive letter references manually. Refer to 
“Changing Drive Letter References with DriveMapper” on page 80 for additional 
information.

While you can use DriveMapper to update references to files, for least impact, consider 
creating all new partitions on the highest disk (for example, disk 3 in a three-disk system) 
and to the right of existing partitions. For more information, “Understanding Drive 
Letters” in Help.
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Creating Bootable Partitions

Before creating a partition where you plan to install an operating system (a bootable 
partition), you should understand the information outlined in the following table.

IMPORTANT! When you create, move, or resize a bootable partition, the partition must 
begin below the boot code boundary specified in the above table in order 
for the operating system to boot. With the exception of DOS 6.22 (or 
earlier) and OS/2, partitions beyond 8 GB are visible to the current 
operating system. For more information, see “Understanding the BIOS 
1,024 Cylinder Limit” and “Understanding the 2 GB Boot Code 
Boundary” in Help. The partition map in the PartitionMagic main window 
displays indicators for the 2 GB boot boundary and the 1024 cylinder limit.

Operating System Boots from 
Primary or 
Logical

Supported 
Partition Type(s)

Boot Code 
Boundary

Space 
Required

DOS 6.22 and 
earlier

Primary FAT 2 GB 8 MB

Windows 95 Primary FAT or FAT32** 8 GB 90 MB

Windows 98 Primary FAT or FAT 32 8 GB 175 MB

Windows NT Primary* FAT, or NTFS 2 GB 117 MB

Windows 2000 Primary FAT, FAT32, 
NTFS

8 GB 600 MB

Linux Either Linux Ext2 8 GB 250 MB

OS/2 Either FAT or HPFS 4 GB 110 MB

* Windows NT must boot from a primary partition on the first drive. However, only a 
few NT files must reside on that partition; the remaining files can reside on a logical 
partition, which can be located on the first or a subsequent drive. The NT boot partition 
can be shared with another operating system.

**FAT32 is only supported by Windows 95 OEM Service Release 2, Windows 98, and 
Windows 2000.
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PartitionMagic displays a warning if you attempt to create, move, or resize a bootable 
partition outside of the 2 GB boot code boundary. If you continue with the operation, you 
may not be able to boot or to see the partition. In either case, you can resolve the problem 
by moving the partition back within the boot code boundary with the PartitionMagic 
rescue disks.

If your system includes SCSI disks and you create a partition before a bootable Linux 
partition, Linux may no longer be bootable. In this situation, you may need to create Linux 
rescue disks, boot from the rescue disks, and repair the Linux boot information on the 
Linux partition. Refer to the README.1ST text file in the \English\Linux folder on the 
PartitionMagic CD for information about creating rescue disks for Linux.

Installing a New Operating System

If you install multiple operating systems, you must follow the steps below for each of 
them. For detailed information about installing operating systems, refer to 
OPERATE.PDF in the English\Docs folder on the PartitionMagic CD.

1 Make the partition active (not necessary if you are installing Linux).

See “Setting an Active Partition” on page 62.

You can only install operating systems on primary partitions.

2 Close all programs and reboot the computer using an operating system installation 
diskette.

3 Install the operating system.

PowerQuest technical support does not help install operating systems. See your 
operating system documentation for details.

4 (If applicable) Add the operating system to your BootMagic configuration so that you 
can select the operating system you want to boot.

For more information, see “Configuring BootMagic” on page 84.

5 Reboot the computer.
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Scenario 1: Creating a Primary Partition for Windows NT

Sample System Configuration

One 4 GB hard disk containing one active primary FAT32 partition (C:) running 
Windows 98.

Objective

Resize drive C: smaller. In the unallocated space created, create a primary FAT partition 
where Windows NT can be installed.

Procedure

1 Resize drive C: smaller by 3 GB. For more information, see “Resizing and Moving 
Partitions” on page 26.

The partition where you want to install Windows NT must begin in the first 2 GB of 
the disk, or Windows NT will not be bootable. You may need to move your existing 
partition to the end of the disk, then create the Windows NT partition at the beginning 
of the disk.

2 Create a primary partition in the unallocated space using the following information:

Partition Type: Select FAT . Do not select FAT32 unless you are using Windows 
2000. Earlier versions do not recognize FAT32 partitions.

Label: Type one, if desired.

Size: Type 3000.

IMPORTANT! Before performing the next step, make sure you have the Windows 
NT installation CD and disks; otherwise, you will not be able to boot 
your computer.

3 Set the new partition active. For more information, see “Setting an Active Partition” 
on page 62.

4 Hide the FAT32 partition. For more information, see “Hiding and Unhiding 
Partitions” on page 60.



Chapter 3: Completing Hard Disk Operations38

5 Apply the changes to your system.

IMPORTANT! Before installing Windows NT, make sure that all partitions end prior 
to cylinder 1024. Otherwise, Windows NT will not install and will 
report that all the partitions are corrupted. If you cannot resize and 
move all partitions, you must obtain updated drivers from Microsoft.

6 Reboot the computer using the first Windows NT installation diskette.

7 Complete the Windows NT installation.

PowerQuest technical support does not help install operating systems. See your 
operating system documentation for details.

8 Add Windows NT to your BootMagic configuration so that each time you start or 
restart your computer, you can select the operating system you want to boot. For more 
information, see “Configuring BootMagic” on page 84.

Result

When the computer restarts, BootMagic presents a list of the available operating systems, 
in this case, Windows 98 and Windows NT. Select the operating system you want to boot.

Scenario 2: Creating a Logical Partition on a Secondary Hard Disk

Sample System Configuration

Disk 1 — One 4 GB disk containing:

• One active primary FAT32 partition (C:) running Windows 95.
• One extended partition enclosing one logical FAT partition (E:).

Disk 2 — One 2 GB hard disk containing:

• One 1 GB FAT32 primary partition (D:).
• 1 GB unpartitioned unallocated space.

One CD-ROM drive (F:).
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Objective

Create a 1 GB logical FAT partition on Disk 2.

Procedure

1 Select Disk 2.

2 Create a logical partition in the 1 GB unallocated space using the following 
information:

Partition Type: Select FAT .

Label: Type one, if desired.

Size: Accept the pre-calculated size.

Create As: Choose Logical.

The partition will be assigned drive F: after reboot. Additionally, an extended partition 
will automatically be created to enclose the logical partition.

3 Apply the changes to your system.

Result

After the computer reboots, the new logical partition is drive F: and the CD-ROM is drive 
G:. 

Scenario 3: Creating Linux Logical Partitions

Sample System Configuration

One 6 GB hard disk containing:

• One active primary FAT partition (C:) running Windows 95.
• One extended partition enclosing one logical FAT partition (D:) and one logical 

FAT32 partition (E:).
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Objective

Resize drive E: smaller. In the unallocated space created, create one logical Linux Ext2 
partition and one logical Linux Swap partition.

Procedure

1 Resize drive E: smaller by 550 MB. For more information, see “Resizing and Moving 
Partitions” on page 26.

2 Create a logical partition in the unallocated space using the following information:

Partition Type: Select Linux Ext2 .

Label: Type one, if desired.

Size: Type 500.

3 Create a second logical partition in the unallocated space using the following 
information:

Partition Type: Select Linux Swap.

Label: Type one, if desired.

Size: Type 50.

4 Apply the changes to your system.

5 Reboot the computer using your Linux installation diskette.

6 Complete the Linux installation.

You do not need to change the active partition to install Linux.

PowerQuest technical support does not help install operating systems. See your 
operating system documentation for details.

WARNING! If you are using a boot utility like BootMagic, LILO (Linux Loader) 
must be installed to the Linux Ext2 partition containing the root 
directory and not installed to the master boot record. If you install LILO 
to the master boot record, other operating systems may become 
unbootable.
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7 (Optional) Add Linux to your BootMagic configuration so that each time you start or 
restart your computer, you can select the operating system you want to boot. For more 
information, see “Configuring BootMagic” on page 84.

Result

When the computer restarts, BootMagic presents a list of the available operating systems, 
in this case, Windows 95 and Linux. Select the operating system you want to boot.

Deleting Partitions

The Delete operation deletes a partition and makes its data inaccessible.

1 From the Disk drop-down list (located on the toolbar), select the disk with the 
partition you wish to delete.

2 On the partition map or in the partition list, select the partition you want to delete.

To delete an extended partition, you must first delete all logical partitions within the 
extended partition. 

3 On the toolbar, click .

You can also click Operations ➤ Delete on the menu bar or right-click the partition 
and click Delete on the context menu.

The Delete Partition dialog appears.

4 Type OK to confirm the deletion.

5 Click OK . 
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6 Click  on the toolbar to apply the changes, or click  on the toolbar to discard 
the changes and start over.

You can also perform other partition operations and then click Apply Changes after 
completing all of them.

PowerQuest recommends running DriveMapper when prompted. Deleting a partition can 
make your drive letters change, causing applications not to run because application 
shortcuts, initialization files, and registry entries refer to incorrect drives. DriveMapper, a 
utility included with PartitionMagic, helps you easily update drive letter references. Under 
some conditions, DriveMapper runs automatically after you delete a partition. For more 
information, see “Changing Drive Letter References with DriveMapper” on page 80.

If your system includes SCSI disks and you delete a partition before a bootable Linux 
partition, Linux may no longer be bootable. In this situation, you may need to create Linux 
rescue disks, boot from the rescue disks, and repair the Linux boot information on the 
Linux partition. Refer to the README.1ST text file in the \English\Linux folder on the 
PartitionMagic CD for information about creating rescue disks for Linux.

Changing Partition Labels

The Label operation lets you to change a partition’s volume label. Giving your partitions 
meaningful names makes managing them easier.

1 From the Disk drop-down list (located on the toolbar), select the disk with the 
partition whose label you wish to change.

2 On the partition map or in the partition list, select the partition with the label you want 
to change.

3 On the toolbar, click .

You can also click Operations ➤ Label on the menu bar or right-click the partition 
and click Label on the context menu.
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The Label Partition  dialog appears.

4 In the New Label box, type the new label.

Labels cannot contain the following special characters: [*?:<>|+=;\/”,].

Labels can be up to 11 alphanumeric characters. Labels follow the same rules as DOS 
names, with two exceptions: spaces are allowed, and no period is required between 
the first eight characters and the last three.

5 Click OK .

6 Click  on the toolbar to apply the changes, or click  on the toolbar to discard 
the changes and start over.

You can also perform other partition operations and then click Apply Changes after 
completing all of them.

Formatting Partitions

The Format operation formats a partition, destroying all its data in the process. 
Formatting enables you to put a different file system on a partition.

PartitionMagic has several conversion options that let you convert from one file system to 
another without destroying existing files in a partition. For more information, see Chapter 
5 of this user guide.

1 From the Disk drop-down list (located on the toolbar), select the disk with the 
partition you wish to format.

2 On the partition map or in the partition list, select the partition you want to format.

3 On the toolbar, click .
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You can also click Operations  ➤ Format on the menu bar or right-click the 
partition and click Format on the context menu.

The Format Partition  dialog appears.

4 From the Partition Type drop-down list, select the desired file system type. 

If the partition is too small or too large, some partition types may not be available.

5 (Optional) Type a label for the partition. 

6 Type OK to confirm that you want to format the partition.

7 Click OK.

8 Click  on the toolbar to apply the changes, or click  on the toolbar to discard 
the changes and start over.

You can also perform other partition operations and then click Apply Changes after 
completing all of them.

Copying Partitions

The Copy operation lets you to make an exact duplicate of a partition.

Reasons why you might want to copy a partition include:

• To duplicate your operating system before upgrading to a new version or a different 
operating system (so that you can remember how the old operating system’s 
windows, program icons, and properties were set up).
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• To quickly move a smaller hard disk’s contents to a larger, new hard disk.

• To change the relative order of partitions.

• To back up a partition.

1 From the Disk drop-down list (located on the toolbar), select the disk with the 
partition you wish to copy.

To copy a partition, you must have unallocated space that is equal to or larger than the 
partition you are copying.

2 On the partition map or in the partition list, select the partition you want to copy.

The Copy command is dimmed if there is not enough unallocated space on your disk 
for the partition.

You cannot use PartitionMagic to copy Windows NT volume or stripe sets. 

3 On the toolbar, click .

You can also click Operations  ➤ Copy on the menu bar or right-click the partition 
and click Copy on the context menu.

The Copy Partition  dialog appears.

4 From the Physical Drives drop-down list, select the disk where you want to copy the 
partition.

5 In the partition list, select the unallocated space where you want to copy the partition.
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6 Click OK .

7 Click  on the toolbar to apply the changes, or click  on the toolbar to discard 
the changes and start over.

The copy is the same size (or slightly different if copied to a disk with a different 
geometry) and file system type and contains the same data as the original.

Checking Partitions

The Check operation checks the integrity of a partition.

1 From the Disk drop-down list (located on the toolbar), select the disk with the 
partition you wish to check.

2 On the partition map or in the partition list, select the partition you want to check.

PartitionMagic can only check partitions that it can lock (that is, partitions that do not 
have open files on them). If there are open files on a partition, the Check option on the 
menu will be dimmed.

3 On the toolbar, click .

You can also click Operations ➤ Check for Errors on the menu bar or right-click 
the partition and click Check for Errors on the context menu.

The Check Partition Results dialog appears.

If Check does not discover any errors, an Info entry appears with “Check Complete” 
in the Description column. 
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If a Check operation fails, “Check Failed” appears in the Used and Unused columns 
in the partition list. You should fix any errors encountered. For more information, see 
“Resolving Check Errors” on page 113.

If Check finds an error, such as cross-linked files, lost clusters, or bad directory 
information on an NTFS volume and can fix it, a Fix button appears at the bottom of 
the dialog. For each error found, Check displays the following:

• Severity describes the seriousness of the problem, which can be one of the 
following:

• Info:  The information given is helpful, but not critical. Does not correspond to 
any error.

• Warning:  The error may or may not cause problems.

• Error: A problem was encountered, but PartitionMagic may still be able to 
make changes to the partition. Run ScanDisk or CHKDSK to fix the error, or 
click Fix, if available.

• Critical: A catastrophic problem. PartitionMagic cannot make any changes to 
the partition.

• Fixed displays Yes for each problem you fix on an NTFS volume. Not 
applicable for FAT, FAT32, or HPFS partitions.

• Number shows a number corresponding to the error. For more information, 
see “Error Messages and Solutions” on page 115.

• Description gives a brief description of the problem.

4 To fix an error on an NTFS volume, highlight the problem and click Fix.

5 When you are finished viewing the check results and fixing NTFS errors, click Close.

Check does not display information about the status and structure of a partition as do the 
DOS, Windows, and OS/2 CHKDSK utilities. To view that information, use the Info  
option. For details, see “Getting Information About Partitions” on page 49.

PartitionMagic checks for OS/2 Extended Attribute errors on FAT partitions. If you do not 
use OS/2 or previously used OS/2 but no longer do, consider enabling the Ignore OS/2 
EA Errors on FAT  preference, as these errors are not a concern. For more information, 
see “Changing PartitionMagic Preferences” on page 16. OS/2 users should not enable 
Ignore OS/2 Errors on FAT, as undetected errors could cause data loss.
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Merging Partitions

You can merge two FAT or FAT32 partitions that are adjacent to each other on a disk. It is 
useful to merge partitions if you have reached the maximum number of partitions on your 
disk, but you do not want to delete a partition. It is also useful if you want to combine FAT 
partitions and convert them to one large FAT32 partition.

1 Click Operations ➤ Merge.

The Merge Adjacent Partitions dialog appears.

2 Under Merge options, choose the partitions you would like to merge.

The contents of one partition will be moved into a folder within the other partition.

You should not merge partitions that contain different operating systems.

3 Under Merge Folder, type a name for the new folder that will be created in the 
partition you are keeping.

4 Choose FAT  for FAT32 for the format of the partition you are keeping.



PowerQuest PartitionMagic 49

If you are combining FAT partitions, be careful not to convert them to FAT32 unless 
you have access to FAT32 partitions. Windows 95b or later, Windows 98, and 
Windows 2000 can access FAT32 partitions.

5 Click OK .

The partition map in the main window changes to show the merged partitions.

6 Click General ➤ Apply Changes to apply pending operations or General ➤ 
Discard Changes to cancel them.

Getting Information About Partitions

The Info operation displays information about the status and structure of a selected 
partition.

1 From the Disk drop-down list (located on the toolbar), select the disk containing the 
partition for which you wish to view information.

2 On the partition map or in the partition list, select the partition on which you want to 
view information.

3 On the toolbar, click .

You can also click Operations ➤ Info  on the menu bar or right-click the partition 
and click Info  on the context menu.
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The Partition Information  dialog appears.

Information is displayed in tabbed pages. To view a page, click its associated tab, 
which is always visible at the top of the pages. Based on the file system the partition 
uses, different pages appear.

4 Click the tab for the page you wish to view.

Each page is described in the following sections.

5 Click Close when you are finished viewing information.

Disk Usage

The Disk Usage page is available for the FAT, FAT32, NTFS, and HPFS file systems. This 
page displays the following information in bytes, megabytes, and as a percentage:

• Used space on the partition, including space wasted by clusters
• Unused space on the partition
• Bad space on the partition
• Total space on the partition (the sum of Used, Unused, and Bad space)

PartitionMagic also displays this information in a pie chart.
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Cluster Waste

The Cluster Waste page applies only to partitions using the FAT or FAT32 file systems.

This page displays the following information:

• Current Cluster Size in bytes or kilobytes
• Data stored on the partition in bytes and megabytes
• Wasted space on the partition in bytes and megabytes
• Total used space in bytes and megabytes (the sum of Data and Wasted space)

PartitionMagic also displays this information in a bar chart.

Partition Info

The Partition Info  page is available for all types of partitions, including unallocated space 
and extended partitions. Information on this page includes the following:

• Partition type  is shown in hexadecimal followed by a text description of the partition 
or file system type (such as FAT, FAT32, NTFS, or HPFS). The hexadecimal 
designation is the conventional way to display partition types.

• Serial Number is shown if the partition’s file system uses serial numbers.

The lower portion of the page shows physical information about the partition:

• First physical sector shows the logical number and the location (cylinder, head, and 
sector) where the partition begins.

• Last physical sector shows the logical number and the location (cylinder, head, and 
sector) where the partition ends.

• Total physical sectors displays the number of sectors in the partition.

• Physical Geometry shows the total number of cylinders, heads, and sectors on the 
physical disk where the partition resides.

File System-Specific Info Pages

The last page in the Partition Information dialog corresponds to the file system used on 
the selected partition. For example, if the file system is FAT or FAT32, the page is FAT 
Info ; if the file system is NTFS, the page is NTFS Info, and so forth.

FAT Info

This page applies to partitions using the FAT or FAT32 file systems.

The first section provides the following information:
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• Sectors per FAT shows the number of sectors in each file allocation table and the 
number of file allocation tables on the selected partition.

• Root directory capacity shows the number of possible entries and the number of 
sectors in the root directory. Because a FAT32 root directory can grow as needed, this 
line is blank for FAT32 partitions.

• First FAT sector shows the logical sector number within the partition where the FAT 
begins.

• First Data sector shows the logical sector number within the partition where the data 
portion of the partition begins.

The next section provides the following information:

• The number of bytes in files on the partition, the number of files, and the number of 
those files that are hidden

• The number of bytes in directories on the partition, the number of directories, and the 
number of those directories that are hidden

The final section of this page, FAT Extensions, provides the following information: 

• The number of bytes used for OS/2 Extended Attributes and the number of files and 
directories affected by Extended Attributes

• The number of bytes used for long filenames and the number of files and directories 
using long filenames

NTFS Info

This page applies to partitions using the NTFS file system. The first section shows the 
following information:

• NTFS Version shows the version number. The NTFS version does not match the OS 
version. For example, Windows NT 4.0 uses NTFS version 1.3.

• Bytes per NTFS sector displays the number of bytes in each logical sector on the 
selected partition. (There are always 512 bytes in each physical sector.)

• Cluster size displays the size of each cluster and the number of sectors in each cluster 
on the selected partition.

• First MFT Cluster  shows the logical number of the first cluster in the master file 
table (MFT).

• File Record Size gives the size of file records in the MFT.
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The next section displays information similar to that shown by NT CHKDSK:

• The number of files on the partition and the bytes and clusters allocated to them
• The number of wasted bytes in file clusters
• The number of indexes (directories) and the bytes and clusters allocated to them
• The number of bytes and clusters reserved for other system structures

HPFS Info

This page applies to partitions using the HPFS file system.

The first section displays the following information:

• Partition status shows one or more of these values:
• Active: OS/2 is running and data has been written to the partition.
• Dirty:  Windows NT or OS/2 was shut down improperly and is not running. 
• Corrupt:  One or more sectors are bad, and the partition needs to be checked. 
• Hot Fixes: Problems have been hot fixed.
• Not Active: The partition is not in use. 

• DirBlock sectors shows the range of sectors in the DirBlock band. The DirBlock 
band is usually preallocated near the center of the disk to reduce head movement.

• Free DirBlocks displays the number of unused DirBlocks in the DirBlock band and 
the total number of DirBlocks. If the DirBlock band fills up, additional DirBlocks are 
allocated from the data area. 

• HotFixes used displays the number of hotfix sectors used and the total number of 
hotfix sectors available. Hotfix sectors are used temporarily to handle write errors. 
CHKDSK /F transfers the data from a hotfix sector to a good sector and makes the 
hotfix sector available again. 

The last section displays information similar to that shown by OS/2 CHKDSK, including:

• The number of bytes and files on the partition and the number of sectors used for files

• The number of unused bytes in file sectors, which is equivalent to wasted bytes in 
FAT clusters. (Because HPFS allocates space by sectors, less space is wasted than in 
FAT clusters.)

• The number of bytes in directories, the number of directories on the partition, and the 
number of sectors used for directories

• The number of bytes in file/dir Fnodes, also shown as a number of sectors

An Fnode is a key structural element of the HPFS file system. Each Fnode is 512 
bytes (one sector). One Fnode exists for each file or directory in the partition.
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• Number of bytes reserved by the system, also shown as a number of sectors

• Number of bytes used for Extended Attributes (EAs)

Scanning a Disk for Errors

MS ScanDisk is a utility included with Windows 95 and Windows 98 that you can run 
from PartitionMagic. ScanDisk scans a partition for errors and fixes them. The Check 
operation also scans for errors, but it does not correct them.

If you are running Windows NT, you can run NT CheckDisk, rather than ScanDisk, from 
PartitionMagic.

1 From the Disk drop-down list (located on the toolbar), select the disk you want to 
scan.

ScanDisk only scans partitions with assigned drive letters; it does not scan hidden 
partitions, extended partitions, unallocated space, or partitions with file systems not 
supported by the active operating system.

2 On the partition map or in the partition list, right-click the partition you want to scan 
and click MS ScanDisk (or NT CheckDisk if you are running Windows NT) on the 
context menu.

You can also select the partition and click Operations  ➤ MS ScanDisk on the menu 
bar.
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The ScanDisk dialog appears.

3 In the Type of test box, click Standard or Thorough.

Thorough scans the partition for bad sectors.

4 (Optional) Click Automatically fix errors .



5 Click Start.

When ScanDisk is finished, the ScanDisk Results dialog displays information about 
errors on the partition (if any were found) and other disk statistics, such as total disk 
space, number of bytes in bad sectors, and total allocation units.

For more information about MS ScanDisk, consult Windows 95 or Windows 98 Help.

Viewing Pending Operations

PartitionMagic queues operations until you apply them. You can view the operations that 
are pending at any time.

1 Click Operations  ➤ View Operations Pending.

The list of pending operations is view-only. You can apply or discard all the changes 
listed using the commands on the General menu or the buttons on the toolbar.
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C H A P T E R4
Completing Advanced 
Operations
This chapter includes the following information:

• Changing a Drive Letter

• Retesting Bad Sectors

• Hiding and Unhiding Partitions

• Resizing the Root Directory

• Setting an Active Partition

• Resizing Clusters
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Changing a Drive Letter

The Change Drive Letter operation is only available when you are running Windows NT. 
This operation lets you change the drive letter assigned to any partition visible to and 
supported by Windows NT.

1 From the Disk drop-down list (located on the toolbar), select the disk with the 
partition whose drive letter you want to change.

2 On the partition map or in the partition list, right-click the partition whose drive letter 
you want to change and then click Advanced  ➤ Change Drive Letter on the context 
menu.

You can also select the partition and then click Operations  ➤ Advanced  ➤ Change 
Drive Letter on the menu bar.

The Change Drive Letter dialog appears.

3 In the New drive letter box, type or select the drive letter you want to assign to the 
partition.

4 Click OK .

5 Click  on the toolbar to apply the changes, or click  on the toolbar to discard 
the changes and start over.

You can also perform other partition operations and then click Apply Changes after 
completing all of them.

Retesting Bad Sectors

The Bad Sector Retest operation lets you check sectors on FAT partitions that have been 
marked bad and recover sectors that are usable.
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The FAT file system allocates disk space for file storage in units called clusters, which are 
composed of a fixed number of sectors. Because the FAT file system tracks bad sectors at 
the cluster level, it marks an entire cluster bad even though the problem may exist in a 
single sector. Use Info  to discover whether a partition contains bad clusters. For more 
information, see “Getting Information About Partitions” on page 49.

As a conservative measure, when you move or resize a partition or increase cluster size, 
PartitionMagic marks all new clusters containing any part of old bad clusters as bad (even 
though the clusters may not actually contain bad sectors). Likewise, when you decrease a 
partition’s cluster size, PartitionMagic divides bad clusters into multiple bad clusters. If, 
after you complete these tasks, PartitionMagic reports bad sectors, you can perform Bad 
Sector Retest and reclaim the good sectors that were marked bad.

1 From the Disk drop-down list (located on the toolbar), select the disk with the 
partition you want to retest.

2 On the partition map or in the partition list, right-click the partition you want to retest 
and then click Advanced  ➤ Bad Sector Retest on the context menu.

You can also select the partition and then click Operations  ➤ Advanced  ➤ Bad 
Sector Retest on the menu bar.

The Bad Sector Retest dialog appears.

3 To continue with the test, click OK .

Some sectors marked as bad are “marginally bad,” meaning that one time the sector 
works fine and another time it does not. Bad Sector Retest may mark a marginally bad 
sector as good. This can result in data loss if the marginally bad sector fails in the 
future. Most modern hard drives detect bad sectors and automatically remap the 
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sector, so in general, you do not see bad sectors on modern hard drives. If you do get 
bad sector errors on a modern hard drive, it is recommended that you replace 
the drive.

4 In the lower right corner of the PartitionMagic main window, click Apply changes.

Hiding and Unhiding Partitions

The Hide Partition  operation lets you secure partitions against unwanted user access. You 
can perform this operation on FAT, FAT32, NTFS, and HPFS partitions. 

When you hide a partition, the next time you boot your computer the partition is not 
assigned a drive letter. Conversely, when you unhide a partition, the next time you boot 
your computer the partition is assigned a drive letter. 

1 From the Disk drop-down list (located on the toolbar), select the disk with the 
partition you wish to hide.

2 On the partition map or in the partition list, right-click the partition you want to hide 
or unhide and click Advanced  ➤ Hide Partition  or Unhide Partition  on the context 
menu.

You can also select the partition and then click Operations  ➤ Advanced  ➤ Hide 
Partition  (or Unhide Partition ) on the menu bar.

WARNING! Note that unless you are running Windows NT, unhiding multiple 
primary partitions may cause data loss.

The Hide Partition  dialog appears, warning you that drive letters may change.

3 To confirm that you want to hide the partition, click OK .
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Hiding and unhiding partitions can cause the drive letters of other partitions to 
change. When this happens, your computer may not boot and applications may not 
run. PowerQuest recommends that you allow DriveMapper to run automatically to 
update drive letter references that change as a result of hiding or unhiding partitions.

4 In the lower right corner of the PartitionMagic main window, click Apply changes.

If your hard disk has more than one primary partition, only one is visible by default. When 
you use the Set Active operation, PartitionMagic unhides the selected primary partition 
and hides other primary partitions. While you can unhide more than one primary partition, 
we recommend that you do not.

If you are running Windows NT, partitions are not hidden automatically; therefore, you 
can have multiple visible primary partitions. 

Resizing the Root Directory

The Resize Root operation lets you change the maximum number of entries that can be 
placed in the root directory of a FAT partition. The number of root entries is set at the time 
the partition is formatted; the limit does not expand automatically as it does in a 
subdirectory or in a FAT32 partition. Consider increasing this number if you use Microsoft 
long filenames in the root directory. During this operation, data within the partition is 
unaffected.

1 From the Disk drop-down list (located on the toolbar), select the disk with the 
partition whose root directory you wish to resize.

2 On the partition map or in the partition list, right-click the FAT partition whose root 
directory you want to resize and click Advanced ➤ Resize Root on the context 
menu.

You can also select the partition and click Operations ➤ Advanced ➤ Resize Root on 
the menu bar.
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The Resize Root dialog appears, displaying the number of used entries and the 
current capacity.

3 In the New capacity box, type or select the number of entries you want the root 
directory to have.

The number you type will be rounded to one that preserves the current cluster 
alignment.

4 Click OK .

5 Apply the changes, or perform other operations and then apply all the changes at 
once.

Occasionally, enlarging the root directory displaces the first few files on the partition (such 
as IO.SYS and MSDOS.SYS if the partition contains an operating system). If the root 
directory is on a boot partition and the partition fails to boot after resizing the root 
directory, you should run SYS.COM to move the displaced files back to the front of the 
disk.

Setting an Active Partition

The Set Active operation lets you make a partition the active partition (the partition the 
computer boots from). Only one partition can be active at a time. To boot your computer 
from a partition, the partition must be on the first disk, and it must contain an operating 
system. When your computer boots, it reads the partition table of the first disk to find out 
which partition is active and boots from that partition.

IMPORTANT! Before you make a partition active, it must be bootable. If the partition is 
not bootable or if you are not certain if it is, have a boot diskette ready.
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PartitionMagic hides inactive FAT, NTFS, and HPFS primary partitions (unlike 
Windows 95, Windows 98, and DOS FDISK programs which cannot hide or unhide 
partitions). Hiding inactive primary partitions makes it easy to install multiple operating 
systems and choose the one you want to use with Set Active. For example, if you have 
Windows 95 and want to install Windows NT in a separate partition, you can make the 
Windows 95 partition smaller, create another primary partition, set it as the active 
partition, and then boot from the Windows NT installation diskettes.

1 From the Disk drop-down list (located on the toolbar), select the disk with the 
partition you want to make active.

2 On the partition map or in the partition list, right-click the partition you want to make 
active and click Advanced  ➤ Set Active on the context menu.

You can also select the partition and click Operations  ➤ Advanced  ➤ Set Active on 
the menu bar.

(Windows NT only) In a configuration with mixed IDE and SCSI hard disks, 
Windows NT does not always see the boot drive as the first disk. PartitionMagic 
displays drives in the order that Windows NT reports them. As a result, you may see 
your boot device as drive 1, 2, etc. PartitionMagic may also incorrectly report that 
there is no active partition. Be sure you identify which which drive is the boot drive.

The Set Active Partition dialog appears.

3 Click OK .

4 Apply the changes, or perform other operations and then apply all the changes at 
once.
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Resizing Clusters

The Resize Clusters operation lets you change the cluster size on FAT and FAT32 
partitions. Reducing cluster size may help you reclaim wasted space on your hard disk.

All files on FAT and FAT32 partitions are stored in allocation units called clusters. Each 
file on a partition is allotted at least one cluster. The size of a partition determines cluster 
size. Unless the size of a file is an exact multiple of cluster size on the partition where the 
file is located, the file includes wasted space. Larger partitions have larger clusters, and, 
therefore, more wasted space. For more information, see “Making Efficient Use of Disk 
Space” in Help.

1 From the Disk drop-down list (located on the toolbar), select the disk containing the 
partition where you want to resize clusters.

2 On the partition map or in the partition list, right-click the FAT or FAT32 partition 
where you want to resize clusters, and then click Advanced  ➤ Resize Clusters from the 
context menu.

You can also select the partition and click Operations  ➤ Advanced  ➤ Resize 
Clusters on the menu bar.

The Resize Clusters dialog appears.

For each cluster size, PartitionMagic displays the following:
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• A bar graph and percentages represent how much space would be used and how 
much space would be wasted if you chose that cluster size for the currently 
selected partition

• Wasted space (in megabytes)

• The range of allowable partition sizes (in megabytes) or other information

• If a cluster size requires a partition that is too small for the data and files on the 
partition, “Not Available” appears in the Notes column. “Not Enabled” appears in 
the Notes column for the 64 KB cluster size because it is only used for Windows 
NT. You can enable the 64 KB cluster size, but it is not recommended. For more 
information, see “Allow 64K FAT Clusters for Windows NT” on page 16.

The lower portion of the Resize Clusters dialog displays information about the 
current and new cluster size and the current and new partition size (based on the new 
cluster size).

3 Using the information in the dialog, decide which cluster size you want to use (and 
can use) and select it from the New cluster size drop-down list.

PartitionMagic adheres to the established limits for partition and cluster sizes. You 
cannot select a cluster size that is invalid for the selected partition.

Choosing a smaller cluster size may resize the partition smaller, creating unallocated 
space next to the partition. You can use this unallocated space by creating a new 
partition.

WARNING! Do not choose the 64 KB cluster size unless you have Windows NT 
and a 2–4 GB disk.

4 Click OK .

5 Apply the changes, or perform other operations and then apply all the changes at 
once.

Default Cluster Sizes

A partition’s cluster size is set by the DOS FORMAT operation, based on the size of the 
partition, as shown in the following tables.

DOS and Windows default FAT cluster sizes

Partition Size (MB) FAT Type Sectors Per Cluster Cluster Size

0-15 12-bit 8 512 bytes
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16-127 16-bit 4 2 KB

128-255 16-bit 8 4 KB

256-511 16-bit 16 8 KB

512-1,023 16-bit 32 16 KB

1,024-2,047 16-bit 64 32 KB

2,048-4,096 16-bit 128 64 KB*

*Only available with Windows NT.

Windows 95 OEM Service Release 2, Windows 95, and 
Windows 2000 default FAT32 cluster sizes

Partition Size (GB) Sectors Per Cluster Cluster Size

0.256- 8.01 8 4 KB

8.02-16.02 16 8 KB

16.03-32.04 32 16 KB

> 32.04 64 32 KB

It is not recommended that you use the smallest cluster size on 
partitions containing a single, large file, such as a database or 
swap file.

DOS and Windows default FAT cluster sizes

Partition Size (MB) FAT Type Sectors Per Cluster Cluster Size
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C H A P T E R5
Converting Partitions
This chapter includes the following information:

• Converting FAT Partitions to FAT32

• Converting FAT Partitions to HPFS

• Converting FAT Partitions to NTFS

• Converting FAT32 Partitions to FAT

• Converting NTFS Partitions to FAT

• Converting NTFS Partitions to FAT32

• Converting Primary Partitions to Logical

• Converting Logical Partitions to Primary
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Converting FAT Partitions to FAT32

The Convert FAT to FAT32 operation converts a FAT partition to FAT32. FAT32 
partitions have less wasted disk space than FAT partitions (for more information, see 
“Resizing Clusters” on page 64). However, you should be aware of these issues:

• You must have Windows 95 OEM Service Release 2, Windows 98, or Windows 2000 
to access files on a FAT32 partition. If you run an operating system other than these, 
FAT32 partitions will be inaccessible when the other operating system is running, 
even if one of these operating systems is installed on your machine.

• Some laptops have a sleep mode that saves all memory to disk. Because this function 
sometimes requires a FAT partition, consult your laptop manual or contact the 
manufacturer before converting to FAT32.

• The minimum recommended size for a FAT32 partition is 256 MB.

1 From the Disk drop-down list (located on the toolbar), select the disk containing the 
partition you wish to convert.

2 On the partition map or in the partition list, right-click the FAT partition you want to 
convert to FAT32 and click Convert ➤ Convert FAT to FAT32 on the context 
menu.

You can also select the partition and click Operations ➤ Convert ➤ Convert FAT to 
FAT32 on the menu bar.

The Convert Partition to FAT32  dialog appears.

3 To continue with the conversion, click OK . 
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4 Click General ➤ Apply Changes to apply the changes, or click General ➤ Discard 
Changes to discard the changes and start over.

You can also click Apply changes in the lower right corner of the PartitionMagic 
main window to apply changes.

You can also perform other partition operations and then apply the changes after 
completing all of them.

Converting FAT Partitions to HPFS

The Convert FAT to HPFS operation converts a FAT partition to HPFS. During this 
operation, PartitionMagic preserves data, long filenames (created by Microsoft Windows 
NT, Windows 95, and Windows 98), and Workplace shell long name Extended Attributes. 

WARNING! You must have OS/2 to access files on an HPFS partition. Without it, you 
will lose all files on the converted partition. Proceed with caution when 
performing this conversion, as it cannot be reversed.

1 Back up the data on your boot drive.

Because the conversion cannot be reversed, we strongly recommend that you take this 
precautionary step. 

If a Corrective Service Facility (CSF) has been applied to your version of OS/2, you 
must make new Install/Utility diskettes and use them in place of your original OS/2 
diskettes. 

2 Reboot your system from a diskette, from a partition other than the one you are 
converting, or from DOS. 

3 Run PartitionMagic from a partition other than the one you are converting.

4 From the Disk drop-down list (located on the toolbar), select the disk containing the 
partition you want to convert.

5 On the partition map or in the partition list, right-click the partition you want to 
convert and then click Convert ➤ Convert FAT to HPFS on the context menu.



Chapter 5: Converting Partitions70

The Convert Partition to HPFS dialog appears, displaying important information 
about the conversion.

6 To continue with the conversion, click OK . 

7 Click General ➤ Apply Changes to apply the changes, or click General ➤ Discard 
Changes to discard the changes and start over.

8 Click Yes to confirm that you want to apply the changes.

9 If you have open files, a prompt appears indicating that the changes you have made 
require going to MS-DOS mode (if you are using Windows 95 or Windows 98) or 
rebooting (if you are using Windows NT). Click OK  to make the changes. After the 
changes are made, the computer is rebooted.

If you do not have any open files, the Batch Progress dialog appears. When all 
operations are complete, click OK  to return to the PartitionMagic main window. 

IMPORTANT! Complete the remaining steps only if the partition you converted to 
HPFS contains OS/2.

10 Copy SYSINSTX.COM from the OS/2 Installation Disk to the root of the new HPFS 
partition. 

11 Copy UHPFS.DLL from the OS/2 Disk 2 to the root of the new HPFS partition.

If you have an OS/2 CD-ROM, consult your IBM documentation for instructions on 
creating a diskette from the disk image. 

12 Change to the new HPFS partition by typing drive:  (where drive is the drive letter 
of the partition you converted from FAT to HPFS). 
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13 From the root of the new HPFS partition, type SYSINSTX drive :  (where drive is 
the drive letter of the partition you converted from FAT to HPFS). 

14 Verify that HPFS.IFS is listed in the CONFIG.SYS file similar to the following: 

IFS=C:\OS2\HPFS.IFS /CACHE:256 /CRECL:4 /AUTOCHECK:C  

If this line is not present, add it, replacing C: and :C with the drive letter of the 
partition you just converted. 

IMPORTANT! If you want to be able to boot to the command line using <Alt+F1>, 
make this change to all CONFIG.* files in \OS2\BOOT. 

15 Verify that HPFS.IFS is present in the OS2 directory. If not, copy it from OS/2 
Installation Disk 1.

Your HPFS partition is now bootable.

Converting FAT Partitions to NTFS

The Convert FAT to NTFS operation launches the Microsoft Convert utility to convert a 
FAT partition to NTFS. You must be running Windows NT to complete this conversion.

If you boot multiple OSs, you must be careful converting FAT to NTFS. NTFS is only 
accessible with Windows NT; therefore, the data in this partition will not be accessible if 
you boot DOS or Windows 95/98.

1 From the Disk drop-down list (located on the toolbar), select the disk containing the 
partition you want to convert.

2 On the partition map or in the partition list, right-click the partition you want to 
convert and click Convert ➤ Convert FAT to NTFS on the context menu.

You can also select the partition and click Operations ➤ Convert ➤ Convert FAT to 
NTFS on the menu bar.
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The Convert Partition to NTFS dialog appears.

3 To continue with the conversion, click Yes. 

When you click Yes, PartitionMagic automatically applies any pending changes and 
exits. The Convert utility is then started.

4 If you have open files, a prompt appears indicating that the changes you have made 
require rebooting. Click OK  to make the changes. After the changes are made, the 
computer is rebooted. The partition is converted.

If you do not have any open files, the Batch Progress dialog appears. Click OK  to  
return to the PartitionMagic main window. The partition is converted.

Converting FAT32 Partitions to FAT

The Convert FAT32 to FAT operation converts a FAT32 partition to FAT.

1 From the Disk drop-down list (located on the toolbar), select the disk containing the 
partition you want to convert.

2 On the partition map or in the partition list, right-click the partition you want to 
convert and click Convert ➤ Convert FAT32 to FAT on the context menu.

You can also select the partition and click Operations ➤ Convert ➤ Convert FAT32 
to FAT  on the menu bar.

To complete this conversion, the partition must have at least 300-400 MB of unused 
space because of how the FAT file system allocates disk space for file storage.
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The menu command is dimmed if your FAT32 partition contains over 2 GB of data. If 
the partition size is over 2 GB but it contains less than 2 GB of data, you can convert 
the partition (without data loss), but the new partition will be 2039 MB.

At this point, PartitionMagic may report too many root directory entries (the 
maximum number of entries in a FAT partition’s root directory is limited, unlike a 
FAT32 partition’s root directory). In this case, move or copy some of the files in the 
root directory to another location and then start the conversion again.

The Convert Partition to FAT  dialog appears.

3 To continue with the conversion, click OK .

4 Click General ➤ Apply Changes to apply the changes, or click General ➤ Discard 
Changes to discard the changes and start over.

You can perform other partition operations and then apply the changes after 
completing all of them.

Converting NTFS Partitions to FAT

Converting an NTFS partition to FAT allows you to view the contents of the partition from 
DOS, Windows 95, or Windows 98.

IMPORTANT! You will lose file system-specific information when converting from 
NTFS to FAT. Refer to “NTFS Information Lost When Converting to FAT 
or FAT32” on page 74 for additional information.

1 Select the disk with the partition you want to convert, from the Disk drop-down list on 
the toolbar.
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2 On the partition map or in the partition list, select the partition you want to convert.

3 Click Operations ➤ Convert ➤ NTFS to FAT.

4 Click OK .

5 Click General ➤ Apply Changes.

NTFS is an advanced version of FAT and FAT32. Therefore, depending on the NTFS 
features used on the partition, the type of data, and partition size, you may or may not 
be allowed to complete the conversion.

If you receive an error message and the conversion stops, it is usually caused by one 
or more of the following:

• The file system for conversion is not allowed for the current partition size. A 
FAT32 partition should be greater than 256 MB, and a FAT partition must be less 
than 2 GB.

• The NTFS partition has data in memory that has not yet been written to the hard 
disk.

• The file system has errors, such as lost clusters and cross-linked files. You can fix 
these problems, then try the conversion again.

• There is not enough temorary space in the partition to do the conversion. The 
conversion will require the NTFS system and the FAT32 system files until the last 
step of the conversion. Also, there is data in NTFS FRS's that must be moved to 
external clusters and saved.

NTFS Information Lost When Converting to FAT or FAT32

If you can complete the conversion from NTFS to FAT or FAT32, you may receive a 
warning about the quality of data and feature loss, depending on the features used on the 
partition, the type of data, and the partition size.

Warning Description

Severe The conversion is allowed. However, because the partition being 
converted is using advanced features in NTFS, you may experience 
unintended data and feature loss. You will receive a severe warning in 
one or more of the following cases:

• There are sparse files on the volume. Any sparse files, except for 
the bad sector file, will stop the conversion.
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Severe 
(Continued)

• There is more than one data stream for any file.
• Any links.
• Any extended attributes.
• Any user-defined attributes in any file.
• Device entries.

Conversion The conversion is allowed. Although a conversion warning is not as 
serious as a severe warning, you may still experience the loss of 
NTFS-specific features that are not supported in FAT32. You will 
receive a conversion warning in one or more of the following cases:

• Disk usage quotas - NTFS supports limiting the amount of disk 
space for a user. After conversion, all users will have full access 
to all free hard disk space.

• Access control lists - This is a file attribute that lists all the users 
that can access a file. After conversion, all users will have full 
access to all files.

• Index of access control lists - A list of all files that have specific 
access rights assigned to them. After conversion, all users will 
have full access to all files.

• FAT index file - This file is sometimes created on Windows 2000 
computers. After conversion, all indexing of keywords will be 
lost.

• Old versions of files - NTFS has the ability to keep versions of 
files, however, only the current version of the file is converted 
and saved.

No Warning The conversion is allowed. The most basic NTFS partition still gives 
files more features than are found in FAT or FAT32. When Windows 
NT 4.0 is used to copy files from an NTFS partition to a FAT 
partition, no warning is given about the features you are losing. Also, 
the conversion will not give you a warning about specific features that 
cannot be converted. These features include:

• Standard journal file (only used internally by NTFS) - This file is 
a transaction log of changes to the NTFS file system. After 
conversion, the journal file will be lost.

Warning Description
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Converting NTFS Partitions to FAT32

Converting an NTFS partition to FAT32 allows you to view the contents of the partition 
from Windows 95b or Windows 98.

IMPORTANT! You will lose file system-specific information when converting from 
NTFS to FAT32. Refer to “NTFS Information Lost When Converting to 
FAT or FAT32” on page 74 for additional information.

1 Select the disk with the partition you want to convert, from the Disk drop-down list on 
the toolbar.

2 On the partition map or in the partition list, select the partition you want to convert.

3 Click Operations ➤ Convert ➤ NTFS to FAT.

4 Click OK .

5 Click General ➤ Apply Changes.

If the conversion fails, refer to the bulleted list on page 74 for a list of possible 
reasons.

No warning 
(continued)

• NTFS-specific file attributes - NTFS and FAT both have 
standard file attributes, such as Read-only, Archive, Hidden, and 
System. NTFS has additional file attributes that can be set. After 
conversion, however, these additional file attributes will be lost.

• NTFS-specific file dates - The last edit date is converted to the 
FAT date. After conversion, the creation date, last access date, 
and last edit date (date change only) will be lost.

• Reliable change journal - This journal file is new to Windows 
2000. After conversion, this file will be lost.

Warning Description
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Converting Primary Partitions to Logical

You might want to convert a primary partition to a logical partition if you have reached the 
limit of primary partitions on your hard disk. If you create a logical partition, 
PartitionMagic will automatically place it in an extended partition. You can then create 
more logical partitions within that extended partition, expanding the maximum number of 
partitions on the disk.

1 Select the disk with the partition you want to convert, from the Disk drop-down list on 
the toolbar.

2 On the partition map or in the partition list, select the partition you want to convert.

3 Click Operations ➤ Convert ➤ Primary to Logical.

If you already have an extended partition on the disk, the partition you want to 
convert must be adjacent to the extended partition; otherwise, it cannot be converted 
to logical.

4 Click OK .

5 Click General ➤ Apply Changes.

Converting Logical Partitions to Primary

You might want to convert a logical partition to a primary partition if you plan to install an 
operating system on it. The partition must be a primary partition to be bootable.

1 Select the disk with the partition you want to convert, from the Disk drop-down list on 
the toolbar.

2 On the partition map or in the partition list, select the partition you want to convert.

The partition must be either the first or last logical partition within the extended 
partition, or it cannot be converted to primary.

3 Click Operations ➤ Convert ➤ Logical to Primary.

4 Click OK .

5 Click General ➤ Apply Changes.
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C H A P T E R6
Using PartitionMagic Utilities
This chapter includes the following information:

• Changing Drive Letter References with DriveMapper

• Moving Applications with MagicMover

• Configuring BootMagic

• Running PartitionMagic from Rescue Disks

• Generating Diagnostic Reports with PartitionInfo

• Changing Bootable Partitions with PQBoot

• Using International Keyboards
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Changing Drive Letter References with DriveMapper

When you create, merge, delete, hide, and unhide partitions, your drive letters can change, 
causing applications not to run because application shortcuts, initialization files, and 
registry entries refer to incorrect drives. DriveMapper is a wizard that lets you easily 
update drive letter references.

1 From the PartitionMagic main window, click Tools ➤ DriveMapper.

You can also click Start (on the Windows taskbar) ➤ Programs ➤ PowerQuest 
PartitionMagic  ➤ DriveMapper .

DriveMapper also runs automatically if the following conditions are all met:

• You apply changes to your system that affect drive letter assignments.
• You are running Windows 95 or Windows 98.
• Your hard disk contains only FAT or FAT32 partitions.
• You have no more than one CD-ROM drive and no more than one removable drive.

If you are using Windows NT as your only operating system, we recommend using the 
Change Drive Letter operation rather than DriveMapper. Change Drive Letter lets you 
permanently set the drive letters for your partitions so that adding and removing partitions 
does not affect drive letters. Note that if you merge partitions, drive letters will change 
even if you are using Windows NT and the Change Drive Letter operation.

If you have installed an alternative desktop on Windows 3.11 or Windows 95/98 with the 
desktop files residing on a different drive than the Windows system files, DriveMapper 
may not be able to adjust your paths. Because DriveMapper is a Windows program, it 
must have Windows loaded to run. If the drive letter has been changed for the drive that 
holds your desktop files, you may not be able to start Windows.

Using DriveMapper With Multiple Operating Systems

If you run multiple operating systems, you should reinstall applications rather than use 
DriveMapper. The following issues make using DriveMapper in a multiple operating 
system environment difficult and error-prone:

• Drive letter assignments are based on the file systems supported by an operating 
system. If you do not put all FAT32, NTFS, and HPFS partitions after all FAT 
partitions, drive letters will change depending on the operating system currently 
running, and DriveMapper may be unable to correctly identify which changes should 
be made. For more information on how drive letters are assigned, see “Basic 
Concepts” in Help.
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• Registry settings are changed for the current operating system only. If you rerun 
DriveMapper from another operating system, references in files will already be 
changed and further changes will introduce errors.

• When DriveMapper is running, files contained in hidden partitions are not updated. If 
you are using multiple primary partitions for different operating systems, only the 
active primary partition may be visible. Thus, only files in that primary partition will 
be updated.

Changing Drive Letters in the Correct Order

DriveMapper must change drive letters in the correct order to avoid destroying original 
references before they are used to make changes for other drive letters. 

For example, assume you have two partitions on your hard disk (a primary partition C: and 
a logical partition D:) and a CD-ROM drive E:. Suppose you create a logical partition 
between C: and D:. The drive letter of D: changes to E:, and the drive letter of E: changes 
to F:; however, references in certain files (such as shortcuts) still reflect the original drive 
letter assignments. DriveMapper must first change the drive E: references to F: and then 
change the drive D: references to E:.

DriveMapper will automatically place changes in the proper order. PowerQuest strongly 
recommends that you apply changes in the order DriveMapper chooses.

Moving Applications with MagicMover

MagicMover is a tool that helps you move applications from one partition to another. For 
example, after creating a logical partition within an extended partition, you can use 
MagicMover to move applications to the new partition.

IMPORTANT! Moving an application with MagicMover does not enable that application 
to run under an operating system different from the one under which it was 
installed.

1 In the PartitionMagic main window, click Tools ➤ MagicMover on the menu bar. 

You can also click Start ➤ Programs ➤ PowerQuest PartitionMagic ➤ 
MagicMover on the Windows taskbar.
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At this point, MagicMover scans your system to obtain the most current information 
about files, including their sizes, dates, and interdependencies, such as which 
executables use which DLLs and their variants (such as OCX and VBX). When 
MagicMover is finished scanning, the MagicMover window appears.

Moving an application involves three steps, which are shown on the left side of the 
main window. A red arrow appears next to the step you are performing; a green check 
appears next to completed steps. 

The right side displays a hierarchy similar to the folder hierarchy in Windows 
Explorer. Icons represent the applications on your desktop, the applications in the 
Start menu, and the drives MagicMover found during the scan.

2 Find the application you want to move by double-clicking the appropriate icon, then 
double-clicking folders, and then clicking individual applications to select them.

You can select an individual application or a program group. 

When you select an application, the complete file path appears in the Selected 
Application/Folder  box.

3 When you have selected the application you want to move, click Next. MagicMover 
analyzes the applications and files to ensure that it can safely move them. A progress 
bar tracks the analysis.
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MagicMover cannot move any application from the Windows directory or any of its 
subdirectories.

If MagicMover can move the application, the dialog shown below appears. The 
Current application(s) folder box displays the path where the application you want 
to move is currently installed.

4 In the Select the destination folder box, type the path where you want to move the 
application or click Browse to select the desired directory.

5 If desired, click Details to view a list of the files that will be moved and changes that 
will be made to the Windows registry and initialization files.

6 Click Move.

A progress bar appears while MagicMover moves the applications, updates links 
between application files, and updates the Windows registry and initialization files.
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When the move is complete, MagicMover summarizes the actions that occurred.

7 To review a list of operations performed during the move, click Details.

8 To exit MagicMover, click Close. 

To move another application, click Continue.

9 Reboot the computer.

Configuring BootMagic

BootMagic is a PowerQuest application that helps you run multiple operating systems on a 
single computer. Each time you start or restart your computer, BootMagic presents a list of 
available operating systems from which you can select the operating system you want to 
boot.

BootMagic has a configuration window you can access from PartitionMagic to select and 
arrange the operating systems you want to appear as boot-up choices.

If the copy of PartitionMagic you purchased includes BootMagic, refer to Chapter 7 of 
this user guide for information about installing BootMagic and changing your BootMagic 
configuration.
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To purchase BootMagic, contact PowerQuest Sales at (800) 379-2566 or (801) 226-8977, 
or go to the PowerQuest web site at www.powerquest.com.

Running PartitionMagic from Rescue Disks

Create Rescue Disks is a wizard that helps you create diskettes you can use to boot your 
computer and run PartitionMagic for DOS (PQMAGIC). Rescue disks are useful when:

• You have hidden the partition where PartitionMagic is installed and need to run 
PartitionMagic to unhide the partition.

• You have accidently converted a partition to FAT32 and your operating system does 
not support FAT32, so your computer will not boot. (You can use the rescue disks to 
convert the partition back to FAT.)

• Other occasions arise when you do not have access to PartitionMagic on the CD or 
hard drive.

When you boot your computer from the first rescue disk, PQMAGIC automatically runs. 
You must insert the second rescue disk when prompted. PQMAGIC has the same look and 
functionality as PartitionMagic for Windows 95, except there are no wizards.

If you run out of space on the first rescue disk as a result of adding network, SCSI, or 
CD-ROM drivers to your boot sequence, you can delete the following files from the disk: 
chkdsk.com, fdisk.exe, ptedit.exe, and partinfo.exe. We recommend that you delete the 
files in that order, freeing up only the space that you need to accommodate additional files. 
These files are included in the Utilities folder on the PartitionMagic CD where you can 
access them later, if necessary.

If you use an international keyboard or character set, you will need to modify the 
AUTOEXE2.BAT and CONFIG.SYS files on the rescue disks. Refer to “Using 
International Keyboards” on page 90 for additional information.

Creating Rescue Disks Under Windows

You must have two blank 1.44 MB floppy disks available before you begin this procedure 
(three disks for double-byte languages). For information about creating rescue disks under 
DOS, refer to “Installing PartitionMagic Under DOS or OS/2” on page 8.
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1 You can create rescue disks under Windows in two ways:

2 Insert a blank formatted 1.44 MB disk into your 3.5-inch disk drive and click OK .

3 Follow the prompts and the instructions on the progress bar (located at the bottom of 
the window).

The rescue disks contain the following files:

If you create rescue disks for a double-byte language, the third disk includes fonts.

Running a Script from the Rescue Disks

If you have PartitionMagic Pro, you can modify the rescue disks to run PartitionMagic 
with a script file automatically.

1 Open the AUTOEXEC.BAT file on PartitionMagic 5.0 Disk 1.

2 Edit line line that includes PQMAGIC as follows, where SCRIPT.TXT is the name of 
the script file you want to execute:

PQMAGIC /CMD=SCRIPT.TXT

IMPORTANT! Do not include a hard return at the end of the line that includes the 
PQMAGIC command. Do not make any other modifications to the 
AUTOEXEC.BAT file.

To create rescue 
disks from: Do this:

PartitionMagic 
main window

Click Tools ➤ Create Rescue Disks on the menu bar.

Windows 95 or 
Windows 98

Click Start ➤ Programs ➤ PowerQuest PartitionMagic 
5.0 ➤ Create Rescue Disks.

PartitionMagic 5.0 Disk 1 PartitionMagic 5.0 Disk 2

• Partinfo.exe (utility program)
• PTEDIT (utility program)
• Keyb.com
• Mode.com
• Miscellaneous system files

• Mouse.com
• PMHelp.dat (help file)
• PQMagic.exe
• PQMagic.ovl
• PQMagic.pqg
• PQPB.rtc
• Rescue.txt
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3 Save the AUTOEXEC.BAT file.

4 Copy the AUTOEXEC.BAT file to PartitionMagic 5.0 Disk 2.

The file must be identical on both disks, or PartitionMagic will not function properly.

When you boot from the first disk, PartitionMagic will execute the script file you 
specified. For additional information about scripting, refer to PartitionMagic help.

Generating Diagnostic Reports with PartitionInfo

PartitionInfo generates a report showing the contents of your hard disk partition table. This 
information is helpful in resolving various partitioning problems (see “Error Messages and 
Solutions” on page 115). 

You can run PartitionInfo under Windows 95, Windows 98, and Windows NT 4.0 
workstation. If you are using DOS or Windows 3.x, run PARTINFO.EXE (see page 89).

The first time you run PartitionMagic on your machine, PartitionInfo creates a snapshot 
file PQ_ORIG.TXT that includes information about all the drives and partitions on your 
machine. The file is saved in the Windows\System folder (for Windows 95/98) or the 
%system root%\system32 directory (for Windows NT). Every other time you run 
PartitionMagic, another snapshot file, PQ_INFO.TXT, is created in the same directory. 
You can run PartitionInfo yourself to create additional snapshot files.

1 Click Start ➤ Program Files ➤ PowerQuest PartitionMagic 5.0 ➤ PartitionInfo . 

The PartitionInfo window appears, displaying partition and disk geometry 
information and disk and partition errors. Disk geometry information includes data 
from the master boot record and the extended partition boot records.

Only errors that display in the box near the top of the screen indicate problems. Do 
not be concerned with Warnings and Infos in the bottom two boxes.
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2 From the Physical Drive drop-down list, select the disk for which you wish to view 
information.

3 You can save the PartitionInfo report as a file, or you can print it.

4 To exit PartitionInfo, click Close.

To do this: Do this:

Save the report as a file Click Save As. In the Filename box, type a name 
for the file. Click Save. (Columns of information 
are separated by tabs, so you can open the file in a 
word processor and easily format the report.)

To change the font for a 
printed report

Click Printer Font . Select the desired font, font 
style, size, and so forth. Click OK .

To change printer setup Click File ➤ Printer Setup. We recommend that 
you set the page orientation to landscape to avoid 
text being cut off at the right margin.

To print a report Click Print , then click OK .
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Generating Diagnostic Reports with PARTINFO.EXE

You can also run PARTINFO.EXE from the second rescue diskette to get partition 
information. The PARTINFO program provides essentially the same information as the 
PartitionInfo program but without the GUI interface.

1 Boot the computer to DOS.

2 Insert the second rescue diskette.

3 You have several options for running PARTINFO. 

Changing Bootable Partitions with PQBoot

PQBoot is a quick and easy way to switch between bootable primary partitions. PQBoot is 
for users who only occasionally change the active partition and do not want to use 
BootMagic. For more information about BootMagic, see “Configuring BootMagic” on 
page 84.

1 (Windows 95/98 or Windows NT workstation) Click Start ➤ Programs ➤ 
PowerQuest PartitionMagic 5.0 ➤ PQBoot. Under Windows 95/98, PQBoot32 
will only run if PQVXD.VXD is in the same directory as PQBOOT32.EXE.

(Windows 3.x) Open the PowerQuest PartitionMagic program group, then 
double-click the PQBoot icon.

(DOS) Go to a DOS prompt. Change to the directory containing PQBOOT.EXE, then 
type PQBOOT.

2 If you are using Windows, a message appears indicating that PQBoot runs in 
MS-DOS mode and that all other programs will close if you continue. To continue, 
click Yes.

To do this: Do this:

To display partition 
information on your screen

Type PARTINFO, then press <Enter>.

To send a report directly to 
your printer

Type PARTINFO >LPT1  or PARTINFO 
>PRN, then press <Enter>.

To save the report as a text file 
on a floppy disk

Type PARTINFO >A:\PARTINFO.TXT , then 
press <Enter>.
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3 PQBoot displays a list of all primary partitions. Type the ID number of the partition 
(shown in the first column) you want to make the bootable primary partition.

Check the Status column to see if a partition is bootable.

4 Press <Enter>. 

PQBoot makes the partition active and reboots the computer.

PQBoot Command Line Switches

PQBoot offers several command line switches that are useful when you know the ID 
number or volume name of the partition you want to make active. To use a switch, run 
PQBoot from a DOS prompt. Supported switches include:

• /A  marks a partition active without rebooting.

• /P:<number> selects the active partition using the partition’s ID number.

• /S shows partition information, including ID numbers and volume names.

• /V:<label> selects the active partition using the partition’s volume label.

• /? displays a brief description of the switches and examples of how to use them.

For example, to set the second available bootable partition active without rebooting, type 
PQBOOT /P:2 /A .

Running PQBoot with Command Line Switches

1 Go to a DOS prompt.

2 Change to the directory containing PQBoot (typically C:\PROGRAM 
FILES\POWERQUEST\PARTITIONMAGIC\UTILITY\DOS).

3 (DOS) Type PQBOOT switch  (where switch  is the appropriate switch).

(Windows 95/98/NT) Type PQBOOT32 switch .

Using International Keyboards

When you use the DOS version of PartitionMagic (see page 85), you may lose the ability 
to use your keyboard the way you are accustomed to or to view extended characters 
properly. The PartitionMagic rescue disks include the files you need to resolve these 
problems.
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If you use an international keyboard or character set, you must edit the AUTOEXE2.BAT 
and CONFIG.SYS files on the rescue disks.

1 The following lines are remarked in the AUTOEXE2.BAT file. Delete the REM from 
the beginning of the line, and replace the variables xx  and yyy  with the keyboard 
code and character set code page for your language.

MODE CON CP PREP=((yyy )EGA.CPI)
MODE CON CP SEL=yyy
KEYB xx , yyy

xx  = two-letter keyboard code (for example, US or FR)
yyy  = character set code page (for example, 437)

2 Save the AUTOEXE2.BAT file.

3 The following line is remarked in the CONFIG.SYS file. Delete the REM from the 
beginning of the line, and replace the variable yyy  with the character set code page 
for your language.

DEVICE=DISPLAY.SYS CON=(EGA,yyy,)

4 Save the CONFIG.SYS file.

5 Reboot from the first rescue disk.
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C H A P T E R7
Using BootMagic
This chapter includes the following information:

• Getting Started

• Configuring BootMagic

• Setting BootMagic Passwords

• Adding an Operating System to the BootMagic Menu

• Removing an Item from the BootMagic Menu

• Modifying a Menu Item’s Properties

• Setting a Default Operating System

• Setting the Startup Delay

• Disabling BootMagic

• Using the BootMagic Menu

• Other BootMagic Options
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Getting Started 

PowerQuest’s BootMagic is a powerful disk-management tool that helps you run multiple 
operating systems on a single PC. Each time you start or restart your computer, 
BootMagic presents a list of operating systems (OSs) you can boot from. The 
configuration program lets you quickly select the OSs you want to appear in the 
BootMagic Menu and lets you set various boot-time options such as a default OS and a 
startup delay. 

With BootMagic, you can easily switch between OSs, using whichever OS best suits your 
immediate needs. You can even try out a new OS risk-free, knowing that your old OS is 
there, readily accessible when you need it.

BootMagic System Requirements

The following table lists the minimum and recommended system requirements for 
installing and using BootMagic.

Hardware/Software Minimum Recommended

Processor Intel/486SX 486 or above

RAM 4 MB (Windows 95, 
Windows 98 and 
Windows NT require 
additional memory)

16 MB or more

Hard-disk free space 10 MB 10 MB

CD-ROM drive Any speed Any speed

3.5-inch diskette 
drive

3.5-inch diskette drive 3.5-inch diskette drive

Operating system Windows 3.x, Windows 95, 
Windows 98, Windows NT 
4.0, DOS 5.0 or later

Windows 3.x, Windows 
95, Windows 98, Windows 
NT 4.0, DOS 5.0 or later

Monitor VGA Super-VGA

Pointing Device No pointing device is 
required to operate 
BootMagic

Microsoft mouse (or 
compatible pointing 
device)
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Supported Operating Systems

BootMagic supports the following operating systems:

Installing BootMagic

You can install BootMagic from Windows 95, Windows 98, Windows NT 3.51 or 4.0, and 
DOS 5.0 or later. For Windows 3.x systems, exit Windows and use the DOS installation.

IMPORTANT! BootMagic must be installed to a FAT or FAT32 primary partition on the 
first hard disk. 

1 Insert the PartitionMagic CD in your CD-ROM drive.

In Windows 95, Windows 98, or Windows NT 4.0, the setup program automatically 
starts when you insert the CD into the CD-ROM drive. 

2 If you are installing from the PartitionMagic CD, select Install  from the 
PartitionMagic setup screen and mark the BootMagic check box to launch the 
BootMagic install program.

If you are using DOS, type drive :\ENGLISH\BTMAGIC\DOS\INSTALL.EXE  
(where drive  is the drive letter of your CD-ROM drive).

3 Follow the on-screen instructions to install BootMagic.

After installation, BootMagic sorts through your system’s hard disks, looking at the 
partition tables and gathering information about each currently-installed operating system. 
BootMagic then automatically runs the configuration program, adding every detected OS 
to the BootMagic Menu. 

• Windows 98

• Windows 95

• Windows NT 4.0

• Windows NT 3.51

• Windows 3.x (must be installed 
with DOS 5 or later)

• MS-DOS 5.0 or later

• PC-DOS 6.1 or later

• Open DOS

• OS/2 3.0 or later

• Linux

• BeOS

• Most other versions of DOS 

• Some other PC-compatible OSs
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At this point, it may be necessary for you to edit the items that appear in the menu list. 
While BootMagic reliably detects most OSs, it may also detect some non-OS partitions. 
For example, if you have a primary NTFS data partition (that is, a partition which contains 
only data, no OS) on the first disk, BootMagic may detect it as Windows NT. Likewise, an 
HPFS data partition may be detected as OS/2 and a primary FAT16 or FAT32 data partition 
may be detected as MS-DOS or Windows 95/98. Because data partitions cannot be booted, 
you should remove them from the menu list. You can also choose to add or remove other 
OS selections, modify OS names and icons for easier identification, add passwords, set a 
new startup delay, or select a different default OS.

For information on detecting non-OS partitions in the menu list, see “Finding the Right 
Operating System” in BootMagic’s online Help. For more information on using the 
configuration program, see “Configuring BootMagic” on page 97 in this guide or refer to 
online Help.

After you make any necessary changes, click Save/Exit. The next time you reboot your 
computer the BootMagic Menu appears. To start an OS, simply select the desired menu 
item from the BootMagic Menu.

Creating a BootMagic Rescue Disk

During installation, you have the option to create a BootMagic rescue diskette. (DOS users 
should run drive:\BTMAGIC.PQ\MKRESCUE.BAT after the BootMagic DOS install to 
create the rescue diskettes.) This diskette is vital if your system’s master boot record 
(MBR) is ever damaged or overwritten. It can also be helpful if you inadvertently disable 
BootMagic and cannot access the configuration program to re-enable it.

WARNING! Technical support may not be able to assist you if you have not created a 
rescue disk.

To launch BootMagic’s configuration program from the rescue diskette, boot from the 
rescue diskette and follow the on-screen instructions.

Once in the configuration program, you can make any needed modifications or additions. 
When you click Save/Exit to exit the configuration program, BootMagic re-saves all the 
necessary files and rewrites the MBR, thereby restoring the program to normal.

Getting Help

If you need more information than this chapter provides, BootMagic’s online Help is your 
best solution. 

•  To access Help in the Windows configuration program, select Help ➤ Contents 
from the menu bar.
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• To access Help in the DOS configuration program, select Help ➤ Topic List  from 
the menu bar.

• To access context-sensitive Help, click Help in the lower-right corner of most 
dialogs, or press <F1>.

If you need further assistance, you can call PowerQuest Technical Support. See “Contact 
Information” on page 133.

Configuring BootMagic

BootMagic’s configuration program consists of two versions, one for DOS and one for 
Windows 95/98 and Windows NT Workstation. Both versions have similar interfaces and 
offer the same functionality.

BootMagic’s configuration program may be manually launched by any of the following:

• In Windows, select Start ➤ Programs ➤ PowerQuest BootMagic ➤ BootMagic 
Configuration .

• In DOS, run drive :\BTMAGIC.PQ\CONFIG.BAT .

• On the PartitionMagic main screen, click Tools ➤ BootMagic Configuration.

When you run the configuration program, the BootMagic Configuration window 
appears. From this window, you can set a password for the configuration program, the 
BootMagic Menu or specific menu items; add or remove an OS to the BootMagic Menu; 
modify an OS’s BootMagic properties; set your default OS; set the startup delay; or 
disable BootMagic. Each of these options are briefly covered in this chapter. For further 
information about configuring BootMagic or for details for each step outlined below, 
please refer to BootMagic’s online Help.

Setting BootMagic Passwords

BootMagic now allows users to password protect the BootMagic configuration program, 
the BootMagic Menu, or even specific menu items.

To set a password for the configuration program or the BootMagic Menu, follow these 
steps:

1 In the BootMagic Configuration window, click the Options menu.
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2 Select Set Configuration Password to password protect the configuration program 
or Set Boot-time Password to password protect the BootMagic Menu.

3 Enter the current password in the Old password text box.

The Old Password text box will be blank and disabled when there is no prior 
password.

4 Enter the new password in the New password text box.

5 Retype the new password in the Confirm new password text box.

6 Click OK .

To clear a password, enter the old password and leave the new password fields blank.

To set a password for specific BootMagic Menu items, you must modify the menu item’s 
properties. For more information, see “Modifying a Menu Item’s Properties” on page 99 
or refer to BootMagic’s online Help.

Adding an Operating System to the BootMagic Menu

1 In the BootMagic Configuration window, click Add.

2 (Optional) To view all your system’s partitions, including those that BootMagic does 
not recognize as containing an OS, mark the Advanced check box.

3 Select the OS you wish to add to the BootMagic Menu.

BootMagic may sometimes detect an OS that doesn’t exist or may detect the wrong 
name for an existing OS. For help on finding the operating system and partition you 
want, see “Finding the Right Operating System” in BootMagic’s online Help.

WARNING! Do not add non-OS partitions to the BootMagic Menu. You cannot 
boot your computer from a partition without an OS. If you add a 
partition that doesn’t have an OS and try to boot, you will be left with 
a black screen. 

In this event, soft boot your computer (press Ctrl-Alt-Delete), boot 
DOS or Windows from the BootMagic Menu, run the BootMagic 
configuration program, and remove the non-OS menu item from the 
BootMagic menu. 

4 Click OK .
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The BootMagic Menu Item Properties dialog appears.

5 Define the menu properties as desired, and then click OK . 

For more information on defining runtime menu properties, see “BootMagic Menu 
Item Properties” in BootMagic’s online Help.

Removing an Item from the BootMagic Menu

1 In the BootMagic Configuration window, select the item you wish to delete from the 
BootMagic Runtime Menu list.

2 Click Delete.

Deleting an OS from the BootMagic Menu does not remove the OS from your 
system. The OS remains in its partition and can be added again to the menu if desired.

Modifying a Menu Item’s Properties

1 In the BootMagic Configuration window, select the item you wish to modify.

2 Click Properties.

3 Modify the properties as desired, then click OK . 

For a description of each property, see “BootMagic Menu Item Properties” in 
BootMagic’s online help. 

Setting a Default Operating System

BootMagic automatically selects the OS on the home partition (that is, the partition on 
which BootMagic is installed) as the system default. This is the OS that BootMagic 
automatically boots if another OS is not chosen before the startup delay expires, or if the 
startup delay is set to None. 

For more information on the startup delay, see the next section, “Setting the Startup 
Delay.”

To select another OS as the default, 
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1 In the BootMagic Configuration window, select the OS you wish to set as the system 
default.

2 Click Set as Default.

Setting the Startup Delay

By default, BootMagic uses a Timed startup delay set to 30 seconds. You may change this 
setting with the following options:

• Select None to eliminate any time delay. BootMagic automatically boots the default 
OS at startup without displaying the BootMagic Menu. 

• Select Indefinite to specify an unlimited time delay. BootMagic displays the runtime 
menu until you choose the OS you wish to boot. 

• Select Timed to designate a time delay from 1 to 99 seconds. BootMagic waits the 
specified amount of time for an OS to be chosen before booting the default OS. 

If you set the startup delay to either None or Timed, you must also ensure that a valid OS 
item is selected as the system default. Without a default OS, BootMagic cannot boot your 
system.

If you set the startup delay to None and select a default OS that cannot run the BootMagic 
configuration program, you will be unable to modify the configuration settings and boot 
other OSs. If this happens, boot your computer while holding down the left Shift key. This 
overrides the timer settings and opens the BootMagic Menu without a timer (as the 
Indefinite  option) for that one boot. 

You can then select DOS or Windows from the BootMagic Menu, run the BootMagic 
configuration program, and change either the default OS or the startup delay.

Disabling BootMagic

You may encounter situations in which you want to disable BootMagic. For example, if 
you are diagnosing an OS startup problem and need to reboot your system multiple times, 
you may wish to bypass loading BootMagic every time. Disabling BootMagic replaces the 
BootMagic master boot record (MBR) with a copy of your original MBR.

Disabling BootMagic does not destroy any of your configuration settings. All of the 
current settings are saved until BootMagic is re-enabled.
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1 Unmark the BootMagic Enabled check box in the BootMagic Configuration 
window. 

The configuration options become unavailable, and BootMagic remains disabled until 
the box is re-checked. 

2 Click Save/Exit to save your changes and exit the configuration program. 

When you reboot your computer, BootMagic no longer loads and the default OS is 
automatically booted.

To re-enable BootMagic, run the configuration program from either your hard drive or the 
BootMagic rescue diskette. Mark the BootMagic enabled check box in the BootMagic 
configuration window. When BootMagic is re-enabled, it saves a copy of the current 
MBR and then reinstalls the BootMagic MBR. Upon reboot, BootMagic loads normally 
and all the previous configuration settings are restored.

For more information on creating a BootMagic rescue disk, see “Creating a BootMagic 
Rescue Disk” on page 96.

Using the BootMagic Menu

Once installed, the BootMagic Menu appears each time you start your computer. The 
BootMagic Menu displays all the OSs configured for booting. Each OS is identified by its 
user-assigned name and icon. Although BootMagic automatically highlights the default 
OS, you can choose any of the listed OSs. Simply click on the OS you want to boot. You 
may also use your arrow keys to select an OS and then press <Enter>.

If the OS you want is not listed, you can run the BootMagic configuration program and 
add it to the menu. For more information on adding an OS to the menu list, see “Adding an 
Operating System to the BootMagic Menu” on page 98.

Other BootMagic Options

BootMagic facilitates a host of OS-related tasks. For example, BootMagic makes 
installing multiple OSs on your system easy. For information on installing to primary or 
logical partitions, see “Using BootMagic to Install a New Operation System” in 
BootMagic’s online Help. You may also want to refer to the help topic on OS-specific 
installation issues. 
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BootMagic also enables you to boot operating systems that are not on the first hard disk. 
For specific instructions on second drive booting and beyond, see help topics “Booting 
Operating Systems from a Second Drive” and “Third Drive Booting and Beyond.”

Other new BootMagic features include Advanced Partition Hiding (that is, hiding all 
primary partitions on all disks except the primary partition being booted) and an option to 
change the BootMagic background screen to a customized, Windows format bitmap. Refer 
to the BootMagic online help for comprehensive information about BootMagic features 
that are not discussed in this chapter.
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A P P E N D I XA
Using PartitionMagic With 
Other Programs
This appendix includes the following information:

• Norton Utilities

• Disk Compression Utilities

• Operating System Boot Utilities

• Virus Protection Software

• Drive Overlay Programs

• SoundBlaster
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Norton Utilities

You can safely use PartitionMagic and Norton products together. The following 
information will help you avoid any problems.

Norton Disk Doctor

If an extended partition ends at the end of a drive, Norton Disk Doctor (NDD) will 
sometimes display this message: “An extended partition has invalid parameters and 
probably is inaccessible. Correct this situation if you are unable to access partitions on 
hard disk 1. Do you wish to correct this problem?” To eliminate this message, use 
PartitionMagic to resize the logical and extended partitions at the end of the drive to leave 
some free space before the end of the drive.

Additionally, when you delete, move, or resize partitions, it appears to NDD that you 
could have inadvertently deleted a partition. NDD displays the following message: “If you 
are unable to access a disk that you previously could, you should revive this partition. 
Would you like to revive this partition?” If you inadvertently deleted a partition, select 
Yes. If you do not want this message to appear every time you run NDD, complete the 
following:

1 Click No. 

NDD displays this message: “You have chosen not to revive the partition. Do you 
want Norton Disk Doctor to mark the partition so it doesn’t ask about it again?”

2 Click Yes. 

The Create Undo File dialog appears.

3 Click Skip Undo File. (Creating an undo file uses many diskettes.) 

NDD displays this message: “If you wish to undelete this partition at a later time, use 
the /UNDELETE switch.”

4 Click OK . 

NDD displays this message: “Partition information has been changed. Would you like 
to restart your computer?”

5 Click Restart Your Computer.
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Norton AntiVirus

Because Norton AntiVirus (NAV) interprets changes to partition tables and boot records as 
potential virus attacks, PartitionMagic takes steps so that NAV automatically reinoculates. 
Should NAV give you the choice of repairing the changes, do not select Repair. Instead, 
inoculate after using PartitionMagic.

Disk Compression Utilities

You can safely use PartitionMagic and some disk compression utilities together. The 
following information will help you avoid any problems.

DriveSpace and DriveSpace 3

To use PartitionMagic with DriveSpace, you must first change the size of a DriveSpace or 
DriveSpace 3 drive in Windows 95 or Windows 98 by completing the following:

1 On the Windows desktop, double-click My Computer.

2 Right-click the drive you wish to alter.

3 Select Properties on the context menu.

4 Click the Compression tab.

5 From the Compression menu, select Advanced.

6 In the Advanced Properties menu, select Run DriveSpace.

A list of your physical drives, compressed drives, and host drives appears.

7 Choose the compressed volume you wish to change.

8 At the top of the menu, click Drive.

9 From the Drive menu, click Adjust  Free Space. 

The Adjust Free Space menu appears. At the bottom of the menu is a slide bar. 

10 To increase compressed space (enlarge the compressed volume), move the slide bar to 
the left. To increase uncompressed space (shrink the compressed volume), move the 
slide bar to the right.

If you wish to shrink the host for a compressed drive, move the bar to the right to 
create more uncompressed space on the host. You can then use PartitionMagic’s 
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Resize/Move operation to make the host partition smaller. If you have already resized 
the partition larger and want to add more space to the compressed volume, move the 
slide bar to the left.

Operating System Boot Utilities

Both OS/2’s Dual Boot and System Commander 2.0 and above accommodate boot sector 
changes made by PartitionMagic. To install System Commander on drives that 
PartitionMagic has modified, you may need to use System Commander 2.06 or later.

If you have System Commander on your computer, you must configure it so that it does 
not simultaneously unhide multiple primary partitions. To configure System Commander 
so that it does not create multiple visible primary partitions, complete these steps for each 
operating system selection on the System Commander menu:

1 On the Operating System Selection menu, select an operating system.

2 Press <Alt+S>. 

3 From the resulting menu, select the Local Special Options menu.

4 Click Primary partitions accessible on drive 0. 

A screen appears with three options: ALL , AUTO , and NONE. AUTO  is the default. 
Select NONE. 

The other primary partitions will now be hidden when this operating system boots. 

5 Repeat this procedure for all operating system selections on the menu.

Virus Protection Software

PartitionMagic modifies the master boot record and partitions’ boot sectors. Virus 
protection software should be able to detect that PartitionMagic is changing partition 
tables and not boot code; however, it is possible that unsophisticated virus protection 
programs may mistake PartitionMagic changes as attempts to install a virus. If this occurs, 
turn off the virus protection program while using PartitionMagic and inform the virus 
protection software manufacturer of the problem. 

Some motherboards contain virus protection software within the BIOS. If this causes a 
problem when you are running PartitionMagic, disable the BIOS virus protection, and 
then restart PartitionMagic.
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Drive Overlay Programs

Drive overlays, such as Ontrack DDO, Microhouse EZ-Drive or Pro-Drive, Maxblast, WD 
DDO, and Seagate DDO, provide your computer with access to larger disk drives. 
PartitionMagic is compatible with these programs only if the drive overlay program is 
loaded before PartitionMagic.

If you boot your computer from a diskette, the overlay will not load, and PartitionMagic 
will not get the correct information from your drive. You can boot from a diskette and still 
load the drive overlay by completing the following:

1 Start your computer as if you were going to boot from the hard disk. 

2 When prompted, press <Space> or <Ctrl> .

3 The drive overlay information appears with an option of booting from a diskette. 
Select this option and insert the boot diskette when prompted.

SoundBlaster

If you load load DOS drivers for a SoundBlaster Live sound card in your autoexec.bat and 
config.sys files and then perform an operation in PartitionMagic that requires 
PartitionMagic to go into boot-mode, PartitionMagic will crash.

To resolve the problem, unload the SoundBlaster drivers until after you have finished 
using PartitionMagic.
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A P P E N D I XB
Troubleshooting
This appendix includes the following information:

• General Troubleshooting

Freeing Memory to Run PartitionMagic under DOS

Assigning a CD-ROM Drive Letter

Using PartitionMagic With a SCSI Hard Disk

Resolving Check Errors

Resolving Partition Table Errors

Partition Tables and Viruses

Partition Will Not Boot After Resizing

• Error Messages and Solutions
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General Troubleshooting

This section addresses the following situations:

• Freeing Memory to Run PartitionMagic under DOS

• Assigning a CD-ROM Drive Letter

• Using PartitionMagic With a SCSI Hard Disk

• Resolving Check Errors

• Resolving Partition Table Errors

• Partition Tables and Viruses

Freeing Memory to Run PartitionMagic under DOS

The DOS PartitionMagic executable requires a minimum of 585 KB of memory in the first 
640 K of the computer’s address space (conventional memory). If you do not have 
sufficient conventional memory, there are several ways you can free additional memory.

Running MEMMAKER

MEMMAKER is a program that automatically configures your computer to save 
conventional memory (while still loading all of the device drivers and other programs you 
usually load when booting DOS). MEMMAKER frees conventional memory by moving 
as many programs as possible out of conventional memory into high memory. Run 
MEMMAKER by typing MEMMAKER at a DOS prompt. Follow the on-screen 
instructions.

MEMMAKER is only available in DOS 5.0 to 6.22. It is not available in Windows 95 or 
Windows 98 DOS mode.

Using the F8 Key to Keep Programs From Loading

Press <F8> immediately after booting your computer (while DOS is booting). As DOS 
reads the each command in the CONFIG.SYS and AUTOEXEC.BAT files, it asks if you 
want the command executed. When you see commands that load device drivers or TSR 
programs not needed to run PartitionMagic, press N so that the software is not loaded into 
memory.
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Deleting Operating System Compression Files

If you use DOS 6.22, Windows 95, or Windows 98 and your system does not have any 
compressed drives (using programs such as DriveSpace, DoubleSpace, and Stacker), you 
can delete the operating system compression files, DRVSPACE.BIN or DBLSPACE.BIN, 
from any boot diskette you create. This frees conventional memory because DOS 6.22, 
Windows 95, and Windows 98 load these files into memory, regardless of the contents of 
CONFIG.SYS and AUTOEXEC.BAT.

DRVSPACE.BIN and DBLSPACE.BIN are hidden system files. To delete them, complete 
the following:

1 Place your boot diskette in your diskette drive.

1 Go to a DOS prompt. 

2 Type A:  and press <Enter>. You should see A:\>  on your screen.

3 Type ATTRIB -R -H -S *.BIN , and press <Enter>.

4 Type DEL *.BIN  and press <Enter>.

Assigning a CD-ROM Drive Letter

If your computer has a CD-ROM drive or any form of removable media, you should be 
aware of potential problems caused by the way drive letters are assigned to these devices.

If you are using Windows NT, you can change drive letter assignments with 
PartitionMagic; otherwise, this is a function of the operating system. The operating system 
assigns drive letters in this order: (1) the first recognized primary partition on each hard 
disk, (2) all logical partitions on each hard disk, (3) any other primary partitions on each 
hard disk, and (4) the CD-ROM drive and any other forms of removable media. For more 
information, see “How the OS Assigns Drive Letters” in Basic Concepts in Help. 

Because the CD-ROM is one of the last drives to receive a letter, any partition you create 
or delete on any of your hard disks affects the drive letter assignment of your CD-ROM 
drive. Occasionally, the operating system may not assign a drive letter to the CD-ROM 
drive. If this occurs, complete the steps outlined below.

If you are using Windows 95/98 and Windows 95/98 drivers for the CD-ROM:

1 On the toolbar, click Start ➤ Settings ➤ Control Panel.

2 Double-click System.

3 Click the Device Manager tab.
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4 Double-click CD-ROM . 

5 Double-click the name of your CD-ROM drive.

6 Select the Settings tab. 

7 In the Start drive letter  and End drive letter boxes, type or select Z. Because the OS 
assigns all other available drive letters before assigning Z, this ensures that partition 
changes you make in the future do not invalidate your CD-ROM drive letter. 

8 Click OK  to close the Settings page. 

9 Click OK  to close the System Properties dialog.

10 When prompted to restart your computer, click Yes.

If you are using DOS or Windows 3.x or are loading your CD-ROM drivers under DOS 
with Windows 95/98:

1 Go to a DOS prompt.

2 Type EDIT C:\CONFIG.SYS . 

Your CONFIG.SYS file opens in the DOS editor program. Look for this line: 
LASTDRIVE=drive (where drive is any letter of the alphabet). Change drive to Z. 
This allows the OS to assign all drive letters through Z.

3 If your CONFIG.SYS file does not contain the LASTDRIVE=drive statement, you 
can add it by simply typing LASTDRIVE=Z.

4 Select File ➤ Exit . 

5 When you are prompted to save the file, select Yes. You should be back to a C:\> 
prompt.

6 Type EDIT C:\AUTOEXEC.BAT . 

7 Your AUTOEXEC.BAT file opens in the DOS editor program. Look for a line that 
includes the word “MSCDEX.” The /L:drive parameter (where drive is the drive letter 
assigned to your CD-ROM before you made changes with PartitionMagic) may 
appear at the end of this line. Change drive to Z. Because the OS assigns all other 
available drive letters before assigning Z, this ensures that partition changes you make 
in the future do not invalidate your CD-ROM drive letter. For more information, type 
HELP MSCDEX  at a DOS prompt.

If your computer is on a network, when you log in to the network, the letter “Z” and 
other letters at the end of the alphabet may be assigned to network search drives. In 
this case, assign your CD-ROM a letter immediately preceding the last letter used by 
the network search drives.
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8 Select File ➤ Exit . 

9 When you are prompted to save the file, select Yes.

10 When you see the DOS prompt (C:>), reboot your machine.

Using PartitionMagic With a SCSI Hard Disk

To use PartitionMagic on a SCSI hard disk, you must have a SCSI controller card that 
supports software Interrupt 13. Most SCSI controller cards let you enable software 
Interrupt 13 support in the BIOS through the card. If your SCSI controller card does not, 
contact the manufacturer to determine if your adapter can support software Interrupt 13. 
As a general rule, if you are able to use FDISK to partition the disk, you will also be able 
to use PartitionMagic.

Resolving Check Errors

PartitionMagic checks the integrity of a partition thoroughly before making changes to it. 
The Check and Info  operations perform the same checks and display error messages 
when they discover problems. For more information, see “Checking Partitions” on 
page 46 and “Getting Information About Partitions” on page 49. These checks are similar 
to those made by an operating system’s CHKDSK, ScanDisk, or AUTOCHK utility.

PartitionMagic also checks a partition after modifying it. While data loss is possible, it is 
not typical. The problem is usually a minor file system error that CHKDSK /F /R (or 
ScanDisk, if you are using Windows 95/98) can correct without data loss. For more 
extensive errors, you may need to restore your files from a backup copy. If problems 
persist, report the problem to PowerQuest technical support.

If you receive a Check error message on any partition, back up your hard disk and then 
run your operating system’s CHKDSK program on that partition (do not use the /F switch 
on the initial run). If you have MS-DOS 6.x, Windows 95, or Windows 98, run ScanDisk. 
CHKDSK and ScanDisk generally discover the same problems as PartitionMagic (except 
that the DOS CHKDSK program does not detect problems in Extended Attributes). 

If CHKDSK or ScanDisk does not show the same errors as the Check operation, contact 
PowerQuest technical support. For more information, see Appendix C of this user guide.

If CHKDSK or ScanDisk and the Check operation detect the same errors, which is usually 
the case, run CHKDSK with the /F switch or run ScanDisk to fix the problems. Then 
run CHKDSK again without the /F switch to ensure that the partition is error free. Under 
OS/2, perform this procedure (running CHKDSK without /F) twice.
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When CHKDSK reports no errors on the partition, run the Check operation. If 
PartitionMagic still reports a problem, reformat the partition and restore your files from 
the backup copy.

Resolving Partition Table Errors

Partition table errors are errors in the 100 - 199 range. In most cases, you must resolve 
partition table errors by creating new, error-free partition tables. The general steps are: (1) 
ensure you have no viruses (see below), (2) back up the data on the affected partitions, (3) 
delete the partitions, (4) recreate them, and (5) restore their contents. You may need to use 
the FDISK program from a recent DOS version, as earlier versions may refuse to delete 
HPFS or hidden partitions, and the OS/2 FDISK program may recognize the partition’s 
corruption and refuse to modify it.

In some cases, you can resolve partition table errors manually. Run PartitionInfo to 
determine the errors on your partitions. PowerQuest technical support can help resolve 
partition table errors if you e-mail the PartitionInfo report to help@powerquest.com. 
Refer to “Generating Diagnostic Reports with PartitionInfo” on page 87 for additional 
information about PartitionInfo.

Partition Tables and Viruses

If partition changes made under one operating system are not reflected under another, and 
vice versa, a master boot record (MBR) virus may be present.

Use a virus check utility that can detect the latest viruses. If a virus is found, data loss is 
likely. Before removing the virus, boot each operating system and use the Check 
operation to evaluate the integrity of the partition. Back up the files on any partition that 
passes the Check operation. Then remove the virus and perform the Check operation on 
the partitions again. Delete and recreate any partitions that fail the check. Finally, reinstall 
the operating systems and restore the backup files as necessary.

Partition Will Not Boot After Resizing

Occasionally, resizing a FAT partition displaces the first few files on the partition (such as 
IO.SYS and MSDOS.SYS if the partition contains an operating system). If you resize a 
boot partition and then it fails to boot, run SYS.COM from DOS or from the 
PartitionMagic rescue diskettes.
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Error Messages and Solutions

PartitionMagic error messages and possible solutions are listed below by number. The 
messages are also grouped in number ranges by error category. 

If you encounter an error not mentioned in this appendix, visit PowerQuest’s web site at 
www.powerquest.com/support/ER/er0000.html for a current listing. Error message 
information on the web site is available in English only.

Miscellaneous Errors (3–38)

#3 Not enough memory

This error can occur when you are resizing, moving, or copying a FAT32 
partition. For more information about memory requirements, see “PartitionMagic 
System Requirements” on page 5.

The DOS PartitionMagic executable requires a minimum of 585 KB of memory 
in the first 640 KB of the computer’s address space (conventional memory) and 8 
MB of total memory. For possible solutions if you have insufficient conventional 
memory, see “Freeing Memory to Run PartitionMagic under DOS” on page 110.

#8 Could not allocate/deallocate DOS real mode memory

The DOS PartitionMagic executable running under DOS, Windows 3.x, 
Windows 95, and Windows 98 requires some memory in the first 1 MB of the 
computer’s address space (PartitionMagic uses a DOS extender). If not enough 
memory is available, PartitionMagic cannot access the hard disk. For possible 
solutions, see “Freeing Memory to Run PartitionMagic under DOS” on page 110.

#27 Cannot lock drive 

Under multitasking operating systems such as Windows 95, PartitionMagic must 
lock a partition before it can safely modify it. If the hard disk contains files that 
are in use by another process, PartitionMagic cannot lock the partition. 

#29 Cannot lock a locked drive

Verify that the partitions you are attempting to modify are not on a locked hard 
disk.

#34 The time has expired on this evaluation version

PowerQuest occasionally releases beta versions and evaluation versions of 
PartitionMagic. Both versions are not as safe as release versions; therefore, 
PowerQuest builds an expiration date into each version. After a predetermined 
test period, the beta or evaluation version no longer functions. 
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Disk Access Errors (40–56)

Errors in the 40–56 number range indicate that accessing your disk is not possible, and 
often result from hardware problems. Some problems may have simple solutions; for 
others, the only solution may be replacing the hard disk. When possible, PartitionMagic 
detects major errors before any changes have been made so you can back up your data 
before replacing the hard disk.

#45 CRC error in data

When PartitionMagic or any other program reads information off of a hard                     
disk, it checks the CRC (cyclic redundancy check) information contained in                     
each sector. If it performs a CRC test and the result is different from the                     
value stored on that sector, there is a CRC error. This usually means one of                     
two things.

• The file being read has become corrupted by some other means.
• A sector used in the file’s storage has become bad and corrupted                     

that part of the stored file.

The solution is to do a surface test to make sure any bad sectors are marked as 
bad, then reinstall the software involved to ensure that files on the system are not 
corrupted. You may also want to try running PartitionMagic with an /IRE switch. 

#48 Sector not found

This error can be reported when a given sector cannot be read or written to.                     
There are many possible causes.

If you are encountering this error, make sure that your BIOS supports the 
operating system and hard disk on the system. Also run a thorough ScanDisk on 
the drive to prevent data from being written to bad sectors. 

#49 Write fault 

#50 Read fault

(The following information applies to errors 49 and 50.) 

PartitionMagic is unable to write to/read from a specific sector on the hard disk. 
Possible causes include:

• If your PC beeps or displays a black box in the middle of the screen, virus 
protection is enabled in your computer’s BIOS. Disable virus or boot sector 
protection in the BIOS.

• A virus protection application (which may be a TSR or DLL program) is in 
use. Disable the application before using PartitionMagic.
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• There is a bad sector on the hard disk (this is usually the case only with older 
hard disks). Run ScanDisk on the hard disk to perform a surface scan to verify 
the existence of bad sectors. If your drive has bad sectors, we recommend you 
replace it.

• You have set up disk mirroring with PC-Tools. Disable the disk mirroring 
option.

Miscellaneous Error

#70 Changes to the drive cannot be made under Windows

If you are using Windows 3.x, you cannot run PartitionMagic for Windows 95, 
Windows 98, or Windows NT Workstation. You must run PartitionMagic for 
DOS from a DOS prompt.

Partition Table Errors (100–199)

Errors in the 100–199 number range are partition table errors. For general information 
about resolving these errors, see “Resolving Partition Table Errors” on page 114 and 
“Partition Tables and Viruses” on page 114.

#100 Partition table is bad

The master boot record (MBR) can contain, at most, one extended partition, and 
each extended partition boot record (EPBR) can contain, at most, one link to 
another EPBR. This error occurs when a partition table violates the foregoing 
rule. It can also occur if you have more than one active partition. Since any 
modifications PartitionMagic makes may decrease the amount of data that is 
recoverable from the hard disk, PartitionMagic does not recognize any of the hard 
disk’s partitions. If you must create new, error-free partition tables to resolve 
your problem, see “Resolving Partition Table Errors” on page 114 for 
instructions.

#104 No sectors in partition 

No partition should contain zero sectors. Delete the partition before using 
PartitionMagic. 

#105 Partition starts on wrong boundary 

The hard-disk partition table contains erroneous values. PartitionMagic expects 
partitions to begin and end on the correct cylinder boundaries. If they do not, the 
disk may be partially corrupted. In this circumstance, if PartitionMagic were to 
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make any modifications it might cause the loss of data. Therefore, PartitionMagic 
refuses to recognize any of the hard disk’s partitions. To resolve this problem, see 
the instructions in “Resolving Partition Table Errors” on page 114.

#106 Partition doesn’t start with sector one

See error #105.

#107 Partition begins after end of disk 

This error can occur if a partition erroneously extends beyond the physical end of 
the hard disk. This may happen if the hard disk has been used on a different 
computer or with a different hard-disk controller or if BIOS settings have been 
changed. Be advised that the physical geometry of the hard disk may differ from 
the logical geometry assigned to the hard disk by the operating system.

#108 Partition doesn’t end at end of cylinder 

See error #105.

#109 Partition ends after end of disk 

See error #107.

#110 Partition table number of sectors is inconsistent 

The hard-disk partition table contains two inconsistent descriptions of the number 
of sectors on the hard disk. This error is serious if both DOS and another 
operating system use the hard disk. Because DOS uses one description and other 
operating systems may use the other, data loss is likely once the partition is 
almost full. To resolve this error, see the instructions in “Resolving Partition 
Table Errors” on page 114.

#111 The order of entries in the EPBR is not correct.

An extended partition boot record (EPBR) is a sector on the hard disk that 
contains a partition table. The EPBR partition table is special because it generally 
only has two valid entries: one for the logical partition and one that is a pointer to 
the next EPBR. The standard is for the logical partition's entry to be the first entry 
in the table and the second entry is the pointer to the next EPBR. The third and 
fourth entries are not used. For some utilities, such as IBM's Boot Manager, the 
order of these entries is important because the utilitiy expects the first entry to be 
the logical and the second entry to be the pointer to the next EPBR. If 
PartitionMagic detects that the EPBR entries are out of order, you will be 
prompted to fix the error. If you choose to fix the error, PartitionMagic will 
reorder the EPBR entries for you automatically.
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#112 Logical partition ends outside Extended 

See error #111. 

#113 Partitions overlap 

The hard-disk partition table contains erroneous values. If data partitions overlap, 
writing to one may destroy data in another.

This error is sometimes the result of an OS/2 FDISK bug. If free space exists 
within the extended partition, OS/2’s FDISK program allows a primary partition 
to be created that overlaps the extended partition. A logical partition is 
subsequently created in the space occupied by the overlapping primary partition. 

If a primary partition overlaps the end of the extended partition but does not 
overlap any logical partitions within the extended partition, the problem can be 
remedied by patching the partition table. Only qualified individuals should 
attempt this repair! An incorrect patch could destroy all data on the hard 
disk! In most instances, you should resolve the problem as explained in 
“Resolving Partition Table Errors” on page 114.

#116 Partition table Begin and Start inconsistent

The hard-disk partition table contains two inconsistent descriptions of the 
partition’s starting sector. This error can occur if the operating system reports a 
hard-disk geometry that is different than the geometry in use when the partition 
table was written. Possible causes include: (1) different operating systems (for 
example, DOS and OS/2) report different hard-disk geometries, (2) you boot 
from a diskette that loads a different driver than is loaded when you boot from the 
hard disk, (3) upgrading the operating system (for example, from OS/2 2.x to 
OS/2 Warp) causes a different driver to be used, (4) the hard disk or controller 
has been changed, (5) the BIOS has been upgraded, (6) the BIOS LBA setting has 
been changed, or (7) there is a partition table virus present on the hard disk.

In most instances, you should resolve the problem as explained in “Resolving 
Partition Table Errors” on page 114. You can also use a virus scanning program 
to remove any partition table virus. Data loss is possible if the number of heads or 
sectors per track has changed since you first created your partitions.

#117 Partition’s drive letter cannot be identified 

Under OS/2, PartitionMagic must be able to find the drive letter for each partition 
before modifications can be made. There are various reasons why OS/2 might not 
be able to find a drive letter for each partition. For example, a driver on your 
system may change the drive letters from their defaults, or your partitions may 
not have serial numbers.
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The solution is to run PartitionMagic from DOS or from MS-DOS mode (in 
Windows 95 or Windows 98). When PartitionMagic runs from DOS or from 
MS-DOS mode, it does not need to be able to find the drive letter for each 
partition. Thus, if the problem indicated by this error message is the only 
problem, PartitionMagic can run successfully.

#120 The logical drive chain is incompatible 

This error occurs under some operating systems when logical partitions are not 
chained together in the expected order. DOS, OS/2, Windows 95, Windows 98, 
and Windows NT require that logical partitions be chained together in ascending 
order. Some other operating systems do not require this. For example, some 
versions of the Linux FDISK utility chain logical partitions together in the order 
they are created. This error message identifies a very dangerous situation; using 
the DOS FDISK in this situation can cause loss of one or more partitions. 

For solutions to this problem, see the instructions in “Resolving Partition Table 
Errors” on page 114. If you decide to back up your data and recreate your 
partitions, you may have to use the same partitioning program that you used to 
create the partitions in order to delete them.

#121 The first sector of the drive cannot be read 

The first sector of the hard disk (cylinder 0, head 0, sector 1) contains the master 
boot record (MBR) and the primary partition table. PartitionMagic cannot make 
changes to this hard disk because an error occurred when it read the first sector. 
See error #50 for information on resolving this error.

#122 A bad sector was found in the current or new partition area 

The partition cannot be moved safely because there is a bad sector in the new or 
current partition area. When you see this error message, the move operation is 
aborted before any corruption can occur. Try moving the partition to a different 
place. If your hard disk has bad sectors, we recommend that you replace the hard 
disk.

Check Errors (500–599)

Check errors occur when PartitionMagic checks the integrity of a partition. For general 
information about resolving these errors, see “Resolving Check Errors” on page 113.

#500 Subdirectory is corrupted 

This error message reveals the name of the corrupted subdirectory. Back up the 
contents of that directory and its subdirectories. You can then delete the corrupted 
subdirectory.
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#501 Cross-linked files were found

Multiple files claim the same clusters. PartitionMagic can fix this error when it 
occurs on an NTFS partition. For more information, see “Checking Partitions” on 
page 46. PartitionMagic lets you fix this error by: (1) copying the shared clusters 
to each affected file, (2) deleting all affected files, or (3) keeping one file and 
deleting the other affected files.

#506 Not enough free space on partition to shrink

Some free space (which is dependent on the hard disk’s current contents) is 
required to resize a partition smaller. Delete unneeded and duplicate files in the 
partition and then attempt the operation again.

#508 As specified, the operation does not change the partition

You have entered a value that is the same as or (when rounded to the required 
cylinder boundary) rounds to the same as the partition’s present value. Enter a 
larger change.

#509 A bad sector was detected in the current or new FS area 

In order to perform the resize operation that you requested, PartitionMagic 
attempted to expand the file system area. However, the program found a bad 
sector in the new area. Try moving the partition before you resize it. No 
corruption occurs when you encounter this error.

#510 The version of the file system is not supported

An updated version of PartitionMagic is required to operate on this new version 
of the file system. Visit www.powerquest.com for information about updated 
versions of PartitionMagic.

Batch Errors (600–633)

#600 Error trying to create batch file 
#601 Error trying to write batch file
#602 Batch file not found

(The following information applies to errors 600–602.) 

PartitionMagic 5.0 lets you specify a series of changes you want to make to your 
partitions, and then executes all the changes when you click Apply . At this point, 
PartitionMagic writes out a command list file (called a “batch file”) to disk in 
preparation for execution, and then reads the file upon execution (immediately if 
a lock can be secured on all impacted partitions, or in a special “reboot” mode 
after rebooting your computer if not all locks can be secured). In the 
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Windows 95, Windows 98, and Windows NT Workstation versions of 
PartitionMagic, the batch file is located in your Windows\System directory. In 
the DOS versions, it is located in the directory from which PartitionMagic 5.0 is 
running. The batch filename is PQ_PM50.PQB.

If the batch file cannot be created, cannot be written, or cannot be located when 
PartitionMagic attempts to execute the command file, the above error messages 
appear. You should contact PowerQuest technical support. See Appendix C of 
this user guide for more information.

#603 Unknown batch operation

The batch file contained an operation unknown to PartitionMagic 4.0. Contact 
PowerQuest technical support. See Appendix C of this user guide for more 
information.

#625 Changes cannot be applied

Generally error 625 only occurs when the system needs to go into boot-mode to 
execute your commands. A 625 error occurs when your disk geometry is seen 
differently in your native Windows version of PartitionMagic than it is in the 
boot-mode version. For security reasons, PartitionMagic cannot apply your 
changes without risking data loss.

One common configuration that will cause a 625 error is a system that has a hard 
disk (such as a SCSI or removable drive) that is visible in Windows but that 
cannot be seen in the boot-mode environment.

Some possible solutions include:

• Make sure the operation executes in native Windows mode (without resorting 
to boot-mode execution). PartitionMagic will only go into boot-mode if it 
cannot lock a partition (that is, if there are any open files on the partition). Try 
to confine all operations to drives PartitionMagic can lock before clicking the 
Apply Changes button.

• Change the configuration of the offending disk (most likely the SCSI or 
removable drive) by changing the BIOS setup for that disk. Doing so will 
ensure that the native and boot-mode environments detect identical hard disk 
configurations. If this does not work, you can try temporarily disabling the 
offending disk.

This error usually indicates that some other application has modified your disk 
configuration while you were running PartitionMagic. Make sure no other 
applications are loaded while PartitionMagic is running.
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User Interaction Errors (950–999)

#950 Unable to detect any disk drives 

No partitionable hard disks were found on your computer. Diskette drives and 
many removable media drives do not support partitioning. PartitionMagic cannot 
perform operations on disks in such drives.

#951 An invalid value was entered

The value entered is outside the range or (when rounded to the required cylinder 
boundary) rounds to a value that is outside the range for the operation specified. 
Check the displayed range and reenter the value.

#952 Value entered is the same as the current value 

See error #508.

#963 Selected operation is currently invalid

Not all PartitionMagic operations can be performed on all partitions. For 
example, you cannot convert an HPFS partition to NTFS, and you cannot create a 
partition if there is not enough unallocated space on the hard disk.

Under Windows, options that are not available either do not appear on the menus 
or they appear dimmed. However, if you are running scripts with the DOS 
version, there are no menus so you cannot see which operations are available. 
Refer to the relevant information in this user guide or the online Help for 
restrictions that explain why an operation is not available.

#967 Could not perform operation to the value specified 

This error occurs only in the enterprise version of PartitionMagic from a running 
script. If the value specified on a resize or move operation is not between the 
minimum and maximum possible, script execution stops and this error displays.

#968 Incorrect Volume Label entered, Deletion not performed

To delete a partition, PartitionMagic requires you to enter that partition’s volume 
label. If the volume label you enter does not match the volume label of the 
partition you want to delete, this error appears. 

#969 Incorrect Volume Label entered, Unable to proceed. 

To format an existing partition, PartitionMagic requires you to enter that 
partition’s volume label. If the volume label you enter does not match the volume 
label of the partition you are attempting to format, this error appears.
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#970 Invalid Bad Sector Check value specified 

This error occurs only in the enterprise version of PartitionMagic from a running 
script. If the script command SET DEFAULT BAD SECTOR TEST STATE is 
not followed by either ON or OFF, this error appears. 

#971 The label entered was too long 

When you enter a volume label, the process that checks the validity of the label 
displays this message if the label is too long. The label must be no longer than 11 
characters.

#972 Invalid characters in the label

When you enter a volume label, the process that checks the validity of the label 
displays this message if the label has characters that are invalid. Invalid 
characters include the following: [ * ? : < > | + = ; \ / ” , ].

#973 Volume Label cannot have leading spaces 

When you enter a volume label, the process that checks the validity of the label 
displays this message if you enter a label in which a space or spaces are the 
leading characters. 

#974 Root size specified was not in the valid range 

This error occurs only in the enterprise version of PartitionMagic from a running 
script. If you use the Create, Format, or Resize Root operations, and the number 
of root entries specified is not within the acceptable range for that partition, this 
error appears. Generally, the valid range is from 64 to 1,024.

#975 The cluster size specified was invalid for this partition

This error message displays only in the enterprise version of PartitionMagic from 
a running script. Many commands have a cluster size option. If a script command 
specifies an invalid cluster size (for the type and size of the partition), this error 
appears.

#976 Cannot create the file system specified in the current space 

This error message displays only in the enterprise version from a running script. 
When you use the Create or Format commands, you must also choose a file 
system type. If the file system or partition type you specified cannot be created in 
the space available, this error appears.
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#977 Partition selected is invalid 

This error message displays only in the enterprise version of PartitionMagic from 
a running script. If the partition selected from the Select Partition command is not 
a valid partition, this error appears.

#978 Unable to set to proper partition after last operation. Script halted.

This error message appears only in the enterprise version of PartitionMagic from 
a running script. After each operation, PartitionMagic ensures that the right 
partition is still selected. If PartitionMagic is not able to select the proper 
partition, it ends script processing and displays this error.

#986 Unable to get information for the specified partition

PartitionMagic reports this error most commonly when MS-DOS-based                     
terminate-and-stay-resident programs (TSRs), are running in the background. 
These TSR's will be located in the Config.sys or Autoexec.bat files.

One such TSR is the SUBST command. The SUBST can be used to associate a 
path with a drive letter. This creates a "virtual drive" that can be accessed as an 
additional local drive. The SUBST command is classified as a "dirty" or "deadly" 
TSR, and cannot be loading at the same time that PartitionMagic is loading.

To solve the problem, you must remark out the Config.sys or Autoexec.bat line 
that is loading the SUBST command. This command can be reinstated after 
running PartitionMagic.

There are other “dirty” or “deadly” TSR's that may cause a problem. If you are 
experiencing this error and are not using the SUBST command, find and remark 
out any of the following commands: Join, Append, or Assign. 

This error can also be reported if your C: drive is compressed. If the C: drive is 
compressed, you will need to either uncompress the drive, or run PartitionMagic 
from the rescue diskettes.

This error can also be caused by multiple partition table errors. If any of the 
above solutions do not apply, run PartitionInfo and send the report to PowerQuest 
technical support. Refer to “Generating Diagnostic Reports with PartitionInfo” 
on page 87 for information about PartitionInfo and PARTINFO.

NTFS Check Errors (1500–1699)

Errors 1500–1699 are NTFS-specific check errors, which can occur when PartitionMagic 
checks the integrity of a partition. PartitionMagic can fix certain errors when you perform 
the Check operation. For more information, see “Checking Partitions” on page 46 and 
“Resolving Check Errors” on page 113.
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In this section, “attribute” does not mean read-only, hidden, system, etc. Rather, 
“attribute” means one of a file’s data streams.

#1501 Wrong version of NTFS 

The partition was created using a version of the NTFS file format that 
PartitionMagic cannot work with.

#1503 Bad NTFS cluster size 

The NTFS cluster size must be 512, 1,024, 2,048, 4,096, 8,192, 16,384, 32,768, 
or 65,536 bytes.

#1512 Restart record mismatch

The two restart entries in the journal file are different. This may happen if 
Windows NT Workstation is not properly shut down. To fix this problem, restart 
Windows NT Workstation and shut it down using the Shut Down command.

#1516 Partition improperly dismounted

The partition dirty flag is set in a restart record in the journal file. This error may 
have been caused by a power failure or system crash while the Windows NT 
operating system was writing the partition. Reboot Windows NT and execute 
CHKDSK /F to repair the damage.

#1527 Bad update sequence number

A buffer contains mismatched update sequence numbers. This error may have 
been caused by a power failure or system crash while the Windows NT operating 
system was writing to the partition. Reboot Windows NT Workstation and 
execute CHKDSK /F to repair the damage.

#1529 Information mismatch in directory entry

A file attribute stored in a file record is different from the attribute stored in its 
directory entry. If this error is in a system file (file 0–10), Windows NT 
CHKDSK does not fix it, but Windows NT rebuilds the root directory on the 
partition the next time the operating system is started.

#1538 Can’t find contiguous space to move

The partition does not contain enough contiguous free space to hold the new copy 
of a file that must be contiguous. You normally encounter this error when you use 
the Resize option to resize a partition smaller.
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#1539 File size mismatch

The size of a system file (file 0–15) recorded in its file record does not match 
either the size recorded in its directory entry in the root directory or the size of its 
data stream.

#1544 External attribute list in external attribute

An external file record has an external attribute list.

#1545 File attributes out of order

The attributes in a file must appear in order of increasing numeric type.

#1546 Attribute neither resident nor nonresident

The attribute resident flag has a value other than resident or nonresident.

#1547 Wrong run limits

A run has more clusters than the difference between its highest and lowest 
cluster.

#1548 File table has fewer than 16 entries

The file table must have at least 16 entries.

#1549 File table has more than 4 billion entries

The file table must have fewer than 4 billion entries.

#1604 File’s parent does not contain the file

The file’s parent directory does not contain a reference to the file, or a file’s size, 
date, or time information does not match the file’s parent directory information. 
This error can be fixed when you perform the Check operation. For more 
information, see “Checking Partitions” on page 46. When you fix this error, 
PartitionMagic updates the file’s parent directory information.

#1609 Lost cluster(s)

The volume bitmap shows clusters as being used which are not used (no file 
claims them). This error can be fixed when you perform the Check operation. For 
more information, see “Checking Partitions” on page 46. PartitionMagic lets you 
fix this error by either deleting the lost clusters or by saving them in a file in the 
root directory. The filename is FILEXXXX.PQE, where XXXX is a number 
between 0000 and 9999.
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#1630 Inconsistent sizes in attribute header

File size information is incorrect. This error can be fixed when you perform the 
Check operation. For more information, see “Checking Partitions” on page 46. 
When you fix this error, PartitionMagic computes the correct file size 
information.

#1644 Bad system file sequence number

A system file has a bad sequence number. System files must have a sequence 
number from 1 to 15. A partition with this problem may pass Windows NT 
CHKDSK, but Windows NT does not mount the partition the next time the 
operating system is started.

#1647 Error in root directory index

There is an error in the root directory’s index. Running Windows NT CHKDSK 
does not fix this problem, but Windows NT automatically rebuilds the root 
directory on the partition the next time it is started.

FAT Check Errors (2000–2099)

Check errors occur when PartitionMagic checks the integrity of a partition. For general 
information about resolving these errors, see “Resolving Check Errors” on page 113.

#2001 FAT copies are not identical

Run ScanDisk to fix this error.

This problem may also be caused by a virus. Run a virus checker and remove the 
virus if possible.

#2002 There are invalid entries in the FAT

This error can generally be fixed by running a thorough ScanDisk on the 
partitions reporting the error.

#2003 File size does not match FAT allocation for file

Run ScanDisk or CHKDSK to fix this error.

#2005 One or more lost clusters are present

Run ScanDisk or CHKDSK to fix this error.

#2012 Formatted FAT file system too big for partition

This error can occur when:
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• The number of sectors in the partition is larger than 65,536, and the 
bsHugeSects field of the boot sector (“Big total number of sectors” in Norton’s 
DISKEDIT utility) shows that there are more sectors in the partition than the 
partition table shows.

• The number of sectors in the partition is less than 65,536, and the bsSects field 
of the boot sector (“Total sectors on disk” in Norton’s DISKEDIT utility) 
shows that there are more sectors in the partition than the partition table shows.

This situation can result in data loss when the FAT file system tries to use space 
outside the partition that does not exist or that belongs to another partition. Since 
file data may exist outside the partition boundary, you cannot fix the problem by 
simply patching the boot sector.

To correct the error, back up all data on the partition, delete the partition, recreate 
the partition, and restore the data. Alternately, it has been reported that you can 
use Norton Disk Doctor to fix this problem.

#2013 A component of FAT geometry is bad

This error can occur when:

• The number of clusters on the hard disk is greater than the FAT limits allow. 
This can result from bad values in the boot sector for the number of sectors, 
FATs, root entries, reserved sectors, and sectors per cluster.

• The number of sectors in the FAT is not large enough to hold the number of 
clusters present on the hard disk.

A qualified consultant may be able to fix the hard disk by performing simple 
patches. Alternately, you can back up the data on the partition, delete the 
partition, recreate the partition, and restore the files.

#2024 The OS/2 Extended Attribute file is corrupt

This error only occurs if you are running OS/2 and a program mistakenly writes 
to or overwrites the OS/2 Extended Attribute file. If this error occurs, you should 
back up your data, delete the partition, recreate the partition, and restore your  
data.

#2027 Too many root entries in the FAT32 partition to convert it to FAT16

Long filenames may be causing this problem, since they use multiple entries per 
file. To fix this error, move some of the root directory entries into a subdirectory 
and defragment the disk. 
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Operating System Errors (over 10,000)

Any number over 10,000 indicates an operating system error. To determine the number of 
the operating system error, subtract 10,000. See your operating system documentation for 
information about resolving the error.
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A P P E N D I XC
PowerQuest Technical Support
This appendix includes the following information:

• Before Contacting Technical Support

• Contact Information
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Before Contacting Technical Support

PowerQuest is committed to providing you with comprehensive technical support. 
However, before contacting our technical support department, please try to resolve your 
problem by using this guide, PartitionMagic Help, the README file, and PowerQuest’s 
corporate web site.

Tips
• Your problem may be resolved by applying the most recent patch or upgrade of the 

software.

• PowerQuest technical support engineers may request information from the 
PartitionInfo utility program to help you resolve problems with PartitionMagic. See 
“Generating Diagnostic Reports with PartitionInfo” on page 87 for more information 
about PartitionInfo and PARTINFO. The PartitionInfo report is always required for 
errors 100-199, 986, and drive detection errors of any kind.

• Your product serial number is required to obtain technical support.

Term of Technical Support for PartitionMagic 5.0

Technical support is available to all registered users throughout the life of the product, 
which began when PowerQuest released PartitionMagic 5.0 to manufacturing and ends six 
months after the release of PartitionMagic 6.0.

Upon registration, PowerQuest provides 90 days of complimentary technical support from 
the day of your first call. In addition, registered users are eligible for special upgrade 
pricing when PowerQuest releases a new version of PartitionMagic. Contact PowerQuest 
Customer Service for additional information about upgrade pricing.
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Contact Information

E-mail

To obtain e-mail technical support for specific technical questions, you can fill out the 
form at http://www.powerquest.com/support/emsupport.html (available in English only). 
If you send the information from PartitionInfo or PARTINFO with your e-mail message, a 
PowerQuest technician will be able to assist you more easily. See “Generating Diagnostic 
Reports with PartitionInfo” on page 87 for more information about PartitionInfo and 
PARTINFO.

E-mail on Demand

PowerQuest maintains an e-mail on demand system to resolve common problems. You can 
view a list of available documents at www.powerquest.com/support/demand.html. To 
request one of the documents, send an e-mail message to support@powerquest.com with 
the index number of the document in the subject of the message. You can only request one 
document per e-mail message. E-mail on demand documents are available in English only.

Corporate Web Site

The PowerQuest web site includes a wide array of information.

Language E-mail (for specific technical problems)

Dutch eurots@powerquest.com

English help@powerquest.com
eurots@powerquest.com

French france@powerquest.com

German germany@powerquest.com

Italian italian@powerquest.com

Portuguese latina@powerquest.com

Spanish spanish@powerquest.com

Information Web Site Address

Overview of support options www.powerquest.com/support/support.html

E-mail support request form www.powerquest.com/support/emsupport.html
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Fax

Fax a description of your problem to the technical support fax number. This service is 
available in the U.S., Canada, and Europe 24 hours a day, 7 days a week. PowerQuest 
technicians try to respond to all fax requests within 24 hours.

Telephone

The U.S.A call center is open Monday through Friday, 7 a.m. to 6 p.m., MST/MDT. Our 
European call centers are open Monday through Thursday from 9:00 to 18:00, CET, and 
Friday from 9:00 to 17:00, CET.

Error messages www.powerquest.com/support/er/er0000.html

PartitionMagic FAQs www.powerquest.com/support/FAQs.html

Location Number

USA +1 (801) 437-4218

Europe +31 (0) 20 582 9260

Language Location Number

Dutch Netherlands +31 (0) 20 581 3906

English Netherlands +31 (0) 20 581 3907

English UK +44 (0) 0171 341 55 17

English USA +1 (801) 226-6834

French France +33 (0) 1 69 32 49 30

German Germany +49 (0) 069 66 568 516

Italian Italy +39 (0) 02 45 28 1312

Portuguese USA +1 (801) 226-6834

Spanish Spain +34 (0) 91 622 3146

Spanish USA +1 (801) 226-6834

Information Web Site Address
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If you have the information from PartitionInfo or PARTINFO ready when you call, a 
PowerQuest technician will be able to assist you more easily. See “Generating Diagnostic 
Reports with PartitionInfo” on page 87 for more information about PartitionInfo and 
PARTINFO.

Postal Service Mail

Please include the information from PartitionInfo with a description of your problem. Also 
include a return address, a daytime phone number, or other relevant contact information.

USA Europe

PowerQuest Corporation
P.O. Box 1911
Orem, Utah 84059-1911
U.S.A.

PowerQuest
Orlyplein 85
1043 DS
Amsterdam
The Netherlands
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check
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checking disk integrity  26

checking partitions  46
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cluster waste  51
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64K, use of  65
FAT, required size  65
resizing  64
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combining partitions  48
command line switches, PQBoot  90
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configuring BootMagic  97

contact information for technical support  133
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FAT32 to FAT  72
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create new partition wizard  22
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drive letter changes resulting from  34
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protection  4

data loss, causes of  17,  47,  60,  114,  118,  119,  129

data partition  96

default operating system  99
setting startup delay  100

deleting
BootMagic menu items  99

deleting partitions  41
details, viewing  56
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DirBlock  53

disabling BootMagic  100
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running PartitionMagic from  85
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changing under Windows NT  58
in partition list  12
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remapping with DriveMapper  80
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PartitionMagic  107

drive, logical See logical partitions
DriveMapper  34,  80

running after merging partitions  24

DriveSpace, compatibility with PartitionMagic  105

Dual Boot, compatibility with PartitionMagic  106

duplicating partitions  44
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e-mail on demand technical support  133

e-mail technical support  133

emergency disks
See rescue disks
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miscellaneous  115,  117
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partition table  117
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master boot record  114
partition table  87,  114
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creating partitions  38
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F
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check error messages  128
cluster size, 64K  65
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converting to FAT32  68
converting to HPFS  69
converting to NTFS  71
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FAT32 file system  18
determining if current operating system 

supports  16
partitions, converting to FAT  72
partitions, information about  50

FAT32x file system  18
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file record size  52

file systems supported by PartitionMagic  18
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first physical sector  51
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formatting partitions  43

free DirBlocks  53
free space
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redistributing, with wizard  24
required to install BootMagic  94
required to move a partition  27
required to resize a partition  29
required to run PartitionMagic  5
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hard disk

formatting  43
geometry  4,  118,  119
SCSI, using PartitionMagic on  113

hard disk, read-only  17

hardware requirements See system requirements
help

context-sensitive  13
online  12
README file  13
technical support  132

hiding partitions  60

hiding wizard buttons  24

HPFS

converting to, from FAT  69
file system  18
Fnodes  53
partitions, information about  50,  53
partitions, minimum size of  30

HPFS/386 file system  19
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icons, hiding wizard  24

index, error in root directory  128
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cluster waste  51
disk usage  50
FAT information  51
HPFS information  53
NTFS information  52
partition info  51

installing
BootMagic  95
operating systems  36
operating systems, multiple  63
PartitionMagic, Linux  9
PartitionMagic, Windows  8
Windows NT, troubleshooting  38

integrity checks, disk  26

integrity checks, partition  46

interface, overview of  9
international keyboards  90

Internet technical support  133
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KEYB.COM  90

keyboards, international  90

L
label  42

last physical sector  51

letters, drive See drive letters
LILO  40

Linux
creating a bootable partition, requirements  35
creating logical partition for, scenario  39
ext2 partition, creating with wizard  23
file system  19
installing on a new partition  36
installing PartitionMagic for  9
unbootable after creating partition  36,  42

list, partition See partition list
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logical partitions, converting to primary  77

long filenames  61
Windows, created by  69

M
MagicMover  81

main window, overview  9
master boot record  117,  120
master boot record viruses, removing  114

master file table  52

memory, freeing to run PartitionMagic  110

merging partitions  48
wizard  24

moving
applications with MagicMover  81
data  53
partitions  26
partitions, bootable  28
partitions, scenarios  30

MS ScanDisk  54

N
naming a partition  42

network drives, simplifying backups to  4

new features  5
Norton utilities  104

NT CheckDisk  54

NTFS
check error messages  125
file system  19
partitions, information about  52

NTFS partitions
converting to FAT  73
converting to FAT32  76
information about  50
minimum size of  30

O
online help  12

BootMagic  96
operating system boot utilities

BootMagic  93
Dual Boot  106
System Commander  106

operating systems
adding to BootMagic menu  98
creating new partitions for  22,  35

installing  36
installing multiple  63
setting a default with BootMagic  99
supported by BootMagic  95

operations
check  46
copy  44
create  31
delete  41
info  49
label  42
move  26
MS ScanDisk  54
NT CheckDisk  54
resize  26
selecting  15
viewing pending  56

OS/2
Dual Boot  106
error messages involving  119,  129
FDISK, errors involving  117,  119
installing PartitionMagic for  8
running PartitionMagic from  85
SYSINSTX.COM  70
UHPFS.DLL  70

overlapping partitions, fixing  119

P
PARTINFO  89

partition info  51
See also PartitionInfo program

partition list
asterisk (*) in, explained  12
drive letters in  12
status in  12

partition list in main window  11

partition map  11

partition table
error messages  117
removing viruses  114
resolving errors  87,  114

partition type  51

PartitionInfo program  87

PartitionMagic
compatibility with other programs  104
PartitionInfo program  87
preferences, setting  16
system requirements  5
uninstalling  20



PowerQuest PartitionMagic 141
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applying changes to  15
backing up  44
bootable  35,  62,  89
checking integrity  46
copying  44
creating  31
creating with wizard  22
creating, scenarios  38
data  96
deleting  41,  123
extended, deleting  42
file systems supported  18
formatting  43,  123
hidden  12
hiding/unhiding  60
information  49
map in main window  11
merging  48
moving  26
moving, scenarios  30
multiple visible primary  60,  106
naming  42
overlapping, fixing  119
primary, hiding/unhiding  61
resizing  26
resizing limitations  29
resizing, scenarios  30
scanning for errors  54
selecting  14
serial number  51
status  12
using 64K FAT clusters on  16

passwords
setting for BootMagic  97

pending changes  15

pending operations, viewing  56
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physical geometry  51
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PQBoot  89
command line switches  90

preferences  16
ignore OS/2 EA errors on FAT  17
set as read-only for PartitionMagic  17
skip nad sector checks  17

system supports FAT32  16
wizard buttons, hiding  24

preferences, PartitionMagic
allow 64K FAT clusters for Windows NT  16

preparing for a new operating system
See creating new partitions

primary partitions
converting to logical  77
hiding/unhiding  61
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README file  13

read-only, set hard disk as  17

reclaiming wasted space  64

redistribute free space wizard  24

reducing the number of partitions  48

remapping drive letters  80
removable drives  4

removable media, assigning a drive letter to  111

removable media, using PartitionMagic with  14

requirements, system  5

rescue disks
BootMagic  96
contents of  86
creating  85
international keyboards and  90
ran out of space on  85
running from, if hard disk is compressed  125
running PARTINFO from  89
running PartitionMagic from  85
running scripts from  86
system requirements for running PartitionMagic 

from  5
resizing clusters manually  64

resizing operations  26

resizing partitions
limitations  29
partition won’t reboot after resizing  114
scenarios  30

resizing the root directory  61

retesting bad sectors  58

root directory
FAT, capacity in  52
index, error in  128
long filenames in  61
resizing  61

running wizards  22
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scanning for errors  54

scenarios
creating Linux partition  39
creating partitions  38
resizing and moving partitions  30

scripting  24
running from rescue disks  86
See also online help

SCSI hard disk, using PartitionMagic on  113

sectors, bad  117,  124

sectors, retesting bad  58

selecting
operations  15
partitions  14
physical disks  14

servers
running PartitionMagic on  4

set active  62

set hard disks as read-only for PartitionMagic  17

skipping bad sector checks  17
software requirements  5

sound card drivers, PartitionMagic incompatible with 
 107

SoundBlaster Live DOS drivers  107

startup delay, setting for BootMagic  100
startup, BootMagic menu and  101

support, term of  132

switching between bootable partitions  89

SYSINSTX.COM  70

System Commander  106

system requirements
hardware requirements  5
software requirements  5

system supports FAT32  16

T
technical support  132

duration  132
e-mail  133
e-mail on demand  133
fax  134
mail  135
postal service mail  135
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web site  133

total physical sectors  51

troubleshooting  109
changes entered seem to have disappeared  22
computer freezes when you boot  98
computer won’t boot  85
hid partition where PartitionMagic is installed  

85
Linux  36,  42
NTFS features lost when converting to FAT or 

FAT32  74
partition unbootable after resizing  114
PartitionMagic crashes in boot-mode  107
rescue disks, ran out of space on disk 1  85
tips  132
Windows NT won’t install  38
workstation is unbootable  28

U
UHPFS.DLL  70

unallocated space  19
unallocated space, redistributing  24

unformatted partitions  19

unhiding partitions  60

uninstalling PartitionMagic  20

unused space  50

unused space, redistributing  24
utilities  6
utilities, operating system

AUTOCHK  113
CHKDSK  46,  53,  113
FDISK  119,  120
NT CheckDisk  54
ScanDisk  54,  113

V
virus protection software  106

viruses, removing  114

volumes
labeling  43
naming  42

W
warnings  74

wasted space, reclaiming  64

Windows
check errors, resolving  113
drive letters, changing  80
DriveSpace, using with  105
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installing PartitionMagic from  8
long filenames  69
running PartitionMagic from  9
uninstalling PartitionMagic from  20

Windows 2000 dynamic disks  14

Windows 95, deleting operating system compression 
files  111

Windows NT
64K FAT clusters  16
changing drive letters  58
CheckDisk  54
creating primary partition for (scenario)  37
error messages, involving  125
installing on a new partition  36
won’t install  38

wizards
applying or discarding changes  22
create new partition  22
hiding buttons on main screen  24
merging partitions  24
overview  10,  22
redistributing free space  24
running  22

Z
Zip disks, using PartitionMagic with  14
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