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1.0 Introduction 
 

Welcome to the MYRIAD Administrator’s Guide!  This document contains information on installing 
standalone and network copies of MYRIAD, MYRIAD’s license management, the NetSetup utility for client 
machines, MYRIAD customization methods, and the Document Stack format.     

1.1 System Requirements 
MYRIAD supports office documents and raster formats, 2D vector, and 3D formats. ProE support is 
available as additional format options. The MYRIAD Browser Plug-in is an included option with all 
forms of MYRIAD. In order to use this plug-in, either Netscape or Internet Explorer is required to be 
installed on the client system. The following are the minimum recommended system requirements for 
running MYRIAD. 

• Pentium 450 or higher (2D) or Pentium 1100 (3D) 
• Windows 2000/XP and 2003 Server 
•  75 MB hard disk space 
• 128 MB RAM (2D) or 256 RAM (3D) 
• 100 MB available swap disk space (500 MB if using 3D) 
• OpenGL accelerated video card strongly recommended (3D only) 

 
 

2.0 Installation 
 

Once you have verified your machine meets the system requirements listed in 1.1 System Requirements, you 
are ready to begin the MYRIAD installation.  MYRIAD can be installed either on individual machines 
(standalone) or on a server machine (network).  If you are installing a network copy of MYRIAD and wish to 
use the NetSetup utility (a zero-admin utility to create the necessary shortcuts, plug-ins, etc. on the end-user 
machines), see 2.4.1 NetSetup.   

****If you have a multi-user license key, you must install the server copy of MYRIAD on a 
Windows XP, 2000, or 2003 Server machine due to requirements of the MYRIAD License Server.  

MYRIAD no longer automatically installs Adobe Acrobat. If you plan to view PDF files with MYRIAD 
through Acrobat, you must install Acrobat before running this installation. 

 

 2.1   Install Design Tracking (Inventor) 
You must install Autodesk Design Tracking version 8.0 or 9.0 if you would like MYRIAD to support 
Inventor 2D and 3D formats and do not already have the software installed. The installations are 
contained on your MYRIAD CD. Note: If you have an earlier version of Autodesk Design Tracking 
installed, you must uninstall that version and then run the Design Tracking 8.0 or 9.0 installation to 
properly view Inventor file formats. 

1. Insert your MYRIAD CD into your CD-ROM and select the “Install Design Tracking” button 
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from your CD browser and then select which version of Design Tracking you wish to install. If 
you do not have autorun enabled, you can run setup.exe from the Inventor 8.0 or 9.0 directory of 
your MYRIAD CD. Uninstalling MYRIAD will not uninstall Design Tracking - they must be 
uninstalled separately. 

2. Follow the on screen installation instructions. 

2.2 MYRIAD Installation Procedure 

1. Place the MYRIAD CD into your CD-ROM drive and select Install MYRIAD 7.0 from the CD browser 
interface. (If you do not have autorun enabled, you can run Setup.exe from the Myriad70 directory of your 
MYRIAD CD.) The Welcome screen appears. Click Next>.  

Note: If the current version of MYRIAD is detected on your machine, the Welcome screen appears displaying 
three installation options.  Select Remove to uninstall all MYRIAD components, and then click Next> to execute 
the uninstall. When complete, eject and re-insert your MYRIAD CD and select Install MYRIAD 7.0 from the 
CD browser again to continue with the installation (or run setup.exe from the Myriad70 folder). (If a previous 
version of MYRIAD is detected on your machine, a warning displays, as the installation of more than one version 
of MYRIAD is not recommended for anything but evaluation purposes. If you select to install an evaluation 
version, you will be prompted to choose a different directory than the one containing the previous version. You 
should not run the previous version while the evaluation version is installed.) 

 

 
 

2. The Informative Graphics License Agreement screen appears.  Click Yes to accept the license 
agreement and continue or No to exit the installation. 
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3. In the Installation type screen, choose whether you are installing a demonstration version of 
MYRIAD, or a fully licensed version. A Demo Install provides full MYRIAD functionality, but only 
for a limited time frame. If you are installing a licensed version of MYRIAD which does not expire, 
you must have obtained a valid serial number from IGC.  
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If you have chosen Full Install in the previous screen, you are prompted for a directory location where 
you have placed the IGCKey.lic file that you have acquired from Informative Graphics, Inc. If a valid 
license key is not found, only the demo install is allowed. 

 
4. If Adobe Acrobat is detected on your system, the installation will prompt you as to whether you want 

to use it to view PDF files. Click Yes if you want MYRIAD to use Acrobat. Click No if you want 
MYRIAD to use its built-in drivers. This message only displays if Acrobat is present on your system. 
Otherwise, this message does not display and MYRIAD uses its built-in drivers. 

 

 
 

5. The Select Components screen appears. The components that you are licensed to install display in the 
selection list. The Drivers selection controls which files MYRIAD is allowed to view. The Fonts 
selection controls which fonts are supported.  Click Change to view a list of sub-components for the 
driver and font options listed to select specific components. You can clear the check box for any 
driver or font you don’t want to install. The Browser Plug-in selection contains the MYRIAD 
Browser Plug-in installation. With the plug-in, you can launch MYRIAD from within Internet 
Explorer or Netscape. To run the Browser Plug-in setup, see section 2.3 MYRIAD Browser Plug-in 
of this document. Integration Client installs the MYRIAD integration components. Select your 
desired components and click Next>. 



Administrator’s Guide 

6 

 
 

6. The Choose Destination Location screen for MYRIAD appears.  Click Next> to install the MYRIAD 
files to the displayed directory (or you can click Browse… to locate and select a different directory). 

 
 

7. The Select Program Folder screen appears.  Select the Program Folder where you wish the MYRIAD 
shortcuts to appear and click Next>.  The selected Program Folder is created under Programs in the 
Windows 2000/XP or 2003 Server Start menu.   
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8. The MYRIAD files are installed.  

If you have a standalone copy of MYRIAD, skip to Step 12. 

9. If you have a multi-user serial number, the Local or Network Adobe Acrobat screen appears asking if 
users will be accessing the network server copy of Acrobat or local copies of Acrobat on their own 
machines.  Note that MYRIAD supports Acrobat 3.01 and higher.  Select Local or Network 
Installation and click Next>. (See section 2.4 for licensing considerations.) 

 
 

10. If you have selected Network and Adobe Acrobat is detected on your Server, the installation will 
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prompt you as to whether you want users to access it to view PDF files. Click Yes if you want 
MYRIAD to use Acrobat. Click No if you want MYRIAD to use its built-in drivers.  

 
If setup does not detect Acrobat on your system and you do not want network users to use Acrobat for 
viewing PDF files, click Yes at the below prompt to continue installing MYRIAD without network 
Acrobat support (clients can use local copies). Click No if you would like to abort the MYRIAD 
installation and install a copy of Acrobat on your Server. When complete, you can begin the 
MYRIAD installation again from step #1. 

 
11. If you have selected that network clients use local copies of Acrobat (during step #9), the following 

message appears on the client machine during a network installation of MYRIAD if a local copy 
Acrobat is not detected. Users can choose to install without Acrobat support, or they can terminate the 
network setup and install a local copy of Acrobat. 

 
12. The InstallShield Wizard Complete screen appears.  If any system files were updated, you are 

prompted to reboot your machine, otherwise you can choose to view the Readme or launch 
MYRIAD.  Make the appropriate selections and click Finish. 
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2.3 MYRIAD Browser Plug-in  
 

1. At any time after installing MYRIAD, you can install the Browser Plug-in (if you have selected 
this component to be installed with MYRIAD). Select the Browser Plug-in Installation icon from 
the MYRIAD program group. If this or a previous version of the plug-in is detected on your 
machine, you must uninstall it before continuing with the setup. Uninstalling MYRIAD will not 
uninstall the Browser Plug-in - they must be uninstalled separately. 

2. The Welcome screen appears. Click Next>. 
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3. If the only Browser installed on your system is Internet Explorer, skip to Step 5, otherwise the 
Select Destination Location screen indicates what browser or browsers were found on your 
machine.  If Netscape is found, Setup will default to that directory.  Internet Explorer will be able 
to access the plug-in from the Netscape directory.  If you are using a different browser, change 
the destination directory.  Otherwise, click Next >. 

 

4. The Select Components screen appears. The components list displays the format types you are 
licensed to view based on your MYRIAD serial number. These items are all selected by default, 
but you can clear the check box for any of the plug-in formats that you don’t want to install. The 
Description section reveals the file types supported by each plug-in. Click Next> 

 

You may be prompted to rename Nppdf32.api to xxnppdf32.api.  Nppdf32.api is Adobe’s plug-in 
for PDF files, located in your browser plug-in directory.  Renaming or deleting it will allow the 
Browser Plug-in to view PDF files.  You must click on Yes to rename the default plug-in before 
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you can use the Browser Plug-in to view PDF files. 

 
 

5. If the only Browser installed on your system is Internet Explorer, the plug-in install runs 
automatically.  When the install is finished, the MyrATLX Register dialog box displays (below).  
Click YES for each extension that you want to associate with the MyrATLX Active-X control.  
Click NO for each extension that you do not want to associate with the MyrATLX Active-X 
control.  Select the Apply To All check box if you want all extensions to be associated with the 
MyrATLX Active-X control. 

 

6. The plug-in files load and the InstallShield Wizard Complete screen displays.  Click on Finish to 
exit the Browser Plug-in Setup. 

 

2.4 License Management 
 

Prior to version 5.2, MYRIAD was available with two floating network license configurations. A floating 
network license allows the customer to install a specified number of licenses on the server for checkout 
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by any operator on the network. Seats become available to other users with this method as soon as a user 
exits MYRIAD. 
 
The two methods for managing floating network licensing were file lock networking and the License 
Server. The File Locking method is no longer available, and the License Server method has changed.  
 
The new Network Licensing method is similar to a named licensing scheme, but it locks licenses to a 
MAC ID (based on the network card) instead of a user name. It is a self-administering method in that 
there is no list of authorized users to maintain. The License Server now monitors how many users are 
accessing MYRIAD at one time by recording the client machine’s MAC ID number. Once the total 
number of licenses allowed is recorded, it prevents any additional copies of MYRIAD from being 
launched. Therefore, if you are licensed for 25 users, the first 25 different MAC IDs to request licenses 
get them. Network Licensing automatically installs and runs the License Server as a service upon the 
install of a network copy of MYRIAD.  
 
The License Server must be running at all times and can be used only for TCP/IP networks. The server 
machine must be assigned a static IP address or machine (host) name as this information is encoded in the 
license key. The License Server will only run on that particular server with the licensed IP address or host 
name. If DHCP is used, the server must be assigned the same address or host name for each request 
occurrence. A network server copy of MYRIAD should be run only on a Windows XP, 2000 or 2003  
Server machine. 
 

2.4.1 NetSetup 
NetSetup provides a zero-admin method of creating shortcuts, program folders, plug-ins, and registry 
keys on client machines accessing a network copy of MYRIAD.  End-users simply run the 
NetSetup.exe file in the NetSetup directory and everything is done for them.  It even configures the 
client machine for the PDF plug-in for either a local or network copy of Acrobat.   

When installing MYRIAD with a multi-user serial number, MYRIAD automatically creates the 
NetSetup directory within the MYRIAD install directory. If the end-users will be using a network 
copy of Acrobat, it must reside on the same machine as the network copy of MYRIAD. 

Note: If a previous version of MYRIAD is detected on a client machine, NetSetup offers to 
uninstall it.  If the current version of MYRIAD is detected, the user receives a message that 
they must uninstall the current version before running NetSetup and Setup exits.  

Configuring NetSetup 
XPSP2 Users: 

If you are installing the MYRIAD server to a Windows XP system running Service Pack 2, there are 
additional steps described below that must be taken to allow MYRIAD to run through Window’s 
Firewall. If these steps are not taken, MYRIAD will not be able to launch from the client machines. 
Perform these steps in addition to the steps contained in the next section “All Users”. 

1. On the server machine where you have installed a copy of MYRIAD, select Security Center 
from the Control Panel. 

2. Select the Windows Firewall option from the Security Center window. 

3. Click the Exceptions tab from the Windows Firewall dialog. 

4. Click Add Program and click Browse from the Add a Program dialog to locate and select the 
file Licserve.exe. This file is located in the MYRIAD installation root directory. 
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5. Click OK. MYRIAD now appears in the Programs and Services list on the Exceptions tab. 

 
 

All Users: 

Once you have installed the server copy of MYRIAD, follow the steps below to configure the 
NetSetup utility properly. 

1. Share the MYRIAD directory on the server machine (not the NetSetup directory).  The NetSetup 
directory must reside directly within the MYRIAD directory. 

2. In the NetSetup directory, open the Netsetup.txt file.  It contains the following entries: 

<Path to Myriad> 
<Serial number> 
<Machine name> 
Adobe Local or <Path to Acrobat>* 

*This line only appears if you have selected to use Acrobat to view PDF files.  If you chose Local Installations 
in the MYRIAD install, “Adobe Local” appears in this line.  If you chose Network Installation, the path to 
Acrobat appears. 

3. If you have opted to use a network copy of Acrobat, share your Acrobat directory (the directory 
containing Acrobat.exe at its root level).  Again, NetSetup is assuming that the share will be the 
server machine name followed directly by the Acrobat directory.  If this path is incorrect, update 
the last line in the NetSetup.txt file.  Acrobat must reside on the same machine as the 
MYRIAD server install. 

4. If you have opted to use Autodesk Design Tracking to view Inventor 2D and 3D file formats, 
you must install Design Tracking version 8.0 or 9.0 (available from the MYRIAD 
installation CD). 
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5. We strongly recommend running a test install on a client machine. Access the Myriad/Netsetup 
directory on the network server from the client machine. Run setup.exe.   Once installed, launch 
MYRIAD from the shortcut created under the Windows Start menu to verify the path is correct.  
If you are using Acrobat to view PDF files, load a PDF file to verify that the PDF plug-in was 
registered correctly and that the Acrobat path is correct.  If you have any difficulties, see 6.0 
Troubleshooting or contact Technical Support (see 7.0 Contacting Informative Graphics). 

 

3.0 Configuring the License Server 
 
The License Server is already configured using the default settings (refer below). You can change the 
settings manually if needed.  When running as a service, the license server does not display the dialogue 
containing license key, number of licenses in use, etc.  To view and edit this information, proceed with 
the following instructions. This shuts down the service, and runs the license server as an application. 
Shutting down the application restarts the service. Stopping the service does not reset the licenses in use. 
 

1. Choose a machine to use as the License Server and install MYRIAD.  

2. To update the License Server, access the License Server shortcut through your Myriad Program group 
on your Start menu (or you can double-click on the licserv.exe file in the installed MYRIAD 
directory).  The MYRIAD License Server dialog box displays.  

 
The following information appears in the MYRIAD License Server dialog box. 

Serial # Your serial number.  This should be supplied automatically.  If it does not 
appear, you must enter it now (you can find it on the sticker sent with the 
MYRIAD CD). 

Total Licenses The total number of copies of MYRIAD that you can run concurrently. 

Licenses in Use The number of copies of MYRIAD currently running. 

Licenses Available The number of available copies remaining to be run. 

Change Serial Number Allows you to change the serial number if, for example, you have increased 
the number of licensed copies and are issued a new number. 

Configure Network Allows you to add and remove TCP/IP protocol support and configure for a 
TCP/IP network, if necessary.   
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3. To add a protocol, click on Configure Network, and then on Add. Select myrsncm.dll for a 
TCP/IP protocol and click Open. 

 
4. To change the TCP/IP protocol, select TCP/IP Communications Protocol and click Properties to 

display the TCP/IP Configuration dialog box. 

 

You should only modify the Broadcast Port or Server Port if you are using another application that 
requires those settings.  The Broadcast Port is the TCP/IP port where the License Server listens for 
new MYRIAD connections.  The Server Port is the port where the License Server processes requests 
for a MYRIAD connection.  Listen Buffers represents the number of requests for connections that can 
be processed at one time before being turned over to the Server Port.  The range for the Broadcast and 
Server ports is 1,024 to 9,999, but only needs to be changed if there is a conflict.  The Listen Buffers 
should not be changed. 

5. Change the desired port or buffer setting and click OK 

6. If you need to change the serial number, clicking on Change Serial Number displays the Serial 
Number dialog box. 

 
7. Enter the new serial number in the Serial Number text box and click OK. You can change the serial 

number while licenses are in use. If the new number of total licensed users is less than the number of 
current users, the excess users are logged off using a first on first off method of elimination. 
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4.0 Customizing MYRIAD 

4.1 General Command Line Arguments 
You can disable virtually any toolbar button or menu option from the command line by using the format 
shown below.  A FALSE value disables the item, while a TRUE value enables any item that has been 
disabled in the MYRuser.INI for that session.  You can enter as many as you need, up to 256 characters, 
by inserting a space after each one.  The example shows how you would remove the Exit option from the 
File menu.  

Format:  myriad32 -c<key>=value 

Example: myriad32 -cAppExit=FALSE 

Some of the popular commands are grouped below by toolbar, followed by a complete alphabetical 
listing.  There are also predefined switches (see 4.2 Predefined Switches) that disable an entire feature 
automatically, such as redlining or printing. 

 
File Toolbar 

FileOpen Removes the Open button from the File toolbar and Open command 
from the File menu. 

MyriadEditRedlineMenu Removes the Redline Menu button from the File toolbar and Redline 
command from the File menu. 

DocStack Removes the Document Stack button from the File toolbar. 
NextDoc Removes the Next Doc button from the File toolbar and command 

from the File menu. 
PrevDoc Removes the Prev Doc button from the File toolbar. 
Print Removes the Quick Print button from the File toolbar and the Print 

command from the File menu. 

View Toolbar 

Select Removes the Select button from the View toolbar and the command 
from the View menu. 

ZoomExtents     Removes the Zoom All button from the View toolbar and the 
command from the View menu. 

Zoom Removes the Zoom button from the View toolbar and the command 
from the View menu. 

ZoomWidth Removes the Zoom Width button from the View toolbar and the 
command from the View menu. 

BirdsEye Removes the Bird’s Eye button command under the View menu. 
Eyeglass   Removes the Eye Glass button from the View toolbar and the 

command from the View menu. 
Color Removes the Monochrome/Color button from the View toolbar. 
RasterToggle Removes the Raster button from the View toolbar. 
BackgroundColor Removes the Background Color button from the View toolbar. 
Layering Removes the Set Visible Layers button from the View toolbar and the 

Visible Layers command from the View menu. 
ToolbarOrient Removes the Orientation button from the View toolbar. 
 

Redline Toolbar 
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RedlineMenu   Removes the Redline Menu button from the Redline toolbar. 
RedlineEntityLine Removes the Line, Sketch, Arc, and Arrow Redline tools from the 

Redline toolbar. 
RedlineEntityHighlight Removes the Cloud and Highlight tools (Rectangle, Ellipse, and 

Polygon) from the Redline toolbar. 
RedlineEntityText Removes the Text, Text Crossout, Text Leader, and Text Caret tools 

from the Redline toolbar. 
RedlinePDF Removes the PDF tools from the Redline toolbar. 
RedlineSymbol Removes the Symbol button from the Redline toolbar. 
RedlineChangemarks Removes the Changemarks tools from the Redline toolbar. 
RedlineLineStyle Removes the Line Style button from the Redline toolbar. 
RedlineLineWidth Removes the Line Width button from the Redline toolbar. 
RedlineColor Removes the Color button from the Redline toolbar. 

All Command Line Arguments (listed alphabetically)  

AppExit Removes the Exit option under the File menu. 
ArrangeIcons Removes the Arrange Icons command under the Window menu.  
Associate Removes the Unrecognized Extension dialog box. 
AuthorTool Removes the Author Tool under the Tools menu. 
BackgroundColor Removes the Background Color button from the View toolbar. 
BirdsEye Removes the Bird’s Eye button from the View toolbar and the Bird’s 

Eye command under the View menu. 
BirdsEyeClose  Removes the Close command in the Bird’s Eye Right Mouse Button 

option menu. 
BirdsEyeStickAround Removes the Stick Around command in the Bird’s Eye Right Mouse 

Button option menu. 
Calibrate Removes the Calibrate feature under the Analysis menu. 
Capture Removes the Capture to Clipboard feature under the Edit menu. 
CascadeWindow Removes the Cascade command under the Window menu. 
Changemarks Removes the Changemark Option from the Redline toolbar and the 

Changemarks command from the Tools menu. 
CloseAll Removes the Close All command under the Window menu. 
Color Removes the Monochrome/Color button from the View toolbar 
Consolidate Removes the Consolidate Redlines command under the Edit menu. 
DocStack Removes the Document Stack button from the File toolbar. 
EyeGlass Removes the Eye Glass button from the View toolbar and the Eye 

Glass command under the View menu. 
EyeGlassClose Removes the Close command from the Eye Glass Right Mouse Button 

option menu. 
EyeGlassCloseSync Removes the Close and Update Original command from the Eye Glass 

Right Mouse Button Option menu. 
FileClose Removes the Close command under the File menu. 
FileOpen Removes the Open command under the File menu. 
FitWindow Removes the Fit to Image command under the Window menu. 
HelpAbout Removes the About MYRIAD command under the Help menu. 
HelpContents Removes the Contents command under the Help menu. 
HelpSupport Removes the Product Support command under the Help menu. 
Layering Removes the Set Visible Layers button from the View toolbar and the 

Visible Layers command from the View menu.  To disable layering 
capabilities completely, you must also disable SetRedlineLayer. 
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MainFileMenu Removes the File menu when no files are open. 
MainHelpMenu Removes the Help menu when no files are open. 
MainToolsMenu Removes the Tools menu when no files are open. 
Measure Removes the 2D Measure feature under the Analysis menu. 
MRU (Most Recently Used List) Removes the most recently used file list. 
MyriadEditMenu Removes the Edit menu. 
MyriadEditRedlineMenu Removes the Redline submenu from the File menu. 
MyriadFileMenu Removes the File menu when there is an active document window(s). 
MyriadHelpMenu Removes the Help menu when there is an active document window(s). 
MyriadToolsMenu Removes the Tools menu when there is an active document window(s). 
MyriadViewMenu Removes the View menu. 
MyriadWindowMenu Removes the Window menu. 
NextDoc Removes the NextDoc button from the File toolbar. 
NewWindow Removes the New Window command under the Window menu. 
Options Removes the Option command under the Tools menu. 
PrevDoc Removes the PrevDoc button from the File toolbar. 
Print Removes the Quick Print button from the File toolbar and the Print 

command from the File menu. 
PrintRegion Removes the Print Region command from the File menu. 
PrintPreview Disables the Print Preview button from the Print dialog box. 
PrintSetup Disables the Print Setup command under the File menu. 
RedlineChangemarks Removes the Changemark tools from the Redline toolbar and removes 

the command from the Tools menu. 
RedlineColor Removes the color palette in the Redline toolbar. 
RedlineEntityLine Removes the Line, Sketch, and Arc Redline tools from the Redline 

toolbar. 
RedlineEntityText Removes the Redline Text tool from the Redline toolbar. 
RedlineEntityHighlight Removes the Cloud and Highlight tools (Rectangle, Ellipse, and 

Polygon) from the Redline toolbar. 
RedlineLineStyle Removes the Line Style button from the Redline toolbar. 
RedlineLineWidth Removes the Line Width button from the Redline toolbar. 
RedlineMenu Removes the Redline menu button from the Redline toolbar. 
RedlineNew Removes the New command under the Redline menu. 
RedlinePDF Removes the PDF tools from the Redline toolbar. 
RedlineOpen Removes the Open command under the Redline menu. 
RedlineOpenForReview Removes the Open for Review command under the Redline menu. 
RedlineSave Removes the Save command under the Redline menu. 
RedlineSaveAs Removes the Save As command under the Redline menu. 
RedlineSymbol Removes the Redline Symbol tool. 
Redraw Removes the Redraw command from Right Mouse Button Option 

menu. 
Select Removes the Select button from the View toolbar and the Select 

command from the Edit menu. 
SendMail Removes the Send Mail feature under the File menu. 
SideBySide Removes the Side-by-Side Compare command under the Tools menu. 
TileHorizontal Removes the Tile Horizontal command under the Window menu. 
TileVertical Removes the Tile Vertical command under the Window menu. 
ToolbarOrient Removes the Orientation button from the View toolbar. 
Undo Removes the Undo command under the Edit menu. 
ViewStatusBar Removes the Status Bar command under the Tools/Toolbars menu. 
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Zoom Removes the Zoom Rectangle button from the View toolbar and the 
Zoom Rectangle command from the View menu. 

ZoomExtents Removes the Fit All button from the View toolbar and the Fit All 
command from the View menu. 

ZoomIn Removes the Zoom In command from the Right Mouse Button Option 
menu and disables the (+) key command. To disable the zoom features 
completely, you must disable all zoom commands.  

ZoomOut  Removes the Zoom Out command from the Right Mouse Button 
Option menu and disables the (-) key command. To disable the zoom 
features completely, you must disable all zoom commands.  

ZoomPrevious  Removes the Zoom Previous command from the Right Mouse Button 
Option menu. To disable the zoom features completely, you must 
disable all zoom commands.  

ZoomWidth Removes the Fit Width button from the View toolbar and the command 
from the View menu. 

 

4.2 Predefined Switches 
You can disable or remove a number of buttons and menu commands through the general command line 
arguments. In addition, you can use the predefined command line switches listed below. You can also add 
predefined switches by editing the target of your Myriad shortcut properties menu. For example, 
…<path>\Myriad32.exe –a –np launches MYRIAD in administrators mode with printing disabled. 

Disable Redline   -v or /v 
This command disables all redlining capabilities so MYRIAD can only be used for viewing.  

Example:   myriad32 -v 

Disable Folder   -d or /d 
This disables the Document Stack, or folder capability.   

Example: myriad32 /d 

Disable Printing   -np or /np 
This option disables all printing capabilities. 

Example: myriad32 -np 

Disable Mail   -nm or /nm 
This option disables Myriad’s mail interface. 

Example: myriad32 /nm 

Disable Calibrate and 2D Measure -ni or /ni 
This command disables all 2D Calibrate and Measure capabilities. 

Example: myriad32 -ni 

Disable View Set -x or /x 
This command disables the View Set Toolbar and menu. 

Example: myriad32 -x 
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Launch with Document Stack -f or /f 
This command automatically loads the specified Document Stack when MYRIAD is launched. 

Example: myriad32 -f c:\project\stack.dsf 

Launch with Changemark List -m or /m 
This command automatically summons the Changemark List when MYRIAD is launched. 

Example: myriad32 -m 

Load in Side-by-Side Compare -s or /s 
This command automatically loads the two specified files in Side-by-Side Compare. 

Example: myriad32 /s (filename1, filename2) 

Launch in Administrator mode -a or /a 
This command launches MYRIAD in System Administrator Mode.  If you have a network copy of 
MYRIAD and do NOT setup a System Administrator, any user will be able to edit the ISO print banners 
and watermark.  Once a System Administrator is defined (you set them by selecting System 
Administrators… from the Tools menu in MYRIAD), you can only edit the ISO print banners by 
launching MYRIAD in Administrator Mode and supplying a valid username and password. 

Example: myriad32 -a  

 

There are three additional items, shown below, that can be customized or disabled using the following format 
at the command line.  No spaces are allowed in the <section>. 
 

Format: -c<section>:<key>=FALSE 

Example: -cChangemark_Tool:Print=FALSE 
 

Item Section Key 
Print button on the 
Changemark List Dialog Box 

Changemark_Tool Print 

Color palette on the Redline 
toolbar 

Custom RedlineColor 

Orientation button on the 
View toolbar 

Custom ToolbarOrient 

 
 

4.3 MYRuser.INI and MYRIAD32.ini Files 
You can modify paths, colors, and other MYRIAD features for an individual user in the MYRuser.INI file 
(MYR followed by the user’s login name and MYRIAD version) or for all users in the MYRIAD32.ini 
file (when using a network install of MYRIAD).  Each user has a different MYRuser.INI file, so each 
user can have different settings.  The MYRuser.INI takes precedence over the MYRIAD32.ini, except for 
settings that only appear in the system configuration file.  You can also customize MYRIAD by disabling 
features for each user through the MYRuser.INI file (as opposed to using command line arguments).   

The sections have the following format, unless otherwise noted: 

Format: Parameter=VALUE 
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Example: Bold=FALSE 

The MYRIAD32.INI file is located in the installed MYRIAD directory. The MYRuser.INI file location is 
as follows: 

Documents and Settings\<username>\Application Data\IGC 
 

Note: The actual file name MYRuser.ini does not exist. This file is named according to the following 
convention: the string “MYR” appended with the user’s login name, appended with the Myriad version 
number. For example, if your Windows login for that session is JDoe, Myriad will create a settings file in 
your Windows (or equivalent) directory called myrjdoe700.ini, and myrjdoe700.tbr with 700 being the 
current version number. 

 

The sections and settings of the MYRuser.INI and/or MYRIAD32.ini file are documented below.  Any 
sections or settings that are not documented should not be modified.  Note:  In both the MYRuser.INI and 
the MYRIAD32.ini, there must be a blank line at the end of the file. 

[Options] 

This section describes both the general display and advanced options, most of which are available through 
the Options dialog box.     

AutoHybrid Automatically senses Hybrid image types and loads all associated files.  This 
corresponds to the Auto Open Hybrid setting in the Options dialog box.   

Note:   This setting should be changed in the Open tab of the Options 
dialog box, not the MYRuser.INI.   

FALSE = Do not sense Hybrids 
TRUE = (Default) Sense Hybrids  

AutoMarkup Specifies to load redlines files associated with an image file automatically.  
This corresponds to the Auto Open Redline setting in the Options dialog box.   

Note:   This setting should be changed in the Open tab of the Options 
dialog box, not the MYRuser.INI.   

FALSE = Do not load redlines 
TRUE = (Default) Load redlines 

AutoZoomWidthEnable Indicates if the image should be considered as a candidate for loading in Fit 
Width mode.  

Note:   This setting should be changed in the View tab of the Options 
dialog box, not the MYRuser.INI.   

FALSE = (Default) Not a candidate  
TRUE = Candidate  

AutoZoomWidthMax This key determines the maximum image size for files to be loaded at Auto 
Fit Width.  The integer value specifies the maximum width in inches or 
centimeters (selected in the View tab of the Options dialog box), of images 
that are opened in Fit Width mode.  For example, the following value 
specifies that any image whose actual width is 10 inches (the default) or 
below, inclusive, is opened in Fit Width mode (based on the 
AutoZoomWidthEnable key below).  
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Note:  This setting should be changed in the View tab of the Options 
dialog box, not the MYRuser.INI. 

AutoZoomWidthMax = 10  

AutoZoomWidthUnit Specifies whether the Auto Zoom Width is specified in inches or centimeters.  

Note:   These settings should be changed in the View tab of the Options 
dialog box, not the MYRuser.INI. 

0 = (Default) Inches 
1 = Centimeter 

Background Color Indicates the index into the background palette (see [BackgroundPalette]).   

Note:   This setting should not be changed by the user.  You can adjust it 
in the Display tab of the Options dialog box.  

CacheImages Specifies to keep standard images (non-multipage) in memory, which speeds 
up subsequent access to those images.   

Note:   This setting should be changed in the Open tab of the Options 
dialog box, not the MYRuser.INI.   

FALSE = Do not keep in memory 
TRUE = (Default) Keep in memory  

DisplayWhileLoading Indicates whether to display images while loading.    

FALSE = Do not display images 
TRUE = (Default) Display images 

Draw Mode Specifies the integer representing the desired raster draw mode.   

Note:   This setting should be adjusted in the Display tab of the Options 
dialog box. 

0 = Sample Draw (Fast, Default) 
1 = Full Draw (Slower) 
2 = Scale to Gray (Slowest) 

DynamicUpdate Indicates whether MYRIAD pans and zooms the image while performing 
rubberbanding that drag off the edge of the visible image window.  

Note:   This setting should be changed in the View tab of the Options 
dialog box, not the MYRuser.INI.   

FALSE = (Default) Do not pan 
TRUE = Pan 

ForegroundColor Indicates the index into the foreground palette (see [ForegroundPalette]).   

Note:   This setting shouldn’t be changed by the user.  You can adjust it in 
the Display tab of the Options dialog box. 

Invert Indicates whether to load monochrome raster files in Invert mode. 

Note:   This setting should be adjusted in the Display tab of the Options 
dialog box. 

FALSE = (Default) Do not load images inverted  
TRUE = Load images inverted 
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Launch Specifies whether the Launch feature is enabled or disabled.  

FALSE = The Launch feature is disabled, and the Launch button is 
not present in the Document Stack Manager 

TRUE = (Default) The launch feature is enabled and the Launch 
button is present in the Document Stack Manager  

MonoMode Indicates whether to load color vector images in Monochrome mode.   

Note:   This setting should be adjusted in the Display tab of the Options 
dialog box. 

FALSE = (Default) Do not load in monochrome 
TRUE = Load in Monochrome  

MRUList Indicates whether to keep a list of the 10 most recently used files under the 
File menu.   

Note:   This setting should be changed in the Open tab of the Options 
dialog box, not the MYRuser.INI.   

FALSE = No MRU list 
TRUE = (Default) MRU list  

MultipageCache Corresponds to the Keep Loaded Pages option in the Open tab of the Options 
dialog box.  Specifies to keep each page visited in a multi-page file in 
memory, which speeds up subsequent access to those pages.   

Note:   This setting should be changed in the Open tab of the Options 
dialog box, not the MYRuser.INI.   

FALSE = (Default) Do not keep in memory 
TRUE = Keep in memory 

Orientation Specifies the integer representing the desired orientation of the image.   

Note:  This setting should be adjusted in the Display tab of the Options 
dialog box. 

0 = (Default) 0 Degrees  
1 = 90 Degrees 
2 = 180 Degrees 
3 = 270 Degrees 

OutlineRedlineHides Specifies to draw an outline around the Redline hide entities, making them 
more visible.   

FALSE = (Default) Do not draw outline  
TRUE = Draw outline 

Precision Determines the number of decimal places used in calibration.  Four is the 
default value.  Values greater than nine are not recommended.  

 Note:   This setting should be changed in the 3D Display tab of the Options 
dialog box (Measurement/Dimension Precision field), not the MYRuser.INI 

ReserveColors Determines whether or not the redline palette colors are added to the image 
colors.  This only affects images with more than 256 colors.  

Note:   This setting should be changed in the Open tab of the Options dialog 
box, not the MYRuser.INI. 
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FALSE = (Default) The redline palette is not added to the image 
colors, allowing a more accurate image palette 

TRUE = The redline palette is added to the image colors 

[Changemark Export] 

This section, located in the MYRIAD32.ini file, indicates the path of the base HTML files for the 
Changemark HTML Publish feature.  

BaseHTMLFile1 Specifies the path for the frame HTML file. 

BaseHTMLFile2 Specifies the path for the graphic HTML file. 

BaseHTMLFile3 Specifies the path for the control HTML file. 

BaseHTMLFile4 Specifies the path for the text HTML file. 

SupportFile1 Specifies the path for the Next button, next.gif. 

SupportFile2 Specifies the path for the Previous button, Prev.gif. 

SupportFile3 Specifies the path for the Index button, index.gif. 

SupportFile4 Specifies the path for the banner image, myrjavapict.jpg 

SupportFile5 Specifies the path for the IGC button, myrjavarigc.jpg 

SupportFile6 Specifies the path for the Changemark frame’s background image, bg3.gif 

IndexFile Specifies the path for the index HTML file, the index of all Changemarks 
exported. 

[3D HTML Export] 

This section, located in the MYRIAD32.INI file, indicates the path of the base HTML files for the 3D 
HTML export feature. 

BaseHTMLFile1 Specifies the path for the 3D frame HTML file, 3DFrame.htm. 

BaseHTMLFile2 Specifies the path for the 3D graphic HTML file, 3DGraphic.htm. 

BaseHTMLFile3 Specifies the path for the 3D control HTML file, 3DControl.htm. 

BaseHTMLFile4 Specifies the path for the 3D text HTML file, 3DText.htm. 

SupportFile1 Specifies the path for the Next button, Next.gif. 

SupportFile2 Specifies the path for the Previous button, Prev.gif. 

SupportFile3 Specifies the path for the Index button, Index.gif. 

SupportFile4 Specifies the path for the banner image, myrjavapict.jpg. 

SupportFile5 Specifies the path for the IGC button, myrjavarigc.jpg. 

SupportFile6 Specifies the path for the background image, bg3.gif. 

IndexFile  Specifies the path for the index 3D HTML file, the index of all view sets 
exported. 

 

 
[3D HTML Assembly Export] 
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This section, located in the MYRIAD32.INI file, indicates the path of the base HTML files for the 3D 
HTML Assembly export feature. In order for the 3D HTML Assembly feature to work, this section must 
not be modified. 

BaseHTMLFile1=3DTreeControl.htm 

BaseHTMLName1=control 

SupportFile1=treeApp.jar 

SupportFile2=file.gif 

SupportFile3=group.gif 

SupportFile4=part.gif 

SupportFile5=pview.gif. 

SupportFile6=uview.jpg. 

SupportFile7=logo.jpg 

SupportFile8=myrjavabanb.jpg 

SupportFile9=myrjavapict.jpg 

SupportFile10=myrjavarigc.jpg 

SupportFile11=bg3.gif 

IndexFile=index.htm 

 

[Changemark_Tool] 

The Changemark_tool section sets the parameters for the Changemark tool. 

State Specifies if the Changemark tool should display on startup. 

FALSE = (Default) Do not display 
TRUE = Display Changemark tool 

Large Specifies whether the Changemark tool should display in expanded form.  

FALSE = Display in collapsed form 
TRUE = (Default) Display in expanded form 

[SidebySide] 

This section sets the parameters for the Side-by-Side Compare tool. 

SxsShadow Specifies the RGB value (in RGB triplet form) for the Alternate Document 
“shadow” in a Side-by-Side view.  The default value is 128, 128, 128.  Note:  
This value is highly dependent on the background color of the view. 

SxsBirdsBackground Specifies the RGB value (in RGB triplet form) for the background of the 
Side-by-Side Bird’s Eye view.  The default value is 0, 0, 0.   

SxsBirdsOnlyMain Indicates the RGB value (in RGB triplet form) for the data only present in 
the main image in the Side-by-Side Bird’s Eye view.  The default value is 0, 
0, 255.   
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SxsBirdsOnlyOther Indicates the RGB value (in RGB triplet form) for the data only present in 
the other (alternate) image in the Side-by-Side Bird’s Eye view.  The default 
value is 0, 255, 0.   

SxsBirdsInBoth Specifies the RGB value (in RGB triplet form) for the data only present in 
both the main and other image in the Side-by-Side Bird’s Eye view.  The 
default value is 255, 0, 0. 

[RedlinePalette] 

This section contains the RGB values (in RGB triplets) for all 18 Redline colors, from 000 to 017.  The 
standard Redline palette is shown below, though the user can change these colors to any valid RGB triplet 
within the limitations of the display hardware and operating system.   

Note:   This section appears in the MYRIAD32.ini file.  The number and format of these keys should 
not be modified. 

Color000=0,0,0 
Color001=0,0,128 
Color002=0,128,0 
Color003=0,128,128 
Color004=128,0,0 
Color005=128,0,128 
Color006=128,128,0 
Color007=192,192,192 
Color008=128,128,128 
Color009=0,0,255 
Color010=0,255,0 
Color011=0,255,255 
Color012=255,0,0 
Color013=255,0,255 
Color014=255,255,0 
Color015=255,255,255 

[BackgroundPalette] 

This section contains the RGB values (in RGB triplets) for the three background colors, from 000 to 002.  
The standard background palette is shown below, though the user can change these colors to any valid 
RGB triplet within the limitations of the display hardware and operating system.   

Note:   This section appears in the MYRIAD32.ini file.  The number and format of these keys should 
not be modified. 

Color000 = 0,0,0 
Color001 = 192,192,192 
Color002 = 255,255,255 

[Background Menu] 

This section controls the background palette used and corresponds with the Background Color menu in 
MYRIAD.   

Color000 = Black:0 
Color001 = Gray:1 
Color002 = White:2 
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[ForegroundPalette] 

This section contains the RGB values (in RGB triplets) for the 16 foreground colors, from 000 to 015.  
The standard foreground palette is shown below, though the user can change these colors to any valid 
RGB triplet within the limitations of the display hardware and operating system.   

Note:  This section appears in the MYRIAD32.ini file.  The number and format of these keys should 
not be modified. 

Color000 = 0,0,0 
Color001 = 0,0,128 
Color002 = 0,128,0 
Color003 = 0,128,128 
Color004 = 128,0,0 
Color005 = 128,0,128 
Color006 = 128,128,0 
Color007 = 192,192,192 
Color008 = 128,128,128 
Color009 = 0,0,255 
Color010 = 0,255,0 
Color011 = 0,255,255 
Color012 = 255,0,0 
Color013 = 255,0,255 
Color014 = 255,255,0 
Color015 = 255,255,255 

[Auto-Recognize File Format Options] 

This section dictates whether MYRIAD automatically recognizes file formats, regardless of extension, or 
not.   

 

Prompt On Success Gives a message box telling the user what type of file was detected and 
verifying if the user wants to load it.  If multiple files were selected, even if 
they are the same type, the message box appears for each one. 

Enable AutoRecognize When set to TRUE, MYRIAD automatically detects the type of file being 
loaded, regardless of extension.  When set to FALSE, the Unrecognized 
Extension dialog box displays, prompting the user to select the file type. 

[PrintHeaders] 

The PrintHeaders section controls the ISO 9000 print banners.  This corresponds to the 
Banners/Watermarks dialog box in MYRIAD. 

OverlayISOBanners When set to TRUE, indicates for MYRIAD to allow the print banners to 
overlay the image.  When FALSE, MYRIAD places the banners outside of 
image margins, but this may result in the image being resized to fit on the 
page. 

Font A comma delimited description of the font.  This should only be set through 
the Banners/Watermarks dialog box. 

TopLeft1, TopRight1, BottomCenter1, etc. 



Administrator’s Guide 

28 

 The actual text or wildcard to place in the field (e.g., TopLeft1= Date : 
%Date, TopRight1= Time : %Time, BottomCenter1= Title: %Title). These 
three appear by default. There are three available fields along each edge 
(TopLeft, TopCenter, TopRight, BottomLeft, BottomCenter, BottomRight, 
etc.).  Each field can be ten lines deep.  Specify which line to print after the 
field location (TopLeft1).  You can also modify these through the 
Banners/Watermark dialog box. 

[Print] 

This section controls the settings and options for the print device on the Printer tab.  These can be 
specified in the MYRIAD32.ini, but any changes made through MYRIAD’s interface are recorded in the 
Myruser.ini file.  If no second print device is configured (there is no Printer 2 tab), this represents the 
only print device.  If Dual Mode Printing is enabled, the settings for the second print device (on the 
Printer 2 tab of the Print dialog box) are stored under the [Plot Section] section of the MyrUser.ini file. 

Allow Dual Output When set to TRUE, this enables dual print mode and adds the second print 
device tab in the Print and Print Setup dialog boxes.  The default is FALSE.  
This option should be set through the Dual Printer tab of the Options dialog 
box. 

Auto Rotate When set to TRUE (default), MYRIAD automatically prints any image 
whose width is greater than length in Landscape mode.  If the length is 
greater, it prints in Portrait mode.  When set to FALSE, images print in 
whichever mode is specified under the Printer Properties.  This corresponds 
to the Auto Rotate option in the print Options dialog box. 

ColorsToBlack When set to TRUE, this prints all colors to black, which can reduce the size 
of the print file spooled.  This is generally only useful for raster documents.  
This corresponds to the Black and White check box in the print Options 
dialog box.  

Metric   When set to TRUE, the Printer2 at Greater Widths Than width is in 
Centimeters.  The default is FALSE, indicating the width is in inches.  This 
corresponds to the cm radio button in the Dual Printers tab of the Options 
dialog box. 

MinLine You can set the minimum line width for printouts, with 1 as the thinnest line 
width available.  Set this equal to the desired number.  This corresponds to 
the Minimum Line Thickness text box in the Print Options dialog box. 

Outline Fills When set to TRUE, this prints all filled entities from the source file with an 
outline, but without color.  The default is FALSE.  This corresponds to the 
Outline Fills check box in the print Options dialog box. 

Plot at Width When Dual Mode Printing is enabled, all files with a width greater than the 
size specified here are sent to the second print device when printing from the 
Document Stack with the Auto Select option.  This should be changed in the 
Printer2 At Widths Greater Than text box in the Dual Printers tab of the 
Options dialog box. 

Note:  The three additional settings (Paper Size, Active Printer, and Printer Name) should not be modified 
by the user. 

[Plot Section] 
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This section controls the settings and options for the print device on the Printer 2 tab.  These can be 
specified in the MYRIAD32.ini, but any changes made through MYRIAD’s interface are recorded in the 
Myruser.ini file.  If no second print device is configured (there is no Printer 2 tab), this section may not 
exist.  All print settings are then contained in the main [Print] section. 

Auto Rotate When set to TRUE (default), MYRIAD automatically prints any image whose width is 
greater than length in Landscape mode.  If the length is greater, it prints in Portrait mode.  When set to 
FALSE, images print in whichever mode is specified under the Printer Properties.  This corresponds to 
the Auto Rotate option in the print Options dialog box. 

ColorsToBlack When set to TRUE, this prints all colors to black, which can reduce the size 
of the print file spooled.  This is generally only useful for raster documents.  
This corresponds to the Black and White check box in the print Options 
dialog box.  

MinLine You can set the minimum line width for printouts, with 1 as the thinnest line 
width available.  Set this equal to the desired number.  This corresponds to 
the Minimum Line Thickness text box in the print Options dialog box. 

Outline Fills When set to TRUE, this prints all filled entities from the source file with an 
outline, but without color.  The default is FALSE.  This corresponds to the 
Outline Fills check box in the Print Options dialog box. 

Note:  The additional settings (Paper Size and Printer Name) should not be modified by the user. 

[Automatic Paper Size] 

This enables MYRIAD to detect the paper size of the file to be printed and send it to the appropriate tray 
of the active printer.  This is an advanced feature of MYRIAD that can only be enabled through the 
MYRIAD32.ini and MyrUser.ini files.  This section must be manually added to and configured by an 
administrator. 

Three printers can be configured under this section.  MYRIAD checks the Active Printer setting under the 
[Print] section of the INI file to determine which of the three printers is currently active (set through the 
Print or Print Setup dialog boxes).  It then determines if the page size of the current file matches any of 
the listed sizes for that printer.  You configure the printers and page sizes using the settings below (an 
example follows). 

AutoSize This setting must be TRUE to enable the detection of page size. 

Printer(n) Specifies the printer path, name, and supported paper sizes.  You can 
configure paper sizes for up to three printers.  Replace (n) with the 
appropriate number between 1 and 3, starting with Printer1.  This setting 
must point to a valid printer accessible by the current machine and the printer 
name should appear exactly as it does in the Active Printer Name text box in 
MYRIAD’s Print dialog box.  Place a comma after the printer name, then add 
the numbers corresponding to the supported page sizes for that printer, 
separated by commas.  Be sure only to use paper sizes that are valid for 
that printer.  Use the following matrix to determine the numbers to use for 
page sizes: 

2   Letter 8.5x11 
3   Tabloid 11x17 
4  Ledger 17x11 
5  Legal 8.5x14.0 
6    Statement 5.5x8.5 
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7    Executive 7.5x10.5 
8    A3 297x420mm / 75.5x106.5 
9    A4 210x297mm / 53.5x75.5 
11  A5 148x210mm / 37.5x53.5 
12  B4250x354mm  / 63.5x90 
13  B5 182x257mm / 46.2x65.2 
14  Folio 8.5x13 
15  Quarto 215x275mm / 54.5x69.8  
16  10x14 
17  11x17 
24  C 17x22 
25  D 22x34 
26  E 34x44 
39  US standard fan 14.8x11 
40  German standard fan 8.5x12 
41  German legal fan 8.5x13 

Example: 

[Automatic Paper Size] 
AutoSize=TRUE 
Printer1=\\<Print Server Machine>\HP LaserJet 4MV,2,3 
Printer2=\\<Print Server Machine>\QMS 1660 Print System,7,14 
Printer3=\\<Print Server Machine>\HP DesignJet 750C (E/A0) Color,9,11,12,24,25,26 

[Redline Present Strings] 

Overrides the default strings that are displayed for the %MrkPresent ISO banner token. If a markup is 
present on the image being printed, then the default Present string value displays “Redlines are present”. 
If no redlines are present, then the default Absent string value displays “No Redlines”. You can 
customize the output of these strings with this key. 

Present=<string> 

Absent=<string> 

 

[Symbol Driver Options] 

Points MYRIAD to the two DWG libraries for symbol support.  This should have been filled in 
automatically at install and should not need to be modified. 

Loader1 The full path to the driver libraries Adinit.dat and Marcomp.dll must be 
specified here, separated by a comma, as shown below.   

Loader1=<Myriad path>\marcomp.dll, <Myriad path>\adinit.dat 

[Symbol Libraries] 

This section controls what symbol libraries are available through the Symbols dialog box.  You can have 
as many symbol files as you require and can control how they are grouped within the dialog box.  Symbol 
files must be DWG files with defined blocks.  Each block is one symbol. 

Library<n> Specifies the group name and dwg file containing the symbol set.  Replace 
<n> with the appropriate number (starting with 1).  The symbols are grouped 
by group name in the dialog box.  More than one library can have the same 
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group name so that all the symbols contained in those libraries appear 
together in the dialog box.  An example is shown below. 

Library1=Mechanical Symbols,D:\Progra~1\IGC\MYRIAD32\myrmech.dwg 

[Launchers] 

Use the [Launchers] section to change which application MYRIAD launches for a particular extension.  
This section does not appear by default in either the Myruser.ini or Myriad32.ini, so you may need to add 
it.  Simply specify the extension, followed by the equals sign (=) and the path to the executable of the 
application you wish to launch, as shown below.  If you specify the same application and path as the 
default, the Launch feature does not work. 

doc=d:\MSOffice\Winword\WINWORD.EXE,WinWord,System,[FileOpen("%1")] 

xls=d:\MSOffice\Excel\EXCEL.EXE,Excel,system,[open("%1")] 

The three fields following the path contain optional DDE information.  The first field contains the 
application name, the second the topic name, and the third the DDE message. Specifying the DDE 
information allows MYRIAD to specify for the application to open another file instead of launching 
another application window. 

[Startup] 

This section sets the parameters for MYRIAD’s startup environment. 

ImagePath Specifies the path where the File/Open… and File/ Document 
Stack…/Add… commands search for image files. 

RedlinePath Indicates the last path where the File/Redline/Open…, /Save…, and /Save 
As… and File/Document Stack/ Redline commands loaded and saved redline 
files.  

PermanentRedlinePath Specifies the default path where the File/Redline/Open…, /Save…, and /Save 
As… and File/Document Stack/ Redline commands load and save redline 
files. Note: This setting can be edited in the Paths tab of the Options dialog 
box.  

DocStackPath Specifies the path where the File/Document Stack/ Open… and /Save… 
commands load and save DSF (Document Stack) files. 

SerialNumber Indicates the path to the MYRIAD license file IGCKey.lic. 

Note:   This value only appears in the MYRIAD32.ini file. 

LicenseServer The IP address of the license server machine on the network. This address 
must match the IP address encoded in the serial number for the License 
Server to run. 

Note:   This value only appears in the MYRIAD32.ini file.  

Network The network protocols and their parameters, comma delimited in order of 
network.  

Note:  This value only appears in the MYRIAD32.ini file. 

[PDF Support] 

This section controls the method used for PDF support. Upon installation, MYRIAD checks to see if a 
version of Adobe Acrobat is available. If found, MYRIAD will prompt the user as to whether or not to 
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use Acrobat for PDF support. If Acrobat is selected, the UseAcrobat setting is automatically set to TRUE. 
If Acrobat is not selected, the UseAcrobat setting is set to FALSE and MYRIAD uses the Liberty driver 
to view PDF files. 

UseAcrobat When set to TRUE, MYRIAD uses Adobe Acrobat to view PDF files. When 
set to FALSE, NULL, or if no version of Acrobat is available on the user’s 
machine, MYRIAD uses the Liberty driver to view PDF files. 

 Note: This value is required to be set to TRUE for MYRIAD to use Acrobat. 

4.4 Disabling Features through INI Files 
You can customize MYRIAD for each user or for all users by creating a Custom section in the individual 
MYRuser.INI file or MYRIAD32.ini file, respectively.  Unlike command line arguments, values entered 
in the MYRuser.INI file remain in effect until you remove them; however, command line arguments 
override any MYRuser.INI values for that session.  The Custom section can be inserted after any other 
section and can contain as many commands as you require.   

You can disable any item by using one or more of the general customization command line arguments 
and assigning it a value of FALSE. 

Format: [Custom] 
<key>=FALSE 

Example: [Custom] 
appexit=FALSE 

Because there are no short-cut commands in the MYRuser.INI file, you must disable all related keys to 
remove certain items completely.  The list below shows the equivalent MYRuser.INI file commands for 
the items with short-cut command line arguments. 

Disable Redline  
MyriadEditRedlineMenu=FALSE 
MyriadRedlineMenu=FALSE 

Disable Mail 
SendMail=FALSE 

Disable Printing  
Print=FALSE 
PrintSetup=FALSE 
PrintRegion=FALSE 
QuickPrint=FALSE 

Disable Calibrate and 2D Measure 
Calibrate=FALSE 
Measure=FALSE 

You can also disable or customize the following three items using the format shown below.  These items 
can also be disabled from the command line.   

Look for the existing section listed below, such as Changemark_tool, in the MYRuser.INI file and enter 
the key and value anywhere in that section.  If you do not see the section that you are looking for in the 
MYRuser.INI, you will need to create it. 

Format: -c<section>:<key>=FALSE 



Administrator’s Guide 

33 

Example: -cChangemark_Tool:Print=FALSE 

 
Item Section Key 
Print button on the 
Changemark List Dialog Box 

Changemark_Tool Print 

Color palette on the Redline 
toolbar 

Custom RedlineColor 

Orientation button on the 
View toolbar 

Custom ToolbarOrient 

 
 

Disabling the Splash Screen 
You can disable the MYRIAD splash screen.  In the [Options] section of either the MYRuser.INI or 
MYRIAD32.INI file, add: 
 
Splash Delay=FALSE 
 
Adding this setting to the MYRuser.INI file disables the splash screen for that user, while adding it to the 
MYRIAD32.INI disables it for all users. Remember that settings in the MYRuser.INI take precedence over 
the settings in the MYRIAD32.INI. 

 

4.5 Myrdrv.ini 
MYRIAD recognizes supported file formats, their file extensions, and any related parameters through the 
Myrdrv.ini configuration.   

For complete details concerning the Myrdrv.ini file and its usage, please refer to the 
Myrdrv_Userguide.rtf document included in your MYRIAD installation directory. 

 

5.0 Document Stack File Format 
 

Just as with the previous version of MYRIAD for Windows, a group file (.dsf), now called a document stack, is used 
to direct MYRIAD to the files specified in the document stack, to describe the files, and to setup markup files for 
documents in the stack.  You can edit the document stack file by opening it in an ASCII text editor, such as Windows’ 
Notepad application.  The formal syntax for document stack files is shown below. 

Stack Header Document… 

Header Informative Graphics Document Stack Version 3.0 Rev 1 

Document DOCUMENT “document-name” [document options] 
  Page… 

 ENDDOC 

Page PAGE [page options] 
  Image… 
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  Markup 
 ENDPAGE 

Image “file-path” [image options] 

Markup MARKUP [file path] 
 

Options 

The document, page, and image options available are listed below.  More detailed descriptions follow under 
Option Descriptions. 

document options: -Bred green blue 
 -Fred green blue 

 -D{0|1|3} 
 -I{0|1} 

 -Oangle 
 -P{0|1} 

page options: -Lminx miny maxx maxy 
 -Cminx miny maxx maxy 

image options: -Fred green blue 
 -Slayerstate 
 -Tdoc-type 

 -Vview-type[page] 

red: 0…255 

green: 0…255 

blue: 0…255 

page: 0… 

angle: {0|90|180|270} 

layerstate: hex-digit… 

view type: {g|m|t} 

Note:  The Stack Header must be included in the format for MYRIAD to recognize the document stack.  If 
you generate the document stack through an integration application, be sure to add the header 
shown above. 

 

Option Descriptions 

 

The options used in the syntax above are listed below with their descriptions. 

Format: -Letter[value] 

Example: -I1 
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-Bred green blue Sets the background color.  The red, green, and blue values are integers from 0 
to 255.  For example, -B255 0 255 sets the background color to purple.  Note:  
This overrides the setting in the Options dialog box. 

-Cminx miny maxx maxy Indicates the initial clip window for the view, or portion of the image displayed.  
For example, -C0.0 0.0 4.25 5.5 sets the clip window to the lower-left quarter of 
the image (assuming the document’s full size is 8.5 by 11 inches). 

-Dmode Specifies the draw mode.   

 0 = Sample 
 1 = Full 
 3 = Scale to Gray 

-Fred green blue Sets the foreground color.  The red, green, and blue values are integers from 0 to 
255.  For example, -F255 0 255 sets the foreground to purple.  Note:  This 
overrides the setting in the Options dialog box. 

-Imode Indicates the invert mode. 

 1 = On 
 0 = Off 

-Lminx miny maxx maxy Specifies the outside limits of the image in inches.  For example,  

 -L0.0 0.0 8.5 11.0 sets the image limits to 8.5 by 11 inches. 
-Oangle Indicates the orientation of the image.  Valid values are 0, 90, 180, or 270. 

-Pmode Specifies the palette type. 

 0 = Color 
 1 = Monochrome 

-Slayerstate Sets the visibility of layers.  It is a string of hexadecimal digits where each bit 
corresponds to a layer.  For example, -S01 specifies that only layer 0 is visible, 
while -SFE specifies that of eight (8) layers, seven are visible and layer 0 is not 
visible. 

-Tdoc-type Indicates the document type or format.  The type is specified by a two or three-
character string: generally, the filename extension for that file type. 

-Vview-type[page] Sets the view type and page.  The view type value can be: 

 g = Graphics 
 t = Text 
 m = Markup 

The pages are numbered starting with 0.  If no page number is specified, 0 is assumed.  For example, -Vg1 
sets the view type to graphics and the page to 1, which is actually the second page. 

Example: 

Informative Graphics Document Stack Version 3.0 Rev 1 
DOCUMENT "objtstbw" -D0 -B200 200 200 -F0 0 255 
 PAGE -L0.0000 0.0000 4.0000 5.0000 
  "C:\documents\objtstbw.ps" -Tps -Vg 
 ENDPAGE 
ENDDOC 



Administrator’s Guide 

36 

DOCUMENT "C:\documents\PROCESS.TIF" -D0 
 PAGE 
  "C:\documents\PROCESS.TIF" -TTIF -Vg 
  MARKUP C:\documents\PROCESS.mrk -S01 
 ENDPAGE 
 

6.0 Troubleshooting 
Install 
Problem: I have an evaluation version of MYRIAD installed on my machine in addition to my current 

version and now my MYRIAD browser plug-in launches the evaluation version.  
Solution:  Installing more than one version of MYRIAD is not recommended or supported. You will not 

be able to install the evaluation plug-in if more than one version is installed, and your current 
plug-in may launch the evaluation version in your browser. To have your current version 
launch, you can change the Application path registry key to point to the current executable 
again: 
HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\App 
Paths\Myriad32.exe 
 
If you also have PDF support using Acrobat, you will need to run the repair utility from 
setup.exe to reinstall the current version myrpdf.api in the Acrobat plug-ins folder. 
 

Problem: I have an evaluation version of MYRIAD installed on my machine in addition to my current 
version and now I can’t launch PDF files in my current version.  

Solution:  Installing more than one version of MYRIAD is not recommended or supported. You cannot 
have PDF support in more than one version simultaneously. If you have PDF support, you will 
need to run the repair utility from setup.exe to reinstall the current version myrpdf.api in the 
Acrobat plug-ins folder. 

 
Problem: I am having trouble using the Inventor format with MYRIAD.  
Solution:  If you want Inventor support, you need to have Design Tracking version 8.0 or 9.0 software 

installed on your system. The MYRIAD CD contains the installation files for Design Tracking 
and you can click the Install Design Tracking button from your CD browser to select which 
version you wish to install and start the installation (or you can run Setup.exe from the Inventor 
folder on your MYRIAD CD). Myriad 7.x is not compatible with Design Tracking versions that 
are earlier than Inventor 7.0. If you are using a previously installed version of Design Tracking 
and are having trouble, running a Design Tracking installation contained on the MYRIAD CD 
should correct any issues. Note: You can view Inventor 8 files with Design Tracking 8.0 and 
you can view Inventor 9 files with Design Tracking 9.0. You cannot view Inventor 8 files with 
Design Tracking 9.0. 

NetSetup 
Problem: I am running Windows XP with Service Pack 2 installed and cannot run a network copy of 

MRIAD. 
Solution:  Windows XPSP2 users must adjust their Window’s Firewall settings to accept MYRIAD. See 

the specific instructions in section 2.4.1 of this document. 
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Problem: I am using a network or local copy of Acrobat.  When I try to launch a PDF file from the client 
machine, I get a message saying that it is loading Acrobat, but nothing happens.   

Solution:  If using a network copy of Acrobat, make sure the network Acrobat is shared and on the same 
machine as the MYRIAD server install. Go to the Acrobat\plug_ins directory on the client 
machine and check for the Myrpdf.api file.  If this is missing, copy it from the 
Acrobat\Plug_ins directory on the network copy of Acrobat. 
Check the registry of the client machine for the following Acrobat keys (these are the keys 
MYRIAD uses to find the Acrobat plug-in): 

  
HKEY_CLASSES_ROOT\AcroExch.App\CLSID\ 

 Under this key, the Default string should point to the Acrobat CLSID key: 
 {85DE1C45-2C66-101B-B02E-04021C009402} 
  

HKEY_CLASSES_ROOT\CLSID\{85DE1C45-2C66-101B-B02E-
04021C009402}\LocalServer 

 
Under this key, there should be a LocalServer subkey. This key's Default string value should 
point to the Acrobat.exe on your machine (or the network copy of Adobe if you used 
NetSetup). Make sure the LocalServer subkey is pointing to the correct path. 
 
Also, Myrpdfps.dll and Myrpdf.exe may not have registered correctly. Verify that the two files 
are in the MYRIAD directory, and then try to re-register these two support files. 
To do this: 

1. Go to a command prompt and change to the Myriad directory.  
2. Type: 
<path to regsvr32.exe>\regsvr32.exe myrpdfps.dll 
3. You should see a message box indicating that the file was successfully registered. Click 

OK. 
4. In the command window, type: 
Myrpdf.exe/regserver 

 
 

As a last resort, you can uninstall and reinstall both Acrobat and MYRIAD. 
 
Problem: The shortcut to MYRIAD on the client machine can’t find MYRIAD. 
Solution: Verify that the Netsetup.txt file in the NetSetup directory on the server machine contains the 

correct share path.  Make sure they still have access to the server machine (it should be 
accessible through Network Neighborhood, for example).  Check the properties for the shortcut 
and make sure the Target text box displays the correct path to MYRIAD.  To check the 
properties, open My Computer or Window’s Explorer and go to <Windows 
Directory>\profiles\<user login>\Start Menu\Programs\MYRIAD 7.0 and right-click on the 
MYRIAD 7.0 shortcut.  Change to the Shortcut tab to review the Target information. 

License Server 
Problem: My License Server service does not automatically start when I launch MYRIAD.   
Solution:  Verify that the server used has a static IP address.  If DHCP is used, the server must be 

assigned the same address each time it requests one.  This is because the IP address is encoded 
in the license key. Using the localhost address does not work. 
Verify that the service is not allowed to interact with the desktop: 
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1. In your Control Panel, click the Administrative Tools icon/Services (for Windows 2000, 
XP, and 2003 Server). 

2. Highlight the Myriad License Server in the Service list and click Properties. 
3. The Properties dialog displays. Click the Log On tab. 
4. Verify that the “desktop in service” checkbox is cleared. 

 
 

Problem: My License Server service does not automatically start when I launch MYRIAD.   
Solution:  To locate the cause, run LicServInstall.exe from a DOS prompt: 
 

<path to MYRIAD>\LicServInstall.exe /P”licserv.exe” 
 

Problem: My License Server does not automatically uninstall when uninstalling MYRIAD components.   
Solution:  To manually uninstall the License Server: 

1. Stop the service. In your Control Panel, select the Services Icon. Select the Myriad 
License Server, and then click Stop.  

2. In the registry, delete the following key: 
HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Myriad License Server 

3. Reboot the Machine. 
4. Navigate to and delete your MYRIAD directory. 

 

7.0 Contacting Informative Graphics 
Technical Support 
You can reach our Technical Support Department Monday through Friday, 7am to 5pm Mountain Standard 
Time, via phone, fax, or e-mail.  Please have the following information ready when you call or include on 
your fax or message: 
 

 Your computer's make and model. 
 Your video driver information. 
 Makes and models of your printer and any other peripheral devices. 
 Your MYRIAD serial number from your IGCKey.lic file. 

 
Phone: (602) 971-6061 
Fax:  (602) 971-1714 
Internet E-mail:  info@infograph.com 
WWW: http://www.infograph.com/ 
FTP: ftp://ftp.infograph.com/ 


