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Recording Tutorials

· Real Time Recording

· Step Recording

· Loop Recording

· Punch Recording

· Multichannel Recording (recording multiple tracks simultaneously)

· Recording a dynamic mix  (moving faders)

· Inserting (Drawing) Notes



Editing Tutorials

· Transposing Notes

· Moving Notes

· Changing Note Durations

· Selecting Notes and other MIDI data

· Quantizing Notes

· Changing Time Signature

· Changing Key Signature



Playback Tutorials

· Playing Sequences

· Auditioning Individual Tracks

Arrangements
· Creating an arrangement

· Inserting additional sequences into an arrangement

· Moving/copying/deleting sequences in an arrangement

· Playing multiple sequences simultaneously



FAQ

· Why can't I hear anything? 

· Why do I hear two instruments when I play? 

· Do I need a lot of MIDI equipment? 

· Is Musicshop a notation program? 

· Why does Notation view show a jumble of letters and numbers rather than notes? 

· Why are all the notes jammed together in Notation View? 

· Why should I send in the Registration Card? 

· How do I contact Technical Support? 



Why can't I hear anything?

There could be numerous causes. Specifically:

If nothing seems to be responding at all

Make sure:

· All devices are plugged in and turned on (don't forget to turn on your MIDI interface!)

· All volume controls are up.

· All connections are made correctly. For example, make sure that your controller's MIDI OUTs are 
connected to your MIDI Interface's MIDI INs; that your sound modules MIDI INs are connected to 
your MIDI Interface's MIDI OUTs; and that the MIDI interface is connected to your computer.

· Make sure your controller is transmitting on one or more MIDI channels.

If the MIDI information seems to be getting to Musicshop, but you still can't hear anything

Make sure:

· The MIDI interface is properly configured to send MIDI information. Some multiport MIDI interfaces 
have numerous internal programs that route MIDI data to devices, so make sure you're using a 
program that routes MIDI from your computer to all your sound modules.

· The volume is turned up on your sound module.

· A sound is loaded into your sound module, or that the patch you selected has an assigned sound.

· The sound module is set to respond to incoming MIDI data.

· MIDI volume control (Control #7) is turned up inside the sound module for that MIDI channel.

If you can hear sound sources when you control them directly, but not when you play them 
through Musicshop

Make sure:

· Setups>Keyboard Thru is checked.

· Your sound module is set to respond to MIDI data arriving on the specified MIDI channel.



Why do I hear two instruments when I play?

This can occur if you're using Musicshop to route MIDI data from your keyboard to a sound module 
and your keyboard's Local Control mode is turned on. As a result, your keyboard plays both its own 
internal sound (as a result of Local Control being on) PLUS sound from the MIDI device specified by 
Musicshop.

To get rid of this problem, always turn off Local Control mode on your MIDI synthesizers.



Do I need a lot of MIDI equipment?

Musicshop responds to and controls any piece of MIDI equipment. It doesn't matter how much your 
MIDI devices cost or how many features they have. Basically, Musicshop can control any device with 
MIDI jacks.

In fact, you can use Musicshop without any actual MIDI devices. As long as you have some kind of 
virtual MIDI device (such as a SoundBlaster card or Apple's QuickTime Musical Instruments), you can 
use Musicshop to play and edit any MIDI sequence. Also, you can input MIDI data without a MIDI 
controller by drawing notes into a score or importing standard MIDI files from the internet or some 
other source. Obviously, it's easier to create custom MIDI sequences if you own some kind of simple 
MIDI controller, such as a MIDI keyboard, MIDI guitar, or MIDI wind controller.



Is Musicshop a notation program?

No. You can use Musicshop to view and print your MIDI data using standard music notation, but 
Musicshop is not an actual music notation application.

A dedicated music notation program, such as Overture for the Macintosh, allows you to customize 
every element of the printed score; adding lyrics, dynamic markings, custom allotment tables, and so 
on. Musicshop does not offer this wealth of customizable options.



Why does Notation view show a jumble of letters and numbers rather 
than notes?

Musicshop uses a special version of the Sonata font to display and print music notation. When you 
install Musicshop, the Sonata font is automatically installed on your computer. If you have removed 
this font, or if you have a font conflict, music notation will not look right. Reinstall the Sonata font to 
alleviate the problem.



Why are all the notes jammed together in Notation View?

If you're using Notation view, and you try to display too many measures in the Edit Window, the note 
heads will all collide with one another. Click the Zoom In Horizontally button to display fewer measures 
in the window.



Why should I send in the Registration Card?

Only when Opcode receives your registration card are you eligible for the following benefits:

· Technical Support

· Free maintenance upgrades to Musicshop

· Notification of and special pricing for New Musicshop versions

· Information about new Opcode products



Edit Window

The Edit Window is Musicshop's main window. Use it to view and edit your tracks and sequences.

The following illustration shows a typical Edit Window (in Graphic View). Click any part of the 
illustration to learn about it.



Transport Controls (Edit Window)

Musicshop's Transport Controls operate like typical buttons on a multitrack tape recorder. Click any 
part of the following illustration to learn what it does.



Record Button (Edit Window)

Initiates recording. If the button doesn't highlight, but the Play button does, it indicates that Musicshop 
is in punch record mode, and the Record button will highlight when the punch-in point is reached.

Key Equivalent: Hit the Tab key to "click" the Record button.



Play Button (Edit Window)

If Setups>Replace is checked, clicking the Play button causes Musicshop to start playback from the 
first bar of the sequence.

If Setups>Punch or Setups>Overdub is checked, clicking the Play button causes Musicshop to start 
playback from the punch-in point.

Key Equivalent: Hit the spacebar to "click" the Play button.



Stop Button (Edit Window)

Stops playback of the sequence.

Windows Key Equivalent: Hit the Enter key to "click" the Stop button.

Macintosh Key Equivalent: Hit the Return key to "click" the Stop button.



Continue/Pause Button (Edit Window)

 

When Musicshop is stopped, this is the Continue button. Clicking it causes the sequence to begin 
playing from the current Counter location. You can start playback from any point in a sequence by 
clicking at that point in the Edit Area, then clicking the Continue button.

When Musicshop is playing, this is the Pause button. Clicking it causes sequence playback to pause.

Key Equivalent: Hit the semicolon key to "click" the Continue button.



Skip Back/Ahead Button (Edit Window)

When you have more than one sequence in your arrangement, these buttons work like the song select 
buttons on a CD player. Clicking the right-most button (Skip Ahead), causes the cursor and counter to 
move to the beginning of the next sequence in the Arrangement Window. Clicking the left-most button 
(Skip Back) causes the cursor and counter to move to the beginning of the current sequence. If you 
quickly click again, you will move to the beginning of the previous sequence.

Key Equivalent: Type < (shift-comma) to "click" the Skip Back button. Type > (shift-period) to "click" 
the Skip Ahead button.



Shuttle Control (Edit Window)

This control works in conjunction with the mouse to give Musicshop a "jog shuttle" control just like a 
professional tape recorder (a procedure known as "scrubbing.") Specifically:

1. Move the cursor over the Shuttle control, then press and hold the mouse button.

2. Drag the mouse to the right of the control's center to scrub forward through your track. Drag it to the 
left of center to scrub backward through your track.

Notice that the further you get from center, the faster you can scrub. This is good for quickly scanning 
a sequence.

Also, the closer you are to the Shuttle control's center, the slower you can scrub. This is useful for 
crawling through a portion of a sequence to find exactly which note you wish to edit.



Sequence Selector (Edit Window)

Shows the letter of the sequence currently displayed by the Edit Window.

1. Press and hold the mouse on the Sequence selector to open a pop-up list from which you can 
select any sequence.

2. When you select a sequence, the Status Bar displays that sequence's attributes, any of which you 
can change.

If you select Sequence Z, Musicshop opens the Arrangement Window, which lets you chain 
sequences together in any order to create complete songs, sets, or playlists.



Patch Selector (Edit Window)

Click the Patch Selector to open a pop-up list of patch names for the MIDI device assigned to the 
current track. The names contained in this list are provided by subscriptions you make using the OMS 
Name Manager.

When you select a patch name from this list, Musicshop sends the necessary program change 
message to your MIDI device and inserts a program change message at the beginning of the track. If 
you select a patch while recording, Musicshop automatically records the program change message 
into your track, which you can then view or edit in the Strip Chart.

NOTE: If the MIDI device is not subscribed to any patch name documents, then clicking this selector 
opens a dialog box in which you enter the desired patch number and, if necessary, any bank select 
messages.

Opening the Name Browser
You can open the Name Browser by alt-clicking the Patch Selector (option-click for Macintosh).



Track Bar (Edit Window)

Use the Track Bar to:

· select which tracks you want to display in the Edit Area (these are called "selected" tracks)

· designate which single track is the record-enabled track (this is called the "current" track)

· view a detailed account of each track

To Select and View Tracks
· Click a track number to display that track in the Edit Area.

· Shift-click additional tracks to display those as well (additionally, you can drag across multiple 
tracks to select them).

· Scroll through the 32 tracks by clicking the arrows above or below the track bar.

· You can select and view all tracks by choosing the Do>Select All Tracks command.

The Current Track
The arrow to the left of the Track Bar points to the current track, which is the track on which Musicshop 
records. Click to the left of any track number to make it the current track.

You can change the current track while recording, and you can use keyboard equivalents (as shown in 
the MIDI>Track Shortcuts submenu) to select current tracks.

The Track Pop-Up List
Press and hold the mouse on the current track indicator (the small arrow to the left of the Track Bar). 
Musicshop opens a pop-up list, which displays:

· the track number

· the track name (as defined in the Track Setup Window), or the name of the device

· the name (or number) of the patch last sent to the device assigned to that track. If the patch name 
is in parenthesis, it signifies that the last patch sent to the device does not match the track's 
assigned patch.

· the length of the track and an indication of whether or not it's set to loop.



Counter (Edit Window)

If a sequence is playing, the Counter displays the current position within the sequence. If a sequence 
is stopped, the Counter displays the Start Edit point.

If you're using arrangements, the Counter displays the relative start time of the sequence within the 
actual arrangement.

The Counter Display
The Counter display is divided into Bars, Beats, and Units.

· Bars: indicates which measure the sequence is playing

· Beats: indicates which beat the sequence is playing.

· Units: indicates how far into a beat the sequence is playing. Specifically, Musicshop divides each 
note into 480 equally-spaced units. Therefore and 8th note would equal 240 units, a 16th note 
would equal 120 units, and so on.

For example, if the Counter reads 6/2/240, then you know the sequence is currently in the sixth 
measure, and an 8th note into the second beat,

Setting the Counter
You can set the counter directly if you:

· click in each field and type a new value.

· click anywhere in the Edit Area and the Counter changes to display that position.

· select a region in the Edit Area and the Counter displays the start time of that region (the Start Edit 
point).



Tempo Field (Edit Window)

Displays the tempo at which the current sequence is playing (or will play).

You can define both the value of the beat and the number of beats per minute.

To define the value of the beat
1. Press and hold the mouse button on the note icon.

2. From the pop-up list, select the value of the beat for which you're defining the tempo.

To set the number of beats per minute
1. Click in the beats per minute field to highlight it.

2. Type a new tempo, then hit the Enter key.

Tapping a tempo
1. Click in the beats per minute field to highlight it.

2. Tap the comma key at the desired tempo. Musicshop constantly analyzes the rhythm of your taps 
and enters them in the Tempo Field.

Tempo with Tracks, Sequences, and Arrangements
Sequences do not have to play at a single static tempo. You can record Tempo Events in the Strip 
Chart to create tempo changes within a sequence. Unlike all other types of control events, tempo 
events are not stored in the current track. Tempo events affect all tracks in a sequence and the Strip 
Chart displays all tempo events, regardless of which track they were entered in or which track is being 
editing in the Strip Chart.

All tracks in a sequence play at the same tempo. Other sequences within an Arrangement can have 
independent tempos as long as they are sequential within the Arrangement. If a sequence is located 
below another sequence in the Arrangement Window, the tempo is derived from the top sequence.



Track Length Field (Edit Window)

Displays, in bars, the length of the current track. The current track is indicated in the Track Bar by a 
small arrow to its left. To change the track length, highlight the Track Length Field and type a new 
value.

To view the lengths of all tracks in a sequence
1. Press and hold the mouse on the current track indicator (in the Track Length field).

2. In the pop-up list that appears, you'll see the length of every track in the right most column.

NOTE: Unless a sequence is locked, its length is always as long as, or longer than, the longest track. 
Therefore, if you lengthen the longest track, Musicshop automatically increases the sequence length to 
match. You can prevent this from happening by locking the sequence length. 

Looping a Track
1. Click the bars on the side of the Track Length field.

2. This turns on track looping (as indicated by the repeat signs inside the bars).

The track loops continuously for the entire length of the sequence. For example, if the track length 
is 8 bars and the sequence is 22 bars (as set in the Sequence Length field in the Status Bar), then 
the track loops two complete times, before ending 6 bars into its third loop.

To turn off looping, click the bar lines in the Track Length field a second time.

Locking a Track Length
1. Alt-click (option-click for Macintosh) on the number in the Track Length field.

2. Musicshop displays a small lock icon in the field.

Once a track length is locked, you cannot change it with any edit operations. For example, pasting 
new data into a track will not increase its length.

To unlock a track, simply Alt-click (option-click for Macintosh) on the Track Length field a second time.



Step Record Button (Edit Window)

Clicking the Step Record button causes Musicshop to enter step-record mode and opens the Step 
Window.

To step record MIDI data into Musicshop
1. Click the Step Record button. The Step Window opens and Musicshop enters record mode.

2. Select the desired record mode (Replace or Overdub) from the Setups menu.

3. Use the Step Window to define your desired step size, note duration and velocity options.

4. Play a note on your MIDI controller. The note appears in the Edit Window and the Counter 
advances by the amount specified by the Step Window's Size parameter.

5. Continue playing notes, adjusting parameters in the Step Window as needed.

6. Press the Stop button when you're finished recording.

To insert rests:

1. Hit the spacebar to advance the Counter without inserting a note.

To step record chords:

1. Hold down your MIDI keyboard's sustain pedal to create chords. (Musicshop does not record the 
sustain pedal as a MIDI event in Step Record mode).

To erase mistakes:

1. Type the backspace key to step backward through the score, erasing the previously entered note or 
chord.



Strip Chart Button (Edit Window)

Displays or hides the Strip Chart at the bottom of the Edit Window.



Edit View Button (Edit Window)

Click this button to switch the Edit Window between Graphic view and Notation view.

· If the Edit Window currently displays Graphic view, the button looks like this  to indicate that 
clicking it will switch Musicshop to Notation view.

· Similarly, if the Edit Window currently displays Notation view, the button looks like this  to 
indicate that clicking it will switch Musicshop to Graphic view.



Marquee Tool (Edit Window)

Click the Marquee Tool to turn the Musicshop cursor into a Marquee selector. In this mode, you can:

· select multiple notes by dragging the cursor across a rectangular region of notes, selecting all 
those notes that begin within the selection rectangle

· select every note in the track that falls within a selected pitch range

· select all MIDI data in a range of time (including Strip Chart data) by dragging across the Ruler at 
the top of the of the Edit area

· select individual notes by clicking them

In addition, you can use the Marquee Tool to transpose a note, change its start time, or change its 
duration.

Learn more about:

· Note selection techniques

· Note editing techniques



I-Beam Tool (Edit Window)

Click the I-Beam Tool to turn the Musicshop cursor into an I-Beam selector. In this mode, you can:

· select all notes within a time range by dragging the cursor across the notes

· select every note in the track that falls within a selected pitch range

· select all MIDI data in a range of time (including Strip Chart data) by dragging across the Ruler at 
the top of the Edit area

· select individual notes by clicking them

In addition, you can use the I-Beam Tool to transpose a note, change its start time, or change its 
duration.

Learn more about:

· Note selection techniques

· Note editing techniques



Note Selection Techniques

Use the Edit Window to select notes. You can use these techniques in either Graphic view  or Notation 
view. The selection methods require use of either the Marquee Tool or the I-Beam Tool, as indicated.

Selecting individual notes
1. Click either the Marquee Tool or the I-Beam Tool.

2. Click any note to select it.

Selecting a contiguous region of notes
1. Click the Marquee Tool.

2. Drag the a rectangle around those notes you wish to select. Any note that begins within the 
rectangle is selected.

Selecting a discontiguous region of notes
1. Click either the Marquee Tool or the I-Beam Tool.

2. Click the first note you wish to select.

3. Shift-click each additional note in the selection.

Selecting all notes in a specified pitch range for the entire track
1. Click either the Marquee Tool or the I-Beam Tool.

2. Move the Cursor to the far left of the Edit Window, so it becomes a horizontal I-Beam.

3. Drag vertically to select a range of pitches for the entire track.

Selecting all MIDI data (including Strip Chart data) in a selected time range
1. Click either the Marquee Tool or the I-Beam Tool.

2. Move the Cursor into the Ruler at the top of the Edit Area.

3. Drag across the Ruler to select all MIDI data in all displayed tracks for the selected time range.



Note Editing Techniques

From the Edit Window (either Notation or Graphic view), you can transpose any note, change its start 
time, or change its duration using only the mouse.

Transposing a Note
1. Click either the Marquee Tool or the I-Beam Tool.

2. Move the cursor over the CENTER of a note (or note head). The cursor looks like this  and is 
called the Transpose Cursor.

3. Drag the note up to raise its pitch. Drag the note down to lower its pitch. The Status Bar updates to 
always show the current pitch of the note.

Changing a Note's Start Time
1. Click either the Marquee Tool or the I-Beam Tool.

2. Move the cursor over the LEFT edge of a note (or note head). The cursor looks like this  and is 
called the Move Cursor.

3. Drag the note left to make it start earlier in time. Drag the note right to make it start later. The 
Status Bar updates to always show the current start time of the note. Notation view automatically 
inserts rests to fill any gaps created by moving notes.

NOTE: Use Cursor Quantize if you want to move the note in actual musical increments.

You can globally move entire selections of notes (and all other types of Strip Chart data) using the 
Edit>Move Events command.

Changing a Note's Duration
1. Click either the Marquee Tool or the I-Beam Tool.

2. Move the cursor over the RIGHT edge of a note (or note head).The cursor looks like this  and 
is called the Duration Cursor.

3. If Musicshop is in Graphic View, drag the cursor to the left to shorten the duration of the note. Drag 
it to the right to lengthen a note.

4. If Musicshop is in Notation View, click the note head with the Duration Cursor to select a new 
duration from a pop-up list.



Pencil Tool (Edit Window)

When you click the Pencil Tool, you can insert notes into Musicshop by "drawing" them. With this tool, 
you can enter MIDI notes without a MIDI controller.

To insert (draw) notes into Musicshop
You can insert notes in either Graphic or Notation view.

1. Double-click the Pencil Tool to open the Insert Window.

2. Use the Insert Window to define your desired note size, note duration and velocity options.

3. Move the cursor over the Edit Window (the cursor becomes note shaped).

4. Watch the Status Bar as you move the cursor around the screen. The Status Bar indicates both the 
pitch of the note and its start time, if you were to click the mouse.

5. If desired, turn on the Cursor Quantize feature to make note placement easier.

6. When you've positioned the cursor at the desired pitch and start time, click the mouse to insert a 
note. The note has the characteristics defined by the Insert Window.

NOTE: If the Edit Window is in Graphic view, you can "paint" notes of any duration by holding down 
the shift key while you drag the note to the desired length.



Quantize Options (Edit Window)

This area contains two pop-up lists, the contents of which change slightly depending on various 
factors.

Quantize Types
Musicshop supports four types of quantization:

· Notation: This option is available only if Musicshop is in Notation view. Use this type of 
quantization to define the smallest note value shown in a printed score. Notation quantization does 
not modify the actual MIDI data, only the way that data is displayed in Notation view.

· Cursor: Causes cursor movements to lock to a grid defined by the Quantize Value selection. Use 
this type of quantization whenever you want to make edits or selections that align to a defined note 
resolution. Cursor quantization does not modify any MIDI data, it only changes the way the cursor 
moves around in either the Edit Window or the Arrangement Window.

· Edit: Permanently alters MIDI data by moving all MIDI notes to the nearest value defined by the 
note grid defined by your Quantize Value selection. Use Edit Quantize to tighten the timing of a 
track. To use this type of quantization, select the notes you wish to quantize, then choose 
Do>Quantize Selection.

· Play: Quantizes MIDI notes during playback, without actually altering the MIDI data. Use this type 
of quantization when you want to experiment with different levels of quantization before 
permanently editing the MIDI data. Each track has its own independent Play Quantize value.

Quantize Values
The appearance of the Quantize Value pop-up list changes depending on which Quantize Type is 
currently selected. For each type of quantization, use the Quantize Value pop-up list to select the 
amount of quantization you wish to apply.



Quantizing Your Sequence

Musicshop supports numerous types of quantization. This section discusses how to permanently 
quantize MIDI data in your sequence. This is called Edit Quantizing.

1. In the Edit Window, select Edit from the Quantize Type pop-up list.

2. Select the desired Quantize Value from the pop-up list immediately to the right of the Quantize Type 
selector.

3. If you wish to quantize the duratation of each note (as well as its start time), select the 
Do>Quantize Duration option to check it.

4. Select the notes you wish to quantize.

5. Choose Do>Quantize Selection.

Musicshop moves the notes to the closest note value selected in the Quantize Value pop-up list 
and, if Quantize Durations is checked, modifies the length of the note as well.



Status Bar (Edit Window)

The Status Bar has four modes that always display relevant information about:

· The Cursor Location

As you move the cursor around in the Edit Area, the Status Bar displays the cursor's current time 
and pitch location.

In this mode, you cannot edit the data contained in the Status Bar.

· The Sequence

When you select a sequence from the Sequence selector, the Status Bar displays that sequence's 
name, length, time signature, and key.

In this mode, you can edit the information contained in the Status Bar. Specifically, you can define 
the sequence's name, length, time signature, and key by selecting the respective fields and 
entering new values.

NOTE: You can lock the sequence length, if desired, by Alt-clicking (option-clicking on Macintosh) 
the sequence length field.

· Recording Modes

Whenever you click one of the transport controls, set a Record Mode, or create a punch point, the 
Status Bar displays your current record information.

If Musicshop is in Wait for Note mode, the left-most field displays a note. If Musicshop is in 
Countoff Mode, use the left-most field to set the number of bars you would like for a countoff.

The fields to the right show where recording will begin and end. Normally, recording starts at bar 1, 
beat 1, unit 0 and ends at infinity (meaning you can record for as long as you want). If, however, 
you set Punch In and Punch Out points, those values are then displayed in these fields. You can 
change punch points directly in the Status Bar, or you can use the Do>Selection->Punch Points 
command.

· Pitch, Velocity, and Duration of a Selected Note

Whenever you press and hold the cursor on a note in the Edit Area, the Status Bar displays the 
MIDI attributes of that note.

From left-to-right, the Status Bar shows a note icon, the note's on time, the note's pitch, the note's 
duration, and the note's velocity.



Locking the Sequence Length

Normally, Musicshop automatically lengthens a sequence to match the length of the longest track 
contained within it. However, you can lock the sequence length so this doesn't happen:

1. Alt-click (option-click for Macintosh) the sequence length field in the Status Bar.

2. Musicshop locks the sequence length and inserts a lock icon to indicate the length is locked.

A locked sequence will always play for the length specified in the sequence length field. If you record a 
track that's longer than the sequence, Musicshop will not increase the length of a locked sequence.

You can unlock a sequence length by Alt-clicking (option-clicking for Macintosh) on the sequence 
length field for a second time.



Edit Area (Edit Window)

Contains a graphic representation of the MIDI notes in the selected tracks.

Musicshop can display notes in either Graphic View or Notation View.

Two switch between views, click the Edit View button.

Use the Edit Area to:

· view MIDI notes

· edit MIDI notes (including their start times, pitch, and durations)

· insert new MIDI notes

· select MIDI notes  for editing, either directly or by dragging the cursor through the Ruler.



Ruler (Edit Window)

The numbered strip above the Edit Area is called the Ruler. It has two functions:

· It provides a visual time reference for the MIDI data in the track(s).

· It provides a means of selecting all MIDI data for all displayed tracks in a specified time range. This 
includes all Strip Chart data, whether or not it's currently displayed.



Strip Chart (Edit Window)

When you open an Edit Window for the first time, you won't see the Strip Chart. To display it, click the 
Strip Chart Button:

Click any element in the following Strip Chart illustration to learn about it.

Use the Strip Chart to graphically display, create, or edit such MIDI track properties as:

· velocity

· duration

· pitch bend

· modulation wheel and other MIDI controls

· program changes

· tempo

· system exclusive data



Strip Chart  I-Beam Tool

Click this tool to select the Strip Chart I-Beam Tool.

With the I-Beam Tool selected, drag across any time range in the Strip Chart to select all Strip Chart 
data within that time range. This tool works independently of the I-Beam Tool and Marquee Tool at the 
top of the Edit Window.



Strip Chart  Pencil Tool

Click this tool to select the Strip Chart Pencil Tool.

Use the Pencil Tool to "draw" MIDI data into the Strip Chart. The Pencil Tool draws with the shape 
shown in the Edit Shape Selector.



Strip Chart Variable Selector

Click the Variable Selector to open a pop-up list of ways to edit Strip Chart data.

Once you select a variable and an Edit Shape, simply drag across any existing Strip Chart data to 
modify it according to the variable you select in this pop-up list. Specifically:

· Scale: Scales Strip Chart data from 25% to 400% of its present value (as indicated by the data 
range shown in the left margin). Musicshop multiplies each event by the scale factor (confining the 
results to the limits imposed by the event type).

· Add Amount: Adds or subtracts a specified value to each Strip Chart event. The value added (or 
subtracted) is shown by the data range in the left margin. For example, if all your MIDI velocity 
values are at 64, and you draw a sloping line beginning at 10 and ending at 20, Musicshop scales 
the velocities such that the first is now 74 (64+10) and the last is 84 (64+20). You cannot increase 
or decrease an event's value beyond the limits of that particular event.

· Max Limit: Sets a maximum value for all selected Strip Chart events. Any values greater than the 
maximum limit are lowered to that maximum value. Any values less than the maximum limit are 
unchanged.

· Min Limit: Sets a minimum value for all selected Strip Chart events. Any values less than the 
minimum limit are raised to that minimum value. Any values greater than the minimum limit are 
unchanged.

· Legato: Changes the duration of selected notes with respect to their proximity to the following note. 
For example, drawing a straight legato line at 100% causes the duration of each MIDI note to 
extend to the beginning of the note following it. This tool is a great way to quickly make a staccato 
performance a legato one, or vice-versa. NOTE: This choice is disabled when the Strip Chart 
shows anything other than note duration.

· Thin: Changes the density of existing MIDI control data. Pitch Bend, Aftertouch, or MIDI Volume 
events that were recorded in real-time are often very dense and contain far more data than is 
necessary. Using the Density numerical, set the desired MIDI density (as a percent of maximum 
MIDI bandwidth), then drag across the existing Strip Chart data with the Thin Tool. Musicshop thins 
the existing MIDI data to the specified percentage. Note that you can use this tool to increase MIDI 
data as well. This is useful if your present MIDI control data is too course (resulting in audible steps 
rather than a smooth change in the control value).



Strip Chart  Edit Shape Selector

Click the Edit Shape Selector to open a pop-up list of shapes with which you can draw in the Strip 
Chart.

The selection you make here is used either for drawing MIDI data (with the Pencil Tool) or modifying 
existing data (with the Variable Tool).

· Straight: Draws a straight line between two points. To do this, press and hold the mouse button at 
the start point, drag to the release point, then release the mouse button.

· Free: Draws a free form line. To do this, press and hold the mouse button, then drag anywhere 
within the Strip Chart. Musicshop draws a shape that follows your drag path, no matter how "curvy" 
it is.

· Parabola: Draws a parabolic curve that starts relatively flat and gets exponentially steeper. To do 
this, press and hold the mouse button at the start point, drag to the release point, then release the 
mouse button. Using this tool you can make either concave or convex fade-ins and fade-outs.

· Flat: Draws a straight flat line of a single value. To do this, press and hold the mouse button, then 
drag across the Strip Chart, releasing the mouse button at the desired point.

· Random: Creates random values within a selection rectangle that you drag in the Strip Chart.



Strip Chart Density Setting

Used to determine the density of MIDI data that you draw (or edit) in the Strip Chart. This numerical 
shows the amount of MIDI data as a percentage of the maximum MIDI bandwidth. In general, you 
should set this value as low as possible (often 1% or less) whenever you create MIDI data with the 
Pencil Tool, or edit it with the Thin Tool.



Strip Chart Data Range

Shows either:

· the numeric value of the MIDI events displayed in the Strip Chart, or

· the amount you can change the data displayed in the Strip Chart (using the Variable Tool).



Strip Chart Data Display

Shows a graphic representation of the MIDI data selected in the Contents Selector.



Strip Chart Contents Selector

Use the Contents selector to determine what type of MIDI data is displayed in the Strip Chart. To do 
this:

1. Click the Contents selector to open a pop-up list of choices

2. Select a choice from the list.

When you make a selection from the Contents list, the Strip Chart displays all data of the selected 
type. You can then use the various Strip Chart editing tools (such as the Variable Tools and the Edit 
Shape Tools) to create or modify the data.

NOTE: The Contents selector uses bold type to distinguish which types of MIDI messages are 
already contained in the track. For example, in the above illustration, Key Velocity, Duration, Patch 
data (program change messages), and Mod Wheel (Controller) data are all contained in the track.

If you select Controller from the list, Musicshop adds a second pop-up list to the right of the Contents 
selector.

This is the Control Type selector. Use it to select which MIDI control message you want the Strip Chart 
to display



Zoom Buttons (Edit Window)

Click these buttons to zoom in or out of the MIDI data displayed in the Edit Area.

There are two types of zoom: vertical and horizontal:

· Vertical Zoom: In Graphic View, the vertical Zoom buttons make a greater or lesser range of 
pitches appear in the Edit Area. In Notation view, the vertical zoom buttons change the notation font 
size.

· Horizontal Zoom: In both Graphic and Notation views, the horizontal Zoom buttons make a greater 
or lesser range of time appear in the Edit Area.

Zooming Shortcuts
To zoom to a specific note range:

· Alt-drag (option-drag for Macintosh) in the Edit Area's left margin (pitch indicator area).

To zoom to a specific time range:

· Alt-drag (option-drag for Macintosh) in the Ruler.

To zoom to a specified range of notes and time:

· Alt-drag (option-drag for Macintosh) a rectangle around the desired notes in the Edit Area.

To automatically zoom the entire track so that it fits in the Edit Area:

· Choose Do>Zoom to Fit.

To zoom out one level:

· Alt-click (option-click for Macintosh) in the Ruler to horizontally zoom out one level.

· Alt-click (option-click for Macintosh) in the left margin (pitch indicator area) to vertically zoom out 
one level.

· Alt-click (option-click for Macintosh) in the Edit Area to zoom out one level (both horizontally and 
vertically).



Graphic View

Displays MIDI notes as a grid in which pitch is indicated by the vertical position of a note (shown by the 
Pitch Indicator) and time (in bars/beats) is indicated by the horizontal position of a note (shown by the 
Ruler). The length of a note indicates its duration.

You can select notes and edit notes in Graphic view.



Notation View

Displays MIDI notes in standard music notation.

Usually, each track is represented as a single staff. Musicshop uses two staves (a grand staff) to 
display any track whose note range crosses Middle-C in either direction by at least a fourth. The clef is 
automatically assigned to the track based on the note content.

Using Notation View
Musicshop is not a dedicated notation program. Notation is provided to simplify MIDI editing and to 
create rudimentary printouts of your sequences. As such, Musicshop does not let you manually create 
rests, or add dynamic markings, slurs, or complex endings. Musicshop does, however provide the 
following notation features:

· Change notation display resolution

· Manually shift octave display  to reduce the number of ledger lines

· Change the time signature

· Change the key signature

· Automatically create rests

Musicshop automatically creates rests in the absence of any MIDI note data.

· Automatically create voicings:

If Musicshop detects more than one distinct rhythmic pattern within a track, it will create separate 
voices and, whenever possible, will automatically point stems and ties in opposite directions so 
they do not collide.

You can select notes and edit notes in Notation view.



Changing the Notation Display Resolution

You can change the resolution that Musicshop uses to display notes.

Changing the notation display resolution does not modify the actual MIDI note values or the way the 
sequence sounds.

1. Make sure Musicshop is in Notation view (if it's not, click the Edit View button at the top of the Edit 
Window).

2. Select Notation from the Quantize Type selector.

3. Select the desired note resolution from the Quantize Value selector.



Changing the Key Signature

1. Make sure Musicshop is in Notation view (if it's not, click the Edit View button at the top of the Edit 
Window).

2. Position the cursor over any staff's key signature. If the song is in the key of C and no sharps or 
flats appear, position the cursor in the area where the key signature is normally displayed 
( between the clef and the time signature).

3. Press and hold the mouse button to open a pop-up list of key signatures.

4. Select the desired key signature from the pop-up list and Musicshop applies the new key signature 
to every track in the sequence.

You can change the Key Signature in any view if you:

1. Select a sequence from the Sequence selector. This causes the Status Bar to display the 
sequence's attributes.

2. In the Status Bar, press and hold the mouse button on the Key Signature and select a new key 
from the pop-up list.



Changing the Time Signature in Notation View

1. Make sure Musicshop is in Notation view (if it's not, click the Edit View button at the top of the Edit 
Window).

2. Move the cursor over any staff's time signature.

3. To change the numerator (number of beats per measure), drag it up or down.

4. To change the denominator (value of a beat), press and hold the mouse button on it, then select a 
new value from the pop-up list.

You can change the Time Signature in any view if you:

1. Select a sequence from the Sequence selector. This causes the Status Bar to display the 
sequence's attributes.

2. In the Status Bar, drag up or down on the Time Signature's numerical to set a new number of beats 
per measure.

3. Also in the Status Bar, press and hold the mouse on the Time Signature's denominator, then select 
a new beat value from the pop-up list.



Shifting Octaves in Notation View

Sometimes your track might consist of notes that are extremely high or low in pitch, which can result in 
a staff that contains too many ledger lines to be readable. You can change the octave that the octave 
in which the music is notated without changing the actual MIDI data.

1. In the staff you wish to change, move the cursor underneath the Clef. The cursor turns into an "8."

2. Press and hold the mouse button and select an octave shift value from the pop-up list.



Technical Support Options

Opcode provides a variety of support options for its customers.

Obviously the first place to look for assistance is in the printed manual or this on-line Help file. For last 
minute changes, check any Read Me files included with Musicshop.

If, after consulting these sources, you are still having problems, Opcode is available to assist you with 
your technical support needs. Before calling the Technical Support line, please be seated near your 
computer with the program running, and have your serial number (located on the original master disk) 
handy.

You may also contact us by fax or email. To inquire about updates, upgrades and disk replacements, 
call our customer service number.

Customer Support Hours
· Monday thru Friday, 9:00 AM to 5:00 PM

· Saturdays, 11:00 AM to 5:00 PM with limited staff support

Times are Pacific Standard and are subject to change without notice.

Phone Numbers
· Customer service: 415-856-3333

· Technical support: 415-856-3331

· Fax: 415-856-0777

Internet Access
· Email: support@opcode.com

· World Wide Web: http://www.opcode.com

· FTP site: ftp.opcode.com
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Punch Recording

With Punch Recording, Musicshop automatically goes into record mode when the Punch In point is 
reached and exits record mode when the Punch Out point is reached.

Punch Recording is useful when you need to record a few bars in the middle of a sequence. You can 
start playing the sequence at the beginning and play along with it, but Musicshop will not record 
anything you play except in the punch region. This is like having a third hand to hit the Record button 
while you're busy playing.



Sequence

A collection of tracks that control the playback of one or more MIDI devices.

Musicshop can record tracks into any of 25 sequences (A-Z), each of which can be thought of as a 
song, song selection, or music layer.

Each sequence, which can contain up to 32 tracks, has its own name, length, meter, key, and tempo.



Step Recording

With step recording, you use a MIDI controller to enter notes into Musicshop but, unlike real-time 
recording, the counter only advances when you play a note. In this way, Musicshop only records a 
note when you're ready to play it.

Step recording is a great way to enter music that may be too complex to play in real-time, or to gain 
more precise control over each note's length, location, and velocity.



Track

A track is the most basic building block in Musicshop. Tracks record a variety of MIDI data such as 
notes, aftertouch, pitch bend, modulation wheel, continuous controller events, patch changes, and 
system exclusive data.

Each of Musicshop's 32 tracks has its own track length and may be independently looped.

Musicshop displays all the track's contents in the Edit Window. Notes are displayed in the Edit Area 
(using either Notation view or Graphic view), and all other types of MIDI events are displayed in the 
Strip Chart.

Tracks can be assembled into sequences.



Arrangement

A series of sequences, which are chained together in the Arrangements Window to create song 
structures. Additionally, sequences can be layered in the Arrangements Window to create unique 
polyrhythms or other creative structures.



Local Control

A setting stored in most MIDI keyboards that enables its keyboard to play its own internal sound 
source. When you turn Local Control off, the keyboard acts as a separate MIDI controller and MIDI 
sound source. You should turn Local Control off whenever you use Musicshop (or any MIDI 
sequencer), since you'll want Musicshop to handle all the MIDI routing tasks.



System

A group of staves; each of which is played at the same time as all the other staves in the system. All 
staves in a system are joined by a single vertical line connecting their left sides.



Arrangement Window

Use the Arrangement Window to string sequences together into any playback order. Each sequence is 
indicated by a block, and you can arrange these blocks in any order you wish. To open the 
Arrangement Window, choose Windows>Arrangement.

Click any part of the following illustration to learn about its function.

Additionally, the following tutorials will help you learn how to use the Arrangement Window:

· Create an arrangement

· Insert additional sequences into an arrangement

· Move/copy/delete sequences in an arrangement

· Play multiple sequences simultaneously



Transport Controls (Arrangement Window)

The transport controls function just like the controls on a typical CD player. Specifically:

 Play from Start: Click this button to start playing the arrangement from the top (beginning with Bar 1 
of the first sequence).

 Stop: Click this button to stop playback of the arrangement.

  Continue/Pause: Click the Continue button to play the arrangement from the point displayed in 
the Counter. When the arrangement is playing, the button becomes a Pause button. Click the Pause 
button to pause playback of the arrangement.

 Skip Back/Ahead: Click the Skip Ahead button (on the right) to move the Cursor and Counter to the 
beginning of the next sequence in the arrangement. Click the Skip Back button (on the left) to move 
the Cursor and Counter to the beginning of the previous sequence. NOTE: If Musicshop is playing, the 
Skip Back button moves the cursor to the beginning of the current sequence. Click it again quickly to 
jump to the beginning of the previous sequence.



Counter (Arrangement Window)

Displays the arrangement's playback location (and cursor location) in bars, beats, and units.

You can set the Counter to any desired value by:

· Clicking the desired field (bars, beats, or units) and typing a new value, or

· Clicking in the Ruler at the top of the Arrangement Window's Sequence List.



Sequence Selector (Arrangement Window)

Use the Sequence selector to add sequences to the arrangement. Specifically:

To insert a sequence
1. In the Arrangement Window, click the Ruler anywhere within the region occupied by the existing 

sequence.

2. Press and hold the mouse button on the Sequence selector.

3. From the pop-up list, select the sequence you wish to add to the list.

4. Musicshop adds the sequence immediately after the existing sequence.

SHORTCUT: You can simply type the letter of the sequence you wish to insert. You do not have to 
select it from the Sequence selector.

To insert blank space in an arrangement
To do this, you must create a blank sequence.

1. In the Edit Window, select a new, empty sequence from the Sequence selector.

2. In the Edit Window's Status Bar, enter the desired length of the blank sequence and name it "Blank 
4 Bars" or something similar.

3. Open the Arrangement Window and enter the blank sequence in the list using one of the methods 
mentioned previously.

NOTE: You need to do this only for the first sequence row in the Arrangement Window. Subsequent 
rows do not need dummy sequences. For more information about multiple sequence rows, see Playing 
Multiple Sequences Simultaneously. 



Creating an Arrangement

1. Choose Windows>Arrangement to open the Arrangement Window.

2. Type the letter of the first sequence in your arrangement. Alternately, you can select in from the 
Sequence Selector pop-up list in the upper-right corner of the Arrangement Window.

3. Musicshop adds a sequence block to the Arrangement Window, and advances the Counter to the 
end of that sequence.

4. Type the letter of the next sequence in your arrangement. Musicshop adds a block for it, and 
advances the Counter.

5. Continue this process until you've built a complete arrangement of sequences.



Editing Arrangements

Rearranging Sequence Order
1. Press and hold the mouse in the left half of a sequence block (the cursor becomes a move cursor 

).

2. Drag the sequence block to the desired location and release the mouse button.

3. Musicshop rearranges the sequences into the order you requested.

Copying Sequences in an Arrangement
1. Hold down the alt key (option key on Mac).

2. Press and hold the mouse in the left third of the sequence block (the cursor becomes a move 

cursor ).

3. While holding the alt (option) key, drag the sequence block to the location in which you want to 
copy it, then release the mouse button.

4. Musicshop copies the sequence to the location you specified.

Deleting Sequences in an Arrangement
1. Click anywhere within the sequence block.

2. Hit the delete key. Musicshop removes the sequence block from the arrangement and automatically 
closes any gap left by its removal.

Replacing One Sequence With Another
1. Click the sequence block you wish to replace.

2. Type the letter of the sequence with which you wish to replace it.

3. Musicshop replaces the selected sequence, shifting any other sequences accordingly.



Playing Multiple Sequences Simultaneously

Musicshop can play sequences simultaneously. For example, assume you want Sequence B to play 
concurrently with Sequence A.

1. In the Arrangement Window, type the letter A, then type the letter B. Musicshop creates two 
sequence blocks, with Seq B following Seq A.

2. Press and hold the mouse in the center of Sequence B. The cursor looks like .

3. Drag down on the block and release the mouse button. Musicshop moves Sequence B to the line 
below Sequence A.

4. Press and hold the mouse in the left third of Sequence B. The cursor looks like .

5. Drag the Sequence to the left so it aligns under Sequence A, then release the mouse button.

6. Play the arrangement. Sequence A and Sequence B now play simultaneously.

Cool reasons to use simultaneous sequences
There are a number of reasons you might want to play multiple sequences simultaneously:

· You could create a "global mix" sequence that contains all the pan and volume changes for the 
entire song rather than putting these mix events inside the individual sequences. You could then 
play the Mix track and the individual sequences simultaneously.

· You could create a separate "Program Change Sequence" that contains all the program changes 
used by your song. If you do this, you won't have to worry about accidently erasing or replacing 
program change messages in your MIDI sequences, since they're all contained in the separate 
program change sequence.

· You can combine repetitive and non-repetitive sequences to create a song. For example, you could 
create basic rhythm and bass sequences, chain them together, then add a long, flowing melody 
sequence that plays over the basic rhythm sequences.

· Experimental music, such as creating unique polyrhythmic structures.



Status Bar (Arrangement Window)

When you move the mouse around in the Arrangement Window, the Status Bar shows the cursor's 
location. You can quantize cursor movements by selecting a setting in the Edit Window.

When you click a sequence block to select it, the Status Bar displays pertinent information about that 
sequence. Specifically, it shows the sequence's letter; name; length; and meter. Use the Status Bar to 
rename a sequence, or to set a new length or meter for that sequence.

NOTE: Your sequence length can not be shorter than the longest track in that sequence. Use the Edit 
Window's Track Bar if you need to see the length of individual tracks in a sequence.



Sequence List (Arrangement Window)

This is the area in which you "build" and edit your arrangement. Each sequence is shown as a block.

· The length of the block indicates the length of the sequence.

· The position of the block indicates the sequence's start time.

Click in the Ruler above the sequence blocks to set the Counter to that value.

Use the Sequence List to:

· Create an arrangement

· Insert additional sequences into an arrangement

· Move/copy/delete sequences in an arrangement

· Play multiple sequences simultaneously



Zoom Buttons (Arrangement Window)

 Zoom Out Button: Each time you click this button, the Arrangement Window shows a greater range of 
time.

 Zoom In Button: Each time you click this button, the Arrangement Window shows a narrower range of 
time.

NOTE: You can zoom the window to automatically show the entire arrangement by choosing 
Do>Zoom to Fit.



Mixer Window

Use the Mixer Window to adjust each track's volume and pan, making the various sounds in your 
sequence sound more balanced. This process is called "mixing." To open the Mixer Window, choose 
Windows>Mixer.

Click any part of the following illustration to learn about its function.

NOTE: Your MIDI device must be able to respond to MIDI volume messages and MIDI pan messages. 
If your device does not respond to MIDI velocity messages, you can assign faders to control MIDI 
velocity values.

Using the Mixer Window, you can:

· create a snapshot of the mix, and insert it into your sequence.

· record a dynamic mix, so that all your fader movements play back each time you play the 
sequence.

· Group faders and move them simultaneously



Recording a Dynamic Mix

1. Select the Setups>Overdub option to check it.

2. Choose Windows>Mixer to open the Mixer Window.

3. In the Edit Window, click the Record button (or hit the Tab key)

4. If Musicshop is in Wait for Note mode, press the spacebar to start the sequence.

5. As the sequence plays, drag the desired faders up and down to record your mix.

6. Click the Stop button to stop recording.

When you play back your sequence, you'll hear the adjustments you made and you'll see the faders 
automatically move to their recorded values.



Auditioning Individual Tracks

Use the Mixer Window to mute or solo individual tracks. Specifically:

To mute track(s)
1. Choose Windows>Mixer.

2. Click the Mute (M) buttons for any tracks you don't want to hear.

3. Click the Play button in the Edit Window.

Musicshop plays only those tracks that aren't muted.

To solo track(s)
1. Choose Windows>Mixer.

2. Click the Solo (S) buttons for those tracks you want to hear.

3. Click the Play button in the Edit Window.

When one or more Solo buttons are pushed, Musicshop plays only those tracks and no others.



Grouping Faders

You can group faders so that you can drag one, and the entire group moves simultaneously:

1. Shift-click each fader you want in the group.

2. Record fader movements as discussed in Recording a Mix.

NOTE: Grouped faders always reach their respective zero points at the same time. That means faders 
that are initially set to higher values decrease in value faster than those initially set to lower values.



Creating Mixer Snapshots

You can take "snapshots" of all the volume and pan settings in the Mixer Window, then place those 
settings at any point in any sequence.

To copy and paste individual faders or groups of faders
1. With the Edit Window active, shift-click all the tracks whose fader settings you wish to copy.

2. Choose Windows>Mixer to open the Mixer Window.

3. With the Mixer Window active, choose Edit>Copy Faders.

4. In the Edit Window, select the Sequence into which you'd like to paste the fader values.

5. Shift-click all the tracks into which you'd like to paste the fader values.

6. Click in the Ruler to set the insertion point.

7. Choose Edit>Merge Selection.

Musicshop pastes the pan and volume fader values into the selected tracks at the specified insert 
point.

NOTE: Musicshop pastes tracks in numerical order, not the order in which they were selected. For 
example, assume you copy the fader values from Tracks 1, 2, and 3. Then you select tracks 20, 30, 
25, and 15 as destination tracks. Musicshop pastes Track 1's fader values into Track 15, Track 2's into 
Track 20, and Track 3's into Track 25 regardless of the order in which you select tracks. Also, nothing 
gets pasted into Track 30 because there are more destination tracks than source tracks.

To copy and paste an entire mix
1. With the Edit Window active, choose Do>Select All Tracks.

2. Choose Windows>Mixer to open the Mixer Window.

3. With the Mixer Window active, choose Edit>Copy Faders.

4. In the Edit Window, select the Sequence into which you'd like to paste the fader values.

5. Click in the Ruler to set the insertion point.

6. Choose Do>Select All Tracks.

7. Choose Edit>Merge Selection.

Musicshop pastes the pan and volume fader values into every track at the specified insert point. 
When you play back the sequence, the fader values in the Mixer Window will jump to the new 
values when playback reaches the insertion point.



Activity Indicators (Mixer Window)

This indicator blinks whenever a track plays any MIDI data. This provides a quick way to see which 
tracks are playing at any given time.



Pan Faders (Mixer Window)

To adjust the stereo positioning of any track:

1. Press and hold the mouse on the pan fader.

2. In the small pop-up window, drag the cursor left or right to position the pan placement.

3. Release the mouse.

NOTE: You must use a stereo MIDI device in order to hear the Pan Fader's affect.



Volume Faders (Mixer Window)

To adjust the volume of any track, drag the fader up or down. Faders send MIDI volume messages 
(control #7) to your MIDI devices, unless you selected Vel in the Track Setup Window's 
Volume/Velocity Fader Control Column.



Mute Buttons (Mixer Window)

If you don't want to hear a particular track, click its Mute (M) button. To turn off muting, click the button 
again.



Solo Buttons (Mixer Window)

If you want to hear a particular track without hearing any of the others, click its Solo (S) button. To turn 
off soloing, click the button again.



Track Name (Mixer Window)

Displays the name of the track that you're currently editing with the mixer controls (the "active track.") 
Track names are provided by the Track Setup Window.



Patch Name (Mixer Window)

Shows the patch last chosen or recorded for the active track.



Fader Value (Mixer Window)

Shows the volume fader value for the active track.



Track Setup Window

Use the Track Setup Window to assign various track attributes that apply to all sequences in a 
Musicshop file. To open the Track Setup Window, choose Windows>Track Setup.

Click any part of the following illustration to learn about its function.



Track Color (Track Setup Window)

Click in this column to select a different display color for each track. Musicshop color codes tracks 
throughout the program, making it easy to distinguish between the different tracks.



Track Name Column (Track Setup Window)

Use this column to name the track. This name appears wherever Musicshop displays track names, 
such as the Mixer Window and the Edit Window. To name a track:

1. Click anywhere in the column.

2. When the cursor turns into an I-Beam, type the desired name, then press Enter or Return.

By default, Musicshop automatically names tracks based on the name of the MIDI device and channel 
assigned to it in the Output column.



Output Column (Track Setup Window)

Use this column to assign a MIDI playback device and MIDI channel to each track. Musicshop derives 
the list from your current OMS Studio Setup document.



Octave Shift Column (Track Setup Window)

Use this column to shift the playback octave of any track(s). This is useful when you want to quickly 
transpose an entire track up or down in octave increments.

NOTE: This feature transposes MIDI data on playback only. It does not modify the actual MIDI data 
contained within the track.



Volume/Velocity Fader Control Column (Track Setup Window)

Use this column to assign which MIDI component (volume or velocity) you want controlled by the 
faders in the Mixer Window. Switch between the two values by clicking in the field.

· Vol: If a track is set to Vol, then the corresponding Mixer Window fader uses MIDI volume data 
(MIDI control #7) to control the playback volume of your synthesizer Most modern MIDI devices 
respond to MIDI volume change messages, so you should use this value for most MIDI devices.

· Vel: If a track is set to Vel, then the corresponding Mixer Window fader uses MIDI velocity data to 
control the playback volume of your synthesizer. This is a far less accurate way to control playback 
volume, since velocities occur only at note-on and must be programmed within the device to control 
output volume. It's offered as an alternative for devices that don't support MIDI volume change 
(control #7) messages.



Insert Window

The Insert Window contains parameters that allow precise control over the duration and velocity of 
notes that you "draw" into a track using the Pencil Tool.

To open the Insert Window, double-click the Pencil Tool in the Edit Window.

Click any part of the following illustration to learn about its function.



Size Parameters (Insert Window)

Use the Size parameters to determine the note value you wish to insert into the track. The duration of 
the note is determined by both the Size parameters and the Duration parameters.

To select a note size, either:

· Select a note size from the Note Selector pop-up, or

· Enter the desired number of units directly into the units field (Musicshop has 480 units per quarter 
note).

If you enter a non-standard note size into the units field, Musichsop displays the closest note value 
and adds a "<" or ">" symbol beside it, indicating that the requested note size is a little less than or 
a little more than the note shown.

· Use keyboard equivalents to type-in a note size.

Tuplets
To define note sizes based on tuplets:

1. From the Note Selector pop-up, select the base value of the tuplet you wish to enter.

2. Check the Tuplet option.

3. Fill in the two tuplet fields to define the type of tuplet you're entering. For example, assume you 
selected a note size of an 8th note, and entered a tuplet value of "3 in the time of 2." This means 
that you want to insert three 8th notes in the time of two (an 8th note triplet).

4. Once you've defined the tuplet value, Musicshop automatically calculates the correct number of 
units, fills in the units field, and updates the note value displayed in the Note Selector pop-up.



Duration Parameters (Insert Window)

Use the Duration parameters to define the actual length of the note you wish to insert into the track. 
You have two choices:

· Percent

The duration is calculated using the setting in the % of Size field.

For example, if you set the Size parameter to an 8th note (240 units), and the duration is set to 
90%, then the actual duration of the note you insert will be 216 units since 90% of 240 = 216.

· Constant Gap

The duration is calculated by subtracting the units value in the Constant Gap field from the units 
value set in the Size parameters.

For example, if you set the Size parameter to an 8th note (240 units) and the Constant Gap to a 
32nd note (60 units), the resulting duration is dotted 16th note (180 units) because 240 - 60 = 180.

· Constant

The duration is set to the value entered in the corresponding field. When you select this mode, the 
Size parameters have no effect on the duration of the inserted note.



Velocity Parameters (Insert Window)

Musicshop enters notes drawn with the Pencil Tool using the Constant velocity you select in this 
section.

Use the field to enter the velocity value for the inserted note. All inserted notes will have this velocity 
until you change it.



Step Window

The Step Window contains parameters that allow precise control over the duration and velocity of 
notes that you step record from a MIDI controller.

To open the Step Window, click the Step Record button in the Edit Window.

Click any part of the following illustration to learn about its function.



Size Parameters (Step Window)

Use the Size parameters to determine the step size used when Step Recording. The step size is the 
amount of time the insertion point advances in the track each time you play a note.

To select a step size, either:

· Select a step size from the Note Selector pop-up, or

· Enter the desired number of units directly into the units field (Musicshop has 480 units per quarter 
note).

If you enter a non-standard step size into the units field, Musichsop displays the closest note value 
and adds a "<" or ">" symbol beside it, indicating that the requested step size is a little less than or 
a little more than the note shown.

· Use keyboard equivalents to type-in a step size.

Tuplets
To define step sizes based on tuplets:

1. From the Note Selector pop-up, select the base value of the tuplet you wish to enter.

2. Check the Tuplet option.

3. Fill in the two tuplet fields to define the type of tuplet you're entering. For example, assume you 
selected a step size of an 8th note, and entered a tuplet value of "3 in the time of 2." This means 
that you want the enter three 8th notes in the time of two (an 8th note triplet).

4. Once you've defined the tuplet value, Musicshop automatically calculates the correct number of 
units, fills in the units field, and updates the note value displayed in the Note Selector pop-up.



Duration Parameters (Step Window)

The Duration setting determines the actual length of a step recorded note (the amount of time between 
the note-on and note-off commands). The Duration selector has 4 modes that work in conjunction with 
the Size parameters to calculate the actual note length:

· Constant Sets the note duration to the length determined by the corresponding note selector.

If you enter a non-standard note duration into the units field, Musicshop displays the closest note 
value and adds a "<" or ">" symbol beside it, indicating that the requested duration size is a little 
less than or a little more than the note shown.

If the note selected in the Duration section is larger than the note selected in the Size section, the 
notes overlap each other. However, the Counter still advances the amount selected by the Size 
parameters.

· Constant Gap: Creates a fixed-length gap between the end of one note and the beginning of the 
next. The size of the gap is determined by the corresponding gap size selector and units field. The 
actual duration entered is determined by the formula: Duration = Size - Gap

· Percent: Calculates the duration by using the setting in the % of Size field to scale the setting 
specified by the Size parameters.

For example, if the step size is set to an 8th note (240 units) and the Duration is set to 75%, then 
the actual duration entered is 180 units (75% of 240 = 180).

· As Played: Records durations with respect to the current metronome setting for the sequence. The 
Counter still advances by the amount of time specified by the Size parameters, but the actual 
duration entered can be arbitrarily long.



Velocity Parameters (Step Window)

The Velocity setting determines how Musicshop creates velocity values for step-recorded notes. You 
have two options:

· Constant: Enter a velocity in the numeric field that appears beneath the word "Constant." 
Musicshop uses this value for all step-recorded notes regardless of the velocities at which you play 
them.

· As Played: This mode records notes using the velocity value at which you played it on your MIDI 
controller. This allows each note step-recorded note to vary in velocity and is useful if you wish to 
record parts with greater dynamics and feel.



Note Size Key Equivalents

type 1 to select a whole note

type 2 to select a half note

type 4 to select a quarter note

type 8 to select an 8th note

type 6 to select a 16th note

type 5 to select a 32nd note

type 3 to select a triplet value of the current note size

type . (period) to select a dotted note value

type + (plus) to add the next note value to the current note value

type - (minus) to subtract the next note value from the current note value

NOTE: Use the + key to create tied notes. For example, typing "1 + . 4" creates a whole note tied to a 
dotted quarter note.



Keyboard Controls

Type Tab to "click" the Record button

Type Space to "click" the Play button

Type Enter (Win) or Return (Mac) to "click" the Stop button

Type ; (semicolon) to "click" the Continue/Pause button

Type < to "click" the Skip Back button

Type > to "click" the Skip Ahead button

Type [ to set the punch-in point to the counter

Type ] to set the punch-out point to the counter

Type { to clear the punch-in point

Type } to clear the punch-out point

Type * (on keypad only) to select track and patch

Type = (on keypad only) to highlight the bar number in the counter

Type / (on keypad only) to enter punch mode and highlight punch-in point

Type arrow keys to move between fields

Type . (period) (on keypad only) to move to next field within the same parameter 



Punch Recording Tutorial

When set to punch record mode, Musicshop automatically starts recording when the punch-in point is 
reached and stops recording when the punch-out point is reached.

Punch recording is useful when you need to record a few bars in the middle of a sequence. You can 
start playing the sequence before the bars you want to record (playing along to get into the feel), but 
Musicshop will not record anything you play until your sequence reaches the punch-in point. This is 
like having a third hand to hit the Record button while you're busy playing.

Step 1: Set the desired punch-in and punch-out points
There are numerous ways to set and clear punch points. The following methods detail a couple of 
different ways to set the punch points:

Method 1

1. In the Edit Window's Ruler, press and hold the mouse at the desired punch-in point.

2. While holding down the mouse button, drag across the Ruler and release the mouse button at the 
desired punch-out point, creating a selection region.

3. Choose Do>Selection -> Punch Points

4. The Status Bar will indicate the chosen punch-in and punch-out points.

Method 2

1. In the Edit Window's Ruler, click at the desired punch-in point.

2. Type the [ key (left, square bracket). The Status Bar shows that you've set the punch-in point.

3. In the Ruler, click at the desired punch-out point.

4. Type the ] key (right, square bracket). The Status Bar shows that you've set the punch-out point 

Step 2: Record a track
1. Select the Setups>Punch option to check it.

2. Select Setups>Countoff then, at the far left of the Status Bar, enter the desired number of countoff 
measures. This is the number of measures that will play before you reach the punch-in point.

3. In the Edit Window, click the Record button (or hit the Tab key).

4. Musicshop begins to play and the Record button flashes to indicate that you are in punch recording 
mode but that you have not yet reached the punch-in point. Anything you play on your MIDI 
controller is not being recorded.

5. When Musicshop reaches the punch-in point, the Record button turns solid and anything you play 
on your MIDI controller is recorded.

6. When the punch out point is reached, Musicshop either stops playing (if Setups>Stop at 
Punchout is checked) or continues playing to the end of the sequence, but without recording any 
additional MIDI data (if Setups>Stop at Punchout is not checked).

7. If you want to stop recording somewhere in the middle of the punch regions, simply click the Stop 
button.



Real-Time Recording Tutorial

1. Select the desired Record Mode (Replace or Overdub).

2. Select the desired Start Mode (Wait for Note or Countoff). If you select Countoff mode, enter the 
desired number of countoff measures at the left-most section of the Status Bar.

3. Choose Setups>Metronome to determine whether or not you want the metronome to play and, if 
so, what sound to use for it.

4. Use the Track Bar to select which track you wish to record. If desired, use the Sequence selector to 
select a different sequence.

5. If desired, use the Patch Selector to send a MIDI program change message to your sound module. 

6. Click the Record button. If you selected Countoff mode, Musicshop plays for the specified number 
of measures before beginning to record. If you selected Wait for Note mode, Musicshop doesn't 
start recording until you hit a note on your MIDI controller or type the spacebar.

7. Play for as long as you want, then click the Stop button when you're finished.



Multichannel Recording

Use this method to record MIDI data arriving on multiple MIDI channels (such as recording MIDI guitar 
controllers).

1. Select the Setups>Multichannel Record option to check it. This causes Musicshop to route MIDI 
channel 1 to Track 1, MIDI channel 2 to Track 2, and so on.

2. Select a record mode and a start mode.

3. Click the Record button.

4. Play your MIDI controller(s).

5. Click the Stop button when you're finished.

6. Musicshop routes MIDI data arriving on any MIDI channel to the like-numbered track, allowing you 
to record on multiple tracks simultaneously.



Playing Sequences

1. From the Sequence selector, choose which sequence you wish to play back.

2. Click the Play button (or type the spacebar).

3. Musicshop plays every track in the sequence from start to finish.

4. If you want to stop playback in the middle, click the Stop button.

To play from the middle of a sequence
1. Click in the Edit Window's Ruler to set a start time.

2. Click the Cont button, or type ; (semicolon).

3. Musicshop plays from the selected start time.

To play multiple sequences
Use the Arrangement Window to string sequences together or to play multiple sequences 
simultaneously. Specifically:

· Creating an arrangement

· Inserting additional sequences into an arrangement

· Moving/copying/deleting sequences in an arrangement

· Playing multiple sequences simultaneously

 



File Menu

New

Open

Close Window

Save

Save As

Save a Copy As

Save as Setup

Export

Revert

Print Setup

Print Preview

Print

Exit



New (File Menu)

Creates and opens a new Musicshop file.

If a file is already open, and that file has unsaved changes, you'll be prompted to save or discard the 
changes before the new file is opened.

A new Musicshop file opens with the following characteristics:

· The Edit Window appears with the name "Untitled." 

· All sequences within the file are labeled "empty" except sequence A, which is    labeled "Untitled."

· Opening a new file has no effect on the state of the OMS Name Manager. The Name Setup created 
by OMS remains current.

· The information in the Track Setup Window is derived from the Setup file created with the 
File>Save as Setup command.



Open (File Menu)

Opens an existing Musicshop file. When you choose this command, a dialog box appears in which you 
select the file you wish to open. You can open both Musicshop files and standard MIDI files (format 0 
and format 1).

If a file is already open when you select a new Musicshop file to open, and if that file has unsaved 
changes, you'll be prompted to save or discard those changes before the selected file is opened.

If you open a MIDI file, it replaces the current sequence in the Edit Window, and all other sequences 
remain unchanged. If the MIDI file contains data for a channel to which no track is assigned, 
Musicshop reassigns an unused track to that channel. If there are no unused tracks, the file won't be 
opened. If the MIDI file contains too many tracks, they are merged together by MIDI channel. 
Musicshop informs you if any of these unusual circumstances arise.



Close Window (File Menu)

Closes the active window. If the Edit Window is active, choosing this command closes the Musicshop 
file and, if you have any unsaved changes, you'll be asked whether or not you want to save them.



Save (File Menu)

Saves the active Musicshop file to disk, overwriting the previously saved version of the file.

If the file has never before been saved, a standard file dialog box appears in which you name the file 
and select a location in which to save it.



Save As (File Menu)

Opens a standard file dialog box in which you name the file and select a location in which to save it.

If the file is untitled, a new name is required before the file can be saved. If the file has already been 
saved, the name appears in the dialog box. You can keep the same name (as long as the name is not 
duplicated within the same folder), or choose another name. The new name becomes the title in the 
Edit Window for the current Musicshop file.



Save a Copy As (File Menu)

Creates and saves a copy of the active Musicshop file, leaving the active file untouched. Choosing this 
command opens a standard file dialog box in which you name the copied file and select a location in 
which to save it.

Use this command to make a backup copy of the existing file while keeping the original file active. By 
using this command, you can experiment with different versions of a sequence while retaining your 
original version.



Save as Setup (File Menu)

Saves certain settings from the active file to the Setup file.

The Setup file stores various common settings that Musicshop uses as defaults when you create a 
new, untitled Musicshop file. Specifically, the Setup file stores:

· Track setup information from the Track Setup Window.

· Mix information from the Mixer Window.

Actual sequence information is not saved as part of the Setup file.

NOTE: The Setup file must reside in the same folder as the Musicshop application.



Export (File Menu)

Saves the sequence or arrangement as a standard MIDI file.

If the Edit Window is active, the current sequence is exported. If the Arrangement Window is active, 
the entire arrangement is exported.

To export a sequence:

1. Choose File>Export. A standard file dialog box appears with the addition of a Multitrack option.

2. Decide whether you want to check the Multitrack option or not Check it if you want to export a 
multitrack (Format 1) standard MIDI file. Un-check it if you want to export a single track (Format 0) 
standard MIDI file. In most cases, Multitrack is preferable because it preserves the track and 
channel information, but some older MIDI applications read only Format 0 files.

3. Name the file, select a location in which to save it, then click OK.



Revert (File Menu)

Discards any unsaved changes and re-opens the file in the state it was in last time you saved it.

Musicshop will give you one last chance to change your mind before it completes this action.



Print Setup/Page Setup (File Menu)

Opens the standard Print Setup dialog box for your printer (Page Setup on the Macintosh) Use the 
dialog box to define various printing option. See your printer documentation for more information.

NOTE: Whenever you change printers, you should choose this command to define your printing 
options for that printer.



Print Preview (File Menu)

Opens the Print Preview Window, which displays how your score will look on the printed page. Use 
this window to change basic page properties of the score and to add titles, comments, and composer 
credits to the score.

NOTE: The Print Preview command is active only when the Edit Window is in Notation View.

Click any part of the following illustration to learn about it.



Title Space (Print Preview Window)

Determines the amount of space between the top of the title text and the top of the first staff in the 
score. Switch between inches or centimeters by clicking the unit display (in or cm).



System Spacing (Print Preview Window)

Determines the amount of space between the bottom of one system and the top of the system below 
it. Switch between inches or centimeters by clicking the unit display (in or cm).



Staff Spacing (Print Preview Window)

Within a system, determines the amount of space between the bottom of one staff and the top of the 
staff below it. Switch between inches or centimeters by clicking the unit display (in or cm).



Staff Indentation (Print Preview Window)

Determines the distance between your printing margins and the left and right sides of each staff. 
Switch between inches or centimeters by clicking the unit display (in or cm).



Bars per Line (Print Preview Window)

Defines the number of measures contained in each system. If you ask Musicshop to create too many 
measures per system, note heads will collide in the printed score.



Systems per Page (Print Preview Window)

Displays the number of systems that Musicshop will print on each page. You cannot change this 
setting directly. It is determined by other factors, such as:

· How many tracks are contained in your sequence (and, hence, how many staves exist in each 
system).

· The System Spacing setting.

· The Staff Spacing setting.

· The Title Space setting.

· The margins setting defined for your printer.



Number of Pages (Print Preview Window)

Displays the total number of pages in your score. You cannot change this setting directly since it is 
determined by other parameters in this window and by the number of tracks in your sequence and how 
much data is contained in those tracks.



Page (Print Preview Window)

Shows the page number currently displayed in the Print Preview Window. Change the Page number to 
display a different page in the window.



Show Bar Numbers (Print Preview Window)

Check this option if you want Musicshop to print bar numbers above each measure in the score.



Barline thru System (Print Preview Window)

Check this option if you want Musicshop to draw a continuous barline through every staff in a system 
(as opposed to breaking the barline at each staff). In some cases, this can increase the legibility of 
your score.



Show Page Numbers (Print Preview Window)

Check this option if you want Musicshop to print page numbers in the lower right corner of each page.



Title Font (Print Preview Window)

Windows
Use this pop-up list to select which font to use for the Title, Comments, and Composer fields in your 
score.

Macintosh
This area displays the name of the font used for the Title, Comments, and Composer fields in your 
score. Use the Font menu in the Macintosh menu bar to select the desired font.



Text Fields (Print Preview Window)

These three text boxes appear only at the top of the left page.

· Title box: Use the top box to type the title of your song.

· Composer box: Use the lower right box to type the composer's name.

· Comments box: Use the lower left box to type any special instructions or comments concerning the 
song.

These text fields print using the font specified in the Title Font pop-up list (for Windows) or the Font 
menu (for Macintosh).



Score Preview (Print Preview Window)

Shows your score as it will look on the printed page.



Units of Measurement (Print Preview Window)

Switch between inches or centimeters by clicking the unit display (in or cm).



Print (File Menu)

Prints the document as it appears in the Print Preview Window.

The appearance of the printed page is also affected by the various options    in the Print Setup dialog 
box. See your printer documentation for more information.



Exit/Quit (File Menu)

Closes the active Musicshop file and exits the Musicshop application. On the Macintosh, this 
command is named Quit.

If the active file contained any unsaved changes, you will be prompted to either save or delete those 
changes.



Edit Menu

Undo/Redo

Cut Selection

Copy Selection

Paste Selection

Clear Selection

Merge Selection

Insert Clipboard

Repeat Paste

Insert Blank Time

Delete Selected Time

Move Events



Undo/Redo (Edit Menu)

Choose Undo to negate the last editing or recording function. The command affected is shown as part 
of the Undo menu title. For example: "Undo Transpose" or "Undo Legato."

After choosing Undo, the menu item becomes Redo. Use these two commands to switch back and 
forth between two edited versions (allowing you to compare them).

Keeping Both an Edited and an Unedited Track
Certain commands don't change the state of the file. For example, Edit>Copy does not disturb the last 
Undo command. Therefore, you can record over a track and decide to preserve both the new 
recording and the track you recorded over: To do so:

1. After recording over the original track, copy the newly recorded track by choosing Edit>Copy. This 
copies the new track to the Clipboard.

2. Choose Edit>Undo Record. This restores the original track data.

3. Paste the contents of the Clipboard into a new track by selecting a track, then choosing 
Edit>Paste. Both versions of the track are now available for comparison.



Cut (Edit Menu)

Copies the selected items in the active window to the Clipboard, then removes those items from the 
active window.

If the selection includes multiple tracks, the Clipboard preserves each track's data separately.

Cut performs the same action as if you chose Edit>Copy followed by Edit>Clear.

NOTE: Cut removes events in the selected area but doesn't remove the time occupied by those 
events. To remove any blank time left behind by cutting events, use the Edit>Delete Selected Time 
command.



Copy (Edit Menu)

Copies the selected items in the active window to the Clipboard and leaves those items unmodified.

If the selection includes multiple tracks, the Clipboard preserves each track's data separately.



Paste (Edit Menu)

Copies the contents from the Clipboard to the selected location in the active window, replacing that 
window's events with the Clipboard's.

Pasting Multiple Tracks
When you paste a selection that contains multiple tracks, you must enable at least that number of 
tracks in the Edit Window. For example, to paste two measures that were copied from tracks 2 and 4 
to tracks 5 and 8:

1. Shift-click Tracks 5 and 8 in the Edit Window to display them both.

2. In the Ruler, click at the desired start time to position the insertion point.

3. Choose Edit>Paste. Musicshop pastes Track 2 from the Clipboard to Track 5 in the Edit Window. 
Similarly, it pastes Track 5 from the Clipboard to Track 8 in the Edit Window.

If the Clipboard contains multiple tracks and there are not enough displayed tracks to receive the data, 
only the tracks that will fit are pasted. For example:

IF: data from Tracks 2, 3, and 4 are copied to the Clipboard

AND: Tracks 5 and 6 are the only tracks displayed in the Edit Window

THEN: only the data from Tracks 2 and 3 are pasted to Tracks 5 and 6 when you choose 
Edit>Paste.



Clear (Edit Menu)

Removes the selected items from the active window without copying them to the Clipboard. Clear does 
not affect the timing of the track.

If the selection includes multiple tracks, Clear deletes data on any displayed tracks in the selection 
region.

NOTE: Clear removes events in the selected area but doesn't remove the time occupied by those 
events. To remove any blank time left behind by clearing events, use the   Edit>Delete Selected Time   
command.



Merge (Edit Menu)

Combines the events in the Clipboard with the events after the insertion point. This command does not 
change the timing of the track.



Insert Clipboard (Edit Menu)

Pastes the time and events from the Clipboard at the insertion point. Events after the inserted time are 
moved by the amount of time in the Clipboard. The track length is also increased by the amount of 
time in the Clipboard.



Repeat Paste (Edit Menu)

Opens the Repeat Paste dialog box, in which you decide how many times to repeat the selection and 
what to do with any data currently in the file. Click any part of the following illustration to learn about it.

The time copied to the Clipboard, set by the Start and End Edit points, determines how far apart each 
copy is spaced.



Repeat Length Options (Repeat Paste Dialog Box)

Use this section to specify either:

· the exact number of times to paste the Clipboard (the Repeat field), or

· the amount of time the new data should occupy (the to fill fields).

By selecting a region of time in the Edit Window before choosing Edit>Repeat Paste, Musicshop 
computes the number of repetitions necessary to fill the time. Setting a value in the Repeat field 
affects the to fill fields (and vice versa) based on the amount of time in the Clipboard.

If the selected amount of time is not an exact multiple of the time in the Clipboard, the Clipboard is 
pasted the selected number of times and then up to the end of the specified time. For example: 

IF: the Clipboard contains 1 measure of 8 eighth notes

AND: the Repeat Paste dialog box is set to 2 repeats in the space of 2/2/0 in 4/4,

THEN the paste includes 2 repetitions of the Clipboard plus the first 4 eighth notes.

The time signature field derives its value from the time signature in the current sequence. Changing 
the meter automatically adjusts the Repeat and to fill fields. For example:

IF: the Clipboard contains 8 eighth notes copied in 4/4 time

AND: The Repeat Paste dialog is set to 2 repeats in 3/4 time,

THEN: The to fill field automatically updates to 2/2/0 to accommodate 2 measures of 4/4 time. 
Each measure of 3/4 has 6 eighth notes. The additional 2 beats contain the 4 extra notes.

Unless you are pasting to a sequence with a different time signature, you'll seldom have to change the 
time signature field.



Repeat Paste Options (Repeat Paste Dialog)

Use this section to determine what to do with any data currently in the paste region of the active file.

Paste over track: data from the Clipboard replaces data in the sequence for the duration of the paste 
region.

Merge with track: data from the Clipboard merges with data in the sequence for the duration of the 
paste region.

Insert into track: Musicshop shifts all existing sequence data later by the duration of the paste region. 
It then pastes the Clipboard data into the new time region, effectively lengthening you sequence by the 
duration of the paste region.



Insert Blank Time (Edit Menu)

Inserts a specified region of time at the Start Edit point. This command is useful if you need to insert 
some extra time into a sequence (such as to add a bridge, lengthen a solo, or create an introduction).

NOTE: This command is available only when you've selected a region of time in the Edit Window.

To insert blank time:

1. Press and Hold the mouse button in the Edit Window's Ruler at the desired start time.

2. Drag across the Ruler and release the mouse at the desired end time.

3. The amount of time occupied by this region will equal the amount of time you insert.

4. Choose Edit>Insert Blank Time.

Musicshop inserts blank time equal to the selected time region beginning at the Start Edit point. All 
events occurring both within and after the selected time region are moved later by the amount of 
inserted time,



Delete Selected Time (Edit Menu)

Deletes all MIDI events occurring in the selected time range and moves all events occurring after the 
selected range earlier by that amount of time. This shortens your sequence by a time equal to the 
selected time range.

This command is available only when there is a time range selection in the Edit Window.



Move Events (Edit Menu)

Opens the Move Events dialog box. The appearance of the dialog box changes slightly depending on 
the options you select.

Earlier by / Later by
Select one of these radio buttons to move the selected events either earlier in time or later in time. 
When you select one of these options, use the Bar, Beats, Units, and Time Signature fields to 
determine how much earlier or later to shift the events

The Time Signature field initially displays the sequence's current time signature and imposes the 
correct range on the Beats and Units fields. For example:

· In 4/4 time there are 4 beats each containing 480 units.

· In 3/4 time, there are 3 beats each containing 480 units.

· In 6/8 time, there are 6 beats each containing 240 units.

To start at
Select this radio button to move the selected events to a specified start time. When you select this 
option, use the Bar, Beats, and Units fields to specify the time at which you want the selected events 
to begin.

The Time Signature field does not appear when you select the To start at option.



Do Menu

Quantize Selection

Quantize Durations

Reassign

Play from Selection

Play Selection

Jump to Selection

Selection -> Punch Points

Select All

Select All Tracks

Zoom to Fit



Quantize Selection (Do Menu)

Quantizes the selected notes by moving their boundaries to the nearest value specified in the 
Quantize Value pop-up list.

If Do>Quantize Durations is checked the durations are also quantized.

NOTE: If you don't like the effect of your quantizing operation, you may choose Edit>Undo Quantize 
to restore the original performance.



Quantize Durations (Do Menu)

Quantizes the duration of the selected notes by rounding each note's duration to the nearest multiple 
of the note value you select in the Quantize Value pop-up list.

Use this command to make a legato performance more staccato, or vice versa.



Reassign (Do Menu)

Opens a dialog box in which you reassign one type of MIDI control event to another.

This has numerous uses. For example, assume you have a sequence that contains aftertouch data, 
but your synthesizer doesn't respond to aftertouchyou could simply reassign aftertouch to a MIDI 
control that your synth does respond to (such as Mod Wheel), then program your synthesizer to 
respond to the Mod Wheel data appropriately.

To Reassign events:

1. In the Strip Chart, select the control events you wish to reassign.

2. Choose Do>Reassign. The Reassign dialog box opens.

3. Use the top row of pop-up lists to select which MIDI controls you want to reassign.

4. Use the bottom row of pop-up lists to select which MIDI controls you want the data mapped to.

The pop-up lists on the left side of the dialog box select between Pitch Bend, After Touch and 
Controller types. The pop-up lists on the right of the dialog box (available only if the left pop-up list 
has Controller selected), display a complete list of all MIDI controls.



Play from Selection (Do Menu)

Plays the current sequence from the beginning of the selection (or the Insertion point) to the end of the 
sequence.



Play Selection (Do Menu)

Plays the selected region in the current sequence and then stops. If there is no selected region, Play 
Selection behaves like Play from Selection and plays from the Insertion point to the end of the 
sequence.



Jump To Selection (Do Menu)

Causes the Edit Window to display the selected region. This is useful if you made a selection and then 
scrolled the display to inspect another section of music. Choosing Jump to Selection quickly returns 
the window to the location of the selection. The zoom level does not change.



Selection -> Punch Points (Do Menu)

Uses the selected region's Start and End Edit points to calculate punch-in and punch-out points, 
respectively. If there is no selection, both the punch-in and punch-out points are set to same location 
as the Insertion point (determined by clicking the the Edit Area's Ruler).

Shortcuts for setting Punch Points
· Set a punch-in point by typing the left square bracket key ([).

· Set a punch-out point by typing the right square bracket key (]).

Shortcuts for clearing Punch Points
· Clear the punch-in point by typing the left curly bracket key ({).

· Clear the punch-out point by typing the right curly bracket key (}).



Select All (Do Menu)

Selects all data in the active window. The behavior differs depending on which window is active.

· Edit Window: Selects all MIDI data (sequence and controller) for all displayed tracks. 

· Mixer Window: Selects all faders.

· Arrangement Window: Selects all sequence blocks in the Arrangement.



Select All Tracks (Do Menu)

Selects all tracks in the current sequence and displays them in the Edit Area of the Edit Window.



Zoom to Fit (Do Menu)

Zooms the display to fit the longest track currently displayed in the Edit Window. If the Arrangement 
Window is active, Zoom to Fit zooms all sequence blocks to fit the screen.

In Notation View, there is a limit to how much data can be presented before the notes start to collide 
and become indistinguishable from one another. In this case, Zoom to Fit does not display the entire 
track but zooms in to the maximum level.



Setups Menu

Replace

Punch

Overdub

Wait for Note

Countoff

Loop Play/Record

Multichannel Record

Countoff in Play

Stop at Punch Out

Metronome

Preferences



Replace, Punch, and Overdub (Setups Menu)

These record mode options function as toggles. Select any one option to enable it, and automatically 
disable one of the other options. Enabled options are checked; disabled options are not.

· Replace: Places Musicshop in Replace record mode. In this mode, recording commences from the 
beginning of the track. All track data is replaced even if the recording stops prior to reaching later 
track data.

· Punch: Places Musicshop in Punch record mode. In this mode, recording replaces existing track 
data within a selected region. Recording is automatically enabled at the Punch In point and 
disabled at the Punch Out point.

· Overdub: Places Musicshop in Overdub mode. In this mode, recorded material is merged with 
existing track data. Recording commences from the beginning of the track unless there are punch 
points set, in which case the recording region is determined by the punch-in and punch-out points.



Wait for Note and Countoff (Setups Menu)

These countoff options function as toggles. Select an option to enable it and automatically disable the 
other option. Enabled options are checked; disabled options are not.

Wait for Note
In this mode, after you press the Record button, Musicshop doesn't begin to record until either:

· you send it a MIDI note, or

· you press the Play button.

This is a good mode to use when you don't want Musicshop to record until you're ready. Musicshop 
provides visual feedback of Wait for Note mode, by showing a note icon at the far left of the Status Bar.

Countoff
In this mode, after you press the Record button, Musicshop begins recording after the number of 
Countoff Bars specified in the Status Bar.

This is a good method if you need a couple of bars to get into the rhythm and feel of a piece before 
you begin to record.



Visual Feedback of Wait for Note and Countoff Modes

Musicshop provides visual feedback of Wait for Note mode and Countoff mode. In countoff mode, 
Musicshop lets you define the number of bars to play prior to commencing recording.



Loop Play/Record (Setups Menu)

Enables Loop Recording but does not initiate the recording process until the Record button is clicked. 
The Record button changes to show that Loop recording is active:

Loop mode cannot be used with external sync. Therefore, if MIDI>External Sync is selected when you 
select Loop Play/Record, an Alert informs you that Sync has been set to Internal. If Loop 
Play/Record is selected when you select MIDI>External Sync, an Alert informs you that Loop 
Play/Record has been turned off.

If there is no track data in a sequence, the first attempt to Loop record opens the Record Loop dialog 
box requesting that you set a loop length.



Loop Recording

Loop recording lets you infinitely loop a few bars of a sequence, adding new recordings to it with each 
pass. In loop record mode, you can:

· record something, then

· listen to it playback, then

· save it or delete it, then

· record more information merged on top of what you've already recorded.

all without ever having    to start or stop playback.

To Loop Record
1. In the Edit Window, set the desired loop length in the Track Length Field.

2. Check the Setups>Loop Play/Record option. Musicshop automatically enters repeat signs in the 
Track Length Field and on the Record button.

3. Click the Record button and begin playing your MIDI keyboard whenever you like (or after the 
requested number of countoff bars).

4. If you like what you've record so far, hit the Enter key to save your changes. Musicshop continue 
looping the sequence.

5. If you don't like what you've recorded, hit the Delete key to remove all MIDI data you've recorded 
since you last typed the Enter key.

6. When you're finished, click the Stop button.

7. Select Setups>Loop Play/Record to turn off loop record mode.



Multichannel Record (Setups Menu)

Enables Multichannel Record mode. In this mode, Musicshop "listens" to all MIDI channels and 
automatically routes each incoming MIDI channel to the like-numbered track. That is:

· MIDI Channel 1 is recorded on Track 1

· MIDI Channel 2 is recorded on Track 2

· MIDI Channel 3 is recorded on Track 3, and so on

Multichannel recording is an excellent method of recording MIDI devices that transmit on several 
channels simultaneously. Since each channel is automatically recorded into a separate track, the 
multitimbral voicing used during the recording is easily re-created during playback.

For example, assume you're playing a "split" keyboard controller that's transmitting your left-hand 
performance on Channel 2 and your right-hand performance on Channel 3. If you're in Multichannel 
Record mode, then Musicshop records the data into Tracks 2 and 3, regardless of which track is the 
current track.



Countoff in Play (Setups Menu)

Enable this option (check it) if, after you press the Play button, you want Musicshop to play the number 
of Countoff Bars specified in the left part of the Status Bar before actual playback begins.



Stop at Punch Out (Setups Menu)

Enable this option (check it) if you want Musicshop to stop recording and playback at the Punch Out 
point.

NOTE: This option works only if Musicshop is in Punch mode or Overdub mode.

If this option is disabled (unchecked), and you're in either Punch mode or Overdub mode, then 
recording stops at the Punch Out point but playback continues to the end of the sequence.



Metronome (Setups Menu)

Opens the Metronome dialog box, in which you assign all of Musicshop's various metronome options. 
Click any item in the following illustration to learn its function:



Internal Click (Metronome Dialog)

Click this radio button to use your PC or Macintosh to provide the metronome's click sound.



MIDI Note (Metronome Dialog)

Click this radio button to use a MIDI note to provide the metronome's sound.

Using a MIDI note provides more flexibility for controlling the sound and volume since you can select a 
different MIDI device, MIDI note, velocity, and duration for both the accented and unaccented MIDI 
notes.



Channel (Metronome Dialog)

Use these pop-up lists to select the MIDI device to use for both the accented and unaccented 
metronome sounds. The pop-up defaults to the device on channel 10 because it's the standard MIDI 
drum channel. Many devices automatically play General MIDI drum patches on channel 10.



Note (Metronome Dialog)

Use these pop-up lists to select which MIDI note to use as a metronome sound for both the accented 
and unaccented sounds. If the device chosen in the Channels column is a drum patch and it uses 
General MIDI names (as defined by the Name Manager), the Note pop-up lists show General MIDI 
note names (such as "Side Stick" or "snare") instead of generic note numbers.



Velocity (Metronome Dialog)

Use these fields to set the MIDI note velocity for both the accented and unaccented beats.



Duration (Metronome Dialog)

Use these fields to set the MIDI note duration for both the accented and unaccented beats. This 
setting is relatively unimportant for drum sounds.



Click in Play (Metronome Dialog)

Check this option if you want to hear the metronome while the sequence plays back.



Click in Record (Metronome Dialog)

Check this option if you want to hear the metronome while the sequence is recording.



Preferences (Setups Menu)

Opens the Preferences dialog box. Click any element in the following illustration to learn about its 
function.



Auto Scroll (Preferences Dialog)

If this option is enabled (checked), the Edit and Arrangement windows scroll automatically during 
playback when notes reach the end of the screen. If Musicshop is playing an arrangement, the Edit 
Window always shows the sequence currently playing in the Arrangement Window.



Audible Feedback (Preferences Dialog)

If this option is enabled (checked), clicking a note in the Edit Window sends the MIDI note messages 
to the sound module, causing the note to be audible.



Show Bouncing Ball (Preferences Dialog)

If this option is enabled (checked), Musicshop displays a bouncing the ball during playback, which 
indicates the rhythm of the sequence and the playback position within the sequence.



Show Vertical Line (Preferences Dialog)

If this option is enabled (checked), Musicshop displays a vertical line during playback, which indicates 
the playback position within the sequence.



Show Piano Keyboard (Preferences Dialog)

If this option is enabled (checked), the left edge of the Edit Window displays a miniature piano 
keyboard.

If this option is disabled (unchecked), the left edge of the Edit Window displays note names only.



Record Aftertouch (Preferences Dialog)

If this option is enabled (checked), Musicshop records any aftertouch data generated by your MIDI 
controller.

NOTE: If you're using a patch that's programmed to support aftertouch, it can add a lot of expression 
to a MIDI performance. However, aftertouch data is very dense and, as such, uses a very large portion 
of your MIDI bandwidth. Therefore, you should turn this option off unless you know you need to 
capture the aftertouch nuances of a specific performance.



Thru in Background (Preferences Dialog)

If this option is enabled (checked), then Musicshop continues to receive MIDI events from your MIDI 
controller(s) and send them to you MIDI sound modules even though Musicshop is not the active 
application.



Middle C = (Preferences Dialog)

This pop-up list contains two options that allow you to select how Musicshop names "Middle C" in all 
Edit Windows.

· C3: Middle C is given the name "C3," which is the convention of some MIDI manufacturers 
(including Yamaha).

· C4: Middle C is given the name "C4," which is the standard naming convention as supported by the 
MIDI specification.



Favorite Controls (Preferences Dialog)

These pop-up lists let you specify the eight MIDI controls that you use most often. These eight controls 
are then displayed in any pop-up list of controls within Musicshop (such as in the Strip Chart).



Colors (Preferences Dialog)

This button opens a standard Colors dialog box in which you define the color palette used by 
Musicshop's Track Setup Window (which allows you to assign a different color to each MIDI track).



MIDI Menu

Default Track Setup

Sync Options

External Sync

Send Sync

OMS MIDI Setup

Enable Input Devices

Auto Remappings

Undefined Channels

Keyboard Thru

Track Shortcuts

Turn off Stuck Notes



Default Track Setup (MIDI Menu)

Opens the Default Track Setup dialog box. Use this dialog box to create a simple track setup that:

· assigns tracks 1-16 to playback on MIDI channels 1-16 of a single MIDI device.

· assigns tracks 17-32 to playback on MIDI channels 1-16 of the same (or a different) MIDI device.

Click any part of the following illustration to learn about it

This is an easy way to quickly configure your track setup by stating the MIDI device(s) you'd like to 
refer to in your Musicshop file. You can create a more complex setup using the Track Setup Window.



Device Selector (Default Track Setup)

Use these pop-up lists to select which MIDI device you want to use for playing tracks 1-16 and for 
playing tracks 17-32. The pop-up lists contain all the MIDI devices (virtual or external) contained in 
your Current Studio Setup document.

To select an external MIDI device not contained in your current Studio Setup document, click the Edit 
button.



Edit Button (Default Track Setup)

Click the Edit button to select MIDI devices that are not contained in your current Studio Setup 
document.

NOTE: The Edit button is disabled if you select a virtual device from the Default Track Setup dialog's 
Device selector:

Clicking the Edit button opens the Manufacturer and Model dialog box.

To use this dialog box:

1. Select the MIDI device's manufacturer from the left list, then select the desired model from the right 
list.

2. Click OK.

IMPORTANT: If you select a MIDI device that's not in your current Studio Setup document, Musicshop 
will automatically modify your current Studio Setup document to include this device, This affects every 
other Musicshop file since all OMS-compatible applications get their knowledge of your MIDI studio 
from the current Studio Setup document. Opcode recommends modifying your Studio Setup 
documents directly using the OMS Setup application.



Device Icon (Default Track Setup)

Displays the MIDI device icon assigned to the currently selected device. You can edit this device icon 
only with your OMS Studio Setup application.



Sync Options (MIDI Menu)

Opens the Sync Options dialog box. Click any item in the following illustration to learn how to use it.

Musicshop can send and/or receive MIDI Beat Clock synchronization to/from an external MIDI device 
or an internal, virtual device.

NOTE: Musicshop does not synchronize to SMPTE, MIDI Time Code, or Direct Time Lock. Use Vision, 
Opcode's professional sequencer, if you require these types of synchronization options.



To Receive Sync

1. Choose MIDI>Sync Options to open the Sync Options dialog box.

2. In the Sync Options dialog box, select the Receive Sync checkbox.

3. Select the Receive Sync device from the pop-up list at the top of the dialog box. The pop-up list 
derives its options from the current OMS Studio Setup document.

You can receive sync signals only from devices that you configure as Sync devices in your Studio 
Setup document.



To Send Sync

1. Choose MIDI>Sync Options to open the Sync Options dialog box.

2. In the Sync Options dialog box, select the Send Sync To checkbox.

3. Check the boxes next to any MIDI device or virtual device to which you wish to send the sync 
signal. Musicshop derives this device list from your current OMS Studio Setup document.

You can send sync signals only to devices that you configure as Sync devices in your Studio Setup 
document.



To Configure a Device for Synchronization

Musicshop can send and/or receive synchronization only from MIDI devices that are configured as 
sync devices in the current OMS Studio Setup document.

To configure a MIDI device as a sync device:

1. Choose MIDI>OMS MIDI Setup. The OMS Setup application launches, and the current OMS 
Studio Setup document appears.

2. Double click the icon of the MIDI device that you'd like to configure for synchronization.

3. In the resulting MIDI Device Info dialog box, select the desired Send and Receive synchronization 
options (Musicshop responds only to MIDI Beat Clock).

MIDI devices configured as sync devices appear in Musicshop's Sync Options dialog box.



External Sync (MIDI Menu)

When this option is enabled (checked), Musicshop synchronizes with the device selected in the 
Receive Sync section of the Sync Options dialog box. 

To play or record while synchronized to an external device:

1. Click the Record or Play button.

2. Start the external device. Musicshop recognizes Song Pointer messages and starts at the proper 
point in time to synchronize with the external device.

3. Stopping the external device also stops Musicshop.

NOTE: Musicshop does not synchronize to SMPTE, MIDI Time Code, or Direct Time Lock. Use Vision, 
Opcode's professional sequencer, if you require these types of synchronization options.



Send Sync (MIDI Menu)

When this option is enabled (checked), Musicshop sends synchronization information (MIDI Beat 
Clock) to the devices selected in the Send Sync To section of the Sync Options dialog box, causing 
those devices to slave to Musicshop.



OMS MIDI Setup (MIDI Menu)

For Windows
Launches the OMS Setup application and opens the current OMS Studio Setup document.

For Macintosh
Opens the OMS MIDI Setup dialog box, in which you specify which serial port(s) your MIDI interface is 
connected to, and whether you want to run MIDI in the background.

You can create a new Studio Setup document by clicking New Easy Setup, or you can edit your 
existing Studio Setup document by clicking Edit Custom Setup.



Enable Input Devices (MIDI Menu)

Opens the Enable Input Devices dialog box, in which you select which MIDI devices and virtual 
devices you want Musicshop to "listen to."

If a device is not selected in this dialog box, then its input is ignored by Musicshop.

Musicshop derives the list from your current OMS Studio Setup document. By default, Musicshop 
selects the devices that you've defined as MIDI controllers in your Studio Setup document.



Auto Remappings (MIDI Menu)

Opens the Auto Remappings dialog box, in which you remap a file's unknown MIDI devices and 
channels to the MIDI devices/channels contained in your current OMS Studio Setup document.

The left side of the dialog box shows (in italics) all the unknown MIDI devices and channels referenced 
by Musicshop.

Use the pop-up lists on the right side to select the MIDI device and channel to which you want to map 
the unknown device/channel.

To delete a remapping, select it and click Remove Line.

About Auto Remapping
Musicshop saves the contents of the Auto Remappings dialog box as part of your OMS Studio Setup 
document. Therefore, whenever you open a file containing undefined MIDI devices and channels, 
Musicshop examines your current Studio Setup document to see if it already contains the necessary 
auto remappings.

· If it does: Musicshop automatically remaps the undefined devices as defined by this dialog box 
without prompting you for further remappings.

· If it does not: Musicshop requests that you manually remap undefined MIDI devices using the 
Undefined Channels dialog box.

Practical Example
Auto remapping is useful if, for example, you make a permanent modification to your MIDI studio. For 
example, assume you trade-in an old synthesizer for a new one. Your old Musicshop files probably 
contain numerous tracks referencing the synthesizer you no longer own. Use the Auto Remappings 
dialog box, to tell Musicshop that you always want it to automatically remap any tracks that reference 
your old synthesizer to your new synthesizer. By using auto remapping, you won't have to manually 
remap any of your old Musicshop files.



Undefined Channels (MIDI Menu)

Opens the Undefined Channels dialog box, in which you remap a file's undefined MIDI devices and 
channels to the MIDI devices/channels contained in your current OMS Studio Setup document.

The left side of the dialog box shows (in italics) all the undefined MIDI devices and channels 
referenced by the Musicshop file. Any tracks assigned to these devices must be remapped before 
you'll be able to hear them.

Use the pop-up lists on the right side to select the MIDI device and channel to which you want to map 
the undefined device.

The dialog box contains three additional options:

· Remap all matching channels: When enabled (checked), all remappings are automatically 
applied to each line with the same device. This saves you from individually remapping each 
channel in a device.

· Remember remappings to reapply later: When enabled (checked), Musicshop saves the 
remappings defined here, and automatically applies them when it encounters the same undefined 
channels in future documents. This information is automatically saved in your Studio Setup 
document. You can edit these remappings in the Auto Remappings dialog box.

· Auto-open this dialog when needed: When enabled (checked), this dialog box appears 
whenever Musicshop encounters a file with undefined channels.

Why You Might Have Undefined Channels
Remapping is necessary if, for example, you open a file created in a different MIDI studio. In most 
instances, this file will reference MIDI devices and channels not used in your own studio. Because of 
this, you need to specify how to remap the undefined MIDI devices and channels to those used in your 
own MIDI studio.



Keyboard Thru (MIDI Menu)

If this option is selected (checked), then Musicshop sends all MIDI events it receives to the device and 
channel assigned to the current track.

The purpose of Keyboard Thru is to maintain a consistent correlation between the sounds made by 
your MIDI controller and the current track.

NOTE: If you're using Keyboard Thru with a synthesizer keyboard, its best to turn OFF its Local 
Control mode. This prevents the keyboard from triggering its own internal sounds. See your 
synthesizer manual to learn how to turn its Local Control mode off.

If Keyboard Thru is not selected (un-checked), Musicshop does not route the MIDI input from your 
MIDI controller to a MIDI device.



Track Shortcuts (MIDI Menu)

Opens a submenu with which you can quickly select a the current Musicshop track. The current track 
is the track on which Musicshop records.

Selecting a Track Shortcut is the same as clicking to the left of a track number in the Track Bar.



Turn Off Stuck Notes (MIDI Menu)

Silences any "stuck" notes by sending a MIDI Note Off message for all 128 notes to all MIDI devices. It 
also turns off all sustain pedals and centers pitch bend values. It takes a few seconds for this 
command to complete its task.



Windows Menu

Edit

Arrangement

Mixer

Track Setup

Names



Name Manager

The Name Manager is an element of OMS. Use it to organize the names of all the patches in your 
MIDI devices and provide those names to your compatible applications. Name Manager components 
include:

· A Names Window, with which you subscribe to various patch name documents. The Names 
Window contains its own Names Menu.

· A Patch Name Editor, with which you edit or create custom patch name documents. The Patch 
Name Editor contains its own Patches Menu .

· A Note Name Editor and a Control Name Editor, which are accessed from the Patch Name Editor.

· A Name Browser, with which you select how to display patch names in your application. The Name 
Browser contains its own Names Menu.



Names Window

The Names Window is actually a part of OMS, which, together with some other windows and menu 
items, is known as the Name Manager. Use the Names Window to subscribe to various patch name 
documents.

1. To open the Names Window, choose Windows>Names.

Click any part of the following illustration to learn about its function.



Device Column

Shows the name of each MIDI device contained in your current OMS Studio Setup document. You 
cannot edit the contents of this column. Its contents change whenever the current Studio Setup 
document changes.

Devices stored in a Name Setup, but not defined in the current Studio Setup appear in italics.



Patch Name Document Column

This column shows the patch name document to which each MIDI device subscribes. To subscribe to 
a patch name document:

1. Click in the Patch Name Document column next to a MIDI device.

2. Select Names>Subscribe.

3. In the resulting dialog box, locate the desired patch name document, then click OK.

NOTE: In Windows, this dialog box is configured to show .ONM files (typed-in patch name 
documents) and .BND files (Galaxy Bundles).

This column contains a couple of additional indicators. Specifically:

· A small "x" appears before the name of every current patch name document.

· A patch name document is italicized if the Name Manager can't locate the document.



Device Mode and MIDI Channel Columns

The Channel and Device Mode functions are interrelated and are described here together.

If a device supports multiple device modes, then the Device Mode column contains a pop-up menu 
listing all the possible modes.

Since each MIDI channel can access a different device mode, the Channel column (Ch) displays 
which MIDI channels access which device modes.

You can view every enabled MIDI channel or just a summary of all MIDI channels by clicking the 
desired device's selector icon, then choosing Names>Show Channels.

· If Show Channels is on (checked), the Names Window displays a separate row for every MIDI 
channel in that device (as assigned in the OMS Studio Setup document). You can then select a 
device mode for each MIDI channel.

· If Show Channels is off (unchecked), the Names Window displays a single row for that MIDI 
device and the Ch column says all. Changing the device mode affects all channels simultaneously. 
If Show Channels is off and different MIDI channels use different device modes, then the Device 
Mode column says various, indicating more than one device mode is active for this device.



Name Setup Control

Since the OMS Name Manager only references one Name Setup at a time, changes made to the 
Name Setup in different OMS-compatible applications can affect one another. Use the Name Setup 
control to determine what happens when changes are made to the Name Setup. Specifically:

· Always use current patches: Making patch name documents current in another application 
changes the Name Setup in the active application.

· Keep using these patches: This "locks in" the current Name Setup for the active application. 
Subscriptions made by the active application can't be changed by accessing the Name Manager 
and modifying subscriptions in another OMS-compatible application.

This setting is not remembered between sessions. Whenever you restart the current application, the 
Name Setup control is reset to Always use current patches.



Names Menu (Names Window)

For Windows, the Names Window contains its own Names Menu. The Macintosh version adds a 
Names Menu to the Menu bar. This menu contains the following commands:

Subscribe

Use Factory/General MIDI Names

Copy Subscription

Paste Subscription

Clear Subscription

Make Current

Use Current Instead

New Patch Document

View/Edit Patch Names

Tell Patch Provider

Show Channels



Subscribe (Names Menu)

Assigns a patch name document to which all selected devices are subscribed.



Use Factory/General MIDI Names (Names Menu)

Causes the selected device to subscribe to a factory patch name document contained in the Factory 
Names folder (For Windows users, this is the FAC_NAM folder located in your Windows directory).

If you select a General MIDI device in the Names Window, choose this command to subscribe to the 
General MIDI patch name document located in the Factory Names folder.

Also, Opcode provides numerous factory patch name documents for various MIDI devices. If you 
select one of these supported devices in the Names Window, and if it's loaded with the factory default 
sounds, choose this command to subscribe to the device's factory patch name document located the 
Factory Names folder.

If the selected device doesn't have an associated factory name file, then choosing this command 
subscribes the device to General MIDI patch names.



Copy Subscription (Names Menu)

Copies the subscription for the selected device(s) to the Clipboard.



Paste Subscription (Names Menu)

Pastes subscriptions from the Clipboard to the selected device(s). Any previous subscription is 
replaced and the new patch name document becomes current.



Clear Subscription (Names Menu)

Removes the subscription information from the selected device.



Make Current (Names Menu)

Makes the selected patch name document current and, if possible, sends the contents of that patch 
bank to your MIDI device. This command opens the Make Current dialog box.

If the Send the patches option is available and checked, the Name Manager attempts to transmit the 
patches to the device when you click the Make Current button. The application that created the patch 
name document must be capable of this operation. Typed-In patch name documents do not have this 
ability, so the Send the patches option is not available.

Click Don't Make Current to retain the previous subscription (this basically acts like a Cancel button).



Use Current Instead (Names Menu)

Replaces the selected device(s)' non-current subscriptions with subscriptions to the current patch 
name document(s). 



New Patch Document (Names Menu)

Creates a blank, untitled patch name document for the selected device.



View/Edit Patch Names (Names Menu)

Opens the Patch Name Editor for the selected device. This is the same as double-clicking in a device's 
Patch Name Document column.



Tell Patch Provider (Names Menu)

This menu item contains a sub-menu listing commands that can control your OMS-compatible Patch 
Name Provider:

· Open Patch Document: opens the corresponding patch name document in your Patch Name 
Provider's native format.

· Find Patch: lets you find a patch within your Patch Name Provider's documents.

· Send Patches to Device: causes your Patch Name Provider to send the bundled patch data to the 
selected MIDI device.

The commands will not work if your OMS-compatible Patch Name Provider is not capable of 
understanding the messages, or if you don't have an OMS-compatible Patch Name Provider.



Show Channels (Names Menu)

Controls whether the Names Window displays either:

· one row per MIDI channel per device, or

· a single row representing all MIDI channels for the selected device.

If you wish to use the Device Mode column to assign different device modes to different MIDI 
channels, this option must be enabled (checked).



Patch Name Editor

The Patch Name Editor is actually a part of OMS, which, together with some other windows and menu 
items, is known as the Name Manager. Use the Patch Name Editor to display or edit existing patch 
name documents, or to create new ones.

To open the Patch Name Editor:

1. Open the Names Window (by choosing Windows>Names).

2. In the Names Window, double-click in the Patch Name Document column next to the device 
whose names you wish to edit. (Alternately, you could select a patch name document in the Patch 
Name Document column, then choose Names>View/Edit Patch Names.)

The Patch Name Editor opens. Click any part of the following illustration to learn about its function.



MIDI Program Number Column

This column displays the actual MIDI Program numbers that OMS sends to your MIDI device when 
you select the corresponding patch name. If you're using Bank Select Messages, this column shows 
those numbers, in the form:

bank0/bank32/patch number (0-127).

For example, if the current bank requires a bank32 message with a value "1" to be sent to access the 
patches, each patch will have "1/x" as its program number, where "x" is the MIDI Program number 
within the bank.

These numbers can't be changed directly and, if the patch name document comes from an external 
librarian, they can't be changed at all (except by the librarian). If the document in question is a Typed-
In patch name document, the numbers are affected by settings in the Bank Select/Numbering dialog 
box.



Device Program Number Column

This column shows how the MIDI device's internal patch numbering corresponds to the actual MIDI 
program number.

For example, some devices number their internal programs 1-128, which corresponds to MIDI 
programs numbers 0-127. Other MIDI devices number their internal programs using an octal format.



Patch Name Column

This column shows the name of each patch. New patch names can be typed directly into this column if 
the patch name document was created by the Name Manager (a "typed-in" patch name document). 
Names shown here appear wherever patch names are seen in any OMS-compatible application.



GM Equivalent Column

If this patch corresponds to a General MIDI patch, you have the option of choosing a relevant GM 
patch from the drop-down list in this column. The Name Manager applies all attributes and benefits of 
General MIDI groupings to that patch.

For example, assume you have a piano sound in your patch name document, and you assign 
"GrandPno1" as its GM equivalent. Then, if you choose to display patch names by General MIDI 
groups, this piano sound appears whenever you ask OMS to display all the piano sounds in your MIDI 
device.



Note Name Indicator Column

This column uses a small note icon to indicate which patches have custom note names.

The OMS Name Manager can store custom MIDI note names along with patch names. Custom note 
names have many uses. For example, names can be assigned to the notes in a drum kit patch, 
causing all your edit    windows to display notes with relevant names like "kick" or "snare" instead of 
"C3" or "D3."

Open a Note Name Editor for any patch by double-clicking in this column.



Control Name Indicator Column

This column uses a small knob icon to indicate which patches have custom MIDI control names.

The OMS Name Manager can store custom MIDI control names along with patch names. Custom 
MIDI control names have many uses. For example, a MIDI effects device might use MIDI control 
numbers to edit its internal parameters. By entering custom control names, all your edit windows 
display controls with relevant names like "Reverb Time" or "Pre Delay" instead of "Control 48" or 
"Control 37."

Open a Control Name Editor for any patch by double-clicking in this column.



Program Selector Dot

If you are pasting names into a typed-in patch name document, you can select the range where the 
names will be pasted by shift-clicking or dragging over the program selector dots. If no dots are 
selected, names are pasted starting at the top of the list and working down until all the names on the 
Clipboard are exhausted.



Mode Name Display

The mode that's being displayed/edited by the Patch Name Editor. You can change the name of the 
mode by choosing Patches>Mode Name.



Patches Menu

For Windows, the Patch Name Editor contains its own Patches Menu. For the Macintosh, the Patch 
Name Editor adds the Patches Menu to the Menu Bar. This menu contains the following commands:

Save

Save As

Save Note/Control Names

Copy Patch Names

Paste Patch Names

Clear

Add Mode

Remove Mode

Mode Name

Default Modes

Add Bank

Remove Bank

Bank Select/Numbering



Save (Patches Menu)

Saves any changes you've made to the active patch name document. If you've previously saved the 
document, choosing this command replaces the old document with the new version. If you haven't yet 
saved the active document, choosing Save opens the Save As dialog box, in which you name the 
document and select a location in which to store it.

This command behaves differently depending on where the document comes from:

· Typed-In patch name documents are saved normally.

· Patch name documents from an OMS-compatible Patch Name Provider are converted to Typed-In 
patch name documents. For this reason, the Save command is not available when you are editing 
this type of document. In this situation, only the Save As command is available.



Save As (Patches Menu)

Use this command to save a copy of the active patch name document using a different name. 
Choosing Save As opens the Save As dialog box, in which you name the document and select a 
location in which to store it.



Save Note/Control Names (Patches Menu)

If note names or control names have been added to a document created by another application, the 
Save Note/Control Names command becomes available. This command adds the new note name 
and control name information to the saved patch name document.



Copy Patch Names (Patches Menu)

Choose this command to copy the list of patch names from the active patch name document onto the 
Clipboard.

Names are copied to the Clipboard as text and can be pasted into other applications. For example, 
you can paste names into a word processor or database program and format, search, or print name 
lists from within those applications. Each line is copied as:

Patch number <tab> Patch Name



Paste Patch Names (Patches Menu)

Choose this command to copy text from the Clipboard into the Patch Name Editor. If the lines of text 
contain tabs, they are interpreted as:

Patch Number <tab> Patch Name

Otherwise, each line of text becomes a patch name. If you have access to a scanner ad OCR (optical 
character recognition) software, you can scan patch name lists for your synthesizers, convert them to 
word processing files, then paste them into the Patch Name Editor.

If you've selected patches in the Patch Name Editor by clicking their selector dots, then pasted names 
overwrite only the selected patches. For example, if you have ten patch names on the Clipboard, but 
select only three patches in the Patch Name Editor, then only the first three patch names are pasted to 
the document.



Clear (Patches Menu)

Erases the currently selected patch name list, should you wish to start with a "clean slate."



Add Mode (Patches Menu)

Creates an entirely new device mode for the document, and opens a new window to display it.



Remove Mode (Patches Menu)

Deletes the device mode displayed in the active window.



Mode Name (Patches Menu)

Opens a dialog box in which you can name (or rename) the device mode displayed in the active 
window. The mode name appears immediately above the MIDI column in the Patch Name Editor.



Default Modes (Patches Menu)

Opens a window in which you select a default mode for each MIDI channel. Whenever you subscribe 
to this patch name document, the channels are set to the modes designated in this window.

For example, General MIDI devices have two modes: standard and drums. Channel 10 is always in 
drums mode, and all other channels are in standard mode. The following illustration shows the Default 
Mode Window for a General MIDI device.



Add Bank (Patches Menu)

Creates a new bank of 128 patches following the bank containing the currently selected patch (or at 
the end of the document if no patch is selected). When you choose this command, the Bank 
Select/Numbering dialog box opens.



Remove Bank (Patches Menu)

Deletes the bank in which the selected patch resides.

NOTE: If the device supports fewer than 128 patches in a bank, leave the unused patches blankblank 
patches won't be displayed in patch selection menus and dialog boxes.



Bank Select/Numbering (Patches Menu)

Choosing either Add Bank or Bank Select/Numbering opens the Bank Select/Numbering dialog box. 
Click any part of the following illustration to learn about its function.



Bank Select Values

Specify the type of Bank Select Message used by your MIDI device by:

· checking one or both of the Bank Select 0 or Bank Select 32 checkboxes.

· entering a bank select value in the box to the right of any selected checkbox.

Consult your synthesizer documentation to determine the appropriate bank select values.

IMPORTANT: Each bank must have a unique combination of bank select messages. A warning 
message appears if two banks have the same bank select combination.



Bank Numbering

If the Automatically number patches in bank option is enabled (checked), then patches are 
automatically numbered according to the selected numbering convention:

· 0-127: Used for MIDI devices with internal patch numbers starting at "0."

· 1-128: Used for MIDI devices with internal patch numbers starting at "1."

· A11-B88: Used for MIDI devices with "bank based," octal numbering conventions (most Roland 
devices use this scheme).

· Prefix: Used for MIDI devices with other types of internal numbering schemes. For example, if a 
synthesizer has a bank of patches stored on a RAM card and those patches are numbered 0-127, 
you could create a prefix to indicate that the patches are contained on a RAM card. Do this by 
entering "RAM1-" in the Prefix box and selecting the 1-127 option. Patch numbers would then 
appear as "RAM1-0," "RAM1-2," RAM1-3," and so on.



Assign GM equivalents to all patches

If this option is enabled (checked), then each patch is assigned a General MIDI patch equivalent. This 
sets each patches' number equal to the GM equivalent. This is useful if you want to configure a bank 
to match the GM defaults without changing the names.



Note Name Editor

The OMS Name Manager can store custom MIDI note names along with patch names. Custom note 
names have many uses. For example, names can be assigned to the notes in a drum kit patch, 
causing all your edit    windows to display notes with relevant names like "kick" or "snare" instead of 
"C3" or "D3."

1. To open a Note Name Editor for a patch, double-click in the Note Name Indicator column in the 
Patch Name Editor.

2. Type names for any or all notes, then click OK.



Control Name Editor

The OMS Name Manager can store custom MIDI control names along with patch names. Custom 
MIDI control names have many uses. For example, a MIDI effects device might use MIDI control 
numbers to edit its internal parameters. By entering custom control names, all your edit windows 
display controls with relevant names like "Reverb Time" or "Pre Delay" instead of "Control 48" or 
"Control 37."

1. To open a Control Name Editor for a patch, double-click in the Control Name Indicator column in 
the Patch Name Editor.

2. Type names for any or all MIDI controls, then click OK.



Name Browser

The Name Browser is actually a part of OMS, which, together with some other windows and menu 
items, is known as the Name Manager. Use the Name Browser to determine how patch names are 
organized, arranged, and displayed in your OMS-compatible application.

1. To open the Name Browser, Alt-click (option-click for Macintosh) on any patch name field.

Click any part of the following illustration to learn about its function.



Group List and Grouping Options

IMPORTANT: This portion of the Name Browser does not appear if your patch name documents do not 
contain any group assignments.

Use the Grouping pop-up and the Group List to organize patch names into groups with common 
characteristics.

For example, the General MIDI patch name document contains three groupings in its pop-up menu:

· None: Select this option to view ALL the patch names in the scrolling right-hand Patch List.

· General MIDI Groups: Select this option to produce a list of groups that contain patches with 
common sound characteristics. When you select a group from the left-hand Group List, the right-
hand Patch List displays all the patches in that group.

· General MIDI Patches: Select this option to produce a list of General MIDI patches. When you 
click a name in the left-hand Group List, the right-hand Patch List displays all the patches that have 
this patch assigned as the GM Equivalent.

NOTE: You can create custom groupings only with an OMS-compatible Patch Name Provider. 
Groupings can't be created for Typed-In patch name documents, but the General MIDI Patches 
grouping can be used to classify sounds by assigning GM Equivalents for each patch in the Patch 
Name Editor.



Patch List

Use this scrolling list to select a patch. The selections you make in the left-hand Group List determine 
which patch names appear in this list.



Display Options

To view patches alphabetically, select the By name option.

To view patches numerically, select the By number option.

The selection you make is global and applies to all places where patch names are displayed.



Names Menu (Name Browser)

The Name Browser contains its own Names Menu. This menu contains the following commands:

Sort by number

Sort by name

Show patches in any selected group

Show patches in all selected groups

Edit selected patch

Play

Stop



Sort by number (Browser Names Menu)

Displays patch names numerically. Selecting this command is the same as checking the By number 
option in the Name Browser.



Sort by name (Browser Names Menu)

Displays patch names alphabetically. Selecting this command is the same as checking the By name 
option in the Name Browser.



Show patches in any selected group (Browser Names Menu)

With this option checked, shift-clicking multiple groupings in the Name Browser displays patches 
belonging to any of the selected groups. This enables a Boolean OR condition between multiple 
groups. This is convenient if you want to audition a number of patches with slightly different sonic 
characteristics, such as Acoustic Pianos OR Electric Pianos.



Show patches in all selected groups (Browser Names Menu)

With this option checked, shift-clicking multiple groupings in the Name Browser displays only patches 
belonging to ALL the groups. This enables a Boolean AND condition between multiple groups. This is 
convenient if you're trying to fine-tune your search to a specific patch.



Edit selected patch (Browser Names Menu)

Launches the Patch Name Provider program that originally created the patch name document.

NOTE: This command is not available when the active patch name document is a Typed-In document.



Play (Browser Names Menu)

If you're running an compatible MIDI application in the background, choose this command to trigger its 
playback from within the active application.



Stop (Browser Names Menu)

If you're running a compatible MIDI application in the background, choose this command to stop its 
playback from within the active application.



Patch

A collection of parameters in a MIDI device that create the actual sound played when you recall it from 
memory. For example, on patch might create a trumpet sound and another might create a guitar 
sound.



Bank

A collection of patches stored in a MIDI device. Most modern MIDI devices have storage for hundreds 
(or even thousands) of different patches. Additionally, many devices contain multiple types of banks, 
which store multiple types of patches. These devices are said to support different modes.



Bank Select Message

Since the original MIDI specification only provided for banks of 128 patches, the Bank Select Message 
was invented to give computers access to the thousands of internal patches contained in some 
modern MIDI devices.

To access this number of patches via MIDI, you must send two messages to the device:

· First: a Bank Select Message telling the device which bank to "look in."

· Second: a Program Change Message, which tells the device which patch to select within that bank.

Different devices from various manufacturers respond to different types of Bank Select Messages.



Mode

The state of a device that determines how MIDI program changes are interpreted.

Different MIDI devices have different modes. For example, a generic synthesizer might have three 
different modes:

· Patch Mode: Individual sounds, such as "Electric Piano," "Acoustic Guitar," or "Flute."

· Effect Mode: Effects programs such as "Hall Reverb," "Slap Delay," or "Flange."

· Performance Mode: A combination of several individual sounds with an effects patch, such as an 
"Electric Piano" layered with a "Flute" patch and assigned to a "Hall Reverb" effect.

Usually devices access the different modes by interpreting Patch Change Messages differently for 
different channels. For example, General MIDI devices have "patch" mode channels and "drum" mode 
channels. Sending program change #1 to a channel in "patch mode" calls up a piano sound, whereas 
sending program change #1 to a channel in "drum mode" calls up a standard drum kit.

By using different device modes, you can display and select any patch type contained in any bank in 
your MIDI device.

Do not confuse modes with banks; a bank of patches for one mode might contain an entirely different 
number of patches than a bank for a different mode.



Patch Name Document

A document that stores and provides patch names and device modes for one or more MIDI devices. 
There are three kinds of patch name documents:

· Typed-in name documents created using the Name Manager

· Galaxy Bundles

· Bundles created by another OMS-compatible librarian



Current Patch Name Document

If a patch name document is "current," OMS thinks that the patches in the document are actually 
loaded into the device. You can manually make a document current, or an OMS-compatible librarian 
program can do it automatically when it sends patches to the device.



Patch Name Provider

An application that can create a patch name document readable by the OMS Name Manager.



Name Setup

A mapping that associates each MIDI device in your current OMS Studio Setup document with a 
specified patch name document. There is only one Name Setup active at a time, and it "lives" inside 
OMS, not the application.

Since the Name Setup is handled by OMS, changes made to the Name Setup in your active 
application also affect the names seen by other OMS-compatible applications.



Subscribing

The OMS Name Manager allows you to assign a patch name document to each MIDI device in your 
Studio Setup document. This patch name document is used by OMS to display patch names in all your 
OMS-compatible applications. The correspondence between a MIDI device and a patch name 
document is called a "subscription."



Current Studio Setup Document

The Studio Setup document referenced by OMS and all your OMS-compatible applications. You can 
create and store any number of Studio Setup documents to describe any number of studios or studio 
configurations, but OMS can reference only one Studio Setup document at a time (the "current" Studio 
Setup document).



MIDI Device

Any device (stand-alone or virtual) that communicates MIDI information.



OMS

Opcode's Open Music System (OMS) is a code library that bridges the gap between MIDI applications 
and MIDI hardware. It has many functions and features:

· OMS acts as a central MIDI driver

· OMS provides a central location for defining and storing a detailed description of your MIDI studio.

· OMS provides a patch name management tool

· OMS handles all your computer's internal MIDI timing

· OMS gives you access to hundreds of MIDI channels

For more information, see the Help file for the OMS Setup application.



OMS Setup

The application used to interface with OMS and to design Studio Setup documents.



Studio Setup Document

A Studio Setup document is an exact model of your MIDI Studio. A fully configured Studio Setup 
document contains information about:

· MIDI interfaces connected either externally (such as an Opcode Music Quest 2Port/SE or Studio 
5LX) or internally (such as an MQX-32M or QuickTime Musical Instruments).

· MIDI cards installed inside your PC (such as a SoundBlaster or MacProteus).

· Software-based synthesizers and other Virtual devices connected directly to your PC.

· MIDI devices connected to MIDI interfaces (such as synthesizers, drum machines, effects devices, 
and MIDI controllers).

· How all this hardware is physically connected.

You can create and store any number of Studio Setup documents to describe any number of studios or 
studio configurations, but OMS can reference only one Studio Setup document at a time. This is called 
the current Studio Setup document.

For more information, see the Help file for the OMS Setup application.



Virtual MIDI Device

A software or card-based synthesizer that the computer accesses directly, rather than through a MIDI 
Interface. On the PC, this could be an AWE32 synthesizer provided by a SoundBlaster card. On the 
Mac, this might be Apple's QuickTime Musical Instruments or a MacProteus card.




