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Introduction
Welcome to Finale! 
This demo contains the entire Finale program with two exceptions: you can't save your 
document and every time you print the allowed one page, the words "Finale" share the 
printed page with your music.
While we can't demonstrate all of Finale in this short "read me", we'll give you a brief 
tour of some of its extraordinary power.
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What's New in Finale 2000



· New Standard Windows interface including toolbars with Open, Print, Cut, Copy and 
Paste.

· Customize your tool palettes, dock them on any edge of the window frame, or hide them 
completely.

· Automatic Music Spacing during note entry, both Step Time and Real Time.
· New Music Spacing Defaults based on the Fibonacci sequence.
· Scrolling Playback in Page View is now available.
· New Smart Shapes including Glissando, Bend, Slide and a Custom Line Tool. Create 

pedal markings, guitar notes, lines with arrowheads and other unique Smart Shapes.
· New Snap to Grid and Guidelines feature lets you easily align expressions, measure 

numbers, text blocks, repeats and other items according to a grid or a snap line.
· New Maestro Font as the default music font. This font more accurately reflects actual 

engraved music: bolder noteheads, elegant clefs and classical articulations. We’ve also 
included Maestro Wide which is identical with the exception of wider noteheads.

· Now shipping with the Jazz Font (available to registered users) which allows you to get 
that session feel in your scores. We’ve also provided a Jazz font template, and Jazz Font 
libraries as well.

· Staff Styles in the Staff Tool allow dozens of new opportunities for notating jazz, musical 
and contemporary scores. Create and apply Staff Styles to sections of your score. Change the 
Staff Style definition and it changes everywhere in the score that it is applied. Use Staff 
Styles to set up instrument transpositions, change the number of staff lines, change the staff 
name, set up alternate notation, create cutaway scores all with a staff.

· Alternate Notation has been moved from the Mass Mover Tool to the Staff Tool as a Staff 
Attribute.

· Partial Measure selection is available in the Staff Tool as well as the Mass Mover Tool. 
The Partial Measure Selection menu item has been moved to the Edit menu as well as the 
Select Region menu item.

· Select a Beaming Style for your beam angles from the new Beaming Options dialog box. 
Also, beaming options from the Document Settings submenu have been collected into this 
dialog box. There’s a new option where rests are no longer treated like notes on the middle 
staff line when beaming. And finally, a new option to prevent or allow beams to cross a space 
in a staff.

· Now add a right closing bracket to your repeat endings. Just drag the rightmost handle 
down to the staff. Also you can set the default length of this bracket.

· Import MidiScan files right into Finale.
· File menu has a New submenu which allows you to select between opening a new document 

based on your default file, a template, a new empty document, or using the new Setup 
Wizard to specify which staves and page size you want. You can also specify whether you 
would like to see the startup wizard when you use the New keyboard shortcut and what file 
action should happen upon startup in the Program Options dialog box.

· The Staff and Score Expression Tool have been merged into one powerful Expression Tool. 
Assign expressions to notes (like the old Staff Expression Tool) or measures (like the old 
Score Expression Tool). You can select whether an expression is attached to a note or a 
measure by where you click in the score, or right in the Expression Selection dialog box.

· New Expression menu appears when you select the Expression Tool.
· Show all the expression handles on a page at once with the Expression menu item Show 



All Handles.
· Attach expression metatools to notes or measures depending on your selection in the 

Expression menu. 
· The Measure Tool, Measure Number Tool and the Measure Attribute Tool have been merged 

into one Measure Tool. As a result Change Barlines, Change Width and Change Positioning 
have been removed from the Mass Edit menu as they are now accessible from the Measure 
Tool.

· Use the new Measure menu in the Measure Tool to enclose measure numbers, change 
barlines, edit multimeasure rests and a number of other things. The Measures submenu and 
the Multimeasure Rest submenu have been moved from the Mass Edit menu to the Measure 
menu.

· Regional Measure selection is available in the Measure Tool.
· Left Barline styles are now available in the Measure Attributes dialog box. You can also set 

the default for left barlines to either use a normal barline or use the previous measures right 
barline instead.

· You can now set a different time signature for display even when you are using 
independent time signatures.

· New Special Tools Tool to adjust the width of individual beams.
· New Special Tools Tool to adjust stems on beamed notes.
· Use two new settings in the Import MIDI File Options dialog box to import patches and 

General MIDI patch names.
· Now use the file structure in your Plug-ins folder to control the structure of your plug-

ins menu.
· More Plug-ins are available for Finale 2000. See our website at www.codamusic.com for 

more information about our developer’s kit to write your own.
· The plug-ins shipped with Finale 2000 include:

· 1. Change Noteheads. This plug-in allows you to change the noteheads of all the notes 
in the selected region.

· 2. Change to Default Whole Rests. This plug-in allows you to change all the whole 
measure rests in the selected region to default rests.

· 3. Change to Real Whole Rests. This plug-in allows you to change all the default 
measure rests in the selected region to real whole rests.

· 4. Clear Lyric Positioning. This plug-in will reset any changes you’ve made to your 
lyric baselines in the selected region. 

· 5. Clear Measure # Positioning. This plug-in clears all measure number positioning in 
the selected region and sets it back to the default position.

· 6. Command Line. This plug-in allows for quick note entry by typing in specific text 
commands.

· 7. Midline Stem Direction. This plug-in changes the stem direction of notes on the 
middle staff line to follow the direction of the melodic line.

· 8. Move Rests. This plug-ins lets you move rests in the selected region to a different 
vertical position.

· 9. Piano Reduction. This plug-in creates a piano reduction of the selected staves.
· 10. Single Pitch. Change all the notes in your selected region to the specified pitch.
· 11. Split Point. This plug-in lets you reset the split point between two staves in the 

selected region.



· 12. Voice 2 to Layer. This plug-ins moves Voice 2 entries to the selected layer.
· Alternate Notation can now be applied to partial measures and any layer using Staff 

Styles.
· A new Rest palette has been added to Simple Entry to allow easier entry of rests. Display 

of this palette is controlled in Program Options and the Window menu. 

·  and  Smart Shapes now affect playback.
· Encore Conversion now supports left barlines for system starts.
· New Symbol option in the Text menu. Select Symbol from the Inserts submenu of the Text 

menu to display the Symbol Selection dialog box for the current font. Select the character 
you want to include and Finale will place it in you text block.

· Now you have more control over showing repeat dots. Use the custom staff setup in the 
staff tool to select either the top or bottom dot to show. This is especially useful for tablature 
staves.

· New Opaque setting in the Enclosure Designer dialog box.
· Display measure number ranges for multimeasure rests.
· Add and Insert Staves have been combined into one New Staves in the Staff menu. Also, 

a new item New Staves (with Setup Wizard) has been added allowing you to add a staff 
using the new setup wizard available also with new files.

· Mass Mover metatools 6-9 are now programmable transpositions. Mass Mover metatool 
7 (which was Elapsed Time) has been moved to metatool 5.

· Use Ctrl- or Ctrl- to change to the next or previous lyric on the score using Type into 
Score.

· A Swing marking has been added to the Expression library.
· Change a notehead into a rest in Speedy Entry without placing the cursor on the note-

head (when it not in a chord).
· You no longer need to "unfreeze" a rest using the asterisk (*) to drag it using Speedy 

Entry. Just drag the rest to move it vertically or horizontally, including default whole rests.
· We’ve added a Show All Messages checkbox in Other Program Options to allow you to 

recover any messages you selected the "Don’t Show This Again" checkbox.
· The Transposition dialog box has been modified slightly to incorporate radio buttons for 

some options.
· Now use the Hand Grabber Tool shortcut in the Shape Designer.
· The Search and Replace function in the Note Mover Tool now can be used in Page View.
· The Music Spacing Options dialog box has been moved to the Document Settings 

submenu of the Options menu. All music spacing settings from this dialog box are now 
document specific.

·  The Update Layout Options dialog box have been moved to the Options menu.
· The Mass Edit menu is always available when the Mass Mover Tool is selected.
· In the Mass Edit menu, Erase has been renamed Clear Items, Clear has been moved from 

the Measures submenu and renamed Clear Entries and Smart Shapes and the Items to 
Erase dialog box has been renamed Clear Items dialog box. Clear Entries and Smart 
Shapes will clear all notes, rests and items attached to notes and rests, as well as measure-
attached Smart Shapes.

· The Options menu is available even without a document open for you to make changes to 
preferences.



Starting Finale
Let's get started.
· Select New, then New From Template from the File menu. Double-click to open 

"Grand Staff." in the Templates folder. Finale comes with over thirty templates: 
everything from "Full Orchestra" to "Lead Sheet". Think of these templates as your 
sheet music that you design and re-use every time you want to create a score. Of 
course, you can create your own score for any configuration, but these templates 
are all set up and ready to go. So, we suggest you use these as a starting point and 
edit them rather than creating your own from scratch.

With the Grand Staff template open, let's begin by learning Finale:
· You'll notice a number of Tools on the top of the screen. Each of these tools has a 

specific function. For example, when you want to do page layout, you'll use the Page 
Layout Tool; when you want to add articulations to your score, you'll use the 
Articulation Tool. When you select a Tool the Message Bar explains the tool's 
function. Finally, by selecting Help, you have instant on-screen help to almost every 
aspect of Finale's power.

Entering Notes
There are six ways to get your notes into Finale:

· Simple Note Entry
· Speedy Note without MIDI
· Speedy Note with MIDI
· Hyperscribe - instant notation while playing a MIDI Instrument
· Transcription Mode
· Standard MIDI Files

This demo will discuss all entry methods but the Transcription Mode. 

Simple Note Entry:
This is the simplest way to get notes into Finale. You'll start entering notes with the 
Simple Entry Tool, but probably graduate to faster note entry methods.

To enter notes using the Simple Entry Palette
· Click the Simple Entry Tool. A palette containing notes of different rhythmic values 

and a palette of rests appear, if they are not already visible. (To show or hide these 
palettes, choose Simple Entry Palette or Simple Entry Rests Palette from the 



Window menu.)
· Click the duration of the note you want to enter.
· Position the cursor at the desired pitch.
· Click on the measure. The note appears. To enter rests, press the shift key as you 

click the measure. You can also use the Rests Palette.

For more information about each tool in the palette, simply click the tool. The Message 
Bar at the bottom of the screen tells you how to use the tool.

To speed things up, try using the number method described in the Speedy Entry section 
below.
· Position the cursor at the desired pitch.
· Click on the measure while holding the number representing the duration you want. 

The note appears. To enter rests, press the shift key and the number as you click a 
measure.

When you use Simple Entry to enter notes in your score remember these points:

1. Make sure Check for Extra Notes is selected under the Simple Entry menu.
2. You don't need MIDI with this tool.

Speedy Note without MIDI:
Many publishers use this tool to enter their music by simply typing it in from the 
computer keyboard.

To enter notes using the Speedy Entry keyboard (without MIDI)
· Click the Speedy Entry Tool on the Main Tool Palette. Notice that a new menu 

named Speedy appears to the right of the other menus.
· Make sure Use MIDI Keyboard is unchecked in the Speedy menu. (If necessary, 

choose Use MIDI keyboard from the Speedy menu to remove the checkmark beside 
it.)

· Click on a measure. A box appears around the measure you clicked, and a cross bar 
appears on the staff.

· Specify the pitch of the note with the cross bar. To move the cross bar up and down:
· Press the up and down arrows on the computer keyboard.    OR
· Click the pitch where you want the cross bar to go. OR
· Press a key on the computer keyboard according to the following diagram. The 

diagram shows which pitch you'll select when you press a key on the computer 
keyboard. It's not that an 'A' is the musical note 'A', but rather that as you type 
along the keyboard the cross bar indicate pitch moves up and down.



· After you specify the pitch, press the duration that you want according to the 
following diagram. Type a '5' and a quarter note appears where the cross bar was. 
The same numeric keypad values work in Simple Entry as well.

· Use the commands shown in the Speedy Entry Keyboard Commands diagram to 
experiment with everything from breaking beams to hiding accidentals.

Did you make a mistake? Don't worry. Just click and drag the notehead up, down or 
sideways. When connected to a MIDI keyboard you'll hear the notes as you move up 
and down the measure.

Speedy Note with MIDI:

To enter notes using the Speedy Entry keyboard (with MIDI)
· Click the Speedy Entry Tool on the Main Tool Palette. Notice that a new menu 

named Speedy appears to the right of the other menus.
· Make sure Use MIDI Keyboard is checked in the Speedy menu. (If necessary, 

choose Use MIDI keyboard from the Speedy menu to place a checkmark beside it.)



· Click on a measure. A box appears around the measure you clicked, and a cross bar 
appears on the staff.

· Specify the pitch of the note by playing (and holding) a note or chord on the MIDI 
keyboard.

· While playing the pitch, press the duration that you want according to the Speedy 
Entry Keyboard Commands diagram show above. Type a '5' and a quarter note 
appears. The same numeric keypad values work in Simple Entry as well.

· Use the commands shown in the Speedy Entry Keyboard Commands diagram to 
experiment with everything from breaking beams to hiding accidentals.

HyperScribe:
The fastest way to enter your notes into Finale is HyperScribe, Coda's real-time note 
entry method. Whether you prefer to play along with music in other staves, or with a 
metronome, Finale can instantly notate your music as you play it. If you want to alter the 
tempo as you play (slow down for difficult parts or speed up for easier parts), you can 
provide your own click track by tapping the foot pedal (or a note on the MIDI keyboard) 
to the beat. 

To notate your music using HyperScribe with a tap
· You should still have the file "Grand Staff" open. If not, choose New, New from 

Template to open it.
· Click on the HyperScribe Tool.
· Click on the HyperScribe menu, then the Beat Source submenu, then Tap.
· In the Tap Source dialog box, click Listen, then play the 'C' below 'middle C' on your 

MIDI keyboard. Finale will automatically enter the MIDI channel and the note that 
you played into the corresponding text boxes.

· Click OK. You've now specified that Finale should listen to 'low C' to determine 
where the beats are. (We've already set up Finale to listen for quarter notes since 
this piece is in common time.) In effect, you will provide the metronome click as you 
play! The advantage is that you can play the music at any tempo you desire. You 
can even vary the tempo and Finale will still notate the music properly.

· Click the first measure of the treble clef in our Grand Staff.
· Play the following example at any tempo you desire.
· When you're done, click anywhere on the screen to leave HyperScribe.



Notice that only the melody transcribed even though you're playing 'low C' quarter note 
taps, which provide the beat reference for Finale. The the low 'C' is your 'tap', which can 
be any note. You can even specify the beat duration. For example if you were playing a 
piece in 6/8 time you might set the beat duration to be a dotted quarter note, or if it's a 
slow piece you might set the beat duration to be an eighth note. If you wish to play a 
piano piece with two hands, you can provide the beat by tapping your foot pedal. 

Try using the left hand 'C' again and play anything you want in the right hand. Just 
remember that if you hit the left hand 'C' and don't play a note, a quarter rest will appear 
instead. If you play two notes in the space of one 'C' they will be eighth notes; four 
would be sixteenth notes. One note held down while two C's are played would be a half 
note and so on. (The durations that are notated depends on the quantization settings. 
For example, if you play 16th notes but Finale notates 8th notes, you need to change 
the settings. Choose Quantization Settings from the Options menu. Select your smallest 
note value and quantization type.)

To multitrack record using HyperScribe
When you multitrack record (listen to other staves as you play new music) or play along 
to a metronome click, you play at a strict tempo. You cannot vary your tempo like you 
can when you provide the tap yourself. 

· Choose Open from the File menu.
· Locate and open 'Twinkle.mus'. We'll have you play in the melody while you listen to 

the other staves.
· Choose Playback and/or Click from the Beat Source submenu of the HyperScribe 

menu.
· Place a check beside Play Staves While Recording.
· Type the tempo at which you want to record the melody. Or, click the Listen button 

and play a few notes on your MIDI keyboard. Finale will automatically update the 
Tempo text box to match the tempo you play.



· Choose Other from the Signal to Start Playback drop-down list then click Listen. Tap 
your MIDI keyboard's sustain pedal, then click OK twice.

· Click the first measure of the flute part.
· Tap the sustain pedal to start the playback and recording session. Finale starts 

playing the piece at the measure you clicked.
· Play the melody, as shown in the following example, along with the accompaniment. 

The chord changes have been provided if you want to improvise your own melody.
· When you're done, click anywhere on the screen to leave HyperScribe.
· If you want different staves to play back, or want the staves to play back using 

different sounds, see Playing Back Your Score in this document.



Standard MIDI Files:
If you use a Sequencing program Finale notate your sequencer's files if they are saved 
as standard MIDI files. 

To transcribe standard MIDI files
· Choose Open from the File menu.



· Select MIDI File Format from the file type drop-down list.
· Locate and open your MIDI file. If you can't open your MIDI file, make sure that 

you've saved it as a standard MIDI file (refer to your sequencer's user manual).
· Select the settings that you want. If you've quantized your MIDI file already, go to the 

next step; otherwise, click the Quant Settings button to set your smallest note value 
and quantization type. Click OK to return to the MIDI Input File dialog box.

· Click OK. Finale begins to transcribe your MIDI file. When Finale is done transcribing 
your MIDI file, the dialog box will disappear and your MIDI file will be notated in 
Finale.

Playing Back Your Score
Finale allows you to playback your piece through your MIDI setup.

MIDI Playback
 If you have a MIDI keyboard, Sound Module or Sound Card capable of playing multiple 
sounds at the same time, you can hear your piece fully orchestrated.

To set up your staves for playback
· Open the file "twinkle.mus".
· Choose Instrument List from the Window menu. Each staff appears in score order.
· For each staff, type in the Channel number you wish to use. For example, a three 

instrument piece like twinkle.mus could have channels 1, 2 & 3 assigned or channels 
3, 4 & 5 assigned depending on your MIDI setup. Since you want the piano sound 
assigned to both piano staves, assign the same channel number to both staves. In 
General MIDI, channel 10 is reserved for percussion sounds. 

· For each staff, type the Patch number you wish to use. In this case, you want the 
middle two staves to be a piano. Find the patch number for the piano sound on your 
MIDI instrument. If the piano sound is patch 1, you would type in the number '1' as 
the patch number in the Instrument List. For the violin, find the sound on your MIDI 
instrument you want and type in its patch number as well. (In Finale, the patch 
numbers must be between 1 and 128. Refer to your MIDI instrument's user manual 
for its patch numbering convention.)

· Select which staves you want to play back. (The Instrument List settings are also 
used for HyperScribe entry when Play Staves while    Recording is selected in the 
Playback and/or Click dialog box.) If you want the entire score to play back, click 
Play All at the bottom of the Instrument List. If you want to hear only one staff, click 
in that staff's Solo column. If you want to hear only a few staves, such as the piano 
part, make sure that a square appears for those staves only.



· To view more of the score, you can click the close button of the Instrument List when 
you're done.

To play back your staves
· Choose Playback Controls from the Window menu if they are not already visible. 

You may wish to drag the Playback Controls out of the way of your music.
· These Playback Controls work just like the controls on a tape deck. Click the Play 

button and listen to your piece.
If you prefer, you can choose to have Finale scroll the music as it plays.

To scroll staves during playback
· Click the Expand arrow in the Playback Controls.
· Select Scrolling from the Play mode drop-down list.
· Make sure    your Playback Controls smaller by selecting the Expand arrow again, 

and move it out of the way if needed.
· Click Play on the Playback Controls. You will now see your music scroll as it plays so 

you can proof it visually as well as aurally.

Editing Your Music
Finale will let you edit your music in almost any way you can imagine: respace, 
transpose, change voicings, move notes, change durations,    and change clefs and 
accidentals. Here are some examples:

To move a note
· Click the Speedy Entry Tool.
· Click on the measure that contains the note that you want to move.
· Click on the notehead you want to move, then drag the note up, down, left or right. If 

Use    MIDI Keyboard is selected (checked) in the Speedy Entry menu, and you're 
connected to a MIDI keyboard, you'll hear the note as it changes pitch.

To change the key signature
· Click the Key Signature Tool.
· Click the    measure where you want your new key signature to begin.
· Select a new key signature by scrolling up for the sharps and down for the flats.
· Specify the measure region that you want to change to the new key signature, then 

click OK.



Adding Dynamics and 
Slurs

When you add dynamic markings or articulations to your score, Finale includes the 
effect of the markings in its MIDI playback. Notes with staccatos play shorter; phrases 
marked fortissimo play louder than those marked pianissimo; and sections marked 
'Allegro' play faster than those marked 'Adagio'. When you add slurs or other musical 
markings with the Smart Shape Tool, the markings do not affect MIDI playback. They do 
however, adjust as the width of the measure changes, and automatically break to 
appear across staff systems in Page View.

To add a dynamic marking
· Click the Expression Tool on the Main Tool Palette.
· Double-click on the note where you want the expression to take effect and the 

Expression Selection dialog box appears in your score. 
· Click to select the expression you want to add to your score.
· Click on Note Attached or Measure Attached, then click Select. Expressions 

attached to a particular note affect the notes on the selected staff. If you want to 
affect the entire score, you'd attach the expression to the selected measure.

· Click OK in the next dialog box that appears. The marking you selected appears in 
your score with a handle attached to it. As with all handles in Finale, simply drag the 
handle and place the dynamic where you want it. 

To add an articulation
· Click the Articulation Tool.
· Click on the note where you want an articulation such as a staccato or accent to 

appear. The Articulation Selection dialog box appears.
· Click to select the marking you want to add to the note, then click Select. The 

marking you selected appears in your score with a handle attached to it. Drag the 
handle to place the articulation where you want it.

To add slurs (attached to notes)
· Click the Smart Shape Tool. The Smart Shape menu appears. Another movable 

palette also appears that contains slurs, decrescendo and crescendo marks, solid 
and dashed lines, and so on. (Choose Smart Shapes Palette from the Window menu 
to show or hide this palette.)



· Click the Slur or Curve Tool on the Smart Shape Palette.
· Make sure that 'Attach to Notes' is selected (checked) in the Smart Shape menu.
· Double-click where you want the slur to start, then drag to draw the slur. (Be sure to 

hold down the mouse button after the second click as you drag across the page.) 
When you double-click, Finale highlights the first note of the slur. When you drag, 
Finale highlights the nearest note. Release the mouse when Finale highlights the 
last note you want included in the slur. Notice that Finale always draws the slur 
correctly based on the notes' stem direction. If you later use the Speedy Entry Tool 
to drag the notes to different pitches the slur changes automatically. When you 
respace your music, the slur automatically adjusts to the new positioning of the 
notes. Feel free to explore the other commands in the Smart Shape menu.

You may also enter slurs using the Expression Tool if you want such effect as 'S' 
shaped slurs. However, unlike Smart Shape slurs, the Expression slurs will not 
automatically reshape when you make changes such as transposing or respacing 
the notes.

Any of the other shapes on the palette such as the decrescendo and crescendo 
marks, solid and dashed lines, and so on are attached to the nearest measure you 
draw the shape by. If you want to attach slurs to measures instead of notes, simply 
choose 'Attach to Measures' from the Smart Shape menu to add a checkmark. This 
feature can be helpful for placing long phrase markings.

Adding Chords and Lyrics
When you add chords and lyrics to your score, Finale remembers what note they are 
assigned to. When you move a note, the chord or lyric syllable moves with the notes.

Chords
There are five ways to enter chords.
1. Manual Input
2. Type Into Score
3. MIDI Input
4. One-Staff Analysis
5. Two-Staff Analysis

Four of the methods work without MIDI. We'll look at MIDI Input, which listens as you 
play the chords on your MIDI keyboard.

To enter chords using MIDI Input



· Open a file with notes entered into it or make a file with notes already entered.
· Click the Chord Tool.
· Choose MIDI Input from the Chord menu. 
· Click any note in the top staff and an ear appears.
· Now play a chord on your MIDI keyboard and the name of the chord appears. Finale 

will even tell you the inversion you played, for example 'C/E'.
· Click the next note that you want to attach a chord to, or play a single note above 

'middle C' on your MIDI keyboard to move the 'ear' forward without using your 
mouse. To move the 'ear' backward without using your mouse, play a single note 
below 'middle C' on your MIDI keyboard.

· Repeat steps 4 and 5 to enter more chords. A chord chart can be created very 
quickly using this method.

Try this: With the ear ready to listen to a chord, play the weirdest chord you can think 
of. If Finale doesn't know the chord (if it was weird enough Finale shouldn't know it) 
a dialog box will come up telling you to name your chord or Let Finale Do It. Select 
Let Finale Do It. Finale will name your chord giving some pretty extraordinary 
results.

To show guitar fretboards for chords
· Once you have a selection of chords in your piece, choose Show Guitar Fretboards 

from the Chord menu. The standard guitar fingering for those chords will appear.
· Choose Position Fretboards from the Chords menu to display the positioning arrows 

for the fretboards. Drag the leftmost arrow to adjust all the fretboards in the piece. 
(Choose Position Fretboards from the Chord menu to display the positioning arrows 
for the chords. Again, drag the leftmost arrow to adjust all the chords in the piece.)

If you transpose your piece (refer to change the key signature explained earlier), 
not only do the chord names change as the music transposes, but the guitar 
fretboards transpose as well.

Lyrics
There are two ways to enter lyrics.
1. Type Into Score
2. Click Assignment

The first method assigns the lyrics as you enter them. The second method requires you 
to first enter the lyrics (using the Edit Lyrics command), then assigns the lyrics using the 
Click Assignment command. The second method is preferable, if the lyrics will be edited 
later.

To enter lyrics using Type Into Score



· Click the Lyric Tool.
· Choose Type Into Score from the Lyrics menu.
· Now click on the first note of the top staff and a cursor starts blinking.
· Type in a word and press the space bar to move the cursor to the next note.

It's that simple. Keep in mind that you'll have to hyphenate syllables. (Type a syllable, 
then type a hyphen, then type the next syllable. For example, to enter "Twinkle, 
Twinkle," you would type "Twin" "-" "kle," "Twin" "-" "kle,"). Finale automatically places 
the hyphen in the correct place.

To enter lyrics using Click Assignment
· Choose Edit Lyrics from the Lyrics menu. A window appears into which you can type 

all of your lyrics. Notice that the lyrics that you previously entered are also in this 
dialog box. That's because the lyrics in the score and the lyrics in the dialog box are 
dynamically linked. This means that if you change the lyrics in the dialog box, the 
lyrics in the score will change as well as vice versa. Type a sentence into the dialog 
box. (Remember to type hyphens between the syllables of your lyrics.)

· Click OK to return to the score. Now that you've entered your lyrics, you can enter 
them in the score.

· Choose Click Assignment from the Lyrics menu. The Click Assignment window 
appears containing the lyrics you just entered.

· Click the note you want your lyric syllable attached to. Finale places the first syllable 
on the note, then advances the Click Assignment window to the next syllable.

· To really speed things up, press the Control key while you click on a note. All the 
lyrics are entered into the score at once.

· Drag the leftmost arrow that appears on the left side of the screen to change the 
vertical positioning of the lyrics.

If you need to make corrections to the notes the lyrics are assigned to, experiment 
with the Shift Lyrics command in the Lyrics menu. Try out the other commands as 
well.

Changing the Page Layout
There are two views in Finale:
· Scroll View - where music is displayed in continuous unbroken staves.
· Page View - where music is displayed on a page.



If you start your piece using one of Finale's templates, your page layout will already be 
done for you. To show you some of Finale's powerful layout features, we'll take an 
actual piece of music, 'Cubes.mus', and purposely solve some issues you might 
encounter along the way. 

Open up 'cubes.mus'. 
· Choose Open from the File menu.
· Locate and open 'cubes.mus'
· Choose Page View from the View menu.
· Choose 50% from the Scale View submenu of the View menu.
· Choose Home Position under the View menu to get a better view of your page. Note 

that the first staff system is not indented. 

To indent a staff system
· Click the Page Layout Tool. 
· Drag the upper left handle to the right. Click anywhere on the system and drag it 

down to leave room at the top of the page for your title. Notice that all the other staff 
systems move down. If you move them down too far, staff system '5' will move onto 
the next page. 

· Choose Update Layout from the Edit menu. Finale will update its display of the 
music according to your latest adjustments.

To reduce the size of your music
Perhaps you want your music smaller on the page. If, for example, you have eighteen 
staves on an 8.5" X 11" piece of paper this next set of instructions is especially helpful.

· Click the Resize Tool.
· Click in the upper left corner of your score.
· Type in '75' where it says Resize Page to 100% then click OK.
· Choose Update Layout from the Edit menu to ensure that Finale makes your latest 

changes. Now your music is 75% smaller and takes up only 2 pages where it took 
up 3 pages before.

To add a title, composer name, and other text
· Click the Text Tool.
· Double-click on the score where you want your text to go. Just type in the 

information.

To change the Font, Style and Size
· Click the Text Tool.
· Double-click an existing text block handle.
· Highlight the text by click-dragging with the mouse, or choosing Select All from the 

Edit menu.
· Choose Character Settings from the Text menu.
· Make the desired changes then click OK.



To align the text on the page or attach it to more than one page
· Click the Text Tool.
· Click on an existed text block handle.
· Choose Attributes from the Frame menu.
· In the Attach box, click on the drop-down menu next to Page. Choose All Pages. You 

could also choose a Page Range and fill in 2 through 99 to skip the first page.
· In the Alignment and Positioning box, click on the drop-down menu next to 

Horizontal. Choose Right. Next to Vertical, choose Bottom.
· Click OK. You've now added the same text in the bottom right corner on all your 

pages.

Printing the Score; 
Creating and Printing Parts
Now that your piece is properly laid out you're ready to print. 

If you want to print your score just choose Print Score from the File menu. Your score 
will be printed. For purposes of this demo the words 'Finale Demo' are superimposed on 
the printed page. This demo will only print one page.

A note on printers: The quality of your printout is dependent on the quality of your 
printer. If you are using a non-PostScript printer, for example, your printout won't 
equal the resolution you would receive with a more expensive Postscript printer.

A note on fonts: Finale ships with five fonts - Maestro, the music font; Seville, the 
Guitar fretboard font; Tamburo, a Percussion font; Petrucci, a music font and Finale's 
Engraver Font set. These fonts are available as TrueTypeTM and PostScript fonts. 
Finale is the only music notation program that lets you switch music fonts. As a result 
many other music fonts are available to Finale users including The Jazz Font (free to 
registered users of Finale), Toccata and Fughetta. Call Coda or visit our website for 



more information.

There are three ways to print your parts in Finale:
1. Extract Parts 
2. Special Part Extraction
3. Print Parts

We will only talk about Extracting parts.

Extract Parts
This option lets you create separate files for each part in your score.

To create parts using the Extract Parts method
· Choose Extract Parts from the File Menu.
· You can control which parts, and how those parts are extracted in the dialog box that 

appears. For example, highlight only those staves you want to extract. Or, apply 
engraver spacing to your parts by selecting either Beat Spacing or Note Spacing 
from the Music Spacing options. 

· Click Options for a dialog box to appear in which you can specify that the staff name 
appears as a title in the extracted parts, or specify that certain elements in the full 
score (staff names, for example) won't appear in the extracted parts. In addition, you 
can click the Page Format button to specify a page layout for the extracted parts that 
differs from the full score page layout, and specify the amount of reduction or 
enlargement you want applied to the music in the extracted parts.

· Click OK to start the extraction process. Finale creates the parts and saves them to 
your hard drive as Numbered versions of the original file.    You can also use the staff 
name group name or filename to name you extracted parts in any format you want to 
specify.    The files will be located in the same folder as the original file, unless you 
specify a different one. Now that your parts are created, you can open, edit and print 
them as individual files.

How to Contact Coda 
Music Technology

These are just a few of the many features Finale offers. For more information on Finale, 
Smart Music products, and third party Finale products visit our website at 
www.codamusic.com or call Coda Customer Service at 1-800-843-2066.



If you have technical questions, visit our forums on our website, Fax questions to (612) 
937-9760, or call at (612) 937-9703 between 11:00 am and 4: pm CST. You can also 
email us at winsupport@codamusic.com.

Coda Music Technology
6210 Bury Drive
Eden Prairie, MN 55346-1718


