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NOTE: This helpfile is best read with Acrobat 4.0.
Look on the original installation CD or go to: http://www.adobe.com

Installation

a. Insert the SmartScore CD into the CD-ROM drive of your
computer.

NOTE: You will need to refer to the Quick Keys map when editing
recognized files until shortcuts are memorized.

b. Double-click the file, SSInstall on the CD. This will begin the
installation of SmartScore. Enter your name and location.

c. We suggest making an alias of the SmartScore directory and
placing it on your desktop (highlight SmartScore folder, press
command+m and drag to the desktop).

d. Drag the sample TIF files from Sample Files directory on the
CD to the SmartScore directory. Drag the VistaScan plug-in to
the Plug-Ins folder in the SmartScore folder

e. Restart you machine and double-click SmartScore icon to
open.

Quick Tour

Since the original printing of the SmartScore manual, recognition
has been improved. Therefore, corrections outlined in the Quick
Tour have changed quite a bit. However, the sample files are still
good a practice aid for learning the program. To start with
recognizing a sample file,

a. Push the RECOGNITION icon in the Navigator found in the
middle of your screen.

b. Drag the sample file, FANDANGO.TIF to the “Recognize Files”
list. Push the Begin Recognition button.

When the file opens, turn to page 13 of the manual and begin.

http://www.adobe.com/
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Scanning Music into SmartScore

SmartScore will drive most Macintosh scanners that include
Photoshop®-type or TWAIN scanning plug-ins. We have included a
number of current ones inside Plug-Ins which can be found in the
SmartScore folder. If your scanner’s plug-in is not included, do the
following:

a. Locate your scanner’s plug-in (in Finder: go to File > Find and
look for “plug-in”).

b. Make an alias of the plug-in (command + m) and drag it to the
Plug-In folder of SmartScore.

NOTE: It may be necessary to reinstall your scanner’s software if
you cannot find the plug-in. Be certain to choose “Install Plug-
In” option.

Testing your scanner

a. In SmartScore, go to File > Scan Music > and choose your
plug-in.

b. Once selected, your scanner should begin to operate. After
having selected your plug-in, you can always initiate scanning
by pushing the Scan button of the Navigator or from the Main
Toolbar.

Navigator Button

If your scanner does support plug-ins or your scanner fails to
operate, please refer to Scanning Outside of SmartScore.
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Scanner Settings

Once your scanner’s interface is visible, you will want to establish
certain presets to acquire the right kind of image at the correct
resolution and darkness settings. All scanning software is different,
so locating the following controls may take some poking around.

Find the controls for RESOLUTION (dpi) and DARKNESS.

Resolution

For most printed music, the recommended resolution is around 350
dpi. If the original music is printed in smaller type, you can increase
resolution to 400-500 dpi. For miniature scores, try 600 dpi, but
don’t expect miracles if the music has extremely small print. It won’t
take you long to guess the optimum resolution for your printed
music by just looking at it. Scanning at too high or too low a
resolution will actually reduce recognition accuracy. It is not
recommended to scan music below 300 dpi or higher than 600 dpi.

Darkness

If the original music is faded, if it is a weak copy or if it has become
degraded, you may want to scan at a darker than normal setting.
This will “fatten up” objects on the page; allowing SmartScore to
find and recognize them easier than they would be with the default
darkness setting. To begin with, it is recommended you leave
Darkness to its default setting.

Scanning into SmartScore’s interface

SmartScore allows you to scan many pages of a score and save
them grouped into one compressed image file, a single, multi-page
TIFF file. This is done automatically in SmartScore’s own scanning
interface.

a. Place the first page of your score face down into your scanner.

b. If your scanning software has a Preview button. Push it.
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NOTE: Preview ONLY the FIRST page in your scanning program.
After the first page, you will preview only in SmartScore’s
interface.

Notice the scanning region defined in your scanner’s preview
window. The scan region is bounded by flashing dots, marching
ants or by some other obvious delineator and can be resized. The
selected region identifies the boundaries of the image passed to
SmartScore’s interface.

c. Using your mouse, drag the edges of the scan region to the
maximum limit allowed. It is very important to acquire a full-
page image at this stage. Otherwise, subsequent scans may
cut off information.

d. Press the Scan or Final Scan button in your scanning
interface.

When the page is scanned, the SmartScore scanning interface,
Image Processing window opens...

SmartScore scanning interface

The SmartScore interface has 2 automatic image-enhancement
functions.
! Auto Deskew (See Correcting Skew)

! Auto Cropping

The red crop rectangle is automatically selected by SmartScore.
Resize the cropping region using your mouse if necessary.
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NOTE:  If the preview image appears mostly black, this means
your scanner is reversing image polarity. In this case, you
will want to check the box, Invert Image, next to the
Preview window.

e. When you are ready to scan the next page, push “Next Page”.

NOTE: You must wait a few seconds after each scan before
selecting “Next Page”. This allows your scanner to reset
itself. Otherwise you may get an error message that
“Scanner cannot be found”.

f. Continue scanning more pages as described above until the
last page of the group is scanned. When done with all pages,
push Finish

NOTE: Do not PREVIEW when continuing. Simply push SCAN.

Scanning Outside of SmartScore

If your scanner does not respond to the Scan command, check that
your scanner plug-in is installed by going to: FILE > Scan Music.

The only alternative to scanning with a plug-in is to first scan
outside of SmartScore using your scanner’s software or an
alternative imaging software like PhotoshopTM (go to File>Acquire).
Then Recognize the saved images in SmartScore.

If you are using your scanner’s scanning software, follow the
following guides for scanning music:
! Place music in the scanner as squarely as possible.

! Scan in Black & White (Line Art, 1 bit or OCR) not color or gray.

! Scan between 350-400 dpi for average printed music.

! Save each scanned page as a compressed TIFF file using a
unique filename for each page... e.g. Page1.tif, Page2.tif, etc.
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Recognition: Saving and Selecting Image Files

After scanning the pages of your score, you will be given the choice
of opening the scanned images in the Image Editor or to begin

Recognition.

Post -scan navigation window

To begin recognition of the music you have just scanned,
! Push the Save As and Begin Recognition button

NOTE: Normally, you will not need to open scanned pages in the
Image Editor. Use it for such things as rotating an image
90 degrees, Correcting Skew manually or for enhancing
such things as system brackets.

Saving the Image File

a. The Save As window will open. Change the destination folder, if
necessary, and type a name you want to give to the image file.

NOTE: For Macs, it is not necessary to give an extension (such
as.TIF) to the saved image. Simply give it a familiar name.
The SmartScore file created after Recognition will assume
the same name.

NOTE: In the SmartScore scanning interface, all scanned pages
are saved as a single, multiple-page TIF file. It is not
necessary to scan and save each page separately.

Rearranging the File List

You can rearrange the order of scanned pages. For example, if you
scan more than 10 pages, may notice Page10 is listed before
Page2; or if you scanned pages out of order.
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a. Click on any page and hit Move Up or Move Down to
reposition. Hitting Remove from List will cause that page to be
skipped during Recognition.

Recognition of pre-scanned images,

a. Push the Recognize button in the Navigator or select Scan from
the Main Toolbar.

Begin Recognition / File Selection window

b. Pop open a folder containing pre-scanned images and drag the
image(s) you want recognized to the selected files list of the
Begin Recognition window.

NOTE: You may also use Finder to locate image files by selecting
Add to List.

c. To begin recognition of a page group, select Begin
Recognition.

Recombining multiple scan files (Page Groups)

If one page of a scanned group is incorrectly scanned or is missing
altogether from a multi-page image file (Page group), you may
reselect individual pages to form a new page group.

a. Drag the original multi-page file to the selected files list of the
Begin Recognition window.

b. Highlight a page to remove and push Remove from List.

c. To add a replacement page to the original page group, drag the
page(s) to the selected files list.

d. Reorder pages as necessary and push Save As to save the
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new page group.

NOTE: It is necessary to select Save As before selecting Begin
Recognition. if a page group has been rearranged.
Otherwise, changes to the page group will be lost.

Recognition and Recognition Accuracy

NOTE: If recognition accuracy is poorer than expected, examine
the file in the Image Editor. Zoom in and determine the
following:

! Refer to Scanner Settings.

! If objects lack detail, rescan with increased resolution.

! If objects such as note stems and staff lines are broken or lack
thickness, rescan with increased darkness.

! If stafflines or systems are missing see Auto Cropping, Manual
Crop and Scanning into SmartScore’s interface.

! If  the image of music appears crooked, you may correct it
manually in the Image Editor.  See Correcting Skew.

Editing an Image file

To open an image file (.TIF,.BMP, .PCX, etc.),

a. Choose Open (Command + O) from the File menu OR press
the Open button on the Navigator.

b. Select Image files from the Files of Type pull-down menu.

c. Highlight an image file from the listed saved files. Press Open.

Zoom

To Zoom in and out click the Zoom Tool in the Main toolbar
(Command + Q). Left-click will increase the scale of your view
(Zoom In), while right-click will decrease the scale of your view
(Zoom Out).
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Page

To view a different page of an image file, go to the View menu and
select Next Page/ Previous Page OR use the paging buttons
located in the Image Toolbar.

Correcting Skew

To correct the skew of an image file, select Line Draw icon. Then
select Deskew from the Edit menu.

Click, hold and drag a deskew line along a stave. Release the left
mouse button and image straightens along the deskew line.

Crop

To crop an image file by trimming unwanted portions of your image
from outside a marked frame, go to the Edit menu and choose the
Selection option OR press the Select button in the Image Toolbar.

Click, hold and drag a box around the area to be marked off.
Release the left mouse button to set the box.

To resize the marked off area, move your mouse cursor over a
boundary line, Click, hold and drag the boundary to any position.

To crop the selected area, select Crop from the Edit menu OR
press the Crop button in the Image Toolbar. The resulting image
will be only the area inside the marked frame.

Rotate

To rotate an image file (landscaped scores), go to the Edit menu
and highlight Rotate OR press one of the Rotate buttons in the
Image Toolbar.
! Rotate the image 90 degrees to the Left

! Rotate the image 90 degrees to the Right

! Select Any degree of rotation for the image file.

! Check the Clip Image Mode to maintain the original page size
and orientation of the image file. Part of the image may be cut
off.
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! Expand Image Mode changes the page size to include the
entire image.

Transparent Background

To Cut or Copy the marked off area of an image file with a
transparent background, highlight Selection Mode from the Edit
menu and select Transparent.

Invert

If the image you open in SmartScore is white-on-black (instead of
the normal black-on-white), then you should reverse the image
output in your scanning software. SmartScore defaults to 0=white
polarity.

Drawing Tools

•  Paint Brush

To draw free hand lines in your image file, select Brush from the
Edit menu OR press the Brush button in the Image Toolbar. Click,
hold and drag to paint.

•  Lines

To draw straight lines in your image file, select Line from the Edit
menu OR press the Line button in the Image Toolbar. Click, hold
and drag to create a straight line. Release the left mouse button to
place the line.

•  Pen Options
! Color

To choose the color used when drawing, highlight Pen Color from
the Edit menu and choose Black or White.
! Width

To change the width of lines when drawing, select a new size from
the Width pull-down menu in the Image Toolbar.
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Cut / Copy and Paste

•  Cut

To Cut a marked off area from the score and place them on the
clipboard, left-click and drag a box with the Select Tool . Go to the
Edit Menu and select Cut (Command + X).

•  Copy

To Copy a marked off area to the clipboard without removing it from
the score, left-click and drag a box with the Select Symbols/ Area
Tool. Go to the Edit Menu and select Copy (Command + C).

•  Paste

To Paste the contents of the clipboard into an image file, select
Paste (Command + V) from the Edit menu. Click, hold and the drag
the contents of the clipboard anywhere in the image file. To drop
the clipboard contents into position release the left mouse button.
To Paste the clipboard contents click outside the marked off area.

Quick Copy and Paste

To quickly copy and paste any section of an image file, mark off an
area with the Select Tool . Click and drag the marked off area
anywhere in the image file. To position the marked off area release
the left mouse button. To Paste the marked off area, click anywhere
outside the box.

Scanning Score Parts

SmartScore can process both kinds of score types; Ensemble and
part. Ensemble scores have grouped staves representing two or
more instruments (or hands) playing simultaneously. Part scores
are sets of pages where each set represents a single instrument. In
an orchestra, the instrumentalists read from score parts and the
conductor reads from an Ensemble score. For more information on
score types, see Score Formats and Scanning Score Parts on how
to scan them.
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NOTE: SmartScore will create part scores automatically by
appending newly recognized files to any open ENF files. If
you have open ENF files that you do not want to append
to the newly recognized score to open ENF files, close
them first.

Scanning score parts will be similar to scanning Ensemble scores.
The only difference will be to group pre-scanned sets of music into
“Score Parts”.

a. Scan each set of parts and save each with a unique filename
such as “Flute Part” and “Guitar Part”.

b. Highlight selected page scans by left-clicking on the saved
names until all the pages belonging to the first part are
highlighted.

c. Push Group to Part. This action groups all selected pages into
one Score Part.

! When all score parts are grouped, press Begin Recognition to
start processing. Each part will be compiled and identified as
discrete score parts when the ENF document is created.

ENF Editing

NOTE: Refer to the Mac Quick Keys chart inserted in the
SmartScore box.

Creating a New ENF Score

To create an empty ENF score using one of the 13 basic templates

a. Push the Score button on the Navigator or select New > New
ENF under the File menu or (Command + “N”). The New
SmartScore Document window will open.

b. Type in a Title for the new score.

c. Add the Composer’s name for the first page score header.

d. Press the Page Setup button to change the basic page layout
of your score. See Page Set-up for details.
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! Tempo will set the metronome for display in ENF and for
playback.

Uncheck the Insert Clef Signs to create an ENF document without
clefs.

NOTE: Settings are only available for adjustment when creating
a Custom Score.

Using Built-in Templates

SmartScore has 13 preset templates including basic piano,
piano/vocal, several chorale formats, quartets and a 16-instrument
orchestra format.

To select a preset score template:
! Go to the Score pull-down menu and select a preset System

Type.

Custom Scores

To create a Custom Score:

a. Select Custom in the System Type in Score pull-down menu.

b. Use the Settings options to define your Custom score
structure.

c. Staves per System is used to determine the number of staves
that will appear in each system.

d. Set the Number of Systems the new ENF document will have
per page.

! The Stave Spacing sets a uniform distance between each staff
within a system.

! System Spacing determines the distance between the bottom
of one system to the top of the next system.

! Apply a uniform Stave Size to each stave of your score.
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Out of Scanning and Recognition

To create an ENF file from scanned images of printed sheet music,

a. Push the Recognition button on the Navigator or select
Recognition under the File menu. The Begin Recognition
window will open. Press the Add Files to List button. Browse
through your directories and select any scanned image file(s)
for Recognition.

b. Press the Begin Recognition button to start SmartScore’s
recognition process.

c. After Recognition is complete, a Save As window will open.
Save your new ENF file.

NOTE: For more detailed information on the recognition process,
see Out of Scanning and Recognition.

Active Staffline

In SmartScore, only one staff can be edited at a time. The active
staff is the staff in which editing is allowed. The active staff can be
highlighted or not. If highlighted, all other (inactive) staves will be
grayed out.

To allow every staff to display in color or in black (see Color Mode),
! go to the Options menu and uncheck Show Active Staff.

TIP: Move the cursor to a different staff to make it Active. Hold
down the Control (Ctrl) key to maintain the Active staff
for extended score editing.

NOTE: Staff colors may be changed depending on whether the
color base is Voice or Part. See Color Mode.

Zoom

To Zoom in and out,
! Click the Zoom Tool in the Main toolbar (Command + Q).

! Left-click will increase the scale of your view (Zoom In), while
right-click will decrease the scale of your view (Zoom Out).
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Go to…

You can quickly jump to any page, measure, or score part of your
ENF file during editing.

To open the Go to… window

a. Choose the View menu and select Go to Page (Command +
G).

b. Select whether you want to jump to a particular Page, Measure,
or Score Part.

c. Determine which Page, Measure, or Part you want to go to.

d. Checking the Open Target in New View box will open a new
ENF at the targeted Page, Measure, or Score Part.

Paging

To view a different page of an ENF document,
! Go to the View menu and select Next Page/ Previous Page

! OR use the paging buttons located in the Image Toolbar.

Measure Numbers

There are several options for displaying measure numbers in an
ENF file. Under the Options menu, highlight Measure Numbers.
! Selecting None removes all measure numbers from the ENF

file.

! Selecting Every Staff displays a measure number for the first
measure of each system only.

! Selecting Every Measure displays a measure number at each
Barline .

Part Names

To display the part name for each staffline,

a. Go to the Options menu and select Show Part Names.

b. Selecting Abbreviations displays Part Names in the first system
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and the Part Abbreviation in subsequent systems.

NOTE: For information on setting and modifying Part Names, see
Instrument Templates.

c. Selecting Show Part Names and Numbers displays Part Names
in the first system and the Part Numbers in subsequent
systems.

d. Selecting Do Not Show removes all Part Names and labelling
from the ENF display.

Tiling

SmartScore allows for multiple ENF and MIDI windows to be open
at the same time.

To display every open windows for simultaneous viewing
! Press the Tile button on the Navigator, the Tile button in the

Main Toolbar, or go to the Window menu and select Tile.

Colors and Color Modes

SmartScore uses 2 base modes for visualizing your music as well
as for controlling how MIDI data is handled. Each mode results in
different characteristics of how notes are displayed and how MIDI
channels are divided.

NOTE: Changing the Color Mode can be done at any time while
an ENF window is open and active.

TIP: When Color Mode = Voice, a discrete MIDI channel for
each voice of each staff is created as well as displaying a
different color for each Voice. For simplicity, the default
setting is Part > Black.

Each mode employs a different color display depending on whether
you want the smallest subdivision of the ENF document to be
Voice-based or part-based: Part is staff-based and more general.
Voice is Voiceline-based and more detailed. Color Mode > By
Voice assigns one of 4 colors per staff to each Voiceline. By Part
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has two different options. Color assigns one color per part (per
staff) and Black displays all parts in black.

To select or change the color base for an open ENF score
! Go to Options > Color Mode

•  By Part

Each part of your score is displayed in a separate color or in black.
Color is particularly helpful in orchestral scores; for keeping “visual
track” of instrumental parts. When base color = Part, each staff is
assigned a discrete MIDI channel. The default colors can be
changed. See Define > Part Color below.

•  By Voice

In this mode, each voice is displayed in a different color, with up to
4 color voices per staff. Voice-1 = black, Voice-2 = red, Voice-3 =
green, and Voice-4 = blue. Each voice can be assigned unique
MIDI parameters including instrument, channel, panning, etc.
Instrument Templates for more about assigning MIDI parameters
and see Out of Scanning and Recognition about converting music
from the ENF environment into the MIDI sequencing environment.

NOTE: Each Voiceline in a given measure should be completely
accounted for in this way: The sum of all its note and rest
durations should equal the current time signature. Very
often with printed sheet music, the above rule is not
followed either because of oversight or outright defiance
of the rule. SmartScore requires voicelines to be properly
filled in if playback is to sound correct.

TIP: If measures in the original music contain incomplete
Voiceline, add rests in the appropriate places to “fill-in”
voicelines until the total of note and rest durations equal
the time signature.

To control other color options,
! Go to the Main Menu > Options > Define > Part Color
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! Change the color of how each Part and associated MIDI track
appear.

•  Background Color

To change the background color of the TIFF or ENF window,
! Go to the Options menu and select Options > Color > Define >

Background and choose Image Color or ENF Color.

ENF Editing Modes

You can select any editing mode from the your computer keyboard
(See Quick Key Card) or from the SmartScore Toolbar.

Insert and Change Modes

Press the “C” key of your computer keyboard to toggle between the
Insert and Change modes. Notice how this changes the
appearance of the cursor. In the Insert mode, the cursor becomes
the selected object. In the Change mode, the cursor becomes an
arrow with the selected object next to it. The Change and Insert
icons in the Toolbar alternate as well.
! Insert mode allows you to insert objects while clicking anywhere

in the active staffline.

! Change mode allows you to change existing objects to the
selected notation object.

Delete by Group/ Delete Any Modes

Press the “X” key of your computer keyboard to toggle between the
Delete by Group and Delete Any modes.

In the Delete by Group mode, the cursor becomes an arrow with
the selected object next to it in grey. In the Delete Any mode the
cursor become an arrow with an “X” next to it.
! Delete by Group mode removes any object that is selected

from this Tool Palette.

! Delete Any mode removes any notation object that is clicked
with the mouse.
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Tool Palettes

The notation objects used in SmartScore are selected from one of
several Tool Palettes. The “Notes” palette is always open in
SmartScore.

TIP: To quickly select any available Tool Palette, Hold the “alt”
key while clicking on any open Tool Palette. A side menu
will open listing all the available Tool Palettes. This works
only when Palette mode is in the Recycle (default) mode.

! Show All opens all 10 SmartScore Tool Palettes.

! Hide All removes all Tool Palettes from view.

! Reset (F1) returns the SmartScore display to its default open
palettes: Notes and Rests.

! Recycle Right-clicking on any open palette will open all palettes

You may also select these options from View > Palettes in the
main menu.

Quick Keys

•  QuickSelect

Hold the Control (Ctrl) key down and click on any object in the ENF
window. Notice the cursor becomes that object and is active for
editing.

TIP: Usually the fastest way to select any object is to
QuickSelect it. Ctrl + Click makes the cursor inherit all of
the object’s attributes.

TIP: Refer to the QuickKeys map for a graphic depiction of all
SmartScore keyboard shortcut keys.

•  Tool Palettes

Use the Function Keys (F2-F9) along the top of your computer
keyboard to selected any of the available Tool Palettes. F1 will
reset the SmartScore display to the default open Tool Palettes
(Notes and Rests).
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•  Dot of Prolongation

Hit the “D” key. This toggles between Insert a dot and Delete a dot
modes. Notice how the cursor alternates between a solid insert dot
and grayed-out delete dot.

•  Ties

Hit the “V” key. This toggles you between the solid Insert tie and
grayed-out Delete tie modes.

•  Beam Direction

With any single flagged note selected, hit the “A” key. This toggles
between Begin beam, Middle beam and End beam note
configurations.

•  Flags and Beams

The “F” key toggles between flagged and beamed notes for
Inserting or Changing notes.

•  Stem Direction

In Insert mode, toggle the “S” key to change the default note stem
direction.

To place a note with a stem in the opposite direction of the cursor,
! Hold the “alt” key and click while in Insert mode. In Change

mode, holding the “alt” key and click on a current note reverses
its stem direction

TIP: Use the Select Tool  select several notes at one time.
Press the “S” key to quickly reverse the stem direction of
every selected note.

•  Note Values

To quickly select note duration values,
! Use the keyboard quickkeys number: 1 = whole note, 2 = half

note, 3 = quarter note, etc.

! Hold down the SHIFT key and a number key to select an
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Accidental: 1 = flat, 2 = natural, and 3 = sharp.

! Press the “R” key to automatically select a quarter rest for
editing. “Shift” + “R” will select an eighth rest. The “Rests”
palette will open as the secondary palette.

•  Barline

Hit the “I” key to select a standard barline for editing. The “Barlines
and Repeats” palette will open as the secondary palette.

•  Dynamics
! Press the “P” key to select p (piano) dynamic marking.

! Hold down “Shift” and “,” to select the crescendo hairpin.

! Hold down “Shift” and “.” to select the decrescendo hairpin.

The “Dynamics” palette will open as the secondary palette.

•  Tuplets

The “T” key activates the Tuplet Tool. Triplets are selected as the
default. Drag the mouse to box the desired notes as a tuplet. The
“Rhythmic Groups” palette will open as the secondary palette.

•  Select Tool (Symbols or Area)

Hit the “O” key (or the Select icon in the ENF Menu icon toolbar) to
activate the Select Tool for Cut / Copy and Paste operations.

•  Unify Signatures / Clefs

Press the “U” key to automatically open the Unify Signatures and
Clefs  window. This will unify Key and Time signatures or Clefs
throughout the entire score.

•  Vertical Alignment

Music often contains notes which are not vertically aligned, but
which ought to sound simultaneously. Such notes are horizontally
offset in order to better show multiple Voices in close proximity.
Applying Vertical Alignment to offset notes will cause grouped
notes to play simultaneously.
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To Vertically Align notes in a score,
! Use the Select Tool to highlight the notes. Press the “Y” key to

group the selected notes into a single vertical event.

TIP: You can quickly group and vertically align notes using a
simple combination of the “O” key (Select tool) and then
using the “Y” key (Apply Vertical Event). This will be
particularly helpful in fixing solo guitar music which often
contain such offsets.

•  Split Voice

To separate two notes of a chord,
! Use the Select Tool to highlight the notes. Press the “H” key to

separate the selected notes into two separate voices.

•  Delete Multiple Ties

To delete all ties from a selected area,
!  Use the Select Tool  to highlight a section of the score. Press

the “G” key to remove the unwanted ties.

•  Beam Flagged Notes*

Flagged notes can be transformed into a single beamed sequence.
Flagged notes do not have to be of the same rhythmic value to be
grouped into a beamed group. Use the Select Tool  to select the
flagged notes. Press the “B” key to group the selected notes into
one beamed sequence.

Editing Notes

•  Inserting, Changing and Deleting

To insert a note anywhere in the active staffline,

a. Toggle the “C” key to activate the Insert mode.

b. Select any note from the “Notes” palette.

c. Click anywhere in the active staff to drop.
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To change the rhythmic value of an existing note,

a. Toggle the “C” key to the Change mode.

b. Select any note value from the “Notes” palette.

c. Click on the notehead of any existing note to change.

TIP: Use QuickSelect (Cntl + Click) to quickly select any
existing note. The cursor will inherit the value of the
selected note.

To Delete any note,

a. Toggle the “X” key to Delete Any mode

b. Click on any note.

•  Stem Direction

Default stem direction of an inserted note is determined by its
vertical position on the staff. Stem direction of inserted notes
automatically changes when the cursor crosses the middle staffline.

To reverse the stem direction while inserting a note,
! Toggle the “S” key to change the default stem direction. Result:

stems up above the middle line, stems down below the middle
line.

or
! Inserting a note while holding the “alt” key will reverse the

default stem direction:

To change the stem direction of an existing note,

a. Toggle the “C” key to activate the Change mode

b. Hold the “alt” key while clicking on any given notehead. The
stem direction will change.

NOTE:  Stem direction is essential for Voice separation. Voice-1
should have stems up and Voice-2 should have stems
down.
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To change the stem direction of several notes at once,

a. Toggle the “O” key to activate the Select Tool

b. Left-click and drag a box around any series of notes.

c. Press the “S” key to reverse the stem direction of the
highlighted notes

•  Pitch

To change the pitch of any note,
! hold down the “Shift” key, left-click and drag the note.

To change the pitch of several notes at once,
! Toggle the “O” key to activate the Select Tool

! Left-click and drag a box around any series of notes.

! Hold down the “Shift” key, left-click and drag the notes

NOTE: You will not be able to slide notes left to right. To
reposition objects horizontally, you will need to delete and
re-insert them.

•  Beaming Notes

With any flagged note selected, choose one of the beam direction
buttons (A) from the “Notes” palette. Click anywhere in the active
staff to insert the beamed note. Beamed notes automatically
connect to one another.

Use the End beamed note to “close” a beamed group.

•  Grace Notes

While in Insert mode, select a rhythmic value and press the grace
note button in the “Notes” palette. Click before any note in the
active staff to insert a grace note. ENF playback will insert the
grace note and truncate the duration of the following note.
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•  Chords (Cluster Tool)

To activate the Cluster Tool

a. press the Cluster Tool button (Z) in the “Notes” palette.

b. While in the Insert mode, click above or below an existing note
to Insert a new note along the stem. The new note inherits the
same duration of the original note.

To Delete a note from a chord,
! press the “X” key with the Cluster Tool active and click on any

note to remove it from the chord.

•  Dots of Prolongation
! While in the Insert mode, select a single (D) or double dot from

the “Notes” palette.   Click on any note head to attach a dot of
prolongation.

To Delete a dot of prolongation, press the “D” key again and click the
notehead.

Editing Voices

Voices appear in ENF as all black notes or as black, red, blue and
green notes depending on which Color Mode is selected.

•  Voice Assignment

When Note Color is displayed By Voice, the voice assignment of a
given note can be changed. See Polyphony and Voiceline for
descriptions. For more details on voice/part colors, see Color Mode.
! Press the Voice Line button located in the SmartScore Toolbar

and select a voice assignment. Click on any notehead or rest to
assign it to the selected voice.

•  Voice Splitting

To separate a two note cluster to two separate voices,

a. Toggle the “O” key to activate the Select Tool

b. Left-click and drag a box around any two note cluster
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c. Press the “H” key to separate the clustered notes as individual
voices (stems-up and stems-down

Rests

To add a rest anywhere in the active staffline,
•  Toggle the “C” key to the Insert mode

•  Select any rest from the “Rests” palette.

To Insert a multi-measure rest,
•  Select the “n-measures” object from the “Rests”

palette.

•  Select the number of empty measures

•  Click anywhere in the active staffline.

TIP: To adjust vertical placement of a rest, hold the SHIFT key
down, left-click and drag the rest up or down.

To Change the rhythmic value of a rest,
! Select a rest from the “Rests” palette.

! Click on an existing rest.

To Delete a rest,
! Toggle the “X” key to Delete Any mode.

! Click on the rest.

Accidentals and Articulations

While in the Insert mode, select any accidental or note specific
articulation (staccato, accents, etc.) from the “Notes” or
“Articulations” palette. Click the notehead that is to receive the
marking.

A courtesy accidental is one placed inside parenthesis and acts as
a “reminder” but does not change the pitch of the note.

To Insert a courtesy accidental,
! press the parenthesis button when any accidental is selected

before clicking a notehead.
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To Change an accidental or note specific articulation,
! select a accidental or articulation from the “Notes” or

“Articulations” palette and click on the notehead.

To Delete an accidental or note specific articulation,
! press the “X” key and click on the notehead.

Barline

While in the Insert mode select any barline from the “Barlines &
Repeats” palette. Click anyway in the active staffline to Insert the
barline.

To Change a barline,
! select a barline from the “Barlines” palette and click on a barline.

Press the “X” key and click on the barline to delete it.

Repeats and Multiple Endings

•  Repeats

While in the Insert mode, select any repeat from the “Barlines &
Repeats” palette and click anyway in the score to place the repeat
barline.

While in the Change mode, click on any existing barline to Change
it to the selected repeat barline.

•  Multiple Endings

a. To create a multiple ending, select the Start Alternate Ending
button from the “Barlines & Repeats” palette. While in the
Change mode, click the first ending barline. Change any barline
into a repeat barline for the end of the first ending

NOTE: SmartScore will automatically switch to an End Alternate
Ending barline (a repeat) for the first ending.

b. To create a second or third ending, select the Start Alternate
Ending button and click the barline of the first measure of the
second ending. In many cases, this is the last barline of the first
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ending. Change a barline into an End Alternate Ending barline

c. Repeat these steps as necessary.

•  Starting at the Segno

To begin a repeat at the Segno

a. Select d.s. (Dal Segno- from segno) from the “Barlines &
Repeats” palette.

b. Insert the d.s. marking in any measure.

c. Select segno from the “Barlines & Repeats” palette.

d. Insert the segno into the measure that begins the repeated
section.

•  Ending at the Segno

To repeat from the beginning of the score and end at a segno

a. Select d.c. al segno (Da Capo al segno -from the beginning to
the Segno) from the “Barlines & Repeats” palette.

b. Insert the d.c. al segno marking into any measure.

c. Select segno from the “Barlines & Repeats” palette.

d. Insert the segno into the measure that ends the repeated
section.

•  Fine

To repeat from the beginning of the score and end at a fine;
! Select d.c. al fine (Da Capo al fine -from the beginning to the

fine) from the “Barlines & Repeats” palette.

! Insert d.c. al fine into any measure. Select fine from the
“Barlines & Repeats” palette.

! Insert the fine into the final measure of the score.
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•  From a Segno

To repeat from a segno and end at a fine,;
! Select d.s. al fine (Da Segno al fine -from the segno to the fine)

from the “Barlines & Repeats” palette.

! Insert d.s. al fine into any measure. Select segno and Insert it
into any measure.

! Select fine and Insert it into the final measure of the score.

Ties

While in the Insert mode, Press the “V” key and click the first note
of the pair to Insert a tie with a downward arc. To insert a tie with an
upward arc, hold down the “alt” key while clicking. The “group-tie”
(double tie) will tie noteheads of chords together.

To delete a tie, press the “V” key again and click the first note of the
pair.

Slurs and Tuplets

While in the Insert mode, select a legato from the “Articulations”
palette or a tuplet (T) from the “Rhythmic Groups” palette.
! Click and drag down to insert the tuplet or legato above the

notes.

! Click and drag up to insert the tuplet or legato below the notes.

! Press the “X” key and click on the tuplet to delete it.

Dynamics and Tempo Markings

To Insert a Dynamic or Tempo marking:
! While in the Insert mode, select a dynamic or tempo marking

from the “Dynamics” or “Tempo” palette. Click anywhere in the
Active staff.

To change a dynamic or tempo marking,
! select a marking from the “Dynamics” or “Tempo” palette and

click the existing marking.
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To delete a dynamic or tempo marking,
! press the “X” key and click on the marking.

Crescendos, Decrescendos, and Trills

To create a crescendo, decrescendo or trill marking,
! Toggle the “C” key to the Insert mode

! Select a dynamic hairpin or trill from the “Dynamics” or
“Articulations” palette.

! Click and drag a box to determine the length and height of the
crescendo/decrescendo.

To delete a dynamic hairpin or trill
! Press the “X” key and click on the notation object.

To insert a trill,
! Select a trill type from the Articulations palette.

! Click and drag a box to determine the length of the trill

Clefs

While in the Insert mode, select a clef from the “Clefs” palette.
Click anywhere in the active staff to insert the new clef.
! To change a clef, select a clef from the “Clefs” palette and click

the existing clef.

! To delete a clef, press the “X” key and click on the clef.

! Select Unify Signatures and Clefs (U) from the Options menu.
See Unify Clefs on how to update clefs throughout the
remaining systems.

Time and Key Signatures

Select a time or key signature from the “Signatures” palette. In
Insert mode, click in the region following the clef to insert a new
signature.

To change an existing key to time signature to another one,

a. select the desired signature from the tool palette.
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b. Hit the “C” key to toggle to the Change mode.

c. Click on the signature to be change.

TIP: Select Unify Key and Time (U) after recognition or after
changing or inserting a new key signature. See Unify
Signatures and Clefs  for more details on this function.

To insert a new key or time signature,
! Click immediately following any Barline .

Changes of key and time signatures that begin on a new line MUST
be indicated at the END of the previous line. This conforms to
standard musical notation practices.

To Insert a new key or time signature that begins a new line,

a. Insert the new key or time signature at the end of the previous
system in the topmost staff. Ensure the following conditions are
met:

b. A bar line must precede the new signature.

c. There must be no bar line after the new signature.

d. The new signature must reside ENTIRELY within the 5
horizontal stafflines (at least ¼” inside the end of the line).

To change a signature,

a. Select a signature from the “Signatures” palette

b. Press the “C” key to toggle to the Change mode.

c. Click on an existing signature.

To delete a signature
! Press the “X” key and click on the signature.

Unify Signatures and Clefs

To update all signatures and clefs based on a selected staff or system,
! Press the Unify button on the Navigator, the Unify Signatures

button in the SmartScore Toolbar or go to Options menu (U)
and select Unify Signatures.
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NOTE: Use Unify to update the ENF file after recognition or after
a clef, key or time signatures has been Inserted or
Changed

Check the Insert Empty Rests box to Insert a whole rest into any
empty measures.

Unify Key and Time Signatures

•  Based on Topmost staffline

Updates all key and time signatures to that of the first staffline,
starting with the first measure of the first page.

•  Based on First System

Updates all key and time signatures based upon the first measure
of each staffline start with the first system of the first page. Any
changes in key or time signatures update the score as they are
encountered.

Unify Clefs

•  Based on First Measure of Active System

Updates all clefs based upon the first measure of each staff in the
active system. Overwrites any change of clef found.

•  Parse Every staffline

Updates each staffline individually. Any change of clef encountered
updates that staffline until another change of clef is encountered.

Instrument Templates

Each staffline in an ENF document is assigned an Instrument
Template whether created out of Recognition or from scratch.
Instrument Templates contain basic MIDI parameters for playback
and default Part Name assignment.
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To modify an existing template or add a new template,

a. Hit (Command + T) or go to the Edit menu

b. Select Instrument Templates.

c. Use the Name pull-down menu to select one of twenty-three
preset Instrument Templates or type in a unique name for a
template.

The Instrument pull-down menu lists all General MIDI Instrument
Assignments.

d. Assign a MIDI Channel for each Template.

e. Select MIDI Port A or B for a Template.

f. Set the playback Transposition for each Template.

g. Push the Add button to create a new Instrument Template.

The Abbreviation listed will be displayed in the score when Options
> Part Names > Abbreviations is selected

Master System

The Master System controls system and staffline spacing, part and
voice visibility and MIDI instrument assignments. The largest
system of an ENF score (the system with the most parts) is the
basis for the Master System. An important component of the Master
System is Logical Part Linking for reassociating systems that
collapse and/or expand in the ENF display. Changes to any or all of
these features can be applied to the currently active system, to all
subsequent systems or to the entire score.

Parts run vertically along the left-hand side of the Master System
window while Voices run horizontally along the top of the Master
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System window.

Master System

To open the Master System window,
! Press (Command + M) or go to the Edit menu and select

Master System.

The Controlling System is the system whose values are displayed
in the current Master System window. The choices are

•  Master (the ENF system which contains the most stafflines)

•  Active (the ENF system in which the cursor is located)

TIP: To verify which system is active, turn on Options > Show
Active Staff.

Active and Master systems may have completely different values.
Be certain changes you apply are derived from the correct
controlling system.

The Apply To selection applies changes made to Part and Voice
Visibility, Part Names, Voice assignment, and Staff and Line
Spacing to:

•  System (The currently active system)

•  System+ (The currently active system and all subsequent
systems)

•  Score/Part (The entire score or Score Part)

•  Master System (Applies changed values to the Master System)

To apply changes,

•  OK to apply changes to the current ENF document

•  OK-New to apply changes in a new ENF document without
affecting the original document.

TIP: Select correct voice, check Voices and push OK-New to
selectively extract Voices from a score.
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Part Names

Part Names are inherited from Instrument Templates but they can
be changed in the Master System.

To modify a Part Name,

a. Left-click in the name column.

b. Type a new name.

OR

c. Select New Part from the Part Name pull-down menu

d. Use the Instrument Template window to create a new template
for the selected part. See Instrument Templates.

To create or remove parts,

a. Choose Master System as the Controlling System.

b. Click on to highlight a Part.

c. Press Insert Above to add a Part above the selected Part.

d. Press Insert Below adds a Part below the selected Part.

e. Press Remove to delete the selected Part.

Collapsing and Expanding Systems

Many scores have parts that do not play for long periods of time.
Rather than string line after line of empty Measures together for
each silent part, most scores “collapse” systems so they only show
actively playing parts. Similarly, instruments may appear briefly or
split into two or more parts themselves causing systems to
“expand”.

Visibility

Parts or voices can have their visibility “removed” from an active
system, subsequent systems or from the entire score by checking
or unchecking the visibility boxes assigned to each.
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•  Part visibility

To change Part Visibility,

a. Check or uncheck the Visibility box next to a Part Name to
remove or restore the visibility of that Part

b. Select a specific scope in the Apply To window).

•  Voice visibility

To change Voice Visibility,

a. Highlight a visible part by clicking on its Part Name.

b. Check or uncheck the Visibility box below the desired voice

c. Apply to the specified scope (Apply To window).

Voice Assignments

Voice assignments are inherited from Parts Names as set in the
Instrument Templates window. Each Part inherits an instrument
abbreviation linked to the MIDI instrument assigned in Instrument
Templates.

To change Voices,
! select an alternative in each of the pull-down menus.

Spacing

•  Line

Line spacing is the distance between stafflines of the listed Part (in
pixels).

To change line spacing,
! enter a new value and apply it to the currently active system,

system+ or score.
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•  Staff

Staff Spacing is the distance between the staff of a listed Part and
the Part immediately below it. To change line spacing, enter a new
value and apply it to the currently active system, system+ or score.

Bracketing

To add brackets to a score,
! go to the Edit menu and select Bracketing.

! Select the staves to bracket together by left-clicking and
dragging in the Part List window.

! Choose a Brace (yellow)or Grand Staff (green)

! Use Clear to remove a bracket from the selected parts

Logical Part Linking

Each Part Name represents a direct link to a MIDI track. The
number of Parts in the Master System will equal the number of
tracks in the subsequent MIDI file.

Logical Part Re-linking

When the Controlling System = Active, the Part Visibility check
boxes mark which Parts SmartScore assumes are being displayed
in the active ENF system. This order may or may not be correct.

To change the part link of any active system,

a. Select Edit > Part Linking (Command + L)

b. Uncheck any incorrect Part Links
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c. Check the actual Part Links

d. A New Part can be assigned from the Part Name pull-down
menu

! Use the Instrument Template window to create a new template
for the selected part. See Instrument Templates

To apply the part change,
! Select Apply To = System to change only the active system.

! Select Apply To = System+ to change the active system and all
subsequent systems.

NOTE: The number of checked Part Links must be the same as
the number of visible parts in the active system

Transposition

To Transpose all or part of your ENF file,
! press the “E” key or the Transpose button in the SmartScore

Toolbar or go to the Edit menu and select Transpose.

Transpose Window

Transposition Type > Change Key

To change the key of the current ENF document,

a. Select a new key for the score using the Key Signature
scroller.
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b. Scroll up to select a key signature with sharps or scroll down to
select a key signature with flats.

c. Choose to move the transposed notes Up or Down.

d. Uncheck the Move Notes box to leave the notes in their
original positions.

Transposition Type > Change Pitch

Transpose the notes of your score without changing the key
signature by selecting the number of half-steps to move each note.
Pitches are moved by a uniform interval.

Range

Determine the scope of the transposition.

•  Entire Part

Will transpose from Measure 1 through the entire score.

•  Selected Area (defined with the Select Tool )
! Range of the Transposition by selecting the first and last

measures to be transposed.

•  Part/ Voice

NOTE:  Transpositions are not limited to the entire score.

! Select All Staves to Transpose every part.

! Any Part can be individually Transposed without affecting the
other Parts.

! Choose to Transpose every voice or an individual voice of a
staff with the Stave Voice pull-down menu.

NOTE: Transposition accounts for any changes of key
encountered in a score. For example: A duet for a flute
and B-flat clarinet is written in the Concert Key of C Major.
At Measure 10, the Concert Key changes to D Major.
Upon Transposition of the clarinet part to the correct
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written key(s), the clarinet part will display in D Major, with
a change to E Major at the 10th Measure.

Cut / Copy and Paste

•  Cut

To Cut the highlighted notes from the score and place them on the
clipboard,

a. Select the Symbols / Area Tool (O) from the Toolbar.

b. Left-click and drag a box with the cursor.

c. Press Command + X or select Cut from the Edit menu.

•  Copy

To Copy the highlighted notes to the clipboard without removing them
from the score,
! left-click and drag a box with the Select Tool . Go to the Edit

Menu and select Copy (Command + C).

•  Select Area

To Copy an area of an ENF file for Pasting into another application
(Microsoft™ Word®, Adobe™ Photoshop®, etc.),
! With the Select Tool , drag a box around the desired area.

Select Edit > Copy (Command + C). The selected area is
Copied to the clipboard and can be Pasted into another
application.

•  Paste

To Paste the contents of the clipboard into an ENF file,
! Select Paste (Command + V) from the Edit menu and click

anywhere in the score. The contents of the clipboard will be
added to the score without replacing the existing notes.
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•  Paste Replace

To Paste the contents of the clipboard into an ENF file in order in order to
replace selected notes,
! Select Paste Replace (Command + R) from the Edit menu and

click anywhere in the score.

TIP: Use Paste Replace to quickly correct a mis-recognized
Measure that is identical to another measure in the score.

Score Header

To create or modify a Score Header for the first page of the ENF file,

a. Select Score Header from the Edit menu.

b. Type in the Title for the score.

c. Add the Composer’s name to score header.

To create a Part Name for a Part Score, see Score Formats.

Tempo Marking

To add a Metronome Marking to your score,
! select Tempo from the Edit menu.

Realtime Playback

To playback an ENF file,

a. Press the spacebar to Play.

b. Press again to Pause.

c. Press again to resume Play.

or go to Realtime in the Main Menu

a. Select Play.

b. Select Stop

c. Rewind resets playback to the beginning of the playback
range.
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Playback Console

To open the Playback Console for ENF playback control of MIDI
instruments,
! Select Realtime > Console (Command + 9).

! Play button plays the active ENF file. Once playback has
begun, the Play button becomes Pause. Pause will stop
playback without rewinding to the beginning of the score.

! Stop button stops playback of the ENF file.

! Rewind button resets playback to the beginning of the playback
range.

! Record button.

For details on MIDI Recording see MIDI Recording.

Adjustable Real-time Settings

! Scroll to any beat in the score using the Measure / Beat slider
for playback.

! Adjust the overall or individual volume of playback with the
Volume sliders.

! Use the Port pull-down menus to select the MIDI output Device.

! Adjust tempo with the Tempo slider.

! Change MIDI Instrument or Channel of any voice.

! the file globally or by individual voices.

NOTE: Transpose in the Playback Console is for playback only.
To transpose notation, see Transpose.

! Mute a voice while all others continue to play or Solo a single
voice for playback.

! Use Pan to create a stereo image.

Default resets all ENF parts to their original settings.

The Close Button will close the Playback Console.
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Playback Range

To specify part of the score for playback,

a. select Playback Range from the Realtime menu.

b. Set the first Measure and last measure of the Play Range.

c. Mark Play All to play the entire score.

d. Check Loop to continually repeat the assigned Playback
Range.

Editing Score Structures

Edit > Systems

•  Insert Above/ Below

To Insert a new system to a score,

a. move the cursor to any system.

b. Hold down the Control (Ctrl) key to select this system as the
active system.

c. Go to the Edit menu and choose System > Insert Above (Insert
Below).

•  Delete

To Delete a system from a score,

a. move the cursor to any system.

b. Hold down the Control (Ctrl) key to select this system as the
active system.

c. Go to the Edit menu and choose System > Remove.
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Edit > Staff

•  Insert

To Insert a new stave to a system,

a. move the cursor to any staffline.

b. Hold down the Control (Ctrl) key to select this staffline as the
active staffline.

c. Go to the Edit menu and choose Staff > Insert Above (Insert
Below).

•  Delete

To Delete a stave from a system,

a. move the cursor to any staffline.

b. Hold down the Control (Ctrl) key to select this staffline as the
active staffline.

c. Go to the Edit menu and choose Staff > Remove

Edit > Parts

For a full definition of Parts, see Score Formats.

•  Insert

To Insert a new score part to a score,
! go to any score part within the active ENF file. From the Edit

menu choose Part > Insert Before (Insert After).

•  Delete

To Delete a part from a score,
! go to any score part within the active ENF file. From the Edit

menu choose Part > Remove.
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File > Page Set-up

To adjust the page layout of an ENF document for printing,
! go to the File menu and select Page Set-up.

Select the Type of Paper: Letter (8.5 x 11 in.), European A4 (210 x
297mm) format or Customize the page size.
! Orientation of the score may be Portrait or Landscape.

! Margins may be adjusted manually.

! Scope pull-down menu applies Setup changes to current page,
the entire score, or to the current part.

File > Printing

To Print the active ENF document,
! go to the File menu and select Print.

File > Save

•  Manual

When you are finished editing the ENF file,

a. go to the File menu and select Save (Command + S). Your
edited ENF file will now be saved.

b. Use File > Save As to save a selected file to directory other
than the working directory or with a different name.

•  Auto Save

The open ENF file is automatically saved in the directory
C:\Windows\Temp as AUTOSAVE.ENF

To change the interval for Auto Save,
! go the Options menu and select Auto Save.

Automatically save the working ENF file
! Every n minutes, even if no editing takes place.

! Every n actions performed in SmartScore; i.e., Inserting,
Changing, Deleting, etc.
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! What is First the number of minutes passes or the number of
actions performed.

! Never Auto Save the active ENF file.
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MIDI Editing

Relationships between the ENF Notation Editor and the MIDI
Editor

•  Parts and Voices to Channels and Tracks

SmartScore is designed to map ENF parts and voices to selected
MIDI tracks or MIDI channels depending on which Voice is selected
in the ENF display. For more information on Parts and Voices, see
table below.

Table 1: Parts and Voices to MIDI
Color
Mode

MIDI Tracks MIDI Channels

Part Each Staff = One Track Each Staff = One Channel

Voice Each Staff = One Track Each Voice = One Channel

•  Updating and refreshing playback and display

SmartScore treats MIDI in two slightly different ways: 1)as virtual
playback and 2)as file data. The ENF (notation) environment treats
playback as virtual MIDI where as the MIDI editing environment
treats it as file data. This allows for changes to be made in any
MIDI view without affecting the original ENF notation representation
or its playback. Using Tile, you can view associated ENF and MIDI
View windows simultaneously.

Changes made in ENF will automatically update the MIDI view, but
changes made in any MIDI window will NOT update ENF notation
display until and unless “New ENF” is selected. Similarly, any
changes made in MIDI View will NOT be applied to ENF playback
unless Refresh MIDI Playback is activated. Please refer to the
following table to clarify the relationship between ENF and MIDI
views.
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Table 2: ENF and MIDI View Relationships
ENF to MIDI MIDI to ENF In ENF View In MIDI View

DISPLAY PLAYBACK
MIDI View is
automatically
updated

ENF View is NOT
automatically
updated

Directly from
ENF

Directly from
MIDI

TO REFRESH
In ENF View:
View > New
MIDI View

In MIDI View:
View > New ENF
View

ENF
Playback:
View > New
MIDI View

In MIDI View:
Push “Refresh”
icon (speaker)

Updating ENF display from a modified MIDI view (View > New ENF

View) will recreate a new ENF document based ONLY on MIDI
data; all notation information will be lost.

Opening the MIDI Editor

•  From an ENF document

To create a MIDI file display from any open ENF document,

a. Press the MIDI View button of the Navigator
or the alternative is to go to
View > New MIDI View (Command + I) in the Main Menu

The New MIDI View Window will open.

b. Select the type of MIDI view desired, Track Overview, Piano
Roll or Event List.

•  From an existing MIDI file

a. In the File menu, select Open.

b. Select MIDI in the Files of Type pull-down menu.

c. Browse and select an existing MIDI file.

d. Press OK

NOTE: SmartScore accepts any Standard MIDI file (type 0 or 1).
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•  By creating an Empty MIDI file

To create an empty MIDI display go to the File menu,
! select New, and choose New MIDI.

MIDI Set-up

•  MIDI Devices

To set the MIDI input and output devices;

a. Select MIDI Devices from the Options menu. The MIDI Devices
window will open

b. Click on the MIDI Input device you will use for MIDI Recording
new MIDI data.

c. Click on the MIDI Output device you wish to use for MIDI
playback. The MIDI device window will display all installed MIDI
device drivers.

d. Press OK to set the selected MIDI devices as the current
SmartScore MIDI sources.

NOTE: If the desired device is not listed in the MIDI Devices
window make sure the Device driver has been properly
installed under Windows.

To change the MIDI settings for any MIDI instrument;

Select Instrument Settings under the Options menu. This will open
the Instrument Settings window
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Instrument Settings

The Instrument Settings window allows the user to change settings
for any MIDI instrument.

b. Select the MIDI Port of the MIDI instrument you will be
adjusting with the MIDI Port pull-down menu.

You can choose a specific Bank or all Banks from the selected
MIDI Port.

c. Use the Instrument pull-down menu to select the type of MIDI
Instrument (MT32, Roland GS, Yamaha XG, or Numeric).

d. Use the Drum pull-down menu to select the type of MIDI
Instrument (No Drums, Roland GS Drums, Yamaha XG Drums,
or Numeric).

Playback

•  Keyboard control

a. The spacebar on your computer keyboard will toggle between
play and pause.

b. Press the Spacebar again to pause playback.

c. Select Rewind (,) from the Realtime menu to return playback to
the beginning of the MIDI file.

•  RealTime Menu > Play

To begin playback from the beginning of the current MIDI file;

a. Select Play from the RealTime menu.

NOTE: Existing MIDI channels, instruments, voices, and
transpositions of the original ENF or imported MIDI file will
be maintained.

b. Select Stop from the Realtime menu to halt playback and
automatically reset playback to the beginning of the MIDI file.

c. Select Rewind (,) from the Realtime menu to return playback to
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the beginning of the MIDI file.

Playback Console

Selecting Playback Console (Command + 9) from the RealTime
menu will open the Playback Console in any window. The Playback
Console allows for playback and real-time editing of the active MIDI
file.

Playback Console

! Play button initiates/ resumes playback of the active MIDI file.
Once playback has begun, the Play button becomes Pause.
Pause will stop playback without rewinding to the beginning of
the score.

! Stop button stops playback/ recording of the MIDI file.

! Rewind button resets playback to the beginning of the playback
range.

! Record Button activates the Record mode. Press Play to begin
recording.

NOTE: Adjusting Playback Console Settings

•  General
! Adjust global playback volume using the Volume slider.

! Adjust Channel volumes using individual Volume sliders.

! Use Pan to adjust stereo balance for each channel.

! Default resets all MIDI tracks to their original settings.

! The Close Button will close the Playback Console.
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! Mute any voice while all others continue to play or Solo a single
voice for playback.

! Change the MIDI Instrument or Channel of any voice.

To playback at a given point in the file;

! Use the Measure / Beat slider and scroll to the desired
measure and beat in the score.

To select the MIDI output Device;

! Use the Port pull-down selector.

To transpose playback globally;

! Use the General Transposition pull-down selector

To transpose an individual track/ voice
! Use the Transposition pull-down selector in any track/ voice

Playback Range

To specify part of the score for playback, select Playback Range
from the Realtime menu.

Set MIDI Play Range

! Set the first Measure and last measure of the Play Range.

! Mark Play All to play the entire score.

! Check Loop to continually repeat the assigned Playback Range
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Display Controls

•  Time

To choose whether the timing of MIDI note events is displayed by
Measure: Beat: Tick or by Tick Number;

! Go to the Options menu and select Time Format.

! Choose by Measure: Beat: Tick or by Tick Number

•  Velocity

To choose whether the velocity of MIDI Event is displayed with
absolute numbers (0-127) or as percentages

! Go to Velocity Format under the Options menu.

! Choose by Value (0-127) or Percent

MIDI Views

a. Press the MIDI View (Command + I) button of the Navigator

b. The New MIDI View Window will allow you to select the type of
MIDI view desired, Track Overview, Piano Roll or Event List.

Track Overview

Overview gives a large-scale view of all MIDI tracks with general
editing functions.

To adjust the horizontal zoom of tracks in Overview.

! Drag a barline horizontally.

To adjust the vertical zoom of tracks in the Overview,

! Drag a track name boundary vertically.

To insert, delete or duplicate tracks:

! Hold the “alt” key while clicking on any track in the Track Name
column (in Piano Roll, select Options > Track in main menu).
The Track Properties window will open.
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The Track Properties window allows for editing of the Track Name
and its Transposition. Use the Piano Roll or Event List buttons to
open a New MIDI View of the selected track.

NOTE: The Transpose selection window will actually move each
MIDI Event of the selected track by the selected number
of half steps.

! New Track will create an empty new track.

! Selecting Duplicate Track will create an exact copy of the active
track at the bottom of the score.

! Delete Track will erase the current MIDI track complete

Piano Roll

Piano Roll displays the selected track in a grid format. Vertical axis
is pitch. Horizontal axis is note timing and duration.

To display the Piano Roll view from New MIDI View:

a. Select Piano Roll from the New MIDI View Window

b. Select the MIDI track you wish to display and press OK.

To display the Piano Roll view from Track Overview:

a. Double click or right-click on the Track Name in the Overview.

b. Choose Piano Roll from the Type pull-down menu and select a
track to view and press OK.

To adjust the horizontal zoom of tracks in Piano Roll.

! Drag a bar division in the track header horizontally.

To adjust the vertical zoom of tracks in the Piano Roll,

! Drag any edge of a key in the margin vertically.

NOTE: To scroll a Piano Roll or MIDI Event List to another track,
without opening a second window, click the paging
buttons located in the Image Toolbar.
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•  Shuttle Tool

The shuttle tool allows you to sound MIDI events forward or
backwards by dragging the mouse over the a range of events Go to
the Options menu and select Shuttle On. Click anywhere in an
Overview or Piano Roll and drag the blue Shuttle Tool to the right to
play the MIDI file at your own tempo. Drag the Shuttle Tool to the
left to rewind and hear the MIDI file simultaneously.

•  MIDI Note Selection

Under the Edit menu choosing Select opens the Select Window.

Select All or an individual track to display. Choose Full track to
display the full length of the MIDI file or designate a portion of the
file to display by entering the measure, beat, and tick into the From
and To fields

NOTE: Edit > Select All is only available from a Piano Roll or
Event List view.

Selecting MIDI notes using the mouse drag can be done from any
view. Mouse functions work the same in all views.

To select a note or group of notes:

! Click on the individual note or click and drag to Group Select
many notes.

To add note(s) to the Group:

! Hold down the Control key and click on the unselected note(s).

To add/ select all notes within a given time:

! Hold down the Shift key, click and drag the region.

NOTE: In Overview, left-clicking in the Track Name box will select
the entire track if no notes have been selected.

•  Changing selected MIDI note characteristics

Insert screen shots here
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To change the start time selected note event(s):

! Click and drag the left edge of the note(s) to the position you
want.

To change the duration of selected note event(s):

! Click and drag the right edge of a note changes the note’s
duration.

To change the velocity (note attack) of selected note event(s):

! Top and bottom edges of a note adjust the note’s velocity.

To change the pitch or position of selected note event(s):

! Click and drag the center of the note to change pitch (vertical
drag) or note placement (horizontal drag).

NOTE: The arrow keys on your computer keyboard can also be
used to adjust the pitch and start time of the selected
notes.

NOTE: To designate the increment at which MIDI notes can be
positioned, go to Options > Snap to and select a rhythmic
value.

To delete selected note event(s):

! Hit the Delete key to remove any highlighted notes.

•  Note Event Window

Double Clicking on any note event will open the Note Event
Window

The Note Event window allows access and adjustment of an
individual note’s parameters.
! Raise or lower the Pitch of the Note Event

! Start Time changes when the Note Event begins

! The Duration of the Note Event can be shortened or
lengthened

! Increase or decrease the Velocity of the Note Event
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! Select a new Voice for the Note Event

•  Velocity and Duration of selected Note(s)

To change the velocity and/or the duration of selected note(s):

a. Select the Velocity/ Duration option from the Edit menu. The
Velocity and Duration window will open.

b. Use the sliders to increase or decrease the velocity and
duration of the selected note(s) by a percentage. Example: You
wish to double the duration of a group of selected notes. In the
Velocity/ Duration window move the Duration slider to 200%.

c. Press OK.

•  Voices and Polyphony in a MIDI track

SmartScore supports reassigning MIDI events to individual voices.
Once assigned to separate voices, events in the same MIDI track
can retain individual properties such as separate MIDI channels
and separate instruments.

To change the voice assignment of selected note event(s):

! Use the Voice Selection pull-down menu located above the
piano keyboard. The current voice will be displayed.

•  Change MIDI Instrument Assignment

To change the MIDI instrument (Program Change) for any given
voice:

a. In a Piano Roll view, click where you want the change of
instrument to take place.

b. In the main menu, select Edit > Program Change. The
Change Instrument window will open.

c. Select a New Instrument from the pull-down menu and the
Voice to which the change applies.

NOTE: SmartScore will support multiple voices, with individual MIDI
instruments, within one staff line or track.
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•  Cut / Copy and Paste

Drag the mouse or use Edit > Select to select a region of music
you would like to cut, copy or paste.
! Cut removes the highlighted notes from the score and places

them in the clipboard

! Copy the selected notes to the clipboard without removing them
from the score.

Click where you want to insert the music back into the score.
! Paste will insert the contents of the clipboard back into the

score without deleting the existing notes.

! Paste Special will open the Paste Special window.

The Paste Special window offers several options for pasting the
contents of the clipboard back into the music.
! Add to existing events will add the contents of the clipboard to

the selected area without erasing the existing notes.

! Replace existing events will replace the existing music with
the contents of the clipboard.

! Move to make room will push the existing music backward and
then insert the contents of the clipboard.

! Use Repetitions to determine the number of times the contents
of the clipboard will be inserted.

! Start from time designates where the inserted music will begin
by choosing the measure, beat, and tick.

! Select Start from track to paste to a selected track number.

! All to track will insert the contents of the clipboard, no matter
how many tracks were original selected, into one track.

•  Inserting / Deleting Measures

NOTE: Measures can be inserted or deleted from either an
Overview or a Piano Roll.
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To Insert blank measures into every track:

! In an Overview, click on a measure number and drag to the
right. The selected measure and all subsequent measures will
move.

To Insert blank measures into an individual track:

! In a Piano Roll view, click on a measure number and drag to the
right. The selected measure and all subsequent measures will
move.

To Delete measures into every track:

! In an Overview, click on a measure number and drag to the left.
The selected measure and all subsequent measures will move,
overwriting the existing measures.

To Delete measures in an individual track:

! In a Piano Roll view, click on a measure number and drag to the
left. The selected measure and all subsequent measures will
move, overwriting the existing measures.

•  Measure Settings

The Measure Settings window allows for inserting changes of
tempo, time signature and Key Signature at the start of any given
measure.
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To open the Measure setting Window:

! Double click on the measure number where you wish to insert a
change in key, time, or tempo.

Measure Settings

To insert a change of Tempo:

! Adjust tempo with the Tempo slider.

To insert a change of Time:

! Use the Time pull-down menus to select the number of beats
per measure and the base measure unit (2=Half note,
4=Quarter note, 8=Eighth note, etc.).
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To change insert a change of Key Signature :

! Select the number of Accidentals in the new Key Signature
with the pull-down menu. Mark the key as major or minor with
the check boxes next to the pull down menu.

Press OK to update the changes through to the end of the active
MIDI file.

•  Setting Repeats and Multiple Endings

Repeats and multiple endings are also created by using the
Measure Attributes window.

Double click any measure to open the Measure Attributes window
of that measure.

•  Simple Repeats

Check the 1st Measure of Repeat box to select a measure as the
beginning of the repeated section.

Use the # of Passes scroller to determine the total number of times
this section will be played. For example: If you want the section to
play through and repeat one time, set the # of Passes to 2 (the
default).

Check the Last Measure of Repeat box to set a measure as the
final measure of the repeated section. During playback, once the
preset number of passes has been met, playback of the remainder
of the score will continue after this measure has finished.
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•  Multiple Endings
! Use the 1st Measure of Repeat box to select a measure as the

beginning of the repeated section.

! Use the Number of Passes scroller to determine the total
number of times this section will be played.

!  The 1st Measure of Ending box designates a measure as the
beginning of an ending.

! The Number of Pass scroller is used to the number this ending,
i.e, 1 = 1st Ending, 2 = 2nd Ending.

!  Use the Last Measure of Ending check box to define the total
length of the ending. After this measure is played, MIDI
playback will jump to the 1st Measure of Repeat and continue on
with the next pass.

NOTE: This measure is also the Last Measure of Repeat. Check
the Last Measure of Repeat box to continue playback with
the First Measure of Repeat.

•  Segnos

A Segno is a musical notation symbol used to denote the beginning
or the end of a repeated section.

Starting from a Segno

Checking the Segno box will place a Segno in a measure.

Activate the Jump to check box and select d.s. or Dal Segno (from
Segno). After this measure is played, MIDI playback will jump to the
Segno measure and continue playback.

Ending at a Segno

Check the Jump to box and select d.c. or Da Capo (from the
beginning) and al segno (to the Segno).

Checking the Segno box will place a Segno in a measure.
Playback will stop with this measure.
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•  Fine

Fine means final or end. It denotes the last measure of a score
when repeats are used.

d.c. al fine

Check the Jump to box and select d.c. or Da Capo (from the
beginning) and al fine (to the end). After this measure is played,
MIDI playback will jump to the beginning of the score and continue
playback

Use the Fine check box to insert a fine into a measure. MIDI
playback will stop at the end of this measure.

d.s. al fine

A Fine can be inserted after a Segno when the Segno is used to
mark the beginning of the repeated section.

Checking the Segno box will place a Segno in a measure.

Activate the Jump to check box and select d.s. or Dal Segno (from
Segno) and al fine (to the end). After this measure is played, MIDI
playback will jump to the Segno measure.

Check the Fine box to insert a fine in a measure. MIDI playback will
play through the score, return to the Segno measure, and stop after
the Fine measure is played.

•  Jump to

Jump to can be used to “send” MIDI playback to a certain measure.

Select to Measure in order to jump to a chosen measure during
playback.

On Pass will send MIDI playback to the selected measure on the
designated pass.

NOTE: Check On Pass if the d.s., d.c, or the Jump to measure
falls within a repeated section and define on which pass
playback will jump.



64

Event List

The Event list is a detailed list of all MIDI events and meta events in
a scrolling columnar format. It is as detailed a picture of each MIDI
event you can get. All events, parameters and controllers can be
edited in this environment.

To view and edit detailed MIDI events, meta events, note events,
controllers, program changes, key and time signatures, etc. and in a
selected track,

a. Press the MIDI View button of the Navigator or in the menu,
select View > New MIDI View.

b. Choose Event List from the Type pull-down menu

c. Select a track to view.

The Event List displays every MIDI event of the selected track:
! Select what events types are displayed in the Event List by

checking or unchecking the Event Type boxes along the top of
the Event List.

•  Changing Parameters of Selected Notes

To change parameters of a group of selected notes:

! Click in any of the columns to change the parameters of an
existing MIDI event or double click in the Type column of a Note
Event to open the Note On window.

The Note On window, like the Note Event window, allows for
adjustment of an individual note’s parameters. Channel, Time,
Duration, Pitch, and Velocity of a selected note.

•  Editing Key, Time and Tempo

Click in any column to make changes to any existing MIDI events.
To insert a new tempo, key, or time signature click the event you
want the new event to follow. Press the New button. The Create
New Event window will open.

Use the scroll bar to select Meta Event. A Meta Event is a MIDI file
instruction. Scroll through the Event Subtype window to choose
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Tempo, Time Signature, or Key Signature . Press OK. Use the
Other column to select the new tempo, time signature, or key
signature OR double click in the Type column to open an event
specific window. You may type in a new value.

•  Inserting Note Events

To insert new events in the Event List View

a. Click the Event you want the Note to follow. Select New from
the upper left hand corner of the Event List. The Create New
Event window will open.

b. Scroll to Note On in the Event Type menu

c. Press OK.

d. A Note On event will be inserted into the Event List.

e. Enter the Voice, Time, Duration, and Pitch of the new event by
clicking in the corresponding columns or double click in the
Type column to open the Note On window.

•  Inserting Non-Note Events

Any MIDI event that is not note-on or note-off event is a non-note
event. This includes MIDI Control Changes, Program Changes,
Channel Pressure, Pitch Bend Information, and Meta Events.

To insert a non-note event in the Event List View:

a. Select the event you want the Non-note event to follow

b. Press the New button.

The New Event window will open.

c. Use the Event Type menu to select the event to be added.

NOTE: Some events, such as Control Change and Meta Event,
have Subtype event listings.

d. Press OK
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•  Program Change

Program Change inserts a MIDI event that changes the Instrument
Assignment playback of a given voice / channel. See Voice
Assignments and Channel.

To insert a Program Change of the voice / channel in Create New
Event

a. Program Change is the default New Event, so simply press OK.

The selected Program Change will be inserted into the Event List.

b. Use the Voice pull-down menu to designate the voice to which
the Program Change applies

c. Use the Other. pull-down menu in the Other column to select a
new Instrument Assignment.

•  Control Changes

Control Changes send adjustable parameters to your selected MIDI
Device i.e., vibrato, hold, volume, pan, effects, etc. You can add
specific changes to these controls from within SmartScore’s Event
List. To find out more about what each control change will do, refer
to the user’s manual of your MIDI device.

•  Meta Events

Meta Events are MIDI file instructions written to the MIDI file. They
information such as file and track headers, SMPTE, tempo, key and
time signatures, etc. can be added to any MIDI file using
SmartScore’s Event List.

MIDI Recording

Recording Options

To activate the Record mode and adjust the recording options
choose Record from the Realtime menu.
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•  Synchro Start

Recording is synchronized to start with the first MIDI note played.
To unsynchronize the start of recording with the first played MIDI
note uncheck Synchro Start from the Realtime menu OR choose
the Metronome Settings listed under the Options menu and
uncheck Synchro On.

•  Thru

Sends new MIDI events to the selected MIDI output Device. The
Active Piano Roll determines the parameters of the MIDI Thru
sound. If no Piano Roll is open, MIDI Channel 1 is used.

•  Metronome

The Metronome is active while recording. To make the Metronome
inactive during recording, uncheck Metronome from the Realtime
menu OR choose the Metronome Settings listed under the
Options menu and uncheck Metronome On.

To make changes to SmartScore’s metronome;

a. Choose Metronome Settings from the Options menu. The
Metronome Settings window will open.

The Metronome Settings window allows the user to adjust the
parameters of SmartScore’s metronome.

NOTE: The Metronome On check box must be selected for the
metronome to sound during recording. To record without a
metronome uncheck the Metronome On box.

With Synchro On, SmartScore will synchronize the start of
recording with the first played MIDI note.

b. Select which MIDI Port the metronome will play through.

c. Choose the metronome’s MIDI Channel.

NOTE: MIDI Channel 10 is the default, as with all MIDI applications,
for drums.

d. Determine the number of Lead-in Measures that will play prior
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to the start of recording.

The Primary Beat (down beat) will sound when the On check box
is selected. The Pitch pull-down menu displays all General MIDI
drum sounds. Use the Volume scroll box to increase or decrease
the volume of the Primary Beat. The default accents the primary
beat.

The Secondary Beat will sound when the On check box is
selected. The Pitch pull-down menu displays all General MIDI
drum sounds. Use the Volume scroll box to increase or decrease
the volume of the Secondary Beat(s).

•  Snap to

MIDI is very strict. Any fluctuation in timing or speed may result in
incorrect notation. To prevent this, you can apply quantization to
your performance. Select Snap to from the Options menu. Choose
the smallest rhythmic value that you want your notes represented
at.

The resulting MIDI events will be justified, spelled to the nearest
selected rhythmic value.

NOTE: Snap to also determines the increment at which selected
MIDI events can be moved, when using the mouse or
arrow keys.

•  Punch In and Out

To set Punch In and Punch Out points for recording, double click
any measure number in an Overview or Piano Roll. The Measure
Attributes window will open.
! Check Punch In to start recording at the beginning of this

measure.

! Check Punch Out to set this measure as the last measure for
recording.

The Punch In and Out Measures are marked with red triangles in
the Overview and Piano Roll.
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•  External Timer

To run SmartScore’s MIDI recording from an external timer, select
External Timer from the Realtime menu.

•  Recording New Tracks / Voices

To Record a new track to a MIDI file,

a. select Record from the Realtime menu OR press the Record
button in the Playback Console. The New View window will
open if any MIDI data already exists.

b. Select an existing track to record a new voice within the same
track.

The new MIDI data will be added to the existing track without
overwriting any material.

c. Select New Track to record a brand new MIDI track for
recording.

NOTE: A Piano Roll will open for the selected track. A Piano Roll
must be open to record in SmartScore. A new voice and
MIDI Channel will automatically be created when
recording into any track.

d. Use the Playback Console to assign the MIDI parameters for
the new track/ voice.

e. Select Play from the Realtime menu OR press the Play button
in the Playback Console to start recording at measure 1, unless
a Punch In point has been set (see Punch).

While recording:

! Pause will temporarily halt recording. Press the Play button
again to resume recording the same track/ voice

! Stop will end the current recording session. SmartScore will
return to the standard MIDI editing environment.
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MIDI to ENF

To create and ENF document from a MIDI file:

! Select New ENF View from the View menu. The MIDI to ENF
window will open.

Staff Voicing:

! Select As Multiple Voices to create an ENF document in Color
Mode > Voice. For more information on color modes, see Color
Mode. Each MIDI tracks will be convert to a single ENF stave
with separate voice lines.

TIP: Use this option when converting MIDI files that contain
Polyphony (contrapuntal Voices).

As Single Voice:

This option converts each MIDI track into a single ENF stave.
! Select By MIDI Channel to convert each MIDI channel as a

separate ENF stave.

TIP: Use this option when converting MIDI files type 0.

Density:

! Measures per System determines the number of evenly
spaced measures per system.

! Systems per Page determines the number of evenly spaced
systems per page.

! Quantization

SmartScore can quantize the MIDI file that will be converted.
Quantization is similar to the Snap to feature available when
recording MIDI data in SmartScore. Each note event will “snap to”
the nearest beat boundary eliminating fluctuations in the timing of a
MIDI performance.
! Check None to prevent the application of quantization.
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! Use Note On/ Note Off to determine the smallest rhythmic
values used to when spelling note start times (Note On) and
end times (Note Off) in the ENF document.

! Use Note On/ Note Duration to determine the smallest
rhythmic values used to when spelling note start times (Note
On) and the minimum length of each note (Note Duration) in
the ENF document.

•  Shorten each note to the last Note Duration value.

•  Lengthen each note to the next Note Duration value

•  Justify each note to the nearest Note Duration value.

! Check the Interpret Tuplets box to allow tuplet spelling in the
ENF document.
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Glossary

Score Formats

•  Score

A musical piece compiled as a document. A score usually contains
more than one part with all the parts to be played together. In
SmartScore, it is a single computer file; an ENF file. A hand-written
score is called a manuscript.

•  Part

A part is represented by a staff line either alone (solo part) or
grouped into a system with other instruments (Ensemble part). A
part is usually an single instrument, but in the case of two-handed
instruments (piano, organ, xylophone, etc.), it may represent one
hand’s part.

•  Voice

Derived from choral music but applied to instrumental music as
well, a polyphonic voice (sometimes referred to as Counterpoint) is
a unique melodic entity distinguished from other voices by both its
timbre and harmonic expression inside an arrangement. Voices are
often distinguished between one another by stem direction and
sometimes by offsetting the horizontal position of notes.

•  Score Part

Scores that are printed in sets for each individual instrument.
Players read from their own unique set of pages. For example, a
duet for guitar and flute would be printed in two separate sets: one
for the flute player and one for the guitar. Staves of part scores flow
like a book where each staff line appends to the one above it.

•  Ensemble

Scores that have multiple staff lines connected by a vertical bar or
“bracket” (usually along the left-hand edge of the music). When
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joined in this way, each staff line represents a different part or
instrument. All parts are played “ensemble”. Piano music, (with left-
hand and right-hand staves) are joined into one system, is regarded
as “ensemble”. SmartScore assigns each stave to separate MIDI
tracks.

•  Landscape

Some scores are wider than they are high. These “landscape”
layouts need to be rotated prior to processing.

•  Folio

Large sized and conductor scores may need to be scaled down
during scanning or reduced on a copy machine before scanning. If
the score must be reduced more than 50% in order to fit the
imaging area of your scanner, you may consider scanning each full-
sized page twice and treat each scan as one “image-page”.

Score components

•  System

A grouping of multiple staff lines linked together by a solid line or
bracket along the left margin is called a “system”. All staves
belonging to a system are played simultaneously. In ensemble
scores, each system appends to the one before it. A single page of
a symphony conductor’s score, containing 10 or 20 staff lines per
system, may represent only a few seconds of music!

•  Staff (Staves)

The field on which notes are represented is called a staff. “Staves”
is normally used when referring to more than one staff. Each
successive line and space are equivalent to a full step in note pitch.
The higher the note appears on the stave, the higher its pitch.
Every staff line normally begins with a Clef sign and a key
signature.
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•  Staffline

A staffline is  one of 5 horizontal line which makes up a staff

•  Voiceline

An individual melodic line formed by a voice within one measure.
When a staff contains more than one voiceline in any given
measure, note stems of each voiceline usually point in the opposite
directions. The sum of all note and rest values of each voiceline in
any given measure should be accounted for, but sometimes are
not. Refer to Voiceline for more on dealing with this rule in
SmartScore.

•  Clef

The clef sign at the beginning of each stave identifies which pitch
“class” that stave belongs to. The lowest instruments are written in
the bass clef, intermediate instruments and voices often use one of
three “C” clef classes while higher-pitched instruments, in addition
to the right-hand part of a piano score, are scored in the treble clef.
The clef sign always appears at the beginning of every staff line
and in the first measure if a change of clef occurs. Change of clef
signs are smaller than normal clefs.

•  Key Signature

The key signature, along with the clef sign, appears at the
beginning of every line; it is also found in the measure where a
change of key occurs. The key signature defines the “tonal center”
of the piece. The number of sharps or flats in the key signature
determines the key tone (or tonic).

•  Time Signature

Time signatures usually appear only once: at the beginning of the
stave in the first measure of the piece. They will also appear when
a change of time signature occurs. Time signatures indicate both
the number of beats per measure (numerator) as well as which
note value is given the fundamental beat (denominator). The sum
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of note duration values in a given measure must equal the value of
the current time signature.

•  Note

A note is the fundamental unit of tone. The duration of a note is
determined by its note value (normally between 1 and 128
divisions). The note’s vertical position on a given staff (with clef)
determines its pitch.

•  Rest

Rests are equivalent to notes insofar as their durations; but
represent silence. They act as “place-holders” used to keep the
rhythmic structure of the measure intact.

•  Measure

Measures segment systems into discrete chunks of time. Each
measure has a strictly defined “pulse” determined by the active time
signature. While note rhythms within each measure are forever
changing, the over-riding pulse of the measure remains constant,
even as tempo speeds and slows.

•  Barline

Barlines are the vertical lines that define the beginning and ending
of measures

•  Accidental

Note pitches often range outside of the tonal center defined by the
key signature. An accidental shifts its associated note up (sharp) or
down (flat) by ½ step. Accidentals may also be doubled. An
accidental remains effective only for the remainder of the measure
in which it appears. A natural “cancels” a note’s current accidental.

•  Dot of Prolongation

Notes and rests that are dotted have the value of their duration
lengthened by ½. For example, a dotted quarter note is equal in
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duration to three eighth notes. Double-dotted notes increase the
note’s duration by ¾ of the original.

•  Tuplet

Some notes belong to a special readmit class called “tuplets”.
These include triplets, quintuplets and sextuplets. A tuplet is a
group of notes, usually marked with a bracket, that are subdivided
within a single beat, equal in duration to the note’s next higher
value. For example, a triplet of three eighth notes is equal in total
duration to one quarter note

•  Ties

A tie links two pairs of notes of the same pitch whose durations are
combined so that both notes are played as if one note. Ties are
often used to sustain the sound of a note across more than one
measure.

NOTE: Ties and slurs (legatos) often look alike, but they are
as different as lightning and a lighting bug. Ties connect two notes
of the same pitch and combine their durations into one note event
and slurs connect two or more notes over a range of pitches
forming a legato that when performed, creates a slight overlapping
of the notes. The arc of a slur can vary from flat to angular. The arc
of a tie is always flat.

•  Articulations

Articulations are performance markings that provide instructions for
playback of the marked notes. For example, a staccato, a dot
placed above/ below a notehead, means the note should be short,
sounding for only a moment.

•  Dynamics

Dynamic markings are used to denote the general volume and
intensity of music. For example, “f” or forte means loud and “p” or
piano means soft.
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Other Notational Terms

•  Polyphony

The dynamic harmony which evolves as Voicelines move
horizontally against one another in time. Polyphony evolved from
the simpler homophony of middle ages where vocal harmony was
more chordal, vertical and static. Polyphony usually refers to the
harmonic relationships between voices but also applies to
instruments and parts. Polyphonic voiceline threading is
fundamental to SmartScore’s design. Refer to Voice Line Threading
for more details.

•  Counterpoint

Similar to Polyphony but more formalized by the theoretical, rule-
based conventions of music composition. Counterpoint usually
refers to the melodic and rhythmic relationship between parts or
voices.

MIDI Terms

•  MIDI

Musical Instrument Digital Interface. Originally a hardware Device
that allowed a computer and a synthesizer to communicate, now a
generally accepted term for hardware or software that operate
according to General MIDI standards.

•  Device

A MIDI driven tone generator. Sound cards, synthesizers, and MIDI
modules all fall under this category.

•  MIDI Event

Each piece of information contained within a MIDI file is an event.
This includes Notes (attack and release), Control Changes, System
Exclusive, Meta Events, Program Changes, etc.
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•  Velocity

The speed at which a note was struck… it’s percussive quality… a
combination of volume and attack. Measured with a number from 0-
127.

•  Channel

A MIDI device sends and receives MIDI information along separate
and distinct Channels. Each channel contains note and non-note
event data. Most MIDI devices can support up to 16 MIDI Channels
at one time.

•  Patch

Every MIDI channel is assigned a Patch. A Patch is the Instrument
Assignment sound your MIDI device will use when playing back on
a particular channel.

•  Bank

MIDI devices divide patches (Instrument Assignments) into groups
of 128. One Bank of patches from a MIDI device can be accessed
at a time by a MIDI computer program or another MIDI device.

•  Port

A computer can run several MIDI devices at a time with the proper
hardware. Each device is connected to a unique Port.

SmartScore Terms

•  ENF

Extended Notation Format. This is SmartScore’s proprietary file
format. It is created after scanning, when creating a new score or
when converting an imported MIDI file into ENF (MIDI-to-ENF).

•  Navigator

A floating window comprised of buttons designed to “navigate”
through SmartScore’s main features and editing environments.
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•  Master System

The Master System is a sort of “virtual system” which allows for
manipulating any or all voices, instruments, parts, staves and
systems in the score. Generally, it is a list of all the parts and voices
that make up the LARGEST system in the score. The Master
System is the basis of many editing features including Visibility,
Voices, Spacing, and Part Names.

•  Voice Line Threading

SmartScore will differentiate multiple Voices by displaying in
different colors (Voice 1-black,  2-red,  3-green, and  4-blue)  while
creating an independent MIDI channel for each voice. The
individual voice lines will “threaded” from the TIFF file, through
Recognition, to the ENF file, from the ENF file to the MIDI file, and
from the MIDI file back to the ENF file.

•  Part Linking

In SmartScore, each staff in a system usually represents an
instrumental part. Some scores do not have a consistent number of
staves in all systems (collapsing and expanding systems). This may
result in the wrong instrument suddenly playing back. Part Linking
(Command + “L”) allows the user to reassign parts in a collapsed or
expanded system and apply the change to the single system, to all
following systems or to the entire score.

ENF Menu Items

ENF Edit Menu Icons

•  Zoom
Activates the Zoom Tool. Left-click to Zoom In; Right-click to Zoom
out. Command + Q



80

•  Select
Activates the Select Symbols or Area Tool. Left-click and drag to
Select Symbols (note editing); Right-click and drag to Select Area.
“O”

•  Insert
Inserts selected notational object into ENF document. “C”

•  Change
Change existing object in the ENF document to that of the selected
notational object. “C”

•  Delete by Group
Deletes only object of the select notational object. Notes will not
Delete when a Rest is the selected notational object. “X”

•  Delete Any
Deletes any notational object. “X”

•  Transpose

Opens the Transpose window. Performs transpositions globally or
to specified regions, staves, or Voices.

•  Special

•  Beam Notes
Beams all selected notes together. “B”

•  Flip Stems
Reverses the default stem direction of Inserted notes. “S”

•  Vertical Alignment
Vertically aligns notes that may be horizontally offset for correct
playback. “Y”

•  Split Voices
Separates two note clusters into individual voice lines. “H”
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•  Stems
Switches the default stem direction when Inserting notes. Changes
stem direction of all selected notes. “S”

•  Delete Ties
Deletes all ties from the selected area. “G”

File

•  New

Select between a new ENF (Command+N) or a new MIDI
(Crtl+M). Choosing New ENF will open the New SmartScore
Document window. Select a Template or use Custom to create a
unique score. Choosing New MIDI will open a blank MIDI Overview
and PianoRoll for MIDI input.

•  Open

Opens File Selection dialog box and lists saved files. A selected file
will be loaded into memory and will display on the screen.
Command+O

•  Save

Writes currently displayed file to the hard disk. If ENF and Image
are displayed, the ENF file is saved. Command+S

•  Save As

Opens Windows File Selection dialog box and saves modified ENF
files to hard disk following Recognition and ENF Editing
procedures.

Saves selected files to directory other than the working directory.

•  Scan Music

Select

Selects scanner plug -in.
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Acquire

Initiates scanning.

•  Recognition

Initiates Recognition to begin processing saved image file(s).

•  Page Setup

Allows adjustments in the page size and orientation of the current
ENF file.

•  Print

Initiates Windows Print Monitor. Current ENF file is output to default
printer from selected printer port. Command+P

•  Recent 1,2,3, or 4

Automatically loads one of the last four files accessed by
SmartScore.

•  Exit

Exit SmartScore. Save current file. Go to Windows main desktop

Edit

•  Undo

Reverses the last action you performed. SmartScore has ninety-
nine layers of Undo. Command + Z

•  Redo

Reapplies the last action that has been Undone. Command + Y

•  Cut

Removes the highlighted notes from the score and places them on
the clipboard Command + X
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•  Copy

Places selected notes on the clipboard without removing them from
the score. Command + C

•  Paste

Insert the contents of the clipboard back into the score without
deleting the existing notes Command + V

•  Paste Replace

Replace the existing music with the contents of the clipboard.
Command + R

•  Delete

Deletes all selected notational objects from the ENF document. Del

•  Select All

Selects all MIDI events in every track. Command + A

•  Bracketing

Opens the Bracketing Options window for creating score brackets.

•  Part Linking

Opens the Re-link Parts window for Logical Part Linking.

•  Master System

Opens the Master System window. Make changes on a system or
score level to Voices, spacing, Part Names, and visibility.
Command + M

•  System

Insert Above

Inserts a new system above the active system
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Insert Below

Inserts a new system below the active system

Remove

Deletes the active system from the page

•  Staff

Insert Above

Inserts a new staff line above the active staff line

Insert Below

Inserts a new staff line below the active staff line

Remove

Deletes the active staff line from this system

•  Score-Part

Insert Before

Appends a new Score Part before the current ENF Score Part

Insert After

Appends a new Score Part after the current ENF Score Part

Remove

Deletes the current ENF Score Part

•  Default Voice

Resets selected notes to original Voice Assignments. Command +
U

•  Instrument Templates

Opens the Instrument Templates window. Determine the name,
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MIDI Instrument Assignment, channel, port, and transposition for
each Voice in the active ENF file. Command + T

•  Score Header

Opens the First Page Header window. Type in the Title, Composer,
and Part Name for the active ENF file.

•  Tempo

Opens the Tempo window. Set or remove a metronome marking for
the ENF document.

View

•  Navigator

Opens and closes the SmartScore Navigator.

•  Main Toolbar

Opens and closes Main Toolbar

•  SmartScore Toolbar

Opens and closes SmartScore Toolbar

•  Image Toolbar

Opens and closes Image Editing Toolbar

•  Status Bar

Opens and closes Status Bar at the bottom of main SmartScore
Window. Displays current page, cursor position, image size, and
zoom percentage.

•  Palettes

Opens and closes tool palettes for ENF document editing.
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•  Image Information

Provides information on the structure and type of the currently
displayed image file.

•  Next Page

Displays next page of ENF document

•  Previous Page

Displays previous page of ENF document

•  Go to Page

Presents a dialog box to select a page number to jump to. Use
scroller to select desired page and click OK. Command+G

•  Zoom

Lists available view percentages. Changing zoom will affect both
the image and the ENF file simultaneously.

•  New MIDI View

Opens New MIDI View dialog box. Command + I Select type of
view.

•  Overview
Displays all staves as MIDI tracks

•  Piano Roll
Displays selected stave as MIDI track

•  Event List
Displays MIDI events of selected stave
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Options

•  Unify Signatures and Clefs

Open the Unify Score window. Unify Clefs, key and time signatures
throughout the entire score. “U”

•  Measure Numbers

Determines whether measure numbers are displayed in the ENF
document at each measure, each staff line, or not at all.

•  Color Mode

By Voice

Each voice of a staff line will display in a different color.

By Part

Each staff line will display in a different color or all staves in black.

•  • Define

Part Color

Define the colors used while Color > By Part is selected

Background

Define the background color for the ENF document or Image file.

•  Show Active Staff

When selected all staves except the Active Staff will be grayed-out.

•  Auto Save

Opens Auto Save Options dialog box. Determines when
SmartScore will automatically update saved ENF file with current
working file.

•  Every “n” minutes

•  Every “n” actions
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•  Which come first- “n” minutes or “n” actions

•  Never

Window

•  New Window

Opens a second copy of the current ENF document.

•  Cascade

Layers all open windows within main SmartScore window. Active
window is stacked on top.

•  Tile

Arranges all open windows to fit within main SmartScore window.
Windows are arranged from left to right, top to bottom starting with
the active window.

•  Split

Cursor moves to ENF window for vertical resizing of ENF and TIFF
display. Cursor automatically controls sizing pane, left-click to
release.

Realtime

•  Set Playback Range

Opens Set MIDI Play Range dialog window.

•  Play/ Pause

Begins/ pauses/ resumes playback of current ENF file. “Spacebar”

•  Stop

Stops playback of current ENF. Resets ENF playback

•  Rewind

Rewinds to beginning of Set Playback Range. “,” comma
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•  Thru

Allows MIDI input to sound

•  Console

Opens the Playback Console

•  Refresh MIDI

Updates MIDI playback based upon current ENF document.

•  Internal Playback

Plays back ENF / MIDI data through QuickTime Musical
Instruments extension when installed.

Help

•  About SmartScore

Opens the About SmartScore window displaying general
information about this copy of SmartScore.

•  Open Help

Opens SmartScore Helpfile (Acrobat PDF).

MIDI Menu Items

File

•  New

Select between a new ENF (Command+N) or a new MIDI
(Crtl+M). Choosing New ENF will open the New SmartScore
Document window. Select a Template or use Custom to create a
unique score. Choosing New MIDI will open a blank MIDI Overview
and PianoRoll for MIDI input.
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•  Open

Opens File Selection dialog box and lists saved files. A selected file
will be loaded into memory and will display on the screen.
Command+O

•  Close

Closes all MIDI views. If any changes were made to the MIDI file,
option to Save MIDI file. Return to main SmartScore window.

•  Save

Writes currently displayed file to the hard disk. Command+S

•  Save As

Opens Windows File Selection dialog box

Save processed or modified MIDI files to hard disk following MIDI
Recording or Editing procedures.

Use to save selected files to directory other than the working
directory

•  Recent 1,2,3, or 4

Automatically loads one of the last four files accessed by
SmartScore.

•  Exit

Exit SmartScore. Save current file. Go to Windows main desktop

Edit

•  Undo

Reverses the last action you performed. SmartScore has ninety-
nine layers of Undo. Command + Z

•  Redo

Reapplies the last action that has been Undone. Command + Y
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•  Select

Opens the Select window for defined note selection.

•  Select All

Selects all MIDI events in every track. Command + A

•  Cut

Removes the highlighted notes from the score and places them in
the clipboard. Command + X

•  Copy

Places selected notes on the clipboard without removing them from
the score. Command + C

•  Paste

Insert the contents of the clipboard back into the score without
deleting the existing notes. Command + V

•  Paste Special

Opens the Paste Special window. The Paste Special window offers
several options for pasting the contents of the clipboard back into
the music.

•  Delete

Deletes the selected section from the MIDI file. Del

•  Program Change (Piano Roll only)

Opens the Change Instrument window. Insert a change to a new
MIDI Instrument Assignment.

•  Velocity / Duration

Opens the Velocity and Duration window. Adjust the Velocity and/
or Duration of the selected MIDI events.
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View

•  Navigator

Opens and closes the SmartScore Navigator.

•  Main Toolbar

Opens and closes Main Toolbar

•  SmartScore Toolbar

Opens and closes SmartScore Toolbar

•  Image Toolbar

Opens and closes Image Editing Toolbar

•  Status Bar

Opens and closes Status Bar at the bottom of main SmartScore
Window. Displays current page, cursor position, image size, and
zoom percentage

•  New MIDI View

Opens New MIDI View dialog box. Select type of view.
! Overview- Displays all staves as MIDI tracks

! Piano Roll- Displays selected stave as MIDI track

! Event List - Displays MIDI events of selected stave

•  Show Track 0 (only in Overview)

Displays MIDI channel 0 in MIDI Overview

•  Synchronize

Synchronizes measure sizes in all MIDI views to that of current
MIDI view. Further horizontal resizing synchronized between all
MIDI views.
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•  New ENF View

Opens the MIDI-to-ENF window for converting the active MIDI file
into and ENF document.

Options

•  Snap to

Snaps selected recorded MIDI events to the nearest specified
rhythmic value. Selects the smallest increment selected MIDI
events move when the arrow keys are used.

•  Time Format

Select whether start time of note events is displayed with Measure:
Beat: Tick numbers or solely with Tick numbers.

•  Velocity Format

Select whether Velocity of note events is displayed with absolute
numbers or as percentages.

•  Track (not in Overview)

Opens Track Properties dialog box. Select a different track view,
delete, duplicate, rename, or transpose the selected track.

•  MIDI Device

Opens MIDI device dialog box. Select MIDI input and output
sources.

•  Instrument Settings

Opens Instrument Settings dialog box. Allows for selection of Port,
Bank, and MIDI channel assignment for Instrument and Drum
sources.



94

•  Metronome Settings

Opens Metronome Settings dialog box. Allows for selection of Port,
MIDI Channel, number of lead in measures, MIDI sound and
volume for Primary and Secondary beats.

•  Shuttle On

Activate/ deactivate SmartScore’s shuttle tool.

•  Restore Default Settings

Realtime

•  Set Playback Range

Opens Set MIDI Play Range dialog window.

•  Play / Pause

Begins/ pauses/ resumes playback of current MIDI file. In Record
Mode will start and pause MIDI recording. “Spacebar”

•  Stop

Stops playback or recording of current MIDI file.

•  Rewind

Rewinds to beginning of Set Playback Range. “,” comma

•  Solo (not in Overview)

Solos the active track during playback.

•  Record

Check to activate MIDI Record mode

•  External Timer

Set recording to begin from an external signal.



95

•  Synchro Start

Active only in Record Mode, check to synchronize start of MIDI
recording with first note played on MIDI keyboard.

•  Thru

Allows MIDI input to sound

•  Metronome

Activates/ deactivates Metronome in recording

•  Playback Console

Opens the Playback Console.

•  Internal Playback

Plays back ENF / MIDI data through QuickTime Musical
Instruments extension when installed.

Window

•  New Window

Opens a second copy of the current MIDI view.

•  Cascade

Layers all open windows within main SmartScore window. Active
window is stacked on top.

•  Tile

Arranges all open windows to fit within main SmartScore window.
Windows are arranged from left to right, top to bottom starting with
the active window.
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Help

•  About SmartScore

Opens the About SmartScore window displaying general
information about this copy of SmartScore.

•  Open Help

Opens SmartScore Helpfile (Acrobat PDF).

Image Menu Items

File

•  New

Select between a new ENF (Command+N) or a new MIDI
(Crtl+M). Choosing New ENF will open the New SmartScore
Document window. Select a Template or use Custom to create a
unique score. Choosing New MIDI will open a blank MIDI Overview
and PianoRoll for MIDI input.

•  Open

Opens File Selection dialog box and lists saved files. A selected file
will be loaded into memory and will display on the screen.
Command+O

•  Save

Writes currently displayed file to the hard disk. Command+S

•  Save As

Opens Windows File Selection dialog box

Save processed or modified Image files to hard disk following
Scanning and Editing. Use to save selected files to directory other
than the working directory.
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•  Scan Music

Selects scanner or initiates scanner to acquire image.

•  Recognition

Initiates Recognition to begin processing saved image file(s).

•  Print

Initiates Windows Print Monitor. Current Image file is output to
default printer from selected printer port. Command+P

•  Recent 1,2,3, or 4

Automatically loads one of the last four files accessed by
SmartScore.

•  Exit

Exit SmartScore. Save current file. Go to Windows main desktop

Edit

•  Undo

Reverses the last action you performed. SmartScore has ninety-
nine layers of Undo. Command + Z

•  Redo

Reapplies the last action that has been Undone. Command + Y

•  Cut

Removes the selected section from the image file and places it on
the clipboard Command + X

•  Copy

Places selected section on the clipboard without removing it from
the image file. Command + C
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•  Paste

Insert the contents of the clipboard back into the image file
Command + V

•  Delete

Deletes the selected section from the image file. Del

•  Crop

Trims the image file down to the selected region

•  Invert

Switches the colors of the image file.

•  Rotate

Left

Rotates the image file counter-clockwise

Right

Rotates the image file clockwise

Any

Opens the Rotate window for rotation by defines degrees.

•  Selection

Activates the Area Selection tool.

•  Line

Activates the Line drawing tool.

•  Brush

Activates the Brush tool.
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•  Deskew

Activates the Deskew tool for straightening “crooked” scans. See
Correcting Skew

•  Selection Mode

Opaque

When a selected area is moved to the clipboard the background will
be included

Transparent

When a selected area is moved to the clipboard only the black
portion of the selected area with be moved.

•  Pen Color

Select the color used by the Brush and Line drawing tools.

View

•  Navigator

Opens and closes the SmartScore Navigator.

•  Main Toolbar

Opens and closes Main Toolbar

•  SmartScore Toolbar

Opens and closes SmartScore Toolbar

•  Image Toolbar

Opens and closes Image Editing Toolbar
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•  Status Bar

Opens and closes Status Bar at the bottom of main SmartScore
Window. Displays current page, cursor position, image size, and
zoom percentage.

•  Palettes

Opens and closes tool palettes for ENF document editing.

•  Image Information

Provides information on the structure and type of the currently
displayed image file.

•  Next Page

Displays next page of ENF document

•  Previous Page

Displays previous page of ENF document

•  Go to Page

Presents a dialog box to select a page number to jump to. Use
scroller to select desired page and click OK. Command+G

•  Zoom

Lists available view percentages. Changing zoom will affect both
the image and the ENF file simultaneously.

Windows

•  New Window

Opens a second copy of the current ENF document.

•  Cascade

Layers all open windows within main SmartScore window. Active
window is stacked on top.
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Help

•  About SmartScore

Opens the About SmartScore window displaying general
information about this copy of SmartScore.

•  Open Help
Opens SmartScore Helpfile (Acrobat PDF).
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