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Software License Agreement

This Software License Agreement (“License Agreement”) is a legal agreement between you (either
an individual or a single entity) and Serif (Europe) Ltd. (“Serif”) for the accompanying software
product, which includes computer software and may include associated media, printed materials,
and “online” or electronic documentation (the “Software Product™). By installing, copying, or
otherwise using the Software Product, you agree to be bound by the terms of this License
Agreement. If you do not agree to the terms and conditions of this License Agreement, do not install
or use the Software Product; you may, however, return it to your place of purchase for a full refund.

THANK YOU FOR LICENSING THE USE OF THE SOFTWARE PRODUCT. IT IS IMPORTANT THAT YOU (THE
“LICENSEE") READ THIS NOTICE CAREFULLY. THESE ARE THE ONLY TERMS AND CONDITIONS APPLICABLE TO
YOUR RIGHTS WITH RESPECT TO THE SOFTWARE PRODUCT. THE SOFTWARE PRODUCT IS PROTECTED BY
COPYRIGHT LAWS AND INTERNATIONAL COPYRIGHT TREATIES, AS WELL AS OTHER INTELLECTUAL PROPERTY
LAWS AND TREATIES. THE SOFTWARE PRODUCT IS LICENSED, NOT SOLD.

1. GRANT OF LICENSE

Serif hereby grants to Licensee a personal, non-exclusive,
non-transferable license (a "License™) to use one (1) copy of
the Software Product, including any updates thereto, and
accompanying documentation, if any, provided by Serif,
according to the terms set forth below. If the Software
Product is being provided to Licensee as an update or
upgrade to software which Licensee has previously licensed
(such software referred to as the "Prior Software"), then
Licensee agrees to destroy all copies of the Prior Software
within thirty (30) days after opening this package except for
one backup copy of the Prior Software.

2. SCOPE OF USE

You may install and use one copy of the Software Product,
on a single computer. The primary user of the computer on
which the Software Product is installed may make a second
copy for his or her exclusive use on a portable computer.
Licensee may also store or install a copy of the Software
Product on a storage device, such as a network server, used
only to install or run the Software Product on other
computers over an internal network; however, you must
acquire and dedicate a license for each separate computer
on which the Software Product is installed or run from the
storage device. A license for the Software Product may not
be shared or used concurrently on different computers.

3. LICENSE PAK

If you have acquired this LICENSE AGREEMENT ina
Serif License Pak, you may make the number of additional
copies of the computer software portion of the Software
Product as authorized in the Serif License Pak, and you may
use each copy in the manner specified above. You are also
entitled to make a corresponding number of secondary
copies for portable computer use as specified above.

4. PROHIBITIONS

You may not: modify, prepare derivative works from,
translate, reverse engineer, decompile, disassemble or
otherwise derive source code from the Software Product
(except to the extent that such acts are expressly permitted
by applicable law notwithstanding this limitation); copy the
Software Product (except as provided above) or the
accompanying documentation; rent, transfer, disclose, make
available or grant any rights in the Software Product
(including any accompanying documentation) in any form to
any person without the prior written consent of Serif;
remove any proprietary notices, labels, or marks on the
Software Product (including any accompanying
documentation); use the Software Product in any manner
that infringes the intellectual property or

other rights of another party; or use the Software Product
to provide on-line or other database services to any other
person.

5. RETENTION OF RIGHTS; TERMINATION

This License Agreement does not constitute a sale. All title,
trade secrets, copyrights, patents and other intellectual
rights to the Software Product, its accompanying
documentation and any copy made by Licensee remain with
Serif, and Licensee hereby agrees to preserve and
acknowledges the foregoing. Licensee further agrees and
acknowledges that the Software Product and all copies
thereof are Serif's exclusive property and constitute a
valuable trade secret of Serif. Licensee further agrees and
acknowledges that unauthorized copying of the Software
Product or the accompanying documentation, or failure to
comply with any of the provisions hereof (each, a
“Terminable Event"), will result in automatic termination of
this License. In the event of a violation of this License by
Licensee, Serif reserves and shall have available all legal
remedies.

6. TERM OF LICENSE FOR TRIAL VERSION
SOFTWARE

The License pertaining to a trial version of the Software
Product (a "Trial Version") shall expire in accordance with
the terms as set forth in the installation process for the Trial
Version along with the designated trial period as set forth in
the trial program.

7. LIMITED WARRANTY AND DISCLAIMER

Serif warrants that, for a period of ninety (90) days after
delivery, the diskettes or CD-ROMs on which the software
included in the Software Product is furnished will, under
normal use, be free from defects that prevent Licensee from
loading the Software Product on a computer. Serif's entire
liability and Licensee's exclusive remedy under this warranty
will be, at Serif's option, to (a) use reasonable commercial
efforts to attempt to correct or work around errors, or (b)
to replace the Software Product with functionally equivalent
Software Product, on diskettes or CD-ROM, as applicable
or (c) return the price paid for the Software Product, in
each case upon return of the Software Product to Serif
together with a copy of your receipt for the purchase
thereof. This Limited Warranty is void if failure of the
Software Product or hardware has resulted from accident,
abuse, or misapplication. Any replacement Software
Product will be warranted for the remainder of the original
warranty period or thirty (30) days, whichever is longer.
Outside the United States, neither these remedies nor any
product support services offered by Serif are available
without proof of purchase from an authorized non-U.S.
source. The Software Product is licensed to you on an "as
is" basis without any warranty of any nature.



8. NO OTHER WARRANTIES

Except for the above express limited warranties, Serif and its
suppliers make and licensee receives no warranties or conditions,
or terms, express, implied, statutory, or in any communication
with licensee. To the maximum extent permitted by applicable
law, Serif and its suppliers disclaim all other warranties and
conditions, either express or implied, including, but not limited
to, implied warranties of merchantability, fitness for a particular
purpose, title and non-infringement, with regard to the software
product and the provision of or failure to provide support
services. Licensee shall be solely responsible for the selection,
use, efficiency and suitability of the software product and serif
shall have no liability therefor. Serif shall have no liability for,
nor obligation to indemnify licensee regarding actions alleging
the infringement of proprietary rights by the software product.
Serif does not warrant that the operation of the software product
will be uninterrupted or error free or that the software product
will meet licensee’s specific requirements. The Limited Warranty
gives you specific legal rights. You may have others, which vary
from state/jurisdiction to state/jurisdiction.

9. LIMITATION OF LIABILITY

In no event will Serif or its suppliers be liable for loss of data,
corruption, lost profits, cost of cover, or other special,
incidental, punitive, consequential, or indirect damages arising
from the use of the software product (including any
accompanying documentation), however caused and on any
theory of liability. This limitation will apply even if Serif or an
authorized distributor has been advised of the possibility of such
damage. In no event will Serif’s liability exceed the amount paid
for the software product. Licensee acknowledges that the
amounts paid by licensee for the software product reflect this
allocation of risk. Some states or other jurisdictions do not allow
the exclusion or limitation of liability for incidental or
consequential damages, so the above limitations and exclusions
may not be applicable in certain instances. None of the above
affects the statutory rights of licensees residing in the United
Kingdom.

10. NOT FOR RESALE SOFTWARE

If the Software Product is labeled “Not for Resale” or “NFR,”
then, notwithstanding section 1 of this License, your use of the
Software Product is limited to use for demonstration, test, or
evaluation purposes.

11. NO RENTAL; OTHER TRANSFERS

You may transfer this License to another computer or
workstation only on a permanent basis (that is, with no intent to
transfer again) provided the computer, workstation, or other
digital electronic device from which you have transferred this
License no longer accesses or otherwise utilizes the Software
Product, and the Software Product is used in accordance with
the terms of this License Agreement.

12. TERMINATION

You may terminate this License Agreement at any time. Serif
may terminate this License Agreement if you fail to comply with
the terms and conditions of this License Agreement. In either
event, you must destroy all copies of the Software Product.

13. UPGRADE

If this License is an “Upgrade,” you must have a valid license for
the Prior Software for this License Agreement to be valid, and
this License Agreement must be used to replace such license for
the Prior Software. The total number of license “Upgrades” you
may acquire may not exceed the total number of computers,
workstations, or other digital electronic devices that were
licensed to access or otherwise utilize the Software Product at
the time you upgraded the Software Product.

14. GUIDELINES FOR THE USE OF DIGITAL
CONTENT IMAGES

This product contains numerous clipart and photo images
(collectively referred to as the “Images™) which are either owned
by SERIF or licensed from a third party. As a user of this
product you are free to use, modify, and publish the Images as
you wish subject to the restrictions set out below. If you are
uncertain as to whether your intended use complies with the
guidelines set out below, we recommend that you seek the
advice of your own attorney or legal counsel.

A. YOU MAY, subject to any restrictions set out below:

1. Incorporate any Image(s) into your own original work and
publish, display, and distribute your work in any media. You
may not, however, resell, sublicense, or otherwise make
available the Image(s) for use or distribution separately or
detached from a product or Web page. For example, the
Image(s) may be used as part of a Web page design, but may not
be made available for downloading separately or in a format
designed or intended for permanent storage or reuse by others.
Similarly, clients may be provided with copies of the Image(s)
(including digital files) as an integral part of a work product, but
may not be provided with the Image(s) or permitted to use the
Image(s) separately or as part of any other product;

2. Make one (1) copy of the Image(s) for backup or archival
purposes.

B. YOU MAY NOT:

1. Create scandalous, obscene, defamatory, or immoral works
using the Image(s) nor use the Image(s) for any other purpose
prohibited by law;

2. Use or permit the use of the Image(s) or any part thereof as a
trademark or service mark, or claim any proprietary rights of any
sort in the Image(s) or any part thereof;

3. Use the Image(s) in electronic format, on-line, or in
multimedia applications unless (a) the Image(s) are incorporated
for viewing purposes only and (b) no permission is given to
download and/or save the Image(s) for any reason;

4. Rent, lease, sublicense, or lend the Image(s), or a copy
thereof, to another person or legal entity. You may, however,
transfer all your license to use the Image(s) to another person or
legal entity, provided that (a) you transfer the Image(s) and this
License, including all copies (except copies incorporated into
your work product as permitted under this License), to such
person or entity, (b) that you retain no copies, including copies
stored on a computer or other storage device, and (c) the
receiving party agrees to be bound by the terms and conditions
of this License;

5. Use any Image(s) except as expressly permitted by this
License.

15. MISCELLANEOUS

This Agreement shall not be governed by the 1980 U. N.
Convention on Contracts for the International Sale of Goods;
rather, this Agreement shall be governed by English law. This
Agreement constitutes the entire agreement between Serif and
Licensee and supersedes all prior agreements, understandings,
communications, advertising, proposals or representations, oral
or written, by either party. If any provision of this Agreement is
held invalid or unenforceable, such provision shall be revised to
the extent necessary to cure the invalidity or non-enforceability,
and the remainder of this Agreement shall continue in full force
and effect. This Agreement shall be amended only by an
executed writing by authorized representatives of both parties.






How to contact Serif
Our main office (USA, Canada):

The Software Center
13 Hampshire Drive, Suite 12, Hudson NH 03051

Main (603) 889-8650
Registration (800) 794-6876
Single Unit Sales (800) 55-SERIF or 557-3743
Technical Support (603) 886-6642
Customer Service (800) 489-6720
General Fax (603) 889-1127

Technical Support E-mail support@serif.com

European office (UK, Europe):

The Software Centre
PO Box 2000, Nottingham, NG11 7GW, UK

Main (0115) 914 2000
Registration (0500) 454 645

Sales (0800) 376 7070
Technical Support* (0115) 914 9090
Customer Service* (0115) 914 9090
General Fax (0115) 914 2020

*Local Rate (UK only)  (0845) 345 6770

Technical Support E-mail support@serif.co.uk

Online

Visit us on the Web at http://www.serif.com
Serif Newsgroupsnews://news.serif.com

International

Please contact your local distributor/dealer. For further
details please contact us at one of our phone numbers
above.
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Introduction

Welcome to Serif PhotoPlus 5.5—the best value in image
creation and editing software for any home, school,
organization, or growing business. PhotoPlus is your
number one choice for working with photographs and paint-
type images, whether for the Web, multimedia, or the
printed page.

PhotoPlus has the features you’ll need... from importing or
creating pictures and animations, through manipulating
colors and effects all the way to final export. Built-in
support for TWAIN scanners and cameras makes it easy to
bring in your own photos, while comprehensive import
filters let you open just about any standard bitmap image.

Once you’ve got your image into PhotoPlus, you can
enhance and alter its on-screen appearance with a diverse
toolkit of functions and effects. A full range of export
options (with special attention to Web graphics), plus
powerful optimization capabilities, round out this high-
performing package.

About the Companion

This Companion is your guide to getting started and getting
results with PhotoPlus—from the basics to advanced
techniques. The chapter sequence begins with basic
concepts and proceeds gradually through various tools and
features. Hands-on Projects are integrated each step of the
way. We hope you’ll take your time and enjoy the learning
process. Here’s a quick summary of chapter contents:

1 Welcome. There, we’ve said it again!

2  Getting Started. Will have you up and running in
no time with an overview of key concepts and the
PhotoPlus interface.

3 Manipulating Images. A rundown of basic
techniques for selecting and operating on all or just
part of an image.
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4  Working with Paint and Text. How to proceed
from the proverbial blank slate, using the PhotoPlus
creation tools.

5 Using Layers and Masks. Understanding and
mastering the creative possibilities of these more
advanced features.

6 Preparing Web Graphics. A review of Web image
formats and step-by-step guidance on animation and
image preparation.

7 Color and Output Options. Combines essential
background material and terminology with helpful
tips to improve your images.

Key PhotoPlus features

PhotoPlus brings professional image editing to everyone—
with features like these:

¢

Powerful Image Export Optimizer

The Export Optimizer lets you see how your image will
look (and how much space it will take up) before you
save it! Its multi-window display provides side-by-side
WYSIWYG previews of image quality at various
output settings, so you can make the best choice every
time.

Web Animation Tools

Now it’s easy and fun to create or edit animations for
the Web. You can import and export animated GIFs,
and even let PhotoPlus create entire animations for you
automatically.

Editable Text

Add formatted color text to an image, reposition and
scale it, integrate it with your design. Text layers keep
the contents separate so you can go back and alter the
words or formatting at any time!
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Image Enhancement

Apply professional, darkroom-style color and
histogram adjustments to your images. We’ve even got
a dedicated tool for removing “red eye” from flash
photos.

Versatile Deform Tool

This “Swiss Army Knife” of image tools lets you
rotate, resize, skew, reshape, or add perspective to any
selection or layer.

Unique Selection Options

PhotoPlus goes well beyond the basic rectangle and
lasso tools, adding more than a dozen completely
customizable selection shapes like polygons, spirals,
and stars. Or define a selection shaped like text—using
any font and style! Advanced options let you fine-tune
the selection and its properties for precise effects.

Smart Shapes

Choose from a panoply of fully adjustable filled shapes
to produce chevrons, hearts, badges, teardrops, moons,
zigzags, and many more. Just drag sliders to control
each shape’s appearance!

Gradient Fills

Take your pick of radial, linear, conical, or square
fills—perfect for masking, to hide or reveal parts of
your photo using smooth graduated blends to
transparency. (Of course, there’s standard flood fill as
well.)

Image Slicing and Image Maps

Now it’s not just the pros who can use these techniques
to add links to Web graphics! Simply click to divide
images into segments—each with its own hyperlink
and popup text—or add hotspots to specific regions.
PhotoPlus outputs the HTML code and lets you
preview the results directly in your Web browser.
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¢ Advanced Tools and Features
Built-in support for most pressure-sensitive graphics
tablets. RGB, CMYK, HSV, and Grayscale color
modes. Robust and convenient layer management with
pop-up preview and masking support.

¢ Professional Output Options
Output using CMYK separations or print directly to
your desktop printer with powerful controls. Include
registration marks, crop marks, file information,
grayscale and color bars, and tile or scale your output if
required.

¢ Productive MDI Interface
Open and view multiple images and edit them
simultaneously. Dockable, floating tab windows work
in conjunction with convenient toolbars. The Layer
Manager provides full control over all regions and
planes. Each document stores a massive Undo range
with dynamic memory and disk management,
compressing information for optimized performance.
And PhotoPlus remembers your preferred export
settings, so your creative flow is undisturbed.

And that’s only part of the story! The PhotoPlus feature
set includes all the standard capabilities you’d expect in a
photo editor. Tools like Paintbrush, Airbrush, Clone,
Smudge, and Erase. Customizable brush tips and opacity.
Flip, rotate, and crop. Anti-aliasing. TWAIN support for
scanner and digital camera input. A full range of supported
file formats for both import and export. In short, more
features for the price than allowed by law in some
jurisdictions (but don’t tell anyone)...
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Registration, Upgrades, and Support

If you see the Registration Wizard when you launch
PhotoPlus, please take a moment to complete the
registration process. Just call Serif toll-free and provide the
installation number and code shown. We’ll give you a
personalized registration number in return. Remember, if
you need technical support please contact us. We aim to
provide fast, friendly service and knowledgeable help.

Installation

PhotoPlus system requirements

PhotoPlus runs with Windows 95 or later, so you’ll need a
PC setup which runs Windows adequately. If you need help
installing Windows, or setting up your printer, see
Windows documentation and help.

¢ IBM compatible Pentium PC with CD-ROM drive and
mouse (or other Microsoft compatible pointing device)

¢ Microsoft Windows® 95, 98, 98 SE, 2000, or
Windows NT® 4.0 or later operating system

¢+ 16MB (Windows 95/98), 24MB (Windows 98 SE),
32MB (Windows NT), or 64MB (Windows 2000)
RAM

¢ 20MB (minimum install) free hard disk space.
¢ SVGA display (16-bit color or higher)

Additional disk resources and memory required when
editing large and/or complex images

Optional:

¢ Windows-compatible printer
¢ TWAIN-compatible scanner and/or digital camera

¢ Stylus or other input device, including pressure
sensitive pens
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¢ Internet account and connection required for accessing
online resources.

What you need to know

PhotoPlus is very easy to use, and you don’t need to have
any prior design experience. However, if you’re new to
Windows computing, you will find it much easier if, before
installing and using PhotoPlus, you spend a little time
becoming familiar with the Windows operating
environment.

O From the Windows desktop, click the St art button at
the lower left and choose Hel p.

First-time install

To install PhotoPlus, simply insert the Program CD-ROM
into your CD-ROM drive. The AutoRun feature
automatically starts the Setup process and all you need to
do is select the PhotoPlus Install option and answer the on-
screen questions. If the AutoRun does not start the install,
use the manual install instructions below.

Manual install/re-install

To re-install the software or to change any part of the
installation at a later date, select Set t i ngs/ Cont r ol
Panel from the Windows St art menu and then click on
the Add/ Remmove Pr ogr ans icon. Make sure the
correct CD-ROM is inserted into your CD-ROM drive,
click the I nst al | .. button, and then simply follow the on-
screen instructions. To install just one particular component
to your hard drive, choose the Custom option and check
only that component.
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Seven Key Concepts

If you’re new to photo editing programs, or perhaps have only worked
with a basic painting program like Microsoft Paint, a number of the
concepts in PhotoPlus may be new to you. Don’t be daunted! Many
thousands of artists have made the leap—the rewards are well worth it!

This section collects in one place some background material that will
hopefully provide a concise introduction and save you some “head-
scratching” later on. We recommend you read through it before racing
ahead to the rest of the chapter.

1 Image size and canvas size

Sometimes a tricky distinction if you haven’t encountered it before, it’s
an important one when working with digital pictures. You probably
know that image dimensions are given in pixels (think of pixels as as
the “dots of paint” that comprise a screen image)—say, 640 wide by
480 high. If you want to change these dimensions, there are two ways to

go about it, and that’s where image and canvas come

into play. Changing the image size (I) means scaling I r O
the whole image or just a selected region up or down. Q
Changing the canvas size (C) means adding or taking

away pixels at the edges of the image—rather like C L O

adding a border around a mounted photo, or taking a
pair of scissors and cropping the photo to a smaller size. Either way,
after resizing, the image and canvas dimensions are once again
identical.

2 Interacting tools and tabs

The Tools toolbar (see the PhotoPlus Toolbars and Tabs diagram later
in this chapter) is at the heart of PhotoPlus. Among its many offerings
you’ll find several basic painting/drawing tools, plus tools for erasing,
filling a region, and cloning a region (all covered in detail in Chapter
4). As you try each of these tools, keep in mind

that the Tool Properties tab and Brush Tip tab g +[:]= O
extend each tool’s functionality by letting you +[®]= o
customize its settings. Only with the aid of the

tabs can you choose a wide brush as opposed to a pencil point, or
experiment with the full range of effects each tool can command.
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3 Making a selection

In any photo editing program, the selection EEEED
tools (see Chapter 3) are as significant as any i I R
of the basic brush tools or commands. The !

basic principle is simple: quite often you’ll i =
want to perform an operation on just a portion

of the image. The wide range of selection options in PhotoPlus lets you:

+ Define just about any selection shape
+ Modify the extent or properties of the selection

¢ Carry out various manipulations on the selected pixels, including
cut, copy, paste, rotate, adjust colors, etc.

Although the techniques for using each selection tool vary a bit, the end
result of making a selection is always the same: a portion of the image
has been roped off from the rest of the image. The boundary is visible
as a broken line or marquee around the selected region.

4 Foreground and background colors

At any given time, PhotoPlus allows you to work

with just two colors—a foreground color and a » ‘
background color. These are always visible as

two swatches on the Color tab. Electronic artists

expend much of their creative energy deciding which of the millions of
available colors should fill those two slots. The actual steps involved,
however, can be quite simple (see Chapter 4).

5 Layers

If you’re accustomed to thinking of
pictures as flat illustrations in books,
or photgraphic prints, the concept of
image layers may take some getting
used to. In a typical PhotoPlus image—for example, a photograph
you’ve scanned in, a new picture file you’ve just created, or a bitmap
file you’ve opened—there is one layer that behaves like a conventional
“flat” image. This is called the Background layer, and you can think of
it as having paint overlaid on an opaque, solid color surface.
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On top of the Background layer, you can create any number of new
layers in your image. Each new one appears on top of another,
comprising a stack of layers that you can view and manipulate with the
Layer Manager tab. We call these additional layers standard layers to
differentiate them from the Background layer. Standard layers behave
like transparent sheets through which the underlying layers are visible.

There’s a third kind of layer, called a text layer (see Chapter 4), which
resembles a standard transparent layer but can only contain text. Text
layers keep blocks of text editable so you can go back and change the
font or retype characters.

With few exceptions, you will work on just one layer at any given time,
clicking in the Layer Manager tab to select the current or active layer.
Selections (see above) and layers are related concepts. Whenever
there’s a selection, certain tools and commands operate only on the
pixels inside the selection—as opposed to a condition where nothing is
selected, in which case those functions generally affect the entire active
layer.

If your image has multiple layers, and you switch to another layer, the
selection doesn’t stay on the previous layer—it follows you to the new
active layer. This makes sense when you realize that the selection
doesn’t actually include image content—it just describes a region with
boundaries. And following the old advice “Don’t confuse the map with
the territory,” you can think of the selection as a kind of outline map,
and the active layer as the territory.

We’ll first enounter layers later in this chapter. Chapter 5 provides in-
depth coverage.

6 Opacity and transparency

Opacity and transparency are complementary—
two sides of the same coin. They both refer to the E

degree to which a particular pixel’s color

contributes to the overall color at that point in the

image. (Pixels again are the “screen dots” that comprise a bitmap image
in PhotoPlus.) Varying opacity is rather like lighting a stage backdrop
(scrim) in a theater: depending on how you light the fine gauze sheet,
you can render the backdrop either visible or invisible. Fully opaque
pixels contribute their full color value to the image. Fully transparent
pixels are invisible: they contribute nothing to the image.
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You’ll primarily encounter these terms in one of two contexts. First, as
a property of the pixels laid down by individual paint tools, which can
be more or less opaque, depending on the tool’s opacity setting.
Second, as a property of individual layers, where opacity works like a
“master setting” that you can vary after paint has been laid down.

7 Saving and exporting

Saving a file in PhotoPlus means storing the

image in the native PhotoPlus file format, using ;E; [
the .SPP extension. This format preserves image @
information, such as multiple layers, masks, or
image map data, that would be lost in conversion
to another graphic format. On the other hand, suppose you’ve opened a
.BMP or .JPG file and want to save it back to its original format. In this

case, use the Save Original command.

In yet another instance, you may be ready to save an .SPP file (or
convert some other image type) to one of the standard graphics formats.
In PhotoPlus, this is known as exporting. PhotoPlus includes a powerful
Export Optimizer that serves as your “command center” for exporting
images to various formats. It not only provides a variety of options for
each supported format, but lets you compare image quality using
different settings and even retains your preferred settings for each
format!

There’s more on saving and exporting later in this chapter, and Chapter
7 includes details on file formats and optimizing images.

Starting PhotoPlus

Enough boring lecture—on to the demonstrations! (We’ll skip the
quiz.) It’s time to begin exploring PhotoPlus.

& NOTE: Throughout the Companion, we’ll use O checkbox
bullets to mark actual the ongoing tutorial thread: steps we’d like
you to complete as you follow along with the text. You’ll come
across many other descriptions and examples of commands,
tools, and procedures (and of course you’re encouraged to
experiment). But remember—unless a step has a checkbox, it’s
entirely optional!

The Setup routine adds a Seri f Phot oPl us item to the Pr ogr ans
submenu of the Windows St art menu.
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O Use the Windows St ar t button to pop up the Start Menu and

click on the PhotoPlus item.
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PhotoPlus launches and displays the Startup Wizard, with a variety of
choices:

¢

Open Saved Wor k displays a browser that lets you preview and
open saved image files—pictures in any supported format as well
as animated GIFs (see Chapter 3).

Creat e New Pi ct ur e opens a new image window using a size
and background color you specify (see Chapter 4).

Creat e New Ani mati on opens a new image window and
displays the Animation tab, with controls for creating animation
frames (see Chapter 6).

| mport from TWAI Nlets you bring in pictures from devices
like scanners and digital cameras (see Chapters 3 and 7).

Vi ew Sanpl es opens the gallery of PhotoPlus images.

Onl i ne Resour ces offers direct access to productivity tools
and reference sources.

If you don’t care to see the Startup Wizard again, uncheck the “Use the
Startup Wizard next time” box. However, we suggest you leave it
checked until you’re familiar with the equivalent PhotoPlus commands.

O Click Open Saved Wor k and then click the Br owse button in

the dialog.
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O PhotoPlus is set to initially display the contents of the PhotoPlus
ProJeCTS folder, located on your hard disk. If the Open dialog
displays a different folder, browse to PROGRAM
FILES\SERIF\PHOTOP50\PROJECTS.

& NOTE: Whether or not you use the Projects folder to store your
own work, remember its location so you’ll know where to find
Companion source files when they’re needed later on.

O Select the file CAT.JPG in the Projects folder and click Open.

The cat photograph opens in a new image window (your precise screen
layout may vary somewhat from the illustration).
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Getting your bearings

Now that you’ve got an image open, and the PhotoPlus menus and tools
are available, let’s take a quick look around the PhotoPlus environment.
Even if you’re in a rush to start working, don’t skip the rest of the
chapter! At the very least, take note of what’s here so you’ll know
where to find the information when you need it later.

Introducing the interface

PhotoPlus is an MDI application. MDI stands for Multiple Document
Interface and it means that you can have multiple documents—images,
in PhotoPlus terms—open at the same time. Each image window
contains one image, with the image’s hame shown in the window’s
titlebar. At any given time, one image window will be active in front of
any others, with its name shown in the main PhotoPlus titlebar.

You can use commands from the W ndow menu to arrange the image
windows. If you have more than one image open, then you can switch to
another window using the Window menu or the keyboard shortcut

Ctr 1 +Tab. Double-click on an image window’s titlebar to maximize
it.

The PhotoPlus toolbars and tab windows (tabs for short) are are
essential features of the PhotoPlus environment. The PhotoPlus
Toolbars and Tabs diagram identifies each tab and provides an
overview of what it does.

i To display the related online help topic for any tab, first click the
Help button on the top toolbar, then click the tab.

When you first launch PhotoPlus, it opens with the PhotoPlus toolbars
and tabs all visible in default positions, with certain tabs “docked” or
joined together. You can hide, show,

or move them individually as needed,

and dock or undock the tabs. Chances Color| Brush Tip |
are you’ll want to keep the Tools ' [

toolbar visible, but if your display ! % T i ml -FI- —
area is large enough you might !

consider moving it to a horizontal ! it Lo
position alongside the top (Standard) ! 1 —

toolbar—or “floating” it as a separate
palette. Remember, there’s nothing fixed about the PhotoPlus interface,
so feel free to try different arrangements until you’re satisfied.
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PhotoPlus Toolbars and Tabs

[DesEEe =ao o9

Standard toolbar
Provides standard file and Clipboard commands.
Click the [?], then any tab, for context-sensitive help!

T ool Properties
Tool F‘mperties]

;&@ﬂEBM

Dpacity: {100 2

Fade: IEI zteps

Stluz: [~ Size [T Opacity

Tool Properties tab
Lets you customize the settings for
many of the tools on the Tools toolbar

Brush Tip tab
Lets you choose and customize brush tips for
the painting tools, and define custom brushes

ZRN\NBPE L RERNN, O

- Bruzh Tip
. Brush Tip]
. e (9 . i
5 " . BE BE "
= . ' ' -

Tools toolbar

Features tools for selecting regions of the screen,
painting and erasing, cropping and deforming
selections, creating Web graphics... and more
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EEE -] Color tab

Eulur]
Color Mode - RGE =]

_HT-W
bl G m——
B?Iﬁ

Lets you select foreground and
background colors and change
the color mode

Layer Manager

Layer Hanager]

Dpacity: [ 100 =7 %

Layer Manager tab

Includes controls for creating, deleting,
arranging, merging, and setting P4
properties of layers in the image

Animation tab

Provides controls for editing
animation files (only appears
in Animation mode)

= ol [
@ ﬂﬂ B ackground

Animation

Animalion]

Frame Delay I 50
Total Time O : 050z

Loop =« l'l_’?/ W
4] |
O % E
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To turn off a tab, click the 2 Cl ose button in its titlebar. To turn a tab
or toolbar off or on, uncheck or check its name on the View menu. If
you need more room on-screen for a particular operation, press the Tab
key to turn all the visible tabs off, and again to turn them back on.

To dock or undock a tab, click on its label and drag to the new position,
either floating independently or docked in a window next to another
tab.

It’s easy to get online help in PhotoPlus. For a summary, see the
“Getting Help” section at the end of this chapter.

Setting preferences

To specify the ruler units, grid interval, and other preferences, choose
Pr ef er ences.. from the File menu to open the Preferences dialog.
Select the appropriate options on the Undo, Transparency, Layout
and/or Startup tab of the dialog.

When you have made your choices, click the OK button to save your
changes or click Cancel to abandon them.

Setting the view

Zooming (changing the relative size of the image in relation to its
window) and panning (moving the image in relation to its window) are
essential when you're operating at different levels of detail, or on
different portions or an image. PhotoPlus provides standard Zoom and
Pan tools.

g To change the image scale, choose the Zoom tool from the Tools
toolbar. To zoom in, left-click on the image. To zoom out, right-click
on the image. The current zoom ratio appears in the titlebar of the
image window, next to the file name.

You can also set a specific zoom ratio by choosing Zoom | n or Zoom
Qut from the View menu, then selecting a ratio from the submenu. To
restore a 1:1 viewing ratio, choose Nor mal Vi ewi ng from the View
menu.

ﬂ To pan, Choose the Pan tool from the Tools toolbar and drag the
image to move it in relation to its window.
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How to Get an Image into PhotoPlus

Before you can manipulate an image, you’ll need something to work
with! PhotoPlus can open images saved in a wide variety of industry-
standard file formats, and acquire images from your TWAIN-compliant
digital camera or scanner.

To get a saved image into PhotoPlus, you select Open Saved Wor k
from the Startup Wizard. The dialog displays image files you’ve
recently worked on; select a file or click the Br owse button to locate
other saved files. As an alternative to using the Startup Wizard, you can
select the name of a recently opened file from the File menu or choose
Fi | e/ Open... to display the Open dialog.

The Open dialog shows dimensions and bit depth (see Chapter 7)
information for each selected image. To display a thumbnail of the
image, check Show pr evi ew (this may slow down the display
somewhat).

If your scanner or digital camera supports the industry-wide TWAIN
standard, you can bring pictures from these devices directly into
PhotoPlus. (To set up your TWAIN device for importing, see the
documentation supplied with the device for operating instructions.)

To begin scanning a picture into PhotoPlus, either select the | mpor t
Fr om TWAI Noption in the Startup Wizard, or, if the program is
already running, choose | nport from the File menu and then select
Acqui r e. (If PhotoPlus is running but there’s no image window open,
choose New from the File menu to display the Startup Wizard.) If you
have more than one TWAIN-compatible device installed, you may be
prompted to select one as the source—or you can specify a different
source by choosing | mport/ Sel ect Sour ce from the File menu.

The acquisition software for the selected device will start up and
display its window, and you can then carry out the scan, possibly having
made a few basic adjustments. Note that the features available in image
acquisition software vary widely and are not under the control of
PhotoPlus. Usually, you will at least be able to adjust settings for the
image source (such as a color photograph, black and white photograph,
or color halftone) and the resolution at which the image is to be
scanned. For color theory and tips on scanning, see Chapter 7.
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Whether you import the image via the Open dialog or the TWAIN
interface, it will appear in a new image window in PhotoPlus. Assuming
the image is not in the native PhotoPlus (.SPP) format, it will always
have just a single layer, called the Background layer (see “Seven Key
Concepts” earlier in the chapter). Chapter 5 will explore layers in
considerable detail; until then we’ll be focusing on techniques that work
perfectly well on one—or at most two—Ilayers.

Saving and Exporting Files

PhotoPlus can save images in its own .SPP format, or export them to
any standard format (again, see “Seven Key Concepts”).

E Use Fi | e/ Save (or click the Save button) to save images in
PhotoPlus’s own .SPP format. Only .SPP images preserve information
such as multiple layers, masks, or image map data that would be lost in
conversion to another graphic format.

Use Fi | e/ Save As..to

save the image as an .SPP file  seenf[See S & @ &
under a different path or B o

name. You can store files
anywhere on your system. It’s
a good idea to group your

images, for example into flegane. e Eee s
project-oriented or thematic o | AN
folders.

Suppose you've opened a .BMP or .JPG file, done some editing
(without adding layers), and now wish to save it back to its original
format. In this case, you can use the Fi | e/ Save Ori gi nal or

Fil e/ Save Original As... commands. Using the former will
overwrite the original file—so be sure that’s what you want to do.

In many situations, you’ll want to
save a file to one of the standard | ST D
gr_ap_hlcs formats. In Phc_)toPIus, ey - emened

this is known as exporting. You el B

can use the Export Optimizer to PLrversise jog
preview image quality before at
File pame: etz Save |

various SettingS before gOing Save as pe: [IPEG Intsrchangs Fomet (*ipg) =l Cenedl
ahead with the export. optinzer

The File menu offers two ways of accessing the Optimizer. Either
choose Fi | e/ Export Optim zer. .. todisplay it directly, or
choose Fi | e/ Export. .. and then click the Qpt i m ze button in
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the dialog. The Export dialog itself is a standard file dialog where you
can specify the path, name, and format for the image file.

The Export Optimizer consists of a left-hand settings region and a right-
hand preview display, with additional buttons along the bottom of the
dialog. In animation mode, there's an extra tab for changing output
settings.

Export Options [x]

Options Is.ze |

Fomnat: -

GIF File size: 172.3 Kb

Bit depth
’7("'32('“24(78(“4 - ‘

Palath
Pal

’7(‘ Websafe  Optimized ‘

Dithering GIF Options
" Mone I Transparent
£ Ordered ™ Interlaced
& Enor diffusion
= 4 H E w12 Close I Cancel | Export |

To display a different portion of the image, drag the image in the
preview pane. To change the display scale, click the Zoom | n or
Zoom CQut buttons at the lower left.

To adjust the preview display, click one of the View buttons at the
lower left to select Single, Double, or Quad display. The illustration
above shows Single view. The multi-pane (Double and Quad) settings
let you compare different export settings for one or more file formats.
Just click one of the display panes to select it as the active pane, then
use the Options panel at the left to choose an export format and specific
settings. Each time you make a new choice, the active pane updates to
show the effect of filtering using the new settings, as well as the
estimated file size!

When you’ve picked the optimum export settings, click the dialog’s
Export or OK button to proceed to the Export dialog.

For details on image file formats and optimization, see Chapter 7.
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Printing

Printing is controlled from the Print dialog, which you can access by
choosing Pr i nt ...from the File menu, clicking the Pri nt button on
the Standard toolbar, or pressing Ct r | +P.

- Printer
Name:  [Lexmark Optra phis P52 = Propeities
Status; Default printer: Ready Options
Type: Lexmark Optra plus P52
Wwhere:  LPT1:
Comment; I Piint to file
i~ Print range: Copie:
& Al Murber of copies: |1 33
°) Fages fiom I Io; !
[ Collate
i Selection
oee_|

Choose the printer to use from the drop-down list. If necessary, click
the Properti es. .. button to set up the printer for the correct page
size, etc. It’s very important to set up your printer correctly to get the
best results. Click the Opt i ons. . . button if you need to set special
print options such as scaling, tiling, or CMYK color separations. (The
various print options are detailed in Chapter 7.)

After setting the printer properties and the print options, click on OK in
the main print dialog to send the image to the printer. Depending on the
size and complexity of the image, and the printer you’re using, it may
take several minutes before the printed page emerges.

Getting Help

The PhotoPlus online help system is designed to work for you.
Whatever your background, you’ll find it easy to navigate.

¢ To begin learning about PhotoPlus tools and menus, just move the
mouse pointer around the screen. Watch the HintLine at the lower
right for capsule descriptions of each feature. Event Tips pop up as
you try new tools and actions.

¢ For help on interface elements like toolbars and tab windows, click
the (3. Hel p button on the top toolbar, then click on an element.

+ For help on dialog boxes, click their internal Hel p button.

Several Help menu choices take you to key features of online help:
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¢ Choose Cont ent s to display the main help menu screen,
including links to the Welcome and Support pages.

¢ Choose | ndex to pop up the alphabetical list of help topics.

¢ Choose Ef fects Gal | ery to display a visual sampler of color
adjustments, and special effects — cross-referenced to help topics
(see Chapter 3 for more).

Once inside online help, choose Vi sual Ref erence or How To to
peruse help information using either a graphical or step-by-step
approach—whichever you prefer. Each section displays its own table of
contents in the main window, while help topics appear in a second
window. Extensive cross-references make sure all the information is
interlinked.
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This chapter will focus on ways of manipulating existing pictures, especially
photos. We’ll begin with a Hands-on Project using the “cat” image you briefly
opened in the previous chapter. Note that all of the techniques described here
can also be applied to images created from scratch, and to animations.

There are many reasons why you might want to manipulate a photo,
including:

¢ Cleaning up an old, damaged photo
¢ Removing an unwanted item or slogan from the background

¢ Preparing an image for printing, use on the World Wide Web or in
another package

If you agree that it’s time to do something about that smug-looking cat
from the previous chapter, here’s a Hands-on Project that provides an
introduction to manipulating images. Remember, the bullet checkboxes
denote the actual steps you should complete; anything else is optional.

HANDS ON: Captioning a Cat

O Open CAT.JPG in the PhotoPlus PROJECTS folder, if it’s not
already open. (See the section “Starting PhotoPlus.”)

o e T e b
D B ¥

Sy IPFR el Il pdd s
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Cropping the image

Cropping is one of the easiest ways to improve the appearance of a
photograph—by creating a more pleasing composition of its main
elements. In this particular photo, there’s just one main element, and it
fills the whole image! However, there are a couple of problems with
leaving the image uncropped. One is the rather boring curtain in the
background; the other is the large blurry tail in front. So let’s crop away
everything except the cat’s face.

PhotoPlus offers two basic ways of cropping an image. You can either
select a region of pixels, using any of the various selection tools, and
then use the | mage/ Crop to Sel ecti on command. We’ll cover
this method later in the chapter. If you’re cropping to a rectangular
shape its generally easier to use the Crop tool.

d H Choose the Crop tool from the
Tools toolbar and drag out a crop
selection around the cat’s head, as in
the illustration. Start at one corner and
drag to the other. Once you release the
mouse button, you can adjust the
selection rectangle by dragging its
edges or corners, or from the center to
move it.

U Once you’ve selected the correct area,
double-click within the selection
rectangle to complete the cropping.

By the way, if you make a mistake, don’t worry. Most actions in
PhotoPlus can be undone using Undo from the Edit menu, the Undo
button on the Standard toolbar, or the keyboard shortcut Ct r | +Z. You
can even undo an “undo”—use Redo on the Edit menu, the Standard
toolbar, or with Ct r 1 +Y. (The Fi | e/ Pref erences. . . dialog lets
you set options for the Undo function.)

Adjusting brightness and contrast

You may have noticed that this image is a little dark. No problem.
We’ll use one of the PhotoPlus image adjustment filters to improve it.

O Choose Adj ust >Bri ght ness/ Cont r ast ...from the Image
menu to open the Brightness and Contrast Filter dialog.
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O Experiment with the Br i ght ness and Cont r ast sliders. Each
time you “upclick” after dragging a slider, the image updates.
Alternatively, you can type values directly into the fields at the
right.

Although you may not achieve perfection with just the Brightness
/Contrast adjustment, try to obtain solid “bottom” and “top” (shadow
and highlight) regions without obscuring details or washing out the
image. The Brightness slider tends to move all the tones in the image
one way or the other; Contrast compresses or expands the spread
between bottom and top. Try the values shown—but remember that
monitor settings and room lighting can make a difference.

Brightness and Contrast Filter E
Brightness s IS
Contrazt s |51

()8 | Cancel |

O When the picture looks good, click OK. (If you click Cancel , the
photo returns to its previous state.)

O At this point, you may wish to save the picture as a PhotoPlus
(.SPP) file using Fi | e/ Save...

Adding a caption

Finally, we’ll venture into uncharted territory. Adding a caption to the
photo is easy, but it will introduce several new operations: choosing a
color, using the Text tool, and working with more than one layer. Don’t
worry—it will be a very mild introduction!
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U Locate the Color tab, which is o] Hach T |
probably still open at the right side - m:“""i"—
of the screen—nbut if it’s hidden, sl s —
check its item on the View menu to ' e L

display it. Click the tab so it comes

to the front and you can see all of u
it.

The Color tab includes (among other things) two color swatches that
show the current foreground and background color (another of those
“Key Concepts™), and a spectrum box that lets you change them.

U Move the cursor over the spectrum box and you’ll see a preview
swatch (not shown in the illustration) appear, showing the exact
color under the cursor. Find a very light color that you like, and
left-click. You’ll see the foreground swatch update. If you want to
choose a different color, move the cursor and click again.

O Now choose the A Text tool from the Tools toolbar. Notice there
are two text tools on the flyout. Pick the first one, which is for solid
text (the other is for creating selections in the shape of text).

O Once your cursor has changed to an “A,” click it on the picture in
the approximate position where you want the text to be. This opens
the Add Text window.

O Type the caption text (on two lines, if you’re using our example)
and choose a font, pointsize, and style (we used Arial 14pt Bold).

[rial e = Bl [= = = F antidlissed
Wake me |

when it's over...

Note that the formatting is applied to all the text in the window (no need
to select it first), and that the text is black (for visibility) rather than the
foreground color at this point. The dialog also has an Adj ust Col or
button—but let’s leave that for later.

O Click OKto insert the caption.

The text appears (in the foreground color) on a new text layer above the
Background layer that has the photo. The text layer is now the active
layer. Because it’s on a separate layer, the text is editable and can be
repositioned independently of any other image layers. (Chapter 4 will
have more on working with text.)
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O Choose the ﬂ Move tool from
the Tools toolbar and drag the
text around until it is in the right
position on the image.

Finally, save the modified image again - : \
and/or export it to another format, T

such as .BMP or .JPG. Since ﬁ;
exporting “flattens” the image into a =

single layer, you’ll probably want to e
retain an .SPP image with the layers

intact, in case you decide to do some
more editing later.

Wake me
when it's over...

Making Selections

Before you can apply effects or filters, or copy parts of a picture to the
Clipboard, you must define an active selection area.

Selection options

In the example just completed, you adjusted brightness and contrast in
the image as a whole, and dragged an entire text layer around. Many
times, however, you’ll want to select just a subset of the image (or
layer) to work on. Selecting, you may recall, was one of the “Key
Concepts” presented in Chapter 2. Understanding what you can do with
selections opens up exciting creative possibilities.

Whenever there's a selection, certain tools and commands operate only
on the pixels inside the selection—as opposed to a condition where
nothing is selected, in which case those functions generally affect the
entire active layer. For example, when there's a selection, the brush
tools only work inside the selection; the color simply doesn't affect
outside pixels. If you apply an adjustment or special effect from the
Image menu, it only affects the selected region.

Clicking a layer’s nhame on the Layer Manager tab makes it the active
layer. To select the whole active layer, choose Sel ect Al | from the
Select menu or press Ct r | +A.
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PhotoPlus offers a very wide range of selection tools, and a variety of
commands for modifying the extent or properties of the selected pixels.

%] The standard selection tools are located on the Standard
Selection Tools flyout on the Tools toolbar. There you can choose from
the Rectangle, Ellipse, Freehand, or Polygon tools.

To select a rectangular or elliptical area, select the . Rectangle or &
Ellipse tool from the flyout and drag to define a region on the image.

Rectangle / Square Ellipse / Circle

The selected region is bounded by a broken line or marquee, and the
cursor over the selection changes to the Move Marquee cursor, which
lets you reposition just the marquee as needed without affecting the
underlying pixels.

Holding down the Ct r | key during dragging constrains the selection
shape to either a square or a circle.

“ To select a freehand (irregular) area, select the Freehand selection
tool and just drag to draw around the area to be selected, making a
closed area.

“# Or use the Polygon selection tool to draw a series of line segments
(double-click to close the polygon).

1
1
1
-—_d

Freehand Polygon-

IJ."’-I‘.T ! L]
-
L e
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The Adjustable Selection Tools flyout, a unique
PhotoPlus feature, offers 16 different variable
selection shapes, including pie, star, arrow, heart,
spiral, wave, and so on.

Here’s how the adjustable selection tools work.
We’ll use the regular polygon selection shape as
an example. Choose a tool from the flyout and drag out a shape on the
image. You can hold down the Shi f t key to constrain the selection's
aspect ratio.

The regular polygon appears as a blue outline with

two slider tracks bounding it. Each of the slider S
tracks has a square handle, and when you move the

cursor on to the handle it will change to a small +

sign. As you drag the sliders, the shape’s

properties change. In the case of the polygon, one

slider varies the number of sides, while the other rotates the shape. As
with standard selections, you can move the whole selection around by
dragging from its center.

Once you’re satisfied with the selection, double-click in the center (just
as you did with the Crop tool) to create the selection marquee.

M Using the Color Selection tool, you can select a region based on
the color similarity of adjacent pixels.

To make a selection in this way, choose the tool from the Tools toolbar
and then click on a starting pixel. This selects the pixel you clicked, and
any adjacent pixels that are similar in color, as measured by the
tolerance value shown on the Tool Properties tab. You can raise or
lower the tolerance setting to include more or fewer pixels.

PhotoPlus also offers a Text Selection tool that lets you create a text-
shaped selection region and vary its size or font (see the next chapter).

Modifying the selection

Once you've used a selection tool to select a region, you can carry out a
number of additional steps to fine-tune the selection before you actually
apply an effect or manipulation to the selected pixels.

Any time you're using one of the selection tools, the cursor over a
selected region changes to the Move Marquee cursor, which lets you
drag the marquee outline to reposition it. In this case you’re only
moving the selection outline—not the image content inside it. You'd use
the Move tool (see below) to drag the selection plus its image content.
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If the selection you've made isn't quite the right shape, or doesn't quite
include all the necessary pixels (or perhaps includes a few too many),
you can continue to use the selection tools to add to, or subtract from,
the selected region. To add to the existing selection, drag with the
selection tool while holding down the Shi ft key. To subtract, drag
while holding down the Al t key. Pressing the Ct r | key changes the
tool temporarily to the Move tool (see below), so you can move the
selection’s content.

The Modi fy item on the Select menu provides a submenu with several
functions that can save you the trouble of hand-drawing to change the
selection boundaries. Choose Cont r act . . . to shrink the borders of
the selection, or Expand. . . to extend its borders.

Growand Si m | ar both expand the selection by seeking out pixels
close (in color terms) to those in the current selection. G- ow only adds
pixels adjacent to the current selection, while Si i | ar extends the
selection to any similar pixels in the active layer. Both of these use the
current tolerance value entered for the Color Selection tool (see above).

To remove the current selection, choose Desel ect from the Select
menu, or use the keyboard shortcut Ct r | +D.

The I nvert command on the Select menu (shortcut
Ctr 1 +Shi f t +1 ) selects the portion of the active layer outside the
current selection. Unselected pixels become selected, and vice versa.

Once you have selected precisely the pixels you want to work on (as
covered so far in this chapter), the question arises, what can you do with
the selection—or technically speaking, with the pixels you've outlined?
This rest of the chapter will survey the many possible manipulations
you can carry out.

Using the Move tool

ﬂ The Move tool (unlike the Move Marquee cursor associated with
the selection tools) is for pushing actual pixels around. With it, you can
drag the content of a selection from one place to another, rather than
just moving the selection outline. To use it, simply click on the
selection and drag to the new location. The selected part of the image
moves also.

If nothing is selected, dragging with the Move tool moves the entire
active layer. Moving image content on the Background layers exposes a
“hole” that appears in the current background color; on standard layers,
exposed region is transparent.
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To duplicate the contents of the selection on the active layer, press the
Al t key and click, then drag with the Move tool.

As a shortcut if you’re working with any one of the selection tools, you
can press the Ct r I key to switch temporarily to the Move tool. Press
Ctrl +Al t to duplicate. Release the key(s) to revert to the selection
tool.

Cut, Copy, Paste, Delete

These operations work pretty much as you’d expect. You can use the
buttons on the Standard toolbar, choose commands from the Edit menu,
or use conventional keyboard shortcuts.

As with the Move tool, “holes” appear as either the current background
color or transparent, depending which layer you’re working on. Also
keep in mind the handy Al t +Move tool operation (above) for quickly
duplicating selected pixels.

When pasting from the Clipboard, PhotoPlus offers several options.
The standard paste (Ct r | +V) operation creates a new, untitled image
window. You can use other Edit menu choices to paste the Clipboard
contents as a new layer, or centered into the current selection (if there is
one).

Cropping

Cropping is the electronic equivalent of taking a pair of scissors to a
photograph, except of course with a pair of scissors there is no second
chance! Cropping deletes all of the pixels outside the crop selection
area, and then resizes the image canvas so that only the area inside the
crop selection remains.

H If you tried the captioning project earlier in the chapter, you’ve
already used the Crop tool to reduce an image to a regular, rectangular
area. Just select the Crop tool from the Tools toolbar and drag out a
rectangular crop selection area on the image. (Hold down the Ct r | key
while dragging to constrain the selection to a square.) Adjust the
selection rectangle as needed, then double-click to complete cropping.
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You can also crop an image to any selection region, no matter what
shape, as defined with one of the selection tools (see above).

Make a selection using one of the selection tools and then choose Cr op
to Sel ecti on fromthe Image menu. For example, here’s cropping
applied to a marquee drawn with the Freehand Selection tool:

P W e

PhotoPlus always crops to a rectangular image. If the selection region is
non-rectangular, the left-over surrounding region will be either
transparent (on a standard layer) or the background color (on the
Background layer).

Tip: To convert the Background layer to a standard layer, right-click
Backgr ound on the Layer Manager tab and choose Pronote to
Layer . Now operations on the layer’s content (such as moving,
cutting, or irregular cropping) will leave transparent “holes.”

Flipping, Rotating, and Deforming

Flipping and rotating are standard manipulations that you can carry out
on the whole image, the active layer, or just on a selection.

To flip, choose either Fl i p Hori zontal Iy orFl i p

Verti cal | y fromthe Image menu, then select | mage, Layer, or
Sel ect i on from the submenu. If you flip an image horizontally, be
careful not to accidentally reverse things like text, numbers, and so on.

To rotate, choose Rot at e...from the Image menu to open the Rotate
dialog. Set the rotation angle (90, 180, or 270 degrees, or enter a
custom angle) and the direction (clockwise or counter-clockwise).
Select | mage, Layer, or Sel ecti on and click OK.
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The image will rotate about the center point.

Original image 15° counter-clockwise 10° clockwise

ﬂ The Deform tool is a “Jack of all trades” that lets you move,
scale, or rotate a selection or layer. Try it on a text layer for unique
results! Start by making a selection if
desired, then choose the tool. A rectangle
appears with handles at its corners and
edges, and a fixed point (initially in the
center of the region). If there's no selection,
the rectangle includes the whole active
layer.

The tool's action depends on the exact position of the mouse pointer. As
you move the pointer around the enclosed region, the cursor changes as
shown below to indicate which action is possible.

@) To move the region without any deformation, drag from its
neutral midsection. This action works just like the Move tool.

To reshape the region, drag from an edge or corner handle. A
‘E@ variety of options are available when you drag from a corner
(watch the HintLine for tips). You can resize in two dimensions or
relative to the fixed point, either with or without a constant aspect ratio.
In addition, you can get skew or perspective effects that move either
one corner by itself, or two adjacent corners!

---.  Torotate the region about the fixed point, drag from inside the
:I @ ‘I dotted line. To constrain rotation in 15-degree steps, press the

_+Shift key after you've begun rotation, and hold it down until
R after you release the mouse button.

h

To reposition the fixed point, move the cursor to the exact
@ center until a small “x” appears, then drag. The fixed point can be
moved anywhere—even outside the deformation region.
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HANDS ON: Deforming text

To get a feel for the versatility of the Deform tool, let’s try a short
project.

U To begin, choose New from the File menu and (on the Startup
Wizard) click Cr eat e New Pi ct ure.

O Inthe New Image dialog, set the image dimensions to 500x500 or
so. The background type should be set to White.

O Click CK and the new image window opens. The image initially
has a single Background layer.

O Now choose the A Text tool and click in the image to open the
Add Text window. Type some text, set it large (around 24pt), and
click OK. (You’ve done this before in the captioning project.) The
new text appears on a separate text layer.

O Choose the Deform tool, which automatically grabs the text on the

layer.
O Move the cursor near a corner handle until you it changes to a

double-headed arrow. Then drag to resize the letters either
vertically or horizontally.

PhotoPlt

U Hold down the Shi f t key and drag from a corner to resize in both
dimensions at the same time. The little chain in the cursor tells you
that the dimensions are linked, constraining the aspect ratio.

PhotoPlt

O Hold down the Ct r| key over a corner handle and the cursor
changes to a grid shape. Continue to hold down the Ct r | key
while dragging to skew the object.
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Zz2/

O Move the cursor over the circle at the center of the grid and it will
change to a rotation arrow. Try dragging to rotate the text, and
holding down the Shift key for constrained rotation.

Phc

O Press Shift+Ctrl +Alt while dragging from a corner for a
perspective effect. Note that you can still apply layer effects, fills,
and other manipulations to deformed image content. And once you
have rotated or deformed text, you can still edit it as long as it’s on
a text layer!

A PIU;

Adjusting Image Colors

The | mage/ Adj ust menu provides a number of different adjustment
filters that you can apply to a selection or to a non-text layer (the
commands are grayed out if the active layer is a text layer).

Each of the Adjustment options works in a similar way. At the top of
most of the dialogs there is a preview area. Zoom in or out by clicking
on the magnifier below the preview image. Alter the values by dragging
on a slider, moving it to the left to decrease the value, or the right to
increase the value, or enter a value in the field at the right of the slider.

Tip: Instead of dragging the slider with the mouse, you can click on it
and then jog it with the left or right cursor arrow keys.

For an overview of image adjustments, take a look at the Effects
Gallery, a component of PhotoPlus online help. It’s a great way to get
an overview of what Adjustments and Effects do.
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To access the Effects Gallery, choose Ef fects Gal l ery... from
the Help menu, or click Ef f ect s Gal | er y on the main help
Contents menu.

The Effects Gallery provides illustrations of all the Image Menu
adjustments and effects. For each category, there’s a list of names.
Clicking on the name shown in red text displays an example, and then
clicking the name again (now in green text) displays the corresponding
help topic in an adjacent window. This way you can browse the
illustrations and read about them at the same time.

EGE IFFECTE
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Click on the View Original button above each illustration to view the
image as it appeared before the filter was applied. Click on the Apply
Effect button to see the after state.

Here’s a quick summary of the PhotoPlus image adjustments.

¢ Brightness/Contrast: Brightness refers to overall lightness or
darkness, while contrast describes the tonal range, or spread
between lightest and darkest values.

¢ Hue/Saturation/Lightness: Hue refers to the color's tint—what
most of us think of as rainbow or spectrum colors with name
associations, like "blue" or "magenta.” Saturation describes the
color's purity—a totally unsaturated image has only grays.
Lightness is what we intuitively understand as relative darkness or
lightness—ranging from full black at one end to full white at the
other.

¢ Replace Color lets you “tag” one or more ranges of the full color
spectrum that requre adjustment in the image, then apply variations
in hue, saturation, and/or brightness to just those color regions.

+ Gamma adjusts the red, green and blue in an image to compensate
for the way the monitor displays colors.
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¢ Threshold creates a monochromatic (black and white) rendering.
You can set the threshold, that is the lightness or gray value above
which colors are inverted.

¢ Equalization evenly distributes the lightness levels between
existing bottom (darkest) and top (lightest) values.

¢  Stretch establishes new bottom and top values and spreads out the
existing lightness levels between them.

¢ Negative Image inverts the colors in a selected area, giving the
effect of a photographic negative.

¢ Grayscale reduces a color picture to 256 shades of gray.

Applying Effect Filters

The PhotoPlus Image menu includes a number of commands that apply
special effects to the active layer or selection. As with the image
adjustment filters you can use these effects to improve the image—for
example by sharpening or removing “red eye”—but more often the
emphasis here is on the wild and wacky (or perhaps we should say
“creative”) possibilities.

(EETIETEEE—C1 Yoy can even define your own custom filters
(see online help for details).

The Effects Gallery, as mentioned earlier,
includes examples of all the special effects,
cross-referenced to explanatory text for each
effect.

To access a group of effects, choose | mage
and select one of the commands.

At the top of most of the dialogs there is a
preview window that updates as you adjust the
sliders or enter new values. To see a different
part of the image, drag it with the hand cursor. Click the Zoom buttons
to zoom in or out. To view the current layer only, check Preview
Current Layer Only.

P [ | e |
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HANDS ON: Photo-painting

This fun project will apply a series of experimental manipulations that
make a photograph of a Paris street scene look more like an abstract
painting.

O Open the file FRANCE.JPG in the PhotoPlus PROJECTS folder.

U Choose Adj ust >Bri ght ness and Contrast from the
Image menu and increase the brightness by 17.

U Choose Bl ur >Gaussi an Bl ur from the Image menu and
apply a Gaussian Blur with a Radius of 5 and a Falloff of 5%.

O Choose Ot her >Post eri ze... from the Image menu and apply a
posterize value of 13.

U Choose Adjust>Hue, Saturation, Lightness from the Image menu
and boost the saturation to 200.

O Choose Edge>Enhance from the Image menu, then
Bl ur >Sof t en from the image menu. Et voila!
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Multiple effects

It’s quite possible to apply several effects to the same image, and,
depending on the order in which they are applied, to end up with a
different final result.

Embossed by 70 Blurred by 20

Original

HANDS ON: Removing Red Eye

Fixing “red eye” in flash photos—the annoying effect which makes
people’s eyes glow like a zombie—is normally tedious and time-
consuming, but PhotoPlus makes it easy with a built-in filter.

We’ve included a sample file that’s ideal for demonstrating the red eye
fix.
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U Open REDEYE.SPP in the
PhotoPlus PRoOJECTS folder.

O Choose Ot her/ Fi x Red
Eye..from the Image menu
to open the dialog.

You work on one eye region at a
time.

Q iﬁ Click the Sel ect

Ar €a bUtton and then CIICk [~ Preview Current Layer Only it)\ 1_1 1-)\
on the pupil of the left eye.
pup 4 E ki
Immediately, a selection mask Looss & Stiict
(circle) appears around the Had s A
designated region and the Bl
current correction settings are ™
Heb 1 cored |

applied there.

The default settings are probably good, but if fine-tuning is needed,
adjust the sliders (or enter specific values) as the preview window
updates. Redness Tolerance (from Loose to Strict) controls how much
red is removed. Blur Amount (from Hard to Soft) expands the black
area to form a bigger pupil.

U When the left eye is fixed, repeat the procedure for the right eye,
and when you’re done, click OK. That’s all there is to it!

HANDS ON: Antiquing a Photo

This sequence will show you how to make a new color photo look like
an old sepia-toned image, and will also introduce some new layer
techniques—a preview of Chapter 5’s in-depth coverage.

O  Open the file HOUSE.JPG in the PhotoPlus PROJECTS folder.
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O Choose Adj ust >Bri ght ness & Cont r ast .. from the Image
menu and increase both the brightness and contrast by 10 to make
the picture look a bit faded.

O Next, add some grain to the
image by choosing
Noi se/ Add.. from the Image
menu. Increase the value to
about 15.

O Choose
Adj ust >Gr ayscal e from
the Image menu to make the
photograph black and white.

To create the sepia look, we will be adding a semi-transparent color
layer above the photo.

O Choose New.. from the Layers menu. In the dialog, call the new
layer “Sepia” and set its Opacity to 40. Click OK and you’ll see the
new layer’s name appear on the Layer Manager tab (although the
image won’t look any different).

O Using the Color tab, set the foreground color to be an orange hue
(suggested values: R=255, G=166, B=0).

a &I: Select the Flood Fill tool and click on
the image to fill the active layer (“Sepia™)
with the foreground color. (The next chapter
will look at fills in more detail.)

The last step is to add a simple frame.

O On the Color tab, define black as the background color, either by
right-clicking in the spectrum or clicking the background swatch
and setting its RGB value to “0,0,0.”
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O Choose Canvas Si ze. .. from the Image menu. Add 40 to
each value shown in the Width and Height boxes. Click the center
Anchor point so that the existing image will be centered with
respect to the edge pixels being added. Click OK.

The result? A black border around the sepia-toned photo. If the results
don’t look quite right to you, feel free to retrace your steps using Undo,
and try new toning values, transparency, or canvas adjustments.
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The previous chapter described a variety of ways of working with
existing images—especially photographs, and usually on a single layer.
Now it’s time to look at creating elements from scratch, using the range
of PhotoPlus paint and text tools. Perhaps you need to add text to a
photo, along the lines of Chapter 2’s “cat” Hands-on Project. Or
perhaps you’re starting out with a blank canvas and want to try some
interesting graphic shapes and color combinations for a logo or custom

Web button.

Whatever your creative goals, all of the functions described in this
chapter can be applied to photographic images or images opened from
file as well as to new work!

Choosing Colors

At any given time, PhotoPlus allows you to work with any two colors—
called the foreground color and the background color. These are
always visible as two swatches on the Color tab. In this example, the
foreground color is set to black and the background color to white.

Codar x|
Color] Brush Tip |

Coloe Miode - RGE

Here are some things to remember about how these colors are used:

¢ Cutting, deleting, or erasing an area on the Background layer
exposes the background color. On other layers,
removing an area exposes transparency.

¢ To swap foreground and background colors, click the @
double arrow next to the Color tab swatches.
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There are a several simple ways to set the foreground or background
color.

ﬂ One is to use the Color Pickup tool on the Tools toolbar. Left-
click with the tool anywhere on an image to “pick up” the color at that
point as the new foreground color, and right-click to define a new
background color. As a shortcut if you’re working with one of the
drawing tools (paintbrush, line, etc.), you can press the Al t key to
switch temporarily to the Color Pickup tool. Release the key to switch
back once you’ve left- or right-clicked to make a color selection.

Another way is to use the Color tab. To quickly
u select foreground or background color, move

the mouse pointer (dropper cursor) around the
tab’s Color Spectrum. As you do so, a preview swatch pops up
showing the color at the cursor position. Left-click in the spectrum to
set a new foreground color, and right-click to set a new background
color.

Yet another way is to click either the foreground or the background
swatch (a white border around either box tells you it’s selected), then
use the sliders or enter numeric values in the boxes to define a specific
color. The selected swatch updates instantly.

Double-clicking either a foreground or background color swatch on the
Color tab brings up the more complex Adjust Color dialog, which lets
you define and store a set of custom colors interactively, using a color
wheel. See the “Choosing colors” topic in online help for details.

The Color tab also makes it possible to set the working color mode to
any one of the following: RGB (Red, Green, Blue); HSL (Hue,
Saturation, Lightness); CMYK (Cyan, Magenta, Yellow, Black); or
Grayscale. (For lots of useful terms and theory relating to color
definition and color modes, see Chapter 7.)

HANDS ON: Step into the Sandbox!

Our approach in exploring the various painting and drawing tools is
going to be decidedly freeform! Rather than prescribe step-by-step
sequences, we’ll let you follow your own muse as you experiment with
each tool. As you read through the descriptions, watch for the checkbox
bullets that will offer suggestions. No one is expecting a masterpiece—
perhaps just some inspired doodling!

O To begin the session, choose New from the File menu and (on the
Startup Wizard) click Cr eat e New Pi ct ure.
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O Inthe New Image dialog, set the image dimensions large enough to
give yourself plenty of white space. 500x500 should be about right.
Leave the resolution at 96 pixels per inch (that’s standard screen
resolution). The background type should be set to White.

O Click OK, and the new image window opens. The image initially
has a single Background layer.

O Choose New. . . from the Layers menu, then click OK in the
dialog.

You’ve just created a new standard (transparent) layer named Layer 1.
You’ll see its name on the Layer Manager tab, above the Background
layer. As we move through the tools, you should try them out on both
the Background layer or the standard layer, to see the difference.

O To begin with, click “Background” on the Layer Manager tab, so it
becomes the active layer for painting on.

Painting and Drawing

PhotoPlus’s basic tools for painting and drawing are located, like the
selection tools, on the Tools toolbar (initially at the left of the main
window).

i If you wish to display the related online help topic, choose the
Cont ext Hel p button and then click the Tools toolbar. (The same
goes for any tab or toolbar.)

Note that if there is currently a selection, the brush tool will only work
inside the selected region. If you try to paint over the edge of a
selection, the cursor will continue moving but the line will come to an
abrupt halt at the edge of the selection. Or if you’ve forgotten that
there’s a selection (perhaps you hid the marquee) and the brush doesn’t
seem to work—you’re probably just painting outside a selected region.

Using the basic Paintbrush tool

g The Paintbrush tool is used for freehand drawing. Successful
freehand drawing requires practice and a steady hand! You might find it
easier if you use a graphics tablet, rather than a mouse.

To paint a line using the Paintbrush tool, select it from the Tools
toolbar. When you move the Paintbrush tool over the image the cursor
will change into a paintbrush.
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U Select “Background” on the Layer Manager tab, so you will start
out painting on the bottom layer.

U Choose the Paintbrush tool. Left-click and drag to draw a freehand
line. Then draw some more lines.

U If you don’t like what you drew, press Ct r | +Z to undo (but
remember, this is all experimental—the more paint you get on the
screen, the better!).

U Your lines appear in the currently selected foreground color. To
paint with the background color, click the arrow on the Color tab to
switch the two colors. Now might be a good time to try various
techniques for selecting different foreground and background
colors, as described earlier in the chapter.

Choosing and customizing brush tips

All of the paint tools work in conjunction with the Brush Tip and/or
Tool Properties tabs, so let’s see how they work with the basic
Paintbrush tool.

Brush Tips determine the basic size and shape of the mark the brush
tools make on-screen. The lines you’ve drawn so far with the
Paintbrush tool may be thick or thin, depending which brush is
currently selected.

Brush Tip
Brush Tip]
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O Display the Brush tip tab and note which tip is selected. Click a
different one. To draw a “pencil” line, choose a single-pixel brush.

You’ll notice that some brushes have hard edges, while others appear
fuzzy, with soft edges. The hardness of a brush is expressed as a
percentage of its outer diameter. If less than 100%, the brush has a soft
edge region within which the opacity of applied color falls off
gradually.

O To see what this means, try using a medium-sized hard-edge brush,
and then switch to a soft-edge brush. You’ll note the difference
immediately.
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To customize a brush tip’s properties, double-click it on the Brush Tip
tab (or right-click it and use the popup menu) to open the Brush
Options dialog. As you vary the controls, you can see the effect of each
change in the preview window. Note there are five brush properties in
all. (See the tab’s Visual Reference entry in online help for details.)
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Right-clicking a brush tip’s square on the Brush Tip tab provides
several other choices, including deleting a brush tip or creating a new
one.

Setting tool properties

The Tool Properties tab is really an extension
of each tool’s functionality. Use it to customize
the way each tool affects pixels on the screen,
and (if you’re using a pressure-sensitive drawing P 0 g
tablet) how the tool responds to pressure Syt I Siw [ Dty
variations you apply with the pen.

For the basic Paintbrush tool and most other creation tools, you can
alter the Opacity, and number of Fade steps.

¢ Opaci ty is basically the same concept as “transparency”—
they’re just different ends of the same scale (0% opaque is 100%
transparent). Thus a lower opacity value produces paint that’s more
transparent, with less effect on existing pixels on the layer—more
of the underlying paint “shows through.” A fully opaque stroke
completely replaces all pixels in its path.

¢ Fade simulates a realistic brush stroke, with less paint applied
over a longer stroke. The more steps, the longer the stroke takes to
fade out. For a continuous flow, with no fade-out, use a setting of
0.
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U Take a few moments to experiment with varying the opacity and
fade settings. With opacity, note how different settings affect the
way the foreground color gets painted over existing color.

U Click “Layer 1” in the Layer Manager tab and try painting on the
upper, transparent layer. Using semi-transparent brush strokes,
you’ll begin to see how you can combine and overlap colors on
different layers.

If you have a pressure-sensitive stylus, checking the Si ze box causes
the brush size to vary according to pressure. A light application of the
pen makes for a very thin brush stroke, and full pressure allows the
brush size to expand up to the defined size. (If your brush tip is defined
as 35 pixels wide, that’s how wide it would be at full pressure.) You can
also turn on the Opaci t y option so that faint pressure then correlates
to a fainter brush stroke.

Using the Airbrush tool

ﬂ Like the Paintbrush tool, the Airbrush tool is used for freehand
drawing in the foreground color, but it behaves like a spray-can.
Holding the tool over one spot with the left mouse button held down
“sprays” more paint.

The choices for Brush Tip and Tool Properties tab settings for the
Airbrush are the same as for the Paintbrush. Note that PhotoPlus
“remembers” your custom settings for each individual tool.

To paint a line using the Airbrush tool, select it from the Tools toolbar
and drag over the image area.

O Choose the Airbrush tool and experiment with it, noting how it
differs from the Paintbrush.

O Try airbrushing on both the Background and the standard
(transparent) layer while varying properties, particularly opacity.

Using the Eraser tool

E The Eraser tool works very much like the preceding brush tools,
with the same range of Brush Tip and Tool Properties tab options. But
it is used instead to rub out pixels and replace them with whichever
color is selected as the background color.

To erase, select the tool from the Tools toolbar and drag over the image
area. On the Background layer, erased pixels are replaced by the current
background color. On other layers, they are replaced by transparency.
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O Try erasing and experiment with varying the opacity setting on the
Tool Properties tab. You’ll see that erasing is by no means an “all-
or-nothing” proposition. Some wonderfully creative effects are
possible using a semi-transparent eraser to reduce the contribution
of existing pixels to the overall image.

O Again, switch between the Background and standard layers to see
the results.

O By now, you may be getting inspired to create something
“interesting” instead of just scribbling. Perhaps it’s time to get a
beverage, make a few phone calls, and while you’re at it (if you
haven’t already) save this masterpiece-in-progress. We’d suggest
SANDBOX.SPP.

Using the Smudge tool

% Smudging may sound silly, but the Smudge tool can be quite
useful for blending pixels the way an artist might hand-blend pastels. It
comes in handy when retouching photos—along with the Clone tool,
which we’ll look at next. Now that you have a trial image with lots of
painted and overlapping lines, let’s briefly try out the Smudge tool.

To use the tool, select it from the Tools toolbar and drag to pick up
color from the initial click point and “push” it in the direction of the
brush stroke.

Ui

Smudge tool properties are the same as for the Paintbrush and Airbrush,
except that there’s no Fade setting.

Q Try using the tool to smear a painted line outward, or create a mix
of two colors (using a semi-transparent setting). Experiment with
the effects of both a hard-edge and a soft-edge brush tip.

Q For best results when using extended strokes, set the brush tip’s
Spacing property to 1.

Using the Clone tool

@ Like the preceding tools, the Clone tool uses a brush, but it’s
really a high-tech version of a pantograph—that

device with two connected stylus points, one that
traces an original drawing, the other that draws an =
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exact duplicate somewhere else. For example, you can use the Clone
tool to brush away skin blemishes by cloning some “good skin” over
them, or remove an unwanted object from an image by extending some
foliage to cover it. Or you can easily clone a sheep...

To clone a region, select the tool from the Tools toolbar and set its
properties. Then Shi f t -click where you want to begin copying; we’ll
call this the “pickup point.” Click and begin dragging somewhere
else—even in another image window—uwhere you want to begin placing
the copied pixels; let’s term this the “putdown point.” You’ll see a
crosshair cursor appear back at the pickup point. As you drag, pixels
from the pickup region are cloned in the putdown region by the tool’s
brush tip. The crosshair and brush tip cursors move in sync. The result?
A perfect copy.

U You really should try this firsthand. Choose the Clone tool and
(working on either layer), follow the procedures just described.
You’ll see the best results if you clone a region that’s well painted
over, rather than just a thin line. Remember: Shi f t -click to pick
up, click and drag to put down. Watch the cursors and what’s
happening will be evident.

In addition to the usual settings, the Clone tool has an Al i gned
option on the Tool Properties tab. This affects what happens if you use
more than one brush stroke. There are two possibilities when you click
to begin a second stroke: either (upper view)

the crosshair resets itself at a fixed distance 07 &
from the brush tip—maintaining the same Q “m,
separation between the cursors as on the first L

stroke, or (lower view) the crosshair resets y
itself to the original pickup point. In the first '}?:Q
case (called “aligned” because the two cursors

remain in alignment), subsequent brush
strokes extend the cloned region rather than producing multiple copies.
In the second you begin cloning the same pixels all over again from the
original pickup point.
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O Again, experience is the best teacher. Repeat the cloning
procedures you tried a moment ago—but this time reverse the
Al i gned setting. You’ll see the difference.

Creating Lines and Shapes

In addition to the various brush tools, the PhotoPlus Tools toolbar
includes the Line tool for drawing straight lines, and the Shape Tools
flyout featuring an assortment of tools for creating rectangles, ellipses,
polygons, and other shapes. Each shape is adjustable, so you can
experiment before committing to a particular figure—with innumerable
possibilities!

-
J To draw a straight line, select the Line tool
from the Tools toolbar and drag the tool on the
image. Fade 1 g

.—-—"/_

Hold down the Shi ft key while dragging to constrain the line to 15°
angles.

The Tool Properties tab provides the familiar Opacity setting for the
Line tool. You can also set the Wei ght (thickness) of the drawn line,
and turn Ant i - al i asi ng on or off. Anti-aliasing produces smooth
edges by making the selection’s edge pixels semi-transparent.

It’s great for avoiding “jaggies” on diagonal lines.

O Go ahead and experiment a bit with the Line
tool—trying various weights and turning anti-
aliasing on and off.

Shapes in PhotoPlus are pre-designed, filled contours that work just
like the Adjustable Selection tools—you can instantly add them to your
page, then adjust and vary them using control handles.

The Shape Tools flyout contains a wide variety of
commonly used shapes, including boxes, ovals,
arrows, polygons, and stars. Each shape has its own
built-in “intelligent” properties, which you can use
to customize the basic shape.

When you draw an adjustable shape, it displays as a
blue outline with one or more sliding handles which are used to control
shape properties. The number of handles varies according to the shape;
for example, the rectangle has just one control, the polygon has two,
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and the star has four.
T .
Hold down the Shi f t key while drawing a shape to constrain its

aspect ratio. To adjust a shape, simply drag one of its handles (the tool
changes to a “+” when it is above a handle).

When you’ve finished editing a shape, double-click inside the blue
outline to fix it and fill it with the foreground color as shown on the
Color tab.

O  You’ll have fun with these! Try building up a pile of shapes, each
using a different color with partial transparency so you can see
through to the shapes below. Or just play around with the
adjustable handles to create zany designs or meaningful symbols.
Often, forms like these can communicate quite a lot in a small
space—think about the possibilities for Web buttons or icons.

Try distorting or rotate shapes using the Deform tool. And possibilities
arise using shapes with the two fill tools described in the next section.
Because it’s easy to create multiple shapes with subtly different
proportions, shapes lend themselves to animation, too. (Chapter 6 has a
Hands-on example.)

Filling Regions

The Fill Tools flyout on the Tools toolbar includes two tools: Flood
Fill and Gradient Fill. As with the paint tools, if there is a selection,
the Fill tools only affect pixels within the selected region.

& The Flood Fill tool replaces an existing color region with the
foreground color. How large a region is “flooded” with the fill color
depends on the difference between the color of the pixel you initially
click and the color of surrounding pixels.

You can use the Tool Properties tab to set a tolerance value—how
much of a color difference the tool looks for. With a low tolerance
setting, the tool gives up easily and only fills pixels very close in color
to the one you click (a setting of 0 would fill only pixels of the same
color; 255 would fill all pixels). As the tolerance increases, so does the
tool’s effect on pixels further in color from the original pixel, so a
larger region is flooded.
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To apply a flood fill using the foreground color, select the tool from the
flyout, and set tolerance and layer fill options. Then just click with the
tool where you want to start the flood!

Q Try flood-filling some existing color regions in your image.

P The Gradient Fill tool creates a “spectrum” effect, filling the active
layer, selection, or mask with colors spreading between the current
foreground and background colors. You can also select starting and
ending opacity values for the fill. Four types of gradient fill (Linear,
Radial, Conical, and Square) are available. Gradient fills are
especially effective when used on a selection or mask (for example, to

produce an “aperture” effect).

Linear Radial Conical Square

To apply a gradient fill, select the tool from the flyout, then use the
Tool Properties tab to choose the gradient type and set an opacity
range. Click with the tool where you want to start the fill, and drag a
path to the point where you want it to end (see the example below).

Let’s try a mini-project simulating a sphere, using a radial fill inside a
circle. First make sure you have some white space (about a square inch
should do it) available on the Background layer. Perhaps its time to
erase a section, or enlarge the canvas area.

O Choose the Ellipse selection tool and Ct r | -drag over the white
region to create a circular selection about an inch in diameter.

O On the Color tab, choose a very dark foreground color and a very
light background color.

O Choose the Gradient Fill tool from the flyout, then select Radi al
as the Fill Type on the Tool Properties tab. You can leave the
opacity settings at 100%.

Q Click inside the selection, near but not at the top left edge, drag
diagonally down and to the right across the opposite edge. When
you release the mouse button, the selected region takes the fill.
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Our “sphere” may not have the convincing depth of a 3D model—but it
shows how gradient fills can interact with special selection shapes to

create unusual effects. Choose the gradient paths carefully so that high
and low values fall at specific points inside the selection.

Working with Text

Use the Text Tools flyout on the Tools toolbar to select from two text
tools—ane for entering solid, colorful text on a new layer, and the other
for creating a selection in the shape of text with which to manipulate
content on an existing layer.

A To create new solid text, choose the standard Text tool from the
flyout. Click with the tool where you want to insert text (it can be
moved later). The Add Text window opens.

| a7 it ] D EE AR A
| &

Type your text and use the formatting options at the top of the dialog.
Formatting is applied to all the text in the window, so you don’t need to
select the text first. To apply semi-transparent edges to the characters,
check the Ant i - Al i as box. (Anti-aliasing is generally recommended
with text sizes 14pt or larger.)

To set text color, click the Adj ust Col or button and use the dialog.
You won’t see the effect of the new color until you close the Add Text
window. (For details on using the Adjust Color dialog, see the
“Choosing colors” topic in online help.)

When you’re done, click OK. The text appears on a new transparent
layer in the image. You can now use the Move tool or other tools and
commands to manipulate it, just like the contents of any layer.
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The Layer Manager tab designates text layers with a T symbol. Solid
text in PhotoPlus is editable: as long as it remains on a separate text
layer, you can go back and change its properties at any time. To edit
existing text, either double-click the text layer’s name on the Layer
Manager tab, or select the layer and—using the standard Text tool—
move the cursor over the text until it changes to an I-beam, then click
on the text. The Add Text window appears, with the text ready for
editing.

In order to keep text editable, only one block of text can occupy a text
layer, and various functions—such as painting functions or the Past e
I nto Layer command—are disabled on text layers. To convert any
text layer to a standard layer, right-click on the layer name and choose
Render Text Layer from the menu.

Text selections work like standard or adjustable selections, except that
(you guessed it) they’re shaped like text! This opens up a number of
creative possibilities, such as using the text selections to “pick up”
patterns or filling the region with unusual fills.

A To create a text selection, choose the Text Selection tool from the
Text Tools flyout and click in the image to display the Add Text
window. Type your text and apply formatting just as when creating
solid text. Click OK when you’re done. Instead of solid text on a
separate layer, you’ll see a selection region on the active layer. Now
you can cut, copy, move, modify, and apply various effects to it, just as
with the other types of selection. (Note that text selections, unlike solid
text, cannot be edited with the Add Text window.)

HANDS ON: Creating Filled Text

This sequence shows you how to create text and fill it with a pattern.

O Open WATER.JPG (our fill image) in the PhotoPlus PROJECTS
folder.

Next, create a new empty image to use for the text.

O Choose New from the File menu to open the New Picture dialog.
Make the size 500x100, with a transparent background.

O Now choose the Text Selection tool and click it in the new image
window to open the Add Text window. Select Cairo SF and 72
points from the formatting options.

O Type the word “water” in the box and click OK to drop the text on
the blank image. Use the Move tool to reposition the selection if
necessary.
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Ej Untitled [1:1] _15]x]

O Now, use Ct r| +Tab to go back to WATER.JPG. Select an area
from that image and copy the selection to the Clipboard.

O Toggle back to the new image and paste the Clipboard contents
into the selection by choosing Past e>Paste i nto
Sel ect i on from the Edit menu.

E Untitled1 [1:1] =1 3
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Layers

If you’re accustomed to thinking of pictures as flat illustrations in
books, or photgraphic prints, the concept of image layers may take
some getting used to. In fact, layers are hardly unique to electronic
images. The emulsion of photographic film has separate layers, each
sensitive to a different color—and we’ve all noticed multiple-image
depth effects like shop window reflections or mirrored interiors. There
is still something magical about being able to build up an image in a
series of planes, like sheets of electronic glass, each of which can vary
in transparency and interact with the layers below to produce exciting
new images and colors.

Kinds of layers
In a typical PhotoPlus image—for

Layer Manager
example, a photograph you’ve scanned  Layer Hanagerl
in, a new picture file you’ve just . —

created, or a standard bitmap file
you’ve opened—there is one layer that
behaves like a conventional “flat”
image. This is called the Background
layer, and you can think of it as having
paint overlaid on an opaque, solid color *
surface.

5 ﬂﬂ Backgiound

You can create any number of new layers in your image. Each new one
appears on top of the rest, comprising a stack of layers that you can
view and manipulate with the Layer Manager tab. We call these
additional layers standard layers to differentiate them from the
Background layer. Standard layers behave like transparent sheets
through which the underlying layers are visible.

Then there are text layers, which are essentially standard layers but
much more limited—their main job is to hold blocks of text separately
from the other layers so that the text remains editable.

A key distinction is that pixels on the Background layer, once laid
down, are fully opaque, while those on standard layers can vary in
opacity (or transparency, which is really the same thing). That’s
because standard layers have a “master” Opacity setting that you can
change at any time, while the Background layer does not. A couple of
examples will show how this rule is applied in PhotoPlus:
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Suppose you are creating a new picture image. The New Image dialog
provides three choices for Background: Wi t e, Backgr ound

Col or, and Tr anspar ent . If you pick White or Background Color,
the Layer Manager shows a single layer named “Background.” If you
pick Transparent, however, the single layer is named “Layer 1”—in this
case, the image (typically an animation file) has no Background layer.

If you cut, delete, or move a selection on the
Background layer, the “hole” that’s left is
filled with the current background color (as
shown on the Color tab). The same operations
on a standard layer leave a transparent hole.

Many standard operations, such as painting, selecting and moving,
Clipboard actions, adjusting colors, applying effects, and so on, are
possible on both the Background layer and standard layers.

Others, such as rearranging the order of layers in the stack, varying
layer opacity (transparency), masking, or creating animation frames,
only work with standard layers.

Once an image has more than just a background layer, the layer
information can only be preserved by saving the image in the native
PhotoPlus (.SPP) format. Multiple layers are merged when you export
an image to a standard “flat” bitmap format like .JPG or .BMP. In
general, we recommend that you save your work-in-progress as .SPP
files, and only export to a different file format as the final step.

Basic layer operations

To select a layer, left- or right-click on its name in the Layer Manager
tab. The selected layer is now the active layer.

L1 To create a new standard layer above the active layer, click the
New Layer button on the Layer Manager tab, or right-click a layer
name and choose New... To clone the active layer and its contents as a
new standard layer, choose Dupl i cat e. .. from the Layers menu.

To convert the Background layer to a standard (transparent) layer,
right-click “Background” on the Layer manager tab and choose
Pronot e to Layer. The layer’s name changes from “Background”
to “Layer <number>.”

. To remove the active layer, click the Del et e button on the Layer
Manager tab. (You can delete the Background layer, as long as it’s not
the last layer.)
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= To make a layer’s contents visible or invisible, click the

H de/ Show Layer button next to its name on the Layer Manager
tab. The icon switches between an open and closed eye. Shortcut: Left-
or right-click a hidden layer’s name to make the layer visible again.

& To prevent further editing of transparent regions on a standard layer,
click the Pr ot ect Transpar ency button next to its name on the
Layer Manager tab.

For a visual preview of layers (including hidden Layer 3
layers) in the image, pause the mouse pointer over a

layer name and the Layer Preview window arE
appears. It’s especially handy if you’re working et

with many similar layers, image fragments, and/or
hidden layers.

Manipulating layers

Control over layers means control over a great variety of creative
possibilities. This section will review some of the manipulations you
should know about.

Note that commands on the Image menu, such as color adjustments and
special effects, typically are applied to the current selection (if one
exists). Otherwise they affect the active layer (the one currently selected
in the Layer Manager tab).

Moving the contents of one or more layers

ﬂ To move the contents of the entire active layer, make sure nothing
is selected, then drag with the Move tool. Note that layer content
moved in this way outside the image window (canvas area) survives—
you can drag it back inside the window later if desired.

Ig You can link one or more layers to the active layer so that when
you drag with the Move tool, the contents of all linked layers move
together. Click the Li nk Layer button next to the layer’s name on
the Layer Manager tab. The link button is always “down” (as shown)
for the active layer. You can see which others are linked to it by
checking to see which other link buttons are also down. Once layers are
linked, they remain so regardless of which layer in a linked group is
active.

To unlink a layer from the active layer, click its link button again (so
it’s now “up,” with an open-link icon).
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Clipboard operations involving layers

To copy (or cut) the contents of the entire active layer to the Clipboard,
select nothing and use the standard Ct r | +Cor Ct r | +X commands.
Cut or deleted pixels are replaced (on the Background layer) with the
current background color, or (on standard layers) with transparency.

You can paste the copied or cut layer into another PhotoPlus image
window, using the Past e>As New Layer command on the Edit
menu. Note that text layers become standard layers when pasted.

Rearranging standard layers in the stack

To move a standard layer up or down in the layer stack, click on the
layer name in the Layer Manager tab and drag up or down. A black line
“drop target” appears between layers as you drag. Drop the layer on a
target to relocate it in the stack.

Another method is to select the layer and choose

Ar r ange from the Layers menu, then choose Ed””g tEII':'F'

one of the following: ove Lp
Maove Down

«Bring to Top places the layer on the top & end to Bottom

of the stack.

« Move Up moves the layer up one in the stack.
« Move Down moves the layer down one in the stack.

+ Send t o Bott omplaces the layer just above the Background layer
(if present) in the stack

Merging layers

Merging layers combines multiple layers into one, decreasing the
memory required to store the image. Once layers have been merged,
they become a single layer and their previous contents are no longer
separately editable.

To merge the active layer with the layer below it, choose Mer ge
Down from the Layers menu. To merge just the currently visible layers
into a single layer, choose Mer ge Vi si bl e from the Layers menu.

To merge all image layers into a single layer, choose Mer ge Al |
from the Layers menu. This is called flattening the image because the
result is a “flat” file with just a Background layer.

To copy the selection (or image, if there’s no selection) to the
Clipboard in flattened form without physically merging its layers,
choose Copy Mer ged from the Edit menu.
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HANDS ON: Making a Montage

Now we’ll put several layers from several files together to create one
image (in this case an ad for a music event) using a base image, text,

and backgrounds. We’re going to use an image of a musical score as the

main background for our composite.
O Open the file SCORE.JPG in the PhotoPlus PROJECTS folder.

Lot mig®
; : i
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ZPT win” et wiis?
Save the image under the name MONTAGE.SPP. This will
become the primary working window (we’ll refer to it as the
“Montage window”).

Now open the file PIANO.JPG in the PROJECTS folder. Copy the
image to the Clipboard and then close the image window without
saving.

In the Montage window, choose Past e>As New Layer from
the Edit menu to paste the piano image as a new layer (Layer 1).

Choose Adj ust >Hue/ Sat ur ati on/ Li ght ness...from the
Image menu and boost the layer’s Lightness by 25.

Open the file STATUE.JPG in the PROJECTS folder.
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a

a

Choose | mage Si ze from the Image menu. In Pixel Size, change
Width from 416 pixels to 600. Move the Resampling Method slider
completely to the right, where it is labelled Quality: the description
will change to Bicubic Interpolation. Then click OK.

Carefully select around the statue, using the “Ellipse” Adjustable
Selection tool to make a circular selection including just the
statue’s head.

Copy the selected area to the Clipboard and close the image
window. Then in the Montage window, choose Past e>As New
Layer from the Edit menu to paste another new layer (Layer 2).

Select the Deform tool and drag to enlarge the head slightly,
keeping the Shi f t key down to maintain the aspect ratio.

Save the work-in-progress at this point (and every so often for the
rest of the project).

Now, we’ll add some text.

a

Make the foreground color red on the Color tab, and then select the
Text tool. Click the Text tool on the image, and in the Add Text
window type the words “Liberty Concert.” Use Basic Sans Heavy
SF, (or Arial, bold) 60 points, with centered alignment and a line
break after “Liberty.” Click OK to place the text as a new text layer.
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Select Rot at e from the Image Menu. Select Custom and enter an
angle of 11 degrees. Select Layer in the Apply To box and ensure
that Direction is set to Counter-Clockwise. (You can also rotate the
text by using the Deform tool.)

Select the piano layer (Layer 1) on the Layer Manager tab. Adjust
the Opacity for that layer to 85% .

Select Adj ust >Bri ght ness/ Cont rast from the Image
Menu. Reduce Brightness by 20%.

A, .
Open MOONL.JPG in the PROJECTS folder and use the “Crescent”

Adjustable Selection tool to select a portion of the moon about one
Inch high. (Select Rul er s from the View Menu if necessary.)

Copy the selected region to the Clipboard, then close the image
window. In the Montage window, choose Past e>As New
Layer from the Edit menu.
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O Make the foreground color in the Color tab white, and select the
Text tool. Add the text “Music By Moonlight” in Basic Sans, bold
(or Arial), size 14 points, on three lines, and drag it next to the
crescent moon using the Move tool.

O Select the Text tool again, and add the text “Independence Day” in
Handscript SF (or Times New Roman), 24 points. Drag the text to
the top of the image using the Move tool.

“' Music
By
Moonlight

U You can save the image as an .SPP if you want to preserve the
layers, or choose Mer ge Al | from the Layers menu to flatten the
file and conserve some disk space.
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Masks

Masking in a program like PhotoPlus is a wee bit more complicated
than applying masking tape to the screen! But fundamentally the
concept is the same: you can hide certain parts of an image—in this
case by rendering them transparent, hence invisible. To do that, you
create a mask on a standard layer.

By changing the grayscale values

on the mask (using the paint tools ‘

and other devices), you can effect »
corresponding changes in the ﬁ

opacity of the underlying layer’s

pixels. For example, by “blacking out” on the mask, you render the
layer’s underlying pixels transparent, and they disappear from the

image. Because you’re working with 256 levels of gray (i.e. opacity),
tremendous variations are achievable.

Besides the creative possibilities, ranging from vignetting to multi-layer
montage to gradient masking and beyond, a great feature of working on
a mask is that it is “temporary”—if you don’t like the way things are
going, you can abandon your changes and start over without ever
having affected the actual pixels on the layer!

Each standard layer can have one mask at any given time. (The
Background layer can’t have one because it doesn’t support
transparency.) Mask information, like layer information, can only be
preserved by saving the image in the native PhotoPlus (.SPP) format.

Mask-making
Here are the three basic steps in using a mask:

1 Create the mask on a layer.
2 Edit the mask itself to “preview” changes to the layer.

3 Merge the mask with the layer to make the changes permanent, or
delete the mask without applying changes.

Let’s take these in turn.
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1 Creating the Mask

Before you can use a mask, you have to create it on a particular layer.
The mask can start out as all transparent (revealing the whole layer) or
all opaque (hiding the whole layer)—or you can create a mask from a
selection, in which case part of the mask will be transparent and the rest
opaque. The choice depends on how you want to work with the layer’s
contents. By darkening portions of a clear mask, you can selectively
fade underlying layer pixels. By lightening an opaque mask, you
selectively reveal layer pixels.

To create a mask, first select the layer where you want to create the
mask, and select specific region(s) if desired. Choose Add Mask from
the Layers menu and then one of the following from the submenu:

« Reveal Al'| foratransparent mask over the whole layer

- Hi de Al | for an opaque mask over the whole layer

« Reveal Sel ecti on for an opaque mask with transparent “holes”
over the selected region(s)

- Hi de Sel ect i on for a transparent mask with opaque “blocks”
over the selected region(s)

On the Layer Manager tab, a little mask icon appears next to the layer
name, to indicate the layer now has a mask.

2 Editing on the Mask

In Edit Mask mode, you can use the full range of painting tools,
selection options, and effects to alter the mask’s grayscale values. These
manipulations cause corresponding changes in opacity, which in turn
changes the appearance of the pixels on the layer itself.

Remember, as long as you are editing the mask,

you’re only seeing a preview of changes on the Color B T | e
layer. No permanent changes will be applied until gom— TR
you actually merge the mask with the layer. You =l

can switch out of Edit Mask mode at any time to
work directly on the layer (or any other part of the

image), then switch back to resume work on the _

mask.

To edit the active layer’s mask, check Edi t Mask on the Layers
menu. (Uncheck to discontinue editing the mask.)

The image window’s titlebar shows “[MASK],” indicating that a mask
is currently being edited. The Color tab switches to Grayscale mode
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when you’re editing a mask, and reverts to the previous setting when
you exit Edit Mask mode. This means anything you paste from the
Clipboard onto the mask will automatically be converted to grayscale.

In Edit Mask mode, you’re normally viewing not the mask, but rather
the effects of changes “as if” you were making them on the layer below.
Adding a Reveal All mask can be a bit confusing, because there’s
initially no evidence the mask is there at all (i.e. the layer appears
exactly the same as it did before you added the mask)! It’s sometimes
helpful to switch on the Vi ew Mask setting (on the Layers menu),
which hides the layer and lets B et

you see only the mask, in all its
black, white, or grayscale glory.
For example, a Reveal All mask
appears pure white in View Mask
mode (as at right). This
represents a clear mask with no
effect on the underlying pixels’
opacity.

View Mask can also be useful in the latter stages of working on a mask,
to locate any small regions that may have escaped your attention.

You can disable the mask (check Di sabl e Mask on the Layers
menu) to see how the layer looks without the mask’s effects. Note that
disabling the mask is not the same as cancelling Edit Mask mode—it
only affects your view of the layer, not which plane (i.e. mask or layer)
you’re working on.

3 Applying changes to the layer
Once you’re satisfied with the appearance of the layer as seen with the

mask enabled, you can choose Mer ge Mask from the Layers menu to
make the changes permanent.

Of course, you may choose to delete the mask (choose Del et e Mask
from the Layers menu) without applying changes... perhaps to try again.
In either case, whether merged or deleted, the old mask is no longer
present and the layer is ready to accept a new mask.

Merging masks reduces clutter and file size, but note that the effects of
masking appear in exported images whether or not you’ve merged
masks.

HANDS ON: Vignetting
QO Open BRIDGE.JPG in the PhotoPlus PROJECTS folder.
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O Right-click the Background layer and choose Pronote to
Layer . Now that the layer (renamed “Layer 1”) is transparent, we
can make a mask on it.

O Select the “Ellipse” Adjustable Selection tool and drag out an
elliptical selection on the image. Move the selection marquee if
necessary so that the bridge is exactly centered within it, and
double-click to confirm your selection.

The region within the oval selection
is our area of interest. To create a
vignette effect—a gradual fade-in
from the edges—we’Il want to make
the pixels at the edge transparent,
grading in to opaque pixels in the part
of the picture we want to keep.
Feathering the selection will

produce this effect.

Feathering proceeds outwards from
the edges of a selection, so to feather
within the region we’ve defined,
we’ll first contract the selection and
then feather out from there.

U Choose Modi f y>Contract ... from the Select menu, and type
in 20 as the number of pixels. Click OK.

O Now choose Mbdi f y>Feat her. .. from the Select menu, and
again enter 20.

There’s no immediately visible effect on the image, but we have altered
the selection, as you’ll see...

O Choose Add Mask>Reveal Sel ection
from the Layers menu.

Right away the effect of the mask created from the
selection becomes clear—literally! The gray-and-
white checkerboard pattern shows the transparent
regions of this single-layer image. You can see
where the feathering has produced a gradation of
opacity.

O Merge the mask with the underlying layer by choosing Mer ge
Mask from the Layers menu.
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Now let’s put a mat around the image.

d

d

Choose New. . . from the Layers menu and click OK to create a
new layer.

On the Layer Manager tab, drag the new layer down below the first
one so that it’s on the bottom. (You still won’t see any change in
the image.) Make the new bottom layer the active layer, and press
Ct r | +Dto remove the selection (if there still is one).

Pick a neutral beige or pastel foreground color, and click with the
Flood Fill tool on the active bottom layer.

As a finishing touch, you can drag
the “bridge” layer slightly with
the Move tool to center it with
respect to the mat.

You can now save the image as an
.SPP, export it to another format,
print it, or perform more
manipulations
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One of the main uses for PhotoPlus is to produce graphics for use on
the World Wide Web. This chapter looks at the prevalent Web graphics
file formats, techniques for creating and editing .GIF animations, and
two specialized techniques (image slicing and image maps) used to
extend the performance of Web images.

“Performance” may seem like an odd aspect of graphic design, but it’s
actually one of the key factors in designing for the Web. Among other
things, it means load time: how long it takes for your whole page,
including text and graphics, to display completely in a Web browser. In
practice, it’s hard to measure. Things like connection bandwidth, server
speed, and modem rating all play a part.

Load time is a function of the total size of all the page objects that need
to load; and graphics usually take up the lion’s share. Is there anything
you can do to reduce the total size of your graphics, aside from using
fewer graphics? An obvious suggestion is not to make them any larger
than they need to be to get your point across. Since file size increases as
the square of each dimension, shrinking both height and width by half
reduces the file size by 75%.

The PhotoPlus Export Optimizer will greatly help you in reducing file
sizes as far as possible while maintaining image quality. For related
background material, be sure to consult the “Color concepts” and
“Optimizing images” sections of Chapter 7.

Formats for the Web

Here are some general notes on the principal file formats used for Web
pictures and animation—.GIF, .JPG, and .PNG—and details on the
options you’ll encounter in the PhotoPlus Export Optimizer.

Q The details will make a lot more sense if you have the Export
Optimizer open. Try using Double or Quad view (see Chapter 3)
for side-by-side quality comparisons at different settings.

.GIF format

The .GIF (Graphics Interchange Format) file format is universally
supported in Web browsers for both static and animated Web graphics.
It’s a lossless format (there’s no image degradation) with excellent
compression but a limitation of 256 colors. Use it for non-photographic
images with sharp edges and geometrics—for example buttons, bursts,
decorative elements, and text graphics. It’s suitable for grayscale photos
as well.
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The .GIF format supports binary transparency. That is, any portion of
the image may be either fully opaque or fully transparent. Typically,
this is used to eliminate the box-shaped frame around the graphic that
would otherwise be present. Elements with rounded edges, such as
characters or shapes, preserve their contours over any background color
or pattern.

If you’re producing transparent GIFs, try to avoid anti-aliasing and
feathering (i.e. turn them off in the Tool Properties tab). The semi-
transparency these functions impart may look fine in PhotoPlus, but
remember that .GIF wants “all or nothing.” Pixels that aren’t 100%
transparent will end up opaque, and the exported graphic will display
sharp or even ragged edges when viewed over a Web page background.

GIF is also a multi-part format, which means one file can store multiple
images. As such, it’s the preferred format for Web animations.

Recommended .GIF export settings

Format (Bits per pixel): 8- bi t (256 colors) is the only available
setting for animations, and the maximum supported by the format. For
pictures, 4- bi t (16-color) and 1- bi t (2-color) exports are also
possible.

Dithering (None, Ordered, Error diffusion): Dithering schemes
substitute pixel patterns for original colors to preserve apparent
coloration when the actual number of colors in the image is being
reduced. Choose Or der ed (not available for animations) for a more
regular dot pattern, and Er r or di f f usi on for a more adaptive dot
pattern.

Palette (Web-safe, Optimized): Choose Opt i m zed to let the
PhotoPlus export filter determine the best colors to apply, but without
regard for standard colors. Choose Web- saf e to reduce the colors to
only those found in the 216-color palette used by Web browsers. This
will ensure that an image you place on a Web page won’t change its
appearance when viewed by users of most other systems or browsers.

GIF Options (Transparent, Interlaced): .GIF files support
transparency—one reason they’re commonly used over backgrounds
on Web pages. PhotoPlus gives you the option of exporting GIFs with
or without a transparent background. Check Tr anspar ent to turn
clear “checkerboard” regions of your graphic (those with no pixels or
0% opacity) into transparent regions in the GIF. All other regions will
become opaque. If unchecked, transparent regions will become white.
Check I nt er | aced to use an image format that will display
“progressively” in a browser: first a low-quality image will display,
followed by an improved image as the complete GIF is loaded.
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JPG format

The .JPG or JPEG (Joint Photographic Experts Group) file format,
like .GIF, is universally supported in Web browsers. Unlike .GIF, it
encodes 24-bit images and is a lossy format (i.e. it discards some image
information) with variable compression settings. JPG is clearly the
format of choice for full-color photographic images. For “black and
white” (256-level, 8-bit grayscale) photos, it has no particular
advantages over .GIF.

The unique aspect of exporting as a JPG is in fact the slider control you
use to choose one setting from 10 possible levels. At one end of the
scale, the export applies maximum compression and produces an
extremely small (but quite ugly) image. At the other end, there is
effectively no loss of quality, but file sizes are relatively much larger,
although still compact compared to BMPs, for example.

When choosing a quality setting for .JPG export, keep in mind the
number of times you expect to be re-exporting a particular image. A
photograph may look fine in the Export Optimizer the first time you
export it at .JPG level 6, but after several such saves, you’ll really see a
cumulative quality loss .

.PNG format

For Web graphics, the newer .PNG (Portable Network Graphics,
pronounced “ping”) format has a number of advantages over .GIF—the
main ones, from an artist’s perspective, being “lossless” 24-bit images
and support for variable transparency. Whereas .GIF supports simple
binary (“on-off”) transparency, .PNG allows up to 254 levels of partial
transparency for normal images. The image file includes an “alpha
channel” that directs pixels in the foreground image to merge with those
in a background image. Most commonly used with 24-bit images, anti-
aliasing creates the illusion of smooth curves by varying pixel colors-—
for rounded images that look good against any background, not just
against a white background. It’s especially useful for the small graphics
commonly used on Web pages, such as bullets and fancy text.

.PNG’s most obvious drawback at the present time is that the major
Web browsers don’t yet provide full .PNG support—nbut this will
change, we hope, as more graphic artists become aware of the format’s
advantages.
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Producing Web Animations

Animation creates an illusion of motion or change by displaying a series
of still pictures, rapidly enough to fool the eye—or more accurately, the
brain. With PhotoPlus, it’s easy to create and edit images with multiple
frames, then export them as animated GIFs that a Web browser can play
back. You use exactly the same tools and interface as for creating
standard, multi-layer PhotoPlus images, with an extra tab window that
includes all the additional controls you need to set up frames, add
special effects, and preview the animation. Once you’re satisfied, use
the Export Optimizer to output to the .GIF file format.

The .GIF format is what makes Web animation possible, for a couple
of reasons. First, it’s universally supported by Web browsers. Second,
it’s a multi-part format, capable of encoding not just one image but
multiple images in the same file. A GIF animation player or Web
browser can display these images in sequence, in accordance with
certain settings (looping, frame delay, etc.) included in the file. The
result—it moves!

PhotoPlus gives you the choice of either creating your animations from
scratch, then exporting to .GIF, or starting out by importing a .GIF
animation and then editing it. Either way, once PhotoPlus detects an
animation file, it switches on the Animation tab. If the image file is
new, you’ll see a single, blank frame, labeled “Frame 1.” If you’ve
imported an animation, the tab displays each frame separately.
Animation files can have one layer, or many (see below), but all their
layers are standard (transparent) layers; there’s no Background layer. (If
you need to brush up on the concept of layers, see Chapter 5.)

Layers and frames

Animations are defined by the Animation tab working together with
the Layer Manager tab. Let’s look at a little animated GIF of a
rotating spiral.

O  Open the file SWIRL1.GIF in the PhotoPlus PROJECTS folder.
When the image opens, the Animation tab appears.

A nkmadicen|
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Notice the playback control buttons on the right, below the frames.

Q Click the L2 Pl ay button to preview the animation, and click

st op to freeze it. Try the other playback buttons, while you're
at it!

To display the Visual Reference topic describing the various features of
the Animation tab, click the [ button and then click anywhere on the
tab.

Let’s examine the Swirl animation more closely. In this file (as in any
imported GIF animation) the individual frames each have been assigned
one layer in the PhotoPlus image.

On the Layer Manager tab, the layer stack for this animation
corresponds nicely with the frame sequence, with default names—in
this case, “Frame 1 of 6” through “Frame 6 of 6.”

 Select Frame 1 on the Animation tab.

Notice that on the Layer Manager only the
“Frame 1” layer is marked as shown, with an
open-eye button; the other layers are all hidden,
with closed-eye buttons.

O  Now select Frame 2 on the Animation tab.

EIECAE]

This time, only the “Frame 2” layer will be =
shown, and the rest will be hidden. And so on

with the other frames. Ig

The above example, with its one-to-one correspondence between
frames and layers, is easy to grasp but deceptively simple. Don’t make
the mistake of thinking that a “frame” is just another name for a “layer.”
Frames in PhotoPlus are actually much more versatile!

Key point: A so-called “frame” is really just a particular state or
snapshot of the various layers in the image, in terms of three layer
properties:

1 Shown/Hidden: Which layers are shown and which are hidden

2 Position: The position of the contents of each “shown” layer

3 Opacity: The opacity setting of each “shown” layer
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As you switch between frames, you are switching between states of the
image. In the simple example above, the six frames define six states in
terms of Property 1—each of the six frames defines a different layer as
“shown.” We could rearrange the stacking order of the layers, or
rename them—and the animation itself wouldn’t change.

Thus, when you create a new frame on the Animation tab, you’re not
adding a new layer. The new frame merely enables you to define a new
state of the layers that already exist. Of course, you could go on and
create an additional layer, but then all your frames would need to take
that layer into account—in other words, hide it when it wasn’t needed.

HANDS ON: Follow the Bouncing Ball

To demonstrate single-layer animation, let’s create an example with a
bouncing ball—created with four frames but on just one layer. In this
animation, the four frames will define four states in terms of Property
2—the position of the layer contents.

O Close the Swirl animation window (we’re done with it). To begin
creating a new animation, choose New... from the File menu. If the
Startup Wizard is enabled, click on Cr eat e an Ani nati onto
open the New Image dialog. You’ll notice that the Ani nat i on
option box is checked.

O Specify dimensions (100x100 is fine), set the Background to
“Transparent,” and click OK.

New Image [x]
~ Dimension:
‘width 100.00 3: m
mels hd Cancel
Height 100.00 3:
Resolution |96.00 3: Fixels/Inch vl
~Background
[white |
¥ Erimatiori Help

A new, untitled image window will open, and the Animation tab will
now something look like this:

Animation

Animation|

Frame Delap I 50
Total Time  Orn: 0.60s

Loop =« |1— ’T\/ W

| L]
o Do [
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Q ™ For this project, make sure the Endl ess Loop button is
down.

& The Show! Hi de Capt i ons button should be up (captions
hidden) so that each frame’s image content is easier to see.

O Working in the image window, choose the
“Ellipse” Shape tool and Ct r | -drag to draw a
small, dark circle at the left side of the square
canvas. (The color doesn’t matter, as long as it .
shows up.)

O Now click the 2 New Fr ame button on the
Animation tab three times to add three clones of Frame 1.

Animation

Animalion]

Frame Delay I 50

Total Time  Om: 0.200s
— = ® ® ®
Loop =l |1—|T\/

I i
o % H ORI (RPN

O On the Animation tab, click on the second dot (Frame 2) to select
it. In the image window, choose the Move tool and (with nothing
selected) drag the whole layer so the ball is now at the top of the
canvas. When you release the mouse, you’ll see Frame 2 on the
Animation tab update to show the new “state” of the image.

Q Click Frame 3 and drag the layer so the ball is at the right of the
window, and finally in Frame 4 put the ball at the bottom of the
window. The Animation tab will show the four frames like this:

Animation )|
Animatiun]
Frame Delay I 50 .
Tatal Time  Om: 0,200z . .
Loop = | 1 ’T\/ .
N i
X E Sl Do DG

Q Click the L2 Pl ay button. Not bad for a few minutes” work!
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a

Q

If the animation runs too fast, you can increase the frame delay.
Each frame has its own delay factor, but here’s how to set one
factor for all frames. Just click all four frames while holding down
the Shi ft key (that selects them all), then enter the new number
in the Frame Delay box. Try playing the animation again.

Click the Fi xed Loop button and try entering a specific number
of repeats in the box. (The most common setting here would be
“1,” for example with a longer sequence that only needed to play
once.)

We suggest that besides saving your creation as an .SPP file, you
also export it as a .GIF. You’ll notice that the Export Optimizer has
a special tab for previewing and setting final animation options
before exporting to the .GIF format. On the Optimizer’s main
Options tab, you can check or uncheck the Transparent box. Since
this little example has only an opaque dot on a clear background, it
should export well as a transparent animation.

You can also choose Previ ew i n Browser from the File
menu to preview your animation in your Web browser.

We’ll leave it to you to create another example, varying only opacity on
a single layer, perhaps some text (like “CLICK HERE”) blinking on
and off. Two frames could accomplish that—in one, the layer set to 0%
opacity, and in the other, to 100%.

Notes on animation

¢

In practice, you can use one, two, or even all three of the layer
properties when creating a given piece of animation. Just remember
that a separate layer is only required for each element that moves
independently, or each differently-drawn state of a given element.
An element that doesn’t change its shape or color, but merely
moves about or changes opacity (appears or disappears), can be
animated on a single layer.

With a little forethought and sketching, you can figure out in
advance how many layers you’ll need. Then you can set up the
image with the right number of layers to begin with.

To preserve layer properties, be sure to save the image in the native
PhotoPlus (.SPP) format. You can reopen an image you’ve
exported as a GIF, but it will have lost PhotoPlus layer properties
like opacity and position.
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¢ Although .SPP animations and .SPP pictures share the same file
extension, there’s no direct conversion option—a file either has
animation properties, or it doesn’t. To convert an .SPP picture file
to an animation, or extract a single frame from an animation to a
picture, first create a new image window and then use conventional
copy/paste commands to copy elements and/or layers from one file
to the other.

¢ Use animations sparingly on Web pages. Like all attention
grabbers, they can lose their impact if overused. Also, animated
.GIFs (because of the additional image information) are
substantially larger than a static graphics, a consideration if you
expect people to view your pages over a slow Internet connection.

Image Slicing

Image slicing and image maps are two convenient ways to create
navigation bars and clickable graphics for Web pages. With image
slicing, a graphic is carved up into smaller graphics—each of which can
have its own link, like any Web graphic—and PhotoPlus saves the
sections as separate files when you export the image. The process also
exports HTML tags describing a table containing the separate graphics,
allowing a Web browser to reassemble them seamlessly. The result
appears as a single larger graphic, but with different regions linked to
different targets.

For example, this menubar graphic...
iome Updates Products Links

...can be sliced into four separate graphics, each linked to a different
Web page.

The Image Slice tool lets you divide the image into sections, which can
be exported using the .GIF or .JPG format. You can specify alternate
text and URL links for each of the image sections individually.

Slicing an image

ﬂ The Image Slice tool looks like a small, black-handled knife.
When it is selected, the cursor also changes to a small knife.
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To slice an image horizontally (left to right) select the image slice tool
and left-click on the image. Shi f t -click to slice an image vertically
(top to bottom). Repeat as many times as necessary. Each click inserts a
red slice guide. You can move a guide up or down by dragging it, or
delete a guide by dragging it out of the image window.

To specify the alternate text and/or URL link for an image slice, right-
click it and enter the information into the dialog, then click OK.

When exporting a sliced image, check the Creat e |1 mage Slices
box on the Export dialog. Specify a name and folder for the files as
usual, and choose either .GIF or .JPG as the export file type. We
recommend using .GIF for non-photographic images and .JPG for
photo-quality images.

This will create multiple files in the specified folder, depending on how
many slices you have defined. There will be a series of image files (for
example, MYFILEHOVO0.GIF, MYFILEHOV1.GIF, etc.) and a single
HTML file (for example, MYFILE.HTM). The HTML file contains the
tags for the set of image slices, ready to be pasted into the source code
for the Web page.

Image Maps

Whereas image slicing subdivides an entire graphic into smaller
graphics and exports them separately, image maps consist of hotspots
that you draw with special tools over selected parts of an image. When
a visitor passes their mouse cursor over the hotspot, a small caption is
displayed and the pointer will change to a pointing hand. Clicking the
mouse while the cursor is over the hotspot will invoke a hyperlink to a
specified URL.

Home| Updates| Products | Links|

You assign each hotspot its own target—for example, the URL of a
Web page. Hotspots aren't attached to a particular image, but become
part of a larger “map” that gets exported along with an image and turns
into HTML code. It's then up to you or your Web developer to embed
the image map code properly into the Web page.

Creating image maps by hand can be difficult and time-consuming, but
PhotoPlus makes it easy. The Image Map Tools flyout on the Tools
toolbar displays a flyout menu of tools for creating and editing image
maps.

There are four image map tools
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¢ The & Selection tool, used to modify the area drawn with one of
the other tools and to actually set the image map properties;

¢ Thed Rectangle tool, used to draw a rectangular hotspot;
¢ The & Circle tool, used to draw a circular hotspot;

¢ The'ld Polygon tool, used to draw a polygonal hotspot.

Creating hotspots

Click the Image Map Tools flyout and choose the Rectangle, Ellipse,
or Polygon tool. Use the tool to draw a hotspot on the active layer. To
draw a polygon, drag and release the mouse button to define each line
segment; double-click to close the polygon. Hotspot outlines appear in
red.

To edit a hotspot, Click the Image Map Tools flyout and choose the
Selection tool. To resize the hotspot, drag from an edge. To move the
hotspot, drag from the center.

Right-click the hotspot with the Selection tool to delete it, set layer
options, or access hotspot properties.

In the Image Map dialog, enter the text which will pop up when the

cursor moves over the hotspot, and the full  ErrTm ]
URL for the hotspot to link to. Previously- et Fescontiebc

used URLSs are saved and can be selected R =i vz oo H
from the drop-down list by clicking on the =] Cencel_|

arrow at the end of the box.

Normally you will export the image for which you have created the
image map as a .GIF (for non-photographic images) or a .JPG (for
photographic images). We recommend that you use the Export
Optimizer (choose Export Opti m zer ... from the File menu) to
compare the quality and file size which results from various settings.

Make sure that the Creat e HTML for | mage Maps boxis
checked in the Export dialog, then click Save. This will create
identically named .HTM and image files. The HTML file contains the
tags for the image map, ready to be pasted into the source code for the
Web page.
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If you’re looking for a powerful yet easy-to-use tool for Web page
design, look no further than Serif PagePlus, which lets you create your
own Web site from scratch or with Web Page Wizards (using its Design
CD-ROM). PagePlus now supports HTML 4.0 for better WYSIWYG
Web page design—and you can incorporate the animations, sliced
images, and image maps you’ve created with PhotoPlus.
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This chapter ties together a variety of loose ends... mindful of the fact
that every PhotoPlus user will arrive with different needs and prior
experience. The other Companion chapters focus on step-by-step
procedures to build familiarity with tools and functions. Much of the
important theory that underlies the program’s workings has had to take
a back seat.

As you read through the topics here—all dealing in one way or another
with different ways of representing pictures as on-screen bits and
bytes—you’ll realize how indispensable these underlying concepts are.
Although this is the final chapter, it can make a good starting point, too.

Color Concepts

It’s always difficult to draw a line between concepts you should
understand before you get started, and those that can wait until you
absolutely need them. Here we’ve collected a few key terms and
concepts relating to color, and presented them roughly in order of
priority, trying to keep it simple without oversimplifying. So we suggest
you just begin at the beginning, and treat this as a reference section you
can revisit at any time.

Bitmaps

First of all, PhotoPlus is all of the following things and more: a “photo
editor,” a “paint program,” a “bitmap editor.” It lets you create
manipulate images called “bitmaps,” “paint-type” images,” or “raster
graphics.” Don’t be overwhelmed by the jargon—all these terms
communicate a single concept! Bitmaps (let’s settle on that term) are
digital pictures (which may or may not be photographs) represented by
lots of colored dots (“pixels”) on a computer screen (“raster”). You
create these images by “painting” or filling in regions on the screen,
regions that can be as small as a single pixel or as large as the whole
screen (or larger).

Bit depth

A bitmap is basically a bunch (literally a “map”) of numbers that tell
each dot (pixel) on a computer monitor what color it should be. And
since computer numbers consist of binary digits (1’s and 0’s, or “bits™),
each pixel in effect has one or more bits backing it up, telling it what to
do. From this fact arises the concept of bit depth (also known as “pixel
depth™), one of the essential attributes of any bitmap image. Bitmaps
not only have height and width, they have depth. The more bits
assigned to each pixel, the more possible color states the pixel can be
told to take—the greater its “color depth.”
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For example: If you’re only using 1 bit per pixel, the pixel can only be
ON or OFF, in other words “1” or “0,” the two states of the bit—hence
white or black (monochrome). By comparison, a bit depth of 4 bits per
pixel can store 16 values; 8 bits per pixel, 256, and so on. 16-bit images
have roughly “thousands” of values to describe each pixel’s color, and
24-bit images have “millions.” Not
surprisingly, the file size of an image is
basically the product of its linear
dimensions (number of pixels) times its bit
depth, so a picture saved as a 24-bit image
would take up three times as much disk
space as an 8-bit version.

Of course, the appearance of a bitmap on a screen depends not only on
the bit depth of the picture but on that of the computer screen displaying
it. Just a few years ago (in the “old days”), many monitors were limited
to 16 colors, and 256 was a big deal. There were “VGA” and “SVGA,”
and today the choices include “High Color” (16 bit) and “True Color.”

Just because you may have a higher-end system, don’t forget that many
others do not. A 24-bit image with millions of colors may look abysmal
on a 256-color monitor—a key consideration when it comes to creating
graphics for the Web, as opposed to CMYK separations for a print
publication. In print publishing, designers must worry about whether the
colors specified in their electronic images will produce “true” output
when reproduced in ink, under standard lighting conditions. In Web or
CD-ROM publishing, the main worry is how to optimize or reduce the
file size as far as possible, while maintaining some semblance of quality
in the image (more about optimizing below). Fortunately, PhotoPlus
includes tools to support all these needs.

Bit depth in PhotoPlus

One of the main differences between PhotoPlus and most other paint
programs is that we’ve put aside the restrictive notion of working with a
limited number of colors. You can work on any image in 24-bit mode,
accessing the full color spectrum via the Color tab. Native format
(.SPP) images are stored in this mode. When and if the time comes to
save in a different format, and reduce colors, PhotoPlus provides the
Export Optimizer for maximum quality control.

While novices will appreciate the ease of use this approach brings,
more experienced users may at first need to adjust to the absence of
color swatches and the constraints of working in 256-color mode. Still,
we’re confident that the benefits of concentrating on image production
first, and color reduction last, will soon become apparent!
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Tip: You can use the Open dialog to browse images on your system.
The dialog displays the bit depth and dimensions (as well as an optional
preview thumbnail) of any selected image in a supported format.

Resolution

Bitmaps are created at a fixed resolution, measured in dpi (dots per
inch) and hence lose quality if resized upwards. Resizing downwards is
a different matter, which is why it’s always a good idea to scan pictures
at higher dpi settings and scale down later (see the “Scanning Tips”
section later in this chapter). The reproduction quality of bitmaps can
vary dramatically, and depends on factors such as the dpi stored in the
original file, the dpi used for reproduction (printing), the bit depth, and
the scaling factor used in reproduction.

High resolution bitmaps compensate for quality problems, but tend to
be very large files.

Color modes

The PhotoPlus Color tab includes a control that lets you select one of
four color modes: RGB, HSL, CMYK, or

Grayscale. You should know something about RGE
these modes, even if you only have occasion to CHYE,
work in one or two of them. Much of the HsL

terminology overlaps. Let’s consider these,
starting with the simplest.

Grayscale

A grayscale image looks like what we would call a “black and white”
photograph, which properly speaking has many levels of black and
white (not just two, as in a monochrome line drawing). On computers,
Grayscale mode stores 256 shades of gray or levels of lightness. A
value of 0 represents pure black, a value of 255 pure white. Sometimes
we speak of the “tones” in a grayscale image—it’s just another word for
the different “values” or “lightness levels.”

To understand HSL, imagine the difference between watching a TV
program on a black and white set as opposed to a color set. It’s the
same color signal, right? But the black and white set doesn’t reproduce
the color. What it does pick up is the grayscale or lightness channel of
the signal. In the same way, any color image in PhotoPlus has a channel
that stores lightness information. The “L” in HSL stands for Lightness.
To repeat—and this is important when it comes to understanding topics
like masking—Ilightness and grayscale values (and for that matter tones,
luminance, and brightness) all refer to the same thing.
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The additional Hue and Saturation channels in HSL mode together
store the color information that’s missing from a simple grayscale
image. Like Lightness/Grayscale values, Hue and Saturation channel
values are expressed in numbers, ranging from 0 to 255. (If you’re alert,
you’ll note that 256 is equivalent to 8 bits of information, so H+S+L
has three 8-bit channels totalling 24 bits—which is where the “24” in
“24-bit” comes from.

Hue refers to the color’s tint—what most of us think of as rainbow or
spectrum colors with name associations, like

“blue” or “magenta.” A color wheel (like the one

in the PhotoPlus Adjust Color dialog) is useful for

representing the spectrum of hues as a continuous

cycle, like a clock. The hue “red” is arbitrarily

assigned the value 0 at a certain position, and the

values run around the circle. Saturation describes

the color’s purity—a totally unsaturated image has only grays.

RGB mode is much less intuitive than HSL as a method of mixing
colors, but it’s the standard way of describing colors the way they’re
displayed on computer monitors—as mixtures of separate Red, Green,
and Blue components. Anyone who’s seen (in a museum, perhaps) a
demonstration of three projector beams in a dark room, one of each
color, merging to produce a pool of white light, has seen a primitive
version of the RGB system. Turn all the elements off and you get black.
On computers, as with the HSL system, 8 bits are used to encode each
of the three channels, for a total of 24 bits, and with 256 possible levels
(0-255) for each channel. An RGB value of “0,0,0” represents pure
black, while a value of “255,255,255” represents pure white.

To quickly get a feel for the HSL and RGB color mode variables,
double-click either the foreground or background color swatch on the
Color tab and try mixing your own colors using the Adjust Color
dialog. (See online help for details.)

Finally, CMYK is a color model used for preparing printed work,
where ink on paper is the medium that determines color reproduction.
It’s based on the “subtractive” principle by which our perception of a
pigment’s color depends on the light wavelengths it absorbs and
reflects. Traditional process color printing creates colors by mixing inks
and absorbing light, so that your eyes can mix the reflected light.
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The four process inks are Cyan, Magenta, Yellow, and Black (Black is
referred to as Key). Mix the four process inks, and you get black. No
ink gives you white (or the color of the paper). In PhotoPlus, the C, M,
Y, and K channel values are given as percentages, from 0 to 100%.
PhotoPlus supports CMYK output of process color separations (see the
section later in this chapter).

Color mode tips

¢ The color mode setting (on the Color tab) determines how image
data gets pasted from the Windows Clipboard—in other words, as
grayscale values in Grayscale mode, or as full 24-bit color in any of
the other modes.

¢ If you start editing a layer mask (which represents opacity values
by shades of gray), the Color tab switches temporarily to Grayscale
mode. Applying the | nage/ Adj ust/ Gr ayscal e filter,
however, doesn’t affect the color mode.

¢ You can use the Color Pickup tool as a probe to read component
values in an image. Move the tool around the image and watch the
HintLine. Depending on the color mode, you’ll see a readout of
values (R, G, B, H, S, L, O, etc.) under the current cursor position.
By the way, the “O” represents Opacity.

Optimizing images

In a perfect world, there would be just one digital picture format that
everybody used. Infinite storage capacity and bandwidth would allow
full-color images to be stored and transmitted instantly, uncompressed...
but let’s leave that for a sci-fi novel! The reality is that at least hundreds
of picture formats have been created, with more ever on the way. A
dozen or so are currently in widespread use among computer
professionals. The tradeoff between image quality and file size will
remain a fact of life. Hence the need to optimize images—that is,
achieve the best quality in the least file size, and within whatever other
contstraints (such as number of colors) the job may impose.
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PhotoPlus features a powerful Export Optimizer (introduced in
Chapter 2) that serves as your “command center” for exporting images
to various formats. It not only provides a variety of options for each
supported format, but lets you compare image quality using different
settings and even retains your preferred settings for each format. You
can access the Export Optimizer at any time—not just at export time—
to take advantage of its compararison capabilities. While the visual
comparisons speak for themselves, some of the available settings may
need some explanation.

Palettes

The PhotoPlus Export Optimizer offers two standard Palette options
when you export using 8 bits or less. A color palette (no relation to a
“floating” palette) is a table of color values that gets stored with any
image having 256 colors or less. This could mean a .BMP, .GIF, .PCX,
or WMF image—plus quite a few more. Computer users with high-
color monitors may not give it much thought, but in the realm of 256-
color displays, palettes can make a great deal of difference. Windows
itself reserves “slots” for its own “system” colors, and each application
must “declare” a palette while the graphics system tries to ensure
peaceful coexistence. When several colorful applications are in use, and
you switch from one you another, you sometimes see the ghastly result
of palettes clashing as neither application wants to relinquish its hold on
a scarce system resource.

To avoid that kind of calamity when displaying Web pages, both
Netscape and Microsoft browsers use the same Web-safe palette of 216
colors to display images. Since you’ve gotten this far, you may be
interested to know that the Web-safe palette is based on RGB values
that are either 0, or divisible by 51. Permissible values are in the series
0, 51, 102, 153, 204, 255. So, for example, the RGB definition
“0,102,51” would be a safe Web color, while “0,102,52” would not.

If you’re exporting at 256 colors or less, and Web display is not an
issue, there’s no question you should choose the Optimized setting—as
a quick side-by-side comparison in the preview window will always
confirm. The program will always do a better job when it’s allowed to
select a range of color values that best match those in the 24-bit version,
rather than having to apply the same 216 colors every time.



Color and Input / Output Options 103

Note: When you open an image that already has an associated palette,
PhotoPlus doesn’t attempt to hold on to the palette—it always re-
optimizes, even if you use the Save Ori gi nal command. Usually
this yields the best possible results; but if keeping exactly the same
image palette is essential to your particular application, our advice
would be to export from PhotoPlus in 24-bit mode and use a third-party
program to apply the palette.

Dithering

Dithering (not to be confused with “showing flustered excitement or
fear”) comes into play with images being reduced to 256 colors or less.
It’s a method of approximating colors outside the actual image
palette—for example, by alternating pixels of red and blue from within
the palette to produce the visual impression of a purple color that’s not
in the palette. Applications (including Web browsers) use dithering in
256-color mode if the images being displayed include colors outside the
application palette. This can degrade solid-color areas and is one of the
main reasons to export Web-bound images using the Web-safe palette.

When you’re exporting to 256 colors or less, PhotoPlus lets you choose
whether or not to use dithering. If you have an image with few colors,
and preserving areas of solid color is essential, you should opt for no
dithering—and the export filter will pick “nearest-match” color values
from the palette being applied. You may see some color shifting, but the
solid color areas will be preserved. For photographic images, on the
other hand, dithering is clearly the best choice. With the “optimized
palette” option, you can choose either ordered or error diffusion
dithering. The former produces a discernably patterned effect, while the
latter tends to average away the patterns for a more natural result.

Compression

Compression schemes, which apply different algorithms to encode the
image information with fewer total bits and bytes, are used in many
formats. With some, like .BMP and .TIF, the Export Optimizer gives
you a choice of compression scheme. In general, use the default setting
unless you know for a fact that some other scheme is called for.
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The .JPG format, widely used for photographs (and detailed in Chapter
6), is unusual in that you can set the level of quality desired using a
slider. As you might expect, the highest-quality setting uses least
compression, with no loss of image quality but the largest file size. The
lowest-quality setting applies maximum compression for smallest size,
but yields rather poor quality. With the aid of the Export Optimizer, you
can judge for yourself—but another factor to keep in mind is the
number of times you expect to be re-exporting a particular image. A
photograph may look fine the first time you export it at JPG level 6, but
after several such saves, you’ll really see the quality loss. As a rule,
keep images in the native .SPP format, or export them using only
lossless compression schemes, until it’s time for the final export.

File Formats

PhotoPlus can import and export most types of graphics file which
you’re likely to encounter. In order to use PhotoPlus images in other
programs, you will have to export them into one of the widely used
formats.

For pictures and animations intended for use on the World Wide Web,
the two prevalent formats are .GIF (for both) and .JPG (just for photos).
A newer format, .PNG, has some advantages but isn’t yet as widely
supported. See Chapter 6 for details on the features and options of each
format.

For print use, we recommend that you use .TIF or .BMP as most other
programs allow you to import files in that format.

If you’re exporting an image so that it can be used in four-color process
printing, then it is essential that you enable the CMYK option in the
Export Optimizer. The other export formats use the RGB color model
(see the section on “Color modes” earlier in this chapter), which is not
suitable for use in process printing.

Tips for Scanning

Scanning hardware and software varies considerably. One myth is that
the higher the resolution of your scanner, the better results you’ll
achieve. While that’s true in theory, the real limit to quality is how the
image will ultimately be reproduced. Will it end up on the printed page
or on-screen? Either way, the real issue is how many “extra pixels”
you’ll need in the original scan.
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If the image will be professionally printed, will that be onto a sheet of
newsprint or a glossy coated stock? Paper itself puts a ceiling on
reproduction quality. Lower-grade paper tends to spread ink around
more easily, so the dots of ink used to print a picture need to be larger.
This means a wider halftone screen with fewer lines per inch (Ipi).

If you’ll generate your output on a desktop printer, the device will be
putting bits of toner or droplets of ink on the paper. On a laser printer,
shades of gray result from variations in toner coverage. Desktop color
printers create color by laying down dots of cyan, magenta, yellow, and
black ink. Again, printer resolution and paper type are quite variable.
Dpi (dots per inch) is the most common measure of print quality.

¢ Asageneral rule, the optimal scanning resolution for print work (in
dpi) is about twice the output setting on the printer or other device
that will be used.

Or will your image end up on-screen instead of in print? If so, it will no
doubt be viewed at standard screen resolution of 96 dpi. (That’s why
this is the default resolution in PhotoPlus.) If you’re producing Web
images, it makes more sense to regard resolution as a fixed factor, and
think in terms of image dimensions instead.

This means that, for an image that will end up on a Web page, it’s just
possible you can get great results scanning at 100dpi, at exactly the
screen dimensions you need. But that’s cutting it close, especially if
you’ll be editing the image at all.

For either print or screen images, you must always take into account
what kinds of manipulations you plan to carry out on the image in your
photo editor, i.e. PhotoPlus. Color adjustments, resizing (with
resampling), blurring, and other effects tend to disturb the arrangement
of pixels in the original scanned image. So let’s add another guideline:

¢ If preserving detail is a consideration—as it almost always is—and
you plan to manipulate the image, then give yourself enough pixels
to work with! Scan at a higher resolution (or higher size) and scale
the image down later.

Of course, file size and the capacity of your system are also factors in
choosing scanner settings. It makes little sense to work slowly on a
20MB file, if you’d get the same final quality working quickly with a
5MB file.
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Depending on your scanner software, your may be able to perform
initial adjustments right at the source. For example, you can use the
controls to get a true black on one end and true white on the other.
Often you can de-screen images to eliminate possible moiré patterns
(interference between the regular dot patterns in printed images and the
scanner’s path).

¢ If your scanner software doesn’t provide de-screening, try using the
PhotoPlus Gaussian Blur filter to remove moiré. Make sure you’ve
scanned at higher resolution (or size) so that you can then scale
down the image to regain detail.

Some other tips:

¢ If you’re scanning a number of pictures, you may find it’s faster to
save scanned images to disk rather than bringing them directly into
PhotoPlus.

+ InPhotoPlus, you can rotate an image if necessary to correct for
any mis-alignment in the scan, then crop to remove any unwanted
border pixels. Use the Br i ght ness/ Cont r ast ,

Hue/ Sat ur ati on /Li ght ness, Gamma, Equal i zat i on,
and/or St r et ch adjustments to improve image quality.

Advanced Printing

Click the Opt i ons.. button from the Print dialog to access additional
printer settings.

Scaling and tiling
The Layout tab is where you can specify Scaling and Tiling options.

Layout |Dutput| Separatlonsl

—Scaling — Prewvi

% Scale: |100% _l::

" Reduce ta fit

~Tling———— I:I

I~ Tie

Overlap: |Opix _Ij

Cancel |
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Scaling is usually set to 100%, but you might reduce it to proof a large
image on one page or increase it to blow up a small image to fit a whole
page. Choose the Reduce to fit optionto make sure that your
image will fit on the page.

Tiling allows you to print a large image on several sheets to be stuck
together later.

The Preview area shows where on the page the image will be printed. It
changes according to whether the printer driver is set to portrait (wide)
or landscape (tall) orientation.

After specifying options, click one of the other tabs to set more options,
or click OK to return to the main Print dialog and save any changes.
Click Cancel to abandon changes.

Including printer marks

On the Output tab, you can specify whether the program is to print
various marks as well as the image.

Lapout  Output | Separationsl

— Printer ark:

¥ e File Information

¥ == Cropmarks

v @ Registration targets
& gist! ztars

v B Grayscale bar
o Color bar

Cancel |

Marks and file information can only be printed if the physical paper
size is one inch or more larger all round than the image.

After specifying options, click one of the other tabs to set more options,
or click OK to return to the main Print dialog and save any changes.
Click Cancel to abandon changes.

CMYK color separations

An offset press needs one independent plate for each color that will
print on the job. PhotoPlus will let you choose to print either a
composite copy or color separations which are used when printing the
job to an imagesetter.
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If the job is created properly, you then get, for each page, one complete
negative for each color. If you were working on a flyer, you could print
out a composite copy on your laser or ink jet printer which would give

you one piece of paper with the whole flyer, or seps, which would give
you four sheets of paper.

The Separations tab controls the printing of color separations.

Options [x]
Layout | Output  Separations |
¥ Print Separations
Frint  Ink Calar Angle Frequency
v [Cyan 105.0000  100.0000
v [Ovelow 75.0000 100.0000
v [0t agenta 30.0000 100.0000
v| [EBlack 45.0000 100.0000
Eroperiies |
Scresns: I Regular Paper [100 Ipi] ;I
|

If you are using a PostScript® output device, checking the Pri nt
Separ at i ons box on the Separations tab allows you to choose
whether to print separations for process printing and if selected, which
separations to print. This box will be grayed out if you are not using a
PostScript® printer driver.

Normally, separations are not enabled. On a color printer (e.g. an ink
jet), if separations are not enabled you will get a single composite color
page and on a mono printer (e.g. a laser printer) it will give a single
grayscale page.

After specifying options, click one of the other tabs to set more options,
or click OK to return to the main Print dialog and save any changes.
Click Cancel to abandon changes.

PhotoPlus as an OLE Server

Finally, PhotoPlus can act as an OLE server. This means that you can
embed PhotoPlus images as objects in other programs, such as Serif
PagePlus, then just double-click them for editing using the PhotoPlus
tools.
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To embed a PhotoPlus object into a document in another program (in
this case PagePlus), copy the image to the Clipboard by choosing Copy

Merged (or Copy, for single-
g ( Py g

Iayer imageS) from the Edit = Fle Edit View Inset Formal Isols Arange Window Help
DSEHE|/ 2ED Y& Q
menu. Ik [BE P B B E BB B T B P e E BT
. V| T
Switch to the other program Yl eoste specia B
H A|Z| souse €y Dosmentshimpressioistson
and choose_Paste Special... i - B
from its Edit menu. The O Ceme [
cursor will change to the A | g [ (S0 e o
insert picture cursor. Click E q
- - | Ingerts the contents of the clipboard into pour
once to insert the image. Ol  Ea] ARmereseetan




PhotoPlus Keyboard Shortcuts

Tool shortcuts

Press... With... To...

S Selection tools  Add to current selection

- - - -
Al --- Selection tools  Subtract from current selection
- - -

Selection tools

Move selection contents

Selection tools

Duplicate selection contents

--- Move tool

Duplicate selection contents

Adjustable
1] Selection tools,
Crop tool, Shape
tools, Image Map

Constrain aspect ratio when
dragging to define shape or
region

rectangle

Shi Line tool Constrain to 15° angle intervals

[Al] ---  Text, Paintorush, Left-click to pick up foreground

TTT Airbrush, Fill, color; right-click to pick up

) Line, Shape tools background color

- - Clone tool Define pickup origin point
st Deform tool Drag center to constrain rotation
R to 15° angle intervals
st Deform tool Drag corner handle to constrain
Tt aspect ratio



Deform tool

Drag corner handle to resize
relative to fixed point

Deform tool

Drag corner handle to resize
relative to fixed point while
constraining aspect ratio

Deform tool

Drag corner handle to skew

Deform tool

Drag corner handle to change
perspective




Menu command shortcuts

Press... With... To...
Undo last action
L]
m Redo last undone action
L]
Paste from Clipboard as new layer
L]
Shi| -- Paste from Clipboard into selection
oo
Copy selection or layer to Clipboard
L]
Shi] -- Copy merged (all layers as one layer) to
ou Cliphoard
@ Cut selection to Clipboard
L]
M Paste from Clipboard as new image
L]
Deselect pixels
L]
Shi] -- 1 Invert selection
oo
A Select all
L]
N  Newimage
L]
Open file
L]
B Print
1]



Save

Switch between image windows

Close current image window

E .- Close PhotoPlus
o
Al ---  ----  Activate menus
Tab Hide/show active tab windows




Index

A
active layer.........ccoccuveeeen. 53, 69
Add Mask command.............. 77
Add Text window........ 32,62,73
Adjust Color dialog........... 52, 62
Adjustable Selection tools...... 35
adjustment filters........ See filters
Airbrush tool..........cccoeeveeenee. 56
animation

.GIF format for Web .....84, 86

creating.......ooocvveeeeeeeeeiins 86
Animation tab .................. 19, 86
anti-aliasing................ 59, 62, 84
arranging layers .........ccc......... 71
arrow

drawing.......cccceveeeeeeeeeiieinns 59

selecting shape .................. 35

aspect ratio, constraining . 35, 60

B
background color .12, 32, 51, 56
Background layer ....... 22,51, 68
bit depth ......ooiiiiien. 84, 96
bitmap ..o 96
blur filters ................... See filters
box, drawing..........ccccccceeeene 59
Brightness/Contrast (adjustment
filter) .o 30, 42
browser, previewing images in
........................................... 90
Brush Tip tab.............. 11, 18,54
C
canvas, resizing ......... 11, 37, 47
captions, adding............... 29,31
circle
drawing.......ccccevveeeeeeeeenne 59

placing hotspot ................... 92

selecting shape .......ccc........ 35
Clipboard operations 37, 71, 100

Clone tool........ccccoveevviiieeennnn 57
CMYK
color separations.............. 106
MOde ....oovveeiiiiiiiieeeennn, 52,99
color
MOdEeS ......ceevviiiiiieeaennn. 52,98
palettes.........ccovvevveeeennnns 101
replacing........occcoveeeeeeennnns 42
separations...........cccceeee.... 106
theory ..o, 96
wheel......cocccovviii 99
Color Pickup tool............ 52, 100
Color Selection tool................ 35
Color tab .............. 12,19, 32,51
colors
adjusting.....ccceeerviiiiiieenenenn. 41
choosing......cccceevevvnneee. 32,52
replacing........occcoveeeeieeennnns 42
Windows system.............. 101
compression ............ 83, 85, 102
Conical (gradient fill type) ...... 61
Context Help button.......... 24,53
contrast, adjusting............ 30, 42
Copy command........ 37,771,108
Copy Merged command ...... 108
Create HTML for Image Maps
L1111 o[ 93

Create Image Slices setting... 92
Crop to Selection command . 30,
38

Crop tool ......ccccvvvveeeeeis 30, 37
custom filters ......ccoeevveevnernnn. 43
Cut command.................. 37,71
D
Deform tool ........ccooevvvveeeennnnn. 39
Delete command ................... 37
Delete Mask command.......... 78
Deselect command................ 36



diameter (of brush) ............... 54
digital camera (TWAIN) input. 21
Disable Mask command ........ 78
distortion filters........... See filters
dithering .....cccccvvveeeiinns 84, 102
dpi (dots per inch) .......... 98, 104
drawing......ccceeeeeeeernnnns See tools
hotspots (image maps)....... 92
lINES ..oviiiiiiiee 53, 59
shapes........ccoccvveeveeeeiiicnn, 59
drawing tablet................... 55, 56
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Grow Selection command ..... 36
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Merge Mask command.......... 78
Moiré patterns............cccuuee... 105
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montage, creating.................. 72
Move Marquee cursor...... 35, 36
Move tool .........ccc....... 33,36, 70
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New Frame button ................. 89
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OLE, PhotoPlus as server ... 107
opacity 13, 38, 54, 55, 61, 68, 87
opening an existing file .......... 21
optimizing images................ 100
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Paste command......... 37,63,71
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placing hotspot.................... 92
Posterize (effect filter)............ 44
preferences, setting ......... 20, 30
Preview in Browser command90
printer marks, including........ 106
Printing .......cccoeeveiivieeeenn. 24, 105

Promote to Layer command . 38,
69

properties, setting for tools..... 55

Protect Transparency............. 70
R

quality
adjustments for................. 105
in exported images............. 83

quality, in exported images ....85

Radial (gradient fill type) ........ 61

rectangle
drawing.......ccccevveeeeeeeeenne, 59
placing hotspot ................... 92
selecting shape .................. 35

Red eye, removing from photo

Reduce to fit option.............. 106
registration ...........cccooecveeeeennn. 7
render filters............... See filters
Render Text Layer command 63
Replace Color (adjustment filter)

........................................... 42
resizing.......ccovveeeeeenn. 11, 37, 47
resolution ..........cccceeenee 98, 104
retouching photos ................. 57
RGB mode......c.ccccocvveeenne 52,99
Rotate command ................... 38

S
saturation

adjusting.....ccceeeviiiiiiieeneeenn, 42

defined ......ccoooviiiiiiee 99
SAVING -eevvieeeiaeaiaiiiiiieeae e e 22
saving files........ccccveeenn. 14, 102
(STor=111 0 To ORI 105
SCaNNING ....coevvvvvvieeeenenn, 21, 103
Select Similar command........ 36
selection.......ccccceveveeennnne 12, 33

Creating .....cceeeeeeieciiieeeeeenn, 33

deselecting.........ccccvvveeeennn. 36

duplicating ..........coccvveeeeenn. 36

feathering .........cccoecvvveeennn. 79

INVErting........ooccvvveeeeeennnns 36

mModifying........cccovvvvreeeiinnns 35

(=117 ] o To SRR 39

rotating ......ooooveevvvevneeeeieinns 39

Text Selection tool.............. 63
separations, CMYK color..... 106
sepia tone, adding to photo ... 46
Shape tools......cccccevveeevicnnnee, 59
shortcuts, table of ................ 109
Smudge tool......cccceeeerviinnnen. 57
Soften filter........ccccceeeiinne 44
solid fill .........c.c....... See flood fill
special effects filters .. See filters
spiral, selecting shape............ 35

SPP file format.... 14, 22, 69, 76,
90, 97
square



drawing .......occevvveeeeeeeinnne 59
selecting shape .................. 35
Square (gradient fill type)....... 61
Standard Selection tools .. 34, 38
Standard toolbar .................... 18
star
drawing .......occcveveeeeeeenninee 59
selecting shape .................. 35
Starting PhotoPlus ................. 14
Startup Wizard.........cccceeeenn. 15
Stretch (adjustment filter)....... 43
support, technical.................... 7
system requirements................ 7
T
tab windows ..........cccoeeveeenne 11
Animation tab ............... 19, 86
Brush Tip tab.......... 11, 18,54
Color tab........... 12,19, 32,51
docking and undocking....... 17

Layer Manager tab 19, 68, 71,
86

Navigatortab...................... 19

Tool Properties tab 11, 18, 35,
55

technical support..........cccveee... 7
text
adding.........coccvvvieneeennn 32,62
creating selection in shape of
........................................ 63
deforming ........ccccceeeeiiinnnee 40
(=10 1111 0o [ 63
textlayers......cooocceeeeiiiiiiinen. 63
Text Selection tool ................. 63
Texttool .......cccceeeeeernnnns 32, 62
Threshold (adjustment filter) .. 42
1111 o TR 105
tolerance setting......... 35, 45, 60

Tool Properties tab....11, 18, 35,
55

toolbars
Standard........ccceeeeeeeiiiiinnnn. 18
TOOIS... i 11, 18

t00IS .. 11

Adjustable Selection tools.. 35

Airbrush tool ....................... 56
Clone tool.....cccoeeevevevvvennnnnn. 57
Color Pickup tool........ 52, 100
Color Selection tool............. 35
Crop tool.......cccvveeeeeennn. 30, 37
Deform tool.......cccocevvevevnnen. 39
Eraser tool.........ccoccevvunnene. 56
Flood Fill tool................. 47, 60
Gradient Fill tool.................. 60
Image Map tools................. 92
Image Slice tool.................. 91
Line tool.......cccoeeeeeveeerirenninn, 59
Move tool................ 33, 36, 70
Paintbrush tool ................... 53
Smudge tool........cccceeeennees 57

Standard Selection tools ... 34,
38

Text Selection tool.............. 63
Texttool .....coveveeiiieeeeeies 62
Tools toolbar............c..uvee. 11, 18
transparency.... See also opacity
in exported images....... 84, 85
TWAIN input......cccovveereeeeens 21
U
Undo optionS..........coccuveveeeennn. 30
URLs
forimage maps .................. 93
for image slices................. 91
V
View Mask setting.................. 78
view, setting........cccceceeveeeinnnns 20
Vignetting........coooocieieeieeeennns 78
W
wave, selecting shape ........... 35
Web images
animationsS..........cccevevevennnns 86
file formats for .................... 83
performance issues............ 83

previewing in browser......... 20



Web-safe palette........ 84, 101

weight (line thickness)............ 59

Windows system colors ....... 101
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