Overview

The Netscape AOL Instant Messenger (AIM) service provides the easiest way to see your friends who are online
and to communicate instantly with them. It allows you to add your buddies to your Buddy List. Your buddies can
be friends, family members, coworkers, and others who are AOL, CompuServe (CS2000), AOL Instant messenger
(SM), or other Netscape AOL Instant Messenger users.

When your buddies sign on, they appear in your Buddy List window, and you can start exchanging messages with
them or send files to them.

Using the Netscape AOL Instant Messenger service, you can:

Get the latest news.
Add buddies to your Buddy List.

Send instant messages to your online buddies, and liven up your instant message sessions by using fun icons
(cartoon characters, symbols, and pictures) to represent buddies.

Chat with a buddy or group of your friends or family members in your own private chat room.

Control who communicates with you through the buddy controls feature. You can allow anyone to send you
messages or block messages from specific people.

Find your buddies by e-mail address, by name and e-mail address , or by common interest. You can find
screen names of those friends who already belong to the Netscape AOL Instant Messenger service, AOL
Instant Messenger (SM) service, AOL, or CS2000.

Transfer files.

Invite a friend to sign up for the Netscape AOL Instant Messenger service through the Sign On A Friend
feature.

Create a personal profile with information such as your e-mail address or a link to your Web page, or you can
display your buddies’ personal profiles.

Warn users who send you annoying or offensive messages.
Search the Internet.
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Steps to Get Started
To get started using your Netscape AOL Instant Messenger service, perform the following steps:

Register for a Netscape AOL Instant Messenger account, and select a screen name.

Download and install the Netscape AOL Instant Messenger software.

Sign on to the Netscape AOL Instant Messenger service.

Start the New User Wizard to help you get started with the Netscape AOL Instant Messenger service.
Add buddies to your Buddy List.

Create a personal profile.
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Refer to AIM Online Help and Frequently Asked Questions (FAQ) for help and answers to your questions that
might already be addressed.
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Registering

Before you can use the Netscape AOL Instant Messenger service, you need to register and select a screen name
and password.

To register and select a screen name and password, perform the following steps:
1 Go to the Netscape AOL Instant Messenger home page, http://register.oscar.aol.com/73026_create.
The Netscape AOL Instant Messenger web page appears on your screen, allowing you to register.

2 If you are not an AOL member, enter your screen name, password (twice for confirmation), and e-mail address
in the appropriate fields.

Note: If you are an AOL member, your AOL screen name is reserved for you to use with AIM. To register it,
click AOL, and follow screen instructions.

3 Click Click Here to initiate the registration process.
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What to Do After Registering

After you register your screen name and password, the Netscape AOL Instant Messenger service sends you an e-
mail, asking you to confirm your registration request.

After you receive the mail, perform the following steps:
1 Confirm your registration by entering only the word OK in the body of your confirmation e-mail.

You must respond to the e-mail within 48 hours to complete your registration. If you don’t respond within 48
hours, you are asked to register again.

2 Download a copy of the Netscape AOL Instant Messenger software.

3 Install the Netscape AOL Instant Messenger software , and sign on with the screen name and password you
registered.
Note: Anyone who knows your password has access to your account; therefore, you should never reveal your
password to anyone online. No one from AOL will ever ask you for your password while you are online.

4 Start the New User Wizard if you are using the Netscape AOL Instant Messenger service for the first time and
want a quick overview.
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Choosing a Screen Name

Your screen name is the name by which you are known to everyone who uses the Netscape AOL Instant
Messenger service, America Online, and CS2000. Your screen name can be between 3 and 10 characters long,
using letters, numbers, and spaces.

Once you select and register your screen name, you cannot change it to a new one. You can, however, format
your screen name to change capitalization and spacing.

Note: If you are already an AOL member, your screen name is reserved for you. However, you still need to
register to use the Netscape AOL Instant Messenger service.
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Removing a Screen Name

If you have a screen name that you don’t want to use anymore, you can remove it from the Sign On screen. Note
that your screen name is only removed from the Sign On screen, and it is not permanently deleted from the screen
name database.

To remove a screen name from the Sign On screen, perform the following steps:
1 Select the screen name that you want to delete.
2 Press the Delete key.
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Using Multiple Screen Names

You can register multiple screen names to use with the Netscape AOL Instant Messenger service.

To sign on with a new screen name you have registered, perform the following steps:

1 Display the Sign On screen.

2 Type your new screen name over the current screen name that is displayed in the Screen Name field.
3 Click Sign On.
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Installing the Netscape AOL Instant Messenger Software

After you have downloaded the Netscape AOL Instant Messenger service, you must install it on your system
before you can communicate with your online buddies.

To install the Netscape AOL Instant Messenger software, perform the following steps:
1 Locate the AIM95 setup file that you downloaded to your system.
2 Double-click the AIM95 icon to start the installation process.

By default, the installer stores the Netscape AOL Instant Messenger in your Windows Program Files directory in
the AIM95 folder. You can store the software in another location if you don’t want to use the default location.
However, make a note of where you store the software in case you want to uninstall AIM.

3 Follow the installation instructions on your screen.
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Uninstalling the Netscape AOL Instant Messenger Software

If you need to uninstall the Netscape AOL Instant Messenger software, you can do it at any time.

To uninstall the Netscape AOL Instant Messenger software, perform the following steps:
1 Locate your AIM95 folder.

2 Double-click the Uninstall AOL Instant Messenger icon.

3 Follow the screen instructions to uninstall AIM.

Related Topic
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Signing On to the Netscape AOL Instant Messenger Service

To sign on to the Netscape AOL Instant Messenger service, perform the following steps:

1 Display the Netscape AOL Instant Messenger Sign On screen. (If the AIM icon appears in your system tray at
the bottom of your screen, click it, and click Connect to AIM.

2 Enter your screen name in the Screen Name field.
3 Type your password in the Password field.
4 Click Sign On, or press Enter.
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Connecting Through a Modem

If you want to connect to the Netscape AOL Instant Messenger service through a modem, you need to dial in to
your Internet Service Provider (ISP) first. When you are connected to the Internet, you can sign on to the service.

Resolving Connection Problems

If you experience problems connecting, run the automatic configuration program to find a host and port through
which you can connect. You must have a live connection to the Internet to complete this procedure.

To resolve connection problems, perform the following steps:
1 Click Setup on the Sign On screen.
2 Click Auto Configure.

The Automatic Configuration program attempts to find a host and port through which you can sign on to the
Netscape AOL Instant Messenger service.

3 Click OK to save the settings and close the dialog box.

Note: If you want to preserve your Internet connection while you are signed on to the Netscape AOL Instant
Messenger service, select the Keep connection alive check box. (Some ISPs automatically disconnect you if you
have been inactive for a given period.) Every five minutes the program sends a signal to keep your connection
alive, even though you may be idle.

Automatically Connecting and Signing On

To make your connection to the Netscape AOL Instant Messenger service as quick and easy as possible, you can
configure the program to start when Windows starts and then automatically sign on when you connect to the
Internet through your ISP.

To connect and sign on automatically, perform the following steps:
1 On the Sign On screen, enter your screen name and password.
Click Setup.

Click the General tab.

Select the Save password check box.

Select the Automatically sign on when AIM starts check box.
Select the Start AIM when Windows starts check box.

In the Internet Connection box, click Modem.

Click OK to save the settings and close the dialog box.
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Connecting Through a Local Area Network

If you want to connect to the Netscape AOL Instant Messenger service through a local area network (LAN) (for
example, at work or school), you need to have a live connection to the Internet before you sign on to the service.

Resolving Connection Problems

If you experience problems connecting, run the automatic configuration program to find a host and port through
which you can connect. You must have a live connection to the Internet to complete this procedure.

If your local area network is behind a firewall, you must use a proxy server to connect to the service. Contact your
network administrator to help you determine the configuration settings to enter.

To check and set connection options, perform the following steps:
1 Click Setup on the Sign On screen.

2 Enter the settings your network administrator supplies.

3 Click OK to save the settings and close the dialog box.

Note: If you want to preserve your Internet connection while you are signed on to the Netscape AOL Instant
Messenger service, select the Keep connection alive check box. (Some ISPs automatically disconnect you if you
have been inactive for a given period.) Every five minutes the program sends a signal to keep your connection
alive, even though you may be idle.

Automatically Connecting and Signing On

To make your connection to the Netscape AOL Instant Messenger service as quick and easy as possible, you can
configure the program to start when Windows starts and then automatically sign on when you connect to the
Internet through your ISP.

To connect and sign on automatically, perform the following steps:
Enter your screen name and password on the Sign On screen.
Click Setup.

Click the General tab.

Select the Save password check box.

Select the Automatically sign on when AIM starts check box.
Select the Start AIM when Windows starts check box.

In the Internet Connection box, click Modem.

Click OK to save the settings and close the dialog box.
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Running the New User Wizard

The New User Wizard provides you with a quick overview of the Netscape AOL Instant Messenger service to help
you get started. It guides you through the basic steps to add or find a buddy and create a personal profie with
information that you would like to share with others.

To run the New User Wizard, perform the following steps:
1 Select the File menu from the Buddy List window.
2 Click New User Wizard.

The Welcome window appears on your screen. The screen instructions step you through the wizard to help
you get started with AIM.
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Inviting a Friend to Register for an AIM Account

Expand your circle of friends in your Buddy List by inviting others to become Netscape AOL Instant Messenger
members. Remember, the Netscape AOL Instant Messenger account is free!

To invite a friend to register with AIM, perform the following steps:

1 Select the People menu from the Buddy List window.

2 Click Sign On A Friend.

3 Enter your friend’s e-mail address.

4 If you want to include a personal greeting in the invitation, type it in the text area.
5 Click Next.

6 When you are finished inviting your friends, click Finish.
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Exiting Netscape AOL Instant Messenger

Exiting the Netscape AOL Instant Messenger application signs you off, closes the application, and removes the
AIM icon from your system tray.

To exit the Netscape AOL Instant Messenger application, perform the following steps:
1 Click the AIM icon in the system tray at the bottom of your screen.
2 Click Exit.

Note: You can also exit the Netscape AOL Instant Messenger application by pressing Ctrl+Shift+F4 when the
Sign On screen or Buddy List window is in the foreground.

Related Topic
Signing Off Netscape AOL Instant Messenger




Signing Off Netscape AOL Instant Messenger

Signing off the Netscape AOL Instant Messenger application, logs you off, closes the application, and leaves the
AIM icon in your system tray. Keeping the AIM icon in the system tray lets you access and sign on to the service
very quickly.

To sign off AIM, perform the following steps:
1 On the Buddy List window, click File.
2 Click Close.

Related Topic
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About the News Ticker

You can use the Netscape AOL Instant Messenger service to get up-to-the-minute news with the News Ticker.
The News Ticker displays the top five news headlines for Top News, Business, Entertainment, and Sports
categories. Clicking on a headline in the News Ticker window launches your browser to the MyNews Web site to
display the news story.

AIM displays all news categories in the News Ticker window by default. If you do not want all news categories to
display, you can set AIM to display only those that interest you. If you do not want to display any news, you can
turn off the ticker entirely.

You can also perform these functions:

e Display your news headlines in bold.

e  Change the speed at which the news headlines scroll across the News Ticker window.

e Expand the News Ticker window to display a list of news headlines, instead of letting them scroll across the
window.

You can move the News Ticker window to any location you want on your screen.

Related Topics
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Changing the News Ticker Display Speed

You can change the rate at which the News Ticker headlines scroll on your screen to slow, medium, or fast.
Medium is the default News Ticker display speed.

To change the News Ticker display speed, perform the following steps:
1 Select the File menu from the Buddy List window.

2 Click My Options, and click Edit Preferences.

3 Click the Ticker tab.

4 Select the ticker speed from the Display speed field.

5 Click OK.

Related Topics

About the News Ticker

Displaying the News Ticker

Displaying Headlines in Bold

Displaying Only Selected News Headlines
Expanding the News Ticker Window
Stopping the News Ticker from Displaying




Displaying the News Ticker

The Netscape AOL Instant Messenger service displays the News Ticker by default when you first sign on. If you
have closed the News Ticker window, you can easily redisplay it.

To display the News Ticker, perform the following steps:
1 Select the Favorites menu from the Buddy List window.
2 Click News Ticker.

Related Topics
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Displaying Headlines in Bold

You can display your news headlines in bold or in plain text. The Netscape AOL Instant Messenger service
displays the headlines in bold by default.

To display the headlines in bold, perform the following steps:
1 Select the File menu from the Buddy List window.

2 Click My Options, and click Edit Preferences.

3 Click the Ticker tab.

4 Select Display headlines in bold.

5 Click OK.

Related Topics
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Stopping the News Ticker from Displaying When You Sign On

The Netscape AOL Instant Messenger service displays the News Ticker by default when you sign on.

To stop the ticker from displaying at sign-on, perform the following steps:
1 Select the File menu from the Buddy List window.

2 Click My Options, and click Edit Preferences.

3 Click the Ticker tab.

4 Deselect Display Ticker at Signon.

5 Click OK.

Related Topics
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Displaying Only Selected News Categories

The News Ticker window displays the top news headlines for Top News, Business, Entertainment, and Sports by
default. You can remove any of these categories, leaving only those that interest you.

To display only selected news categories, perform the following steps:
1 Select the File menu from the Buddy List window.

2 Click My Options, and click Edit Preferences.

3 Click the Ticker tab.

4 Deselect the news categories in the Categories field that you do not want the Netscape AOL Instant Messenger
service to display in the News Ticker window.

5 Click OK.
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Expanding the News Ticker Window

You can expand the News Ticker window to display a list of news headlines, instead of having it scroll across the
ticker window.

To expand the News Ticker window, when it is displayed on your screen, double-click the small box in the upper-
left corner of the window. (See example below.)
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Check your desired options.



Check your desired options.



Closes this dialog and saves any changes you have made.



Closes this dialog without saving any changes you have made.



Saves your changes but does not close the dialog.



Select your preferred option.



Select your preferred option.



Select your preferred option.



Click this button to make your choice.



Click this button to make your choice.



Click this button to make your choice.



Click this button to make your choice.



Check your desired options.



Check your desired options.



Allow all users to see you in their Buddy List windows and send you messages.



Prevent all users, except those you specify in the Allow List, from seeing you in their Buddy List windows and sending you
messages.



Prevent all users from seeing you in their Buddy List windows and sending you messages.



Allow all users, except those you specify in your Block List, to see you in their Buddy List windows and send you messages.



This list box is active if you have selected Allow only the users below. To add a Screen Name, click Add Name, type in the Screen
Name, and press Enter. To delete a Screen Name, select the Screen Name and click Remove.



This list box is active if you have selected Block the users below. To add a Screen Name, click Add Name, type in the Screen
Name, and press Enter. To delete a Screen Name, select the Screen Name and click Remove.



Prevent all users, except those on your Buddy List, from seeing you in their Buddy List windows and sending you messages.



Add a user to the Allow List.



Remove the selected user from the Allow List.



Add a user to the Block List.



Remove the selected user from the Block List.



Allow other users to see how long you have had an AOL Instant Messenger account.



Allow other users to see whether you are idle.



Specify which users can and cannot contact you with Instant Messages.



Determine whether or not other users can view information on how long you have been idle and how long you have had an AOL
Instant Messenger account.



This list box is active if you have selected Allow only the users below. To add a Screen Name, click Add Name, type in the Screen
Name, and press Enter. To delete a Screen Name, select the Screen Name and click Remove.



This list box is active if you have selected Block the users below. To add a Screen Name, click Add Name, type in the Screen
Name, and press Enter. To delete a Screen Name, select the Screen Name and click Remove.



Specify which information can be obtained through the Find a Buddy feature by users who know your e-mail address.



Allow users who know your e-mail address to obtain your screen name through the Find a Buddy feature.



Allow users who know your e-mail address to learn only that you have an account (but not to learn your screen name) through the
Find a Buddy feature.



Allow users who know your e-mail address to learn nothing about you through the Find a Buddy feature.



Specify the pathname of an alternate web browser.



Select an alternate Web browser.



Open each additional Web document in a new window, instead of re-using an open window.



Use your default web browser when you click on Web links.



If you select this option and specify the pathname of an alternate web browser, AOL Instant Messenger will use the browser you
specify.



Use the default e-mail program specified in your registry when you click on mailto links.



Use the e-mail program included with your Web browser.



If you select this option and specify the pathname of an alternate e-mail program, AOL Instant Messenger will use the e-mail
program you specify.



Specify the pathname of an alternate e-mail program.



Select an alternate e-mail program.



Enter the command line arguments that your e-mail program requires to address a message. Use the argument %1 to specify
where to put the e-mail address. For example, mailto:%1.



Specify which Web browser AOL Instant Messenger uses when you click on a link to a Web document, and whether additional
Web documents should be opened in new windows.



Specify which e-mail program AOL Instant Messenger uses when you click on a mail link.



Select this option to conduct a Web search.



Choose a font from the list.



Choose a point size from the list.



Select this option to dim the display of your buddies after they have been idle for the specified number of minutes.



Enter your input in this field.



Select this option to flash the Buddy List window for five seconds when your buddies sign on or off.



Click this button to make your choice.



Choose an item from the list.



Click this button to make your choice.



Click this button to make your choice.



Click this button to make your choice.



Click this button to make your choice.



Check your desired options.



Click this button to make your choice.



Closes this dialog without saving any changes you have made.



Supply information about yourself that you would like others to be able to access. (For example, your name, hobbies, etc.)



Supply information about yourself that you would like others to be able to access. (For example, your name, hobbies, etc.)



If you select this option and enter a message, the message will be automatically sent to those who send you a message after your
computer is idle for more than ten minutes.



Enter your idle message.



If you select this option and activate your away message, the message will be automatically sent to those who send you a
message. Your away message Will also appear in the Personal Profile section of the Buddy Info window when someone requests
information about you.



If you select this option and activate your away message, the message will appear only in the Personal Profile section of the
Buddy Info window. An automatic response will not be sent.



Select an away message for use or removal.



Add the new message you have entered to your Away messages list.



Remove the selected message from your Away messages list.



Display the selected away message.



Enter new away messages. After you have entered a new message, click the Add Message button.



Specify and enable your idle message.



Specify and control your away messages.



Save your password between sessions, so you don't have to enter it each time you sign on. Note that saving your password is
less secure, since another person could easily sign on using your screen name.



Automatically connect to the AOL Instant Messenger service each time you launch the program. This option is only available if you
have selected the Save password option.



Select a default font style and size for the Instant Message window.



Select a default background color for the Instant Message window.



Select this option if you want the Enter key to insert a line break. Deselect this option if you want the Enter key to send your
message.



Select this option if you want the Tab key to insert a tab. Deselect this option if you want the Tab key to toggle among fields in the
Instant Message window.



Select this option if you want the messages you send and receive to be marked with the time they are sent.



Customize the default font and window color used in your Instant Message window.



Automatically start AIM when Windows starts. Once started, AIM will wait until it detects an Internet connection. When it does, it
will log on automatically.



Select this button if you connect to the Internet by a modem (dialup) connection.



Select this button if you connect to the Internet by a local area network connection.



Customize the default font and window color used in your Instant Message window.



Customize the appearance and behavior of your Instant Message window.



Customize your sign on preferences and specify the type of Internet connection you use.



Select this option if you do not want graphical smilies to appear in your Instant Message window.



Select this option if you want to be able to choose whether to accept messages from people not on your Buddy List.
Deselect this option if you want all messages to appear as soon as they are received.



Play a sound when one of your buddies signs on.



Choose a sound from the list.



Select a sound file to play when buddies sign on.



Hear the sound you have chosen to play when buddies sign on.



Play a sound when one of your buddies signs off.



Choose a sound from the list.



Select a sound file to play when buddies sign off.



Hear the sound you have chosen to play when buddies sign off.



Play a sound the first time you receive a message from a particular buddy, but not on subsequent messages from that buddy.



Choose a sound from the list.



Select a sound file to play the first time you receive a message from a particular buddy, but not on subsequent messages from
that buddy.



Hear the sound you have chosen to play the first time you receive a message from a particular buddy, but not on subsequent
messages from that buddy.



Play a sound every time you receive a message.



Choose a sound from the list.



Select a sound file to play every time you receive a message.



Hear the sound you have chosen to play every time you receive a message from a particular buddy.



Play a sound every time you send a message.



Choose a sound from the list.



Select a sound file to play every time you send a message.



Hear the sound you have chosen to play every time you send a message.



Control sounds that play when buddies sign on or off.



The settings in this box control sounds that play when you send or receive instant messages.



Specify the server address and port number to be used on the AOL Instant Messenger™ server. Under normal circumstances,
you do not need to change these settings. If you should change them accidentally, you can restore the default settings by clicking
the Reset button.



This field contains the default Internet address of the AOL Instant Messenger™ server. Under normal circumstances, you do not
need to change this field. If you should change it accidentally, you can restore the default setting by clicking the Reset button.



This field contains the default server port number to be used on the AOL Instant Messenger™ server. Under normal
circumstances, you do not need to change this setting. If you should change it accidentally, you can restore the default setting by
clicking the Reset button.



If necessary, specify proxy server information for using AOL Instant Messenger through a Local Area Network firewall (for example
at your workplace). Your network administrator may need to configure these settings.



Activate the proxy server controls.



Supply the name of the proxy server.



Supply the port number to be used on the proxy server.



Select this option if your proxy server uses SOCKS 4 protocol.



Select this option if your proxy server uses SOCKS 5 protocol.



Select this option if your proxy server uses HTTPS protocol.



Supply the authentication username required by the proxy.



Supply the authentication password required by the proxy.



Use the proxy server to act as a name server for hosts that are behind the firewall.



If you click this button, the AOL Instant Messenger™ software will attempt to configure itself to work in your computer's network
environment. Try Auto Configure if you are having difficulty connecting with AOL Instant Messenger™ Service.



If you click this button, the AOL Instant Messenger™ software will restore the default Server Host and Port values.



Preserve your Internet connection during idle periods. (Some Internet Service Providers automatically disconnect users who have
been inactive for a given period.)



Creating a Personal Profile

To create a personal profile, perform the following steps:

1.
2.

Select the File menu on the Buddy List window.
Click My Profile.

AIM displays a message, reminding you that all AIM members can see information included in your personal
profile. If you don’t want to be reminded of this in the future, click the Do not tell me this again checkbox.

Click OK.

If you want others to be able to find you, using your name and address, click Allow People to Search for Me,
and enter your name and address in the appropriate fields.

Click Next.

If you want to chat with others of specific interests, click | am available for chat. Indicate your interest by
clicking Choose Interest and selecting your interest from the list. You can specify up to five interests.

Click Next.

Type any additional information that you want others to know about you. Information that you enter is
displayed when others click More Info.

Click Finish when you are finished creating your personal profile.

Related Topics
Editing Your Profile

Creating A Hyperlink in Your Profile

Displaying Information About Someone Else




Editing Your Profile

You can change your profile whenever you are signed on to the Netscape AOL Instant Messenger service. Your
profile can also include up to five interests (or hobbies) by which you want others to be able to find you on the
Internet.

To edit your profile, perform the following steps:

1 On the File menu, click My Profile.

2 Edit the appropriate fields that you want to update.

3 Click Next.

4 Change the interests you want by selecting Choose Interest, then selecting a different area of interest.

If you have not specified that you are available for chat and want to chat with your buddies, click | am available
for chat. If you don’t want to specify your interests so that other users can find you and send messages to
you, leave this field unchecked.

5 Click Next.
6 Edit the information that you want to change.

You can use the toolbar to change text and background color or font sizes; to make text bold, italic, or
underlined. You can use the link button on the toolbar to create hyperlinks to your e-mail address and web sites.

7 Click Finish when you are finished updating your profile.

Note: You do not need to fill out this information in order to use the Netscape AOL Instant Messenger service.

Related Topics

Creating a Personal Profile

Creating A Hyperlink in Your Profile
Displaying Information About Someone Else




Creating a Hyperlink in Your Profile

You can include hyperlinks in your personal profile (for example, you can link users to your personal web page).

To create a hyperlink in your personal profile, perform the following steps:
1 Type and select the text you want to turn into a hyperlink.
2 Click link on the toolbar.
The Edit Hyperlink dialog opens.
3 Specify the URL (Internet location) of the site you want the link to point to.
You can also specify an e-mail address as the URL. For example, mailto:johndoe@aol.com.
4 Click OK to apply your changes and close the dialog.

Tip: You can also click link with no text selected. If you do this, you need to enter the link text into the Edit
Hyperlink dialog. The link appears at the insertion point location.

Related Topics

Creating a Personal Profile

Editing Your Profile

Displaying Information About Someone Else




Displaying Information About Someone Else

Every user of the Netscape AOL Instant Messenger service can provide personal information that is available to
other users. This information includes, for example, name, e-mail address, favorite quotation, or link to a web
page. This information is only available when the user is signed on.

To display information about someone else, perform the following steps:

1 On the Online tab of the Buddy List window, select the buddy whose information you want to see.
The name of the buddy appears highlighted.

2 Click the right mouse button and choose Get Member Info from the popup menu.
The Buddy Info screen is displayed.

3 Click Close when you have finished reviewing the information.

Note: You can view information only about other Netscape AOL Instant Messenger users. You cannot view the
profiles of AOL members.

Related Topics

Editing Your Profile

Creating A Hyperlink in Your Profile
Displaying Information About Someone Else




How the Buddy List Works

When you sign on to the Netscape AOL Instant Messenger service, your Buddy List window appears. There are
two tabs in your Buddy List window: List Setup and Online.

The List Setup tab allows you to add your buddies' screen names to your Buddy List and create groups for them.
For example, you can create groups for specific interests such as Tennis Pals, Photographers, Classmates, and
so forth, then add your buddies to them. The List Setup tab also allows you to manage your Buddy List by
letting you delete buddies and groups or rearrange them.

The Online tab lists your buddies who you have added to your Buddy List who are signed on. Once they are
signed on, you can exchange instant messages with them.

Initially, three empty groups appear on these tabs: Buddies, Family, and Co-Workers. Add your buddies to any of
these groups or create additional groups. If you don't know your buddies' screen names (from either America
Online or the Netscape AOL Instant Messenger service), you can find a buddy by e-mail address, by name and
address, or by common interest.

In the List Setup tab:

§ Each group appears as a folder.

§ The buddies in each group appear as branches from the folder. You must expand the group to see buddies in
that group.

§ You cannot see which of your buddies is online when you display the List Setup tab. Click the Online tab to
see which buddies are online.

In the Online tab:

§ Groups in the Buddy List window are initially shown expanded, displaying all your buddies in each group. You
can toggle the display mode between expanded and collapsed by clicking the small triangle to the left of each
group name.

§ Each group has a number in parentheses to the right of the group name to indicate how many people in the
group are online out of the total number of buddies in the group. For example, (3/9) means that three of the
nine buddies in the group are currently online.

§ Buddy names in bold indicate the buddies who signed on most recently. Buddy names in gray and italic
indicate the buddies who just signed off. You can move the cursor over your buddy’s screen name to display
information such as the name of the online service that your buddy is using, warnings, and online time.

Tip: To toggle between the Online and List Setup tabs, press CTRL+TAB.

Related Topics

Adding a Buddy to Your Buddy List
Adding a Group to Your Buddy List
Rearranging Your Buddies

Renaming a Buddy or Group

Finding a Buddy by E-mail Address
Finding a Buddy by Common Interest
Finding a Buddy by Name and Address
Buddy List FAQ




Finding a Buddy by E-mail Address

To find a buddy by e-mail address, perform the following steps:

1 On the People menu, point to Find a Buddy, and then click By E-mail Address.
2 Type your buddy's e-mail address.

3 Click Next.

Related Topics

Finding a Buddy by Common Interest
Finding a Buddy by Name and Address
Buddy List FAQ




Finding a Buddy by Name and Address

To find a buddy by name and address, perform the following steps:

1 On the People menu, point to Find a Buddy, and then click By Name and Address.
2 Type the information about your buddy in the fields.

3 Click Next.

Related Topics

Finding a Buddy by E-mail Address
Finding a Buddy by Common Interest
Buddy List FAQ




Finding a Buddy by Common Interest

You can search the Internet to find buddies with common interests. For example, if you are interested in
photography, you can search for others who are also interested in photography and send instant messages to
them.

To find a buddy with a common interest, perform the following steps:
1 On the People menu, point to Find a Buddy, then select By Common Interest.
2 Click Choose Interest.
The service displays a list of interests from which you must select.
3 Select an interest.
4 Click Next to display a list of users who share your interest.
5 Select a user from the Lookup Reply List window.
To display more information about the user, click More Info.
To send an instant message, click IM.
6 Click Finish when you are done.

Related Topics
Finding a Buddy by E-mail Address
Finding a Buddy by Name and Address

Buddy List FAQ




Adding a Buddy to Your Buddy List

You can add buddies (friends, family members, and coworkers who are AOL, CS2000, AOL Instant Messenger
(SM), or other registered Netscape AOL Instant Messenger users) to your Buddy List. Whenever your buddies
sign on, you can see them in your Buddy List and send them messages instantly.

To add a buddy to your Buddy List, perform the following steps:
1 In the Buddy List window, click the List Setup tab.

2 Click the folder to which you want to add your buddy.

3 Click the Add Buddy icon:
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A branch appears with the default name *New Buddy*.
4 Type the screen name of the buddy you want to add, and press Enter.

Remember to enter just the buddy’s screen name, not your buddy’s full E-mail address. For example, johndoe,
rather than johndoe@aol.com.

Notes:
§ If you don't know your buddy’s screen name (from either America Online or the Netscape AOL Instant
Messenger service), you can find a buddy by e-mail address, by name and address, or by common interest.

8 You can invite friends who have not yet signed up to join the Netscape AOL Instant Messenger service. On the
People menu, click Sign On A Friend and follow the instructions.

Related Topics

Adding a Group to Your Buddy List
Rearranging Your Buddies
Renaming a Buddy or Group

Buddy List FAQ




Adding a Group to Your Buddy List
To add a group to your Buddy List, perform the following steps:

1 In the Buddy List window, click the List Setup tab.
2 Click the Add Group icon:
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e

A folder appears with the default name *New Group*.
3 Type a new name for the group, and press Enter.

Related Topics

Adding a Buddy to Your Buddy List
Rearranging Your Buddies
Renaming a Buddy or Group

Buddy List FAQ




Rearranging Your Buddies

To rearrange your buddies in your Buddy List, perform the following steps:
1 In the Buddy List window, select the buddy or group you want to move.
2 Drag and drop the entry to a different location in your Buddy List.

Related Topics

Adding a Buddy to Your Buddy List
Adding a Group to Your Buddy List
Renaming a Buddy or Group

Buddy List FAQ




Renaming a Buddy or Group

To rename a buddy or group in your Buddy List, perform the following steps:
1 In the Buddy List window, click the List Setup tab.
2 Select the buddy or group you want to rename.
The name of the buddy or group appears highlighted.
3 Click the right mouse button and choose Edit from the popup menu.
4 Enter the new name for the buddy or group, and press Enter.

Related Topics

Adding a Buddy to Your Buddy List
Adding a Group to Your Buddy List
Rearranging Your Buddies

Buddy List FAQ







About Buddy Icons

Have fun with the Netscape AOL Instant Messenger service by livening up your instant message sessions with
buddy icons. Buddy icons are images such as cartoon characters, symbols, pictures, and other graphical images
you can use to represent buddies in your Buddy List. The buddy icons appear in the lower-left corner of your
Instant Message windows when you send messages to your buddies who are online, and the icons remain in the
windows until you end your conversation.

The graphics file that you want to use for your buddy icon must be installed on your computer. If you don’t have
images installed, you can choose them from the Internet while you are using AIM, install them, and then select
them to be used as your buddy icons.

You can use .BMP, .GIF, .ICO, and .XBM file formats for your graphical images. There is no limit to the height and
width of the images you use, but you do have disk space limitations. Your image must not use more than 7,168
bytes of disk space. If you are creating your own icons in a paint program, you should use a size of 48x48 pixels.

Note: You can download some graphical images from the Internet for free, while some manufacturers require
that you purchase their images.

Related Topics

Choosing a Buddy Icon
Sending an Instant Message
Sending Icons to Your Buddies
Buddy Icon Preferences




Choosing a Buddy Icon

You can choose icons to represent buddies in your Buddy List. When you send instant messages to your
buddies, the icons appear in the lower-left corner of your Instant Message windows.

You can choose a different icon to represent each buddy and group. When you use a buddy icon for a group, you
can also use a different buddy icon for each buddy in the group. In this case, when you send an instant message,
AIM uses the icon you chose for your buddy, instead of the icon chosen for the group. For more information
about buddy icons, see About Buddy Icons.

To choose a buddy icon for one of your buddies in your Buddy List, perform the following steps:
1 Select the File menu on the Buddy List window.
2 Click My Options, and click Edit Preferences to display the Preferences window.
3 Click the Buddy Icon tab.
4 Click your buddy’s screen name to which you want to add the icon.
To choose an icon to be used for all buddies within a group, select the group name, instead of a buddy’s name.

5 Choose Browse PC to go to the location of the image file, and select the image that you want to use for your
buddy.

If you don’t have images installed on your computer, you can select them from sites that are listed in the Buddy
Icons Center area in the preferences window.

Note that you can download some graphical images from the Internet for free, while some manufacturers require
that you purchase their images.

6 Click Apply.
7 Click OK when you are finished adding icons to your buddies’ screen names.

Related Topics

About Buddy Icons

Choosing a Buddy Icon
Sending an Instant Message
Sending Icons to Your Buddies




Sending Icons to Your Buddies

You can send icons (cartoon characters, symbols, pictures, and other graphical images) to your buddies to display
in their Instant Message windows when you send instant messages to them. Your buddies can either accept or
reject your image file.

For example, if you select Mickey Mouse or Minnie Mouse as your buddy icon and send an instant message to
your buddy, the image shows up in the lower-left corner of your Instant Message window if your buddy accepts it.
The image also remains in the window until you end your conversation.

Note: You can send icons only to buddies who have your screen name on their Buddy Lists.

To choose a buddy icon for one of your buddies in your Buddy List, perform the following steps:
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Select the File menu on the Buddy List window.

Click My Options, and click Edit Preferences to display the Preferences window.
Click the Buddy Icon tab.

Click My Buddy Icon in the Images to use for buddies field.

Choose Browse PC to go to the location of the image file, and select the image file that you want to send to
your buddy.

If you don’t have images installed on your computer, you can select them from sites that are listed in the Buddy
Icons Center area of your preferences window.

Note that you can download some graphical images from the Internet for free, while some manufacturers require
that you purchase their images.

The Netscape AOL Instant Messenger service allows your buddy to either accept or reject your image file.
Click OK.

Related Topics
About Buddy Icons

Choosing a Buddy Icon

Sending an Instant Message




About Instant Messages

You can communicate instantly with your buddies (friends, family, coworkers, and others), who are signed on to
AOL, CS2000, or AIM. Add your buddies to your Buddy List , send messages to them, and watch as messages
pop up on your screen — instantly!

You can also have fun with AIM by livening up your instant message sessions with buddy icons. Buddy icons are
images such as cartoon characters, symbols, pictures, and other graphical images you can use to represent
buddies in your Buddy List. The buddy icons appear in the lower-left corner of your Instant Message windows
when you send messages to your buddies who are online, and the icons remain in the windows until you end your
conversation.

Using the Instant Message feature, you can:

e  Share your favorite Web site with your buddies, by including links in your messages.

e  Create an Emoticon (or smiley) in an instant message.

e Change the default appearance of your messages such as adding color and changing font and size.
e Time-stamp your messages.

e  Save your instant message sessions.

Related Topics

Choosing a Buddy Icon

Sending an Instant Message

Sending Icons to Your Buddies

Creating a Hyperlink in an Instant Message
Create an Emoticon in an Instant Message
Changing Key Bindings for Messages
Changing the Default Appearance of Messages
Viewing the Timestamp in Messages

Saving Instant Messages




Sending an Instant Message

To send an instant message to your buddy, perform the following steps:
1 On the Online tab of the Buddy List window, select your buddy's screen name.
2 Click the Instant Message icon:

&

The Instant Message window opens.
3 Type your message in the text message area, and click Send.

Tip: You can use the toolbar to change text or background colors, change text size, or emphasize text with bold,
italic, or underlining.

Related Topics

About Instant Messages

Sending Icons to Your Buddies

Changing Key Bindings for Messages
Changing the Default Appearance of Messages
Creating a Hyperlink in an Instant Message
Saving Instant Messages

Viewing the Timestamp in Messages




Creating a Hyperlink in an Instant Message

To create a hyperlink in an instant message, perform the following steps:
1 In an Instant Message window, type and select the text you want to turn into a hyperlink.
2 Click link on the toolbar.
The Edit Hyperlink window opens.
3 Specify the URL (Internet location) of the site you want the link to point to.
You can also specify an e-mail address as the URL. For example, mailto:johndoe@aol.com.
4 Click OK to save the setting and close the dialog box.

Tips:
§ You can also click link with no text selected. If you do this, you need to enter the link text into the dialog box.
The link appears at the insertion point location.

§ If you enter an URL as text (for example, http://www.aol.com or mailto:;johndoe@aol.com), the text
automatically converts to a hyperlink when you send the message.

Related Topics

About Instant Messages

Sending Icons to Your Buddies

Changing Key Bindings for Messages
Changing the Default Appearance of Messages
Sending an Instant Message

Saving Instant Messages

Viewing the Timestamp in Messages




Creating an Emoticon in an Instant Message

You can add the following commonly used emoticons (or graphical smileys) to your messages by typing the
corresponding characters:

Type To Create
-) ]
=( &
) ©
) ]
Notes:

8  You can also create emoticons by holding down the right mouse button in a message and selecting the Insert
option from the menu.

§ To control whether these emoticons appear in your Instant Message window and on your right mouse button
menu, see Turning Emoticons On or Off.

Related Topics

About Instant Messages

Sending Icons to Your Buddies

Changing Key Bindings for Messages
Changing the Default Appearance of Messages
Sending an Instant Message

Saving Instant Messages

Viewing the Timestamp in Messages




Saving Instant Messages

To save instant messages to a file, perform the following steps:
1 In an Instant Message window, choose Save from the File menu.
The Save Text to File window opens.
2 Enter a name for the file in the File name field.
3 In the Save as type field, select Text Only if you want to save just the text of the messages.

If you want to save the text and be able to follow any hyperlinks in the messages, select AOL Rich Text
Format. This creates an HTML file you can view with your web browser.

4 Click Save to save the messages that appear in the upper pane of the Instant Message window.

Related Topics

About Instant Messages

Sending Icons to Your Buddies

Changing Key Bindings for Messages
Changing the Default Appearance of Messages
Sending an Instant Message

Viewing the Timestamp in Messages




About Chat

The Netscape AOL Instant Messenger Chat feature lets you exchange messages with several of your buddies in
your own private chat rooms. You can join popular chat rooms such as Health Chat, Entertainment Chat,
Romance Chat, Computing Chat, and a host of others that interest you.

Using Chat, you can also:

e Invite buddies to a chat room.

e  Create hyperlinks in your chat message.

e  Create emoticons in your chat message.

e Save chat messages to a file to read offline or to just keep in your files.

Note: Only Netscape AOL Instant Messenger users can chat in Buddy Chat rooms.

Related Topics

Inviting a Buddy to Chat

Sending a Chat Message

Creating a Hyperlink in a Chat Message
Creating an Emoticon in a Chat Message
Saving Chat Messages




Inviting a Buddy to Chat

To invite a buddy to chat, perform the following steps:

1 In the Buddy List window, click the Online tab.

2 Select the screen names of the buddies you want to invite to the chat room.
To select multiple screen names, hold down the Ctrl key as you select each name. You can also select an entire
group of buddies.

3 Click the Buddy Chat icon:

T

The Buddy Chat Invitation window opens.
If you want to send the invitation to additional buddies, type their screen names in the Screen names to invite field.
4 Click Send to send the invitation.

Tip: You can invite a buddy to join a chat in progress. In the Chat Room window, select People on the menu bar
and click Invite a Buddy to send an invitation.

Note: Only AIM users can receive Buddy Chat invitations. To see what service your buddy is using, click the
Online tab in the Buddy List window, and move the cursor over your buddy’s screen name. A small window
appears with the service type.

Related Topics

About Chat

Sending a Chat Message

Creating a Hyperlink in a Chat Message
Creating an Emoticon in a Chat Message
Saving Chat Messages




Sending a Chat Message

To send a chat message, perform the following steps:
1 Type the message that you want to send in the text area box of the Chat Room window.

You can send chat messages with hyperlinks and emoticons or format them using different styles such as bold,
italic, or underlining.  Using color or a different font can also help emphasize messages you send.

2 Click Send.
When you are finished with your chat conversation, you can save it to a file.

Tips:

§ To stop receiving messages from someone in the chat room, select the person’s screen name in the field that
lists everyone in the chat room and click Ignore. An X appears next to the selected screen name. Click Ignore
again to toggle the ignore feature off.

8§ You can use the toolbar to change text color or emphasize text with bold, italic, or underlining.

Related Topics

About Chat

Inviting a Buddy to Chat

Creating a Hyperlink in a Chat Message
Creating an Emoticon in a Chat Message
Saving Chat Messages




Creating a Hyperlink in a Chat Message

To create a hyperlink in a chat message, perform the following steps:
1 In a Chat Room window, type and select the text you want to turn into a hyperlink.
2 Click link on the toolbar.
The Edit Hyperlink window opens.
3 Specify the URL (Internet location) of the site you want the link to point to.
You can also specify an e-mail address as the URL. For example, mailto:;johndoe@aol.com.
4 Click OK to save the setting and close the dialog box.

Tips:
§ You can also click link with no text selected. If you do this, you need to enter the link text into the dialog box.
The link appears at the insertion point location.

§ If you enter an URL as text (for example, http://www.aol.com or mailto:johndoe@aol.com), the text automatically
converts to a hyperlink when you send the message.

Related Topics

About Chat

Inviting a Buddy to Chat

Sending a Chat Message

Creating an Emoticon in a Chat Message
Saving Chat Messages




Creating an Emoticon in a Chat Message

You can add the following commonly used emoticons (or graphical smileys) to your messages by typing the
corresponding characters.

Type To Create
-) ]
=( &
) ©
) ]
Notes:

8 You can also create emoticons by holding down the right mouse button in a message and clicking Insert, then
clicking the symbol you want to insert.

§ To control whether these symbols appear in your Chat Room window and on your right mouse button menu, see
Turning Emoticons On or Off.

Related Topics

About Chat

Inviting a Buddy to Chat

Sending a Chat Message

Creating a Hyperlink in a Chat Message
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Saving Chat Messages

To save chat messages to a file, perform the following steps:
1 In a Chat Room window, choose Save from the File menu.
The Save Text to File window opens.
2 Enter a name for the file in the File name field.
3 In the Save as type field, select Text Only if you want to save just the text of the messages.

If you want to save the text and be able to follow any hyperlinks in the messages, select AOL Rich Text
Format. This will create an HTML file you can view with your web browser.

4 Click Save to save the messages that appear in the upper pane of the Chat Room window.

Related Topics

About Chat

Inviting a Buddy to Chat

Sending a Chat Message

Creating a Hyperlink in a Chat Message
Creating an Emoticon in a Chat Message




How Away and Idle Messages Work

If you need to step away from your computer but do not want to sign off, you can instruct Netscape AOL Instant
Messenger to use the Away message and the Idle message to let other users know you are temporarily not
available.

For planned absences, you can turn on your Away message to let others know when you will be back. Netscape
AOL Instant Messenger displays this message when anyone requests information about you and automatically
replies with your Away message to anyone who sends you a message while you are away.

For unplanned absences, Netscape AOL Instant Messenger turns on your Idle message after 10 minutes of
inactivity. Netscape AOL Instant Messenger displays this message when anyone requests information about you
and automatically replies with your Idle message to anyone who sends you a message while you are away.

Related Topics

Away Preferences

Defining a New Away Message
Deleting an Away Message




Away Message Definition

A message you create for Netscape AOL Instant Messenger to use when you are away from your computer.



Idle Message Definition

A message you create for Netscape AOL Instant Messenger to use when your account is idle.



Defining a New Away Message

To define (or create) a new Away message, perform the following steps:

1 On the File menu, point to My Options, and then click Edit Preferences.
2 Click the Away tab.

3 Select the Auto respond and insert in personal profile option.

If you do not want Netscape AOL Instant Messenger to reply automatically to messages you receive when you
are away, select the Insert in personal profile only option.

4 Type the new Away message in the text field below these options.
5 Click Add Message.
6 Click OK to save your change and close the dialog box.

Related Topics

Away Preferences

Deleting an Away Message

How Away and Idle Messages Work




Turning an Away Message On and Off

To turn an Away message on or off, perform the following steps:

1 On the File menu, point to Away Message, and then click the Away message you want to use.
The Away message appears on your screen.

2 To turn off your Away message, click I’'m Back.

Related Topics

Away Preferences

Defining a New Away Message
Deleting an Away Message

How Away and Idle Messages Work




Deleting an Away Message

To delete an Away message, perform the following steps:

1 On the File menu, point to My Options, and then click Edit Preferences.
2 Click the Away tab.

3 Select the Away message you want to delete.

4 Click Remove.

5 Click OK to save your change and close the dialog box.

Related Topics

Away Preferences

Defining a New Away Message
How Away and Idle Messages Work




Defining an Idle Message

To define (or created) an Idle message, perform the following steps:

1 On the File menu, point to My Options, and then click Edit Preferences.
2 Click the Away tab.

3 Select the Auto respond with message option.
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In the text area next to this checkbox, type the message you want to send to anyone who sends you a message
while your computer is idle.

4 Click OK to save your change and close the dialog box.

If you do not use your computer for 10 minutes, Netscape AOL Instant Messenger automatically sends your Idle
message to anyone who sends you a message. To resume your service, press any key or click a mouse button.

Related Topics

Away Preferences

Defining a New Away Message
How Away and Idle Messages Work




How Buddy Controls Work

You can prevent (or block) any Netscape AOL Instant Messenger service user (or all users) from sending you
messages. This feature is useful if you find someone's messages offensive or if you simply don't want to receive
messages for a while. You can also specify only those users you want to be able to send you messages.

Related Topics

Allowing Everyone to Send You Messages

Allowing Only Buddies to Send You Messages
Blocking a Specific User from Sending You Messages
Blocking Everyone from Sending You Messages




Blocking Specific Users from Sending You Messages

To block a specific user from sending you messages, perform the following steps:
On the File menu, point to My Options, and then click Edit Preferences.
Click the Controls tab.

Select Block the users below.

Click Add Name.

Type the name of the user you want to add in the Block List.

Click OK to save your change and close the dialog box.
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Related Topics

Allowing Everyone to Send You Messages
Allowing Only Buddies to Send You Messages
Blocking Everyone from Sending You Messages




Blocking Everyone from Sending You Messages

To block everyone from sending you messages, perform the following steps:
1 On the File menu, point to My Options, and then click Edit Preferences.
2 Click the Controls tab.

3 Select Block all users.

4 Click OK to save the setting and close the dialog box.

Related Topics

Allowing Everyone to Send You Messages

Allowing Only Buddies to Send You Messages
Blocking a Specific User from Sending You Messages




Allowing Only Buddies to Send You Messages

To allow only buddies to send you messages, perform the following steps:
On the File menu, point to My Options, and then click Edit Preferences.
Click the Controls tab.

Select Allow only the users below.

Click Add Name.

Type the name of the user you want to add in the Allow List.

Click OK to save the setting and close the dialog box.
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Related Topics

Allowing Everyone to Send You Messages

Blocking a Specific User from Sending You Messages
Blocking Everyone from Sending You Messages




Allowing Everyone to Send You Messages

To allow everyone to send you messages, perform the following steps:

1 On the File menu, point to My Options, and then click Edit Preferences.
2 Click the Controls tab.

3 Select Allow all users to contact me.

4 Click OK to save the setting and close the dialog box.

Related Topics

Allowing Only Buddies to Send You Messages
Blocking a Specific User from Sending You Messages
Blocking Everyone from Sending You Messages




How Warnings Work

No one patrols the Internet to make sure people remain polite or decent. If someone else using the Netscape AOL
Instant Messenger service sends you annoying or offensive messages, you have two ways to respond. You can
issue a warning to the person or you can block the person.

When you issue a warning to another Netscape AOL Instant Messenger user, the recipient’s warning level
increases and that user’s ability to send and receive messages decreases. With enough warnings, the user can
be prevented from exchanging any messages with anyone and may even be signed off. However, warnings are
not permanent; the warning level decreases over time. If a user is warned off the service, the user can return after
a "cooling off" period.

You can see someone’s warning level if you let the cursor hover over the person's screen name in your Buddy List
window.

Alternatively, you can permanently block one or more people from sending you messages. See Blocking Specific
Users from Sending You Messages for more information.

Related Topics

Blocking Everyone from Sending You Messages
Warning a User

Warning FAQ




Warning a User

To warn a user who has sent you an offensive message, click Warn in the Instant Message window in which you
received the message.

Warn imposes a warning on the sender, hampering that person's ability to send and receive messages. With
frequent warnings, the user will not be able to exchange any messages with anyone. Only after a "cooling off"
period can that user send and receive messages again.

You can choose to impose the warning anonymously. Anonymous warnings are less severe and the user you are
warning may not know who issued the warning.
Notes:

8 You can issue only one warning for each message someone sends you.

§ If a user warns you, consider ending the conversation. Every additional message you send enables that user to
warn you again.

Related Topics
Blocking Everyone from Sending You Messages
Warning FAQ







About File Transfers

The Netscape AOL Instant Messenger service File Transfer feature allows you to share files with your online
buddies. Before you begin to transfer files, you should install antivirus software on your computer to protect your
computer against computer viruses that can damage files on your system.

Using the File Transfer feature, you can:

Send files to your online buddies

You can either create a folder that you want to store files that you want to send to others, or use the default
directory to store your files. This ensures that other users do not see any files on your system that you don’t
want them to access.

Get files from your buddies’ computers

If you don’t want to send files to your buddies, you can let them get files that they need directly from your
computer. You don’t have to worry about users seeing other files on your computer that you don’t want them
to access. Your buddies can only access files that are stored in the folder that you specify as a shared
folder.

Control who gets your files by allowing anyone to get your files or only buddies who are listed in your Buddy
List window

Check files for computer viruses

Specify the folder from which others can get your files
Change your default download folder

Track who gets files from your computer

Related Topics
Accepting File Transfers Automatically

Displaying the Receive File Dialog Box




Sending a File to Your Buddy

The Netscape AOL Instant Messenger service lets you send files stored on any medium such as diskette, hard or
zip drive, or network volume to your online buddies.

When you want to send a file, make sure you notify your buddy that you are sending it. Your buddy must be
signed on and cannot be in an idle state. Once you send the file transfer request, your buddy can accept, reject,
or ignore your file transfer request. Your buddy can also impose a warning on you, which can slow the rate at
which you can perform activities in AIM.

WARNING: Your buddy can determine your Internet Protocol (IP) address when you send files. This a potential
security risk, so make sure you know and trust the person to whom you are sending a file.

To send a file to your online buddy, perform the following steps:
1. Select the People menu on the Buddy List window.

2. Click Send File.

3. Enter your buddy’s screen name in the Send File dialog box.

If you don’t know your buddy’s screen name (from either America Online or the Netscape AOL Instant
Messenger service), you can find it by searching for your buddy by e-mail address, by name and address, or
by common interest.

4. Click OK.
5. Click Browse to locate and enter the file that you want to send in the File or Directory to send field.

Note that by default, AIM goes to your filelib folder, which was created for you when you downloaded the AIM
software; however, you can change the default folder to any folder that you want to store files that you want to
send to others.

6. Enter a file description.
This field is optional, but it can provide brief information about the content of the file for your buddy.

7. Click Send.
The File Transfer Status window appears, indicating that AIM is waiting for your buddy to accept the file.
After your buddy accepts your file, the window disappears from your screen.
If you don’t want the File Transfer Status window to appear each time you send a file, you can set your file
transfer preference to stop it from appearing. To cancel the file transfer, click Cancel.

Related Topics
About File Transfers
Changing Your Default Shared Folder




Blocking All Incoming File Transfers
You can block all incoming file transfers if you don’t want to download any files to your system.

If you don’t have antivirus software installed on your system, you should block all incoming file transfers until you
install protection software. You should always make sure you know and trust the person who wants to send files
to you.

To block all incoming file transfers, perform the following steps:
1. Select the File menu on the Buddy List window.
2. Click My Options, and select Edit Preferences.
The Preferences window appears on your screen.
3. Click the File Transfer tab.
Click Block all incoming invitations.
5. Click OK.
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Related Topics

Allowing Everyone to Get Your Files
Allowing Only Your Buddies to Get Your Files
Stopping Others from Getting Your Files

File Transfer Preferences




Checking Files for Viruses

Antivirus software detects and removes viruses in programs and files on disks, in compressed files, and in any file
that you download from the Internet. When you first install AIM, it tries to automatically detect your antivirus
software. If it can't find your protection software, you must install antivirus software on your system and point AIM
to its location.

To let AIM automatically check files that you download, perform the following steps:
1. Select the File menu on the Buddy List window.

2. Click My Options, and select Edit Preferences.

The Preferences window appears on your screen.

Click the Virus Checker tab.

4. Make sure Check files for virus after transfer is selected.

If you want to use a different antivirus program than the one AIM is pointing to, click Browse to locate and
enter the software in the Virus checker executable path field.

5. Click OK.
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Related Topics

About File Transfers

Displaying the Receive File Dialog Box
Virus Checker Preferences




Displaying the Receive File Dialog Box

The Netscape AOL Instant Messenger service can notify and warn you each time someone tries to send you a file.
This warning also lets you know that you should have antivirus software installed on your system before you
receive files from anyone.

To display the Receive File dialog box, perform the following steps:
1. Select the File menu on your Buddy List window.
2. Click My Options, and select Edit Preferences.
The Preferences window appears on your screen.
3. Click the File Transfer tab.
4. Click Always display the Receive File Dialog.
5. Click OK.

If you don’t want the service to notify or warn you each time someone tries to send you a file, you can set your file
transfer preference to accept files automatically .

Related Topic
About File Transfers




Accepting File Transfers Automatically

You can set up the Netscape AOL Instant Messenger service to automatically accept file transfers from everyone
or accept files only from users listed in your Buddy List.

To accept file transfers automatically, perform the following steps:
1. Select the File menu from the Buddy List window.
2. Click My Options, and select Edit Preferences.
The Preferences window appears on your screen.
3. Click the File Transfer tab.

To automatically accept files from only users listed in your Buddy List, click Automatically accept files from
users on my buddy List.

To automatically accept files from anyone who sends you a file, click Automatically accept files from
everyone.

4. Click OK.

Related Topics

About File Transfers

Displaying the Receive File Dialog Box
Checking Files for Viruses

Changing Your Default Download Folder
File Transfer Preferences




Getting Files from Your Buddy's Computer

The Netscape AOL Instant Messenger service allows you and your buddies to share files with each other. If you
don’t want to send files to your buddies, you can let them get files that they need directly from your computer.

You can also get files from their computers. You and your buddies can download any software, text, and graphics
files from each other’s computer that you want others to access.

You don’t have to worry about users seeing other files on your system; they can only access files that are in the
directory that you specify as a shared area. You can also control who can get your files by allowing anyone to get
your files or only buddies that are listed in your Buddy List.

To get a file from your buddy’s computer, perform the following steps:
1. Select the People menu on the Buddy List window.

2. Click Get File.
3. Enter your buddy’s screen name in the Get File dialog box.
4. Click OK.

The system displays a list of all the files that are in your buddy’s shared folder.
5. Select the file that you want to download to your system.

To select multiple files, hold the Ctrl key down as you select the files that you want to download. After
selecting your files, the service runs your antivirus program and downloads the file to your AIM download
folder by default. You can change the default download folder if you want to use a different one for storing
files.

After your antivirus software finishes, exit the program (if it doesn’t close automatically) to return to AIM.

Note: If you want your buddies to get files from your system, you can store files that you want to share with
others in the AIM default folder, filelib, or you can specify a different location to store files you want to share with
others.

Related Topics

About File Transfers

Checking Files for Viruses

Allowing Everyone to Get Your Files
Allowing Only Buddies to Get Your Files
Displaying File Transfer Status
Changing Your Default Download Folder
Stopping Others From Getting Your Files
Tracking Who Gets Your Files

File Transfer Preferences




Stopping Others from Getting Your Files

The Netscape AOL Instant Messenger service enables you to stop unauthorized users from getting files from your
system.

To stop others from getting your files, perform the following steps:
1. Select the File menu from the Buddy List window.
2. Click My Options, and select Edit Preferences.
The Preferences window appears on your screen.
3. Click the File Transfer tab.
Select Allow no users to get my files.
5. Click OK.
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Related Topics

About File Transfers

Allowing Everyone to Get Your Files
Allowing Only Buddies to Get Your Files
Displaying File Transfer Status

Changing Your Default Shared Folder
Getting Files from Your Buddy’s Computer
Tracking Who Gets Your Files

File Transfer Preferences




Allowing Everyone to Get Your Files
By default, no one can get files from your system.

To allow everyone to get your files from your shared folder, perform the following steps:
1. Select the File menu from the Buddy List window.
2. Click My Options, and select Edit Preferences.
The Preferences window appears on your screen.
3. Click the File Transfer tab.
Click Allow everyone to get my files.
5. Click OK.
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Related Topics

About File Transfers

Allowing Only Buddies to Get Your Files
Blocking All Incoming File Transfers
Changing Your Default Shared Folder
Getting Files from Your Buddy’s Computer
Tracking Who Gets Your Files




Allowing Only Buddies to Get Your Files

If you don’t want everyone accessing and getting files from your shared folder, you can set your file transfer
preference to allow only the users who are listed in your Buddy List to get your files.

To allow only the users listed in your Buddy List to get your files, perform the following steps:
1. Select the File menu from the Buddy List window.
2. Click My Options, and select Edit Preferences.
The Preferences window appears on your screen.
3. Click the File Transfer tab.
Click Allow only users on my Buddy List to get my files.
5. Click OK.

&

Related Topics

About File Transfers

Allowing Everyone to Get Your Files
Blocking All Incoming File Transfers
Changing Your Default Shared Folder
Getting Files from Your Buddy’s Computer
Tracking Who Gets Your Files

File Transfer Preferences




Displaying File Transfer Status

The Netscape AOL Instant Messenger service displays the status of each of your file transfers (for example,
sending or getting files). If you don’t want the status dialog box to appear on your screen, perform the following
steps:

1. Select the File menu from the Buddy List window.

2. Click My Options, and select Edit Preferences.
The Preferences window appears on your screen.

3. Click the File Transfer tab.

Click Never display Status dialog.

5. Click OK.
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About File Transfers

Allowing Everyone to Get Your Files
Blocking All Incoming File Transfers
Changing Your Default Shared Folder
Getting Files from Your Buddy’s Computer
Tracking Who Gets Your Files

File Transfer Preferences




Changing Your Default Download Folder

The Netscape AOL Instant Messenger service stores all files that you download from your buddy’s computer in
your AIM download directory by default. You can change the default if you want to use a different folder.

To change your default download folder, perform the following steps:
1. Select the File menu from the Buddy List window.
2. Click My Options, and select Edit Preferences.
The Preferences window appears on your screen.
3. Click the File Transfer tab.

4. Enter the complete path of the folder that you want to use as your default folder in the Directory to put files |
receive field.

5. Click OK.

Related Topics

About File Transfers

Allowing Everyone to Get Your Files
Blocking All Incoming File Transfers
Changing Your Default Shared Folder
Getting Files from Your Buddy’s Computer
Tracking Who Gets Your Files

File Transfer Preferences




Changing Your Default Shared Folder

When your buddies try to get files from your system, the Netscape AOL Instant Messenger service locates your
filelib folder in your AIM directory by default. If you want others to get files stored on your system from a different
folder, you must specify the new location.

To change your default shared folder, perform the following steps:
1. Select the File menu from the Buddy List window.
2. Click My Options, and select Edit Preferences.
The Preferences window appears on your screen.
3. Click the File Transfer tab.

4. Enter the complete path of the folder that you want to use as your default shared folder in the Directory from
where others can get my files or | send files field.

5. Click OK.

Related Topics

About File Transfers

Allowing Everyone to Get Your Files
Allowing Only Buddies to Get Your Files
Blocking All Incoming File Transfers
Getting Files from Your Buddy’s Computer
Changing Your Default Download Folder
Stopping Others from Getting Your Files
Tracking Who Gets Your Files
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Tracking Who Gets Your Files

You can keep a record of everyone who gets files from your system. Each time someone downloads a file from
your system, AIM records the file name (along with the date and time the file was downloaded) and user’s name in
the logdfile.txt file. The logfile.txt file is stored in your \windows\aim95\username directory.

To track who gets your files, perform the following steps:
1. Select the File menu from the Buddy List window.
2. Click My Options, and select Edit Preferences.
The Preferences window appears on your screen.
3. Click the File Transfer tab.
Click Keep a record in logfile.txt of who has gotten files.
5. Click OK.
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Allowing Only Buddies to Get Your Files
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Changing Your Password

You can change your password whenever you are signed on to the Netscape AOL Instant Messenger service. You
can make any change you want to your password as long as your password contains between 4 and 16
characters.

To change your password, perform the following steps:
1 On the File menu, point to My Options, and then click Change Password.
The Change Password window appears.

2 Type your current password in the appropriate field and then type and re-type a new password in the
appropriate fields.

3 Click OK.

Note: Anyone who knows your password has access to your account. Therefore, you should never reveal your
password to anyone online. No one from America Online will ever ask you for your password while you are online.



Formatting Your Screen Name

If you are dissatisfied with the capitalization and spacing in your screen name, you can change (or format) it while
you are signed on. Any other changes constitute a new screen name, and you must register it at the Netscape
AOL Instant Messenger web site.

To format your screen name, perform the following steps:
1. On the File menu, point to My Options, and then click Format Screen Name.
2. Change your screen name in the appropriate field.

The only changes you can make to your screen name are the addition or deletion of spaces or the
capitalization of letters. For example, if your screen name is johndoe, you can change it to Johndoe or John
Doe. You cannot change it to Jane Doe.

3. Click OK.

Related Topics

Choosing a Screen Name

Removing a Screen Name

Working with Multiple Screen Names




Updating Your E-mail Address

One way that others can find you and add you to their Buddy List window is through your e-mail address. If your e-
mail address changes (for example, if you change jobs or switch from one Internet Service Provider to another),
you should update your e-mail address to allow others to find you by your screen name.

To update your e-mail address, perform the following steps:

1 On the File menu, point to My Options, and then click Update E-mail Address.
2 Enter your new e-mail address in the dialog box.

3 Click OK.



Changing Sounds that Play When You Send or Receive Messages

To change sounds that play when you send or receive messages, perform the following steps:
1 On the File menu, point to My Options, and then click Edit Preferences.
2 Click the Sounds tab.
3 Select an option in the IM Sounds group.
4 Click Browse for the option you selected.
The Browse for Sound dialog opens.
5 Select the sound you want to use and click Open.
6 Click OK to save the setting and close the dialog box.

Tips:
8 To test a sound, click Preview.
§ To turn a sound off, deselect the check box for that sound.

Related Topics
Changing Sounds that Play When Buddies Sign On or Off
Sound FAQ




Changing Sounds that Play when Buddies Sign On and Off

To change sounds that play when your buddies sign on or off, perform the following steps:
1 On the File menu, point to My Options, and then click Edit Preferences.
2 Click the Sounds tab.
3 Select an option in the Buddy Sounds group.
4 Click Browse for the option you selected.
The Browse for Sound dialog opens.
5 Click the sound you want to use and click Open.
6 Click OK to save the setting and close the dialog box.

Tips:
8 To test a sound, click Preview.
§ To turn a sound off, deselect the check box for that sound.

Related Topics
Changing Sounds that Play When You Send or Receive Messages
Sound FAQ




Setting Visual Alerts in Your Buddy List Window

You can set visual alerts to let you know when your buddies sign on or off or when they become idle.

To set visual alerts, perform the following steps:
1 On the File menu, point to My Options, and then click Edit Preferences.
2 Click the Buddy tab.

3 To make your Buddy List window blink for five seconds each time a buddy signs on or off, select the Flash
Buddy List window when buddies sign on or off option.

4 To dim the display of buddies who are idle, select the Dim buddies after they have been idle for __ minutes
option and enter the number of minutes buddies must be idle. The default is 20 minutes.

5 Click OK to save the changes.



Changing the Font in Your Buddy List Window

You can change the default font used to display groups and buddies in your Buddy List window.

To change fonts, perform the following steps:
1 On the File menu, point to My Options, and then click Edit Preferences.
2 Click the Buddy tab.

3 Select the font name and font size you want to use to display your groups and buddies in your Buddy List
window.

4 Click OK to save the setting and close the dialog box.



Displaying or Hiding Information About Yourself

You can determine whether or not other users can see how long you have had a Netscape AOL Instant Messenger
service account or how long you have been idle. Other users can see this information by holding their cursor over
your screen name in their Buddy List windows. You can also determine whether or not other users who know your
e-mail address can use the Find a Buddy feature to learn your screen name or whether you have an account.

To display or hide information about yourself, perform the following steps:
1 On the File menu, point to My Options, and then click Edit Preferences.
2 Click the Controls tab.

3 Select the options you prefer in the Allow other users to see and the Allow users who know my e-mail
address to find groups.

4 Click OK to save the settings and close the dialog box.



Changing Key Bindings for Messages

You can change the behavior of the Enter and Tab keys in the Instant Message window.

To change key bindings for messages, perform the following steps:
1 On the File menu, point to My Options, and then click Edit Preferences.
2 Click the General tab.

If you want the Enter key to insert a line break, select the Enter key inserts Return option. (Deselect this option
if you want the Enter key to send your message.)

If you want the Tab key to insert a tab, select the Tab key inserts Tab option. (Deselect this option if you want
the Tab key to toggle among fields in the Instant Message window.)

3 Click OK to save the setting and close the dialog box.



Turning Emoticons On or Off

You can control whether emoticons (or graphical smileys) appear in your Chat and Instant Message windows.

To turn emoticons on or off, perform the following steps:
1 On the File menu, point to My Options, and then click Edit Preferences.
2 Click the General tab.

If you do not want to see the emoticons in your Chat and Instant Message windows, select the Disable option.
The emoticon submenu is also removed from the Insert menu (accessed by clicking the right mouse button in a
message).
If you want to see the emoticons in your Chat and Instant Message windows, deselect the Disable option.

3 Click OK to save the setting and close the dialog box.



Changing the Default Appearance of Messages

You can customize the appearance of messages you compose by changing the default font, text color, or
window color.

To change the default font used for messages:

1 On the File menu, point to My Options, and then click Edit Preferences.
2 Click the General tab.

3 Click Font.

4 Select the font settings you want to use and click OK.

The Font and Size settings affect only the display of messages on your screen. They do not change the font
or size of messages you send.

5 Click OK to save the settings and close the dialog box.

To change the default window color used for messages:

1 On the File menu, point to My Options, and then click Edit Preferences.
2 Click the General tab.

3 Click Window Color.

4 Select the color you want to use and click OK.

5 Click OK to save the settings and close the dialog box.

Note: If you want to change the size of text you send, use the toolbar to increase or decrease it.



Viewing the Time Stamp in Messages

You can have the time included on all of your instant and chat messages.

To view time stamp messages, perform the following steps:

1 On the File menu, point to My Options, and then click Edit Preferences.
2 Click the General tab.

3 Select the Always view time stamp option.

4 Click OK to save this setting and close the dialog box.

Note: You can choose Time Stamp from the View menu of any Chat or Instant Message window to toggle the
time stamp on or off.



Why Load and Save Settings?

Loading and saving your Netscape AOL Instant Messenger settings allows you to:

§ Save your settings so you can quickly set up your account and list of online buddies on another computer. For
example, you can copy your settings from a desktop computer to a notebook computer.

§ Share your settings with others. For example, you can copy the settings you use to connect to the Netscape
AOL Instant Messenger server through a firewall and e-mail the file to your coworkers.

Notes:

8 Not all versions of Netscape AOL Instant Messenger can load and save settings.
§ You cannot load or save settings from an America Online account.



Saving Settings

You can save your Buddy List, current preferences, and other configuration settings to import them to another
computer where you are going to install the Netscape AOL Instant Messenger software.

To save your settings, perform the following steps:

1 On the File menu click Save Buddy List.

2 Select the type of settings you want to save and click Save.
3 Enter a name for the file you want to save and click Save.



Loading Settings

To load your settings, perform the following steps:

1 On the File menu click Load Buddy List.

2 Select the file containing the settings you want to load (or import) and click Open.
3 Select the type of settings you want to load.

If you are loading Buddy List Preferences, you can choose whether or not to add the groups to your existing list
(Merge with my existing Buddy List). If you choose not to merge the settings, your existing list of online buddies
will be replaced by the ones you are loading.

4 Click Load.



Settings You Can Load and Save

There are six types of settings you can save and load to your copy of the Netscape AOL Instant Messenger
software:

Connection Preferences
This setting corresponds to the settings on the Connection tab of the Preferences dialog: host server, port, and
proxy information. In addition, this setting stores the setting of the Auto-login checkbox on the Sign On screen.

Personal Profile
This setting corresponds to the information you enter on the My Info tab of the Preferences dialog box.

Controls Preferences

This setting corresponds to the information on the Controls tab of the Preferences dialog box: your privacy
setting, your allow list, your block list, and the settings that allow others to see your idle time or how long you
have been a member.

Sound Preferences
This setting corresponds to the settings on the Sounds tab of the Preferences dialog box. The on or off value of
each option on the tab is imported or exported, but neither the sound files nor the pointers to them are saved.

Text Composition and Viewing Settings
This setting corresponds to the default text properties of your Instant and Chat Message windows as you
defined them on the General tab of the Preferences dialog.

Buddy List

This setting corresponds to the buddies and groups in your Buddy List window. You can choose to export any or
all of the groups. When you import buddy list preferences, you can choose to replace your groups with the ones
you are importing or merge them into your existing groups. If you merge a group that has the same name as an
existing group in your Buddy List window, the imported buddies are added to the existing group.



Sounds Preferences

The Sounds Preferences dialog box allows you to set which sounds, if any, play when your buddies sign on or off
and when you send or receive messages.

Play a sound when buddies sign on
Select this option to play a sound whenever one of your buddies signs on.

Play a sound when buddies sign off
Select this option to play a sound whenever one of your buddies signs off.

Play a sound when first message is received
Select this option to play a sound the first time you receive a message from a particular buddy, but not on
subsequent messages from that buddy.

Play a sound when receiving a message
Select this option to play a sound every time you receive a message.

Play a sound when sending a message
Select this option to play a sound every time you send a message.
Tip
Netscape AOL Instant Messenger software includes a directory of default sound files. This SOUNDS directory is
located in the same directory in which you installed the Netscape AOL Instant Messenger software.



General Preferences

Save password
If you select this option, Netscape AOL Instant Messenger saves your password, so you won’t have to type it for
subsequent logins.

Automatically sign on when AIM starts
If you select this option, you are signed on automatically whenever you launch the Netscape AOL Instant
Messenger service. This option is active only if you select the Save password option on the Sign On screen.

Start AIM when Windows starts
If you select this option, Netscape AOL Instant Messenger starts automatically when Windows starts.

Internet Connection: Modem
If you select this option, Netscape AOL Instant Messenger uses your modem. This option is active only if you
select the Start AIM when Windows starts option.

Internet Connection: Local area network
If you select this option, Netscape AOL Instant Messenger uses your local area network. This option is active
only if you select the Start AIM when Windows starts option.

Enter key inserts Return
Select this option if you want the Enter key to insert a line break. Deselect this option if you want the Enter key
to send your message.

Tab key inserts Tab
Select this option if you want the Tab key to insert a tab. Deselect this option if you want the Tab key to toggle
between fields in the Instant Message window.

Always view time stamp
Select this option if you want the messages you send and receive to be marked with the time they are sent.

When you are finished entering and formatting your information, click OK to apply your changes and close the
dialog box.

Disable graphical smileys

Select this option if you do not want emoticons (or graphical smileys) to appear in your Instant Message window.
The emoticon submenu is also removed from the Insert menu (accessed by clicking the right mouse button in a
message).

Show 'Accept Message' dialog for messages from users not in Buddy List

Select this option if you want to choose whether to accept a message from someone not on your Buddy List.
Whenever such a person attempts to start a conversation by sending you a message, a dialog appears asking if
you want to accept the message.

If you deselect this option, messages from everyone appear as soon as you receive them.

Font
Click this button to select a font style and size for the Instant Message window.

Window Color
Click this button to select a background color for the Instant Message window.

Text Magnification: 200%

If you select this option, Netscape AOL Instant Messenger displays the text in your Instant Message window
magnified by 200 percent. Although the text is magnified in your Instant Message window, it is displayed
normally, using the font selections you made, to the buddy who receives your message.

Text Magnification: 133%

If you select this option, Netscape AOL Instant Messenger displays the text in your Instant Message window
magnified by 133 percent. Although the text is magnified in your Instant Message window, it is displayed
normally, using the font selections you made, to the buddy who receives your message.

Text Magnification: 100%

If you select this option, Netscape AOL Instant Messenger displays the text in your Instant Message window
magnified by 100 percent. Although the text is magnified in your Instant Message window, it is displayed
normally, using the font selections you made, to the buddy who receives your message. 100 percent is the
actual size of the text.

Text Magnification: 75%



If you select this option, Netscape AOL Instant Messenger displays the text in your Instant Message window
magnified by 75 percent. Although the text is magnified in your Instant Message window, it is displayed normally,
using the font selections you made, to the buddy who receives your message.



Connection Preferences

If you access the Internet through an Internet Service Provider, you most likely will not need to make any changes
to the Server or proxy sections of the Connection Preferences tab. However, if you access the Internet through a
Local Area Network firewall (for example, at your workplace), then your network administrator may need to
configure the proxy section of the Connection Preferences tab.

Server Host

This field contains the default Internet address of the Netscape AOL Instant Messenger server. Under normal
circumstances, you do not need to change this field. If you should change it accidentally, click Reset to restore
the default address.

Server Port

This field contains the default server port number to be used on the Netscape AOL Instant Messenger server.
Under normal circumstances, you do not need to change this field. If you should change it accidentally, click
Reset to restore the default port number.

Auto Configure

If you click this button, the Netscape AOL Instant Messenger software attempts to configure itself to work in your
computer's network environment. Try Auto Configure if you are having difficulty connecting with the Netscape
AOL Instant Messenger service.

Reset
If you click this button, the Netscape AOL Instant Messenger software restores the default Server Host and Port
values.

Connect using proxy
If you click this button, the Netscape AOL Instant Messenger software activates the proxy server controls.

Proxy Server Host
Supply the name of the proxy server.

Proxy Server Port
Supply the port number to be used on the proxy server.

Protocol
Specify whether your proxy server uses the SOCKS 4, SOCKS 5, or HTTPS protocol.

Authentication Username
Supply the authentication username required by the proxy.

Authentication Password
Supply the authentication password required by the proxy.

Use proxy to resolve hostnames
Select this option if you want the proxy to act as a name server for hosts that are behind the firewall.

Keep connection alive

Select this option if you want Netscape AOL Instant Messenger to preserve your Internet connection during idle
periods. (Some Internet Service Providers automatically disconnect users who have been inactive for a given
period.)



Controls Preferences

Allow all users to contact me
Select this option to allow all users to see you in their Buddy List windows and send you messages.

Allow only users on my Buddy List
Select this option to allow only users on your Buddy List to see you in their Buddy List windows and send you
messages.

Allow only the users below
Select this option to allow only users you specify to see you in their Buddy List windows and send you
messages.

Block all users
Select this option to prevent all users from seeing you in their Buddy List windows and sending you messages.

Block the users below
Select this option to prevent the users you specify from seeing you in their Buddy List windows and from
sending you messages.

Allow List
This list box is active when you select Allow only the users below. To add a Screen Name, click Add Name, type
the Screen Name, and press Enter. To delete a Screen Name, select the Screen Name and click Remove.

Block List
This list box is active when you select Block the users below. To add a Screen Name, click Add Name, type the
Screen Name, and press Enter. To delete a Screen Name, select the Screen Name and click Remove.

Allow users to see how long I've been idle
Select this option to enable other users to see whether you are idle when they hold the cursor over your screen
name in their Buddy List window.

Allow users to see how long I've had an account
Select this option to enable other users to see how long you have had a Netscape AOL Instant Messenger
service account when they hold the cursor over your screen name in their Buddy List window.

Allow users who know my e-mail address to find my screen name
Select this option to allow users who know your e-mail address to obtain your screen name through the Find a
Buddy feature.

Allow users who know my e-mail address to find only that | have an account
Select this option to allow users who know your e-mail address to learn only that you have an account (but not
to learn your screen name) through the Find a Buddy feature.

Allow users who know my e-mail address to find nothing about me
Select this option to allow users who know your e-mail address to learn nothing about you through the Find a
Buddy feature.



Buddy Preferences

The Buddy tab of the Preferences dialog box allows you to control the appearance of your list of online buddies.

Font
From the dropdown menu, select a font for the Buddy List window.

Size
From the dropdown menu, select a size for the font in the Buddy List window.

Dim buddies after they have been idle for __ minutes

Dims your buddies’ screen names after they have been idle for the specified number of minutes. You must
specify at least 10 minutes because the AOL Instant Messenger service (SM) may not be able to report your
buddies’ idle state until after 10 minutes.

Flash Buddy List window when buddies sign on or off
Flashes the Buddy List window for five seconds when buddies sign on or off.



Away Preferences

The Away Preferences dialog box allows you to define messages that appear to others while you are away from
your computer or while your computer is idle.

Auto respond with message (when idle)
If you select this option and enter a message, this message is automatically sent to those who send you a
message when your computer is idle for more than ten minutes.

Auto respond and insert in personal profile (when away)

If you select this option and activate your Away message, this message is automatically sent to those who send
you a message. Your Away message also appears in the Personal Profile section of the Buddy Info window
when someone requests information about you.

Insert in personal profile only (when away)
If you select this option and activate your Away message, the message appears only in the Personal Profile
section of the Buddy Info window when someone requests information about you.

Away messages

Click Add Message and type a label and a new Away message in the text fields. After you have entered a new
message, click Save.



Buddy Chat Preferences

The Buddy Chat tab of the Preferences dialog box allows you to set controls for your chat room and sounds.
You can also control whether or not you receive chat invitations.

Set your chat preferences with these options:

e Chat Room Window
Select the Flash window when message is received option if you want the chat window to flash when
someone sends you a chat message while you are working in another window.
If you want the service to display an announcement when users enter and leave a chat room, select the Show
announcements when users enter and leave room option.

e Sounds
The Sounds Preferences dialog allows you to indicate which sound (if any) plays when your buddies receive
your messages and when you send messages:

Play a sound when messages are received
Select this option to play a sound when chat participants receive your message.

Play a sound when sending a message
Select this option to play a sound each time you send a chat message.

e Block all incoming chat invitations
Select this option if you don’t want to receive any chat invitations.

Tip: Netscape AOL Instant Messenger software includes a directory of default sound files. This SOUNDS
directory is located in the same directory in which you installed the Netscape AOL Instant Messenger software.



File Transfer Preferences

The File Transfer tab allows you to set your preferences to receive files and control who can get them. You can
set options to control operations such as blocking all incoming invitations and receiving files from buddies
automatically.

WARNING: Make sure you have installed antivirus software on your system before you receive files from
anyone. Files that you download from the Internet could contain viruses that can damage files on your system or
cause it to crash.

You can control your file transfer operations with the following options:

Block all incoming invitations
Set this option if you do not want to receive any file transfer invitations.
Always display the Receive File Dialog

Set this option if you want to confirm all file transfers before you download any files to your system. The
dialog box shows who is sending you a file, the name of the file, and a description of the file.

If you don’t want the warning to display in future file transfers, click the Don’t ask me again option in the
Receive From warning window.

Automatically accept files from users on my Buddy List

Set this option if you want to receive files automatically from buddies listed in your Buddy List window. When
you select this option, you are not warned about who is sending you files or warned about having antivirus
software installed on your system.

Automatically accept files from everyone

Set this option if you want to automatically accept files from anyone without being warned of who is sending
you the file.

You can set preferences with the following options to control what happens when users try to get files from your
system:

Allow no users to get my files

Set this option to stop anyone from getting your files.

Allow only users on my Buddy List to get my files

Set this option to allow only users who are on your Buddy List to get your files.

Allow everyone to get my files

Set this option if you want everyone to get your files.

Never display status dialog

Set this option if you don’t want a dialog box to appear that shows your file transfer status.
Keep a record in logfile.txt of who has gotten files

Set this option if you want to know who has downloaded files from your system. The lodfile.txt file is stored
in your \windows\aim95\username directory.



Virus Checker Preferences

The Virus Checker tab allows you to set preferences to receive files in your system and to indicate the antivirus
software that you want to use for files that you send or receive.

You can set these options:
e View Antivirus Warning dialog box

Set this option to let AIM remind you to check all files that you download from your buddies’ systems.
e Check files for virus after transfer

Set this option to allow the service to check all files automatically that you download from the Internet. Even
if you know the person who is sending you files, you should check files with your antivirus software.

The Virus checker executable path indicates to the service what antivirus software to use when it downloads
files or receives them from your buddies.



Buddy Icon Preferences

The Buddy Icon tab allows you to set preferences for whether or not you want to receive buddy icons (images
such as cartoon characters, symbols, small drawings, and other graphical images) from your buddies. AIM
displays icons in the lower-left corner of your Instant Message window while you are having a conversation with
your buddy if you accept a buddy icon from a buddy. (For more information about buddy icons, see About Buddy
Icons.)

You can set these options to control the Buddy Icon feature:
e Never display Buddy Icons

Set this option if you do not want to receive icons from your buddies. When you set this option, you also
won’t be able to see any buddy icons that you have chosen for other buddies.

¢ Never accept Buddy Icons

Set this option to prevent others from sending you their buddy icons. However, when you set this option, you
are still able to see buddy icons that you have chosen for your other buddies

e Accept from users on Buddy List
Set this option if you want to accept buddy icons from only buddies on your Buddy List.
¢ Display Buddy Icon Knock-Knock dialog

Set this option if you want to be alerted when a buddy wants to send you a buddy icon. When enabled, AIM
displays a dialog box when another user sends you a buddy icon. You can either accept or reject the buddy
icon. When you disable this option, you automatically receive buddy icons from users without any warning.

Note: Setting the Never display buddy icons or Never accept buddy icons option overrides this option
setting because you won’t be receiving any buddy icons.



News Ticker Preferences

The Ticker tab allows you to set your News Ticker preferences to change the way you display news. You can set
these options:

Categories

Allows you to select the news that you want AIM to display in the News Ticker window. By default, AIM
displays top news in these categories: Top News, Business, Entertainment, and Sports. Deselect any news
category you do not want AIM to display in your News Ticker window.

Display Ticker at Sign on

Allows you to control whether or not AIM automatically displays the News Ticker after you sign on. Deselect
this option if you do not want AIM to display the ticker.

Display Headlines in bold

Allows you to control whether AIM displays the News Ticker headlines in plain text or bold. By default the
news headlines are set to display in bold text. If you want your news headlines in plain text, deselect this
option.

Refresh every
Allows you to control how often AIM refreshes the News Ticker window. The default setting is 30 minutes.
Display speed

Allows you to control the rate at which the news headlines scroll across the News Ticker window. You can
select Slow, Medium, or Fast.



If You Can't Sign On

Check for one of the following instances:
§ Is the password you entered valid? If not, check your case-sensitive password and try again.

§ Did your request to sign on get denied? If so, you have signed on too many times in a short period. Wait a few
minutes and try again. Additional attempts to sign on now will extend the period you need to wait.

§ Are you currently connected to the Internet? If not, and you have been able to connect before, check the
following:

@ Is your Internet Service Provider (ISP) connection operating properly? If not, contact the company supplying
your connection and be prepared to change your connection configuration.

@ Is your LAN connection operating properly? If not, contact your LAN network administrator and be prepared
to change your connection configuration.

You might not be able to sign on if:

§  Your Internet connection is only 16-bit. AIM needs a 32-bit connection. Contact your ISP if you are not sure.

8§ There is a DNS problem with your ISP or network. Contact your ISP or system administrator, or try again
later.

8  Your network is using a firewall. If this is the case, contact your system administrator for information about
setting up a proxy server. After you obtain this information, you must enter it in your Connection preferences.

§ The AIM service is temporarily unavailable. Try to sign on again later.

If none of the above conditions is true, there is either a temporary problem somewhere in the network that is
preventing the connection from completing or the Netscape AOL Instant Messenger server is down. In either case,
you simply need to wait and try again later.

Related Topics

Connecting Through a Local Area Network
Connecting Through a Modem

Connection Preferences




To Change Your Connection Configuration

1 Click Setup on the Sign On screen.

2 On the Connection tab, enter the settings supplied by either the company supplying your ISP connection or your
LAN network administrator.

3 Click OK to save the settings and close the dialog.



If You Can't See Anyone in Your Buddy List Window

§

i
=
§

Have you added any buddies to your Buddy List? If not, click the List Setup tab in the Buddy List window and
click the Add Buddy icon:

Are you viewing the Online tab in the Buddy List window? If not, click the Online tab in the Buddy List window
to display your online buddies.

Are any of your buddies signed on? If not, they won't appear in your Buddy List. On the People menu, click
Sign On A Friend to invite a friend to register with the Netscape AOL Instant Messenger service.

Is the Block all users option selected? If so, this prevents anyone from seeing you and also prevents you
from seeing anyone in your Buddy List window. To deselect the Block all users option, on the File menu,
point to My Options, and then click Edit Preferences. Click the Controls tab and deselect the option.

Are all of your buddies blocking you? If so, on the People menu, click Sign On A Friend to invite another
friend to register with the Netscape AOL Instant Messenger service.

Related Topics
Allowing Everyone to Send You Messages

Allowing Only Buddies to Send You Messages

Blocking a Specific User from Sending You Messages

Blocking Everyone from Sending You Messages




If You Can't Send Instant Messages

§ Is your buddy blocking your instant message? If so, on the People menu, click Sign On A Friend to invite
another friend to register with the Netscape AOL Instant Messenger service.

§ Is your buddy signed on? If not, you need to wait and try again later when your buddy is signed on.
8 Did you exceed the rate limit for sending instant messages? If so, wait until the power bar under Send turns
yellow or green.



Rate Limit Definition

The rate limit is a technical constraint the Netscape AOL Instant Messenger service uses to encourage users to
use the service in a reasonable manner. As your rate limit decreases, the rate at which you can send messages
decreases. If the rate is low enough, you are unable to send any instant messages. Your current rate limit is
displayed in the power bar under Send.

Two factors determine your rate limit:

§ The rate at which you send instant messages

8  Your warning level

If you try to send a lot of messages quickly, you decrease your rate limit. Each time you receive a warning, your
warning level increases and your rate limit decreases.

You cannot reset your warning level or your rate limit. Gradually your warning level is reduced and your rate limit
increases as it returns to a normal state.



If Your Web Browser Doesn't Open Properly

If your web browser doesn’t open, check to make sure you did not remove your default web browser accidentally.
If you did, you need to either register an existing browser as the default web browser with your operating system's
Registry, or you need to install a new web browser.



If Your E-mail Program Doesn't Open Properly

If your e-mail program doesn’t open, check to make sure you did not remove your default e-mail program
accidentally. If you did, you need to either register an existing e-mail program as the default e-mail program with
your operating system's Registry or you need to install a new e-mail program.



If You Want to Disable Automatic Launch

1 On the File menu, point to My Options, and then click Edit Preferences.
2 Click the General tab.

3 Deselect the Start AIM when Windows starts option.

4 Click OK to save this setting and close the dialog box.



If You Want to Disable Automatic Sign On

1 On the File menu, point to My Options, and then click Edit Preferences.
2 Click the General tab.

3 Deselect the Automatically sign on when AIM starts option.

4 Click OK to save this setting and close the dialog box.



Firewall

A firewall is a computer system that is placed between networks to restrict traffic to and from an organization for
security reasons.



Registrations

How do | confirm my registration after I’ve registered?

After you register, AIM sends you e-mail, allowing you to confirm your registration request. You must respond to
this e-mail within 48 hours to complete your registration

The confirmation e-mail provides instructions on how to respond.

What if | accidentally typed the wrong e-mail address during registration?

You can easily update your e-mail address while signed on to AIM by performing the following steps:
1. On the File menu, select My Options.

2. Click Update E-mail Address.

3. Enter your correct e-mail address in the New e-mail address field.

4. Click OK.

Why am | having problems registering?
Check for one of the following instances:
e Have you typed your e-mail address correctly in the proper format (for example, joeuser@domain.com)?

e If you are an America Online member, be sure that you entered the zip code listed in your America Online
account information.

¢ Did you choose a password and enter it twice correctly?
e Did you choose a screen name that isn’t already in use?

Should the e-mail address that | specify during registration be valid?

Yes, you should always use a valid e-mail address when you register your AIM screen name. AIM uses the e-mail
address that you supply during registration to mail your password to you in the event that you forget your
password.



Screen Name

What can | do if the screen name | want is already taken?

If the screen name you want is already taken, try variations of that name, or select another. You can use up to 10
letters, numbers, and spaces for your screen name. For example, if the screen name you want is "Hearty", try
using "Heart101" or "NYC Heart”.

Can | change my screen name?

No, you cannot change your screen name to a new one; however, you can change the capitalization and spacing
of your screen name by performing the following steps:

1. On the File menu, click My Options, and select Format Screen Name.
2. Format the screen name.
3. Click OK.

Can | delete one of my old AIM screen names?

No, you cannot delete old AIM screen names. However, you can prevent other users from finding one of your
Screen Names by performing the following steps:

1. On the File menu, click My Options, and then click Edit Preferences.
A window appears.

2. Click the Controls tab.

3. Click Nothing about me.

How do | delete screen names from the Sign On screen?
Select the screen name on the Sign On screen, and press the Delete key.

How do | delete screen names from the list in the Instant Message window or from the Info window?

Highlight the screen name, and press the Delete key. If the screen name is still not deleted, upgrade to the latest
version of AIM.

Do my screen names and Buddy List transfer to a new copy of AIM that | install on the same computer?

Yes, the latest version of AIM copies your Buddy List, screen names, and preferences to any other copies of AIM
that you install on the same computer.



Signing On

When | sign on to AIM, why do | have to choose between my profile on the host and my profile on my PC?
This choice has one of two causes:
e The host has misplaced your profile, and it needs an updated copy from your computer.

e If you've signed on to AIM from a different computer, the host notices a difference between the profile on the
new computer and the profile that was sent to the host from the other computer. The host is confirming
which profile you would like to use.

Why am | unable to sign on with all of my registered AIM screen names? With the same copy of AIM, |
can sign on with only one of my two screen names.

Wait about an hour, and try signing on again with the screen name that is experiencing the problem.

Why do | get the message, "No Internet connection detected” when I try to sign on to AIM using my AOL
connection?

This problem occurs if you are using the 16-bit version of AOL, which is intended for use in Windows 3.1. All
recent versions of AIM are 32-bit applications. In order to use a 32-bit Internet application such as AIM, you must
have a 32-bit Internet connection as well.

To obtain the 32-bit version of AOL, sign on to AOL and go to Keyword: UPGRADE. It is a free download (not
including any telephone company charges). To find out whether you have the 16-bit or 32-bit version of AOL,
select About America Online from the Help menu. On the screen that appears, you see either "for Windows" or
"for Windows 95/98." If it has just "for Windows," then you have the 16-bit version of AOL.

The problem also occurs if your AOL screen name is designated as a Child, Young Teen, or Mature Teen. With
these types of AOL screen names, you are not able to use any Internet software through your AOL connection.

To change the status of an AOL screen name, you must sign on with the master screen name, and go to Keyword:
ParentalControls.



Passwords

Can | change my password once I'm signed on to AIM?

Yes, you can change your password while you are signed on to AIM. To change your password once after you
have signed on, perform the following steps:

1. Select the File menu.
2. Click My Options, and select Change Password.
3. Change your password to one that you want.

Why doesn't my password work any more?

Unlike AOL, your AIM password is case-sensitive. That means that correct capitalization is necessary. Make
sure that the Caps Lock key is not on.

Also, if you share a screen name on both AIM and AOL, changing the password on AOL does not change it on
AlM, and vice-versa.

You can have your password sent to your e-mail address by submitting your screen name at the following Web
page:

http://www.aol.com/aim/password.adp?

What should I do if | forget my password?

When you enter an incorrect password to sign on, AIM displays an error message, asking you if you forgot your
password. In the error message window, click Forgot Password. After your browser opens to the Web site,
enter your screen name, and click Submit.

Your password is sent to you through e-mail. However, if the e-mail address you provided during registration is
invalid, the service cannot send you your password. In this case, you must register another screen name by
choosing <New User> on the Sign On screen, and clicking Sign On.



Service Connections

What should | do when | lose my connection to the server and AIM displays the message, “Internet
Connection Lost — check connection?”

This is probably just a temporary communication problem between your modem and your Internet Service Provider
(ISP). Your ISP is able to keep its connection, but AIM gets disconnected. (In many cases, you won’t see

noticeable symptoms in your other Internet applications, such as your web browser, but AIM requires a constant
uninterrupted connection.)

You should sign on to AIM again. If you are frequently disconnected, it may help to change the access number you
use to connect to your ISP.

Why am | unable to connect to AIM through my company LAN? In the past, | made the connection with
no problem.

Your system administrator must update login.oscar.aol.com on the LAN DNS table.



Buddy Lists

Why can't | see my buddies in my Buddy List, even though they are online?
You might not be able to see buddies in your Buddy List for several reasons:

Make sure that the "Online" tab in the Buddy List window is the active tab.

e [f the number in parentheses next to a group indicates that there are buddies online, make sure that the group
is expanded. For example, if it says "Friends (5/10)" but no names are listed, then the group is not
expanded. To expand the group, click the arrow on the left of the group name so that the arrow points
downward.

e Make sure that your buddies are not blocking you and that you are not blocking your buddies. If you block
buddies or they block you, you cannot see them.

e If the buddies you can't see are using AOL, then they have enabled an option that allows you to send them
instant messages but doesn't let you see them on your Buddy List. This feature is only available to AOL
users. Ask the AOL users to go the Privacy Preferences in their AOL Buddy List, and choose one of the
Allow or Block options that does not cause you to be blocked.

How do | transfer my Buddy List from one computer to another?

To transfer your Buddy List from one computer to another, perform the following steps:
1. Select the File menu from the Buddy List window.

2. Click Save Buddy List.

3. Save your Buddy List to a file, and transfer it to your other computer by using a disk or by attaching it to an e-
mail.

To load the Buddy List file to your other computer, click the File menu, and select Load Buddy List.

Why don't other users see me as being idle when | am signed on to AIM but not performing any AIM
activities?

If you are using any application in your computer (or just pressing a key or moving your mouse slightly), AIM does
not consider you to be idle. For example, if you are using a word-processing application while you are signed on,
AIM does not consider you to be idle.

Why does AIM ignore my option setting to dim buddies in my Buddy List after they've been idle for 5
minutes? Instead, AIM doesn't dim my buddies' screen names until they've been idle for at least 10
minutes.

Your buddy's Buddy List program might not be notifying the server that your buddy is idle until after 10 minutes.
Each client may be different.

What should | do when AIM incorrectly reports how long my buddies have been signed on?

Open your Control Panel and double-click the Date/Time icon. Check to make sure that the correct time zone,
date, and time are set and that the Daylight Savings Time setting is correct.



Instant and Chat Messages

Why can't | send an instant message to one of my friends? AIM displays a message indicating that my
friend is using unsupported software.

The person is probably using an old version of the Macintosh AOL software. AOL's Macintosh users must use AOL
3.0 to send instant messages to AIM users. Ask the AOL user to upgrade to the latest version of AOL at Keyword:
UPGRADE. The upgrade is free to the AOL user (not including any telephone company charges).

Why can't | send an instant message to someone I've blocked in my Buddy List?
That is an intentional feature of the AIM software.

What can | do about someone | don't know who keeps sending me messages?

If you don't want to receive messages from the user, you can:
e Add the user to your Block List under the Controls Preference.

e Warn the user by clicking Warn on the Instant Message window or Chat Invitation window from the user.

Why does AIM display the message, “Sorry, chat is not available at this time,” when | try to enter a chat
room?

Occasionally, our host system has a problem initializing chat rooms. Try entering a chat room again in hour or so.



Warnings

When | mistakenly warn a buddy, can | undo the warning?

You can't undo a warning, but a user's warning level is not permanent and is eventually reset to zero. Warnings
are also not kept on any kind of permanent record.

What can | do when | find that I'm always being warned by a particular user?
Don't send any messages to that user. You can only be warned by someone if you send that user a message.

Why is a user able to warn me after I've sent the user an instant message, even though I've blocked the
user?

If you send an instant message to another user and then blocked that user, the user can still warn you one or more
times for messages that you've already sent. (Blocking the other user prevents both of you from seeing each
other in your Buddy Lists, and it also prevents both of you from sending each other any more messages.)

Why does my buddy's warning level appear differently in the Instant Message window than in the Buddy
List window?

Warning levels shown in the Buddy List window are updated frequently, but when you have an Instant Message
window open with another user, the warning level shown in that Instant Message window is only updated when the
other user sends you more text.

Why is my buddy's warning level increasing even though | didn't issue him any warnings?
Someone else is warning your buddy, and you are seeing your buddy's warning level increase as a result.



Sounds

Why don't my AIM sounds work?

You might need to check your sound settings to make sure that there is a sound file associated with each event
and that the sound events are all enabled (or turned on).

To check your sound settings, perform the following steps:

1. On the File menu, click My Options, and select Edit Preferences.

2. Click the Sounds tab.

3. Make sure that there is a sound file associated with each event and that the sound events are all enabled.
If no sound file is listed for one of the events, click Browse, and choose a sound in the Sounds directory in
your AIM directory. If a sound file is listed but you don't get any sound when you click Preview, it is possible
that the sound file is damaged. If checking your sound settings doesn't fix the problem, try reinstalling AIM as
alast resort. If you don’t have a sound card, choose Beep, so that AIM uses your internal speakers.



Automatic Operations

How do | stop AIM from starting automatically when | start my computer?
Go to General Preferences in AIM, and clear the Start AIM when Windows starts check box.

How do | stop AIM from sending automatic responses to other users? When | have not been active for a
while and someone sends me an instant message, my computer automatically responds to the other
person with an "auto-response"” message, even though | have not set my Away option.

To stop AIM from sending automatic responses, perform the following steps:

1. On the File menu, click My Options, and select Edit Preferences.

2. Click the Away tab.

3. Clear the Auto respond with message check box in the "When idle" section.
4. Click OK.

How do | keep my Buddy List groups from expanding automatically every time | sign on?
You must modify a registry key using the Windows Registry Editor program.

WARNING: You can cause Windows to stop functioning if you make a mistake in the Registry Editor program. If
you need assistance, find someone who is familiar with the program to help you. AOL is not responsible for any
damage you do to your computer.

To modify the registry key, follow these steps:

1. ExitAIM.

2. From the Start menu, launch regedit from the Run dialog box.

3. Browse to the following registry key:

HKEY_CURRENT_USER\Software\America Online\AOL Instant Messenger (TM)
\CurrentVersion\Users\<Your_Screen_Name>\Buddy

4. Right-click Buddy.
5. Click New, and select DWORD Value.

A new item appears on the right side of the Registry Editor window. For the name of this new item, type:
AutoExpandGroups

6. Press the Enter key to save the "AutoExpandGroups" name, and then exit the Registry Editor.
Now when you collapse any of your groups, they should still be collapsed when you sign on again.



AIM and AOL Users

What features of AIM can | use with my AOL buddies?

AIM users can see AOL users in their Buddy List windows and can send instant messages to them. However,
AIM users cannot chat with their AOL buddies, view AOL users’ profiles, or transfer files.

Why can't | send an instant message to an AOL user who is displayed in my Buddy List? When I try to do
this, | receive a message that the person is not online.

AOL users have a feature that lets them block all incoming instant messages but still be seen in Buddy Lists. ltis
possible that the AOL user has blocked all instant messages or blocked all instant messages from you.

Why do | get my instant messages in AOL instead of AIM when I'm online with both AOL and AIM?

This feature is intentional. If you want to receive your instant messages only in AIM, you can use a different screen
name for AIM from the one you are using with AOL.

Can | convert my AIM account to an AOL account?
Yes. While you are registering your AOL account, make sure you select the following option to convert your AIM
account to an AOL account: You are an AOL Instant Messenger user and you want to create an AOL account.

How do | use my current AOL screen name with AIM?

As an AOL member, your screen name is reserved for you if you want to use it with AIM; however, you must still
register the screen name with the AIM service before using it. To register your AOL screen name for an AIM
account, go to the Web site, http://register.oscar.aol.com/73026_reuse.



E-mail
Can | access my e-mail through AIM?
No, this feature is not available at this time.

Why can’t | update my e-mail address?

Reply to the confirmation e-mail that is sent to your new address. You must do this within 72 hours after choosing
Update E-mail Address in AIM. Make sure you follow the directions in the e-mail exactly. You must put only the
work “OK” in the body of your reply, and you must not modify the Subject line.

Do not reply to the e-mail that is sent to your old address. This piece of e-mail is only there to allow you to cancel
the update. If you reply to this e-mail within 72 hours after choosing Update E-mail Address in AIM, your update
won’t take effect.

In all cases, the e-mail address update does not take effect for at least 72 hours after you choose Update E-mail
Address in AIM. Even if you immediately respond to the confirmation e-mail that is sent to your new address,
you must still wait 72 hours for the update to occur. The reason for this is that you still have 72 hours to cancel
the update by replying to the e-mail that is sent to your old address.



Others

Can | use AIM with WebTV?
No, this feature is not available. For more information, refer to http://www.aim.aol.com/tik/webtv.html.

What should | do when one of my AIM windows always opens off the screen?
When the window opens off the screen, perform the following steps:

1. Press Alt+Spacebar once to open the Control menu at the top-left of the window.
2. Press the M key once to select Move.

3. Use your arrow keys to move the window into the middle of the screen. You see only the outline being
moved.

4. When the outline is in the location you want, press Enter.
5. Download the newest version so that your windows do not migrate off the screen.

Why do | get strange error messages when | try to install AIM?

Your copy of the AIM Installer probably was not transferred completely when you downloaded it. Download the
AIM Installer again.

How do | include spaces in an "aim"™ URL?

Use the plus character (+) for each space. For example, "aim:GoChat?RoomName=My+Room".






Before You Report a Bug

Before you report a software bug, check to make sure it has not already been reported and addressed. See the
topic, Frequently Asked Questions (FAQ), and locate the topic area you want.

Related Topic
Reporting Bugs



Reporting Bugs

To report bugs that occur while you are using the Netscape AOL Instant Messenger software, perform the following
steps:

1. On the File menu, click Help, and select Report a Bug.

AIM opens your browser and takes you to the Web site for reporting bugs.
2. Enter your name and e-mail address.
3. Enter a description of the problem that you are experiencing.

Related Topic
Before You Report a Bug







