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Hatim Kantawalla

S
o you�re planning to buy a TV-tuner
card? Smart move! Doing your TV-
viewing on the computer rather
than buying another TV not only

saves you the money and space, it also
makes life so much more convenient.
Now you won�t have to leave your desk to
catch a glimpse of the latest cricketing

action, or fight for the TV remote with
other family members. And TV-tuner
cards now have tons of extra features to
offer, such as FM radio receivers, com-
posite video-outs and desktop cameras
capable of working like video security
devices. Of course, it will help if you
happen to have a 21-inch monitor, but
what the heck, you can�t have everything,
can you?

Installing the TV-tuner card into your
PC is a simple procedure, as you will
soon see for yourself. For this workshop
the card we used was the PixelView
PlayTV PAK. It is a PCI-based tuner card
that consists of a PV-BT878P tuner mod-
ule for tuning into the channels. Howev-
er, this card does not have an FM radio
receiver. Now let�s get started without
further ado.

TV-tuner cards provide an ideal solution for Net surfers who are couch potatoes as well. 
Here�s how you can turn your desktop computer into a TV screen in a few easy steps 

Tune In Right

If the card is an add-on, it should be a PCI card. If you�re going
in for a combo (a card containing both the tuner module and
display chip for VGA output), it should preferably be an AGP
card.

This may sound easy, but can sometimes be a bit tricky
because some PCI slots share Interrupt requests (IRQs) and
in case there is an IRQ conflict, it may render the tuner card
useless, or some features such as video-capture may not work.
Usually the last two PCI slots share IRQs. Avoid installing
your card in these slots.

Selecting the Card Fixing the Card

Step 1: First turn off the
power. Remove the case
and insert the TV
tuner/capture card (fig
1). Make sure the
adapter card is well seat-
ed in the slot, then fas-
ten it securely with a
screw (fig 2).

Step 2: If inserting the
card into the slot is a bit
difficult, you can remove
the CATV header from
the TV-tuner card during
insertion and then re-
insert it after installing
the card (fig 3).
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Installation Procedure

Step 3: Most TV-tuner cards come along with a remote control
and a remote control receiver. Plug the remote receiver into the
slot where �Remote� is inscribed. Keep the remote receiver mod-
ule in the line of sight of the remote.

Step 5: Connect the CATV/VHF/UHF antenna cable. If the
card has an FM radio receiver, you can plug that cable too into
the extra tuner input port of the tuner module.

Step 4: Plug one end of the audio cable into the �Audio� output
and the other end into the �Line In� of the soundcard. 

DDoo  kkeeeepp  tthheessee  ccoommppaattiibbiilliittyy  iissssuueess  iinn  mmiinndd:
✔ Before buying your TV-tuner card, check
that it supports your VGA card as an inter-
face. Some older TV-tuner cards are very
choosy about the VGA card they work along
with. Some may not work with a high-end
3D-accelerator card either. 

✔ Ensure the card is not sharing any IRQs
with any other expansion cards in your sys-

tem. Usually, installing the card in the sec-
ond, third or fourth PCI slots will prevent
any problems occuring due to sharing 
violations.

✔ Make sure PCI bus mastering is enabled in
your BIOS.

✔ Turn on DMA (direct memory access) from
the device manager for your IDE drives if you

want to do some heavy video capturing.
✔ Check whether your line-in volume is
turned on.

✔ If possible, dedicate an IRQ to the card in
the BIOS to avoid further conflicts.

✔ Check for an onboard jumper for NTSC or
PAL (BGHI). Make sure PAL (BGHI) is
enabled using the jumper on the card. 

Troubleshooting and General Guidelines
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Finalising Settings

After this, start the TV-tuner program (in
this workshop, this was the PixelView sta-
tion). It will prompt you to select various
options such as:

1. Country code configuration
2. VGA card identification 
3. Motherboard chipset identification 
4. PAL or NTSC mode selection menu.

[Note that this will be done automatically
if the proper country is selected. In any
case, for India this is PAL(BGHI) or

PAL(BG)]. 
After these settings are done with, the

setup program will auto scan all of the
channels available. You can do this man-
ually too by selecting �Scan� from the
menu.

After all the channels are scanned and
stored, you can change the view size to
full screen by double-clicking the display
window. Some VGA cards may not be
compatible with the full-screen option if it

does not support the 640x480 resolution.
The remote control requires no addition-
al settings and will work once enabled
from the menu. 

Well, that�s all there is to it! Channel
surfing is now possible on the comput-
er. Sit back, go click-click on the remote,
watch Amitabh Bachchan reel off ques-
tions on KBC and go click-click on the
keyboard searching for answers on the
Internet at the same time! 

The software installed will differ from
model to model, but as long as you follow
and understand basic terms and settings
you should be fine.

After the physical installation of the
card, start up your PC. Usually Windows
will detect the card and ask for drivers.

Provide the drivers from the driver CD
provided with the card. After this proce-
dure, Windows will prompt you to restart
the PC. After restarting the PC, open Con-
trol Panel and go to the System option. In
that, move to the Device Manager tab and
then click on Sound, video and game con-

trollers option. You will find extra devices
with the module chipset name in front of
each device. Select the device and then
click Properties. Check in the Resource
option tab for each of these devices to
make sure they are not sharing IRQs with
any other devices.

Installing Software and Drivers
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Sumod Hajela

I
f many people share your computer,
Windows 98 simply doesn�t do
enough for you. Its user management
is limited to individualising the look

of your Windows desktop and switching
between a few data folders. Windows
2000 Professional with NTFS offers far
more control over who gets to do what
with your computer. By assigning differ-
ent access permissions to other users, you
can effectively limit interference between
you and them. Each user gets his private

documents and settings that no other user
can modify. Additionally, you can desig-
nate folders, and even entire partitions,
off-limits or read-only for other users.

Before starting with the process of
creating users it is important to under-
stand the relationship between users
and groups. Each user can be assigned
an individual set of permissions regu-
lating access to the system. This would
include the ability to read or write to
files in a specific folder, use an installed
printer or modify its settings, connect to
the Internet or modify connection

parameters, etc. A personal set of per-
missions makes it easy for each user to
have a different experience with the
same computer, without intrusion from
other users.

It is possible that more than one user
is assigned the same set of permissions.
All such users are usually grouped 
together. A group can have the same 
security information that a single user
has. Groups are used to maintain permis-
sions and users are assigned the required
permissions by making them members of
groups that have those permissions.

Make sure you have the administrative
rights for the system. The default �admin-
istrator� account on the system is initially
the only account with these rights. 

Step 1: User management can be done
through the Control Panel. Go to Start >
Control Panel > Users and Passwords.

Step 2:. The Control Panel applet shows
the list of accounts available on the sys-
tem (Administrator and Guest accounts
are there by default). To add more users
click on the �Add�� button.

Step 3: The �Add New User� wizard starts
and leads you through the process. You
have to first give a name to the user. You

only have to fill in the �User Name� field;
the remaining fields are helpful in

identifying people if you have many users,
but are not really necessary.

Step 4: Assign a password to the user. Of
course, the user can change this initial
password after he logs in. To do that, he
has to press Ctrl+Alt+Del and click on

�Change Password� in the Security win-
dow. You can leave the password blank to
allow the user to log in and change his
password without having to be told the
initial one.

Step 5: Finally, the user is assigned to a
group. This window shows the two
default user types created but also
allows you to select another group. You
should select �Restricted User� if you do
not want the user to install applications
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Creating users, assigning them to groups and setting permissions offer a convenient way to share 
your computer among many users. Let�s go about doing this with Windows 2000 Professional

Too many Too many users�

The Simple Way of Adding Users

You need to log in as administrator to add users

Fill in the required details of the user

A good password is easy to remember and hard to guess
Initially, there are only the default accounts present



or else select �Standard User� if that does
not matter. 

While assigning a group, do not select
the Administrator group, since this will
effectively create a second administrator
level account and the user will have com-
plete control over the system (See box,
�Standard Groups in Windows 2000� for a
detailed description of the permissions for
each default group). 

If you have created your own groups,
use the last option to select that group.
You can only assign multiple group
membership through the advanced inter-
face. That�s all there is to creating user
accounts.

More user account control is available
in the Advanced Configuration mode. To
get there, click on the �Advanced� button
in the �Advanced� tab.

The Advanced control interface is an
MMC (Microsoft Management Console)
applet that shows users and groups in two
folders. Right-click any user account to set
its password or choose �Properties� from
the menu.

From the Properties view you can
enable or disable an account and manip-

ulate its password settings. You can also
force the user to change his password, or
prevent him from ever doing so through
the appropriate check boxes. 

The �Memberships� tab allows you
greater control over the user�s group
membership. If you configure the secu-
rity settings correctly, you will only need
to assign permissions to groups and not
to individual users. 

Then, when you add a user to a par-
ticular group, he will have the appro-
priate permissions. With multiple
groups, you can even have more flexible
security rules.
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Assign rights through group membership

Control freaks get to know this interface well

More control over account access

The user inherits permissions from both groups

The Powerful Way of Adding Users

AAddmmiinniissttrraattoorrss:: Members of this group have
full control over the computer. That means
any user of this group can make any kind of
changes to the system including creating,
modifying and deleting other users. It is the
only built-in group that is automatically
granted almost every built-in right in the
system. 
BBaacckkuupp  OOppeerraattoorrss:: Members of this group
can back up and restore files on the comput-
er regardless of any permissions that protect
those files. 

They can also log on to the computer and
shut it down, but they cannot change secu-
rity settings. With complete access to the
file system, they can potentially cause

security problems so use this group with
care.
PPoowweerr  UUsseerrss:: Users who are a part of this
group can create user accounts. They can
modify and delete only those accounts that
they create. They can create local groups
and remove users from local groups they
have created. 

They can also remove users from the
Power Users, Users, and Guests groups.
But they cannot modify the Administrators
or Backup Operators groups, nor can they
take ownership of files, back up or restore
directories, load or unload device drivers or
manage the security and auditing logs.
Even if you have administrative access, you

should use this group for your working
account to minimise the damage done by
viruses or worms.
UUsseerrss:: Members of this group can perform
most common tasks such as running applica-
tions, using local and network printers and
shutting down and locking the workstation.
Users can create local groups, but can modi-
fy only the local groups that they created.
They cannot share directories or create local
printers.
GGuueessttss:: The Guests group allows occasional
or one-time users to log on to a workstation�s
built-in Guest account and be granted limited
rights. Members of this group can also shut
down the system.

Standard Groups in Windows 2000
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The Advanced view
is the only view from
which you can
manipulate groups.
You only need to cre-
ate new groups if
you want to organise
permissions differ-
ently from the stan-
dard groups.  When
created, the group
inherits permissions
available to �Every-
body�. Click on
Action > New Group
in the MMC menu to
create a new group.
In the �New Group�
window that comes up, you need to assign the group a name.
Click on the �Add�� button to assign users and other groups to
the new group.

All objects in Windows 2000 have permissions associated with
them. The most common objects you see are files and folders. To
be able to control access to files and folders, you must have an

NTFS partition. If
you are using a
FAT partition,
you can convert it
to NTFS using
the convert.exe
tool. 

To set permis-
sions for any fold-
er, right-click on
the folder and
select Properties.
After this, switch
to the Security
tab to modify the
permissions. By
default, most
folders have full
permissions for
�Everyone� and
the inherit per-
missions check-
box is enabled.
To restrict access,

uncheck the inherit permissions checkbox and remove the
�Everyone� group. Now add groups that you wish to allow access
to, and select the level of access from the list. 

Creating a Group

Assigning Permissions

The Security tab shows permissions assigned for this folder.
Only the groups listed have any access and the �article� user
can read files but not make any changes to them

A group can contain user accounts as well as other
groups
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Frank Jennings

I
nstant messaging is cool and offers
an easy mode of communicating
online. But have you ever tried going
beyond conventional messaging

clients such as MSN Messenger or
Yahoo! and opted for some real, interac-
tive chatting? Or for that matter ever

tried setting up an online meeting of all
the employees?

Software such as Microsoft NetMeet-
ing offer features that go beyond conven-
tional chatting. NetMeeting enables real
time audio, video and data communica-
tion over the Internet/intranet. It�s a free
utility that comes with the Windows 9x
installation, though it doesn�t get installed

by default. If you have not installed Net-
Meeting as yet, go to Start > Settings >
Control Panel > Add/Remove Programs
and click on the Windows Setup tab.
Select Communications, click on Details
and tick the NetMeeting checkbox to
install the software. Here, we show you
how to use the software over the local
network.

Step 1: Before you start using NetMeeting,
you have to configure the settings based on
your system resources. Open NetMeeting
and go to Tools > Option. Click on the Call-
ing tab and you will see a few configurable

options. Uncheck �Log on to the directory
server when NetMeeting starts�. Enable
�Automatically adding people to speed dial
when you place a call�. In the General tab,
select your bandwidth setting or connec-
tion speed. If you are in a local intranet,
select LAN.

Step 2: Configure your audio and video
for use with NetMeeting. Click on the
Audio tab and enable �Full duplex audio�,
which will enable you to speak simulta-
neously while receiving audio. Enable
�Auto-gain and DirectSound� for enhanced
audio performance. Enable silence detec-
tion automatically, so that NetMeeting can
track idle time.

Step 3: In the Video tab, disable �Auto-
matically receive video at the start of each
call�, as all the calls may not have video
transmission enabled. Adjust the setting
to have a good compromise between faster

video and better quality. Select your video
capture device in the video camera prop-
erties.

NetMeeting is now configured for
receiving and placing calls over your LAN.

Placing a call enables you to send a meet-
ing request to a remote machine. Of course,
it goes without saying that NetMeeting
should also be installed on that machine.
One vital criteria is that the machine�s Net-
Meeting should be running and should not

be in the �Do Not Disturb� state.

Step 1: Click on the Call button and you
will be prompted with a small dialog box.
In the �To� combo box enter the computer
name or IP for the machine you want to

send a request to. In the �Using� option,
select �Network� if you are calling a local
intranet computer.

Step 2: Alternatively, if you know the
name of the meeting you want to join, type

Do formal tie-and-suit meetings leave behind a stuffy feeling? 
Get real with online meetings that allow you to chat, collaborate, share applications and more

Me ting Timee

Configuring NetMeeting

Placing and Receiving Calls

The Calling tab provides you many configurable options

Select your network bandwith
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the name and click OK. NetMeeting will
send a request to the remote machine and
will wait for the response.

Step 3: At this juncture, the remote
machine will get a message box showing
your name and your request. The remote
machine can either accept or decline your

request. If the request is declined you will
be disconnected from the meeting net-
work. If accepted, you are then in a meet-
ing and can start communicating.

At any point of time if you feel the
meeting is getting too dull, you can hang
up. This does not in any way disturb the
meeting. NetMeeting at present supports

a maximum of 32 users, though the net-
work bandwidth may also play a role in
limiting the number of users. You can
also place NetMeeting calls to multiple
users. 

Any person in a meeting can place
NetMeeting calls to other people. In
addition, other people can join a Net-
Meeting in progress by calling one of the
participants. 

Step 1: NetMeeting allows users to share
application for others to view and use it
on a network. To allow participants in the
meeting to use an application in your
machine, you have to first share the appli-

cation from Tools > Share Application.
The applications that are shared come up
as a list on everyone�s machine. Anyone
can double-click on that application to
start it. In collaborative sharing, other par-
ticipants can also use the application at
the same time. For instance, you can type
a sentence in Word, then some other par-
ticipant can type in his reaction. This
increases the interactiveness of the meet-
ing to a great extent. 

Step 2: The latest version of NetMeeting
(version 3) also has an option of remote
desktop sharing, which enables NetMeet-
ing to call an unattended computer (with-
out host) and share the desktop. To
enable remote desktop sharing, go to

Tools and click Remote Desktop Sharing.
A wizard will guide you through some
simple steps which will facilitate the shar-
ing of the desktop files. 

The file transfer option enables you to
exchange files with the participants in the
middle of a meeting.

Step 1: Go to Tools > File Transfer and
click Send File. In the File dialog box,
select the file you want to send and click
OK. The file will be transferred to the
remote machine. You have the option of
sending files to just one user in the

meeting or to all the participants.

Step 2: When you get the file from some-
one, NetMeeting does not ask you for
download permission. Instead it down-
loads the file in the default directory. You
have the option of saving, opening or
deleting the file. File transfer is very fast in
a local intranet when compared to a
meeting hosted on the Internet.

Sharing Applications

Transferring Files

Enter the name of the person whom you want to call

File transfer is fast

Collaborating of files can be done

Sometimes a request may be rejected 

To receive calls over a null modem
cable, click the Tools menu, click

Options and then click the Protocols tab.
Select the Null Modem protocol, and then
click Properties. Select the COM port to
which the null modem cable is connected. 
If you want to connect to some machine
through a proxy server, you have to manu-
ally configure audio and video properties.

Sharing applications has been made easy
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NetMeeting enables you to chat with all the participants in
the meeting. When one person in the meeting starts the
chat, a chat window opens in the computers of all the par-
ticipating PCs. 

Step 1: When you click on the chat button, a small window
opens in which messages can be typed for other users to see.
You can save the chat messages in a .htm file for later view-

ing in a Web
browser. Howev-
er, for the chat
option, all partic-
ipants need to
have the same
version. If some
of the partici-
pants are using a
different version,
chat will not
work properly.
The Whiteboard
feature in Net-
Meeting allows
one participant
to draw some-
thing and explain
to the other par-
ticipants. This
can be useful
while explaining
some company
plans, flow charts
or even a simple
diagram. 

Step 2: Click on
the white board
and a small MS
Paint miniature
window will
open in the PCs
of all partici-
pants. You can
draw freehand
drawings, sym-
bols or write text
for other partici-
pants to view and
edit. 

By default, anyone in the meeting can modify the dia-
grams or whatever else you have made on the white board
which will be seen by all the participants. To disable that,
click on �Lock contents� button in the Control Panel. As a
result, participants will only be able to view but not edit the
diagrams. So the next time you feel reluctant to attend a
meeting in a stuffy room, start an online meeting using this
power tool. 

Chatting and Chalking

You can chat with other participants

Whiteboard lets you draw symbols for others to see

Video chatting is clear

1/2 page hor.AD
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Configuring VCDCutter Cutting a Clip

Sumod Hajela

Y
ou went and bought that Mission
Kashmir video CD because the songs
are so amazing. Now you have a little
problem. Every time you want to lis-

ten to a song, you have to hunt around for
it on the VCD. And forget about queu-
ing the songs in a playlist. 

Take another scenario: what
do you do if you want to keep
funny bits of the latest Jim

Carey movie on your hard disk for a
quick laugh but haven�t got 650 MB
spare on your hard disk? Use a video
clipping software to chop out just the
bits you want. You don�t need to shell
out piles of money for heavy duty video
editing software to do this. There are
plenty of smaller tools such as

VCDGear and VCDCutter that
will do the trick for cheap.
Let�s get cracking with the
simple VCDCutter.

Once you have
installed VCDCutter,
go to View > Options to
configure capture settings. In the
�Extract� tab, choose one of the extract
modes. The �mpg� mode extracts video with sound, the �m1v�
mode extracts only video and the �mp3� mode extracts only
the sound. For now, set the extract mode to �mpg�. From the
Settings tab, set the folder in which all the video manipula-
tion will take place. By default, this folder is the one in which

VCDCutter is installed.
You can set the screen
capture format here as
well. JPEG will produce
poorer quality caps but
they will occupy far less
space than the BMPs.

Step 1: Mark the begin-
ning: Insert the VCD in the CD-

ROM drive and click on File > Play VCD
in VCDCutter.

This will make VCDCut-
ter automatically scan
the VCD and add all
video files to its playlist.
Play the movie file to the
point you want to begin
clipping. Click on the
downward pointing
arrow button on the
toolbar, or press F5 to
mark the beginning of
the selection.

Step 2: Mark the end:
As the video plays along,
you will see a blue selec-
tion marking within the
time tracking bar. When

Step into the first learning blocks of video editing 
by making clips of video using VCDCutter

Set up your output
options here

1

T he Final

Imaging: Neeta Wadiker



the video plays out to the point where you
want to stop the clip, click on the upward
pointing arrow button, or press F6. The
video will continue playing but the selec-
tion marker will stop moving.

Step 3: Add to list: Now, click on the
'Add to list button' which looks like many
little screens stacked up, or press F7.

Switch to the Clip List tab below the time
tracking bar. You can see that a little
thumbnail picture of the clip has been
added to the clip list. You can repeat these
three steps for all the clips you want to cut
from the video and they will be added to
the clip list.

Step 4: Cut scene: Once you have all the

clips you want, click on the video camera
button or press F8 to save the clips to your
working directory. The output depends
on the options you set in the Extract tab.
If you checked 'Save to multiple files', each
of the clips will be saved to a separate file,
otherwise all the clips are joined together
in the order in which they are marked,
and saved to one big file.

Songs are usually heard not seen, there-
fore you might want to save the song
sequences as audio tracks rather than
video segments. Conveniently enough,
the sounds are encoded in the video using
an MPEG algorithm similar to MP3. If you
select the 'mp3' option from the Extract
options tab and follow the sequence out-
lined in Step 2, then you will get only

audio tracks. To extract the audio track
from a clip you have already taken, click
Tools > Split System Stream. This will out-
put separate video clips without sound
and an audio track that you can play in
WinAmp or some other audio player. The
audio-less video clips are much smaller as
well, so if you do not need a soundtrack,
you can save space on video this way.
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Separating Audio and Video

Most video capture takes place to an
uncompressed AVI format. These AVI
files are huge, and take up a lot of hard
disk space. VCDClip lets you convert
these AVI files to the much more effi-
cient MPEG compressed format. The
conversion also helps because there are
many different encoding schemes used
for compressed AVI and the viewer must
have the right Codec. If the Codec is not
available, the AVI cannot be viewed.
There�s no such confusion with MPEG.

The conversion process on compressed
AVI causes a slight loss in quality, so it
is best used with raw AVIs. To convert
files, click Tools > File Convert : AVI to
MPG and select the input AVI and the
output MPEG file names. If your video
capture file does not have sound or you
do not want the sound, check the �Make
Video (m1v) �� check box to reduce the
file size. To create a VCD style MPEG
stream, check the �Use Video-CD��
check box. 

Better than AVI

2 3 4
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Switch your little Palm into an overload of
ultra-cool with real moving video in the
ActiveSky video player (download the
software from www.activesky.com). Run the
installer to automatically set up the play-
er on your Palm. One HotSync and you
are almost set. 

The player requires a free registration

or it expires after 30 days. Go to the Web
site and click the �Register� link. Tap the
Menu button and select �Register ActiveSky�
to get the registration screen. You will need
the DeviceID shown there. After you fill up
the short form, you will be mailed the reg-
istration code for your DeviceID. Enter that
into your player and you are done.

Sumod Hajela

I
f you still use your Palm for just ToDo
lists and Contact management, you are
surely missing out on something.
Microsoft�s PocketPC offers built in

multimedia capability on a gorgeous 256

colour screen, so why should users of
Palm Pilot be left behind? 

Even though most Palms offer just four
levels of greyscale in a small screen, there
are many graphic viewers around, and
now there is even video for the brave
hearted or for those who miss the tiny,

grainy postage stamp size things that
passed for video in the days of the 486.
You can download most of these image
viewers from various Web sites. But for
this workshop, we have got cracking with
two cool, nifty viewers�ActiveSky and
AlbumToGo.

Installing

Watching the Videos

Pretty pictures, palm size
So what if your Palm IIIxe has a black and white screen? You can still 

carry pictures around in it and even watch videos while you walk

Step 1: Now you need the videos. Go to
the ActiveSky Web site and click the �Con-
tent� button to get a list of sites that offer
ActiveSky compatible videos. Download
any you want to see and HotSync them to
the Palm. They will show up in the video
list.

Step 2: Choose the video you want to see
and tap the Play button. Use the standard
player buttons to control the video. You will
notice that purpose made animation films
(2b) look far better than real videos of fash-
ion models (2a) converted to ActiveSky
format, though both are viewable.

You can set the playback options from
the �Video Options� menu. You can set the
player to loop through just one movie or
the entire list. If your Palm supports 16
levels of grey or if you happen to have a
Palm IIIc colour screen, you can put those
to good use here.

1 2a 2b

ActiveSky Video Player
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Working with the Images

Installing 

AlbumToGo

A much more practical application,
AlbumToGo from Club Photo (download
from www.clubphoto.com) is a picture library
for the Palm. Simply unzip the archive to
your hard disk to install the PC version of
this program. HotSync to install the
AlbumToGo.prc Palm program. The desk-
top application is used to convert your
standard JPG images to the Palm DB (PDB)

format. The conversion process trans-
forms your high colour image to a small
160x120 pixel greyscale image. The appli-
cation comes with a set of sample images
in both JPG and converted PDB formats
that you can immediately try out. Once the
images are in the PDB format, HotSync
them to make them available to the Palm
component of the program.

Click on a file in the list to view it.
If the contrast isn�t too great, use
the contrast dial on the left to
adjust the levels.

Flip through all the pictures using
the Slide-show button. You can set
transition styles using the menu
on the top right.

Switch to Rename mode if you
want to rename files. Click the
file you wish to rename and type
in the new name in the pop-up
window.

Sick of seeing a picture? Zap it
from the Delete mode. Pictures
do not take too much space so
you needn�t worry on that
account unless you have a few
hundred of them in there.

The Notes mode lets you edit more detailed descrip-
tions for your images. You can also click on the little
note icon along the left margin to edit a note without
switching to this mode. 

The PC program converts JPEG to AlbumToGo format


