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1 Introduction
Rhinoceros is a 3-D NURBS modeling program for Windows. With Rhino you can
model anything from a heart valve to a ship hull and from a mouse to a monster.
Rhino provides a flexible, accurate, and fast working environment. You can model
and render objects that you could previously create only using software and
hardware many times more expensive.

Rhino is easy to learn and use. With Rhino, you can create free-form curves,
surfaces, and solids. You are free to create the model any way you want.

NURBS

Non-uniform rational B-splines (NURBS) geometry is a mathematical
representation that can accurately define any shape from a simple line, circle, arc, or
box to the most complex 3-D free-form organic surface or solid.

Because of their flexibility and accuracy, NURBS models can be used in any
process from illustration and animation to manufacturing.

Rhino’s Geometry Types

There are five fundamental geometric objects in Rhino: points, NURBS curves and
surfaces, and polygon meshes.

Points. NURBS curves.

NURBS surfaces. Polygon meshes.

Polygon mesh objects are used by some programs for rendering and animation,
stereolithography, VRML, and finite element analysis to approximate a smooth
surface. Rhino can create polygon mesh objects that approximate the NURBS
objects to export to those programs.

For additional information on Rhino features go to page 66.
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2 Your First Look
Working in 3-D on a computer requires that you visualize three-dimensional objects
drawn on a two-dimensional medium— the computer screen. Rhino provides tools to
help you do this.

You can manipulate the views and look at your model from different angles easily
by dragging with your right mouse button. You can do this in both a wireframe view
and a shaded view. When you have a view you like, you can render the view. By
rendering you can add color, texture, shadows, and lights.

Wireframe. Shaded preview. Rendered.

If you have experience using a 3-D modeling program, the following exercises may
seem simple, but they will help you understand Rhino’s interface and navigation
tools.

If you have never worked with 3-D computer modeling before, Getting Started with
3D, A Designer’s Guide to 3D Graphics and Illustration, by Janet Ashford and John
Odam is one of several excellent books that will help you learn some of the
terminology and basic principles of 3-D design on computers.

In the exercises, you will use Rhino’s navigation tools, shaded preview, render, and
use some basic object manipulation.

The first exercise model.

Rhino Commands

Rhino uses commands to accomplish various tasks. As you work through the
exercises, you will learn what commands do, when and how to use them and how to
decide which command to use to accomplish your task.
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Start Using Rhino

In the first exercise you will learn how to:

• Shade the model

• Rotate, pan, and zoom in wireframe and shaded preview

• Drag objects to move them

To look at your first Rhino model:

1 Start Rhino.
2 From the File menu, click Open.
3 In the Open dialog box, in the Tutorials folder, select First Model.3dm.

Two parallel viewports and one perspective viewport.

This model contains five objects: a cube, a cone, a cylinder, a sphere, and a
rectangular plane.
You won’t be able to select or move the plane. You will learn about how to do
this later. It is just there to provide you with a floor underneath the objects.

4 Click the mouse in the Perspective viewport to make it active.
An active viewport is the viewport where all your commands and actions take
place. The active viewport’s title highlights so you can easily see which
viewport is active.

Command
prompt

Status
bar

Snap toggle
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5 From the Render menu, click Shade.
The objects appear shaded. Shade lets you preview the shapes with a surface
instead of a mass of curves. Previewing with no color also lets you focus on the
geometric shape of the object instead of color and texture. The model is shaded
in the viewport. You can still manipulate the view in shaded mode. In addition,
Rhino provides rendering with color and texture.

Shaded preview.

6 From the Render menu, click Render.
When you render the model, you can see the color and texture that has been
applied to the objects. Rendering opens a separate display window. You cannot
manipulate the view in the render display window. In addition to assigning color
and texture to the objects, you can set lights and a background. Rendering is
slower than the shaded preview.

Render.

7 Close the render Display Window
8 From the Render menu, click Shade.
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9 In the Perspective view, click and drag with your right mouse button held down
to rotate the view.

Rotate the view in shaded mode.

The plane helps you stay oriented. If the objects disappear, you are looking at
the bottom of the plane.

10 From the Render menu, click Render.

Render the rotated view.

11 Close the render Display Window.
12 In the large Perspective viewport on the right, click and drag with your right

mouse button to rotate the view around.

Rotating the wireframe view.
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13 Rotate your view by dragging from the bottom of the view toward the top.

Looking at the objects from the bottom in wireframe mode.

You are now under the objects looking up.
14 From the Render menu, click Shade.

Looking at the objects from the bottom in shaded mode.

In shaded mode, the plane helps you see when your viewpoint is below the
objects.

To get back to your original view:

u Press the Home key to undo your view changes.

Try on Your Own

• Click in other viewports and shade them.

• Render the other viewports.

• What happens when you drag with your right mouse in other viewports?

• Dragging the right mouse in the viewports that do not have a perspective view
pans instead of rotating. You will learn more about navigating around in Rhino as
we go along.

• You can change the way Rhino rotates the view. See View Options in Rhino Help.
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Navigating Around the Model

You have used the right mouse button to rotate in the Perspective viewport. You can
drag with the right mouse button to pan. Dragging the right mouse button to
manipulate the view does not interrupt any commands you are using.

To pan in a viewport:

u In the Top viewport, drag with the right mouse button to pan the view.

 
Panning with Shift and the right mouse button.

Zooming In and Out

Sometimes you want to get closer to your objects or move back so you can see more.
This is called zooming. As with many things in Rhino, there are several ways to do
this. The easiest way is to hold down the Ctrl key and drag up and down in a
viewport with the right mouse button. If you have a mouse with a scroll button, turn
the scroll button to zoom in and out.

To zoom in and out:

u In the Top viewport, hold the Ctrl key, click and hold the right mouse button,
and drag the mouse up and down.
Drag up to zoom in.
Drag down to zoom out.

Zooming with Ctrl and the right mouse button.

What if …

Instead of panning or rotating, something funny happened.

If you just right-click in viewport, the last command starts again. You must hold the
right mouse button down while panning or rotating.

I panned in another viewport, and it shaded too. What’s going on?

When you are in shaded mode and make a change in any viewport, the viewport also
displays in shaded mode. Press Esc or click in a viewport to exit shaded mode.
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Zooming Extents

The Zoom Extents command zooms your viewports so the objects fill the viewport
as much as possible. You can use this command to make everything visible.

To zoom extents in a viewport:

u From the View menu, click Zoom, and then click Extents.
If you get lost, it’s often handy to zoom extents in all your viewports at once, so
there is a command to do just that.

To zoom extents in all viewports:

u From the View menu, click Zoom, and then click Extents All

Drag Objects

Now drag the objects around. You can drag in any viewport. In this model snap is
set to one-half of a grid line. Using this snap, you should be able to line objects up
with each other.

To drag objects:

1 In the status bar, click Snap to turn on the grid snap.
Grid snap may already be on in your system. Be careful that you don’t turn it off
instead of on. If grid snap is on, the word “Snap” will be black in the status bar.
If it is off, the word “Snap” will be gray.

Note This is an important step. Grid snap only lets you move in certain intervals. In this model,
grid snap is set to one half of a grid line. Grid snap helps you line up your objects as if you
were building with LEGO  blocks.

2 Click the cone.
The cone turns yellow to show it is selected.

The selected cone highlights.

3 Drag the cone in the Perspective viewport until it lines up with the cylinder.
It will be inside the cylinder.
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The cone moves on the base that is represented by the grid. This base is called a
construction plane. Each viewport has its own construction plane. When you
start Rhino, the Perspective viewport construction plane is the same as the Top
viewport. You will learn more about using construction planes later.

Drag the cone.

4 In the Front viewport, drag the cone to the top of the cylinder.
Watch what happens in the Perspective viewport.
There are many times when you have to watch what is happening in other
viewports to accurately place your objects.

Drag the cone in the Front viewport.

5 Click in the Perspective viewport.
6 From the Render menu, click Shade.
7 From the Render menu, click Render.

Try on Your Own

Drag the objects around. Use the Front viewport to drag the objects vertically and
the Top or Perspective viewport to drag them horizontally.

Try these:

• Drag the cone to the top of the box.
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• Drag the sphere so its equator is at the top of the cylinder.

Drag the cone and sphere.

• Try some other movements on your own.

• Use Shade and Render to look at your work.

• From the Transform menu, click Move and try this command. It is a little
different from simply dragging. The Move command lets you use some placement
techniques you will learn later.

• Select a command from the menu. Press F1 to read the Help topic for that
command.

Copy Objects

To create more objects, copy the shapes.

To start with a fresh model:

1 From the File menu, click Open.
2 Don’t save the changes.
3 In the Open dialog box, in the Tutorials folder, select First Model.3dm.

To copy objects:

1 Click the box to select it.
2 From the Transform menu, click Copy.
3 At the Point to copy from ( Vertical InPlace ) prompt, click somewhere in the

Top viewport.
It usually helps to click a spot that relates to the object like the middle.

Select and copy the box.

4 At the Point to copy to prompt, click where you want the first copy.
Zoom in closer if you like.
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To zoom, hold Ctrl and drag with the right mouse button.

Zoom in closer.

5 At the next Point to copy to prompts, click other places to make some copies of
the box.

6 When you have enough copies, press Enter.

Review

In this chapter you learned some basic Rhino commands and techniques. You
learned how to:

• Rotate the view in a perspective viewport

• Zoom and pan

• Drag objects to move them

• Copy objects using the Copy command

• Shade and render

Try on Your Own

Make copies of more objects and drag them around. See if you can build something.

• Watch the prompt for instructions.

• Move your mouse from one viewport to another in the middle of a command to
see what happens.

• Shade your viewport often to see what your shapes look like.

• Select a command from the menu. Press F1 to read the Help topic for that
command.

Build a castle. Hint: there are six overlapping
spheres in the box.
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Repeat the Last Command

Many tasks in Rhino are repetitive. You might want to move or copy several objects,
for example. It’s easy to repeat the command you just used. Any time you press
Enter when no command is active, the previous command repeats.

In addition to pressing either Enter key on your keyboard, you can press the spacebar
or click the right mouse button in a viewport. These all perform the same function.

You can press the Esc key to cancel a command any time.

Undo a Mistake

If you did something you did not want to do, you can undo your actions.

To undo commands:

u From the Edit menu, click Undo.
The prompt displays the action you are undoing.
You can undo a series of commands.
You can also Redo the Undo if you go too far.

To redo a command:

u From the Edit menu, click Redo.
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3 Create a Flashlight
You will learn how to use Rhino solids to create a simple model of a flashlight.
While building the model you will create the basic shape with a cylinder, and a
truncated cone. A sphere is added to create the switch. To complete the model you
will add solids together and subtract other solids from your basic shapes.

The rendered flashlight with color.

You will be entering numbers to set sizes for the shapes. This lets you draw to a
certain scale. The units in Rhino can stand for anything you want them to be: inches,
feet, centimeters. For the moment, they will be simply units. When the model is
finished you will have three distinct parts— the flashlight body, the lens, and the
switch.

This exercise shows how to:

• Create a cylinder

• Type distances at the prompt

• Create a truncated cone

• Create a sphere

• Add two solids together

• Subtract one solid from another

• Assign colors to an object for rendering

• Render the model

Start the Flashlight Model

Each command is available from either the menu or the toolbars. In this exercise, we
will use the menu commands. You are, of course free to find the command in the
toolbars if you prefer to use them. There is no “right” way. Some people just prefer
one method to another.

To start the model:

1 From the File menu, click New.
2 In the Template File dialog box, select 4 Viewports.3dm and click Open.
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Draw the Body

The flashlight body is created using cylinders and truncated cones. You will also
create a cylinder and a truncated cone that will be used to hollow out the inside of
the flashlight body.

To draw the body:

1 From the Solid menu, click Cylinder.
2 Move the cursor to the Right viewport.

In this case, you don’t have to click in the viewport, just move the cursor there
to make it active. The viewport title highlights.

3 At the Base of cylinder ( Vertical ) prompt, type 0,0.
This sets the base point for the cylinder at the origin (0,0,0 point) of the
coordinate system for the Right viewport.
Coordinates define points in space. You will learn more about using coordinates
later.

4 At the Radius ( Diameter ) prompt, type .75 and press Enter.
5 At the End of cylinder prompt, type 5.5 and press Enter.

This turns on the distance constraint that restricts the distance from the last point
to 5.5 units.

6 Turn Ortho on.
Click Ortho in the status bar or hold down Shift.

7 At the next End of cylinder prompt, in the Front viewport, click so the cylinder
points to the right.

With ortho on, drag the cylinder to the right in the Front viewport.

8 From the View menu click Zoom, then click Extents All.
Or, right-click the Zoom Extents button.

9 Click in the Perspective viewport.
When you are not in the middle of a command or selecting objects, you have to
click in a viewport to make it the active viewport.
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10 From the Render menu, click Shade.

Shaded view of the first cylinder.

To draw the flashlight reflector shield:

1 From the Solid menu, click Truncated Cone.
2 At the Base point of truncated cone ( Vertical ) prompt, snap to the center of

the right end of the cylinder.
To turn on the Center object snap, on the status bar, click Osnap, then check
Cen.
It’s easiest to use the Perspective viewport for this.

Snap to the center of the cylinder.

3 At the Radius ( Diameter ) prompt, type .875 and press Enter.
A truncated cone has two radius values, the base and top.

4 At the next Radius ( Diameter ) prompt, type 1 and press Enter.
5 At the End of cone prompt, type 2 and press Enter.

This sets the length of the cone.
6 At the next End of cone prompt, pick in the Front viewport to the right of the

cylinder.
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You may have to zoom out a little to get some space in the Front viewport. Hold
down Ctrl and drag with the right mouse button. You can do this right inside the
command. The end of the cone won’t be entered until you click with the left
mouse button.

Use the Front viewport to drag the truncated cone to the right.

Being able to zoom and pan inside a command makes moving around in Rhino
easy.

7 Zoom extents in all viewports.
8 Shade the Perspective viewport.

Cut the Reflector Shield

You will now copy the truncated cone to create another truncated cone that will be
used to cut the inside shape of the reflector shield.

To create the cutting cone:

1 Select the truncated cone.
2 From the Transform menu, click Copy.
3 At the Point to copy from ( Vertical InPlace ) prompt, in the Front viewport

pick any point.

Pick a base point for the copy. It can be anywhere.

4 At the Point to copy to prompt, turn on Ortho and drag the cone to the right
until the sides of the copy are inside the first cone.

5 Pick a point to place the copy, and press Enter.
We need to move the truncated cone to the right so it does not cut into the sides
of the flashlight.
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It may help at this point to turn off the Center object snap.

Move the copy out beyond the first truncated cone.

Ortho will keep it moving in a straight line.

To add the two parts of the flashlight body together:

1 From the Solid menu, click Union.
2 At the Select surface or polysurface prompt, select the cylinder.

You can’t select the object first when using these commands. Starting the
command cancels your selection. You can only select one object.

3 At the Select surface or polysurface to union prompt, select the first
truncated cone.
Not much appeared to happen, but the cylinder and the truncated cone are now
one piece.

To cut the inside of the reflector shield:

1 From the Solid menu, click Difference.
2 At the Select surface or polysurface prompt, select the flashlight body.
3 At the Select surface or polysurface to subtract prompt, select the new

truncated cone.
4 Shade the Perspective viewport.
5 Rotate the view a bit so you can see inside the flashlight.

Cut Out the Inside of the Flashlight Body

You will now draw a cylinder that you will use to “hollow out” the inside of the
flashlight body.

To draw the cutting cylinder:

1 From the Solid menu, click Cylinder.
You will create a cylinder that will be subtracted from the inside of the
flashlight.
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2 At the Base of cylinder ( Vertical ) prompt, pick a point in the Perspective
viewport that is at the center of the cylinder at the flashlight base.

Start the cylinder at the center of the base.

3 At the Radius ( Diameter ) prompt, type .625 and press Enter.
4 At the End of cylinder prompt, pick a point in the Front viewport to the right of

the truncated cone.
This sets both the length of the cylinder and the rotation angle at the same time.

Extend the cylinder beyond the right end.

To move the cylinder away from the base:

We need to move the cylinder away from the base a little so it won’t cut through
the flashlight’s bottom.
You can move objects just by selecting and dragging them.

1 Select the cylinder you just created.
2 Turn Ortho on, if it is not already.
3 Turn off the Center object snap.

Sometimes having object snaps on interferes with your ability to click and drag
freely.

4 In the Front viewport, click near the right end of the cylinder and drag it a little
bit to the right.
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Ortho will keep it moving in a straight line.

Move the cylinder away from the base.

5 Zoom extents in all viewports.
6 Shade the Perspective viewport.

To cut out the interior of the flashlight:

1 From the Solid menu, click Difference.
2 At the Select surface or polysurface prompt, select the flashlight body.
3 At the Select surface or polysurface to subtract prompt, select the new

cylinder.
4 Shade the Perspective viewport.

Draw the Lens

The lens is a small cylinder inside the flashlight body.

To draw the lens:

1 From the Solid menu, click Cylinder.
2 At the Base of cylinder ( Vertical ) prompt, snap to the center of the inside edge

of the truncated cylinder.

Start the lens cylinder at the center.

3 At the Radius <0.625> ( Diameter ) prompt, press Enter.
The radius is already set to .625 because you entered it for the last cylinder
radius. You can simply press Enter to use this radius again.

4 At the Choose a point prompt, in the Front viewport pick a point slightly to the
left of the center point.
It helps at this point to turn off the Center object snap. Otherwise, it’s hard to
drag the cylinder a very small amount.
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You are trying to make a thin piece of glass.

The lens is a very shallow cylinder.

The glass won’t show much in your model, but later, when you render it, you
can make the flashlight more realistic by making this cylinder transparent.

Draw the Switch

The switch is just a sphere drawn so part of it sticks up above the flashlight body.

To draw the switch button:

1 From the Solid menu, click Sphere, and then click Center, Radius.
2 At the Center point prompt, in the Front viewport pick a point near the top of

the cylinder.
3 At the Radius ( Diameter ) prompt, pick a radius.

You can type .4 and press Enter, or just draw a size that looks good to you.

Draw the switch.

4 Shade the Perspective viewport.

Render the Flashlight with Color

You can use Rhino to add color, texture, and lights to your model to make simple
presentations. In this exercise you will add only color to the flashlight parts and use
Rhino’s render to create a more realistic picture.

Render the Flashlight with No Color

To see what our starting point is, render the flashlight model with no color or lights
assigned.
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To render the model:

1 Click in the Perspective viewport.
2 From the Render menu, click Render.

A separate window appears with the model rendered.

The fully rendered model.

Add Color to the Flashlight Parts

Render color and texture are object properties that are not visible in wireframe or
shaded mode.

To set the color for the flashlight body:

1 Select the flashlight body.
2 From the Edit menu, click Object Properties.
3 In the Object Properties dialog box, under Render color, click the color swatch.

The Object Properties dialog box.
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4 In the Select Color dialog box, from the Named Colors list, select Red, and
click OK.

The Select Color dialog box.

5 In the Object Properties dialog box, check Highlight.
6 Move the Highlight slider to near the middle of the Small to Big range.
7 Click OK.

To set the lens to be transparent:

1 Select the lens.
2 From the Edit menu, click Object Properties.
3 In the Object Properties dialog box, move the Transparency slider to the right.

Don’t move it all the way to the right or it will disappear completely. You want
it to be a little opaque so you can still see it.

4 From the Render menu, click Render.

The rendered flashlight with color.

Note If you want to save your flashlight image, from the File menu in the Display Window,
click Save As.
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Try on Your Own

Try using some of the following techniques:

• Draw some solids that overlap each other. Try the Add, Subtract, and
Intersection commands on them to cut and join them.

• Change the colors and the highlight, and render in other viewports.
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4 Create a Rubber Ducky
When building models in Rhino, you should first determine which methods should
be used for each part of the project. There are two basic ways to model in Rhino—
free-form and accurate. Some models require more attention to exact dimensions
because they might have to be manufactured or parts may have to fit together.
Sometimes it is the shape of the object, not the accuracy that is important. These
techniques can be merged together to create accurate, free-form shapes.

This exercise focuses only on the free-form, squishy aspect. The exact size and
placement of the objects is not critical. The overall form is the main objective.

The rubber ducky.

You will:

• Create simple surfaces

• Rebuild a surface

• Edit surface control points

• Draw and project curves

• Split surfaces

• Blend between two surfaces

• Light and render the model

When you model the rubber ducky, you will use similar modeling techniques for the
head and the body. In this exercise you will create spheres that will be deformed to
make the shapes.

To start the model:

u Start a new model.
You can use layers to separate your parts, but for this model, it isn’t necessary.

Create the Body and Head Shapes

The body and head of the ducky are created by modifying two spheres. The size and
placement of the spheres doesn’t need to be exact.
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To create the basic shapes:

1 From the Solid menu, click Sphere, then click Center, Radius.
2 At the Center of sphere prompt, in the Front viewport, pick a point.
3 At the Radius ( Diameter ) prompt, pick another point in the same viewport to

create a sphere as shown.
4 Repeat this procedure for the second sphere.

Draw two spheres.

To move a control point on the sphere:

1 Select the large sphere.
2 From the Edit menu, click Point Editing, then click Control Points On.
3 Select a control point and drag it.
4 Click in the Perspective view.
5 Shade the Perspective viewport.

Moving control points creates sharp edges.

Notice that you have sharp edges in the sphere. The spheres you just created do
not lend themselves well to deformation. To make them smoothly deformable,
you have to add control points and thereby the ability to deform smoothly.
Rhino has a command to do this.

6 Click in a viewport to exit shaded mode.
7 Press Esc to turn off control points.
8 From the Edit menu, click Undo.

To make the spheres deformable:

1 Select both spheres.
2 From the Surface menu, click Edit Tools, then click Rebuild.
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3 In the Rebuild Surface dialog box, change the Point Count to 8 for both U
and V.
Change the Degree to 3 for both U and V.
Check Delete input.
Clear Current layer.
Click OK.

Rebuilding the surface adds control over deformation.

The spheres are now deformable. Having more control points allows more
control over smaller parts of the surface. A degree-three surface will have a
smoother shape when deformed.

To modify the body shape:

1 Select the large sphere.
2 From the Edit menu, click Point Editing, then click Control Points On.
3 In the Front viewport use a window to select the control points near the bottom

of the sphere.

Select the control points as shown.

4 From the Transform menu, select Set Points.
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5 In the Set Points dialog box, check Set Z, and click World Coordinates.
6 In the Front viewport, drag the selected control points up.

This will align all of the selected control points to the same z-value (up in Front
viewport), flattening the surface.

Use Set Points to move the control points up in the Front viewport.

7 Adjust the control points at the top of the body using the same technique.

Use Set Points to move the control points down in the Front viewport.

8 Use a window to select the control points at the upper left edge of the body, and
drag them up to form the tail.

Drag two control points in the Front viewport.
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Notice in the Top viewport that two control points are selected, though in the
Front viewport, it looks like only one is selected. This is because the second
control point is directly behind the one you can see in the Front viewport.

In the Top viewport, you can see both points.

9 Window select the control points at the front of the body, and drag them to the
right to bulge out the chest.

Drag out the chest.

10 Window select the control points at the upper right, and drag them up and to the
right.

Adjust the chest up.

Adjust the control points further until you get the shape you want.
11 Shade the Perspective viewport.
12 Press Esc to exit shaded mode.
13 Press Esc to turn off control points.

To create the head:

1 Select the small sphere.
2 From the Edit menu, click Point Editing, then click Control Points On.
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3 Select the control points on the right side and drag them to begin forming the
bill.

Drag control points to form the bill.

4 Select the control points at the top right side and drag down to continue forming
the bill.

Drag the point down to form a forehead.

5 Selecting control points in the Top viewport and drag to make the bill wider.

6 Press Esc to turn control points off.
7 Shade the Perspective viewport.

Separate the Bill From the Head

For the final rendering, the bill must be a different color from the body, so they must
be separate surfaces. You can split a single surface into multiple surfaces many
ways. The following technique is just one.

To make the head and bill two separate surfaces, split it with a curve. It is easiest to
draw a curve in one view and project it to the surface to create a 3D curve.

To create the curve for the bill:

1 From the Curve menu, click Free-form, and then click Interpolate Points.
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2 In the Front viewport create a curve that looks like the red curve below.

Draw a curve in the Front viewport.

To project the curve onto the surface of the head:

1 From the Curve menu, click From Objects, then click Project.
2 At the Select curve(s) to project prompt, in the Front view, select the curve 1

and press Enter.

Project the curve onto the head surface.

3 At the Select object(s) to project onto prompt, select the head 2, and press
Enter.
The curve is projected onto the head.

The projected curve wraps around the head.

4 Delete the original curve.

To split a surface with a curve:

1 From the Edit menu, click Split.



I N T R O D U C T I O N  T O  R H I N O C E R O S

35

2 At the Select object to split prompt, select the head 1.

Split the head with the projected curve to create two parts.

3 At the Select cutting objects prompt, select the new projected curve (2) and
press Enter.

The bill separates from the head.

Create the Ducky’s Neck

The ducky needs a neck. We are first going to make an edge on the surface of the
head and a corresponding edge on the surface of the body so we can create a blended
surface between the two edges.

To create a cutting plane:

1 Select the head.
2 From the Surface menu, click Rectangle, then click Cutting Plane.
3 At Start of cut plane prompt, in the Front view, pick the first point of a line (1)

to define a plane.

Create a cutting plane at the bottom of the head.
(We cheated a bit and moved the head up.)
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4 Toggle Ortho on.
5 At the End of cut plane prompt, select the end point of a line (2) that cuts

through the lower part of the head, and press Enter.

To trim the head with the cutting plane:

1 From the Edit menu, click Trim.
2 At the Select cutting edges ( Options ) prompt, select the cutting plane you

created (1).

Trim off the bottom of the head.

3 At the Select cutting edges ( Options ) prompt, press Enter.
 4 At the Select object to trim ( Options ) prompt, select the bottom edge of the

head (2).
5 At the Select object to trim ( Options ) prompt, press Enter to end the

command.
The bottom of the head will be trimmed.

6 Delete the cutting plane.

The trimmed head.

To cut a hole in the body that matches the opening in the bottom of the head:

1 From the Curve menu, click From Objects, then click Project.
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2 At the Select curve(s) to project prompt, in the Perspective viewport, select
the edge curve at the bottom of the head (1).

3 At the Select curve(s) to project prompt, press Enter.
 4 At the Select Object to project onto prompt, in the Top viewport, select the

body (2) and press Enter.
It is important to project this in the Top or Perspective viewport. The curve is
projected perpendicular to the active construction plane.
The curve is projected to the top and the bottom of the body.

5 From the Edit menu, click Trim.
6 At the Select cutting edges ( Options ) prompt, select the curve at the top of

the body and press Enter.
7 At the Select object to trim ( Options ) prompt, select the body on the inside of

the curve and press Enter.
A hole will be created in the body. If Trim doesn’t work try Split.

It may be difficult to find the isoparm to
pick inside the curve.

The trimmed body.

8 Delete the projected curves.
Use a window in the Front viewport. Occasionally the curve gets broken into
pieces.
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To create the blend surface between the head and body:

1 From the Surface menu, click Blend.
2 At the Select edge to blend - pick near one end ( PlanarSections

Degree=Quintic ) prompt, select the curve at the bottom of the head (1).

3 At the Select edge to blend - pick near one end ( PlanarSections
Degree=Quintic ) prompt, select the curve on the body (2).

4 At the Select seam point to adjust, press Enter when done ( FlipDirection
Automatic Natural ) prompt, check to see that the seam point lines up.
If it doesn’t, select one of the seam points and drag it until it lines up with the
other one.

The direction on one of these curves needs to be flipped.

5 To flip a curve direction, at the Location of seam point ( FlipDirection )
prompt, pick the seam point on the curve you want to flip, then type F and press
Enter.

The direction arrows now point the same way.
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6 At the Location of seam point ( FlipDirection ) prompt, press Enter.
A surface is blended between the body and the head.

The neck blend surface.

To join the parts:

1 From the Edit menu, click Join.
2 At the Select object for join prompt, select the body.
3 At the Select next surface or polysurface to join prompt, select the neck.
4 At the Select next surface or polysurface to join prompt, select the head.
5 At the Select next surface or polysurface to join prompt, press Enter.

The joined head, neck and body.

6 Shade the Perspective viewport.

To make an eye:

1 From the Solid menu, click Ellipsoid.
2 Toggle Ortho and Snap on to help.
3 At the Center of ellipsoid prompt, pick a point in the Top viewport.
4 At the End of first axis prompt, pick a point.
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5 At the End of second axis prompt, pick a point that gives approximately the
same radius as the previous pick.

Create a flattened ellipsoid.

6 At the End of third axis prompt, pick a point in the Front viewport that creates
a flat ellipsoid.

Drag the height in the Front viewport.

To make the pupil for the eye:

To be able to assign a different color for the pupil of the eye, the ellipsoid
surface has to be split into two parts.

1 From the Curve menu, click Circle, then click Center, Radius.
2 At the Center of circle ( Vertical AroundCurve ) prompt, pick the center of the

ellipsoid.
3 At the Radius <1> ( Diameter ) prompt, pick a point in the Top viewport that is

slightly smaller than ellipsoid.
4 From the Curve menu, click From Objects, then click Project.
5 At the Select curve(s) to project prompt, in the Top viewport, select the circle

and press Enter.
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6 At the Select object(s) to project onto prompt, in the Top view, select the
ellipsoid and press Enter.

7 Delete the original circle and the one on the bottom of the ellipsoid.
8 From the Edit menu, click Split.
9 At the Select object to split prompt, select the ellipsoid.

10 At the Select cutting objects prompt, select the circle on the top of the
ellipsoid.

11 At the Select cutting objects prompt, press Enter.

Split the ellipsoid with the projected circle.

To assign a render color to the pupil:

1 Select the surface at the top of the ellipsoid. If it is broken into two halves, join
the pieces together. Make sure the top of the ellipsoid is selected.

2 From the From the Edit menu, click Object Properties
3 In the Object Properties dialog, under Render Color, click the color control

patch and select a render color for the pupil of the eye, like black.
4 Render the Perspective viewport.

To move the eyes to the surface of the head:

1 From the Transform menu, click Orient, then click On Surface.
2 At the Select base surface prompt, select the head.
3 At the Select objects to orient prompt, window select the whole eye and press

Enter.
4 At the Base point on surface ( WorldCoordinates ) prompt, type W and press

Enter.
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5 At the Base point in world coordinates ( OnSurface ) prompt, snap to the
center of the ellipsoid.

6 At the Offset point prompt, move the cursor onto the head to place the eye and
press Enter.

Orient the eye to the head.

7 Shade the Perspective viewport.
8 Mirror the eye to the other side of the head.
9 Delete the extra eye on the floor.

10 Render the Perspective viewport.

Render a Picture of the Ducky

Rendering creates a “realistic” picture of your model with colors you assign. These
render colors are different from the layer colors you might be using, which control
the display in wireframe mode.

To render the ducky:

1 Select the beak.
2 From the From the Edit menu, click Object Properties.
3 In the Object Properties dialog, set a color for the beak, like orange.
4 Select the body.
5 From the From the Edit menu, click Object Properties.
6 In the Object Properties dialog, set a color for the body, like yellow.
7 From the Render menu, click Render.

Add colors to the body and bill.
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To place lights:

1 From the Render menu, click Create Spotlight.
2 At the Base of cone ( Vertical ) prompt, select a point in the middle of the

model.
3 At the Radius < > ( Diameter ) prompt, drag the radius until it is approximately

twice as large as the model.
4 At the End of cone prompt, use elevator mode and two viewports to place the

end of the cone so the light cone shines on the ducky from the upper left side.
5 From the Render menu, click Render.
6 Try placing two lights.

7 From the Render menu, click Render.

Try on Your Own

Try using some of the following techniques:

• Draw a sphere.

• Try editing the control points to create an apple, an orange or a potato.

• Try changing the colors and the highlight.
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• Render one of the orthographic viewports to see the highlight better.

Look at the gallery images

To see what else can be modeled in Rhino, check out the Rhino gallery at
http://www.rhino3d.com.

Build your own models

Try modeling anything you have on your desk or around your house. Come up with
your own designs to model.  Try a few different versions of each idea.
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5 Create a Pull Toy
In the following exercise, you will create a wheeled pull toy.

The completed pull toy.

You will learn how to:

• Enter coordinates to place points exactly

• Draw a curve, polygon, ellipsoid, torus

• Create a pipe along a curve

• Use a polar array to copy objects in a circular pattern

• Extrude a curve to create a surface

Enter Coordinates

In the exercises you have done so far, when you picked a point with the mouse, the
point lay on the construction plane of the active viewport unless you used a
modeling aid such as object snap or elevator mode. Each viewport has its own
construction plane on which its x- and y-coordinates lie. The z-coordinate for the
active viewport is perpendicular to the x-y plane.

When Rhino prompts for a point, you can enter x-, y-, and z-coordinates instead of
picking a point.

The grid is a visual representation of the construction plane. The intersection of the
red and green lines show the location of the origin point (x=0, y=0, z=0) of the
coordinate system.

Draw the Pull Toy Body

This exercise uses x-, y-, and z-coordinates to accurately place points. When you are
to type coordinates, type them just as they are shown in the manual. The format is
x,y,z. For example, type 1,1,4. You must type the commas. This sets the point at
x=1, y=1, and z=4 in the active viewport.

Whenever you type points, look in all viewports at where the point is placed so you
can start getting an idea of how coordinate entry works.

Note Pay close attention to the viewport required in each instruction.
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To start the model:

u Begin a new model.
Use the viewport layout you are comfortable with.

To create an ellipsoid:

1 Turn on Ortho.
2 From the Solid menu, click Ellipsoid.
3 In the Top viewport, at the Center point prompt, type 0,0,6 and press Enter.

This places the center point of the ellipsoid at x=0, y=0, and z=6. Look at the
point in the perspective viewport.

4 At the End of first axis prompt, type 7 and press Enter.
5 Drag the cursor to the right and click to show the direction.

Drag the cursor to the right to show the first axis direction.

6 At the End of second axis prompt, type 4 and press Enter.
This sets the width of the ellipsoid.

7 At the End of third axis prompt, type 4.5 and press Enter.
You now have an egg shape that has different dimensions in all three directions.

8 Rotate the perspective viewport so you are looking along the x-axis as shown.
9 Shade the Perspective viewport.

An ellipsoid is an egg shape.

Draw the Axles and Wheel Hubs

The axles and wheel hubs are cylinders. The axles are long, thin cylinders, and the
wheel hubs are short, fat cylinders. You are going to make one axle and one
complete wheel. You will then mirror the complete wheel to the other side. You can
then either mirror or copy the complete axle and wheel set to the front of the toy.
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To create the axle:

1 From the Solid menu, click Cylinder.
2 In the Front viewport, at the Base of cylinder ( Vertical ) prompt, type 4,3,5

and press Enter.
Look at where this point is. It is four units in the x-direction, three units in the
y-direction, and five units in the z-direction of the active viewport.

3 At the Radius ( Diameter ) prompt, type .25 and press Enter.
4 At the End of cylinder prompt, type 10 and press Enter.
5 In the Top viewport drag the cylinder as shown to place the axle.

Drag up in the Top viewport to place the axle.

To create a wheel hub:

1 From the Solid menu, click Cylinder.
2 In the Front viewport, at the Base of cylinder ( Vertical ) prompt, type 4,3,4.5

and press Enter.
3 At the Radius ( Diameter ) prompt, type 2 and press Enter.
4 At the End of cylinder prompt, type 1 and press Enter.
5 At the next End of cylinder prompt, click in the top viewport to place the hub.

Drag down in the Top viewport to place the wheel.

6 Shade the Perspective viewport.

One hub made.
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Draw the Lug Nuts

You will make the lug nuts by extruding a hexagonal polygon curve.

To create the hexagon:

1 From the Curve menu, click Polygon, and then click Center, Radius.
2 At the Center of polygon ( NumSides=4 Circumscribed ) prompt, type 6 and

press Enter.
3 In the Front viewport, at the Center of polygon ( NumSides=6 Circumscribed )

prompt, type 4,4,5.5 and press Enter.
This will place the polygon right on the surface of the wheel hub.

4 At the Radius prompt, type .25 and press Enter.

We have zoomed in the Front viewport.

To make a solid from the polygon:

1 Select the hexagon you just created.
2 From the Solid menu, click Extrude Planar Curve.
3 At the Extrusion distance ( Direction Cap=yes Bothsides Tapered ) prompt,

notice the command options.
Many commands have options. You will learn how to change and use them as
you learn to use the commands. Take a moment and look at the options available
for Extrude Planar Curve.
Press F1 to look at the Help topic for this command. The Help topic explains the
options.

4 At the Extrusion distance ( Direction Cap=yes Bothsides Tapered ) prompt,
type -.25 and press Enter.
Notice the negative number. If you type a positive number at this point, the nuts
will be buried in the wheel hub. You want them to stick out.
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5 Shade the Perspective viewport.

The lug nut should protrude.

Assign Colors

Now that you have the basic parts built, you are going to assign colors to them
before we start copying them. If we wait until we have all the parts, you will have to
select 20 lug nuts separately. If we assign colors now, the color property will be
copied when we copy the parts.

To assign color to the parts:

1 Select the lug nut.
2 From the Edit menu, click Object Properties.
3 In the Object Properties dialog box, under Render color, click the color swatch

as shown.

Click the color swatch to set object color.

4 In the Select Color dialog box, under Named Colors, click Black and click OK.

The Select Color dialog box

5 In the Object Properties dialog box, click OK.
6 Follow steps 1 through 6 to set a color for the toy body.
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You will be assigning colors to objects as we go along.
7 Render the Perspective viewport.

The wheel and axle look gray because they are
assigned the default white color and are not directly lit.

Array the Lug Nuts

To create the lug nuts on the first wheel, you are going to use a polar (circular) array.
An array is a set of copies of an object. You control how the copies are made. A
polar array copies the objects around a central point. The objects are rotated as they
are copied.

To array the nuts:

1 Select the lug nut.
2 From the Transform menu, click Array, and then click Polar.

The hexagon is still there, so be sure you select the extruded lug nut. (The Select
One Object dialog will list it as a polysurface.)

3 At the Center point prompt, snap to the center of the hub.
4 At the Number of elements < 1 > prompt, type 5 and press Enter.
5 At the Angle to fill <360> prompt, press Enter.
6 Render the Perspective viewport.

Polar array copies objects around a center point.

Draw the Tires

The tires are a solid form called a torus, which looks like a donut. When you are
drawing a torus, the first radius is the radius of a circle around which the “tube” is
drawn. The second radius is the radius of the tube itself.
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To draw the tires, you will draw the center of the torus tube a bit larger than the
diameter of the wheel hub. The tube itself is slightly larger than the hub. This makes
it dip into the hub.

To create a torus for the tires:

1 From the Solid menu, click Torus.
2 In the Front viewport, at the Center point ( Vertical AroundCurve ) prompt,

type 4,3,5 and press Enter.
This places the center of the torus at the same point as the center of the wheel
hub.

3 At the Radius ( Diameter ) prompt, type 2.5 and press Enter.
This makes the center of the torus 0.5 units larger than the wheel hub.

4 At the Second radius ( Diameter ) prompt, type .75 and press Enter.
This makes the hole .25 units smaller than the wheel hub.

5 Set the Color of the tire to Black.
6 Render the Perspective viewport.

Change the color of the tire to black.

Mirror the Wheels

Now that you have a whole wheel created, you can use Mirror to create the other
three.

To mirror the wheel to the other side:

1 In the Top viewport, use a window to select the wheel as shown.

Use a window to select all the wheel parts.

2 From the Transform menu, click Mirror.
3 At the Start of mirror plane prompt, type 0,0,0.
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4 In the Top viewport, with Ortho on, drag to the right as shown and click.

Mirror the wheel in the Top viewport.

5 Shade the Top viewport.

The completed back wheels.

To mirror the front wheels and axle:

1 In the Top viewport, use a window to select the back wheels and axle as shown.

Use a window to select the wheels and axle.

2 From the Transform menu, click Mirror.
3 At the Start of mirror plane prompt, type 0,0,0.
4 In the Top viewport, with Ortho on, drag down as shown and click.

Mirror the wheels in the Top viewport.
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5 Shade the Top viewport.

The completed front wheels.

Draw the Eyes

While drawing the eyes, you are going to practice using elevator mode. You are
going to start the center of the eye spheres in the top viewport and use elevator mode
to move them up.

To create an eye:

1 From the Solid menu, click Sphere, and then click Center, Radius.
2 At the Center point prompt, in the Top viewport hold Ctrl and click near the

front edge of the ellipsoid.

Position the sphere in the Top viewport.

This will start elevator mode.
3 Move the cursor to the Front viewport, drag the sphere near the top edge of the

ellipsoid, and click.

Drag it up in the Top viewport.

4 At the Radius ( Diameter ) prompt, type 1.5 and press Enter.
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5 Render the Perspective viewport.

You now have one eye.

6 In the Top viewport, Mirror the sphere to the other side of the ellipsoid.
Use the same procedure you used to mirror the wheel hub.

7 Render the Perspective viewport.

Mirror the eye.

8 Use the same technique to make two more small black pupils. Make one
Sphere, move it if you have to. Change its color to black and mirror it.

Add pupils.

Make the Pull Cord

To make the cord, you are going to draw a freehand curve using elevator mode.
When the curve is complete, you will use the Pipe command to make it a thick solid.

To create the pull cord at the front of the toy:

1 Zoom out in all the viewports, you are going to need some space to work.
2 From the Curve menu, click Free-form, and then click Control Points.



I N T R O D U C T I O N  T O  R H I N O C E R O S

55

3 At the Start of curve prompt, in the Top viewport, hold Ctrl and click near the
front end of the ellipsoid.

Start a curve.

4 Move the cursor to the Front viewport, drag the curve near the end of the
ellipsoid, and click.
This is similar to the vertical ortho constraint, but lets you draw off the
construction plane.

Use elevator mode to move point up in Front viewport.

5 At the Next point, press Enter when done ( Undo ) prompt, click to the left of
the ellipsoid in the Top viewport.
Use elevator mode to move it up. Watch the curve in the Top and Front
viewports.

Add more points using elevator mode.

Drag up in the Front viewport.
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6 At Next point, press Enter when done ( Close Undo ) prompts, click several
more points to create a curved line. Experiment with elevator mode.
You want a free-form curve.

7 Draw an Ellipsoid to represent a handle at the end of the curve.

Draw a small ellipsoid for the handle.

Make the cord fat:

1 Select the curve you just made from the front of the pull toy.
2 From the Solid menu, click Pipe.
3 At the Starting radius <1> ( Diameter Cap=yes Thick=No ) prompt, type .125

and press Enter.
4 At the End radius <.125> ( Diameter ) prompt, press Enter.

The pipe will be the same diameter for the full length of the curve.
5 Change the cord color to black and the handle color to any color you like.
6 Render the Perspective viewport.

The finished pull toy.

Try On Your Own

Using what you know, try drawing some things of your own. You should be able to
use the basic Rhino commands.
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6 Create Surfaces
You can draw surfaces directly by placing corner points or by drawing a rectangular
plane. However, most surfaces you create in Rhino will be based on a curve or
another surface.

Rhino contains a variety of surface constructions, including free-form surfaces fit to
points, tapered offset surface constructions, rolling-ball fillets, and blend surfaces.

Note When using any of these creation methods, if the curves you are using have kinks, the
result will be a polysurface instead of a surface. You cannot turn on control points for editing
a polysurface.

Create a Surface From Edge Curves

You can create a surface from three or four curves that form the sides of the surface.

The curves.

The surface created from the curves.

To try this command:

1 Open Edge Curves in the Tutorials folder.
2 From the Surface menu, click Edge Curves.
3 At the Select 2, 3, or 4 curves prompt, select the curves.
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Revolve a Curve Around an Axis

Revolving a curve creates a surface by revolving a shape curve about an axis. The
resulting object can be either an open surface or a closed solid depending on whether
or not the shape curve is open or closed and how far you revolve it. In this example,
both endpoints of the shape curve intersect the axis of revolution, so a solid is
created. This is sometimes called lathing.

The profile curve and axis.

The revolved closed polysurface.

To try this command:

1 In the Tutorials folder, open Revolve.3dm.
2 From the Surface menu, click Revolve.
3 At the Select curve to revolve prompt, select the profile curve.
4 At the Start of revolve axis prompt, snap to one end of the axis of revolution

line.
5 At the End of revolve axis prompt, snap to the other end of the axis of

revolution line.
6 In the Rotate Options dialog box, click OK.
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Extrude a Curve Straight

Extrude creates a surface from a curve. If the curve is planar, the extrusion is
perpendicular to the plane of the curve. If the curve is not planar, the extrusion
direction depends on the active construction plane.

Planar curve.

Extruded surface.

To try this command:

1 In the Tutorials folder, open Extrude.3dm.
2 From the Surface menu, click Extrude, and then click Straight.
3 At the Select curves to extrude prompt, select the purple curve, and press

Enter.
4 At the Extrusion distance ( Direction Cap=No BothSides Tapered ) prompt,

drag a distance and click.
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Sweep a Curve Along a Single Rail Curve

Sweeping creates a surface with cross sections that maintain the initial orientation of
the shape curve(s) to the path curve. Note the difference between the surface created
with this method and the previous Extrude example that used the same path curve.

The rail curve and the cross section curve.

The swept surface.

To try this command:

1 In the Tutorials folder, open 1Rail.3dm.
2 Select both curves.
3 From the Surface menu, click Sweep 1 Rail.
4 In the Sweep 1 Rail Options dialog box, click OK.

The Sweep 1 Rail may not be able to decide which curve is the rail and which is
the cross section curve.
Your sweep may look like this:

If this happens, start the Sweep 1 Rail command again and follow the prompts to
select the rail curve and the cross section curve separately.
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Sweep a Curve with Two Rails

Using two rails for a sweep creates a smooth surface through two or more shape
curves that follow two curve rails. The rails also affect the overall shape of the
surface. Use this command when you want to control the location of the edges of the
surface.

Cross section and rail curves.

The swept surface.

To try this command:

1 In the Tutorials folder, open 2Rail.3dm.
2 From the Surface menu, click Sweep 2 Rails.
3 At the Select 2 rail curves prompt, select the two rail curves.
4 At the Select cross-section curves ( Point ) prompt, select the two

cross-section curves, and press Enter.
5 In the Sweep 2 Rails Options dialog box, click OK.

Or, click Shaded Preview and then click Preview.
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Revolve a Curve With a Rail

Rail Revolve creates a surface by revolving a profile curve around an axis while at
the same time following a rail curve. This is basically the same as a Sweep Along 2
Rails, except one of the rails is a central point.

The profile curve, path curve, and revolve axis.

The revolved closed polysurface.

To try this command:

1 In the Tutorials folder, open RailRev.3dm.
2 From the Surface menu, click Rail Revolve.
3 At the Select profile curve prompt, select the profile curve.
4 At the Select path curve prompt, select the path curve the revolve will follow.
5 At the Start of revolve axis prompt, snap to an endpoint of the revolve axis

line.
6 At the End of revolve axis prompt, snap to the other end of the revolve axis

line.
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Loft a Surface Through Curves

Lofting creates a smooth surface that blends between selected shape curves. This
surface looks similar to the example in the next section, “Sweep a Curve with Two
Rails,” but is created without rail curves. Instead, the edges of the surface are created
by fitting smooth curves through the shape curves.

Curves to loft.

The lofted curve.

To try this command:

1 In the Tutorials folder, open Loft.3dm.
2 Select the three curves.
3 From the Surface menu, click Loft.
4 In the Loft Options dialog box, click OK.

Or, try some of the Style options, click Shaded Preview, and then click
Preview to see the various loft styles.

When to Use Loft and When to Use Sweep

A surface created with Loft normally has no creases. Unless the cross-cross section
curves have kinks, the surface is smooth. The Straight sections style of loft creates
shapes with creases at shape curves and straight lines connecting the shapes. This is
sometimes called a ruled surface.

If you find yourself adding lots of extra shape curves to make the shape you want,
you might want to use Sweep 1 Rail instead. The rail curve directs the surface
along it.
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If you are having trouble getting the edges of a loft or one-rail sweep to go where
you want, use a Sweep 2 Rails. The two-rail sweep lets you select the
surface’s edges.

Blend a Surface Between Two Surfaces

You can create a blend between two surfaces that will smoothly meet at the
surface edges.

Two surfaces.

A surface blend between the two surfaces.

To try this command:

1 In the Tutorials folder, open BlendSrf.3dm.
2 From the Surface menu, click Blend.
3 At the Select edge to blend - pick near one end ( PlanarSections

Degree=Quintic ) prompt, select an edge to blend.
4 At the Select edge to blend - pick near one end ( PlanarSections

Degree=Quintic ) prompt, select the edge on the other surface.
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Offset a Surface

You can offset a surface a specified distance to create a new surface.

A surface.

The new surface is offset two units.

To try this command:

1 In the Tutorials folder, open OffsetSrf.3dm.
2 Select the surface.
3 From the Surface menu, click Offset.
4 At the Offset distance prompt, type 2.

The surface is offset in the direction of the surface normal.
To view the direction of the surface normal, select the surface, and then from the
Analyze menu, click Direction.

Other Ways to Create Surfaces

Rhino includes many other tools for creating surfaces. In addition to a blend, you
can create fillets or chamfers between two surfaces. You will learn some of these by
going through the exercises. Others are designed for special tasks. See the topics
Draw Surfaces in Help.
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7 Features

Features

Rhino can create, edit, analyze, and translate NURBS curves, surfaces, and solids in
Windows. There are no limits on complexity, degree, or size.

Features include:

User interface: extremely fast 3-D graphics, unlimited viewports, working
perspective views, coordinate read-out, named views, named construction planes,
customizable icons and toolbars, extensive on-line help, electronic updates,
newsgroup support.

Construction aids: unlimited undo and redo, exact numeric input, object snaps, grid
snap, ortho, planar, construction planes, layers, background bitmaps, object
hide/show, object lock/unlock.

Create curves: point, line, polyline, free-form curve, circle, arc, ellipse, rectangle,
polygon, helix, spiral, conic, TrueType text, point interpolation, control points
(vertices), sketch.

Create curves from other objects: extend, fillet, chamfer, offset, blend, from 2
views, cross section profiles, intersection, contour, section, border, silhouette,
extract isoparm, projection, pullback, sketch, wireframe, detach trim, create 2-D
drawings, flatten developable surfaces.

Edit curves: control points, edit points, handlebars, smooth, fair, change degree,
add/remove knots, add kinks, rebuild, refit, match, simplify, change weight, make
periodic, adjust end bulge, adjust seam.

Create surfaces: from 3 or 4 points, from 3 or 4 curves, from planar curves,
rectangle, extrude, ribbon, rule, loft, sweep along a path, sweep along two rail
curves, revolve, rail revolve, blend, patch, drape, point grid, heightfield, fillet,
chamfer, offset, TrueType text.

Edit surfaces: control points, handlebars, change degree, add/remove knots, match,
extend, merge, join, untrim, rebuild, shrink, make periodic, Boolean (union,
difference, intersection).

Create solids: box, sphere, cylinder, tube, pipe, cone, truncated cone, ellipsoid,
torus, extrude planar curve, extrude surface, cap planar holes, join surfaces,
TrueType text.

Edit solids: fillet edges, extract surface, Booleans (union, difference, intersection).

Create polygon meshes: from NURBS surface, from closed polyline, mesh face,
plane, box, cylinder, cone, and sphere.

Edit polygon meshes: explode, join, weld, unify normals, apply to surface.

Edit tools: cut, copy, paste, delete, delete duplicates, move, rotate, mirror, scale,
stretch, align, array, join, trim, split, explode, extend, fillet, chamfer, offset, twist,
bend, taper, shear, orient, flow along curve, smooth, project, object properties.
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Analysis: point, length, distance, angle, radius, bounding box, normal direction,
area, area centroid, area moments, volume, volume centroid, volume moments,
curvature graph, geometric continuity, deviation, naked edges, nearest point.

Rendering: flat shade, smooth shade, render with textures, spotlights and shadows,
and customizable resolution.

File formats supported: DWG, DXF, 3DS, LWO, STL, OBJ, AI, RIB, POV, UDO,
VRML, BMP, TGA, JPG, IGES (Alias, Ashlar Vellum, AutoShip, Breault,
CAMSoft, Catia, Cosmos, FastSurf, Intergrity Ware, MasterCAM, ME30,
Mechanical Desktop, Microstation, NuGraf, Pro/E, SDRC I-DEAS, Softimage,
Solid Edge, Solidworks, SurfCAM, TeKSoft, Unigraphics).

File management: Notes, templates, merge files, and export selected objects.

I/O plug-ins: 3D Studio MAX, Softimage, and programmer’s I/O tool kit with
source code.

3-D digitizing support: MicroScribe 3D and Faro Space Arm.

Rhino is a Companion to Other Design Programs

Rhino is designed for designing and creating 3-D models. Although it has some
rendering capabilities that can be quite useful, this is not Rhino’s primary function.
In addition, Rhino you cannot generate 2-D drawings with annotation and
dimensioning; you must import your model into a CAD program to accomplish that
task.

Rhino is a companion for other modeling and rendering software. Rhino gives you
full support for trimmed NURBS surfaces, a robust IGES translator, and a
streamlined interface that lets you model quickly. Rhino’s free-form modeling
complements:

• Parametric feature-based modelers

• Rendering and animation software

• Computer-aided manufacturing (CAM) software

• Finite element analysis (FEA) software

Technical Support and Additional Documentation

One of the most important learning methods for Rhino is to try the commands on the
menu and to read the description of the command in the Help.

Rhino Help

Rhino commands are documented in Rhino Help. If you have a question about a
specific command, look first in Help. Many topics such as importing and exporting
Rhino models to other software, using a digitizing arm, tracing bitmaps to create
curves, and using Rhino analysis tools are only documented in Help.
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To access Help:

u From the Rhino Help menu, click Help Topics or Command List.
Or, press F1.

The Rhino Web Site

The Rhino Web site contains a gallery of images, short examples, white papers on
technical issues, links to Rhino related web sites, and news about Rhino. Connect to
the Rhino Web site at the following location: www.rhino3d.com

To connect to the Rhino Web site directly from Rhino:

u From the Rhino Help menu, click Rhino Web Site.

The Rhino Newsgroup

Ask questions about using Rhino and get answers from other users and Rhino
technical support at the following newsgroup location:
news://news.rhino3d.com/rhino

To connect to the newsgroup directly from Rhino:

u From the Rhino Help menu, click Rhino Technical Support.

Technical Support

Technical support is also available via e-mail.

E-mail: rhino@mcneel.com

Ordering information

The Rhino Web site contains ordering information. You can order from a dealer in
your local area. Connect to the Rhino Web site at the following location:
www.rhino3d.com/sales


