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USING THE PAGESUITE LINK

Readiris and the
Microtek

PageSuite software
This short manual discusses how to use the OCR package Readiris with the

Microtek PageSuite scanning platform. It contains all you need to know to get
started with this I.R.I.S. product successfully using a Microtek PageWiz scan-
ner.

This manual does not intend to replace the PageSuite or Readiris User's Guide.
To make full use of the many advanced capabilities of these software packages,
it is mandatory that you study their comprehensive user documentation closely.

INSTALLING READIRIS UNDER PAGESUITE

The Readiris software is delivered exclusively on an autorunning CD-ROM.
To install, simply insert the CD-ROM in your CD-ROM drive and wait for the
installation program to start running. Follow the on-screen instructions.

What additional steps are required to install Readiris under PageSuite? Start
the PageSuite software and click the "Setup" button on the toolbar to select
Readiris as your OCR tool. (You can also select the command "Setup Panel"
under the "Edit" menu to do so.)

You are given access to the "Preferences" window. When Readiris is set up
correctly, your "Preferences" window looks like this.
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Click the OCR button on the left and select the option "Customized" as your
OCR application. Next, enter the full path name of Readiris' PageSuite link or
click the browse button to select Readiris.

The PageSuite link is the file RDIPGWIZ.EXE in your Readiris folder.
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You can now click "OK" to quit this window. Readiris is set up as your OCR
tool.

STARTING UP THE PAGESUITE SCANNING SOFTWARE

Start the PageSuite software by clicking the corresponding icon. There should
now be two icons on the Windows taskbar: one for the PageSuite software and
one for the PageWiz Controller. (The latter icon indicates if your PageWiz scan-
ner is available or not.)

When the PageSuite desktop is displayed, you will notice that the OCR icon
is included in the device icons.
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“Drag and drop” is how you do things with the scanned images: to OCR a
document, it suffices to drag the image thumbnail onto the OCR device and the
scanned document will be converted into editable text. (You can also select a
document and just click on the OCR device icon or select a document and click
the command "Send to OCR" under the "File" menu.)

OCR device icon
Device icon bar

Image thumbnail Toolbar
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SETTING YOUR SCANNER FOR READIRIS

To get good OCR results, it is essential that you scan your documents with
the correct settings. Click the "Settings" button on the toolbar or select the com-
mand "Scanning Setting" under the "File" menu to verify this.

The scanning settings are displayed by default.

The correct scanning settings for OCR are displayed above. Select "Plain
Text" as "Document Content" option to ensure that you generate black-and-white
images (lineart or “single level” scanning). It is imperative to leave the bit depth
on one: Readiris only accepts black-and-white images.
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You are given more information on color modes when you click the button
"Advanced".

The user is recommended to enable the option "Adaptive Threshold": that
image enhancement technology provides higher quality images by erasing col-
ored backgrounds etc.

Secondly, select the output quality "ExtraFine". Doing so ensures that you
scan the images at the maximal resolution of 300 dpi. You are not recommended
to use the output quality modes "Fine" and "Normal", which use a lower resolu-
tion. Use these settings for “rough” black and white images which you want to
archive, fax etc. Such images do not provide enough detail and quality to guaran-
tee good OCR.

Which page format you select depends on the documents you want to scan.
You can select the document size "Other" for all circumstances, as this setting
applies autocropping to your documents: dark borders around the actual docu-
ment will be erased automatically.

Don't forget to set the brightness correctly! As PageSuite generates the im-
ages which are then passed on to the target application, it is here that all scan
settings must be adjusted for optimal results.
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Finally, don't forget to calibrate your scanner before using it! You are prompted
to do this when you first start up the PageSuite software, but you can always
correct the calibration data from your desktop by clicking the button "Image
Adjustment" in the advanced scan settings window.

READIRIS OFFERS FULL FLEXIBILITY!

You are by no means limited to recognizing full pages as you scanned them.
In fact, Readiris offers full control and high flexibility to the PageSuite user.

Thanks to Readiris zoning capabilities, you can limit the recognition to spe-
cific parts of a scanned page. You can for instance scan columnized pages from
a magazine and OCR a single column. And OCRing the first half of the left
column, a single paragraph in the middle column and the lower half of the right
column is accomplished with the same ease!

Furthermore, Readiris allows you to indicate the document's language - no
less than 52 languages are supported - and allows you to execute font training
to increase the OCR accuracy even more.

Let's see how all this works. When you drop an image thumbnail on the OCR
device icon on the device icon bar, Readiris is started up automatically and dis-
plays the scanned image. Page analysis is used to detect the various text blocks.
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As the system now stops, you can use all controls that Readiris offers to fine-
tune the operation of the OCR software. Where the page analysis has detected
three blocks, you can select only some for recognition with the "Sort" button. Or
even erase all blocks and start from scratch by drawing windows around the text
blocks of interest yourself.

You can also create font dictionaries to train the system on specific fonts,
complete and activate existing font dictionaries to make good use of previous
learning, define the document's language or limit recognition to numeric sym-
bols when reading tables of figures, indicate you want to read dot matrix print-
ing, have the layout of the source document recreated automatically etc.
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Please refer to the Readiris manual to discover how fully featured and user
controllable the Readiris software actually is!

There's one element the user has to take care of: defining where he'll take the
output. You can create text files in all common text formats and copy the recog-
nized text to the Windows clipboard. Refer to the Readiris User's Guide to learn
how you are given full control over the output results.

When you click the button "Recognize", the recognition is executed - with or
without learning; when the recognition is completed, you are prompted to save
the results.

You are recommended not to specify a file extension for the text file, it will
be added automatically. Which file extension will be used depends on the text
format you selected for the output text with the "Format" button on the main
toolbar of Readiris.

When you click "OK", you return to the PageSuite desktop automatically.
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AUTOMATIC RECOGNITION

This mode of operation offers full control over all settings. However, you can
also execute automatic OCR of full pages.

It's all very simple: disable the option "View after Scan" under the "Prefer-
ences" menu of Readiris and save the default settings with the command "Save
Default Settings" under the "File" menu. As soon as you drop an image thumb-
nail on the OCR device icon, the image is exported and recognized promptly -
page analysis is used to detect the text blocks.

RECOGNIZING TABLES

Readiris not only allows you to recognize texts but also tables of figures.
Drop the scanned table onto the OCR device icon to execute recognition.

The Readiris User's Guide tells you how to window tables correctly - how
you do this depends on the table's appearance - and how to limit the recognition
to numeric symbols.
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IMPORTING PRESCANNED IMAGES AND FAXES

There's another way to OCR documents: importing prescanned images onto
your PageSuite desktop.

The "Open" button on the toolbar and the command "Open" from the "File"
menu allows to import prescanned images in various formats.
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The original format has no relevance as the import converts them into
PageSuite files anyway. The color mode on the other hand is relevant: don't
forget that Readiris only accepts black-and-white images.

Another possibility to import documents is dragging an image file onto the
PageSuite icon.

The major application is undoubtedly importing faxes! Recognizing them
with Readiris is certainly an option.
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WHAT ABOUT STACKS OF PAGES?

Let's turn to some specific questions now. Can we recognize stacked pages?
We can: Readiris will process the pages one after the other and write the recog-
nized text to a single output file. You are only asked to specify the filename for
the text output at the end of the OCR batch!

WHAT ABOUT ANNOTATIONS?

PageSuite documents can be annotated: highlighting is applied, pen strokes,
text notes and arrows are added etc., all this is part of PageSuite's capabilities.
What happens when you try to recognize an annotated page?

These annotations do not prevent recognition, but are not taken into account
by Readiris. If a text was annotated, Readiris will recognize the original image
without the annotations.

CLOSING YOUR APPLICATIONS

PageSuite starts up your applications when needed, but doesn't close them
again! Don't forget to close the applications which are no longer used.

To quickly access applications, you can always click on the button represent-
ing them on the taskbar.

A much better way of proceeding is this: use the key combination Alt+Tab to
browse through your open applications. This will allow you to close them one
after the other quickly.



16

ERASING SUPERFLUOUS IMAGES

When you scan documents with the objective to OCR them, the scanned im-
ages are no more than a temporary “vehicle”; they can be discarded from the
PageSuite desktop.

Don't forget that all scanned images remain on the PageSuite desktop until
the user decides to erase them. Unless you have good reasons to archive the
images with PageSuite, you should delete superfluous images from your desktop
to save disk space. Drop them onto the trashcan icon in the device icon bar or
select the command "Delete" from the "Edit" menu.

MAKING OPTIMAL USE OF PAGESUITE

This concludes our overview of the Readiris link for the PageSuite software.
Some additional information is given below on PageSuite functions which

can be useful to the operation of Readiris. I.R.I.S. recommends you to make use
of them given the right circumstances.

Buttons are available on the toolbar to access these commands quickly.
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Rotate Left, Rotate Right and Flip
The "Rotate Left", "Rotate Right" and "Flip" buttons and the corresponding

commands from the "Desktop" menu allow to modify the original orientation of
the scanned documents.

Readiris is also equipped with rotation functions.

Invert
The "Invert" button from the "Desktop" menu and the corresponding com-

mand from the "Desktop" menu inverts the image: black “pixels” become white,
white “pixels” become black. As a result, white text on a black background be-
comes legible.

SOME FILE MANAGEMENT

Let's end with the boring stuff: file management! The following file specifi-
cally concerns the PageSuite link.

Readiris Folder
RDIPGWIZ.EXE PageSuite link
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