
Introduction to PolyView

Welcome to PolyView, Polybytes’ high performance image viewer and format conversion tool for 
Windows 95 and Windows NT. PolyView’s major features are:

· Supports most of the popular graphics image formats , including BMP, GIF, JPEG, PCX, 
Photo-CD (read-only), PNG, TARGA, TIFF, and many others.

· Sophisticated support for animated GIF creation and playback.
· TWAIN support for acquiring blocks of images from scanners and digital cameras.
· Multiple threads enhance usability and allow time consuming operations, such as image file 

reading and writing, to be performed in parallel with user interface operations.
· Both full screen and windowed slide shows , using specified or random ordering.
· A wide variety of image appearance manipulation and filtering operations.
· Highly effective interpolated zooming .
· Sophisticated color resolution and image size manipulation algorithms.
· Thumbnail and directory browsers for image file management.



PolyView Registration

PolyView is distributed as shareware. This allows you to try it out to determine if it fits your needs. If 
you decide you like PolyView and intend to keep it and use it, you are obligated to register with 
Polybytes. The current registration rate for PolyView is:

Single user license: $20.00 US

A single user license is a license to use PolyView on one machine at a time. If PolyView is to be 
installed and used on multiple machines simultaneously, then multiple single user licenses should be 
purchased.

Registration Benefits
Registered users receive a license key number from Polybytes that enables several features of 
the program not accessible to non-registered users. These features include:

· Export of images to formats beyond simple BMP, GIF, and JPEG
· Multiple image file select from the file open dialog
· Printing images
· Storing of user supplied text in certain exported or saved image files

When the registration key is received, execute the Licensing Information dialog under the 
Registration menu to enter the key information. It is important to enter the information exactly as 
received from Polybytes.

A user registration and the associated key does not expire and will work with all future versions 
of PolyView. The user registration information is stored in the Windows Registry. If for some 
reason this information is lost from the registry, simply run the Licensing Information dialog and 
re-enter the key information.

Registration Restrictions
Registered users are required to abide by the provisions of the licensing agreement with Unisys 
Corporation concerning the usage of LZW-GIF/TIFF compression/decompression technology.

Registering Directly With Polybytes
You can register PolyView by sending an order form along with a check or money order for the 
registration amount (in US$ please) to:

Polybytes
3427 Bever Avenue S.E.
Cedar Rapids, Iowa 52403-3161
USA

Registration checks sent directly to Polybytes should be made payable to Polybytes.

Registering Through Kagi Shareware
Registrations for PolyView are also handled by Kagi Shareware services. Kagi Shareware can 
process payments in many forms, including personal checks, foreign currency, and a variety of 



credit cards. In addition, online WWW, electronic mail, and FAX registration services are 
available from Kagi Shareware. To register while online simply point your browser to

http://order.kagi.com/?LR 
For email or FAX registration the companion Register program provides access to Kagi 
Shareware registration services. To run Register, choose the Register Now option from the 
Registration menu.

To contact Kagi Shareware for information about their service point your WWW browser to 
http://www.kagi.com.

Registering Through CompuServe
CompuServe users can use the CompuServe Shareware Registration service to register for 
PolyView. There is an additional $2.00 charge for registration via this means. GO SWREG to 
access the service and use ID 10664 to register PolyView.

Please be sure to include your electronic mail address with your registration so that we can provide you 
with more timely information about PolyView. Registration key information is sent to registered users 
via electronic mail if your electronic mail address is available. Otherwise the information will be sent via 
the US Postal Service.



Support and Availability

Support
All PolyView support is handled by Polybytes through electronic mail. Our support address is:

support@polybytes.com

We encourage you to write to us if you have bugs to report or suggestions for additional 
features. (Whether or not you are a registered user.) Every effort will be made by Polybytes to 
provide satisfaction. If you have image files in formats supported by PolyView which are not 
reading correctly, please tell us about them. We can provide the best service in this regard if the 
problem images are made available to us. You can either attach them to an email message, tell 
us the address of the FTP or WWW site where they can be accessed, or mail them to us on a 
disk. Our mailing address is:

Polybytes
3427 Bever Avenue SE
Cedar Rapids, Iowa 52403-3161

Availability
To see the latest information about PolyView, or to download the most current version, visit our 
WWW page at:

http://www.polybytes.com



Release Notes
2.90.4

Brightness, Contrast, Gamma, and RGB adjustment operations from the Operations menu now 
provide an instant update feature to continuously update the image appearance as the slider 
position is changed.

The keyword selection logic now supports an AND NOT operation to exclude keywords from a 
search.

Mouse wheel support in the Explore window now scrolls the pane the mouse cursor is currently 
positioned on rather than only the pane that has the input focus.

Added 1 bit/pixel uncompressed bitmaps to Format Conversions choices.

Corrected a problem with reading X-window dump (XWD) images.

2.90.3
Added support for reading FlashPix images.

Added image rotation to the Browse window.

Added support for playing sound files during a slide show. (This first version has no interactive 
support. Manual editing of the slide show script files is required.)

Added support for displaying transparencies in GIF images, and full support for displaying 
transparencies and alpha channel information in PNG images. See the Display Image 
Transparencies option on the General tab of the Properties dialog.

The number keys 1-4 have been added as shortcuts for sending images to the first through 
fourth “Open With” applications.

Changed the TWAIN operation shortcut keys to F3 to avoid a conflict with the Rename operation 
on F2.

Corrected the default copy/move mode when using the left mouse button to drag/drop images 
and folders in the Explore window.

Fixed a problem with displaying incorrect file dates in the Browse window.

Fixed a problem with creating new folders beneath unexpanded folders in the Explore window.

Fixed a problem with rotating large 1 bit/pixel images.

2.90.2
Added the Windows Desktop as the root node in the Explore window tree and the directory 
picker dialog used by various functions.

Improved the startup speed for the Explore window when dealing with large thumbnail 



databases.

Enhanced the Explore window to keep open folders open after refresh and other operations.

Added the standard Alt+Enter mechanism for soliciting an image’s properties in the Explore and 
Browse windows.

Fixed a problem with matching thumbnails for files created on the opposite side of a daylight 
savings time change boundary. (This problem only shows up on Windows NT NTFS drives when 
NT’s “Automatically adjust clock for daylight savings changes” option has been enabled from 
the Control Panel Date/Time Properties applet.)

Fixed a problem with the interpretation of monochrome GEM IMG files.

Fixed various problems with PNG file reading.

Fixed initial display update problems when performing automatic gamma adjustments on file 
open.

Fixed a problem with reading certain color mapped IFF images.

2.90.1
Improved the display of images with greater than 256 colors (greater than 8 bits/pixel) on 
systems configured for 256 colors. This also improves the quality of images written to GIF and 8 
bit/pixel BMP files under some circumstances.

Fixed a problem with the display and manipulation of certain monochrome images that resulted 
in a negative image being rendered.

2.90.0
PolyView’s help system has been significantly rewritten with this release. In addition, “What’s 
This?” help has been added to all property pages and dialogs. With this feature you can click on 
the “?” button on a window’s title bar and then click any control in the window to get additional 
help information.

Added image browsing and thumbnail filtering by keyword. See the Browsing by Keyword topic 
for an overview. 

Added thumbnail printing from the Explore window.

Added methods of building an image window containing the print format of all or selected 
images in the thumbnail pane of the Explore window and the Thumbnail Database Explorer. The 
resulting window can subsequently be saved to any supported file format. See the notes 
accompanying the Print Thumbnails To Window command on the File menu for further 
information.

Added drive independent mapping of thumbnails to the Explore Window. This option, which is 
enabled via the Thumbnails tab of the Properties dialog, causes the name matching algorithms 
to consider a thumbnail as matching an image if its path, size and date match the image, but 
regardless of which drive letter that path is assigned to. Note: turning this option on may cause 



unexpected behavior when image files are stored on more than one drive. See the notes 
accompanying the Thumbnails tab for further information.

Added the Thumbnail Database Explorer for off-line thumbnail database manipulations. In 
conjunction with this addition, the thumbnail database format has been modified to hold the 
volume name and image dimensions of each image. The image dimensions are now shown on 
the status line and tool tip display of the image file name. The volume name is used by the 
Thumbnail Database Explorer for thumbnail database organization. Note that thumbnail 
databases manipulated by this version of PolyView are not readable by previous versions of 
PolyView.

Added file size and page count (for multiple page files and animated GIFs) to the information 
status line for open images and thumbnails.

The thumbnail database is now written to disk after each thumbnail creation operation has been 
completed.

Added middle/wheel button support for panning operations when viewing images.

Added mouse wheel support for scrolling within images, scrolling the thumbnail panes, moving 
around in slide shows, and zooming in and out of images.

Added a command line option to rotate argument images after decompression.

Added a method of associating an arbitrary list of file types with PolyView in the Register File 
Types dialog.

The directory browser now supports viewing only image types (View menu).

The files displayed in the Explore window can now be filtered to a set that contains a specific 
string in the file name (View menu).

Added the capability of sorting the thumbnail display by image size, where image size is the 
total number of pixels in an image.

Added enhanced metafile objects as a supported clipboard object type for pasting. This allows 
PolyView to retrieve picture items copied to the clipboard from popular word and drawing 
processor applications.

Added an option to the Browsing tab of the Properties dialog to start a slide show from the last 
image displayed in a slide show, from the image selected in the slide show dialog, or from the 
last image selected in a Browse or Explore window.

Slide show script files can now use relative addressing for file paths, with the base for a file 
name the folder containing the script.

The last directory used to open or save a slide show script file is now used as the starting point 
for a subsequent open or save script file operation.

Added a command to the Windows menu to raise all image windows above other PolyView 



windows. This command is useful to raise images above the Explore and browser windows.

Added the specification of JPEG quality to the Export Image dialog box.

PolyView’s setup program is now built with a different tool set than previous versions. All the 
“DelsL*.isu” files in the PolyView installation directory can be deleted, as they are remnants of 
the previously used system.
 
Windows 95 and Windows NT shortcuts to images are now resolved when opening or browsing 
files, or when viewing thumbnails in the Explore window.

The Open With selection on various context menus now detects when the application to be 
executed is a “legacy” 16 bit application. In this case a DOS compatible version of an image’s 
long file name is passed to the application.

Enhanced the path selection algorithms to correctly establish the previously used folder when it 
was found under the “Network Neighborhood” folder.

Updated Portable Network Graphics (PNG) support code to improve gamma handling for 16 bit 
sample sizes, and to cure some low-probability compression problems.

Added sort columns and file icons to the Browse window.

Added a “flat” toolbar button option to General tab of Properties dialog.

Added the TWAIN acquire to multi-page format option to the Files tab of the Properties dialog to 
create multi-page TIFF and DCX files during TWAIN acquire operations.

Added the Area Color Average command to the Operations menu. This command is active only 
when the Area Selection Tool has been used to outline an image area for subsequent area 
operations.

Added a command to the Browse menu to empty the marked file list.

Files on the marked file list are now automatically removed when they are deleted by various 
PolyView operations.

Minor speed improvements have been made to the JPEG decompression algorithm.

Enhanced the GIF file read/write capabilities to include 1 bit/pixel images.

Pressing the Tab key now changes the keyboard input focus between the folder tree and the 
thumbnail panes in the Explore window.

The keyboard arrow keys now move the current selection in the thumbnail pane of the Explore 
window.

The Enter key now opens the currently selected thumbnail when the keyboard input focus is in 
the thumbnail pane of the Explore window.



The source and destination paths for the Format Conversions window are now saved separately 
from    the paths for opening and saving (exporting) image files.

The Show Hidden File property now also controls the display of hidden folders in the Explore 
window and folder selection dialogs.

Added the Default Comment for Saved or Converted Files field to the Files tab of the Properties 
dialog.

The directory path used in the last Open Database command in the Explore window is now 
saved for use as the starting point for the next Open Database command.

Moved all image manipulation commands from an image’s Options menu to the new Operations 
menu.

Changed the name of the Zoom Out command on the View menu to be Undo Zoom and added 
Zoom Out as a command that reduces image magnification.

Added a property on the Files tab of the Properties dialog to control the viewing of hidden files in 
the Explore and Browse windows.

The Rename dialog now defaults the new name to the original name, reducing the typing for the 
common case where only a simple change is desired to the original name.

Successful entry of license information now automatically disables the splash screen.

Fixed a problem which sometimes led to the wrong folder being selected in a drag operation in 
the Explore window.

Fixed some problems in the thumbnail printing algorithms that caused pagination differences 
between the print preview screens and the printed output.

Fixed a problem which caused the image name to be wrong for the current image after an 
aborted file Move operation.

Fixed a problem with incorrect color mapping on 2 bit/pixel grayscale PNG format images.

Fixed a problem with incorrect handling of masked Commodore-Amiga IFF images.

Fixed a problem with incorrect handling of uncompressed type 1 MSP images.

Fixed a problem with reading/writing certain 1 bit/pixel Adobe Photoshop (PSD) images. (A new 
snbd6w9s.dll version is supplied with this update.)

Fixed some problems that occurred in various file list collection dialogs when the Windows 
Explorer is directed to “Hide file extensions for known file types”.

Fixed a problem that caused negative image displays and printing when certain inverted 



colormap monochrome images were processed.

Fixed a problem with the Open With operation that left process handles open.

Fixed various problems with Animated GIF creation.

Fixed a problem which prevented the Add All button on the Slide Show dialog from functioning 
when the Desktop folder was selected.

Fixed a problem with converting 1 and 4 bit/pixel files to JPEG format.

Fixed a problem that caused a crash when defining a selection region with boundaries outside 
the edges of an image.

Fixed problems with animated GIF playback.

Fixed a problem with thumbnails created from 4 bit/pixel images.

Fixed a problem with crashes caused by certain types of corruption in PCX file headers.

Fixed a problem with thumbnail updating after modified images were saved as a result of a 
prompted file close operation.

Fixed a problem which caused a PolyView crash if the color table in an image was larger than 
the number of colors indicated by the images bits per pixel ratio.

Fixed a problem with displaying YCCK encoded JPEG files.

Fixed a problem that caused incorrect updates to the thumbnail pane when the Explore window 
was horizontally resized.

2.80
Added an animated GIF creation command to the File menu. Automatic playback of animated 
GIFs will occur based on a setting in the General tab of the Properties dialog.

Added support for acquiring images from scanners, digital cameras, and other devices 
supporting the TWAIN interface. See the TWAIN topic of the File menu.

Added an Open With command to the image context menus. The Open With tab of the 
Properties dialog can be updated with the names of up to 4 applications to open PolyView 
images with for further processing. 

Added recursive (include subfolders) thumbnail creation operations to the Thumbnails menu.

Added new/move/copy/rename/delete operations on folders to the Explore window.

Added the Next Page, Previous Page, and Go To Page commands to the View menu for moving 
around in multi-page DCX, GIF, and TIFF files.    With this change we also disabled the 
automatic assembly of tiled TIFF files to better deal with very large images (the primary purpose 



for tiled TIFFs). Tiled TIFF files are now handled like multipage TIFF files. (If requested, an 
option to assemble a tiled TIFF into a complete bitmap image can be added to a future version 
of PolyView.)

Added the option to append additional pages to DCX and TIFF files if export of these formats is 
specified to go to an existing file.

Added    X,Y position of the mouse cursor on the current image to the status line.

Added window arrangement commands to the Window menu.

Added a command to the Window menu to close all image windows.

Added a global Gamma adjustment factor capability to the Gamma Adjustment dialog.

Added the RGB Adjust command to the Appearance popup of the Options menu to implement 
precise control of the red-green-blue components of an image.

Added new image Brightness and Contrast Adjustment menus to the Options menu.

Changed the Register File Types operation to use a separate File Description for each file type.

The Register File Types dialog now programs .PVX and .PVD thumbnail database files to 
directly invoke the Explore window.

Added a choice of icons to the Register File Types dialog for use in the Windows Explorer.

Added the F2 key as a shortcut to the rename operation in the Explore and Browse windows.

Added an option to the File Properties Tab of the Properties dialog to add TWAIN files to the 
current slide show list as they are acquired.

Added a command to Browse Selected Folder to the Browse menu of the Explore window.

Added Delete and Browse options to the tree context menu in the Explore window.

Added Move and Rename operations to those available with an open image.

Added a command to the Options menu of the Explore window to set the font used to display file 
names for files which do not have thumbnails.

The title used for windowed slide shows is now the name of the script file which defines the slide 
show.

Added an option to the Browsing tab of the Properties dialog to disable screen savers while a 
full screen display is in progress.

Added an option to the Files tab of the Properties dialog to enable the stripping of the path and 



extension from the image file name as displayed in the window title for the image.

Fixed a problem which caused thumbnail information to be inaccurate after a File Save or 
Export operation.

Fixed a problem which caused hidden thumbnails to become unhidden after a thumbnail 
database Maintain operation.

The Directory Browser no longer resets the selected file position when a file is deleted.

The Move and Rename operations of the Browser window now also rename and move the 
associated image thumbnails if the Explore window is open.

Fixed a problem which caused an access violation if the last file in the list presented by the 
Directory Browser was deleted.

Fixed a problem with Delete key handling during in-line editing of folder names in the Explore 
window and in various edit boxes.

Added additional exception handlers to better deal with low memory situations.

Fixed a problem with pasting clipboard device independent bitmaps which are 24 bits-per-pixel 
and contain a non-empty color map.

Fixed a problem with the decompression of 4 bits-per-pixel gray scale images.

Fixed a problem with the decompression of 24 bits-per-pixel PNG images which also contain an 
alpha channel.

2.70.2
Improved the way the thumbnail pane positioning is managed when the Explore window is 
resized. This also corrects anomalous behavior when the Explore window is maximized.

2.70.1
Fixed a problem which caused an access violation GPF to be generated if a corrupted thumbnail 
database file was encountered.

Fixed a problem which caused the thumbnail for a renamed file to disappear until the containing 
folder was refreshed.

Added some additional robustness for dealing with errors encountered while creating 
thumbnails.

2.70
Created a new Browse menu which has some of the commands that were previously in the File 
menu, and several new ones (see below).

Added an Open Script choice to the Browse menu for the direct opening of slide show script 
files.

Added commands to the Browse menu to invoke a browser for directories and files marked 
during slide shows.



Added the capability to display slide shows (or multiple slide shows) in on-screen windows. (See 
the Browsing tab of the Properties dialog.)

Added the capability to mark files during slide shows, as well as pause and continue 
functionality.

Added an option to the Browsing tab of the Properties dialog to expand slide show images to fill 
the available viewing area.

Added an option to the Files tab of the Properties dialog to force PolyView to interpret multiple 
command line arguments as a single file name containing spaces.

Added a command to the File menu save a file as wallpaper.

Added the Display Reduction Method option to the General tab of the Properties dialog to 
control the method used to reduce a large image to a small window.

Added the Background Color command to the Options menu to set the background color used 
for images.

Added a Tools menu to facilitate selection of the area selection, zooming, and panning tools.

Added an area selection tool to the Tools menu and the associated Crop and Copy Selected 
Area commands to the Edit menu.

Added a panning tool to the Tools menu to simplify moving the visible window around in a large 
or zoomed image.

Added a Photo-CD tab to the Properties dialog with options to control the size image to 
decompress from a photo-CD image pack file.

Added a splash screen to display the PolyView logo during program startup and initialization, 
and added an option to the General tab of the Properties dialog to disable it.

Added appearance adjustment commands to the context menu for an image.

The thumbnail position now stays constant after Deleting an open image while the Explore 
window is open.

Fixed a bug which caused misbehavior if full screen state was interrupted by a pop-up window 
or screen saver activation.

Corrected the actions of the Tool Bar and Status Bar options in the View menu for the Explore 
window.

Improved the screen update algorithms to reduce flickering when resizing image windows.

Corrected the consistency of the actions on the thumbnail context menu of the Explore window. 



The Add to slide show and Delete options now affect all selected images.

Clicking the right mouse button on the thumbnail pane of the Explore window no longer 
deselects selected images.

Fixed a problem which caused a maximized window to be incorrectly displayed after a full 
screen slide show or image view operation had taken place.

Fixed a bug in the Soften routine invoked through the Options menu.

Fixed a bug in the Export Image command of the File menu which caused the last save/export 
directory to not be used.

The splitter bar position in the Explore window is now restored between sessions.

The thumbnail position now stays constant after Delete or Move operations in the Explore 
window.

Fixed a problem which prevented purging the slide show list if the slide show dialog was closed 
with an empty list.

2.60.3
Fixed a bug which could leave the last few rows unreachable in the Explore window.

2.60.2
The slide show dialog now uses a device dependent bitmap for display if the corresponding 
option is checked in the General tab of the Properties dialog, resulting is a faster screen update 
on displays configured for more than 256 colors.

Fixed a bug which corrupted the output file name during batch file format conversions if the 
destination directory was the root directory of a drive.

Fixed a bug which caused excessive system resources to be used, and a potential for a stack 
failure, during the opening of some folders in the Explore window.

2.60
Added Undo operations.

Added variable thumbnail sizes.

Added palette optimization techniques to improve display of thumbnails in 256 color systems.

Added ReCreate Selected and Recreate All options from the Thumbnail menu of the Explore 
window to simplify recreation of thumbnails after a size change.

Added a progress bar for the thumbnail creation process.

Added a command to stop thumbnail creation.

Added a Sort option on the View menu for the Explore window to sort thumbnails by Name, 
Type, Size, and Date, with either ascending or descending sort order.



Improved the behavior when moving files in the Explore window so that the thumbnail for the 
image is retained.

Improved the handling of large folders in the Explore window for better responsiveness.

Added /E:Startup_Folder to the command line options to specify that the Explore window is to 
start with a specific folder opened. Example: polyview /E:c:\picture\my vacation

Dragging thumbnails to the Recycle Bin icon in the Explore window tree is now supported.

Added display of hidden folders in the Explore window

Added standard length and width options on the dialog presented from the Options:Change 
Pixel Resolution command.

Added the Gamma Adjustment operation to the Options menu.

Added the Change Color Depth operation to the Options menu.

Changed the layout of the slide show dialog when the screen resolution is 640x480 or 800x600 
to achieve a better fit when large fonts have been selected.

Deleting a displayed image from the File menu sends the file to the Recycle Bin on Windows 95 
and Windows NT 4.0 system.

Corrected a problem with the decompression of PNG files which are grayscaled and contain 16 
bit channel information.

Corrected a scrollbar thumb positioning problem after delete operations in the Explore window.

Corrected the View:Refresh option of the Explore window to correctly update when folder 
configurations have changed.

Fixed a problem with color map manipulations which caused printing and other difficulties when 
the number of colors in an image is less than the maximum.

2.53
Fixed problem with interpolating 24 bit per pixel images when the display mode is 8 bit.

2.52
Fixed problem with interpolation algorithm. This change makes minor improvements when 
interpolating 24 bit images, and major improvements when interpolating 8 bit images.

2.51
Added an option to the General Tab of the Properties dialog to turn off the generation of the 
device dependent bitmap used to optimize panning images.

Added an option to the General Tab of the Properties dialog to create a new window when some 
filtering operations are performed.

Added the Neon filter to the Special Effects available for 24 and 8 bit (grayscale) images.



Fixed a problem with the Format Conversions window which incorrectly interpreted the output 
image type for non-registered users.

2.50
Added the Format Conversions window.

Added edge detection image filters.

Added image appearance commands to sharpen and soften an image.

Added emboss and engrave special effects.

Added the Duplicate Image command.

Added an image appearance command to make the photographic negative of an image.

Restored the behavior of keeping child windows maximized when new images are opened.

Enhanced the internal handling of 1 and 4 bit per pixel images to improve speed and efficiency.

Added numerous export format options for 1 and 4 bit per pixel images.

Further optimized the steps taken during decompression and display of most graphics images to 
improve overall speed and efficiency.

Removed the Explore window restriction on the number of thumbnails that can be displayed in a 
single folder.

Added a Refresh option under the View menu of the Explore window. It is mapped to the F5 key 
for compatibility with Windows 95 and Windows NT. The previous mapping of the F5 key, to the 
thumbnail create function, is now mapped to F4.

Added a sort button to the slide show dialog.

Corrected a problem with the Add All button of the slide show dialog.

Added a more sophisticated printing algorithm.

Corrected the Print and Print Preview operations which erroneously determined the printed 
image borders when only the visible regions of an image were printed.

Added several options for specifying a progress bar to be used in lieue of or in addition to the 
normal progress image display during decompression.

Corrected the behavior of the Slide Show dialog when a file name was double-clicked in the file 
list box.

2.40
Added support for numerous additional image formats.



Enhanced the operation of the Slide Show dialog under Windows 95.

Added the Flip and Mirror manipulations.

Corrected an error which prevented image appearance adjustments from being written back to 8 
bit image formats under some conditions.

2.30
Added the Explore Window.

2.21
Added Transparent Color dialog for specification of GIF transparency.

File type used for the last file exported is now remembered as the starting type for a new export.

Fixed incompatibilities with Windows 95 taskbar during full screen modes.

Fixed a problem where errors occurring during manual slide shows were not ignored.

Fixed a problem with recovering from certain varieties of GIF file corruption.

Fixed several problems with image sizing and full screen behavior when the PolyView toolbar is 
floating instead of docked on a window edge.

2.20
Changed method of opening a file in one-for-one mapping to eliminate resolution change at end 
of read.

Added interpolated zoom.

Added the Change Resolution and Smooth to New Window commands.

Added option to the Browsing Properties Tab of the Properties dialog to ignore errors during 
slide shows.

Corrected behavior when Prompt for file save on exit is in effect and a close on a created 
window is attempted.

2.19
Added printing.

Corrected the behavior which occurs when the display resolution is changed under Windows 95 
while images are being displayed.

2.18
Added individual image timing during slide shows.



PNG files are now written as 8 bit gray scale even if the source is 24 bits if it is found that the 
source is really gray scale in disguise.

Added exporting to GIF files.

Added exporting to progressive JPEG files.

Added separate storage of open and save directory paths.

Added Most Recently Used file list manipulation functions.

Removed support for LZW compressed TIFF files due to patent licensing restrictions.

Fixed a bug which caused incorrect operation of the Browsing Properties dialog.

2.17
Added support for reading progressive JPEG files.

Restored the ability to convert 8 bit images to JPEG format.

Added saving (exporting) to PNG format files.

Added slide show randomization.

2.16
Fixed a bug which caused image size problems when the toolbar was positioned at the right or 
left edge of the viewing area.

Fixed a bug which caused name recognition problems for folders with names which ended 
in .GIF, .JPG, etc.

Enhanced the image context menu.

Added .JPEG and .TIFF as recognized file types.

Added support for viewing PNG files.

Enhanced Register File Types dialog to show current PolyView registrations.

2.15 Fixed a bug which prevented the file-open dialog from working correctly.
2.14 Added saving to 8 bit RLE bitmap format.

Added saving to 16 bit bitmap format.
Added multiple file selection from Explorer file open dialog.
Added editing and saving of comments to JPEG files.
Added user registration for feature set enabling.

2.13 Corrected processing of multiple files dragged to a PolyView shortcut.
Corrected processing of dragged files containing slide show scripts.



2.12 Added the optional display of the image file name during full screen mode.
2.11 Fixed a bug which caused JPEG file handle ownership to be retained.

Added File:Image Properties command.
Added image context menu from right mouse button.

2.10 Added scripted slide shows.
Added copy and paste operations.
Added support for reading 1, 4, 16, and 32 bit BMP files, and 4 and 8 bit RLE BMP files.
Added background operation of color manipulation, rotation, and image exporting operations.

2.00 Removed image configuration file usage.
Changed image appearance algorithms to work on all systems.
Added gray scale operation.
Added image save operations.
Improved capabilities for reading damaged files.

1.92 Added Register File Types dialog box.
1.91 Added context sensitive help.
1.90 Added TIFF file support.

Added 24 bit BMP support in 256 color modes.
Added File:Delete option.

1.80 Added photo-cd upsizing option.
1.70 Added photo-cd file support.

Added system registry use for file association.
1.60 Added slide show viewing mode.

Added properties dialog and additional JPEG decompression options.
1.50 Added full screen viewing mode.
1.40 Added "on-the-fly" image painting during file reading.

Remember last screen position and state.
Remember last directory used to open a file.

1.30 Added support for 8 bit color modes.
1.20 Added JPEG DCT method choice.

Changed bitmap algorithms for better Win95 compatibility.
1.10 Added default saving for application and image configuration defaults.

Added “View:Resize to fit” command.
1.00 Initial release.
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The PolyView Warranty

THE POLYVIEW SOFTWARE IS PROVIDED "AS-IS" AND WITHOUT WARRANTY OF ANY KIND,    
EXPRESS, IMPLIED OR OTHERWISE, INCLUDING WITHOUT LIMITATION, ANY WARRANTY OF 
MERCHANTABILITY OR FITNESS FOR A PARTICULAR PURPOSE. 

IN NO EVENT SHALL LARRY REEVE OR POLYBYTES BE LIABLE FOR ANY SPECIAL, 
INCIDENTAL, INDIRECT OR CONSEQUENTIAL DAMAGES OF ANY KIND, OR ANY DAMAGES 
WHATSOEVER RESULTING FROM LOSS OF USE, DATA OR PROFITS, WHETHER OR NOT 
ADVISED OF THE POSSIBILITY OF DAMAGE, AND ON ANY THEORY OF    LIABILITY, ARISING 
OUT OF OR IN CONNECTION WITH THE USE OR PERFORMANCE    OF THIS SOFTWARE.



LZW GIF/TIFF Licensing Information

The Unisys Corporation owns U.S. Patent 4,558,302, and foreign counterparts, and has the right to 
grant licenses for the use of this technology. Polybytes has licensed this technology for use in 
PolyView, subject to the following restrictions for registered users:

A single user PolyView license is restricted to being used on a single computer at a time. If a 
registered version of PolyView is to be used on multiple computers simultaneously, then the 
agreement requires that an additional registration be purchased for each computer.



PolyView Registration Form

Name: ____________________________________________________________
Address: ____________________________________________________________
Address: ____________________________________________________________
City/State/Zip: ____________________________________________________________
Email: ____________________________________________________________
Comments:

Print this form, fill it out, and mail along with a check or money order for $20.00 US to:

Polybytes
3427 Bever Avenue SE
Cedar Rapids, IA 52403-3161
USA

Please make registration checks payable to Polybytes.



The Thumbnail Database

The Thumbnail Database is used by PolyView to store the thumbnail sketches for the images on a 
computer system and the indexing information needed to rapidly access the thumbnails while 
navigating through the system with the Explore window. The Thumbnail Database consists of two files: 
the index file, which has a file type of PVX, and the database file, which has a type of PVD.

When the Explore window is invoked for the first time, a Thumbnail Database named PolyView is 
automatically created. The two files for this default database are:

PolyView.PVX
PolyView.PVD

These files are created in the same directory as PolyView.exe. Warning: If PolyView.exe resides in a 
read-only directory, then the Explore operation will fail when executed for the first time. To get things 
started successfully, move PolyView.exe to a writable directory before invoking the Explore window. 

Once the Explore window is active, the Open Database command under the Thumbnails menu can be 
used to open or create an alternate database. It will be useful to use an alternate database if thumbnail 
sketches of images on a removable device such as a CD or floppy disk are to be created. This will 
allow the management of the Thumbnail Database through the Thumbnail Database Maintenance 
dialog to be most effective, since the main database for the non-removable devices in the system can 
be maintained without regard to which removable devices are currently resident.

There is no hard limit to the number of thumbnails that can be managed by a single Thumbnail 
Database, except the limits imposed by the size of the database and the available disk space for its 
storage.



About Gamma

The appearance of an image displayed on a computer screen, or any other media, is dependent on a 
complicated interaction between the way humans perceive colors and intensities and the way the 
particular media translates its input signals into light. Although a host of other factors contribute, these 
two factors dominate.

Human visual perception is sensitive to the ratios between light intensities. Consider a gray light 
intensity scale where 0 indicates a black image and 100 represents a white image. The three 
intensities 25, 50, and 75 will not be seen by the eye as linearly increasing in intensity, as you might 
expect. Instead, the intensity of 50 is twice as bright as 25, while 75 is only 1.5 times as bright as 50.

The rendering of an image on a computer display is a highly non-linear problem which is potentially 
different for every system. The intensity of a pixel depends on the characteristics of the screen 
phosphor and the characteristics of the electron beam that is exciting the phosphor to radiate light. Add 
to this the intensity response of human vision and the problem of correctly displaying the colors and 
brightness of an image becomes quite a challenge.

Gamma attempts to compensate for these effects by pre-adjusting the intensities of the pixels in an 
image according to the equation:

NewIntensity = Intensity**(1/Gamma)
where ** represents the exponentiation operation. The overall effect of this operation is that for Gamma 
settings greater than 1.0 there is a brightness boost in an image which tends to decrease as the 
intensity of a pixel increases. That is, the dark areas of an image increase more in brightness than do 
the light areas. Choosing the right gamma factor can result in the realistic display of an image.

The wide variety of image storage formats available treat gamma compensation with an equivalently 
wide variety of methods. Some formats, like Portable Network Graphics (PNG) format, offer the 
capability of storing the gamma compensation for an image along with the bits of the image. Others, 
like JPEG File Interchange Format (JFIF), simply specify that the images be stored with a gamma 
factor of 1.0 - leaving it up to the image viewers to appropriately compensate the image for display. In 
both cases, the specification and compensation of gamma is widely ignored. Many PNG images have 
no or incorrect gamma compensation, and many JPEG, GIF, and other formats are corrected to 
something other than 1.0.

Faced with these disparities in handling gamma, PolyView assumes that unless it is specified 
differently in the input file, an input image has been stored with a gamma factor of 1.0. For images 
where this assumption is invalid, the Gamma Adjustment dialog provides interactive adjustment of the 
gamma factor for an image. The dialog also allows the specification of a global gamma to be used to 
compensate all images as they are opened and displayed.



Starting PolyView

PolyView.exe is the executable file that contains the implementation of the PolyView application. 
PolyView can be started from the Windows Explorer by double-clicking on the PolyView.exe file or 
through the many varieties of Windows shortcuts that can be created.



Opening and Displaying Images

PolyView can be directed to open and display images in a variety of ways, including dragging an image 
from the Windows Explorer and dropping it on a PolyView window or shortcut, using a standard file 
Open dialog box, or opening directly from a PolyView Browse or Explore window. In addition, if a 
graphics file type has been associated with PolyView through the Windows Explorer or by using 
PolyView’s Register File Types dialog, then double-clicking on an image of that type will directly 
execute PolyView to open and display the image.



Drag-and-Drop

Drag-and-drop a file on a running PolyView application, on a PolyView shortcut, or on a minimized 
PolyView icon, to send the file or files to PolyView. Depending upon the setting of the Drag and Drop 
File Actions property of the File Properties Tab of the Properties dialog, PolyView will

· Create a new window for each dragged file

· Create a new slide show from the dragged files

· Add the new files to an existing slide show

· Start a slide show if the file is a Slide Show Script file

See the information about Full Screen Display Modes for an explanation of slide show mode 
characteristics.

Caution: If PolyView is configured to create a new window for each dragged file and a large number of 
files are "dropped", then PolyView can fairly quickly use up large amounts of the real and virtual 
memory resources in your system. If this occurs accidentally, the multithreaded nature of PolyView will 
allow you to correct your mistake by choosing the Exit command from the File menu to terminate 
image decompression and release all resources.

Limitation: When multiple files are dragged from the Explorer to a PolyView shortcut, the method used 
by the Explorer is to pass the file names on the internal command line used to execute PolyView. Since 
there is a limit to the number of characters allowed on an application command line, there is a 
significant limitation to the number of files that can be dragged at once using this method. If the line 
length limit is exceeded, one of two things will happen. Under Windows 95 a notification will be issued 
that there is a problem, and PolyView will not be executed. Under Windows NT the file name at the end 
of the command line may be truncated, resulting in an error message from PolyView. The work-around 
to this problem is to execute PolyView first and then drag and drop files on it.



Command Line Arguments

The command line used to run PolyView can contain 0 or more file names separated by spaces. The 
action taken when multiple files are passed depends upon the setting of the Drag and Drop File Actions 
property of the File Properties Tab of the Properties dialog, and is the same as those action taken 
when multiple files are dragged and dropped on PolyView. Warning: file paths containing spaces must 
be enclosed in double quote characters to be interpreted correctly.

Automatically invoking the Explore window
PolyView’s Explore Window can be started automatically by including the /E option on 
PolyView’s command line:
polyview /E

Optionally, the path name of a folder can be added to the /E option to start the Explore Window 
with the named folder opened:
polyview /E:FolderPathName
Note: the entire /E:FolderPathName option must be the last entry on the PolyView command 
line. Do not enclose the folder name in quotes, even if it contains spaces.

Rotating images
Image files passed on the command line are automatically rotated after decompression if the 
command line includes the /R option:
polyview filename /Rn
where n is a number from 1 to 3 that indicates the number of 90 degree clockwise rotations to 
perform. For example:
polyview x.jpg /R2
will rotate x.jpg by 180 degrees.

Note: the inclusion of a /R option causes all images passed on the command line to be rotated.



The Tool Bar

The PolyView toolbar contains buttons for:

· Starting the Explore Window 

· Opening image files

· Playing slide shows 

· Copy and Paste

· Printing the visible portion of the current image

· Invoking full screen display mode 

· Undoing previous operations (See: Undo Properties )

· Manipulating an image’s appearance

· Viewing PolyView’s About dialog box

Tool Tips
The function of a toolbar button can be determined by placing the mouse cursor over the button. 
After a few moments a small caption will be drawn near the cursor indicating the function of the 
button.

Toolbar Positioning
The PolyView toolbar is a docking toolbar. This means that it can be grabbed with the left mouse 
button and dragged to a new position within the PolyView window. If positioned against an edge 
of the window it will be docked there. The toolbar can also be left floating anywhere in the 
window, or made invisible through the Toolbar option on the View menu.



The Status Bar

The Status Bar contains:

· an indicator which displays the action a highlighted menu option will perform

· a working indicator which is displayed when a PolyView background thread is working on 
reading or saving a file, creating thumbnail sketches, or adjusting the appearance of an 
image

· the coordinates of the mouse cursor when it is positioned within an open image window

The status bar can be made invisible through the Status Bar option on the View menu.



Windows Registry Usage

PolyView uses the Windows registry for the storage of all information pertaining to individual user 
settings from the Properties menu, most recently used file list, and the most recently used directory. 
The polyview.ini file created by PolyView versions prior to 1.70 is no longer needed and may be 
discarded.

PolyView automatically registers itself upon startup, but only for the purpose of storing user 
preferences under the HKEY_CURRENT_USER\Software\Polybytes\PolyView key. The association of 
file types with PolyView is done only by user direction from the Register File Types dialog that can be 
selected from the Options menu.



The Properties Dialog

The PolyView Properties dialog box, accessed through the Properties selection of the Options menu, is 
used to control the user preferences for the operations performed by PolyView during its operations.

File Properties Tab 
General Properties Tab 
Browsing Properties Tab 
JPEG Properties Tab 
MRU File List Properties 
Photo-CD Properties 
Open With Properties 
Thumbnail Properties 
Undo Properties 



File Properties

The file properties are available from the Files tab of the Properties dialog. These include:

Drag and Drop File Actions
Options to control whether files dragged from the File Manager and dropped on PolyView create 
new image windows, or are used to create or augment a slide show. Two options are presented:

Create a window for each file 
Create a slide show from files 

Add to existing list 

Image File Open Actions
Options to control whether a file opened by PolyView creates a new image window or replaces 
the current image window. Two options are presented:

Create New Window 
Replace Current Window 

Prompt for file save on exit
If this option is checked then PolyView will remember if the appearance of the image is altered 
and will allow a last chance to save the image when the image is closed.

Write PolyView Signature to GIF
If this option is checked then PolyView will write an information string to all exported GIF files 
which designates PolyView as the creator of the file.

Assume single command line argument
This option controls the way PolyView interprets its command line arguments. If checked, then 
multiple arguments separated by spaces are assumed to be a single image file name containing 
spaces. If unchecked, then multiple arguments are assumed to be the names of multiple files, 
and names containing spaces must be enclosed in double quote characters. 
For example, the command line
polyview my picture
will be interpreted as a request to open the files “my” and “picture” if this option is unchecked, 
but as a request to open the file “my picture” if checked. The command line
polyview “my first picture” “my second picture”
will be interpreted as a request to open the two files “my first picture” and “my second picture” 
regardless of whether this option is checked or unchecked.

Show full path in window title
This option controls the format of the image name placed in an open image window’s title. If 
checked the full path name of the original file will be displayed.    If unchecked the name without 
the directory and file extension portions of the name will be displayed.

Prompt for all names in TWAIN acquire
If checked then all file saves in a direct-to-file TWAIN acquisition will be preceded by a prompt 
for the name and type of the file.



TWAIN acquire to multi-page format
If checked then a TWAIN acquire to file operation will create multi-page files if DCX or TIFF is 
selected as the output file type. A new file will be created to contain the first image acquired. 
Subsequently acquired images will be appended to the file as additional pages. 

Add TWAIN files to slide show
If checked then TWAIN files will be added to the current slide show list as they are acquired 
from the TWAIN data source.

Show hidden files
If checked then hidden files will be available for viewing from the Explore and Browse windows.

Default Comment for Saved or Converted Files
This field is used to program a string that will be written as a comment to all files saved as GIF , 
JPEG , or PNG formats. This field might be used, for example, to specify a copyright string to 
place in all output images.



Create a window for each file

If this option is chosen, then each file dragged and dropped on PolyView will create a separate image 
window. Caution: if a large number of files are dropped, then correspondingly large quantities of 
memory resources will be consumed.



Create a slide show from files

If this option is chosen, then a group of files dragged and dropped on PolyView will be used as the file 
list for a slide show and the slide show will be automatically entered.



Add to existing list

If Create a slide show from files has been selected, then this option controls whether the dropped 
group of files replaces an existing slide show list or is added to it. Note: this option will be disabled 
unless Create a slide show from files has been selected.



Create New Window

If this option is chosen, then each file opened by PolyView will be displayed in a separate, newly 
created window.



Replace Current Window

If this option is chosen, then each file opened by PolyView will be displayed in the current window, 
replacing any existing image. If no images are currently being displayed then PolyView will create a 
new window for the image. Note: If multiple files are dropped on PolyView when this option has been 
selected, then only the first file will be opened.



General Properties

The general properties are available from the General tab of the Properties dialog. These include:

Image Adjustment Percentages
These controls set the percentage change that will occur when the Image Manipulation 
commands from the Operations menu are used to adjust brightness, contrast, color saturation, 
red/green tint, and sharpness. Setting the Brightness Adjustment Percentage value to 10, for 
example, will cause the Options:Brighter+ command to increase the overall brightness of the 
image by 10 percent. The allowable range for each item is 1 to 20.

Default One-For-One Mapping
This option controls the way PolyView deals with images that are larger than the maximum size 
image that can be displayed in the current viewing area. If Default One-For-One Mapping is 
selected, then PolyView will prepare the largest size window possible and equip it with scroll-
bars to enable panning around in the image. If Default One-For-One Mapping is not selected, 
then PolyView will scale the image to fit within the viewing space. In this case the View:One-for-
One Mapping command can be used to achieve the same view of the image.

Enable interpolated zoom
This option controls the way PolyView zooms an image. If interpolated zoom is enabled then a 
new window will be created from the contents of the defined area. The size of the new window 
will be the maximum size that can be created within the confines of the current viewing area 
within PolyView. An interpolation algorithm will be used to present as realistic an image as is 
possible based on the original resolution of the image.

If interpolated zoom is disabled, then a quick zoom will be executed which simply rescales the 
current window to display an enlarged version of the area of interest.

Enhance monochrome printing
PolyView has two printing techniques available - sending images directly to the printer with no 
processing except stretching to fit the specified page size, or a technique that uses error 
diffusion when sending color images to monochrome printers to insure the best print quality. The 
former method, used if Enhance monochrome printing is not selected, usually takes significantly 
less time to produce printed output. The latter method, however, will usually produce much 
better quality prints when color images are sent to monochrome printers.

Use default WMF size
This option controls the action taken when PolyView opens a Windows metafile. If unchecked, 
then the WMF Dimensions dialog will be invoked whenever a metafile is opened to allow the 
specification of the window size for the metafile image. If checked, then the dimensional 
information contained in the metafile will be used to determine the window size, or 300x200 for 
metafiles that contain no dimensional information.

Create Device Dependent BMP
If checked, then PolyView will create a device dependent bitmap for each image processed 
when the display is configured for more than 256 colors. The presence of the device dependent 
bitmap will enhance panning operations and speed up slide show screen updates at the cost of 
additional memory usage.



Filter to new window
If checked, then filtering operations that drastically change the appearance of an image will be 
written to a new window, leaving the current image unchanged. The operations altered by this 
option include some edge filters and the special effects filters.

Disable Splash Screen
Turns off the display of the opening splash screen.

Animate GIFs on Open
Controls whether an animated GIF will be animated when the file is opened, or whether it will be 
treated as a multipage image.

Use “new” flat toolbars
Use MS Internet Explorer style "flat" toolbars. This option does not take effect until PolyView is 
closed and restarted. Also note that it may be ineffectual or cause anomalous behavior on 
systems which do not have the current MS Internet Explorer or MS Office 97 products installed.

Display image transparencies
Controls the display of transparency information in GIF images, and transparency and alpha 
channel information in PNG images. When enabled, this information will be used to blend the 
image with the current background color (see the Options menu) to allow the images to be 
viewed as they will be in a WWW browser. Note: enabling this option changes the basic bitmap 
information retained internally for the image. If the image is subsequently resaved then the 
saved image will retain this altered appearance.

Progress Bar
These options specify the behavior of the Progress Bar that PolyView can optionally display 
while decompressing an image.

Display Reduction Mode
This property controls the method used to draw images that must be reduced in size to fit the 
available viewing area.

Color photo mode - pixels eliminated during reduction are simply deleted. This is the fastest 
method and generally does a very good job with complex color images like photographs.

Favor black pixels - black pixels are favored over white in monochrome images. This method 
works well for line drawings when black lines are drawn on a white background.

Favor white pixels - white pixels are favored over black in monochrome images. This method 
works well for line drawings when white lines are drawn on a black background.



Browsing Properties

The browsing properties are available from the Browsing tab of the Properties dialog. These properties 
include:

Browsed Image Display Time
The number of seconds an image is to be displayed in auto-browse or slide show modes. This is 
the minimum time for the display of the image in slide show mode. The next image load is 
started when an image is displayed, so long image load times may increase the image display 
time.

Timed Browsing Mode
These properties control the method used to terminate auto-browse or slide show mode. Three 
alternatives are provided:

Cycle Images Once 
Cycle Images Continuously 
Cycle Images Manually 

Randomize Slide Shows
This property controls the order in which images are displayed during slide shows. If selected 
then the image display order will be randomized. If not selected, then the image display order 
will be the same as the order shown in the slide show open dialog, or the order of the files listed 
in a slide show script file.

Ignore read errors during slide shows
This property controls the behavior when image file decode errors occur during slide shows. If 
checked then any errors that occur will be ignored and the offending file will just be skipped 
over. If unchecked then any error will abort the slide show with a message indicating the file that 
caused the problem. Note: if an error occurs while reading the first file to be displayed in a slide 
show then the show will always be aborted.

Display Filenames with Full Screen Image
This property controls whether or not the name of the displayed image is displayed along with 
the image when in full screen mode.

Zoom images to fill window or screen
This property controls the behavior when a slide show or full screen image is smaller than the 
available screen display area. If checked then the image will be expanded to fit the available 
space, preserving the aspect ratio of the original image.

Select multiple names in dialog
On Windows NT systems prior to version 4.0, this property controls whether or not the 
slideshow selection dialog is configured to allow the selection of multiple names. If checked, 
then multiple names can be selected from the file name list box, but names containing spaces in 
this box and in the directory box will have their DOS compatible short names substituted.

Disable Screen Saver
If checked, then screen saver activation will be disabled during a full screen slide show.



Start slide show from last/selected image
If checked, then a slide show will be started from the image last displayed in a slide show during 
the current PolyView session. A slide show will also start on the image selected when the Play 
button is pressed on the slide show dialog. (See the Slide Show command on the Browse 
menu.)



Cycle Images Once

The images are cycled once from the beginning to the end of the list. When the end of the image list is 
reached the full screen mode will be terminated.



Cycle Images Continuously

The images are cycled continuously. When the end of the image list is reached the list is restarted from 
the beginning. User intervention via the mouse or the keyboard is required to interrupt the display 
cycling.



Cycle Images Manually

Image cycling is controlled by the user via the mouse or the keyboard. The right mouse button 
advances to the next image in the list. The left mouse button advances to the previous image in the list. 
In a like manner the keyboard cursor control keys cycle through the image list.



JPEG Properties

The JPEG properties are available from the JPEG tab of the Properties dialog.

DCT Arithmetic Method
The PolyView JPEG algorithms provide several methods for performing the Discrete Cosine 
Transform (DCT) used during JPEG file reading and writing. The methods available are:

Accurate Integers 
Fast Integers 
More Accurate Floating Point 

Chroma Component Upsampling Method
The Chroma component upsampling method controls the speed and accuracy of certain color 
manipulations performed during JPEG file reading. The methods available are:

Slow, careful, and accurate 
Fast, but less accurate 

Output Quality Factor
Controls the relative quality of the image resulting from saving to a JPEG format file, and is 
proportional to the resulting size of the file. (Higher quality images result in larger files.) The 
PolyView default value of 50 is a reasonable compromise between output quality and file size.



Accurate Integers

Slow but accurate integers - this method is slower than the fast integer method, but achieves high 
quality results.



More Accurate Floating Point

Fast or slow but accurate floating point - this highly accurate method may be the fastest on some 
machines, but on machines without floating point capability will be VERY slow.



Fast Integers

Fast but inaccurate integers - this is the fastest method on most machines, but may suffer from 
degraded image quality. For many images there will be insignificant visible degradation.



Accurate Chroma Upsampling

Chroma (color) upsampling is performed very carefully and accurately. This is the slowest method.



Less Accurate Chroma Upsampling

Chroma (color) upsampling is performed with a sloppier method that leads to some image degradation. 
This method is much faster, however, and the degradation is frequently not detectable.



MRU List Properties

The Most Recently Used (MRU) File List Properties are available under the MRU Files tab of the 
Properties dialog. The following options are available for manipulating the properties of the MRU file 
list:

# of files in MRU file list
Controls the maximum number of files in the MRU file list. This can be any number between 0 
and 16 inclusive, where 0 indicates that the MRU file list should always be empty. Note that 
changes in this option will not take effect until PolyView is restarted.

Purge MRU file list on exit
When this option is checked the MRU file list will behave normally while PolyView is executing, 
but will be emptied when PolyView is closed. PolyView will then always start with an empty MRU 
file list.



Photo-CD Upsizing

The algorithm that PolyView uses to select the display image size of a photo-cd file depends on the 
Enable Photo-CD Upsizing option of the Photo-CD Tab of the Properties dialog.

If upsizing is not enabled, then PolyView chooses an image size which fits within the dimensions of the 
full screen viewing area, yielding the most accurate display of the image. For example, if a horizontal 
image is to be displayed on an 800x600 resolution display, then the 768x512 image size will be 
chosen. On the same display, however, a vertical image will be displayed in a 256x384 format, since 
the next available size of 512x768 will overfill the screen in the vertical direction.

If upsizing is enabled, then PolyView chooses an image that fills the screen to the Screen Fill 
Percentage in at least one direction. For example, consider the case where a 75% Screen Fill 
Percentage has been chosen. On an 800x600 display, a horizontal image will be displayed in the 
768x512 image size because this fills the screen to 96% in the horizontal direction, and 85% in the 
vertical direction. For a vertical image a 512x768 image will be chosen, because the next smaller size 
of 256x384 will fill the screen to only 32% in the horizontal direction, and 64% in the vertical direction. 
In this case, the 512x768 image will be "shrunk" to exactly fill the available display area.

Caution: upsizing can cause PolyView to use a significantly larger amount of memory during photo-cd 
image decompression and display. Specifying a 90% Screen Fill Percentage on an 800x600 display 
will result in PolyView choosing a 1536x1024 image. During decompression this size image requires a 
4.6 Mbyte memory structure to be allocated for the storage of a device independent bitmap. On a 24 bit 
display the resulting device dependent bitmap is also 4.6 Mbytes in size, so the peak memory 
requirement to display this image is more than 9.2 Mbytes. This may lead to excessive disk activity and 
performance degradation on memory challenged systems.



Photo-CD Properties

The Photo-CD properties are available from the Photo-CD tab of the Properties dialog.

Photo-CD Sizing Options
These options control the size of the image loaded when a Photo-CD file is opened. The 
choices include the available sizes, and:

Automatic - PolyView will choose an image size based upon the options selected from the 
Photo-CD Upsizing properties.

Ask on each PCD - each time a Photo-CD file is opened a dialog box will be invoked from which 
the image size to be loaded can be chosen.

Photo-CD Upsizing
The Photo-CD Upsizing options control the way PolyView selects the image size to use from a 
Photo-CD image file. Note: the Photo-CD Upsizing properties are used only when a Photo-CD 
file is opened with the Sizing Options set to Automatic.



Progress Bar Options

The progress bar is an indicator on the PolyView status bar that graphically displays the progress 
being made towards the completion of the various activities associated with decompressing image 
files. These activities include:

Initial image decompression
Image color reduction (two passes) on 256 color displays
Final bitmap production
Thumbnail creation

Depending on the progress bar settings, one or more of these activity states will be reflected in the 
progress bar. Note: if multiple images are being decompressed simultaneously, only the activity 
associated with the first image started will be reflected in the progress bar.

The following options control the behavior of the progress bar indicator:

Never
The progress bar is never displayed during file decompression operations.

On Intermediate Ops
The progress bar is displayed while decompression activity is ongoing, but the image data is not 
yet available for display in the image window. This will occur, for example, when an interlaced 
image is being decompressed. In this case the entire image is read into memory before the 
creation of the final display bitmap and the subsequent display of the completed image.

Always
The progress bar is displayed for all activities and the progressive display of the image during 
decompression is not performed.



Open With Properties

The manipulation of the list of applications defined for alternate processing of PolyView images is 
available through the Open With tab of the Properties dialog. The controls on this page include:

Helper Applications for the “Open With” menu
A list box containing up to 4 applications to use for alternate PolyView image processing. The 
defined applications will appear on the context menu for an image under the Open With popup. 
Selecting an Open With application from the context menu will send the associated image to the 
application.

Title for current selection
A field for entering the title to be used for the current Open With application selection. Any title 
entered here will be used in the Open With menu list in an image context menu.

Use quotes with current selection
If checked, then the image file name argument sent to the selected Open With application will 
be enclosed in double quotes. This is necessary for some applications if the selected image 
contains space characters. If you have trouble getting an application to correctly process an 
image file, try changing this option.

Add Application
This button invokes a standard file selection dialog for navigating to and selecting an EXE file to 
be defined as an alternate processing application for PolyView images.

Remove
This button removes selected applications from the application list box.



Context Menu

A context menu is the popup menu that appears when objects are clicked with the second mouse 
button. Context menus in PolyView are available on open images, Explore window thumbnails, and 
Directory/Marked File browser entries.



Thumbnail Properties

The thumbnail properties are available from the Thumbnails tab of the Properties dialog. These 
properties control the methods by which thumbnail sketches of images are created and stored. 

Thumbnail Creation and Storage
Two types of thumbnail bitmaps are created by PolyView: a 256 color bitmap which provides 
excellent color reproduction when the system display is configured for a mode which provides 
greater than 256 colors (16, 24, or more bits per pixel), and a 216 color bitmap which uses an 
error diffusion technique to accurately reproduce colors on 256 color (palette based) systems. 
The Thumbnail Creation and Storage options control which of these bitmaps will be created and 
stored in the thumbnail database:

Optimize for 256 color displays - thumbnails will be stored as a 216 color bitmap using error 
diffusion to most accurately reproduce colors on 256 color (8 bit) display configurations. On 
systems that will view thumbnails in 8 bit and higher color resolutions, this option is the best 
compromise between thumbnail database size and color reproduction.

Optimize for greater than 256 color displays - thumbnails will be stored as a 256 color bitmap 
to most accurately reproduce colors on systems which are configured for more than 256 colors. 
Color reproduction on 256 color systems is compromised because each image in the thumbnail 
pane potentially uses a different 256 color set, and at most 256 colors can be displayed at one 
time on these systems.

Optimize for all displays - both types of bitmaps will be stored in the thumbnail database. The 
bitmap used for display will be the correct one to best reproduce colors for the display 
configuration selected. This option results in the largest thumbnail database, but gives the best 
color reproduction on systems which frequently switch between color resolutions.

Default thumbnail dimensions
PolyView creates and displays thumbnails to fit square regions which are 100, 150, or 200 
pixels on each edge. This option controls the size used for the initial creation of a thumbnail 
database. Note: this option is also updated when the Thumbnail Size dialog is used to change 
the display size.

Drive Independent Mapping
This property controls the mapping of thumbnails to images. When checked, the strict matching 
criteria is relaxed to allow thumbnails to be matched to images where the image was on a 
different drive when the thumbnail was created. This is useful where drive letter assignments 
have changed due to hardware changes, or in dual-boot situations where drive letter 
assignments differ between two operating systems. Note: Enabling drive independent mapping 
may result in unexpected behavior when identical images (identical path, size, and 
creation/modification time) exist on more than one drive. Consider, for example, the situation 
where a file named X.GIF is stored in both a c:\images directory, and a d:\images directory. If a 
thumbnail has been created for the file in the c:\images directory and the file in the d:\images 
directory is then moved via drag and drop in PolyView’s Explore Window, the result will be that 
the thumbnail information will be assigned to the new location for the moved file, and the file in 
the c:\images directory will appear to no longer have thumbnail information.

Number of thumbnails per row when printing
This property controls the number of thumbnails that are placed on each row of printed output. 



Between 4 and 7 thumbnails can be specified.

Include image dimensions with name
If checked then the actual image dimensions of each thumbnail will be printed along with the 
thumbnail names.



Undo Properties

The Undo properties are available from the Undo tab of the Properties dialog. These properties control 
the way PolyView saves information about an image so that a requested operation can be undone and 
the image restored to its previous appearance.

Undo Policy
The Policy PolyView uses for managing the memory space allocated for saving undo 
information can be specified to be one of the following:

Disable undo operations - Choosing this operation turns off undo saving entirely. The only 
recourse for undoing operations is to start over by closing and reopening the image file.

Replace oldest undo block for another image when buffer is full - When the undo buffer is 
full and another undo block needs to be stored, delete the oldest undo block in the buffer which 
belongs to an image other than the current image. If the undo buffer contains only blocks for the 
current image, then delete the oldest block found.

Replace oldest undo block for the current image when buffer is full - When the undo buffer 
is full and another undo block needs to be stored, delete the oldest undo block in the buffer for 
the current image. If the undo buffer contains no blocks for the current image, then delete the 
oldest block found for any image.

Do not save current undo block when buffer is full - When the undo buffer is full then no 
further undo blocks will be stored.

Undo buffer size
The size to use for the Undo buffer, in megabytes.



Create Animated GIFs

Animated GIF files are GIF89a compliant files containing two or more images and the necessary 
information for performing simple animation using the images. The Create Animated GIFs command 
under the File menu provides a mechanism for creating and viewing animated GIFs from within 
PolyView.

The Create Animated GIFs window contains the following controls:

Input GIF Names
The list of GIF files containing the images to be placed in the output file, in the order they are to 
be added. The file names can be reordered by sorting (click the sort bar at the top of the list) or 
by dragging images around using the mouse.

Add Files…
Invokes a file selection dialog to choose GIF files, or a PolyView GIF animation script , to add to 
the list of files.

Remove Selected
Removes any selected files from the list of GIF names.

Save Script…
Saves all specified information for the animated GIF to a PolyView GIF animation script file.

Unpack existing GIF…
Unpacks an existing GIF into its constituent files and an animation script . The individual files 
from the original file will have an index number appended to their names, indicating the order of 
placement within the original file. The script file will be the original name with the “.GIF” 
extension replaced with “.PVA”. If the Replace during unpack option is checked then existing 
files will be silently overwritten, otherwise the unpack operation will fail if file name conflicts are 
found. At the conclusion of the unpack operation the Create Animated GIFs window will be 
updated to reflect the operations necessary to recreate the original file.

Delay Time
The amount of time an individual image is to be displayed during animation, in hundredths of 
seconds. Entering a new value into this field changes the delay time for all selected (highlighted) 
image names.

Disposal Method
Controls the action to be taken by a web browser at the conclusion of the delay time for an 
image and just before advancing to the next image. Selecting a new value for this field changes 
the disposal method for all selected (highlighted) image names. The available options are:
Not specified - perform no action.
Do not dispose - leave the image on the screen. This should be the same as the first option.
Restore background - replace with the background color.
Restore previous - replace with the previous image.
Note: not all web browsers perform the same actions when presented with these options.

Color Map



Controls the way the color map for each image is handled as images are added to the output 
animated GIF. Selecting a new value for this field changes the color map option for all selected 
(highlighted) image names. The available options are:
Use this image - the color map for this image will be transferred to the output file as the local 
color map for this image.
Use first image - the color map used for this image during playback of the animated GIF will be 
the color map from the first image place in the output file.
Note: the color map from the first image in the list is always used as the global color map for the 
output file.

Left and Top Offsets
The Left and Top offsets control the position for the selected image within the image space 
defined for playback of the animated GIF (defined by the Width and Height fields). Entering 
values into these fields changes the corresponding option value for all the selected (highlighted) 
image names. Note: PolyView does not honor these offsets during playback. You will have to 
open the GIF with your web browser to see the effect.

Loop Count
The iteration loop count to apply to the animation. Entering 0 in this field implies continuous 
looping. Any other value is the number of times the GIF images should be cycled each time the 
animation is displayed. Note: PolyView does not honor this count during playback but instead 
always loops continuously. You will have to open the GIF with your web browser to see the 
effect.

Width and Height Fields
These fields define the width and height of the display rectangle for the animated GIF file. If both 
fields contain non-zero integers then they will be written to the output GIF file. Otherwise, the 
width and height of the first image in the list will define the display rectangle size.

Output GIF Name Selection
The Output GIF field must be filled in with the name of the animated GIF file to be created. Use 
the Browse button to select the folder and file name.

View
Opens the Output GIF file in a normal PolyView window. If the file is an animated GIF then it will 
automatically be animated. This button is useful for evaluating the result of building a file.

Build
Builds the animated GIF file.



Viewing Animated GIFs

PolyView can view an animated GIF either with automated animation, or by paging through the file one 
image at a time using the multipage image commands under the View menu. This capability is a 
simplistic imitation of that available within modern World Wide Web browsers, however, so it is 
recommended that animations being prepared for web pages be previewed using an actual browser 
before final publication.



Animation Script Files

An animation script file contains all the commands necessary to create an animated GIF file. The script 
is normally created by unpacking an existing animated GIF or by saving the script from the Create 
Animated GIFs window. PolyView uses ".PVA" as the extension for an animation script file.)



File Menu

New Folder…
Creates a new folder as a sub-folder of the currently selected folder in the Explore Window .

Open...
Presents a standard file-open dialog box from which a graphics image file or a slide show script 
can be selected for display. Newly opened files will be created in a new window or in an existing 
window, depending on the settings of the Image File Open Actions property of the File 
Properties Tab of the Properties dialog. If a Windows 95 Explorer dialog is available for the file-
open dialog box, then multiple files can be selected at once using the standard technique of 
combining the control and shift keys with mouse button selections.

Save
Saves the current file in the original format, subject to the default settings for that format as 
specified by the Properties dialog. This menu option is enabled only for images that are in a 
format supported by PolyView for file saving .

Close
Closes the currently displayed image.

Delete
Deletes the file associated with the currently displayed image and closes the image window. A 
confirming dialog box will be presented to reduce the chances of accidentally deleting an image.

Rename
When the Explore Window is active this option renames files or folders. 

Export Image...
Exports the current file in a format supported by PolyView for file saving .

Save as wallpaper
Saves the current image as the current wallpaper. Note: the image is saved into the Windows 
directory as a file named “PolyView Wallpaper.bmp”, replacing any file by that name that 
previously existed.

Page Setup...
Invokes the Page Setup dialog for the specification of print margins and centering options.

Print Setup...
Invokes a standard printer setup dialog for the specification of the printer to use, properties for 
the printer, page orientation, and other print related items.

Print
Brings up a choice of printing the current image in its entirety, or printing just the currently visible 
portion of the current image. Either choice leads to a dialog box that offers another opportunity 
to change printer characteristics before printing commences.



Print Thumbnails
When either the Explore Window or Thumbnail Database Explorer is active, one or more pages 
of thumbnails will be printed.

Print Preview
Brings up a choice of previewing the printing of the current image in its entirety, or previewing 
just the currently visible portion of the current image. The print preview window shows the 
general relationship of the image to the page it will be printed on. In most cases the colors seen 
in the print preview will not reflect the actual color to be printed, but the preview display can be 
useful to view the proportions and positioning of the image with respect to the printed page.

Print Preview Thumbnails
When either the Explore Window or Thumbnail Database Explorer is active, one or more pages 
of printed thumbnails will be previewed.

Print Thumbnails to Window
When either the Explore Window or Thumbnail Database Explorer is active, the current contents 
of the thumbnail pane will be used to build an image window containing the print formatted 
image of all or selected thumbnails. The resulting image window can subsequently be exported 
to any supported file format. Note: printing a large number of thumbnails to an image window 
can create a very large image requiring large amounts of system memory resources. When the 
command to print to a window is invoked, PolyView will provide you with information regarding 
the size of the resulting image prior to commencing the build operation.

The image window created by this command uses the current PolyView background and text 
colors for background and titling colors. Use the appropriate commands on the Options menu to 
select the best combination for your purposes.

Create Animated GIFs…
Invokes the Animated GIF creation window.

Format Conversions…
Invokes the Format Conversions window to convert groups of files to a common output format.

TWAIN
Invokes the TWAIN menu for acquiring images from scanners, digital cameras, and other 
devices compatible with the standard TWAIN interface.

Image Properties...
Displays the Image Properties dialog box that provides information about the specific properties 
of the currently displayed image and, for registered users, the opportunity to add or modify the 
comments for subsequent saving to any supported file format which can contain embedded 
comment text, such as JPEG .

Recently Opened File List
A list of the most recently opened image files. Selecting one of these file names is equivalent to 
selecting it again through the Open... command. The characteristics of this list can be 
manipulated through the MRU tab of the Properties dialog.

Purge recent file list



Immediately clears the most recently opened image file list from the file menu.

Exit
Closes all image windows and exits PolyView.



Windows Directory

The Windows directory has various names and locations on various computers. It might be c:\windows, 
c:\winnt35, c:\winnt351, etc. PolyView will find the correct directory for your system.



TWAIN Interface Support Menu

The TWAIN menu accesses the TWAIN interface options for acquiring images directly from compatible 
scanners, digital cameras, and other instruments providing standard TWAIN interfaces.

Acquire…
Opens the default TWAIN data source and accepts any image bitmaps transmitted from it. 
Bitmaps received are displayed in standard PolyView “Untitled” image windows from which they 
can be saved to image files via the Export Image command of the File menu.

Acquire to File…
Opens the default TWAIN data source and accepts any image bitmaps transmitted from it. 
Bitmaps are saved to image files as they are received.

When the first bitmap is received from the TWAIN data source a file save dialog box will be 
invoked to get the choice of a base name for the image save files. (If the Prompt for all names in 
TWAIN acquire option of the File Properties Tab of the Properties dialog is checked, each 
individual file name will be prompted for.) The base name will be used to generate the save file 
name according to the following formula:
Save_Name = Base_Name + “_” + N + “.” + <ext>
where
Save_Name is the name of the file to be saved
Base_Name is the name entered in the file save dialog box
N is the index of the saved file, where 1 is the first file saved in a sequence
<ext> is the extension for the file type chosen from the file save dialog box

For example, if “xyz” is chosen as the save name, and JPEG is chosen as the file type, then the 
first two bitmaps transmitted from the TWAIN data source will be saved to:
xyz_1.jpg
xyz_2.jpg

Note: If a file with a generated name already exists, the index number for the name generation 
will be automatically advanced until an unused index is found. For example, if a directory 
contains the files
xyz_1.jpg
xyz_2.jpg
and another acquisition is made with “xyz” chosen as the save name, then the first file saved for 
the new acquisition will be “xyz_3.jpg”.

Select Source…
Presents a dialog of the available TWAIN data sources on the computer system. The source 
selected will be used for all TWAIN acquisition operations.



Edit Menu

Undo
Undo the most recent operation on the current image.
See also: Undo Properties 

Flush Undo Buffer
Discard all information in the undo buffer.

Copy Full Image
Copies the current image to the Windows clipboard. The entire image is copied, not just the 
currently displayed portion.

Copy Visible Image
Copies the currently displayed portion of the current image to the Windows clipboard.

Copy Selected Area
Copies the currently selected portion of the current image to the Windows clipboard.

Paste
Creates a new image window from a bitmap or metafile currently stored in the Windows 
clipboard.

Flush Clipboard
Removes all information from the Windows clipboard.

Select All
Selects all the images in the current folder displayed by the Explore Window .

Unselect
Removes the current area selection.

Crop
Crops the current image to the image within the boundaries of the currently selected area.

Keywords
Invokes the Keyword Entry Dialog for the current image, or for the selected images in the 
browser or Explore windows.



View Menu

Zoom In, Zoom Out, and Undo Zoom
See Panning and Zooming .

Multi-page Images
Navigation commands for moving from page to page in a multi-page image (DCX , GIF , or TIFF 
), including Next Page, Previous Page, and Go To Page commands.

Start/Stop GIF Animation
Starts or stops GIF animation. Note: GIF animation will be started automatically when a file is 
opened if the Animate GIFs on Open property of the General Properties Tab of the Properties 
dialog select is checked.

Auto-browse Images
Presents a full screen slide show of the currently open images. The behavior in the full screen 
display mode is controlled by the settings of the Browsing Properties Tab of the Properties 
dialog. 

Full Screen View
Displays the current image in full screen mode.

One-for-One Mapping
Changes the display of the current image to be actual size. The default PolyView behavior when 
opening large images is controlled by the Default One-For-One Mapping property of the General 
Properties Tab of the Properties dialog.

Resize to fit main window
Scales the current image to better fit the display area in the PolyView main window. A large 
image will be shrunk to fit the display, but small images will not be expanded.

Toolbar
Enables or disables the display of the toolbar .

Status Bar
Enables or disables the display of the status bar .

Only Image Types
When the browser or Explore windows are active this option controls the files that will be 
displayed. If Only Image Types is checked, then only files with extensions that match a PolyView 
supported image file will be shown.

Name Tips
When the Explore Window is active this option controls the display of tool tips style name 
prompts which can be output when the mouse pointer is positioned over the rectangle for an 
image file.

Sort



Sorting options for controlling the order of the files displayed in the thumbnail pane of the 
Explore Window include sorting by file name, by file type, by file size, by file date, and by image 
size . An option on the menu provides for selecting ascending or descending sort order.

Filter by Keyword
When the Explore Window is active this option enables or disables filtering the thumbnail view 
by keyword. When enabling, the Keyword Search dialog is invoked to select the keyword filter.

Change Keyword Filter
When the Explore Window is active this option invokes the Keyword Search dialog to specify a 
new keyword filter.

Filter by Name
When the Explore Window is active this option enables or disables filtering the thumbnail view 
by file name. When enabling, the Filename Filter dialog is invoked to specify the name filter.

Change Name Filter
When the Explore Window is active this option invokes the Filename Filter dialog to specify a 
new name filter.

Refresh
When the Explore Window is active this option refreshes the current folder view to reflect any 
file movement or disk change activity that might have occurred.



Browse Menu

Slide Show...
Presents a dialog box from which a list of images can be created for use in a slide show 
presentation. A pre-display rotation can be selected for individual image files if the default 
orientation of the image file is not correct. In addition, the timing of the display of the individual 
images in the slide show can be specified. On Windows 95 and Windows NT 4.0 systems the 
order of the slide show presentation can be changed by dragging and dropping image files to 
new positions in the slide show list, or by dragging and dropping files from the folder list to 
specific positions in the slide show list.

Open Script…
Open and play a slide show script file.

Play Slide Show
Starts the execution of the current slide show .

Save Slide Show...
Saves the current slide show in a slide show script file.

Add to Slide Show
When the active window is the Explore Window or a browse window this command is available 
to add selected images to the current slide show .

Empty Slide Show
Sets the current slide show back to empty.

Explore
Invokes the Explore Window .

Browse Thumbnail Database
Invokes the Thumbnail Database Explorer .

Browse Directory…
New Directory Browser…

Invokes a new browser window that is useful for perusing the images in a directory.

Change Directory…
Changes the directory viewed by the currently active browser .

Browse Marked Files
Invokes a new browser window to browse the images marked during a previous slide show.

Browse Selected Folder
Invokes a new browser window on the folder currently open in the Explore Window .

Browse by Keyword



Invokes the Keyword Search dialog to select images by keyword for browsing .

Change Keyword
Invokes the Keyword Search dialog to select images by keyword for browsing . Unlike the 
Browse by Keyword command, the Change Keyword command will reuse the current browse 
window rather than create a new one.

Empty Marked List
Removes all entries from the current list of marked files.



Operations Menu

Image Appearance Adjustments
See Image Appearance Manipulation .

Adjust Gamma
Invokes the Gamma Adjustment dialog to change the display gamma for the current image.

Adjust RGB
Invokes the RGB Adjustment dialog to implement precise control over the individual red-green-
blue components of an image.

Adjust Contrast and Brightness
Invokes the Adjustment Dialog to change the contrast or brightness of the current image.

Duplicate Image
Create a new window which contains a duplicate of the current image. This command is useful 
when image appearance adjustments are to be made which might drastically alter the 
appearance of the original image. Such is the case, for example, when Edge or Special Effect 
Filters are used on an image.

Smooth to New Window
Creates a new window from the currently visible area of the current image. The new window is 
the same size as the current window but is created using an interpolation algorithm which 
eliminates many of the pixelation effects which occur when an image is magnified.

Change Pixel Resolution...
Invokes the New Image Dimensions dialog to specify the dimensions of a new image that is to 
be created from the current image. This command is useful for creating wallpaper bitmaps from 
images that are not large enough to fill the entire screen.

Change Color Depth…
Invokes the Color Depth Wizard to guide the process of reducing or increasing the color depth 
of the current image.

Save Palette
Saves the current image’s color map to a Windows palette format file.

Transparent Color...
Invokes the Choose Transparent Color dialog to specify the color to represent transparency if 
the current image is exported as a GIF file.

Area Color Average 
Computes and reports the average color in an image area outlined by an area selection box. 
The color is reported as the byte values of the Red, Green, and Blue components of the color.



Options Menu

Properties...
See Properties .

Register File Types...
See Register File Types .

Background Color…
Invokes a color chooser dialog box to specify the background color used for image displays and 
in images created by the File menu Print Thumbnails To Window command. The chosen color 
will be displayed outside the actual image boundaries in the directory browser , slide shows , 
and image windows.

Text Color…
Invokes a color chooser dialog box to specify the text color used in images created by the File 
menu Print Thumbnails To Window command.

Font…
When the Explore Window is active this option invokes a dialog which selects the font used to 
display names for files that do not have thumbnails.



Thumbnails Menu

Create Selected
Starts the operations to create thumbnail sketches for the selected images and add them to the 
current thumbnail database. 

Create All
Starts the operations to create thumbnail sketches for all images and add them to the current 
thumbnail database . Options are offered to create thumbnails for images in the current folder 
only, or for the current folder and all subdirectories beneath the current folder.

ReCreate Selected
ReCreate All

Like their Create counterparts, these commands create thumbnails for all or selected images in 
a folder. The difference is that the Create commands create thumbnails only for images which 
do not currently have a thumbnail, while the ReCreate commands will replace existing 
thumbnails. This is a recommended operation to perform after the size of the displayed 
thumbnails has been changed through the Thumbnail Size dialog. Like the Create All command, 
the ReCreate All command offers options to create thumbnails for images in the current folder 
only, or for the current folder and all subdirectories beneath the current folder.

Open Database…
Opens an existing or creates a new thumbnail database .

Maintain Database…
Invokes the Thumbnail Database Maintenance dialog to view status and perform maintenance 
on the current thumbnail database .

Delete Selected Thumbnails
Deletes the thumbnails for the selected images in the Explore Window , or marks thumbnails for 
deletion in the Thumbnail Database Explorer . Note: the sizes of the thumbnail database files 
are not reduced until the Thumbnail Database Maintenance dialog is used to removed unused 
space. Note: in the Thumbnail Database Explorer the marking of thumbnails for deletion is only 
made permanent when a Maintain Database operation is performed, or the window is closed.

UnDelete Selected Thumbnails
Removes the delete mark and restores the thumbnail images for selected images in the 
Thumbnail Database Explorer .

Delete Thumbnails in Tree
This option is available in the Thumbnail Database Explorer to mark for deletion all the 
thumbnails in the current folder and subfolders of the current folder. Note the marking of 
thumbnails for deletion is only made permanent when a Maintain Database operation is 
performed, or the window is closed.

UnDelete Thumbnails in Tree
This option is available in the Thumbnail Database Explorer to remove the deleted status from 
all the thumbnails in the current folder and subfolders of the current folder.



Hide Selected
Hides the selected images from viewing via the Explore window by marking them as hidden in 
the current thumbnail database . Note: in the Thumbnail Database Explorer the marking of 
thumbnails for deletion is only made permanent when a Maintain Database operation is 
performed, or the window is closed.

UnHide Selected
Removes the hidden attribute associated with the selected images. Note: After this operation is 
performed in the Explore Window the thumbnails for the images must be recreated. 

Show Hidden
Shows both hidden and unhidden images in the Explore window. This command is useful to 
temporarily display hidden images so that the hidden attribute can be removed.

Thumbnail Size…
Invokes the Thumbnail Size dialog to view or change the dimensions used for creation, storage, 
and display of thumbnails.



Tools Menu

The Tools menu is displayed when an image window is the currently active window.

Area Selection Tool
Choose the Area Selection Tool when you want to select an area of the displayed image for 
cropping or copying to the Windows clipboard.

Zoom Selection Tool
Choose the Zoom Selection Tool when you want to zoom in on an area of the currently 
displayed image.

Panning Tool
Choose the Panning Tool when you want to reposition the currently displayed image by 
dragging a point on the image to a new location.



Windows Menu

New Window
Creates a new view of the current image. This might be useful for viewing separate portions of 
the same image at the same time.

Arrange Icons
Arranges the current image icons in an orderly fashion within the PolyView main window.

Tile Horizontal
Tile all open windows horizontally (top to bottom).

Tile Vertical
Tile all open windows vertically (left to right).

Cascade windows
Cascade all open windows.

Close all image windows
Close all open image windows.

Current Window List
The list of currently open windows. Select a window from this list to make it the current window.

Raise Images
Raise image windows above all other PolyView windows. This command is useful when several 
images are opened by the browser or Explore windows and a comparison between them is to 
be made.



Registration Menu

The Registration menu is displayed only when all other PolyView windows are closed.

License Information
Invokes the License Information dialog to view or enter PolyView licensee and license number 
information.

Register Now (Off line)
Invokes the Kagi Register program to prepare email or fax order forms for PolyView registration 
through Kagi Software.

Register Now (On line)
If the computer is connected to the Internet, this command invokes the standard browser and 
connects it to the PolyView online registration point.

See also: Registration Information 



Help Menu

Topics
Displays the PolyView help system topics.

Search For Help On
Search the PolyView help system for information on a specific subject.

Registering
Displays information about registering PolyView.

About PolyView
Displays a dialog box with information about the current version of PolyView.

Note: Context sensitive help is also available by pressing the F1 key. Context sensitive help directs the 
user to the help topic appropriate to the action currently being performed.



Image Size

For the purposes of sorting, image size is defined as the number of pixels in an image.



File Format Conversions

The Format Conversions window is entered by choosing Format Conversions from the File menu. This 
window provides a method of converting a group of files in various formats to a different output format. 
All file reading and writing is done by a background thread to insure that these potentially lengthy 
operations do not prevent the continuation of other image processing in PolyView.

The Format Conversions window contains the following controls:

Source Files List
The list of files which are to be converted. Note: the files in this list will be considered to be read-
only during the conversion process. The converted form of the image in each file will always be 
written to a different file.

Select Files…
Press this button to bring back the file open dialog to change the files in the source file list.

Destination Folder
Presents a tree of the available devices and folders accessible from your computer system. 
Select the folder where all the output image files should be written.

Destination Format
A drop down list of all the formats available for conversion. Note that not all input formats can be 
written to all output formats. Refer to the list of supported formats for further information.

Start
Push this button to start the conversion operation.

Stop
Push this button to terminate the conversion process. The process will terminate when the 
current file read or write has completed. 

Replace Existing Files
If checked then files in the destination folder with names that match the name of a converted 
output file will be replaced by the converted output file. If left unchecked then a warning 
message will be written to the Conversion Results window and the converted output file will not 
be written.

Conversion Results
A scrolling window which displays text messages indicating the current progress of the 
conversion process and informative messages about any errors that might occur.

Scroll Messages 
If checked then the Conversion Results window will automatically scroll down as the conversion 
progresses. Check this box to stop the scrolling so that messages higher up in the list can be 
viewed during the conversion.

Close



Closes the Format Conversions window. Any conversion in progress will be terminated at the 
completion of the current file being read or written.



Page Setup

PolyView uses the specification for the top, bottom, left, and right margins to define the area on the 
printed page where an image will be placed. Note that PolyView always preserves the aspect ratio 
(ratio of height to width) of an image or the visible portion of an image. Within that restriction an image 
will be expanded in all directions to fit within the specified margins. The Page Setup dialog box displays 
and changes the settings for the margins.

Units
This drop down list sets the dimensional units used to interpret the margin settings for printing. 
The available units are inches, centimeters (CM) and millimeters (MM).

Top Margin
The distance from the top of the printed page to the top of the printed image. The actual 
distance used may be different if Center Vertically is selected.

Bottom Margin
The distance from the bottom of the printed image to the bottom of the printed page. The actual 
distance used may be different if Center Vertically is selected.

Left Margin
The distance from the left edge of the printed page to the left edge of the printed image. The 
actual distance used may be different if Center Horizontally is selected.

Right Margin
The distance from the right edge of the printed image to the right edge of the printed page. The 
actual distance used may be different if Center Horizontally is selected.

Center Horizontally
If selected then an image that does not fill the area defined by the right and left margins will be 
centered between those margins.

Center Vertically
If selected then an image that does not fill the area defined by the top and bottom margins will 
be centered between those margins.



Gamma Adjustment

The Adjustment dialog offers an interactive method of adjusting the gamma factor, contrast, and 
brightness of an image.

The gamma value shown on the Adjustment dialog represents the current gamma setting for the 
image.

The action taken for the buttons on the Adjustment dialog are:

Apply
Apply the current value to the image. The image intensity is changed and the image is 
redisplayed.

Accept
Accept the current value for the image. The stored image information is updated to reflect the 
current settings.

Cancel
Cancels the dialog box and leaves the image unchanged.

Use for all images
When this box is checked on the Gamma Adjustment dialog, then the selected gamma factor 
will be applied to all images when they are opened and displayed. Caution: The gamma 
compensation performed by this operation modifies the in-memory bitmap for each image 
opened. If the image is subsequently saved, the modified bitmap is stored to the file. Unless the 
image file is saved to a format that also saves the gamma factor, such as PNG, an additional 
viewing of the file will again apply the global gamma compensation, causing undesirable color 
distortion. We recommend that the global gamma compensation always be turned OFF prior to 
opening images which are to modified and saved back to disk.

Note: The changes made to an image by the Adjustment dialog cannot be completely undone by 
running the dialog again and changing back to the original settings. Certain distortions are inevitable 
due to the flattening or expansion of the intensity curves for an image. Use the Undo command on the 
Edit menu to cancel the effects of an adjustment operation.



RGB Adjustment

The RGB Adjustment dialog implements precise control over the red-green-blue (RGB) components of 
an image. Use the individual color slide controls to adjust the percentage change you want for an 
individual component.

The action taken for the buttons on the RGB Adjustment dialog are:

Apply
Apply the current RGB adjustment values to the image. The image colors are changed and the 
image is redisplayed.

Accept
Accept the current appearance for the image. The stored image information is updated to reflect 
the current settings.

Cancel
Cancels the dialog box and leaves the image unchanged.

Note: The changes made to an image by the RGB Adjustment dialog usually cannot be completely 
undone by running the dialog again and readjusting the color components in the reverse of the original 
changes. Use the Undo command on the Edit menu to cancel the effects of an adjustment operation.



Change Image Dimensions

The New Image Dimensions dialog is used to specify the pixel dimensions of a new image that is to be 
created from an existing image.

Height and Width
Enter the height and width, in pixels, of the new image to be created. The new dimensions can 
be entered directly, or a standard screen width and/or height can be selected from the drop 
down list for the associated item.

Full or Visible Image
If Full Image is selected then the resulting image will be based on the entire contents of the 
source image. If Visible Image is selected then the resulting image will be based on only the 
portion of the source image that was visible when the dialog was invoked.

Interpolate
If selected then an interpolation algorithm will be used to generate the final image. This 
algorithm can significantly enhance the appearance of the resulting image when the final image 
is larger than the source image. It may or may not improve the appearance of an image whose 
size is being reduced.

Retain Aspect Ratio
If selected then the original aspect ratio (ratio of width to height) of the source image will be 
taken into account whenever the height or width values are changed, and the corresponding 
dimension will be automatically updated. For example, if the height is changed then the width 
value required to maintain the source aspect ratio will be calculated and inserted into the width 
field.



Color Depth Wizard

Images in PolyView can be represented and displayed in 24 bits/pixel (16 million colors), 8 bits/pixel 
(256 colors), 4 bits/pixel (16 colors), and 1 bit/pixel (2 colors) formats. The Color Depth Wizard 
provides a guided method of converting the color depth (bit/pixel ratio) to a higher or lower value. The 
resulting image is stored and displayed in a new window, leaving the original image unchanged. The 
Color Depth Wizard is invoked by choosing Change Color Depth from the Operations menu.

The Color Depth Wizard converts images to the following depths:

1 bit/pixel (monochrome) - 24, 8, and 4 bit/pixel images can be converted to monochrome 
(black and white) images. Either an error diffusion or a patterned dither method can be chosen 
to perform the conversion.

4 bits/pixel (2-16 colors) - 24, 8, and 1 bit/pixel images can be converted to 4 bits/pixel images.

8 bits/pixel(17-256 colors) - 24, 8, 4, and 1 bit/pixel images can be converted to 8 bits/pixel.

24 bits/pixel - 8, 4, and 1 bit/pixel images can be promoted to 24 bit/pixel images.

Choosing Fewer Colors
When the number of colors in an image is to be reduced, the Color Depth Wizard offers several 
choices for determining the colors that will be present in the converted image.

If a 4 bits/pixel image is to be produced, the optimum color set can be produced by analyzing 
the current image, the standard 16 color VGA color set can be used, or a palette file stored on 
disk can be chosen. (See Palette Files below.)

If an 8 bits/pixel image is to be produced, the optimum color set can be produced by analyzing 
the current image, a 216 color palette which matches that used by most World Wide Web 
browsers can be used, or a palette file stored on disk can be chosen. (See Palette Files below.) 
Choosing the 216 color palette is useful for creating an image that will be included in a web 
page and viewed on 256 color displays, guaranteeing that the browser does not create 
additional image distortions due to the use of its own color approximation algorithms. A further 
discussion of browser palettes and their limitations can be found at 
http://www.connect.hawaii.com/hc/webmasters/Netscape.colors.html.

Palette Files
Changing the colors in an image to match those of another image is best accomplished by 
saving the palette for an image to a palette file (see the Save Palette File command on the 
Operations menu), and then choosing the palette file when the Color Depth Wizard offers the 
choice of methods to determine the output colors for a reduced image. PolyView saves palette 
files in the Windows standard palette file format, and can read palette files in Windows format 
and in the format produced by some other popular image manipulation programs.

Reduction Methods
When an image is to be reproduced using a different color palette than originally, PolyView can 
use either an error diffusion or closest color algorithm. While error diffusion almost always 
creates an image that more closely approximates the appearance of the original image, the 
closest color algorithm is faster.



Increasing Color Depth (Promotion)
When the color depth of an 8, 4, or 1 bit/pixel image is increased, the appearance of the image 
will be unchanged in the resulting image. Only the storage format for the image is changed by 
this operation.



Choose Transparent Color

Graphics Format Information (GIF) files can include the specification of a color that is to be treated as 
transparent by the decoder of the file. Although PolyView displays this transparent color using the 
specified color, World Wide Web browsers will display the current background color or pattern in the 
transparent areas, resulting in the display of irregularly shaped or overlaid images on web pages.

The Choose Transparent Color dialog is used to specify the color to be used as the transparent color if 
the image is exported or saved to a GIF file. The dialog displays the current palette for the image and a 
check box that enables the output of a transparent color to the GIF file. Up to 256 colors are displayed 
in the dialog. Either the color map from the input image will be displayed, or the 256 colors which were 
calculated for an image which did not include a color map. Clicking on a color will select it as the 
transparent color, and will cause the display of the Red, Green, and Blue intensities for the chosen 
color.



Register (Associate) File Types

The Register File Types dialog is accessed through the Register File Types selection of the Options 
menu. This dialog provides direct control over the file extensions that the Windows Explorer associates 
with PolyView. Once this association is made, running the image file or slide show script file will result 
in the launching of PolyView and the display of the image or slide show.

The dialog box offers file types with their most common extensions:

Bitmap image files (.bmp)

GIF image files (.gif)

JPEG image files (.jpg and .jpeg)

Photo-CD image files (.pcd)

PNG image files (.png)

TIFF image files (.tif and .tiff)

Slide show script files (.pvs)

User defined (an arbitrary list of extensions separated by spaces, i.e., “.iff .dcx .xpm”)

When the dialog OK button is pressed, the Registry file associations for the checked extensions will be 
updated, replacing any previous association for those extensions. Press the Cancel button to close the 
dialog without making any changes.

Caution: PolyView provides no method of undoing an association. If PolyView is instructed to change 
an existing association it will do so. Restoring the original association is usually accomplished by 
reinstalling the originally associated application, although this varies from application to application.



Thumbnail Size

The size used to create and display thumbnails is initially controlled by the Default thumbnail 
dimensions option of the Thumbnails tab of the Properties dialog. Once a thumbnail database is 
created and thumbnails are being displayed, the Thumbnail Size Dialog can be used to change the 
creation and display size.

PolyView creates and displays thumbnails to fit square regions that are 100, 150, or 200 pixels on each 
edge. When the display size is changed then the new size is programmed into the current thumbnail 
database and the display dimensions for thumbnails will be immediately changed. Previously existing 
thumbnails must be deleted and recreated to make optimal use of the new display size.



Maintain Thumbnail Database

The Thumbnail Database Maintenance dialog displays the following information about the current 
thumbnail database :

The name of the current database
The number of thumbnail sketches in the current database
The space occupied by the thumbnail sketches
The unused space in the database

Unused space in the database is the space occurs when:

Thumbnails are deleted
Images are deleted
Thumbnails are hidden

The Thumbnail Database Maintenance dialog provides two methods of maintenance on the database:

Reclaim unused space
The current thumbnail database is packed to remove all unused space and reduce the size of 
the database file.

Purge thumbnails for non-existent files
The computer system is scanned to determine the accessibility of all file reference in the current 
thumbnail database . Inaccessible files are removed from the database index file. By itself this 
operation does not reclaim the associated space in the database file. Check both the Reclaim 
unused space and Purge thumbnails for non-existent files to perform complete maintenance on 
the database.



A context menu is a popup menu that is invoked by clicking the right mouse button on an object. In 
PolyView, context menus are available for thumbnails in the Explore window, or for any open image 
file.



License Information Dialog

The License Information dialog displays the current user name and license number, or allows entry of 
the current user name and license number.

Note: When entering licensing information it is imperative that the information be entered exactly as 
provided on the registration message from Polybytes.



Color Component Intensity

The intensity of a color component varies from 0 to 255. The color 0,0,0 is black and the color 
255,255,255 is white.



Metafile Dimensions

Windows metafiles contain a series of graphics commands that draw an image when played back into 
a window. The size of the window to be used is arbitrary, although some metafiles contain information 
about the intended size of the viewing window. Whether or not a suggested size is available, PolyView 
offers the Metafile Dimensions dialog to allow the dimensions to be entered, or altered.

The Metafile Dimensions dialog contains:

Original Width
The width specified for the metafile. (0 if the metafile contained no dimensional information.)

Original Height
The height specified for the metafile. (0 if the metafile contained no dimensional information.)

Bitmap Width
Edit this field to change the width of the window for the metafile.

Bitmap Height
Edit this field to change the height of the window for the metafile.

Keep Aspect Ratio
If checked, then changes to the width or height fields will be reflected in the opposite field to 
keep the window size at the same aspect ratio as the originally specified width and height.



Choose the new color depth

The first step in changing the color depth of an image is to choose the new depth. This screen offers 
the following choices for color depth:

1 bit/pixel (monochrome) - 24, 8, and 4 bit/pixel images can be converted to monochrome 
(black and white) images.

4 bits/pixel (2-16 colors) - 24, 8, and 1 bit/pixel images can be converted to 4 bits/pixel images.

8 bits/pixel(17-256 colors) - 24, 8, 4, and 1 bit/pixel images can be converted to 8 bits/pixel.

24 bits/pixel - 8, 4, and 1 bit/pixel images can be promoted to 24 bit/pixel images.

Press the Next button after choosing the depth that best suits your needs and the wizard will take you 
to the next step in the process.

See Color Depth Wizard 



Choose the color palette

Since you have chosen to change to an 8 or 4 bits/pixel image, you must now choose the method that 
PolyView should use to create the color palette for the new image. The available choices depend on 
whether an 8 or 4 bits/pixel image has been chosen.

Optimize colors for this image
PolyView will analyze the image and choose the best colors it can for the colors in the new 
image.

Use the browser standard 216 color palette (8 bit target)
The 216 color palette used for this choice is the same as that used by most popular web 
browsers when they are displaying images on 256 color systems. Choosing this palette is useful 
if you are creating images for web pages and want to be certain that they display the same on 
all systems regardless of their display settings.

Use the VGA standard 16 color palette (4 bit target)
The standard VGA palette can be used as the palette for 16 color images.

Use a palette stored in a file
Choosing this option will match the color of the image to the colors in a previously saved palette. 
PolyView can read palette files in Windows format and in the format produced by some other 
popular image manipulation programs.

Press the Next button to go to the next step in the specification process, or press the Back button to 
change the bit/pixel ratio desired for the output format.

See Color Depth Wizard 



Choose the depth reduction method

Several methods are available when an image is to be reproduced using a color palette different from 
the original:

Use the error diffusion method
The error diffusion method usually creates the best image appearance. It is the slowest method.

Choose the nearest color for each pixel (4 and 8 bit targets)
The nearest or closest color method often creates an acceptable image appearance, and is 
relatively fast.

Choose an ordered dither pattern (1 bit target)
The patterned dither method is the fastest way to create monochrome images.

Press the Finish button to begin the color reduction operation, or the Back button to change the way 
the operation has been specified.

See Color Depth Wizard



Choose the number of colors

When you have chosen to let PolyView optimize the color palette for the new image then you must also 
specify the number of colors you want to be included in the new image.

Press the Next button to choose the reduction method to use, or the Back button to change the method 
of selecting colors.

See Color Depth Wizard 



Choose the palette file

When you have chosen to match an image to the colors saved in a palette file you must specify the 
name of the file to use. PolyView can read palette files in Windows format and in the format produced 
by some other popular image manipulation programs. Specify the name of such a file, or press the 
Browse button and use a standard file open dialog to browse your system for a palette file.

Press the Next button to choose the reduction method to use, or the Back button to change the method 
of selecting colors.

See Color Depth Wizard 



Begin promotion operation

When an image is to be promoted to an increased bit/pixel ratio, its appearance will be unchanged, but 
its storage size will increase. The current step displays the uncompressed size for the new image.

Press the Finish button to begin the promotion operation, or the Back button to change the 
specification of the destination bit/pixel ratio.

See Color Depth Wizard 



Error Diffusion

Error diffusion is a method of reducing the color depth of an image that blends the available palette 
colors to approximate the appearance of the original image. As an image is scanned, the difference 
between the desired color and the closest available palette color is calculated for each pixel. This error 
value is then distributed, or diffused, amongst the pixels that border the pixel being worked on. Error 
diffusion can achieve outstanding results on many images, but it is the most time consuming of the



Patterned Dither

Patterned dither is a method of reducing the color depth of an image that blends the available colors to 
approximate the appearance of the original image through the use of a dither matrix. The net effect of 
patterned dithering is that local regions of an image have the correct color intensity, but a pronounced 
and regular pattern can be seen in the colors of the individual pixels. Patterned dither is quite fast and 
achieves acceptable results for many images.



Closest Color

The closest color algorithm chooses the color for a pixel in an image by finding the color in the palette 
that most closely matches the original color of the pixel. This method often produces acceptable 
images and is faster than error diffusion.



Choose Photo-CD Size

Choose Automatic to load an image size from the Photo-CD file based upon the Photo-CD Upsizing 
options selected from the Photo-CD Properties tab of the Properties dialog

or

choose from one of the 5 image sizes available from a Photo-CD file.



Choose Directory

The Choose Directory dialog presents an Explorer-like directory tree. Select the directory to use for the 
chosen operation from the tree presentation, or directly edit the edit box provided for the directory 
name.



Go To Page

The Go To Page dialog is available when a multi-page image is open. Select the page of the image you 
wish to view.



Keyword Entry Dialog

The Keyword Entry Dialog displays the list of keywords associated with a file or a group of files, and 
allows this list to be manipulated. The following controls are present:

File(s)
The list of files for which the keywords are to be viewed and manipulated.

Associated Keywords
The list of keywords associated with the file(s).

Existing Keywords
The list of keywords currently available in the database.

New Keywords
Enter new keywords for the file(s) here. One or more keywords can be entered, separated by 
spaces. Press the associated Add button to add them to the list for the file(s).

Add
Moves selected or entered keywords from the existing or new list to the list of those associated 
with the file(s).

Remove
Removes selected keywords from the list of those associated with the file(s).

Apply
Update the keyword database with the changes and exit the dialog.

Cancel
Exit the dialog with no changes to the keyword database.

See also: Browsing by Keyword 



Keyword Search Dialog

Use the Keyword Search dialog to initiate an image search by keyword. The following controls are 
present:

Keyword List
This is the list of keywords to search on. Enter a new list or select a previous to modify by 
dropping down the selection list for this box.

Keywords can be separated by "or", "and", and “and not” to achieve logical combinations of 
keywords. Note: Evaluation is always in left to right order with no implied precedence.

An "and" operation is assumed if a list of keywords is not separated by a logical operator.

Available Keywords
The list of keywords currently associated with images. Choose one or more of them and press 
the And or Or buttons on the right to add them to the list of keywords to search on.

And
Press the And button to add the selected keyword(s) to the search list as a logical AND 
operation.

The AND operation indicates that the search should find only images containing ALL of the 
keywords.

And Not
Press the And Not button to add the selected keyword(s) to the search list as a logical AND 
NOT operation.

The AND NOT operation indicates that the search should find only images containing none of 
the keywords.

Or
Press the Or button to add the selected keyword(s) to the search list as a logical OR operation.

The OR operation indicates that the search should find images containing ANY of the keywords.

See also: Browsing by Keyword 



Filename Filter Dialog

The Filename Filter Dialog is the entry mechanism for specifying a name filter to be applied to the 
image file names in the Explore window. Only images containing the specified name filter string in their 
file names will be displayed in the thumbnail pane.

For example, if the string “wolves” is entered,    then files named
5wolves.jpg
wolves on rock.gif

will be displayed, but
birds in a flock.gif

will not.



Panning and Zooming Images

Panning
Images that do not fit within a displayed window can be panned (positioned) by using the scroll-
bars that appear on the window or by using the Panning Tool available on the Tools menu. On 
systems with a wheel mouse or three-button mouse, the middle or wheel button can be used for 
panning by pressing and holding the button and dragging the resulting anchor point to a different 
location.

Zooming the Image
PolyView can change the magnification of a displayed image in several ways.

The Zoom In command on the View menu increases the magnification of a displayed image by 
about 50%. If the image displayed at the resulting magnification level will fit entirely within the 
dimensions of the PolyView viewing area, then the image window size is increased. Otherwise, 
the original window size is maintained, with the center of the newly magnified image the same 
as that at the previous magnification, and scrollbars are added to the image window. On 
systems with a wheel mouse, rotate the wheel one step forward (away from you) with the 
keyboard Control (Ctrl) key held down to zoom in by about 50%.

The Zoom Out command on the View menu decreases the magnification of a displayed image 
to about 75% of its previous value. On systems with a wheel mouse, rotate the wheel one step 
back (towards you) with the keyboard Control (Ctrl) key held down to zoom out by about 75%.

The Undo Zoom command on the View menu changes the magnification and image display 
position to the conditions which existed prior to the previous Zoom In or Zoom Out command. 

A more interactive zoom is available by selecting the Zoom Selection Tool from the Tools menu 
and then using the left mouse button to draw a rectangle around the area to be displayed in the 
magnified image. When the button is released the image will be rescaled. The Undo Zoom 
command can be used to go back to the previous magnification. (This action is only available if 
the Enable interpolated zoom option of the General Properties Tab of the Properties dialog is 
not selected.)



Interpolated Zoom

If the Enable interpolated zoom option of the General Properties Tab of the Properties dialog is 
selected then a zoom operation invoked by drawing a rectangle around an area of an image causes a 
new window to be created which contains an interpolated version of the area of interest. The 
interpolation method of zooming typically results in much better looking images than non-interpolated 
zooming. As usual, the tradeoff is speed and memory usage versus image quality. The interpolated 
image takes significantly longer to produce (especially on 386 systems without math coprocessors) 
and causes a new internal memory structure to be allocated to hold all the data associated with the 
new image.

Recommendation: Leave the Enable interpolated zoom option disabled so you can quickly zoom in on 
an area of interest in an image. Once the area is displayed at the appropriate scale use the Smooth to 
New Window command from the Operations menu to create a smoothed version of the image view you 
are looking at.



Full Screen Display Modes

The Full Screen View and Auto-browse Images commands on the View menu display the current 
image using the entire display screen. Images displayed in full screen mode will be downscaled to fit 
within the screen boundaries if the raw image size exceeds the screen pixel dimensions.

Automatic Image Cycling
In auto-browse mode images will be changed at the rate indicated by the Browsed Image 
Display Time property of the Browsing Properties Tab of the Properties dialog.

Manual Image Cycling
While browsing images in full screen mode, the left and right mouse buttons and cursor control 
keys can be used to manually cycle through the selected images, pausing any timed image 
cycling that is in progress. The left mouse button causes the display of the previously displayed 
image, and the right mouse button causes the display of the next image. Press the ‘P’ key to 
resume timed image cycling.

Note: Under Windows 95 and Windows NT 4.0 a right mouse button click near the top of the 
screen will invoke the standard context menu, interfering with the full screen mechanisms used 
by PolyView. There is currently no workaround for this problem except to avoid this area of the 
screen with the mouse cursor while using the right button to cycle images.

Canceling Full Screen Mode
Full screen mode is canceled by entering any non-controlling key from the keyboard.



General Slide Show Information

A slide show is a collection of images displayed by PolyView in a sequential fashion that is similar to a 
traditional slide show done with photographic slides. A slide show can be displayed in a fully automatic 
mode with a fixed or variable display time for the images, and the order the images are displayed can 
be randomized. In addition, the individual images in a slide show can be rotated from their default 
configuration. Slide shows are displayed in a window or using the computer’s entire screen. Images 
that are larger then the display area will be downscaled to fit within the display area boundaries. Many 
of the characteristics of slide shows can be customized through the Browsing Properties Tab of the 
Properties dialog.

Automatic Image Cycling
Images are changed at the rate indicated by the Browsed Image Display Time property of the 
Browsing Properties Tab of the Properties dialog if an individual image display time has not 
been specified. If Browsed Image Display Time indicates that images are to be cycled manually, 
then images are changed under keyboard and mouse control.

Note 1: When a slide show is manually browsed there will be periods of time after a new image 
is displayed when the next image will not be available for display. During this period while the 
next image is decompressed the system displays an hourglass cursor. PolyView attempts to 
load the next image to be displayed by assuming that it is the next file in the slide show list in 
the direction that was directed by the last mouse click.

Note 2: Under Windows 95 and Windows NT 4.0 a right mouse button click near the top of the 
screen will invoke the standard context menu, interfering with the full screen mechanisms used 
by PolyView. There is currently no workaround for this problem except to avoid this area of the 
screen with the mouse cursor while using the right button to cycle images.

Randomized Slide Shows
If Randomize Slide Shows has been selected from the Browsing Properties Tab of the 
Properties dialog then the ordering of images displayed in a slide show will be randomized.

Starting a Slide Show on a Specific Image
If Start slide show from last/selected image has been selected from the Browsing Properties Tab 
of the Properties dialog then slide show will start with the image that was last displayed in a 
slide show during the current PolyView session. With Start slide show from last/selected image 
selected a slide show can also be directed to start on a specific image. To start the slide show 
on a specific image, view the current slide show list from the Slide Show command of the 
Browse menu, select the desired image from the lower image list, and press the Play button.



Keyboard Control During Slide Shows

The following keyboard and mouse commands are effective during a slide show:

‘p’ or ‘P’ pauses or resumes a timed slide show.

‘m’ or ‘M’ marks the image that is currently displayed. Marked images can be reviewed and 
manipulated through the use of the Browse Marked Images command on the Browse menu.

Cursor Keys and Mouse Buttons move the display forward or backward through the image 
list. Up or Left keys (left arrow, left button, up arrow, Page Up) move the display to the previous 
image in the list. Down or Right keys (right arrow, right button, down arrow, Page Down) move to 
the next image in the list. Note: when a slide show is displayed in full screen mode the left and 
right mouse buttons will move the display to the previous and next images respectively.

Mouse Wheel rotation also moves the display forward or backward through the image list. 
Rotating the wheel towards you moves the display to the next image in the list. Moving the 
wheel away from you moves to the previous image in the list.

All other keys cancel the slide show. Note: a full screen slide show is also canceled by 
spurious Windows operations that occur, such as another applications window popping up, or 
the termination of the PolyView splash screen. If a PolyView slide show script is used to start 
PolyView from the Windows Explorer or File Manager you should first disable PolyView’s splash 
screen through the General tab of the Properties dialog.



Slide Show Scripts

Slide show script files contain a list of image file names to be included in a slide show. The ordering of 
the file names in the script determines the order the images will be displayed during the slide show.

Slide show script files should be stored in a text file with the file type PVS. When a file with the type 
PVS is opened by PolyView, the contents are read and the slide show is started. If the PVS file type 
has been registered for PolyView through the Register File Types dialog, then Windows 95 Shortcuts 
or Program Manager Program Items can be created for the script file.

Rotation Options
In some cases, particularly with Photo-CD images, the default orientation of an image is 
incorrect. Script files can therefore contain rotation options for each individual file. A rotation 
option is a character string of the form "/rn" attached to the end of a line in the script file for a 
specific image, where "n" is in the range from 1 to 3 and indicates the number of 90 degree 
clockwise rotations to be applied to the image prior to display. For example, if the following lines 
are stored in a file named "slideshow.pvs"

c:\images\image1.jpg
d:\images\image2.pcd /r1
c:\images\image3.bmp

then the images "image1.jpg", "image2.pcd", and "image3.bmp" will be displayed in the order 
shown, with "image2.pcd" rotated clockwise 90 degrees from its "normal" orientation.

Sound Options
Slide show images can optionally be associated with sound files by including the “/s” option on 
an image description line:

c:\images\image1.jpg /s mysound.wav
c:\images\image2.jpg /l mysound.wav

When the image specified with a sound file is displayed, the playing of the sound file will be 
started. If a previously specified sound file is still playing it will be terminated.

If the “/s” option is included on an image line without a sound file specification, any currently 
playing sound file will be terminated.

Like the option to play a sound, the “/l” (letter L, as in Loop Forever) option starts playing a 
sound file. At the conclusion of the playing, however, the same wave file will be automatically 
restarted.

The “/w” option on an image description line specifies that the image is to be displayed until its 
display time has elapsed and any playing sound file has finished.

c:\images\image1.jpg /s mysound.wav
c:\images\image2.jpg /w

The above sequences starts the wave file playing on image1.jpg and displays image2.jpg until it 



has finished. Both options can be included on the same description line:

c:\images\image1.jpg /w /s mysound.wav

Timing Option
A timing options is a character string of the form “/ts” attached to the end of a line in the script 
file for a specific image, where “s” is in a non-zero number specifying the display time for the 
image named on that line. For example, if the following lines are stored in a file named 
“slideshow.pvs”

c:\images\image1.jpg
d:\images\image2.pcd /t100
c:\images\image3.bmp

then the images “image1.jpg” and “image3.bmp” will be displayed for the time which is 
specified by the Browsed Image Display Time property of the Browsing Properties Tab of the 
Properties dialog, and “image2.pcd” will be displayed for 100 seconds.

Saving Script Files
Each time a slide show is displayed by PolyView, the list of files and their rotation options are 
maintained in memory. When the Slide Show option of the Browse menu is invoked, the current 
slide show list is displayed in the dialog box. At this point the files in the show can be removed 
or have their rotation options changed, or new files can be added. After the slide show is started 
and then stopped, the Save Slide Show option of the Browse menu can be invoked to create or 
change a script file. By using this mechanism, script file creation and editing can be 
accomplished entirely within PolyView, minimizing the chances for creating script files with 
incorrect formats.



Image Properties

The Image Properties dialog is invoked when by choosing the Image Properties command from the 
File menu, or by choosing Properties from the context menu for an image or its thumbnail. The Image 
Properties dialog provides:

Format Specific Description
A read-only text box that lists the format of the image, and various pieces of informat about its 
internals.

Embedded Comments
A text box that lists any comment records found in the image. On open images, and for 
registered users of PolyView, this text box can be updated with additional information. If the 
image is later saved to a GIF, JPEG, or PNG file, the updated comment records will also be 
output to the file.

Width and Height
Lists the Width and Height of the image, in pixels.

Bits per Pixel
Lists the number of bits per pixel for the image. This is a indicator of the maximum number of 
colors that can be present in the image.

File Size
The size of the image file, in bytes.



Selecting the Image Window Background Color

The background color is used for filling in the areas outside the image when an image window is 
expanded past the dimensions of an image, and for full screen displays when the image is smaller than 
the screen. Choosing the Background Color command from the Options menu will invoke a Windows 
color selection dialog to select the background color of choice.



Multi-page Images

Several standard image formats have a structure that supports storing multiple images in a single file. 
PolyView supports multi-page images in GIF , DCX , and TIFF formats.

When a multi-page image is initially opened, the first image in the file is displayed in the normal 
manner. At the same time, however, the Next page (Ctrl-Page Down), Previous page (Ctrl-Page Up) 
and Go to page choices on the View menu (cascaded under the Multipage Images item) are enabled. 
These menu choices enable navigation through the images contained in the file. Note: the Next page 
and Previous page commands treat the images in a file as if they were arranged circularly. That is, 
choosing Previous page while you are viewing the first image in a file will cause the last image in the 
file to be displayed, and choosing Next page while viewing the last image in the file will cause the first 
to be displayed.



Saving and Exporting Images

The save format for an image is determined according to the user operations performed and the 
original format of the image to be saved.

If the Save selection from the File Menu is made, then the image is saved in the same format as the 
original format of the current image, and replaces the original input file. The Save selection is only 
enabled if the original image format is one of the formats supported by PolyView for file saving.

If the Export Image... selection from the File Menu is made, the Export Image dialog box is invoked.    
The save format is specified by the user by selecting the format from the Files of Type: drop down list 
in the Export Image dialog box.

If the Yes response is chosen from the Save changes to <filename> dialog invoked when closing a 
modified image, and the original format is one of the formats supported by PolyView for file saving, 
then the modified image will replace the original image in the input file. If the format of the current 
image is not supported for saving, then the Yes response will invoke the Export Image dialog box 
where the new name and format for the file can be specified.

See also:

JPEG Properties 
Supported Formats 



Batch Format Conversions

The Export Image command on the File menu stores an open image to any format supported by 
PolyView for output. When multiple files are to be converted to the same format, however, it is faster 
and more convenient to use PolyView’s Format Conversion window to perform the conversions in an 
automated fashion.

The Format Conversions command on the File menu invokes the Format Conversion window. When 
the command is initially chosen, PolyView activates a modified file open dialog to solicit the list of files 
to be converted.    Drag and drop files from the list of files in each chosen folder to the Input files for 
conversion list and/or use the supplied buttons to add or remove files from the list. Press the Continue 
button when the selection of files to convert is complete and the Format Conversion window will be 
activated to allow further specification of the characteristics of the conversion operations. 



Saving Images as Wallpaper

The image or pattern that is displayed on your computer screen behind all windows and icons is known 
as wallpaper. PolyView can save an open image as your computer’s wallpaper by invoking the Save 
as wallpaper command from the File menu while the image is the currently active image. If the image 
to be made into wallpaper is smaller than the screen then you may want to use the Change Pixel 
Resolution command from the Operations menu to resize it appropriately. This command invokes the 
New Image Dimensions dialog to interactively specify new dimensions for the image. Note: the image 
is saved into the Windows directory as a file named “PolyView Wallpaper.bmp”, replacing any file by 
that name that previously existed.



Saving to Multi-page Images

Several standard image formats have a structure that supports saving multiple images in a single file. 
PolyView supports multi-page images in DCX and TIFF formats. (See the discussion of animated GIF 
files for a discussion of storing multiple images in GIF files.)

When the Export Image command on the File menu is used to specify output to a multi-page format 
file, and the name of an existing file is chosen, you have a choice of whether to replace the existing file, 
or append the current image to it. Refer to the discussion on multi-page file viewing for information on 
viewing files created or modified in this fashion.



Saving an Image's Palette

The palette for an image contains the set of colors used in the image. PolyView’s palette support is 
aligned with Window’s palette support, however, so a palette can contain at most 256 colors. PolyView 
can save the palette for an image to a Windows standard palette file (.PAL extension) through the Save 
Palette command on the Operations menu. Note: this command will create a reduced color palette if it 
is run on an image with more than 256 colors.

Why would you want to save an image’s palette? One of the uses of the Color Depth Wizard, selected 
by choosing Change Color Depth from the Operations menu, is to force the palette for an image to 
contain use the same palette as another image. This can be accomplished by first saving the palette 
for the image whose colors are to be used in the second image, then providing the name of the saved 
palette file to the wizard at the appropriate point.



Specifying the Print Positioning Information

The Page Setup command on the File invokes the Page Setup dialog. Use this dialog to specify print 
margins and centering characteristics for subsequent image and thumbnail printing operations.



Specifying the Printer

The Print Setup command on the File menu invokes a standard printer selection dialog. Use this dialog 
to specify the printer to use for image and thumbnail printing, the page orientation (portrait or 
landscape), and any printer specific properties that are needed to get the desired printed output.



Previewing Printed Output

The Print Preview commands on the File menu allow you to see a representation of printed output on 
the screen. This is useful to see the relationships between the dimensions of the printed page and the 
size of the image or thumbnails that are being printed. Although the size and position representation 
shown in the Print Preview window is accurate, please note that the representation of colors will 
typically not be.



Printing Images

The Print commands on an image’s File menu, and the Print button on the Print Preview window, are 
used to print all or a portion of an image on a printer connected to your computer system. Note: image 
printing is restricted to registered users of PolyView.

When printing is requested through one of the above mechanisms, a standard print dialog dialog is 
invoked to allow specification of the printer to use, the page orientation (portrait or landscape), and any 
printer specific properties that are needed to get the desired printed output. If you have run the dialog 
previously in the current PolyView session, or used a printer setup dialog through the Print Setup 
command, then pressing the OK button on the dialog will start printing using all the previous settings.

Image printing uses the specifications set by the last invocation of the Page Setup dialog to control 
margins and centering. The settings specified in the Page Setup dialog are saved between PolyView 
sessions.



Printing Thumbnails

The Print Thumbnails command on the Explore window’s File menu is used to print one or more pages 
of thumbnails from the currently open folder.

When thumbnail printing is requested, a standard print dialog dialog is invoked to allow specification of 
the printer to use, the page orientation (portrait or landscape), the thumbnail pages to print, and any 
printer specific properties that are needed to get the desired printed output. If you have run the dialog 
previously in the current PolyView session, or used a printer setup dialog through the Print Setup 
command, then pressing the OK button on the dialog will start printing using all the previous settings.

Thumbnail printing uses the specifications set by the last invocation of the Page Setup dialog to control 
margins. The settings specified in the Page Setup dialog are saved between PolyView sessions.

The number of thumbnails printed on each page is controlled by the setting of Number of thumbnails 
per row when printing specification on the Thumbnails tab of the Properties menu.



The Explore Window

The PolyView Explore window provides methods of exploring the contents of the folders accessible to 
an Explorer compatible computer system. These methods include creating, viewing, and manipulating 
the thumbnail sketches of the image files contained in the system’s folders. The Explore window is 
started by selecting the Explore command from the Browse menu.

The appearance and operation of the Explore window is the same in most ways as the appearance 
and operation of the Windows Explorer. The Explore window presents a hierarchical tree view of the 
folders accessible to your computer in the left pane of the window, and a representation of the image 
files in the currently selected folder in the right pane of the window. 

When the Explore window opens a folder it reserves a rectangle for each image file found in the folder. 
If a thumbnail is available for an image then it is displayed, otherwise the name of the file is displayed 
against a gray background. Since the display rectangle for files is frequently too small for the long file 
names commonly used, PolyView displays the full path name of a file on the Explore window status bar 
whenever the mouse cursor is positioned over the file. Also, if the mouse cursor is left stationary for a 
few moments then a small window containing the name of the file under the cursor will be displayed.



Explore Window Compatibility Requirement

The Explore window requires Windows 95 or Windows NT 4.0 or later.



Thumbnail Creation and Management

The following are the thumbnail creation and management operations available within the Explore 
window :

Creating or Recreating Thumbnails
Thumbnail sketches of images are created by choosing Create All, Create Selected, Recreate 
All, or Recreate Selected from the Thumbnails menu, or by choosing Create, Create All, or 
Create Selected from the context menu for an image. The context menu Create command 
creates a thumbnail only for the image that was clicked. The All and Selected variants of the 
Create and Recreate commands create thumbnails for all the images in a folder or the selected 
images in a folder respectively.

PolyView creates thumbnails using a background thread to insure that user operations can 
occur responsively at the same time. While thumbnail creation is taking place, a progress 
indicator on the status bar will be active. If the Explore window is closed while thumbnail 
creation is ongoing, then the operation will be aborted. Any thumbnails created before closing 
will be preserved.

Deleting Thumbnails
The thumbnail sketch of an image that is not currently selected can be deleted from the 
thumbnail database by choosing Delete Thumbnail from the context menu for an image. The 
thumbnails of all the selected images in a folder can be deleted by choosing Delete Selected 
Thumbnails from the File menu, or by choosing Delete Thumbnail from the context menu for one 
of the selected images.

Hiding and Unhiding Images
An image can be hidden from display in the Explore window by choosing Hide from the context 
menu for an image, or the selected images can be hidden by choosing Hide Selected from the 
Thumbnails menu. Hidden images can be seen again by choosing Show Hidden from the 
Thumbnails menu at which point they can be unhidden using the unhide commands in the 
menus. Note: when an image is hidden its thumbnail sketch is lost and must be recreated when 
it is unhidden.



Image and Folder Management

The following are the image and folder management operations available within the Explore window :

Printing Thumbnails
When the Explore window is active the Print and Print Preview commands on the File menu 
print or preview the thumbnails in the currently selected folder. Options concerning thumbnail 
printing can be found on the Thumbnails tab of the Properties dialog.

Printing Thumbnails to a Window
When the Explore Window is active the Print Thumbnails To Window command on the File 
menu uses the current contents of the thumbnail pane to build an image window containing the 
print formatted image of all or selected thumbnails. The resulting image window can 
subsequently be exported to any supported file format. Note: printing a large number of 
thumbnails to an image window can create a very large image requiring large amounts of 
system memory resources. When the command to print to a window is invoked, PolyView will 
provide you with information regarding the size of the resulting image prior to commencing the 
build operation.

The image window created uses the current PolyView background and text colors for 
background and titling colors. Use the appropriate commands on the Options menu to select the 
best combination for your purposes.

Selecting Image Thumbnails
Image thumbnails are selected by clicking the left mouse button on the rectangle for the image. 
If the Control key is held down while a selection is made, then any previously selected images 
will remain selected. If the Shift key is held down while a selection is made, then all images will 
be selected between and including the current image and the previously selected image.

A selected image is indicated by a colored outline on the image rectangle.

Opening and Viewing Images
An image can be opened for viewing by double-clicking the image rectangle, by selecting Open 
from the context menu for an image, or by selecting the image and choosing Open from the File 
menu. Note: the Open command will open all selected images if the Create New Window 
property from the File Properties tab is selected. If the Replace Current Window property is 
active, then only the first selected image will be opened.

Creating New Folders
Choose the New Folder command from the File menu to name a new folder to be created as a 
sub-folder on the currently selected folder.

Moving and Copying Images and Folders
Folders and mage files can be moved and copied by using drag and drop. Drag an item by 
pressing and holding the left or right mouse button on the item and moving the mouse cursor to 
the folder that is to be the destination of the move or copy. The operation will be completed 
when the mouse button is released while the destination folder is highlighted.

If the left mouse button is used for the drag and drop operation, then the default operation 
performed is to move the item to the destination folder. To copy an item using the left mouse 



button, hold down the Control key on the keyboard before releasing the mouse button.

If the right mouse button is used for the drag and drop operation, then a popup menu will appear 
when the button is released over a destination folder. This menu offers the choices of moving, 
copying, or canceling.

Renaming Images and Folders
An image or a folder can be renamed by choosing Rename from the context menu for an image, 
or by selecting the image or folder and choosing Rename from the File menu. Either method will 
invoke a dialog box into which the new name for the item can be entered. Note: you cannot 
rename a file into a different folder using this method.

Deleting Images and Folders
An image that is not currently selected can be deleted by choosing Delete File from the context 
menu for the image. All the selected images in a folder, or a selected folder, can be deleted by 
choosing Delete from the File menu, or by choosing Delete File from the context menu for one 
of the selected images. Note: Deleted files and folders are actually sent to the Recycle Bin. The 
properties set in the Recycle Bin control whether or not a confirmation message is displayed 
when items are deleted from the Explore window. 

Adding Images to a Slide Show
An image can be added to the current slide show by choosing Add to slide show from the 
context menu for an image, or the selected images can be added by choosing Add to slide show 
from the Browse menu. Images added to the slide show are added to the end of the existing list.

Accessing Image Properties
The properties for an image can be viewed by choosing Image Properties from the context 
menu for the image.



The Thumbnail Database Explorer

The PolyView Thumbnail Database Explorer provides a mechanism for exploring and manipulating the 
contents of PolyView’s thumbnail databases independent of the image files represented by the 
thumbnails. The following operations are available within the Thumbnail Database Explorer:

Viewing Thumbnails
Thumbnails for active images, deleted images, and images not on a currently mounted 
removable drive can be viewed in the Thumbnail Database Explorer.

Printing Thumbnails
When the Thumbnail Database Explorer is active the Print and Print Preview commands on the 
File menu print or preview the thumbnails in the currently selected folder. Options concerning 
thumbnail printing can be found on the Thumbnails tab of the Properties dialog.

Printing Thumbnails to a Window
When the Thumbnail Database Explorer is active the Print Thumbnails To Window command on 
the File menu uses the current contents of the thumbnail pane to build an image window 
containing the print formatted image of all or selected thumbnails. The resulting image window 
can subsequently be exported to any supported file format. Note: printing a large number of 
thumbnails to an image window can create a very large image requiring large amounts of 
system memory resources. When the command to print to a window is invoked, PolyView will 
provide you with information regarding the size of the resulting image prior to commencing the 
build operation.

The image window created uses the current PolyView background and text colors for 
background and titling colors. Use the appropriate commands on the Options menu to select the 
best combination for your purposes.

Deleting Thumbnails
Commands are available on the Thumbnails menu to Delete and UnDelete individual or entire 
trees of thumbnails. Thumbnails marked for deletion in the Thumbnail Database Explorer are not 
actually deleted until a Maintain operation is performed, or the Thumbnail Database Explorer is 
closed.

Hiding Thumbnails
Commands are available on the Thumbnails menu to Hide and UnHide thumbnails. The data 
associated with thumbnails marked as hidden in the Thumbnail Database Explorer is not 
discarded until a Maintain operation is performed, or the Thumbnail Database Explorer is 
closed.



The Browse Window

The PolyView Browse window is an image preview window that displays a list of file names in the left 
pane and a view of the currently selected image file in the right pane. The file name list is either the 
contents of a browsed folder, or the list of currently marked files.

See also: Browsing Folders 
Browsing Marked Files 
Browse by Keyword 

The following image management operations are supported from the Browse window:

Copying and Moving Files
Selected files can be copied or moved to a different location by choosing Copy or Move from the 
File menu. A directory selection dialog will be invoked to solicit the destination for the operation.

Renaming Files
A single selected file can be renamed by choosing Rename from the File menu. A rename dialog 
will be invoked to solicit the new name for the file.

Deleting Files
Selected files can be deleted by choosing Delete from the File menu.

Adding Images to a Slide Show
Selected images can be added to the current slide show by choosing Add to slide show from the 
Browse menu.

Accessing Image Properties
The properties for a selected image can be viewed by choosing Image Properties from the File 
menu.



Selecting Images

A single image is selected by clicking on its name in the left pane of the Browse window. Select 
multiple images by holding down the Control key while additional images are clicked, or use the Shift 
key to select ranges of images.



Browsing Folders

The Browse window can be used to browse a file folder by selecting Browse Directory from the Browse 
menu, or by selecting Browse Selected Folder from the Browse menu when a folder is selected in the 
Explore window  ’  s   folder tree.



Browsing Marked Files

The Browse window can be used to browse the current list of marked files by selecting Browse Marked 
Files from the Browse menu. See the discussion on keyboard control during slide shows for further 
information on marking files.



Browsing by Keyword

The Browse window can be used to browse images selected via keywords by selecting Browse by 
Keyword from the Browse menu. 

Assigning keywords to images
Use the Keywords command on the Edit menu to assign keywords to an open image, or to a 
group of images selected in the Browse or Explore windows. One or more keywords can be 
assigned to each image or group of images.

Selecting images by keyword
The Browse by Keyword command on the Browse menu invokes the Keyword Search dialog to 
enter a set of keywords for image selection. 

Keywords can be combined in logical combinations to select images. For example:

mountains or lakes

selects images containing either the keywords “mountains” or “lakes”. The keyword expression:

mountains and lakes

selects images containing both the keywords “mountains” and “lakes”, but not images 
containing only one or the other.

PolyView’s logical combination of keywords progresses from left to right through the keyword 
expression without regard to precedence. The expression:

mountains and lakes or valleys

creates a list of images containing both the “mountains” and “lakes” keywords. This list is then 
combined with all images containing the keyword “valleys”. The expression:

mountains or lakes and valleys

creates a list of images containing either “mountains” or “lakes”. This list is then pruned of 
images which do not contain the “valleys” keyword.



General Appearance Manipulation

When an image file is initially opened and displayed, PolyView displays it using the specifications 
found in the file. In some cases it is desirable to change that default appearance, either to apply some 
special effects, or just to enhance its appearance on the display screen. PolyView offers a number of 
operations for altering an image’s appearance, ranging from the subtle to the bizarre. These 
operations fall into the following general categories:

Color and Intensity 
Methods that adjust the color balance, contrast, and brightness of an image.

Gamma Adjustment 
An adjustment which compensates for the intensity distortion imposed by color display systems.

Filters and Special Effects 
Various operations which can subtly or drastically alter an image’s appearance.

Rotation 
Methods which change an images orientation.

Cropping 
Trimming off unwanted areas of an image.

Color Resolution 
Changing the number of colors that can be contained in an image.

Resizing 
Changing the size and the number of pixels in an image.

Transparent Color Specification 
Specifying a color to use to denote transparency when displaying images on web pages.



Adjusting Color and Intensity

The operations to adjust the color and intensity of an image are found on the Appearance submenu of 
the Operations menu, and most are on the tool bar . They include:

Brighter+
Brighter-

Adjusts the brightness level of the current image. The Brightness Adjustment Percentage on the 
General tab of the Properties dialog controls the percentage change for each click.

Contrast+
Contrast-

Adjusts the contrast of the current image. The Contrast Adjustment Percentage on the General 
tab of the Properties dialog controls the percentage change for each click.

Color+
Color-

Adjusts the relative color saturation level of the current image. (Disabled for gray scale 
images.) . The Color Adjustment Percentage on the General tab of the Properties dialog 
controls the percentage change for each click.

Red+
Green+

Adjusts the red/green tint of the current image. (Disabled for gray scale images.) The 
Red/Green Adjustment Percentage on the General tab of the Properties dialog controls the 
percentage change for each click.

Gray Scale
Converts the current image to gray scale. (Disabled for images which are already gray scale.)

Negative
Converts the current image to its photographic negative.

RGB Adjust
The RGB Adjustment dialog is available to interactively adjust the individual red-green-blue 
components of an image.

Brightness Adjust
Contrast Adjust

The Adjustment Dialog is available to interactively adjust the brightness or contrast of an current 
image.



Gamma Adjustment

The Gamma Adjust option on the Appearance submenu of the Operations menu invokes the Gamma 
Adjustment dialog to interactively specify the gamma factor for an image.

The Gamma Adjustment dialog also allows the specification of a global gamma to be used to 
compensate all images as they are opened and displayed. Caution: The gamma compensation 
performed by this operation modifies the in-memory bitmap for each image opened. If the image is 
subsequently saved, the modified bitmap is stored to the file. Unless the image file is saved to a format 
which also saves the gamma factor, such as PNG, an additional viewing of the file will again apply the 
global gamma compensation, causing undesirable color distortion. We recommend that the global 
gamma compensation always be turned OFF prior to opening images which are to modified and saved 
back to disk.



Filters and Special Effects

The Filters and Special Effects available for modifying an image’s appearance include:

Sharpen
Soften

Sharpen or soften the focus of the image. These options are available for all 24 bit images, and 
8 bit grayscaled images. The Sharp/Soft Adjustment Percentage on the General tab of the 
Properties dialog controls the percentage change for each click. The Sharpen and Soften 
commands are on the Appearance submenu of the Operations menu.

Edge Filters
Several filters which find or enhance the edges of the image. These options are available for all 
24 bit images, and 8 bit grayscaled images. The edge filters are all found on the Edge Filters 
submenu of the Operations menu.

Special Effects
Several filters which perform various special effects on the image. These options are available 
for all 24 bit images, and 8 bit grayscaled images. These filters are all found on the Special 
Effects submenu of the Operations menu.



Rotating and Flipping Images

The rotation and flipping operations are found on the Operations menu and include:

Flip
Flips the current image upside down by rotating it 180 degrees.

Mirror
Converts the current image to a mirror image of itself.

Rotate Clockwise
Rotates the current image clockwise by 90 degrees.

Rotate Counter Clockwise
Rotates the displayed image counter clockwise by 90 degrees.



Cropping Images

Cropping an image is an operation that removes unwanted parts of the image and retains the rest. 
PolyView’s cropping capability allows you to define the rectangular area on the image that you want to 
retain.

To crop an image:

1. Choose the Area Selection Tool from the Tools menu.
2. Use the primary mouse button to drag out a rectangle that defines the area of the image you 

wish to retain. (If you get this wrong just draw a new rectangle and the first will disappear.)
3. Choose the Crop command from the Edit menu and the image will be cropped down to the 

selected rectangle.



Changing Color Resolution

Color resolution changes in PolyView are performed by the Color Depth Wizard that is available by 
choosing Change Color Depth from the Operations menu.

Color resolution refers to the number of colors that are found in an image. The size of an image is 
proportional to the maximum number of colors allowed for an image. A two color image requires 1 bit 
per pixel for storage, a 4 color image requires 2 bits per pixel, etc. PolyView can reduce the number of 
colors in an image and increase the maximum number of colors in an image.

The operation to increase the maximum number of colors in an image does not change an image’s 
appearance, only its storage requirements. It is a necessary operation to perform prior to saving to 
certain file types or performing certain filtering operations, however. For example, a GIF file usually 
contains an image that uses 8 bits per pixel and contains up to 256 colors. To perform an edge filtering 
operation on a colored GIF image requires first increasing its resolution to 24 bits per pixel – a 
requirement of PolyView’s edge filtering algorithms.

Decreasing the number of colors in an image is commonly required to store images into certain file 
formats. A JPEG image, for example, usually contains an image that requires 24 bits to store each 
pixel. Storing a 24 bit image in an 8 bit TARGA format requires first decreasing the color resolution of 
the image to 8 bits per pixel.



Changing Image Size

The size of an image can be changed by choosing the Change Pixel Resolution command on the 
Operations menu. This command invokes the New Image Dimensions dialog to specify the new height 
and width of the image. Choices can be made in the dialog to preserve the original image aspect ratio 
and to use an interpolation algorithm to do the best job of creating new pixels when an image’s size is 
being increased.



Transparent Color Specification

Some image formats can include the specification of a color that is to be treated as transparent by the 
decoder of the file. World Wide Web browsers will display the current background color or pattern in 
the transparent areas, resulting in the display of irregularly shaped or overlaid images on web pages. 
PolyView supports the specification of a transparent color when reading and writing GIF image files.

The Transparent Color command on the Operations menu invokes the Choose Transparent Color 
dialog to support the specification of the color index to use for the transparent color if a file is to be 
written as a GIF file. Note: although PolyView preserves the transparent color specification in a file on 
input, the color is displayed normally.



Aspect Ratio

The ratio between the height and width of an image.



Creating Animated GIF Files

The GIF89a specification for Graphics Information Format files included the capability of a single GIF 
file containing multiple images, along with the specification of a display time and display method for 
each image. Support for an application specific construct in    GIF files was later added to the Netscape 
Navigator browser, and later to the Microsoft Internet Explorer. These specifications have resulted in 
the Animated GIF files, and image format which provides many of the animation and moving images 
that are seen on web sites today.

PolyView supports the creation of animated GIFs through the Create Animated GIFs window. Choose 
the Create Animated GIFs command from the File menu to invoke this window.



Viewing/Playback of Animated GIFs

In its default configuration PolyView treats animated GIF files as multi-page files and supports 
navigation through these files in the standard fashion. The Start/Stop GIF Animation command on the 
View menu will start the animation sequence on a file, or stop the sequence if the animation is currently 
running. Keep in mind, however, that PolyView’s playback capability is a simplistic imitation of that 
available within modern World Wide Web browsers. It is recommended that animations being prepared 
for web pages be previewed using an actual browser before final publication.

PolyView can also be configured to automatically start an animated GIF when it is opened. This 
capability is controlled through the Animate GIFs on Open item on the General tab of the Properties 
dialog.



TWAIN Basics

TWAIN is an interface mechanism that has been developed by the TWAIN Working Group as a 
standard method of transferring information between data sources and applications. PolyView can be 
used with TWAIN compliant scanners and digital cameras to acquire images for display or saving to 
disk files.

PolyView requires the 32 bit version of the TWAIN software for its operation. If it finds the file 
TWAIN_32.DLL in your Windows directory , then the TWAIN operations on the File menu will be 
enabled. If you have a TWAIN compatible scanner or digital camera but do not have the 
TWAIN_32.DLL file, then please check with the manufacturer of your device for an update.



Acquiring Images

Images are acquired from a TWAIN data source by choosing the Acquire command from the TWAIN 
submenu on the File menu. As images are received from the data source they are displayed in open 
image windows within PolyView. Use the Export Image command on the File menu to save each 
image.



Direct to File TWAIN Acquisitions

Images are acquired from a TWAIN data source and sent directly to image files by choosing the 
Acquire to file command from the TWAIN submenu on the File menu. The Prompt for all names in 
TWAIN acquire option of the File Properties Tab of the Properties dialog is used during this operation to 
name the individual files acquired. The Add TWAIN files to slide show option on the same tab can also 
be selected. Please refer to the information on the TWAIN submenu for further details.



TWAIN

According to the TWAIN Working Group, TWAIN is not an acronym. TWAIN stands for TWAIN.



TWAIN Data Source

A TWAIN data source is a set of software drivers provided by scanner and digital camera 
manufacturers to implement a standard mechanism of transferring image data and other information to 
applications.



The TWAIN Working Group

The TWAIN working group is a consortium of major manufacturers who developed and control the 
TWAIN standard. Further information on the working group is available at http://www.twain.org.



File Names in Slide Show Scripts

File names in slide show scripts can be either absolute path names (containing complete drive and 
directory information) or can be relative names. The “root” directory for a relative name is the directory 
where the script file is located, and the “root” drive is the drive where the script file is located. For 
example, if the script “c:\vacations\slides.pvs” contains the entries:

mountains\hood.jpg
lakes\michigan.jpg
\scenery\thebeach.jpg

then PolyView will look for the following files when the slide show is played:
c:\vacations\mountains\hood.jpg
c:\vacations\lakes\michigan.jpg
c:\scenery\thebeach.jpg



PolyView Format Dictionary

PolyView supports the following standard graphics formats for image viewing:

Adobe Photoshop (PSD) 
Apple PICT 
Bitmap (BMP) 
Commodore-Amiga IFF 
Computer-aided Acquisition and Logistics Support (CALS) 
DCX 
Encapsulated PostScript (EPS) 
FAX 
FlashPix 
GEM IMG 
Graphics Interchange Format (GIF) 
Halo CUT 
IBM IOCA 
Joint Photographics Experts Group (JPEG) 
LaserData LaserView 
MacPaint (MAC) 
Microsoft Paint (MSP) 
Photo-CD 
Pixmap (XPM) 
Portable Network Graphics (PNG) 
Sun Raster 
Tagged Interchange File Format (TIFF) 
Truevision TARGA 
Windows Icon 
Windows Metafile 
WordPerfect Metafile (WPG) 
X Bitmap 
X Windows Dump 
ZSoft PCX 



Adobe Photoshop

Adobe Photoshop format images in 1, 4, 8, and 24 bit format with a variety of compression and color 
space types can be read and displayed by PolyView.

All but 4 bits per pixel images can be saved to Adobe Photoshop files.

Note: Adobe Photoshop storage is available only to registered users of PolyView.



Apple PICT

Apple PICT is a common format for the Apple Macintosh. PolyView can read and display the raster 
form of PICT files.

All images can be saved to Apple PICT files.

Note: Apple PICT storage is available only to registered users of PolyView.



Bitmaps

BMP format files in both Windows and OS/2 formats are read and displayed by PolyView.

All images can be saved to some form of BMP format file.

1 bit Windows BMP files are bit-packed monochrome images stored as 8 bits per pixel.

4 bit Windows BMP files contain up to a 16 element color table and the uncompressed bits which make 
up the image - two pixels per byte.

4 bit Windows RLE BMP files contain up to a 16 element color table and the run length encoded bits 
which make up the image. The storage size for this format may be smaller than an uncompressed 4 bit 
Windows BMP file, particularly when an image has large areas of constant color. In some cases, 
however, an RLE file will be larger than an uncompressed image.

8 bit Windows BMP files contain up to a 256 element color table and the uncompressed bits which 
make up the image - one byte per pixel. The pixel data from 24 bit images will be color reduced for 
storage in this format. 

8 bit Windows RLE BMP files contain up to a 256 element color table and the run length encoded bits 
which make up the image. The pixel data from 24 bit images will be color reduced for storage in this 
format. The storage size for this format may be smaller than an uncompressed 8 bit Windows BMP file, 
particularly when an image has large areas of constant color. In some cases, however, an RLE file will 
be larger than an uncompressed image.

16 bit Windows BMP files contain the uncompressed bits which make up the image - two bytes per 
pixel. Up to 65536 colors can be represented by this format, using 5 bits for red, 6 bits for green, and 5 
bits for blue. This format is only available for storing 24 bit images.

24 bit Windows BMP files contain the uncompressed bits which make up the image - three bytes per 
pixel. Up to 16 million colors can be represented by this format. Note that this format is only available 
for storing 24 bit images.

Note: only 8 bit uncompressed BMP file storage is available to non-registered users.



Commodore-Amiga IFF

Commodore-Amiga IFF image files in all forms can be read and displayed by PolyView.

All images can be saved to IFF files. 

Note: IFF storage is available only to registered users of PolyView.



Computer-aided Acquisition and Logistics Support (CALS)

Computer-aided Acquisition and Logistics Support (CALS) images can be read and displayed by 
PolyView.

1 bit per pixel monochrome files can be saved to CALS format. 

Note: CALS file storage is available only to registered users of PolyView.



DCX

DCX files contain multiple PCX formatted images in a single file. Navigation commands under the View 
menu can be used to view all the images within a DCX file.

All images can be saved to DCX files. If the DCX file named for export already exists, then the file will 
either be replaced or appended to, according to user response to a prompting dialog box. 

Note: DCX file storage is available only to registered users of PolyView.



Encapsulated PostScript 

Encapsulated PostScript files can contain vector, bitmap, and screen preview image data. PolyView 
can extract and display the screen preview data from EPS files.

PolyView cannot write files in EPS format.



FAX

PolyView can read and display FAX a variety of FAX formats, including AT&T G4, Brooktrout, KOFAX, 
etc.

PolyView cannot write files in FAX formats.



GEM IMG

GEM IMG contain 16 color or grayscale bitmaps.

PolyView can read and display but cannot write files in IMG format.



Graphics Interchange Format (GIF)

GIF file images in 1, 4 and 8 bit formats are read, written,    and displayed by PolyView. PolyView 
ignores non-image related information found in GIF 89a files.

All images can be saved to non-interlaced and interlaced GIF formats. Interlaced GIF files use a 
scheme that is useful when the file is to be displayed while it is being received over a relatively slow 
medium like a serial network link. In these situations the GIF interlacing scheme allows a partial view of 
the image to be displayed when only a small portion of the entire image has been received.

GIF files can contain at most 256 colors. The pixel data from 24 bit images will be color reduced for 
storage in this format.

If the embedded comments for a file have been updated from the Image Properties dialog box 
accessible from the File menu then these comments will be written to the GIF files as comment 
records. 

Animated GIF files are a method of performing simple animation on World Wide Web pages. PolyView 
creates animated GIF files through the Create Animated GIFs command on the File menu.

Note that saving to interlaced GIF format and output of embedded comments are available only to 
registered users of PolyView.



Halo CUT

Halo CUT files are 8 bit image files generated by various DOS paint programs.

PolyView can read and display but cannot write CUT files.



IBM IOCA

IBM IOCA files are 1 bit per pixel files that support various FAX compression schemes. PolyView can 
read and display all variants of IOCA files.

PolyView cannot write files in IOCA format.



Joint Photographics Experts Group (JPEG)

JPEG format files containing 8 and 24 bit images in both progressive and non-progressive form are 
read and displayed by PolyView. Progressive format JPEG files use a storage scheme that allows 
images to be displayed while they are being received, useful when the file is to be displayed while it is 
being received over a relatively slow medium like a serial network link.

All images with a storage format greater than or equal to 8 bits per pixel can be saved to JPEG format 
files, both progressive and non-progressive. 256 color images such as those produced from GIF files, 
however, may create JPEG files which, although much smaller than the original GIF file, have 
considerable visual distortion as compared to the original. You should compare the exported JPEG file 
against the original image and experiment with the JPEG Output Quality Factor to achieve the best 
results.

If the embedded comments for a file have been updated from the Image Properties dialog box 
accessible from the File menu then these comments will be written to the JPEG file as marker text.

Note that saving to progressive JPEG format and output of embedded comments are available only to 
registered users of PolyView.



LaserData LaserView

LaserData LaserView files are 1 bit per pixel files which contain data in CCITT Group 4 format.

PolyView can read and display but cannot write LaserView files.



MacPaint

MacPaint files are 1 bit per pixel files that are always in a 720x576 size.

PolyView can read and display but cannot write MacPaint files.



Microsoft Paint

Microsoft Paint files are 1 bit per pixel files.

PolyView can read and display but cannot write Microsoft Paint files.



Eastman Kodak Photo-CD

Photo-CD is the Eastman Kodak Photo CD format. PolyView can extract any of the image sizes stored 
within these files. The Photo-CD tab of the Properties dialog controls the way PolyView opens Photo-
CD format files.

PolyView cannot write files in Photo-CD format.



Pixmap

Pixmap is a 256 color format developed for X Windows by MIT. Polyview can read and display Pixmap 
files.

PolyView can write 8 bit images to Pixmap files.

Note: Pixmap storage is available only to registered users of PolyView.



Portable Network Graphics

PNG, or Portable Network Graphics Format (pronounced ping) is a new format that may eventually 
become the standard for lossless image storage. PNG was initially designed to replace GIF, but offers 
many features that were lacking in GIF, including higher resolution color, potentially better 
compression, and patent free implementation.

8 and 24 bit format images can be saved to non-interlaced and interlaced PNG formats. Interlaced 
PNG files use a complex two-dimensional interlacing scheme that is useful when the file is to be 
displayed while it is being received over a relatively slow medium like a serial network link. In these 
situations the PNG interlacing scheme allows a highly intelligible view of the image to be displayed 
when only a small portion of the entire image has been received. If PNG files are only to be displayed 
by viewers like PolyView, then the non-interlaced format will display faster and will be slightly smaller.

If the embedded comments for a file have been updated from the Image Properties dialog box 
accessible from the File menu then these comments will be written to the PNG files as comments 
identified by the Comment keyword.

Note: PNG file storage is available only to registered users of PolyView.



Sun Raster

Sun Raster is a 1, 8, 24, or 32 bit raster image format from Sun Microsystems. PolyView can read and 
display all variants of Sun Raster files.

All images can be saved to Sun Raster files. 

Note: Sun Raster file storage is available only to registered users of PolyView.



Tagged Interchange File Format 

TIFF files come in many shapes, sizes, and colors. Because of this it is difficult to guarantee that all 
possible combinations of TIFF storage techniques will be interpreted and rendered correctly. PolyView 
does, however, support 1-4-8 bit grayscale images, 4 and 8 bit color mapped images, and 24 bit RGB, 
CMYK, and JPEG color images. These formats are supported with a variety of compression methods 
and planar configurations.

TIFF files can contain multiple images. Navigation commands under the View menu can be used to 
view all the images within a TIFF file.

PolyView saves or exports images to TIFF files in 1 bit monochrome, 8 bit grayscale, 4 and 8 bit color 
mapped, 24 bit RGB, and JPEG formats. TIFF images can be saved in uncompressed or LZW 
compressed form, as well as CCITT Group 3 and 4 FAX formats (1 bit monochrome images). If the 
TIFF file named for export already exists, then the file will either be replaced or appended to, according 
to user response to a prompting dialog box.

Note: exporting to TIFF files is only available to registered users.



Truevision TARGA

Truevision TARGA files are 8, 16, or 24 bit format images. PolyView can read and display all variants of 
TARGA files.

All images can be saved to TARGA files. Either 8 or 24 bit storage will be used, depending on the 
format of the image being saved.

Note: TARGA file storage is available only to registered users of PolyView.



Windows Icon

Windows ICON files can be read and displayed by PolyView.

PolyView cannot write Windows ICON files.



Windows Metafile

Windows metafiles are Windows standard image formats that contain series of graphics commands 
which describe images. Metafiles are found in three formats:

· Windows Metafile Format - the original standard format
· Aldus Placeable Metafile - a Windows Metafile with a header containing dimensional 

information.
· Windows Enhanced Metafile - a new metafile format.

PolyView can read and display but cannot write metafile images.



WordPerfect Metafile 

WordPerfect metafiles contain both vector and bitmap information. PolyView can display only the first 
bitmap record from a WordPerfect metafile.

PolyView cannot write WordPerfect metafiles.



X Bitmap

X Bitmaps are monochrome bitmaps. PolyView can read and display X Bitmaps.

PolyView can write 1 bit per pixel monochrome files to X Bitmaps. 

Note: X Bitmap file storage is available only to registered users of PolyView.



X Windows Dump

X Windows Dump files are 1, 4, 8, and 24 bit image files. PolyView can read and display all variants of 
X Windows Dump files.

All images can be saved to X Windows Dump files.

Note: X Windows Dump file storage is available only to registered users of PolyView.



ZSoft PCX

XSoft PCX files are 1, 4, 8, and 24 bit image files. PolyView can read and display all variants of PCX 
files.

All images can be saved to PCX files.

Note: PCX file storage is available only to registered users of PolyView.



FlashPix

FlashPix is a format for digital image storage developed by Eastman Kodak Company in collaboration 
with Hewlett-Packard Company, Live Picture, Inc., and Microsoft Corporation. FlashPix image files 
contain multiple resolution images along with transformation information to insure the best display on 
the viewing hardware.

PolyView can read and display variants of the FlashPix format. FlashPix writing and image 
transformation operations are not supported.





The name of the person registering PolyView. This item is case sensitive and must be entered exactly as shown on the message 
from Polybytes.



The license number for the registration. Enter the number that was received in the registration letter from Polybytes.



Each file dragged and dropped on PolyView will create a separate image window.



A group of files dragged and dropped on PolyView will be used as the file list for a slide show and the slide show will be 
automatically entered.



If checked then a group of files dragged and dropped will be added to the existing slide show list instead of replacing it.



Each file opened by PolyView will be displayed in a separate, newly created window.



Each file opened by PolyView will be displayed in the current window, replacing any existing image. 



A default internal comment to be written to all saved GIF, JPEG, and PNG files.



Always ask about saving images that have been altered while viewing.



Write PolyView's version signature to all saved GIF images as an internal comment.



If checked, then assume that a command line argument containing spaces is really a single long file name. Otherwise file names 
containing spaces must be enclosed in quotes.



Display the full path for an image in the window title instead of just the name of the image.



Show file names in the Explore and Browse windows even if they have been marked as hidden by the operating system.



Prompt for each name in a TWAIN multiple file acquire operation instead of    auto-generating the names based upon the first 
name entered.



Create multi-page DCX and TIFF files during TWAIN acquire to file operations.



Add the name of each file acquired during a TWAIN operation to the current slide show list.



The percentage change to be made each time a Brightness change operation is performed.



The percentage change to be made each time a Contrast change operation is performed.



The percentage change to be made each time a Red/Green adjustment operation is performed.



The percentage change to be made each time a Colorfulness adjustment operation is performed.



The percentage change to be made each time a Sharpness adjustment operation is performed.



Never display a progress bar during image decompression.



Always show a progress bar during image decompression.



Display a progress bar only on intermediate file decompression operations.



Do not automatically shrink large images to fit the available    display space.



Create a new window from an area to be zoomed by interpolating “between” the existing pixels.



Use a dithering algorithm to improve image rendering when printing color images on a monochrome printer.



If a metafile contains dimension information then use it to define the size of the window for displaying the metafile contents. If 
unchecked, then metafile dimensions will always be solicited.



Create a device dependent bitmap for each image processed when the display is configured for more than 256 colors. The 
presence of the device dependent bitmap will enhance panning operations and speed up slide show screen updates at the cost 
of additional memory usage.



Filtering operations that drastically change the appearance of an image should be used to create a new window, leaving the 
current image unchanged. 



Turn off the display of the PolyView splash screen during startup.



Automatically start playing the animation frames of an animated GIF when it is initially opened.



Reduce large images to smaller windows using a method that works best for color images.



Reduce large images to smaller windows using a method that works best for line drawings made using black lines on a white 
background.



Reduce large images to smaller windows using a method that works best for line drawings made using white lines on a black 
background.



The number of seconds an image is to be displayed in auto-browse or slide show modes. 



The images in the slide show list are each to be displayed once.    The slide show will then be terminated.



The images in the slide show list are to be continuously cycled. The slide show must be manually terminated.



The images in the slide show list are cycled only by keyboard or mouse input.



The images in the slide show list are displayed in a random order during the slide show presentation.



Ignore errors that occur while processing slide show images. If this option is not checked then errors will terminate the slide 
show.



Show the image file name in the lower right hand corner of full screen image displays.



Display a slide show in a window instead of full-screen.



Images that are smaller than the display area for a slide show should be expanded to fill the available space.



Allow multiple name selection in the slide show creation dialog. (This option should be checked to display long filenames 
correctly in an NT 3.51 system.)



Prevent a screen saver from activating during a full-screen slide show presentation.



The mode of arithmetic to be used for JPEG operations - slow but accurate integers, slow but very accurate floating point, or fast 
but slightly inaccurate integer.



JPEG chroma upsampling method – carefully and accurately, or less carefully but faster.



JPEG compression quality factor. The higher the number the better the resulting JPEG image will match the original, and the 
larger the size of the JPEG image file.



Automatically select the image size for a photo-CD image display based upon the available screen size of your machine.



Ask for the display size for each photo-CD image file opened.



The photo-CD image should be displayed in a 192W x 128H format.



The photo-CD image should be displayed in a 384W x 256H format.



The photo-CD image should be displayed in a 768W x 512H format.



The photo-CD image should be displayed in a 1536W x 1024H format.



The photo-CD image should be displayed in a 3072W x 2048H format.



Enable the photo-CD upsizing algorithm to determine the size of a photo-CD image to display based upon screen size and the 
specified “Screen Fill Percentage”.



The percentage of the screen to be filled in at least one direction when photo-CD upsizing is enabled.



The maximum number of image file names to be shown in the Most Recently Used image file list on the File menu.



Use the MRU list only during a single PolyView session. Always purge it on exit, erasing the history of the files most recently 
opened.



The list of applications that PolyView will include in the "Open With" list on an image's context menu. Click on an application to 
select it for further processing.



Add an application to the list of helper applications.



Remove the selected application from the list of helper applications.



The name that should appear on the "Open With" list for the selected application. If left blank, then the name of the application 
will appear on the list.



Enclose the file name in quotes when an image file name is sent to the selected application. This is required for some 
applications if an image file name contains spaces.



Save a thumbnail image that is optimized for display on a computer system configured to display 256 colors. This option usually 
results in the smallest thumbnail database size.



Save a thumbnail image that is optimized for display on a computer system configured to display more than 256 colors. This 
option does not display well on 256 color systems.



Save thumbnail image's for both 256 color and higher color display systems. This option results in the largest thumbnail 
database size, but the resulting thumbnails will display optimally on all display color configurations.



The number of thumbnails in each row of a printed thumbnail page.



Include the dimensions of the image with the image file name when printing thumbnail pages.



The size of a created thumbnail, in pixels, as measured along one edge of the thumbnail. This option is used only for the initial 
default thumbnail size of the database when creating a new thumbnail database.



Relax the strict drive matching criteria to allow thumbnails to be matched to images where the image was on a different drive 
when the thumbnail was created. This is useful where drive letter assignments have changed due to hardware changes, or in 
dual-boot situations where drive letter assignments differ between two operating systems. Note: Enabling drive independent 
mapping may result in unexpected behavior when identical images (identical path, size, and creation/modification time) exist on 
more than one drive.



Turns off all Undo operations. Changes made to an image cannot be reversed.



When the undo buffer is full and another undo block needs to be stored, delete the oldest undo block in the buffer which belongs 
to an image other than the current image. If the undo buffer contains only blocks for the current image, then delete the oldest 
block found.



When the undo buffer is full and another undo block needs to be stored, delete the oldest undo block in the buffer for the current 
image. If the undo buffer contains no blocks for the current image, then delete the oldest block found for any image.



When the undo buffer is full then no further undo blocks will be stored.



The size of the Undo buffer, in megabytes. An internal memory block will be allocated using this size.



The list of image files to be converted. Manipulate the files in this list by pressing the Select Files button.



Invoke the file list dialog for adding files to or removing files from the list of image files to be converted.



Start the image conversion process.



Stop the image conversion process.



Close this window and continue.



When this box is checked the Conversion Results window will automatically scroll up as conversion information is written. 
Uncheck this box if you want to stop the scrolling operation to study messages in the window while the conversion process is 
ongoing.



Progress and error information relating to the conversion process is written here.



Select the destination folder for converted files. All files created during the conversion process will be written to the selected 
folder.



The currently selected destination folder for converted files. All files created by the conversion process will be written to this 
folder.



The destination image format for the conversion process. All files created by the process will be written in this format.



A check in this box indicates that the conversion process should replace files in the destination folder if a file is to be created with 
the name of an existing file in that folder. Note that the source file for the conversion is never replaced.



The image files to be used as the source image list.



Invokes a file selection dialog to add files to or remove files from the list of source image files.



Remove the selected file(s) from the source list.



Saves all specified information for the animated GIF to a PolyView GIF animation script file.



Unpacks an existing GIF into its constituent files and an animation script. The individual files from the original file will have an 
index number appended to their names, indicating the order of placement within the original file. The script file will be the original 
name with the “.GIF” extension replaced with “.PVA”. If the Replace during unpack option is checked then existing files will be 
silently overwritten, otherwise the unpack operation will fail if file name conflicts are found. At the conclusion of the unpack 
operation the Create Animated GIFs window will be updated to reflect the operations necessary to recreate the original file.



If this box is checked then existing files will be silently overwritten during an unpack operation, otherwise the unpack operation 
will fail if file name conflicts are found.



The name of the animated GIF file to be created. Use the Browse button to select the destination name and folder.



Choose a name and folder for the destination file.



Opens the Output GIF file in a normal PolyView window. If the file is an animated GIF then it will automatically be animated. This 
button is useful for evaluating the result of building a file.



Start the build process for the animated GIF.



The amount of time an individual image is to be displayed during animation, in hundredths of seconds. Entering a new value into 
this field changes the delay time for all selected (highlighted) image names.



Controls the action to be taken by a web browser at the conclusion of the delay time for an image and just before advancing to 
the next image. Selecting a new value for this field changes the disposal method for all selected (highlighted) image names. The 
available options are:

Not specified - perform no action.

Do not dispose - leave the image on the screen. This should be the same as the first option.

Restore background - replace with the background color.

Restore previous - replace with the previous image.



Controls the way the color map for each image is handled as images are added to the output animated GIF. Selecting a new 
value for this field changes the color map option for all selected (highlighted) image names. The available options are:

Use this image - the color map for this image will be transferred to the output file as the local color map for this image.

Use first image - the color map used for this image during playback of the animated GIF will be the color map from the first image 
place in the output file.

Note: the color map from the first image in the list is always used as the global color map for the output file.



Controls the left position for the selected image within the image space defined for playback of the animated GIF (defined by the 
Width and Height fields). Entering values into these fields changes the corresponding option value for all the selected 
(highlighted) image names. Note that PolyView does not honor these offsets during playback. You will have to open the GIF with 
your web browser to see the effect.



Controls the top position for the selected image within the image space defined for playback of the animated GIF (defined by the 
Width and Height fields). Entering values into these fields changes the corresponding option value for all the selected 
(highlighted) image names. Note that PolyView does not honor these offsets during playback. You will have to open the GIF with 
your web browser to see the effect.



The iteration loop count to apply to the animation. Entering 0 in this field implies continuous looping. Any other value is the 
number of times the GIF images should be cycled each time the animation is displayed. Note that PolyView does not honor this 
count during playback but instead always loops continuously. You will have to open the GIF with your web browser to see the 
effect.



The Width and Height fields define the width and height of the display rectangle for the animated GIF file. If both fields contain 
non-zero integers then they will be written to the output GIF file. Otherwise, the width and height of the first image in the list will 
define the display rectangle size.



The Width and Height fields define the width and height of the display rectangle for the animated GIF file. If both fields contain 
non-zero integers then they will be written to the output GIF file. Otherwise, the width and height of the first image in the list will 
define the display rectangle size.



Play the slide show image list as it is currently specified.



Add the selected image file(s) to the image source list.



Add all the files in the current folder to the image source list.



Remove all the files from the image source list.



Specify the rotation to be used when displaying the selected images(s). The choices are:

None – no rotation.

Clockwise 1 – rotate the image clockwise by 90 degrees.

Clockwise 2 – rotate the image clockwise by 180 degrees (flip it upside down).

Clockwise 3 – rotate the image clockwise by 270 degrees (counterclockwise by 90 degrees).



The number of seconds to display the selected image(s). If left blank then the display time specified on the Browse tab of the 
Properties dialog will be used for the selected image(s).



Enter a value between -100 and 100 indicating the percentage change to make in the red component of each pixel.



Enter a value between -100 and 100 indicating the percentage change to make in the blue component of each pixel.



Enter a value between -100 and 100 indicating the percentage change to make in the green component of each pixel.



Adjust the slider to modify the percentage change to make in the red component of each pixel.



Adjust the slider to modify the percentage change to make in the blue component of each pixel.



Adjust the slider to modify the percentage change to make in the green component of each pixel.



Apply the current adjustment settings to the image. This operation can be undone by pressing the Cancel button or made 
permanent by pressing the Accept button.



Accept the current changes to the image's appearance and close this dialog box.



Apply the current adjustment settings to the image. This operation can be undone by pressing the Cancel button or made 
permanent by pressing the Accept button.



The selected gamma factor will be applied to all images when they are opened and displayed. Caution: The gamma 
compensation performed by this operation modifies the in-memory bitmap for each image opened. If the image is subsequently 
saved, the modified bitmap is stored to the file. Unless the image file is saved to a format that also saves the gamma factor, such 
as PNG, an additional viewing of the file will again apply the global gamma compensation, causing undesirable color distortion. 
We recommend that the global gamma compensation always be turned OFF prior to opening images which are to modified and 
saved back to disk.



The new gamma factor to be applied to the image, or the percentage change to be made in brightness or contrast.



Move this slider to adjust the gamma factor value or the percentage change in brightness or contrast to be applied to the image.



The width for the image to be created. Enter a value or choose from among several standard settings by clicking the arrow on 
this control.



The height for the image to be created. Enter a value or choose from among several standard settings by clicking the arrow on 
this control.



Use interpolation to generate the final image. This algorithm can significantly enhance the appearance of the resulting image 
when the final image is larger than the source image. It may or may not improve the appearance of an image whose size is being 
reduced.



If selected then the original aspect ratio (ratio of width to height) of the source image will be taken into account whenever the 
height or width values are changed, and the corresponding dimension will be automatically updated. For example, if the height is 
changed then the width value required to maintain the source aspect ratio will be calculated and inserted into the width field.



Base the final image on the entire source image, not just the visible portion.



Base the final image on only the visible portions of the current image.



Navigate the tree and click on the target folder to select it.



Contains the path name of the currently selected folder.    Select a new folder by navigating the tree, or type in a path here.



Choose the page number to display from this multi-page image by choosing from the list of available pages.



A description of the internal format of the image as determined by PolyView during the decompression operation.



Information found in comment records embedded in the image file. Changes made to these comments will be written to the 
output image file if this image is exported or saved to a GIF, JPEG, or PNG format file.



The width of the image, in pixels.



The height of the image, in pixels.



The number of bits representing a single pixel of the image.



The size of the file containing the image.



The base name of the current thumbnail database. The database is comprised of two files - <basename>.pvx and 
<basename>.pvd.



The number of non-deleted thumbnails in the database.



The number of bytes utilized by thumbnail information in the thumbnail database .pvd file.



The number of bytes in the .pvd file that are occupied by deleted thumbnails. These bytes can be reclaimed and the database 
size reduced by this amount by choosing the Reclaim unused space option.



If this option is chosen then a database pack operation will take place when the OK button is pressed. All deleted thumbnail 
blocks from the database .pvd file will be removed and the size of the file will be reduced accordingly.



If this option is chosen then the database will be scanned for non-existent image files when the OK button is pressed. All 
thumbnail information for image files which cannot be found on the system in their original locations will be removed and the size 
of the thumbnail database files will be reduced accordingly.



The distance from the top of the printed page to the top of the printed image. The actual distance used may be different if Center 
Vertically is selected.



The distance from the bottom of the printed image to the bottom of the printed page. The actual distance used may be different if 
Center Vertically is selected.



The distance from the left edge of the printed page to the left edge of the printed image. The actual distance used may be 
different if Center Horizontally is selected.



The distance from the right edge of the printed image to the right edge of the printed page. The actual distance used may be 
different if Center Horizontally is selected.



The dimensional units used to interpret the margin settings for printing. The available units are inches, centimeters (CM) and 
millimeters (MM).



If selected then an image that does not fill the area defined by the right and left margins will be centered between those margins.



If selected then an image that does not fill the area defined by the top and bottom margins will be centered between those 
margins.



Choose the icon to the left as the icon to display on PolyView registered file types in the Windows Explorer.



Choose the icon to the left as the icon to display on PolyView registered file types in the Windows Explorer.



Choose the icon to the left as the icon to display on PolyView registered file types in the Windows Explorer.



"Griffin", a Polybytes mascot, a Bernese Mountain Dog, and an intrepid explorer.



A stick-figure Macaw, familiar to many as PolyView's original icon.



PolyView's program icon, designed and contributed by George Edward Purdy (email: slogan@i-link.net).



Associate Windows Bitmap files (type BMP) with PolyView.



Associate Graphics Information Format files (type GIF) with PolyView.



Associate Joint Photographic Expert Group files (type JPG and JPEG) with PolyView.



Associate Kodak photo-CD files (type PCD) with PolyView.



Associate Portable Network Graphics files (type PNG) with PolyView.



Associate Tagged Interchange File Format files (type TIF and TIFF) with PolyView.



Associate slide show script files (type PVS) with PolyView.



The current name for the file to be renamed.



The new name for the file. Please note that this is a rename in place operation, so do not include any path specification in the 
new name, i.e., no backslash directory separator characters.



The current display and create size for thumbnails.



Choose a new size for thumbnails. This size will be used for subsequent thumbnail display and create operations.



This is the color palette for the current image. Click on a color to choose it as the transparent color to use if this image is 
exported to a GIF file.



Check this box to output the transparent color specification if this image is exported to a GIF file. If left unchecked then the GIF 
will be written without a transparent color specified.



The value of the green component of the currently selected color.



The value of the blue component of the currently selected color.



The value of the red component of the currently selected color.



The actual width specified in the metafile.



The actual height specified in the metafile.



The width to use for the bitmap to be created by "playing" the metafile.



The height to use for the bitmap to be created by "playing" the metafile.



If checked then the aspect ratio (height to width ratio) of the original metafile will be preserved. Changes made in the width or 
height fields of this dialog will cause the value of the corresponding field to be automatically recalculated.



Use MS Internet Explorer style "flat" toolbars. This option does not take effect until PolyView is closed and restarted. Also note 
that it may be ineffectual or cause anomalous behavior on systems which do not have the current MS Internet Explorer or MS 
Office 97 products installed.



If checked then a slide show will start with the image that was last displayed in a slide show in this session of PolyView, or from 
the image that is selected in the slide show dialog when the "Play" button is pressed.



JPEG compression quality factor. The higher the number the better the resulting JPEG image will match the original, and the 
larger the size of the JPEG image file.

Enter a number between 1 and 100 inclusive.



This is the list of keywords currently associated with, or to be associated with the file(s).



The names of the files to have their keyword lists updated.



Click this button to move the selected keywords from the existing keyword list into the list of keywords to be associated with the 
file(s).



Click this button to add the list of new keywords to the list of keywords for the file(s).



This is a list of all the keywords that have been associated with files. Select one or more and press the Add button to associate 
them with the current file list.



Type new keywords into this list, separated by spaces. To add them to the list for the current file(s), click the Add New button.



Remove the selected keywords from the list of those associated with the current file list.



This is the list of keywords to search on. Enter a new list or select a previous to modify by dropping down the selection list for this 
box.

Keywords can be separated by "or" and "and" to achieve logical combinations of keywords. "and" means that a selection of 
images which have both keywords is to be made. "or" means that a selection of images which have either keyword is to be 
made. Evaluation is always in left to right order with no implied precedence.

An "and" operation is assumed if a list of keywords is not separated by a logical operator.



This is the list of available keywords. Choose one or more of them and press the "And" or "Or" buttons on the right to add them 
to the list of keywords to search on.



Press this button to add the selected keyword(s) to the search list as a logical AND operation.

The AND operation indicates that the search should find only images containing ALL of the keywords.



Press this button to add selected keyword(s) to the search list as a logical OR operation.

The OR operation indicates that the search should find images containing ANY of the keywords.



The date of the file's last modification.



A list of file extensions to register as PolyView images. Enter the list with spaces separating individual items. For example:

        .dcx .iff .xpm



Enter a name filter here. As the Explore window scans through the image files, only image file names containing this string will 
be made visible. For example, if the string

wolves

is entered,    then files named

5wolves.jpg

wolves on rock.gif

will be displayed, but

birds in a flock.gif

will not.



This field indicates the number of files that had conversion errors in the most recent set of operations.



Check this option to display the transparency and alpha channel information in GIF and PNG files. Note: enabling this option 
changes the basic bitmap information retained by PolyView after an image is read by merging the file information with the 
background color specified under the Options menu.



Check this option to have slider position changes reflected immediately in the picture being manipulated. Note: direct editing of 
value entries will cause picture updates only when the value entry field is left via the Tab key or by mouse clicking on a different 
control.



Press this button to add selected keyword(s) to the search list as a logical AND NOT operation.

The AND NOT operation indicates that the search should find images containing NONE of the keywords.




