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Installation

To install SafetyScan, run the file called Setup.exe that comes with the downloaded package.

To run SafetyScan, click the Start Button, find the program group where SafetyScan is installed (usually StartUp) and
click the Icon labeled SafetyScan.

By default, SafetyScan will install itself in your StartUp group so that it runs automatically at the beginning of Windows. If you
choose not to install SafetyScan in the StartUp group on install, you may do it manually later - click here to find out how.




Overview

SafetyScan operates by regularly scanning your hard drive for various error producing files and then optionally cleaning them
from your system for you.

SafetyScan targets specific types of error producing files that common disk utilities, un-install, defrag, scandisk, and sweep type
programs will miss.

The error files that SafetyScan searches for and deletes can produce very hazardous results if not properly cleaned from your
drive on a periodical basis.

The symptoms that these error files can produce include:

Lost network and Internet connections.
Mysterious application lock ups.

Lost data
Unexplainable General Protection Faults (GPF’s) or Fatal Errors in your applications.

Virus like behavior
Mysterious Reboots

These error files accumulate over time, occupying megabytes of space on your hard drive. SafetyScan will clean these files and
recover the lost space from your system. Regular use of SafetyScan will prevent these files from accumulating and wasting

valuable disk space.

SafetyScan stays out of the way and is very easy to use. It sits quietly in your Windows 95 System Tray, scanning for and
cleaning error files on a scheduled basis.

The only thing you will notice is less problems with your computer and more hard drive space!



Operation

SafetyScan is very simple and easy to operate. It resides in the Windows 95 System Tray (usually the lower right corner of the
screen with the small icons) and may be accessed by ‘Right-Clicking’ on the magnifying glass icon, and selecting ‘Open’.

There are two tabbed sections of the application: The Main Tab and the Options Tab.

The Main Tab

This displays the files that SafetyScan finds when it scans. You may select a partial list of these files for deletion by using the
<Shift> and <Ctrl> keys with the mouse to select individual files, and then clean them using the ‘Clean Selected’ button, or you
may use the ‘Clean All’ button to clean all displayed files from your system.

The ‘Scan’ button allows you to manually scan for error files at any time. If the SafetyScan window is not minimized in the
System Tray, SafetyScan will not automatically scan for files.

To view the contents of the files before cleaning them from your system you may do one of two things: Double click the individual
file that you would like to look at, or right-click it and select ,View File“. This will launch NotePad (or WordPad depending on the
size of the file) with the file contents displayed. Although you can view the raw contents of these files, most of the files that
SafetyScan finds are undecipherable when viewed.

Note: SafetyScan will not delete files that are locked by your system or are tagged as ‘read-only’ files. Files that are cleaned
are permanently deleted.

The Options Tab
This displays the configuration options for SafetyScan. They are:

1. Scan For...: These checkboxes allow you to choose which of the most common error producing files to scan for. These are
the ‘filters’ that SafetyScan will use in order to ‘filter out’ the error files from your hard drive.

2. Also Scan For...: These two spaces allow the advanced user to set two custom ‘filters’ for SafetyScan to use when
determining which files are error files.

Be careful !! These custom filters can do damage to your system if not used properly and should only be used by an
individual with a good knowledge of such filters!! Unisyn cannot take any responsibility for misuse of this option.

3. Drive to Scan: Use this to select the drive that SafetyScan will scan and clean files from.

4. Scan Interval: Use this to set the interval that SafetyScan scans your system for error files. It can be from every minute to
every hour. Sliding this all the way to the left will disable automatic scanning.

5. Re-Scan after all manual cleans: Select this option if you would like SafetyScan to re-scan for errors each time you
manually clean your drive. Leaving this option unchecked can save time.

6. Automatically clean all found files after each timed scan: Select this option if you would like SafetyScan to
automatically delete the files that it finds when scanning in the background automatically.



30 Day License

This version of SafetyScan is released as shareware. You may evaluate SafetyScan on your system at no charge for 30 days.
If after 30 days you decide to keep it, you must register your copy with Unisyn. For information on registering SafetyScan, see
Ordering Informaion.

LICENSE AGREEMENT

UNISYN  DISCLAIMS ALL WARRANTIES, EITHER EXPRESSED OR IMPLIED, INCLUDING, BUT NOT LIMITED TO
IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE, WITH RESPECT TO THE
SOFTWARE OR DOCUMENTATION. SHOULD THE PROGRAM PROVE DEFECTIVE, THE PURCHASER ASSUMES THE
RISK OF PAYING THE ENTIRE COST OF ALL NECESSARY SERVICING, REPAIR, OR CORRECTION AND ANY
INCIDENTAL, SPECIAL, OR CONSEQUENTIAL DAMAGES. IN NO EVENT WILL UNISYN BE LIABLE FOR ANY DAMAGES
WHATSOEVER (INCLUDING WITHOUT LIMITATION TO DAMAGES FOR LOSS OF BUSINESS PROFITS, BUSINESS
INTERRUPTION, LOSS OF BUSINESS INFORMATION AND THE LIKE) ARISING OUT OF THE USE OR THE INABILITY TO
USE THIS PRODUCT EVEN IF UNISYN HAS BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES. IN PARTICULAR,
UNISYN SHALL HAVE NO LIABILITY FOR ANY DATA STORED OR PROCESSED WITH THIS SOFTWARE, INCLUDING THE
COSTS OF RECOVERING SUCH DATA. AS ARESULT, THIS SOFTWARE AND DOCUMENTATION ARE LICENSED ,AS IS*
AND YOU, THE LICENSEE, ARE ASSUMING THE ENTIRE RISK AS TO ITS QUALITY AND PERFORMANCE.

Information in this document is subject to change without notice and does not represent a commitment on the part of Unisyn. The
software described in this document is furnished under this license agreement. The software may be used or copied only under
the terms of the agreement. It is against the law to copy the software on any medium except as specifically allowed in the license
agreement.

USE OF THIS PRODUCT FOR ANY PERIOD OF TIME CONSTITUTES YOUR ACCEPTANCE OF THIS AGREEMENT AND
SUBJECTS YOU TO ITS CONTENTS.

US GOVERNMENT RESTRICTED RIGHTS

Use, duplication, or disclosure by the Government is subject to restrictions as set forth in subdivision (b)(3)(ii) of the Rights in
Technical Data and Computer Software clause at 25 2.227-7013. Contractor / manufacturer is

UNISYN
3450 Wilshire Blvd.
Suite 316
Los Angeles, CA 90010

Copyright and Trademark Acknowledgments
The SafetyScan software, the contents of this help file, and the Unisyn logo are trademarks of Unisyn Corporation.
Windows, Windows 95 Windows NT are trademarks of Microsoft Corporation.



Loading SafetyScan automatically at the start of Windows

We recommend placing SafetyScan in your StartUp group so that it is automatically loaded each time you start
Windows. By running the installation program, this is the default, however here are instructions on doing this
manually:

1. Launch Explorer and find the file safescan.exe

2. Right click on the Windows 95 Start Button and select ‘Open’.
3. Double Click on ‘Programs’.

4. Double Click on ‘StartUp’.

5. With the right mouse button, drag the safescan.exe file into the ‘SartUp’ window, and select ‘Create Shortcut Here’. You may
rename the shortcut to ‘SafetyScan’ if you wish.

6. SafetyScan will automatically be loaded each time Windows starts now, keeping your system in top shape all of the time!



Unisyn Order Form

You may use this order form for faxing or mailing orders for SafetyScan. To print this form, select File>Print Topic

Fax To: 1(213)738-7665 or Call Unisyn at 1(213)738-1700

Company Name: Your Name:
PhoneNumber: FAX Number:
Address:

E-Mail Address (please make sure this is correct):

Where did you hear about SafetyScan?

[1YES Please send me SafetyScan.

Number of Users:
14........... $29.95 per user
5-24.......... $18.95 per user
25-49........ $15.95 per user
50-99.......$13.95 per user
100-249....$11.95 per user
250-999....$8.95 per user
10000+......Contact Unisyn
Number of Users:

1 would like to pay with
[1] Mastercard

[] Visa

[1 American Express

Credit Card Number: Expiration:

SafetyScan is distributed exclusively electronically, please be sure that your E-Mail address above is correct so that
we may provide you with your registration information in order to convert the demo software into a commercial

copy.

Please allow 24 hours for order processing.

Checks or money orders are accepted if a copy is faxed with this order form. Product will be shipped upon arrival of the check or money order if mailed.
There will be an additional processing fee of $20.00 for Purchase Orders under $100.00.

Orders are processed Monday through Friday. Please allow 24 hours for order processing.

Please FAX to (213)738-7665. Or mail to 3450 Wilshire Blvd., Suite 316, Los Angeles, CA 90010



Ordering Information

SafetyScan is available for $29.95 (US) from Unisyn.
Payment methods are:

MasterCard, Visa, American Express.
Company checks are accepted. Product is sent upon receipt of check.
Company Purchase Orders are accepted for orders of more than $100.00 (US). Payment must be net-15.

The fastest and most convenient way to order SafetyScan is through the use of Unisyn’s Secure On-Line Order Form, located
on our Web Site at http://lwww.unisyn.com. This order form is securely encrypted, and your credit card and personal
information will remain private during transfer and processing. Compuserve users may use the SWREG service, ID#12767.
Most orders that are processed by this means are sent the same day.

You may also order by faxing us your name, company name, address, and telephone number along with a credit card number for
payment. Please be sure that you include a correct e-mail address, as this is how you will be receiving instructions on how to
convert your demo into a commercial version. Orders are usually sent the same business day of receipt.

If you would like to print an order form, click here.

Site license discounts and reseller terms are available. For more information, contact Unisyn.

To order, contact Unisyn at:

Sales: (213)738-1700

FAX:  (213)738-7665

eMail: sscan@unisyn.com
CIS: 74667,3166

AOL:  unisynsw

Web:  http://www.unisyn.com



Getting Started

Thanks for your interest in SafetyScan, here are a few pointers to help you get started right away.

1. This message will only display itself the first time you start SafetyScan, if you need to read through it again, seelct Help from
SafetyScan’s menu and then select ,Getting Started®.

2. When you close or "hide" the main screen, SafetyScan will reside in the System Tray, located in the lower right corner of your
Taskbar next to the clock. You can access the main screen again by either double-clicking on the miniature magnifying glass
icon or right-clicking and selecting "Open".

3. The first thing you should do with SafetyScan is perform a manual scan and clean of your drive. To do this:
a. Click the "Scan Now" button. This will take a few seconds, depending on the size of your drive and the speed of your
computer.

b. When SafetyScan is done scanning, it will present you with a list of files that it has found that may be cleaned from your drive.
Click the "Clean All" button and watch how much space SafetyScan recovers from your drive!

4. After you have performed your initial scan and clean, you may set SafetyScan to automatically scan and clean files on a regular
basis. To do this:
a. Click the Options Tab on the main screen
b. If you are unfamiliar with file extensions, leave the "Files to scan for" options alone, otherwise select the extensions to search
for.
c. Adjust the "Scan Interval" by sliding it back and forth. This is the amount of time SafetyScan will wait in between automatic
scans and cleans, 30 minutes is adequate.

d. Select the "Hide" button. This hides SafetyScan in the System Tray (lower right corner of the screen next to the clock) so that
it is out of your way, but still performing it's vital functions.

5. If you have SafetyScan configured to start at the beginning of each windows session, this message will not appear again, but
SafetyScan will run and complete it's scheduled scans and cleans - keeping your drive free of error files automatically!

If there are any questions regarding this information or operation of the software, please feel free to use the following resources:

Web Technical Support Facilities: http://www.unisyn.com/support
eMail: sscan@unisyn.com

Phone Sales: 213-738-1700

Phone Support: 213-738-6966

FAX: 213-738-7665

Again, thanks for your interest in SafetyScan - we hope you enjoy using it as much as we do!






