
 



PC Insight Help
First and foremost, we would like to thank you for purchasing this software. The following list of help 
topics is arranged to make the help you need available quickly and easily. When you are viewing the help, 
green words are available to give more information, either in a pop up window, or by jumping to the topic 
in question. The pointer arrow will change into a pointing finger when the word or icon it is over has 
additional text. Simply click the left mouse button <LMouse> on the following items to access help on:
Getting technical support 
Locating images and/or text 
Glossary/Index    (a listing of all kinds of helpful stuff)
Viewing text and/or images 
Menus (click on the menu names for more information on each menu)

 
Computer Systems (click on the icons for information on each system)

 

 

 

 

 

 

 

 

 

 
Utility Icons (click on the icons for information on each command)

 

 

 

 

 

 

 
Viewing Icons (click on the icons for information on each command)



 

 

 

 

 

 

 

 
Note: It is a good idea to read and/or print out the release notes file included with all Insight Reference Series 
products. This file is on disk#1 in uncompressed form, and can be viewed with any text editor. Another version of 
the same file will be placed in the program's directory, only it has the Windows Write extension WRI. The 
installation routine will create a Release Notes icon in the program group along with the Insight icon. Clicking this 
icon will launch Windows Write, allowing you to read the release notes file. This file includes helpful information 
unavailable at the time that the help and the user manual were created. 

If you are unable to find a README.DOC file on the installation disk#1, a Release Notes icon, or a 
RELEASE.WRI file in the program's directory, then no new information is necessary for use of this 
program. Since the release notes are more current than this help file or the user manual, any information it 
contains overrides these sources.



Customer Service
Informative Graphics is committed to giving our customers the very best technical support possible. If you 
have any problems running PC Insight, call Informative Graphics' Technical Support Department at    (602) 
971-1839 from 9:00 am to 5:00 pm Mountain Standard Time. You can also fax your questions to 
Informative Graphic's Technical Support Department at (602) 971-1714. Include the information below 
with your question.

If you call, be sure that you have consulted your Users Manual and the Release notes, and that you are 
ready with the following information:
1. Your computer's make and model.
2. Your video monitor and video card's make and model.
3. The video driver you use within Windows.
4. The amount of free disk space and conventional memory on your computer. You can use the DOS 
CHKDSK command.    Type: CHKDSK, then press <Enter>.
"Bytes available on disk" is free disk space.
"Bytes free" is free conventional memory . 
5. Makes and models of printer, mouse and any other peripheral.
6. Contents of your config.sys file, autoexec.bat, win.ini and system.ini files. 

We look forward to hearing your comments and suggestions. Send us a Fax anytime at (602) 971-1714. 

For your convenience, Informative Graphics has a BBS available. The BBS supports baud rates up to 14.4 K bps. 
The BBS number is (602) 971-6079.



Exiting the program
You can exit PC Insight by:
1. Selecting the Exit command from within the Files menu (or)
2. By double-clicking the <LMouse> on the (control-menu button) in the upper left corner of the main 
window.



Customizing the display
Button Bar
The ButtonBar command in the Options menu allows you to enable and disable the buttonbar at the top of 
the screen. To toggle the buttonbar visibility, click the <LMouse> on the command in the Options menu. A 
check mark indicates that the buttonbar will appear at the top of your screen. If the button bar is disabled, 
all commands must be acessed through the menus.

Always On Top
The Always on Top command enables you to determine the way you want your text to appear. If this 
command is toggled on, your text window will always be the "front" window on your screen; the image 
window will always appear behind the text window. You can move the text window anywhere on your 
screen, but it will always appear "on top" of the image. 

To toggle the Always on Top option: View any text, and select the Always on Top command in the text 
window's Options menu. A check mark indicates the status of the Always on Top display option. 



Glossary/Index
Animations 
Backing up (to a previous image) 
Bird's Eye Viewer 
Customer service 
Customizing the PC Insight display 
Clipboard usage 
Exiting the program 
Hyperlinking 
Main computer systems 
Panning across images 
Printing images and text 
ReadMe File 
Release notes 
Reviewing Quiz questions 
Searching for parts 
Searching for text 
See Also 
Sending images to the clipboard 
Sending text to the clipboard 
Setting up printers 
System Requirements 
Taking a Quiz or an Exam 
Topics of interesting information 
Tutorial help for any image 
Viewing the images 
Viewing the text 
Zooming in and out 



Hyperlinking
All items selected (parts or their names) serve as gateways to more information. Once you have selected an 
item, a textual discussion is available, and another image may be available which directly relates to the 
item. A blue box before an item name indicates that a sub-image is available. The jump is made if you 
double-click the <LMouse> button on the item or its name, or click the View Image Icon. A black box 
indicates that there are no sub-graphics available for the item, only text. While you are reading a text file, 
you can double click on any wordwithin the file. If there is a related text file or image within PC Insight, it 
will be listed in a selection menu. Double clicking on these will take you to that text or image.



Viewing the images
The Insight image viewer is designed to provide instant logical flow between all of its related images. 
When the pointer is in the image display area, a    colored diamond  appears over each identified part in 
the system. The status bar at the bottom of the display will display the name of the part you point to, and 
also display SUB-IMAGE if there is an additional image for the part you are pointing to. All parts have 
accompanying text which can be accessed. 

If the part's name in the parts list has a blue box next to it, there is a related or more detailed image available. 
Double-clicking the <LMouse> on a part's diamond  (or on the part's name in the parts list) will hyperlink you to 
the related image. 

For our base jumping off point, we have a PC with some peripherals. The PC is divided into ten systems. The system 
icons are used to change the display to show the system selected. When some of the systems are being viewed, the 
zooming and panning tools become active, allowing you to zoom in on areas of interest. Major computer 
components which don't appear on the PC (like tape backup drives) can be found by using the Search or See Also 
commands.

Selecting parts from the parts list 
Selecting parts from the images 



System Requirements
PC Insight requires:
IBM PC or compatible, 386 or greater
4 Megabytes (4MB) of memory
DOS 3.0 or higher
Windows 3.1 or higher
3.5 Megabytes (MB) of    storage space on your hard disk drive
3.5"    floppy disk drive (5.25 " installation diskettes are available upon request) 
Microsoft Mouse or compatible

Consult the Release notes for the latest compatibility and system requirements



Green Words
Green words are used to link key topics and to explain terms. Click the <LMB> (left mouse button) on green 
words to jump to their help text.



Selecting parts from the parts list
The item name list to the right of the display shows each item currently contained in the image.    This list is 
refreshed every time the graphics display changes from either scrolling, zooming or hyperlinking. Select 
the name of the item you want to identify by clicking on it with the <LMouse>. When you select a name, a 
pointer line will connect the item in the image to its name in the list. You can now view the text for the item 
selected, or view a sub-image if one is available.



Selecting parts from the image
Moving the mouse pointer into the image area causes several "diamonds"  to display. As the mouse is 
moved over a diamond, the item name appears in the status bar. Select    the diamond with a <LMouse> 
click; a pointer line will connect the diamond with the item's name.    You can now view the text for the 
item selected, or view a sub-image if one is available.





Files Menu

The Files menu allows you to set up printers, print images or text, and exit the Insight program. In a text window, 
the Files menu allows you to print the text, set up your printer, or exit (close) the text window.



Display Menu

The Display menu contains all of Insight's special viewing functions.    Commands from the Display menu allow you 
to use the Bird's Eye function, and all of the zooming functions.



View Menu

The View menu provides you with functions that enable you to: go back through the images you have already 
viewed, search for items of interest, access the See Also information for the image, read about special topics, take a 
test with quiz mode, run animations, display text, or display the next image.



PC Systems Menu

The PC Systems menu contains all of the major computer systems that you can look at and read about in PC Insight. 
To select a system from the menu, click on it with the <LMouse>.



Options Menu

In the main menu bar, the Options menu gives you the following options:
Clipping and sending images to the clipboard, toggling the buttonbar visibility, and toggling the button description 
prompt line.

Text Window Options Menu
In text windows, the Options menu allows you to search for a particular word or letters (string), send text to the 
clipboard , or toggle the Always On Top option. 



Help Menu

The Help menu provides on-line help with whatever you're trying to do at any point in the program, whether it is 
getting help, or learning how to use help. The About command calls up a box containing information about PC 
Insight.



Button Description Toggle
The default 'on' setting of this toggle lets you see what the buttons are for by clicking and holding down the 
<LMouse> over them and looking at the prompt line. The Button Description Toggle is provided in the Options 
menu so that you can turn off the descriptions of button functions displayed in the prompt line. This useless option 
was created by lemming-like developers with nothing better to do than make work for their help and documentation 
slaves. Asked why this is included as a feature, they say "everybody else does it".





Multimedia System
Multimedia is a much-used term that usually means a PC with a CD-ROM. As a general term, it can be defined as a 
PC that is capable of Text, Graphics, Sound, and Video (animation) output.    In the Multimedia overview section, all 
of the components that are necessary to create a multimedia computer are discussed in detail. From here, you can 
learn about CD-ROMs, video and audio components, MIDI operation, Sound processing, and more. 

A listing of all of the basic PC systems can be found in the PC Systems menu.



Networking
When two or more computers are connected to a network, it opens up a host of options to the users. With 
networking, the PCs can share their hardware, and software applications as well. In this system, different network 
topologies, such as client/server, Token Ring, Star, LAN/Wan, and Bus Networks are explained, in addition to the 
hardware that is necessary to make it all work. 

A listing of all of the basic PC systems can be found in the PC Systems menu.



Video System
Have you ever wondered how the computer displays your work?    What IS interlacing, anyway, some fancy way to 
tie shoes?    The Video system section explains video cards (adapters) video modes, video RAM, and how the CPU 
controls it all. Paintings, spreadsheets, 3-D models, games, and word processors all use video devices and systems to 
display all that wonderful data visually. 

A listing of all of the basic PC systems can be found in the PC Systems menu.



Storage System
Do you know the difference between Primary and Secondary storage?    The Storage Overview explains the 
fundamentals of    Floppy disk drives, Hard Drives, CD ROM's, and Tape backup systems.    All the information you 
will need to understand the terminology will be covered. 

A listing of all of the basic PC systems can be found in the PC Systems menu.



Main Box
The 'Main Box', for lack of a better term, is where all of the real heavy action is.    The motherboard, CPU, RAM, 
BIOS, CMOS, Bus, Power Supply and a host of other circuitry can be found here. Within this system, even the 
smallest components (like internal CPU components) are described in detail and explained.

A listing of all of the basic PC systems can be found in the PC Systems menu.



Peripheral Equipment
If a device can be plugged into the computer, you will probably find it in this system.    Without peripherals, the 
computer is rather useless, but with the right input and output devices, it becomes a magical wonder. Devices such 
as a printers, scanners, keyboards, mice, joysticks are described in graphic detail, along with information on how 
they are connected to the PC, how they work internally, and valuable info on what to consider when buying them.

A listing of all of the basic PC systems can be found in the PC Systems menu.



Communication System
Communication is the key to the information age. The modern PC can communicate with other PCs around the 
world, and with mainframe-based services known as 'bulletin boards' like Compuserve and Prodigy. The devices and 
software that connect you with the world are discussed in detail. 

A listing of all of the basic PC systems can be found in the PC Systems menu.



Operating System
The basic operating system that makes most PCs run is DOS, which stands for Disk Operating System. The 
Operating System section explains the basic functions which are at the heart of PC software.    Other operating 
systems are also discussed, as well as those cryptic AUTOEXEC.BAT and CONFIG.SYS files. Within DOS there is 
a utility called DOSSHELL which is handy for all kinds of reasons, and it's secrets are revealed in this section.

A listing of all of the basic PC systems can be found in the PC Systems menu.



Graphic User Interface
The Graphic User Interface, (GUI for short) is an operating environment, not an Operating System.    Originally 
pioneered by Apple computers, GUIs have developed into the most common form of interaction between the user 
and his/her computer.    This section describes how the popular Windows environment can best be used.    From 
simple functions to setting up a DOS application to run under Windows, a strong working knowledge of Windows 
can easily be learned. 

A listing of all of the basic PC systems can be found in the PC Systems menu.



Application Software
Applications (software packages) are the real reason why people like computers. They are also what makes the 
computer such a versatile tool. The same computer can be used in a vast number of ways, simply by loading new 
applications.    The Application Software system gives a wealth of information on major varieties of software to be 
used at home or at the office.

A listing of all of the basic PC systems can be found in the PC Systems menu.





 Printing text and images
To print images or text, click the <LMouse> on the Print icon, or select the Print command in the Files menu of the 
window containing the image or text.
Your selection will be sent to the printer and printed.

Setting up a printer
The Printer Setup menu item allows you to select a printer.
1. Select the Printer Setup command from the Files menu.
The printer selection dialog box appears.
2. Scroll through the list of printers. Select the one you want to use with the <LMouse>.
The printer you select will be highlighted.
3. Once you have selected your printer, click the <LMouse> on the OK button.
Your selection will now be printed.



 Viewing previous images
The Go Back command walks you back through the previous images, allowing you to backtrack through a topic. 
The software will remember twenty-five previous images. This is also useful for reviewing Quiz Questions. To view 
the previous image, click the <LMouse> on the Go Back icon, or select the Go Back command from the View menu.
The previously viewed image will now be displayed.



 Searching for parts and terms
The Search command calls up a dialog which allows direct access to any image, text item, or animation in the 
program. You can look up specific items by entering the name of the item to be searched for, or by accessing the 
image or text indexes. To search for a part, click the <LMouse> on the Search icon, or select Search from the View 
menu.
The Search menu appears.
Selecting String Search opens the Search For dialog.
Selecting Index Listing calls up a full list of the item names. 
Selecting Image Listing calls up a complete list of the images. 
Selecting Animation Listing calls up a list of all the animations.

Using String Search
To find an item using String Search:
1. Type the name of the item in the Search For... box. If you aren't sure of the spelling, type in the first few letters 
and click the <LMouse> on the Sounds Like... button.
2. Press the OK button, or the <Enter> key to start the search. To abort the search, press the Cancel button, the 

<Esc> key, or double-click the <LMouse> on the  button . 
A list of all items that match your search entry will be displayed. If what you type is not recognized by PC Insight, it 
will let you know.
3. Scroll through the list until you find what you're looking for. Click the <LMouse> on the item. PC Insight will 
take you to the related graphic image. 

To close a list, click the <LMouse> on the Cancel button, the <Esc> key, or double-click the <LMouse> on the 
button.



 Accessing related information
The See Also... command calls up selections of text topics and/or images which are related to the current image 
being viewed. An overview discussion explaining the current image is the first item in the See Also list. To 
access this information, click the <LMouse> on the See Also icon, or select the See Also... command from the View 
menu.
The See Also... menu appears.
Select any of the See Also listings (some are text, some are images). 
PC Insight now displays the item you selected. 

If you want to cancel a list box, click the <LMouse> on the Cancel button, press the <Esc> key, or double-click the 

<LMouse> on the  button.



 PC topics
The Topics... command brings up a list of interesting topics about computers such as; ergonomics, Windows and 
DOS tips and tricks, the true meanings of all those cryptic DOS error messages, and how to set up your system to 
your best advantage. Selecting any of these basic categories calls up a sublist of the various chapters. To use this 
command, select the Topics... command from the View menu, or click the <LMouse> on the Topics icon.
The Topics menu now appears.
To select one of the Topics... listings, double-click it with the <LMouse> or select a list by clicking on it once with 
the <LMouse>. Then click the <LMouse> on the OK button or press the <Enter> key. 
A list of chapters for the topic you selected appears. 
Scroll through the list until you find what you want, and select the topic you want. 
PC Insight now displays the chapter text.
You can now read the text, print it, search for specific text within it, or send it to the clipboard.



 Testing your computer knowledge
Pop Quiz and Final Exam provide a way to find out how much you've learned. To take a test, select the Quiz 
command from the View menu, or click the Quiz icon. The Test Yourself list box appears with various options. You 
can use the Cancel button to chicken out of Quiz Mode at any time. When you're done, you can review the questions 
(with the correct answers of course).

There are two types of tests: Pop Quiz calls up a series of questions about the image you are currently looking at. 
Final Exam pulls out all the stops. Get ready, because any computer part within PC Insight may be on the test. Both 
programs choose parts identifiers at random from PC Insight's massive database, so some questions may be more 
fair than others, and some images will definitely be easier than others. View High Scores calls up a list of the ten 
highest scores achieved so far.

Taking the test
When a test (Quiz or Exam) begins, an arrow will point to a part in the display along with the question: "What is 
this?" You will be given four multiple guess answers to choose from. Select an answer by double-clicking on it with 
the <LMouse>. If your answer is correct, you will go on immediately to the next question. If you choose the wrong 
answer (it could happen), the correct answer will be displayed before you go on to the next question. 

Scoring
While you are taking a test, PC Insight will keep you posted on your stats. The scoreboard    posts the following:
Score to Beat- the highest current score
Time to Beat- the fastest current time
Total Questions- how many questions are in this quiz/exam
Questions Left- number of questions remaining to be answered
Answers Correct- how many correct answers in current quiz/exam
Answers Incorrect- how many wrong answers you've given in the current quiz/exam
Current Score- how well (?) you are doing in this quiz/exam
Elapsed Time- how long you have spent torturing yourself with the current quiz/exam

Reviewing test questions (with the correct answers!)
After you finish a quiz or exam, you have the option of back-tracking through the questions. After a test, click the 
<LMouse> on the Go Back icon, or select Go Back from the View menu. Each time you click the Go Back icon, a 
pointer line to the parts on the test will be displayed, connected to the correct part name in the list. You can now read 
the text, continue to back-track through the test items, or resume normal operation of PC Insight.

If your score is one of the ten best (it could happen), a dialog box will pop up. Type your name and click the OK    
button with the <LMouse>. If you're really modest and don't want your score to be recorded, use the Cancel    button 
instead.

Click the <LMouse> at    any time on the Cancel button to exit Quiz Mode.



 Sending data to the Windows Clipboard
The Windows Clipboard can be used to export image and text from PC Insight into most Windows programs.
To send an entire image to the clipboard:
1. Select the To Clipboard command from the Options menu.
A two-part sub-menu appears
2. Select Entire Image
The entire image is now sent to the Windows clipboard.
Note: Selecting Entire Image performs the same function as clicking the To Clipboard icon.

To send part of any image to the clipboard:
1. Select the To Clipboard command from the Options menu.
A two-part sub-menu appears
2. Select Clip Window from the menu
3. Move the mouse pointer into the image viewing area, press and hold the <LMouse> to place the first point of your 
clip window. 
4. Drag the mouse to draw a box around the area, release the <LMouse> to place the second point of the clip 
window.
The image within the clip area is now sent to the Windows clipboard.



Searching for text within a topic
When a text item is being viewed, PC Insight can locate specific bits of text (referred to as text strings) within the 
document. To find a specific word or phrase, select the Search String command from the Options Menu with the 
<LMouse>.
The Find dialog box appears.
Enter the text string you want to find, and click the <LMouse> on the Find Next button (or press <Enter>). If the 
string is found, PC Insight scrolls to the first occurrence of the text and highlights the string in the text. If the string 
is not found, a message of Search Complete displays. To find the next occurrence of the same string, click the 
<LMouse> on the Find Next button.

Text Search Options
PC Insight allows you to adjust the search parameters by selecting option buttons:
Whole Word: The Whole Word option allows you to search for a specific word, rather than letters that might be 
contained within another word. For example: If you enter "PART" in the Find What text box, the program will find 
all words containing the letters, such as "PARTNER." Selecting    the Whole Word option button will cause a search 
only for the letters as a whole word. 
Match Upper/Lowercase: The Match Upper/Lowercase option button allows you to search for characters of a 
specific case. For example, if you enter "ABC" in the Find What text box, PC Insight will find all occurrences of 
"ABC" (uppercase), but it will not find occurrences such as "abc" (lowercase).

Closing the Search Dialog Box
Click the <LMouse> on the Cancel button in the Find dialog box to close and return to the previous display. 





Zoom Commands
PC Insight provides a wealth of zooming functions. They are available through the viewing icons, or in the Display 
menu.

 Zoom Extents returns the image to a full extents view. The same effect can be achieved with multiple zoom-
outs.

 Zoom Window allows you to select the area that you want to zoom in on. To do this, click the <LMouse> on 
the Zoom Window icon, press and hold the <LMouse>, and drag a window around the area.

 Zoom In enlarges the display image incrementally. Because Zoom In increases the detail of the image, it 
reduces the amount of the image that you can see.

 Zoom Out reduces the display's zoom level incrementally. Because Zoom Out decreases the detail of the 
image,    it enlarges the total area that you can see.
Zoom Point allows you to zoom in on a selected area within the current display to a 1:1 zoom level. To use the 
Zoom Point function, select Zoom Point from the Display menu, then click the <LMouse> at the point you want to 
zoom in on. 



 Bird's Eye Viewer
Bird's Eye is a powerful, yet easy to use tool that allows you to zoom and pan to any area of the image. Selecting the 
Bird's Eye command from the Display menu (or clicking on the Bird's Eye icon) opens a pop-up window on the 
screen. This display window contains a smaller version of the image. This window is used as a backdrop to establish 
a new view. When Bird's Eye is summoned, the area of the image that you are currently viewing will be outlined 
with a green rectangle. If you are viewing the entire image, you won't see the rectangle, because it is overlapping the 
border. This rectangle can be dragged to view another section of the overview to perform a panning operation. You 
can also draw a new window to select any area of the image for viewing.
Zooming with Bird's Eye
To zoom in on an area using the Bird's Eye Viewer:
1. Summon the The Bird's Eye Viewer.
2. Using the <LMouse>, drag a box around the area of interest.
The display updates, and the Bird's Eye window closes automatically.
Panning with Bird's Eye
After any area of the displayed image is zoomed in on, you can use the Bird's Eye panning function. This allows a 
new area of the image to be displayed at the same zoom level as the previous view.    You can also use the scroll bars 
to pan at any time, but only Bird's Eye allows you to pan diagonally. 
To pan using Bird's Eye:
1. Click the <LMouse> on    the Bird's Eye icon. 
2. Click and hold the <RMouse> in the Bird's Eye window.
The box will 'attach' to the mouse pointer.
3. Move the mouse to re-position the viewing box to determine the new view area.
4. Release the <RMouse> to display the new area of the image. 
The display updates, and the Bird's Eye window closes automatically.



 Animations
For a better understanding of the computer, PC Insight has many animated images to demonstrate how complex 
parts of the computer work. As you hyperlink through the images, you will see that the Animation icon "pops up" 
when viewing some of the images. These images can be animated. 

Available also in the View menu, the Animation command will normally be "grayed out". It will be available only 
when you are looking at an image that has an animation sequence. To start the animation on such an image, click the 
<LMouse> on the Animation icon, or select Animation from the View menu.

Animation controls

Use the scroll bar to slow down or speed up the animation.
Click on the Rewind button to go back to frame #1 and start the animation over.
Clicking on the Pause button pauses the animation.
Click on the Stop button to stop the animation.

Animation Listing Menu
The Animation Listing Menu contains a complete list of all of the animations in PC Insight. Use the Search 
command button, or select Search in the View menu, and then select Animation Listing to open the Animation 
Listing menu.



 View Image command
When the View Image icon is in color and appears to be "raised," it means that a sub-image is available for the part 
you have currently identified. If the icon appears "grayed" and recessed, no sub-image is available. To view a sub-
image, click the <LMouse> on the Image icon after selecting an item. You can also select the Display Image 
command from the View menu. The items in the Parts List with blue boxes next to their names have sub-images.



 View Text command
Whenever an item is selected, the View Text icon appears to be "raised." To view the item's text, Click the 
<LMouse> on the View Text icon after selecting an item, or select Display Text from the View Menu. The text 
window can be left open by selecting the Always On Top option in the Options menu. Various search and clipboard 
commands are also available when viewing the text. 

You can move your text window to any location. Insight will remember the last location you chose for your text 
window, and it will re-appear in the same place when summoned (until you move it).


