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Introduction 

Welcome to the WireFusion Tutorials - Part I. These exercises are provided to give you 
both introductory and in-depth knowledge of WireFusion's features. By using these 
tutorial series you will quickly master the basics of using WireFusion and how the 
different objects work. 

These tutorials are for everybody. If you've never used WireFusion before these tutorials 
are for you. If you have used earlier WireFusion versions, no matter what your 
experience level is, these tutorials are for you too. 

In these tutorials you will learn to use WireFusion through a series of hands-on exercises, 
and you are expected to work through them starting with the first exercise followed by 
the second, then the third and so on. But before you start with these tutorial exercises, it is 
highly recommended to work through the 'Getting Started with WireFusion' manual, 
which requires no former WireFusion knowledge. 

Help on each individual object and port description can be found inside WireFusion by 
choosing Help > Object Help (or by pressing F2) or by selecting an object and choosing 
Help from its local menu (or by selecting the object and pressing H). 

It is also recommended to read the 'Working in WireFusion' book, which explains the 
WireFusion environment and different concepts. 

The exercises included in this tutorial are: 

Exercise 1: Load an URL when pressing a button 

Exercise 2: Change the opacity of an image with a slider 

Exercise 3: Move images, which are placed in different layers, with the mouse 

Exercise 4: Create a roll-over button 

Exercise 5: Play around with some filter functions 

Exercise 6: Shape a rectangular filter Target Area using an alpha channel map 
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Exercise 1 

This exercise describes the steps to connect to an URL using a simple widget button. 

If you don't want to work through this exercise, but still want to see how it looks like, 
then you can load the project from: 

• [Path]/WireFusion 3/projects/ex1.wfp  

Objects used in this exercise: 

• 1 URL 
• 1 Button 

In this exercise, you'll accomplish the following tasks:  

• Start a New Project 
• Insert an URL object 
• Set URL address to 'http://www.demicron.com'. Click OK to close the dialog 
• Insert a Button object 
• Change the Button label to 'Load URL' 
• Change the Button cursor to Hand. Click OK to close the dialog 
• Connect: 'Button 1', Out-ports > Button Clicked to 'URL 1', In-ports > Load URL 
• Insert a Progressor object 
• Change the Progressor Time Interval to 3 seconds. Click OK to close the 

dialog 
• Connect: 'Progressor 1', Out-ports > Progress [Number] to 'Button 1', In-ports > 

Set Opacity [Number] 

 

1.1 New Project 

Start a new project by clicking the New Project button in the Menu Bar or choose File > 
New Project 

 

1.2 Insert an URL object 

Insert an URL object into your project, Objects > Environment > URL. When its 
properties dialog opens up, enter the URL address 'http://www.demicron.com' (Figure 
1.1). Click OK to close the dialog. 
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Figure 1.1 URL Properties dialog 

 

1.3 Insert a Button object 

Insert a Button object into your project, Objects > Widgets > Button.  

When its properties dialog opens up, change the label to 'Load URL'.  

Before closing the dialog window, change the Button mouse cursor, select Target Area 
tab > Cursor > Hand (Figure 1.2). The cursor will now change to a hand cursor when 
rolled over the Button. Click OK. 
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Figure 1.2 Selecting a Hand cursor 

 

1.4 Trigger the URL to load 

Connect: 

• 'Button 1', Out-ports > Button Clicked to 'URL 1', In-ports > Load URL  

To make the above connection do the following: 

Open the Button object's local menu by clicking the top-left arrow (or by right-clicking 
the object) (Figure 1.3). 
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Figure 1.3 Opening the Button object menu 

 

Select the out-port option Button Clicked (Figure 1.4). 

 

Figure 1.4 Out-port Button Clicked selected 

 

Open the URL object's local menu and select the in-port option Load URL (Figure 1.5). 
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Figure 1.5 In-port Load URL selected 

 

The connection is done (Figure 1.6). 

 

Figure 1.6 The Button object triggering the URL to load 

 

1.5 Test 

There are two methods to preview a presentation; in the viewer or in the browser. 

To preview in the viewer: 

• Choose Projects > Preview Presentation or click F9 (Figure 1.7) 
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Figure 1.7 Preview in the viewer 

 

To preview in the browser: 

• Choose Projects > Preview Presentation in browser or press CTRL+F9 

To set the browser path, choose File > Preferences 

When the presentations is started, click the 'Load URL' button to see that it loads the 
URL as it should. Note that the mouse cursor changes to a hand pointer when rolled 
over the button. 

Note: Always close the viewer or the browser after previewing to ensure better 
WireFusion performance. 

 

1.6 Insert a Progressor object 

We want to animate the Button opacity at the presentation startup, going from full 
transparancy (opacity = 0) to full opacity (opacity = 100) in 3 seconds. 

Insert a Progressor object into the project, choose Objects > Logic > Progressor 

When its properties dialog opens up, set the Time Interval (seconds) to 3. Click OK 
(Figure 1.8). 
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Figure 1.8 Setting the time interval to 3 seconds 

 

1.7 Animate the Button opacity 

Connect: 

• 'Progressor 1', Out-ports > Progress [Number] to 'Button 1', In-ports > Set 
Opacity [Number] (Figure 1.9) 

 

Figure 1.9 Setting the Button opacity 
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Press F9 to preview. 

 

1.8 Save and publish 

Save your project by choosing, File > Save project As... 

To publish to an HTML page, choose File > Publish... 

 

1.9 Short Summary 

In this exercise you have learned how to: 

• Load a web page with the URL object 
• To trigger an event with the Button object 
• To animate the opacity with the Progressor object 
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Exercise 2 

This exercise describes the steps to change the opacity of an image using a slider. We 
will also show how to resize and change the color of the Stage. 

If you don't want to work through this exercise, but still want to see how it looks, 
then you can load the project from: 

• [Path]/WireFusion 3/projects/ex2.wfp  

Objects used in this exercise: 

• 1 Image 
• 1 Slider 

In this exercise, you'll accomplish the following tasks:  

• Start a New Project 
• Set the Stage dimension to 300x300 pixels 
• Set the Stage color to black 
• Insert an Image object and load the image 'Leaves_300x240.jpg'. Click OK to 

close the dialog 
• Position the Image object at X:0 and Y:0 
• Rename 'Image 1' to 'Leaves' 
• Insert a Slider object and set the Initial value to 100. Click OK to close the 

dialog 
• Position 'Opacity slider' at X:65 and Y:165 
• Rename 'Slider 1' to 'Opacity slider' 
• Connect: 'Opacity slider', Out-ports > Slider Value [Number] to 'Leaves', In-ports 

> Set Opacity [Number]  

 

2.1 New Project 

Start a new project by clicking the New Project button in the Menu Bar or choose File > 
New Project 

 

2.2 Change Scene properties 

To change Scene properties for the project, choose Projects > Properties... 
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When the Scene Properties dialog opens up, change the Stage Width to 300 and Stage 
Height to 300 (Figure 2.1) 

Then change the Stage background color by clicking the Background color box. When its 
dialog opens up, select the color black (0, 0, 0). Click OK to close the color dialog and 
then click OK to close the Properties dialog. 

 

Figure 2.1 The Scene Properties dialog 

 

2.3 Insert an Image object 

Insert an Image object into your project, Objects > Multimedia > Image 

When its properties dialog opens up, load a new image by clicking Change Image...  

Load the image named 'leaves_300x240.jpg' found at: 

• [Path]/WireFusion 3/exercises/Tutorial2/ 

After loading the image, click the Target Area tab and position the image at X:0 and Y:0. 
Click OK to close the dialog (Figure 2.2). 

Rename 'Image 1' to 'Leaves' 
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Figure 2.2 The 'Leaves' image 

 

2.4 Insert a Slider object 

Insert an Slider object into your project, Objects > Widgets > Slider 

When its properties dialog opens up, change the Initial Value to 100 (Figure 2.3). Click 
OK to close the dialog. 
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Figure 2.3 The Slider dialog 

 

Position the 'Opacity slider' Target Area at X:65 and Y:165 by pressing Alt on your 
keyboard and then dragging the Target Area with the mouse (Figure 2.4). 

Rename 'Slider 1' to 'Opacity slider' 

 

Figure 2.4 Moving the 'Opacity slider' Target Area 
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2.5 Animate the Image opacity 

Connect: 

• 'Opacity slider', Out-ports > Slider Value [Number] to 'Leaves', In-ports > Set 
Opacity [Number] (Figure 2.5) 

 

Figure 2.5 Setting the Image opacity 

 

2.6 Test 

Press F9 to preview (Figure 2.6). 
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Figure 2.6 Previewing the presentation 

 

2.7 Save and publish 

Save your project by choosing, File > Save project As... 

To publish to an HTML page, choose File > Publish... 

 

2.8 Short Summary 

In this exercise you have learned how to: 

• Change the Stage dimension 
• Set the Stage color 
• To animate the opacity using a Slider object 
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Exercise 3 

This exercise demonstrates how the layers work in WireFusion. Three images will be 
placed in different layers and you will move them seperately with the mouse. We will also 
re-order the images and take a closer look at the Layer view checkboxes. 

If you don't want to work through this exercise, but still want to see what it looks like, 
then you can load the project from: 

• [Path]/WireFusion 3/projects/ex3.wfp  

Objects used in this exercise: 

• 3 Image 

In this exercise, you'll accomplish the following tasks:  

• Start a New Project 
• Set the Stage dimension to 400x400 pixels 
• Insert an Image object and load the image 'fish_175x140.jpg'. Click OK to close 

the dialog 
• Position the Image object at X:50 and Y:70 
• Rename 'Image 1' to 'Fish' 
• Connect: 'Fish', Out-ports > Mouse Events > Mouse Drag [2D Number] to 'Fish', 

In-ports > Set Position [2D Number]  
• Insert an Image object and load the image 'flower_175x140.jpg'. Click OK to 

close the dialog 
• Position the Image object at X:170 and Y:110 
• Rename 'Image 1' to 'Flower' 
• Connect: 'Flower', Out-ports > Mouse Events > Mouse Drag [2D Number] to 

'Flower', In-ports > Set Position [2D Number]  
• Insert an Image object and load the image 'leaves_175x140.jpg'. Click OK to 

close the dialog 
• Position the Image object at X:90 and Y:180 
• Rename 'Image 1' to 'Leaves' 
• Connect: 'Leaves', Out-ports > Mouse Events > Mouse Drag [2D Number] to 

'Leaves', In-ports > Set Position [2D Number]  

 

3.1 New Project 

Start a new project by clicking the New Project button in the Menu Bar or choose File > 
New Project 



 21

 

3.2 Change Scene properties 

To change Scene properties for the project, choose Projects > Properties... 

When the Scene Properties dialog opens up, change the Stage Width to 400 and Stage 
Height to 400. 

 

3.3 Insert an Image object 

Insert an Image object into your project, Objects > Multimedia > Image 

When its properties dialog opens up, load a new image by clicking Change Image...  

Load the image named 'fish_175x140.jpg' found at: 

• [Path]/WireFusion 3/exercises/Tutorial3/ 

After loading the image, click the Target Area tab and position the image at X:50 and 
Y:70. Click OK to close the dialog. 

Rename 'Image 1' to 'Leaves' 

Connect: 

• Connect: 'Fish', Out-ports > Mouse Events > Mouse Drag [2D Number] to 'Fish', 
In-ports > Set Position [2D Number] (Figure 3.1) 

 

Figure 3.1 'Fish' connected to itself 

 

3.4 Insert an Image object 

Insert another Image object by loading the image named 'flower_175x140.jpg' found at: 
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• [Path]/WireFusion 3/exercises/Tutorial3/ 

Position the image at X:170 and Y:110. Click OK to close the dialog. 

Rename 'Image 1' to 'Flower' 

Connect: 

• Connect: 'Flower', Out-ports > Mouse Events > Mouse Drag [2D Number] to 
'Flower', In-ports > Set Position [2D Number] (Figure 3.2) 

 

Figure 3.2 'Fish' and 'Flower' 

 

3.5 Insert an Image object 

Insert yet another Image object by loading the image named 'leaves_175x140.jpg' found at: 

• [Path]/WireFusion 3/exercises/Tutorial3/ 

Position the image at X:90 and Y:180. Click OK to close the dialog. 

Rename 'Image 1' to 'Leaves' 

Connect: 

• Connect: 'Leaves', Out-ports > Mouse Events > Mouse Drag [2D Number] to 
'Leaves', In-ports > Set Position [2D Number] (Figure 3.3) 
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Figure 3.3 'Fish', 'Flower' and 'Leaves' 

 

3.6 Test layers 

As you can see in the Layers view (Figure 3.4) 'Leaves' is placed in a layer above 
'Flower', and 'Flower' is placed above 'Fish'.  

 

Figure 3.4 Layers view with 'Leaves' on the top, then 'Flower' and 'Fish' at the bottom  

 

Press F9 to preview and use the mouse to drag the images around in the presentation to 
confirm the layer order (Figure 3.5). 
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Figure 3.5 Previewing the presentation 

 

3.7 Re-order the layers 

Without closing the viewer, in the Layers view, use the mouse to drag 'Leaves' and drop 
it between 'Flower' and 'Fish' (Figure 3.6). 

 

Figure 3.6 Re-ordering layers 

Press F9 to test again. 'Leaves' will now be in a layer between 'Flower' and 'Fish'. Close 
the viewer. 
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3.8 Layer view checkboxes 

There are two checkboxes to the left of each layer in the Layer view (Figure 3.7). The left 
most checkbox indicates that the object is Activated (marked).  

 

Figure 3.7 Layer checkboxes 

 

If the right most checkbox is marked, then the object will leave a Stamp in background at 
the presentation startup. Mark the Stamp background checkbox for 'Leaves' (Figure 3.8). 

 

Figure 3.8 Marking the Stamp background checkbox for 'Leaves' 

 

Press F9 to preview, notice that there is a permanent stamp in the background of the 
'Leaves' image (Figure 3.9). 
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Figure 3.9 'Leaves' stamped at presentation startup 

 

3.9 Short Summary 

In this exercise you have learned how to: 

• Connect an object to itself 
• Make an image draggable 
• Re-ordering layers 
• Stamp an image in the background 
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Exercise 4 

This exercise demonstrates how to create a simple roll over button. The roll over's objects then 
will be grouped (stored) in a Scene object. We will then save the roll over button for 
later use. 

If you don't want to work through this exercise, but still want to see what it looks like, 
then you can load the project from: 

• [Path]/WireFusion 3/projects/ex4.wfp  

Objects used in this exercise: 

• 3 Image 
• 1 Mouse Area 
• 1 Scene 

In this exercise, you'll accomplish the following tasks:  

• Start a New Project 
• Insert an Image object and load the image 'button1.jpg'. Click OK to close the 

dialog 
• Position the Image object at X:0 and Y:0 
• Rename 'Image 1' to 'Button' 
• Insert an Image object and load the image 'button2.jpg'. Click OK to close the 

dialog 
• Position the Image object at X:0 and Y:0 
• Rename 'Image 1' to 'Button over' 
• Deactivate 'Button over' 
• Insert an Image object and load the image 'button3.jpg'. Click OK to close the 

dialog 
• Position the Image object at X:0 and Y:0 
• Rename 'Image 1' to 'Button pressed' 
• Deactivate 'Button pressed' 
• Insert a Mouse Area object. 
• Position it at X:0 and Y:0 and set its dimension to Width:45 and Height:39. 

Change to a Hand cursor. Click OK to close dialog 
• Rename 'Mouse Area 1' to 'Button sensor' 
• Connect: 'Button sensor', Out-ports > Mouse Events > Mouse Roll Over [2D 

Number] to 'Button over', In-ports > Activate 
• Connect: 'Button sensor', Out-ports > Mouse Events > Mouse Roll Out [2D 

Number] to 'Button over', In-ports > Deactivate 
• Connect: 'Button sensor', Out-ports > Mouse Events > Mouse Press [2D Number] 

to 'Button pressed', In-ports > Activate 
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• Connect: 'Button sensor', Out-ports > Mouse Events > Mouse Release [2D 
Number] to 'Button press', In-ports > Deactivate 

• Insert a Scene object. Click OK to close the dialog 
• Open the Scene object and change its Stage dimension to Width:45 and 

Height:39. Go back to the project root. 
• Select all objects, except the Scene object, and cut (Ctrl-X) them. 
• Open the Scene object again and paste the objects by right clicking the Script 

Area. 
• Go back to the project root again and rename 'Scene 1' to 'Roll Over Button'. 
• Position the 'Roll Over Button' at X:50 and Y:60 
• Save the 'Roll Over Button' object for later use 
• Make a copy of the 'Roll Over Button' and position the copy at the position X:140 

and Y:60 

 

4.1 New Project 

Start a new project by clicking the New Project button in the Menu Bar or choose File > 
New Project 

 

4.2 Insert an Image object 

Insert an Image object and load the image named 'button1.jpg' found at: 

• [Path]/WireFusion 3/exercises/Tutorial4/ 

Position the image at X:0 and Y:0 and rename it to 'Button' 

 

4.3 Insert an Image object 

Insert an Image object and load the image named 'button2.jpg' found at: 

• [Path]/WireFusion 3/exercises/Tutorial4/ 

Position the image at X:0 and Y:0, rename it to 'Button over' and Deactivate it in the 
Layers view (Figure 4.1). 
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Figure 4.1 'Button over' deactivated 

 

4.4 Insert an Image object 

Insert an Image object and load the image named 'button3.jpg' found at: 

• [Path]/WireFusion 3/exercises/Tutorial4/ 

Position the image at X:0 and Y:0, rename it to 'Button pressed' and Deactivate it in the 
Layers view. 

 

4.5 Insert a Mouse Area object 

Insert an Mouse Area object into your project, Objects > Environment > Mouse Area 

Position it at X:0 and Y:0 and change its dimension to Width:45 and Height:39. 

Change the cursor to a Hand cursor. Click the OK button to close the dialog. 

Rename '"Mouse Area 1' to 'Button sensor' (Figure 4.2). 

 

Figure 4.2 'Button sensor' 
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Make sure the layer order looks like Figure 4.3. 

 

Figure 4.3 The layer order. 

 

4.6 Roll over function 

Connect: 

• 'Button sensor', Out-ports > Mouse Events > Mouse Roll Over [2D Number] to 
'Button over', In-ports > Activate 

• 'Button sensor', Out-ports > Mouse Events > Mouse Roll Out [2D Number] to 
'Button over', In-ports > Deactivate 

• 'Button sensor', Out-ports > Mouse Events > Mouse Press [2D Number] to 
'Button pressed', In-ports > Activate 

• 'Button sensor', Out-ports > Mouse Events > Mouse Release [2D Number] to 
'Button press', In-ports > Deactivate 

 

Figure 4.4.The 'Button sensor' connections 

 

So what do the four connections above do? 

Connection 1: When the mouse cursor is over the button, it will activate (show) the 
'Button over' image. 
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Connection 2: When the mouse cursor rolls out from the button, it will deactivate 
(hide) the 'Button over' image. 

Connection 3: When the mouse button is pressed over the button, it will activate (show) 
the 'Button pressed' image. 

Connection 2: When the mouse button is released over the button, it will deactivate (hide) 
the 'Button pressed' image. 

 

4.7 Test 

Press F9 to test the roll over button (Figure 4.5).  

 

Figure 4.5 Previewing the button 

 

4.8 Insert a Scene object 

Insert an Scene object into your project, Objects > Misc > Scene (Figure 4.6) 
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Figure 4.6 A Scene object inserted 

 

Open the Scene object by choosing Explore from its local menu (Figure 4.7) or by 
clicking its icon in the Folder view (Figure 4.8). 

 

Figure 4.7 Opening the Scene object with the Explore option 
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Figure 4.8 Opening the Scene object with the Folder view 

 

4.9 Change Scene Properties 

When you are inside the Scene object you will see a new empty Stage. Change its 
dimensions by choosing Scene > Scene Properties 

When the Scene Properties dialog opens up, change the Stage Width to 45 and Stage 
Height to 39. 

Go back to the project root by clicking the project icon in the Folders view (Figure 4.9) 
or by clicking the Up button in the Menu Bar (Figure 4.10). 

 

Figure 4.9 Going back using the Folders' view, by clicking 'Untitled 1' 

 

 

Figure 4.10 Going back (up) with the Up button 
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4.10 Group objects 

When you are at the root level, use the mouse to select all objects in the Script Area, 
except the Scene object (Figure 4.11). 

 

Figure 4.11 Selecting objects 

 

Cut the objects by choosing Edit > Cut, or by pressing Ctrl-X on your keyboard. The 
objects and their connections will disappear. 

Now, open the Scene object again and paste the objects by right-clicking anywhere in 
the empty Script Area (Figure 4.12 and Figure 4.13). 

 

Figure 4.12 Pasting the objects 
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Figure 4.13 Objects pasted 

 

4.11 Test local Scene 

You can now test the local Scene, i.e. the Scene you currently are located in, by 
choosing Scene > Preview Scene or by pressing F8 (Figure 4.14). Close the viewer when 
ready previewing. 

 

Figure 4.14 Previewing the local Scene
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4.12 Saving the button 

Move back (up) to the project root again and rename 'Scene 1' to 'Button Roll Over'. 

Save the 'Button Roll Over' object for later use by choosing Save... from the 'Button Roll 
Over' local menu (Figure 4.15). 

 

Figure 4.15 Saving 'Button Roll Over' 

 

4.13 Copy the button 

Copy the 'Button Roll Over' by selecting it and then choosing Edit > Copy, or Ctrl+C. 
Then right-click anywhere in the Script Area to paste it (Figure 4.16). 

 

Figure 4.16 Copy and past of 'Button Roll Over' 

Position one of the 'Button Roll Overs' at X:50 and Y:60 and the other at X:140 and Y:60 
(Figure 4.17). 
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Figure 4.17 

Preview by pressing F9. 

 

4.14 Short Summary 

In this exercise you have learned how to: 

• Activate and Deactivate objects 
• Use a MMouse Area object to trigger events 
• Navigate the project using the Folders view 
• Group objects into a Scene object 
• Cut and paste a group of connected objects 
• Copy and paste a single object 
• Save an object for later use 
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Exercise 5 

This exercise demonstrates how some of the filter objects works and how to animate their 
parameters. 

If you don't want to work through this exercise, but still want to see what it looks like, 
then you can load the project from: 

• [Path]/WireFusion 3/projects/ex5a.wfp  
• [Path]/WireFusion 3/projects/ex5b.wfp  
• [Path]/WireFusion 3/projects/ex5c.wfp  

Objects used in this exercise: 

• 1 Image 
• 1 Slider 
• 1 Blur 
• 1 Brightness 
• 1 Lens 

In this exercise, you'll accomplish the following tasks:  

• Load Exercise 2, 'ex2.wfp' 
• Switch to List View and disconnect (delete) the connection between 'Opacity 

slider' and 'Leaves' 
• Switch back to Wire View and insert a Blur object. Click OK to close the dialog 
• Connect: 'Blur 1', Out-ports > Mouse Events > Mouse Drag [2D Number] to 'Blur 

1', In-ports > Set Position [2D Number]  
• Rename 'Opacity slider' to 'Filter slider' 
• Connect: 'Filter slider', Out-ports > Slider Value [Number] to 'Blur 1', In-ports > 

Set Strength [Number]  
• Preview (F9) 
• Remove 'Blur 1' 
• Insert a Brightness object. Click OK to close the dialog 
• Connect: 'Brightness 1', Out-ports > Mouse Events > Mouse Drag [2D Number] 

to 'Brightness 1', In-ports > Set Position [2D Number]  
• Open 'Filter slider' Properties dialog and change Min value to -100. Click OK to 

close the dialog 
• Connect: 'Filter slider', Out-ports > Slider Value [Number] to 'Brightness 1', In-

ports > Set Brightness Level [Number]  
• Preview (F9) 
• Remove 'Brightness 1' 
• Insert a Lens object. Click OK to close the dialog 
• Connect: 'Lens 1', Out-ports > Mouse Events > Mouse Drag [2D Number] to 

'Lens 1', In-ports > Set Position [2D Number]  
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• Open 'Filter slider' Properties dialog and change Min value to -50, Max value to 
50 and Initial value to 30. Click OK to close the dialog 

• Connect: 'Filter slider', Out-ports > Slider Value [Number] to 'Lens 1', In-ports > 
Set Brightness Level [Number]  

• Preview (F9)  

 

5.1 Load a Project 

Load Exercise 2 (the slider that animates the image opacity), choose File > Open Project 
and load: 

• [Path]/WireFusion 3/projects/ex2.wfp  

 

5.2 Delete a connection 

Switch to List View by clicking the List View tab (Figure 5.1). 

 

Figure 5.1 Switching to List View 

 

Select the 'Opacity slider' in the Object List (Figure 5.2). 

 

Figure 5.2 'Opacity slider' selected in the Object List 

 

Select the connection that appears in the Wire List, between 'Opacity slider' and 'Leaves' 
(Figure 5.3). 
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Figure 5.3 Connection selected in the Wire List 

 

Delete the connection by clicking the Delete button (Figure 54.) in the Menu Bar or by 
pressing the Delete button on your keybaord. 

 

Figure 5.4 Delete button 

 

Switch back to the Wire View by clicking the Wire View tab (found next to the List View 
tab). 

 

5.3 Insert a Blur object 

Insert a Blur object into your project, Objects > Filters > Blur 

In the Blur dialog you can set the default blur strenght, but since we will use a Slider to 
set the strength you can leave it as it is. Close the dialog. 

Connect: 

• 'Blur 1', Out-ports > Mouse Events > Mouse Drag [2D Number] to 'Blur 1', In-
ports > Set Position [2D Number]  

 

5.4 Animate the blur strength 

Rename 'Opacity slider' to 'Filter slider' 

• Connect: 'Filter slider', Out-ports > Slider Value [Number] to 'Blur 1', In-ports > 
Set Strength [Number] (Figure 5.5) 
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Note: The Initial value (100) set in the 'Filter slider' will be sent out at startup and hence 
override the default blur strength (5) set in the 'Blur 1' Properties. 

 

Figure 5.5 'Filter slider' connected to 'Blur 1' 

 

Preview by pressing F9. 

You can now move the Blur filter by dragging the mouse and change the its strength 
with the Slider (Figure 5.6). 
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Figure 5.6 Animated blur filter strength 

 

Note: This completes the first part of Exercise 5 (ex5a.wfp) 

 

5.5 Insert a Brightness object 

Remove 'Blur 1' by selecting it and clicking the Delete button in the Menu Bar or by 
pressing the Delete button on your keyboard. Note how the connection is automatically 
removed as well when deleting. 

Insert a Brightness object into your project, Objects > Filters > Brightness 

In the Brightness dialog you can set the default brightness level, but as we will use a 
Slider to set the strength you can leave it as it is. Close the dialog. 

Connect: 
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• 'Brightness 1', Out-ports > Mouse Events > Mouse Drag [2D Number] to 
'Brightness 1', In-ports > Set Position [2D Number]  

 

5.6 Animate the brightness level 

Open the 'Filter slider' Properties dialog and change the Min value to -100 (Figure 5.7). 
Click OK to close the dialog. 

 

Figure 5.7 Changing the Slider Min value to –100 

 

• Connect: 'Filter slider', Out-ports > Slider Valie [Number] to 'Brightness 1', In-
ports > Set Brightness Level [Number]  

Note: The Initial value (100) set in the 'Filter slider' will be sent out at startup and hence 
override the default brightness level (50) set in the 'Brighteness 1' Properties.  

Preview by pressing F9. 
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You can now move the Brightness filter by dragging the mouse and change the 
brightness level with the Slider (Figure 5.8). 

 

Figure 5.8 Animated brighntess level 

 

Note: This completes the second part of Exercise 5 (ex5b.wfp) 

 

5.7 Insert a Lens object 

Remove 'Brightness 1' and insert a Lens object into your project, Objects > Filters > 
Lens 

In the Lens dialog you can set the default lens strength, but as we will use a Slider to 
set the strength you can leave it as it is. Close the dialog. 

Connect: 
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• 'Lens 1', Out-ports > Mouse Events > Mouse Drag [2D Number] to 'Lens 1', In-
ports > Set Position [2D Number]  

 

5.8 Animate the lens strength 

Open the 'Filter slider' Properties dialog and change the Min value to -50, Max value to 
50 and the Initial value to 30. Click OK to close the dialog. 

• Connect: 'Filter slider', Out-ports > Slider Valie [Number] to 'Lens 1', In-ports > 
Set Lens Strength [Number]  

Note: The Initial value (30) set in the 'Filter slider' will be sent out at startup and hence 
override the default lens strength (20) set in the 'Lens 1' Properties. 

Preview by pressing F9. 

You can now move the Lens filter by dragging the mouse and change the lens 
strength with the Slider (Figure 5.9). 

 

Figure 5.9 Animated lens strength 
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Note: This completes the third part of Exercise 5 (ex5c.wfp) 

 

5.9 Short Summary 

In this exercise you have learned how to: 

• Delete a connection between two objects in the List View 
• Delete an object from the project 
• Change Slider settings (Min, Max and Initial values) 
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Exercise 6 

This exercise demonstrates how to use an alpha channel map to shape a Brightness 
filter. 

If you don't want to work through this exercise, but still want to see what it looks like, 
then you can load the project from: 

• [Path]/WireFusion 3/projects/ex6.wfp  

Objects used in this exercise: 

• 2 Image 
• 1 Slider 
• 1 Brightness 

In this exercise, you'll accomplish the following tasks:  

• Load Exercise 5b, 'ex5b.wfp' 
• Open 'Brightness 1' Alpha Channel 
• Insert an Image in the 'Brightness 1' Alpha Channel.  
• Load the image 'flares_60x60.jpg'. Click OK to close the dialog 
• Resize 'Image 1' to the same size as the Stage dimension, press Alt-S. 
• Preview (F9)  

 

6.1 Load a Project 

Load Exercise 5b (the slider that animates the brightness level), choose File > Open 
Project and load: 

• [Path]/WireFusion 3/projects/ex5b.wfp  

 

6.2 Open the Alpha Channel 

Open the 'Brightness 1' Alpha Channel by choosing Explore Alpha Channel from the 
'Brightness 1' object menu (Figure 6.1) or by first clicking the 'Brighntess 1' icon in the 
Folders view and then the 'Alpha Channels' icon (Figure 6.2). 
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Figure 6.1 Opening the Alpha Channels for 'Brightness 1' using the local menu 

 

 

Figure 6.2 Opening the Alpha Channels for 'Brightness 1' using Folders view 

 

You are now positioned in 'Alpha Channels', which is located in 'Brightness 1', and you will 
see an empty Work Area and Script Area (Figure 6.3). 
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Figure 6.3 Work Area and Script Area in the 'Alpha Channels' object 

 

6.3 Insert an Image object 

In the 'Alpha Channels', insert an Image object and load the image named 
'flare_60x60.gif' found at: 

• [Path]/WireFusion 3/exercises/Tutorial6/ 

Click OK to close the dialog. Resize the 'Image 1' Target Area to the same size as the 
Stage dimension, i.e. 240x180 pixels, by pressing Alt+S (Figure 6.4). 
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Figure 6.4 'Image 1' resized to the Stage dimension 

 

Preview by pressing F9. You can now see how the before rectangular 'Brightness 1' 
Target Area has the shape of the flare-map (Figure 6.5). 
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Figure 6.5 'Brightness 1' shaped as the flare-image. 

 

6.4 Short Summary 

In this exercise you have learned how to: 

• Navigate to the Alpha Channels of an object 
• Use an alpha channel map to shape a rectangular Target Area 
• Resize a Target Area quickly to the same size as the Stage dimension 
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