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Introduction
Welcome to StuffIt by Aladdin Systems. Before you install this software, 
please read the license agreement located inside this booklet. 

The StuffIt package includes the following:

• StuffIt Browser™ application

• Drag-and-drop applications: DropStuff™, DropZip™, and Aladdin 

Expander™

StuffIt Browser
Aladdin’s StuffIt Browser provides a familar Explorer-style interface for you 
to create and expand archives in a variety of common formats. This versatile 
program offers full support for StuffIt (SIT), for the smallest possible 
archives, ZIP, CAB, LZH, ARC, TAR, TGZ, GZ, and Z file compression and 
expansion. There is also StuffIt Browser support for the following additional 
compression formats when they are purchased from their respective vendors: 
RAR, ARJ, and ACE.

When you select an archive file in the StuffIt Browser, the contents are 
displayed as if you had opened a folder. You can run programs, view 
documents, call Quick View (available as a Windows Accessory), and in 
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most cases, perform basic file management operations such as delete, 
rename, move, copy, and synchronize directories, whether or not the file or 
folder is contained within an archive.

Drag-and-drop operation is supported for file management functions. The 
StuffIt Browser allows you to easily create self-extracting ZIP archives, and 
it also supports variable compression levels, archive comments, password 
protection, and true MultiVolume capabilities.

An automatic Archive History log of each archive can be created and stored 
in a History folder. Archive History files contain a list of the archive 
contents, the archive name, creation date, and any archive, or file 
descriptions you may have entered. The Archive History interface is very 
similar to the Windows Explorer. You can also create a new history from any 
existing archive.

The StuffIt Browser supports several system options, such as Map Network 
Drive, Find File, File (Folder or Drive) Properties, Open With, and so on. 
This version of the StuffIt Browser allows you to virus-check all supported 
archive formats. It is fully compatible with Norton AntiVirus™ for 
Windows, McAfee Virus Scan™, and F-Prot for Windows.

DropStuff, DropZip, and Aladdin Expander
DropStuff and DropZip provide easy and flexible data compression with 
StuffIt or Zip using drag-and-drop, context menus, or the open application. 
Drag the files or folders you want compressed to the desktop shortcut and 
the complete archive will be created in your specified location. 
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Right-click a file or folder and several options are presented, including 
compress and email, or compress and send to. You can even select one-time 
options for "special" occasions. With Aladdin Expander, decompressing an 
archive is even easier—double-click on an associated archive type and it 
completely expands to display the original contents.

StuffIt installation
This section describes how to install the StuffIt package. 

System Configuration: The minimum system configuration for StuffIt is 
Windows 95, a 486DX/100 MHz processor, 16 MB RAM, and 5 MB disk 
space. 

Before You Install: Please take a few moments now to register StuffIt. You 
can register electronically, see “Registering electronically” on page 5, or you 
can fill out the included registration card and send it to Aladdin Systems (it’s 
postage paid). When you register, we can notify you of upgrades, new 
products, and special offers. 

Note: Please see the Read Me file for important last-minute information.

Standard installation
The standard installation process puts several items into the Program Files 
folder, creates an Aladdin Systems folder on your hard disk, and places 
shortcuts to the StuffIt Browser, DropStuff, DropZip, and Aladdin Expander 
on your desktop.

1. The setup program automatically runs from your CD-ROM drive. 
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If it doesn’t, navigate to the drive letter of your CD-ROM, display the 
contents, then double-click “StuffIt55.exe”.

2. Enter your name (if it isn't already inserted for you).
3. Enter a minimum of three characters in “Company Information”.
4. Enter the registration number as it appears on the back of the CD-ROM 

jewel case. (If you purchased StuffIt electronically, the registration 
number will be included with your purchase information from Aladdin).

Uninstalling the software
If you decide to remove all or part of the StuffIt package, use the provided 
uninstall program.

1. Click the Windows Start button. Choose Programs, StuffIt, and select 
“Uninstall”. Or, select the Control Panel folder from Start / Settings, 
then select the Add/Remove Programs option.

2. Click the components you want to remove, then click “Uninstall.”

Registering electronically
If you have Internet access, select the “Aladdin on the Internet” option from 
the Start/Programs/StuffIt menu. 

Or, register online at: http://www.aladdinsys.com/register. 
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The StuffIt Browser window

Expanding complete archives 
To expand archives:

1. In the Directory List Box (left-most box) select the folder with the 
archive to be expanded.

2. In the File List Box (right-most box), select the archive to be expanded.

Diretory List Box File List Box

Destination dialog box
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3.  If the archive is segmented, select the one with extension .arj, .ace, .rar, 
.cab, or .z00.

4. Click the Expand button, right-click and select Expand from the menu, 
or select the File menu > Expand command.

5. In the Destination panel, select the target location for expansion.
6. If desired, click the Advanced button to choose additional options for 

expanding (Preserve Folders, MultiVolume, Password entry).
7. Click the Expand button.

Extracting selected files from archives using the 
StuffIt Browser
To expand selected files from within archives:

1. In the Directory List Box (left-most box), select location with 
archives(s) to be expanded.

2. Click the Open Archive button, or double-click the archive.
3. Select the files you wish to extract from the archive. 
4. Click the Copy/Expand button. There is a context menu with the same 

options available by right-clicking the archive.
5. In the Destination panel, select the target location for expansion.
6. If desired, click the Advanced button to choose additional options for 

expanding (Preserve Folders, MultiVolume, Password entry).
7. After expansion completes, click the Close / Refresh Archive button to 

close the open archive.

You can also expand archives using drag-and-drop operations. Refer to 
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“Drag-and-drop” on page 9 to learn more.

Compressing files with the StuffIt Browser
Making an archive:

1. In the Directory List Box, select a directory with files to compress.
2. In File List Box, select the files or folders to compress.
3. Select Compress from the toolbar, File menu, or right-click and select 

Compress from the menu.
4. In the Destination panel, select the archive name (the name of the first 

item in the archive is the default name), select the location where you 
would like to create the archive, and select a compression format if 
different from the default.

5. If desired, click the Advanced button to choose additional options for 
compressing (MultiVolume, Password, Archive Comment).

6. Click the Compress button, select File menu > Compress, or right-click 
and select Compress from the menu. You can also compress files using 
drag-and-drop. 
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Drag-and-drop
The StuffIt Browser supports drag-and-drop operations with files and 
archives.

To use drag-and-drop instead of using menus:

1. In the File List Box, find the file or folder with which you want to work.
2. In the Directory List Box, make sure the location to which you want to 

drag the file or folder is visible.
3. Drag the file or folder to the destination.

The result will depend on the type of file you selected and the destination. 
For example, to add a file to an archive, drag it to the Archive file icon.

If you drag a file to a folder from an open archive, it will be expanded in that 
folder. If you drag a file to a folder from a regular folder, it will be copied.

To copy a file, use simple drag-and-drop. However, you can also use these 
modifier keys while dragging:

• To move a file, use SHIFT.
• To decompress a file, use ALT.
• To compress a file, use CTRL.

Viewing the contents of an archive
1. In the Directory List Box, select the directory containing the archive to 

be viewed.
2. In the File List Box, select the archive to be viewed.
3. Open the archive for viewing with the Open Archive button, or by 
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double-clicking the selected archive.
4. To exit viewing, click Close / Refresh Archive or change to another 

working directory.

You can also view the contents of an archive by clicking the archive icon in 
the Directory List Box. 

To expand selected files from an archive to a designated target, use the Copy 
/ Expand function.

Archive History
Why create an Archive History?

It can be easy to forget what information any single archive contains, so an 
archive history provides a kind of index that is very easy to use and navigate 
when you need to search for a specific file in an archive.

To learn more about using the StuffIt Browser, refer to the Help file which 
you can access through the StuffIt Browser Help menu.
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Aladdin Expander
There are four simple ways to use Aladdin Expander when you want to 
expand an entire archive: 

1. You can double-click on the archive. 
2. Right-click the archive, then choose Expand from the context menu.
3. Drag and drop the archive onto the Expander desktop shortcut.
4. Drag the archive onto the open application area that is marked with the 

text "Drag and drop archives and encoded files here"

While the archive is being expanded, a progress bar appears, then disappears 
upon completion.

Expanded files are placed into a directory according to settings in the 
Destinations Options Property Sheet which can be seen from View > 
Options in the toolbar. The default destination setting for Expander is the 
same directory in which the original archive or encoded file(s) reside.
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You can also expand an archive using the Expand command in the File 
menu. To learn more about using Aladdin Expander, refer to the Expander 
Help file, which you can access from the Expander Help menu.

Aladdin DropStuff
DropStuff compresses files and folders using the StuffIt™ (.sit) file format 
for smallest size and cross-platform compatibility. In addition, DropStuff can 
also compress files and folders using the Zip compression format. 

There are four easy ways to compress your files and folders.

1. Drag and drop the selected files onto either the application icon or the 
shortcut icon.

2. Drag and drop the selected files into the application view where the text 
"Drag and drop files here." is displayed.
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3. Right-click the files and choose a DropStuff method (Stuff or Zip) from 
the context menu.

4. From the open application, use the Stuff menu or click the Stuff toolbar 
button. When the standard open dialog appears, select the file(s) you 
want to compress.

To learn more about using DropStuff, refer to DropStuff Help, which you 
can access from the DropStuff Help menu. 

Aladdin DropZip
DropZip compresses files and folders using the Zip file compression 
method. In addition, DropZip can also compress files and folders using the 
StuffIt™ format for smallest size and cross-platform compatibility. 

There are four easy ways to compress your files and folders:

1. Drag and drop the selected files onto either the application or desktop 
shortcut icon.

2. Drag and drop the selected files into the open application view where 
the text "Drag and drop files here." is displayed.

3. Right-click the files and choose a DropZip method from the context 
menu.

4. From the open application, use the Zip menu or click the Zip toolbar 
button. When the standard open dialog appears, select the file(s) you 
want to compress.

To learn more about using DropZip, refer to DropZip Help, which you can 
access from the DropZip Help menu.
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Common Questions
What is compression?
Compression is the process by which a file or a folder is made smaller. The 
four primary uses of compression are to save disk space, to speed modem 
and network transfers when sending email attachments, to save space when 
doing a backup, and to archive files for long-term storage.  The StuffIt 
Browser, DropStuff, and DropZip are compression programs.

What is an archive?
An archive is a special document that can contain multiple files or folders. 
Archiving is the process by which one or more files and folders are 
combined into a single document and often compressed during the process. 
StuffIt archives are created by any member of the StuffIt family of products.

Where did it go? 

By default, Aladdin products place the result of either expansion or 
compression in the same location as the original item.  You may change the 
default destination by selecting View > Options > Destination from the menu 
bar of any of the drop box applications, or by selecting the Options icon on 
the toolbar of the StuffIt Browser.

Where To Go From Here
You can access the online Help systems for the StuffIt Browser, Aladdin 
Expander, DropStuff, and DropZip using the Help menu in each of these 
applications. 
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Software License Agreement
LICENSE AGREEMENT FOR StuffIt
This is a legal agreement between you and Aladdin Systems, Inc. covering your use of StuffIt (the 
"Software"). Be sure to read the following agreement before using the Software. BY USING THE 
SOFTWARE (REGARDLESS IF YOU HAVE REGISTERED THE SOFTWARE OR NOT), YOU ARE 
AGREEING TO BE BOUND BY THE TERMS OF THIS AGREEMENT. IF YOU DO NOT AGREE TO 
THE TERMS OF THIS AGREEMENT, DO NOT USE THE SOFTWARE AND DESTROY ALL COPIES 
IN YOUR POSSESSION.
The Software is owned by Aladdin Systems and is protected by United States copyright laws and international 
treaty provisions. Therefore, you must treat the Software like any other copyrighted material (e.g., a book or 
musical recording). Paying the license fee allows you the right to use one copy of the Software on a single 
computer. You may not network the Software or otherwise use it or make it available for use on more than one 
computer at the same time. You may not rent or lease the Software, nor may you modify, adapt, translate, 
reverse engineer, decompile, or disassemble the Software. If you violate any part of this agreement, your right 
to use this Software terminates automatically and you must then destroy all copies of the Software in your 
possession.
The Software and its related documentation are provided "AS IS" and without warranty of any kind and 
Aladdin Systems expressly disclaims all other warranties, expressed or implied, including, but not limited to, 
the implied warranties of merchantability and fitness for a particular purpose. Under no circumstances shall 
Aladdin Systems be liable for any incidental, special, or consequential damages that result from the use or 
inability to use the Software or related documentation, even if Aladdin Systems has been advised of the 
possibility of such damages. In no event shall Aladdin Systems' liability exceed the license fee paid, if any.
This Agreement shall be governed by the laws of the State of California. If for any reason a court of 
competent jurisdiction finds any provision of the Agreement, or portion thereof, to be unenforceable, that 
provision of the Agreement shall be enforced to the maximum extent permissible so as to effect the intent of 
the parties, and the remainder of this Agreement shall continue in full force and effect.
The Software and documentation is provided with RESTRICTED RIGHTS. Use, duplication, or disclosure 
by the Government is subject to restrictions as set forth in subdivision (b)(3)(ii) of the ASPR Rights in 
Technical Data and Computer Software clause as 252.227-7013. 

The supported ACE32, ARJ and RAR compressors are not free software and must be installed separately. If 
you use any of these programs for compression you must register it with the appropriate vendor. The LHA, 
CAB and TAR DLL's are free. Expansion of ACE32, ARJ and RAR archives in StuffIt is free.

SPECIAL NOTEs
MulitVolume self-extracting ZIP archives with extensions .z00, .z01,..., are registered and under copyright to 
Aladdin Systems. Distribution of programs for revenue made with MultiVolume self-extracting ZIP archives 
made with this software requires a license from Aladdin Systems.
Manufacturer is: Aladdin Systems, Inc., 245 Westridge Dr., Watsonville, California, 95076, United States of 
America (831) 761-6200 telephone, (831) 761-6206 facsimile.


